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Active Window
Arrange Icons
As-of Date
Assigning Resources
Assignments Info Box
Attachments
Baseline
Bitmap
Borders
Calculations
Calendars
Cascade
Collapse
Collapse All
Combining files
Command line parameters
Condition
Connect tool
Consolidating Schedules
Consulting
Control menu
Co-Pilot
Copy Picture
Copy task or resource
Critical path
Cumulative cost graph
Customer service
Customized conditions
Cut
Data columns
Date bar
Default settings
DEFAULT.TLP
Define Condition
Dehoist
Delay Lines
Delete
Dependencies
Detail tasks
Duration
Duration Conversions
Duration-driven tasks
Edit bar
Edit menu
Effort-driven tasks
Embedding Attachment Objects
Exit
Expand
Expand All



Export
Fields
File Combine
File Export
File Import
File menu
Filter condition
Filters
Fixed dates
Fixed tasks
Fonts & Colors
Footers
Format Active Window
Format Fonts & Colors
Format Global Defaults
Format Highlights
Format menu
Format Gantt
Format Global Defaults
Format PERT 
Format Resource Spreadsheet
Format Task Bar Symbols
Format Time Scale options
Gantt window
Global Defaults
Graphs
Headers
Help
Highlights
Histogram
Hoist
Holidays
Icon Bar
Import
Indent
Info Boxes
.INI file
Insert
Insert Attachment
Keyboard shortcuts
Level Resources
Libraries
Linking Attachment Objects
Local Area Network
Master Calendar
Maximize
Menus
Microsoft Project files
Milestone
Minimize
Move Down
Move tool
Move Up
MSP Importer
Networks: Using Time Line on a LAN
New File



New Window
Note Info Box
Object Linking and Embedding (OLE)
On Target
Open File
Open Library
Options menu
Outdent
Outline
Outline menu
Page Setup
Pane divider
Paste
Paste Attachment
Period cost graph
PERT window
Picture
Preferences
Preview
Print
Print Calendar
Print Preview
Printer Setup
Properties
Quick Start
Quit
Recalculation
Remove Dependencies
Reposition PERT
Resource
Resource calendars
Resource data columns
Resource leveling
Resource Spreadsheet
Responsible resource
Restore
Save
Save As
Save As Library File
Schedule Options
Schedule Start Date
Scheduling logic
Select tool
Set Baseline
Set Dependencies
Slack
Snap to Alignment
Sorting
Spreadsheet
Spreadsheet columns
Standard Workweek
Starter Schedules
Summary tasks
Task
Task bars
Task Bar Symbols



Task Info Box
Technical support
Tile
Time Line for DOS
Time Scale options
Time Scale pane
Timing Info Box
Title & Border Options
TLWIN.INI
Training
Tutorial
Undo
Update Consolidations
Update Manual Sort
Update Percent Complete
Window controls
Window menu
Workweek
Zoom tools





Time Line Menu Commands

Click the name of a Time Line menu listed below to learn about the commands that appear on that menu.

File - File management and printing. 
Edit - Editing and arranging spreadsheet items.
Format - Organization, fonts, and graphic design of windows and reports.
Outline - Structure and display of the task outline.
Options - Defaults and general preferences for the entire schedule.
Window - Managing windows with different views of the plan.
Help - Getting help within Time Line. 



The File Menu 

The File menu lists commands for file management and printing.    Click a command name below to learn 
about it.

New
Open
Save
Save As
Combine
Import 
Export 
Page Setup 
Print 
Print Preview 
Print Calendar 
Printer Setup 
Exit

Related Topics:
Time Line Menus



The Edit Menu 

The Edit menu lists commands for editing and arranging spreadsheet items, and for object linking and 
embedding (OLE).    Click a command name below to learn about it.

Undo
Cut
Copy
Paste
Copy Picture 
Insert
Delete
Assign Resource
Set Dependencies
Remove Dependencies
Consolidate
Paste Attachment
Insert Attachment
Attachment

Related Topics:
Time Line Menus



The Format Menu 

The Format menu lists commands for controlling the organization, fonts, and graphic design of windows 
and reports.    Click a command name below to learn about it.

Fonts & Colors 
Active Window
Global Defaults
Task Bar Symbols 
Highlights 

Related Topics:
Time Line Menus



The Outline Menu 

The Outline menu lists commands for controlling the structure and display of the task outline.    Click a 
command name to learn about it.

Expand
Collapse
Expand All
Collapse All
Indent
Outdent
Move Up
Move Down
Hoist
Dehoist

Related Topics:
Time Line Menus



The Options Menu 

The Options menu lists commands for choosing methods, defaults, and general preferences for the entire 
schedule.    Click a command name below to learn about it.

Schedule 
Preferences 
Calculations
Calendars 
Info Boxes
Recalculate Now
Update Consolidations
Reposition PERT
Update Percent Complete
Set Baseline 
Update Manual Sort

Related Topics:
Time Line Menus



The Window Menu 

The Window menu lists commands for managing windows with different views of the schedule.    Click a 
command name below to learn about it.

New Window 
Open Library File 
Save As Library File 
Tile
Cascade
Arrange Icons
[default open window names]

Related Topics:
Time Line Menus





Opening a New File 

The New command on the File menu clears the current schedule from the screen, providing a clean file to 
begin a new schedule.    A message reminds you to save the current schedule first.

The Quick Start box appears automatically to help you open a Starter Schedule or another file.    You can 
turn Quick Start off in the Preferences box.

The formatting options that are set by default when you create a new schedule are stored internally within 
Time Line.    You can change the default formatting by customizing a file and then saving it with the name 
DEFAULT.TLP.    To restore the original default settings, delete the file DEFAULT.TLP.



Opening an Existing File

The Open command on the File menu opens a file previously created with Time Line for Windows.    You 
can also use this command to import On Target or Time Line for DOS files into Time Line for Windows. 

The Open File box appears for you to specify the directory and filename:

File Name: The path and filename currently selected for opening appears at the top of the list, which 
shows all files in the specified directory that include the extension set under List Files of Type.    Click a 
filename to select it, or double-click to open it.

Directories: The directory currently open for selection appears at the top of the list of all directories at the 
current level on the specified drive.    The parent directory is [..].    Double-click a directory to open it.

Drives: Sets the drive for which directories are listed.

List Files of Type: Identifies the file format by means of the extension included in the filename list.

Click OK to open the file.    A message reminds you to save the current schedule first.    Any problems 
related to opening a Time Line for DOS file are reported in an Import Error Log box that opens 
automatically.

Related Topics:
Command Line Parameters



Combining Files

The Combine command on the File menu merges another Time Line for Windows or On Target schedule 
into the current file.    Always save your file before using this command.

The File Combine box opens for you to specify the filename and select the data to combine:

File Name: The path and filename currently selected for combining appears at the top of the list, which 
shows all files in the specified directory that include the extension set under List Files of Type.    Click a 
filename to select it, or double-click to combine it.

Directories: The directory currently open for selection appears at the top of the list of all directories at the 
current level on the specified drive.    The parent directory is [..].    Double-click a directory to open it.

Drives: Sets the drive for which directories are listed.

List Files of Type: Identifies the file format by means of the extension included in the filename list.

Data to Combine indicates the types of data from the selected file to be combined with the active file.

Task Info combines task and connection data.    Time Line inserts a new summary task with the 
same name as the incoming file and indents the incoming tasks beneath it.

Resource Info combines resources and resource calendars. If any resource in the incoming file has 
the same name as one in the active file, the Duplicate Resources box lets you choose how to handle 
them.

Selecting both Task Info and Resource Info combines resource assignments as well.

Filter & Highlight Conditions combines named conditions for filters and highlights.    If a condition 
in the incoming file has the same name as one in the active file, the Duplicate Conditions box lets 
you choose how to handle them.

Master Calendar 

Leave As Is applies the current Master Calendar to tasks from the incoming file.

Overwrite replaces the current Master Calendar with the calendar from the incoming file.

To begin combining, click OK or double-click the filename in the Files list. 



Saving a File

 Click the Save button on the Icon Bar or choose Save from the File menu to save the active file to 
disk under its current name and path.    If you have not previously saved the schedule, the Save File As 
box asks you to name the file.

The Save As command on the File menu also opens the Save File As box, so you can change the name 
of a schedule when saving it.    If the file named already exists, a message asks if you wish to replace it.

File Name: The path and filename currently selected for saving appear at the top of the list, which shows 
all files in the specified directory that include the extension set under List Files of Type.    Click a filename 
to select it, or double-click to save it.

Directories: The directory currently open for selection appears at the top of the list of all directories at the 
current level on the specified drive.    The parent directory is [..].    Double-click a directory to open it.

Drives: Sets the drive for which directories are listed.

List Files of Type: Identifies the file format by means of the extension included in the filename list.

Click OK to save the named file. 



Importing a File

The Import command on the File menu translates data from other file formats for use in Time Line. 

· If the Gantt window is active, only task data s imported. 
· If the Resource Spreadsheet is active, only resources are imported.
· Dependencies, resource assignments, and calendars are not imported.

Time Line inserts the resources or tasks at the selected row and at the same level of the outline.    The 
order of columns in the active spreadsheet must be the same as the fields of the imported file.      
Additional fields without corresponding columns are ignored.    Default data is inserted in any columns for 
which no fields are imported. 

The File Import box opens for you to identify the file to be imported:

File Name: The path and filename currently selected for import appear at the top of the list, which shows 
all files in the specified directory that include the extension set under List Files of Type.    Click a filename 
to select it, or double-click to import it.

Directories: The directory currently open for selection appears at the top of the list of all directories at the 
current level on the specified drive.    The parent directory is [..].    Double-click a directory to open it.

Drives: Sets the drive for which directories are listed.

List Files of Type: Identifies the file format by means of the extension included in the filename list.
· From Lotus 1-2-3, you must import from a range named "TLW" containing only data. 
· From CSV or tab-delimited formats, you must import the entire file.    Each line 

corresponds to a task or resource row.

Click OK or double-click the filename in the Files list to begin importing.

Any duplicate tasks are not overwritten, so multiple tasks of the same name may exist.    After importing is 
completed, the Import/Paste Error Log box opens automatically, listing any problems that may have 
occurred.    Imported tasks are not visible if hidden by a filter.

The Paste command imports data on the Windows Clipboard from other Windows applications.

Related Topics:
Insert Position in the Preferences box
Exporting a File
Importing files from Time Line for DOS
Importing files from On Target
Importing files from Microsoft Project



Exporting a File

The Export command on the File menu saves data from Time Line in a file format usable by another 
program.

· If the Gantt window is active, only task data is exported.
· If the Resource Spreadsheet is active, only resources are exported.
· Dependencies, resource assignments, and calendars are not exported.

Collapsed tasks, or tasks hidden from view by active filters or hoists are not exported.

The File Export box asks you to select the file to be exported:

File Name: Enter the filename for the file to be exported at the top of the list, which shows all files in the 
specified directory that include the extension set under List Files of Type.

Directories: The directory currently open for selection appears at the top of the list of all directories at the 
current level on the specified drive.    The parent directory is [..].    Double-click a directory to open it.

Drives: Sets the drive for which directories are listed.

List Files of Type: Identifies the file format by means of the extension included in the filename list.
· For Lotus 1-2-3, a range named "TLW" is created to include all the exported data.    You 

may need to adjust column widths in your spreadsheet to view the complete exported 
fields.

· For CSV or tab-delimited formats, each line corresponds to a task or resource row.    
Dates and text fields are surrounded by quotation marks. 

Options
Selected Tasks Only exports only the currently selected tasks. 
All Tasks exports all visible tasks in the schedule.

Click OK or double-click the filename in the Files list to begin exporting.

The Copy command can be used to export to other Windows applications.

Related Topics:
Importing a File



Page Setup

 Click the Page Setup button on the Icon Bar or choose Page Setup from the File menu to control the 
titles, borders, margins, and orientation of reports that you print.    The Page Setup box opens for you to 
select:

Titles & Borders

Border Lines prints a line separating any headers and footers from the report.    Click Options for a 
choice of styles. 

Headers & Footers prints titles at the top and/or bottom of pages.    Click Options to specify the 
content.

Legend prints a key to symbols used in the Gantt or PERT window and any highlight conditions that 
are in effect.

Print On Every Page prints selected options on each page of the report, with centered headers, 
footers at bottom left, legend at bottom right, and border framing the page completely.

When Print On Every Page is turned off, title and border options are positioned for a multi-page 
report, with the border framing the entire layout, header at top left of the first page, footer at bottom 
left and legend at bottom right of the last page.

The Print command controls the ratio of pages across and down.

The Format Global Defaults command sets the background color of the border area, as well as fonts and 
colors for titles.

Margins
Specify the top, bottom, left, and right margins, measuring from the paper's edge.    Most printers cannot 
print to the paper's edge, so margins of less than .25" are not recommended.    Use the Microsoft 
Windows Control Panel to change the unit of measurement from inches to centimeters.

Page Orientation
Your choice here applies to this file only and temporarily overrides the orientation chosen for Printer 
Setup.

Landscape prints horizontally on the page.

Portrait prints vertically on the page.

Use the Printer Setup command to specify the paper size.

Related Topics:
Print options
Print Preview



Printing a File

 Click the Print button on the Icon Bar or choose Print from the File menu to print the contents of the 
active window.    Any tasks hidden by Hoist or Collapse commands, or by filters, are not included in the 
printed report.    All spreadsheet columns included in the layout are printed, although they may be scrolled 
off screen.

The Print box opens for you to select options:

Scale
Changing any one of these options automatically recalculates the others when you click the Rescale 
button.

Force to One Page changes the scale so that the entire report fits on a single page.    Note that if the 
area to be printed requires scaling to less than 25%, you will not be able to print the report on one 
page.

Pages Across and Down together set the size of the printed report as a rectangular array of pages.

Scale % sets the size of the printed report as a percentage of the normal font size. 

Date Range 
From and To specify the beginning and ending dates of the period included in the report.    These 
apply only to the Gantt window.    If left blank, the default range covers the entire schedule.    Click 
Rescale to adjust the Scale for a new Date Range.

Pages
All prints all pages.
From and To specify the range of page numbers to print.    Use this to reprint pages without 
reprinting an entire schedule.

Print Black & White adapts onscreen colors for optimum printing in black and white.

Draft prints more quickly with some loss of quality, if your printer offers this option.

Copies sets the number of copies to print.

Rescale recalculates the Scale options to correspond to your last entry for any Scale or Date Range 
option.

Preview displays the report as it will appear when printed. 

Click Print to begin printing.

Related Topics:
Page Setup
Printer Setup



Print Calendar

 Click the Print Calender button on the Icon Bar or choose Print Calendar from the File menu to print 
the schedule as a wall calendar with one month to a page.    Task bars run across the days they are 
scheduled, labeled with the task name.    The size is determined by the paper size entered in the Printer 
Setup. 

You can create calendars for specific resources and limit the tasks included by filtering.    A title on each 
page shows the month and year.    Use the Page Setup command to add headers, footers, and borders, 
and change the orientation.    Titles and borders are always printed on every page.    The legend does not 
appear on a calendar report. 

The Print Calendar box opens for you to select:

Scale
These options affect the task bars only.    Changing any of these options automatically recalculates the 
others when you click the Rescale button.

Show All Bars calculates the number of task bars required for the day with the greatest number of 
tasks and the Scale % needed to fit them in the calendar.

Bars per Day sets the maximum number of bars displayed for any day.    Use this to prevent task 
bars being reduced to less than readable size.

Scale %    sets the size of the task bars as a percentage of the font size.    At 100%, the height of the 
task bars matches the largest font size in use for a task or resource. 

Date Range
From and To specify the beginning and ending dates of the period covered in the calendar report.    
The entire month is printed for any date entered.    If left blank, all of the months in the schedule are 
printed.    Click Rescale to adjust the Scale for a new Date Range.

Filter
Resource shows only tasks to which the selected resource is assigned or named as responsible.    
Nonwork days, if shaded, reflect the specific resource calendar.

Condition shows only tasks that meet the condition you select.

New opens the Define New Condition box, where you name a new condition before defining it.

Edit opens the Define Condition box, where you can customize the selected filter condition.

Clear removes any filter condition currently in effect.

Other Options
Copies sets the number of copies to print.

Draft prints more quickly with some loss of quality, if your printer offers this option.

Black & White adapts onscreen colors for optimum printing in black and white.

Exclude Summary Tasks removes all summary tasks from the calendar, printing only detail tasks. 

Use Hoist in Active View removes any tasks hidden by the Hoist command in the active window.



Shade Nonwork Days shows any nonwork days on the Master Calendar in gray.    If a resource is 
selected, nonwork days on the resource calendar are also shaded.

Rescale recalculates the Scale options to correspond to your last entry for any Scale or Date Range 
option.

Preview displays the calendar as it will appear when printed. 

Click Print to begin printing.



Printer Setup

The Printer Setup command on the File menu controls which printer is active.    The Printer Setup box 
opens for you to select from a list of installed printers.

Click Setup for further print options including paper size and source, default orientation, cartridges, 
graphics resolution, and font installation.    Help is provided directly from Microsoft Windows within the box 
that opens. 

The Microsoft Windows Control Panel in the Program Manager also includes options for choosing 
printers, ports, and network routing.



Exit

The Exit command on the File menu closes Time Line and returns to Microsoft Windows.    A message 
reminds you to save the file.

Related Topics:
The Window Control Menu





Pasting Attachments

The Paste Attachment command on the Edit menu embeds or links a document from another Windows 
application to the selected task or resource.    Before this command is available to paste an attachment, 
you must have copied valid data from the document in the other application onto the Clipboard.

The Paste Attachment box opens.

Source identifies the file format of the data currently on the Clipboard.
Embed inserts a copy of the Clipboard data only into a document attached to the selected task or 
resource.    This document is saved with the Time Line schedule and is not accessible outside the 
schedule.
Link establishes an attachment from the selected task or resource to the entire file from which the data 
was copied onto the Clipboard.    (The copied data remains selected but is not otherwise distinguished.)    
The attached file can be edited in the original application as well as in Time Line.

The attached document can be opened by double-clicking its icon in the Note Info Box or the Attachments 
data column.

Related Topics:
Object Linking and Embedding (OLE)
Inserting Attachments
Deleting Attachments and Changing Links



Inserting Attachments

The Insert Attachment command on the Edit menu embeds or links a document from another Windows 
application to the selected task or resource. 

The Insert Attachment box opens.

Data Type identifies the file format of the document to attach.
Embed New Attachment inserts an attachment for a new document, opens it, and launches the 
application that created it.    The document is saved within the schedule and is not accessible outside of 
Time Line.
Link To Existing File establishes an attachment from the selected task or resource to a document 
already created in another application.    The Create New Link box opens for you to specify the filename 
and path.

The attached document appears as an icon in the Note Info Box or the Attachments data column, and 
can be opened by double-clicking the icon.

Related Topics:
Object Linking and Embedding (OLE)
Pasting Attachments
Deleting Attachments and Changing Links



Changing and Deleting Attachments

Choose Attachments on the Edit menu to open a submenu of commands for activating, deleting, or 
changing attachments.    These commands are also available on the Attachments menu in the Note Info 
Box.    The command you choose from the Attachments menu affects the currently selected attachment 
icon.    Click an icon to select it before choosing a command.    (When multiple attachment icons are 
available, the selected icon appears with a dark outline and clear image.)

Activate opens the document window for the selected attachment icon in the Note Info Box or 
Attachments data column, an alternative to double-clicking the icon.
Delete removes the selected attachment.    If the attachment is embedded, the entire document is 
deleted.    If the attachment is linked, the link is deleted, but the document remains available outside of 
Time Line.
Properties    opens the Attachment Properties box with the following options:

Links identifies the file format, filename, and data range of each linked attachment.    Select a link 
before choosing a function below.
Change Link opens the Change Link box where you can edit the filename and path of an existing 
link. This is useful if the linked file has been moved or renamed since the link was established.
Edit opens the selected linked document, ready for editing.
Delete removes the selected link.    The document remains available outside of Time Line.

Related Topics:
Object Linking and Embedding (OLE)
Pasting Attachments
Inserting Attachments
Deleting Attachments and Changing Links



Consolidating Schedules

 Click the Consolidate button on the Icon Bar or choose Consolidate from the Edit menu to 
consolidate data from another schedule, summarizing it in the selected task.    (Create a new task for the 
purpose.    Existing task data is overwritten by the consolidated data, which cannot be edited in the 
current schedule.    The consolidated task has fixed start and end dates.) 

The Edit Consolidate box opens for you to specify the schedule to consolidate.

File Name: The path and filename currently selected for consolidating appear at the top of the list, which 
shows all files in the specified directory that include the extension set under List Files of Type.    Click a 
filename to select it, or double-click to consolidate it.

Directories: The directory currently open for selection appears at the top of the list of all directories at the 
current level on the specified drive.    The parent directory is [..].    Double-click a directory to open it.

Drives: Sets the drive for which directories are listed.

List Files of Type: Identifies the file format by means of the extension included in the filename list.    On 
Target and Time Line for DOS files are also available for consolidation.

Options
Summarize Entire Schedule imports timing and cost data, summarizing all tasks in the external 
schedule.
Direct Link To Task imports timing and cost data for a single task in the external schedule, identified 
by its WBS number, below.
WBS Value identifies the task in the external schedule for a direct link. 

Click OK to consolidate the file. 

Consolidating creates a dynamic data exchange between the two schedules: if data is changed in the 
external schedule, you can automatically update the corresponding summary data at any time by 
choosing Update Consolidations from the Options menu.    You can also update whenever you open the 
current schedule. 

To delete a consolidation, either delete the task containing the summarized data or delete its data in the 
Consolidate Info data column.    In this case, the last updated information for the task remains in effect, 
but no further updates are available.

Related Topics:
Combining Schedules



Undoing a Command

The Undo command on the Edit menu reverses the effect of the last action taken with any of the following 
commands:

File
Combine
Import

Edit
Cut
Paste
Insert
Delete
Set Dependencies
Remove Dependencies
Assign Resource

Choose the Undo command again to restore the last change.



Cutting Tasks or Resources

 Click the Cut button on the Icon Bar or choose Cut from the Edit menu to delete any selected tasks 
or resources and place them onto the Windows Clipboard.    You can then use the Paste command to 
insert the items in a new position.

Task dependencies, resource assignments, and outline information are automatically included when you 
cut a task.    When cutting a summary task, all of its detail tasks are also included.

Related Topics: 
Selecting Tasks or Resources 



Copying Tasks or Resources

 Click the Copy button on the Icon Bar or choose Copy from the Edit menu to place a copy of any 
selected tasks or resources onto the Windows Clipboard.    You can then use the Paste command to 
insert the copied items in a new position in the schedule.    Task dependencies, resource assignments, 
and outline information are included automatically when you copy a task.    When copying a summary 
task, all of its detail tasks are also included. 

Tasks or resources that have been copied to the Windows Clipboard can be pasted into any Windows 
applications that accept data in the following formats: Lotus 1-2-3, CSV, or tab-delimited text.    All data 
columns in the active Gantt window or Resource Spreadsheet are transferred. 

Related Topics:
Selecting Tasks or Resources 
Exporting a File



Pasting Tasks or Resources

 Click the Paste button on the Icon Bar or choose Paste from the Edit menu to copy any tasks or 
resources from the Windows Clipboard into the schedule, inserting them below the selected row. 

Change the Insert Position in the Preferences box if you prefer to insert above the selected row.

The Cut and Copy commands move items onto the Windows Clipboard for pasting in a new position.

You can bring task or resource information into the Gantt window or Resource Spreadsheet from other 
Windows applications by pasting from the Windows Clipboard.    The order of data columns in the active 
window must correspond to the columns being pasted into the window.    Lotus 1-2-3, CSV, and tab-
delimited text formats are supported.    After importing or pasting is completed, an Import/Paste Error Log 
box lists any problems that may have occurred.    Imported or pasted tasks may not be visible if hidden by 
a filter.

Related Topics:
Importing a File



Copy Picture

The Copy Picture command on the Edit menu copies an exact graphic image of the active window onto 
the Windows Clipboard.    Resize the window to frame the image exactly as you wish.    You can then 
create graphic presentations by pasting this image into other Windows applications that support bitmap or 
Windows metafile formats. 



Insert

The Insert command on the Edit menu opens a new row in the Spreadsheet below the selected task or 
resource.    If multiple items are selected, the same number of new rows is inserted.

Change the Insert Position in the Preferences box if you prefer to insert above the selected row.

To insert a task in the PERT window:
· Double-click within a summary box to add a new detail task to that task family.
· Double-click the background to insert a new task at the highest level of the outline.

This command is not available while a filter condition is in effect.



Delete

The Delete command on the Edit menu erases any selected tasks or resources.    The deleted items are 
not stored on the Windows Clipboard, but they can be restored by using the Undo command.

Related Topics:
Cutting Tasks or Resources



Setting Dependencies

The Set Dependencies command on the Edit menu schedules all selected tasks in sequence, so that the 
end of one task is followed immediately by the start of the next task.    The tasks are connected in the 
order in which you selected them, regardless of their order in the Gantt window.

If you try to set a dependency that is not logically possible (for example, between a summary task and 
one of its detail tasks), Time Line ignores it.    If a dependency already exists between the tasks you are 
trying to connect, a Co-Pilot box opens to clarify your action.

You can also set dependencies by using the Move tool to reschedule the task bars in sequence, or the 
Connect tool, or the Add command in the Timing Info Box.    To specify lead or lag time between 
dependent tasks, see the Edit option in the Timing Info Box.

Related Topics:
Selecting Tasks
Removing Dependencies
Scheduling Logic



Removing Dependencies

The Remove Dependencies command on the Edit menu deletes dependencies between selected tasks.    
The Remove Dependencies box opens for you to specify which dependencies to delete:

Between Selected Tasks Only deletes a dependency between two tasks only if both tasks are selected.

All Dependencies For Selected Tasks deletes any dependencies from selected tasks to any other 
tasks.

Tasks hidden by filters or in collapsed portions of the outline are not affected by the Remove 
Dependencies command.    To remove all dependencies in a schedule use the Dehoist and Expand All 
commands on the Outline menu and turn off any filters.    Then select all tasks and choose Remove 
Dependencies.

You can also use the Delete command in the Timing Info Box to remove a selected dependency.

Related Topics:
Dependencies



Assigning Resources and Costs to Tasks

The Assign Resource command on the Edit menu assigns a resource or cost category to selected tasks. 
Choosing Add on the Commands menu in the Assignments Info Box has the same effect.    In both cases, 
the Assign Resource box opens for you to select a resource:

· Click a resource name to select it.
· Click New to add a new resource to the list.
· Click OK to assign the selected resource to all currently selected tasks.

Number Assigned defines the assignment for duration-driven tasks as the number of individuals working 
full time or an equivalent.    For example, an entry of 1.00 could indicate one individual working full time or 
two individuals, each working half-time.    The default assignment is 1.00, which you can change by 
editing the Default Assignment column of the Resource Spreadsheet.

Effort defines the assignment for effort-driven tasks as the amount of work time the resource is 
committed to the task.

Responsible names the assigned resource as the individual responsible for the task.

If the resource has already been assigned to the same task, a Co-Pilot box opens automatically for you to 
clarify your action.

Related Topics:
Assigning Resources with the Connect tool



Format Fonts & Colors

 Click the Fonts & Colors button on the Icon Bar or choose Fonts & Colors from the Format menu to 
customize the font and color of selected tasks or resources.    The Format Fonts & Colors box opens:

Font

Name: The font in which selected items will be formatted. Available fonts depend on the setting for 
Printer Fonts.    Selecting [Default] automatically sets the Size and Style options specified in the 
Format Global Defaults box. 

Size: The point size of the selected font.    If you are using a printer that supports scalable fonts you 
can type in font sizes that are not listed.

Style: Bold, Italic, Underline, and Strikethrough options can be used in combination.    Not all style 
options are available for all fonts, and screen font styles may differ from printed styles. 

Printer Fonts displays fonts available for the active printer in the Font Name list box.    When turned 
off, only standard Microsoft Windows screen fonts appear in the Font Name list box.

Colors
Selecting [Default] applies the colors specified using the Global Defaults command on the Format menu. 

Foreground sets the color of selected tasks or resources, including text in the Spreadsheet cells, 
task bars, dependency lines, and PERT task boxes. 

Background sets the background color of selected Spreadsheet rows and PERT task boxes.

Sample Text demonstrates the selected fonts and colors. 

Clear restores all options to the [Default] settings.

Related Topics:
Selecting Tasks or Resources
Selecting a Printer and Installing Fonts
Using Highlights



Format Active Window

The Active Window command on the Format menu customizes the choice of information in the active 
window and its presentation on screen or in a printed report.    The name you give a customized window 
appears in the list of open windows on the Windows menu.    Any open windows are saved with the file.    
You can also save customized window formats in libraries for use with other files.

The formatting options depend on the type of window that is active when you choose the command.    
One of the following boxes opens:

Format Gantt
Format PERT
Format Resource Spreadsheet

Related Topics:
Opening a New Window



Format Gantt 

When the Gantt window is active, choosing the Active Window command on the Format menu lets you 
customize the Spreadsheet and Time Scale panes, sort or filter tasks, and create cost graphs, crosstabs, 
and histograms. 

The Format Gantt box opens:

Layout Name: The name you enter identifies the customized window on the Window menu.

Zoom %    enlarges or reduces the onscreen image by the percentage entered.    The Zoom tools have 
the same effect.    For printing, use the Scale options in the Print box instead.

Spreadsheet
The table shows the current layout of data columns in the Spreadsheet pane. 

· Click a cell to select it for editing, inserting, or deleting.
· Edit the Name, Width, or Custom Title by typing in the edit bar.

Click to select from a list of available columns. 

Name lists the data columns in the order they appear on screen from left to right. 
Width sets the width of the column in characters.    You can also change column widths by dragging 
the lines that separate the column titles.
Custom Title replaces the standard column title with the title entered here.
Insert opens space for a new data column at the selected position.
Delete removes the selected column from the Spreadsheet.
Outline Indentation displays the indentation of tasks in the outline.
When turned off, all task names are aligned at the left regardless of outline position, and any + 
symbols for collapsed summary tasks are hidden.
Grid Lines displays gray lines to separate rows and columns.

Each of the following buttons presents further options for formatting the Gantt window.    Click one for 
more information:

Time Scale
Filter
Sort

Shortcut:    Double-click the data column titles in the spreadsheet to open the Format Gantt box with 
Spreadsheet card selected.

Related Topics:
Resizing the Spreadsheet and Time Scale Panes 
Data Columns 
Formatting Global Defaults



Formatting Time Scale Options

Click the Time Scale button in the Format Gantt box to select options affecting the Time Scale pane.

Shortcut:    Double-click the background of the Time Scale pane to open the Format Gantt box with Time 
Scale card selected.

Data
Display controls the panes of the Gantt window. 
Choose Task Bars to include the normal Time Scale pane.    Choose Spreadsheet only to exclude 
the Time Scale pane from the screen display and printed reports. 
Choose Crosstab to display a tabular report of the cost or effort of the resource selected below, with 
columns corresponding to the time scale units of the date bar.    The Crosstab distributes cost and 
resource effort evenly over the entire calendar duration of each task.    (To minimize the distortion of 
costs or effort displayed for non-work days, set the time scale of the date bar to weeks, or any unit 
larger than days.)
Graph displays a histogram, period cost graph, or cumulative cost graph in the Time Scale pane, 
representing the effort or cost of the resource selected below.    The graph corresponds directly to the 
task bars of the Time Scale pane.
Crosstab provides a choice of data presented in the crosstab display.    These options are available 
only if Crosstab is selected for Display, above. 
Resource specifies the resource for which data is displayed in the cost graphs, histogram, or 
crosstab.    All resources combines data for all resources for the relevant time period.    Histograms 
require that you choose a single resource. 

Task Bar Labels
Left 
Right 
You can label each task bar to the right and/or left of the bar with from any of the data columns 
available for the Spreadsheet pane.    All data columns are listed for both sides.    See the help topic 
on Data Columns for definitions. 
Clear removes any previously set task bar labels.

Scale
Time Units sets the time unit represented by the divisions of the date bar.    You can also change the 
time unit by double-clicking the time unit labels on the lower line of the date bar until it displays the 
desired unit.
Width sets the width of the time unit divisions in characters. You can also change the width onscreen 
by dragging the dividing lines between the time unit labels.

Display Options
Baseline displays task bars for baseline data in addition to current task bars. 

Clicking the Baseline button on the Icon Bar has the same effect. 
Dependency Lines marks each dependency with an arrow from the predecessor task to the successor 
task. 

Clicking the Dependency Lines button on the Icon Bar has the same effect. 
Slack Lines displays the slack available for a task as a line extending from the end date of the task bar. 

Clicking the Slack Lines button on the Icon Bar has the same effect. 
(Use the Calculations box to designate whether the lines represent free or total slack.)
Delay Lines shows a delay caused by resource leveling or slipped fixed dates as a line from the original 
start date to the beginning of the task bar.    The line style set by the Task Bar Symbols command on the 
Format menu differentiates the two types of delay.    If both types of delay affect the same task, only the 
delay to fixed dates is shown.



Vertical Grids extends a gray line vertically from each division of the date bar.
Horizontal Grids extends a gray line horizontally every five task rows.
Show Totals on Graph includes total cost amounts in the cost graphs and histogram.

Related Topics:
Other Gantt Window Formatting Options
Graphic Options for Task Bar Symbols, Patterns, and Lines



Using Filters

Click the Filter button in the Format Gantt box to select a condition for filtering tasks.    Tasks that do not 
meet the terms of the condition are hidden from view and excluded from printed reports. 

Shortcut: Click the Set Filter button on the status line to open the Format Gantt box with filter conditions 
ready to select.    Click the Clear Filter button to remove any filter in effect.

Condition: Select one of the pre-defined conditions for evaluating tasks.    Click for an explanation of 
each condition:

Almost Critical
Consolidated Tasks
Critical
Custom Date Range
Late (vs. Baseline)
Milestones
Near Critical
Needs Update
Not Completed
Over Budget (vs. Baseline)
Resource Combo
Resource Conflict
Text Combo
This Month/Quarter/Week/Year
[Resource Names]

New opens the Define New Condition box, where you can name a new condition before defining it.

Edit opens the Define Condition box, where you can edit or examine the selected condition.

Clear removes any filter currently in effect.

A filter applies only to the window active when the condition is selected; different conditions can be used 
in different windows.

If you change a visible task so that it does not meet a filter condition currently in effect, the task will 
disappear from view.    Use highlights to mark tasks that meet a condition instead of hiding those that do 
not.

Related Topics:
Other Gantt Window Formatting Options



Sorting Tasks

Click the Sort button in the Format Gantt box to select options for sorting tasks in alphabetical, 
chronological, or numerical order of the data in any column.    Sorting does not affect the outline structure. 
Tasks at the same level of indentation that share a common summary task are sorted within that group 
but are not moved beyond the group.

Manual Sort leaves the tasks in the order they are positioned without sorting.
When Manual Sort is turned off, tasks are sorted on the basis of the data columns chosen as sort keys.

Sort Keys
1st Sort Key determines which data column is used as the basis for sorting. 
2nd Sort Key determines which data column is used as the basis for sorting any tasks that tie for the 
same position in the first sort.
3rd Sort Key determines which data column is used as the basis for sorting any tasks that tie for the 
same position in both the first and second sort.
Descending sorts tasks from the highest to lowest numerical value or alphabetically from Z to A.    
When turned off, tasks are sorted in ascending order, from lowest to highest numerical value or 
alphabetically from A to Z.

As long as the Manual Sort option is turned off, the sorting action continues so that any task you move 
automatically returns to its sorted position.    Use the Update Manual Sort command on the Options menu 
to set the current sort order as the new manual sort order.

Related Topics:
Other Gantt Window Formatting Options



Format PERT Window

When the PERT window is active, choosing the Active Window command from the Format menu lets you 
customize the task boxes.    The Format PERT box opens for you to select:

Layout Name: The name you enter identifies the customized window from the Window menu.

Zoom % enlarges or reduces the onscreen image by the percentage entered.    The Zoom tools have the 
same effect.    For printing, use the Scale options in the Print box instead.

Task Box 
The task box shown serves as a model for all detail tasks.    You can customize it by

· Adding fields with the Insert button.
· Dragging additional fields to new positions that change the size or shape of the box.
· Stretching fields by dragging either end.

Insert opens the Insert Field box where you can select a new field from a list corresponding to the 
Spreadsheet data columns. 
Delete removes the currently selected field from the task box. Click a field to select it for deleting.

Snap to Alignment positions the task boxes on an invisible grid to align them neatly.

Formatting choices for Fonts & Colors and Global Defaults apply to field text in the PERT window.

Related Topics:
Reorganizing Task Boxes



Format Resource Spreadsheet

When the Resource Spreadsheet is active, choosing the Active Window command on the Format menu 
lets you customize the data columns presented in the Spreadsheet.

Shortcut:    Double-click the data column titles in the Resource Spreadsheet to open the Format 
Resource Spreadsheet box. 

Layout Name: The name you enter identifies the customized window on the Window menu.

Zoom % enlarges or reduces the onscreen image by the percentage entered.    The Zoom tools have the 
same effect.    For printing, use the Scale options in the Print box instead.

Spreadsheet
The table shows the current layout of data columns in the Resource Spreadsheet. 

· Click a cell to select it for editing, inserting, or deleting.
· Edit the Name, Width, or Custom Title by typing in the edit bar.

· Click  to select from a list of available columns. 

Name lists the data columns in the order they appear from left to right. 
Width sets the width of the column in characters.    You can also change column widths onscreen by 
dragging the lines that separate the column titles.
Custom Title replaces the standard column title with the title entered here.
Insert opens space for a new column at the selected position.
Delete removes the selected column from the Spreadsheet.
Grid Lines displays gray lines to separate rows and columns.
Sort Alphabetically organizes the list of Resource Names alphabetically.

Related Topics:
Formatting Global Defaults
Data Columns for the Resource Spreadsheet



Formatting Global Defaults

The Global Defaults command on the Format menu customizes the fonts and colors of various text and 
graphic elements in the screen display and in printed reports.    The Format Global Defaults box opens:

Item 
The font and color choices displayed opposite apply to the current selection in the Item list.    Selecting 
[Default] in the Item list applies the current font and color options to all text for task and resource data, 
and to all categories in the Item list that you do not customize separately.

Font

Name: The font in which the selected item will be formatted. Available fonts depend on the setting for 
Printer Fonts.    Selecting [Default] here applies the font, size, and style options currently set for the 
item labeled [Default].

Size: The point size of the selected font.    If you are using a printer font for a PostScript printer you 
can type in font sizes that are not listed.

Style: Bold, Italic, Underline, and Strikethrough options can be used in combination.    Not all style 
options are available for all fonts, and screen font styles may differ from printed styles. 

Printer Fonts displays fonts available for the active printer in the Font Name list box.    When turned 
off, only standard Microsoft Windows screen fonts appear in the Font Name list box.

Colors
Selecting [Default] applies the colors currently specified for the [Default] option in the Item list.

Foreground sets the color of text in the spreadsheet cells, task bars, dependency lines, and PERT 
window task boxes. 

Background sets the background color of the spreadsheet cells and PERT task boxes.

Sample Text demonstrates the selected fonts and colors selected. 

Clear restores all options to the default settings.

Related Topics:
Formatting Selected Tasks and Resources
Selecting a Printer and Installing Fonts
Using Highlights
Headers, Footers, and Borders (Page Setup)
Cost Graphs and Histograms
Print Calendar



Format Task Bar Symbols

The Task Bar Symbols command on the Format menu customizes the fill patterns, symbols, and line 
styles used in the Time Scale pane.    The Format Task Bar Symbols box opens:

Sample Tasks demonstrates the fill patterns currently selected for summary and detail task bars.    Each 
sample shows the baseline task bar behind the current task bar.    The left side shows the completed 
portion of the bar and the right shows the remaining portion.

Click the Patterns, Symbols, or Lines button to see more options.

Patterns
Up to 13 different patterns can be used to distinguish task bars.

Complete and Remaining portions of each task bar are determined by the amount entered for 
Percent Complete.
Baseline task bars show the original baseline information for comparison with current revisions.

Symbols 
Additional symbols can be used to mark the start and end of each task bar or to indicate milestones.

Use Custom Symbols puts the currently selected symbols into use.    Sample Tasks demonstrates 
the selected symbols.

Lines
The Time Scale options in the Format Gantt box determine whether slack and delay lines are displayed or 
hidden.    Use different line styles to distinguish them.

Fixed Delays show delays to fixed tasks as a line from the fixed start date to the scheduled start 
date of the task.
Resource Delays show delays caused by resource leveling as a line from the original start date to 
the start date rescheduled after leveling.
Slack shows the slack time available as a line from the end date to the date when further delay 
would affect other tasks.    Use the Calculations command on the Options menu to select alternate 
methods of calculating slack.

Use the Page Setup command to include a legend identifying task bar symbols on printed reports.

Related Topics:
Formatting Time Scale Options
Milestones



Format Highlights

 Click the Highlights button on the Icon Bar or choose Highlights from the Format menu to identify 
tasks that meet specific conditions by displaying them in distinctive fonts or colors.    The Format 
Highlights box opens for you to select the conditions.

Up to six different highlight conditions can be used simultaneously and are distinguished by different fonts 
and colors.    Select each from the list of pre-defined conditions.    On printed reports, the legend set in the 
Page Setup box identifies the highlights.

Click for an explanation of each condition:

Almost Critical
Consolidated Tasks
Critical
Custom Date Range
Late (vs. Baseline)
Milestones
Near Critical
Needs Update
Not Completed
Over Budget (vs. Baseline)
Resource Combo
Resource Conflict
Text Combo
This Week/Month/Quarter/Year
[Resource Names]

New opens the Define New Condition box where you can name a new condition before defining it.

Edit opens the Define Condition box where you can edit or examine the selected condition.

Clear removes the selected highlight condition.

Use the Global Defaults command on the Format menu to customize fonts and colors for each highlight 
condition. 

Highlights apply only to the currently active window.    Different highlight conditions can be used in 
different windows.

Related Topics:
Using Filters



Expanding the Outline

The Expand command on the Outline menu opens any selected summary tasks that have previously 
been collapsed, displaying the tasks indented beneath them.    Collapsed tasks are marked by a plus (+) 
sign in the Task Name column.    This command affects only the active window.

Shortcut:    Double-click on the task you wish to expand in the Gantt or PERT window.

 Click the Expand All button on the Icon Bar or choose Expand All from the Outline menu to open all 
summary tasks that have previously been collapsed.    This does not affect tasks that are hidden by a filter 
or hoist.

Related Topics:
Selecting Tasks
Outline Overview
Summary Tasks



Collapsing the Outline

The Collapse command on the Outline menu closes the selected summary task, hiding any other tasks 
indented beneath it.    A plus (+) sign precedes the task name to show that it is collapsed but does not 
appear on printed reports.    This command affects only the active window.

Shortcut:    Double-click the task you wish to collapse in the Gantt window.

 Click the Collapse All button on the Icon Bar or choose Collapse All from the Outline menu to close 
all summary tasks so that only tasks at the highest level of the outline are visible.    If a filter or hoist is in 
effect, this may remove all tasks from view.

Related Topics:
Outline Overview
Expanding the Outline
Summary and Detail Tasks
Selecting Tasks



Indent

 Click the Indent button on the Icon Bar or choose Indent from the Outline menu to indent selected 
tasks one level in the outline.    You can also use the Move tool to indent a single task by dragging the 
Task Name to the right.

Indenting a summary task automatically indents all tasks beneath it one level further.    The task 
immediately above an indented task becomes its summary task.    When indenting a task causes another 
task to change from a detail task to a summary task, some information may be lost and replaced by 
calculated data.    See Tasks for more information.

Related Topics:
Selecting Tasks
Outline Overview
Summary and Detail Tasks
The Outdent Command



Outdent

 Click the Outdent button on the Icon Bar or choose Outdent from the Outline menu to move selected 
tasks one level higher in the outline.    You can also use the Move tool to outdent a single task by dragging 
it to the left.

Outdenting a summary task automatically outdents all detail tasks beneath it.

Outdenting a task may cause its former summary task to become a detail task; when this occurs, costs 
that were previously calculated as summary roll-up information may change.

Related Topics:
Selecting Tasks
Outline Overview
Summary and Detail Tasks
Indent



Moving Up and Down in the Outline

The Move Up and Move Down commands on the Outline menu move a selected task up or down to a 
new position at the same level of the outline under the same summary task.

Shortcut: Use the Move tool to drag a task to a new position anywhere in the outline.

Related Topics:
Selecting Tasks
Outline Overview



Hoisting and Dehoisting the Outline

 Click the Hoist button on the Icon Bar or choose Hoist from the Outline menu to display only the 
selected task and any tasks indented beneath it, hiding all others from view.    This is useful for isolating 
subprojects in the plan.    You can use the Hoist command repeatedly to focus on deeper levels of the 
outline.

The Dehoist command on the Outline menu removes any hoists in effect, restoring the full outline to view. 

Shortcuts:    Press [Shift] and double-click a task to hoist. Click the Dehoist button on the status line to 
restore all tasks to view.

Hoist and Dehoist affect only the currently active window.

Related Topics:
Selecting Tasks
Outline Overview
Collapsing the Outline
Expanding the Outline



Updating Consolidations

Choose the Update Consolidations command on the Options menu to import the most recent data from 
any external schedules that are consolidated in tasks within the current schedule. 

Because Time Line also offers the option of updating a schedule containing consolidated data whenever 
you open it, this command is intended for use on a Local Area Network where external schedules may be 
updated simultaneously with the current schedule.

Related Topics:
Consolidating Schedules



Schedule Options

The Schedule command on the Options menu presents important information about the schedule as a 
whole in the Schedule Options box.    This box also opens automatically when you begin a new schedule, 
as long as Quick Start is selected in the Preferences box.

General Information
Schedule Name identifies the plan in printed reports.
Manager identifies the manager in printed reports.

Select Title & Border Options in the Page Setup box to include these names in printed headers 
or footers.

Schedule Start Date sets the date on which all tasks start unless postponed by dependencies, fixed 
dates, or other constraints.    No task can start before this date, which is marked by a vertical blue 
line in the Time Scale pane.    Directly or indirectly, this date affects the scheduling of all tasks. 

Schedule Statistics summarizes the start dates, end dates, and duration of the schedule as a whole, as 
well as the total effort and cost for all tasks.    If you have set a baseline, the original as well as the current 
version of the schedule is summarized.

Related Topics:
Preferences
Scheduling Logic 



Preferences

The Preferences command on the Options menu controls miscellaneous choices, including default 
settings for task options.    The Preferences box opens for you to select:

User
The settings for these options affect all schedule files and are stored in the TLWIN.INI file.

User Name includes your name in the header or footer of a printed report when specified in    Title & 
Border Options in the Page Setup box.
Date Format sets the style for all dates shown in Time Line. Changing the separator affects the 
options shown.
Separator sets the character between day, month, and year in the Date Format.    Do not use 
numbers or letters.
Insert Position determines whether the Insert and Paste commands on the Edit menu add items 
after (below) or before (above) the selected item.
Quick Start automatically opens a dialog box to help you choose a file when starting Time Line, and 
opens the Schedule Options box when you create a new file.    When Quick Start is turned off, these 
boxes do not open automatically.
Co-Pilot dialog boxes appear when you make changes that affect scheduling logic.    Simple 
questions guide you in setting fixed dates and dependencies, or changing assignments.    When Co-
Pilot is turned off, these boxes do not appear.    The Co-Pilot button on the Icon Bar serves as a 
shortcut for this option.
Icon Bar displays a row of icons below the menu bar to serve as shortcuts for menu commands.    
When turned off, the Icon Bar is hidden from view.

Task Defaults affect tasks created after the default is set.    Changing the defaults does not affect existing 
tasks.

Driven By determines whether new tasks are duration-driven or effort-driven.    You can also enter 
the typical amount of duration or effort that Time Line uses as a default for newly created tasks.    The 
method of driving a task and the estimated duration or effort can be edited for individual tasks in the 
Task Info Box.
Task Type determines the default method for scheduling tasks: as soon as possible, as late as 
possible, or on fixed dates.    Task type for individual tasks that vary from the default can be set in the 
Timing Info Box.

Related Topics:
Schedule Options
Calculations



Calculation Options

    Click the Calculations button on the Icon Bar or choose Calculations from the Options menu to set 
choices for different methods of recalculating the schedule.    The Calculations box opens for you to 
select:

Recalculation
Automatic recalculates the schedule automatically whenever a change affects timing, workloads, or 
costs.
Manual displays the Recalc button on the status line whenever a change affects timing, 
assignments, or costs.    You can then click the Recalc button or press [F9] to recalculate the 
schedule.    Each recalculation takes processing time, so save time by making several changes 
before manually recalculating.

Date Line
Time Line uses the As-of Date as the beginning of the current reporting cycle for automatically updating. 
It appears as a red line in the Time Scale pane.

Today sets the As-of Date at today's date.
Date sets the As-of Date at a date you specify, usually the beginning of a weekly or monthly cycle for 
status reports.
Slip Tasks to As-of Date moves any tasks that were scheduled to start before the As-of Date but 
have not yet begun, rescheduling them to start at the As-of Date.    Use this to automatically update 
tasks that have slipped.    Time Line determines whether a task has begun by the amount entered for 
Percent Complete. 

Slack
Free calculates slack as the amount of time a task can slip without affecting the timing of any other 
task, except its own summary tasks.
Total calculates slack as the amount of time a task can slip without affecting fixed dates or the end 
date of the entire schedule.

Use the Time Scale options in the Format Gantt box to display slack lines on the task bars.    See the Help 
topic Slack for more information. 

Level Resources avoids the overcommitment of resources by delaying tasks until the assigned resource 
is available.    The amount entered in the Max Available column of the Resource Spreadsheet determines 
the maximum commitment for a resource.

Duration Conversions opens the Duration Conversions box to set rules for converting equivalent time 
units measuring task durations.

Percent Complete Weighting sets a weighting factor to emphasize a particular aspect of the schedule 
when calculating the percent complete of summary tasks from their detail tasks.    Each detail amount is 
multiplied by the value for that task of the data column chosen as the weighting factor.    The resulting 
detail amounts are added, and then divided by the sum of the weights.

Baseline Cost produces a standard earned value analysis. 
Total Cost approximates standard earned value analysis without a baseline. 
Other Cost or Resource Cost may sometimes produce a more accurate reflection of the true value 
of tasks than Baseline or Total Cost.
Baseline Effort is an alternative method of earned value analysis,useful if material costs distort the 
analysis of resource costs.
Effort produces an approximation of effort analysis useful when no baseline is set.
Baseline Duration weights tasks based on original estimates for duration. 
Duration gives more weight to longer tasks.
Calendar Duration factors in nonwork time excluded from Duration or Baseline Duration.
Numeric factors in the amount entered in the Numeric data column so you can create your own 



weighting system.

Related Topics:
Preferences
Updating Percent Complete



Calendars

The Calendars command on the Options menu sets the work time and holidays that controls task 
scheduling.    The Master Calendar applies to all tasks in the schedule; individual resource calendars 
apply only to effort-driven tasks to which that resource is assigned.

The Calendars box opens for you to select:

Calendar:    Select Master Calendar to set the standard workweek and holidays that apply to all tasks.    
Select a resource to set a workweek or vacations that apply only to that resource.

Workweek opens the Standard Workweek box to set the workhours for each day in the week.    These 
hours appear as the defaults in the calendar display.    Variations on the Standard Workweek can be set 
individually for each resource. 

Click Duration Conversions in the Standard Workweek box to see the equivalents for calculating durations 
entered in various time units.    These settings should be adjusted to correspond to any changes in the 
Standard Workweek for the Master Calendar.

Editing the Calendars
Any changes made to the Master Calendar also apply to resource calendars and appear in blue.    
Changes to a resource calendar appear in red and override the Master Calendar in scheduling effort-
driven tasks assigned to that resource.

· Edit the number of work hours directly on the calendar.    The pointer becomes an insert 
cursor ( | ) over the number.

· Double-click a gray date number to switch between a full workday or 0 hours for that day.
· Click the scroll bar arrows to move one month at a time.

Holidays opens the Holidays box to select from a list of commonly observed holidays.    Selected holidays 
apply to all calendars.

Reset clears any changes you have made to the calendar.    If the Master Calendar is displayed, the 
default settings are restored.    If a resource calendar is displayed, it is reset to match the Master 
Calendar. 

If the calendar settings you use for most projects differ from the Time Line defaults, change the defaults 
by saving your customized settings in the DEFAULT.TLP file. 



Recalculating the Schedule

Clicking the Recalc button or pressing [F9] has the same effect as choosing the Recalculate Now 
command on the Options menu: Time Line recalculates the schedule, incorporating any changes made 
since the last recalculation. 

You need to recalculate changes only if you select Manual Recalculation in the Calculations box.    When 
Automatic Recalculation is selected, Time Line automatically recalculates each time you change 
information that affects scheduling, assignments, or costs.



Reposition PERT

Clicking the Reposition button has same effect as choosing the Reposition PERT command on the 
Options menu: Time Line organizes the task boxes in the PERT window by positioning each one to the 
right of any predecessor tasks. 

Tasks that are hidden by the Hoist or Collapse commands are not affected, so that you can reorganize the 
PERT window selectively.    To reposition all tasks, first choose the Dehoist and Expand All commands on 
the Edit menu.

Related Topics:
The PERT Window
Formatting the PERT Window



Updating Percent Complete

 Click the 100 Percent Complete button on the Icon Bar or choose Update Percent Complete on the 
Options menu to adjust the Percent Complete field to reflect the amount of work completed for tasks that 
have started.    The Update Percent Complete box opens for you to select:

Mark At 100% Complete adjusts the percent complete field to 100% complete for all tasks or selected 
tasks.

Calculate Based On The As-of Date adjusts the percent complete field to indicate the portion of each 
started task's duration that falls before the As-of Date, divided by its total duration.    If you have already 
entered a higher amount for any task, Time Line does not change the percent complete.    (If you first 
selected Slip Tasks to As-of Date in the Calculations box to reschedule tasks that have not yet started, 
only tasks that have a previous estimate for percent complete are adjusted.)

For Selected Tasks Only applies the update process chosen above only to started tasks that are 
currently selected.

For All Tasks applies the update process chosen above to all started tasks in the schedule.

You can also adjust the amount of work completed by editing the Percent Complete column or field in the 
Task Info Box.



Setting the Baseline

The Set Baseline command on the Options menu takes a "snapshot" of the current schedule for 
comparison with later revisions.    The Set Baseline box opens:

All Tasks records the entire schedule.
Selected Tasks Only records only those tasks that are currently selected.    This is useful for making 
limited changes to a baseline previously set.

Information on the start date, end date, duration, and cost of each task is copied into the following data 
columns:

Baseline Start
Baseline End
Baseline Duration
Baseline Cost 

As you make changes to tasks, Time Line keeps two sets of data for each task: the baseline version and 
the current version. 

You can display task bars showing the baseline along with current task bars by clicking the Baseline 
button on the Icon Bar or selecting Baseline in the Format Gantt box.



Update Manual Sort

The Update Manual Sort command on the Options menu sets the current sorted order of tasks as the 
normal order so that you can move tasks freely without having them forced back to a sorted position.

This command is available only when the Manual Sort option is turned off in the Format Gantt box.



Opening a New Window

The New Window command on the Window menu opens a new Gantt, PERT, or Resource Spreadsheet 
window.    The New Window box opens for you to select the window type.

Click for more information on a window type:

    Gantt

    PERT

    Resource Spreadsheet

To customize a new window, use the Active Window command on the Format menu.

Note that saving or retrieving a file with a large number of windows may be slow, depending on your 
system configuration.    It is better to save a large number of windows to a library file, which you can open 
as needed.



Opening a Library File

The Open Library File command on the Window menu retrieves a library file and opens all the windows 
contained within.

The Open Library File box appears first, for you to specify the directory and filename:

File Name: The path and filename currently selected for opening appears at the top of the list of all library 
files in the selected directory.    The extension .TLL identifies Time Line library files.    Double-click a 
filename to open it. 

Directories:    The directory currently open for selection appears at the top of the list of all directories at 
the current level.    Double-click a directory to open it.

Drives:    The drive on which the listed directories are located.

List Files of Type:    Identifies the filenames to be listed above, whether Time Line or On Target, by 
means of the extension. 

Click OK to open the windows in the selected library file.    Any other windows currently open are not 
affected.

Related Topics:
Creating Library files



Saving Windows as a Library File

The Save as Library File command on the Window menu stores your customized window layouts in a 
library file.    You can then open the library in a different schedule to display that schedule in the 
customized windows.    Use libraries to store groups of standard reports that you produce periodically.

The Save as Library File box opens:

File Name: The path and filename currently selected for saving appears at the top of the list of all library 
files in the selected directory.    The extension .TLL identifies Time Line library files.    Click a filename to 
select it. 

Directories:    The directory currently open for selection appears at the top of the list of all directories at 
the current level.    Double-click a directory to open it.

Drives:    The drive on which the listed directories are located.

List Files of Type:    Identifies the filenames to be listed above, whether Time Line or On Target, by 
means of the extension. 

Options
Active Window Only saves a library file containing only the currently active window.
All Windows as a Group saves a library file containing all windows currently open.

Related Topics:
Opening a Library File



Tiling Windows

The Tile command on the Window menu arranges any currently open windows side by side on the screen 
without overlapping.

Related Topics:
Cascading Windows



Cascading Windows

The Cascade command on the Window menu arranges any currently open windows in an overlapping 
series staggered diagonally on the screen.    The title bar of each window is visible so that you can easily 
select a new active window.

Related Topics:
Tiling Windows



Arranging Window Icons

The Arrange Icons command on the Window menu organizes any minimized window icons side by side in 
the bottom left corner of the screen.

Related Topics:
Minimizing and Restoring Windows



Currently Open Windows

Any windows currently open are listed at the bottom of the Window menu.    Default versions of the 
Resource Spreadsheet, PERT, and Gantt windows open automatically with a new file.    Activate a window 
by choosing it from this list.

The windows are numbered on the Window menu in the order they were opened, and identified by 
window type.    If you have named a layout when customizing the window with the Active Window 
command, the name also appears on the menu.    Choosing a window name from the menu activates that 
window.    A checkmark on the menu shows the currently active window. 

Use the New Window command on the Window menu to open new default windows for customizing.

Any open windows are saved with the file when you use the Save or Save As command on the file menu. 
You can also save windows independently for use with other plans by creating a library file.



Using Help

You can get help in Time Line several different ways:

· Press [F1].    The Help window opens on a topic related to the currently selected menu 
command, dialog box, Info Box, or window.

·     Click the Help Pointer button on the Icon Bar or press [Shift/F1], or choose Point 
from the Help menu to use the help pointer. 

 With the help pointer, click an object on the screen to open the Help window on its topic.

· If you have a 3-button mouse, click the middle mouse button to open the Help topic for the object 
under the cursor.

· Choose Index from the Help menu to open an alphabetical index of Help topics.    Click a topic 
to go there.

· Choose Menus from the Help menu to open a list of Time Line menu commands, organized as 
they appear on-screen.    Click a command name to learn about it.

· Choose Time Line DOS from the Help menu to learn about importing Time Line for 
DOS files into Time Line for Windows, and about differences between the two programs. 

Click the Search button while the Help window is open, and type or select a word to view a list of related 
topics.    Select a topic and click the Go To button.

While the Help window is open, you can click any text that looks like this underlined text to go to a related 
topic.    Click and hold the mouse button down for any text that looks like this dashed underlined text for a 
quick explanation on the spot.

The Tutorial command on the Help menu launches a computer-based "tour" of Time Line.    The tour 
shows you how to quickly create and present your first plan, and also gives you a brief overview of Time 
Line features.

The About command on the Help menu provides information about this version of Time Line.



New Topic

This is an example of jumping to a related topic from another topic in Time Line Help.    Go back to Using 
Help by clicking the underlined words or choosing the Back button. 



Definition 

This is an example definition.



Tutorial

Choose Tutorial from the Help menu to launch a computer-based "tour" of Time Line.    The tour shows 
you how to quickly create and present your first plan, and also gives you an overview of some of the 
features of Time Line.

A separate workbook tutorial is included in Chapter 2, Up & Running of the Time Line for Windows User 
Manual.



Using Info Boxes

Info Boxes are small windows that present information on the currently selected item.    There are four Info 
Boxes; each can be opened by clicking its icon or by choosing Info Boxes on the Options menu:

    Task Info: basic task information.

    Timing Info: dependencies and scheduling.

    Note Info: any notes concerning the task or resource.

    Assignments Info: resource assignments for the task. 

Info Boxes can be left open while you work in the main window. The information changes to reflect the 
selected task, and you can edit the fields of the Info Box.    Time Line accepts any changes as soon as 
you click elsewhere; no OK button is needed.

The colored title bar shows when an Info Box is active.    When boxes overlap, click on one to bring it to 
the front.

You can move an Info Box by dragging the title bar.    Close the box by clicking its icon again or double-
clicking the Control Menu icon on the box.



The Task Info Box

    Open the Task Info Box by clicking its icon.

The Task Info Box contains basic information on the selected task.    Each field corresponds to one of the 
data columns available for the Spreadsheet.    You can edit the fields within the box, or use it to review 
information as you move from task to task. 

Information that appears grey cannot be edited, as it is calculated automatically.    For summary tasks, 
some fields are calculated based on information for their detail tasks.

Click a field name for more information:

Name
Responsible
Keyword
Other Cost
TotalCost
Percent Complete
Duration
Effort
Start
End

In the Responsible field, you can choose from the resources listed or type in a new name.    Choose 
[Inherit] for a detail task if you want the person responsible for its summary task to be assigned 
automatically.

Click Duration or Effort to determine which method drives the task before entering data in one of these 
fields.

Related Topics:
Using Info Boxes
Summary and Detail Tasks
Fixed Tasks



The Timing Info Box

    Open the Timing Info Box by clicking its icon.

The Timing Info Box contains information on dependencies and fixed dates that directly affect the 
scheduling of the selected task.

The scrolling list describes the dependencies of the selected task to any predecessor tasks, or in the case 
of a selected ALAP task, to any successors.    Click a dependency in the list to select it for editing or 
deleting.

Type determines how Time Line schedules the task.
ASAP tasks start as soon as possible after the schedule start date.
ALAP tasks start as late as possible, allowing for the schedule end date.
Fixed Start tasks start on the date you set in the Start field.
Fixed End tasks end on the date you set in the End field.
Fixed Start tasks start and end on the dates you set.

Any task type can be delayed by dependencies, but only delays to fixed tasks can be shown as 
Delay Lines on the task bars.    Resource leveling can delay ASAP tasks but not fixed tasks. 

Start and End set the fixed dates for starting and/or ending the selected task, if you have chosen Fixed 
Start, Fixed End, or Fixed Start and End for the task type.

Commands menu:

Add opens the Add Predecessor (or, for ALAP tasks, Add Successor) box, where you can create a new 
dependency for the selected task.

Edit opens the Edit Dependency box, where you can adjust the dependency selected in the scrolling list 
to schedule lead or lag time between the two tasks. 

Delete removes the dependency selected in the scrolling list.

Controlling opens the Controlling Factors box where detailed information appears on the factors that 
determine the timing of the selected task.

Related Topics:
Using Info Boxes
Scheduling Logic



The Note Info Box

    Open the Note Info Box by clicking its icon.

Use the Note Info Box to write notes or reminders about the selected task or resource.    The first line of 
text entered here also appears in the Note data column.

The Note Info Box displays icons for any attached documents that are embedded or linked to the task or 
resource.    Select an icon by clicking it, or activate it by double-clicking it.    The Attachments menu in the 
Note Info Box, like that on the Edit menu, provides commands for activating, deleting, or changing 
attachments.

Related Topics:
Using Info Boxes
Linking and Embedding Attachments



The Assignments Info Box

    Open the Assignments Info Box by clicking its icon.

The scrolling list names the resources assigned to the selected task, the "amount" of the resource 
assigned, and the equivalent amount of effort.    For example, 1.00    5d represents a single individual 
working fulltime, or two people each working half-time for a period of 5 workdays.    An asterisk (*) marks 
the resource named as responsible, if any.    The caret (^) marks resources that are overcommitted.    The 
tilde (~) marks resources whose assignments have been leveled.

Click a resource to select it for deleting or editing. 

Commands menu:

Add opens the Assign Resource box to add a new resource to the task.

Delete removes the selected resource from the task.

Edit opens the Edit Assignment box for you to adjust the selected assignment amounts.

Related Topics:
Using Info Boxes





The Gantt Window

The Gantt window is the most important window in Time Line.    Based on a Gantt chart, it consists of two 
panes that scroll horizontally and vertically:

The Spreadsheet pane displays one task in each row in an outline structure.    A broad range of data 
columns is available to display different task information.

The Time Scale pane shows the duration of each task as a bar graph plotted over time. 

You can edit the information displayed in the Spreadsheet pane and also adjust the task bars to change 
their timing.    Use the pane divider to adjust the size of each pane relative to the other. 

You can also display cost graphs, crosstabs, and histograms in the Gantt window. Choose Active Window 
from the Format menu to display graphs, select data columns for the Spreadsheet, and choose other 
customizing options.



The PERT Window

Choose PERT on the Window menu to activate the PERT window. 

The PERT window, similar to a PERT chart, is the best view for visualizing dependencies.    Tasks appear 
as boxes connected by arrows representing dependencies.    Detail tasks are nested inside the boxes of 
their summary tasks, which have a shaded edge.

To organize the layout of task boxes quickly, click the Reposition button on the status line.    Reposition 
the first time you enter the PERT window and whenever you want to automatically rearrange task box 
positions.

Choose Active Window from the Format menu to adjust the size of the task boxes and display task data 
in fields corresponding to the data columns available for the Gantt window.

· Click a task box to select it for editing.
· Use the Move tool to drag a task box to a new position.
· Double-click to insert a new task box in the window.
· Double-click inside a summary task box to add a new detail task beneath it.
· Use the Connect tool to set dependencies between tasks.
· Type in the edit bar to edit information in the selected task box field.



The Resource Spreadsheet

Choose Resources from the Window menu to activate the Resource Spreadsheet. 

The Resource Spreadsheet displays data columns with information about each resource on a separate 
row.    The columns scroll horizontally, so you can display or print more columns than fit on screen at one 
time.

Inserting a new name in the Resource Name column adds a new resource to the plan.    Type in the edit 
bar to edit the data within a selected cell.    Some columns contain data that is calculated automatically 
and cannot be edited.    To delete a resource, select any cell in the resource row and choose Delete on 
the Edit menu or press the [Del] key.

Choose Active Window from the Format menu to change the columns displayed.    See the help topic 
Resource and Cost Data Columns for an explanation of each column. 

To assign resources to tasks from the Resource Spreadsheet:
1. Use the Tile command on the Window menu to display the Resource Spreadsheet beside 

the Gantt or PERT window.
2. Use the Connect tool to draw a line from the resource in the Resource Spreadsheet to 

the task in the other window.

Related Topics:
Assigning Resources
Histograms
Resource Leveling



The Spreadsheet Pane of the Gantt Window

The Spreadsheet pane of the Gantt window displays data columns with information about each task on a 
separate row.    The columns scroll horizontally, so you can display or print many more than fit on screen 
at one time.    An outline within the Task Name column structures the breakdown of larger tasks into more 
detailed tasks.

Double-click the column titles or choose Active Window from the Format menu to change the columns 
displayed.    See the help topic Data Columns for an explanation of each column.

Inserting a new name in the Task Name column creates a new task in the plan.    Type in the edit bar to 
edit the data within a selected cell.    Some columns contain data that is calculated automatically and 
cannot be edited.

Related Topics:
Resizing the Panes
The Time Scale Pane



The Time Scale Pane of the Gantt Window

The Time Scale pane shows the duration of each task as a bar graph plotted over time.    The date bar at 
the top of the pane sets the time scale for the graph.    A vertical red As-of Date shows the current date for 
automatic updating.    A vertical blue line shows the Schedule Start Date, set in the Schedule Options box.

Use the Select tool or the Move tool to reschedule a task bar:
· Drag the center of a task bar to move it to a new position in the schedule. 
· Drag the right side of a task bar to extend or shorten its duration.

The pointer changes shape to show which action is available.    During the move, a status box reflects the 
changing start date, end date, and duration. 

Different patterns distinguish the task bars for summary and detail tasks.    A triangle indicates a 
milestone.    Use the Task Bar Symbols command on the Format menu to customize these patterns and 
symbols.

Double-click the background of the Time Scale pane or choose Active Window from the Format menu to 
customize the task bars by displaying additional information, including:

· Text labels showing selected data.
· Additional task bars for the baseline.
· Symbols showing slack, delays, and dependencies. 

You can also display cost graphs, crosstabs, and histograms at the bottom of the Time Scale pane.

Related Topics:
Resizing the Panes
The Spreadsheet Pane



The Date Bar

The date bar at the top of the Time Scale pane controls the time scale of the task bars and of other 
graphs displayed in the Gantt window. 

The Schedule Start Date entered in the Schedule Options box sets the beginning of the date bar.    The 
Date Format selected in the Preferences box sets the format of the date bar display.

To change the date bar:
· Double-click the lower half of the date bar to change the time units.    Repeat as needed 

to cycle through the possible choices: days, weeks, months, quarters, or years. 
· Drag the dividing line between two time unit columns to change the width of the time unit 

columns.
You can also change the time scale of the date bar in the Format Gantt box under the Time Scale options.

Related Topics:
The Time Scale Pane of the Gantt Window
Calendars
Cost Graphs, Crosstabs, and Histograms



The As-of Date 

The As-of Date is represented by a vertical red line in the Time Scale pane of the Gantt window.    
Sometimes known as the status date, the As-of Date serves as the beginning of the current reporting 
cycle when updating the schedule. 

In the Calculations box you can set the As-of Date to appear at today's date (which is updated 
automatically) or at a fixed date you specify. 

Time Line uses the As-of Date in two different methods of automatically calculating the schedule:
· Update Percent Complete on the Options menu.
· Slip Tasks to As-of Date in the Calculations box.

The As-of Date also affects the information in the Timing Status column.



The Pane Divider 

    The pane divider appears as black space between the horizontal scroll bars of the Spreadsheet 
pane and the Time Scale pane at the bottom of the screen.    When the pointer changes shape 

    you can drag the Pane divider left or right to change the relative sizes of the two panes.

Related Topics:
The Time Scale Pane
The Spreadsheet Pane



The Window Controls

    The icon at the top left corner of the screen opens the application Control menu, listing commands 
to control the main Time Line window.    This menu, and the title bar and scroll bars, are standard features 
explained in your Microsoft Windows User's Guide.

    The icon immediately below the application Control icon opens the window Control menu. 
Commands on this menu are similar to the application Control menu but control only the active window 
within Time Line.

Icons at the top right corner of the screen have the same effect as some of the Control menu commands.

    Restore returns a window to its previous size after having been maximized or enlarges a window 
that has been reduced to an icon. Double-clicking a window icon also restores it.

Move lets you use the arrow keys to move the window to a new position.    Drag the title bar to move the 
window with the mouse.

Size lets you use the arrow keys to enlarge or reduce the window. Drag the window border to change the 
size with the mouse.

    Minimize reduces the window to an icon.

    Maximize enlarges the window to fill the screen.

Close closes the window.    Double-clicking the Control menu icon also closes the window.

Next brings the next open window forward as the active window.

Related Topics:
Tiling Windows
Cascading Windows
Arranging Window Icons



Select Tool

    Click the icon to use the Select tool. 

Time Line often requires you to select a task (or resource in the Resource Spreadsheet) before choosing 
a command that affects the selected item.    Use the Select tool for these actions:

· Click anywhere on a task (or resource) row, on a task bar, or on a PERT task box, to 
select it.    A black background marks the selected item.

· Click a cell in the Spreadsheet to select it for editing in the edit bar.    A red outline marks 
the selected cell, in addition to the black background for the remaining cells of that row.    
You can also click individual fields within a PERT task box for editing.

· Drag to select a continuous series of items.    In the PERT window, dragging draws a 
lasso to select any task boxes contained within.

· Press [Shift] while you click an item in the Spreadsheet to select a continuous series 
starting from the previously selected item.

· Press [Ctrl] while you click an item to select it without affecting other selected items.

You can also use the Select tool to reschedule a task by moving or resizing the task bar.    See the help 
topic on the Time Scale pane for details.



Move Tool

    Click the icon to use the Move tool.    Clicking or dragging with the right mouse button, instead of the 
left, temporarily selects the Move tool.

Use the Move tool for these actions in the Gantt window or Resource Spreadsheet:
· Click anywhere on a task (or resource) row, or on the task bar, to select it.    The Move 

tool is identical to the Select tool in this case, but it cannot select multiple items.
· Click the Task Name cell and drag to the right to indent a task in the outline.
· Click the Task Name cell and drag to the left to move a task out one level in the outline.
· Drag a task (or resource) vertically to move it up or down to a new position in the 

Spreadsheet.

Use the Move tool for these actions in the PERT window:
· Drag a detail task box to move it to a new position on the screen.
· Drag a summary task box by its border to move it to a new position on the screen.
· Draw a lasso by dragging the cursor around a group of items.    Put the Move tool on any 

task in the group and press and hold the [Ctrl] key.    When you move the task, the group 
of tasks moves also.

The Move tool does not affect the outline position of tasks in the PERT window.    If you try to move a task 
to a place that would change its outline position, it jumps automatically to an allowable position.
 
You can also use the Move tool to reschedule a task by moving or resizing the task bar.    See the help 
topic on the Time Scale pane for details.



Connect Tool

    Click the icon to use the Connect tool for setting dependencies or assigning resources.

To set dependencies with the Connect tool:
1. Click the task to be scheduled first.    A line then follows the Connect tool as you move.
2. Click the task you wish to start as soon as the previous task is finished.

Choose Edit on the Commands menu in the Timing Info Box to set other types of dependencies or 
schedule lead or lag time between the two tasks.

To assign resources to tasks with the Connect tool:
1. Use the Tile command on the Window menu to display the Resource Spreadsheet beside 

the Gantt or PERT window.
2. Use the Connect tool to draw a line from the resource in the Resource Spreadsheet to 

the task in the other window.
If the resource has already been assigned to the same task, a Co-Pilot box opens to clarify your action.

Related Topics:
Scheduling Logic
The Assign Resource command on the Edit menu



Zoom Tools

    Click the Zoom In tool to enlarge the image within the active window.

    Click the Zoom Out tool to reduce the image within the active window.

Using the Zoom tools has the same effect as entering a percentage for Zoom % when you choose Active 
Window on the Format menu.    Each time you click a Zoom tool, the image changes to the next 
percentage.

The Zoom tools affect the onscreen image only.    To enlarge or reduce the image for printing, use the 
Scale % option in the Print box.



The Edit Bar

The edit bar is below the menu bar, to the left of the tool and Info Box icons.

The text contained within the selected Spreadsheet cell, or PERT task box field, appears within the edit 
bar unless it is calculated automatically.    The pointer changes to an Insert cursor ( | ) for editing text 
within the edit bar. 

After clicking the cursor within the edit bar, the Cancel and OK icons  appear.
· Cancel ignores edits, leaving the text in the cell unchanged.
· OK transfers the edited text into the cell.

If specific choices are available for entering data in the selected cell, the drop-down list icon  appears 
at the left of the edit bar. Click the icon to select from a drop-down list. 

Related Topics:
The Gantt Spreadsheet
The Resource Spreadsheet
The PERT Window
Editing Fields in Info Boxes
Selecting Items



The Icon Bar

In the Preferences box on the Options menu you can choose to display or hide the Icon Bar, which 
displays 23 buttons.    Each button serves as a shortcut for choosing the following options or menu 
commands.    Click an item below to go to the related Help topic.

    Save

    Page Setup

    Print

    Print Preview

    Print Calendar

    Cut

    Copy

    Paste

    Expand All

    Collapse All

    Outdent

    Indent

    Hoist

    Fonts & Colors

    Highlights

    Dependency Lines

    Slack Lines

    Baseline Task Bars

    Calculations

    Consolidate

    100 Percent Complete

    Co-Pilot

    Help Point

Related Topics:
Info Box icons



Dependency Lines Button

 Click the Dependency Lines button on the Icon Bar to display or hide arrows representing 
dependencies between task bars in the Time Scale pane. 

Related Topics:
Format options for the Time Scale pane



Slack Lines Button

 Click the Slack Lines button on the Icon Bar to display or hide lines showing available slack time on 
the task bars in the Time Scale pane. 

You can choose whether the slack lines represent free or total slack in the Calculations box on the 
Options menu.

Related Topics:
Format options for the Time Scale pane



Baseline Task Bars Button

 Click the Baseline Task Bars button on the Icon Bar to display or hide the baseline task bars behind 
the current task bars in the Time Scale pane. 

The Task Bar Symbols command on the Format menu lets you customize the pattern of the task bars.

Related Topics:
Format options for the Time Scale pane





Change Link

The Change Link box opens when you click the Change Link button in the Attachment Properties box.    
Use it to edit the filename and path of an existing link if the document file has been moved or renamed 
since the link was established.

File Name: The path and filename currently selected appears at the top of the list, which shows all files in 
the specified directory that include the extension set under List Files of Type.    Click a filename to select 
it.

Directories: The directory currently open for selection appears at the top of the list of all directories at the 
current level on the specified drive.    The parent directory is [..].    Double-click a directory to open it.

Drives: Selects the drive for which directories are listed.

List Files of Type: Identifies the file format by means of the extension included in the filename list.

Related Topics:
Object Linking and Embedding (OLE)
Inserting Attachments
Pasting Attachments
Note Info Box



Create New Link

The Create New Link box opens when you select Link To Existing File in the Insert Attachments box.    
Use to specify the filename and path of the document to link to the selected task or resource.

File Name: The path and filename currently selected appears at the top of the list, which shows all files in 
the specified directory that include the extension set under List Files of Type.    Click a filename to select 
it.

Directories: The directory currently open for selection appears at the top of the list of all directories at the 
current level on the specified drive.    The parent directory is [..].    Double-click a directory to open it.

Drives: Sets the drive for which directories are listed.

List Files of Type: Identifies the file format by means of the extension included in the filename list.

Related Topics:
Object Linking and Embedding (OLE)
Pasting Attachments
Deleting Attachments and Changing Links
Note Info Box



Title & Border Options

The Title & Border Options box opens when you click Options in the Page Setup box.    Choices in the 
Page Setup box determine whether headers, footers, and borders are printed and control their position on 
the page.

Header and Footer Text
Type the text that you wish to appear in headers and/or footers. You can use these symbols to include 
information that is calculated or transferred from other places:

&p Page number
&d Today's date

From Schedule Options:
&m Manager's name 
&n Schedule name

From Calculations:
&a As-of Date

From Preferences:
&u User name

From Format Active Window:
&w Window name
&F Filter condition in effect
&R Resource specified for graphs

Borders
Select thick or thin lines, and rounded or square corners for the border lines separating the margin area 
from the report body.

Use the Global Defaults command on the Format menu to choose a color for the border background and 
to format the text of headers and footers.



Print Preview

 Click the Print Preview button on the Icon Bar or choose Print Preview from the File menu to display 
a preview of the active window or calendar report as it will appear when printed.    You can also open Print 
Preview from the Print or Print Calendar box.

All pages appear on the screen together.    Although the screen resolution produces a rough image, the 
placement of information is accurate.    Margins, titles, and borders appear as specified in the Page Setup 
box.

Next moves the zoom view to the next page in the report.

Previous moves the zoom view to the previous page in the report.

Zoom enlarges the preview to show one page at a time, beginning with the first page.    Click Zoom again 
to return to the overview.

Print prints the report in full, using the current settings in the Print or Print Calendar box.

Setup leads to the Page Setup box.

Options leads to the Print box.

Cancel closes the Print Preview without printing.

Click the pointer on a page in the overview to zoom in directly on that page.



Defining a Filter or Highlight Condition

The Define Condition box opens after you create a new condition by naming it in the Define New 
Condition box, or when you click Edit in the Format Highlights box or Filter option in the Format Gantt box. 

Use the Define Condition box to create customized conditions for filters and highlights.    Each condition is 
expressed as a statement about the data in a particular column.    Any task for which the statement is true 
is displayed by the filter or marked by the highlight.

Condition Name identifies the condition whose statement is displayed.    The drop-down list includes all 
pre-defined conditions, which can serve as examples or templates for creating new conditions.

New opens the Define New Condition box, where you can name a new condition to add to the drop-down 
list of condition names.

Copy opens the Define New Condition box, where you can name a new condition using the same 
statement as the selected Condition Name.    The new name is added to the drop-down list of condition 
names.

Delete erases the selected condition.

Rename opens the Define New Condition box where you can rename the currently selected condition.    
The new name is added to the drop-down list of condition names.

Condition Definition
The table shows the statement for the selected condition as series of cells, each containing one syntax 
category.

· Click a cell to select it for editing, inserting, or deleting.
· Edit the cell by typing in the edit bar.

· Click the drop-down list icon  to select from a drop-down list of choices for the 
selected cell.

Data Field specifies the data column that is evaluated to meet the condition.    Most of the data 
columns available for the Gantt window can be specified, as well as a Status field unique to 
conditions.
Rule gives a choice of negative or positive terms to express the statement.    If the selected field 
contains numerical data, you can also choose "less than" or "greater than" options.
Value determines which data within the selected field meets the condition.    Possible entries depend 
on the selected field.    See Status Values for an explanation of possible values for the Status field.    
Wild card characters can be used for string values.
And/Or offers a choice of logical operators to create a statement that tests for multiple conditions.

Condition Selects Related Summary Tasks includes highlighting or filtering for all summary tasks of 
any detail tasks that meet the condition.    When turned off, only summary tasks that meet the condition 
themselves are included.    To maintain the integrity of the outline structure, turn off the Outline Indentation 
option in the Format Gantt box when using a condition that does not include related summaries.

Insert adds space for a new row in the definition so that you can insert part of a statement that tests for 
multiple conditions.

Delete erases the definition row where the selected cell is located.

Related Topics:
Using Filters
Formatting Highlights



Status Values

In defining a condition for filters or highlights, the following choices are available for the Value cell of the 
definition statement when Status is the selected field:

Critical: Slack is <= 0. 
Early: Scheduled End date of task is < than Baseline End date.
Finished: Percent Complete = 100% 
Late: Scheduled End date of task is > than Baseline End date.
On Budget: Scheduled Cost = Baseline Cost of task. 
On Time: Scheduled End date of task = Baseline End date. 
Over Budget: Scheduled Cost > Baseline Cost of task. 
Planned: Percent Complete = 0. 
Ready-to-Start: All preceding tasks are completed. 
Started: Percent Complete is > 0 and < 100.
Under Budget: Scheduled Cost < Baseline Cost of task. 
Resource Conflict: A resource assignment for the task is over capacity. 
Resource Leveled: Task has been delayed due to resource leveling. 

Related Topics:
Defining Conditions



Naming a New Condition

The Define New Condition box opens under a variety of circumstances when you are required to name, 
or rename, a condition before defining it in the Define Condition box. 

New Condition Name specifies the name for the new, copied, or renamed condition. 

The name you enter here appears on the Condition Name list in the Define Condition box, and is also 
added to the drop-down list of available conditions in the Format Highlights box and in the Filter options of 
the Format Gantt box.



Creating a New Resource

The Create New Resource box opens when you click New in the Assign Resource box. 

Name of New Resource specifies a new name to add to the list of available resources. 

You can also use the Resource Spreadsheet to add new resources and to change the default assignment 
for resources that you add through the Create New Resource box.



Inserting Fields

The Insert Field box opens when you click Insert in the Format PERT box.    Use this to select a new field 
that will appear in the PERT task boxes.    Click a field name to select it. 

The list of available fields corresponds to the data columns for the Spreadsheet.    See the help topic Data 
Columns for a definition of each. 



Duration Conversions

The Duration Conversions box opens when you click Duration Conversions in the Calculations box or in 
the Standard Workweek box.    Time Line uses these settings as the basis for translating task durations 
from one time unit to another.    For example, the setting for Days per Week is used to convert a duration 
entered in weeks to the equivalent number of days.

You should only change the Duration Conversion settings when your project-wide standards for Hours per 
Day, Days per Week and Weeks per Month are different from the defaults given, in which case you should 
also change the Standard Workweek settings on the Master Calendar. 

Related Topics:
Task Duration
Calendar



Standard Workweek

The Workweek button in the Calendars box opens the Standard Workweek box, where you can set the 
normal work hours for each day in the week.    These hours appear as the defaults in the calendar display. 

Settings entered here apply to the currently selected calendar only.    Changes to the Master Calendar do 
not automatically apply to resource calendars.

You can also change the settings Time Line uses for translating equivalent time units for task durations by 
clicking the Duration Conversions button.

Related Topics:
Task Durations
Holidays



Holidays

The Holidays button in the Calendars box opens the Holidays box, where you can set commonly 
observed holidays as nonwork days.

Country sets the country for which appropriate holidays are listed.

Holidays to Observe sets the holidays that will appear as nonwork days on the Master Calendar and 
resource calendars.

· Click a holiday to select it.
· Drag down the list to select multiple holidays.
· Press [Ctrl] while you click a holiday to select or de-select multiple holidays.

Related Topics:
Standard Workweek
Task Durations



Adding Dependencies 

Choose Add from the Commands menu in the Timing Info Box to open the Add Predecessor box where 
you can set a new dependency for the selected task.    If the selected task is an ALAP task, the Add 
Successor box opens instead.

While the box is open, click the task which is to become a predecessor or successor of the previously 
selected task.

Related Topics:
Dependencies



Editing Dependencies

The Edit Dependency box opens when you choose Edit from the Commands menu in the Timing Info Box 
while a dependency is selected. 

Predecessor identifies the earlier task in the dependency relationship.

Successor identifies the later task in the dependency relationship.

Type defines the dependency between the predecessor and successor as a relationship between the 
start and/or finish of either task.    Finish-to-start is the normal default. 

Lead/Lag lets you schedule a gap or overlap between the tasks by specifying the amount of time, 
whether positive or negative, between the start and/or finish chosen under Type.    For example, in a start-
to-start dependency with lead/lag set to 2 days, the successor starts two days after the start of the 
predecessor.

When Co-Pilot is turned off in the Preferences box, the Edit Dependency box opens automatically if you 
try to set a dependency between two tasks that are already connected.

Related Topics:
Scheduling Logic



Controlling Factors

Choose Controlling from the Commands menu in the Timing Info Box to open the Controlling Factors box, 
which displays detailed information on factors that affect the timing of the selected task. 

Possible factors are:

· The Schedule Start Date, set in the Schedule Options box, determines the earliest 
possible start date.

· Fixed start or end dates have been set in the Timing Info Box.
· A dependency on a predecessor controls the timing.    (ALAP tasks may be controlled by 

successors.)
· Resource conflicts have delayed the start date, as a result of selecting Level Resources 

in the Calculations box.
· For effort-driven tasks, assigned resources are unavailable because of vacation or other 

nonwork time set on the resource calendars.
· The task has been moved to the As-of Date as a result of selecting Slip Tasks to As-of 

Date in the Calculations box.
· The start date of a summary task of the selected task is delayed by one or more of the 

factors above. 

Related Topics:
Scheduling Logic



Editing Assignments

The Edit Assignment box opens when you choose Edit from the Commands menu in the Assignments 
Info Box while an assignment is selected.    If Co-Pilot is turned off, the Edit Assignment box also opens 
automatically when you assign a resource to the same task twice. 

Use the Edit Assignment box to change the resource assignment selected in the Assignments Info Box.

Number Assigned defines the assignment for duration-driven tasks as the number of individuals working 
fulltime, or an equivalent.    For example, an entry of 1.00 could indicate one individual working fulltime, or 
two individuals each working half-time. 

Effort defines the assignment for effort-driven tasks as the amount of worktime the resource is committed 
to the task.

Responsible names the assigned resource as the individual responsible for the task.

Delete removes the assignment from the task.



Import/Paste Error Log

When you import or paste data from a Lotus 1-2-3, CSV, or tab-delimited format file into Time Line, an 
Error Log box opens to indicate any errors that occurred during the process.

Each error message is preceded by the row and column number in the Time Line spreadsheet where the 
error occurred.    Error messages are identical to the messages that would appear if you entered invalid 
data into Time Line data columns.

The number and order of columns or fields that are imported must match those in the active window, 
whether Gantt or Resource Spreadsheet.    You can include extra columns on the right side of the Gantt 
window or Resource Spreadsheet.

If the file format you are importing does not match the format specified, many errors are generated, and 
data may be unusable.



Time Line Import Error Log

The following list of errors may appear after opening a Time Line for DOS file in Time Line for Windows:

"Task notes were truncated."
"Resource notes were truncated."
"Project notes were truncated."
Time Line for Windows allows 511 characters for note fields, including carriage return and line feed. 
If longer, the notes from the Time Line for DOS file will be truncated.

"Task notes were filtered."
"Resource notes were filtered."
"Project notes were filtered."
Time Line for Windows and Windows do not allow non-printing characters such as Greek letters and 
line and block graphics.    Time Line for Windows will replace these characters with spaces.



Quick Start

When you start Time Line, Quick Start guides you through opening a schedule. 

Use Last Schedule reopens the most recently used file.

Use Another Schedule lets you select any previously created Time Line file.    This is the same as 
choosing the Open command from the File menu.

Create New Schedule opens a new empty file.    The Schedule Options box opens for you to set the 
schedule start date.

Use Starter Schedule opens the template file you select from the list box.    The Starter Schedules are 
adaptable generic plans designed for typical business situations.    The Schedule Options box opens for 
you to set the schedule start date.    See Chapter 2, Up and Running, of the Time Line for Windows 
User Manual, for details on customizing the Starter Schedules.

If you prefer to start Time Line without help from Quick Start, choose Preferences from the Options menu 
and deselect the Quick Start checkbox.



Co-Pilot

Co-Pilot is an "intelligent" help feature that guides you in situations where your actions may have effects 
other than intended. 

In each case, a different Co-Pilot box opens with a series of options to clarify what you intended: 

Rescheduling a Task With No Dependencies
Rescheduling a Task With Dependencies
Setting Dependencies for Fixed Tasks
Resetting Existing Dependencies
Reassigning Resources
Exceeding the Maximum Available Assignment
Changing the Duration of an Effort-DrivenTask
Changing the Effort of a Duration-DrivenTask

Experienced Time Line users may wish to avoid these dialog boxes by turning off Co-Pilot.    You can do 
this in the Preferences box or by clicking the Co-Pilot button on the Icon Bar:



Rescheduling a Task With No Dependencies

This Co-Pilot box opens when you move the beginning of a task bar near the end of an adjacent task, 
possibly implying a dependency between the tasks.

Set dependency to start after [Task Name] connects the two tasks with a normal finish-to-start 
dependency.

Start on [date] and End on [date] set fixed dates for the start and end of the task you have moved, 
without adding a dependency.

When Co-Pilot is turned off, Time Line does not connect the tasks but sets the fixed start date for the task 
you moved.    If a fixed end date was previously set for the task, this is also revised.



Rescheduling a Task With Dependencies

This Co-Pilot box opens when you move a task bar that has dependencies to other tasks.

Update dependencies based on new position adjusts the dependencies to schedule lead or lag time 
between the tasks.    Time Line automatically makes the necessary changes in the Edit Dependency box. 

Keep dependencies leaves dependencies unchanged and cancels the movement of the task bar.

Delete dependencies removes all dependencies from the task you have moved.



Setting Dependencies for Fixed Tasks

This Co-Pilot box opens when you set a dependency to a task that has fixed dates already set.

Clear fixed dates removes the fixed dates and sets the dependency.

Keep fixed dates leaves the fixed dates and sets the dependency.

When Co-Pilot is turned off, the dependency is set without changing the fixed dates.



Resetting Existing Dependencies

This Co-Pilot box opens when you try to set a dependency between two tasks that are already connected. 
You can use this as a shortcut for editing or deleting dependencies. 

Keep dependency leaves the existing dependency unchanged.

Edit dependency opens the Edit Dependency box, where you can schedule lead or lag time between the 
two tasks.

Delete dependency removes the dependency.

When Co-Pilot is turned off, the Edit Dependency box opens automatically instead of this box.



Reassigning Resources 

This Co-Pilot box opens when you try to assign a resource to the same task twice.    You can use this as a 
shortcut for editing or deleting assignments.

Keep assignment leaves the existing assignment unchanged.

Edit assignment opens the Edit Assignment box, where you can adjust the assignment.

Delete assignment removes the assignment.

When Co-Pilot is turned off, the Edit Assignment box opens automatically instead of this box.



Exceeds Max Available 

This Co-Pilot box opens when you try to enter a Default Assignment in the Resource Spreadsheet at an 
amount greater than the entry for Max Available.

Adjust Assignment changes the default assignment to match the Max Available.

Adjust Max Available changes the Max Available to match the Default Assignment just entered.

Allow Discrepancy leaves the Default Assignment as entered without changing the Max Available.

When Co-Pilot is turned off, the discrepancy is allowed.



Changing the Duration of an Effort-DrivenTask

This Co-Pilot box opens when you enter a value in the Duration column for a task that is effort-driven.

OK changes the task from effort-driven to duration-driven.

Cancel leaves the task as effort-driven and reverts back to the original duration value.

When Co-Pilot is turned off, the task is changed to duration-driven.



Changing the Effort of a Duration-DrivenTask

This Co-Pilot box opens when you enter a value in the Effort column for a task that is duration-driven.

OK changes the task from duration-driven to effort-driven.

Cancel leaves the task as duration-driven and reverts back to the original effort value.

When Co-Pilot is turned off, the task is changed to effort-driven.



Duplicate Conditions

When combining files, the same names for filter and highlight conditions may exist in both the incoming 
file and the active file.    In this case, the Duplicate Conditions box opens for you to select:

Use existing conditions ignores the duplicate condition names from the incoming file. 

Use incoming conditions overwrites the duplicate condition names in the active file with those from the 
incoming file.

Related Topics:
Combining Files
Using Filter and Highlight Conditions



Duplicate Resources

When combining files, the same resource names may exist in both the incoming file and the active file.    
In this case, the Duplicate Resources box opens for you to select:

Use existing resources ignores the duplicate resource names from the incoming file. 

Use incoming resources overwrites the duplicate resource names in the active file with those from the 
incoming file. 

Keep both sets of resources adds the incoming resources to those in the active file, inserting them at 
the bottom of the Resource Spreadsheet.

Related Topics:
Combining Files



Move Summary Task

The Move Summary Task box opens when you try to move a summary task whose detail tasks have fixed 
dates assigned.

Revise detail fixed dates changes the fixed dates to match the new position.

Keep detail fixed dates leaves the fixed dates unchanged, although they may be delayed. 

You can display delays to fixed tasks on the task bars by selecting Delay Lines in the Time Scale options 
of the Format Gantt box.



Invalid Date

The Invalid Date box opens when you try to set a fixed start or end date earlier than the Schedule Start 
Date specified in the Schedule Options box.    The Schedule Start Date is the earliest possible date for 
any task in the schedule.

Automatically revise Schedule Start Date changes the Schedule Start Date to accomodate the fixed 
date just entered.

Cancel entered date removes the fixed date just entered.



Converting On Target Files

An On Target file is automatically converted into the Time Line for Windows format when you open the 
file.    Use the Open command on the File menu. 

When you save the file, the Save File As box opens for you to rename the file.    Using the .TLW extension 
provided ensures that the original On Target file remains unchanged.

Check the settings in the Preferences, Schedule, and Calculations boxes on the Options menu after 
opening the On Target file.    Changes may occur if the defaults used in Time Line for Windows vary from 
the original settings in On Target.

Differences between the programs may affect the schedule.    See Chapter 10, Exchanging Data With 
Other Programs in the Time Line for Windows User Manual for more detailed information on 
differences between the two programs.

· Time Line applies individual resource calendars to effort-driven tasks and not to duration-
driven tasks.    On Target does not use effort-driven tasks, and its resource calendars 
apply to all tasks.    To reproduce the original On Target schedule dates, you may need to 
change some tasks from duration-driven to effort-driven.



Starter Schedules

Starter Schedules are generic plans designed for typical business situations.    You can use them as 
templates to easily create your own schedules.

When you create a new schedule, a Quick Start box appears.    Select Use Starter Schedule to open the 
template file selected in the list box.    The Schedule Options box then opens for you to set the schedule 
start date.    See Chapter 2, Up and Running, in the Time Line for Windows User Manual for details on 
customizing the Starter Schedules. 



OLE (Object Linking and Embedding) Attachments

Attachments are documents, including spreadsheets, graphics, or word processing documents, created in 
any Microsoft Windows application that supports OLE (Object Linking and Embedding), that can be 
opened and edited without leaving Time Line.    Attachments appear as icons in the Note Info Box or the 
Attachments data column, associated with a particular task or resource.    Double-clicking an icon opens 
the document, launching the application that created it.

There are two types of attachments:
Linking connects a task or resource to an external file.    You can open and edit the file with the original 
application as well as in the Time Line schedule.    Any changes made to the file in the original application 
are updated automatically in the Time Line attachment.    Linking is preferred for files maintained by other 
users, shared on a network, or too large to embed.
Embedding inserts a new document or copies all or part of an existing document from another 
application into the Time Line file.    You can access the application within Time Line for editing, but you 
cannot open an embedded document outside of Time Line.    Embedded documents are saved as part of 
the Time Line file and therefore affect the size of the file and the amount of memory used. 

You can link or embed documents by choosing Insert Attachment on the Edit menu to initiate an 
attachment from within Time Line.    Choose Paste Attachment to attach data that was copied onto the 
Clipboard from another application that supports OLE.

Related Topics:
Deleting Attachments and Changing Links



Importing Files from Microsoft Project

Time Line provides a utility called MSP Importer for translating Microsoft Project files into the Time Line 
file format.    MSP Importer is a separate application that is included when you install Time Line for 
Windows.

To import a Microsoft Project File into Time Line:

· Recalculate the schedule in Microsoft Project and save it with the extension .MPX. 
· Open the MSP Importer from the Windows Program Manager.
· Choose Translate from the File menu.
· Enter the filename of the Microsoft Project document you want to convert, and click OK.
· Enter the filename of the new Time Line file to be created and click OK.
· Choose Exit from the File menu.

When you open the new file in Time Line, be sure to recalculate the schedule, manually or automatically, 
before proceeding. 

Data fields or columns that share the same name in both programs are treated as equivalent.    See 
Chapter 10 of the Time Line for Windows User Manual for a table of other equivalent data columns. 



Resource Leveling

Resource leveling avoids the overbooking of resources by delaying tasks until assigned resources are 
available.    The amount entered in the Max Available column of the Resource Spreadsheet determines 
the maximum availability for a resource.    Tasks with assignments that exceed this amount are 
rescheduled when Level Resources is selected in the Calculations box.

Task delays caused by resource leveling can be displayed on the task bars by selecting Delay Lines in 
the Format Gantt box.    Options in the Format Task Bar Symbols box differentiate Delay Lines caused by 
resource leveling from those caused by dependencies of fixed tasks.

Individual resources can be exempted from leveling by selecting Unleveled in the Type data column of the 
Resource Spreadsheet.    Individual tasks can be given priority during resource leveling by entering an 
appropriate number in the Priority data column of the Gantt window.

Related Topics:
Histograms



Slack

The critical path is a chain of tasks connected by dependencies, with no slack or leeway in scheduling.    A 
delay to any one of these tasks will delay other tasks in a domino effect.    A pre-defined condition for 
filters and highlights shows which tasks are on the critical path. 

Time Line offers two alternative methods of calculating slack, selected in the Calculations box:

Free slack is the amount of time a task can slip without affecting the timing of any other task, except its 
own summary tasks.
Total slack is the amount of time a task can slip without affecting any fixed tasks or the end date of the 
entire schedule.

You can display a Slack data column in the Spreadsheet, showing the amount of slack available for each 
task. Use the Time Scale options in the Format Gantt box to display slack lines on the task bars.    Use the 
Task Bar Symbols command on the Format menu to customize the style of the slack lines. 



Milestones

A milestone is a task with no duration.    Milestones are useful for marking deadlines and deliverables, and 
serve as checkpoints for evaluating progress.    You can set dependencies and fixed dates for milestones 
just like for other tasks.

To create a milestone:
· Insert a task. 
· Edit the duration to 0 in the Duration column or the Task Info Box.    Or, use the Select or 

Move tool to drag the right side of the task bar to meet the left side.

A milestone appears in the Time Scale pane as a small triangle. Use the Task Bar Symbols command on 
the Format menu to customize this symbol.



Task Durations

A task duration is an estimate of the amount of work time necessary to complete a task.    Time Line 
provides a default duration of 5 days when creating tasks.    You can change the default duration in the 
Preferences box if a different duration is typical for your tasks.

You can change the duration for each duration-driven task by using the Move or Select tool to resize the 
task bar, or by editing the Duration column in the Spreadsheet or the Task Info Box.

Do not include holidays, weekends, or other nonwork time when entering durations.    Time Line 
automatically makes adjustments for nonwork time entered in the calendars    when scheduling tasks.    
The Calendar Duration data column shows the actual time scheduled for the task.

The duration of a summary task is calculated on the basis of its detail tasks.    The duration of an effort-
driven task is calculated on the basis of its estimated effort and its resource assignments.    The more 
resources assigned to an effort-driven task, the shorter its duration.

Related Topics:
Duration Conversions



Duration-Driven and Effort-Driven Tasks

In the Task Info Box you can choose to drive a task by duration or by effort.    This choice applies only to 
detail tasks, as summary task durations depend on their detail tasks.

Duration-driven tasks
The duration you enter remains constant, regardless of the resources assigned.    You can assign 
resources to duration-driven tasks to manage costs and workload assignments, but the assignments do 
not affect the duration.    Duration-driven tasks are scheduled according to the Master Calendar without 
taking resource calendars into account. 

Effort-driven tasks
The duration is calculated on the basis of the estimate you enter for Effort and the number of resources 
assigned.    For example, an effort-driven task that takes 3 work days to complete with 1 resource takes 
only 1 day with 3 resources assigned.    Effort-driven tasks are affected by resource calendars as well as 
by the Master Calendar.    The start date of an effort-driven task is delayed until assigned resources are 
available. 

In the Preferences box on the Options menu, you can set the default method for driving newly created 
tasks, as well as the default duration or effort amount.



Outline

In the Task Name column you can create an outline to show the breakdown of larger tasks into more 
detailed tasks.    Indenting one task beneath another establishes a relationship between them as detail 
and summary tasks.    Time Line uses start dates, durations, and costs that you enter for detail tasks to 
calculate the information for summary tasks automatically as a roll-up.

The Indent and Outdent commands on the Outline menu and Icon Bar create the structure of the outline. 
The Move tool offers shortcuts for these commands.    You can indent tasks as many levels deep as you 
wish.    Detail tasks are at the lowest levels, and all tasks above them are summary tasks.

The outline structure remains the same in all windows, but you can change the display separately for 
each window to customize reports.

· Use the Expand and Collapse commands on the Outline menu display or hide the detail 
tasks indented beneath a summary task.

· Use the Hoist command to display only the selected task and any tasks indented beneath 
it.

· Turn off Outline Indentation in the Format Gantt box to temporarily display all tasks at the 
same level without affecting the outline structure.

The outline display is saved with each window in the file but does not remain in effect for windows saved 
in libraries.



Fixed Tasks

When you enter a fixed start or end date for a task in the Timing Info Box, Time Line schedules the task 
for these dates.    If dates are not fixed, the task is scheduled for the earliest possible time, allowing for 
dependencies and calendar constraints.

When dependencies or resource conflicts cause a task with fixed dates to slip, you can spotlight the 
problem in the Time Scale pane.    Select Delay Lines in the Time Scale options of the Format Gantt box 
to display each delay as a line from the fixed start date to the actual start date of the task.    Use the Task 
Bar Symbols command on the Format menu to customize the style of the delay lines. 



Scheduling Logic

Time Line assumes that you want to complete your project as quickly as possible.    If no other constraints 
were involved, all tasks would start simultaneously on the Schedule Start Date set in the Schedule 
Options box.    The information you provide about real-life constraints shapes the actual scheduling of 
tasks.

Dependencies 
When one task cannot realistically start until another is completed, a dependency between the two tasks 
includes this constraint in the scheduling.    Use the Connect tool or the Set Dependencies command on 
the Edit menu to set a dependency from the end of one task to the start of another.

The Timing Info Box displays information about the dependencies of a selected task.    Choose Edit from 
the Commands menu in this box to set dependencies other than standard finish-to-start, or to schedule 
lead or lag time between tasks.

Other factors that affect scheduling are:
· The duration estimated for each task.
· Nonwork time specified on the Master Calendar.
· Fixed dates.
· Whether tasks are duration-driven or effort-driven.
· Unavailability of resources specified on the resource calendars.
· Whether resources are leveled, as set in the Calculations box.

You can view a detailed list of all factors affecting the timing of each task by choosing Controlling on the 
Commands menu in the Timing Info Box. 

Related Topics:
Displaying Dependencies on the Task Bars
Displaying Dependencies in the PERT Window
Co-Pilot



Tasks

Tasks are activities that can be measured over time and must be accomplished to complete the schedule. 
To create a task, enter a name in the Task Name column.    Task names in Time Line do not need to be 
unique.

You can enter and display information about tasks in data columns.    A few of the most useful columns 
appear in the default Gantt window and in the Task Info Box, but many more can be displayed by 
choosing the Active Window command on the Format menu to customize the Spreadsheet pane of the 
Gantt window.

The outline structure in the Task Name column lets you break down larger tasks into more detailed tasks 
for greater control of the schedule.    Indenting one task beneath another establishes a relationship 
between them as detail and summary tasks.    The start dates, durations, and costs that you enter for 
detail tasks are "rolled up" to automatically calculate the timing and costs of their summary tasks.    You 
cannot enter this information directly for summary tasks.



Command Line Parameters

By using command line parameters in DOS, you can start Time Line automatically when you start 
Microsoft Windows. 

At the DOS prompt, type:

win timeline 

You can also specify a schedule file and a library file to open automatically on starting. 

At the DOS prompt type:

win timeline [schedule filename] [library file filename] 

If you specify both a schedule and a library file, the windows in the library are added to the existing 
windows in the schedule file.

Related Topics:
The Open command on the File menu



The TLWIN.INI File

The TLWIN.INI file is saved in your Windows directory and stores default settings that apply to all 
schedule files.    Other types of defaults can be changed and saved in the DEFAULT.TLP file.

The following defaults are stored in the TLWIN.INI file:

Recalculation: Automatic
Slack: Free
As-of Date: System date)
Slip Tasks to As-of Date: Off
Hours per Day: 8.00
Days per Week: 5.00
Weeks per Month: 4.35
User Name: Blank
Date Format: Windows Control Panel International Short Date Format default
Separator: Windows Control Panel International default
Default Duration: 5.00 days
Insert Position: After
Quick Start: On
Co-Pilot: On
Screen or Printer Fonts: Screen
Application Window (maximized or normal): Maximized
Last Schedule Filename: None

Most of the settings above can be changed in the Preferences, Calculations, and Duration Conversions 
boxes.    The Screen or Printer Fonts setting can be changed in the Format Fonts & Colors box or Format 
Global Defaults box.    The Application Window setting corresponds to the window size when you last 
exited from Time Line.    The Last Schedule Filename is the name of the last Time Line schedule you 
opened or saved.

If you delete the TLWIN.INI file, Time Line automatically recreates it.    Delete the file to restore the 
standard default settings or if the original file has been corrupted.

Related Topics:
DEFAULT.TLP File



The DEFAULT.TLP File

Settings other than those stored in the TLWIN.INI file are saved separately with each schedule file, and 
their defaults stored internally within Time Line.    When you choose the New command from the File 
menu, the default settings automatically apply.

If you would like to change the defaults applied automatically to new files, you can customize a file with 
the settings you prefer, and then save it with the filename DEFAULT.TLP.    This is useful if you routinely 
use customized calendar settings, fonts or colors, print options, task bar symbols, and other options 
associated with a particular file.

If you delete the DEFAULT.TLP file, Time Line automatically reverts to the standard defaults stored 
internally and applies them when you open a new file. 



Time Line Support Services

Within the USA and Canada:

Symantec provides a variety of technical support, training, and consulting services.    For information 
call (415) 898-1919 or Fax (415) 898-1297.

Time Line Technical Support
Phone (415) 892-1424 between the hours of 6 a.m. and 5 p.m. Pacific Standard Time.

Online Services
Symantec's Project Management Group maintains a 24-hour electronic bulletin board service free of 
charge.    Downloadable files are provided by Symantec Time Line Technical Support:

415/892-0408
Baud rate: 300, 1200, 2400
Eight data bits
One stop bit
No parity
XModem protocol for transfers

Symantec also offers support services through CompuServe.    Use the command GO SYMFORUM to 
reach the Symantec Applications Forum.    Use the Message section to leave a message or view other 
customer input.    Browse through the Library section for product information, accessory files, and 
technical tips.    To join CompuServe call (800) 848-8199.

Symantec Professional Services
Symantec offers comprehensive training and consulting services.    For information about Time Line for 
Windows workshops, consulting services, Windows installation or systems integration, call Symantec 
Professional Services at (800) 786-8620.

Outside the USA and Canada:

Please contact your local Symantec office or distributor for product support.    For information about the 
Symantec office or distributor in your area:

In Europe (Leiden, The Netherlands): Phone 31 71 353 111.    Fax 31 71 353 150.

In Australia: Phone 61 2 879 6577.    Fax 61 2 879 6805.

All other areas, contact Symantec USA: Phone 1 408 252 3570.    Fax 1 408 255 3344.



Using Time Line on a Local Area Network

To install Time Line on a local area network, run the install program on the file server.    To add users, you 
must purchase a Time Line LAN Node.    Each LAN Node you purchase provides you with one additional 
concurrent user slot for use in Time Line on the file server.

Each user can have his own personal defaults for Time Line files.    The TLWIN.INI file that Time Line 
creates is stored in each user's Personal Windows Directory.    Each user can also have his own 
DEFAULT.TLP file.
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Wild Cards

The characters "*" and "?" represent wild cards.    You may use these special characters in the Value field 
when defining a filter or highlight condition.      "*" can be used to replace any number of characters, 
whereas "?" is used to replace individual characters.    Examples of usage and meaning:

*video*: strings containing the word "video";
video*: strings starting with the word "video";
*video: strings ending with the word "video".
???video: strings starting with any three characters, followed by the word"video".

You may use any combination of the two wild card characters in each specification. 



Keyboard Equivalents For Mouse Actions

Access Menus with the Keyboard

The following keyboard equivalents navigate the menu bar and choose commands.

[Alt] + [Letter]: Select the menu whose underlined letter matches the letter you type.
[Alt] or [F10] or [/]: Select the menu bar.
[Alt] + [-]: Open the window Control menu.
[Left Arrow] or [Right Arrow]:    Move selection left and right across the menu bar.
[Enter]: Open the selected menu, or choose the selected command from a menu.
[Up Arrow] or [Down Arrow]:    Open the selected menu, or move selection up or down among commands 

on a menu.
[Letter]: When a menu is open, choose the command whose underlined letter matches 

the letter you type.
[Esc]: Close the open menu.

Using the Keyboard For Time Line Commands

The following keystrokes are equivalent to choosing menu commands.

File Menu
New [Ctrl/N]
Open [Ctrl/O]
Save [Ctrl/S]
Print [Ctrl/P]
Print Preview [Ctrl/V]

Edit Menu
Undo [Alt/Bksp]
Cut [Shift/Del]
Copy [Ctrl/Ins]
Paste [Shift/Ins]
Insert [Ins]
Delete [Del]
Assign Resource [Ctrl/A]
Set Dependencies [Ctrl/C]

Outline Menu
Expand [Ctrl/+] 
Collapse [Ctrl/-]
Indent [Ctrl/Right Arrow]
Outdent [Ctrl/Left Arrow]
Move Up [Ctrl/Up Arrow]
Move Down [Ctrl/Down Arrow]

Options Menu
Recalculate Now [F9]

Other Time Line Operations
[F1] Get context-sensitive help on the current area of focus.
[Shift/F1] Help Pointer: Click anywhere onscreen for context-sensitive help.
[F2] Edit cell contents at edit bar.
[Ctrl/F6] Move to next Time Line window.
[Shift/Ctrl/F6] Move to previous Time Line window.
[Shift/Up Arrow] or [Shift/Down Arrow]    Extend a selection in the Gantt window.
[Alt/Shift/Left Arrow]    Scroll Gantt window to the left.



[Alt/Shift/Right Arrow]    Scroll Gantt window to the right.
[Ctrl/<number of window>]    Activate an open window.
[Backspace] Clear edit bar.

Keyboard Equivalents For Standard Windows Operations
[Ctrl/Esc] Move to Windows Task List.
[Alt/Esc] Move to next application window or minimized icon, including full screen programs.
[Alt/Tab] Move to next application window, restoring applications that are reduced to icons.
[Print Screen]    Copy screen to Clipboard.
[Alt/Print Screen] Copy active window to Clipboard.
[Alt/F4] Close application window.
[Ctrl/F4] Close active document window.
[Alt/Spacebar]    Open the Application Control menu.
[Alt/Hyphen]    Open the Window Control menu.

Keyboard Equivalents In Dialog Boxes
[Tab] Move to next option.
[Shift/Tab] Move to previous option.
[Alt/Letter] Select option or group with matching underlined letter.
[Direction Arrows]    Move and select within active group of option buttons.
[Home] Move to first item or character in a list or text box.
[End] Move to last item or character in a list or text box.
[Page Up] or [Page Down]    Scroll up or down in a list box.
[Alt/Down Arrow]    Open a drop-down list.
[Alt/Up Arrow] or [Alt/Down Arrow]    Select an item in a drop-down list.
[Spacebar]    Select or cancel a selection in a list.
[Ctrl/Slash]    Select all items in a list.
[Ctrl/Backslash]    Cancel all multiple selections except the current one.
[Shift/Direction Arrow]    Extend the selection in a text box.
[Shift/Home]    Extend the selection to the first character in a text box.
[Shift/End] Extend the selection to the last character in a text box.
[Letter key]    Select the next item in a list beginning with the letter you type.
[Esc] or [Alt/F4] Close box without entering changes.
[Enter] Close box and accept changes.



Data Columns for Task Information

Time Line provides many different data columns for displaying information about tasks.    Use the Active 
Window command on the Format menu to change the selection, order, or width of data columns in the 
Spreadsheet, and to customize their titles.    Data column names that appear with commas in the 
alphabetical drop-down list provide an alternative selection method; for example, Cost, Spent is a 
synonym for the column Spent Cost.

The most commonly used data columns appear as fields in the Task Info Box for quick access.    All data 
columns can also be displayed as fields within the task boxes of the PERT window. 

You can enter and edit data in many columns using the edit bar; other columns display data that is 
calculated automatically.    Some columns can be edited for detail tasks but not summary tasks.

Click a column name to see its definition:

Achieved Cost (BCWP)
Attachments
Baseline Cost (BAC)
Baseline Duration
Baseline Effort
Baseline Elapsed Cost (BCWS)
Baseline End
Baseline Start
BCWP (Achieved Cost)
BCWS (Baseline Elapsed Cost)
Calendar Duration
Consolidate Info
Cost Performance Ratio
Cost Status
Cost Variance
Cost Variance Percent
Critical
Driven By
Duration
Duration (Days)
Duration (Hours)
Duration (Months)
Duration (Quarters)
Duration (Weeks)
Duration (Years)
Duration Variance
EAC (Total Cost)
Earned Value
Effort
Effort (Days)
Effort (Hours)
Effort (Months)
Effort (Quarters)
Effort (Weeks)
Effort (Years)
Effort Variance
Elapsed Time Percent
End
End Variance
Fixed End



Fixed Start
Keyword
Late End
Late Start
Mathematical EAC Cost
Note
Numeric
Other Cost
Outline Level
Outline Task Name
Percent Complete
Predecessors
Priority
Projected Cost
Projected Duration
Projected Effort
Projected End
Remaining Cost
Remaining Duration
Remaining Effort
Resource Assignments
Resource Cost
Resource Effort
Resources
Responsible
Row #
Schedule Performance Ratio
Schedule Variance
Schedule Variance Percent
Scheduling Delay
Slack
Slack (Hours)
Slack (Days)
Slack (Months)
Slack (Quarters)
Slack (Weeks)
Slack (Years)
Slack Percent
Spending Ratio
Spent Cost
Spent Cost Variance Ratio
Spent Duration
Spent Duration Variance Ratio
Spent Effort
Start
Start Status
Start Variance
Successors
Summary Task
Task Name
Task Type
Text 1 - 2
Timing Status
Total Cost (EAC)
Total Cost Variance
Total Cost Variance Percent



Total Cost Variance Ratio
Unleveled End
Unleveled Start
WBS
Workload

Related Topics:
Formatting the Gantt Window
Data Columns for the Resource Spreadsheet



Data Columns for the Resource Spreadsheet

Time Line provides data columns for displaying information about resources in the Resource Spreadsheet 
that are different from the task data columns in the Gantt window.    Use the Active Window command on 
the Format menu to change the selection, order, or width of data columns, and to customize their titles.    
Data column names that appear with commas in the alphabetical drop-down list provide an alternative 
selection method; for example, Effort,Total is a synonym for the column Total Effort.

You can enter and edit data in many columns using the edit bar; others display data that is calculated 
automatically.

Click a column name to see its definition:

Attachments
Cost Rate
Default Assignment
Max Available
Note
Resource Name
Text 1 - 5
Standard Workweek
Status
Total Cost
Total Effort
Type





Not Available

This data column is not available in Time Line for Windows.



Standard Workweek

The number of work hours in a resource's typical workweek, as specified in the individual resource 
calendar.



Max Available

The maximum number of individuals working full time (or the equivalent working overtime or less than full 
time) that comprises the resource.    This value is used as the upper limit during resource leveling.



Status

"Conflict" indicates that a resource is overcommitted.    "Leveled" indicates that one or more of its 
assignments have been delayed by resource leveling.



Unleveled End

The date a task would end if resources were not leveled.



Unleveled Start

The date a task would start if resources were not leveled.



Spending Ratio

The Baseline Elapsed Cost divided by the Spent Cost.    If the ratio is less than 1, spending is outpacing 
the baseline estimate; if greater than 1, spending is within the budgeted rate.



Spent Cost Variance Ratio

The Spent Cost of a task divided by its Baseline Cost.    As this ratio approaches 100%, the task should 
be approaching completion.



Spent Duration Variance Ratio

The Spent Duration of a task divided by its Baseline Duration.    As this ratio approaches 100%, the task 
should be approaching completion.



Spent Duration

The elapsed duration of a task, calculated as Duration * Percent Complete.



Spent Effort

The amount of resource effort expended on a task to date, calculated as Effort * Percent Complete.



Start Variance

The difference, in days, between a task's baseline start date and the current start date.    If 0, the task is 
started or scheduled to start according to the original estimate.    If negative, the task is late.    If positive, 
the task is early.



Slack (Hours)

The number of hours the task can be delayed before affecting the schedule.    Your choice in the 
Calculations box determines whether this represents free slack or total slack.



Slack (Days)

The number of days the task can be delayed before affecting the schedule.    Your choice in the 
Calculations box determines whether this represents free slack or total slack.



Slack (Weeks)

The number of weeks the task can be delayed before affecting the schedule.    Your choice in the 
Calculations box determines whether this represents free slack or total slack.



Slack (Months)

The number of months the task can be delayed before affecting the schedule.    Your choice in the 
Calculations box determines whether this represents free slack or total slack.



Slack (Quarters)

The number of quarter years the task can be delayed before affecting the schedule.    Your choice in the 
Calculations box determines whether this represents free slack or total slack.



Slack (Years)

The number of years the task can be delayed before affecting the schedule.    Your choice in the 
Calculations box determines whether this represents free slack or total slack.



Slack Percent

A task's available slack time expressed as a percentage of its duration, calculated as Slack divided by 
Duration.    Your choice in the Calculations box determines whether this represents free slack or total 
slack.



Projected End

A task's estimated end date based on current progress, calculated as Start Date + Projected Duration.



Row Number

Indicates the sequential position of the task in the task list.



Schedule Performance Ratio

An analysis of earned value, calculated as Achieved Cost divided by Baseline Elapsed Cost.



Schedule Variance

The difference between a task's Achieved Cost and its Baseline Elapsed Cost.    Schedule Variance is 
negative if achievement is behind schedule.



Schedule Variance Percent

The percentage by which a task has varied from its scheduled achievement, calculated as (Achieved 
Cost - Baseline Elapsed Cost) / Achieved Cost.



Scheduling Delay

The number of days a task has been delayed from its Early Start date, as a result of resource leveling 
and/or dependencies.



Elapsed Time Percent

The proportion of a task's duration that has passed, calculated as (Start Date - As-of Date) / Duration.



End Variance

The difference between the current end date and the baseline end date.



Mathematical EAC Cost

The Mathematical Estimated At Completion Cost is an estimate of the total task cost, calculated as Spent 
Cost + (Baseline Cost - Achieved Cost).



Numeric

A generic column that can be used for any numeric data.    The Percent Complete Weighting in the 
Calculations box can be set to use a weighting factor entered in this column.



Other Cost

Expenses associated with a task that are not charged to a resource or cost category.    The Other Cost 
column does not roll-up to the summary task level; the Total Cost column contains the roll-up of the Other 
Cost and Resource Cost columns combined.



Projected Cost

An estimate of the total cost of the task based on current progress, calculated as (Elapsed Time Percent / 
Percent Complete) * Total Cost.



Projected Duration

An estimate of the total duration of the task based on current progress, calculated as (Elapsed Time 
Percent / Percent Complete) * Duration.



Projected Effort

An estimate of the total effort of the task based on current progress, calculated as (Elapsed Time 
Percent / Percent Complete) * Effort.



Duration Variance

The difference between a task's baseline duration and the currently scheduled duration, calculated as 
(Baseline Duration - Duration) * Percent Complete.



Effort

An estimate of the amount of resource effort needed to complete the task, calculated automatically for 
duration-driven tasks or entered for effort-driven tasks.



Total Effort

The sum of the resource's effort based on all its task assignments.



Effort (Hours)

An estimate of the number of resource hours needed to complete the task, calculated automatically for 
duration-driven tasks or entered for effort-driven tasks.



Effort (Days)

An estimate of the number of resource days needed to complete the task, calculated automatically for 
duration-driven tasks or entered for effort-driven tasks.



Effort (Weeks)

An estimate of the number of resource weeks needed to complete the task, calculated automatically for 
duration-driven tasks or entered for effort-driven tasks.



Effort (Months)

An estimate of the number of resource months needed to complete the task, calculated automatically for 
duration-driven tasks or entered for effort-driven tasks.



Effort (Quarters)

An estimate of the number of resource quarter years needed to complete the task, calculated 
automatically for duration-driven tasks or entered for effort-driven tasks.



Effort (Years)

An estimate of the number of resource years needed to complete the task, calculated automatically for 
duration-driven tasks or entered for effort-driven tasks.



Effort Variance

A comparison of a task's projected and current effort, calculated as (Percent Complete * Baseline Effort) - 
Spent Effort.



Baseline Effort

The amount of Effort entered for the task at the time the baseline was set.



Baseline Elapsed Cost (BCWS)

The Baseline Elapsed Cost, or Budgeted Cost of Work Scheduled, is the amount of baseline dollars 
represented by the task's elapsed time, calculated as (As-of Date - Baseline Start)/Baseline Duration * 
Baseline Cost.



Consolidate Info

Displays the name of a file consolidated to the selected task and, if a single task in the file is 
consolidated, its WBS number.



Cost Performance Ratio

An earned value analysis ratio calculated as Achieved Cost divided by Spent Cost.



Driven By

Indicates whether a task is driven by duration or by effort, as specified in the Task Info Box.



Achieved Cost (BCWP)

Achieved Cost, or Budgeted Cost of Work Completed, is an estimate of the cost of work completed on the 
task, calculated as Percent Complete * Baseline Cost.



Spent Cost 

The Spent Cost is the amount spent on a task to date, calculated as Total Cost * Percent Complete. 



Attachments

Icons representing documents attached through Object Linking and Embedding.



Baseline Cost (BAC)

Baseline Cost, or Budgeted At Completion, is the Total Cost amount for the task when the baseline was 
set.



Task Name

A descriptive name to identify a task.    Task names need not be unique.

Items in the Task Name column can be organized into an outline.



Start

The date scheduled for a task to start, which Time Line calculates automatically based on the calendar, 
dependencies, and other scheduling information.    If you have specified Fixed Start or Fixed Start and 
End for Task Type in the Timing Info Box, you can enter a date to override the calculated date.    The start 
date of a summary task is the earliest start date of its detail tasks.



End

The date scheduled for a task to end, calculated from the duration, dependencies, and other scheduling 
information.    If you have specified Fixed End for Task Type in the Timing Info Box, you can enter a date 
to override the calculated date.    The end date of a summary task is the latest end date of its detail tasks.



Duration

The amount of work time needed to complete a task.    Do not include holidays or other nonwork time 
when estimating for duration-driven tasks.    The durations of summary tasks and effort-driven tasks are 
calculated automatically.    Time Line accepts decimal amounts and the following abbreviations: 

Hour H
Day D
Week W
Month M
Quarter Q
Year Y



Keyword

A code number or text of any type which you can use for filtering and sorting tasks.



Percent Complete

An estimate of the percentage of the task that has already been completed.    The Percent Complete of a 
summary task is calculated from its detail tasks.



Responsible

The resource named as the person responsible for the task.    The Responsible resource for a summary 
task automatically applies to any of its detail tasks that are not yet assigned.    In this case, the name 
appears in square brackets. 



Note

A text field, corresponding to the first line of the Note Info Box, where you can enter descriptive notes 
about the selected task or resource.



WBS

A Work Breakdown Structure code of any type to identify the task.



Text 1 - 5

Text columns for entering information of any type.    Customize the column title to identify its purpose.



Priority

A number from 0.1 to 9.9 that determines the relative priority of the task when Time Line reschedules 
tasks during resource leveling.    Lower numbers are given higher priority.    A task with a blank priority is 
treated as the lowest relative priority.

A detail task, if left blank, is automatically assigned the same priority as its summary task, which appears 
in square brackets.



Fixed Start

The date on which you want the task to start, if you have specified Fixed Start or Fixed Start and End as 
the Task Type in the Timing Info Box.    The date in the Start field may be later than your fixed start date if 
dependencies or resource conflicts delay the task.    These delays can be displayed as delay lines on the 
task bars.



Fixed End

The date on which you want a task to end, if you have specified Fixed End or Fixed Start and End as the 
Task Type in the Timing Info Box.    The scheduled end date may be later than your fixed end date if 
dependencies or resource conflicts delay the task.    These delays can be displayed as delay lines on the 
task bars.



Baseline Start

The start date of the task at the time the baseline was set.



Baseline End

The end date of the task at the time the baseline was set. 



Baseline Duration

The duration of the task at the time the baseline was set.



Start Status

Indicates whether the task is Future, Started, or Done, based on the entry for Percent Complete.



Timing Status

Indicates whether the task is on schedule, based on data in the Percent Complete column.    The following 
values are possible:

Planned      (0 Percent Complete) 
Started    (Percent Complete is > 0 and    < 100)
Finished    (100 Percent Complete)



Cost Status

Indicates whether the task is on budget, under budget, or over budget, based on a comparison of Spent 
Cost against Baseline Cost * Percent Complete. 



Cost Variance

The difference between a task's Achieved Cost and its Spent Cost, calculated as the difference between 
BCWP and Spent Cost. 



Cost Variance Percent

A task's Cost Variance divided by achievement, calculated as (BCWP - Spent Cost)/BCWP.



Remaining Cost

The estimated cost remaining to complete the task, calculated as the difference between Total Cost and 
Spent Cost.



Earned Value

The earned value of the completed work, calculated as Percent Complete * Baseline Cost.



Calendar Duration

The duration of the task as scheduled, including any nonwork time that falls within the period.



Duration (Days)

The task duration expressed in days.



Duration (Hours)

The task duration expressed in hours.



Duration (Weeks)

The task duration expressed in weeks.



Duration (Quarters)

The task duration expressed in quarter years.



Duration (Months)

The task duration expressed in months.



Duration (Years)

The task duration expressed in years.



Remaining Duration

The estimated work-time duration remaining to complete the task, calculated as the difference between 
Duration and Spent Duration.



Remaining Effort

The estimated resource effort remaining to complete the task, calculated as the difference between Effort 
and Spent Effort.



Late Start

The latest date that the task can start within the available slack time.    The choice of free or total slack in 
the Calculations box affects this date.



Late End

The latest date that the task can end within the available slack time.    The choice of free or total slack in 
the Calculations box affects this date.



Slack

If Free Slack is selected in the Calculations box, Slack is the amount of work time the task can slip without 
delaying the start date of another task.

If Total Slack is selected in the Calculations box, Slack is the amount of work time the task can slip 
without delaying any fixed tasks or the end date of the plan.



Predecessors

Lists all preceding tasks on which this task is directly dependent.    A predecessor's WBS numbers, if 
entered, are displayed.



Successors

Lists all directly dependent tasks that follow this tasks.    A successor's WBS number, if entered, is also 
displayed.



Resources

Lists all resources assigned to the task.    An asterisk (*) marks the resource named as responsible, if any. 
The caret (^) marks resources that are overcommitted.    The tilde (~) marks resources whose 
assignments have been leveled.



Resource Effort

Lists all resources assigned to the task, with each one's effort displayed in parentheses. 



Resource Assignments

Lists the name and number assigned for all resources assigned to the task.



Task Type

Indicates whether a task is scheduled to start and/or end on fixed dates you specify, or to start as soon as 
possible (ASAP) or as late as possible (ALAP).



Type

A specification of how a resource is handled for effort-driven scheduling and resource leveling.    Choose 
Cost Only if the availability of the resource does not affect scheduling.    (Histograms and resource 
calendars are not available for this resource type.)    Choose Resource if the Max Available amount and 
unavailabilities on the resource calendar should be taken into account when scheduling effort-driven tasks 
and leveling resources.    Choose Unleveled if availability affects effort-driven tasks, but the resource is 
exempt from leveling.



Summary Task

Indicates whether or not the task has detail (child) tasks.



Outline Task Name

Lists all summary tasks of the task, with each name separated by a backslash.



Critical

Indicates whether the task is on the critical path, with no available slack.



Workload

Indicates "Leveled" if a task has been delayed because of resource leveling, or "Conflict" if a resource 
assigned to the task is overcommitted. 



Outline Level

Indicates the level of the outline to which the task is indented, with 1 representing the highest level.



Resource Name

A descriptive name to identify a resource.    Resource names must be unique.



Cost Rate

The cost of the resource per unit of time or per unit of measure.    Time Line recognizes standard time 
units; other units of measure are defined when you first enter them here.



Total Cost (EAC)

The Total Cost, Estimated At Completion, is the sum of a task's resource costs and any amount entered 
for Other Cost.



Total Cost (Resource Spreadsheet)

The sum of the costs of all the resource's assignments.    The cost of each assignment is based on the 
Cost Rate and task Duration.



Default Assignment

The number of individuals at full time that typically constitutes a specific resource.    For example, an 
assignment of 1 can represent one individual working full time or two individuals each working half time.    
If you change this number after a resource has been assigned to tasks, the new value applies only to 
subsequent assignments.



Total Cost Variance

The difference between Baseline Cost and Total Cost.    If negative, the task is forecast over budget; if 
positive, the task is forecast under budget.



Total Cost Variance Percent

The amount a task's total cost varies from its baseline estimate, expressed as a percentage of the total; 
calculated as (Baseline Cost - Total Cost) / Baseline Cost.



Total Cost Variance Ratio

A comparison of a task's currently scheduled cost to its baseline cost; calculated as Total Cost divided by 
Baseline Cost.



Resource Cost

The total cost of all resources for the task.    The Resource Cost column does not roll-up to the summary 
task level; the Total Cost column contains the roll-up of the Resource Cost and Other Cost columns 
combined.



Condition Name: Critical

This condition tests whether tasks are on the critical path with no available slack.



Condition Name: Almost Critical

This condition tests whether tasks are almost on the critical path, with available slack at no more than 
20% of each task's duration.



Condition Name: Consolidated Tasks

This condition tests whether tasks are consolidated, representing data from external schedules.



Condition Name: Needs Update

This condition tests whether the start date of a task is earlier than the As-of Date, for easy identification of 
tasks that may need their Percent Complete amount updated.



Condition Name: Custom Date Range

This condition tests whether tasks fall within the date range specified in the Value cells of the Define 
Condition box.



Condition Name: Not Completed

This condition tests whether tasks are completed on the basis of the entry for Percent Complete.



Condition Name: Late (vs. Baseline)

This condition tests whether the scheduled end date of a task falls after the baseline end date.



Condition Name: Over Budget (vs. Baseline)

This condition tests whether the current cost of a task is greater than the baseline cost.



Condition Name: Resource Combo

This condition tests whether the resources assigned to a task include any of the resources named in the 
Value cells of the Define Condition box.



Condition Name: Text Combo

This condition tests whether the Task Name or Note columns contain text specified in the Value cells of 
the Define Condition box.



Condition Name: Resource Conflict

This condition tests whether any resource assigned to the task is committed above the capacity specified 
in the Max Available column of the Resource Spreadsheet.



Condition Name: This Week/Month/Quarter/Year

These conditions test whether the start and end dates of a task fall within the current time period.



Condition Name: Near Critical

This condition tests whether a task has 5 days or less of available slack.



Condition Name: Milestones

This condition identifies milestones by testing whether a task has a duration of 0.



Condition Name [Resource Name]

This condition tests whether a task has an assignment for the named resource.    A resource condition is 
created automatically for each resource in the schedule.





Coming from Time Line for DOS

To learn the Time Line for Windows equivalents of the following items in Time Line for DOS, click:

Menu commands
Keyboard shortcuts
Forms
Data columns

For information on using existing Time Line for DOS files in Time Line for Windows, see Converting Time 
Line for DOS Files.

See Appendix A, Coming from Time Line for DOS in the Time Line for Windows User Manual for more 
detailed information on differences between the two programs.



Converting Time Line for DOS Files 

A Time Line for DOS files is automatically converted into the Time Line for Windows format when you 
open the file.    Use the Open command on the File menu. 

When you save the file, the Save File As box opens for you to rename the file.    Using the .TLW extension 
provided ensures that the original Time Line for DOS file remains unchanged.

Check the settings in the Preferences, Schedule, and Calculations boxes on the Options menu after 
opening the file.    Changes may occur if the defaults used in Time Line for Windows vary from the 
settings in Time Line for DOS. 

Differences between the programs may affect the schedule.    See Appendix A, Coming from Time Line for 
DOS in the Time Line for Windows User Manual for more detailed information on differences between 
the two programs.    Not all data columns in Time Line for DOS correspond to those in Time Line for 
Windows.

· Each Note in Time Line for Windows contains a maximum of 511 characters.    Additional 
characters are not imported.

· Entries in the OBS data column in Time Line for DOS appear in the Text 1 column in Time 
Line for Windows.

· Entries in the Aux 1 data column in Time Line for DOS appear in the Text 2 column in 
Time Line for Windows.    Entries in the Aux 2-50 columns are appended to the task 
Notes.

· In the Priority data column in Time Line for Windows, lower numbers are always given 
higher priority.    In conversion, priorities remain the same relative to each other but their 
absolute values may change.

· Each Rate Profile in Time Line 5.0 for DOS is averaged to produce a single entry for the 
Cost Rate data column in the Resource Spreadsheet in Time Line for Windows.    The 
average is weighted by the amount of the total cost spent at each rate.

· Each Availability Profile in Time Line 5.0 for DOS is averaged to produce a single entry 
for the Max Available data column in the Resource Spreadsheet in Time Line for 
Windows.    The average is weighted by the percentage of the total cost spent at each 
availability level.

· Fixed tasks with a Must Start restriction in Time Line 5.0 for DOS are treated as normal 
fixed tasks in Time Line for Windows, and can be delayed by dependencies.

· The Other Cost column in Time Line for Windows contains the sum of entries in the Extra 
Cost column for any assignments of the task in Time Line 5.0 for DOS.

Any problems encountered by Time Line during file conversion are listed in an Error Log box that appears 
when the conversion is complete.



Coming from Time Line for DOS: Menu Commands

Time Line for DOS menu commands are listed below, with the nearest equivalent Time Line for Windows 
command.    Click the Time Line for Windows command name to go to the related topic in Help.

File/Retrieve - File/Open
File/Save - File/Save
File/Combine - File/Combine
File/Previous - not applicable
File/Import/Time Line Ver 3 & 4 - File/Open
File/Import/Time Line Ver 2 - not applicable
File/Import/On Target - File/Open
File/Import/Tables - File/Import
File/Import/Outlines - not applicable
File/Xport - File/Export
File/Erase - use Microsoft Windows File Manager
File/Form - File/Save As

Schedule/Tasks/Add - Edit/Insert
Schedule/Tasks/Edit - Task Info Box
Schedule/Tasks/Copy - Edit/Copy
Schedule/Tasks/Notes - Note Info Box
Schedule/Tasks/Search - not applicable
Schedule/Tasks/Indent - Outline/Indent
Schedule/Tasks/Outdent - Outline/Outdent
Schedule/Tasks/Delete - Edit/Delete
Schedule/Tasks/Form - Task Info Box
Schedule/Dependencies/Join - Edit/Set Dependencies
Schedule/Dependencies/Unjoin - Edit/Remove Dependencies
Schedule/Dependencies/Show - Timing Info Box
Schedule/Dependencies/List - Timing Info Box
Schedule/Dependencies/PERT - Window/PERT
Schedule/Dependencies/Form - Timing Info Box
Schedule/Resources/Histogram - Format Active Window
Schedule/Resources/List - Resource Spreadsheet
Schedule/Master Calendar/Workhours - Options/Calendars
Schedule/Master Calendar/Dates - Options/Calendars
Schedule/Master Calendar/Settings - Duration Conversions
Schedule/Sort - Format/Active Window
Schedule/Filters/Select - Set Filters button
Schedule/Filters/Highlight 1, 2, 3 - Format/Highlights
Schedule/Filters/Clear - Clear Filters button or Format/Highlights
Schedule/Layouts - Format/Active Window
Schedule/Options - Options/Schedule and Options/Preferences
Schedule/Journal - not applicable
Schedule/Baseline - Options/Set Baseline
Schedule/Erase - File/New
Schedule/Calculations - Options/Calculations

Views/Gantt - Window/Gantt and Window/New Window
Views/Histogram - Format/Active Window
Views/PERT - Window/PERT and Window/New Window
Views/Work Tree - not applicable

Reports/ - In Time Line for Windows, reports are based on the contents of the active window.
Choose:



Format/Active Window to include the appropriate information on screen.
File/Page Setup to set titles and page layout.
File/Print Preview to view the layout before printing.
File/Print to print the contents of the window. 
File/Print Calendar to create calendar reports independent of the active window.

Utilities/Macros - use Microsoft Windows Recorder or Norton Desktop for Windows BatchBuilder
Utilities/Exit to DOS - use Microsoft Windows Program Manager or Norton Desktop for Windows
Utilities/Stats - Options/Schedule
Utilities/DOS Date/Time - use Microsoft Windows Control Panel
Utilities/TL4.0 Config - not applicable

Graphics/ - In Time Line for Windows, graphics capabilities are fully integrated and require no separate 
procedures.

Configure/Video - not applicable
Configure/Sound - use Microsoft Windows Control Panel
Configure/Printer - use Microsoft Windows Control Panel
Configure/Date Formats - Options/Preferences
Configure/Disk File - not applicable
Configure/Mouse - use Microsoft Windows Control Panel

Assist/Help - Help/Index, Help/Point, and Help/Menus
Assist/New Schedule - see Quick Start
Assist/Update - Options/Calculations
Assist/WBS Manager - not applicable
Assist/Tutorial - Help/Tutorial
Assist/Undo - Edit/Undo
Assist/Redo - Edit/Undo

Quit - File/Exit



Coming from Time Line for DOS: Keyboard Shortcuts

Time Line for DOS keyboard shortcuts are listed below, with the nearest equivalent command in Time 
Line for Windows.    Note that Time Line for Windows offers many graphical shortcuts not available in 
Time Line for DOS as alternatives to using menu commands or keyboard shortcuts.    For more 
information on Time Line for Windows keyboard shortcuts, see Keyboard Equivalents.

Click the Time Line for Windows command, below, to go to the related topic in Help.

[F1] Help Pointer button (Icon Bar)
[Shift/F1] Help/Index
[Ctrl/F1] Options/Calendars
[Alt/F1] use Microsoft Windows Recorder or Norton Desktop for Windows BatchBuilder

[F2] Task Info Box icon
[Shift/F2] Note Info Box icon
[Ctrl/F2] Task Info Box icon
[Alt/F2] not applicable

[F3] Connect tool icon
[Shift/F3] Timing Info Box icon
[Ctrl/F3] Edit/Remove Dependencies
[Alt/F3] not applicable

[F4] Timing Info Box icon
[Shift/F4] Timing Info Box icon
[Ctrl/F4] Window/PERT

[F5] not applicable
[Shift/F5] not applicable
[Ctrl/F5] not applicable

[F6] Format/Active Window (double-click data column titles or Time Scale background)
[Shift/F6] Options/Schedule and

Options/Preferences
[Ctrl/F6] File/Save As
[Alt/F6] not applicable

[F7] Highlights button (Icon Bar)
[Shift/F7] Set Filter button
[Ctrl/F7] Highlights button (Icon Bar)
[Alt/F7] Highlights button (Icon Bar)

[F8] double-click Time Scale background
[Shift/F8] Window/Resources
[Ctrl/F8] Window/Gantt
[Alt/F8] double-click Time Scale background

[F9] Recalc button
[Shift/F9] not applicable

[F10] [Enter] or click OK
[Shift/F10] Edit/Undo
[Ctrl/F10] Edit/Undo



Coming from Time Line for DOS: Forms

The most important forms used in Time Line for DOS are listed below, with their nearest equivalent in 
Time Line for Windows.    Click to go to the related topic in Help.

Dates Form - Calendars box
Workhours Form - Standard Workweek box
Calendar Settings Form - Duration Conversions box
Options Form - Schedule Options box and Preferences box
Calculations Form - Calculations box
Task Forms - Task Info Box, Assignments Info Box, and Timing Info Box
Dependency Form - Edit Dependency box
Resource/Cost Form - Resource Spreadsheet
Resource and Cost Assignment Forms - Assignments Info Box
Layout Form - Format Active Window
Notepad - Note Info Box and Object Linking and Embedding
Filter Form - Define Condition box



Coming from Time Line for DOS: Data Columns

Data columns used in Time Line for DOS are listed below.    Click a name and hold down the mouse 
button for a description of the equivalent data column in Time Line for Windows.

Achieved Dollars (BCWP)
Auxiliary 1- 50
Baseline Duration
Baseline Effort
Baseline Elapsed Dollars (BCWS)
Baseline End Date
Baseline Proportional Percent Achieved
Baseline Start Date
Baseline To Go Dollars (Predicted)
Baseline Total Dollars (BAC)
Cost (Projected)
Cost Performance Ratio
Cost Variance
Cost Variance Percent
Costs and Resources with Dollars
Costs with Amounts
Current Cost Efficiency
Dependency Markers (P/S)
Duration
Duration (Projected)
Duration Method
Duration Variance
Duration as Percent of Baseline
Duration in Days
Duration in Hours
Duration in Months
Duration in Weeks
EAC Variance
EAC Variance Percent
Effort
Effort in Days
Effort in Hours
Effort in Months
Effort in Weeks
Effort Variance
Elapsed Days to End
Elapsed Days to Start
Elapsed Time Percent
Elapsed Weeks to End
Elapsed Weeks to Start
End Date
End Date (Late Free)
End Date (Late Independent)
End Date (Late Total)
End Date (Projected)
End Date (Spent Effort)
End Date (User Entered)
End Date Variance
Extra Dollars
Filter (Highlights 1-3)
Fixed Date Delay



Force Critical
Indentation Level
Keyword
Late Task?
Link Status
Linked File
Linked Task WBS
Mathematical EAC
Notes
OBS
Parent WBS
Percent Achieved
Predecessor WBS
Priority
Proportional Percent Achieved
Resources
Resources with Amounts
Schedule Performance Ratio
Schedule Variance
Schedule Variance Percent
Scheduling Delay
Sequence Number
Slack Days (Free)
Slack Days (Independent)
Slack Days (Total)
Slack Hours (Free)
Slack Hours (Independent)
Slack Hours (Total)
Slack Percent (Free)
Slack Percent (Independent)
Slack Percent (Total)
Spaces
Spending Rate Ratio
Spent Dollars as Percent of Total
Spent Dollars as Percent of Baseline
Spent Dollars (ACWP)
Spent Duration
Spent Duration as Percent of Baseline
Spent Effort
Spent Effort Percent
Start Date
Start Date (CPM)
Start Date (Fixed)
Start Date (Late Free)
Start Date (Late Independent)
Start Date (Late Total)
Start Date Restriction
Start Date (Spent Effort)
Start Date Variance
Start Status
Status
Successor WBS
Task Name
Task Name (Abbreviated)
Task Parentage (Abbreviated)
Task Type



To Go Dollars
To Go Duration as Percent of Baseline
To Go Duration
To Go Effort
Total Dollars as Percent of Baseline
Total Dollars (EAC)
WBS
WBS Errors


