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Overview of creating a show
Overview

In ScorePlayer, you can open existing ScorePlayer show files, or start new ones; import clip, score, show, or 
media files; arrange the order of the scores, clips, and media files; and then play them one after another to create 
a show. You can also add a background to a show, or show status messages.

The following procedure outlines the basic steps for creating a show. Click a topic to jump to step-by-step 
instructions.

To create a show file:
1. Create a new show file.

Creating a new ScorePlayer show file

2. Import scores, clips, or media files.
Importing a score, clip, or media file

3. Save your show file.
Saving a ScorePlayer show file



3. Optional. Add a background bitmap, color wash, or status messages to your show.
Adding a background bitmap, color wash, or status messages
Viewing a background wash or bitmap

4. Optional. Modify your show file.
Playing a score, clip, or media file
Deleting a score, clip, or media file



ScorePlayer Commands
For Help on buttons and controls, see the map of screen elements.

File menu
New
Open
Import
Save
Save As
Assemble
Send Mail
Exit
Update Client (OLE)
Save Copy (OLE)
Assemble Copy (OLE)
Exit to Client (OLE)

Edit menu
Cut
Copy
Paste
Include in Play List
Delete Selection

Play menu
Play List
Play Selection

Options menu
Check Media
Set Background
View Background

Help menu
Contents
Commands
Step by Step
Glossary
Using Help
About ScorePlayer



ScorePlayer Step by step
Click a procedure to jump to step-by-step instructions.

Adding a background bitmap, a color wash, or status messages
Assembling a show
Asymetrix Technical Support
Checking media
Creating a new ScorePlayer show file
Deleting a score, clip, or media file
Editing an embedded or linked show (OLE)
Embedding or linking a show with OLE
Importing a score, clip, media file, or show file
Opening a show or score file
Playing a score, clip, or media file
Running ScorePlayer from a command line
Saving a ScorePlayer show
Sending mail
Viewing a background wash or bitmap



Map of screen elements
Click the ScorePlayer screen below to display descriptions of screen elements.



What is MediaBlitz?
Overview

MediaBlitz makes it easy for you to create interactive multimedia shows. By incorporating sound, graphics, video, 
and animation, you can enliven training materials, prototypes, presentations, information kiosks, electronic mail 
messages, spreadsheets, and word-processing documents. MediaBlitz includes the following applications:

ClipMaker: Create clips which are references to segments from any CD audio, wave audio, MIDI, animation, 
or digital video source.

ScoreMaker: Synchronize graphic and sound clips and files into a multimedia event called a score.
ScorePlayer: Assemble and play shows (combinations of scores, clips, and media files).
Using MediaBlitz to create a score

1. Use ClipMaker to create a library of media clips.
2. Use ScoreMaker to combine bitmaps, files, and clips into a synchronized multimedia score.
3. Use ScorePlayer to link or embed your score or clips into a document or another application, or to distribute 

your files as a stand-alone application.

The relationship between the three applications is shown below.

MediaBlitz and OLE
You can use ClipMaker, ScoreMaker, and ScorePlayer together to create scores (or a show made up of several 
scores) that can be played from within any application that supports object linking and embedding (OLE).

MediaBlitz and Multimedia ToolBook
You can run MediaBlitz directly from Multimedia ToolBook if Multimedia ToolBook is installed on your computer. 
MediaBlitz adds its own complete menu to Multimedia ToolBook. You can use MediaBlitz to:

link media files, clips, scores, and shows to graphic objects, hotwords, or pages without programming.
integrate ScorePlayer's capabilities into applications with the ScorePlayer application program interface 

(API).
MediaBlitz and C

If you program in the C language, you can integrate ScorePlayer's capabilities, such as playing scores, into 
applications with the ScorePlayer application program interface (API).



About Multimedia
Overview

Multimedia is a combination of sound, graphics, digital video, and animation. Windows 3.1 includes the Media 
Control Interface (MCI), a standard control interface for multimedia devices and media files. MediaBlitz uses MCI 
to control a variety of devices and files so you can easily combine sound and graphics to create inspiring, 
educational, or entertaining shows or applications.

You can use the following types of sound in MediaBlitz: wave audio, Musical Instrument Digital Interface (MIDI), 
and CD audio.

You can also use bitmap images, digital video, and animation in your MediaBlitz files.



Glossary
Click a letter to display glossary entries.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A
About animation
About bitmaps
About CD audio
About digital video
About MIDI
About wave audio
Animation
Animation clip
Application program interface (API)
Author

B - C
Bitmap
CD audio
CD audio clip
Client (OLE)
Clip
Clip file
ClipMaker
Control Panel



D - K
Duration
Embed

L - O
Link
Load
Media file
MIDI
MIDI clip
Object linking and embedding (OLE)

P - R
Play List
Reader

S
Sampling frequency
Score
Score file
Score item
ScoreMaker
ScorePlayer
Server (OLE)
Show
Show file
Source List

T - Z
Timeline
Track
Video
Video clip
Wave audio
Wave audio clip



Control menu
Keyboard: Alt+Spacebar

Located at the left end of the title bar in the ScorePlayer window. Contains commands that control the size and 
position of the ScorePlayer window. Double-clicking the Control Menu box closes the current window.



Maximize button
Located at the right end of the title bar in the ScorePlayer window, when it has not been maximized.

Click the maximize button to enlarge the ScorePlayer window to fill the screen.



Menu bar
Located below the title bar, along the top of the ScorePlayer window. The menu bar contains all available 
ScorePlayer menus and their commands.

To view the contents of a menu, do one of the following:
Within ScorePlayer, click the menu name with the mouse.
Within ScorePlayer, press Alt+n, where n is the underlined letter in the menu name.



Minimize button
Located at the right end of the title bar in the ScorePlayer window.

Click the minimize button to shrink the ScorePlayer window to an icon at the bottom of the screen.



Restore button
Located at the right end of the title bar in the ScorePlayer window, when the application has been maximized.

Restores the ScorePlayer window to the size it was prior to being maximized.



Play
Plays the contents of the Play List, which can include media files, clips, and scores. Clicking this button has the 
same effect as choosing the Play List command from the Play menu.



Repeat Play
Continuously plays the contents of the Play List.



Manual Advance
Controls when the next item in the the Play List plays. With the Manual Advance box checked, ScorePlayer 
pauses after playing each item, then continues playing when you press the spacebar.



Clear All
Removes all items from the Play List, but does not affect items in the Source List.



Clear
Removes the selected items from the Play List, but does not affect items in the Source List.



Include
Adds the selected items in the Source List to the Play List. If you click the Include button more than once, 
ScorePlayer adds additional copies of the selected items to the Play List. The Include button works the same as 
the Include in Play List command.



Delete
Removes the selected items from the Source List and from the show file. If the deleted item has been added to the 
Play List, ScorePlayer removes the item from it as well.



Source List
Lists all scores , clips , and media files that have been opened or imported into the current show file.



Play List
Lists all scores , clips , and media files that are in the current show and which will play when you click the Play 
button.



Status bar
When the selection arrow is on top of a ScorePlayer feature, the status bar displays an explanation of the feature's 
function.



New
File menu

Keyboard: Ctrl+N

Creates a new show file.

When you start ScorePlayer, a new file is automatically opened. If you select the New command when another 
show is open, ScorePlayer closes the active show before opening the new one. If the active show has unsaved 
changes, ScorePlayer prompts you to save the changes.

See also

Commands
Open



Open
File menu

Keyboard: Ctrl+O

Opens an existing show file or score file.

Options

File Name Lists all show files in the current default directory with the ScorePlayer file extension. A file 
selected from this box replaces the contents of the File Name box.

List Files of Type Indicates the default file extension is .SPF.

Directories Displays the default path. To change the directory, select a new path from the Directories 
list box, which lists all directories available on the current drive. To change the drive, make 
a selection from the Drives list box.

Drives Lists the available drives. Selecting a new drive changes the contents of the Directories 
list box.

See also

Step by step
Opening a show or score file

Commands
New



Import
File menu

Imports a media file, clip file, score file, or the contents of another show file.

Options

File Name Lists all show files in the current default directory with the ScorePlayer file extension. A file 
selected from this box replaces the contents of the File Name box.

List Files of Type Indicates the default file extension is .SPF.

Directories Displays the default path. To change the directory, select a new path from the Directories 
list box, which lists all directories available on the current drive. To change the drive, make 
a selection from the Drives list box.

Drives Lists the available drives. Selecting a new drive changes the contents of the Directories 
list box.

See also

Step by step
Importing a score, clip, media file, or show file



Save
File menu

Keyboard: Ctrl+S

Saves the contents of the Source List and Play List as a ScorePlayer show file.

Options

File Name Specifies the name of the file under which the show will be saved. By default, ScorePlayer 
adds the file extension .SPF.

List Files of Type Indicates the default file extension is .SPF.

Directories Displays the default path. To change the directory, select a new path from the Directories 
list box, which lists all directories available on the current drive. To change the drive, make 
a selection from the Drives list box.

Drives Lists the available drives. Selecting a new drive changes the contents of the Directories 
list box.

See also

Step by step
Saving a ScorePlayer show file

Commands
Save As



Save As
File menu

Saves the contents of the Source List and Play List as a ScorePlayer show file under a specified file name. An 
existing show can be saved under its current file name or under a different one.

Options

File Name Specifies the name of the file under which the show will be saved. By default, ScorePlayer 
adds the file extension .SPF. If the show has already been saved and named, the name of 
the existing file appears in the File Name box. You can change the file name by entering a 
new name in the box.

List Files of Type Indicates the default file extension is .SPF.

Directories Displays the default path. To change the directory, select a new path from the Directories 
list box, which lists all directories available on the current drive. To change the drive, make 
a selection from the Drives list box.

Drives Lists the available drives. Selecting a new drive changes the contents of the Directories 
list box.

See also

Step by step
Saving a ScorePlayer show file

Commands
Save



Send Mail
File menu

Sends a ScorePlayer show via Microsoft Mail.

Options

ScorePlayer file Sends only the ScorePlayer file. If the person receiving your mail does not have access to 
the necessary media files and ScorePlayer, they will not be able to play the score.

Media files Sends the media files associated with the open ScorePlayer file.

Runtime program Sends Runtime ScorePlayer.

See also

Step by step
Assembling a show
Sending Mail



Assemble
File menu

Copies the files you need to play a show to a single directory that you specify, and removes items from the Source 
List that you don't need to play the show.

Options

File Name Specifies the name of the file under which the show will be saved. By default, ScorePlayer 
adds the file extension .SPF.

List Files of Type Indicates the default file extension is .SPF.

Directories Displays the default path. To change the directory, select a new path from the Directories 
list box, which lists all directories available on the current drive. To change the drive, make 
a selection from the Drives list box.

Drives Lists the available drives. Selecting a new drive changes the contents of the Directories 
list box.

See also

Step by step
Assembling a show



Exit
File menu

Keyboard: Alt+F4

Closes ScorePlayer.

See also

Step by step
Saving a ScorePlayer show file



Update Client (OLE)
File menu

Saves changes to an object linking and embedding (OLE) client document. Only appears when ScorePlayer is 
started as an OLE server.

See also

Step by step
Editing an embedded or linked show (OLE)
Embedding or linking a show with OLE



Save Copy (OLE)
File menu

Saves the contents of the Source List and Play List as a ScorePlayer show file, but does not update the object 
linking and embedding (OLE) client document. Only appears when ScorePlayer is started as an OLE server.

See also

Step by step
Editing an embedded or linked show (OLE)
Embedding or linking a show with OLE



Assemble Copy (OLE)
File menu

Copies only the files you need to play a show to a single directory that you specify, and removes items from the 
Source List that you don't need to play the show. Appears only when ScorePlayer is started as an object linking 
and embedding (OLE) server.

This command does not update the OLE client document.

See also

Step by step
Editing an embedded or linked show (OLE)
Embedding or linking a show with OLE



Exit to Client (OLE)
File menu

Exits ScorePlayer, giving you the option of updating the object linking and embedding (OLE) client document or 
discarding changes. Appears only when ScorePlayer is started as an OLE server.

See also

Step by step
Editing an embedded or linked show (OLE)
Embedding or linking a show with OLE



Cut
Edit menu

Keyboard: Ctrl+X

Removes the entire contents of both the Source List and the Play List and places them onto the Windows 
Clipboard.

See also

Step by step
Embedding or linking a show with OLE

Commands
Copy
Paste



Copy
Edit menu

Keyboard: Ctrl+C

Places a copy of the entire contents of both the Source List and the Play List onto the Windows Clipboard.

See also

Step by step
Embedding or linking a show with OLE

Commands
Cut
Paste



Paste
Edit menu

Keyboard: Ctrl+V

Places a copy of the contents of the Windows Clipboard into ScorePlayer, but only if the Clipboard contains a 
ScorePlayer show that was previously cut or copied.

See also

Commands
Copy
Cut



Include in Play List
Edit menu

Adds the selected items in the Source List to the Play List.

If you choose this command more than once, ScorePlayer adds additional copies of the selected items to the Play 
List.

See also

Step by step
Playing a score



Delete Selection
Edit menu

Removes the selected items in either the Source List or the Play List.

See also

Step by step
Deleting a score, clip, or media file



Play List
Play menu

Plays the contents of the Play List.

See also

Step by step
Playing a score, clip, or media file



Play Selection
Play menu

Plays only the selected items in either the Source List or the Play List.

See also

Step by step
Playing a score, clip, or media file



Check Media
Options menu

Verifies that all media files necessary to play items listed in the Source List or the Play List are available to 
ScorePlayer.

If items are not available, you can locate and re-link to the media files with this command. ScorePlayer also 
automatically checks media when you open, import, assemble, or send a show via electronic mail.

See also

Step by step
Checking media



Set Background
Options menu

Specifies options for adding a background color wash, a background bitmap, and status messages to a 
ScorePlayer show.

Options

Background bitmap Specifies whether to show the bitmap during or between scores. Also specifies the bitmap 
file to display.

Background color Selects the color to display and specifies whether to display it.

Status text Specifies whether to display messages and errors, and selects the color to display.

Defaults Restores the background options to their original settings.

See also

Step by step
Adding a background bitmap, color wash, or status messages
Viewing a background wash or bitmap



View Background
Options menu

Displays the current settings for the options in the Background Options dialog box. Cancel this command by 
pressing Esc or the spacebar.

See also

Step by step
Adding a background bitmap, color wash, or status messages
Viewing a background wash or bitmap



Contents
Help menu

Provides a list of ScorePlayer Help topic areas.

See also

Commands
About ScorePlayer
Commands
Glossary
Step by Step
Using Help



Commands
Help menu

Provides a list of the ScorePlayer commands defined in Help.

See also

Commands
About ScorePlayer
Contents
Glossary
Step by Step
Using Help



Step by Step
Help menu

Provides a list of the ScorePlayer procedures described in Help.

See also

Commands
About ScorePlayer
Commands
Contents
Glossary
Using Help



Glossary
Help menu

Provides a list of terms used in MediaBlitz and their definitions.

See also

Commands
About ScorePlayer
Commands
Contents
Step by Step
Using Help



Using Help
Help menu

Provides standard information about using online Help in Microsoft Windows.

See also

Commands
About ScorePlayer
Commands
Contents
Glossary
Step by Step



About ScorePlayer
Help menu

Displays copyright and version information about ScorePlayer.

See also

Commands
Commands
Contents
Glossary
Step by Step
Using Help



Opening a show or score file
Step by step

You can open one or more show or score files in ScorePlayer.

To open a show or score file in ScorePlayer:
1. Choose Open from the File menu.
2. Select the type of file you want to open from the List Files of Type list box.
3. Locate and select the file you want to open (show files and score files have an .SPF and .SCF file extension, 

respectively), then click OK.
The media files, clips, and scores contained in the show file or score file appear in the Source List.

See also

Commands
Open



Playing a score, clip, or media file
Step by step

You can play either a single score, clip, or media file, or create and arrange a play list of two or more scores, clips, 
and media files.

To play a single score, clip, or media file in ScorePlayer:
Select a score, clip, or media file from the Source List or Play List, then choose Play Selection from the Play 

menu.
Double-click the name of the score, clip, or media file in the Play List.
To play more than one score, clip, or media file in ScorePlayer:

1. Select each score, clip, or media file from the Source List and click Include. Alternatively, double-click the name 
in the Source List, or choose Add to Play List from the Edit menu.
The scores, clips, or media files appear in the Play List in the order they are added.

2. Click Play.

To control how scores play:
Check Repeat Play if you want ScorePlayer to return to the beginning of the play list and keep playing.
Check Manual Advance if you want to control when the next score, clip, or media file in the play list plays. 

With Manual Advance checked, the first score, clip, or media file plays immediately when you play a show. You then 
start each subsequent score, clip, or media file by pressing the spacebar.

To stop playback of a score, clip or media file:
Press Esc.



Deleting a score, clip, or media file
Step by step

You can remove one or more items from the Source List or Play List.

To remove a score, clip, or media file from the Source List:
Select one or more items from the Source List and click Delete, press Delete, or choose Delete Selection 

from the Edit menu.
If you delete an item from the Source List, it is deleted from the Play List as well.

To remove a score, clip, or media file from the Play List:
Select one or more items from the Play List and click Clear, press Delete, or choose Delete Selection from 

the Edit menu.
ScorePlayer removes the item from the Play List (but it remains in the Source List).

To remove all scores, clips, and media files from the Play List:
Click Clear List.

The Source List is unaffected.

If you inadvertently delete one or more items, re-open the ScorePlayer show file without saving changes.

See also

Commands
Delete Selection



Creating a new ScorePlayer show file
Step by step

You can create a new file at any time while working in ScorePlayer. (When you start ScorePlayer, it automatically 
creates a new show file.)

To create a new ScorePlayer show file:
Choose New from the File menu.

If you select the New command when another show is open, ScorePlayer closes the active show before opening 
another one. If the active show has unsaved changes, ScorePlayer asks whether the changes should be saved.

If you are working in ScorePlayer as an OLE server, ScorePlayer warns you that creating a new ScorePlayer file 
will break the OLE connection with the currently open file (even if the open file is empty).

See also

Step by step
Opening a show or score file



Saving a ScorePlayer show
Step by step

You can save the arrangement of scores, clips, and media files as a ScorePlayer show that you can play later.

To save a ScorePlayer show:
Choose Save from the File menu to save the file, or Save As to save the file under a new name.

If the Save As dialog box appears, specify a name and location for the file and click OK.

For details about saving your show and moving it to another system, see the Assemble command

See also

Commands
Assemble
Save
Save As



Importing a score, clip, media file, or show file
Step by step

You can import clips created in ClipMaker; scores created in ScoreMaker; any media file supported by MediaBlitz; 
or another ScorePlayer show file containing clips, scores, and media files. ScorePlayer imports only information 
about the location of the file on your hard disk; the file itself is not moved, copied, or altered.

When you import a score, clip, or show file, ScorePlayer automatically checks media files used in the show. You 
can re-link to files that it doesn't find.

To import a score, clip, media file, or show file:
1. Choose Import from the File menu.
2. In the File Import dialog box, select the score, clip, show, or media file you want to import (score files have 

an .SCF file extension, clip files have a .CPF file extension, and show files have an .SPF extension), then click 
OK.
The scores, clips, and media file names appear in the Source List. If the name of an imported score, clip, or file 
duplicates one already in the list, ScorePlayer appends a number to the name of the new score, clip, or file. If 
you import a ScorePlayer (.SPF) file, the scores, clips, and media files that are in the play list of the imported 
show are added to the end of the list of files in the Play List.

Note: In order to import a score, clip, or media file, the file name extension must correspond to the driver installed 
on your system. File name extensions for each installed driver are shown in the File Import dialog box.

See also

Command
Import



Adding a background bitmap, a color wash, or status messages
Step by step

You can specify a bitmap or a full-screen color wash to appear in the background during a show, and add 
messages that indicate the show status or prompt the user.

To set background options:
1. Choose Set Background from the Options menu.
2. In the Background Options dialog box click Set File in the Background Bitmap area.
3. In the Choose Background Bitmap dialog box select a file and click OK.
4. Select one or both of the Background Bitmap options:

Show During Scores Displays the bitmap only when a score is playing.
Show Between Scores Displays the bitmap only between scores.
Bitmaps are aligned with the upper-left corner of your screen.

5. Click OK.

To select a background color wash:
1. Choose Set Background from the Options menu.
2. In the Background Options dialog box, click Set Color in the Background Color area.
3. Select a color from the Color picker, then click OK.
4. Check Wash Full Screen to turn on the color wash you selected.
5. Click OK.

To add messages that indicate status:
1. Choose Set Background from the Options menu.
2. In the Background Options dialog box, click Set Color in the Status Text area.
3. Select a color from the Color picker, then click OK.
4. Select an option from the Status Text area:

Show Messages Displays prompts and status messages that can help guide a user through a show. It is most 
useful when the Manual Advance option is checked.
Show Errors Displays error messages for problems that occur while the show is running, such as when media 
files cannot be located. This option is most useful when you are testing a show as you work.

5. Click OK.

At any time, you can quickly restore background options to their original settings by clicking the Defaults button.

See also

Step by step
Converting Photo CD files to Windows bitmaps
Playing a score, clip, or media file
Viewing a background wash or bitmap



Viewing a background wash or bitmap
Step by step

You can check the background settings without actually playing a score.

To view the background bitmap, color wash, or text:
Choose View Background from the Options menu.

Press the spacebar to make ScorePlayer appear again.

See also

Step by step
Adding a background bitmap, a color wash, or status messages



Embedding or linking a show with OLE
Step by step

ScorePlayer is an object linking and embedding (OLE) server application, which means that you can link or embed 
shows into other OLE-capable applications, and then play or edit the show from within the other application.

To link or embed a ScorePlayer file:
1. Choose Copy from the Edit menu.

The contents of the ScorePlayer file are placed on the Clipboard.
2. In the OLE-client document, position the insertion point where you want to link or embed the ScorePlayer file.
3. Follow the procedure in the other application for linking or embedding a file.

See also

Step by step
Editing an embedded or linked show (OLE)



Editing an embedded or linked show (OLE)
Step by step

You can edit a linked or embedded show from within some client applications.

To edit a linked or embedded show:
1. Follow the application's procedures to open and edit a linked or embedded object.
2. In ScorePlayer, edit the ScorePlayer show.
3. Choose Update from the File menu to automatically update an embedded object, or Save to update a linked 

object.

When you're working with an embedded object, several different commands appear on the File menu: Update 
Client, Save Copy, Assemble Copy, and Exit To Client.

See also

Step by step
Embedding or linking a show with OLE



Checking media
Step by step

The Check Media command on the Options menu determines if all media files necessary to play the items in the 
ScorePlayer file are available.

To check media:
1. Choose Check Media from the Options menu.

If ScorePlayer cannot locate a media file, the Locate dialog box appears. The name of the file for which 
ScorePlayer is searching appears in the title bar.

2. If the Locate dialog box appears, do one of the following:
Locate and select the requested file and then click OK. If you locate a file, ScorePlayer adds the location to 

its search list for subsequent files.
Click Skip to bypass the file. If you skip a file, ScorePlayer continues to search for the other media files in 

the show, and continues prompting you to locate these files, if necessary.
Click Cancel to stop checking media. If you cancel the Check Media command, ScorePlayer remembers the 

locations of the media files you've already located.
ScorePlayer automatically checks media whenever you open a ScorePlayer show file; import a show, score, or 
clip; assemble a show using the Assemble command from the File menu; or send a show using the Send Mail 
command from the File menu.

See also

Step by step
Assembling a show
Sending shows via electronic mail
Distributing a show

Commands
Check Media



Assembling a show
Step by step

When you assemble a show, ScorePlayer saves the Play List as a ScorePlayer show file, and copies it and the 
media files used in the show to a directory that you specify. (It also removes the items in the Source List that are 
not used in the Play List.)

To assemble a ScorePlayer show:
1. If you want to save the current version of your ScorePlayer file, choose Save from the File menu.
2. Choose Assemble, from the File menu.
3. Type a name for the ScorePlayer show file.
4. Select a directory for the files.

Select an empty directory for assembling a show so you can easily copy the entire directory to a disk, cartridge, 
network, or other storage device. If you select a directory that contains other files, ScorePlayer will not overwrite 
media files of the same name that are already in the directory.

5. Click OK.

When you assemble a show, ScorePlayer automatically checks the media files used in the show. You can re-link to 
files that it doesn't find.

After you assemble a show, the new file is opened in ScorePlayer.

If you intend to move your show to a different computer, you'll need to copy SCOREPLR.EXE, SCORPLAY.DLL, 
and SCOREPLR.HLP to the new system, in addition to using the Assemble command to copy the show.

See also

Step by step
Checking media
Sending shows via electronic mail
Distributing a show



Sending shows via electronic mail
Step by step

If you have Microsoft Mail, you can distribute ScorePlayer shows via electronic mail.

To send a ScorePlayer show via electronic mail:
1. Choose Send Mail from the File menu.
2. In the Send Mail dialog box, select the files you want to attach.

The options you select depend on what portions of your show are already available to the recipient. If the media 
files are stored on a server to which both you and your recipient have access, you need to attach only your 
ScorePlayer file and the ScorePlayer runtime program files. Or if your recipient already has ScorePlayer and 
the media files, you need attach only your ScorePlayer file.

3. Click OK.
ScorePlayer opens the Microsoft Mail Send Note dialog box. An icon represents each file, and you can add a 
message.

4. Click Send.

Because sending large files can be time-consuming and may affect network performance, copying or assembling 
the media files for a show onto a network drive and then sending only the ScorePlayer file (and runtime files, if 
necessary) is preferable to sending large media files via electronic mail. You can also minimize the number of files 
you need to send by first assembling the show.

See also

Step by step
Assembling a show
Checking media

Commands
Send Mail



Running ScorePlayer from a command line
Step by step

You can run a ScorePlayer show from any application that provides access to a Windows command line.

ScorePlayer recognizes five command line switches, where filename is a ScorePlayer show (.SPF) or ScoreMaker 
score (.SCF) file, along with the file location:

SCOREPLR.EXE Starts ScorePlayer with no files open.
SCOREPLR.EXE filename Starts ScorePlayer and opens the 

specified show or score file.
SCOREPLR.EXE filename /p Starts ScorePlayer, opens and plays 

the specified show or score file.
SCOREPLR.EXE filename /p /q Starts ScorePlayer, opens and plays 

the specified show or score file, then 
closes ScorePlayer.

SCOREPLR.EXE filename /d Resets ScorePlayer's OLE registration. 
You may need to use this command if you 
change the location of ScorePlayer on your 
hard drive (for example, move it to a 
different directory)

For example, the command 
SCOREPLR.EXE C:\myshows\demo.spf /p /q 
starts ScorePlayer, opens and plays demo.spf, and then closes ScorePlayer.

Note: If you use Microsoft PowerPoint 3.0, you may need to use a special ScorePlayer command that 
compensates for the way PowerPoint registers itself as an OLE application. To determine if and when you need to 
use this command, see the topic Using MediaBlitz with Microsoft PowerPoint 3.0 found in the README.TXT file in 
the MediaBlitz directory.

See also

Step by step
Playing a score, clip, or media file



Distributing a show
Step by step

You can distribute ScorePlayer and ScorePlayer files to others who do not have MediaBlitz. For details on 
distributing a show via Microsoft Mail, see Sending shows via electronic mail.

Distributing a ScorePlayer show:
1. Open the show you want to distribute.

You can check the media in your show to make sure all your media files are available. See checking media.
3. Assemble your show.

Assembling a show
4. In addition to your show (.SPF) file and media files, you need to include:

SCOREPLR.EXE
SCORPLAY.DLL
SCOREPLR.HLP
your .SPF file(s)
all media files used in your shows

See also

Step by step
Assembling a show
Checking media
Sending shows via electronic mail



ClipMaker
ClipMaker is the MediaBlitz application that you use to create a library of clips of media files and CD audio.



ScoreMaker
ScoreMaker is the MediaBlitz application that you use to synchronize multimedia events, which you can play back 
in ScorePlayer or incorporate into Multimedia ToolBook applications.



ScorePlayer
ScorePlayer is the MediaBlitz playback application that opens and plays shows, scores, clips, and media files.



Score
A score is a combination of synchronized sound and graphic clips and files. You create a score by arranging clips 
and files along the ScoreMaker timeline.



Clip
A clip is a stored reference to any wave audio, MIDI, video, or animation file, or to CD audio. You create clips using 
ClipMaker.



Load
To load is to open a clip or score in ClipMaker or ScoreMaker so you can review or modify it.



Wave audio clip
A wave audio clip is a stored reference to a segment of a wave audio file. You can create a clip of a wave audio file 
using ClipMaker.



MIDI clip
A MIDI clip is a stored reference to a segment of a MIDI (Musical Instrument Digital Interface) file. You can create a 
clip of a MIDI file using ClipMaker.



Animation clip
An animation clip is a stored reference to a segment of an animation file. You can create a clip of an animation file 
using ClipMaker.



Video clip
A video clip is a stored reference to a segment of a digital video file. You can create a clip of a video file using 
ClipMaker.



CD audio clip
A CD (compact disc) audio clip is a stored reference to a segment of CD audio. Using ClipMaker, you can create a 
clip of a CD audio.



Track
A track is a band on an audio compact disc (CD), usually representing one song.



Media file
A media file can be any wave audio, MIDI, animation, video, or bitmap file.



Score item
A score item is a sound or graphic clip or file that you arrange along ScoreMaker's timeline.



Duration
Duration is the length of time you specify for a bitmap to appear on the screen.



Video/animation
Digital video is video that is stored or played on a computer, in which all the image and sound information is stored 
digitally.

Animation is the simulation of movement produced by displaying a series of successive images on the screen.



Bitmap
Bitmap images are created as patterns of individual dots (pixels).



Wave audio
Wave audio is a digitized sample of an entire waveform of audio. Wave audio files are recorded sounds that are 
converted into a digital format and stored on a hard disk, CD-ROM, or floppy disk.



MIDI
Musical Instrument Digital Interface (MIDI) is a standard format for sound created digitally with keyboard, and other 
musical instruments.



CD audio
CD (compact disc) audio, or Redbook audio, is stored digitally and converted to analog within the CD-ROM drive 
and then played back via the audio cable.



Score file
A score file contains scores created in ScoreMaker. You must create or open a score file before you can save a 
score.



Clip file
A clip file contains references to media files or CD audio created in ClipMaker. A single clip file can contain clips 
from more than one medium. For example, you can store clips of wave audio, animation, and MIDI files all in one 
clip file. You must create or open a clip file before you can save a clip.



Author
The Author command appears on the edit menu only if you have ToolBook installed on your computer. Author is 
the level in ToolBook where you develop Windows applications. It provides tools and commands for creating and 
modifying objects, pages, backgrounds, and books. At Author level the Text, Page, Object, Draw, and Window 
menus are added to ClipMaker and ScoreMaker, and the File and Edit menus gain additional commands. Also, the 
Reader command replaces the Author command.



Timeline
The timeline is the area in the ScoreMaker application window where you arrange files and clips to create a score.



Show file
A show file contains a list of references to scores, clips, and media files. You create and play a show file using the 
ScorePlayer application.



Play List
The ScorePlayer Play List contains the scores, clips, and media files that are in the current show and which will 
play when you click the Play button.



Source List
The ScorePlayer Source List contains the scores, clips, and media files that have been opened or imported into 
the current show file.



Show
A show is the list of references to scores, clips, and media files in the ScorePlayer Play List. When you play a 
show, ScorePlayer plays each of the items in Play List.



Object linking and embedding (OLE)
Object linking and embedding (OLE) is a Windows protocol that makes it possible for you to play ScorePlayer 
shows from within other applications that support OLE, and update play lists from within clients that support OLE 
editing.



Server (OLE)
An OLE server is an application, such as ScorePlayer, that can export an OLE object (for example, a ScorePlayer 
show) to another application, maintaining an active link with the other application.



Client (OLE)
An OLE client is an application that can accept an OLE object from a server application (such as ScorePlayer), 
maintaining an active link with the server application.



Embed (OLE)
Embedding imports an OLE object, such as a ScorePlayer show, into an OLE-client application. An embedded 
show file is stored in the document file of the client application. Changes to an embedded object are not updated 
in the original file.

Note: Only the show (.SPF) file information is embedded; media files are not copied and must remain on your hard 
disk where ScorePlayer can find them.



Link (OLE)
Linking creates a reference within an OLE client document to an external object, such a ScorePlayer show. The 
OLE client document only stores the location, name and file type of the object. When you play or edit the linked 
object, changes are made to the original file.



Reader
Reader is the level in ToolBook that MediaBlitz runs at. It allows you to use ToolBook applications such as 
ClipMaker, ScoreMaker, and ScorePlayer, but not modify them.



Video
Digital video is video that is stored or played on a computer, in which all the image and sound information is stored 
digitally.



Application program interface (API)
An application program interface (API) is a set of routines that an application uses to request and carry out lower-
level services performed by a computer's operating system. For example, the ScorePlayer API can be used by 
ToolBook and C programmers to start or stop a ScorePlayer file from within another application.



Sampling frequency
The number of sound samples that the sound board takes per second, measured in kilohertz (kHz). The three 
standard sampling frequencies for wave audio are: 11.025kHz, 22.05kHz, and 44.1kHz. The higher the frequency, 
the better the sound quality, but more disk storage space is also required.



About wave audio
Wave audio is a digitized sample of an entire waveform of audio. Wave audio files are recorded sounds that are 
converted into a digital format and stored on a hard disk, CD-ROM, or floppy disk.

Wave audio files are recorded and played through a sound card. The sound quality of the file depends on the 
sampling frequency    the number of of sound samples the sound board takes per second, measured in kilohertz 
(kHz). The three standard sampling frequencies for wave audio are: 11.025kHz, 22.05kHz, and 44.1kHz. The 
higher the frequency, the better the sound quality, but more disk storage space is also required.



About MIDI
Musical Instrument Digital Interface (MIDI) devices are the standard way to connect synthesizers, keyboards, and 
other musical instruments to computers to create synthesized sound. MIDI is not actual sound, but commands 
sent to the synthesizer. You must have a Media Control Interface (MCI)    compatible sound card installed to play 
MIDI files.

MIDI has many advantages: it requires only 1 percent of the storage size of wave audio for memory, creating 
smaller file sizes than other types of sound; and MIDI music is easy to edit.



About CD Audio
CD audio, or Redbook audio, is sound that is stored digitally (as a series of binary values) and converted to analog 
(continuous sound) within the CD-ROM drive and then played back via the audio cable. Since the CD-ROM, and 
not the CPU, converts the data from digital to analog, it does not limit the other actions the CPU can 
simultaneously perform.

In order to use CD audio, you must have a CD-ROM drive and a CD audio driver installed through the Windows 
Control Panel.



About bitmaps
Bitmap images are composed of a set of dots that together create a picture. Bitmaps are typically used to 
reproduce images that contain detail, shading, and color, such as photographs and film images. You can create 
bitmaps by using paint software, by scanning photographs or flat art with a scanner, or by digitizing video frames 
using a video camera and video frame-grabbing equipment.

Tip: For the best results, you should display 256-color bitmaps on machines equipped with a 256-color or better 
video card. If you display a 256-color bitmap on a standard VGA (16-color) system, the bitmap may appear gray or 
grainy.



About animation
There are two basic kinds of computer animation: frame animation and cast-based animation. Frame animation is 
created by designing a separate frame for each screen view, much like a separate individual frame of a filmstrip or 
videotape. Cast-based animation is created by individually designing all of the moving objects to be used through 
a series of frames; assigning each object its own character traits (such as position, pattern, size, and ink); then 
assembling a complete picture frame containing the individual objects. Both types of animation are played by 
going through the frames in quick succession.



About digital video
Digital video is video that is stored or played on a computer, in which all the image and sound information is stored 
digitally.

You can digitize video that you shoot with a video camera, or use a clip from another source such as a CD-ROM. 
MediaBlitz supports all classes of digital video, and includes a driver for Microsofts Video for Windows format, 
called AVI (Audio/Video Interleaved). Video for Windows integrates video and audio using a software-only 
playback engine and drivers. This means you can play a score containing AVI video on any 80386-class computer 
without special video hardware.



Control panel
The control panel is the area at the bottom of ClipMaker that you use to select and play a media file. ClipMaker 
has a separate control panel for each medium (CD audio, wave audio, MIDI, video/animation).



Asymetrix technical support
Step by step

You can receive technical support from Asymetrix in a variety of ways. Click a procedure to jump to step-by-step 
instructions about technical support.

Calling technical support
Using the Asymetrix Bulletin Board System (BBS)
Using CompuServe
Using America Online
Using America Online for the hearing-impaired
Using Byte Information Exchange (BIX)
Using Internet



Calling technical support
Step by step

You can reach Asymetrix Technical Support from 6 a.m. to 6 p.m. Pacific time Monday through Friday. Call 
technical support at (206) 637-1600. Or use our FAX number, (206) 454-0672.

When you call technical support, please be at your computer, and have the following information:

Your MediaBlitz 2.0 serial number, found on the first installation disk, your license agreement envelope, or 
your MediaBlitz 2.0 product box.

Your system configuration information. You can find additional information in Windows Setup, located in the 
Program Manager in the Main group.

The exact wording of any error message you have encountered.
What happened and what you were doing when the problem occurred.
How you tried to solve the problem.

See also
Using the Asymetrix Bulletin Board System (BBS)
Using CompuServe
Using America Online
Using America Online for the hearing-impaired
Using Byte Information Exchange (BIX)
Using Internet



Using the Asymetrix Bulletin Board System (BBS)
Step by step

You can receive online technical support on the Asymetrix Bulletin Board System (BBS) by leaving a message for 
the Asymetrix System Operator. The System Operator checks the BBS daily for new messages and answers them 
within 48 hours or less. To help the System Operator answer your question, you will need to know some 
information about your system configuration.

The data configuration is: No parity, 8 data bits, 1 stop bit.

To gather system configuration information for the System Operator:
1. In the Program Manager, open the Main group, then open Windows Setup.
2. Copy down all the information listed in the Windows Setup dialog box.

To connect to the Asymetrix Bulletin Board System:
1. Call the Asymetrix Bulletin Board System (BBS) number:

If you have a 1200-2400 baud modem, call (206) 451-1173.
If you have a 9600 or 14400 baud modem, call (206) 451-8290.

2. Enter your first name and last name at the prompts.
If you are a new BBS user and you see a welcome message, there is probably another user with the same 
name. Hang up the phone, redial, and use a different name, such as "Jim" instead of "James" or include your 
middle initial.

3. Enter your password, then retype your password to confirm its spelling.
4. If you are a new user, complete the new user questionnaire.

Make sure you have your MediaBlitz 2.0 serial number, found on the first installation disk, your license 
agreement envelope, or your MediaBlitz 2.0 product box. You will be asked about your software and hardware. 
Where applicable, it is recommended that you accept the defaults.

5. To leave a message for the System Operator, type C for "Comments to the sysop," then leave a message 
containing the following information:

The information you gathered about your system configuration.
The version of DOS you are running.
The version of Windows you are running.
The exact wording of any error message you have encountered.
What happened and what you were doing when the problem occurred.
How you tried to solve the problem.

6. To log off the BBS, type G for "Goodbye," then type Y to confirm.

Tip: At any time, you can type "?" to get online command Help. If you have any problems or difficulties with the 
Asymetrix BBS, leave a message for the BBS System Operator or call the Asymetrix technical support line at (206) 
637-1600.

See also
Calling technical support
Using CompuServe
Using America Online
Using America Online for the hearing-impaired
Using Byte Information Exchange (BIX)
Using Internet



Using CompuServe
Step by step

If you are a CompuServe member, you can receive online technical support by leaving a message for the 
Asymetrix Forum Moderator. The Forum Moderator checks CompuServe daily for new messages and answers 
them within 48 hours or less. To help the Forum Moderator answer your question, you will need to know some 
information about your system configuration.

To gather system configuration information for the Forum Moderator:
1. In the Program Manager, open the Main group, then open Windows Setup.
2. Copy down all the information listed in the Windows Setup dialog box.

Refer to your CompuServe documentation for step-by-step instructions for logging onto CompuServe, leaving 
messages for the Forum Moderator, and logging off CompuServe.

To connect to CompuServe:
1. Log on to CompuServe.
2. Type Go WINAPA at the prompt.

3. In the Asymetrix section (section #1), leave a message for the Forum Moderator containing the following 
information:

The information you gathered about your system configuration.
Your MediaBlitz 2.0 serial number, found on the first installation disk, your license agreement envelope, or 

your MediaBlitz 2.0 product box.
The version of DOS you are running.
The version of Windows you are running.
The exact wording of any error message you have encountered.
What happened and what you were doing when the problem occurred.
How you tried to solve the problem.

4. Log off CompuServe.

See also
Calling technical support
Using the Asymetrix Bulletin Board System (BBS)
Using America Online
Using America Online for the hearing-impaired
Using Byte Information Exchange (BIX)
Using Internet



Using America Online
Step by step

If you are an America Online member, you can receive online technical support by leaving a message for the 
Asymetrix Forum Moderator. The Forum Moderator checks America Online daily for new messages and answers 
them within 48 hours or less. To help the Forum Moderator answer your question, you will need to know some 
information about your system configuration.

You can receive the software required to use America Online at no cost, plus 5 free hours of online time. For 
details about America Online, call 1-800-827-6364 or (703) 893-6288.

To gather system configuration information for the Forum Moderator:
1. In the Program Manager, open the Main group, then open Windows Setup.
2. Copy down all the information listed in the Windows Setup dialog box.

Refer to your America Online documentation for step-by-step instructions for logging onto America Online, leaving 
messages for the Forum Moderator, and logging off America Online.

To connect to America Online:
1. Log on to America Online.
2. Do one of the following:

From the Go To menu, select Keyword, then type Asymetrix.
Go to the Computing and Software area, select Industry Connection, then select Asymetrix.

3. Leave a message for the Forum Moderator containing the following information:
The information you gathered about your system configuration.
Your MediaBlitz 2.0 serial number, found on the first installation disk, your license agreement envelope, or 

your MediaBlitz 2.0 product box.
The version of DOS you are running.
The version of Windows you are running.
The exact wording of any error message you have encountered.
What happened and what you were doing when the problem occurred.
How you tried to solve the problem.

4. Log off America Online.

See also
Calling technical support
Using the Asymetrix Bulletin Board System (BBS)
Using CompuServe
Using America Online for the hearing-impaired
Using Byte Information Exchange (BIX)
Using Internet



Using America Online for the hearing-impaired
Step by step

America Online operates a text telephone for the deaf or hearing-impaired (TDD). If you are an America Online 
member, you can receive online technical support by leaving a message for the Asymetrix Forum Moderator. The 
Forum Moderator checks America Online daily for new messages and answers them within 48 hours or less. To 
help the Forum Moderator answer your question, you will need to know some information about your system 
configuration.

You can receive the software required to use America Online at no cost, plus 5 free hours of online time. For 
details about America Online for the hearing impaired, call 1-800-759-DEAF.

To gather system configuration information for the Forum Moderator:
1. In the Program Manager, open the Main group, then open Windows Setup.
2. Copy down all the information listed in the Windows Setup dialog box.

Refer to your America Online documentation for step-by-step instructions for logging onto America Online, leaving 
messages for the Forum Moderator, and logging off America Online.

To connect to America Online:
1. Log on to America Online.
2. Do one of the following:

From the Go To menu, select Keyword, then type Asymetrix.
Go to the Computing and Software area, select Industry Connection, then select Asymetrix.

3. Leave a message for the Forum Moderator containing the following information:
The information you gathered about your system configuration.
Your MediaBlitz 2.0 serial number, found on the first installation disk, your license agreement envelope, or 

your MediaBlitz 2.0 product box.
The version of DOS you are running.
The version of Windows you are running.
The exact wording of any error message you have encountered.
What happened and what you were doing when the problem occurred.
How you tried to solve the problem.

4. Log off America Online.

See also
Calling technical support
Using the Asymetrix Bulletin Board System (BBS)
Using CompuServe
Using America Online
Using Byte Information Exchange (BIX)
Using Internet



Using Byte Information Exchange (BIX)
Step by step

If you are a Byte Information Exchange (BIX) member, you can receive online technical support by leaving a 
message for the Asymetrix Forum Moderator. The Forum Moderator checks BIX daily for new messages and 
answers them within 48 hours or less. To help the Forum Moderator answer your question, you will need to know 
some information about your system configuration.

To gather system configuration information for the Forum Moderator:
1. In the Program Manager, open the Main group, then open Windows Setup.
2. Copy down all the information listed in the Windows Setup dialog box.

Refer to your BIX documentation for step-by-step instructions for logging onto BIX, leaving messages for the 
Forum Moderator, and logging off BIX.

To connect to BIX:
1. Log on to BIX.
2. At the prompt, type join asymetrix.

3. Select media.blitz from the list of topics.

4. Leave a message for the Forum Moderator containing the following information:
The information you gathered about your system configuration.
Your MediaBlitz 2.0 serial number, found on the first installation disk, your license agreement envelope, or 

your MediaBlitz 2.0 product box.
The version of DOS you are running.
The version of Windows you are running.
The exact wording of any error message you have encountered.
What happened and what you were doing when the problem occurred.
How you tried to solve the problem.

5. Log off BIX.

See also
Calling technical support
Using the Asymetrix Bulletin Board System (BBS)
Using CompuServe
Using America Online
Using America Online for the hearing-impaired
Using Internet



Using Internet
Step by step

If you have access to Internet mail, you can receive online technical support by leaving a message for the 
Asymetrix Forum Moderator. The Forum Moderator checks Internet daily for new messages and answers them 
within 48 hours or less. To help the Forum Moderator answer your question, you will need to know some 
information about your system configuration.

To gather system configuration information for the Forum Moderator:
1. In the Program Manager, open the Main group, then open Windows Setup.
2. Copy down all the information listed in the Windows Setup dialog box.

Refer to your electronic mail documentation for step-by-step instructions about starting mail and sending 
messages on Internet.

To access Internet:
1. Start your electronic mail application.
2. In the box where you enter the receiver's address, type support@asymetrix.com.

3. Leave a message for the Forum Moderator containing the following information:
The information you gathered about your system configuration.
Your MediaBlitz 2.0 serial number, found on the first installation disk, your license agreement envelope, or 

your MediaBlitz 2.0 product box.
The version of DOS you are running.
The version of Windows you are running.
The exact wording of any error message you have encountered.
What happened and what you were doing when the problem occurred.
How you tried to solve the problem.

4. Send your message.

See also
Calling technical support
Using the Asymetrix Bulletin Board System (BBS)
Using CompuServe
Using America Online
Using America Online for the hearing-impaired
Using Byte Information Exchange (BIX)




