To adjust the colour cycling playback
1 On the Options menu, click Colour Palette.
2 To cycle the colours backwards, select the Cycle backwards check box.

3 To control the cycling speed, change the Cycle speed value.



To control the palette used for fractal windows

1 On the File menu, click Preferences.
2 Click the Miscellaneous tab.

3 Select a Palette Auto-Loading option:
Always -- Use the palette of the opened fractal. All open fractals update using this new palette.
Query -- Ask you whether to use the palette of the opened fractal or use the existing palette.
Never -- Use the existing palette for the opened fractal.



To cycle the colours in a palette

1 On the Options menu, click Colour Palette.

2 Select the Cycle colours check box.

You can also shift the colour values manually by dragging the slider's knob.

Notes

Colours cycle slower in higher colour depths, such as 24-bit displays.

While colour cycling is fundamentally a 256-colour operation, Fractal eXtreme's colour cycling is fully functional in 64K
(high colour) and 16 million (true colour) colour modes. Although colour cycling in these modes requires redrawing the images, this
happens very quickly and performance is quite respectable on most graphics cards.

Colour cycling totally controls the system colour palette (refusing even to share its colours with other running
applications), which will force other paletted applications to redraw themselves. This can make them look very unattractive (due to
the small number of colours left to them), but it will allow colour cycling to proceed at top speed. This is the only way to do colour
cycllng Note that a backdrop image, if visible, makes use of the system palette, and therefore causes these problems.

Colour cycling stops whenever the Colour Palette window becomes inactive, such as when another window is activated.



To open a previously saved colour palette
1 On the Options menu, click Colour Palette.
2 On the Colour Palette window's File menu, click Open.

3 Select the previously saved palette or fractal file to use, then click Open.

Fractal eXtreme's colour palette files use a .fxp file name extension.
Tip: You can also select a fractal (.fx) file to use its palette.

All currently open fractal windows use the new colour palette.

To save the current colour palette to disk

1 On the Options menu, click Colour Palette.

2 Do either of the following:

To save the current palette using its current name, on the Colour Palette window's File menu, click Save.

To save the current palette with a different name or to a different folder, on the Colour Palette window's File menu, click
Save As, navigate to the desired folder, enter a name for the palette in the File name text box, then click Save.

Fractal eXtreme's colour palette files are saved with a .fxp file name extension.



To restore the default colour palette

1 On the Options menu, click Colour Palette.

2 On the Colour Palette window's File menu, click Reset.



To select the colours to use

1 On the Options menu, click Colour Palette.

2 Add, move, or remove control points in the red, green, and blue colour bands, as follows:
" To select a control point, click it.
. To select multiple control points, hold down the SHIFT key as you click control points. Alternatively, drag a marquee box
around them. Note that you can drag across one or more colour bands.
" To select all control points on a colour curve, with the pointer above the colour band, click the right mouse button to open
the pop-up menu, then choose Select All.
" To toggle the select of a control point, hold down the CTRL key as you click a control point.
To add a control point, hold down the cTRL key as you click at the location to add a control point.
To remove a control point, select the control point, then press the DEL key or choose Delete from the Colour Palette
window's Edit menu. You can also choose Cut from the same menu if you want to place the control point in a different location in
the same colour band or a different colour band (using one of the Paste commands described below).
. To move a control point, drag the control point. Hold down the SHIFT key as you drag a control point to restrict its
movement either vertically or horizontally. The first direction you drag is the constrained axis.
" To copy control points, select them, choose Copy from the Colour Palette window's Edit menu, then paste them in one of
the following ways:
- To replace with the copied control points, choose Paste from the Colour Palette window's Edit menu. The control points
are pasted into the same bands from which they were copied or cut.
- To add the copied control points to a colour band's existing control points, click the right mouse button above the colour
band to open the pop-up menu, then choose Insert Paste.
- To replace a colour band's existing control points with the copied control points, click the right mouse button above the
colour band to open the pop-up menu, then choose Replace Paste.
" To undo or redo an editing operation, choose Undo or Redo from the Colour Palette window's Edit menu. Fractal
eXtreme's Colour Palette window supports multiple levels of undo and redo.

Note

Fractal eXtreme remembers colour palette changes, even when the Colour Palette window is not open. For example, if
you open a fractal that replaces the current colour palette, you can open the Colour Palette window and choose Undo from its Edit
menu to restore the previous colour palette.



To set the colour of the fractal's interior

1 On the Options menu, click Colour Palette.

2 On the Colour Palette window's Colour menu, click Interior.

3 Adjust the red (R), green (G), and blue (B) sliders to the desired colour.

As you change the values, the interior colour of open fractal windows changes accordingly to make it easier to see how a
particular interior colour will look.

4 Click OK.



To set the colour used between edges

1 On the Options menu, click Colour Palette.

2 On the Colour Palette window's Colour menu, click Edge Fill.

3 Adjust the red (R), green (G), and blue (B) sliders to the desired colour.

As you change the values, the colour between edges of open fractal windows that are showing edges changes accordingly to
make it easier to see how a particular colour will look.

4 Click OK.



To use a preset colour palette

1 On the Options menu, click Colour Palette.

2 On the Colour Palette window's Presets menu, select a palette.



Advanced Settings dialog box

The Advanced Settings dialog box contains calculation controls, that you can adjust for the current fractal.

Note: The default settings in this dialog box are appropriate for casual uses of Fractal eXtreme. These controls are available for
people either who know what they do or who have mastered the rest of the program and want to experiment with these settings.

To open the Advanced Settings dialog box: On the Options menu, click Advanced Settings.
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To learn more about the information in this dialog box, click it.



Provides a space for you to adjust the threshold value (expressed as a number of bits of precision) for switching between calculation
routines. You can also click the scroll arrows to select a new setting.

As you zoom further into a fractal, the program requires more digits of accuracy to perform the fractal calculations. The program
automatically switches to the appropriate level of precision, based on the zoom level and image size; the Status window's More Info
view displays the current level of precision. To ensure that the program is using sufficient precision, you can increase its cushion of
extra bits of precision.

Every time the magnification is doubled, an extra bit of precision is required. For example, setting this value to 10 means that the
program will switch to the next higher calculation routines ten zooms earlier. If you feel that you are seeing imprecise results, you
can increase this setting. However:

a Fractal eXtreme is very good at choosing the correct level of accuracy. There are no known problems with the current method.
b If you are not close to the point where Fractal eXtreme would change the level of accuracy, changing this setting may have no
effect. This is normal and expected.
For best performance with no quality problems, leave this setting at zero or a fairly low number.



Specifies whether to automatically fill in or "guess" areas of similar colour, instead of calculating them (which can be a very slow
process for little gain). By default, this setting is selected, meaning Fractal eXtreme will try to notice these areas and fill them in, or
"guess" them.

Fractal eXtreme does very aggressive guessing to ensure that it gets the largest possible speed-up (sometimes a ten times speed-
up, or more). Then, when it has finished calculating 99% of an image, it does a final pass looking for any pixels that it may have
erroneously guessed. This is why the progress bar in the Status window sometimes seems to stop at around 99% for a few
seconds. This guess correction finds the overwhelming majority of the misguessed pixels so that the quality of the images is not
visibly corrupted, yet enough pixels are guessed that the calculations typically run much faster.

For best performance with no visible quality problems, keep this option selected at all times.



Click this to store the current settings in this window as the default settings.



Provides a space for you to type the value (overflow point) at which the absolute value of Z (in the following formula for the
Mandelbrot set) should not exceed.

Z(n+1l) =Z(n) *Z(n) + ¢
This formula is repeated until either the Maximum Number of Iterations (as set in the Iteration Control window) is reached, or until
the absolute value of Z exceeds this specified overflow point (signifying that the calculations will then quickly tend towards infinity).
For the Mandelbrot set, any overflow point from 2.0 or higher will work. The default value of 2.0 is used because calculations are
slightly faster and, in many areas, it produces the most interesting images.
You are encouraged to experiment with different numbers. As you increase the overflow point, the bands of colour move slightly out.
In some areas this is almost invisible, in others it is very dramatic. Setting the overflow point to less than 2.0 is not mathematically
meaningful for the Mandelbrot set, but it still looks cool! The default overflow points for other equations may be different.

On a non-zoomed Mandelbrot, set you can see the effect of changing the overflow point quite clearly, as the outermost bands move
outwards.



Specifies whether to store iteration information in the fractal (.fx) file on disk. By having iteration data available, Fractal eXtreme can
remap colours without recalculation, show and hide edges, and render iteration movies, all in real time!

Saving iteration data can increase the size of fractal files substantially, so this option is deselected by default. However, if you have
a reasonably large hard drive, we encourage you to select this option and make it the default setting so that iteration data is always
available.



Specifies whether to calculate the current fractal at a size other than that defined by its window.

By default, fractals are calculated at the size as the window in which it is being displayed. You can maximize the main and fractal
windows, but you are limited to the size of your desktop. With a virtual screen, you can render fractals at any size, limited only by
available memory. The fractal is then scaled down to fit its window.

Note: To save these oversized fractals as bitmaps, use the Save Bitmap Only command in the File menu..



Provides a space for you to type the height (in pixels) of the virtual screen. You can also click the scroll arrows to select a new
setting.



Provides a space for you to type the width (in pixels) of the virtual screen. You can also click the scroll arrows to select a new
setting.



Auto Explorer window

The Auto Explorer window lets you control the unattended exploration of fractals.

To open the Auto Explorer window: On the Location menu, click Auto Explorer.
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To learn more about the information in this window, click it.

Note: In Advanced mode, this window is nonmodal, meaning you can switch among fractal windows while this window is open; the
Exit button is labeled Close.




Click this to start or stop exploring the current fractal.



Specifies the number of zoom levels to skip after the current zoom image has been fully rendered. You can also click the scroll
arrows to select a new setting.

Larger zoom increments cause the program to explore deeper levels more quickly.



Colour Mapping window

The Colour Mapping window is where you adjust how the fractals use the colours in the colour palette. Use the controls in this
window to assign (map) the possible thousands or millions of different iteration bands in a fractal to the limited number (possibly a
few hundred) of colours possible on your computer display. Each fractal window has its own colour mapping settings.

By increasing the mapping speed, you can map many adjacent iteration bands to the same colour. By increasing the mapping
acceleration, you can map a few iteration bands to one colour for fractals at low iteration levels, but map many iteration bands to
one colour at high iteration levels. By adjusting the offset, you can select the first colour in the colour palette to use. This is
equivalent to cycling the colours in the Colour Palette window, except that changes in the Colour Mapping window affect only the
current fractal window.

To open the Colour Mapping window: On the Options menu, click Colour Mapping.
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To learn more about the information in this window, click it.

Note: Changing a fractal's max. iterations value changes the colour mapping when Acceleration is not set to one. This is because
changing the number of iterations changes the size of the range over which the colours have to be accelerated. This can be very
useful when searching for that perfect colour distribution, but it is rather disconcerting at first when your picture magically recolours
itself after you adjust the iterations or zoom in (which automatically adjusts the iterations for you).



Adjusts the detail near the interior of the fractal by mapping several iteration bands near the interior (where there are several in a
small area) to a single colour.

Increase the acceleration to see more detail at the interior's edges. This can produce a sharper interior edge because fewer colours
are being used.



Adjusts the first colour to start with from the colour palette. This value is added to the index value of the leftmost colour in the Colour
Palette window to get the first colour to use in the current fractal.



Click this to restore the default values in this window.



Adjusts how many iterations use a particular colour index in the colour palette. The default setting (1.000) uses one colour per
iteration.

Decrease the speed to see more colours at a time or increase the speed to see fewer colours.



Colour Palette window

The Colour Palette window is where you adjust the colours used by a fractal to identify different iteration values. All open fractal
windows use the same colour palette.

A good palette is absolutely critical to bringing out the detail and beauty of an interesting fractal image. Yet, most fractal exploration
programs give you a very rudimentary and difficult-to-use palette editor. Typically, you use a grid of cells for the number of available
colours, with sliders that let you adjust the red, green, and blue values of individual colours. If you are lucky, these programs supply
a command to create a smooth transition between two colour cells.

We think we've found a better way in Fractal eXtreme. Instead of forcing you to adjust hundreds of separate colours, why not treat
the red, green, and blue values as continuously varying quantities, controlled by a small number of control points, and visualized as
a rainbow of colour, and three separate curves.

The three graphs, with curves flowing through them, control how the amount of red, green and blue should vary throughout the
palette. Because iteration bands are, by default, colour mapped directly onto colours, this also defines how the colours should
change as the iterations change.

To open the Colour Palette window: On the Options menu, click Colour Palette.
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To learn more about the information in this window, click it.
The three most important operations in this window are:

" Move a control point -- Drag a control point around the graph. Moving a control point upwards increases the amount of
that colour, whereas moving it down lowers it.

. Add a control point -- Hold down the cTRL key as you click on one of the graphs.

" Delete a control point -- Select a control point, and then press the DELETE key.

Notes

. The Colour Palette window does not work in 16-colour or monochrome mode. However, it is fully functional in 64K (high
colour) and 16 million (true colour) colour modes!

" If you switch to another application that uses a colour palette and then switch back to Fractal eXtreme, Fractal eXtreme

doesn't restore its own colour palette until its main window is activated. Activating the Colour Palette window or any other dialog box
does not restore Fractal eXtreme's colour palette.

" Out of a palette of 256 colours, the Windows palette reserves 20 colours. Fractal eXtreme reserves another 8 colours for
dlsplaylng the center of the Mandelbrot set, the edge fill, among others. That leaves 228 colours -- plenty for displaying fractals.

For optimal fractal results, Fractal eXtreme uses the entire system colour palette, with the exception of the 20 colours
reserved by Windows. This means that if are running any other applications that try to use the palette, they may impair optimal
operation of Fractal eXtreme. Both applications should continue to run properly, but they may slow each other down. Each time you
change the palette in Fractal eXtreme (for example, every time you drag a point in the Colour Palette window), the system palette
will be remade and other paletted applications will have to redraw themselves, slowing down performance.

1 Related Topics



Specifies whether to cycle the colours in a right-to-left direction through the colour palette.



Specifies whether to display an animated view of the colours being shifted. This makes the colours seem to flow from the outer parts
of the fractal to its interior.

Note: Clicking outside the Colour Palette window or closing the window stops the animated view.



Specifies how fast the colours cycle through the palette. You can also click the scroll arrows to select a new setting.



Displays the offset of the last selected control point within the colour palette. The index value can be any number between 10 and
237.



Displays the red, green, and blue values of the last selected control point. Each value can be between 0 and 255.



Displays the current colour palette used to display all open fractals and provides a space for you to modify the colour palette.



Adjusts how the colours are assigned to iteration values in a fractal by cycling the colour palette. You can also drag the slider knob
to manually cycle the colours.




Drawing behaviour

Fractal eXtreme has the same behaviour as Mand2000 for drawing fractals. For faster visualizations, fractals are drawn in multiple
passes and drawn from the center of the window outward.




Exploration capabilities

Fractal eXtreme uses the same methods as Mand2000 for exploring fractals. Double-click the mouse button to zoom in or out.
Drag in a fractal window to pan around. View multiple fractal windows simultaneously.



Fast calculations

Fractal eXtreme calculates fractals with the same blazingly fast speeds as in Mand2000. Fractal information is continually
calculated while you change settings in the program.




Location identification

Fractal eXtreme can display where you are in a fractal as in Mand2000.




Virtually unlimited accuracy

Fractal eXtreme uses the same Mandelbrot calculation code as Mand2000 for virtually unlimited accuracy of fractal information.




To contact Cygnus Software about Fractal eXtreme
Use one of the following methods:

Post: Cygnus Software
33 University Square #199
Madison, W1 53715
USA

Web: http://www.cygnus-software.com

E-Mail:  sales@cygnus-software.com (Sales)
support@cygnus-software.com (Technical Support)
comments@cygnus-software.com (General Feedback)



To adjust the animated zoom speed

1 On the File menu, click Preferences.

2 Click the Miscellaneous tab.

3 Select the desired zoom speed from the Zoom speed list.

The default speed is Medium.



To control Julia seed dragging behaviour

1 On the File menu, click Preferences.
2 Click the Miscellaneous tab.

3 Under Julia Seed Dragging, adjust the following settings:

Max block size -- This controls how much of a fractal window gets recalculated while dragging a Julia seed. Lower block
sizes are appropriate for fast machines or small Julia windows, where you can get higher quality animations when dragging the Julia
seed. However, this may mean that the entire window doesn't have time to get calculated on each frame. Conversely, higher block
sizes are appropriate for slow machines or large Julia windows.

" Frame rate -- This controls the speed at which the fractal window is updated while dragging the Julia seed. If you have an
extremely fast machine, or a small Julia window, you may want to increase the frame rate, for better animation quality.



To control how the mouse buttons behave

1 On the File menu, click Preferences.

2 Do either of the following:

. To control the use of the left (primary) mouse button, click the Left Button tab.
" To control the use of the right (secondary) mouse button, click the Right Button tab.

3 Adjust the various settings to control what happens when you perform a particular operation with the selected mouse button.



To control palette changes when opening fractals

1 On the File menu, click Preferences.
2 Click the Miscellaneous tab.

3 Under Palette Auto-Loading, select one of the following options:
Always -- Use the palette of the opened fractal. All open fractals update using this new palette.
Query -- Ask you whether to use the palette of the opened fractal or use the existing palette.
Never -- Use the existing palette for the opened fractal.



To control the zoom location
1 On the File menu, click Preferences.
2 Click the Miscellaneous tab.

3 Under Zoom Destination, select either of the following options:
" Mouse position -- Zooms in or out from the location of the mouse pointer. The pixel under the pointer stays stationary.
Pixels around the pointer move farther away from it.
. Window center -- Zooms in or out from the center of the fractal window.



To hide or show the toolbar
b On the View menu, select or deselect Toolbar.

To hide or show the status bar
b On the View menu, select or deselect Status Bar.

To show the Status window
¥ On the View menu, click Status Window.



To select the zoom routines to use

1 On the File menu, click Miscellaneous.

2 Click the Miscellaneous tab.

3 To use Fractal eXtreme's custom scaling (zoom) routines, select the Custom zoom code option.

4 To use the system's scaling routines, deselect the Custom zoom code option.

Note
" On some computer systems, the custom routines will be faster, whereas on others, the system scaling routines will be
faster. Select the one that works best on your computer system.



To show or hide the startup screen
1 On the File menu, click Preferences.
2 Click the Miscellaneous tab.

3 Do either of the following:
To display the startup screen, select the Show startup screen check box.
To stop the startup screen from appearing, deselect the Show startup screen check box.



To switch between Simple and Advanced modes
1 On the File menu, click Preferences.
2 Click the Miscellaneous tab.

3 Do either of the following:
To switch to Advanced mode, select the Advanced check box.
To switch to Simple mode, deselect the Advanced check box.



AVI

Audio-Video Interleave (AVI) is the standard file format for animation files on the Microsoft Windows operating system. This file
format is also referred to as the Video for Windows format.

Fractal eXtreme renders iteration movies in AVI format.



BMP

BMP, or BitMaP, is the standard file format for storing bitmapped images on the Microsoft Windows operating system. Fractal
eXtreme stores its fractal files in BMP format, so that the images can easily be used in other programs. BMP files typically
have .bmp file name extensions.

However, some programs do not properly or completely support the reading of BMP files and cannot handle reading Fractal
eXtreme files directly.

Fractal eXtreme stores all the fractal information it needs to save (location data, bitmap data, palette data, and possibly more)
between the header and the actual bitmap data in a BMP file. This is a perfectly legal variant on the BMP format, but many
programs have problems with it. Also, the bitmap data is stored compressed, to avoid wasting enormous amounts of hard drive
space. Although storing images compressed on disk is clearly the sensible thing to do, many programs to not support this variant
of the BMP format.

If your favourite program that deals with BMP files does not load Fractal eXtreme files properly, complain to the vendor.
Or, alternately, use the Save Bitmap Only command (in the File menu) or the Copy command (in the Edit menu), both of which
create BMP files that are optimized for compatibility.



CPU

CPU stands for Central Processing Unit. The brains of a computer. A single chip containing a whole lot of transistors.



FPU

FPU stands for Floating Point Unit. Back in the dark ages, when CPUs had fewer than a million transistors, most computers had
no built-in ability to do math with floating point numbers. They had to simulate floating point math using clever combinations of
integer math. Power users could buy an extra chip, essentially a second CPU, to do their fancy arithmetic for them. These
separate units were called floating point units. Thankfully, those barbaric days are past and virtually all new computers come with
a built-in floating point unit.




Julia

Many fractal types, the Mandelbrot set for instance, have a related set of fractals called Julia sets. These Julia set fractals use
the same equation as their non-Julia counterparts, but the equations are evaluated differently.

For each type of fractal that has Julia sets, there are an infinite number of Julia sets. Each one is uniquely defined by a seed
location, which is a point on the fractal from which they are derived. This seed location is set in the Set Julia Seed window.

Julia sets have their own distinct style and visual appeal but, despite their differences, they maintain a certain similarity to the
fractal which they are based upon. In fact, if you zoom in on a Julia set, and at the same time zoom in on the corresponding non-
Julia fractal in the area of the Julia seed, the Julia and non-Julia fractals become more and more similar -- an odd thing
considering their radically different appearances when zoomed out.

For an example of this similarity, try out the Finding order in chaos exercise.



Julia seed

A Julia seed is a pair of numbers which correspond to a point on the Julia's corresponding non-Julia fractal. This pair of numbers
uniquely defines a particular Julia set fractal. The Julia seed is used in the Julia calculations as the value for C in the equation Z
=Z + C, while the pixel being calculated is used as the initial value for Z. The Julia seed can be adjusted and viewed by using
the Set Julia Seed window.

As the Julia seed approaches and crosses the edges of the non-Julia fractal associated with the current Julia set, the Julia set
changes dramatically. When the seed goes inside the interior of the non-Julia fractal, the Julia set is ripped apart by an explosion
of the interior colour at its center. When it goes outside of the non-Julia fractal, the Julia set instantly collapses in on itself,
producing dramatically different images.

The mathematical details are not important for an appreciation of Julia sets.



Mand2000
Mand2000 is the name of Cygnus Software's Amiga-based fractal exploration program, on which Fractal eXtreme is based.

You can open Mand2000 files in Fractal eXtreme. However, you cannot open Fractal eXtreme files in Mand2000. Sorry, but
innovation has its price.



Mandelbrot

The Mandelbrot set is probably the most famous of all fractals. It is named for its discoverer, Benoit Mandelbrot, one of the
people who pioneered the exploration of fractals and other chaotic systems. The Mandelbrot set is a fascinating object because,
while it is probably one of the most complex objects in mathematics, it is created by iterating an extremely simple formula: Z = Z *
Z + C, where Z and C are complex numbers. The initial value of Z is zero, and the initial value of C is the location of the current
pixel. How odd that this trivial little formula can produce the endless complexity and infinite length of the Mandelbrot set.



Simple/Advanced modes

Simple mode (the default) hides certain advanced controls for a simpler interface to the program. Advanced mode gives you
access to these controls.

If you are new to Fractal eXtreme or like to view fractals mainly for their visually beauty, stick with Simple mode. If you want the
most control over the fractals you view in Fractal eXtreme, use Advanced mode.

Advanced mode enables the following:
EFavourite Spots window can view any folder on your machine.

Auto Explorer is opened as a modeless window, to allow you to continue using Fractal eXtreme while it auto-explores in
one window.

You select Advanced mode in the Miscellaneous page of the Preferences window.



calculation (calc) path

In the process of calculating a fractal, such as the Mandelbrot set, a simple equation is applied repeatedly to each pixel in the
fractal window. The equation takes the coordinates for that pixel, does some math, and produces another pair of numbers to
serve as the input to the next iteration. This pair of numbers can be thought of as being a set of coordinates, and can be plotted
on the fractal window.

A calculation (calc) path is simply the series of points created by iterating on one point, connected up with lines to show the
movement from one to the other. The internal workings of the calculations can be made much more transparent by viewing the
calc paths. Many patterns become suddenly apparent, and the differentiation between points inside the Mandelbrot set, that
never escape, and points outside of the Mandelbrot set, that run for infinity, is clearly visible.



complex number

A complex number is the sum of two terms, the first one a real number and the second an imaginary number. Complex numbers
are written in equation form as:

A+ Bi

where A is the real number and B is the imaginary number. The "i" in the equation is the mathematical representation of the
square root of -1.



complex plane

The complex plane is the two-dimensional space made up of real and imaginary numbers, where real numbers lie along the
horizontal axis and the imaginary numbers lie along the vertical axis.



cycle

In the process of calculating a fractal such as the Mandelbrot set, a simple equation is applied repeatedly to each pixel in the
fractal window. The equation takes the coordinates for that pixel, does some math, and produces another pair of numbers to
serve as the input to the next iteration. This pair of numbers can be thought of as being a set of coordinates. If the point is a

member of the Mandelbrot set, these points will stay forever quite near to the origin.

One way that a sequence of points, or calculation path, can be sure that it never strays too far from home is to run around in
circles. That is, to loop around a bit and then start following in its own footsteps. Once a point in a calculation sequence returns
to a point it has previously visited, it is trapped. From then on, it will always follow exactly the same sequence of steps, running
around the same sequence of points forever more.

That's one way that a point can avoid running away to infinity, and it turns out (I believe) that it is the only way. Points either get
trapped in a cycle or run around for a while and then head for the hills.



edges

An edge is the boundary between iteration bands, the contours visible in most images.

When edge visibility is toggled on and off, Fractal eXtreme dissolves smoothly from one image to the next.



fixed point

Fixed point math refers to using integer math to perform math on non-integral numbers. The programmer is responsible for
shifting numbers around and converting when necessary in order to properly simulate the behaviour of calculating with floating
point numbers.



floating point numbers

Floating point numbers are numbers that are represented with a multiplier and an exponent. This allows efficient representation

of numbers with a wide range of values. When printed out for human usage, these numbers are frequently printed in scientific
notation.



fractal

For those mathematically inclined, a fractal is a graphic representation of a whole bunch of complex numbers. The numbers are
plotted on a plane with the real-number component representing the distance left or right of the center, and the imaginary
component representing the distance above or below the center.

For the rest of us, a fractal is just cool eye candy.

There are several types of fractals, the most famous being the Mandelbrot set. In Fractal eXtreme, several other types are
available for you to explore.

Fractals appear in fractal windows.



guessing

Fractal images can be extraordinarily compute intensive. If you zoom far enough into a fractal, you can make the world's fastest
computer seem slow. Guessing is a way to try to avoid some of the time-consuming calculations. The guessing technique comes
from the observation that, although some parts of fractals are infinitely complex, there are also frequently places that have very
large iteration bands. Fractal eXtreme tries very aggressively to detect such areas and minimize the number of redundant
calculations it makes. This aggressive guessing will cause noticeable errors on some pictures, which is why Fractal eXtreme
finishes off each calculation by scanning for potentially incorrectly guessed pixels, and fixing them. Even with this correction
stage at the end, guessing speeds up Fractal eXtreme's calculations by up to a factor of ten, or more, with no discernible loss of
quality.



iteration

To iterate is to repeat the same process again and again. When used in reference to fractal calculations, an iteration usually
implies using the results of one calculation as the input to the next. See also: recursion.

But what really is an iteration?

The equation used to calculate the Mandelbrot set is an extremely simple equation, involving nothing more complicated than
addition and multiplication. What allows the infinite complexity of the Mandelbrot set to come out of such a simple equation (the
actual equation is Z = Z * Z + C), is that the equation is iterated. That is, it isn't just calculated once per point, it is calculated
many times. Each time the result of the previous iteration is fed into the new calculation. The basic idea is that if the value of Z
always stays near zero, then the point is in the Mandelbrot set. If the value of Z heads off to infinity, then it isn't in the Mandelbrot
set.

Recognizing when Z heads off to infinity is easy, but ensuring that it will never head off that way is considerably trickier. The only
way to be certain would be to continue iterating the equation forever. Clearly this would not be practical, so instead we choose a
maximum number of times to iterate the equation. The trick is to set it high enough so that all points heading off to infinity have
time to declare their intentions, yet low enough so that pictures can be calculated in a reasonable time.




iteration bands

The bands of colour which are clearly visible in most fractals consist of pixels that required the same number of iterations to
calculate. In the Mandelbrot set, these iteration bands all go entirely around the Mandelbrot set, while never overlapping each
other. This creates an unusual series of concentric circles where the inner circles are actually longer than the outer circles. The
inner iteration bands grow successively longer due to the increased meandering and complexity. The innermost iteration band, if
there was such a thing, would be infinitely long.




iteration movie

An iteration movie is an animation file that displays the same area of a fractal, but cycling through different iterations. These
types of movies simulate the flow of colour through a fractal's iteration bands, producing interesting animations.




location
Location is just another term for describing a fractal's coordinates.

You specify the location in a fractal in the Set Location window. A fractal's location is the middle point within a fractal window.



max. iterations

Most fractal equations involve iterating the same equation many times for the each pixel. If the coordinates you keep modifying
start heading towards infinity, you can stop iterating and display the appropriate colour for the number of iterations that you did. If
the coordinates never head for infinity, you can colour them with the interior colour because that means they are part of the set

(Mandelbrot set, or whatever fractal you are calculating).

But how do you decide that they are never going to head for infinity? The only way to be sure is to iterate the equation an infinite
number of times, a process that tends to take quite awhile! So, max. iterations specifies the threshold of your patience. A high
value will produce more detailed pictures, with more iteration bands, but will take longer to calculate.

You set the max. iterations value using the Maximum Iterations Per Pixel control in the Iteration Control window.



origin
The origin is just an intimidating term that mathematicians use when they talk about the point whose coordinates are 0, 0. It's the

point where the x and y axes meet, and whose real and imaginary components both have zero magnitude. It's also the center of
the complex plane. It's nowhere.



overflow point

The overflow point is the value at which the fractal's equation shouldn't exceed. When Fractal eXtreme calculates the value for a
particular location of a fractal, it evaluates the fractal's equation (defined by its plug-in) until either the max. iterations value or the
overflow point has been reached.



plug-in
In Fractal eXtreme, a plug-in describes how to create a type of fractal. Included in Fractal eXtreme are several fractal plug-ins.

The program can be extended to support new types of fractals by simply installing new fractal plug-ins. Contact Cygnus Software
for information on the Fractal eXtreme Plug-In Developer Kit.



recursion

Recursion is when a process invokes or calls itself. This is similar, and indeed equivalent, to iteration.



scientific notation

Scientific notation is a way of writing down numbers that may get very large or very small, by specifying a multiplier and an
exponent.

For example, 1.079e+011, means 1.079 times ten to the eleventh power. This could also be written as 1.079 * 100,000,000,000,
or as 107,900,000,000.



virtual screen

A virtual screen is a method of creating fractals at sizes larger than what can be displayed in a fractal window. By default, fractals
are calculated at the size that they are displayed. However, if you need to save or print a fractal at a larger size, use a virtual
screen.

You create a virtual screen using the controls in the Advanced Settings dialog box.



yak
A Tibetan ungulate.

Yaks are not know for their interest in fractals. Neither are penguins.



zero

(a.k.a. big goose egg) The number that comes before one.



zoom level
The zoom level (known as the number of zooms) is a value representing the magnification of a fractal.

For more information on zoom levels, see the zoom level discussion.



zoom (tween) movie

A zoom movie is a movie showing an animated zoom deep into the depths of a fractal image. Fractal eXtreme makes use of
some unique technology to allow faster rendering of zoom movies, more compact storage of zoom movies, and more flexible
playback of zoom movies.

By only calculating and storing key frames, the time to render and the space required to store zoom movies are both reduced.
When you play the zoom movies, Cygnus Software's innovative FX Movie Player loads in the key frames and produces all of the
intermediate frames on the fly. This process of creating inbetween frames from key frames is sometimes called "tweening."

Because the frames are being created at playback time instead of at render time, you can adjust the playback speed and the
window size of the movie.



Edge Fill Colour dialog box

The Edge Fill Colour dialog box is where you select the colour to use to fill the areas of the fractal between edges. By default, this
area is black.

To open the Edge Fill Colour dialog box: On the Colour Palette window's Colour menu, click Edge Fill.
Set Edge Fill Colour
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To learn more about the information in this Edge Fill Colour dialog box, click it.

_1 Related Topics




Adjusts the red (R), green (G), and blue (B) component values. Each component can be a number between 0 (no intensity) and 255
(full intensity), giving you over 16 million colour choices.



Displays the colour defined by the R, G, and B sliders.



Exercise: Creating and viewing a zoom movie

With zoom movies, you can create animated explorations into and out from locations within a fractal. To see how it easy it is to
create and view a zoom movie, do the following:

1 Create a fractal or open an existing fractal.
2 Double-click and scroll in the fractal window until you get to the location that you want to zoom towards in the animation.

3 Resize the fractal window to the dimensions that you want the zoom movie to be.

You can see the fractal's pixel dimensions in the status bar (at the bottom of the main window) and in the Status window.
4 On the Render menu, click Make Zoom Movie.
5 In the Save Zoom Movie As dialog box, specify a location and name for your zoom movie.

By default, the dialog box is set to the movies subfolder. Enter a name in the File name text box, and then click Save.

The zoom movie is rendered to disk using the name you provided. After the zoom movie has finished rendering, the FX Movie
Player starts up and automatically loads and plays the rendered zoom movie.

6 Control the playback of the zoom movie using the VCR-style controls in the FX Movie Player.

7 When you are done viewing the zoom movie, choose Exit from the FX Movie Player's File menu to close the movie player
and the zoom movie.



Exercise: Cycling the colours of a fractal
For some cool eye candy, try the following:

1 Create a fractal or open an existing fractal.
2 On the Options menu, click Colour Palette.

3 Select the Cycle colours option.

The colours in the colour palette continually shift to the right, producing waves of colour through the iteration bands in all open
fractal windows.

To change the direction of the colour cycling, select the Cycle backwards option.
To change the speed of the colour cycling, specify a new Cycling speed value.

Deselect the Cycle colours option.
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To manually cycle through the colour palette, drag the slider left and right.



Exercise: Dragging a Julia seed

When you view a Julia version of a fractal, you can manually change the Julia seed in the Set Julia Seed window. To get an
animated view of a Julia whose seed changes over time, drag in a non-Julia window to adjust the Julia seed value, as follows:

1 Create a fractal or open an existing fractal, preferably of the Mandelbrot type.
2 Press CTRL+SHIFT+D to open a Julia window of the same type of fractal.

Initially, the Julia window uses the center of the Mandelbrot window as its seed location.

3 ALT-click in the Mandelbrot fractal window to adjust the Julia seed, thereby causing dramatic changes in the shape and look of
the Julia set.

4 ALT-click and drag around in the Mandelbrot window to continually update the Julia window using the changing seed value.

Notice the fundamentally different types of Julia sets that you get when you move the seed onto the black area of the Mandelbrot
set as opposed to the coloured areas.

Also notice that the type of Julia set you get is thematically similar to the type of Mandelbrot set you would get if you zoomed in
on the area of the Mandelbrot set where the seed is.

For best results, keep the Julia window relatively small so that it can be updated more easily.

Or, adjust the Julia Seed Dragging settings in the Miscellaneous page of the Preferences window.

Or, read up on Julia sets.



Exercise: Finding order in chaos
Part 1. Finding patterns in the Mandelbrot set

Although the Mandelbrot set, like many fractals, displays a frightening amount of complexity, it also overlays that with an overall
pattern. Try the following:

1 Open the following fractals from the favourites folder:

3 arms.fx
4 arms.fx
5 arms.fx
6 arms.fx
2 On the Location menu, click View Location.

Notice that these four images are quite neatly lined up along the large cardiod (pear shaped thing) in the Mandelbrot set. As
you move from one bulb to the next along the edge of the cardiod, the number of arms in major structures gradually increases.
You can get any numbers of arms that you want (well, no less than three).

3 Find the bulbs that have three arms and four arms, respectively.
Notice that there is another smaller bulb inbetween these two arms.
4 Zoom in on this smaller bulb.
Notice that it has seven arms -- the sum of three and four. Isn't that weird?

This pattern repeats itself all over the Mandelbrot set, at every level. How does it keep all these rules straight? Remember that
all of this is produced by an incredibly simple formula.

To continue with Part 2 of this exercise, click ™.



Exercise: Using the Auto Explorer

For unattended exploration of a fractal, use the Auto Explorer. Try the following:

1 Create a fractal or open an existing fractal.
2 On the Location menu, click Auto Explorer.
3 Click the Start button.
The program automatically starts zooming into randomly selected interesting locations in the fractal.
4 To zoom in at a faster rate, increase the Zoom increment value.
Note: The program will continue exploring the fractal until you either stop it to close this window.
5 Click the Stop or Exit button when you are done exploring the fractal.



Exercise: Finding order in chaos
Part 2. Viewing calculation paths

But it doesn't stop there. Do the following:

1

4

While holding down both the CTRL and SHIFT keys, click the bulb with three arms. This displays the calc path.

If the CTRL+SHIFT-click action does not display the calc path, check the left mouse button settings in the Left Button page of
the Preferences window.

While still holding down the mouse button, drag the mouse around the fractal.

Notice that the white line (representing the path taken by the point being calculated) seems to come back very close to its
starting point. It gets into a cycle, continually looping around the same path.
If the status bar is visible, Fractal eXtreme calculates the length of the cycle (that is, how many iterations it takes before the

calculations end up at the same point twice. You should notice that the calculation path does a cycle of length three! Gosh,
what a surprise? | wonder if this pattern holds? Of course it does!

It's interesting to note that if you go to the smaller bulb between the three bulb and the four bulb, the cycle is (of course) seven
lines long, but (if you zoom out enough to see the entire cycle) you will see that it goes around twice, instead of just once, like
all of the bulbs in the main sequence.

If you drop down to the next level of bulbs, the calc path goes around three times.

So, it appears that you can tell how many cycle lengths are being added up, by viewing a calc path's number of orbits.

To continue with Part 3 of this exercise, click *.



Exercise: Finding order in chaos
Part 3. Viewing thematic similarities between Julia and non-Julia fractals

The same numbers and themes also show up in Julia sets whose seeds are in and around these bulbs. To show this, do the
following:

1
2

Zoom into a bulb whose characteristic number you know.

On the File menu, click Duplicate as Julia.

Notice how the characteristic number also shows up in the Julia set.

Moving through the major bulbs to the right increases the number of arms (and the cycle length) by one. Moving to the left
through the major bulbs increases the number of arms by two. And the patterns and rules are subtly different. Why? | don't
know.

We've seen how the bulbs in the Mandelbrot set can count, and can do addition. Now let's see them do multiplication.

If you go to the three-arm bulb (the fairly large one at the top of the Mandelbrot set), you can see some smaller bulbs coming
off of it.

5 If you go into the topmost one of these, you get a cycle of six -- two orbits, each three long.

6 As you move along to other major bulbs, the number of orbits keeps increasing, thus allowing you to multiply any nhumber by

three.

If you want to multiply by a number other than three, you'll have to move into a bulb with a different base cycle length.

These regularities can be useful. If you find a picture you like, but you wish it had a few more arms, with a bit of practice and with
careful use of the View Location command, you can find other areas that are variations on your picture.



Exercise: Zooming into the Mandelbrot set

Most of the time, as you zoom into an interesting spot in a fractal, the coordinates of the center seem nothing more than a
jumbled mixture of random digits. If you type in a regular series of digits, and zoom in with the Zooms control (in the Set.
Location window), you almost invariably end up looking at a screen filled with all one colour. However, there are a few spots on
some fractals where extremely simple coordinates lead you into areas that, while not the most fascinating areas, remain detailed
no matter how far in you go.

Type the following locations into to the Real and Imaginary text boxes of the Set Location window for a Mandelbrot set, and use
the Zooms control to head down inside:

Location Real Imaginary
Top o' the world and end of 0.0 1.0

the set

Way out west -2.0 0.0

Stem of the pear 0.25 0.0

First vertical cusp -0.75 0.0
Second vertical cusp -1.25 0.0

(For the last three locations, you need to set the max. iterations value quite high.)

It is interesting to note that despite the incredible "chaoticness" of the Mandelbrot set, some points are very clearly and concisely
defined.



Favourite Spots window

The Favourite Spots window is where you can select a previously saved fractal to open. Unlike the Open Fractal dialog box, the
Favourite Spots window displays a preview of the fractal before you open it. Simply double-click the fractal you would like to open.

To open the Favourite Spots window: On the Location menu, click Favourite Spots.
+ Favourite Spots
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To learn more about the information in this window, click it.



Displays the current folder being viewed.



Lists the available drives that you can view. These correspond to the drives available on your system.
This control is available only in Advanced mode.



Click this to view the parent folder of the current folder.
This button is available only in Advanced mode.



Displays small previews of the fractals in the current folder.

A stamps subfolder is created in this current folder to store these small previews (stamps). This makes the display of these
stamps much quicker the next time you view the folder's contents.



To identify an iteration value

1 On the View menu, click Status Window.

2 Click the More Info button.

3 Move the pointer above the iteration band in the fractal.

The Iteration count text field in the Status window displays the iteration value under the pointer.



To identify the colour used in a fractal
1 On the Options menu, click Colour Palette.

2 Click at the colour in a fractal window. Be careful not to drag the fractal.

While the mouse button is held down, the colour palette index and RGB values of the colour under the pointer appear in the
Colour Palette window.



To show a point's calculation path
¥ Hold down the cTRL and SHIFT keys as you click the point in a fractal.

The calculation path appears in white. You can move the pointer while the CTRL and SHIFT keys are held down to see how the
calculation path changes for different points in a fractal.

The status bar (in the lower-left corner of Fractal eXtreme's workspace window) displays whether a cycle exists at the selected
location in the fractal. If one exists, it displays the length of the cycle.

Note

Showing the calculation path of a point on a fractal is, by default, assigned to the cTRL+sHIFT-click action. If you've

changed the mouse button behaviour in the Left Button or Right Button pages of the Preferences window, use the modified mouse
button action instead.



Fractal Size dialog box

The Fractal Size dialog box is where you can specify the pixel dimensions of a fractal displayed in a fractal window. You'll want to set
a fractal to a specific size if you will be creating a zoom or iteration movie or saving the fractal as desktop wallpaper.

To open the Fractal Size dialog box: On the Options menu, click Fractal Size.
Fractal Size - awezome.x
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To learn more about the information in this dialog box, click it.

"_Related Topics



Click this to change the Fractal width value to 320 and Fractal height value to 240.



Click this to change the Fractal width value to 640 and Fractal height value to 480.



Click this to set the current fractal to its maximum size. Use this setting when you want to save a fractal as desktop wallpaper that
fills the entire desktop.

Note: If you use the desktop setting, both the Fractal eXtreme window and current fractal window enlarge to their maximum sizes.



Provides a space for you to type the desired height (in pixels) of the current fractal. You can also click the scroll arrows to select a
new setting.

By default, this value represents the fractal's current height.



Provides a space for you to type the desired width (in pixels) of the current fractal. You can also click the scroll arrows to select a
new setting.

By default, this value represents the fractal's current width.



Fractal Theory: Complex Numbers

After you get into more complicated math, you start coming across some equations where the answer is neither a real number nor
an imaginary number, but the sum of both -- an answer that looks like this: 1 + 2i; or 7 + 56i. There's no way of simplifying these
equations. You can't reduce them so that there's only one term. You can't derive a sum. You just have to write them down as 1 + 2i.
These numbers, part real, part imaginary, are called complex numbers.

To add two complex numbers, say 7 + 4i and 3 + 9i, simply add the real and imaginary components separately (that is, 7 + 3 is 10
and 4i + 9i is 13i for a result of 10 + 13i).

What about multiplication? Do you have to learn brand new weird math to do that? Not really. Start with the easy part: 7 * 3 is 21.
More complicated is 4i * 9i. Or is it? It's the same as saying 4 * 9 *i *i. 4 * 9 is 36, and you know (because we defined it as such)
thati *iis -1. Therefore, 4i * 9i is -36. That leaves 7 * 9i, which is 63i, and 4i * 3, which is 12i. First, add up the real parts (21 + -36,
which is -15). Then, add up the imaginary parts (63i + 12i, which is 75i). So, the answer is -15 + 75i. A bit cumbersome and error
prone, but not too incomprehensible.

From all this the fractal is born.

Click the Next button to continue.

{button < Back,JI( FRACTALX.HLP>primary'," Fractal_Theory__Imaginary_Numbers')} {button Next
> JICFRACTALX.HLP>primary',"Fractal_Theory __The_Mandelbrot_Set')}



Fractal Theory: Connectedness

It's quite obvious that the outer bands around the Mandelbrot set form complete loops around the Mandelbrot set. The band
representing two iterations, for example, travels smoothly around the outer edges and then connects back up to itself. There are no
other points that have an iteration count of two except on this band, and all the points on this band are connected by other points
with an iteration count of two. This is less obvious but equally true for all other bands. If you zoom in to the band that represents ten
iterations, you can "drive" all the way around the Mandelbrot set, following that band, and return to where you started. You could try
it for the band representing 100 or 1,000 iterations, but it would take a very long time.

This little idea, of all the bands being single bands going all the way around, doesn't seem too amazing when you look at the outside
of the Mandelbrot set. But when you've zoomed in 20 times and are looking at a complex shape surrounded by spirals, it's quite
amazing to think that each band you see somehow works it way around each of the individual nodes in the structure, into and out of
all the arms in the spiral and then onwards around the Mandelbrot set, without ever crossing another band or ever quite
disappearing.

The Mandelbrot set, the internal black (by default) area, itself is not excluded from this rule. Whenever you come across a miniature
copy of the Mandelbrot set (and there are an infinite number of them scattered around), you can be sure that this tiny copy is
connected to the main Mandelbrot set by one, and only one, infinitely thin filament that you will never see, but whose presence can
be detected by seeing the constantly thinning bands of colour squeezing in on it from both sides.

{button < Back,JI( FRACTALX.HLP>primary',"Fractal_Theory__Fractal_Dimensions')}



Fractal Theory: Fractal Dimensions

The Mandelbrot set and Julia sets are fractals. What this means is that the boundary between the black area that is the Mandelbrot
set and the surrounding area that isn't the Mandelbrot set is not a simple line or a curve (one dimensional), but it also isn't a filled-in
circle or square (two dimensional). It is so convoluted, folded, and detailed, that it is considered to have fractional dimension.

When you double the magnification of a fractal, the length of the curve, and hence the area covered, does not merely double. All
previously visible portions of the curve double in length, but new bumps, curves, and fjords in the boundary become visible and add
to the length.

The Mandelbrot set has been proven to have a fractal dimension of two. That means that each time you double the magnification,
the length of the boundary increases four times. It also means that the Mandelbrot set is as complicated as a fractal can get. The
length of the boundary of the Mandelbrot set is infinite -- it can be any length you want, if you measure it with a small enough
measuring stick.

Click the Next button to continue.

{button < Back,JI( FRACTALX.HLP>primary', Fractal_Theory__The_Battle_for_Z_s_Destiny')} {button Next
> JICFRACTALX.HLP>primary',"Fractal_Theory__Connectedness')}



Fractal Theory: Imaginary Numbers

But first, a quick refresher math course.

We should all remember that the square root of nine is three, of four is two, and of one is one. But how many remember what the
square root of negative one is? (Those who said "me" can skip to the next paragraph. Those of us who once knew but have
somehow forgotten should probably read on.) Well one answer to what is the square root of -1 is that there isn't one. However
another answer, which is equally valid, and perhaps far more interesting, is that because there isn't any number which multiplied by
itself gives us -1, we'll create one. That's a handy way of plugging up all sorts of mathematical theories that would otherwise have
special cases for when you need the square root of a negative number. How do we "create" a number which is the square root of
-1? Simple. Just get enough mathematicians together in one room and get them to all agree that from then on, the letter "i"
represents the square root of -1. That's all it takes. That's all it took. A convention of mathemeticians creates the convention of "i,"
and "i" is subsequently recognized as being the square root of -1.

So, if "i" is the square root of negative one, then two times "i" is the square root of negative four, three times "i" is the square root of
negative nine, etc. All these numbers that are multiplied by "i" are called imaginary numbers, a throwback to those early years when
mathematicians weren't quite sure whether they were real or not. Numbers that aren't multiplied by "i", regular numbers, are called
real numbers. Simple enough.

Click the Next button to continue.

{button < Back,JI( FRACTALX.HLP>primary', Fractal_Theory__Sample_Code")} {button Next
> JICFRACTALX.HLP>primary',"Fractal_Theory__Complex_Numbers')}



Fractal Theory: Introduction

What is the Mandelbrot set? A mathematician might say it was the locus of points, C, for which the series Zn+1 =Zn*Zn + C, Z0 =
(0,0) is bounded by a circle of radius two, centered on the origin. For most of us who aren't mathematicians, the Mandelbrot set is:
. A pretty picture.

. A mathematical wonder that we can appreciate, and to some extent understand, even if we don't understand the first
paragraph.
. Just one example of an amazing new science with applications as far ranging as weather forecasting, population biology,
and computerized plant creation.

" A floor wax and a dessert topping!

" All of these and more.

One of the fascinating things about the Mandelbrot set is the seeming contradiction in it. It is said to be the most complex object in
mathematics, perhaps the most complex object ever seen. But at the same time, it is generated by an almost absurdly simple
formula. Multiply Z by itself. Add C. The answer is the new value for Z. Repeat until the absolute value of Z is greater than two, or
until our counter expires. If Z exceeds two, then the point is not in the Mandelbrot set. If it doesn't exceed two after a large number
of iterations, then it is assumed to be in the Mandelbrot set.

Click the Next button to continue.

{button Next >,JICFRACTALX.HLP>primary',"Fractal_Theory _Sample_Code")}



Fractal Theory: Sample Code

To demonstrate just how simple it is to generate pictures of the Mandelbrot set, here's a small program written in the C programming
language. If you have a C compiler, try it out. It is a complete working program

#include "stdio.h"

#define MaxIters 200

#define SIZE 80
#define BLACK -1
#define LEFT -2.0
#define RIGHT 1.0
#define TOP 1.0
#define BOTTOM -1.0

main (int argc, char *argv[])

{
short X, y, counter;
long double zr, zi, cr, ci
long double rsquared, isquared;

for (y = 0; y < SIZE; y++)

{
for (x = 0; x < SIZE; x++)
{

zr = 0.0;
zi = 0.0;
cr = LEFT + x * (RIGHT - LEFT) / SIZE;

ci = TOP + y * (BOTTOM - TOP) / SIZE;
rsquared = zr * zr;
isquared = zi * zi;

for (counter = 0; rsquared + isquared <= 4.0
&& counter < MaxIters; counter++)

zi = zr * zi * 2;
zi += ci;

zr = rsquared - isquared;
zr += cr;

rsquared = zr * zr;
isquared = zi * zi;

}

if (rsquared + isquared <= 4.0)

printf ("*"); /* In the set. */
else
printf (" "); /* Not in the set. */
}
printf ("\n");

}

return 0;

For those of you who aren't programmers, here's an excerpt of the code that actually does all of the calculations. Here itis, all
eleven lines of it:

for (counter = 0; rsquared + isquared <= 4.0 && counter < MaxIters; counter++)
{

zi = zr * zi * 2;

zi += ci;

zr = rsquared - isquared;
zr += cr;

rsquared = zr * zr;



isquared = zi * zi;

That's all it takes to do a rudimentary exploration of the Mandelbrot set. Slowly.

But where did this magical sequence of instructions come from? It certainly looks very arbitrary, and very peculiar. It turns out that
it is a computerized version of an even simpler formula.

Click the Next button to continue.

{button < Back,JIFRACTALX.HLP>primary', Fractal_Theory__Introduction’)} {button Next
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Fractal Theory: The Battle for Z's Destiny

Z starts out being initialized to zero, that is, both the real and imaginary parts are set to zero. C is initialized to the complex number
representing the point to calculate, its real portion is its horizontal distance from the center of the plane, its imaginary portion is its
vertical distance from the center of the plane. Continuing to go through the loop (described in the previous panel), take the square Z
and add C to it. What's the point to all of this? Whether Z will start getting large, or will stay a very small number, trapped around the
center of the complex plane.

After the first iteration, Z is equal to C, because zero squared is zero. Then, if Z is larger than one, when it is squared, it will leap
outwards, trying to break free. However, if C is pointing in the opposite direction, then when C is added in, it will pull Z back. If Z is
smaller than one, squaring Z makes it even smaller, but again, C is a wild card -- which way will it push Z -- in or out? There is no
shortcut way of finding out. The calculations have to be performed. But as we zoom in to the convoluted boundary of the Mandelbrot
set, we can see that Z and C have fought a mighty battle to see whether Z escapes or not. Constantly changing sides, teetering
near the brink of two, only to fall back towards zero. It is a battle where a change of a millionth of a unit can be the difference
between staying forever trapped or shooting off to infinity.

The Julia set is very similar to the Mandelbrot set in how it is calculated. The actual calculation loop is identical, but the initialization
is slightly different. For the Julia set, Z is initialized to the current point, and C is initialized to a seed value, another complex number
which is typically taken from the Mandelbrot set. For each different value of C, you get an entirely different Julia set. Because an
infinite number of values for C exists, there are an infinite number of Julia sets, each of which can be zoomed to any level of
magnification. That's why, a thousand years from now, you'll still be able to look around the Mandelbrot and Julia sets and know that
you're almost certainly exploring an area that no human being has ever seen before.

Click the Next button to continue.

{button < Back,JI FRACTALX.HLP>primary',"Fractal_Theory__The_Mandelbrot_Set')} {button Next
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Fractal Theory: The Mandelbrot Set

So that brings us to today. The Mandelbrot set is found in the complex plane. Each point on that plane represents a single complex
number of the form a + bi, where a is the distance left or right from the center line (negative when left, positive when right) and b is
the distance above or below the center line (negative when below, positive when above) and i is the root of -1.

With the understanding we now have of complex math, we can write out the Mandelbrot formula in a much more compact form. If
we had a computer language that understood complex numbers (some do), we could even write a program in the following form:

Z = (0 + 01)
C = (a + bi)
for (counter = 0; BABS(Z) <= 2.0 && counter < MaxIters; counter++)

7 =12 %2+ C;

That's it. The Mandelbrot set is really simple. All the lines of code at the beginning of this discussion were just teaching the computer
how to do the single line of math above. Multiply Z by itself. Add C. The answer is the new value for Z. Repeat until the absolute
value of Z is greater than two, or until our counter expires.

The only unexplained feature above is the ABS (z) part. ABS stands for absolute value. The absolute value of a complex number is
simply its distance from the center of the plane. If we think of the number as a point on the plane, we can measure the distance from
the center with a ruler. Or, that distance can be calculated (because it's simple to create a right-angle triangle on a plane) by
determining the square root of a squared plus b squared. If the answer is less than or equal to two, you are looking at a point in a
Mandelbrot set. If the answer is greater than two, the point is outside the set.

Click the Next button to continue.

{button < Back,JICFRACTALX.HLP>primary',"Fractal_Theory__Complex_Numbers")} {button Next
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Fractal eXtreme Help

Welcome to Fractal eXtreme(TM), version 1.0 for Windows NT® and Windows® 95.
. To view online help, click the Help Topics button.

Copyright © 1997 Cygnus Software. All rights reserved.
Fractal eXtreme is a trademark of Cygnus Software. Windows and Windows NT are either registered trademarks or trademarks of

Microsoft Corporation in the United States and/or other countries. All other registered trademarks and trademarks are the property of
their respective owners.



Fractal eXtreme License Agreement

Warranty

We've done our darndest to make sure that Fractal eXtreme works properly on all of the machines it is supposed to run on. If it
doesn't, please let us know.

If for some reason Fractal eXtreme fails to perform properly I'm afraid neither we, nor anyone else involved in creating and
distributing Fractal eXtreme, can be held responsible. Neither Cygnus Software nor anyone else involved in creating and distributing
Fractal eXtreme shall be liable for any damages caused by problems with Fractal eXtreme.

Restrictions
Use of this software without purchasing it is restricted to a 15-day trial period.

After this software is purchased you may install it on a maximum of two machines, for your sole use. Additional payment is required
to use the software on additional machines or by additional people.

You may have been charged a nominal fee by a shareware distributor to receive a copy of the shareware version of Fractal
eXtreme. This fee does not constitute payment for the licensed version and does not entitle you to use Fractal eXtreme beyond the
end of the 15-day trial period.

You may not reverse engineer, reverse compile, or disassemble any of the files in the distribution.

All of the files in the distribution are Copyright © 1997 Cygnus Software, except for those associated with SalesAgent, which are
Copyright © 1996 Release Software Corporation, and those from Microsoft, which are Copyright © 1981-1996 Microsoft
Corporation.

Cygnus Software retains ownership of all algorithms, routines, and implementations contained within Fractal eXtreme, except for
those owned by Release Software Corporation and Microsoft Corporation.

Any images or animations produced with Fractal eXtreme may be freely used with no restrictions or royalties.
You may freely distribute the Fractal eXtreme files, subject to the following conditions:

You may not charge for distributing the files, other than a nominal fee to cover media costs.
" You may not distribute any of the files for profit, or on a cover disk, or on a CD-ROM, without written permission from
Cygnus Software.

You must distribute a complete, unaltered set of files, with any added files being clearly distinguished from the Fractal
eXtreme files distributed by Cygnus Software.
You must take reasonable steps to ensure that the recipients see this agreement and agree to be bound by its terms and conditions.
Choice of Law
This License shall be governed and construed in accordance with the laws of the State of Wisconsin.

Acknowledgment

By using Fractal eXtreme you acknowledge that you have read this agreement, understood it, and agree to be bound by its terms
and conditions.



Fractal window

A fractal window is the document or project window in Fractal eXtreme. Fractal images appear in these windows.
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To exit Fractal eXtreme
. On the File menu, click Exit.

If you made changes to any open fractal windows, you are given the opportunity to save those changes before exiting the
program.




Click this to display an overview of this dialog box.



Click this to display an overview of this window.



To replace your Fractal eXtreme unlocking code
" Contact Release Software at 800-210-5517 or 415-833-0200 to obtain your unlocking code.

You can also call Release Software to purchase additional licenses of Fractal eXtreme.



To start Fractal eXtreme under Windows 95 or later or Windows NT 4.0 or later
1 Click the Start button on the taskbar.

2 Move the pointer above Programs, then to Cygnus Software, then click Fractal eXtreme.

To start Fractal eXtreme under Windows NT 3.51

1 Open the Cygnus Software program group.

2 Double-click the Fractal eXtreme icon.



To uninstall Fractal eXtreme under Windows 95 or later or Windows NT 4.0 or later

1 Click ll to open the Add/Remove Programs applet.
2 Select the Fractal eXtreme entry in the list.
3 Click Add/IRemove.

4 Follow the instructions for uninstalling the software.

To uninstall Fractal Extreme under Windows NT 3.51

1 Inthe Cygnus Software program group, double-click the Uninstall icon.

2 Follow the instructions for uninstalling the software.

Note
Any fractal files or movies saved in the program's folder or one of its subfolders will not be uninstalled.



Displays the name of the current fractal. The settings in this window apply to the current fractal.
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To display general help for Fractal eXtreme
1 On the File menu, click Help Topics.
The Contents tab of the Help Topics dialog box appears.
2 Select a help topic, then click Display. Alternatively, double-click a help topic.

The selected topic appears in a help window, such as what your viewing right now.



To display help for a window or dialog box
" Click the Help button in the window or dialog box.

The help topic for the current window or dialog box appears.



To view tips for using the program
1 On the Help menu, click Tip of the Day.
2 Browse the tips using the Next Tip button.

By default, these tips appear when you start the program. You can stop these tips from appearing on startup by deselecting the
Show Tips on StartUp check box in the Tip of the Day window.

Note
You can keep the Tip of the Day window open as you work in Fractal eXtreme.



Common features

Fractal eXtreme and Mand2000 share some basic features and capabilities.
. Exploration capabilities
" Drawing behaviour
- Fast calculations
. Location identification
" Virtually unlimited accuracy




Improved features

Fractal eXtreme improves on several Mand2000 features and capabilities.

. Calculation speed

. Movie creation

- Colour palette control
. Iteration control

. Location control

" Printing

- Preferences

. Online help



Missing features

Fractal eXtreme includes all the features and capabilities of Mand2000, with a few exceptions.
" Morph movies




New features

Fractal eXtreme improves upon Mand2000's features and capabilities in several ways.
. Multiple processor support

. Rotation

" Virtual screens

. Edge detection

. Favourite Spots

" Auto Explorer

. Plug-in architecture

. And much, much more




Calculation speed

Animated zooming is faster and fractal calculations are much faster.




Colour palette control

The colour palette is much more powerful. Also, mapping of colours has been improved.



Iteration control

The maximum number of iterations you can set has increased from 30,000 in Mand2000 to 100 million in Fractal eXtreme.



Location control

You have much finer control of the location of a fractal using the Set Location window.




Movie creation
Zoom movie creation has been greatly simplified. The resulting movies are now stored in a single file, and play back more

smoothly and cleanly.

Iteration movie creation has been made more powerful.



Online help

You have a more comprehensive online help system, including task-based instructions and reference material.



Preferences

You have more control over the actions associated with mouse clicks and dragging in fractal windows.



Printing

You have more control over the printing of fractals, including the ability to preview a fractal before it is printed.



Interior Colour dialog box

The Interior Colour dialog box is where you select the colour to use to fill the middle area of the fractal. By default, this area is black.

To open the Interior Colour dialog box: On the Colour Palette window's Colour menu, click Interior.
Set Interior Colour
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To learn more about the information in this dialog box, click it.
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Adjusts the red (R), green (G), and blue (B) component values. Each component can be a number between 0 (no intensity) and 255
(full intensity), giving you over 16 million colour choices.



Displays the colour defined by the R, G, and B sliders.



Iteration Control window

The lteration Control window is where you specify the maximum number of iterations (max. iterations) that Fractal eXtreme should
do per pixel. By adjusting the max. iterations value, you are deciding on what you feel is the appropriate compromise between
maximum image detail and reasonable calculation time. Or, you may decide that a particular fractal just looks better with a lower
max. iterations value, and therefore fewer jteration bands.

To open the Iteration Control window: On the Options menu, click Iteration Control.
Iteration Control - awesome._ fx [ x|

bd axirnurmn [kerations Per Pixel
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To learn more about the information in this window, click it.

Note

. Fractal eXtreme always tries to remember the iteration information it has calculated for each pixel. This minimizes the
need for recalculation if you change the number of iterations or the colour mapping. For instance, if you set the Maximum Iterations
Per Pixel value to 1000, wait for the picture to calculate, and then set Maximum Iterations Per Pixel to any number less than
1000, the picture will redraw immediately, with no calculation time. It does this because, if it knows what the picture should look like
at 1000 iterations, it also knows what it should look like at 500 or at 50. (This is especially useful for very efficient creation of iteration
movies). You can then set Maximum Iterations Per Pixel back to 1000 and it will again redraw without recalculation. However, if
you then set it higher than 1000, Fractal eXtreme will have to recalculate some pixels. All those pixels which are black must be
recalculated to see whether they are really in the Mandelbrot set or not.

Tips
" This window, like many in Fractal eXtreme, is sizable, to allow more precise control over the iteration slider.

. After an image has finished calculating, you can see an animation of the effect of changing max. iterations, in real time, by
using the lteration Movie Creator window.
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Specifies whether the number of iterations should change as you zoom in or out. By default (this check box is cleared), the number
of iterations changes as you zoom.



Adjusts the quality of a fractal by controlling the maximum number of iterations to calculate the current fractal's mathematical
equation before stopping.

Higher values produce more accurate images, but can take longer to render. Lower values don't take as long to render, but may not
be as detailed.



Lists several maximum iteration values. This affects the values you can adjust using the Maximum Iterations Per Pixel slider.

Use a smaller range for more precision, but with lower fractal quality. Use a larger range for less precision, but with higher fractal
quality.




Click this to restore the default values for the settings in this window. Note that the default value for max. iterations varies depending
on how far zoomed in you are.



Iteration Movie Creator window

The lteration Movie Creator window is where you set up the iteration movie settings and preview, in real time, how the movie would
appear.

To open the Iteration Movie Creator window: On the Render menu, click Make Iteration Movie.

Iteration Movie Creator - awesome._fx [ =]
Frame number; 43 JI
# of frames: 320 [teration count: 261
Speed: 1.000 I T
Acceleration: 5500 J
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To learn more about the information in this window, click it.
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Adjusts the detail near the interior of the fractal by mapping several iteration bands near the interior (where there are several in a
small area) to a single colour.

Lower acceleration values produce more frames, whereas higher acceleration values produce less frames.



Displays the current frame of the iteration movie being previewed. You can use the slider to browse frames of the iteration movie.



Displays the current iteration of the fractal being displayed.



Displays the number of frames that would be generated in the resulting iteration movie if the current settings were used.



Click this to pause or resume the real-time preview of the iteration movie.



Specifies whether the real-time preview of the iteration movie loops back and forth or simply loops.



Click this to specify the name of the iteration movie on disk and to start the rendering process.



Click this to restore the default values for the settings in this window.



Click this to adjust the file format settings for the iteration movie.



Adjusts how many iterations use a particular colour index in the colour palette. The default setting (1.000) uses one colour per
iteration.

Lower speeds produce more frames, whereas higher speeds produce less frames.



Julia Theory

Whereas the Mandelbrot set and other non-Julia fractal sets are defined entirely by the their coordinates (which specify its location
in the complex plane), the Julia set needs an additional parameter -- a seed point in the complex plane.

The location of the seed point turns out to be very important in determining the Julia set's appearance. In fact, the Mandelbrot set
was first discovered when Benoit Mandelbrot was plotting how different seed locations affected the Julia set.

If the seed location is in the Mandelbrot set (the black area is the only part which is the Mandelbrot set -- the beautiful coloured
bands around it are merely very attractive side effects), the Julia will seem "connected.” If the Julia seed is taken from outside the
Mandelbrot set, the Julia is "dust" or Cantor Dust, to be more precise.

These two different types of Julia sets -- connected and dust -- have technical definitions that involve a lot of mathematical terms
used in their most precise and obscure ways. However, the basic idea is that if a Julia set is connected, it looks connected, if it
doesn't, it's dust. If the center point of the Julia set is black, then it's connected, if not, it's not. The Mandelbrot set is the set of all
seeds for connected Julias.

The relation between the Mandelbrot set and the Julia seed location doesn't end with the rule stated above. If you put the Julia seed
in the medium-sized bulb at the top of the very largest bulb, you will notice that the Julia set created is made up of black areas that
always meet together in threes. As you move around the bulb, the exact shape changes, but that rule remains the same. If you
move down and to the right, to the next largest bulb in that area, you should see the Julia set change so that the black areas now
meet in fours. At the next largest bulb, they meet in fives, and so on. Now go back to those bulbs in the Mandelbrot set and zoom
and scroll with the mouse towards the main arms coming out of the ends of each of those bulbs. You will notice that the arms meet
three at a time, then four at a time, then five at a time...

Chaos?



To control the frame to view in a zoom movie

In the FX Movie player, use the Number of Zooms slider or the transport controls (First Frame, Play Backwards, Stop,
Play Forward, and Last Frame) to control the amount of zoom.

To control the speed of playback
Adjust the Zooms Per Second slider.

Tip

For zoom movies with a few number of frames, use a low value for smoother playback. For zoom movies with a large
number of frames, use a higher value, especially if your computer and display hardware can handle them.



To explore from a location in a zoom movie

1 In the FX Movie Player, use the Number of Zooms slider to select a position in the zoom movie from where to explore.

2 Click Explore.

A new fractal window appears, displaying the current zoom movie's zoom level.



To set up a zoom movie

1 In a fractal window, zoom in and move to the location that you want as the last frame of the zoom movie.

2 On the Render menu, click Make Zoom Movie.
3 Specify a location and name for the zoom movie on disk, then click Save.
Fractal eXtreme saves zoom movies with a .fxz file name extension.

The movie begins rendering to disk. After all frames have been rendered, the FX Movie Player displays the rendered zoom
movie. Use the controls in the FX Movie Player to view the zoom movie.

Tip
" Typically, you would render animations at a larger size (pixel dimension) to produce better results. However, for zoom
movies, it's better to render at a smaller size, then view them at a larger size in the FX Movie Player.
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To set up an iteration movie

1 In a fractal window, zoom in and move to the location that you want to appear in the iteration movie.

2 Adjust the detail of the fractal to the desired level. Do this by modifying the Maximum Iterations Per Pixel value in the
Iteration Control window.
The more level of detail in the fractal, the more frames will be generated. However, you can control other factors to affect the
frame count.

2 On the Render menu, click Make lteration Movie.
The lteration Movie Creator window appears, automatically previewing what iteration movie.
3 Adjust the values in the Iteration Movie Creator window to produce the desired animated effect.

4 To adjust the Video for Windows (AVI) settings, click the Setup button, specify the video compression settings, then click OK.

5 When you are ready to save the iteration movie as an AVl file, click Render, specify a location and name for the iteration
movie on disk, then click Save.

The movie begins rendering to disk. After all frames have been rendered, the Windows Media Player displays the rendered AVI
file of the iteration movie. Use the controls in the Media Player to view the AVI file.
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To view a zoom movie from Fractal eXtreme
On the Render menu, click Play Zoom Movie.

The FX Movie Player appears. If a zoom movie was previously rendered in the current session, it automatically appears.
Otherwise, manually open a zoom movie, as described next.

To view a zoom movie from the FX Movie Player

1 On the FX Movie Player's File menu, click Open.

2 Select a previously saved zoom movie, then click Open.

Fractal eXtreme's zoom movie files use a .fxz file name extension.
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To view an iteration movie from Fractal eXtreme
On the Render menu, click Play Iteration Movie.

The Windows Media Player appears. If an iteration movie was previously rendered in the current session, it automatically
appears. Otherwise, manually open an iteration movie (saved as an AVI file), as described next.

To view an iteration movie outside of FX Movie Player

1 On the Windows Media Player's File menu, click Open.

2 Select a previously saved iteration movie (saved in AVI format), then click Open.
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Colour Palette Window Menu

The Colour Palette window's menu bar contains commands in four menus: File, Edit, Presets, and Colour.

File
Open... Displays the Open Palette dialog box, from which you can select CTRL+O
a previously saved colour palette to open. You can also load
palettes from saved fractal images.
Save Stores the current palette to disk using its current file name. CTRL+S
Save As... Displays the Save Palette dialog box, from which you can save
the current palette to disk using a different file name.
Reset Restores the current palette to the default palette. CTRL+R
Close Closes the Colour Palette window.
Edit
Undo action Undoes the last change to the palette. This can even be used to CTRL+Z
undo changes to the palette that occur while the Colour Palette
window is not open, such as palette changes caused by opening
a fractal from disk.
Redo action Redoes the last action undone. CTRL+SHIF
T+z
Cut Cuts the currently selected control points to the palette window CTRL+X
clipboard.
Copy Copies the currently selected control points to the palette CTRL+C
window clipboard.
Paste Pastes the contents of the palette window clipboard. If you need CTRL+V
more precise control of pasting, such as specifying a particular
location to paste to, you can use the curve graph's pop-up
menus.
Delete Delete's the currently selected control points. DEL
Presets
List of colour palettes Lists ten common or interesting colour palettes CTRL+1 to
CTRL+0

Colour

Interior... Displays the Interior Colour dialog box, from which you can
select the colour to use for the interior of the fractal; by default,
the interior colour is black

Edge Fill... Displays the Edge Fill Colour dialog box, from which you can

Show Stripes

select the colour to use between edges of a fractal that is being
viewed with the Edges option selected; by default, the edge fill
colour is black

Toggles whether the palette window should display two different
colour sets, intermingled



Edit Even

Edit Odd

When displaying two intermingled colour sets, selects the even
colours for editing

When displaying two intermingled colour sets, selects the odd
colours for editing

Fractal Window Menu

A fractal window's menu bar contains commands in eight menus: File, Edit, Location, View, Options, Render, Window, and Help.

If no fractal windows are open, a subset of these menus and commands are available. These menus and commands are indicated

by a asterisk (*).

File*

New...*

Duplicate

Duplicate As Not Julia/
Duplicate As Julia

Open...

Close

Save

Save As...

Save Bitmap Only...

Save As Wallpaper

Print...

Print Preview

Print Setup...*

Preferences*

Displays the New Fractal dialog box, from which you can select
a new fractal to explore.

Opens a new fractal window with the same type and location as
the current fractal window. This makes it easy to continue
exploring an interesting region without losing your current
picture.

Performs the same operation as Duplicate, but toggles the type
of fractal (from the non-Julia type to the Julia type or vice versa).
This makes it easy to see, side by side, the differences and
similarities between the related families of fractals. Duplicate as
Julia takes the center of the non-Julia window as the initial value
of the Julia seed.

Displays the Open Fractal dialog box, from which you can select
a previously saved fractal to open. The selected fractal's colour
palette may be loaded in as the new global palette, depending
on your preferences settings.

Closes the current fractal window.

Stores the current fractal to disk using its current file name. The
fractal coordinate information is stored inside a BMP file, which
other programs should be able to load as an image.

Displays the Save Fractal dialog box, from which you can save
the current fractal to disk using a different file name.

Displays the Save Bitmap Only dialog box, from which you can
save the current fractal as an uncompressed BMP file usable in
other programs. This option is supplied because some programs

do not properly read the BMP files saved by the Save command.

Note that files saved with this command cannot be opened in
Fractal eXtreme.

Saves a copy of the current fractal to the windows folder as
FXWallpaper.bmp and sets the current wallpaper settings to use
this image.

Displays the Print dialog box, from which you can control how to
print the current fractal.

Displays a preview of how the current fractal would appear on
paper using the current print settings.

Displays the Print Setup dialog box, from which you can specify
how the current fractal appears on the printed page.

Displays the Preferences window, from which you can adjust

CTRL+N

CTRL+D

CTRL+SHIF

T+D

CTRL+O

CTRL+S

CTRL+P



n List of recent projects*

global settings that affect the program and all open fractal
windows.

Displays a list of the eight most recent fractals that you worked
on.

Exit* Quits the program.

Edit

Undo action Restores the current fractal window to the state it was before the CTRL+Z
last action you performed. The undo has multiple levels.

Redo action Performs the last undone operation in the current fractal window. CTRL+SHIF

T+z

Copy Copies the current fractal to the Windows Clipboard for use in CTRL+C
other programs that can paste bitmap images.

Location*

Zoom In Increases the magnification of the current fractal relative to the CTRL+=
center of its window, increasing the fractal's zoom level by 1.00
and its magnification by a factor of 2. To zoom in on a particular
area of the current fractal, double click with the left mouse
button.

Zoom Qut Decreases the magnification of the current fractal relative to the CTRL+-
center of its window, decreasing the fractal's zoom level by 1.00
and its magnification by a factor of 2. You can also zoom out by
double clicking with the right mouse button.

Reset Zoom Restores the zoom level of the current fractal to 0.00, CTRL+R
magnification 1.00.

View Location Opens a new fractal window with a duplicate of the current CTRL+SHIF

Show Location

Current

All

None

Set Location...

Set Julia Seed...

Favourite Spots...*

Auto Explorer...

fractal at no magnification (zoom of 0.00), and showing the T+L
current fractal's location as a red box. This is a convenient way

to remind yourself of your location in the infinite fractal

landscape.

Contains a submenu of options that control which of the other
open fractals' locations to indicate in the current fractal window.

Toggles the displaying of the locations of other fractal windows in CTRL+L

the current window.

Graphically displays the locations of fractal windows in all
windows.

Turns off the graphical displaying of fractal locations in all
window.

Displays the Set Location window, from which you can view and
edit the current fractal's location, zoom amount, and rotation.

Displays the Set Julia Seed window, from which you can view
and edit the current Julia fractal's seed value.

Displays the Favourite Spots window, from which you can
graphically select a fractal to open.

CTRL+F

Displays the Auto Explorer window, from which you can control
the automatic exploration of interesting spots in the current



View*

fractal (as selected by the program).

Toolbar*

Status Bar*

Status Window

Shows or hides the row of buttons along the top of the program
window.

Shows or hides the area along the bottom of the program
window.

Displays the Status window, from which you can view detailed CTRL+A
information about the current fractal and the location under the
pointer.

Edges Shows or hides the edges between iteration values. CTRL+E
Options
Iteration Control Displays the Iteration Control window, from which you can CTRL+

Colour Palette

Colour Mapping

Advanced Settings

balance the competing needs of fractal level of detail and
rendering time by adjusting the maximum iterations per pixel.

Displays the Colour Palette window, from which you can adjust CTRL+T
the global colour palette used to display your fractals..

Displays the Colour Mapping window, from which you can adjust CTRL+M
how iteration bands are mapped onto colours.

Displays the Advanced Settings dialog box, from which you can
control various advanced settings.

Fractal Size Displays the Fractal Size dialog box, from which you can change
the dimensions of the current fractal window.
Plug-In Setup... Displays the Plug-In Setup dialog box, from which you can
adjust parameters specific to the current fractal plug-in, if
applicable.
Plug-In About Displays the Plug-In About dialog box, from which you can
display miscellaneous information about the current fractal plug-
in, such as its version number and copyright notice.
Render*
Pause Suspends and resumes calculation of the current fractal. This is P

Make Zoom Movie...

Play Zoom Movie*

Make Iteration Movie...

useful if you are running another program which needs more
CPU power, or if you have multiple fractals calculating in Fractal
eXtreme and want to give one of them all of the processor time.
Pausing a calculation can also be useful if you are zoomed in so
far that the fractal calculations are making the user interface
unresponsive.

Displays the Save Zoom Movie As dialog box, from which you
can specify the location and hame of the zoom movie on disk.

Starts the FX Movie Player and, if a zoom movie has been
rendered, opens it.

Displays the Iteration Movie Creator window, from which you can
view and control then animated appearance and disappearance
of iteration bands, and create an AVl movie of the animation.




Play lteration Movie*

Window

Starts the default Windows movie player for AVI files and plays
the most recently rendered iteration movie.

Cascade

Tile

Arrange Icons

n List of open fractals

Help*

Staggers the open fractal windows so that you can access their
title bars

Arranges the open fractal windows so that they don't overlap
each other

Positions the minimized fractal windows so that you can easily
access them

Lists the titles of all open fractal windows

Help Topics*

Tip of the Day*

About Fractal eXtreme*

Purchase Fractal
eXtreme*

Morph movies

Displays the Contents tab of the Help Topics dialog box, from
which you can display online help for the program

Displays the Tip of the Day window, from which you can view
tips on using the program

Displays the program's About dialog box, from which you can
see the program's version number and copyright notice

Displays the instructions for purchasing the Fractal eXtreme
program

Morph movies are not supported in Fractal eXtreme.
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Scripting

The lack of ARexx support in Fractal eXtreme means that you cannot extend its functionality in the ways you could with
Mand2000.



To adjust the zoom speed
1 On the File menu, click Preferences.
2 Click the Miscellaneous tab.

3 Adjust the Zoom speed value.



To automatically explore interesting locations
1 On the Location menu, click Auto Explorer.

2 Adjust the Zoom increment value to set the number of zooms to increment in each step in the exploration.
3 Click the Start button.

The program continually zooms in on interesting locations, in a somewhat intelligent (not random) way so that you don't zoom
in on uninteresting regions, like the middle of the fractal which, by default, is black. If you find yourself interested in pitch dark
places, this feature may not be for you.

4 When you want to stop exploring, click the Stop button.

Note

If you leave the Auto Explorer running, you might forget that the program is still exploring, especially if it's zoomed far into
the fractal where rendering can take longer.



To set the Julia seed location
1 With a Julia window active, on the Location menu, click Set Julia Seed.
2 Specify the horizontal coordinate of the Julia seed in the Julia X text box, then press the TAB key.

3 Specify the vertical coordinate of the Julia seed in the Julia Y text box, then press the TAB key.

To interactively explore different Julia seed locations
. Hold down the ALT key as you click or drag in a non-Julia window. This is known as dragging the Julia seed, or Julia seed
dragging.

If you have multiple Julia windows open, the last active Julia window will be updated.



To display the location of Julia seeds

1 With a Julia window active, on the Location menu, click Set Julia Seed.

2 Select the Display Julia seeds check box.

All the currently defined Julia seeds appear as red crosshairs in all the open non-Julia windows.



To identify the current location
On the Location menu, click View Location.

A new fractal window appears at no magnification (0.00 zooms), with the locations of all other open fractals identified by a red

rectangle. As you activate other fractal windows, they are highlighted in this zoomed-out fractal window by a brighter red
rectangle.

To identify the location other other fractals in a fractal window
On the Location menu, click Set Location, then click one of the following:
Current -- This displays the location of all other fractals in the current window.

All -- This displays the location of all other fractals in all open windows. Choosing this option is equivalent to selecting the
Current option in all windows.

" None -- This hides the location indicators in all windows. Choosing this option is equivalent to deselecting the Current
option in all windows.



To import Fractint data

1 Open a fractal window. Either create a new fractal or open an existing fractal.
On the Location menu, click Set Location.

Open the FractInt(TM) .par file in a text editor, such as Notepad.

A W N

Search for the line starting with "corners=".

For example:
corners=-1.86057396488/-1.86057395514/-0.00000093796/-0.00000093078/

5 Copy the characters between "corners="and the last slash character on the line to the Clipboard.
In the previous example, you would copy:
-1.86057396488/-1.86057395514/-0.00000093796/-0.00000093078

6 In Fractal eXtreme's Set Location window, delete the contents of the Real text box.
7 With the cursor in the Real text box, press cTRL+V to paste the Clipboard's contents.

8 Press 1AB to update the Real, Imaginary, and Zoom text boxes with the information copied from the Fractint file.

Note
" In some Fractint files, the center location (that is, two values instead of four values) is provided. With these files, enter the
first number in the Real text box and the second number in the Imaginary text box.

"__Related Topics



To keep the iteration count the same while zooming

1 On the Options menu, click Iteration Control.

2 Select the Lock iteration count check box.



To move to a specific location

1 On the Location menu, click Set Location.

2 Enter the real and imaginary values, zoom amount, and rotation in the appropriate text boxes.
Either press TAB or click in another text box to finish changing a value in a text box.

Tip
For Fractint users, you can copy location data from a .par file into Fractal eXtreme. For details, see Importing Fractint

o_.
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To pan (scroll) around
. Drag in a fractal window.

To scroll horizontally or vertically only
1 Click anywhere in a fractal window and hold down the mouse button.

2 Hold down the SHIFT key as you drag either horizontally or vertically.



To rotate a fractal

Hold down the cTRL key as you drag in a fractal window. To rotate in 45 degree increments, hold down the SHIFT and CTRL
keys as you drag.

Note

If you have modified the mouse button behaviour assigned to the rotate operation in the Miscellaneous page of the
Preferences window, use that method instead.




To undo changes
. On the Edit menu, click Undo action.

To redo undone changes
" On the Edit menu, click Redo action.



To use fractal coordinates from other sources

1 Open a fractal window. Either create a new fractal or open an existing fractal.
On the Location menu, click Set Location.

Type the real-number part of the coordinate in the Real text box, then press TAB.

Type the imaginary-number part of the coordinate in the Imaginary text box, then press TAB.

a b~ wWwN

Adjust the Zooms level in this window or use the standard zoom controls until the magnification or picture looks right.

You have to use the zoom controls in this window, rather than zooming in by double-clicking in the fractal window, because

double-click zooming loses the current center (unless you have zooming operations always using the center of a fractal
window).

Note

If you have the coordinates for the edges, rather than the center, of a fractal, the Set Location window will help you out
here as well. Simply type the left- and right-edge coordinates into the Real text box, separated by a ":" (colon), "|" (vertical bar), or a
"I" (forward slash) character. Fractal eXtreme will use the average of the two numbers for the center, and will calculate an
appropriate zoom level based on their difference. Do the same for the imaginary coordinates into the Imaginary text box.

"_Related Topics



To zoom in

Double-click with the left (primary) mouse button at the location to zoom in on. Alternatively, move the mouse pointer
above this location and then press I.

To zoom out
Double-click with the right (secondary) mouse button at the location to zoom out from.

Notes
. If you have modified the mouse button behaviour assigned to the zoom operations in the Miscellaneous page of the
Preferences window, use that method instead.

" If the animated zoom is too slow or too fast, adjust the Zoom speed setting in the Miscellaneous page of the Preferences

window.



New Fractal dialog box

The New Fractal dialog box is where you select a fractal to view. The list of available fractal types (equations) will vary depending on
how many fractal plug-ins you have installed. Although all fractal images have their own unigue charm, we recommend starting out
by exploring the classic Mandelbrot set.

To open the New Fractal dialog box: On the File menu, click New.

+ New Fractal

Auto Guadratic a| I Julia
Hidden Mandelbrat

‘M andelbrat

b andelbrot Cubed
t andelbrat Faurth
b andelbrat Fifth

b andelbrot Sixth

M andelbrat Seventh
b andelbrat Eighth
t andelbrat Minth

Cancel
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Help

The Mandelbrot zet iz probably the mozt Famous of all fractalz. Itz -
diztinctive sping pear hape is what many people think of when

they think. of fractals. It iz an extremely complex and beautiful
fractal, yet it iz one of the zimplest to caloulate. [tz Farmula,
exprezzed in complex numberz, iz zimply '2 =2 * 2 + T

“i'et this gimple formula, applied iteratively to evern pikel in the
image, produces an image =0 comples and detailed that the

L

|Se|eu:t a fractal to explore, or just prezs EMTER.

To learn more about a control in this dialog box, click it.
The selected fractal appears in a new fractal window. If you already have a fractal window open, the fractal type settings in the New
Fractal dialog box default to the type of the active window. The number of simultaneous fractal windows you can open is limited only

by available memory.

Tip

. This dialog box, like many in Fractal eXtreme, can be resized to display more of the description or more fractal types in
the list box.



Click this to use a Julia version of the selected fractal.



Displays a short description of the selected fractal type (plug-in).




Lists the available types of fractals that you can create.




Displays a preview of the selected fractal type.



And much, much more

Fractal eXtreme has so much that is new (such as easily displaying calculation paths) or improved to list here. Check out the rest
of the online help or just explore on your own.



Auto Explorer

View a hands-free (automatic) exploration of a fractal using the new Auto Explorer. Cool eye candy...without the sticky fingers!




Edge detection

Display the edges between iterations for a cool variation on a fractal. You can even create movies while viewing edges.



Favourite Spots

Graphically browse your favourite fractals to select the one to open using the new Favourite Spots window.




Multiple processor support

Fractal eXtreme takes advantage of the power of multiple-processor machines so fractals render faster.




Plug-in architecture

Fractal eXtreme can support new fractal types through its plug-in architecture.

Developers wishing to create fractal plug-in should contact Cygnus Software for the Fractal eXtreme Plug-In Developer Kit.



Rotation

Interactively rotate fractals to view and print fractals in the way you want or need.




Virtual screens

Create multiple-million virtual-screen fractals for high quality printouts.



Plug-In About dialog box
The Plug-In About dialog box displays information about and a description of the plug-in that created the current fractal. The

description that appears in this dialog box is the same one that would appear in the New Fractal dialog box.

To open the Plug-In About dialog box: On the Options menu, click Plug-ln About.

i About AutoQuad Plugin Ed
l Fractal extreme Auto Luadratic Plugin - Yersion 1.0

Copyright = 1957 Cygnuz Software

&ll rights rezerved

Additional Infarmation:
’7 Build D ate: Jan 14 1337

& fractal generatar inspired by Julien C. Spratt and Clifford =
& Pickaover.

To generate a new and unigue fractal, on the Options

men, click Plug-ln Setup, then click the B andomize
button,

k|

To learn more about the information in this dialog box, click it.



Displays additional information about the current fractal plug-in, such as the date it was created.



Displays the copyright notice for the current fractal plug-in.



Displays a description of the current plug-in. This is the same information that is displayed in the New Fractal dialog box.



Displays the name and version number of the current fractal plug-in.



Plug-In Setup dialog box

The Plug-In Setup dialog box displays the settings that you can adjust for the plug-in that created the current fractal. Not all fractal
plug-ins have adjustable settings.

To open the Plug-In Setup dialog box: On the Options menu, click Plug-In Setup.
Auto Quadratic Setup |

Parameters: IEHF'LWTDJHE.-‘-‘«F'

Bandamize | Ahot | Cancel |

This is an example of a Plug-In Setup dialog box.



Preferences window (Left Button)

The Preferences window is where you adjust the global settings for the program and all fractal windows. The Left Button page
contains the settings to control how the left (primary) mouse button works in the program.

To open the Preferences window's Left Button page: On the File menu, click Preferences, then click the Left Button tab.

Preferences

Mizcellaneous  Left Button I Right Buttan I
Clicl: I Scroll Fractal j Diouble-click:
Shift-click: IScale Fractal j Izmm in two j
Chrl-click: IFh:utate Fractal =] Shift-double-click:
Alt-click: ISet JuliaSeed ) Iz':":'m infour ]
Chl+Shift-click: | Show Calc Path 7|
Al+Shift-click: — Nathing =]
Ctrbelt-click: | Nathing =]
Chil+Shift+lt-click: |Noting =

Beset | Help

To learn more about a control in this window, click it.



Lists the actions that you can assign when you ALT+sHIFT-click with the left mouse button in a fractal window.



Lists the actions that you can assign when you ALT-click with the left mouse button in a fractal window.



Lists the actions that you can assign when you click with the left mouse button in a fractal window.



Lists the actions that you can assign when you cTRL+ALT-click with the left mouse button in a fractal window.



Lists the actions that you can assign when you CTRL+SHIFT-click with the left mouse button in a fractal window.



Lists the actions that you can assign when you CTRL+SHIFT+ALT-click with the left mouse button in a fractal window.



Lists the actions that you can assign when you cTRL-click with the left mouse button in a fractal window.



Lists the actions that you can assign when you double-click with the left mouse button in a fractal window.



Click this to restore the current page's settings to their defaults.



Lists the actions that you can assign when you sHIFT-click with the left mouse button in a fractal window.



Lists the actions that you can assign when you sHIFT-double-click with the left mouse button in a fractal window.



Preferences window (Miscellaneous)

The Preferences window is where you adjust the global settings for the program and all fractal windows. The Miscellaneous page
contains all the general settings not dealing with the use of mouse buttons.

To open the Preferences window's Miscellaneous page: On the File menu, click Preferences, then click the Miscellaneous tab.

Preferences
Mizcellaneous I Left Button I Right Buttar I
Julia Seed Dragaging — Palette Auto-Loading: —
Max block size: 282 :ll & Always
- ' Querny
Frame rate: b fpz —  Mever
[T Advanced — 2oom Destination
¥ Customn zoom code " Mouze position
V' Show startup screen % Center of window
Zoom speed:
IMedium j
Reszet Help

To learn more about a control in this window, click it.



Specifies whether to use the Advanced or Simple modes of Fractal eXtreme.




Specifies whether zoom operations use Fractal eXtreme's custom bitmap scaling routines or the system's routines. On some
computer systems, the custom routines will be faster, whereas on others, the system scaling routines will be faster.

To determine what is best for your computer system, try double-clicking and sHIFT-double-clicking to zoom in and out of a fractal in
both settings. Pick the setting that seems smoother and faster to you.



Specifies how quickly (in frames per second) to update a Julia fractal window while dragging the Julia seed around.

Lower values update the window less often, which may produce better results on slower machines or large windows. Higher values
update the window more often, but require a faster machine or a smaller window to produce a smooth, animated look. Otherwise,
only a tiny area (sometimes no area at all) of the window would be updated at a very fast speed.

By default, the Julia seed is updated no more than five times a second, so that each Julia set has at least one-fifth of a second to
calculate. If you have an extremely fast machine, or a small Julia window, you may want to increase the frame rate, for better
animation quality.



These controls affect the responsiveness (update speed) of Julia windows when dragging the Julia seed location.



Specifies the maximum block size of pixels to draw when dragging the Julia seed. When drawing fractals, Fractal eXtreme usually
starts by drawing 8x8 blocks, then 4x4, then 2x2, and finally 1x1 blocks. Because Julia sets are frequently quite simple, and draw
quite quickly, the blocky mode of drawing can be very distracting. Fractal eXtreme may end up drawing 8x8, 4x4, 2x2, and then 1x1
blocks each time you move the mouse, making it hard to see the changes. The default setting of 2x2 blocks means that, when
dragging Julia seeds, the block size doesn't go above 2x2, thus minimizing the block size flicker.

Lower block sizes are appropriate for fast machines or small Julia windows, where you can get higher quality animations when
dragging the Julia seed. However, this may mean that the entire window doesn't have time to get calculated on each frame.
Conversely, higher block sizes are appropriate for slow machines or large Julia windows.




This setting controls whether the current colour palette should be modified when a new fractal (that has a different colour palette) is
created or opened.

" Always -- Use the palette of the opened fractal. All open fractals update using this new palette.

" Query -- Ask you whether to use the palette of the opened fractal or use the existing palette.

. Never -- Use the existing palette for the opened fractal.




Click this to restore the current page's settings to their defaults.



Specifies whether to display the startup screen when the program is started.
This option is selected by default.



Controls the location of a fractal window to zoom into or away from when clicking in it. You can either zoom relative to the position
where you clicked or to the center of the fractal window regardless of where you clicked.



Lists the available speed settings that you can use when zooming in or out of a fractal.



Preferences window (Right Button)

The Preferences window is where you adjust the global settings for the program and all fractal windows. The Right Button page
contains the settings to control how the right (secondary) mouse button works in the program.

To open the Preferences window's Right Button page: On the File menu, click Preferences, then click the Right Button tab.

Preferences
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To learn more about a control in this window, click it.



Lists the actions that you can assign when you ALT+sHIFT+click with the right mouse button in a fractal window.



Lists the actions that you can assign when you ALT-click with the right mouse button in a fractal window.



Lists the actions that you can assign when you click with the right mouse button in a fractal window.



Lists the actions that you can assign when you cTRL+ALT+click with the right mouse button in a fractal window.



Lists the actions that you can assign when you CTRL+SHIFT+ALT-click with the right mouse button in a fractal window.



Lists the actions that you can assign when you CTRL+SHIFT-click with the right mouse button in a fractal window.



Lists the actions that you can assign when you cTRL-click with the right mouse button in a fractal window.



Lists the actions that you can assign when you double-click with the right mouse button in a fractal window.



Click this to restore the current page's settings to their defaults.



Lists the actions that you can assign when you sHIFT-click with the right mouse button in a fractal window.



Lists the actions that you can assign when you sHIFT-double-click with the right mouse button in a fractal window.



Print Setup dialog box

The Print Setup dialog box is where you specify how fractals should appear on the printed page.

To open the Print Setup dialog box: On the File menu, click Print Setup.
Print 5 etup |

Magrification: |100.0% j Eririter... |

¥ Center [ Fit page

k. I Canicel | Help |

To learn more about a control in this dialog box, click it.




Specifies whether the fractal appears centered on or in the upper-left corner of the printed page.




Specifies whether the fractal will be scaled to fill as much of the printed page, without changing its aspect.

Note: If you want to print a wide fractal in landscape mode, you must first change the orientation of the paper in the printer's Print
Setup dialog box; click the Printer button in the Print Setup dialog box to open this dialog box. The Fit page check box doesn't
automatically rotate a fractal to make the best use of the paper size.



Provides a space for you to type the percentage by which to scale the fractal when printed. You can also click the scroll arrows to
select a new setting.



Click this to display the printer's Print Setup dialog box, from which you can change the printer to use and the paper and orientation
settings.



To preview a fractal before you print it
1 On the File menu, click Print Preview.

2 To zoom in, click the mouse button with the magnifying glass pointer above the area to magnify. Alternatively, click the Zoom
In button.

There are three levels of magnification in the print preview.
3 To zoom out, click the Zoom Out button.

4 Do either of the following when you are done previewing the fractal:
To print the fractal, click the Print button.
To stop previewing, click the Close button.



To print a fractal
1 On the File menu, click Print.

2 Adjust the Printer, Print range, and Copies settings as necessary.
3 Click OK to begin printing.



To set up the printer

1 On the File menu, click Print Setup.
2 Adjust the settings in the dialog box.
3 Click OK.

These settings will be used the next time you print.



To purchase Fractal eXtreme

1
2

On the Help menu, click Purchase Fractal eXtreme.

Follow the instructions to purchase a copy.
You will be able to purchase the software by credit card or check. The purchase price is $34.95.
After your order has been processed, an unlocking code will be sent to you.

3 On the User Registration page, enter information about yourself. When you are done, click Next.

On the Purchase Item(s) page, add the Fractal eXtreme product to your shopping list. When you are done, click Next.

5 On the Select Payment Method page, select the payment method from the Payment Type section. If you selected to pay by

credit card, fill out the Credit Card Information section. When you are done, click Next.

Credit card payments can be made by phone, direct connection via modem, or through a secure transaction via the Internet.
Check payments can be mailed or faxed.

On the Comments and Feedback page, enter any comments you want send to Cygnus Software about Fractal eXtreme. This
is optional. When you are done, click Next.

On the Order Summary page, confirm the information about your order. If you need to change anything about the order, click
Back. Otherwise, click Next.

On the Select Communications Method page, select the method by which you intend to pay for your order. If you selected to
pay by check, your only option is to mail or fax your order form. When you are done, click Next.

Depending on your selected payment method, you will be connected to Release Software's order placement center. After your
payment has been processed, you will receive an unlocking code. Follow the instructions for entering the unlocking code.

After you unlock the software, you will be automatically registered as a Fractal eXtreme user.

Thank you for supporting Cygnus Software and Fractal eXtreme. We appreciate your business.



Set Julia Seed window

Whereas the Mandelbrot set and other non-Julia fractal sets are defined entirely by the their coordinates (which specify its location
in the complex plane), the Julia set needs an additional parameter, a seed point (known as a Julia seed) in the complex plane. The
Set Julia Seed window lets you easily set that third defining point.

Use the Set Julia Seed window to display and adjust the location of the Julia seed for the current Julia window. It also gives you a
way to make all Julia seeds currently in use visible on any non-Julia windows that are displaying that part of the complex plane.

To open the Set Julia Seed window: On the Location menu, click Set Julia Seed. This command is available only for Julia
fractals.

Set Juha Seed - awesome_fx x|

¥ Display Julia Seeds

Julia = |-1 .996.375,240.560,720.4

Julia 't |+EI_DEIEI,DDD,DDD,4EE,?'I 7.5

Cloze I Help

To learn more about the information in this window, click it.

Fractal exploration programs rarely specify Julia seed information numerically. Instead, they use the related non-Julia set, the
Mandelbrot set for instance, as a map of all Julia sets. Simply ALT-click in a non-Julia fractal window, preferably of the same type, to
set the Julia seed. If you ALT-drag, the Julia set will animate, as fast as your computer can manage. For details on how to optimize

the speed and quality of this animation, see the Miscellaneous page of the Preferences window.

"_ Related Topics



Specifies whether to display the Julia seed locations (as red "+" symbols) in the fractal windows.



Provides a space for you to type real-number (horizontal axis) component of the Julia seed.



Provides a space for you to type the imaginary-number (vertical axis) component of the Julia seed.



Set Location window

The Set Location window is where you view and can adjust the location, zoom level, and rotation of the current fractal.

To open the Set Location window: On the Location menu, click Set Location.
Set Location - awesome_fx x|
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Imaginary: |+EI.EIEIEI,EIEIEI,EIEIEI,42I3,?

TSR
£00mE —
kM agnification: 1.073e+011 = 1079 thauzand millian
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To learn more about the information in this window, click it.
Tip

This window, like many in Fractal eXtreme, is sizable, to allow displaying of extremely precise location, magnification and
height information.

"_Related Topics




Displays the current fractal's vertical size in fractal coordinates. This is simply the imaginary coordinate of the bottom of the fractal
window subtracted from the imaginary coordinate of the top of the fractal window. For an unzoomed fractal, this is approximately
four. For a zoomed-in fractal, it is the initial height (four) divided by the magnification. This value gives you an idea of how small an

area of the original image you are looking at.




Displays and provides a space for you to type the imaginary-number portion (vertical value) of the location of the center of the
current fractal. This value appears with the appropriate number of digits, based on how far in you are zoomed. As you zoom in and
out, the number of digits displayed changes.




Displays the current fractal's magnification amount, relative to the initial image. This number is based on the number of zooms.
Neutral or no magnification is 1.000. The magnification is displayed both in words and in scientific notation.




Displays and provides a space for you to type the real-number portion (horizontal value) of the location of the center of the current
fractal. This value appears with the appropriate number of digits, based on how far in you are zoomed. As you zoom in and out, the
number of digits displayed changes.



Displays and provides a space for you to type the angle of rotation of the current fractal. Positive values rotate the fractal in a
counter-clockwise direction.




Displays and provides a space for you to type the zoom level of the current fractal. You can also click the scroll arrows to select a
new setting.

If you zoom out with this control, you can zoom back in with this control and end up at precisely the same location. If you zoom in or
out by double-clicking the image, your precise location is gradually lost, and you won't end up at precisely the same location.



Displays the average number of iterations performed per pixel. This is simply the total number of iterations required for the entire
image, divided by the number of pixels in the image.



Displays the type of calculation routines being used.

In most cases, this will appear as "FPU calcs," indicating that your computer's very capable floating point unit is being used to do the
fractal calculations. To allow zooming beyond the limitations of your floating point unit, some fractal plug-ins will supply high-
precision fixed point routines. These will typically appear as "96 bit calcs," or something similar, indicating the current number of bits
of precision being used.



Displays the time it has taken to render the current fractal. This number changes while a render is in progress.

The elapsed time is represented in one of the following forms:
. minutes : seconds . fractional-seconds

. hours . minutes : seconds . fractional-seconds

" days hours . minutes : seconds . fractional-seconds (for truly long calculations)



Displays the current fractal's dimensions (width x height) in pixels.




Displays the current fractal's type, as selected from the New Fractal dialog box. Possible values include Mandelbrot, Mandelbrot
Cubed, and so on.




Displays the real (top number) and imaginary (bottom number) parts of the location under the pointer. The coordinates are shown to
the appropriate level of precision required, based on how far in you have zoomed.



Dlsplays the actual number of iterations performed for the current pixel under the pointer. Possible values are:
A number between zero and max. iterations minus one -- The point is not in the Mandelbrot set, and that the point

"escaped" towards infinity after that many iterations.
" Infinite -- After performing max.-iterations number of iterations, the point had still not escaped towards infinity, and is

therefore assumed to be part of the Mandelbrot set.
" Unknown -- The point has not yet been calculated.




Displays the number of iterations that were performed per second on the current image. This value is obtained by dividing the total
number of iterations for the entire image by the calculation time.

Note: Due to various optimizations, such as guessing and watching for cycles, the number of iterations per second may actually be
far beyond that capable of your computer. This is OK. It means that those optimizations worked well, and allowed your computer to
do better than it ever thought it would.



Displays "Julia" when the current fractal is the Julia version of it. This area is blank if it is the non-Julia version.




Status window (Less Info)

The Status window displays additional information about the current fractal.

To open the Status window in its Less Info mode: On the View menu, click Status Window. If the window is in More Info mode,
click the Less Info button.

Status - awesome.fx H
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Fractal type: bl andelbrat Julia
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To learn more about the information in this window, click it.
Tip
. This window, like many in Fractal eXtreme, can be resized so you can view extremely precise image coordinate
information.



Displays the maximum iterations per pixel as set by the lteration Control window.




Status window (More Info)

The Status window displays additional information about the current fractal.

To open the Status window in its More Info mode: On the View menu, click Status Window. If the window is in Less Info mode,
click the More Info button.

Status - aweszome_fx E3
| 100%
Fractal type: bl andelbrat Julia
Elapzed time: 2095
Procezsars uzed: 1 Murber of zooms: 367

Window zize: 320 % 240

R atatian:
Less |nfo I Help

Image Coordinates

-1.936,375,240 5640

+0.000,000,000, 424 4
b aw iterations: 32434 Tatal iterations: 378.441 hag
[teration count; 4169 Ayg. iterationzdpinel.  4,927.6
FPU calcz [terations/second: 2,922,848

To learn more about the information in this window, click it.
Tip

This window, like many in Fractal eXtreme, can be resized so you can view extremely precise image coordinate
information.



Displays the zoom level of the current fractal.



Displays the number of processors used by Fractal eXtreme for calculations. For single-processor machines, this number never
changes. For multiple-processor machines running Windows NT, this number reflects the number of processors the machine has.

Fractal calculations are one of the best applications for multiple processors, because the speed increase is almost linear with the
number of processors added.



Displays the rotation angle of the current fractal. Positive values of rotation move the fractal in a counter-clockwise direction.




Displays the sum of all iteration counts required to calculate the entire image. This can be an extremely large number.



Displays a graphical representation of the rendering of the current fractal. The bar represents the total time to fully render the fractal,
with the green portion representing the completed percentage.




Tip: Finding yourself when zoomed way in

What do you do if you're zoomed way into the Mandelbrot set, or any other fractal, perhaps using some coordinates you grabbed
from a web page, and you want to find out where you are? You can look at the coordinates in the Status window or the Set.
Location window, but somehow those endless strings of coordinates don't really give a satisfying answer to the metaphysical
question, "Where am [?"

You could double-click a bunch of times with the right mouse button to zoom yourself out until you reach recognizable territory.
However, this method is much like lighting all of your matches in order to make sure they work -- you know where you are, but
you're not there anymore! You can use Fractal eXtreme's multi-level undo to get back there, but there are some other methods
available.

Fractal eXtreme gives you two effective methods to find out where in the infinite expanses of the complex plane you are:

Method 1: Use the View Location command
" On the Location menu, click View Location.

A new fractal exploration window appears. The fractal is zoomed out all the way and the Show Location check box is selected
for this window. This means that all of the other fractal exploration windows will be shown as white and blue rectangles drawn on
the Mandelbrot set within this window. If you select the window whose location you wanted to find, its box will be highlighted.
This gives you a rough idea of where you are. If you want to see more precisely, simply zoom in towards the rectangle, watching
where you are going. Eventually, the rectangle will begin growing larger, and then you will get precisely to where you were.

Method 2: Use the Set Location window
1 On the Location menu, click Set Location to open the Set Location window.
2 Use the Zooms spin control to reduce the zoom level, or type in a zoom level of zero.

Now you can use the spin control to zoom in and out, always precisely centered on the area where you were, stopping anywhere
along the way.

Warning: If you zoom all the way out and then scroll over a pixel, or zoom in by double-clicking the image, the tiny location
error that this causes will be magnified by whatever magnification you were at. Using the Zooms spin control to zoom will now
zoom you towards a totally different location. If you do this accidentally, use the multi-level undo to back up as far as necessary.
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Tip: Making iteration bands stand out

Fractal eXtreme's curve-based Colour Palette window makes it easy to make smooth colour palettes, where the individual
iteration bands are barely visible. However, if you want to make those colour bands stand out, use the Show Stripes option (in
the Colour Palette window's Colour menu). This lets you define the even-numbered colours of the palette separately from the
odd-numbered colours. For examples of this feature, use the Rainbow Stripes or Black and White preset palettes.



Tip: Making zoom movies efficiently

When making zoom movies, you can save time and disk space by making the fractal window fairly small -- perhaps 160 by 120 --
before rendering the zoom movie. Fewer pixels means less calculation time and storage space, but it has surprisingly little effect
on the quality of the resulting animations. You can size the movies larger when playing them back, with very little loss of quality.



Tip: Showing a fractal's location in other types of fractals

The View Location command is fairly straightforward and intuitive when the only windows involved depict Mandelbrot fractals.
However, it is a bit more complicated if there are several different types of fractal windows open. Here are a couple of examples.

Example 1:

If you want to show the location of a regular Mandelbrot fractal in a Mand-cubed location window, Fractal eXtreme will oblige.
However, this isn't a very meaningful thing to do.

To illustrate this meaninglessness, consider the Earth and Mars. Both are planets and both have longitude and latitude defining
locations on their surface. Consequently, you could look at a map of Mars and determine where Canada would be on that planet
by looking for the same longitude and latitude. But it doesn't really make sense to show Canada's longitude and latitude on a
map of Mars and suggest that this is in fact, Canada's location. What you have shown are Canada's coordinate's on the planet
Mars.

In much the same way, each type of fractal is its own planet, and each fractal window has coordinates. Thus, you can't truly
display the location of a Mandelbrot fractal on the planet Mand-cubed. You can simply copy the coordinates.

Example 2:

If you are displaying the location of a Julia window within a Julia location window, and you then change the seed location of that
Julia, you no longer have a true mapping. You are showing coordinates -- not location. This is because changing the Julia seed
fundamentally changes the fractal. Each Julia seed defines a different Julia planet.

While each Julia seed is a planet, the Mandelbrot set is a map of all Julias (or a planet made of many planets). And despite the
impression you may have gained from this and the previous example, showing the coordinates of a Julia set on the Mandelbrot
sometimes has quite a lot of meaning. This is the result of a rather difficult mathematical theorem (which we don't entirely
understand) that says: If you have a Mandelbrot set and a Julia set, and if you zoom in on the Mandelbrot set towards the Julia
seed, and if you also zoom in on the Julia set around the same coordinates, the two fractals, which start out looking quite
different, will begin to look more and more similar, until eventually they look almost identical. Usually. The reasons why it doesn't
always work are way beyond us, but suffice it to say that if you choose a seed location in a nice busy area, it will probably work.

That was a bit confusing. To illustrate this example, do the following:
1 Zoom into a nice detailed area of a fractal, preferably of the Mandelbrot set.
2 On the File menu, click Duplicate as Julia.
Notice that the two fractals, while different, have a certain thematic similarity.
3 Double-click with the right mouse button in both windows to gradually zoom out.
Notice that the two fractal images gradually grow less and less similar, until they have virtually nothing in common.
You can see the similarity moving in the other direction, from dissimilar to similar, by using the Undo command (in the Edit
menu) to reset the Julia window to its zoomed-in state, then toggling the Current option in the Show Location submenu of the

Location menu for the Mandelbrot window, and then gradually zooming in towards the Julia window's location, as shown by the
red box.



Tour: Fractal eXtreme Basics
Using Fractal eXtreme is as simple as:
1 Selecting a fractal
To select a fractal: From the File menu, click New to open the New Fractal dialog box, then click OK.
2 Zooming in and out
To zoom in: Double-click with the left mouse button at the location to zoom in on.
To zoom out: Double-click with the right mouse button.

3 Panning around

To pan around a fractal window: Click and drag the fractal around within the window.



Why can't | render a zoom movie?

You cannot render a zoom movie if either of the following is true:
" You aren't zoomed in on the current fractal. The zoom level must be 1.00 or greater.

" The Auto Explorer window is open.




Why can't | render an iteration movie?

You cannot render an iteration movie if either of the following is true:
. The fractal is not 100% calculated.
. Iteration data is not available.

This can happen if you open a fractal from disk that was saved without iteration data (that is, the Save iteration data option in
the Advanced Settings dialog box wasn't selected). This can also happen if you have just rendered a zoom movie, which may
destroy the iteration data.

The most efficient way to recreate the iteration data is to zoom in, and then choose Undo from the Edit menu to force a total
recalculation.



Why can't a zoom movie play smoothly?

A zoom movie will not play smoothly (that is, jerky motion) if Fractal eXtreme is calculating an image in the background.

To fix this problem, either pause the FX Movie Player until the fractal finishes calculating, or pause the fractal calculation while
you play the movie.



Why did Fractal eXtreme switch to demo mode?

If you haven't purchased Fractal eXtreme, the program runs in demonstration mode for a 15-day period. To purchase Fractal
eXtreme, see the Purchasing Fractal eXtreme topic.

If you previously purchased Fractal eXtreme, but your hard drive crashed or you need to move your license to another machine,
you need to contact Release Software at 800-210-5517 or 415-833-0200 to obtain your unlocking code.



Why does the colour palette change?

All open fractal windows share the same colour palette. When you open a fractal that has a different colour palette than the

current one, and you have Palette Auto-Loading (in the Miscellaneous page of the Preferences window) set to Always, the
colour palette will change and all open fractals will be remapped to use this new colour palette.



Why is the fractal rendering so slowly?

A fractal will render slowly if one of the following is true:
" The fractal is zoomed in a large amount.
Fractals are extremely calculation intensive. Fractal eXtreme's highly optimized calculation code probably calculates fractals
faster than other programs, but if you zoom in far enough on the right kind of area, the fastest computer in the world can be
made to seem slow by the intense demands of fractal calculations.
" The Maximum Iterations Per Pixel value (in the Iteration Control window) is set too high.

Higher values take longer to calculate. Lower numbers can (if set too low) produce less detailed results.
. The fractal window is too large.

A larger window will take longer to fully calculate than an smaller window.
" You are running a CPU-intensive application, such as America Online (AOL) version 2.5 (other versions may not exhibit
the same problem).
Even when the AOL software is idle, it tries to use up 100% of the CPU time. This typically means that when Fractal eXtreme
tries to run, it does so at about 1/8th its normal speed. To fix the problem, exit the AOL software and complain to AOL about this
bug.



Why isn't box zoom available?

Box zoom, or the ability to drag a box around the area to zoom into or out of, is not available in the current version of Fractal
eXtreme. However, you can gain the same, if not better, functionality with either the following methods:
By holding down the SHIFT key as you double-click (known as sHIFT-double-clicking), you can quickly zoom into an area of

a fractal.

. By holding down the SHIFT key as you drag the mouse away from you (known as SHIFT-drag), you can easily zoom into an
area, interactively adjusting the zoom level. If you don't like the area you zoomed into, you can quickly undo the zoom operation as
you are zooming by pressing the Esc key or clicking the right mouse button.

Essentially, SHIFT-drag zooming is box zoom, but with a real-time "what you see is what you get" (WYSIWYG) preview!



Why isn't colour cycling smooth?

Colours cannot cycle smoothly in true-colour modes. To view smoother colour cycling, reduce the number of colours in your
desktop's colour palette.

For Windows 95 (or later) and Windows NT 4.0 (or later) users, click * to adjust the Color palette setting in Display Properties.



Why isn't the desktop wallpaper appearing?

If you are running under Windows NT 4.0, saving a fractal as desktop wallpaper may not automatically update the desktop. This
seems to be a bug with Windows NT 4.0. The fractal is correctly saved as FXWallpaper.bmp to the windows (winnt) directory, but

isn't used.

To use the selected fractal wallpaper, do the following:

1 Click " to open the Display Properties applet's Background tab.
2 Under Wallpaper, select Fxwallpaper.

3 Set the Display to either Tile or Center.

4 Click OK.



To adjust the dimensions of a fractal freely
. Drag the edges of the fractal window.

The width and height appear on the right side of the status bar as W: and H:.

To set the dimensions of a fractal exactly

1 On the Options menu, click Eractal Size.
2 Adjust the Fractal width and Fractal height values.
You can click the available preset buttons to set the width and height to common values.

Use the Desktop button to use a fractal as desktop wallpaper. This setting will automatically maximize the current fractal
window and the Fractal eXtreme window so that the Save As Wallpaper command will save the current fractal to fully cover
the desktop.

3 Click OK.
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To adjust the quality of a fractal
1 On the Options menu, click Iteration Control.

2 Increase the Maximum Iterations Per Pixel value.

Changing the Maximum Iterations Per Pixel value causes the fractal to be rerendered. Setting this value too low will cause
some points to be incorrectly identified as being in the Mandelbrot set and make most of the fractal window black. Setting this
value too high will produce more detailed fractals along the edges of the interior, but the fractal will take noticeably longer to
render.

Note
. Fractal eXtreme allows you to set the Maximum Iterations Per Pixel value as high as 100,000,000. Sometimes this is
necessary. Usually it is not. For most pictures, one or two thousand is sufficient. Setting this value to the maximum may produce a
marginally better picture, but may also take considerably longer to calculate. If you set Maximum Iterations Per Pixel that high, you
may notice Fractal eXtreme becomes very slow to respond. This is normal. This is because Fractal eXtreme can only respond to
your requests after it has finished the pixel it is working on, which can take a few seconds at the higher values. To restore its
responsiveness, drag the slider to the left and wait for the program to respond, or choose Pause from the Render menu.

Tip
. When increasing the Maximum Iterations Per Pixel value no longer makes noticeable changes to the fractal image, the
value is high enough. Typically, the farther you zoom in though, the higher you need to set this value.



To copy a fractal to the Clipboard
. On the Edit menu, click Copy.

Any other program that supports bitmap information on the Clipboard can paste the copied fractal into it.



To duplicate the selected fractal
. On the File menu, click Duplicate.

To open a Julia equivalent of a Mandelbrot fractal
. On the File menu, click Duplicate As Julia.

To open a non-Julia equivalent of a Julia fractal
. On the File menu, click Duplicate As Not Julia.



To open a previously saved fractal
1 On the File menu, click Open.

2 Navigate to the folder containing the previously saved fractal, then click its name.

Fractal eXtreme's fractal files use a .fx file name extension.
3 Click OK.

The selected fractal appears in a new window whose title is the fractal's name on disk.

Note
Fractal eXtreme can open Mand2000 files. However, the colour palettes and bitmaps in these files will not be used.
Tip

To preview a fractal before opening it, use the Favourite Spots window.
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To pause a render in progress or resume a paused render
. On the Render menu, click Pause.



To save a fractal under its current name
. On the File menu, click Save.

If the fractal hasn't been previously saved to disk, the Save Fractal dialog box appears for you to specify a location and name.

To save a fractal under a new name
1 On the File menu, click Save As.
2 Specify a location and name for the fractal on disk, then click Save.

Fractal eXtreme's fractals are saved with a .fx file name extension.

Notes
. When you save a fractal using the Save or Save As commands, the BMP file that is saved includes extra information
about the fractal. However, some programs cannot properly handle this extra information (which is valid to have) in the BMP file. If
you are having problems loading a fractal in another program, use the Save Bitmap Only command instead.
. If you are creating a fractal using a virtual screen, use the Save Bitmap Only command to save the fractal at the intended
virtual-screen size.

Tip
. To save a fractal to disk so that you can easily preview it in the Favourite Spots window, save the fractal in the
favourites folder within the same folder you installed Fractal eXtreme (by default, \Program Files\Cygnus
Software\Fractal eXtreme).



To select a fractal to view
1 On the File menu, click New.
2 Select a fractal from the list.
Background information about the currently selected fractal appears in the text box.
3 If you want to open the Julia version of the selected fractal, select the Julia check box.
4 Click OK.

The selected fractal appears in a new untitled fractal window.



To use a fractal as desktop wallpaper
On the File menu, click Save As Wallpaper.

Notes

. The wallpaper appears using the current wallpaper settings. To adjust the settings under Windows 95 or Windows NT 4.0
or later, click

. The Save As Wallpaper command always saves the wallpaper bitmap as FXWallpaper.omp in your windows directory. To
save multiple bitmaps, use the Save Bitmap Only command instead.

Tip

To save a fractal the same size as your desktop, maximize the Fractal eXtreme window and maximize the fractal window
before choosing Save As Wallpaper. You can also maximize both windows from the Eractal Size dialog box.
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To view a favourite fractal
1 On the Location menu, click Favourite Spots.

2 If you are in Advanced mode, you can navigate to different drives and folders using the Drives and Parent controls.
Subfolders appear as entries within the list box.

3 Double-click the stamp of the fractal to view.

A new fractal window appears, displaying the selected favourite fractal spot.
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To view the edges between iterations

. On the View menu, click Edges.
Note
" Edges don't fully appear until a fractal is completely rendered (calculated).
Tip
" To adjust the speed at which edges appear and disappear, adjust the Zoom speed value in the Miscellaneous page of the

Preferences window.



And much, much more

Fractal eXtreme's plug-in architecture makes it trivial for amateur and professional programmers to add new fractal types.

Support for long file names means you can save your favourite images with descriptive names.



Colour controls

Fractal eXtreme has the coolest fractal colour palette editor in the world.




Exploration controls

Fractal eXtreme lets you explore multiple fractals simultaneously, each in its own window. Multiple fractal windows allow easy side-
by-side comparison of different fractal areas, different types of fractals, or Julia sets and Mandelbrot sets.

You explore fractals in real time, with high-speed animated zooms and rotations. Use simple click, double-click, and drag
operations to zoom in and out, rotate, and pan around a fractal. You can also graphically identify a fractal view's location in other
fractal windows using the Show Location options.

Fractals are drawn from the center of a window outward, instead of top-to-bottom, because you're probably more interested in the
center area.

If you want the program to automatically find fascinating areas of a fractal, use the Auto Explorer.



Fractal movies

Fractal eXtreme lets you create zoom movies that animate the exploration of a fractal. The innovative fractal zoom movie player
(FX Movie Player) allows deeply zoomed fractal movies to be calculated an order of magnitude faster than most zoom movies,
stored an order of magnitude more efficiently, and sized up at playback time with virtually no loss in quality. You determine the
number of frames when playing the movie, instead of when creating it. This magic is done by calculating key frames and
interpolating between them in real time to create as many frames of data as are desired.

Fractal eXtreme also lets you create real-time iteration movies, showing the iteration bands sweeping onto the screen. Either view
the iteration movies in Fractal eXtreme or save them as Video for Windows (AVI) files.




Speed and precision

Fractal eXtreme has possibly the fastest raw fractal calculation speed available on your desktop. The visualization speed goes
even beyond the already fast calculations, by giving you successive approximation previews, giving you a rough overview of your
image in as little as 1/64th the time it takes to generate the entire image. Auto-loop detection, self-correcting area guessing, and
other calculation optimizations let Fractal eXtreme's already fast calculations run up to ten times faster -- or more!

Fractal eXtreme is threaded, so that it's always calculating. It is multi-threaded, to make use of multiple processors. It is a 32-bit

application, to take full advantage of your 32-bit processor. It also lets you view huge images, restricted only by available virtual
memory.

Fractal eXtreme's high-precision code means that you never have to worry about running out of precision. Innovative coding
technigues mean that these high-precision calculations are much faster than competing products.



What makes Fractal eXtreme so eXtreme?

We at Cygnus Software feel Fractal eXtreme is the best fractal exploration program on the market. Click one of the buttons below
to find out for yourself.
Speed and precision

Exploration controls

Fractal movies

Colour controls

And much, much more




Zoom level discussion

If you describe fractal magnifications in the same way that you do a microscope (for example, 10x, 50x, and 1000x), you quickly find
yourself getting into ridiculously large numbers. Whereas microscopes are limited at around a million times magnification, fractal
programs frequently use up to a billion, billion, billion, billion times, or more.

Instead of describing magnifications in terms of incomprehensibly large numbers that are very difficult to say, Fractal eXtreme
describes magnifications in terms of the number of zooms it takes to get to a magnification level. This information is always
displayed in the status bar, Status window, and the Set Location window. The computer and math wizards in the audience can call it
the base two logarithm of the magnification, but we'll just call it the number of zooms. Conversion of the number of zooms to the
magnification is fairly easy. A magnification of one thousand is approximately 10 zooms. A magnification of one million (one
thousand thousand) is approximately 20 zooms. A magnification of one thousand million is approximately 30 zooms, and so on.

The most we at Cygnus Software have zoomed in on a fractal is one thousand times. The magnification of the picture was
approximately ten to the 300th power -- that's a one followed by three hundred zeros. That's equivalent to a million times a million
times a million times...times itself about fifty times. That's serious magnification. At that magnification, a wee tiny subatomic particle
would appear to be considerably larger than the visible universe! How much larger? Well, it actually only takes about one hundred
and forty zooms to make an electron the size of the visible universe, so one thousand zooms, is simply an incomprehensibly,
outrageously, enormously, ridiculously large zoom level. But this program will let you do it. Warning: Due to the incredible accuracy
required and the high number of iterations per pixel, our one thousand zoom picture took rather a long time to calculate. We went on
holidays.

The following table lists some example zoom levels, their corresponding magnifications, and another attempt to put that
magnification into perspective. Zooming in eight times with Fractal eXtreme, for example, magnifies the fractal 256 times. If you
increased the size of the average computer at the same rate, this would translate to having a football field on your desk and a very
scary mouse. A magnification listed in the form ~1E30 means "approximately one times ten to the thirtieth power" or one followed by
thirty zeros.

Zooms Number of Magnifications Size of Monitor

1 2 bigger than a bread box
2 4

3 8

4 16

5 32

6 64

7 128

8 256 football field

9 512

10 1024 100-story building

20 ~1E6 Vancouver Island

30 ~1E9 Jupiter's radius

40 ~1E12 Earth's orbit

50 ~1E15

60 ~1E18 distance to Alpha Centauri
70 ~1E21 Milky Way galaxy

80 ~1E24 large doesn't cover it!
90 ~1E27

100 ~1E30 huge

110 ~1E33 really huge

120 ~1E36 even huger

130 ~1E39 enormously gargantuan
140 ~1E42 size of electron to the universe

6000 ~1E1800 incomprehensibly big...but we did it!







