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GoldWave is a sound player, recorder, and editor.    Before using GoldWave, make sure the sound drivers 
have been installed and configured with Window's Control Panel.    The manual contains more detailed 
information about GoldWave and sound editing.

To learn how to use help, press F1.
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New Wave

GoldWave supports a wide range of sound attributes.    These attributes must be specified when creating 
a new file.    All new files will be saved in standard RIFF WAVE format.

8 bits vs. 16 bits
16 bits sounds better than 8 bits, but uses twice as much memory.    Also, more sound devices support 8 
bits than 16 bits.    Therefore, GoldWave selects 8 bits as the default.

Mono vs. Stereo
Stereo sound uses twice as much memory as mono sound and can take twice as long to edit.    You can 
edit individual channels by using the Options | Editing dialog.

Sampling Rate
This value determines the quality of the sound.    It is the number of times per second data is sent to or 
received from the sound device.    The drop down list box provides many standard rates.    Microsoft 
recommends that this value should be one of 11025, 22050, or 44100.

11025 Voice and low pitch sounds, relatively small memory usage.
22050 Medium quality music, medium memory usage.
44100 High quality music, potentially CD quality, high memory usage.

Time
The length of the sound in seconds.

The highest quality sound is produced with 16 bit, stereo, 44100Hz.    Note that this uses 176,400 bytes 
for every second of sound.

The default rate of 8 bit, mono, 22050Hz uses only 22050 bytes for every second.    This format is good if 
memory and disk space are limited and quality is not very important.

If you plan to do some recording, make sure you specify attributes that are compatible with your audio 
device.

For more information, see the Appendix A in the manual.



Introducing GoldWave

GoldWave is a digital audio editor, player, and recorder.    It can load and edit many different sound file 
formats and display separate graphs for the left and right channels of stereo sounds.

Features:
+ Supports several RIFF WAVE formats: PCM, MULAW, ADPCM
+ Support other file formats: VOC, Amiga 8SVX, Sun, NeXT, Matlab
+ Independent channel editing of stereo sounds
+ A "real-time" oscilloscope, both amplitude and spectral
+ Separate "Controls" window for playing and recording
+ Expression evaluator
+ Intelligent editing
+ Direct editing with the mouse
+ Many effects
+ Fast processing using 32-bit instructions

Author:
Chris Craig
P.O. Box 51
St. John's, NF
CANADA    A1C 5H5

E-mail address:
chris3@garfield.cs.mun.ca

CompuServe:
>INTERNET:chris3@garfield.cs.mun.ca

See the manual for more information.



GoldWave Windows

There are three types of windows used by GoldWave: the Main window, the Device Controls window, 
and Sound windows.    The Main window contains a menu bar, a tool bar (sometimes called a speed bar 
or button bar), and an information/status bar at the bottom.    This window keeps all the sound windows 
grouped together.    It is similar to the main window of a word processor, where you can have several 
document windows open at once.

The Device Controls window contains an oscilloscope and sound device controls.    The oscilloscope 
displays the sound as it is being played.    The controls determine the volume, left/right balance, and 
speed at which sounds are played.    A row of standard cassette buttons for playing and recording sounds 
are kept in this window.    Several features of this window can be configured by using the Setup button.

Sound windows are created whenever sound files are opened.    Up to 5 sounds can be opened 
(provided there is enough memory).    Sound windows display a graph of the sound.    Mono sounds are 
shown with a single green graph.    Stereo sounds are shown using a green graph for the left channel and 
a red graph for the right channel.

Below the graph is the "Overview Bar".    It provides useful information about what part of the sound is 
currently selected and what part of the sound is displayed by the graph.    You can zoom in on a section of 
a sound by using the View Menu Commands.

See Also
File Menu Commands
View Menu Commands



View Menu Commands

View commands allow you to zoom in to and zoom out of the sound graph.    When a sound file is initially 
opened, the graph shows the entire sound.    By using the View Menu Commands, you can get a more 
detailed graph of the selection.

Zoom Block (Block Button)
Magnifies the selected part of the sound, increasing the detail of the graph.    You can zoom in many times 
(by selecting part of a sound, then zooming again) until a single sample is shown in the graph.

Unzoom (Out Button)
Shows the entire sound.    Sound windows are initially unzoomed.

Zoom user defined (User Button)
Magnifies the sound to the level of detail specified under the Options | Settings dialog.    The start marker 
is used as the zoom location.    The level can be set to any value you find convenient.

Zoom any
This magnifies the graph to any level you specify.    The level is given as 1:X, where X is the number you 
enter at the prompt.    A value of 10 gives a 1:10 level as described below.    A value of 0.05 is equivalent 
to a 20:1 zoom level.    If the given level is not possible, the closest valid level is used.

Zoom 20:1
Magnifies the sound to give a very high level of detail.    At this level, individual samples are easily visible. 
The start marker is used as the zoom location.    Direct sample editing with the mouse is possible at this 
level.

Zoom 5:1
Magnifies the sound to give a high level of detail.    At this level, individual samples are visible.    The start 
marker is used as the zoom location.    Direct sample editing with the mouse is possible at this level.

Zoom 1:1 (1:1 Button)
Magnifies the sound to give a true representation of the graph of the sound.    The start marker is used as 
the zoom location.

Zoom 1:10
Magnifies the sound to give a rough representation of the graph of the sound.    The start marker is used 
as the zoom location.

Zoom 1:100
Magnifies the sound to give a very rough representation of the graph of the sound.    The start marker is 
used as the zoom location.

See Also
Direct editing of individual samples



Editing Overview

The GoldWave editor is block based.    A block is defined as the highlighted part of the sound graph 
between two vertical markers.    Most editing and effects are performed on this highlighted (selected) 
block.    The vertical markers are cyan lines located at the far left side (start marker) and far right side 
(finish marker) of the graph; they may be difficult to see.

There are two ways to move the markers, depending on Options | Settings setup.    GoldWave does not 
use Windows' standard "click-and-drag" method because it does not allow accurate positioning of the 
markers.    The methods below allow you to independently set the start and finish markers to the nearest 
sample (when zoomed in at a 1:1 level or better).

Method 1, Quick selecting (default):
To move the start marker:

Click the left mouse button on the graph at the point where you want to place the start marker.
To move the finish marker:

Click the right mouse button on the graph at the point where you want to place the finish marker.

The drawback of this method is that it is easy to accidently change the start/finish marker when clicking 
on a sound window.

Method 2, Grab and drag:
If the "Quick selecting" check box in Options | Settings is not checked, then a grab and drag method is 
used.
To move a marker:

1) Position the mouse arrow over the marker.    Make sure the mouse is inside the 
graph area.    You should see the arrow change into a vertical bar with small arrows on 
either side.
2) Press and hold the left mouse button.
3) Move the mouse to the left or right.
4) Release the mouse button when the marker is at the desired position.

The drawback of this method is that the marker must be inside the graph box before you can move it.    
This may not be the case if you are zoomed in.

See Also
Edit individual channels of stereo sounds
Direct editing of individual samples
Edit Menu Commands
View Menu Commands



File Menu Commands

New
Creates a new sound file and allows you to choose the file's attributes.    New files will always be saved 
with Microsoft's RIFF WAVE format.

Open
Opens an existing sound file.    Only 5 files can be opened at one time.    Note that encoded files may take 
some time to decode.    If GoldWave does not recognize the file's format, the Raw File Format dialog is 
presented.    See the manual for more details on supported formats.

Save
Saves the current file to the disk.

Save as
Saves the current file to the disk under a different name.    Note: Files are saved in their original format.    
To save files is a different format, use the Export command.

Export
Brings up the Export Dialog that allows you to save the current file with a new name and format.

Exit
Exits GoldWave.



Edit Menu Commands

Undo
Reverses the last modification.

Cut
Copies the block into the clipboard and deletes it from the sound window.

Copy
Copies the block into the clipboard.

Paste
Pastes the clipboard into the sound window.

Mix
Mixes the clipboard with the sound window.

Delete
Deletes the block.

Trim
Removes sounds outside the block.

Insert space (Space Button)
Inserts a blank space into the sound window of a size you specify in seconds.    The space is inserted at 
the start marker's position.

Select view (Sel Vw Button)
Moves the start and finish markers to the far left and far right of the sound graph.

Cue points
Brings up the Cue points dialog, where cue points may be created or edited.

See Also
Edit individual channels of stereo sounds
Direct editing of individual samples
Editing Overview



Undo (Undo Button)

Reverses the most recent change made to a sound.    Only one undo is possible across all sound 
windows.    The undo feature keeps a copy of the original data in a temporary file.    This file is created in 
the temporary directory specified by the TEMP environment variable.
Since the undo feature has to save large amounts of data, you will notice a slight delay before each 
edit/effect command is performed.    The undo feature can be disabled in the Settings dialog.



Cut (Cut Button)

Removes the block from the active sound and puts it in the clipboard. The contents of the clipboard can 
then be pasted into a sound window using Paste.    Note that if only the left or right channel is active in a 
stereo sound, then only that channel is removed.    Since it is not possible for one channel to be larger 
than the other, the end of the cut channel is padded with silence.
To cut:

1) Move the start and finish markers to the part of the sound you want to cut.
2) Choose Cut from the Edit menu or click on the Cut button.

See Also
Delete
Trim



Copy (Copy Button)

Copies the block into the clipboard.    The block is not removed.    The contents of the clipboard can then 
be placed into a sound window using Paste.
To copy:

1) Move the start and finish markers to the part of the sound you want to copy.
2) Choose Copy from the Edit menu or click on the Copy button.



Paste (Paste Button)

Places the sound in the clipboard into the active sound.    The sound is inserted at the start marker's 
position.    The length of the active sound is increased so that the clipboard sound will fit.    The clipboard 
sound is automatically converted to match the attributes of the active sound.
To paste:

1) Move the start marker to the place where you want to paste the clipboard sound.
2) Choose Paste from the Edit menu or click on the Paste button.

See Also
Mix



Mix (Mix Button)

This is a special editing feature for sounds.    The sound in the clipboard is blended (superimposed) with 
the active sound.    You are asked for the mix volume.    This volume is applied to the clipboard sound as it 
is being mixed.
To mix:

1) Move the start marker to the place where you want to mix the clipboard sound.
2) Choose Mix from the Edit menu or click on the Mix button.

3) Enter the volume to mix the clipboard (100 = normal volume).
4) Choose OK.

See Also
Volume
Paste



Delete (Delete Button)

Delete permanently removes the block from the active sound.    The block is not copied to the clipboard.    
Note that if only the left or right channel is active in a stereo sound, then only that channel is removed.    
Since it is not possible for one channel to be larger than the other, the end of the deleted channel is 
padded with silence.
To delete:

1) Move the start and finish markers to the part of the sound you want to delete.
2) Choose Delete from the Edit menu or click on the Delete button.

See Also
Cut
Trim



Trim (Trim Button)

Trim permanently removes the parts of the sound that are outside the block from the active sound.    The 
parts are not copied to the clipboard.    Note that if only the left or right channel is active in a stereo sound, 
then only that channel is removed.    Since it is not possible for one channel to be larger than the other, 
the ends of the trimmed channel is padded with silence.
To trim:

1) Move the start and finish markers to the part of the sound you want to delete.
2) Choose Trim from the Edit menu or click on the Delete button.

See Also
Cut
Delete



Effects Menu Commands

Echo
Produces an echo.

Exchange channels
Exchanges the left and right channels.

Filter
Displays a pop-up menu listing several filter related commands.

Interpolate
Fades from the start marker's value to the finish marker's value.

Invert
Turns the sound up-side-down.

Mechanize
Adds a mechanical characteristic to sounds.

Offset
Changes the dc offset of a sound.

Pan
Sets internal balance and left/right channel panning.

Reverse
Reverses the sound so that it will play backwards.

Silence
Silences (mutes) the selection.

Volume
Displays a pop-up menu listing several volume related commands.

Playback rate
Changes the rate at which the entire sound is played.

Resample
Changes the sound so that it can be played at a different sampling rate.

Transpose
Changes the pitch of a sound by resampling it.

Expression evaluator
Brings up the expression evaluator.

See Also
Editing Overview
Edit Menu Commands



Echo

Produces an echo effect with the block.    The echo delay and volume can be entered after choosing this 
command.    You may want to try the default values first.

The longer the delay, the longer it takes for the echo to "bounce" back.    Try values less than 0.1 for a 
large room, 0.3 for a baseball stadium, above 0.3 for a canyon echo.

The lower the volume, the quieter the echo will be. Values less than 50 give good results.

The Reverb check box enables or disables regeneration of the echo.

To make the echo sound correct, GoldWave extends the effect slightly outside the block boundary.    This 
may increase the length of the sound.    If you do not want to modify sound outside the block or you do not 
want the length of the sound to change, use the Options | Editing dialog to disable modification outside 
the block.
To add an echo:

1) Move the start and finish markers to the part of the sound you want to add an 
echo.
2) Choose Echo from the Effects menu.
3) Enter the delay time.
4) Enter the volume.
5) Check Reverb if desired.
6) Choose OK.



Filter

Brings up a pop-up menu listing several filter related commands.    Filters are used to remove a range of 
frequencies from the sound.    They can produce a variety of effects on the sound.

Lowpass 50%
Passes the sound through a lowpass filter.    Frequencies above one half of the Nyquist (or one quarter 
the sampling rate) are removed.    For example, a sound recorded at 44100Hz will have frequencies 
above 11025Hz removed.

Lowpass 25%
Passes the sound through a lowpass filter.    Frequencies above one quarter of the Nyquist (or one eight 
the sampling rate) are removed.    For example, a sound recorded at 44100Hz will have frequencies 
above 5512.5Hz removed.

Highpass 10%
Passes the sound through a highpass filter.    Frequencies below one tenth of the Nyquist (or one 
twentieth the sampling rate) are removed.    For example, a sound recorded at 44100Hz will have 
frequencies below 2205Hz removed.

Highpass 25%
Passes the sound through a highpass filter.    Frequencies below one quarter of the Nyquist (or one eight 
the sampling rate) are removed.    For example, a sound recorded at 44100Hz will have frequencies 
below 5512.5Hz removed.



Fade out

Gradually decreases the volume throughout the block.    The percentage of fade can be entered after 
choosing this command.    The fade percentage is the amount that the volume should decrease.    A value 
of 100 fades to complete silence.    A value of 50 fades to half the original volume.
To fade out part of a sound:

1) Move the start and finish markers to the part of the sound you want to fade.
2) Choose Fade out from the Effects | Volume pop-up menu.
3) Enter the fade percentage, then choose OK.

See Also
Fade in



Fade in

Gradually increases the volume throughout the block.    The initial volume percentage can be entered after 
choosing this command.    A value of 25 starts with one quarter volume and fades in to full volume.    A 
value of 0 starts at silence and fades in to full volume.
To fade in part of a sound:

1) Move the start and finish markers to the part of the sound you want to fade in.
2) Choose Fade in from the Effects | Volume pop-up menu.
3) Enter the initial volume percentage, then choose OK.

See Also
Fade out



Invert

Reflects the block data about the x (time) axis.    This produces no noticeable effect in mono sounds and 
has a slight effect in stereo sounds.    Inverting a single channel of a stereo sound will produce a 
surround-sound effect.
To invert part of a sound:

1) Move the start and finish markers to the part of the sound you want to invert.
2) Choose Invert from the Effects menu.



Maximize

Searches the block for the maximum percent that the volume can be increased without producing 
distortion or clipping errors.    This volume is then applied to the block.    If the percentage is above 2000% 
or equal to 100%, no changes will be made.
To maximize the volume of part of a sound:

1) Move the start and finish markers to the part of the sound you want to increase 
the volume.
2) Choose Maximize Volume from the Effects | Volume pop-up menu.



Mechanize

Adds a robotic or mechanical characteristic to sounds.    The percentage of quality can be entered after 
selecting this command.    Low values produce an untuned radio effect.    Higher values give a rough 
distorted effect.
To mechanize part of a sound:

1) Move the start and finish markers to the part of the sound you want to 
mechanize.
2) Choose Mechanize from the Effects menu.
3) Enter the quality percentage, then choose OK.



Offset

Adjusts or removes a dc offset in a sound by shifting it up or down vertically.    When this command is 
selected, it first scans the sound for any existing offset.    The existing offset is then displayed in a dialog 
where it may be changed.    A positive value shifts the graph up and a negative value shifts it down.
To adjust the offset of part of a sound:

1) Move the start and finish markers to the part of the sound you want to adjust.
2) Choose Offset from the Effects menu.
3) Enter the offset, then choose OK.



Pan

You are presented with the Shape Dialog.    For panning, the shape dialog is divided into green and red 
regions, representing the left and right channels respectively.    The line, initially located between the 
regions, represents the center for panning.    By bending and/or moving the line, you can alter the sound's 
left/right balance or pan to and from each channel.



Playback rate

Changes the playback rate of the entire sound.    The sound will play faster (or slower) and its pitch will be 
higher (or lower).    Essentially, this just changes the first number in the information bar.    Values of 11025, 
22050, and 44100 are the recommended values.
To change the playback rate of the entire sound:

1) Choose Playback rate from the Effects menu.
2) Enter the new rate, then choose OK.

The Spd control in the Device Controls window also affects playback speed.    It only changes the 
device's playback rate, whereas the Playback rate command changes the rate within the sound.    A 
speed of 1.00 is normal.    The new speed will be used the next time a sound is played.
To change the playback rate of the audio device:

1) Move the Spd scroll bar thumb to the left or right.    GoldWave will automatically 
find the closest speed that is compatible with your audio device.

See Also
Resample
Transpose



Resample

Changes the sampling rate of the entire sound.    Unlike Playback rate, this command re-calculates and 
optionally interpolates all the data so that the pitch and playback time are not affected.    You are prompted 
to enter a new rate.    Values of 11025, 22050, and 44100 are the recommended values.    If you check the 
Interpolate check box, interpolation is used to re-calculate sample values at fractional positions.    This 
usually gives a higher quality result.

To change the sampling rate of the entire sound:
1) Choose Resample from the Effects menu.
2) Enter the new rate.

3) Choose Interpolate if required.
4) Choose OK.

See Also
Playback rate
Transpose



Transpose

Changes the sampling rate of the entire sound so that it plays back at a different pitch.    This is useful for 
converting instrument samples from one note to another.    Transpose combines the Resample and 
Playback rate effects. You are prompted to select the original pitch and a new one from drop down lists. 
The lists specify notes.    By specifying "C" as the original pitch and "C2" as the new one, you can shift the 
sound up one octave.

See Also
Resample
Playback rate



Change

Modifies the block so that it sounds louder or softer.    The percentage of volume can be entered after 
selecting this command.    Values less than 100 make the sound softer and values greater than 100 make 
the sound louder.    A value of 100 has no effect.    Enter 50 to half the volume and 200 to double the 
volume.
To maximize the volume of part of a sound:

1) Move the start and finish markers to the part of the sound you want to change the 
volume.
2) Choose Change from the Effects | Volume menu.
3) Enter the new volume percentage, then choose OK.



Shape

You are presented with the Shape Dialog.    With the Shape Dialog, you can define the amplitude 
envelope of a sound.    The shape line is initially horizontal at 100.    By bending/moving the line, you can 
easily change the volume of different parts of the sound.



Volume

Brings up a pop-up menu containing several volume related commands.    Volumes are usually specified 
by a percentage of the sound's original amplitude.

The Vol (volume) and Bal (balance) controls in the Device Controls window also affect volume (if your 
audio device supports them).    They change the device's output volume, whereas the Volume commands 
actually changes the volume within a sound.
To change the output volume of the audio device:

1) Move the Vol or Bal scroll bar thumb to the left or right.

Change
Changes the volume.

Fade in
Gradually increases the volume throughout the block.

Fade out
Gradually decreases the volume throughout the block.

Maximize
Increases volume as high as possible without distortion.

Shape
Allows envelope shaping.

See Also
Pan



Options Menu Commands

Input device
Allows you to choose a device for recording sounds.    It also shows you the capabilities of your device.

Output device
Allows you to choose a device for playing sounds.    It also shows you the capabilities of your device.

Aux volume
Sets the output volume on an auxiliary device.

Settings
Allows you to set certain features in GoldWave.

Editing
Allows you to set sound editing options.



Editing Options

By selecting the menu command Options | Editing, you are presented with a dialog box.

The Channel Editing group lets you control which channel (or channels) will be edited for stereo sounds. 
For example, if you choose "Left channel", all effects and editing will only change or use the left channel. 
You can then use Edit | Copy to extract the left channel into the clipboard or use Edit | Mix to mix the 
clipboard with the left channel and so on.
You can also use the Chan button to quickly switch to different channel editing.

The Modify outside block option prevents certain effects (like Echo) from changing the sound outside 
the block markers.

See Also
Editing Overview



Output device

The list shows you the names of output devices/drivers.    Above the list is a table that tells you what 
sound attributes/formats the driver supports.    All boxes with check marks in them are supported by the 
currently selected driver.    You can select any driver to see its capabilities.



Input device

The list shows you the names of input devices/drivers.    Above the list is a table that tells you what sound 
attributes/formats the driver supports.    All boxes with check marks in them are supported by the currently 
selected driver.    You can select any driver to see its capabilities.



Aux volume

This dialog allows you to set the output volume on an auxiliary device.    This may be useful when 
recording from a CD-ROM.    A list of installed auxiliary devices is displayed at the bottom of the dialog.
To change auxiliary output volume:

1) Select a device.    If the device supports volume control, the "left" control will be 
enabled.    If the device supports stereo volume control, both the "left" and "right" controls 
will be enabled.

2) Adjust the volume with the "left" and/or "right" controls.



Settings

Sound Path
Used by File | Open.    You can specify the directory where you keep your sound files.    If you type "d:
\sound\wave", for example, the File | Open dialog will automatically list the files in that directory whenever 
you start GoldWave.

Save window positions
If this is checked, the Main window and Device Controls window positions will be saved when you exit 
GoldWave.    This means you will not have to adjust window positions every time you start GoldWave.

Decode file to 8-bits
If this is checked, any encoded files will be converted to 8-bit PCM format.    This will cause some loss of 
quality, but will allow playback on a larger variety of audio devices.    If the box is not checked, the data is 
converted to 16-bit PCM format. If your audio device supports 16-bit PCM files, uncheck this box.

Quick selecting
This check box allows you to choose which method to use when selecting a block.

Graph averaging
If this box is checked, the graphs displayed in Sound windows will be drawn using an average of samples 
rather than just one sample.    While averaging can give a cleaner display, the amplitude will be somewhat 
inaccurate.    Averaging is not applied when the zoom level is 1:10 or closer (such as 1:1, 5:1, or 20:1).

Allow undo
Enables or disables the undo feature.    Since the undo feature can use large amounts of disk space and 
slow editing, you may want to disable undo by unchecking this box.

User zoom
This is where you specify the level of zoom for the View | Zoom user defined command (User button).    
Values between 0.01 to 100 are valid.

See Also
Editing Overview
View Menu Commands



Playing and Recording Sounds

To play part of a sound:
1) Move the start and finish markers to the part of the sound you want play.

2) Choose the  button on the Device Controls window.

You can pause playback with the  button.

The  (rewind) button and the 

 (fast forward) button move you quickly through the file.

To record a sound (provided your audio device can record):
1) Move the start and finish markers to the part of the sound you want to record 
over (you can use Edit | Insert space to create a place to record the sound).

2) Choose the  button on the Device Controls window.

You can use the  button to stop playback or recording at any time.

See Also
Editing Overview
Device Controls Window



Raw File Format

The Raw File Format dialog is presented if any of the following occur:
1) The file has no header information.
2) The file does have a header, but the file structure is incorrect for the given format.
3) The file has a new format that GoldWave does not recognize.
4) The file is in a format not supported by GoldWave.

The dialog allows you to specify the attributes for the data in the file.    See the manual for a table of 
supported formats in the Open subsection.

To specify the attributes:
1) Select one of the radio buttons in the Bits group.
2) Select the number of channels.    Stereo data must be interleaved (i.e. left and 
right channel data for a single sample are grouped together).
3) Select the sample rate.
4) Select "Signed" or "Byte swapped" as appropriate.
5) Choose OK.
6) Play the sample to ensure the attributes are correct.

If the attributes are wrong, the sound will play distorted.    You will have to close the sound window and 
reopen it using a different format.
If the sampling rate is incorrect, the sound will play too fast or too slow.    You can use the Effect | 
Playback rate to quickly fix this.

Warning: If you save the file later, any header information will be lost.    You are encouraged to save the 
file under a different name using File | Export or File | Save as.    Be sure to give a meaningful filename 
extension.



Convert Attributes

By using File | New in conjunction with Edit | Copy and Edit | Mix or Edit | Paste, you can change the 
attributes of a sound file.

To convert:
1) Use File | New to create a new sound window with attributes you need.
2) Use File | Open to open the sound file to be converted.
3) Choose Edit | Copy to copy the entire file into the clipboard.
4) Active the new sound window by clicking on its title bar.
5) Choose Edit | Mix or Edit | Paste to convert the sound and place the result in 
the new sound window.

Using Edit | Mix with a volume of 100 is similar to using Edit | Paste.    Paste, however, will insert the 
converted sound, leaving 5 seconds of blank space at the end of the new sound window.

You can also use the File | Export command to save a file in a different format and with different 
attributes.

See Also
Editing Overview
Edit Menu Commands
File Menu Commands



Shape Dialog

The shape dialog consists of a graph window and several buttons. The graph window initially contains a 
single horizontal line with two endpoints (shown as square boxes). By clicking the left mouse button 
anywhere inside the graph window, you can insert new points to "bend" the line into a variety of zigzag 
shapes.    You can move points up and down by clicking and dragging them to a new location.

To remove a point (except an endpoint), click the right mouse button over the point.    Endpoints cannot be 
removed.

To remove all the points (except the endpoints), choose the Clear button.

The shape dialog is used for volume shaping and panning.



Direct Editing of Samples

GoldWave lets you directly edit samples with the mouse.    To do this, you must first zoom in so that 
individual samples are visible (see View Menu Commands).

1) Zoom in 5:1 or closer.
2) Place the mouse arrow directly over the sample you want to edit.    The arrow will 
change into a thin horizontal line with two small arrows pointing to it.
3) Click and hold the left mouse button.
4) Move the mouse up or down to change the sample.
5) Move the mouse slowly left or right to change neighbouring samples (if you move 
too fast, you may skip a sample).
6) Release the mouse button.



Expression Evaluator

The Expression Evaluator is a versatile tool for manipulating and generating audio data.    Expressions 
can be entered by clicking on the buttons, using the keyboard, or selecting an expression from the Group 
and Expression name lists.

For example, say you want to generate a sine wave.    The mathematical equation is:

y = sin(2 * pi * f * t) where f is the frequency, t is the time and pi = 
3.14159...

To generate this function in the active sound window, you would:
    1) Choose Effects | Expression evaluator
    2) Type in the expression in the large Expression edit box:

sin(2*pi*f*t)
    3) Enter the desired frequency in the "f" edit box (500Hz, for example). 

500
    4) Choose the Start button.

You can also use the expression evaluator to implement new effects.    To create a tremolo effect, you 
would:
    1) Choose Effects | Expression evaluator
    2) Type in the following expression (assuming the active sound is number 1):

wave1(n) * (0.6 + 0.4 * sin(2*pi*f*t))
    3) Enter the tremolo rate in the "f" edit box (4 per second, for example). 

4
    4) Choose the Start button.

You can alter the depth of the tremolo by changing the values "0.6" and "0.4" (to "0.8" and "0.2" for 
example).

See the manual for more information.



Group and Expression name

The Group name and Expression name boxes allow you to organize and store expressions in the 
EXPRESS.EQX file located in your Windows directory.    Similar expressions can be stored    together in 
groups.    The Group name box lists all these groups, while the Expression name box lists all the 
expression in a group.

To retrieve an expression:
1) Select the group from the Group name list.
2) Select the expression from the Expression name list.

To add an expression:
1) Enter the expression.
2) Type in the group name or select a group from the Group name list.

3) Type in an expression name.
4) Choose the Add button.

To delete an expression:
1) Select the group from the Group name list.
2) Select the expression from the Expression name list.
3) Choose the Delete button.

When a group becomes empty, it will automatically be deleted.



Device Controls Setup

The Setup button presents a dialog containing many configurable options for the Device Controls window. 
These options are described below.

Graph type
The Graph type group allows you to set the type of oscilloscope to display.    These include:

Amplitude: the sound is shown as a series of amplitudes.
Spectral: the sound is shown a frequency spectrum.
None: the oscilloscope is disabled.

Controls
The Controls group lets you configure the speed of the fast forward and rewind buttons.    By entering a 
value of "3.00" for the Rewind time, for example, the rewind button will move the current position 
backwards through the sound three times as fast as regular playback speed.
By entering small numbers (such as "0.01") the rewind and fast forward buttons will move the current 
position very slowly through the sound.    This is useful for finding pops or clicks, since the oscilloscope 
will also move slowly through the data.

Graph length
The size of the oscilloscope windows can be changed by using the radio boxes in the Graph length 
group.    If Long is selected, the graph will show 256 points.    If Short is selected, the graph will display 
128 points.

Looping
Looping options allows both playback and recording to be looped continuously.    Record looping is useful 
when you want to monitor the audio inputs.    This lets you to adjust volumes to prevent clipping.    You can 
also analyze the input using the Spectral oscilloscope.    You may want to use File | New to create a 
working area for record looping.

Playback
The Playback options define what part of the sound will be played when the play button is pressed.    If 
All is checked, the entire sound is played.      If Window is checked, only the visible segment of the sound 
is played.    If Selected is checked, only the sound between the start and finish markers is played.

Other
The Spectral windowed check box enables or disables windowing of sound data before spectrum 
processing.
If the Grid on graph check box is checked, the oscilloscope windows will have horizontal and vertical grid 
lines.
If the Save setup check box is checked, all the settings will be saved in GoldWave's ".ini" file after the OK 
button is pressed.

Positioning
The Positioning group lists several methods for determining the current position when a sound is played. 
This position is used to synchronize the oscilloscopes and the white "current position" line.    GoldWave 
relies heavily on correct positioning for many of the device controls such as rewind, fast forward, and 
speed adjustment.



Cue Points

Cue points allow you to remember and describe specific positions within sounds.    Cue points can be set 
at the start or finish marker's position.    Also, the start and finish markers can be moved to a cue point.    
Cue points can be save only in WAVE files.
To set a cue point (using the start marker):

1) Move the start marker to the position where you want to create a cue point.
2) Choose Cue points from the Edit menu.

3) Choose the Start marker radio button.
4) Choose the Add button.
5) Enter a name and description for the cue point.
6) Choose OK.

To move the start marker to a cue point:
1) Choose Cue points from the Edit menu.

2) Select the cue point from the list.
3) Choose the Start marker radio button.
4) Choose the Set button.

5) Choose OK.

To delete a cue point:
1) Choose Cue points from the Edit menu.

2) Select the cue point from the list.
3) Choose the Delete button.

Note:
Currently, cue points are fixed and do not change position when a sound is modified.    This should be 
considered when certain commands, such as delete, are used.    Any cues inside the deleted selection will 
not be deleted and the cues outside the selection will not be adjusted to account for the new positions.



Export Dialog

This dialog lets you save a sound in a wide variety of formats.    You are presented with two lists.    Use the 
left list to specify the file format and the right list to specify the attributes.    Note that not all attributes are 
supported by some formats.    Pick the format first to see what attributes are available.

After you have selected the format and attributes, choose the OK button.    You will then be presented with 
the standard file dialog where you can specify the filename for the exported file.

When exporting a file in certain formats such as Sun (.au), GoldWave automatically converts the data to a 
compatible sampling rate.

This command is useful when files must be used on platforms other than Microsoft Windows.



Keyboard Commands

Tip:
The Home and End keys allow you to quickly jump to the start and finish markers when zoomed in.

Keystroke Action
Shift+Del Remove block and copy it into the clipboard.
Ctrl+Ins Copy block into the clipboard.
Paste Copy clipboard into the active sound at the start marker's position.
Del Delete the block, permanently.
Shift+Ctrl+Ins Mix clipboard with the active sound at the start marker's position.
Ctrl+T Trim sound.    Removes all data outside the block.
Left Scrolls the active Sound window left.
Right Scrolls the active Sound window right.
Pg Up Scrolls the active Sound window left one screen.
Pg Dn Scrolls the active Sound window down right screen.
Home Redraws the active Sound window at the start marker's position.
End Redraws the active Sound window at the finish marker's position
Ctrl+Home Redraws the active Sound window at the beginning of the sound.
Ctrl+End Redraws the active Sound window at the end of the sound.
F1 Starts on-line help.
Alt+F6 Switch between Main window and Device Controls window.
Ctrl+F6 Switch between Sound windows.

Use the following keys when the Main window is active:
Space Plays a sound.
F4, F5, F6, F7, F8 Plays, fast forwards, pauses, rewinds, and stops respectively.
Pause Pauses a sound.
Esc Stops a sound.



Registering

GoldWave is a shareware program.    To register and encourage further development, please follow the 
directions in the ORDER.WRI file included with this program.    If this file is missing, you can send your 
name, address, check, and GoldWave version number to the address in Introducing GoldWave.

Please be sure to include sufficient postage (USA to Canada is about 40¢).
Due to the openness of the Internet, passwords cannot be sent by e-mail.

Standard Registration ($25 US)
You will receive a personalized password that will remove the startup shareware message and unlock all 
version of GoldWave.    The password will make all future versions of GoldWave fully functional.    This is 
equivalent to a lifetime of free updates!    All you have to do is download the latest version.

Deluxe Registration ($45 US)
You will receive a personalized password as above.    You will also receive a diskette and a spiral bound 
manual for the next version of GoldWave (when completed).    The diskette will contain a new version of 
GoldWave, some wave files, and a few other things.



GoldWave Shareware Version

This application is a fully functional shareware version of the GoldWave digital audio editor.    Shareware 
allows you to try a program before you buy it.    If you find GoldWave useful, you are required to register it 
(see Registering).

As shareware, you can give copies of GoldWave to anyone you think might find it useful.    You can also 
upload it to BBS or ftp sites and post it to appropriate forums or newsgroups.    Before copying, uploading, 
or posting, please click here.

If you experience any problems, the README.TXT file and the GOLDWAVE.WRI file include some 
information that may help.    GOLDWAVE.WRI is the manual in Write format.    It contains installation 
instructions, trouble shooting tips, and answers to common questions.



Only the original GoldWave zip file (gldwav21.zip) may be copied, uploaded, or posted.    This ensures 
that everyone will get a complete and working copy.    Distributing modified or incomplete copies is a 
violation of the copyright.




