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Signing In to Schedule+

You can work with Schedule+ online or offline. To use Schedule+ online, you must be connected to your 
postoffice.

To work with Schedule+ offline

From the File menu, choose Work Offline (ALT+F, W).

To work with Schedule+ online

From the File menu, choose Work Online (ALT+F, W).

Whether you work with Schedule+ offline or online, you must type your mail name and password.

To type your mail name and password

1 In the Sign In dialog box, type your mail name and password.
2 Choose the OK button.

See Also
Quitting Schedule+
Working Offline
Changing Your Password



Signing In to Schedule+

To use the group scheduling features of Schedule+, you must work with Schedule+ online.

Unless you select the Schedule+ option that instructs Schedule+ always to start up offline, Schedule+ 
always starts up online if you are connected to the postoffice. If you use Schedule+ offline, you don't 
need a connection to your postoffice.

Schedule+ ensures the privacy of your personal schedule information by asking you to sign in with your 
mail name and password before it displays your schedule.

If you are already signed in to Mail or the Schedule+ Reminders program is running, your sign-in 
information is validated by one of those programs. Schedule+ does not prompt you to sign in when you 
start.



Changing Your Password

To change your password

Note: If you start to change your password and then decide not to change it, choose the Cancel button. 
Your password will not be changed.

1 From the Options menu, choose Change Password (ALT+O, C).

2 In the Password box, type your current password.
For security, your password does not appear as you type it.

3 Choose the OK button. 
4 In the Password box, type your new password.
5 Choose the OK button.
6 In the Password box, type your new password again.

If the characters you type the second time do not match those you typed the first time, Schedule+ 
asks you to type your password again until they match.

7 Choose the OK button.

Note: If you use Mail, your Schedule+ password is the same password you use to sign in to Mail. 
Remember to use your new password the next time you sign in to Mail.

See Also
Signing In to Schedule+



Changing Your Password

If you're using Mail, your Schedule+ password is the same password you use to sign in to Mail. You can 
change your password at any time.

If you change your password in Schedule+, remember to use the new password the next time you sign 
in to Mail.

You can change your password while you are using Schedule+ offline. However, the password change 
will not be in effect the next time you work online with Schedule+. The next time you sign in to Schedule+ 
to work online, you must provide the password you had before you changed it offline.



Quitting Schedule+

You can quit Mail, the Schedule+ Reminders program, and Schedule+ in one step, or quit Schedule+ 
only.

To quit Schedule+ only

From the File menu, choose Exit (ALT+F4).

To quit Schedule+, the Schedule+ Reminders program, and Mail

From the File menu, choose Exit And Sign Out (ALT+F, T).

The next time Schedule+, Mail, or the Schedule+ Reminders program starts, you are asked for your 
mail name and password.

See Also
Signing In to Schedule+



Quitting Schedule+

When you quit Schedule+, your Schedule and Messages windows are closed.

If you quit only Schedule+ and leave Mail or the Schedule+ Reminders program running, you won't be 
prompted to sign in when you start Schedule+ again. If you quit Schedule+ and Mail separately, and 
leave the Schedule+ Reminders program running, you won't be prompted to sign in when you start 
Schedule+ or Mail again.

If you quit Schedule+, Mail, and the Schedule+ Reminders program, you are asked for your password 
the next time you start any one of the programs.



Changing the Date in the Appointment Book or Planner

To change the date you are viewing in the Appointment Book or Planner

Tip: To display today's page in your Appointment Book, click the Today tab at the left of the schedule 
window.

1 In the calendar, click the day you want to view.
2 In the month and year boxes, click the arrows to select the month and year.

Tip: If you're changing only the day of the week, press ALT and one of the arrow keys to select the 
day you want in the calendar. To change only the month, press SHIFT+ALT and one of the arrow keys to 
select the month you want to view.

1 From the Edit menu, choose the Go To Date command (CTRL+G) or the Go To Week 
command (CTRL+W). The Go To Week command is available only if you've set your options to display 
week numbers in the calendar.

2 In the Go To Date dialog box, use the LEFT and RIGHT ARROW keys to select the part of the 
date you want to change. Then type the correct number(s) over the selected number(s). In the Go To 
Week dialog box, type the number of the week you want to display.

3 Choose the OK button.



Changing the Date in the Appointment Book or Planner

The calendar makes it easy to change the date you are viewing in the Appointment Book or Planner. 

The current date has a border, and the selected date has a black box around it. The month and year are 
displayed at the top of the calendar.
Days that have scheduled appointments or daily notes are shown in bold.



Scheduling an Appointment

To schedule an appointment

Tip: A quick way to add an appointment with the default settings is to select the time slot you want and 
then type a brief appointment description in the selected time slot.

1 In the Appointment Book calendar, select the time slot for the appointment you want to schedule.
2 From the Appointments menu, choose New Appointment (CTRL+N).

3 To schedule this appointment in your Appointment Book as tentative, select the Tentative check box.
4 In the Description box, type a brief description of the appointment.

This description appears in the time slot when you view your Appointment Book.
5 To set a reminder for the appointment, select the Set Reminder For check box and specify how long 

beforehand you want to be reminded of the appointment.
6 To make this appointment private, select the Private check box and choose the OK button.

To copy an appointment

Tip: If the appointment you want to copy recurs more than a couple of times and in a pattern, it may be 
easier to make it recurring than to copy it manually.

1 In the Appointment Book, select the appointment you want to copy.
2 From the Edit menu, choose the Copy Appt command (CTRL+Y).

3 In the Appointment Book, select the day you want to move the appointment to.
4 In the Appointment Book, select the time slot you want to copy the appointment to.
5 From the Edit menu, choose the Paste command (CTRL+V).

6 To copy the same appointment to additional time slots, repeat steps 3 through 5 for each copy.

See Also
Changing or Deleting an Appointment
Scheduling a Recurring Appointment



Scheduling an Appointment

You can schedule an appointment in your own Appointment Book, and other users can give you access 
privileges to schedule or change appointments in their Appointment Books.

You can easily copy an appointment to other times or days in your Appointment Book, or to another 
user's Appointment Book, if you have appropriate access privileges. When you copy an appointment, the 
description, reminder setting, tentative setting, and private setting are also copied.

If you designate an appointment as "tentative," it appears in the appropriate time slot in your 
Appointment Book, but does not appear as a schedule conflict when other users view your schedule to 
set up meetings.

You can also invite people to an appointment (meeting) and schedule a conference room and other 
resources for it.

If an appointment occurs on a regular basis, you can make it a recurring appointment.



Scheduling a Recurring Appointment

You can designate a new or existing appointment as recurring.

To designate a new appointment as recurring

1 In the Appointment Book, select the time slot for the recurring appointment.
2 From the Appointments menu, choose New Recurring Appt (CTRL+R).

3 At the top of the Recurring Appointment dialog box, confirm the recurrence pattern and start date of 
the appointment. To change the information, choose the Change button; select the pattern and start 
date you want; then choose the OK button.

4 To change the start or end time for the appointment, select the part of the time you want to change in 
the Start or End box, and then click the up or down arrow to change the time or type the correct time 
over the selected time.

5 In the Description box, type a brief description of the appointment.
This description appears in the time slot when you view your Appointment Book.

6 To set a reminder for each appointment, select the Set Reminder For check box and specify how long 
beforehand you want to be reminded of the appointment.

7 To schedule this appointment in your Appointment Book as a tentative appointment, select the 
Tentative check box.

8 To make this appointment private, select the Private check box and choose the OK button.

To designate an existing appointment as recurring

1 In the Appointment Book, select the appointment you want to designate as recurring.
2 From the Appointments menu, choose New Recurring Appt (CTRL+R).

3 To make changes to the recurrence pattern shown in the This Appointment Occurs box, choose the 
Change button, make the changes, and then choose the OK button.

See Also
Changing or Deleting a Recurring Appointment
Scheduling an Appointment



Scheduling a Recurring Appointment

If you have an appointment that occurs on a regular basis, such as a weekly status meeting, you can 
designate it as a recurring appointment. You can specify an appointment as recurring while you are 
creating it, or you can designate an existing appointment as recurring.

When you designate an appointment as recurring, you only have to schedule it once. Schedule+ 
schedules all future occurrences of the appointment automatically for you in your Appointment Book. By 
default, recurring appointments are scheduled for a duration of one year, but for any recurring 
appointment, you can specify a different duration.

You can change or delete single or multiple occurrences of an appointment.



Setting Appointment Reminders

You can set a reminder for a new or existing appointment, or you can set a Schedule+ option to 
automatically set a reminder for each new appointment.

You can also turn off all reminders at once.

To set a reminder for a new appointment

1 In the Appointment Book, select the time slot for the appointment.
2 Double-click the selected time slot, or from the Appointments menu, choose New Appointment 

(CTRL+N).
3 In the Appointment dialog box, type a description for the appointment and select the settings you want.
4 Select the Set Reminder For check box.
5 If you want to be reminded earlier or later than the reminder time shown, delete the number and type a 

new number in its place. Click the down arrow to select minutes, hours, or days. Then choose the OK 
button.

To set a reminder for an existing appointment

Note: Use the following procedure to set a reminder for an existing appointment or for a single 
occurrence of a recurring appointment.

1 Select the appointment.
Tip: A quick way to set a reminder for the default time is to choose Set Reminder from the 
Appointments menu (CTRL+SHIFT+R).

2 Double-click the appointment, or from the Edit menu, choose Edit Appt (CTRL+E).

3 Select the Set Reminder For check box.
4 If you want to be reminded earlier or later than the reminder time shown, delete the number and type a 

new number in its place. Click the down arrow to select minutes, hours, or days. Then choose the OK 
button.

To set a reminder for all occurrences of a recurring appointment

1 From the Appointments menu, choose Edit Recurring Appts (ALT+M, C).

2 In the list of recurring appointments, double-click the recurring appointment you want to set a reminder 
for, or select it and choose the Edit button.

3 Select the Set Reminder For check box.
4 If you want to be reminded earlier or later than the reminder time shown, delete the number and type a 

new number in its place, then click the down arrow to select minutes, hours, days, weeks, or months.
5 Choose the OK button.
6 Choose the Close button.

To automatically set a reminder for each new appointment

1 From the Options menu, choose General Options (ALT+O, G).

2 In the Reminders box, select the Set Reminders Automatically check box.
3 If you want to be reminded earlier or later than the reminder time shown, select the new time, and then 

choose the OK button.
Any reminder you now set on an appointment displays this time as a default. You can change the 
reminder time for a specific appointment without affecting this default setting.

To turn off all reminders

From the File menu, choose Turn Off Reminders.

Reminders remain off until you turn them back on or until you restart Schedule+, Mail, or Windows.

To turn on all reminders



From the File menu, choose Turn On Reminders.

See Also
Scheduling an Appointment
Scheduling a Recurring Appointment



Setting Appointment Reminders

You can set a reminder for any upcoming appointment that is scheduled in your Appointment Book.

You can set the number of minutes, hours, days, weeks, or months in advance that you want the 
reminder to occur. If you set a reminder and do not specify a time, the reminder occurs 15 minutes 
before the appointment, unless you've changed the default reminder time in the Options menu.

You can set up Schedule+ to set reminders automatically for all new appointments. You can also turn all 
reminders on and off by choosing the Turn On/Off Reminders command from the File menu.



Changing or Deleting an Appointment

To change an appointment

Tips: To change the description of an appointment, select the appointment, delete the text in the time 
slot, and type the new description. To change the time of an appointment, select the appointment, click 
its top handle, and drag the appointment to the new time. To extend an appointment, select the 
appointment, click its bottom handle, and drag the handle to the new end time.

1 From the Appointment Book, select the appointment you want to change.
2 From the Edit menu, choose Edit Appt (CTRL+E).

3 In the Appointment dialog box, make the changes you want to the start or end times, description, 
reminder, private status, tentative status, or attendees.

4 Choose the OK button.

To delete an appointment from your Appointment Book

1 In your Appointment Book, select the appointment you want to delete.
2 From the Edit menu, choose Delete Appt (CTRL+D).

See Also
Changing or Deleting a Recurring Appointment
Scheduling an Appointment
Setting Appointment Reminders



Changing or Deleting an Appointment

You can change the times, date, and description of, as well as delete, any appointment booked in your 
Appointment Book. You can also change the reminder and privacy settings, and attendees and tentative 
status.



Changing or Deleting a Recurring Appointment

You can change or delete one or all occurrences of a recurring appointment.

To view a list of all recurring appointments

From the Appointments menu, choose Edit Recurring Appts (ALT+M, C).

To change a single occurrence of a recurring appointment

Note: The procedure for changing a single occurrence of a recurring appointment is the same as the 
procedure for changing a regular appointment.

1 In the Appointment Book, double-click the appointment you want to change.
2 In the Appointment dialog box, make the changes you want to the appointment and then choose the 

OK button.

To change all occurrences of a recurring appointment

1 From the Appointments menu, choose Edit Recurring Appts (ALT+M, C).

2 From the list of recurring appointments, double-click the recurring appointment you want to change, or 
select it and then choose the Edit button.

3 In the Recurring Appointment dialog box, make the changes you want.
4 To change the day(s) the appointment occurs on, choose the Change button, make the changes to the 

appointment's dates, then choose the OK button.
5 Choose the OK button.
6 Choose the Close button.

To delete a single occurrence of a recurring appointment

Note: The procedure for deleting a single occurrence of a recurring appointment is the same as the 
procedure for deleting a regular appointment.

1 From the Appointment Book, select the appointment you want to delete.
2 From the Edit menu, choose Delete Appt (CTRL+D).

To delete all occurrences of a recurring appointment

1 From the Appointments menu, choose Edit Recurring Appt (ALT+M, C).

2 From the list of recurring appointments, select the appointment you want to delete.
3 Choose the Delete button.
4 Choose the Close button.

See Also
Setting Appointment Reminders



Changing or Deleting a Recurring Appointment

You can quickly view a list of all your recurring appointments, including their descriptions, frequencies, 
and next occurrences. With this information at hand, you can decide whether to change or delete one or 
all occurrences of a recurring appointment.

If you change or delete single occurrences of a recurring appointment, the remaining occurrences are 
not affected.



Adding a Daily Note in the Appointment Book

To add a daily note in the Appointment Book

1 Display the Appointment Book by clicking the Appts tab at the left of the Schedule window.
2 Click inside the Notes box or press ALT+N to place the insertion point in the Notes box.
3 Type the text of your note.

To set a reminder for days you have daily notes

1 From the Options menu, choose General Options (ALT+O, G).

2 In the Reminders box, select the Set Reminders For Notes check box and then choose the OK button.

To delete a daily note

1 Display the Appointment Book.
2 In the Notes box, select the text you want to delete.
3 Press DEL.

See Also
Noting a Completed Task in Your Appointment Book



Adding a Daily Note in the Appointment Book

You can add daily notes to any day in your Appointment Book. Daily notes are usually items you want to 
remember for the day. They aren't associated with specific time slots. Daily notes do not appear when 
other users view your Appointment Book.

When you complete a task in your Task list, you can instruct Schedule+ to record it in the Notes section 
of your Appointment Book.

When you print your schedule, your daily notes are also printed.

When the Set Daily Reminder preference is on, Schedule+ reminds you with a message at the beginning 
of each day for which you have daily notes. The message lists your notes for the day.



Finding Text in the Appointment Book

To find a text string in the Appointment Book

1 From the Edit menu, choose Find (CTRL+F).

2 In the Search For box, type the character string you want to find.
3 Select the search method you want Schedule+ to use, and then choose the Start Search button.

As the search progresses, the percentage of your Appointment Book that has been searched is 
displayed.

When Schedule+ finds an occurrence of the string you're searching for, it displays your Appointment 
Book (if it is not currently displayed) for the day in which the string occurs and highlights the string.



Finding Text in the Appointment Book

You can search for a word, partial word, or group of words (up to 64 characters) that occur in an 
appointment or daily note in the Appointment Book.

You can search forward or backward from the current day, as well as throughout the entire Appointment 
Book.

If Schedule+ finds the character string, it displays the day of the first occurrence, with the string 
highlighted. You can view all occurrences of the string throughout the Appointment Book, one at a time.

When you search for text in another user's Appointment Book, Find searches only the appointments you 
have permission to view.



Saving (Archiving) Your Schedule

To save schedule information

1 From the File menu, choose Create Archive (ALT+F, A).

2 In the Archive Data Before box, type the date for which you want all preceding information archived, or 
use the up and down arrow buttons to change the date.

3 If the archive file specified in the Create Archive dialog box is incorrect, type the correct filename. 
Select the correct drive and directory, if those shown are not correct.
The default archive filename is the first eight characters of the schedule owner's mailbox name, with 
an .ARC extension in the Schedule+ directory. If the specified file already exists and is an archive file, 
the data will be added to the existing data in the archive file.

4 Choose the OK button.

To view archived schedule information

1 From the File menu, choose Open Archive.
2 In the archived Appointment Book window, you can view or make changes to the schedule.

Changes you make to the archived schedule are saved in the archive file.
3 To exit the archived schedule, close the archive Appointment Book window.



Saving (Archiving) Your Schedule

You can store old schedule information in a file where you can view and modify its contents. After the 
information in a schedule is archived, it is removed from your schedule. You can delete old schedule 
information or archive it.

You can store your personal schedule information in one archive file or several. In most cases, it is best 
to store it in one file.

You can make the same types of changes to the Appointment Book in the archive that you can to a 
current Appointment Book. These changes are saved in the archive when you close it.



Adding a Project

To add a project to your Task list

1 Display the Task list.
2 From the Tasks menu, choose New Project (ALT+K, P).

3 In the Name box, type the name of the new project.
4 To make this project private, select the Private check box.
5 Choose the OK button.

Note: If the new project doesn't appear in the Task list, you're viewing your tasks with no projects shown. 
To view your tasks with their projects, choose View By Project from the Tasks menu (CTRL+SHIFT+V).

See Also
Adding a Task
Changing or Deleting a Task or Project
Displaying Your Task List
Sorting and Displaying Your Projects and Tasks



Adding a Project

You can group related tasks into categories you define, which are called "projects." Tasks do not have to 
be part of a project, although if you have several related tasks, you may find it convenient to create a 
project under which to group them. Project names appear in the Task list in bold, and the tasks 
associated with them appear under the project names.

Projects do not have priorities associated with them, although the individual tasks they contain may.

You can view your tasks by project, or as a list with no project names shown.

You can designate a new or existing project as private. This makes all tasks (including existing tasks) 
under the project private, regardless of whether you designated the individual tasks as private or not.



Adding a Task

You can add a new task or copy an existing one.

To add a new task

Tip: To add a task with the default settings, click the project you want to add the task to, type the new 
task's description in the New Task box at the top of the Task list, and then choose the Add button.

1 Display the Task list.
2 From the Tasks menu, choose New Task (CTRL+T).

3 In the Description box, type a brief description of the task.
4 In the Project box, use the arrow buttons to select the name of the project you want to add the task to. 

If you don't want to associate this task with any project, select "None."
5 To associate this task with a specific due date, select the By option button and use the arrow buttons 

to select the due date.
To assign no due date, select the None option button.

6 To specify when this task becomes active, type a number in the Start Work box. Use the arrow button 
to select Days, Weeks, or Months in the Before Due box.

7 To set a reminder for this task, select the Set Reminder check box. You must set a Due Date before 
you can set a reminder.

8 To change the task's priority, in the Priority box use the arrow buttons to select the priority level for the 
task, or type the new priority level.

9 To designate this task as private, select the Private check box and then choose the OK button.

To copy a task to another project

1 Display the Task list.
2 Select the task you want to copy.
3 While pressing CTRL, drag the task to the project you want to copy it to.

See Also
Adding a Project
Changing or Deleting a Task or Project
Displaying Your Task List
Adding a Recurring Task
Setting Task Reminders
Sorting and Displaying Your Projects and Tasks



Adding a Task

You can add tasks to your Task list anytime. A task can be part of a project, or it can be independent. If a 
task is part of a project, it is displayed with the other tasks in that project.

You can assign a task a priority between 1-9 or A-Z. Priority 1 is the highest possible priority (including 
letter priority levels), and Z is the lowest possible priority (including number priority levels). The default 
priority is 3 (or C, if you are using only letter priority levels). Number priority levels are higher (more 
important) than letter priority levels. You can change a task's priority at any time by using the up and 
down arrow buttons at the bottom of the Task list.

You can also assign optional due dates to tasks and specify how long before the due date you want the 
task to become "active." If you set a reminder for a task, Schedule+ reminds you of the task when it 
becomes active. When you copy a task, its due date and other settings are also copied.

Users who have access privileges to view your schedule can also view your Task list. However, tasks 
you've designated as private are not visible to other users when they view your list.



Sorting and Displaying Your Projects and Tasks

Note: For all views of your tasks, past-due tasks are displayed in red.

To view your tasks by project

From the Tasks menu, choose View By Project (CTRL+SHIFT+V).

A check mark appears next to View By Project.

To view your tasks as a list with no projects shown

From the Tasks menu, choose View By Project (CTRL+SHIFT+V).

The check mark next to View By Project disappears.

Whether you are viewing your tasks by project or not, you can sort them by priority, due date, or 
description.

Tip: To sort your tasks in reverse priority, due-date, or alphabetic order, press the CTRL key while you 
click the appropriate button at the top of the list or choose the appropriate command from the Tasks 
menu.

To sort your tasks by priority

In your Task list, click the Priority button at the top of the list or choose the Sort By Priority 
command from the Tasks menu (ALT+K, I).

To sort your tasks by due date

In your Task list, click the Due By button at the top of the list or choose the Sort By Due Date 
command from the Tasks menu (ALT+K, B).

To sort your tasks by description

In your Task list, click the Description button at the top of the list, or choose the Sort By 
Description command from the Tasks menu (ALT+K, D).

You can view all tasks or only active tasks, regardless of how your tasks are sorted.

To view only your active tasks

From the Tasks menu, choose Show Active Tasks (ALT+K, A).

If the Show Active Tasks command is not in the Tasks menu, the Task list is already displaying only 
your active tasks. 

To view all of your tasks

From the Tasks menu, choose Show All Tasks (ALT+K, A).

If the Show All Tasks command is not in the Tasks menu, all your tasks are already displayed.

See Also
Adding a Project
Adding a Task
Changing or Deleting a Task or Project



Sorting and Displaying Your Projects and Tasks

You can sort your tasks in ascending or descending order by priority, due-date, or description. You can 
view your tasks sorted in a variety of ways, as a flat list, or as collections of tasks organized by project. 
You can also view all your tasks, or only the active ones. 

When you're viewing your Task list, the status bar at the bottom of the Schedule+ workspace indicates 
whether you're viewing all your tasks or only the active ones.

When you're viewing your tasks by project, the priority, due date, and description sorts are completed on 
a per-project basis. For example, if you are viewing your tasks by project and you sort by priority, the 
tasks under each project are displayed from highest to lowest priority. To view all tasks sorted by priority, 
rather than by priority within a project, view them as a flat list instead of by project.

Printouts of your schedule reflect the current Tasks display. For example, if you are viewing only your 
active tasks when you print your task list, the printout includes only your active tasks.



Adding a Recurring Task

To designate a new task as recurring

1 From the Tasks menu, choose New Recurring Task (ALT+K, R).

2 In the Description box, type a description of the task.
3 In the Project box, use the arrow button to select the name of the project you want to add the task to. If 

you don't want to associate this task with any project, select "None."
4 To change the default due date displayed in the Due By box, choose the Change button, select the 

new due date, and then choose the OK button.
5 To specify how long before the due date the task becomes active, type a number in the Start Work box 

and use the arrow button to select Days, Weeks, or Months in the Before Due box.
6 To set a reminder for this task, select the Set Reminder check box.
7 To change the task's priority, in the Priority box, use the arrow buttons to select the priority level for the 

task.
8 To designate this task as private, select the Private check box.
9 Choose the OK button.

See Also
Adding a Task



Adding a Recurring Task

If you have a new task that occurs on a regular basis, such as a weekly status report, you can set it up 
as a recurring task.

When you designate a task to be recurring, you only have to schedule it once. Schedule+ schedules all 
future occurrences of the task automatically for you in your Task list.

You can designate any new task to be recurring.

You can change or cancel single or multiple occurrences of a recurring task.



Changing or Deleting a Task or Project

To change a task

Tips: A quick way to change a task's priority level is to select the task and then click the up or down 
arrow button at the bottom of the Task list. A quick way to move the task to another project without 
changing any of its settings is to select the task, drag it to the project you want, and then release the 
mouse button.

1 In the Task list, double-click the task you want to change, or select it and press ENTER.

2 In the Task dialog box, make the changes you want and then choose the OK button.

To delete a task

1 In the Task list, select the task you want to delete.
2 Choose the Delete button.

To change a project

1 In the Task list, double-click the project you want to change, or select it and press ENTER.

2 In the Name box, delete the name and type the new project name in its place.
3 Choose the OK button.

To delete a project and its tasks

1 In the Task list, select the project you want to delete.
2 Choose the Delete button.
3 When Schedule+ notifies you that all tasks in this project will also be deleted, choose the OK button.

To delete a project without deleting its tasks

Tip: If your Task list already has tasks associated with a project, a quick way to move a task from a 
project to no project is to select the task you want to move, drag it to the tasks that have no project, then 
drop the task you're moving onto the tasks that have no project.

1 For each task in the project, change the project name to "None" by double-clicking the task (or 
selecting it and pressing ENTER), selecting None in the Project box, and then choosing the OK button. 
Repeat this step for each task in the project.

2 In the Task list, select the project you want to delete.
3 Choose the Delete button.

See Also
Adding a Project
Adding a Task
Changing a Task's Priority
Changing or Deleting a Recurring Task



Changing or Deleting a Task or Project

With Schedule+, you can change or delete any task or project. 

When you delete a project, the tasks within it are automatically deleted unless you move them to another 
project first.



Changing or Deleting a Recurring Task

You can change or delete one or all occurrences of a recurring task.

To view a list of your recurring tasks

From the Tasks menu, choose Edit Recurring Tasks (ALT+K, C).

To change a single occurrence of a recurring task

Note: The procedure for changing a single occurrence of a recurring task is the same as the procedure 
for changing a regular task.

1 From the Task list, double-click the task you want to change.
2 In the Task dialog box, make the changes you want.
3 Choose the OK button.

The changed occurrence now appears in your Task list separately from the recurring task.

To change all occurrences of a recurring task

1 From the Tasks menu, choose Edit Recurring Tasks (ALT+K, C).

2 From the list of recurring tasks, double-click the task you want to change, or select it and then choose 
the Edit button.

3 In the Recurring Task dialog box, make the changes you want.
4 To change the day(s) the task occurs on, choose the Change button, make the changes to the task's 

dates, then choose the OK button.
5 Choose the OK button.
6 Choose the Close button.

To delete a single occurrence of a recurring task

Note: The procedure for deleting a single occurrence of a recurring task is the same as the procedure 
for deleting a regular task.

1 In the Task list, select the task you want to delete.
2 Choose the Delete button.

To delete all occurrences of a recurring task

1 From the Tasks menu, choose Edit Recurring Tasks (ALT+K, C).

2 From the list of recurring tasks, select the task you want to delete.
3 Choose the Delete button.
4 Choose the Close button.

See Also
Adding a Task
Adding a Recurring Task



Changing or Deleting a Recurring Task

You can quickly view a list of all your recurring tasks, including their descriptions, frequencies, and next 
occurrences.

If you change or delete specific occurrences of a recurring task, the remaining occurrences are not 
affected.



Changing a Task's Priority

To give a task a higher priority

1 Display your Task list.
2 Select the task you want to give a higher priority.
3 Click the up arrow button at the bottom of your Task list until the number or letter in the Priority column 

for the task reflects the priority you want.

To give a task a lower priority

1 Display your Task list.
2 Select the task you want to give a lower priority.
3 Click the down arrow button at the bottom of your Task list until the number or letter in the Priority 

column for the task reflects the priority you want.

See Also
Adding a Task
Displaying Your Task List



Changing a Task's Priority

Unless you specify a different priority level, all tasks are assigned a priority of 3 (or C if you are using 
only letters as priorities). You can change a task's priority anytime.



Setting Task Reminders

To set a task reminder

1 In the Task list, double-click the task you want to set a reminder for, or select it and press ENTER.

The task you select must have a specific due date.
2 In the Task dialog box, select the Set Reminder check box.
3 If you have not already selected a time to start work, specify a number in the Start Work box, and use 

the arrow button to select days, weeks, or months.
At the time you specify before the task's due date, the reminder will occur, signaling that the task has 
become active.

4 Choose the OK button.

See Also
Adding a Task
Changing or Deleting a Task or Project



Setting Task Reminders

You can set a reminder for any task that has a specific due date. A reminder is a pop-up message that 
occurs on the first day that the task becomes active. For example, if you set the Start Work time for one 
day before the task's due date, the reminder occurs the day before the due date.

You can turn all reminders off or on, and specify whether reminder pop-up messages are accompanied 
by an audible bell.



Noting a Completed Task in Your Appointment Book

To note a completed task in your Appointment Book

1 Display the Task list.
2 Select the task you want to note in your Appointment Book as completed.
3 Choose the Completed button (ALT+C).

The description text of the task appears in the Notes section of your Appointment Book, and the task is 
removed from your Task list. 

See Also
Displaying Your Task List
Sorting and Displaying Your Projects and Tasks



Noting a Completed Task in Your Appointment Book

As you complete a task, you can record your accomplishment in your Appointment Book. Tasks you note 
as completed appear in the Notes section of your Appointment Book.

For example, suppose that today you completed the task described as "Send invoices." When you add 
this completed task to your Appointment Book, the note "Done: Send invoices" appears in today's Notes 
section.

By using the Find command from the Edit menu, you can search for the string "done" to view tasks 
you've completed.



Adding a Task to Your Appointment Book

You can add a task from your Task list to a specific time slot in your Appointment Book.

To add a task to your Appointment Book

1 In the Task list, select the task you want to add to your Appointment Book.
2 Choose the Add To Schedule button.
3 In the Choose Time dialog box, select the time slot and day the task will occupy in your Appointment 

Book.
4 Choose the OK button.

Note: When you add a task to your Appointment Book, it is not removed from your Task list.

See Also
Sorting and Displaying Your Projects and Tasks



Adding a Task to Your Appointment Book

As you work, you may want to schedule a specific time in your Appointment Book for a task. You can 
easily add the task to your Appointment Book.

When you add a task to your Appointment Book, it is not removed from your Task list.



Printing Your Appointments and Daily Notes

To print your appointments and daily notes

1 Display your Appointment Book.
2 From the File menu, choose Print (CTRL+P).

3 In the Schedule Range box, select the days you want to print. If you are printing your Task list, all 
tasks will be printed. You do not select a range.

4 In the Print box, click the arrow to select the way you want your printout organized.
5 In the Print Quality box, select the quality of printing you want.
6 In the Paper Format box, select the size of printout you want. To customize the margins for a different 

printout size, choose the Setup button, adjust the Margins settings, and then choose the OK button.
7 Choose the OK button.

See Also
Displaying Your Appointment Book
Printing Your Tasks



Printing Your Appointments and Daily Notes

You can print your schedule in a daily, weekly, monthly, or text format. 

Daily is divided into 30-minute time slots and shows your schedule for each day you specify.
Weekly is divided into 7 one-day time slots for each week you specify.
Monthly is divided into 30 (or 28 or 31) one-day time slots for each month you specify.
Text lists your appointments and notes for the day, without displaying them in 30-minute time 

slots.
You can print any of these ways in three set sizes or with margins you specify. You can print your 
schedule in a size that fits your notebook.

You can print up to 99 months of your schedule, and you can print your schedule for specific days or 
ranges of dates.



Printing Your Tasks

To print your tasks

1 Display the Task list.
2 Display all your tasks or just the active ones.
3 Display your tasks by project or as a flat list.
4 Sort your tasks by priority, due date, or description.
5 From the File menu, choose Print (CTRL+P).

6 In the Print box, click the down arrow button to display a list of options, and then select Tasks.
7 Choose the OK button.

See Also
Displaying Your Task List
Printing Your Appointments and Daily Notes
Sorting and Displaying Your Projects and Tasks



Printing Your Tasks

You can print your tasks in any sorting and viewing combination that you can display on your screen.

If your printout doesn't include the tasks or projects you expect, check the Tasks menu to confirm your 
viewing configuration. You may have your Task list set up to display only active tasks, or to omit project 
names.



Working Offline

The procedure for working offline depends on whether you are currently running Schedule+.

To work offline if you are running Schedule+

From the File menu, choose Work Offline (ALT+F, W).

To work offline if you are not running Schedule+

1 Disconnect from your postoffice.
2 Start Schedule+.
3 If you are prompted to let Schedule+ create a local schedule file for you, choose the OK button.
4 If you are prompted for the location of your existing local schedule file, type it in the space provided.

Note: You can set up Schedule+ to automatically start up offline by choosing the General Options 
command from the Options menu.

See Also
Signing In to Schedule+
Making or Changing Schedule+ Settings



Working Offline

You are working offline when you work with your schedule while your computer does not have a 
connection to your postoffice. Working offline is convenient when the postoffice is experiencing problems 
or you want to work with your schedule on a portable or home computer. You can set up Schedule+ to 
start offline automatically.

When you work offline, you use a local copy of your schedule file instead of the copy on the postoffice. 
The next time you work with Schedule+ online, the changes you made offline are automatically merged 
into your schedule file on the postoffice.

While working offline, you can add appointments to your Appointment Book and work with your Task list. 
However, the group scheduling and viewing features of Schedule+ are not available because those 
features require a connection to the postoffice.



Moving Your Local Schedule File

To move your local schedule file

1 From the File menu, choose Move Local File (ALT+F, L).

2 In the Drives box, specify the drive for the file.
3 In the Directories box, select the directory for the file, and then choose the OK button.

See Also
Working Offline



Moving Your Local Schedule File

You can move your local file to a floppy disk so you can work on your schedule from a portable or home 
computer.



Copying Information to Another Program

To copy information to another schedule program

1 From the File menu, choose Export Appointments (ALT+F, E).

2 In the File Format box, select the file format in which you want to copy (export) your schedule.
3 Select the schedule range to copy by selecting the From option button and specifying the range, or by 

selecting the All option button to copy the whole schedule.
4 To copy daily notes, select the Include Daily Notes check box. Then choose the OK button.
5 In the File Name box, type the name of the file you want to copy your schedule to and then select the 

correct drive and directory to copy to, if the locations shown aren't correct.
6 Choose the OK button.

See Also
Merging Information from Another Program



Copying Information to Another Program

You can copy (or export) your appointments to a floppy disk so you can work on your schedule from 
another computer, or to a file that is compatible with other schedule products.

You can create the export file in one of two different formats: Schedule+ or readable text. 

The default file format is Schedule+. If you've exported a Schedule+ file before to a different format, the 
default file format is the last format you exported a file to.

If you don't specify a file extension, the standard extension for the specified or default file format is used. 
The standard extension for Schedule+ format is .SCH. The standard extension for text format is .TXT.



Merging Information from Another Program

To merge information from another schedule program

1 From the File menu, choose Import Appointments (ALT+F, I).

2 In the File Name box, type the name of the file you want to copy into your schedule, and select the 
correct drive and directory to copy from, if the locations shown aren't correct. Then choose the OK 
button.

3 In the Import File From box, select the type of schedule program you want to copy your schedule from.
4 To copy all appointments, including duplicate and conflicting appointments, select the Add All 

Appointments option button.
5 To copy all appointments except duplicates, select the Do Not Add Duplicate Appointments option 

button.
6 To instruct Schedule+ to prompt you before copying conflicting appointments, select the Ask About 

Conflicting Appointments option button.
7 Choose the OK button.

Schedule+ attempts to recognize and preselect the format of the file you are importing. If no file format is 
selected, you must select one.

Note: If you cancel the import process before it is complete, appointments that have already been added 
(imported) to your Appointment Book will not be removed.

You must have access privileges to create or modify appointments and tasks on the schedule you're 
copying information to.

See Also
Copying Information to Another Program
Working Offline



Merging Information from Another Program

You can copy (or import) information into your schedule from compatible schedule products, such as 
Windows 3.0 Calendar or WordPerfect Office. If you've been working on your schedule on a portable or 
home computer, you can copy the changes you made offline into your online schedule.

You can instruct Schedule+ to point out each conflicting appointment it encounters; you can decide 
whether to replace the existing appointment with the imported one or to maintain both in your 
Appointment Book. If you do not choose to be notified of schedule conflicts, Schedule+ adds all 
conflicting appointments to your Appointment Book.

You can instruct Schedule+ not to duplicate appointments that already exist in your Appointment Book. 



Making or Changing Schedule+ Settings

To make or change Schedule+ display settings

1 From the Options menu, choose Display (ALT+O, D).

2 In the Display dialog box, select or change any of the settings.
3 Choose the OK button.

To make or change general Schedule+ options

1 From the Options menu, choose General Options (ALT+O, G).

2 In the General Options dialog box, select or change any of the settings.
3 Choose the OK button.

Note: Using the Windows Control Panel, you can also easily customize the formats for the time and date 
in your schedule.

See Also
Displaying or Removing the Status Bar



Making or Changing Schedule+ Settings

Schedule+ has the following options, which you can customize:

The type and timing of reminders.
Whether week numbers of the year are displayed in the calendar.
What time your day starts and ends.
Whether you automatically start Schedule+ offline.
Which day every week starts on.
Whether the schedule account is for a resource. (Resources are special accounts, such as for 

conference rooms, equipment, and other services.)
The color of your Appointment Book.
The colors of your Planner.
The font size for Appointment Book entries.

Using the Windows Control Panel, you can also customize the formats for the time and date displays in 
your schedule.



Displaying or Removing the Status Bar

To display the status bar

From the Options menu, choose Status Bar (ALT+O, S).
When the status bar is on, a check mark appears next to the Status Bar command in the Options 
menu.

To remove the status bar

From the Options menu, choose Status Bar (ALT+O, S).

When the status bar is turned off, there is no longer a check mark next to the Status Bar command in 
the Options menu.

See Also
Making or Changing Schedule+ Settings



Displaying or Removing the Status Bar

Schedule+ provides an optional status bar that appears at the bottom of your Schedule+ workspace. 
When you choose a menu or command, the status bar summarizes the purpose of the menu or 
command.

When you're not choosing a command, the status bar displays today's date and time, regardless of the 
day or time you are currently viewing in the Appointment Book, Planner, or Task list. 

When you're working in your Appointment Book or Planner, the status bar also displays the currently 
selected time slot. When you're working in your Task list, the status bar indicates today's day and time, 
and indicates whether all tasks or only active tasks are currently displayed.



Tracking Appointments by Associated Projects

To track appointments by the projects they're associated with

1 For each appointment you make that's associated with a specific project or billing system, type the 
project name as the first part of the appointment's description.

2 When you need a report of the time spent on specific projects, export your schedule to a file, using the 
text (.TXT) format.

3 From a spreadsheet or database program, open the exported file.
4 In the spreadsheet or database program, sort the schedule information by project name.

See Also
Scheduling an Appointment
Copying Information to Another Program



Tracking Appointments by Associated Projects

If you want to track your appointments by project or client for a specific purpose (such as billing), you 
can use the Export Appointments command to prepare a copy of your appointments that you can sort in 
a spreadsheet or database program.

You continue to use your schedule as your normally do, but for each appointment related to a specific 
project or client, you must type the text you use to identify the project as the first part of the 
appointment's description. For example, the text may be the client's name or billing code.



Setting Up a Meeting

You can set up a meeting from your Planner or Appointment Book.

Tips

If the attendees list includes people you don't want to include, you can quickly remove them from 
the meeting arrangements by clicking their names in the Attendees box. This removes their schedule 
information from the Planner and prevents their names from being included in your meeting request.

If you're inviting individuals who are on a mail group name, you can choose the Details button in 
the address list to display the individual names of the group members, and then select and add each 
member of the group individually before pressing the OK button. You can easily see which members are 
busy during which time slots.

To quickly select a time when everyone's available, select a time slot anywhere in the grid that is 
as long as the meeting will be. Then, from the Appointments menu, choose Auto-Pick (CTRL+A).

To set up a meeting from the Planner

1 Display your Planner.
2 If the names in the Attendees box aren't those of the people you want to invite, choose the Change 

button and select the correct name(s) from the address list. Then choose the OK button.
If the name of a person you want to invite isn't in the address list currently shown, check another 
address list. You can view other address lists the same way you do in mail.

3 Select a time slot for the meeting, based on the times when all attendees are available.
4 Choose the Request Meeting button.
5 In the Subject box, type a brief description of the meeting.

The subject of the meeting message is also the description of the appointment when it's scheduled in 
an Appointment Book.

6 If you don't want recipients to send a personal response, cancel the selection of the Ask For 
Responses check box.

7 In the message area, type any message you want to include in your meeting request.
8 Choose the Send button.

To set up a meeting from the Appointment Book

Tip: A quick way to select a time when everyone's available is to choose the Auto-Pick button (CTRL+A). 
Then choose the OK button.

1 Display your Appointment Book.
2 Select a proposed time slot for the meeting. (You can change the time after you view the other 

attendees' schedules, if you discover they cannot attend.)
3 From the Appointments menu, choose New Appointment (CTRL+N).

4 Choose the Choose Time button.
5 In the Attendees box, choose the Change button and select the correct name(s) from the address list. 

Then choose the OK button.
6 Select a time slot for the meeting, based on the times when all attendees are available, and then 

choose the OK button.
7 In the Description box, type a brief description of the meeting and then choose the OK button.
8 If you don't want recipients to send a personal response, cancel the selection of the Ask For 

Responses check box.
9 In the message area, type any message you want to include in your meeting request. Then choose 

the Send button.

To read a response to your meeting request

Tip: When you are in the Messages window, you can bypass steps 2 and 3 by double-clicking the 
meeting response you want to read.



1 From the Window menu, choose Messages.
2 Select the meeting response you want to read.
3 Choose the Read button (ALT+R).

See Also
Displaying Your Appointment Book
Displaying Your Planner
Rescheduling or Canceling a Meeting
Scheduling a Conference Room or Other Resource



Setting Up a Meeting

You can quickly set up a meeting with the Planner or Appointment Book. Schedule+ makes it easy to find 
times when all attendees are available, and to send and respond to meeting requests.

After you find a possible time for a meeting, you send a Meeting Request form to invite the attendees. 
Your request arrives in their Messages window (and in their Mail Inbox, if they're running Mail). Their 
replies arrive in your Messages window (and in your Mail Inbox, if you're running Mail).

You can immediately see whether the respondent will attend your meeting. A check mark means the 
respondent has accepted the request; an "X" means the respondent has declined; a question mark 
means the respondent is not sure he or she will attend. Read any messages that might include 
additional information. Responses you haven't read are in bold.



Responding to a Meeting Request

To respond to a meeting request

Tip: When you are in the Messages window, you can bypass steps 2 and 3 by double-clicking the 
meeting request you want to reply to.

1 From the Window menu, choose Messages.
2 Select the meeting request you want to respond to.
3 Choose the Read button (ALT+R).

4 If you want to check your schedule before responding, choose the View Schedule button (ALT+S).

5 Choose the Accept, Decline, or Tentative button to send your response. If you choose Accept or 
Tentative, the meeting is automatically booked in your Appointment Book as an appointment or 
tentative appointment.

6 If you want to add a note to your response, type it in the message area.

If you decline a meeting request but it is still in your Messages window, you can reply to it again to 
change your response.



Responding to a Meeting Request

The Messages window lists responses to your meeting requests and requests from others to attend 
meetings. The Messages window is available when you are connected to the postoffice. In your Mail 
Inbox, Schedule+ messages look like standard Mail messages.

When responding to a meeting request, you can accept, decline, or tentatively accept. You can also 
include additional information with your response.



Rescheduling or Canceling a Meeting

To reschedule a meeting

1 Display your Appointment Book.
2 In the Appointment Book, move the meeting to its new time slot.
3 When Schedule+ asks you whether you want to notify the attendees of the change, choose the Yes 

button.
Schedule+ displays a Meeting Request form.

4 To add a personal note to the Meeting Request form, type it in the message area.
5 Choose the Send button.

Attendees receive a new meeting request for the new time; they can accept, decline, or tentatively 
accept.

To cancel a meeting

1 Display your Appointment Book.
2 In the Appointment Book, select the meeting.
3 From the Edit menu, choose Delete Appt (CTRL+D).

4 When Schedule+ asks you whether you want to notify the attendees of the cancellation, choose the 
Yes Button.
Schedule+ displays a Cancel Meeting form.

5 To add a personal note to the Cancel Meeting form, type it in the message area.
6 Choose the Send button.

Attendees receive Meeting Cancellation forms notifying them of the cancellation. 

See Also
Displaying Your Appointment Book
Setting Up a Meeting



Rescheduling or Canceling a Meeting

When you reschedule or cancel (delete) a meeting, Schedule+ guides you through the steps for notifying 
the attendees.



Scheduling a Conference Room or Other Resource

To schedule a room or resource while you are scheduling a meeting

Include the room or resource in the Attendees list. 

To schedule a room or resource without inviting people to a meeting

Tip: A quick way to select a time when both you and the resource are available is to select a time slot 
anywhere in the grid that is as long as the meeting will be. Then, from the Appointments menu, choose 
Auto-Pick (CTRL+A). 

1 Display your Planner.
2 If the conference room or resource isn't in the Attendees box, choose the Change button and select 

the name of the room or resource from the address list. Then choose the OK button. 
If the name of the resource you want to invite isn't in the address list currently shown, check another 
address list. You can view other address lists the same way you do in mail.

3 Select a time slot for using the resource, based on the times when it is available.
4 Choose the Request Meeting button.
5 In the Subject box, type a brief description of the meeting (optional).
6 In the message area, type any message you want to include in your meeting request (optional).
7 Choose the Send button.

If the room or resource has been set up so that you can enter your own requests in its Appointment 
Book, the appointment is booked automatically. If an assistant controls the schedule for the resource, he 
or she sends you a reply to your request.

See Also
Adding or Removing a Resource
Displaying Your Planner
Rescheduling or Canceling a Meeting
Setting Up a Meeting



Scheduling a Conference Room or Other Resource

You can schedule a conference room, piece of equipment, or other group resource. You can confirm the 
availability of a conference room or other resource by comparing its schedule to yours, just as you do 
with attendees when you set up a meeting. 

You can set up Appointment Books for conference rooms and other resources, and determine whether 
there is an assistant for each room or resource. If you do not assign an assistant to a room or resource, 
users can book their time slots in its Appointment Book directly.



Viewing Users' Access Privileges for Your Schedule

To view users' access privileges for your schedule

1 From the Options menu, choose Set Access Privileges (ALT+O, A).

The default access privilege for all users are displayed in the Users box. The Users box also indicates 
any other users (including an assistant) for whom you've set specific (nondefault) access privileges, in 
addition to their privileges.

2 Choose the OK button.

See Also
Designating an Assistant for Your Schedule
Setting or Changing Users' Access Privileges for Your Schedule



Viewing Users' Access Privileges for Your Schedule

You can view a specific user's access privilege for your schedule, as well as the default access privilege 
for all users.

When you assign a user a specific access privilege, that privilege overrides the default access privilege 
that applies to all users.

Similarly, designating a specific appointment, task, or project as private overrides the specific access 
privilege you have given a user, as well as the default access privilege for all users. No user (including 
your assistant) can view an appointment, task, or project that is marked private, even if he or she has the 
necessary access privilege to view or modify your appointments.



Setting or Changing Users' Access Privileges for Your Schedule

To set or change a user's access to your schedule

Tip: To quickly give a user the default access privilege you've assigned to all users, select the user's 
name and then choose the Remove button.

1 From the Options menu, choose Set Access Privileges (ALT+O, A).

2 If the user's name is already in the Users box, select it.
If the user's name isn't in the Users box, choose the Add button, then select the user's name from the 
address list. Choose the Add button, then choose the OK button. Then select the user's name in the 
Users box.

3 In the Privileges box, select the privilege you want to assign:
None
View Free/Busy Times
Read Appointments & Tasks
Create Appointments & Tasks
Modify Appointments & Tasks
Assistant

4 Choose the OK button.

See Also
Designating an Assistant for Your Schedule
Setting or Changing Users' Access Privileges for Your Schedule
Viewing Users' Access Privileges for Your Schedule



Setting or Changing Users' Access Privileges for Your Schedule

With Schedule+, you can give all users the same access privileges to your schedule. You can give 
individual users specific privileges, while other users have the default access privileges. You can view or 
change users' access privileges for your schedule anytime you are working online.

If you do not give individual users specific access privileges for your schedule, they have the default 
access privilege for all users. You can view this default by choosing the Set Access Privileges command 
from the Options menu.

When you give an individual user a specific access privilege, that access privilege overrides the default 
access privilege that applies to all users.

You can also designate an appointment or task to be private. This overrides other users' access 
privileges for that appointment, whether they have the default privilege for all users or privileges you 
specifically assigned to them.



Designating an Assistant for Your Schedule

To designate another user as your assistant

1 From the Options menu, choose Set Access Privileges (ALT+O, A).

2 If the user's name is already in the Users box, select it.
If the user's name isn't in the Users box, choose the Add button, then select the user's name from the 
address list. Choose the Add button, then choose the OK button. Then select the user's name in the 
Users box.

3 In the Privileges box, select the Assistant option button.
4 Choose the OK button.

Note: You can have only one assistant for your schedule at a time.

To change your assistant

1 From the Options menu, choose Set Access Privileges (ALT+O, A).

2 In the Users box, select your assistant's name.
3 In the Privileges box, select the option buttons granting the user's new access privilege for your 

schedule. 
To give this user the default access privilege you've assigned to all users, choose the Remove button. 
The user's name is removed from the Users box, and the user now has the default access privilege to 
your schedule.

4 If the name of your new assistant is already in the Users box, select it.
If the user's name isn't in the Users box, choose the Add button, then select the user's name from the 
address list. Choose the Add button, then choose the OK button. Then select the user's name in the 
Users box.

5 In the Privileges box, select the Assistant option button.
6 Choose the OK button.

To instruct Schedule+ to send meeting messages to your assistant, without copying you

1 From the Options menu, choose General Options (ALT+O, G).

2 Select the Send Meeting Messages Only To My Assistant check box.
3 Choose the OK button.

To remove your assistant

1 In the Options menu, choose Set Access Privileges (ALT+O, A).

2 In the Users box, select your assistant's name.
3 In the Privileges box, select the option buttons granting the user's new access privilege for your 

schedule. 
To give this user the default access privilege you've assigned to all users, choose the Remove button. 
The user's name is removed from the Users box, and the user now has the default access privilege to 
your schedule.

4 Choose the OK button.

See Also
Setting or Changing Users' Access Privileges for Your Schedule
Viewing Users' Access Privileges for Your Schedule



Designating an Assistant for Your Schedule

You can designate a user to be your assistant, a person who has the necessary access privilege to 
modify your schedule, but who cannot view or change appointments or tasks you've designated as 
private. Your assistant can add, delete, and modify appointments in your Appointment Book, and can 
send and respond to meeting requests on your behalf.

Appointments that your assistant creates, and meeting requests and responses sent by your assistant, 
are identified as being handled by your assistant. You can have only one assistant for your schedule at a 
time.

When your assistant sets up a meeting in your Appointment Book and sends meeting requests on your 
behalf, the responses are sent to your assistant, and your schedule automatically tracks them.

When people invite you to meetings, your assistant receives copies of the requests; he or she can view 
your schedule for conflicts and respond on your behalf. You can specify that your meeting messages be 
sent only to your assistant, or to you and your assistant.

Your assistant does not need to know your password.

You can easily select a different (or no) assistant anytime while you are working with Schedule+ online.



Viewing Another User's Appointment Book or Task List

To view someone else's Appointment Book or Task list

Note: If the name of the person or resource whose schedule you want to view isn't in the address list 
currently shown, check another address list. You can view other address lists the same way you do in 
mail. You must be working with Schedule+ online to view another user's Appointment Book.

1 From the File menu, choose Open Other's Appt Book (ALT+F, O).
2 In the address list, select the name of the user whose Appointment Book or Task list you want to view. 
3 Choose the OK button.

Schedule+ informs you if the user's schedule file is unavailable. If you have the correct access 
privilege, the user's Appointment Book appears in your Schedule+ workspace.

4 To view the user's Task list, click the Tasks tab on the left of the user's schedule. 

To close another user's Appointment Book or Task list

From the user's Appointment Book or Task list, double-click the Windows Control-menu box in the 
upper-left corner of the window, or select it and choose the Close button.

See Also
Adding, Changing, or Deleting Another User's Appointments or Tasks
Acting as an Assistant for Another User's Schedule
Acting as an Assistant for a Conference Room or Other Resource



Viewing Another User's Appointment Book or Task List

Other users can give you the access privilege to view their Appointment Books. This is convenient when 
you need to know more than just the times of another user's appointments. For example, you may need 
to know where to find that person during the day.

In another user's Appointment Book, you cannot see appointments the user has marked as private, or 
that user's daily notes.

If you have another user's Appointment Book open when you exit Schedule+, it is opened automatically 
the next time you use Schedule+ online.



Adding, Changing, or Deleting Another User's Appointments or Tasks

Tip: The procedures for adding, changing, or deleting appointments or tasks in another user's schedule 
are the same as those for adding, changing, or deleting appointments or tasks in your own schedule. In 
another user's schedule, however, you are only able to perform the operations for which you have the 
correct access privilege.

To add, change, or delete an appointment in another user's Appointment Book

1 From the File menu, choose Open Other's Appt Book (ALT+F, O).
2 In the address list, select the name of the user whose Appointment Book you want to update.

If the name of the person whose schedule you want to update isn't in the address list currently shown, 
check another address list. You can view other address lists the same way you do in mail.

3 Choose the OK button.
If you have been granted the necessary access privilege, the user's Appointment Book appears in 
your Schedule+ workspace.

4 In the user's Appointment Book, add, change, or delete the appointment, following the same 
procedures you use in your own Appointment Book.

To add, change, or delete a task in another user's Task list

1 From the File menu, choose Open Other's Appt Book (ALT+F, O).
2 In the address list, select the name of the user whose Task list you want to update.

If the name of the person whose schedule you want to update isn't in the address list currently shown, 
check another address list. You can view other address lists the same way you do in mail.

3 Choose the OK button.
If you have the necessary access privilege, the user's Appointment Book appears in your Schedule+ 
workspace.

4 Click the Tasks tab on the left of the user's Appointment Book.
5 Add, change, or delete the task, following the same procedures you use in your own Task list.

See Also
Acting as an Assistant for a Conference Room or Other Resource
Acting as an Assistant for Another User's Schedule
Viewing Another User's Appointment Book or Task List



Adding, Changing, or Deleting Another User's Appointments or Tasks

Adding, changing, and deleting appointments and tasks in another user's schedule is identical to adding, 
changing, and deleting appointments in your own schedule.

Before you can create appointments or tasks for another user, however, the user must grant you the 
access privilege for creating his or her appointments or tasks. If you have this access privilege, you can 
add appointments and tasks for the user, and you can change or delete the items you add.

To change or delete appointments or tasks that you did not create yourself, the user must grant you the 
access privilege for modifying his or her appointments and tasks, or you must be that user's schedule 
assistant.



Acting as an Assistant for Another User's Schedule

To view or change the owner's Appointment Book

When you're acting as someone's schedule assistant, you view or change his or her Appointment Book 
the same way you would view or change another user's Appointment Book. The person for whom you're 
acting as an assistant is the owner of his or her Appointment book. 

To set up a meeting on behalf of the owner

1 From the File menu, choose Open Other's Appt Book (ALT+F, O).
2 From the address list, select the name of the user whose Appointment Book you want to open. Then 

choose the Add button.
If the name of the schedule owner isn't in the address list currently shown, check another address list. 
You can view other address lists the same way you do in mail.

3 Choose the OK button.
4 In the owner's Appointment Book, perform the steps for setting up a meeting, just as you do in your 

own schedule: Choose attendees, compare their schedules to the owner's, select a time slot, and 
send a Meeting Request form on the owner's behalf.

As the owner's assistant, you receive the responses to the meeting request you sent on the owner's 
behalf. The responses are automatically logged in the owner's schedule.

To accept an invitation to a meeting on behalf of the owner

When you receive a copy of a meeting request on behalf of the owner, perform the steps for 
responding to any meeting request: Confirm the owner's availability at the proposed time and respond to 
the message on the owner's behalf.

See Also
Adding, Changing, or Deleting Another User's Appointments or Tasks
Responding to a Meeting Request
Setting Up a Meeting
Viewing Another User's Appointment Book or Task List



Acting as an Assistant for Another User's Schedule

As an assistant for another user's schedule, you can modify the owner's schedule and read and send 
meeting messages on the owner's behalf. The owner must grant you the Assistant access privilege 
before you can act as his or her assistant. You do not need to know the owner's password.

The procedures for working with appointments and tasks, and for scheduling meetings for the owner, are 
the same as those for working with your own appointments and tasks or scheduling meetings for 
yourself. The main difference is that appointments you book and meeting messages you send on the 
owner's behalf are identified as created or sent by you on the owner's behalf.



Acting as an Assistant for a Conference Room or Other Resource

To book an appointment on behalf of the resource

When you receive a copy of a meeting request sent to the resource, perform the steps for 
responding to any meeting request: Confirm the resource's availability at the proposed time, and respond 
to the message.

See Also
Adding, Changing, or Deleting Another User's Appointments or Tasks
Changing or Deleting an Appointment
Responding to a Meeting Request
Scheduling an Appointment
Viewing Another User's Appointment Book or Task List



Acting as an Assistant for a Conference Room or Other Resource

With Schedule+, conference rooms and other resources have Appointment Books. Users can compare 
the resource's schedule to their own and book appointments in the resource's Appointment Book. Users 
"invite" resources to their meetings, just as they invite attendees.

As the assistant for a conference room or other resource, you receive meeting requests on behalf of the 
resource. You are responsible for confirming the resource's availability for the proposed time, responding 
to the sender, and booking the appointment in the resource's Appointment Book.



Adding or Removing a Resource

To add a resource

1 Make sure that the resource has a Mail account.
2 Sign in to Schedule+ using the mailbox name and password you've assigned to the resource.
3 From the Options menu, choose the General Options command (ALT+O, G).

4 Select the This Account Is For A Resource option, then choose the OK button.
5 From the Options menu, choose the Set Access Privileges command.
6 Make sure that all users have access privileges to at least view the resource's free and busy times.

Note: If you want users to be able to schedule time with the resource directly (instead of going through 
the resource's assistant), make sure they have access privileges to create appointments for the 
resource.

7 If you want to assign an assistant for this resource, select the assistant's name from the address list, 
and then select the Assistant privilege.

8 Choose the OK button.

To remove a resource

Remove the resource's Mail account.

See Also
Designating an Assistant for Your Schedule
Making or Changing Schedule+ Settings
Setting or Changing Users' Access Privileges for Your Schedule
Signing In to Schedule+



Adding or Removing a Resource

In Schedule+, accounts for resources (such as conference rooms or equipment) are set up on the 
system virtually the same way user accounts are set up. For example, as with users, each resource 
must first have a Mail account on the postoffice. The primary difference between user and resource 
accounts is that you must select an option that designates the account as a resource.

Just as users can designate assistants to manage their schedules, resources can have assistants, too. 
You must designate an assistant for the resource if you don't want users to schedule time in the 
resource's Appointment Book directly. Only the user or users who know the password for the resource's 
account can designate an assistant for the resource.



Accept

Choose this button to schedule the appointment in your Appointment Book and notify the sender that you 
plan to attend.

If the sender requested a response (by checking the Ask For Responses box in the Meeting Request 
form), Schedule+ displays a Meeting Response form for you to complete and send.



Access privileges

Levels of permission for other users to view or change your schedule. You grant access privileges for 
your own schedule. 

The access privileges are:

None
View Free/Busy Times
Read Appointments & Tasks
Create Appointments & Tasks
Modify Appointments & Tasks
Assistant



Active task

A task you should be working on, according to the time you specified in the Start Work and Before Due 
boxes of the Task dialog box. For example, if you specified that you want to start a task two days before 
its due date, the task becomes active two days before its specified due date. Past-due tasks appear in 
red on your Task list.

Tasks for which you have not specified a due date are always active.



Add All Appointments

An option for merging information from other programs, which causes Schedule+ to add all 
appointments from the other schedule to your Schedule+ Appointment Book, including duplicate 
appointments.



Address list

The list of mail users on the postoffice. To work with Schedule+ online, your name must be in an address 
list on the system.



Appointment

An entry in your Appointment Book that specifies a meeting you plan to attend or somewhere you have 
to go at a specific time. When you accept a request to attend a meeting, that meeting is entered 
automatically in your Appointment Book. If you designate an appointment to be a recurring one, it is 
entered into appropriate future time slots in your Appointment Book.



Appointment Book

The Schedule+ view that shows you the daily view of your schedule, broken into 30-minute time slots, 
and your notes for the day. A time slot can contain a combination of appointments and tentative 
appointments. If you grant other users access privileges, they can view your appointments from their 
Appointment Books.



Appointment handle

One of the two thick borders on the top and bottom of a selected appointment in the Appointment Book. 
The appointment handles provide a way to quickly move or extend the appointment. The top handle 
moves the appointment and the bottom handle extends the appointment. 



Archive

A stored copy of your part of your schedule file, usually from a time period that has already passed. 
When you open a schedule archive to look at it, it is displayed in the Appointment Book format.



Ask About Conflicting Appointments

This option for merging information from other programs causes Schedule+ to tell you when it finds an 
appointment from the other program that conflicts with one in your Appointment Book. You can choose to 
have Schedule+ copy it to your Appointment Book anyway.



Attendees

People (or resources) that you invite to a meeting that you set up. You select attendees from list of 
people and resources the same way you select mail recipients. After you have selected attendees, you 
can compare their schedules to yours in the Planner.



Calendar

Tool for changing the date you are viewing in the Appointment Book or Planner. 

The current date has a border, and the selected date has a black box around it. The month and year are 
displayed at the top of the calendar.
Days that have scheduled appointments or daily notes are shown in bold.



Create Appointments & Tasks

The access privilege that grants the specified user the ability to create entries in your Appointment Book 
and Task list. The user can delete or modify any appointments he or she makes.



Read Appointments & Tasks

The access privilege that grants the specified user the ability to view your appointments and tasks 
(except for those you designated as private). This access privilege does not allow the user to create, 
modify, or delete entries in your Appointment Book or Task list.



Modify Appointments & Tasks

The access privilege that grants the specified user the ability to create, modify, or delete any entries in 
your Appointment Book and Task list, regardless of who made the appointments and tasks, except those 
you designated as private.

When you appoint another user to be your schedule assistant, that user automatically receives this 
access privilege.



View Free/Busy Times

The access privilege that grants the specified user the ability to overlay your schedule on his or hers in 
the Planner, to compare availability for meetings.

Users with this access privilege cannot view or change your appointments, tentative appointments, or 
tasks.



None

The access privilege that denies the specified user(s) all access to your schedule, including viewing your 
Appointment Book and Task list, and comparing your free and busy times to theirs in the Planner.



Assistant

The access privilege that permits the specified user to view, create, delete, and modify your 
appointments and tasks, except those you've designated private. Your assistant can send and receive 
meeting messages on your behalf. Your assistant does not need to know your schedule password.



Character string

A sequence of letters and numbers you search for in an Appointment Book. For example, if you 
remember you have a meeting with Thomas, but you don't remember what day or time it is booked for, 
you can instruct Schedule+ to find the character string Thomas in your Appointment Book. 

The maximum length of a character string you can search for is 64 characters. Schedule+ ignores 
spaces at the beginning or end of the string, and ignores whether the letters are uppercase or 
lowercase.



Choose

When you choose a button or command, the action that button or command represents begins 
immediately. 

To choose a button or command

Click the button or command.

1 Using the arrow keys or other special keys, place the pointer on the button or command.
2 Press ENTER.



To close a window

1 In the window you want to close, click the Control-menu box in the upper-left corner of 
the window.

2 Select Close (CTRL+F4).

In the window you want to close, press CTRL+F4.



Connection

The software link between a workstation and a shared network resource. You make connections by 
assigning a network drive on your computer to a shared directory. For example, to use the group-
scheduling features of Schedule+, your computer must have a connection to a postoffice.



To copy an appointment from one place in your Appointment Book to another

1 Select the appointment you want to copy.
2 From the Edit menu, choose Copy Appt (CTRL+Y).

3 Select the time slot you want to place a copy of the appointment in.
4 From the Edit menu, choose Paste (CTRL+V).



Daily

One of the Schedule+ options for printing your schedule (the other options are weekly and monthly). The 
daily format shows your schedule one day per page, broken into 30-minute time slots.



Decline

Choose this button to notify the sender that you are not planning to attend the meeting.

If the sender requested a response (by checking the Ask For Responses box in the Meeting Request 
form), Schedule+ displays a prepared Meeting Response form for you to complete and send.

If the sender didn't request a response, you can send one by checking the Send Response box in the 
Meeting Request form.



To display your Appointment Book

The procedure for displaying your Appointment Book depends on whether you're currently in the 
schedule or Messages window and whether the schedule window is active or minimized (represented by 
an icon).

If you are currently in the schedule window

Click the Appts tab on the left of the window, or press ALT+A.

You can also click the Today tab (ALT+Y) to view your Appointment Book.

If you are currently in the Messages window and the schedule window is open behind the 
Messages window

1 Click anywhere in the schedule window.
2 If the Appointment Book is not currently displayed in the schedule window, click the Appts tab on the 

left of the window, or press ALT+A.

If you are currently in the maximized Messages window

1 From the Window menu, choose your name.
2 Press ALT+A.

Tip: You can also press CTRL+F6 as many times as necessary to switch views until the schedule window 
appears. Then, if your Appointment Book is not already displayed, click the Appts tab or press ALT+A.

If the schedule window is currently minimized

1 Double-click the icon for the schedule window.
2 If the Appointment Book is not currently displayed in the schedule window, click the Appts tab on the 

left of the window or press ALT+A.



To Display Your Planner

The procedure for displaying your Planner depends on whether you're currently in the schedule or 
Messages window, and whether the schedule window is active or minimized (represented by an icon).

If you are currently in the schedule window

Click the Planner tab on the left of the window, or press ALT+P.

If you are currently in the Messages window and the schedule window is open behind the 
Messages window

1 Click anywhere in the schedule window.
2 If the Planner is not currently displayed in the schedule window, click the Planner tab on the left of the 

window or press ALT+P.

If you are currently in the maximized Messages window

1 From the Window menu, choose your name.
2 Press ALT+P.

Tip: You can also press CTRL+F6 as many times as necessary to switch views until the schedule window 
appears. Then if your Planner is not already displayed, click the Planner tab or press ALT+P to display it.

If the schedule window is currently minimized 

1 Double-click the icon for the schedule window.
2 If the Planner is not currently displayed in the schedule window, click the Planner tab on the left of the 

window or press ALT+P.



To Display Your Task list

The procedure for displaying your Task list depends on whether you're currently in the schedule or 
Messages window and whether the schedule window is active or minimized (represented by an icon).

If you are currently in the schedule window

Click the Tasks tab on the left of the window, or press ALT+T.

If you are currently in the Messages window and the schedule window is open behind the 
Messages window

1 Click anywhere in the schedule window.
2 If the Task list is not currently displayed in the schedule window, click the Tasks tab on the left of the 

window or press ALT+T.

If you are currently in the maximized Messages window

1 From the Window menu, choose your name.
2 Press ALT+T.

Tip: You can also press CTRL+F6 as many times as necessary to switch views until the schedule window 
appears. Then if your Task list is not already displayed, click the Tasks tab or press ALT+T.

If the schedule window is currently minimized 

1 Double-click the icon for the schedule window.
2 If the Task list is not currently displayed in the schedule window, click the Tasks tab on the left of the 

window or press ALT+T.



To Display Your Messages Window

To display your Messages window

From the Window menu, choose Messages.

Tip: You can also press CTRL+F6 as many times as necessary to switch views until the Messages 
window appears.



Do Not Add Duplicates

This option for merging information from other programs causes Schedule+ to add all appointments and 
tasks from the other schedule to your Schedule+ schedule, except duplicate appointments and tasks.



Tentative

Choose this button to notify the sender that you are not sure whether you will attend. The meeting is 
booked as a tentative appointment in your Appointment Book.

If the sender requested a response (by checking the Send Response box in the Meeting Request form), 
Schedule+ displays a prepared Meeting Response form for you to complete and send.

If the sender didn't request a response, you can send one by checking the Send Response box in the 
Meeting Request form.



Due date

The date you have scheduled a task for completion. Tasks that are overdue are displayed in red.



Export

To send information from one system or program to another system or program. For example, you can 
export your appointments to another scheduling program and work with your schedule there.



File format

The structure in which a file is saved. Although Schedule+ saves its files in its own format, it is capable 
of reading or sending information that is in other file formats, such as those used by other schedule 
programs.



Schedule+ icons

Schedule+ uses several icons to designate specific types of appointments, tasks, or projects in your 
schedule. Icons appear in your Appointment Book or Task list next to the items they describe.

Meeting icon    A hand-shaking symbol that indicates the appointment has attendees or resources 
associated with it.

Private icon    A key symbol that indicates the appointment, task, or project is private. Other users 
(including your assistant) cannot view private events.

Recurring icon    A circular-arrow symbol that indicates the appointment or task occurs on a regular 
basis.

Reminder icon    A bell symbol that indicates that you've asked to be reminded before the appointment 
occurs or task becomes active.



Import

To bring information from one system or program into another system or program. For example, when 
you are finished working with your schedule on a portable computer, you can import the new and 
changed appointments, tasks, and notes to your postoffice or your computer and work with your 
schedule there.



Inactive task

A task for which the time specified in the Start Work box has not occurred. For example, if you specified 
that you want to start a task two days before its due date, the task is inactive until two days before the 
due date, when it becomes active.



To place the insertion point in the Notes box

Click any place in the Notes box.

Press ALT+N.



Local file

A file that is on your own computer, rather than on the postoffice.



Mail name

The unique name under which you are registered with your Mail system and Schedule+.



Meeting

An appointment that has designated attendees and is set up using the Meeting Request form. If you 
accept a request to attend a meeting, that meeting is automatically entered in your Appointment Book. If 
you tentatively accept the meeting, it is booked in your Appointment Book as a tentative appointment.

A meeting is represented in your Appointment Book by a hand-shaking icon.



Meeting request

A Schedule+ message you receive from another user, asking you to attend a specific meeting. Every 
request contains the sender's (or assistant's) name, as well as the proposed meeting date and time. 
Usually the sender also includes a brief comment.



Meeting Request form

The Schedule+ message form, filled out automatically by Schedule+, that you send to ask people to 
attend your meeting. 



Meeting response

A Schedule+ message an invited user sends to the requesting user, replying whether he or she plans to 
attend the meeting. Every response contains the sender's (or assistant's) name, as well as the proposed 
meeting date, and time. The sender can also include a brief explanation for his or her answer.



Meeting Response form

The Schedule+ message form, filled out automatically by Schedule+, that you send to people who invite 
you to their meetings.



Message

A general term for a meeting request or meeting response. Requests and responses are listed in the 
Messages window. Schedule+ provides forms for sending meeting requests or responses.



Message area

The portion of the message where you can type additional information or instructions for the recipients. 
The message is separated from the message's header information (such as To, From, and Subject) by a 
horizontal line.



Messages window

One of the two primary windows in Schedule+. The Messages window lists the meeting requests and 
responses you've received.



Up arrow button

Pressing this button gives a task a higher (more urgent) priority level. For example, if a task's priority is 
3, clicking the up arrow button at the bottom of the Task list changes the task's priority to 2, a higher 
priority. Similarly, if a task's priority is D, clicking the up arrow button changes its priority to C, a higher 
priority.



Monthly

One of the Schedule+ options for printing your schedule (the others are daily and weekly). The monthly 
format shows your schedule one month per page, broken into 30 (or 28, 29, or 31, as appropriate) days.



Note

A message written for a specific date in your Appointment Book. Unlike an appointment or tentative 
appointment, a note usually applies to the day in general, not to a specific time slot.



Offline

Working with Schedule+ without a connection to the postoffice. When you work offline, the copy of your 
schedule file on the postoffice isn't updated until you connect to the postoffice again.

While you're working offline, the group scheduling features of Schedule+ are unavailable because they 
require a connection to your postoffice.



Online

Working with Schedule+ while connected to the postoffice. When you work online, both your schedule 
file on the postoffice and your local schedule file are kept up to date.



Password

A string of characters that you type, along with your mail name, to verify your Schedule+ account.



Past-due task

A task for which the specified due date has passed. Past-due tasks are displayed in red in your Task list.



Down arrow button

Pressing this button gives a task a lower (less urgent) priority level. For example, if a task's priority is 3, 
clicking the down arrow button at the bottom of the Task list changes the task's priority to 4, a lower 
priority. Similarly, if a task's priority is D, clicking the down arrow button changes its priority to E, a lower 
priority.



Postoffice

The list of Mail users on the system. To work with Schedule+ online, your name must be in a postoffice 
on the system.



Priority

You can assign a task a priority between 1-9 or A-Z. Priority 1 is the highest possible priority (including 
letter priority levels), and Z is the lowest possible priority (including number priority levels). The default 
priority level is 3. If you are using only letter priorities, the default priority level is C.

Number priority levels are higher (more important) than letter priority levels. For example, although 9 is 
the lowest number priority you can assign to a task, it is a higher priority than A.



Private

This option makes an appointment or task you create hidden to other users, including your assistant (if 
you have designated one).

A private task or appointment is represented by a key icon.



Project

A name for a collection of related tasks. For example, you can group the tasks "do research" and "write 
first draft" under a project called "sales report."

Tasks do not have to be part of a project. You might decide not to divide your tasks into projects, or you 
might put some under projects and leave others independent.

When you designate a project to be private, all tasks currently under it become private, and all tasks you 
add to it become private.



Recurrence exception

A change to an appointment's or task's recurrence pattern. For example, if an appointment's recurrence 
pattern defines it as weekly, on Tuesdays, and at 11:00 A.M., a recurrence exception might be that the 
next meeting only will occur on a Wednesday, instead of Tuesday. When you specify a recurrence 
exception by changing one occurrence of a recurring appointment or task, Schedule+ adjusts your 
Appointment Book or Task list automatically.



Recurrence pattern

The regular basis on which an appointment or task occurs. For example, if a meeting occurs weekly on 
Tuesdays at 11:00 A.M., the recurrence pattern contains the following information: weekly, Tuesdays, 
11:00 A.M.

Schedule+ uses the recurrence pattern you specify to book a recurring appointment or task 
automatically.



Recurring appointment

An appointment that occurs regularly, such as every Monday at 10:00 A.M. In your Appointment Book, 
when you specify that an appointment is recurring, it is entered automatically into the appropriate future 
time slots.

A recurring appointment is represented in your Appointment Book by a circular-arrow icon.



Recurring task

A task that occurs regularly, such as every Monday. In your Task list, if you specify that a task is 
recurring, it is entered automatically into your task list.

A recurring task is represented in your Task list by a circular-arrow icon.



Reminder

A pop-up message or bell sound (optional) that notifies you of an upcoming appointment or task entered 
in your Appointment Book or Task list. You can specify the type and default timing of the reminder with 
the General Options command on the Options menu. You can also specify the timing of reminders for 
specific appointments or tasks by changing the time shown in the respective Appointment or Task dialog 
box. 

Reminders are optional; you can set them for all appointments or for specific appointments. You can also 
set a reminder for any task that has a due date.

Appointments and tasks you set reminders for are indicated in the Appointment Book or Task list by the 
bell icon.



Schedule+ Reminders program

The Reminders program, MSREMIND.EXE, makes it possible for you to quit Schedule+ and still receive 
appointment reminders as you work.

The Reminders program is automatically added to your Windows Startup group if you use the Express 
Schedule+ Setup.

You can quit the Reminders program by choosing either the Turn Off Reminders command or the Exit 
And Sign Out command from the File menu.

Like Schedule+ and Mail, the Reminders program keeps track of your sign-in information, so if it's 
already running, you won't be prompted to sign in to Schedule+ or Mail.



Resource

A technician, conference room, piece of equipment, or anything else that is assigned an Appointment 
Book and whose time Schedule+ users can reserve.



Planner

The Schedule+ view that shows your appointments several days at a time. If you are connected to a 
postoffice, you can also view the time slots during which other users are busy.



Schedule window

One of the main windows in Schedule+. The schedule window (identified in the Window menu as your 
name) contains your Appointment Book, Planner, and Task list.



Schedule+ workspace

The portion of the screen that Schedule+ fills. The Schedule+ workspace is bordered on the top by its 
title bar and menu bar. The two main Schedule+ windows (schedule and Messages) are displayed in the 
Schedule+ workspace. If you are currently viewing an archive file, a specific message, or another user's 
Appointment Book or Task list, those windows also appear in the Schedule+ workspace.



To scroll the list of users

In the scroll bar on the right of the list of users, click the up arrow button to move toward the top of 
the list, and click the down arrow button to move toward the bottom of the list.



Search method

The method you instruct Schedule+ to use to find text in a schedule. Schedule+ can search forward or 
backward from today's date, or throughout the entire schedule.



Assistant

A user you may appoint to modify your Appointment Book, set up meetings, and respond to meeting 
requests on your behalf.

Your assistant does not need to know your password. 



Select

When you select an object on the screen, it becomes highlighted. Selecting an object doesn't start an 
action. To start an action on a selected object, you must double-click the object, press ENTER, or choose 
a button (such as the Add or Delete button).

To select an object

Click the object.

Using the arrow keys or other special keys, place the pointer on the object.



To select a time slot in the Appointment Book or Planner

1 Click the start time for the appointment. 
That 30-minute block of time is highlighted.

2 Drag the pointer to the end time for the appointment.
The entire time slot is highlighted.

1 Using the UP or DOWN ARROW key, place the pointer at the start time for the appointment.
That 30-minute block of time becomes highlighted.

2 Holding the SHIFT key down, use the UP or DOWN ARROW key to extend the highlighted 
time slot.



To select an appointment in the Appointment Book

Click the appointment or press TAB until the appointment is selected.

To select an appointment in the Recurring Appointments list

Click the summary line for the appointment or press the UP or DOWN ARROW key until the 
appointment is selected.



To select part of your schedule to print

In the Print dialog box, select the settings you want in the Schedule Range, Print, Print Quality, 
and Paper Format boxes.



To select the day

1 In the calendar, click the day you want to view.
2 In the month or year box, click the down arrow button to display a list of months or years, 

and then click the month or year you want; or select the month or year you want and then press ENTER.

1 From the Edit menu, choose the Go To Date command (CTRL+G) or the Go To Week 
command (CTRL+W). The Go To Week command is only available if you have set your options to display 
week numbers in the calendar.

2 In the dialog box, use the LEFT and RIGHT ARROW keys to select the part of the date or 
week you want to change. Then type the correct number(s) over the selected number(s). Choose the OK 
button.



Signing in

The process of typing your mail name and password to identify yourself as a Schedule+ user and access 
your schedule.



Task

A specific duty or errand you must perform and want to track through completion. A task can be a 
personal item or a work-related item.

You can group similar tasks into a group (project), or you can leave them listed as independent tasks.

You can assign priorities and due dates for your tasks, and you can set reminders to occur at specified 
times before the task is due. You can also designate a task to be private.



Task list

The Schedule+ view that displays tasks you want to track, including their corresponding priority levels 
and due dates.



Task printout

One of the Schedule+ options for printing your schedule. Your tasks are printed in a list that resembles 
the format in your Task list. If you are currently viewing only active tasks, or are viewing your tasks by 
project, those views will be reflected in the printout.



Tentative appointment

An appointment that you can track in your Appointment Book but that does not appear as a busy time 
slot when other users view your schedule from their Planners.

For example, suppose you want to schedule a block of time during the day to work on your novel, but 
you want to be available for any appointments that come up during that time. By making the appointment 
tentative, the time slot appears to be free when other users view your schedule.

When you identify an appointment as tentative, it appears in gray in your Appointment Book. You can 
change the tentative appointment to an actual appointment anytime.



Text printout

One of the Schedule+ options for printing your schedule. Your appointments and notes are printed in a 
list, organized by day. The printout is not shown in 30-minute time slots; the only times shown on the 
printout are those for which you have scheduled appointments.



Time slot

A block of time in your Appointment Book or Planner that represents the duration of an appointment. The 
Appointment Book and Planner are broken into several 30-minute units. You can select a time slot that 
consists of several 30-minute units. You can also start or end a meeting outside the half-hour (such as at 
2:08). However, appointments that do not start or end on even 30-minute intervals are displayed in the 
Appointment Book and Planner to the nearest (inclusive) half-hour.



Using the arrow next to Minutes

Click the down arrow next to the Beforehand box to select minutes, hours, days, weeks, or months, as 
appropriate. (Not all options are available for every occasion.)



View Schedule

Choose this button to display your Appointment Book so you can decide whether or not to attend the 
meeting.

When you are finished viewing your schedule, you can return to the Meeting Request form and choose a 
reply.



Weekly

One of the Schedule+ options for printing your schedule (the others are daily and monthly). The weekly 
format shows your schedule one week per page, broken into seven days.



Window

In Schedule+, one of the two main views of your schedule information: the schedule window or the 
Messages window. The schedule window has your name at the top and tabs for your Appointment Book, 
Planner, and Task list. The Messages window displays your Schedule+ message inbox, and is only 
available when you are working online.

You can resize, minimize, maximize, or arrange one or both of the Schedule+ windows.



Workgroup

A group of users who work together on similar projects or teams and often use the same information or 
resources. For example, there may be a marketing workgroup and a research workgroup.




