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Introduction
Welcome to The Print Shop Deluxe for Windows. With The Print Shop Deluxe, you can create 
Greeting Cards, Signs, Letterhead, Banners and Calendars. When you add the additional features 
and the dazzling array of design elements to the basic project types, you can create everything from 
cards and announcements to menus, posters, coloring books, bookmarks, notepads, stationery, even 
bumper stickers and fax cover sheets!

The Print Shop Deluxe for Windows provides a wealth of scalable graphics. Scalable graphics can be 
squeezed and scaled with no loss of quality. Square shaped graphics, horizontal row-shaped graphics 
and vertical column-shaped graphics can be stretched, rotated or flipped to create stunning effects.

Layouts provide placeholders for graphics and text which can be filled in and modified in any way you 
desire. The Print Shop Deluxe has a large collection of layouts specially designed to work with the 
existing graphics to save you time. Using layouts is like having a professional designer at your side.

Backdrops provide attractive background graphics for your project. Selecting a backdrop will provide 
a special assortment of layouts designed for each project type.

Text can be added to your project to deliver your message using a rich assortment of TrueType fonts. 
Special headline text allows you to add shape and style to your text. 

While most Print Shop Deluxe graphics are full color, even monochrome graphics can be highlighted 
with color accents. Color can be added to text, behind text, behind graphics and more to create eye-
catching effects.

 



How to...

Create a Greeting Card 
Create a Calendar 
Create a Sign 
Create a Banner 
Create Letterhead 
Add or Change a Backdrop 
Select or Change a Layout 
Add a Graphic 
Add Text 
Add a Headline 
Add or Change Colors 
Choose a Printer 
Resize an Object 
Scale an Object 
Rotate an Object 

 



Adding a Graphic
Select a graphic type:

Square Graphic 

Row Graphic 

Column Graphic 

Horizontal Ruled Line 

Vertical Ruled Line 

Border Graphic 

Mini-border Graphic 

New Print Shop Graphic 

Windows Bitmap Graphic 

 



Tools
Click on a tool icon for a description:

    Pointer Tool

    Rotate Tool

    Hand Tool

    New Object Tool

    Zoom Tool

    Delete Tool

    Flip Tool

    Frame Tool

    Item Selector

    Color Selector

    Shading Slider

 



Menu Commands
Select a menu title to see a list of the menu commands:

File Menu 

Edit Menu 

Object Menu 

Project Menu 

View Menu 

Help Menu 

 



File Menu
New 

Open 

Save 

Save As... 

Revert to Saved 

Preferences... 

Printer Setup... 

Print 

Exit 

 



Edit Menu
Undo 

Cut 

Copy 

Paste 

Delete 

Duplicate 

Select All 

 



Object Menu
Add 

Edit... 

Shadow 

Frame 

Order 

Scale... 

Rotate 

Flip 

Lock 

Unlock 

Align... 

 



Project Menu
Change Backdrop... 

Change Layout... 

NOTE: Depending on the project type, the following menu item(s) will be added to the Project Menu.

Greeting Card Project

Front of Card 

Inside of Card 

Back of Card 

Calendar Project
Depending on the type of calendar, the following menu item(s) will be added to the Project Menu.

Change Year 

Change Month 

Change Week 

Change Day 

Edit Day 

Edit Hour 

Calendar Options 

Banner Project

Adjust Length 

 



View Menu
Zoom In 

Zoom Out 

Fit to Window 

25% 

50% 

Actual Size 

150% 

200% 

Preview 

Hide Backdrop 

Hide Placeholders 

Hide Tools 

 



Help Menu
Index 

Using Help 

About... 

 



Keyboard Guide
Global Keys
______________________________________________________

Ctrl+A Select All
Ctrl+B Send an object backward
Ctrl+C Copy
Ctrl+D Duplicate
Ctrl+F Bring an object forward
Ctrl+K Scale an object
Ctrl+L Lock an object
Ctrl+N New
Ctrl+O Open
Ctrl+P Print
Ctrl+R Rotate an object
Ctrl+S Save
Ctrl+U Unlock an object
Ctrl+V Paste
Ctrl+X Cut
Ctrl+ + Zoom In
Ctrl+ - Zoom Out
F1 Help
F3 Stop object redraw
Alt+F4 Exit
Alt+Backspace Undo
Del Delete
Enter Edit an Object

Dialog Box Keys
______________________________________________________

Page Up Scroll up one screen.
Page Down Scroll down one screen.
An arrow key Moves the cursor left, right, up or 

down within a list or text box.
Home Moves cursor to the beginning of 

the current line in a list or text box.
End Moves cursor to the end of the 

current line in a list or text box.
Tab Moves the insertion point from 

option to option.
Shift+Tab Moves the insertion point from 

option to option in reverse order.
Alt+Down Arrow Displays a pop-up list.
Esc Close a dialog box without 

completing the command.



Pointer Tool
Selects, resizes and moves objects. Hold down the SHIFT key while clicking the mouse to select multiple 
objects.



Rotate Tool
Rotates selected object(s). Hold down the SHIFT key while clicking the mouse to select multiple objects 
for rotation.



Hand Tool
Moves the view of your document around in the window when the project is larger than the window. 
Provides an alternative to using scroll bars.



New Object Tool
Adds new objects to a project. An object is a graphic, text, or headline placeholder. Select an object from 
the pop-up list. To add multiple objects, hold the Control key down while selecting an object from the 
pop-up list.



Zoom Tool
Zooms the view of the project in or out. From the pop-up list, select a view or choose "Zoom In" or "Zoom 
Out".



Delete Tool
Deletes the selected object(s). If you accidentally delete an object, select Undo from the Edit menu.



Flip Tool
Flips the selected object(s) horizontally, vertically or both. Select a direction from the pop-up list.



Frame Tool
Places a frame around the selected object(s). Select a frame type from the pop-up list.



Item Selector
Part of the Color Control Panel, the Item Selector lets you choose an object to apply color or shading. 
Click on the item selector to see a list of items.



Color Selector
Part of the Color Control Panel, the Color Selector lets you apply color to the item that is displayed in the 
Item Selector. A color spectrum (as pictured) represents an object which contains multiple colors. While 
you can change the shading, you cannot change the color of a multi-color graphic. Select a different item 
from the Item Selector or use a monochrome graphic.



Shading Slider
The Shading Slider lets you change the shading value of the item displayed in the Item Selector. Click on 
the left or right arrow to increase or decrease the shading value. New Print Shop graphics, Windows 
Bitmap graphics, and Frames cannot be shaded.



Creating a Greeting Card

    To create a greeting card:

1. From the Select a Project dialog, click on the Greeting Card button.

2. The Greeting Card Orientation    dialog will appear. Click on the Side Fold, Top Fold, Side Fold 
Spread, or Top Fold Spread button.

3. From the Select a Backdrop    dialog, choose a backdrop from the list.

4. Click the OK button.

5. After selecting a backdrop, the Select a Layout    dialog will appear. Choose a layout from the list.

6. Click the OK button.

7. Each gray box represents a placeholder for a Text , Headline , or Graphic    object. Double-click 
on any gray box in the main window to add text or graphics to your project.

8. Once you have filled in all the gray boxes with text or graphics for the front of the greeting card, 
click on the right arrow of the Page Navigation Tool    at the bottom right of the screen.

9. Repeat steps 3 through 7 for the inside of the greeting card.

10. After you have filled in all the gray boxes with text or graphics for the inside of the greeting card, 
click on the right arrow of the Page Navigation Tool    at the bottom right of the screen.

11. Repeat steps 5 through 7 for the back of the greeting card.

12. Once you have filled in all the gray boxes with text or graphics for the back of the greeting card, 
select Save from the File menu .

13. Once you have saved your file, select Print from the File menu .

 



Creating Letterhead

    To create letterhead:

1. From the Select a Project dialog, Click on the Letterhead button.

2. The Letterhead Orientation    dialog will appear. Depending on which style you would like, click on 
the Single Page or Notepad button.

3. From the Select a Backdrop    dialog, choose a backdrop from the list.

4. Click the OK button.

5. After selecting a backdrop, the Select a Layout    dialog will appear. Choose a layout from the list.

6. Click the OK button.

7. Each gray box represents a placeholder for a Text , Headline , or Graphic    object. Double-click 
on any gray box in the main window to add text or graphics to your project.

8. Once you have filled in all the gray boxes with text or graphics, select Save from the File menu .

9. Once you have saved your file, select Print from the File menu .

 



Creating a Sign

    To create a sign:

1. From the Select a Project dialog, click on the Sign button.

2. The Sign Orientation    dialog will appear. Click on the Tall or Wide button.

3. From the Select a Backdrop    dialog, choose a backdrop from the list.

4. Click the OK button.

5. After selecting a backdrop, the Select a Layout    dialog will appear. Choose a layout from the list.

6. Click the OK button.

7. Each gray box represents a placeholder for a Text , Headline , or Graphic    object. Double-click 
on any gray box in the main window to add text or graphics to your project.

8. Once you have filled in all the gray boxes with text or graphics, select Save    from the File menu .

9. Once you have saved your file, select Print from the File menu .

 



Creating a Calendar

    To create a calendar:

1. From the Select a Project dialog, click on the Calendar button.

2. The Calendar Type    dialog will appear. From this dialog click on the Yearly, Monthly, Weekly, or 
Daily button.

3. The Calendar Orientation    dialog will appear. Click on the Tall or Wide button.

4. If you chose a yearly calendar, the Calendar Year    dialog will appear for you to choose a year. If 
you chose a monthly calendar, the Calendar Month    dialog will appear for you to choose a month. 
If you chose a weekly calendar, the Calendar Week    dialog will appear for you to choose a week. If 
you chose a daily calendar, the Calendar Day    dialog will appear for you to choose a day.

5. From the Select a Backdrop    dialog, choose a backdrop from the list.

6. Click the OK button.

7. After selecting a backdrop, the Select a Layout    dialog will appear. Choose a layout from the list.

8. Click the OK button.

9. Each gray box represents a placeholder for a Text , Headline , or Graphic    object. Double-click 
on any gray box in the main window to add text or graphics to your project.

10. Once you have filled in all the gray boxes with text or graphics, select Save from the File menu .

11. Once you have saved your file, select Print from the File menu .

 



Creating a Banner

    To create a banner:

1. From the Select a Project dialog, click on the Banner button.

2. The Banner Orientation    dialog will appear. Click on the Horizontal or Vertical button.

3. From the Select a Backdrop    dialog, choose a backdrop from the list.

4. Click the OK button.

5. After selecting a backdrop, the Select a Layout    dialog will appear. Choose a layout from the list.

6. Click the OK button.

7. Each gray box represents a placeholder for a Text , Headline , or Graphic    object. Double-click 
on any gray box in the main window to add text or graphics to your project.

8. Once you have filled in all the gray boxes with text or graphics, select Save from the File menu .

13. Once you have saved your file, select Print from the File menu .

 



Adding a Backdrop
When creating any new project, The Print Shop Deluxe will prompt you to select a backdrop. 

Click on a topic for more help on selecting a backdrop:

Selecting a Backdrop 
Selecting a Different Library 
Changing a Backdrop 

 



Selecting a Layout
When creating any new project, The Print Shop Deluxe will prompt you to select a layout. The 
available layout choices are based on the previously selected backdrop. Selecting "Blank 
Page," will list all the layouts for the orientation on which you are working.

Click on a topic for more help on selecting a layout:

Making a Selection 
Layout Icon Guide 
Changing a Layout 

NOTE: If you choose the Lighten Backdrop option, you will not only see the layouts designed 
specifically for the selected backdrop, but all the other layouts for the orientation on which you are 
working. This gives you access to a wide variety of designs and can create quite a striking effect.

 



Adding Text
To add text:

1. Click on the  New Object tool or Add from the Object menu and select the Text option.

2. Double-click on the  text block or press the ENTER key.
3. Enter text in the typing area. Words will "wrap" automatically to the next line.
4. Click the OK button.

Select a topic for more help on adding text:

Entering Text 
Modifying Text 
Previewing Text 
Selecting a Font 
Font Size 
Justification 
Selecting Colors 

NOTE: As you type in the text, the text itself will be displayed without the formatting and style. 
To see how the text will look when printed, you must choose the Preview button below the 
text entry box. When you preview the text, it will be displayed in the text entry area in the 
chosen font, size, style, and color. When previewing using the preview button, text that will 
not fit in the text block will appear below the horizontal line.

 



Adding a Headline
To add a headline:

1. Click on the  New Object tool or Add from the Object menu and select the Headline option.

2. Double-click on the  headline block or press the ENTER key.
3. Enter text in the typing area.
4. Click the OK button.

Select a topic for more help on adding a headline:

Entering Headline Text 
Customizing Headline Text 
Shaping Headline Text 

NOTE: Justify options are only available when two lines of text are entered.

 



Color Usage
To add color to an item:

1. Click on the Item Selector    above the Color Selector    in the Tool Palette. A list of items will 
appear. If you are applying color within a dialog, an Item Selector will appear above the Color 
Selector within the dialog.

2. Select an item from the Item Selector list by clicking on the name of the item.

3. Click and hold the mouse button down on the right arrow of the Color Selector or the currently 
displayed color. A list of colors will appear.

4. Select a color by releasing the mouse button while pointing to the desired color.

To add shading to an item:

1. Click on the Item Selector above the Color Selector    in the Tool Palette. A list of items will 
appear. If you are applying color within a dialog, an Item Selector will appear above the Color 
Selector within the dialog.

2. Select an item from the list by clicking on the name.

3. Click on the left or right arrow of the Shading Slider to increase or decrease the shade value. The 
slider moves in increments of 10.

NOTE: New Print Shop graphics, Windows Bitmap graphics, and Frames cannot be shaded.

 



Printer Configuration
To select a printer:

1. Select Printer Setup    from the File menu .

2. Select a printer from the list of installed printers. If no printer name appears in the list, consult 
your Windows User's Guide.

3. Click the OK button.

NOTE: You may configure printer settings for the selected printer by clicking on the Setup button in 
the Printer Setup dialog. The Setup button will display print driver options regarding resolution, page 
size, orientation, etc., that are specific to the printer.

 



Square Graphic
To add a square graphic:

1. Click on the  New Object tool or Add from the Object Menu and select the Square Graphic 
option.

2. Double-click on the  square graphic placeholder or press ENTER.
3. Select a graphic from the list by clicking on the name. A preview of each highlighted graphic will appear 
to the right.
4. Click the OK button.

Select a topic for more help on adding a square graphic:

Selecting a Different Library 

 



Row Graphic
To add a row graphic:

1. Click on the  New Object tool or Add from the Object menu and select the Row Graphic 
option.

2. Double-click on the  row graphic placeholder or press ENTER.
3. Select a graphic from the list by clicking on the name. A preview of each highlighted graphic will appear 
to the right.
4. Click the OK button.

Select a topic for more help on adding a row graphic:

Selecting a Different Library 

 



Column Graphic
To add a row graphic:

1. Click on the  New Object tool or Add from the Object menu and select the Column Graphic 
option.

2. Double-click on the  column graphic placeholder or press ENTER.
3. Select a graphic from the list by clicking on the name. A preview of each highlighted graphic will appear 
to the right.
4. Click the OK button.

Select a topic for more help on adding a column graphic:

Selecting a Different Library 

 



Horizontal Ruled Line
To add a horizontal ruled line graphic:

1. Click on the  New Object tool or Add from the Object menu and select the Horizontal Ruled 
Line option.

2. Double-click on the  horizontal ruled line placeholder or press ENTER.
3. Select a horizontal ruled line from the list by clicking on the name. A preview of each horizontal ruled 
line will appear to the right.
4. Click the OK button.

Select a topic for more help on adding a horizontal ruled line:

Selecting a Different Library 

 



Vertical Ruled Line
To add a vertical ruled line:

1. Click on the  New Object tool or Add from the Object menu and select the Vertical Ruled 
Line option.

2. Double-click on the  vertical ruled line placeholder or press ENTER.
3. Select a vertical ruled line from the list by clicking on the name. A preview of each vertical ruled line will 
appear to the right.
4. Click the OK button.

Select a topic for more help on adding a vertical ruled line:

Selecting a Different Library 

 



Border Graphic
To add a border graphic:

1. Click on the  New Object tool or Add from the Object menu and select the Border option.

2. Double-click on the  border placeholder or press ENTER.
3. Select a graphic from the list by clicking on the name. A preview of each highlighted graphic will appear 
to the right.
4. Click the OK button.

Select a topic for more help on adding a border:

Selecting a Different Library 

 



Mini-border Graphic
To add a mini-border graphic:

1. Click on the  New Object tool or Add from the Object menu and select the Mini-border 
option.

2. Double-click on the  mini-border graphic placeholder or press ENTER.
3. Select a graphic from the list by clicking on the name. A preview of each highlighted graphic will appear 
to the right.
4. Click the OK button.

Select a topic for more help on adding a mini-border graphic:

Selecting a Different Library 

 



New Print Shop Graphic
To add a New Print Shop graphic:

1. Click on the  New Object tool or Add from the Object menu and select the New Print Shop 
Graphic option.

2. Double-click on the  New Print Shop Graphic placeholder or press ENTER.
3. Select a graphic from the list by clicking on the name. A preview of each highlighted graphic will appear 
to the right.
4. Click the OK button.

Select a topic for more help on adding a New Print Shop Graphic:

Selecting a Different Library 

 



Windows Bitmap Graphic
To add a Windows bitmap graphic:

1. Click on the  New Object tool or Add from the Object menu and select the Windows Bitmap 
option.

2. Double-click on the  Windows bitmap graphic placeholder or press ENTER.
3. Select a graphic from the Files list by clicking on a file name. If you want a Windows bitmap graphic 
from another directory, double-click on the desired directory. Click on the "[..]" symbol in the Directories 
list to move back one directory level. If you want a Windows bitmap graphic from another Drive, double-
click on the drive letter at the bottom of the Directories list.
4. Click the OK button.

 



Resizing an Object
You can resize an object without any loss of quality.

 Stretching a graphic object:

1. Select the  Pointer tool from the Tool Palette.
2. Click on the object to select it.
3. Position the pointer over one of the corner handles on the selected object.
4. While pressing the CTRL key, hold the mouse button down and drag the handle to stretch. 

 Resizing a text block

1. Select the  Pointer tool from the Tool Palette.
2. Click on the text block to select it.
3. Position the pointer over one of the corner handles on the selected object.
4. Hold the mouse button down to drag the handle. 

NOTE: Calendar blocks, Banner text blocks, and borders cannot be resized.

 



Rotating an Object
 To rotate an object:

1. Select the  Rotate tool from the Tool Palette.
2. Click on the graphic object to select it.
3. Position the pointer over one of the corner handles on the selected object.
4. Hold the mouse button down and drag the handle to rotate the object.

 To rotate by degree:

1. Select Rotate from the Object menu and then select the Other... command from the sub-menu.

2. Click the up or down arrow to specify the angle.

3. Click the OK button.

NOTE: Calendar blocks, Banner text blocks, Windows Bitmaps graphics, New Print Shop graphics, 
and borders cannot be rotated.

 



Scaling an Object
 Scaling graphic objects:

1. Select the  Pointer tool from the Tool Palette.
2. Click on the graphic object to select it.
3. Position the pointer over one of the corner handles on the selected object.
4. Hold the mouse button down to drag the handle.

 Scaling text blocks and headlines:

1. Select the  Pointer tool from the Tool Palette.
2. Click on the graphic object to select it.
3. Position the pointer over one of the corner handles on the selected object.
4. While pressing the CTRL key, hold the mouse button down to drag the handle.

 Scaling by percentage:

1. Select the  Pointer tool from the Tool Palette.
2. Click on the graphic object to select it.
3. Choose Scale from the Object menu.
4. Press the up arrow to increase the size or press the down arrow to decrease the size.

 



New

Creates a new project.

 Use this menu command to start a new project.

 Selecting this command will bring up the Select a Project dialog.

NOTE: If you select New while working on a project which has not yet been saved, you will be 
prompted to save your current project before a new project can be created.

 



Open...

Opens a previously saved project.

 Use this menu command to load a saved project.

 Selecting this command will bring up the File Open    dialog.

 



Save

Saves the current project.

 Use this menu command to save a project.

 If the project has never been saved, selecting this command will bring up the File Save As dialog. If 
the project has previously been saved, selecting this command will save the project with the current 
modifications.

NOTE: If a project has not been saved, the title "The Print Shop Deluxe: Untitled" appears in the title 
bar at the top of the window. Once you save a project, the word "Untitled" will be replaced with your 
saved name.

 



Save As...

Saves a copy of the current project.

 Use this menu command to save a project for the first time or to save a currently open project with a 
different name.

NOTE: If a project is not saved, the title "The Print Shop Deluxe: Untitled" appears at the top of the 
window. Once you save a project, the word "Untitled" will be replaced with your saved name.

 



Revert to Saved

Reverts to the last saved version of a project.

 Use this menu command to switch back to the last save you made of your project.

NOTE: If a project is not saved, the title "The Print Shop Deluxe: Untitled" appears at the top of the 
window. Once you save a project, the word "Untitled" will be replaced with your saved name.

 



Preferences...

Sets the default font, color mode and save mode.

 Selecting this command will bring up the Preferences    dialog.

 Use this menu command to change the default font, the color mode to work in and the save mode.

NOTE: The changes you make in preferences will stay the same until you change them. This means 
that exiting and restarting the program will not change them back.

 



Printer Setup...

Lets you specify a printer to print your project and configure the printer settings.

 Selecting this command will bring up the Printer Setup    dialog.

 Use this menu command to select a printer from the list of installed printers and settings for the 
printer.

 



Print

Prints the currently open project.

 Selecting this command will bring up the Print    dialog.

 Use this menu command to print the currently open project and to set the number of copies. 
Coloring book and poster-sized options are also available for specific projects.

 



Exit

Exits The Print Shop Deluxe and returns to the Windows Program Manager.

 Use this menu command to close your Print Shop Deluxe document and quit the program. If you 
have created a new project that has not yet been saved, a dialog will appear asking you if you want to 
save the project.

 



Undo

Undoes your last action.

 Use this menu command immediately after you make a mistake or change your mind about an 
action. You can Redo changes if Undo was chosen by mistake.

 



Cut

Removes the selected object(s) and places them on the Clipboard.

 Use this menu command to remove the selected objects from your project to the Clipboard.

NOTE: Whatever was previously on the clipboard is replaced when cut is chosen.

 



Copy

Makes a copy of the selected object(s) and puts it on the Clipboard.

 Use this menu command to copy the selected object(s) from your project to the Clipboard for 
pasting.

NOTE: Whatever was previously on the Clipboard is replaced when copy is chosen.

 



Paste

Takes a copy of what is on the Clipboard and places it onto the currently open project.

 Use this menu command, after choosing Cut or Copy to place the contents of the Clipboard onto 
your project.

 



Delete

Removes any selected object(s) from the project without placing them on the clipboard.

 Use this menu command to delete any selected object(s). Selecting an object and pressing the 
DELETE key has the same effect.

 



Duplicate

Makes a copy of the selected object(s) and pastes them on top of the current object(s).

 Use this menu command to create a copy of the selected object(s) and paste them in one quick 
step.

 



Select All

Selects all objects in the currently displayed section of a project.

 Use this menu command to quickly select all the currently displayed objects in a section of a project. 
This can be easier than selecting each object individually.

 



Add
Places one of the following objects in your project. Click on an object name for more help selecting 
the specific object:

Square Graphic 
Row Graphic 
Column Graphic 
Text 
Headline 
Horizontal Ruled Graphic 
Vertical Ruled Graphic 
Mini-border 
Border 
New Print Shop Graphic 
Windows Bitmap Graphic 

 



Edit...

Brings up the editing or selection dialog for the selected object.

 Use this menu command to edit text or select a graphic. Pressing ENTER on the keyboard has the 
same effect.

NOTE: The edit command works only when one object type is selected.

 



Shadow

Places a gray shadow behind the selected graphic object(s).

 Use this menu command to add a shadow to a graphic object.

NOTE: The shadow command works only with graphic objects and adds a shadow behind the graphic 
itself, not behind the graphic box.

 



Frame

Places a frame around each selected object.

 Use this menu command to add a thin, thick, double line or drop shadow frame around each 
selected object.

 



Order

Lets you move the current object forward or backward in relation to other objects.

 Use this menu command to change the order in which objects appear or to find a hidden object.

Bring Forward - Moves selected object(s) one layer towards the front.
Bring to Front - Moves selected object(s) to the front.
Send Backward - Moves selected object(s) one layer towards the back.
Send to Back - Moves selected object(s) to the back.

NOTE: The backdrop will always remain the bottom most layer and the border the top most layer in 
your design. You are not able to use the order command to place anything behind a backdrop or in 
front of a border.

 



Scale...

Lets you change the size of the selected object(s) while maintaining the aspect ratio.

 Use this menu command to make an object larger or smaller while maintaining the same size 
aspect ratio.

 Selecting this command will bring up the Scale dialog.

 



Rotate

Lets you rotate any selected object(s) any degree.

 Use this menu command to rotate any objects clockwise or counter-clockwise a specfied number of 
degrees.

 Selecting this command will bring up the Rotate dialog.

NOTE: Borders, Windows Bitmap graphics, Banner text blocks, and calendar blocks cannot be 
rotated.

 



Flip

Lets you flip objects horizontally, vertically, or both.

 Use this menu command to flip objects relative to the horizontal, vertical or both axes.

Horizontal - Flips selected object(s) relative to the vertical axis.
Vertical - Flips selected object(s) relative to the horizontal axis.
Both - Flips selected object(s) relative to both the horizontal and vertical axes.

 



Lock

Prevents the resizing and movement of objects.

 Use this menu command to avoid accidental modification of an object.

NOTE: While a locked object's contents can be edited or changed, the object cannot be moved, 
resized, or scaled.

 



Unlock

Unlocks previously locked objects.

 Use this menu command after choosing the Lock command to regain the ability to move, resize, or 
scale a previously locked object.

 



Align...

Aligns two or more selected objects.

 Selecting this command will bring up the Align dialog.

 Use this menu command to align objects relative to the position of other another object.

NOTE: To select multiple objects, hold down the shift key while clicking on the object.

 



Change Backdrop...

Lets you select a backdrop for your project.

 Selecting this command will bring up the Select a Backdrop    dialog.

 Use this menu command to add or change a backdrop for your project.

 



Change Layout...

Lets you select a layout for your project.

 Selecting this command will bring up the Select a Layout    dialog.

 Use this menu command to use or change a layout for your project.

 



Zoom In

Magnifies the view of the project.

 Use this menu command to see your project in greater detail.

 



Zoom Out

Makes the view of the project smaller.

 Use this menu command to see more of the overall project appearance and less project detail.

 



Fit to Window

Fits the entire page of the project into the current program window size.

 Use this menu command to see more of the overall project appearance.

 



View 25%

Makes the view of the project a quarter of the actual size.

 Use this menu command to see more of the overall project appearance and less project detail.

 



View 50%

Makes the view of the project half of the actual size.

 Use this menu command to see more of the overall project appearance and less project detail.

 



Actual Size

Views the document at the actual printed size.

 



View 150%

Makes the view of the project one and a half times the actual size.

 Use this menu command to see more of the project detail and less of the overall project 
appearance.

 



View 200%

Makes the view of the project twice the actual size.

 Use this menu command to see more of the project detail and less of the overall project 
appearance.

 



Preview

Provides a full-screen view of how your project looks.

 Use this menu command to view the overall project appearance.

 



Hide Backdrop

Hides the backdrop.

 Use this menu command to remove the backdrop from view. Allows you to work on certain parts of 
the document without having to view the backdrop.

NOTE: Select this command again to show the backdrop.

 



Hide Placeholders

Hides the object placeholders.

 Use this menu command to remove the gray object placeholders from view. Allows you to work on 
certain parts of the document without having to view the placeholders.

NOTE: Selecting    "Hide Placeholders" will change the title of this menu command to "Show 
Placeholders." Select the "Show Placeholders" menu command to display the placeholders.

 



Hide Tools

Hides the Tool Palette.

 Use this menu command to remove the tool palette from view. Allows you to work on certain parts of 
the document without having to view the tool palette.

NOTE: Select this command again to show the Tool Palette.

 



Help Index

Displays an index of help topics.

 Use this menu command to view the help topic index of The Print Shop Deluxe.

 



Using Help

Displays help on using help.

 Use this menu command to view help on using the help system.

 



About...

Displays information about The Print Shop Deluxe.

 



Front of Card

Displays the front page of a greeting card.

 Use this menu command to view the front of the card when you are viewing the inside or back of a 
greeting card.

 



Inside of Card

Displays the inside page of a greeting card.

 Use this menu command to view the inside of the card when you are viewing the front or back of a 
greeting card.

 



Back of Card

Displays the back page of a greeting card.

 Use this menu command to view the back of the card when you are viewing the front or inside of a 
greeting card.

 



Change Year

Lets you change the year of a yearly calendar project.

 



Change Month

Lets you change the month of a monthly calendar project.

 



Change Week

Lets you change the week of a weekly calendar project.

 



Change Day

Lets you change the day of a daily calendar project.

 



Edit Day

Lets you edit the day of a monthly or weekly calendar project.

 Use this menu command to add or change text or graphics for a day of a monthly or weekly 
calendar project.

 



Edit Hour

Lets you edit the hour of a daily calendar project.

 Use this menu command to add or change text or graphics for an hour of a daily calendar project.

 



Calendar Options

Lets you change various options depending on the type of calendar project. Select a calendar type for 
more information:

Yearly Calendar Options 

Monthly Calendar Options 

Weekly Calendar Options 

Daily Calendar Options 

 



Adjust Length
Lets you increase or decrease the leading and trailing space of a banner to adjust the overall length.

 



Page Navigation Tool

 

Takes you to the front, inside or back of a greeting card. The tool appears at the bottom right of the 
screen. Select the left or right arrow to go to the previous or next page.

 





Yearly Calendar Options

The appearance of the calendar can be changed by modifying the font and month Block.

 Select a Font by clicking on the font name or the down arrow to the right of the font name.

 To enhance text, select the Bold or Italic options by clicking on the 
 box.

Month Blocks are the lines which separate the months of the year. Select plain, underlined 
or boxed by clicking the down arrow to the right of the current setting.

 



Monthly Calendar Options

The appearance of the calendar can be changed by modifying the font, font style and other 
display options.

 Select a Font by clicking on the font name or the down arrow to the right of the font name.

 To enhance text, select the Bold or Italic options by clicking on the 
 box.

Month Thumbnails will display a small monthly calendar of the month before and after the current 
month. To select thumbnails, click on the box to turn the option on.

Preceding/Following Days option will fill empty calendar days with the previous month's last few days 
and following month's first few days by displaying the numbers for those days in a smaller size font.

Highlight Sundays will emphasize the number for all Sundays of the month.

 



Weekly Calendar Options

The appearance of the calendar can be changed by modifying the font.

 Select a Font by clicking on the font name or the down arrow to the right of the font name.

 To enhance text, select the Bold or Italic options by clicking on the 
 box.

 



Daily Calendar Options

The appearance of the calendar can be changed by modifying the font.

 Select a Font by clicking on the font name or the down arrow to the right of the font name. 

 To enhance the text, select the Bold or Italic options by clicking on the 
 box.

Clock time can be represented in 12 hour or 24 hour time by selecting the appropriate button.

 



Greeting Card Orientation

Select the type of greeting card you want to create.

 Side Fold cards fold at the left side. 

 Top Fold cards fold at the top. 

 Side Fold Spread cards fold at the left side and have a backdrop that can fill the entire inside 
spread of the card. 

 Top Fold Spread cards fold at the top and have a backdrop that can fill the entire inside spread of 
the card.

 



Sign Orientation

Select the type of sign you want to create.

 Tall signs have a vertical, or portrait orientation.

 Wide signs have a horizontal, or landscape orientation.

 



Banner Orientation

Select the type of banner you want to create. Banners can be horizontal or vertical.

 Horizontal banner text will run from left to right.

 Vertical banner text will run from top to bottom.

 



Calendar Orientation

Select a page orientation for your calendar.

 Tall calendars have a vertical, or portrait orientation.

 Wide calendars have a horizontal, or landscape orientation.

 



Type of Calendar

Select the type of calendar you want to create.

 Yearly calendars show each month of the year.

 Monthly calendars show each day of the month.

 Weekly calendars show each day of the week.

 Daily calendars show 10 hourly time slots of a day.

 



Letterhead Orientation

Select the letterhead size you want to create.

 Regular size is 8.5 x 11 inches.

 Notepad size is 5.5 x 8.5 inches. Notepad size will print two to each sheet of 8.5 x 11 inch paper.

 



Yearly Calendar

Select a year for your calendar.

To select a Year, click on the up or down arrow. To type in a year, highlight the year by 
double-clicking on the year in the box and type in the year you want.

 



Calendar Month

Select a year and month for your calendar.

 To select a Year, click on the up or down arrow. To type in a year, highlight the year by double-
clicking on the year in the box and type in the year you want.

 To select a Month, simply click on the desired month.

 



Weekly Calendar

For a weekly calendar, select the month, year and starting date. The calendar will cover 
seven days beginning with the date you choose.

 Select a Month by clicking on the name of the month or the down arrow to the right of the month 
name and a list will appear. Select a month from the list.

 Select a Year by clicking on the up or down arrow. To type in a year, highlight the year by double-
clicking on the year in the box and type in the year you want.

 Select a starting Day by clicking on a day in the monthly calendar display.

 



Calendar Day

For a daily calendar, click on the name of the month or click on the down arrow to the right of 
the month and a list will appear. Select a month from the list.

 Select a Year by clicking on the up or down arrow. To type in a year, highlight the year by double-
clicking on the year in the box and type in the year you want.

 Select the Day by clicking on the day in the calendar display.

 Select the starting Time for your daily calendar. The calendar will include 10 time blocks beginning 
with whatever starting time you choose. For example, if you select 9 A.M. the calendar will display hourly 
time slots from 9 A.M. to 6 P.M.

 Clock time can be represented in 12 hour or 24 hour time by selecting the appropriate button.

 



Selecting a Project

The Select a Project dialog lets you choose a project type to create with The Print Shop 
Deluxe. It also lets you open a saved project or exit the program.

Click on a project type for more help:

Greeting Card 
Letterhead 
Sign 
Calendar 
Banner 

Open lets you open a previously saved greeting card, letterhead, sign, calendar or banner.

Exit    quits The Print Shop Deluxe and returns to the Windows Program Manager.

 



Editing Text

You can place text anywhere on your project. The text is entered in to a text block which can 
be sized, moved, rotated, framed, and colored. Text modification choices include the font, 
size, style, color, justification, and placement of the text within the text block. Your choices 
can be applied to all of the text or to selected sections only. This "rich text" feature allows you 
to make your printed message as interesting and individual as you wish.

Select a topic for more help:

Entering Text 
Modifying Text 
Previewing Text 
Selecting a Font 
Font Size 
Justification 
Selecting Colors 

 



Headline Text

Headline text lets you apply special effects to one or two lines of text. Headline text fills the 
entire headline block, expanding or contracting as necessary but always extending to the 
outermost boundaries of the block. The text can be squeezed, arched, slanted, stretched and 
otherwise manipulated to produce dramatic, eye-catching results.

Select a topic for more help:

Entering Headline Text 
Customizing Headline Text 
Shaping Headline Text 

NOTE: Justify options are only available when two lines of text are entered.

 



Banner Text

You can have one or two lines of text on your banner. Each line can have up to 63 characters 
of text; the length of the banner will adjust automatically to accommodate the text. The text 
can be arched, slanted, stretched and otherwise manipulated to produce dramatic, eye-
catching results.

Select a topic for more help:

Entering Banner Text 
Customizing Banner Text 
Selecting a Font 
Shaping Text 
Justify 
Size 

 



Rotating

The Rotate option lets you rotate the current object by any number of degrees you want. 

 To use the angle dial, drag the indicator to the desired location. You can click the lines around the 
dial to quickly select the direction or you can type the degrees in the box.

 



Selecting a Library

Backdrops, layouts and graphics are stored in libraries. A list of available files will appear in 
the Files list.

 If you want a library from another directory, double-click on the desired directory or click on the "[..]" 
symbol in the Directories list to move back one directory level.

 If you want a library from another Drive, double-click on the drive letter from the bottom of the 
Directories list.

If you have problems loading a library, refer to The Print Shop Deluxe User's Manual.

 



Setting Preferences

You can permanently save your default font and color mode.

 The Default Font is the font that you would like to use whenever you create text or headlines. 
Select the font from the list of fonts by clicking on the font name or the down arrow. Scroll through the list 
of fonts and select the font.

 Select the Work In option to select Color, Grayscale or Black and White.

NOTE: The changes you make in preferences will stay the same until you change them. This 
means that exiting and restarting the program will not change them back.

 



Printer Setup and Selection

Specify the default printer for printing your projects.

 Select a printer from the list of installed printers. If no printers appear in the list, you will need to 
install printer drivers in Windows. For help on installing printer drivers, consult your Windows User's 
Guide.

 You may configure printer settings by selecting the printer from the list and clicking on the Setup 
button.

 



Printing

Choose the print options you want from the list that apears on the screen. Click on a topic for 
more help:

Number of Copies 
Coloring Book Option 
Poster Sized Option 

Options not available for the current project and printer will appear grayed-out.

The currently selected printer name will appear at the top of the dialog. Click on the Printer Setup 
button to choose a different printer or to modify printer settings.

 



Scaling

Scaling lets you resize an object, making it larger or smaller. The proportions will remain the 
same.

 To make the object larger, click the up arrow.

 To make the object smaller, click the down arrow.

 



Custom Effect

A custom style effect can be used to create interesting and eye-catching type. Outlines, fills 
and shadows can be added or changed along with the color specification for each element. 

In the Text section of the dialog:
Effect options allow the specification of outlines.
Fill options provide various fill effects.

In the Shadow section of the dialog:
Effect options allow the specification of shadow types.
Position options determine the location of the shadow.
Fill options provide various shadow fill effects.
Shadow options will be grayed-out when "No Shadow" appears in the Shadow Effect field. 
Select a different shadow effect option by clicking on the effect name.

Click on a topic for more help:

Selecting Colors 

 



Aligning

You can align objects in a number of ways.

 To adjust objects so that they are positioned in a specified location relative to one another, select 
one of the align buttons. Select the button which displays the desired position.

 



Vertical Banner Text

A vertical banner has one line of text. The line can have up to 63 characters of text; the length 
of the banner will adjust automatically to accommodate the text.

Select a topic for more help:

Entering Vertical Banner Text 
Customizing Vertical Banner Text 

If you want to enhance your text, select the Font, Bold or Italic options. Your modifications 
will apply to the entire text.

 



Registration

Enter a name for your copy of The Print Shop Deluxe. This name will appear on the title 
screen every time you start the program.

 



Adjusting Banner Length

The Adjust Length option lets you increase the length of the banner without adding more 
text. You can add space to the beginning or the end of the banner.

 Add Leading Space adds space to the front of the banner.

 Add Trailing Space adds space to the end of the banner.

Type in the number of inches you want to add, using whole numbers only.

If you later want to change the amount of space you've added, simply select Adjust Length 
again and type in the number you want. If you want to remove leading or trailing space that 
you have added, enter a zero.

 



Editing a Day of the Month

To edit a day, select the day from the calendar display. When you click on a day, a highlight 
box will appear around the day and the number of the day will be shown in the preview 
display.

Click on a topic for more help:

Edit Text Button 
Clear Text Button 
Select Graphic Button 
Clear Graphic Button 
Circle Date Option 
Selecting Colors 
Shading Slider 

 



Editing a Day of the Week

To edit a day, select the day from the weekly calendar display. When you click on a day, a 
highlight box will appear around the day and the selected date will be shown in the preview 
display at the top of the dialog.

Select a topic for more help:

Edit Text Button 
Clear Text Button 
Select Graphic Button 
Clear Graphic Button 
Circle Date Option 
Selecting Colors 
Shading Slider 

 



Editing an Hour
To edit an hour, select the hour from the hour display. When you click on an hour, a highlight 
box will appear around the hour and the selected hour will be shown in the preview display at 
the top of the dialog.

Click on a topic for more help:

Edit Text Button 
Clear Text Button 
Select Graphic Button 
Clear Graphic Button 
Circle Date Option 
Selecting Colors 
Shading Slider 

 



Selecting a Backdrop
Beautiful full-color backdrops have been created especially for each type of Print Shop 
Deluxe project. The backdrops are designed to take advantage of the entire display area 
while allowing ample space for whatever text or graphics you may want to add. When 
creating a new project, layouts designed especially for the selected backdrop will become 
available once you have made your backdrop choice.

Click on a topic for more help:

Making a Selection 
Selection Navigation Keys 
Modifying a Backdrop 
Selecting a Different Library 

 



Selecting a Graphic
A wide variety of square, row, and column graphics are available for your Print Shop Deluxe 
projects. Row graphics are long horizontal graphics. Column graphics are long vertical 
graphics.

Click on a topic for more help:

Making a Selection 
Selection Navigation Keys 
Selecting a Different Library 

Select the Apply to All check box if you would like the current graphic selection to be used 
for every graphic of the same type on the current project page.

 



Selecting a Rule
Decorative straight-line graphics are called ruled lines. Horizontal or vertical ruled lines are 
ideal for separating sections of text and graphics or for adding a decorative touch. The same 
graphics are available for both orientations; a vertical ruled line is simply a horizontal ruled 
line set at 90 degrees.

Click on a topic for more help:

Making a Selection 
Selection Navigation Keys 
Selecting a Different Library 

Select the Apply to All Rules check box if you would like the current rule selection to be 
used for every rule on the current project page.

 



Selecting a Border
Decorative borders can be added to your Print Shop Deluxe project. The borders are 
designed to complement and enhance the backdrops and other graphic elements. You can 
modify the border by changing its color if it is monochrome, its color intensity if it is multi-
color, and the color or color intensity of the background behind the border. You can also 
change the width of the border from normal to wide.

Click on a topic for more help:

Making a Selection 
Selection Navigation Keys 
Selecting a Different Library 

Select the Wide Border check box to make the border wide.

 



Selecting a Mini-Border
Mini-borders are a way of creating a decorative frame around a block of text or a graphic. The 
available mini-border patterns are the same patterns that you see in the border list. You can 
modify the mini-border by changing its color if it is monochrome, its color intensity if it is multi-
color, and the color of the background on which it appears. You can also change its width 
from normal to wide. The mini-border can be rotated, stretched, and moved anywhere you 
want on the page.

Click on a topic for more help:

Making a Selection 
Selection Navigation Keys 
Selecting a Different Library 

Select the Apply to All Mini-borders check box if you would like the current mini-border 
selection to be used for every mini-border on the current project page.

 



Selecting a New Print Shop Graphic
You can use any New Print Shop graphics with The Print Shop Deluxe. The New Print Shop 
uses bit-mapped graphics. The entire library of New Print Shop graphics can be used with 
The Print Shop Deluxe.

NOTE: Since New Print Shop graphics are bit-mapped, they will not appear as smooth as 
the object-oriented graphics of The Print Shop Deluxe; the results when you scale or 
stretch them may not be as satisfactory.

Click on a topic for more help:

Making a Selection 
Selection Navigation Keys 
Selecting a Different Library 

Select the Apply to All PS Graphics check box if you would like the current New Print Shop 
graphics selection to be used for every New Print Shop graphic on the current project page.

 



Selecting a Windows Bitmap
You can use any Windows bitmap with The Print Shop Deluxe. This greatly expands design 
possibilities, giving you the ability to import your own graphics. Once you have selected a 
Windows bitmap graphic you can modify it in many of the same ways you modify a Print Shop 
Deluxe graphic.

NOTE: Since Windows bitmap graphics are bit-mapped, they will not appear as smooth as 
the object-oriented graphics of The Print Shop Deluxe; the results when you scale or 
stretch them may not be as satisfactory.

To select a Windows bitmap graphic, a list of available files will appear in the Files list.

If you want a Windows bitmap graphic from another directory, double-click on the desired 
directory. Click on the "[..]" symbol in the Directories list to move back one directory level. If 
you want a Windows bitmap graphic from another Drive, double-click on the drive letter from 
the bottom of the Directories list.

 



Selecting a Layout
The Print Shop Deluxe contains numerous layouts designed to work with specific backdrops. 
The layouts provide space for text, graphics, and other design elements. The transparent 
gray boxes superimposed over the chosen backdrop represent the different graphic elements 
that can be used in a Print Shop Deluxe project. Once you have chosen a layout, you can fill 
it in and modify it.

Click on a topic for more help:

Making a Selection
Selection Navigation Keys 
Layout Icon Guide 

NOTE: If you choose the Lighten Backdrop option, when you proceed to selecting a layout, 
you will not only see the layouts designed specifically for the selected backdrop, but all the 
generic layouts for the orientation on which you are working. This gives you access to a wide 
variety of designs and can create quite a striking effect.

 



Opening a Project

Select the button next to the name of the specific project type to open. A list of available files 
will appear in the Files list.

 If you want a project from another directory, double-click on the desired directory. Click on the "[..]" 
symbol in the Directories list to move back one directory level.

 If you want a project from another Drive, double-click on the drive letter from the bottom of the 
Directories list.

 



Saving a Project

You can save your project and use it again whenever you want. To save, type in a file name 
up to eight characters long in the Filename field.

 Use the Description field to save a brief description to describe your project. A description will help 
you identify the project later on.

 Select the directory location from the Directories list.    To change directories, double-click on the 
desired directory. Click on the "[..]" symbol in the Directories list to move back one directory level. If you 
want to save a project to a different Drive, double-click on the drive letter from the bottom of the 
Directories list.

Click on a topic for more help:

Full Save Mode 
Fast Save Mode 

 



Selecting Backdrops, Layouts and Artwork

Backdrops provide attractive backgrounds to be used along with additional graphics and text. 
Layouts provide spaces for graphics and type. Artwork refers to Graphics, Borders, Mini-
Borders, Rules, New Print Shop Graphics and Windows Bitmap Graphics. 

Choose a topic for more help:

Backdrops 
Layouts 
Graphics (Squares, Columns, Rows)
Borders 
Mini-Borders 
Rules 
New Print Shop Graphics 
Windows Bitmap Graphics 

 



Greeting Card
The Print Shop Deluxe lets you produce beautiful cards for all occasions. Your personalized 
message and graphic choices make the card uniquely your own. The striking backdrops and 
accompanying layouts help you achieve professional-quality results in minutes.    You can use 
the back of the card for adding more graphics and giving yourself credit for your creation.

You can create cards that fold at the side or the top. In addition, you can use designs that fill the 
entire inside spread of the card.



Sign
Sign projects let you create eye-catching signs for every purpose. Use signs to create 
announcements, flyers, or bulletin board notices. Make large-sized posters by printing your 
designs at greater than 100%.

You can choose a tall (portrait) or wide (landscape) orientation. Many different backdrops and 
layouts are available to guide your design. 



Banner
Banner projects let you make horizontal or vertical banners to deliver your message. You can 
use backdrops designed for each orientation and add up to 63 characters of text. As you add 
text, the banner will increase in length. Graphic objects will shift so they always remain in the 
same position relative to the text.



Calendar
Calendar projects let you create yearly, monthly, weekly, and daily calendars personalized with 
your own notes, messages, graphics, and highlighted dates. With all these possibilities, Print 
Shop Deluxe calendars make great gifts and are useful additions to your busy life at home, 
school, or in the office.



Letterhead
Letterhead projects let you produce impressive-looking letterhead or informal stationery in 
standard business or notepad size. By saving your designs you'll be able to print a new supply 
of stationery whenever you want. If you need to change a name, address, or phone number you 
can do so quickly and easily without additional expense.



Entering Text

Enter text in the text entry area. Words will "wrap" automatically to the next line.

Select a topic for more help:

Starting a New Line 
Making a Mistake 
Navigation Keys 
Previewing Text 

NOTE: As you type in the text, the text itself will be displayed without the formatting and style. 
To see how the text will look when printed, you must click on the Preview button below the 
text entry box. When you preview the text, it will be displayed in the text entry area in the 
chosen font, size, style, and color. When previewing using the preview button, text that will 
not fit in the text block will appear below the horizontal line.

 



Modifying Text

Modifications will apply to all of the text or to a specific section of text that you highlight. To 
highlight text, click and hold the mouse button down and drag the cursor over the text. To 
highlight text using the keyboard, use the arrow keys to move the cursor to the left or right of 
the text section you want. Hold down the SHIFT key and use the left or right arrow key to 
highlight the text.

Once text is highlighted, the font, size, style, color, and justification of the text within the text 
block can be modified.

Additional shortcuts for highlighting text are pressing the SHIFT and HOME or the SHIFT and 
END keys to highlight the line of text that the cursor is currently on. Pressing CTRL-SHIFT-
HOME or CTRL-SHIFT-END keys to highlight all text from the current cursor position to the 
beginning or end of the text entry field. If you are using a mouse, move the cursor to the left 
of the text section; then hold down the left mouse button and move the mouse to highlight the 
text.

 



Entering Headling Text

Enter headline text in the text entry area at the top of the window. You can enter one or two 
lines of text. When you have finished the first line, press ENTER; the cursor will move to the 
second line. If you make a mistake or want to change any words in the text, use the arrow 
keys or a mouse to position the pointer to the right of the text you want to change. Use the 
backspace key to erase. Then type in your new text. The more text you enter, the more 
compressed the letters will be in the headline text block. If your text is too compressed, resize 
the headline object to a wider size.

 



Customizing Headline Text

To modify and enhance the text, select the style options you want. A library of 18 effects are 
available to use. The last effect is a special effect you can customize. Scroll through the 
library by clicking on the left or right arrow below the displayed effect. Click on the Customize 
button to create a custom effect.

 



Entering Banner Text

Enter banner text in the text entry area at the top of the window. You can enter one or two 
lines of text. When you have finished one line, press the ENTER key; the cursor will move to 
the next line. If you make a mistake or want to change any words in the text, use the arrow 
keys or the mouse to position the pointer to the right of the text you want to change. Use the 
backspace key to erase. Then type in your new text.

 



Customizing Banner Text

To modify and enhance the text, select the style options you want. A library of 18 effects are 
available to use. The last effect is a special effect you can customize. Scroll through the 
library by clicking on the left or right arrow below the displayed effect. Click on the Customize 
button to create a custom effect.

 



Entering Vertical Banner Text

Enter banner text in the typing area at the top of the window. If you make a mistake or want to 
change any words in the text, use the arrow keys or the mouse to position the pointer to the 
right of the text you want to change. Use the backspace key to erase. Then type in your new 
text.

 



Customizing Vertical Banner Text

To modify and enhance the text, select the style options you want. A library of 18 effects are 
available to use. The last effect is a special effect you can customize. Scroll through the 
library by clicking on the left or right arrow below the displayed effect. Click on the Customize 
button to create a custom effect.

 



Starting a New Text Line

Words will "wrap" automatically, but to force the start of a new line, press the ENTER key. The 
cursor will move to the next line.

 



Mistakes Entering Text

If you make a mistake or want to change any words in the text, use the arrow keys or the 
mouse select the text. Using the mouse, click to position the cursor to the right of the text you 
wish to change. While holding the mouse button down, drag in the direction to highlight the 
text. Using the keyboard, position the cursor to the right of the text you want to change using 
the arrow keys. Select the text by holding the SHIFT key down while pressing on the Left 
Arrow key to highlight the text you wish to change. Use the backspace key to erase. Then 
type in your new text.

 



Text Entry Navigation Keys

The following keys will assist you in navigating the cursor location within a text entry box.

 Press the HOME key to position the cursor at the beginning of the line of text.

 Press the END key to position the cursor at the end of the line of text.

 Press CTRL-HOME to move the cursor to the first character in the text entry field.

 Press CTRL-END to move the cursor to the last character in the text entry field.

 



Preview Button

Preview lets you see how your text looks with all the design options you have selected. Until 
you choose Preview, you will see only the the plain text in the text entry area.

 When you preview the text, it will be displayed in the text entry area in the chosen font, size, style, 
justification, and color.

 When text appears to go beyond the horizontal line in the text entry display window, one or more of 
the following will need to be performed: the font size will need to be reduced, the amount of text will need 
to be reduced, or the size of the block increased.

 Once you have chosen the Preview button, it will be replaced by and Edit button. Click on the Edit 
button to return to text editing mode.

 



Selecting a Font

 Select the Font name from the list of fonts by clicking on the font name or the down arrow to the 
right of the font name. Scroll through the list of fonts by clicking on the down arrow to view more font 
choices. Click on a font name to choose the font.

 To apply a Bold or Italic style, turn the option on or off by clicking on the appropriate 
.

 



Font Size

Font size changes will be applied to the text that is currently selected.

 Font sizes are expressed in points, a standard type measurement. Choose sizes ranging from extra 
small to extra large. The actual point size is shown in parentheses.

 To select a size, click on the down arrow to the right of the current font size number. To enter a 
specific point size, choose "Other" from the font size list and type in a point size.

 



Justification

Justification refers to the alignment of text. Justification will be applied to the text that is 
currently selected.

 To select justification, click on the name of the current justification setting or on the down arrow to 
the right of the current justification.

 Choose the justification you want: Left, Center, Right, or Full. If you choose "Full" the text will be 
spaced so that it spans the full distance from the left margin to the right margin of the text block.



Selecting Color

Color is applied to items, such as the page, text, border, etc. A list appears in the Item 
Selector    found in the Tool Palette above the Color Selector . Perform the following to apply 
color:

1. Select an item by clicking on the name of the currently displayed item or the down arrow 
that appears to the right of the Item Selector    in the Tool Palette.

2. The color can be changed for the selected item by clicking on the currently displayed 
color or the arrow that appears to the right of the Color Selector    in the Tool Palette. A list 
of colors will appear. Select a color by releasing the mouse button while pointing to the 
desired color.

 



Edit Text
The Edit Text button enables you to add or change text for the calendar display. You can edit 
text by clicking on the button or by double-clicking on the text placeholder in the preview 
display.



Clear Text
The Clear Text button will remove all text from the calendar display.



Select Graphic Button
The Select Graphic button enables you to add or change a graphic for the calendar. You can 
select a graphic by clicking on the Select Graphic button or by double-clicking on the graphic 
placeholder in the preview display.



Clear Graphic Button
The Clear Graphic button will remove the graphic from the calendar display.



Circle Date
The Circle Date option will draw a circle around the number of the day. To select or de-select 
the option, click on the box.



Making a Selection
Make a selection from the list in the dialog. Use the mouse to click on a name to highlight. To 
see more items in a list, click on the down arrow that appears to the right of the list. A thumbnail 
preview of each highlighted item will appear next to the selection list.



Selection Navigation Keys
To view more files, click the scroll arrow at the right of the list box or use one of the following 
keys to view more files quickly.

Press HOME to go to the beginning of the list.

Press END to go to the end of the list.

Press PG UP to move up one screen.

Press PG DN to move down one screen.



Selecting a Different Library
The Library option at the top of the list allows you to use files stored in other libraries. A library 
is a collection of graphics for use with the Print Shop Deluxe. Click on the library name or on 
the down arrow to the right of the library name and a list will appear. Highlight the choice you 
want. Select "Other" to load a library that is not currently listed.



Number of Copies
Type in the number of copies you want. You can print as many as 99. When printing multiple 
copies on a dot matrix printer, pause printing from time to time to avoid overheating the 
printhead.



Coloring Book Option
Prints your project in outline only. Ideal for producing coloring books. Also a good way to save 
on ribbons when printing projects such as banners.



Poster Sized Option
You can increase the size of your printed project by selecting a poster size. Choose the Poster 
sized check box to the left of the title to turn this option on and select the down arrow at the 
right to select a different size. Sizes range from 2 x 2 to 4 x 4.



Shaping Text

Select a shape to make your text fit the shape. Select a shape by clicking on the down arrow 
that appears to the right of the currently displayed shape.

Experiment to find the shape you want for your text. Virtually hundreds of headline effects can 
be created when the shape option is used in conjunction with other design options.

 



Full Save Mode
Full save mode should be used if you want to move a file to a different computer.



Fast Save Mode
Fast save mode saves your project with references to the graphic information. Fast save mode 
conserves disk space, but does not retain all graphic information when loading the project on a 
computer which does not have the same installed graphics. If you plan to open your project on 
a different computer, use the Full Save Mode.



Banner Text Size

The Size option lets you specify the relative size of the lines of text.

 Small Over Large - Two lines of text: the first line is small, the second is large

 Large Over Small - Two lines of text: the first line is large, the second is small

 Medium Over Medium - Two lines of text with equal height

 



Modifying a Backdrop
You can modify the backdrop by changing its color if it is monochrome, its color intensity if it is 
multi-color, and the page color (the color of the background on which it appears).

To modify color for the page, select the "page" item from the Item Selector    in the Tool 
Palette and select the appropriate color from the Color Selector    in the Tool Palette. 

To modify color intensity, click on the left or right arrow of the Shading Slider    to increase or 
decrease the shade value of the selected item.



Layout Icon Guide

The list below shows the various types of layout placeholders:

      Square Graphic

      Text Block

      Headline

    Ruled Line

      New Print Shop Graphics

      Windows Bitmap

      Border

      Mini-Border

      Row Graphic

      Column Graphic

 




