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Icon Selection (Program Item Property)
The    particular icon within the icon file to be used to represent the program item.



Icon Filename (Program Item Property)
File containing the icon to be used to represent the program item. After changing the filename or path in 
this field, click the View button to have the icons from the file displayed in the Icon Selection field. If this 
field is empty, or if the selected file contains no icons, when you click Ok an icon from progman.exe will 
be used.



Run Minimized (Program Item Property)
Value which, if set, will cause GFile (or Program Manager) to start the program item in a minimized 
(iconized) state.



Shortcut Key/Hotkey (Program Item Property)
A keyboard sequence, unique to the particular program item, which will, when typed, cause the item to 
be launched. If the program item has been previously launched, typing the shortcut key will restore the 
item, if minimized, and will raise it above other programs. Must be    Ctrl+Shift, Ctrl+Alt, or    
Ctrl+Shift+Alt followed by a    normal or function key. 



Working Directory (Program Item Property)
The program item's working drive and directory. May be overridden by the program itself, launch options, 
or limitations/restrictions imposed by underlying (usually network) system level software.



Command Line (Program Item Property)
The command sequence required to run the program. Include the program (path)name and any 
switches or arguments to be used every time the program is run.



Description (Program Item Property)
Descriptive name for the program item. Appears below the item's icon when using Program Manager, 
beside the icon when using GFile.



Command Line (GFile Control)

Single line text field for entering Windows or DOS commands. See Command Line for more information.



Configurable Button Bar

Array of 8 buttons, with program items assigned to each. See Button Bars for more information.



Command Button Bar

Array of 8 buttons with GFile functions permanently assigned to each. See Button Bars for more 
information. Click on buttons above to identify each.



Panel - File Mode

Collection of controls for displaying and selecting files for manipulation. Displays only the names of files. 
See Panels for more information. Click on picture above to identify each control.



Panel - Long Mode

Collection of controls for displaying and selecting files for manipulation. Displays the name, size, and 
date/time of last modification for each file. See Panels for more information. Click on picture above to 
identify each control.



Panel - Info Mode

 A single box containing information about a panel's selected drive/directory and resource information 
from Windows. See Panels for more information.



Panel - Program Group Mode

Collection of controls for displaying program group contents, and for manipulating program items. See 
Panels for more information. Click on picture above to identify each control.



Status Line

Displays information about the currently selected file(s) or program item(s). See Status Line for more 
information.



Menu Bar

Row of labels representing pulldown menus that are displayed when the corresponding label is clicked. 
See Menu Bar for details. Click on picture above to see each menu.



Executable
A file that has an extension of .exe ,    .com ,    .pif , or .bat and can presumably be executed by 
Windows as a program.



Drag
Place the mouse over a list that has a selection or selections, press the left mouse button, and while still 
pressing the mouse button, move the mouse to another location. If dragging is taking place, the mouse 
cursor will change to reflect whether or not the dragged selection(s) can be dropped.



Drop
While dragging a selection or selections, release the left mouse button over a list, button, or other 
graphical item. 



Group Box

A drop-down list containing the names of program groups. The current selection in this list will determine 
what is displayed in the corresponding program item list. Click on picture above to see/return to Program 
Group Mode panel.



Program Item List

A multiple-selection scrolled list containing the icons and (optionally) names of program items as 
determined by the group box. Select individual items by clicking with the left mouse button. Make 
multiple selections by combining pressing the Shift (contiguous) or Control (non-contiguous) keys and 
clicking with the left mouse button. Click on picture above to see/return to Program Group Mode panel.



Drive Box

A combo-box displaying a panel's current drive, and containing the drive letters and labels for each disk 
drive found on the system. Determines the drive whose contents will be displayed in the panels directory 
list and file list. To change the current drive, click on the drive box, then select the desired drive from the 
drop-down list that is displayed. Click on picture above to see/return to File Mode panel.



Directory List

A scrolled list displaying the panel's current directory, the directories superior to the current directory, 
and the sub-directories of the current directory for the drive displayed in the corresponding drive box. 
Determines the directory whose files are displayed in the panels file list. To change directories, double 
click on the desired directory name. Click on picture above to see/return to File Mode panel.



File List

A multiple-selection scrolled list containing the names of files as determined by the drive box, directory 
list, and template field. If the panel's display mode is Long File, the file list displays the size and 
date/time of last modification for the files. Select individual files by clicking on their names with the left 
mouse button. Make multiple selections by pressing the Shift (contiguous) or Control (non-contiguous) 
keys and clicking with the left mouse button. Click on picture above to see/return to File Mode panel.



Template Field

An editable text field in which comma or semicolon separated filename templates may be entered. 
Determines the filenames that will be displayed in the panels file list. After changing the contents of the 
field, you must press Enter or the field will be restored to its previous value when it loses the keyboard 
focus. Click on picture above to see/return to File Mode panel.



Active Panel
The last panel which was activated. It will be highlighted using the Active color. Most times, it is the 
panel in which a drive, directory, template, file, group, or item was last selected or changed. To change 
the active panel, either click on a control in the desired panel, use the Next command (perhaps several 
times) from the View menu, or press the Tab key (perhaps several times) until the desired panel is 
highlighted. Use of the Next menu command is the only way to make an Info Mode panel the active 
panel.



Refresh Button

Refreshes all panels. See Refreshing Panels. Click on picture above to see/return to Command Button 
Bar display.



Search Button

Searches for filename. See Finding Files. Click on picture above to see/return to Command Button Bar 
display.



Create Dir/Group Button

Creates directory or program group. See Creating Directories and Creating Program Groups. Click on 
picture above to see/return to Command Button Bar display.



Delete Button

Deletes items. See Deleting Files, Deleting Program Items, Deleting Directories, and Deleting Program 
Groups. Click on picture above to see/return to Command Button Bar display.



Move Button

Moves items. See Moving/Renaming Files, Moving Directories, Moving Program Groups, and 
Moving/Renaming Program Items. Click on picture above to see/return to Command Button Bar display.



Copy Button

Copies items. See Copying Files, Copying Program Items, Copying Directories, and Copying Program 
Groups. Click on picture above to see/return to Command Button Bar display.



Print Button

Prints files. See Printing Files. Click on picture above to see/return to Command Button Bar display.



Run Button

Launches applications. See Launching Applications From File Lists and Launching Program Items. Click 
on picture above to see/return to Command Button Bar display.



Serialized Execution

As described under Printing Files, GFile uses a queue to serialize print operations in order to prevent 
large numbers of associated programs from starting at the same time when printing multiple files. This 
same queue can be used to serialize the launching of applications - from program items, files, or the 
command line.

When serialization is in effect, applications you launch from GFile (other than via shortcut key) are 
placed at the end of the queue, and only one application from the queue is allowed to be running. When 
an application that was started from the queue terminates, GFile will start the next application in the 
queue,    and begin listening for notification that the newly launched application has completed. GFile 
continues this sequence until all the jobs in the queue have been completed.    You can continue to use 
GFile while items are waiting in the queue, and in fact, can add new jobs to the queue.

You can turn off serialization while jobs are in the queue, start some applications immediately (non-
serialized) with GFile, and it will have no effect on the queued jobs - they will continue to wait until it is 
their turn to start. As you might expect, you can then turn serialization on, and add more jobs to the 
queue - going back and forth between serialized and non-serialized execution as often as you like.

The queue used for serialized execution is the same queue that is used for serialized printing - thus 
execution and print jobs can be mixed and will wait for each other - only one job from the queue runs at 
a time.

There are three menu options that control serialized execution:

Serialize Execution on the Options menu:

When selected (checked) will cause all future (until de-selected) programs launched to be placed in 
the queue. Note that the jobs are fully qualified at the time they are placed in the queue - if Prompt 
for Dir/Arguments and/or Append Selected Files options (see Application Launch Options) are 
selected and are appropriate, they will be performed prior to the job being added to the queue.

When de-selected (un-checked), will cause future program launching to be performed immediately. 
However, de-selecting this option will not affect any jobs currently in the queue - they will continue to 
wait for their turn to start.

Pause Queue on the System menu:

When selected (checked), causes GFile to stop starting new jobs when old jobs complete. Does not 
affect the contents of the queue, nor does it prevent new jobs from being added to the queue, either 
as a result of launching with Serialize Execution selected or as a result of printing.    Has no effect on 
non-serialized execution.

When de-selected (un-checked), will allow GFile to continue starting queued jobs when old jobs 
complete. If no previous jobs are running when this option is de-selected, will start the job that is now 
at the head of the queue.

Clear Queue on the System menu:

Cancels all queued jobs.



What Can GFile Do?

GFile is a Windows desktop manager program, designed to allow you to perform the most commonly 
used Program Manager and File Manager operations. It supports the use of both the keyboard and 
mouse for doing these operations, and provides a variety of configuration options.

General Capabilities

Copy, move/rename, delete, change attributes on, and make program associations for files

Create, copy, move, delete, and change attributes on directories

Copy, move, and delete entire directory trees

Launch Windows and DOS applications using program items, hotkeys, command lines, and user 
configurable command buttons

Print documents for which there is a defined Document Class

Create, configure, copy, move/rename, and delete program groups and program items

Search disks/directory trees for files of a particular name or which match a template

Perform binary comparisons between files

Launch applications in serialized (batch - one job at a time) mode

Set the Windows shell program, reboot Windows, or reboot the system

Techniques for Performing Operations

Menu selections

Pre-defined command buttons for some of the more common operations

Drag and drop operations for most common operations

Configuration Options

Number, size, and position of file/program group panels displayed

Number and position of button bars displayed

Whether or not a status line is displayed

The colors, 3D shadow thickness, and font used can be specified in the GFile initialization file 
(gfile.ini)



GFile Windows and Buttons

Select the item on which you wish to receive help

Main Window and Component Names

Menu Bar

Panels

Button Bars

Command Line

Status Line



GFile Glossary

Following are a list of terms and names used in the GFile documentation that apply specifically to GFile. 
No attempt is made to define standard Windows terms or names. Please refer to your Windows 
documentation or help files for those standard terms. Click on the term or name, and a definition will 
appear in a pop-up window.

Active Panel

Command Button Bar

Command Line (GFile Control)

Command Line (Program Item Property)

Configurable Button Bar

Description (Program Item Property)

Directory List

Drag and Drop

Drive Box

Executable

File List

File Mode

Group Box

Hotkey (Program Item Property)

Icon File (Program Item Property)

Icon Selection (Program Item Property)

Info Mode

Long Mode

Menu Bar

Minimized (Program Item Property)

Program Group Mode

Program Item List

Shortcut Key (Program Item Property)

Status Line

Template Field

Working Directory (Program Item Property)



Menu Bar 

The GFile Menu Bar provides access to the commands that GFile performs. If you are unfamiliar with 
Windows menu bar operations, please see the Help Commands selection of How to Use Help.

The seven entries on the GFile menu bar are:

File
Commands that directly manipulate files, directories, groups and program items

Edit
Commands that select files, and compare file contents

View
Commands that affect the information displayed in the panels

System
Commands that deal with operating system level facilities

Options
On/Off parameters that affect application launching, and copying/moving/deleting files and 
program items

Window
Commands that determine the number and arrangement of displayed panels, button bars, and 
other visual elements

Help
Informational commands



Panels

The panels are the major components of GFile. They display information about the objects (files, 
directories, program groups, program items) that GFile manipulates, and allow you to select the objects 
to be manipulated. You can have up to 12 (depending on the resolution of your monitor) panels 
displayed at once, arranged in a 4x3 grid. Or, more likely, a subset of the 12 panels can be displayed. 
Some popular combinations on standard VGA are:

One row of two panels

Two rows of one panel

One row of one panel and one row of two panels

Two rows of two panels

The panels are always in one of four possible display modes:

Program Group 

Displays a Group Box for selecting a program group whose contents are to be displayed, and a 
multiple-selection Program Item List containing the icons and names of the program items from the 
currently displayed group.

File 

Displays a Drive Box for selecting a drive, a Directory List for selecting a directory, an editable 
Template Field for specifying the filename template(s) to be used, and a multiple-selection File List for 
selecting filenames.

Long File 

Displays an expanded format version of the File display mode. The information on each file includes 
the size and date and time of creation as well as the name.

Info 

Displays information about the currently selected drive and directory for the panel, and mode, 
memory, and resource information from Windows. The information is updated at regular intervals, or 
can be manually refreshed by clicking on the panel with the left mouse button.

For instructions on selecting the panels to be displayed, panel sizing and arrangement, and changing 
panel modes, see Changing the Windows and Buttons Displayed.



Button Bars

The button bars provide convenient alternatives to the menu entries and program group panels for 
performing specific GFile operations or launching applications. There are two kinds of button bars: The 
command button bar and user configurable button bars.

Command Button Bar 

Consists of 8 push buttons that correspond to commonly used GFile commands. The GFile 
commands associated with the buttons cannot be changed. The buttons, in left to right order, are:

Run Used to launch applications. See Launching Files and Launching 
Program Items for more information.

Print Prints files. See Printing Files for more information.
Copy Copies items. See Copying Directories, Copying Files, Copying Program 

Groups, or Copying Program Items for more information.
Move Moves or renames items. See Moving Directories, Moving/Renaming 

Files, Renaming Program Groups, or Moving/Renaming Program Items 
for more information.

Delete Deletes items. See Deleting Directories, Deleting Files , Deleting 
Program Groups, or Deleting Program Items for more information.

Create Creates a directory or program group. See Creating Directories or 
Creating Program Groups for more information.

Search Searches a drive or directory tree for a filename that matches a specified 
filename or template. See Finding Files for more information.

Refresh Re-reads panel information, updates and repaints the panels. See 
Refreshing Panels for more information.

Configurable Button Bars 

GFile defines 20 user configurable button bars, any (or none) of which can be displayed at any time. 
Each button bar contains 8 buttons that can have program items assigned to them. The following 
topics describe how to configure and use the configurable button bars:

Assigning Program Item to Button
Button Bar Position and Layout
Changing the Button Bar Titles
Copying Button Assignment to Another Button
Determining the Program Item Assigned to a Button
Displaying/Hiding Button Bars
Launching Applications From Button Bars
Removing Button Assignment



Command Line 

The command line is an editable text field used for performing DOS command line operations, or 
invoking Windows programs. It allows command lines up to 255 characters in length and automatically 
determines whether the command is a DOS command/program, a Windows program, or a file with an 
associated application. Has a command history facility accessed from the keyboard. See Using The 
Command Line. for more information.



Status Line

The status line displays one of three types of information

Information about the currently selected file(s)

Information about one or more program items, and the status of the serialized execution facilities

Nothing

The general rule is that the information displayed describes the currently selected file(s) or program 
item(s). If no file/item is selected, nothing is displayed.

The exception to the rule is when the last action performed was clicking with the right mouse button on 
a button in a button bar. In that case, the information displayed identifies the clicked item.

File Information

When information about a single file is being displayed, the information consists of:
The filename
The size of the file
The date and time the file was last modified
The file's attributes

When information about multiple (selected) files is being displayed, the information consists of:
The number of selected files
The total size of the selected files

Program Item Information

When information about a single program item is being displayed, the first field in the status line is the 
program item name. If information concerning multiple items is being displayed, the first field is the 
number of selected program items.

The other information displayed consists of:
Whether serialization is enabled (On) or disabled (Off)
Whether the serialization queue is Enabled or Paused
The number of serialized jobs waiting in the queue



Main Window and Component Names

Click on the names or picture below to see a description and jump destination for each of the GFile 
components

Menu Bar

Panel - Long Mode

Panel - File Mode

Panel - Info Mode

Panel - Program Group Mode

Command Button Bar

Configurable Button Bar

Command Line

Status Line



Changing the Windows and Buttons Displayed

Select the item on which you want help

Panels

Changing a Panel's Display Mode

Changing the Files and Directories Displayed

Displaying/Hiding Panels

Displaying/Hiding Program Item Names

Resizing Panel Contents

Resizing the Panels

Button Bars

Button Bar Position and Layout

Changing the Button Bar Titles

Displaying/Hiding Button Bars

Others

Displaying/Hiding the Status Line

Resizing the Main Window



Manipulating Directories and Files

Select the item on which you want help

Directory Operations

Copying Directories

Creating Directories

Deleting Directories

Moving Directories

Viewing/Changing File/Directory Attributes

File Operations

Associating Files with Applications

Comparing File Contents

Copying Files

Deleting Files

Finding Files

Moving/Renaming Files

Printing Files

Viewing/Changing File/Directory Attributes



Manipulating Program Groups/Items

Select the item on which you want help

Program Group Operations

Copying Program Groups

Creating Program Groups

Deleting Program Groups

Moving Program Groups

Program Item Operations

Copying Program Items

Creating Program Items

Deleting Program Items

Modifying Program Item Properties

Moving/Renaming Program Items



Configuring and Launching Applications

Select the item on which you want help

Application Launch Options

Configuring Button Bar Buttons

Launching Applications From Button Bars

Launching Applications From File Lists

Launching Applications From Shortcut Keys

Launching Program Items

Using the Command Line



Configuring Button Bar Buttons

Select the item on which you want help

Assigning Program Item to Button

Copying Button Assignment to Another Button

Determining the Program Item Assigned to a Button

Removing Button Assignment



Performing Other Operations

Select the item on which you want help

Exiting GFile

Formatting Floppies

Monitoring File System Changes

Rebooting the System

Refreshing Panels

Restarting Windows

Saving GFile Settings

Setting Shell Program



Application Launch Options

The following are selections on the Options menu that affect or are related to launching applications.

Append Selected File

When selected, causes the filename of all selected files to be appended to the command line (as 
arguments) whenever the command line is run. This is particularly useful for programs/commands 
that can take multiple arguments.

Drop Full Path

If selected, when a file is dropped onto or Inserted into the command line, the entire pathname will be 
dropped/Inserted. If not selected, only the filename is dropped/Inserted.

Prompt for Dir/Arguments

If selected, when an application is launched, a popup dialog will appear prompting for the working 
directory, and any arguments to supply to the program being launched.

Serialize Execution

Turns serialized execution on or off. See Serialized Execution    for detailed information.



Customizing GFile

GFile uses a pif named gfilecmd.pif and the value of the environment variable COMSPEC to launch 
DOS command lines. If you are using a command processor named anything other than 
command.com, you will have to edit (using pifedit) gfilecmd.pif and change the Program Filename 
field from command.com to the appropriate name. You should also verify that COMSPEC is being 
correctly set (usually within autoexec.bat) prior to Windows starting. 

You may wish to change other fields in gfilecmd.pif, even if you are running command.com.    The 
Close Window On Exit and Full Screen/Windowed settings are likely candidates.

GFile creates and uses the file named gfile.ini in the Windows directory to save the program settings 
between invocations of GFile, and, optionally, to specify color, font, buffer size, and shadow thickness 
information.

The program settings information is in a section named [GFILE] and should not be changed with a text 
editor. If this portion of the file becomes corrupted, GFile may fail to run. If GFile fails to start, gfile.ini 
has probably become corrupted. The cure is to delete it. The next time GFile is invoked, the file will be 
re-created.

Color, font, and shadow thickness information is in a section named [USER] and you should feel free to 
change this information with an editor. If this information becomes corrupted, GFile may look ugly (or 
absurd), but it shouldn't crash. If it does, merely delete the [USER] section from gfile.ini. GFile can then 
be restarted, and will have the default values (described shortly) for all of the parameters.

Following are the names, descriptions, possible values, and default values for the parameters in the 
[USER] section. The default value is selected by specifying the word default as the parameter value in 
gfile.ini. For example, ShadowThickness=default.

MaxBuffK

Indicates the largest buffer, in kilobytes (1024 bytes), that will be used for copying files. The default 
value is 1024 (i.e. 1 megabyte). Small changes in this will probably have very little effect on either 
GFile or system performance. If you are in a tight memory situation, you may find it advantageous to 
set this much lower. If you are memory rich, copying multiple files may be much quicker if you 
increase this value.

ShadowThickness

Indicates the pixel width of the shadows drawn to create the 3-D visual effect. Also used for spacing 
within some of the lists and boxes. The default value is 1. The parameter can be set to 1 or 2.

FontFaceName

Indicates the name of the font that is placed in the logical font structure that selects the GFile font. 
This font is used to draw all the text in GFile except for the menus and dialog boxes. The default 
depends on whether a value for IconTitleFaceName is specified in win.ini (determines the font name 
for progman.exe). If so, that value is used. If not, MS Sans Serif is used. Any font name can be 
used. However, the actual font that Windows uses to satisfy a logical font request depends on the 
name requested, the size requested, and the fonts available on the system. If you aren't happy with 
the default, you'll probably have to do a bit of experimentation with this and the FontSize parameter 
to get what you want.

FontSize

Indicates the point size of the desired font. If the font size is set too large, GFile might attempt to 
create its window larger than the screen. If this happens, part of GFile's main window will be chopped 
off.

The remaining parameters refer to colors. The values are specified as a set of three numbers in the 
range 0 to 255, representing the Red, Green, and Blue components of the final color. For example,    
MainColor=128 0 128 results in a medium magenta (red+blue) color. The Colors option of control panel 



can be used to see the effect of different combinations prior to putting the values in gfile.ini.

MainColor

The color to be used to paint the body of GFile. That is, the area that is outside the panels and 
command line areas.    Also used as the background color for the button bars. The default is the 
system Button Face color.

MainText

The color of text drawn on the body of GFile. The default is the system Button Text color.

WorkColor

The color used to paint the background of the command text area and the components of the panels. 
The default is the system Window Background color.

WorkText

The color of text in the command text area and the components of the panels. The default is the 
system Window Text color.

Active

The color painted between the components of the currently active panel. The default is the system 
Active Border color.

Inactive

The color painted between the components of the inactive panel. The default is the system Inactive 
Border color.

WorkHighlight

The color used as the background for selected items in the panels. The default is the system Active 
Title Bar color.

WorkHighlightText

The color used to draw the text for selected items in the panels. The default is the system Active Title 
Bar Text color.

BtnShadow

The color used to draw the shadow portion of the 3-D effects. The default is the system Button 
Shadow color.

BtnHighlight

The color used to draw the highlighted portion of the 3-D effects. The default is the system Button 
Highlight color.



Displaying/Hiding Panels

The panels that are currently displayed or can be displayed are shown in the Window Panels sub-
menu. Each panel is designated by either:

The name of the directory (possibly compressed) selected in the panel (File, Long File, or Info mode)

Or the name of the program group selected (Program Group mode)

Visible panels have their corresponding menu entries selected (checked). Hidden panels are not 
selected (un-checked).

To Display or Hide a Panel:

1 Click on Panels on the Window menu

2 Click on the desired panel on the Panels sub-menu

Note:

GFile will not allow you to display a panel if doing so would cause the horizontal or vertical size of 
GFile to be larger than the corresponding screen dimension



Displaying/Hiding Button Bars

The Command button bar, and the 20 Configurable button bars are listed by title on the Window Button 
Bars sub-menu. If the button bar is visible, the corresponding menu entry is selected (checked). If the 
button bar is hidden, the corresponding menu entry is not selected (un-checked).

To Display or Hide a Button Bar:

1 Click on Button Bars on the Window menu

2 Click on the desired button bar on the Button Bars sub-menu

Note:

GFile will not allow you to display a button bar if doing so would cause the horizontal or vertical size of 
GFile to be larger than the corresponding screen dimension



Button Bar Position and Layout

The location and orientation of the button bars depend on two settings:

The button bar position as specified in the Window Bar Position sub-menu

Whether or not Buttons 2x4 is selected (checked) on the Window menu

The button bar position (Top, Left, Right, Bottom) defines where the button bars are to be placed 
relative to the panels. It also describes the orientation of the button bars - horizontal for Top and 
Bottom, and vertical for Left and Right.

The 2x4 setting determines whether the button bars are to be displayed in 1x8 (not selected/un-
checked) or 2x4 (selected/checked) format.

In 1x8 format for horizontal (Top, Bottom) orientation, each button bar is displayed as 1 row of 8 
buttons. Multiple button bars are stacked in the same top to bottom order as they appear in the Button 
Bars sub-menu. Thus, if 3 button bars were visible, you would see 3 rows of 8 buttons.

In 1x8 format for vertical (Left, Right) orientation, each button bar is displayed as a single column of 8 
buttons. Multiple button bars are placed side by side in the same left to right order as they appear (top to 
bottom) in the Button Bars sub-menu. Thus, if 3 button bars were visible, you would see 3 columns of 8 
buttons.

In 2x4 format for horizontal (Top, Bottom) orientation, each button bar is displayed as 2 rows of 4 
buttons. As before, multiple button bars are stacked in the same top to bottom order as they appear in 
the Button Bars sub-menu. Thus, if 3 button bars were visible, you would see 6 rows of 4 buttons.

Finally, in 2x4 format for vertical (Left, Right) orientation, each button bar is displayed as 2 columns of 4 
buttons. As you might expect, multiple button bars are placed side by side in the same left to right order 
as they appear (top to bottom) in the Button Bars sub-menu. Thus, if 3 button bars were visible, you 
would see 6 columns of 4 buttons.

To Change the Button Bar Position:

1 Click Bar Position on the Window menu

2 Click on the desired button bar position on the Bar Position sub-menu

To Change Between Formats:

1 Click the Buttons 2x4 entry on the Window menu

Note:

GFile will not allow you to change the position or format of the button bars if doing so would cause the 
horizontal or vertical size of GFile to be larger than the corresponding screen dimension



Determining the Program Item Assigned to a Button

To Determine the Program Item Assigned to a Button:

1 Display the status line

2 Display the button bar containing the button in question

3 Click on the button using the right mouse button

4 Read the program item name in the status line



Changing Button Bar Titles

Each button bar has a title that is used to identify it in the Window Button Bars sub-menu. The 
Command button bar's title is Command - and cannot be changed. The 20 Configurable button bars are 
initially titled Custom 0 through Custom 19. However, these titles can be changed to more meaningful 
values by following the procedure described below.

To Change a Button Bar's Title:

1 Click Bar Titles on the Window menu

2 Click on the desired button bar on the Bar Titles sub-menu

3 Enter the desired name in the popup dialog that is displayed

4 Click Ok

Note:

You can supply a keyboard mnemonic for the title by preceding the character to be underlined (and 
thus serve as the mnemonic) with an ampersand (&). For example, if you want the title of a button bar 
to appear as Games, enter it as &Games in the popup dialog. For the mnemonics to work properly, 
make each title's mnemonic unique.



Changing a Panel's Display Mode

To Change a Panel's Display Mode:

1 Make the target panel the active panel

2 Select the desired mode (Program Group, File, Long File, or Info) from the View menu

Or

1 Click using the right mouse button in the desired panel. This will cycle through the modes in 
Program Group to File to Long File to Info to Program Group order. If either Shift key is held 
down while you click the right mouse button, the modes cycle in reverse order.



Displaying/Hiding Program Item Names

The Show Item Names selection on the View menu determines whether or not program item names are 
displayed next to the corresponding icon in the Program Item List. If Show Item Names is selected 
(checked), the names are displayed. If not selected(un-checked), the names are not shown.

To Change Whether a Panel Displays Program Item Names:

1 Make the panel the active panel

2 Click on Show Item Names on the View menu



Changing the Files and Directories Displayed

The files and directories displayed and the ordering of the files is determined by 5 different settings or 
related groups of settings:

The drive that is selected in the drive box

The directory that is selected in the directory list

The template(s) specified in the template field

The current sort order as determined by the Sort Criteria selection in the View menu

The attribute mask for the panel as determined by the Select Attributes and Attributes Exclusive 
selections in the View menu

How to change, and the effect of changing, the value of the drive box, directory list, or template field is 
described in the pop-up help you can view by clicking on their names above. Below are descriptions of 
the other two items.

Sort Criteria

The order in which the filenames appear in the file list is determined by the Primary sort order and, when 
the value of the Primary sort order for multiple files is equal, the Secondary sort order. The values of the 
Primary and Secondary sort orders are viewed/changed by selecting Sort Criteria on the View menu.

To View a Panel's Sort Criteria:

1 Make the panel the active panel

2 Select Sort Criteria from the View menu

3 When you have finished viewing the information displayed, click Cancel

To Change a Panel's Sort Criteria:

1 Make the panel the active panel

2 Select Sort Criteria from the View menu

3 On the Sort Order dialog that is displayed, select the Primary and Secondary sort values. Name 
Root is the filename without the extension. The other choices are obvious

4 If you want the Primary or Secondary (or both) sort to be in inverse (z to a, largest to smallest, or 
latest to earliest) order, select the corresponding Descending Order checkbox

5 Click Ok

Attributes Mask

The Attributes Exclusive, and Select Attributes selections on the View menu work together to 
determine the attribute masks used to select files to be displayed in the file list.

If Attributes Exclusive is not selected (un-checked), all normal files (files with no attributes), and all 
files that have any of the panel's selected attributes will be displayed.

If Attributes Exclusive is selected (checked), only files that have at least one of the panel's selected 
attributes will be displayed.

To Change a Panel's Attributes Exclusive Setting:

1 Make the panel the active panel

2 Click on Attributes Exclusive in the View menu

To View a Panel's Selected Attributes:

1 Make the panel the active panel

2 Click on Select Attributes in the View menu

3 When you have finished viewing the information displayed, click Cancel

To Change a Panels Selected Attributes

1 Make the panel the active panel



2 Click on Select Attributes in the View menu

3 Change the attributes displayed on the popup dialog

4 Click Ok



Displaying/Hiding the Status Line

To Display/Hide the Status Line:

1 Click on Status Line on the Window menu



Copying Files

Individual files can be copied either by selecting the file(s) to be copied or by specifying a filename 
template in the Copy Files popup dialog.

Several of the selections from the Options menu affect copying files. See Copy/Move/Delete Options for 
more information.

GFile also has the ability to copy files to character devices - assuming no other Windows program is 
using the device. To do so, follow the procedure for copying files, but put the name of the device as the 
destination - without a trailing colon. For example, prn or com1 (yes, it will copy to con - but the result is 
pretty worthless). A device cannot be the source (From:).

To Copy Files:

1 Display the destination directory in one panel

2 Select the file(s) to be copied in another panel

3 Select Copy from the File menu

Or Click the Copy command button

Or Drag the selected file(s) and drop it/them on the Copy command button

4 Verify/Change the information displayed on the popup dialog

5 Click Ok

Or

1 Display the destination directory in one panel

2 Select the file(s) to be copied in another panel

3 Drag the selected file(s) and drop it/them on the destination panel's drive box or a target directory 
in the destination panel's directory list

4 Verify the information displayed on the popup dialog is correct

5 Click Ok

To Copy Files Using a Filename Template:

1 Display the destination directory in one panel

2. Display the source directory in another panel

3 Select Copy from the File menu

Or Click the Copy command button

4 Add the filename template to be used to the end of the Source (Copy:) field of the Copy popup 
dialog (e.g. C:\DOS\*.com)

5 Click Ok



Copying Program Items

The Show Progress selection from the Options menu affects copying program items. See 
Copy/Move/Delete Options for more information.

To Copy Program Items:

1 Display the destination group in one panel

2 Display and select the item(s) to be copied in another panel

3 Select Copy from the File menu

Or Click the Copy command button

Or Drag the selected item(s) and drop it/them on the Copy button

4 Verify/Change the information displayed on the popup dialog. Note that program items are 
referenced as Group Name::Program Item Name. For example, the item named Clipboard 
Viewer in the group Accessories would be referenced as Accessories::Clipboard Viewer

5 Click Ok

Or

1 Display the destination group in one panel

2 Select the item(s) to be copied in another panel

3 Drag the selected item(s) and drop it/them on the other group box

4 Verify the information displayed on the popup dialog is correct

5 Click Ok



Copying Program Groups

Copying a program group is done by GFile in two steps:

The destination group is created if it doesn't already exist.

The program items from the source group are copied to the destination group.

The Show Progress selection from the Options menu affects copying program groups. See 
Copy/Move/Delete Options for more information.

To Copy a Program Group:

1 Display the group to be copied in any panel

2 Select Copy from the File menu

Or Click the Copy command button

Or Drag the source group and drop it on the Copy command button

3 Type the name of the destination group in the To: field of the popup dialog. Note that group 
names must be followed by two contiguous colons (::). For example, a group named Strategy 
Games would be typed as    Strategy Games::

4 Click Ok

Or (if the destination group already exists):

1 Display the destination group in any panel

2 In another panel, display the source group

3 Drag the source group box and drop it on the destination group box

4 Verify the information displayed on the popup dialog is correct

5 Click Ok



Copying Directories

GFile copys directories in two steps:

The destination directory is created if it doesn't already exist

The contents of the source directory are copied to the destination directory

Several of the selections from the Options menu affect copying directories. See Copy/Move/Delete 
Options for more information.

Only files selected by the Select Attributes and Attributes Exclusive settings for the active panel will be 
copied.

To Copy a Directory:

1 Select the directory that contains, or will contain, the destination directory in a panel

2 Select the directory to be copied in another panel

3 Select Copy from the File menu

Or Click the Copy command button

Or Drag the source directory and drop it on the Copy command button

4 Verify/Change the information displayed on the popup dialog

5 Click Ok

Or:

1 Select the directory that contains, or will contain, the destination directory in one panel

2 In another panel, select the directory to be copied

3 Drag the directory to be copied and drop it in the other panels drive box

4 Verify the information displayed on the popup dialog is correct

5 Click Ok



Moving/Renaming Files

Files can be moved or renamed either by selecting the file(s), or by specifying a filename template in the 
Move/Rename Files dialog.

If a file to be move/renamed can have its path and/or filename changed by merely renaming (destination 
on same drive), it is renamed. Otherwise, it is copied, and the original deleted.

Several of the selections from the Options menu affect moving/renaming files. See Copy/Move/Delete 
Options for more information.

If you do not want to change the path, but merely the name of a single file, proceed as described below, 
but when the popup dialog appears, change the destination (To:) to contain only the new name - no 
path.

To Move/Rename Files:

1 Display the destination directory in one panel

2 Select the file(s) to be moved/renamed in another panel

3 Select Move/Rename from the File menu

Or Click the Move command button

Or Drag the selected file(s) and drop it/them on the Move command button

4 Verify/Change the information displayed on the popup dialog

5 Click Ok

To Move/Rename Files Using a Filename Template:

1 Display the destination directory in one panel

2 Display the source directory in another panel

3 Select Move/Rename from the File menu

Or Click the Move command button

4 Add the filename template to be used to the end of the Source (Move/Rename:) field in the 
popup dialog (e.g. C:\DOS\*.com)

5 Click Ok



Moving Directories

GFile performs three steps when moving a directory :

The destination directory is created if it doesn't already exist

The contents of the source directory are moved to the destination

The source directory is deleted if it is empty

Only files selected by the Select Attributes and Attributes Exclusive settings for the active panel will 
be moved.

Moving a directory uses several of the selections from the Options menu. See Copy/Move/Delete 
Options for more information.

To Move a Directory:

1 Select the directory that contains, or will contain, the destination directory in a panel

2 Select the directory to be moved in another panel

3 Select Move/Rename from the File menu

Or Click the Move command button

Or Drag the source directory and drop it on the Move command button

3 Verify/Change the information displayed on the popup dialog

4 Click Ok



Moving Program Groups

GFile performs three steps when moving a program group:

The destination group is created if it doesn't already exist

The program items in the source group are moved to the destination

The source group is deleted

To Move a Program Group:

1 Select the group to be moved in a panel

2 Select Move/Rename from the File menu

Or Click the Move command button

Or Drag the source group and drop it on the Move command button

3 Enter the destination group name in the destination (To:) entry of the popup dialog. Be sure it is of 
the form: New Group Name::

4 Click Ok



Moving/Renaming Program Items

To change the name of a single program item, you can rename the program item as described below, or 
change the Description property of the program item as described in Modifying Program Item Properties.

The Show Progress selection from the Options menu affects moving/renaming program items. See 
Copy/Move/Delete Options for more information.

To Move Program Item(s) to a Different Group:

1 Display the destination group in one panel

2 Select the item or items to be moved in another panel

3 Select Move/Rename from the File menu

Or Click the Move command button

Or Drag the selected item(s) and drop it(them) on the Move command button

4 Verify/Change the information displayed on the popup dialog

5 Click Ok

To Rename a Program Item (Same Group):

1 Select the item to be renamed in any panel

2 Select Move/Rename from the File menu

Or Click the Move command button

Or Drag the selected item and drop it on the Move command button

3 Enter the appropriate information in the popup dialog. Be sure the destination is of the form: 
Groupname::NewName

4 Click Ok



Deleting Files

Files can be deleted either by selecting them or by using a filename template. 

Several of the selections from the Options menu affect deleting files. See Copy/Move/Delete Options for 
more information.

To Delete Individual Files:

1 Select the file(s) to be deleted

2 Select Delete from the File menu

Or Click the Delete command button

Or Drag the selected files and drop them on the Delete command button

3 Verify the information displayed in the popup dialog

4 Click Ok

To Delete Files Using a Filename Template

1 Display the directory containing the files to be deleted

2 Select Delete from the File menu

Or Click the Delete command button

3 Add the filename template to be used to the end of the target (Delete:) field in the popup dialog 
(e.g. C:\DOS\*.com)

5 Click Ok



Deleting Program Items

Several of the selections from the Options menu affect deleting program items. See Copy/Move/Delete 
Options for more information.

To Delete Program Items:

1 Select the item(s) to be deleted

2 Select Delete from the File menu

Or Click the Delete command button

Or Drag the selected items and drop them on the Delete command button

3 Verify the information displayed in the popup dialog

4 Click Ok



Deleting Directories

Several of the selections from the Options menu affect deleting directories. See Copy/Move/Delete 
Options for more information.

To Delete a Directory:

1 Display the directory to be deleted

2 Select Delete from the File menu

Or Click the Delete command button

Or Drag the directory to be deleted and drop it on the Delete command button

3 Verify/Change the information displayed on the popup dialog

4 Click Ok



Deleting Program Groups

Several of the selections from the Options menu affect deleting program groups. See Copy/Move/Delete 
Options for more information.

To Remove a Program Group:

1 Display the group to be removed

2 Select Delete from the File menu

Or Click the Delete command button

Or Drag the group to be deleted and drop it on the Delete command button

3 Verify/Change the information displayed on the popup dialog

4 Click Ok



Printing Files

GFile uses the same file association mechanism for printing that File Manager uses. Within the 
registration database are kept associations between file extensions, and programs (with options) that 
are able to print files with those extensions.    These associations exist only for Document Classes. For 
details on the mechanisms involved, refer to Associating Files with Applications.

When multiple files are selected for printing, GFile places the print requests in a queue. It waits for 
completion of the associated print program for the first file (but not completion of printing) before starting 
the second print request. This prevents GFile from trying, for example, to start 26 instances of the 
Paintbrush program at the same time (a 50MHz '486 with 64MB of memory might handle it ok - those of 
us with more modest iron wouldn't like the result !).

To Print Files:

1 Select the file(s) to be printed

2 Select Print from the File menu

Or Click the Print command button

Or Drag the selected files and drop them on the Print command button



Finding Files

GFile will search part or all of a drive for a file that matches a name or filename template you supply. If 
the search is successful, the matching file becomes the selected file. A search can be continued from 
where it found a match, looking for additional matches, without having to re-enter any information.

To Search For a File:

1 Display the drive and, optionally the directory, where the search is to begin

2 Select File Search from the Edit menu

Or Click on the Search command button

3 In the popup dialog, specify the drive/directory where the search is to begin, and the filename 
template or name to be matched in the appropriate fields

4 Click Ok

If the search is successful, the active panel    will have its drive box, directory list, and file list changed (if 
necessary) to display and select the file that matched the name or filename template supplied. If the 
search fails, a dialog box informing you of the failure is displayed.

To Search For Additional Occurrences or Matches:

1 Select Continue Search from the Edit menu

If an additional occurrence of the filename is found, or another file is found that matches the filename 
template, the new match becomes the selected file. Otherwise a dialog box informs you of the search 
failure.



Comparing File Contents

GFile will compare the contents of two files, and will tell you if the file contents are identical.

To Compare Two Files:

1 Display and select one of the files to be compared

2 Select Compare Selected from the Edit menu

3 In the popup dialog, specify the path and name of the file to which the selected file is to be 
compared

4 Click Ok

After the comparison is complete, a popup dialog will tell you if the files are, or aren't, identical.



Viewing/Changing File/Directory Attributes

File properties, or attributes in DOS, can be viewed or changed by GFile.

If a single file is selected, the properties/attributes of the file are displayed in the status line component 
of GFile. The following letters are used to represent the individual properties:

A Archive

H Hidden

R Read-Only

S System

Attributes for a file or directory can also be determined by selecting the file/directory, and following the 
directions below for changing the attributes, but clicking Cancel rather than Ok on the pop-up dialog.

To Change File/Directory Properties/Attributes:

1 Select the file(s) or directory (with no files selected) whose attributes are to be changed

2 Select Properties from the File menu

3 Select/de-select the attributes desired (or None) on the popup dialog box

4 Click Ok



Associating Files with Applications

An association defines the program that is invoked (or in certain cases the DDE message to send) when 
files with a particular filename extension are Run/Opened or Printed.

One way the association for an extension can be defined is as a command line consisting of a program 
(path)name and any switches necessary to Run/Open files that have the desired extension. This is the 
most commonly used technique for DOS programs, and Windows programs that do not define 
Document Classes .

The other way in which the association can be defined is by indicating that the extension is associated 
with a Document Class. The Document Classes are normally defined as part of installing the 
applications that are used to Open and Print particular types of documents. Some common examples of 
Document Classes are:

Paintbrush Picture

Files that can be edited with pbrush.exe - .bmp and .pcx files

Write Document

Files that can be edited with write.exe - .wri files

Text File

Files that can be edited with notepad.exe - .txt files

For further details on file extension associations, refer to the printed documentation for File Manager.

Defining an association between a filename extension and either an executable file, or an existing 
Document Class is simple - as described below.

To Define an Association:

1 Select a file with the desired extension

2 Select Associate from the File menu

3 Enter the program name (Open association) and switches in the edit field of the popup dialog

Or If the desired program has been previously associated with a different extension, select the 
program from the popup dialog list

Or Select the appropriate pre-defined Document Class from the popup dialog list

4 Click Ok

Example 1 - Using Document Classes

Suppose you want to be able to Run/Open files named read.me using Notepad:

Select a file with .me as the extension

Select Associate from the File menu

Scroll down and select Text File from the list displayed in the popup dialog

Click Ok

That all there is to it! Now, any time you Open or Run a file with .me as its extension, Notepad will be 
invoked with the target file as an argument. Further, since the Text File class has a Print association 
(notepad.exe /p), you can print .me files from GFile (or File Manager).

Example 2 - Using an Executable File

Suppose you have a program (DOS or Windows) with the path C:\utility\xyzzy.exe that processes files 
with the .zyx extension. To define the association between the program and the extension:

1 Select a file with the .zyx extension

2 Select Associate from the File menu

3 Type C:\utility\xyzzy.exe in the text field of the popup dialog

4 Click Ok



Now, whenever you Open or Run a file with the .zyx extension, xyzzy.exe will be invoked - with the file 
you are running passed as an argument.

As a final note, defining a Document Class is not normally considered a "user operation". However, if 
you wish to investigate document classes further, refer to printed and Help documentation for the 
program regedit.exe. Another good reference is The Microsoft Windows 3.1 Programmer's Reference, 
Volume 1, Chapter 7.

BACKUP YOUR REGISTRATION DATABASE (REG.DAT) BEFORE MESSING AROUND WITH 
REGEDIT.EXE!



Creating Directories

To Create a Directory:

1 Display the directory that is to be the parent of the new directory

2 Select Create from the File menu

Or Click the Create command button

3 Add the new directory name to the end of the path displayed in the popup dialog

4 Click Ok



Creating Program Groups

To Create a Program Group:

1 Select Create from the File menu

Or Click the Create command button

2 Type the name of the new group, followed by two contiguous colons (::) in the popup dialog (e.g. 
My New Group::)

3 Click Ok



Creating Program Items

Creating a new program item consists of supplying values for the properties that control an item's 
display and execution.

Supplying values for the properties is optional except for the Command Line property. If not specified, 
defaults will be chosen for the other properties.

There are two, very different ways to create new program items:

To Create a New Program Item Explicitly:

1 In one panel display the group that will contain the new program item, and make it the active 
panel.

2 Select New from the File menu

3 Enter values for the desired fields in the Program Item Properties dialog box. If you specify the 
Icon Filename, click the View button to see the icons contained in the new file. Select the desired 
icon from the scrolled list at the bottom

4 Click Ok

To Create a New Program Item or Items Using Drag/Drop:

1 In one panel display the group that will contain the new program item or items

2 In another panel, display and select the file(s) for which program items are to be created

3 Drag the file(s) and drop it/them on the destination group box



Modifying Program Item Properties

The properties of a program item are the values that were chosen when the item was created (see 
Creating New Program Items) which control a program item's display and execution.

To Change a Program Item's Properties:

1 Select the item whose properties are to be changed

2 Select Properties from the File menu

3 Change the desired fields in the Program Item Properties dialog box. If you change the Icon 
Filename, click the View button to see the icons contained in the new icon file. Select the desired 
icon from the scrolled list at the bottom.

4 Click Ok



Launching Applications From Shortcut Keys

Launching via shortcut keys does not make use of any of the launch related selections on the Options 
menu.

If an item has been previously launched (by GFile), typing the shortcut key sequence does not launch 
another instance - rather, it restores (if minimized) the existing instance and raises it above other 
applications.

To define a shortcut key sequence for an item, see Modifying Program Item Properties.

To Launch an Application Using Shortcut Keys:

1. Type the shortcut key sequence. GFile does NOT have to be the active application



Using the Command Line

From the command line, you are able to launch arbitrarily complex commands containing:

DOS programs with switches and arguments

Windows programs with switches and arguments

Document files associated with a program or Document Group (see Associating Files with 
Applications)

DOS built-in commands with switches and arguments

Program items

The command line uses all application launch options. See Application Launch Options.

The command line contains a built in history facility, able to hold 9 previous commands.

To specify a program item rather than a filename, use the form:    Group Name::Program Item Name

Command lines that contain the command.com pipe or redirection characters (|, >, <) are automatically 
assumed to be DOS command lines. Arguments to the command line that are a result of the Prompt for 
Dir/Arguments and/or Append Selected Files options will be placed on the final command line before 
the first occurrence of a pipe or redirection character - unless that character is the first character in the 
command line.

If you wish to launch a DOS command line, and not have GFile search the disk attempting to resolve the 
command before deciding that it is a DOS command line, begin the command line with >. 

If you create a command line containing only the character >,    your command processor will be 
launched in interactive mode. The Prompt for Dir/Arguments and Append Selected Files options will 
be ignored. However, serialized execution will still be honored.

DOS command lines use a pif named gfilecmd.pif and the value of the COMSPEC environment 
variable. See Customizing GFile if you wish or need to change the default values for these.

To Use the History Mechanism:

1 Press the Up arrow key on the keyboard to move backward through the command history

2 Press the Down arrow key to move forward through the command history

To Launch a Command Line:

1 Enter the desired command using the keyboard and/or dragging and dropping filenames, 
directory names, or program items

2 Press the Enter key on the keyboard

Or Double-click on the command line



Launching Applications from Button Bars

Launching applications from button bars is affected by the setting of Prompt For Dir/Arguments and 
Serialized Execution from the Options menu. See Application Launch Options. for more information.

To Launch an Application From a Button Bar:

1 Display the button bar containing the desired application

2 Click the desired application button

Or Drag the application button and drop it on the Run command button

To Launch a Button Application Passing Selected Files as Arguments:

1 Display the button bar containing the desired application

2 Display and select the file(s) to be used as arguments

3 Drag the selected file(s) and drop it/them on the application button



Launching Applications From File Lists

GFile will launch two types of files:

Program files - files with    .exe, .com, .bat or .pif extensions (Windows or DOS)

Data files whose extensions are associated with program files or a Document Class - see Associating 
Files with Applications.

GFile will allow you to launch multiple files with a single operation. However, this should be used 
carefully. It is very easy to bring your system to its knees by launching too many applications 
concurrently.

Launching files is affected by the setting of Prompt For Dir/Arguments and Serialized Execution from 
the Options menu. See Application Launch Options. for more information.

Launched files do not make use of the Append Selected File option (rather nasty recursion if they did!). 
Rather, to launch a file using other file(s) as arguments, the argument file(s) are dragged and dropped 
onto the file to be launched as described below.

To Launch a File or Files

1 Display the directory containing the file(s) to be launched

2 Select the file(s) to be launched

3 Select Run or Open from the File menu

Or Click the Run command button

Or Drag and drop the selected files onto the Run command button

Or Press the Enter key on the keyboard

Or (Single File Only)

1 Display the directory containing the file to be launched

2 Double-click the file to be launched

To Launch a File Passing Selected Files as Arguments:

1 In any panel, display the directory containing the program file to be launched

2 In another panel, select the file(s) to be used as arguments

3 Drag the selected file(s) and drop it/them onto the file to be launched



Launching Program Items

Launching program items is affected by the setting of Prompt For Dir/Arguments and Serialized 
Execution from the Options menu. See Application Launch Options. for more information.

To Launch a Program Item or Items

1 Select the program group containing the program items to be launched

2 Select the program items to be launched

3 Select Run or Open from the File menu

Or Click on the Run command button

Or Press the Enter key on the keyboard

Or (Single Item Only)

1 Select the program group containing the program item to be launched

2 Double click on the program item icon or name

To Launch a Program Item Passing Selected Files as Arguments:

1. Display the group and program item to be launched

2. In another panel, select the file(s) to be used as arguments

3. Drag the files and drop them on the program item icon or name



Assigning Program Item to Button

To Assign a Program Item to a Button:

1 Display the Configurable button bar containing the desired button

2 In any panel, display and select the desired program item

3 Drag the program item and drop it on the button



Removing Button Assignment

To Remove the Assignment From a Button:

1 Display the Configurable button bar containing the desired button

2 Display the Command button bar

3 Drag the desired button and drop it onto the Delete command button



Copying Button Assignment to Another Button

To Copy a Button Assignment to Another Button:

1 Display the Configurable button bar containing the target button

2 Display the Configurable button bar containing the source (to be copied) button

3 Drag the source button and drop it onto the target button



Resizing the Main Window

Resizing the main window will mainly affect the sizes of panels. Button bars, the command line, and the 
status line will be resized only as necessary to maintain proper alignment. If you are displaying multiple 
panels, once the main window is resized, you may wish to resize the individual panels. See Resizing the 
Panels for more information.

To Resize the Main Window:

1 Move the mouse to the outer border of GFile's window, and press the left mouse button

2 If the cursor changes to a double-headed arrow, move the mouse until the outline displayed 
corresponds to the desired size for GFile's main window. If the cursor does not change, release 
the mouse button and try step 1 again

3 Release the mouse button



Resizing the Panels

Each panel can be resized horizontally to any size within the constraints of minimum panel size and 
GFile main window size.

In order to maintain alignment between the panels, vertical resizing applies to all panels on a row.

To Resize a Panel:

1 Place the mouse in either the vertical or horizontal area between two panels and press the left 
mouse button

2 If the cursor changes to a double-headed arrow, move the mouse in either direction indicated by 
the cursor until the guide line displayed corresponds to the desired panel size. If the cursor does 
not change, release the mouse and try step 1 again

3 Release the mouse button. The panels above and below or to the left and right of the guide line 
will be resized



Resizing Panel Contents

When a panel is in File or Long File mode, you can change the horizontal dimensions of the 
Drive/Directory and Template/File components. However, the space in which you must position the tip of 
the mouse cursor is quite small (twice the shadow thickness), therefore you may have to attempt step 1 
below several times before succeeding.

To Resize a Panel's Contents:

1 Place the mouse in the vertical space between the directory list and file list, and press the left 
mouse button

2 If the cursor changed to a double-headed arrow, move the mouse left or right until the guide line 
displayed corresponds to the desired dimensions. If the cursor did not change, release the mouse 
and try step 1 again

3 Release the mouse button. All four components of the panel will be resized



Refreshing Panels

Choosing Refresh on the View menu or clicking the Refresh command button causes all internal lists to 
be updated, and all visible panels to be updated and repainted. It also de-selects any selected 
files/program items

To Refresh All Panels:

1 Select Refresh on the View menu

Or Click on the Refresh command button



Monitoring File System Changes

Windows provides a mechanism to allow one program to be notified whenever a Windows program 
causes a change to the file system. GFile does not use this mechanism to detect when it changes the 
file system, but GFile can use it to update its file lists when another Windows program makes a change. 
To enable this facility, select the Monitor File System Changes option on the System menu.

File Manager uses this mechanism to detect its own changes as well as other Windows program 
changes. As only one program can use this facility, prior to invoking File Manager turn this option off. 
You may also want to turn this option off prior to printing several files. Print Manager creates temporary 
files and having this option on causes unnecessary (but harmless) updating of the file lists.

To Change the Setting of Monitor File System Changes:

1 Click Monitor File System Changes on the System menu



Formatting Floppies

To Format a Floppy

1 Select Format From the System Menu .

2 Enter the appropriate information in the pop-up dialog that is displayed
Drive Select one of the floppy drives listed in the combo-box
Label Standard volume label. Specify only if your version of format.com 

supports /v:label option - Do NOT include quotation marks
Density Default for drive, or 360K/1.2M/720K/1.44M/2.88M    (/f:format)
System files Select one of three buttons: None (don't reserve space), Reserve 

Space(/b), or Copy System Files(/s)
Quick Format Select only if your version of format.com supports /q
Unconditional Select only if your version of format.com supports /u

3 Click Ok. Format.com will then run as a DOS application, using the arguments and options 
specified.



Restarting Windows

To Restart Windows:

1 Select Restart Windows from the System Menu

2 Select Yes from the pop-up confirmation dialog

Selecting this option will terminate all active programs. Use it the same way you would use Exit 
Windows on your shell application.



Rebooting the System

To Reboot the System:

1 Select Reboot System from the System Menu

2 Select Yes from the pop-up confirmation dialog

Although all Windows programs will have an opportunity to clean up, you should avoid using this option 
while programs that have open files are still active. Also, be very careful about using this with 
smartdrive if write caching is enabled. This command is implemented via a Windows API call that will 
signal smartdrive to flush its write cache buffers. However, I would test extensively with non-critical data 
before using this "for real". Disk drives, systems, disk related TSRs, and operating system versions vary 
so widely that all possible combinations cannot be checked (reasonably - within the current century). 



Exiting GFile

To Exit GFile:

1 Select Exit or Exit Windows (if GFile is running as the Windows shell program) from the File 
menu

2 Click Yes on the confirmation popup dialog



Saving GFile Settings

To Save GFile Settings:

1 While holding down either Shift key, double-click the Control Menu icon
Or

1 Select the Save Settings On Exit option on the Options menu

2 When you next exit GFile, the settings in effect at the time you exit will be saved



Setting Shell Program

Selecting Set Shell on the System menu allows you to set the Shell= parameter in win.ini. A Popup 
dialog will appear that prompts for the name of the program to be set as the shell. If GFile is currently 
the shell program, the default value in the dialog is progman.exe. If GFile is not the current shell, 
gfile.exe is the default value displayed. After clicking Ok, another dialog pops up asking whether you 
want to restart Windows with the new shell.

To Set the Shell Program:

1 Select Set Shell on the System menu

2 Enter the name/path of the desired shell program in the popup dialog that appears. If the program 
is not in a directory that is on the system PATH when Windows starts, you must specify a 
complete path name to the program

3 Click Ok

4 Click Yes on the Restart Windows dialog that appears



Copy/Move/Delete Options

Following are options that can be selected for copy, move, or delete operations as appropriate. These 
options are set in the Options Menu or may be selected on the popup dialog box that is displayed when 
the Options button on the Copy/Move/Delete dialog is selected.

Confirm Delete

When selected, causes a confirmation (Yes/No/Cancel) popup dialog to be displayed before any file 
or program item is deleted.

Confirm Overwrite

When selected, causes a confirmation (Yes/No/Cancel) popup dialog to be displayed before any 
existing file is overwritten by a copy or move/rename operation.

Copy Date/Time

When selected, causes the date and time of the source file to be given to the newly created 
destination file by a copy operation. Otherwise, the new copy has the current date and time.

Copy Attributes

When selected, causes the attributes of the source file to be given to the newly created destination 
file by a copy operation. Otherwise, the new copy has no attributes set (Normal File).

Show Progress

When selected, copying, moving, deleting, and searching operations cause a popup dialog to be 
displayed, showing the current item being manipulated. The operations usually take a little less time 
when this option is not selected.

Verify Copy

When selected, causes the newly created copy of a file (whether copying or moving to a different 
drive) to be compared with the original file. If the comparison fails, the copy fails, and the original file 
is restored (in the case of a move).

Safe Copy

When selected, and a file is being copied (or moved to a different drive), if the destination file already 
exists, GFile will:

Rename the destination file to a temporary name
Copying the source file to the destination
Deleting the temporary file (old destination file)

Thus, if an error occurs during the copy, GFile displays an error message, deletes (if necessary) the 
bad copy, and rename the temporary file back to its original name. Thus, although the copy failed, no 
information is destroyed.

Include Subdirectories

When selected, will result in all sub-directories and their contents being included in a 
copy/move/delete directory operation. Selecting this option effectively changes the directory 
operations to directory tree operations - clone/graft/prune if you prefer.



File Menu Commands 

New

Creates a new program item. See Creating Program Items.

Open

Runs the currently selected file(s) or program item(s). If no files/items are selected, but a directory list 
or drive box has the keyboard focus, causes the currently highlighted drive/directory to be selected. 
Exists primarily for compatibility with File Manager.

Move/Rename

Moves or renames the selected files, program items, directory or program group. See 
Moving/Renaming Files, Moving Directories, Moving Program Groups, or Moving/Renaming Program 
Items for more information.

Copy

Copies the selected files, program items, directory, or program group. See Copying Files, Copying 
Program Items, Copying Directories, or Copying Program Groups for more information.

Delete

Deletes the selected files, program items, directory, or program groups. See Deleting Files, Deleting 
Program Items, Deleting Directories, or Deleting Program Groups for more information.

Create

Creates a directory or program group. See Creating Directories or Creating Program Groups for more 
information.

Properties

Displays or changes selected file or program item properties. See Viewing/Changing File/Directory 
Attributes or Modifying    Program Item Properties for more information.

Run

Runs the selected file(s) or program item(s). See Launching Applications From File Lists or Launching 
Program Items for more information.

Print

Prints the selected file(s). See Printing Files for more information.

Associate

Associates all files with the same extension as the selected file with a program or Document Group. 
See Associating Files with Applications for more information.

Exit/Exit Windows

Terminates GFile. See Exiting GFile for more information.



Edit Menu Commands 

File Search

Searches for a file whose name matches a specified filename or filename template. See Finding Files 
for additional information.

Continue Search

Searches for the next filename that matches a previously specified name or template. See    Finding 
Files for additional information.

Compare Selected

Performs a binary comparison between two files. See Comparing File Contents for additional 
information.

Select All

Selects all files or program items displayed in the active panel.

Clear All

De-selects all files in the active panel.



View Menu Commands 

Next

Changes the active panel to the next visible panel in left to right, top to bottom order. If the active 
panel is currently the rightmost bottom visible panel, will switch to the leftmost top visible panel.

Program Group
File
Long File
Info

Determines the information to be displayed in the active panel. See Panels or Changing a Panel's 
Display Mode for additional information 

Sort Criteria

Selects the file information - name, extension, date, size - by which the file list entries are sorted. See 
Changing the Files and Directories Displayed for more information.

Select Attributes
Attributes Exclusive

Determine the attribute mask used to select files to be displayed in the active panel's file list. See 
Changing the Files and Directories Displayed for more information.

Show Item Names

Turns on (checked) or off (un-checked) the display of program item names in the program item list for 
the active panel. See Displaying/Hiding Program Item Names for more information.

Refresh

Updates/repaints all visible panels. See Refreshing Panels for more information.



System Menu Commands 

Format

Formats a floppy using format.com. See Formatting Floppies for more information.

Monitor File System Changes

Turns on/off GFile's monitoring of file system changes. See Monitoring File System Changes for more 
information.

Pause Queue

When checked,    prevents GFile from starting serialized jobs. See Serialized Execution .

Clear Queue

Removes all serialized jobs from the queue.    See Serialized Execution .

Set Shell

Allows you to change the Windows shell program and restart Windows. See Setting Shell Program for 
more information.

Reboot System

Reboots the system. See Rebooting the System for more information.

Restart Windows

Restarts Windows. See Restarting Windows for more information.



Options Menu Commands 

Append Selected File
Drop Full Path
Prompt for Dir/Arguments
Serialize Execution

Options related to launching applications. See Application Launch Options for more information.

Confirm Delete
Confirm Overwrite
Copy Date/Time
Copy Attributes
Show Progress
Verify Copy
Safe Copy
Include Subdirectories

Options related to copying/moving/deleting items. See Copy/Move/Delete Options for more 
information.

Minimize on Use

When selected, causes GFile to minimize (iconize) itself whenever an application is launched.

Save Settings on Exit

Determines whether GFile should save its configuration when terminated. See Saving GFile Settings 
for more information.



Window Menu Commands 

Panels

Displays a sub-menu that allows you to select a panel to display or hide. See Displaying/Hiding 
Panels for more infomation.

Button Bars

Displays a sub-menu that allows you to select a button bar to display or hide. See Displaying/Hiding 
Button Bars for more infomation.

Bar Position

Displays a sub-menu that allows you to specify the position of the button bars relative to the panels. 
See Button Bar Position and Layout for more infomation.

Bar Titles

Displays a sub-menu that allows you to specify the titles associated with the configurable button bars. 
See How to Change Button Bar Titles for more infomation.

Buttons 2x4

Allows you to select a 1x8 (un-checked) or 2x4 (checked) layout for the button bars. See    Button Bar 
Position and Layout for more infomation.

Status Line

Determines if the status line is displayed. See Displaying/Hiding the Status Line for more infomation.



Help Menu Commands 

Contents

Invokes the Windows Help program, displaying the table of contents for this help file.

Search for Help on

Invokes the Windows Help program, displaying the topic search dialog for this help file.

How to use Help

Invokes the Windows Help program, displaying a help file that explains how to use the Windows help 
facility.

About GFile

Displays author, revision, and copyright information for GFile.

Registration

Displays information concerning how to register GFile.



File Menu

Commands that    directly manipulate files, directories, groups and program items. See File Menu 
Commands. Click on picture above to see/return to Menu Bar.



Edit Menu

Commands that select files, and compare file contents. See Edit Menu Commands. Click on picture 
above to see/return to Menu Bar.



View Menu

Commands that affect the information displayed in the panels. See View Menu Commands. Click on 
picture above to see/return to Menu Bar.



System Menu

Commands that deal with operating system level facilities. See System Menu Commands. Click on 
picture above to see/return to Menu Bar.



Options Menu

Parameters that affect application launching, copying/moving/deleting objects, and GFile operation. See 
Options Menu Commands. Click on picture above to see/return to Menu Bar.



Window Menu

Commands that determine the number and arrangement of displayed panels, button bars, and other 
visual elements. See Window Menu Commands. Click on the entries with arrow heads to see the 
associated sub-menu. Click elsewhere on picture above to see/return to Menu Bar.



Help Menu

Informational commands. See Help Menu Commands. Click on picture above to see/return to Menu Bar.



Panels Sub-menu

Commands that hide/show panels. See Displaying/Hiding Panels. Click on picture above to see/return to 
Window Menu.



Button Bars Sub-menu

Commands that hide/show button bars. See Displaying/Hiding Button Bars. Click on picture above to 
see/return to Window Menu.



Bar Titles Sub-menu

Commands that allow changing the button bar titles. See Changing the Button Bar Titles. Click on 
picture above to see/return to Window Menu.



Bar Position Sub-menu

Commands that control button bar positioning. See Button Bar Position and Layout. Click on picture 
above to see/return to Window Menu.



Keyboard and Mouse Operations

GFile conforms to the usual Windows conventions for keyboard and mouse use. However, due to its 
nature, there are some special keyboard and mouse operations as detailed below.

Shifting Focus

The currently active or focused element in GFile is changed by use of the Tab and Shift-Tab keys, or 
by clicking with the left mouse button in the component. The arrow keys are used within many 
components to change the current selection or perform other operations, and are thus not used to 
shift focus. Popup dialog boxes follow the usual conventions of Tab/Shift -Tab moving between 
related groups of items and arrow keys moving the focus between items in a group.

History

The command line history feature remembers    9 previous command lines. Previously entered 
commands are stepped through using the Up arrow key (assuming the command line is the active 
component). The Down arrow key can be used to move forward through previously stepped over 
commands.

Double Click

Double clicking has special significance in the file list components, the program item list components, 
and in the command line component. In any of those three components, double-clicking has the same 
effect as pressing the Enter key    or clicking the Run command button - the selected file(s), item(s), 
or command line is launched.

Double clicking is also used to change the selected directory in the directory list components    -    the 
usual behavior for Windows applications.

Shift-Double Click

Double clicking in the file list components (File or    Long File mode) while holding down either Shift 
key, has the same effect as clicking the Print command button - the selected file(s) is/are printed 
using whatever print association (See Associating Files with Applications ) is in effect for that type of 
file.

Enter Key

In most cases, pressing the Enter (Return) key has the same effect as selecting Run from the File 
menu or clicking on the Run command button - the currently selected file/item is launched.

If the drive or group    boxes, or directory list is the currently active item, and the Up/Down arrow keys 
have been used to change the highlighted item, the Enter key (or Space bar) causes the highlighted 
item to become the current selection. 

If a template field is the active component, and the contents of the template field are changed,    
pressing Enter confirms the change. Tabbing or clicking in a different component without pressing 
Enter will cause the template field to revert to its previous value.

Insert Key

When the command line has the focus, pressing the Insert key will paste the path/filenames of the 
selected files or program items at the end of the command line. This is equivalent to dragging the 
files/items from the active panel and dropping them on the command line. Whether a simple filename 
or full pathname is pasted depends on the setting of Drop Full Path on the Options menu. See 
Application Launch Options. for more information.

Info Box

When the info box is displayed in either of the panels, clicking in the info box with the left button 
causes an update of the information being displayed. This does NOT cause the panel containing the 
info box to become the active panel - the assumption is that since the info box is displaying 
information only, there would be few cases where making it the active panel would be advantageous, 
but many cases where doing so would be a disadvantage.



Right Click

Clicking in any component of either panel with the right mouse button causes the panel to cycle to the 
next display mode. Thus, if a panel was currently displaying Program Group information,    four clicks 
would cycle from    Program Group to File to Long File to Info and back to Program Group. Holding 
either Shift key down while clicking with the right mouse button cycles through the modes in reverse 
order.

Control Menu

Double-clicking on the control-menu box while holding down either Shift key saves the current 
settings (size, position, directories, groups, mode, options) of GFile in gfile.ini. This occurs whether 
Save Settings on Exit on the Options menu is selected or not.



Program Item Properties Dialog

The Program Item Properties dialog box appears when you choose to create a new program item (see 
Creating New Program Items) or change an existing program item's properties (see Modifying Program 
Item Properties).

Following is a picture, and names of each of the fields found in the dialog. To see    descriptions of the 
fields, click on the appropriate location on the picture, or on the names.

Description

Command Line

Working Directory

Shortcut Key

Run Minimized

Icon Filename

Icon Selection

For additional information concerning program item properties, see Creating Program Items and consult 
the Program Manager portion of the Windows documentation.




