
INSTALLING THE PROGRAM FROM THE CD-ROM

This CD contains a Master Installer program that provides an easy and convenient way to
install the programs on the CD. Follow these instructions to use the Master Installer.

1. Insert the program CD into the CD-ROM drive.

2. From the Windows Program Manager, click once in the File menu option to
display the File menu and select Run.

3. In the Run dialog box, type D:\INSTLL.EXE (note the spelling, no “A”), and
press Enter. If your CD-ROM drive letter is not D, substitute accordingly.

4. The Master Installer main screen is displayed and you are presented with a list of
products to choose from. Make your selections from the list and click on Install to
continue. Master Installer will launch the individual installers for each of the
products selected, and return to the Master Installer screen. Follow the on-screen
instructions to complete the installation for each program. Please note that some
installations may restart your Windows session.

If you encounter problems installing several programs at once, quit the Master Installer
program, and restart it. Install one program at a time.

THE ON-LINE USER’S GUIDE
Documentation for these products have been provided in an on-line format, along with a
Viewer utility. To view the manual, you must first install the On-line Document Viewer
program from the CD. To do this, follow the instructions in the above section. The last
option shown in the Master Installer list box installs the On-line Document Viewer
program to your hard drive. Please note that this installation restarts your Windows
session.

After the installation is complete, run the On-line Document Viewer program and from
the Open File Dialog box, select the file called MANUAL.PDF which is located in the
MANUALS directory of the program CD (e.g. D:\MANUALS\MANUAL.PDF). The
Viewer also contains a full and comprehensive help system to assist you in learning how
to use the documentation.

InstallationInstallation



Getting Started

Welcome to Instant Calendar, the program that makes it easy to publish your business and personal events in customized calendars that look
as if they were designed and printed by a graphic designer.

To install Instant Calendar:

Please refer to the section in front of this manual entitled "Installing the Programs from the CD-ROM"

To start Instant Calendar:

Double-click the program icon.

Finding Help

If questions arise while you are using the program, use the Help system when you need a quick answer to a question.

To learn the function of a menu, menu option, or a button, point to the option or button, then press and hold the left mouse button. An
explanation of the tool appears in the message line at the bottom of the screen.

The Help menu provides information about specific procedures, tools, and terms used in Instant Calendar:

Contents  is a table of contents for the entire Help system. As a shortcut, press F1 to display the contents.
Keyboard & Mouse  is a list of the shortcut keys that you can use instead of the mouse to select options from menus.
How to  gives you quick step-by-step procedures for all Instant Calendar functions.
Tools  is a directory of the icons on your screen.
Messages  tells you how to deal with error messages you may encounter while using the program.
Glossary  defines special terms used in the program.
For CC+ DOS users  outlines important differences between Calendar Creator Plus for DOS and Instant Calendar (Windows).
Using Help  explains how to use the Help system.
About Instant Calendar  tells you the number of the Instant Calendar version you are using.

Quick Start

The following sections lead you through a series of short lessons on using the basic features of Instant Calendar. If you need more
information on specific functions of the program, use the on-line help system.

Creating Event Lists

An event list is a group of events that you keep in one file. It’s a good idea to create event lists that group events by subject. This gives you
greater flexibility in creating calendars because one calendar can combine several event lists about different subjects.

To create a new event list:

1. If you haven’t already done so, start Instant Calendar.
The upper part of a one-month calendar for the current month appears. This working area is called the calendar window.

2. To start creating a new event list, choose New from the File menu.
The working area is now split vertically. The calendar window remains on the left side, and the event list window appears on the right.

3. To add your first event, choose Add Event from the Events menu.
Instant Calendar divides events into two categories: fixed events that take place on specific dates in a specified month and repeating
events that recur regularly on a day of the week or date of the month, such as a meeting every Wednesday.

Instant Calendar



To add a single event:

1. In the Event Name text box, type the text that you want to appear on the calendar, for example:  Jordan sales demo.
2. Click the Start Date box and type the day the event starts..

The event name and the start date are all you need to enter an event. The rest of the information in the dialog box is optional.

3. Click the Add Another button to add more events.
The second type of event is an ongoing activity that takes place on fixed dates that are scattered throughout the month. In Instant Calendar,
this is called a scattered event. Since this event has several dates, you can use the QuickDate calendar to enter them.

To add a scattered event:

1. Once again, type the event name, for example:  Call clients.
2. Click on the appropriate year, month and days in the QuickDate calendar. For example, click the following date buttons: 5, 6, 10, 12,

25, so that the calendar looks like this:

3. Click the Start Time box and type the time the event begins, such as 8:30 am.
4. Click the End Time box and type the time the event ends, such as 11:30 am.
5. Choose Add Another to incorporate additional events.

The third type of event is called a duration event, for example, a conference that takes place on five successive days.

To add a duration event with a banner:

1. Type an event name, for example:   Atlanta Regional Conference.
2. Place the pointer on the date on the day the event starts. Drag the mouse across the date buttons to the day the event ends and

release the mouse button.
At this point, if you displayed this event, the event name would repeat on each day of the week. To save space and emphasize the length
of the event, you can place it in a long box, called a banner, that extends over all five days.



3. Choose Banner on the right side of the screen.
4. Click the option button next to Banner Event, so that the button changes color.
5. Choose OK.
6. Choose OK to add the event and close the dialog box.

The event list displays all the events you’ve added.

Changing the Time Period

To see events  in the calendar window, you need to display the month in which they occur. One way to do this is to use the arrow buttons
on either side of the date field in the window control bar. The left arrow moves the calendar time period backward, and the right arrow
moves it forward.

Saving an Event List

After you add events or edit existing events, you should save the changes that you made. Saving moves the changes from temporary to
permanent storage. If you do not save events after entering them, you will lose them when you close the event list or exit Instant Calendar.

To save an event list:

1. Choose Save from the File menu and select List1.
2. Type a file name for the event list, such as business, in the File Name field.

Event list names can be a maximum of eight characters; the program automatically adds a .CCE extension.

3. Choose OK.

Adding repeating events

You can also add events that repeat according to a regular rule over a longer period of time, such as a birthday or a meeting that occurs the
first Monday of every month. Defining the rule saves you the trouble of entering each occurrence of the event.

To add an event that repeats every week:

1. Choose Add Event from the Events menu.
2. Type an event name, for example:  Aerobics without fail!
3. Type a starting date, such as 1/2/95.
4. Type a start and/or end time if you wish.
5. Click the Repeats button on the right side of the dialog box.

The Repeat dialog box provides for three types of rules, with a different set of options for each type. Initially, no rule is in effect.

Select... For an event that repeats...
Every Every x days, weeks,, months, or years
Day of week On a specific day of the week, such as Monday
Day of month On a specific day of the month, such as the 1st, the 15th, or the last

6. Choose the appropriate option.
For example, for a class that repeats every week, choose Every.

7. Choose an option from the Repeat every: drop-down box, such as Weeks.



8. If you wish, type an end date in the Ending Date text box.

You can leave this at the default; however, giving repeating events end dates decreases the size of event lists.

9. Click on OK.
10. Choose Add Another if you want to add more events.

You can also create repeating events that have exceptions, such as a department meeting that is held the first Thursday of each month
except during the holiday season in November and December.

To add a repeating event with exceptions:

1. As usual, type a name for the event.
2. Type a start date for the event.
3. Type starting and ending times if you wish.
4. Click Repeats, then click the appropriate option, for example:  Day Of Week.
5. In the month box, click all the other months except those where the event won’t occur, for example:  November and December.

6. Choose OK.
7. Choose OK to add the event and close the dialog box.
8. Remember to save your event lists. Choose Save As from the File menu and select the temporary name of the new list, such as

List2.
9. Type a file name for the list, then choose OK.

Using QuickDate

To move quickly to another part of the year or to another year, use QuickDate.

To use the QuickDate button:

1. Click the QuickDate button on the left end of the calendar control bar.



2. Click on the year, month, and day you wish to view.

3. Click on OK.
The calendar window now displays the calendar for the date you selected.

Viewing Calendar and Event Lists

You can enlarge the calendar in the calendar window so you can read the events, or you can reduce the calendar to look at the overall
layout.

To change the calendar magnification:

1. Choose Zoom from the View menu the select the option you want.

 Select..., To...
100%, Display the calendar at actual size.
Form Preview, See the entire calendar with its margins.
Fit Width, Fit the side edges of the calendar in the width of the calendar window.
 Fit Height, Fit the top and bottom edges of the calendar in the height of the calendar window.

2. Use the vertical and horizontal scroll bars to view any section of the calendar that is off screen.

Switching Event Lists

If you have more than one event list open, it’s easy to switch the event list window display from one event list to another. The names of
event lists appear on buttons on the view bar, located just above the two windows.

To switch between event lists:

Click on the button of the event list that you want to view.

The events in that list appear in the event list window. This is now the active list; you can see the events and select them for editing.

Changing Views

Now try some of the different ways to display the calendar and event list windows.

To change calendar and event list views:

1. Choose Event List from the View menu to display only the event list window.
2. Select Calendar from the View menu to display only the calendar window.
3. Choose Split Horizontal from the View menu to show a split screen with the calendar window on the top and the event list window

on the bottom.
4. Select Split Vertical from the View menu to return to the vertical split-screen view.

Practice switching views until you feel comfortable with them.

NOTE:  You can also use the different view buttons on the toolbar to change calendar and event list views.

Click to switch to view the BUSINESS event list.



Editing and Formatting Events

Any time after adding an event, you can modify it to change any of the information or to change the way the event displays on the calendar
by selecting a different font, point size, style or color.

Editing Event Text

You can select an event for editing from either the calendar or the event list window.

To edit an event:

1. Click on the event you want to change so it is highlighted.
2. Choose Modify Event from the Events menu.
3. Change any event information.

If you’re using the QuickDate calendar the days on which an event occurs, simply click on additional days to add them. Click on previously
selected days to turn them “off” if the event won’t occur on that day.

4. When you’re finished making your changes, click on OK to save them.

Formatting an Event

You can change the way event text looks in the calendar, the font, type size, type style, and so on. Use colors and styles, such as bold, to
make events stand out in a crowded calendar.

You must be working in the calendar window to format event text.

To format an event:

1. Click on the event you want to format.

NOTE: Formatting one occurrence of a repeating event also formats all other occurrences.

2. Choose Font from the Format menu.
3.  Choose a font from the list.

A sample of the font appears in the sample box.

4. Select a style, such as Bold, from the Font Style box.
5. In the Color box, choose a color for the event text.
6. In the Alignment box, choose Left, Center or Right to justify the event within its day cell.
7. Choose OK.

NOTE:Colors appear as black, white or gray on black and white monitors.

After you modify events, you should save your changes.

To save your changes:

1. Choose Save from the File menu.
2. To save changes to all open event lists, choose All Event Lists.

Modifying a Layout

A layout is both a time unit and a calendar design. There are 11 layouts for time units ranging from a year to a day. When you create a
calendar, you print events from the open event lists in a specified calendar layout for specified dates.

It’s helpful to have the full calendar on screen when you’re changing the layout. To do so, choose Calendar from the View menu.

To modify the calendar layout:

1. Choose Zoom from the View menu and select Fit Width.
2. Click on an empty area of the desired day cell to select it. Black squares appear at the four corners of the box when it is selected.

A selected day cell



3. Choose layout you want, such as Week, from the Layout menu.
The month calendar changes to a one-week calendar that includes the day you selected.

If you have many events on each day, you may wish to use a layout that shows you one day at a time, giving you more room for events on
each day.

4. Choose Day from the Layout menu.
Now that you are familiar with displaying events in different calendar layouts, you are ready to learn how to modify the layout design.

Formatting a Calendar

The calendar layouts are already formatted for you. However, you can use the layout options to modify different parts of the layout to suit
your taste.

To format a calendar:

1. Choose the layout you want from the Layout menu.
2. Choose Layout Options from the Layout menu.

Any time you need more information about options you see in this dialog box, click on the Help button.

3. Click on the Page Setup button.
Here you can make changes to the calendar margins and change from portrait to landscape orientation if you wish.

4. Now click on the Appearance button.
Here you’ll see specific options for the layout that you selected. For example, if you chose the multi-week calendar, you can change the
number of weeks displayed.

5. Click on the Titles & Pictures button.
The upper box contains the title text (sometimes it is an insert field, a code that generates the title). The lower box shows a sample of the
title as it will look in the calendar.

6. In the Item field, click the arrow next to the box and choose the option you want, such as Subtitle, from the drop-down list.
7. Click in the text box and type your text, for example:   Business and Personal Calendar.

If you need to, use the BACKSPACE and DELETE keys to remove any previous text or correct any typing errors.

8. Choose OK to save all of your changes.

Saving Workspaces

A workspace is the environment in which you work. It consists of the currently selected layout, the names of the open event lists, the
current screen settings, plus the layout options currently in effect for all the layouts.

To save you the trouble of constantly resetting options such as the changes you just made to the calendar, Instant Calendar lets you save
your workspace file. When you open the workspace file, all the options are reset for you and the event lists that were open when you saved
the workspace reopen automatically.

To save a workspace:

1. Choose Workspace from the File menu and select Save As.
2. In the File Name field, type a name, such as myspace.

The program automatically adds a .CCW file name extension.

3. Choose OK.
The next time you want to print or change this calendar, just choose Workspace from the File menu and select Open.



Printing Your Calendars

Before you start, make sure that your printer is properly connected and turned on. It should already be set up to work with your version of
Windows. If you are not sure how to do this, consult your printer manual.

To print a calendar:

1. Choose Print from the File menu.
2. Click the single and double-arrow buttons to the left or right of the Starting Date field until the Starting Date field displays a time

period for the calendar you want to print.

3. Choose Print.
You should now have a basic understanding of how the program works and you are ready to start creating your own calendars.

Use the program’s help system if you have more questions about using the program.



Notice

Copyright © 1994
SoftKey International Inc.
1 Athenaeum St
Cambridge, MA 02147

All rights reserved.

This manual and the software it describes may not be reproduced, in whole or in part, in any form whatsoever, without the written
permission of SoftKey, except for making a backup copy for archive purposes.

Instant Calendar and SoftKey are registered trademarks of SoftKey International Inc. Microsoft, MS-DOS, and Windows are registered
trademarks of Microsoft Corporation. TrueType is a registered trademark of Apple Computer Inc.

Contacting Technical Support

If you have questions about the program, consult this manual and the program’s on-line Help system. If you’re still experiencing difficulty,
gather the following information:

The name of the program you have a questions about.
The versions of Windows and MS-DOS you’re using.
Amount of RAM in your system.
A brief description of your problem, including the exact wording of any error messages.
A list of the steps required to replicate the problem.

Contact Technical Support at:
(707) 428-0008
9:00 am to 8:00 pm Monday through Friday
(Eastern Standard Time)

Send correspondence to:
SoftKey International Technical Support
450 Franklin Road
Suite 100
Marietta, GA 30067

For information regarding replacement diskettes and manuals, contact Customer Service at:
(800) 227-5609
9:00 am to 6:00 pm Monday through Friday
(Eastern Standard Time)
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