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Introduction
InfoRecall is a new type of Software, specifically made to store and find personal and business 
information fast and easy. InfoRecall ties all your information together, accross all Inforecall files 
and records with its powerful search features. Never again will you be looking all over for that 
important information.

Unlike some of the structured software programs, InfoRecall uses a free-form approach. A 
record page can have a few words of information up to 30,000 bytes of data. And you can link 
the information of one record to another record with the hypertext functions.

Clean up your desk, clear away the bits and pieces of information scattered all over the place 
and see how fast your productivity and decision making improves.

Information is vital to success, getting easy access to the information you need is the key to 
your success. You deal with a tremendous amount of information, daily, but too often the 
information you need is not quickly accessible. Some times you can't find it at all. 

Information is power but not having it where you can find it, robs you of that power. A page here, 
a note there, bits of paper in file folders; that's just not good enough any more. If information is 
vital and quick access is the key to success then organization provides that key for you. 
InfoRecall will do that for you! Expand your productivity, take control of your information with 
InfoRecall! We makes it easy!

No programming necessary! Whether you are a business person, a professional or run a 
household, there is lots of information to organize:

· Pieces of Information, normally scatter strored

· Contracts,    clauses, provisos and stipulations. 

· Health    and medical terms referenced and explained. 

· Business terms, concepts, practices, policies, etc. 

· Words and Terms 

· Advertising, Slogans, Campaigns 

· Words that Sell

· A collection of Letters

· Customer Records

· Client Lists

· Inventories

· Product Lists

· Membership Lists

· Obscure English words and terms

· Fitness 

· All type of Lists

· Foreign Languages, 

· Corporate training aid for all kinds of subjects.



Its use is limited only by your imagination.

Now with InfoRecall you can store it all, access it quickly, manipulate it, search through it, import 
text to it, export the whole thing or parts of it to other software, print it out, fax it and more. Use 
the power of the InfoRecall hypertext like functions to switch back and forth from one record to 
the next, and back by simply double clicking on a word. You can cross reference any word to 
any record and instantly access these records. Every piece of text, every word, can be treated 
as a linkable element of your information system.    Large amounts of data can be accessed and 
linked with a few key words or data associations.

InfoRecall supports not only links between text, but also between files in its hypertext like 
environment to provide a robust multi-file access medium. You only need to double click on a 
record that equals a file name and it will open for you, at once. You can get at the power of 
InfoRecall through the simplicity of its push buttons. Conveniently located, the push buttons give 
you immediate access to the power of InfoRecall. And you won't be stuck with our colors. You 
can customize your InfoRecall interface with the built in features that let you change the screen 
fonts, the screen font color and the screen background color, instantly.

InfoRecall is the most productive way to organize your information and it's so easy to learn, 
you'll probably never even have to look at the manual. It's guaranteed to help you increase your 
productivity.



Standard Windows Elements
When you start InfoRecall, you'll see the main window which contains the standard Windows 
control elements. In the upper left-hand corner, the Control Menu box button. In the upper right-
hand corner, the Maximize and Minimize and Restore buttons. The Title bar, with the InfoRecall 
label on it. If you're not too familiar with the operation of these standard Windows elements, you 
should read Chapter 2, Basics in your Windows manual.



Re-Sizing Window
InfoRecall will always start in the Maximized form. You can reduce the size by clicking on the 
down arrow of the button that has an up-arrow and a down-arrow. Once reduced in size, 
InfoRecall will be surrounded by a border which can be used to vary the size of the window both 
vertically and horizontally.



Display Areas
The InfoRecall window has six different display areas: 

The Menu Bar contains all the commands for all the features of InfoRecall. When one of these 
menus is selected, a pull down menu will appear, containing further menu items.

The Information Line consists of:

· The date box

· The Time box

· The files Trop Down box

· The Record Name field

The Tool Bar has is conveniently located and affords you quick access to the most often used 
features

The Record Field is the field on the left. It will hold, in alphabetical order, all the Records that 
you will establish within a File.

The Text Filed is the large field to the right of the InfoRecall window. It will hold the text 
associated with your Records.

The Status Bar consists of:

· The File name box

· The number of records box

· The Record size box

· The help message box



The Menu Bar
The Menu Bar is located just below the title bar. When one of these menus is selected, a pull 
down menu will appear, containing further menu items. Some of the menus have three periods, 
indicating that if you select one of them, a dialog box will appear asking you for more 
information before proceeding.

A Function Key    number (F3..) to the right of the menu item indicates that the function can be 
accomplished by pressing this Function Key or by selecting the menu item. Some menu items 
may have a Check    Mark to the left of them indicating that particular menu item is in use.

Some letters of the menu items are underlined. This means that the menu item can also be 
selected by pressing the Alt key in combination with the underlined letter. As an example: To 
create a new file, press Alt-F-C. or to print a file, press Alt-F-P.



The Information Line
The Information Line is just below the Menu Bar. The first item on this line is the date followed 
by the time. Next to the time is the Drop-Down Files Box and on the right-hand side is Record 
Name Field. 



The Drop-Down Files Box
The Drop-Down Files Box holds the names of all the files that have been established so far. By 
clicking on the arrow to the right of the Drop-Down Files Box, the box will open up and the file 
names will drop down. Click on a file name and InfoRecall will clear the file currently in use, if 
any, and load the new file you've selected. It's a quick and convenient way to open and load 
files.



Record Name Field
This field is used to established the names of new records. Whenever you want to add a new 
record to the file, you'll use this field to type in the record name. Press Enter or click on the text 
field and you are ready to enter text to the record.



The Tool Bar
InfoRecall tool-bar is conveniently located and affords you quick access to the most often used 
features. Please read the section on the File Menu Items for a more in depth explanation of 
these features.

 Show First Record 
This function will select and show the first record in an opened file. 

 Show Next Record
This button will select and show the next record in an opened file.

 Show Previous Record
Will select and show the previous record in an opened file.

 Show Last Record
This tool will select and show the last record in an opened file.

 Search File
This feature will permit you to search for any word or phrase in the currently loaded File.

 Find Next Occurrence
Finds the next occurrence in the currently loaded File, of the word or phrase you've chosen with 
the Search File button.

 Expand/Contract Text Field
Expands the Text Field if it is normal and contracts it back to normal size if it is Expanded.

.  Search Records Field
Finds the occurrence of a Record in the Records Field. If found it will select that Record and 
display its contents.

 Enter New Record
Clears the Record Name Field, the Records Field and the Text Field, readying them for a new 
Record entry.

 Save New Word
Saves a new Record to the file.

 Save Changed Records
Saves changes of an existing Record .

 Delete a Record
Deletes a Record from the file.



 Select Printer Fonts
This feature enables you to select different printer fonts and font sizes.

 Print
Prints a Record to your printer.

 Exit
Closes all Files and exits InfoRecall



The Status Bar
At the very bottom of InfoRecall is the Status Bar. It is a line reserved for messages. The Status 
bar contains the following information when a file is loaded.

· The name of the file currently in use

· The number of records contained in the file

· The Record size when a Record is displayed

· Help messages. 

The record size is continually adjusted as text is added or deleted.

The help messages are directly related to the currently selected menu item or the Tool Bar 
button directly under the mouse pointer. Once you activate a menu and highlight a menu item, a 
short explanation of this feature appears in the Status Bar. This explanation also appears when 
you move the mouse pointer over a Tool Bar button.



Technical
Database

A database is a set of interrelated data records stored in a direct access storage device in a 
data structure that is designed for easy access. The InfoRecall Data base is designed so that its 
size is variable, it allows for growth and change of records. InfoRecall uses a Indexed 
Sequential Access method to create and manage files.

Dataset

A dataset is a File that you have created and consists of 3 DOS files, thus, a set of files or 
dataset. These datasets contain your records and indexes, fast find tables and internal map 
tables. Their extensions are: .ISD, .ISF, and .ISM. The dataset are maintenance free. There is 
no need for any periodic File compacting or reorganization. Files are adjusted automatically for 
growth and change of records.

Files

A File consists of a dataset containing indexes and records. Every time a File is created, you will 
be asked to name the File. The File will be known to you by the name you've given it. The File 
can hold many thousands of records. InfoRecall efficiently manages files up to 512 megabytes.

Records

Records are what are stored in files.    A complete unit of information in a File is called a Record. 
A Record in InfoRecall is made up of the name of the Record and a text field that contains the 
text of the Record. The Record Name can be up to 26 characters long.    InfoRecall allows you 
to have variable length Records, from just a few bytes (characters) up to 30,000 bytes.



Start-Up
Starting InfoRecall
Loading a File



Starting InfoRecall
InfoRecall can be started like all other windows programs, from the Program Manager or 
whatever other means you've selected. In addition, InfoRecall can load a File upon starting. To 
do so, add the file name in the Program Manager. Form the Menu Bar, select the File Menu, 
click on Properties and the Program Item Properties dialog box will display.

Under Command Line and after C :\INFO\INFO.EXE, type the name of the File that you want to 
start with. In the above dialog box, the File Name is "Sample". InfoRecall will start with the file 
Sample loaded automatically. 

The Default Settings for InfoRecall on Start-Up are set to: 

· Screen Font Name: System

· Screen Font Size: 9.75

· Screen Font Colors: Black

· Screen Background Colors: White

· Printer Fonts: Courier

· Printer Font Size: 12

· Hypertext ON

· Toolbar ON

These setting can be changed. To find how, please read the sections on Printer Fonts and 
Screen Settings. 



Loading a File
InfoRecall files can be loaded (opened) four different ways. 

1. Start InfoRecall with a file name specified as described in the above example.

2. From the File Menu select Open File and choose a file name.

3. From the Drop-Down File Box. Click the arrow and click on a File Name.

4. Hyper Load a File by double clicking on a Record Name that corresponds to a File Name. 
(See the section on Hypertext)

5. Please see the menu items for a more in depth explanation of these features



Hypertext

What is Hypertext
The term "hypertext" was coined in the mid-1960's by computer scientist Ted Nelson.    The 
original idea of hypertext came from Vannevar Bush, President Roosevelt's wartime science 
advisor. He proposed a machine called the "Memex" in an Atlantic Monthly magazine article in 
July, 1945 titled "As We May Think".

The strict theoretical vision of hypertext proposes that every piece of text, every word, be 
treated as a linkable element of an information system.    Large amounts of data can be 
accessed and linked with a few key words or data associations. InfoRecall supports hypertext 
like functions. Simply capitalize the words that you want to cross reference. Establish Records 
with names that equal the capitalized words. Double click the capitalized word and you will 
immediately be moved to that Record.

Overview

A InfoRecall File can be made up of many Records that may be related in some ways. Because 
the records are related to each other in this way, it is useful to be able to cross-reference words 
to Records. 

Operation

As an example, a word is used in a Record Text that is more fully illustrated in another Record. 
Capitalize the word, and establish a Record by that name. 

Now, when you double click on the capitalized word, InfoRecall will jump to the Record of that 
name and display its content. If you use and capitalize the word from the previous Record as 
well as capitalizing other words and establishing Records for them, you can jump quickly from 
one Record to another to another yet and back again, to look up related words and terms or 
meanings. You can practice this extremely useful feature with the Sample files that come with 
InfoRecall. 



Hype File Loading

Hyper Loading
Eventually, you may have created many Files, some related in some ways. Similar to the above 
described Hyper Text Function that works with words and records, this function works with 
Record Names in the Records Field. 

A File may contain Records that are related to another file. These Files can be cross-referenced 
so that if you double click on a Record that is also the name of a File, InfoRecall will load that 
File for your viewing. The previously loaded File will be unloaded.

Operation

As an example, a Record used in a File covers a certain subject, but the subject is broad and is 
covered in another File in much more detail. Still you want quick access to this information. 
Capitalize the Record Name, and establish a File by that name, if one does not already exist, 
and place in whatever Records that are required. 

Now, when you double click on the capitalized Record Name, InfoRecall will unload the current 
File and load the File whose name equals the Record Name you just double clicked. 

You may want to    capitalize a Record Name that corresponds to the previous File as well as 
capitalizing other Record Names and establishing Files for them, so that you can move quickly 
between many Files.

The Sample files that come with InfoRecall, provide you with an opportunity to practice this 
important feature.
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The File Dialog Box
The Standard Windows file dialog box is used for the following File Menu Items:

· Open File 

· Create New File

· Delete File

· Import Text File

· Export Text    File



Open File
From the File menu select Open File and the Windows Open File dialog box will appear.The 
Directory shown will always be the directory in which the InfoRecall executable file is located.    
Select a file by clicking on a file name and clicking OK or double clicking on a file name. 
InfoRecall will load the selected file.InfoRecall will display the File Name in the Drop-down    
Files Box in the Information Line as well displaying file information in the Status Bar.



Create New File
Choose Create New File from the File Menu and a dialog box similar to the Windows Open File 
will appear. The File List Box will show all the files but the file names will be ghosted.

Type in the name of the file you want to create. You can type directly over the highlighted file 
extension (*.isd). It is not necessary to add the extension to the file name. InfoRecall will add it 
when it creates the file.Press enter or click OK and your new file will be created and immediately 
loaded into InfoRecall, ready for your use. The file name must consist of 8 letters or less, not 
counting the file extension (isd). If it is longer, you will be informed that it is not a valid file name.

If you click on a ghosted file name, InfoRecall will assume that you want to replace an existing 
file and will issue the warning message, telling you that the file already exists and asking you if 
you want to replace it.If you click Yes, InfoRecall will issue another warning message, just to 
make sure that you don't erase a file by accident. You'll be given another change to choose Yes 
or No. If you click OK, the existing file will be deleted. All your data in that file will be destroyed! 
A new file by the same name will be created. 

It will help to organize your file names to reflect their subjects. For instance, if you want to store 
medical information, call the file MEDICAL. Other files may be BUSINESS or ENGLISH or 
LEGAL, COOK BOOK, TRAVEL etc. 



Delete File
Choose Delete File from the File Menu and a dialog box similar to the Windows Open File 
dialog box will be shown. All the current files will be displayed. Click on a file name and click OK, 
or double click on a file name and a warning message will ask you if you want to delete the file.

Clicking Yes will delete the file. All the data contained in the file will be destroyed.

You can delete a file even if it is currently loaded and in use by InfoRecall. If you choose the 
name of a file currently in use by InfoRecall, a message will be displayed giving you a Yes or No 
choice.Clicking Yes will delete the file. All the data contained in the file will be destroyed. 
The file will be unloaded and any reference of it deleted. You can delete other files. Choose a 
different file extension or choose All Files (*.*) and the Delete File dialog box will display the files 
with that meet the new file extension. Select a File and click OK to delete it.



Import Text File
When you select Import Text File, another menu will pop up and give you a choice of importing 
as a New Record,    Prefix to Record or Append to Record. If you select    New Record, all text 
will be cleared as InfoRecall will assume that this will be a new Record. If you select Prefix to 
Record, the imported file will be adding to the beginning of the existing Record, if you select 
Append to Record the imported file will be adding to the end of the existing Record.

A dialog box appear. The extension *.txt will be prompted in the File Name box and all the files 
that have this extension will be shown in the files list box. You can select the extensions of other 
files (*.doc;*.bat) or all files (*.*) by clicking on the arrow to the right of the 'List Files of Type' 
box.    If this is a new Record, the name of the imported file will be used as the Record name. 
Accept the name or change it and then save it, if you want to keep it as a record.

To select a file, click on a file name in the list box and click OK, or double click on a File name. 
InfoRecall will import the file and place it in the Text Field. Import Text File enables you to import 
and save any ASCII file up to 30,000 bytes long. Any ASCII file can be imported, regardless of 
the file extension. The    imported files are shown in the Text Field AS IS. Any formatting    has to 
be done manually. 



Export Text File
You can export any record as an ASCII text file to be used with Word processor or any other 
software that can use ASCII files. When you select Export Text File, the export file dialog will 
appear.    InfoRecall will suggest a name and displayed it in the File Name box. Accept or 
change the name or change it then press enter or click OK. It is not necessary to add a file 
extension (.ext). You can add any other extension, if no extension is added, InfoRecall will add 
(.txt) to the file name. 

The file name must be made up of 8 characters or less. The total length of the name, including 
the extension .txt, must not exceed 12 characters.If you select a name from the files list box of 
the dialog box or if you have typed in a name of a file that already exists, InfoRecall will warn 
you and ask you if you want to overwrite this file. If you choose to overwrite the file, the previous 
text will be lost, and will be replaced with the new text.



Printer Fonts
When you choose Printer Fonts the Windows Font dialog box will come into view.

The Printer Fonts feature enables you to select different printer fonts. The dialog box will show 
all the fonts available to you. Select a font and a font size and font style then click the OK 
button. 



Printer Setup
The Windows Printer Setup dialog box will become visible.

The dialog box allows you to accept the default printer or select a new printer. You can also 
select the paper orientation to either Portrait or Landscape. When you're done, click OK.



Print Full Text
Prints the Record. If you haven't selected a printer font and a font size, InfoRecall will print the 
record in its default setting. The default font is Tms Rmn and the default font size is 12.

A message will tell you the number of pages required to print the full text and asks you to click 
Yes to continue printing or No to exit printing To print part of the text, see next section on 
Printing Selected Text.Text can be printed both in the Portrait or Landscape orientation. The 
amount of text that will be printed on a line will adjust to the paper orientation.



Print Selected Text
To print part of the text, hold the mouse button down and drag the mouse across the text you 
want to print, then click print.You can also select any text by placing the insertion point at one 
end of the text you want to print, then holding down the SHIFT key, and clicking the opposite 
end of the text.

To select multiple lines, drag the mouse down to the left of the lines.Text can be printed both in 
the Portrait or Landscape orientation. The amount of text that will be printed on a line will adjust 
to the paper orientation.



File Information
A Message box gives you information about the file that is currently in use. The file name along 
with the number of records the file contains and the total size of the file is given.



Exit
Exit will close all files and exit you from InfoRecall, bringing you back to Windows. This 
command can be found on the menu and can be activated from the exit button. If the text has 
changed and has not been saved, InfoRecall will warn you and offer you an option of Yes or No 
to Exit.

If you choose Yes, the text or the changed part of the text, will not be saved to the record.



Data Control
Enter New Record
Save New Record
Save Changed Record
Delete Record
First Record
Next Record
Previous Record
Last Record



Enter New Record
This command clears the Record Name Field and the Record Field as well as the Text Field, 
readying them for a new record entry. If you attempt to enter a new record before the previous 
record has been saved, InfoRecall will warn you with a message that the text has changed and 
ask you if you want to clear it.

Click on the appropriate response button. This warning is for your safety. It can prevent the loss 
of important data if you choose this menu item and the record hasn't been saved.



Save New Record
Saves the newly established record to the file and adds the record to the Record Field. Should 
you attempt to save a record that already exists, InfoRecall will display a message telling you 
that the record exists and if it was a change to an existing Record, to choosethe Save Record 
command.

If this happens, simply change the Record Name and select Save New Record again. If you 
selected Save New Record by accident and you only changed the record then select 
SaveChanged Record from the menu or click on the Save Change Record Button.



Save Changed Record
If you make    changes to a Record Text, select Save Changed Records from the menu or click 
the Save Changed Record    button and the changes will be saved. You can also change the 
Record Name, InfoRecall will delete the old Record Name from the Records Field and add the 
new Record Name. If you change the Record Name to one that already exists, InfoRecall will 
caution you to change the name of the Record.

If this happens,    change the Record Name and select SaveChanged Record again from the 
menu or click on the Change Record Button.



Delete Record
Delete Record allows you to delete a record from the File. Place the cursor bar on the Record 
Name in the Records Field and press the delete button or the Delete Record Menu Item. 
InfoRecall will ask you if you want to delete the Record and present you with a choice of Yes or 
No in a message box.

If you choose Yes, the Record will be deleted!    InfoRecall will remove the Record Name from 
the Records Field. Deleting a Record will destroy the Record and the Record Text. You can not 
undelete a Record!



First Record
This feature will select the first Record in the dataset of the loaded file. This Record may not 
correspond with the first record shown in the Records Field as it is sorted alphabetically. 



Next Record
Choose Next Record    from the menu or click on the Next Record Button and InfoRecall will 
display the next Record in the sequence. 



Previous Record
Select PreviousRecord    from the menu or click on the Previous Record Button and InfoRecall 
will display the previous Record in the sequence.



Last Record
This feature will select the last record in the dataset of the loaded file. This record may not 
correspond with the last Record shown in the Records Field as it is sorted alphabetically. 

When InfoRecall selects the Records as described above, the cursor bar in Records Field will 
be focused on the Record Name and the Record content will be displayed. 



Search
Search Records Field
Search all Files
Search File
Find Next
Find First
Search Text
Find Next Text
Replace



Search Records Field
There are two ways to find a Record in the Records Field. An approximate match and an exact 
match. The default is the approximate match. In the dialog box, type in the name or the partial 
name of a Record. InfoRecall will find the first match of the name and display the Record and its 
content. The exact match, requires you to check off Exact in the dialog box. This method will 
look for the exact match and if found will display the Record and its content.

Search Records Field is not case sensitive.



Search all Files
InfoRecall ties all Files and all Records together through its ability to search for any word or 
phrase in all InfoRecall Files. This feature enables you to find any information, at any time, 
regardless of what file it was saved in.When you select Search all Files from the menu a dialog 
box    will be displayed.Type in the text to search for and press Enter or click Search. InfoRecall 
will search through all Files in the INFO directory and all occurrences will be displayed in a List 
box. The order of display is: the File name, the Record name and part of the sentence that met 
the search requirements.

When you find the instance of the word or phrase that meets your search requirements, place 
the mouse cursor on it and double click. InfoRecall will open the File, locate the Record, show 
the Record's text and highlight the word or phrase you searched for.The Search all Files Result 
listing for the current search can be accessed as many times as you want to. The information 
will be retained until another search is performed.

Search all Files is not case sensitive.



Search File
This feature will permit you to search for a word or a phrase in the currently loaded File. It will 
start the search with the first record and proceed to the last record of the File. The below dialog 
box will ask you to input your search requirement.Simply enter your word or phrase in the 
Search File dialog box and press enter or click on SEARCH . InfoRecall will go to the Record 
that contains your word or phrase and display its content and highlight the word or phrase it 
found. Another way to search is to highlight a word or phrase in the Text Field and choose 
Search File, the dialog box will show that word or phrase. Click SEARCH or press enter to start 
the search. Search Records is not case sensitive.



Find Next
Click the Find Next button or choose Find Next from the search menu or press the F3 key to find 
the next occurrence of the word or phrase you've previously chosen. InfoRecall will go to the 
occurrence of the word or phrase, highlight it and display its content. The next occurrence may 
take place in the same Record or if no more occurrences are found in one Record then the next 
Record will be searched and then the next until the last Record is reached. If no more 
occurrences are found, you'll be notified with a message.

Find Next is not case sensitive.



Find First
Choose the Find First from the menu or press F1 to relocate the first occurrence of the word or 
phrase and again go to the Record that contains your word or phrase and highlight it and 
display its content.



Search Text
This feature will locate any word or phrase in the text of the record that is currently displayed. It 
will start the search with the first word of the text and proceed to the last word. The Search Text 
dialog box will be displayed and prompt you for information.Simply enter your word or phrase in 
the dialog box and press enter or click on FIND. InfoRecall will highlight the word or phrase if it 
is found.Another way to search is to highlight it in the Text Field and choose Search Text, the 
dialog box will show that word or phrase. Click FIND or press enter to start the search.

Search Text is not case sensitive.



Find Next Text
Choose the Find Next from the Search menu or press the F4 key to find the next occurrence of 
the word or phrase you've previously chosen. If found, InfoRecall will again highlight the word or 
phrase. This process can be repeated until InfoRecall reaches the end of the Records Text. If no 
more occurrences are found, you'll be notified with the above message.



Replace
You can replace any occurrence of a word or phrase with another word or phrase or blank 
space. Simply enter the word or phrase to replace in dialog box , then enter the word or phrase 
to replace it with and press enter or click on replace. 

If you don't choose Global Replace, InfoRecall will replace the first instance that matches.If you 
choose global replace, InfoRecall will replace all occurrences with the new word or phrase. If 
you check start at the beginning, then replace will start at the very beginning of the text, 
otherwise it will start at the cursor position. 

Check Verify if you want InfoRecall to ask you if a replace should take place. If verify is not 
checked,    InfoRecall will replace a matching occurrence without notifying you.When Verify is 
checked, InfoRecall will highlight the word or phrase it found and then ask you if you want to 
replace it. 

You can drag the message box around    to make it easier to read your text.

Click No and InfoRecall will look for the next match. If Yes was clicked, then that word or phrase 
will be replaced and InfoRecall will look for the next match. Click on Cancel and the procedure 
will be terminated.

Search & Replace is case sensitive.



Options
Font Types
Changing Text Case
Hypertext ON / OFF
Toolbar ON / OFF
Text Field NORMAL / EXPAND
Select Screen Fonts
Select Screen Color
Default Settings
Restore Saved Settings
Save Settings



Font Types 
You can quickly change the screen display Font Type by selecting one of the following Font 
Types from the Options Menu.

· Regular Fonts

· Regular Bold Fonts

· Regular Italic Fonts

· Bold Italic Fonts

A check mark will appear next to the selected Font Style so that you can tell at a glance which 
type is in use.



Changing Text Case
You can quickly change the case of your text without retyping, making all or part of your text 
lowercase or uppercase.

To change text case:

Choose Upper or Lower case from the Options Menu. All text will change.

Or:

Select the text for which you want to change the case then choose either Upper or Lower case 
from the Options Menu. The selected text will change.



Hypertext ON / OFF
Inforecall treats all capitalized words as potential Hypertext words, checking them against 
records to see whether a link exists. For instance, if you perform a search and InfoRecall finds a 
match that is capitalized, it may highlight the search word and immediately jump to the record 
that has a hypertext links to it. Searches and text editing may be easier with the Hypertext 
switched OFF. 

When Hypertext is ON the Hypertext menu item will show a check mark and read Hypertext ON. 
To switch it off, click on the Hypertext menu item. When OFF, the check mark does not show 
and the menu will read Hypertext OFF. To save your setting, chose Save Settings from the 
Options Menu.



Toolbar ON / OFF
InfoRecall enables you to turn the Toolbar display on and off. To switch it on or off, click on the 
Toolbar menu item.

When Toolbar is displayed, the Toolbar menu item will show a check mark and read Toolbar ON. 
To switch it off, click on the Toolbar menu item. When Toolbar is not displayed, the check mark 
does not show and the menu will read Toolbar    OFF. To save your setting, chose Save Settings 
from the Options Menu.



Text Field NORMAL / EXPAND
You can expand InfoRecall's Text Field by clicking    the Text Field Expand/Contract button on 
Toolbar or by choosing the Text Field Expand menu item. With the Text Field expanded, the 
menu item will read Text Filed EXPANDED.

To Contract the Text Field to normal size click the Text Field Expand/Contract button on Toolbar 
or choose the Text Field Expand menu item. With the Text Field normalized, the menu item will 
read Text Filed NORMAL.



Select Screen Fonts
This feature along with the ability to change the screen color enables you to customize 
InfoRecall to your liking. Choose Select Screen Fonts from the Options Menu. The Windows 
Font dialog box will appear that allows you to change the Font, the Font Style and the Font Size. 
You can see what the font looks like in the Sample box. InfoRecall does not save your new 
Screen Font setting. You can do this by selecting Save Settings from the Options Menu.



Select Screen Color
For those of you who don't enjoy black text on a white background, InfoRecall    enables you to 
achieve the color combination that suits you the best. Some stunning effects can be achieved 
by changing the Screen Color along with Screen Font Colors.

Choose Select Screen Color from the Screen Setting Menu and part of the color palette will 
come into view.

Click on the button and the Palette will open fully.

The color palette will stay on top as you change colors, thus enabling you to try many colors and 
see the result immediately.

There are four check boxes:

1. Text

2. Records

3. Background Color

4. Foreground Color

Text refers to the Text field and Records to the Records field. (Refer to the InfoRecall window 
section) To change the background color in the Text field, check off Text and Background 
Colors. To change the color of the text in the Text field, check off Text and Foreground Color. 
Check Records to change the colors in the records field.To return to the main window, click 
Okay.

InfoRecall does not save your new Screen Color setting. You can do this by selecting Save 
Settings from the Options Menu.



Default Settings
The Default Setting will always change the Screen Fonts, Screen Font Color, Screen Color and 
other defaults to those set by InfoRecall. They are:

· Screen Font Name: System

· Screen Font Size: 9.75

· Screen Font Colors: Black

· Screen Background Colors: White

· Printer Font: Courier

· Printer Font Size: 12

· Hypertext: ON

· Toolbar: ON

The default settings are set internally. There is no need to save them.



Restore Saved Settings
This feature restores InfoRecall to the Screen Fonts and Screen Font Color as well as the 
Screen Color    that was previously saved. This feature is for your convenience, so that you can 
experiment with Options and always restore the screen after you're done.



Save Settings
After you have chosen a combination of Fonts and Font Color and Screen Color that pleases 
you, you can save these setting by choosing Save Settings from the Options menu. A dialog box 
will show and inform you that it is about to save your new setting and enable you to do so or 
cancel the procedure. 

Once saved, InfoRecall will use this setting every time you start.



Edit
Undo
Copy Full Text
Copy Selected Text
Cut Selected Text
Paste



Undo
Reversing an action.

If you perform an action that produces an unwanted result, you can reverse or "undo" the 
action.If    new text has been typed and you choose Undo, InfoRecall restores the Text field to 
the its previous state by erasing the newly typed text. You can    reverse the erase and get the 
text back by choosing Undo again.

If you delete text, you can restore it with Undo. 

Note: You must choose Undo before performing any other action. If you delete text with the Cut 
Full Text or Cut Selected Text menu items then use Paste to restore the text.



Copy Full Text
Copies the full text of a Record to the clipboard. It will be available from the clipboard to be 
pasted to this or any other program as needed. 

This feature is only enabled if a File with Records has been loaded.



Copy Selected Text
Copies the text chosen by you to the clipboard. It will be available from the clipboard to be 
pasted to this or any other program as needed.

To copy part of the text, hold the mouse button down and drag the mouse across the text you 
want to copy then release the mouse button.You can also select any text by placing the insertion 
point at one end of the text you want to copy, then holding down the SHIFT key, and    clicking 
the opposite end of the text.

To select multiple lines, drag the mouse down to the left of the lines.

This feature is only enabled if a File with Records has been loaded.

Cut Full Text

Cuts all the text in the Text Field. The cut text is not lost, it is placed into the clipboard and can 
be pasted back to this or any other program. The status bar will adjust the record size to zero.

This feature is only enabled if a File with Records has been loaded.



Cut Selected Text
Cuts selected text. The cut text is not lost, it is placed into the clipboard and can be pasted back 
to this or any other program. The record size in the status bar will adjust to show the new record 
size. 

To cut part of the text, hold the mouse button down and drag the mouse across the text you 
want to cut then release the mouse button.

You can also select any text by placing the insertion point at one end of the text you want to cut, 
then holding down the SHIFT key, and    clicking the opposite end of the text.

To select multiple lines, drag the mouse down to the left of the lines.

The status bar will display the adjusted record size.

This feature is only enabled if a file with records has been loaded.



Paste
Pastes text from the clipboard to the Text Field of InfoRecall. When you paste an addition to 
existing text, the status bar will display the new record size. 

This feature is only enabled if a file with records has been loaded.


