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Program Registration

REGISTRATION
This software is distributed as "Shareware".    As such, you are free to use it to determine if it meets your 
needs before you are required to pay for it.    You are free to evaluate this software for a 15 day period.    
If, after that time, you determine that you wish to continue to use it, you are required to register your copy 
for a fee of $10. 

To register, send a check or money order made payable to: Don Fordham.
Mail, along with your name, address and telephone number to:

Southwest Software Associates
6888 Granero Drive
El Paso, Texas          79912

Feel free to distribute this program provided that you include all files without modification including 
readme files.    Above all, ENJOY IT!



The File Menu

The File Menu contains only one selection, EXIT.    This is one of two methods for exiting CD Professional, 
the other being through the System Menu (the MINUS sign in the upper left corner of the CD Player 
display.

On exiting CD Professional, the CD can be automatically stopped or can continue to play until Windows is 
terminated.    That choice is governed by an option in the SETTINGS menu called EXIT MODE.



The Catalog Menu

The Catalog Menu controls the database operations of CD Professional.    It contains three options:

n This CD - This selection will bring up a dialog box which displays detailed information about the 
CD currently in the CD drive.    If the CD is already in the catalog, all the information will be displayed 
automatically.    If it is a new CD not yet in the catalog, this is the screen you will use to enter the 
necessary information.    It is not necessary to enter all the information at once since this screen is 
available at any time and information can always be added or changed.

NOTE:    When entering a CD's information, you may check as many Categories as you wish.    For 
example, you may want to categorize Ella Fitzgerald as both Jazz and Vocal.    This will affect how CD's 
are displayed in the database's browsing features.

n Browse By Artist - This selection brings up a browsing dialog box.    Each CD's Artist will appear in 
a sorted list box and the Title of each CD will appear at the top of the dialog box as it is highlighted in the 
list box.    Double clicking on a list box selection or clicking on the VIEW button will bring up the detail on 
the selected CD.    Hitting the DELETE button while browsing will delete the highlighted CD from the 
database.

The browsing dialog box also contains a bitmap area.    If a bitmap file has been associated with a CD, the 
bitmap will appear in this area whenever that CD is highlighted in the list box.    Typically those bitmaps 
would be miniature scanned images of the CD cover.    Such scanned images should be about 80 pixels 
by 80 pixels in .bmp format.

The Category selections filter the database displaying only those CD's matching the selected category.    
Remember, when a CD is entered in the catalog it can have more than one classification and, therefore 
can appear under different filter categories here.

n Browse By Title - This selection brings up a browsing dialog box similar to that described above. 
The only difference is that now the list box is filled with a sorted list of CD Titles rather than Artists.    This 
time the Artist will appear at the top of the dialog box as selections are highlighted in the list box.



The Settings Menu

The Settings Menu contains three selections related to configuration options for CD Professional.    The 
selected options automatically become program defaults and are active each time the program is run until 
they are changed.

n Color - Selecting this option will bring up a standard Windows color palette selection dialog.    The 
selected color will affect all displays on the simulated CD Player front panel including Volume,    Time and 
Track, Repeat and Shuffle.

n Mixer ID - This selection enables you to tell CD Professional where your sound card's Windows 
Mixer is located.    You will be prompted for the full path and file name.    Once this information is entered, 
you will be able to call up the Mixer to adjust such things as Bass and Treble right from the CD 
Professional front panel display.

n Exit Mode - This selection will determine the playing status of your CD Player when CD 
Professional is terminated.    If Play on Exit is selected, the CD will continue to play even after you exit CD 
Professional.    If Stop on Exit is selected, the CD will stop playing on program exit.

NOTE:    If Play on Exit is selected, the CD will continue to play on exit from CD Professional but if 
SHUFFLE or REPEAT are selected they will NOT work once the program terminates.



The Help Menu

The Help Menu provides the usual Windows on-line help functions including a topic on How to Use Help. 
In addition, the About dialog box is selected in the typical manner through the Help Menu, providing an 
animated display of program version information.



General Information

CD Professional is designed to play Audio CD's through your computer's CD Player and sound card.    It 
provides the appearance of a rack mounted piece of audio equipment along with the functionality of the 
controls normally found on audio CD players. 

CD Professional also provides database functions for your CD collection.    It allows you to store the 
Name, Artist and Track Contents for each CD.    Once the data has been entered for any CD, CD 
Professional will automatically recognize it each time it is inserted into the CD Drive.    The database 
feature allows you to browse through your collection either by Artist or by Title and, optionally, attaches 80 
pixel by 80 pixel bitmaps to its display.

CD Professional is distributed as SHAREWARE.    You are authorized to use it for a reasonable period of 
time to determine its suitability, after which you must register it and pay the nominal fee of $10.    
Registration will assure continued support of the program and notification of future upgrades.



Volume Controls

The Up and Down Volume Controls work in conjunction with the Volume Bars on the Front Panel Display 
section.    When CD Professional is started, it determines your sound card's current CD Audio volume 
setting.    This becomes the initial display on the Volume Bars.    As the Volume Up and Down Controls are 
clicked, the volume will be adjusted accordingly, assuming your sound card and mixer support this 
feature.



Eject Button

Assuming your CD ROM device supports this feature, the Eject Button will automatically open and close 
the CD ROM door and/or tray.    Depending on your CD ROM's device driver, you will probably have to 
manually insert the first disk of the session into the drive.    From then on, CD Professional will handle 
ejecting and loading CD's for you.



Stop Button

No matter what state CD Professional is in, the Stop Button will stop playing and reset any special 
conditions like REPEAT, SHUFFLE and PAUSE.    The Track display will return to '1' and the Time display 
will return to '0'.    The Repeat and Shuffle indicators will be turned off, if necessary.



Play Button

The Play Button is used to begin play from a stop condition or to restart play from a pause condition.    
From pause, play will resume at the point it was stopped.    From stop, play will begin from track #1 unless 
SHUFFLE has been selected, in which case play will begin at a track randomly selected by CD 
Professional



Pause Button

The Pause Button will stop the CD at the current point without resetting anything.    Unlike the Stop Button 
which returns to Track 1, Time 0 and resets Shuffle and Repeat, play will resume at the current track and 
time and in the current mode when the Play Button is clicked.



Reverse Track Skip Button

The Reverse Track Skip Button causes CD Professional to skip backwards to the beginning of the prior 
track.    If the button is pressed while the CD is playing, play will continue from the new location, otherwise 
play will start when the Play Button is pressed.    If Reverse Skip Track is clicked while on Track 1, the 
new track will be the highest number track on the CD.



Reverse Seek Button

The Reverse Seek Button causes CD Professional to "rewind" the current track by 20 seconds each time 
it is clicked.    It works on if the CD Player is playing and the position in the current track must be at least 
20 seconds from the start of the track.



Forward Track Skip Button

The Forward Track Skip Button causes CD Professional to skip forward to the beginning of the next track. 
If the button is pressed while the CD is playing, play will continue from the new location, otherwise play 
will start when the Play Button is clicked.    If Forward Skip Track is clicked while on the last track of the 
CD, the new track will be Track 1.



Forward Seek Button

The Forward Seek Button causes CD Professional to "fast-forward" by 20 seconds in the current track.    It 
works only if the CD is playing and if the current position in the track is more than 20 seconds from the 
end of the track.



Repeat Button

The Repeat Button causes the current CD to repeat.    Repeat will continue indefinitely and the Repeat 
status is indicated by the Repeat Indicator located immediately to the left of the Repeat Button.



Shuffle Button

The Shuffle Button causes the currently loaded CD to play in a random order.    Shuffle must be selected 
from a stopped condition; it is ignored if the CD is playing.    Shuffle can be used in conjunction with the 
Repeat Button.    Shuffle status is indicated by the Shuffle Indicator located immediately to the left of the 
Shuffle Button.



Mixer Button

The Mixer Button automatically brings up your sound card's Auxiliary Mixer.    In order to do this you must 
first tell CD Professional the complete path and file name for your Mixer.    This is done through the Setting 
Menu by selecting the Mixer ID option.    NOTE:    If you are unsure of the path and file name, consult the 
documentation for your sound card or contact the vendor's technical support.



Volume Bars

The Volume Bars indicate the volume setting for CD Professional.    They actually represent the volume 
setting of the CD Audio channel of your sound card's Auxiliary Mixer.    When CD Professional is started, it 
determines the current volume setting of the Mixer and causes the Volume Bars to indicate accordingly.    
From then on, clicking on the Volume Buttons will modify the Mixer's CD Audio channel volume and the 
Volume Bars will indicate the relative change.

NOTE:    Changes to volume made directly in the mixer will not necessarily be shown by the Volume Bars 
if CD Professional is running.    It's best to use CD Professional to make the volume change.



Track Readout

The Track Display is a simulated LED readout indicating the currently selected or currently playing track.



Time Readout

The Time Display is a simulated LED readout indicating the elapsed time of the currently playing track.



Repeat Indicator

The Repeat Indicator is controlled by the Repeat Button just to its right.    When on, the Repeat Indicator 
signals that the entire CD will be automatically played again when the last track has been played.    It can 
be used in conjunction with the Shuffle function which will replay the CD once again in a random order.    
Repeat continues indefinitely until the Repeat Button disables the function or until the Stop Button is 
pressed.



Shuffle Indicator

The Shuffle Indicator is controlled by the Shuffle Button just to its right.    When on, the Shuffle Indicator 
signals that the CD will be played in a random order until all tracks have been played.    If it is used in 
conjunction with the Repeat function, the random order will be repeated indefinitely until the Stop Button 
or the Repeat Button are pressed.



Track Title Display
The Track Title Display shows the title of the currently playing or currently selected track.    Its display is 
based on data from your CD database so it only works for CD's already in your catalog.



Track Time Display
The Track Time Display shows the total playing time for the currently playing or currently selected track.    
This information is read directly from the CD so it is available whether the CD is in your database or not.



Title Bar
The Title Bar will indicate the name of the program (CD Professional) until a CD is inserted into the player. 
If the CD is already in your catalog, the title of the CD will appear in the Title Bar.    If the CD is not yet in 
your catalog, "Unknown CD" will be displayed in the Title Bar until you program the CD.



Quick Start

Use the mouse to move around the Front Panel.    Click the mouse any time the cursor is in the shape of 
a hand and information about that part of the Front Panel will be available.




