Tutorial

Welcome
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Welcome to the Ray Dream Studio tutorial.
This tutorial is designed to introduce all
the major features and functions in Ray
Dream Studio 5. The main goal of the
tutorial is to teach you the techniques you
need to know to create 3D illustrations.

Each section of lessons is self-contained so
you can start the tutorial at any point. For
example, if you already know how to model
an object but need assistance on shading,
skip the lessons on modeling and start the
tutorial at the shading section.
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To help you follow along the tutorial, every lesson
contains a section called “The Story so Far”, which
summarizes the procedures that have been covered in
the tutorial up to that point. It also tells you where you
can get pre-set files to complete the lesson.
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Getting Started
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The first thing you need to do is start Ray
Dream Studio and create an empty scene.
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To open a blank scene in Ray Dream
Studio:

q Launch Ray Dream Studio. The New
dialog appears.

a Click the Create Empty Scene button.

A new document is created and four
windows appeatr: the Perspective
window, the Properties palette, the Time
Line window and the Browser palette.

Before starting any project in Ray Dream
Studio, you need to set up the program’s
interface to help you work the most
effectively. Ray Dream Studio’s interface is
very flexible. You can setup menus,
toolbars, and palettes.
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Lesson 1: Setting up your
Workspace

When you first open Ray Dream Studio, the
palettes and toolbars are displayed in their
default positions. If you change these
positions or hide elements, Ray Dream
Studio saves the new positions and use the
them the next time you open the
application.

The workspace configuration shown below
was selected because it allows you to quick
access to all the tools you’ll need during
the course of the tutorial.
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To begin, set up your workspace to look like
this.
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To setup the workspace:

Choose Windows menu» Workspace»
800x640 (Macintosh) /800x600 (Windows).

For more detailed instructions on
workspace settings, refer to“Setting up
your Workspace” on page 25.
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To setup toolbars:

q Choose Diew menu» Toolbars. The
Toolbars dialog appears.

e Click the toolbars you want to view.

A toolbar is displayed when a checkmark
appears next to its name.
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The tools available in the Tools toolbar change
depending on the window displayed.

After you setup your toolbars you can set
the view of the Time Line window. The
Time Line window displays a textual
representation of your scene. This window
is where you’ll arrange groups of objects
and set up the action in your animations.
For more on the Time Line window, refer to
“Using the Time Line Window” on page 32.
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To setup the Time Line window:

q Click the Time Line window to select it.

e Choose View menu» Horizontal.The
Time Line window changes to Hierarchy
mode.

The Perspective window is where you’ll be
arranging and positioning objects to create
a scene. The window displays three grid



planes called the Working Box. The
Working Box can help you orient objects in
three dimensional space. The planes in the
Working Box represent each of the three
axises used to define 3D space, namely X,
Y,and Z.

The Working Box has three grid planes for X,
Y and Z.
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To display planes:

q Click the Perspective window to make it
the active window.

a Click each of the planes on the Display
Plane tool icon.

You will see the planes appear in the
Perspective window.

)

Click on the Display Plane tool icon to
display each plane.

When all the planes are visible, you'll
notice that one of the planes is light blue,
while the other two are light grey. The
colored plane is called the active plane.
When you drag an object in the Perspective
window, it moves parallel to the active
plane by default.

Displaying additional planes allows you to
see the projections of all the objects in
your scene.

The Working Box and the active plane are
important reference tools, there are several
options you can set for there tools. For
more information, refer to “The Working
Box” on page 225.

Arranging Objects in the
Scene
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A 3D illustration is made up of a number of
3D objects arranged in an order that is
pleasing to eye.

Since you’re working in a three dimensional
space your scene can be viewed form any
angle which can produce a wide variety of
different illustrations. A good arrangement
of objects makes your scene look good
from any angle.

The lessons in this section will help you
learn some of the arranging skills you’ll
need to create 3D illustrations.

The Story so Far

Before starting this lesson you should have
your workspace set up to best display all
the necessary tools in the available video
display.

What You’ll Need

To complete this lesson you’ll need some
objects which you can arrange. The
Arranging Objects folder contains all the
objects you’ll need. To start the lesson you
will need to add this folder to the Browser
palette.

Ray Dream Studio’s Browser palette can be
an invaluable utility when arranging
objects. The Browser palette lets you store
Light, Cameras Effects and Objects. For

Chapter 5 e Tutorial 39



more information on the Browser palette,
refer to “Using the Browser Palette” on
page 28.
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You can use the Browser palette to store
scene items including object, Shaders,
Deformers and Links.
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To add folders to the Browser palette:
ﬂ If the Browser palette is not already

visible, choose Windows menu»

Browser.

€] Click the Objects tab.

eChoose Browser palette: File
menu» Add Directory/Folder.

Q Locate the Tutorial folder on the Ray
Dream Studio 5 CD. Open the Arranging
Obijects folder within the Tutorial folder
and then click Select Current Directory.
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The folder contains a library with
pre-made objects you’ll use to create an
underwater scene.
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Once you add Arranging Objects, its contents
appears in the Browser palette’s Objects tab.

Lesson 1: Adding Objects

The simplest way of creating an illustration
is by adding existing objects from various
sources and arranging them to create a
scene. In fact, most complex scenes consist
of a few original objects combined with
stock images or library objects.
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To add objects from the Browser palette:

{ Click the Objects tab.

a Make sure you have the Selection tool
chosen.Click on the Sea Terrain object
and drag it into the Time Line window.

Drag the Sea Terrain object into the Time
Line window.

When you drag an object into the Time
Line window, it appears at the origin of

your scene (i.e. at coordinates X=0, Y=0,
Z=0.

e Drag the objects Shell and Angel Fish
into the Time Line window.

Q Click the object labeled School of Fish
and drag it into the Perspective window.



Objects dragged directly into the
Perspective window are positioned at
the point where you release the mouse
button.

Add the Shell, Angel Fish and School of Fish
to your scene.

Now that all the necessary objects are in
the Perspective window, you'll need to
position them to create a scene.

You'll notice that the terrain takes up a lot
of the scene. This will probably make
positioning difficult. To make it easier to
view the other objects you can make the
terrain object invisible.
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To make objects invisible:

q Click the Sea Terrain object in the Time
Line window.

a Choose View menu» Ob ject
Invisible.

Hide the Sea Terrain to make it easier to
view the other objects.

Lesson 2: Positioning Objects

When you drag objects into the Time Line
window, they appeared at the exact center
of your scene, while objects dragged
directly into the Perspective window
appear wherever you released the mouse
button. This can make it difficult to tell
exactly where objects are in 3D space. For
example, in the front view, two spheres can
appear to be adjacent. However, when you
switch to Reference view, it becomes clear
that the two objects are at completely
different depths.
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When the scene is viewed from the front
view, objects can appear to be adjacent.
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When the scene is viewed in Reference view,
you can see that the same objects are at two
different depths.

To help you position objects in 3D space,
objects have projections which indicate
their position in each of the planes in the
Working Box.

You can tell the exact position of an object
in the scene by locating at least two of the
object’s projections. One projection
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indicates the object’s vertical and
horizontal position and the other indicates
its depth in the scene.
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An object’s projections help you determine
its position in 3D space.
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To position objects manually:

{ Click the object labeled Angel Fish in the
Time Line window.

a In the Perspective window click the fish’s
projection on the ground plane and drag
it towards the left edge of the working
box.
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Click the Angel Fish’s projection on the
ground plane and drag to position it in the
scene.

Q As you drag take notice of the object’s
projections on the other two planes only
move horizontally along the X or Y axis.

q Hold down Option/Alt and drag the fish
upwards.

Option/Alt constrains movement to be
perpendicular to the Active plane.

Hold down Option/Alt as you drag the fish
to position it vertically.

Although you can position objects using
their projections, it’s not the most precise
method. By entering exact values into the
Properties palette, you can precisely
position an object anywhere in your scene.
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To position objects numerically:

d Click the School of Fish object in the
Time Line window.

e Choose Windows menu» Properties.

e Click the Transform tab.



Q In the top row of Position controls, enter
X=-30, Y=-16, and Z=31.
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Enter numerical Position controls in the
Properties palette’s Transform tab.

Q If Auto is not enabled, click Apply.
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The School of Fish are positioned
numerically.

Lesson 3: Rotating Objects

Often, positioning objects vertically and
horizontally is not enough. To get objects
in just the right position in your scene
you'll probably need to rotate them. Like
positioning, you can rotate objects both
manually, using the Rotation tools, or
numerically, using the Properties palette.

Before you begin rotating, you should
adjust the object’s Hot Point. When
rotating, the Hot Point acts as the pivot
point for the object, meaning that the
object will rotate around the Hot Point.

By moving the Angel Fish’s Hot Point you
can rotate it around its nose.
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To adjust the Hot Point:

d Using the Selection tool, click the Angel
Fish object.

a Hold down the Shift key and drag the
black dot in the center of the object to
the nose of the fish.
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With the Selection tool, click the Hot Point...
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...and drag it to the nose of the fish.

Now that the Hot Point is in the correct
position, you can rotate the object.
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To rotate an object using the Rotation
tools:

q Press on the Rotation tool to pop-up and
choose the 2D Rotation tool.

Press to pop-up and choose the 2D Rotation
tool.

a Click the Angel Fish object’s projection
on the ground plane.

€ Hold down the Shift key and drag the
projection to the left until it's rotated 30

degrees. Then release the mouse button.

Holding down the Shift key constraints
the rotation to 30 degree increments.
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Use the 2D Rotation tool to drag the fish’s
projection and rotate it.

Lesson 4: Aligning Objects
Another way of positioning objects is to
align them to certain parts of your scene or
to other object. In Ray Dream Studio, you
can use the Alignment palette to align
objects along each of the three axises (X, Y,
and Z). The Alignment palette gives you
several different methods of aligning. For
more detailed information on the methods
available, refer to “Aligning Duplicating
Objects” on page 244.

In the scene you’ll use the Contact Sides
align option to align the Angel Fish to the
Shell.
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To align objects:
d Click outside the Working Box to make
sure all the objects in the Perspective
window are deselected.

a Click the Shell object with the Selection
tool.

e Hold down the Shift key and click the
Fish object.

QChoose Arrange menu» HAlign
Ob jects. The Alignment dialog appears.

e In the X axis panel, select the Contact
radio button. The Sides radio button is
automatically enabled.

d Click the extension button (key) at the
bottom right of the palette to show the Y
and Z axis panels.
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Click the extension button (key) to expand
the palette.

q In the Y axis panel, click the Align radio
button. The Center radio button is
enabled by default.



Q In the Z axis panel, enable None.

Q Click Apply.

The Fish moves closer to the Shell.

@ Click the Close box to close the
Alignment dialog.

Once you click Apply, the Fish and Shell are
aligned.

Lesson 5: Duplicating and
Grouping

Duplicating is a quick way of creating a
complex object from a simple one. For
example by duplicating a blade of grass you
can create an entire field. Duplicating
creates exact copies of an object.

Although duplicating can be a great way of
creating large objects, arranging many
duplicates in a scene can quickly become a
complex task. You can make arranging

easier by combining a number of

duplicates into a single group. A group can

let you position and edit a number of
objects all at the same time.

In the scene you’'re creating, you can add a

bed of sea anemones by duplicating a
simple object and grouping it.
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To duplicate objects:
q Click the SeaTerrain in the Time Line
window and choose View menu»
Ob ject Visible.

a Drag the object labeled Anemone out of
the Browser palette and into the Time
Line window.

q Choose Windows menu» Properties.
The Properties palette appears.

Q Click the Transform tab.

e In the Position controls, enter X=46,
Y=-10 and Z=-1.5.
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The Position controls in the Properties
palette let you numerically position objects.

When the new position values are applied to

the anemone, it moves to the edge of the

terrain.

Q Click the Anemone object in the Time
Line window.

q Choose Edit menu» Duplicate.

Q In the Position controls, enter X=42.75,
Y=-13.25, Z=-1.5 and in the Orientation
controls enter Yaw= 6.5, Pitch=-8.85,

Roll=85.

The duplicate object is now offset and
slightly rotated.
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By entering values in the Properties palette
you can offset and rotate the duplicate.

Q Duplicate the object again and enter
X=46.85, Y=-15.75, Z=-1.5 and Yaw=-6.5,
Pitch= 8.85, Roll= 95 into the Properties
palette.

Duplicate the object again and change its
position to create a series of anemones in
your scene.
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Now that you have a series of anemones,
you can group them and create a bed of
anemones.
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To group objects:
q In the Time Line window, hold down the
Shift key and select all the objects
labeled Anemones.

a Choose Arrange menu» Group. A new
group object is created.

e Click the group’s title and type Anemone
Bed.

L
Sea Temain
s ()
Angel Fish
Lg-e
Anemone Bed Anemone
<
Anemone
<

Anemone

The Anemone bed appears as a new group in
the Time Line window.

You can use the minus/arrow icon to open
or collapse the group. When the group is
collapsed you can only edit the group,
when it’s open you can edit the individual
objects.

Moving On

Your scene is now complete. If you're
happy with the way your scene looks,
choose File menu» Save and save it as
ARRNG_TUT.

You can now adjust the position of lights
and cameras, then render your scene. If
you want to learn how to setup your scene
for rendering skip ahead to “Lesson 2:
Positioning Lights” on page 70.

If you want to learn how the objects in the
scene you just arranged were created,
move on to the next section.

Arranging is an essential part of modeling
SO you may want to refer to “Arranging
Objects” on page 232 for more detailed
information.



Modeling Objects
OO G- OG-0-0-0

Modeling refers to the process of creating
three dimensional objects in Ray Dream
Studio. A 3D model can be anything from a
basic cube to a complex sea monster.

The lessons in this section will lead you
through the different types of 3D modeling
you can do in Ray Dream Studio.

The Story so Far

At the start of this section you should
already know the basics of arranging
objects in your scene. If you're not clear on
how to align, rotate or numerically position
objects, review “Arranging Objects in the
Scene” on page 39, or Chapter 12,
“Arranging Objects.”

What You’ll Need

In these next lessons you’ll be creating
objects from scratch so you don’t need any
other components. However, we have
included completed versions of all the
objects described in the lessons. If you
have trouble, open the completed object
and see how it was made. Completed
objects are located in the Tutorial:
Modeling Objects folder.

So as not to clutter the workspace, start
each lesson with a blank scene.

Lesson 1: Free Form Modeling

The Free Form modeler lets you create 3D
objects by drawing cross section shapes
and extruding them along a sweep path.

The cross sections determine the basic
outline of the object, while the sweep path
determines its depth.

The modeler has three drawing planes
which you can use to create and extrude
cross sections: the cross section plane and
two sweep path planes. The active plane is
shown in color while inactive planes are
displayed in gray. Like the Perspective
window, you can use the Zoom tools to
magnify areas of your object.
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Use the Free Form modeler to create new 3D
objects.

Refer to “Free Form Modeling” on page 109
for more on the Free Form modeler.

In this lesson you’ll use the Free Form
modeler to create some seaweed.
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To create an oval cross section:

d Click the Free Form tool and drag it into
the Time Line window.

<]
Drag the Free Form tool into the Time Line

window to open the Free Form modeler.

The Free Form modeling window
automatically opens.

a Enter a name for your object and
click OK.

eChoose UView menu» Preset
Position» Drawing Plane.

This changes the view of the modeling
window to display only the active plane.

QChoose View menu» No Preview.

This turns off all shading, making it
easier to see what you’re drawing.

eChoose Geometry menu» Extrusion
Method» Pipeline.

This translation method lets you create a
more tubular shape. For more on
translation methods, refer to
“Translation vs. Pipeline” on page 131.

d Click the Zoom tool and enlarge an area
of the Modeling window.
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Q Press on the Square tool to pop-up and
choose the Oval tool

The Oval tool creates oval cross sections.

Q Click a point on the cross section plane
and drag diagonally. Try to create more
of a flat oval shape than a circle, this will
be the cross section of the seaweed.

-

Use the Oval tool to create oval shapes as a
cross section for the seaweed.

Q Press Command-Shift-C/Ctrl+Shift+C to
center the cross section.
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To use multiple shapes in a cross
sections:

d Choose the Selection tool and click the
oval.

a Choose Edit menu» Copuy.
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eChoose Edit menu» Paste.
Q Deselect all shapes.

Q Hold down the Shift key and drag the
oval to the right. The two ovals should
be just touching as shown below.
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Move the pasted oval to the right so that the
two ovals are touching slightly.
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GChoose Edit menu» Select RIIto
select both shapes.

aChoose Arrange menu» Combine as
Compound.

Q Press Command-Shift-C/Ctrl+Shift+C to
center the compound cross section.

QChoose View menu» Preset
Position» Reference.

@ Click the Zoom tool.

Q

The Zoom tool lets you magnify your view of
the scene.

@ Hold down Option/Alt and click the
center of the scene to zoom out.
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When you zoom out in Reference view you

can see you new cross section in the Free
Form modeling window.

Now that you have the outline of the object
you'll need to adjust the sweep path and
extrusion envelope to give it a more
organic look.

Before you can adjust the shape, you will
need more points on the sweep path.
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To add points to the sweep path:

q Click the ground plane to make it active.

aChoose View menu» No Preview.



Q Hold down the Shift key and click the
sweep path, then extend it to the edge of
the Modeling window.

The sweep path is displayed in red.
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Extend the sweep path all the way to the

edge of the Free Form modeling window.

QChoose Geometry menu» Extrusion
Enveloper» Symmetrical to add an
extrusion envelope.

e Double-click the Convert Point tool to
choose the Add Point tool.

Every time you click the tool on the
toolbar, a new tool appears. You can
cycle through all the tools by clicking on
it repeatedly.
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The Add Point tool lets you add control
points to path.

G Click the sweep path. A new point is
added.

Each time you click the path a new point
is added. You'll need the new points to
create additional cross sections. Every
point on the sweep path represents a
point where you can place a cross
section.

Q Add two more points to the sweep path.

When you’re done adding points, your sweep
path should look like this.

Now that you've added points, you can
move them to reshape the sweep path.
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To move points:

d Choose the Selection tool.

e Click the second point and drag it to the
left.
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Make sure you're selecting a point on the
sweep path (the red line) not on the
envelope (the blue lines).

.
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Add a second point on your sweep path and
drag to the left.

Make sure all the points are deselected
before going on.

Q Click the next point and drag it to
the right.
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Q Click the next point and drag it to
the left.

After adjusting the points along your sweep
path, it should look like this.

Q Press on the Add Point tool to pop-up
and choose the Convert Point tool.
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Choose the Convert Point tool.

@ Click each point on the sweep path and
drag up.

Your sweep path should now look like
awave.

After you use the convert points to smooth
the sweep path it should look like a wave.

QChoose View menu» Preset
Position» Right.

Q Click the Zoom tool and zoom in on the
sweep path.



Q Click the second point on the sweep path
with the Selection tool and move
it down.
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Use the Selection tool to move the second
point on sweep path down.

You'll need to deselect all the points
before selecting the next point.

@ Click the next point and move it up.

G Click the next point and move it down.
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When you’re done adjusting the points, your
sweep path should look like a wave.

Your seaweed now waves both side to side
and up and down. Next you’ll adjust the
extrusion envelope to add the final touches
to your seaweed.
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To adjust the extrusion envelope:
d Click the final point on one of the
envelope line and drag it towards the
center.

Envelope definition lines are shown
in blue.

Drag the final point to the center to “pinch
off” the extrusion envelope creating the tip of

the seaweed.

aChoose View menu» Preset
Position» Reference.

Q Click Done.

Your completed seaweed should look
like this.

Your seaweed stalk is now complete. You
may want to save it in a convenient
location. Once the object is in the
Perspective window, you can position and
duplicate it to create a seaweed bed. For
more information, refer to “Lesson 5:
Duplicating and Grouping” on page 45.
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a Press to pop-up and select the Draw e Choose Diew menu» Preset
Oval tool. Position» Reference.

@ Choose the Add Point tool.
A
g
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Select the Draw Oval tool to draw oval cross T
sections. |
Q Hold down the Shift key and draw a Use the Add Point tool to add new control
You can arrange and duplicate the seaweed circle about five grid squares in points to a path.
diameter.

in the scene. .
Q Click the sweep path on the ground

plane and add a point about two grid
squares from the first point.

Lesson 2: Complex Free Form
Modeling

Now that you know how to create simple
objects using the Free Form modeler, you
can use the skills you learned to create
much more complex objects. Many objects
have more detail than can be extruded
using only a simple cross section and
sweep path. In the next chapter you'll learn
how to use multiple cross sections and
shape numbering to create a sea anemone.
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To create multiple cross sections: Use the Draw Oval tool to create the first
Ccross section.

q Open the Free Form modeler.
Use the Add Point tool to add a point on the

Q Press Command-Shift-C/Ctrl+Shift+C to ; '
sweep path two grid squares from first.

center the cross section.
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QChoose Sections menu» Create.
Q Choose the Selection tool.

@ Click the new cross section and choose
View menu» Preset Position»
Drawing Plane.

mChoose View menu» No Preview.

@Choose Sections menu» Next. If Next
is not available you are already on the
correct section.

@ Choose the Oval tool.

@ Hold down the Shift key and draw six
smaller circles inside the larger circle.

You may need to move the circles to get
them inside the larger circle.

Add six smaller circles inside the larger circle
with the Oval tool.

@Choose View menu» Preset
Position» Reference.

@ Choose the Selection tool.

Q On the ground plane, click the last point
on the sweep path.

@ Hold down the Shift key and drag it to
the end of the Working Box.

Extend the sweep path to the end of the Free
Form modeling box.

@Choose Sections menu» Create. A
new cross section is added to the end of
the path.

To ensure that shapes with multiple
cross sections are extruded properly,
you can assign numbers to shapes. Ray
Dream Studio uses corresponding
numbers to determine how to extrude
Cross sections.
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To adjust shape numbers:

d Click the last cross section on the sweep
path.
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When you select the last cross section on the
path, the cross section becomes the active
Drawing plane.
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aChoose Sections menu» Show
Shape Numbers.

Q Change the number of the cross sections

to match those shown below.

You can use the cross sections shape
numbers to control how multiple sections are
extruded.

eChoose Sections menu» Previous.
thoose Sections menu» Previous
again. You should be on the first cross

section.

If Previous is not available you’'re already
on the first cross section.

eChoose Sections menu» Next.
@ Click a cross section number. The Shape

Number dialog appears.This dialog lets
you change the shape’s number.
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When you’re done adjusting the shape
numbers on your cross section, they should
match these shown.

Q Choose Sections menu» Next.

Q Select shape #1 and delete it. All the
numbers change.

@ Change the shape numbers to match the
diagram shown below.

After you delete a shape, the number all
change so you need to adjust the remaining
numbers to match those shown.

@ Click shape #2 with the Selection tool.

@ Choose Windows menu» Properties.

@ In the Position controls, enter
Width=0.25, Hieght=0.25. Be sure the
Keep Proportions box is enabled.

Qclick Apply.



@ Repeat steps 11 to 14 for each of the
remaining shapes.
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When you’re done resizing the cross sections,
your cross sections should look like these.

Now that the numbers are correct, you can
add more sections.
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To add more sections:

q Click the ground plane to make it active.

a Choose the Add Point tool.

Q Add a point between the second and last
cross sections.

The new point determines where the cross
section will be placed.

q Choose Sections menu» Create.

e Click the new cross section.
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The new cross section has the same number
of shapes as the previous section.

QChoose UView menu» Preset
Position» Drawing Plane.

a Choose Sections menu» Show»
Current.

Q Drag the circles away from the center as
shown below.

When you’re done repositioning shapes, your
cross section should look something like this.

QChoose View menu» Preset
Position» Reference.

@ Click the Shaded Preview Quality
button.

@

Use the Shaded Preview Quality button to see
a preview of your object with shading.
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mChoose Sections menu» Show» AIIL
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Your object should look like this in Shaded
Preview.

Now that you have all the necessary cross
sections, you can add a extrusion envelope
to reshape the anemone.

A A e A e A
To adjust the object’s envelope:

QChoose Geometry menu» Extrusion
Envelope» Symmetrical.

e Choose the Add Point tool.
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Q Add a point on the envelope as shown.

e

™
Use the Add Point tool to create a new point
on the object’s envelope.

Q Choose the Selection tool.

e Drag the new point down and to the left
as shown.

-

Use the Selection tool to adjust the position
of the new point.

G Choose the Convert Point tool.

il

T

Use the Convert Point tool to convert lines to
curves.

a Smooth the points as shown.

-

After you adjust the points on the envelope,
your object should look like this.



Q Click Done.

This is how your completed anemone
appears in the Perspective window.

Your sea anemone is complete. You may

want to save it in a convenient location. In
the Perspective window you can duplicate
the anemone to create a sea anemone bed.

¥ &
-

Duplicate the anemone to form a bed.

Lesson 3: Mesh Form Modeling

The Mesh Form modeler lets you create 3D
objects by adjusting the position of
vertices, or points, mapped onto a shape or
outline.

The Mesh Form modeler is a very organic
way of modeling. You can think of the
objects you create in the modeler as being
made out of a malleable medium, like clay,
that can be reshaped by pulling or pushing
it’s surface.

The Mesh Form modeler lets you create
objects using vertices and polymeshes.

Like the Free Form modeler, the Mesh
Form modeler has three drawing planes
representing the X, Y, and Z axises.
However, since you’re not working with a
sweep path there are no projections to
work with. All your modeling is done
directly in 3D.

The axis indicator will help you tell which
plane you’re working in.

The Mesh Form modeler axis indicator helps
determine the plane you’re working in.

Each plane has a different color. The X axis
is in green, the Y axis in blue and the Z axis
is red.

Refer to “Mesh Form Modeling” on
page 137 for more on the Mesh Form
modeler.

In this next lesson you'll create a fish using
a 3D primitive and the Sphere of Attraction
tool.

To open the Mesh Form modeler:

q Drag the Mesh Form tool into the
Perspective window.

S

Drag the Mesh Form tool into the Perspective
window to open the Mesh Form modeler.

The Mesh Form modeler opens.

a Enter a name for your new object and
click OK.
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To create a 3D primitive

d Choose the Create Sphere tool.

=||
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Drag with the Create Sphere tool to make a
3D sphere.

a Drag the tool in the Mesh Form modeling
window. Using the grid squares, make
your object approximately 4 x 4.

Your 3D sphere should be about four grid
boxes wide and four grid boxes long.

Q Choose the Selection tool.
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Q Click the top right point of the sphere’s
bounding box and drag to flatten and
stretch the sphere as shown.

The flattened sphere should be about
two grid squares wide.

Drag the sphere’s bounding box to stretch
and flattened it.

Now that you have the basic shape, you
can move its points (also called vertices) to
reshape the sphere’s outline

. SR e e e e e
To edit an object’s mesh:

QChoose View menu» Preset
Position» Left.

a Choose the Marquee tool.

="
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Use the Marquee tool to select a group of
vertices.

Q Drag to select the back half of the
sphere.

Use the Marquee tool to selected the vertices
on the back half of the object.

QChoose Selection menu» Subdivide.
This will double the number of points in
the selected area. The more points you

have, the more control you have over the
shape of the object.

Q Click the Sphere of Attraction tool.
N

Use the Sphere of Attraction tool to move a

group of vertices.

e Choose Windows menu» Properties.
The Properties palette appears.

q Click the Tool Options tab.

Q Select the Spiky radio button.



Q Set the Radius of Sphere to 4.00.

4E Mumerical * Tool UDliuns\ Action Modifiers \

Sphere of Altraction Tool
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& Spiky ¢ Bumpy
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Altraction mods
’7(? Move selection. attract other vertices

= Attract only selected vertices

Radiuz of Sphere:

Use the Sphere of Attraction options to set
the radius and shape of the tool.

@ Click outside the sphere to deselect it.

G Select the left-most point on the sphere
and drag it left.

The left-most point on the sphere is
approximately in the position shown. You
may need to zoom in on the object.

Stop dragging when your shape looks
like the one shown below.

Your object should look like the one shown
after you drag the vertex.

=i
To create the fish’s tail:
d Click the Zoom tool.

a Zoom in on the extended section.

Q Click the second point from the left on
the top edge of the tail.

You may need to click a few time to find
the right point. Refer to the diagram
below for more precise positioning.

Tip: If you accidentally click on a segment
(a line with two points), click outside the
object to deselect it.

Click the vertex shown above and drag it to
the left.

Q Drag the point up and towards the left as
shown.

After you’re finished moving the vertex your
object should look like this.

Q Click the second point from the left on
the bottom edge of the tail.

Click the point shown and drag it down and
to the left.

Chapter5 e Tutorial 59



G Drag the point down and to the left.
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The tail should look like this when you're
finished adjusting the vertex.

d Choose the Sphere of Attraction tool.

Q Inthe Properties palette: Tool
Options tab, enable the Spiky radio
button and set the Radius of Sphere to
0.5.

Q Click a point on the top edge of the
object and drag it up and to the left.
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Your dorsal fin should look like this when
you're finished adjusting it with the Sphere of
Attraction tool.

The basic shape of your fish is now

complete. To finish it off you’ll need to
adjust the smoothness of the fish shape.
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To smooth object edges:

d Choose the Marquee tool and select the
entire object.

eChoose Poly Mesh menu» Smooth
Edges.

Q Click Done.

Your completed fish should look like this.

The fish is now complete. You may want to
save it in a convenient location. The fish
object you just completed was used to
create the School of Fish object in the first
section.

To create the school you’ll need to
duplicate and group the fish. For more
information, refer to “Lesson 5: Duplicating
and Grouping” on page 45.

When your fish is complete you can duplicate
and group it to create a school of fish.

Lesson 4: Deformers

Deformers are a special set of tools that let
you reshape objects or groups of objects.
Using deformers you can easily create
effects that would require a large amount of
repositioning and editing. For example, you
can explode an object by just applying a
deformer instead of breaking the object
apart manually and repositioning all the
pieces. For more on Deformers, refer to
“Deformers” on page 171.

In this lesson you’ll apply the Wave
deformer to a fish object. The Wave
deformer will give the fish object a fluid
look.



Although this tutorial instructs you to use
the fish from the Browser palette, feel free
to use the fish object you created in the
Mesh Form modeler.
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To apply a deformer:

q If you haven’t done so already, add the
Modeling Obijects folder in the Tutorial
folder to the Browser palette:

Ob jects tab.

a Drag the Mesh Form Fish object from the
Browser palette to the Perspective
window.

Browser &

Shaders \' Deformers \\,‘" Behawiors \_

=
ks N 1

Arranging Objects : LANDSEA Modeling Objects : NATURE REC
j ¢ 2 2
) & ¢ & 9 ~ | B N E
Anmon.. Ange fis.| Buldcer... Countach... anstnons. . [ssh for_| Butteny. . Crocae.. o
B x " = .
s xR &
Arrangin.. Sshootar..| Curdag... Dubtdeck...| Seesd A
@ 5
& | % | i ®
Ses terr. Shellrdd | Motrbike .. Speshutl Iriz rdd  Magnolia Pir
- % -lf— #
Sr-71rdd  Truck.rdd Palmtres Wasp.rdd W {}
K& [ B

When you add the Modeling Objects folder to
the Browser, you should see the Mesh

Form Fish.

e Choose Windows menu» Properties.

Q Click the Deformers tab.

Q Choose Wave from the Defomers pop-up.

Propeitis
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Phase:
0%
Number of Wave Cycles
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Height of Waves
19%
Shape
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Drientation
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Use the Wave Deformer controls to set the
phase and shape of the wave.

@ If it is not already enabled, enable the
Auto button at the bottom of the dialog.

When this button is enabled, any settings
you change are automatically applied to
the object.

Q Set Phase to 0.

Q Orientation to X Axis.

Q Set Number of Wave cycles=1.5.

@ Set Height of waves =08%.

@ Click the Direct Manipulation button.

o

Click the Direct Manipulation button to
display the Deformer’s control handles.

Direct manipulation lets you adjust the
deformer’s settings interactively in the
Perspective window.

@ Click the center point and drag it to the
left. The center points adjust the phase.

The Direct Manipulation controls let you
adjust the Wave deformer’s attributes in the
Perspective window.

@ Close the dialog.

The fish should now look like its swimming
though water. Deformers can also be
applied to groups of objects. For example if
you create a school of fish from the single
fish object you can apply the Wave
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deformer to the entire school. All the fish
will then appear to be swimming in the
same direction.

Moving On

After completing the lessons in this section
you should be familiar with the different
types of objects you can create with Ray
Dream Studio. The objects you created are
just the beginning. You can create some
incredibly complex objects just by
combining the skills outlined in these
lessons. For example, the same techniques
used in Lesson 1, can be used to create
leaves or plants. The techniques in

Lesson 2 can be used to create an octopus
or any number of tentacled creatures.

A good way to expand your modeling skill
is to jump into some of the objects in the
Browser palette. You can examine their
sweep paths and cross sections to see how
you might go about creating your own
objects.

The next section of the tutorial will lead
you through the process of creating and
applying shaders to objects.
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Shaders are used to apply surface
properties to objects. The Shader
determines whether the object is shiny or
dull, rough or smooth, transparent or
opaque. By combining several different
surface properties you can make even the
simplest objects come alive.

A Shader can be saved as a file in the
Browser palette which allows you to apply
the same surface properties to several
different objects.

The lessons in this section will teach you
how to create, save and apply shaders.

The Story so Far

In the previous sections, you learned how
to create and arrange objects. The type of
shader you create will largely depend on
the shape of your object, so you should be
familiar with modeling concepts and
procedures. For more details of modeling,
refer to “Free Form Modeling” on page 109
and “Mesh Form Modeling” on page 137.

What You’ll Need

In the next lessons you’ll be creating
shaders. To see the effects of the Shaders
you'll need to apply them to some objects.

B e e e T

To add lesson files to the Browser
palette:

q Click the Objects tab and choose
Browser palette: File menu» Hdd
Directory/Folder.

a Locate and open the Tutorial folder on
the Ray Dream Studio 5 CD-ROM. Open
the Tutorial folder, then open the
Shading Objects folder.

e Click Select Current Directory.

Q Click the Shaders tab and choose
Browser palette: File menu» Add
Directory/Folder.

Q Locate the Tutorial folder on the Ray
Dream Studio 5 CD-ROM. Open the
Tutorial folder, then open the Shading
Objects: Tutorial Shaders folder.

Q Click Select Current Directory.

For more instructions on opening folders in
the Browser palette, refer to “Arranging
Objects in the Scene” on page 39.

Lesson 1: Creating Shaders

Shaders are a collection of surface
properties that are saved in a special file
called a shader file. You can create new
shader files and edit existing ones using the
Current Shader Editor palette.



In this lesson you'll use the Current Shader
Editor to create a new shader and save it in
the Browser palette.

Since you’ll be applying shaders to your
objects in this lesson you should adjust
your preview mode to better see the affects
of the shaders.
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To change the preview mode:

Click the Shaded Preview Mode button.

Fl

Use the Shaded Preview Mode button to see
the effects of shaders on an object.

In this preview mode, you will be able to
see any texture maps you apply to objects.
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To create new shader:

q Drag the Shell object from the Browser
palette to the Perspective window.

a Choose the Eyedropper tool.

Z

Use the Eyedropper tool to pick up the
selected object’s shader and display it in the
Current Shader Editor palette.

€ Click the Shell.

The Current Shader Editor palette
appears. When you create a new object,
Ray Dream Studio places a default
shader on it. The default shader has all
the shader’s channels set to 50. Each
shader has eight channels which store a
different surface property.

9_ Doc2 Shader =] E3

Editing:
. Browser Selection

[4B]  Color | Highiiaht |
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The Current Shader Editor lets you edit the
shader’s eight property channels.

Q Click the Color tab.

eChoose Shader Editor: Insert
menu» Texture Map.

G Locate the file Tutorial: Shading
Objects: SHELL_TEXTURE on the Ray
Dream Studio 5 CD-ROM.
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You can import this image to use as Texture
map on your object.
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The Texture map controls appear.

Texture Map
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The Texture Map controls let you specify the
tile size and orientation of the texture map.

@ Click the Highlight tab.
Q Set the value to 50.

Q Click the Shininess tab and set the value
to 50.

@ Click the Bump tab.
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@Choose Shader Editor: Insert menu»
Texture Map.

@ Locate the file Tutorial: Shading
Objects: SHELL_BUMP on the Ray Dream
Studio 5 CD-ROM

! 14}
You can also import a different image in the
Bump channel to use as a Bump map.
@ Set Brightness to 30%.

Bump channel effects can only be seenin
the final rendered image.

@ Click Apply.
Your shader is now complete. If you want

to apply the shader to other objects, you
need to save it in the Browser palette.
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When you click Apply, Ray Dream Studio
applies al the attributes in all the Shader
channels to the Shell.
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To save a shader in the Browser palette:

q Click the Browser palette: Shader
tab.

a In the Current Shader Editor, click the
shader preview image and drag it to the
Browser palette.

Browser
File View
(B o Shadelslﬁ Objects | Q Lights I

Shaders

Checkers |Conchs..

0

Green Marble

@

Orange:

Apply o« [

You can drag your Shader to any shader
family in the Browser palette.

Q Enter a name for the shader.

Lesson 2: Applying Shaders

Ray Dream Studio lets you apply shaders in
a number of different ways. You can apply
the shader uniformly, or use the 3D Paint
tools to apply shaders to specific areas of
an object.

In this lesson you'll use Paint shapes to
apply stripes to a fish and then use the 3D
Paintbrush to fade them.
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To apply a shader uniformly:
q Drag the object labeled Angel Fish from
the Browser palette to the Time Line
window.

a Click the Shaders tab.



Q Locate the drag the Angel Fish Skin
shader from the Browser palette onto
the Angel Fish object.

The fish’s skin was created by applying the
base shader Angel Fish Skin.

The Fish Skin shader is designed to be
used as a base shader, meaning that the
properties set for this shader will be
carried over to any other shader you
apply on top of it.

Once the fish’s base color is set you can
add the stripes.
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To a place a paint shape on an object:

¢ Click the Angel Fish Stripes shader in the
Browser palette.

The Angel Fish Stripes shader was
created using a single image map of
stripes. All the other channels in the
shader are empty.
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You can see how the Fish stripes shader was
created by opening it in the Current Shader
Editor.

I Inwert color

a Choose the Rectangular Paint Shape
tool.

Use the Rectangular Paint Shape tool to

create a rectangular paint shapes on objects.

The Paint Shape tools let you place
image maps directly onto the surface of
an object.

eChoose View menu» Preset
Position» Left.

Q Drag a large square over the body of the
fish.

Drag the Paint Shape tool on the object’s
surface to size the paint shape.

The stripes appear when you release the
mouse button.
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If the stripes are not in the right place,
Choose the Paint Shape Selection tool
and drag it to a different location.

When you release the mouse button the
stripes appear.

eChooseUiew menu» Preset
Position» Right.

6 Draw a large square on this side as well.

Since the fish’s stripes are in a shader, you

apply them again to the other side of the fish.

Now that you have the stripes on the fish.

You can make them appear to fade as they

reach the fish’s edges.
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To apply a shader using the 3D
Paintbrush:

q In the Browser palette, click the Fish
Skin shader.

a Choose the 3D Paintbrush tool.

&

Use the 3D Paintbrush tool to paint brush
strokes onto your object.

The Brushes palette appears.

Opacity  ——]95%
Advance [f——— 0%
Hardness [fF—— 0%
Flatness [f———— 0%
Angle  [——— 07

Use the Brushes palette controls to set the
size and Opacity of your 3D Paintbrush.

e Set the Size value to 99.

Q If the palette is not extended, click the
Extend icon to extend the palette.

£

Use the extend icon to view more 3D
Paintbrush controls.

Q Set the following:
Opacity to 95%
Advance to 0%
Hardness to 0%
Angle to 0 degrees.

GChooseUiew menu» Preset
Position» Right.

Q Drag the brush over the top and bottom
edges of the fish.

The brush you created will fade fish’s stripes
when you paint over them.

eChooseUiew menu» Preset
Position» Left.



Q Paint over the edges of the fish on this
side as well. You don’t have to worry
about matching to the two sides as the
fade will look more natural the more
uneven your strokes.

Use the 3D Paintbrush to fade the other side
of the fish as well.

@ Choose View menu» Reference.

When you’re done painting on the fish,
switch to Reference view to the see the
results of your changes.

The fish is now complete. If you want to see
the rendered shader use the Render
Preview tool or skip ahead to “Rendering”
on page 92.

Moving On

The lessons in this section covered most of
the basics of working with Shaders, but
that doesn’t mean that’s all there is to
learn. Shaders can give you an almost
infinite variety of textures and colors.
There are many more complex ways of
creating shaders. Refer to “Creating
Shaders” on page 197 for details on all the
features you can use to create complex
shaders.

As with modeling objects, a good way to
learn more about shaders is to take a look
at how other shaders are made. Try
opening some of the pre-made Shaders in
the Current Shader Editor.

The next section of the tutorial will lead
you through the process of adding lights to
your scene.

Setting up Lights
COro OG- OG-0-0-0

The final appearance of your scene
depends greatly on how you light it. In fact,
many of the effects you applied to objects
using shaders can only be seen if the they
are lit properly. For example, you can’t see
the shininess of an object’s surface unless
you shine a light onto it.

In Ray Dream Studio, you can apply the
same lighting techniques used in real
photography. By adjusting the position and
attributes of lights you can produce a large
number of different scenes using the same
set of objects.

The lessons in this section will take you
through adding lights using the Browser
palette and position them using the Direct
Manipulation controls.

The Story So Far

This tutorial has lead you through the
steps necessary to create, arrange and
shade objects. If you're unclear on any of
these concepts refer to earlier sections of
this tutorial or see the relevant chapters.

What You’ll need

To see the affects of the lights you’ll need a
scene. You can use the scene you arranged
in the first section of the tutorial, or use the
file LIGHT_TUTOR 1.
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To begin setting up lights:
d Open the scene file Tutorial: Setting Up
Lights: LIGHT_TUTOR _1 on the Ray
Dream Studio 5 CD-ROM.

€] Click the Lights tab.

eChoose Browser palette: File
menu» Add Directory/Folder.

Q Locate Tutorial: Setting Up Lights folder
and click Select Current Directory.

Like shaders, some of the lighting effects
cannot be seen until you render your
scene. Ray Dream Studio offers you two
tools for see light effects without having to
render your scene: Shaded Preview Mode,
and the Render Area tool.
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To switch to Shaded Preview mode:

Click the Shaded Preview button.

|

Use the Shaded Preview button to see the
effects of lights on your objects.

Shaded Preview slows the redraw time
dramatically so its a good idea to work in
Preview mode while you’re setting up lights
and then switch to Shaded Preview only
when you're finished.
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The Render Area tool lets you check your
lighting by rendering a small area of your
scene.
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To render an area of a scene:

q Choose the Render Area tool.

Use the Render Area tool to render areas of
your scene.

a Drag the tool over the area you want to
render.

Lesson 1: Adding Lights

There are two different types of lights you
can add to your scene: ambient and
specific. Ambient light acts like daylight. It
has no origin and doesn’t cast shadows.
Specific lights like, spot lights or bulb
lights, have an origin which can be
positioned in your scene.

When deciding how many lights to add, you
should consider the contents of your scene
and your systems memory limitations. The
more lights you add, the longer the
rendering time.

In most cases you can adequately light
your scene using only three specific lights.
One light in front of the object to illuminate
the scene (Key Light), one behind the

scene to highlight object outlines (Back
Light) and one to create shadows (Fill
Light).

Back Light

This basic lighting setup can be used to
effectively light most scenes.

In Ray Dream Studio this basic setup can be
created using a Spot light as a Key Light,
Distance light as a Back Light and Ambient
light as a Fill Light.

Ambient light settings depend on the
environment you want to create. For an
underwater scene, the ambient light should
be set fairly low to create murky
atmosphere.
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To set ambient light:
QChoose Windows menu» Scene
Settings. The Scene Settings dialog
appears.



€] Click the Effects tab.
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Use the Effects tab of Render Effects palette
to set the color and brightness of your
ambient light.

e Display the Ambient Light controls.

Q Click the color chip and choose a dark
blue color from the palette.

Q Set Brightness to 30%.
6 Close the palette.

Now that you've set the ambient light you
can add specific lights to the scene. You
can begin by adding a bulb light.
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To add a light:
q Drag the Create Light tool into the Time
Line window.
| &
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Drag the Create Light tool into the
Perspective window to create a new light.

a Choose Windows menu» Properties.

The Properties palette appears.
e Click Auto.

Q Choose Bulb Light from the pop-up.

Propeties: [Ligh]
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IV Shadows: —— ooz
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Use the Light tab of Properties dialog to
choose a light type and color.

e Disable the Shadows checkbox to save
on rendering time.

Q Click the Direct Manipulations button.

]

Use the Direct Manipulations button to
display the light’s control handles.

Two points appear on the bulb light
(called control handles) in the
Perspective window. You can adjust the
light’s properties by dragging its control
handles.

o
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Use the light’s Direct Manipulation controls
to set its properties in the Perspective
window.
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Q Click the control handle that extends
from the light and drag it away from the
light. This adjusts the Brightness value in
the Properties palette.

A

As you drag the Bulb brightness control, the
Brightness value in the Properties palette
changes.

You can use the Direct Manipulation
controls to adjust the properties any type
of light. Spot lights have many more control
points than bulb lights. For more details on
interactive controls, refer to “Controlling a
Spot Light Directly” on page 277.

You can also add lights by dragging them
out of the Browser palette.
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To add lights from the Browser palette:

QChoose Browser palette: Lights tab.

jects |Q Lighlsllﬁl Ca

Click the Light tab on the Browser palette to
view any saved lights.

a Drag the light labeled Light Tutor to
Time Line window.

Your new lights appear at preset positions.
You now have all the lights you’ll need to
create a good lighting effect, but you still
need to properly position the lights.

Lesson 2: Positioning Lights
There are several ways of positioning
lights. Like other objects you can position
lights numerically or manually. As well, you
can also assign special behaviors to lights
which will automatically position them.
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To position lights using Transform
controls:

d Click the Bulb light in the Time Line
window.

a Choose Windows menu» Properties.
The Properties palette appears.

e Click the Transform tab.

Q Set Position values to X=0, Y=65, and
Z=80.

e Click Apply.

The light moves to the upper left corner of
the Working Box.
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You can enter values in the Properties
palette’s Transform tab to numerically
reposition the bulb light.

The remaining light can be positioned
easily by applying the Point At behavior.
The Point At behavior forces the light to
always point at the object no matter what
position it is in. Wherever you move the
object, the lights will follow.

A e A e
To add the Point At behavior to a light:

q In the Time Line window, click the light
labeled Key light.

a Choose Windows menu» Properties if
the Properties palette is not already
visible.



Q Click the Behaviors tab.
Q Click the Add Component button.

sl

Click the Add Component button to see a list
of available components.

e Choose Point At from the list and
click OK.
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Use the Behaviors tab to add or delete
behaviors for an object.

G Type the name Conch Shell in the Point
At box.

This forces the light to point at the
Conch at all times.

a Make sure the Enabled checkbox is
checked.

@ Click Apply.

Q To see the results of the pointed light,
enable the Shaded Preview button.

In Shaded Preview you can see the results of
your light settings.

Now that your lights are all in the correct
position you can refine individual light
properties to create special effects.

Lesson 3: Lighting Effects

Just like in a real studio, a light doesn’t
have to be just a simple spot light. You can
adjust the light’s properties to create
subtle effects, or you can add gels to lights
to create a special lighting effect.

Gels are images that act as transparency
masks when you place them in front of a
light.

B e e e T
To add a gel:

d Click the light labeled Key light in the
Time Line window.

a Choose Windows menu» Properties.
The Properties palette appears.

€ Click the Gel tab.
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EE Generall Transfurml Light | Gel | Link |

e

v Tile
Harizontally

times

—&
Wertically
—& times

300x300 |
™ Seamlsssly - h)\‘ls pitels

¥ Better [but slower] sampling I Invert color

Brightriess: ——hox

T Aad_Apply [ Restoela] | oy

Use the Gel tab in the Properties palette to
load image maps as gels.

Q Choose Map from the pop-up.
e Click the disk icon and choose Open.
G Locate the file: Tutorial: Setting Up

Lights: WATER on the Ray Dream
Studio 5 CD-ROM and click Open.

@ Click Apply.
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Your lighting setup is now complete. If you
want to see the lighting effect, drag the
Render Preview tool over the entire scene.

When you render your image you can see the
effects the gel on your objects.

Moving On

The lighting setup can be quickly adapted
to any scene by just changing the Point At
object.

Many other lighting setups are available
through the Scene Wizard. The Scene
Wizard will lead you through he process of
creating a lighting setup by answering a few
questions. For more on the Scene Wizard,
refer “Using the Scene Wizard” on page 27.

The next section of the tutorial will show
you how to set up cameras.
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Setting up Cameras
COro OG- OO-0-0-0

Just like in a real photo studio, the
appearance of your scene can vary
depending on where you view it from. That
is why you strategically place cameras at
specific positions. Since all your objects in
Ray Dream Studio exist in a 3D space, you
can position cameras to view your scene
from any angle.

When you’re rendering an image or
animation, the view you see through a
camera is used to produce the final image.

The lessons in this section will teach you
how to add cameras using the Browser
palette and position them using the Direct
Manipulation controls.

The Story so Far

You've learned how to create, arrange,
shade and light objects in your scene. Since
lighting can be essential to deciding where
you place cameras, you should be familiar
with lighting concepts and procedures.

For more information, refer to “Lesson 1:
Adding Lights” on page 68, or“Setting
Lights” on page 271.

What You’ll Need

To get a feel for how different camera
perspectives can be used in a scene, you'll
need a sample scene.

A A e A e e
To begin setting up cameras:

d Open the file Tutorial: Setting Up
Cameras: CAMERA TUTOR on the Ray
Dream Studio 5 CD-ROM.

You can also use the scene you arranged
in the first section of the tutorial.

a Choose Browser palette: Cameras
tab.

eChoose Browser palette: File menu»
Add Directory/folder.

Q Locate the Tutorial: Setting Up Cameras
folder and click Select Current
Directory.

Lesson 1: Adding Cameras

By default, your scene already has one
camera. The preset positions available
from the View menu are based on the
default camera. You can add other cameras
to view your scene from different
perspectives. You can also add cameras to
save commonly used camera angles.

The simplest way of adding a camera is to
drag one out of the Browser palette.

B = e g e S e
To add cameras from the Browser
palette:

d If the Browser palette is not visible,
choose Windows menu» Browser.



a Choose the Cameras tab.

File Yiew 1 file
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The Camera tab in the Browser palette
contains sets of camera settings.

Q Drag the Camera Set camera from the
Browser palette into the Time Line
window.

The new camera appears at its preset
position.

You can also create new cameras and
customize their attributes.

e i e S el el i
To add cameras using the Create
Camera tool:

q Choose the Create Camera tool and drag

it into the Time Line window.

Drag the Create Camera tool into the Time

Line window to add a new camera to your
scene.

A new camera appears at the origin. By
default, the camera is named Camera 2.

aChoose Windows menu» Properties.
The Properties palette appears.

e Click the Camera tab.

" Wwide [24mm]
% Mormal [S0mm]
™ Telephoto [200mm)

" Zoom (F——— 5[

Use the Camera tab in the Properties palette
to set camera type and zoom level.

Q Choose Conical from the pop-up.

e Enable the Normal radio button.

Q Enable the Auto box.

a Click the Direct Manipulation button.

o

Use the Direct Manipulation button to display
the camera’s control handles.

The camera’s control handles appear in
the Perspective window. You can set the
camera’s attributes by dragging these
control handles.

The control handle that extends in front
of the camera controls the viewpoint, the
control that extends behind it controls

the position of the camera in the scene.
The triangle that extends out in front of
the camera controls the zoom level.

Use the camera’s direct manipulation
controls to adjust its attributes in the
Perspective window.

Q Drag the zoom controls (the triangle

extending in front of the camera)
towards the camera.

Chapter5 < Tutorial 73



Your new camera setup is complete.

If you find it difficult to move the zoom When you release the mouse button, the
control, try adjusting the zoom control camera changes position.
on one of he camera’s projections. Lesson 2: Viewing your Scene
i from Different Cameras
] —' 1 Now that you have more than one camera
you can choose which camera you want to

¥ f e use to view your scene.
" :
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To switch between cameras:

QChoose Windows menu» Camera
Properties. The Camera Properties

palette appears.

I
|
T o
Drag the camera position control handle to
move the camera to a new position. =
L erties (|
+ [ T-'r'pe:lﬁonical vl ﬂ
 Wide [24mm)

FELLR
LJL |
._\__. & ...-_.-';. '\.::&
o o @ On the right plane, click the control
handle that extends out in front of the Eamets: [Camera 1 | (‘: Nomal (50mm)
. L Telephota [200mm)
camera and drag it over the center of the Eosmon- [Freference 1| & Zoom — 0

Drag the camera’s zoom controls to adjust
Use the Camera Properties palette to switch

scene.

The camera is now pointing at the center between cameras.

the zoom level.

When you release the mouse button, the
zoom value in the Properties palette
of the scene.

should read about 45.

a Choose Camera 2 from the Camera
pop-up.

Q Drag the control handle that extends
from behind the camera to front of the

workspace.

Drag the viewpoint control out to the object
you want the camera to point at.
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The view of the scene changes.

A
When you change the camera in the Camera
Properties palette the view of your scene
changes.

e Choose Reference from the Position
pop-up. The view changes to the
Reference view for Camera 2.

q Choose Camera 1 from the Camera
pop-up. The view changes to the
Reference view from the default camera.

You can use the Camera Properties
palette to switch between different
cameras and to save your most
commonly used positions. For more on
cameras, refer to “Setting up Cameras”
on page 72.

Now that you've added some cameras you
need to position them to get the best views
of your scene.

Lesson 3: Positioning Cameras

There are several ways of positioning
cameras in Ray Dream Studio besides using
the Direct Manipulation controls. You can
send the camera to a specific position
using the transform commands, or using
the Camera Dolly, Camera Pan, or Camera
Track tools.

e s el e =
To numerically position a camera:

q Select Camera Set in the Time Line
window.

aChoose Properties palette:
Transform tab. If the Properties
palette is not visible, choose Windows
menu» Properties.

e In the Position Controls enter X=23, Y=50
and Z=40.

Position

: |
Center [2300 ZFH[s000 Ef40m0 H—
& 2 r

HotPoint|23.00 & |s000  &]40.00 §|—'|

Use the Position controls in the Properties
palette to numerically position cameras.

q Click Apply.
The camera moves to a new position.

You can also use the camera tools to
position your cameras.

B e e e T
To position a camera manually:

q Choose Windows menu» Camera
Properties. The Camera Properties
palette appears.

a Choose Cameras menu» Camera
Tutor.

e Choose Position menu» Reference.

q Click the Shell object in the Perspective
window.

Q Choose the Dolly tool from the toolbar.

Use the Dolly tool to interactively adjust the
position of the camera.
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The production frame appears and the
pointer changes to a camera. The
production frame defines the area of
your scene that appears in the final
artwork when you render the scene.

The production frame defines the area of
your scene that is used to produce a rendered
image or animation.

Q Drag the pointer down and to the left.
The view of the scene rotates around the
selected object.

You can also use the other Camera tools to
adjust the position. The production frame
for each camera can also be adjusted
separately.

A AT U
To adjust the Production Frame:

q Select the Camera Tutor camera in the
Perspective window.
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aChoose View menu» Production
Frame. A green frame appears around
your scene.

e Shift-drag one of the points on the
production frame towards the center.
The frame shrinks proportionately.

If you drag a point without holding down
the Shift key, a dialog appears warning
you that you’re about to change the
frame’s aspect ratio.

A A e A N
To move the production frame:

Click the production frame and drag it to a
new location.

Your camera setup is now complete. Using
the cameras you set up in this lesson you
can produce a number of different 3D
illustrations using the same scene. If you
want to see how your scene will look
rendered from a particular angle, drag the
Render Preview tool over the scene.

Use the Render Preview tool to see how your
scene will look when it's rendered.

Moving On

The cameras you created in this section
can be used in a wide variety of scenes. If
you like the custom camera you created,
save it in the Browser palette. Refer to

“Using the Browser Palette” on page 28 for
instructions on saving to the Browser
palette.

Ray Dream Studio comes with a number of
preset cameras which can be accessed
through the Scene Wizard. The Scene
Wizard will set up cameras and lighting
based on your answers to a few questions.
For more information, refer to “Using the
Scene Wizard” on page 27.

The next section of the tutorial will lead
you through the process of animating the
objects in your scene.

Animating Objects
OG- OO-0-0-0

Ray Dream Studio uses a process known as
key frame animation to animate objects. In
this process, each point in time where an
action begins, ends or changes is know as a
key frame. All the frames in between the
key frames, or action, are filled in Ray
Dream Studio.

For example, if you wanted to animate a
bouncing ball, you would set up a key
frame showing the ball in its starting
position, a frame showing it bouncing off
the ground and a frame showing its final
position. When the animation is rendered,
Ray Dream Studio creates all the frames in
between, showing the ball moving towards
the floor and then away from the floor.



The lessons in this section will show you
how to create key frames and apply
Tweeners and Behaviors to them to create
simple animations.

The Story So Far

In this tutorial you've learned how to
create, arrange, and light objects and how
to add cameras. In the next section you'll
learn how to animate objects. Before you
can animate an object you should know
how to create one. For more information on
modeling, refer to “Free Form Modeling” on
page 109 and “Mesh Form Modeling” on
page 137. Key frame animation relies
heavily on changes in position and angle so
it's essential that you also understand how
to position objects. For more information,
refer to “Arranging Objects in the Scene” on
page 39 or “Arranging Objects” on

page 223.

What You’ll Need

In order to animate objects, you'll need a
few sample objects. Since animation takes
up a large amount of memory, it is
recommended that you use only a few
objects in you scene.The file ANIMATE
TUTOR in the Tutorial folder on the CD-
ROM has been designed especially for this
animation section.

A e S e e
To begin animating objects:
q Open the file Tutorial:Animating

Objects: ANIMATE TUTOR on the Ray
Dream Studio CD-ROM.

aChoose Browser palette: Objects tab.

eChoose Browser palette: File menu»
Add Directory/Folder.

Q Locate the folder Tutorial: Animating
Objects and choose Select Current
Directory.

The first step in any animation is to set the
its time limit.

B TR e S e
To set animation time limit:
q Make sure the Time Line window is

visible. If it’s not, choose Windows
menu» Time Line of HAnimate

Tutor.

Your animation will now last for three
seconds.

When you’re animating, you’ll probably
need to quickly move between frames. Ray
Dream Studio’s Time Controller tools let
you jump from the beginning of an
animation, to the end, or anywhere in
between.

A AT U
To display the Time Controller:

q Choose Diew menu» Toolbars. The
Toolbars dialog appears.

a Enable Time Controller. A toolbar is
visible when a checkmark appears next
its name.
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The Time Line window displays all the key
event markers in the animation and its
current length.

a Click the Time Axis at 00:02:00 and drag
it to 00:03:00.
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Drag the end of the Time Axis to 00:03:00 to
extend the length of your animation.

The Time Controller toolbar contains all the
tools you’ll need to preview your animation
in the Perspective window.

Lesson 1: Creating Key Frames

In key frame animation you need to create a
key frame anywhere you want action to
start, stop or change. In this lesson you'll
be creating a simple animation with only
one action so you’ll only need to create two
key frames one to tell Ray Dream Studio
where you want the action to begin and
another to define where you want the
action to stop.
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To create a key frame:

d Make sure you’re at the first frame of
your animation. If you’re not, click the
First Frame button.

™

Click the First Frame button to jump to the
first frame in your animation.

By default, Ray Dream Studio creates key
frames for all the objects in the scene at
the start of the time line. So, you already
have the starting key frame of your
animation. All you have to do now is
create a key frame for the end of the
animation.

o

By default Ray Dream Studio creates the first
key frame in your animation when you open
a scene.
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a Click the Last Frame button on the Time
Controller.

44

Click the Last Frame button to jump to the
last frame in your animation.

The Current Time indicator jumps to the
end of the animation.

Q Click the Angel Fish object in the Time
Line window.

Q Click Command-T/Ctrl+T to display the
Object Properties palette.

e Click the Transform tab.
G Enter the Position values X=34, Y=-16,

Z=20 and Yaw= 45, Pitch=-5 and Roll=-5
click Apply.

w
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When you adjust the position of objects, Ray
Dream Studio creates a new key frame.

Q Click the First Frame button.

Q Click the Perspective window to make it
the active window.

Q Click the Interactivity button. This
button should be active whenever you
preview animations in the Perspective
window.

9

When the Interactivity button is active you
can see your objects moving between key
frames.

@ Click the Play button to preview your
animation.

1

Click the Play button to run your animation.

The fish appear to move towards the
shell.

Lesson 2: Applying Tweeners

In the animation you created in Lesson 1
you probably noticed how quickly the fish
approached the shell. In reality, the fish
would probably slow down as it gets closer
to the shell. This type of behavior can be
controlled using Tweeners. A tweener lets
you control how Ray Dream Studio fills in
the transitions between key frames.



If you apply a Bézier tweener to the Angel
fish, the fish will slow down as it
approaches the shell.

B = L e S e e
To apply a Tweener:
q In the Time Line window, double-click
the time track between the first and last
key frames for the Angel Fish object.

The tweener icon appears in the space
between frames when you apply a tweener to
your animation.

The Transition Options dialog appears

e Choose Bézier from the pop-up.

Transition Dptions

time
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Use the Transitions Options dialog to select a
Tweener type and set its attributes.

The Bézier tweener lets you control the
acceleration of an object and its
trajectory. For more on tweeners, refer
to “Using Tweeners” on page 309.

Q Set the Ease-in /out values to 40% and
40%.

These values control the speed of the
object.

Q Set the Tighten-in /out values to 50% and
50%.

These values control the trajectory of
the object.

e Click the First Frame button then click
Play to preview the new animation.

The fish now appears to slow down as it
approaches the Conch shell. If you're
happy with this animation, save it to a
convenient location.

Lesson 3: Applying Behaviors
Using a combination of key frames and
tweeners you can create some very
realistic looking animations. However, by
applying Behaviors to objects you can
create realistic animations that would be
very complicated to create using only key
frames.

A behavior gives an object a specific set of

instructions that determine or modify their

actions during an animation.

In this lesson you'll apply a special set of
behaviors called physically-based
behaviors.

Physically-based behaviors let you set up a
simulation of real world physical action like
gravity or velocity.

To set up a simulation you must first define
which objects are to be included in the
simulation and then apply some kind of
force to move those objects.

For example, to simulate a collision, you
would create two physical objects, then
apply directional force to one of them.
When rendered, one object would appear
to crash into another and then rebound
off it.

In this lesson you’ll apply the Flow Force
behavior to a school of fish and then watch
as they swim away in every direction
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To apply physically-based behaviors:
d Drag the Mesh Form Fish object out of

the Browser palette and into the

Perspective window.

This is what the Mesh Form Fish looks like in
the Perspective window

a Choose Windows menu» Properties.
The Properties palette appears.

e Enable the Auto checkbox.
When Auto is enabled, any change you

make to the behavior’s values are
automatically applied to the object.
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Q Click the Behaviors tab. If the tab is not
visible, click the arrow buttons to scroll
the tabs.

Propertie

EEI Behaviurs\Mapping Iade
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Use the scroll buttons to view Properties tabs
that are not visible.

e Click the Add button. The Add dialog
appears.

h|

Use the Add button to display a list of
available behaviors.

Q Select Apply Physical Effects and
click OK.
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When you select a behavior from the
Properties palette’s Behaviors tab, controls
for that behavior are displayed.

Apply Physical Effects is the base
behavior for all physical simulation. you
must apply this behavior to any object
you want to be included in the
simulation.

Once the behavior is applied, the other
objects in the simulation will interact
with it as if it were a real object.

Q Enable the Movable by impact checkbox.

Q Click the Add button again.



Q Choose Flow Force from the list and click
OK. The Flow Force controls are added
to the Behaviors tab.

Flow Force simulates the force of water
currents on an object.

@ Set the Turn Density to 70%.
@ Enable the Rotate with flow checkbox.

The behavior setup is now complete. If you
ran the simulation at this point the little
fish would appear to swim through the
scene towards the camera. However, you
can create a much more interesting effect
by creating an entire school of fish.
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To duplicate objects:

q Select the School Fish in the Perspective
window and press Command-D/Ctrl+D.

a Drag School Fish up and to the left.

Q Press Command-D/Ctrl+D again. A new
fish appears.

You may need to move the fish around to
get the right positions for the school.

Q Continue duplicating and repositioning
the fish until you have enough to look
like a school.

As you duplicate fish, each duplicate will
have the same behaviors applied to it.

In order to see the full affect of the
behaviors in your scene, you'll need to
activate Interactivity and extend the time
limit of the animation.
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To preview behaviors:

q Click the Interactivity button.

When the Interactivity button is active you

can see your objects move during the
animation.

a In the Time Line window, drag the end of
the animation in the Time Axis from
00:03:00 to 00:10:00.

e Click the First Frame button and then
click Play. Make sure the Interactivity
button is enabled.

The school of fish appears to break apart
an swim away in all directions.

If your not happy with the speed of the
action, you can use the techniques you
learned in the previous lesson to apply
Tweeners to the fish.

If you get an animation you’re satisfied
with, save it to a convenient location.

Moving On

The animations you created in this section
are just the beginning. Try experimenting
with different objects to create key frames
or apply different tweener settings.

The Physically-based behaviors you added
in this section are one example of the kinds
of simulations you can create. These new
behaviors open up a whole new world of
possibilities in animation. Experimenting
with different simulations can produce
some astounding results. For a full
descriptions of the Behaviors available in
Ray Dream Studio, refer to “Behaviors” on
page 314.

The next section of the tutorial will lead
you through the process of animating
objects by altering their shape.
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When you play the animation, Ray Dream
Studio plays the physically-based simulation.

82 Ray Dream Studio User Guide

Animating Shapes
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In Ray Dream Studio there are several ways
of animating objects. The previous section
showed you how to animate objects by
changing their position. You can also
animate objects by altering their shape
using either the Free Form or Mesh Form
modelers or by applying a Deformer.

In this section you'll alter the shape of
several objects across several key frames
to produce moving objects.

The Story So Far

In this tutorial you've learned how to
create, arrange, light and animate objects
in a scene. Since you'll be using the object
modelers and deformers to alter object
shapes in this section it is essential that
you understand the concepts involved in
modeling objects. It would be a good idea
to review the “Modeling Objects” on

page 47 before beginning this section.

What You’ll Need

This section of the tutorial deals with
altering object shapes so you’ll need some
shapes to start with. If you’ve been
following the tutorial, you can use the
objects you created in the Modeling
Objects section, or you can use the
Animating Shapes folder in the Browser
palette. This folder contains the models
used as examples in this section.
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To begin animating shapes:
d Make sure the Browser palette is visible.
If it’s not, choose Windows menu»
Browser.

Q Click the Objects tab.

eChoose Browser palette: File menu»
Add Directory/Folder.

Q Locate the folder Tutorial: Animating
Shapes and click Select Current
Directory.

Lesson 1: Animating the
Extrusion Path

You can animate the shape of a Free Form
object by altering the shape of its sweep
path in different key frames.
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To animate an object using the sweep
path:

q Drag the Seaweed object from the
Browser palette into the Perspective
window.

a Click the Last Frame button.

(|

Click the Last Frame button to jump to the
last frame in your animation.



Q Double-click the seaweed in the
Perspective window to open the Free
Form modeler.

Q Select the Zoom tool and zoom in on the
sweep path on the ground plane.

The sweep path looks like this at the
beginning of your animation.

Q Choose the Selection tool.

@ Click the second point on the sweep path
and drag it to the right as shown.

Make sure that you’re not selecting a
point on the extrusion envelope (blue
lines).

N

This is what you sweep path should look like
after you reposition the second point.

a Click the third point and drag it to the
opposite side of the sweep path.

Your sweep path should look like this after
you reposition the third point.

G Click the fourth point and repeat step 7.

‘ e \
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T
When you’re done repositioning the fourth
point, your sweep path should look like the
one shown.

QChooseUiew menu» Preset
Position» Left.
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@ Zoom in on the horizontal sweep path.

@ Click on the second point on the sweep
path and drag it up.

S

T
This is what you sweep path should look like
after you reposition the second point.

@ Click the third point and drag it down.

)

Your sweep path should look like this after
you reposition the third point.
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@ Click the fourth point and drag it up.

When you’re done repositioning the fourth
point, your sweep path should look like this.

When you play this animation the
seaweed will appear to sway, but the
motion will be somewhat stiff. To smooth
out the motion, you can apply the
Oscillate tweener.
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To apply the Oscillate tweener:

d Double-click between the first and last
frame of the Seaweed object in the
TimeLine window. The Transition
Options dialog appears.

¥ Time Line of Doc3
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Double-click the space between frames to
display the Transition Options dialog.

a Choose Oscillate from the Tweener
pop-up.

Transition Dptions

time:

3
Hbr Dscillation

——{100%

" Saw/Loop
" Triangular Damping
" Bounce

—————— 0%

Up phase

The controls available in the Transition
Options dialog change depending on the
tweener you select.



Q Set the Nbr Oscillation slider to 2 and
click OK.

Q Click the First Frame button on the Time
Controller.

144

Click the First Frame button to jump to the
first frame in your animation.

If the Time Controller is not displayed,
choose View menu» Toolbars and
then enable Time Controller.

g click Play.

The seaweed appears to sway in the
current.

1 2

When you run your animation, the seaweed
will appear to sway.

If you're satisfied with this animation, save
it to a folder on your hard drive.

Lesson 2: Animating the Mesh
Form Modeler

You can animate an object’s shape in the
Mesh Form modeler the same way you
would in the Free From modeler, by
altering the object’s shape over several key
frames.
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To animate an object by repositioning its

vertices:

q Make sure the Objects tab is selected on
the Browser palette, and drag the Mesh
Form Fish from the Browser palette to
the Perspective window.

a Click the First Frame button. If the
button is not available, you're already on
the first frame.

™

Click the First Frame button to jump to the
first frame of your animation.

e Double-click the fish to open the Mesh
Form modeler.

q Choose the Zoom tool.

Q

Use the Zoom tool to enlarge an area of your
scene.

Chapter5 e Tutorial 85



G Zoom in on the fish’s tail. @ Enable Spiky.

@ Set the Radius of Sphere to 30.

@ Click the center point of the three
selected points and drag it to the left.

Use the Marquee tool to select the points

Use the Zoom tool to zoom in on the back shown.
d of the Mesh F Fish’s tail

end ot fhe fesh Form FIshs fat Q Choose the Sphere of Attraction tool.
Choose the Marquee tool.

e q QChoose Windows menu» Properties

and then click the Tool Options tab in the : =
Select the center point in the tail and drag it

r=A
U1 Properties palette.
U = he M | | " to the left.
Set.t e arquee tool to select a grouD 0 HF] Mumerical ~ Tool Options . Action Modifiers ™.
Vertices. Szl Aesen e @ Click the Last Frame button.
@ Select the rear of the tail. ‘ ‘
 Cubic Spline © Linear
& Spiky " Bumpy

Radius of Sphere: 3000 =in =|

Attraction mod
’7: tove selection, attract other vertices

 Altract only selected vertices

Use the Sphere of Attraction tool options to
set the tool’s size and shape attributes.
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@ Drag the center point to the right.

N\

Select the same center point again and drag
it to the right

When you play this animation the tail of
your fish will appear to swing from left to
right. However, the movement will
appear somewhat rigid. To smooth out
the motion you can apply an Oscillate
tweener.

G In the Time Line window, double-click
the time line between the first and last
frames of the Mesh Form Fish and apply
the Oscillate tweener.

For more detailed instructions on
applying the Oscillate tweener, refer to
“To apply the Oscillate tweener:” on
page 84.

@ Click Done.

Q Click the First Frame button on the Time
Controller and then click Play.

™

Click the First Frame button to jump to the
first frame of your animation.

If the Time Controller is not displayed,
choose View menu» Toolbars and
then enable Time Controller.

Your fish now appears to swim. To

create a school of fish, duplicate the
Mesh Form Fish object.

2
h ' i -
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When you run the animation, the fish’s tail

appears to move from left to right.

If you’re happy with the animation as it is,
save it to your hard drive.

Lesson 3: Animating Deformers

Deformers you applied to objects to alter
their shape can also be animated. By
adjusting the parameters of the Deformer
in different key frames, you can have the
objects appear to change over time. In this
lesson you'll learn another way of making
your fish swim--by animating the Wave
deformer.

e i e Sl el el i

To animate a deformer:

d Make sure you’re on the first key frame
of your animation. If you’re not sure,
click the First Frame button on the Time
Controller.

144

Click the First Frame button to jump to the
first frame of your animation.

If the button is grayed out, you’'re already
on the first frame.

a Drag the Mesh Form Fish object from the
Browser palette into the Perspective

window.

eChoose Windows menu» Properties.
The Properties palette appears.

q Click the Deformer tab.
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The Wave deformer controls appear. If
you want to learn how the Wave
deformer was applied to the object refer
to “Lesson 4: Deformers” on page 60.

General | Transfom | Deformers|

=]
= Twave | 7ﬂ

Bhase

e 113 551
Humber of Wave Cycles

e — 10
Height of waves
: e

- Shape o ;
 |Planara - : s
Onentaton o
|z =|!

Use the Wave deformer controls to control
the phase and shape of the wave applied to
your object.

e Enable the Auto checkbox.
G Make sure the Phase slider is set to 0%
a Click the Last Frame button. The current

time indicator jumps to the last key
frame.

HH

Click the Last Frame button to jump to the
last frame of your animation.

Q Set the Phase slider to 100%
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Q Click the First Frame button and then
click Play to preview you animation.
Make sure the Interactivity button is
enabled.

The little fish appear to swim. You can
now duplicate the fish to create a school
of swimming fish.

e e e e e
To duplicate the deformed fish:

q Click the First Frame button.

€] Click the Mesh Form Fish in the
Perspective window.

e Press Command-D/Ctrl+D to duplicate
the fish.

Q Drag the Mesh Form Fish up and to the
left.

@ Click the duplicate fish and press
Command-D/Ctrl+D again.

G Continue moving and duplicating fish
until you have a good sized school.

When you duplicate the fish, each duplicate

will have the Deformer applied to it.

Q Click the First Frame button and then
click Play to preview your animation.

The school of fish appears to swim.
"wn N
S N
3 ‘h‘ 4
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When you run the animation the fish appear
to all be swimming in the same direction.




Moving On

The techniques you just learned can be
combined with tweeners to fine tune the
animation.

You may want to try these animation
techniques with some of the more complex
objects in the Browser palette. You'll
quickly find out how easy it is to create
some very complex effects by just
adjusting a few parameters.

The techniques you learned in this tutorial
are just a few of the ways you can use the
modelers in animations. For more
information, refer to “Free Form Modeler”
on page 328 and “Mesh Form Modeler” on
page 329.

The next section of the tutorial will show
you how to add special effects to your
animations.

Animating Effects
COro OG- OO-0-0-0

After you've created the main action of
your animation you may feel that
something is still missing. Perhaps your
environment needs a little added realism,
or do you want your object to change
color? Using key frame animation, you can
animate almost any object parameter to
create subtle effects to enhance your
animations.

In this section you’ll learn how to add
Rotoscoping to your animations and how
to animate Shader settings.

The Story So Far

You've learned how to create, shade, light
and animate objects. In this lesson you’ll be
animating Shaders and adding Rotoscoping
to lights, so you should be familiar with
shading and lighting concepts. You may
want to review “Shading Objects” on

page 62 and “Setting up Lights” on page 67,
or refer to “Applying Shaders” on page 181
and “Setting Lights & Cameras” on page 269
for a detailed explanation of these
concepts.

What You’ll Need

To create the effects shown in this section,
you’ll need some lights and a shader. The
file ANI_EFF has all the models and lights
you’ll ned to complete the lessons in this
section.

B e e e T
To begin animating effects:

d Locate the Tutorial: Animating Effects
folder and open the file ROTOSCOPING
TUTORIAL.

aChoose Browser palette: Shaders
tab.

eChoose Browser palette: File
menu» Add Directory/Folder.

q Locate the folder Tutorial: Animating
Effects and click Select Current
Directory.

Lesson 1: Rotoscoping

Rotoscoping lets you add a movie to your
animation. You can use movies as animated
textures on your objects or apply them to
lights as gels.

R e e e e e
To apply rotoscoping to a light:

q Click the Key Light in the Time Line
window to select it.

Q Click the First Frame button to move to
the first key frame in your animation.

e If necessary choose Windows menu»
Properties to display the light’s
properties.

@ Click the Gel tab.
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Q Enable the Auto button.

6 Choose Movie from the Gels pop-up.

[Light]

Prop: it
Mkl Lot | Gel | Link | Behaviors | Shadaws |

T e e 3

1 Tl

Harizartally :
r— 1 tirmes

Wertically: .
— 1 limes

= | Seamlessly

= | Betten (but elower sampling D*‘g E_‘“EIS

I= | [Fivert cols &

Brighthess:

—100%

™ Bud fpoly [ Fesoe]4] | o

Use the Movie controls in Properties palette
to load a movie as a gel.

@ Click the disk icon.

Q Use the dialog to locate the file
Tutorial:Animation:Effects:H20.MQOV or
H20.AVI and click Open.

When you add the movie, Ray Dream
Studio automatically creates a key frame
at the end point of the movie’s. Since the
movie is only 1.46 seconds long, a new

key frame appears at 1.46 in the time line.
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Q In the Time Line window drag the key
frame indicator from 00:01:46 to
00:02:00.

>
5126512 pixelz
24 bits

You can use the Movie controls to play the
movie you loaded.

@ In the Properties palette, enable Tile.

G Move the Horizontal slider to 3 times.

i

(] ][ 8] wee.
v Tile
Haorizontally -

3times
Wertically: :

[—3 bimes

[ Seamlessly
[+ Better [but slower) samplin
™ Irveett colar

Use the Tile Controls to tile the movie
3 times.

To view the rotoscoping effect you need
to preview the rendered animation.

AT A e A U =
To preview a rendered animation:
Choose Render menu» Best
Animation Preview.

Your scene now has a realistic underwater
look to it.

[ S =

When you render your animation in Best
Animation Preview you’ll be able to see the
effects of the movie as a gel.

Lesson 2: Animating Shaders

By adjusting shader parameters, you can
animate a change in color, or texture on the
surface of objects.

= L e
To animate a shader:

q Click the First Frame button to move to
the beginning of your animation.



a Drag the Shaded Fish from the Browser
palette to the Perspective window.

e Choose the Eyedropper tool.

Q Click the Shaded Fish in the Perspective
window. The Current Shader Editor
appears.

Current Shader Editor

<
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¥ Color ™ Highlight " Shininess " Bump ™.

Mix,
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tarble
Global Scale  ——F— 121%
Direction:
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Undulation ——— 86

ein Blending ————1- 33

When you click the fish with the Eyedropper
tool, its shader appears in the Current Shader
Editor.

e Click the Last Frame button to move to
the end of your animation.

@ In the Current Shader Editor, double-
click the left color chip.

Q Click the Color palette button.

-

Click the Color palette button to display your
system’s color picker.

Q Select a green color, then click OK.

Q Double-click the right color chip, then
click the Color palette button.

@ Choose a light gray color, then click OK.
@ Click Apply.

@Choose Render menu» Best
Animation Preview. to create a
preview of your animation.

The school of fish will appear to change
from silvery red to silvery green.

1 2
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When you play the preview of your
animation you can see the shader change
color over time.

Moving On

The animation effects you learned in this
section are only two of the many types of
effects you can add to your animation. By
changing the properties of objects across
different key frames you can create a wide
variety of effects. For example, you could
adjust an object’s size across key frames
and the object would appear to grow. For
more details on creating animation effects,
refer to Chapter 15, “Animating.”

The next section of the tutorial will show
you the fundamentals of rendering your
scenes and animations.
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Rendering
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Rendering is the process of creating a two-
dimensional image or movie from a three-
dimensional scene. The settings you
choose for your rendering can have a large
impact on the final appearance of your
image. Ray Dream Studio offers you several
different types of renders that you can use
to achieve different effects. For detailed
information on the different types of
renderers available, refer to “Renderers”
on page 342.

The lessons in this section will teach you
how to set up a rendering session for an
image and for an animation.

The Story so Far

The previous sections have shown you
how to create and arrange objects, how to
set up lights and camera, how to animate
objects and now finally you will learn how
to turn your scene into an image or an
animation. Before you begin this section
you should understand how to set up a
scene using the arranging features as well
as understanding how to set up cameras
and the production frame. You may want to
review “Setting up Cameras” on page 72 or
“Setting Lights & Cameras” on page 269.

What You’ll Need

The materials you need for this section
depend on how you’ve been using this
tutorial. If you have been following the
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tutorial from the beginning, you’ll need the
scene you arranged in “Arranging Objects
in the Scene” on page 39, the lighting setup
from “Setting up Lights” on page 67, and
the camera setup from “Setting up
Cameras” on page 72.

If you've skipped ahead to this section you
can complete the lessons using the preset
files provided.
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To open preset files for the rendering
lessons:

d Locate the folder Tutorial: Rendering
and open the file RENDERING

TUTORIAL.

aChoose Browser palette: Cameras
tab and add the folder Tutorial: Setting
Up Cameras.

e Choose Browser palette: Lights tab
and add the folder Tutorial: Setting Up
Lights.

Q Drag the objects Camera Tutor and Light
Tutor from the Browser to the
Perspective window.

Lesson 1: Rendering an Image
The first thing you need to do to set up a
rendering is to choose a renderer. A
renderer converts your scene into a bitmap
or movie.

In this lesson you’ll be using the RDI Ray
Tracer since it's one of the renderers that
handle reflections and refractions.
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To choose a renderer:
QChoose Render menu» Current
Scene Settings. The Scene Settings
palette appears.
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Use the Render Settings dialog to choose a
renderer and set its attributes.

a Click the Renderer tab.
e Choose RDI Ray Tracer from the pop-up.

Q Make sure that all the rendering options
are enabled.

If you want to speed up the rendering,
disable the options you won’t be using in
your scene. For example, since there are
no transparent objects in your scene,
you can disable the Light through
transparency option.



After you've selected a renderer, you
need to set the atmosphere for your
scene.
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To set the atmosphere:

dChoose Scene Settings palette:
Effects tab.

e Choose Distance Fog from the
Atmosphere pop-up.

Distance Fog makes objects appear to
fade the further they move away from

the camera.

e Click the plus/arrow icon next to the

Atmosphere title to display its controls.

Use the Plus icon to display more controls.

The Distance Fog controls appear.
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Fog Color

Fog starts 1200.00 in vl from wiewpoint
Wigibility 1200.00 in vl past start of fog

The Distance Fog controls let you set the
color and range of the fog.

Q Double-click the Fog Color chip.

Q Choose a light blue color and then
click OK.

G Enter Fog starts= 120
& Enter Visibility = 300

The Distance Fog will add realistic depth to
your image. If you want to add a more
detailed realism, you can add a background
to the scene. Now that your scene has an
environment, you can set the output file
options.
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To set Output options:

QChoose Scene Settings palette:
Output File tab.

a Click the plus/arrow icon next to Image
Size. The Image size options appear.

= Image Size

Width : lﬂm 300 pisels
Height : lﬂm 400 pinels

Regalution 7200 %: dpi 458K [~ Keep Proportions
1 %: hourID %: minutes

" Best Resolution
Estimate )
' Render Time

Render Time :

Use the Image Size options to set the height,

width and resolution of your rendered image.

€ Set Width=300 and Height=400.

d Set the Resolution to 72 dpi.

Q Click the plus/arrow icon next to
Camera. The Camera options appear.

= —Camera

Use the Camera options to select a camera to
use for your rendering.

Q Choose Render Camera from the
Rendering Camera pop-up.

d Click the File Format plus/arrow icon.
The Format options appear.

i=i—File F t
IEMF’[HD] VI Options...

&+ Current Frame
 Movie
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Use the File Format options to set the output
format for your rendered image.

Q Choose BMP (RD) from the pop-up.

Q Click the Save button to save your
rendering setup.

Your rendering setup is now complete.
Now you can use these saved settings to
render your scene.
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To start a rendering:

Choose Render menu» Use Current
Settings.
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Ray Dream Studio starts rendering your
image. Depending on the complexity of
your image, rendering can be a time
consuming process, so it’'s a good idea to
only render when you’re happy with your
scene.

The rendering options you just set can be
used in any number of rendering sessions.
So you can adjust the cameras and lights in
your scene and then render multiple views
of your scene using the same settings.

Lesson 2: Rendering an
Animation

The only difference between rendering a
movie and an image is the file output type.
Instead of selecting an image format as the
output format, you select an animation
format.

™ . e e S e S
To render a movie:

QChoose Render menu» Current
Scene Settings.

a Click the Renderer tab and choose a
renderer from the pop-up.

If you're creating a preview of your
animation, choose Draft Z-Buffer,
otherwise choose RDI Raytracer.

€ Click the Effects tab.

Q Choose Distance Fog from the
Atmosphere pop-up.
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Q Expand the Atmosphere controls by
clicking the plus/arrow icon.

G Click the Fog Color chip and choose a
blue color.

d Enter Fog starts=300, Visibility=200.
Q Click the Output tab.
Q Choose QuickTime/AVI from the pop-up.

@ Set the frame rate to 6fps (frames per
second).

Leave the time limits as they are. By
default the time limits in the Scene
Settings palette are the same as those
shown in the Time Line window.

@ Click Save to save your settings.

@Choose Render menu» Use Current
Settings. The rendering preview window

appears.

ntitled-1
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Ray Dream Studio displays a preview
window as it renders your animation.

When the rendering is complete you can
save the file for use in other applications.

Moving On

The rendering settings you choose can
have a large affect on the final artwork you
produce. You should make sure that you're
using the best settings for your scene. If
you find that the rendering is taking too
long you or you run out of memory you
may want to reduce the complexity of your
image. One area you should watch out for
is reflection and refraction. These effects
take a long time to render and require a
great deal of memory. If you're having
memory problems you may want to use
this effect sparingly.

For complete descriptions of how to
choose the right renderer for your image,
refer to Chapter 17, “Rendering.”

Wrapping Up

Now that you’ve completed the tutorial you
may be asking yourself where do | go from
here? Well the best way to learn Ray Dream
Studio is to experiment. The techniques
outlined in this tutorial are only the
beginning. You can apply the skills you've
learned to any project you have in mind.

If you want to learn more about modeling,
open some of the models in the Browser
palette and see how they were made. Even
in the most complex models you'll be able
to see the basic techniques described in
this tutorial. Another great modeling



resource is the Modeling Wizard. The
Modeling Wizard is a picture-based
assistant that guides you through the
process of creating many types of objects,
teaching you valuable modeling principles
along the way. For instructions on
accessing the Modeling Wizard, refer to
“Free Form Modeling” on page 109.

If you want to learn more about arranging
scenes, try using the Scene Wizard. This
wizard leads you through the process of
setting up lights and backgrounds. Refer to
“Using the Scene Wizard” on page 27.

Some of the files you created in this tutorial
can be the basis for your own 3D
illustration cookbook. The shader you
created can be the start of your own
Shader library. The Shell shader can be
applied to other underwater creatures
such as snails and hermit crabs. Trying
saving the shader in a personal shader
folder and then add more shaders as you
create other objects.

The lighting setup you created can be used
to light almost any scene effectively. It's a
great starting point for even the most
complex lighting setups. The cameras you
set up can also be used in other scenes.

You’re now ready to explore Ray Dream
Studio in more detail. The remaining
chapters in this User Guide will explain in
detail all the features and functions of Ray
Dream Studio 5. Remember, you can use
this tutorial as a reference source. If you

want to brush up on a certain aspect of Ray
Dream Studio, jump into the tutorial lesson
that deals with the topics you want to
review.
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	5 Choose Sections menu> Next.
	6 Click a cross section number. The Shape 6 Number...
	7 Change the number of the cross sections 7 to mat...
	8 Choose Sections menu> Next.
	9 Select shape #1 and delete it. All the 9 numbers...
	º Change the shape numbers to match the diagram sh...
	¡ Click shape #2 with the Selection tool.
	™ Choose Windows menu> Properties.
	£ In the Position controls, enter Width=0.25, Hieg...
	¢ Click Apply.
	° Repeat steps 11 to 14 for each of the remaining ...

	To add more sections:
	1 Click the ground plane to make it active.
	2 Choose the Add Point tool.
	3 Add a point between the second and last 3 cross ...
	4 Choose Sections menu> Create.
	5 Click the new cross section.
	6 Choose View menu> Preset 6 Position> Drawing Pla...
	7 Choose Sections menu> Show> 7 Current.
	8 Drag the circles away from the center as 8 shown...
	9 Choose View menu> Preset 9 Position> Reference.
	º Click the Shaded Preview Quality button.
	¡ Choose Sections menu> Show> All.

	To adjust the object’s envelope:
	1 Choose Geometry menu> Extrusion 1 Envelope> Symm...
	2 Choose the Add Point tool.
	3 Add a point on the envelope as shown.
	4 Choose the Selection tool.
	5 Drag the new point down and to the left 5 as sho...
	6 Choose the Convert Point tool.
	7 Smooth the points as shown.
	8 Click Done.


	Lesson 3: Mesh Form Modeling
	To open the Mesh Form modeler:
	1 Drag the Mesh Form tool into the 1 Perspective w...
	2 Enter a name for your new object and 2 click OK....

	To create a 3D primitive
	1 Choose the Create Sphere tool.
	2 Drag the tool in the Mesh Form modeling 2 window...
	3 Choose the Selection tool.
	4 Click the top right point of the sphere’s 4 boun...

	To edit an object’s mesh:
	1 Choose View menu> Preset 1 Position> Left.
	2 Choose the Marquee tool.
	3 Drag to select the back half of the 3 sphere.
	4 Choose Selection menu> Subdivide.
	5 Click the Sphere of Attraction tool.
	6 Choose Windows menu> Properties. 6 The Propertie...
	7 Click the Tool Options tab.
	8 Select the Spiky radio button.
	9 Set the Radius of Sphere to 4.00.
	º Click outside the sphere to deselect it.
	¡ Select the left-most point on the sphere and dra...

	To create the fish’s tail:
	1 Click the Zoom tool.
	2 Zoom in on the extended section.
	3 Click the second point from the left on 3 the to...
	4 Drag the point up and towards the left as 4 show...
	5 Click the second point from the left on 5 the bo...
	6 Drag the point down and to the left.
	7 Choose the Sphere of Attraction tool.
	8 In the Properties palette: Tool 8 Options tab, e...
	9 Click a point on the top edge of the 9 object an...

	To smooth object edges:
	1 Choose the Marquee tool and select the 1 entire ...
	2 Choose Poly Mesh menu> Smooth 2 Edges.
	3 Click Done.


	Lesson 4: Deformers
	To apply a deformer:
	1 If you haven’t done so already, add the 1 Modeli...
	2 Drag the Mesh Form Fish object from the 2 Browse...
	3 Choose Windows menu> Properties.
	4 Click the Deformers tab.
	5 Choose Wave from the Defomers pop-up.
	6 If it is not already enabled, enable the 6 Auto ...
	7 Set Phase to 0.
	8 Orientation to X Axis.
	9 Set Number of Wave cycles=1.5.
	º Set Height of waves =08%.
	¡ Click the Direct Manipulation button.
	™ Click the center point and drag it to the left. ...
	£ Close the dialog.
	Moving On



	Shading Objects
	The Story so Far
	What You’ll Need
	To add lesson files to the Browser palette:
	1 Click the Objects tab and choose 1 Browser palet...
	2 Locate and open the Tutorial folder on 2 the Ray...
	3 Click Select Current Directory.
	4 Click the Shaders tab and choose 4 Browser palet...
	5 Locate the Tutorial folder on the Ray 5 Dream St...
	6 Click Select Current Directory.

	Lesson 1: Creating Shaders
	To change the preview mode:
	To create new shader:
	1 Drag the Shell object from the Browser 1 palette...
	2 Choose the Eyedropper tool.
	3 Click the Shell.
	4 Click the Color tab.
	5 Choose Shader Editor: Insert 5 menu> Texture Map...
	6 Locate the file Tutorial: Shading 6 Objects: SHE...
	7 Click the Highlight tab.
	8 Set the value to 50.
	9 Click the Shininess tab and set the value 9 to 5...
	º Click the Bump tab.
	¡ Choose Shader Editor: Insert menu> Texture Map.
	™ Locate the file Tutorial: Shading Objects: SHELL...
	£ Set Brightness to 30%.
	¢ Click Apply.

	To save a shader in the Browser palette:
	1 Click the Browser palette: Shader 1 tab.
	2 In the Current Shader Editor, click the 2 shader...
	3 Enter a name for the shader.


	Lesson 2: Applying Shaders
	To apply a shader uniformly:
	1 Drag the object labeled Angel Fish from 1 the Br...
	2 Click the Shaders tab.
	3 Locate the drag the Angel Fish Skin 3 shader fro...

	To a place a paint shape on an object:
	1 Click the Angel Fish Stripes shader in the 1 Bro...
	2 Choose the Rectangular Paint Shape 2 tool.
	3 Choose View menu> Preset 3 Position> Left.
	4 Drag a large square over the body of the 4 fish....
	5 Choose View menu> Preset 5 Position> Right.
	6 Draw a large square on this side as well.

	To apply a shader using the 3D Paintbrush:
	1 In the Browser palette, click the Fish 1 Skin sh...
	2 Choose the 3D Paintbrush tool.
	3 Set the Size value to 99.
	4 If the palette is not extended, click the 4 Exte...
	5 Set the following:
	6 Choose View menu> Preset 6 Position> Right.
	7 Drag the brush over the top and bottom 7 edges o...
	8 Choose View menu> Preset 8 Position> Left.
	9 Paint over the edges of the fish on this 9 side ...
	º Choose View menu> Reference.
	Moving On



	Setting up Lights
	The Story So Far
	What You’ll need
	To begin setting up lights:
	1 Open the scene file Tutorial: Setting Up 1 Light...
	2 Click the Lights tab.
	3 Choose Browser palette: File 3 menu> Add Directo...
	4 Locate Tutorial: Setting Up Lights folder 4 and ...

	To switch to Shaded Preview mode:
	To render an area of a scene:
	1 Choose the Render Area tool.
	2 Drag the tool over the area you want to 2 render...

	Lesson 1: Adding Lights
	To set ambient light:
	1 Choose Windows menu> Scene 1 Settings. The Scene...
	2 Click the Effects tab.
	3 Display the Ambient Light controls.
	4 Click the color chip and choose a dark 4 blue co...
	5 Set Brightness to 30%.
	6 Close the palette.

	To add a light:
	1 Drag the Create Light tool into the Time 1 Line ...
	2 Choose Windows menu> Properties. 2 The Propertie...
	3 Click Auto.
	4 Choose Bulb Light from the pop-up.
	5 Disable the Shadows checkbox to save 5 on render...
	6 Click the Direct Manipulations button.
	7 Click the control handle that extends 7 from the...

	To add lights from the Browser palette:
	1 Choose Browser palette: Lights tab.
	2 Drag the light labeled Light Tutor to 2 Time Lin...


	Lesson 2: Positioning Lights
	To position lights using Transform controls:
	1 Click the Bulb light in the Time Line 1 window.
	2 Choose Windows menu> Properties. 2 The Propertie...
	3 Click the Transform tab.
	4 Set Position values to X=0, Y=65, and 4 Z=80.
	5 Click Apply.

	To add the Point At behavior to a light:
	1 In the Time Line window, click the light 1 label...
	2 Choose Windows menu> Properties if 2 the Propert...
	3 Click the Behaviors tab.
	4 Click the Add Component button.
	5 Choose Point At from the list and 5 click�OK.
	6 Type the name Conch Shell in the Point 6 At box....
	7 Make sure the Enabled checkbox is 7 checked.
	8 Click Apply.
	9 To see the results of the pointed light, 9 enabl...


	Lesson 3: Lighting Effects
	To add a gel:
	1 Click the light labeled Key light in the 1 Time ...
	2 Choose Windows menu> Properties. 2 The Propertie...
	3 Click the Gel tab.
	4 Choose Map from the pop-up.
	5 Click the disk icon and choose Open.
	6 Locate the file: Tutorial: Setting Up 6 Lights: ...
	7 Click Apply.
	Moving On



	Setting up Cameras
	The Story so Far
	What You’ll Need
	To begin setting up cameras:
	1 Open the file Tutorial: Setting Up 1 Cameras: CA...
	2 Choose Browser palette: Cameras 2 tab.
	3 Choose Browser palette: File menu> 3 Add Directo...
	4 Locate the Tutorial: Setting Up Cameras 4 folder...

	Lesson 1: Adding Cameras
	To add cameras from the Browser palette:
	1 If the Browser palette is not visible, 1 choose ...
	2 Choose the Cameras tab.
	3 Drag the Camera Set camera from the 3 Browser pa...

	To add cameras using the Create Camera tool:
	1 Choose the Create Camera tool and drag 1 it into...
	2 Choose Windows menu> Properties. 2 The Propertie...
	3 Click the Camera tab.
	4 Choose Conical from the pop-up.
	5 Enable the Normal radio button.
	6 Enable the Auto box.
	7 Click the Direct Manipulation button.
	8 Drag the zoom controls (the triangle 8 extending...
	9 Drag the control handle that extends 9 from behi...
	º On the right plane, click the control handle tha...


	Lesson 2: Viewing your Scene from Different Camera...
	To switch between cameras:
	1 Choose Windows menu> Camera 1 Properties. The Ca...
	2 Choose Camera 2 from the Camera 2 pop�up.
	3 Choose Reference from the Position 3 pop�up. The...
	4 Choose Camera 1 from the Camera 4 pop�up. The vi...


	Lesson 3: Positioning Cameras
	To numerically position a camera:
	1 Select Camera Set in the Time Line 1 window.
	2 Choose Properties palette: 2 Transform tab. If t...
	3 In the Position Controls enter X=23, Y=50 3 and ...
	4 Click Apply.

	To position a camera manually:
	1 Choose Windows menu> Camera 1 Properties. The Ca...
	2 Choose Cameras menu> Camera 2 Tutor.
	3 Choose Position menu> Reference.
	4 Click the Shell object in the Perspective 4 wind...
	5 Choose the Dolly tool from the toolbar.
	6 Drag the pointer down and to the left. 6 The vie...

	To adjust the Production Frame:
	1 Select the Camera Tutor camera in the 1 Perspect...
	2 Choose View menu> Production 2 Frame. A green fr...
	3 Shift-drag one of the points on the 3 production...

	To move the production frame:
	Moving On



	Animating Objects
	The Story So Far
	What You’ll Need
	To begin animating objects:
	1 Open the file Tutorial:Animating 1 Objects: ANIM...
	2 Choose Browser palette: Objects tab.
	3 Choose Browser palette: File menu> 3 Add Directo...
	4 Locate the folder Tutorial: Animating 4 Objects ...

	To set animation time limit:
	1 Make sure the Time Line window is 1 visible. If ...
	2 Click the Time Axis at 00:02:00 and drag 2 it to...

	To display the Time Controller:
	1 Choose View menu> Toolbars. The 1 Toolbars dialo...
	2 Enable Time Controller. A toolbar is 2 visible w...

	Lesson 1: Creating Key Frames
	To create a key frame:
	1 Make sure you’re at the first frame of 1 your an...
	2 Click the Last Frame button on the Time 2 Contro...
	3 Click the Angel Fish object in the Time 3 Line w...
	4 Click Command-T/Ctrl+T to display the 4 Object P...
	5 Click the Transform tab.
	6 Enter the Position values X=34, Y= -16, 6 Z=20 a...
	7 Click the First Frame button.
	8 Click the Perspective window to make it 8 the ac...
	9 Click the Interactivity button. This 9 button sh...
	º Click the Play button to preview your animation....


	Lesson 2: Applying Tweeners
	To apply a Tweener:
	1 In the Time Line window, double-click 1 the time...
	2 Choose Bézier from the pop-up.
	3 Set the Ease-in /out values to 40% and 3 40%.
	4 Set the Tighten-in /out values to 50% and 4 50%....
	5 Click the First Frame button then click 5 Play t...


	Lesson 3: Applying Behaviors
	To apply physically-based behaviors:
	1 Drag the Mesh Form Fish object out of 1 the Brow...
	2 Choose Windows menu> Properties. 2 The Propertie...
	3 Enable the Auto checkbox.
	4 Click the Behaviors tab. If the tab is not 4 vis...
	5 Click the Add button. The Add dialog 5 appears.
	6 Select Apply Physical Effects and 6 click�OK.
	7 Enable the Movable by impact checkbox.
	8 Click the Add button again.
	9 Choose Flow Force from the list and click 9 OK. ...
	º Set the Turn Density to 70%.
	¡ Enable the Rotate with flow checkbox.

	To duplicate objects:
	1 Select the School Fish in the Perspective 1 wind...
	2 Drag School Fish up and to the left.
	3 Press Command-D/Ctrl+D again. A new 3 fish appea...
	4 Continue duplicating and repositioning 4 the fis...

	To preview behaviors:
	1 Click the Interactivity button.
	2 In the Time Line window, drag the end of 2 the a...
	3 Click the First Frame button and then 3 click Pl...
	Moving On



	Animating Shapes
	The Story So Far
	What You’ll Need
	To begin animating shapes:
	1 Make sure the Browser palette is visible. 1 If i...
	2 Click the Objects tab.
	3 Choose Browser palette: File menu> 3 Add Directo...
	4 Locate the folder Tutorial: Animating 4 Shapes a...

	Lesson 1: Animating the Extrusion Path
	To animate an object using the sweep path:
	1 Drag the Seaweed object from the 1 Browser palet...
	2 Click the Last Frame button.
	3 Double-click the seaweed in the 3 Perspective wi...
	4 Select the Zoom tool and zoom in on the 4 sweep ...
	5 Choose the Selection tool.
	6 Click the second point on the sweep path 6 and d...
	7 Click the third point and drag it to the 7 oppos...
	8 Click the fourth point and repeat step 7.
	9 Choose View menu> Preset 9 Position> Left.
	º Zoom in on the horizontal sweep path.
	¡ Click on the second point on the sweep path and ...
	™ Click the third point and drag it down.
	£ Click the fourth point and drag it up.

	To apply the Oscillate tweener:
	1 Double-click between the first and last 1 frame ...
	2 Choose Oscillate from the Tweener 2 pop�up.
	3 Set the Nbr Oscillation slider to 2 and 3 click�...
	4 Click the First Frame button on the Time 4 Contr...
	5 Click Play.


	Lesson 2: Animating the Mesh Form Modeler
	To animate an object by repositioning its vertices...
	1 Make sure the Objects tab is selected on 1 the B...
	2 Click the First Frame button. If the 2 button is...
	3 Double-click the fish to open the Mesh 3 Form mo...
	4 Choose the Zoom tool.
	5 Zoom in on the fish’s tail.
	6 Choose the Marquee tool.
	7 Select the rear of the tail.
	8 Choose the Sphere of Attraction tool.
	9 Choose Windows menu> Properties 9 and then click...
	º Enable Spiky.
	¡ Set the Radius of Sphere to 30.
	™ Click the center point of the three selected poi...
	£ Click the Last Frame button.
	¢ Drag the center point to the right.
	° In the Time Line window, double-click the time l...
	§ Click Done.
	¶ Click the First Frame button on the Time Control...


	Lesson 3: Animating Deformers
	To animate a deformer:
	1 Make sure you’re on the first key frame 1 of you...
	2 Drag the Mesh Form Fish object from the 2 Browse...
	3 Choose Windows menu> Properties. 3 The Propertie...
	4 Click the Deformer tab.
	5 Enable the Auto checkbox.
	6 Make sure the Phase slider is set to 0%
	7 Click the Last Frame button. The current 7 time ...
	8 Set the Phase slider to 100%
	9 Click the First Frame button and then 9 click Pl...

	To duplicate the deformed fish:
	1 Click the First Frame button.
	2 Click the Mesh Form Fish in the 2 Perspective wi...
	3 Press Command-D/Ctrl+D to duplicate 3 the fish.
	4 Drag the Mesh Form Fish up and to the 4 left.
	5 Click the duplicate fish and press 5 Command-D/C...
	6 Continue moving and duplicating fish 6 until you...
	7 Click the First Frame button and then 7 click Pl...
	Moving On



	Animating Effects
	The Story So Far
	What You’ll Need
	To begin animating effects:
	1 Locate the Tutorial: Animating Effects 1 folder ...
	2 Choose Browser palette: Shaders 2 tab.
	3 Choose Browser palette: File 3 menu> Add Directo...
	4 Locate the folder Tutorial: Animating 4 Effects ...

	Lesson 1: Rotoscoping
	To apply rotoscoping to a light:
	1 Click the Key Light in the Time Line 1 window to...
	2 Click the First Frame button to move to 2 the fi...
	3 If necessary choose Windows menu> 3 Properties t...
	4 Click the Gel tab.
	5 Enable the Auto button.
	6 Choose Movie from the Gels pop-up.
	7 Click the disk icon.
	8 Use the dialog to locate the file 8 Tutorial:Ani...
	9 In the Time Line window drag the key 9 frame ind...
	º In the Properties palette, enable Tile.
	¡ Move the Horizontal slider to 3 times.

	To preview a rendered animation:

	Lesson 2: Animating Shaders
	To animate a shader:
	1 Click the First Frame button to move to 1 the be...
	2 Drag the Shaded Fish from the Browser 2 palette ...
	3 Choose the Eyedropper tool.
	4 Click the Shaded Fish in the Perspective 4 windo...
	5 Click the Last Frame button to move to 5 the end...
	6 In the Current Shader Editor, double- 6 click th...
	7 Click the Color palette button.
	8 Select a green color, then click OK.
	9 Double-click the right color chip, then 9 click ...
	º Choose a light gray color, then click�OK.
	¡ Click Apply.
	™ Choose Render menu> Best Animation Preview. to c...
	Moving On



	Rendering
	The Story so Far
	What You’ll Need
	To open preset files for the rendering lessons:
	1 Locate the folder Tutorial: Rendering 1 and open...
	2 Choose Browser palette: Cameras 2 tab and add th...
	3 Choose Browser palette: Lights tab 3 and add the...
	4 Drag the objects Camera Tutor and Light 4 Tutor ...

	Lesson 1: Rendering an Image
	To choose a renderer:
	1 Choose Render menu> Current 1 Scene Settings. Th...
	2 Click the Renderer tab.
	3 Choose RDI Ray Tracer from the pop-up.
	4 Make sure that all the rendering options 4 are e...

	To set the atmosphere:
	1 Choose Scene Settings palette: 1 Effects tab.
	2 Choose Distance Fog from the 2 Atmosphere pop-up...
	3 Click the plus/arrow icon next to the 3 Atmosphe...
	4 Double-click the Fog Color chip.
	5 Choose a light blue color and then 5 click�OK.
	6 Enter Fog starts= 120
	7 Enter Visibility = 300

	To set Output options:
	1 Choose Scene Settings palette: 1 Output File tab...
	2 Click the plus/arrow icon next to Image 2 Size. ...
	3 Set Width=300 and Height=400.
	4 Set the Resolution to 72 dpi.
	5 Click the plus/arrow icon next to 5 Camera. The ...
	6 Choose Render Camera from the 6 Rendering Camera...
	7 Click the File Format plus/arrow icon. 7 The For...
	8 Choose BMP (RD) from the pop-up.
	9 Click the Save button to save your 9 rendering s...

	To start a rendering:

	Lesson 2: Rendering an Animation
	To render a movie:
	1 Choose Render menu> Current 1 Scene Settings.
	2 Click the Renderer tab and choose a 2 renderer f...
	3 Click the Effects tab.
	4 Choose Distance Fog from the 4 Atmosphere pop-up...
	5 Expand the Atmosphere controls by 5 clicking the...
	6 Click the Fog Color chip and choose a 6 blue col...
	7 Enter Fog starts=300, Visibility=200.
	8 Click the Output tab.
	9 Choose QuickTime/AVI from the pop-up.
	º Set the frame rate to 6fps (frames per second).
	¡ Click Save to save your settings.
	™ Choose Render menu> Use Current Settings. The re...
	Moving On
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