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Chapter 1: Installation and Getting Started

Installation

The 3D Fun Pack is installed by default when you install the latest version of Ray Dream Studio™
or Ray Dream Designer™. If you do not wish to install the extension at this time you must do a
custom install as described below. The 3D Fun Pack will run in demonstration mode until you
enter a serial number. This is NOT the same serial number as your Ray Dream software, but a spe-
cific serial number for the 3D Fun Pack.

Macintosh®

1. Turn off any virus protection and compression programs and close any other applications
currently open.

2. Insert the Ray Dream Extensions CD-ROM into your CD-ROM drive.

3. Double click the Installer icon from the CD-ROM and follow the instructions on the screen.

The installer gives you the option of doing an Easy or Custom installation. Easy Install
will install your updated version of Ray Dream Designer 4 or Ray Dream Studio and
all third party Extensions.

Choose Custom if you want to select the individual files for installation. Choose your
custom options carefully –– your Ray Dream software includes large volumes of con-
tent, such as the Dream Models™ and shaders, that could take up valuable space on
your hard disk. Your best strategy is to install the options that you use frequently and
use the CD-ROM to access your models and shaders.

4. Choose the Install Location for your Ray Dream folder and click Install.

During installation you will be asked to choose either a “Fat” or “Smart” version.
Choose Fat to install a version for both 68040 and Power Macintosh machines. (The
Fat version is most useful for people with PowerPC upgrade cards. With the Fat ver-
sion you will be able to run Ray Dream from either your PowerPC or your 680x0
processor.) Choose Smart to install a version for your Macintosh type only. The Smart
option requires less disk space.

5. After your Ray Dream software and Extensions have finished loading, click Quit to quit the
Installer.
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Windows™ 95

1. Turn off any virus protection and compression programs and close any other applications
currently open.

2. Insert the Ray Dream Extensions CD-ROM into the CD-ROM drive.
Windows 95 will automatically locate the Ray Dream installation program on the CD-ROM.

3. Follow the instructions on the screen. Click Next to confirm each option and move to the
next screen.

You have the option of running a Typical, Compact or Custom installation. Typical
will install your software in a standard configuration appropriate for most users,
including all the 3rd party extensions available on the CD-ROM. Compact will install
a minimum configuration (no 3rd party Extensions and no Wizards).

Choose custom if you want to select the individual files for installation. Choose your
custom options carefully –– your Ray Dream software includes large volumes of con-
tent that could take up valuable space on your hard disk. Your best strategy is to
install the options that you’ll use frequently and use your CD-ROM to store your
models and shaders.

You will be given options to choose your Destination Directory and Program Folder.

4. Once you’ve made these selections you’ll be able to confirm your installation settings. Then
click Start to install.

After your Ray Dream software and Extensions have finished loading, click Finish.

Windows™ 3.1 or Windows NT™

1. Turn off any virus protection and compression programs and close any other applications
currently open.

2. Insert the Ray Dream Extensions CD-ROM into your CD-ROM drive.

3. Choose Run from the Program Manager File menu. The Run dialog appears.

4. Type E:setup in the Command Line text box. If you are installing from a drive other than E,
substitute the letter for the source drive. Since Ray Dream Studio and Ray Dream Designer
install from a CD, please use the drive number associated with your CD-ROM drive.
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5. Click OK. The Setup dialog appears. Follow the installation instructions that appear. The rest
of the installation instructions will be similar to those described in the Windows 95
Installation section above.

Congratulations! Your updated Ray Dream Software and Extension(s) have been successfully
installed. The first time you try to use your new Extensions you will be prompted to enter your seri-
al number.

Getting Started

Typically, before your apply your 3D Fun pack effects, you’ll first want to create a 3D scene. When
you’re ready to apply your filter, choose Render>Effects. The 3D Fun Pack filters are located under
the Filters Tab of the Effect dialog box. To use a filter, click Add and select the filter you’d like to use.
Clicking Edit will allow you to adjust the controls of your 3D Fun Pack Extensions.

Tutorials

Your Tutorial files are on your Ray Dream CD in the 3D Fun Pack Folder, inside a folder called
Tutorials. They have not been installed by default because of their size. Chapter 4 provides brief
tutorials for Anaglyphs and AutoStereograms.

Removing Extensions

To remove the 3D Fun Pack, simply go to the folder called Extensions and drag the folder called 3D
Fun Pack Extensions to the trash.

Warning!
The enclosed glasses are for viewing Anaglyph pictures only. Do not operate machinery or any
vehicle while wearing these glasses. These glasses are not to be used as sunglasses and are not
designed for extended wear Please use only as directed. Ray Dream, Inc. assumes no liability for
usage other than as described above.

If you received your 3D Fun Pack on your Ray Dream Studio or Ray Dream Designer CD-ROM, you
have to call Ray Dream, Inc. 1 (800) 846-0111 to purchase the extension and to receive your
unlocking serial number and Anaglyph glasses.
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Chapter 2: Anaglyph

How Does the Anaglyph Extension Work?

To “see” 3D objects a human brain needs two different pictures which correspond to the images
generated by the human eye. Each eye actually sees a slightly different picture due to the distance
between the eyes. To test this, notice what happens when you alternate closing one eye and then
the other. Objects appear to shift back and forth. The amount of shifting depends upon the dis-
tance the viewer is from the object. The closer the objects are, the more they seem to shift from left
to right.

The Anaglyph extension uses a new and powerful algorithm from RAYflect, Inc. to create, using
only one scene, the two images needed for 3D viewing. These two images are then translated into
left and right views using the Eye Spacing command. They are then composited using a color filter
to create the final screen or printed image. The standard for anaglyphs is Red for the left image and
Cyan for the right image.

When wearing the Red and Cyan, or Anaglyph, glasses, your left eye will see only the Cyan picture
and your right eye the Red picture. Since the Red and Cyan images have been translated with the
Anaglyph process, your eyes see two different pictures that mimic the way distance is perceived in
the real world. Your brain is fooled into seeing “3D”.

Getting Started

To apply the Anaglyph extension to a scene:
• Choose Render>Effects
• Click the Filter tab.
• Click Add.
• Select FP Anaglyph.
• Edit the anaglyph parameters for your file.
• Render effects will be applied after your file is rendered.

Note
The 3D Fun Pack filters work only with the RDI RayTracer renderer.

Anaglyph Parameters
• Eye  spacing
• Color mode
• Black Borders
• Left Lens RGB
• Right Lens RGB
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The Anaglyph Interface

Eye Spacing

The Eye Spacing slider controls the distance between the virtual cameras used to render the image.
The values are represented in pixels, with 5 pixels being the least distance between the images and
100 being the greatest distance between the images.

The higher the pixel value set on the slider, the more distance there will appear to be when your
image is viewed through anaglyph glasses.

Change the Eye Spacing slider value slowly when creating anaglyph images. If the value is set too
large in relation to the size of the final image, your eyes will be unable to merge the left and right
images and there will be no 3D effect. Experiment to find the eye spacing which best suits your
vision, because everyone’s vision is slightly different. Some suggested settings are below.

Remember, for a given image size, increasing the Eye Spacing value will increase the Anaglyph
depth. This means, that if you increase your image size, you must also proportionately increase Eye
Spacing value to maintain a constant depth.

5

3D Fun Pack User Guide

Eye Spacing
Slider

Click to select
Intensity Levels

or Colors

Set lens color
with these
slider bars

Click to add
Black Borders

Use this graphic
to check calibration
on your Anaglyph

glasses

Context-sensitive
help panel

Toggle help
balloons on/off

Eye Spacing values
in pixels

Preview window

RGB values

Click OK to
save your settings

and
Cancel to exit the

dialog box
without saving



For example, when creating a image that measures 640 x 480, a good Eye Spacing value to start
with is 16 pixels. For an image of 1280 x 960, a good value to try is 32. If you have trouble seeing
depth in your anaglyphs, the first thing to try is reducing the Eye Spacing.

Color/Intensity Mode

The Anaglyph extension offers two algorithms to render the 3D effect:
• Intensity levels mode
• Color mode

The Intensity level mode converts your rendered image into grayscale and then applies red and
cyan filtering. This is the “classic” method used since the 1950’s to generate 3D images. In general,
Anaglyphs generated using Intensity levels are easier to see.

Exclusively from RAYflect, the Color mode applies a filter which maintains the image’s color bal-
ance even when viewed through the Anaglyph glasses. Color mode may not always be the best
choice for your anaglyphs and you’ll want to experiment with the two modes to see which best
suits your needs.

Warning!
If you use the color mode on an image that includes Red or Cyan objects, the objects’ colors can
interfere with the Color mode algorithm. The results will be an image with no perceptible 3D
effect. When this occurs, switching to Intensity mode will restore depth to the image.

Black Borders

To create the illusion of depth, the Anaglyph extension translates, or moves, the Red image to the
left and the Cyan picture to the right. This creates border areas on the image which are Red (left)
and Cyan (right). To hide  these, click on the black borders option. This adds black borders to the
left and right of your files, replacing the Red and Cyan borders. The border size will increase or
decrease according to the Eye Spacing value set.

Glasses Calibration

If you use the Anaglyph glasses included in the 3D Fun Pack, no calibration is necessary, as the
algorithms have been customized for these glasses. If you want to use your own Anaglyph glasses,
calibration will be necessary. Anaglyph glasses can be Red/Green or Red/Blue instead of being
Red/Cyan.
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Note
This calibration is designed to optimize viewing your anaglyphs on a computer screen. Your print-
ed anaglyph may experience some color shifting due to inherent  differences between the RGB
color model used for monitors and the CMYK method generally used for printing. Some experi-
mentation with calibration may be necessary to optimize viewing printed anaglyphs.

To calibrate glasses: adjust the Red, Green and Blue sliders to match the colors in your anaglyph
glasses as best you can. To fine tune the calibration, put the glasses on and watch the lenses on the
Anaglyph dialog box. There are three parts on each lens:

• a white half disk
• a black half disk
• a colored square in the middle

Close your right eye while wearing the glasses. You should see the image below:

Now close your left eye. You should see the image below:
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If your results don’t reasonably match the above images, adjust the RGB sliders slowly until they
do. Unfortunately, because viewing glasses are rarely perfect color filters, it may be impossible to
match the images perfectly.

Remember, if you use glasses other than those provided with the 3D Fun Pack, calibration is essen-
tial. The Anaglyph process relies on this calibration to produce the 3D effect.

Rendering Your Anaglyph

After you’re satisfied with your Eye Spacing and Color/Intensity mode adjustment, click OK.
Render the image with the RDI RayTracer as usual (Anaglyphs must be rendered using ray tracing).
When the ray traced rendering is complete, the Anaglyph extensions will automatically begin
transforming your image into Anaglyph.

All of the usual options of the RDI RayTracer are available except for Adaptive Oversampling. The
3D Fun Pack uses Ray Dream’s G-Buffer technology which does not handle multistage
Oversampling. As a result, the Adaptive Oversampling option is automatically disabled when using
the Anaglyph extension.

If you need your Anaglyphs to be Oversampled, render your images at two times the needed reso-
lution and re-size before printing. Don’t forget to increase the Eye Spacing value to compensate for
the increased size of the image.

Animating Anaglyphs

If you are using Ray Dream Studio, which includes Ray Dream Animator*, you can easily use the
Anaglyph extension on animations. Rendering an Anaglyph animation is very simple. Just create
your animation as usual. Then, with the current time bar at time 0:00:00, apply the Anaglyph
extensions as noted above and edit its parameters. Render your animation as usual.

You can also animate Anaglyph extension parameters over the course of your animations. To do
this, set your current time indicator to the time you want and change the values in the Anaglyph
dialog box. New key events will be added to the Total Control Timeline under the Effects tab. For
example, you can animate Eye Spacing over time in an animation. This technique creates a dra-
matic special effect with the depth changing throughout the animation.

*For information about upgrading from Ray Dream Designer to Ray Dream Studio contact Ray Dream, Inc.

at (800) 846-0111.
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One pitfall to avoid: the Anaglyph extension will always maximize the picture depth. This can gen-
erate unwanted depth shifting in animation. To work around this shifting, add objects in both the
foreground and the background of your animation. These need not be visible in the production
frame.

Printing Anaglyphs

Rendered Anaglyphs can be printed just like any other Ray Dream image. Because Anaglyphs rely
heavily on accurate color values, color matching between your printer and your monitor is critical
to preserve the 3D effect. In addition, depth also depends upon the Eye Spacing value set, so your
image must be printed at the same size it was rendered at.

Limitations

As stated in “Chapter 2: How Does the Anaglyph Extension Work?” anaglyphs use a powerful algo-
rithm which combines the two images seen by the human eye into one rendered image. The algo-
rithm saves time by rendering one image instead of two.

This faster method does have a limitation. It cannot “see” objects that are hidden behind other
objects. In the real world, sometimes your left eye can see an object that your right cannot, or vice
versa. If you create an image on screen that duplicates this phenomena, the algorithm will not see
the hidden object. The result of this could be an image where the left eye image is correct, but the
right eye image is wrong. In other words, in the right eye image, the hidden object will be missing.
In this case, the algorithm will try to interpolate the pixels to render the hidden object. Most times
this will work, but if the hidden object is too complex, the algorithm will fail.

Here are some tips to help avoid this limitation:

• Do not hide complex objects behind other objects.
• If you run into this limitation, move the hidden object to the right or to the left until it can

be seen.
• Avoid high Eye Spacing with small pictures.
• Use uniform and simple backgrounds.
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Chapter 3:  AutoStereograms

How Does the AutoStereogram Extension Work?

AutoStereograms are one of the latest fads in book and poster art. At first glance, they appear to be
meaningless patterns. After closer examination, the viewer begins to see 3D images emerging from
the pattern. If you are unable to see the 3D images in your AutoStereograms and you still find them
to be mysterious images of meaningless patterns, jump ahead to “Why Can’t I See
AutoStereograms?”

There are two kinds of AutoStereograms, both of which are supported by the 3D Fun Pack:
• Random Dots
• Textured

As stated in the Anaglyph chapter, to “see” 3D objects the human brain needs two different images.
Imagine that your monitor is a window.  Behind this window imagine a small, floating cube –– like
a fish in an aquarium. If you close your left eye, the cube appears to move a bit to your left. If you
close your right eye, the cube moves a bit to the right. So, if you were to take one picture of what
your left eye sees, and then another picture of what your right eye sees, those two images would be
slightly different. AutoStereograms replace these two images with an image consisting  of random
or textured dots. The dots in the image are the same color at any place where they represent the
same area on the virtual cube. It is this convergence that creates an AutoStereogram.

To see the hidden 3D cube, look through your monitor as if it were an open window. Try to set your
focal point about 12 inches past the face of your monitor. Your objective is to look “at” the virtual
cube. The dots created during the AutoStereogram will merge at the right place to create a virtual
cube inside your monitor.

Getting Started

To apply the AutoStereogram extension to a scene:
• Choose Render>Effects.
• Click the Filter tab.
• Click Add.
• Select AutoStereogram and click OK.
• Begin selecting AutoStereogram parameters for your file.
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AutoStereogram Parameters
• Eye spacing
• Wall-Eyed mode
• Cross-eyed mode
• Add Convergence dots
• Textured AutoStereogram
• Open a texture
• Tile

The AutoStereogram Interface

Eye Spacing

The Eye Spacing slider controls the distance between the virtual cameras used to render the image.
The values are represented in pixels, with 5 pixels being the least distance between the images and
100 being the greatest distance between the images.

The higher the pixel value set on the slider, the more distance there will appear to be when your
image is viewed.
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Change the Eye Spacing slider value slowly when creating AutoStereogram images. If the value is
set too large in relation to the size of the final image your eyes will be unable to merge the left and
right images and there will be no 3D effect. Experiment to find the eye spacing which best suits
your vision, as everyone’s vision is slightly different. Some suggested settings are below.

Remember, for a given image size, increasing Eye Spacing value will increase the AutoStereogram
depth. This means consequently, that if you increase your image size, you must also proportion-
ately increase Eye Spacing value to maintain a constant depth.

For example, when creating a image that measures 540 x 400, a good Eye Spacing value to start
with is 90 pixels. For an image at 1080 x 800, try an Eye Spacing value of 180. Do not hesitate to
experiment to find the Eye Spacing value that gives the best results. Remember, everyone’s eyes are
slightly different.

Summary

• For a given image size, increasing Eye Spacing will increase the AutoStereogram depth.
• Consequently, if you increase image size you must also increase Eye Spacing proportion-

ately to maintain a constant depth.

Wall-Eyed Mode or Cross-Eyed Mode?

Wall-Eyed and Cross-Eyed are two different kinds of AutoStereogram. Posters and books use Wall-
Eyed AutoStereogram. If you are accustomed to viewing AutoStereograms in books, or if your
AutoStereograms will be used in books or posters, use Wall-Eyed mode.

Wall-Eyed AutoStereograms look better and have more depth than Cross-Eyed ones, but some peo-
ple cannot see this kind of AutoStereogram. The Cross-Eyed mode is sometimes easier to view so
we have included it in the 3D Fun Pack.

Some people can see both kinds of AutoStereogram. If you are one of them, you can chose the
method you prefer. To see a comparison of the two different methods see “Why Can’t I See
AutoStereograms?”

Convergence Dots

Convergence dots are two black dots that are added to the picture to help you converge your eyes
at the right place to see hidden 3D objects. If you are very good at seeing AutoStereograms, the
dots are not necessary.
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Textured AutoStereogram

To render a textured AutoStereogram, load a texture using the Open Texture button. The 3D Fun
Pack can use only PICT images for textured AutoStereograms. You will be prompted for a texture
file. You will also be prompted for a texture map if you select the Use Texture check box. When
loaded, the texture file will be displayed in a small preview screen.

The two sliders let you tile the texture on the AutoStereogram.

If you want to achieve good results with textured AutoStereograms, you must follow these proce-
dures:

• Create a Random Dots AutoStereogram.
• Use standard Wall-Eyed mode.
• Choose the appropriate Eye Spacing value as described above.

You can experiment with different values until the Random Dots AutoStereogram looks good to
you.

• Load a texture which has the same width as the Eye Spacing (measured in pixels).
• Choose a tile value for your texture.
• Render the image with its width equal to: (Texture Size) x (Number of Horizontal Tiles)  

If you follow this procedure you will get a seamlessly tiled AutoStereogram. If you do not want a
seamless AutoStereogram, you can choose any value for the AutoStereogram parameters. Results
can be surprising and interesting!

Choose whatever parameters you want for vertical tiling. These will not effect the AutoStereogram
quality. For example, choose an Eye Spacing value of 64. Load a texture map that is 64 pixels wide.
Tile it 10 times horizontally. The rendered picture width must be equal to 64 x 10 = 640 pixels.

Rendering your AutoStereogram

After choosing values for Eye Spacing and Mode (Cross-Eyed or Wall-Eyed), render the image with
the RDI RayTracer (Stereograms must be ray traced –– they will not work with the Production Z-
buffer.). When the ray traced rendering is complete, the AutoStereogram extension will automati-
cally transform your image into an AutoStereogram.

All of the usual options of the RDI RayTracer are available except for Adaptive Oversampling. This
is because the 3D Fun Pack uses Ray Dream’s G-Buffer technology which does not handle multi-
stage Oversampling. As a result, the Adaptive Oversampling option is automatically disabled when
using the AutoStereogram extension.
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Note
Even though Adaptive Oversampling is disabled in the RDI RayTracer, the AutoSterogram exten-
sion automatically oversamples the image.

Animating AutoStereograms

If you are using Ray Dream Studio, which includes Ray Dream Animator*, you can easily use the
AutoStereogram extension on animations. Rendering an AutoStereogram animation is very simple.
Just create your animation as usual. Then, with the current time bar at time 0:00:00, apply the
AutoStereogram extension as noted above and edit its parameters. Render your animation as
usual.

You can also animate the AutoStereogram extension parameters over the course of your anima-
tions. To do this, set your current time indicator to the time you want and change the values in the
AutoStereogram dialog box. New key events will be added to the Total Control Timeline under the
Effects tab. For example, you can animate Eye Spacing over time in an animation. This results in an
animation special effect where the depth changes.

One pitfall to avoid: the AutoStereogram extension will always maximize the picture depth. This
can generate unwanted depth shifting in animations. To work around this, add objects in both the
foreground and the background of your animation. These need not be visible in the production
frame or rendering.

Printing AutoStereograms

Rendered AutoStereograms can be printed just like any other Ray Dream images. Remember,
depth also depends upon the Eye Spacing value set, so your image must be rendered and printed
at the same dpi. For example, if you want to print an image at 300 dpi, you must render it at 300
dpi with the appropriate eye spacing value.

Why Can’t I See AutoStereograms?

That is a good question! 

First and foremost, do not panic! Many people have trouble seeing AutoStereograms and have
given up trying. Most people can see AutoStereograms after taking time to train themselves.
Depending upon the individual, it can take from one second to several hours to see their first
AutoStereogram. If after 5 or 10 minutes you can’t see a single 3D object, you’re absolutely normal
–– keep trying! The more you look at AutoStereograms the faster you’ll learn to see them.

*For information about upgrading from Ray Dream Designer to Ray Dream Studio contact us 
at Ray Dream, Inc.(800) 846-0111
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Try these methods:

Wall-Eyed Method

To see this kind of AutoStereogram (the most common one), you must imagine that your monitor
screen is transparent and you can see objects behind the screen. You focus on the image that is
“inside” the monitor.

Step 1
Create a simple scene with a centered sphere which is no larger than one quarter of the total image
size. Use the Production Frame to verify the sphere’s size.
Step 2
Apply the AutoStereogram extension as described in the tutorial in Chapter 4. Select an Eye
Spacing value of 90 using Wall-Eyed mode. Turn on the convergence dots and don’t use a texture.
Step 3
Render the image at 640 x 480 using the RDI Ray tracer.
Step 4
Look at the rendered image on screen. Focus on the two black dots at the top of the screen.
Step 5
Get very close to the monitor (2 or 3 inches away) and continue to look at the black dots.
Step 6
The dots should begin to appear blurred.
Step 7
Relax and try to look behind your screen. You should now see 4 black dot. Do not try to focus on
the dots!
Step 8
Begin to move back from the screen very slowly while still looking “behind” it. Do not focus on the
dots. The farther back you are, the closer the two center black dots appear.
Step 9
When the two center black dots merge, stop moving back. You should  see 3 blurry black dots. Do
not try to focus your eyes.
Step 10
Slowly begin to move your eyes around the AutoStereogram. You should begin to see a blurry 3D
object. The middle black dot should appear to float in the air.
Step 11
Focus your efforts on clearly seeing the dots and the 3D sphere. This is the hardest part. If you de-
converge your eyes you’ll lose everything. If that happens, just try again!

If you follow these steps, you will soon see your first AutoStereogram. Congratulations!
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Why it is so difficult to see AutoStereograms? Because you have to learn the difficult task of seeing
behind your monitor while maintaining your focus on it. Since birth, you’ve been focusing  on
what you’re looking at. With AutoStereograms you must learn how to focus differently.

Cross-Eyed Method

With a Wall-Eyed AutoStereogram you must focus behind your monitor. With a Cross-Eyed
AutoStereogram,  you must focus in front of your monitor.

To look at a Cross-Eyed AutoStereogram, you must visualize the object popping out of the front of
your monitor.

Step 1
Create a simple scene with a centered sphere which is no larger than one quarter of the total image
size. Use the Production Frame to verify the sphere’s size.
Step 2
Apply the AutoStereogram extension as described in the Tutorial in Chapter 4.  Select an Eye
Spacing value of 90 using Cross-Eyed mode. Turn on the convergence dots and don’t use a texture.
Step 3
Render the image at 640 x 480 using the RDI Ray tracer.
Step 4
View the finished AutoStereogram on screen. Focus on the two black dots at the top of the screen.
Step 5
When the AutoStereogram is done, look at the two black dots on the top of the screen.
Step 6
Stand about 3 feet away from your monitor
Step 7
Hold up a pencil or your finger vertically between you and the screen.
Step 8
Cross your eyes to look at the pencil.
Step 9
Now try to focus on the screen while still watching the pencil.
Step 10
Slowly remove the pencil. You should see three convergence dots and your eyes should stay
crossed. If you see four convergence dots, your eyes are too crossed. Try again.
Step 11
Enjoy the 3D effect.

Wall-Eyed AutoStereograms yield a much stronger 3D effect. If you can see Cross-Eyed ones, try to
learn to see Wall-Eyed ones also. You will be astonished by the results!
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Experienced Users

Yes, you can look at Wall-Eyed AutoStereograms using the Cross-Eyed method or Cross-Eyed
Autostereogram using the Wall-Eyed method! You will see inverted depth. 
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Chapter 4: Tutorials and Examples

Note
Our screen shots below were created on a Macintosh, however, the 3D Fun Pack functions exactly
the same under all Windows operating systems, so Windows users should have no trouble com-
pleting the Tutorial.

Creating an Anaglyph

Creating an Anaglyph image is easy. Follow the simple steps below to create your first Anaglyph
using one of Ray Dream’s Scene Wizards.

• Launch Ray Dream Studio/Ray Dream Designer.

• Choose Use Scene Wizard to open the Scene Wizard dialog box.

• Click once on Indoor Scenes and then click Next or hit the Enter key.

• Select Indoor Templates and then click Next or hit the Enter key.

• Scroll down to the Hallway Scene, select it and click Done.

• Choose Render> Settings and set your image size to 400 x 300 pixels. Leave the rest of the settings
at their default. Click OK to exit this dialog box.

• Choose Render> Effects and then click on the Filters tab in that dialog box.

• Click the Add button and select FP Anaglyph. Click OK.
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• Edit the Anaglyph settings.

• Using the Spacing slider, adjust the Eye Spacing value to 24.

• Make sure that you’ve selected Intensity Levels and Black Borders.

• Click OK.

• In the Render Effects dialog click OK.

You’re ready to render. Choose Render>Use Current Settings. Your image now begins rendering.
Don’t worry if it doesn’t appear that the Anaglyph filter is being applied. The filter will apply once
your image has finished its rendering.

Congratulations! You’ve rendered your first Anaglyph. Put your glasses on and give it a try.
Remember, you might need to adjust the Eye Spacing values to get the best possible image for you,
because everyone’s eyes are slightly different.

Compare your rendered image to the Hallway Anaglyph image we’ve rendered for you. It’s in the
3D Fun Pack Examples folder on your Ray Dream CD-ROM.
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Examples

Other sample Anaglyph images included are AGP Fish.tiff, which uses Ray Dream’s tutorial image,
and an animation rendered using the Anaglyph filter called AGP Planet Anim. The Ray Dream
Scene files for these two Anaglyphs are included in your Tutorial folder so you can try to duplicate
the effects you see in the final images.

Creating an AutoStereogram

In this example, you will create a Wall-Eyed AutoStereogram.

• Launch Ray Dream Studio/Ray Dream Designer.

• Choose Open an Existing File and open the file called AST Duck.rd4 in the AutoStereogram
Tutorial folder.

• Choose Render>Settings and set your image size to 540 x 540 pixels. Leave the rest of the settings
at their default. Click OK to exit this dialog box.

• Choose Render>Effects and then click the Filters tab in the Render Effects dialog box.

• Click the Add button and select FP AutoStereogram. Click OK.
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• Edit your AutoStereogram settings.

• Using the Spacing slider, adjust the Eye Spacing value to 90.

• Make sure that you’ve selected Wall-eyed, Show convergence dots and Use texture.

• When you click the Use texture check box, you are automatically prompted to select a texture.

• Select Texture B in the folder called AutoStereogram Tutorial inside the folder 3D Fun Pack and
then click Open.
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Your texture will appear in the Mini Preview on the right.

• Tile your texture six times vertically and six times horizontally.

• Click OK.

• In the Render Effects dialog box click OK.

You’re ready to render. Choose Render. > Use Current Settings. Your image now begins rendering.
Don’t worry if it doesn’t appear as if the AutoStereogram filter is being applied. The filter will apply
only after your image has finished its rendering.

Congratulations! You’ve rendered your first AutoStereogram. If you can’t see the 3D effect, refer
back to “Why Can’t I See AutoStereograms?” for some viewing hints. Remember, you might have to
adjust the Eye Spacing values to get the best possible image for you, because everyone’s eyes are
slightly different.

Compare your rendered image to the Duck.tiff image on the CD.
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Examples

Other sample AutoStereogram images included are AST Hammer Anim, which is an animation
rendered using the AutoStereogram filter. The Ray Dream Scene file for this AutoStereogram is
included in your Tutorial folder so you can try to duplicate the effects you see in the final anima-
tion.
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