
Chat Options (Personal Info tab)



Provides a space for you to type your real name. Your name is displayed in the list of users on the chat server in the User List 

dialog box.



Provides a space for you to type your nickname. 

Microsoft Chat uses your nickname to identify you to other people inside a chat room.



Provides a space for you to type information about yourself. 

If other people ask Microsoft Chat for your personal profile, they will see this information.



Create Chat Room dialog



Provides a space for you to describe the room’s topic. 

The topic description appears in the Chat Room List dialog box next to the room’s name.



Specifies whether the room is moderated. 

In a moderated chat room, only a room host and the speakers the host designates can send messages. All other room members 

are spectators. Only a room host can select this box. 



Specifies whether anyone, or only a room’s host, can set the room’s topic. Only a room host can select this box.



Specifies whether an invitation from the room host is required to enter the room. Only a room host can select this box.



Specifies that only people in this chat room will see the room in the Chat Room List dialog box. Only a room host can select this 

box.



Specifies whether information about who is inside the room is available to people outside the room. Only a room host can select 

this box.



Specifies whether the number of people allowed into the room is limited. After selecting the Set maximum users check box, 

type the greatest number of people allowed. Only a room host can select this box.



Chat Options (Comics View tab)



Specifies the number of comic strip panels to be displayed in a single row.



 Chat Options (Settings tab)



Specifies whether Microsoft Chat-specific information will be sent to the people you're talking to. This feature is useful when 

chatting with members using text-only chat programs.



Specifies whether you want to be prompted to save a copy of your conversation whenever you close a Microsoft Chat window.



Specifies whether you want to be able to receive "whispers."

Whispers are messages that only you and the person who sent the message can see.



 Chat Options (Character tab)



Lists the available cartoon characters. Click a character to see what he, she, or it looks like.



Displays the cartoon character you selected from the character list, with the expression you selected by using the emotion wheel.



Adjusts the cartoon character’s expression. 

You can drag the large black dot around the emotion wheel to change the character’s expressions.



 Chat Options, Text View tab, Set Font Text dialog



Lists the available fonts.



Lists the available styles for the selected font.



Lists the available point sizes for the selected font.



Displays what the text will look like after the selected font options are applied.



Lists the available foreign language support installed on your computer.



 Chat Options (Background tab)



Lists the available cartoon backgrounds. 

Click a background to see what it looks like.



Displays the selected background.



Room List dialog



Provides a space for you to type words or a portion of a word that matches all or part of the room name you are looking for in the 

Room list. 

Only room titles with words that match will appear in the Chat Room List dialog box. 



Specifies whether you also want to search the Topic list for the words you typed in the Display chat rooms that contain box.

Only rooms that have titles or topics with words that match will appear in the Chat Room List dialog box.



Updates the Chat Room List by asking the chat server for a current list of rooms.



Takes you to the selected room.



Creates a new chat room.

You automatically become the host of rooms you create.



Chat Connection dialog (Connection tab)



Lists the available chat rooms you've added to your Favorites list.



Provides a space for you to type the name of a chat server you want to connect to.



Specifies that you want to enter a particular chat room and provides a space for you to type its name.



Specifies that you want to see a current list of every chat room that is available on the server.



Invite dialog



Provides a space for you to type the nicknames of people you want to invite into the room. 



Kick dialog



Provides a space for you to type the reason you are removing someone temporarily from the room.

Microsoft Chat displays your reason to everyone in the room. “Kicking someone out” is effective only until the person rejoins the 

room. 



Specifies whether you also want to ban the person you are kicking out of the room. 

A banned person cannot re-enter the room until you remove the ban or until the room is recreated, at which time the ban list is 

cleared. 



Provides a space for you to select or type the identity of the person you want to ban or readmit to the chat room. 



Specifies that you want to ban the person whose name appears in the Person to ban or unban box. Only a room host can 

select this box.



Specifies that you want to remove the ban from the person whose name appears in the Person to ban or unban box. Only a 

room host can select this box.



Chat Options, Settings tab



Provides a space for you to type the locations of your sound files. Microsoft Chat can send or play only sounds it finds in these 

folders. You can list several folders, separated by semicolons—for example, c:\windows\media; c:\windows .



Specifies whether to show the arrival and departure of people from your room.



Chat Options, Text View tab



Specifies that a blank line should appear between each message in text-only mode.



Specifies that a blank line should appear between messages that are not of the same type in text-only mode.

Actions, thoughts, and whispers are examples of different message types.



Specifies that a blank line should not appear between messages in text-only mode.



Click this to change the fonts used to display messages on your computer.



Resets the fonts used to display messages to their default settings.



Specifies whether to display room host message headers with a bold font.



Specifies whether to display room host messages with a bold font.



User List



Specifies that you want to search for every person connected to the server.



Lists the nickname and identity of every person that matches the search criteria you specified.



Specifies that you want to search for every person having a nickname that contains the text you type in the Names containing 

box.



Specifies that you want to search for every person with an identity that contains the text you type in the Names containing box.



Invites the person you selected from the Nickname list to enter the current room you are in. 



Opens the Whisper Box, in which you can "whisper" to the person you selected from the Nickname list.

Whispers are messages that can be seen only by the person sending the message and the person receiving it.



 Set Text Font dialog    (???--not hooked up, or if hooked up, not exactly this text??)



Specifies whether a line is drawn through the selected font.



Specifies whether the selected font is underlined.



Lists the available colors for the selected font.



Shows how the different message and header types will look.



Lists the available message and header types.



Play Sound dialog



Lists the available sound files.



Provides a space for you to type a message that will be sent with the selected sound.



Plays the selected sound.



Chat Options, Settings tab



Specifies whether you want to be able to receive invitations to join other chat rooms.



Chat Options, Auto tab



Specifies that you do not want to automatically send greetings to people as they enter the room.



Specifies that you want to automatically send a whispered greeting to individuals as they enter the room. Type the message you 

want whispered in the text box.



Specifies that you want to automatically send a greeting as people enter the room. Type the message you want sent in the text 

box. Everyone in the room will see the greeting.



Provides a space for you to type a message that will automatically be sent to people as they enter the room. You can use 

variables for the name and room as indicated in the sample text.



Lists the available key combinations you can use to run a macro. Select a key combination, and then type the message you want 

to associate with it in the text box.



Provides a space for you to type a message you want sent whenever you press the key combination associated with it.



Provides a space for you to type a name for a macro you create. A macro consists of a message you type plus the key 

combination associated with it.



Saves the macro identified in the Name box. You must add the macro before you can use it.



Deletes the macro identified in the Name box. You need to select the macro in the Key combination box before deleting it.



Chat Options, Personal Info tab



Provides a space for you to type your e-mail address. The e-mail address must be in the format name@company—for example, 

someone@microsoft.com. 

If other members want to send you e-mail, Microsoft Chat provides this e-mail address.



Provides a space for you to type the URL (address) for your World Wide Web home page. 

If other members want to view your Web page, Microsoft Chat provides this URL.



Chat Options, Settings tab



Specifies whether to display the identity of each of the members when they enter the chat room (text view only).



Specifies whether to play sounds sent by other members.



Specifies whether you want to be notified of incoming Microsoft NetMeeting calls. If you clear this check box, your computer 

ignores other members’ attempts to place a NetMeeting call to you.



Room List



Specifies that you want to display only rooms that are registered. 

Rooms are usually registered by the administrator of the chat server or the Internet service provider. Administrators can choose 

not to register rooms that might contain objectionable or offensive names or topics.

By displaying only registered rooms, you might avoid objectionable or offensive chat rooms.



Provides a space for you to type the smallest chat room you want to display in the Chat Room list. 



Provides a space for you to type the largest chat room you want to display in the Chat Room list.



Provides a space for you to type the name of the room you want to create. 



Provides a space for you to type a password that others must use to access this chat room. The password is case sensitive, so 

members must type the password with the same characters and the same case as you have typed them.



Specifies whether you want to be notified when someone attempts to send you a file. If you do, Microsoft Chat will ask you 

whether you want to receive the file and where you want to store it on your computer. If you clear this check box, your computer 

ignores other members’ attempts to send you files.



Specifies whether rich text formatting (for example, color, bold, and italic) in a sent message is displayed in Comics view. If this is 

box selected and the message sent to you has been formatted, it will be displayed as such. Otherwise, all messages in Comics 

view are displayed in a uniform format.



Specifies that you want Chat to automatically ignore a person who sends a flood of messages, multiple lines of text sent in rapid 

succession. You define exactly what constitutes a flood by setting Message Count and Interval. 



Specifies the number of messages that constitute a flood.



Specifies the interval in seconds at which the number of messages specified above must be sent to constitute flooding.



Connects you to the same chat room as the person whose nickname you have selected.



Displays a message published by the chat server you are connecting to. The message typically contains information about 

server status and other news.



Specifies that you want to display the Message of the Day from the chat server each time you connect to the server.



Specifies whether you want the speaker's name on one line and the message on the next. If you clear the check box, the 

speaker’s name appears on the same line as the message.



Help is available for each item in this group. Click        at the top of the dialog box, and then click the specific item you want 

information about.



Provides a space for you to type a message that is sent to all of the rooms you are in, indicating that you are away. Your icon in 

the list of members changes to a teacup.



Provides a way to help you control the types of content that your computer can access on the Internet. 



Click this to turn Content Advisor on and off.



Click this to modify the Content Advisor settings.



Specifies whether your name appears in the list of all the users on the server. 



 



Introducing Microsoft Chat

Microsoft Chat is the only Internet chat program that gives you the option of conversing inside a comic strip. As with a standard 

chat program, you can enter a chat room on an Internet server and conduct real-time conversations with other people. But with 

Microsoft Chat, you can also pick a cartoon character to represent you, and your conversation appears as word balloons inside 

the frames of a comic strip. As a cartoon character, you can express a wide range of emotions, send "thoughts," whisper to a 

single recipient, and save the chat session for offline viewing.
Send hyperlinks in your conversation—for e-mail addresses, Web pages, FTP sites, and newsgroups.
Send and receive requests to play sounds.
Send and receive files.
Use another program, such as Microsoft NetMeeting, to communicate using video and audio outside the chat room with a 

chat room member, while also conversing in the chat room with them.
Save or print your chat conversation for publication or offline viewing.
Filter which chat rooms are displayed on your computer by size, content, or ratings.
Host your own chat rooms, and control access, size, and content.

Note
For more information on Microsoft NetMeeting, go to the NetMeeting Web site.



Getting started with Microsoft Chat

Microsoft Chat provides a place for you to talk with other people on the Internet, using either text or cartoon characters to convey 

your thoughts. To get started, you must have an Internet connection, which links you to a computer (that is, a server) that 

contains chat rooms. You follow these basic steps to enter into a chat:
Log onto a chat server.
Select the room you want to go to on that server.
Start typing a chat message.

The following topics explain how you get started using cartoon characters to talk in a comic strip.

Basic setup

{button ,JI(`',`cchat_profile')}    Provide information about yourself

{button ,JI(`',`CCHAT_SPEC_CHAR')}    Choose a character

{button ,JI(`',`CCHAT_DEF_BACK')}    Choose a comic background

{button ,JI(`',`cchat_connect_server')}    Connect to a chat server

Chatting with someone

{button ,JI(`',`cchat_find_right_room')}    Finding a chat room to join

{button ,JI(`',`cchat_change_place')}    Enter a chat room

Exiting a chat room

{button ,JI(`',`cchat_exit')}    Leave a chat room

{button ,JI(`',`cchat_save')}    Save a conversation



To connect to a chat server

1 Establish a connection to the Internet via your modem or a local area network.

2 On the Start menu, point to Programs, point to Internet Explorer, and then click Microsoft Chat. 

3 In the Chat Connection dialog box, type or select the name of the chat server in the Server box. 

4 Either click Go to chat room and type the name of the chat room, or click Show all available chat rooms so you can select 

one.

If this is the first time you are using Chat, you should indicate your personal information, your character choice, and a comic 

background on the other tabs in the Chat Connection dialog box. For more information, click Related Topics below.

Note
If Microsoft Chat is already open, you can click the Room menu and then click Connect to connect to a chat server.

{button ,AL("charspec;profile;background")} Related Topics



To provide information about yourself

1 On the View menu, click Options.

2 In the Nickname box, type a name you’d like to be known by.

3 In the Brief description of yourself box, type something that you’d like other people to know about you. This information 

appears when other people request your profile.

Tips
You can make it easy for others to send you e-mail or visit your World Wide Web home page by including your e-mail 

address and home page URL (address) in your personal information.
For Help on an item, click 

    at the top of the dialog box, and then click the item.

{button ,AL("charspec ")} Related Topics



To chat using text only

1 On the View menu, click Plain Text.

2 In the text box at the bottom of the window, type what you want to say, and then click one of the buttons to the right of the text 

box, or press ENTER.

If you click this Your message appears with your 

nickname, followed by

Say The word "says" and your message.

Think The word "thinks" and your message.

Whisper The words "whispers to" and the other 

person's nickname and your message. 

The message is sent only to people you 

have selected in the list of members.

Action Your message, displayed in italics.

Play Sound Your message and the name of the sound 

file. Other chat members must have that 

sound file on their computers in order to 

hear it.

{button ,AL("whisperto;comictalk;sound;soundset;textfont;a-mschat-format-text")} Related Topics



To change fonts used in text-only conversations

1 On the View menu, click Options.

2 On the Text View tab, click Change Font.

3 In the Choose a message type to change its font list, click a message type.

Examples of message types and their current font settings appear in the box below the list.

4 Click the font and other settings that you want.

Tip
For Help on an item, click 

    at the top of the dialog box, and then click the item.

{button ,AL("talk;a-mschat-format-text")} Related Topics



To choose a character

1 On the View menu, click Options.

2 Click the Character tab. 

3 In the Character list, click the character you want. Your character appears in the Preview area.

Tip
To see your character with different emotions, drag the black dot in the center of the emotion wheel to different positions.

{button ,AL("wheel;gesture")} Related Topics



To choose a comic background

1 On the View menu, click Options.

2 Click the Background tab.

3 In the Background list, click the background you want. The background you select appears in the Preview area. 



Customizing comic strip text

You can change the look of the text in the comic strip balloons in a number of ways:

{button ,JI(`',`mschat_font_comic')}    Change the comic strip font

{button ,JI(`',`mschat_format_text')}    Format message text

{button ,JI(`',`cchat_rtf')}    Display rich text in the comic strip



To change the comic strip font

1 On the View menu, click Options.

2 On the Comics View tab, click Change Font.

3 Click the font and other settings that you want.

Tips
You can view formatted text (for example, bold or colored) in the comic strip by selecting the Show rich text formatting 

check box. For more information, click Related Topics below.
For Help on an item, click 

    at the top of the dialog box, and then click the item.

{button ,AL("comictalk;a-cchat-rtf")} Related Topics



To format message text

In your message, select the text you want to format, and then use one or more of the commands on the Format menu to 
add these effects:

Color (choose from the palette)
Bold
Italic
Underline
Fixed pitch font
Symbol font (Symbol font)



To display rich text on your computer

1 On the View menu, click Options.

2 On the Comics View tab, select the Show rich text formatting check box.

Notes
Earlier versions of Microsoft Chat cannot display rich text.
If the Show rich text formatting check box is clear, you can still send formatted text; you will just not see in it your own 

comic strip.



Using sounds with Chat

You may want to use sound to accent the    messages you send. You cannot actually send a sound file, but rather a request to 

play a sound file, specifically a .wav file, located on the recipient’s computer. Conversely, if someone wants to include a sound 

with their message to you, the sound file must already be located on your computer. 

When Windows was installed on your computer, several sound files were also installed. Most Microsoft Chat room users will 

have a similar set of files on their computers also. When you send or receive a request for a sound, Chat is limited to the .wav 

files in the folder you have specified.

The following topics provide more information:

{button ,JI(`',`CCHAT_SEND_SOUNDS')}    Send sounds to other people

{button ,JI(`',`CCHAT_SOUNDSET')}    Specify where sounds are located on your computer



To specify where sound files are located on your computer

1 On the View menu, click Options.

2 Click the Settings tab. 

3 In the Sound search path box, type the location on your computer where you want Microsoft Chat to look for sound (.wav) 

files.

You can have Chat look in more than one folder for sound files. Separate each directory with semicolons—for example, c:

\windows; c:\windows\media. 

{button ,AL("sounds")} Related Topics



Finding a chat room to join

You can find chat rooms to join on a chat server. Or, depending on your service provider, you may be able to start your own chat 

room. On a chat server, you can look through the room list for a chat room, or you can type the name of a specific chat room. 

You can even look for a specific person on the server and join them in the room they are in. And when you find a chat room you'd 

like to return to, you can add it to your Favorites list.

If you don't find anything you like in your current chat server, you can check other chat rooms on different servers. Or you can 

host your own chat room. 

The following are strategies for finding a chat room:

{button ,JI(`',`CCHAT_CHANGE_PLACE')}    Enter a chat room

{button ,JI(`',`CCHAT_WHOIS')}    Find other people

{button ,JI(`',`CCHAT_ADD_FAV')}    Add a chat room to your Favorites list

{button ,JI(`',`cchat_host_yourown')}    Host your own chat room



To enter a chat room 

1 On the File menu, click New Connection.

2 In the Server box, type or select the name of the server that contains the chat room you want to enter—for example: 

comicsrv1.microsoft.com

3 If you know the name of the chat room you want to go to, click Go to chat room, and then type the name of the chat room you 

want to enter. If you type the name of a chat room that does not exist, Microsoft Chat creates a new chat room with that name.

If you want to pick a chat room from the room list, click Show all available chat rooms. You might be able to screen out chat 

rooms that might contain inappropriate or offensive names or topics by selecting the Show only registered rooms check box. 

Rooms are registered by the Internet service provider or system administrator, so depending on how closely they monitor 

names and topics, some inappropriate material may slip through.

Tips
To find a specific chat room by room name, type a word or a portion of a word in the Display chat rooms that contain 

box, attempting to match all or part of the room name you are looking for. If you also want to search chat room topics, select the 
Also search in room topics check box.

You can be in more than one chat room at a time as long as the chat rooms are on the same chat server. If you want to 
participate in a second chat on a different server, you must open another instance of Microsoft Chat.

For Help on an item, click 
    at the top of the dialog box, and then click the item.

{button ,AL("a_cchat_find_right_room;favorite")} Related Topics



To enter a favorite chat room

On the Favorites menu, click Open Favorites, and then double-click the room that you want to enter.

{button ,AL("a_cchat_find_right_room;change")} Related Topics



Hosting your own chat room

If you cannot find a chat room that's just right for you, it's easy to create and host your own. When you host your own chat room, 

you can decide the topic, control access, and limit the number of members in the chat room. You can even kick out or ban 

members who are disruptive or offensive.

{button ,JI(`',`cchat_create_new')}      Create a chat room

{button ,JI(`',`cchat_customize')}      Customize your chat room 

{button ,JI(`',`cchat_make_admin')}      Allow others to host your chat room 

{button ,JI(`',`cchat_ban')}      Ban someone from a chat room 

{button ,JI(`',`cchat_kick_out')}      Kick someone out of a room temporarily



To create a chat room

1 On the Room menu, click Create Room.

2 Type a name for the chat room.

3 In the Chat room topic box, type a description of the chat topic for your room.

Note
You automatically become the host of any room you create. 

{button ,AL("a_cchat_host_yourown")} Related Topics



To customize your chat room 

You must be the host of a room to customize it.
On the Room menu, click Room Properties, and then select the room properties you want.

Tip
For Help on an item, click 

    at the top of the dialog box, and then click the item.

{button ,AL("a_cchat_host_yourown")} Related Topics



To keep everyone’s backgrounds in sync

On the Member menu, click Host, and then click Sync Backgrounds.

From this point on, the background in the comic strip will be the one you, the host, have chosen, overriding the individual 

choices of the other room members. 



To send automatic greetings to new room members

1 On the View menu, click Options.

2 Click the Automation tab.

3 In the Automatic greeting area, select how you want to send the greeting.

To send the greeting only to the person entering the room, click Whispered. 

To send the greeting to everyone in the room each time someone new enters, click Said.

4 In the text box, type the message you want to send.

Tips
You can use the special text %name and %room to personalize your greeting. Microsoft Chat substitutes the person’s 

nickname wherever it finds %name, and your room’s name wherever it finds %room.
For Help on an item, click 

    at the top of the dialog box, and then click the item.

{button ,AL("customize")} Related Topics



To kick someone out of a chat room temporarily

1 In the list of members, select the person you want to "kick out" (remove temporarily).

2 On the Member menu, click Host, and then click Kick.

3 In the Why are you kicking (nickname) box, type the reason you are removing the person from the chat room. The reason 

you type will appear to other members of the room.

Notes
"Kicking someone out" does not prevent them from re-entering the chat room. If you want to permanently ban someone, 

click Related Topics below.
Only a chat room host can kick someone out of a room.

{button ,AL("a_cchat_host_yourown")} Related Topics



To ban someone from a chat room permanently

Banning someone prevents that person from re-entering the room until you "unban" them.

1 In the list of members, select the person you want to ban.

2 On the Member menu, click Host, and then click Ban / Unban.

Notes
Only a chat room host can ban someone from a room.
If everyone leaves the room and then someone creates the room again, the ban list will be clear.

{button ,AL("a_cchat_host_yourown;a-mschat-remove-ban")} Related Topics



To remove the ban on someone

1 On the Member menu, click Host, and then click Ban / Unban.

2 Select the name of the banned person from the list, and click Unban.



To find other people

1 On the Member menu, click User List.

2 In the Search for area, define what you want to search for; to narrow down the search, you can type text to search for in the 

Names containing box.

3 Click Update List.

Tips
If a person is listed in the User List dialog box, you can whisper to them, send invitations to them, or join them in their chat 

room—even if they are in a different chat room than you are—by clicking the appropriate button at the bottom of the dialog box.
You can click the column headings in the User List to organize the listing alphabetically by room name or topic, or 

numerically by number of members in a room.
For Help on an item, click 

    at the top of the dialog box, and then click the item.

{button ,AL("a_cchat_find_right_room")} Related Topics



To get information about other people

In the list of members, right-click the person you want to get information about, and then click Get Profile.

This information appears only on your screen.

{button ,AL("profile")} Related Topics



To chat inside a comic strip

1 On the View menu, click Comic Strip.

2 In the text box at the bottom of the window, type what you want to say, and then click one of the buttons to the right of the text 

box, or press ENTER.

If you click this Your message appears like this

Say Inside a word balloon.

 

Think Inside a word balloon with "thought" 

bubbles leading to it.

Whisper Inside a word balloon surrounded by a 

dotted line. The message is sent only to 

people you’ve selected in the list of 

members.

Action Inside a box across the top of the comic-

strip pane. Your message begins with 

your nickname.

Play Sound Inside a box across the top of the comic-

strip pane. It begins with your nickname, 

followed by your message and the name 

of the sound file. Other chat members 

must have that sound file on their 

computers in order to hear it.

Tip
If you select someone in the list of members before sending a message, Microsoft Chat poses your character to appear to 

be talking directly to the other character.

{button ,AL("wheel;gesture;expchange;whisperto;sound;soundset;talk;comicfont")} Related Topics



To use character gestures

When you begin a sentence

with these words Your character does this

I Points to himself or herself

You Points to the other person

Hello or Hi Waves

Bye Waves

Welcome Waves

Howdy Waves

When your sentence

contains these words Your character does this

are you Points to the other person

will you Points to the other person

did you Points to the other person

aren't you Points to the other person

don't you Points to the other person

I'm Points to himself or herself

I will Points to himself or herself

I’ll Points to himself or herself

I am Points to himself or herself

When you type this Your character displays this emotion

All capitals Shouting

!!! Shouting

ROTFL ("roll on the floor laughing") Laughing

LOL ("laugh out loud") Laughing

:)    or    :-) Happy

:(    or    :-( Sad

;-) Coy

{button ,AL("wheel;expchange")} Related Topics



To whisper to other people

1 In the list of members, select the people you want to whisper to. To select more than one name, press and hold down the 

CTRL key while you click.

2 In the text box at the bottom of the window, type what you want to say, and then click the Whisper button.

Your message appears only to the people you selected.

Tip
You can also send whispered messages by using the Whisper Box. This enables you to keep track of several whispered 

conversations at the same time. For more information, click Related Topics below.

{button ,AL("a_cchat_meet_beyond")} Related Topics



To send sounds to other people

1 Click the Play Sound button at the bottom of the Microsoft Chat window.

2 In the Sound file to play list, click the sound file you want other people to hear.

3 In the Accompanying message box, type a message to send with the sound you selected.

Notes
To hear your sound before you send it, click Test.
Other people can hear sound files only if the files are already on their computers. For more information, click Related 

Topics below.

{button ,AL("sounds")} Related Topics



To leave a chat room

On the Room menu, click Leave Room.

After you leave a room, you are still connected to the chat server.



To save a conversation

1 On the File menu, click Save.

2 Double-click the folder you want to save the conversation in.

3 In the File name box, type a name for the conversation, and then click Save.

Tips
When you are in Plain Text view, you can save a conversation as an .rtf (Rich Text Format) file. All character formatting is 

saved, including font, color, size, and style. 
By saving conversation files offline, you can view and print chat-room sessions and share them with your friends.

{button ,AL("offline")} Related Topics



Meeting beyond the chat room

There are several ways you can communicate privately with chat room members, some within Microsoft Chat, and some using 

other Internet programs. Just right-click a person in the list of members to see what options are available. 

{button ,JI(`',`CCHAT_WHISPER_TO')}    Whisper to other people

{button ,JI(`',`MSCHAT_WHISPER_BOX')}    Whisper to more than one person at a time

{button ,JI(`',`cchat_dcc')}    Send a file to a chat room member

{button ,JI(`',`cchat_place_netmeeting_call')}    Place a NetMeeting call to a chat room member

{button ,JI(`',`cchat_send_mail')}    Send e-mail to a chat room member

{button ,JI(`',`cchat_view_web_pages')}    View another member's web page



To send e-mail to a chat room member

In the list of members, right-click the person you want to send an e-mail message to, and then click Send E-mail.

{button ,AL("a_cchat_meet_beyond")} Related Topics



To send a file to a chat room member

1 In the list of members, right-click the person you want to send a file to, and then click Send File.

2 Specify the file you want to send.

Notes
File transfer may not work across some corporate “firewalls.” If you have difficulty sending files, consult your system 

administrator.
You can set Microsoft Chat to refuse all incoming file transfer requests. For more information, click Related Topics below.

{button ,AL("cchat_dcc_refuse;a_cchat_meet_beyond")} Related Topics



To place a NetMeeting call to a chat room member

In the list of members, right-click the person you want to place a Microsoft NetMeeting call to, and then click NetMeeting.

Currently, placing a NetMeeting call to a chat room member is possible only if you both are using Microsoft Chat version 2.0 or 

higher.

Notes

Both you and the person you are placing the call to must have NetMeeting installed. 
You can set Microsoft Chat to ignore incoming NetMeeting calls. For more information, click Related Topics below.

{button ,AL("a_cchat_ignore_netmeeting_call;a_cchat_meet_beyond")} Related Topics



To view the Web page of a chat room member

In the list of members, right-click the person, and then click Visit Home Page.

{button ,AL("a_cchat_meet_beyond")} Related Topics



To send a link in a message

In the text box at the bottom of the window, type what you want to say, using the appropriate syntax for the type of link.

To link to a Web page, type http://website    where website represents the URL (address) of the Web page.

To link to an FTP site, type ftp://ftpaddress where ftpaddress represents the URL (address) of the FTP site.

To link to a newsgroup, type news: newsgroup where newsgroup represents the name of the newsgroup.

To send a link to a new mail message, type mailto:someone@company.com where someone@company.com represents the 

e-mail address of the person the message is to be sent to.

{button ,AL("a_cchat_meet_beyond")} Related Topics



To have multiple whispered conversations

You can have multiple whispered conversations with members in your chat room and with other people on the chat server.
To whisper separately to several people in your chat room, in the list of members, right-click the name of a person, and 

then click Whisper Box. Repeat for each person you want to whisper to.

If you want to have a single whispered conversation with several members at the same time, select each member, type your 

message, and then click the Whisper button to the right of the text box at the bottom of the window.
To whisper to someone on the chat server, in the User List, click that person’s nickname, and then click the Whisper Box 

button.

Tip

In the Whisper Box, you can easily switch between whispered conversations by clicking the name of the person you want 
to whisper to.

{button ,AL("a_cchat_meet_beyond")} Related Topics



To create a message macro

You can use macros to send the same message many times without retyping it each time—for example, "Where are you from?"

1 On the View menu, click Options.

2 Click the Automation tab.

3 In the Key combination list, select the key combination you want to use to run the macro.

4 In the Name box, type a name for the macro.

5 In the Macros box, type the message you want to send.

{button ,AL("keyboard")} Related Topics



To send a cartoon character expression without talking

1 In the emotion wheel, drag the black dot to an emotion.

2 Right-click the emotion, and then click Send Expression. 

The expression appears in the most recent comic strip pane.

{button ,AL("wheel;gesture")} Related Topics



To ignore a person

In the list of members, right-click the person you want to ignore, and then click Ignore.

You will no longer see messages from this person. Other members of the chat room will still continue to see them.

{button ,AL("whisperto")} Related Topics



To invite others into a chat room

1 On the Member menu, click Invite.

2 Type the nicknames of people you want to invite into the chat room. 

Tip

To invite more than one person at a time, type a comma ( , ) between nicknames.

{button ,AL("a_cchat_host_yourown")} Related Topics



To add a chat room to your Favorites list

While in the chat room, click the Favorites menu, and then click Add to Favorites.

{button ,AL("a_cchat_find_right_room")} Related Topics



To read conversation files offline

1 On the File menu, click Open.

2 Double-click the conversation file that you want to read offline.

Note

You can only read previously saved conversation files.

{button ,AL("save")} Related Topics



Microsoft Chat keyboard shortcuts

You can use shortcut keys to choose commands, format text, and send information.

To do this in the compose pane Press this

Select all text in the pane. CTRL+A

Copy selected text to the Clipboard. CTRL+C

Cut the selected text and place on the 

Clipboard.

CTRL+X

Paste text you've copied into the 

compose pane.

CTRL+V

Undo the most recent action in the 

compose pane.

CTRL+Z

Send the contents of the compose 

pane.

CTRL+Y

Send the contents of the compose 

pane as a thought.

CTRL+T

Send the contents of the compose 

pane as a whisper.

CTRL+W

Send text as a caption (action) to the 

comic strip pane.

CTRL+J

Play a sound. CTRL+H

Make the selection bold. CTRL+B

Make the selection italic. CTRL+I

Underline the selection. CTRL+U

Give the selection a color. CTRL+K

Format the selection in a fixed pitch 

font.

CTRL+F

Format the selection in the Symbol 

font.

CTRL+D

To do this in Microsoft Chat Press this

Open a new connection after 

disconnecting from another. 

CTRL+N

Open a file. CTRL+O

Print a file. CTRL+P

Open the Microsoft Chat Options 

dialog box.

CTRL+Q

Save a file. CTRL+S

{button ,AL("macro")} Related Topics



To define the size of the comic strip

1 On the View menu, click Options.

2 Click the Comics View tab.

3 In the Page layout list, click the number of comic strip panels you want to display across the window.



To change a character’s emotion

Drag the black dot in the center of the emotion wheel around the wheel. The closer to the edge of the wheel you move the 
dot, the stronger the emotion.

You can choose eight different emotions for your character:

Shouting Angry

Happy Laughing

Bored Scared

Sad Coy

The pane above the emotion wheel displays your character's current emotion. 

Tip

Not all characters can display the full range of emotions.

{button ,AL("expchange;a-mschat-freeze-emotion;gesture")} Related Topics



To freeze a character's emotion

Right-click your character in the self-view pane and then click Frozen. The expression will not change until you click 
Frozen again or drag the black dot in the emotion wheel to a different location, at which time this new emotion is frozen.

Freezing an emotion is useful if you want to lock one of several neutral expressions (if your character has more than one), or 

avoid the default expressions associated with various grammatical structures (click Related Topics).

{button ,AL("gesture")} Related Topics



To allow others to host your chat room

1 In the list of members, select the person you want to make a host.

2 On the Member menu, click Host, and then click Host.

Notes

Only a chat room host can select other people to become hosts. 
A chat room can have any number of hosts; all of these hosts are then able to change room properties.

{button ,AL("a_cchat_host_yourown")} Related Topics



To ignore incoming NetMeeting calls

1 On the View menu, click Options. 

2 On the Settings tab, make sure the Receive NetMeeting Calls check box is clear.

{button ,AL("a_cchat_place_netmeeting_call")} Related Topics



To refuse all incoming file transfer requests

1 On the View menu, click Options. 

2 On the Settings tab, make sure the Receive file transfer requests check box is clear.

{button ,AL("a_cchat_dcc")} Related Topics



To track activity in multiple chat rooms

Take note of a color change in a room’s tab in the main window. 

If you have several open chat rooms that overlap, you can see when there is activity in a room because the color of the room 

name on the tab will change. 



To notify others when you are away

1 On the Member menu, click Away from Keyboard.

2 Type the message you want to publish to members currently in the room and to new members when they enter the room.

A coffee-cup icon now appears next to your name in the list of members.

Note
Repeat the procedure above to notify members of your return to the chat room.



To ignore a person sending floods of messages

1 On the View menu, click Options.

2 On the Automation tab, select the Auto ignore enabled check box to ignore a person who is sending a flood of messages to 

you.

3 Define what you want to constitute a “flood” by setting the Message Count and Interval dials.






