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What the press is saying

· “...walks you through the creation of Windows help files in a visual step-by-step process” - PC 
Magazine.

· “Fun and simple to use...” - Visual Basic Programmer's Journal.

· “You don't have to be a programmer to create professional quality help files.” - Windows 
Magazine.

· “We were very impressed with Visual Help because of its simplicity and its completeness.” - 
Windows Tech Journal.



Introduction

Welcome to Visual Help, the Windows WYSIWYG help authoring system. 

Microsoft Windows has become one of the most popular working environments for personal 
computers today, due in large part to its ease of use. One particular feature that contributes to 
Window's user friendliness is its on-line help. On-line help provides quick and easy access to 
information about the features and operation of Windows applications. On-line help systems add 
professional polish to software programs and make them easier to use. Visual Help is a powerful, 
easy-to-use development environment that you can use for creating Windows help files.
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About Visual Help

A powerful easy to use help development tool
Compared to conventional methods of creating Windows help files, Visual Help's intuitive drag-and-
drop interface makes the assembly of help systems fast and easy.    Visual Help not only streamlines 
the process of creating Windows help files, but many other on-line documents as well.

Easily create on-line documents of all types:

· Procedures Manuals

· Company Databases

· Multimedia Presentations

· Information Guides

· Readme Files

· Shared Network Information

· Electronic Books

· On-line Tests

Compatible, Portable, and Sharable
Any personal computer running Windows can open help files created with Visual Help. WinHelp (the 
Windows help system driver supplied with Windows) is all that is required to run your compiled Visual 
Help projects, making them extremely portable. Visual Help documents are also easily shared across 
a Windows-based network, making updates less time consuming.



What is a Windows Help File?

Windows Help Engine:
To provide an efficient and consistent method of providing help to users of Windows-based 
applications, Microsoft has devised a system that centers around WinHelp. The WinHelp application 
is referred to as the engine of the help system because it starts up whenever the user requests help. 
Every time a user opens a help file, Windows starts WINHELP.EXE to load WinHelp.

Windows Help File:
The WinHelp engine opens the Windows help files you will create with Visual Help.    These help files 
have a very specific format and can be    recognized by their HLP extensions. Most Windows based 
systems contain one or more help files for each application installed, but typically just the one copy of 
WinHelp. In fact,    WinHelp is included in Windows setup, and its existence can be expected on any 
system that is running Windows.



System Requirements

Before installing Visual Help, check that your computer does meet the following minimum 
requirements:

· A personal computer using a 80286 or higher micro-processor is required.

· 2 MB of    available memory

· VGA, SVGA, XGA, 8514/A or compatible video graphics adapter

· Hard disk with at least 3 MB available

· Mouse of    equivalent pointing device

· MS-DOS version 3.1 or later

·  Microsoft Windows version 3.1 or later



Installation

To install Visual Help:

1 From the Window's Program Manager, choose Run from the File menu.

2 Type A:SETUP.EXE or B:SETUP.EXE depending on the designation of your floppy disk drive.

3 Respond to the prompts presented, and Visual Help will be installed to your hard drive.



Product Support

Product Support for Visual Help is available to registered users through the WinSIG Bulletin Board 
System and through Compuserve.    Please note Visual Help Technical Support some where at the 
beginning of all your messages.

WinSIG BBS
(714) 363-9802          2400/9600/14400 N-8-1
Please direct your questions to the sysop by selecting 'C' for comments from the main menu.

Compuserve
Please direct your questions to:
WinWare Inc.
Compuserve ID# 70272,1656

Internet
For technical support via Internet, write to 702721656@compuserve.com.



Testing a Project

Runtime Start

At any time during the construction of the help project you can test jumps by clicking on the runtime 
start button on the main window toolbar. The contents topic is displayed similarly to the way it looks 
when the compiled version is opened by the user. Be sure that jumps are in place from the contents 
topic to the sub-contents and regular topics that you wish to test. 

Runtime Stop

Click the runtime end button      to halt the simulation and return to the development environment. 
This button is located to the right of the runtime start button.

Note: The runtime test will accurately simulate most of the features within your help file such as 
jumps, text appearance, and image placement.    However, it may not be suitable for testing some of 
the more advanced features in your help file such as macros, non-scroll areas, buttons, or 
glossaries.    To test any advanced features, you will need to compile your project, and run the help 
file.
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Compiling a Project

After thoroughly testing your help project, you can proceed to compile it and see how the finished 
help file works. Visual Help automates this process with the All of the Above command under the 
Compile menu; also available with the toolbar button. After the help file is compiled, WinHelp will 
open and display the finished help file in its own window.

Build Process Flow

Note: Before you compile the project, make sure you have a copy of the Microsoft Windows Help 
Compiler version 3.1 or higher. The file is named HC31.EXE or HCP.EXE.    This compiler takes the 
information from your Visual Help project and converts it into a format recognized by WinHelp. You 
can modify the path and file name Visual Help uses when compiling help files by, choosing the 
Environment item from the Options menu. Type in the path and file name of the compiler in the edit 
box labeled “Compiler” or click the      button to browse for it.



Environment Options

Environment options control various aspects of the Visual Help working environment that effect all 
Visual Help projects. Choose Environment from the Options menu to view and modify the following 
settings:

· Target File Format

· Help Compiler Selection

· Regenerate Context IDs



Project Options

Project options control how Visual Help files are created, processed, and optimized.    The most likely 
project options you'll need to adjust are the Title and copyright.    The Title option determines the title 
of the help file when it is opened, and the Copyright contains the text that will be displayed in the 
About Help window of WinHelp. To edit the either option, select it by clicking on it, and edit the 
existing value.



Import

You can reuse topics created in other Visual Help projects by using the Import feature.

To import topics into the current project:

1 Choose Import from the File menu.

2 Locate the desired Visual Help project (.VH) and click OK.

3 Select the topics to import from the list provided. Hold down the SHIFT key to select a 
continuous range of topics. Hold down the CTRL key to select multiple, discontinuous topics

4 If you want to import the glossary from the source project, check the Import Glossary 
checkbox.

5 Click Import to copy the topics into the current help project.

Note: If duplicate topic names are encountered, Visual Help will prompt you to rename the topic.



Export Include Files

An include file is generated by Visual Help for a programmer to include in a project to reference 
context IDs in the help file. By defining constants for the context IDs which use the name of the topic, 
the programmer can avoid problems which arise from changing context ID numbers. Include files can 
be created for BASIC, C/C++, and Pascal programmers.

To create an include file:

1 Choose Export from the File menu.

2 Select the Include File option and click Continue.

3 Select the appropriate development language and click Continue to advance to the next 
wizard window.

4 Enter the file name and path, then click Continue to create the file.



Export Manual

A word processing document can be generated from a help project, and can also be used to create a 
printed manual or be used as way to easily proofread all help topic materials. The document will be 
in RTF (Rich Text Format), which can be opened by many word processing programs including 
Microsoft Word.

To create a Manual File:

1 Choose Export from the File menu (the Export Wizard window will open).

2 Click on the Manual Document button, then click Continue.

3 Click the RTF file option, then click the Continue button.

4 Enter the desired file name, then click Continue to create the RTF file using the specified 
name.

During the export process, Visual Help's styles are translated as follows:

Title        »      Heading1
Heading      »      Heading2
Sub-heading  »      Heading3
Paragraph    »      Normal

Note: The structure of the manual will mirror the Visual Help outline view.



Editing Topics

Editing topics is usually where you will spend the majority of your time when developing a help file. 
The Topic Design Window includes many features that automate and assist you whenever you are 
editing a particular topic.

Adding a Topic
You can add a topic to your current project by:

· Clicking the new topic button from the main window toolbar

· Selecting the New Topic menu item from the File Menu

Removing a Topic
You can remove a topic by selecting the Remove Topic item from the File menu.    When selected, 
you will be prompted with a message box to confirm that you want to permanently remove the 
current topic.

Saving the Current Topic
You can save the current topic at any time by clicking the save toolbar button.

Closing the Current Topic
You can close a topic, by selecting the Close item from the system menu of the Topic Design 
Window.    This will also save the topic at the same time.    If you do not want to save changes made 
to the current topic, you can click the      button.

Browse Sequence
Visual Help automatically generates the Browse Sequence for you, as you develop your topics and 
assign links between them, Visual Help will assign the browse indexes depending on the hierarchy of 
the topics.
Note: topics that are only jumped to from within hypergraphics or by using the glossary window will 
not be assigned browse indexes since Visual Help cannot accurately determine their proper 
sequence.



Topic Properties

The Properties Window can be accessed from the Properties button on the Topic Design Toolbar.

Context ID:
You may enter up to a 7 digit numeric context ID that you can use to support a context sensitive 
application.

Topic Title:
By default, the Topic Title will have the same value as the Topic Name Field on the Topic Design 
Window; however, the two are not the same.    The Topic Name is only used within Visual Help to 
uniquely identify a topic.    The Topic Title is used to identify the topic within the compiled help file, 
and can also accept extended ASCII characters when it is necessary to produces non-English 
characters.

Context String:
The Context String field cannot be edited, but is automatically generated from the Topic Title.
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Topic Design Window

Topic Design Toolbar
The toolbar on the Topic Design window provides easy access to a number of commonly used topic 
specific commands.



Topic Keywords

WinHelp's search dialog relies on a keyword list to help the end user find topics based on words and 
phrases related to the topics. You can open Visual Help's help file by choosing Search from the Help 
menu (or by choosing Contents from the Help menu and clicking on the search button along the top 
of the window) to see an example of how this works. By default, Visual Help assigns all topic names 
to the keyword list, but you can add additional keywords by using the Keywords option.

To add a keyword:

1 Open the desired topic.

2 Click on the Keyword toolbar button.

3 If no keywords yet exist in the dialog for this topic, then just start typing in the first new 
keyword.    Otherwise, click on the insert button to enter a new keyword.

4 Repeat these steps for each keyword you want to add.



Topic Name

The topic name is used within Visual Help to uniquely identify a topic.    By default, the Topic Title is 
also set to the same value as the name; unless changed by the user.    The properties window can be 
used to modify the topic title.

Default Setting:
When you add a new topic, Visual Help will set its name to a default value.    This value is unique and 
initially set to Topicn, where n is 1, 2, 3, and so on.    Visual Help names the first topic Topic1, the 
second Topic2, and the third Topic3.    The default name can be kept as is, but when you have added 
several Topics, it makes sense to change their names to something more descriptive.

Setting the Title Object:
 You may notice that new topics always have a title object included.    This feature is provided for 
convenience as it does save a few steps when creating a new topic.    After you have created the new 
topic, the name field will be active,    you may type in the name, then press TAB to move to the Title 
object, and at the same time change the text of it to duplicate the topic name.



Attaching a Topic Note

Visual Help provides capabilities for attaching notes to individual topics to help remind you of 
changes or updates that need to be done, to communicate with another person working on the 
project, or store any other information related to the topic. This is a development tool available only 
while working in Visual Help; the end user won't see or have access to these notes.

To attach a note to a topic:

1 Open the topic.

2 Click on the Note button.
(The note edit window will appear, stamped with the current date and time).

3 Enter your note and close the dialog to save it.
(The note indicator will appear just to the right of the topic name field).

Note: If you want to edit or add to the note in the future, just click on the note button or the note 
indicator while the topic is open.



Setting the Nonscroll Area

Often a topic is too long to fit into one regular sized help window. If the help information extends 
below the bottom of the window, a scroll bar automatically appears that allows the user to view 
everything contained in the window by scrolling. It is often helpful in such topics to freeze the title to 
remind the user which topic is currently being viewed.

To set the non-scroll area:

1 Select the topic above where you want the non-scroll area to start.

2 Click on the non-scroll area button.

To remove the non-scroll area:

1 Click on the object above the line to select it.

2 Click on the non-scroll area button again to toggle it off.

Note: a line is placed into the topic showing the boundary between the non-scrolling and scrolling 
areas of the window; this line is not a line object. The non-scroll area will be functional only in the 
compiled help file.



Viewing and Printing Topics

To view a topic:
From the View menu, choose one of these two view options to display the View Topic window which 
will list all topics in the selected format.

· Outline:    Topics are listed in multi-leveled list representing the structure of your help file.

· Browse: Topics are listed in their assigned browse sequence.    Browse sequences are 
automatically generated for you, as you develop your topics, and will be based on the 
hierarchy of the topics.

To print topics:

1 Select the Print item from the File menu to display the Print window.

2 Choose either All Loaded Topics or just the Current Topic.



Popup Menu

The popup menu provides instant access to the commands you will use most frequently while editing 
objects.    You can easily display the popup menu by clicking the right mouse button over any object 
within the topic design window.



Searching for Topics

The Search window can be activated by using the Edit menu.      You can limit the search by checking 
the Match Whole Word Only option.    Pressing F3 will perform another search for the next 
occurrence of the specified text within a topic name, and SHIFT+F3 will search for a previous 
occurrence.



Editing Objects

One of the first steps in creating a help file is to create the topics.    Using the Topic Design Window in 
combination with the objects toolbox, developers can simply drag and drop objects to create very 
sophisticated topics.    The following sections describe the many ways that you may work with topics 
in your help project using Visual Help.

Adding an Object
You can add an object to your topic by simply dragging it off the Object Toolbox and dropping it on 
the topic window.

Deleting an Object
Select the object you want to delete by clicking the mouse over it.    Then click the trash can button, 
or select the Edit Delete main menu item, or select the Delete popup menu item.

Moving an Object
An object may be moved within a topic by clicking the appropriate up/down toolbar buttons.

Cut, Copy, Paste, and Duplicate
To cut, copy, paste, or duplicate an object, first select it by clicking the mouse over it (ensure no text 
is highlighted), and then select the appropriate item from either the main edit menu or the popup 
menu.



Text Objects

One of the most important needs of a help file is to present textual information in a format that allows 
the user to quickly access the information they are seeking.    Visual Help fulfills this need by 
providing you with 10 different text specific objects representing a large variety of possible formats 
and styles that you can use within your help project.

Title

Heading

Subheading

Footnote

Paragraph

Monospaced Paragraph

Bitmap Paragraph

Bullet

Enumerated Bullet
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Jump Objects

Jump Objects provide the links between topics, and allow help file users to quickly navigate through 
a large help file.    Every jump must have a destination topic, that is, the topic that will be displayed 
whenever the help file user clicks on the jump.    Other options are also supported, such as jumping 
to another window, or jumping to a topic in another help file.    Visual Help provides several jump 
objects and includes an easy to use Action window for defining all the attributes of a particular jump.

Jump Label

Bitmap Jump

Index, Using the Index Object

Glossary, Using the Glossary Object

Letter Scroll Bar



Graphic and Multimedia Objects

Graphics and multimedia are alternate sources of information that can dramatically improve the 
appearance of your help files by adding style, interest, and visual structure.    Visual Help provides 
you with many different ways to incorporate graphics and multimedia into your help files.    This 
section discusses the various objects that will allow you to use graphics and multimedia.

Line

Image

Hot Spot,    Using the Hot Spot Object

MCI, Using the MCI Object

Bitmap Paragraph



Applying a Style

To apply a substyle to an existing object:

1 Click on the object with the right mouse button to bring up the Popup Menu.

2 Choose the desired substyle type from the Style submenu.



Extended ASCII

Extended ASCII characters are often used to produce symbols or non-English letters.    Visual Help 
supports extended ASCII by allowing you to insert these characters in any one the available text 
objects.

To insert an extended ASCII character:

1 Run the Character Map applet by using the Window menu (or by starting it from the 
Accessories Group).

2 Select the same font that was used by the text object.

3 Copy the desired characters.

4 Select the text object within Visual Help.

5 Paste the previously copied characters using the popup menu.

Example:    ß™ü¾ä



Object Styles

Since users of Windows help systems have come to expect a certain look and format, Visual Help 
has default styles for text objects that follow the WinHelp conventions.    However, there are many 
situations that require alternate styles to be used within your project, and this is where the Define 
Styles dialog becomes useful.    To access this feature, choose the Styles item from the Options 
menu.



Window Designer

You may need to vary the size, shape, and color of topic windows depending on the type, quantity, 
and formatting of the help information inside. The WinHelp application allows the use of multiple 
windows with varying sizes and shapes. Visual Help provides the capability of creating window styles 
which determine the appearance of topic windows when they are opened.



Button Designer

When WinHelp opens your help file, a button bar is visible across the top of the window. This button 
bar contains various default buttons that allow the user to: jump to the contents topic, keyword 
search, display history,    go to the previous topic, and go to the next topic.    The Visual Help Button 
Designer enables you to add new buttons to the button bar to provide quick access to the macro 
functions that you specify.

To add buttons to the help project:

1 Choose Button Design from the Window menu to display the Button Designer window.

2 If no buttons exist, you can begin typing the caption of the new button, otherwise select 
insert.    The caption is the text that will appear on the menu button.

3 Enter a name for the button in the Name box.

4 From the Macro box, choose the WinHelp macro that will run when the user clicks the button. 
If you choose the “Run...” macro, click on the Browse button to select the program to run 
when that button is selected.
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Image Designer

The Image Designer allows you to import existing image files (.BMP, .DIB, .ICO, & .WMF) or create 
new images. Then you can display your    bitmap file within your project using any of the Visual Help 
graphic objects.

To create a new image:

1 Choose the Image Design item from the Window menu.

2 To load an existing image file, click on the ellipsis (3 dots) button next to Image field.

3 Use the available options to add colors, text, 3D effects, or even a Windows button style.

4 Select the Save As button to save the new image to a bitmap file.



Reports

Visual Help features useful tools to assist in the development of the help system. The Topics List 
Report, Topics Outlined Report, and Project Options Report are three of these features. It is often 
very helpful to refer to a list of topics or an outline showing the structure of the help system in 
designing or trouble-shooting your project.



Tips, Tricks, and Advice
1 Use the Popup Menu by clicking the right mouse button on any object to access frequently used 

commands such as: Cut, Paste, Copy, Delete, Duplicate, Action, Image, Active Style, Change 
Styles, and any other object specific functions.

2 When you create a new topic, the generic topic name "Topicn" is highlighted. Simply begin typing 
the topic name and press TAB to lock in the name and automatically copy it directly to the title 
object.

3 To create a new topic for an existing jump label, press the CTRL key and click on the jump label.

4 To go to the topic that is already assigned to a jump label, hold down the CTRL key and click on 
the jump label.

5 Use the runtime testing feature of Visual Help to test jumps, text appearance, graphics, and 
sound files without having to compile the project.

6 Give your topics logical names that will make good keywords for Winhelp search. Visual Help 
includes topic names in the keyword list by default.

7 Use the Search command under the Edit menu to help you locate topics in projects with a large 
number of topics. You can search by typing in any letter, word, or phrase which is contained in 
the title object of the topic you are seeking.

8 Limit the number of open topic windows to conserve system resources.

9 To quickly close all open topic windows, select the Compile Build option, and when the Build 
Wizard window displays, click on the Cancel button.

10 Match the text in jump labels to the name of the topic it jumps to when possible to help you keep 
track of jumps.

11 Help speed the execution of WinHelp by converting 256 color (or greater) bitmaps to 16 color.

12 If you experience problems with graphics and you are using a high resolution video driver, try 
switching to the Windows VGA video driver.

13 Wait until the end of the development cycle to link images to your image objects. The help 
compiler executes faster when no images are included, reducing help system development time. 
Compilation speed is also improved by deselecting the Generate Index Objects and Generate 
Glossary Objects check boxes in the build dialog until needed.

14 Although the first topic created is assigned by default to be the Contents Topic, you can 
designate any topic as the Contents topic. The topic window that is designated as the Contents 
topic is the first topic displayed by Winhelp upon loading the help file. To designate a topic as the 
Contents topic, select Project from the Options menu. Click on Contents in the list of project 
options, then select the topic you want to be designated as the Contents topic.

15 You can also give your help project a title by selecting Project from the Options menu. Click on 
Title from the list of project options, then type the title for your help project. This title will appear in 
the title bar of each window when the help file is compiled and run.

16 You can assign a jump, sound, or Winhelp macro to a image by clicking on the action button and 
choosing the desired action. Bitmaps can also be aligned to the left, center, or right by clicking on 
the Image Alignment buttons.

17 To allow the help compiler to function more efficiently, ensure that your CONFIG.SYS file has the 
statements: FILES=55 and BUFFERS=8.

18 The help compiler does need a significant amount of hard disk space and memory to function 
properly; make sure you have enough of each to support the size of your project file.

19 If your help project takes a long time to compile, you can assign it to work in the background by 
creating a PIF file for the help compiler which specifies windowing and background attributes. 
Make sure you also select the "Close window on exit" checkbox.

20 If you would like the help compiler window to pause after each compilation, create a PIF file that 
runs the help compiler (uncheck Close window on exit), and specify the new PIF file in Options 



Environment window.

21 To copy a topic, use the Save As item from the File menu to save the current project to another 
file.    Then reload the original file, choose File Import , select the new file you previously saved, 
and import the desired topic.

22 If your project (VH) file experiences corruption, first try to recover using the BAK file which is a 
mirror image of your VH file (the BAK file is saved every time you save your VH file).    Secondly, 
you can use the AGIFIX.EXE utility (located in your Visual Help directory) to repair your 
corrupted file.    To use Agifix: go to the DOS Prompt, and type AGIFIX YOURFILE.VH.

23 If you are panning on including large blocks of text (>16K) within your project as paragraphs, you 
should be aware that Visual Help does perform more efficiently when you place the text among 
multiple paragraph objects.    Visually, there should be no difference in your resulting help file as 
opposed to using a single paragraph object.

24 If you are using TAB characters within your text objects for text formatting, you should be aware 
that tab spacing in Visual Help is set at every .5 inches; whereas, WinHelp tab spacing is every 1 
inch.

25 To quickly add glossary terms as you are editing a text object, just highlight the term, click the 
Right mouse button to activate the popup menu, select the Action menu item, the Glossary 
Window will appear with the highlighted term already entered in the list, and then you can 
complete the process by just entering the definition text.

26 Visual Help automatically generates the Browse Sequence for you, as you develop your topics 
and assign links between them, Visual Help will assign the browse indexes depending on the 
hierarchy of the topics.
Note: topics that are only jumped to from within hypergraphics or by using the glossary window 
will not be assigned browse indexes since Visual Help cannot accurately determine their proper 
sequence.

27 Although you may have adequate system memory, the Help Compiler may occasionally 
experience 'Out of Memory' errors when attempting to process your project.    If this happens, 
first try exiting any other running DOS applications. Second, try increasing the memory settings 
in your _default.pif file using the Pif editor provided with Windows.



Calling Help from Visual Basic

Global Definitions/Declarations
Place the following global definitions and declarations in a module file within your Visual Basic 
Project.    Be sure to type the function declarations each on a single line.

Global Const HELP_CONTEXT = &H1
Global Const HELP_QUIT = &H2
Global Const HELP_INDEX = &H3
Global Const HELP_HELPONHELP = &H4
Global Const HELP_PARTIALKEY = &H105

Declare Function WinHelp Lib "User" (ByVal hWnd As Integer, ByVal lpHelpFile As String, ByVal 
wCommand As Integer, ByVal dwData as Any) As Integer

Help Menu Code
The following code should be placed in the click events of your Help menu.

Note: As part of your application initialization, you will need to set the HelpFile property of the App 
object to contain the location of your help file as shown in the following example:
 App.HelpFile = "C:\YOUR.HLP"

Sub mnuHelpContents_Click
Dim Result%
    '*** Display the contents topic of your help file
    Result% = WinHelp(Me.hWnd, App.HelpFile, HELP_INDEX, cLng(0))
End Sub

Sub mnuHelpSearch_Click
Dim    Result% 
Dim Temp$
      '*** Display search window for your help file
      Result% = WinHelp(Me.hWnd, App.HelpFile, HELP_PARTIALKEY, Temp$)
End Sub

Sub mnuHelpOnHelp_Click
Dim    Result% 
      '*** Display WinHelp's Help File 
      Result% = WinHelp(Me.hWnd, App.HelpFile, HELP_HELPONHELP, cLng(0))
End Sub

Sub mnuHelpTechSupport_Click
Dim    Result% 
      '*** Open your help file to a particular topic by context ID
      Result% = WinHelp(Me.hWnd, App.HelpFile, HELP_CONTEXT, 41067)
End Sub

Sub CloseHelp()
Dim    Result%
    '*** Before your application terminates, call this sub to close your help file
    Result% = WinHelp(Me.hWnd, "", HELP_QUIT, 0&)



End Sub
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Visual Help - How to order
Visual Help is shareware and requires $49.00 plus shipping and handling registration fee.

Telephone
To register using your credit card directly through WinWare, call 1-714-586-4492

Fax
To register using your credit card directly through WinWare, Fax your order to WinWare Inc. at 714-
586-9792. Make sure you include:

· Name of credit card holder.

· VISA or MASTER CARD number.

· Expiration date of the credit card.

Mail
To register by mail select the jump below and print the registration form.

 Registration Form

CompuServe
To register through CompuServe, you need to have a CompuServe account.

· Log on to Compuserve

· At any prompt type "GO SWREG"

· Select registration Id# "891".

The registration fee will be billed to your CompuServe account.

Public Software Library
You can order with MC, Visa, Amex, or Discover from Public Software Library by calling:

· 800-2424-PSL

· 713-524-6394

· 713-524-6398 (FAX)

THE ABOVE NUMBERS ARE FOR ORDERS ONLY. Any questions about the status of the shipment 
of the order, registration options, product details, technical support, volume discounts, dealer pricing, 
site licenses, etc, must be directed to WinWare Inc. at CIS Email 
70272,1656 or the address bellow.

WinWare Inc. 
P.O. BOX 2923
Mission Viejo CA 92690



Visual Help Registration Form
(To print the following form, select Print Topic from the File menu.)

Name:

Company:

Address1:

Address2:

City: State: Zip:

Country:

Tel: Fax:

Email:

          Single-User Registration
Single user ..............................................$49.00      __________

          Multi-User Registration (Site license)
10 to 20 users ............................................$400.00      __________
21 to unlimited ............................................$700.00      __________

          Shipping and handling
U.S. ...............................................$5.00      __________
Canada and Mexico ...............................................$7.00      __________
All Others .............................................$10.00      __________

          Total
.......................................................      __________

Please Note that for international orders we cannot accept Eurocheques or International bank 
checks, we accept company checks only. Please indicate funds in U.S. Dollars. We also accept VISA 
and MASTER CARD.



Visa or MasterCard
Card Holder Name ..........................................................................
VISA or MC card number ..........................................................................
Expiration Date ..........................................................................

Sign Here ..........................................................................

Send completed form with payment to
WinWare
P.O. Box 2923
Mission Viejo,    CA      92690
USA

Where did you hear about Visual Help?



Visual Help Pro
The object oriented help development tool.

 What the press is saying

 System Requirements

 How to order

 Features

What is Visual Help Pro
It is the professional version of Visual Help, with more features such as:

· Spell Checker with 100,000+ word dictionary.

· Elastic or Fixed width tables.

· Outline control for cascading menus.

· Global Search and Replace of text within topics.

Why Visual Help
The answer is right in front of you.    It's the completely integrated help development environment.    
Visual Help enables you to produce your help files and on-line documentation quickly and easily.    
You may have used some of the other help authoring tools that require you to type in special codes 
and use a separately purchased word processor.    But when you're using Visual Help, development 
time can be cut down from days to just minutes!, YES just minutes!!!

Wizardry
To start a new help file, you simply just use the Project Wizard, answer the questions, and click the 
finish button.    A base project will then be created with all the initial elements that you have selected: 
title, icon, copyright, contents topic, glossary topic, glossary terms and definitions, index topic, and all 
formatted in one of three styles.    From this base project, you can then add additional topics, drag 
and drop any of the object types, and most importantly -- enter your help text.

Power
The ease of use of Visual Help does not hinder its power, you will be able to access all the 
professional features of the windows help environment such as macros, secondary windows, menu 
buttons, segmented hyper graphics, and non-scroll regions, all with the ease of click drag and drop. 
This makes Visual Help the right choice for the advanced users as well as the novice. Another power 
feature also include the ability to export your help project to an RTF user manual, which provides you 
with the first draft of hard copy documentaion.

Advantage
The real advantage of Visual Help is its object oriented interface.    This is most evident whenever 
editing the contents of a particular topic; an area you'll be spending 90% of your time.    Whenever 
you edit a topic, it is opened in its own special “Design Window” containing its own toolbar and status 
line.    You can then add paragraphs, headings, bullets, jumps, bitmaps, sound, video, and other 
objects by dragging them off the toolbox and dropping them onto topic window. All properties of each 
object such as style, action, and links can be easily changed within the topic window by clicking the 
right mouse button to display the popup Menu Assistant.    This floating menu provides instant access 
to the most common commands and properties -- a definite time saver.



Multimedia
Add multimedia elements in your help file without the need for dynamic link libraries or any other files 
to re-distribute with your help file. Visual Help supports the use of Windows audio/video files (AVI), 
multimedia movie files (MMM), and MIDI files (MID). Visual Help also support Microsoft Multimedia 
Viewer, just flip a switch and Visual Help will do the rest.

Programmer Support
Generate reports about your project or view an outline of the hierarchy of your help topics. Assign 
context ID's manualy or let Visual Help automaticaly assign then for you. Also an include file is 
generated by Visual Help for the programmer to include in a project to reference context IDs in the 
help file. By defining constants for the context IDs which use the name of the topic, the programmer 
can avoid problems which arise from changing context ID numbers. This results in saving time and 
effort when integrating help with your programs, or just maintaning it.

The Price
Is Visual Help affordable?    In a word, YES.    Other comparable help development tools have been 
priced as high as $495!    At WinWare, we acknowledge the importance of a high quality at a low 
price, and feel that creating on-line documentation shouldn't take a big cut out of your budget.    
That's why we're offering Visual Help for only a fraction of    the price!    This is a spectacular value 
considering all the powerful features that are included in Visual Help.



System Requirements

· A personal computer using a 80286 or higher micro-processor is required.    80386 or higher 
recommended.

· 2 MB of available memory.

· VGA or compatible video graphics adapter.

· A hard disk with 3MB available.

· Mouse or equivalent pointing device.

· MS-DOS version 3.1 or later.

· Microsoft Windows version 3.1 or later.



Visual Help Pro - How to order
Visual Help Pro is $189.00 plus shipping and handling

Telephone
Have you VISA or MASTER CARD ready and call 1-714-586-4492

Fax
To register using your credit card directly through WinWare, Fax your order to WinWare Inc. at 714-
586-9792. Make sure you include:

· Name of credit card holder.

· VISA or MASTER CARD number.

· Expiration date of the credit card.



Features
Project Wizard
With just a few clicks of the mouse you can create a custom help file structure in just seconds!

User-Defined Object Styles
You can define your own custom styles for each object type allowing you more control over colors, 
fonts, and margins.

WinHelp Macro Support
Jump to a topic in another help file, copy topic to clipboard, print topic, run an executable program, 
and many others.

Multimedia Support
Supports these file formats: AVI, WAV, MID, and MMM.    Simply click on an environment option and 
your help file can be recompiled as a Multimedia Viewer file!

Spell Checker
Proof    your help topics using the built in spell checker, with support to check one topic at a time or all 
topics within the project.

Image Designer
Imports existing files (.bmp, .dib, .ico, & .wmf) or create new bitmaps; you can add colors, text, 3d 
effects, and even a Windows button style.

Glossary Definition
makes managing your glossary easy.    Just select a term, choose, the scope, and enter a definition.

Help Window Designer
lets you have complete control of the size, position, color, and caption of each different window.

Help Button Designer
lets you add menu-buttons to your help window to call supported WinHelp macros.

Tables
Add elastic or fixed width tables to your help file, use them to present data or just to organize the 
contents of your help document.

Outlines
Create cascading outlines with branches and leaves, to give your help files the maximum screen 
real-estate, and the look of professional help documents.

Letter Scroll Bar
Create a professional looking index or glossary with a complete Alphabetic Toolbar allowing 
immediate access to any selected letter.



File-Export
Generate either a manual document or an include file containing context ID    declarations.



Action Window

The Action window is used to define an action for an object.    There are three basic types of actions:

1 Jump to Topic:    select a destination topic and window.

2 WinHelp Macro:    select one of the listed macros, and enter any    required parameters.

3 Play Media:    select a media file to play
(file must reside in the current directory).

To define the jump, you need to access the Action window by clicking on the toolbar button or 
choosing the Action item from the popup menu.    Depending on which Action Type you choose, other 
options will be offered for further selection.



Applying a Window

To apply a window style to a particular topic:

1 Select the jump label that jumps to that topic.

2 Click on the Action button to bring up the Action or Glossary dialog.

3 Choose the window name from the list at the bottom of the dialog.

Note: You won't be able to see the effects of the formatting until you compile and run the help 
project.



Defining a Style

To modify or create a style:

1 Choose the Styles item from the Options menu.

2 Select a style item from the list or click on the New Substyle button to define a substyle 
(substyles are useful if you need to have several related styles for a particular object type).

3 Choose the desired options from the accompanying style fields: Font Name, Font Size, 
Margins, Text Color, and Text format. An example of    how the style will look is displayed in 
the Sample box.

4 Click the OK button to accept changes or Cancel to disregard and close the dialog.

Note: any existing topics which contain the altered style(s) will be changed to reflect the new style.    
Visual Help only offers the standard Windows fonts for selection it the styles dialog.



Designing a Window

To set the shape of a help window, drag the corners of the sample window to the desired size and 
shape while the name of the window you want to designate a size and shape for is in the Name list 
box in the Window Design window. Set the attributes and shapes of the windows you want to define 
and click the OK button on the Window Design window to accept the changes.

Visual Help's window design mode also provides information for help developers who want to 
account for users who have different video monitor types. While in the window design mode, notice 
along the left side on the screen labels indicating the size of EGA and VGA monitors:

EGA 640x350

VGA 640x480

If you are developing help for multiple monitor resolutions, use these lines as guides to create 
windows which will be displayed on a specific monitor type.



Glossary Object

The Glossary object is used to provide a list of the Definition Terms included in your help file.    Like 
the Index object, this list consists of separately labeled sections sorted alphabetically.    Within each 
section, Terms are listed as popup jump labels; each assigned to their respective definitions.    The 
user can easily locate an entry within the Glossary and click on it to display the associated definition.

Example:
Click on the following jump to see an example of the Glossary Object being used in this help file.

Visual Help Glossary

Note: the list produced by the Glossary object will only be visible within the compiled help file; within 
Visual Help the presence of a Glossary object in a topic is represented by the existence of its toolbox 
icon.



Glossary Window

You can access the Glossary window by choosing the Glossary item from the Window menu or by 
highlighting some text within a topic and selecting the Action command.    This window has primarily 
two main functions: entry of Glossary Terms, and the insertion of paragraph jumps.

To enter a new glossary term:

1 Click on the Insert button.

2 Type in the new term.

3 Enter the definition text which may include line feeds or Extended ASCII.
You can insert line feeds in your definition by pressing CTRL+ENTER, or insert Extended 
ASCII by using the Character Map Applet (available in the Windows menu or in the 
Accessories Group).

4 In the Scope box, you may leave the default choice as Global to place popup jumps in all 
topics or you may select a single topic from the list to just affect one topic.

5 Check the All Occurrences box to place popup jumps at every occurrence of the term, or you 
may uncheck this option to only affect the first occurrence within the scope

6 Check the Case Sensitive box to force a case sensitive match whenever placing a popup 
jump, or uncheck this option to place popup jumps regardless of whether the case matches.



Hot Spot Object

The Hot Spot object is used to incorporate Segmented HyperGraphics into your help file.    This is a 
special type of bitmap that includes Context Sensitive regions (Hot Spots) that allow a user to click 
on a graphic region to jump to another topic or display a popup definition.    For example, a screen 
capture of an application's main window can be transformed into a hypergraphic (SHG file format) 
where a user can click on different parts of the screen to jump to a topic that describes that region of 
the screen.

To assign a file to the Hot Spot object:

1 Either double-click on the object or select Image from the popup menu.

2 From the Image File window, choose the graphic file you want to include.

Where to get the Hot Spot Editor:
The Hotspot Editor (SHED.EXE) is included with Visual Basic Professional, Microsoft SDK, and other 
development tools. The Hotspot Editor creates segmented hypergraphic (SHG) files from bitmap 
(BMP) files.

Tips for Using the Hot Spot Editor:

1 When working in the Hotspot Editor, you should make sure that the context strings you 
assign to regions of your graphic exactly match the context strings of the topics that they 
jump to. If you are not sure what the context string of a topic is, open the topic, and click on 
the properties button.

2 Context strings for glossary terms within your project are not accessible from Visual Help, but 
they can be obtained from the RTF file that is generated whenever you compile your help.

3 The jump information in hypergraphic files cannot be determined until the actual compile 
step; therefore, the effect of    these jumps cannot be determined within Visual Help.    This 
may become apparent when using features such as the View-Outline and the Runtime Test.

4 For more information about using and creating hypergraphics, refer to the documentation that 
accompanied your Hotspot Editor.



Image Object

The Image object is used to display any of the supported graphic file formats: DIB, BMP, and WMF.

To assign a graphic file to the currently selected Image object:

1 Either double-click on the object or select Image from the popup menu.

2 From the Image File window, choose the graphic file you want to include.

To assign an Action:

1 Click on the image object, and select the Action item from the popup menu or click on the 
Action toolbar button.

2 From the Action window, you can specify the action you want to include.



Index Object

The Index object is used to provide a list of the Topic Titles and Keywords included in your help file.    
This list consists of separately labeled sections sorted alphabetically.    Within each section, topic 
titles and keywords are listed as jump labels; each assigned to their respective topics.    The user can 
easily locate an entry within the Index and click on it to jump to the associated topic.

Example:
Click on the following jump to see an example of the Index Object being used in this help file.

Visual Help Index

Note: the list produced by the Index object will only be visible within the compiled help file; within 
Visual Help the presence of an Index object in a topic is represented by the existence of its toolbox 
icon.



See Also:

 Action Window

 Glossary Window

 WinHelp Macros

 Popup Jumps

 Paragraph Jumps

 Jumps to Other Help Files

 Jumps to Run an Executable Program

 Play Media

 Topic Jumps



WinHelp Macros

The WinHelp application provides macros you can access through Visual Help. These macros 
automatically perform common WinHelp tasks like moving between topics, printing, and displaying 
dialog boxes.

Macros are assigned to jump objects. Instead of jumping to another topic, the jump object invokes a 
macro. WinHelp macros can only run after compilation of the help project, so you won't be able to 
test changes to the help file without compiling and running it.

List Item    
in Action 
Dialog

WinHelp 
Macro

Descriptio
n

Copy Topic 
to 
Clipboard

CopyTopic Copies text 
in the 
current 
topic to the 
Windows 
clipboard.

Display 
About 
Dialog box

About Displays 
the About 
dialog box.

Display 
Annotation 
Dialog box

Annotate Displays 
the 
Annotation 
dialog box

Display 
Bookmark 
Dialog Box

Bookmark
Define

Displays 
the 
Bookmark 
Define 
dialog box.

Display 
Copy 
Dialog Box

CopyDialo
g

Displays 
the Copy 
dialog box.

Display 
Help on 
Help

HelpOn Displays 
the Using 
Help file.

Display 
History 
Window

History Displays 
the Help 
History 
window.

Display 
More 
Dialog Box

Bookmark
More

Displays 
the 
Bookmark 
More 
dialog box.

Display FileOpen Displays 



Open 
Dialog Box

the Open 
dialog box.

Display 
Printer 
setup 
Dialog Box

PrinterSetu
p

Displays 
the Printer 
Setup 
dialog box.

Display 
Search 
Dialog Box

Search Displays 
the Search 
dialog Box

Exit Help Exit Exits the 
WinHelp 
application.

Goto 
Contents

Contents Displays 
the 
Contents 
topic of the 
current 
help file.

Goto Last 
Topic

Back Displays 
the 
previous 
topic in the 
“Back” list.

Goto Next 
Topic

Next Displays 
the next 
topic in the 
browse 
sequence.

Goto 
Previous 
Topic

Prev Displays 
the 
previous 
topic in the 
browse 
sequence.

Print Topic Print Send the 
currently 
displayed 
topic to the 
printer.

Run an 
Executable 
Program

ExecProgr
am

Starts up a 
Windows 
application

Jump to 
Contents

JumpCont
ents

Jumps to 
another 
compiled 
Help file.

Jump to 
Context 
String

JumpCont
ext

Jumps to 
the 
specified 
Context 
String in 
another 



compiled 
Help file.

Popup to 
Context 
String

PopupCont
ext

Displays a 
popup 
topic from 
another 
help file.



Popup Jumps

A popup jump is similar to a topic jump, except the topic is displayed in a non-sizable popup window 
that disappears whenever the user clicks the mouse.

To define a popup jump:

1 Select the jump object.

2 Choose the Action option to display the Action window.

3 Select the desired destination topic.

4 Choose the popup item from the window list.



Paragraph Jumps

Visual Help does support topic jumps within paragraph objects by using the Glossary Definition 
window.

To create a paragraph jump:

1 Highlight the text within the paragraph.

2 Click on the Action button.
(The Glossary Definition window will display)

3 From the Scope list, choose the current topic, or Global to affect all topics.

4 Select Jump to Topic type.

5 Choose a destination from the topic list.

6 Check the Case Sensitive box to use a case sensitive search.

7 Check the All Occurrences box to affect all matching text within the scope, or leave it 
unchecked to affect only the first match found within the scope.

Note: Within Visual Help, the paragraph text will not visibly change colors, but when compiled the 
text will appear as a jump in the help file.    A paragraph jump may be modified by selecting the 
Glossary item from the Window menu.    The Glossary Definition window will be displayed, you can 
choose the appropriate item from the Term List, and then make the desired modifications.



Jumps to Other Help Files

Many times a reference in one help file may require information that is in another help file.    Rather 
than duplicating the information, you can define a jump to load the other help file, and display the 
desired topic.

To create a jump to a topic within another help file:

1 Select the jump object.

2 Display the Action window.

3 Choose WinHelp Macro.

4 Select Jump to Context String.

5 Type in the help file name or click the browse button.

6 Type in the Context String of the desired topic.

To create a jump to the Contents of another help file:

1 Follow steps 1 through 3 above.

2 Select Jump to Contents.

3 Type in the help file name or click the browse button.

Example:
The following jump will open the contents topic of NOTEPAD.HLP.    Whenever you jump to another 
help file, you will need to click the Back button to return to the previous help file.

Notepad Help Contents

Note: this type of jump does have the side effect of unloading the original help file.    For defining this 
type of jump for a Button, select Button Design from the Window menu, and follow steps 3 through 6.



Jumps to Run an Executable Program

There may be situations in developing your help file that require the use of another application.    For 
example, you may want to define a jump that will start up a spreadsheet application, and display a 
particular worksheet.    This feature allows you to include capabilities in your help file that are not 
offered in Windows Help.

To create a jump to Run an Executable Program:

1 Select the jump object.

2 Display the Action window.

3 Choose WinHelp Macro.

4 Select Run an Executable Program.

5 Type in the program file name or click the browse button.

6 Continue to type in any program parameters after the file name.

Example:
The following jump will run CALC.EXE.

Run Calculator

Note: For defining this type of jump for a Button, select Button Design from the Window menu, and 
follow steps 3 through 6.



Play Media

Visual Help supports the use of Windows sound files (WAV) in a help project. A sound file can be 
assigned to a jump object just like a topic or WinHelp macro.

To assign a sound file:

1 Select the object to which you want to assign the sound file.

2 Click on the Action button.

3 Choose Play Media from the Action Type combo box.

4 Select the sound file you want from the list.

5 Close the Action dialog by clicking OK or by pressing the ENTER key.

Example:
If you have the proper sound hardware, you will hear a sample whenever you click on the bitmap 
jump below:

 Play Sound

Note: make sure any sound files you want to use are located in the same directory as your project. 
Sound files will only work on systems that support sound and have the proper drivers installed.    If 
the sound files do not have a WAV extension, you must first convert them to WAV format.



Topic Jumps

The topic jump is the most common of all jumps and Visual Help makes defining them very easy.

To create a Topic Jump:

1 Select the jump object.

2 Choose the Action option to display the Action window.

3 Click on the desired destination topic from the list.

4 Choose the desired secondary window name from the window list (or leave it set to default). 
You can also modify any of the secondary windows by using the Window Design feature.

Note: You can click on jump object while at the same time pressing the CTRL key, and Visual Help 
will automatically define a jump Action and create a new topic.    The new topic will have the same 
name as the jump object's text.



Managing Projects

Testing a Project
Compiling a Project
Environment Options
Project Options
Import
Export Include Files
Export Manual



Manual
Overview
Managing Projects
Using Topics
Using Objects
Other Features
References



MCI Object

The MCI Object is used to add a Multimedia file to your topic. Visual Help supports the use of 
Windows audio/visual files (AVI), multimedia viewer files (MMM), and MIDI files (MID). You must 
have the proper hardware and software drivers installed to take advantage of multimedia capabilities 
in your help project. Refer to the appropriate Windows documentation for more information about 
configuring Windows to have specific multimedia capabilities.

To assign a file to the MCI object:

1 Either double-click on the object or select Image from the popup menu.

2 From the Image File window, choose the graphic file you want to include
(the multimedia file must reside in the same directory as your help project file).

Example:
The following play and stop buttons represent a MCI object.    If you have the proper sound hardware, 
you will hear a sample whenever you click on the play button below:

 

Note: since you cannot test multimedia objects with Visual Help's runtime test feature, you must compile 
the project to enable the multimedia functions. After you compile the project, a Play and Stop button will 
be placed into the topic at the location of the MCI object. Click on the Play button to test the multimedia 
file.



See Also:

 Defining a Style

 Applying a Style

 Object Styles: Overview



Project Options Report

Choose Project Options from the Reports menu. The project file names are listed along with the time 
and date in the report window.      Visual Help then lists all of the open help project options. Project 
options control how Visual Help files are created, processed, and optimized. Except for the Title and 
Copyright items, it is usually best to leave these options in their default settings unless you are 
knowledgeable in the use of these options. The Project Option defaults are set so that no adjustment 
is necessary for normal operation of Visual Help.



See Also:

 Topic List Report

 Topic Outline Report

 Project Options Report

 Reports: Overview



Topic List Report

Choose Topics List from the Reports menu. All files associated with the project are listed along with 
the current time and date. Visual Help scans all topics and constructs an alphabetical list of topics. In 
addition to the topic name, the Context ID and any keywords associated with that topic appear in the 
window. Click on the Print button to print the list.



Topic Outline Report

Visual Help scans all topics and constructs a hierarchical outline. The outline starts with the Contents 
topics and, while proceeding down the branches of the structure of the system, lists all the topics in 
the order in which they were encountered. Each topic is indented according to its level in the 
hierarchy. The Browse number for each topic is also listed. The Browse number indicates the order in 
which topics were encountered, and also determines the topic sequence when the user clicks on the 
arrow keys to navigate through the application's help file.

 If a topic is preceded by “Index: Loop” instead of a number, that topic is “jumped to” from the topic 
above it that has an Index number. This is helpful for finding every occurrence of a jump to a 
particular topic. Click on the Print button to print the outline.



Using Context IDs

Windows supports context-sensitive help. Context-sensitive help provides the ability for the end user 
to press the F1 key and receive help information about the item that currently has focus. Developing 
context-sensitive help requires that the help system author and the application programmer agree on 
a list of context ID's so that WinHelp and the application pass the correct information back and forth. 
You can assign context ID's arbitrarily, but you should not change them after they have been 
programmed into the application. Visual Help will also generate context ID's automatically during the 
build process.

You can manually edit the context ID for a topic by opening the topic and clicking on the topic 
properties button    .    Enter the new context ID in the Properties dialog and close the window.    You 
can also edit context ID's from the Outline or Browse windows by highlighting the desired topic and 
clicking on the Context ID button at the top of the window.



Setting Window Attributes

Window styles are set by choosing Window Design from the Window menu. Visual Help goes into 
the Window Design mode, where the main Visual Help workspace is temporarily obscured by the 
Window design elements. Since Visual Help requires the entire screen to help you determine window 
attributes, the Window Design functions are modal, which means you cannot perform other Visual 
Help tasks until you are finished with window design and either click OK or Cancel to return to the 
topic design environment.

When you choose Window Design from the Window menu, two windows will be displayed on a 
colored background. The window on top is called the design window.

The Design window contains fields and buttons where you can set various attributes for Visual Help's 
six available window types. Notice the list box called Name. It contains a list of the six available 
window types, called Main, Window1,...., Window5. When you select a window from the Name list 
box, its attributes are displayed in the Design window and the actual size and shape of the window 
are also shown.



See Also:

 Setting Window Attributes

 Designing a Window

 Applying a Window

 Window Designer: Overview



Add Topic Name to the Keywords List
This option, set to true by default, causes Visual Help to automatically include topic names as keywords.



Bitmap Jump
The Bitmap Jump object is a single line of text formatted in a green-underlined regular font.    You can 
also include a graphic file to be displayed on the left or right side of the text.



Bitmap Paragraph
Multiple line text formatted with a small size regular font and full word wrapping is enabled.    You can 
also include a graphic file to be displayed on either the right or left side of the text.



Bitmap
An image defined as a rectangular pattern of colored dots (pixels).



Browse Sequence
A sequence of Help topics, accessible by use of the forward and back arrows on the WinHelp menu bar. 
The Browse sequence is helpful for users who like to read several related topics in a predefined order.



Bullet
Multiple line text formatted with small size regular font, word wrapping, and dot style bullet at beginning 
of line.



Button Designer
When WinHelp opens your help file, a button bar is visible across the top of the window. This button bar 
contains various default buttons that allow the user to: jump to the contents topic, keyword search, 
display history,    go to the previous topic, and go to the next topic.    The Visual Help Button Designer 
enables you to add new buttons to the button bar to provide quick access to the macro functions that 
you specify.



Compilation
The process of converting a word processing file into a help file which can be opened by WinHelp. 
HC31.EXE or HCP.EXE performs the compilation on a help project RTF file.



Contents Topic
The topic that the help system opens when the user invokes the help system. The contents topic should 
contain an overview of the help system and pathways to other help information.



Context ID
A number assigned to a topic which is also programmed into the application so that when a user presses 
the F1 key in a particular application mode, help information about that mode is immediately displayed.



Context Sensitive
Receiving help information which pertains to an item that the user is currently viewing by pressing the F1 
key. By programming context IDs into different application modes, the user is allowed to bypass contents 
topics and gets the needed information immediately.



Context String
A string that identifies a topic in the Help system. Each context string must be unique; it can be assigned 
to only one topic in a help project.



Enumerated Bullet
Multiple line text formatted with small size regular font, word wrapping, and number at the beginning of 
line.    A group of Enumerated Bullet objects that are continuous with no other object types separating will 
maintain numbering sequence.    Any separation of another object type will cause numbering to restart at 
1.



Footnote
Single line text formatted with a small size regular font. Usually placed at the end of a topic to indicate 
footnote information.



Glossary
The Glossary object is used to provide a list of the Definition Terms included in your help file.



Heading
Single line text formatted with a medium size bold font.    Usually placed after a Title to indicate another 
sub-level of information.



Help Compiler Selection
The Windows help compiler, HC31.EXE or HCP.EXE, is executed each time the help project is compiled. 
The help compiler text box in the Environment Options dialog contains the name and path of help 
compiler. If the directory which contains HC31.EXE or HCP.EXE is in the “Path” statement of your 
AUTOEXEC.BAT file, then the name of the help compiler is sufficient. You can also click the Browse 
button to locate the help compiler.



Help Compiler
The file HC31.EXE or HCP.EXE included with Visual Basic Professional, the Microsoft SDK (Software 
Development Kit), and most other Windows development tools. This compiler takes the information from 
your Visual Help project and converts it into a format recognized by the WinHelp engine.



Help File
A file with a very specific format which is recognized by the HLP extension in the file name. The WinHelp 
engine opens the Windows help files you create with Visual Help.    Most Windows-based systems 
contain one or more help files for each application installed, but typically just the one copy of the 
WinHelp engine installed with Windows.



History Window
A window that displays the last 40 topics the user has viewed since opening the help file.



Hot Spot
The Hot Spot object is used to incorporate Segmented HyperGraphics (SHG file format) into your help 
file.



Hotspot editor
The Hotspot Editor (SHED.EXE) is included with Visual Basic, Microsoft SDK, and other development 
tools. The Hotspot Editor creates segmented hypergraphic (.SHG) files from bitmaps (.BMP).



Hypergraphic
A hypergraphic is a bit mapped graphic that can be segmented, with each segment defined as a jump to 
a topic. Hypergraphics are created using the Hotspot editor.



Hypertext
A type of document management in which the user navigates by reading information presented in the 
help window, clicking with the mouse on predefined text or graphics in the window, then “jumping” to a 
different screen in the help file. A new screen is presented with more information and jump options. The 
user can jump to another topic or return to a previous screen. Hypertext works well for on-line help 
systems.



Image
The Image object is used to display any of the supported graphic file formats: DIB, BMP, and WMF.



Include File
A file generated by Visual Help that a programmer can include with a project to reference context IDs in 
the help file. By defining constants for the context IDs which use the name of the topic, the programmer 
can avoid problems which arise from changing context ID numbers.



Index
The Index object is used to provide a list of the Topic Titles and Keywords included in your help file.



Jump Label
The Jump Label object is a single line of text formatted in a green-underlined regular font.



Jump
A predefined text or graphic object which the user clicks on to "jump" to another topic window. A new 
screen is then presented with more information and jump options. The user can then jump to another 
topic or return to a previous screen. This type of document management is known as “Hypertext” and 
works well for on-line help systems.



Keyword
A word or phrase you can associate with a topic which appears in an index object you use in your help 
system. WinHelp's search dialog relies on a “keyword” list to help the end user find topics based on 
words and phases related to the topics.



Letter Scroll Bar
The Letter Scroll Bar places buttons for each letter A-Z that a user can click on to scroll immediately to a 
certain letter in an index or glossary object.



Line
You may place a Line object anywhere in your topic to produce a single black line that extends from one 
side of the help window to the other.



MCI
The MCI Object is used to add a Multimedia file your topic. Visual Help supports the use of Windows 
Audio/visual files (AVI), multimedia viewer files (MMM), and MIDI files (MID).



Metafile
A Windows file that stores an image in terms of graphic objects rather than pixels. A metafile preserves 
an image better than a bitmap when it is resized.



Monospaced Paragraph
Multiple line text formatted with a small size fixed-pitch regular font and word wrapping is disabled.



Multiple-Resolution Bitmap
A bitmap file that contains the bitmap at several resolutions.



Non-Scroll Area
Often a topic is too long to fit into one regular sized help window. If the help information extends below 
the bottom of the window, a scroll bar automatically appears that allows the user to view everything 
contained in the window by scrolling. It is often helpful in such topics to freeze the title to remind the user 
which topic is currently being viewed.



Paragraph
Multiple line text formatted with a small size regular font and full word wrapping is enabled.



Pop-up window
A topic which appears in an overlapping window that “pops-up” until the reader clicks the mouse or 
presses a key.



Regenerate Context IDs
A context ID links a help topic to a specific program object. For example, if the user needs help with a 
certain dialog box currently on the screen and presses F1 for help, then the context ID programmed into 
the application will instruct WinHelp to open to the topic which gives information about that dialog box. 
Visual Help can automatically regenerate context IDs. If the Regenerate Context ID's box is checked in 
the Environment Options dialog when the project is built, then context IDs will be automatically 
generated and inserted into each topic. This option is then automatically reset to false so that the context 
IDs will not be overwritten on the next build. Limit generation of context IDs to certain stages in the 
development cycle to reduce the chance of incorrect context IDs.



RTF
Rich Text Format. Visual Help builds an RTF file for each project which is compiled into a help file by 
HC31.EXE.



Runtime Testing
A time saving feature of Visual Help which allows the help system developer to test the jumps and sound 
files in a help project without having to compile the help project.



Screen Capture
The process of converting a screen image to a graphic file that can be used in Visual Help. Press 
ALT+PRINT SCREEN to capture a bitmap image of what you see in a window and place it on the 
Windows clipboard. Then paste the graphic into a Paintbrush file to save an image that can be used in 
your help system.



Secondary Window
A window which displays additional information without closing the original topic window. All Visual Help 
window styles are secondary windows except for "Main."



Style
Predefined text formatting used for various text objects. Since users of Windows help systems have 
come to expect a certain look and format, Visual Help has default styles for text objects that follow the 
WinHelp conventions.



Sub-contents topic
A topic which provides a pathway between the main contents topic and topics which contain specific 
help information. A sub-contents topic is jumped to from the main contents topic, and contains other 
jumps to topics like Procedures or Commands.



Subheading
Single line text formatted with a medium size italic-bold font. Usually placed after a Heading to indicate 
another sub-level of information.



Target File Format
This list box provides the two file types you can create, Windows Help file or Windows Multimedia 
Viewer file.



Title
Single line text formatted with a large bold font.    As the name implies, it is usually used as a topic title.



Topic Note
Visual Help provides capabilities for attaching notes to individual topics to help remind you of changes or 
updates that need to be done, to communicate with another person working on the project, or store any 
other information related to the topic. This is a development tool available only while working in Visual 
Help; the end user won't see or have access to these notes.



Topic
The primary unit of information in a help file. A topic is the help information displayed in one window by 
WinHelp during runtime. Each topic has its own window in the Visual Help development environment.



WinHelp button
When WinHelp opens your help file, several default buttons are created along the top of the window. 
These buttons take the user to the contents topic, allow keyword searches, bring up the WinHelp History 
dialog box, and take the user forward and backward in the help file. Visual Help enables the help system 
author to add buttons to the default WinHelp buttons, and assign WinHelp macros to the new buttons.



WinHelp Macro
The WinHelp application provides macros you can access through Visual Help. These macros 
automatically perform common WinHelp tasks like moving between topics, printing, and displaying 
dialog boxes.



WinHelp
To provide an efficient and consistent method of providing help to users of Windows-based applications, 
Microsoft has devised a system that centers around WinHelp. The WinHelp application is referred to as 
the “engine” of the help system because it starts up whenever the user requests help. Every time a user 
opens a help file, Windows executes the file WINHELP.EXE, and WinHelp is loaded. The WinHelp 
engine opens the Windows help files you create with Visual Help.






