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Overviews
What is VB DB Draw?
Getting Started with VB DB Draw - basic instructions for using VB DB Draw

VB DB DRAW Windows
Opening VB DB Draw Window 
Database Tables and Fields Window 
Edit Generated Form Window 

Dialog and Message Boxes
Change Properties Dialog
Save Changes to Form Message Box 
Save Generated Form Message Box 
Replace Existing Form File Message Box 
Register Program Dialog

Menu Commands
File Menu Commands 
Edit Menu Commands 
Help Menu Commands 
File Menu Commands on Sample Form 

Misc.
Keyboard Shortcut Keys 
Registration 
Order Form 
Future Enhancements 

Important      If you are using Access 2.0 databases with Visual Basic 3.0, you must have the Microsoft 
Visual Basic 3.0 -- Microsoft Access 2.0 Compatibility Layer installed.



What is VB DB Draw?

VB DB Draw creates a Visual Basic form with a Data Control and bound controls that are bound to an 
Access database and table. You specify the database, the table, and the fields, and VB DB Draw does 
the rest of the work. After you have saved the form, you can add it to your own Visual Basic project. 
While in VB DB Draw, you can also make modifications to the form and controls : resize the form; move 
and rename the form and controls; change form and control captions.



Getting Started with VB DB Draw
Here is how to use VB DB Draw to create a Visual Basic form with bound controls.

Open an Access Database file.
Choose a table from the database.
Choose the fields from the table that you want on your Visual Basic form.
Choose Generate Form from the Edit Menu. This creates and displays the form.
Change your new form's layout: resize or move form; move controls on the form.
Double click the form or any control to rename the form or control or to change the caption.
Close your new form.
Choose Save from the File Menu to save your new form.
In Visual Basic, Add the new form to your project.



Visual Basic
Microsoft Visual Basic for Windows release 3.0 or higher.



Rock Ridge Computer Solutions
You can contact me via email on CompuServe as 71041,1452 or the Internet at 
71041.1452@compuserve.com or on Genie as S.HOWARD11. You can also write to me at the address 
on the Order Form. - Steve Howard



Opening VB DB Draw Window
See Also

This is the opening window that appears when you first start VB DB Draw. The only thing to do here is: 
Open a database; Exit the program; or Read online help. Click on parts of the window below for more 
information.



See Also
File Menu 
Help Menu 



Database Tables and Fields Window
See Also

This is the main window for VB DB Draw. You choose the table and fields for which you want to generate 
a Visual Basic form that has bound controls. You then generate the form; edit the form and controls; and 
then save the form as a file to use in a Visual Basic project. Click on parts of the window below for more 
information.



See Also
File Menu 
Edit Menu 
Help Menu 



File Menu
Open Database

Open an Access database. After the database is opened, the tables in the database are displayed so 
that you may chose one to generate a Visual Basic form from.

Save Form
Save the Visual Basic form that you have generated as a Visual Basic text file. After the form is saved, 
you can add it to a Visual Basic project.

Save Form As
Save the Visual Basic form with a new name.

Exit
Stop executing VB DB Draw.



Edit Menu
Generate Form

After you have chosen a database table and fields, this will create a Visual Basic form with a Data 
control that points to the database and the table. It creates bound controls that are bound to the fields 
that you have chosen. After the form is generated, the form is displayed so that you can change some of 
the properties of the form and the controls.

Edit Generated Form
Display the generated form so that you can change some of the properties of the form and the controls.



Help Menu
Contents

Display the Contents of the help file.

Search For Help On
Open the Search dialog for the help file.

About
Display version and copyright information about VB DB Draw.

Register Program
Allows you to register your copy of VB DB Draw. See Register Program Dialog for more information.



Edit Generated Form File Menu
Exit And Save Changes

Save any changes that you have made to the properties of the generated form or controls. You will be 
returned to the Database Tables and Fields window.

Cancel Changes
Discard any changes that you have made to the properties of the generated form or controls. You will be 
returned to the Database Tables and Fields window.



Edit Generated Form Window
See Also

Allows you to change the layout of the generated Visual Basic form. You can also change some of the 
properties of the form or of the controls on the form. Click on parts of the window below for more 
information.



See Also
Change Visual Basic Control Properties



Change Visual Basic Control Properties Dialog

Allows you to change the properties of your generated Visual Basic form or the Visual Basic controls on 
the form. Click on parts of the dialog below for more information. You get to this dialog from the Edit 
Generated Form Window 



Keyboard Shortcuts
Here are the keyboard shortcut or accelerator keys for VB DB Draw.

Ctrl+O File Open Database
Ctrl+SFile Save Form
Ctrl+A File Save Form As
Ctrl+F4 File Exit
Ctrl+G Edit Generate Form
Ctrl+EEdit Generated Form
F1 Context Sensitive Help throughout program



VB DB Draw Registration and License

VB DB Draw is distributed as Shareware. Shareware allows you the opportunity of trying out software 
before you put out your hard earned cash. To register your copy of VB DB Draw, see the order form. 
After you receive you registration information, choose Register from the Help Menu.

License to evaluate VB DB Draw
You are granted a license from Rock Ridge Computer Solutions to try VB DB Draw for a period of 30 
days to see if the program is useful to you. At the end of that 30 day period, you must either register your 
copy of VB DB Draw or stop using the program.
During the evaluation period, you will see the About Box for VB DB Draw, which you must dismiss before 
you can proceed with using the program. This is a minor annoyance during evaluation that will go away 
when you register your copy of VB DB Draw. It does not affect the operation of the program
You may: make as many copies of the Shareware version of this software and documentation as you 
wish; give exact copies of the original Shareware version to anyone; and distribute the Shareware 
version of the software and documentation in its unmodified form via electronic means.    There is no 
charge for any of the above.

Reasons to register
 When you register your copy of VB DB Draw, you will be given a registration number. This will remove 
About Box when the program is started. It will also entitle you to free future updates to VB DB Draw as 
they become available on CompuServe and Genie. If you want updates mailed to you, there will be a 
postage and handling charge of $3.00. per update. I strongly suggest electronic updates to the program.
One registered copy of VB DB Draw may be used by a single person who uses the software personally 
on one or more computers. This means that you can use this software at work and at home when you 
register a single copy.



Order Form
Fill out this form and send with a check to the address below. Make checks payable to Rock Ridge 
Computer Solutions. Your registration information will be sent to you via electronic mail or via U.S. mail 
if you do not have an email address.    More information on registration. To print this order form, click on 
Print Topic in the File menu.

Rock Ridge Computer Solutions
P.O. Box 412
Belvidere, NJ 07823

VB DB Draw 1.0    ________ copies @ $10 each = ______________________

N.J. residents add 6% sales tax $0.60 per copy = ______________________

Total Payment $ _______________________

Name: ____________________________________________________

Company:____________________________________________________

Address:____________________________________________________

City, State, Zip:____________________________________________________

Day Phone:____________________________________________________

Email Address:____________________________________________________

Date:____________________________________________________

Where did you hear about VB DB Draw?_______________________________________

Comments:____________________________________________________



Table Name
Database table for which you are creating the form.



Field Name
Field in the database table that the Visual Basic control that you are changing is bound to.



Control Name
Name of the Visual Basic control for which you are changing properties.



Control Caption
Caption for the Visual Basic control for which you are changing properties.



OK Button
Choose the OK button to save the changes you have made to the Visual Basic control's properties.



Cancel Button
Choose the Cancel button to undo the changes you have made to the Visual Basic control's properties.



Tables in Database
This is the list of tables in the database that you opened. Choose the table for which you want to 
generate a Visual Basic form. The Data control's RecordSource property on the generated form will be 
set to the table you choose. The Data control's DatabaseName property will be set to the database that 
the table is part of.



Fields in Table
This is the list of fields in the table for which you have chosen to generate a Visual Basic form. Choose 
the fields that you want on the form. As each field is chosen, it is moved from this list to the next list, 
New Fields to Draw. You can choose a field in a number of ways: Double click a field; Press the Enter 
key while field is highlighted; Use the > or >> buttons.



Fields to Draw on Visual Basic Form
This is the list of fields that will be drawn on the Visual Basic form that you generate. You must first 
choose a database table from the list of Tables in Database and then the fields to be drawn from the list 
of Fields in Table. You can remove fields from this list in several ways: Double click a field; Press the 
Enter key while field is highlighted; Use the < or << buttons.



Add Field to Form Button
This button moves the fields that are currently highlighted from the list of Fields in Table to the list of 
New Fields to Draw. Those fields will be drawn on the Visual Basic form that is generated.



Add All Fields to Form Button
This button moves all the fields from the list of Fields in Table to list of New Fields to Draw. Those fields 
will be drawn on the Visual Basic form that is generated.



Remove Field from Form Button
This button moves the fields that are currently highlighted from the list of New Fields to Draw to the list 
of Fields in Table. Those fields will not be drawn on the Visual Basic form that is generated.



Remove All Fields from Form Button
This button moves all the fields from the list of New Fields to Draw to the list of Fields in Table. Those 
fields will not be drawn on the Visual Basic form that is generated.



Open Database Button
This toolbar button performs the same function as choosing Open Database from the File Menu. Opens 
an Access database.



Save Generated Form Button
This toolbar button performs the same function as choosing Save Form from the File Menu. Saves the 
Visual Basic form that you have generated with VB DB Draw.



Generate Visual Basic Form
This toolbar button performs the same function as choosing Generate Form from the Edit Menu. A Visual 
Basic form based upon the table and fields that you have chosen is created.



Edit Generated Form
This toolbar button performs the same function as choosing Edit Generated Form from the Edit Menu. A 
sample form of the form you have generated is displayed. This sample form allows you to change 
certain properties of the generated form and controls.



Exit Program
This toolbar button performs the same function as choosing Exit from the File Menu. VB DB Draw will 
exit.



File Menu
This is the File Menu. It allows you to Open a database; Save a generated form; and Exit VB DB Draw.



Edit Menu
This is the Edit Menu. It allows you to Generate a Visual Basic form or Modify the generated form and 
controls.



Help Menu
This is the Help Menu. It allows you to look at Help for VB DB Draw.



File Menu for Editing Generated Form
This is the File Menu inuse while editing the generated form. It allows you to Save or Cancel your 
changes to the generated form and controls.



Data Control RecordSource Property
This property specifies the underlying table, SQL statement, or QueryDef for a data control.    It is 
read/write at both design time and run time. See Visual Basic Help or the Visual Basic documentation for 
more information.



Data Control DatabaseName Property
Determines the name and location of the source of data for a data control.    Read/write at both design 
time and run time. See Visual Basic Help or the Visual Basic documentation for more information.



Save Changes to Form? Message Box
See Also

This message box appears when you have made changes to the generated form and then close the 
form without saving the changes. You can choose to save or undo the changes or not exit from editing 
the form. Click on parts of the message box below for more information.



See Also
Edit Generated Form Window
Database Tables and Fields Window 



Save Changes? Yes Button
Choose the Yes button to save the changes you have made to the generated form and controls. You will 
then be returned to the Database Tables and Fields window where you can save your form in a file.



Save Changes? No Button
Choose the No button to return to the    Database Tables and Fields window without saving the changes 
you have made to the generated form and controls. You might choose this option because you have 
really made a mess of the form and want to go back to the state it was in before you made your 
changes.



Save Changes? Cancel Button
Choose the Cancel button to not exit back to the Database Tables and Fields window. You will stay in 
the editing window as if you had not chosen to exit.



Save Generated Form Message Box
See Also

If you do not save a form that you have generated and then generate another form or exit VB DB Draw, 
this message box appears to ask what you want to do with your previously generated form. This acts as 
a reminder so that you do not accidentally lose work because you forget to save your form. You can 
choose to save or not save the form or to cancel the operation that you just choose. Click on parts of the 
message box below for more information.



See Also
File Menu



Save Generated Form? Yes Button
Choose the Yes button to save your generated form before proceeding with the operation    that you just 
choose. Choosing Yes will invoke the File Save Form menu option. See File Menu for more information.



Save Generated Form? No Button
Choose the No button to throw away the generated form that you had been working on. VB DB Draw will 
proceed with the operation you had just chosen.



Save Generated Form? Cancel Button
Choose the Cancel button to not do anything. The operation that you just chose will be ignored.



Replace Existing Form File? Message Box
See Also 

This message box appears when you try to save your generated form with the same name as an 
existing file. You can choose to overwrite or not to overwrite the existing file. Click on parts of the 
message box below for more information.



See Also
File Menu



Replace File? Yes Button
Choose the Yes button to replace the existing file with the file you have generated.



Replace File? No Button
Choose the No button to not replace the existing file. You will be returned to the Save File dialog to 
choose a new name for your form file.



Change Form's Properties
The form can be resized or moved. Double click on the form to change the form's Name or Caption 
properties.



Drag and Drop
Position the mouse cursor over a control. Press and hold the left mouse button. Move the mouse which 
will Drag the control about on the form. Release the left mouse button when the control is positioned 
where you want it. This Drops the control, moving it to the new position.



Change Data Control
The Data control can be moved on the form using drag and drop. Double click on the data control to 
change the Data control's Name or Caption properties. 



Change Text Control
Text controls and other controls can be moved on the form using drag and drop. Double click on a 
control to change the control's Name or Caption properties. Pressing the Enter key in a text control does 
the same as double clicking with the mouse.



Change Label Control
Label controls can be moved on the form using drag and drop. Double click on the label control to 
change the label control's Name or Caption properties



Future Enhancements to VB DB Draw
Here are future directions and enhancements that I plan for VB DB Draw.

Add options to give you more control of the Visual Basic forms that VB DB Draw generates.
Option to generate or not generate Labels for the database fields.
Set Length property on Visual Basic Text Boxes to the length of database field.
Use other Visual Basic controls that you specify for each database field, including custom controls.
Add support for more databases than Microsoft Access.

Comments and suggestions
If you have any comments on VB DB Draw or suggestions on future enhancements please contact Rock 
Ridge Computer Solutions. You can also write to me at the address on the Order Form. I look forward to 
any comments or suggestions that you may have. - Steve Howard



Register Program Dialog

Allows you to register your copy of VB DB Draw. You get to this dialog by choosing Register from the 
Help Menu. Enter the Registration Number that you received, along with your name and optionally your 
company name. This information will be displayed in the About Box for VB DB Draw. The registration 
number will be good for all future upgrades to VB DB Draw. If you do not have your registration number, 
you can cancel out of this dialog. Click on parts of the dialog below for more information.



Registration Number
Enter the registration number that you received in the mail after you sent in the Order Form for VB DB 
Draw. The number must be a valid registration number for this program. If the number you received is 
not valid, please contact Rock Ridge Computer Solutions for help.



Your Name
Enter your name. The name you enter will appear in the About Box for VB DB Draw.



Company Name
Enter your company 's name. It will appear in the About Box for VB DB Draw. This field is optional.



Register Program OK Button
Press Enter or click the OK button to process your registration. You should click the Cancel button if you 
do not want to register the program at this time.



Register Program Cancel Button
Press Esc or click the Cancel button to exit the Program Registration dialog without registering your 
copy of VB DB Draw.



Register Program Help Button
Press F1 or click the Help button to bring up the Help information for the Program Registration dialog.




