
[Text] is too long.

The text you are entering is too long. You can type a maximum of 255 characters of text.    Reduce the 
number of characters used in the text.



Cannot access [document].

You have chosen the Import command, the Open Microsoft Excel Chart command, or the Set As Default 
Chart command from the File menu and the document you are trying to import, open, or set as the 
default cannot be accessed.

Some possible reasons for this are:

The document name or path you specified in a dialog box does not exist.
Check the spelling of the name or path, and try to access the document again.
The document you are trying to import or open is being used by another application.
When the document is no longer being used, try to open it again.
The name of the document you are trying to save is the same as the name of another document 

that is read-only or that is being used by another application.
The default chart is saved in the file DEFAULT.GRA. The status of this file has been changed to 

read-only.
Change the status of DEFAULT.GRA to read-write; then try again.    For information on changing 

the read-only attribute of a file to read-writ, see your Windows documentation .
The buttons that appear in the message box vary, depending on the cause of the error. 

OK Closes the message box.

Retry Tries to access the document again.

Cancel Cancels the command.



Cannot access [document].

You have chosen the Import command, the Open Microsoft Excel Chart command, or the Set As Default 
Chart command from the File menu and the document you are trying to import, open, or set as the 
default cannot be accessed.

Some possible reasons for this are:

The document name or path you specified in a dialog box does not exist.
Check the spelling of the name or path, and try to access the document again.
The document you are trying to import or open is being used by another application.
When the document is no longer being used, try to open it again.
The name of the document you are trying to save is the same as the name of another document 

that is read-only or that is being used by another application.
The default chart is saved in the file DEFAULT.GRA. The status of this file has been changed to 

read-only.
Change the status of DEFAULT.GRA to read-write; then try again.    For information on changing 

the read-only attribute of a file to read-writ, see your Windows documentation .
The buttons that appear in the message box vary, depending on the cause of the error. 

OK Closes the message box.

Retry Tries to access the document again.

Cancel Cancels the command.



Disk is full.

There is not enough room on the disk to save the current chart as the default chart.

Delete some files from the disk and try again.

If you have set the default chart before,    don't assume the previous version is still on the disk. Microsoft 
Graph may have erased it to make room for the new version of the default chart.



Unable to read file.

Microsoft Graph cannot read the file due to an unrecoverable error.    The file is probably corrupted.

Try using the backup copy of the file.



Filename is not valid.

The name you entered for your file does not adhere to the rules for valid filenames.

Valid filenames are made up of two parts separated by a period (.).    The first part, the name, can be up 
to eight characters long.    The second part, the extension, can be up to three characters long.    For 
example:    SALES.XLS

The following characters are valid in filenames:

a-z                  A-Z                  0-9                    period 

$    %    '    -    @    {    }    ~    !    #    & _



Maximum number of data series per chart is 255.

Microsoft Graph allows you to use up to 255 data series in a chart (main chart and overlay).



Maximum number of data points in a data series is 4000.

Microsoft Graph allows you to use up to 4000 data points per series if series are defined in columns (see 
Defining Series in Rows or Columns).



Negative or zero values cannot be plotted on log charts.

Only positive values can be interpreted on a logarithmic scale. Therefore, only values greater than zero 
can be plotted on a log chart.

Include only positive values for the chart or choose another chart type.



Error drawing chart due to problem with printer [printer].

Microsoft Graph draws the chart based on the printer and printer driver specified by the main application. 
There are several possible causes of errors in drawing the chart:

Not enough memory. Try closing other applications (such as Help) and then print again.
If your computer is connected to a network for printing, the network connection may have been 

canceled or your computer or printer may not be connected to the network.
There may be loose cables or bad connections between your computer and printer.
There may be a problem with the printer driver. Try installing it again using the Control Panel in 

Windows.



Tick mark intervals must be greater than 0.

In the Scale dialog box, Major Unit and Minor Unit refer to subdivisions of the axis. The length of a 
subdivision must be a positive number.

Either select the Auto check boxes for the Major Unit and Minor Unit options, or specify a number greater 
than zero for both.



Cannot add any more custom formats.

You can have a total of only 64 built-in and custom formats. 

Before creating another format, you must delete one of the custom formats (you cannot delete a built-in 
format).

To delete a custom format:

1. From the Format menu, choose Number.

2. Select the custom format to delete.

3. Choose the Delete button.

4. Choose the OK button.



[Document] is read-only.

You have chosen the Import command, the Open Microsoft Excel Chart command, or the Set As Default 
Chart command from the File menu and the document you are trying to import, open, or set as the 
default cannot be accessed.

Some possible reasons for this are:

The document name or path you specified in a dialog box does not exist.
Check the spelling of the name or path, and try to access the document again.
The document you are trying to import or open is being used by another application.
When the document is no longer being used, try to open it again.
The name of the document you are trying to save is the same as the name of another document 

that is read-only or that is being used by another application.
The default chart is saved in the file DEFAULT.GRA. The status of this file has been changed to 

read-only.
Change the status of DEFAULT.GRA to read-write, then try again.    For information on changing 

the read-only attribute of a file to read-write, see your Windows documentation .
The buttons that appear in the message box vary, depending on the cause of the error. 

OK Closes the message box.

Retry Tries to access the document again.

Cancel Cancels the command.



[Document] is currently in use. Open as Read-Only?

You have chosen the Import command, the Open Microsoft Excel Chart command, or the Set As Default 
Chart command from the File menu and the document you are trying to import, open, or set as the 
default cannot be accessed.

Some possible reasons for this are:

The document name or path you specified in a dialog box does not exist.
Check the spelling of the name or path, and try to access the document again.
The document you are trying to import or open is being used by another application.
When the document is no longer being used, try to open it again.
The name of the document you are trying to save is the same as the name of another document 

that is read-only or that is being used by another application.
The default chart is saved in the file DEFAULT.GRA. The status of this file has been changed to 

read-only.
Change the status of DEFAULT.GRA to read-write, then try again.    For information on changing 

the read-only attribute of a file to read-write, see your Windows documentation .
The buttons that appear in the message box vary depending on the cause of the error. 

OK Closes the message box.

Retry Tries to access the document again.

Cancel Cancels the command.



Value must be a number.

In the Scale dialog box, you cleared one or more Auto check boxes, but did not type a number in the box 
associated with it.

Either type a number or select the Auto check box you want.



Minor unit must be less than major unit.

Major and minor units are subdivisions of the axis. Major units specify major subdivisions; minor units 
specify more refined or minor subdivisions of the axis. In the Scale dialog box, the number you specify for 
the minor unit increment must be less than the number you specify for the major unit.

If you don't know what values to specify, select the Auto check box next to Major Unit and Minor Unit in 
the Scale dialog box and Microsoft Graph will determine a correct set of values. Specify major unit and 
minor unit increments only if you want to customize your chart.



Maximum axis value must be greater than minimum axis value.

The minimum value is the smallest number on the axis and the maximum value is the largest number on 
the axis. Numbers labeled on the axis are scaled between the minimum and the maximum.    In the Scale 
dialog box, the number you specify for the minimum value must be less than the number you specify for 
the maximum value.

If you don't know what values to specify, select the Auto check box next to Minimum and Maximum in the 
Scale dialog box and Microsoft Graph will determine a correct set of values. Specify numbers only if you 
want to customize your chart. Make sure that the maximum axis value you have specified is greater than 
the minimum axis value.



Unit of log scale must be at least 10.

A log scale axis is based on powers of 10. For major and minor unit increments, you must specify a value 
of at least 10.



Number is not valid.

Depending on the command you've chosen, you must type either an integer or a decimal number in the 
box. 

If it appears you have entered a valid number, try deleting the number completely and then re-entering it.



Cannot open printer driver.

Microsoft Graph draws the chart based on the printer and printer driver specified by the main application. 
There is a problem opening the printer driver. Possible problems include:

Not enough memory. Try closing other documents and applications (such as Help) and try again.
There may be a problem with the printer driver itself. Try installing it again with the Control Panel 

in Windows.



File error: data may have been lost.

An error occurred while you opened a Microsoft Excel chart. It is possible that the Microsoft Excel chart 
contained formatting that Microsoft Graph does not understand. Graph has loaded as much of the 
formatting as possible.



Cannot find [document].

Microsoft Graph cannot find the document you are trying to open or import.    Either the document does 
not exist, you specified the wrong directory or disk, or you made a spelling error. 

Choose the OK button, and then choose the Import or Open Microsoft Excel Chart command again.    
Use the dialog box to find the correct name and location of the file you want to open. 



Cannot access [document].

The default chart is saved in the file DEFAULT.GRA. The status of this file has been changed to read-
only.

Change the status of DEFAULT.GRA to read-write, then choose Set As Default Chart from the File menu 
again.

For information on changing the read-only attribute of a file to read/write, see your operating system 
documentation .



A high-low-close stock chart must contain three series.

This type of chart is intended to compare a stock's high, low, and closing prices for each day.    The chart 
must contain exactly three series in this order:

High prices

Low prices

Closing prices

The categories should be the days that the various prices occurred.



A volume-high-low-close stock chart must contain four series.

This type of chart is intended to show the daily volumes of stock traded and to compare a stock's high, 
low, and closing prices for each day.    The chart must contain exactly four series in this order:

Volume traded

High prices 

Low prices

Closing prices

The first series is plotted on the main chart; the remaining series are plotted on the overlay chart. The 
categories should be the days that the various prices occurred.



A open-high-low-close stock chart must contain four series.

This type of chart is intended to compare a stock's opening, high, low, and closing prices for each day.    
The chart must contain exactly four series in this order:

Opening prices

High prices

Low prices

Closing prices

The categories should be the days that the various prices occurred.



A volume-open-high-low-close stock chart must contain five series.

This type of chart is intended to show the daily volumes of stock traded and to compare a stock's 
opening, high, low, and closing prices for each day.    The chart must contain exactly five series in this 
order:

Volume traded

Opening prices

High prices 

Low prices

Closing prices

The first series is plotted on the main chart; the remaining series are plotted on the overlay chart. The 
categories should be the days that the various prices occurred.



You cannot combine an XY chart with another chart type. Delete overlay chart?

If you want to use an xy (scatter) chart in a combination chart, both the main and overlay charts must be 
xy (scatter) charts.

Yes Deletes the overlay chart, moving all series to the main chart; applies the selected 
formatting to the main chart.

No Redisplays the dialog box so you can make another selection.

Cancel Cancels the command.



Font name is too long.

The font name you typed in the Font dialog box is too long.    The maximum number of characters you 
can enter is 32.

Check the length of the font name you typed and try again.



Cannot create backup file.    Save DEFAULT.GRA without backup?

Microsoft Graph cannot create a current backup file for DEFAULT.GRA. In order to create a current 
backup file, the status of the previous backup file must be read-write. Check the file and try again. 

OK Continues to set the current chart as the default chart without creating a backup.

Cancel Cancels the command.

For information on changing the status of a file to read-write, see your Windows documentation.



Replace existing DEFAULT.GRA?

A default chart and data has already been set. Choosing the OK button replaces the previously set 
default chart with the current chart.



Document not saved.

The save process was halted.    Microsoft Graph has not saved the new version successfully.    Try 
deleting unnecessary files from the disk, and then try setting the default chart again. For information on 
deleting files, see your Windows documentation.



Document not saved. Any previously saved copy has been deleted.

The save process was halted.    Microsoft Graph deleted the original document from the disk to save the 
version in memory, but has not saved the new version successfully.    Try deleting unnecessary files from 
the disk, and then try setting the default chart again. For information on deleting files, see your Windows 
documentation.



Cannot delete built-in format.

You can delete custom formats you have created, but you cannot delete formats built into Microsoft 
Graph.



This format is too long.

The format you are entering is too long. You can type a maximum of 255 characters.    Reduce the 
number of characters used in the format or cancel the entry.



Number format is not valid.

Microsoft Graph cannot understand the number format you typed. 

Correct the format or select one of the built-in formats.

For more information, see Creating Custom Number Formats.



Column width must be between 1 and 255.

Microsoft Graph sets column width based on the width of unformatted numeric characters. Negative 
values are not valid.    The maximum column width is 255 unformatted numeric characters. The number of 
characters actually displayed in a cell may vary, depending on the font and format. In the Column Width 
dialog box, change the column width to a value between 1 and 255.



Cannot shift nonblank cells off sheet.

To prevent possible loss of data, Microsoft Graph will not allow you to use the Insert     Row/Col   command 
from the Edit menu to shift cells containing data beyond the edges of the datasheet. Delete or clear the 
cells, or move the data to a new location, and try again. 



Incorrect password.

The password you entered is not correct for the document you are trying to import or open. Try again with 
the correct password.



Data on the Clipboard is not the same size and shape as the selected area.

The area you selected is either too large or too small for the data now on the Clipboard. The paste area 
must be one of the following:

A single cell
A rectangle the exact size and shape of the copied area
A rectangle able to contain two or more rectangles the exact shape of the copied area.

Select another paste area and try again.



Picture too big to copy. Only cell data will be copied.

The selection occupies an area that exceeds the internal Windows limit for an image area. The data itself 
will be copied, but not all of the formatting will be copied.

To copy as a picture, make the selection smaller by:

Selecting a smaller area on the datasheet
Reducing the font size and width of columns within the selected area
Deleting empty or excluded rows or columns within the selected area.

See Also

Changing Column Width

Changing Fonts

Deleting Rows and Columns

Including and Excluding Data from Charts



The series plotted on the x-axis cannot be excluded.

The selection includes the series marked with an X in the row or column header.    As the scale for the x-
axis is calculated from this series, it cannot be excluded from the chart.    If you want to exclude this 
series:

Select another series and choose the Plot On X Axis command from the DataSeries menu.
OR

Choose a chart type other than xy (scatter).



Rows already included.

The selected row or rows are already included in the chart and you chose the Include Row/Col command 
from the DataSeries menu.



Rows already excluded.

The selected row or rows are already excluded from the chart and you chose the Exclude     Row/Col   
command from the DataSeries menu.



Columns already included.

The selected column or columns are already included in the chart and you chose the Include     Row/Col   
command from the DataSeries menu.



Columns already excluded.

The selected column or columns are already excluded from the chart and you chose the Exclude     
Row/Col command from the DataSeries menu.



The series plotted on the x-axis cannot be deleted.

The selection includes the series marked with an X in the row or column header.    As the scale for the x-
axis is calculated from this series, it cannot be deleted from the chart.    If you want to delete this series:

Select another series and choose the Plot On X Axis command from the DataSeries menu.
OR

Choose a chart type other than xy (scatter).



Cannot open the Clipboard.

You are trying to do a procedure that requires the Clipboard, but Microsoft Graph is unable to open the 
Clipboard. Some possible reasons are:

Another application may be using the Clipboard for copying or pasting.    Wait until the operation 
is finished and try again.

There may not be enough memory to use the Clipboard.    Try closing other documents and 
applications (such as Help) and try again.



Cannot empty the Clipboard.

You are doing a procedure that requires using the Clipboard, but the Clipboard is full and Microsoft 
Graph is unable to empty it. Some possible reasons are:

Another application is using the Clipboard while Microsoft Graph is trying to put something onto 
the Clipboard.    Try again.

Another application used the Clipboard but did not close it properly, preventing other applications 
from using it. Quit Microsoft Graph, restart Graph, and try again.

There is not enough memory to use the Clipboard.    Try closing other documents and applications 
(such as Help) and try again.



The imported data extends beyond the edge of the datasheet. Choose OK to import what will fit.

Data is imported beginning from the active cell.    The amount of space between the active cell and the 
lower right corner of the datasheet is not enough to accommodate the data you are importing.    Choosing 
the OK button imports as much of the data as will fit in the space available.    Or you can choose the 
Cancel button and:

Specify a smaller range of data to import, 
OR

Select a cell nearer the top-left corner of the datasheet and try importing again.



The name you typed is not defined in the selected file.

Microsoft Graph can't find the range name you typed. Try one of the following:

Check to see that you spelled the name as defined in the file; 
Give the range reference rather than a name (for example, A1:C5);
If the file is not large, you could import the entire file.



[Text] will be interpreted as a range name. Continue?

The name you typed contains characters that may be interpreted as a reference rather than a name.    If 
this is the case, cancel the message and correct the spelling of the reference.    If what you typed is a 
range name, choose the OK button to continue importing the data.



The imported data has more formats than Graph can hold. Change extra formats to General?

Microsoft Graph can hold up to 64 number formats in memory at once.    Graph currently has a number of 
formats in memory.    Adding all the formats in the imported data would make more than 64.    Choosing 
the OK button changes all formats beyond the sixty-fourth to General.

To import the data with its formats intact, delete the custom formats you don't need and try importing 
again.



Imported data will overwrite existing data. Continue?

The imported data will replace existing data in one or more cells.    To avoid this, import the data 
somewhere else on the datasheet.



Cannot read this file.

Microsoft Graph cannot read the file due to an unrecoverable error.    The file is probably corrupted.    Try 
using the backup copy of the file.



Not enough memory to import data.

Microsoft Graph cannot import the data unless you free up some memory. 

Try one or both of these actions:

Import a smaller range.
Close other documents and applications.



There are no named ranges in this file.

The file you have selected is either a simple text file or a .CSV (comma-separated values) text file.    
Neither type of file can have named ranges.

However, you can specify ranges to import from these files in the form A1:B5.    A1:B5 means import the 
first two words (A through B) in the first five lines (1 through 5).

See Also

Importing Data from Other Files



This program can only be run from within another program.

Microsoft Graph creates charts which are embedded in documents created by other applications. It is not 
intended as an independent application and, except for the default chart (DEFAULT.GRA), does not 
create document files.



Return the chart and data to your document before closing Graph?

Program Manager attempts to close all open applications before closing itself. Your choices are:

Yes Return the data and chart to the main application before closing Microsoft Graph. 

No Discard the data and chart; then close Graph.

Cancel Do not close anything.



Not enough memory to return this amount of data. Exit Graph and discard changes?

You can choose the Cancel button and try closing some other applications or documents to free up some 
memory. Or you can choose the OK button to close Microsoft Graph without updating the data and chart 
in the main application. Any changes you have made since the last time the chart and data were 
successfully updated in the main application will be lost.



Not enough memory to return this amount of data. Exit Graph and discard changes?

You can choose the Cancel button and try closing some other applications or documents to free up some 
memory. Another possibility is to choose the Set As Default Chart command to save the data and chart in 
the file DEFAULT.GRA.

Or you can choose the OK button to close Microsoft Graph without returning the data and chart to the 
main application. Any changes you have made since the last time the chart and data were successfully 
returned to the main application will be lost.



You must close the dialog box in Graph before Graph can close.

The main application is attempting to close Microsoft Graph, but Graph has an open dialog box.    
Choose the Cancel button to close the dialog box or complete the operation in progress so that Graph 
can close.



Number must be between [number] and [number].

The number you typed is not valid. Enter a number between the valid limits.



Update Graph in [document]?

Yes Updates the changes you've made in the chart, and then quits Graph.

No Quits Graph without updating the changes you've made in the chart.

Cancel Cancels the command.



Not enough memory.    Continue without Undo?

There is not enough memory for the operation you want to perform.    You may be able to complete the 
operation, but you won't be able to choose the Undo command after the operation has been performed.

OK Proceeds with the operation; you will not be able to undo it.

Cancel Cancels the operation, leaving the document as it was before the operation began.



Font size must be between 1 and 409 points.

Font size is measured in points.    Negative values and decimal values are not valid.    The maximum size 
you can enter in the chart is 409 points.    The Font dialog box lists sizes available for printing.    If you 
type a size that differs from those in the box, Microsoft Graph attempts to produce that size as closely as 
possible.    Depending on your screen display and your printer driver, the results may appear ragged. 

Check the font size you specified and try the operation again.



Not enough memory to run Microsoft Graph.

There is not enough memory to run Microsoft Graph. Close other open applications and try starting 
Graph again.

For more information, see your Windows documentation.



Opening a Microsoft Excel chart will overwrite existing data and chart formatting. Continue?

The imported data and chart formatting will completely replace the existing data and chart formatting. 

OK Proceeds with the operation; you will not be able to undo it.

Cancel Cancels the operation, leaving the document as it was before the operation began.



Font size must be between 1 and 128 points.

Font size is measured in points.    Negative values and decimal values are not valid.    The maximum size 
you can enter in the datasheet is 128 points.    The Font dialog box lists sizes available for printing.    If 
you type a size that differs from those in the box, Microsoft Graph attempts to produce that size as 
closely as possible.    Depending on your screen display and your printer driver, the results may appear 
ragged. 

Check the font size you specified and try the operation again.



Not enough system resources to display completely.

The percentage of system resources available is not sufficient for Microsoft Graph to update the screen 
display.    Any command you've just chosen was completed successfully, but the screen does not 
completely reflect the changes.    To check system resources, switch to the Microsoft Windows Program 
Manager and choose the About Program Manager command from the Help menu.    The percentage of 
free system resources is displayed in the dialog box.

To free more system resources, try closing other applications or documents.    Then, to have the data on 
the screen updated, move the window off the screen and back again, minimize and restore the window, 
or close and reopen the window.



Updating Graph in main document.    Waiting for response.

Graph is attempting to update the changes in the main document, but the main application has not 
responded.    Try canceling the Update or Exit And Return command.    Then switch to the main 
application.    If there is an open dialog box in the main application, close it.    Switch back to Graph and 
choose Update or Exit And Return again.



Entire row or column selected.    Graph will only apply formatting up to the last row or column 
containing data.

Formatting all the selected cells will take up a large amount of memory.    This could interfere with 
updating the chart in the main application.

If you choose OK, Graph will determine which cells    to format based on the current selection and the    
cells already containing data:

If you have selected a row, Graph will format only cells in the row up to the last column which 
contains data.

If you have selected a column, Graph will format    only cells in the column up to the last row 
which contains data.

If you have selected the entire datasheet, Graph will format only the cells from the upper-left cell 
to the    last cell already containing either data or formatting.
To control exactly which cells are formatted, choose Cancel, select the specific cell or range (not entire 
rows or columns) you want to format, and then choose Number from the Format menu.



Graph will fill the entire datasheet (4000 x 256 cells) with copies of the data in the Clipboard.    
Continue?

The Paste command on the Edit menu fills the entire selected area with copies of the data on the 
Clipboard.    Because the entire datasheet is selected, this will take a long time and Graph may run out of 
memory.

OK Fill the entire datasheet with the contents of the Clipboard.

Cancel Cancel the command.

If you want Graph to paste a single copy of the data on the Clipboard onto the datasheet, select the top 
left cell of the area where you want the data before you choose Paste from the Edit menu.



Titles command (Chart menu)

Attaches a title to the chart or an axis.

Appears dimmed when the Chart window is not active.
If an axis moves or changes size, attached text stays with it.
After choosing this command, type the title text you want and press Esc.

Dialog Box Options

Chart Title 

Attaches the text "Title" above the plot area.

Value (Y) Axis (or Value (Z) Axis)

For 2-D charts, attaches a "Y" centered on the value axis (y-axis). For 3-D charts, this option 
changes to Value (Z) Axis, and attaches a "Z" centered on the    value axis (z-axis).

Category (X) Axis

Attaches an "X" centered on the category axis (x-axis).

Series (Y) Axis

Attaches a "Y" centered on the series axis (y-axis). Only available for 3-D charts.

Overlay Value (Y) Axis

Attaches a "Y" centered on the overlay value axis.    Only available for a 2-D chart with an overlay.

Tasks That Use This Command

Attaching a chart title, axis titles, or data-point labels

See also

Data Labels command

Unattached Chart Text



Data Labels command (Chart menu)

Attaches labels to all the data points in the chart. 

Appears dimmed if the Chart window is not active. 
For pie charts, you can label the data points with their values, percentages, or category labels. 
For all other charts, you can label the data points with their values or category labels.

Dialog Box Options

None

No data points in the chart will be labeled.

Show Value

Labels each data point with its numeric value.

Show Percent

In a pie chart, labels each slice with its percentage of the total value of the pie.

Show Label

Labels each data point with its category name from the datasheet.

Tasks Using This Command

Attaching a chart title, axis titles, or data-point labels

See Also

Titles command

Unattached Chart Text



Add Arrow and Delete Arrow commands (Chart menu)

Inserts or removes an arrow from the chart.

Appears dimmed when the Chart window is not active.
You can add as many arrows to the chart as you want.
You can resize an arrow and change the direction to which it points by dragging one end of the 

arrow.
You can move an arrow by dragging the shaft of the arrow.
The command name changes to Delete Arrow when an arrow is selected.

Tasks That Use This Command

Adding, deleting, moving, sizing, and formatting arrows



Add Legend and Delete Legend commands (Chart menu)

Inserts or removes a legend. 

The chart is resized to accommodate a legend placed at the bottom, top, right, left or corner of 
the chart area.

You can move a legend by dragging it with the mouse or choosing the Legend command. For 
information about how the size of the chart is affected by the position of the legend, see Moving the 
Legend.

The command name changes to Delete Legend after a legend has been added.

Tasks That Use This Command

Adding and removing a legend



Axes command (Chart menu)

Controls whether axes are visible on the chart.

You can display or hide any available axis by selecting the appropriate check box..
If there is an overlay chart, separate options are included for the overlay chart axes.

Tasks That Use This Command

Showing and displaying axes



Gridlines command (Chart menu)

Adds or removes major and minor gridlines for all axes in the chart.

Select the check boxes for the gridlines you want; clear the check boxes for the ones you don't 
want.

If you select the 2-D Walls And Gridlines check box (available only for 3-D clustered or stacked 
charts with right angle axes), the walls of the chart will become a single wall.    The gridlines will be drawn 
on this wall, rather than on the side and back walls.    For an example, see the 3-D Column command 
from the Gallery menu.    The eighth format in that dialog box is the same as the fourth except that it has 
2-D Walls And Gridlines selected.

Tasks That Use This Command

Adding and removing gridlines



Overview of Editing an Existing Chart

This topic provides an overview of editing an existing chart. For specific editing tasks, click one of the 
topics below.

To edit a chart inserted into your document, you first display it in Microsoft Graph. 

To display a chart in Graph after it has been inserted in your document:

Double-click the chart.

After you have finished modifying the data and chart, choose Exit And Return from the File menu in 
Graph to close Graph and update the chart in the main document.

Tasks for Editing an Existing Chart

Changing the Chart Type

Copying the Entire Chart

Setting the Default Chart

Sizing Charts

Undoing Changes

Updating Changes to the Chart

See Also

Overview of Entering and Editing Cell Data



Changing the Chart Type

Twelve chart types are available on the Gallery menu. The dialog box for each type shows several 
formats for the type. These formats are shortcuts that apply all at once a combination of formatting and 
chart items that you could also apply separately. Once you have selected the chart type and format you 
want, you can customize the chart to suit your needs.

To change the type of chart:

1. From the Gallery menu, choose the type you want.

2. Select the format you want.

3. Click the OK button or press Enter.

Note    It is best to choose a chart type before applying custom formatting. Changing the chart type with a 
command from the Gallery menu overrides custom formatting you may have applied, such as patterns 
and gridline settings. If you have already customized a chart and want to change the chart type without 
losing custom formatting, use the    following procedure.

To change the type of a customized chart:

1. From the Format menu, choose Chart.

2. In the Chart Type box, select the chart type you want.

3. If more than one format is available for the type of chart you selected, select a format in the Data 
View box.

4. Click the OK button or press Enter.

See Also

Common Uses for Chart Types

Creating a New Chart



Common Uses for Chart Types

Area Shows how values change in proportion to the total over a period of time. Similar to a 
line chart, but emphasizes magnitude of values rather than flow of time and rate of 
change. The 100% option shows relationships to the whole.

Bar Shows individual figures at a specific time or draws comparisons among items.    
Similar to a column chart, but the vertical orientation places less emphasis on the 
flow of time.    The stacked and 100% options show relationships to the whole.

Column Shows variation over a period of time or draws comparisons among items.    The 
stacked and 100% options show relationships to the whole.

Line Shows trends or changes in data over a period of time. Similar to an area chart, but 
emphasizes flow of time and rate of change rather than magnitude of values. Often 
used for stock quotes.

Pie Shows the relationship of parts to the whole.    Can contain only one series.

XY (Scatter) Shows the relationship or degree of relationship between numeric values in different 
groups of data. Useful for finding patterns or trends and for determining whether 
variables are dependent on or affect one another.    See Entering Data for an XY 
(Scatter) Chart.

Combination Shows related data that is measured in different units (up to four axes can be used in 
a combination chart); useful for comparing two different kinds of data or juxtaposing 
series to show correlations that might not otherwise be recognized.

3-D Area Shows a 3-D view of an area chart; emphasizes the sum of plotted values, and 
separates series into distinct rows to show differences between the series.

3-D Bar Shows a 3-D view of a bar chart; emphasizes values of individual figures at a specific 
time or draws comparisons among items.

3-D Column Shows a 3-D view of a column chart; emphasizes comparison of data points along 
two axes--a category axis and a series axis--so you can compare data within a series 
more easily and still view data by category.

3-D Line Shows lines in a line chart as 3-D ribbons; makes individual lines easier to view, 
particularly when they cross, while still showing all series in one chart for comparison.

3-D Pie Shows a pie chart with height to the slices; places additional emphasis on the data 
values that are in front.



Copying the Entire Chart

To copy the entire chart:

1. Switch to the Chart window.

2. From the Edit menu, choose Copy Chart.

3. Switch to the document in which you want to paste the chart.

4. From the Edit menu in your main application, choose Paste.

Note    Individual parts of the chart cannot be copied.

See Also

Copying Data



Customizing Colors

Each chart you create with Microsoft Graph has a palette or set of 16 colors that you can use to format 
items in the chart. You can customize any or all of the colors.

To customize colors:

1. Switch to the Chart window.

2. From the Format menu, choose Color Palette.

3. Double-click the color you want to customize, or select the color and then choose the Edit button.

The color editing dialog box appears.

4. Change the color by clicking in the color box and by adjusting the brightness bar.

OR

Change the color by changing the numbers in the Red, Green, and Blue boxes or in the Hue, Sat 
(saturation), and Lum (luminosity) boxes.

The customized color appears in the left side of the Color|Solid box. If you want to use the solid 
color nearest the color you have created, double-click the right side of the box.

5. Click the OK button or press Enter.

The color editing dialog box closes and the custom color appears in the palette.

6. Repeat steps 3 through 5 to customize additional colors. 

7. When you are finished customizing colors, click the OK button or press Enter. 

To restore the default palette:

1. Switch to the Chart window.

2. From the Format menu, choose Color Palette.

3. Choose the Default button.

4. Click the OK button or press Enter.



Setting the Default Chart

You can instruct Microsoft Graph to use any chart and datasheet in place of the built-in defaults. For 
example, you might want to start out with a blank datasheet, with different labels in the columns and 
rows, or with a different chart type.

To save the current chart and datasheet as the default:

From the File menu, choose Set As Default Chart.

The datasheet and chart are saved as DEFAULT.GRA in the WINDOWS directory. Whenever you 
create a new chart without specifying data in your document to be used in the chart, this datasheet 
and chart appear.

To return to the built-in default chart and datasheet:

Delete the file DEFAULT.GRA from the disk.

For more information about deleting files, see your Windows documentation.

Note    If there is no file named DEFAULT.GRA in the WINDOWS directory, Graph checks that directory 
for DEFAULT.PPG (a file created by earlier versions of Graph). If neither DEFAULT.GRA nor 
DEFAULT.PPG is in the WINDOWS directory, Graph checks for DEFAULT.GRA in the directory in which 
you installed Microsoft Graph version 3.0. If no default file is found, Graph uses the built-in default 
datasheet and chart.



Sizing Charts

To change the size of a chart:

Drag the borders of the Chart window. You can also choose the Size command from the Control 
menu on the Chart window and press the arrow keys to make the chart the size you want.

Graph automatically reformats the axes, axis scales, chart text, and all other chart elements to 
accommodate the new size of the chart. 

Graph can display the chart in six views. Changing the view does not change the size of the chart in 
your document. For example, if 50% View is checked on the Window menu, the chart in Graph is 
half the size it will appear in your document. If 100% View is checked, the chart in Graph is the 
same size as it will be in your document. Your main application may also have different views.

To change the view:

From the Window menu, choose one of these commands:
33% View
50% View
66% View
100% View
200% View
400% View

Note    You can also resize the chart from within your document, but the results may not be satisfactory. 
When you resize a chart within Graph, Graph recalculates the axis scale and makes other adjustments to 
adapt the chart to the new size. Other applications vary in their ability to make these adjustments, so line 
thicknesses may not look right, text may be distorted, and relative placement of the parts of the chart 
may not be optimal. For more information, see your main application's documentation.

See Also

Creating a New Chart



Updating Changes to the Chart

You can update in your document the changes you've made to the chart at any time without quitting 
Microsoft Graph.    This is useful for seeing how the chart looks in your document while you continue to 
make changes.

To update the changes in your document without quitting Graph:

From the File menu in Graph, choose Update.

To quit Graph and update changes in your document at the same time:

1. From the File menu in Graph, choose Exit And Return.

2. When the dialog box appears asking if you want to update the changes, choose the Yes button.

Note  Updating changes you've made does not save your chart and data. When you quit Graph, your 
chart appears within your main document. When you save your main document, the chart and data are 
saved along with it. 

See Also

Starting and Quitting Graph

Creating a New Chart



Overview of Selecting and Changing Items in the Chart

You can change the appearance of many items and parts of items in the chart. To change an item, you 
first select it and then choose an appropriate command. When an item is selected, it is surrounded with 
white or black selection squares. Black squares are handles you can drag to move and resize the item; 
white squares mean that you cannot change the size or position of the item directly (it is dependent on 
some other aspect of the chart).

Shortcut    Double-click the item you want to change. The Patterns dialog box appears so you can 
make changes.

To select a chart item:

Click the item or use the arrow keys to select each item in turn.

To cancel selection of all items:

Click just inside the chart window where there is no other chart item.
If the chart is selected, click closer to the edge of the window (inside the window but outside the 
chart).

Items You Can Select in a Chart

A series of data points

An individual data marker

Arrows

Axes

Axis titles

Chart title

Data markers

Data-point labels

Drop lines

Floor of a 3-D chart

Gridlines

Hi-lo lines

Legend

Plot area

Series lines

The entire chart

Tick marks

Tick-mark labels

Unattached chart text

Up/down bars

Walls of a 3-D chart

Note    Clicking a data marker selects the entire data series. To select a single data marker, hold down 
the Ctrl key and click the data marker.

See Also

Adjusting Data Values in the Chart

Creating a New Chart

Formatting the 3-D Chart View



Arrows

To add an arrow:

From the Chart menu, choose Add Arrow.

If the Chart menu has a Delete Arrow command instead of Add Arrow, an arrow is selected. Select 
something else and try again.

To delete an arrow:

1. Select the arrow.

2. Press Delete. You can also choose Delete Arrow from the Chart menu or Clear from the Edit menu.

To move an arrow:

Drag the arrow shaft where you want it.

To resize an arrow or change its direction:

1. Select the arrow.

2. Drag the black handle on either end of the arrow until the arrow is the size and is pointing in the 
direction you want.

To format an arrow:

1. Double-click the arrow, or select the arrow and choose Patterns from the Format menu.

2. Select the options you want. Graph shows a sample of what the new formatting will look like in the 
lower-right corner of the dialog box.

3. Click the OK button or press Enter.



Axes

Axes are lines, usually bordering the chart, that provide a frame of reference for measuring or comparing 
the data. 2-D charts have two axes, 3-D charts have three axes, and pie charts have no axes. For 
information about the axes and the data that is plotted along them, see More About Axes.

To show or hide axes:

1. From the Chart menu, choose Axes.

2. Select the check boxes for the axes you want to show; clear those for the axes you want to hide.

If there is an overlay chart, separate options are included for the axes on the overlay.

3. Click the OK button or press Enter.

To hide an axis:

1. Select the axis you want to hide.

2. From the Edit menu, choose Clear.

For information about adjusting the scale of an axis, see Adjusting the Axis Scale.

For information about changing the axis patterns, see Formatting the Pattern of an Axis.

See Also

Gridlines

Tick Marks

Tick-Mark Labels



Adjusting the Axis Scale

To adjust the axis scale:

1. Double-click the axis you want to adjust; then click the Scale button.    You can also select the axis 
and choose Scale from the Format menu.

2. Type values and select or clear check boxes to achieve the format you want.

The options available depend on which axis you are formatting.

3. Click the OK button or press Enter.

See Also

Axes

More About Axes

Tick Marks

Tick-Mark Labels



Formatting the Patterns of an Axis

To format axis patterns:

1. Double-click the axis you want to format.    You can also select the axis and choose Patterns from 
the Format menu.

2. Under Axis, select the style, color, and weight you want for the axis line.

Microsoft Graph shows a sample of what the new formatting will look like.    You can also change 
the alignment of tick marks and position of tick-mark labels.

3. Click the OK button or press Enter.

See Also

Axes

More About Axes

Tick Marks

Tick-Mark Labels



More About Axes

In these examples, each of the three categories (Jan, Feb, Mar) contains one data point from each of the 
two series (North and South).

2-D Column Chart

In 2-D charts, numeric values or data points are plotted along the y-axis and categories    are plotted 
along the x-axis. In most charts, the y-axis is vertical and the x-axis is horizontal. In bar charts only, the x-
axis is vertical and the y-axis is horizontal. In xy (scatter) charts, the x-axis and y-axis are both value 
axes.

Simple 3-D Column Chart

3-D Column Chart with Series Plotted Separately 

In most 3-D charts, the vertical axis is the z-axis and the horizontal axis is the x-axis. In 3-D bar charts 
only, the vertical axis is the x-axis and the horizontal axis is the z-axis. Values are plotted along the z-axis 
and categories along the x-axis. Series markers may be side by side as in a 2-D chart, or may be plotted 
behind one another along the y-axis (sometimes called the series axis). 
For information about hiding axes and changing the way Graph calculates the scale, see Axes.
In xy (scatter) charts, values are measured against both axes. For examples, see Entering Data for an XY 
(Scatter) Chart.

See Also

Tick Marks

Tick-Mark Labels



Chart Title, Axis Titles, and Data-Point Labels

The chart title, axis titles, and data-point labels are all attached text. This means that their sizes and 
positions depend on the items to which they are attached. When attached text is selected, it is 
surrounded with white squares to indicate that it cannot be moved or sized with the mouse.

To attach a title to the chart or an axis:

1. From the Chart menu, choose Titles.

2. Select the option button you want.

3. Click the OK button or press Enter.

Graph adds the default text "X", "Y", "Z", or "Title".

4. Type the text you want.

Use the Backspace key to delete text and the arrow keys to move the insertion point within the text. 
To insert a line break, press the Enter key.

5. Click anywhere in the window outside the text you are editing. You can also press the Esc key. 

To delete titles:

1. Select the text.

2. Press Delete. You can also choose Clear from the Edit menu, 

To attach labels to all the data points:

1. From the Chart menu, choose Data Labels.

2. Select the Show Value or the Show Label option button. In a pie chart, select the Show Value, 
Show Percent, or Show Label option button.

3. Click the OK button or press Enter.

To delete data-point labels:

1. Select a data-point label.

2. Press Delete. You can also choose Clear from the Edit menu.

OR

1. From the Chart menu, choose Data Labels.

2. Select the None option button.

3. Click the OK button or press Enter.

See Also

Aligning and Orienting Chart Text

Changing the Font of Chart Text

Changing Fonts in the Datasheet

Changing Text Borders and Area Patterns

Creating a New Chart

Keys for Editing Chart Text

Moving and Resizing Chart Text

Tick-Mark Labels

Unattached Chart Text



Data Markers

A data marker is a graphic symbol corresponding to a single value from the datasheet. The type of chart 
determines the type of marker used (for example, in a column chart, the markers are columns). You can 
control the line or border style, border color, weight, pattern, and foreground and background colors, and 
shape, depending on the type of marker. You can control the arrangement, overlapping, distance 
between markers, and other aspects of the marker layout.

To change the appearance of one or more markers:

1. For all the markers in a series: Double-click any marker in the series.

For a single marker:    Hold down Ctrl and double-click the marker.

You can also select the series or marker you want and choose Patterns from the Format menu.

The Patterns dialog box appears, showing all options available for the type of marker you have 
selected.

2. Select the options you want.

3. If you want to apply these formats to all markers on the chart, regardless of which were selected, 
select the Apply To All check box.

4. Click the OK button or press Enter.

To reset data marker formats:

1. Select the marker or series whose formatting you want to clear.

2. From the Edit menu, choose Clear.

3. Select the Formats option button.

4. Click the OK button or press Enter.

If you selected a series, the automatic formatting it originally had is restored.

If you selected a single data marker, it takes on the formatting of the other markers in the series.

To exclude a data series from the chart:

1. Select the series you want to exclude.

2. From the Edit menu, choose Clear.

3. Select the Series option button.

4. Click the OK button or press Enter.

Graph redraws the chart without the series you selected. The data remains unchanged in the 
datasheet.

To format the layout of the data markers on the main or overlay chart:

1. From the Format menu, choose Chart or Overlay.

The Chart or Overlay dialog box appears. Only those options that apply to the current chart type are 
available.

2. Select the options you want.

3. Click the OK button or press Enter.

See Also

Chart Title, Axis Titles, and Data-Point Labels

Including and Excluding Data from the Chart



Gridlines

Gridlines are extensions of the tick marks from the axes across the chart. They help guide the eye from 
the data marker to the corresponding value or category on the axis. In 3-D charts, the z-axis gridlines are 
displayed along the back and side walls of the plot area and the x-axis and y-axis gridlines are displayed 
across the base, or floor, of the chart and extend up the walls. In 3-D bar charts, the "floor" is adjacent to 
the vertical axis.

To add or remove gridlines from a chart:

1. From the Chart menu, choose Gridlines.

2. Select the check boxes for the gridlines you want displayed; clear the check boxes for those you 
don't want displayed.

If you want the gridlines to appear to line up with the front of the data markers, select the 2-D Walls 
And Gridlines check box (available only for 3-D clustered or stacked charts with right angle axes).

3. Click the OK button or press Enter.

To format gridlines:

1. Double-click a major or minor gridline, or select one of the major or minor gridlines and choose 
Patterns from the Format menu.

2. Select the style, color, and weight options you want for the gridlines.

Graph shows a sample of what the new formatting will look like.

3. Click the OK button or press Enter.



Legend

The legend matches the name of each series with the pattern or symbol used for that series. If there is 
only one series in the chart, the legend shows the names of the categories within the series. The text in 
the legend is taken directly from the first row or column of the datasheet. To change the legend text, edit 
the cells in the datasheet  that contain the series or category names.

To add a legend:

From the Chart menu, choose Add Legend.
The command on the Chart menu changes to Delete Legend.

To remove a legend:

From the Chart menu, choose Delete Legend.
OR

1. Select the legend.

2. From the Edit menu, choose Clear.

Note    It is possible to customize the pattern and color of each individual data marker in a series (see 
DataMarkers). If you do this, the Legend will show the pattern or symbol set for the series as a whole.

See Also

Moving the Legend

Formatting the Legend

For information about changing the font of the text in the legend, see Changing the Font of Chart Text.



Moving the Legend

You can move the legend to any of five standard positions: bottom, corner (upper-right), top, right, or left. 
Microsoft Graph automatically redraws the chart so that the legend does not overlap it. You can also 
move the legend anywhere you want. When you do this, Graph redraws the chart to fill the whole 
window; the legend will probably overlap parts of the chart.

To move the legend with the mouse:

Drag the legend to the new position.
As you drag, a long vertical or horizontal line may appear. This means that the mouse pointer is 

over one of the five standard positions for the legend. If you release the mouse button when this line is 
visible, the legend is moved to the standard position and the chart is drawn so that the legend does not 
overlap it.

To move the legend with the Legend command: 

1. Select the legend.

2. From the Format menu, choose Legend.

3. Select the position you want.

4. Click the OK button or press Enter.



Formatting the Legend

To format the border and area of the legend:

1. Double-click the legend. You can also select the legend and choose Patterns from the Format 
menu.

2. Select the border and area options you want.

3. Choose the Font or the Legend button for more options.

4. Click the OK button or press Enter.

For information about changing the font of the text in the legend, see Changing the Font of Chart Text.



Overlay Charts

An overlay chart is a second chart plotted on top of the main chart. Use an overlay chart when you want 
at least two series plotted in the same chart but one or more of the series use a different scale for the 
value axis (y-axis) or a different chart type than the other series.

To create an overlay chart:

1. Activate the Chart window.

2. From the Gallery menu, choose Combination.

3. Select the format you want.

4. Click the OK button or press Enter.

Graph plots half the data series in the main chart and half in the overlay. If there is an odd number 
of series, Graph plots one series more in the main chart than in the overlay. In the datasheet, series 
included in the overlay chart are indicated by a white dot in the row or column heading.

Any custom formatting on the main chart is lost when you use this method.

OR

1. Select a series in the chart or one or more series in the datasheet.

2. From the DataSeries menu, choose Move To Overlay.

Graph creates an overlay line chart with the selected series. In the datasheet, series included in the 
overlay chart are indicated by a white dot in the row or column heading. Overlays cannot be added 
to 3-D charts.

Any custom formatting on the main chart is retained. 

To delete an overlay chart:

1. Select each series in the overlay chart or, in the datasheet, select all the series included in the 
overlay (marked by white dots in the row or column headings).

2. From the DataSeries menu, choose Move To Chart.

The overlay chart is deleted and the chart is redrawn with all series in the main chart. In the 
datasheet, the dots are removed from the row or column headings.

OR

From the Gallery menu, choose any chart type other than Combination.

To change the overlay chart type:

1. From the Format menu, choose the Overlay command.

2. In the Overlay Chart Type box, select the chart type you want.

3. If more than one format is available for the chart type you select, you can select a format under 
Data View.

4. Click the OK button or press Enter.

OR

1. Select one of the series in the overlay chart.

2. From the Gallery menu, choose the chart type you want.

3. Hold down Shift as you click the OK button.

If you select a series in the main chart or if no series is selected, the chart type of the main chart 
changes.

Note    If either the main or overlay chart is an xy (scatter) chart, then the other chart must also be an xy 
(scatter) chart.

See Also

Common Uses for Chart Types

Combination command (Gallery menu)



Plot Area

The plot area is the rectangular area bounded by and including the x-axis and y-axis on a 2-D chart. On 
a 3-D chart, it is the area enclosing the three axes, their tick-mark labels, and their titles. You can change 
the colors and pattern of the plot area as well as the line style, color, and weight of the plot area borders. 
In a 3-D chart, you can format the walls behind the data markers and the floor of the chart as well as the 
entire plot area.

To select the plot area:

Click any part of the plot area not occupied by another chart item. You can also press the arrow 
keys until the plot area is selected.

To format the plot area or 3-D walls or floor:

1. Double-click any unoccupied part of the plot area, 3-D walls, or 3-D floor. You can also select it and 
choose Patterns from the Format menu.

2. Select the border and area options you want. Graph shows a sample of what the formatting will look 
like.

3. Click the OK button or press Enter.



Tick-Mark Labels

Tick-mark labels identify the values or categories represented by the tick marks.

For information about changing the text or number format for tick-mark labels, see Formatting Numbers.

For information about changing the axis scale and the tick marks indicating the scale, see Adjusing the 
Axis Scale.

For information about changing the font for tick-mark labels, see Changing the Font of Chart Text.

To hide or show tick-mark labels or change their location:

1. Double-click the axis whose tick-mark labels you want to format. You can also select the axis and 
choose Patterns from the Format menu.

2. Under Tick Labels, select the location you want relative to the axis for the tick labels.

You can also select a location for tick marks and change the axis patterns.

3. Click the OK button or press Enter.

To change the interval between tick-mark labels:

1 Double-click the axis whose tick-mark labels you want to change, and then click the Scale button.    
You can also select the axis and choose Scale from the Format menu.

2. For a category axis or series axis, type a number in the Number Of Categories (or Series) Between 
Tick Labels box. (For example, if you type 2, every other tick mark will be labeled.)

For a value axis, all major tick marks are labeled; changing the Major Unit changes the interval 
between the major tick marks and their labels.

3. Click the OK button or press Enter.

To change the tick-mark label orientation:

1. Double-click the axis whose tick-mark labels you want to format, and then click the Text button.    
You can also select the axis and choose Text from the Format menu.

2. Select the orientation you want.

3. Click the OK button or press Enter.

See Also

Tick Marks



Tick Marks

Tick marks are small lines that intersect the axes to mark points on the scale or divisions between 
categories. The controls that determine their appearance and spacing vary depending on the type of axis 
selected. For information about the types of axes, see More About Axes.

To hide or show tick marks or change their position relative to the axis:

1. Double-click the axis you want to format. You can also select the axis and choose Patterns from the 
Format menu.

2. Under Tick Mark Type, select the alignment you want for the major and minor tick marks.

You can also select a position for tick-mark labels and change the axis patterns.

3. Click the OK button or press Enter.

To change the interval between tick marks:

1. Double-click the axis whose tick marks you want to change, and then click the Scale button. You 
can also select the axis and choose Scale from the Format menu.

2. For a category axis or series axis, type a number in the Number Of Categories (or Series) Between 
Tick Marks box. (For example, if you type 2, every other category will have a tick mark.)

For a value axis, type a number in the Major Unit or Minor Unit box to change the intervals between 
the major or minor tick marks.

3. Click the OK button or press Enter.

See Also

Tick-Mark Labels



Unattached Chart Text

Unattached text can be placed anywhere on the chart. When selected, unattached text is surrounded 
with black selection handles that you can drag to resize the text.

To add unattached text:

1. With no other text selected, type the text you want.

The text appears on the chart.

2. Click anywhere in the window outside the text you are editing. You can also press the Esc key.

To edit unattached text:

1. Select the text.

2. Click the text to open it for editing.

3. Edit the text.

Use the Backspace key to delete text and the arrow keys to move the insertion point within the text. 
To insert a line break, press the Enter key.

4. Click anywhere in the window outside the text you are editing. You can also press the Esc key.

To delete unattached text:

1. Select the text.

2. Press Delete. You can also choose Clear from the Edit menu.

See Also

Aligning and Orienting Chart Text

Changing the Font of Chart Text

Changing Fonts in the Datasheet

Changing Text Borders and Area Patterns

Chart Title, Axis Titles, and Data-Point Labels

Moving and Resizing Chart Text

Tick-Mark Labels



Moving and Resizing Chart Text

When you select a text item, it is surrounded by white or black selection squares. If the selection squares 
are white, the text is attached text. Attached text moves with the item to which it is attached; it cannot be 
moved or resized with the mouse. 

If the squares are black, they are handles you can use to resize the text.

To move unattached text:

If the text is not selected (surrounded by black selection handles), point to the text and drag it to 
the position you want.

If the text is already selected, point to the border of the text and drag it to the position you want.

To resize unattached text:

1. Select the text.

2. Drag a black selection handle until the text is the size you want it.



Changing the Font of Chart Text

To change the font:

1. Double-click the text and then choose the Font button. You can also select the text or the chart item 
to which the text is attached and choose the Font command from the Format menu.

2. In the Font box, select the font you want. Graph shows a sample of what the new formatting looks 
like.

3. In the Size box, select the size you want. 

You can also type a size. However, if you type a size that is not listed, the results may not be 
satisfactory.

4. Under Style, select or clear the check boxes for the styles you want.

5. In the Color list, select a color.

If you want to select the color that was set for the window text color in the Windows Control Panel, 
select Automatic. 

6. Under Background, select how you want the area behind the text to appear.

To see the pattern behind the text, select the Transparent option button.

To see a solid color behind the text regardless of the pattern of the item behind the text, select the 
Opaque option button.

7. Click the OK button or press Enter.

See Also

Aligning and Orienting Chart Text

Changing Fonts in the Datasheet

Changing Text Borders and Area Patterns

Tick-Mark Labels

For information about how to change the available colors, see the Color Palette command.



Aligning and Orienting Chart Text

You can change the horizontal and vertical alignment of attached and unattached chart text relative to the 
edges of the area containing the text. You can rotate text to a vertical orientation. You can also specify 
whether the border automatically changes size to fit the text or stays the same size until you change it. If 
you attach text to a data point, you can also display the marker or series pattern next to the text or 
replace the text with the data marker's value.

To change the alignment and orientation of chart text:

1. Double-click the text, and then click the Text button. You can also select the text and choose the 
Text command from the Format menu.

2. Select the options you want for horizontal and vertical alignment and orientation.

3. If you want the border of unattached text to automatically adjust to fit the text, select the Automatic 
Size check box. If you want the text border size to remain fixed until you change it, clear the 
Automatic Size check box. If you size the text border yourself, the Automatic Size check box is 
cleared. 

4. To restore the default text entered by Microsoft Graph when you first attached the text, select the 
Automatic Text check box.

5. If the text is attached to a data point, select the Show Value option button to replace the text with 
the marker's value; select the Show Key option button to display the pattern used by the marker or 
series next to the text.

6. Click the OK button or press Enter.

See Also

Changing the Font of Chart Text

Changing Fonts in the Datasheet

Changing Text Borders and Area Patterns

Tick-Mark Labels



Changing Text Borders and Area Patterns

To change the style, color, and weight of text borders and the pattern and color of the text area:

1. Double-click the text, or select the text and choose Patterns from the Format menu.

2. Select the border and area options you want. Microsoft Graph shows a sample of what the formats 
look like.

3. Click the OK button or press Enter.

See Also

Aligning and Orienting Chart Text

Changing the Font of Chart Text

Changing Fonts in the Datasheet

Chart Title, Axis Titles, and Data-Point Labels

Tick-Mark Labels



Adjusting Data Values in the Chart

You can drag the data markers on a chart to increase or decrease their value. This changes the value on 
the datasheet.

You can drag markers on 2-D line charts, bar charts, column charts, and xy (scatter) charts.
You cannot drag markers beyond the current range of the y-axis.

To adjust data values in the chart:

1. Select the data marker you want to adjust by holding down Ctrl as you click the marker.

2. Drag the black handle in the direction you want to change the value.

As you drag, a line appears on the y-axis to show the adjusted value. When you release the mouse 
button, Graph stores the new value in the datasheet.

See Also

Overview of Entering and Editing Cell Data



Formatting the 3-D Chart View

To adjust the angle from which you view the 3-D chart:

1. From the Format menu, choose 3-D View.

2. To show axes at right angles to each other, select the Right Angle Axes check box.

To show axes in perspective, clear the Right Angle Axes check box.

If you clear the Right Angle Axes check box, the Perspective box appears.

3. In the Elevation, Perspective, and Rotation boxes, click the arrows to adjust the values or type the 
values you want.

4. In the Height box, type the percentage of the x-axis length you want used as the height of the chart.

5. Click the OK button or press Enter.

Notes    The Perspective option is not available for 3-D bar charts; 3-D bar charts always have the Right 
Angle Axes check box selected.

The Apply button in the dialog box applies the current settings to the chart without closing the dialog box. 
This allows you to see and correct the current settings without having to choose the command again. The 
Default button returns the settings to the default values.



Overview of Microsoft Graph

What Is Microsoft Graph?

Starting and Quitting Graph

See Also

Creating a New Chart



What Is Microsoft Graph?

Microsoft Graph is an application you use from within other applications to display numeric data in 
graphic form for presentation and analysis.

When you start Graph, two windows appear, one with sample data and one with a sample chart. You can 
edit the data in the Datasheet window, replace this data with entirely new data, or import data from a file 
created by another application, such as Microsoft Excel. Graph redraws the chart in the Chart window to 
reflect changes in the datasheet. You can change the chart type and many details of the chart.
A chart created with Microsoft Graph is said to be embedded in your document. You can copy, cut, and 
resize this embedded chart with commands from your document's main application. But to edit the chart 
itself or its underlying data, you need to open Microsoft Graph. You do this by double-clicking the chart.

See Also

Creating a New Chart

Starting and Quitting Graph



Starting and Quitting Graph

To create a new chart within another document:

1. Select the place in your document where you want to insert a chart.

2. Insert a Microsoft Graph chart in your document, following the instructions in the documentation for 
the main application you are using to create your document.

The Graph window opens. If your main application sent data to Graph, a chart of that data appears. 
If your main application did not send data to Graph, the default datasheet and chart appear.

To open an existing chart for editing:

Double-click an existing chart in your document.
The Graph window opens, showing the datasheet and chart.

To quit Graph:

1. From the File menu in Graph, choose Exit And Return.

A message appears asking if you want to update changes.

2. If you want to update the chart in your main document, choose Yes.

The Graph window closes; changes made to the chart are now reflected in your document.

If you want to quit Graph without keeping the changes you've made, choose No.

The Graph window closes; changes made to the chart since the last time it was updated are lost.

For information on switching between windows, see your Windows documentation.

Note You do not save your chart and data in Microsoft Graph. When you close Microsoft Graph, your 
chart appears within your document. The chart is now an object that you can move, copy, cut, paste, and 
size in your document. When you save your document, the chart and data are saved in the same file with 
the document. 

See Also

What Is Microsoft Graph?

Creating a New Chart

Updating Changes to the Chart



Restore command (Control menu)

Restores the active window to the size and location it had before you chose the Maximize or the 
Minimize command. With the mouse, click the Restore button on the window you want to restore.

This command does not affect changes made to a window with the Move or Size command.

Shortcut:    Ctrl+F5 (restores Graph window)



Move command (Control menu)

Displays a four-headed arrow that you can use to move the active window. Press the arrow keys; then 
press Enter.

If a dialog box is open and has a Control menu, you can also use this command to move the 
dialog box.

If the window is maximized, this command is unavailable.
Shortcut:    Ctrl+F7 (moves the document window)



Size command (Control menu)

Displays a four-headed arrow you can use to change the size of the active window. Press the arrow keys 
to size the window; then press Enter.

Appears dimmed if the window is maximized.
Shortcut:    Ctrl+F8 (resizes document window)

Tasks That Use This Command

Sizing Charts



Maximize command (Control menu)

Enlarges the active window to fill the available space.

Clicking the Maximize button is the same as choosing Maximize.

The Maximize command on the Microsoft Graph Control menu expands the Graph window to fill 
the entire screen.

The Maximize command on the Datasheet Control menu expands the Datasheet window to fill 
the entire Microsoft Graph window. 

You can restore a maximized window to its former size by using the Restore command.
Shortcut:    Ctrl+F10 (maximizes the document window)



Close command (Control menu)

Closes the Graph window or the active document window. If a dialog box is open and has a Control 
menu, choosing this command closes the dialog box.

Double-clicking the Control-menu button is the same as choosing Close.

Closing the Graph window is the same as choosing Exit And Return from the    File menu.
Shortcut:    Alt+F4 (closes Graph window)



Switch To command (Control menu)

Lists all the open applications. This command appears only on the Graph Control menu.

Dialog Box Options

Switch To

Activates the selected application.

End Task

Quits the selected application.

Cancel

Closes the Task List window.

Cascade

Sizes all open applications so that they overlap with each title bar visible.

Tile

Maximizes all open applications and sizes them so that the upper-left portion of each window is 
visible.

Arrange Icons

Arranges the icons of all minimized applications across the bottom of the screen.



Next Window command (Control menu)

Activates the next document window. This command appears only on the Chart and Datasheet Control 
menus.

Shortcut:    Ctrl+F6 



Minimize command (Control menu)

Shrinks the Microsoft Graph window to an icon at the bottom of the screen.

Clicking the Minimize button is the same as choosing Minimize.

Minimizing is useful when you are running another application at the same time as Microsoft 
Graph.

This command appears only on the Control menu for Graph. A document window cannot be 
minimized.

You can restore a minimized window to its former size by using the Restore command.



Overview of Entering and Editing Cell Data

There are two ways to enter or edit data in a cell:

Select a cell and start typing. 
The data you type replaces all of the existing data in that cell when you press Enter.
Double-click a cell or select a cell and press F2.
The Cell Data dialog box appears with the contents of the cell.    You can move the insertion point 

within this dialog box with the mouse or arrow keys and enter or edit data as necessary.    Click the OK 
button or press Enter when you are finished.

You need to enter a name for each series, a label for each category of data points, and a number for 
each value to be plotted on the chart. If series are in rows, enter the series names in the first column 
and the category labels in the first row. If series are in columns, enter the series names in the first row 
and the category labels in the first column.

Tasks for Entering and Editing Cell Data

Changing Column Width

Copying Data

Creating a New Chart

Deleting Data

Deleting Rows and Columns

Importing Data from Other Files

Inserting Rows and Columns

Moving Around the Datasheet

Moving Data

Selecting Cells

Undoing Changes

Note    If a number is too long to be displayed in a cell that has the General format (the default), Microsoft 
Graph stores the value as you enter it, but displays the number in scientific notation.    For example, 
250,000,000 would be displayed as 2.5E+08.    If the number in exponential notation is still too long, or if 
the cell has any format other than General, Microsoft Graph displays a series of number signs (#####).    
Widen the column to see the number.

See Also

Defining Series In Rows or Columns

Keys for Editing in the Cell Data Dialog Box



Changing Column Width

Columns can be from 1 to 255 characters wide.    The default width is nine characters.

To change the width of columns:

With the Mouse

1. Point to the vertical line to the right of the column heading.

2. When the pointer changes to a vertical bar with arrows on each side, drag to the right to widen the 
column or drag to the left to narrow it.

With the Keyboard

1. Select a cell in each column you want to change.

2. From the Format menu, choose Column Width.

3. Type the width you want or select the Standard Width check box.

4. Click the OK button or press Enter.

See Also

Deleting Rows and Columns



Copying Data

1. Select  the cell or cells to copy.

2. From the Edit menu, choose Copy.

This puts a copy of the data onto the Clipboard.

3. Select the upper-left cell of the area where you want to put the copy.

4. From the Edit menu, choose Paste.

See Also

Copying the Entire Chart

Deleting Data

Moving Data



Deleting Data

You can remove data from cells, remove formatting from cells (return the cells to General format), or 
remove both data and formatting from cells.    You can delete the cells themselves only by deleting an 
entire row or column.

1. Select  the cells containing the data you want to delete.

2. From the Edit menu, choose Clear.

3. Select the Clear Data option button to remove the data, the Clear Format option button to remove 
the formatting but not the data, or the Clear Both option button to remove both the formatting and 
the data.

4. Click the OK button or press Enter.

Note    Cleared data is not put onto the Clipboard. You can recover cleared data by choosing Undo from 
the Edit menu before you choose any other commands.

See Also

Copying Data

Deleting Rows and Columns

Moving Data



Deleting Rows and Columns

To delete rows or columns:

1. Select the rows or columns you want to delete. 

You can select several rows or columns by dragging across several row or column headings.

2. From the Edit menu, choose Delete Row/Col.

If you do not select entire columns or rows before choosing Delete Row/Col, a dialog box appears 
asking whether you want to delete columns or rows. 

See Also

Inserting Rows and Columns



Importing Data from Other Files

To enter data from another file, you can import it from a file on the disk or you can copy it from an open 
document. For information about what can be imported, see File Formats. For information about how 
Microsoft Graph converts Lotus 1-2-3 number formats, see Lotus 1-2-3 Data.

To import data from a file on the disk:

1. Select the cell where you want the imported data to begin, usually the upper-left cell in the 
datasheet.

2. From the File menu, choose    Import Data.

3. In the Files box, select the file you want, changing the directory in the Directories box if necessary.

4. To import all the data in the file, select the All option button. To import part of the data, type a range 
of data or a range name in the Range box.    For example, to import cells A1 through B5, type A1:B5 
in the Range box.    For a text file, A1:B5 means import the first two values (A through B) in the first 
five lines (1 through 5).

5. Click the OK button or press Enter.

The data is imported, beginning with the active cell. Imported data replaces any existing data in 
cells. If there are cells not needed for the imported data, any existing data in those cells is left 
intact.

To import a Microsoft Excel chart:

1. From the File menu, choose Open Microsoft Excel Chart.

2. In the Files box, select the file. If necessary, change directories in the Directories box.

3. Click the OK button or press Enter.

The data and chart formatting completely replace any existing data and formatting.

To copy data from an open document:

1. Switch to the application containing the document you want to copy from.

2. Select the data you want to copy.

3. From the application's Edit menu, choose Copy.

4. Switch to Graph.

5. Activate the Datasheet window.

6. Select the cell in which you want the copied data to begin.

7. From the Edit menu in Graph, choose Paste.

See Also

Moving Data

Copying Data

Creating a New Chart



File Formats

With the Import Data command on the File menu, you can import data from ASCII (text-only) files in 
which fields are separated by commas or tab characters (.CSV files). You can also import data that is in 
one of these file formats:

.WKS Lotus 1-2-3 (version 1A) and Microsoft Works

.WK1 Lotus 1-2-3 (version 2.0)

.WR1 Lotus Symphony

.XLS Microsoft Excel worksheet

.SLK Microsoft Multiplan, Microsoft Excel, and other symbolic link files

With the Open Microsoft Excel Chart command on the File menu, you can import a Microsoft Excel chart 
(.XLC extension). 

Imported data can be up to 4000 rows long by 256 columns wide. 
Graph begins importing data at the first selected cell.
Imported data replaces existing data.
If the descriptive labels are not imported into the first row and column of the datasheet, use the 

Cut and Paste commands on the Edit menu to move the labels into the first row and column so they will 
appear on the chart.

For information about how Microsoft Graph converts Lotus 1-2-3 number formats, see Lotus 1-2-3 
Data.

See Also

Importing Data from Other Files



Lotus 1-2-3 Data

When you import data from a Lotus 1-2-3 document, Microsoft Graph converts Lotus 1-2-3 number 
formats as shown in the following table.    Microsoft Graph attempts to convert to a format with the same 
number of decimal places as specified in Lotus 1-2-3.    If necessary, Microsoft Graph creates a custom 
format to accommodate extra decimal places.

Lotus 1-2-3 format Microsoft Graph format
Fixed, 0 decimals 0

Fixed, 2 decimals 0.00

Scientific, 0 decimals 0E+00

Scientific, 2 decimals 0.00E+00

Currency, 0 decimals $#,##0;($#,##0)

Currency, 2 decimals $#,##0.00;($#,##0.00)

Percent, 0 decimals 0%

Percent, 2 decimals 0.00%

Comma, 0 decimals #,##0;(#,##0)

Comma, 2 decimals #,##0.00;(#,##0.00)

General General

+/- General

Date1 (dd-mmm-yy) d-mmm-yy

Date2 (dd-mmm) d-mmm

Date3 (mmm-yy) mmm-yy

Text General

For more information about the formats available in Microsoft Graph and the meanings of the formatting 
symbols, see Creating Custom Number Formats.

See Also

Importing Data from Other Files

File Formats



Inserting Rows and Columns

The datasheet can contain a maximum of 4000 rows and 256 columns.    If there are already 4000 rows 
or 256 columns containing data, a message will appear when you attempt to insert more.

To insert rows or columns:

1. Select the number of rows or columns you want to insert. For example, if you want to insert one 
column, select one column; if you want to insert three rows, select three rows.

You can select several rows or columns by dragging across several row or column headings.

2. From the Edit Menu, choose Insert Row/Col.

If you do not select entire columns or rows before choosing Insert Row/Col, a dialog box appears 
asking whether you want to insert columns or rows. Rows are inserted above the selected row; 
columns are inserted to the left of the selected column.

See Also

Deleting Rows and Columns



Moving Around the Datasheet

With the Mouse

Click the cell you want to move to.
Use the scroll bars to scroll through the datasheet. Scrolling changes only the screen display; the 

active cell and current selection do not change.

With the Keyboard

To move Press
One cell Arrow key 

To beginning of row Home

To first data cell Ctrl+Home

        (row 2, column 2)

To end of row End

        (last occupied column)

To lower-right cell with data Ctrl+End

Down one window Page Down

Up one window Page Up

Right one window Ctrl+Page Down

Left one window Ctrl+Page Up

See Also

Keys for Moving and Selecting in the Datasheet



Moving Data

1. Select  the cell or cells that contain the data you want to move.

2. From the Edit menu, choose Cut.

This puts a copy of the data onto the Clipboard.

3. Select the upper-left cell of the area where you want to move the data.

4. From the Edit menu, choose Paste.

Note    If you move data to cells that already contain data, the moved data and formats replace the 
original data.

See Also

Copying Data

Deleting Data



Selecting Cells

There is always at least one cell selected, the active cell. To change the active cell, select another cell.

With the Mouse

To select Do this
One cell Click the cell.

Group of cells Drag from one corner of the group to the opposite corner.

Row or column Click the row or column heading.

All cells Click the upper-left corner of the datasheet.

With the Keyboard

To select Do this
One cell Use the arrow keys.

Group of cells Hold down Shift as you use the arrow keys to extend the selection.    Or press F8 
to turn on Extend mode; then use the arrow keys to select the cells you want (no 
need to hold down Shift); then press F8 to cancel Extend mode.

Entire row Press Shift+Spacebar.

Entire column Press Ctrl+Spacebar.

All cells Press Ctrl+Shift+Spacebar or choose Select All from the Edit menu.

Cancel selection of Press Shift+Backspace
        all but active cell

See Also

Moving Around the Datasheet

Keys for Moving and Selecting in the Datasheet



Undoing Changes

To undo the last change you made to the chart or datasheet:

From the Edit menu in Microsoft Graph, choose Undo.

To cancel all the changes you have made to the chart:

1. From the File menu in Graph, choose Exit And Return.

2. When the message appears asking if you want to update changes, choose the No button.



Overview of Arranging Data for a Chart

Graph initially assumes that each row in the datasheet contains a series of values or data points that 
should be plotted using the same color and pattern. If your data is arranged in columns    rather than 
rows, you have to define the series in columns. You can also choose to have Graph exclude particular 
rows or columns of data when making a chart. There are some special considerations for creating xy 
(scatter) charts and overlay charts. 

Tasks for Arranging Data for a Chart

Defining Series in Rows or Columns

Entering Data for an Overlay Chart

Entering Data for an XY (Scatter) Chart

Including and Excluding Data from the Chart



Defining Series In Rows or Columns

A series is one row or column of data points that are displayed as a set of data markers on the chart, 
such as bars, lines, or pie slices. What you type into the first row and column of cells and which 
orientation you choose (series in rows or series in columns) determines how the data is plotted on the 
chart. The default chart is plotted with series in rows. 

When you choose the Series In Rows command, the text in the first column of the datasheet 
appears in the legend as series names.    The text in the first row (category names) appears on the 
horizontal axis of the chart as tick-mark labels.

When you choose the Series In Columns command, the text in the first row of the datasheet 
appears on the legend as series names.    The text in the first column (category names) appears on the 
horizontal axis of the chart as tick-mark labels.

To plot series in rows or columns:

From the DataSeries menu, choose Series In Rows or Series In Columns.
A check mark appears next to the current setting in the menu.

See Also

Entering Data for an XY (Scatter) Chart

Including and Excluding Data from the Chart



Entering Data for an XY (Scatter) Chart

Instead of plotting numeric values along one axis and labels along the other, an xy (scatter) chart plots 
values along both axes. This shows the relationship between two or more series of values.

To create an xy (scatter) chart, you must include at least two series in the datasheet.    Each pair of 
values in the datasheet is plotted as a data point on the scatter chart. A value from one series determines 
the data point's location along the x-axis (horizontal axis), and a value from the other series determines 
the point's location along the y-axis (vertical axis).

By default, the first series in the datasheet is used to calculate tick-mark labels along the x-axis. You can 
change which series is used with the Plot On X Axis command from the DataSeries menu.

Example

The following example includes a datasheet with two series in columns, Time and Distance.    In the first 
chart, the Time series is plotted on the x-axis. Therefore, the marker for Smith is positioned along the x-
axis (horizontal axis) at 3.8 and along the y-axis (vertical axis) at 12.

In the second chart, the Distance series is plotted on the x-axis. Therefore, the marker for Smith is 
positioned along the x-axis at 12 and along the y-axis at 3.8.



Entering Data for an Overlay Chart

When you create an overlay chart with the Combination command from the Gallery menu, Graph plots 
half of the data series in the main chart and half in the overlay. If there is an odd number of series, Graph 
plots one series more in the main chart than in the overlay. You can change which series are in the main 
and overlay charts with the Move To Chart and Move To Overlay commands from the DataSeries menu.

In the datasheet, series included in the overlay chart are indicated by a white dot in the row or column 
heading. 

See Also

Overlay Charts



Including and Excluding Data from the Chart

All rows and columns containing data are included in the chart by default.    When you exclude data, 
Graph redraws the chart without the excluded data.    Excluded rows and columns appear dimmed in the 
datasheet.

There are three ways to exclude rows and columns:

Double-click the headings of the rows or columns you want to exclude from the chart. 
OR

1. Select the rows or columns you want to exclude.

2. From the DataSeries menu, choose Exclude Row/Col.

3. If you have not selected entire rows or columns, a dialog box appears. Select the Exclude Rows or 
Exclude Columns option button.

4. Click the OK button or press Enter.

OR

1. In the chart window, select the series you want to exclude.

2. Choose Clear from the Edit menu.

3. Select the Series option button.

4. Click the OK button or press Enter.

To include excluded rows and columns:

Double-click the headings of the excluded rows or columns.
OR

1. Select the excluded rows or columns.

2. From the DataSeries menu, choose Include Row/Col.

3. If a dialog box appears, select the Include Rows or Include Columns option button.

4. Click the OK button or press Enter.



Overview of Formatting Data

The way numbers are formatted in the datasheet--currency, percentage, number of decimal places, and 
so on--determines the way numbers appear in the chart. The width of columns in the datasheet and the 
font used do not affect the chart in any way.

Tasks for Formatting Data

Changing Fonts in the Datasheet

Creating Custom Number Formats

Deleting Custom Number Formats

Formatting Numbers

Formatting Tick-Mark Labels

Note    Microsoft Graph uses the settings defined in the operating system to determine the default 
settings for the currency sign, the date format, and list separators. For example, if your operating system 
is configured for Sweden, Microsoft Graph uses "kr" as the currency sign, day-month-year as the date 
format, and semicolon (;) as the list separator. To change these defaults, change the International 
settings in the Windows Control Panel. For more information, see your Windows documentation.



Changing Fonts in the Datasheet

You can assign one font, size, and font style for the entire datasheet.    Only fonts and sizes for the printer 
selected in your document's main application appear in the lists.    For information about changing the 
printer, see the documentation for your main application. 

To change the font, size, and font style of the datasheet:

1. From the Format menu, choose Font.

2. In the Font box, select a font.

3. In the Size box, select a size or type the size you want.

4. Select the style options you want.

5. Click the OK button or press Enter.

See Also

Changing the Font of Chart Text



Creating Custom Number Formats

To create a custom number, date, or time format:

1. Select the cells in the datasheet you want to format.

2. From the Format menu, choose Number.

3. Select a built-in format to use as a model and edit it in the Format box.

You can also type a new format in the Format box.

4. Click the OK button or press Enter.

The new format is added at the end of the list.

Formats can have up to three sections separated by semicolons. The first section is for positive numbers, 
the second for negative numbers, and the third for zeros. If you specify only two sections, zeros are 
formatted like positive numbers. If you specify only one section, all numbers are formatted that way.

Examples

Format Number Displayed
000-00-0000 987654321 987-65-4321

"Acct. No. "0000 8997 Acct. No. 8997

 #,##0 \l\b\s 4567 4,567 lbs

0;-0; 0 (not displayed)

0.00E-00 2000000 2.00E06

d-mmm-yy 365 30-Dec-00

dddd 365 Sunday

[Red]General 1000 1000 (appears red)

See Also

Deleting Custom Number Formats

For a list of all symbols you can use to create custom number formats, see Number Format Symbols.



Number Format Symbols

0 Display digit, even if zero.

# Display digits other than zero.

; Separates formats for positive, negative, and zero values.

. Decimal point.

, Thousands separator.

% Percentage. Microsoft Graph multiplies the number entered by 100 and adds a 
percent sign.

$ - + ( ) space Display these characters.    These characters are included in the number format 
where you place them.    You can include other characters by preceding them with a 
backslash (\) or by enclosing them in double quotation marks (" "). 

[red] Display the cell contents in the specified color, even if that color is no longer in the 
color palette. Valid colors are red, green, blue, cyan, yellow, magenta, black, and 
white.

d Display the day as a number.

dd Display the day as a two-digit number.

ddd Display the three-letter abbreviation for the day of the week.

dddd Display the day of the week as a complete word.

m Display the month as a number.

mm Display the month as a two-digit number.

mmm Display the three-letter abbreviation for the month.

mmmm Display the month as a complete word.

yy Display the last two digits of the year.

yyyy Display the year in full.

h Display the hour.

mm Display the minutes.

ss Display the seconds.

E-    E+ e- e+ Display the number in scientific format.

"text" Display the text between the double quotation marks.

\ Display the following character (same as enclosing it in double quotation marks).

* Repeat the following character enough times to fill the column width.    You cannot 
have more than one asterisk in each section of a format.

See Also

Creating Custom Number Formats

Formatting Numbers

Number command



Deleting Custom Number Formats

To delete a custom number, date, or time format:

1. From the Format menu, choose Number.

2. Select the format you want to delete.

You cannot delete built-in formats.

3. Choose the Delete button.

4. If you want to apply the General format to the selected cells, click the Cancel button or press Esc.

If you want to apply another format to the selected cells, select the format; then click the OK button 
or press Enter.

See Also

Creating Custom Number Formats



Formatting Numbers

The format you choose for numbers in the datasheet affects the way the data appears in the datasheet 
and the way tick marks are labeled on the axes. You can use a built-in format or create a custom format.

To change the format of numbers in the datasheet:

1. Select  the cell or cells you want to format.

2. From the Format menu, choose Number.

3. In the Number Format box, select a format or type your own in the Format box.

4. Click the OK button or press Enter.

For example, to see dollar signs before the numbers along the vertical axis, choose a format that 
includes a dollar sign for the numbers in the datasheet.

Microsoft Graph uses the General format as the default for all cells in the datasheet.    The General 
format displays numbers as precisely as possible.    If the number is longer than what will fit in the cell, 
Microsoft Graph displays it in scientific notation. If it is not possible to display the number in the cell, it 
is shown as a sequence of number signs (#).    Increase the column width to see the number in your 
chosen format.

Each built-in format other than General is a sequence of symbols that describe how the format looks.

Examples

Format Example
General 5

0 5

0.00 5.00

#,##0 5

#,##0.00 5.00

$#,##0;($#,##0) $5

$#,##0;[Red]($#,##0) $5

$#,##0.00;($#,##0.00) $5.00

$#,##0.00;[Red]($#,##0.00) $5.00

0% 500%

0.00% 500.00%

0.00E+00 5.00E+00

m/d/yy 1/5/00

d-mmm-yy 5-Jan-00

d-mmm 5-Jan

mmm-yy Jan-00

h:mm AM/PM 12:00 AM

h:mm:ss AM/PM 12:00:00 AM

h:mm 0:00

h:mm:ss 0:00:00

m/d/yy h:mm 1/5/00 0:00

See Also

Changing Fonts in the Datasheet

Creating a New Chart

Creating Custom Number Formats

Formatting Tick-Mark Labels

Number Format Symbols



Tick-Mark Labels



Formatting Tick-Mark Labels

The format of the cell containing the first data point of the first included series determines the format of 
numeric tick-mark labels in the chart.    In the default datasheet, this is the cell in the second row and 
second column.

If the second row or the second column is excluded, Graph uses the number format of the first 
included cell instead.

For xy (scatter) charts, the number format you assign to the first cell in the series plotted on the x-
axis applies to all numbers along the horizontal axis.

See Also

Formatting Numbers

Tick-Mark Labels



Plot On X Axis command (DataSeries menu)

Specifies the series used to calculate tick-mark labels along the x-axis of an xy (scatter) chart.

Appears dimmed if the chart is not an xy (scatter) chart or if the Datasheet window is not active.
The default is the first row or column in the datasheet.
An X appears at the left of the row or at the top of the column containing the series used for the x-

axis.

Tasks That Use This Command

Entering Data for an XY (Scatter) Chart

See Also

Defining Series in Rows or Columns



Include Row/Column command (DataSeries menu)

Includes data in selected rows or columns in the chart.

Appears dimmed if the Datasheet window is not active.
All rows and columns containing data are included in the chart by default. 
Use this command to restore rows or columns you have excluded with the Exclude Row/Col 

command.
If you have not selected entire rows, when you choose this command a dialog box appears 

asking if you want to include rows or columns. 

Shortcut:    Double-click the heading of the row or column you want to include or exclude.

Tasks That Use This Command

Including and Excluding Data from the Chart



Exclude Row/Column command (DataSeries menu)

Excludes data in selected rows or columns from the chart.    The data remains on the datasheet but is not 
used in drawing the chart.

Appears dimmed if the Datasheet window is not active.
You can restore excluded rows or columns to the chart with the Include Row/Col command.

If you have not selected entire rows, when you choose this command a dialog box appears 
asking if you want to exclude rows or columns. 
Shortcut:    Double-click the heading of the row or column you want to include or exclude.

Tasks That Use This Command

Including and Excluding Data from the Chart



Series In Rows command (DataSeries menu)

Plots each row in the datasheet as a single series.

This command name is preceded by a check mark if series are already in rows.
Double lines separate rows on the datasheet to indicate that series are in rows.
Text in the first column appears on the chart as series names.
Text in the first row appears on the chart as labels along the category (x)    axis. XY (scatter) 

charts are an exception; see Entering Data for an XY (Scatter) Chart.
If series are in columns and you have an overlay chart, this command deletes the overlay chart 

and returns all series to the main chart.

Tasks That Use This Command

Defining Series in Rows or Columns

See Also

Series     In     Columns command  



Series In Columns command (DataSeries menu)

Plots each column in the datasheet as a single series.

This command name is preceded by a check mark if series are already in columns.
Double lines separate columns on the datasheet to indicate that series are in columns.
Text in the first row appears on the chart as series names.
Text in the first column appears on the chart as labels along the category (x) axis.    XY (scatter) 

charts are an exception; see Entering Data for an XY (Scatter) Chart.
If series are in rows and you have an overlay chart, this command deletes the overlay chart and 

returns all series to the main chart.

Tasks That Use This Command

Defining Series in Rows or Columns

See Also

Series In Rows command



Move To Overlay command (DataSeries menu)

Plots the selected series on the overlay chart rather than the main chart.

Appears dimmed if the chart is an xy (scatter) chart and the series plotted on the x-axis is 
selected.

A white dot appears in the row or column heading for each series plotted in the overlay chart.
If a selected series is excluded, this command includes it.
If series are in rows, the first row of the datasheet cannot be in the overlay; if series are in 

columns, the first column of the datasheet cannot be in the overlay.
Overlays cannot be added to 3-D charts.

Tasks That Use This Command

Creating an overlay chart

See Also

Move To Chart command



Move To Chart command (DataSeries menu)

Plots the selected series on the main chart    rather than the overlay chart.

Appears dimmed if the chart is a 3-D chart.
Appears dimmed if the chart is an xy (scatter) chart and the series plotted on the x-axis is 

selected.
A white dot appears in the row or column heading for each series plotted in the overlay chart.
If a selected series is excluded, this command includes.

Tasks That Use This Command

Deleting an overlay chart

See Also

Move To Overlay command



Definition of Terms

active cell

attached text

axis

category

category axis

cell 

chart

Clipboard

data point

data-point labels

data series

drop lines

exclude

floor

gridlines

hi-lo lines

legend

main application

marker

overlay chart

plot area

row/column headings

series

series axis

series lines

series name

tick mark

tick-mark label

unattached text

up/down bars

value axis

value label

walls



active cell

The cell with a thick border around it. What you type is entered into this cell.



axis

A line that serves as a reference for plotting data in a chart. Charts other than pie charts have two axes; 
3-D charts have three axes.



category

A group or cluster containing one data point from each series included in the chart. The first category 
contains the first data point from each series, the second category contains the second data point, and 
so on. The categories are arranged along the x-axis and are usually separated by tick marks and labeled 
with tick-mark labels.



category axis

The data points are arranged along the x-axis or category axis in groups or categories. The first category 
comprises the first data point of each series, the second category comprises the second data point of 
each series, and so on.



cell 

The intersection of any row and column on the datasheet. You enter data into cells. A cell on the 
datasheet can be represented on the chart by a data point or a label.



chart

A graphic presentation of the data on the datasheet.



Clipboard

The Clipboard holds the last item or data you copied using the Copy command or cut using the Cut 
command. The Paste command from the Edit menu inserts the contents of the Clipboard into your 
document. For more information about the Clipboard, see your Windows documentation.



data-point labels

Labels that identify either individual data points or a series of data points.



data point

A numeric value represented on the datasheet by a number in a cell and in the chart by a column, bar, 
pie slice, marker, area, or point along a line.



drop lines

Vertical lines that extend from the highest value in each group of data points to the horizontal axis. These 
lines guide your eyes to the corresponding tick marks on the axis.



exclude

Graph initially uses all the data in the datasheet to draw the chart. You can exclude one or more rows or 
columns of data from the chart by double-clicking the row or column heading or by choosing the Exclude 
Row/Col command from the DataSeries menu. Excluded data remains in the datasheet but is not used in 
drawing the chart.



floor

The area bounded by the x-axis and y-axis of a 3-D chart.



gridlines

Lines that extend from the tick marks on an axis across the chart.



hi-lo lines

Lines that extend from the highest value to the lowest value in each cluster of data points.



legend

A key that identifies the patterns, colors, or symbols associated with the data points and series.



main application

The application from which you started Microsoft Graph.



marker

A symbol that represents a single data point (a value from one cell on the datasheet) on the chart. The 
type of chart determines the shape of the marker: column, bar, area, or pie slice. In line and xy (scatter) 
charts, a variety of marker shapes are available; the markers may be connected by lines and made 
invisible or not.



overlay chart

A second chart plotted on top of the main chart. Usually the overlay chart uses a different axis scale or 
chart type than the main chart. All charts created with the Combination command from the Gallery menu 
include overlay charts.



plot area

The area within which the data is plotted. In a 2-D chart, the horizontal and vertical axes are two of the 
sides of the rectangular plot area. In a 3-D chart, the plot area encloses the three axes, their tick-mark 
labels, and their titles.



row/column headings

The areas above the top row and to the left of the first column of the datasheet. Click a heading to select 
an entire row or column. Double-click a heading to quickly include or exclude rows or columns from the 
chart. A heading appears dark when the row or column is included and dimmed if it is excluded. A white 
circle in a row or column heading means that that data series is included in the overlay chart. If the chart 
is an xy (scatter) chart, an X in a row or column heading means the series that is used to calculate the x-
axis scale.



data series (also called series)

A group of related data points in a row or column. A data series appears in the chart as a set of bars, 
columns, lines, or other markers, depending on the type of chart. A chart can have one or more series.



series name

The name that identies a row or column of data. Series names appear in the legend.



series axis

In some types of 3-D charts, the series are arranged one behind the other along the y-axis or series axis. 
A 2-D chart does not have a series axis.



series lines

Lines connecting the top of each bar or column to the next bar or column from the same data series. 
Series lines are available in stacked bar and stacked column charts only.



tick-mark label

The text that appears along the axes to identify the value or category represented by the tick mark.



tick mark

A small line that intersects an axis like a division on a ruler. Tick marks are considered parts of an axis. 
Double-clicking an axis displays the Patterns dialog box, in which you can specify what kind of tick marks 
you want.



value axis

The axis along which each data point is plotted according to its numeric value. In a 2-D chart, the value 
axis is the y-axis; in a 3-D chart, it is the z-axis, in accordance with standard mathematical convention.



value label

An optional label for each bar, column, area, pie slice, or point on the chart. The label is the actual 
numeric value of each data point.



walls

The back and side of the plot area in a 3-D chart.



attached text

Text that is attached to a chart item, such as an axis. Attached text moves with the item; it cannot be 
moved separately. When selected, attached text is surrounded with white squares to indicate that it 
cannot be moved or sized. There are three kinds of attached text: chart title, axis titles, and data-point 
labels. Tick-mark labels are considered part of the axis.



unattached text

Text that can be placed anywhere on the chart. When unattached text is selected, it is surrounded with 
black handles that you can drag to move or size the text.



up/down bars

A rectangle that extends from the opening price to the closing price on a given day. Up/down bars are 
intended for open-high-low-close charts, which track stock prices. They are available for line charts only.



Undo command (Edit menu)

Reverses the last change you made to the datasheet or chart.

Appears dimmed if the last change is not reversible.
The command name reflects the action that will be reversed (for example, Undo Cut).

Shortcut:    Ctrl+Z

Tasks That Use This Command

Undoing Changes



Cut command (Edit menu)

Removes data and formats from selected cells and puts them onto the Clipboard. 

Appears dimmed when the Datasheet window is not active.
Shortcut:    Ctrl+X

Tasks That Use This Command

Moving Data

See Also

Clear command



Copy and Copy Chart commands (Edit menu)

Copies data and formatting from selected cells or the entire chart onto the Clipboard.

Shortcut:    Ctrl+C

On the Datasheet

You can paste copied data into another area of the datasheet or into another application with the 
Paste command from the Edit menu.

On the Chart

Copy Chart copies the entire chart onto the Clipboard.
You can paste a copied chart into another application as a picture or as an active, embedded 

chart, depending on the capabilities of the application.    Double-clicking the embedded chart starts Graph 
so you can edit the chart.

Tasks That Use This Command

Copying Data

Copying the Entire Chart



Paste command (Edit menu)

Pastes cut or copied data and formatting from the Clipboard into the datasheet, beginning at the upper-
left cell that is selected. 

Appears dimmed if no data has been copied or cut.
Before choosing Paste, select the cell in the datasheet where you want the cut or copied data to 

appear.
Pasted data replaces existing data.
To paste a copied chart into another application, use the Paste command in that application.

Shortcut:    Ctrl+V

Tasks That Use This Command

Copying Data

Importing Data from Other Files

Moving Data



Clear command (Edit menu)

Removes the selected data, item, or formatting without putting it onto the Clipboard.

Shortcut:    Delete

On the Datasheet

Clear removes the contents of selected cells, not the cells themselves. To remove cells, use the 
Delete Row/Col command from the Edit menu.

In the dialog box, you can specify whether to remove the data, the number formats, or both.
Removing number formats is equivalent to changing the format to General.

On the Chart

Clear removes the selected arrow, legend, or text (attached or unattached).
If you have selected a data series, you can clear it from the chart (this is the same as excluding a 

data series from the chart without deleting the data from the datasheet). You can also clear the formats, 
returning the markers to their default formats.

If you have selected the entire chart, you can clear the formatting, making the chart a simple 
column chart; the data, excluding all series from the chart; or both the data and formatting.

See Also

Deleting an arrow

Deleting data and Formatting

Hiding axes

Removing the legend

Resetting data-marker formats



Select All command (Edit menu)

Selects all the cells in the datasheet.

Appears dimmed if the Datasheet window is not active.
Shortcut:    Ctrl+A



Delete Row/Column command (Edit menu)

Removes selected rows or columns from the datasheet. 

Rows below a deleted row move up.
Columns to the right of a deleted column move to the left.

Shortcut:    Ctrl+Hyphen (-)

Tasks That Use This Command

Deleting Rows and Columns



Insert Row/Column command (Edit menu)

Inserts one or more rows or columns into the datasheet.

Rows are inserted above the selection.
Columns are inserted to the left of the selection.
The number of rows or columns inserted corresponds to the number of rows or columns included 

in the selection.
Shortcut:    Ctrl+Plus Sign (+)

Tasks That Use This Command

Inserting Rows and Columns



Import Data command (File menu)

Copies data from files created in other applications into the datasheet.

Appears dimmed when the Datasheet window is not active.
This command cannot be undone with the Undo command from the Edit menu.
Graph imports data beginning in the active cell; data contained in any of the cells needed for 

imported data is replaced.
You can import all or a part of the data from another file.
You can import data as large as 4000 rows by 256 columns.
You can import text (ASCII) files with the following extensions:

.CSV .TXT

You can import data from files with the following extensions:
.WKS .WK1 .WR1

.XLS .SLK

To import Microsoft Excel charts (files with the extension .XLC), use the Open Microsoft Excel 
Chart command.

Dialog Box Options

File Name

Type the filename you want.

Directory Is:

Shows the current directory.

Files

Lists all files in the current directory. You can select a filename from this list instead of typing it in the 
File Name box.

Directories

Lists all available directories. To change the current directory, double-click the drive letter or 
directory name. You can also select the drive or directory and then choose the OK button. The Files 
box is updated to show all the files in the directory you selected.

All

Imports all data.

Range

Imports the range of data you specify, for example, A1:H26. If a name has been assigned to the 
range, you can type the range name instead.

Tasks That Use This Command

Importing Data from Other Files



Open Microsoft Excel Chart command (File menu)

Copies the data and formatting from chart files created by Microsoft Excel (files with the extension .XLC) 
into Microsoft Graph.

The imported data and formatting replace any existing data and formatting.
To retain the existing chart formats while importing data from a Microsoft Excel chart file, use the 

Import Data command.
To plot the data correctly in Graph, series must be defined in columns (see Defining Series in 

Rows or Columns).
To import files other than Microsoft Excel chart files, use the Import Data command.

Dialog Box Options

Open File Name

Type the filename you want.

Directory Is:

Shows the current directory.

Files

Lists all files in the current directory. You can select a filename from this list instead of typing it in the 
Open File Name box.

Directories

Lists all available directories. To change the current directory, double-click the drive letter or 
directory name. You can also select the drive or directory and then choose the OK button. The Files 
box is updated to show all the files in the directory you selected.

Tasks That Use This Command

Importing Data from Other Files



Update command (File menu)

Updates the chart in your document with any changes you have made in the datasheet or chart.

The main application determines whether this command is available in Microsoft Graph.
If this command is dimmed, use the Exit And Return command instead.

Note  Updating changes you've made in the chart does not save them. When you close Graph, your 
chart appears within your document. The chart is now an object that you can move, copy, cut, paste, and 
size in your document. When you save your document, the chart and data are saved along with the 
document in the same file. 

Tasks That Use This Command

Updating Changes to the Chart



Set As Default Chart command (File menu)

Saves the current chart and its associated datasheet as the new default chart.

The default chart is saved in the DEFAULT.GRA file in the WINDOWS directory.
Whenever you create a chart without sending data to Microsoft Graph from the main application, 

the default chart is used.
If there is no file named DEFAULT.GRA in the WINDOWS directory (the directory containing the 

Microsoft Windows files), Graph checks that directory for DEFAULT.PPG (a file created by older versions 
of Graph). If neither DEFAULT.GRA nor DEFAULT.PPG is in the WINDOWS directory, Graph checks for 
DEFAULT.GRA in the directory in which you installed Microsoft Graph version 3.0. If no default file is 
found, Graph uses the built-in default datasheet and chart.

To return to the original default chart and datasheet:

Delete the file DEFAULT.GRA from the WINDOWS directory. For information about deleting files, 
see your Windows documentation.

Tasks That Use This Command

Setting the Default Chart



Exit And Return command (File menu)

Quits Microsoft Graph and updates the chart in your document. If you have made any changes to the 
datasheet or chart, Graph displays a dialog box asking if you want to update the document:

Yes updates the chart in your document and closes the Graph window.
No discards the changes you've made and closes the Graph window.
Cancel cancels the command.
The chart is now an object in your document.    You can move, copy, cut, paste, and size it as you 

do any other object.
When you save the document, the chart and all of its data are saved as a part of the document 

rather than in a separate file.

Tasks That Use This Command

Undoing Changes

See Also

Updating Changes to the Chart



Patterns command (Format menu)

Controls the appearance of the selected item in the chart. The options available depend on the item 
selected. 

Dialog Box Options

Automatic

Applies the default patterns to the selected item.

None

Makes the selected item or part of the chart item invisible.    When this option appears dimmed or 
does not appear at all, you cannot hide the item with the Patterns command. To find information 
about which command to use to delete or hide the item, use the Search button in the Help window 
to search for topics about an item.

Custom

Indicates whether custom formatting has been selected for the item.

Color

Controls the color of an axis, line, arrow, or item border.

You can apply colors even if you are using a monochrome monitor. On a monochrome monitor, the 
standard color names are shown on the Color list. Customized colors are labeled Color 1, Color 2, 
and so on.

Style

Controls the appearance of the border (solid, dashed, shaded, and so on) of the selected item. In a 
line or xy (scatter) chart, also controls the appearance of the lines leading to the selected data 
markers and the shape (square, triangle, star, and so on) of the selected data markers.

Weight

Controls the thickness of the axis, arrow, line, or border of the selected item.

Shadow

Adds a shadow to the bottom and right sides of an item.

Apply To All

Applies the choices you make to all data points in the chart. Available only when a data point or 
data series is selected.

Invert If Negative

Reverses the foreground and background colors of the data markers that represent negative values 
in a bar, column, area, or pie chart.

Pattern, Foreground, Background 

These three options work together to determine the pattern and color of the selected item.

If you select a solid pattern, the color of the item is the foreground color. If you choose any other 
pattern, the color of the item is a combination of the foreground color and the background color.

Tick Mark Type

Makes major or minor tick marks invisible or displays them only on the chart side of axes (inside), 
on the other side of axes (outside), or across the axes (cross).

Tick Labels

Displays tick-mark labels at the low end of the axis, high end of the axis, next to the axis, or not at 
all.

Arrow Head

Controls the style, width, and length of the arrowhead for a line.



Sample

Shows what the current settings look like so that you can see how formats look before you apply 
them to your chart and close the dialog box.

Text 

Applies the pattern changes you've made and then displays the Axis Text or Chart Text dialog box 
so you can choose the text alignment and orientation.

Scale 

Applies the pattern changes you've made and then displays the Format Axis Scale dialog box so 
you can format the selected axes.

Font 

Applies the pattern changes you've made and then displays the Font dialog box.

Legend 

Applies the pattern changes you've made and then displays the Legend dialog box so you can 
move the legend.

Tasks That Use This Command

Changing Text Borders and Area Patterns

Changing the position of tick marks relative to the axis

Formatting arrows

Formatting data markers

Formatting gridlines

Formatting the Legend

Formatting the Patterns of an Axis

Formatting the plot area, 3-D walls, or floor

Hiding and showing tick-mark labels

Hiding or showing tick marks

Moving tick-mark labels



Font command (Format menu)

Changes the font, size, style, color, and background of text. In the datasheet, this command applies to 
the entire datasheet. In the chart, this command applies only to the selected item: legend, chart title, axis 
title, data label, axis (tick-mark labels), or unattached text.

Appears dimmed if the Chart window is active and no item containing text is selected.
To change the font of all text in the chart at once, select the entire chart by clicking just outside 

the plot area before choosing the Font command.

Dialog Box Options

Font

Displays a list of the fonts you can use. Select a font from the list or type the name of the font you 
want in the box below the list. The fonts available are determined by the main application.

Size

Lists available sizes for the font selected in the Font box.    Select a size from the list or type the 
size you want in the box below the list.

Style

Contains check boxes that select the available font styles:    Bold, Italic, Underline, and Strikeout.    
You can apply one or more of these styles to the selected text.

Color

Controls the text color.    Select a color from the list or select Automatic to set the color to the color 
of the window text defined in the Control Panel for Microsoft Windows.    Unless you have changed 
the window text color, choosing Automatic sets the font color to black.

Automatic, Transparent, Opaque

These three options control the color of the background for the selected text in the chart. A 
Transparent background allows both the color and the pattern of the area behind the text to show 
through. An Opaque background is the same color as either the foreground or the background of 
the area behind the text (depending on the color of the text itself), but is solid, regardless of the 
pattern of that area. 

When the background is Automatic, Microsoft Graph applies a background to make the text 
readable.

Patterns 

Applies the font changes you've made and then displays the Area Patterns or Axis Patterns dialog 
box so you can format the border and area of the selected item in the chart. This button appears 
only if the chart is active.

Text 

Applies the font changes you've made and then displays the Axis Text or Chart Text dialog box so 
you can change the alignment and orientation of the text. This button appears only if the chart is 
active.

Scale 

Applies the font changes you've made and then displays the Format Axis Scale dialog box so you 
can adjust the scale of the selected axis. This button appears only if the chart is active and an axis 
is selected.

Legend 

Applies the font changes you've made and then displays the Legend dialog box so you can change 
the position of the legend. This button appears only if the chart is active and the legend is selected.

Column Width 

Applies the font changes you've made and then displays the Column Width dialog box so you can 
change the width of the selected column or columns. This button appears only if the datasheet is 



active.

Number Button

Applies the font changes you've made and then displays the Number dialog box so you can change 
the format of the numbers in the selected cells. This button appears only if the datasheet is active.

Sample

The Sample box in the lower right corner of the dialog box shows what the current settings look like. 
It changes as you change the settings in the dialog box so that you can see how formats look 
before you apply them to your chart and close the dialog box.

Tasks That Use This Command

Changing Fonts in the Datasheet

Changing the Font of Chart Text



Text command (Format menu) 

Controls the alignment and orientation of selected text.

Appears dimmed if no item containing text is selected or if the datasheet is active.
You can format a chart title, axis title, tick-mark labels, data-series or data-point label, or 

unattached text.
The options available depend on what type of text is selected.

Dialog Box Options

Text Alignment

Controls the horizontal and vertical alignment of selected chart text within its text border.

Orientation

Controls the direction the selected chart text faces (such as vertical, horizontal, or sideways).

If you select a vertical orientation and there is too much text to format into a single column, 
Microsoft Graph wraps the text into additional columns. 

For a chart axis, this option controls the orientation of the tick-mark labels along the axis. The 
Automatic button in the Orientation group restores the original orientation if it has been changed.

Automatic Text

If you created text with the Titles command or Data Labels command and later edited it, this option 
restores the original text.

Automatic Size

Sets the border to fit exactly around the text.    Whenever the text is changed, the border adjusts 
automatically to fit the changed text.

Show Value

If a data point or series label is selected, this option replaces the label with the value of the data 
point.

Show Key

If a data point or series label is selected, this option displays the pattern used by the data point or 
series next to the text.

Patterns 

Applies the changes you've made and displays the Area Patterns or Axis Patterns dialog box.

Font 

Applies the changes you've made and displays the Font dialog box.

Scale 

Applies the changes you've made and displays the Format Axis Scale dialog box. Availalbe only 
when an axis is selected.

Tasks That Use This Command

Aligning and Orienting Chart Text

Changing the orientation of tick-mark labels



Scale command (Format menu)

Controls the scale settings used for each of the chart axes.

Appears dimmed if no axis is selected.
Different options are available depending on which axis is selected: a category (x) axis, value (y 

or z) axis, or series (y) axis.

Dialog Box Options for a Category (X) Axis 

Most charts: horizontal axis. Bar charts: vertical axis. XY (scatter) charts: neither axis; see Dialog Box 
Options for a Value Axis.

Categories In Reverse Order

Reverses the order in which the categories and the data within each category is displayed. This 
does not permanently change the order of the data or categories; it just displays them in reverse 
order.

Font 

Displays the Font dialog box so you can format the axis font, size, style, color, and background.

Number Of Categories Between Tick Labels

Specifies which categories will have labels. For example, if you type 1, each category will have a 
label. If you type 2, every other category will have a label, and so on.

Number Of Categories Between Tick Marks

Specifies which categories will have tick marks. For example, if you type 1, each category will have 
a tick mark. If you type 2, every other category will have a tick mark, and so on.

Patterns 

Displays the Axis Patterns dialog box so you can format the axis, tick-mark type, and tick-mark 
labels.

Text 

Displays the Axis Text dialog box so you can select the axis text orientation.

Value (Y) Axis Crosses At Category Number

Specifies the category (for example, category number 2) at which the value axis will cross the 
category axis. This option is not available for 3-D charts.

Value (Y) Axis Crosses At Maximum Category

Displays value axis at the last plotted category.    This option overrides the Value (Y) Axis Crosses 
At Category Number setting.    This option is not available for 3-D charts.

Value (Y) Axis Crosses Between Categories

In 3-D charts: Value (Z) Axis Crosses Between Categories

For a 2-D chart, this option controls whether the value axis is displayed at the edge or the middle of 
the category indicated in the Value (Y) Axis Crosses At Category Number box.

For 2-D charts and 3-D line and area charts, this option controls whether data is plotted at the tick 



marks or between tick marks. When this check box is selected, data markers are plotted between 
the tick marks and gridlines; the tick marks and gridlines appear at the edges of the categories. 
When this check box is cleared, data markers are plotted at the tick-mark positions and the 
category axis gridlines cross through the center of the categories. The following illustrations show 
the same chart. In the first illustration, this check box is selected; in the second, it is cleared.

  

Dialog Box Options for a Value (Y or Z) Axis 

Most charts: vertical axis. Bar charts: horizontal axis. XY (scatter) charts: both axes.

Category (X) Axis Crosses at Maximum Value

For x-axis in an xy (scatter) chart: Value (Y) Axis Crosses At Maximum Category

Displays the category axis at the highest value. This option overrides the Category (X) Axis Crosses 
At option. For the x-axis of an xy (scatter) chart, displays the y-axis at the highest x-axis value.

For 3-D charts, this option is replaced with the Floor (XY Plane) Crosses At Minimum Value setting.

Floor (XY Plane) Crosses At Minimum Value

Displays the floor of the 3-D plotted chart at the lowest value on chart.    This option overrides the 
Floor (XY Plane) Crosses At setting.

Category (X) Axis Crosses At 

Specifies the value at which the category axis crosses the value axis. If the Auto check box is 
selected, the category axis crosses at zero or, if the scale does not include zero, at the value 
closest to zero.

For xy (scatter) charts, this option is replaced by the Value (Y) Axis Crosses At option.

For 3-D charts, this option is replaced by the Floor (XY Plane) Crosses At option.

This example shows this option set to 50:



Value (Y) Axis Crosses At

Specifies the value at which the value axis crosses the category axis.    If the Auto check box is 
selected, the other axis crosses at zero or, if the scale does not include zero, at the value closest to 
zero.

Floor (XY Plane) Crosses At

Specifies the value at which the floor of a 3-D plotted chart crosses the value axis (z-axis).    If the 
Auto check box is selected, the floor crosses at zero or, if the scale does not include zero, at the 
value closest to zero.

Font 

Displays the Font dialog box so you can format the axis font, size, style, color, and background.

Logarithmic Scale

Recalculates the Minimum, Maximum, Major Unit, and Minor Unit values as powers of 10, based on 
the range of data plotted in the chart. No zero or negative data values are permitted on logarithmic 
charts.    The Major Unit and Minor Unit must both be at least 10. If you type a value that is not a 
power of 10 in the Minimum box, it will be rounded down to the next power of 10. If you type a value 
that is not a power of 10 in the Maximum box, it will be rounded up to the next power of 10.

Major Unit

Specifies increment between major tick marks. If you select the Auto check box, Microsoft Graph 
calculates the increment based on the range of values plotted and the current size of the chart; if 
you change the size of the chart, Graph automatically adjusts the scale. This example shows the 
Major Unit set to 20.

 

Minor Unit

Specifies the increment between minor tick marks. If you select the Auto check box, Graph 
calculates the increment based on the major unit and the current size of the chart; if you change the 
size of the chart, Graph automatically adjusts the scale.

Minimum

Specifies the lowest data value to appear in the chart. Values below the number typed here are not 
shown on the chart, although the data on the datasheet is not affected. Selecting the Auto check 
box displays all values.

Maximum

Specifies the highest data value to appear in the chart. Values above the number typed here are not 



shown on the chart, although the data on the datasheet is not affected. Selecting the Auto check 
box displays all values.

Patterns 

Displays the Axis Patterns dialog box so you can format the axis, tick-mark type, and tick-mark 
labels.

Text 

Displays the Axis Text dialog box so you can select the axis text orientation.

Values In Reverse Order

For x-axis in an xy (scatter) chart: Categories In Reverse Order

Inverts the chart and displays the lowest value on the scale at top of the chart and the highest value 
at the bottom. 

Dialog Box Options for a Series (Y) Axis 

Font 

Displays the Font dialog box so you can format the axis font, size, style, color, and background.

Number Of Series Between Tick Labels

Specifies which series will have labels. For example, if you type 1, each series will have a label. If 
you type 2, every other series will have a label, and so on.

Number Of Series Between Tick Marks

Specifies which series will have tick marks. For example, if you type 1, each series will have a tick 
mark. If you type 2, every other series will have a tick mark, and so on.

Series In Reverse Order

Reverses the order in which the series are displayed.    This does not reverse the plot order of the 
series; it just displays them in reverse order.

Patterns 

Displays the Axis Patterns dialog box so you can format the axis, tick-mark type, and tick-mark 
labels.

Text 

Displays the Axis Text dialog box so you can select the axis text orientation.

Tasks That Use This Command

Adjusting the Axis Scale

Changing the interval between tick-mark labels

Changing the interval between tick marks



Legend command (Format menu)

Repositions the legend on a chart.

Appears dimmed if the legend is not selected.
You can move a legend using the mouse or the Legend command.
Microsoft Graph automatically adjusts the size and position of the chart so that the legend does 

not overlap it.

Dialog Box Options

Top, Bottom

Centers the legend above or below the chart.

Right, Left

Places the legend at the right side or left side of the chart.

Corner

Places the legend in the upper-right corner of the chart.

Patterns 

Repositions the legend and displays the Area Patterns dialog box.

Font 

Repositions the legend and displays the Font dialog box.

Tasks That Use This Command

Moving the Legend



Chart command (Format menu)

Controls the main chart's type and formats.

Use instead of a Gallery command to change the chart type or other options when you want to 
preserve the chart's custom formats.

Only the dialog box options that apply to the selected chart type are available.
To change an overlay chart's type and formats, choose Overlay from the Format menu.

Dialog Box Options

Chart Type

Changes the main chart to the type selected in the box:    Area, Bar, Column, Line, Pie, XY (Scatter) 
3-D Area, 3-D Bar, 3-D Column, 3-D Line, or 3-D Pie. 

Note    If there is an overlay chart, the main chart can be an xy (scatter) chart only if the overlay 
chart is also an xy (scatter) chart.

Data View

Shows the arrangements of data available for the selected chart type. Select the arrangement you 
want.

Overlap 

In a bar or column chart, this option determines how much the bars or columns within a category 
cluster overlap each other. The number in the box is a percentage of the bar or column width. A 
negative value sets a gap between markers.

Gap Width 

In a bar or column chart, this option determines the amount of space between category clusters. 
The number in the box is a percentage of the bar or column width. The number must be between 0 
and 500.

Vary By Category

Assigns a different color or pattern to each data marker when the chart has only one data series.

Drop Lines

Extends lines from the highest positive value and lowest negative value in each category to the x-
axis. Available for line and area charts only.

Hi-Lo Lines

Extends lines from highest point to the lowest in each category. Available for line charts only.

Angle Of First Pie Slice

Determines the angle at which the first pie slice starts. The angle is measured in degrees clockwise 
from vertical. The default is 45 degrees.

Gap Depth

Determines the distance between the data series in a 3-D chart. The number in the box is a 
percentage of the width of the marker (column, bar, and so on).

Chart Depth

Determines the depth (front-to-back dimension) of a 3-D chart relative to the width of the chart. The 
number in the box is a percentage of the chart width. 

Series Lines

Connects the tops of the data markers for each series with lines. Available for stacked bar and 
stacked column charts only.

Up/Down Bars

This option is intended for open-high-low-close charts which track stock prices. An up/down bar is a 
rectangle extending from the opening price to the closing price on a given day. Available for line 



charts only.

Tasks That Use This Command

Changing the Chart Type

Formatting the layout of data markers



Overlay command (Format menu)

Controls the overlay chart's type and formats.

Available only when you have created an overlay chart.
Only the dialog box options that apply to the selected chart type are available.
To change the main chart's type and formats, choose Chart from the Format menu.
To change the distribution of data series between the main and overlay charts, use the Move To 

Chart and Move To Overlay commands from the DataSeries menu.

Dialog Box Options

Overlay Chart Type

Changes the overlay chart to the type selected in the box:    Area, Bar, Column, Line, Pie, or (XY) 
Scatter.

Note    The overlay chart can be an xy (scatter) chart only if the main chart is also an xy (scatter)    
chart.

Data View

Shows the arrangements of data available for the selected chart type. Select the arrangement you 
want.

Overlap 

In a bar or column chart, this option determines how much the bars or columns within a category 
cluster overlap each other. The number in the box is a percentage of the bar or column width. A 
negative value sets a gap between markers.

Gap Width 

In a bar or column chart, this option determines the amount of space between category clusters. 
The number in the box is a percentage of the bar or column width. The number must be between 0 
and 500.

Vary By Category

Assigns a different color or pattern to each data marker in the selected series.

Drop Lines

Extends lines from the highest value in each category to the x-axis. Available for line and area 
charts only.

Hi-Lo Lines

Extends lines from the highest positive value to the lowest negative value in each category. 
Available for line charts only.

Angle Of First Pie Slice

Determines the angle at which the first pie slice starts. The angle is measured in degrees clockwise 
from vertical. The default is 45 degrees.

Series Lines

Connects the tops of the data markers for each series with lines. Available for stacked bar and 
stacked column charts only.

Up/Down Bars

This option is intended for open-high-low-close charts which track stock prices. An up/down bar is a 
rectangle extending from the opening price to the closing price on a given day. Available for line 
charts only.

Tasks That Use This Command

Changing the overlay chart type

Formatting the layout of data markers



3-D View command (Format menu)

Controls the angles at which you view the data in a 3-D chart.

Appears dimmed if the chart is not a 3-D chart.
A sample chart in the dialog box shows the current settings.

Dialog Box Options

Elevation

Controls the height from which you view the data. The elevation is measured in degrees.    For all 
charts except pie charts and bar charts, elevation ranges from -90 (the chart appears as if you were 
directly below the plot area) to 90 degrees (the chart appears as if you were directly above the plot 
area).    For 3-D bar charts, the value must be between 0 and 44. For pie charts, elevation ranges 
from 10 (thickness of slices is prominent) to 80 degrees (surface of pie is prominent).

Perspective

Controls the amount of perspective. More perspective makes data markers at the back of the chart 
smaller than data markers at the front of the chart, providing a sense of depth. The perspective 
value specifies the ratio of the front of the chart to the back of the chart and can range from zero to 
100. A perspective of zero makes the farthest edge of the plot area equal in width to the nearest 
edge of the plot area--that is, no perspective. This option is not available if Right Angle Axes is 
selected.

Rotation

Controls the rotation of the plot area around the z-axis (vertical axis). The rotation is measured in 
degrees and can range from 0 to 360 (for 3-D bar charts only, the range is from 0 to 44). A rotation 
of zero displays the chart as you would view it from facing the x-axis. A rotation of 180 displays the 
chart as you would view it from the opposite side or the back, visually reversing the plot order of the 
series. A rotation of 90 displays the chart as you would view it from the side.

Right Angle Axes

Displays axes at right angles regardless of the settings of the Rotation and Elevation options. 
Select the check box to show axes at right angles. Clear the check box to show axes in 
perspective. If this check box is selected, the Perspective option is not available.

Height % Of Base

Controls the height of the z-axis and walls relative to the size of the x-axis (the width of the chart). 
The height is measured as a percentage of the x-axis length. For example, a value of 200% makes 
the chart twice as high as the x-axis is long. Changes in this setting are not reflected in the sample 
chart shown in the dialog box.

Apply 

Applies the current settings to the active chart without closing the dialog box, so that you can see 
the effects of your changes.

Default 

Restores all the settings in the dialog box to the default values.    If you change the chart type using 
a Gallery menu command, the 3-D view formats are not reset to their original values.    You can 
restore the original settings only by choosing the Default button.

Auto Scaling

When you change a 2-D chart into a 3-D chart, it is sometimes drawn somewhat smaller. For charts 
with right-angle axes and a rotation of less than 45 degrees, this option scales the 3-D chart so that 
it is closer in size to the 2-D version.

Tasks That Use This Command

Formatting the 3-D Chart View



Number command (Format menu)

Determines how numbers, dates, times, and text values are displayed in the selected cells and in tick-
mark labels along the chart axes.    Select from among the built-in formats in the Number Format box or 
type a custom format in the Format box.

 The format of the cell containing the first data point of the first included series determines the 
format of tick-mark labels for the vertical axis.    In the default datasheet, this is the cell in the second row 
and second column.

For xy (scatter) charts, the format of the first cell plotted on the x-axis determines the format of 
tick-mark labels for the horizontal axis.

You can delete a custom format with the Delete button. You cannot delete a built-in format.
For a list of formatting symbols, see Number Format Symbols.
If the selection includes cells with different formats, the Format box appears blank. Otherwise, the 

format assigned to the selected cell appears in the box.

Tasks That Use This Command

Creating Custom Number Formats

Deleting Custom Number Formats

Formatting Numbers

See Also

Formatting Tick-mark Labels



Column Width command (Format menu)

Changes the width of selected columns.

You need to select only one cell in a column to change that column's width.
To change the width of all columns, select an entire row.
Columns can be from 1 to 255 characters wide.
The Standard Width check box returns selected columns to a width of nine characters.

Tasks That Use This Command

Changing Column Width



Color Palette command (Format menu)

Customizes the colors on the Microsoft Graph color palette.

You need a color monitor to customize colors.
On a monochrome monitor, standard color names are shown instead of samples of the color. 

Previously customized colors appear as Color 1, Color 2, and so on.
You can change the color directly by choosing the Edit button and clicking in the color box and 

moving the arrow along the brightness bar. If you use this method, you do not need to change the values 
in the boxes at the bottom of the color editing dialog box.

There are two systems for determining the color. Each system involves three different values that 
together determine the color. One system uses hue, saturation, and luminosity. The other uses the three 
primary colors used by color monitors: red, green, and blue. These systems work independently. Both are 
provided so you can specify colors in an way with which you are familiar.

Dialog Box Options

Color Palette

Shows the current color palette.

Default 

Resets the color palette to the original 16 colors.

Edit 

Displays the color editing dialog box.

Color box

This is the large colored box. Clicking or dragging in this box changes the current color. This is 
reflected in the Color|Solid box; in the Hue, Sat (saturation), and Lum (luminosity) boxes; and in 
the Red, Green, and Blue boxes.

Brightness bar

This is the colored bar to the right of the color box. Dragging the arrow along this bar changes 
the amount of white and black in the current color. This has the same effect as changing the 
value in the Lum (luminosity) box.

Color|Solid

The left side of this box displays the current color. The right side shows the nearest solid color. 
To use the nearest solid color to the one you have created, double-click the solid color.

Hue

The basic color: red, yellow, green, blue, and so on.    You can change the hue by typing a value 
from 0 to 239 or by clicking the arrows. Changing this value has the same effect as moving 
horizontally in the color box.

Sat (saturation)

A measure of how pure the color is; in other words, how different it is from gray.    You can 
change the saturation by typing a value from 0 to 240 or by clicking the arrows. Changing this 
value has the same effect as moving vertically in the color box.

Lum (luminosity)

The lightness (amount of white) or darkness (amount of black) in the current color. You can 
change the luminosity by typing or by clicking the arrows. Changing this value has the same 
effect as dragging the arrow along the brightness bar.

Red, Green, Blue

Changing the amounts of red, green, and blue changes the overall color. You can change these 
values by typing or by clicking the arrows. Changing the red, green, and blue values is an 
alternate method of changing the hue, saturation, and luminosity.

Tasks Using This Command



Customizing Colors



Area command (Gallery menu)

Chanves the chart to an area chart and completely replaces all formatting in the chart with the formatting 
you specify. To change the chart type without losing any custom formatting you have applied, and to see 
additional options not available through the Gallery menu, use the Chart command from the Format 
menu.

Dialog Box Options

1. Simple area chart

2. 100% area chart

3. With drop lines

4. With horizontal and vertical gridlines

5. With areas labeled

Custom

Opens the Chart dialog box so you can change the chart type or other aspects of the chart format 
individually. For a combination chart, opens the Overlay dialog box if you have selected a series in 
the overlay chart.

See Also

Common Uses for Chart Types

Creating a New Chart

Undoing Changes



Bar command (Gallery menu)

Changes the chart to a bar chart and completely replaces all formatting in the chart with the formatting 
you specify. To change the chart type without losing any custom formatting you have applied, and to see 
additional options not available through the Gallery menu, use the Chart command from the Format 
menu.

Dialog Box Options

1. Simple bar chart

2. Bar chart for one series with varied patterns or colors

3. Stacked

4. Overlapped

5. 100% stacked

6. With vertical gridlines

7. With value labels

8. Step chart

9. Stacked with series lines

10. 100% stacked with series lines

Custom

Opens the Chart dialog box so you can change the chart type or other aspects of the chart format 
individually. For a combination chart, opens the Overlay dialog box if you have selected a series in 
the overlay chart.

More 

The dialog box can display up to eight chart types. This button displays additional chart types. 
Choose the More button a second time to return to the first eight chart types.

See Also

Common Uses for Chart Types

Creating a New Chart

Undoing Changes



Column command (Gallery menu)

Changes the chart to a column chart and completely replaces all formatting in the chart with the 
formatting you specify. To change the chart type without losing any custom formatting you have applied, 
and to see additional options not available through the Gallery menu, use the Chart command from the 
Format menu.

Dialog Box Options

1. Simple column chart

2. Column chart for one series with varied patterns

3. Stacked

4. Overlapped

5. 100% stacked

6. With horizontal gridlines

7. With value labels

8. Step chart (no space between categories)

9. Stacked with series lines

10. 100% stacked with series lines

Custom

Opens the Chart dialog box so you can change the chart type or other aspects of the chart format 
individually. For a combination chart, opens the Overlay dialog box if you have selected a series in 
the overlay chart.

More 

The dialog box can display up to eight chart types. This button displays additional chart types. 
Choose the More button a second time to return to the first eight chart types.

See Also

Common Uses for Chart Types

Creating a New Chart

Undoing Changes



Line command (Gallery menu)

Changes the chart to a line chart and completely replaces all formatting in the chart with the formatting 
you specify. To change the chart type without losing any custom formatting you have applied, and to see 
additional options not available through the Gallery menu, use the Chart command from the Format 
menu.

Dialog Box Options

1. Lines and data point markers

2. Lines only

3. Markers only

4. Lines and markers with horizontal gridlines

5. Lines and markers with horizontal and vertical gridlines

6. Lines and markers with logarithmic scale and horizontal gridlines

7. Hi-lo chart with markers and hi-lo lines

8. Hi-lo-close chart for stock quotes; must contain three series.

9. Open-hi-lo-close chart for stock quotes; must contain four series.

Custom

Opens the Chart dialog box so you can change the chart type or other aspects of the chart format 
individually. For a combination chart, opens the Overlay dialog box if you have selected a series in 
the overlay chart.

More 

The dialog box can display up to eight chart types. This button displays additional chart types. 
Choose the More button a second time to return to the first eight chart types.

See Also

Common Uses for Chart Types

Creating a New Chart

Undoing Changes



Pie command (Gallery menu)

Changes the chart to a pie chart and completely replaces all formatting in the chart with the formatting 
you specify. To change the chart type without losing any custom formatting you have applied, and to see 
additional options not available through the Gallery menu, use the Chart command from the Format 
menu.

Dialog Box Options

1. Each slice patterned or colored differently

2. All slices black and labeled with categories

3. First slice exploded

4. All slices exploded

5. With category labels

6. With value labels expressed as percentages

7. With both category and percentage labels

Custom

Opens the Chart dialog box so you can change the chart type or other aspects of the chart format 
individually. For a combination chart, opens the Overlay dialog box if you have selected a series in 
the overlay chart.

See Also

Common Uses for Chart Types

Creating a New Chart

Undoing Changes



XY (Scatter) command (Gallery menu)

Changes the chart to an xy (scatter) chart and completely replaces all formatting in the chart with the 
formatting for the chart type you specify. To change the chart type without losing any custom formatting 
you have applied, and to see additional options not available through the Gallery menu, use the Chart 
command from the Format menu.

Dialog Box Options

1. With data point markers only

2. With markers from the same series connected by lines

3. With markers and horizontal and vertical gridlines

4. With markers and semi-logarithmic gridlines

5. With markers and log-log gridlines

Custom

Opens the Chart dialog box so you can change the chart type or other aspects of the chart format 
individually. For a combination chart, opens the Overlay dialog box if you have selected a series in 
the overlay chart.

See Also

Common Uses for Chart Types

Creating a New Chart

Entering Data for an XY (Scatter) Chart

Undoing Changes



Combination command (Gallery menu)

Adds an overlay chart and distributes the series evenly between the main and overlay charts.

The first group of series is plotted in the main chart and the second group in the overlay. If there 
is an odd number of series, Microsoft Graph puts one more series in the main chart than in the overlay. 
For example, if there are five series, the first three are plotted in the main chart, and the remaining two in 
the overlay.

This command completely replaces all formatting in the chart with the formatting for the chart type 
you specify. To change the chart type without losing any custom formatting you have applied, and to see 
additional options not available through the Gallery menu, use the Chart and Overlay commands from the 
Format menu.

Dialog Box Options

1. Column chart overlaid by a line chart

2. Column chart overlaid by a line chart with an independent y-axis scale

3. Line chart overlaid by a line chart with an independent y-axis scale

4. Area chart overlaid by a column chart

5. Column chart overlaid by a line chart containing three data series (for showing stock volumes 
related to high, low, and closing prices)

6. Column chart overlaid with open-high-low-close chart (for showing stock volumes related to open, 
high, low, and closing prices)

Custom

Opens the Chart dialog box so you can change the chart type or other aspects of the chart format 
individually. Opens the Overlay dialog box if you have selected a series in the overlay chart.

Tasks That Use This Command

Creating an overlay chart

See Also

Common Uses for Chart Types

Creating a New Chart

Undoing Changes



3-D Area command (Gallery menu)

Changes the chart to a 3-D area chart and completely replaces all formatting in the chart with the 
formatting you specify. To change the chart type without losing any custom formatting you have applied, 
and for additional options not available through the Gallery menu, use the Chart command from the 
Format menu.

Dialog Box Options

1. Stacked area chart with 3-D areas

2. Stacked 3-D areas and labels

3. Stacked 3-D areas and drop lines

4. Stacked 3-D areas and gridlines

5. 3-D areas, each series plotted separately

6. 3-D areas plotted separately with gridlines

7. 3-D areas plotted separately with x-axis and y-axis gridlines only

8. Stacked 3-D areas with right angle axes and 2-D walls and gridlines 

Custom

Opens the Chart dialog box so you can change the chart type or other aspects of the chart format 
individually. For a combination chart, opens the Overlay dialog box if you have selected a series in 
the overlay chart.

See Also

Common Uses for Chart Types

Creating a New Chart

Formatting the 3-D Chart View

Undoing Changes



3-D Bar command (Gallery menu)

Changes the chart to a 3-D bar chart and completely replaces all formatting in the chart with the 
formatting you specify. To change the chart type without losing any custom formatting you have applied, 
and to see additional options not available through the Gallery menu, use the Chart command from the 
Format menu.

Dialog Box Options

1. Simple bar chart with 3-D bars

2. Stacked 3-D bars

3. Stacked 100% 3-D bars

4. 3-D bars with value axis (z-axis) gridlines

5. 3-D bars with right angle axes and 2-D walls and gridlines 

Custom

Opens the Chart dialog box so you can change the chart type or other aspects of the chart format 
individually. For a combination chart, opens the Overlay dialog box if you have selected a series in 
the overlay chart.

See Also

Common Uses for Chart Types

Creating a New Chart

Formatting the 3-D Chart View

Undoing Changes



3-D Column command (Gallery menu)

Changes the chart to a 3-D column chart and completely replaces all formatting in the chart with the 
formatting you specify. To change the chart type without losing any custom formatting you have applied, 
and to see additional options not available through the Gallery menu, use the Chart command from the 
Format menu.

Dialog Box Options

1. Simple column chart with 3-D columns

2. Stacked 3-D columns

3. Stacked 100% 3-D columns

4. 3-D columns with value axis (z-axis) gridlines

5. 3-D columns, each series plotted separately

6. 3-D columns plotted separately with gridlines

7. 3-D columns plotted separately with x-axis and y-axis gridlines only

8. 3-D columns plotted separately with right angle axes and 2-D walls and gridlines 

Custom

Opens the Chart dialog box so you can change the chart type or other aspects of the chart format 
individually. For a combination chart, opens the Overlay dialog box if you have selected a series in 
the overlay chart.

See Also

Common Uses for Chart Types

Creating a New Chart

Formatting the 3-D Chart View

Undoing Changes



3-D Line command (Gallery menu)

Changes the chart to a 3-D line chart and completely replaces all formatting in the chart with the 
formatting you specify. To change the chart type without losing any custom formatting you have applied, 
and to see additional options not available through the Gallery menu, use the Chart command from the 
Format menu.

Dialog Box Options

1. 3-D lines, each series plotted separately

2. 3-D lines plotted separately with gridlines

3. 3-D lines plotted separately with x-axis and y-axis gridlines only

4. 3-D lines plotted separately with logarithmic gridlines

Custom

Opens the Chart dialog box so you can change the chart type or other aspects of the chart format 
individually. For a combination chart, opens the Overlay dialog box if you have selected a series in 
the overlay chart.

See Also

Common Uses for Chart Types

Creating a New Chart

Formatting the 3-D Chart View

Undoing Changes



3-D Pie command (Gallery menu)

Changes the chart to a 3-D pie chart and completely replaces all formatting in the chart with the 
formatting you specify. To change the chart type without losing any custom formatting you have applied, 
and to see additional options not available through the Gallery menu, use the Chart command from the 
Format menu.

Dialog Box Options

1. Each slice patterned or colored differently

2. All slices patterned and colored the same and labeled with categories

3. First slice exploded

4. All slices exploded

5. With category labels

6. With value labels expressed as percentages

7. With both category and percentage labels

Custom

Opens the Chart dialog box so you can change the chart type or other aspects of the chart format 
individually. For a combination chart, opens the Overlay dialog box if you have selected a series in 
the overlay chart.

See Also

Common Uses for Chart Types

Creating a New Chart

Formatting the 3-D Chart View

Undoing Changes



Index command (Help menu)

Displays the table of contents of Help topics.

Click an underlined term to go to that topic.



Keyboard command (Help menu)

Displays a list of topics that describe Microsoft Graph shortcut keys and their functions.

Click an underlined term to go to that topic.



Using Help command (Help menu)

Displays the introductory topic that describes how to start and use Help.

Click an underlined term to go to that topic.



About command (Help menu)

Displays the Microsoft Graph version number and copyright notice.



Keyboard Shortcuts

Function Keys

Keys for Editing Chart Text

Keys for Editing in the Cell Data Dialog Box

Keys for Editing in the Datasheet

Keys for Moving and Selecting in the Datasheet

Keys for Selecting Items in the Chart



Keys for Editing in the Cell Data Dialog Box

F2 Opens the Cell Data dialog box so you can edit the contents of the active cell.

Backspace Opens the Cell Data dialog box and deletes its contents.

Ctrl+; Opens the Cell Data dialog box and enters the current date.

Ctrl+: Opens the Cell Data dialog box and enters the current time.

Once the Cell Data dialog box is open:
Esc Closes the Cell Data dialog box without changing the data.

Enter Enters the contents of the Cell Data dialog box into the cell.

Home Moves to the beginning of the data.

End Moves to the end of the data.

Left Arrow Moves one character to the left.

Right Arrow Moves one character to the right.

Shift+Left Arrow Extends the selection one character to the left.

Shift+Right Arrow Extends the selection one character to the right.

Backspace If no character is selected, deletes the character to the left of the insertion point; 
otherwise deletes selected characters.

Del Deletes the selected text.



Keys for Editing in the Datasheet

F2 Displays the Cell Data dialog box so you can edit its contents.

Backspace Displays the Cell Data dialog box and deletes its contents.

Ctrl+; Displays the Cell Data dialog box and enters the current date.

Ctrl+: Displays the Cell Data dialog box and enters the current time.

Del Removes data, formatting, or both from selected cells.    Same as the Clear 
command on the Edit menu.

Ctrl+X Removes data and formatting from selected cells and puts them onto the 
Clipboard.    Same as the Cut command on the Edit menu.

Ctrl+V Pastes cut or copied data and formatting from the Clipboard into the datasheet, 
beginning at the upper-left cell selected.    Same as the Paste command on the Edit 
menu.

Ctrl+C Copies data and formatting from selected cells onto the Clipboard.    Same as the 
Copy command on the Edit menu.

Ctrl+Plus Sign (+) Inserts one or more rows or columns into the datasheet.    Same as the Insert 
Row/Col command on the Edit menu. 

Ctrl+Minus Sign (-)Removes selected rows or columns from the datasheet.    Same as the Delete 
Row/Col command on the Edit menu. 

Ctrl+A Selects all cells in the datasheet.    Same as the Select All command on the Edit 
menu.



Keys for Moving and Selecting in the Datasheet

Moving the active cell or extending the selection:
Arrow keys Moves one cell in direction of arrow.

Shift+Arrow key Extends selection one cell in direction of arrow.

Home Moves to beginning of row.

Ctrl+Home Moves to first data cell (row 2, column 2).

Shift+Home Extends selection to beginning of row.

Ctrl+Shift+Home Extends selection to first data cell (row 2, column 2).

End Moves to end of row (last occupied column of datasheet).

Ctrl+End Moves to lower-right cell of data.

Shift+End Extends selection to end of row.

Ctrl+Shift+End Extends selection to last cell of data.

Ctrl+Spacebar Selects entire column.

Shift+Spacebar Selects entire row.

Ctrl+Shift+Spacebar Selects entire datasheet.

Shift+Backspace Cancels selection of all but the active cell.

Page Down Moves down one window.

Ctrl+Page Down Moves right one window.

Shift+Page Down Extends selection down one window.

Ctrl+Shift+Page Down Extends selection right one window.

Page Up Moves up one window.

Ctrl+Page Up Moves left one window.

Shift+Page Up Extends selection up one window.

Ctrl+Shift+Page Up Extends selection left one window.

Tab Moves right one cell.

Shift+Tab Moves left one cell.

Enter Moves down one cell in the selection.

Moving the active cell within the selection:
Enter Moves down one cell to the bottom of the selection; then to the first selected 

cell in the next column.

Shift+Enter Moves up one cell to the top of the selection; then to the last selected cell in 
the next column.

Tab Moves right one cell to the end of the selection; then to the first selected cell in 
the next row.

Shift+Tab Moves left one cell to the beginning of the selection; then to the last selected 
cell in the previous row.

Ctrl+Period Moves to next corner of selection in a clockwise rotation.

See Also

Moving Around the Datasheet



Keys for Selecting Items in the Chart

Right Arrow Selects the next item in the same class; then the next class.

Left Arrow Selects the previous item in the same class; then the previous class.

Up Arrow Selects the first item in the next class.

Down Arrow Selects the last item in the previous class.

Esc Cancels selection of all items.

Order in which arrow keys select item classes:
1.    Chart  6.    Axes 11.    Second series, and so on

2.    Plot area  7.    Text 12.    Drop lines

3.    3-D floor  8.    Arrows 13.    Hi-lo lines

4.    3-D walls  9.    Gridlines 14.    Series lines

5.    Legend 10.    First series 15.    Up/down bars

See Also

Selecting and Changing Items in the Chart



Function Keys

F1 Opens Help and displays the topic for the selected command, dialog box, or 
message.

Shift+F1 Adds a question mark to the mouse pointer. You can then use the question-mark 
pointer to choose the command, click the screen region. While this pointer is 
displayed, you can also press a key or key combination you want to know more 
about.

F2 Displays the Cell Data dialog box.

Alt+F4 Closes the Graph window and inserts the chart you created in the active document. 
Same as choosing Exit And Return from the File menu.

F8 Turns Extend mode on or off.    When Extend mode is on, the arrow keys extend the 
selection rather than moving the active cell. "EXT" appears in the status area at the 
lower-right of the Graph window to indicate that Extend mode is on.

F10 Activates the menu bar (Same as Alt).



Keys for Editing Chart Text

Esc Closes the text to end editing.

Enter Inserts a line break.

Home Moves to the beginning of the line.

Ctrl+Home Moves to the beginning of the text.

End Moves to the end of the line.

Ctrl+End Moves to the end of the text.

Left Arrow Moves one character to the left.

Shift+Left Arrow Extends the selection one character to the left.

Ctrl+Left Arrow Moves one word to the left.

Right Arrow Moves one character to the right.

Shift+Right Arrow Extends the selection one character to the right.

Ctrl+Right Arrow Moves one word to the right.

Ctrl+X Moves the selected characters onto the Clipboard. Same as the Cut command on 
the Edit menu.

Ctrl+C Copies the selected characters onto the Clipboard. Same as the Copy command 
on the Edit menu.

Ctrl+V  If no character is selected, pastes the contents of the Clipboard to the left of the 
insertion point; otherwise, replaces the selection with the contents of the Clipboard. 
Same as the Paste command from the Edit menu.

Backspace If no character is selected, deletes the character to the left of the insertion point; 
otherwise deletes selected characters.

Del Deletes the selected text.



Microsoft Graph for Windows Help

Click a topic, or click the Search button to find the information you want.

How to Use Microsoft Graph

Overview of Microsoft Graph

Creating a New Chart

How To ... 

Reference

Commands and Menus

Keyboard Shortcuts

Definition of Terms

For information about using Help, press F1.



Creating a New Chart

This is an overview of creating a new chart. For details on the individual steps, click the underlined 
topics.

To create a new chart:

1. Select the place in your document where you want to insert a chart.

2. Insert a Microsoft Graph chart in your document, following the instructions in the documentation for 
the main application you are using to create your document.

The Graph window opens. If your main application sent data to Graph, a chart of that data appears. 
If your main application did not send data to Graph, the default datasheet and chart appear.

3. Type the data directly into the datasheet or import it from another file.

Graph automatically creates the chart from your data.

4. Format the data.

5. Change the chart type to one appropriate for the data.

6. Add a title and other chart text.

7. Change the appearance of any item in the chart.

8. Resize the Chart window to make the chart the size you want.

9. Update the chart in your document and quit Graph.

The chart in your document now reflects the changes you've made, but the chart has not been 
saved. The chart and data will be saved as part of your document when you choose Save from the 
File menu in your main application.



How To . . .

Enter and Edit Cell Data

Overview

Changing Column Width

Copying Data

Deleting Data

Deleting Rows and Columns

Importing Data from Other Files

Inserting Rows and Columns

Moving Around the Datasheet

Moving Data

Selecting Cells

Undoing Changes

Arrange Data for the Chart

Overview

Defining Series in Rows or Columns

Entering Data for an Overlay Chart

Entering Data for an XY (Scatter) Chart

Including and Excluding Data from the Chart

Format Data

Overview

Changing Fonts in the Datasheet

Creating Custom Number Formats

Deleting Custom Number Formats

Formatting Numbers

Formatting Tick-Mark Labels

Select and Change Items in the Chart

Overview

Adjusting Data Values in the Chart

Arrows

Axes

Axis Titles

Chart Title

Data Markers

Data-Point Labels

Gridlines

Legend

Overlay Charts

Plot Area

Tick Marks

Tick-Mark Labels

Unattached Chart Text

3-D Chart View

Edit an Existing Chart



Overview

Changing the Chart Type

Copying the Entire Chart

Quitting Graph

Setting the Default Chart

Sizing Charts

Undoing Changes

Updating Changes to the Chart



Commands and Menus 

You can get help on any Graph command by pressing Shift+F1; then choosing the command.

File Menu

Import Data

Open Microsoft Excel Chart

Update

Set As Default Chart

Exit And Return

Edit Menu

Undo

Cut

Copy

Copy     Chart  

Paste

Clear

Select All

Delete     Row/Col  

Insert     Row/Col  

DataSeries Menu

Plot     On     X     Axis  

Include     Row/Col  

Exclude     Row/Col  

Series     In     Rows  

Series     In     Columns  

Move To Overlay

Move To Chart

Gallery Menu

Area

Bar

Column

Line

Pie

XY (Scatter)

Combination

3-D Area

3-D Bar

3-D Column

3-D Line

3-D Pie

Chart Menu

Titles

Data Labels

Add Arrow/Delete Arrow

Add Legend/Delete Legend



Axes

Gridlines

Format Menu

Patterns

Font

Text

Scale

Legend

Number

Column Width

Chart

Overlay

3-D View

Color Palette

Window Menu

Chart

Datasheet

400% View

200% View

100% View

66% View

50% View

33% View

Help Menu

Index

Keyboard

Using Help

About

Control Menus

Restore

Move

Size

Minimize

Maximize

Close

Next

Switch To



Chart command (Window menu)

Switches to the Chart window so that you can format the chart.

Shortcut:    Ctrl+F6



Datasheet command (Window menu)

Switches to the Datasheet window so that you can enter and edit data.

Shortcut:    Ctrl+F6



400% View command (Window menu)

Displays the chart at four times the size it will appear in the main document.

Appears dimmed if the chart will be too large to display on the screen in this size.

See Also

200% View command

100% View command

66% View command

50% View command

33% View command

Tasks That Use This Command

Changing the display size of a chart



200% View command (Window menu)

Displays the chart at twice the size it will appear in the main document.

Appears dimmed if the chart will be too large to display on the screen in this size.

See Also

400% View command

100% View command

66% View command

50% View command

33% View command

Tasks That Use This Command

Changing the display size of a chart



100% View command (Window menu)

Displays the chart in the same size it will appear in the main document.

See Also

400% View command

200% View command

66% View command

50% View command

33% View command

Tasks That Use This Command

Changing the display size of a chart



66% View command (Window menu)

Displays the chart at two thirds the size it will appear in the main document.

See Also

400% View command

200% View command

100% View command

50% View command

33% View command

Tasks That Use This Command

Changing the display size of a chart



50% View command (Window menu)

Displays the chart at half the size it will appear in the main document.

See Also

400% View command

200% View command

100% View command

66% View command

33% View command

Tasks That Use This Command

Changing the display size of a chart



33% View command (Window menu)

Displays the chart at one third the size it will appear in the main document.

See Also

400% View command

200% View command

100% View command

66% View command

50% View command

Tasks That Use This Command

Changing the display size of a chart


