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Introduction

WinPtr is an icon based set of printer control functions. Major functions are available via
hotkeys from anywhere in any Windows application (provided that application doesn't kill a
hotkey).

WinPtr allows capture of the screen, current window or its client area, or a user delimited
rectangle to the printer, a fax, the clipboard or a file. Additionally, the user can print a
picture or text file; load the clipboard from such a file; print the clipboard contents whether
picture or text; and store those contents in a file.

Miscellaneous functions trigger a page eject; clear or view the clipboard; allow changing
the default printer; identifying the fax driver; and accessing the Windows printer setup
dialog or the Control Panel printer applet.

The tasteful WinPtr pelican icon (pel-icon) shows the default printer orientation (P=portrait,
L=landscape) on its body and the current default printer's name in its title.



The Pel - ICON
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The WinPtr icon, a tastefully designed pelican, serves as the anchor to the printer control
functions. The pelican's body displays the current orientation of the default printer: P =
portrait, L = landscape. It will display an X if the selected printer is not available, such as
when you're on a network and the printer is not attached. The icon caption is the name of
the current default printer as defined in the [devices] section of Win.ini.

Double-clicking the icon toggles the orientation. This can also be achieved by using
hotkeys {CTRL}{SHIFT}{P} and {CTRLH{SHIFTHL} set the orientation to portrait and
landscape, respectively.

Single-clicking the icon displays the control menu augmented with WinPtr's functions.



Changing Hotkey Combo

The default hotkey combination is {CTRLHSHIFT}. Pressing these two keys
simultaneously with a neumonic key (such as P for portrait orientation) signals WinPtr to
awaken, intercept and interpret the following key stroke, and carry out the designated
action.

If you prefer another hotkey combination, you can specify it by changing the
appropriate entry in the PELIWARE.INI file in the WinPtr directory (c:\windows\winptr) if
you didn't override it during setup. You can use any editor, including Windows Notepad.

The installed peliware.ini file contains the following relevant lines:

[winptr]

; hotkey - 1=shift,2=ctrl,4=alt - for a combination add the numbers
: i.e ctri/shift=1+2=3

;hotkey=3 ... is the default

To change the hotkey combo, uncomment the last line by removing the semi-colon (;), then
change the number 3 to whatever number represents the sum of key values for your
desired keys, e.g. 6 (= 4+2) for Alt-Ctrl.

You must close and re-open WinPtr for the new combo to become effective.



WinPtr Menus
WinPtr's menus are accessed by:

" single-clicking on the pelican icon, or
" pressing {CTRLY{SHIFT}I} (for icon)

Either will bring up the following menu first-page:

Move

Close Alt+F4

? -» File Ctrl-shift-F »
? -» Clipboard Ctrl-shift-K. »
?-» Fax Ctrl-shift-X »
?File -> Printer »
Clipboard -> Printer Ctrl-shift-B
Adjust Clipboard -> Printer

Client area -> Printer Ctrl-shift-C
Screen area -> Printer Ctrl-shift-5
Adjust Screen -> Printer Ctril-shift-A
Rectangle -> Printer Ctrl-shift-R
Adjust Hectangle -> Printer

YWindow -> Printer Ctrl-shift-W
Help ... Ctrl-shift-F1
Hotkeys ... Ctrl-shift-H
About ...

Printer Control Stuff b

Single-clicking on the last item: Printer Control Stuff adds the following menu page:

Clear Clipboard .

View Clipboard Ctrl-shift-¥

Eject Page

Printer Setup ...

Printer Information ...

Identify Fax Driver... 3
Control Panel - Printers...

Portrait Orientation Ctrl-shift-P
Landscape Orientation Ctrl-shift-L

Reroute Printer Output to FILE:

Change Default Printer... K




Capture Areas

When printing from the Windows desktop, you have several choices:

" Screen -- The entire surface of the monitor.

" Window -- The currently active window, including borders, menus and title bar.

" Client Area -- The inside area of the currently active window, excluding borders, title bar, menus
and scroll bars.

" Rectangle -- a user defined area outlined by dragging the cross-haired cursor.

The following picture is a screen print with a window and client area highlighted:
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Hotkey Reminder Window

Pressing {CTRLH{SHIFTHH} or selecting the Hotkeys menu item from menu page 1 brings
up the following reminder window:

WinPtr Hotkey Assignments
JAdjust screen > printer
.Clipboard -> printer
.Client Area -> printer
..7 to File
.Hotkey list
Icon Main Menu
.7 -» Klipboard
.Landscape
..Portrait
.Rectangle -> printer
.3creen -> print
.¥iew Clipboard
W. . Window -> printer

A,
B.
C.
F.
H.

l..
K.
L.
P.
R.
5.
V.




It's a Pelican, Dammit

My last name, Poellinger, when properly pronounced (the O is silent like the P in
swimming) sounds somewhat like pelican, at least to juvenile minds, thus it became my
nickname long ago. A pelican collection ensued, and the state bird of Lousiana has
become my mascot. If enuf registered users requested it, | guess | could make an
alternative exe with a more printer-like icon...but | personally have become pretty attached

to old Pelly.

A marvelous bird is the Pelican.
His mouth holds more than his belly-can.
He takes in his beak
enuf food for a week;
but I'm damned if | see how the hell-he-can.



Orientation
The WinPtr icon pelican's body displays the current orientation of the default printer: P =
portrait, L = landscape. It will display an X if the selected printer is not available, such as
when you're on a network and the printer is not attached.

Double-clicking the icon toggles the orientation.

This can also be achieved by using hotkeys {CTRLH{SHIFT}H{P} and {CTRLH{SHIFT}L}
set the orientation to portrait and landscape, respectively.

Finally, you can change the orientation by clicking on the appropriate menu item on menu
page 2.




Capturing the Screen

To capture an image of the current screen, you must first decide on the destination of the
image:

Printer -- Screen image printing comes with 2 output options, monitor sizing and printer adjusted.
Monitor sizing -- {CTRLH{SHIFT}S}

Printer adjusted -- {CTRL{SHIFTHA}

File -- Click on the '2 -> File' entry on menu page 1, then on the Screen entry.

Clipboard --This entry is equivalent to pressing the {PRINTSCREEN} key on your keyboard.

Click on the '? -> Clipboard' entry on menu page 1, then on the Screen entry.

Fax -- You must have identified your fax driver prior to sending it a screen image. Click on the '?

-> Fax' entry on menu page 1, then on the Screen entry.

All screen printing functions are available to clicking on menu page 1.

\WinPtr hides the icon (after its menus disappear) for 2 seconds while it captures the
screen image. Sometimes it returns under Windows Print Manager's icon, which has

usurped the empty icon space.




? -> File Output Options

Clipboard -> File

Client -> File
Screen -> File
YWindow -> File
Rectangle -> File



? -> Fax Output Options

Clipboard -> Fax
Client -> Fax

Screen -» Fax
Window -> Fax
Rectangle -> Fax




? -> Clipboard Input Options

?File -> Clipboard

Window -> Clipboard Al-Prisc
Client -> Clipboard

Rectangle -» Clipboard

Screen -> Clipboard Prisc




Capturing a Window

To capture an image of the active window, you must first decide on the destination of the
image:

" Printer -- {CTRLH{SHIFT}S}. Note that you can get a printer adjusted print of the window by 1)
capturing the window to the clipboard, then printing the clipboard.
" File -- Click on the 2 -> File' entry on menu page 1, then on the Window entry.

Clipboard --This entry is equivalent to pressing the {ALTH{PRINTSCREEN} keys on your
keyboard. Click on the ? -> Clipboard' entry on menu page 1, then on the Window entry.

" Fax -- You must have identified your fax driver prior to sending it a window image. Click on the
'? -> Fax' entry on menu page 1, then on the Window entry.

All window printing functions are available to clicking on menu page 1.

\WinPtr hides the icon (after its menus disappear) for 2 seconds while it captures the

window image. Sometimes it returns under Windows Print Manager's icon, which has
usurped the empty icon space.




Capturing Client Area

To capture an image of the active window's client area, you must first decide on the
destination of the image:

" Printer -- {CTRLH{SHIFTHC}. Note that you can get a printer adjusted print of the client area
by capturing the client area to the clipboard, then printing the clipboard.

" File -- Click on the "2 -> File' entry on menu page 1, then on the Client Area entry.

" Clipboard -- Click on the '? -> Clipboard' entry on menu page 1, then on the Client Area entry.
" Fax -- You must have identified your fax driver prior to sending it a client area image. Click on
the 2 -> Fax' entry on menu page 1, then on the Client Area entry.

All client area printing functions are available to clicking on menu page 1.

\WinPtr hides the icon (after its menus disappear) for 2 seconds while it captures the

window image. Sometimes it returns under Windows Print Manager's icon, which has
usurped the empty icon space.




Capturing a Rectangle
To capture a rectangular portion of the screen, you must
FIRST decide on the destination of the image:

Printer -- Screen image printing comes with 2 output options, monitor sizing and printer adjusted.
Monitor sizing -- {CTRLH{SHIFTKR}

Printer adjusted --Click on the 'Adjust Rectangle to Printer' entry on menu page 1.

File -- Click on the "2 -> File' entry on menu page 1, then on the Rectangle entry.

Clipboard -- Click on the '? -> Clipboard' entry on menu page 1, then on the Rectangle entry.
Fax -- You must have identified your fax driver prior to sending it a client area image. Click on
the '2 -> Fax' entry on menu page 1, then on the Rectangle entry.

SECOND, you must outline the rectangle to be captured. WinPtr changes the cursor to
a crosshairs. Hold down the left mouse button and drag the cursor to form a rectangle
defining the desired area. A rectangular outline with dimensions displayed inside
displays as you drag. Release the left mouse button to complete the capture.

All rectangle printing functions are available to clicking on menu page 1.

\WinPtr hides the icon (after its menus disappear) for 2 seconds while it captures the
window image. Sometimes it returns under Windows Print Manager's icon, which has
usurped the empty icon space.

Suggestion: With WinPtr active, go to the Hotkey Reminder Help Topic, press {CTRL}
{SHIFTH{RY}, capture the text inside the sample popup window there, sending it to the
printer. This will create a handy hotkey reference card for you.



Printing a File

Click on the '? -> Printer' entry on menu page 1, bringing up this submenu:

Bitmap File -> Printer
Adjust Bitmap File -> Printer
Metafile -> Printer

Text File -> Printer

Select the desired input source.

WinPtr then pops up the Windows standard file open dialog for you to select the input file.

Note: WinPtr prints ASCII / Text files using a Windows edit control. This limits the file
size of printable files to about 32K. Files larger than that will be only partially printed.




Printer Information

To see a screen describing your printer and its capabilities, click on 'Printer Control Stuff'
on menu page 1, then 'Printer Information' on menu page 2.

HP LaserJet Series Il LPT1:

Orientation: Portrait

Paper Size: Letter 8 12 x 11 in
Paper Length: 288

Paper Width: 770

Paper Scale: 1284

Copies: 1

Bin: Upper

Print Quality: Unknown

Color: Color

Duplex: Simplex

YHResolution: 300
True Type Option: Download - Print as soft fonts




Clearing the Clipboard

To clear the clipboard of its contents, click on 'Printer Control Stuff' on menu page 1, then
'Clear Clipboard' on menu page 2.



Viewing the Clipboard

To launch the windows clipboard viewer (equivalent to typing ‘clipbrd' in the Windows
Program Manager run menu):

Press {CTRLY{SHIFTHV}.
Click on 'Printer Control Stuff' on menu page 1, then 'Clear Clipboard' on menu page 2.



Printing the Clipboard
To print the clipboard press {CTRLH{SHIFTHB} (for board). This output is monitor sized.

Winptr determines the format of the clipboard contents and prints accordingly, whether it's
text, a Windows bitmap (BMP) or metafile (WMF).



Ejecting the Printer Page

To send a page eject to the default printer, click on 'Printer Control Stuff' on menu page
1, then 'Eject Page' on menu page 2.



Launching Windows Printer Setup Dialog

To launch Windows Printer Setup dialog, click on 'Printer Control Stuff' on menu page 1,
then 'Printer Setup' on menu page 2.



Launching Control Panel Printers Dialog

To launch Windows Control Panel Printers dialog, click on 'Printer Control Stuff' on menu
page 1, then ‘Control Panel - Printers' on menu page 2.



Clipboard Output Options
To send the clipboard contents to the:
Printer

Monitor sized -- Press {CTRLH{SHIFTHB}.
Printer Adjusted -- Click on the Adjust Clipboard -> Printer entry on menu page 1.

File -- Click on the ? -> File entry on menu page 1, then on the Clipboard entry.



Clipboard Input Options

Click on the ? ->Clipboard entry on menu page 1, bringing up the following submenu:

?File -> Clipboard

Window -> Clipboard Al-Prisc
Client -> Clipboard

Hectangle -» Clipboard

Screen > Clipboard Prtsc

. File -- Select the "?File -> Clipboard' entry, then select the input file type

Bitmap File -> Clipboard

Metafile -> Clipboard
Text File -> Clipboard

Alternatively, for two of the sources hotkeys are available:

" Screen - alternatively, press the {PRINTSCREEN} key.
" Window - alternatively, press {ALTHPRINTSCREEN}.

Note: WinPtr loads ASCII / Text files using a Windows edit control. This limits the file
size of text input files to about 32K. Files larger than that will be only partially loaded.




Adjust to Printer Output Option
WinPtr provides two size options for printing the following:

Screen
Rectangle
Clipboard

Bitmap (BMP) file

Hotkey printing of the first three defaults to monitor sizing. Bitmap files and the others can
be printed so that the output is adjusted to the printer page by clicking on the appropriate
'adjust’ item on the menus.

When adjusted size printing is requested, WinPtr computes the maximum size output
image that will fit on the page and still retain the image's aspect ratio.



Monitor Sizing Printer Output Option
WinPtr provides two size options for printing the following:

Screen
Rectangle
Clipboard

Bitmap (BMP) file

Hotkey printing of the first three defaults to monitor sizing. Bitmap files and the others can
be printed so that the output is adjusted to the printer page by clicking on the appropriate
'adjust’ item on the menus.

When monitor size printing is requested, WinPtr sizes the output image to have the same
horizontal and vertical pixel measurement on the printer as it has on the monitor. This
usually results in a smaller image.

Note that where monitor size printing is not an explicit option, you can capture or transfer
the image to the clipboard using the WinPtr functions available for that, then print the

clipboard with {CTRLH{SHIFTHKB}, which defaults to monitor sizing.




File Output Options

File output options can be accessed by pressing {CTRLH{SHIFT}F} or by clicking on the
'? -> File' entry on menu page 1. The following submenu appears:

?File -> Clipboard

Window -> Clipboard Al-Prisc
Client -> Clipboard

Hectangle -» Clipboard

Screen > Clipboard Prtsc

Select the entry corresponding to the source. In the case of the clipboard, WinPtr can
discern whether the contents are text, a bitmap or metafile and creates the appropriate
output file. All captured images are stored as (DIB) bitmaps.



Fax Output Options

Fax output options can be accessed by clicking on the '? -> Fax' entry on menu page 1.
The following submenu appears:

?File -> Clipboard

Window -> Clipboard Al-Prisc
Client -> Clipboard

Hectangle -» Clipboard

Screen > Clipboard Prtsc

Select the entry corresponding to the source.

You must have identified your fax driver to WinPtr prior to requesting that it send fax output



Features Under Consideration

Some things I'd like to add to WinPtr, in a later version; some easy, some iffy:

. Hotkey access to Print Manager

" Print directory

- Print 'Whereis' type report

- Print 'grep’ type report

" Hex printing file contents

" Netware print queue capturing to sync with printer changes

" Netware printer queue status

. Enhance device capability information display

. Provide capability to print text files larger than 32K

. Add option to save successive captures to files automatically named sequentially avoiding

interruptions during a capture sequence.

Let me know if you have a print need that would make a good addition. If | use it, I'll send
you a free upgrade.



The Peliware.INI File

WinPtr stores working information in this file in the directory where the WinPtr executables
are stored. Typical contents are:

[winptr]

; hotkey - 1=shift,2=ctrl,4=alt - for a combination add the numbers
: i.e ctri/shift=1+2=3

;hotkey=3 ... is the default

fax=HP LaserJet Series Il on LPT1:

Lines beginning with semi-colons (;) in Windows INI files are treated as comments.
The commented hotkey information documents the default and how to change it.

WinPtr stores the 'fax="entry to remember your fax driver from session to session. It
creates this entry when you identify your fax driver, which you must do prior to sending
WinPtr output to your fax.




Identifying Your Fax Driver

Before you can route WinPtr output to your fax, you must tell WinPtr which Windows
device is your fax. WinPtr then records its name in peliware.ini for retrieval when needed.

Identify your fax by clicking the 'Printer Control Stuff' entry on menu page 1, then
the 'ldentify Fax Driver' entry on menu page 2. WinPtr displays a list of available active
devices from your win.ini file, e.g.

COMPAQ PAGEMARQ 20 +2012.015 on LPT1.PFP

Generic | Text Only on LPT1:
HP DeskJet 1200C on LPT3.pip
HP LaserJet lISi on LPT2.pfp
HP LaserJet Series Il on LPT1:
QMS ColorScript 100 on LPT1:

Click on the line containing your fax name.

When you route something to your fax, WinPtr:

" changes the Windows default printer to your fax using the device information it recorded in
peliware.ini when you identified the fax,
" "prints" the output to the default printer (your fax), then

" restores the prior default printer (your printer).



Printer Output Options

All printer output choices are available via items on menu page 1, partially depicted here:

?File -> Printer »
Clipboard -> Printer Ctrl-shift-B
Adjust Clipboard -> Printer

Client area -> Printer Ctrl-shift-C
Screen area -> Printer Ctrl-shift-5
Adjust Screen -> Printer Ctril-shift-A
Rectangle -> Printer Ctrl-shift-R
Adjust Hectangle -> Printer

YWindow -> Printer Ctrl-shift-W

Many are also available via hotkeys, as noted on the above menu section.

Additionally, several printer output options offer a choice of monitor or printer adjusted
sizing.



Changing the Default Printer

Windows maintains the identification information about the default printer, printer name,
driver file name and output port, in the win.ini file in its [windows] section's "device=" entry.
It also has a list of available output devices in its [devices] sections with the same
information for each.

When you wish to change the default printer, you select the 'Printer Control Stuff' entry
on menu page 1, then the 'Change Default Printer' entry on menu page 2. WinPtr
displays all available active devices from your win.ini file (devices with port not "none") in a
list like this:

Generic | Text Only on LPT1:
HP DeskJet 1200C on LPT3.pip
HP LaserJet lISi on LPT2.pfp
HP LaserJet Series Il on LPT1:
QMS ColorScript 100 on LPT1:

The current default printer is grayed (or grayed, depending on your chromatic persuasion).

Click on the line containing the desired new printer identification. WinPtr changes win.ini
to the new printer and issues the proper notification to other active Windows applications
that the default printer has changed. Note, though, that not all Windows applications pay
attention to such notifications.



Registration

This excellent program is shareware. Shareware means you can try the program before
you buy it. You are free to try this program for 30 days.

If you decide to use it thereafter, you are obligated to send $20 to:
PAUL POELLINGER
2019 Round Lake Drive
Houston, TX 77077
Texas Residents, include 8.25% sales tax (total = $21.65).

Here's a terrific idea. Clip out the following little form to send me using WinPtr's print
rectangle function.

Paul F Poellinger
2019 Round Lake Drive
Houston, TX 77077

| Name

| Address

I

I

|

| E-Mail id

| Diskette preference: 35t 525"
| Where'd you find WinPtr

I

| Comments:

| Thanks, Paul, you sure did a terrific job on WinPtr.
I

I

I

I

I

| Amount:___ copies @ $20 + TX sales tax = total
|

| Send to:

I

I

I

-- OR --
Register via Compuserve's shareware registration service by typing GO SWREG at the
prompt. | charge $23.50 for registering this way because Compuserve gets 15%...guess
shareware means everyone who can gets a share :-( ... TX residents, I'll eat the tax.

When you do, I'll send you a version without the nag screen.

Please include your e-mail address if you have one (automatic with SWREG) ...unless
you say no, I'll send your nagless version via e-mail.

Please note that even if you paid for a diskette or CD containing this package, you must



still pay my registration fee for use of WinPtr past the 30 day free trial. The fee you paid
for the CD or diskette is someone else's "share" :-(

If you paid for WinPrt, a smaller, simpler incarnation (see below), you can own this one for
$10.

I, and all those dependent on me, thank you.

You are free to pass the TRIAL VERSION package on to others or upload it to bulletin
boards provided that 1) you do not charge for it above the cost of distribution, and 2) all
parts of the package are included (see "included" at the top).

A registered version may not, of course, be uploaded or passed on to others.

Thank you for supporting shareware.

Product support for WinPtr, and all Peliware, can be obtained free via e-mail. Send all
correspondence to 70732,3576 on Compuserve (70732.3576@compuserve.com).

Corporate licenses are available:

2 to 25users... $250

26 to 250 users ... $500

over 250 users ... $500 plus $1 per user

unlimited users ... $1000 just in case Microsoft wants one :-)

The latest version of this package, and all other Peliware, can always be found in the
libraries of the WINSHARE and MSBASIC fora on Compuserv.

I've been selling a group of simpler utilities for screen and clipboard printing and printer
orientation control (PPrint/Prtsc, PClip/PrtClip, and Portland), collectively called WinPrt, for
some time. Look for them in the WINSHARE and MSBASIC fora of

Compuserve (search for WINP*.ZIP for latest version).

The set is $10. Corporate licenses are $250.

Look for PPRTR*.ZIP in WINSHARE or MSBASIC for a DLL providing advanced printer
control to higher level languages (like Visual Basic).



About Bitmaps
WinPtr handles bitmaps in several formats:

" Windows Bitmaps (BMPs) -- This is the "normal” windows bitmap, also called a DDB or device
dependent bitmap. It is "dependent" on the color organization and capabilities of your video display, thus
restricted to the colors the device driver supports, for example. The normal method of copying and
resizing BMPs is the Windows API BitBIt function. Depending on the drivers involved (display and
printer), the results of using BitBlIt to print a bitmap can vary from extremely poor output quality to no
output at all. Although all printer drivers are able to BitBIt a monochrome bitmap to the printer, this
technique generally produces poor results because the printer cannot apply gray-scaling to the image.

. Device Indepent Bitmaps (DIBs) --DIBs were introduced in Windows 3.0, provides color
capabilities without regard to the device it will eventually be displayed on. The process of displaying the
image on devices with different display capabilites is simplified. For instance, capturing a screen from a
24-bit display adapter and printing it on a 1-bit (monochrome) printer can produce exceptional results if
DIBs are used. Additionally, many printer drivers implement gray-scale dithering; the output on these
printers is also excellent when DIBs are used. Using a DIB to convert a bitmap between display devices
with different capabilites can preserves the original color information.

" Windows Metafiles (WMFs) -- Bitmaps are the result of executing Windows GDI (Graphic
Device Interface) function calls which "paint” the image to the output device. Metafiles are a package of
the coded GDI function calls necessary to create the image. The functions are "played” (re-executed)
to create the resulting image when the need for its display arises. Metafiles are more device-
independent than other images, as the GDI functions are interpreted at run time, based on the output
device (and its capabilities) involved. Metafile support in Windows is spotty at best, however.

WinPtr supports metafiles whereever it finds them. It also uses DIBs wherever possible,
converting BMPs to DIBs as soon as it finds them. All output images are stored as DIBs.



Product Plugs

During preparation of WinPtr I've used a few tools that | feel are worth recommending to
others who might find themselve with similar needs.

Borlands Resource Workshop is the best resource tool around. WinGIF is a shareware
product I've used successfully for some time to mess with bitmaps. To enhance
debugging I've found PC-Lint and Bounds Checker to be invaluable. Bounds Checker is
one of the most amazing programs I've seen...and the company, NuMega also uses a bird
as it's alter ego, this one really is a penguin...which validates that bird fanciers make useful
tools. Finally, I've created a lot of Help files with WinWord, the default help file production
tool, but | hadn't lived until | was able to use Help Magician on this file...what a
difference...akin to the comparison of writing with a pencil versus a word processor. The
authors of these products have my admiration and thanks, not to mention a goodly amount
of my money.



Uninstalling WinPtr

In the unlikely event that you decide not to register WinPtr, you have a moral obligation to
remove it from your system. Your loss. To make that loss easier, I've included in the
package an uninstall program.

If you followed my recommendations in the read.me file, X_WINPTR, my uninstall program,
can be found on the WinPtr diskette. If, instead, you placed it in the directory where
WinPtr is installed, it cannot properly execute, because it won't delete itself. Move it
somewhere else first.

Close WinPtr if it's active. Then, from Program Manager's File/Run menu item, run
X_WINPTR.

If you for some reason manually set up the Icon in the Program Manager Startup group,
use [Description:  WinPtr] ... If you don't use this, the uninstall won't find it..

Thanks for giving WinPtr a try, and for taking part in the shareware experience.




Routing Printing to a File

WinPtr provides menu options to direct a specific output function to a file:

?File -> Clipboard

Window -> Clipboard Al-Prisc
Client -> Clipboard

Hectangle -» Clipboard

Screen > Clipboard Prtsc

This direction of output to a file applies only that one time to that specific menu
selection. It has no effect on any other printer output, because it does not effect the
default printer port assignment used in other printing functions (or by other applications, for
that matter).

However, there are times when it's desirable to have all printer output go to a file(s)
instead of the printer. Typically, the output file is subsequently transported to another
computer to be printed. Windows allows this by recognizing an output port of FILE:.

There are two major differences between WinPtr menu functions '-> File' output and
changing the Windows default printer's output destination to FILE:

. WinPtr -- writes to a file only that one time.
. FILE: port -- all subsequent printer output goes into a file, with Windows prompting for a file name
each time a print operation is requested.

" WinPtr -- no printer control characters are included in the file.
. FILE: port -- Windows sends to the file exactly what it would have sent to the printer, including all
printer directive control characters.

Typically, files created when Windows "prints" to the FILE: port are later sent to the printer
using DOS copy commands (copy xxx.xxx > LPT1 /b).

WinPtr provides a menu item for designating that all current default printer output
henceforth be routed to the FILE: port. The menu entry for doing this is found by clicking
the 'Printer Control Stuff' entry on menu page 1.

. The menu page 2 entry for this function will read 'Reroute Printer Output to FILE:' when such
output is not currently being so directed. Click this entry to activate FILE: printer port output.

. If output is being routed to the FILE: port, the menu page 2 entry will read 'Reroute Printer
Output to XXX:' where the XXX: represents the normal port for the current default printer. Clicking this
entry then will revoke FILE: output. Subsequent printing will go to the appropriate printer port.

When FILE: port output is in effect, whenever you print Windows will ask you to name the
output file:

= Print To File

DOutput File Hame:

[
| |




Enter a file name (with path) and the print operation will continue with that file as the
destination. 'Cancel’ will cancel the print operation.

Note that changing the Windows default printer using the Change Default Printer menu
page 2 entry terminates FILE: port output. The new default printer's port will be used.
Follow the instructions above to reroute it's output to FILE:.



Find the Icon

Selecting WinPtr functions are easy when you can see the icon: simply click on it and traverse the
menu paths...OR use the hotkeys. BUT what do you do when you're deep in your work, with lots of
windows opened and the icon deeply buried somewhere on your desktop below?

WinPtr provides a hotkey {SHIFT}{CTRL}{I} for icon which brings menu page 1 in front of your
workspace. The icon doesn't appear, nor do the menus stay around to mess up any capturing you're
doing. What a guy!






