
    INOTEPAD HELP 
 This program provides a few additions over the standard Microsoft Windows Notepad program.    Added 
features include the ability to choose fonts, operates with word wrap on at all times, typing macros, ability 
to strip CrLfs from selected text, and printing of filename as a header for each page. 

 The program operates almost identically to Notepad.    Typing macros maximum size is 2000 characters. 
The macro menu is obtained by either pressing    the control key and shift key or with the mouse clicking 
on the MACROs menu.    Macros are edited using the Edit Macros selection under the Edit menu. 

 In Inotepad WORD WRAP is always on and cannot be turned off. 

  MENU COMMANDS 
 File Menu 

  Edit Menu 

  Search Menu 

  Macros Menu 

  HOW TO 
  How to edit and use the typing macros 

  Print selected portions of the text 

  Strip CrLfs from selected text 

 Listing of Shortcut Keys 

 About INOTEPAD - author, programing environment, usage 



 File Menu 
 The File Menu is utilized to open and close files, Choose printer/Screen fonts, print files and to exit the 
program.    these menu actions are very similiar to the Windows Notepad with the addition of the Font 
Selection. 

  New                    Shortcut      Ctrl-N 
 To start a new file, select File New.    All text in the notepad is removed.    If you have not Saved the 
previous file, you are prompted to save before opening a New file. 

 Open 
 To open a file on disk, select File Open.    This will bring up a standard WIndows File Open dialog to 
select a file.    Default file mask is All text Files. 

 Save              Shortcut    Ctrl-S 
 This is save, without prompting, the current file to disk.    The current open file is part of the 
INOTEPAD Form label.    If there is no file currently open, the Save    As procedure is automatically 
called. 

 Save As 
 This will bring up a standard WIndows Dialog box to specify both the directory where you want to 
save the file and for the filename.    If you try to overwrite and existing file, a caution prompt will be 
made and the file save operation may be canceled. 

 Choose Font 
 This will bring up a standard Windows Dialog box to select the font desired.    The font set is used 
both for printing and for screen display.    The last font selected is also saved to disk and when the 
program is started up again that will be the font is use.    Font size is restricted to 8-12 point font 
sizes. 

 Note, the default setting in the font dialog box is "Regular".    Selecting "BOLD" will provide a slightly 
better screen display.    The fontweight is NOT sent to the printer - thus you can pick "BOLD" for the 
screen display and the printed text will still be regular. 

 Print 
 This will send the current file to the printer.    If there is no text currently selected, the entire file is 
printed without any prompts.    If you have a portion of the text selected (highlited), then a standard 
Windows dialog box appears and you can select to either print the entire file or ONLY the selected 
portion of the file. 

 Exit 
 Selecting this will close down the program.    If the current file has not been saved a prompt is 
issued. 



 Edit Menu 
 The Edit menu contains the normal procedures for working with the Clipboard plus to additional features: 
Strip CrLf and Edit Macros.    Strip CrLf is used to strip CrLfs from selected blocks of text.    Edit Macros is 
used to edit the typing Macros available. 

  Strip CrLfs 

 Edit Macros 

  Undo: Undo will immediately UnDo the previous typing action taken.    But this must be the next 
action you choose.    If you perform any other editing, the UnDo buffer will be lost.    If you Delete 
something by mistakes, click on the Edit Menu, then Undo and the deleted text will be restored. 

  Cut:    Shortcut:    Ctrl + X Cut will deleted the selected text from the textpad and copy it to the 
Clipboard. 

  Copy:      Shortcut: Ctrl + C Copy will make a copy of the selected text and place it on the 
Clipboard.    No change is made to the textpad 

  Paste:      Shortcut: Ctrl + V Paste will place the text on the Clipboard into the textpad at the 
current location of the cursor. 

  Del: Del will remove the selected text from the textpad but it DOES NOT place the deleted text on 
the Clipboard.    This action can be restored with the UnDo button. 

  Select All: Select All simply selects all of the text on the textpad. 



 Strip CrLfs              Shortcut:    Ctrl - Z 
 Selecting this item will remove all Carriage Return - Line Feeds (CrLfs) from the selected text.    To use:    
first select the text to operate on.    Then click on Edit Menu, Strip CrLf (or use the shortcut key: Ctrl + Z). 
All CrLfs are removed. 

 This item is particularly useful when you copy text from the clipboard that has embedded CrLfs.    If 
you want to strip them from the entire document use Edit Menu - Select All to select the text.    
Usually, paragraph breaks will want to be maintained.    The easiest way to reformat the text is to use 
the mouse to select a paragraph and then use the shortcut key, Ctrl - Z, and strip the CrLfs.    Be sure 
you do not include the paragraph ending CrLf. 

 The UnDo function does not work on this action. 



 Edit Macros 
 The macro capability with INOTEPAD provides the capability of storing keystrokes, up to 2000 
characters, and later inserting them into a document by use of a Pop up menu.    The Pop up menu can 
be activated by either holding down the ctrl key and pressing the Shift Key or by clicking the mouse over 
the Macros menu item.    The Pop up menu displays a list of the Macro TITLES. 

  Editing Macros 
 to set up the macros, under the Edit Menu, select Edit Macros.    This will bring up a second screen. 
The top portion of the screen lists the titles of the 25 macros available.    The multiline text box at the 
bottom of the form displays the actual macro text attached to any specific label.    Macro titles are 
limited to 30 characters.    Macro text is limited to 2000 characters. 

 To edit a macro, click the mouse on either the labeled button (A through Y) or click the text entry box 
immediately to the right of the label.    Type the macro title in the box next to the label.    This is the 
title that will be displayed in the pop up menu.    Then click in the textbox at the bottom of the form 
and type the desired text into the textbox. 

 Whenever you click on one of the lettered buttons (A throughY) the cursor is shifted to the textbox.    
You can start typing the text for the macro immediately.    When the textbox looses focus the first 30 
characters of the text box is inserted as the macro title.    The only purpose of the title is to provide a 
basis for selecting the desired macro from the pop up menu.    If the first 30 characters of the text of 
the macro is sufficient to identify the macro, then you do not have to separately type in a title. 

 As a shortcut, if you know you need to type in a separate title, just click the title box immediately to 
the right of the label to which you wish to attach the macro.    Then type the title.    When you have 
completed the title, pressing the Tab key will switch you to the textbox so you will be able to type the 
macro text. 

 You may also paste whatever is on the Clipboard into the Textbox.    If you elect to Paste from the 
Clipboard whatever is currently on the Clipboard will replace whatever was attached to that macro 
before.    After you press the Paste From Clipboard button, a standard Windows dialog box will 
appear for the title of the macro.    By default, the first 30 characters of what is currently on the 
Clipboard is offered as the title.    you may accept this by pressing the OK button or edit it.    Note, the 
entire title is highlighted, thus if you start typing, your typing will delete what is currently in the title 
and place there what you type into the prompt box. 

 At any point Clicking the Save Macros button will save the macros and text to disk.    Clicking the 
Done button saves all macro data to disk AND closes the edit macro screen.    If you expected to be 
revising the macros during work, you do not need to close the macro screen.    It can be collapsed to 
an icon and reactivated anytime with a double mouse click on the icon.    Macros are available as you 
revise them.    After completing any editing action it is a good practice to Click the SAve Macros 
button to write all macro data to disk. 

 While working in the text box the Macro Pop up menu can be activated by pressing down the Ctrl 
key and holding the Ctrl key down while pressing the Shift key. They can also be selected by clicking 
the mouse over Macros on the menu bar.    To select a particular macro, press the letter of the macro 
you want or move the highlite up and down the menu with the up and down arrow keys until the one 
you want is highlited.    Then press the Enter key.    You can also click the item you want with the left 
mouse button.    Selecting a Macro will insert the macro text at the cursor location in the text box. 



 Search Menu 
 The Search Menu will find a text pattern within the text box.    All searches when using the FIND menu 
item start from the TOP of the document.    The Find Next item will find the next occurance of the text 
pattern starting from the last find location. 

  Find: 
 To find a text pattern, select Search - Find.    A standard Windows dialog box will open to enter the 
text pattern you want to find.    The Find operation IS CASE SENSITIVE.    If the text pattern is found, 
the cursor is placed at the start of the pattern.    Searches start from the top of the document, no 
matter where the cursor is currently located. 

  Find Next:    (Shortcut:    F3 key) 
 Find Next will located the NEXT occurance of the text pattern entered with the preceeding Find 
operation.    No Dialog box is provided.    Note the SHORTCUT.    The Find Next searches only 
downward through the document. 



 Macros                Shortcut:    Ctrl + Shift 
 Clicking this menu selection will Pop up the macro menu.    To cancel the menu, press the ESC key 
or click, with the mouse, anywhere outside the menu. 

 The Macros Pop up menu can also be activated by holding down the Ctrl Key and pressing the Shift 
Key. 

 To select a macro, press the letter of the macro (A through Y), use the up and down arrow keys to 
select the menu item desired by pressing the enter key, or click the item you want with the mouse. 

 If you Pop up the Macros menu and the item you want is not on the menu, you want to edit one of 
the items, or you can't remember what the text is associated with the title: then Select Edit - Edit 
Menus from the menu bar and a form will open for editing/reviewing the macros.    Since these 
macros take effect immediately after revising, they can be quickly revised.    (Note:    if you have the 
macros screen in an icon, just double click the icon to bring up the edit/review form).    When you 
have completed revising macros it is a good practice to select click the Save Macros button to write 
the revisions to disk. 



 How to Use the Macros 
 Before the macros can be used, the typing strokes desired with each title must be entered.    This is 
done using the Edit Menu - Edit Macros Edit Macros. 

 To use a macro,    select the Macros menu item, by: 

 1 - Click on the Macros menu title 

 2 - Hold down the Alt key and press letter "M" (This shortcut activates the Macros menu) 

 3 - Hold down the Ctrl Key and press the Shift Key 

 The edit macros screen can be left open while working within the Inotepad.    It can be minimized to 
an icon by clicking on the down arrow in the upper right corner of the Edit Macros form. 

 Limits: 

 Size of macro text - 2000 characters 

 Number of macros - 25 



 HowTo Print Selected Text 
 To only print selected portions of the text: 

 1 - Select the portion of text you want to print. (The easiest way is to place the cursor at the start 
of the text and while holding down the left mouse button, drag across the text desired.) 

 2 - Select File Menu - Print 

 3 - A standard Windows Print Select dialog box then appears.    Click the option button for 
"Selection" and click OK.    The selected block of text is then printed. 



 How to Strip CrLfs 
 This function is used to remove CrLfs from text you may bring into the text box.    Proceed as follows: 

 1 - Select the text from which you want to remove the CrLfs.    This can be done by dragging the 
mouse across the text.    (If you want to remove CrLfs from the entire document, use Select All 
on the Edit Menu. 

 2 - Select Edit Menu - Strip CrLfs or use the Shortcut keys:    Ctrl + Z 



 SHORTCUT KEY LIST 
 Ctrl + Shift          Macro Pop up Menu 

 Ctrl + S              Quick Save 

 Ctrl + Z              Strip CrLf 

 F3                      Find Next 

 Ctrl + X              Cut 

 Ctrl + C              copy 

 Ctrl + V              Paste 



 About and Technical Info 

  Author 

  Gordon Smith 

  341 RiverBend Road 

  Great Falls, VA 22066 

  703-759-4415 

  CompuServe 72567,3416 

  Resources: 
 INOTEPAD was written using Microsoft Visual Basic (VBRUN100.DLL required) and MicroHelp 
Muscle (Muscle.Vbx required).    The Muscle calls are identified since they all start with "Mh".    The 
declarations for each is in the Global module.    The Muscle.Vbx runtime distributed copy CANNOT be 
run from within the Visual Basic environment. 

  Restrictions: 
 This program is placed in the Public Domain.    The program and all code is uploaded on 
Compuserve Visual Basic Forum.    Visual Basic Forum users are welcome to use the program or 
modify the program and use it in any way desired.    Owners of MicroHelp Muscle have the mximum 
flexibility in modifying the code.    For those who do not own Muscle, most uses of Muscle can be 
derived from other means; in fact, most can be done from pure VB code and the use of Windows API 
functions.    (Muscle was used to either speed up certain operations or to simplify others (like API 
uses).    The program and code is uploaded as a small means of REPAYING all the help received by 
the author from other Visual Basic Forum users. 




