
Welcome

AutoSketch is a precision drawing tool for the Microsoft Windows NT 4.0 and Windows 95 environments. It is 
developed for use by anyone who needs fast, accurate drawings and wants the power and flexibility afforded by 
Windows NT 4.0 and Windows 95. Uses for AutoSketch include:

Engineering drawings
Architectural drawings
Electrical schematics
Facility plans
Office layouts
Interior design drawings
Process flow diagrams
Maps
Business graphics
Charts and diagrams

The emphasis throughout AutoSketch is on speed, power, and ease of use. Features appear when you need them 
but are kept out of the way when you don’t. If you’re already a Windows NT 4.0 and Windows 95 user, you’ll find 
the menu system and much of the screen familiar. If you’re new to Windows NT 4.0 and Windows 95, you’ll find it 
an easy place to work. AutoSketch is also a Microsoft Office 97 Compatible product, which means that many of its 
basic features (including toolbars, menus, and accelerator keys) are similar to those used by Microsoft Office97 
products. If you are already using a Microsoft Office 97 Compatible product, you’ll notice that many tasks can be 
completed in a similar manner in AutoSketch.
    Related Topics



Contents of Package

AutoSketch comes with everything you need to install and use the software. The package includes the following 
items:

AutoSketch CD
AutoSketch Getting Started Guide
AutoSketch What’s New? Guide
Registration card

    Related Topics



System Requirements

In order to run AutoSketch, you must have an 486 DX or Pentium-based computer. In addition, your system must 
include the following:

A hard drive with at least 41 megabytes of free space. 
Microsoft Windows NT 4.0 or Windows 95. AutoSketch is not compatible with earlier versions of Windows.
Eight megabytes of RAM, 16 megabytes is recommended. 
A mouse (or other pointing device) supported by Windows.
A display adapter and 256 color monitor that Windows NT 4.0 and Windows 95 supports.
A CD-ROM drive.
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Device Drivers

As a Windows program, AutoSketch uses the device drivers provided by Microsoft and others specifically for use 
with Windows NT 4.0 and Windows 95. AutoSketch itself does not provide drivers for printers, plotters, display 
adapters, pointing devices, and so on.
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Registering AutoSketch

There are three ways to register your new software with Autodesk. 

In all countries:
Fill out the registration card included with your software and drop it in the mail. 

In the United States and Canada:
During installation a prompt appears to register your software online. If you have a Web browser installed on 

your system, click Yes and the Autodesk Personal Solutions Online Software Registration starts. Simply fill out the 
information on the Online Software Registration dialog box, then click Submit Form. 

Register online after installation at our Web site: just point your browser to http://www.autosketch.com 
then click Register and enter your information.

Registering makes you eligible for technical support and for early notification when new product releases become 
available. It also provides Autodesk with important information about how you use your software.
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Technical Support

If you have a software problem that you can’t solve, contact your local technical support line. The number is listed 
on the technical support card included with your software. 

For an updated list of Frequently Asked Questions (FAQ), refer to the AutoSketch Web site at 
http://www.autosketch.com and click Support. You may find the information you need, and save yourself a 
telephone call.
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Microsoft Office 97 Compatible 

AutoSketch is a Microsoft Office 97 Compatible product, which means that many of its basic features (including 
toolbars, menus & accelerator keys) are similar to those used by Microsoft Office. If you are already using a 
Microsoft Office 97 Compatible product, you’ll notice that many tasks can be completed in a similar manner in 
AutoSketch.

Look for the Microsoft Office 97 Compatible logo when purchasing software. For more information about the 
Microsoft Office 97 Compatible program, and for a complete listing of Microsoft Office 97 Compatible products, 
please see the Microsoft web site at http://www.microsoft.com/office/msofc/overview.htm or call Microsoft 
Customer Service at 1-800-426-9400. Customers outside the United States should contact their local Microsoft 
Office. 

Office Compatible Features Supported by AutoSketch
Using the toolbar
AutoSketch has a toolbar similar to the toolbar in Microsoft Office 97, additionally each toolbar button 

displays ToolTips. For example, you can save a drawing just by clicking the Save button on the Standard toolbar. 
Using the menus
AutoSketch menus, menu commands, and dialog boxes are designed to look and respond like Microsoft 

Office 97 Compatible programs. 
Using keyboard shortcuts
AutoSketch keyboard shortcuts are designed to match those of Microsoft Office 97 Compatible programs. 

For instance, to copy an object to the Windows Clipboard, press CTRL+C, and to paste it press CTRL+V. 
Sending AutoSketch files through Microsoft Mail
Using the Send command on the File menu, you can attach an AutoSketch drawing file and send it through 

Microsoft Mail. 

Using AutoSketch with Microsoft Office 97
Cutting, copying, and pasting AutoSketch objects into other programs
AutoSketch objects can easily be cut, copied, and pasted from one program to another, using the Cut, Copy 

and Paste commands on the Edit menu. 
Object linking and embedding (OLE)
You can use OLE to include an AutoSketch drawing in another program, such as Microsoft Word, and also 

include objects from other programs in your AutoSketch drawing file. 



Important Concepts

You are probably familiar with “paint” and “draw” programs that are common on personal computers. A paint 
program creates an image by assigning colors to each dot in a rectangular array of dots. A draw program creates 
an image by defining objects mathematically. A line, for example, is a specific pattern of dots in a paint program. In 
a draw program, a line may have properties such as color, width, style, and so on, but in its simplest form, it has a 
startpoint and an endpoint.

AutoSketch is similar to an ordinary draw program, but it goes a few steps further. It allows you to work with the 
actual (world) sizes of the objects you draw whether those objects are miles, millimeters, or microns across. It also 
allows you to zoom in or out of your drawing almost without limit. And during all of this, it keeps track of the scale 
of your drawing, showing you exactly how it will appear when printed.

But there is more to an AutoSketch drawing than the way it looks. Underlying each drawing is a database a 
series of predefined and user-defined properties that you can use as a basis for selecting entities, generating 
reports, and exporting information to other Windows applications. For example, by assigning properties to a line, 
you can record the fact that it represents a half-inch cold water pipe located under the master bedroom. The ability 
to store and recall database information makes AutoSketch a powerful tool for organizing graphic and textual 
information.

In this brief topic, you will learn about the special concepts on which AutoSketch is based. Reading it helps you 
understand how AutoSketch works and makes it easier for you to become productive.
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Entities

Each item you add to a drawing is called an entity. Entities are the building blocks of a drawing. Other programs 
may refer to entities as objects, items, or elements. AutoSketch creates the following entity types:

Arc An arc is a portion of a circle. You can use an arc to show the direction a door swings, a rounded wall, 
and so on. For more information, see Arcs and Circles.

Circle A circle is a curved line with every point equally distant from the center. You can use a circle to 
represent a hole, a round object, and so on. For more information, see Arcs and Circles.

Curve A curve is a polyline that is rendered onscreen and on printed output in a special way. AutoSketch 
supports two curve types: fitted curves and spline curves. Fitted curves pass directly through each control point. 
Spline curves pass through the first and last control points and are drawn toward intermediate ones. A closed curve 
can contain pattern fill. Use curves to create free-form shapes such as curved sidewalks and car fenders. For more 
information, see Polylines, Polygons, and Curves.

Dimension A dimension is a predefined collection of lines, arcs, markers, and text used to display a 
measurement in the drawing. The text label is updated automatically when you stretch or reshape the dimension. For 
more information, see Creating Dimensions.

Hatch A hatch is a special symbol AutoSketch generates to crosshatch an area closed by a group of 
selected entities. Once created, a hatch symbol behaves the same as any other symbol. For more information, see 
Pen and Pattern Properties.

Line A line is an entity that connects two points. You can use a line to represent any straight object such as 
a water pipe, a wall edge, an electrical connection, or a street. For more information, see Lines.

Marker A marker is a special entity that notes a specific point in a drawing. For more information, see 
Markers.

OLE Object An OLE object is a special entity created in one application and embedded into another. When 
you double-click a linked or embedded OLE object, Windows opens the source application that created it and loads 
the associated file. For more information, see Using the Clipboard & OLE.

Raster Image A raster image is a picture or bitmap that can be imported and placed in the drawing. 
AutoSketch treats the raster image like most other entities, allowing you to move, scale, or duplicate it as needed. For 
more information, see Tracing in AutoSketch.

Polyline A polyline is a multi-segmented line AutoSketch treats as a single entity. When a polyline is closed, 
it becomes a polygon. Use a polyline in situations where you need to know the total length of a series of connected 
segments. For more information, see Polylines, Polygons, and Curves.

Polygon A polygon is a closed polyline that can contain a fill pattern. Use a polygon when you need to know 
the area of an enclosed region or when you need to fill an area with a hatch pattern or a solid color. For more 
information, see Polylines, Polygons, and Curves.

Symbol A symbol is a group of entities that AutoSketch treats as a single entity. Symbols can be stored in 
libraries for use in multiple drawings. For more information, see Symbols.

Text A text entity can be any size and can use any AutoSketch or TrueType font. It can be rotated at any 
angle. For more information, see Working With Text.
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Properties

Properties, the individual qualities that define an entity, are divided into three categories:
Geometric properties are those that define an entity’s size, position, and so on. AutoSketch assigns 

geometric properties automatically as you draw and edit.
Graphic properties are those that specify the appearance of an entity. Graphic properties include layer, color, 

width, style, and pattern. AutoSketch assigns graphic properties as you draw based on the current settings on the 
property bar.

Fields are those you define yourself. You define a field by specifying its name, type, and width or precision. A 
desk symbol, for example, could have fields for model, size, color, and style. A resistor symbol for a printed circuit 
board could have fields for resistance, wattage, and tolerance. You can assign fields to any entity except a text entity, 
a marker, or a dimension. A field has two components: a field name, such as Manufacturer, and a value, such as 
“AAA Casements.” Assigning this value to the Manufacturer field of a window symbol attaches that information to the 
symbol.
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Coordinates

Coordinates are numbers that specify the location of one point in relation to another. This relationship is classified 
as either absolute or relative. Absolute coordinates reference the origin of the current coordinate system, for 
example, the Drawing Origin, the Grid Origin, or the Page Origin. Relative coordinates reference the last point you 
entered. They are useful when you want to draw or place another entity a know distance from another entity or 
point.

AutoSketch expresses location in three ways: xy (Cartesian), polar, and isometric coordinates. XY coordinates 
express location in terms of horizontal and vertical distances from another point. Polar coordinates express 
location in terms of distance (radius) and angle. For example, the xy coordinates 7,5 are equivalent to the polar 
coordinates 8.6,35.5.

Isometric coordinates differ from xy coordinates in that they add a third axis (Z) to the expression. Isometric 
drawings are usually used to create two-dimensional models of a three-dimensional object.
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Drawing Origin

AutoSketch locates most points in relation to the drawing origin, even if you move the grid origin. If you move the 
drawing origin on the page, the entire drawing shifts to reflect that change. The drawing origin appears onscreen 
as colored arrows indicating the positive x and y (and, if isometric, z) directions. It does not appear on printed 
output. Normally, the drawing origin is located at the lower-left corner of your page, however, if you need to move 
it, you can center the Drawing Origin on the page, or relocate it with the mouse, or by entering new coordinates. 
For more information, see Moving the Drawing Origin.
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Grid Origin

The grid origin is similar to the drawing origin in function and appearance. However, the grid origin serves as a 
reference point for grid coordinates only. By default the grid origin is located at the drawing coordinates 0,0, for 
example, at the drawing origin. However, you can move the grid origin of rectangular, circular, or isometric 
reference grids. For more information, see Customizing the Grid.
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Scale

Scale is the ratio between the actual (world) size of the entities in a drawing and their size on printed output. In 
conventional drafting, you scale the components of a drawing by using a special ruler. In AutoSketch, you simply 
enter the actual size of an entity and the software keeps track of the scale for you. Because of this, you could 
create drawings in AutoSketch without regard for scale.

Specifying a drawing scale, however, has two important benefits. It allows AutoSketch to accurately depict 
onscreen how your drawing will look on a printed page. And it allows you to specify entities such as text, markers, 
and dimensions by output size. This is usually more convenient than specifying such entities according to their 
size in relation to actual (world) entities. For more information, see Setting the Drawing Scale.
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Layers

Layers help you place entities together in logical groups. An architectural floor plan, for example, might contain a 
framing layer, a plumbing layer, an electrical layer, and so on. You can mask layers while working on others to 
remove distracting clutter and improve performance. Masked layers are not printed or displayed. You can also 
lock a layer to protect its contents from unintended change. For information on layers, see Organizing With 
Layers.
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Screen Layout 

The AutoSketch screen provides an assortment of features that make it easy to create precise technical drawings. 
This topic describes the components of the AutoSketch screen.

In most cases, this topic does not provide detailed information on standard Windows concepts or on specific menu 
items. For information on standard Windows concepts, such as the mouse, the Control menu, the window border, 
the maximize button, dialog box controls, and so on, refer to Windows online Help.
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The Interface

AutoSketch allows you to choose from two basic interfaces. New users, or users who are more comfortable with 
the look of most Microsoft applications can use the Microsoft Office 97 Compatible interface. Users who are 
familiar with the previous versions of AutoSketch can select the AutoSketch Classic interface. Both interfaces 
allow you full access to all of the functions and features of AutoSketchonly the positioning of toolbars varies. For 
more information, see Selecting an Interface.
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Title Bar

The AutoSketch title bar extends across the top of the application window. It displays the name of the program 
and the name of the current drawing file if the window that contains the drawing is maximized. The buttons at the 
right end of the title bar allow you to minimize, maximize, close, or restore the AutoSketch window. You can also 
maximize or restore a window by double-clicking on the title bar. You can exit AutoSketch by clicking the Control 
menu box, then clicking close on the drop-down menu. Double-clicking the Control menu box at the left end of the 
title bar is another quick way to exit. If AutoSketch is running in a window rather than maximized, dragging the title 
bar moves the entire window on the desktop.
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Menu Bar

You can choose menu items using either the mouse or the keyboard. To use the mouse, click the menu name. 
When the menu drops down, click the item you want. Menu items with an arrow to the right display cascading 
menus when you place the pointer over one of them. When you highlight a menu item a description appears in the 
status bar.

To use the keyboard, press ALT and type the underlined letter in the menu name, then the underlined letter in the 
menu item’s name. If there is a cascading menu, you must type another letter. You can also use arrow keys to 
move through menu items, and press ENTER to select one. Pressing ESC backs out of the menu items one level 
at a time.

There are single-key or key combination shortcuts for certain frequently-used menu items. Each menu lists 
available shortcut keys to the right of item’s name.

You can use the techniques for choosing menu items in combination. For instance, you could press ALT+D to 
choose Draw, then use the down arrow to choose Line, then use the mouse to click.
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Drawing Windows

The large area in the center of the AutoSketch screen is the workspace. This area contains drawing windows for 
each open drawing. The amount of memory in your computer limits the number of open drawings.

The title bar of each drawing window displays the name of the drawing it contains. When a drawing window 
contains a new, unsaved drawing, the title bar displays the word Drawing followed by a number that reflects the 
number of new drawings created in the current AutoSketch session.

The active window contains the drawing on which you are currently working and is the only one in which you can 
make changes. Normally, the title bar of the active window is displayed in a different color different from those of 
other windows. Clicking a drawing window makes it active. You can resize, minimize, maximize, and close each 
drawing window independently.
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Page

The large rectangle that appears in the drawing window when you load a drawing is the page. The shaded bands 
along each edge of the page are the margins. You can draw in the margins and off of the page, but any part of a 
drawing that falls in this area does not normally appear on scaled output. AutoSketch reads the default margins 
from the default Windows printer driver. For more information, see Setting the Page Size or Setting the Margins.

The pattern of lines or dots on the page is called the reference grid. It has three components: a snap grid, a major 
grid, and a minor grid. The snap grid is invisible. It is the grid to which points “snap” when you use Gridpoint snap 
mode. The major and minor grids are comprised of lines, crosses, or dots, and appear onscreen for reference 
only. They do not appear on printed output. For information on how to set up the grid, see Customizing the Grid.

When you create a new drawing using the Standard Blank Drawing template, AutoSketch automatically assigns a 
page size and orientation based on the default printer. If you prefer a different size or orientation, you can redefine 
the page using Page Setup on the File menu. If you choose a page size that is larger than the paper for which 
your printer is configured, AutoSketch automatically tiles the drawing.

Tiling is the process of printing a drawing on multiple sheets of paper. Several factors affect tiling, including page 
size, page orientation, and margin settings. You can display the tiling pattern onscreen by checking the Page 
Tiling check box on the Appearance page of the View Options dialog box.
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Scroll Bars

Scroll bars allow you to move across the drawing that is, to change the part of the drawing visible in the window 
without changing the level of magnification. To move the view in small increments, click the scroll arrow that points 
in the direction you want to move. To move in larger increments, click the control shaft, between the scroll box and 
a scroll arrow. To move by a custom increment, drag the scroll box in the direction you want to move. To hide the 
scroll bars from view, uncheck the Scroll Bars check box on the Appearance page of the View Options dialog box.
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Rulers

Rulers appear along the top and left sides of the drawing window. They represent units of measurement either in 
world size (the actual size of the object you are drawing), or the current page (output) size, depending on which 
ruler is active. To switch between rulers, click the toggle button in the upper left corner of the drawing window. To 
hide rulers from view, uncheck the Rulers check box on the Appearance page of the View Options dialog box. For 
more information on using Rulers in AutoSketch, see Using Rulers.
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Split Boxes

Split boxes allow you to split a drawing window into two or four panes areas that display separately controllable 
views of a drawing. There are several ways to split and unsplit a window. To split a window at a specific location, 
drag the appropriate split box to that location. To split a window at the exact center, double-click the horizontal or 
vertical split box. On the Control menu, click Split to split a window into four equal panes. To unsplit a window, 
drag the appropriate split bar to a corner, double-click the split bar, or on the Control menu, click Unsplit.

Some tools, such as Redraw and Extent, affect only the “active” pane. When there is only one pane, it is always 
active. When the drawing window is split into multiple panes, the active pane is the one to which the active pane 
indicator points. To change the active pane, click the active pane indicator until it points to the correct pane. You 
can also change the active pane by pressing F6 or SHIFT+F6.
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Drawing and Grid Origin

By default, the drawing and grid origin is located in the lower left corner of the drawing page. AutoSketch 
measures all points in relation to the drawing origin. You can easily change the location of the origin, but if you 
move the origin, all entities in the drawing move with it. To hide the origin from view, uncheck the Drawing Origin 
check box on the Appearance page of the View Options dialog box. To change the drawing origin colors, click the 
direction you want to change and a Color dialog box appears. Simply adjust the Red, Green, and Blue color 
values (RGB values) and click OK.
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Toolbars

Clicking a button on a toolbar has the same effect as choosing the menu item or operating mode it represents.

A toolbar often contains more buttons than are practical to display at once. Because of this, buttons are divided 
into toolsets. Each toolset contains a group of buttons that represent similar functions. For instance, all of the 
polyline tools are located in one toolset. Only one button from a toolset is visible at a time normally, the one 
used most recently. Even when you initiate an action or mode by other means, the corresponding button, if it is 
present in a toolbar, is made the current one in its toolset. For example, if you type the letter E to switch to 
Endpoint snap mode, the snap mode toolset in the All-In-One toolbar is updated to reflect the change. Buttons that 
contain hidden toolsets contain a small arrow in the lower right corner. 

To select a button that is not visible, click the top button and hold for a moment. When the complete toolset 
appears, drag the pointer to the button you want and release. 

The Standard toolbar contains buttons that perform some of the most common tasks in AutoSketch, such as 
opening, copying, and printing files, and so on. Buttons on the left side of the Standard toolbar are exactly the 
same as other toolbars in Microsoft Office 97 Compatible products. The Standard toolbar also contains the 
context-sensitive Help button, which you can use to display pop-up window Help on buttons or anything else in the 
AutoSketch application window. The All-In-One toolbar contains buttons related to drawing functions, selection 
functions, view functions, and so on.

You can move a toolbar to almost any location in the AutoSketch window by clicking near one of its edges then 
dragging it to its new location. Toolbars can also be docked alongside one another. To dock a toolbar, simply click 
and drag the toolbar alongside another toolbar.

The All-In-One, Standard, and other built-in toolbars are predefined and cannot be changed. You can create other 
toolbars, however, and configure them as you like. In a custom toolbar you can specify which buttons to include, 
how the buttons are grouped, and the name of the toolbar. For every toolbar you can specify location and whether 
to hide or display it. You can change the button size used in all toolbars. For information on how to customize a 
toolbar, see Creating Custom Toolbars.

In all, there are over 30 predefined toolbars in AutoSketch. Most consist of tools that are also available as toolsets 
on the All-In-One toolbar. Others, such as the Grid toolbar or the Office toolbar, contain unique commands that are 
useful to specific situations. Depending on which wizard option you select at start up, not all of the toolbars are 
visible when you first begin AutoSketch (for instance, if you select Office Layout from the Start Up dialog box, the 
Standard, All-In-One, and Office toolbars are visible). However, the visibility of all toolbars can be controlled from 
the Toolbars dialog box by checking or unchecking the toolbars. If a check appears in the check box next to a 
toolbar’s name, that toolbar is visible onscreen.
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Property Bar

The property bar is the primary means by which you specify the current layer, color, style, width, and pattern. Any 
change you make on the property bar affects future entities and any entities that are currently selected.

To change a setting on the property bar, click the drop-down list and make a new selection. To apply a new setting 
to an entity, select the entity you want to change, then click the current property setting on the property bar. If you 
forget the meaning of an item on the property bar or in a drop-down list, hold the pointer over it for a moment and 
a ToolTip and status bar message appears.

The Pattern control is somewhat different from other controls on the property bar. It applies only to polygons and 
closed curves. The Pattern control has three settings: None, Solid, and Hatch. None specifies no pattern fill, Solid 
specifies a solid fill pattern, and Hatch specifies a hatched fill pattern. The drop-down list box next to the Pattern 
control lists all the Solid and Hatch patterns available. For Solid patterns, the control allows you to select one of 
256 named colors. For Hatch patterns, it allows you to select one of several standard patterns. You can also 
create your own hatch patterns. For more information, see Creating Custom Hatch Patterns. 

Tip
A quick way to display the Graphic Options or Layer Properties dialog boxes is to right-click the 

corresponding control on the property bar, then click Layer Properties or Graphic Options on the pop-up menu that 
appears. 

Do not confuse polygon hatching with hatch symbols. Polygon hatching is a property. You can change the hatch 
pattern associated with a selected polygon by changing the hatch setting on the property bar. Hatch symbols, on 
the other hand, are entities based on a selection set and the current pattern settings on the property bar. You can 
manipulate a hatch symbol using any technique available for a normal symbol. The pattern setting on the property 
bar affects both types of hatching. 

You can change the location of the property bar by clicking and dragging it. The property bar can also be docked 
alongside another toolbar. To dock the property bar, simply click the edge of the bar and drag it alongside another 
toolbar. 

You can specify whether the property bar is hidden or displayed by right-clicking any bar, and clicking Property on 
the pop-up menu. If Property is checked, it is displayed. If it is unchecked, it is hidden from view. The same is true 
for all bars listed on the pop-up menu.
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Edit Bar

The controls on the edit bar allow you to edit the geometric properties of most entities. The controls change 
depending on your current activity, selection set, grid, and so on. When you select a single entity or when you 
draw an entity, the edit bar displays controls based on the entity type. When you click buttons for transform and 
trim operations, the edit bar displays corresponding controls.

The various text boxes on the edit bar display information such as coordinates, angles, line widths, bulge factors 
and other information appropriate to the entity that is selected. You can change any of these values by clicking in 
the appropriate text box to place an insertion point, then entering the new value on the keyboard, and pressing 
ENTER. If you want to change more than one value, use TAB to move the insertion point to the next text box to 
the right.

You can change the location of the edit bar by clicking on its edge and dragging it. The edit bar can also be 
docked alongside another bar by simply dragging it there, though the edit bar may not fully appear if space is 
limited.

You can specify whether the edit bar is hidden or displayed by right-clicking any bar, and clicking Edit on the pop-
up menu. If Edit is checked, it is displayed. If it is hidden, some commands will not work. The same is true for all 
bars listed on the pop-up menu or in the Toolbars dialog box.

When the pointer changes to an Edit Bar pointer, AutoSketch requires you to enter information on the edit bar. For 
instance, when you click the Grid Edit button on the Standard toolbar, the grid edit controls appear and the pointer 
changes to an Edit Bar pointer. All actions performed in this mode must be performed on the edit bar. 
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Status Bar

The status bar has two principal components: the message area and the dial. The message area occupies the left 
end of the status bar and displays prompts and other messages. The message area provides step-by-step 
instructions during most procedures.

You can specify the information displayed in the message area by right-clicking the status bar then clicking 
Properties on the pop-up menu that appears.

The dial occupies the right end of the status bar. The coordinates on the left display the absolute location of the 
point (its position in relation to the drawing origin) and the coordinates on the right display the relative location of 
the point (its position in relation to the last point entered). You can specify whether AutoSketch displays 
coordinates as XY, polar, or isometric coordinates.

To change the type of coordinates displayed, right-click the status bar, then click Properties on the pop-up menu. 
Click the Coordinate Display page tab, then click one of the Coordinate System buttons. If you want AutoSketch to 
automatically switch between coordinate systems, check the Automatically Update to Match Grid and Ruler check 
box. You can also select whether absolute or relative coordinates are displayed checking their corresponding 
check boxes. 

You can specify whether the status bar is hidden or displayed by right-clicking any bar, and clicking Status on the 
pop-up menu. If Status is checked, it is displayed. If it is unchecked, it is hidden from view. The same is true for all 
bars listed on the pop-up menu. 
    Related Topics



Symbol Library Bar

The symbol library bar is one method by which you can select a symbol for placement in a drawing. Another way 
is to open the Symbol Explorer by clicking either a toolbar button or its equivalent choice on the Draw menu. Each 
button in the symbol library bar contains a small drawing of the symbol it represents. The number of buttons on 
the bar changes, depending on how many symbols are in that library. The symbol library bar can display up to 150 
symbols. 

If the symbol library bar is not visible when you begin drawing, simply right-click a toolbar and click Symbol Library 
on the pop-up menu that appears. For more information on hiding and displaying toolbars, Changing the Size and 
Location of a Toolbar. 

The options for changing the appearance and location of the symbol library bar are like those for other bars that 
contain buttons. They allow you to change the location, size, and shape of the symbol library bar, as well as 
whether it is hidden or displayed. You can also use the symbol library bar’s pop-up menu to change libraries. 
AutoSketch also allows you to convert and import AutoSketch 2.1 part files or other symbol libraries into 
AutoSketch Release 5 symbol libraries. To learn more about placing symbols, creating and editing symbol 
definitions, and converting part files, see Symbols.

Tip
You can also use the Current Symbol drop-down list box to place further instances of the current symbol, or 

to place other symbols from the current library.
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Pop-up Menus

Pop-up menus provide quick access to tools applicable to a specific situation or task. They appear beside the 
pointer when you right-click specific parts of the screen. These menus are context sensitivethat is, they contain 
choices that are applicable in the context of your current situation. A pop-up menu is available when the pointer is 
over:

The property bar, edit bar, or status bar
A toolbar
The symbol library bar
Any entity
The selection set
The about point

    Related Topics



ToolTips and Pop-up Windows

ToolTips provide brief information about the name or nature of toolbar buttons. AutoSketch displays a ToolTip next 
to a button if you place the pointer over the button and pause a moment. Additional information is shown on the 
status bar. You can hide ToolTips from view by unchecking the Show ToolTips check box in the Toolbars dialog 
box. To display the Toolbars dialog box, click Toolbars on the View menu. 

A pop-up window is a form of online Help that appears when you click the Context Sensitive Help button on the 
Standard toolbar, then click a button, control, or an area of a dialog box for which you need an explanation. The 
pop-up window displays a sentence or short paragraph describing the item clicked.
    Related Topics



Entering & Modifying Points

A point is a specific location in a drawing. Almost every activity in AutoSketch requires you to enter points. To draw 
a line, for example, you enter a startpoint and an endpoint. To move an entity, you must enter a “from” point and a 
“to” point. To stretch or resize the selection set, you must click a handle and drag it to a new point. This topic 
describes all of the ways to enter a point in AutoSketch.

Entering a point is a matter of entering its coordinates. If you know the coordinates, you can enter the point from 
the keyboard. If you do not know the coordinates, but know the location of the point in relation to the reference 
grid or to another entity, you can click near the location and have AutoSketch enter the coordinates for you.

In all, there are fourteen ways to enter a point in AutoSketch twelve using the mouse and two using the 
keyboard. These correspond with the fourteen snap modes you can choose by clicking their buttons on the All-In-
One toolbar, or by typing the letter shown on the button.

There are also four automatic modifications you can have AutoSketch make to the point you enter. These “lock 
modifiers” force the point you enter into horizontal, vertical, orthogonal, or “normal” alignment with the last point. You 
can choose a lock modifier at any time in the drawing or editing process by clicking its button on the All-In-One 
toolbar or by typing the letter shown on the button. 

Snap and Lock commands are also located on their own toolbars, which contain the same commands as the 
toolsets but can be docked anywhere onscreen. You can make the Snap or Lock toolbar visible by right-clicking a 
bar, then clicking Toolbars on the pop-up menu that appears. Simply check Snap or Lock in the Toolbars dialog 
box, then click OK to make the toolbar visible onscreen.

When a snap mode or lock modifier is active, two letters appear beside the pointer indicating the current snap 
mode and lock modifier. The letter on the left indicates the current snap mode. The letter on the right indicates the 
current lock modifier. Each time you change snap modes or lock modifiers, AutoSketch updates the letters.

When snap modes involving the mouse are active and Automatic Snap is active, a red dot appears, called the 
AutoPoint Indicator. If a lock modifier is active as well, a yellow dot refers to the intermediate snap point while the 
red dot, as constrained by the lock modifier, indicates the actual Automatic Snap point. For instance, if you draw a 
diagonal line from top to bottom, then activate Endpoint snap mode and the Y-axis lock modifier, the yellow 
AutoPoint Indicator identifies the endpoint nearest the pointer, and the red AutoPoint Indicator represents the 
potential snap point based on the current snap mode and lock modifier if you have the pointer near the start of the 
diagonal line.

If you don’t want the AutoPoint Indicator to appear, you can turn Automatic Snap off. All snap modes and lock 
modifiers will function as before, without giving a visual indication onscreen of the actual point until you click to 
enter it.



Each time you complete an action, AutoSketch returns to the default snap mode. You can change the default snap 
mode to any of three settings in the Drawing page of the Drawing Options dialog box. 
    Related Topics



To disable Automatic Snap

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Drawing page tab.

3 Uncheck the Automatic Snap check box. When this check box is checked, Automatic Snap is enabled.

4 Click OK.



To change the default snap mode

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Drawing page tab.

3 Click the mode you want from the Default Snap Mode drop-down list box, in the Coordinate Input section. The 
Use Last option specifies that the snap mode used most recently remains in effect when an action is complete.

4 Click OK.



Entering a Point Based on Pointer Position

Some points do not require precise placement. Basepoints for tree symbols, for example, are often positioned by 
sight as are those for text entities. The best snap mode for such points is “Snap off.” This snap mode allows 
you to enter points based solely on the position of the pointer onscreen.
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To enter a point based only on the position of the pointer

1 While in a drawing mode, type S to disable Snap modes, or click the Snap Off button on the All-In-One toolbar.

2 Click where you want to enter the point.

Important
Do not use snap off snap mode to enter precise locations, such as the midpoint or endpoint of an entity.



Entering a Point on the Reference Grid

Gridpoint snap mode allows you to enter points on the reference grid. As you move the pointer in the drawing, the 
AutoPoint Indicator identifies the nearest gridpoint.

The current settings for the reference grid have a direct impact on the usefulness of Gridpoint snap mode. If the 
snap interval is too fine, gridpoint mode is little better than snap off. If it is too coarse, gridpoint mode may prevent 
you from entering the point you need. For information on how to set up the reference grid, see Customizing the 
Grid.
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To enter a point on the reference grid

1 While in a drawing mode, type G to switch to Gridpoint snap mode, or click the Gridpoint button on the All-In-
One toolbar.

2 Click near where you want to enter the point.



Entering a Point Exactly on an Entity

The Nearest Point snap mode allows you to enter a point on a specific entity. It is especially useful in combination 
with lock modifiers. For example, to draw a line that extends vertically from the previous point and ends at a 
specific entity, you could combine Nearest Point snap mode with the Y-axis lock modifier. 
    Related Topics



To enter the nearest point on an entity

1 While in a drawing mode, type N to switch to Nearest snap mode, or click the Nearest button on the All-In-One 
toolbar.

2 Click the entity. The example below shows Nearest snap mode combined with the Y-axis lock modifier.



Entering the Midpoint of an Entity

Midpoint snap mode allows you to enter a point at the precise midpoint of a line, arc, polyline segment, or polygon 
segment. As you move the pointer over the drawing, the AutoPoint Indicator identifies the midpoint of any 
qualifying entities you pass over.

Note
Midpoint snap mode cannot be used to enter a point at the center of an arc or circle. You must use 

Centerpoint snap mode to accomplish this.
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To enter a point at the midpoint of an entity

1 While in a drawing mode, type M to switch to Midpoint snap mode, or click the Midpoint button on the All-In-
One toolbar.

2 Click the entity.



Entering a Point at a Symbol Basepoint

Basepoint snap mode allows you to enter a point at the basepoint of an existing symbol. As you move the pointer 
over the drawing, the AutoPoint Indicator identifies the basepoint of any symbol you pass over.
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To enter a point at the basepoint of an existing symbol

1 While in a drawing mode, type B to switch to Basepoint snap mode, or click the Basepoint button on the All-In-
One toolbar.

2 Click the symbol.



Entering the Endpoint of an Entity

Endpoint snap mode allows you to enter a point at the nearest endpoint on an existing line, arc, polyline segment, 
or polygon segment. As you move the pointer over the drawing, the AutoPoint Indicator identifies the nearest 
endpoint of any entity you pass over. Endpoint snap mode is handy for connecting one entity to the endpoint of 
another entity. Lines and arcs have two endpoints. Polylines and polygons have an endpoint for each segment.
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To enter the endpoint of a line, arc, polyline segment, or polygon segment

1 While in a drawing mode, type E to switch to Endpoint snap mode, or click the Endpoint button on the All-In-
One toolbar.

2 Click a line, arc, polygon segment, or polyline segment near the endpoint you want to enter.



Entering a Point Where Two Entities Intersect

Intersection snap mode allows you to enter a point at the intersection of two entities. These two entities can 
include arcs, lines, circles, polygon segments, or polyline segments. The intersection point of the two entities does 
not have to fall on either entity. If the infinite extension of either entity results in a valid intersection point, 
AutoSketch enters that point. As you move the pointer over the drawing after selecting the first entity, the 
AutoPoint Indicator identifies the nearest intersection point.

It is possible for arcs and circles to intersect at more than one point. If the entities intersect in more than one 
location, as in the case of intersecting of arcs, AutoSketch enters the intersection point nearest where you clicked.

Some entity pairs cannot be extended to intersect. This is the case with parallel lines, concentric arcs, certain arcs 
that do not intersect, and so on. You cannot enter a point using Intersection snap mode if the second entity you 
select cannot be extended to intersect with the first.
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To enter a point where two entities intersect

1 While in a drawing mode, type I to switch to Intersection snap mode, or click the Intersection button on the All-
In-One toolbar or on the Snaps toolbar.

2 Click the first line, arc, circle, polygon segment, or polyline segment.

3 Click the second line, arc, circle, polygon segment, or polyline segment.



Entering a Point That Creates a Perpendicular

Perpendicular snap mode allows you to enter a point that creates a line perpendicular to an existing line, polyline 
segment, or polygon segment. When used with an arc or circle, it allows you to create a line that extends radially 
outward or inward. Unlike Intersection snap mode, AutoSketch does not extend the reference entity. As you move 
the pointer over the drawing, the AutoPoint Indicator identifies the nearest perpendicular point of any entity you 
pass over.
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To enter a point that creates a line perpendicular to an existing entity

1 Enter the startpoint of a line or poly-entity.

2 Type P to switch to Perpendicular snap mode, or click the Perpendicular button on the All-In-One toolbar.

3 Click the line, arc, polygon segment, or polyline segment.



Entering the Center of an Arc or Circle

Centerpoint snap mode allows you to enter a point at the center of an arc or circle. As you move the pointer over 
the drawing, the AutoPoint Indicator identifies the centerpoint of any arc or circle you pass over.
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To enter a point at the center of an arc or circle

1 While in a drawing mode, type C to switch to Centerpoint snap mode, or click the Centerpoint button on the All-
In-One toolbar.

2 Click the arc or circle.



Entering a Point to Create a Tangent

Tangent snap mode makes it easy to enter a point that creates a line tangent to an existing arc or circle. As you 
move the pointer over the drawing, the AutoPoint Indicator identifies the nearest point tangent to the original point.
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To enter a point that creates a line tangent to an arc or circle

1 While in a drawing mode, type T to switch to Tangent snap mode, or click the Tangent button on the All-In-One 
toolbar.

2 Click the arc or circle. Because there are two tangent points, you must click near the tangent point you want to 
use.



Entering a Quadrant Point on an Arc or Circle

Quadrant snap mode allows you to enter a point that coincides with a quadrant snap point on an arc or circle. As 
you move the pointer over arc or circle, the AutoPoint Indicator identifies the nearest quadrant point. Normally, 
there are four such points, however, you can specify up to 72 evenly spaced snap points.
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To enter a point at a quadrant point on a circle or arc

1 While in a drawing mode, type Q to switch to Quadrant snap mode, or click the Quadrant button on the All-In-
One toolbar.

2 Click the arc or circle.



To change the number of quadrant snap points

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog bog appears.

2 Click the Drawing page tab.

3 In the Coordinate Input section, click a number in the Quadrant Snap drop-down list box to indicate how many 
snap points you want to use.

4 Click OK.



Entering a Point from the Keyboard

There are two snap modes that allow you to enter points from the keyboard. These correspond with the two types 
of coordinates you can use absolute and relative. Entering a point from the keyboard is useful when you know 
the coordinates of a point, either in relation to the last point or to the drawing, grid, or page origin.

When you type A to enable Absolute snap mode, or R to enable Relative snap mode, the Enter 2D Coordinates 
dialog box appears. This dialog box displays text boxes for entering coordinates. The first coordinate is entered in the 
top control, and the second coordinate in the bottom control. When you finish entering the first coordinate, press TAB 
to move the insertion point to the other control. When you finish entering both coordinates, press ENTER or click OK, 
then repeat the procedure to continue entering points.

The Last Coordinate area of the dialog box displays the location of the last point you entered. The Enter 2D 
Coordinates dialog box also features buttons that allow you to specify absolute or relative coordinates by clicking 
the corresponding button. There is also a row of buttons which allow you to choose from Actual (World) XY, Actual 
(World) Polar, Grid XY, Grid Polar, Isometric Top (XY), Isometric Left (XZ), Isometric Right (YZ), and Paper Space 
(Output) XY (for more information, see Coordinates) coordinate systems. The row of buttons across the bottom of 
the dialog box allows you to switch to other snap modes.

The Enter 2D Coordinates dialog box remains onscreen until you click Cancel, press ESC, or select a different 
snap mode from the row of buttons along the bottom of the dialog box or from the snap modes toolset on the All-
In-One toolbar.

You can switch to a keyboard snap mode at any time by clicking the corresponding button on the All-In-One 
toolbar or by typing the letter that appears on the button. For a general discussion of coordinates, see 
Coordinates. Here are some important things to remember as you enter coordinates from the keyboard:

Coordinates entered without units of measurement are assumed to be expressed in the default units of 
measurement for lengths or angles.

Units can be mixed. Both the following, for example, are valid coordinate pairs:

8-1/2cm,1.66305”
2’6-3/4”,12.6m

Spaces are optional in coordinate input. They are not allowed inside a number. All of the following, for 
example, have the same effect when entered in the dialog box.

5.75 in
5.75in
5.75”

You must separate the whole and fractional parts of a mixed number with a hyphen.
You can use a numeric expression for coordinate input if it is preceded by an equal sign (=). A numeric 

expression is always interpreted using the default units of measurement, so it cannot include units of measurement. 
For information on how to enter a numeric expression, see Using Numeric Expressions.
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To enter a point from the keyboard using absolute coordinates

1 While in a drawing mode, type A to switch to absolute snap mode. The Enter 2D Coordinates dialog box 
appears.

2 Enter the absolute x-coordinate (X) in the X text box and press TAB.

3 Enter the absolute y-coordinate (Y) in the Y text box and click OK.



To enter a point from the keyboard using absolute isometric coordinates

1 While in a drawing mode, type A to switch to absolute snap mode. The Enter 2D Coordinates dialog box 
appears.

2 Click one of the Isometric coordinate buttons (top, left, or right).

3 Enter the first coordinate in the text box and press TAB.

4 Enter the second coordinate in the text box and click OK.



To enter a point from the keyboard using absolute polar coordinates

1 While in a drawing mode, type A to switch to absolute snap mode. The Enter 2D Coordinates dialog box 
appears.

2 Click the Polar coordinate button.

3 Enter the distance of the point in the R text box and press TAB.

4 Enter the angle of the point in the Angle text box and click OK.



To enter a point from the keyboard using relative coordinates

1 While in a drawing mode, type R to switch to relative snap mode.

2 Enter the relative x-coordinate in the X text box and press TAB.

3 Enter the relative y-coordinate in the Y text box and click OK.



To enter a point using relative isometric coordinates

1 While in a drawing mode, type R to switch to relative snap mode. The Enter 2D Coordinates dialog box 
appears.

2 Click one of the Isometric coordinate buttons (top, left, or right).

3 Enter the first relative coordinate in the text box and press TAB.

4 Enter the second relative coordinate in the text box and click OK.



To enter a point using relative polar coordinates

1 While in a drawing mode, type R to switch to relative snap mode. The Enter 2D Coordinates dialog box 
appears.

2 Click the Polar coordinate button.

3 Enter the relative distance of the point in the R text box and press TAB.

4 Enter the relative angle of the point in the Angle text box and click OK.



To change to the advanced Enter 2D Coordinates dialog box

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the toolbar. The Drawing 
Options dialog box appears.

2 Click the Drawing page tab.

3 Check the Advanced Input Dialog check box. When this check box is unchecked, AutoSketch defaults to the 
Standard Enter 2D Coordinates dialog box.

4 Click OK.



Using Lock Modifiers

Lock modifiers allow you to enter points that are aligned with the last point. You can lock a point into horizontal (x-
axis), vertical (y-axis), orthogonal (both), or “normal” alignment. In normal alignment, the new point is 
perpendicular to the last two points. You can apply a lock modifier at any time by clicking the corresponding button 
in the All-In-One toolbar or by typing the letter that appears on the button. The X-axis and Y-axis lock modifiers 
must be activated before each point. However, the Orthogonal and Normal lock modifiers remain active until you 
type U on the keyboard.

Note
X-axis, Y-axis, and Orthogonal lock modifiers reference grid lines

as the grid is rotated so too are the reference lines for the lock modifiers. For more information, see Setting Up the 
Grid.
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To enter a point aligned horizontally with the last point

1 While in a drawing mode, type X to apply the X-axis lock modifier, or click the X-axis lock modifier button on 
the All-In-One toolbar.

2 Enter the point using any snap mode.



To enter a point aligned vertically with the last point

1 While in a drawing mode, type Y to apply the Y-axis lock modifier, or click the Y-axis lock modifier button on the 
All-In-One toolbar.

2 Enter the point using any snap mode.



To enter a point aligned either horizontally or vertically with the last point

1 While in a drawing mode, type O to apply the “Orthogonal” lock modifier, or click the Orthogonal lock modifier 
button on the All-In-One toolbar.

2 Enter the point using any snap mode.



To enter a point aligned “normally” with the last two points

1 While in a drawing mode, type L to apply the normal lock modifier, or click the Normal lock modifier button on 
the All-In-One toolbar.

2 Enter the point using any snap mode.



To disable lock modification
While in a drawing mode, type U to switch to unlock mode, or click the Unlock modifier button on the All-In-

One toolbar.



Changing the Last Point

A Working snap point allows you to redefine the last point entered. For instance, if you want to place a door 1’ 
from the corner, or a bolt hole 7 mm from the edge of a metal plate, you can enter a Working point, then enter the 
next point. You can use a Working snap point anytime AutoSketch prompts you to enter a point. 

Some operations, such as those that use the normal lock modifier, are based on two last points rather than one. In 
these cases, you can set the last point twice to specify both points.
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To enter a point based on a Working point

1 While in a drawing mode, type W or click the Set Last (Working) Point button on the All-In-One toolbar to 
specify that the next point is a Working point.

2 Enter the working point(s) using any combination of snap modes and lock modifiers.



Modifying a Point

Sometimes it becomes necessary to move one of the points you’ve used to place a line, arc, or symbol. By using 
the controls in the Change Coordinates dialog box, you can move a line’s startpoint or endpoint, or the centerpoint 
of an arc, circle, marker, and so on.

The Change Coordinate dialog box has controls that allow you to enter your new point in relative or absolute 
modes, using any coordinate system. There are also buttons that allow you to click the new X and/or Y coordinate 
of a point. You can access the Change Coordinate dialog box by right-clicking a coordinate text box on the edit 
bar, then clicking Change Coordinate on the pop-up menu that appears.
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To change the coordinates of an existing point using the mouse

1 Select an entity such as a line in the drawing.

2 Place the insertion point in the appropriate Coordinate text box on the Edit bar, then right-click. A pop-up menu 
appears.

3 Click Change X, Change Y, or Change XY.

4 Click a new point.



To change the coordinates of an existing point using the keyboard

1 Select an entity such as a line in the drawing.

2 Place the insertion point in the appropriate Coordinate text box on the Edit bar, then right-click. A pop-up menu 
appears.

3 Click Change Coordinate. The Change Coordinate dialog box appears.

4 (optional) Click either the Absolute Input or Relative Input button at the top of the dialog box.

5 (optional) Click a new coordinate system from the Coordinate System toolbar.

6 Enter new locations in the X and/or Y text boxes, then click OK.



Entering Lengths & Angles

One of the advantages of drawing with AutoSketch is that it allows you to work with the drawing in its actual size. 
You can, for example, specify that a line is eight miles or eight millimeters long. This topic describes the methods 
you can use to specify exact measurements in AutoSketch.

When you enter a length, or angle measurement, you can also enter a unit label. If you do not enter a specific unit 
label, AutoSketch defaults to the current units of measurement.
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Entering Lengths

Values that represent length include distances, coordinates, text heights and so on. To enter a length on the 
keyboard, simply enter the length value followed by any of these units of measurement:

Note: # represents a whole, decimal, or exponential number (e.g., 3, 4.123, 5e20).

You can enter a length on the edit bar using either the keyboard or the mouse. Entering a length with the mouse is 
handy when you want to match the length of a specific entity in the drawing. You can enter a length with the 
mouse by entering two points or by clicking on an entity in the drawing.
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To enter a length on the edit bar by entering two points

1 Select an entity, such as a line, in your drawing.

2 Place the insertion point in the length (or appropriate) text box and press CTRL+ENTER or right-click in the 
text box clicking Change Length from the pop-up menu.

3 Enter a point in the drawing using any of the snap or keyboard snap modes. A rubber-band line appears from 
this point.

4 Enter a second point.



To enter a length on the edit bar by clicking on an entity

1 Select an entity, such as a line, in your drawing.

2 Place the insertion point in the length (or appropriate) text box and press CTRL+ENTER or right-click in the 
text box clicking Change Length from the pop-up menu. 

3 Press and hold SHIFT.

4 Click an entity in the drawing. A length associated with the type of entity you clicked on is entered on the edit 
bar:



Entering Angles

AutoSketch recognizes three types of angles: standard angles, compass angles, and bearings. Standard angles 
measure rotation counterclockwise with respect to the x-axis. Compass angles measure rotation clockwise with 
respect to the y-axis.

Bearings are used by surveyors, geologists, and mapmakers. For a detailed discussion of bearings, see Compass 
Angles & Bearings.

Standard and compass angles use the same system of notation. To enter an angle using the keyboard, simply 
enter the angular value followed by any of the following angle notations:

Note: # represents a signed, whole, decimal, or exponential number (e.g., 3, 4.123, 5e20).

You can also enter angles using the mouse. Entering angles with the mouse is handy when you need entities to 
have the same orientation. You can enter an angle with the mouse by entering three points in the drawing, by 
entering two points in the drawing, or by clicking on an arc, line, polyline or polygon segment, text entity, marker, 
or symbol.

Symbols have angles associated with each base entity. The exact number of angles associated with a symbol 
varies with the individual symbol.
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To enter an angle on the edit bar based on three points

1 Select an entity in the drawing.

2 Place the insertion point in the Angle text box and press CTRL+ENTER or right-click in the text box clicking 
Change Angle from the pop-up menu. 

3 Enter the vertex (the center point) of the angle.

4 Enter a point that defines the beginning point of rotation. A rubber-band arc appears.

5 Enter the ending point of rotation.



To enter an angle on the edit bar based on two points

1 Select an entity in the drawing.

2 Place the insertion point in the Angle text box and press CTRL+ENTER or right-click in the text box clicking 
Change Angle from the pop-up menu.

3 Press and hold CTRL.

4 Enter the vertex of the angle. A rubber-band arc appears.

5 Enter a point to establish the angle.



To enter an angle based on a line, polyline or polygon segment

1 Select an entity in the drawing.

2 Place the insertion point in the Angle text box and press CTRL+ENTER or right-click in the text box clicking 
Change Angle from the pop-up menu.

3 Press and hold SHIFT.

4 Click an entity in the drawing that establishes the angle. An angle is entered based on entity type:



To enter an angle on the edit bar based on an arc

1 Select an entity in the drawing.

2 Place the insertion point in the Angle text box and press CTRL+ENTER or right-click in the text box clicking 
Change Angle from the pop-up menu.

3 Press and hold SHIFT.

4 Click an arc in the drawing that establishes the angle. An angle is entered based on the end of the arc that is 
closest to where you clicked.



To enter an angle on the edit bar based on a marker or text entity

1 Select an entity in the drawing.

2 Place the insertion point in the Angle text box and press CTRL+ENTER or right-click in the text box clicking 
Change Angle on the pop-up menu.

3 Press and hold SHIFT.

4 Click a marker or text entity in the drawing that establishes the angle. An angle is entered based on entity type.



To enter an angle on the edit bar based on a symbol

1 Select an entity in the drawing.

2 Place the insertion point in the Angle text box and press CTRL+ENTER or right-click in the text box clicking 
Change Angle from the pop-up menu.

3 Press and hold SHIFT.

4 Click the portion of the symbol in the drawing that you want to use to establish the angle. An angle is entered 
based on the symbol entity and where you click.



Entering a Scalar Value

Values that represent scalars, such as scaling factors, bulges, and so on, are numbers entered with no units. 
AutoSketch displays scalar values on the edit bar and in dialog boxes. When entering a scalar value, in addition to 
entering a value or expression, you can enter a scalar as a ratio of two lengths (the second length over the first). 

You can change a scalar value on the edit bar using either the keyboard or the mouse. 
    Related Topics



To enter a scalar value on the edit bar using the mouse

1 Select an entity, such as a symbol, in the drawing.

2 Place the insertion point in the Scalar text box and press CTRL+ENTER or right-click in the text box and click 
Change Value from the pop-up menu. The Change Values dialog box appears

3 Enter two lengths using any method of entering lengths previously discussed.



To enter a scalar value using the keyboard
Select the existing value from the edit bar, enter the new one, and press ENTER.



Controlling Views

AutoSketch provides many options for looking at your drawing onscreen. You can display several windows, each 
containing the same or different drawings. Each window can display one, two, or four panes at a time. Each pane 
can contain a different view of the drawing. This gives you the flexibility to see all of the areas of a drawing that 
you need at any given time, from highly magnified detail views to broad overviews of the entire drawing.

In addition, AutoSketch provides a number of commands designed to let you choose the exact view you want for 
any window or pane. You can magnify the drawing by zooming in or reduce the view of the drawing by zooming 
out. You can also scroll the view in any direction. AutoSketch offers a number of preset views designed to quickly 
give you the views you use the most. If you find that you need quick access to other areas of your drawing, you 
can save and recall your own views.

Using the View Options dialog box, you can customize the AutoSketch drawing window to fit your needs, from 
changing the screen, reference grid, and drawing page, to creating custom views and defining entity visibility. For 
more information, see Customizing AutoSketch.

View commands can be accessed from the View menu or the View toolset on the All-In-One toolbar. You can also 
activate the View toolbar (which contains the same commands but can be docked anywhere onscreen) by right-
clicking a bar, then clicking Toolbars on the pop-up menu that appears. Simply check View in the Toolbars dialog 
box, then click OK to make the View toolbar visible onscreen.
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Viewing Several Areas at Once

To work on different parts of a drawing at the same time, you can open additional windows or split a window into 
several panes. Both methods create independent views that you can draw or edit between. You split a window by 
dragging the split bars or by clicking Split on the drawing window Control menu. The UnSplit command restores 
the active window to a single pane. When you edit the drawing in one pane, the other views also display the 
changes. When the drawing window is split into multiple panes, the active pane indicator marks the active pane.

When you open a new drawing window, it becomes the active window. You can change how drawing windows are 
arranged by using the commands on the Window menu.
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To split the drawing window into multiple panes
Click the Split command on the drawing window Control menu, or drag either the horizontal split bar down 

from the top of the window or the vertical split bar to the right from the left side of the window, or double-click either 
split bar.



To return the drawing window to a single pane
Click the UnSplit command on the drawing window Control menu, or drag either the horizontal or vertical 

split bar back to its original location at the top and left sides of the display, respectively, or double-click either split bar.



To open another window for the active drawing
On the Window menu, click New Window, or click the New Window button on the Standard toolbar.



To change the active pane
Click the pane indicator or press F6. F6 makes the next pane active. SHIFT+F6 makes the previous pane 

active.



Zooming In and Out

You can get a closer look at an area or see a larger portion of the drawing by zooming in or out. You can use the 
mouse or the keyboard to change the view magnification. The mouse offers more control over the view, while the 
keyboard allows you to quickly change the magnification by a preset amount.
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To zoom in

1 On the View menu, click Zoom In, or click the Zoom In button on the All-In-One toolbar.

2 Click and drag from one corner of the region you want to enlarge, to the opposite corner.



To zoom in by a preset factor
Instead of drawing a region after clicking Zoom In, simply click in the drawing window. AutoSketch enlarges 

the view around that point by the zoom factor.

OR
Press CTRL+plus (+) or SHIFT+plus (+) on the numeric keypad, with NUM LOCK turned off. CTRL+plus 

enlarges the view by the zoom factor. SHIFT+plus enlarges the view around the current selection set by the zoom 
factor.



To zoom out

1 On the View menu, click Zoom Out, or click the Zoom Out button on the All-In-One toolbar.

2 Click and drag to indicate the area the current view should occupy after the zoom. 



To zoom out by a preset factor
Instead of drawing a region after clicking Zoom Out, simply click in the drawing window. AutoSketch reduces 

the view around that point by the zoom factor.

OR
Press CTRL+minus (-) or SHIFT+minus (-) on the numeric keypad, with NUM LOCK turned off. 

CTRL+minus reduces the view by the zoom factor. SHIFT+minus reduces the view around the current selection set 
by the zoom factor.



Using Preset Views

AutoSketch provides several common views. These preset views can be a useful starting point before zooming in 
on a specific region. The page view shows your drawing as it appears when printed. The extent view displays all 
entities in the drawing. The selection view shows the extent of the currently selected entities. For each of these 
preset views, AutoSketch provides a corresponding command on the window Control menu that sets the view for 
all panes of a split window.
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To view the page
On the View menu, click Page, or click the View Page button on the All-In-One toolbar. To view the page in 

all panes of a single window, on the drawing window Control menu, click View All, Page.



To view all entities in a drawing
On the View menu, click Extent, or click the View Extent button on the All-In-One toolbar. To view all entities 

in all panes of a single window, on the drawing window Control menu, click View All, Extent.



To view the selection set

1 Select an entity or group of entities.

2 On the View menu, click Selection, or click the View Selection button on the All-In-One toolbar. To view all 
entities in all panes of a single window, on the drawing window Control menu, click View All, Selection.

Note
You can also view the selection set by clicking View Selection on the pop-up menu for the selection set. To 

display the menu, position the pointer inside the selection handles, but not on the about point, of a selection set, and 
right-click.



Panning Across the Drawing

You can move the drawing window to see portions of the drawing which are outside the current view by panning. 
There are two ways to pan the view: you can click and drag to make the view move the distance and angle of the 
two points you enter, or you can click once to move that location to the center of the view.
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To pan in any direction

1 On the View menu, click Pan, or click the Pan button on the All-In-One toolbar.

2 Click and drag to establish a startpoint and direction. A rubber-band line appears, moving with the pointer.

3 Release the mouse button. The drawing window moves the distance and direction you specified.



To move the center of your view

1 On the View menu, click Pan, or click the Pan button on the All-In-One toolbar.

2 Click the point you want to appear in the center of the view.



Using the Intellimouse

The Intellimouse is a two-button mouse with a small wheel between the buttons. This wheel can be rotated by 
discrete values, which are controlled by a series of detents. You can use the wheel to zoom and pan your drawing, 
without using any AutoSketch commands. You can also set the IntelliMouse zoom factor to fit your needs. By 
default, the zoom factor is set at 20%, with each increment in the wheel rotation changing the zoom level by 20%. 
For more information on zoom, see Zooming In and Out.
    Related Topics



To zoom in or out using the IntelliMouse
Rotate the mouse wheel forward to zoom in, backward to zoom out.



To pan using the IntelliMouse
Hold down the wheel button and drag the mouse.



To set the IntelliMouse zoom factor

1 On the View menu, click Options. The View Options dialog box appears.

2 Click the Current page tab, and enter a new zoom factor in the IntelliMouse Zoom Factor text box in the View 
Changes Section.

3        Click OK



Returning to a Previous View

You can return to any of the most recent views. This is useful when you have not saved the view you need as a 
custom view, but it was recently displayed. You don’t have to wait until a view is completely drawn before issuing 
another command to return to a previous view. 
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To return to a previous view
On the View menu, click Last, or click the Last View button on the All-In-One toolbar.



To return to a subsequent view
On the View menu, click Next, or click the Next View button on the All-In-One toolbar.

Important
You must use the Last View tool before you can use the Next View tool. The Next View tool has an effect 

only when a view other than the most recently created one is displayed in the drawing window.



Saving and Recalling Views

Custom views make it easy to return to parts of a drawing you display often. You create a custom view by 
assigning a name either to the view in the active pane or to one defined by a marquee. You can save 16 custom 
views per drawing. To change the number of custom views saved, use the Current page tab on the View Options 
dialog box. 
    Related Topics



To save the view displayed in a pane

1 On the View menu, click Save, or click the View Save button on the All-In-One toolbar. The View Save dialog 
box appears.

2 Enter a name for the view in the As Custom View text box.

3 Click OK.



To save the view defined by a marquee

1 On the Edit menu, click Select, Marquee, or click the Marquee button on the All-In-One toolbar.

2 Draw a marquee around the view area by clicking and dragging from one corner of the area to the opposite 
corner.

3 On the View menu, click Save, or click the View Save button on the All-In-One toolbar. The View Save dialog 
box appears. 

4 Enter a name for the view in the As Custom View text box.

5 Click OK.



To recall a custom view

1 On the View menu, click Recall, or click the View Recall button on the All-In-One toolbar. The View Recall 
dialog box appears.

2 Click a saved view from the list. A preview of the selected view appears.

3 Click OK.



Redrawing a Pane or Window

The drawing window sometimes leaves remnants from a drawing or editing procedure. You redraw to clean up the 
display of the drawing. A complex redraw can be a lengthy process, but it doesn’t have to interrupt your work. The 
background redraw feature in AutoSketch allows you to perform most operations during redraw. Simply continue 
working normally and AutoSketch redraws during idle moments in your work.
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To redraw the drawing
On the View menu, click Redraw, or click the Redraw button on the All-In-One toolbar. To redraw all panes of 

a single window, on the drawing window Control menu, click View All, Redraw.



Arranging Drawing Windows

AutoSketch supplies three commands to quickly rearrange and organize drawing windows. Arranging the icons 
causes the icons for all minimized drawings to return to the bottom left of the workspace. Horizontal or vertical 
tiling causes the drawing windows to resize so they are as large as possible without overlapping and minimized 
drawing windows return to the lower left of the workspace. Cascading the drawing windows causes them to 
redraw at a uniform size, arranged so they overlap each other revealing the title bars, and minimized drawing 
windows return to the lower left of the workspace.

You can use the Window menu list to activate a different drawing window that is obscured by other drawing 
windows. Clicking a drawing window on the Window menu makes it the active drawing window in AutoSketch.
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To arrange minimized drawing windows
On the Window menu, click Arrange Icons, or click the Arrange Icons button on the Standard toolbar.



To show all drawing windows without overlapping
On the Window menu, click Tile Horizontally or Tile Vertically, or click the Tile Horizontally or the Tile Vertical 

button on the Standard toolbar.



To overlap all drawing windows so each title bar is visible
On the Window menu, click Cascade, or click the Cascade button on the Standard toolbar.



To switch between drawing windows
On the Window menu, click the drawing you want to make active from the list of open drawings at the 

bottom of the Window menu.

OR
Press CTRL+TAB.



Opening and Saving Drawings

A drawing file contains all the information necessary to recreate a drawing. Before you can work on a drawing, you 
must open it that is, display it on your screen. Once the drawing file is open, you can modify, print, save, and view 
it.

You can have more than one drawing file open at a time. The exact number of files that can be open depends on the 
amount of memory in your system and the complexity of the drawing files. When you open a drawing file, AutoSketch 
displays the drawing in a new window on top of any open drawing windows.

To preserve a drawing file for later use, you must save it to a file. If you have already saved the drawing 
previously, you can save any changes using the File menu’s Save command. You can save a new drawing, save 
the drawing under a new name, or save the drawing using a different file type using the File menu’s Save As 
command.
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Using Wildcards to Specify Files

To include a group of files that have different names, you can use wildcard characters to define the group. A 
wildcard matches multiple file names or extensions. Simply include the wildcard in the file name. There are two 
wildcards:

The asterisk (*) matches any remaining characters in the file name or extension.
The question mark (?) matches any single character in the file name or extension.

The default file specification is *.SKF. This includes any file name with an .SKF extension in the current folder. A 
list of all SKF files in the current folder appears, regardless of the number of characters in the name. To display all 
SKF files whose file names begin with “PRO207,” you could use the following file specification:

PRO207*.SKF

Possible matches to this file specification could be:

PRO2071.SKF, PRO2072.SKF, PRO20710.SKF, and PRO207XY.SKF
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Opening a Drawing File

You can quickly open any of the last four or eight drawings you have worked on (you specify four or eight in the 
Drawing Options dialog box) because their names appear at the bottom of the File menu. You can open any other 
drawing using the File menu’s Open command.

You can open a file as read-only to protect you from accidentally making changes to an important drawing. If you 
check the Open as Read-Only check box and then try to save changes, AutoSketch displays a message that the 
file is read-only. If you need to modify the original, open it without using the read-only feature.
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To open a recently opened, saved, or closed drawing
On the File menu, click the name of the drawing you want to open. The last few files you opened are listed 

near the bottom of the File menu.



To open an existing drawing

1 On the File menu, click Open, or click the Open File button on the Standard toolbar. The Open Drawing File 
dialog box appears.

2 Click the name of drawing you want to open in the Filename list box, or enter the name of the drawing in the 
Filename text box. If you do not see the name of the file you want, click a new drive, folder, or type of file.

3 Click Open.



To open a drawing as read-only

1 On the File menu, click Open. The Open Drawing File dialog list appears.

2 Click the name of drawing you want to open in the Filename list box, or enter the name of the drawing in the 
Filename text box. If you do not see the name of the file you want, click a new drive, folder, or type of file.

3 Check the Open as Read Only check box.

4 Click Open.

Note
Preview only works with certain file types and in some instances only with newer versions of those file types. 



Combining Two Drawings

You can add the contents of another drawing to the current drawing by merging. If the drawing you want to merge 
was created in a program other than AutoSketch, you must first import the drawing and save it in AutoSketch 
(SKF) format. For information on importing drawing files, see Importing and Exporting.

When you merge two files, AutoSketch ignores duplicated layer names, field names, and symbol definitions. For 
example, if the current drawing and the drawing you merge both have layers named “Walls” but the settings for 
that layer are not the same, AutoSketch uses the settings for the current drawing.
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To merge another drawing with the current drawing

1 On the File menu, click Merge, or click the Merge button on the Standard toolbar. The Merge Drawing File 
dialog box appears.

2 Click the name of drawing you want to open in the Filename list box, or enter the name of the drawing in the 
Filename text box. If you do not see the name of the file you want, click a new drive, folder, or type of file.

3 Click Open. The Merge dialog box appears.

4 Enter the origin, scale, and rotation for the drawing being merged and click OK. 



Saving a Drawing

When you open a drawing, AutoSketch copies the drawing file to your computer’s memory. As you work, you are 
modifying the copy stored in memory. To store your latest work on disk, you should save your work periodically. A 
good rule of thumb is to save every 15 to 20 minutes, or after you’ve completed any work you wouldn’t want to 
redo.

Before you save a drawing for the first time, it’s a good idea to assign project information about your drawing. 
Project information is descriptive text such as the title of the drawing, your name, and the revision number. Storing 
project information with your drawings can help you remember important details about a drawing file later.

When you click the Save command, AutoSketch saves the active drawing using the name and location you last 
gave it. You can create more than one version of a drawing or save copies on another disk for safekeeping. You 
can save each version under a different name, or you can save them under the same name in different folders or 
on different drives.

The File page of the Drawing Options dialog box lets you specify whether AutoSketch should create backup files 
when you save a file, whether it should automatically save the current file at a time interval set by you, and 
whether you want the File New dialog box or the Start Up dialog box    to appear when you click New on the File 
menu, or start AutoSketch. To reach these controls, click Drawing Options on the Tools menu, then click the File 
page tab.

If you want to save changes to a read-only drawing, you must save the drawing with a new name.
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To save an existing drawing
On the File menu, click Save, or click the Save File button on the Standard toolbar.



To save a new, unnamed drawing

1 On the File menu, click Save or Save As. The Save Drawing File dialog box appears.

2 In the Filename text box, enter a filename. AutoSketch automatically adds a SKF extension unless you specify 
another extension.

3 Click Save.



To save a drawing to a different name, format, drive, or folder

1 On the File menu, click Save As. The Save Drawing File dialog box appears.

2 If you want to save the drawing under another name, enter a new filename in the Filename text box.

3 If you want to save the drawing to a different drive or folder, click a different drive and folder or enter the 
complete path in the Filename text box.

4 If you want to save the drawing in another format, click a new format in the Save As Type drop-down list box.

5 Click Save.



To enter project information for the current drawing

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the File page tab.

3 Enter the appropriate text in text boxes in the Summary Information section.

4 Click OK.



Closing a Drawing

When you finish working with a drawing file, close it to remove the window from the screen and to free up your 
computer’s memory. When you are done working in AutoSketch, close all your drawing files and exit the program.
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To close a file
On the File menu, click Close, or click the Close button on the Standard toolbar. If you have unsaved 

changes in your drawing, the program prompts you to save them before it closes the file.



To close all open files
On the Window menu, click Close All, or click the Close All button on the Standard toolbar. If any open 

drawings have unsaved changes, AutoSketch prompts you to save them before it closes their files.



To close all open files and exit AutoSketch
On the File menu, click Exit. If any open drawings have unsaved changes, AutoSketch prompts you to save 

them before it closes their files.



Undoing, Redoing, & Repeating Actions

AutoSketch allows you the flexibility to return to earlier stages of the drawing process by undoing the last action, 
or series of actions, performed. This makes the drawing process more efficient by making it easier to correct 
mistakes. Likewise, if you mistakenly undo an action, the Redo command allows you to reinstate the action, or 
series of actions, most recently undone.

Similarly, if you need perform an editing function repeatedly, AutoSketch’s Repeat Edit function allows to perform 
the same procedure quickly.
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Undoing Actions 

If you make a mistake while performing an editing operation or other action, you can use AutoSketch’s undo 
command to reverse the action, even undoing an entire sequence of actions at once. Clicking the arrow of the 
Undo button displays a drop-down list of previously performed actions. Simply move the pointer down the list until 
all of the actions you want to undo are highlighted, then click. The number of actions that can be undone is 
specified on the Drawing Page of the Drawing Options dialog box. The default setting is 16. When it’s impossible 
to undo an action, AutoSketch grays the Undo button.
    Related Topics



To reverse an action
On the Edit menu, click Undo Edit or click the Undo button on the Standard toolbar. AutoSketch restores the 

drawing to its state before you performed the last action.



To reverse multiple actions

1 Click the Undo drop-down arrow on the Standard toolbar. A list of edit actions appears. 

2 Move the pointer down the list until all of the actions you want to undo are highlighted, then click. AutoSketch 
reverses the actions.



Redoing Actions 

If you mistakenly undo an action, you can use the Redo command to restore the drawing. To reverse multiple 
undo actions simply click the Redo drop-down arrow and select how many actions to redo.
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To reverse an undo
Click the Redo button on the Standard toolbar. 



To reverse multiple undo actions

1 Click the Redo drop-down arrow on the Standard toolbar. A list of actions appears. 

2 Move the pointer down the list until all of the actions you want to redo are highlighted, then click. AutoSketch 
reverses the undo actions.



Repeating Commands

Sometimes you may need to perform the same edit or draw operation several times throughout the drawing. 
Instead of selecting the same commands each time, you can use AutoSketch’s Repeat Edit to access the 
command again. When there is no action to repeat, Repeat Edit is grayed out. 
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To repeat an editing command
On the Edit menu, click Repeat Edit, or press F3. 



To repeat a draw command
On the Edit menu, click Repeat Draw, or press F4.



Moving, Rotating, and Resizing Entities

Moving, rotating, and resizing are examples of transformations. You can transform an entity by selecting it and 
clicking a transformation tool, or by dragging the selection set handles.

Moving an entity repositions it in relation to other entities. You can save time by copying and moving entities rather 
than redrawing them from scratch. For example, if you were creating a flowchart, you could draw a single triangle, 
copy it, and move it wherever you need a triangle to represent a decision in the flow.

Rotating an entity changes its orientation. By default, you rotate an entity around its about point. However, 
AutoSketch allows you to rotate an entity about another point you enter. For example, you could rotate copies of a 
single chair about the center of a table to quickly draw a table and chairs. 

Resizing an entity makes it easy to reuse a component of your drawing. For example, if you were planning a 
landscaping project, you could draw one tree and enlarge or reduce copies to represent other trees.

In addition to performing the transformation on the selection set, there are two additional options. First, you can leave 
the original selection and transform a copy. Second, you can create a three-dimensional effect by extruding the 
selection set. Extrusion is a process where AutoSketch draws polygons that connect the original selection set to the 
transformed copy, creating the illusion of depth.
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Working With the About Point

When you select an entity or group of entities, a dot appears with the selection handles. This dot is the about point
that is the point about which AutoSketch rotates the selection set. The default location of the about point varies 

with the type of entity you select. AutoSketch places the about point for most entity types in the center of the 
selection. The about point for text, markers, and symbols is their basepoint. 

AutoSketch gives you the flexibility to move the about point to another location. For example, you can move the 
about point of a chair that faces a table to the center of the table. Rotating the chair, using the Leave Original 
option, creates another copy of the chair that is positioned facing the table. Repeating the transformation creates 
another copy of the chair, at the specified rotation angle around the table. This method is faster than adding 
additional instances of the chair symbol and then moving and rotating them individually.

If the selection set contains a single symbol, marker, or text string, the about point is located at the entity’s 
basepoint. In some instances, it might be easier to perform transformations on these entity types if their about 
point were in the center of the selection set. Center About Point allows you to move the about point to the exact 
center of the selection set.

If you have moved the about point of a selection set and need to return it to the default location, use Entity About 
Point. This moves the about point to the basepoint of a selected symbol, marker, or text string, the centerpoint of 
an arc or circle, or the center of a polygon. If the selection set contains multiple entities, the about point is placed 
in the center of the selection set.
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To change the location of the about point

1 Select the entity or group of entities, then right-click above the about point.

2 On the pop-up menu, click Move About Point.

3 Click the new about point location.



To center the about point of a selection set

1 Select the entity or group of entities, then right-click above the about point.

2 On the pop-up menu, click Center About Point.



To return the about point to its default location

1 Select the entity, then right-click above the about point.

2 On the pop-up menu, click Entity About Point.



Moving or Copying an Entity

You can move or copy one or more selected entities from their present location to a new location, or even to 
another open drawing file, without changing their orientation or size. When moving or copying entities between 
two drawing files, be sure to have both drawings displayed. For more information, see Arranging Drawing 
Windows. AutoSketch allows you to move entities by:

Dragging the selection set with the mouse.
Dragging the selection set with the mouse, right-clicking, and clicking a choice on a pop-up menu.
Entering a “from” point and a “to” point by clicking Transform, Translate on the Edit menu.
Cutting or copying the selection set to the Clipboard, and then pasting it back in the drawing at a point you 

enter.
Using the arrow keys to move the selection set one unit of the grid snap interval or line interval for each 

keystroke.

Sometimes, it is necessary to move entities to another location in your drawing. If you will be picking the new 
location visually, or you want the entities to snap to a point on the grid, dragging the selection set is probably the 
fastest method.

To enter two points that define how far to move the selection set, click Transform, Translate on the Edit menu. This 
is useful when you need to move the selection set a known distance and direction from its current location. 

Note
Before you can extrude a symbol, circle, arc, curve, or text entity, you must convert it to polylines or 

polygons. For more information, see Converting & Exploding Entity Types. .

You can move entities in your drawing or transfer them to another drawing by cutting, copying, and pasting them 
using the Clipboard. When pasting, you specify the location of the lower-left corner of the selection set. The 
information in the Clipboard remains in memory until you cut or copy again. This allows you to create multiple 
copies of entities by pasting additional copies at different locations.

You can use SHIFT and the arrow keys on the keyboard to quickly move the selection set in the direction of the 
arrow. This method is useful for making small corrections after dragging an entity with the mouse. For information 
on setting the snap interval, see Setting Up the Grid. 
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To move entities with the mouse

1 Select the entity or entities to move.

2 (optional) Press and hold CTRL to move a copy of the selection set and leave the original behind.

3 Using the left mouse button, drag anywhere inside the selection handles to move the selection set to another 
location, or drag the about point if you are extruding the selection set.

OR

1 Select the entity or entities to move.

2 Right-click and drag anywhere inside the selection handles to move the selection set to another location. 
When you release the right mouse button, a pop-up menu appears.

3 Click Move Here, Copy Here, or Extrude Here on the pop-up menu.



To move entities a distance and direction defined by two points

1 Select the entity or entities to move.

2 On the Edit menu, click Transform, Translate, or click the Translate button on the All-In-One toolbar.

3 (optional) Check the Copy or Move check box on the edit bar to move a copy of the selection set and leave the 
original.

4 (optional) Check both the Copy or Move and Extrusion Polygon check boxes on the edit bar to extrude the 
selection set as you move.

5 Enter the “from” point. This is the starting point used to calculate the translation.

6 Enter the “to” point that defines the relative distance and direction to move the entities.



To move entities using the Clipboard

1 Select the entity or entities to move.

2 On the Edit menu, click Cut, or click the Cut button on the Standard toolbar. AutoSketch removes the selection 
set from the drawing and places it on the Clipboard.

3 (optional) Open another drawing and click inside its window to make that drawing window active if you want to 
move the entities to another drawing.

4 On the Edit menu, click Paste, or click the Paste button on the Standard toolbar.

5 Enter the lower-left corner of the extent for the entities on the Clipboard.



To copy entities using the Clipboard

1 Select the entity or entities to copy.

2 On the Edit menu, click Copy, or click the Copy button on the Standard toolbar. AutoSketch places a copy of 
the selection set on the Clipboard.

3 (optional) Open another drawing and click inside its window to make that drawing window active if you want to 
copy the entities to another drawing.

4 On the Edit menu, click Paste, or click the Paste button on the Standard toolbar.

5 Enter the lower-left corner of the extent for the entities on the Clipboard.



To move entities using the keyboard

1 Select the entity or entities to move.

2 Press and hold SHIFT while pressing the arrow key that corresponds to the direction you want to move the 
selection set by the grid snap interval. Pressing HOME, END, PAGE UP, and PAGE DOWN moves the 
selection set by the grid line interval.



Rotating an Entity

Rotating an entity changes its orientation about a point. AutoSketch allows you to rotate entities by:
Dragging the rotation handle with the mouse.
Using the plus (+) and minus (-) keys on the numeric keypad, or F5 and SHIFT+F5 to rotate the selection set 

by the plus/minus rotation interval.
Using Transform, Rotate on the Edit menu to rotate the selection set a specified angle around a point you 

enter.
Using Transform, Align on the Edit menu to move and rotate the selection set based on points you enter.

Clicking on an entity selects it and causes the selection and rotation handle to appear. You can quickly change the 
orientation of a selection set by dragging its rotation handle. This rotates the entity around its about point. As it 
rotates, the entity is constrained by the angle intervals specified in the Plus/Minus Rotation text box in the Drawing 
Parameters section of the Drawing Options dialog box. The default setting is 45 degrees, allowing you to rotate 
the entity to any of eight angles. You can change the setting in the Drawing Options dialog box, or rotate 
unconstrained by pressing SHIFT while dragging the rotation handle.

You can also rotate a selection set from the keyboard. Pressing plus (+) or minus (-) on the numeric keypad 
rotates the selection set by the plus/minus rotation interval. The F5 and SHIFT+F5 keys duplicate the actions of 
the plus and minus keys respectively.

You can rotate the selection set around a point other than its about point. Rotate allows you to specify a rotation 
angle and enter a new rotation basepoint.

Align rotates and moves the selection set. Aligning is useful when you know the location and angle you want for a 
particular selection, but you don’t know the exact angle measurements and distance. When you align, you simply 
enter two points to define the current location and orientation of the selection set, and another two points that 
define the new location and angle.

Note
Some entities, such as raster images and OLE objects, cannot be rotated.
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To rotate the selection set by dragging the rotation handle

1 Select the entity or entities to rotate.

2 (optional) Place the pointer on the about point. Right-click, then click Move About Point from the pop-up menu, 
then specify a different about point for the rotation.

3 (optional) Hold CTRL to leave a copy of the original entities in their current location.

4 (optional) Hold down SHIFT to ignore the angle constraints.

5 Drag the rotation handle until the selected entities are in the correct position.



To rotate the selection set using the keyboard

1 Select the entity or entities to rotate.

2 Use the plus (+) and minus (-) keys on the numeric keypad, or the F5 and SHIFT+F5 keys to rotate the 
selection set.



To change the rotation angle interval

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Drawing page tab.

3 Enter a different setting in the Plus/Minus Rotation text box.



To rotate a selection set about a point you enter

1 Select the entity or entities to rotate.

2 On the Edit menu, click Transform, Rotate, or click the Rotate button on the All-In-One toolbar.

3 Enter a value in the Rotation Angle text box on the edit bar and press ENTER.

4 (optional) Check the Copy or Move check box on the edit bar to rotate a copy of the selection set and leave the 
original.

5 (optional) Check the Extrusion check box on the edit bar to extrude the selection set as you rotate.

6 Enter the rotation basepoint.



To align entities along a new axis

1 Select the entity or entities to align.

2 On the Edit menu, click Transform, Align, or click the Align button on the All-In-One toolbar.

3 (optional) Check the Copy or Move check box on the edit bar to align a copy of the selection set and leave the 
original.

4 (optional) Check both the Copy or Move and Extrusion check boxes on the edit bar to extrude the selection set 
as you align.

5 Enter the startpoint of the axis to define the current location and orientation of the selection.

6 Enter the endpoint of the axis

7 Enter the startpoint of the new axis to define the new location. 

8 Enter a point that defines the orientation of the new axis.



Rubber Stamping an Entity

Rubber Stamping allows you to place multiple copies of an entity, or entities, in a drawing. Using the current 
contents of the selection set, Rubber Stamp creates an exact duplicate of the selection set that can be placed in a 
drawing multiple times. You can place the copies visually or use any combination of snap modes or lock modifiers. 
For more information on using snap modes and lock modifiers, see Entering & Modifying Points. 
    Related Topics



To rubber stamp an entity by entering a single point

1 Select an entity or entities to copy. 

2 On the Edit menu, click Transform, Rubber Stamp, or click the Rubber Stamp button on the All-In-One toolbar, 
or right-click the entity, then click Rubber Stamp on the pop-up menu that appears. An outline of the entity 
appears and follows the pointer. 

3 (optional) Rotate the rubber stamped entity by pressing plus(+) or minus(-) on the numeric keypad, or F% or 
SHIFT+F5. 

4 Click to place copies of the entity. To stop placing copies, either right-click or press      ESC. The last copy 
placed is automatically selected.



To rubber stamp an entity while aligning it with two points

1 Select an entity or entities to copy. 

2 On the Edit menu, click Transform, Rubber Stamp, or click the Rubber Stamp button on the All-In-One toolbar, 
or right-click the entity, then click Rubber Stamp on the pop-up menu that appears. An outline of the entity 
appears and follows the pointer. 

3 Press CTRL and click a point in the drawing for the basepoint of the rubber stamped entity. 

4 Right-click or press ESC to stop placing copies. The last copy placed is automatically selected.



To rubber stamp an entity while scaling it and aligning it to points

1 Select the entity or entities to copy. 

2 On the Edit menu, click Transform, Rubber Stamp, or click the Rubber Stamp button on the All-In-One toolbar, 
or right-click the entity and click Rubber Stamp on the pop-up menu that appears. An outline of the entity 
appears and follows the pointer. 

3 Press SHIFT+CTRL and click a point in the drawing for the basepoint of the entity. A rubber-band outline 
appears and rotates and scales with the pointer. 

4 Continue pressing SHIFT+CTRL and click a second point. The copy is placed.

5 Right-click or press ESC to stop placing copies. The last copy placed is automatically selected.



Mirroring an Entity

AutoSketch provides two methods of creating a mirror image of the selection set. You can mirror by dragging one 
of the middle selection handles across the selection set, or you can use the Mirror tool. Either method can reduce 
your drawing time by half when you’re drawing something that is symmetrical. With mirroring, you need only 
create half of the symmetrical drawing and then use a mirroring procedure to create the other half.

If you need another copy of an existing entity in your drawing, pressing CTRL while mirroring an entity specifies 
that AutoSketch leaves the original entity behind and mirrors a copy of the selection set to the new location.

Note
Some entities, such as text and OLE objects, cannot be mirrored.

    Related Topics



To mirror entities using selection handles

1 Select the entity or entities to mirror.

2 (optional) Press and hold CTRL to mirror a copy of the selection set and leave the original.

3 Drag one of the side selection handles across the entity until the edit bar displays either “Scale X -1.00” or 
“Scale Y -1.00” and release the mouse button.



To mirror entities across an axis you specify

1 Select the entity or entities to mirror.

2 On the Edit menu, click Transform, Mirror, or click the Mirror button on the All-In-One toolbar.

3 (optional) Check the Copy or Move check box on the edit bar to mirror a copy of the selection set and leave 
the original.

4 (optional) Check both the Copy or Move and Extrusion check boxes on the edit bar to extrude the selection set 
as you mirror.

5 Enter the startpoint of the axis about which to perform the mirror transformation.

6 Enter the endpoint of the mirror axis.

Tip
Use Lock Modifiers to help define correct points. For more information on using Lock Modifiers, refer to 

Using Lock Modifiers. 



 

Scaling an Entity

Scaling resizes an entity by a scaling factor. Usually, you scale by resizing both the width and height 
proportionally. However, AutoSketch provides the flexibility to scale a selection set    by different amounts in each 
direction. AutoSketch allows you to scale any entity except arcs and circles. To scale an arc or circle, you must 
first convert it to a polyline or polygon. For information on converting entities, see Converting & Exploding Entity 
Types. 

Dragging one of the corner selection handles is a fast way to visually scale an entity. The x- and y- scale factors 
appear on the edit bar as you drag the handle. 

You can scale the selection set by a specified factor using Transform, Scale on the Edit menu. When you do this, 
you have the option of scaling the entities about a point you enter, or you can scale markers, text, and symbols 
about their respective basepoints.

If you need another copy of an existing entity in your drawing, pressing CTRL while scaling an entity specifies that 
AutoSketch leaves the original entity behind and scales a copy of the selection set to the new location.
    Related Topics



To scale an entity by dragging a selection handle

1 Select the entity or entities to scale.

2 (optional) Press and hold CTRL to scale a copy of the selection set and leave the original.

3 (optional) Press and hold SHIFT to unconstrain the x- and y- scale.

4 Drag one of the selection handles to scale the selection set.



To scale entities by a known factor

1 Select the entity or entities to scale.

2 On the Edit menu, click Transform, Scale, or click the Scale button on the All-In-One toolbar.

3 (optional) Check the Scaling Factor check box, to uncheck it, on the edit bar to change the x- and y-scale of 
the selection independently.

4 Enter values in the Scale text box and press ENTER.

5 (optional) Check the Move or Copy check box on the edit bar to scale a copy of the selection set and leave the 
originals.

6 (optional) Check both the Move or Copy and Extrusion check boxes on the edit bar to extrude the selection set 
as you scale.

7 Enter the scaling basepoint. 



To scale markers, symbols, and text entities about their basepoints

1 Select the entity or entities to scale.

2 On the Edit menu, click Transform, Scale, or click the Scale button on the All-In-One toolbar.

3 Enter values in the Scale text box and press ENTER.

4 (optional) Check the Move or Copy check box on the edit bar to scale a copy of the selection set and leave the 
original.

5 (optional) Check both the Move or Copy and Extrusion check boxes on the edit bar to extrude the selection set 
as you scale.

6 Click the Entity Basepoint button on the edit bar.



Stretching an Entity

Stretching resizes an entity in one direction the result is taller or wider than the original. Stretching an entity 
moves its basepoint, thereby moving the entity. You cannot stretch arcs and circles without converting them to a 
polyline or polygon. For information on converting entities, refer to Converting & Exploding Entity Types. You 
cannot stretch text, markers, and symbols using this method because they have only one basepoint.

You can stretch entities with the Stretch button on the toolbar. It stretches entities by moving the entity endpoints 
that fall inside a marquee. For example, if a line has one endpoint in the marquee and one out, the point outside 
the marquee stays in place while AutoSketch moves the point in the marquee. This lengthens or shortens the line 
depending upon the points you enter. If both endpoints were inside the marquee, Stretch would move the entire 
line without stretching it.
    Related Topics



To stretch entities inside a specified region

1 On the Edit menu, click Select, Marquee, or click the Marquee Select button on the All-In-One toolbar.

2 Select the region to stretch.

3 On the Edit menu, click Transform, Stretch or click the Stretch button on the All-In-One toolbar.

4 (optional) Check the Copy or Move check box on the edit bar to stretch a copy of the selection set and leave 
the original.

5 Enter the startpoint of the stretch.

6 Enter the endpoint of the stretch.



Arranging Entities

The order that entities stack becomes more apparent when your drawing contains overlapping entities that are 
different colors or use fills. When two or more entities overlap, AutoSketch displays one of them on top of the 
other. AutoSketch determines the display order of entities in each layer according to their position in the stacking 
order within the layer.

You can change the stacking order of entities located in the same layer using Arrange. Move to Front places an 
entity on top of the other entities in that layer. Move to Back places an entity at the bottom of other entities in that 
layer. You cannot change the display order of entities on different layers.
    Related Topics



To change the stacking order of entities on the same layer

1 Select an entity or entities to arrange.

2 On the Edit menu, click Arrange, Move to Front to place the selection set on top of other entities on the same 
layer, or on the Edit menu, click Arrange, Move to Back to place the selection set under other entities on the 
same layer.



Repeating a Transformation

After you complete any copy, move, rotate, stretch, or scale transformation, you can repeat it by pressing a 
shortcut key. You can repeat the last transformation once or many times.
    Related Topics



To repeat the last transformation once

1 Select an entity.

2 Type an asterisk (*).



To repeat the last transformation many times

1 Select an entity.

2 Type the pound sign (#). The Repeat Transformation dialog box appears.

3 Enter the number of times to repeat the last transformation and click OK. 



Trimming Entities

Trimming is the process of refining and finishing a drawing. On the Edit menu, click Trim to shorten and lengthen 
entities to meet at a specific point, create rounded and beveled corners, or break apart and divide entities. 
Boolean operations on polygons are also provided.

Unlike most of the Edit commands in AutoSketch, Trim requires you to select a command before you specify the 
entities you want to trim. Choosing Trim clears the selection set.
    Related Topics



Creating a Corner Between Two Entities

AutoSketch can create a corner at the intersection of a line, arc, or polyline with another. If the two entities you 
specify do not intersect, AutoSketch automatically extends one or both of them, until they meet. If part of either 
entity extends beyond the intersection, it automatically trims off that part on the opposite side of the intersection 
from where you click. This process forms a perfect corner that would otherwise require manual editing.

This procedure does not create a single entity by joining the two entities together. The two entities you specify 
remain separate entities. For information on joining lines, arcs, and polylines, see Joining Entities.
    Related Topics



To form a corner between two entities

1 On the Edit menu, click Trim, Corner, or click the Corner button on the All-In-One toolbar.

2 Click the first line, arc, or polyline you want to trim. Click the portion of the entity you want to keep, near the 
point where it intersects the second entity.

3 Click the second line, arc, or polyline you want to trim. Again, click the portion of the entity you want to keep, 
near the intersection with the first entity. AutoSketch creates the corner by extending the entities to the 
intersection and removing any excess.



Rounding an Intersection

On the Edit menu, click Trim, Round to create an arc with a predefined radius to connect two existing entities 
smoothly. Lines, arcs, circles, and polylines can be rounded with this command. AutoSketch trims off or extends 
the two entities to meet the endpoints of the new arc. 

When rounding a middle section of a polyline to another entity, the polyline breaks into two polylines at that 
segment. If the polyline is a closed polygon, it breaks at that segment to form an open polyline. When rounding 
two adjacent segments of the same polyline, the arc becomes a bulge segment of the polyline. Non-adjacent 
segments of the same polyline are not allowed to round. When rounding two end segments of a polyline, the 
polyline becomes a closed polygon. When a circle is rounded to another entity, it breaks into an arc at the point 
where it intersects with the new arc.

A rounded corner may create three separate entities which are not joined together. For information on joining 
entities, refer to Joining Entities. 
    Related Topics



To round the intersection of two entities

1 On the Edit menu, click Trim, Round, or click the Round button on the All-In-One toolbar.

2 (optional) Enter a radius length in the Radius text box on the edit bar and press ENTER.

3 Click the first entity to round. Click the portion of the entity you want to keep, near the point where it intersects 
the second entity.

4 Click the second entity to round. Click the portion of the entity you want to keep, near to the point it intersects 
with the first entity.



Beveling an Intersection

AutoSketch allows you to create a beveled corner between two lines (including straight segments of a polyline) if 
the two lines intersect. The beveled edge is a new line entity that is controlled by setting the two bevel lengths on 
the edit bar. Bevel length is the distance from the intersection of the two lines to one of the endpoints to the new 
bevel edge. AutoSketch trims off or extends the two existing lines to meet the endpoints of the beveled edge. 

When beveling a middle section of a polyline with another entity, the polyline breaks in two at that segment. If the 
polyline is a closed polygon, it breaks at that segment into an open polyline. When beveling two adjacent 
segments of a polyline, the bevel edge becomes a new segment of the polyline. Non-adjacent segments of the 
same polyline are not allowed to bevel. When beveling two end segments of a polyline, the polyline becomes a 
closed polygon.

Beveling an intersection usually results in three separate entities which are not automatically joined together. For 
information on joining entities, refer to Joining Entities.
    Related Topics



To bevel the intersection of two lines or polylines

1 On the Edit menu, click Trim, Bevel, or click the Bevel button on the toolbar.

2 (optional) Enter a length in the Bevel Length text box on the edit bar to set the distance from the intersection 
point to the bevel line for the first line or polyline. 

3 (optional) Uncheck the Constrain check box on the edit bar and enter a length in the Bevel Length text box to 
set the distance from the intersection point that the bevel line or polyline trims the second line or polyline.

4 Click the first line to bevel. Click the portion of the entity you want to keep, near the point where it intersects 
the second entity.

5 Click the second entity to bevel. Click the portion of the entity you want to keep, near to the point of 
intersection with the first entity.



Trimming to an Edge

AutoSketch allows you to trim one or more lines, polylines, polygons, arcs, or circles to the edge of another. 
AutoSketch automatically extends or shortens the entities, as necessary. Each entity remains separate and 
individually editable. For information on joining lines, polylines, and arcs, refer to Joining Entities.
    Related Topics



To trim one or more entities to the edge of another entity

1 On the Edit menu, click Trim, Edge, or click the Edge button on the All-In-One toolbar.

2 Click the line, polyline segment, polygon segment, arc or circle you want to trim the other entities to.

3 Click the line, polyline segment, polygon segment, arc, or circle you want to trim to the edge entity. Click the 
portion of the entity you want to keep, near the point where it intersects the edge entity.

Tip
Press ESC or right-click once to select another edge by repeating step 2.



Removing Sections of Entities

AutoSketch provides two methods to remove a section from a line, arc, circle, or polyline. The Break command 
creates a gap in an entity by clicking a single point at the center of the gap. The Channel command creates a 
trimming path that removes sections from one or more entities at the edges of the channel.

Removing a section from an entity, either by breaking or channeling, results in two separate entities which can be 
selected or edited independently.
    Related Topics



To remove a section from a single entity

1 On the Edit menu, click Trim, Break, or click the Break button on the All-In-One toolbar. 

2 Click the line, arc, circle, polyline segment or polygon segment you want to break, the entity is highlighted.

3  (optional) Enter a different length in the Gap Width text box on the edit bar to specify the length of the break 
opening and press ENTER. A rubber-band line representing the width of the gap appears and follows the 
pointer.

4 Enter the point for the break, this is the center of the gap. AutoSketch removes the section from the entity, 
leaving two separate entities.



To cut a channel through one or more entities

1 On the Edit menu, click Trim, Channel, or click the Channel button on the All-In-One toolbar.

2 Enter two points that define the width and angle of the channel. Dashed lines illustrate the channel path.

3 Click the line, arc, circle, or polyline that is inside the channel path. AutoSketch removes the section of this 
entity that is inside the path of the channel. Repeat this step to trim additional entities that intersect the 
channel.



Dividing an Entity

On the Edit menu, click Trim, Divide to divide two lines, arcs, or circles at the point where they intersect. When 
dividing two intersecting entities that are alike, such as two lines, the resulting entities are four separate entities 
with new endpoints at their intersection. When dividing two intersecting entities that differ, such as a line and an 
arc, the resulting entities are four separate entities with new endpoints at their intersection. When dividing a circle, 
AutoSketch converts it to a single arc, with its starting and ending points at the intersection nearest to the selected 
point.

This command also allows you to divide the first entity you select and leave the second unchanged by pressing 
CTRL while selecting the first entity.
    Related Topics



To divide one or both of two intersecting entities

1 On the Edit menu, click Trim, Divide, or click the Divide button on the All-In-One toolbar.

2 Click the first line, arc, or circle you want to divide. If you only want to divide the first entity, press CTRL while 
clicking on the entity.

3 Click the second line, arc, or circle you want to divide. AutoSketch divides the entities at the intersection.



Dividing an Entity into Equal Segments

On the Edit menu, click Trim, Subdivide to divide a line, polyline segment, polygon segment, arc, or circle into a 
specified number of equal lengths. You can use it to create up to 64 equal-length entities from a single entity.

Subdividing an arc or circle results in the specified number of separate arcs, each having equal lengths. When 
subdividing a line, AutoSketch converts it to a polyline with the specified number of segments, each having equal 
lengths. Subdividing a polyline segment or polygon segment results in dividing the selected segment into the 
specified number of multiple segments, each having equal lengths.
    Related Topics



To divide a line, polyline segment, arc or circle into equal segments

1 On the Edit menu, click Trim, Subdivide, or click the Subdivide button on the All-In-One toolbar.

2 Enter the number of segments you want AutoSketch to divide the entity by in the text box on the edit bar and 
press ENTER.

3 Click the line, arc, circle, polyline segment, or polygon segment.



Creating an “Alcove” in a Line or Polyline

On the Edit menu, click Trim, Alcove to create an offset in a line or a polyline segment by adding four vertices. It is 
useful primarily for creating alcoves, bay windows, and so on in architectural floor plans that use wide polylines to 
represent walls.

You create an alcove by entering two points that specify the width of the alcove opening and another two points 
that specify its depth. AutoSketch breaks the line or polyline at the first set of points and moves that segment the 
distance and direction specified by the second set of points. AutoSketch creates polyline segments between the 
break opening and the moved segment at the angle set in the angle text box on the edit bar. Specifying a 45 or 60 
degree angle results in an alcove that resembles a bay window.

Adding a alcove to a line entity converts the line to a polyline. Performing an alcove on a polyline results in a 
single polyline with vertices and segments necessary to create the alcove.
    Related Topics



To create an alcove in a line or polyline

1 On the Edit menu, click Trim, Alcove, or click the Alcove button on the All-In-One toolbar.

2 (optional) Enter an angle in the Alcove Angle text box on the edit bar and press ENTER.

3 Click the line or polyline to which you want to add the alcove.

4 Enter the startpoint and the endpoint of the alcove. 

5 Enter a point to specify the depth of the alcove.



Joining Entities

You can join several entities into a single poly-entity. For example, if your drawing contains two polylines that 
share a common endpoint, you can join them to form a single polyline. Once you have joined them, you can 
select, move, or edit the entity as a single entity rather than having to perform the same tasks on multiple entities. 
Joining entities also reduces the redraw time and decreases the size of the drawing file. 

In AutoSketch you can join any line, polyline, or arc to any other line, polyline, or arc if the two entities share an 
endpoint. You can also join a series of lines, polylines, or arcs together if each entity shares an endpoint with the 
next entity. If the entities do not share an endpoint, you must trim them to a corner before you join them. For 
information on trimming entities to a corner, refer to Trimming to an Edge.

Pressing CTRL while joining entities causes AutoSketch to join all the entities in a series, until it encounters an 
ambiguous intersection with another entity. AutoSketch searches both directions from the point you enter, and 
continues until it finds an ambiguous intersection in both directions.
    Related Topics



To join two entities that share a common endpoint

1 On the Edit menu, click Trim, Join, or click the Join button on the All-In-One toolbar.

2 Click the first line, polyline, or arc.

3 Click the second line, polyline, or arc. AutoSketch joins the two entities together to form a polyline.



To join a series of entities

1 On the Edit menu, click Trim, Join, or click the Join button on the All-In-One toolbar.

2 Press and hold CTRL and click a line, polyline, or arc in the series. AutoSketch joins any connected entities.



Combining Two Polygons

AutoSketch allows you to combine two intersecting polygons. The new polygon assumes the combined shape of 
the two polygons. The new entity has the graphic properties of the second polygon you click.
    Related Topics



To join two overlapping polygons to form a single entity

1 On the Edit menu, click Trim, Union, or click the Union button on the All-In-One toolbar.

2 Click the first polygon.

3 Click the second polygon.



Creating a Polygon from the Intersection of Two Polygons

On the Edit menu, click Trim, Intersection to create a new polygon from the intersection of two polygons in your 
drawing. The new polygon assumes the shape of the parts of the original polygons that overlap. The new entity 
has the graphic properties of the second polygon you click on.

The original polygons are removed by this procedure. If you want to keep the original polygons, make a copy 
before you begin this procedure.
    Related Topics



To create a polygon from the intersection of two polygons

1 On the Edit menu, click Trim, Intersection, or click the Intersection button on the All-In-One toolbar.

2 Click the first polygon.

3 Click the second polygon.



Subtracting One Polygon From Another

On the Edit menu, click Trim, Difference to create a new polygon by subtracting an intersecting polygon from 
another. The new polygon assumes the shape of the second polygon, with the first polygon removed. The new 
entity has the graphic properties of the second polygon you click on. One application of this command is to make 
a polygon with a hole in it. The first polygon you click defines the shape of the hole. It must be located entirely 
inside the larger polygon for the operation to result in a polygon with a hole.

The original polygons are removed by this procedure. If you want to keep the original polygons, make a copy 
before you begin this procedure.
    Related Topics



To subtract one polygon from another

1 On the Edit menu, click Trim, Difference, or click the Difference button on the All-In-One toolbar.

2 Click the first polygon.

3 Click the second polygon. AutoSketch removes the shape of the first polygon from the second.



To create a hole in a polygon using another polygon

1 On the Edit menu, click Trim, Difference, or click the Difference button on the All-In-One toolbar.

2 Click the first polygon. This polygon defines the shape of the hole.

3 Click the second polygon. AutoSketch removes the shape of the first polygon from the second.



Reshaping Polylines, Polygons & Curves

You can reshape polylines, polygons, curves, and lines in AutoSketch by editing their vertices. Vertices are the 
control points for poly entities. For example, a polyline with a single segment has two vertices: a startpoint and an 
endpoint. You can add, move, or delete a vertex. You can also add or remove segments and specify if a segment 
is shown or hidden.

There are two different pointers in vertex editing mode. The type of pointer AutoSketch displays while you are 
editing vertices depends on where you position it: when you position the pointer on one of the boxes that mark a 
vertex, the vertex editing pointer appears; when the pointer is over a segment, the segment editing pointer 
appears.

The ability to reshape entities can drastically impact the way you create a drawing. For instance, you can quickly 
“rough in” entities to get an overall feel for the drawing, then refine these entities using vertex editing later.
    Related Topics



To enter vertex editing mode
Select the entity you want to reshape then click the Edit Vertices button on the edit bar.

OR
Select the entity you want to reshape and right-click, from the pop-up menu that appears, click Edit Vertices.

Tip
Double-clicking on a selected poly-entity is a shortcut to begin vertex editing.



Selecting Vertices

AutoSketch allows you to perform editing functions on single or multiple vertices. To select a single vertex for 
editing, simply position the pointer over the vertex and click. The hollow box that marks the vertex becomes solid. 
To select several vertices, you can region select by clicking and dragging all of the vertices within the region you 
define will be selected. You can also select multiple vertices by pressing SHIFT while clicking the vertices you 
want to edit. If you want to edit all of the vertices in an entity, simply click the Select All Vertices button on the edit 
bar.
    Related Topics



To select a single vertex
Position the pointer over the vertex and click. The coordinate location for the vertex is displayed on the edit 

bar. 



To select multiple vertices
Click and drag the pointer over all the vertices you want to select. All the vertices in the region you define will 

become selected. 

OR
Press SHIFT while clicking the individual vertices you want to edit. 



To select all the vertices in an entity
Click the Select All Vertices button on the edit bar. All the vertices of the entity are selected. 



Moving and Aligning Vertices

The primary means of reshaping an entity is moving a vertex. You move vertices by entering points with the 
mouse, entering point using the keyboard, or by aligning selected vertices using a command on the edit bar. You 
can use any combination of snap modes and lock modifiers to enter points. For information on entering points, 
see Entering & Modifying Points.
    Related Topics



To move a vertex or endpoint with the mouse

1 Enter vertex editing mode.

2 Click and drag a vertex or vertices (for more information on selecting single or multiple vertices, see Selecting 
Vertices. A rubber-band line follows the pointer. Releasing the mouse button moves the vertices to the new 
location.



To move a vertex or endpoint with the keyboard

1 Enter vertex editing mode. 

2 Position the pointer over a vertex and click. The coordinate location for the vertex appears on the edit bar. 

3 In the Coordinate text box on the edit bar, enter new coordinates for the location of the vertex and press 
ENTER. 



To align a set of vertices

1 Enter vertex editing mode.

2 Select the vertices to align (for more information on selecting single or multiple vertices, see Selecting 
Vertices. 

3 Click an alignment option (left, right, bottom, or top) from the Alignment drop-down list box on the edit bar.



To move multiple vertices or endpoints using the keyboard

1 Enter vertex editing mode. 

2 Select the vertices to align (for more information on selecting single or multiple vertices, see Selecting 
Vertices. 

3 In the Set X text box on the edit bar, enter the x-coordinates to move the vertices, and press ENTER. 

4 In the Set Y text box on the edit bar, enter the y-coordinates to move the vertices, and press ENTER. 



Moving a Segment

AutoSketch also allows you to move the individual segments of an entity. When a segment is moved, connecting 
segments are automatically lengthened or shortened as the segment is placed in another location. You can use 
any combination of snap modes and lock modifiers to enter points. For information on entering points, see 
Entering & Modifying Points.
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To move a segment

1 Enter vertex editing mode. 

2 Click a segment that you want to move, the segment is highlighted. 

3 Click the Move Segment button on the edit bar. 

4 Using the rubber-band segment, position the segment in the new location and click. 



Adding a Vertex, Segment, or Bulge

You can add a vertex at any point between the startpoint and the endpoint of a polyline segment by simply clicking 
on the point along the segment and beginning to drag. Release the mouse button when the new vertex is where 
you want it to be. If you need to add a vertex to the end of a polyline or curve, use the Extend command.

You can add as many vertices or segments as you need. After you add a vertex or segment, you can reposition it 
using vertex editing. For information, see Moving and Aligning Vertices.

A bulge is simply a curved segment of a polyline. In vertex editing mode you can quickly create a bulge in a 
polyline segment. You can think of a polyline bulge as a 3-point arc. The startpoint and endpoints of the polyline 
segment are the endpoints of the arc. The point you drag becomes the middle point of the arc. For more 
information on bulges, refer to Drawing Polylines.
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To add a vertex to a poly entity

1 Enter vertex editing mode.

2 Position the pointer on a segment where you want to add a new vertex and click and hold the left mouse 
button. When you begin to drag, a new vertex is created.

3 Drag the vertex to the new location and release the left mouse button.



To add a segment at the end of a poly entity

1 Enter vertex editing mode.

2 Click one of the vertex endpoints of the poly entity.

3 Click the Extend button on the edit bar.



To create or modify a bulge in a polyline segment

1 Enter vertex editing mode.

2 Position the pointer on the segment where you want to create the bulge and press CTRL. The segment is 
highlighted.

3 Drag the segment to position the bulge, then release the mouse button and CTRL.



Editing the Properties of a Polyline or Polygon Segment

You can change the appearance of a polyline or polygon segment using vertex editing and the edit bar. The edit 
bar’s width text boxes control the thickness of the polyline segment at its beginning and end. Typically, these 
values are the same, for example on a polyline representing a wall that is 4" thick. Setting these properties to 
different values creates a segment with a tapered appearance. When checked, the constrain check box forces the 
same value that you enter in the Width text box to be used for both ends. This results in a segment that is not 
tapered.

The Bulge Factor text box allows you to create a curved polyline segment. The value of a bulge is equal to two 
times the measured height of the bulge, divided by the distance between its startpoint and endpoint. Another way 
to measure bulge is the tangent of one-quarter of its included angle. For information on bulges, refer to Drawing 
Polylines.
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To change the properties of a polyline or a segment of a polygon

1 Enter vertex editing mode.

2 Click the polyline segment you want to edit. The segment is highlighted.

3 Change the settings for start width, end width, bulge, or other settings on the edit bar.



Controlling the Visibility of a Segment

Each polyline segment is either visible or hidden. AutoSketch automatically hides the segment that a symbol 
occupies when using Symbol, Insert on the Draw menu. You can also make a segment hidden, or make it visible 
again, by using vertex editing. Making a segment hidden does not open a polygon or change its other properties.

Tip
The selection handles appear around the extent of the entire selected entity, including hidden segments. 

When AutoSketch is in vertex editing mode and you pass the pointer over a hidden segment a small slash appears 
on the pointer. This is a useful feature for locating hidden segments. 
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To make a polyline segment hidden

1 Enter vertex editing mode.

2 Position the pointer on the polyline segment you want to hide, then click. The segment is highlighted.

3 Check the Hide check box on the edit bar.



To make a hidden polyline segment visible

1 Enter vertex editing mode.

2 Position the pointer on the polyline segment you want to make visible, then click. The segment is highlighted. 

3 Uncheck the Hide check box on the edit bar.



Deleting a Vertex or Segment

As a part of vertex editing, you can delete a vertex or segment and change the actual shape of the poly entity. 
Deleting a segment or a vertex at the startpoint or endpoint of a multi-segmented polyline removes the segment 
between that vertex and the next one. Deleting any other vertex creates a single segment between the vertices on 
either side. 

After you use vertex editing, you may find that the resulting entity contains extra vertices. If you delete a vertex 
that is colinear with the startpoint and the endpoint of an adjacent segment, or one that is located on top of 
another vertex, the shape of the entity does not change. The Clean command deletes all the extra vertices in the 
current selection set. This speeds up the time required to redraw or print the drawing, plus it affects the results of 
some trim operations.
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To delete a vertex and change the shape of the selected entity

1 Enter vertex editing mode.

2 Select the vertex you want to delete. If selected, the vertex box is solid.

3 Click the Delete Vertex button on the edit bar.



To delete a segment of a poly entity

1 Enter vertex editing mode. 

2 Select the segment you want to delete. If selected, the segment is highlighted. 

3 Click the Delete Segment button on the edit bar. 



To delete unnecessary vertices without changing the shape of the selected entity

1 Select the entity you want to clean, then right-click.

2 On the pop-up menu, click Clean.



Opening and Closing Poly Entities

A polyline or curve is either open or closed (a closed polyline is a polygon). You can open a polygon or a closed 
curve in vertex editing mode by clicking the Open button on the edit bar. This command opens the segment you 
select, converting the entity to a polyline or open curve. 

You close a polyline or curve in vertex editing mode by clicking the Close button on the edit bar. This command 
adds a segment connecting the entity’s startpoint and endpoint.

Tip
Opening and closing an entity using vertex editing has a similar result as selecting the entity and changing 

its entity type on the edit bar. However, this method allows you to control which segment to open.
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To open a polygon or closed curve

1 Enter vertex editing mode.

2 Position the pointer on the segment you want to open and click. The segment is highlighted. 

3 Click the Open button on the edit bar.



To close a polyline or curve

1 Enter vertex editing mode.

2 Position the pointer over any segment and click. The segment is highlighted. 

3 Click the Close button on the edit bar.



Dividing a Polyline at a Vertex

If a polyline has at least three vertices, you can divide it into individual polylines. For example, you can divide a 
polyline with 5 vertices into 4, 3, or 2 separate polylines. Position the pointer on a vertex between the startpoint 
and endpoint of a polyline and click the Divide button on the edit bar. AutoSketch divides the polyline at the 
selected vertex and creates two separate polylines. You cannot divide a closed curve or a polyline with less than 
two segments.
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To divide a polyline with two or more segments

1 Enter vertex editing mode.

2 Position the pointer on the vertex where you want to divide the polyline and click.

3 Click the Divide button on the edit bar.



Converting & Exploding Entity Types

Each entity type in AutoSketch has unique properties and editing procedures. Because of this, it is often 
advantageous to use one type of entity rather than another for a particular purpose. Converting an entity or group 
of entities from one type to another allows you to gain the features of the new entity type, usually without 
noticeably altering the look of the drawing. 

For instance, assume you want to fill a circle with a solid color. While you cannot fill a circle, you can convert the 
circle to a polygon. The new entity still looks like a circle, but because it has the properties of a polygon, you can 
now fill it with a solid color. AutoSketch can make many other conversions:

*The polyline must have at least three vertices.

Explode converts an entity, such as a dimension, marker, symbol or polyline to its component entities. For 
instance, in an exploded door symbol you could select the individual lines and arcs that make up the door. This is 
particularly useful when you need to create symbols using existing symbols as a basis. 
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Converting Entities to Polylines and Polygons

Converting a group of entities to a single polyline or polygon. This type of conversion is useful when you need to 
calculate the length of the group as a whole or when you need to create a polygon so you can apply pattern fill. 
The group can contain any combination of lines, arcs, and polylines, so long as each entity shares an endpoint 
with the next. For more information on joining entities, Joining Entities.

On the Edit menu, click Trim, Join to join lines, arcs, and polylines that have a common endpoint. Pressing CTRL 
while using this joins all lines, arcs, and polylines that are in a series and have common endpoints.

If a series of lines and/or polylines forms a closed shape, with the first and last entities sharing an endpoint, a 
polygon is formed. If there are any arcs in the closed series, a polyline is formed. You can convert this closed 
polyline to lines and in turn convert the lines to an irregular polygon to which you can apply pattern fill.
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To convert a pair of pre-trimmed entities to a polyline

1 On the Edit menu, click Trim, Join or click the Trim Join button on the All-In-One toolbar. 

2 Click the first line, arc, or polyline.

3 Click the second line, arc, or polyline.



To automatically convert pre-trimmed entities to a polyline or polygon

1 On the Edit menu, click Trim, Join or click the Trim Join button on the All-In-One toolbar. 

2 Press and hold CTRL and click a line, arc, or polyline in the series. 



Converting Arcs and Circles

You can convert arcs to polylines or to curves. You can convert circles to polygons or to closed curves. For 
information on how to create arcs and curves, see Polylines, Polygons, and Curves. 
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To convert arcs and circles to curves

1 Select the arcs and circles you want to convert.

2 Place the pointer over the arc or circle, but not on its about point, and right-click. A pop-up menu appears.

3 Click Convert, Arcs/Circles to Curves.



Converting Curves

A curve is a finely segmented polyline. You can convert back and forth between curves and polylines or polygons 
by choosing an entity type from the edit bar. AutoSketch converts each control point to a vertex for the polyline or 
polygon. This type of conversion creates a rough polyline; it does not look like the curve.

You can also convert a curve to a polyline or polygon that looks like the original curve by converting the fine 
segments that AutoSketch uses to display the curve to lines, polyline segments, or polygon segments. This type of 
conversion is useful when you need to calculate the approximate length of a curve. While you can convert this 
entity back to a curve, you would get a different curve with a far greater number of control points. You cannot 
convert back to the original curve when you use this method. For information on polylines, polygons, ellipses and 
curves, see Polylines, Polygons, and Curves.
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To convert curves to polylines or polygons by changing how AutoSketch draws the entity

1 Select the curve you want to convert.

2 Select the entity type from the drop-down list box on the edit bar. AutoSketch redraws the entity as the new 
entity type.



To convert curves to polylines, or polygons

1 Select the curve you want to convert.

2 Place the pointer over the curve, but not on its about point, then right-click. A pop-up menu appears.

3 Click Curves to Polylines/Polygons to convert open curves to polylines and closed curves to polygons.



Closing and Opening Curves

Curves can be open or closed. An open curve has a separate point for the start and end of the curve. When you 
close a curve, AutoSketch visually connects the two ends of the curve. You can create open or closed curves 
when drawing by selecting or unchecking the Closed check box on the edit bar. For information on drawing fitted 
and spline curves, see Drawing Curves.
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Converting Polylines and Polygons

Polylines can be converted to polygons. To convert a polyline to an irregular polygon, you must close the polyline. 
In fact, an irregular polygon is a closed polyline. To close a polyline, you can click Close on the vertex editing edit 
bar or click Irregular Polygon from the drop-down list box on the edit bar. Simply moving the startpoint and the 
endpoint of the polyline on top of one another does not close the polyline and create a polygon.

You can convert a polygon a polyline. You lose any solid or hatch fill patterns when you convert a polygon to 
polylines. To convert a regular polygon to a polyline, you must edit the vertices of the polygon. You can convert an 
irregular polygon by vertex editing, although it is generally much easier to simply click Polyline in the drop-down 
list box on the edit bar. Using this method does not allow you to select the location of the opening. Instead, 
AutoSketch creates the opening by removing the segment between the first and last vertices.

Any type of vertex editing converts a regular polygon to an irregular polygon. The following procedure converts a 
regular polygon without changing the length of any of its sides.
    Related Topics



To convert a polyline to an irregular polygon

1 Select the polyline you want to convert. It must have at least three points.

2 Click Irregular Polygon in the drop-down list box on the left side of the edit bar.



To convert a polygon to a polyline

1 Select the polygon you want to convert.

2 Click Edit Vertices on the pop-up menu for the selection set.

3 Click any segment of the polygon and click the Open button on the Edit bar.



Converting TrueType Fonts

Some plotters do not support TrueType fonts. Converting text entities that use TrueType fonts to polygons can 
greatly improve the appearance of TrueType text on such plotters. Converting TrueType text to polygons also 
makes it possible for you to reshape individual characters. Some fonts included with AutoSketch are designed 
especially for plotter output and cannot be converted to polygons.
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To convert TrueType text to polygons

1 Select the text entities you want to convert.

2 Position the pointer over the selection set, but not over its about point, and right-click. A pop-up menu appears.

3 Click Convert, Text Entities to Polygons.



Exploding Entities

AutoSketch can explode dimensions, symbols, and markers to their component entities. This allows you to edit 
the individual components of an entity. On the Draw menu, click Symbol, Create if you want to update a symbol 
definition after editing its components. You must select the component entities first. 
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To explode an entity

1 Select the entity you want to explode.

2 Position the pointer over the selection set, but not over its about point, and right-click. A pop-up menu appears.

3 On the Edit menu, click Explode, or click the Explode button on the edit bar.



Making Inquiries

Each time you create a new entity or change field values, AutoSketch keeps track of useful information that you 
can retrieve later by making an inquiry. The dialog boxes that display the results of inquiries include buttons that 
let you copy the data to the Clipboard, print it, or export it as a .CSV file. Depending on what types of values are 
displayed, certain buttons are grayed in some cases.

An inquiry can provide detailed information on a single entity, generalized information about all the entities in the 
current selection set, or information about the entire drawing. For instance, you can use an inquiry to provide a list 
of symbols and the number of times each appears in the current drawing. This feature might be useful to count 
chairs in an office or to tally the different sizes of bolts and the number of each size in a machine part.

You can make inquiries to determine the coordinates of a point you enter. Typically, the point you enter is on an 
entity in your drawing. This is useful for determining the exact location of entities in your drawing. Additionally, you 
can measure lengths, angles, perimeters, or areas. AutoSketch displays coordinates, lengths, angles, and areas 
using current units of measurement for the drawing. On the Tools menu, click Options to change the units of 
measurement used for a specific type of value. For information on changing the current units of measurement, 
see Setting the Units of Measurement.
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Displaying Information About a Specific Entity

AutoSketch allows you to inquire about the properties of a selected entity. This inquiry shows all of the stored 
information, such as extent, layer, UID, hyperlink URL, and so on. The information displayed in the dialog box 
varies with the type of entity selected.



To display information about the properties of a specific entity
Right-click the entity, then click (entity name) Properties on the pop-up menu. 

OR
On the Inquire menu, click Entity Properties, then click the entity. 

OR
Click the Inquire Entity button on the All-In-One toolbar, then click the entity. A dialog box appears, displaying 

information on the entity.



Displaying Information on Groups of Entities

Often, it is useful to display information about the selection set or the current drawing as a whole. On the Inquire 
menu, click Selection Properties or Drawing Properties to display the extent and count of each entity type in the 
selection set and the drawing, respectively. On the Inquire menu, click Symbol Count to display a symbol list 
containing the names of the symbol definitions stored in the drawing and the number of times they appear in the 
drawing.

The selection set extent is the smallest rectangle that fits around the set. The drawing extent is the smallest 
rectangle that fits around all of the entities in the drawing. AutoSketch displays an extent as the lower left 
(Minimum XY) and upper right (Maximum XY) coordinates of the rectangle.
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To display the extent and entity totals for the current selection set
On the Inquire menu, click Selection Properties, or click the Inquire Selection button on the All-In-One 

toolbar. The Selection property sheet appears.

OR
Right-click the selection set and click Selection Properties on the pop-up menu, 



To display the extent and entity totals for the current drawing
On the Inquire menu, click Drawing Properties, or click the Drawing Properties button on the All-In-One 

toolbar. If a selection set exists, AutoSketch temporarily suspends it. The Drawing Properties dialog box appears 
displaying information about all entities in the drawing, regardless of whether any were selected.



To display information on the symbol definitions in the current drawing
On the Inquire menu, click Symbol Count, or click the Symbol Count button on the All-In-One toolbar. If a 

selection set exists, AutoSketch temporarily suspends it. The Symbol Count dialog box appears displaying 
information about all symbols in the drawing, regardless of whether any were selected.



Displaying the Coordinates of a Point

AutoSketch allows you to determine the coordinates of a point you enter. On the Inquire menu, click Coordinate to 
display both the world coordinates and page coordinates of the point. World coordinates (based on the actual size 
of the objects in your drawing) are measured from the drawing origin. Page coordinates are measured from the 
lower left corner of the page. When the drawing scale is 1:1 and the drawing origin is at the lower left corner of the 
page, world and page coordinates are identical.
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To display the coordinates of a point

1 On the Inquire menu, click Coordinate, or click the Inquire Coordinate button on the All-In-One toolbar. If a 
selection set exists, it is temporarily suspended and the selection handles are grayed.

2 Enter the point. The Coordinate dialog box appears displaying the coordinates of the point you entered.

3 Click Close or click Inquire Again to display another coordinate, or click the Copy button to copy the currently 
displayed coordinates to the Clipboard.



Measuring Distances

Often, you need to know the distance between two points but you don’t want to draw a dimension. For example, 
you might want to know the distance between home plate and a point on the outfield fence in a drawing of a 
baseball field. To measure this distance, simply enter two points and AutoSketch calculates the distance between 
them. For information on distance input methods, Entering Lengths.

AutoSketch can also calculate the length associated with a specific entity. This feature allows you to measure the 
length of a specific entity, such as a line or one segment of a polyline. All entities except curves and dimensions 
have an associated length. Polylines and polygons have a distance associated with each segment. Symbols have 
a distance associated with each component entity.

If you don’t know a specific distance, but know a numeric expression that produces the distance, AutoSketch can 
calculate and display it using current units of measurement.
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To display the distance between two points

1 On the Inquire menu, click Distance, or click the Inquire Distance button on the All-In-One toolbar. If a selection 
set exists, it is temporarily suspended it and the selection handles are grayed.

2 Enter the point that defines the startpoint of the measurement. A rubber-band line appears beginning at the 
entered point.

3 Enter the point that defines the endpoint of the measurement. The Distance dialog box appears, displaying the 
distance between the two points, plus the delta-x and delta-y of the measurement.

4 Click Close or click Inquire Again to display more distances, or click the Copy button to copy the currently 
displayed data to the Clipboard.



To display the length of an entity or entity component

1 On the Inquire menu, click Distance, or click the Inquire Distance button on the All-In-One toolbar. If a selection 
set exists, AutoSketch temporarily suspends it and grays the selection handles.

2 Select the entity in the drawing while pressing SHIFT. The Distance dialog box appears, displaying one of the 
following distances:

3 Click Close or click Inquire Again to display another length, or click Copy to copy the currently displayed 
length to the Clipboard



To display a length based on a numeric expression

1 On the Inquire menu, click Distance, or click the Inquire Distance button on the All-In-One toolbar. If a selection 
set exists, AutoSketch temporarily suspends it and grays the selection handles.

2 Type = (equal sign). The Distance Input dialog appears.

3 Enter the numeric expression that evaluates to the distance you want to measure and click OK. The Distance 
dialog box appears.

4 Click Close or click Inquire Again to display another length, or click Copy to copy the currently displayed length 
to the Clipboard



Measuring Angles

You can make an inquiry that measures the angle between points you enter. You can enter these points to 
measure the angle of an entity, such as the angle of a bevel. You can enter an angle using two or three points. 
The first point you enter defines the vertex of the angle you want to measure. The remaining points define the 
angle to include.

You can measure the angle associated with a specific entity in the drawing. All entities except dimensions have at 
least one associated angle. Lines, polyline segments, and polygon sides have two associated angles one for 
each endpoint. AutoSketch displays the angle associated with the endpoint closest to where you click on the 
entity.

Arcs have two associated angles one for each endpoint. When you make an inquiry about an arc, AutoSketch 
displays the angle associated with the endpoint closest to where you click on the arc.

Symbols have angles associated with each component entity. The exact number of angles associated with a symbol 
varies with the individual symbol.
Markers and text have one associated angle. The angle is a property of the entity and AutoSketch measures this 
angle about the entity’s basepoint.

If you don’t know a specific angle, but you know a formula that produces it, you can let AutoSketch calculate the 
formula and display the resulting angle.
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To display an angle defined by three points

1 On the Inquire menu, click Angle, or click the Inquire Angle button on the All-In-One toolbar. If a selection set 
exists, AutoSketch temporarily suspends it.

2 Enter the vertex (the center point) of the angle.

3 Enter the beginning point of rotation. A rubber-band arc appears to mark the angle. 

4 Enter the ending point of rotation. The Angle dialog box appears.

5 Click Close or click Inquire Again to display another angle, or click the Copy button to copy the currently 
displayed angle to the Clipboard



To display an angle defined by two points

1 On the Inquire menu, click Angle, or click the Inquire Angle button on the All-In-One toolbar. If a selection set 
exists, AutoSketch temporarily suspends it.

2 Press CTRL while entering the point that defines the vertex of the angle. A rubber-band line appears beginning 
at the entered point.

3 Enter the second point. The Angle dialog box appears displaying the measured angle.

4 Click Close or click Inquire Again to display another angle, or click the Copy button to copy the currently 
displayed angle to the Clipboard



To display the angle associated with an entity

1 On the Inquire menu, click Angle, or click the Inquire Angle button on the All-In-One toolbar. If a selection set 
exists, AutoSketch temporarily suspends it.

2 Click the entity in the drawing while pressing SHIFT. The Angle dialog box appears and displays the angle.



To display an angle based on a formula

1 On the Inquire menu, click Angle, or click the Inquire Angle button on the All-In-One toolbar. If a selection set 
exists, AutoSketch temporarily suspends it.

2 Type = (equal sign). The Angle Input dialog box appears.

3 Enter the formula that evaluates to an angle and click OK. The Angle dialog box appears and displays the 
angle



Measuring Areas

AutoSketch allows you to make an inquiry that measures the area and perimeter of an irregular polygon you 
specify by entering points. For example, if you wanted to determine the square footage of a piece of property in a 
drawing, you might enter points that follow the boundary of the property lines. After you create the irregular 
polygon that defines the area you want to measure, the area and perimeter measurements appear in a dialog box. 
When you are finished viewing the measurement, the polygon disappears.
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To display the area and perimeter of a region

1 On the Inquire menu, click Area/Perimeter, or click the Inquire Area button on the All-In-One toolbar. If a 
selection set exists, it is temporarily suspended.

2 Enter a point to begin the irregular polygon. A rubber-band line follows the pointer.

3 Enter a point to define a corner of the polygon. A rubber-band polygon follows the pointer. Repeat this step 
until you define all of the corners of the irregular polygon.

4 Right-click. The Area and Perimeter dialog box appears.

5 Click Close or click Inquire Again to display another area and perimeter, or click the Copy button to copy the 
currently displayed area and perimeter to the Clipboard.



Setting Up a New Drawing

Starting a new drawing is as easy as clicking a button. However, AutoSketch offers many options that allow you to 
tailor a drawing file to your needs. This topic discusses most of the options available when starting a new drawing. 
For a discussion of grid options, see Customizing the Grid.
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Creating a New Drawing

You can create a new drawing anytime you are working in AutoSketch. The Start Up dialog box appears when you 
first begin AutoSketch and allows you to start different types of new drawings, select from a list of the most 
recently opened drawings, load a template, or choose between the AutoSketch Classic or Microsoft Office 97 
Compatible interfaces. 

You can also begin a new drawing after you have started a drawing session. The New dialog box is a simpler form 
of the Start Up dialog box. It lists several ways to begin a drawing, allowing you to select from different drawing 
types and templates. 

When you begin a new drawing from scratch, you can begin drawing immediately (using AutoSketch’s default 
settings) or configure it for the specific object you plan to draw. The latter process includes establishing an 
appropriate scale, setting the page size and orientation, setting up the reference grid, specifying the units of 
measurement to be used, and so on.

Until you save the drawing, the name “Drawing” and a unique number appear in the drawing window’s title bar. 
This name is replaced with the drawing name you designate when you save it.

If you don’t want the Start Up dialog box or the New dialog box to appear, they can be turned off using controls in 
the Drawing Options dialog box. When the Start Up dialog box or the New dialog box is disabled, AutoSketch 
opens each new drawing session as if you had selected Start Drawing Immediately from the Wizard page of the 
Start Up dialog box.
    Related Topics



To create a new drawing from start up using default settings
In the Start Up dialog box, click Start Drawing Immediately, then click OK. The AutoSketch application 

window appears using the default interface, template, and settings.



To create a new drawing from start up using custom settings

1 On the Start Up dialog box, click Create Precision Drawing, then click OK. The AutoSketch application window 
and the New Drawing Wizard appear.

2 The New Drawing Wizard presents a series of dialog boxes that walk you through the process of setting up 
your drawing.



To create a new drawing using default settings
Click the New button on the Standard toolbar.

OR

1 On the File menu, click New. The New dialog box appears.

2 Click Start Drawing Immediately, then click OK.



To create a new drawing using custom settings

1 On the File menu, click New. The New dialog box appears.

2 Click Create Precision Drawing, then click OK.

3 The New Drawing File Wizard presents a series of dialog boxes that walk you through the process of setting 
up your drawing.



To disable the Start Up dialog box

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the File page tab, then uncheck the Show Start Up Dialog check box. When this box is checked, the Start 
Up dialog box appears when you begin AutoSketch.



To disable the New dialog box

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the File page tab, then uncheck the Show File New Dialog check box. When this box is checked, the 
New dialog box appears when you click New on the File menu.



Selecting an Interface

AutoSketch allows you to choose from two basic interfaces. New users, or users who are more comfortable with 
the look of most Microsoft applications can use the Microsoft Office 97 Compatible interface. Users who are 
familiar with previous versions of AutoSketch can select the AutoSketch Classic interface. Both interfaces allow 
you full access to all of the functions and features of AutoSketch only the positioning of toolbars varies.

You can select an interface at start up, or change interfaces after you have begun a drawing session. The default 
interface is Microsoft Office 97 Compatible.
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To select an interface at start up

1 Click a drawing option on the Wizard page of the Start Up dialog box.

2 Click the Classic page tab.

3 Click either the AutoSketch Classic button or the Microsoft Office 97 Compatible button.



To change the interface once a drawing session has begun

1 On the View menu, click Toolbars, or right-click a toolbar, then click Toolbars on pop-up menu that appears. 
The Toolbars dialog box appears.

2 Click either the AutoSketch Classic button or the Microsoft Office 97 Compatible button at the bottom of the 
dialog box.

3 Click Yes to confirm the interface selection.

Note
Changing the interface once you have begun a drawing session overrides the current bar arrangement.



Selecting a Template

AutoSketch includes dozens of drawing templates that make setting up drawings a snap. Each template contains 
setup information such as the drawing scale and page size, plus custom drawing features like borders. You can 
also create your own template from an existing drawing and add it to the list of templates available on the 
Template page of the Start Up or New dialog boxes.
    Related Topics



To select a template

1 In the Start Up dialog box click the Template page tab.

2 Click a new template from the Template list box. Notice that a preview of the template style appears in the 
Preview window.

3 (optional) Check the Use Selection as New Default check box. When this option is checked, your selection 
becomes the new default template.

4 Click OK.

OR

1 Click New on the File menu, then click the Template page tab in the New dialog box.

2 Click a new template from the Template list box. Notice that a preview of the template style appears in the 
Preview window.

3 (optional) Check the Use Selection as New Default check box. When this option is checked, your selection 
becomes the new default template.

4 Click OK.



To delete a template

1 Click the Template page tab in the Start Up or New dialog boxes as described in the preceding sets of steps.

2 Click the Organize Templates button. The Organize Templates dialog box appears.

3 Click the template you want to delete in the Templates list box, then click Delete.

4 AutoSketch prompts you for a confirmation. Click Yes, then click Close.



To add a template

1 Click the Template page tab in the Start Up or New dialog boxes.

2 Click the Organize Templates button. The Organize Templates dialog box appears.

3 Click Add. The Add Template From Drawing dialog box appears.

4 Enter the filename and the folder location to use as a template in the Drawing Name text box. If you don’t 
know the filename or exact location, click Browse button, then select a drawing and click OK.

5 (optional) Check the Delete Existing Entities When Making Template check box. When this option is checked, 
all entities in a drawing are deleted from the template. Leave this check box unchecked if you want to include 
entities such as title blocks in the new template.

6 Enter a new name for the template, then click OK. The Organize Templates dialog box appears. 



Setting the Drawing Scale

The drawing scale is the ratio of an object’s size on scaled output to its real world size. AutoSketch lets you draw 
and measure using the real world size of the items you are drawing. This allows you to enter lengths using real 
world measurements. AutoSketch uses the drawing scale to resize your printed drawing. For example, in a 
drawing whose scale is at one-quarter inch equals one foot, a line that is one-quarter inch long when printed 
represents a line that is actually one foot long.

You can change the drawing scale at any time. The controls are located on the Scale page of the Drawing Options 
dialog box. You can choose from many pre-set scales or enter a custom scale.

The Apply Scale Change check box applies any changes in scale to all text, markers, and dimensions. These are 
specified in size on output, rather than real world size. In all but rare cases, this option should be checked. All 
drawing parameters are updated, if this box is checked, by the ratio of the previous scale to the new scale. If there 
are existing dimensions, text, or markers in your drawing, click the Scale Annotation or Do Not Scale Annotation 
buttons located to the left of the Apply Scale Change check box.

AutoSketch features two automatic scaling functions on the Scale page of the Drawing Options dialog box that 
can make setting your drawing scale easier. AutoScale selects the closest scale from the current scale list. AutoFit 
calculates a non-standard scaling factor that scales your drawing to the largest size that will fit on the page. Using 
AutoFit may result in a scaling factor that is not appropriate for most building, or other, standards.
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To change the drawing scale to a common scale

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Scale page tab.

3 Click the page tab for Any Scale, Architectural, Engineering, Mapping, or Metric.

4 Click a scale in the list box, then click OK.



To change the drawing scale to a custom scale

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Scale page tab.

3 Click the page tab for Any Scale, Architectural, Engineering, Mapping, or Metric.

4 Click Custom Scale from the list box.

5 Enter the page units in the Page (Output) text box.

6 Enter the actual units in the Actual (World) text box. The ratio of the page units to the actual units is the 
drawing scale.

7 Click OK.



To change the drawing scale and move an existing drawing so that it fits on a single page

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Scale page tab.

3 Click Auto Scale or AutoFit, then click OK. AutoScale selects the closest scale from the current scale list. 
AutoFit calculates a non-standard scaling factor that scales your drawing to the largest size that will fit on the 
page. Using AutoFit may result in a scaling factor that is not appropriate for most building, or other, standards.



Moving the Drawing Origin

When you create a new drawing, AutoSketch places the drawing origin at the lower-left corner of the page. 
However, you can specify any point as the drawing origin, either by entering coordinates or by entering a point 
with the mouse. This is especially useful when you want to reposition the drawing on the page without changing 
the coordinate values.

The drawing origin appears as colored arrows indicating the positive x- and y-coordinate (and, if isometric, z-
coordinate) directions. It does not appear when you print your drawing.

You can also hide the drawing origin from view without affecting the origin’s functionality. 
    Related Topics



To place the drawing origin at the lower-left corner or center of the page

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Scale page tab.

3 Click Lower Left Corner or Center from the Drawing Origin drop-down list box.

4 Click OK.



To reposition the drawing origin using coordinates

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Scale page tab.

3 Click Custom from the Drawing Origin drop-down list box.

4 Enter coordinates in the text boxes to specify the location of the drawing origin on the page. These coordinates 
are measured in relation to the page size from the lower-left corner of the page.

5 Click OK.



To reposition the drawing origin using the mouse

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Scale page tab.

3 Click Select After OK from the Drawing Origin drop-down list box.

4 Click OK.

5 Click a point on the page for the drawing origin.



To hide the drawing origin from view

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Scale page tab.

3 Uncheck the Display Drawing Origin check box. When checked, the drawing origin is displayed, when 
unchecked, the drawing origin is hidden from view.

4 Click OK.

OR

1 On the View menu, click Options. The View Options dialog box appears.

2 Click the Appearance page tab.

3 Uncheck the Drawing Origin check box. When checked, the drawing origin is displayed, when unchecked, the 
drawing origin is hidden from view.

4 Click OK.



To change the colors of the drawing origin

1 On the View menu, click Options. The View Options dialog box appears.

2 Click the Appearance page tab, then click an Axis Color button in the Screen section. The Color dialog box 
appears.

3 Click a color from the palette then click Apply.

4 Click OK in each dialog box.



Setting the Page Size

You can set the page size by using the size of the current Windows printer, by specifying a standard size, by 
entering a tiling pattern based on the printer page, or by entering custom measurements. You can also specify the 
orientation of the page.

When you create a new drawing, AutoSketch sets the page size using the size of the current Windows printer. If 
you need to create a drawing larger than the paper size your output device supports, AutoSketch will tile your 
printed output on multiple printer pages.
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To set the page size by using the page size of the current printer

1 On the File menu, click Page Setup. The Page Setup dialog box appears.

2 Click the Size page tab.

3 Click the Printer Page option button.

4 Click OK.



To change the default printer page options

1 On the File menu, click Page Setup. The Page Setup dialog box appears.

2 Click the Printer Page page tab.

3 Click an item from the Paper Size drop-down list box. Notice that the paper dimensions appear in the grayed 
boxes below the Paper Size drop-down list box.

4 Click an orientation from the Paper Orientation drop-down list box.

5 Click a source from the Paper Source drop-down list box.

6 Click OK.



To set the page to a standard size

1 On the File menu, click Page Setup. The Page Setup dialog box appears.

2 Click the Size page tab.

3 Click the Standard Size option button.

4 Click an item from the page size drop-down list box.

5 Click either portrait or landscape from the orientation drop-down list box.

6 Click OK.



To set the page size by tiling printer pages together

1 On the File menu, click Page Setup. The Page Setup dialog box appears.

2 Click the Size page tab.

3 Click the Tiling Pattern option button.

4 Enter the number of horizontal printer pages for the tiling pattern.

5 Enter the number of vertical printer pages for the tiling pattern, then click OK.



To set the page size using exact measurements

1 On the File menu, click Page Setup. The Page Setup dialog box appears.

2 Click the Size page tab.

3 Click the Custom Size option button.

4 Enter the horizontal size of the page.

5 Enter the vertical size of the page, then click OK.



Using Rulers

Rulers appear along the top and left sides of the drawing window. They represent units of measurement either in 
actual size, or the page size, depending on which ruler is active. 

Actual (world) rulers are based upon scale settings you choose and indicate the actual size your drawing 
represents. For instance, the actual object in your drawing might be 20’ x 60’. When you create a new drawing, 
the default actual (world) scale setting is 1”= 1”. You can select a different scale setting or create your own 
custom scale setting using the Drawing Options dialog box. For more information on setting the scale, see Setting 
the Drawing Scale.

Page (output) rulers reflect the size of the drawing page on output, and are automatically updated to reflect printer 
or page size settings. For more information on setting the current page size, see Setting the Page Size.

Alternating between page (output) rulers and actual (world) rulers is as simple as clicking the mouse.
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To alternate between actual (world) rulers and page (output) rulers
Click the actual or page icon in the upper-left corner of the drawing window, where the top and left rulers 

intersect.



To change the actual (world) scale factor

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Scale page tab, then click the Any Scale page tab.

3 Click a scale from the list box.

4 (optional) Click a page tab for an alternate scaling method, then define a scaling factor.

5 Click OK. The scaling factor you selected is applied to the current drawing page.



To hide the rulers from view

1 On the View menu, click Options. The View Options dialog box appears.

2 Click the Appearance page tab. 

3 Uncheck the Rulers check box on the Screen section. When checked, the rulers are displayed in the drawing 
window.



Setting the Margins

Most printers cannot print on the margin. AutoSketch indicates the margins onscreen with a shaded band around 
the page. When you create a new drawing, AutoSketch reads the hard margin from the current Windows printer 
driver. You can specify a larger margin using the Page Setup dialog box, but the hard margin is the minimum 
margin that your printer driver supports.
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To adjust the margins

1 On the File menu, click Page Setup. The Page Setup dialog box appears.

2 Click the Margins page tab.

3 Enter the margin values in the appropriate text boxes.

4 Click OK.



Setting the Units of Measurement

You can set the default units of measurement using the Drawing Options dialog box. The default units of 
measurement are the ones used by AutoSketch to display measurements. AutoSketch also assumes the default 
units of measurement if you do not specify a particular unit when entering data. Regardless of the default units of 
measurement, you can always enter a measurement using any of the units AutoSketch supports.

Each type of measurement (e.g., linear, angular, etc.) has its own precision settings. These settings control how 
AutoSketch formats numbers for output. Regardless of these precision settings, AutoSketch always performs all 
calculations at the maximum possible precision. 
    Related Topics



Setting the International Units of Measurement

AutoSketch lets you set the default measurement system for Windows from within the program. You can set 
AutoSketch to use English or Metric units, place leading zeros before decimal values, and format decimal 
numbers using a comma instead of a period for the decimal separator.
    Related Topics



To set the international units of measurement

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Units page tab.

3 Click a method from the Measurement System drop-down list box.

4 (optional) Check the Show Leading Zeros check box.

5 (optional) Click the Period or Comma option button in the Decimal Symbol section.

6 Click OK.



Setting the Linear Units

AutoSketch allows you to choose from nine standard units of measurement for lengths. Six are English measures 
and three are Metric. You can also specify the precision AutoSketch uses to display decimal and fractional linear 
values separately. The choices for decimal precision range from 1 to 0.0000001, while the choices for fractional 
precision range from 1 to 1/128.
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To set the linear units of measurement

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Units page tab.

3 Select the units of measurement from the first drop-down list box in the Length section.

4 (optional) To set the decimal precision for linear measurements, select a value from the Decimal Precision 
drop-down list box.

5 (optional) To set the fractional precision for linear measurements, select a fraction from the Fractional 
Precision drop-down list box.

6 Click OK.



Setting the Angular Units of Measurement

AutoSketch allows you to choose from six standard units of measurement for angles: degrees, degrees-minutes-
seconds, minutes, radians, bearing, and grads. You can specify the precision AutoSketch uses to display angular 
values from 1.0 to 0.0000001. You can specify whether AutoSketch measures angles using the standard format or 
using compass orientation. For information on compass angles, see Compass Angles & Bearings.
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To set the angular units of measurement

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Units page tab.

3 Select the angular units of measurement from the first drop-down list box in the Angle section.

4 (optional) Select a value from the Decimal Precision drop-down list box.

5 (optional) Select a method in the Orientation drop-down list box.

6 Click OK.



Setting the Area Units of Measurement

AutoSketch allows you to choose from eight standard units of measurement for areas. Five are English 
measurements and three are metric. You can also specify the precision AutoSketch uses to display area values. 
The choices for decimal precision range from 1 to 0.0000001.
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To set the area units of measurement

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Units page tab.

3 Click the units of measurement from the first drop-down list box in the Area section.

4 (optional) Click a value from the Decimal Precision drop-down list box.

5 Click OK.



Setting Decimal Precision for Scalar Values

AutoSketch allows you to set the decimal precision for scalar values. Scalar values are unit-less numbers, such as 
symbol scale or a bulge factor for a polyline segment. The choices for decimal precision range from 1 to 
0.0000001.
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To set the decimal precision

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Units page tab.

3 Click a precision from the Precision drop-down list box in the Scalar section.

4 Click OK.



Storing Data in a Drawing

In most CAD applications the information you can store is limited to entities or annotations you place in your 
drawing. However, in AutoSketch, your drawing can double as a database. In other words, you can assign data to 
a drawing, creating a visual resource of information. You could, for example, create a drawing of your house and 
assign insurance information to illustrations of your furniture and other valuables. AutoSketch stores database 
information in entities to which you can assign properties. Properties act as containers for data, storing the 
characteristics of an entity such as layer, color, and style. When you change an entity’s color, you assign a new 
value to that entity’s color property.

You can create your own properties, called fields, when you need to store information that does not correspond to 
an existing property. Think of a field as a custom container of information. Continuing the insurance example 
above, you might create a Purchase Price field and assign a dollar value to entities that represent valuables. You 
could then create an insurance report if a valuable was damaged, lost, or stolen. For information on creating 
reports from data stored in a drawing, see Retrieving Data from a Drawing.
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Creating Fields

You can create fields to hold data you want to store in the drawing. A field is a user-defined property. On the 
Database menu, click Options to create a new field. 

Before adding new fields, you should ask yourself what type of data you want to store. For example, if you are 
planning a computer network, you might want to know how much cable you need. To store this data, you could 
create a Cable Length field. If you are creating an electrical schematic, you might want to know the tolerances of 
the resistors in the circuit. To store this data, you could create a Tolerance field.

Once you know what type of data you want to store in a field, you are ready to select its type. Every field must be 
one of five types:

You can have many fields in a drawing, but each field you create must have a unique name. The field name should 
describe the data it contains because it appears when you request information about an entity. Field names can 
contain letters, numbers, spaces, and punctuation marks.
When you are naming fields that you plan to export to another application, consider that some programs do not 
support the use of blank spaces, special characters like an underscore (_), or punctuation. If this is the case, it is best 
to use only letters and numbers in field names. AutoSketch can validate field names to limit them to ten characters 
where the first character is a letter and remaining characters are letters, numbers, or underscore characters.
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To create new fields

1 On the Database menu, click Options, or click the Database Options button on the Standard toolbar. The 
Database Options dialog box appears. 

2 Click the Fields page tab. 

3 (optional) To limit field names, check the Validate Name check box. This option can make it easier to export the 
database to older database applications.

4 Enter the name of the field in the Field Name text box.

5 Click a field type in the Type section.

6 (optional) Enter a value in the Width text box. This determines the number of characters AutoSketch includes if 
you export the database.

7 (optional) If the field type is Number, Length, Angle, or Area, enter a value in the Precision text box. This 
determines the number of decimal places AutoSketch uses to round the field value to if you export an ASCII 
file.

8 Click Add. Repeat steps 3 through 7 to create other fields.

9 Click Close.

Tip
If you are planning to create several drawings that require similar fields, you can create a blank drawing with 

the necessary fields and use it as a template for the drawings.



Assigning Fields and Values to Entities

Once you’ve created the fields to store data in your drawing, you must assign those fields to specific entities. This 
adds your fields to the list of properties for that entity.

You assign a field to an entity by specifying a value for the entity, even if that value is zero. On the Database 
menu, click Assign Field to assign a field by setting a value for one or more entities.

On the Database menu, click Edit Entity Fields to edit all of the fields for a specific entity. You can assign a field by 
setting a value or by editing a value that is already in a field.
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To assign one field to several entities

1 Select the entities to which you want to assign a field.

2 On the Database menu, click Assign Field, or click the Assign Fields button on the Standard toolbar. The 
Assign Field dialog box appears.

3 Select a Field Name from the list.

4 Enter a value for the selected field that is applicable to the selected entities.

5 Click OK.



To assign one or more fields to a single entity

1 Select an entity to which you want to assign a field.

2 On the Database menu, click Edit Entity Fields, or click the Edit Entity Fields button on the Standard toolbar. 
The Edit Entity Fields dialog box appears.

3 Click in the value text box for a field and enter a new value. Repeat this step to edit other values.

4 (optional) Click Edit Again, click another entity, and repeat step 3.

5 Click OK.

Note
The Edit Entity Fields dialog box can be resized, in order to access or view the fields for an entity.



Calculated Values

Instead of entering a constant value in a field, you can assign it a calculated value. AutoSketch updates the 
calculated value each time the drawing changes. For example, the calculated value “%Length” returns the length 
of a line, arc, circle, polyline, or polygon and stores the length in the field. If you change the length of that entity, 
AutoSketch instantly updates the calculated value assigned to that entity. If that field is visible, you can see the 
change.

You enter a calculated value just as you would any other value. AutoSketch returns the text or numbers to the field 
automatically. There are specific calculated values for the five different field types. AutoSketch ignores the 
calculated value if the field type is not correct, for example if %Length is used in a string field.

Note
Dimensions and text entities cannot have fields assigned to them.

String    The following calculated values return a text string:

Number    The following calculated values return a number formatted as a scalar value:

Length    The following calculated values return a length in the current units of measurement:

Angle    The following calculated values return an angle in the current units of measurement:



Area    The %Area calculated value returns the area of a polyline or polygon formatted in the current units of 
measurement to a field with the area type.
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Removing Fields

AutoSketch allows you to remove fields from specific entities or from the entire drawing. On the Database menu, 
click Options to remove a field. When you remove a field in this manner, the value stored in the field is lost, 
because there is no longer a container to store the value. On the Database menu, click Delete Field to remove 
fields from specific entities.
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To unassign a field from a selection set

1 Select the entity whose fields you want to unassign.

2 On the Database menu, click Delete Field, or click the Delete Field button on the Standard toolbar. The Delete 
Field dialog box appears.

3 Click a field in the list that you want to unassign from the selected entity.

4 Click OK.



To delete a field from the drawing

1 On the Database menu, click Options, or click the Database Options dialog box on the Standard toolbar. The 
Database Options dialog box appears. 

2 Click the Fields page tab. Any existing fields in the drawing are displayed. 

3 Click the field you want to delete.

4 Click Delete. AutoSketch displays a dialog box asking if it is OK to delete the field.

5 Click OK. Repeat steps 2-4 to remove another field from the drawing.

6 Click Close.



Retrieving Data from a Drawing

Once you’ve created and assigned fields to entities in your drawing, you need to be able to access and organize 
that information in a useful way. You can retrieve information from your drawings using three methods: by creating 
database reports formatted in spreadsheet-like grids, by exporting data to a spreadsheet or database, and by 
displaying text from the database directly in the drawing. Report generation is one of the primary features that sets 
AutoSketch apart from a traditional drawing program.

Before you can generate a report, you must enter data. AutoSketch stores a great deal of data in the drawing as 
you create entities. Graphic properties such as color, style, and width are stored along with the geometric 
information for each entity. However, reports are only available if fields have been defined. For information on 
creating fields and storing information in them, see Storing Data in a Drawing.

Creating a good report is a process of choosing what information to include and to exclude from the report. You 
want to display the significant data and nothing more. Provide too little information and your report isn’t a useful 
source of data. Provide too much information and it is difficult to find the pertinent facts.
    Related Topics



Creating Reports

AutoSketch generates reports formatted in rows and columns like a spreadsheet. Reports display information you 
store in the drawing. There are two types of reports: detail and summary. Detail reports display information for 
every entity in the selection set. Summary reports display information for each symbol definition in the selection 
set along with a count of the number of instances of each symbol. Summary reports exclude non-symbol entities. 
You can display the sum of a column of numeric database fields in a detail report.

You can export information contained in the report fields of a AutoSketch drawing to other applications using the 
Windows Clipboard. Open the report that you want to export and click Copy. This transfers all the data to the 
Clipboard in standard text format and comma-separated values. This information can then be pasted into most 
Windows applications.

Reports operate on the current selection set. If no entities are selected, the report operates on the entire drawing. 
Additionally, you can include selection criteria in the report to further refine the selection set.

The reports you create are available to all of the drawings you edit on your system. However, for the reports to 
operate correctly, the drawings you try to generate reports from must have all of the fields used by the report.
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To edit or create a report

1 On the Database menu, click Report, or click the Database Report button on the Standard toolbar. The 
Database Report dialog box appears.

2 Click the Reports page tab. 

3 Click Create to create a new report, or select a report and click Edit to edit an existing report. The Create 
Database Report or Edit Database Report dialog box appears.

4 Enter a title in the Report Title text box. This title appears in the Reports dialog box and at the top of printed 
reports.

5 (optional) Enter the text you want to appear in the report footer in the User Text text box.

6 Click a field from the Available Fields list box and click Add or Insert. Insert places the new field directly above 
the highlighted field while Add places the new field directly below.

7 (optional) Click a field from the Report Fields list box and click Delete to remove a field from the report.

8 In the Report Type section of the dialog box, click the Detail option button or the Summary option button.

9 (optional) In the Selection Criteria section of the dialog box, click Change to change the selection set for this 
report. The Selection Modifier window appears. For more information on the Selection Modifier, see Using the 
Selection Modifier.

10 Click OK. The Custom Report Column Configuration dialog box appears.

11 (optional) Enter new text in the Column Head cell for the field you want to change.

12 In the Editable column, check the check boxes for any fields you want to be able to directly edit in the report.

13 Click Close to exit the Custom Report Column Configuration dialog box.

14 Click Cancel to exit the Reports dialog box.



To view a report

1 On the Database menu, click Report, or click the Database Report button on the Standard toolbar. The 
Database Report dialog box appears.

2 Click the Reports page tab. 

3 Click the report you want to view, then click Report to display the report. If no reports appear in the list, you 
must create a new report.

4  (optional) Click the Total button to total the columns of the report.

5  (optional) Click the Print button to print the report.

6  (optional) Click the Copy button to copy the report data to the Clipboard.

7 (optional) Click the Export button save the report data in a .CSV file.

8  (optional) Click the Sort button to change the order for the report fields. The Sort Entries dialog box appears 
(see the following procedure).

9 Click Close to exit the Reports dialog box.



To sort entries in a detail report or summary report

1 Use the preceding set of steps to create a report.

2  Click the Sort button. The Sort Entries dialog box appears.

3 Click a column from the Column drop-down list box on the Primary Key section of the Sort Entries dialog box. 
This specifies the main field to use in deciding the order in which to place items.

4 Click Ascending or Descending from the Order drop-down list box.

5 Click the data type for values in the column from the Type drop-down list box.

6 Repeat steps 3-5 on the Secondary Key side of the dialog box. In the event that there are identical 
occurrences of the Primary Key, this controls what order those symbols are listed in.

7 Click OK.

Tip
You can click a column heading to sort by a single column in ascending order, or click again to sort in 

descending order.



Organizing Reports

AutoSketch reports can be stored in two manners: locally or globally. A local report is stored with a particular 
drawing, while a global report can be used in multiple drawings. The information stored in the local report can be 
about a particular drawing, or a smaller version of a global report containing only information relevant to a 
particular drawing. 

A global report is designed to be used in multiple drawings. Global reports are useful for compiling similar 
information from a variety of sources. For instance, if you have multiple drawings for each floor of an office, you 
can create a global report based on the same data fields, without having to create an individual report for each 
drawing. 
    Related Topics



To organize global and local reports

1 On the Database menu, click Report or click the Database Report button on the Standard toolbar. The 
Database Report dialog box appears. 

2 Click the Organize page tab. 

3 From the drop-down list, select the drawing in which you want to organize the reports. 

4 (optional) To copy a local report to a global report, click a report name, then click the >> button. 

5 (optional) To copy a global report to a local report, click the report name, then click the << button.

6 (optional) To rename a report, click the report name in either list box, then click Rename. Enter the new name 
in the Reports dialog box that appears.

7 (optional) To delete a report, click the report name in either list box, then click Delete. 

8 Click Close. 



Sending Information to Other Applications

You can send information stored in your drawings to other applications. AutoSketch allows you to send the 
information contained in a report or to export all of the stored values for selected entities. To send the information 
displayed in a report, you copy the report and paste it in a Windows application that supports the Clipboard, such 
as a spreadsheet, database, or word processor. To export all of the data for a selection set, you create an export 
file. AutoSketch allows you to create export files in the following formats:

Comma Separated Value (*.CSV): ASCII file where commas separate data items.
Microsoft Excel (*.XLS): Native Microsoft Excel binary file.
Fixed ASCII (*.SDF): ASCII file where data items are written as fixed width fields.

    Related Topics



To send a report to another application

1 On the Database menu, click Report, or click the Database Report button on the Standard toolbar. The 
Database Report dialog box appears.

2 Click the Reports page tab. 

3 Click the report you want to send and click Report to display the report.

4 Click the Copy button.

5 Click Close.

6 Switch to the Windows application where you want to paste the report.

7 On the Edit menu, click Paste, or click the Paste button on the Standard toolbar. If your application does not 
support pasting Clipboard data in this manner, consult your application’s documentation for the exact 
procedure.



To export the data for selected entities

1 Select the entities whose data you want to export.

2 On the Database menu, click Options, or click the Database Options button on the Standard toolbar. The 
Database Options dialog box appears. 

3 Click the Format page tab. 

4 (optional) Check the Format Lengths, Angles, and Areas as Strings check box. This causes AutoSketch to 
export values for lengths, angles, and areas as string text rather than numbers.

5 (optional) Check the Automatically Calculate Width and Precision check box. This limits exported character 
strings and numeric values according to settings in the Field Setup dialog box. This option is ignored for 
Microsoft Excel files.

6 Click OK.

7 On the Database menu, click Export, or click the Export button on the Standard toolbar. The Export Database 
File dialog box appears.

8 (optional) In the Save As Type drop-down list box, click the format in which you want to export the data (your 
choice depends on what application you’re exporting to). The dialog box displays any files with the same 
extension.

9 (optional) Enter a new filename in the File Name text box. By default, AutoSketch uses the drawing filename.

10 (optional) Click a different drive and folder in the Save In drop-down list box, or enter the complete path in the 
File Name text box to save the data file to a different drive or folder.

11 Click Save.



Displaying Values in a Drawing

AutoSketch can display entity information directly in the drawing. Displaying data directly in the drawing is 
especially useful for schematics, maps, and floor plans where the physical location of an entity is a significant part 
of the drawing.

AutoSketch allows you to format the database value text. You can specify the text font, size, and color. You can 
also display the name of the field next to the values. This is helpful when it is not obvious what the value 
represents when it is written by itself.
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To display database values in a drawing

1 Select the entities whose database values you want to display.

2 On the Database menu, click Make Visible, or click the Make Visible button on the Standard toolbar.



To format the display of database values

1 On the Database menu, click Options, or click the Database Options button on the Standard toolbar. The 
Database Options dialog box appears. 

2 Click the Format page tab. 

3 In the Text Font drop-down list box, click a font.

4 Enter the text height in the Text Height text box.

5 In the Text Color drop-down list box, click a color.

6 Check the Display Field Names check box. When it is checked, AutoSketch displays the field name before 
each value.

7 Click OK.



To hide data fields and values

1 Select the entities whose fields and values you want to hide.

2 On the Database menu, click Make Invisible, or click the Make Invisible button on the Standard toolbar



Including AutoFields

Each time you place a new symbol, AutoSketch appends AutoField to the symbol instance. You can control 
whether these fields appear when you generate a visual report. These fields contain the following data:

Symbol Name    A text string that identifies the symbol. A symbol definition must have a value assigned to 
the Symbol Name field. To edit this field, click Symbol, Explore on the Draw menu. In the Symbol Explorer, click the 
symbol, then click Edit Fields and enter new values for this field.

Symbol Type    A text string designed to help you organize and classify your symbol definitions. A symbol 
definition does not have to include a value for the Symbol Type field. To edit this field, click Symbol, Explore on the 
Draw menu. In the Symbol Explorer, click the symbol, then click Edit Fields and enter new values for this field.

Symbol Description    A text string that describes the symbol in detail. A symbol definition does not have to 
include a value for the Symbol Description field. To edit this field, click Symbol, Explore on the Draw menu. In the 
Symbol Explorer, click the symbol, then click Edit Fields and enter new values for this field.

Symbol Fields    A set of database fields whose values were defined when the symbol was created. The 
fields become part of the database when you place the symbol containing them in your drawing. To edit this field, 
click Symbol, Explore on the Draw menu. In the Symbol Explorer, click the Drawings page tab, click the drawing, click 
the symbol, then click Edit Fields and enter new values for this field. Symbol fields are not considered AutoFields, as 
described in the following steps.

UID    A unique number that AutoSketch creates automatically for each entity in the drawing. All entities have 
a UID that distinguishes them from other entities. You cannot edit a UID value. It is important to include the UID field 
in a report you export to another application if you are planning to import the report back to the drawing. If AutoSketch 
does not find the UID fields for the entities, it cannot reassign the database information back to the entities in the 
drawing.

Hyperlink (URL)    An embedded operation that opens specific documents in the same or other applications. 
These documents can contain dynamic data such as text, image, audio, or video files. Hyperlinks are similar to topic 
jumps in a online help system. For more information, see Using Web Tools.
    Related Topics



To specify which AutoFields to display when fields are visible

1 On the Database menu, click Options or click the Database Options button on the Standard toolbar. The 
Database Options dialog box appears. 

2 Click the Format page tab. 

3 Check the check boxes next to any of the fields that you want to include with visible fields. Uncheck the check 
boxes next to the fields you want hidden.

4 Click OK.



Using Web Tools

The Web Edit tools in AutoSketch allow you to assign hyperlinks to objects in your drawings that point to web 
pages, other files stored on local servers, or on the Internet. Your Internet Browser can even be launched from 
AutoSketch. Hyperlinks are embedded operations that open specific documents in the same or other applications. 
These documents can contain dynamic data such as text, image, audio, or video files. Hyperlinks are similar to 
topic jumps in an online help system. 

Using the Web Edit tools, you can, for instance, create a hyperlink between an electrical outlet symbol in your 
drawing and a document detailing code specifications. You can also save your drawings as.DWF files and place 
them on web pages. These compressed, vector based files are completely accurate representations of drawing 
data. They are easier to generate than comparable bitmap images, and usually take less time to download. 

Once you have assigned several hyperlinks, you can use the Web Edit tools to browse the drawing for hyperlinks 
and to select entities, or groups of entities, based on shared URLs (Unique Resource Locators). A URL is a type of 
filename that provides access to any file directory that is accessible to the internet. 
    Related Topics



Assigning URLs

To assign URLs to an entity, or group of entities, in a drawing, simply select them and enter a URL in the Edit 
Hyperlink dialog box.

A URL doesn’t always have to include the complete path for the file you want to open. For instance, if you are 
linking to a website you should enter the entire website address including the “http://” prefix. Similarly, you should 
include the entire pathname of a document that has a different drive location and file folder. However, if you create 
a hyperlink to another drawing in the same directory and folder, you need only enter the complete drawing name 
and AutoSketch use the current drawing’s path settings.

Tip
You can check the validity of a URL address by clicking Run on the Windows Start menu. Just enter the 

address in the Open text box, and click OK. If it’s a valid address, Windows will open the document.
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To assign a URL to an entity or group of entities

1 Select the entity or entities to which you want to assign the hyperlink.

2 Click the Hyperlink Edit button on the Standard toolbar. The Edit Hyperlink dialog box appears.

3 Enter the URL address in the Hyperlink (File or URL) text box, then click OK. The entities are now hyperlinked 
to the file you specified. 

Note
If you drag the pointer from left to right, only entities that are completely inside the region are selected. If you 

drag the pointer from right to left, even entities that are partially inside the region are selected.



To modify a URL 

1 Select the entity, or group of entities, whose URL you want to modify. 

2 Click the Hyperlink Edit button on the Standard toolbar. The Edit Hyperlink dialog box appears. 

3 Enter the URL address in the URL text box on the edit bar, then press ENTER. Each entity selected is 
hyperlinked to the file you specified.



Browsing Hyperlinks

AutoSketch provides an easy method to view the hyperlinks already contained in a drawing. Using the Browse 
Hyperlinks button the Standard toolbar, you can easily determine which entities are hyperlinked, by passing over 
them with the pointer. The URL address is displayed on the edit bar. 
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To browse the hyperlinks in a drawing
Click the Browse Hyperlinks button on the Standard toolbar, then move the pointer over entities in the 

drawing. Those entities which are hyperlinked are highlighted and the attached URL address is displayed on the edit 
bar. 

Note
Entities which are placed on masked layers cannot be identified by the Browse Hyperlinks tool. For more 

information on controlling a layer’s visibility, see Organizing with Layers.



Using Hyperlink Jumps

Once you have assigned one or more hyperlinks , you can easily make the jump from AutoSketch to your target 
document. Data, such as text, dimensions, even bitmapped images can then be copied to the Windows Clipboard 
and pasted into the drawing. For more information, see Using the Clipboard & OLE or Tracing a Scanned 
Drawing. 
    Related Topics



To use a hyperlink jump
Select a hyperlinked entity in the drawing, then right-click. Click Jump to Hyperlink on the pop-up menu.

OR

1 Click the Browse Hyperlinks button on the Standard toolbar. The pointer becomes a browse tool.

2 Move the pointer over the drawing, noticing that items which have hyperlinks assigned to them appear 
highlighted when the pointer passes over them. 

3 Click one of the highlighted entities. AutoSketch opens the target application and the file you specified.

OR
Click the Hyperlink Jump button on the edit bar. 



Organizing With Layers

AutoSketch allows you to organize your drawing in multiple overlapping layers. Layers are the CAD equivalent of 
mylar sheets in conventional overlay drafting. They allow you to organize the entities in your drawing into groups 
in order to limit printing, display, or accidental modification. Layers give you additional flexibility and control, 
especially if your drawing is complex. A layer can be current, editable, background, or masked:

The current layer is the one that AutoSketch adds new entities to as you draw them.
An editable layer allows you to modify existing entities but does not allow you to add new ones. 
A background layer can be seen but not modified. 
A masked layer is not visible.

Each drawing file has its own layer structure. If you do not specify otherwise, all the entities in your drawing are on 
the same layer. When you merge a drawing, AutoSketch adds any layers in the merged drawing to the current 
layer structure.

The number and types of layers you use depends on the type of drawing you create. For an architectural drawing, 
you might create separate layers for structural elements, electrical devices, plumbing, and so on. You can then 
display and hide layers as you need them to remove clutter and improve AutoSketch’s speed.
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Adding or Editing a Layer

You add and edit layers using the Graphic Options dialog box. Adding a layer is as simple as giving it a name. You 
can also include an expanded description of the layer.

You can assign a pen color, style, and width for each layer. Entities on that layer can use these “by layer” 
properties or you can assign properties to these entities individually. For information on assigning properties, refer 
to Pen and Pattern Properties.
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To create a new layer

1 On the Tools menu, click Graphic Options, or click the Graphic Options button on the Standard toolbar. The 
Graphic Options dialog box appears. 

2 Click the Layer page tab. 

3 Enter a unique name for the new layer in the Layer Name text box.

4 (optional) Change the Color, Style, and Width settings in the Layer Properties section.

5 Enter a description for the new layer in the Layer Description text box.

6 Click Add.

7 Click Close.

8 In the Layer drop-down list box on the property bar, click the new layer.

Tip
You can also open the Graphic Options dialog box by placing the pointer over the Layer drop-down list box 

box on the property bar, right-click, and click Layer Properties on the pop-up menu.



To change the color, style, and width for a layer

1 On the Tools menu, click Graphic Options, or click the Graphic Options button on the Standard toolbar. The 
Graphic Options dialog box appears.

2 Click the Layer page tab. 

3 From the list of layer names, click the layer you want to modify. To select more than one layer, press SHIFT or 
CTRL and click again.

4 Select a different color, line style, and line width in the Layer Properties section.

5 Click Change.

6 Click Close.

Tip
You can also open the Graphic Options dialog box by placing the pointer over the Layer drop-down list box 

box on the property bar, right-click, and click Layer Properties on the pop-up menu.



Making a Layer Current

When you add an entity to a drawing, you place it on the current layer. The current layer is like an editable layer 
except that it is the layer that new entities are added. You click the current layer using the Layer drop-down list 
box on the property bar or the Graphic Options dialog box. There can be only one current layer at any given time. 
When you make a layer current, AutoSketch makes the old current layer editable.

When you first install AutoSketch, there is only one layer. As you create new layers, AutoSketch adds them to the 
drawing and new layers are displayed on the property bar and in the Graphic Options dialog box.
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To select which layer to draw new entities on
In the Layer drop-down list box on the property bar, click the layer name.



To make any layer current using the Graphic Options dialog box

1 On the Tools menu, click Graphic Options, or click the Graphic Options button on the Standard toolbar. The 
Graphic Options dialog box appears.

2 Click the Layer page tab. 

3 Select the layer you want to place new entities on.

4 Click the Current option button in the Layer State section.

5 Click Change.

6 Click Close.



Moving Entities to Another Layer

You can move entities to any current or editable layer. The selected entities do not need to belong to the same 
layer. When you move entities to a new layer, AutoSketch makes the new layer the current layer.

When checked, the Protect Layer Changes check box in the Graphic Options dialog box prevents you from 
selecting background and masked layers from the Layer drop-down list box on the property bar. This prevents you 
from inadvertently moving existing entities to a protected layer. If you uncheck this check box, you will be able to 
use the property bar to move an entity to any layer at a cost of some security to background and masked layers. 
Otherwise, you need to make any background or masked layer editable using the Graphic Options dialog box 
before you can move the entities.
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To move entities to a different layer

1 Select the entity or entities you want to assign to another layer.

2 Select the new layer from the Layer drop-down list on the property bar.



Protecting Layers from Changes

You can protect layers from editing by making them background or masked layers. Background layers are visible 
in the current drawing, but cannot be edited. Masked layers are hidden from view and also cannot be edited. You 
can make any layer a background or masked layer as long as one layer remains current.

Because entities on a background layer are still visible, you can use the entities on these layers for reference in 
drawing other entities. Snap modes that require you to click an existing entity, such as endpoint or on-item, 
continue to operate for entities that reside on background layers. You can specify a color for entities on 
background layers that will override the entity color to distinguish entities on the background layer from editable 
entities.
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To make an entire layer visible but not editable

1 On the Tools menu, click Graphic Options, or click the Graphic Options button on the Standard toolbar. The 
Graphic Options dialog box appears.

2 Click the Layer page tab. 

3 Select an existing layer to modify from the list of layers. To select more than one layer, press SHIFT or CTRL 
and click again.

4 In the Layer State section, click the Background option button.

5 (optional) On the Background Layer Color drop-down list, click a color to substitute for entities on background 
layers.

6 Click Change.

7 Click Close.



To hide a layer from view

1 On the Tools menu, click Graphic Options, or click the Graphic Options button on the Standard toolbar. The 
Graphic Options dialog box appears.

2 In the list of layers, click the layer you want to hide. To select more than one layer, press SHIFT or CTRL and 
click again.

3 Click the Masked option button in the Layer State section of the dialog box.

4 Click Change.

5 Click Close.



To unprotect a layer, making it editable

1 On the Tools menu, click Graphic Options, or click the Graphic Optiosn button on the Standard toolbar. The 
Graphic Options dialog box appears.

2 Click any masked or background layers in the list of layers. To select more than one layer, press SHIFT or 
CTRL and click again.

3 Click the Editable option button in the Layer State section of the dialog box.

4 Click Change.

5 Click Close. 



Duplicating Entities

AutoSketch allows you to select an entity and duplicate it to very exacting specifications. You can create a single 
copy of the entity and draw it parallel to the original. Using this method, you can place the duplicate visually or 
with the aid of any combination of snap modes or lock modifiers. A variation of this method, called offset, allows 
you to create a duplicate parallel entity at a specified offset distance. You can repeat this method at the same 
offset distance, or specify a different one. For information on creating a duplicate entity while making a 
transformation, refer to Moving, Rotating, and Resizing Entities. 

Another method of duplicating entities creates multiple copies of selected entities and arranges them in a specific 
pattern called an array. An array created using AutoSketch can contain any number of copies and you can specify 
the exact size and shape of the resulting array.
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Parallel Placement of Duplicate Entities

AutoSketch allows you to specify parallel placement of lines, polylines, polygons, circles, and arcs. When you 
duplicate them, each entity type has similar results. AutoSketch creates a duplicate line, arc, or polyline parallel to 
the original. Duplicated polygons and circles assume the exact shape of the original except they are larger or 
smaller. Duplicated arcs and circles share the same centerpoint.

You can use either of two methods to create duplicate parallel entities. If you click Duplicate, Parallel on the Draw 
menu, AutoSketch allows you to specify the original entity in your drawing, then creates a rubber-band parallel 
duplicate entity. You can visually place the duplicate entity or use any combination of snap modes and lock 
modifiers to help position it exactly. If you click Duplicate, Offset on the Draw menu, AutoSketch allows you to 
select an entity in your drawing and create and duplicate it at a specific offset distance. AutoSketch displays the 
Offset Distance text box on the edit bar each time you click Duplicate, Offset on the Draw menu. You can use the 
existing setting or specify a new one. If you change the Offset Distance setting, the distance you enter remains in 
affect for future offsets until you change it again, or end the session. Where you position the pointer while clicking 
on the original entity determines where AutoSketch creates the duplicate entity. For example, positioning the 
pointer on, but above the original entity creates the duplicate above the original.

Once you create a duplicate parallel or offset entity, it becomes a separate independent entity. You can edit, move, 
or delete either the original or the duplicate without affecting the other.

Creating an offset or parallel duplicate of a polyline or polygon differs slightly from doing the same thing with lines, 
arcs, and circles. Holding CTRL while clicking on a segment causes AutoSketch to duplicate a single segment 
rather than the entire entity.
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To create a parallel line, arc, or circle

1 On the Draw menu, click Duplicate, Parallel, or click the Parallel button on the All-In-One toolbar.

2 Click the line, arc, or circle you want to duplicate. A rubber-band entity follows the movement of the pointer.

3 Position the rubber-band entity in the new location and click.



To create a duplicate line, arc, or circle that is offset at a specific distance

1 On the Draw menu, click Duplicate, then click Offset, or click the Offset button on the All-In-One toolbar.

2 (optional) Enter a new value in the Offset Distance text box on the edit bar and press ENTER.

3 Position the pointer on, and slightly toward the side where you want AutoSketch to create the new entity and 
click. Notice that a rubber-band entity follows the movement of the pointer. 



To create a parallel polyline or polygon

1 On the Draw menu, click Duplicate, Parallel, or click the Parallel button on the All-In-One toolbar.

2 (optional) Press CTRL to duplicate a single segment.

3 Click the polyline or polygon you want to duplicate. A rubber-band entity follows the movement of the pointer.

4 Position the rubber-band entity in the new location and click.



To create a duplicate polyline or polygon that is offset a specific distance

1 On the Draw menu, click Duplicate, Offset, or click the Offset button on the All-In-One toolbar.

2 (optional) Enter a new value in the Offset Distance text box on the edit bar and press ENTER.

3 (optional) Press CTRL to duplicate a single segment.

4 Position the pointer on, and slightly toward the side where you want AutoSketch to create the new entity and 
click. Notice that a rubber-band entity follows the movement of the pointer.



Creating Patterns of Duplicate Entities

Many types of drawings make it necessary to use the same entity in several instances that create a pattern, such 
as a row of bolts or a circular pattern of holes. An easy way to create a pattern of entities is to create an array. An 
array is a pattern of identical sets of entities. There are three types of arrays: linear, rectangular, and circular. In a 
linear array, the identical sets fall on a straight horizontal or vertical line. In a rectangular array, AutoSketch places 
the sets in rows and columns, forming a grid-like pattern. This is a useful feature for creating rows and columns of 
identical, evenly or irregularly spaced, copies of an entity or a group of entities. When creating a circular array, 
AutoSketch arranges the identical sets on a series of concentric rings. This is a useful feature for creating radial 
patterns of entities in identically even or irregular intervals.

The array may force the entities upright or rotate them around its center. Each time you create an array you have the 
option to generate the array as an anonymous symbol. If you have included symbols in the selection set, the result is 
an anonymous nested symbol one that contains multiple instances of the same symbol(s). For information on 
anonymous symbols, see Symbols.
There are two types of duplication spacing for arrays: regular and irregular. Regular spacing always results in copies 
with equal spacing. It requires only that you enter the number of copies you want and a spacing interval. Irregular 
spacing requires that you enter an expression that specifies the spacing interval for each copy. Regular spacing is 
easier to use, while irregular spacing provides greater flexibility.
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Creating Linear and Rectangular Arrays

A linear array might be useful when drawing a row of rivets. You might use a rectangular array of squares to draw 
the buttons of a push-button phone. In either instance, you could draw the entities one at a time but it is much 
faster to create them using an array.

To add a new linear array or a rectangular array to your drawing you must select an entity in the drawing that you 
want to duplicate. On the Edit menu, click Transform, Rectangular Array to open the Rectangular Array dialog box 
and set the controls for how the array appears.

The Horizontal Duplication controls allow you to determine the number of copies and the distance between them 
along the horizontal axis. The default setting for the number of duplicates is 1 copy. Entering 3, creates an array of 
4 entities horizontally the original plus 3 copies. Each copy is drawn adjacent to the previous. AutoSketch enters 
a default spacing between the entities that equals the horizontal width of the selection set. You can increase or 
decrease this setting as needed. The spacing between copies can be regular or irregular. For information on 
creating arrays with irregular spacing, refer to Specifying Irregular Spacing in Arrays. 

The Vertical Duplication controls allow you to determine the number of copies and the distance between them 
along the vertical axis. These controls follow the same general criteria as those for horizontal duplication.

The Selection Set area of the dialog box displays the minimum and maximum coordinates of the selection set. 
The Minimum XY display shows the drawing coordinates of the lower left corner of the current selection set. The 
Maximum XY display shows the drawing coordinates for the upper right corner of the current selection set.

As you create an array of entities, you can save the array as a symbol. This allows you to reuse it without having 
to create the array again. Checking the Create Symbol check box saves the resulting array as a symbol named 
RArray followed by a unique number. Symbols created using this method can be reused in the current drawing. To 
reuse this symbol in another drawing, you need to save it to a symbol library by clicking Symbol, Create on the 
Draw menu. For information on creating and saving symbols, see Symbols.
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To create a rectangular array at regular intervals

1 Select the entity or entities you want to duplicate.

2 On the Edit menu, click Transform, Rectangular Array, or click the Rectangular Array button on the All-In-One 
toolbar. The Rectangular Array dialog box appears.

3 In the Horizontal Duplication section, on the row that includes the Regular option button, enter the number of 
copies you want to add horizontally in the first text box, then press TAB.

4 Enter the interval distance between each copy in the second text box.

5 In the Vertical Duplication section, on the row that includes the Regular option button, enter 0 in the first text 
box and press ENTER to add the new entities. The selection set remains the same so that it can be duplicated 
elsewhere.



Creating Circular Arrays

Often, entities in a drawing must form a circular pattern. For instance, you might use a circular array of hex nut 
symbols to illustrate the lug nuts on a wheel. You could draw and position each entity, but it’s much faster to create 
the pattern using an array.

To add a new circular array to your drawing you must first select an entity or group of entities in your drawing that 
you want to duplicate. For information on selecting entities, see Selecting and Deleting Entities. On the Edit menu, 
click Transform, Circular Array to open the Circular Array dialog box and set the controls for how the array 
appears.

The center of a circular array is the point about which AutoSketch generates the circular array. You can specify the 
location of the center of a circular array by directly entering absolute world coordinates or by entering a point after 
you set the controls and click OK. Another option allows AutoSketch to adjust the position of the centerpoint so it 
aligns horizontally with the basepoint of the selection set.

The Radial Duplication settings allow you to specify the distance between each “ring” of new entities. This setting 
is the distance from the basepoint of the original entity to the basepoint of the next radial copy. You can specify the 
number of rings at even spacing or the number of rings at irregular spacing. 

The Angular Duplication settings determine the number of copies and the angles AutoSketch uses to place copies 
of the selection set around the center of the array. You can specify regular placement by defining the number of 
copies and the relative angular spacing, or irregular placement by defining the number of copies and their irregular 
placement. For information on specifying irregular expressions, refer to Specifying Irregular Spacing in Arrays.

The location of the basepoint of the selection set greatly affects the results of a circular array. The Basepoint of 
Selection Set drop-down list box allows you to specify the location of the basepoint for the current selection set. 
The default basepoint is the standard about point of the selection set. You can change the basepoint to the lower-
left corner of the selection set extent, or to a point you enter after clicking OK.

AutoSketch allows you to determine whether the selection set is rotated as it is copied. This feature is useful if you 
want all the entities to be oriented the same way, such as a circular array of chairs that all face the front of the 
room. When Keep Upright is checked, each copy of the selection is not rotated as it is copied. When it is 
unchecked, AutoSketch rotates each copy about the centerpoint as it is copied.

The Circular Array dialog box also contains controls that display the minimum and maximum coordinates of the 
selection set extent. This control is equivalent to the same area in the Rectangular Array dialog box. For 
information on these controls, refer to Creating Linear and Rectangular Arrays.

As you create a circular array of entities, you can save the array as a symbol. This allows you to reuse it without 
having to create the array again. Choosing the Create Symbol option saves the resulting array as a symbol 
named CArray followed by a unique number. Symbols created using this method can be reused in the current 
drawing. You can edit the symbol’s name or save it to a symbol library for reuse in other drawings by clicking 
Symbol, Create on the Draw menu. For information on creating and saving symbols, see Symbols.
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To create a circular array at regular intervals

1 On the Edit menu, click Transform, Circular Array, or click the Circular Array button on the All-In-One toolbar. 
The Circular Array dialog box appears.

2 Specify the center of the array by either entering absolute coordinates in the XY text boxes or by clicking the 
Select after OK option button.

3 (optional) Check the Align Horizontally with Basepoint check box.

4 Enter the number of rings in the first text box in the Radial Duplication section, then press TAB.

5 Enter the interval distance in the second text box.

6 (optional) Check the Keep Upright check box.

7 (optional) Check the Create Symbol check box.

8 Click OK.

9 Enter a point in the drawing to serve as the center of the array if you clicked Select after OK in step 2.



Specifying Irregular Spacing in Arrays

The distance between entities in arrays does not have to be evenly spaced. You can specify irregular spacing 
between columns, rows, or rings in an array.

To use irregular duplication, click the Irregular option and enter an irregular expression into the text box. An 
irregular expression is a series of numbers and special operators separated by spaces. AutoSketch evaluates 
each number as distance or angle in the current units of measurement. With irregular spacing, you have complete 
control over the spacing used in any type of array. 

By default, AutoSketch evaluates irregular expressions in absolute mode. In absolute mode, the value entered is 
unaltered. In relative mode, the value is added to the previous one (i.e., relative to last). To switch to relative 
mode, enter “++” in the expression separated by spaces. Type “++” again to return to absolute mode.

The following irregular expression contains an example of changing to relative mode and back:

1 2 +   + 1 1 +   + 5

Entering every number for a large array is a tedious operation. Irregular expressions support loops and repetitions 
to abbreviate patterns of numbers. A loop is a series of numbers between a starting and ending value. A repetition 
is the same value repeated a number of times.

A loop places all of the numbers between a starting value and an ending value in the irregular expression. The 
loop can be entered anywhere in the irregular expression. The operator “to” separates the starting and ending 
values. The following example illustrates a loop:

1 to 10

The preceding irregular expression is equivalent to the following numeric series:

1 2 3 4 5 6 7 8 9 0

In addition, you can have the loop count by an interval other than one. The following irregular expression 
illustrates a loop that counts in an interval of 4.

4 to 12 by 4

The preceding irregular expression is equivalent to the following numeric series:

4 8 12

A repetition is a list of numbers with the same value. AutoSketch allows repetitions in absolute mode, but only 
creates unique values in relative mode where each repeated number is equal to the sum of itself and the previous 
value. To use a repetition, insert the repetition operator “@” to separate the number of repetitions and the number 
to repeat. The following numeric list creates the same list of values in the previous example:

4 + + 2 @ 4

In addition, each number in the list can be an expression. Putting them all together, the following expression 
illustrates the series 0 to 100 by 10, the hard way:

3/3-1 10 to 30 by 10 5*8 + + 3 @ 10 + + 80 to 100 by 10
    Related Topics



To enter an expression that defines irregular spacing in an array

1 On the Edit menu, click Transform, Rectangular Array or Circular Array, or click the Rectangular Array or 
Circular Array button on the All-In-One toolbar. The Rectangular Array or Circular Array dialog box appears.

2 Click the Irregular option button for the control where you want to specify irregular spacing.

3 Enter the expression, then press ENTER.



Importing and Exporting

Often, it is necessary to use an AutoSketch drawing in another application or to import a drawing created by 
another application into AutoSketch. Perhaps a colleague sends you a drawing created in another application and 
you want to make changes to it in AutoSketch. In these and similar situations it is important to know how to import 
and export drawings.

In AutoSketch, there are several ways to exchange drawing data with another application. Each time you transfer 
data, select the one that works best for that drawing. See Using the Clipboard & OLE for information on 
transferring information using the Windows Clipboard and OLE.

Import and export filters are the most accurate and reliable means of transferring drawings, but they are also the 
slowest. Use filters for large, complex drawings.
    Related Topics



Using Import and Export Filters

A filter converts a drawing file from one format to another. File filters work with the broadest range of applications, 
but they are the slowest method of conversion. Use them for importing large drawings or when you need to get 
the most accurate conversion of the original file.

Each file type supported by AutoSketch stores drawing information in a slightly different way. Knowing how 
AutoSketch handles these differences can help you track down file conversion problems. This section tells how 
each of the following conversion filters works in AutoSketch:

AutoCAD files (DWG and DXF)
Drafix Port Files (POR)
Hewlett Packard Graphics Language files (PLT and PRN)
AutoCAD Drawing Web Format files (DWF)
AutoSketch for Windows Release 2.0 and 2.1 files(SKD)
Windows Metafiles (WMF)

    Related Topics



To export a drawing using a filter

1 On the File menu, click Save As. The Save Drawing File dialog box appears.

2 In the Save as Type drop-down list box, click a file type.

3 Enter a name in the Filename text box. AutoSketch automatically adds the appropriate extension.

4 Click Save.



To import a drawing using a filter

1 On the File menu, click Open, or click the Open button on the Standard toolbar. The Open Drawing File dialog 
box appears.

2 In the Files of Type drop-down list box, click a file type.

3 Enter a name in the Filename text box or browse in folders until the filename you want appears, then click the 
name.

4 Click Open.



AutoCAD Conversions

AutoSketch imports and exports AutoCAD Drawing Interchange (DXF) files and exports AutoCAD’s native drawing 
(DWG) files as Release 14 files. The DXF filter reads all versions through AutoCAD Release 14 and AutoCAD LT 
97. Two DXF filters are provided when saving a file so you can create either Release 12/LT 2 or Release 14/LT 97 
files. Entities are converted as follows:

When you import DXF (or DWG) files, AutoSketch ignores objects it does not recognize (that is, objects that have no 
equivalent in AutoSketch). Entities ignored on import include 3D Solid, Body, feature control frames, OleFrame, 
Region, PolyFaceMesh, PolyMesh, Proxy, Viewport, and Shape. Similarly, external references, applications, elevation 
(z coordinates), extrusion direction, thickness, and XDATA are ignored on import.

The following conversions occur when exporting to DXF or DWG:
Dimensions are exploded into sub-entities so their visual integrity is preserved.
Hatches are converted to anonymous symbols containing the individual line segments.
Properties like pixel width are ignored.

The following limitation should be observed when creating files in AutoSketch if you plan to export them to 
AutoCAD.    Especially if you plan to bring the file back into AutoSketch.

Limit names to alphanumeric characters without blanks for layers, fields, symbols, etc.
Use only standard AutoCAD line types (styles) and hatch patterns.
Do not use CAD vector fonts.    Use only TrueType fonts included with AutoCAD equivalent SHX or 

TTF.
Do not use pixel width for entities.
Do not use fields assigned to entity types other than symbols.

    Related Topics



Drafix Port File Conversions

AutoSketch both imports and exports Drafix Port files. AutoSketch dimensions are converted to base entities when 
you export these file types. AutoSketch converts other entities as follows:

    Related Topics



HPGL and PLT Conversions

AutoSketch can import Hewlett Packard Graphics Language (HPGL) files. These files usually have a PLT or PRN 
extension. AutoSketch can import both basic and extended HPGL files, as well as HPGL2 files, though not all 
commands are converted to entities. AutoSketch places all entities on a single layer and assumes a scaling factor 
of 1 to 1. AutoSketch uses the following entity conversions when importing HPGL files:

To export an HPGL file, select an HP plotter as your Windows output device and print to a file.
    Related Topics



DWF Conversions

AutoSketch allows you to export drawings as AutoCAD Drawing Web Format (DWF) files. This format is useful if 
you want to publish your drawings on the World Wide Web because others can then view your drawing (even 
zooming in on specific locations) without using a CAD application. To view a DWF file, you must use either 
Netscape Navigator or Microsoft Internet Explore with the Autodesk WHIP!ª Plug-In. This plug-in can be 
downloaded for free at http://www.autodesk.com.

Wide polylines and polygons drawn in AutoSketch lose their width in the conversion and some entities such as 
curves and bulges are converted to polygons. All other entities are converted as follows:

    Related Topics



SKD Conversions

The SKD import filter supports only AutoSketch for Windows Release 2.0 and 2.1 (version 12 and 13 database 
files), hereafter described as AutoSketch Classic. Older files are not previewed in the File Open dialog box and 
will display an error message when selected.

As entities in an SKD file are read, they are converted to standard Release 5 entities. Entities which have a 
matching entity type include lines, arcs, circles, text, bitmaps, dimensions, poly-entities, and points (markers). The 
biggest differences fall into two categories: entities which have no equivalent, and differences in properties.

AutoSketch Release 5 has no ellipse or bezier curve. Ellipses are converted to polylines (or polygons, if closed). 
Bezier curves are converted to fitted curves with additional points added for visual integrity. The b-spline curve is 
converted to a spline curve which has some (usually) slight variation in parametrics, but keeps the control points, 
or vertices, intact. Regular polygons with greater than 32 points are converted to irregular polygons. Groups, 
menu strips, buttons, and bars are ignored. Entities within groups are added to the drawing as base entities.

AutoSketch Release 5 applies pattern (solid fill, none, hatch) to the interior of closed bounded areas of polygons. 
Further, wide polylines are solid filled with the pen color assigned to the entity. AutoSketch Classic assigned 
pattern to the interior of the width of wide entities. An attempt was made to keep entity integrity for these wide 
entities. A wide line, wide arc, wide circle, wide ellipse, wide elliptical arc are converted to a polyline with width 
(and bulges as appropriate). In these cases, the overall geometry will be the same but the interior pattern will be 
lost. In addition, SKD files contain a separate entity type for fills. Fill entities are converted to polygons with the 
appropriate pattern applied and all edge segments hidden. Release 5 does not support bitmap fill patterns which 
are converted to similar standard hatch patterns.

AutoSketch Release 5 does not support SHX (AutoCAD Shape file) fonts. All fonts are mapped to True Type fonts. 
There will be some variations in placement and sizing because of the difference in fonts. All the TrueType fonts 
available with AutoCAD R14 are included for compatability. All the hatch patterns from Classic are included in the 
SKETCH.PAT file. If you have your own custom hatch patterns they will need copied to the Property folder.

Header variables are converted to drawing variables as appropriate. AutoSketch Release 5 does not support 
linear units for yards, miles, points, and kilometers; if any of these are the default then another is used (feet, feet, 
inches, and meters, respectively). If you were using no units, or custom units, you will need to scale the entities, 
using Transform Scale, to resize the data into inches if you want dimensioning, the dial, entity geometry, etc., to 
be correct.

The internal linear units for AutoSketch Classic was meters. The internal linear units for AutoSketch Release 5 is 
inches. Angular internal units are radians in both.

After importing the drawing, an AutoFit command is executed to adjust the scale and origin so the entire drawing 
is visible. You can adjust the scale more precisely on the Scale page of the Drawing Options dialog box. You may 
also need to adjust the page size or orientation using the Page Setup command on the File menu since it will 
default to the current printer configuration.
    Related Topics



AutoSketch Release 1.0 Conversions
If you have an AutoSketch Release 1.0 or other AutoSketch DOS-based drawing file that you want to open in 
AutoSketch Release 5, you need to first open the file in AutoSketch Release 2.1. To obtain a copy of AutoSketch 
Release 2.1 for file conversions, call your local AutoSketch technical support number.

Once you have opened an AutoSketch Release 1.0 drawing file in AutoSketch 2.1, you need to resave the file. 
Saving the file in AutoSketch 2.1 automatically updates the file. Once the file is saved as a 2.1 file, simply follow 
the instructions in AutoSketch Release 5 documentation or online Help to open the file in AutoSketch Release 5.
    Related Topics



To open an AutoSketch Release 1.0 in AutoSketch 2.1

1 On the File menu, click Open, or click the Open button on the Standard toolbar.

2 Double-click the icon that represents the file you want to open, or select the file on the Active Filename drop-
down list box, and click OK. The file appears in the drawing window.



To save a drawing file in AutoSketch Release 2.1

1 On the File menu, click Save, or click the Save button on the standard toolbar. 

2 Select a directory and enter a filename, then click Save.



Windows Metafile Conversions

AutoSketch exports placeable Windows metafiles (WMF). AutoSketch converts exported drawings to an integer 
coordinate system and reduces the size of large drawings. In addition, AutoSketch converts symbols, dimensions, 
and markers to base entities when exporting WMF files. WMF supports all other AutoSketch entity types.

Metafiles support a much smaller entity set than a AutoSketch drawing, therefore imported drawings do not 
contain a number of entities, such as symbols, dimensions, and the like. 

    Related Topics



Using the Clipboard & OLE

In AutoSketch, there are several ways to exchange drawing data with another application, and use information 
from other applications in AutoSketch drawings. Each time you transfer data, select the one that works best in the 
current situation. Using the Windows Clipboard in a simple cut and paste procedure is the easiest way to transfer 
a drawing but often less accurate in applications other than CAD applications. Use the Clipboard when you want 
to convert simple drawings and information quickly.

Object Linking and Embedding (OLE) is a more advanced use of the Clipboard. It allows you to copy or move 
information from one application to another while still allowing you to edit the information or object using the 
original application. It also allows you to “package” your AutoSketch drawing so other Windows applications can 
display and print it but still allows you to edit the drawing using AutoSketch.
    Related Topics



Using the Clipboard

The Clipboard is the most basic means of transferring drawing data between applications. Most Windows 
applications offer some level of support for the Windows Clipboard and the three commands required to import 
and export drawings: Cut, Copy and Paste, on the Edit menu.

When you transfer drawings using the Clipboard, entity conversion is handled as though you used the Windows 
Metafile filter to import or export the data. For more information on how this file filter converts entities, refer to 
Windows Metafile Conversions.

In addition to the Windows metafile format, you can use the Clipboard to transfer a drawing as a Windows bitmap, 
when a marquee is defined. When you use this method, AutoSketch copies information directly from your screen.
    Related Topics



To export a drawing using the Clipboard

1 Select the entities you want to copy. If no entities are selected, all entities are copied.

2 On the Edit menu, click Copy, or click the Copy button on the Standard toolbar.

3 Make the destination document current.

4 On the Edit menu in the destination application, click Paste, or click the Paste button on the Standard toolbar.



To import a drawing using the Clipboard

1 From the source application, copy information to the Clipboard.

2 Switch to AutoSketch.

3 On the Edit menu, click Paste, or Paste Special if the source application is an OLE server.

4 Enter a point to establish the lower-left corner of the imported drawing.

Note
The Source application must copy a metafile to the Clipboard. When copying text, the text becomes a text 

entity if there is no metafile.



To export a drawing as a bitmap

1 Display the entities on the screen the way you want them to appear in the exported bitmap.

2 Configure the page, the reference grid, and so on as you want them to appear in the exported bitmap. If you 
do not want such components to appear in the bitmap, use Options on the View menu to disable them.

3 On the Edit menu, click Select, Marquee, or click the Marquee Select button on the All-In-One toolbar.

4 Draw a marquee that defines the portion of the AutoSketch display you want to include in the bitmap.

5 On the Edit menu, click Copy, or click the Copy button on the Standard toolbar.

6 Make the destination document current.

7 On the Edit menu, click Paste, or click the Paste button on the Standard toolbar.

Note
The destination application must accept bitmaps. 



Understanding OLE

Object Linking and Embedding (OLE) allows you to copy information from one Windows application, a source 
application or server, to a destination application, or container, creating a compound document that accepts OLE 
objects created by the server. The ability to edit the information using the server, or source application is retained. 
In simplified terms, OLE works much the same as an ordinary cut and paste transfer. In fact, cutting and pasting 
actually embeds an object using OLE. When you double-click a linked or embedded OLE object, Windows opens 
the source application that created it and loads the associated file.

It is important to note the difference between linking and embedding. Both linking and embedding insert the 
Clipboard information from one document to another, and the information can be edited in the compound 
document. However, the way the information is stored differs. 

When you link an object or document, OLE establishes a connection, or link, to information stored in a source, or 
server file. This means you can edit the original information and any changes you make are reflected in the 
compound document or drawing. Because this information is linked, it is necessary to retain access to the server 
application and document, establishing a new link if changes are made to the filename or location. Linking objects 
is a good way to maintain control over information that you plan to copy into several documents. Use linking to 
update dynamically as the information in the original file changes.

When you embed an object or document, OLE only inserts the information into the compound document. This 
means that there is no longer a relationship or connection between the original, or source, and compound 
documents. The embedded information, or object, becomes part of the compound document. You can edit the 
information you embedded using the application that created it, but editing the original document itself will not 
change the embedded object. Use embedding when you want to edit information separately from the original file, 
or if you think the original file will not be available. When an object or information is embedded, it means that all 
information is contained in one file and it may be easier to move or copy the entire file.

You can embed a AutoSketch entity by “dragging and dropping,” in addition to copying or cutting and pasting it in 
an OLE client application. To do this you simply select an entity or group of entities, drag it out of the AutoSketch 
application window, and “drop” it (release the mouse button) in another open application window. 
    Related Topics



Using AutoSketch drawings and Objects in Other Applications

An AutoSketch drawing or object can be linked or embedded into other applications. For instance, you can copy a 
diagram created in AutoSketch to a Microsoft Excel spreadsheet by linking or embedding the drawing itself, or an 
icon representing the linked drawing, directly into the spreadsheet. 
    Related Topics



Linking AutoSketch Drawings to Other Applications

You can link an AutoSketch drawing to other applications using the OLE Copy, Paste Special, and Paste Link 
commands, depending on the destination application, or container. The compound document then stores the 
referenced link that identifies the AutoSketch drawing file’s location. When you double-click a linked drawing in the 
compound document, it becomes grayed and contains diagonal lines to indicate that it is the active AutoSketch 
drawing. You can then edit the drawing in AutoSketch. 
    Related Topics



To link an AutoSketch drawing to another document

1 Save the AutoSketch drawing you want to link.

2 Set the drawing view, and click Select, All on the Edit menu to select all of the entities in the drawing.

3 On the Edit menu, click Copy. The AutoSketch drawing is copied to the Clipboard.

4 Open the container application and a new or existing file. The application that contains the document must be 
an OLE client.

5 Click a command in the container application that pastes the OLE object. In most applications this is either 
Paste Link or Paste Special on the Edit menu.



To edit a linked AutoSketch drawing in the destination document

1 Open the document that contains the linked drawing. 

2 Double-click the linked drawing or drawing icon. AutoSketch opens the drawing.

3 Make necessary changes to the drawing. 

4 On the File menu, click Save, or click the Save File button on the Standard toolbar, and return to the 
compound document. 



To edit a linked drawing in AutoSketch

1 Start AutoSketch and open the original, linked drawing.

2 Make necessary changes to the drawing.

3 On the File menu, click Save, or click the Save File button on the Standard toolbar, and return to the 
compound document. The next time the compound document is opened, the OLE item is updated. 



Embedding AutoSketch Entities in Other Applications

You can select AutoSketch entities and embed them in other documents using the Windows Clipboard. However, 
any changes you make to the embedded AutoSketch entities won’t be reflected in the original AutoSketch 
drawing.
    Related Topics



To embed AutoSketch entities in another document

1 Select the entities you want to transfer.

2 On the Edit menu, click Copy or Cut, or click the Copy or Cut button on the Standard toolbar.

3 Open the container application and a new or existing file. The application that contains the document must be 
an OLE client.

4 Click a command in the destination application that pastes the OLE object. In most applications this is either 
Paste, or Paste Special on the Edit menu.



To edit embedded AutoSketch entities

1 Open the compound document.

2 Double-click the embedded object. AutoSketch opens and displays the embedded entities.

3 Make necessary changes to the entities.

4 On the File menu, click Update, and return to the compound document.

Note
Any changes made to an embedded entity aren’t reflected in the original drawing that includes the 

embedded entities.



Dragging AutoSketch Entities into Other Applications

You can drag selected AutoSketch entities into other running applications. Dragging entities is the same as cutting 
and pasting, or embedding. The entities are permanently removed from AutoSketch and placed into the 
compound document. A drag-and-drop pointer appears when you drag selected entities over the destination 
document. 
    Related Topics



To drag AutoSketch entities into other application documents

1 Select the entities you want to cut.

2 Click and drag the entities to the compound document. It is helpful to have both AutoSketch and the container 
application running side-by-side, vertically positioned on your desktop, or drag the entities to the container 
application’s icon on the start bar. For more information on using the start bar, refer to Windows online Help. 

Tip
Press CTRL while dragging the entities to make a copy of the entity instead of permanently moving them. 



Using Information from Other Applications in AutoSketch

You can link or embed information from other OLE server applications into AutoSketch drawings. For example, 
you might want to insert a Microsoft Excel spreadsheet, or graphic created in Paint Shop Pro in an AutoSketch 
drawing. You can edit linked or embedded information or objects in AutoSketch by double-clicking the OLE Object, 
or by using tools on the OLE edit bar that appears when the object is selected. The information or objects from 
other applications can be placed in the drawing as an icon. Simply check the Display as Icon check box that 
appears when using Paste Special, and the application icon appears in the drawing in place of the embedded or 
linked object.
    Related Topics



Linking Objects and Information to an AutoSketch drawing

You can link objects from other applications, or create new linked objects starting from AutoSketch using the Insert 
Object and Paste Special commands. These links either reference an existing file, a newly created file, or 
information copied from the Clipboard.

Tip
When selected in AutoSketch, linked objects appear with dotted lines, while embedded objects appear with 

solid lines.
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To create and insert an embedded object starting from AutoSketch

1 On the Edit menu, click Insert Object. The Insert Object dialog box appears. 

2 Click the Create New option button. 

3 Click the type of object you want to insert from the Object Type list.

4 (optional) Check the Display as Icon check box to create an icon for the object in the drawing. To later open 
the object, simply double-click the icon. 

5 Click to place the object or icon in the AutoSketch drawing.

6 Click OK. The server application opens. (For instance, if you selected a Paint Shop Pro Image, Paint Shop Pro 
opens).

7 Create the object you want to insert in the server application, then (in most cases) click Update on the server 
application’s File menu.



To link an existing object to an AutoSketch drawing

1 On the Edit menu, click Insert Object. The Insert Object dialog box appears. 

2 Click the Create from File option button. 

3 Enter the filename in the File text box, or click Browse and locate the file. 

4 Check the Link check box to link the file to the drawing. If the Link check box is unchecked, an embedded item 
is created using the file contents.

5 (optional) Check the Display as Icon check box to display the object’s application icon in place of the actual 
object. To later open the object, simply double-click the icon. 

6 Click OK. 

7 Click to place the object or icon in the AutoSketch drawing.



To link information to an AutoSketch drawing using the Clipboard

1 Open the original object’s application and copy the information to the Clipboard.

2 On the Edit menu, click Paste Special. The Paste Special dialog box appears.

3 Click the Paste Link option button to create a link to the original file. (If you click Paste, the Clipboard contents 
will be embedded instead of linked). 

4 Click the data format you want to use from the As list box. If nothing appears on the list, linking is not possible.

5 (optional) Check the Display as Icon check box to create an icon for the object in the drawing. To open the 
object, simply double-click the icon. 

6 Click OK. 

7 Click to place the object or icon in the AutoSketch drawing.



Dragging Objects into AutoSketch 

You can drag objects from other running applications into AutoSketch. Dragging objects is the same as cutting and 
pasting, or embedding. The objects are permanently removed from the original document and placed into 
AutoSketch. 
    Related Topics



To drag objects into AutoSketch

1 Select the objects you want to cut.

2 Click and drag the objects into AutoSketch. It is helpful to have both AutoSketch and the other application 
running side-by-side, vertically positioned on your desktop.

Tip
Press CTRL while dragging the entities to make a copy of the entity instead of permanently moving it.



Updating, Breaking, and Changing Links

You can select whether AutoSketch updates drawings automatically or manually when information or objects in 
the source document changes. AutoSketch, by default, automatically updates linked information. 

You can break links to source documents when the link is no longer necessary. Breaking links does not affect the 
inserted information, it just breaks the connection between the information and the source document. 

You can update or change links when the source document location or filename information has changed.
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To manually update a link

1 On the Edit menu, click Links. The Links dialog box appears.

2 Click the link you want to update.

3 Click the Manual option button located at the bottom of the dialog box.

4 Click Update Now, then click Close. You must now update this link every time you make a change to the 
source document.



To break a link

1 On the Edit menu, click Links. The Links dialog box appears.

2 Click the link you want to break.

3 Click Break Link, then click Close.

Important
You cannot reconnect a link once it is broken.



To change a link

1 Select the linked object you want to change.

2 On the Edit menu, click Links. The Links dialog box appears.

3 Click Change Source. The Change Source dialog box appears.

4 Select the server file, and click OK. 



Converting OLE Objects or Information

Sometimes the application in which you created an embedded object is not installed on your computer. If this is 
the case, you can convert the object to a file format of an application you do have installed. For instance, if you 
embed a spreadsheet created in Microsoft Works, but do not have it installed on your computer, you can convert it 
to a format that you can open in Microsoft Excel, an application you do have installed on your system. 

Depending on the object or information you have linked or embedded in your AutoSketch drawing, a different set 
of converting options will appear. 
    Related Topics



To convert a linked or embedded object or information

1 Select the OLE object or information you want to convert.

2 On the Edit menu, click Convert Object, or click the Convert button on the edit bar. The Convert dialog box 
appears. 

3 Click the conversion option you want, then click OK. The OLE object or information is converted.



Using OLE Verbs

A drop-down list of OLE Objects or information verbs is located on the edit bar when the OLE object or information 
is selected. Depending on the OLE object you currently have selected, a varying list and number of verbs appear. 
These verbs allow you to edit, play, and so on, the selected OLE object. For instance, if you have a .WAV file 
embedded or linked in your AutoSketch drawing, verbs such as Play .WAV file, Edit .WAV file, and so on, appear. 
    Related Topics



To apply OLE verbs to an OLE object or information

1 Select an OLE object or information.

2 On the Edit bar, click the verb you want to use from the Verbs drop-down list.



Compass Angles & Bearings

AutoSketch recognizes three types of angle measurements: standard angles, compass angles, and bearings. It 
can display angles in degrees, minutes, degrees-minutes-seconds, radians, grads, and bearings.

You are probably already familiar with standard angles but may not be familiar with the other methods. Standard 
angles measure rotation counterclockwise from the x-axis. Compass angles measure rotation clockwise from the 
y-axis. Bearings measure rotation from north or south toward east or west.
    Related Topics



Standard and Compass Angles

The difference between standard angles and compass angles is the direction of rotation and the zero position. 
Standard angles measure rotation counterclockwise with respect to the x-axis. Compass angles measure rotation 
clockwise with respect to the y-axis. 

Standard and compass angles use the same notation. You specify the method used to interpret angular 
input on the Units page of the Drawing Options dialog box. You can enter standard or compass angles using 
any of the following notations:
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To switch angle measurement methods

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Units page tab.

3 In the Angle section, from the Orientation drop-down list box, click Compass or Standard.

4 Click one of the choices from the drop-down list box of angle unit types (e.g., Degrees, Radians, Grads).

5 Specify the decimal precision for displaying angular measurements.

6 Click OK.



Bearings

Surveyors, geologists, and map makers often express angles in terms of bearings. A bearing expresses an angle 
as rotation from north or south toward east or west. For example, a bearing might be 20 degrees from north 
toward east, or 20 degrees east of north. You can express certain bearings using a compass point, such as W or 
ENE. 

Bearings have a unique notation that AutoSketch recognizes automatically. Therefore, you can enter a bearing 
angle at any time without changing the angle input mode. Notation for bearings is as follows:

N|S degreesd [minutes’ seconds”] E|W

The first direction is either north or south (N or S). Degrees is the rotation angle toward the second direction, 
which is either east or west (E or W). If you want, you can use degrees-minutes-seconds notation. For example, 
you could express the standard angle 13û 52’ 15” as a bearing 76û 07’ 45” east of north. In AutoSketch, the 
notation for this bearing is as follows:

N76d07’45"E

Bearings always have a positive value, and their value may not exceed 90 degrees. 
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Using Numeric Expressions

A numeric expression is a mathematical formula that evaluates to a single number. For example, the expression 
2+2 evaluates to the number 4. AutoSketch lets you enter numeric expressions instead of a number in most edit 
bar and dialog box text boxes. Numeric expressions are particularly useful when you know how to calculate a 
number, but you don’t know the number itself.

You can use numeric expressions like a calculator. When you enter a numeric expression, you begin with an equal 
sign. At least one number must follow the equal sign, although you usually want to perform a mathematical 
calculation. If, for example, you need to enter a length that is one-seventh of 17.78, you could enter the following 
numeric expression:

= 17.78 / 7

The above example demonstrates the most common type of numeric expression, two numbers separated by an 
operator. An operator tells AutoSketch what mathematical procedure to perform. One such operator is the division 
operator, demonstrated in the example above. 

Aside from operators, you can create numeric expressions using numbers and functions. A function is a 
mathematical procedure that operates on a single value. For example, the following numeric expression uses a 
function to enter the square root of 52:

= sqrt(52)
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To enter a numeric expression

1 Place the insertion point in the text box that contains the value you want to change. If there is an existing 
value, select it.

2 Type an equal sign (=).

3 Add operators, numbers, and functions, as necessary, to complete the formula.

4 Press ENTER.

Note
When entering lengths, angles, or areas using a numeric expression, you must use the default units of 

measurement. AutoSketch displays an error message if you include characters representing units of measurement, 
such as “mm” for millimeters, in a numeric expression.



Using Existing Values in Numeric Expressions

Numeric expressions become powerful tools when combined with values displayed in text boxes. Many dialog 
boxes display default values that you can include in your numeric expressions. Edit bar text boxes display 
geometry when you edit entities and default values when drawing.

By including values displayed on the edit bar in a numeric expression, you can quickly and precisely modify an 
entity’s geometry. For example, to move a selected circle 11.73 inches to the right, enter “=11.73+” before the 
existing value in the X text box, remove the inch marker, and press ENTER.
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To enter an expression using an existing value

1 Place the insertion point in the text box that contains the value you want to change.

2 To remove any measurement notation, such as “mm” for millimeters, press END and then press BACKSPACE.

3 Press HOME.

4 Type an equal sign “=” and add operators, numbers, and functions, as necessary, to complete the formula.

5 Press ENTER.

Tip
You can press CTRL+C and CTRL+V to copy and paste values from one text box to another.



Using the Expression Calculator

AutoSketch provides the Expression Calculator dialog box to evaluate numeric expressions without entering a 
result in a text box. This dialog box is a handy built-in calculator, in addition to being a useful tool for evaluating 
formulas. You can open the Expression Calculator at any point without interrupting your current drawing or editing 
command.
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To display the result of a numeric expression

1 Type an equal sign (=). The Expression Calculator dialog box appears.

2 Enter a numeric expression in the Expression text box. An initial equal sign is optional in this dialog box.

3 Click Evaluate to display the result of the calculation.

4 (optional) Click Copy to copy the result to the Clipboard.

5 Click Close.



Components of a Numeric Expression

A numeric expression is made of up to three components: numbers, operators, and functions. All numeric 
expressions must contain at least one number. Functions require one number and most operators require two.

Numbers    AutoSketch supports both integers and numbers with decimal values. A number must contain at least 
one digit. Numbers can also contain an exponent. Exponents are preceded by the letter e (or E). If an exponent 
has no sign, AutoSketch assumes it is positive. Each of the following is a valid number:

7.2

-5

2.323e-5

Numbers in AutoSketch are double-precision floating point numbers. That is, positive and negative numbers with 
up to 14 significant figures. AutoSketch performs all calculations for an expression at the maximum possible 
precision.

Operators    An operator performs a mathematical procedure on one or two numbers. To use an operator, enter 
the first number, then the operator, then the second number. AutoSketch supports the following mathematical 
operations:

*This operator allows you to enter lengths in feet and inches only if your current units of measurement is inches or feet-inches. It 
multiplies the first number by 12 and adds the second number.

Functions    A function is a built-in procedure that acts on a single value. You can use the following functions in a 
numeric expression:



*This function returns an angle using the current angular units of measurement (typically degrees).
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Combining Multiple Operators and Functions

AutoSketch supports complex numeric expressions consisting of multiple operators and/or functions. This is 
useful for evaluating formulas that require several levels of computation. To work with complex expressions, it is 
important to understand the order in which AutoSketch carries out the calculations.

Any operators enclosed in parenthesis are evaluated first. If you use two or more operators in the same 
expression that have equal precedence, such as addition and subtraction, AutoSketch evaluates that part of the 
numeric expression from left to right. AutoSketch uses the following order of precedence for operators.

1 exponentiation (^) and feet to inches conversion (    '    )

2 negation ( - )

3 multiplication ( * ) and division ( / )

4 addition (+) and subtraction ( - )
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Tracing in AutoSketch

You may have a rendering, blueprint, or model in the form of a paper drawing, that you need to convert to CAD 
form. You can trace the original from either of two sources: a raster image or a digitizer tablet. Using snap modes 
and lock modifiers, you can match the relative positions of objects in the original drawing with a high degree of 
accuracy. 
    Related Topics



Tracing a Scanned Drawing

If you have access to a scanner, you can create a bitmap version of an existing drawing. You can place this raster 
graphic, or multiple raster graphics, on a drawing page and trace it, using the same tools and methods you would 
use to create any drawing. In this way, you convert a collection of colored pixels to vector, or “draw” graphics, in 
which images are defined mathematically. For more information on the difference between “draw” and “paint” 
images, see Important Concepts.

Once a raster graphic is placed on a drawing page you can select, resize, move, and delete it like any other entity. 
Using the Image tools on the Edit bar, you can flip the raster image either horizontally or vertically, resize the 
height and width, and even embed it into the drawing.

It’s important that you match points from the raster image to points in your drawing, in order to correctly position 
and size the bitmap. This makes it possible for you to recreate the relative positions and sizes of objects. When 
you’re finished tracing, you remove the bitmap and are left with a drawing that you can modify. It’s also important 
that you correctly scan the original image, so that any line intended to be horizontal or vertical is oriented that way 
in the bitmap. An image scanned incorrectly will produce inaccurate results when traced.

When a raster graphic is brought into a drawing it is still directly linked to the source of the image file. Because 
this information is linked, it is necessary to retain access to the image file, establishing a new link if changes are 
made to the filename or location. If the link is broken, it directly affects the raster image in the drawing. Embedding 
a raster image inserts the raster graphic directly into the drawing. Meaning that there is no longer a relationship 
between the image file and the drawing, it becomes part of the drawing. 

While it may appear to be in the correct proportions, you need to make slight adjustments to make sure the 
measurements in the bitmap match those in the CAD drawing. To do that, you match two points from the bitmap to 
their CAD counterparts. You must know the locations of the two points. You can then enter the points using any of 
the four keyboard snap modes. Whatever snap mode you choose, the important thing is that the points are in the 
correct positions in relation to each other.

The points must be at least slightly diagonal to each other. If they’re in a straight line from each other horizontally 
or vertically, repositioning will produce poor results. The farther the points are from each other, the more accurate 
the tracing will be.

When entering points on the raster image, zoom in so you can place points precisely, then zoom out again before 
continuing. After repositioning the bitmap, try entering several known points in Absolute or Relative snap modes to 
see whether points in the AutoSketch drawing correspond to positions on the bitmap. It may take more than one 
try to exactly match points in the raster image to points in the AutoSketch drawing window.
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To place a raster image in the drawing window

1 Scan the original, paper drawing and create a file on your system with a .BMP (bitmap) or DIB (device-
independent bitmap) extension.

2 On the Draw menu, click Picture, or click the Picture From File button on the All-In-One toolbar. 

3 Enter the path and filename for your bitmap file in the Image File text box, then press ENTER. 

4 (optional) If you aren’t sure of the directory location and filename, click the Browse button on the Image edit 
bar to locate the file. 

5 Enter the point where you want to locate one corner of the bitmap. A rubber-band rectangle appears, stretching 
from that point.

6 Enter the point where you want to locate the opposite corner of the bitmap. If the exact horizontal and vertical 
distance from the first point is known, use relative snap mode. Otherwise, press SHIFT to constrain the 
rectangle to image proportions. The bitmap appears in the drawing



To flip a raster image
In the drawing page, select the bitmap to flip. On the Image edit bar check the Flip Vertical check box to flip 

the image up and down or the Flip Horizontal check box to flip the image left to right. 



To resize a raster image
In the drawing page, select the bitmap to resize. On the Image edit bar click the Resize Y button to change 

the height of the raster graphic. To change the width of the raster graphic click the Resize X button on the Image edit 
bar. 



To embed a raster image
In the drawing page select the bitmap to embed. On the Image edit bar click the Embed Image button, 

**Embedded** will appear in the Image File text box. To re-establish the link to the source, simply re-enter the path 
and filename in the Image File text box, and press ENTER. 



To reposition the raster image for tracing

1 Select the raster graphic to reposition, then type S to disable Snap modes. 

2 Click the Align Picture button on the Image edit bar. 

3 Click a point in the bitmap that corresponds to the first point you chose in the printed drawing. A diamond 
marker marks the point. 

4 Enter a point in the AutoSketch drawing, using any snap mode, that you want to correspond with the point you 
just entered.

5 Type S to disable Snap modes, then click a second point in the bitmap. A diamond marker marks the point.

6 Enter a point in the AutoSketch drawing, using any snap mode, that you want to correspond with the second 
point you just entered on the bitmap.

Important
The preceding steps show only one of several possible ways to reposition the raster image. For example, to 

trace a map you might want to use Absolute Polar snap mode and enter bearings for both points in the AutoSketch 
drawing. To trace a house plan, you could draw two walls in the correct positions, then use Endpoint snap mode to 
use the endpoints of those walls to reposition the raster image.



Tracing With a Digitizing Tablet

A mouse translates each movement of your hand into a similar movement of the pointer on the screen. Unlike a 
mouse, a digitizing tablet translates each point on the tablet into a specific point on the screen. This property is 
what allows you to use a digitizing tablet to trace an existing drawing. 

After the tablet is installed and configured for use in Windows, you must follow a setup procedure for each tracing 
session. This setup is retained in memory only during the current AutoSketch session. If you exit AutoSketch, 
change drawings, or adjust the position of the drawing on the surface of the digitizer, you must repeat the 
procedure.

To maximize the accuracy of your drawing, be sure to enter points for which the coordinates are known using 
normal CAD procedures. For example, if a point is known to be 13.5 meters above and 22 meters to the right of 
another point, use this information and Relative snap mode to enter the point normally rather than digitizing it. 
When you must digitize a point, don’t forget to use a lock modifier to align it with a known point if possible.

AutoSketch has two operating modes when used with a digitizing tablet: mouse mode and tracing mode. In mouse 
mode, the puck acts as a normal pointing device. The behavior of your tablet in mouse mode is determined by the 
tablet driver and by Windows. It is not controlled by AutoSketch.

In tracing mode, the only actions you can perform with the tablet are entering points and canceling actions. Other 
actions, such as choosing menu items and snap modes, must be accomplished with the keyboard. 
    Related Topics



To set up a digitizing tablet for use with AutoSketch

1 Install the tablet on your system. Refer to the manufacturer’s instructions for information on how to do this.

2 Install the driver for the tablet on your hard drive. Be sure that the driver is the most current one available. If a 
newer driver is available, obtain it from the manufacturer. The driver must support the Wintab32ª standard for 
digitizing tablets used in Microsoft Windows. When you start AutoSketch with a tablet properly installed, an 
icon will appear on the far right side of the status bar.



To set up a drawing for tracing with a digitizing tablet

1 Attach the drawing to the tablet surface with tape or by placing it under the clear plastic overlay. The drawing 
doesn’t have to be perfectly aligned on the tablet, but the part you want to trace must fit within the tablet’s 
active area.

2 On the Tools menu, click Tablet, Register. This menu choice is available only when your tablet is properly 
installed and configured.

3 Examine the printed drawing and choose two points to use as reference points. You must know the distance 
between them and the orientation of the second point in relation to the first. The farther the points are from 
each other, the more accurate the tracing will be.

4 Digitize the first point on the printed drawing.

5 Enter the point in AutoSketch you want to correspond with the point you digitized.

6 Digitize the second point on the printed drawing.

7 Enter the point in AutoSketch you want to correspond with the second point you digitized. Use any combination 
of snap modes and lock modifiers you need to locate the point exactly as it is on the printed drawing.



To switch from tablet to mouse mode
You can switch from tracing mode to mouse mode by selecting Tablet, Tracing Mode on the Tools menu, or 

by pressing CTRL+T, or by double-clicking the icon at the far right side of the status bar.



Customizing AutoSketch

By customizing screen components, the display, and drawing and editing preferences you can change AutoSketch 
to better suit your drawing and editing needs.

You can modify the components of the display including the drawing window, the edit bar, property bar, Standard 
toolbar, status bar, symbol library bar, and other toolbars. By changing these items, you alter the basic parts of the 
AutoSketch user interface. In addition, you control how much space you have available for your drawing. You can 
also select the methods AutoSketch uses to indicate that you have selected an entity. For that matter, you can 
optimize the display of entities for speed or for accuracy.
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Changing the Appearance of the Page

AutoSketch gives you great flexibility in determining how your drawing appears onscreen. AutoSketch displays the 
current drawing over a page to give you a working preview of printer output. You can display page tiling to show 
how AutoSketch will tile output if you create a drawing that is larger than your printer supports.

You can select a different onscreen page color without changing how a drawing prints. For instance, you can 
change the page color to black if you are more comfortable viewing your drawings this way.

AutoSketch can invert colors that match the page. By default, white lines that appear on a white page appear 
black. This feature is especially useful if you are opening drawings created by someone else or importing 
drawings from another application. However, if you want to be able to use entity colors that match the page to hide 
other entities, you can turn this feature off.

You can also hide the printer page if you find it unnecessary. Many CAD applications do not offer a working 
preview of output with an onscreen page. If you feel comfortable working without this feature, AutoSketch makes it 
easy to turn the page display off. When you turn off the page display, AutoSketch fills the screen using the page 
color.
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To change the page color

1 On the View menu, click Options. The View Options dialog box appears.

2 Click the Appearance page tab.

3 Click a color from the drop-down list box located under the Page check box.

4 Click OK.



To invert pen or pattern colors that match the page color

1 On the View menu, click Options. The View Options dialog box appears.

2 Click the Appearance page tab.

3 To invert pen colors that match the page color, check the Pen check box in the Invert If Same As Page Color 
section.

4 To invert pattern colors that match the page color, check the Pattern check box in the Invert If Same As Page 
Color section.

5 Click OK.



To display or hide the page or page tiling

1 On the View menu, click Options. The View Options dialog box appears.

2 Click the Appearance page tab.

3 Check the Page or the Page Tiling check boxes. When these are checked, Page or Page Tiling components 
appear. When they are unchecked, Page or Page Tiling components are hidden.

4 Click OK.



Hiding Rulers and Scroll Bars

There are times when you may want more space in your drawing window. AutoSketch allows you to hide rulers 
and scroll bars from view with just a few clicks of the mouse.

Rulers are located on the top and left of the drawing window and provide a visual reference for entering points. 
For more information on rulers, see Using Rulers. Scroll bars are located on the bottom and right of the drawing 
window and allow you to move across the drawing, changing the part of the drawing visible in the drawing window, 
without changing the level of magnification. For more information about using scroll bars, see Scroll Bars.

Note
Turning the display of rulers and scroll bars on and off affects all open drawing windows.

    Related Topics



To hide the rulers

1 On the View menu, click Options. The View Options dialog box appears. 

2 Click the Appearance page tab.

3 Uncheck the Rulers check box. When checked, the rulers are visible in the drawing window, when unchecked, 
the rulers are hidden. 



To hide the scroll bars

1 On the View Menu, click Options. The View Options dialog box appears. 

2 Click the Appearance page tab.

3 Uncheck the Scroll Bars check box. When checked, the scroll bars are visible in the drawing window, when 
unchecked, the scroll bars are hidden.



Changing the Way Entities are Displayed

You can customize AutoSketch to speed screen regeneration or to change the level of onscreen detail. It is 
important to understand that this process involves trading onscreen detail for speed, or vice-versa. When you first 
install AutoSketch, it has been optimized to provide a balance of detail and high performance on most machines.

In most cases, AutoSketch tries to accurately represent onscreen how your drawing will appear when printed. 
There are situations where you may want to optimize your display to assist you in editing certain types of entities 
or to speed up screen redraws.

You can display or hide curve control points, symbol basepoints, and text basepoints independently. These control 
points or basepoints can assist you in the placement and editing of curves, text, and symbols. The first time you 
start AutoSketch, it displays text basepoints but not curve control points or symbol basepoints.

To reduce redraw times simple shapes can be substituted for complex entities. You can substitute boxes for text 
and symbols or polylines for curves. Another way to improve redraw speed is to hide pattern fills for polygons. 
None of these methods changes the way your drawing prints. They only modify the onscreen display of the 
drawing.

Entities can also be hidden or displayed by their type. However, this changes the way your drawing prints, so you 
need to decide before you print which entities should be visible.

You can also select the color and style AutoSketch uses to highlight entities. Highlighting provides a visual means 
of showing which entities are in the current selection set.
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To display or hide entity basepoints and control points

1 On the View menu, click Options. The View Options dialog box appears. 

2 Click the Visibility page tab.

3 Check the Curve, Text, or Symbol check box in the Point Visibility section. When these are checked, 
basepoints or control points for the corresponding entities appear on the screen. When they are unchecked, 
basepoints or control points for corresponding entities are hidden.

4 Click OK.



To substitute shapes for entities to speed redraw times

1 On the View menu, click Options. The View Options dialog box appears. 

2 Click the Visibility page tab.

3 Check any of the check boxes in the Fast View section. When checked, the Fast View settings described for 
the check box are used.

4 Click OK.



To hide or display entities by type

1 On the View menu, click Options. The View Options dialog box appears. 

2 Click the Visibility page tab.

3 Check any of the check boxes in the Entity Visibility section. When checked, an entity type is displayed.

4 Click OK.



To customize the appearance of the Selection Set

1 On the View menu, click Options. The View Options dialog box appears. 

2 Click the Appearance page tab.

3 In the Selection Set section, click a color from the Highlighting Color drop-down list box.

4 From the Highlighting Style drop-down list box, click a style.

5 From the Handle Size drop-down list box, click a new size.

6 Click OK. 



Displaying ToolTips and Status Bar Messages

ToolTips and status bar messages are short messages that describe controls. ToolTips are small balloons that 
briefly tell you the name or function of a toolbar button or other control. When you first install AutoSketch, ToolTips 
appear when you place the pointer over a control and pause for a moment. When you become familiar with the 
AutoSketch controls, you can turn off the display of ToolTips. When AutoSketch displays a ToolTip for a toolbar 
button, it simultaneously displays more detailed information on the status bar. When you initiate a procedure 
(clicking a Draw menu item, for example), the status bar displays step-by-step guidelines.
    Related Topics



To display a ToolTip
Place the pointer over a control and pause for a moment.



To turn the display of ToolTips on or off

1 On the View menu, click Toolbars, or right-click any toolbar and click Toolbars on the pop-up menu. The 
Toolbars dialog box appears.

2 Uncheck the Show ToolTips check box. When checked, ToolTips appear, when unchecked, ToolTips are 
hidden.

3 Click OK.



Configuring AutoSelect

You can toggle AutoSelect on or off as well as specify its status on startup. AutoSelect automatically selects and 
highlights the last entity you drew, or the last entity you edited, and displays its information on the edit bar. 
Changes made on the edit bar affect the selected entity and subsequently drawn entities. AutoSelect can be 
toggled from active to inactive by pressing INSERT or by using the pop-up menu for the selection set. When you 
install AutoSketch, AutoSelect is on.
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To toggle AutoSelect mode on or off
Position the pointer inside the selection handles, but not on the about point of a selection set. Right-click, 

then click AutoSelect on the pop-up menu.

OR
Press INSERT.

OR
On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. 

Click the Selection page tab, then check or uncheck the AutoSelect Active check box.



Changing the Size and Location of a Toolbar

You can move or hide the edit bar, property bar, standard bar, symbol bar, and other toolbars. Toolbars can be 
docked on any side of the application window, alongside one another, or floated anywhere on your screen. You 
can’t move the status bar, but you can hide it.

You can change the shapes of the All-In-One toolbar, the Standard toolbar, the symbol bar, and any other custom 
toolbar when they are floating. By dragging on the border of any of these, you can change it from a single line of 
buttons to some other configuration. The buttons in these toolbars can also be made larger or smaller. When you 
first install AutoSketch, it selects a button size based on the resolution of your Windows video driver.

Each button displays a bitmap associated with the command that it executes or the symbol that can be placed 
with it. You can change the bitmap associated with any command. If you want to use one of the built-in buttons for 
your own buttons, you can export the built-in graphic to a bitmap file, change it, and then reassign the command 
to the new bitmap.

To revert to the default button bitmap for a command, click the command from the Commands drop-down list box 
and then click Delete.
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To relocate toolbars
Click a border of the toolbar (if it’s floating, click its title bar) and drag to another location. To dock a toolbar 

along any edge of the application window or alongside another toolbar, drag until you see its outline dock, then 
release the mouse button.

Note
To prevent a toolbar from docking, press and hold CTRL while dragging.



To display or hide any toolbar
Right-click a toolbar, then click a toolbar name on the pop-up menu. A check mark next to a toolbar’s name 

means it is being displayed.



To display a toolbar when no bars are displayed

1 On the View menu, click Toolbars, or right-click any toolbar and click Toolbars on the pop-up menu. The 
Toolbars dialog box appears.

2 Check the check box next to the toolbar’s name. When checked, a toolbar is displayed, when unchecked, it is 
hidden.

3 Click OK.



To change the shape of a floating toolbar
Drag the borders of the toolbar.



To change the button size on all toolbars that display buttons

1 On the View menu, click Toolbars, or right-click any toolbar and click Toolbars on the pop-up menu. The 
Toolbars dialog box appears.

2 Click a new size from the Button Size drop-down list box.

3 Click OK.



To change the bitmap for any command

1 On the Tools menu, click Customize Commands, or click the Customize Commands button on the Standard 
toolbar. The Customize Commands dialog box appears.

2 Click the Commands Bitmaps page tab. 

3 In the Commands drop-down list box, click the command whose bitmap you want to change.

4 Click Browse, and enter or select the name of a bitmap file in the Open Bitmap File dialog box, then click 
Open. The bitmap filename and directory location are displayed in the Current Bitmap File text box. 

5 Click Assign. The bitmap file is attached to the command. 

6 Repeat steps 2-4 to change the buttons for other commands, then click Close.



To export a built-in button to a bitmap file

1 On the Tools menu, click Customize Commands, or click the Customize Commands button on the Standard 
toolbar. The Customize Commands dialog box appears.

2 Click the Commands Bitmap page tab.

3 From the Built-In Bitmaps list, click a bitmap. 

4 In the Size drop-down list box, click a bitmap size to export.

5 Click Export, enter a filename in the Save Bitmap File dialog box, then click Save.

6 Repeat steps 2-4 to export other button bitmaps, then click Close.



Creating Custom Toolbars

You can create and edit your own toolbars. AutoSketch protects the default toolbars from modification, but you can 
create and edit other toolbars. Toolbars are automatically saved to disk when you create or modify them. A toolbar 
file can also be imported from your hard drive, letting you share your custom toolbars with other AutoSketch users. 

Each toolbar is made up of toolsets. Only one button from each toolset is visible in the toolbar at a time. If you 
click and hold the pointer on that button, the rest of the buttons in the toolset appear. You can also add gaps 
between different tools in the toolbar, giving you greater flexibility in the number and type of tools that are included 
in a toolbar. 

Buttons or toolsets from the default All-In-One toolbar can be copied, but you can’t make modifications to it.
    Related Topics



To create a new toolbar

1 On the View menu, click Toolbars, or right-click a toolbar, then click Toolbars on the pop-up menu. The 
Toolbars dialog box appears.

2 Click New. The New Toolbar dialog box appears.

3 Enter the name that you want AutoSketch to display in the title bar of the toolbar.

4 Enter a filename in the File text box, click Browse to see if the name already exists, then click OK. The 
Customize Toolbar dialog box appears.

5 In the Commands list, select a command. The button for the command appears below the list.

6 Click the button, drag it to the Sets window and position (1, 2, and so on), and release the mouse button, or 
double-click on the button, or on an item in the command list, to add it to the end of the selected toolset. If you 
forget what the command for the button is, place your pointer over the button and pause, a ToolTip appears 
next to the button. 

7 Repeat steps 5 and 6 to add other buttons to this set.

8 Select the next toolset from the Sets list. Repeat steps 5, 6, and 7 to add buttons to this toolset.

9 (optional) Click the toolset position, then click Add Gap to add a blank set between toolsets.

10 Click Close when you are done adding toolsets to the toolbar.



To import a toolbar

1 On the View menu, click Toolbars, or right-click a toolbar, then click Toolbars on the pop-up menu. The 
Toolbars dialog box appears.

2 Click New. The New Toolbar dialog box appears.

3 Click Browse, enter or click the name of a toolbar in the Open Toolbar File dialog box, then click Open. 
AutoSketch returns you to the New Toolbar dialog box.

4 Enter the name that you want AutoSketch to display in the title bar of the imported toolbar, then click OK.

5 Click Close.



To add, remove, or reposition buttons from a toolbar

1 On the View menu, click Toolbars, or right-click a toolbar, then click Toolbars on the pop-up menu. The 
Toolbars dialog box appears.

2 Select a toolbar, then click Customize. The Customize Toolbar dialog box appears.

3 Click a toolset in the Sets list.

4 (optional)    In the Commands list box, click a command and drag the button that appears below the list to the 
Set window and position where you want it inserted.

5 (optional) Drag the button out of the set box to remove a button, or drag it to another set box, or drag it to a 
different location within the same set box.

6 (optional)    On the Sets list, click a toolset and then click Delete to remove an entire toolset.

7 (optional) Click the toolset position, then click Add Gap to add a blank set between toolsets.

8 Click Close when you are done adding or removing buttons.



To move a toolset in a toolbar

1 On the View menu, click Toolbars, or right-click a toolbar, then click Toolbars on the pop-up menu. The 
Toolbars dialog box appears.

2 Select a toolbar, then click Customize. The Customize Toolbar dialog box appears. 

3 Click a toolset in the Sets list.

4 Click Move Up to move a toolset up one row. To move a toolset down one row, click Move Down.

5 (optional) Click the toolset position, then click Add Gap to add a blank set between toolsets.

6 Click Close.



To copy a toolset from one toolbar to another

1 On the View menu, click Toolbars, or right-click a toolbar, then click Toolbars on the pop-up menu. The 
Toolbars dialog box appears.

2 Select a toolbar, then click Customize. The Customize Toolbar dialog box appears.

3 Click a toolset in the Sets list, then click Copy.

4 In the Toolbar drop-down list box, click the toolbar where you want to place the toolset.

5 On the Sets list, click the toolset and click Paste. AutoSketch places the copied buttons after any existing 
buttons in the toolset. If you clicked on the number at the end of Sets list in the preceding step, the copied 
buttons are added as a new toolset.

6 Click Close.

Note
The buttons on a toolbar are grayed if the toolbar cannot be edited.



Defining Shortcut Keys

You can add shortcut keys to quickly select commands. AutoSketch has many shortcut keys built in, such as 
CTRL+C for Copy or CTRL+Q for Drawing Options. Shortcut keys can be added for any command by clicking 
Customize Commands on the Tools menu. AutoSketch has reserved the CTRL+SHIFT+(key) combinations for 
user-defined shortcut keys.
    Related Topics



To create a shortcut key

1 On the Tools menu, click Customize Commands, or click the Customize Commands button on the Standard 
toolbar. The Customize Commands dialog box appears.

2 Click the Key Assignments page tab.

3 In the CTRL+SHIFT+Key drop-down list box, click a key to assign.

4 In the Commands drop-down list box, click a new command, then click Assign.

5 Repeat steps 2 and 3 to create other shortcut keys.

6 (optional)    In the CTRL+SHIFT+Key list box, click a shortcut key and then click Delete to remove it.

7 Click Close.



Controlling Folder Settings

AutoSketch allows you to control the default folder it uses to locate drawing files, symbols, and properties. This is 
especially useful if you store these files in separate drives or folders than those set up during the AutoSketch 
installation.
    Related Topics



To change the default folder settings

1 On the Tools menu, click Customize Commands, or click the Customize Commands button on the Standard 
toolbar. The Customize Commands dialog box appears.

2 Click the Folders page tab.

3 Enter a new folder name in one of the text boxes. 

OR

If you’re unsure of the correct path, click the Browse button. The Browse For Folder dialog box appears 
displaying the hierarchy of folders in your system. click the location you want, then click OK. 

4 Click OK. 



Network Administration

Using AutoSketch on a network is similar to using it on a local hard drive. After you create a network installation, 
AutoSketch can be run simultaneously by as many users as you have licenses. If you installed AutoSketch on a 
local drive and you do not share files on a network, you can disregard the information contained in this section. 

No special provisions are required for using AutoSketch with specific types of networks. AutoSketch provides the 
following features for network users:

File Sharing and Locking    AutoSketch manages drawing files that are stored on the network to allow you 
to share your drawing files with colleagues without worrying about corrupting your data. For more information on 
sharing drawing files, refer to Sharing Drawing Files on a Network.

Shared Printing    AutoSketch can print to any available network printers just as it prints to any printers 
attached directly to your computer. If your network printers are not usually available to you under Windows, you may 
need to send special network commands to access a printer. Refer to your network documentation for information on 
accessing a network printer under Windows.

Floating Licenses    AutoSketch licenses are for a specific number of users rather than to specific 
individuals. This gives you the flexibility to let a larger user base access AutoSketch provided that they do not need 
access at the same time. The number of users at any given time is limited to the number of licenses you purchase. 

Error Correction    AutoSketch automatically corrects network errors that can occur when a system failure 
or temporary power loss occurs. When you restart your network software, it unlocks drawing files that were locked by 
users who are no longer accessing the files. When AutoSketch is restarted, it also removes any inactive users who 
were using the software when the network went down. It also allows you to manually clean up any errors yourself.

When you restart your network software, it unlocks drawing files that were locked by users who are no longer 
accessing the files. When AutoSketch is restarted, it removes your name from the user list when the network went 
down. It also allows you to manually clean up any errors yourself.
    Related Topics



Copying AutoSketch to a Network Drive

You can share AutoSketch across a network. This means that the network administrator can copy the AutoSketch 
files to a network drive, then you, and others, can install it locally on your workstation. Without a network pack, 
only one user at a time can use AutoSketch. By adding a network pack, you are adding AutoSketch license 
agreements, and additional users can access the program simultaneously.

To copy the AutoSketch files to a network drive, the system administrator must run the Setup application on the 
AutoSketch CD-ROM. This copies the files to a specified location on the network drive, but it does not install it to 
run on individual workstations. Each user will need to run the Setup application from his or her workstation to 
install AutoSketch.

After the network administrator copies the files to a network drive and then installs AutoSketch on his workstation, 
he can enter the information included with a network pack to increase the number of simultaneous users.

Before attempting to copy AutoSketch files to a network drive, be sure the network software is properly installed, 
that you have read/write access to the folder where you plan to copy the files, and that Windows NT 4.0 or 
Windows 95 is available on each workstation where AutoSketch will be used.

In order to add a network pack, you must first install AutoSketch on your local workstation. 

Tip
Be sure to store your authorization numbers in a safe place. If you need to reinstall AutoSketch or later 

upgrade to a new version, you’ll need them again.
    Related Topics



To copy AutoSketch to a network drive in Windows NT 4.0 or Windows 95

1 Insert the AutoSketch CD into your CD-ROM drive. Installation begins automatically.

2 Follow the installation prompts that appear, being careful to specify a network installation and not an individual 
installation.



To add a network pack to increase the number of AutoSketch users

1 Open AutoSketch.

2 On the Tools menu, click Network. The Network Setting dialog box appears.

3 Click Add Users. The Add Users dialog box appears.

4 Enter your authorization number.

5 Enter the number of users allowed by your network upgrade license.

6 Click Close.



Sharing Drawing Files on a Network

Keeping your drawing files on a network drive makes it possible to share them with other network users. This 
makes it easier for a group of people to revise and edit a drawing file, keeping the most current version available 
for review.

However, if two users were able to access the same drawing file at the same time, they could save conflicting 
versions of the file, corrupting the file and losing data. To prevent more than one user from accessing any file, 
AutoSketch locks each drawing file when you open it.

When AutoSketch locks a file, it limits who can save the file to the one who first opened it. Other users on the 
network can open the file as read-only to view the drawing. To save the drawing file, they must give it a different 
filename or save it to a different folder. There is no limit to the number of users who can open a file in the read-
only mode. 

Any action that results in an attempt to gain read/write access of a locked file produces an error. If such an error 
occurs, you have the option of opening the file in read-only mode or canceling the action. 

AutoSketch protects from modification any drawing files which have the read-only attribute. You can add or 
remove the read-only attribute using Windows Explorer or My Computer. For more information, consult Windows 
online Help.
    Related Topics



Displaying AutoSketch Network Usage

When you click Network on the Tools menu, the Network Settings dialog box displays the number of users 
currently running AutoSketch, the maximum number of users allowed by your installation, and the names of 
current users at the time you start the utility. To update the information displayed by the Network Settings dialog 
box, click the Refresh List.
    Related Topics



To display the AutoSketch users on your network

1 On the Tools menu, click Network. The Network Settings dialog box appears.

2 Click Refresh List to display the current list of users.



Removing a User

You can remove inactive users manually if AutoSketch fails to do so. You can remove users by using the Network 
Settings dialog box or by using the ADMIN command line option described in the following procedures.

Usually, AutoSketch automatically removes users from the list of current users when they exit. Even when a user 
unexpectedly exits the program, such as in the event of a system or server crash, AutoSketch removes any users 
when they restart AutoSketch. However, it is possible that AutoSketch could fail to detect an inactive user. Since 
an inactive user that appears in the current user list counts against your maximum user limit, you need to remove 
the user manually.

Caution
Be absolutely certain that you do not remove an active user. Doing so can result in a loss of data. 

    Related Topics



To remove a user from your network

1 On the Tools menu, click Network. The Network Settings dialog box appears.

2 Select the user you wish to remove from the list and click Log-Off User.



To remove users after a network crash

1 Log on to the network and connect to the drive that contains AutoSketch.

2 Click Start, then click Run. The Run dialog box appears.

3 Enter “F:\CAD\CAD.EXE” /ADMIN (notice there is a space after CAD.EXE) in the Open text box and click OK. 
If you installed AutoSketch on a different network drive or folder, substitute the drive letter and folder name, 
such as “R:\DRAW\CAD\CAD.EXE” /ADMIN. The Network Settings dialog box appears.

4 Select the name of a user you are certain is not active and click Log-off User.

5 Repeat step 4 to remove the other users, once you are certain they are not active.

6 Click Close.



Command Names

The following commands are available in the Customize Toolbar dialog box. All commands have predefined button 
bitmaps. 

 Command  Menu Command or Description

FileNew File, New

FileOpen File, Open

FileMerge File, Merge

FileClose File, Close

FileSave File, Save

FileSaveAs File, Save As

FilePageSetup File, Page Setup

FilePreview File, Print Preview

FilePrint File, Print

FileSend File, Send

File1, File2, ... File1, n filename

FileExit File, Exit

Undo Edit, Undo 

Redo Edit, Redo

RepeatEdit Edit, Repeat Edit

Cut Edit, Cut

Copy Edit, Copy

Paste Edit, Paste

PasteSpecial Edit, Paste Special

Links Edit, Links

InsertObject Edit, Insert Object

ConvertObject Edit, Convert Object

Delete Edit, Delete

SelectAll Edit, Select, All

SelectModifier Edit, Select, Modify Selection

SelectClear Edit, Select, Clear Selection

SelectInPoly Edit, Select, Inside Polygon

SelectFence Edit, Select, Fence

SelectMarquee Edit, Select, Marquee

SelectIrrMarquee Edit, Select, Irregular Marquee

SelectMarqueeClear Edit, Select, Clear Marquee

RubberStamp Edit, Transform, Rubber Stamp

TransformTranslate Edit, Transform, Translate

TransformScale Edit, Transform, Scale

TransformRotate Edit, Transform, Rotate

TransformAlign Edit, Transform, Align

TransformMirror Edit, Transform, Mirror

TransformStretch Edit, Transform, Stretch

ArrayRectangular Edit, Transform, Rectangular Array



ArrayCircular Edit, Transform, Circular Array

TrimCorner Edit, Trim, Corner

TrimFillet Edit, Trim, Round

TrimChamfer Edit, Trim, Bevel

TrimEdge Edit, Trim, Edge

TrimBreak Edit, Trim, Break

TrimChannel Edit, Trim, Channel

TrimDivide Edit, Trim, Divide

TrimSubdivide Edit, Trim, Subdivide

TrimJoin Edit, Trim, Join

TrimAlcove Edit, Trim, Alcove

TrimUnion Edit, Trim, Union

TrimIntersection Edit, Trim, Intersection

TrimDifference Edit, Trim, Difference

ArrangeToFront Edit, Arrange, Move to Front

ArrangeToBack Edit, Arrange, Move to Back

Explode Edit, Explode

EditEntities Edit, Entities

RepeatDraw Draw, Repeat drawcommandname

LineSingle Draw, Line, Single

LineMultiple Draw, Line, Multiple

LineDouble Draw, Line, Double

LineTangent Draw, Line, Tangent

LinePerpendicular Draw, Line, Perpendicular

LineAngle Draw, Line, Angle

Arc3Points Draw, Arc, 3 Points

Arc2PointsCenter Draw, Arc, 2 Points & Center

Arc2PointsAngle Draw, Arc, 2 Points & Angle

CircleCenterSide Draw, Circle, Center, Side

CircleSideSide Draw, Circle, Side, Side

Circle3Points Draw, Circle, Circle 3 Points

CircleCenterRadius Draw, Circle, Center, Radius

CircleTangent2 Draw, Circle, Tangent 2 Entities

CircleTangent3 Draw, Circle, Tangent 3 Entities

PolylineSingle Draw, Polyline, Single

PolylinePerpendicular Draw, Polyline, Perpendicular

PolylineCornerRectangle Draw, Polyline, Corner Rectangle

PolylineSketch Draw, Polyline, Sketch

PolygonRectangle Draw, Polygon, Rectangle

PolygonRotatedRectangle Draw, Polygon, Rotated Rectangle

PolygonRegCenterEdge Draw, Polygon, Regular: Center, Edge

PolygonRegEdgeOpposite Draw, Polygon, Regular: Edge, Opposite

PolygonRegEdgeAdjacent Draw, Polygon, Regular: Edge, Adjacent

PolygonRegCenterRadius Draw, Polygon, Regular: Center, Radius



PolygonIrregular Draw, Polygon, Irregular

EllipseRectangle Draw, Polygon, Ellipse Rectangle

EllipseAxes Draw, Polygon, Ellipse Axes

CurveFitted Draw, Curve, Fitted

CurveSpline Draw, Curve, Spline

MarkerPoint Draw, Marker, Point

MarkerAlignEntity Draw, Marker, Align On-Entity

MarkerAlignEnd Draw, Marker, Align to Endpoint

TextPoint Draw, Text

DimensionHorizontal Draw, Dimension, Horizontal

DimensionVertical Draw, Dimension, Vertical

DimensionRotated Draw, Dimension, Rotated

DimensionAligned Draw, Dimension, Aligned

DimensionAngular Draw, Dimension, Angular

DimensionRadius Draw, Dimension, Radius

DimensionDiameter Draw, Dimension, Diameter

DimensionCenterline Draw, Dimension, Centerline

DimensionOrdinate Draw, Dimension, Ordinate

DimensionLeader Draw, Dimension, Leader

DrawParallel Draw, Duplicate, Parallel

DrawOffset Draw, Duplicate, Offset

Hatch Draw, Hatch

SymbolSelect Draw, Symbol, Explore 

SymbolLibraryOpen Draw, Symbol, Change Library, Open

SymbolLibrary1...SymbolLibrary8 Draw, Symbol, Change Library, n libraryname

SymbolCreate Draw, Symbol, Create

SymbolPoint Draw, Symbol, Point

SymbolInsert Draw, Symbol, Insert

Picture Draw, Picture

ViewRedraw View, Redraw

ViewZoomIn View, Zoom In

ViewZoomOut View, Zoom Out

ViewPan View, Pan

ViewLast View, Last

ViewNext View, Next

ViewSelection View, Selection

ViewSheet View, Page

ViewExtents View, Extent

ViewSave View, Save

ViewRecall View, Recall

BarToolbars View, Toolbars

OptionsView View, Options

InquireEntity Inquire, Entity Properties

InquireSymbolCount Inquire, Symbol Count



InquireSelection Inquire, Selection Properties

InquireTotals Inquire, Drawing Properties

InquireCoordinate Inquire, Coordinate

InquireDistance Inquire, Distance

InquireAngle Inquire, Angle

InquireArea Inquire, Area/Perimeter

OptionsPenPattern Tools, Graphic Options

OptionsGeneral Tools, Drawing Options

CommandCustomize Tools, Customize Commands

OptionsNetwork Tools, Network

OptionsTablet Tools, Tablet, Register

TabletModeToggle Tools, Tablet, Tracing Mode

OptionsDatabase Database, Options

DatabaseAssign Database, Assign Field

DatabaseEdit Database, Edit Entity Fields

DatabaseDelete Database, Delete Field

DatabaseVisible Database, Make Visible

DatabaseInvisible Database, Make Invisible

DatabaseExport Database, Export

DatabaseReport Database, Report

WindowNew Window, New Window

WindowTileHorizontal Window, Tile Horizontally

WindowTileVertical Window, Tile Vertically

WindowCascade Window, Cascade

WindowArrange Window, Arrange Icons

WindowCloseAll Window, Close All

Window1...Window9 Window, n windowname

HelpTopics Help, AutoSketch Help

HelpTip Help, Tip of the Day

HelpReadMe Help, Read Me

HelpOfficeCompatible Help, Office Compatible

HelpAbout Help, About AutoSketch

HelpSensitive Initiate context sensitive help mode

PaneNext Move to the next pane

PanePrevious Move to the previous pane

ActivateEditBar Activate the edit bar

ActivatePropertyBar Activate the property bar

ViewFastZoomIn Zoom in by factor about center of pane

ViewFastZoomOut Zoom in by factor about center of pane

ViewFastZoomSelectIn Zoom in by factor about center of selection set

ViewFastZoomSelectOut Zoom out by factor about center of selection set

ViewSelectionAll Display selection view in all panes of current window

ViewSheetAll Display page view in all panes of current window

ViewExtentsAll Display extent view in all panes of current window



ViewRedrawAll Redraw all panes in current window

ViewSplit Split current window into four equal panes

ViewUnsplit Unsplit current window 

AutoselectToggle Toggle the autoselect on or off

SelectDirect Change to direct selection mode

SnapGridpoint Change to Gridpoint snap mode

SnapEndpoint Change to Endpoint snap mode

SnapOnEntity Change to Nearest snap mode

SnapMidpoint Change to Midpoint snap mode

SnapBasepoint Change to Basepoint snap mode

SnapIntersection Change to Intersection snap mode

SnapPerpendicular Change to Perpendicular snap mode

SnapCenterpoint Change to Centerpoint snap modeap

SnapTangent Change to Tangent snap mode

SnapQuadrant Change to Quadrant snap mode

SnapOff Change to “Snap off” snap mode

SnapAbsolute Change to Absolute snap mode

SnapRelative Change to Relative snap mode

SnapWorkingPoint Change to Working Point snap mode

LockUnlock Disable lock modifiers

LockHorizontal Apply the X-axis lock modifier

LockVertical Apply the Y-axis lock modifier

LockBoth Apply the Orthogonal lock modifier

LockNormal Apply the Normal lock modifier

ConvertCurveToPoly Convert selected curves to polylines

ConvertEllipseToCurve Convert selected arcs and circles to curves

ConvertTextToPoly Convert selected TrueType text to polylines

EditDimension Display reshaping nodes for the selected dimension

EditText Display the Text Editor for the selected text entity

EditVertices Display reshaping nodes for the selected entity

TransformClean Remove unnecessary vertices for the selected poly

TransformFlip Flip the endpoints on the selected lines or arc

Calculate Evaluate numeric expression

PropertyPainter Activate the Property Painter

HyperlinkBrowse Browse the hyperlinks

HyperlinkEdit Display the Hyperlink edit bar

HyperlinkJump Jump to hyperlinked document

EditGrid Display the Grid edit bar



Frequently Asked Questions (FAQ)

    What are snap modes?
    Why can’t I see the symbol library bar?
    How do I edit an existing symbol?
    Why are objects selected outside of my selection region?
    How do I close the Enter 2D Coordinate dialog box?
    How do I control the number of radial gridlines AutoSketch displays on the circular reference 

grid?
    Why doesn’t my drawing print in color when I drew it in color?
    How do I set up up my drawing tablet or digitizer?
    What are DWF files?
    How do I create Encapsulated Postscript (EPS) files?
    Why is my serial number invalid?
    How do I insert text into a dimension label?
    Why do some of the tables in online Help appear as black rectangles?
    Why does nothing happen when I click About AutoSketch on the Help menu?
    Why does some text disappear when I tile my drawing across multiple pages?



What are snap modes? 

Snap modes allow you to enter a point using the mouse precisely in relation to an existing entity or a point on the 
reference grid. For instance, if you need to enter a point on the end of a line segment, click the Endpoint button on 
the Drawing toolbar, or type E, then click a line segment closest to where you want to place the point. It is 
automatically placed precisely on the closest end of the line segment you clicked. For more information see 
Entering & Modifying Points.



Why can’t I see the symbol library bar? 

The symbol library bar might be hidden when you open AutoSketch, depending on your selection from the Start 
Up dialog box. To display the symbol library bar, simply right-click any toolbar and click Symbol Library on the pop-
up menu that appears. For more information on hiding and displaying toolbars, see Changing the Size and 
Location of a Toolbar.



How do I edit an existing symbol? 

To edit a symbol you must first convert it to its component entities (lines, polylines, arcs, and so on). Simply select 
the symbol to edit and right-click. On the pop-up menu that appears, click Convert, Symbols to Base Entities. You 
can now edit the base entities just as you would any normal entity. You can change the pen color, pen style, move 
and scale, remove entities, and so on. When you are satisfied with the result, simply select all the entities you 
want to include in the symbol and click Symbol, Create on the Draw menu. For more information, see Converting 
& Exploding Entity Types, and Creating Symbol Definitions.



How do I close the Enter 2D Coordinate dialog box? 

The Enter 2D Coordinate dialog box appears when the Relative or Absolute keyboard modes are active. You can 
exit the dialog box by clicking Cancel, pressing ESC, or clicking the close button in the upper right corner of the 
dialog box. If you select another snap mode, for instance Endpoint snap mode or Midpoint snap mode the Enter 
2D Coordinate dialog box will also close. For more information on the Enter 2D Coordinate dialog box, refer to 
Entering & Modifying Points.



Why are objects selected outside of my selection region?

Objects can be selected by defining a rectangular region in the drawing. If the region is defined by drawing the 
selection region from left to right, only objects that are entirely within the region are selected. 

If the region is defined by selecting from left-to-right, objects that are not only within, but also partially within the 
selection region are selected. The result of a right-to-left selection would include any polygons that are entirely 
surrounding the selection region even if they are much larger and do not even appear in the current view.



How do I control the number of radial gridlines AutoSketch displays on the circular reference grid?

The controls for determining the number of radial gridlines are located on the Grid edit bar, which appears when 
you click the Edit Grid button on the Standard toolbar. To change the number of radial gridlines, enter a new angle 
in the Circular Grid Angle text box on the Grid edit bar. This is the angle between radial gridlines. Since the sum of 
all the angles must equal 360, smaller angles will result in the display of more major lines. For more information 
about the Grid edit bar, see Using the Grid Edit Bar.



Why doesn’t my drawing print in color when I drew it in color? 

There are several possible causes. Most likely, the Print All Black check box in the Print dialog box is checked. 
This will print the entire drawing in black even if you used different colors. There may be a similar setting in your 
printer driver. Usually the setting choices are Automatic, Manual Color, or Color as Grayscale. If the printer driver 
setting is Color as Grayscale, colors will print as different shades of gray. Other possible causes include:

The color cartridge in the printer is empty. 
Inkjet printers that require different cartridges may have a color cartridge that isn’t in the printer. 
Your printer isn’t capable of printing in color. 

For more information on printing and printer settings, refer to Printing and Plotting.



How do I set up my drawing tablet or digitizer? 

To set up your drawing tablet select four pointstwo on the tablet itself and two in the AutoSketch drawing page. 
These four points set up a new AutoSketch drawing page the same size as the drawing you want to digitize. 
Before you setup the drawing tablet, make sure the drawing scale in AutoSketch is the same as the scale of the 
printed drawing. If you don’t know the scale, just leave it at 1:1. You can scale entities later using the Transform 
command on the Edit menu. See Scaling an Entity for more information on changing the scale of an entity. 

On the Tools menu, click Tablet, Register, or click the Register Tablet button on the Standard toolbar. To select the 
first reference point, move the puck to the upper left corner of the printed drawing on the tablet and click. The 
second reference point is on the AutoSketch drawing page, this time move the puck to the upper left corner of the 
drawing page and click. The third reference point is on the tablet, move the puck to the lower-right corner of the 
printed drawing on the tablet and click. The last reference point is on the AutoSketch drawing page, this time 
move the puck to the lower right corner of the drawing page and click. You are now ready to go. To switch 
between tablet and mouse mode, press CTRL+T. For more information, see Tracing in AutoSketch. 



What are DWF files?

The Drawing Web Format (DWF) was developed primarily as a practical means to transfer 2D vector drawings 
over the internet. It is application independent, in that no specific CAD package is required to view drawings in this 
format. All that is needed to view these files is an internet browser with the appropriate accessory. Currently, 
Netscape’s Navigator 3.0x or higher and Microsoft’s Internet Explorer 3.0 or higher, support the accessory known 
as WHIP! The WHIP! plug in for Netscape is available from Autodesk at http://www.autodesk.com.

The DWF file format has been described as an “electronic plot” because it breaks more complex elements into 
simpler drawing components, much the same as a plotter needs to have the complex entities in a drawing file 
broken down into simple lines and arcs which it can easily draw on a sheet of paper. Additionally, the DWF file 
format provides mechanisms which compress the file size by minimizing duplication of information. A DWF file can 
also contain information that attaches hyperlinks to areas it describes. These can allow a viewer of the file to jump 
to other locations described by Internet URLs.

Applications that exploit this flexibility are limited only by your imagination! For example, you could produce a 
DWF version of a drawing of a building’s elevation view in which hyperlinks were defined for each floor, then 
publish this drawing on the World Wide Web. A user could then click on the floor of interest and open a floor plan 
for that particular floor. Hyperlinks can direct you to other DWF files, images, video, sound, 3D VRML models, 
other Web pages, or any internet resource definable by the hyperlink’s URL.

More details on the DWF file format and the WHIP! viewer can be found on the Autodesk home page on the World 
Wide Web at http://www.autodesk.com, and Importing and Exporting. 



How do I create Encapsulated Postscript (EPS) files?

Before you can create an EPS file, you must have a Postscript printer driver installed on your computer. You only 
need the driver, you don’t need to have the actual printer. For instance, you could install the HP LaserJet 4P/4MP 
Postscript driver included on the Windows 95 CD.

During the installation process, be sure to select “File” instead of “LPT1” or “COM1” when choosing where to 
connect the printer. Also, change the driver to Encapsulated Postscript. In Windows 95, click the Start menu, then 
click Settings, Printers. Right-click on the driver, then click Properties from the pop-up menu that appears. A 
Properties dialog box for that driver appears. Click the Postscript page tab, then click Encapsulated Postscript 
(EPS) from the Postscript Output Format drop-down list box.

After your AutoSketch drawing is complete, click Print on the File menu. Select the Postscript printer from the 
Name drop-down list box, then click OK. The Print File dialog box appears. Specify the location for the EPS file 
and filename, then click Save. An EPS file is created and saved in the folder you specified. 

When you open an EPS file in some applications, a gray box appears where the EPS file should be. This is 
because EPS files are actual Postscript data, which is not translatable by many applications.



Why is my serial number invalid?

If you receive the “Invalid Serial Number” message during installation, make sure that you are entering the serial 
number with no spaces. There is also no need to enter the S/N label as part of the serial number.



How do I insert text into a dimension label?

You can insert text into a dimension label in a couple of ways. To add a dimension to drawing click Dimension, 
Horizontal on the Draw menu. On the edit bar click Format, the Linear Dimension Format dialog box appears. On 
the Label page delete the <> characters from the Label Text dialog box, and enter text. If the dimension is already 
in the drawing, simply select the dimension and click Format on the edit bar, repeating the same steps as 
previously discussed. For more information on using dimensions in AutoSketch, see Creating Dimensions.



Why do some of the tables in online Help appear as black rectangles?

If your system is not capable of displaying 16 bit color at a resolution of 1024 X 768, it may affect the ability of 
online Help to display tables and other graphics. 



Why does nothing happen when I click About AutoSketch on the Help menu?

If you do not have Microsoft Office 97, or another application such as Microsoft Word, installed on your system, 
this feature will not function.



Why does some text disappear when I tile my drawing across multiple pages?

When tiling a drawing over two or more pages, True Type fonts may drop a letter in the tiling gap. To correct this 
set your printer driver to "print text as graphics".



Keyboard Shortcuts

Keyboard shortcut keys allow you to carry out a function from the keyboard instead of clicking a button or menu 
item. AutoSketch provides single-key and key combination shortcuts for certain frequently-used items. When a 
shortcut is available for a menu choice, its key combination is listed on the menu to the right of the item’s name.

Keyboard shortcut keys are available for the following menu items and functions:
Choosing certain File menu items
Choosing certain Edit menu items
Choosing certain View menu items
Moving the selection set
Modifying certain Draw and Edit operations
Extending selection in list boxes
Shortcuts to various other functions

File Command Keys

The following shortcut keys access File menu commands or control the current drawing window:

Selection Editing

The following shortcut keys create or edit the selection set.

Repeating Transformations

The following keys cause AutoSketch to repeat the most recent Translate, Rotate, Align, or Scale command.



Moving The Selection Set

The following shortcut keys move the selection set.

Controlling the View

The following shortcut keys change views.

Scrolling the View

The following keys control what is displayed in the active pane:



Miscellaneous Shortcut Keys

The following keys are used to perform special functions:



Glossary

A

absolute coordinates active pane

actual size alcove

alignment axis aligned dimension

aligned marker aligned symbol

All-In-One toolbar angle

angle orientation angular dimension

annotation ANSI character set

arc array

arrow keys aspect

AutoField Automatic Snap

AutoPoint Indicators AutoSelect

axis

B

background layer backup file



base entity baseline dimensioning

basepoint Basepoint snap mode

bearing bevel

break break length

by-layer by-symbol

C

CAD calculated value

cartesian coordinates centerline dimension

Centerpoint snap 
mode

chain dimensioning

channel circle

circular array circular grid

circular grid angle circumscribed polygon

closed polygon or 
curve

command

command bitmap compass angle

convert coordinate

coordinate system corner

current property current layer

current symbol current symbol library

curve custom view

D

decimal precision default snap mode

delete detail report

dial diameter dimension

difference dimension

dimension label dimension line

direct selection direction keys

divide DLL (Dynamic Link Library)

double line drawing file

drawing origin drawing scale

drawing window Dropper tool

DWF file format DWG file format

DXF (drawing 
interchange) file format

E

edge edit bar

editable layer ellipse

embed embedded object

Endpoint snap mode entity



explode export

expression extension line

extension line overrun extent

extent view extrude

F

fast view field

field name field precision

field type field width

fill fillet

fitted curve format string

formula fractional precision

function

G

geometry grad

graphic property grid angle

grid coordinates grid origin

grid snap interval Gridpoint snap mode

H

handle hard margin

hatch hatch angle

hatch spacing hatch style

horizontal dimension hyperlink 

HPGL (Hewlett 
Packard Graphics 
Language) file

I

import included angle

initial offset inscribed polygon

intersection Intersection snap mode

irregular polygon isometric grid

J-K-L

join justification

last point layer

layer description layer name

layer state leader

leader length leading zero

library line



line terminator linear dimension

link linked object

lock modifier

M

margin marker

marquee masked layer

math coprocessor merge

metafile Midpoint snap mode

mirror

N

Nearest snap mode nested symbol

Normal lock modifier numeric expression

numeric list

O

OLE OLE Object

offset open curve

operator ordinate dimension

orientation origin

Orthogonal lock 
modifier

P

page page coordinates

page tiling page view

pan pane

pattern pen

pen color pen style

pen width Perpendicular snap mode

plotter file plus/minus rotation

polar coordinates poly

poly-entity polygon

polyline poly width

pop-up menu pop-up window

port file printable area

project information property

property bar Property Painter

proportional scaling

Q-R

Quadrant snap mode qualifier



question mark radian

radius dimension raster image

rectangle rectangular array

rectangular grid redo

redraw reference grid

region selection regular polygon

relative coordinates render depth

resizing handle rotated dimension

rotation basepoint rotation handle

round rubber band

S

scalar scale

segment selection fence

Selection Modifier selection operator

selection qualifier selection set

selection statement shortcut key

single dimensioning sizing method

sketch SKD file format

snap off mode snap mode

spline curve split box

standard angle standard toolbar

status bar stretch

subdivide summary report

symbol symbol basepoint

symbol bar Symbol Explorer

symbol library

T

Tangent snap mode template

terminator text angle

text aspect text basepoint

Text Editor text entity

text height tiling pattern

tolerance toolbar

tooltip tracing

transform translate

trim

U-V

UID URL



undo uniform resource locator (URL)

union unique identifier (UID)

units of measurement Unlock lock modifier

user-defined property value

vertex vertical dimension

view

W-X

Windows metafile wizard

working point world coordinates

x-axis X-axis lock modifier

XY coordinates XYZ coordinates

Y-Z

y-axis Y-axis lock modifier

z-axis zoom in

zoom out



absolute coordinates

Coordinates that specify location in relation to the current coordinate system origin (0,0). For example, the 
absolute XY coordinates 13,2 describe a point 13 units right of and two units above the drawing origin. 

See also relative coordinates.



active pane

In a split window, the pane specified by the active pane indicator. AutoSketch applies some of the commands on 
the View menu, such as Redraw and Extent only to the active pane. 

See also view, extent view, page view, and custom view.



actual size

The size of an object in real world size. This is the size objects are stored in the drawing. The size the drawing 
appears onscreen is controlled by view settings. The size the drawing appears on printed output is controlled by 
drawing scale and print settings. View and print settings do not effect the actual drawing size. See also page size 
and world coordinates.

see world coordinates.



alcove 

An offset created in a line or polyline by adding four vertices to the entity. Alcoves are useful to create alcoves for 
bay windows in an architectural floor plan.



alignment axis

The reference axis you specify after you click Transform, Align on the Edit menu. Two points define the alignment 
axis. The first determines its origin and the second its direction.



aligned dimension 

A linear dimension whose length and angle you determine by entering two points. 

See also rotated dimension.



aligned marker

A marker whose location and angle of rotation you determine by selecting an entity. When you click Marker, Align 
To Endpoint on the Draw menu, markers created are aligned at the end of a line, polyline, or arc you select. When 
you click Marker, Align On-Entity on the Draw menu, markers created are positioned at a point you enter on an 
entity, oriented toward the nearest endpoint.



aligned symbol

A symbol instance whose angle you determine by entering two points. The first point determines the symbol’s 
location and the second its angle of rotation.



All-In-One toolbar

A bar with buttons that perform drawing tasks in AutoSketch, as well as buttons for snap modes, controlling views, 
editing entities, and so on. To display or hide the All-In-One toolbar, click Toolbars on the View menu, check the 
All-In-One check box, then click OK.



angle

A measurement of rotation. AutoSketch displays angles using the current units of measurement for angles and 
assumes these units of measurement when you do not enter a specific one. 

See also compass angle, standard angle, and bearing.



angle orientation

The system that specifies direction of rotation for positive angles and the direction specified by zero degrees.

See also standard angle and compass angle.



angular dimension 

A dimension that measures the angle between two lines. An angular dimension consists of an arc, a pair of 
terminators, a pair of extension lines, and a dimension label.



annotation

An entity that is not a part of the geometric or graphic model, but one which provides information for the drawing. 
Text, dimensions, and markers are annotation entities.



ANSI character set

The set of 256 characters specified by the American National Standards Institute. Microsoft Windows uses the 
ANSI character set.



arc

A partial circle. AutoSketch uses an arc’s center, radius, starting angle, and delta angle to determine its shape.



array

A series of entities or groups of entities arranged in a rectangular or circular pattern.

See also rectangular array and circular array.



arrow keys

The four keys on your keyboard labeled with arrows. Each arrow key is named for the direction its arrow points: 
Up Arrow, Down Arrow, Left Arrow, and Right Arrow. In AutoSketch, pressing SHIFT in combination with an arrow 
key moves the selection set by the grid snap interval. Also known as direction keys.



aspect

In AutoSketch, the ratio of character width to character height in a text entity. Lower values (e.g., 0.2) make 
narrow characters. Higher values (e.g., 2.0) make wide characters. The default aspect for most fonts is between 
0.6 and 1.0.



AutoField

A field that AutoSketch assigns automatically when you create an entity. There are four AutoFields: UID, 
SymbolName, SymbolType, SymbolDesc, and Hyperlinks. AutoSketch assigns the UID (unique identifier) 
AutoField to all entities except text and dimensions, while it assigns SymbolName, SymbolType, and SymbolDesc 
to symbols only.



Automatic Snap

An input feature that uses the criteria of the current snap mode to locate the nearest eligible point for the pointer.



AutoPoint Indicators

A red dot that appears when snap modes involving the mouse are active and follows your pointer indicating 
possible snap points. If a lock modifier is active as well, a yellow dot refers to the intermediate snap point while the 
red dot, as constrained by the lock modifier, indicates the actual autopoint. For instance, if you draw a diagonal 
line from top to bottom, then activate Endpoint snap mode and the Y-axis lock modifier, the yellow AutoPoint 
indicator will identify the endpoint nearest the pointer, and the red AutoPoint Indicator represents the resulting 
point based on both the current snap mode and lock modifier.



AutoSelect

A feature that automatically selects the last entity drawn when you cancel most Draw and Edit commands. 
AutoSelect also highlights the last entity drawn while using a Draw command. When AutoSelect is active, changes 
you make on the edit bar affect both the highlighted entity and the entity you are currently drawing.



axis

An imaginary line used as a reference for positioning or manipulating entities.

See also x-axis, y-axis, z-axis and alignment axis.



background layer

A layer on which entities are visible but not editable. 

See also editable layer and masked layer.



backup file

A duplicate drawing file created to safeguard data in the original file from accidental loss. AutoSketch creates 
backup files automatically when the Create Backup File option is checked on the File page of the Drawing Options 
dialog box. Backup files normally have a .BAK extension.



base entity

An entity that consists of a single drawing element such as a line, arc, or circle.

See also entity.



baseline dimensioning

A type of dimensioning in which each dimension in a series of linear dimensions is measured from a single 
extension line.

See also chain dimensioning and single dimensioning.



basepoint

A reference point used for positioning or manipulating entities in a drawing.

See also rotation basepoint, symbol basepoint, and text basepoint.



Basepoint snap mode 

A snap mode you use to enter a point at the basepoint of a symbol by clicking anywhere on the entity.



bearing

An angle expressed in terms of points on the compass. Bearings are expressed as an east or west rotation from 
north or south. A standard 13û52'15" angle, for example, could be expressed as a bearing 76û07'45" east of 
north, or N 76û07'45" E.



bevel 

To replace the intersection of two lines with an angled line segment. Also known as chamfer.

See also round. 



break 

To divide an entity into two shorter entities separated by a gap of a specified width.



break length

In dimensioning, the length of the gap that separates an extension line from its dimension point.



by-layer

Term used to indicate that the layer an entity is on determines its color, style, or width.



by-symbol

Term used to indicate that the symbol instance properties are used for color, style, or width.



CAD

Computer-aided design (or drafting).



calculated value

A database value that is calculated automatically based on the geometry or other property of an entity. Assigning 
certain variables, such as %length, %area, or %color, to a field returns a calculated value.



cartesian coordinates

See XY coordinates.



centerline dimension 

A type of dimension used to mark the center of an arc or circle. It consists of a “cross” marker at the center point 
and four lines extending from the center point through the quadrant points.



Centerpoint snap mode 

The snap mode that allows you to enter the center of an arc, circle, polygon, or bulged poly-segment by clicking 
anywhere along the entity itself.



chain dimensioning

A type of linear dimensioning in which each dimension in a series is measured from the extension line of the 
previous dimension.

See also baseline dimensioning and single dimensioning.



channel 

To trim an entity by removing any portion that falls between two specified parallel lines.



circle 

An entity defined by a center point and a radius.



circular array 

A series of entities or entity groups arranged in a circular pattern.



circular grid

A reference grid whose axes extend radially from the grid origin. Circular grids provide an excellent reference tool 
for drawings that require alignment of points along an arc or circle, such as a mechanical drawing of a gear.

See also isometric grid, rectangular grid, and reference grid.



circular grid angle

The angle between major gridlines in a circular reference grid. Since the sum of all the angles must equal 360, a 
smaller grid angle will result in the display of more major lines.



circumscribed polygon

A regular polygon whose sides are tangent to a defining circle at their midpoints.

See also inscribed polygon and regular polygon.



closed polygon or curve

A polygon or curve whose startpoint and endpoint are connected.



command

The full name associated with an action you carry out by clicking a screen component such as a menu item or 
button. In AutoSketch, a complete list is displayed in the Customize Commands dialog box. 



command bitmap

The bitmap graphic associated with a command that AutoSketch uses to represent the command as a button.



compass angle

An angle measured assuming positive angles rotate clockwise and zero degrees is in the “twelve o’clock” 
direction.

See also standard angle.



convert

To replace an entity of one type with a similarly shaped entity of another type. To translate a drawing file from one 
file type to another. 



coordinate

A pair of numbers that together specify the location of a point.

See also XY coordinates and polar coordinates.



coordinate system

A means of defining a point in space relative to another point (usually called an origin). XY (cartesian) coordinates 
are defined in terms of distances along the X-axis and Y-axis. Polar coordinates are defined in terms of distance 
and angle from the origin. 



corner 

To extend or truncate a pair of existing lines to form a “corner.” Lines extended to form a corner remain separate 
entities.



current property

The layer, pen color, pen width, pen style, or pattern setting that will be applied to new entities. Current properties 
appear on the property bar.



current layer

The layer on which all new entities are drawn. Entities on the current layer are both visible and editable.

See also editable layer, background layer, and masked layer.



current symbol

The symbol that appears in the drawing when you click a button or Draw menu choice for placing a symbol and 
then enter a point. The symbol most recently selected from the symbol bar is current.



current symbol library

The library whose symbols appear on the symbol bar and are listed in the drop-down list box on the edit bar.



curve

In AutoSketch, a special finely-segmented polyline whose shape is determined by three or more control points you 
specify.

See also fitted curve and spline curve.



custom view 

A view saved with a dialog box that you reach by clicking Save on the View menu. Saving a view makes it easy to 
display or print at a later time.

See also view.



decimal precision

The number of decimal places that AutoSketch displays and prints numeric values.



default snap mode

The snap mode to which AutoSketch returns when you cancel an operation.



delete

To remove the selection set from the current drawing without copying it to the Clipboard.



detail report

A report that individually lists each symbol included in the report’s selection criteria. You can update the database 
fields of entities listed in a detail report from the dialog box used to create the report.

See also summary report.



dial

The area at the right end of the status bar where you view the absolute or relative coordinates of the pointer. The 
type of coordinates displayed in the dial changes automatically as you change the grid type: for instance, if you 
change from an isometric to a circular grid, the dial will shift from XYZ to polar coordinates.



diameter dimension 

A dimension that measures the diameter of an arc or circle. A diameter dimension consists of a line, a pair of 
terminators, and a dimension label.



difference 

Subtracting the area of one polygon from another.



dimension

A drawing entity that shows a measurement in a standard format. In AutoSketch, dimensions are associative. That 
is, they update the measurement display automatically when you resize them or when you change the default 
units of measurement.



dimension label

The text string that accompanies a dimension. A dimension label can display text before and after the measured 
value of the dimension.



dimension line

The line or arc in a dimension that shows the range being measured.



direct selection 

The process of selecting entities by clicking on them individually or by enclosing them in a region.

See also Selection Modifier and marquee.



direction keys

See arrow keys.



divide 

To break an entity in two at the point where it is intersected by a second entity.



DLL (Dynamic Link Library)

A file that contains program code that can be used by any Windows application.



double line 

Parallel lines created when you click Line, Double on the Draw menu. Double lines are frequently used to create 
walls in architectural drawings.



drawing file

A storage container for a drawing. An AutoSketch drawing file contains information such as the list of layers and 
database fields, what parts of the drawing are visible, and so on. For each entity, the drawing file stores its 
geometry, a list of graphic properties, and a list of any fields that you have assigned to it.



drawing origin

The point in a drawing that serves as a location reference for all entities in the drawing. The x- and y-axes cross at 
the drawing origin. The coordinates of the drawing origin are 0,0.



drawing scale

The ratio between page (output) size and actual (world) size. In a drawing whose scale is 1:10, for example, an 
entity that is 3 inches long on scaled output represents a real world object that is 30 inches long.



drawing window

A document window that contains a AutoSketch drawing.



Dropper tool 

A tool used to extract the properties of an entity and make them current on the property bar. 



DWF file format

A compressed file format that is easy to publish and view on the Web.



DWG file format

One of two binary drawing file formats used by AutoCAD and Drafix CAD Ultra, respectively. AutoSketch 
exports .DWG files to AutoCAD only.



DXF (drawing interchange) file format

An ASCII- or binary-based drawing file format developed by AutoDesk, Inc. and widely supported by CAD 
programs. AutoSketch both imports and exports .DXF files.



edge

To extend or truncate one entity so it ends at another entity.



edit bar

A bar displayed above or below the AutoSketch workspace. The edit bar allows direct editing of geometry and 
certain other properties for the current entity.

See also property bar and status bar.



editable layer

A layer on which entities are both visible and editable.

See also masked layer and background layer.



ellipse 

Mathematically, the path of a point that moves so the sum of the distances from it to a pair of fixed points remains 
constant. In AutoSketch, an ellipse is approximated using a polygon. The number of sides in the polygon is 
specified on the Drawing page of the Drawing Options dialog box.



embed

To use object linking and embedding (OLE) information from a source document in a destination document. 



embedded object

An object that is a copy of the information from a source document that is placed in the destination document and 
has no link to the source document. 

See also embed and link.



Endpoint snap mode 

A snap mode that allows you to enter the endpoint of an entity by clicking anywhere along it.



entity

A single item or object in a drawing. There are two types of entities: base entities and compound entities. Base 
entities consist of a single drawing element such as a line, polygon, or marker. Compound entities, such as 
symbols and dimensions, are comprised of one or more base entities.



explode

To convert an entity to its base entities.

See also base entity.



export

To save a file using a file format other than the AutoSketch file format. AutoSketch exports several types of 
drawing files: AutoCAD (.DWG), AutoCAD ASCII drawing interchange (.DXF), Drafix CAD port (.POR), and 
Windows metafile (.WMF).

See also import.



expression

A combination of values and operators that yields a result upon evaluation. Expressions are allowed in most text 
boxes on the bars of the AutoSketch screen and in dialog boxes.



extension line

In linear and angular dimensioning, the lines used to indicate the beginning and end of the measurement, which 
usually run from the dimensioned entity to slightly past the dimension line.



extension line overrun

In dimensioning, the distance an extension line runs past the dimension line.



extent

The smallest rectangle that encloses all of the entities in a certain group. The drawing extent is the smallest 
rectangle that encloses all of the entities in the drawing. Likewise, the selection extent encloses the current 
selection set.



extent view 

The smallest view that shows all of the entities currently in a drawing.

See also view, active pane, page view, and custom view.



extrude

To move or copy an entity or group of entities while adding polygons that connect the entities vertices to their 
original location.



fast view

A technique for speeding redraw time by replacing slow-rendering items such as text, symbols, and curves with 
simple components such as lines and boxes.



field

A property assigned to an entity for use in reports. A field consists of a field name, such as “Price,” and a value, 
such as “$1000.00.” 

See also field name and value.



field name

The name of a specific user-defined property assigned to an entity in a drawing. In the field “Price=$1,000”, 
“Price” is the Field Name.

See also field and value.



field precision

The number of decimal places a numeric field value is formatted during export. See also field width.



field type

The datatype of a user-defined database field, either: string, number, length, angle, or area.



field width

The total number of characters for a numeric field including the decimal point and digits following the decimal 
point.

See also field precision.



fill

See pattern.



fillet

See round.



fitted curve 

In AutoSketch, a curve drawn through its control points. 

See also curve and spline curve.



format string

See dimension label.



formula

A mathematical statement that describes the action to be performed on numeric values. A formula sets up a 
calculation without regard to the actual values it is to act upon. A formula can be defined within text entities to 
insert calculated values. 

See also expression and calculated value.



fractional precision

The precision expressed as a fraction in which fractional numeric values are displayed. Fractional precision is 
expressed as a fraction, such as 1/2, 1/4, 1/8, and so on. AutoSketch displays a fraction in its simplest form. This 
means that the fraction 16/32 is displayed as 1/2, even when fractional precision is set to 1/32.



function

A component, either built-in or user-defined, that performs a task and returns a value. You can include functions in 
an expression.



geometry

Mathematical properties of entities, including both those inherent in the definition of the entity (base geometry) 
and those that can be calculated.



grad

Units of measurement for angles equal to approximately 0.9 degrees or 0°54¢0². There are 400 grads in a 
complete circle. In AutoSketch, a grad measurement is expressed with a number followed by a “g,” as in the 
expression “100 g.”



graphic property

A property assigned automatically to all entities. Graphic properties include layer, pen color, pen width, pen style, 
and so on.



grid angle

The degree of rotation applied to all axes of the reference grid. For instance, in a rectangular grid the X axis 
extends from the grid origin at 0 degrees and the Y axis extends at 90 degrees. If you enter a grid angle of 45 
degrees, the X axis will extend from the grid origin at 45 degrees, and the Y axis will extend at 135 degrees.



grid coordinates

Coordinates, or pairs of numbers that, together, specify the location of a point, measured from the grid origin.



grid origin

The point from which the axes of the reference grid extend outward.

See also drawing origin.



grid snap interval

The distance between possible snap points on the reference grid. This determines the accuracy of Gridpoint snap 
mode (if the snap interval is too low, Gridpoint snap mode may not be as useful, if it’s too high, Gridpoint snap 
mode may not allow you to enter the point you want).



Gridpoint snap mode 

A snap mode that allows you to specify points by snapping to the reference grid.



handle

A small graphic, either a box or circle, that appears when editing to allow you to modify the selection set, a 
dimension line, or an entity. AutoSketch has several types of handles: about point handles, rotation handles, 
vertex editing handles, dimension editing handles, and resizing handles.



hard margin

The area built-in to a printer or printer driver which cannot be used for printing. While you cannot reduce the hard 
margin, you can reduce the available printing area by adding your own margins, called soft margins.

See also margin.



hatch 

To annotate a polygon by filling it with a repetitive line pattern. Also an entity created as an anonymous symbol to 
hatch an area bounded by the selection set, i.e. to crosshatch an area.



hatch angle

The angle of rotation at which hatching in a drawing is applied.



hatch spacing

The distance between lines, dashes, and so on, for hatch patterns. Hatch spacing applies to existing polygons 
and future hatch symbols.



hatch style

One of the repetitive line patterns (crosshatches) that you can use to annotate an area or polygon.



horizontal dimension 

A linear dimension that measures the horizontal distance between two points.



hyperlink 

A “jump”, or link, to another location within a document, or a location in a different document. The target of a 
hyperlink can be text, an image, audio, or video file. A hyperlink is similar to a topic jump in a help file.

See also URL.



HPGL (Hewlett Packard Graphics Language) file

A file containing the plotter instructions needed to plot a specific drawing . HPGL is a common format used to 
place graphics in word processors.



import

To open a file using a file format other than the AutoSketch (.SKF) file format. AutoSketch imports several types of 
drawing files: AutoSketch v2.x (.SKD), AutoCAD ASCII drawing interchange (.DXF), Design CAD 2D (.DC2), 
Drafix CAD port (.POR), HPGL (.PLT, .PRN), and Windows metafile (.WMF).



included angle

The relative angle between the start angle and end angle which is the visible portion of the circle.



initial offset

The default distance between the first control point for a linear or angular dimension and the location of the 
dimension line measured along the extension line.



inscribed polygon

A regular polygon whose vertices fall on a defining circle.

See also circumscribed polygon and regular polygon.



intersection 

Creating a polygon from the shared area of two overlapping polygons.



Intersection snap mode 

A snap mode that allows you to specify intersection points by clicking anywhere along a pair of entities including 
lines, polylines, polygons, arcs, or circles.



irregular polygon 

A polygon whose sides or angles are of unequal length.



isometric grid

A reference grid aligned along three major axes, instead of two. This allows you to create two-dimensional 
drawings of three-dimensional objects. Because perspective is not applied, the objects can be accurately 
dimensioned.

See also circular grid, rectangular grid, and reference grid.



join 

To connect a line, arc, or polyline to another line, arc, or polyline, forming a new polyline.



justification

In AutoSketch, the alignment of text in relation to the basepoint. Horizontally, text can be justified left, right, or 
centered. Vertically, text can be justified top, bottom, or centered. Text justified “top right,” for instance, has a 
basepoint at the top right corner of the text extent.



last point

The previous point entered in the current command. Used for Relative snap mode and lock modifiers.



layer

An organizational structure in a drawing roughly equivalent to a sheet of mylar in conventional overlay drafting.



layer description

A detailed description of a layer. Layer descriptions have a maximum of 63 characters.



layer name

The name of a layer. Layer names have a maximum of 31 characters.



layer state

The setting that determines whether new entities are added to a specific layer and whether or not entities on that 
layer are visible and/or editable. There are four layer states in AutoSketch: current, editable, masked, and 
background. 

See also current layer, editable layer, masked layer, and background layer.



leader 

A type of annotation consisting of a marker, one or more connected lines, and text.



leader length

In dimensioning, the length of the automatically generated line segment between the text entity and the extension 
line.



leading zero

Zero displayed before decimal point in decimal numbers less than one (e.g., 0.250 vs. .250).



library

See symbol library.



line 

A straight segment between two points.



line terminator

In dimensioning, a marker used to identify the end of a dimension line or leader.



linear dimension

A dimension that measures linear distance. Linear dimensions normally consist of a line with terminating markers, 
a line of generated text, and, optionally, a pair of extension lines. Linear dimensions include horizontal, vertical, 
aligned, and rotated dimensions.



link 

To use object linking and embedding (OLE) to reference data in another file. When data is linked, any changes to 
it in the source document are automatically updated in the destination document.

See also embed.



linked object

An object that is a copy of the information from a source document that is placed in the destination document and 
has a direct link to the source document. 

See also embed and link.



lock modifier

One of five modifications that you can apply to a snap mode. Lock modifiers align input with the last point and are 
applied after the snap mode.

See also Orthogonal lock modifier, Normal lock modifier, X-axis lock modifierY-axis lock modifier, and Unlock lock 
modifier. 



margin

The area at the perimeter of a page where AutoSketch does not print.

See also hard margin.



marker 

A special type of entity used to mark a point in the drawing. 



marquee 

An area you define for reference in other operations. There are two types of marquees: rectangular and irregular. 
You can define marquees to copy bitmaps to the Clipboard, for reference in selection operations, to save a view, 
and so on.



masked layer

A layer on which entities are neither visible nor editable.

See also background layer and editable layer.



math coprocessor

A chip designed to speed math-intensive programs such as AutoSketch. Math coprocessors handle math 
operations rapidly, freeing the main processor, or CPU, to work on other tasks. Some CPUs, such as the 486DX 
and Pentium processors, have math coprocessors built in.



merge 

To add the contents of a drawing file to the current drawing.



metafile

See Windows metafile.



Midpoint snap mode 

A snap mode that allows you to specify the midpoint of a line, arc, polyline segment, and so on by clicking 
anywhere on it.



mirror 

To create a reversed version of a selected entity or group of entities by reflecting it (applying a negative scaling 
factor) across a specified axis.



Nearest snap mode 

A snap mode that allows you to select a point on an existing entity by clicking near the entity.



nested symbol

A symbol that contains other symbols as components.



Normal lock modifier 

The lock modifier which restricts input to points perpendicular to an imaginary line drawn between the previous 
two points.

See also Orthogonal lock modifier, X-axis lock modifierY-axis lock modifier, and Unlock lock modifier.



numeric expression

An expression that evaluates to a single numeric value. Numeric expressions can contain numbers, numeric 
variables, numeric functions, and operators. You can enter numeric expressions in most text boxes on the 
AutoSketch screen and in dialog boxes.

See also expression.



numeric list

A list of numbers. In AutoSketch, the syntax for numeric lists allows loops and repetitions of both relative and 
absolute expressions. For example, you could express the numeric list “1 2 3 4 5 6 7 8 9 10” as the loop “1 TO 10 
BY 1” or as the repetition “1++9@1.”



OLE

For Object Linking and Embedding. An information-sharing method in which data from a source document can be 
linked to or embedded in a destination document. Selecting the data in the destination document opens the 
source application so that the data can be edited. 

See also embed and link.



OLE Object

See embedded object and linked object.



offset

The distance measured perpendicularly from the nearest segment of an existing entity or input line. Offsets are 
positive to the right of an entity when looking from the start toward the end of a line segment.



open curve

A curve whose beginning and ending points are not automatically connected.



operator

A keyword, such as AND, or a symbol, such as “*,” that manipulates values in an expression.

See also expression.



ordinate dimension 

A dimension used to mark either the x- or y-coordinate of a specific point in a drawing.



orientation

The position of a page. Portrait orientation displays a page taller than it is wide. Landscape orientation displays a 
page wider than it is tall.



origin

The point having the location 0,0 in any coordinate system.



Orthogonal lock modifier 

The lock modifier which restricts input to a points aligned either horizontally or vertically with the previous point.

See also lock modifier.



page

A single piece of paper. By default the page size is set as the printer page size, i.e., if you select an envelope size 
in your default printer setup that will be used as the default page size. If the selected page is larger than the 
printer page output will be automatically tiled onto multiple pages. Also a section of a dialog box or property sheet 
reached by clicking a tab.



page coordinates

Coordinate system based on output size. If your scale is 1:1 and the drawing origin is located at the lower left 
corner of the page, paper coordinates are the same as drawing coordinates.



page tiling

The process of tiling pages horizontally and vertically into rows and columns so as to print the entire page.



page view 

The view which displays the page as large as possible in the drawing window.

See also view.



pan 

To “move” a drawing in a pane by selecting two points. The points specify the distance and direction of 
movement. Panning does not change the level of magnification, or zoom level, for the pane.



pane

A rectangular portion of a drawing window capable of independent zooming, panning, and so on. You can position 
the split boxes to create either one, two, or four panes in a drawing window.



pattern

For polygons, the property that specifies its fill as either solid, hatch, or none. For hatch symbols, the hatch used 
to create the symbol.



pen

A property assigned to a entity that defines its color, style, and width.



pen color

A color assigned to an entity. There is a 256 color custom palette in AutoSketch.



pen style

A line pattern assigned to an entity. There are nine pen styles in AutoSketch: solid, short dash, long dash, center 
line, phantom, dotted, dash dot, divided, and border.



pen width

A line thickness assigned to an entity. There are five pen widths in AutoSketch: one, three, five, seven, and nine 
pixels.

See also poly width.



Perpendicular snap mode 

A snap mode that allows you to draw a line perpendicular to a selected line by entering a single point.



plotter file

See HPGL (Hewlett Packard Graphics Language) file.



plus/minus rotation

The angle applied to the current angular rotation of a symbol or a regular polygon while inserting using the plus 
and minus keypad keys.



polar coordinates

Coordinates of the form (r, Ø) that represent a point in terms of a distance (r) and directed angle (Ø). Example: If 
centimeters and degrees are current units of measurement, a point twelve centimeters away at 45 is specified by 
the coordinates 12, 45. 



poly

A general term used to mean polyline, polygon, curve, ellipse, and so on.



poly-entity

An entity consisting of several segments.



polygon

A closed shape with multiple sides. A polyline whose beginning and ending points are connected (closed).

See also irregular polygon and regular polygon.



polyline 

A series of lines with connected endpoints. Polylines are treated as a single entity by AutoSketch.



poly width

Width in world coordinates of the start or end of a poly segment.

See also pen width.



pop-up menu

A menu which appears at the current pointer location over the AutoSketch screen. You create pop-up menus by 
assigning a set of pop-up items to a command name. Also called right mouse button menu.

See also command.



pop-up window

A small window that displays information telling you what a control or other screen element is and how you can 
use it. You access it by clicking the question-mark button and then clicking the item.



port file

An ASCII-based graphics file format used by some third-party applications to manipulate data from certain 
versions of Drafix CAD Ultra and Drafix CAD 1 Plus.



printable area

The area of the page where a printer can place ink. Calculated as the page size minus the hard margin.

See also hard margin and margin.



project information

Information about a drawing file that can help you identify the drawing it contains. Project information includes 
information such as project title, the drawing number, the revision number, and so on.



property

An item of information assigned to an entity. Properties include geometry, layer, pen, pattern, and so on. User-
defined properties are called fields.



property bar

A tool bar containing controls for setting graphic entity properties. 

See also edit bar and status bar.



property painter 

A tool used to match the properties of one entity to another: for instance, to make sure a polygon has the same 
appearance as another polygon or is on the same layer. 



proportional scaling

To constrain scaling so as not to distort an entity while resizing. That is, to keep both the horizontal and vertical 
scaling factors equal.



quadrant snap mode 

A snap mode that allows you to specify a point at 0, 90, 180, or 270 degrees on an arc or circle by clicking near 
the point. You can set a finer interval using the Quadrant Snap drop-down list on the Drawing page of the Drawing 
Options dialog box.



qualifier

See selection qualifier.



question mark

The character (?) you type to match a single character in a filename or database field.



radian

Units of measurement for angles equal to approximately 57°17¢44.6². There are 2p radians in a complete circle. 
In AutoSketch, a radian measurement is expressed with a number followed by “rad,” as in the expression “1.5708 
rad.” You can convert radians to degrees by multiplying radians by 180/p gives degrees.



radius dimension 

A dimension used to note the radius of an arc, circle, or bulged poly-segment.



raster image

A bitmap file.



rectangle 

In AutoSketch, a four-sided irregular polygon whose opposite sides are equal and whose angles are all 90 
degrees. 



rectangular array 

To repeat a selection set in a two-dimensional array based on a list of x- and y-values. The list may be regular 
(even spacing) or irregular.



rectangular grid

A reference grid with snap intervals and lines that parallel the X and Y axes. This grid is the standard reference 
tool for most two-dimensional drawings. 

See also circular grid, isometric grid, and reference grid.



redo 

To reverse the effects of an undo command. 

See also undo.



redraw 

To update the image in the drawing area. A redraw is sometimes necessary when an operation leaves some part 
of the image incomplete. To force a redraw, click Redraw on the View menu or toolbar or the shortcut key 
CTRL+R. 



reference grid

An on-screen drawing aid consisting of a snap grid and a pattern of lines and dots which represent the grid 
visually. 

See also circular grid, isometric grid, and rectangular grid.



region selection 

The process of selecting entities by including them in a rectangular or irregular area of the drawing.

See also marquee.



regular polygon 

A polygon in which all sides are equal and all angles are equal.



relative coordinates

Coordinates that specify location in relation to the last point. For example, the relative XY coordinates 18,-26 
describe a point 18 units right of and 26 units below the previous point. 

See also absolute coordinates.



render depth

A value that specifies the smoothness of fitted curves. Higher values make curves smoother. Lower values make 
them faster to display and print.



resizing handle

A scaling handle that appears when an entity is selected, or handles that appear around a selection set.



rotated dimension 

A linear dimension oriented at an angle you specify rather than at one determined by the control points.



rotation basepoint

The point about which an entity or selection set is rotated. 



rotation handle

Handle extending from about point of a selection set used for rotation. 

See also handle.



round 

To replace the intersection of two lines with an arc of a specified radius. 

See also bevel.



rubber band

The dynamic display of an entity or region as it is entered or resized while you drag or move the mouse.



scalar

Numeric value without unit conversion factor., i.e., a unitless number. An example of this is Text Aspect, on the 
Label page of the Linear Dimension Format dialog box.



scale

In AutoSketch, the ratio between the size of an entity on scaled output and the size of the real world object it 
represents. For example, if an entity that is one inch long on scaled output represents a real world object that is 48 
inches long, the drawing scale is 1:48.



segment

A straight line between control points in a curve or between vertices in a polygon or polyline.



selection fence          

A selection tool that allows you to select entities by creating special polyline. Only entities that the polyline, or 
fence, crosses are selected.



Selection Modifier

A dialog box that allows you to modify the current selection set by adding or subtracting entities on the basis of 
layer, symbol type, field value, or position in relation to a marquee.



selection operator

An operation used to combine selection qualifiers in the Selection Modifier. AutoSketch contains three selection 
operators: AND, OR, and NOT.



selection qualifier

One of the commands used to select a groups of entities in the Selection Modifier.



selection set

A group of selected entities. The selection set is indicated by selection handles around the highlighted entities. 

See also handle and Selection Modifier



selection statement

A description of entities to include in a selection set. The Selection Modifier uses selection statements to select 
entities. 

See also Selection Modifier, and selection set.



shortcut key

A key or key combination that carries out an action in Windows. In AutoSketch, for example, CTRL+A selects all 
entities in a drawing. 



single dimensioning

A type of dimensioning in which each dimension has extension lines not shared by other dimensions.

See also baseline dimensioning and chain dimensioning.



sizing method

A method of transforming coordinates from world coordinates to page coordinates for output. Methods included 
fitted and scaled. 



sketch 

To create a “freehand” polyline by holding down the mouse button and dragging while AutoSketch traces the 
movement of the pointer.



SKD file format

The file format used by AutoSketch release 3.0 and earlier files. Autosketch can import .SKD files, but cannot 
export them.



snap off mode 

A snap mode that allows you to specify points based only on pointer position.



snap mode

A means of entering points using the mouse or keyboard. You can change the snap mode at any time during most 
Draw and Edit operations by typing the appropriate keyboard shortcut. 

See also lock modifier.



spline curve 

A curve that does not pass through its control points but is “drawn toward” them. 



split box

The black box found on the scroll bars of drawing windows. Dragging a split box toward the center of its scroll bar 
causes the drawing area to be split into two or four separate panes.



standard angle

An angle measured assuming positive angles rotate counterclockwise and zero degrees is in the “three o’clock” 
direction. 

See also compass angle.



standard toolbar

A Microsoft Office compatible toolbar with buttons that perform some of the most common tasks in AutoSketch, 
such as opening, copying, and printing files. To display or hide the Standard toolbar, click Toolbars on the View 
menu, click the Standard check box, then click OK.



status bar

A graphic bar displayed below the workspace. The status bar is comprised of the message area and the dial. The 
message area displays command descriptions and other messages. 

See also dial, edit bar, and property bar.



stretch 

To elongate an entity or group of entities. Reached by clicking Edit, pointing to Transform, then clicking Stretch, 
this command stretches by moving any entity control points that fall inside a marquee region without moving any 
of the remaining control points.



subdivide 

To divide a segment into equal size smaller segments.



summary report

A report that lists by entity type the entities included in the report’s selection criteria. Subtotals by type are 
automatically generated. 

See also detail report.



symbol

In AutoSketch, a collection of entities combined to form a single entity. A symbol definition contains the entity data 
needed to place a symbol anywhere in the drawing. A symbol instance records the location of a symbol in the 
drawing. While you can create many instances of a symbol in a single drawing, AutoSketch only needs to store its 
definition once, saving memory. 

See also symbol library.



symbol basepoint

The point you enter when placing a symbol.



symbol bar

A bar that displays all of the symbols in the current symbol library. Holding the pointer over one of the symbols in 
the palette displays a pop-up window. Clicking one of the symbols makes it current.



Symbol Explorer

A tool for performing a wide variety of symbol-related functions, including creating and renaming symbol libraries, 
copying symbols between libraries and drawings, deleting symbols, and setting a current library and a current 
symbol.



symbol library

A file containing one or more symbols. Symbol libraries make it easy to share symbols across drawings. Symbol 
libraries use their own file format separate from the AutoSketch drawing file format. They typically have an 
extension of .SLB. 



Tangent snap mode 

A snap mode that allows you to specify the tangent point on an arc or circle from the current point by clicking 
anywhere along the arc or circle.



template

A drawing file in which all desired parameters such as borders, title blocks, grid spacing, units, and so on have 
been set. You can use templates to quickly set up a new drawing. When you use a template, you should save the 
new drawing under a different name to preserve the template file.



terminator

See line terminator.



text angle

In dimensioning, the orientation of the dimension label with respect to the page. There are two choices: aligned 
and one direction. Aligned text runs parallel to the dimension line. One direction text is parallel to the bottom of the 
page.



text aspect

The ratio of text width to height.



text basepoint

The point used to establish the location of a text string. The text string is rotated and justified about this point. 
When so specified on the Visibility page of the View Options dialog box, text points are displayed on the screen as 
small crosses. 

See also basepoint.



Text Editor

The window that allows multi-line text entry, cutting, copying, and pasting to the Clipboard, and merging other text 
files. The Text Editor is accessed by double-clicking on an existing text entity or by clicking the Editor button in the 
Text Input dialog box.



text entity

A drawing entity comprised of characters from an AutoSketch or TrueType font.



text height

In AutoSketch, the height of the upper case characters in a font measured in output size.



tiling pattern

See page tiling.



tolerance

AutoSketch supports two tolerance display modes: plus/minus and range. Plus/minus tolerance shows the 
calculated measurement followed by a negative tolerance and a positive tolerance. Range tolerance shows the 
lower end of the range and the upper end. AutoSketch calculates these values automatically by subtracting the 
minus tolerance from the calculated value and adding the plus tolerance.



toolbar

A bar containing buttons which you can click to carry out an operation. Clicking some buttons reveals a group of 
related buttons.



ToolTip

A screen component that provides brief information about buttons in a toolbar. A tooltip appears when you position 
the pointer over a button for a few seconds without moving it.



tracing

Drawing over a raster image of an existing drawing onscreen, or on a drawing tablet, using the same tools and 
methods used to create any drawing. In this way, you convert a collection of colored pixels to vector, or “draw” 
graphics, in which images are defined mathematically.



transform

To move, scale, or rotate an entity. AutoSketch also supports compound transformations such as aligning, 
mirroring, and stretching.



translate

To move an x- and y-displacement (or delta x and y) defined by two points.



trim

To edit an entity’s geometry by performing one of the following operations: alcove, bevel, break, channel, corner, 
difference, divide, edge, intersection, join, round, subdivide, or union.



UID 

See unique identifier (UID).



URL 

See uniform resource locator (URL).



undo 

To reverse the effects of the most recent edit or draw command. Using the drop-down arrow, you can select a 
sequence of several editing operations to reverse. 

See also redo.



uniform resource locator (URL) 

A networked extension of the standard filename concept that points to a file in a directory that can exist on any 
computer on the Internet and can be served using a variety of different methods. URLs can point to many things 
other than files including, documents stored within a database, queries, a Web page, and so on.



union 

Creating a polygon from the combined area of two overlapping polygons.



unique identifier (UID)

A unique number AutoSketch assigns to each entity automatically.



units of measurement

The set of units for displaying and entering coordinates, distances, angles, and areas.



Unlock lock modifier 

The lock modifier which effectively “turns off” other lock modifiers to allow you to enter points without regard to the 
previous point. Unlock is the default lock modifier. 

See also lock modifier.



user-defined property

See field.



value

The specific numeric or textual information assigned to a Database Field. In the field “Price=$1,000”, “$1,000” is 
the value. In the field “Name=Mr. Jones”, “Mr. Jones” is the value.



vertex

In AutoSketch, the control points between which segments are drawn or a curve is generated.



vertical dimension 

A linear dimension whose length is determined by points you select, but whose angle is restricted to vertical.



view

A specific rectangular area of a drawing. Views define what part of the current drawing is displayed or printed. 

See also active pane, extent view, page view, custom view, and marquee.



Windows metafile

A Windows-supported file format used for transferring graphics from one application to another as objects (i.e., 
lines, circles, polygons, etc.) rather than pixels.



wizard

A dialog box, or series of dialog boxes, which help guide you through specific procedures by displaying options 
and simple instructions.



working point 

A point not used in a draw or edit operation but required to construct one that is.



world coordinates

Coordinates that specify location in terms of real world distances. A point, for instance, that is 16 feet to the right of 
the origin and 25 feet below it has the world coordinates 16¢,-25¢.



x-axis

An imaginary horizontal line through the drawing origin that serves as a reference for all horizontal distances in 
the drawing. 

See also drawing origin and y-axis.



X-axis lock modifier 

The lock modifier which restricts input to points aligned horizontally with the previous point. 

See also lock modifier.



XY coordinates

Coordinates that determine location in terms of an offset measured along the x- and y-axes. In AutoSketch, the 
term used to refer to Cartesian coordinates. 



XYZ coordinates

Coordinates that determine location in three-dimensional space measured along the x-, y-, and z-axes. 

See also isometric grid.



y-axis

An imaginary vertical line through the drawing origin that serves as a reference for all vertical distances in the 
drawing. 

See also drawing origin and x-axis.



Y-axis lock modifier 

The lock modifier which restricts input to points aligned vertically with the previous point. 

See also lock modifier.



z-axis

An imaginary line through an isometric drawing that represents a third dimension. 

See also drawing origin, x-axis, and y-axis



zoom in 

To magnify a portion of the drawing.



zoom out 

To shrink a portion of the image in the active pane.



Customizing the Grid

AutoSketch’s reference grid is an onscreen drawing aid consisting of a snap grid and a pattern of lines or dots 
which represent the grid visually. There are three types of reference grids available in AutoSketch, each suited for 
different drawing purposes. 

The default grid is rectangular, with snap intervals and lines that parallel the x- and y- axes. This grid is the 
standard reference tool for most two-dimensional drawings. Circular grids extend radially from the grid origin. 
They provide an excellent reference tool for drawings that require alignment of points along an arc or circle, such 
as a mechanical drawing of a gear. Finally, isometric grids align along three major axes, instead of two. This 
allows you to create two-dimensional drawings of three-dimensional objects. Because perspective is not applied, 
the objects can be accurately dimensioned.

AutoSketch allows you to modify the settings for each of the reference grids. For each type of grid, controls on the 
Grid page of the Drawing Options dialog box allow you to change the default origin, angle, grid snap interval, and 
so on. Likewise, controls on the Appearance page of the View Options dialog box allow you to change the default 
color and appearance of the grid’s lines and dots. You can also change the grid type, angle, origin, and so on, 
from the Grid edit bar. If your drawing requires you to switch grid types often, you can also use the Grid toolbar to 
change the grid type or to double or halve the size of the grid.
    Related Topics



Changing the Grid

You may have projects or preferences that require you to change AutoSketch’s grid default settings to meet 
specific requirements. If so, you can easily adjust the grid snap interval, as well as the frequency and position of 
major and minor grid lines, to increase or decrease the grid’s density. You can even change the grid origin and 
angle if you need to align your drawing to a known point or angle.

Changes to the grid settings are performed on the Grid page of the Drawing Options dialog box. Changes to the 
default color or style of lines, dots, and the Drawing Origin are made on the Appearance page of the View Options 
dialog box. 
    Related Topics



Setting Up the Grid

The grid snap interval the distance between the points on the reference grid
affects a drawing anytime you are using Gridpoint snap mode. When you use Gridpoint snap mode, the coordinates 

of all points you enter are rounded to a multiple of the snap interval. Normally, the horizontal and vertical settings for 
the grid are the same, but they can be specified individually.
The lines and dots of the grid provide a visual reference only. The lines of the reference grid are separated into two 
categories: major and minor. AutoSketch allows you to customize the appearance of the reference grid by selecting 
color and pen style for major and minor lines. 

By default, the grid origin of the default reference grid is located at the drawing origin, which, in turn, is located in 
the lower left corner of the page, with the x-axis extended at 0 degrees and the y-axis extended at 90 degrees. 
However, if you need to align an entity, you can change the grid origin position, which is normally set to 0,0. 
Likewise, if you need to draw along a specific alignment or angle, you can rotate the grid. This realigns the pattern 
of lines and dots in the reference grid, affecting both the snap points available in Gridpoint snap mode and the X-
axis lock modifier, Y-axis lock modifier, and Orthogonal lock modifier.

The circular grid is a useful tool for drawings that require points to align along an arc or circle. However, when 
setting up the circular grid, it is almost always necessary to reposition the Grid Origin so the radial lines of the grid 
are aligned correctly with the drawing.

There are three isometric grid types to choose from each offering a different drawing plane for the snap grid. 
Isometric Top aligns the snap and line grids along 30- and 150- degree axes. Isometric Left aligns the grids along 
90- and 150- degree axes. And Isometric Right aligns the grids along 90- and 30- degree axes. When drawing a 
three dimensional model, you can use the isometric grids to draw on a top, left, or right plane.

    Related Topics



To set up the rectangular reference grid

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Grid page tab, then click the Rectangular page tab.

3 (optional) Check the Keep Grid Square check box. When the check box is unchecked, you must enter both 
horizontal and vertical values in each of the following steps.

4 Enter the distance between gridpoints in the Snap Interval text box.

5 (optional) Check the Major as Interval check box. This check box is the direct link between the displayed grid 
and the snap interval grid. When the check box is unchecked, you must enter the number of snap intervals 
between major lines. When the check box is checked, you must enter the interval between major lines.

6 (optional) Enter the number of snap intervals between major lines in the Major Frequency text box.

7 (optional) Enter the distance between major lines in the Major Interval text box.

8 Select a style from the Minor Style drop-down list box. 
None removes the minor lines from the reference grid. 
Subdivisions creates a pattern of minor lines, all equally spaced between major lines
Offset creates one minor line, offset a specific distance from the major line. 
Double Offset creates minor lines offset a specific distance on both sides of each major line.

9 (optional) Click a number of subdivisions between major lines in the Minor Subdivisions drop-down list box.

10 (optional) Enter an offset distance between the minor and major lines in the Minor Offset distance text box.

11 (optional) In the Grid Position section, enter new coordinates in the Origin text boxes. The first text box is the 
x-coordinate, the second is the y-coordinate.

12 (optional) Enter a new angle for the x-axis in the Angle text box.

13 Click OK.



To set up the circular reference grid

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Grid page tab, then click the Circular page tab.

3 Enter the distance between gridpoints in the Snap Interval text boxes.

4 (optional) Check the Major as Interval check box. This check box is the direct link between the displayed grid 
and the snap interval grid. When the check box is unchecked, you must enter the number of snap intervals 
between major lines. When the check box is checked, you must enter the interval between major lines.

5 (optional) Enter the number of snap intervals between major lines in the Major Frequency text box.

6 (optional) Enter the distance between major lines in the Major Interval text box.

7 Select a style from the Minor Style drop-down list box. 
None removes the minor lines from the reference grid. 
Subdivisions creates a pattern of minor lines, all equally spaced between major lines
Offset creates one minor line, offset a specific distance from the major line. 
Double Offset creates minor lines offset a specific distance on both sides of each major line.

8 (optional) Click a number of subdivisions between major lines in the Minor Subdivisions drop-down list box.

9 (optional) Enter an offset distance between the minor and major lines in the Minor Offset distance text box.

10 (optional) In the Grid Position section, enter new coordinates in the Origin text boxes. The first text box is the X 
coordinate, the second is the Y coordinate.

11 (optional) Enter a new angle in the Angle text box.

12 Click OK.



To set up the isometric reference grid

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Grid page tab, then click an Isometric page tab.

3 (optional) Check the Keep Grid Square check box. When the check box is unchecked, you must enter both 
horizontal and vertical values in each of the following steps.

4 Enter the distance between gridpoints in the Snap Interval text box.

5 (optional) Check the Major as Interval check box. This check box is the direct link between the displayed grid 
and the snap interval grid. When the check box is unchecked, you must enter the number of snap intervals 
between major lines. When the check box is checked, you must enter the interval between major lines.

6 (optional) Enter the number of snap intervals between major lines in the Major Frequency text box.

7 (optional) Enter the distance between major lines in the Major Interval text box.

8 Select a style from the Minor Style drop-down list box. 
None removes the minor lines from the reference grid. 
Subdivisions creates a pattern of minor lines, all equally spaced between major lines
Offset creates one minor line, offset a specific distance from the major line. 
Double Offset creates minor lines offset a specific distance on both sides of each major line.

9 (optional) Click a number of subdivisions between major lines in the Minor Subdivisions drop-down list box.

10 (optional) Enter an offset distance between the minor and major lines in the Minor Offset distance text box.

11 (optional) In the Grid Position section, enter new coordinates in the Origin text boxes. The first text box is the 
x-coordinate, the second is the y-coordinate.

12 (optional) Enter a new angle in the Angle text box.

13 Click OK.

Tip
It is important to set the grid origin if you want the dial to display x, y, and z values accurately. 



Changing the Appearance of the Grid and the Drawing Origin

AutoSketch allows you to customize the visual appearance of the reference grid and drawing origin. You can 
change the color AutoSketch uses to display these drawing aides and you can change the size of the lines and 
crosses that make up the reference grid. For information on configuring the reference grid, see Setting Up the 
Grid.

You can hide the reference grid if you don’t need this drawing aid. AutoSketch automatically hides lines or dots 
lines if the current zoom level would place so many of them onscreen that it would obscure the drawing. Gridpoint 
snap mode continues to operate correctly regardless of the onscreen grid display.

You can also hide the drawing origin if you find it unnecessary for a drawing. If you do not use absolute 
coordinates, you may not be concerned with the position of the drawing origin. Much like hiding the reference grid, 
hiding the drawing origin does not remove any functionality. Absolute snap mode still operate normally.
    Related Topics



To change the appearance of the reference grid

1 On the View menu, click View Options. The View Options dialog box appears.

2 Click the Appearance page tab.

3 Click a color from the Major Color and Minor Color drop-down list boxes.

4 (optional) Click a line style from the Major Style and Minor Style drop-down list boxes.

5 (optional) Click a size from the Cross Size drop-down list box. 

6 Click OK.

Note
Changing the size of the crosses that make up the reference grid also affects the size of the drawing origin. 



To hide the reference grid

1 On the View menu, click View. The View Options dialog box appears.

2 Click the Appearance page tab.

3 Check the Show Grid check box. When checked, the Reference Grid appears in the drawing window. When it 
is unchecked, the Reference Grid is hidden.

4 Click OK.



To change the colors of the drawing and grid origins

1 On the View menu, click View. The View Options dialog box appears.

2 Click the Appearance page tab.

3 Click the X, Y, or Z Axis color button. The Color dialog box appears.

4 Click one of the pre-mixed colors from the palette on the left, or design your own custom color using the 
controls on the right.

5 Click Apply.

6 Click OK.



To hide the drawing origin

1 On the View menu, click View. The View Options dialog box appears.

2 Click the Appearance page tab.

3 Uncheck the Drawing Origin check box. When checked, the Drawing Origin is displayed in the drawing 
window. When unchecked, the Drawing Origin is hidden.

4 Click OK.



Using the Grid Edit Bar

AutoSketch’s Grid edit bar, allows you to alter the current grid, or select a new grid type. The Grid edit bar has 
many controls similar to those found on the Grid page of the Drawing Options dialog box, including those that 
control grid type, grid snap interval, major line interval, minor subdivisions, minor offset, circular grid angle, grid 
origin, and grid angle. There are also buttons that open the Appearance page of the View Options dialog box and 
the Grid page of the Drawing Options dialog box.

The Grid edit bar appears when you click the Edit Grid button on the Standard toolbar and remains until you 
cancel the command, or until you click the Close button at the right end of the bar.
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Changing a Drawing’s Grid Type on the Grid Edit Bar

While the default reference grid is rectangular, AutoSketch’s Grid edit bar allows you to select circular or isometric 
grids for specific tasks or drawings. Circular grids are useful for drawings that require points to align along an arc 
or circle. Isometric grids allow you to create 2D drawings of 3D objects for a standard isometric view.
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To change grid types

1 Click the Edit Grid button on the Standard toolbar. The Grid edit bar appears.

2 Select a grid type from the Grid Type drop-down list box.

3 (optional) Enter new coordinates for the grid origin in the Grid Origin text box and press ENTER. 

4 (optional) If you selected a circular grid, enter a new angle in the Circular Grid Angle text box. This is the angle 
between radial gridlines. Since the sum of all the angles must equal 360, smaller angles will result in the 
display of more major lines.



Changing Other Grid Settings on the Grid Edit Bar

You can also change settings such as the grid snap interval and grid angle from the Grid edit bar. This is 
especially useful when a specific task requires you to align some points to a known angle or point, or at specific 
intervals.

Using buttons on the Grid edit bar, you can also make changes on Options pages that relate to the reference grid. 
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To change other grid settings

1 Click the Edit Grid button on the Standard toolbar. The Grid edit bar appears.

3 (optional) Enter a new value in the Grid Snap Interval text box.

4 (optional) Enter a new value in the Major Line Interval text box. This number should be a multiple of the grid 
snap interval.

5 (optional) If you selected Subdivisions from the Minor Style drop-down list box, enter the number of 
subdivisions in the Minor Subdivisions text box.

6 (optional) If you selected Offset or Double Offset from the Minor Style drop-down list box, enter a value in the 
Offset Distance text box.

7 (optional) If you are using a circular grid, and if you selected Offset or Double Offset from the Minor Style drop-
down list box, enter a value in the Angular Offset text box.

8 (optional) If you are using a circular grid, enter a new value in the Circular Grid Angle text box.

9 (optional) Enter new coordinates for the grid origin in the Grid Origin text box.

10 (optional) Enter a new rotation angle in the Grid Angle text box.



To change grid settings from the Grid edit bar
Click the View Options button at the left end of the Grid edit bar. The View Options dialog appears with the 

Appearance page displayed. Follow the instructions in Setting Up the Grid.



To change grid appearance from the Grid edit bar
Click the Grid Options button near the left end of the Grid edit bar. The Drawing Options dialog box appears 

with the Grid page displayed. Follow the instructions in Changing the Appearance of the Grid and the Drawing Origin.



Using the Grid Toolbar

The Grid toolbar is designed for drawings that require frequent changes in grid type or size. For example, when 
drawing an isometric model, it’s helpful to use the isometric top grid to draw on a top plane, the isometric left grid 
to draw on a left plane, and the isometric right plane to draw on a right plane. By clicking one of the buttons on the 
Grid toolbar, you can easily switch between grid types.

The final two buttons allow you to change the size of the reference grid by increasing or decreasing the Major Line 
Interval by a factor of two. The Double Grid Size button doubles the Major Line Interval. The Halve Grid Size 
button halves the Major Line Interval.
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To display the Grid toolbar
Right-click any bar or toolbar and click Grid on the pop-up menu that appears. If a check appears beside the 

item, that toolbar is displayed in your drawing window.

OR

1 On the View menu, click Toolbars. The Toolbars dialog box appears.

2 Scroll down the list of toolbars, then click in the Grid check box. When the check box is checked, the Grid 
toolbar appears in your drawing window.



To change the grid type and size using the Grid toolbar

1 Click one of the Grid Type buttons (Rectangular, Circular, Isometric Top, Isometric Left, or Isometric Right) on 
the Grid toolbar.

2 Click one of the Grid Size buttons on the Grid toolbar.



Selecting and Deleting Entities

In general, only entities that are selected can be acted upon. To delete an entity, for example, you must select it, 
then click Delete on the Edit menu. This topic describes all of the techniques for selecting entities in AutoSketch.

When you select an entity, it becomes part of the current selection set. This group consists of highlighted entities 
surrounded by handles. You can add entities to the selection set and remove them anytime you like. With each 
change, the handles are adjusted to reflect the extent of the current selection set. The selection set can contain 
any number of entities from a single entity to all entities in the drawing. Any action you perform on the selection 
set affects all selected entities.

You can select entities using a variety of techniques. You can select them directly, using the mouse, you can 
select all of the entities in the drawing using a command, or you can use the Selection Modifier.

The Selection Modifier allows you to select entities based on their properties. This is a very powerful capability. 
With it, you can select all of the entities on the Plumbing layer, all of the symbols that represent desks costing over 
five hundred dollars, or all of the entities in the drawing except red circles and green arcs.

The buttons for selecting entities are contained in the first toolset of the All-In-One toolbar.

When you finish working with a selection set, you can clear it. This deselects all entities and results in an empty 
selection set. Clearing the selection set when you are finished with it is a good way to avoid inadvertent changes.
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Selecting Entities with the Mouse

Using the mouse is the simplest way to select an entity. With the mouse you can select a single entity or multiple 
entities using one of the two region selection methods. If you drag the pointer from left to right, only entities that 
are completely inside the region are selected. If you drag the pointer from right to left, even entities that are 
partially inside the region are selected. You can also select single or multiple entities by defining a special polyline, 
in which only entities that the polyline crosses are selected. The edit bar displays the number of entities selected.

You can also use the mouse to add or subtract entities from the selection set. This technique actually toggles the 
status of each entity it affects.
    Related Topics



To select an entity with the mouse

1 Click the selection button on the All-In-One toolbar.

2 Click the entity.



To select entities in a rectangular region

1 Click the selection button on the All-In-One toolbar.

2 Click and drag to define the region.



To select all entities inside an irregular region

1 On the Edit menu, click Select, Inside Polygon, or click the Inside Polygon Select button on the All-In-One 
toolbar.

2 Enter three or more vertices to define the region. A rubber-band line follows the pointer. Press DELETE to 
remove the last vertex entered. 

3 Right-click. The entities completely inside the irregular polygon are selected.



To select entities using a polyline

1 On the Edit menu, click Select, Fence or click the Select Fence button on the All-In-One toolbar. 

2 Enter two or more vertices to define the polyline. A rubber-band line appears and follows the pointer. Press 
DELETE to remove the last vertex entered. 

3 Right-click to stop entering vertices. Any entities the polyline crosses are selected. 



To add or remove entities from the selection set
Press SHIFT as you use any of the three methods described above.



Selecting All Entities in a Drawing

With a single command you can select every entity in the drawing except those on background layers and masked 
layers. Selecting everything is useful when you want to reposition the drawing on the page, align the entire 
drawing to the grid, change specific properties for the entire drawing, and so on.
    Related Topics



To select all entities in a drawing
On the Edit menu, click Select, All, or click the Select All button on the All-In-One toolbar.



Using the Selection Modifier

The Selection Modifier allows you to add or subtract entities from the selection set    based on their properties. On 
the Edit menu, click Select, Modify Selection to access the Selection Modifier dialog box, or click the Selection 
Modifier button on the All-In-One toolbar. Using the Selection Modifier, you can select all entities on the Electrical 
Connections layer, all entities displayed with red dashed lines, all symbols that represent equipment purchased 
from a specific manufacturer, and so on.

To specify the entities you want to add or subtract with the Selection Modifier, you build a selection statement. 
This statement describes a group of entities using qualifiers and operators. A qualifier is a phrase, such as 
color=‘Red’ or layer=‘Plumbing’, that identifies a specific condition. An operator is a word that combines qualifiers 
to form a more complex qualifier. There are four logical operators:

Enclosing part of the selection statement in parentheses causes AutoSketch to evaluate that portion before the parts 
that are outside the parentheses. For example, the following statement selects all entities on the Electrical layer and 
that are either red or blue:

Layer=’Electrical’ AND (Color=’Red’ OR Color=’Blue’)

Changing the parentheses in a selection statement can dramatically change which entities are selected. The 
following statement uses the same qualifiers and operators as the previous statement, but selects all entities that 
are either on the Electrical layer and are red, or all entities that are blue:

(Layer=’Electrical’ AND Color=’Red’) OR Color=’Blue’

Once you create a selection statement, you can choose to add the entities it describes to the selection set or 
subtract them. For the duration of the current drawing session, the Selection Modifier retains the last selection 
statement for each open drawing. At any point, you can clear the selection statement and start over, or you can 
cancel the Selection Modifier entirely.
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To add a qualifier that selects all entities

1 On the Edit menu, click Select, Modify Selection, or click the Modify Selection button on the All-In-One toolbar. 

2 On the Selection Modifier menu bar, click Qualifier, All. The word ALL is added to the selection statement.



To add a qualifier that selects entities based on a graphic property

1 On the Edit menu, click Select, Modify Selection, or click the Modify Selection button on the All-In-One toolbar.

2 On the Selection Modifier menu bar, click Qualifier, Type, Layer, Color, Width, or Style. A corresponding 
selection dialog box appears. 

3 Select the values you want to allow for the property. To select multiple values, press SHIFT or CTRL as you 
click.

4 Click OK. The qualifier is added to the selection statement.



To add a qualifier that selects entities based on the marquee

1 On the Edit menu, click Select, Modify Selection, or click the Modify Selection button on the All-In-One toolbar.

2 On the Qualifier menu of the Selection Modifier menu bar, click Marquee. A cascading menu appears. A 
marquee must already exist in the drawing, otherwise these commands appear grayed.

3 Click Totally Inside to include entities that are totally inside the marquee, or click the corresponding menu 
command to include entities that are partially inside, totally outside, or partially outside the marquee.



To add a qualifier that selects entities based on a database field

1 On the Edit menu, click Select, Modify Selection, or click the Modify Selection button on the All-In-One toolbar.

2 On the Selection Modifier menu bar, click Qualifier, Database. The Select By Field dialog box appears.

3 Select the field you want to use to include entities in the selection statement from the Field Name section of 
the dialog box.

4 Select one of the following qualifiers in the Is section of the dialog box:

5 Enter the value you want to use to compare with the entity’s field value in the Value text box.

6 Click OK.

Tip
To select a character database field regardless of its value, use the wildcard “*” to match all values. You can 

also use the wildcard “?” to match any single character of a character database field.



Clearing a Selection Set

Clearing the selection set is a good idea when you are done with an editing operation. Otherwise, you may 
accidentally make additional changes to entities in the set.
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To clear the selection set
On the Edit menu, click Select, Clear Selection, or click the Clear Selection button on the All-In-One toolbar.

OR
Right-click the selection set and click Clear Selection on the pop-up menu. 

OR
Press ESC or click outside the selection set. 



Marquee Selection

Unlike the previously mentioned selection methods that allow you to select entities, marquee selection allows you 
to select an area onscreen. You can define a marquee to:

Copy a bitmap to the Clipboard. For information on copying a bitmap to the Clipboard, see Using the 
Clipboard & Ole.

Reference in the Selection Modifier. For information on referencing a marquee in the Selection Modifier, see 
Using the Selection Modifier.

Save a view. For information on saving a view, see Controlling Views.
Print a view. For information on printing a view, see Printing and Plotting.
Stretch an entity. For information on stretching an entity, see Stretching an Entity.

Do not confuse marquee selection and directly selecting entities with the mouse. Marquee selection marks a 
specific area of the drawing for use with other commands. It does not directly create a selection set. Defining a 
new marquee clears the previous one.
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To create a rectangular marquee

1 On the Edit menu, click Select, Marquee, or click the Marquee Selection button on the All-In-One toolbar.

2 Enter a point to begin the marquee. A rubber-band rectangle follows the pointer from the point.

3 Enter a second point for the opposite corner of the marquee rectangle. A dotted line defines the marquee 
boundaries.

Tip
You can also draw a marquee holding CTRL while in direct selection. Click and drag from one corner to the 

opposite corner to form the marquee.



To create an irregularly shaped marquee

1 On the Edit menu, click Select, Irregular Marquee, or click the Irregular Marquee Selection button on the All-In-
One toolbar.

2 Enter a point to begin the marquee. A rubber-band line follows the pointer.

3 Enter a point to define a corner of the marquee. A rubber-band polygon follows the pointer. Repeat this step 
until you define all of the corners of the marquee.

4 Right-click. A dotted line defines the marquee boundaries.

Note
Dragging the pointer from left to right selects only entities that are completely inside the defined region. 

Dragging the pointer from right to left selects entities that are partially inside the defined region.



To clear a marquee
On the Edit menu, click Select, Clear Marquee, or click the Clear Marquee button on the All-In-One toolbar.



Modifying the Properties for the Entire Selection Set

Once you have created a selection set, you can make modifications to all the entities in the selection set. If your 
selection set is a single entity, you can use the controls on the edit bar and property bar to make changes to the 
entity’s geometric and graphic properties. If your selection is a group of entities, such as polygons, you can use 
the controls on the property bar to change their layer or graphic properties.

You can also edit the properties of the selection set by clicking Entities, either on the Edit menu or on the pop-up 
menu for the selection set. When you click this command, the Edit Entities dialog box appears and displays 
controls for all the entity types contained in the current selection set. Each set of controls appears on a page of 
the dialog box associated with each entity type. These controls allow you to edit any portion of the properties for 
the selected entities. AutoSketch applies any changes you make to all the entities of that type in the current 
selection set.
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To modify the properties of a selection set

1 Create a selection set.

2 Change the settings on the property bar.



To modify the geometric or graphic properties of a selection set

1 Create a selection set.

2 On the Edit menu, click Entities, or right-click and select Entities from the pop-up menu. The Edit Entities 
dialog box appears. 

3 Click the General page tab, or the page tab associated with each entity type. 

4 Edit the properties you want to change in the selection set.

5 Click OK.



Deleting Entities

You remove an entity from your drawing by deleting the entity. The ability to quickly delete entities makes cleaning 
up a drawing fast. You should delete any unneeded entities from your drawings to cut down on the size of the file 
and to make redrawing the screen faster.
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To delete entities

1 Select the entities to delete.

2 On the Edit menu, click Delete.

OR
Press DELETE.



Printing and Plotting

Most of the time, printing in AutoSketch is a simple, single command procedure. However, AutoSketch provides 
many advanced printing features. You can print your drawing to scale or force it to fit on a single printer page. If 
you want to create output that is larger than your printer supports, AutoSketch can automatically tile your output 
onto several pages. Before printing, you can check onscreen how your drawing will look by using the Print 
Preview window. In this topic, you will learn both the basics of printing and how to take advantage of the 
AutoSketch advanced printing features. 
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To preview output onscreen

1 On the File menu, click Print Preview, or click the Print Preview button on the Standard toolbar. The Print 
Preview window appears.

2 (optional) To view a multi-page drawing one page at a time, click One (click the Tile button to return to viewing 
multiple pages). Use the browse buttons (<< and >>) to change the displayed page of a multi-page drawing.

3 (optional) To change the page size, click Page, then click the Size page tab in the Page Setup dialog box. For 
more information on changing the page size, see Setting the Page Size.

4 (optional) To change the page margins, click Page, then click the Margins page tab in the Page Setup dialog 
box. Enter margin sizes in the text boxes.

5 (optional) To change the paper size, orientation, or source, click the Page button, then click the Printer Page 
tab in the Page Setup dialog box. Use the drop-down list boxes to change settings.

6 (optional) To change the view or sizing method, use the two drop-down list boxes in the Print Preview window.

7 (optional) To print while previewing the drawing, click Print. Clicking Print closes the Print Preview window. To 
return to the Print Preview window, click Preview in the Print dialog box.

8 Click Close. The Print Preview window closes.



To print a drawing using the current settings

1 On the File menu, click Print. The Print dialog box appears.

2 Click OK.

OR

Click the Print button on the Standard toolbar.



To cancel printing
Press ESC.



Understanding Page Tiling

If you create a drawing that is larger than a single printer page, AutoSketch automatically tiles it across multiple 
pages. This gives you the flexibility to generate large output on any printer. AutoSketch prints tick marks to 
indicate the margins on tiled output. Before connecting the printed pages together, you must first cut away the 
margin area indicated by the tick marks.

For example, let’s assume you have created a drawing using an 11”x17” page with a landscape orientation. 
However, your printer only supports 8.5”x11” pages. In addition, you discover that there is a .25” wide margin at all 
sides of the printer page that the printer can’t print on. This means that you only have an active printing area of 
8”x10.5”.

Fortunately, AutoSketch can print this drawing using four printer pages tiled together. When you print the drawing, 
four pages emerge from your printer. Tick marks at the corners indicate the printable area and margins for each 
printer page. These serve as a guide for splicing the pages together.
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Selecting an Output Device

AutoSketch normally prints your drawings using the current Windows printer. However, you can print using any 
installed printer. The Print dialog box allows you to specify a printer or plotter from among those that are currently 
installed. 
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To set hardware parameters for an active printer

1 On the File menu, click Print. The Print dialog box appears.

2 Click a printer from the drop-down list box in the Printer section.

3 Make any changes that are necessary and click OK.



Printing a Drawing to Scale

Any output you plan to measure with an architectural or engineering scale must be printed to scale. When you 
create scaled output, you can print the entire drawing or a portion of the drawing. The scale used when printing is 
the current drawing scale. For information on setting the drawing scale, see Setting the Drawing Scale.
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To print the entire drawing to scale

1 On the File menu, click Print. The Print dialog box appears.

2 In the View to Print drop-down list box, click Extent View.

3 In the Sizing Method drop-down list box, click Scaled.

4 Click OK.



To print part of the drawing to scale

1 On the File menu, click Print. The Print dialog box appears.

2 Click a view from the View to Print drop-down list box. Current View prints the currently displayed view. Page 
View prints the onscreen page. Extent View prints the entire drawing. Other items in this list print previously 
saved views. Marquee View prints the current marquee region (if one is defined).

3 In the Sizing Method drop-down list box, click Scaled.

4 Click OK.



Printing a Drawing to Fit on a Page

Fitted output is useful anytime you need the largest image possible rather than one printed at a specific scale. You 
cannot scale from fitted output. However, AutoSketch provides the ability to automatically set the scale as a 
compromise between fitted and scaled output. 
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To print the entire drawing on a single page

1 On the File menu, click Print. The Print dialog box appears.

2 In the View to Print drop-down list box, click Extent View.

3 In the Sizing Method drop-down list box, click Fitted to Printer Page.

4 Click OK.



To print part of the drawing on a single page

1 On the File menu, click Print. The Print dialog box appears.

2 In the View to Print drop-down list box, click a view. 
Marquee View prints the current marquee region (if one is defined). 
Current View prints the currently displayed view. 
Page View prints the onscreen page. 
Extent prints the entire drawing. 
Other items in this list print previously saved views.

3 In the Sizing Method drop-down list box, click Fitted to Printer Page.

4 Click OK.



To print all or part of the drawing as large as possible on multiple pages

1 On the File menu, click Page Setup. The Page Setup dialog box appears.

2 Click the Size page tab.

3 To specify the size to print in terms of printer pages, click the Tiling Pattern option button. To specify the size to 
print using exact measurements, click the Custom Size option button. For more information on setting the page 
size, see Setting the Page Size. 

4 Click OK.

5 On the File menu, click Print. The Print dialog box appears.

6 In the View to Print drop-down list box, click a view.

7 In the Sizing Method drop-down list box, click Fitted to Page.

8 Click OK.



Setting the Drawing Scale Automatically 

When you need to print your drawing as large as possible on a single page, AutoSketch can set the scale for you 
automatically. AutoScale causes AutoSketch to choose a standard scale that displays your drawing as large as 
possible on the page and it adjusts the drawing origin to center your drawing on the page. AutoFit causes 
AutoSketch to choose a non-standard scale, which may not meet certain building, or other, scale standards.

This procedure uses the File menu’s Page Setup and Print commands, and the Tools menu’s Options command. 
For more information on setting the page size, see Setting the Page Size. For more information on setting the 
drawing scale, see Setting the Drawing Scale.
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To print, setting the drawing scale automatically

1 On the File menu, click Page Setup. The Page Setup dialog box appears.

2 Click the Size page tab, click Printer Page, then click OK.

3 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

4 Click the Scale page tab, click AutoScale, then click OK.

5 On the File menu, click Print. The Print dialog box appears.

6 In the View to Print drop-down list box, click Page View.

7 In the Sizing Method drop-down list box, click Scaled.

8 Click OK.



Lines

A line is a straight entity that begins at a startpoint and ends at an endpoint. Lines can represent real world items, 
such as the edge of a wall or the top of a bolt, or they can draw attention to other parts of a drawing, such as the 
leader line in a dimension.

Lines and polylines are different in several ways, even though they look similar. A polyline is a single entity 
regardless of the number of segments. A series of lines with common endpoints may look like a polyline, but they 
are actually multiple line entities. If you need to store independent information about the individual components of 
a series of line segments, use lines. If you delete part of an entity created using lines, you can delete the lines one 
at a time. If you perform the same procedure on an entity created with a single polyline, the entire figure is 
deleted.

Tools for drawing lines can be accessed from the Draw menu or the Line toolset on the All-In-One toolbar. You can 
also activate the Line toolbar (which contains the same commands but can be docked anywhere onscreen) by 
right-clicking a toolbar, then clicking Toolbars on the pop-up menu that appears. Simply check the Line check box 
in the Toolbars dialog box, then click OK to make the Line toolbar visible onscreen.

Edit bar controls allow you to directly modify the length, startpoint, endpoint, or associated angle of the entity by 
entering new values.

You can join lines to convert them to polylines. For more information on joining lines, see Converting & Exploding 
Entity Types.
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Drawing Single Lines

You draw single lines by entering two points with the Draw menu’s single line command. Use single lines when 
you need to draw lines that are not connected.
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To draw separate, unconnected lines

1 On the Draw menu, click Line, Single, or click the Single Line button on the All-In-One toolbar.

2 Click a point to start the line. A rubber-band line appears from that point.

3 Click a point to end the line.



Drawing Connected Lines

You draw connected lines by entering two or more points using the Draw menu’s multiple line command. Use 
connected lines when you need the look of a polyline, but you need to store information about each line segment 
individually. If you need to know the total length of the connected lines or if you need width control, use a polyline. 
For information on drawing polylines, see Polylines, Polygons, and Curves.

AutoSketch also allows you to draw two parallel lines at once. The Draw menu’s double line command operates 
like the multiple line command, except that this command uses the points you enter to define two parallel lines. 
AutoSketch trims the intersections automatically as you draw. 

You can specify the width, offset method, and offset distance from controls on the edit bar. The Width text box 
allows you to specify the distance between the double lines. The offset method determines how AutoSketch draws 
the double lines with respect to the points you enter either left, centered, right, or user-defined offset. The left and 
right methods determine which of the two lines intersect the points you enter. The center method centers the 
double lines on either side of the points you enter. The user-defined method requires you to enter an offset 
distance on the edit bar. AutoSketch draws the double lines with the center of the two lines offset from the points 
you enter by the specified distance .

You can determine when lines are prevented from doubling back on themselves, by entering the Double Line 
Minimum Angle value in the Drawing page tab of the Drawing Options dialog box. The default value is 10 degrees. 
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To draw a series of connected lines

1 On the Draw menu, click Line, Multiple, or click the Multiple Line button on the All-In-One toolbar.

2 Enter a point to start the first line. A rubber-band line appears from that point.

3 Click one or more points. Each point ends the previous line and starts a new line. If you press CTRL and enter 
a point, AutoSketch moves to that point without drawing a line and starts a new line.



To draw two parallel series of connected lines

1 On the Draw menu, click Line, Double, or click the Double Line button on the All-In-One toolbar.

2 Enter the distance between the double lines in the Width text box on the edit bar, then press ENTER.

3 (optional) Click a different offset method from the Method drop-down list box on the edit bar. If you select the 
user-defined method, enter the distance between lines in the Offset Distance text box on the edit bar.

4 Click a point to start the series. Rubber-band lines appear from that point.

5 Click one or more points. Each point ends and trims the previous pair of lines and begins a new pair. If you 
press CTRL and enter a point, AutoSketch moves to that point without drawing a line and begins a new pair.



To change the minimum angle of double lines

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Drawing page tab.

3 Enter a new angle measurement in the Double Line Min Angle text box.

4 Click OK.



Drawing a Line in Relation to an Entity

There are three ways to draw lines in relation to another entity:
tangent to existing arcs or circles
perpendicular to an existing line, polyline segment, polygon segment, arc or circle.
at a specific angle to the end of an existing line

The Draw menu’s tangent line command allows you to draw a tangent line to the side of the arc or circle that is 
closest to where you select the entity. This is true even when you select an arc that does not extend to the point of 
tangency.

The Draw menu’s perpendicular line command allows you to draw a line that is perpendicular to a reference entity 
and ends at a selected point. Note that the new line does not have to touch the reference entity.

AutoSketch also allows you to draw a line at a specific angle from the endpoint of an existing line. The new line 
starts at the endpoint nearest the point you clicked and extends in one of four directions at the angle you specify 
on the edit bar. The second point defines the direction and length of the line.
    Related Topics



To draw a line tangent to a pair of arcs and/or circles

1 On the Draw menu, click Line, Tangent, or click the Tangent Line button on the All-In-One toolbar.

2 Click a point on an arc or circle.

3 Click a point on a second arc or circle.



To draw a line perpendicular to an existing entity

1 On the Draw menu, click Line, Perpendicular, or click the Perpendicular Line button on the All-In-One toolbar.

2 Click a line, arc, circle, polyline segment, or polygon segment in the drawing. A perpendicular rubber-band line 
appears, following the pointer.

3 Click an endpoint.



To draw a line at a specific angle to an existing line

1 On the Draw menu, click Line, Angle, or click the Angle Line button on the All-In-One toolbar.

2 Enter the offset angle in the Line Angle text box on the edit bar and press ENTER. This angle should be 
positive and less than 90 degrees.

3 Click near the end of the line where you want the new line to start. A rubber-band line appears from the 
endpoint of the line, locked to the specified angle.

4 Click the point that defines the length of the new line.



Polylines, Polygons, and Curves

Polylines, polygons, curves, and ellipses, share a common characteristic they are single entities that contain 
multiple segments. A polyline can contain a single segment, but usually contains more. Polygons have three or 
more segments. Curves and ellipses contain many segments.

A polyline is different from a line in several ways. A polyline is a single entity regardless of the number of segments. A 
series of connected lines with common endpoints may look like a polyline, but they are actually multiple entities. 
AutoSketch can calculate the total length of a series of polyline segments, since they are a single entity.

You have more control over a segment of a polyline than you do a line. As you create polylines, controls on the 
edit bar allow you to specify the start width, the end width, and a bulge factor for each segment. You can edit 
these properties later using vertex editing and edit bar controls. When you select an existing polyline, the edit bar 
displays a text box for editing the width of the entire polyline segment. 

If you select and delete an entity created with a single polyline, the entire polyline is deleted, however, you can 
delete individual segments of a polyline using vertex editing. Vertex editing also allows you to change the shape of 
an existing polyline. For information on vertex editing and segment editing, see Reshaping Polylines, Polygons & 
Curves.

You can explode polylines to lines or join connected lines to form a polyline. Therefore, you needn’t be overly 
concerned with the initial choice you make between drawing with a line or polyline. For more information on 
converting polylines to lines, see Converting & Exploding Entity Types.

Polygons are closed shapes bounded by three or more segments. There are two types of polygons: regular 
polygons and irregular polygons. A regular polygon must have sides that are of equal lengths. An irregular polygon 
can have sides of any length. AutoSketch also provides a command that creates an irregular polygon in the shape 
of an ellipse.

AutoSketch defines a regular polygon by its centerpoint, radius, angle, number of sides, and whether the polygon 
is circumscribed or inscribed. Individual vertices define irregular polygons. 

Polygons can contain a pattern fill. A pattern can be a solid color or a hatch fill. You specify patterns with the 
property bar. For information on fills and hatches, see Pen and Pattern Properties.

You can convert a regular polygon to an irregular polygon, however, you cannot convert an irregular polygon to a 
regular polygon. Additionally, you can convert polygons to polylines, curves, splines, or lines. For information on 
converting polygons, see Converting & Exploding Entity Types.
    Related Topics



Drawing Polylines

A polyline is useful for drawing entities that have a fixed width, such as a wall in a floor plan. As you create each 
polyline segment, text boxes for the segment width and bulge appear on the edit bar. Polyline width is a real-world 
measurement, like the thickness of a wall. The Width of Segment text box allows you to create a tapered polyline 
segment by entering one width that is greater than the other. The constrain option forces both widths equal to the 
value in the Width of Segment text box.

The Bulge text box allows you to create a curved polyline segment. The value that defines a bulge is a ratio of two 
times the height of the bulge, divided by the length between its startpoint and endpoint.

Another way to measure the bulge factor is the tangent of one-quarter of the angle of the bulge. For example: for a 
bulge of 180 degrees, one quarter is 45 degrees. The tangent of 45 degrees is 1, so typing 1 in the Bulge text box 
yields a bulge of 180 degrees between the startpoint and endpoint of the polyline segment. If you enter the bulge as a 
numeric expression, AutoSketch calculates the trigonometry. For example, to calculate the bulge factor for a segment 
with a 180 degree arc, enter the following:
=tan(180/4)

You can substitute a different angle for 180 in the example above. For more information, see Using Numeric 
Expressions.

Each segment of a polyline can be edited individually. Selecting an existing polyline in your drawing allows you to 
edit its poly entity type and its width on the edit bar. For more information, see Adding a Vertex, Segment, or 
Bulge.

Vertex editing allows you to change the shape of an existing polyline, and to add or delete vertices. For more 
information, see Editing the Properties of a Polyline or Polygon Segment.

Tools for drawing polylines can be accessed from the Draw menu or the Polyline toolset on the All-In-One toolbar. 
You can also activate the Polyline toolbar (which contains the same commands but can be docked anywhere on 
screen) by right-clicking a bar, then clicking Toolbars on the pop-up menu that appears. Simply check the Polyline 
check box in the Toolbars dialog box, then click OK to make the Polyline toolbar visible on screen.

In addition to regular polylines, there are three other ways of drawing polylines available in AutoSketch: 
perpendicular, corner and sketch polylines. A perpendicular polyline is drawn at a right angle to another entity, 
polyline segment, or polygon segment.    A corner polyline creates a rectangle at the intersection of two polyline or 
polygon segments. A sketch polyline simulates “freehand” drawing. Sketch polylines are discussed in Sketching.
    Related Topics



To draw a polyline

1 On the Draw menu, click Polyline, Single, or click the Single Polyline button on the All-In-One toolbar.

2 (optional) Change the settings on the edit bar for start width, end width, and bulge.

3 Click a startpoint. A rubber-band line appears from that point.

4 Enter one or more additional vertices. Each one continues from the endpoint of the previous segment and 
begins a new segment. If you make a mistake, press DELETE to remove vertices one at a time in reverse 
order.

5 Right-click to complete the polyline.



To draw a perpendicular polyline

1 On the Draw menu, click Polyline, Perpendicular, or click the Perpendicular Polyline button on the All-In-One 
toolbar. The pointer changes to a drawing tool.

2 Click a line, arc, circle, polyline segment, or polygon segment. The segment appears highlighted and a rubber-
band line appears and follows the pointer at right angles to the segment.

3 Click an endpoint for the polyline. 

4 Right-click to stop drawing perpendicular polylines.



To draw a corner polyline

1 On the Draw menu, click Polyline, Corner, or click the Corner Polyline button on the All-In-One toolbar. The 
pointer changes to a drawing tool.

2 Enter lengths in the Corner Length 1 and Corner Length 2 text boxes on the edit bar.

3 Click the line or poly-segment you want to be parallel to the first line. The segment appears highlighted.

4 Click the line or poly-segment you want to be parallel to the second line. The polyline appears, creating a 
rectangle from the original corner.



Sketching

Sometimes you need a polyline that represents an unusually shaped entity in your drawing, such as the isobars in 
a weather map or an elevation in a topographical map. AutoSketch simulates freehand drawing with the Sketch 
command by closely following the movement of your mouse.

Controls on the edit bar allow you to specify the real world width a of sketch polyline prior to creating it. Selecting 
an existing sketch polyline displays similar controls that allow you to change its type or width.

The Polyline Sketch Units value on the Drawing page of the Drawing Options dialog box determines how closely 
sketch polylines follow your mouse movement. This value specifies how many pixels of movement occur before 
AutoSketch adds another vertex to the sketch polyline. Smaller values produce a finer sketch with more vertices in 
the polyline. Larger values result in rougher sketches and a simpler entity. The default number is 8. Increasing the 
number creates longer segments that take up less memory.
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To draw a “freehand” polyline

1 On the Draw menu, click Polyline, Sketch, or click the Sketch Polyline button on the All-In-One toolbar.

2 (optional) Change the Width setting on the edit bar.

3 Click a point where you want the polyline to begin, then drag. As long as you hold the left mouse button down, 
segments are added to the polyline.

4 Release the mouse button.



To change sketch precision

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Drawing page tab.

3 Change the number in the Polyline Sketch Units drop-down list box. Lower values increase the accuracy of the 
sketch polyline.

4 Click OK.



Drawing Irregular Polygons

An irregular polygon might be a simple triangle or it could contain hundreds of segments. AutoSketch creates an 
irregular polygon by connecting the vertices that define the individual segments. The Draw menu’s irregular 
polygon command allows you to draw an irregular polygon by entering its vertices. In operation, it is very similar to 
the Draw menu’s single polyline command except that it maintains a rubber-band line to the first point and 
automatically closes the polygon.

As you draw an irregular polygon, text boxes for the width and a bulge factor for each segment appear on the edit 
bar. Each segment can have a different start width, end width, and bulge setting. Segments with different start and 
end widths have a tapered appearance. When you select an irregular polygon, AutoSketch displays settings on 
the edit bar that allows you to change the width of all the segments of the polygon and to align the polygon with 
the grid. 

Vertex editing allows you to change the shape of an existing irregular polygon, and to add or delete vertices. For 
information on vertex editing, see Reshaping Polylines, Polygons & Curves.

Tools for drawing polygons can be accessed from the Draw menu or the Polygon toolset on the All-In-One toolbar. 
Or you can activate the Polygon toolbar (which contains the same commands but can be docked anywhere on 
screen) by right-clicking a bar, then clicking Toolbars on the pop-up menu that appears. Just check the Polygon 
check box in the Toolbars dialog box, then click OK to make the Polygon toolbar visible on screen.

AutoSketch also allows you to draw a rotated rectangle by clicking three points. The first point defines the corner 
of the rectangle, while the second point establishes the width and angle of the rectangle. The last point defines the 
rectangle height. To skew or slant the rectangle, press and hold CTRL. Skewed rotated rectangles are especially 
useful for isometric drawings.
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To draw an irregular polygon

1 On the Draw menu, click Polygon, Irregular, or click the Irregular Polygon button on the All-In-One toolbar.

2 Click the startpoint of the irregular polygon. A rubber-band line follows the pointer.

3 Click two or more points to define the sides of the polygon. Each one ends the previous segment and begins a 
new one. If you make a mistake, press DELETE to remove vertices one at a time in reverse order.

4 Right-click to complete the polygon.



To draw a rectangle

1 On the Draw menu, click Polygon, Rectangle, or click the Rectangular Polygon button on the All-In-One 
toolbar.

2 (optional) Click the Align to Grid button on the edit bar. When this button is checked, the rectangle is aligned to 
the grid type and angle.

3 Click the point that defines one corner of the rectangle. A rubber-band rectangle appears beginning at the 
selected point.

4 Click the point that defines the opposite corner to draw the rectangle.



To draw a rotated rectangle

1 On the Draw menu, click Polygon, Rotated Rectangle or click the Rotated Rectangle button on the All-In-One 
toolbar. 

2 Click a point to define the first corner of the rectangle. A rubber-band line follows the pointer. 

3 Click a second point to define the angle and width of the rectangle. A rubber-band rectangle follows the pointer. 

4 Click a third point to define the height of the rectangle. Press and hold CTRL to skew, or slant, the rectangle. 



Drawing Ellipses

An ellipse is a closed symmetrical curve that resembles a flattened circle. You might use an ellipse to illustrate the 
path of a planet in a drawing of the solar system, or to accurately convey the appearance of a bolt hole in an 
isometric drawing.

AutoSketch provides two commands that allow you to draw ellipse-shaped polygons. The Ellipse Rectangle 
command creates an ellipse using two points to define a bounding rectangle for the ellipse. The Ellipse Axes 
command allows you to create an ellipse by specifying the major and minor axes using three points. This 
command lets you create a slanted ellipse using the third point to determine slant for the ellipse.

Tools for drawing ellipses can be accessed from the Draw menu or the Ellipse toolset on the All-In-One toolbar. 
You can also activate the Ellipse toolbar (which contains the same commands but can be docked anywhere 
onscreen) by right-clicking a bar, then clicking Toolbars on the pop-up menu that appears. Simply check the 
Ellipse check box in the Toolbars dialog box, then click OK to make the Ellipse toolbar visible onscreen.

You can change the number of segments AutoSketch uses when creating ellipses by changing the Ellipse 
Segments text box found on the Drawing page of the Drawing Options dialog box. Higher values result in 
smoother polygons that follow the elliptical shape more closely. Smaller values result in rougher polygons that 
redraw faster and require less drawing memory. The default value is 36.
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To draw an ellipse-shaped polygon that fills a rectangle

1 On the Draw menu, click Polygon, Ellipse Rectangle, or click the Ellipse Rectangle button on the All-In-One 
toolbar.

2 Click the point that defines an edge of the rectangle. A rubber-band rectangle follows the movement of the 
pointer.

3 Click the point that defines the diagonal edge of the rectangle. AutoSketch draws an ellipse tangent to all four 
sides of this rectangle. 

Note
If you are using an isometric reference grid, you can align the ellipse to the grid by clicking the Align to Grid 

button on the edit bar before entering the first point.



To draw an ellipse-shaped polygon by entering three points

1 On the Draw menu, click Polygon, Ellipse Axes, or click the Ellipse Axes button on the All-In-One toolbar.

2 Click the startpoint of the major axis. A rubber-band line appears beginning at the entered point.

3 Click the endpoint of the major axis. A rubber-band ellipse follows the movement of the pointer. 

4 (optional) Press and hold CTRL to slant the ellipse.

5 Click a third point that defines the minor axis of the ellipse.



To change the number of polygon segments used to draw an ellipse

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Drawing page tab.

3 Enter a new value in the Ellipse Segments text box.

4 Click OK.



Drawing Regular Polygons

A regular polygon has segments of equal length. A regular polygon can be an equilateral triangle, or have many 
segments. You might use a regular polygon to draw the head of a hex bolt, or to draw the outline of a stop sign. 

AutoSketch draws a regular polygon in relation to an invisible reference circle. It is either inscribed inside the circle 
or circumscribed around it. The one you choose depends on whether you need to specify the corners of the 
polygon or the sides. To specify the corners of a polygon, click inscribed. To specify the sides, click circumscribed.

AutoSketch provides four ways to draw regular polygons by specifying:
a centerpoint and either a vertex point or a side midpoint
opposite corners or sides
two adjacent corners or sides
a center and the radius of the reference circle

As you draw a regular polygon, a text box for the width of the segments, a drop-down list box specifying inscribed 
or circumscribed polygon, and another specifying the number of segments appear on the edit bar. If you use the 
Regular: Center, Radius command to draw a polygon, a text box appears on the edit bar so you can enter the 
radius.

When you select an existing regular polygon, AutoSketch displays controls on the edit bar that allow you to 
change the width of all the segments of the polygon, the x- and y- coordinates of the centerpoint, the reference 
circle radius, whether it is inscribed or circumscribed, the number of segments, and the rotation angle. For 
information on changing the start width, end width, or bulge factor of a polygon segment, see Editing the 
Properties of a Polyline or Plygon Segment.

Vertex editing allows you to change the shape of an existing regular polygon, and to add or delete vertices. After 
performing vertex editing, the resulting entity will no longer be a regular polygon. For information on vertex editing, 
see Reshaping Polylines, Polygons & Curves.
    Related Topics



To draw a regular polygon by entering its center and edge points

1 On the Draw menu, click Polygon, Center, Edge, or click the Center-Edge Polygon button on the All-In-One 
toolbar.

2 (optional) Click or enter the different number of sides in the Number of Segments box on the edit bar and press 
ENTER.

3 (optional) Click Inscribe or Circumscribe from the drop-down list box on the edit bar to determine if the polygon 
is inscribed in the reference circle or circumscribed around it. This setting determines the meaning of the 
points you enter in the following steps.

4 Click the centerpoint of the regular polygon. A small diamond marker marks the point and a rubber-band 
polygon appears, moving with the pointer.

5 (optional) Press and hold CTRL while you click the point in the next step to reverse the points.

6 Click the corner point for the polygon if Inscribe appears on the edit bar, or enter a midpoint for a side of the 
polygon if Circumscribe appears. If you are holding CTRL, the corner or side point is switched with the 
centerpoint.



To draw a regular polygon by entering opposite corners or sides

1 On the Draw menu, click Polygon, Regular: Edge, Opposite, or click the Edge-Opposite Polygon button on the 
All-In-One toolbar.

2 (optional) Click or enter a different number of sides in the Number of Segments box on the edit bar and press 
ENTER.

3 (optional) Click Inscribe or Circumscribe from the drop-down list box on the edit bar to determine if the polygon 
is inscribed in the reference circle or circumscribed around it. This setting determines the meaning of the 
points you enter in the following steps.

4 Click the corner point for the polygon if Inscribe appears on the edit bar, or enter the midpoint for a side of the 
polygon if Circumscribe appears. A small diamond marker marks the point and a rubber-band polygon moves 
with the pointer.

5 Click the opposite corner or midpoint. 



To draw a regular polygon by entering adjacent corners or sides

1 On the Draw menu, click Polygon, Regular: Edge, Adjacent, or click the Edge-Adjacent Polygon button on the 
All-In-One toolbar.

2 (optional) Click or enter a different number of sides in the Number of Segments box on the edit bar and press 
ENTER.

3 (optional) Click Inscribe or Circumscribe from the drop-down list box on the edit bar to determine if the polygon 
is inscribed in the reference circle or circumscribed around it. This setting determines the meaning of the 
points you enter in the following steps.

4 Click the corner point for the polygon if Inscribe appears on the edit bar, or enter the midpoint for a side of the 
polygon if Circumscribe appears. A small diamond marker marks the point and a rubber-band polygon moves 
with the pointer.

5 (optional) Press and hold CTRL while you click the point in the next step to flip the polygon.

6 Click the adjacent corner or midpoint.



To draw a regular polygon by specifying its center and radius

1 On the Draw menu, click Polygon, Regular: Center, Radius, or click the Center-Radius Polygon button on the 
All-In-One toolbar. A rubber-band polygon follows the pointer.

2 (optional) Click or enter a different number of sides in the Number of Segments box and press ENTER.

3 (optional) Click Inscribe or Circumscribe from the drop-down list box on the edit bar to determine if the polygon 
is inscribed in the reference circle or circumscribed around it. This setting determines the meaning of the 
radius of the polygon.

4 Enter the distance from the centerpoint to the corner of the polygon in the Radius text box on the edit bar and 
press ENTER if the button on the edit bar displays Inscribe, or enter the distance from the centerpoint to the 
midpoint of a side of the polygon in the Radius text box if the button displays Circumscribe.

5 Click a centerpoint.

Tip
Pressing plus (+) and minus (-) on the numeric keypad prior to picking a centerpoint causes the polygon to 

rotate by the angle specified in the Plus/Minus Rotation text box in the Drawing Options dialog box. The change is 
reflected in the rubber-band polygon.



Drawing Curves

A curve is a finely-segmented polyline whose shape is determined by three or more control points. Instead of 
connecting a series of straight segments, the vertices in a curve guide the path of the polyline that approximates a 
smooth curve. There are two curve types: fitted curves and spline curves. A fitted curve passes through each 
vertex. A spline curve is drawn toward each vertex. An open spline curve passes through its startpoint and 
endpoint. 

As with a normal polyline, you can specify that a curve be open or closed and you can assign it real world width. You 
can apply pattern fill to closed curves. Unlike a polyline, a curve has uniform width throughout its length, and it must 
have at least three vertices rather than two. You can convert a curve to a polyline at any time by selecting it and 
changing the current type setting in the drop-down list box on the left side of the edit bar. 

You can convert a curve to a series of short lines or to a polyline that duplicates the curve as it is rendered 
onscreen. This is useful when you want to retain the appearance of the curve but must edit a portion of it. For 
information on converting curves, see Converting & Exploding Entity Types.

Tools for drawing curves can be accessed from the Draw menu or the Curve toolset on the All-In-One toolbar. You 
can also activate the Curve toolbar (which contains the same commands but can be docked anywhere onscreen) 
by right-clicking a bar, then clicking Toolbars on the pop-up menu that appears. Simply check the Curve check box 
in the Toolbars dialog box, then click OK to make the Curve toolbar visible onscreen.

You can change how smoothly AutoSketch renders fitted curves by adjusting the Fitted Curve Render Depth 
setting on the Drawing page of the Drawing Options dialog box. The default value is 4. Higher values result in 
smoother curves. Lower values improve redraw speed.

You can change how smoothly AutoSketch renders spline curves in a drawing by adjusting the Spline Segs Per 
Vertex setting on the Drawing page of the Drawing Options dialog box. The default settings are 8 segments per 
vertex and a maximum of 511 vertices. Higher values result in smoother fitted curves. Lower values improve the 
redraw speed and reduce the drawing file size.

Tip
As you are drawing a curve, you can press DELETE to remove the last drawn vertex.
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To draw a fitted curve

1 On the Draw menu, click Curve, Fitted, or click the Fitted Curve button on the All-In-One toolbar.

2 Check the Closed check box on the edit bar if you want a closed curve. If you want an open curve, leave the 
check box unchecked.

3 Click the startpoint. A rubber-band line appears.

4 Click three or more vertices.

5 Right-click to complete the curve.



To draw a spline curve

1 On the Draw menu, click Curve, Spline, or click the Spline Curve button on the All-In-One toolbar.

2 Check the Open/Close Curve check box on the edit bar, leaving it checked if you want a closed curve, or 
unchecked if you want an open curve.

3 Click the startpoint. A rubber-band line appears.

4 Click three or more vertices.

5 Right-click to complete the curve.



To change the smoothness of fitted curves

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Drawing page tab.

3 Enter a number in the Fitted Curve Render Depth text box.

4 Click OK.



To change the smoothness of spline curves

1 On the Tools menu, click Drawing Options, or click the Drawing Options button on the Standard toolbar. The 
Drawing Options dialog box appears.

2 Click the Drawing page tab.

3 Enter new values in the Spline Segs Per Vertex text box.

4 Click OK.



Working With Text

In AutoSketch, a text entity is made up of characters from a TrueType or AutoSketch font. AutoSketch does not 
consider text to represent real objects in the drawing. Instead, it views text as annotation to the drawing. 
AutoSketch scales text, and other annotation entities such as markers, dimensions, and hatch patterns, at output 
size. If you enter text that is .25" high, it prints as .25" high, regardless of the current drawing scale. This is 
consistent with most drafting standards, which specify text size in terms of printed output.

AutoSketch supports both TrueType and AutoSketch fonts. TrueType fonts are resizeable, solid filled fonts. 
AutoSketch fonts are stroke fonts, which are resizeable, but they are not solid filled. Stroke fonts give your 
drawings the traditional look of computer drafting while TrueType fonts provide a look that integrates well with 
output from other Windows applications.

Three geometric properties define a text entity in AutoSketch: basepoint, angle, and character height. 

You can change the geometric properties of a text entity by changing the corresponding settings on the edit bar.
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Placing Text

Use text to add information to your drawing. For example, you might add text to specify a manufacturer for a 
specific part in a drawing of an engine. AutoSketch gives you the flexibility to place text anywhere in your drawing 
using different formatting for each text entity.

To place text, enter the text’s basepoint, determining its location. You can specify the justificationhow AutoSketch 
orients text about its basepoint for a text entity using the drop-down list box at the right of the edit bar.

You can place text at any angle, even if you aren’t sure of the measurement. The Draw menu’s Text command 
allows you to place text aligned to two points. The first point specifies the text basepoint and the second specifies 
the angle. You do not have to use the same snap mode or lock modifier for both points. For instance, you could 
use Gridpoint snap mode for one point and Relative snap mode for the other.
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To add a text entity

1 On the Draw menu, click Text, or click the Text button on the All-In-One toolbar.

2 Make sure the Formula check box on the edit bar is not checked.

3 (optional) Change the edit bar values to adjust the font, height, and/or angle.

4 (optional) From the Justification drop-down list box on the edit bar, click a justification.

5 Click a point for the basepoint of the text. The Text Input dialog box appears.

6 Enter the text. To enter more than one line of text, click Editor. For information on using the Text Editor, see 
Editing Text with the Text Editor.

7 Click OK.



To add text aligned to two points

1 On the Draw menu, click Text, or click the Text button on the All-In-One toolbar.

2 Make sure the Formula check box on the edit bar is not checked.

3 (optional) On the edit bar, change the font, height, and/or justification.

4 Press and hold CTRL and enter a point for the basepoint of the text. 

5 Enter a second point for the angle of the text. The Text Input dialog box appears.

6 Enter the text. To enter more than one line of text, click Editor. For information on using the Text Editor, refer to 
Editing Text with the Text Editor.

7 Click OK.



Modifying Text

You can edit the content, as well as the geometric and graphic properties, of any text entity in the drawing. There 
is a built-in editor included with AutoSketch for updating the content of existing text entities. In addition, you can 
modify many text properties including font, height, angle, and justification directly from the edit bar.
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Changing Text Height, Angle, and Justification

AutoSketch allows you to individually place each text entity using a separate height, angle, and justification for 
each. You can modify any of these settings on the edit bar by entering new values in the appropriate text boxes.
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To change the height, angle, and justification of an existing text entity

1 Select the text.

2 To change the text height, enter a different height in the Text Height text box on the edit bar and press ENTER.

3 To rotate the text about its basepoint, enter a different angle in the Text Angle text box on the edit bar and 
press ENTER.

4 To move the text in relation to its basepoint, click a new justification from the drop-down list box on the edit bar.



Choosing a Font

AutoSketch supports both TrueType and AutoSketch fonts. Most older plotters do not support TrueType fonts. If 
you are planning to output your drawing on such a plotter, you can use AutoSketch fonts or you can convert the 
TrueType fonts to polygons (see Converting TrueType Fonts). If your output device supports TrueType, you can 
select any available font. AutoSketch provides the following fonts:

CAD Block CAD Cursive Bold CAD Simplex
CAD Century CAD Gothic Bold CAD Slant
CAD Century Bold CAD Greek Math CAD Special
CAD Century Bold 

Italic
CAD Helvetica CAD Standard

CAD Century Italic CAD Italic CAD Times Roman
CAD Complex CAD Santura

CAD Cursive CAD Santura Bold

AutoSketch also includes the following AutoCAD TrueType fonts: 

Bank Gothic GDT Symusic
Commerical Pi Monospace 821 Swiss 721 Regular
Commerical Script Simplex Swiss 721 Condensed
Complex Stylus BT Swiss 721 Outline
Country Blueprint SuperFrench Technic Vineta
Dutch 801 Regular Symap Universal Math 1
Dutch 801 

Expanded
Symath

EuroRoman Sytmeto

Some TrueType fonts support different styles, such as bold or italic. These provide added versatility in how text 
appears in your drawing. You can specify styles and effects for TrueType fonts using controls in the Text Editor or 
the Font dialog box, accessible by right-clicking the font drop-down list box on the edit bar.
    Related Topics



To change the current font
Select a text entity and click a new font from the drop-down list box on the edit bar.



To change the font style for an entity using the Text Editor

1 Select a text entity, then right-click.

2 Click Edit Text on the pop-up menu for the selection set or double-click the selected text entity. The Text Editor 
window appears.

3 To select a different font, click a font from the Font drop-down list box.

4 To select a different font style, click one of the style buttons on the Text Editor edit bar.

5 (optional) Enter a new text height in the Height text box.

6 Click OK when you are finished modifying text.



Editing Text with the Text Editor

AutoSketch includes an editor so you can modify the content of a text entity. You can edit text directly in the Text 
Editor or you can open and merge files created using another editor. You can also save the contents of the Text 
Editor to a file. In addition to being able to open and save text files, the Text Editor supports cut, copy, and paste 
operations through the Windows Clipboard.

The Text Editor supports a number of character editing keys that speed up text editing. These keys control the 
position of the pointer, help you add text and delete text, and control the Text Editor window.

    Related Topics



To edit text using the Text Editor

1 Select a text entity.

2 Right-click, then click Edit Text on the pop-up menu for the selection set or double-click the selected text entity. 
The Text Editor window appears.

3 Edit the text and click OK.



To import a text file

1 On the Text Editor’s File menu, click Open. The Open Text File dialog box appears.

2 Click the folder that contains the file, click the name of the file you want to open, then click Open.



To merge a text file with the text in the editor

1 Position the insertion point at the location you want to merge the new text.

2 On the Text Editor’s File menu, click Merge. The Open Text File dialog box appears.

3 Click the folder that contains the file, click the name of the file you want to merge and click Open. The text 
appears in the Text Editor dialog box.

4 Click OK.



To paste text from the Clipboard

1 Place text on the clipboard from the source application using the Clipboard commands for that application.

2 Position the insertion point at the location you want to place the new text.

3 On the Text Editor’s Edit menu, click Paste, or click the Paste button on the Text Editor toolbar. The text 
appears at the insertion point.



To save the text in the editor to a file

1 On the Text Editor’s File menu, click Save As, or click the Save button on the Text Editor toolbar. The Save 
Text File dialog box appears.

2 Click the folder where you want to save the file.

3 Enter a filename and click Save.



To place text on the Clipboard

1 Select the text you want to put on the Clipboard.

2 To place a copy of the text and leave the original, on the Text Editor’s Edit menu click Copy, or click the Copy 
button on the Text Editor toolbar. To move the text to the Clipboard and delete it from the editor click Cut on the 
Edit menu.

Note
The Text Editor can import or merge a standard ASCII text file (either ANSI or OEM/PC format). These file 

formats are supported by most popular word processors. Be sure the word processor you use can save an ASCII text 
file.



To change the text font characteristics

1 Click a different font on the drop-down list box on the edit bar and right-click.

2 (optional) Click Font on the edit bar pop-up menu. The Font dialog box appears. 

3 Click a different font, style, or height. A sample will appear in the window.

4 Click OK.



Working with Formulas

Text entities can contain formulas strings that instruct AutoSketch to insert text automatically into a text entity. For 
example, the formula <%date> inserts the current date. Formulas make it possible for you to easily create 
drawings and symbols that display current information. For example, you could create an automatically updating 
title block. Or, you could create a personnel symbol for an office diagram that displays the name of the specific 
employee it represents.

You can add a formula to any text entity. AutoSketch distinguishes formulas from other text by two characters: “<” 
and “>.” You control whether AutoSketch searches a text entity for formulas by checking or unchecking the 
Formula check box on the edit bar. When this box is unchecked, AutoSketch does not evaluate any formulas 
contained in the selected text entity. You should uncheck this box for entities without formulas to maintain the 
highest level of performance.

There are four types of formulas that you can place directly in the drawing:
<%date> Inserts the current date based on the settings of your computer. 
<%time> Inserts the current time based on the settings of your computer. 
<%scale> Inserts the current scale formatted as a string.
<%getdata(variable)> Inserts information about the drawing file or this AutoSketch installation. Variable is 

the name of a drawing file variable. The following is a short list of variable names that are particularly useful with this 
type of formula.

For example, the following text contains two formulas that display the draftsman and company name in a format 
useful for a title block:

Produced by <%getdata(ProjectDraftsman)> at <%getdata(ProjectCompany)>.
    Related Topics



To add text containing a formula

1 On the Draw menu, click Text, or click the Text button on the All-In-One toolbar.

2 Make sure the Formula check box on the edit bar is checked.

3 Enter a point for the basepoint of the text. The Text Input dialog box appears. 

4 Enter text containing a formula.

5 Click OK. The text appears with the formula.

Note
You can add or edit a text entity containing a formula as you would any other text entity.



Embedding Formula Text in Symbols

You can use formulas to create symbols that automatically display associated database information. In addition to 
the four types of formulas listed in Working with Formulas, there is a fifth that is useful only as a part of a symbol 
definition:

<%db(variable)> Inserts database field information specific to a particular symbol. Variable is the name of a 
database field.

For example, you could create a resistor symbol with formulas that reference three database fields: label, ohms, 
and tolerance. When you assign data to a resistor symbol in the drawing, the symbol displays the referenced 
values automatically. For information on creating and assigning database fields, refer to Storing Data in a 
Drawing.
    Related Topics



To create a symbol containing formula text

1 On the Draw menu, click Text, or click the Text button on the All-In-One toolbar.

2 Make sure the Formula check box on the edit bar is checked, then enter a point for the basepoint of the text. 
This text will be part of the symbol definition, so choose a location that is useful in relation to the rest of the 
entities. The Text Input dialog box appears. 

3 Enter text containing a formula in the Text Input dialog box (for symbols, the formula usually references a 
database field), then click OK. The text appears with the formula code.

4 Select the entities from which you want to create the symbol (being sure to include the text containing the 
formula), then click Symbol, Create on the Draw menu, or click the Create Symbol button on the All-In-One 
toolbar. The Create Symbol Definition dialog box appears.

5 (optional) If you want to store the symbol in a library, check the Save In Library check box.

6 (optional) To include pre-defined values for certain database fields in the symbol definition, click Fields. These 
values are assigned to all instances of the symbol.

7 Enter a name, type, and description for the symbol, select a method for entering the basepoint from the drop-
down list box, then click OK.

8 If you checked the Save In Library check box, the Open Symbol Library dialog box appears. Enter a library 
name. If the library does not exist, you are given the option of creating it, then click Save. 

9 If you chose the Basepoint Select After OK option, AutoSketch prompts you to select the symbol basepoint.

Tip
You can add formulas to existing symbols by replacing their definitions. Place an instance of the symbol you 

want to update in the drawing. To convert a symbol to its base entities, right-click the symbol and click Explode from 
the pop-up menu. Then follow the above steps to create a new symbol definition containing formula text. Make sure 
you use the original name and basepoint when you create the updated definition. Finally, click OK when AutoSketch 
prompts you to confirm the symbol definition update.



Creating Dimensions

Often, drawing entities to scale is not enough to convey precise measurements. In such cases you must note the 
measurements explicitly using dimension entities. AutoSketch supports the following basic dimension types. Most 
dimension types also have variations that allow you to create almost any type of standard dimension notation in a 
drawing.

Dimension controls can be accessed from the Draw menu or the Dimension toolset on the All-In-One toolbar. You 
can also activate the Dimension toolbar (which contains the same commands but can be docked anywhere 
onscreen) by right-clicking a bar, then clicking Toolbars on the pop-up menu that appears. Simply check 
Dimension, then click OK to make the Dimension toolbar visible onscreen.



    Related Topics



Linear Dimensions

Use linear dimensions to note any distance that is “straight.” There are four linear dimension types: horizontal, 
vertical, aligned, and rotated. The difference lies in the angle of the dimension line the line that shows the 
measured value. In a horizontal dimension, the dimension line is always horizontal no matter where dimension 
points are located. A vertical dimension is similar, but its dimension line is always vertical. In an aligned dimension, 
the angle of the dimension line matches that of a line drawn between the two dimension points. In a rotated 
dimension, the angle of the dimension line is specified on the edit bar. This type of dimension is useful when you 
want a dimension drawn at a specific angle unrelated to the dimension points.

The label on a linear dimension always shows the correct measurement. AutoSketch calculates it automatically based 
on settings in the Dimension Format dialog box, that can be opened by clicking on the Format button on the edit bar.
You can draw linear dimensions as single, chained, or baseline dimensions. Single dimensions show individual 
measurements. Chained dimensions show a series of back to back measurements. Baseline dimensions show a 
series of measurements all measured from the same point. A drop-down list box on the edit bar allows you to specify 
the style you want.

Regardless of the style you use, remember that single, chained, and baseline dimensioning are merely different ways 
to enter the same basic type of entity. They make it easy to arrange those entities in a specific way. After entering a 
linear dimension, you can edit it using any of several techniques. For information on editing linear dimensions, see 
Changing Linear Dimensions with the Mouse.



Note
For precise dimensioning, use snap modes to identify snap points. For more information on using snap 

modes, see Entering & Modifying Points.
    Related Topics



Single Dimensions

Single dimensions are the simplest of linear dimensions. Each one is completely separate and unrelated to other 
dimensions in the drawing. Because each single dimension is entered in a separate operation, you can customize 
it as you draw before going on to the next dimension. Use single dimensioning for any linear dimension that is not 
part of a chained or baseline series.
    Related Topics



To draw a single dimension

1 On the Draw menu, click Dimension, Horizontal, Vertical, Rotated, or Aligned, or click the appropriate 
dimension button on the All-In-One toolbar.

2 From the Dimension Method drop-down list box on the edit bar, click Single.

3 Enter the initial offset on the edit bar and press ENTER. This is the distance from the dimension line to the 
closest dimension point on printed output. It applies to each single dimension you draw and can be changed at 
any time. 

4 Enter the first dimension point. A rubber-band dimension appears.

5 Enter the second dimension point to complete the dimension. Notice that where you place the second point 
determines the orientation of the dimension. You can reverse the orientation of the dimension by pressing 
CTRL as you enter the second dimension point.



Chained Dimensions

Often, you must draw a series of dimensions arranged back to back. Such dimensions appear to share extension 
lines. That is, each dimension in the series begins where the previous one ends. Chained dimensions are useful 
when you need to dimension a series of parts in a whole.

Unlike single dimensioning, chained dimensioning does not allow you to customize each dimension individually, 
as you draw. Instead, it uses the current settings in the Dimension Format dialog box and lines up all of the 
dimensions in the series with the first one.
    Related Topics



To draw a series of chained dimensions

1 On the Draw menu, click Dimension, Horizontal, Vertical, Rotated, or Aligned, or click the appropriate 
dimension button on the All-In-One toolbar.

2 From the Dimension Method drop-down list box on the edit bar, click Chained.

3 Enter the initial offset on the edit bar. This is the distance from the dimension line to the closest dimension 
point on printed output. It applies to the first dimension only. Other dimensions in the chain are aligned with the 
first. For information on changing a linear dimension after it is drawn, see Changing Linear Dimensions with 
the Mouse.

4 Enter the first dimension point. A rubber-band dimension appears.

5 Enter the second dimension point to complete the first dimension. Notice that where you place the second 
point determines the orientation of the dimension. You can reverse the orientation of the dimension by pressing 
CTRL as you enter the second dimension point.

6 Enter the third dimension point, the fourth dimension point, and so on. Each dimension point after the first adds 
a dimension to the series.



Baseline Dimensions

In baseline dimensioning, each dimension in the series seems to extend from the same extension line. Use 
baseline dimensioning when you need to show several dimensions measured from the same point.

Unlike single dimensioning, baseline dimensioning does not allow you to customize each dimension individually, 
as you draw. Instead, it uses the current settings in the Dimension Format dialog box, incrementing the initial 
offset by the baseline offset with each new dimension in the series.
    Related Topics



To draw a series of baseline dimensions

1 On the Draw menu, click Dimension, Horizontal, Vertical, Rotated, or Aligned, or click the appropriate 
dimension button on the All-In-One toolbar. The edit bar displays controls for linear dimensions.

2 From the Dimension Method drop-down list box on the edit bar, click Baseline.

3 Enter the initial offset on the edit bar and press ENTER. This is the distance from the dimension line to the 
closest dimension point on printed output. It applies to the first dimension only. For information on changing a 
linear dimension after it is drawn, see Changing Linear Dimensions with the Mouse.

4 Enter the baseline offset on the edit bar and press ENTER. This is the distance between baseline dimensions 
on printed output.

5 Enter the first dimension point. A rubber-band dimension appears, moving with the pointer.

6 Enter the second dimension point to complete the first dimension. Notice that where you place the second 
point determines the orientation of the dimension. You can reverse the orientation of the dimension by pressing 
CTRL as you enter the second dimension point.

7 Enter the third dimension point, the fourth dimension point, and so on. Each dimension point after the first adds 
a dimension to the series.



Changing Linear Dimensions With the Mouse

You can reshape a linear dimension after it is drawn by double-clicking on it and dragging components to new 
locations. Using this technique, you can change the location of the dimension line, the dimension label, and both 
dimension points.
    Related Topics



To move the dimension line of a linear dimension

1 Double-click the dimension or right-click it and click Edit Dimension from the pop-up menu. Resizing handles 
appear over the dimension points.

2 Click the dimension line and drag it to the new location. A rubber-band line shows the new position as you 
drag.



To move the dimension label of a linear dimension

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu. Resizing handles 
appear over the dimension points.

2 Click the dimension label and drag it to the new location. A rubber-band line shows the new position as you 
drag.



To center a linear dimension label after moving it

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu. Resizing handles 
appear over the dimension points.

2 Press CTRL and click the dimension line.



To move a linear dimension label without moving the dimension line

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu. Resizing handles 
appear over the dimension points.

2 Press CTRL as you click the dimension label and drag it to the new location.



To move a dimension point on a linear dimension

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu. Resizing handles 
appear over the dimension points.

2 Click the dimension point handle, or the extension line, and drag it to the new location. A rubber-band line 
shows the new position as you drag.



Angular Dimensions

An angular dimension notes the angle that exists between two entities in a drawing. It is similar to a linear 
dimension, but the dimension line is an arc rather than a line and extension lines, when present, extend toward 
the vertex of the measured angle. You can place the label for an angular dimension inside or outside of the 
referenced angle. If the dimension label is too long to fit inside the angle, AutoSketch forces the dimension line 
and label outside of the arc. AutoSketch automatically calculates the value displayed in the dimension label based 
on settings in the Dimension Format dialog box.
    Related Topics



To draw an angular dimension

1 On the Draw menu, click Dimension, Angular, or click the Angular Dimension button on the All-In-One toolbar.

2 Click two nonparallel lines in the drawing. A rubber-band dimension appears. Notice that you can dimension 
one of four angles: one between the two entities or dimension lines and three other angles.

3 Enter a point to establish the location of the dimension line. The dimension line passes through this point when 
it is drawn.





Changing Angular Dimensions With the Mouse

You can reshape an angular dimension after it is drawn by double-clicking on it and dragging components to new 
locations. You can use this technique to move the dimension line, the dimension label, or both.
    Related Topics



To move the dimension line on an angular dimension

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu.

2 Click the dimension line and drag it to the new location. A rubber-band line shows the new position as you 
drag.



To move the dimension label on an angular dimension

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu.

2 Click the dimension label and drag it to the new location. A rubber-band line shows the new position as you 
drag.



To center an angular dimension label after moving it

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu.

2 Press CTRL and click the dimension line.



To move an angular dimension label without moving the dimension line

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu.

2 Press CTRL as you click the dimension label and drag the handle to the new location.



Radius Dimensions

A radius dimension notes the radius of an arc (including a bulged segment of a polygon or polyline) or circle. You 
can place the label for a radius dimension inside or outside of the referenced arc or circle. Clicking just inside the 
arc or circle places it inside. Clicking just outside the arc or circle places it outside. AutoSketch automatically 
calculates the value displayed in the dimension label based on settings in the Dimension Format dialog box, that 
can be opened by clicking on the Format button on the edit bar.
    Related Topics



To dimension the radius of an arc or circle

1 On the Draw menu, click Dimension, Radius, or click Radius Dimension on the All-In-One toolbar.

2 Click anywhere along the arc or circle. Clicking just inside the arc or circle places the dimension inside. 
Clicking just outside the arc or circle places it outside. Pressing CTRL as you click changes the dimension 
style as follows:



Changing Radius Dimensions With the Mouse

You can reshape a radius dimension after it is drawn by double-clicking on it and dragging components to new 
locations. You can use this technique to change the angle of the dimension line or to move the dimension label.
    Related Topics



To change the angle of a radius dimension

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu.

2 Click the dimension line and drag it to the new location. The dimension line is rotated so it passes through the 
point you enter. The dimension label remains in the same relative location.



To move the label and change the angle of a radius dimension

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu.

2 Click the handle and drag it to the new location. The dimension label moves to the new location and the 
dimension is aligned to match.



To move the label of a radius dimension

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu.

2 Press CTRL and drag the handle to the new location.



Diameter Dimensions

A diameter dimension notes the diameter of an arc (including a bulged segment of a polygon or polyline) or circle. 
You can place the label for a diameter dimension inside or outside of the referenced arc or circle. Clicking just 
inside the arc or circle places it inside. Clicking just outside the arc or circle places it outside. AutoSketch 
automatically calculates the value displayed in the dimension label based on settings in the Dimension Format 
dialog box.
    Related Topics



To dimension the diameter of an arc or circle

1 On the Draw menu, click Dimension, Diameter, or click Diameter Dimension on the All-In-One toolbar.

2 Click anywhere along the arc or circle. Clicking just inside the arc or circle places the dimension inside. 
Clicking just outside the arc or circle places it outside.



Changing Diameter Dimensions With the Mouse

You can reshape a diameter dimension after it is drawn by double-clicking on it and dragging components to new 
locations. You can use this technique to change the angle of the dimension line or to move the dimension label.
    Related Topics



To change the angle of a diameter dimension

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu.

2 Click the dimension line and drag it to the new location. The dimension line is rotated so it passes through the 
point you enter. The dimension label remains in the same relative location.



To move the label and change the angle of a diameter dimension

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu.

2 Click the handle and drag it to the new location. The dimension label moves to the new location and the 
dimension is aligned to match.



To move the label of a diameter dimension

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu.

2 Press CTRL and drag the handle to the new location.



To center a diameter dimension label after moving it

1 Double-click the dimension or right-click it and click Edit Dimension on the pop-up menu.

2 Type C to switch to Centerpoint snap mode.

3 Click the handle and drag it to any point on the arc or circle edge. The label moves to the center.



Centerline Dimensions

Often you must mark the center of an arc or circle. A centerline dimension allows you to do this. It consists of a 
cross marker at the centerpoint and four lines extending through the quadrant points. In the case of an arc, these 
lines are drawn regardless of the arc’s included angle.
    Related Topics



To mark the center of an arc or circle

1 On the Draw menu, click Dimension, Centerline, or click Centerline Dimension on the All-In-One toolbar.

2 Select an arc or circle. AutoSketch draws the centerline dimension.



Ordinate Dimensions

Ordinate dimensions are used to note the x-or y- coordinate of a specific point. AutoSketch measures the 
coordinate either from the drawing origin or from a temporary origin you specify. You must specify two points to 
create an ordinate dimension: an ordinate point and a text point. The position of the text point in relation to the 
ordinate point determines whether the x-or y-coordinate is displayed. AutoSketch automatically calculates the 
value displayed in the dimension label based on settings in the Dimension Format dialog box.
    Related Topics



To note the x- or y- coordinate of a point

1 On the Draw menu, click Dimension, Ordinate, or click Ordinate Dimension on the All-In-One toolbar.

2 (optional) Specify a temporary origin by pressing CTRL while you enter a point. Until you cancel the command, 
AutoSketch continues to measure all ordinate dimensions from this point.

3 Enter the ordinate point (the point you want to dimension). A small diamond marks the point.

4 Enter the text point (the point where you want the coordinate displayed).



Leaders

Leaders are notes that reference specific points in a drawing. Unlike other dimensions, leaders do not display a 
measurement. They do, however, reflect certain settings in the Dimension Format dialog box. When you add a 
leader, AutoSketch does not add a leader entity to the drawing. Instead, it adds separate polylines, markers, and 
text entities. This makes it easy to edit a leader after creation.
    Related Topics



To add a leader

1 On the Draw menu, click Dimension, Leader, or click Leader Dimension on the All-In-One toolbar.

2 Enter a point to locate the arrowhead (or other marker). A rubber-band line appears.

3 Enter one or more vertices. Each vertex ends the previous segment and begins a new one. If you make a 
mistake, press DELETE to remove vertices one at a time in reverse order.

4 Right-click to complete the polyline. The Leader Dimension Text dialog box appears.

5 Enter the text you want beside the arrow and click OK.



Formatting Dimensions

Most dimension components are generated automatically based on points you specify. You can tailor these 
components to suit your preferences with settings in the Dimension Format dialog box. The Dimension Format 
dialog box appears when you click the Format button on the edit bar or when you click Format Dimension on the 
pop-up menu for dimensions. Settings in the Dimension Format dialog box are divided into the following 
categories:

Dimension Lines
Extension Lines
Label 
Tolerance

Lengths in the Dimension Format dialog box, such as terminator size and text height, specify size on printed 
output, not real world size as in some CAD applications.
    Related Topics



Dimension Lines

The dimension line is the part of the dimension entity that has an arrow or other terminator at each end. In an 
angular dimension, the dimension line is an arc. In all other dimension types, it is a line.
    Related Topics



To specify the dimension line for a dimension

1 Select the dimension.

2 Click the Format button on the edit bar. The Dimension Format dialog box appears.

3 Click the Dimension Line page tab.

4 Select an item from the Terminator Type drop-down list box. The list includes all AutoSketch marker styles. 

5 Enter a terminator size. This is the height of the line terminator on printed output.

6 Enter a minimum leader length. This is the minimum length that AutoSketch allows for dimension lines 
displayed inside extension lines.

When the dimension line and label are too long to fit inside the extension lines, AutoSketch automatically 
displays them outside:

7 Check the Save As Defaults check box if you want to use the settings on future dimensions, then click OK.



Extension Lines

Most linear dimensions and certain angular dimensions include extension lines. These lines extend from the ends 
of dimension lines toward corresponding dimension points. Extension lines for linear dimensions are 
perpendicular to the dimension line. Those for angular dimension lines extend toward the vertex of the measured 
angle. When extension lines are unnecessary, you can suppress one or both of them.
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To specify extension lines for a dimension

1 Select the dimension.

2 Click the Format button on the edit bar. The Dimension Format dialog box appears.

3 Click the Extension Line page tab.

4 Enter a break length. This is the gap between the dimension point and the end of the extension line on printed 
output.

5 Enter the overrun length. This is the distance the extension line extends beyond the dimension line on printed 
output.

6 To omit the first extension line, check the Suppress Line 1 check box. To omit the second extension line, check 
the Suppress Line 2 check box.

7 Check the Save As Defaults check box if you want to use the settings on future dimensions, then click OK.



Dimension Label Font

The dimension label font is the font AutoSketch uses to display the text component of a dimension. Any font that is 
available in a text entity can be used in a dimension label. This includes any TrueType font installed on your 
system and any of the plotter fonts supplied with AutoSketch.
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To specify the font used in a dimension label

1 Select the dimension.

2 Click the Format button on the edit bar. The Dimension Format dialog box appears.

3 Click the Label page tab.

4 From the Text Font drop-down list box, click a font. The list includes all TrueType fonts available on your 
system and (if installed) the 19 plotter fonts supplied with AutoSketch. 

5 Enter a text height. This is the height of capital letters in the selected font.

6 Enter a value in the Text Aspect text box. This is the ratio of width to height of an average character in the 
selected font. Larger ratios create wider characters. Smaller ones create narrower characters. For most fonts, 
the default setting is 0.6.

7 Check the Save As Defaults check box if you want to use the settings on future dimensions, then click OK



Dimension Label Format

The dimension label is the text component of a dimension entity. In most dimensions, it contains a calculated 
measurement, but it can contain other text you specify. If you include the calculated measurement in the label, you 
can have AutoSketch display tolerance values as well. You can also omit the calculated measurement entirely and 
supply your own label.
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To format a dimension label

1 Select the dimension.

2 Click the Format button on the edit bar. The Dimension Format dialog box appears.

3 Click the Label page tab.

4 From the Alignment drop-down list box, click an option. This determines how the label is aligned in relation to 
the dimension line. The available options are None, Text Above, Text In, and Text Below. 

Normally, the dimension line appears between the extension lines. When the dimension label is too long to fit 
between the extension lines, AutoSketch automatically moves the dimension line and label outside the 
extension lines.

5 Select the units of measurement and a precision for the calculated value. Settings other than Use Drawing 
Units and Use Drawing Precision allow you to override current settings in the Drawing Options dialog box. For 
more information on setting the units of measurement and precision, see Setting the Units of Measurement 
and Setting Decimal Precision for Scalar Values. 

6 Check the Display Units check box if you want units of measurement displayed along with the calculated 
value.

7 Enter the text you want in the label. The default text for linear and angular dimensions is “<>.” It displays the 
calculated value only. The default text for a diameter dimension is “¿ <>.” For a radius dimension it is “R <>.” 
To customize the label, add text on either side of “<>.” To omit the calculated value from the label, delete “<>.” 
Do not add characters between “<“ and “>.”

8 Check the Save As Defaults check box if you want to use the settings on future dimensions, then click OK



Dimension Tolerance

Some drawings depict objects that do not conform to exact measurements but instead fall in a range of 
measurements. You can show this range in a dimension entity by specifying tolerance. AutoSketch supports two 
tolerance display modes: plus/minus and range. Plus/minus tolerance shows the calculated measurement 
followed by a negative and positive tolerance. Range tolerance shows the lower and upper ends of the range. 
AutoSketch calculates these values automatically by subtracting the minus tolerance from the calculated value 
and adding the plus tolerance.
    Related Topics



To specify dimension tolerance

1 Select the dimension.

2 Click the Format button on the edit bar. The Dimension Format dialog box appears.

3 Click the Tolerance page tab.

4 Click a tolerance method from the Method drop-down list box. The default method, “None,” disables 
tolerancing.

5 Enter the plus and minus tolerance values. These specify the positive and negative variance that is allowed in 
the measurement.

6 Enter the text height factor. This determines the height of text used to display variance in plus/minus 
tolerancing. The default setting, 0.8, specifies that plus and minus values are 80% as high as the calculated 
value.

7 Check the Save As Defaults check box if you want to use the settings on future dimensions, then click OK. 



Markers

A marker is an entity that displays one of several pre-defined shapes. You can use a marker to note the location of 
a specific coordinate, the endpoint of a line, directional flow, and so on. Like a symbol, you can resize, move, 
rotate, or convert a marker to its component entities. 

Markers are not intended to represent real objects in the drawing. Instead, AutoSketch views them as annotation 
to the drawing. AutoSketch scales markers, and other annotation entities, at output size. If you enter a marker that 
is .25” high, it prints as .25” high, regardless of the drawing scale.

Four geometric properties define a marker in AutoSketch: the basepoint, angle, height, and width. You can edit 
these properties by selecting the marker and changing the settings on the edit bar.

Marker controls can be accessed from the Draw menu or the Marker toolset on the All-In-One toolbar. You can 
also activate the Marker toolbar (which contains the same commands but can be docked anywhere onscreen) by 
right-clicking a bar, then clicking Toolbars on the pop-up menu that appears. Simply check the Marker check box 
in the Toolbars dialog box, then click OK to make the Marker toolbar visible onscreen.
    Related Topics



Placing a Marker

You place a marker by entering a point in the drawing for the marker basepoint. Markers make it easy to draw 
attention to a point in the drawing, because the basepoint is usually the focal point of the marker.

You can use the plus (+) and minus (-) keys on the numeric keypad (or use F5 or SHIFT+F5 if you don’t have a 
keypad) to rotate a marker before or after you enter its basepoint. You can specify this angle of rotation by 
modifying the Plus/Minus Rotation text box on the Drawing page of the Drawing Options dialog box.

You can also align a marker to specific points on an entity. To align a marker onto an entity click Marker, Align On-
Entity on the Draw menu. Click Marker, Align to Endpoint in the Draw menu, to align a marker to the endpoint of 
an entity.

If you need to rotate or align a marker at a specific angle, you can place the marker using two points. The first 
point is the basepoint of the marker. The second point determines the angle of rotation for the marker.
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To add a marker at a specific point

1 On the Draw menu, click Marker, Point, or click the Marker Point button on the All-In-One toolbar.

2 Click the marker type from the Marker Types drop-down list box on the edit bar.

3 Enter the marker basepoint.



To add a marker aligned to two points

1 On the Draw menu, click Marker, Point, or click the Marker Point button on the All-In-One toolbar.

2 (optional) Click the marker type from the drop-down list box on the edit bar.

3 Press and hold CTRL while entering the marker basepoint. An outline of the marker appears. 

4 Enter a second point to define the alignment of the marker.



To add a marker at a specific point and angle

1 On the Draw menu, click Marker, Align On-Entity, or click the Marker Align Entity button on the All-In-One 
toolbar.

2 (optional) Select the marker type from the drop-down list box on the edit bar.

3 An outline of the marker appears, click the entity at the point you want the marker to appear. Use the plus (+) 
and minus (-) keys on the numeric keypad or SHIFT+F5 to rotate the marker. 



To add a marker to the endpoint of a line, polyline, or arc

1 On the Draw menu, click Marker, Align to Endpoint, or click the Marker Align Endpoint Marker button on the All-
In-One toolbar.

2 (optional) Select the marker type from the drop-down list box on the edit bar.

3 An outline of the marker appears at the endpoints of the entity, click the entity at the endpoint where you want 
the marker to appear.



Selecting a Marker Type

AutoSketch provides 24 different marker types for highlighting parts of your drawings. You can select a marker 
after you click Marker, Point on the Draw menu. When Autoselect is active and you place the marker, the marker 
is highlighted. While it remains highlighted, you can change the marker type. 

Tip
While drawing markers, if Autoselect mode is active, changing marker types on the edit bar causes the 

highlighted marker to change.
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Arcs and Circles

An arc is a segment of a circle defined by a centerpoint, radius, starting angle, and included angle. Two geometric 
properties define a circle: the centerpoint and radius. You can change these properties by selecting an arc or 
circle and changing the corresponding settings on the edit bar.

You can draw an arc by specifying any of the following:
Startpoint, endpoint, and a point on the arc
Startpoint, endpoint, and centerpoint
Startpoint, endpoint, and included angle

You can draw a circle by specifying any of the following:
Centerpoint and a point on the circle
Two points on opposite sides of the circle
Three points on the circle.
Centerpoint and radius
Radius and two entities to which the circle is tangent
Three entities to which the circle is tangent

Tools for drawing arcs and circles can be accessed from the Draw menu or the Arcs & Circles toolset on the All-In-
One toolbar. You can also activate the Arc or Circle toolbars (which contain the same commands but can be 
docked anywhere onscreen) by right-clicking a bar, then clicking Toolbars on the pop-up menu that appears. 
Simply check Arc or Circle, then click OK to make the Arc or Circle toolbar visible onscreen.
    Related Topics



Drawing Arcs Based on Points

The Draw menu has three commands for drawing arcs. Two of the commands, 3 Points and 2 Points & Center, 
have modifier keys. In each case, pressing CTRL as you enter the third point switches the second and third 
points. Instead of entering the startpoint, endpoint, and a point along the arc, for instance, you can enter the 
startpoint, a point along the arc, then, while pressing CTRL, enter the endpoint.
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To draw an arc by specifying its endpoints and a third point

1 On the Draw menu, click Arc, 3 Points, or click the 3 Points Arc button on the All-In-One toolbar.

2 Click the startpoint. A small diamond marks the point.

3 Click a second point. Another diamond marks this point and a rubber-band arc appears and follows the pointer.

4 Click the endpoint or press CTRL and click a point along the arc.



To draw an arc by specifying its endpoints and the centerpoint

1 On the Draw menu, click Arc, 2 Points & Center, or click the 2 Points & Center Arc button on the All-In-One 
toolbar.

2 Click the startpoint. A small diamond marks the point.

3 Click a second point. Another small diamond marks the point.

4 Click the centerpoint or press CTRL to click the endpoint.



To draw an arc by specifying its endpoints and included angle

1 On the Draw menu, click Arc, 2 Points & Angle, or click the 2 Points & Angle button on the All-In-One toolbar.

2 Enter the included angle on the edit bar and press ENTER.

3 Click the startpoint. A small diamond marks the point and a rubber-band arc appears.

4 Click the endpoint.



Drawing Circles Based on Points

You can add circles to a drawing by using any of six commands on the Draw menu. The first four commands allow 
you to add circles based on points you know.
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To draw a circle by entering the centerpoint and a point on the circle

1 On the Draw menu, click Circle, Center, Side, or click the Center-Side Circle button on the All-In-One toolbar.

2 Click the centerpoint or a point on the circle. A small diamond marks the point and a rubber-band circle 
appears.

3 Click a point on the circle or press CTRL and click the centerpoint.



To draw a circle by entering two points on opposite sides of the circle

1 On the Draw menu, click Circle, Side, Side, or click the Side-Side Circle button on the All-In-One toolbar.

2 Click a point on the circle. A diamond marks the point and a rubber-band circle appears.

3 Click a point on the opposite side of the circle.



To draw a circle through three points

1 On the Draw menu, click Circle, 3 Points, or click the 3 Point Circle button on the All-In-One toolbar.

2 Click a point on the circle. A small diamond marks the point.

3 Click a second point on the circle. A small diamond marks this point as well and a rubber-band circle appears.

4 Click a third point on the circle.



To draw a circle by specifying its centerpoint and radius

1 On the Draw menu, click Circle, Center, Radius, or click the Center-Radius Circle button on the All-In-One 
toolbar. A rubber-band circle appears.

2 (optional) Enter the radius in the Radius text box on the edit bar and press ENTER.

3 Click the centerpoint.



Drawing Tangent Circles

In some cases, you must draw a circle that is tangent to existing entities but whose centerpoint is unknown. 
AutoSketch can calculate the centerpoint and, in some cases, the radius, of such a circle for you. You need only 
specify two or three entities to which the circle is tangent. When you specify two entities, you must also provide 
the radius of the circle. When you specify three entities, AutoSketch calculates the radius for you.

You can use any combination of lines, arcs, circles, and poly segments to define a tangent circle. When used for 
this purpose, lines and poly segments are treated as lines of infinite length. Arcs and bulged poly segments are 
treated as circles. Because of this, a tangent circle may not actually touch any of the entities used to define it.

Often, AutoSketch is able to draw several circles that are tangent to the entities you specify. In this case, it 
chooses one circle based on where you click the entity and, in the case of arcs, circles, and bulged poly 
segments, whether you click inside or outside. Clicking inside an arc, circle, or bulged poly segment creates an 
inside tangent. Clicking outside the same entities creates an outside tangent.
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To draw a circle that is tangent to two entities

1 On the Draw menu, click Circle, Tangent 2 Entities, or click the Tangent 2 Entities Circle button on the All-In-
One toolbar.

2 Enter the radius in the Radius text box on the edit bar and press ENTER.

3 Click the first entity. The entity is highlighted.

4 Click the second entity. Notice that which side of each entity you click affects the location of the circle.



To draw a circle that is tangent to three entities

1 On the Draw menu, click Circle, Tangent 3 Entities, or click the Tangent 3 Entities Circle button on the All-In-
One toolbar.

2 Click the first entity. The entity is highlighted.

3 Click the second entity. The entity is highlighted.

4 Click the third entity. Notice that which side of each entity you click affects the location of the circle. 



Pen and Pattern Properties

AutoSketch uses pen and pattern properties to determine how to display and print entities. There are three pen 
properties: color, style, and width. Pen properties apply to all entities except symbols (symbols display the pen 
properties of their component entities or the symbol instance.) Pattern properties apply only to polygons and 
closed curves. 

The pattern property specifies one of three pattern styles: hatch, solid or none. The hatch style consists of a 
repetitive line pattern. The solid style consists of a solid color. None removes hatching and solid fills.

You can edit pen and pattern properties using the property bar or the Graphic Options dialog box. Using the 
controls in either of these locations changes the properties for new entities and for any selected entities. You can 
access the Graphic Options dialog box by clicking Graphic Options on the Tools menu, or you can right-click the 
Color, Style, Width, or Pattern drop-down list boxes on the property bar and click Graphic Options on the pop-up 
menu that appears.

AutoSketch also allows you to match the pen and pattern properties of an entity. The Property Painter tool 
matches the properties of a single entity to a selection set, while the Dropper tool updates the current settings on 
the property bar from the properties “extracted” from a single entity. Matchable properties include layer, pen color, 
pen style, pen width, and pattern styles.
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Setting Pen Properties

AutoSketch supports three pen properties: color, style, and width. Color is the color in which the entity is 
displayed. Style is the pattern of lines and dots AutoSketch uses to display and print the entity. Width determines 
the width of the entity. When you set pen properties, you set the properties for new entities as well as any selected 
entities.

Pen width is independent of the width settings for polyline and polygon entities. It is specified in the smallest unit 
available for the hardware that displays the entity. On your display, the pen width property is measured in pixels, 
the individual dots that your video card uses to “paint” the screen. On a printer, pen width is measured in the 
pixels that generate the printed image. Printer pixels are generally much finer than screen pixels. On a plotter, pen 
width is the width of one stroke of a pen.

You can assign pen properties by layer. You determine the associated color, style, and width for a layer using the 
Graphic Options dialog box. This makes it possible for you to determine what layer an entity is on just by looking 
at the drawing. For information on setting up layers for your drawings, refer to Organizing With Layers.

You can also assign pen properties by symbol. Again, you determine the associated color, style, and width for a 
symbol using the Graphic Options dialog box. This makes it easier to distinguish between symbols by sight.

Note
The first nine pen styles retain their appearance regardless of the scale setting. Global and Entity Style 

Scale factor do not apply to these styles.
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To set pen properties

1 Select the entities whose properties you want to modify.

2 Click the Color, Style, or Width drop-down list boxes on the property bar, depending on the pen property you 
want to change.

3 Click an item in the list. If the pen property you want is already current, simply click the current setting. 

Note
You can also set these properties using the corresponding controls in the Graphic Options dialog box. To 

display this dialog box, click Graphic Options on the Tools menu or right-click the Color, Style, Width, or Pattern drop-
down list boxes on the property bar and click Graphic Options on the pop-up menu. You can also click the Graphic 
Options button on the Standard toolbar.



Using Color Palettes

With AutoSketch you can define your own custom colors using the Palette page of the Graphic Options dialog 
box. You can customize individual palettes, load and save entire palettes, and control the presentation in which 
colors are displayed in each palette. 

You can also create and name your own custom color by starting with an available color on the palette and 
changing its red, green, and blue values (RGB values), or by picking a color from the color spectrum using the 
Color dialog box. 

Note
There are 16 default colors in the pen and pattern color palette that cannot be changed. When a default 

color is selected all information is grayed out. 
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To customize color palette presentation

1 On the Tools menu, click Graphic Options, or click the Graphic Options button on the Standard toolbar, or right-
click a pen or pattern box on the property bar, then click Graphic Options on the pop-up menu. The Graphic 
Options dialog box appears. 

2 Click the Palette page tab. 

3 (optional) In the Presentation Order section, click an option button to select the order in which the palette 
colors are displayed. Color Sort groups colors according their color category. Darkness First sorts the palette 
with the dark colors appearing first, while Lightest First sorts the palette with the lightest colors appearing first. 



To create a custom color by changing RGB values

1 On the Tools menu, click Graphic Options, or click the Graphic Options button on the Standard toolbar, or right-
click a pen or pattern box on the property bar, then click Graphic Options on the pop-up menu. The Graphic 
Options dialog box appears. 

2 Click the Palette page tab.

3 Click a color on the color palette. 

4 Enter new Red, Green, Blue values in the R, G, and B text boxes. The color you selected adjusts as you 
change the RGB values.

5 Enter a name for your new custom color in the Name text box and press ENTER. 



To create a custom color using the Color spectrum

1 On the Tools menu, click Graphic Options or right-click a pen or pattern box on the property bar, then click 
Graphic Options on the pop-up menu. The Graphic Options dialog box appears. 

2 Click the Palette page tab.

3 Click Pick. The Color dialog box appears. 

4 Click an area on the color spectrum window to select a custom color. Notice that the Color/Solid block changes 
depending on where you click in the color spectrum. 

5 Adjust the Red, Green, Blue values and the Intensity level to create the custom color you want, then click OK. 

6 Enter a name for your new custom color in the Name text box and press ENTER. 



To save a color palette

1 On the Tools menu, click Graphic Options or right-click a pen or pattern box on the property bar, then click 
Graphic Options on the pop-up menu. The Graphic Options dialog box appears. 

2 Click the Palette page tab. 

3 Make necessary changes to the palette order or create custom colors.

4 Click Save Palette. The Save Palette File dialog box appears. 

5 Enter palette filename in the Filename text box. If you want to save the palette to a different location, click a 
different drive and folder or enter the complete path in the Filename text box. 

6 Click Save. 

Note
In AutoSketch you cannot have duplicate names for a color palette. 



To load a color palette

1 On the Tools menu, click Graphic Options or right-click a pen or pattern box on the property bar, then click 
Graphic Options on the pop-up menu. The Graphic Options dialog box appears. 

2 Click the Palette page tab. 

3 Click Load Palette. The Open Palette dialog box appears. 

4 Click the palette you want to open, or enter the name in the Filename text box. 

5 Click Open. 



Creating Custom Pen Styles

From time to time you may need to define your own pen styles. AutoSketch pen styles are composed of a series 
of dashes and dots separated by spaces, and are saved in linetype definition files, which have an .LIN file 
extension. To create your own pen style, a text editor, such as Microsoft Notepad, is needed. 

Each pen style file is based on two lines of text in the linetype file. The first line defines the linetype name while 
the second is the actual code that describes the pattern. The first line must begin with an asterisk, immediately 
followed by the pen style name and optional description. 

The second line contains the alignment code and pattern descriptors. The alignment code “A” (the only alignment 
code currently available) ensures that the lines will start and end with a dash. The descriptors specify the length of 
the segments that make up the linetype. A pen style definition must contain at least four descriptors, but you can 
enter up to 12, as long as they fit on an 80 character line. The first value describes the length of the dash in the 
pattern or a dot. The second describes the length of the gap. If the descriptor is a positive number, a dash 
segment is drawn at that length. For instance, a value of .5 draws a dash that is .5 drawing units long. A negative 
value represents a blank segment, so -.25 would create a gap of -.25 drawing units between dashes. To draw a 
dot, use the dash length 0.

*PEN1, dashed line
A, .5, -.5, .5, -.5

Custom pen style files should be saved to the Properties folder in order for AutoSketch to locate the new files. If 
you have already defined custom pen styles, you can use them with your AutoSketch projects as well. To include 
previously defined line type files in your AutoSketch palette, simply copy the line type files to the property folder.

Note
AutoCAD linestyle files are also compatible with AutoSketch, but complex AutoCAD linestyle files will be 

ignored in AutoSketch. 
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To create a new pen style

1 Start your text editor.

2 On the first line, type an asterisk, then enter a style name. 

3 (optional) Type a comma, then, without inserting a space, enter a brief description of the pen style and press 
ENTER. If you omit the description, simply press ENTER after entering the style name. 

4 On the second line, type A for the alignment code, followed by a comma, then enter values for the pattern 
descriptors, separating each with a comma. Remember, positive values represent dash segments, negative 
values represent blank segments, and dots are represented by a 0.

5 Repeat the sequence of pattern descriptors.

6 Save the new pen style in the property folder. The file name should be the same as the style name you 
entered in Step 1. For instance, a pen style named PEN1 would be saved in the PEN1.LIN file. 

Note
In order to use a new pen style, AutoSketch must be restarted. 



Patterns for Polygons and Closed Curves

Polygons and closed curves can be filled with a hatch pattern or solid color. A hatch pattern is a repetitive line 
pattern AutoSketch uses to fill polygons and closed curves. When you select a pattern style, you set the pattern 
for new closed poly entities as well as any highlighted polygons or closed curves.

The pattern style you select depends on how you use the drawing. Solid fills look great on color displays but don’t 
display as clearly when printed using a black and white printer. Hatch patterns aren’t as bright as solid fills, but 
they display sharply using most printers and plotters.
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To select a solid fill for a polygon or closed curve

1 Select the polygons and/or closed curves you want to fill.

2 On the Pattern drop-down list box on the property bar, click Solid. A drop-down list box displaying solid colors 
appears.

3 On the fill color drop-down list box, click a color.



To select a hatch for a polygon or closed curve

1 Select the polygons and/or closed curves you want to hatch.

2 On the Pattern drop-down list box on the property bar, click Hatch. A drop-down list box displaying hatch 
patterns appears.

3 On the drop-down list box, click a hatch pattern.



To remove a solid fill or hatch pattern from a polygon

1 Select the polygons and/or closed curves whose hatch patterns or fills you want to remove.

2 On the Pattern drop-down list box on the property bar, click None.

Note
You can also set these properties using the corresponding controls in the Graphic Options dialog box. To 

display this dialog box, click Graphic Options on the Tools menu or right-click the Color, Style, Width, or Pattern drop-
down list boxes on the property bar and then click Graphic Options on the pop-up menu. You can also click the 
Graphic Options button on the Standard toolbar.



Matching Entity Properties

AutoSketch allows you to match the properties of an entity to a selection set or to the property bar. Properties that 
can be matched include layer, pen color, pen style, pen width, and pattern style. 

The Property Painter tool is used to match the properties of one entity to another: for instance, to make sure a 
polygon has the same appearance as another polygon or is on the same layer. After selecting the entity whose 
properties you want to match, simply check the check boxes for properties to match on the edit bar then select the 
entity to which to apply the property changes. 

The Dropper tool is used to extract the properties of an entity and make them current on the property bar. This can 
help you ensure that the properties you want can be assigned to other entities that haven’t yet been added to the 
drawing. Simply select the entity to match and pick which properties to extract to the property bar. 
    Related Topics



To match the properties of an entity or entities to a selection set

1 Click the Property Painter button on the Standard toolbar. 

2 Select the entity whose properties you want to extract (the source entity). 

3 On the edit bar, check the property check boxes to apply to the target entities.

4 Select the entities whose properties you want to change. You may have to drag to define a region of selection. 
The properties of the entity are applied. 

5 (optional) Right-click once to redefine the source entity and continue matching properties using the Property 
Painter.



To match the properties into the property bar 

1 Select the entity whose properties you want to extract.

2 Click the Dropper button on the property bar. 

3 On the edit bar, click those properties you want to extract. The properties selected are copied to the property 
bar. 



Hatch Spacing and Angle

A hatch is made up of a line pattern, the space between the hatch lines, and the line angle. You can customize the 
hatching for your drawing by changing the space between hatch lines and the angle at which the hatch lines are 
drawn. Changing the hatch spacing and angle updates the entire drawing, modifying all hatched polygons.

Note
Hatch spacing is only applied to the first fifteen hatch patterns on the Hatch drop-down list.
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To set the hatch spacing and angle

1 On the Tools menu, click Graphic Options, or click the Graphic Options button on the Standard toolbar. The 
Graphic Options dialog box appears.

2 Click the Current page tab. 

3 To set the hatch spacing, enter a length in the Hatch Spacing text box.

4 To set the hatch angle, enter an angle in the Hatch Rotation text box.

5 Click OK.



Filling a Closed Area with a Hatch Symbol

You can create a hatch symbol to fill any closed area. AutoSketch creates an anonymous symbol made up of lines 
forming the hatch pattern to fill the area. AutoSketch names this symbol “Hatch” and then a unique number. You 
can move, scale, and convert it the same as other symbols. For information on symbols, see Symbols.

Unlike polygons with hatches assigned to them, hatch symbols do not update when you change the hatch spacing 
and angle settings for a drawing. A hatch symbol is independent of other entities in the drawing. You can even 
delete the original entities that were used to create the hatch without modifying the hatch symbol.
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To fill a closed area with a hatch symbol

1 Select the entity or group of entities that define the closed area. 

2 (optional) On the property bar, click a different hatch pattern.

3 On the Draw menu, click Hatch or click the Hatch button on the All-In-One toolbar. A symbol is created to hatch 
the defined area.



To remove a hatch symbol

1 Click the hatch pattern. The hatch highlights and selection handles appear.

2 On the Edit menu, click Delete, or press DELETE.



Creating Custom Hatch Patterns

Individual designers and companies often rely on custom hatches to define areas in their projects. Creating a 
custom hatch pattern for AutoSketch can be as simple or complex as you want. In their simplest form, they consist 
of two lines of text and code created in a text editor such as Windows Notepad. More complex patterns require 
two or more lines of code to define the hatch.

The first line, the header line, contains the pattern name and optional pattern description. This header line must 
begin with an asterisk, followed immediately by the pattern name. The pattern name must be the same as the file 
name for the hatch pattern. For instance, a pattern named HTCH1 would be contained in the HTCH1.PAT file. The 
pattern name appears on the property bar and in the Graphic Properties dialog box. 

The remaining lines consist of the pattern description the actual code that makes up the hatch pattern. The 
pattern description contains the following information: 

angle
The angle of the described pattern. 

X, Y origins
The origin of the pattern element. 

delta X, delta Y
The vertical (X) and horizontal (Y) spacing between hatch lines. 

dash 1, dash 2
For dashed-line patterns, the length of each dash in the pattern and the spaces between them. 

Each field of the pattern uses descriptors to specify the segment making up the hatch pattern lines. If the length is 
positive, a segment is drawn at the length you specify. For instance, a value of .5 draws a segment that is .5 
drawing units long. A negative value represents a blank segment, so -.25 would create a space or gap of -.25 
drawing units long. To draw a dot, use the dash length 0. 

All hatch patterns follow this basic format: 

*pattern name[ , description]
angle, X origin, Y origin, delta X, delta Y [ , dash 1, dash2 ...]

For instance, a simple hatch pattern with 35-degree lines separated by a spacing of 0.5 would be defined: 

*Hatch36, 36 - lines
36, 0, 0, 0, .6

To add dashes with a spacing of .25 between them, the pattern file would be defined: 

*Hatch36, 36 - lines
36, 0, 0, 0, .6, .6, -.25

More complex patterns can be created using multiple pattern definitions within a single file. This allows you to 
create patterns with lines at different angles. For instance, a pattern of 45 degree crossing lines would be defined: 

*Hatch46
46, 0, 0, 0, .6
-46, 0, 0, 0, 0, .6

Custom hatch pattern files (.PAT) should be saved to the property folder in order for AutoSketch to locate them. If 
you have already defined custom hatch patterns in the past, you probably want to use them with your AutoSketch 
projects as well. To include previously defined hatch patterns in your AutoSketch palette, simply copy the hatch 
pattern files to the property folder.

Note
Pattern files from AutoCAD are also compatible with AutoSketch. 
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To create a custom hatch pattern

1 Start your text editor.

2 On the first line, type an asterisk, then enter a pattern name. 

3 (optional) Type a comma, then, without inserting a space, enter a brief description of the hatch pattern and 
press ENTER. If you omit the description, simply press ENTER after entering the pattern name. 

4 On the second line, enter the angle of the hatch lines, the X origin, the Y Origin, delta X, and delta Yall 
separated by commas.

5 Enter values for the pattern descriptors, separating each with a comma. Remember, positive values represent 
dash segments, negative values represent blank segments, and dots are represented by a 0.

6 (optional) For a pattern with lines at different angles, press ENTER, then repeat steps 4 and 5 with the new 
values.

7 Save the new pen style in the property folder. The file name should be the same as the pattern name you 
entered in Step 1. For instance, a pattern named HTCH1 would be contained in the HTCH1.PAT file.

Note
In order to use a new hatch pattern, AutoSketch must be restarted.



Symbols

A symbol is a group of entities that AutoSketch treats as a single entity. You can save drawing time and establish a 
uniform look using symbols. AutoSketch responds faster and uses less storage space if you use symbols rather 
than repeatedly copying entities.

AutoSketch stores the information it needs to draw a symbol once, regardless of how many times you use the 
symbol in the drawing. The symbol definition contains all of the information needed to place a symbol, including its 
geometry, graphic properties, and default database fields. Each time you place a symbol, AutoSketch records a 
symbol instance. A symbol instance marks the location to insert the image contained in the definition.

While you can assign database information to most entity types, symbols are the only entity types that can contain 
database values before you place them. By creating symbols with default values specified for the type of 
information you want to track in your drawing, you can use symbols as building blocks for your drawing database. 
For information on storing database fields in symbols, see Creating Symbol Definitions.

A drawing created with symbols is easier to update and maintain than one without symbols. For example, assume 
you have a drawing of an office floorplan with many identical doors. With symbols, if you decide to redesign the 
doors, you need only edit one door and redefine the symbol. All instances of the symbol are then automatically 
updated.
    Related Topics



Placing a Symbol

AutoSketch provides two methods to place symbols in your drawing. You can place a symbol by entering the 
basepoint of the symbol or by entering two points to align the symbol. You do not have to use the same snap 
mode or lock modifier for both points. That is, you could use Gridpoint snap mode for one point and Relative snap 
mode for the other. You can choose the symbol to place at these points using the symbol library bar.

The symbol library bar is a means for choosing symbols to place in a drawing. Each button in the symbol library 
bar contains a small image of the symbol it represents. You can change which symbols are available by using the 
symbol library bar’s pop-up menu to change symbol libraries or clicking Symbol, Change Library on the Draw 
menu. 

A symbol library is a file that contains symbol definitions. Symbol libraries provide an external copy of your 
symbols in case they are deleted from a drawing and they allow you to use your symbols in multiple drawings. 
Another way to choose symbols, change libraries, and perform other symbol-related tasks is to use the Symbol 
Explorer.

Tools for placing symbols and selecting symbol libraries can be accessed from the Draw menu or the Symbol 
toolset on the All-In-One toolbar. You can also activate the Symbol toolbar (which contains many of the same 
commands, plus some related commands like Inquire Symbol Count) by right-clicking a bar, then clicking Toolbars 
on the pop-up menu that appears. Simply check the Symbol check box in the Toolbars dialog box, then click OK to 
make the Symbol toolbar visible onscreen.
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To place a symbol by entering a single point

1 Click a button on the symbol library bar.

2 (optional) Rotate the symbol by pressing plus (+) or minus (-) on the numeric keypad, or F5 or SHIFT+F5.

3 Click the basepoint of the symbol.

Note
Symbols with “Draw with Insert” turned on are automatically in Insert Symbol mode. For more information 

on inserting symbols see, Inserting Symbols in Lines, Polylines, and Polygons.



To place a symbol by aligning it with two points

1 Click a button on the symbol library bar.

2 Press CTRL and click a point in the drawing for the basepoint of the symbol. 

3 Click a second point.



To place a symbol while scaling it and aligning it to points

1 Click a button on the symbol library bar.

2 Press SHIFT+CTRL and click a point in the drawing for the basepoint of the symbol. 

3 Continue pressing SHIFT+CTRL and click a second point.

Note
Instead of choosing a symbol from the symbol library bar, you can click the Point Symbol button on the All-

In-One toolbar or click Symbol, Point on the Draw menu. An image or extent box of a symbol appears and moves with 
the pointer, and its name appears in the drop-down list box on the edit bar. You can place this symbol or select a 
different symbol from the drop-down list box. 



Inserting Symbols in Lines, Polylines, and Polygons

AutoSketch can automatically open a gap in lines, polylines, or polygons when you insert symbols on top of them. 
Many symbols are designed for you to place them on top of other entities. For example, door and window symbols 
in a drawing of a floorplan are usually inserted in polylines representing walls.

When you insert a symbol on top of a line, AutoSketch divides the line and deletes the portion of the line in which 
you inserted the symbol.

You can make a symbol automatically start Symbol Insert when picked from the Symbol Library toolbar, instead of 
choosing Symbol, Insert on the Draw menu. This feature is available through the Symbol Explorer.

If you delete an inserted symbol, the insertion gap remains. To restore a line, either draw a connecting line 
between the two endpoints of the remaining line, or click Undo on the Edit menu immediately after inserting the 
symbol.
    Related Topics



To insert a symbol in a line or polyline

1 On the Draw menu, click Symbol, Insert, or click the Insert Symbol button on the All-In-One toolbar. 

2 Click a symbol on the symbol library bar or select a symbol name from the drop-down list box on the edit bar.

3 (optional) Enter a custom opening width in the Opening Width text box on the edit bar and press ENTER. The 
default setting uses the width of the symbol extent.

4 Click a point on a line, polyline, or polygon for the basepoint of the symbol.

5 Click a second point to establish the direction AutoSketch draws the symbol in relation to the first point 
entered. 



To insert a symbol at a specific point along a line or polyline

1 On the Draw menu, click Symbol, Insert, or click the Insert Symbol button on the All-In-One toolbar.

2 Click a symbol on the symbol library bar or select a symbol name from the drop-down list box on the edit bar.

3 (optional) Enter a custom opening width in the Opening Width text box on the edit bar and press ENTER. The 
default setting uses the width of the symbol extent.

4 Enter the offset distance in the Offset text box on the edit bar and press ENTER.

5 Click the startpoint of the offset.

6 Click the second point to establish the direction AutoSketch draws the symbol in relation to the first point 
entered.

Tip
You also can select a symbol to insert by clicking a button on the symbol library bar before you click Symbol, 

Insert on the Draw menu.



To automatically insert symbols

1 On the Draw menu, click Symbol, Explore. The Symbol Explorer appears. 

2 Click the Libraries page tab, then select a symbol library. 

3 Select a symbol name, then right-click. To select multiple symbol names press SHIFT. 

4 Click Draw with Insert from the pop-up menu that appears. 

5 Click Close. 

Note
To deactivate Draw with Insert, repeat the preceding steps. In step 4, make sure Draw with Insert is 

unchecked. Press SHIFT to toggle between Symbol Insert and Symbol Point.



To change symbol libraries

1 Right-click the symbol library bar and click Change Library, Open on the pop-up menu. The Open Symbol 
Library dialog box appears.

2 Select a symbol library, then click Open.

Tip
You can also reach the Open Symbol Library dialog box by clicking Symbol, Change Library, Open on the 

Draw menu or right-clicking the symbol drop-down list box on the edit bar and clicking Change Library, Open on the 
pop-up menu that appears.



Creating Symbol Definitions

You can create symbol definitions and modify existing ones. This section explains the components of entities and 
how to create them. To learn how to modify them, see Using the Symbol Explorer.

There are three major components of a symbol definition: geometry, graphic properties, and database fields. The 
geometry and graphic properties of a symbol definition are determined by the component entities that are selected 
and combined to create it. If you want the graphic properties to be changed based on the symbol instance 
properties, use by-symbol settings. You set the values for a symbol’s database fields when you create the symbol 
definition.

All symbol definitions have AutoFields, or database fields that AutoSketch sets up automatically: Symbol Name, 
Symbol Type, Symbol Description, and Hyperlink. Of these, you are required to include a Symbol Name. You have 
the option of adding a symbol type, description, or hyperlink by entering information in the corresponding text 
boxes in the Create Symbol Definition dialog box. You can also assign data to the symbol using any of the fields 
available in the current drawing. To learn how to create new fields, see Creating Fields.

When you create a symbol definition, the selection set is not replaced with the symboltherefore, your symbol is 
defined but no instances exist. To replace the entities with a symbol, delete the selection set and place a symbol. 
For more information on placing symbols, see Placing a Symbol.

A symbol can contain other symbols. The container symbol is called a nested symbol. You can create additional 
levels of nesting by placing a nested symbol inside another symbol. There is no firm limit to how many times you 
can nest a symbol, but repeated nesting can deteriorate system performance.

In addition to AutoFields, you can add new fields to symbols as you create them. When you place these symbols, 
they automatically update the drawing’s database.

If you save a new symbol to a library, then insert it in a different drawing, the fields may not exist. In such a case, 
AutoSketch adds them to the drawing. If the drawing contains fields with the same name but with a different type 
than those fields in the symbol, AutoSketch uses the drawing’s field type to convert the value stored in the 
symbol.
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To create a new symbol

1 Select the entities from which you want to create a symbol.

2 On the Draw menu, click Symbol, Create, or click the Create Symbol button on the All-In-One toolbar. The 
Create Symbol Definition dialog box appears.

3 Enter a symbol name in the Name text box.

4 (optional) Enter a type and description for the symbol in the corresponding text boxes.

5 (optional) Enter a hyperlink in the corresponding text box. For more information on hyperlinks, see Using Web 
Tools.

6 (optional) Check the Save In Library check box to store the symbol in a library.

7 Select a method for entering the basepoint from the Basepoint drop-down list box, then click OK.

8 If you checked the Save In Library check box, the Open Symbol Library dialog box appears. Click an existing 
library name or create a new one by entering a name in the Filename text box, then click Save.

9 If you chose the Basepoint Select After OK option, click the symbol basepoint.



To define database fields when creating a symbol definition

1 Select the entities that define the symbol.

2 On the Draw menu, click Symbol, Create, or click the Create Symbol button on the All-In-One toolbar. The 
Create Symbol Definition dialog box appears.

3 Enter a symbol name in the Name text box.

4 Click Fields. The Symbol Fields dialog box appears. If no fields are available for the current drawing, the 
button is grayed. 

5 Click a field name and enter its value. If more than one field is available, you can enter values for any or all of 
them.

6 Click OK, complete the Create Symbol Definition dialog box, and click OK again.



Using the Symbol Explorer

The Symbol Explorer can perform a wide variety of symbol-related functions. It’s a tool for managing symbol 
definitions and the symbol libraries in which they are stored, much like Windows Explorer is a tool for managing 
files and folders. Finally, it’s one of the means for setting a current library and a current symbol.

The current library is the collection of symbols that appears on the symbol library bar (if the symbol library bar is 
set to be visible). Symbols in the current library also appear in the drop-down list box on the edit bar, along with 
additional symbol definitions in the current drawing.

The current symbol is the one that appears in the drawing when you click a button or Draw menu choice for 
placing a symbol and then click a point. Clicking any symbol on the symbol library bar or in the drop-down list box 
on the edit bar makes it current.

The Symbol Explorer displays both the hierarchy of folders on your computer and the files and folders in each 
selected folder. However, the only files it displays are symbol libraries (files with an .SLB extension). It displays the 
symbol definitions in any selected library or open drawing, indicating which library and symbol are current. The 
default path can be changed on the Path page of the Customize Commands dialog box.
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To start the Symbol Explorer
On the Draw menu, click Symbol, Explore or right-click the symbol library bar, then click Explore on the pop-

up menu, or right-click the symbol drop-down list box on the edit bar, then click Explore on the pop-up menu.



Managing Symbol Libraries

Symbol libraries are a means to organize your symbol collection, and the Symbol Explorer is a means to organize 
the libraries. You can organize symbols in libraries by using methods, such as discipline, project, author, and so 
on.

The Symbol Explorer provides several ways to copy and move symbols between drawings and libraries. You use 
it to create, rename, and delete symbol libraries. Deleting unused symbols can keep your symbol libraries from 
becoming unmanageable.
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To copy symbol definitions from any open drawing to the current library

1 On the Draw menu, click Symbol, Explore. The Symbol Explorer appears.

2 (optional) Change the current library (see Setting a Current Library).

3 Click the Drawings page tab, then click the name of an open drawing.

4 Select one or more symbol definitions that you want to save in the current library.

5 Right-click a symbol definition, then click Send To, Current Library on the pop-up menu.

6 Click Close.



To copy symbol definitions from one open drawing to another

1 On the Draw menu, click Symbol, Explore. The Symbol Explorer appears.

2 Click the Drawings page tab, then select the name of an open drawing.

3 Select one or more symbol definitions that you want to copy to another open drawing.

4 Right-click one of the selected symbol definition, then click Send To and the name of a drawing on the pop-up 
menu or drag selected symbols and drop them on the name of a drawing.

5 Click Close.



To copy symbol definitions from one library to another or to an open drawing

1 On the Draw menu, click Symbol, Explore. The Symbol Explorer appears.

2 (optional) Change the current library (see Setting a Current Library).

3 Click a library name, then select the symbol definitions you want to copy to another library.

4 Drag the selected symbol definitions and drop them on the name of a library or right-click one of the selected 
symbol definitions, then click Send To and a file name on the pop-up menu.

5 Click Close.



Editing Symbol Definitions

You can edit all fields on one or more symbol definitions at a time. This includes AutoFields that AutoSketch sets 
up automatically, plus any additional database fields created and assigned by you. You can change existing 
values or assign them where no values existed. 

The Edit Fields on Add setting automatically displays the Edit Symbol Fields dialog box after a symbol selected 
from the Symbol Library bar is placed in drawing. This allows you to enter the field information, for already defined 
fields only, for those symbols you use from the symbol library. 

You can move, rotate, scale, and delete symbols like other entities. To edit components of a symbol, first convert 
the symbol to its component entities, then edit the entities and re-combine the symbol. It is important to remember 
to preserve the basepoint and by-symbol    properties. For information on converting symbols, see Converting & 
Exploding Entity Types.
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To create a new library

1 On the Draw menu, click Symbol, Explore. The Symbol Explorer appears.

2 Click the New Symbol Library button at the top of the Symbol Explorer.

3 Enter a name for the library file.

4 Click Close.



To delete a library

1 On the Draw menu, click Symbol, Explore. The Symbol Explorer appears.

2 Right-click a library file and click Delete from the pop-up menu.

3 A prompt box appears asking if you’re sure you want to delete this library, click Yes.

4 Click Close.



To remove symbol definitions from a drawing or a library

1 On the Draw menu, click Symbol, Explore. The Symbol Explorer appears.

2 Click the Drawings page tab or the Libraries page tab, then click the library or the name of the drawing where 
you want to delete a symbol definition.

3 Select one or more symbol definitions you want to delete, then click Delete.

4 A prompt box appears asking if you’re sure you want to delete this symbol, click OK.

5 Click Close.



To enter field information for a symbol after it is placed in a drawing

1 On the Draw menu, click Symbol, Explore. The Symbol Explorer appears. 

2 Select one or more symbol definitions and right-click. 

3 From the pop-up menu, click Edit Fields on Add.

Note
Edit Fields on Add only works when a symbol is selected from the Symbol Library bar to be placed in a 

drawing, not from the Symbol drop-down list box on the edit bar. 



To edit fields for one or more symbols

1 On the Draw menu, click Symbol, Explore. The Symbol Explorer appears.

2 Click the Libraries page tab or the Drawings page tab, depending on the location of the symbol definitions you 
want to modify.

3 Select the symbol or symbols you want to modify, then click Edit Fields. The Symbol Fields dialog box 
appears.

4 Edit the fields you want to change. Grayed areas can’t be edited. To edit a symbol name, select only one 
symbol in step 2.

5 (optional) Check one or more of the Update check boxes (if you edit the fields for only one symbol, the check 
boxes do not appear). If a box is checked, the value in the corresponding text box replaces any values 
previously assigned to that field for all the selected symbols. If the text box is empty the field is deleted.

6 Click OK, then click Close.

Note
The Update check boxes are important when you edit the fields for more than one symbol at a time. If you 

select two symbols and then change a value for a field that has been assigned to both symbols, AutoSketch 
automatically checks the Update check box. This means the new value is assigned to that field for both symbols, 
even if each symbol originally had different values in that field. To prevent this, uncheck the box. When you don’t edit 
a value, the corresponding Update check box remains unchecked and the original values don’t change. You can 
delete a value by checking the Update check box without entering a new value.



Importing Other Symbol Libraries or Part Files

If you’re an upgrade user, you may want to convert your existing AutoSketch for Windows 2.0 or later part files 
into symbol libraries. You can import other libraries or part files into an existing symbol library, or you can create 
an entirely new symbol library.

Once another symbol library or part file has been converted and imported into AutoSketch, it can be placed and 
used in a drawing just as any other AutoSketch symbol. 
    Related Topics



To import symbols or parts from AutoSketch

1 On the Draw menu, click Symbol,Explore. The Symbol Explorer appears. 

2 Select a symbol library in which to place the symbols or parts to import, or create a new library by clicking the 
New Symbol Library button at the top of the Symbol Explorer. 

3 Click Import. The Select File(s) to Import dialog box appears.

4 Select the part files you want to import by clicking. You can select more than one file by pressing SHIFT and 
clicking the filenames.

5 Click Open. The parts, or symbols, are opened into the library you selected in step 2.

Note
The symbol name is the name of the part file and its base point is set to the origin.



Using AutoExplode

AutoExploding converts nested symbols into their individual component symbols. For instance, in a dining room 
group symbol, exploding would allow you to select individual chairs within that dining room set. 
    Related Topics



To explode a symbol

1 On the Draw menu, click Symbol Explore. The Symbol Explorer appears. 

2 Click the Libraries page tab, then select the symbol library file you want to use. 

3 Right-click a symbol name. To select multiple symbols, press SHIFT. 

4 Click AutoExplode from the pop-up menu that appears. 

5 Click Close. When the symbol is placed in a drawing it is exploded. 



To disable AutoExplode

1 On the Draw menu, click Symbol Explore. The Symbol Explorer appears. 

2 Click the Libraries page tab, then select the symbol library file you want to use. 

3 Select a symbol name, then right-click. To select multiple symbol names press SHIFT. 

4 Uncheck AutoExplode from the pop-up menu that appears. 

5 Click Close. 



Setting a Current Symbol

Certain actions automatically make a symbol current. Selecting a symbol from the drop-down list box on the edit 
bar makes it current. A newly-created symbol always becomes the current symbol. Clicking a button on the 
symbol library bar makes the symbol current. 
    Related Topics



To set the current symbol from a library

1 On the Draw menu, click Symbol, Explore. The Symbol Explorer appears.

2 Click the Libraries page tab, then select the symbol library file you want to use.

3 Select a symbol name, then click Set Current.

4 Click Close. The symbol and the library from which it came both become current.



To set the current symbol from an open drawing

1 On the Draw menu, click Symbol, Explore. The Symbol Explorer appears.

2 Click the Drawings page tab, then click the title of an open drawing.

3 Select a symbol name, then click Set Current.

4 Click Close. The symbol becomes current but the current library doesn’t change.

Tip
You can also right-click a symbol name and click Set Current Symbol on the pop-up menu or simply double-

click the symbol.



Setting a Current Library

There are several ways to choose a current library. One simple way is to use the Symbol Explorer to choose a 
current symbol from a library, which automatically makes that library current, too. You can change symbol libraries 
without changing the current symbol.

You have the option of creating a new library at the same time you create a new symbol definition. If you do so, 
that library contains the new symbol and becomes the current library. For more information see Creating Symbol 
Definitions. A new library created in the Symbol Explorer doesn’t automatically become the current library.
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To select the current symbol library without changing the current symbol

1 On the Draw menu, click Symbol, Explore. The Symbol Explorer appears.

2 Click the Libraries page tab, then select a symbol library file.

3 Click Set Current, then click Close.



To select the current library automatically when selecting the current symbol

1 On the Draw menu, click Symbol, Explore. The Symbol Explorer appears.

2 Click the Libraries page tab, then select a symbol library file.

3 Select a symbol name.

4 Click Set Current, then click Close. The selected library and symbol become current.

Note
When you change libraries with the Open Symbol Library dialog box, whatever symbol library you open 

becomes the current library. 



Using the Building Wizard

The Building Wizard allows you to set up a drawing of a commercial or residential building. You can select the 
general shape and dimensions of the building shell, set the default thickness for walls, select from dozens of 
layers and database fields, choose which toolbars you want to display, and so on.

Once the Building Wizard has set up your drawing, you can draw interior walls, add doors and windows, draw 
electrical cabling or water pipes, and even add furnishing or symbols from any of AutoSketch’s dozens of symbol 
libraries. For more information on placing symbols and selecting symbol libraries, see Symbols.

Walls are essentially polylines to which you assign a uniform width, create alcoves, hide or remove segments, and 
so on. For more information on drawing polylines, see Polylines, Polygons and Curves. For more information on 
editing polylines, see Trimming Entities and Reshaping Polylines, Polygons & Curves.
    Related Topics



To draw a wall

1 On the Draw menu, click Polyline, Single, or click the Single Polyline button on the Wizard Tools toolbar.

2 (optional) Change the settings on the edit bar for start width, end width, and bulge.

3 Click a startpoint. A rubber-band line appears from that point.

4 Enter one or more additional vertices. Each one continues from the endpoint of the previous segment and 
begins a new segment. If you make a mistake, press DELETE to remove vertices one at a time in reverse 
order.

5 Right-click to complete the polyline.



To draw a perpendicular wall

1 On the Draw menu, click Polyline, Perpendicular, or click the Perpendicular Polyline button on the Wizard 
Tools toolbar. The pointer changes to a drawing tool.

2 Click a line, arc, circle, polyline segment, or polygon segment. The segment appears highlighted and a rubber-
band line appears and follows the pointer at right angles to the segment.

3 Click an endpoint for the polyline. 

4 Right-click to stop drawing perpendicular polylines.



To draw a corner wall

1 On the Draw menu, click Polyline, Corner, or click the Corner Polyline button on the Wizard Tools toolbar. The 
pointer changes to a drawing tool.

2 Enter lengths in the Corner Length 1 and Corner Length 2 text boxes on the edit bar.

3 Click the line or poly-segment you want to be parallel to the first line. The segment appears highlighted.

4 Click the line or poly-segment you want to be parallel to the second line. The polyline appears, creating a 
rectangle from the original corner.



To move walls with the mouse

1 Select the wall to move.

2 (optional) Press and hold CTRL to move a copy of the selection set and leave the original behind.

3 Using the left mouse button, drag anywhere inside the selection handles to move the wall to another location.

OR

1 Select the wall to move then right-click and click edit vertices on the pop-up menu that appears.

2 Select a segment to move, then click the Move Segment button on the edit bar. A rubber-band wall appears 
and follows the pointer.

3 Reposition the wall, then click to place it.

4 Right-click to exit vertex editing mode.



To move an entire wall a distance and direction defined by two points

1 Select the wall to move.

2 On the Edit menu, click Transform, Translate, or click the Translate button on the All-In-One toolbar.

3 (optional) Check the Copy or Move check box on the edit bar to move a copy of the selection set and leave the 
original.

4 (optional) Check both the Copy or Move and Extrusion Polygon check boxes on the edit bar to extrude the 
selection set as you move.

5 Enter the “from” point. This is the starting point used to calculate the translation.

6 Enter the “to” point that defines the relative distance and direction to move the wall.



To delete walls

1 Select the wall, then right-click and click edit vertices on the pop-up menu that appears.

2 Select the segment of the wall you want to delete, then click the Hide Segment button on the edit bar. A check 
in this button means that the segment is hidden.

OR
Select the wall and press DELETE.

Note
There are many other ways to remove or hide portions of a wall polyline, for more information see .Trimming 

Entities.



To select and place plan doors or windows

1 Click the Symbol Library Menu button, then click Structural Elements, and click either Doors(plan) or 
Windows(plan) from the cascading menu. The symbol library you select is activated and the symbol palette is 
placed on the Symbol Library toolbar.

2 Click a door or a window from the Symbol Library toolbar. If you position the pointer over a symbol for a few 
moments, a ToolTip appears with the name of the symbol.

3 Click on the wall where you want to place one edge of the door or window. A rubber-band line appears, 
stretching from the hinge point of the door or window.

4 Position the pointer on one side or the other of the hinge point, and on one side or the other of the wall. This 
specifies the direction the door or window is to openthere are four possible combinations of left, right, inward, 
and outward.

5 Click to draw the door. AutoSketch automatically creates a wall opening to accommodate the door.



To Change Symbol Libraries
Click the Symbol Library Menu button on the Symbol Library toolbar, then click a choice from the drop-down 

list box. The symbol library you select is activated and the symbol palette is placed on the Symbol Library toolbar.



To edit or create a report

1 On the Database menu, click Report, or click the Database Report button on the Standard toolbar. The 
Database Report dialog box appears.

2 Click the Reports page tab. 

3 Click Create to create a new report, or select a report and click Edit to edit an existing report. The Create 
Database Report or Edit Database Report dialog box appears.

4 Enter a title in the Report Title text box. This title appears in the Reports dialog box and at the top of printed 
reports.

5 (optional) Enter the text you want to appear in the report footer in the User Text text box.

6 Click a field from the Available Fields list box and click Add or Insert. Insert places the new field directly above 
the highlighted field while Add places the new field directly below.

7 (optional) Click a field from the Report Fields list box and click Delete to remove a field from the report.

8 In the Report Type section of the dialog box, click the Detail option button or the Summary option button.

9 (optional) In the Selection Criteria section of the dialog box, click Change to change the selection set for this 
report. The Selection Modifier window appears. For more information on the Selection Modifier, see Using the 
Selection Modifier.

10 Click OK. The Custom Report Column Configuration dialog box appears.

11 (optional) Enter new text in the Column Head cell for the field you want to change.

12 In the Editable column, check the check boxes for any fields you want to be able to directly edit in the report.

13 Click Close to exit the Custom Report Column Configuration dialog box.

14 Click Cancel to exit the Reports dialog box.



To view a report

1 Select the entities you want to include in the report, then click Report on the Database menu, or click the 
Database Report button on the Standard toolbar. The Database Report dialog box appears.

2 Click the Reports page tab. 

3 Click the report you want to view, then click Report to display the report. If no reports appear in the list, you 
must create a new report.

4  (optional) Click the Total button to total the columns of the report.

5  (optional) Click the Print button to print the report.

6  (optional) Click the Copy button to copy the report data to the Clipboard.

7 (optional) Click the Export button save the report data in a .CSV file.

8  (optional) Click the Sort button to change the order for the report fields. The Sort Entries dialog box appears 
(see the following procedure).

9 Click Close to exit the Reports dialog box.



To sort entries in a detail report or summary report

1 Use the preceding set of steps to create a report.

2  Click the Sort button. The Sort Entries dialog box appears.

3 Click a column from the Column drop-down list box on the Primary Key section of the Sort Entries dialog box. 
This specifies the main field to use in deciding the order in which to place items.

4 Click Ascending or Descending from the Order drop-down list box.

5 Click the data type for values in the column from the Type drop-down list box.

6 Repeat steps 3-5 on the Secondary Key side of the dialog box. In the event that there are identical 
occurrences of the Primary Key, this controls what order those symbols are listed in.

7 Click OK.

Tip
You can click a column heading to sort by a single column in ascending order, or click again to sort in 

descending order.



To draw a single dimension

1 On the Draw menu, click Dimension, Horizontal, Vertical, Rotated, or Aligned, or click the appropriate 
dimension button on the Wizard Tools toolbar.

2 From the Dimension Method drop-down list box on the edit bar, click Single.

3 Enter the initial offset on the edit bar and press ENTER. This is the distance from the dimension line to the 
closest dimension point on printed output. It applies to each single dimension you draw and can be changed at 
any time. 

4 Enter the first dimension point. A rubber-band dimension appears.

5 Enter the second dimension point to complete the dimension. Notice that where you place the second point 
determines the orientation of the dimension. You can reverse the orientation of the dimension by pressing 
CTRL as you enter the second dimension point.



To draw a series of chained dimensions

1 On the Draw menu, click Dimension, Horizontal, Vertical, Rotated, or Aligned, or click the appropriate 
dimension button on the Wizard Tools toolbar.

2 From the Dimension Method drop-down list box on the edit bar, click Chained.

3 Enter the initial offset on the edit bar. This is the distance from the dimension line to the closest dimension 
point on printed output. It applies to the first dimension only. Other dimensions in the chain are aligned with the 
first. For information on changing a linear dimension after it is drawn, see Changing Linear Dimensions with 
the Mouse.

4 Enter the first dimension point. A rubber-band dimension appears.

5 Enter the second dimension point to complete the first dimension. Notice that where you place the second 
point determines the orientation of the dimension. You can reverse the orientation of the dimension by pressing 
CTRL as you enter the second dimension point.

6 Enter the third dimension point, the fourth dimension point, and so on. Each dimension point after the first adds 
a dimension to the series.



Using the Office Layout Wizard

The Office Layout Wizard allows you to set up a drawing of a single office or an entire floor of offices. You can 
select the general shape and dimensions of the office shell, select from available database reports and dozens of 
layers and fields, coordinate your grid settings to match units in the office drawing, choose which toolbars you 
want to display, and so on.

Once the Office Layout Wizard has set up your drawing, you can add doors and windows, draw electrical or 
phone cabling, and even add furnishing or symbols from any of AutoSketch’s dozens of symbol libraries. For more 
information on placing symbols and selecting symbol libraries, see Symbols.

Walls are essentially polylines to which you assign a uniform width, create alcoves, hide or remove segments, and 
so on. For more information on drawing polylines, see Polylines, Polygons and Curves. For more information on 
editing polylines, see Trimming Entities and Reshaping Polylines, Polygons & Curves.

    Related Topics



To draw a wall

1 On the Draw menu, click Polyline, Single, or click the Single Polyline button on the Wizard Tools toolbar.

2 (optional) Change the settings on the edit bar for start width, end width, and bulge.

3 Click a startpoint. A rubber-band line appears from that point.

4 Enter one or more additional vertices. Each one continues from the endpoint of the previous segment and 
begins a new segment. If you make a mistake, press DELETE to remove vertices one at a time in reverse 
order.

5 Right-click to complete the polyline.



To draw a perpendicular wall

1 On the Draw menu, click Polyline, Perpendicular, or click the Perpendicular Polyline button on the Wizard 
Tools toolbar. The pointer changes to a drawing tool.

2 Click a line, arc, circle, polyline segment, or polygon segment. The segment appears highlighted and a rubber-
band line appears and follows the pointer at right angles to the segment.

3 Click an endpoint for the polyline. 

4 Right-click to stop drawing perpendicular polylines.



To draw a corner wall

1 On the Draw menu, click Polyline, Corner, or click the Corner Polyline button on the Wizard Tools toolbar. The 
pointer changes to a drawing tool.

2 Enter lengths in the Corner Length 1 and Corner Length 2 text boxes on the edit bar.

3 Click the line or poly-segment you want to be parallel to the first line. The segment appears highlighted.

4 Click the line or poly-segment you want to be parallel to the second line. The polyline appears, creating a 
rectangle from the original corner.



To move walls with the mouse

1 Select the wall to move.

2 (optional) Press and hold CTRL to move a copy of the selection set and leave the original behind.

3 Using the left mouse button, drag anywhere inside the selection handles to move the wall to another location.

OR

1 Select the wall to move then right-click and click edit vertices on the pop-up menu that appears.

2 Select a segment to move, then click the Move Segment button on the edit bar. A rubber-band wall appears 
and follows the pointer.

3 Reposition the wall, then click to place it.

4 Right-click to exit vertex editing mode.



To move an entire wall a distance and direction defined by two points

1 Select the wall to move.

2 On the Edit menu, click Transform, Translate, or click the Translate button on the All-In-One toolbar.

3 (optional) Check the Copy or Move check box on the edit bar to move a copy of the selection set and leave the 
original.

4 (optional) Check both the Copy or Move and Extrusion Polygon check boxes on the edit bar to extrude the 
selection set as you move.

5 Enter the “from” point. This is the starting point used to calculate the translation.

6 Enter the “to” point that defines the relative distance and direction to move the wall.



To delete walls

1 Select the wall, then right-click and click edit vertices on the pop-up menu that appears.

2 Select the segment of the wall you want to delete, then click the Hide Segment button on the edit bar. A check 
in this button means that the segment is hidden.

OR
Select the wall and press DELETE.

Note
There are many other ways to remove or hide portions of a wall polyline, for more information see .Trimming 

Entities.



To select and place plan doors or windows

1 Click the Symbol Library Menu button, then click Structural Elements, and click either Doors(plan) or 
Windows(plan) from the cascading menu. The symbol library you select is activated and the symbol palette is 
placed on the Symbol Library toolbar.

2 Click a door or a window from the Symbol Library toolbar. If you position the pointer over a symbol for a few 
moments, a ToolTip appears with the name of the symbol.

3 Click on the wall where you want to place one edge of the door or window. A rubber-band line appears, 
stretching from the hinge point of the door or window.

4 Position the pointer on one side or the other of the hinge point, and on one side or the other of the wall. This 
specifies the direction the door or window is to openthere are four possible combinations of left, right, inward, 
and outward.

5 Click to draw the door. AutoSketch automatically creates a wall opening to accommodate the door.



To Change Symbol Libraries
Click the Symbol Library Menu button on the Symbol Library toolbar, then click a choice from the drop-down 

list box. The symbol library you select is activated and the symbol palette is placed on the Symbol Library toolbar.



To edit or create a report

1 On the Database menu, click Report, or click the Database Report button on the Standard toolbar. The 
Database Report dialog box appears.

2 Click the Reports page tab. 

3 Click Create to create a new report, or select a report and click Edit to edit an existing report. The Create 
Database Report or Edit Database Report dialog box appears.

4 Enter a title in the Report Title text box. This title appears in the Reports dialog box and at the top of printed 
reports.

5 (optional) Enter the text you want to appear in the report footer in the User Text text box.

6 Click a field from the Available Fields list box and click Add or Insert. Insert places the new field directly above 
the highlighted field while Add places the new field directly below.

7 (optional) Click a field from the Report Fields list box and click Delete to remove a field from the report.

8 In the Report Type section of the dialog box, click the Detail option button or the Summary option button.

9 (optional) In the Selection Criteria section of the dialog box, click Change to change the selection set for this 
report. The Selection Modifier window appears. For more information on the Selection Modifier, see Using the 
Selection Modifier.

10 Click OK. The Custom Report Column Configuration dialog box appears.

11 (optional) Enter new text in the Column Head cell for the field you want to change.

12 In the Editable column, check the check boxes for any fields you want to be able to directly edit in the report.

13 Click Close to exit the Custom Report Column Configuration dialog box.

14 Click Cancel to exit the Reports dialog box.



To view a report

1 On the Database menu, click Report, or click the Database Report button on the Standard toolbar. The 
Database Report dialog box appears.

2 Click the Reports page tab. 

3 Click the report you want to view, then click Report to display the report. If no reports appear in the list, you 
must create a new report.

4  (optional) Click the Total button to total the columns of the report.

5  (optional) Click the Print button to print the report.

6  (optional) Click the Copy button to copy the report data to the Clipboard.

7 (optional) Click the Export button save the report data in a .CSV file.

8  (optional) Click the Sort button to change the order for the report fields. The Sort Entries dialog box appears 
(see the following procedure).

9 Click Close to exit the Reports dialog box.



To sort entries in a detail report or summary report

1 Use the preceding set of steps to create a report.

2  Click the Sort button. The Sort Entries dialog box appears.

3 Click a column from the Column drop-down list box on the Primary Key section of the Sort Entries dialog box. 
This specifies the main field to use in deciding the order in which to place items.

4 Click Ascending or Descending from the Order drop-down list box.

5 Click the data type for values in the column from the Type drop-down list box.

6 Repeat steps 3-5 on the Secondary Key side of the dialog box. In the event that there are identical 
occurrences of the Primary Key, this controls what order those symbols are listed in.

7 Click OK.

Tip
You can click a column heading to sort by a single column in ascending order, or click again to sort in 

descending order.



To draw a single dimension

1 On the Draw menu, click Dimension, Horizontal, Vertical, Rotated, or Aligned, or click the appropriate 
dimension button on the Wizard Tools toolbar.

2 From the Dimension Method drop-down list box on the edit bar, click Single.

3 Enter the initial offset on the edit bar and press ENTER. This is the distance from the dimension line to the 
closest dimension point on printed output. It applies to each single dimension you draw and can be changed at 
any time. 

4 Enter the first dimension point. A rubber-band dimension appears.

5 Enter the second dimension point to complete the dimension. Notice that where you place the second point 
determines the orientation of the dimension. You can reverse the orientation of the dimension by pressing 
CTRL as you enter the second dimension point.



To draw a series of chained dimensions

1 On the Draw menu, click Dimension, Horizontal, Vertical, Rotated, or Aligned, or click the appropriate 
dimension button on the Wizard Tools toolbar.

2 From the Dimension Method drop-down list box on the edit bar, click Chained.

3 Enter the initial offset on the edit bar. This is the distance from the dimension line to the closest dimension 
point on printed output. It applies to the first dimension only. Other dimensions in the chain are aligned with the 
first. For information on changing a linear dimension after it is drawn, see Changing Linear Dimensions with 
the Mouse.

4 Enter the first dimension point. A rubber-band dimension appears.

5 Enter the second dimension point to complete the first dimension. Notice that where you place the second 
point determines the orientation of the dimension. You can reverse the orientation of the dimension by pressing 
CTRL as you enter the second dimension point.

6 Enter the third dimension point, the fourth dimension point, and so on. Each dimension point after the first adds 
a dimension to the series.



To place panel symbols quickly and accurately

1 Click the Symbol Library Menu button, then click Modular Components, Panels, from the drop-down list box. 
The Panels symbol library is activated and the symbol palette is placed on the Symbol Library toolbar.

2 Click one of the panel symbols from the Symbol Library toolbar.

3 Type G to switch to Gridpoint snap mode, then click to place the panel in the drawing. Use PLUS and MINUS 
on the numeric keypad (or F5 and SHIFT+F5, respectively) to rotate the panels as you place them.

4 Right-click to stop drawing panels.

Note
If your panels are of a uniform size, it may help to change the grid snap interval to match the length of the 

panels. For more information on setting up the grid, see Using the Grid Edit Bar.



To place persons and associated AutoFields in your drawing 

1 Click the Symbol Library Menu button, then click People from the drop-down list box. The People symbol 
library is activated and the symbol palette is placed on the Symbol Library toolbar.

2 Click one of the single person buttons, then click to place the symbol in the drawing. The Edit Symbol Fields 
dialog box appears.

3 Enter values for each field in the appropriate Value text boxes, then click OK. The information you entered is 
stored with the other data about your drawing and can be accessed in reports.



Using the Work Bench Wizard

The Work Bench Wizard allows you to quickly set up a drawing of a small home project.

Below, is a list of topics that may be especially helpful in executing this kind of project:
Customizing the Grid
Trimming Entities
Creating Dimensions
Entering a Point from the Keyboard
Drawing Circles Based on Points
Changing Symbol Libraries
Duplicating Entities

    Related Topics



Changing Symbol Libraries
Click the Symbol Library Menu button on the Symbol Library toolbar, then click a choice from the drop-down 

list box. The symbol library you select is activated and the symbol palette is placed on the Symbol Library toolbar.



Using the Mechanical Part Wizard

The Mechanical Part Wizard allows you to quickly set up a mechanical drawing.

Below, is a list of topics that may be especially helpful in executing this kind of project:
Customizing the Grid
Trimming Entities
Creating Dimensions
Entering a Point from the Keyboard
Drawing Circles Based on Points
Changing Symbol Libraries
Duplicating Entities

    Related Topics



Using the Diagram Wizard

The Diagram Wizard helps you display information diagrams such as organizational trees, web site maps, flow 
diagrams, piping diagrams, and electrical schematics. Your diagrams can be custom made, or , for organizational 
trees or web site maps, created from information in a spreadsheet program.

Once the Diagram Wizard has set up your diagram, AutoSketch features tools that help you rearrange or add 
diagram components, insert symbols, or change the style of various entities in the diagram.
    Related Topics



Importing Diagram Information from a Spreadsheet Application

AutoSketch’s Diagram Wizard allows you import information from a spreadsheet application(.CSV) when creating 
a web site map or an organizational tree. The spreadsheet should be organized into four columns with a column 
each for row number, reports to row number, name, and description as shown below:

Note
If you are creating a site map the description column will contain a URL address instead of a description.



To change diagram text in the Text Editor

1 Double-click the text, or select it and right-click, then click Edit Text on the pop-up menu that appears. The Text 
Editor appears.

2 Make changes to the text, then click OK.



To change the color of a diagram component
Select the diagram component, then click a new color from the Pen Color drop-down list box on the property 

bar.



To move a diagram component or group of components

1 On the All-In-One toolbar, click the Marquee button. The pointer changes to a marquee selection tool.

2 Drag to define a rectangle around the diagram component or components you want to move.

3 On the Edit menu, click Transform, Stretch or click the Stretch button on the All-In-One toolbar.

4 Enter the startpoint of the stretch.

5 Enter the endpoint of the stretch. The portion of the diagram you selected moves and the connector line 
follows.

Note
To move the diagram component or group more precisely, type G to switch to Gridpoint snap mode at the 

beginning of step 5.



To select diagram components or text using the selection fence tool

1 On the Edit menu, click Select, Fence or click the Select Fence button on the Wizard Tools toolbar. 

2 Enter two or more vertices to define the polyline. A rubber-band line appears and follows the pointer. Press 
DELETE to remove the last vertex entered. 

3 Right-click to stop entering vertices. Any entities the polyline crosses are selected. 



To add an arrowhead to the endpoint of a connector line

1 Click Marker, Align to Endpoint on the Draw menu, or click the marker Align Endpoint button on the Wizard 
Tools toolbar.

2 From the Marker Types drop-down list box on the edit bar, select an arrowhead. Notice that a rubber-band 
marker appears as you move the pointer over connector lines in the diagram.

3 Place the insertion point in the Marker Size text box and enter a new size for the marker, then press ENTER.

4 When the rubber-band marker is positioned over the correct connector line, click to place it.

Note
When the marker appears in your diagram, it may be too large or too small. You can resize the marker by 

right-clicking it, clicking Entities on the pop-up menu that appears, then changing the marker size on the Marker page 
of the Edit Entities dialog box that appears..



To add diagram components, or component groups, to an organizational tree

1 Click the Organizational Tree button on the Wizard Tools toolbar, or click the Change Symbol Libraries button, 
then click Organizational Tree from the drop-down list. The Symbol Library toolbar changes to display the 
Organizational Tree library.

2 Click one of the diagram component symbols. A rubber-band component, or component group, appears and 
follows the pointer. 

3 Click to place it in the diagram.

4 Select the text in an existing diagram component, then press CTRL as you click and drag the text to the new 
diagram component. 

5 Release the mouse button. A copy of the original    text is placed in the new diagram component.

6 Double-click the text, or select it and right-click, then click Edit Text on the pop-up menu that appears. The Text 
Editor appears.

7 Make changes to the text, then click OK.

Note
To position the diagram component, component group, or diagram text precisely, use a snap mode such as 

Midpoint snap mode or Endpoint snap mode. For more information, see Entering & Modifying Points. You may also 
want to set the grid snap interval to make placement of the diagram components more uniform by using Gridpoint 
snap mode. For more information on setting up the grid, see Customizing the Grid.



To change a diagram component

1 On the Edit menu, click Select, Fence or click the Select Fence button on the Wizard Tools toolbar. 

2 Enter two or more vertices to draw the polyline so that it intersects one of the diagram components.

3 Right-click. The diagram component is selected.

4 Right-click inside the selection set, then select Entities on the pop-up menu that appears. The Edit Entities 
dialog box appears.

5 Click the Symbols page tab, then select a different diagram component type from the Name drop-down list.

6 Click OK. 



To insert a symbol in a connector line

1 On the Draw menu, click Symbol, Insert, or click the Insert Symbol button on the Wizard Tools toolbar. 

2 Click a symbol on the symbol library bar or select a symbol name from the drop-down list box on the edit bar.

3 (optional) Enter a custom opening width in the Opening Width text box on the edit bar and press ENTER. The 
default setting uses the width of the symbol extent.

4 Click a point on a connector line for the basepoint of the symbol.

5 Click a second point to establish the direction AutoSketch draws the symbol in relation to the first point 
entered. 



To insert a symbol in a piping diagram

1 On the Wizard tools toolbar, click the polyline button.

2 Type G to switch to Gridpoint snap mode, then click a startpoint and an endpoint for the polyline. Right-click to 
stop drawing pipes.

3 Click a symbol from the Symbol Library bar then click on the polyline.

4 Click the Trim Break button on the Wizard Tools toolbar.

5 Click the symbol you placed on the polyline. A break the width of the symbol appears in the polyline and a 
rubber-band line, the size of the trimmed segment, appears and follows the pointer.

6 Click anywhere in the drawing to clear the trimmed polyline.



Note on placing a person in the Organizational Tree Wizard
The arrows on the Structure page of the Diagram Wizard indicate which direction you can move a person 

when establishing the hierarchy. Some of the arrow keys may be grayed out when you are placing persons in the 
chart. You may have to move a person left or right before you can move them up or down in the structure.



To add text to a diagram component

1 Use the Selection Fence tool to select all of the text in an existing diagram component.

2 Right-click the about point, then click Move About Point on the pop-up menu that appears.

3 Type G to switch to Gridpoint snap mode, then click to place the about point at the gridpoint nearest the center.

4 Right-click the text entity, then click Rubber Stamp on the pop-up menu that appears.

5 Click to place as many copies of the text as you want. Right-click to stop rubber-stamping the text entity.

6 Double-click each text entity, or select it and right-click, then click Edit Text on the pop-up menu that appears. 
The Text Editor appears.

7 Make the appropriate changes to the text, then click OK.




