
Topics
The following Help Topics are available: 

Using the Oxford Talking Dictionary
Introduction
Looking Up a Word
Hearing a Pronunciation
Finding Synonyms and Antonyms (Using the Thesaurus)
About Alternate Spellings
Using Partial Word Find
Using Search in Entries
Returning to a Previous Word
Printing a Definition, Thesaurus Entry, Quotation, Picture or Map
Viewing a Picture or Map
Using the Abbreviation Guide
Using the Key to the Pronunciation
Using the Guide to the Dictionary and Guide to the Thesaurus
Using Mini View
Using the Program with Other Applications

Navigation Tools
The Full View
The Toolbar
The Menus
The List Box
Keyboard Shortcuts

Customizing the Program
Selecting a Source
Re-sizing the Full View Window and Its Components
Setting Text Size and Language Preferences
Linking Microsoft   Word   to the Dictionary  

Installing and Un-installing the Program
Installation Options
Changing the Installation Option after the Program Is Installed
Un-installing the Program

Copyrights
Notices

For information about using Help, press F1.



Introduction
The Oxford Talking Dictionary is a comprehensive electronic dictionary with all the features of its paper 
counterpart and more. This product combines a user-friendly interface with dictionary and thesaurus 
contents from Oxford University Press to create an outstanding reference tool. In addition to a wealth of 
definitions, etymologies, quotations and related words, this multimedia-rich resource also includes colour 
photographs, illustrations and maps, plus spoken pronunciations for thousands of words and variants. 
The dictionary contents are further supplemented with proper names, comprising more than 9,000 
biographical and geographical entries.

This edition of the Oxford Talking Dictionary has been developed with ease-of-use in mind. Among the 
features designed for effortless reference are:

· A Mini View mode that keeps a small dictionary window on-screen at all times while you use other 
programs, plus direct accessibility from Microsoft Word, version 6.0 or later

· A simple search feature that finds the word you want, even if you don't know how to spell it

· A convenient diskless installation option that puts the complete text contents of the dictionary at 
your disposal while leaving your CD drive free for other uses

· Two separate dictionary/thesaurus reference sets, allowing you the choice between 
comprehensive entries and concise entries

Whether you are a seasoned writer or a student, an experienced computer user or a novice, you will find 
that the Oxford Talking Dictionary is an indispensable electronic reference for work, school or home.



Looking Up a Word
Questions about the meaning, function and usage of a word make us reach for a dictionary. The Oxford 
Talking Dictionary provides this information right on your computer screen. There are many different ways 
to look up a word.

Typing a word:

Type a word into the entry box. As you type each letter, the list box automatically scrolls to display 
the words that begin with the letters you have entered. When you've finished typing your word, 
press Enter.

· If your word is recognised by the dictionary, its definition is displayed below the entry box.

· If the letters you typed have no matching entry in the dictionary, the program automatically 
searches for alternate spellings. See About Alternate Spellings for more details.

Tip: If the list box displays the word that you want before you have finished typing, simply 
double-click on the list box entry to view the definition.

Dragging and dropping a word from another application:

Be sure that the dictionary's Mini View or Full View window is visible. Highlight a word or phrase 
in another application, then click on your selection and drag it to the entry box in the dictionary 
window.

Note: Drag-and-drop capability is available in Windows 95 only. Windows 3.1 users, see 
"Copying and pasting a word from another application" below.

Copying and pasting a word from another application:

Highlight a word or phrase in another application, use the application's Copy option to copy the 
text, click on the Paste button on the toolbar in the dictionary window and press Enter.

Browsing the entry list:

Use the scroll bar on the list box to browse the list of entries. When you find a word you want 
defined, double-click on it.

Note: If the list box is not currently displaying All Entries, click on the Lists button and select All 
Entries from the drop-down menu. 

Cross-referencing from a definition or thesaurus entry:

While reading a definition or thesaurus entry, you may find a word you want defined. Simply 
double-click on the word in the definition or thesaurus entry.

Returning to a previous definition or thesaurus entry:

As you use the dictionary and thesaurus, the program keeps track of the 15 words you looked up 
most recently. To return to a previous definition or thesaurus entry, click on the small button with 
the down arrow at the end of the entry box and click on a word in the resulting drop-down list.

For more ways to find words and view their definitions, see Using Partial Word Find and Using Search in 
Entries.



Hearing a Pronunciation
Most of the dictionary entries and many of the thesaurus entries contain a Pronounce icon, which 
represents a sound recording of the word as it is pronounced in English. (The grey and black Pronounce 
icon shows a profile of a speaking person.) Some entries also include pronunciations of word variants.

To hear a word's pronunciation, click on the Pronounce icon in the text of the definition or thesaurus 
entry.

Oxford's English dictionaries describe the normative pronunciation of Standard English using the 
International Phonetic Alphabet. However, individual speakers will produce slight variations of certain 
sounds without changing the meaning of the word in which they occur. This is known as "free variation" 
and may be heard in the voice recordings.

Note: In addition to a Windows-compatible sound card with a WAV device, speakers or headphones 
must be connected to your computer in order to hear sound. See the documentation that came 
with your computer or speakers for details on how to properly connect your system to play 
sound.



Finding Synonyms and Antonyms
In addition to definitions, the Oxford Talking Dictionary includes thousands of thesaurus entries to help 
you find synonyms and antonyms. You can view thesaurus entries with the dictionary or alone, using the 
Thesaurus Only option.

Using the dictionary and thesaurus together:

If a thesaurus entry is available for a word you find in the dictionary, it is displayed automatically 
when you open the definition in Full View mode. Thesaurus entries appear in the thesaurus/media 
box, below the definition. 

If a dictionary entry has a related quotation, picture or map in addition to a thesaurus entry, click 
on the Thesaurus, Quotation*, Picture and Map buttons at the bottom of the Full View window 
to move between the available items.

Note: Because the components of the Full View window can be re-sized, the lower box may be 
reduced so that it is no longer visible. To see thesaurus entries, make sure the lower box is 
not hidden from view. See Re-sizing the Full View Window and Its Components for more 
details.

Using the Thesaurus Only option:

To use the thesaurus by itself, click on the Thesaurus Only On/Off button or select Thesaurus 
Only On/Off from the Book menu. When this option is selected, the definition box disappears 
and only thesaurus entries are displayed. Other program features, such as Partial Word Find, the 
Search function and the list box, refer only to the thesaurus when the Thesaurus Only option is 
on.

To return to the dictionary, click on the Thesaurus Only On/Off button again or open the Book 
menu and select Thesaurus Only On/Off.

Note: In Mini View mode, you can see either dictionary definitions or thesaurus entries; you cannot 
view both references together like you can in Full View. Click on the Thesaurus Only On/Off 
button to switch between definitions and thesaurus entries.

* The Quotation button is available only in the Full Reference set. See Selecting a Source for details.



About Alternate Spellings
You don't need to know exactly how a word is spelled to find it in the Oxford Talking Dictionary. Whenever 
you enter a word that is not recognised by the dictionary, the program automatically searches for words 
that have spellings similar to the word you entered. The results of the Alternate Spellings search are 
displayed in the list box on the right side of the Full View window. Double-click on an entry in the list box 
to see its definition.

Note: If you are using the program in Mini View mode, the Alternate Spelling search results appear in 
a separate window. To see the entry for a word found by this search, double-click on the word 
in the Alternate Spellings Found window.

Tip: If the search results do not contain the word you want, try the Partial Word Find feature to 
search the dictionary using wild card characters in place of letters that you don't know.



Using Partial Word Find
Whenever you want to find words that contain specific letters, such as a certain prefix, root or suffix, use 
the Partial Word Find feature. This feature is also useful when you don't know enough letters in a word for 
the Alternate Spellings search to find what you want. Using wild card characters in your search may 
provide enough information for the program to find the word you need.

To find words using partial information:

1. Click on the Partial Word Find button on the toolbar, or open the Tools menu and select 
Partial Word Find, to open the Partial Word Find window.

2. Type 3 or more characters into the Part of word to find box.

3. Press Enter or click on OK.

Double-click on a word in the list that appears in the list box to see its definition or thesaurus 
entry.

Example:

Let's say you want to find the word that describes the fear of spiders, and you already know that 
the word you want ends in "phobia". Type phobia into the Part of word to find box, and press 
Enter. In the list of words found to contain the partial word "phobia", you will see the word you 
want -- "arachnophobia". 

To perform a search using wild card characters:

1. Click on the Partial Word Find button on the toolbar or select Partial Word Find from the 
Tools menu to open the Partial Word Find window.

2. Type 3 or more characters into the Part of word to find box, replacing unknown letters with 
one of these wild card characters:

To Find: Use:

Any single letter ?

Any number of letters, including none *

3. Press Enter or click on OK.

Double-click on a word in the list that appears in the list box to see its definition or thesaurus 
entry.

Example:

Let's say you want to use the word "onomatopoeia", but you aren't sure how to pronounce the 
entire word, let alone spell it. You aren't sure if the word begins with "o-n-o" or "o-n-a", and the 
last three syllables have you stumped altogether. Your attempts to find the word via the entry box 
have resulted in unsuccessful Alternate Spellings searches. Using wild card characters to 
represent the letters you don't know may provide sufficient information to the Partial Word Find 
feature to find the word.

In this example, use a ? to represent the one unknown character at the beginning of the word 
("ono..."/"ona...") and a * to represent the undetermined number of characters at the end.



Type on?ma* in the Part of word to find box and press Enter. The resulting list contains 
"onomatopoeia".



Using Search in Entries
The Search in Entries feature lets you search the complete dictionary and thesaurus contents to find 
words in the text of definitions, thesaurus entries and quotations. You can also use wild card characters in 
your searches.

To search the text of definitions, thesaurus entries and quotations:

1. Click on the Search in Entries button or select Search in Entries from the Tools menu to 
open the Search window.

2. Type a word in the Look For box.

3. Type any additional search words in the text boxes below and select AND,     OR   or   NOT   to 
define the relationship between your search terms. 

4. Click in one or more check boxes in the Look In section to de-select or select the types of 
entries you want to search.* 

5. Press Enter or click on OK. 

Double-click on a word in the resulting list to see its definition, its thesaurus entry or a related 
quotation. The items toward the top of the list are most likely to contain the information you want.

Example using one search word:

Let's say you want a noun that describes an impractical person. Your search for "impractical" in 
the thesaurus yields no appropriate nouns. Using the Search feature, you can search the 
complete text of the dictionary to find words whose definitions contain the word "impractical". 
Among these you may find a noun that suits your purpose.

Type impractical in the Look For box, make sure the Dictionary option in the Look In section is 
selected, and press Enter. The resulting list contains suitable nouns such as "idealist" and 
"luftmensch".

Example using more than one search word:

Let's say you want to find a list of plants that have pink flowers.

Type pink into the Look For box, choose AND as the operator, type flower into the adjacent text 
box, and press Enter. The resulting list contains words whose definitions include the words "pink" 
and "flower".

For other examples using more than one search word, see About Search Operators.

To perform a wild card search:

1. Click on the Search in Entries button or select Search in Entries from the Tools menu to 
open the Search window.

2. Type a word in the Look For box, replacing unknown letters with one of the wild card 
characters listed below.

To Find: Use:

Any single letter ?

Any number of letters, including none *



3. Type any additional search words in the text boxes below and select AND,     OR   or   NOT   to 
define the relationship between your search terms. Use wild card characters to represent any 
unknown letters.

4. Press Enter or click on OK.

Double-click on a word in the resulting list to see its definition or thesaurus entry.

Example:

Let's say you want to find kinds of antelopes that inhabit Africa but you can't remember whether 
"antelope" is spelled "a-n-t-e" or "a-n-t-a".

Type Africa into the Look For box, choose AND as the operator, type ant?lope into the adjacent 
text box, and press Enter. The resulting list contains animals whose definitions contain both 
"Africa" and "antelope".

* The Look In box is not available in the Thesaurus Only mode; searches are limited to thesaurus entries only. If 
you're in Thesaurus Only mode and you want to search the dictionary and/or quotations, click on the Thesaurus 
Only On/Off button or select Thesaurus Only On/Off from the Book    menu to de-activate the Thesaurus Only 
feature. For more information about Thesaurus Only, see Finding Synonyms and Antonyms.

Quotations can be searched only in the Full Reference set. See Selecting a Source for details.



Returning to a Previous Word
As you use the dictionary and thesaurus, the program keeps track of the 15 words you looked up most 
recently.

To see a list of these previous words, click on the small button with the down arrow at the end of the entry 
box. To return to a previous definition or thesaurus entry, click on a word in the resulting drop-down list.



Using Mini View 
The Mini View mode reduces the size of the dictionary window to provide an unobtrusive reference tool 
that is always available while you use your word processor or other text-based application.

To change to Mini View mode, click on the Mini View/Full View button on the toolbar or open the View 
menu and select Mini View/Full View. The Full View window changes to the Mini View, which displays 
the entry box, the current definition (or thesaurus entry when in Thesaurus Only mode) and a simplified 
toolbar.

The Mini View window can be reduced further so that it occupies even less space on your screen. To 
reduce the Mini View window to its smallest size while still keeping it on-screen, click on the Windows 
Restore button on the title bar or select Restore from the Windows menu.

When the Mini View window is at its smallest, the definition or thesaurus entry is hidden. Whenever you 
look up a word, the window is enlarged automatically to display the new definition or thesaurus entry. If 
you have reduced the Mini View window to its smallest size, and you want to see the current definition or 
thesaurus entry again, click on the Windows Restore button again or select Restore from the Windows 
menu.

To look up a word in Mini View, do one of the following:

· Type a word in the Mini View window's entry box and press Enter.

· Highlight a word in another application, then drag and drop it into the Mini View window's 
entry box (Windows 95 users only).

· Copy a word in another application, paste it into the Mini View window's entry box, and 
press Enter.

· Double-click on a word within a definition or thesaurus entry in the Mini View window.

The definition or thesaurus entry for your word appears automatically. If you enter a word that is not 
defined in the dictionary or doesn't appear in the thesaurus, the program automatically searches for 
alternate spellings. 

Mini View's streamlined design offers access to only the dictionary or the thesaurus contents at any one 
time. To switch between the dictionary and thesaurus, click on the Thesaurus Only On/Off button. 

Quotations, pictures and maps are not available in Mini View mode. To view quotations, pictures and 
maps, click on the Mini View/Full View button to return to the Full View.

In addition to the Thesaurus Only On/Off and Mini View/Full View buttons, Mini View's simplified 
toolbar offers two other buttons: Copy and Paste. To access other program features, such as Partial 
Word Find and Search, click on the Mini View/Full View button to return to the Full View.

The Mini View window is automatically configured to remain on top of other applications so that it is 
accessible at all times. To change the "Always on Top" setting, open the Windows system menu at the left 
end of the title bar and click on Always on Top to de-select it. When this setting is de-selected (no check 
mark), the program window only appears when called. Use the application button on the Windows taskbar 
or press Alt+Tab to call the window to the front.



Printing a Definition, Thesaurus Entry, Quotation, Picture or Map
Any definition, thesaurus entry, quotation*, picture or map currently on the screen can be printed. Simply 
click on the Print button or open the File menu and select Print. To print a picture displayed in the pop-up 
image window, click the right mouse button and select Print Image from the drop-down menu.

If the program window shows two different items, such as a definition and a picture, a Print Selection box 
appears when you click on Print, allowing you to select which item to print. Select an item and click on 
OK.

To print an item that is not currently displayed, find its entry in the list box and double-click on it to display 
it. (Use the Thesaurus, Quotation, Picture and Map buttons at the bottom of the window, if necessary.) 
Then click on the Print button or open the File menu and select Print.

* Quotations are available only in the Full Reference set. See Selecting a Source for details.



Viewing a Picture or Map
Pictures and maps can be accessed in two ways: directly or from a related definition.

To open a picture or map directly:

1. Click on the Lists button and select Pictures and Maps from the drop-down menu.

2. Scroll through the contents of the list box to find a picture or map to view.

3. Double-click on the item you want to see.

To view a picture or map from a related definition:

Whenever you open a definition that has an associated thesaurus entry, quotation*, picture and/or 
map, one of these items appears automatically in the thesaurus/media box. When viewing a 
definition that is linked to more than one item, use the Thesaurus, Quotation, Picture and Map 
buttons at the bottom of the window to switch between the items. (If the text on the button is 
dimmed, no media of that type is linked to the current definition.)

Many pictures and maps are larger than the thesaurus/media box. To see more of the item, you can either 
open a separate pop-up window, re-size the application window, move the item within the 
thesaurus/media box or re-size the image itself.

To change your view of a picture or map, do one or more of the following:

· Click the right mouse button on the picture or map and select Pop-up Image from the drop-
down menu. (This option displays a larger image in a separate pop-up window.)

· Re-size the Full View window or the thesaurus/media box to expand your view. (See Re-
sizing the Full View Window and Its Components for details.)

· Click on the picture or map and drag the mouse to move it within the box.

· Click the right mouse button on the picture or map and select Size Image from the drop-
down menu. (This option switches between the actual picture size and a size that fits into 
the thesaurus/media box.)

* Quotations are available only in the Full Reference set. See Selecting a Source for details.



Using the Abbreviation Guide
The Abbreviation Guide is a detailed list of the abbreviations used in the definition text. Here you will find 
abbreviations for many kinds of information found in definitions, such as parts of speech, countries and 
languages, books of the Bible, Shakespearean works and branches of knowledge.

To access the Abbreviation Guide, do one of the following:

· Click on the Abbreviation Guide button on the toolbar.

· Open the Help menu and select Abbreviation Guide.

To close the Abbreviation Guide, click on the Return to Dictionary button.



Using the Key to the Pronunciation
The Key to the Pronunciation provides information on the symbols used in the pronunciation 
transcriptions in the definitions and thesaurus entries. The guide lists each symbol along with a word that 
illustrates how the symbol is pronounced. The letters in the example word that correspond in sound to the 
symbol are shown in boldface. Click on the Pronounce icons to hear the sounds or example words. 

To access the Key to the Pronunciation, do one of the following:

· Click on a pronunciation transcription within the definition text. 

· Click on the Key to the Pronunciation button on the toolbar. 

· Open the Help menu and select Key to the Pronunciation. 

To close the Key to the Pronunciation, click on the Return to Dictionary button.



Using the Guide to the Dictionary and Guide to the Thesaurus
The Guide to the Dictionary and the Guide to the Thesaurus provide information on the kinds of entries 
found in the dictionary and thesaurus and the features found within the entry text. Here you will also find a 
detailed explanation of the conventions used in the entries. 

To access the guides:

Open the Help menu and select Guide to the Dictionary or Guide to the Thesaurus.

To close the Guide to the Dictionary, click on the Return to Dictionary button.



The Full View
The program's main window, which is displayed in Full View mode, contains the menus, toolbar, entry 
box, list box, definition box and thesaurus/media box.

Note: When you open the Oxford Talking Dictionary from within Microsoft Word, version 6.0 or later, 
the program opens to the smaller Mini View window.

The menus and toolbar provide access to the program's functions and commands. The most commonly 
used features can be activated in any one of three ways: by clicking on a button on the toolbar, selecting 
an option from a menu or using a keyboard shortcut.

The entry box, directly below the toolbar, on the left, is where you can type, paste or "drag and drop" a 
word you want to look up -- even if you're not sure of its spelling. If the word you enter is recognised by 
the program, its definition appears in the definition box below. (If the Thesaurus Only option is on, a 
thesaurus entry appears.) If the word is not recognised by the program, a list of alternate spellings 
appears in the list box on the right side of the window. For more information about using the entry box, 
see Looking Up a Word.

As you use the dictionary and thesaurus, the program keeps track of the 15 words you most recently 
looked up. To see a list of these previous words, click on the small button with the down arrow at the end 
of the entry box. To return to a previous definition or thesaurus entry, simply click on a word in the 
resulting drop-down list.

The definition box contains the definition text for the word you have looked up. The definition text usually 
includes the word's pronunciation, part of speech, meanings and other details. For more information 
about this feature, see Definition Box.

To enlarge the definition box so you can view dictionary entries only, without thesaurus entries, 
quotations, pictures or maps, choose Expand Definition Box from the Book menu. The definition box 
will be enlarged to hide the thesaurus/media box completely. Select the same menu item to see the 
thesaurus/media box again.

The thesaurus/media box displays thesaurus entries, quotations*, pictures and maps. Whenever you 
open a definition that has an associated thesaurus entry, quotation, picture and/or map, one of these 
items appears automatically in the thesaurus/media box. Click on the Thesaurus, Quotation, Picture 
and Map buttons below the thesaurus/media box to switch between the available items. (If a button's text 
is dimmed, no item of that type is available.)

To enlarge the thesaurus/media box so you can view and search thesaurus entries only, without 
definitions, quotations, pictures or maps, choose Thesaurus Only On/Off from the Book menu or click 
on the Thesaurus Only On/Off button. Choose the same menu item or click on the same button to see 
definitions, quotations, pictures and maps again.

The list box, which appears on the right side of the Full View window, displays a list of available entries. 
Double-click on an item in the list to display it. Click on the Lists button to select a list to display. For more 
information about this feature, see List Box.

The Full View window and its components can be re-sized. See Re-sizing the Full View Window and Its 
Components for details.

* Quotations are available only in the Full Reference set. See Selecting a Source for details.



The Definition Box
The definition box displays the complete dictionary entry for the word you have selected.

Most of the contents of the definition box are interactive: 

· Click on the Pronounce icon, found in most definitions, to hear the word's pronunciation.

· Double-click on any word in the text to see that word's definition and/or thesaurus entry.

· Click on the pronunciation transcription to open the Key to the Pronunciation.

To see the explanation for an abbreviation used in a definition, click on the Abbreviation Guide button.

To view only dictionary entries (no thesaurus entries, quotations, pictures or maps), choose Expand 
Definition Box from the Book  menu to hide the thesaurus/media box completely. Select the same menu 
item to show the thesaurus/media box again.

In the Full View window, the definition box can be re-sized. See Re-sizing the Full View Window and Its 
Components  for details.



The Thesaurus/Media Box
The thesaurus/media box displays thesaurus entries, quotations*, pictures and maps, when available.

Use the Thesaurus, Quotation, Picture and Map buttons below the thesaurus/media box to switch 
between the available items. (If a button's text is dimmed, no item of that type is available.)

When the Thesaurus Only option is on, the thesaurus/media box fills the dictionary window and displays 
only thesaurus entries. To see definitions, quotations, pictures and maps, click on the Thesaurus Only 
On/Off button to turn the option off.

When a picture or map is displayed, click the right mouse button within the thesaurus/media box to 
access a pop-up menu with these options: Copy Image, Print Image and Size Image. Use Copy Image 
to copy the picture or map to the Windows clipboard. Use Print Image to print the picture or map. Use 
Size Image to switch between the image's actual size and the size that best fits into the thesaurus/media 
box. Use Pop-up Image to display the image in a separate, larger pop-up window.

To hide the thesaurus/media box completely, choose Expand Definition Box from the View menu. Select 
the same menu item to show the thesaurus/media box again.

In the Full View window, the thesaurus/media box can be re-sized. See Re-sizing the Full View Window 
and Its Components  for details.

* Quotations are available only in the Full Reference set. See Selecting a Source for details.



The List Box
The list box displays a list of available words, pictures and maps, or various search results. Use the scroll 
bar to scroll through the list. Double-click on an item to display it.

Every entry in the list box is preceded by an icon that identifies its type. The icons are:

D indicates a dictionary entry

T indicates a thesaurus entry

Q indicates a quotation (available in the Full Reference set only)

P indicates a proper name entry (biographical or geographical entry)

To view a different list, click on the Lists button and click on a selection on the drop-down menu.

· The All Entries list contains all the words defined in the dictionary. When the Thesaurus Only 
option is on, All Entries lists all thesaurus entries. 

· The Alternate Spellings list displays the results of the program's search for alternate spellings 
when you have entered a word that is not recognised by the dictionary or that does not have a 
thesaurus entry. Switching to the Alternate Spellings list displays the results of the latest search 
only; results of previous searches are replaced whenever a new search is performed.

· The Partial Word Results list displays the words found when you use the Partial Word Find 
feature to find words that contain specific letters. Switching to the Partial Word Results list 
displays the results of the latest search only; results of previous searches are replaced whenever 
a new search is performed.

· The Pictures and Maps list contains a complete list of the words that are linked to pictures or 
maps. The Pictures and Maps list is always available, except when the program is in Thesaurus 
Only mode or running without the CD.

· The Search Results list displays the words found when you use the Search in Entries feature to 
find words within the definition or thesaurus entry text. Switching to the Search Results list 
displays the results of the latest search only; results of previous searches are replaced whenever 
a new search is performed.

The lists counter box, which appears below the list box, displays the number of items available in the 
current list.

In the Full View window, the list box can be re-sized. See Re-sizing the Full View Window and Its 
Components  for details.



The Toolbar
The toolbar contains the buttons that provide quick access to the program's most frequently used 
features.

· Clicking on the Mini View/Full View button displays the program in the smaller Mini View mode 
so you can maintain easy access to the dictionary while using other applications. Click on the 
Mini View/Full View button again to return to Full View, the program's main window. For more 
information about this feature, see Using Mini View.

· Clicking on the Thesaurus Only On/Off button hides the definition box and shows thesaurus 
entries only. Click the Thesaurus Only On/Off button again to turn the option off and restore 
access to definitions, quotations, pictures and maps. For more about the Thesaurus Only option, 
see Finding Synonyms and Antonyms.

· Clicking on the Search in Entries button allows you to search the contents of the definitions, 
thesaurus entries and quotations. For more about this feature, see Using Search in Entries.

· Clicking on the Partial Word Find button finds words that contain the letters you type and allows 
the use of wild card characters in search words. For more information about this feature, see 
Using Partial Word Find.

· Clicking on the Copy button copies the text you have highlighted to the Windows clipboard.

· Clicking on the Paste button pastes the contents of the Windows clipboard into the entry box.

· Clicking on the Print button prints the displayed item. For more information about printing, see 
Printing a Definition, Thesaurus Entry, Quotation, Picture or Map.

· Clicking on the Abbreviation Guide button opens a guide to the abbreviations used in the 
definition text. For more about this feature, see Using the Abbreviation Guide.

· Clicking on the Key to the Pronunciation button opens a guide to the symbols used in the 
pronunciation transcription in the definitions and thesaurus entries. For more information about 
this feature, see Using the Key to the Pronunciation.

· Clicking on the Help button provides quick access to information on the program's features. Click 
on the Help button, then click on a button or other feature for which you want help.



The Menus
The menus provide access to the program's features.

· Use the File menu to print an item or to exit the program.

· Use the Edit menu to copy or paste text.

· Use the View menu to switch between the Mini View and Full View modes, change the size of the 
display text and select a language for the user interface. For more information about these 
features, see Using Mini View, The Full View and Setting Text Size and Language Preferences.

· Use the Book menu to switch between the two reference sources, change the size of the 
definition box and change to and from the Thesaurus Only mode. For more information about 
these features, see Selecting a Source, The Full View and Finding Synonyms and Antonyms.

· Use the Tools menu to access the Search and Partial Word Find features. For more information 
about these features, see Using Search in Entries and Using Partial Word Find.

· Use the Help menu to access the Help Topics, the Abbreviation Guide, the Key to the 
Pronunciation, the Guide to the Dictionary and the Guide to the Thesaurus. For more information 
about the Abbreviation and Key to the Pronunciations and the Guide to the Dictionary, see Using 
the Abbreviation Guide, Using the Key to the Pronunciation and Using the Guide to the Dictionary 
and Guide to the Thesaurus.



Re-sizing the Full View Window and Its Components
The program's Full View window and the boxes within it can be enlarged or reduced to suit your viewing 
preference.

To re-size the Full View window, do one of the following:

· Move the cursor to an edge or corner of the program window until it turns into a double-
headed arrow. Then click and drag in the direction you want. When the window is the size 
you want, release the mouse button.

· Click on the Windows Restore button on the title bar or select Restore from the Windows 
menu.

To re-size the boxes within the Full View window, do one or more of the 
following:

· Choose Expand Definition Box from the Book menu.

· Move the cursor to the space between the list box and the definition and thesaurus/media 
boxes until the cursor turns into a double-headed arrow. Then click and drag left or right. 
When the boxes are the size you want, release the mouse button.

· Move the cursor to the space between the definition box and thesaurus/media box until the 
cursor turns into a double-headed arrow. Then click and drag up or down. When the boxes 
are the size you want, release the mouse button.

Note: In the Full View mode, the definition box is configured to remain on-screen at all 
times (except when the Thesaurus Only option is on and the definition box is hidden 
completely by the thesaurus box). In the Full View mode, with the Thesaurus Only 
option off, the definition box cannot be reduced beyond a minimum size.



Setting Text Size and Language Preferences
The Oxford Talking Dictionary can be customised in two ways:

· You can change the size of the text that is displayed in the definition and thesaurus/media boxes.

· You can change the language of the user interface (the text that appears on-screen).

To change the text size, open the View menu, point to Font Size (Windows 3.1 users, click on Font 
Size), then click on Small, Medium or Large.

To change the language of the user interface, open the View menu, point to Interface Language 
(Windows 3.1 users, click on Interface Language), and click on the language you prefer. 

Note: The Interface Language option affects only the text displayed in the menus, tool tips and 
program windows. The program contents (definitions, thesaurus entries, quotations, maps) 
and Help information are available in English only.



Using the Program with Other Applications
The Oxford Talking Dictionary has been designed for quick and easy access from any word processor 
and other text-based applications and specially designed for direct access from newer versions of 
Microsoft Word.

If you have Microsoft Word, version 6.0 or later, you can choose to install an Oxford Talking Dictionary 
icon and menu item in Word. With the icon and menu item in place, simply click on the icon or select The 
Oxford Talking Dictionary from the Tools menu to open the dictionary. For details, see Linking Microsoft 
Word   to the   Oxford Talking Dictionary  .

To open the dictionary while using an older version of Word or another application, select the dictionary 
from the Start menu (Windows 95 users) or the Program Manager (Windows 3.1 users).

The dictionary's Mini View mode is specifically designed for use with word processors and text-based 
programs. Mini View keeps a small window on top of other applications so you have access to the 
dictionary and thesaurus at all times. For more information about this feature, see Using Mini View.



Linking Microsoft Word to the Dictionary
If you have Microsoft Word, version 6.0 or later, the Oxford Talking Dictionary can install a button directly 
onto Word's toolbar and a menu item on Word's Tools menu so you can open the dictionary directly from 
Word whenever you need it.

To link Microsoft Word to the Dictionary:

After installing the Oxford Talking Dictionary onto your system, you are asked whether you want 
to install a button or a menu item on the Word toolbar to create a direct link from Word to the 
dictionary program. Click on Yes to install the button or menu item. To open the dictionary from 
within Word, simply click on the button or open the Tools menu and select The Oxford Talking 
Dictionary.

If the Oxford Talking Dictionary button does not appear on the Word toolbar, you may create it by 
right-clicking any unused area of the toolbar and placing a check next to The Oxford Talking 
Dictionary.

Note: If you choose not to install the button and menu item, or if you install Microsoft Office or Word 
after installing the Oxford Talking Dictionary and you decide later that you want the direct link 
from Word to the dictionary, you must re-install the dictionary program.

To re-install the program so you can link it with Word:

1. Make sure the Oxford Talking Dictionary CD is in the CD-ROM drive.

2. Windows 95 users: Click on the Windows Start button to open the Start menu and choose 
Run.

Windows 3.1 users: Open the Program Manager's File menu and choose Run.

3. Type D:\SETUP.EXE (or substitute for D the letter of the CD-ROM drive you are using) in the 
Command Line box. Then press Enter or click on OK.

4. When the window titled "Previous Install Detected" appears, make sure the Re-install option is 
selected, and click on Next.

5. Follow the on-screen instructions to complete the re-installation process.

6. Once the installation is complete, open the Oxford Talking Dictionary. When asked if you want 
to install a button and menu item in Word, click on Yes.



Keyboard Shortcuts
For users who prefer the keyboard to the mouse, most of the program's features and functions can be 
accessed or activated via keyboard shortcuts. (For shortcuts that use two keys, be sure to press both 
keys simultaneously.)

To     Press

Display a related map
(if available)

CTRL + A

Copy highlighted text to the clipboard CTRL + C

Display the list of pictures and maps CTRL + E

Activate the Partial Word Find feature CTRL + F

Pronounce the current word CTRL + H

Display a related picture
(if available)

CTRL + I

Display the next list in sequence CTRL + L

Switch between Mini View and Full View CTRL + M

Print CTRL + P

Activate the Search in Entries feature CTRL + S

Switch to or from Thesaurus Only mode CTRL + T

Enlarge or reduce the definition box CTRL + U

Paste the contents of the clipboard into 
the entry box

CTRL + V

Open the list selection box ALT + L

Return to the previous word ALT + [left arrow]

Move forward in your research history ALT + [right arrow]

Open the Help index F1

Open the Abbreviation Guide F3

Open the Key to the Pronunciation F5

Open the Guide to the Dictionary F7

Open the Guide to the Thesaurus F9

Installation Options



During the installation process, the Oxford Talking Dictionary offers three installation options: 

Typical

The Typical configuration allows you to run the program at optimum speed. This option copies the 
program's executable and configuration files to your hard disk, requiring a little over 8 MB of disk space.

Minimal

The Minimal configuration allows you to run the program while using the least amount of hard disk space 
(99K). Please note that this option may result in sluggish performance.

Diskless

The Diskless configuration copies the textual contents of both the Full and Quick Reference sets onto 
your hard disk, requiring approximately 102 MB of hard disk space. This option allows you to use the 
program in either of the following ways:

· When you want to keep your CD-ROM drive free for other uses, or when you want to access only 
definitions and thesaurus entries, run the program without the CD in the CD-ROM drive.

· When you want to hear pronunciations and view pictures and maps, in addition to accessing 
definitions and thesaurus entries, insert the CD into your CD-ROM drive before loading the 
program.

To change the current configuration, see Changing the Installation Option after the Program Has Been 
Installed.



Changing the Installation Option after the Program Has Been Installed
Note: Be sure to exit the Oxford Talking Dictionary before re-installing it!

If you need the following instructions to complete this process, select Print Topic from the 
File menu in this Help window. Then exit Help, exit the Oxford Talking Dictionary, and 
proceed with the instructions on the printout.

To re-install the program using a different installation option: 

1. Make sure the Oxford Talking Dictionary CD is in the CD-ROM drive.

2. Windows 95 users: Click on the Windows Start button to open the Start menu and choose 
Run.

Windows 3.1 users: Open the Program Manager's File menu and choose Run.

3. Type D:\SETUP.EXE (or substitute for D the letter of the CD-ROM drive you are using) in the 
Command Line box. Then press Enter.

4. When the window titled "Previous Install Detected" appears, make sure the Re-install option is 
selected and click on Next.

5. Follow the on-screen instructions to complete the re-installation process.



Un-installing the Program
Note: Be sure to exit the Oxford Talking Dictionary before un-installing it!

If you need the following instructions to complete this process, select Print Topic from the File 
menu in this Help window. Then exit Help, exit the Oxford Talking Dictionary and proceed with 
the instructions on the printout.

To remove the Oxford Talking Dictionary from your computer:

Windows 95 Users:

1. Click on the Windows Start button to open the Start menu.

2. Point to Settings and click on Control Panel.

3. In the Control Panel window, double-click on Add/Remove Programs.

4. Select Oxford Talking Dictionary from the list and click on the Add/Remove button.

5. Follow the on-screen instructions to complete the removal process.

Windows 3.1 Users:

1. Make sure the Oxford Talking Dictionary CD is in the CD-ROM drive.

2. Open the Oxford program group.

3. Double-click on the Uninstall OTD icon.

4. Follow the on-screen instructions.



About Search Operators
Search operators are short, everyday words that define the relationship between two search words. 
Below are step-by-step instructions on how to use operators in two- and three-word searches and a 
description of each operator:

To perform a search with two or three words: 

1. Click on the Search in Entries button or select Search in Entries from the Tools menu to 
open the Search window.

2. Type the first word in the Look For box.

3. At the next text box, select an operator by clicking on the down arrow and choosing AND, OR 
or NOT from the drop-down menu. Then type another search word in the adjacent text box.

To include a third word in your search, repeat this step in the next text box.

4. Click in the check boxes in the Look In section of the search window to select the types of 
entries you want to search. (If you are searching in Thesaurus Only mode, disregard this step; 
the Look In section is not available in Thesaurus Only mode.)

5. Press Enter or click on OK.

AND

If your search words make up a phrase, you should probably use AND.

Use AND when you want to find entries that contain both words connected by this operator. For example, 
if you want to find entries about flightless birds, you would type flightless into the Look For box, choose 
AND as the operator and type bird into the adjacent text box. The search results would include only 
entries that contain both "flightless" and "bird".

OR

If your search words are synonyms, you should probably use OR.

Use OR when you want to find entries that contain either word connected by this operator. For example, if 
you want to find entries about tornadoes or cyclones, you would type tornado into the Look For box, 
choose OR as the operator and type cyclone into the adjacent text box. The search results would include 
entries that contain the word "tornado", entries that contain "cyclone" and entries that contain both words.

NOT

If you want to exclude a specific topic from your search, you should use NOT.

Use NOT when you want to find entries that contain the first word in your search and then exclude any of 
those entries that contain the second word in your search. For example, if you want to find entries about 
dramatists who were not English, you would type dramatist into the Look For box, choose NOT as the 
operator and type English into the adjacent text box. The search results would include entries that 
contain the word "dramatist" but no entries that contain the word "English".

Three-word examples:

To find entries related to Holy Roman emperors, you would enter holy AND roman AND emperor.

To find entries related to percussion instruments, excluding instruments that consist of or include bells, 
you would enter percussion AND instrument NOT bell.



To find entries related to reindeer, moose or elk, you would enter reindeer OR moose OR elk.



Selecting a Source
The Oxford Talking Dictionary includes two separate dictionary/thesaurus reference sets, the Full 
Reference and the Quick Reference. The name of the current source appears in the title bar above the 
definition box (or the thesaurus box in Thesaurus Only mode). When you first use the program, the Full 
Reference set is selected; it remains selected until you change the Source setting.

The Full Reference contains comprehensive entries with details such as etymology and the earliest 
recorded use of the word. In the Full Reference dictionary, the senses of the word are presented in 
chronological order, with the oldest sense first. In addition to definitions and thesaurus entries, the Full 
Reference set offers related quotations for many words, and more than 9,000 proper names, including 
biographical and geographical entries.

The Quick Reference contains concise entries that are suitable for casual and younger users. The 
senses of the words in the Quick Reference set are listed in order of familiarity and importance, with the 
most current and important senses first. In addition to definitions and thesaurus entries, the Quick 
Reference offers more than 9,000 proper names, including biographical and geographical entries.

To change the source:

Open the Book menu, point to Source (Windows 3.1 users, click on Source), then click on the 
source you want.
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Running the Program without the CD
Running the program without the CD in the CD-ROM drive allows you to access only definitions, 
thesaurus entries and quotations. To hear pronunciations and view pictures and maps, the CD must be in 
your computer's CD-ROM drive. Your options are:

Insert the CD-ROM and run the program.

This option allows you to insert the CD into the CD-ROM drive before the program continues loading so 
you can access the complete contents of the dictionary -- text, sounds, pictures and maps.

Run the program without the CD-ROM.

This option continues loading the diskless version of the program. Only definitions, thesaurus entries and 
quotations are available.

Do not run the program.

This option stops loading the program.

Tip: If you do not want to see this message again, click in the checkbox next to Do not show this 
dialog again so that a check mark appears in the checkbox.



About
Offers copyright information about the program and the names of the people and companies involved in 
its creation. For information on how to use the program, select Help Topics from the Help menu.



Print Selection
Choose an item to print. Any definition, thesaurus entry, quotation*, picture or map currently displayed 
may be printed. (To display an item, choose it from the list box and use the Thesaurus, Quotation, 
Picture or Map button at the bottom of the window if necessary.)

* Quotations are available only in the Full Reference set. See Selecting a Source for details.



Search in Entries
Search in Entries allows you to search the contents of the definitions, thesaurus entries and quotations*.

To search definitions, thesaurus entries, and/or quotations:

Type a word in the Look For box. Type any additional search words in the text boxes below and 
select AND, OR or NOT to define the relationship between your search words. Click in one or 
more check boxes in the Look In section to select or de-select the types of entries to search. 
Then press Enter or click on OK.

For more details, see Using Search in Entries.

* Quotations are available only in the Full Reference set. See Selecting a Source for details.



Search Thesaurus Only
In Thesaurus Only mode, Search allows you to search the contents of the thesaurus entries.

To search thesaurus entries:

Type a word in the Look For box. Type any additional search words in the text boxes below and 
select AND, OR or NOT to define the relationship between your search words. Then press Enter 
or click on OK.

For more details, see Using Search in Entries.



Partial Word Find
Partial Word Find allows you to search for words that contain specific letters (such as prefixes, roots or 
suffixes). It is also useful when you don't know enough letters in a word for Alternate Spellings to find the 
word you want. Using wild card characters to replace the letters you don't know may help the program 
find the word you want.

To find partial words:

Type three or more characters into the Part of word to find box and press Enter or click on OK.

To perform a search using wild card characters:

Type three or more characters into the Part of word to find box, replacing unknown letters with 
one of these wild card characters:

To Find: Use:

Any single letter ?

Any number of letters, including none *

Then press Enter or click on OK.

For more details, see Using Partial Word Find.



Alternate Spellings Found
When you search for a word that is not recognised by the dictionary or thesaurus, the program 
automatically searches for words with similar spellings and displays the results in the Alternate Spellings 
Found box.

To see the entry for a word in the results list, click on it, and click on OK.

To close the Alternate Spellings Found window without selecting a word, click on Cancel.

Tip: If the results list does not contain the word you want, try the Partial Word Find feature to 
perform a search using a combination of the letters you know and wild card characters that 
represent letters you don't know.



Thesaurus Only On/Off Button

Hides the definition box and shows thesaurus entries only. Click on the Thesaurus Only On/Off button 
again to see dictionary definitions, quotations, pictures and maps.



Mini View/Full View Button

Changes to the Mini View mode, which reduces the size of the dictionary window and keeps it on the 
screen while you use other programs. Click on the Mini View/Full View button again to return to Full 
View, the program's main window.



Partial Word Find Button

Finds all words that contain specific groups of letters, such as prefixes, roots and suffixes. Also allows the 
use of wild card characters in your search words.



Search in Entries Button

Searches for words within definitions, thesaurus entries and quotations.



Copy Button

Copies the selected text to the Windows clipboard.



Paste Button

Pastes the contents of the Windows clipboard into the entry box.



Print Button

Prints the displayed item.



Abbreviation Guide Button

Opens a list of the abbreviations found in dictionary entries.



Key to the Pronunciation Button

Opens a detailed list of the phonetic symbols used in the pronunciation transcriptions found in definitions 
and thesaurus entries.



Lists Button

Displays a drop-down menu from which you can select a list to display in the list box. 



Thesaurus Button

Displays a thesaurus entry for the current word. If the text of the button is dimmed, no thesaurus entry is 
available.



Quotation Button

Displays a quotation related to the current word. If the text of the button is dimmed, no quotation is 
available.



Picture Button

Displays a picture associated with the current word. If the text of the button is dimmed, no picture is 
available.



Map Button

Displays a map associated with the current word. If the text of the button is dimmed, no map is available.



Entry Box

Type, paste or drag and drop a word here to find its dictionary or thesaurus entry.

To see a list of the last 15 words you have looked up, click on the small button with the down arrow. Click 
on a word in the drop-down list to return to a previous definition or thesaurus entry.



Definition Box

Displays the complete definition text for the word you have selected.



Thesaurus/Media Box

Displays thesaurus entries, quotations, pictures and maps, when available.

When the Thesaurus Only option is on, the thesaurus/media box fills the dictionary window and displays 
thesaurus entries only.



List Box

Displays a list of available words, pictures and maps or search results.



Toolbar

Contains buttons that provide quick access to the program's most frequently used features.



Lists Counter Box

Displays the number of items available in the current list.




