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INTRODUCTION
What Is FreeHand?
FreeHand 8 is Macromedia’s award-winning design and illustration program for
print and the Internet. Its drawing and layout tools are used to develop everything
from the simplest illustrations to the most complex designs. Because FreeHand
is a vector illustration program, it is the ideal tool for any designer who needs to
edit and scale art, create PostScript text and art, print spot colors, and maintain
small file sizes.

Designers worldwide use FreeHand to create illustrations of all kinds, from fine
art and maps to newspaper infographics, as well as corporate identity, marketing
materials, and web graphics.

The best way to understand who uses FreeHand and why is to let them speak
for themselves:

“I have and always will use FreeHand for illustration. It is simply superior to
any other program.” -Neville Brody, Research Studios, London

“With FreeHand, I have a lot of control and flexibility; there are an amazing
number of options.”-Mickey Richardson, Design Consultant and Manager,
Superior Tape & Label

“We love FreeHand and use it for everything: design, animation, web graphics,
and layout of both print and web pages.”-Jenny Horn, Co-Producer, The
Center for Advanced Whimsy

The best way to form your own opinion of FreeHand is to start working with it.
This tutorial provides several sample projects and the steps for you to follow to
explore the FreeHand's design environment and tools. While certainly not
covering everything, it should give you a good idea of just how powerful and
intuitive FreeHand is.

Using This Demo Tutorial
This tutorial was written with two different users in mind. The first is the person
who has never used a vector drawing program. You don’t need a lot of experience
to complete the exercises. The second is the person who has used other vector
programs, especially Adobe Illustrator or CorelDRAW. You will find notes in the
exercises explaining how FreeHand is different from other programs. Once you
understand those differences, you will see just how powerful FreeHand 8 is.

As you read through the exercises, there are several conventions you should
know.

1. When you see a command listed as Modify > Combine > Blend, it means open
 the Modify menu, then choose Combine, and then the Blend command.

2. Whenever keys are listed, the Macintosh key is listed first, then the Windows
key. So Command/Ctrl-N means hold Command-N on the Macintosh and
Ctrl-N on Windows.

3. The tutorial is modular so you can skip around from section to section. However,
if you have never worked with a graphics program, it is suggested that you
follow the order listed.

4. While you can read the tutorial onscreen, you will probably find it easier to
print it out to refer to as you work.

5. The demo version of FreeHand does not let you save your work. So as much
as it hurts, you will just have to close without saving the graphics you create.

USER INTERFACE
In this section you will become familiar with the FreeHand 8 toolbox, the panels
and interface features. You will also learn how to use the new FreeHand 8 tabbed
panels and docking feature.

Opening FreeHand
1. Launch the FreeHand demo application as you would any other application.

On Windows you can use the Start menu. On the Macintosh you can double
click on the FreeHand demo icon.

2. On Windows, you see a Welcome to FreeHand 8 screen. This is the wizard
that helps you with various features. Click the New button to start a new file.

On the Macintosh, choose File > New to start a new document. The document
window appears as shown (UI-1).

UI-1
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Magnification and Views
1. If you do not see the entire page of the document,

choose View > Fit To Page. This is the equivalent
of Fit in Window in other programs. However, you
notice that the View menu offers you far more
choices than other programs. This includes Fit
Selection, which zooms in on the currently
selected objects, and Fit All, which zooms to show
all the pages in a file.

2. FreeHand also has a zoom tool (UI-2) that works
similarly to other programs. You can click with the
Zoom tool to zoom in. Press the Option/Alt key
while clicking with the Zoom tool to zoom out.
You can also drag with the Zoom tool to zero in
on a specific area and magnification.

3. You can also change your magnification by
entering a specific amount in the magnification
field in the lower-left corner of the document
window. Simply double-click in the field (UI-3),
enter a new amount, and then press the Return
key. Unlike other programs, FreeHand lets you
view at any amount from 6% to 25600%.

4. FreeHand also lets you change the ruler units
without leaving the document. Open the units
pop-up menu on the bottom of the document
window (UI-4), and change from points to inches.

Opening Panels
1. Depending on how the program was last used,

you may or may not see the panels you need. If
you do not see the Toolbox (UI-5) on your screen,
choose Window > Toolbars > Toolbox.

2. If you do not see the Color Mixer (UI-6), choose
Window > Panel > Color Mixer.

3. If you do not see the Color List (UI-7), choose
Window > Panel > Color List.

4. If you do not see the Layers panel (usually behind
the Color List), choose Window > Panel > Layers.

5. Use the Inspector panels to control much of the
features of objects and your document. They
usually are grouped into one unit. If you do not
see the Inspector panels (UI-8), choose Window >
Inspectors > Object. All five Inspectors should be
visible in a group.

Docking and Moving Panels
1. FreeHand gives you total control over how the

toolbox and panels are arranged. One feature is
the ability to dock panels so they open, close, and
move together. To dock the Colors List to the
Color Mixer, press on the top bar of the Colors
List. Hold the Control/Ctrl key as you drag the
panel. Release the mouse when you are near the
panel. A gray bar appears between the two  panels
indicating they are docked (UI-9). To release the
dock, just click the gray bar between the panels.

2. If you are familiar with the tabbed panels of other
programs, you will find it easy to work with
FreeHand’s tabbed panels. Tabbed panels can
be separated and combined in any form you want.
For instance, you may want the Stroke and Fill
Inspectors to be separate from the rest of the
Inspector panels.

UI-3

UI-4

UI-7

UI-5

UI-6

UI-2

UI-8

UI-9
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3. Press the tab for the Stroke Inspector (UI-10) and drag it away from the other
Inspectors. When you release the mouse, the Stroke Inspector appears as a
separate panel.

4. Press on the tab for the Fill Inspector (UI-11) and drag it into the panel for the
Stroke Inspector (UI-12). The Fill and Stroke Inspectors will be on their own
panel (UI-13). Position the panels in the positions that are best for you.

Customizing FreeHand
If you are more comfortable using other programs such as Illustrator or
CorelDRAW, you can change the keyboard shortcuts to those in other programs.

1. Choose File > Customize > Shortcuts. The
Customize dialog box appears.

2. Use the Keyboard shortcuts setting pop-up menu
(UI-14) to choose the program that you are familiar
with. Click Done to close the dialog box and
change the shortcuts. In addition to the preset
shortcuts, you can customize the keystrokes to
any combination you want.

BASIC DRAWING TOOLS
BASIC COLOR
In this section you will use a selection of the drawing tools to create some basic
shapes. You will use FreeHand’s Pointer tool to modify the objects. You will learn
how to mix and store colors. You will also learn how to apply colors.

Basic Drawing Tools
1. If you do not have a file open, choose File > New.

2. Click the Rectangle tool in the Toolbox
(BD-1). If you are familiar with other drawing

programs, you will find the Rectangle tool easy to
use. Press and drag from corner to corner to
create a rectangle. Hold the Shift key to draw a
square.  Create several different sized rectangles
on your page. (Do not worry if they overlap.)

3. Click the Ellipse tool in the Toolbox (BD-2). Press
and drag to create an ellipse. Hold the Shift key
to draw a circle. If you want to draw a rectangle or
an ellipse from the center point outward, hold the
Option/Alt key as you drag. Create several
different sized ellipses on your page.

4. FreeHand also has a polygon tool to create
polygons and stars. Double-click the Polygon
tool in the Toolbox (BD-3). This opens the
Polygon Tool dialog box (BD-4). (Any tool with a
bracket  indicates there is a dialog box associated
with the tool.) Set the Polygon tool for 5 sides
and Star shape. Set the Star Points for automatic
to create a “perfect” star. Click OK to return to
the page and drag to create several stars. Polygon
and Star shapes are always drawn from the center
outward. Hold the Shift key to keep the star
aligned vertically.

5. The main drawing tool of FreeHand is the Pen tool (BD-5). This tool allows
you to create multi-sided objects with both straight and curved segments. If
you are not at all familiar with using a vector pen, just remember that clicking
with the Pen will create straight lines between the points (BD-6). Dragging
with the Pen will create curved segments between the points (BD-7).

6. With the Pen tool chosen, click several times around the page. As you get to
the first point, the cursor shows a black dot indicating that the path will be
closed (BD-8).

7. Draw several paths with the Pen tool. If you want to leave the path open, hold
the Command/Ctrl key and click to deselect the path. Then start using the
Pen again.

Optional Exercise: If you have a pressure-sensitive tablet, explore working with
the Freehand tool (BD-9) in its three modes.

UI-10

UI-11 UI-12

BD-1

BD-3

BD-4

BD-6

BD-7

BD-8 BD-9

UI-13

BD-2
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Selecting Points and Paths
1. Click the Pointer tool in the Toolbox (BD-10).

Unlike other programs with several different tools
to select objects, FreeHand has just one tool that
can perform all types of selections.

2.Press and hold on the edge of one of the objects
to move that object around the page. A four-
headed arrow appears. Drag with that arrow to
move the object (BD-11).

3. Click one of the points of the stars or the Pen
paths. Drag to reshape those objects (BD-12).

Tip: Ellipses and rectangles are created as grouped
objects. This means that you need to ungroup
them before you can manipulate their individual
points.

4. Select one of the ellipses and choose Modify > Ungroup. This allows you to
manipulate individual points.

Tip: A selected point in FreeHand is white. If you drag an object by its edge it
moves even if the points are not white. The points are part of the object
and move without each one selected.

Colors
1. Select one of the objects on the page. The Colors

List indicates the fill and stroke settings for the
object (BD-13). The first box is the Fill Selector
and it indicates the fill color. The second box is
the Stroke Selector and it shows the stroke. The
third box indicates if the fill and stroke are the
same color.

2. Drag the Black color chip onto the Fill Selector. The object has a black fill.

3. Drag the None color chip onto the Stroke
Selector. The object has no stroke.

4. If you do not see the Color Mixer, choose
Window > Panels > Color Mixer. Click the CMYK
button in the Mixer panel (BD-14). To create a
CMYK color, either type in the numbers directly
or drag the sliders. Drag to create a color of 100%
Cyan. The color well at the bottom of the mixer
shows the color created.

5. To apply the color to an object, drag the color
from the bottom of the Color Mixer onto one of
the objects (BD-15).

6. You also need to store the color in Color List.
Drag the color from the Color Mixer onto the drop
box arrow in the Color List (BD-16).

7. In addition to CMYK, FreeHand lets you define
colors using RGB, HLS, Tint, or Windows/
Macintosh color systems. Click the RGB tab in
the Color Mixer and then create an RGB color
255R, 0G, 255B. Store that RGB color in the
Color List.

8. While you could continue to define colors one at
a time, you can add colors from the built-in color
libraries. The standard version of FreeHand
provides 21 different color libraries. The demo
version you are working with only contains two
libraries. Choose Crayon in the Options pop-up
menu in the Color List to import the Crayon colors.
The Crayon library appears (BD-17).

9. Use the Shift key to select as many colors as you
want. Then click the OK button to add the colors
to the Color List.

Transformation Handles
One of the new features in FreeHand 8 is the ability to scale or rotate objects
directly on the page without changing tools. To do so, use the transformation
handles.

1. With the Pointer tool, double-click an object. The eight transformation handles
and centerpoint appear (BD-18).

2. Move the cursor onto any of the handles. The straight double-headed arrow
indicates you can scale the object (BD-19). Drag to scale the object up or
down.

3. Move the cursor next to any of the handles. The curved double-headed arrow
indicates you can rotate the object (BD-20). Drag to rotate the object clockwise
or counterclockwise.

Tip: You can move the centerpoint to control the point around which the
transformation occurs. This can be a point inside or outside the object.

BD-10

BD-12

BD-11

BD-13

BD-14

BD-15

BD-16

BD-17
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Lens Effects
One of the most sought-after looks in vector programs is transparency—the
ability to see through objects. FreeHand's transparency effects are some of the
most sophisticated in the field of vector illustration. In this exercise you will use
a variety of the lens fills to embellish an existing file.

See-through effects
1. Choose File > Open and then find the file Map.fh8. This file is in the Demo

folder that accompanies this tutorial. The file is a map. (The small blue shield
on the pasteboard is used in another exercise and is not part of this one.)

2. Move the letters NY over the left side of the map. These letters will be used
to show a variety of the lens effects. (The letters are text that was converted
into paths.)

3. With the letters selected, click the tab for the Fill
Inspector. Use the top pop-up menu to change
the fill of the letters from Basic to Lens (LE-1).
The letters immediately change their appearance.

4. Use the second pop-up menu to choose the
different lens effects (LE-2).

5. Choose Transparency and then change the color
of the object to a light blue. The slider lets you
adjust the amount of transparency of the color.

6. Choose Invert to swap the color values of the area
inside the letters. (White becomes black, black
becomes white, and so on.)

7. Choose Lighten or Darken and then adjust the
slider to change the effect on the image.

8. Choose Monochrome to change the image to
one color. Apply different colors to see the various
monochrome effects. Leave the letters set for
Monochrome with a Blue color (LE-3).

Magnifying effects
The other type of lens fill is the Magnify fill. This fill allows you to blow up an area
of an image. This is excellent for creating callouts or exploded views of technical
illustrations, maps, diagrams, and so on.

1. Draw an oval over the right side of the map. Set
this oval for Lens fill at the Magnify setting of 2
(LE-4).

2. Because you need to move the oval off of the
map, you need to fix the oval so it continues to
magnify that area of the map. Click the
Centerpoint box. A small diamond icon appears
inside the oval (LE-5). This icon fixes the center
of the magnification effect of the lens.

3. Move the oval over to the right area of the page.
The centerpoint icon stays over the original area.

4. Move the letters NY to the middle of the map.
The blue appears inside the magnification oval.
You need a way to keep this blue from appearing
inside the oval.

5. Move the letters to the left so they do not appear
inside the oval. Select the oval and then click the
Snapshot option. This freezes the effect inside
the oval to the current look.

6. Move the blue letters back to the middle of the
map. This time the letters do not appear inside
the oval

Optional effect
Make a copy of the magnification oval and set it to darken. Use the Modify >
Arrange > Move Backward to position the darkened oval as a shadow behind
the magnification oval (LE-6).

LE-1

LE-2

LE-3

LE-4

LE-5

LE-6
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Multi-page Environment
FreeHand offers you very sophisticated multi-page features. Even dedicated
page layout programs do not provide all the features for varying page size,
orientation, and position. In this section you will open a multi-page document.
You will learn how to add new pages and then modify the artwork to fit the size
of the new pages.

1. Choose File > Open and then find the file Music.fh8. This file is in the Demo
folder that accompanies this tutorial. If you do not see all four pages of the file
(MP-1), choose View > Fit All.

2. Click the Document Inspector tab (MP-2) The
four pages of the document are shown in the
thumbnail window (MP-3).

3. The Document Inspector indicates that page 1 is
the active page by the dark black line around the
thumbnail labeled 1. If you double-click the
thumbnail labeled 2, you will move to that page
as well as fit the page to the size of the window.

4. You can also use the arrows, or the page pop-up
menu in the lower-left corner of the window (MP-
4) to move from page to page.

Adding Pages
1. Use the Document Inspector or the pop-up menu to move to page 4 of the

document. This page is for a business card for the group.

2. You need to copy this page and then modify it
into ticket for the group. Open the Options pop-
up menu in the Document Inspector and choose
Duplicate (MP-5). This duplicates the page as
page 5.

3. Move to page 5 by scrolling to the right or press
on the page pop-up menu or double click on the
page 5 thumbnail. (Make sure that page 5 is
highlighted in the Document Inspector.)

4. To make page 5 wider, click on the X field in the
Document Inspector and change the amount to
6 inches. Press Return to apply the change.

Modifying Art
1. Deselect any objects on page 5 by clicking off the page. Then click on the

edge of the black rectangle.

2.Drag the top corner of the black rectangle to fill
the new size of the page. A small symbol appears
next to the arrow indicating you are at the edge
of the page (MP-6). Click away from  the page to
deselect the rectangle.

3. With the Pointer tool, select the word “Shattered.”
Use the Shift key to select the word “Sounds,”
and drag both words over to the right side of the
page.

4. Select the text for the name and title and delete
it.

5. Select the “shattered” artwork. Because this
artwork has been grouped together you can
simply drag on one of the corners to make the
artwork bigger or smaller. Hold the Shift key as
you drag to make keep the artwork in proportion
(MP-7).

6. Add a rectangle with a white fill in the blank area of the ticket. This is where
the local information for the concert will be added. Choose View > Fit All to
see all the elements in your presentation (MP-8). Each page will print out with
its own crop marks and registration marks in the right positions.

MP-1

MP-2

MP-3 MP-4

MP-5

MP-6

MP-7
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Special Effects
FreeHand has expanded the types of tools available to artists. In addition to the
tools found in other programs, FreeHand has added many new types of tools
that are revolutionary in the field of vector illustration. In this exercise you will use
many of FreeHand's special effect tools to create an illustration. Even if you don't
consider yourself an illustrator, you will see how simple it is to work with the
FreeHand tools.

Freeform tool
1. Choose File > Open and then find the file Tree.fh8.

This file is in the Demo folder that accompanies
this tutorial. The file is a blank page with a brown
rectangle on the workpage and a green oval and
two little "apples" on the pasteboard.

2. The rectangle needs to be made into the trunk
and branches of the tree. Double-click the
Freeform tool (SE-1) in the Toolbox to open the
dialog box (SE-2). Make sure the setting is for
Push/Pull. Click OK to close the dialog box.

3. The Push/Pull tool has two different modes
depending on where you start the drag. Place the
cursor on the edge of the rectangle. The cursor
displays the pull icon, an arrow with an S after it
(SE-3).

4. Drag away from the edge. The rectangle reshapes
into a branch shape.

5. Press the 1, [, or left arrow key to decrease the
size as you drag to make smaller branches. (Press
the 2, ], or right arrow key to increase the size of
the shape.) Continue to pull branches out from
the rectangle until you have enough branches.

Tip: If you use  a pressure-sensitive tablet, the size
of the branch changes as you drag.

You now need to change the oval so it resembles
the leaves on top of the tree.

6. Move the green oval so that it covers the top
branches of the tree. Place the cursor outside.
The cursor displays the push icon, an arrow with
an O after it (SE-4).

7. Drag around the oval. The perfect edge of the
oval becomes more natural looking. Continue to
drag on both the inside and the outside of the
oval until you have created the top of the tree.

Graphic Hose
You now need to add the apples to the tree. Right now, you only have two
different apples. Rather than copy and paste identical apples on the tree, you
can use the Graphic Hose to "paint" apples of different sizes and rotations.

1. Open the Xtra Tools panel by choosing Window >
Xtras > Xtra Tools. Double-click the Graphic Hose
tool (SE-5) to open the Graphic Hose dialog box.

2. Make sure the Hose option is selected. This is
where you define objects for each of the Graphic
Hose sets.

3. To create a new set, press the top pop-up menu
in the Graphic Hose dialog box and choose New.
Type the name Apples and click OK.

4. Select one of the apples on the pasteboard and
choose Edit > Copy. Then click the Paste in button.
The apple appears in the preview window (SE-
6). Repeat for the other apple. This gives you two
apples in the set.

5. Click the Options button. This side of the dialog
box is where you set the controls for painting with
the hose.

6. Set the pop-up menus as follows. Order: Random. Spacing: Variable at 200
(Loose). Scale: Random at 130. Rotate: Random at 45°. These settings give
a variety apples.

7. Click the Graphic Hose in the Xtra Tools panel and drag around the top of the
tree. The apples are placed in different sizes and rotations.

Color Effects
FreeHand also lets you apply special effects such as gradients, very simply.

1. Set the color in the Mixer to a very light green.

2. Hold the Option/Alt key as you drag that color square onto the leaves at the
top of the tree (SE-7). This turns the fill from a solid green to a radial gradient
with a light green center (SE-8).

SE-1

SE-2

SE-3

SE-4

SE-5

SE-6

SE-4
SE-7 SE-8
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Special Effects
In this exercise you will use many of FreeHand’s special effects tools. The project
you will create is ta 3-dimensional slice of cheese. (While you probably won’t
need to draw a slice of cheese in your work, the project was designed to show
you how you can enhance your work using FreeHand’s special effects.

1. Close any previous documents and then choose File > New.

2. Use the Rectangle tool to draw a rectangle.

3. Click the tab for the Object Inspector (SP-1) and
enter 4i for the width and 3i for the height. (The
“i” suffix is needed only if the unit of measurement
for the document is not in inches.)

4. Change the corner radius to .25i. (Unlike other programs that make discrete
objects for a corner radius, FreeHand’s corner radius can be modified at any
time.)

5. Use the sliders in the Color Mixer to create a yellow color of Magenta 12%,
Yellow 100%. Drag that yellow color onto the rectangle. (If the object has a
stroke, drag the None color onto the Stroke Selector or the edge of the
rectangle.) Your rectangle is now ready for some special effects.

Effects Tools
1. Open the Xtra Tools panel (SP-2) by choosing

Window > Xtras > Xtra Tools.

2. Rather than have a “perfect” rectangle, you will
use several tools to make it more organic. The
first tool is the Fisheye Lens. Click on the Fisheye
Lens tool and position the + cursor in the middle
of the rectangle. Hold the Option/Alt key as you
drag so that the Fisheye Lens oval extends all
around the rectangle (SP-3). Release the mouse
to set the Fisheye effect.

3. Next you will use the Knife to punch some holes
in the object. Double-click the Knife tool
(SP-4) in the Toolbox. The Knife Tool dialog box
appears (SP-5).

4. At the width of 0, the Knife tool can be used to cut selected objects. Set to
a larger width, the Knife can be used to eat away objects. Set the Knife tool
as Freehand and a 47 width. Make sure that Close cut paths is checked and
that Tight fit is unchecked.

5. As you drag with the Knife tool, you see black
circles. Drag as shown (SP-6) to punch holes in
the object. (Make sure you punch some holes on
the edges of the object.)

6. You now need to make your rectangle a little less
“perfect.” FreeHand’s Roughen tool will do this.
Double-click the Roughen tool in the Xtra Tools
and set it for 7 amount and Rough Edge. Click
OK.

7. Drag with the Roughen tool on the object. A black
line indicates the effect is being applied. Release
the mouse when the edge has been slightly
modified (SP-7).

8. One of the most complex effects to make is a
smudge or soft shadow for an object. Fortunately,
FreeHand’s Smudge tool makes this effect very
easily. Click on the Smudge tool in the Xtra Tools
and drag slightly down and to the right (SP-8).
The Smudge fingers indicate the length and
direction of the Smudge. Your rectangle is now
ready for some more sophisticated coloring.

Color Effects
1. FreeHand also lets you apply special effects, such as gradients, very simply.

Change the color in the Color Mixer to 100% yellow, and then drag that color
chip onto the object (SP-9). (Only the top object changes color, leaving the
rest of the smudge the darker yellow.)

2. Set the color in the Color Mixer to 50% yellow. Drag this lighter color onto
the object while holding the Option/Alt key. This will turn the fill from a solid
yellow to a radial gradient with a light yellow center (SP-10). (Hold the
Control/Ctrl key to make a linear gradient.) Congratulations, you’ve finished
your 3D slice of cheese.

SP-1

SP-2

SP-3

SP-4

SP-5

SP-6

SP-7

SP-8 SP-9 SP-10
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Blends and
Blends on a Path
FreeHand has some of the most sophisticated blending commands of any vector
program. With FreeHand 8 those commands are  even more versatile. In this
section you will use the Blend command to create dramatic highlight effects.
You will also modify those blends using FreeHand’s live blends feature. Finally,
you will use the Join Blend to Path to create complex effects very quickly.

1. Close any previous documents and then choose File > New.

2. Use the Polygon tool to draw a 5-pointed star. Fill the star with a dark blue
color and set the stroke for None.

3. Position the cursor in the middle of the first star and draw another star slightly
smaller than the first. Make this star fill: white; stroke: none.

4. Draw one more star positioned inside the other two. Make this star fill: light
blue, stroke: none. Your screen should appear as shown (BB-1).

5. Choose Edit > Select > Select All. Then choose Modify > Combine > Blend.
Unlike other programs that force you to create blends between only two
objects at a time, FreeHand 8 allows you to select several objects at once
and apply the Blend command. All three objects are blended together (BB-
2) creating a highlight effect in the middle of the star.

Live Blends
Unlike programs that create finite objects from blends, FreeHand lets make
changes to the objects. This is the concept of live blends.

1. Use the Color Mixer to create a light yellow color. Drag the color chip onto
the white highlight. The highlight and the rest of the blend changes to reflect
the new color.

2. Drag some other color chips onto the blended objects. Remember, only the
original three objects are modified as a Live Blend. The objects in between
are modified as part of the blend.

Optional Step: You can modify the shape of any of
the original objects in a blend, and the blend
adjusts accordingly. Hold the Option/Alt key and
select one of the points of the outside star
(BB-3). Release the Option/Alt key, drag the point
down, and watch how the blend redraws.

Blends on a Path
Perhaps one of the most exciting uses of blends in FreeHand 8 has been the
ability to align blends onto a path. In this case you will create the outer edge of
the face of a clock.

1. Clear any previous objects off the page by choosing Edit > Select > Select
All. Then press the Delete/Backspace key. If you have no document open,
choose File > New.

2. Use the Line tool or Pen tool to draw a short line at the top of your page. Make
sure the line has a stroke.

3. To make an exact duplicate of this line, switch to the Pointer tool and hold the
Option/Alt key as you drag the line to the right. Notice a + sign next to the
selection arrow (BB-4). This indicates that you are creating a copy of the line,
rather than just moving it.

4. Select both lines at the top of your page, and choose Modify > Combine >
Blend. Don’t worry about the number of steps. You just need to create a blend
between the lines (BB-5).

5. To create the circle for the clock, drag with the Ellipse tool while holding the
Shift key.

6. Use the Pointer tool to select both the circle and
the blend. Choose Modify > Combine > Join Blend
To Path.  The lines arrange themselves around
the circle (BB-6).

Blend Steps
Unlike other programs that create a finite number of steps for a blend, the number
of steps in a blend can be adjusted at any time using the Object Inspector.

1. Click on the Object Inspector. The Blend on a
path information appears (BB-7). (The Inspector
information changes depending on the type of
object selected.)

2. Change the number of steps to 59. This creates
a circle with 60 lines around it. (The number of
steps means the number of interim steps between
the original two lines. Since the original two lines
are stacked over each other, 59 steps makes a
circle with 60 visible lines around it.)

3. Change the number of steps to 11 and you create
a circle with lines for 12 hours.

BB-1 BB-2
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Tracing Graphics
Converting Text
FreeHand lets you import graphics and then convert them into vectors using the
Trace tool. Once graphics have been traced, they are vector objects that can be
further manipulated. In this section you will convert both text and a imported
image into a form that can be manipulated using the 3D Rotation tool.

1. Choose File > Open and then find the file Logo.fh8. This file is in the Demo
folder that accompanies this tutorial.

Tracing a Placed Image
The image of the butterfly in the file was scanned in a program such as Adobe
Photoshop or Macromedia xRes, saved as a TIFF, and them imported into
FreeHand. In order to create the logo, this image needs to be converted from
a single bitmap into distinct vector objects. For this you will use the Trace tool.

1. Double-click the Trace tool (TG-1) to open the
Trace Tool dialog box (TG-2).

2. Open the Color mode pop-up and choose 16
colors. This gives the image a solarized effect.

3. Make sure the Resolution mode is set for Normal,
the Trace layers is set for ALL, and the Path
conversion is set for Outline. Also check the box
for Overlap paths. This creates the best look for
the image.

4. Set the Trace conformity to 6. This causes the
Trace Tool to put down a relatively high number
of points in following the image contours.

5. Because the scan is rather clean, you can set the
Noise tolerance for 0. This too will create a tighter
representation of the artwork. Click OK to return
to your document.

6. Drag with the Trace tool to create a marquee
around the butterfly image (TG-3). When you
release the mouse, the Trace Tool outlines your
image. You will see many control handles in the
image. These handles indicate the many vector
objects that have been created. Do not deselect
the objects that have been created. Go to the
next part of this section.

Grouping Traced Images
Because tracing images can create many objects at once, you need to group
the currently selected objects.

1. Choose Modify > Group. All the control handles are then grouped into one
object with four control handles. This makes it easier to select all the objects
created by the Trace tool.

2. Use the Pointer tool to move the traced objects away from the original image.
You should now see two butterflies, the original and the trace.

3. Open the Preview pop-up menu at the bottom of the document window and
choose Keyline (TG-4). This shows you the difference between the original
placed image and the traced objects (TG-5).

4. Although you can always work in Keyline mode, you will most likely want to
choose Preview to continue your work.

Tip: Hold the Option/Alt key to select individual members of a group. To then
select all the members of a group, press the Tilde (~) key.

Converting Text
Just as placed images need to be converted to vector objects before some
effects can be applied, so does text need to be converted.

1. Choose the Text tool (TG-6) in the Toolbox and
click on an empty area on the page. A blinking
cursor indicates you can now type.

2. Type the words BLUE BUTTERFLY.

3. Choose Edit > Select All to select all the text.

4. If you do not have the Text toolbar (TG-7) at the
top of your screen, choose Window > Toolbars >
Text. Then open the font pop-up menu (TG-8)
and choose a thick, sans serif typeface such as
Arial Black or Futura Heavy.

TG-1

TG-2

TG-3

TG-4 TG-5

TG-6

TG-7

TG-8
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Page Layout
Many designers have discovered that FreeHand is an excellent application for
page layouts. In this section you will flow the text between the pages of a brochure.
You will also use styles to quickly modify text and objects. Finally you will work
with FreeHand’s sophisticated tab commands.

1. Choose File > Open and then find the file Brochure.fh8. This file is in the Demo
folder that accompanies this tutorial.

2. If you see a missing font dialog box (PL-1) that
says the font “Times” is missing, click the Replace
button. Then use the font pop-up menu to choose
a font from your system. Try to choose a similar
font such as Times New Roman.

3. Choose View > Fit To Page and then choose
Keyline from the bottom Preview pop-up menu.

Linking Text
The text that was imported is in the lower text block on the page.

1. Use the Pointer tool to select this text block (PL-
2). Handles appear as well as a square with a large
blue dot in it. This is the overflow symbol which
indicates there is more text than can fit in the
block. You need to add more text blocks on the
other pages to hold the additional text.

2. Click the Text tool (PL-3) in the Toolbox, and drag
within the guides on page 2 (PL-4). This creates
another text block.

3. Drag with the Text tool within the guides on page 3 to create a text block on
that page.

4. Change your magnification so you can see both pages 1 and 2. Using the
Pointer tool, drag from the overflow symbol on that page to the text block on
page 2. A curved blue line indicates when you have reached the new text
block (PL-5). Release the mouse button. The text is linked.

5.  Open the point size pop-up menu (TG-9) and
choose 72 point. (Use a smaller point size if the
text is too big for the page.)

6. With the text still selected, choose Text > Convert
To Paths. (Unlike other programs, text in FreeHand
can be converted to paths when selected as text
or as an object.)

7. Hold the Option key as you drag with the Pointer
tool around the word BLUE. This selects just those
letters within the group (TG-10).

8. Click the inside of one of the selected letters and move it to the left so there
is enough room for the traced butterfly. (Do not drag on the control handles,
just the inside or edges of the letters.)

9. Select the traced image and drag it in the space you just created. Your artwork
should look as shown (TG-11).

3D Rotation
The traced image and text can now be manipulated using the 3D Rotation tool.

1. Select both the converted text and the traced image. You can tell they are
both selected because two sets of control handles appear around the images.

2. If you do not see the Xtra Tools panel, choose Window > Xtras > Xtra Tools.

3. Click the 3D Rotation tool (TG-12) and then
position its cursor inside the letter U of the word
Butterfly.

4. Press and hold with the 3D Rotation tool and then
drag to the right. A box appears and a line extends
out from the cursor.

5. Drag along the line until the box looks as shown
(TG-13). This is the perspective you are applying
to the art.

6. Release the mouse and the artwork is rotated into
that position (TG-14).
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5. Do the same for the text from page 2 to page 3. Don’t worry if there is still an
overflow.

6. Move to page 1. Make sure the text in the block stops with the words “Flash,
Director, or Authorware.” If not, use the Pointer tool to drag one of the bottom
corner handles to change the size of the block.

7. Move to page 2. Make sure the text in the block stops with the words “much
as 500K.” If not, drag one of the corner handles to change the size of the
block.

Tip: Use the corner handles to change the size of text blocks. Dragging on the
side handles lets you change the leading or tracking as well as changing
the size of the block.

Formatting with Styles
With text styles you can automatically apply and modify text formatting. The
document you are working on already has some styles in it.

1. If you do not see the Styles panel (PL-6), choose
Window > Panels > Styles.

2. Select the Normal Text style and then choose
Edit from the Options pop-up menu. The Edit
Style dialog box appears as shown (PL-7). Make
sure the correct font is listed and then click OK.

3. Click with the Text tool inside any of the linked
text blocks and choose Edit > Select > All. Select
the Normal Text style in the Styles panel. This
applies the style to all the text.

4. On page 1, select the text “With Shockwave you can enjoy the best of the
Web.” Select the Subheads style. The text changes as shown (PL-8).

5. Select the bulleted text and click on the Bullets style. The text will change.

6. You can also apply styles by dragging the little Style chip “A” onto the text
(PL-9). On page 3, drag the Style chip for Subheads onto the following lines:
“Shockwave attracts more visitors.” “Visitors to shocked sites stay longer.”
“Visitors to shocked sites return often.”

7. Drag the style chip for Small Subheads onto the following lines: “MCI”
“Broderbund Software” “Multimedia Art Design” “Zeek Interactive” “Sportsline
USA” “K-Swiss”

8. Use either method (click or drag) to apply the Bullets style to the bulleted text.

Modifying Styles
Once you have applied styles, you can then make global changes very quickly.

1. Deselect any objects by clicking off the page with the Pointer tool. Then click
the Small Subheads style name in the Styles panel and choose Edit from the
Options pop-up menu.

2. In the Edit Style dialog box, open the color list, and choose Pantone 1665
CVC (PL-10). Click OK. All the subheads automatically change to the new
color.

The brochure also has an object style applied to the rounded rectangles. By
changing the definition of the style, you can globally change all those objects.

3. Instead of using the Options pop-up menu, hold the Option/Alt keys and click
the Top Banners style. This opens the Edit Style dialog box (PL-11).

4. In the Edit Style dialog box, open the Fill pop-up menu and choose Gradient.
The Gradient controls appear where you can set the fill colors for the object.

5. Open the color pop-up menu at the bottom of
the gradient controls and choose the 30% tint
of the Pantone color. This means that the objects
start at 100% of the Pantone color and then fade
to a 30% tint. Click OK to apply the change to
the style. All the objects filled with the style adjust
automatically.

6. Choose Hide Names from the Options pop-up
menu in the Styles panel. This gives a visual
display of the styles (PL-12).
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Columns and Copyfitting
FreeHand can also change single columns of text into multi-columns.

1. Use the Pointer tool to select the text block on
page 3. Click on the tab for the Text Inspector
(PL-12). This is where you can control many of
the text functions.

2. Click on the Column button (PL-13) within the
Text Inspector. The column controls (PL-14)
appear.

3. Change the columns field from 1 to 2. Press Return
to see the change.

The text is now in two columns, but they need to be balanced.

4. Click the Copyfit button (PL-15) on the Text inspector. The copyfit controls
appears.

5. Check Balance (PL-16). The text is automatically
balanced within the columns.

Wrapping Tabs
In addition to ordinary tabs, FreeHand has a feature called “wrapping tabs” that
is virtually unique in the field of desktop publishing. With wrapping tabs you can
easily create multi-column tables.

1. Move to page 4 and zoom in on the chart. This
chart is supposed to be columns of information
but has come in as continuous text. You can use
wrapping tabs to clean up the chart. If you do not
see the Info Bar (PL-17), choose View > Info Bar.

2. Select all the text in the chart. If you do not see the Text Ruler (PL-18) at the
top of the block, choose View > Text Rulers.

3. Drag the wrapping tab icon (PL-19) and place the
tab on the ruler at the 116 point mark (PL-20).

4. Drag the wrapping tab icon again, and place the
tab at the 132 point mark. Your text will start to
arrange in columns.

5. Continue adding wrapping tabs at the followng
marks:
218
236
354
371

6. Deselect the text. All the columns will be correctly wrapped (PL-21).

Tip: To work with wrapping tabs, you need to add two tab characters between
the text as well as two wrapping tabs. The first tab ends the column. The
second tab begins the next column.
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Find and Replace Graphics
Once you have created a project, you may find it necessary to make global
changes to the many items in the project. These could be design decisions or
production needs. Since clicking and selecting objects one at a time can take
hours, you need some way of automating the procedure. In this section you will
use FreeHand’s incredibly powerful Find and Replace Graphics feature to make
some changes to a map.

1. Choose File > Open and then find the file Map.fh8. This file is in the Demo
folder that accompanies this tutorial.

Color Find & Replace
The first thing that needs to be changed is that the light red lines need to be
changed to a darker red. These lines are directly behind the white stripe. While
FreeHand does let you select through objects stacked on top of each other, it
would still be cumbersome to select all the lines one by one. So you will use the
Find and Replace Graphics.

1. Choose Edit > Find and Replace > Graphics to open the Find and Replace
Graphics dialog box (FR-1).

2. Set the dialog box as follows:
Attribute: Color.
Change in: Document.
From: Light red tint.
To: Red.
Apply to: Strokes.

3. Click the Change button and all the light red lines are automatically changed
to dark red. A message at the bottom of the box indicates that 14 items were
changed.

Path Shape Find and Replace
Next, the oval road markers need to be changed to a shield shape. One shield
has already been drawn. You now need to make the global changes.

1. Set the Find and Replace Graphics dialog box as follows:
Attribute: Path Shape
Change in: Document.

2. Use the Pointer tool to select and copy one of the numbered circles. (Select
the circle, not the number.)

3. Click the Paste In button on the From side.

4. Use the Pointer tool to select and copy the blue shield at the upper-left corner.

5. Click the Paste In button on the To side.

6. Check Transform to fit original. This scales the shield down to fit the same
size as the original numbered markers. The Find and Replace Graphics panel
should appear as shown (FR-2).

7. Click the Change button and all the road markers are automatically changed.
(The message indicates 11 items were changed.)

Stroke Width Find and Replace
Finally, some of the strokes for the roads are too thick. They need to be made
thinner by a certain amount.

1. Set the Find and Replace Graphics dialog box as follows:
Attribute: Stroke width.
Change in: Document.

2. Set the Min field:  > 3. This will find all strokes greater than 3 points. Because
you used the greater than symbol in front of the 3 you do not need to set a
Maximum value.

3. Set the To field: -1.5. This will subtract 1.5 points from each of the strokes
(FR-3). So a stroke of 6 points will reduce to 4.5 points and a stroke of 4
points will reduce to 2.5 points. Without the minus sign, all the strokes would
be changed to one finite amount.

4. Click the Change button and all the strokes that are greater than 3 points are
changed. (The message indicates that 45 items were changed.)

FR-1

FR-2

FR-3
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Inter-application Compatibility
Macromedia recognizes that people working with FreeHand also work with other
programs such as Adobe Photoshop. Macromedia has made sure that FreeHand
8 offers the highest degree of integration with Adobe Photoshop.

FreeHand Compatibility with Photoshop
If you are accustomed to working with Illustrator and Photoshop, you may be
concerned with how well FreeHand interacts with Photoshop. The answer is
FreeHand actually works better with Photoshop than Illustrator 7.0.1. (Because
you are working with the demo version of FreeHand, you will not be able to use
these features.)

• No loss of resolution: Photoshop files can be dragged and dropped directly
onto FreeHand pages without any downsampling of resolution as they are
into Illustrator 7.0.1.

• Pixels or paths: FreeHand paths can be copied and pasted directly into
Photoshop files as either pixel art on layers or vector art on paths. They can
also be dragged and dropped with the same results.

• Opening Vector and Bitmap art: FreeHand EPS files open correctly in
Photoshop with both vector and placed images rasterized together. Native
Illustrator files do not open correctly in Photoshop and must be saved in the
EPS format.

Working with Scanned Artwork
FreeHand also offers some of the most impressive tools for working with scanned
artwork. Some of these tools mean you may not need to work with Photoshop
at all.

1. Choose File > Open and then find the file America.fh8. This file is in the Demo
folder that accompanies this tutorial.

Modifying Grayscale Images
A grayscale TIFF image was placed, then embedded, in the file. However, you
can now recolor that grayscale image so that it matches the vector graphics in
the file.

1. Press and drag the Dark Red color chip from the Color List onto the grayscale
image (IA-1). The image changes color. Drag the Medium blue color onto the
image.

2. You can also change the brightness and contrast of imported placed images.
With the placed image selected, open the Object Inspector. The Grayscale
TIFF information appears (IA-2).

3. Click the Edit button. The Image adjustment dialog box appears (IA-3).

4. While you can change the Lightness and Contrast settings using the sliders,
you will use the solarize effect. Click the solarize icon (IA-4). Then click the
OK button to see how the image has been adjusted.

5. Click the Links button in the Object Inspector. The Links dialog box opens.
This is where you can check the status of placed images or extract embedded
images back into linked ones. This is particularly helpful for working in cross-
platform environments. Click OK to close the Links dialog box.

IA-1

IA-2 IA-3 IA-4
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Masking Out a White Background
Silhouetted TIFF images contain a white background that will obscure any
objects behind them. Fortunately the combination of FreeHand’s Trace tool and
Paste Inside feature makes it very easy to eliminate the white background.

1. Click on the tab for the Layers panel and check
the mark for the Banner layer (IA-5). This makes
the Banner layer invisible, which will help working
with the Trace tool.

2. Double-click the Trace tool (IA-6) in the Toolbox.
The dialog box appears (IA-7).

3. Set the Path conversion pop-up menu to Outer
edge. Set the Trace conformity to tight and the
Noise tolerance to Max. This will create a path
that follows all the details of the silhouetted image.
(Because you are creating an Outer edge only,
you do not have to worry about the Color mode,
or resolution. Nor do you have to worry about the
layers.)

4. Drag with the Trace tool cursor to create a
marquee all around the image (IA-8). When you
release the mouse, a path is created around the
image.

5. Use the Pointer tool to select the image. Choose
Edit > Cut. The image disappears leaving an
outline of the original image.

6. Click with the Pointer tool to select the outline.
Then choose Edit > Paste Inside. (The Paste Inside
command is the equivalent of masks or clipping
paths in other programs.)

7. Click again on the Layers panel and turn the
checkmark back on. The image is only seen within
the boundaries of the traced outline.

8. With the outline still selected, drag the None color
chip onto the Stroke Selector. This eliminates the
black outline on the path.

Animation and Web Graphics
FreeHand is not just a print illustration program. FreeHand gives you the ability
to convert static images into dynamic animations. In this section you will use two
different techniques to convert FreeHand files into animations.

1. Choose File > Open and then find the file M.fh8. This file is in the Demo folder
that accompanies this tutorial.

Creating a Blend Animation
This animation will take the “M” logo and morph it into the question mark and
then into the person.

1. Select all four of the images on the page (AW-1). Do not select the spiral on
the pasteboard.

2. Choose Modify > Combine > Blend. All four objects are joined by intermediate
blend steps.

3. Move the spiral onto the art as shown (AW-2).

4. Choose Edit > Select All. Then choose Modify > Combine > Join Blend To
Path. The objects of the blend follow the spiral.

5. Open the Object Inspector. Change the number of blend steps to 7.

6. Uncheck the Rotate on path box in the Object Inspector. This keeps all the
objects vertical as they spiral around (AW-3).

7. Choose Xtras > Animate > Release to Layers and then look at the Layers
panel. Each of the objects of the blend has been placed on its own layer.

Because you are working with the demo version you cannot export the file as a
Flash animation. However, in order to let you understand how exciting these
animations can be, we have created an animation based on the above steps.
There are several different ways you can see this animation.
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Playing a Flash Movie
1. Find the file Mmovie.swf. This file is in the Demo folder that accompanies this

tutorial.

2. Drag the Mmovie.swf file onto the Flash player
(AW-4) which comes with the trial version of
FreeHand 8. The animation window opens and
you can choose Play from the Play menu.

3. You can also drag the Mmovie.swf file onto the
open window of the Netscape or Internet Explorer
browsers that have the Shockwave for Flash plug-
in. The animation automatically plays.

As you can see from the size of this animation, Flash files are incredibly small.
This makes them very useful for working on the web where the smaller the file
size, the faster the download and playback.

Creating a Page Animation
In addition to animations created from blends, FreeHand also lets you create
animations from individual pages.

1. Close any files you may have open. Choose File > Open and then find the file
Clip.fh8. This file is in the Demo folder that accompanies this tutorial. This file
already has the first three pages of the animation created. In each page the
illustration of the cherub gets smaller as the arrow changes its position.

2. Open the Document Inspector and use the
thumbnail preview (AW-5) to make sure you are
working on page 3.

3. Use the Options pop-up menu to duplicate page
3 and then move to page 4. Deselect the art by
clicking on the pasteboard.

4. Select the cherub group and use the corner
handles of the group to decrease the size of the
art (AW-6). (While you could use the
Transformation Handles to scale the cherub, you
can also you the corner handles of a group to
change its size.) Make sure the cherub moves
down and to the left corner of the page.

5. Select the arrow group. Click the Rotation tool
(AW-7) in the Toolbox and press with the tool to
rotate the arrow (AW-8). (You could also you the
transformation handles to rotate the arrow.)

6. Use the Options pop-up menu to duplicate page 4 and then move to page
5. Deselect the art.

7. Repeat step 4 and make the cherub even smaller.

8. Click on the arrow group and move the arrow slightly off the page.

9. Duplicate the page one last time. And perform the same operations on the
artwork. Your finished set of pages should appear as shown (AW-9).

Again, since you are working with the FreeHand demo application, you cannot
complete the rest of the steps for a real animation. This would be to choose
Xtras > Create > Flash Animation. This opens a dialog box where you can name
your file and set the animation options.

However, we have created another animation based on the above steps. Follow
the steps in the Playing a Flash animation exercise (earlier in this section) to view
the file Clipmvie.swf.

FreeHand and Flash on the Web
In the short time that Flash 2 has been available, it has become an important tool
for web designers. The following are some web sites where you can see how
FreeHand and Flash 2 animations can be used.

MSN (www.microsoft.com): Animation used extensively throughout the
North American and International websites.

Spooky & the Bandit (www.spookyandthebandit.com): Flash 2 used to
create “web toys.”

Simpsons (www.foxworld.com/simpsons): A total experience of interactivity,
even animated cartoons on the Simpsons television.

Macromedia (www.macromedia.com/shockzone.ssod/): It’s hard to keep
up with how many sites now use FreeHand and Flash 2 technology. Visit
our own page for the most recent “Site of the Day” for a look at the most
recent exciting ones.

GIF Exporter
Because you are working with the demo version, you cannot see FreeHand’s

GIF Exporter. However, as the
illustration shows (AW-10), the GIF
Exporter in FreeHand 8 gives you
complete control over
transparency, colors, etc. when you
export from FreeHand as a GIF.
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Print Output
Just as FreeHand has been innovative in the creation of artwork, so has it
pioneered some innovations in printing. In this section you will explore the many
options available for printing.

1. Choose File > Open and then open any of the files in the Demo folder that
accompanies this tutorial.

Creating Print Settings
One of FreeHand’s print features is the ability to save complicated print setups
as customized Print Settings. This means that you can use individual sets for
each of the printers in your office or you can have specialized settings for different
client’s output needs.

1. Choose File > Print to open the Print dialog box and click the Setup button.
(On the Macintosh, switch from General to the FreeHand application settings
to access the Setup button. The Print Setup dialog box appears (PO-1).

2. Click one of the three tabs on the right side of the Print Setup box and set
each for the way you would want your artwork to be printed.

3. Click on the + sign next to the Print setting to save these settings.

Printing
1. Click OK. This sets the Print settings and returns you to the Print dialog box.

2. Click Print. This demo version prints your file with banners at the top and
bottom of the page that read “FreeHand 8 Demo Version.”

Collect For Output
If you send files to another locations, such as a service bureau, for printing, you
may find that you need to send linked files and fonts as well as the original
FreeHand file. FreeHand 8 gives you a sophisticated Collect For Output feature
that automatically finds all the necessary files to print a job and copies them all
into one central location.

How to Purchase
FreeHand 8 can be purchased as a single application or in the Design in Motion
Suite, which includes FreeHand 8 together with Flash 2 for web animations with
sound and interactivity, and Insta.HTML for converting FreeHand files into
complete web pages.

To order, go to www.macromedia.com/freehand, call 800-457-1774, or contact
your favorite reseller or mail order company.

Resources
Online
One of the best places to get the latest information about FreeHand 8 is to visit
the FreeHand pages of the Macromedia web site (www. macromedia. com/
freehand). The site also has an Searchable Knowledgebase (www. macromedia.
com/ freehand/ support/) where you can search for the answers to your specific
design and technical questions.

You can also subscribe to the Macromedia newsgroup (News:// forums.
macromedia. com), which is an open forum for Macromedia users to discuss
technical issues and share helpful techniques involving Macromedia products.

Training Materials
This tutorial can only give you a glimpse of all the features in FreeHand 8. If you
are interested in learning to use FreeHand 8, there are many sources you can
choose from.

Authorized Training Centers
Macromedia maintains a list of training centers that have been authorized to
provide FreeHand training. You can find the centers nearest you by going to the
Macromedia web site (www. macromedia. com/ support).

Books and CD-ROM Training
You can use any of the excellent books and training materials available from
Macromedia Press and Peachpit Press. These books are available at bookstores
or may be purchased by calling 1-800-283-9444 or through the Peachpit Press
web site (www.peachpit.com).

On the web, visit the Peachpit Press web site (www.peachpit.com), or visit
www.macromedia.com for updated information on the latest FreeHand books
and training materials, authored by experts such as Sandee Cohen and Olav
Martin Kvern. On Macromedia's web site, search for Macromedia Press or
TechNote #3624, FreeHand Publications.
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