Presto! VideoWorks Help Contents

Welcome to the world of Presto! VideoWorks!!

You will get simple explanations about the functions in Presto! VideoWorks from the on-line help. For
more detailed information, please refer to your User's Manual.

If you have previous version of Presto! VideoWorks, please click on what's new for new features of this
version.

Choose a topic for help from the following:
m Screen Introduction

Keyboard

Menus and Commands

__Glossary

Ilcon Summary




Screen Introduction

During your operation in Presto! VideoWorks, the working screen displays the following parts:

Title Bar

Menu Bar

Icon Bar

Video Editing Area
Video Window
Video Viewer

Film Edit Window
Status Bar



Title Bar

The title bar indicates the name of the software "Presto! VideoWorks".



Menu Bar

The menu bar lists the available menus. In each menu, there is a list of commands. The menu commands
indicate the tasks you might want to perform.

To open a menu, click on the menu or press its underlined letter while pressing and holding the [Alt] key.
To invoke (or activate) a command, point to it and click or strike the underlined letter in the command
name. To close a menu without choosing a command, click anywhere outside of the menu or press the
[Esc] key.



Icon Bar

The icons in the icon bar offer quick and convenient access to several menu commands.

Click on the icons to execute the related commands.



Video Editing Area

The video editing area is that large portion in the center of the screen where you can playback and work
on your video. The video appears as a window in that area; it can be moved and sized within this video
editing area through the general Windows operating method.

Video Window

Video Viewer

Film Edit Window



Video Window

Video windows are where you playback and edit video sequences. The elements in the video window are
described below:

Dol === [a[n]

Video Title
Displays the filename of the video.

Film Mode Display Button

Closes the video window and opens a Film Edit window displaying the video sequence frame-by-frame in
film pattern for editing. Refer to the section Film Edit Window for details.

Information Button

Displays the information about the current file. This is the same function as the File Info command under
the File menu.

Import Sound Button

Imports a sound file (*.\WAV) starting from the current frame. The operation is similar to the setting
procedure in the Import dialog box, except that it is not necessary to set the options.

Actual Size Button
Restores the video window to its actual size. Refer to the section Actual Size for details.

Rebuild Button

After you have made editing to a AVI file, you can not playback the file using MCI driver. If you have
enabled the Use MCI Playback When AVI File Not Changed option in the Preferences dialog box, click
the Rebuild button to rebuild the AVI file for MCI playback.

Video Playback Area
Displays the video playback and current frame.

Play/Stop Button

Starts the video playback action. As soon as the playback action has started, this button immediately
changes to the [Stop] button which is used to stop the playback action. You may click the button to stop
the playback action anytime before the playing is over, or wait until the playing automatically stops when



the video sequence runs to the end.

Volume Button

Displays the percentage of current sound volume. To change the volume, click on the percentage you
want.

Frame Sequence Slider

Indicates the location of current displayed frame comparing to the whole video sequence. Dragging the
slider to any location on the slide bar displays the frame corresponding to that location in the whole
sequence.

Selection Indicator
Indicates the location of a series of frames which is currently selected by the user.

Moving Backward Button
Displays the previous frame.

Moving Forward Button
Displays the next frame.



Video Viewer

After you have enabled the Video Viewer command under the View menu (a check mark appears to the
left of the command name) or pressed the [F7] key, a video window, named Video Viewer, for displaying
the living video from your video device appears in the video editing area. All you have to do is to start
playing your video device, and then the video appears in the Video Viewer window.

v Wideo Yiewer

Title
Displays the name of Video Viewer.

Video Playing Area
Displays the living video from the video device.

Single Frame Button
Captures the current frame displayed.

Capturing Frames Button
Captures multiple frames in the video.

Capturing Video Button
Captures a fragment of the living video.

See also:
Single Frame



Film Edit Window

Whenever you click on the Film Mode Display button in a video window the film edit window appears in
the video editing area. In the film edit window you can select a video's frame fragment precisely by
viewing the sequence frame by frame, add sounds, and perform simple editing to the AVI file.
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Video Window Display Button
Clicking on this button opens the video window and closes the film edit window.

Information Button

Click on this button to bring up the Information dialog box. This function is the same as the File Info
command under the File menu.

Import Sound Button

Imports a sound file (*WAV) into audio track starting from the current frame. The operation is similar to
the setting procedure in the Import dialog box, except that it is not necessary to set the options.

Frame Sequence Indicator

The function of this indicator is the same as the Frame Sequence Slider in the video window. The
difference is that the Frame Sequence Indicator in the film edit window illustrates the frame location more
precisely in frame count or time format.

Video Track
This track displays all the frames of a video sequence in shrunken images like films.

Audio Track

This track displays the audio signals of a video sequence in wave form. If there is no audio signals in the
video sequence, this track will be empty.

Linking Lock

This button lets you decide whether to link the video and audio tracks together or not. When the rings on
the button are linked, the video frames and its corresponding audio waves are locked together. Click on
the button to make the changes.

Ratio Scaling Bar
This scaling bar shows the ratio of frame number to the scale on the Frame Sequence Indicator.



Scroll Bar

Drag the pointer on the scroll bar to display any portion of a video sequence in the video and audio
tracks.



Status Bar

The Status Bar is located at the very bottom of the working screen. The Status Bar consists of the status
box and the message box.

The status box displays the information indicating where the current frame is in your active video window.
This is illustrated in two kinds of formats: one is in frame counts, and the other is time format. In frame
count format, the figure at the right of the slash (/) indicates the total number of frames contained in the
video sequence, and the figure at the left indicates the sequence of the current frame. In time format, the
time at the right of the slash indicates the total time for the video to playback, and the time at the left
indicates the time calculating from the beginning of the sequence to the current frame. The formats are
selected by the Show Position in Time Format option in the Preferences dialog box.

The message box displays a message about the item the pointer is currently on.

During processing, the message box indicates the command you have selected and the progress of the
operation.



Video Title



Film Mode Display Button



Information Button



Import Sound Button



Actual Size Button



Rebuild Button



Video Playback Area



Play/Stop Button



Volume Button



Frame Sequence Slider



Selection Indicator



Moving Backward Button



Moving Foreward Button



Title



Video Playing Area



Single Frame Button



Capturing Frames Button



Capturing Video Button



Video Window Display Button



Frame Sequence Indicator



Video Track



Audio Track



Selected Fragment



Linking Lock



Ratio Scaling Bar



Scroll Bar



Keyboard

This section lists the keyboard shortcut for executing specific commands.
The following table lists the general keyboard usage in Presto! VideoWorks.
Key Function

[Alt] Combined with the underlined letter of an item
on the menu bar, pulls down and open the
menu. (To invoke a menu command or a dialog
box action, press the appropriate underlined

letter.)
[Ctrl]+[O] Open
[Ctrl]+[S] Save
[Ctrl]+[R] Revert
[Ctrl]+[X] Cut
[Ctrl]+[C] Copy
[Ctrl]+[V] Insert
[Del] Delete
[Ctrl]+[A] Select All
[Ctrl]+[N] Select None
[Ctrl]+[Z] Undo
[F5] Toggle icon bar display
[F6] Toggle status bar display
[F7] Toggle Video Viewer display
[F8] Freeze or unfreeze the video
[Enter] Execute the current command
[Esc] Cancel the current command
[Alt]+[F4] Exit

Menus and Commands

There are several pull-down menus located on the menu bar. Each menu contains a list of commands to
execute special functions for image processing.

Choose a menu from the following list to view the command function under it.
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File Menu

The following commands are included in the File menu:

Print to Video
Preferences
Exit



Open

The Open command is used to load an already existing AVI file. To open a file, do as follows:

1.

4.

Open the File menu and select Open, click on the Open icon on the icon bar, or strike the [O] key
while pressing and holding the [Ctrl] key. The Open dialog box appears.

If the file you want to open is on a different drive, select the drive you want from the Drives box.
In the Directories box, choose the directory you want to open a file from.

The software displays the names of all files in that directory that are of the type selected in the List
Files of Type box. In general, video files are of AVI file format.

From the list of files, select the file you want to open.

Note:

You can open multiple files by clicking on the file names while holding down the [Ctrl] key to select non-
contiguous files, or on the file names while holding down the [Shift] key to select contiguous files.

5.

7.

After you have selected a video file, the first frame of the selected video appears in the playback
preview window at the right of the dialog box. Click on the Play button to preview the whole video
sequence. You may stop playing anytime by clicking on the Stop button.

If there is no audio signals in the selected file, the Sound button will be dimmed. If there is audio
signals in the file and your system has a sound card, the Sound button is used to enable or disable
audio playback.

If you have selected multiple files, the video sequences will be played from the first to the last file
continuously after you click on the Play button.

Click on the [i] button to view the file information. The Information dialog box appears. This is the
same as the dialog box when you select the File Info command under the File menu.

If you have selected multiple files, you may click on the [Next] or [Prev] button to see the information
of all the selected files.

Click on the [OK] button to return to the Open dialog box.

Click on the [OK] button to open the file(s); or click on the [Cancel] button to abandon the process.



Save

Save is used to save a video sequence that already exists on disk. After saving, you can keep on working
on the video. It is a good idea to save often to prevent accidental loss of the video changes you have
created.

In addition to open the File menu and select Save, a shortcut method to invoke the Save command is to
press [Ctrl]+[S].



Save As

This command saves a new or previously existing file you have been working on. You can name a new
file or save an existing file under a new name and preserve the original file in its previously saved form. To
save a new or existing file:

1. Open the File menu and click on Save As, or click on its icon on the icon bar. The Save As dialog box
appears.

If the file you want to save is on a different drive, select the drive you want from the Drives box.
In the Directories box, choose the directory you want to save the file in.

Click on the extension that corresponds to the format of the file to be saved in the List Files of Type
box. The video sequences are of AVI file format.

5. Click on the [Option] button to set the compression method and other options. Refer to the section
entitled Save Options for details.

6. Enter the filename for the video in the File Name text box, or go to the list box and choose an existing
filename for the video.

7. Click on the [OK] button to save; click on the [Cancel] button to cancel the process.



Save Options

Several compressors provided by Video for Windows are included in the software in order to assist users
in handling the processing of large video files and save disk space. To compress a file before saving it:

1. Click on the [Option] button in the Save As dialog box. The Save Option dialog box appears.
2. In the Method option, select a way to compress the file or not to compress the file.

3. In the Quality option, drag the pointer in the scroll box to define the compression quality. The
compression quality determines by how much a video sequence is compressed. Dragging the pointer
near the Coarser end will obtain lower quality video with smaller file size; dragging the pointer near
the Finer end will obtain higher quality video with larger file size.

4. Set the data transfer rate of the target playback drive in which you intend to playback the AVI file in
the Data Rate option. If you are not aware of your storage device's data transfer rate, refer to its
manual or run a utility such as Norton Utilities to find out.

5. Set the key frame rate for compression in the Key Frame Every option. If the image data in your video
sequence does not change very much among frames, you may set a higher key frame rate. If the
frames in the video are mixed with many motion or background changes, you should set a lower key
frame rate.

6. Set the video and audio interleave intervals in the Interleave Audio Every option. If you disable this
option, you will need a large amount of memory for storing the audio signals. In general, this option
should be enabled.

The default setting of interleave intervals is 1 frame. This will maintain a general listening demand and
match the CD-ROM data structure. You may change the setting as required, but higher interleave
intervals may result in interrupts during the playback process.

7. For a more efficient playback of files on CD-ROMs, enable the Pad Frames for CD-ROM Format
option. This will rearrange the data structure for CD-ROM playback.

8. The [Configure] and [About] buttons offers you a chance to view the information and configure the
selected compressor. The contents of the pop-up dialog box vary for each compressor. Usually the
About dialog box contains the information about copyright and version of the compressor, and the
Configure dialog box allows you to set the compression ratio.

9. Click on the [OK] button.



Revert

After you have made changes to a video sequence, if you are not satisfied with your editing, you may
abandon the changes and reload the last saved version of the file with the Revert command. To revert a
video sequence, open the File menu and select the Revert command, or strike the [R] key while pressing

and holding the [Ctrl] key.



File Info

The File Info command under the File menu provides information about the current active video
sequence. Clicking on either the command or the information button in a video/film Edit window brings up
a dialog box with the related information.

Click on the [OK] button to close the dialog box.



Recall

You can quickly open any of the last few files you worked on by choosing the Recall command from the
File menu. The number of files Presto! VideoWorks can recall depends on the setting of File Recall Level

in the Preferences dialog box.



Close

If a video sequence opened on screen is not used or edited, it is recommended to close it to increase
working space in memory. To close a video sequence, simply open the File menu and select the Close
command.



Close All

The Close All command is used to close all the video files on the working area. If any file has been edited
and not saved, a dialog box will appear prompting you to save. Answer Yes to save the file, No to
abandon the changes or Cancel to cancel the command.



Import

You can import audio files (*.\WAV), animation files (*.FLI, *.FLC) and image files (*.BMP, *.JPG, *.TIF, ...)
created in other applications into Presto! VideoWorks and transform them as AV files.

To import a file:

1.
2.
3.

Open the File menu and select Import. The Import dialog box appears.
If the file you want to import is on a different drive, select the drive you want from the Drives box.
In the Directories box, choose the directory you want to import a file from.

The software displays the names of all files in that directory that are of the type selected in the List
Files of Type box.

From the list of files, select the file you want to import.

If you are importing a wave or image file, click on the [Option] button to set the frame rate and
dimensions of video for transforming the file into an AVI file. If you do not set these options, Presto!
VideoWorks will apply default settings for transformation.

The AVI file generated by importing a wave file contains no images. The background color you
selected in the Preferences dialog box appears in the video.

When importing image files, you can select whether to rescale the image to the specified video
dimensions or pick the rectangle of the upper left corner in the image according to the specified video
dimensions. If you decide to rescale the image, enable the Fit in Video Dimensions option.

Moreover, you can set the video format as 8 bits, 16 bits or 24 bits in the Video Format section. The
image will be coverted if it is not the type you select.

On importing an image, the images used to form a video file should be duplicated from one image or
different images with relative consistancy. You can select to duplicate the selected image file with the
Duplicate option in the Method section. If you have several images with relative consistancy and
named in contiguous numbers (i.e. FILEO1.BMP, FILEO2.BMP, FILEO3.BMP, ...), you can select the
first file and enable the Stream option. The software will automatically find all the image files with
contiguous file names in the same directory and place them into frames in the video.

Click on the [OK] button to import the file(s); or click on the [Cancel] button to abandon the process.



Print to Video

The Print to Video command allows you to play the AVI file in full screen mode for recording the video to
video devices such as VCR. This is useful when you want to record the video on a video tape through a

VGA-to-TV convertor.

After invoking the command, the AVI starts to play in full screen mode. You should operate your VGA-to-
TV convertor and video device to complete the recording.



Preferences

The options in Preferences dialog box are provided for setting some features as you run Presto!
VideoWorks.

Keep Background Video Quality

When you simultaneously open several files on screen, it is recommended to enable this option. When it
is enabled, the colors in the inactive videos will automatically approach to the colors used in the palette of
the active video, thus letting you view all videos in better quality. If this option is not checked, the colors in
the inactive videos may look abnormal.

Auto Rewind After Playback

You may select to have the Frame Sequence Slider in the video window return to the beginning of the
sequence immediately after the playback action was stopped, or stay at the position where it was
stopped.

Auto Replay

After this option is enabled, a video sequence will be continuously replayed once you click on the Play
button until you stop the playing by clicking on the Stop button.

Show Position in Time Format

The status box displays the information indicating where the current frame is in your active video window.
This is illustrated in two kinds of formats: one is in frame counts, and the other is time format. In frame
count format, the figure at the right of the slash (/) indicates the total number of frames contained in the
video sequence, and the figure at the left indicates the sequence of the current frame. In time format, the
time at the right of the slash indicates the total time for the video to playback, and the time at the left
indicates the time calculating from the beginning of the sequence to the current frame. When this option is
enabled, the information will be illustrated in time format; if it is disabled, the information will be displayed
in frame counts.

Use MCI Playback When AVI File Not Changed

When this option is enabled, an AVI file that has not been changed by any process in Presto! VideoWorks
is played back by using the MCI driver provided by Windows or your video card. After the AVI file has
been changed, it can only be played back with Presto! VideoWorks's MCI driver.

Note:

If you encounter abnormal playback, disable this option and try again.

Skip Some Frames If Playback Speed Not Match

Sometimes you may encounter that the playback speed of a video sequence does not match with your
system performance so the playback duration will be extended. You may choose to skip some frames to
maintain the original playback speed by enabling this option.

File Recall Level
This option specifies the number of recorded AVI files from 0 to 7 to be recalled by the Recall command.

Background Color

The selected background color appears in the video generated by importing a wave file and after applying
the Clear command in the Edit menu.

Working Directory



This option sets the working directory for Presto! VideoWorks operation. Use a directory containing more
free space for video operation. Click on the [Browse] button to search for a proper directory for working.



Exit

To quit Presto! VideoWorks, select the Exit command under the File menu.

If your video has been modified and not saved yet, a dialog box will appear and prompt you to save the
file. Click on the [Yes] button to save the file; click on the [No] button to ignore the modification and exit
the software; click on the [Cancel] button to quit the Exit command.



Edit Menu

The Edit menu contains the following commands for editing images:

Paste Insert
Paste Overwrite
Paste as New
Select All
Select None

Before actually editing the video, you must first learn how to select a fragment from a video sequence:
Selecting a Frame Fragment



Undo

The Undo option cancels the last action Presto! VideoWorks performed. Click on this command or the
Undo icon on the icon bar to undo or redo the action.



Extract

The Extract function enables you to place into a new video window the reproduction of an existing frame
fragment. When you execute the Extract command, a hew video window appears on screen containing
the same frame fragment as that in the current active video window.

To extract a frame fragment, select the Extract command from the Edit menu or click inside the video and
drag the pointer to the empty space outside the video window.



Cut

The Cut command removes a selected portion of video sequence and places it on the Windows
clipboard. You can use the Insert or Paste Insert command to place the content last cut and put on the
clipboard back onto the original video sequence, or paste it to another file. Only the last cut content
resides in the clipboard. To cut a frame fragment, do the following:

1. Select a frame fragment in the current video window.

2. Open the Edit menu and select the Cut command, or click on its icon in the icon bar. The content of
the selected area is removed.

Note:

The keyboard shortcut to execute the Cut command is [Ctrl]+[X].

See also:

Insert

Paste Insert
Paste Overwrite
Paste as New




Copy

The Copy function enables you to make a copy of your selected frame fragment (or portion of video
sequence) and place it on the Windows clipboard. The original video is unaffected by the Copy command.
You could use the Insert or Paste Insert options to move the content last copied on the clipboard to
another document. Only the last copied content resides in the clipboard. To copy a frame fragment:

1. Select a frame fragment in the current video window.

2. Open the Edit menu and select the Copy command, or click on its icon in the icon bar. A copy of the
selected video then resides in the clipboard.

Note:

The keyboard shortcut for copying the image is [Ctrl]+[C].

See also:

Insert

Paste Insert
Paste Overwrite
Paste as New




Clear

The Clear command is used to remove the image(s) and/or sound in the selected frames. The cleared
video is filled with the background color specified in the Preferences dialog box.

To apply this effect:

1. Select the frame(s) you want to clear. You may select video, audio or both.

2. Click on the Clear command in the Edit menu.



Insert

The Insert command allows you to paste the clipboard content into a separate point of the video
sequence without applying any transition effect.

To paste the clipboard content using the Insert command:

1. Drag the Frame Sequence Slider in the destination video window until the frame you want to start
inserting appears.

2. Open the Edit menu and select Insert, click on its icon in the icon bar, or use the keyboard shortcut
[Ctrl]+[V].

A more simple way to insert a frame fragment into another video sequence is to utitlize the drag-and-drop
feature in Presto! VideoWorks. You don't need to cut or copy the frame fragment into the clipboard. All you
have to do is to drag the selected frame fragment to the destination video window. To do this:

1. Select a frame fragment from the source video sequence.

2. Move the Frame Sequence Slider in the distination video window until the frame you want to start
inserting appears.

Click and hold the mouse left button inside the source video playback area.
Drag the pointer to the destination video playback area.

Release the mouse button.

o g >~ w

When a list of submenu appears at the location of your mouse pointer, click on Insert.

The frame fragment will be inserted immediately into the separate point and increase the total number of
frames in the destination video sequence. The number of frames being added conforms to the number of
frames in the frame fragment.

See also:
Cut

Copy
Paste Insert
Paste Overwrite

Paste as New



Paste Insert

The Paste Insert command allows you to paste the clipboard content before a selected frame and apply
transition effects for linking with the destination video.

To apply the Paste Insert function:

1.
2.

Select a frame fragment from the source video sequence.

Drag the Frame Sequence Slider in the destination video window until the frame before which you
want to insert the frame fragment appears. This will be the separate point of the video sequence for
inserting the frame fragment.

Execute either way:

a. Select Cut or Copy from the Edit menu. Then with the destination video activated, open the Edit
menu and click on Paste Insert.

b. Click and hold the mouse left button inside the source video playback area, drag the pointer to the
destination video playback area, and release the mouse button. When a list of submenu appears
at the location of your mouse pointer, click on Paste Insert.

The Transition Effect dialog box appears.

In this dialog box you may select the way the frame fragment in the clipboard combines with the
current video sequence. The Begin Time section sets how the beginning of the frame fragment
combines with the last few frames before the separate point of the destination video. The End Time
section however sets how the ending of the frame fragment combines with the first few frames
starting from the separate point of the destination video.

In the Begin Time section set the frame number or duration, depending on the format you had
selected for the Status Box, for applying the transition effect from the current video sequence to the
pasted fragment in the Length option .

In the Destination option select a way to process the end of the destination video before the separate
point to apply the effect you will choose later for combining with the pasted fragment.

If you select Overlap, the last few frames before the separate point of the destination video will be
overlapped by the pasted fragment.

If you select Duplicate Last Frame, the last frame before the separate point of the destination video
will be duplicated, and the duplicated frames will be overlapped by the pasted fragment.

If you select Background Color, the software will use a background color to overlap with the first few
frames of the pasted fragment. Click on the [Choose Color] button to choose a background color for
overlapping. The chosen color will be displayed at the left of the button.

The number of frames to be overlapped, duplicated or applied a background color is decided by the
setting in the Length option.

In the Source option select a way to process the beginning of the pasted fragment to apply the effect
you will choose later for combining with the destination video.

If you select Overlap, the first few frames of the pasted fragment will be overlapped by the last few
frames before the separate point of the destination video.

If you select Duplicate 1st Frame, the first frame of the pasted fragment will be duplicated, and the
duplicated frames will be overlapped by the last few frames before the separate point of the
destination video.

If you select Background Color, the software will use a background color to overlap with the last few
frames before the separate point of the destination video. Click on the [Choose Color] button to
choose a background color for overlapping. The chosen color will be displayed at the left of the
button.



10.

11.

12.

The number of frames to be overlapped, duplicated or applied a background color is decided by the
setting in the Length option.

Select a transition effect from the Video Effect list box. The Sample box below will demonstrate the
current selected effect.

If the [Option] button is enabled, click on it to invoke a dialog box for further setting on the selected
transition effect such as setting of the transition direction.

If there is also audio signals to be combined, select an audio transition effect in the Sound Effect list
box.

In the End Time section set the frame number or duration for applying the transition effect from the
pasted fragment to the current video sequence in the Length option.

In the Source option select a way to process the end of the pasted fragment to apply the effect you
will choose later for combining with the destination video after the separate point.

If you select Overlap, the last few frames of the pasted fragment will be overlapped by the first few
frames after the separate point of the destination video.

If you select Duplicate Last Frame, the last frame of the pasted fragment will be duplicated, and the
duplicated frames will be overlapped by the first few frames after the separate point of the destination
video.

If you select Background Color, the software will use a background color to overlap with the first few
frames after the separate point of the destination video. Click on the [Choose Color] button to choose
a background color for overlapping. The chosen color will be displayed at the left of the button.

The number of frames to be overlapped, duplicated or applied a background color is decided by the
setting in the Length option.

In the Destination option select a way to process the beginning of the destination video after the
separate point to apply the effect you will choose later for combining with the pasted fragment.

If you select Overlap, the first few frames of the destination video after the separate point will be
overlapped by the last few frames of the pasted fragment.

If you select Duplicate 1st Frame, the first frame of the destination video after the separate point will
be duplicated, and the duplicated frames will be overlapped by the last few frames of the pasted
fragment.

If you select Background Color, the software will use a background color to overlap with the last few
frames of the pasted fragment. Click on the [Choose Color] button to choose a background color for
overlapping. The chosen color will be displayed at the left of the button.

The number of frames to be overlapped, duplicated or applied a background color is decided by the
setting in the Length option.

. Select a transition effect from the Video Effect list box. The Sample box below will demonstrate the

current selected effect.

. If the [Option] button is enabled, click on it to invoke a dialog box for further setting on the selected

transition effect such as setting of the transition direction.

. If there is also audio signals to be combined, select an audio transition effect in the Sound Effect list

box.

. Click on [OK] to start pasting, or [Cancel] to abandon the process.

See also:
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Paste Overwrite
Paste as New



Paste Overwrite

The Paste Overwrite command allows you to paste the clipboard content into a video sequence by
overwriting the overlapped frames of the destination. The number of frames being overwrote depends on
the frame number of the pasted fragment.

To apply the Paste Overwrite effect:
1. Select a frame fragment from the source video sequence.

2. Drag the Frame Sequence Slider in the destination video window until the frame which you want to
start overwriting by the pasted fragment appears.

3. Execute either way:

a. Select Cut or Copy from the Edit menu. Then with the destination video activated, open the Edit
menu and click on Paste Overwrite.

b. Click and hold the mouse left button inside the source video playback area, drag the pointer to the
destination video playback area, and release the mouse button. When a list of submenu appears
at the location of your mouse pointer, click on Paste Overwrite.

There are two ways you can apply special effects to the overlapping frames. Select either Mix or Chroma
Effect to invoke their respective dialog box.

Mix

Chroma Effect

See also:
Cut

Copy
Insert

Paste Insert
Paste as New




Paste as New

This command allows you to paste the clipboard content as a new video sequence. The clipboard content
can include a single frame or multiple frames.

To create a new video sequence by pasting, open the Edit menu and click on Paste as New. A new video
window containing the current clipboard content appears on screen.

See also:

Cut

Copy

Insert

Paste Insert
Paste Overwrite




Mix

This method mixes the pixels of the overlapping frames of the pasted fragment and destination video by
defining the transparency level of each image.

To apply this effect when pasting:

1.

In the Mix dialog box, drag the upper slider in the Begin Time section to set the transparency
percentage of the first overwritten frame in the destination video (Destination). The figure above
reflects your setting while you are dragging the slider.

Drag the lower slider in the Begin Time section to set the transparency percentage of the first
overwritten frame in the pasted fragment (Source).

You can preview the mixing effect from the sample picture.

Drag the upper slider in the End Time section to set the transparency percentage of the last
overwritten frame in the destination video.

Drag the lower slider in the End Time section to set the transparency percentage of the last
overwritten frame in the pasted fragment.

If you want to restore the original settings, click on the [Reset] button to reset all the values. Click on
the left arrow button to reset the values in Begin Time section, and click on the right arrow button to
reset the values in End Time section.

You may click on the [Swap] button to exchange the settings in the Begin Time and End Time section
SO as to obtain a reverse transformation of the previous defined effect. Clicking on the left arrow
button copies the setting of End Time section to the Begin Time section. Clicking on the right arrow
button copies the setting of Begin Time section to the End Time section.

Click on [OK] to start mixing, or [Cancel] to abandon the process.



Chroma Effect

This method allows you to replace a color selected from the overlapping frames of the destination video
with the colors of the pasted frames at the same location of the replaced portion in the destination
images, which in view the images of the destination video are placed on top of the images of the pasted
fragment and you can see part of the images of the pasted fragment revealed from the location of the
selected color.

You can also reverse the layer sequence of the destination and pasted videos.

To apply this special effect:

1.
2.

In the Chroma Effect dialog box, move the cursor into the sample picture in the Begin Time section.

When the cursor changes to a color picker, click on the color to be replaced by the pasted image for
the first overwritten frame. The selected color will be displayed in the Color option below the sample
picture.

Drag the slider to set the range for the selected color to be replaced in the Tolerance option.
Move the cursor into the sample picture in the End Time section.

When the cursor changes to a color picker, click on the color to be replaced by the pasted image for
the last overwritten frame.

Drag the slider to set the range for the selected color to be replaced in the Tolerance option.

If you want to reverse the layer sequence between destination and source video, enable the Swap
Source and Destination option and then execute steps 3 to 8.

If you want to restore the original settings, click on the [Reset] button to reset all the values. Click on
the left arrow button to reset the values in Begin Time section, and click on the right arrow button to
reset the values in End Time section.

You may click on the [Swap] button to exchange the settings in the Begin Time and End Time section
S0 as to obtain a reverse transformation of the previous defined effect. Clicking on the left arrow
button copies the setting of End Time section to the Begin Time section. Clicking on the right arrow
button copies the setting of Begin Time section to the End Time section.

10. Click on [OK] to start applying the effect, or [Cancel] to abandon the process.



Delete

The Delete command deletes a selected portion of the video. This way of deleting is similar to that of the
removing action of the Cut command, but with a major difference: the content deleted will not reside in the
clipboard. In other words, you can't bring back the portion you deleted using the Delete command. To
delete a portion of the image, do the following:

1. Select a frame fragment in the current video window.
2. Open the Edit menu and select the Delete command, or click on its icon in the icon bar.

Note:

You can also press the [Del] key on the keyboard to delete the selected frame fragment.



Reverse

The Reverse command reverses the frame sequence of the selected fragment so that the last frame
becomes the first and the first becomes the last.

To reverse a video sequence:

1. Drag the Frame Sequence Slider in the video window to select the fragment you want to reverse.

2. Open the Edit menu and click on Reverse. The frame sequence is reversed immediately.



Duplicate Current Frame

This command duplicate the current selected frame so as to increase the total frame number of the video
sequence.

To duplicate a frame:

1. Drag the Frame Sequence Slider in the video window until the frame you want to duplicate appears.
2. Open the Edit menu and click on Duplicate Current Frame. A dialog box appears on screen.

3. Set the number of copies you want to duplicate the selected frame.
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Click on [OK] to start duplicating, or [Cancel] to abandon the process.



Select All

The Select All command enables you to select an entire video sequence. To do so, use the Select All
menu command or click on its icon on the icon bar.



Select None

The Select None command enables you to deselect the currently selected frames of a video sequence.
To do so, use the Select None menu command or click on its icon on the icon bar.



Selecting a Frame Fragment

In a video sequence, you may select a specific portion (a series of contiguous frames) for editing work
(such as copy, delete, paste, etc.) without affecting other portions of the sequence.

You make the selection of a frame fragment in the video window or film edit window.

In the File Edit window, you can perform more editing than just selecting frames.

Selecting in the Video Window
Selecting and Editing in the Film Edit Window

Note:

You may select the Select All or Select None command under the Edit menu, or click on their icons in the
icon bar to select all the frames of a video sequence or abandon the selection, respectively.



Selecting in the Video Window

On opening a video sequence, all the frames are selected in default. You can identify this situation by the
selection indicator at the bottom of the video window (the entire indicator bar appears as dark gray).

To select a frame fragment in the video window, follow the instructions below:

1. Drag the frame sequence slider in the video window until the first frame you want to select appears.
2. Press and hold the [Shift] key.

3. Drag the slider until the last frame you want to select appears. The portion of the indicator bar
corresponding to the location of the selected frames becomes dark gray.

4. Release the mouse button and then the [Shift] key.

Now you have selected a frame fragment successfully.



Selecting and Editing in the Film Edit Window

Selecting a Frame Fragment

In the film edit window you can select a video's frame fragment precisely by viewing the sequence frame
by frame.

To select a frame fragment in the film edit window, follow the instructions below:
1. Drag the scroll bar until the first frame you want to select appears in the video track.

2. Point to the beginning of the first frame or sound wave you want to select in the video or audio track
and click.

The cursor will blink at the location you clicked. If the Linking Lock is enabled, both the video and
audio tracks will be selected.

Press and hold the mouse left button.

Drag through the frames or waves you want to select. When the cursor is dragged near the left or
right border, the next portion of the video sequence will automatically be brought into view.

You can also use the [Home], [End], [Page Up], [Page Down] and arrow keys to locate the frame(s)
you want.

5. When you reach the last frame or wave you need to select, release the mouse button.

To deselect a highlighted fragment, click the right mouse button.



Drag-and-drop Feature

After selecting a frame fragment, you can utilize Presto! VideoWorkss drag-and-drop feature to perform
Insert, Paste Insert and Paste Overwrite functions without having to copy the selected frames to the
clipboard.

Click in the area of selected fragment and drag the pointer to the video window or film edit window of
another AVI file to paste. A list of paste commands will appear at the point you release the mouse button.
Select the appropriate command to execute. Or you can drag to the empty space in the editing area to
extract the frames. This is the same procedure as utilizing the drag-and-drop feature in the video window.

Audio Editing

After selecting a fragment in the audio track, you can move the fragment to another position in the AVI file.
You can also import wave files by clicking on the Import Sound button. Thus you can perform simple
editing to the sound in the file.

To move a selected sound fragment, hold the [Ctrl]] key and drag in the area of selected fragment along
the audio track.



View Menu

The commands provided under the View menu are related to the display on the image editing screen or
the information about the system and documents. They are:

Actual Size

Icon Bar

Status Bar

Video Viewer

Overlay/Preview Modes



Actual Size

All the video windows can be resized to magnify or reduce the displaying dimensions of the video by
dragging the borders of the window. A video display appears in its actual size when the video is opened.
The video displaying dimensions change as you drag the window's borders. An enlarged video display
than the video actual size is referred to a zoom-in view; a shrunken video display than the video actual
size is referred to a zoom-out view.

To return the video display to its actual size, select the Actual Size command from the View menu or click
on the Actual Size button in the video window.



Icon Bar

This command decides whether to display the icon bar. When a check mark "v" appears at the left of the
command, the icon bar is displayed.

See also:

Icon Bar



Status Bar

This command decides whether to display the status bar. When a check mark "v" appears at the left of
the command, the status bar is displayed.

See also:

Status Bar



Video Viewer

This command decides whether to display the Video Viewer. When a check mark "v" appears at the left of
the command, the Video Viewer is displayed.

See also:

Video Viewer



Overlay/Preview Modes

Due to the different design technique used for each video capture board, some video capture boards
have the function to combine (overlay) video and VGA signals together and display them simultaneously
on the screen, but others can only capture uncontiguous frames and display them on the screen.
According to your hardware feature, you should select the video display as Overlay or Preview mode. If
your video capture board has the feature to overlay video and VGA signals, set the video to Overlay
mode; otherwise, set the video to Preview mode.

To set the video mode, open the View menu and click on the Overlay Mode or Preview Mode option as
required.

In effect, the overlay mode displays a video sequence with the best quality as smoothly as if the video
were playing on a TV screen; however, the preview mode displays captured uncontiguous frames, and its
display speed is influenced by the performance of your PC.

Capturing in preview mode pauses the displaying of the video. If you want to view the video during the
capturing process, set the display to overlay mode.



Video Menu

In Presto! VideoWorks you can change the actual dimension of your video, the format of the images and
the frame rate of the video. Furthermore, you can apply various special effects to the video sequence and
make it even more attractive.

These functions are all provided under the Video menu.

Crop
Resize
Change Frame Rate

Change Format
Add Border

Invert

Mirror

Emboss

Fade In

Fade Out
Mosaic

Slant

Zoom

Magic
Brightness/Contrast
Hue/Saturation

:



Brightness/Contrast

The Brightness/Contrast command is used to change the brightness and contrast of the image pixels in
each selected frame, much as the brightness/contrast controls work on a monitor by increasing or
decreasing the brightness and contrast levels between pixels.

To change the brightness or contrast:
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Select the frame fragment you want to apply the effect.

Open the Video menu and click on Brightness/Contrast. A dialog box appears.

Select a Channel option for processing, either Red, Green, Blue, or All.

Drag the sliders to set the brightness and contrast level of the first frame in the Begin section.
Set the brightness and contrast level of the last frame in the End section.

If you want to restore the original settings, click on the [Reset] button to reset all the values. Click on
the left arrow button to reset the values in Begin section, and click on the right arrow button to reset
the values in End section.

You may click on the [Swap] button to exchange the settings in the Begin and End section so as to
obtain a reverse transformation of the previous defined effect. Clicking on the left arrow button copies
the setting of End section to the Begin section. Clicking on the right arrow button copies the setting of
Begin section to the End section.

Click on the [OK] button to apply the effect, or [Cancel] to abandon the process.



Huel/Saturation

The Hue/Saturation command is used to change the hue and saturation of the images' colors
transforming from the first to the last frame of a selected frame fragment. To apply this effect:

1.
2.
3.

Select the frame fragment you want to apply the effect.
Open the Video menu and click on Hue/Saturation. A dialog box appears.

Drag the Saturation slider in the Begin section to set the saturation for the first frame. Negative
percentages decrease the intensity of color pixels in the image. Setting the saturation to -100%
causes the image color to change to pure gray. Positive percentages increase the intensity of color
pixels in the image so as to enhance the purity of colors.

Enter the value for changing the saturation of the last frame in the End section.

Set the degree value for changing the hue of the first frame by dragging the indicator on the switch
under the Begin section. The degree value changes as you drag the indicator, each cycle 360° on the
HLS color wheel. The color sequence on the HLS wheel is counter-clockwise from the red to the
purple colors of the rainbow. Notice the hue changes when you move the indicator.

Set the degree value for changing the hue of the last frame in the End section.

If you want to restore the original settings, click on the [Reset] button to reset all the values. Click on
the left arrow button to reset the values in Begin section, and click on the right arrow button to reset
the values in End section.

You may click on the [Swap] button to exchange the settings in the Begin and End section so as to
obtain a reverse transformation of the previous defined effect. Clicking on the left arrow button copies
the setting of End section to the Begin section. Clicking on the right arrow button copies the setting of
Begin section to the End section.

Click on the [OK] button to apply the effect, or [Cancel] to abandon the process.



Crop
The Crop command enables you to cut out unwanted portions in the video sequence and decrease the
size of the video window. To crop a video:

1. Open the Video menu and select the Crop command, or click on its icon in the icon bar. The Crop
dialog box appears.

2. Set the starting point, in pixels, of the part of image that you want to keep after cropping in the Crop
from Left (horizontal starting point) and Crop from Top (vertical starting point) options.

3. Set the width and height, in pixels, of the part of image that you want to keep after cropping in the
Width and Height options.

Note:

You can directly change the position and size of the cropping box anytime by dragging the nodes on the
border of the box.

4. Drag the slider at the middle of the dialog box to check each frame to see if the cropping area is
correct.

5. Click on the [OK] button to start cropping, or click on the [Cancel] button to abandon the process.



Resize

The dimension of the frames in a video sequence can be magnified or reduced by the Resize command.
This is done by increasing or decreasing the number of pixels in the images composing the video
sequence. To resize the video:

1. Open the Video menu and select the Resize command, or click on its icon in the icon bar. The Resize
dialog box appears.

The Source Video Size section displays the original dimension of the frame.

2. You can set the scaling ratio by entering its size, in pixels, in the Target Video Size section or by
entering the X (horizontal ratio) and Y (vertical ratio) values in the Resize Factor section. You can also
specify the scaling ratio by dragging the sliders between the 25% and 400% values indicated.

If you have enabled the Keep Ratio option, you can enter either the width or the height of the resized
images. The software will automatically determine the other value for you.

If you have disabled the Keep Ratio option, you have to enter both the width and height to resize the
images. If the values you enter are not proportional, the resized images will be distorted.

3. Click on [OK] to start resizing, or [Cancel] to abandon the process.



Change Frame Rate

Changing the frame rate (number of frames displayed in each second) of a video sequence means either
to duplicate or remove the frames to meet the new value of frame rate but the playback time of the entire
sequence remains (only the frame number is different), or to increase or decrease the playback time of
the entire sequence by changing the number of frames being displayed in each second (the frame
number of entire sequence is not changed).

The first way is used when you need to decrease the frame number to reduce the file size for saving disk
space or when you need to paste a frame fragment from the current video to another with a different
frame rate.

The playback effect using the second way of changing frame rate is to speed up (when the frame rate is
increased) or down (when the frame rate is decreased) the playback speed.

To change the frame rate of a video sequence:
1. Open the Video menu and select the Change Frame Rate command. A dialog box appears.

2. If you want to use the first way (playback time remains), enable the Keep Playback Speed option;
otherwise disable this option.

Set a new frame rate in the Frame Rate option.

Click on [OK] to change the frame rate, or [Cancel] to abandon the process.



Change Format

The images in a video sequence can be stored in 8-bit, 16-bit or 24-bit format as required. 24-bit format
results in better image quality but takes more disk space. If you want to save more disk space, you may
convert the images to 8-bit (index 256 color) format.

To convert the image type:

1. Open the Video menu and select Change Format command, or click on its icon in the icon bar. A
dialog box appears.

The Source Type and Compressor options show the current image type and the compressor used for
the active video sequence.

Select the image type to convert the images in the Target Image Type section.

The supported compressors may change after you have selected a different image type. Select a
different compressor and compression level if necessary.

You may also change the compressor and compression level used for the AVI file without changing
the image type as you need.

4. Click on [OK] to start converting, or [Cancel] to abandon the process.



Add Border

This command allows you to add horizontal and/or vertical borders to the left/right and/or top/bottom
edges of the selected frames.

To add borders:

1. Select a frame fragment for adding borders.

2. Open the Video menu and click on Add Border. A dialog box appears on screen.

3. Set the width, by pixels, of the vertical borders for the left and right edges of the selected frames in
the Width option.

4. Set the height, by pixels, of the horizontal borders for the top and bottom edges of the selected
frames in the Height option.

Select the color used for the added borders in the Border Color option.

Click on [OK] to proceed, or [Cancel] to abandon the process.



Invert

The Invert command reverses the brightness and color of each image in the selected fragment.
To utilize the Invert effect:

1. Select a frame fragment for applying the effect.

2. Open the Video menu and click on the Invert command to invert.

Click again to get back the original images.



Mirror

The Mirror command flips the images of a selected fragment vertically, horizontally, or diagonally. When
you select this command, three options for mirroring directions, vertical, horizontal and diagonal, pop up

at the right of the command for your selection.



Emboss

The Emboss command enables you to make each image in a selected frame fragment stand out from the
paper surface or stand in relief against its background. The emboss process coats the images with mostly
gray shades on the surface of objects, and with midetone colors from the originals for object outlines.

To apply the emboss effect:

1. Select a frame fragment for applying the effect.

Open the Video menu and click on Emboss. A dialog box appears.

Set the transparency level of the first frame in the Begin Time section by dragging the slider.

Set the transparency level of the last frame by dragging the slider in the End Time section.
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Click on the [OK] button to apply the effect, or [Cancel] to abandon the process.



Fade In

The Fade In effect displays the images from the darkest to brightest level of the images during the
selected frame fragment, so as to results in a smooth slide-in effect for a new scene in the video
sequence.

In those frames the image is lighter than its original brightness level, a background color will be applied to
overlap the image with appropriate transparent percentage.

To apply the Fade In effect:
1. Select the frame fragment you want to apply the effect.
2. Open the Video menu and click on Fade In. A dialog box appears.

3. Select a background color used during fading in the Background Color for Fading Effect option. Click
on the down arrow to display available colors and select one.

4. Click on the [OK] button to start or [Cancel] to abandon the process.



Fade Out
The Fade Out effect displays the images from the brightest to darkest level (disappeared) of the image
during the selected frame fragment, so as to results in a smooth slide-out effect in the video sequence.

In those frames the image is lighter than its original brightness level, a background color will be applied to
overlap the image with appropriate transparent percentage.

To apply the Fade Out effect:
1. Select the frame fragment you want to apply the effect.
2. Open the Video menu and click on Fade Out. A dialog box appears.

3. Select a background color used during fading in the Background Color for Fading Effect option. Click
on the down arrow to display available colors and select one.

4. Click on the [OK] button to start or [Cancel] to abandon the process.



Mosaic

The Mosaic effect can display each image in the selected frame fragment as a series of mosaic tiles in
different sizes. The colors of the tiles are averaged with the original image colors and according to the tile
size selected. To achieve this effect:

1. Select the frame fragment you want to apply the effect.
2. Open the Video menu and click on Mosaic. A dialog box appears.

3. Drag the slider under the Begin Time section to set the tile (cell) size applied to the first frame of the
selected fragment.

4. Drag the slider under the End Time section to set the tile (cell) size applied to the last frame of the
selected fragment.

The images between the first and last frames of the selected fragment will be applied with different tile
sizes gradually increased or decreased from the specified Begin Time tile size to the End Time tile
size.

5. Click on the [OK] button to start or [Cancel] to abandon the process.



Slant

The Slant command allows you to distort the images into the shape of parallelograms in a selected frame
fragment by changing the slant degree of the left/right borders of the images.

To apply the slant effect:

1.
2.
3.

Select the frame fragment for applying the effect.
Open the Video menu and click on Slant. A dialog box appears.

In the lower part of the Begin Time section, drag the slider to set the slant degree for the left/right
borders of the first image in the selected fragment.

Drag the pointers in the scroll bars at the right and bottom sides of the Begin Time image to define the
position of the first image.

In the lower part of the End Time section, drag the slider to set the slant degree for the left/right
borders of the last image in the selected fragment.

Drag the pointers in the scroll bars at the right and bottom sides of the End Time image to define the
position of the last image.

If you want to restore the original setting of slant degrees, click on the [Reset] button between the
sliders. If you want to reset the position of the slanted images, click on the [Reset] button between the
sample images. Click on the left arrow buttons to reset the values in Begin Time section, and click on
the right arrow buttons to reset the values in End Time section.

You may click on the [Swap] button to exchange the settings in the Begin Time and End Time section
SO as to obtain a reverse transformation of the previous defined effect. Clicking on the left arrow
button copies the setting of End Time section to the Begin Time section. Clicking on the right arrow
button copies the setting of Begin Time section to the End Time section.

Click on the [Color] button to select a background color for filling the empty space in the frames. If you
disable the Clear with Background Color option in the Color Selection dialog box, the original image
for each frame will be used as background.

10. Click on the [OK] button to start applying the effect, or [Cancel] to abandon the process.



Zoom

The Zoom command allows you to transform the images in a selected frame fragment from magnified to
reduced dimensions or from reduced to magnified as if they were viewed from the zoom lens of a camera.

To apply the zoom effect:

1.

2
3.
4

Select the frame fragment you want to apply the effect.
Open the Video menu and click on Zoom. A dialog box appears.
In the Begin Time section, set the scaling ratio for the first frame by dragging the Rescale Ratio slider.

Drag the pointers in the scroll bars at the right and bottom sides of the Begin Time image to define the
position of the first image.

In the End Time section, set the scaling ratio for the last frame.

Drag the pointers in the scroll bars at the right and bottom sides of the End Time image to define the
position of the last image.

If you want to restore the original setting of rescale ratios, click on the [Reset] button between the
sliders to reset both ratios. If you want to reset the position of the rescaled images, click on the
[Reset] button between the sample images. Click on the left arrow buttons to reset the values in Begin
Time section, and click on the right arrow buttons to reset the values in End Time section.

You may click on the [Swap] button to exchange the settings in the Begin Time and End Time section
SO as to obtain a reverse transformation of the previous defined effect. Clicking on the left arrow
button copies the setting of End Time section to the Begin Time section. Clicking on the right arrow
button copies the setting of Begin Time section to the End Time section.

Click on the [Color] button to select a background color for filling the empty space in the frames. If you
disable the Clear with Background Color option in the Color Selection dialog box, the original image
for each frame will be used as background.

10. Click on the [OK] button to apply the effect, or [Cancel] to abandon the process.



Magic
The Magic command combines the zooming, rotating, panning and chroma effect functions, which can
generate numerous 3-D image moving effects for videos.

This is specially useful when you are overlapping two videos with one of them as background and the
other moving at foreground.

To apply this effect:

1. Open the video(s) you want to apply the effect.

2. Make the video you want to use as foreground active.

3. Select Magic from the Video menu. A dialog box appears.

The upper left part of the dialog box shows the filename of the active AVI file with its frame numbers
as well as a representative illustration of the video with Play button and scroll bar for locating
individual frame.

4. Set the control points in the Panning Control window.

Click and drag on the E point at the center of the window. An S point appears representing the starting

point of image movement. The gray area indicates the video playback area and the white area
represents the unseen area outside the video. As you drag the S point, the video illustration at left
moves consequently to show the position of the image. The S point sets the position of the image in
the first frame and the E point sets that in the last frame of the video. You can move the E point as
well to change the position of the image in the last frame.

While the S point is moved, a line connecting the S and E points is also moved. This line indicates the
moving path of the images from the first to the last frames. You can add more control points on the
line to produce more complicated path for moving the images.

Clicking on the [Split] button adds a specific number of control points on the line so as to split the line

into equal-lengthed parts; every part indicates a equal number of frames. As you click on the button, a

dialog box appears for setting the number of control points you want to add. If you want to add control
points a second time, click on (select) the control point preceding the part of line you want to add
more points and then click the [Split] button again. Each control point can be dragged anytime to set
the moving path.

To delete a control point, select the control point and click on the [Del Point] button. The moving path
between its preceding and following points will be straightened.

You can also add a control point on any point of the line. Use the scroll bar to display the frame you

want to add a control point for. Click on the [Add Point] button (on the same location of [Del Point]) to

add a control point for this frame.

After you add some control points on the moving path, you can equal the length of each part on the
line by clicking on the [Same Speed] button, which means you can make every part of the line contain
the same number of frames.

5. In the Rotate section, set the 3-D rotating degrees for the image on each control point. Turn the switch

counter-clockwise to increase or clockwise to decrease the rotating degrees. The plus and minus
degrees indicates opposite directions of rotation.

Select the control point first. Then set the rotating degrees. The rotating degree for each frame is
equalized from the settings between two control points.

6. Inthe Rescale section, set the image rescaling ratio (X, Y axises) and the distance for perspective

view (Z axis) on each control point. Drag the sliders to specify the rescaling ratio. When the Keep X-Y

Scale Ratio option is checked, the X and Y sliders moves consequently.

The rescaling ratio and distance for each frame are equalized from the settings between two control
points.



7.

10.

11.

In the Composite Option section, select a color or an AVI file as the background for the moving
images on each control point.

Different background color and AVI selections can be applied among control points. The changes will
take place starting from the first frame of each control point.

You can select any of the files opened on the working area as the background. This is the same
function as applying chroma effect. The background AVI is overlapped beginning with the first frame
and ending on the frame of the same number before next control point with a different background
setting in the foreground AVI. If the same background AVI is used again on another control point later,
it will be overlapped beginning with the first unused frame since last control point it was applied.

Set the transparency and feathering effects for the moving images with the Transparent and Feather
options if necessary.

You can set different values on each control point. The values for each frame are equalized from the
settings between two control points.

You can save the settings with VWK file extension by clicking on the [Save] button and recall the file
later with the [Load] button.

You can click on the Play button under the illustration window to see the result of your settings. If you
want to see the real images of the video, enable the Preview Mode option.

Click on [OK] to apply the effect or [Cancel] to abandon the process.



Audio Menu

The audio special effects provided in Presto! VideoWorks are used to enhance the audio signals in a
video sequence to meet the video theme. If there is an audio track in your AVI file, you may apply these
special effects to improve the whole feeling of your compilation.

The Audio menu contains the following options:

Synchronize



Fade In

The Fade In command allows you to gradually increase the volume to the normal level of the entire video
sequence from the first to the last frame selected. This gives a smooth listening effect to avoid an
unexpected shock when the beginning of a sound fragment bursts out.

To apply the Fade In effect:
1. Select the frame fragment in which you want the sound fades in.

2. Open the Audio menu and click on Fade In.



Fade Out

The Fade Out command allows you to gradually reduce the volume to mute level from the first to the last
frame selected. This gives a smooth listening effect when a sound fragment is cut off.

To apply the Fade Out effect:

1. Select the frame fragment in which you want the sound fades out.

2. Open the Audio menu and click on Fade Out.



Echo

The Echo effect produces reflected echoes of the selected audio signals as if the waves of sound were
sent back from a wall of rock or mountain.

To produce echoes:

1. Select the waves of sound or the frame fragment for producing echoes.

2. Open the Audio menu and click on Echo. The Echo dialog box appears.

3. Inthe Delay section, drag the slider to set the echoing delay time by the number of frames or mini-
seconds (ms).

Drag the slider at the lower section to set the echoing level as stronger or weaker.

Click on the [OK] button to apply the effect, or [Cancel] to abandon the process.



Amplitude

The Amplitude command allows you to increase or decrease the normal volume level of a selected frame
fragment or the entire video sequence.

To adjust the volume level:

1. Select the frame fragment for adjusting volume level.

2. Open the Audio menu and click on Amplitude. The Amplitude dialog box appears.

3. Drag the slider to set the percentage of volume level.
4

Click on [OK] to apply the effect, or [Cancel] to abandon the process.



Change Format

You may redefine the audio characteristics by using the Change Format command under the Audio menu.
This will help you to improve your sound effect or manage the memory space used for audio track.

To change the audio format:

1.
2.

Open the Audio menu and select Change Format. A dialog box appears.

In the Sample Size section, select the data format of the audio to be 8-bit or 16-bit. 8-bit audio uses
less memory space than 16-bit audio, but 16-bit audio gives better quality sound.

In the Channels section, set the audio as Mono or Stereo. The Mono sound contains a single audio
track, and Stereo sound contains two audio tracks. Stereo sound has better quality but uses twice as
much memory as Mono.

In the Frequency section, set the sound frequency as 11 kHz, 22 kHz or 44 kHz. The frequency
setting determines the clarity of the sound. The frequency of 44 kHz gives the best sound effect but
requires the most memory. When the sound effect is not very important, it is recommended to use the
frequency of 11 kHz for saving memory space.

Click on the [OK] button to apply the changes, or [Cancel] to abandon the process.



Synchronize

The Synchronize command allows you to change the first frame where the audio signals start. This is
useful when you want to adjust a sound effect to meet the video.

To synchronize the audio signals with the video:

1.
2.
3.

Select the audio signals to be changed in the Audio Track of film window.
Open the Audio menu and select Synchronize. The Synchronize dialog box appears.

In the Audio Offset option, set the number of frames to move the selected audio signals from their
current location.

A negative value moves the audio signals to the frames before the current location; and a positive
value moves them to the frames after the current location.

The value of seconds below will change as well according to the frame number you specify.
In the Sample Playback of Video section, you can test the result of your setting.

Set the starting time in the AVI you want to test in the Start option.

Set the total testing duration you want in the Duration option.

Click on the [Test] button. Wait for a moment while Presto! VideoWorks is rebuilding the AVI. Then the
video will be played back in the video window at the lower right of the dialog box.

When you are satisfied with the setting, click on the [OK] button.



Capture Menu

With a video capture board and a video device installed on your system, you can view your favorite video
on your PC screen, capture it in digital form, and save it in AVI format through Presto! VideoWorks. If your
system is also equipped with a sound board, the audio frequency will also be captured and saved along
with the video.

Presto! VideoWorks provides abilities for capturing frames as images to its accompanying image
processing software, ImageFolio or Prolmage Plus, or as AVI files.

Single Frame
Frames

Video
Palette

Options
Freeze




Single Frame

The Single Frame option under the Capture menu allows you to capture one frame from the video as an
image to ImagefFolio or Prolmage Plus, if it is active, or to the clipboard.

To capture a single frame:

1. If you want to capture a single frame to ImageFolio or Prolmage Plus, open ImageFolio or Prolmage
Plus as a background application.

Enter Presto! VideoWorks.
Start playing the video containing the frame you need to capture.

When the frame to be captured appears, pull down the Capture menu and click on Single Frame or
click on the Single Frame button at the bottom of Video Viewer.

5. The captured frame will be transferred to the clipboard, ImageFolio or Prolmage Plus and a new AVI
document will be opened from the clipboard.



Frames

The Frames option under the Capture menu allows you to capture one frame per specific time period
from the video during a time limit or capture frames manually until you stop capturing, and save all the
captured frames as an AV file.

To capture multiple frames:

1. Pull down the Capture menu and select Frames. A dialog box appears.

2. Select the way for capturing as Automatic or Manual by clicking on the small circles.

3. If you have selected Automatic at the previous step, set the time period for capturing in the Frame
Interval option. For example, if you set the frame interval as 20 seconds, the software will capture one
frame every 20 seconds.

4. Enter the time limit for capturing in the Capture Time Limit option. Otherwise the software will
automatically decide the total number of frames to be captured in accordance with your disk space.

Note:

Please set the Frame Interval and Capture Time Limit according to the free capacity of your hard disk.

5.

Type the path and filename for the AVI file captured in the Captured Filename option. You may click
on the [Browse] button to search for the path or filename to use in this option.

Start playing the video you want to capture.

Click on [OK] to save the setting. Another dialog box will pop up asking you whether to start capturing
at the moment. Strike [OK] when you are ready to start capturing or [Cancel] to save the setting only.

If you have selected Manual at Step 2, a dialog box will appear after you click on [OK]. When the
Video Viewer displays the frame you want to capture, click on the [Capture] button to capture the
frame. Repeat this action to capture all the frames you want to save in an AVI file.

If you did not start capturing at last step, click on the Capturing Frames button when you want to start
capturing. The Capture Frames dialog box will appear again for your setting.

10. When using Automatic capturing method, press [Esc] whenever you want to stop capturing.

The captured AVI file will be opened on screen for playback and further editing.



Video

The Video command under the Capture menu allows you to capture video fragments in digital format,
each fragment as an AV file.

To capture video:

1. Start playing the video you want to capture.

2. Pull down the Capture menu and select Video. A dialog box appears.

3. Set the frame rate (the number of frames captured per second) for capturing in the Frame Rate
option.

4. If you want the software to control the capturing time limit, enable the Capture Time Limit option and
enter the time limit. Otherwise the software will automatically decide the total number of frames to be
captured in accordance with your disk space.

Note:

Please set the Frame Rate and Capture Time Limit according to the free capacity of your hard disk.
5. If you want to capture the audio signals and your system is equipped with a sound board, enable the
Capture Audio option.

6. Clicking on the [Video] button opens the Video Format dialog box provided by your capture board's
driver.

7. Click the Compress to setup the software compressor if necessary.
8. If the Capture Audio option is enabled, you may click on the [Audio] button to set the audio format.

9. Type the path and filename for the AVI file captured in the Captured Filename option. You may click
on the [Browse] button to search for the path or filename to use in this option.

10. Click on [OK] to save the setting. Another dialog box will pop up asking you whether to start capturing
at the moment. Strike [OK] when you are ready to start capturing or [Cancel] to save the setting only.

11. If you did not start capturing at last step, click on the Capturing Video button when you want to start
capturing. The Capture Video Sequence dialog box will appear again for your setting.

The captured video fragment will be saved as an AVI file with the path and filename specified.
12. Press [Esc] whenever you want to stop capturing.

The captured AVI file will be opened on screen for playback and further editing.



Options

The first step to display video on your PC is to set up your video devices and let them be able to
communicate with Presto! VideoWorks. This should be done by the three commands, Video Format,
Video Display and Video Source, in the Options under the Capture menu.

To set up the video device(s), do the following:
1. Open the Capture menu and click on Options.

2. From the pop-up submenu at the right of the Options command name, select Video Format, Video
Display or Video Source.

A dialog box will appear whenever you select one of these commands. The dialog box varies for
difference video boards because manufacturers design their own user interface.

Refer to your video board manual to complete the setting in the dialog boxes.

If there is a sound board installed in your system, select the Audio Format command from the same
submenu. A dialog box will appear for your setting on audio output. Make the setting according to the
sound board's manual.



Freeze

You may freeze the video by selecting the Freeze command under the Capture menu or pressing [F8]
when the frame to be captured appears. The video displayed in Video Viewer immediately stops showing
the current frame for capturing, but the video device actually keeps on playing.



Help Menu

Besides the messages shown on the status bar, click on the Help menu for more information on any of
the functions, commands and dialog boxes.

If you are not familiar with the Windows help system, open the Help menu and click on Using Help for
instruction.



Glossary

Choose a term from the following list to view its definition:

Audio Video Interleave (AVI) Files

Clipboard
Default

Dialog Box
Frame

Frame Fragment
Frame Rate

Video Duration
Video Sequence



Audio Video Interleave (AVI) Files

The file format used as a standard for all video files in desktop environment. The AVI files contain both
video and audio data as well as different options such as the compression scheme used.



Clipboard

A part of memory which temporarily stores the object that was proceeded with the Cut or Copy command.



Default

The program's initial setting for an option.



Dialog Box

A window that pops up on the screen to allow you to set the values of a function's options before
activating its command.



Frame

Each still image (picture) contained in a video sequence is referred to a "frame".



Frame Fragment

A series of frames with contiguous motions which can be edited as part of an entire video sequence.



Frame Rate

The number of frames captured or played per second for a video sequence. This value decides how
smooth the motion is shown and how much the memory (or disk space) is needed for a video sequence.



Image

A picture created from individual pixels (dots).



Memory

Also called RAM (Random Access Memory). A computer's temporary storage area for the information
(data and images) you are working on. You copy the contents of that memory to disk (the computer's
permanent storage area) to save it permanently.



Node

The small solid rectangles that are positioned on different location on cropping box's outline. The nodes
can be dragged by mouse action in order to resize the cropping box.

See also:

Crop



Pixel

The smallest unit displayed on a monitor.



Track

The images and sound composing a video sequence are referred to as video and audio tracks. The video
track consists of a number of still images, and the audio track is recorded by way of frequency.



Video Duration

The playback time of an entire video sequence.



Video Sequence

A video sequence is composed of a series of frames with images of constant motions to perform a
specific topic.



Icon Summary

This following lists all the icons on the icon bar and their functions used in Presto! VideoWorks.

(= Open

Save As
Cut

Copy

@ Insert
Delete
Select All
Select None
Crop

Resize
Change Video Format
Undo



What's new!!

This revision of Presto! VideoWorks has new enhanced functions as follows:

1. The Import function now includes FLI and FLC animation file formats and image files like BMP, TGA,
JPG, TIF, PCX, PCD.

Now you can use the drag-and-drop feature to edit the AVI files:
a. Open multiple AVI files for editing.

b. Click and drag the mouse left button in the source AVI window and then move the mouse to the
target AVI window.

c. When you release the mouse button in the target window, a pop-up menu will appear listing three
functions to combine the videos.

d. The three functions are Insert, Paste Insert and Paste Overwrite which are the same as the
corresponding commands in Edit menu. With drag-and-drop, it is much easier for you to combine
any two videos.

e. If you drop the video in the client area of Presto! VideoWorks in Step 2, a new AVI file will be
extracted from the source AVI file.

New Undo function is included in Edit menu.

New Magic function included in Video menu which provide panning, zooming, 3D rotating and color
keying functions all in one.

New Print to Video function in File menu.
New Clear function in Edit menu.

New Synchronize function in Audio menu.
New Close All function in File menu.

A Rebuild button included in Video window.
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Film Edit window now can move audio and video separately.
10. New Preference setting included.
11. Palettized 8-bit capture function under capture menu.

12. Video compressor options under Capture Video Sequence settings.



Palette...

Captures color information from the incoming video stream. Using this command, you can build a color
palette from a series of frames captured automatically by the program. This command is used mostly to
capture the color video in 8-bit capture mode.

1. Open Video Viewer window and have color live video displayed.

2. Click Capture menu and select Palette.

3. At Capture Palette dialog box, set color range (recommend 256 color) and frames.
4. Click [OK] after setting. The program will record palette of the played live video.

5. At Capture Video Sequence dialog box, set Video at 8-bit capture mode of your capture
device.

6. Click [OK] to start capturing video frames. The palette information will be included in your captured AVI
file.



Compressor Options

This dialog box lets you specify software compression techniques to apply during a capture session. Use
software compression techniques can reduce the file size of the video sequence and also reduce the data
transfer rate while playing back. However, since software compression requires processing time, it's
generally inappropriate to use during a real-time capture except you want to capture the video in low
frame rate. Some capture boards provide hardware-based compression that can be used during capture;
however, these compression schemes are specified in the Video Format dialog box, not in this dialog box.
The contents of this dialog box are dependent on the video formats supplied by your capture board.

To enabling the software compression feature :

1. In Capture Video Sequence dialog box, click [Compress].

2. Select Compressor such as MS Video 1, Intel Indeo, and set Quality.
3. Click [OK] and set other parameters under Capture Video Sequence.

4. Click [OK] to start capturing process.






