
Palettes

Expression’s interface consists of several types of toolbars and palettes. Some of the toolbars and palettes open automatically 
when you launch Expression. You can hide, display or move any or all of the toolbars and palettes on your workspace to meet your 
particular working style. 

Many of Expressions functions are contained in floating palettes.    To display a palette choose Window menu then select the 
name of the palette you wish to display.

Expression uses a variety of palettes to control specific functions. Most of these functions are not available elsewhere in 
Expression. You will find that certain palettes are so crucial to your work that you will always want them open.

Some palettes include tabs that open additional layers of the palette. Clicking a tab brings specific information forward so 
you can select options relating to the particular function listed on the tab.

Using tabs.

Use the close button in the title bar to hide unused palettes. The title bar also contains the name of each palette. Click-drag 
the title bar to move the palette on the screen.

Displaying Palettes

The Window menu contains the name of each palette available in Expression. To open a palette, choose a palette name 
from the Window menu. A check mark appears next to open palettes.

See also:

Paint Style palette

Color palette

Gradient Editor palette

Custom Color palette

Layers palette

Stroke Warehouse palette

Font palette

Panner palette

Transformation palette

Alignment palette



Panner Palette

Use this palette to quickly reposition your page so you can draw in a manner that is comfortable for you. 
Click the side arrows to rotate the page clockwise or counterclockwise. Click the plus or minus button to move the page 
forward or backward.

See also:

Navigating Your Document

Navigation Tools



Sizing Your Working Space

Use the scroll bars on the right and bottom of the document to move the page. The workspace is larger than the page that 
prints so be careful to keep your artwork inside the page outline if you want it to be part of your printed document. 

Use the remainder of the space as a desktop or drawing board. For example, you might work off the page when creating 
new strokes. Then work on the page when applying the stroke to a path as part of your image. After you create a new 
document, you can set the size of your page, page orientation and unit of measurement to accommodate the size of the 
drawing you are going to create.



Rulers

The document window includes rulers on the top and left side. As you move the cursor around the window a line on each 
ruler indicates the cursor position. You can change the rulers from the default inches to pica or points by clicking the small 
box at the upper left corner. You can toggle the rulers by choosing View menu> Show Rulers.



Show Grid. 

Choose View menu> Show Grid to see a non-printing grid that can help you position and arrange objects in Expression.

When View menu> Snap to Grid is active, all drawing and editing tools (except the Freehand tool) are influenced by the grid. 
When you click or drag near a grid line or intersection, the cursor snaps to the grid. The snap is stronger at grid intersections 
than along grid lines.

Expression also provides a snap to node constraint by using View menu> Snap to Nodes. When you click or drag near an 
existing node (point), the cursor snaps to the node



The Status Bar

At the lower left corner of the Expression window is the Status Bar. The Status Bar displays information regarding the Snap 
To Grid or Snap to Node functions and the size of the Grid as set in the Preferences> View tab.

Choose Window menu> Toolbars: Status to toggle on/off the Status Bar at the bottom of the main Expression window.



Multiple Windows

You may have multiple document windows open while you are working in Expression. The Window menu provides a list of 
currently open Expression documents. If you have multiple documents open, choose the name of the document from the 
Window menu to bring the document to the foreground and make it the active document.

The Window menu also allows you to control how multiple windows are displayed. These functions are only available on the 
Windows platform.

Choose Window menu> Cascade to arrange open windows starting in the upper left corner with each additional window 
positioned slightly to the right and lower so you can see the title bar of each window.

Choose Window menu> Tile to arrange open windows as tiles.

Choose Window menu> Arrange Icons to arrange open minimized windows along the bottom of the screen.



Navigating Your Document

You can navigate through a document or image by changing the level of magnification (zooming in or out), scrolling to a 
different part of the image, or rotating the page. By navigation, we mean moving around a document, changing views, or 
moving the page.

See also:

Zooming In and Out

Using the Grabber Tool

Changing Your View

Creating a New View



Zooming In and Out

By default Expression opens a document at 100% view, but you can change the view to suit your needs. The Zoom Ratio 
box in the lower left corner of the document displays the current zoom ratio. Click-hold to choose another zoom ratio.

The View menu also offers you a variety of ways of changing the zoom ratio: 

Zoom in Enlarges the workspace to the next smallest zoom ratio.

Zoom out Reduces the workspace to the next largest zoom ratio.

Zoom on Selection Magnifies the current selection.

View All Reduces the page to view all objects in the workspace.

Actual Size Enlarges or reduces the workspace to 100% size.

Center View Zooms into the center of the workspace to the next smallest zoom ratio.

You can also zoom in and out with the Magnifier tool.



Objects, Paths and Points

Expression objects are paths. An object may be a simple or compound path, a group of paths, a clone of another object, or a 
text object. Each object is defined by points based on the particular drawing tools used in its creation. Before you can 
arrange or edit an object you must select the object or its points. 

Note: Points are available for selection within a simple or compound path but are not available within a clone. For more 
information on clones, see Cloning Objects. 



Selecting Objects and Points

The Object Selection, Group Selection and Node Selection tools are used for selecting and moving objects and points. The 
three tools have a lot in common and behave in Expression as they do in other applications. 

See also:

Selecting

Selection tools

Selecting Objects

Selecting Objects and Points



Selecting

Mouse Hints and Tips

The following are hints and tips for selecting and moving objects with the mouse and Expression tools. 

Click an object with any selection tool to select the object. 

Drag a marquee with the Object or Group Selection tools to select all objects included or partially included within the 
selection area. 

Drag a marquee with the Node Selection tool to select all points contained within the selection area.

Click an object (or point) to select that object (or point), replacing the previous selection. 

Hold down the Shift key while clicking additional objects or points to add them to the selection, or while clicking selected 
objects or point(s) to remove them from the selection.

Click an object within a group with the Object Selection tool to select the whole group. 

Click with the Group Selection tool to select an object within a group. Click the object again to select the entire group.



Deselecting

Click an empty space to deselect all. 

Choose the Deselect All button from the Composition toolbar. This can be especially useful if you have a large background 
object, making it difficult to click in an empty space.



Constraining and Moving

Hold down the Shift key while moving a selection to constrain the movement to 45¡ increments.

Drag to move an object.

By default, Expression displays the Resize handles (four corner and four transformation handles). These handles can be 
used to scale, rotate, or skew the selection.



Scaling

Drag one of the four corner handles to scale the selection in both the x and y directions.

Drag one of the four corner handles while holding down the Shift key to scale proportionately. The opposite corner serves as 
the anchor point as the scaling is done.



Transforming

Drag one of the four transformation handles to skew the selected path. · Drag one of the four transformation handles 
while holding down the Shift key to rotate the selected path. 

See also:

Transformation tools



Selecting Objects

Before you can edit or arrange an object you must select it. When an object is selected, its appearance changes indicating 
that it is selected.

Its path(s) and nodes are highlighted in the selection color of the object’s layer. By default, Resize handles also appear, 
allowing you to transform the object directly. 

Resize handles can be disabled via a user preference.

You should select an entire object (as opposed to some or all of its individual nodes) whenever you want to transform the 
object (move, rotate, scale, shear or mirror) without changing its basic shape. 

Transformations applied to an object are stored in memory and can be reset at any time, restoring the object to its original 
location, orientation and scale.



Selecting Points

In order to change the shape of a path, you must be able to select individual points. When a node is selected, it is displayed 
as a large, solid-filled square in the selection color of the object’s layer. The path is also highlighted, and all of its unselected 
nodes are displayed as small, hollow squares.

Multiple nodes may be selected at once, whether they are on the same path or on several different paths. When more than 
one node is selected, Resize handles appear, allowing you to transform the multi-node selection. 

The Transformation tools also work on multi-node selections. Unlike transformations applied to objects, transformations 
applied to nodes actually change the basic shape of the path(s) and thus cannot be reset.



Viewing Selected Objects and Points 

The appearance of an object or point varies depending on whether it is selected or unselected, as well as the View quality 
(Path, Wireframe or Preview) currently active.



Selected Objects

In all selected objects, all points are visible, each represented by a small, filled square. The last node is always represented 
by an arrowhead indicating the direction of the path.

In Path view, a selected path is shown as a colored line. Set selection colors for each layer by choosing 
Arrange menu> Layer> Info. 

In Wireframe view, a colored line indicating the path, is superimposed on the wireframe. 

In Preview view, a colored line indicating the path, is superimposed on the color preview of the object.

No BŽzier tangent handles are visible when the entire object is selected. Handles are only displayed when individual points 
(nodes) are selected.

B-Spline points are shown with a dotted line indicating the imaginary polygon that controls the shape of the B-Spline path. 

If your Preferences are set to Show resize handles, a triangle is positioned at each corner of the invisible bounding box 
containing the object. These corner handles can be used to resize the object. 

The transformation handles are the center handles. These can be used to skew or rotate the selected object or nodes, 
depending on whether or not a modifier key is depressed.

Drag the double arrows to skew the object.

Drag the double arrows while holding down the Shift key to rotate the object

A selected text object is shown with its baseline.

Selected Text on a Path is shown with point of origin and baseline. 

The beginning and ending points on a clone object are displayed as filled circles. You can not edit the shape of a clone 
object.



Viewing Selected Points

The path is displayed, as described above, depending on view quality you have set.

Selected points are represented by a large filled square.

The path is displayed, as described above, depending on view quality you have set.

Selected points are represented by a large filled square.

BŽzier points show tangent handles.



Unselected Points

Unselected point is represented as a hollow square.



Transforming Objects

Transformation is a general term that refers to changes or modifications to a path that do not involve adding, removing or 
editing points. The object remains the same basic shape but is moved, scaled, rotated, mirrored or skewed. Transformations 
are done by dragging the object’s handles. You are given a real-time preview of the changes as you drag. Or use the 
Transformation palette to make your changes numerically.

See Also:

Transformation tools

Moving Objects

Scaling Objects

Rotating Objects

Mirroring Objects

Shearing Objects

Changing Perspective

Transformation Shortcuts



Moving Objects

There are two methods for moving objects in Expression. You can move selected objects and points manually using the 
mouse, or you can enter specific distances into the Transformation palette.

See also:

Transformation palette

Transforming Objects



Scaling Objects

These settings increase or decrease the distance between selected points along the x and y axes. Scaling is proportional 
along the specific axis but a different scaling factor may be applied to each axis. Scaling is applied relative to the point you 
select to serve as anchor or remain stationary during the scaling operation.

In addition to scaling selected objects using the Resize handles, scaling can be done using the Scale tool or the 
Transformation palette. Scaling may also be applied to individual points on a path as well as the whole path. 

Transforming Objects



Rotating Objects

You can also change the angle of any selected path. The distance between points is not changed. You can rotate around the 
object’s center or simply click to set a different center of rotation.

You can rotate objects using the transformation handles, the Rotation tool or the Transformation palette.

Transforming Objects



Mirroring Images

Mirroring inverts the position of each point in the selection, creating a mirror image based on the object’s center point or any 
point of reflection you set.

Transforming Objects



Shearing Objects

You can think of shearing as the way an image printed on the edges of a book can be distorted by pulling the book at an 
angle. The original image is contained in an imaginary rectangle. Once sheared, that rectangle has been changed to a 
parallelogram with the image distorted appropriately. 

Shearing changes the angular relationship between each point in the selection and a specific point on the shear axis. A 
given point’s shear anchor point is the point on the shear axis nearest to the point’s original position. You specify the shear 
axis (plane) and shear angle.

Transforming Objects



Changing Perspective

Expression’s Perspective tool allows you to quickly change the perspective of your artwork. This tool is especially helpful to 
edit an object which already has some perspective. Take for example, the image of a child’s ABC block. In order to view this 
block from a different angle, you must set the Perspective Control Frame to the shape of one side of the cube, then use the 
Perspective Frame to change the angle. 

The object’s Perspective Frame may be considered to be a piece of imaginary paper with your artwork on it. The 
Perspective Control Frame can be edited when it is displayed with small circles at each corner.

Click anywhere with the Perspective tool to change the Perspective Control Frame into the Active Perspective Frame, 
represented by larger circles at each corner. When the Active Perspective Frame is available changes you make will 
transform the artwork. Click to toggle back and forth between the Perspective Frame and the Active Perspective Frame.

Transforming Objects



Transformation Shortcuts

Expression’s Arrange menu also has some functions that assist you in using the Transformation tools. You can repeat, undo 
and make transformations permanent.

Repeat Last Transformation. The last transformation is applied again to the current selection. 

Repeat Accumulated Transform. The selected object is transformed in the same manner as the original object selected in 
step one, using the same reference point for transformations that require a reference point.

If you transform an object then later decide you do not want the transformation you can reset the object to its original 
state.

Reset Transform. The object is returned to its original state.

After you transform an object you can commit to the new state before continuing. In that case, the Reset Transform will 
return the object to the state it was when you committed to it

Commit Transform. The object does not change appearance. However, if you continue to transform the object then later 
select Reset Transform the object returns to this committed state rather than the original state



Using the Grabber Tool

The Grabber tool gives you a quick way to scroll an image

To use the Grabber tool while another tool is selected, hold down the Spacebar.



Changing Your View

In addition to controlling the Grid, Rulers, Snap To and Zoom Ratio the View menu controls the display quality for your paths.

Path: Shows the path only.

Wireframe: Shows the path plus an outline of any stroke applied to the path.

Preview: Shows the path plus the stroke and/or fill as applied to the path.



Creating a New View

The View menu can also be used to open up an additional window showing a different view of the document you are 
currently editing. This can be very useful when working on a complex image, as you can set each view window to its own 
zoom ratio. 



Vector or Bitmap

Computer graphics are either vector or bitmap. A vector graphic is defined by placing nodes (or vector points), then using a 
mathematical formula to describe the line that connects the points. Vector artwork is also referred to as outline. 

The advantage of vector art is that it is resolution independent and can easily be resized at any time, still printing out 
beautifully on a Postscript printer. Drawing packages such as Adobe Illustrator, Macromedia FreeHand and CorelDRAW! are 
examples of vector-based graphics programs. 

Bitmap artwork is defined pixel by pixel or dot by dot. Bitmaps have no outline, therefore, resizing such an image may result 
in stairstepped edges. 

Bitmaps have a real advantage when creating a textured look or for photographic quality images. Bitmaps can show subtle 
color changes and blends such as shadows. Graphics created by scanning, or by paint programs such as Fractal Design 
Painter and Adobe Photoshop, are examples of bitmap artwork.

You can export artwork from Expression in either vector or bitmap format. If you want to place or edit your image in another 
application, while still retaining resolution independence, you should choose a vector format. If you want to refine it or 
generate color separations in a painting or image editing application, you should choose a bitmap format.

If your image contain transparent object, you will probably want to save it in bitmap format (rasterized), since other vector-
based applications and printers do not support transparency.

See also:

Setting Bitmap Resolution

Saving as Vector



Setting Bitmap Resolution

When you save a file as a bitmap you can select the size and resolution of the file. Multi-view strokes saved as movies also 
have the same options. 

Resolution, in general, refers to the number of dots per inch (dpi) that make up an image. When you select a resolution, 
there are three kinds of resolution to consider:

The monitor’s resolution, measured in pixels. Expression is preset to 72 pixels per inch. The resolution of your monitor may 
be different.

· The document’s resolution. You can assign the resolution when an image is scanned or an image is rasterized (saved as 
a bitmap) in Expression.

· The output device’s resolution, measured in dpi. Output device resolutions vary depending on the printer.

The default resolution setting is screen resolution or 72 dpi. The image on-screen at 100% is the size it will be when it’s 
output. On most printers, 72 dpi bitmap renders a coarse image, so you may want to choose a higher resolution value.

If you are using a personal laser printer, set your bitmap Width and Height in inches, centimeters, points or picas. Set 
resolution to the dpi your printer supports. Your file will be output correctly at the best resolution for your laser printer and at 
the proper size.

If you are using a commercial printer or a more sophisticated output device, the dimensions should always be set to the 
actual size it will appear in the printed piece. It’s a good idea to check with your service bureau if you have questions about 
output device resolution.



Opening Existing Documents

Artwork created in other software applications can be brought into Expression for continued editing. You might use imported 
artwork as the basis for a path, a Skeletal Stroke or a Pattern. You can use Expression to work with images already existing 
in the following vector formats:

Adobe Illustrator 5.5 and earlier (*.ai)

CorelDRAW! 3, 4, 5 and 6 (*.cdr)

Computer Graphics Metafile (Windows) (*.cgm)

Vector PICT (Mac)

WMF (Windows)

Fractal Design Expression

See also:

Opening Clipboard Images



Opening Clipboard Images

You can also use the Clipboard to bring artwork from another application into Expression. Expression supports the following 
formats through the Clipboard:

Vector PICT (Macintosh)

WMF (Windows)

Fractal Design Expression

Text



Saving Documents

You can save your Expression artwork in several different ways:

Expression format for use in Expression in a future session.

Vector artwork for placement into a vector-based application such as Adobe Illustrator or CorelDRAW!.

Bitmap artwork for placement into a bitmap application such as Fractal Design Painter or Adobe 
Photoshop.

Movie format (Multi-view strokes only) for viewing an animation.

It is a very good idea to always save your document in Expression format. You never know when you might decide to make 
some very basic changes. If you have saved your document only in a bitmap format you might have to recreate the whole 
image to make a small change. 

See also:

Vector Or Bitmap

Setting Bitmap Resolution

Saving as Vector

Saving Multi-view Strokes As Movies 



Saving Multi-view Strokes As Movies

A Multi-view stroke can be rasterized, then saved as an animation or as a series of bitmapped still images. The animation 
can then be used in another application as a movie. 

When rasterizing Multi-view strokes the goal is to produce a sequence of bitmaps to make up an animation. To achieve this, 
more parameters are required. Based on the number of frames per second (fps) and the duration of the movie, Expression 
can rasterize the appropriate number of bitmaps. 

You must be in the Stroke Definition window and have open a Skeletal Stroke with two or more views.

Note: Only positions of nodes can be animated. Dragged paths do not animate.

Movie files can very easily take up several megabytes of hard drive space, since they are essentially sequences of many 
images (potentially hundreds). The following factors contribute to the size of a movie: frame size (height x width), frame rate 
(frames per second), duration (in seconds), and compression settings.

Not only do large movies take up a lot of space on your hard disk; they also tend to play very sluggishly on all but the fastest 
computers. You should experiment with the variables listed above to determine which settings produce movies that play 
smoothly on your computer and take up reasonable amounts of storage space. Below are some general guidelines which 
may help you. For more detailed information, consult the documentation that came with your multimedia authoring or video 
production software or hardware.

For video to be exported to tape and played back on television: 640 x 480 pixels, 30 fps, save as sequenced images, 
QuickTime, or AVI with no compression (most video production software and hardware solutions provide their own 
compression).

For multimedia productions to be played on a typical desktop computer: 320x240 pixels, 15 fps, save as QuickTime or AVI 
with moderate compression.

For web animation: Lower resolution, a small, fixed number of frames, save as sequenced JPEG images with compression. 
If you require GIF images, you will need to convert to GIF in another application.



Understanding Paths

A path is a continuous line made up of one or more curved or straight path segments. Each path segment is defined by a 
series of points. These points, and the tangent handles associated with the points, can be moved and edited to change the 
shape of the path. Expression uses standard computer graphics tools to draw and edit paths.

Two or more paths can be combined to make a compound path. A compound path is a set of paths which Expression treats 
as a single object. Compound paths are useful primarily for creating objects with holes. 

Every path has a beginning and end. Expression identifies the end point on a path with an arrow 
indicating the direction of the path. With an open path, it is very easy to identify the beginning and ending points. In a closed 
path, such as a circle or rectangle, the beginning and ending points are at the same location. Any path or shape you create 
can be defined as a Skeletal Stroke or can be combined with other paths or shapes to create a Skeletal Stroke. The Skeletal 
Stroke can then be applied to a path. 

The direction of a path is very important in Expression when using Skeletal Strokes. Since Skeletal 
Strokes often have a distinct start and end, you may want the stroke image to be pointing in a certain direction.

See also:

Drawing Tools



Saving as Vector

Your Expression artwork can be saved in the following vector-based formats:

Fractal Design Expression

Adobe Illustrator (*.ai)

Computer Graphics Metafile (Windows) (*.cgm)

CorelDRAW! Exchange (*.cmx)

Vector-based PICT (Macintosh)

WMF (Windows)

EPS (This type of file stores only printer information. Expression EPS files cannot be edited.)

See also:

Save

Save as Bitmap

Saving Documents

Vector or Bitmap



Undoing Operations

Multiple Undo allows you to undo and redo actions within Expression. This gives you the freedom to experiment freely 
without fear of making mistakes. 

The number of undos is set in the Preferences found under File menu> Preferences> Options. The default setting is ten 
levels.

Operations that cannot be undone provide you with warnings before allowing you to proceed. It is a good habit to save 
your file before performing such functions so you can choose File menu> Revert to Saved if you don’t like the changes.

See also:

Reverting to the Last Saved Version



Reverting to the Last Saved Version

Occasionally you will find it useful to revert to the last saved version of your file. This is especially useful if you have 
experimented with changes but decide you don’t want to keep the changes after all. You can also use the Undo/Redo 
function but there are some functions which can not be undone. In these instances, Expression warns you before you take 
the action. If you save your file just before such an action you can revert to the last version saved if you decide you don’t like 
the changes.

See also:

Undoing Operations



Closing Documents and Quitting

You can quit and close Expression documents the way you do other programs. 

Choose File menu> Exit or press Alt+F4.

See also:

Saving Documents



How an Expression Image is Made

Like most drawing software programs, Expression’s objects are comprised of paths. A path is a sequence of points 
connected together as lines or curves. Expression allows an arbitrary mixture of straight-lines, Bezier curves and B-Spline 
curves linked together to form a path. 

Each path is assigned a stroke and a fill. Stroke refers to the outline or edge of an object. Picking a stroke in Expression is 
similar to picking up an artist’s brush.

Fill refers to the inside color or pattern. Expression combines the stylistic expressiveness of paint, brush strokes and other 
traditional artists’ tools with the flexibility, speed, edibility and resolution independence of an advanced, vector based 
drawing application.

Most drawing programs are limited to the attributes which can be assigned to strokes and fills. Expression removes this 
limitation. With Expression, you can designate any vector picture as a stroke. This Skeletal Strokeª technology can be 
applied to boxes, text, freeform shapes, lines—anything you can create in Expression.

Expression uses three types of Skeletal Strokes:

Natural-Media strokes

Graphic Element strokes

Multi-view strokes

See also:

Expression Drawing Tools

Creating and Editing Skeletal Strokes

How is a Skeletal Stroke Created

Applying a Skeletal Stroke

Creating Multi-view Strokes



Cloning Objects

A clone is similar to a duplicate, but a clone maintains a link with the original or master object. A clone may be made from 
any path. Whenever the master object is edited (except for transformations and paint style) the clone is updated. 

A clone may be transformed and its paint style may be edited, but it can not be edited in any other way. A clone is 
represented on screen with only the node(s) at its ends visible and these nodes are displayed as filled circles. 

If you duplicate a clone you get a duplicate of the master object including the Paint Style from the master object.

You can not edit the shape of a clone object. Editing the shape of the master edits the shape of the clone in the same 
manner. Editing the paint style of the master object does not change the paint style of the clone.

You can change a clone into a master object, which can then be edited by breaking the link between the master object and 
the clone. Once the link is broken it can not be restored except by using Edit menu> Undo immediately.



Grouping and Ungrouping Objects

Grouping allows you to designate a set of objects to be treated as a single object. Any set of two or more objects, even 
groups, can be grouped. Any group can be ungrouped. 

Most Expression operations can be applied to a grouped object. For example, if you select a group, then apply a paint 
attribute to the group, the attribute is assigned to each element within the group.

However, individual objects and points within a group can not be selected separately with the Object Selection tool. To select 
individual objects within a group you need to use the Group Selection tool. To select individual points within a group use the 
Node Selection tool.



Duplicating Objects

You can create an exact copy of any object by duplicating it. You can duplicate by giving an explicit command or during a 
transformation, transforming only the duplicate while leaving the original untouched.



Arranging Objects

Expression provides several arrangement functions so you can quickly position selected objects in relation to each other. 
Arranging applies to objects, not individual points. All arrangement operations work along the document’s horizontal and 
vertical axes and are based on the objects’ rectangular bounding boxes.

There are three different arrangement operations that you can use with objects:

Align Arranges selected objects based on a particular line.

Distribute Arranges selected object equidistant from each other between the two extreme objects. 

Stack Arranges selected objects along the specified axis with a user-specified gap between the objects bounding boxes. The 
default gap size is 0 pts.

See also:

Aligning Objects

Distributing Objects

Stacking Objects. 



Aligning Objects

Use Expression’s Align function to arrange objects exactly in relation to each other. Alignment is always 
based on the object’s bounding box. A bounding box is the smallest rectangle that can enclose the entire object or group, 
including it’s tangent handles and shear/width handle.

Align has six variations:

Top The topmost selected object remains stationary while the other selected objects are moved vertically 
so that their tops align with the topmost object’s top edge.

Bottom The bottommost selected object remains stationary while the other selected objects are moved 
vertically so that their bottoms align with the bottommost object’s bottom edge.

Left The leftmost selected object remains stationary while the other selected objects are moved 
horizontally so that their lefts align with the left-most object’s left edge.

Right The rightmost selected object remains stationary while the other selected objects are moved 
horizontally so that their rights align with the right-most object’s right edge.

Vertical Center All of the selected objects are moved vertically so that their centers are aligned with the 
original center of the multiple selection.

Horizontal Center All of the selected objects are moved horizontally so that their centers are aligned with 
the original center of the multiple selection.

You can also choose Arrange menu> Align to select the alignment you want.



Distributing Objects

Use Expression’s distribute function to evenly space selected items in relation to each other. Distribution is especially useful 
for creating images such as a picket fence or railroad track. 

Distribute has six variations:

Horizontal Lefts The leftmost and rightmost selected objects remain stationary while the other selected 
objects are moved horizontally so that the left edges of all the selected objects are evenly spaced.

Horizontal Centers: The leftmost and rightmost selected objects remain stationary while the other 
selected objects are moved horizontally so that the centers of all the selected objects are evenly spaced.

Horizontal Rights The leftmost and rightmost selected objects remain stationary while the other selected 
objects are moved horizontally so that the right edges of all the selected objects are evenly spaced.

Vertical Tops The topmost and bottommost selected objects remain stationary while the other selected 
objects are moved vertically so that the tops of all the selected objects are evenly spaced.

Vertical Centers The topmost and bottommost selected objects remain stationary while the other selected 
objects are moved vertically so that the centers of all the selected objects are evenly spaced

Vertical Bottoms The topmost and bottommost selected objects remain stationary while the other selected 
objects are moved vertically so that the bottoms of all the selected objects are evenly spaced.

You can also choose Arrange menu> Distribute to select the distribution you want.



Stacking Objects

Use Expression’s stack function to arrange two or more objects so there is gap of a specified distance between their 
bounding boxes. Set the gap to zero when you want objects to touch but not overlap.

To set the gap size, choose File> Preferences.

Top (Up) The bottom-most object remains stationary while the other selected objects are moved vertically 
so that there is a vertical gap of the specified distance between each pair of neighboring objects.

Bottom (Down) The topmost object remains stationary while the other selected objects are moved 
vertically so that there is a vertical gap of the specified distance between each pair of neighboring objects.

Left The leftmost object remains stationary while the other selected objects are moved horizontally so 
that there is a horizontal gap of the specified distance between each pair of neighboring objects.

Right The rightmost object remains stationary while the other selected objects are moved horizontally so 
that there is a horizontal gap of the specified distance between each pair of neighboring objects.

You can also choose Arrange menu> Stack to select a stacking method.



Layering Objects

Each Expression document consists of one or more layers. A layer may contain any number of objects and every object is 
assigned to a specific layer although you can change its layer. 

Layers are ordered from front to back with back layers being drawn first and front layers being drawn last, possibly obscuring 
parts of back layers. Use this feature to control the appearance of the image. You can create and delete layers, assign 
names to layers, lock them, and change the display quality of specific layers. 

Any object on any unlocked layer may be selected and manipulated. A multiple selection may include objects on several 
different layers. Adding additional objects to a selection does not change the currently active layer. 

Removing objects from a multiple layer selection may change the currently active layer. If all remaining 
objects are from a single layer, that layer becomes the current layer.

You can use the Arrange menu> Layer command or the Layers palette to maintain your layers. To display 
the Layers palette, choose Window menu> Layers.

You can also choose Arrange menu> Layer.

See also:

Hiding Layers

Locking and Unlocking Layers

Changing the Active Layer

Changing the Selection Color



Hiding Layers

Layers can be hidden on your Workspace. This is useful if you do not want objects on the layer to be visible on the screen, 
you want to work on layers partially covered by other layers or you do not want certain layers to print.

From the Layers palette, click on the eye icon next to the layer you want to hide. Click again to display the layer.

See also:

Layering Objects



Locking and Unlocking Layers

Layers can be locked to prevent accidental changes to a layer.

Locked layers must be unlocked in order to edit or move objects within the layer.

You can also choose Arrange menu> Layer> Info. 

See also:

Layering Objects



Changing the Active Layer

All new objects are created on the active layer. When you want to add an object to a particular layer, make it the active layer

See also:

Layering Objects



Changing the Selection Color

Each layer is identified by its own color. This color appears as an outline on any selected object within a layer. The selection 
color can be changed as needed to assist you in identifying different layers.

See also:

Layering Objects



Editing Paths

Edit a selected path with the following tools:

Node Selection tool

Convert Node tool · Add Node tool

Delete Node tool

Split Path tool

Reverse Path tool

Change Start Point tool 

See also:

Selecting and Moving Points

Changing Point Continuity

Converting Points

Adding Points

Deleting Points

Splitting Paths

Reversing Path Direction

Changing the Start Point

Unstructuring Objects

Converting Objects to Bezier Paths

Editing Ellipse



Selecting and Moving Points

The Node Selection tool lets you select a particular point along a path. Selected points are shown as filled squares. Use this 
tool also to manipulate handles to alter the shape of your path.

Using the Node Selection tool from the Tools toolbar, select a point. A selected point is displayed as a 
large filled square and its tangent handles as well as the tangent handles before and after the point, if 
any, are also displayed. 

Drag the BŽzier point to reposition it.

Drag the point’s tangent handle or an adjacent line segment to edit the shape of the path. Tangent 
handle behavior depends on the assigned Node Continuity

Freehand tool Smooth

Smoothed Polyline tool Smooth

Pen tool Symmetrical

Polyline tool Unconstrained



Changing Point Continuity

Expression gives you several choices for the behavior of tangent handles when you are editing. This makes it easier for you 
to edit your paths just the way you want to. Set your preference by selecting Edit menu> Node Continuity Mode or by 
clicking on the preferred button in the Actions toolbar. 

To select a toolbar not currently visible choose Window menu> Toolbars. 

Symmetrical Tangent handles remain opposite each other and equidistant from the point itself. 

Smooth As you move one tangent handle the other handle remains opposite but the distance between 
the point itself and the other handle is not changed. 

Angle Locked As you move one tangent handle, the other handle moves so that the angle between the 
two handles is maintained.

Unconstrained Moving one tangent handle does not change the position of the other tangent handle at 
all. 



Converting Points

The Convert Node tool changes a corner point, with tangent handles pulled in, into a curve point with tangent handles visible 
for manipulation. The same tool changes a curve point, with tangent handles visible, into a corner point with tangent handles 
retracted. It also changes the Node Continuity when used on a tangent handle.

Click on a BŽzier curve point to retract both the preceding and following tangent handles, turning it into a BŽzier corner 
point.

Click a standard B-Spline point to turn it into a B-Spline cusp point.

Click a standard B-Spline cusp point to turn it into a standard B-Spline point.

Drag on a BŽzier corner point to turn it into a BŽzier curve point and show its tangent handles.

The drag gesture determines the positions of the new tangent handles, just as drag behaves when drawing with the Pen 
tool.

Hold down the Shift key while dragging to constrain the angular relationship between the opposite tangent handle and the 
BŽzier point.

Hold down the Option/Alt key before or during the drag gesture to lock the opposite tangent handle in its current position: 
the drag thus affects the position of one tangent handle only. If you release the Option/Alt key before releasing the mouse 
button, the opposite tangent handle snaps back into the position symmetrically opposite the tangent handle you have 
moved.

Drag on a tangent handle to change its position or move it. This action causes the path segment to change. 

If the initial constraint is Unconstrained, the constraint is changed to Symmetrical. The two tangent handles are opposite 
each other and move appropriately as you drag.

If the initial constraint is Symmetrical, Smooth or Angle Locked the constraint is changed to Unconstrained and the 
tangent handles move independently of each other as you drag.

For more information on constraints, see Node Continuity Controls. 



Adding Points

The Add Node tool allows you to add additional points to an existing path segment.

Adding a point to a B-Spline path converts the path to a BŽzier path. 

Adding a point to an existing path segment does not affect the shape of the path. 

Clicking on a point has no effect.

It is even possible to create a path with B-Spline controls for part of the shape and Polyline or other controls for a different 
part of the path.



Deleting Points

The Delete Node tool allows you to remove points from an existing path segment.



Splitting Paths

The Split Path (scissors) tool allows you to split an existing open path into two paths, or to open an existing closed path.



Reversing Path Direction

Since the beginning point and the direction of a path are important considerations in how you apply Skeletal Strokes, 
Expression allows you to define which point is the beginning point as well as set the direction of a path.

Expression allows you to change the direction of your path. This is especially useful with Skeletal Strokes that are not 
symmetrical.

There may be times when you want to reverse the direction of a path and other times when what you really want to do is 
mirror the image. For additional information on mirroring, see Transformation tools.

You can also choose Objects menu> Reverse Path to reverse the direction of a path.



Changing the Starting Point

On a closed path such as a rectangle or circle, you may want to change the starting point for your path. This affects the way 
Skeletal Strokes are applied to the path.

Click at the desired start point.

If there is no existing point at the place you wish to designate as the new start point use the Add Point tool to add a point 
then use the Change Start Point tool to select the new point.

Using the Change Start Point tool on an open path causes the path to become closed. 



Unstructuring Objects

Expression allows you to take a Skeletal Stroke that has already been applied to a path and unstructure the stroke so you 
can edit its shape.

Before you can unstructure a stroke applied to text, you must first convert the text to a path using the Convert to Path 
command.



Converting Objects to Bézier Paths

There may be instances when it would be easier to start out with a regular text or shape object, such as a letter or an ellipse, 
then convert it to a BŽzier path (or paths). This allows you to have more control over the shape of an object.

You can select any object or combination of objects to work on separately. You can edit the shape of an individual letter by 
selecting a point with the Node Selection tool.



Editing Ellipses

Unlike circles or ovals from other drawing applications, the Expression ellipse is a special case shape object. An ellipse 
consists of only one point. By dragging this point, you can create a partial ellipse.

Open Arc No connection between the ends of the ellipse.

Pie A straight line segment connects each end of the ellipse with the center point of the ellipse.

Add Chord A straight line segment connects each end of the ellipse with the other end.



Natural-Media Strokes

These strokes mimic traditional artist tools such as paint brushes, pencils and pens.

See also:

Graphic Element strokes

Multi-view strokes



Graphic Element Strokes

These strokes contain vector drawings and objects. You can create a stroke out of any vector graphic.

See also:

Natural-Media strokes

Multi-view strokes



Multi-View Strokes

Multi-view strokes incorporate both Natural Media and graphic elements and consist of two or more related pictures. 
Expression automatically creates additional views in between those you start with, allowing you to quickly create related but 
non-identical images. 

For example, you create a Multi-view stroke of a hand. The first view shows the hand pointing the index finger. The second 
view shows the hand in the open position. Expression creates in between views showing varying degrees of the hand open 
and closed. Each time you apply this stroke you can specify which view is displayed or let Expression create them randomly. 
Multi-view strokes can also be saved as animations. (QuickTime for Macintosh or AVI for Windows)

See also:

Natural-Media strokes

Graphic Element strokes



Expression's Interface

Expression’s interface consists of several types of toolbars and palettes. Some of the toolbars and palettes open 
automatically when you launch Expression. You can hide, display or move any or all of the toolbars and palettes on your 
workspace to meet your particular working style.

See also:

Toolbars

Palettes

Sizing your workspace

Rulers

Show Grid

The Status Bar

Multiple Windows

Navigating your document

Zooming in and out

Using the Grabber Tool

Changing your view

Creating a new view



Select By

Use the Select By function to select objects that share the same attribute(s). To use choose Edit menu> Select By. The Select By 
dialog box appears. Click to select all objects that share the same stroke, outline color and/or fill type.



Toolbars

Expression’s interface consists of several types of toolbars and palettes. Some of the toolbars and palettes open automatically 
when you launch Expression. You can hide, display or move any or all of the toolbars and palettes on your workspace to meet your 
particular working style. 

Expression has a variety of toolbars allowing you do design the workspace to match the way you like to work.

To select which toolbars are displayed:

Choose Window menu> Toolbars. The Toolbars dialog appears. Toolbars currently displayed on your workspace have a 
check mark in front of their name.

Click to select or deselect the toolbars you want to display.

Click OK. All selected toolbars appear on the workspace. You can resize and move toolbars as needed.

See also:

Moving and Resizing Toolbars

The toolbars include:

Standard toolbar

Composition toolbar

Tools toolbar

Actions toolbar

Miscellaneous toolbar



Miscellaneous Toolbar

The Miscellaneous Toolbar controls Blending and Boolean Operations. Choose Window menu> Toolbars: Miscellaneous to 
toggle the Miscellaneous toolbar on or off.

Blend Paths

Creates a series of new paths based on two selected paths.

See also:

Boolean Operations



Boolean Operations

Expression offers standard Boolean operations, allowing you to create new shapes based on different original object.

Union

Creates a new path based on the outline of all selected source paths as if they were merged into one object. Paths inside 
are ignored.

Back-Front

Creates a new path that contains areas in the back path that are not overlapped by areas of the front path.

Front-Back

Creates a new path that contains areas in the front path that are not overlapped by areas in the back path.

Intersection

Creates a new path that contains areas where the selected source paths overlap. Areas and paths that do not overlap are ignored.



The Actions Toolbar

The Actions toolbar includes controls for the behavior of node tangent handles as well as the Ellipse Closure controls, 
Anchor and Repeat controls and the Pressure Sensitive buttons. Choose Window menu> Toolbars: Actions to toggle the 
Actions toolbar on or off. 

The Actions toolbar contains the following buttons:

Node Continuity Controls

Ellipse Closure Controls

Anchor Controls

Repeating Controls

Pressure Sensitive Controls



Pressure Sensitive Controls 

These buttons toggle pressure sensitivity on or off. These functions are only available when a pressure sensitive drawing 
tablet is used instead of a mouse.

Disable Pressure Sensitivity

Allows a pressure sensitive graphics tablet to behave just as a mouse device.

Enable Pressure Sensitivity

Allows you to control the width of a stroke based on the amount of pressure applied when using a pressure sensitive 
graphics tablet. Light pressure results in thin stroke, while heavy pressure results in thicker stroke.



Repeating Controls

These tools, which are only available when the Stroke Def. Box window is active and then only when the Repeating tool has 
been used to select objects to repeat, control the behavior of repeating nodes. 

To use, first use the Stroke Def. Box tool to drag a marquee around the objects you wish to use as a Skeletal Stroke. 
Second, use the Repeating tool to drag a marquee that selects the objects you wish to repeat. Thirdly, click the Make 
Repeating button to make the selected objects repeating or click the Make Non-repeating to remove the repeating function 
from the selected objects.

Make Repeating

Repeats the selected part of stroke based on length of path.

Make Non-repeating

Removes the repeating function from the selected objects.



Anchor Controls

These tools, which are only available when the Stroke Def. Box window is active and then only when the Anchor tool has 
been used to select points to anchor, control the behavior of anchored points. 

To use, first use the Stroke Def. Box tool to drag a marquee around the objects you wish to use as a Skeletal Stroke. 
Second, use the Anchor tool to drag a marquee that selects the points you wish to anchor. Thirdly, click the Anchor Control 
that describes the type of anchor you wish to apply to the selected nodes.

Anchor at Start

Constrains selected points to the start of the Skeletal Stroke as it is applied to a path. 

Anchor at End

Constrains selected points to the end of the Skeletal Stroke as it is applied to a path.

Anchor at Fixed Point

Constrains selected points to a specific part of the Skeletal Stroke as it is applied to a path.

No Anchor

Removes anchor constraint from selected point.



Node Continuity Controls

.A pair of tangent handles is attached to each node on a path. The position of the tangent handles controls the shape of the 
path between nodes. Nodes that are corner points have their tangent handles retracted so you can not see them. 

The Node Continuity buttons determine how selected nodes and handles are controlled when editing. Select a node then click the 
preferred Node Continuity button.

Symmetrical

Positions the tangent handles so they are opposite each other and equidistant from the node.

Smooth

Positions the tangent handles so they are opposite each other. In this case, changing the distance from 
the node of one handle does not change the distance of the other. 

Angle Locked

Positions the tangent handles so they are locked in relation to each other. Moving one handle causes the 
other handle to move the same distance and direction.

Unconstrained

Allows tangent handles to move independent of each other.



Ellipse Closure Controls

These buttons allow you to control how an open ellipse is closed. Expression’s ellipse is a special case object. After creating 
an ellipse you can drag its single point with the Select Node tool to open it up, then use one of the following buttons to 
complete the shape.

Open Arc

Allows you to create an open ellipse line segment.

Pie

Allows you to create an ellipse line segment closed by a pair of straight lines. These lines connect with 
each other in the center of the ellipse.

Add Chord

Allows you to create an ellipse line segment with a flat side. The ellipse is closed by a straight line segment 
from beginning point to ending point.



Moving and Resizing Toolbars

To change the location of a toolbar click-drag in the gray toolbar frame area. Drag the toolbar to the middle of the window to 
let the toolbar float or drag a floating toolbar onto the left or top toolbar area to dock the toolbar.

The floating toolbars can be resized by click-dragging at the corners. Reposition a floating toolbar by click-dragging its title bar.



The Standard Toolbar

The Standard toolbar contains buttons for basic File menu commands. Choose Window menu> Toolbars: Standard to toggle 
the Standard toolbar on and off. The Standard toolbar contains the following buttons:

New File

Open File

Save File

Print

Cut

Copy

Paste



New File

Creates a new Expression document.



Open file

Opens the standard Open dialog, allowing you to open an existing Expression document or graphics file. To limit file type to 
a specific file format, select the preferred type from the Format or Files of Type field.

Expression can open and use most vector based artwork.

See also:

Opening Existing Documents

Opening Clipboard Images

Vector or Bitmap



Save file

Saves the current document to hard drive or floppy diskette.

See also:

Vector or Bitmap

Saving Documents

Saving as Vector

Saving as Bitmap

Saving Multi-view Strokes as Movies



Saving as Bitmap

Expression allows you to save your artwork in the following bitmap formats:

Adobe Photoshop 2.5

TIFF/TIF

Targa (Windows)

PCX (Windows)

PhotoPaint (Windows)

Bitmap PICT (Macintosh)

BMP

JPEG (without LZW compression)

See also:

Anti-Aliasing

Bitmap settings



Print

Displays the standard Print dialog, allowing you to print the current document. 

See also:

Printing from Expression



Cut

Removes selected object(s) from the workspace and saves the selection to the Clipboard until another selection is cut or 
copied. 



Copy

Copies selected object(s) to the Clipboard and saves the selection until another selection is cut or copied. 



Paste

Inserts information previously stored in the Clipboard into the document



The Composition Toolbar

The Composition toolbar contains buttons that allow you to edit your document by clicking rather than using command 
keystrokes. Choose Window menu> Toolbars: Composition to toggle the Composition toolbar on and off. The Composition 
toolbar contains the following buttons:

Select All

Deselect All

Delete Selection

Up One

Down One

To Top

To Bottom



Select All

Selects all objects in the current document.



Deselect All

Deselects all objects in the current document.



Delete Selection

Deletes all selected objects. The objects are not stored in the Clipboard. However, you can use Expression’s Undo function 
to return the deleted selection.



Up One

Moves the currently selected object up one level in the stack order of the current layer.



Down One

Moves the currently selected object down one level in the stack order of the current layer.



To Top

Moves the currently selected object to the top level of the stack on the current layer.



To Bottom

Moves the currently selected object to the bottom level of the stack on the current layer.



Tools Toolbar

The Tools toolbar contains tools for basic object drawing and manipulation. Choose Window menu> Toolbars: Tools to toggle 
the Tools toolbar on and off.

The Tools toolbar contains the following set of tools:

Selection tools

Editing tools

Navigation tools

Drawing tools

Attribute control tools

Transformation tools

Definition tools



Navigation tools

Grabber Tool 

Provides an alternative way to scroll an image. Click in the workspace and drag to move the page.

Magnifier Tool 

Allows you to magnify areas of an image when you are performing detailed work, or reduce your workspace to get an overall 
view of an image. Click to zoom in, or hold the Command/Ctrl key and click to zoom out. You can also drag a marquee to 
zoom into a specific area.



Drawing tools

Expression includes a variety of drawing tools and object creation tools including:

The Classic Drawing Tools

Supplemental Drawing Tools

Line Tool

Shape Object Tools

Text Tool 



Classic Drawing Tools

These tools are used to draw freeform shapes. After creating paths, you can use the Path tools to edit any path.

Freehand Tool

Creates shape paths by drawing freehand lines.

Pen Tool 

Creates shape paths using standard Bezier points.



Supplemental Drawing Tools

Expression’s Polyline, B-Spline and Smoothed Polyline tools provide additional ways of creating paths. These are especially 
useful for creating stylized artwork.

Polyline Tool

Draws straight line and circle arc line segments.

B-Spline Tool

Draws smooth curved line segments based on straight line control polygon.

Smoothed Polyline Tool

Draws curved line segments.



Line Tool

Draws straight lines. Hold down the Shift key to constrain your line to 45¡ increments. For information on changing the angle 
of constraint see Preferences: Options: Arrangement



Shape Object Tools 

These tool are used to draw rectangles, squares, ellipses (ovals) and circles.

Rectangle Tool

Creates rectangles and squares. Hold down the Shift key to constrain the object to a square.

Ellipse Tool

Creates ellipses or circles. Hold down the Shift key to constrain the object to a circle.



Text Tool

Creates text objects. Text objects can be applied to a path. Each letter can be assigned a distinct stroke and fill. Text can be 
converted to a path so you can edit the shape of each letter.



Attribute control tools

Use these tools to control stroke and fill attributes of your objects.

Gradation Tool

Controls the direction and rate of change for a gradient stroke or fill.

Dropper Tools 

These tools allow you to quickly copy color or stroke and fill attributes from one part of your artwork to 
another.

Color Dropper Tool

The Color Dropper tool picks up color from one object, or area of an object, so you can drop the color 
onto another object or area. 

Attribute Dropper Tool

The Attribute Dropper tool picks up the stroke and fill attributes from one object, so you can drop the 
attributes onto another object.



Transformation tools

These tools are used to transform selected objects by rotating, scaling, mirroring, shearing, or changing its perspective.

Rotation Tool

Allows you to rotate selection. Click to set the center of rotation, then click drag to rotate selection.

Scale Tool

Allows you to change the size of selected object. Click to set the anchor for the scaling, then click drag to 
scale selection. 

Mirror Tool

Allows you to create a mirror image of the selected object. Click to set the center for the reflection, then 
click drag to mirror the selection.

Shear Tool

Allows you to shear or skew the selected object. Click to set the center for the shear, then click drag to 
skew the selection.

Perspective Tool

Allows you to change your perspective of the selected object. Click on the tool, then click drag a corner of 
the bounding box to change the perspective of the selection.

See also:

Transforming Objects



Definition tools

These tools are used to define Skeletal Strokes as well as Patterns to use as fills. This group of tools includes:

The Stroke Definition Box

The Pattern Definition Box

Anchor and Repeat Tools



Stroke Definition Box

Opens the Stroke Definition window, allowing you to create a Skeletal Stroke. Choose the Stroke Def. Box tool and drag a 
marquee around the artwork you wish to use as a Skeletal Stroke. The Stroke Definition window opens. To complete the 
stroke, click the Define button at the bottom of the window. Give your stroke a name.

See also:

Creating and Editing Skeletal Strokes



Pattern Definition Box

Opens the Pattern Definition window, allowing you to define a new pattern. Choose the Pattern Def. Box tool and drag a 
marquee around the artwork you wish to use as a Pattern. The artwork within the marquee is repeated as a pattern. To 
complete the stroke, click the Define button at the bottom of the window. Give your pattern a name. If you decide you don’t 
want to keep the pattern hit Delete while the pattern box is selected.

See also:

Applying Pattern Fills



Anchor and Repeat Tools

These tools are used to control the behavior of particular parts of a Skeletal Stroke and are available only when the Stroke 
Definition window is active. As a Skeletal Stroke is applied to a path it can be useful to have certain parts maintain their 
original proportions, while other parts of the same stroke are stretched along the path. Likewise, it can be useful to specify 
that certain parts should repeat along the path, rather than stretch.

See also:

Anchor Tool 

Repeat Tool 



Anchor Tool

Allows you to anchor selected points so they remain a constant proportion when a Skeletal Stroke is applied to a path. This 
is used when you want specific parts of a Skeletal Stroke to maintain their original proportions. For example, the dog stroke 
below is defined with the head and tail parts anchored to the beginning and ending points of the stroke. The section between 
the two anchored areas can stretch on any long path but the tail and head remain the same.

To use this feature you must first use the Stroke Def. Box tool to select artwork that will be used as a stroke.



Repeat Tool

Allows you to define selected objects to repeat rather than distort as Skeletal Stroke is applied to path. For example, you 
might create a train with an engine, a passenger car and a caboose. Anchor the engine to the beginning point and the 
caboose to the ending point. Then define the passenger car as repeating. The length of path to which you apply such a 
stroke determines how many passenger cars are contained in your train.



Selection Tools 

The Object Selection and Group Selection tools allow you to select individual objects or groups of objects.

Object Selection Tool Selects objects or groups of objects.

Group Selection Tool Selects an individual object within a group.

Node Selection Tool Selects points on a path.



Editing Tools 

These tools are used to edit paths and point on paths.

Convert Node Tool

Add Node Tool

Delete Node Tool

Split Path Tool

Reverse Path Tool

Change Start Point Tool

See also:

Editing Paths



Stroke Definition Options Dialog

Use this dialog to name your new Skeletal Stroke, to set its default width and to select a location for storing the stroke.

See also:

Creating and Editing Skeletal Strokes



Save Stroke

When you create or edit a Skeletal Stroke by save your stroke by clicking the Define button at the bottom of the document window. 
Select a directory or folder where the stroke should be stored. Give the stroke a name and set its default width. Click OK. When 
you edit a stroke, if you save it with the same name the original stroke is replaced by the edited version.

See also:

Creating and Editing Skeletal Strokes



Paint Style Palette

This palette controls how your path is displayed including stroke, fill and color. Use the Paint Style palette to assign the stroke and 
fill you prefer. 

Your stroke may be none, Basic (a fixed width with solid color), Gradient (a fixed width with gradient color) or a Skeletal Stroke. 
Use the Stroke tab to select the style of stroke you prefer.

Your fill may be none, a plain color, a gradient or a pattern. Use the Fill tab to select the style of fill you prefer.

The Colorize tab of the Paint Style palette gives you several ways of controlling the colors used in your strokes. These colors are 
based on grayscale values. Changes made in this area affects all selected objects and any new path you draw while the same 
Skeletal Stroke is selected.

See also:

Applying Paint: The Paint Style Palette



Custom Color Palette

This palette contains a list of custom colors which you can apply to any document.

See also:

Using Custom Colors



Color Palette

This palette controls the use of colors. When you set the stroke and/or the fill to plain color or a gradient, you can then use the 
Color palette to apply colors. Select a color model, then click on the color wheel to see the range of colors available in the Value 
Picker. Click to apply a color.

See also:

Using the Color Palette



Stroke Warehouse

This palette contains a selection of pre-designed Natural-Media, Graphic Element, and Multi-view strokes. Each stroke can be 
thought of as a customized brush. Strokes can be applied to any path in Expression.

Click to select a Skeletal Stroke. Double-click a Skeletal Stroke to edit it.

See also:

Applying a Skeletal Stroke



Layers

Use the Layers palette to switch between layers.

Click the lock icon to lock or unlock the layer.

Click the eye icon to make the layer visible or invisible.

Click hold the arrow icon above the scroll bar to view the Layers menu, which allows you to create a new layer, delete a layer or 
open the Layer Information dialog  Use this menu also to change the order of layers or move a selection from one layer to another.

See also:

Layering Objects



Layer Information Dialog

Use this dialog to control layers. Name a layer by entering the name in the Layer Name box.

Click to make the layer visible or locked.

Click to set the display quality.

Select a unique color for the layer.

See also:

Layering Objects



Gradient Editor Palette

Use the Gradient Editor Palette to create and edit gradients. Select a gradient from the list. To edit a gradient select a triangle 
below the sample bar, then select a new color from the Color palette. 

Click New to create a new gradient. Assign the new gradient a name then select it from the list and edit the gradient.

Click to select linear gradient or radial gradient.

See also:

Applying Gradient Strokes

Applying Gradient Fills



Preferences

Expression’s preferences enable you to customize Expression to the way you like to work. There are four tabs to take you to the 
specific areas you can customize.

Options 

Color match

View and palettes 

Raster/Scratch 



Preferences: Raster/Scratch

This tab provides you the option for selecting a scratch disk and plug-in directory.

Scratch Disk: Use Select a disk that has plenty of free space.The scratch disk is used only when rasterizing. It should only be 
necessary when you do not have enough RAM to keep the entire rasterized image in memory.

If transparency is used in the image, Expression must rasterize the image before printing, since PostScript does not support 
transparency.

Plug-Ins: Set Directory The only plug-ins Expression uses are file format input/output filters. By default, Expression looks for 
these plug-ins in its own plug-ins directory. The only time it is necessary to change this directory is if you have other PhotoShop-
compatible file format filters in another directory and want to use those instead of the filters supplied with Expression.



Font Palette

Use this palette to select the font and other attributes for Text objects.

See also:

Text tool



Bitmap Settings

Any artwork that includes transparency must be converted to bitmap before printing. 

To print artwork that includes transparency:

Choose File menu> Print, then select Rasterize before Printing and set the dpi appropriate for your printer.

You may want to take artwork created in Expression into an image processing application for further work. To do so choose File 
menu> Save Bitmap. 

Expression allows you to save your artwork in the following bitmap formats:

Adobe Photoshop

TIFF/TIF

Targa

PCX

PhotoPaint

BMP

JPEG (without LZW compression)

See also:

Keep proportions

Width and Height

Anti-aliasing

Set Resolution

Save as Bitmap



Set Resolution

When you save a file as a bitmap you can select the size and resolution of the file. Multi-view strokes saved as movies also have 
the same options.

Resolution, in general, refers to the number of dots per inch (dpi) that make up an image. The default resolution setting is screen 
resolution or 75 dpi. The image on-screen at 100% is the size it will be when it’s output. On most printers, 75 dpi bitmap renders a 
coarse image, so you may want to choose a higher resolution value.

If you are using a personal laser printer, set your bitmap Width and Height in inches, centimeters, points or picas. Set resolution to 
the dpi your printer supports. Your file will be output correctly at the best resolution for your laser printer and at the proper size.

If you are using a commercial printer or a more sophisticated output device, the dimensions should always be set to the actual size 
it will appear in the printed piece. It’s a good idea to check with your service bureau if you have questions about output device 
resolution.

See also:

Save as Bitmap



Anti-aliasing 

Anti-aliasing is a process used to make color images appear smoother when the image includes curved and diagonal areas with 
high contrast. Without anti-aliasing the curves and diagonal lines may appear to be stairstepped.

With the Anti-Alias option enabled, Expression modifies areas with stairstepping, changing some pixels to intermediate colors. For 
example, if your image is a red and yellow beachball on a blue background, individual pixels along the edge of the ball are 
changed to shades of orange and green, fooling the human eye into “seeing” a smoother curve. 

Unless you are working on a project which specifically requires that images not be anti-aliased, such as multimedia cast members, 
there is no reason to disable the Anti-aliasing option. Anti-aliasing does not significantly increase the time required to rasterize an 
image.

See also:

Save as Bitmap



Width and Height

Set the width and height you prefer for your bitmap image. Use the drop down menu to select points (pts), inches (in.) or 
centimeters (cm). When Keep Proportions is selected changing one measurement automatically changes the other.



Keep proportions

Select Keep proportions to keep the aspect ratio of the original artwork. Deselect Keep proportions to crop the image as it is 
rasterized.



Preference Options Sub

This tab controls settings for various options including:

Tools

Objects

Arrangement

Miscellaneous



Preferences: Options: Miscellaneous

No fill with Skeletal strokes When this option is enabled, choosing a Skeletal Stroke automatically removes any fill which has 
been applied. If you want to fill an object which has a Skeletal Stroke applied, you can choose the stroke first, then apply a fill. 

When this option is disabled, the Skeletal Stroke uses whatever fill is active in the Paint Style palette. In most cases you probably 
do not want a fill with a Skeletal Stroke.

Undo levels Sets number of Undo levels. Higher levels of Undo use up more RAM.



Preferences: Options: Arrangement

Angular constraint steps Sets the angle of constraint when holding down the Shift key while moving or rotating an object.

Nudge increment Sets the increment applied when you use the keyboard arrow keys to move an object.

Stack: Gap Size Sets the size of the gap (in points) between objects when using the Stack function.



Preferences: Options: Objects

Quick (area) select Determines whether clicking on a fill area selects an object or whether you need to click on the path itself in 
order to select an object.

Transform patterns Controls the way a pattern is handled when an object containing a pattern is transformed (rotated, skewed, 
scaled). When this option is enabled, the pattern is applied to the object before the transformation and therefore transforms with 
the object. When this option is disabled the object is transformed and then the pattern is reapplied and not affected by the 
transformation.

Path operations: keep originals Toggles on/off to keep or discard original objects after performing a Boolean operation. 

Show resize handles Toggles on/off the on-screen resize handles that appear around selected objects. When on (default), resize 
handles are displayed at the corner of the bounding box and the transform handles appear on the top, bottom and sides.

When off, the path itself appears in color but no handles appear.



Preferences: Options: Tools

Drawing tools: append to path When this option is enabled (the default), all drawing tools (except the Freehand tool) can be 
used to append points to an existing path. Just position the cursor over the endpoint of an existing path before starting to draw—a 
~ is added to the cursor, indicating that it is ready to append points to the existing path.

When this option is disabled, none of the drawing tools append points to existing paths. Clicking on the endpoint of an existing 
path creates a new path starting at that point. By holding down the Shift key, you can force any drawing tool to append points to an 
existing path.

Freehand Tool: Tightness of fit Controls the precision with which the path follows the movement of the mouse or stylus pen 
when using the Freehand tool. If the setting is too high every minor waver is captured, possibly resulting in a line that is quite 
irregular. If the setting is too low the resulting path may be less precise than you intended. 

In most cases the default setting should give you acceptable results. 

Color Dropper: resets primaries This preference determines what happens when you use the Color Dropper tool to drop color 
onto an object whose colors have already been adjusted using the Foreground/Background color swatches or the Colorize 
controls.

When this preference is enabled (the default), using the color dropper automatically resets the Colorize or Foreground/Background 
information. This ensures that the color you're dropping is the color you actually see on the object.

When the preference is disabled, the color you drop may not be the color you see on the object. For example, suppose you have a 
grayscale stroke with the foreground color set to red, so your entire stroke appears in reds of varying shades. Then suppose you 
use the color dropper to drop black into an area of your stroke which is currently medium red. The spot where you drop the color 
will not appear black, but instead will appear full red. This is because the red foreground color transforms all black regions within 
the stroke into red.



Preference Color match

Use the Color Match tab to calibrate your monitor for the best match possible when printing to a color printer. 

Choose File menu> Preferences. The Preferences dialog appears. Click the Color match tab. The dialog displays the color match 
selections.

In the gamma field, enter the same target gamma setting you used in Fractal Design Painter, Adobe Photoshop,.Adobe Illustrator 
or CorelDRAW! to calibrate your monitor in that application. 

If you have not calibrated your monitor in one of those applications, leave the gamma setting at the default 1.8. If you are using a 
third party monitor calibration utility, type in your gamma setting from that application.

Hold the color printer’s progressive color bar up to the monitor and adjust the RGB sliders to match the screen colors as closely 
as possible to the printed colors.

If you are using a paper color other than white, set the color patch labeled “White” to match the color of your paper. This will 
compensate for the color of your paper and better match the colors you see on your screen. Click OK. 

To return the Color Match settings to the default setting click the Reset to Default button. To return to the last settings, prior to 
recent changes, click the Reset to last button.



Hatch Dialog

Expression can fill an object with a hatching pattern based on the value of the colors beneath the object. To hatch, select object 
then choose Objects menu> Hatch. The Hatch dialog opens. Select the hatching pattern from the Hatch Pattern list.

Scale the pattern by entering a value in the Scale Pattern entry box or click on the up and down arrows. This option can be used to 
enlarge or reduce the size of the tile used in the pattern.

Click Scale Stroke Width to control the width of each hatching stroke based on the light and dark intensity of the background color. 
Control the contrast by adjusting the Min. Intensity scale and/or Max. Intensity scale. When this checkbox is deselected, hatching 
behaves just like a pattern.

Click Use Background Color to apply hatching over the object’s original color. When this option is deselected, hatching is applied 
to the object based on the intensity of the original color. The color is discarded and only hatching remains.

Click Keep Original Paths to include the object’s original path in the hatched image. When this option is deselected, the path itself 
is discarded and the resulting object consists of only the hatching pattern.

Click OK. The hatch is applied to the selected object. 

See also:

Applying Hatching



Hatching

With Expression you can mimic and extend the traditional pen and ink shading technique known as hatching. Hatching generates 
a pattern of strokes whose characteristics vary based on the contrasting lightness/darkness of the source imagery you provide. 

The shape, thickness and relative placement of individual lines within the hatching pattern determine how the object is perceived. 
Hatching can indicate depth or curvature as well as distance and texture. Hatching is one of the features that gives Expression its 
exciting Natural Media feel.

Hatching is applied to a path, which defines the boundary of the region to be hatched.

If the path is unfilled, the artwork stacked beneath the path is used as the source imagery for the hatching operation. The variety of 
the hatching depends on the varying lightness and darkness of the source image.

If the path is filled, for example, with a gradient or pattern, the fill itself is used as the source image for the hatching operation and 
any underlying artwork is ignored.

In addition to selecting a path, you must choose your hatching pattern. Hatching patterns are specialized patterns composed of 
strokes. Variations in the hatching are achieved by varying the characteristics

See also:

Hatch Dialog



Preference View SetUp

This tab provides you options for the view displayed in your workspace and options for some of the palettes. These settings are 
applied when creating a new document.

Set preferences for:

Grid

Color palette

Display Quality

Stroke Warehouse



Preference: View and palettes: Grid

Snap to Grid    This option determines whether or not the Snap to Grid function is enabled when a new document is created.

Snap to Nodes When this function is enabled Expression automatically moves to the closest node on a selected path when you 
perform any action that applies to a node.

Show Grid Toggles on/off a non-printing grid that is useful for precise placement of points and objects. This option determines 
whether or not the Show Grid function is enabled when a new document is created.

Grid Spacing Sets the spacing/size for the grid in the workspace.



Preference: View and palettes: Color Palette

Draggable Color Wheel When this option is enabled, drag to rotate the Color Wheel. The color touching the point of the Value 
Picker triangle or diamond is the active color. When this option is disabled the Color Wheel is stationary and you click the desired 
color to make it active. The Value Picker reflects the current color selection.

Color Palette Border Sets the display for the Color palette with no border between colors in the Color Table, with black border 
between colors or with white border between colors. 



Preference: View and palettes: Display Quality

Display Quality Determines the view Expression defaults to when a new document is created. You can choose from Path, 
Wireframe or Preview views. 

Greek limit (pts) Sets the minimum size for a font to be displayed on screen. Fonts smaller than this size display as gray lines 
rather than actual text.



Preference: View and palettes: Stroke Warehouse

Animated stroke thumbnails Toggles on/off the animation of stroke thumbnails in the Stroke Warehouse list. When this option is 
enabled, the Stroke Warehouse displays the currently selected stroke as an animation demonstrating how the stroke may appear 
when applied to a path. This is particularly useful for Multi-view strokes.



Alignment Palette

Use the Alignment palette to Align, Distribute or Stack object.

Select two or more objects then click to set the Align or Stack method. Select three or more objects when using the Distribute 
function.

See also:

Aligning Objects



Blending Function

With Expression you can create a series of new paths based on two different source paths. 

The Blend command allows you to specify the number of steps in the blend, then automatically generates the new paths 
based on the characteristics of the source paths. The resulting paths are placed into a single group. The original source 
objects are left untouched.

The following characteristics are interpolated:

Color, Line/Stroke width, Stroke opacity, Shape parameter of Multi-view strokes, and location in relation to each other

Characteristics which can not be interpolated (Stroke definition, cap/join types, outline/fill types) are taken from the first 
source path.

See also:

To blend paths. 



To blend paths

Create two paths. These paths may be open or closed but may not be grouped. They both must be assigned the same 
Skeletal Stroke. This command cannot blend two different types of strokes.

Choose the Blend button from the Miscellaneous toolbar or choose Objects menu> Blend Paths.

Specify the number of steps in the blend. Use the up and down arrows to enter a number in the entry box.

Use the From and To entry boxes to control where the new paths should be created.

If you want only one new path select Just One then use the slider to set the point at which the new path should be created.

Select a method for interpolating path geometry: Linear or Length



Transformation Palette

Use this palette to translate (move), rotate, shear, mirror or scale objects. Use the small arrows to the right or left of the tabs 
to display additional tabs as you need them. Click Apply to apply your changes to any selected object. Using the Duplicate 
button instead of the Apply button to create a duplicate of the selected object as you transform it, leaving your original object 
untouched.

See also:

Transformation tools



Document SetUp

You can set the size of your workspace, page orientation and unit of measurement to accommodate the size of the drawing 
you are going to create.

To adjust the size of your workspace:

Select a standard size or enter the size for your workspace.

Click on the In. button to display and select a unit of measurement.

To select the page orientation 

Click the icon representing the orientation you prefer.

When you have completed your selections click OK.



Expression Drawing Tools

These tools allow you to create new paths or to add to an existing path. By default, all of the drawing tools (except the Freehand 
tool) automatically add points to an existing path when you position the cursor over an existing endpoint and continue drawing. 
You can disable the behavior by setting a user preference.

You can force any drawing tool (including the Freehand tool) to continue an existing path by holding down the Shift key. The 
cursor changes to indicate the type of action expected from using the tool in the current location.

Expression includes nine drawing tools:Freehand tool 

Pen tool

Polyline tool

B-Spline tool

Smoothed Polyline tool

Line tool

Rectangle tool

Ellipse tool

Text tool

See also:

 Tools toolbar



Freehand tool

Freehand tool allows you to create paths by drawing freely while holding down the mouse button. Expression automatically 
creates points based on the path you draw. 

If you are using a stylus, the pressure sensitivity can be enabled to take advantage of pressure strokes. For more information on 
using a stylus, see Using a Stylus. 



Pen tool

The Pen tool is used to create Bezier paths, point by point. The tangent handles of each point control the shape of the path. You 
place a Bezier point by clicking or dragging.. Use the Convert Point tool to change points from corner to curve or from curve to 
corner.

Clicking creates a point with tangent handles retracted (corner point).

Dragging creates a point with preceding and following tangent handles (curve point). Click then drag the tangent handles as 
needed to adjust the shape of the path. This allows you to edit the Bezier path segments as the path is created.

To end a path double click or pres the Return/Enter key.

By default, the preceding handle is symmetrically opposed (opposite) to the following tangent handle, an equal distance from the 
point itself.

You can also use the following keys to create other effects:

Hold downt he Shift key while dragging to constrain the angular relationship between the following tangent handle and the Bezier 
point.

Hold down the Option/Alt key before or during the drag to lock the preceding tangent handle in its current position: the drag thus 
affects the position of the following tangent handle only. If you release the Option/Alt key before releasing the mouse button, the 
preceding tangent handle snaps back into the position symmetrically opposite the following tangent handle.



Polyline tool

Polyline tool is used to create straight lines and arc

Click to place a point at the location of the click. Click again to create a straight line segment.

Drag to create a circular arc segment. The initial mouse click determines the tangent of the arc. The arc’s tangent path and 
endpoint are determined by the position of the point when the mouse is released.

To end a path double click or pres the Return/Enter key. The completed path is converted to Bezier points.



B-Spline tool

B-Spline tool is used to draw smooth curves based on an imaginary polygon. It works like a standard polyline tool—you simply 
click to place points, or node, on the page. Instead of connecting the nodes with straight line segments, the B-Spline tool creates 
a smooth curve which passes near each node.

As you draw, both the B-Spline curve and the imaginary polyline connecting the vertices are displayed to give you interactive 
feedback. No dragging is necessary to create a B-Spline curve. The curve is automatically stretched between clicks as you move 
the mouse. When you complete a shape, the path is displayed as a solid line while the imaginary polygon is displayed as a 
dotted line.

When using the B-Spline tool on an open path, the beginning and ending points are located on the line but all the points between 
the first and last points are offset from the path itself. On a closed path, all the points are offset from the path itself.

Moving or deleting an existing point modifies the shape of the B-Spline path. 

· Adding a new point converts the path into a standard Bezier path.

· Option/Alt-click starts a new B-Spline curve whose beginning point is the same as the end point of 
the previous curve. This creates a cusp or corner point on the path.



Smoothed Polyline tool

Smoothed Polyline tool creates a smooth path based on your placement of points. While drawing, straight line segments appear, 
connecting each point created. Upon completion, the straight line segments are replaced by smoothed curves, each point 
behaving as a Bezier curve point.

Click to place points. Double click or press Return/Enter to end the path.



Using the Line tool

Line tool creates straight path segments. The beginning point is defined by the first click and the end point, by the location at 
which the mouse button is released.

Hold down the Shift key to constrain the angle of the line between the beginning and ending points. The angle of constraint can 
be set by choosing File menu> Preferences: Options> Angular constraint steps.



Using the Rectangle tool

Rectangle tool creates a rectangle or square. One corner of the rectangle is set to the location at which you start the click-drag 
while the opposite corner is set to the position at which you release the mouse button.

Drag to create a rectangle. Hold down the Shift key to constrain the rectangle to a square.



Using the Ellipse tool

Ellipse tool creates a ellipse (oval) or circle. Each ellipse has a bounding box which is the smallest rectangle that can contain the 
ellipse. One corner of the bounding box of the ellipse is set to the location at which you start the click-drag while the opposite 
corner is set to the position at which you release the mouse.

Drag to create a ellipse. Hold down the Shift key to constrain the ellipse to a circle.

Note: The Ellipse is a special class of path; unlike the rectangle and line segment. A complete ellipse is created by default, but 
you may move the ellipse’s special point to specify beginning and ending points, thus creating a partial elliptical line segment. 

You then use the Ellipse Closure controls in the Action toolbar to specify whether the open ends of a partial ellipse are 
unconnected, connected to the center point of the ellipse with two straight line segments or connected by a single straight line 
segment.



Using the Text tool

The Text tool creates text objects based on True Type or Type 1 fonts. (Bitmapped fonts are not supported since Expression 
needs the vector based outlines.) You can set characteristics for text object, such as font, style and size.

Each of the characters of a text object can have its own individual stroke and fill attributes.

Expression gives you the ability to assign text to flow along a path. See Text on a Path.



Text on a Path

Some Text on a Path constraints:

· Multiple lines of text are not supported. Only the first line of text is applied to a path.

· Text that extends beyond the end of the path proceeds in a straight line following the direction of the tangent at the end 
of the path.

;

Note: Alignment and Leading are only useful when using more than one line of text.

To create text on a path, select the path then choose the Text tool and click the path at the point you want to insert text. 

To assign text to a path, select text object and path then choose Objects menu> Text on Path: Attach. 

To release text on a path select the object then choose Objects menu> Text on Path: Release.



Compound Shapes

In a compound shape, two or more paths are grouped in a special way so that the shape of one path is “cut out” of the other. 
This function can be very useful in creating letters such as A, O, P and R but can also be used for creating more interesting 
shapes and objects which you can “see through” to view objects beneath. 

To create a compound shape select two or more objects then choose Objects menu> Compound: Make.



Filling Complex Shapes

On simple shapes, rectangle, ellipse, or closed path, it is easy to tell what is inside and should therefore be filled. On an open 
path an imaginary line connects the first and last points thus defining which areas are inside. 

However, on any shape where a path crosses itself, or where one path encloses another path, Expression must decide which 
areas to fill and which to leave empty. 

The Fill Rule Control in the Paint Style palette lets you set which of two methods is used in applying your fill to such an object:

· Non-Zero Winding Rule: All areas within the object, including overlapping areas, are filled.

· Even-Odd Rule: Overlapping areas are not filled, and multiple overlaps alternate between filled or not filled.

These two choices are based on standard Postscript rules but you may find it simplest to just experiment to get the desired 
effect. The traditional example used to illustrate the two methods is a star drawn with five lines, creating a pentagon in the center. 
With the Non-zero Winding Number rule the pentagon is filled. With Even-Odd rule the pentagon is empty. 

To select the fill mode click the Fill Rule button and select the Even-Odd rule or the Non-Zero rule.

;

Note: For more technical explanation of Non-Zero Winding Number rule and Even-Odd rule, see Appendix C, “Glossary”    In the 
Fractal Design Expression User Guide.

Note: The direction in which the path is drawn makes a difference when using the Non-zero Winding Number rule. Expression 
automatically reverses one path when you create a compound shape. But some shapes may still need to have a path reversed. 
If you find yourself with a shape that is not filling as you thought it would try reversing one of its paths.



Using the Clipper (Masking)

Using Expression’s clipper, you can mask particular areas of your artwork. A mask or clipper allows only those objects or parts of 
objects that lie inside the mask path to be seen. This operation is similar to using a cookie cutter; the area you cut out of the 
dough is the area you keep. 

The masking object must be a simple or compound path. Text and grouped paths can not be used as masks. The top-most 
object is used as the mask and its original fill is discarded. Strokes and fills from lower layer base objects only appear in the 
masked area.

To mask select the mask and base object then choose Objects menu> Clipper: Make.



Expressions Boolean Functions

Expression supports Boolean operations which allow you to create closed paths based on the area enclosed by two source 
paths.

The source objects or paths may be opened or closed paths. The area enclosed by an open path is defined by an unseen 
straight line segment connecting the beginning and end points of the open path. Paths created by Boolean operations are always 
closed paths and may also be compound paths.

The Boolean functions supported are:

Union

Front minus Back

Back minus Front

Intersection.

For more information see Boolean Operations

Boolean operations may be applied to a selection containing more than two source paths. In this case, the operation is applied 
first to a pair of selected paths. Then the same operation is applied to the new path and the next path in the selection. This 
process is continued until all source paths have been processed. When applying Boolean functions to multiple paths, the 
selected paths are processed in order depending on the type of Boolean functions you are applying. 

Union or Intersection: Order is of no importance.

Back minus Front: Paths are processed from the back to front.

Front minus Back: Paths are processed from the front to the back.

Paths resulting from Boolean operations are painted with the paint characteristics of the front-most selected path for Unite, 
Intersect and Front minus Back operations. With Back minus Front operations the paint characteristics are taken from the back-
most selected path.



Blending Paths

With Expression you can create a series of new paths based on two different source paths. 

The Blend command allows you to specify the number of steps in the blend, then automatically generates the new paths 
based on the characteristics of the source paths. The resulting paths are placed into a single group. The original source 
objects are left untouched.

The following characteristics are interpolated during a blend:

Node and object position

Color

Line/Stroke width

Opacity

Shape parameter of Multi-view strokes

Path direction

Characteristics which can not be interpolated (Stroke definition, cap/join types, outline/fill types) are taken from the topmost 
source path in the stacking order. 

See also:

Blending More Than Two Paths

Tagging Paths for Blending



Tagging Paths for Blending

You can also set up a point-to-point correspondence between the two paths, which sometimes produces better results. The 
paths do not need to have the exact same number of points. Expression automatically compensates for any difference.

By default, correspondence between paths is automatic. However, this feature allows you to tag specific points before using 
the Blend command to manually set the point-to-point correspondence.



Blending More Than Two Paths

You can use the Blend command on more than two source paths. In this case, Expression blends the first two paths, creating the 
number of steps you requested, then blends the second path with the third path, again with the same number of steps. The 
process continues until all source paths have been blended.



Using a Stylus

In most cases, there is no different between drawing with the mouse verses drawing with a stylus. However, when using the 
Freehand drawing tool, you have the ability to take advantage of the pressure sensitive stylus to vary the width of Skeletal 
Strokes. A stroke appears thin where light pressure is applied, and thicker where heavy pressure is applied.



Using the Color Palette

The Color palette is divided into two parts: the Color Picker pane and the Color Table pane. The Color Picker pane enables you 
to edit the color currently selected in the Paint Style palette. The Color Table pane enables you to replace the currently selected 
color with a color from a library of colors.

See also:

Color Table

Color Selection

Current Color

Attribute Buttons



Color Table

Toggle the Color Table display on or off by clicking the key in the upper right corner of the Color palette. When you select a color 
from the color table the color pane, regardless of mode, adjusts to reflect the color you have chosen.

The Color Table can display the colors with no border, black border or white border. See Preferences: View and palette: Color 
palette. 



Color Selection

The bottom of the Color palette displays the currently selected color(s).

When editing a Skeletal Stroke, two rectangles appear at the bottom of the Color palette indicating the primary and secondary 
colors that are currently selected. The left-hand rectangle, which is in front represents the primary color. The right-hand 
rectangle, in the back represents the secondary color. A bar indicates which of the two color swatches is currently active. Click a 
swatch to make it active. A secondary color is frequently used in a Natural Media stroke. 

When editing a Fixed Width stroke, only one rectangle appears at the bottom of the Color palette.



Current Color

Below the current color swatches in the Color palette, is the name of the current color. The name will be the RGB or CMYK color 
model numbers, or the name you have assigned to a custom color. 



Attribute Buttons

Click one of the three buttons to choose which attribute to edit: Stroke Color, Fill Color or Gradient Color. 

Click Stroke Color to edit the color of the current stroke.

Click Fill Color to edit the color of the current fill.

Click Gradient to open the Gradient palette, then select the gradient you wish to edit.



Using Color Models

You can select colors in Expression visually by picking them from Expression’s Color palette. You can choose a color from the 
palette color table, from one of the four available HSL color pickers, or enter a specific RGB, or CMYK color value. Internally, 
Expression saves the color information as CMYK or RGB information, depending on how the color was selected. 

Depending on the use or your final image, electronic or paper, determine which color model is appropriate for your project. As a 
rule of thumb, electronic images are best in RGB, and printed images are most commonly created in CMYK.

See also:

Creating HSL Colors

Specifying RGB Colors

Specifying CMYK Colors



Creating HSL Colors

HSL defines shades using Hue, Saturation and Lightness. This color model describes the way artists generally think about color.

Hue The color itself, i.e., red.

Saturation The purity of the color. Gray has a saturation of 0% while pure red has a saturation of 100%. A low saturation of red 
creates a muddy red.

Lightness The light value in the color. 100% lightness of any color gives white and 0% gives black. Pink has more light than a 
deep red.

Click the Color Wheel to select a basic starting hue. The Color Wheel can be fixed or draggable. See Preferences: View and 
palettes: Color Palette. 

Select an HSL Value Picker from the pop-up menu directly above the HSL color values. The Value Picker displays all the 
available colors within a predominant hue.

The Value Picker is represented as a triangle, diamond or square. Use the method that works best for you. Click in the Value 
Picker to select a color. Dragging left or right controls saturation. Dragging up or down controls lightness.

See also:

 Understanding the Color Palette HSL Value Picker 



Understanding the Color Palette HSL Value Picker

The HSL Value Picker comes in three different shapes: triangle (the default), diamond, and square. The Picker's behavior is 
similar in all of its three shapes, so you can choose the one which best suits your tastes. The differences between them are 
described below.

To choose the shape of the HSL Value Picker, use the pull-down menu to the right of the color wheel, above the Hue, Saturation, 
and Lightness fields. This pull-down menu contains four icons. The first three icons represent the three available shapes for the 
Value Picker. The fourth icon (at the bottom of the menu) represents a special display mode which allows you to see whether the 
current color falls within the printable gamut.

The Triangle Value Picker

The triangle Value Picker displays all the colors in a particular hue. The colors are organized in increasing saturation from left to 
right and in increasing lightness from bottom to top. The left edge of the triangle represents a 0% saturation and is therefore a 
neutral gray axis making the triangle Value Picker convenient for choosing neutral grays. 

Dragging all the way to the right gives the purest color of the predominant hue. Dragging to the left gives muddier or grayer 
colors. Values span the triangle from top to bottom, with the top of the triangle being the highest value (white), the bottom the 
lowest value (black). 

Click or drag the small crosshair to select the value you want. The current selection is shown in the swatch at the bottom of the 
palette.

The Diamond and Square Value Pickers

The diamond and square Value Pickers display all the colors in a particular hue as well as the complementary hue and all its 
colors. (The complementary hue is the one directly opposite the selected hue on the color wheel.) Think of the square and 
diamond as two triangle Value Pickers, back to back. These two modes display a richer range of colors to choose from and are 
particularly useful for color design purposes where complementary color schemes are often used. The diamond and square 
Value Pickers behave the same; the square is just larger.

· The right half of the diamond or square is the same as the triangle described above. 

· The left half is a triangle pointing to the complimentary (opposite) color and functions as a mirror image; dragging right 
selects a muddier or grayer saturation while dragging left selects a purer hue. 

· Click or drag the small crosshair to select the value you want. 

· The current selection is shown in the swatch at the bottom of the palette.

See Checking the Gamut  for information regarding the gamut of printable colors.



Checking the Gamut

The fourth icon on the Value Picker pull-down menu selects the printable gamut display mode. This mode allows you to see 
whether the current color falls within the printable gamut. When you choose the printable gamut mode, the HSL Value Picker is 
temporarily replaced with a display which shows the current color in relation to the printable gamut.

After you have checked the printable gamut display, click anywhere within the display to restore the HSL Value Picker.

The printable gamut display shows the gamut slice corresponding to the intensity (brightness) of the current color being edited. 
The shape of the gamut depends on the current color calibration settings which are specified in the Color Match tab in the 
Preferences dialog

The current color is represented as a small circle on the display. If the circle is within the gamut, the color is printable; otherwise 
the output might not be what you would expect. The gamut display is not for picking colors. It is mainly for displaying how far off 
your chosen color is from the printable gamut. Since the gamut display only shows the gamut slice with the same intensity as the 
current color, it is possible that the gamut slice vanishes completely if the current color is brighter than the brightest printable 
color.

Not all colors visible on the computer screen can be successfully reproduced when printing on paper. When you select a hue that 
is outside the gamut of printable colors a clipped color ring appears around the selected color in the selection swatch at the 
bottom of the palette



Specifying RGB Colors

This model is based on how colored light is generated on a television or computer monitor screen. All colors are defined using 
combinations of red, green and blue phosphors. 

With all three kinds of phosphors emitting light at full intensity, a white color is perceived. If no light is emitted, darkness or black 
is perceived. Because lights are added together to produce the effect of a particular color, RGB is considered to be an additive 
color model.

Click the RGB tab in the Color palette. Adjust the three sliders to select a color or enter specific numbers for each value. You can 
set specific values for red, green and blue.



Specifying CMYK Colors

The CMYK color model is used by printers and service bureaus. CMYK is based on the process colors: cyan (C), magenta (M), 
yellow (Y), black (K) used in four color printing. This model is used for most printed materials such as magazines, books and 
brochures. All shades are defined using combinations of cyan, magenta, yellow and black.

Each kind of ink absorbs different amounts of light of different wavelengths, producing different colors. A color model based on a 
mixture of inks is a subtractive color model.

Click the CMYK tab in the Color palette. Adjust the four sliders to select a color or enter specific numbers for each value. You can 
set specific values for cyan, magenta, yellow and black.



Building Your Own Color Tables

Custom color tables are used to organize groups of colors. You can customize your table to control the colors in particular 
projects or create groups of your favorite colors. You might name your color tables according to use or color family. Use the slider 
at the right of the Color table to scroll through the entire table.

Select or define a color in the Color palette. The color you created appears in the color selection rectangle at the bottom of the 
palette. Click-hold on the color selection rectangle at the bottom of the palette. The Color Dropper cursor fills, indicating the color 
has been copied. Drag the cursor into the color table and release the mouse over the swatch you want to replace.

Save Color Table

Once you have changed the table, it can be saved and opened as needed. Choose File menu> Color Table> Save. You can also 
click-hold the pop-up menu next to the Color Table and choose Save Color Table.

Load Color Table

To load a color table, choose File menu> Color Table> Load. You can also click-hold the drop down menu next to the Color Table 
and choose Load Color Table.

Sort Color Table

Choose File menu> Color Table> Sort. Expression organizes the colors. You can also click-hold the pop-up menu next to the 
Color Table and choose Sort Color Table.

See also:

Blending Color Table Colors



Blending Color Table Colors

Expression can automatically generate color in the color table by interpolating (blending two existing colors).

Drop a color into a swatch in the color table.

Drop a second color into another swatch, “deeper” into the Color Table (the table is organized lift-to-right, top-to-bottom). The 
number of swatches between the two colors determines how many intermediate colors are generated.

Select the first of the two colors you copied to the Color Table.

Hold down the Shift key. The cursor changes to a flag.

Click the second color. The swatches between the two colors are filled with the blended colors, replacing colors previously in the 
Color Table.



Using Custom Colors

Expression also provides support for custom (spot) colors. A custom color is a particular color to which you assign a name. In 
Expression, custom colors are always converted internally to CMYK values and saved as such. 

Once defined, a custom color can be saved and applied to any number of objects within your document. Each instance 
maintains a reference to the custom color’s definition. This makes it easy to use consistent colors on multiple objects and to 
make global color changes. It also allows you to take advantage of compatible software applications which perform spot color 
separations. 

Expression also includes a large number of predefined custom colors, named intuitively and ready for your use (navy blue, rose, 
brick, tomato, etc.). To select a custom color open the Custom Color palette then click on a custom color name in the Custom 
Color list. The custom color becomes the currently selected color in the Color palette

The colors which appear under the System tab in the Custom Color palette, are from a collection developed for the X Window 
Systemª by the X Consortium

Creating Custom Colors

You can also name specific custom colors so you can use them on different objects. Editing a custom color edits all objects using 
that color.

To add a color to the Custom Color palette, first create or select the color in the Color palette, then click-hold on the color 
selection rectangle at the bottom of the palette. The Color Dropper cursor fills, indicating the color has been copied. Drag the 
cursor into the Custom Color palette’s color selection rectangle (at the bottom of the palette) and release the mouse. Assign a 
name for the color then click Return/Enter. The new name appears next to the color in the list box.

To delete a custom color: 

Select the custom color from the Custom Color palette. Click Del. The selected color is removed from the Custom Color palette. 
CAUTION: THIS CANNOT BE UNDONE!

Controlling Custom Color Tint

The tint control slider lets you specify a tint of the selected custom color. The setting on the tint control slider does not change the 
definition of the custom color; it only affects the instance of the color applied to the current selection. Changes in tint are 
displayed in the Paint Style palette Color swatch and the Value Picker.



Copying Attributes From One Object to Another

Expression has two tools which allow you to copy color and stroke attributes and apply them to other objects with a couple clicks 
of the mouse. The Color Dropper tool picks up color from one object, or area of an object, so you can drop the color onto another 
object or area. The Attributes Dropper tool copies the stroke and fill attributes from one object to another.

Copying Colors

In addition to choosing colors from the Color palette you can use the Color Dropper to pick up a color from an object and drop it 
onto another object. 

Click the Dropper Tools icon in the Tools toolbar and choose the Color Dropper tool. The cursor changes to an eye dropper. 
Click-hold on the color you want to copy. The Color Dropper cursor fills, indicating that the color has been copied. Drag to the 
object or area you want to color then release the mouse button. The area now displays the new color.

Copying Attributes

The Attribute Dropper tool allows you to copy one object’s paint attributes, (stroke, fill, and colorize settings) to another object. All 
paint attributes are copied, including stroke type, fill type, color, width, shear angle, etc.

Click the Dropper Tools icon in the Tools toolbar and choose the Attribute Dropper tool. The cursor changes to an eye dropper. 
Click-hold on the object whose attributes you want to acquire. The Attribute Dropper cursor fills, indicating that the attributes 
have been copied. Drag to the object you want to edit then release the mouse button. The area now displays the new stroke and 
fill attributes.



Using Gradients

Expression gives you complete control over gradients. You can select the direction, type of blend, colors used in the blend and 
the rate of change.

Applying Gradients

The Paint Style palette allows you to select a gradient scheme and apply it to a selected object or path.

Click the Stroke or Fill tab in the Paint Style palette. If you want to apply the gradient to a stroke, click the Stroke tab. If you want 
to apply the gradient to an object fill, click the Fill tab.

Click the Gradient icon. The palette changes to reflect gradient related choices. Select a gradient scheme from the scrolling list. 
You also can create new gradients. For more

Controlling Gradients

The Gradient tool is used to control the direction and rate of change for a gradient stroke or fill within an object.

Select the Gradient tool from the Tools toolbar then ldrag across an object to set the gradient direction. 

When you start and end your drag very near opposite edges of the object, the gradient changes equally across the entire object. 
Drag from the middle of the object to have a larger band of beginning color.

See also:

Creating Gradient Color Schemes



Creating Gradient Color Schemes

Expression includes a selection of default gradients which are ready to use. You can also edit these gradients or design your 
own.

;

Note: Gradients are stored globally by the application. This means that editing a gradient affects all objects which use the same 
gradient pattern. If you want to edit a gradient on a particular object without affecting other objects, create a new gradient and 
apply it to the object, then edit the new gradient.

In the Gradient palette, click the New button below the Gradient list. The New Gradient dialog appears.

You can also create a new gradient directly from the Paint Style palette by choosing Gradient from the Paint Style palette’s 
Stroke or Fill tab and clicking the New button below the Gradient list. When you do so, the New Gradient dialog appears, and the 
Gradient Editor is automatically opened.

Enter a name for the new gradient, then click OK. The new gradient is added to the Gradient list. The initial settings for the new 
gradient are duplicated from the currently selected gradient. Edit the new gradient as described below.

If it is not already selected (filled) click the left triangle under the Gradient sample bar. Select or define a color from within the 
Color palette. The color appears in the color selection rectangle at the bottom of the Color palette as well as at the start of the 
Gradient sample bar. Select and edit the color for each triangle under the Gradient sample bar.

Click-drag the triangles to control the rate of color change. You can also use the input box at the lower right corner of the 
Gradient palette to precisely set the position of the selected triangle. Enter a number or use the up/down arrows, then press Tab 
or Return/Enter.

If you want additional colors, click directly below the Gradient bar to add additional triangles. Apply colors to the new triangles as 
needed. 

To remove a color from a gradient, simply drag its triangle down away from the Gradient bar.

Click-drag the diamond indicators above the Gradient bar to control the rate of color change.

Select the type of gradient by clicking on the Gradient Type button to the right of the Gradient bar. You can choose from 
a linear or radial gradient.

Linear: The colors change in a straight line.

Radial: the colors change from a center point outward in all directions.

To delete a gradient select it in the Gradient list, then click the Delete. You can also delete a gradient directly from the Paint Style 
Palette by choosing Gradient from the Paint Style palette’s Stroke or Fill tab, selecting the gradient you want to delete, and 
clicking the Delete button below the Gradient list.



Colorizing Objects

Expression provides several ways of controlling the colors used in your strokes. These colors are based on grayscale values. 
Any changes made, affect all selected objects and any new path you draw while the same Skeletal Stroke is selected.

Why Colorize?

· To shift the color range of a portion or the entire picture as a whole without modifying the individual colors of the objects.

· To tint black and white objects such as clip art.

· To swap the primary color channels to create a different impression.

· To control the color scheme of a multi-colored Skeletal Stroke.

Experiment with the Paint Style palette’s Colorize tab. Use it to change the mood of your artwork, to change individual instances 
of a stroke or to restrict your color to a specific range.

For example; you want to create an image with a school of fish. The fish is created using three or four colors. Make the fish into a 
Multi-view stroke so each instance may be a slightly different view. Then, select one copy and adjust the Colorize tab to give it a 
distinct set of colors. 

The colors retain the value (light/dark) of the original but now reflect a different color scheme. Colorize each fish in your school to 
quickly create a school of related but different instances. 

How to Colorize

Expression offers two methods of colorizing: 

· Foreground/Background which applies to Skeletal Strokes only.

· Three Primaries plus Background which applies to any object.

See also:

Foreground/Background Mode

Primary Color Substitution Mode

Combined Color Substitution

Background Color Substitution

Removing Colorization



Foreground/Background Mode

When working with a Skeletal Stroke that includes two colors, such as a Natural Media brush stroke, control the colors using the 
Foreground/Background Mode. 

The foreground and background colors for Skeletal Strokes are applied based on value. Black areas are replaced by the 
foreground color while white areas are replaced by the background areas. Gray areas (between black and white) are replaced by 
appropriate hues based on the balance of black and white. 

In strokes with only black and white you see only the foreground and background color. In strokes with grays you see color(s) 
assigned to the particular grayscale value. A stroke with two colors, but little contrast, say black and forest green, shows very 
little difference between the foreground and background color.

When you have a fully colored Skeletal Stroke and use foreground/background mode to colorize the stroke, the intensity (or 
lightness) of the colors are taken to get a color between the foreground and background colors. The original hue of the colors is 
ignored; only the intensity value is used. 

The most intense (lightest) areas receive the background color. The least intense (darkest) areas receive the foreground color. 
All areas with intensity between the most intense and least intense areas are assigned colors between the foreground and 
background based on their relationship to the two extremes. 

To use Foreground/Background Mode click the Colorize tab. The palette changes to reflect the Colorize options. Click on the 
Fg/Bg Mode button. Two squares, appear in the palette, representing the foreground color (upper left) and the background color 
(lower right). Select the opacity required by click-dragging the Opacity slider at the bottom of the palette. Changes to the stoke 
appears in the box below the slider. Select or define a color from within the Color palette. The color appears in the color selection 
rectangle at the bottom of the palette.

Click-hold on the color selection rectangle at the bottom of the Color palette. The Color Dropper cursor fills, indicating the color 
has been copied. Drag the cursor into the Foreground swatch in the Paint Style palette’s Colorize tab and release the mouse. 
Apply a color to the background swatch the same way. Click Apply. The new colors are applied to the selected object.



Primary Colors Substitution Mode

The Foreground/Background mode is ideal for colorizing grayscale strokes. Since most of Expression's Natural-Media Strokes 
are designed in grayscale, this mode is very useful. However, it does not work as well for colorizing multi-colored strokes, since it 
replaces all of the original colors with just two. 

To alter the colors of multi-colored strokes, you can use the Primary Colors Substitution mode. By allowing you to substitute 
different colors for the standard primaries, this mode enables you to apply subtle or dramatic color shifts to one or more objects 
in your illustration.

The Primary Colors Substitution mode allows you to selectively substitute the primary colors in a Stroke's color model to alter the 
appearance of the colors in the Stroke. You can work in the Subtractive color model (the default) where the primaries are Cyan, 
Magenta and Yellow, or the Additive color model, where the primaries are Red, Green and Blue.

Substituting the primaries in the Subtractive color model is like substituting different colored inks for Cyan, Magenta, and Yellow 
in the printing process. Substituting the primaries in the Additive color model is like changing the colors of the light emitted by the 
computer screen (or changing the color of the phosphors used in the CRT).

See also

To apply color using Primary Color Substitution



Combined Color Substitution

In addition to altering colors on an object by changing the colors used for the primaries, you can alter the color by changing the 
color of the intersection of the three primary color circles. This way you change the whole color spectrum toward the new color 
you have introduced. When you change the intersection of the three circles Expression actually changes the three primary colors 
to primaries that create that color.

;

Note:The combined color represents the maximum intensity color possible with the new primaries when the additive models is 
chosen; or the minimum intensity color possible when the subtractive model is chosen. Therefore selecting black as the 
combined color under the additive model would give three blacks as primaries, turning every color black on such substitution. 
Similarly, selecting white as the combined color under the subtractive model would give three whites as primaries, turning every 
color white.



Background Color Substitution

The background color, represented by a square in the Colorize tab affects how color is seen. It is equivalent to changing the 
color of the paper the object is printed on, except each object in your image could have a different background color. Changing 
the background color does not change the primary colors but does change the appearance of the object.

For a real-world example of colorizing object with the primary substitution method, see the Expression Creative Techniques 
guide.



To apply color using Primary Color Substitution

Using the Object Selection tool from the Tools toolbar, select the object to be colorized. This mode only works for Skeletal 
Strokes.

If the Paint Style palette is not displayed, choose Window menu> Paint Style. The Paint Style palette appears.

Click the Colorize tab. The palette changes to reflect the Colorize options.

Click on the Additive Model or Subtractive Model button. Three overlapping circles and a square appears in the palette. The 
circles display the primary ink colors. The square represents the background upon which the inks are placed.

Changing one of the color circles represents changing an ink color. The standard inks, Cyan, Magenta and Yellow can be 
substituted with any other color to change the overall color scheme.

Select the opacity required by click-dragging the Opacity slider at the bottom of the palette. Changes to the stoke appears in the 
box below the slider.

If the Color palette is not displayed, choose Window menu> Color. The Color palette appears.

Select or define a color from within the Color palette. The color appears in the color selection rectangle at the bottom of the 
palette.

Click-hold on the color selection rectangle at the bottom of the Color palette. The Color Dropper cursor fills, indicating the color 
has been copied.

Drag the cursor into the appropriate primary color swatch in the Paint Style palette’s Colorize tab and release the mouse.

Apply a color to the other primary color swatches the same way. Click Apply. The new colors are applied to the selected object.



Removing Colorization

If you decide later on that you want all of your colorized objects to have the same colors, you can reset the colorization option.

To reset the color:

Using the Object Selection tool from the Tools toolbar, select the colorized object. 

If the Paint Style palette is not displayed, choose Window menu> Paint Style. The Paint Style palette appears.

Click the Reset Color button. This button is only available if colorization has been applied to the selected object. The original 
color is restored to the selected object.



Setting Colorize Preferences

Replacing colors with the Color Dropper tool is normally a straightforward process—the color you pick up is simply dropped 
wherever you release the mouse. However, when you try to replace one of the colors in a Stroke which has previously been 
colorized, the process is not so simple. 

Expression cannot simply drop the color into the Stroke because the color you are dropping may not even exist within the 
Stroke's substituted color model.

Instead, Expression must do one of two things. By default, Expression resets the colors of the Stroke before dropping the new 
color in. This ensures that the color you pick up and drop with the Color Dropper is the color you actually see in your document. 
However, resetting the colors often drastically alters the appearance of the rest of the Stroke. 

If you prefer, Expression can instead leave the Stroke's substituted colors intact. In this case, however, the color you drop is not 
the color you see in your document, as it is colorized along with the rest of the Stroke.

See Preferences: Options: Tools .



Setting Color Calibration

Colors that display on the computer screen can only be approximated by printed color and vice-versa. To get your printed output 
as close as possible to the colors you see on screen you must calibrate your monitor. If you are using a color printer use 
Expression’s Color Match feature to calibrate your monitor to your printer.

The computer uses a mix of three basic colors, red, green and blue, to generate the full range of colors displayed on your 
monitor. Printers, however, use a mixture of four basic ink colors, cyan, magenta, yellow and black, to create a similar range of 
colors. Because these two methods are fundamentally different a perfect match between what you see on screen and what you 
see printed is often impossible. 

You can use calibration hardware and software, such as a gamma device, to calibrate your monitor. But even if you do, you 
should still take the time to set Expression’s Color Match settings.

After calibrating your system with Expression’s Color Match feature to match the setting you have in Fractal Design Painter, 
Adobe Illustrator, Adobe Photoshop or CorelDRAW!, you can print your Expression artwork from one of those applications and 
be assured that the color will still print out as true as possible.

Of course, the best color matching can be achieved on 24-bit monitors which can display millions of colors. Anything less than 
24-bit means the colors will need to be dithered or approximated. A 24-bit monitor offers you the largest number of colors to 
choose from. 8-bit or 16 bit color monitors can not give you as large a selection of colors.

The first step in color calibration is to acquire a printed sample of the standard color combinations, known as a progressive color 
bar. If you are taking your color image to a service bureau for output, the service bureau should supply you with this tool. If you 
have a color printer in your office you should use the progressive color bar supplied with the printer. The progressive color bar 
contains color swatches of the following colors:

cyan, magenta, yellow and black (the four process colors), magenta/yellow, cyan/ yellow, cyan/magenta, cyan/magenta/yellow, 
white and a four-color black.

See Preferences: Color match



Applying Paint: The Paint Style Palette

You paint a path by specifying two main attributes: stroke and fill. The stroke you set determines the appearance of an 
object’s path(s). The fill you select determines the appearance of the area enclosed by the path(s). You control these 
attributes by using the Paint Style palette. When no object is selected the Paint Style palette displays the current attributes. 
These are the attributes applied to the last selected object or attributes to be applied to the next object created.

When a single item is selected, the Paint Style palette displays that object’s attributes. When multiple objects are selected 
the Paint Style palette displays those attributes which are common to all selected objects. If a particular attribute differs 
between the selected objects, that field is blank or displays a special item (i.e., a question mark) to indicate there is a 
difference. The preview windows near the bottom of this palette display the selected stroke on the left and the selected fill on 
the right.

See also:

Using Apply and Auto Apply

Controlling Opacity/Transparency

Using the Paint Style Palette Tabs



Using Apply and Auto Apply

You can set Expression to automatically apply any attributes selected in the Paint Style palette by selecting the Auto box in 
the lower left of the Paint Style palette. 

When Auto is selected, all changes made are automatically applied to the selected path(s). Otherwise, after making changes 
in the Paint Style palette, click the Apply button to apply the changes to your path(s).



Controlling Opacity/Transparency

Opacity refers to the ability of material to block light, which is the inverse of transparency. Drag the Opacity slider near the 
bottom of the Paint Style palette to change the opacity of the selected object(s)

With Opacity set to 100%, your object is opaque and you can not see through it. Set Opacity to 0% to make the object 
completely transparent and invisible.

Note: Since many file formats do not support Opacity, you need to consider your output plans when using this feature.



Using the Paint Style Palette Tabs

Use the tabs at the top of the Paint Style palette to activate the controls for the attribute you wish to edit. To select Stroke, 
Fill or Colorize, click the appropriate tab.



Changing Stroke Attributes

Expression allows you to choose from several types of strokes: None, Basic, Gradient or Skeletal. Each stroke type has 
attributes specific to that type. The information within the tab changes to reflect the type of stroke selected. Click to select 
the type of stroke you want to apply.

None No stroke is displayed so there are no specific parameters.

Basic Path is drawn with a solid color.

Gradient Path is drawn with color changing gradually from a starting color to an ending color.

Skeletal Stroke Path is drawn with the Skeletal Stroke chosen from the Stroke Warehouse palette.

See also:

Applying No Stroke

Applying Basic Stokes

Applying Color

Changing the Stoke Width

Creating Dashes

Changing Corner Attributes

Editing Caps

Applying Gradient Strokes

Applying Skeletal Strokes



Applying No Stroke

When None is selected as your stroke from the Paint Style palette, no stroke is displayed on the selected object. If you set 
both stroke and fill to None, no image displays. With stroke set to None and Fill set to Color, Gradient or Pattern you see the 
color or pattern with no outline.



Applying Basic Stokes 

This is similar to the standard stroke you use in Adobe Illustrator or CorelDRAW!. The stroke is displayed as a solid color, set 
to the width you prefer. Dashed lines can be created using a basic stroke. You can also specify corner joint type and end 
caps to be used.



Applying Color

Color can be applied to Basic, Gradient and Skeletal strokes. The method for applying color to each stroke varies. 

For fixed width strokes, select or define a color from within the Color palette. The color appears in the color selection 
rectangle at the bottom of the Color palette as well as in the Paint Style palette.



Changing the Stoke Width

Expression allows you to set the width (in points) of any Basic, Gradient or Skeletal Stroke. In the Width entry box, highlight 
the current number displayed and enter a new number. You can also click the up and down arrows to increase or decrease 
the width in increments of one point. Drag the up/down arrows to adjust the width more quickly.



Creating Dashes

Expression allows a dash pattern to be specified to a stroked path with each dash being an instance of your stroke. This 
works the same way for Basic, Gradient and Skeletal strokes.

Select the Dash check box.

Enter a pattern of numbers indicating the size and interval for the dashes. For example, enter 20 10 to create a line that has 
dashes of 20 points separated by spaces of 10 points.

You can create more complex dash patterns by entering sequences of more than one or two numbers.



Changing Corner Attributes

The Join buttons give you the ability to select how Expression applies a stroke to a corner. To change, select path then click 
Join button. Your choices are:

Miter join

Bevel join

Round join



Editing Caps

The Caps buttons define the shape of the ends of open paths or dashed segments. Caps do not apply to Skeletal Strokes.

To change caps, select path then click Caps button. Your choices are:

Flat cap

Round cap

Square cap



Applying Gradient Strokes 

When you select Gradient as your stroke, Expression displays the stroke as a Basic stroke but, instead of a solid color, the 
color is a simple or complex gradient, changing gradually from one specified color to another.

Gradient strokes are set in the same manner as Gradient fills.



Applying Skeletal Strokes

The core of Expression is the Skeletal Stroke. In most graphic software when you draw a path you can set certain 
characteristics of the path, such as color or fill. 

Some software allows you to use tools that mimic real world art tools, such as a calligraphy pen or a dry brush. With 
Expression you can go far beyond these standard characteristics. 

Expression gives you a Natural-Media feel, with the advantages of resolution independent artwork. You can assign a path 
characteristics of any other path or groups of paths. For example, you may create a path or group of paths that create an 
image of a fish. You can use that fish image to create a Skeletal Stroke which you can then apply to a new path. The fish 
image follows the shape of the path to which it is assigned.

See also:

How is a Skeletal Stroke Created? 

Applying a Skeletal Stroke

Setting Skeletal Stroke Parameters

Changing the Width of the Skeletal Stroke

Changing the Mode

Shearing the Stroke

Twisting a Stroke



How is a Skeletal Stroke Created?

Each Skeletal Stroke is contained in its own individual reference frame or stroke definition box. The stroke may be as simple 
as a dot or as complex as a sailing ship but once it has been defined as a stroke you can apply it as a characteristic to any 
path you draw. 

The stroke definition box becomes the reference for the stroke. As it is pulled along the path, the artwork within the stroke is 
deformed based on the distortion of the box. You can even twist and skew the stroke.



Applying a Skeletal Stroke

Just like any other type of stroke (Basic or Gradient), a Skeletal Stroke can be applied to any path. You can choose from any 
of the Skeletal Strokes in the Stroke Warehouse palette.

“Painting” with a Skeletal Stroke is very simple—just choose a stroke from the Stroke Warehouse palette and draw with the 
drawing tool of your choice. Instructions for applying a Skeletal Stroke to an existing path appear below. 

Once you have applied a Skeletal Stroke, the Paint Style palette allows you to set several special Skeletal Stroke 
parameters, in addition to the standard stroke parameters.

See also:

Using Quick Strokes



Using Quick Strokes 

This feature can be used to assign single keystrokes to your favorite Skeletal Strokes. Instead of returning to the Stroke 
Warehouse palette each time you need to change your stroke, you simply use a keystroke to switch between strokes.

You can quickly assign quick strokes by selecting a stroke from the Stroke Warehouse palette then press 
Command/Ctrl+any number between 1 and 9. The number your select is the quick key number assigned to that stroke.

To use a Quick Stroke type the Quick Stroke number. The selected stroke becomes highlighted in the Stroke Warehouse 
palette and becomes the active stroke in the Paint Style palette.



Setting Skeletal Stroke Parameters

When you select a Skeletal Stroke the object is drawn based on the stroke you select. In addition to Width, Dash and Join, 
described earlier, you can set Skeletal Stroke specific parameters including Mode (Ribbon or Sausage), Shear, Twist and 
Shape.



Changing the Width of the Skeletal Stroke 

You can control the width of a Skeletal Stroke as you can for a Basic or Gradient stroke; by using the Width entry box in the 
Paint Style palette. In addition, you can also control the width by manipulating the Shear/Width handle assigned to each 
Skeletal Stroke. 

Drag the Shear/Width handle up or down to change the width. Holding down the Shift key constrains the change so only the 
width is adjusted. Otherwise, the Shear is also adjusted.



Changing the Mode

Expression offers two ways to apply a stroke to a path: Sausage or Ribbon. The default mode is Sausage but you can change 
the mode simply by clicking on the mode icon that you prefer.

Sausage mode displays a more literal path with the Skeletal Stroke distorted accordingly. The Skeletal Stroke remains 
perpendicular to the path, turning as the path curves an turns.

Ribbon mode creates an image something like what you get with a calligraphy pen. The Skeletal Stroke remains oriented 
along the Y axis or the paper as it was originally defined.



Shearing the Stroke

Shear refers to the angle at which the stroke is drawn. Imagine the stroke shape as being on a clear piece of fabric. By 
default the clear fabric is a rectangular shape, with right angles. Using Shear you can pull that rectangular shape into a 
parallelogram thus distorting the stroke. 

Note: Do not confuse this ability to shear the Skeletal Stroke with the transformation handles on the bounding box of a 
selected object. The transformation handles on the bounding box affect the path. The Shear/Width handle on the object itself 
and the Shear slider in the Paint Style palette affect the Skeletal Stroke.

In Sausage mode the Shear angle is relative to the particular Skeletal Stroke. In Ribbon mode the Shear angle is based on 
the global Y axis or the paper on which the stroke is placed.

Control the shear by using the Shear slider or the Shear/Width handle that is assigned to each Skeletal Stroke.

Drag the Shear/Width handle to the left or right to change the shear. 



Twisting a Stroke

You can twist your Skeletal Stroke by dragging the Twist slider to set the number of turns you want.



Setting the Shape of a Multi-view Stroke

Whereas ordinary Skeletal Strokes are defined from a single picture, Multi-view strokes are defined from a sequence of 
different (but closely related) pictures. Expression treats these pictures as different views of a single stroke, any of which 
may be used each time you apply the stroke. For more information on Multi-view strokes, see ä“Creating Multi-view 
Strokes,” later in this chapter.

Each view is assigned a shape parameter between 0% and 100%, which allows you to specify which view to use. Because 
Expression automatically generates “in-between” views from the original views in the Stroke definition, a Multi-view stroke 
can have a wide range of appearances.

By dragging the Shape slider in the Paint Style palette, you can specify which view of the stroke you want to use. 
Alternatively, if you enable the Random checkbox, Expression randomly chooses a view. The Shape slider and the Random 
checkbox are enabled only when the Paint Style palette contains a Multi-view stroke (Multi-view strokes are marked in the 
Stroke Warehouse with a blue dot).

Drag the Shape slider to select a percentage value. 0% (the default setting) specifies the stroke’s first view; 100% specifies 
the last view. 

Each value in between specifies a particular view, which (depending on the stroke) may be a view from the original Stroke 
definition or a view automatically generated by Expression.

Or

Enable the Random checkbox below the Shape slider. The Shape slider is now disabled, and a value is randomly generated

See also:

Creating Multi-view strokes



Applying Fills

Expression allows you to choose from four types of fill; None, Solid, Gradient and Pattern. The currently active fill is 
displayed and can be changed using the Paint Style palette’s Fill tab.

Regardless of which fill type you choose, the Fill rule allows you to define which areas of your object are filled. There are two 
methods which can be used when applying a fill to complex objects:

· Non-Zero Winding Rule

· Even-Odd Rule

Click a Fill Type icon to select a fill type. You have four fill options: 

None No fill displayed. No parameters to set

Solid Fill is a solid color.

Gradient Fill is drawn with color changing gradually from a starting color to an ending color. 

Pattern Fill is drawn with a repeating pattern.

See also:

Applying Solid Fills

Applying Gradient Fills

Applying Pattern Fills



Applying Solid Fills

When you select Solid Fill, Expression displays the fill as a solid color.

Click the Fill tab in the Paint Style palette. If the Paint Style palette is not displayed, choose Window menu> Paint Style. 

Click the Solid fill type icon. Set the color by clicking the preferred color in the Color palette. The display at the bottom right 
of the Paint Style palette updates.



Applying Gradient Fills

When you select Gradient Fill, Expression displays the fill as a simple or complex gradient, changing gradually from one 
selected color to another.

Gradient fills are set in the same manner as Gradient strokes.



Applying Pattern Fills

Patterns are tiled repetitions of pictures that are used as Expression fills. Expression presents you with a selection of 
predefined fills but you can also create your own. You can create a pattern out of anything you can draw.

See also:

Creating a New Pattern

Controlling the Pattern During Transformation

Pattern Storage

Patterns Within Strokes

Patterns and Color Substitution

Using Hatching



Creating a New Pattern

Expression's Pattern Definition tool allows you to create a pattern from any artwork in your Expression document. You simply 
drag a marquee around the artwork to create a Pattern Definition Box. The Pattern Definition Box is a special type of object 
which allows you to define the contents of a single pattern tile. 

By transforming the Pattern Definition Box with the transformation tools, you can create a pattern whose tiles are skewed or 
rotated. This often results in a pattern with less obvious seams. Once you have adjusted the Pattern Definition Box to your 
liking, you define the pattern by clicking a button. After you define a pattern, it becomes accessible from the list in the Paint 
Style palette.

See also:

To define a new pattern: 



To define a new pattern:

Create or open a basic tile picture in the Expression workspace.

Click the Definition Tools icon in the Tools toolbar and choose the Pattern Definition Box tool.

Drag a marquee around the area to be turned into a pattern. The size of the marquee you draw defines the tile size and 
controls the spacing between repetitions. For more space, drag the marquee larger. For less space leave less free space 
within the marquee. 

A marquee that is smaller than the object itself creates overlapping tiles

When you release the mouse, a pattern definition box is created. This box allows you to further adjust the pattern tile and 
displays a preview of the pattern.

Using the Transformation tools from the Tools toolbar or the selection handles on the pattern definition box, rotate, skew, 
scale, etc., the pattern definition box as needed.

Click the Define button in the lower left corner of the Pattern Definition window to define the pattern. Enter a name for the 
new pattern and click OK. The new pattern is added to the list of available patterns, ready for you to use.



Controlling the Pattern During Transformation

Expression allows you to set a preference to determine whether pattern fills are transformed (moved, scaled, rotated, or 
sheared) along with the objects to which they are applied. 

When the Transform Patterns option is enabled, a pattern is treated as part of the object to which it is applied and is 
subsequently affected when the object is transformed. When this option is disabled, the object is like a window, simply 
revealing the pattern. Transforming the object may affect which part of the pattern is revealed, but the pattern itself is not 
transformed.

To set preference choose File menu> Options tab. Select the Transform Patterns check box. From now on, transformations 
applied to objects with a pattern fill are applied to the pattern as well. This option can be turned on and off in an editing 
session and the effect is accumulative.



Pattern Storage

All patterns are stored in a single pattern file within the main Expression directory. In addition, each Expression document 
file contains the pattern definitions for all patterns used in the document. 

If your pattern list becomes cluttered, you can simply delete patterns you use infrequently. Since pattern definitions are also 
kept within individual Expression documents, you don’t have to worry about missing patterns when you re-open a file.



Patterns Within Strokes

When a stroke definition includes an object with a pattern fill, the pattern is re-applied to each instance of the stroke. 
Therefore, the pattern is not deformed with the contents of the stroke.



Patterns and Color Substitution

When you change the primary colors of an object whose fill or Skeletal Stroke uses a pattern, the colors of the pattern are 
affected along with the rest of the object’s colors. However, the individual colors within a pattern cannot be edited on an 
object-by-object basis.



Using Hatching

With Expression you can mimic and extend the traditional pen and ink shading technique known as hatching. Hatching 
generates a pattern of strokes whose widths vary based on the contrasting lightness/darkness of the source imagery you 
provide. 

The shape, thickness and relative placement of individual lines within the hatching pattern determine how the object is 
perceived. Hatching can indicate depth or curvature as well as distance and texture. Hatching is one of the features that 
gives Expression its exciting Natural-Media feel.

See also:

Applying Hatching

To apply hatching: 

Hatching Results



Applying Hatching

Hatching is applied to a path, which defines the boundary of the region to be hatched.

Any imagery which falls within this region, including the fill of the path itself and any objects which overlap it, is used to 
generate the hatching. Often, simple gradients or blends make the best source imagery for hatching.

The widths of the individual hatching strokes depend on the varying lightness and darkness of the source image. Lighter 
areas are hatched with thin strokes, darker areas with thicker strokes.

In addition to selecting a path, you must choose your hatching pattern. Hatching patterns are specialized patterns composed 
of strokes. Variations in the hatching are achieved by varying the width and parameters of these component strokes at the 
time of application according to the source image.

Expression includes several patterns designed for hatching (they all have “hatch” or “hatching” in their name). You can also 
design your own patterns for hatching. Hatching patterns are defined and stored like any other pattern, and are kept in the 
same list. In fact, you can use any pattern for hatching, although patterns not specifically designed for hatching are not likely 
to produce good results. For a lesson in designing a hatching pattern, see the Expression Creative Techniques guide.



To apply hatching:

Select an object to hatch. Choose Objects menu> Hatch. Choose a hatch pattern from the Hatch Pattern list. Scale the 
pattern by entering a value in the Scale Pattern entry box or click on the up and down arrows. This option can be used to 
enlarge or reduce the size of the tile used in the pattern.

Click Scale Stroke Width to control the width of each hatching stroke based on the light and dark intensity of the background 
color. Control the contrast by adjusting the Min. Intensity scale and/or Max. Intensity scale. When this checkbox is 
deselected, hatching behaves just like a pattern—the strokes do not vary in width. 

Click Use Background Color to color the hatching strokes with the object’s original color. When this option is deselected, 
hatching is applied to the object based on the intensity of the original color. The color is discarded and only hatching 
remains.

Click Keep Original Paths to include the object’s original path in the hatched image. When this option is deselected, the path 
itself is discarded and the resulting object consists of only the hatching pattern.

Click OK. The hatch is applied to the selected object.



Hatching Results

After hatching has been applied the boundary path is deleted by default. Any other objects used as source imagery are 
unaffected. The final result of a hatching operation is simply a group of strokes.



Creating and Editing Skeletal Strokes

We provide you with a number of predefined Skeletal Strokes located in the Stroke Warehouse palette but the real power of 
Expression comes as you create and edit your own Skeletal Strokes.

Expression allows you to create a Skeletal Stroke from any vector picture, whether it is clip art, artwork you create in 
Expression, or artwork you import from another application.

See also:

To define a new Skeletal Stroke: 

Using Anchoring

Repeating Elements of a Stroke



To define a new Skeletal Stroke:

Create or open a picture you would like to use as a Skeletal Stroke.

Click the Definition Tools icon in the Tools toolbar and choose the Stroke Definition Box tool. The cursor changes to a 
crosshair. Drag a marquee around your picture defining its reference frame. An outline of the reference frame appears and 
an arrow indicates the direction of the stroke.

Consider the following when creating the reference frame:

Be aware of exactly how you draw your marquee: The stroke includes any space before, after, above or below the paths 
in your stroke, if that space is included in the reference frame. 

Any object partially or completely enclosed in the marquee is included in the selection. However, you can delete or edit 
the objects after you take them into the Stroke Definition window.

Instead of using the Stroke Definition Box tool, you can select the objects you want to include in your Stroke, and choose 
Stroke menu> New Stroke Definition.

If an object you are including in a stroke definition contains a pattern fill, the pattern will appear to be scaled differently in the 
Stroke Definition window. If the pattern has an excessive amount of white space, it may not be visible in the Stroke Definition 
window. Don’t worry—the display of the pattern in this window is for reference only. When you draw with the stroke, the 
pattern will be scaled correctly.

Stroke Definition window appears displaying your new stroke and its reference frame. You can continue editing your picture 
from this window using the standard drawing tools

Use anchoring or repeating as desired to maintain the aspect ratio or repeat certain elements along a path.

When you are happy with the picture, click the Define button at the lower left of the window or choose Stroke menu> Define 
Stroke. The Define Stroke dialog appears



Using Anchoring

When you apply a Skeletal Stroke to a path, the Skeletal Stroke stretches or compresses to fit the path. When a stroke 
stretches or compresses, its aspect ratio—the ratio of width to height—changes, distorting the appearance of the stroke. 

You can control this distortion by using anchoring to constrain the aspect ratio of the entire stroke or just a part.

See also:

Creating Anchors



Creating Anchors

Anchoring allows you to define what part of the stroke maintains its proportion when the aspect ratio of a path is changed.

Anchors can be created at the beginning and/or end of a stroke, or at a fixed point along the stroke.

From within the Stroke Definition window, click the Anchor/Repeat Tool icon from the Tools toolbar and choose the Anchor 
tool.

Drag a marquee to select all points to be included in the anchor. Shift-click to select additional points or to remove points 
from the selection.

Choose an anchor type from the Actions toolbar to create an anchor. You have the following options:

Anchor node at the start of stroke. You can also choose Stroke menu> Anchor to Start. 

Anchor node at the end of stroke. You can also choose Stroke menu> Anchor to End. 

Anchor node at a fixed point along the stroke.

To remove an anchor select it then click the Anchor Free button from the Actions tool. You can also choose Stroke menu> 
Free Anchor. The node is removed from the anchor. Any other nodes belonging to the same anchor is not affected..

Relocating Anchors

After you have created an anchor, you can move it anywhere along the length of the stroke reference frame. Moving an 
anchor does not move the associated nodes; it simply changes the point to which they are anchored.



Repeating Elements of a Stroke

You can designate certain elements of a stroke to repeat instead of stretching to fit your path. This function can be very 
effective if you plan your stroke carefully. 

For example, you could create a train consisting of an engine, a passenger car and a caboose. By designating the 
passenger car as repeating, with just one path you can create a train consisting of numerous passenger cars but only one 
engine and one caboose.

See also:

To repeat part of a stroke: 

Anchoring the Starting and Ending Points of a Repeat Frame



To repeat part of a stroke:

From the Stroke Definition window, click the Anchor/Repeat Tool icon from the Tools toolbar and choose the Repeat tool. 
Drag a marquee to select all objects to be included in the repeat.

Shift-click to select additional objects or to remove objects from selection.

Click the Make Repeating button from the Actions toolbar. A Repeat frame appears, indicating that the selected objects have 
been designated to repeat, rather than stretch along the path. 

You can also choose Stroke menu> Make Repeating.

Unlike the Anchor tool, which operates on node selections, the Repeat tool operates on object selections. Individual nodes 
cannot be selected with the Repeat tool 

The Repeat frame has draggable handles which allow you to specify the portion of the stroke (as a percentage of the 
entire stroke length) over which the selected object(s) should repeat. By default, the Repeat frame covers the entire 
reference frame, meaning that the object(s) repeat over the entire length of the stroke.

If desired, use the Repeat tool to drag the center handle on either end of the Repeat frame left or right. This specifies the 
start and end points for the repetition, as percentage values of the entire stroke length.

The top and bottom handles on the right end of the Repeat frame allow you to scale the repeating object(s) up or down as 
they repeat. By default, the handles are set so that the object(s) do not scale.

If desired, use the Repeat tool to drag the top or bottom handle on the right end of the Repeat frame up or down. This 
specifies the extent to which the object(s) are scaled as they repeat along the path. When you drag one handle the other 
mirrors it, constraining the scaling to be centered vertically on the stroke’s horizontal axis.



Anchoring the Starting and Ending Points of a Repeat Frame

If you want, you can anchor the starting or ending point of a Repeat frame to the beginning or end of the stroke, respectively. 
In this case, the limits of the Repeat region are not defined as percentages of the stroke length (proportional to its width), but 
as set distances from the ends of the stroke.



Creating Multi-view Strokes

Expression's Multi-view stroke feature is particularly useful for adding variations to your artwork. It also allows you to create 
simple animations with very little work. This section explains how to create and edit Multi-view strokes. 

Whereas ordinary Skeletal Strokes are defined from a single picture, a Multi-view stroke is defined from a sequence of 
different (but closely related) pictures. Expression treats these pictures as different views of a single stroke, any of which 
may be used each time you apply the stroke. Each view is assigned a shape parameter between 0% and 100%, which 
allows you to specify which view to use. Because Expression automatically generates “in-between” views from the original 
views in the Stroke definition, a Multi-view stroke can have a wide range of appearances.

To add randomness to your artwork, you can create a Multi-view stroke and have Expression randomly pick a view each 
time you draw with the stroke. Or, if you prefer a more controlled approach, you can explicitly specify which view to use for 
each instance of the stroke. For example, a Multi-view stroke might be used to simulate a brush which spatters paint in spots 
of varying size and shape; because each instance of the stroke is slightly different, the simulation is more convincing. The 
same principle also applies to Graphic Element strokes. You could design a Multi-view stroke to create an entire school of 
fish, each one slightly different, without the tedium of tweaking a bunch of duplicates.

You can animate with Expression by treating a Multi-view stroke's sequential views like keyframes in an animation. 
Expression automatically creates the “in-between” frames. Any Multi-view stroke can be rasterized (converted to a bitmap) 
and saved as a movie. You can save movies in any of the following formats: QuickTime (Macintosh), AVI (Windows), or a 
sequence of still images in any of the formats Expression supports. 

The basic process for designing a Multi-view stroke is straightforward. You simply draw (or import) artwork for the stroke's 
initial view. Then, within the Stroke Definition window, you create additional views by editing the initial artwork with 
Expression's editing tools. The only limitation is that there must be a one-to-one correspondence between objects and nodes 
across all of the views in a particular stroke. That is, you cannot add or delete objects or nodes from one view to the next.

See also:

To create a Multi-view Stroke: 

Adding Views

Multi-view stroke within a Multi-view stroke

Moving a View

Saving Multi-view Strokes as Animation



To create a Multi-view Stroke:

In the Stroke Definition window, click the Add button. A new view is added to the stroke. A View marker representing the new 
view is added to the right end of the View bar. 

A selected marker indicates which view you are currently working on. The shape parameter of the current view (a 
percentage value between 0% and 100%) is displayed to the right of the View bar. Using any of the Selection tools and 
Transformation tools (Rotate, Scale, Mirror and Shear), move and edit objects and points in the selected view. 

You can also edit certain attributes of any Skeletal Strokes within the view. Create additional views and adjust the spacing 
between views if desired. 

Click the Define button in the lower left corner of the Stroke Definition window to define the stroke. 

Enter a name for the new stroke, enter a default width and specify a directory in which to save the stroke.

Click OK. The stroke is automatically added to the Stroke Warehouse palette. Multi-view strokes are identified in the Stroke 
Warehouse palette by a blue dot.



Adding Views

A Multi-view stroke can have as many views as you like. Rather than draw each new view from scratch, you edit existing 
nodes (points) to create new views. You can add a new view at a specific point along the View bar, or automatically add a 
view halfway between two existing views.

When you create a new view, its initial appearance is automatically generated by Expression, based on the adjacent views. 
You can then use the Selection tools and the Transformation tools (Rotate, Scale, Mirror and Shear) to move and reshape 
the paths to your liking. If your Multi-view stroke contains instances of other Skeletal Strokes, you can also use the Paint 
Style palette to change certain attributes of these strokes width, shear angle and shape between views.

Only the positions of object and nodes and the stroke parameters listed above can be changed between views of a Multi-
view stroke. Any other changes you make while working in a particular view are applied across all of the views in the Multi-
view stroke. Such changes include adding or deleting objects, changing colors, etc.



Multi-view stroke within a Multi-view stroke

Try using one Multi-view stroke within the definition of another Multi-view stroke. You can use the Shape slider on the Paint 
Style palette to change the appearance of the nested Multi-view stroke from one view to the next. This allows the nested 
Multi-view stroke to behave like an “animated sprite” within the other Multi-view stroke. For an example of this technique, 
see the Expression Creative Techniques guide which came with your documentation.

If a Skeletal Stroke is used in the construction of a Multi-view stroke, the shear and width information of that stroke is 
actually stored as the position of its Shear/Width handle. On generating the in-between views, the Shear/Width handles are 
interpolated in the same manner as other nodes. This approach could sometimes result in a fluctuation of the shear and 
width of a moving stroke between a pair of views, even if the shear and width of that particular stoke are identical in both 
views. The effect can be minimized by inserting an extra view if the fluctuation is particularly noticeable



Moving a View

After you have created a view, you can drag its marker left or right along the View bar to change its shape parameter. This 
allows you to alter the spacing between views, or even the order of the views.

From the Stroke Definition window, select a view marker in the View bar.

Drag the view marker left or right along the View bar to its new position. The view's new shape parameter is displayed to the 
right of the View bar



Saving Multi-view Strokes as Animation

A Multi-view stroke may be saved as a movie, allowing you to create a simple animation. When you use a Multi-view stroke 
to animate, you can think of the stroke's views as key frames, and the View bar at the top of the Stroke Definition window as 
a timeline. The relative timing of the events in your animation depends on the spacing of the views along the View bar. The 
rectangular reference frame in the Stroke Definition window acts as a viewfinder, everything within the frame is “on camera.”

To create a movie, Expression must rasterize the Multi-view stroke to create a sequence of bitmap images. You can specify 
the duration of the movie (in seconds) and the frame rate (in frames per second), as well as the height, width and resolution. 

If you leave the resolution set at 72 dpi (the default) and enter the height and width in points, then the height and width 
values you enter correspond to the actual height and width of the animation in pixels. This is generally recommended, since 
animations are for viewing on screen and are usually measured in pixels rather than real-world units.

You should consider the final format of your animation when choosing its height, width and frame rate. For on-screen 
multimedia animation, a frame rate of about 15 fps and height and width of 320x240 pixels are typical. When producing 
animation for the Internet, lower frame rates and smaller sizes are often used to keep file sizes small. Television animation, 
by contrast, is generally 640x480 pixels at 30 fps. 

The type of compression you use also plays a role in the file size and playback rate of your animation. Experiment with the 
compression options offered by QuickTime (Macintosh) and Video for Windows (Windows) until you find the settings that 
best suit your needs.

A finished animation can be saved in any of the following formats: Quicktime (Macintosh), AVI (Windows), or a sequence of 
still images in any of the bitmap formats 

Expression does not have the ability to play movies, so you need to view your completed animations in another application. 
Your computer probably came with a utility for playing movies. If not, you can acquire a shareware movie player at little or no 
cost via the Internet, an on-line service or a local user group.

See also:

Choosing Video Compression



Choosing Video Compression

Animations can consume a significant amount of hard disk space. If you have disk space limitations, you will want to 
compress any movies you make.

The software compression and decompression algorithms (called codecs) that you can select in the Video Compression 
dialog are provided with QuickTime (Macintosh) or Video for Windows (Windows). Codecs compress data when you render 
an animation and decompress the data when you play the movie. Any Macintosh or Windows system with QuickTime or 
Video for Windows software can play back a compressed movie.

If you are using hardware for MPEG compression, see the instructions that accompanied your board for a description of 
available compression options.



Printing from Expression

Like other draw programs, Expression produces artwork which is vector-based. Unlike bitmap images, which simply consist 
of many colored pixels (dots), vector images consist of mathematically defined curves with control points. This is why 
Expression artwork is so highly editable, and why it prints beautifully at any size. However, because printers work by placing 
tiny dots of ink, toner, or dye on the page, a vector image must be converted to dots (rasterized) before it can be printed.

When you print artwork from Expression, you can let your printer rasterize the image, or you can have Expression rasterize 
the image before sending it to the printer. Which option you choose depends on the image itself and the capabilities of your 
printer. A checkbox in the Print dialog allows you to choose each time you print an image.

See also:

Printing Images with Transparency

Quality Considerations

Performance Considerations

Printable Area

Printing Your Work



Printing Images with Transparency

Because printers do not yet support transparency in vector images, the only way to preserve transparency when printing an 
Expression image is to have Expression rasterize the image before sending it to the printer. If you choose to let your printer 
rasterize an image with transparency, the transparency will simply be ignored; objects which are transparent will be printed 
as if they were opaque.

Many of the Natural-Media strokes included with Expression use transparency to achieve subtle effects, so your image may 
include transparency even if you have not explicitly applied it.



Quality Considerations

Having Expression rasterize an image is generally the best way to ensure that the printed image will faithfully reproduce the 
image on screen. However, many images will look equally good when rasterized by your printer, and may require less time 
and system resources to print (see ä“Performance Considerations,” later in this chapter). 

In general, it is best to rasterize your image at a resolution (dpi) one and a half to two times the linescreen frequency (lpi) of 
your printer. Most laser printers have a linescreen frequency of approximately 60 lpi. Most high-end image setters have a 
linescreen frequency of 100-150 lpi.

You may want to rasterize at lower resolutions when printing proofs to speed up the printing process. You will rarely, if ever, 
want to rasterize at a higher resolution (dpi) than your printer is capable of printing. If you are not sure of your printer’s 
resolution (dpi) or linescreen frequency (lpi), consult the printer’s documentation or contact its manufacturer.

Most printers are capable of rasterizing vector images, but not all printers rasterize images in the same way. Expression 
supports PostScript-compatible printers (Macintosh and Windows), PICT-compatible printers (Macintosh), and WMF-
compatible printers (Windows). PostScript printers tend to do a better job of rasterizing Expression artwork than non-
PostScript printers, because non-PostScript printers do not support some Expression features (e.g., clipping, BŽzier curves, 
and the Non-zero Winding rule for fills). As a result, certain Expression images may not print satisfactorily when rasterized 
by PICT- or WMF-compatible printers.

If you are not satisfied with a printed image which was rasterized by your printer, try printing the image again with the 
Rasterize Before Printing option enabled.



Performance Considerations

When Expression rasterizes an image, your computer will be busy for a time (perhaps up to several minutes for a complex 
image printed at high resolution). However, once the image has been sent to the printer, it will print in less time, since the 
printer does not have to rasterize it.

In general, the total time required to print should be comparable whether the image is rasterized by Expression or by your 
printer; the option you choose simply determines how the printing task is divided between the computer and the printer. 
However, if you are running Expression on an older or lower-powered system, you may find that images print considerably 
faster when rasterized by your printer. Likewise, if your printer is older or less powerful, rasterizing the image before printing 
may yield faster results.

The amount of RAM and hard disk space available to Expression may also affect your choice. Expression requires 
additional memory to rasterize an image. If there is not sufficient memory available, a scratch disk is automatically used to 
temporarily store information. If you experience trouble when rasterizing an image in Expression, check to make sure that 
you have as much memory available to Expression as possible, and that you have some free space on your hard disk. If you 
are still unable to print the image, try printing with the Rasterize Before Printing option disabled (transparency and perhaps 
certain other features of your artwork will not be supported in this case.



Printing Color Separations of Expression Artwork

Expression does not directly support color separations. However, Expression artwork can be exported in either bitmap or 
vector format and separated in another application. When you export for separations, some of the printing limitations 
described above apply, most notably the fact that vector formats do not support transparency. 

If you want to produce separations from an image which includes transparency, you should export the image in a bitmap 
format. It can then be converted to CMYK and separated in an image editing application. 



Printable Area

Each printer and paper size combination has a specific printable area associated with it. Expression allows you to place 
artwork elsewhere but only the artwork within the printable area prints. 

Generally, place your artwork inside the Workspace within the Expression document window. If you change your printer you 
need to check that your artwork still lies within the confines of the printable area



Printing Your Work

Expression allows you to print to most color and black and white printers. Some print options vary depending on the printer 
and driver you choose.




