Help IDs

0-89 currently unused
90-99 jumps to Internet or email address (94-99 currently used)

100+ regular IDs (100-122 currently used; 123-124 spares) Note that the Context String should show the ID number otherwise
you'll never find them in the future.



Test page 123
This page is currently unused. It is a place marker for Help ID 123.



Test page 124
This page is currently unused. It is a place marker for Help ID 124.



2D Objects are two dimensional objects imported in Windows metafile (WMF & EMF) format or Xara WEB & XAR format. Use
Import on the File menu to import 2D objects. Or use Import button if you want to use the object as a button shape.



Creating buttons

You can use Xara3D to produce instant 3D buttons in a variety of shapes.
To create a button

1. Click Button options (the U button). This opens the Button Options dialog box.

2. Select Button in the dialog box. This creates a button showing the current text wording. The colors, texture, extrude and bevel
of the button are the current settings.

3. Select a button shape from the drop-down list (see Notes).

If the button doesn't have the right bevel or extrude depth, you can edit these in the regular way.
Notes:
L] ALT+U or Button on the Window menu also displays the Buttons dialog box.

u For extra button shapes click Import button on the dialog box. This displays the Buttons folder. You can also add your
own button shapes to this folder; this makes them easily available for future use - details.

L] You can also import a 2D shape and use it to create a 3D button - more details.
L] After creating a button you can edit the wording in the regular way. See Altering the text. (But see the next Note.)
L] See this page for details of changing the text size or position on the button.

Related topics
Buttons



Link page (94)
This jumps to www.xara.com/examples
Help closes automatically.



Link page (95)
This jumps to www.xara.com
Help closes automatically.



Link page (96)
This jumps to www.xara.com/xara3d
Help closes automatically.



Link page (97)
This jumps to an email to xara3dsuggest@xara.com
Help closes automatically.



Link page (98)
This jumps to a www.buyfonts.com
Help closes automatically.



Link page (99)
This jumps to www.xara.com/xara3d/helpv4/techniques.html
Help closes automatically.



Altering the effects applied to individual characters

You can alter any of the effects (such as color or extrude depth) applied to an individual character or selected group of characters.
This lets you give, for example, one character a different bevel shape to the other characters in the heading. The exception is a text
texture - this is common to all characters.

Altering the effects:
1. Select the character or characters you want to alter - more details.
2. While the characters are selected, any changes you make apply only to those characters.

Related topics
Altering characters



Altering the 3D extrude

Pressing the E button (or ALT+E on the keyboard) displays the Extrusion Options dialog box. This lets you change the extrude 3D
depth.

More information on the Extrude Options dialog box.

New for version 4: you can apply a different extrude to a part of the text. Select the characters you want and then change the
extrude.



Altering the Bevel

To adjust the bevel (the type of corner applied to edges):
1. Press the B button to display the Bevel dialog box.
2. Select from the list of bevel types (see Notes).
Set the bevel size by typing into Depth.
Select Miter or Round (see notes).

Notes:
L] ALT+B also displays the Bevel dialog box.
L] Bevels go along the sides, not the face. So, for example, selecting the 'Curved' bevel produces a budge effect to the

extruded part. This also means the bevel takes the color of the sides. (In Xara3D4 the color of the face can be different to the color
of the sides.)

L] Square Faced & Square Cornered bevels are particularly effective when the sides are a different color to the face. This
can give the effect of a two-colored face to the text.

L] Beveled objects are slower to display than objects with no bevel.

L] The Miter and Round options affect the corners of objects. Usually text has sharp mitered corners, but you can round the
corners by selecting Round. This is usually only obvious for fonts that have sharp corners or serifs.

L] New for version 4: you can apply a different bevel to a part of the text. Select the characters you want and then change

the bevel.



Altering the background color or texture

To use a flat color as the background behind the text:
1. Choose Background Color from the View menu. This displays the Color Options dialog box.

To use a bitmap texture as the background:
1. Choose Background Texture from the View menu.
You can also drag-and-drop textures onto the background.

Bitmap texture backgrounds are useful where you want a 3D text heading to appear on a web page that has a texture
background. Using the same bitmap as the web page background ensures that any 3D heading 'fits in' with the whole page
background. You can import any BMP, PNG, JPEG or GIF file as a background and Xara3D repeats this (tiles it) in exactly the
same way as a Web browser.

After choosing a texture you can move it relative to the the text. Either drag on the background (not the text) or, for more
precise control, use the Texture dialog box.

Note for Version 2 users:

The texture is now stored in the X3D file. If you give the X3D file to someone, you no longer need to give them the texture file as
well.



Altering the font

Use the drop down list on the Text Toolbar (at the bottom of the window) to alter the font. Any installed TrueType font is available in
the font list. With Xara3D you may find that some of the more unusual block and ‘curvy’ fonts work particularly well.

Click B (or press CTRL+B) to make the text bold.
Click I (or press CTRL+1) to make the text italic..

Notes:

L] You can also click the T button at the top of the window to display the Text options dialog box. This lets you preview the
different fonts installed on your computer. Click on a font name and use the up/down cursor (arrow) keys on the keyboard to step up
and down the list of fonts.

L] New for version 4: you can apply a different font to a part of the text. Select the characters you want and then change
the font.



Altering the lights

Xara3D has three lights shining on the objects. These lights can be any position and color.
To view the lights:
1. Press the ‘light bulb’ button. (You can also press CTRL+TAB.)

This shows the three lights, represented by colored arrows. A fourth arrow (striped arrow) controls the position of the shadow.
To change the color of a light:
1. Double click the appropriate light arrow. Or select from the View menu.
This displays the Color Options dialog box.
Details of changing the color of the shadow.
To reposition a light:

1. Drag the arrow. This rotates the light around the text object.
To move a light behind the objects, just keep dragging right or left until it rotates behind the objects.

Notes:

u An alternative way to control the light colors is right-click on the window. Or use the View menu. Either brings up a pop-up
menu that lets you control the lights as well as colors or bitmap textures.

L] You can rotate the lights in some animation types - see Creating an animation.



Altering the Shadow

Xara 3D includes an advanced shadow tool that can give a very realistic effect of the object hanging in front of a surface. The
position of the shadow is controlled by one of the arrows in the lighting control. The shadow blur and darkness is controlled from the
Shadow Dialog Box - click the S button. You can even control the color of the shadow for special effects.

Note: GIFs with shadows are usually larger than with no shadow. Also the further the shadow is away from the text, or the more
blurred, the larger the file. To get the most realistic shadow effects on your web page, ensure the Xara3D background matches that
of the web page. See Shadows and Backgrounds for details.

What do you want to do...

adjust the shadow position?

blend the shadow into a background?

display or remove the shadow?

change the shadow style (type)?

change the shadow color?

change the shadow transparency?

change the shadow blur?



Altering the text

Maximum number of characters: 120

You can either directly edit the text in the window or use the Text Options dialog box. Text Options is easier to use when editing
complex text that is slow to redraw on screen. Click the T button to open the Text Options dialog box (or press ALT+T.)

What do you want to do...

add characters to the end of the text?
delete characters from the end of the text?
start a new line?

add or delete characters in the middle of a line?
change only selected characters?

change the spacing between characters?
make characters wider or narrower?
change the height of selected characters?
change the spacing between lines of text?
change the alignment of lines of text?

make text hollow (outlined)?

type in accented (international) characters?

start a new page in a multipage animation?
merge two pages in a multipage animation?
move or resize the text on a 3D button?




Altering the text color

You can make the text any color. This color is then modified by the three lights shining on the text.

Changing the text color:
1. Choose Text Color on the View menu. This displays the Color Options dialog box. (Or double-click on the text.)
2. Select the color you want. (See Notes.)
If you select anything but a very light or pale color you'll find the light colors have relatively little effect.
Note that you can use the same color on the faces (front/back) as on the sides. Or you can have the faces a different color to
the sides and bevel. Select the required option from the drop-down list in the Color Options dialog box.
Shiny or matt text surface

The surface of the text can be shiny or matt - this alters the reflectivity of the surface. The Extrude dialog box controls this. Press the
E button (or ALT+E on the keyboard) to display this dialog box.

However the difference won't always be obvious unless the lights are at the necessary angle to reflect off the surface. This is usually
by moving a light behind the text (keep dragging the light right or left so it goes behind) so it can reflect off the surface of the text.

Notes

L] New for version 4: you can apply a different color to a part of the text. Select the characters you want and then change
the color. Note you can tint a texture to change its color slightly.

L] New for version 4: the sides (and bevels) can be a different color to the face of the text.

u If you are creating a 3D button, select Button text to change the text color. The front and sides options change the button
colors.

L] Changing the color automatically removes any texture already applied to the text or background. Select Texture to
reapply the texture.

L] If you want to tint a texture (modify its color), select Texture and Tint.

See also:

Coloring the text using a texture



Animation dialog box
You can create Animated GIFs and AVI movies using Xara3D. You can preview the effect of the current Animation settings by
clicking Start/Stop Animation on the Toolbar. More details of creating animations.
To display this dialog box:
1. Either click Animation Options on the Toolbar at the top of the window
or choose Animate on the Window menu
or press ALT+A.
Frames per cycle

Dimmed for Step animations.

This is the number of frames for each complete cycle through the animation sequence. The greater the number of frames the
smoother the animation. The drawback is that the file is bigger - this is a big disadvantage for web graphics. You may need to try
different values to get the best results.

Multipage animations: this is the number of frames in the entire animation.

Frames per second

Dimmed for Step animations.

The animation speed. Slow speeds can give jerky movement. High speeds can also give jerky movement as the program displaying
the animation may not be able to keep up. Again you may need to try different values.

Pause

You can only pause Animated GIFs not AVI movies.

This pauses the first frame before continuing the rest of the animation. Type in a value in centiseconds (1/100ths of a second) - a 2
second pause is 200 cs. Note that this applies only to the first frame; use Frames per cycle and Frames per second to control the
overall speed of the animation.

Multipage animations: Pause applies to each page in the animation.

Loop

This applies to Animated GIFs not AVl movies.

This lets you specify how many times the animation should repeat itself. Note that some browsers take any value other than 1 to
mean 'loop forever'. Therefore, your animation either plays once or forever. Other browsers may display the animation correctly.
Style

This controls the type of animation:

Rotate options:

Rotate 1 rotates all the text as one; Rotate 2 rotates each character. (Buttons have a single Rotate option.)

Front face only - normally the animation shows only the front face of the text and not the back. This looks better and makes the
exported file smaller (because there's only half the number of frames.)

Rotate text/Rotate lights - select whether you want the text to rotate or the lights or both. You cannot rotate the shadow as this
would create very large files.

Direction - selects the direction of rotation.

Swing options:

Swing 1 swings all the text as one; Swing 2 swings each character. (Buttons have a single Swing option.)

Angle - how much you want the heading to swing.

Angle check box - when selected the heading rotates through 180°. This button mainly applies to multipage animations. With
Angle selected, the animation moves to the next page after each complete rotation (a complete left & right or up & down cycle).
With Angle unselected, the change to the next page is at the start of each swing (for example, as the heading starts to swing
left and then again as it starts to swing right). This means you can create animations with half the number of frames as with
Angle selected.

Direction - selects the plane of rotation. Clockwise only has an effect if you Pause the animation.
Pulsate options:
Pulsate 1 pulsates all the text as one; Pulsate 2 pulsates each character. (Buttons have a single Pulsate option.)

Minimum text size - how far back to pulsate the text.

Shrink+Grow & Grow+Shrink - only have an effect if you Pause the animation. These options select the starting point for the
animation (maximum or minimum.)

Fade options:
Fade in - the heading emerges from the background color.
Fade out - the heading merges into the background color.
Step options
This displays a series of static (non-rotation) headings in a multipage animation.



Frame duration - how long to display each page in the animation.



Bevel dialog box

The bevels are the joins between the face and sides of the 3D objects, More details on using bevels.
To display this dialog box:
1. Either click Bevel Options on the Toolbar at the top of the window
or choose Bevels on the Window menu
or press ALT+B.
Bevel types
Select from the list.
Miter/Round

These affect the corners of the letters. Miter gives square edges; Round rounded edges. Which you use depends on the effect you
want.

Depth
This is the depth (size) of the bevel.



Making buttons wider or narrower
By default the width of Xara3D buttons is the same as the height. You can change the button to make it wider or narrower (change
the aspect ratio).
To change a button's aspect ratio
1. Click Button options (the U button). This opens the Button Options dialog box.

2. Use Stretch to set a different aspect ratio (width:height). 100% creates buttons with the same width as height; above 100%
makes the button wider.

If the button doesn't have the right bevel or extrude depth, you can edit these in the regular way.

Notes:
L] ALT+U or Button on the Window menu also displays the Buttons dialog box.
L] See this page for details of making the text wider or narrower.

Related topics
Buttons



Changing the corner radius of buttons

You can alter the radius of the corner of Xara3D buttons. Alternatively you can make the corners square (no radius).
To change the corner radius

1. Click Button options (the U button). This opens the Button Options dialog box.
2. Use Corners to set the radius (curvature) of the corners. 100% is the default radius; above 100% increases the radius.
Deselect Corners for no radius (square-edged). This is the same as 0% radius.

Notes:

L] ALT+U or Button on the Window menu also displays the Buttons dialog box.

Deselecting Corners (or using small corners) for the Rounded option creates a diamond.
Related topics
Buttons



Button dialog box

To display this dialog box:
1. Either click Button Options on the Toolbar at the top of the window
or choose Button on the Window menu
or press ALT+U.

Button

Select this to create a button with the current text in the center.

Drop-down list

Select the required button shape.

Stretch

At 100% the button has the same width as height. Below 100% the width is less than the height. Maore details.
Corners

Check Corners if you want rounded corners to the button. You can then change the radius by typing into the text field. 100% is the
default radius for the selected button type. More details.

Import button
Import a 2D shape (Windows metafile WMF/EMF, Xara WEB/XAR) or Xara3D XAR file as the button shape. More details.

Related topics
Buttons



Resources on the CD version

The CD is mailed to you when you purchase Xara3D. The CD contains extra examples, textures, and fonts.

L] Example 3D graphics
u Textures
L] Fonts: there's a range of extra fonts. See Installing fonts.

To access these folders on the CD:
1. Load the Xara3D CD in the CD drive.
2. Double-click the My Computer icon. This displays the drives on your computer.
3. Right-click (do not double-click) on the CD icon. This displays a menu.
4. Choose Open - this displays the contents of the CD.
5. Double-click on the folder you want to use.

You can use the examples and textures either direct from the CD or copy them to your hard drive. Copying all the examples and
textures requires about 40Mb of hard disc space. Do you see several files with the same name?

You must install the fonts before you can use them - details of installing fonts.



Many of the examples have long descriptive names such as "Hollowed Red.x3d" and "Hollowed Blue.x3d". This makes it easier to
identify them. Unfortunately some older CD drivers limit filenames to a maximum of 8 characters (plus suffix). If you have drivers like
this you see both files as "Hollowed.x3d". This is beyond the control of Xara3D. Check with your local dealer to see if there are
updated drivers available.



Example 3D graphics

These are in the Examples folder. You can use these examples as templates for your own heading. Find an example similar to the
heading you want to create. Customize it to your requirements and then export it. Simple.

Examples are divided into categories to make navigation easier.



Textures:

These can be used either on the face of your headings or as backgrounds behind them. Textures are regular GIF files so you can
use them as background on your web pages.

L] Using textures to color headings
L] Using background textures

Textures are divided into Coarse (very large patterning), Medium, and Fine (small patterning.) These are subdivided into high
contrast (large color changes), middle, and low contrast (subtle color changes.)

Wood & Stone are collections of textures based on wooden or stone/gravel photographs. All these textures are duplicated in the
Coarse, Medium, or Fine folders.

Words are text messages that you can use to create 3D buttons. Xara3D includes a range of button shapes (more details). You can
also import your own shapes (see Importing 2D objects) and then use these textures to add a message. There's more details on the
web site at www.xara.com/xara3d/helpv4/techniques.htm



Changing button size

After creating a Xara3D button you can resize it in the regular way by either
L] resizing the window
L] or selecting a point size from Font size on the Text toolbar.
You can also resize the text - more details.
Related topics
Buttons



Changing the Default document

(The Default document is the document you see when you click New.)

1. Open a new document.

2. Make the changes you want (for example, changing the text).

3. Choose Save as default on the File menu.
To restore the original Default document, delete the file Default.x3d in the folder where you installed Xara3D.
Related Topics:

Customizing Xara3D



Changing the short cut

Installing Xara3D places a short cut to the program in the top level of the Programs menu.

To move the short cut to a submenu:
1. Right click on the Start menu on the Taskbar and select Open.
2. Double-click on Programs. This displays the contents of the top level menu with Xara3D shown at the bottom.
3. To move Xara3D to another folder simply drag-and-drop it over the desired folder.

To create a short cut on the Windows desktop:
1. You can drag the Xara3D icon onto the Desktop to create a short cut for launching the program.



Color Options dialog box

The Color Options dialog box lets you select any hue and any shade of color.

To display this dialog box:
1. Either click Color Options on the Toolbar at the top of the window
or choose Color on the Window menu.

To select a color for editing:
1. Select from the drop-down list at the top of this dialog box.
Note that you have three options for the text: edit both the faces and the sides, the faces only, or the sides only.

The current color is displayed in the square on the right of the dialog box. This square shows hatching if the text uses multiple
colors.

To adjust the shade:

1. Click or drag on the central area of the Color Options dialog box. You'll see the exact color in the top right corner of the dialog
box.

To alter the hue:
1. Click or drag on the rainbow strip along the lower part of the dialog box.

HSV and RGB

If you want a exact color type in values:
HSV (Hue, Saturation, Value) Hue is a color wheel with values in the range 0-360 degrees. Saturation and Value are percentages.
RGB (Red, Green, Blue) Enter values in the range 0-255 or 0-FF (see Hex below.)

You can create the same range of colors using either HSV or RGB - use the one you are familiar with.

Hex

You can define RGB colors as either 0-255 (Hex off) or O-FF (Hex on.) These are identical (256 steps), just different ways of
showing the same value.

Many color lists show RGB colors as six characters such as FFO57F. To use this color R=FF G=05 B=7F.
Texture:

Select this if you want to display a bitmap texture on the face of the text or the background. You can use Text texture or
Background texture on the View menu or the Texture Options dialog box to select a texture. (This duplicates the Texture button in
the Texture Options dialog box.)

Tint:

(Dimmed unless Texture selected. This duplicates the Tint button in the Texture Options dialog box.)

L] Unselected: display the original colors of the texture bitmap.

L] Selected: tint (modify) the bitmap colors by the color selected in this dialog box. Note that dark colors can hide detail in

the bitmap.



Help for Xara3D

Welcome to Xara3D, a ‘slimware’ program that produces great, super high quality, three-dimensional 3D headings, and animated
GIFs/AVIs in seconds.

This Help is deliberately simple and lacking illustrations to keep the download size small. An enhanced version of the user
documentation is available on-line at www.xara.com/xara3d/helpv4/ F3*
(Blue text and E3* denote links to an Internet page; click to go to that page.)

Getting Started:
These pages help you when you first install Xara3D.
Introduction
The basics
Installing the free fonts
Moving the Xara3D short-cut
Purchasing Xara3D

Unlock codes and Key codes
What's New in Version 4

Resources on the CD

License terms
How do I...?

Use these pages if you want to find out how to do something in Xara3D.
What does this do?

Use these pages to find out more about the menu options or the dialog boxes.
Other information

Customizing Xara3D

Direct3D

Keyboard short cuts

Hidden and advanced options

Uninstalling Xara3D

Technical Support
Version 4.00 April 2000

All trademarks acknowledged.
Geotype, Greek Diner, Russel Write, and Whimsy fonts kindly provided by Gary David Bouton.

Many of the WMF symbols on the CD are letters from EFF fonts - Creatures, Chess, Symphony, Picturesque, Birdie and ArrowPi -
gliCh are some of the variety of quality fonts from the EFF range which can be purchased from our web site www.buyfonts.com/

Other WMF symbols are courtesy of James Parry or come from the Publish Art CD produced by SmartDTP. Details about this
%gphical resource can be found at: www.intecc.co.uklusers/parrygroup/ I#* or from parrygroup@intecc.co.uk

Still more WMF symbols were produced from Gary David Bouton's symbolic fonts Geotype, Haxton and Sympols. GeoType and
Haxton are included on this CD, Sympols can be downloaded from Gary's site www.theboutons.com/ F3*

License Terms:

The license distributed with Xara3D grants you the right to use the Xara3D software (including the bundled fonts and textures) on a
single client computer at a time and by a single user at a time, subject to the restrictions listed below and the disclaimer relating to
warranties, support and damages.

1. Disclaimer: This software is provided on an "as is" basis, without any other warranties, or conditions, express or implied, including
but not limited to warranties of merchantable quality, merchantability or fitness for a particular purpose, or those arising by law,
statute, usage of trade or course of dealing. The entire risk as to the results and performance of the Product is assumed by you.
Neither we nor our dealers or suppliers shall have any liability to you or any other person or entity for any indirect, incidental, special
or consequential damages whatsoever, including but not limited to loss of revenue or profit, lost or damaged data or other
commercial or economic loss, even if we have been advised of the possibility of such damages or they are foreseeable; or for claims
by a third party. You may have other rights which vary from state to state.

2. Restrictions: This license gives you the right to use this software but all rights not specifically mentioned in this agreement,
including ownership rights, intellectual property rights, trademarks and copyright, are reserved by Xara Ltd. You may not decompile,
reverse engineer, disassemble or otherwise reduce the software to a human perceivable form. You may not modify, rent or resell for
profit the software, or create derivative works based upon the software.



Correcting mistakes

You often need to experiment to get the best results. Xara3D makes this easy - if you don't like the result use the Undo button to
discard the change. (Undo is also on the Edit menu or press CTRL+Z.) It's not just the last operation you can undo. Xara3D has
unlimited undo so you can step all the way back to the beginning.

If you step back too far, click the Redo button (also on the Edit menu or CTRL+Y) to undo an Undo. You can use Redo at any time
until you make new changes.



Creating a movie or Animated GIF

It's easy to create 3D animations and movies in Xara3D. You can preview an animation by pressing the Start/Stop Animation
button. The 3D objects can rotate, swing or pulsate around their center. You can control the animation speed and frame rate using
the animation dialog box available from the A button.

You can either animate a single heading or a sequence of headings (called multipage animations).

For rotating animations Xara3D includes an option to show only the front face of the objects. This restricts the rotation to 180
degrees so that, although it appears to perform a continuous rotation, it actually skips 180 degrees and text is always readable. This
has another significant advantage of reducing the file size of the animation, particularly important for Animated GIFs. You can also
choose 360 degree revolution if you want to see the back of the objects.

Steps to producing a movie or animation:

1. Resize the Xara3D window to the required image size. Remember that Animated GIFs need be very small to have an
acceptable download time.

2. Select the Animation dialog box (the A button) and choose the number of frames for a complete cycle through the animation.
Again for Animated GIFs the fewer the better.

3. Choose the number of frames per second (animation speed). A slow animation speed with only a few frames per revolution can
give a jerky animation - you may need to experiment to get the best results.

4. Choose the animation style (type.) More details of the animation styles.

5. Select Export Animation on the File menu. Select AVI or Animated GIF file type. Give the file a name and press Save. This
displays the Export quality dialog box where you can select the size, number of colors etc., see Export options for AVI movies
and Export options for Animated GIFs

When previewing an animation, the program displays a much lower quality to be as fast as possible - however when exporting an
Animated GIF or AVI movie Xara3D always renders all frames at the maximum quality. To preview an Animated GIF simply drop the
file onto your web browser window.

Xara3D can produce, in minutes, top quality Animated GIFs and movies that would take hours using traditional 3D design programs.

Note:

L] Xara3D Step animation displays a static (non-rotating) image. It is best used in multipage animations where a sequence
of headings is displayed.

See also
Previewing AVl movies

Tips for reducing the size of Animated GIFs




Creating button templates

Xara3D includes a range of predefined button shapes.

You can also create your own button shapes for use as templates in the future. This is very handy if, for example, you want to use a
consistent shape, bevel and extrusion for the buttons on your site. Just save this shape into the buttons folder. It also means that
you can create irregular shaped button templates from imported shapes or TrueType symbols.

To create a button template:

1. You can use either a character from a font (see Notes) or an imported 2D shape for the button shape. Load the character or
shape you want to use.

2. Select the required bevel shape and size.
3. Select the required extrusion.
4. Save the character or shape to the Buttons folder. This is in the folder where you installed Xara3D.

Notes:

L] Angles, colors, textures and shadow in the template are ignored when creating a button.

L] Symbolic fonts often contain a range of shapes suitable for use as button templates.

L] Atemplate can contain more than one character. However only the first character is used as the button shape. Other

characters are ignored.

Related topics
Buttons



Creating multipage animations

You can create animations that display a sequence of different headings. Xara3D calls these "multipage" animations.

To create a multipage animation:

1.

o0 MWD

7.

Create the first heading in the regular way.

Insert a page break (CTRL+ENTER) to create a second page.

Create the heading for this new page.

Repeat steps 2 & 3 until you have created all the pages.

Open the Animation options dialog box. (Click the A button on the Toolbar.)

Set the required animation options.

Export the animation as either Animated GIF or AVI (Export animation on the File menu).

Notes:

u
| |
box.

All headings are at the same angle and shares the same background color or texture.
You can also insert a page break by clicking Insert page break (the button showing a diamond) in the Text options dialog

You can use the PageUp/PageDown keys to move between pages. CTRL+PageUp or CTRL+PageDown moves to the

first or last page.

You can also use the Page Up/Page Down buttons on the right hand scrollbar to move between pages.
To select all the text on the current page use CTRL+P. To select all the text on all pages use CTRL+A.
See this page for general information on creating animations.



Credits

Program written by Gavin Theobald from the depths of Loughborough, England & Fort William, Scotland.
Original Help written by Charles Moir; revised, expanded and updated by Mick Robinson.



Customizing Xara3D

What do you want to do:

L] Change the Default document?

Display or hide Toolbars?
Dock dialog boxes?



Direct3D

Xara3D doesn't use Direct3D as the Xara3D engine is more advanced in many ways than the Microsoft Direct3D software solution
(for example, the anti-aliasing). Obviously having a hardware accelerator would be faster; however these are also usually inferior
and unpredictable quality and would not support the advanced features of Xara3D such as soft shadows.



Displaying Toolbars

The Window menu lets you control display of:

L] the main Toolbar at the top of the window
L] the Text Toolbar at the bottom of the window
L] the Status Bar, also at the bottom of the window

The main Toolbar and Text Toolbar can be either docked to the side of the window or free-floating - more details.
Related Topics:
Customizing Xara3D



Docking dialog boxes and Toolbars

This applies to
L] Bevel, Button, Color, Extrude, Shadow, Texture, and Animate options dialog boxes
u the main and Text Toolbars.

These can be either free-floating (you can move them independently of the main window) or docked (attached to the side of the
window.)

To dock a dialog box or Toolbar:

1. Drag the dialog box or Toolbar over either the left hand edge or right hand edge of the window. The dialog box outline changes
to a thin line when it can be docked.

To undock a dialog box or Toolbar:
1. Drag the dialog box or Toolbar away from the window. The outline changes to a thick line when undocked.

Tip:

L] If you don't want a dialog box or Toolbar to dock, CTRL-drag it.

L] At the top-left or bottom-right of the window you can dock Toolbars either horizontally or vertically. SHIFT to select
vertically.

Related Topics:
Customizing Xara3D



Edit Menu

Edit

Display the text caret ready for on-screen editing of the text. More details of editing text.
Undo

Undo the last edit. More details of Undo & Redo.

Redo

Undo the last Undo operation. More details of Undo & Redo.

Cut

Delete the selected text and put it on the clipboard. You can then paste it as plain text into other applications. Note that this loses all
lighting and 3D effects.

Copy
Similar to Cut except that this doesn't delete the text.
Paste

Paste the clipboard contents into Xara3D. This option is dimmed if Xara3D cannot interpret the clipboard contents. (For example, if
the clipboard contains a bitmap.)

Delete

Discard the selected text.

Select All

Select all the 3D objects on all pages ready for editing.

Select Page

Select all the 3D objects on this page ready for editing. Objects on other pages remain unselected.

Select Line

Select the line containing the text cursor. (By default the bottom line.) For a single line of text this is the same as Select All.
Insert Page Break

Page breaks separate pages in an animation that shows a sequence of messages.



Export options for AVI movies

Experimentation has shown that exporting AVIs as True-color (24-bit) produces the smallest file size. Perhaps surprisingly, exporting
as 256 color (8-bit) produces larger files but usually higher quality. This is because it uses a different compression system.

Current Window Size lets you export just the area surrounding the text (Crop on) or the entire window area (Crop off.)

User Defined lets you specify the dimensions of the bitmap. With Fit to Width (on the Text Toolbar) selected, the text and the
background scales to suit the values you type in. If you specified a font size, the size of the text does not change but the background
scales to the values you type in. This is useful if you want to create several headings, all the same height and width.

Note. It's very important to make sure the compression option is switched on. Even at 100% quality, compression makes the file up
to 10 times smaller.

See also:
Creating a movie or Animated GIF
Previewing AVI movies



Export options for Animated GIFs

To learn more about exporting animated GIFs see Creating a movie or Animated GIF

Because Animated GIFs can be quite large, you may find that a 16 or 32 color, optimized palette per frame, produces the best
results for the smallest file size. However you might need to experiment.

Dithering always makes GIFs look better, but also makes them larger. When outputting at 256 colors you may find that there is no
need to turn dithering on.

Current Window Size lets you export just the area surrounding the text (Crop on) or the entire window area (Crop off.)

User Defined lets you specify the dimensions of the bitmap. With Fit to Width (on the Text Toolbar) selected, the text and the
background scales to suit the values you type in. If you specified a font size, the size of the text does not change but the background
scales to the values you type in. This is useful if you want to create several headings, all the same height and width.

Note:

There is an issue with ‘optimized palette per frame’ with Macintosh web browsers. Unfortunately they all seem to have a serious bug
that prevents per frame optimization working. If you know your audience consists of Apple Mac viewers then we advise you not to
use per frame palette optimization.

See also
Tips for reducing the size of Animated GIF files



Export options for GIF, PNG or BMP

GIF export is the most common and probably the best format for use on the Web. GIF images can have no more than 256 colors,
which you might think is a limitation. However, using Xara3D'’s advanced dithering and palette optimization features, you can get
near perfect quality images using only 256 colors. Indeed you'll be surprised at how good GIFs with just 16 colors can be.

For all export formats you have control over not only the number of colors but also whether the image is dithered and has an
optimized palette. These are techniques to improve the image quality while using a reduced number of colors. For example using
only 16 color GIF nearly always produces the smallest file size, but with no dithering the shading can be poor. By using an optimized
palette and diffusion dithering you can substantially increase the quality of the result.

There are no hard and fast rules as to which combination of export options is best - it depends on the image and your requirements.
Therefore we recommend exporting in a number of different formats to see which is the best and has the smallest file size. Typical
options to try include 16 color with diffusion dithering, or 256 color with no dithering.

For examples of the different quality settings see the web page GIF quality settings I3*

When exporting as a GIF or PNG you have the option of making it interlaced (progressive rendering as it's downloaded) and
whether the image is transparent. For more details on the transparent options see the web page GIF & PNG transparency I#*
Current Window Size lets you export just the area surrounding the text (Crop on) or the entire window area (Crop off.)

User Defined lets you specify the dimensions of the bitmap. With Fit to Width (on the Text Toolbar) selected, the text and the
background scales to suit the values you type in. If you specified a font size, the size of the text does not change but the background
scales to the values you type in. This is useful if you want to create several headings, all the same height and width.

Additional quality control:

Also available from Xara is Xara Webster, which provides even more advanced color reduction facilities and can be used to further
reduce the size of files by selecting intermediate numbers of colors. To do this, export the image as a True color 24-bit BMP image
and use Xara Webster to color reduce the file to a specific number of colors.

More details on Xara Webster I3*



Export options for JPG

JPEG bitmaps are always 24-bit, true color, but the JPEG compression system means that the quality is often not as good as a GIF.
The Quality setting determines how small the resultant file is - the higher the quality, the larger the file. Quality settings less than
80% usually produce inferior images to those available from using palette optimized GIFs.

Current Window Size lets you export just the area surrounding the 3D objects (Crop on) or the entire window area (Crop off.)

User Defined lets you specify the dimensions of the bitmap. With Fit to Width (on the Text Toolbar) selected, the 3D objects and
the background scale to suit the values you type in. If you specified a font size, the size of the objects does not change but the
background scales to the values you type in. This is useful if you want to create several headings, all the same height and width.



Extrusion dialog box

To display this dialog box:
1. Either click Extrusion Options on the Toolbar at the top of the window
or choose Extrude on the Window menu
or press ALT+E.

Color
The opens the Color Options dialog box ready to change the color of the 3D objects. More details of changing colors.
Gloss/Matt

Gloss make the object surface reflective, Matt non-reflective. The best results with Glossy requires careful positioning of the lights.
See Altering the text color for more details.

Front Face
Switching off display of the front face creates hollow objects and can give interesting effects. See Hollow text for more details.
Back Face

Similar to front face but controls display of the back of the objects. This has no effect unless you also turn off Front Face or rotate
animated text through 360 degrees

Outline

Produces outline objects. This is different to switching off face display. See Hollow text for more details.
Outline Width

Controls the thickness of the outline. See Hollow text for more details.

Depth

Controls the extrude depth. See Extruding for more details.



File menu

New
Open a new document. You are warned if the existing document has unsaved changes.
Open

Open (reload) an existing Xara3D .X3D file. (A file previously saved using Save or Save as.) You cannot reload GIFs, JPEGs, AVIs,
or PNGs exported from Xara3D.

Save

Save the document as an .X3D file. This lets you reload it back into Xara3D in the future.
Save as

Save the document under a different name.

Save as default

The default document is the document you see when you select New. If you want a customized default document, make the
required changes then select Save as default.

Import

Lets you import a 2D object (Windows metafile WMF/EMF or Xara WEB/XAR.) Xara3D can then turn it into a 3D heading (more
details.)

Import button

Lets you import a Xara3D file (X3D), Xara WEB/XAR or Windows metafile and use that as a button shape. Any existing text appears
on the face of the button (more details).

Export bitmap

Create a GIF, JPEG, or PNG bitmap file of the current document. Note that you cannot reload bitmaps back into Xara3D (except as
background or text textures) so if you want to make further edits in the future, save the document as an .X3D file. (See Save and
Save as above.)

Export animation

Create an Animated GIF or AVI movie of the current document.
Recent file list

A list of the last few documents edited.

Quit

Exit Xara3D



Hidden or advanced options

Wire-frame mode:

You can turn on a wire-frame mode that can speed up the moving and positioning. To do this press CTRL+SHIFT+W Press it again
to turn wire-frame off.

Perspective:

You can adjust the Z distance of the objects using CTRL and + or - keys on the numeric keypad. Note that at maximum zoom you
get a rather unrealistic perspective, as if the image were very close to the eye, causing a fish-eye lens effect. This exaggerates the
perspective. The default perspective is about right for the typical distance these images will be viewed on screen.

To cancel any changes to perspective hold down CTRL and click * on the numeric keypad.

The following options are Registry entry changes. Do not attempt these changes unless you fully understand editing the Registry.
Editing mode
Registry key: Software, Xara, X3D4, Settings, Edit mode
0 - apply any changes (such as font or size) to the selected region or (if there is no selected region) to all text.
1 - apply any changes to the selected region or to hew characters you type in.
Compact save
Registry key: Software, Xara, X3D4, Settings, Save compact

0 - save text and background textures as part of the X3D file. If you use textures, this creates larger files but is often more
convenient.

1 - do not save textures in the X3D file. (This is how Xara3D2 worked.)



Creating hollow text

You can turn off display of the faces of the text (show only the sides) to create interesting effects. There are two options:

L] as outlined text with thick sides. Both the inside and outside edges show a bevel.

L] turn off display of either the front or back face. This creates totally hollow text - the sides are wafer-thin and you can see
inside the text. Only the outer bevel is shown.

The two options are illustrated on the web help pages - click here to view them #*
To create outlined text:
1. Click Outline on the Text Toolbar.

Or, for more control, display the Extrusion Options dialog box. (Click the E button.) This duplicates the Outline button and also lets
you control the width of the outline.

To turn off display of the faces:
1. Display the Extrusion Options dialog box. (Click the E button.)
2. Deselect Outline.
3. Deselect Front Face and Back Face for the result you want.
Note:

L] New for version 4: you can make selected characters hollow. Select the characters you want and then select Outline.
Similarly, text can have different outline widths.



How do I...7?

Use these pages if you want to find out how to do something in Xara3D.
The basics
Text & 2D objects:

positioning & rotating
changing the size
changing the wording
changing text spacing
changing the font
changing the color
changing the bevel (edges)
changing the 3D extrude (depth)
changing the effects applied to selected characters
changing the lighting
creating hollow text
shiny & matt surfaces
selecting text
typing international (accented) characters
importing 2D objects
creating 3D buttons
Colors
changing the text color
changing the background color
changing the colors of the lights
changing the shadow color
Shadows
general information
moving the shadow
creating and deleting shadows
changing the shadow color
changing the shadow transparency
changing the shadow blur

shadows and backgrounds
Textures

and text
and the background
The lights
changing their color
changing their position
Buttons
creating buttons
moving the text on a button
making the buttons wider or narrower
changing the curvature of the corners
changing the size of buttons
making buttons from imported shapes
Animation
creating an animation/movie
creating a multipage animation
Step animation
previewing an AVI movie
Saving
saving for reloading later
saving as a bitmap
graphics for the Internet
creating an animation/movie

previewing an AVI| movie
Correcting mistakes




Undo & Redo
Customizing Xara3D
changing the default document
displaying Toolbars
docking dialog boxes



Importing button shapes

As well as the range of pre-defined button shapes, you can also use imported shapes. Suitable formats are Xara3D X3D files, Xara
WEB/XAR files and Windows metafiles WMF/EMF (see notes).
To import a button shape:
1. Either:
choose Import button on the File menu
or click Import button on the Button Options dialog box.
Both options open an import dialog box.
2. Browse to the appropriate folder.
3. Click Open to load the shape. The existing text appears on the face of the button.

If the button doesn't have the right bevel or extrude depth, you can edit these in the regular way.

Notes:
L] Importing X3D files: the first character is used as the button shape. All other information is ignored.
L] There are some points to note when importing WEB/XAR files and Metafiles.

Related topics
Buttons



Installing the fonts

Included with Xara3D are some free fonts in a Font folder inside the Xara3D folder. You can preview the fonts by double clicking on
them in this folder. Details of finding fonts on the CD.
To use these fonts in Xara3D or other Windows programs, you need to install them using the Fonts Control Panel.
To install the fonts:
1. Open the Control Panel by double-clicking on Control Panel in My Computer.
2. Open the Fonts Control Panel by double clicking on its name. This shows all the TrueType fonts installed on your system.
3. Drag the fonts over the Fonts Control Panel window.

Notes:

L] In step (1) you can also click Start on the Taskbar then choose Settings, Control Panel.

u In step (3) you can also select Install New Font on the File menu of the Font Control Panel, and then locate the fonts
where Xara3D was installed (or on the CD).

L] Two of the fonts downloaded with Xara3D are from the large range of fonts available for individual download at

www.buyfonts.com

The download fonts are:

Balthazar - an unusual old fashioned ‘pen’ font

Dayton - a modern blocky font

GeoType - a wonderful collection of symbols and shapes
Greek Diner - an open face font

Russel Write - a distinctive modern display font

Whimsy - an informal, angular font

The CD includes many more fonts.
Geotype, Greek Diner, Russel Write, and Whimsy fonts kindly provided by Gary David Bouton.



Introduction

Xara3D is a ‘slimware’ program as opposed to the increasingly complex 'bloatware' that is released from the major software
developers nowadays. This does not mean that Xara3D is low quality or produces inferior results compared to more complex 3D
programs; on the contrary, it produces better output, and faster than just about anything else.

‘Bloatware', while often very capable, includes so many features that most people never get to use more than 10% of the
functionality. It's often huge, impractical to download over the Internet, requires huge amounts of disc space, and is nearly always so
complex that to use its advanced features takes a considerable learning effort.

Xara3D is designed to be a program that does one thing, and does it supremely well, that is dead simple to use, and costs very little.
It's designed to be small enough to be easily downloaded from the Internet.

Xara3D produces high quality three-dimensional images and nothing else. These images would typically be used on Web pages
although they can be used anywhere. Xara3D can create animated 3D images with absolute ease (AVI movie or GIF). You have
control over the text, the font, the depth of the 3D extrude, the type of the bevel on the edges and the lighting. You can position and
rotate the 3D objects just by dragging, and it updates the image in real-time, interactively. You resize the image just by resizing the
window. It couldn't be easier.



Keyboard short cuts

Open new document CTRL+N
Open existing document CTRL+O

Save document
Export image
Export animation
Import 2D object

CTRL+S
CTRL+SHIFT+E
CTRL+SHIFT+X
CTRL+SHIFT+I

Import button shape CTRL+SHIFT+B
Undo last operation CTRL+Z

Redo (cancel Undo) CTRL+Y

Open Animation Options ALT+A

Open Bevel Options ALT+B

Open Extrude Options  ALT+E

Open Shadow Options  ALT+S

Open Text Options ALT+T

Open Button Options ALT+U

Open Textures Options  ALT+X

Display text bar CTRL+T
Display lights CTRL+TAB
Start/stop animation CTRL+SPACE
Add new page CTRL+ENTER
Cancel rotation ALT+HOME

1 degree rotation ALT+arrow keys

15 degree rotation CTRL+ALT+arrow keys
Change color of heading ALT+C

Apply texture to heading CTRL+SHIFT+C
Change text color on button CTRL+SHIFT+B
Change color of background ALT+G

Apply texture to background CTRL+SHIFT+G

Edit light 1 color ALT+1

Edit light 2 color ALT+2

Edit light 3 color ALT+3

Edit Shadow color CTRL+SHIFT+S
Make text bold CTRL+B

Make text italic CTRL+I

Make character to right of cursor upper case
CTRL+U

Make character to right of cursor lower case
CTRL+SHIFT+U

Swap case of character to right of cursor
CTRL+W

Select all text (all pages) CTRL+A

Select line of text CTRL+L

Select all text (this page) CTRL+P

Negative kerning F5

Positive kerning F6

Shift selected text up F7

Shift selected text down F8

Outline text CTRL+SHIFT+O

Display text cursor CTRL+E

Insert page break in multipage animation
CTRL+ENTER

Move to next page in multipage animation
PageDown

Move to previous page PageUp

Move to first page CTRL+PageUp

Move to last page CTRL+PageDown

Copy heading to clipboard CTRL+C

Paste clipboard contents CTRL+V

Change Quality settings ALT+Q

Display as wire-frame =~ CTRL+SHIFT+W



Xara3D lets you create 3D buttons from a range of shapes. But you can also import a 2D shape and use it to create a 3D button.
The CD contains a range of text messages and symbols you can use on the face of such buttons. There's full details on the Xara3D

website:

www.xara.com/xara3d/helpv4/techniques.htm 3*



To make selected characters larger or smaller

You can change the height of all the characters by either
L] resizing the window
L] or selecting a value on Font size on the Text toolbar at the bottom of the window. (When you have no selected
characters.)
You can also make selected characters larger or smaller than the other characters:
1. Select the characters you want to change - see Selecting text.
2. Change Font size - 100% is no change; less than 100% makes the selected characters smaller. Any changes then apply only
to the selected characters.

Note:

L] You can also use Font size in the Text Options dialog box. Font size is dimmed unless you have selected characters.



Multipage animations display a series of separate headings or "pages"”. Pages are separated by a Page Break (CTRL+ENTER)
character.

So to merge two pages, you just need to delete the page break.
L] In the main Xara3D window:

You need to display the text cursor - click Showl/hide cursor (the I-beam button) on the Toolbar.
Use Page Up/PageDown to move to the page you want to merge into
Move the cursor to the end of the text on that page.

Press DELETE.
L] In the Text options dialog box, Page breaks are shown as diamonds. You can delete these diamonds in the regular way.

EE A



Importing 2D objects

As well as using regular text in Xara3D, you can also import 2D objects and extrude them. 2D objects can be in Windows
metafile .EMF or WMF format or Xara .XAR or .WEB format.

After importing you can recolor, scale, and extrude 2D objects in exactly the same way as text. You can even slant the text using the
Italic option on the Text Toolbar.
To import a 2D object (add to the existing heading):

1. Choose Import on the File menu.

2. Select Windows Metafile or Xara filter as the file type.

3. Browse to the folder containing the EMF, WEB, WMF, or XAR file.

4. Click Open to import. This adds the 2D object to the end of any existing text or 2D objects.
To open a new document showing only a 2D object:

1. Choose Open on the File menu.

2. Select Windows Metafile or Xara filter as the file type.

3. Browse to the folder containing the EMF, WEB, WMF, or XAR file.

4. Click Open to import. This opens a new document containing only the 2D object.

Notes:

L] Simple shapes work best. Complex shapes often lose detail when converted to 3D.

u Any color information in the imported file is discarded. The 2D objects take the current text color.
L] More information on XAR/WERB files

- More information on metafiles

See this web page I?* for the latest information on importing 2D objects.



Notes on metafiles

L] Very complex shapes can take a long time to process. Some metafiles may be too complex for Xara3D to translate; in this
case, only part of the shape is imported into Xara3D. If this happens, simplify the original shape and create a new metafile.

If the imported file contains

only filled objects (for example, colored circles): these are imported.

only lines (also known as stroked paths) or unfilled objects: these are imported as outlines.

a mixture of filled objects and lines/unfilled objects: only the filled objects are imported.

bitmaps: these are not imported. Some packages such as Paint Shop Pro create metafiles that contain only a bitmap.
Some drawing packages convert curves to a series of polygons in the metafile. This is a feature of the drawing package.
These polygons can be noticeable in Xara3D because the light catches the faces of the polygons. To reduce the effect, create the
original drawing larger than required, then scale it down in Xara3D. A web page

E* shows this.

L] Some drawing packages can export both WMF & EMF format files. We recommend using EMF.



Moving or resizing the text on a button

After creating a button you can move the text (or even rotate it) relative to the button. You can also change the size of the text.

To move a button's text
1. Click Texture options (the X button). This opens the Texture Options dialog box.
2. From the drop-down list choose Button text.
3. Change Size to make the text larger or smaller.
Change X or Y to move the text relative to the button.
Change Angle to rotate the text around the center of the button.
You can either drag the sliders or type in values.

Notes:

L] ALT+X or Texture on the Window menu also displays the Texture dialog box.
L] To change the size of the button either

¥ resize the window

b or select a point size from Font size on the Text toolbar.

Related topics
Buttons



Multipage animations display a sequence of headings or "pages". Pages are separated by a Page Break (CTRL+ENTER) character.

So, to start a new page, just press CTRL+ENTER. You can do this either in the main Xara3D window or the Text Options dialog box.
(The Text Options dialog box has a special button for easy insertion of page breaks.)



Positioning & rotating 3D objects

To position or rotate the objects:
1. Drag on the window. The operation of this has been made as intuitive as possible.
Hold down CTRL to move only horizontally.
Hold down SHIFT to move only vertically.
Alternatively you can use the vertical and horizontal scroll bars to rotate the objects vertically or horizontally.

If you want a precise rotation, hold down ALT and use the cursor (arrow) keys on the keyboard to change the rotation in 1 degree
steps. CTRL+ALT+ the cursor keys gives 15 degree steps.

You can also rotate the objects around their center line. Either:

= CTRL+SHIFT drag
u or hold down SHIFT and use the up/down cursor keys for 1 degree steps
L] or CTRL+SHIFT+up/down cursor keys for 15 degree steps.

Note that when the text is horizontally face-on, rotation around the center line gives the same effect as vertical movement.
ALT+HOME cancels any rotation and displays the objects face-on.
See this page for details of positioning and rotating textures.



Previewing AVI movies

To preview a movie:
1. Double-click on the movie file icon in a folder window.

However this uses the standard Windows 95 AVI player which plays the movie once and then closes the window. If you want to keep
the movie on screen, right-click on the AVI file icon and select Open. When the movie player has opened, you can select the 'Auto-
repeat' option that allows the AVI movie to cycle continuously.

Microsoft have a newer and more advanced movie playing solution, called ActiveMovie. This is available for free download on the
Web. See www.microsoft.comlie/download/ F&*

You will need to select the OS type (Windows 95 and NT4) and then proceed to select ActiveMovie 1.0 for Windows 95 and NT4.



Previewing GIF and JPEG files
The easiest way to see how your saved GIF or JPEG files will appear on the web is to preview using your web browser.

To preview GIF and JPEG files:

1. Drag the file from the folder in which you saved the file and drop it over your web browser window. This works for both
Netscape and Microsoft Internet Explorer. The same applies to animated GIFs.

Note that Netscape versions prior to Navigator 4 do not get the timing right for animated GIFs - they always ran about half the speed
they should. Navigator version 4 and Internet Explorer display animation with the correct inter-frame timing.

See also
Previewing AVI movies



Purchasing Xara3D

This page applies if you are running the time-limited trial version of Xara3D.

This version of the software displays a background message, which you cannot change. (With the full version you can use any color
or bitmap as a background.)

When you start up Xara3D a dialog box reminds you that you are running the trial version - click Purchase on that dialog box. This
lets you purchase Xara3D using a fully secure transaction process, 24 hours a day, 7 days a week.

As soon as you purchase Xara3D, you can unlock all the features. We then automatically mail you a CD which contains an unlocked
copy of the program. Please make sure you enter your correct address when purchasing Xara3D. You should receive the CD within
28 days; if not email xaraclub@xara.com #*

If you have already purchased Xara3D but get an 'Invalid Key Code' message or need a new Unlock Code:

look at the Unlock Codes page for more details.



Quality Settings

This option on the Window menu lets you alter the quality settings for display and export. (Keyboard short cut ALT+Q.) Usually the
default settings give excellent results, but you may wish to try different settings to fine-tune Xara3D to your requirements.
Screen Quality controls the quality of the on-screen display. Increasing the quality setting means that the preview takes longer to
redraw on screen. Static and moving images have separate controls: animations can use a lower setting.
Anti-aliasing is a technique of blurring the edges between color transitions. Turning anti-aliasing on gives better results but
takes longer to redraw.
True perspective displays the heading with slightly non-parallel sides. (As if drawn from a distant vanishing point.) This gives
better results for some images than displaying parallel sides. The drawback is the extra processing can slow down redraw. This
may be noticeable when previewing animations.
Export Quality controls images exported as static bitmaps. Increasing the quality may give better results for some graphics in
shadow or highlight areas. The drawback is that graphics may take longer to display on screen.
Animation Quality controls images exported as animated GIFs and AVIs. As the viewer sees each frame only briefly, the quality is
less important than for static bitmaps. Note that increasing the quality too much can cause jerky animation on slow computers.



Saving for reloading later

You can save Xara3D graphics in two types of format:

L] as Xara3D X3D files. You can reload these into Xara3D for further editing but cannot use them on web pages.
L] as bitmaps (PNG, GIF, JPEG, or AVL.) You cannot edit these in Xara3D. Saving in these formats. GIF or JPEG are best for

static images on the web, Animated GIF for animations.
So if you want make future changes to a graphic, make sure you save it in X3D format.

To save in X3D format:
1. Click the Save icon on the Toolbar. For a new graphic, you are prompted to type in a name.

You can also use Save on the File menu. Or Save As to save under a different name.



Saving an image

When you've positioned and sized the objects as required you will need to export the image as a bitmap. Xara3D can export the
image as: BMP, PNG, GIF or JPEG static bitmap images, or either of two animating types - AVI movie and Animated GIF.

If you want to make future edits, make sure you also save the file in X3D format - more details.

To save an image:

1. For static bitmaps choose Export bitmap on the File menu.
For animations choose Export animation on the File menu.
(Or click the Export button on the Toolbar. This exports an animation if the image is rotating otherwise a static image.)

2. Select the appropriate type from the drop down Save as type list on the Export dialog box

3. Enter the required name.

4. Press OK. This displays the export options dialog box which provides all the control over the quality of image.
The export options depend on the export format:

Export options for GIF, PNG, or BMP

__Export options for Animated GIF
___Export options for JIPG
___Export options for AVI movies
Hint
While there are no hard and fast rules as to which file type, JPEG or GIF, is best for the web, we suggest trying GIF format first as
this can produce higher quality images than JPEG.
See also

Previewing GIF and JPEG files



Screen Saver
Not implemented in this release



Changing the blur of the shadow

This can give the effect of either a pin-point light source (little blur) or diffuse light source (greater blur.) For best results we suggest
always blurring the shadow slightly - in real-life shadows don't have sharp edges.

1. Click the Shadow Options button on the Toolbar.
2. Type a value into Blur.

Related Topics:
Shadows



Changing the color of the shadow

1. Double-click on the shadow. This displays the Color Options dialog box.
2. Edit the color.

Note: you can also click the Shadow Options button then click Color.

Related Topics:
Shadows



Displaying/removing a shadow

1. Click the Shadow Options button on the Toolbar.
2. Select Shadow to display a shadow.
Deselect to remove a shadow.

Related Topics:
Shadows



Moving the shadow

You can move the shadow relative to the 3D objects. You can also move it closer to the objects or away from them.
To move the shadow:
The easiest way to move the shadow is to drag it in the window. Make sure you drag the shadow and not the text or the background.

Alternatively the shadow is cast by a special light, which does not affect the color of the 3D objects:
1. Select the Show Lighting light bulb on the Toolbar. This displays the three colored lights and the shadow light (striped arrow.)
2. Drag the shadow light. Shadows look "right" if they are slightly below and to the left or right of the text.

To move the shadow closer:

1. Hold down the ALT key and press the + (plus) key on the numeric keypad.
To move the shadow away:

1. Hold down the ALT key and press the - (minus) key on the numeric keypad.
To cancel any movement of the shadow:

1. Hold down the ALT key and press the * (asterisk) key on the numeric keypad.
Related Topics:

Shadows



Changing the transparency of the shadow

This controls how much of the background color or texture shows through the shadow. Semitransparent shadows are more realistic
than solid shadows.

1. Click the Shadow Options button on the Toolbar.

2. Type a percentage into Transparency.

Related Topics:
Shadows



Changing the shadow style (type)

This controls the angle of the background.
1. Click the Shadow Options button on the Toolbar.
2. Select1or 2.

1is a blurred copy of the objects. Artistically this is not a true shadow but it looks "correct" for simple drop shadows (the most
common type on web pages.)

2 is a true shadow, thrown by the Shadow Light. This type looks best in animations where the eye is more aware of the shape
of a shadow.
Related Topics:
Shadows



Shadows and Backgrounds

Because Xara3D shadows are semi-transparent, to ensure the best, most effective results on web pages make sure Xara3D is
using the same background GIF or JPG file as your web page. You can save a web page background to your local disc by using the
right mouse button. Click over a part of the background in a browser window and select Save Background As. You can then just
drag and drop the file onto the Xara3D background.

GIF files (especially animated GIF files) with soft shadows over background textures are larger than those with no soft shadow.

Related Topics:
Shadows



Shadow dialog box

More information on using shadows.
To display this dialog box:
1. Either click Shadow Options Options on the Toolbar at the top of the window
or choose Shadow on the Window menu
or press ALT+S.
Shadow
Select this to display a shadow.

Style
1is a blurred copy of the objects. Artistically this is not a true shadow but it looks "correct" for simple drop shadows (the most
common type on web pages.)

2 is a true shadow, thrown by the Shadow Light. This type looks best in animations where the eye is more aware of the shape of a
shadow.

Color

Displays the Color Options dialog box ready to change the shadow color. Normally the shadow is gray and shows some of the
background color through.
Transparency

Controls how much of the background color or texture shows through the shadow. Semitransparent shadows are more realistic than
solid shadows.

Blur

This can give the effect of either a pin-point light source (little blur) or diffuse light source (greater blur.) For best results we suggest
always blurring the shadow slightly - in real-life shadows don't have sharp edges.

Related Topics:
Shadows



Squared - square corners. Unlike None, this option makes the text thicker. Because you can use bevel depth to control the extra
width, this is an effective way of selectively emboldening text. Note that because the bevel takes the color of the sides, you can
create a two-color effect on the face of the text.

Round incut - create a rounded rebate around the text.

Square incut - similar to Round incut but the rebate is square.

Rolled - a flat face but curved sides.

Round cornered 1a & 2a - these are the same as Round cornered 1 & 2 in previous versions of Xara3D.

Round cornered 1b & 2b - these are new versions with rounded inside corners. (1a & 2a have square inside corners.)



Step animation is one of the animation types in Xara3D. It displays a static (non-rotating) image and so is suitable only for
multipage animations. These display a sequence of images - see Creating multipage animations.



Technical support

If you have any problems with Xara3D you can contact our tech support by emailing support@xara.com F#*
or check out the support pages on our web site www.xara.com/support/ F3*



Typing international (accented) characters
You can insert accented characters using either dead keys (where supported) or the Character Map. The Character Map also lets
you select non-Latin alphabets such as Greek or Cyrillic.
Dead Keys:
Xara3D lets you enter a wide range of accented characters using "dead keys". These work by:
1. pressing CTRL+the accent character then
2. typing the regular character.
So, for example, to enter & (e grave) you first type CTRL+' (single quote) then type e. Common accent characters are
A"~ |weéCEEAD
u Not all fonts include a full set of accented characters. This is a feature of the font and beyond the control of Xara3D.

L] If you know their number, you can enter characters by holding down ALT and typing the number on the numeric keypad.
For example ALT+0233 gives é.

There's more details on a web page IF3*
Character Map:
You can also select characters using the Character Map in the Text Options dialog box. To display this, click More in the dialog box.

In the Character Map:
u click a character for an enlarged view,
L] double-click a character to insert into your 3D heading.

There are two types of fonts: regular fonts (which have up to 256 characters) and Unicode fonts (which have many more
characters).

L] For regular fonts the Character Map shows all the available characters. Note that many fonts do not include a full set of
characters; unused positions appear as rectangles.
L] Unicode fonts contain several sets of characters (such as Latin, Greek, Cyrillic, Phonetic). The U button and the drop-

down list gives you access to the different character sets. Note that nearly all Unicode fonts contain several character sets. A ">"
next to a character set in the drop-down list shows that this character set is included. This relies on information contained in the font
which might not be accurate. You may find that some options just display blank characters (rectangles) because these characters
are not included in the selected font.



Editing text in the middle of a line

In the main Xara3D window:
1. Click Show/Hide Cursor (the I-beam) on the Toolbar to select it. This displays a vertical cursor.
2. Use the arrow keys on the keyboard to move the cursor.
3. You can then type in new text or delete existing text using BACKSPACE or DELETE.
In the Text Options dialog box:
1. Use the arrow keys on the keyboard to move the cursor.
2. You can then type in new text or delete existing text using BACKSPACE or DELETE.



Selecting characters

(For example to change them to a different font.)
The first step is to select the characters you want to change:
1. Close the Text Options dialog box if you have this open.
2. Click Showl/Hide Cursor (the I-beam) on the Toolbar to select it. This displays a vertical cursor.
3. Using the arrow keys on the keyboard to move the cursor to where you want the selection to start.
4. Use SHIFT+arrow keys to select characters. (See Note.)

Any options you change then apply to the selected characters only. You can change options such as font, size, color, and bevel
type. Note that a text texture is common to all characters; different characters cannot use different textures.

Note:

L] SHIFT+left/right arrow selects the character to the left or right of the cursor (and moves the cursor).

L] CTRL+SHIFT+left/right arrow selects from the cursor to the start (left arrow) or end (right arrow) of the line.
- CTRL+A selects all the text.

| |

CTRL+P selects all the text on the current page - this is useful in multipage animations.



To control the size of the 3D objects:

You can control the size of the objects in two ways:
u resizing the Xara3D window by dragging the bottom right corner, as you would normal windows
L] or specifying a size in points. Change the size using the Text Size field on the Text toolbar. Either type in a new value or
select one from the drop down list.
To switch between the sizing options:
1. If the Text toolbar is not displayed at the bottom of the window choose Text Toolbar on the View menu.
2. In Font Size select Fit to Width to resize the text as you resize the window. Alternatively specify the text size in points.

Everything in Xara3D is WYSIWYG - so with either method, the size you see in the window will be the size of the resultant image on
your Web page. (Although you can override the size setting when you export the image.)

Xara3D uses one of the most advanced 3D rendering engines around. For instance, it automatically anti-aliases the image to
produce the highest quality jaggy-free image. However as the anti-aliasing process can take a second or two, when you are
‘interacting’ with Xara3D (that is when you are dragging the text or altering other aspects in real time, such as the lighting) the
program produces a lower-quality non anti-aliased display. When you stop moving or altering things, the program automatically
redisplays the top quality version. (You can use Quality on the Window menu to select on-screen quality.)



Text dialog box

To display this dialog box:
1. Either click Text Options on the Toolbar at the top of the window
or choose Text on the Window menu
or press ALT+T.

If you have some text selected, any changes you make apply only to the selection. Otherwise changes apply to all text.
Bold - make the text bold. This button duplicates the Bold button on the Text Toolbar. Has no effect on 2D objects.
Italic - make the text italic. This button duplicates the Italic button on the Text Toolbar. Also slants any 2D objects.
Outline - select for outline text. This button duplicates the Outline button on the Text Toolbar.

Size - this lets you make 3D objects larger or smaller. Its main use is to change the size of selected characters. Size is relative so
if you change Font Size (on the Text Toolbar) the characters scale in proportion.

Aspect Ratio - change the width relative to the height. This duplicates Aspect Ratio on the Text Toolbar.

Alignment - change the alignment (justification) of two or more lines of text. Has no effect for a single line of text. Duplicates the
Alignment button on the Text Toolbar.

Line Spacing - changes the vertical space between lines of text (more details). This duplicates Line Spacing on the Text Toolbar.

Tracking - changes the horizontal space between characters (more details). This duplicates Tracking on the Text Toolbar.

Baseline Shift - move the selected text vertically. Keyboard short cuts: F7 shift up; F8 shift down.

Kerning - change the horizontal space between two characters. Dimmed if there is selected text. Keyboard short cuts: F5 reduce
spacing; F6 increase spacing.
Note the difference between Kerning (which affects a pair of characters) and Tracking (which affects several characters.)

Page break (CTRL+ENTER) - create a new page in a Multipage animation.

Font list - this lets you select the font (typeface). If you click on a font name, you can then scroll up and down the list using the
arrow keys on the keyboard. The preview (on the right) then shows you how the text looks in the current font.

Preview window - shows you the text. You can select text in this preview (by dragging or using the arrow keys) and then apply
any of the options in this dialog box to just the selection.

More - this displays the Character Map, which lets you select any character in the selected font. For more information see Typing
international characters.



To change the alignment of two or more lines of text

(Also known as Justification.)
Click the three align buttons on the Text Toolbar at the bottom of the window. These buttons have no effect for a single line of text.



To change spacing between lines of text

Change Line Spacing on the Text Toolbar (displayed at the bottom of the window.) This value is a percentage of the regular line
spacing. 100% is regular spacing. Less than 100% moves the lines closer together. Line spacing has no effect for a single line of
text.

This always affects the entire line. To move selected characters vertically, use Baseline Shift on the Text dialog box. Or use F7 to
move the selection upwards; F8 downwards.



Changing the spacing between characters

To change the spacing between several or all characters:
1. Change the value in Tracking on the Text Toolbar (displayed at the bottom of the window.) Tracking is measured in ems. One
em is the width of the letter 'M' in the current font.
If there is some text selected, the tracking change applies just to the selection. (See Selecting text.) Otherwise the change
applies to all characters.
You can also use the Text dialog box.
To change the space between two characters:
1. Open the Text dialog box.
2. In the dialog box move the cursor between the two characters.
3. Change the value in Kerning. Positive values increase the space between characters; negative decreases the space.
Keyboard short cut:
F5 reduce spacing
F6 increase spacing



To make the objects wider or narrower

Change Aspect Ratio on the Text Toolbar (displayed at the bottom of the window.) 100% is regular width. Less than 100%

compresses the characters. Note the difference between Aspect Ratio (change the width of characters) and Tracking (change the
space between characters.)

You can change the aspect ratio of just a part of the text. Select the characters you want and then change the aspect ratio.
See this page for details of making 3D buttons wider or narrower.



Texture dialog box

More information on using textures
To display this dialog box:
1. Either click Texture Options on the Toolbar at the top of the window
or choose Texture on the Window menu
or press ALT+X.

Drop-down list

Normally the options are Text texture and Background texture.

If you are creating a button the options are Button text, Button texture and Background texture.
Note that some options in this dialog box apply only to Text/Button texture.

Texture (Text/Button texture only)

Select this to display a texture on the text or on the background.

Tint (Text/Button texture only)

(Dimmed unless Texture selected. This duplicates the Tint button in the Color Options dialog box.)

Select this if you want to tint (slightly recolor) the texture. You can then use the Color Options dialog box to modify the color of the
texture.

Size
(Text/Button texture) - scales the texture bitmap. Only you know the best size for a particular heading. At large scalings, the

individual pixels that make up the bitmap may become noticeable - this can create interesting effects. At smaller scalings you see
multiple copies of the bitmap.

(Button text) - scales the text on a 3D button. More details.
X

Move the bitmap (or button text) sideways. This lets you position the bitmap precisely. Movement is relative to the bitmap size - for a
small bitmap (as you get with low values of Size), movement is less noticeable. Note that if you rotate the texture, you also rotate
the angle of X movement.

Y

Move the bitmap (or button text) vertically. Similar to X.

Angle

(Text/Button texture) - rotate the texture.

(Button text) - rotate the text around the center of the button.

Load texture (dimmed for Button text)

Opens the Load Texture dialog box. This duplicates Text texture or Background texture on the View menu.



The basics

To create a 3D heading is easy:

step 1: just enter the text you want. You can delete existing text using Backspace.

step 2: select the font for the heading.

step 3: change the bevel and extrude if you wish (using the B and E buttons).

step 4: drag the text to get the angle you want.

step 5: change the color of the text or background (using the color palette button)

or you can import a bitmap texture for the text or background (using the X button).

step 6: resize the Xara3D window to set the size of the text.

step 7: select Export bitmap on the File menu to save the heading as a BMP, PNG, GIF, or JPEG.
Want an animated heading?

Simple. After step 4 change the animation options (using the A button). You can preview the animation by clicking the Start
animation button. Then in step 7, select Export animation on the File menu to save as an AVI or Animated GIF.

Want to change the lighting angles or colors?

Simple. Click the light bulb button. This displays the three lights that color the text (and a special striped light that creates the
shadow). Drag the lights to change the angles or double-click on a light to display the color picker.

Detailed information on using Xara3D



Tip of the day

This pops-up a message giving hints and tips. A different message appears each time you start Xara3D.

To disable "Tip of the day"

1. Uncheck Show tips on start-up on the Tips dialog box.
L] You can display the Tips dialog box at any time using Tip of the day on the Help menu.
To re-enable "Tip of the day"

1. Choose Tip of the day on the Help menu. This opens the Tips dialog box.

2. Check Show tips on start-up on the Tips dialog box.



Tips for reducing the size of Animated GIF files

Images of any type that are larger than, say, 50Kb are not really welcomed by Web users.

Make the image as small as possible by selecting the Crop option on export.

Select 'Front face only' for “"Rotate" animations.

Have no more than about 20 frames per animation.

For multipage animations avoid having too many pages.

When exporting try selecting 16 colors (4-bit) with no dithering and optimized palette. When images are animating, the
banding is far less obvious than with a static image.

L] When exporting GIFs (animated or static) that have a complex background, try exporting them as transparent GIFs.

u Rotating the lights changes the file size only slightly.




Uninstalling Xara3D

Download version:

To keep the download size small, there isn't an Uninstall option. However uninstalling is simple:
1. delete the folder containing Xara3D
2. right-click on Start on the Taskbar, and select Open
3. double-click on Programs. This displays the contents of the top level menu with Xara3D shown at the bottom
4. delete the Xara3D short cut
CD version:
This includes an Uninstall option.
1. click on Start on the Taskbar
2. move over Programs - this displays the program list
3. move over Xara3D4 - this displays the options for Xara3D
4. click Uninstall Xara3D4



Unlocking Xara3D
When you purchase, we mail you a CD. If you need to reinstall we recommend using the program on the CD - you don't need an
unlock code for the CD version.

However, when you first purchase Xara3D, the CD takes a few days to arrive. So you need to unlock your existing downloaded or
trial version.

Unlocking uses two keys:
] a nine letter Key code
] a seven letter Unlock code

The Key code changes if you change or reformat your hard drive or change to a new computer. You will need a new Unlock
code.

If you have already purchased Xara3D, you will not be charged for getting a new Unlock code. However, you will need your
XaraClub user name and password. Forgotten your password? You can find help at

https:/Isecure.commerce.xara.com/registration/passwordhint.asp = .
To unlock Xara3D:
1. If necessary, reinstall Xara3D on the machine you want to use it on.
2. Run Xara3D and click Purchase.

3. Click Purchase Online or type in the URL secure.commerce.xara.com/x3d4/unlockmain.asp =
4. Follow the instructions for generating a new unlock code.
5. Type that seven letter Unlock code into the Purchase dialog box in Xara3D. Note: use upper case letters - type
'ABCDEFG' not 'abcdefg'.

Remember: this Unlock code applies only to your current set-up. Changing the hard disc or computer means you need a new
Unlock code.

To unlock a trial version on a machine without an Internet connection repeat steps 1. and 2. as above. Make a note of the nine letter
key code displayed in the title bar of the Purchase dialog box. You can generate a matching unlock code from a machine that is
online by logging into your XaraClub account from our home page www.xara.com/ =

From the CD:
The CD sleeve shows a 12-digit unlock code. Type this in when installing from the CD.
Related Topic:

Purchasing Xara3D



Using a texture to color the objects

You can use a bitmap texture to color the objects. Use Text Texture on the View menu to select a bitmap. You can also drag-and-
drop textures onto the objects. You can use any BMP, PNG, JPEG or GIF file. For light colored textures you can use the normal
lighting. Darker textures need bright lights (white or pale colors) to give the best results.

You can change the size, position and angle of the texture from the Texture Options dialog box. (Texture on the Window menu or
ALT+X.) If you make the bitmap smaller than the heading, you see multiple copies of the bitmap. This dialog box lets you create a
wide range of effects.

You can tint (slightly recolor) a text texture. In the Texture dialog box or Color Options dialog box (Color on the Window menu)
select Tint. Then use the Color Options dialog box to madify the color.

See also:
Altering the text color



View menu

Text color/Button color
This option reads Text color unless you are creating a button.

Display the Color Options dialog box ready to edit the color of the faces and sides of the heading or button. More details of the color
options.

Text texture/Button texture

This option reads Text texture unless you are creating a button.

Select a bitmap texture to display on the surface of the text. More details of using textures.

Front and back color

Display the Color Options dialog box ready to edit the color of the faces of the heading or button. More details of the color options.
Side color

Display the Color Options dialog box ready to edit the color of the sides of the heading or button. More details of the color options.
Background color

Display the Color Options dialog box ready to edit the color of the background. More details of changing the background color.
Background texture

Select a bitmap texture to display as the background. More details of using textures.

Button text color (dimmed unless you are creating a button)

Display the Color Options dialog box ready to edit the color of the text on a button. More details of the color options.

Display lighting

Show the three colored lights. You can then change their positions or, by double-clicking, their color. More details on the lights.
Light source 1

Display the Color Options dialog box ready to edit the color of Light 1. More details on the lights.

Light source 2

Display the Color Options dialog box ready to edit the color of Light 2. More details on the lights.

Light source 3

Display the Color Options dialog box ready to edit the color of Light 3. More details on the lights.

Shadow color

Display the Color Options dialog box ready to edit the color of the shadow. More details on shadows.

Start/Stop animation

Start or stop the on-screen animation. More details on animation options.



What does this do...?

Use these pages to find out more about the menu options or the dialog boxes.

The menus

u File menu

= Edit menu

u View menu

L] Window menu

Dialog boxes

Animation dialog box
Bevel dialog box
Button dialog box
Color dialog box
Extrusion dialog box
Shadows dialog box
Text dialog box
Texture dialog box



What's new in Version 4

The main features added are:

L] A powerful new multipage animations feature where the animation runs through a sequence of images or pages
L] More attributes per character - text format and font, color, extrusion and bevel attributes can now be applied to individual
characters

L] An easy to use button tool which converts your heading into a button with a single click

u Rotation around a third axis, the center line of the text

L] Exact positioning of an object against its texture background

L] New fade in/out and step through animation types

L] Separate control over the front and side colors of the heading

u Six new bevel types

L] Easier access to the Color Picker (now called Color Options) using a button on the Toolbar

u Color tinting of textures

- Loop control for GIF animations

= Character map support for instant access to full character sets

- Customizable Default document

]

Handy "Tip of the day"



Window menu

Text

Open the Text Options dialog box. This dialog box provides a range of options for changing the appearance of text. More details on
this dialog box.

Color

Open the Color Options dialog box. This dialog box lets you change the text, background, shadow, and lights colors. More details on
this dialog box.

Extrude

Open the Extrusion Options dialog box. This lets you change the depth of the 3D extrude. More details on this dialog box. More
details on extruding.

Button
Open the Button Options dialog box. This lets you create 3D text buttons. More details.

Bevels

Open the Bevel Options dialog box. More details on this dialog box. Mare details on changing the bevels.
Shadow

Open the Shadow Options dialog box. More details on this dialog box. More details on shadows.
Texture

Open the Texture dialog box. More details on this dialog box. More details on textures.

Animate

Open the Animation Options dialog box. More details on this dialog box. More details on creating animations.
Quality Settings

Change the on-screen viewing quality. More details.

Toolbar

Display the Toolbar at the top of the window.

Text Toolbar

Display the Text Toolbar at the bottom of the window.

Status Bar

Display the Status Bar at the bottom of the window.



Notes on Xara WEB/XAR files

These are produced by CorelXARA and Xara Webster.
L] Installing from the CD automatically installs the Xara file importer.
L] To keep the download small, the file importer is not included with the trial version of Xara3D. You can download it
separately from
www.xara.com/xara3d/plugin.htm| =

Notes on imported files:

Line widths are ignored.

Dash patterns, joins, end caps, and arrows on lines are ignored.

Objects on all visible layers are imported.

Objects on the current frame are imported; other frames are ignored.

Bitmaps are ignored.

If the imported file contains

only filled objects (for example, colored circles) or text: these are imported.

only lines or unfilled objects: these are imported.

a mixture of filled objects/text and lines/unfilled objects: only the filled objects/text are imported.

More details on Xara Webster =
More details on CorelXARA =



Xara3D lets you create multipage animations that run through a sequence of 3D headings. We refer to each separate heading as a
"page".



Typing characters as normal adds them to the end of the text. Or you can Import a 2D object.



BACKSPACE deletes characters from the end of the line.



Press ENTER to start a new line.






