
What is LiveAdvisor?

LiveAdvisor is a messaging service that delivers email from Symantec advising you of such things as upgrades, 
product updates, and tips. Some messages are strictly informational, while others present offers you can act on 
immediately using LiveAdvisor.

You can customize LiveAdvisor to specify which services you want to receive, when, and how. The types of 
messages you are sent match the types of products you have registered.

If you did not sign up for LiveAdvisor when you registered your Symantec product, you can do so from 
LiveAdvisor.

Click here {button ,AL("06;07;10;22",0,`',`')} for more information.



How does LiveAdvisor work?

LiveAdvisor connects to Symantec through the Internet on a schedule you define to check for messages in the 
services you have requested. When an appropriate message is received, LiveAdvisor notifies you in the manner 
you have chosen.

For example, you can schedule LiveAdvisor to check for upgrade notification messages about all your registered 
Symantec products each time you start Windows, and notify you of new messages by playing a sound.

LiveAdvisor presents the messages grouped by service for easy access. You can read, print, or delete the 
messages at your convenience.

Click here {button ,AL("08;15;18;19;20",0,`',`')} for more information.



Will LiveAdvisor affect my Internet connection?

LiveAdvisor connects to the Internet at your discretion: you can specify that it connect only at your request or 
automatically when Windows starts.

LiveAdvisor will not interfere with any existing Internet connection, but will disconnect if it established a connection 
itself.

Click here {button ,AL("09;14",0,`',`')} for more information.



How does Symantec use my contact information?

Symantec uses your contact information to provide you with messages by email, phone, or postal mail. You can 
request that you not be sent these messages.

At your request, Symantec may also provide your postal mail address to other companies whose products or 
services you might find interesting.

Click here {button ,AL("22",0,`',`')} for more information.



Add the LiveAdvisor icon to the system tray:

1 Click Options on the LiveAdvisor toolbar

Or

From the Tools menu, select Options.

2 In the Options dialog box, select the General tab.

3 Select Show The LiveAdvisor Tray Icon.

4 Select one of the three options. The tray icon can be visible while LiveAdvisor is running, when 
messages are received, or shown in place of a taskbar button.



To check the Symantec product list:

1 Click My Profile on the LiveAdvisor toolbar

Or

From the Tools menu, choose My Profile.

2 Click the Products tab. 

All Symantec products that you have installed on your computer are listed. The word "Unregistered" 
in the Serial Number column indicates all unregistered products. Symantec sends you messages 
only about the products you have registered.

3 Optional: If you want to register a product, select it and click Register. 



To specify the types of messages to receive from Symantec:

1 Click Options on the LiveAdvisor toolbar

Or

From the Tools menu, choose Options.

2 In the Options dialog box, select the Services tab.

3 Check each type of message you want to receive.

Or

Clear the checkboxes for the types of messages you don't want.

Click here {button ,AL("06",0,`',`')} for more information.



To set LiveAdvisor to run at startup:

1 Click Options on the LiveAdvisor toolbar

Or

From the Tools menu, choose Options.

2 In the Options dialog box, select the General tab.

3 Check Run Symantec LiveAdvisor When Windows Starts Up.

If you do not run LiveAdvisor every time Windows starts, you must run it whenever you want to 
check for messages. 

4 Optional: To get messages when LiveAdvisor starts up, select the Delivery tab and select Get New 
Messages When LiveAdvisor Starts Up.

Click here {button ,AL("05;10",0,`',`')} for more information.



To play a sound when a message arrives:

1 Click Options on the LiveAdvisor toolbar

Or

From the Tools menu, choose Options.

2 In the Options dialog box, select the Delivery tab.

3 Check Play a sound when new messages arrive.

Click here {button ,AL("14;20",0,`',`')} for more information.



To change your user identification profile:

1 Click My Profile on the LiveAdvisor toolbar

Or

From the Tools menu, choose My Profile.

2 To update or review your name and address information, click the Name/Address tab.

3 Optional: If you want to review Symantec’s privacy policy and your contact options, click Privacy.

4 To review the list of products for which you are receiving messages, click the Product tab.

You will not receive messages for any products listed as unregistered.

5 Optional: If you want to register Symantec products installed on this computer, select a product and 
click Register. Once registration is complete, you will return to the My Profile dialog box.



To change the appearance of the LiveAdvisor window:

1 Open the View menu.

2 Do the following:

To make an item visible, select it so a check appears in front of the item.
To hide an item, select it so the check is removed from in front of the item.



To get new messages:

Click Get New Messages on the LiveAdvisor toolbar or from the Tools menu, choose Get New 
Messages. The status bar will display the progress of the process.

Click here {button ,AL("08;10",0,`',`')} for more information.



To read a message:

1 In the Views pane of the LiveAdvisor window select a category.

The messages in that category are listed in the Message pane to the right. 

2 Do any of the following:

Select the message and choose Open Selected Item from the File menu.
Right-click the message and choose Open from the context menu.
If Preview Pane in the View menu is checked, select the message and it will appear in the 

Preview pane.

Note: To purchase an upgrade directly from the LiveAdvisor message, double-click the message to 
go to the Symantec Online Upgrade Center.

Click here {button ,AL("13;16;17",0,`',`')} for more information.



To mark or flag a message:

1 Select the message.

Messages with a closed-envelope icon are unread. An open-envelope icon indicates that the 
message has been read. A red flag next to the received date indicates the message has been 
flagged.

2 Do any of the following:

If the message has not been read, choose Mark As Read from the Edit menu.
If the message has been read, choose Mark As Unread from the Edit menu
To flag the message, choose Flag Message from the Edit menu

Note: The Mark As Read, Mark As Unread, and Flag Message commands are also available in the 
menu that appears when you right-click a message.

Click here {button ,AL("15",0,`',`')} for more information.



To find a message:

Note: LiveAdvisor can search for a specific word or phrase in the message text.

1 Click Search on the LiveAdvisor toolbar

Or

From the Edit menu, choose Search.

2 Enter the text you are looking for and click Find.

The next message containing the word or phrase is selected in the Message pane. If no match is 
found, LiveAdvisor displays a message.

Click here {button ,AL("15;18;19",0,`',`')} for more information.



To print a message:

To print a message, select it and from the File menu, choose Print.

Click here {button ,AL("15;17",0,`',`')} for more information.



To delete a message:

 Deleting a message cannot be undone.

1 Select the message and from the Edit menu, choose Delete

Or

Right-click the message and select Delete from the context menu.

2 Verify your request to delete.

Note: LiveAdvisor can display a warning prior to deleting a message. To enable this message, click 
Options, click the General tab, and select Warn Me Before Permanently Deleting Messages.

Click here {button ,AL("15;17;18",0,`',`')} for more information.



To save a message as a text file:

1 Select the message.

2 From the File menu, choose Save As.

3 Enter a name and select a location for the file.

Note: The text files are not visible in LiveAdvisor.

Click here {button ,AL("19",0,`',`')} for more information.



To repair LiveAdvisor:

Note: Use the Repair command if advised by Symantec Technical Support or prompted by 
LiveAdvisor.

1 From the Help menu, choose Repair.

2 In the dialog box, review the information and click Yes to complete the repair.



Get help while using LiveAdvisor

LiveAdvisor provides two types of help. You are currently using the LiveAdvisor help, which contains 
task and reference information about LiveAdvisor. For quick help with dialog box controls, use “What’s 
This?” help to display specific help about a button, list, or field.

To see the table of contents for LiveAdvisor help:

1 From the Help menu, choose LiveAdvisor Help.

2 In the Table Of Contents dialog box, click a closed help book to display its topics.

3 Select a topic and click Display.

To use “What’s This?” help:

Right-click on the item for which you want help and select “What’s This?” from the context menu
Or
Click the question mark button at the upper right of the dialog box and use the question mark 

cursor to click on the item for which you want help.



To update the message list:

1 Open the View menu.

2 Click Refresh.

LiveAdvisor will remove old messages.

Click here {button ,AL("14;19",0,`',`')} for more information.



backup

To save information to another location or medium.



check box

1. Small box associated with an option in a dialog box. When you click the check box, you may change the option 
or affect related options. 2. Dialog box component that acts like a switch, representing an option that you can turn 
on or off. 3. Graphical interface component that acts like a switch, representing an option that can be toggled on 
and off. When the option is on, a check mark appears in the box.



click

To press and release the primary mouse button.



connection

Point at which devices establish a communications link.



context menu

Menu that appears when you right-click an interface object, and that provides options and information specific to 
that object.



Control Panel

Windows application that allows you to modify the Windows environment, such as adding printers and fonts, or 
adjusting the tracking speed of your mouse.



default

Preset value for a parameter that is assumed unless a different value is explicitly specified.



desktop

Screen background on which windows, icons, dialog boxes, menu bar, and toolbar appear. It is similar to the 
surface of a physical desk.



dialog box

Special kind of window that either requests or provides information. Many of these windows contain information 
needed before a program can complete a command. Others display warnings and other system messages.



dimmed

Unavailable menu item. A dimmed item cannot be accessed and appears in light gray.



double-click

To press the primary mouse button twice in rapid succession. Generally used to select an item.



email

Electronic mail. Correspondence or other information (including files) sent electronically from one computer 
through a common computer network to another.



file type

Classification of a file usually distinguishable by the last three characters of the filename. For example, files with 
the “.EXE” and “.COM” extension are program files, “.TXT” is for text files, and “.BAT” is for batch files.



icon

1. Small picture representing an object, concept, or message. 2. Pictorial representation of an application, a 
document, a group item, or a desktop item.



Internet

Largest internet, or network of networks, in the world. It is a three-level hierarchy composed of backbone networks 
(for example, ARPANET, NSFNET, MILNET), mid-level networks, and stub networks. These networks in include 
commercial (.com or .co), university (.ac or .edu), and other research (.org, .net) and military (.mil) networks and 
span many different physical networks around the world with various protocols, including the IP.



launch

To start a program or application.



load

1. Add an item or information to a program. 2. Start a program or application.



menu

1. List of options. Clicking an option from this list performs an action. 2. In an application, a list of options that can 
be selected by the user. Choosing from a menu often leads to a dialog box or a cascading menu containing further 
options.



message

1. Piece of information passed from the application or operating system to the user to indicate a condition or 
suggest an action. 2. Primary means by which applications, and the windows they create, communicate. Every 
time a button is clicked, for example, a message is sent to the application indicating that the button was clicked.



migration

Moving data or a program from one application or machine to another.



override

To change a default setting for an individual item or set of items.



pane

A section of a window containing options or a display of information.



patch

A section of programming code that upgrades an application or fixes a problem within an application.



right-click

To click the right mouse button. Right-clicking while the mouse cursor is over an object displays a context menu 
containing options specific to that object.



run

To start a program or application.



Scheduled Tasks

Scheduled Tasks is a Windows system tool that displays a folder containing the tasks you have scheduled for 
Windows. To review or change your scheduled tasks click the Start button, select Programs>Accessories>System 
Tools>Scheduled Tasks.



search

To look for the location of a file, or to look for specific data in a file or data structure. It is carried out by a 
comparison or calculation to determine whether a match to some specified pattern exists.



select

In general computer use, to specify an item displayed on screen by highlighting or otherwise marking it, with the 
intent of manipulating the item in some way. It generally indicates only that a choice has been made. A program 
does not act on a selection until instructed to do so.



shortcut

An icon that appears on your desktop or in the Start menu that you can select to start a program or application.



slider bar

Small box that slides left and right in the LiveAdvisor Options dialog box, indicating the currently selected 
frequency of message checking.



Start menu

The Windows menu from which you can start all applications and programs on your computer, as well as shut 
down your computer.



startup

1. To run a computer or program that is shut down. 2. The moment at which a computer or program is starting.



status bar

Graphical interface component that displays information about a process, function, or selected item. The status 
bar normally appears at the bottom of a window or dialog box.



System Agent

An application with which you can set up an automatic schedule of tasks for your computer to perform.



system tray

The right side of the Windows taskbar, containing icons indicating what applications are running in the 
background.



tab

The button providing access to a page of options in a multipage dialog box.



toolbar

Row of pictographic command buttons displayed in an application window, usually immediately under the 
window’s menu bar. These buttons provide quick mouse access to options or commands that are specific to the 
window or application.



undo

To reverse an action and restore the state of the application before the action was taken.



upgrade

A newer version of a product.



window

1. Framed area in which you can run an application, view a file listing or a document, or perform a task. This area 
can be opened, closed, resized, and moved. 2. In Windows programming, object displayed by an application (for 
example, check boxes and option buttons within dialog boxes). 3. Graphical interface component that provides an 
area for display of data and user interaction with an application. There are two major types of windows 
distinguished by their function in the application: (1) the primary window is the main window (usually a document 
window) of the application in which most of the information is displayed; (2) the secondary windows are the 
ancillary windows (property sheets, dialog boxes, messages, or palettes) used by the application.



Windows

Graphical user interface between the command line of a DOS-based machine and the user.



Contents pane

The Contents pane lists the type of messages provided by LiveAdvisor.

What would you like to do?

Specify the types of messages to receive from Symantec 

Change your user identification profile 

Set LiveAdvisor to run at startup 

Check the Symantec product list 

Play a sound when a message arrives 

Change the appearance of the LiveAdvisor window 



Messages pane

The Messages pane lists the messages you have received from Symantec. What would you like to do?

Find a message 

Get new messages 

Read a message 

Mark or flag a message 

Print a message 

Delete a message 

Save a message as a text file 



Preview pane

The Preview pane contains the text of the message you selected to read. What would you like to do?

Print a message 

Delete a message 

Find a message 




