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Introduction

Memo PLUS is a supercharged Memo Pad. To create Memo PLUS, we started
with the built-in Memo Pad, and then added the features that Palm OS users
like yourself were requesting.

With Memo PLUS installed, you can take full advantage of the power of your
Palm device. Memo PLUS has the following features:

• Improved graphics and toolbars

• Attachable drawings

• Templates for both memos and drawings

• Creation and modification date tracking

• Password protection

• Alarms

• Font selection for Palms that normally do not allow font selection.

How does it work?

Memo PLUS shares the same information that your built-in MemoPad uses.
You will notice that when you create or add a memo in Memo PLUS, it will
also appear in you built-in Memo Pad. This gives you a big benefit...to edit
memos on your PC, you use the desktop software that you normally use to
edit your Memos. Memo PLUS is compatible with the Palm desktop, as well
as other contact managers like Microsoft Outlook, ACT, or Goldmine, when
those programs are combined with the appropriate synchronization software.

Memo PLUS also saves additional information on to your Palm, like draw-
ings, extra category information, and alarms. However, this information is not
visible in your desktop software.

System Requirements

Memo PLUS is compatible with all devices running Palm OS 2.0 and above.
This will include the PalmPilot Personal, PalmPilot Professional, Palm III,
IBM WorkPad, Palm V series of devices, Palm VII series of devices and any
device that has a Palm upgrade card installed.

Memo PLUS is not compatible with the original Pilot 1000 or Pilot 5000,
unless it has been upgraded with a Palm upgrade card.
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Getting Started

Installation

Windows Installation

Double-click on the MemoPLUS.EXE file and follow the instructions. After
using the installer, put your Palm device in the cradle and HotSync.

Macintosh Installation

Open the Memo PLUS folder and double-click on the MemoPlus.prc file. Put
your Palm device in the cradle and HotSync.

Default Memo Button

Since Memo PLUS is designed to replace your built-in Memo Pad, you should
set up your Palm device to show Memo PLUS when you press the Memo
button on your Palm device.

To set Memo PLUS to be your default Memo application, tap on your applica-
tions icon, then tap on the Prefs application. Once the Prefs application has
started choose Buttons from the popup menu in the upper right corner. You
will see the following screen:

Button Preferences

Tap on the drop down menu next to the Memo icon, and choose Memo PLUS
from the list that pops-up. That is all there is to it! Test it out by pressing the
Memo button. Memo PLUS should start.
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Using the Memo List

The opening screen shows you a list of the Memos that you have created, and
lets you add new memos, attach drawings, and work with templates. The
various parts of the Memo List are pictured below:

Memo List

Working with Notes in the Memo List

Creating a New Note

To create a new note, tap the Note button. You will then be taken to the Note
Edit screen. See Editing a Note for more information about the Note Edit
screen.
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Editing a Note

To view or edit a previously created note, tap the small note icon that is on the
line with the note.

You will then see the note in the Note Edit screen.

Attaching a Note to a Drawing

To attach a note to a drawing, first select the line with the drawing by tapping
on the text of that line. The line number will highlight, indicating that the line
is selected. Then tap the note button. You can also start your note with a
template by tapping on the arrow next to the Note button, and choosing your
template.

Deleting a Note

To delete a note, tap on the note title and then tap the trash can button.

Working with Drawings in the Memo List

Creating a New Drawing

To create a new drawing, tap the Drawing button. You will then be taken to
the Drawing Edit screen. See Editing a Drawing for more information about
the Drawing Edit screen.

Attaching a Drawing to a Note

To attach a drawing to a note, first select the line that contains the note by
tapping on the text of that line. The line number will highlight, indicating that
the line is selected. Then tap the drawing button. You can also start your
drawing with a template by tapping on the arrow next to the Drawing button,
and choosing your template.

Editing a drawing

To view or edit a previously created drawing, tap the small drawing icon that
is on the line with the drawing.

You will then see the drawing in the Drawing Edit screen.

Deleting a Drawing

To delete a drawing, tap on the drawing title and then tap the trash can button.

Sorting and Filtering

Memos may be sorted either alphabetically or in reverse-alphabetic order by
tapping on the Sort List at the bottom right of the screen.
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To also filter your memo list by category, tap on the category name at the top
right of the screen. You can quickly cycle through your categories by tapping
the left and right arrows next to the category name.

Editing a Title

Memo PLUS allows you to edit the title of each Memo right in the Memo
List. Just tap the title of the memo and use graffiti to edit the memo title.
Editing the memo title will not affect the contents of your note.

Changing the Font

You may change the font of the Memo list screen by choosing Font from the
Memo menu. Tap on the letter representing the font you want to display.

Font Selector

To display the Memo menu, tap the Menu button at the lower left corner of
your Palm screen, and then tap “Memo”, displayed in the popup menu along
the top of the screen.

Beaming a Memo

If you are using a Palm computing device that supports beaming, you can
beam a memo, together with its note and drawing, to another user of Memo
PLUS. See the chapter on Beaming for more information.

Using the Palm Keyboard

If you have attached a keyboard to your Palm, you will find the following
helpful:

To select a memo in the list with the keyboard, use the up and down arrow
keys.

To create a new note or drawing, use Cmd-N or Cmd-D.

To attach a note or drawing to a memo, or to view the attached note or draw-
ing, use the up and down arrows to select the memo, and then press Cmd-A or
Cmd-W.
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Editing a Note

To edit a note, tap on the note icon next to the note, or tap on the Note button
at the bottom of the screen. You will be shown the following screen:

Note Edit screen

Changing the Font

To change the font displayed in the memo, tap the letter “A” at the bottom of
the screen. Select the letter that represents the font you want to display.

Selecting a Template

To insert a Memo PLUS template, tap the note button at the bottom of the
screen. Select a template from the list that pops up. See the Templates chapter
to learn more about templates.

Deleting a Note

To delete the displayed note, tap the trash can button. If a drawing is associ-
ated with this note, only the note portion will be deleted, and not the drawing.

The Command Menu

Tap the menu button, then tap the word Command at the top of the screen, to
display the command menu.
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The Note Command Menu

Saving the Note as a Template

Choose Save as Template to automatically put the note into the template list.
See the Template chapter for more information on Templates.

Editing Note Templates

To jump to the template edit screen for notes, choose Edit Note Templates.

Beaming a Note

Choose Beam Note to beam the note to another Memo PLUS user via the
infrared port. See the Beaming chapter for more information on beaming.

Compute Size

To display the number of letters in the note, choose Computer Size.

The Options Menu

To display the options menu, tap the menu button at the lower, left corner of
your Palm screen, then tap the word “Options” that appears along the top.

Options Menu

Jumping to the Top or Bottom of a Notes

The first two selections of the Options menu let you quickly scroll up or down
to the top or bottom of the memo.

Hiding and Showing Underlines

To hide the underlines that are display in the note, choose Underlined from the
menu. To show the underlines, choose Underlined again.

Looking up a Phone Number

To paste a name and phone number from the address book into the note,
choose Phone Lookup.
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Editing a Drawing

To edit a drawing, either tap on the Drawing button at the bottom of the Memo
list, or tap on the small drawing icon on a line that contains a drawing. You
will then see the following screen:

Edit Drawing screen

The Drawing Tools

Select a drawing tool by tapping on one of the icons along the bottom of the
screen. After selecting a tool, tap on the drawing area above the line and drag
to draw with your tool. The available tools are: Pencil, Eraser, Line, Rect-
angle, and Ellipse.

The dots next to the drawing tools let you specify the line width of the tool.
Tap on the dot that is the size you want to use.

If you are using Palm OS 3.5 or above, the Color Picker box will be visible.
To pick a color to draw with, tap the color picker.

Selecting a Memo PLUS Template

To start a drawing with a template, tap on the drawing icon in the lower right
corner of the screen. If you have created drawing templates, a list of templates
will pop up to choose from. See the Templates chapter for more information
on templates.
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Erasing and Deleting a Drawing

To erase a drawing, tap the menu button, and choose Clear All from the Edit
Menu. To delete a drawing and return to the task list, tap on the trash can icon.

Undoing

To undo your last drawing action, choose Undo from the Edit menu. If you
change your mind, you can choose Undo from the Edit menu again to redo
your last drawing action.

Changing a Drawing to Text

If you are in a situation where you need to quickly jot down a note, but you do
not have the time to carefully graffiti in the text, you can use a drawing to
write your note, and then later convert your handwriting to text.

To help with the process of converting your writing to text, select Show Edit
Text from the Edit menu. A window will pop up along the bottom of the
screen. Enter text into this window using graffiti, then tap the Copy button to
copy the text to the clipboard. You can then go to a memo, or any other Palm
application, and choose Paste from the Edit menu to paste your text into a
field.

Other Options

You can add your drawing to the template list by choosing Save as Template
from the Drawing menu. See the Templates chapter for more information.

A drawing can also be beamed to another user of Memo PLUS, if your hard-
ware and the other user’s hardware support beaming. See the chapter on
Beaming for more information.
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Memo Details

To access the detail information of a memo, tap on the memo number. You
will then see the following screen:

Details screen

This screen lets you choose various options for the memo, and displays infor-
mation about the creation and modification dates.

Protecting a Memo

To prevent a memo from being seen, you have two options, Private and
Password. Both options require that the security features of your Palm be
enabled.

To turn on your security features, do the following:

1) Tap the Applications button at the lower left corner of your Palm screen,
and choose the Security application.

2) Select Hide from the Privacy setting menu, (or optionally Mask on OS 3.5
and above).

3) Tap on the password setting and assign a password.

Private

A memo that is protected by the Private checkbox will not display in the
Memo List when private records are hidden in the Security application of your
Palm device. Once this feature is checked and the memo is hidden, the only
way to see your Memo or change this options is to choose “Show” in the
Security application of your Palm device.
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Password

The password protected memo will show in the Memo List. However, when
you tap on the note, drawing or details of the memo, you will be asked for
your password. This is the same password you assigned in the Security appli-
cation of your Palm device.

Important Note: You must have a password assigned and choose Hide or
Mask from the privacy setting in order for Passworded memos to work.

Setting an Alarm

Tap the alarm checkbox to display the alarm options and to set an alarm.

You can either set an alarm for a particular time, or in a particular number of
minutes from the current time.

To set an alarm for a particular time, tap on the number you want to change in
the “at:” row, hold the pen down, and drag up for a bigger number, or down
for a smaller one. Tapping the AM/PM button will toggle it back and forth.

To set an alarm a certain number of minutes in advance of the current time by
filling in the hours and minutes fields in the “in:” row.

You can even set an alarm for a particular day by tapping the date in the “on:”
row. Tap the arrow next to the date to quickly choose tomorrow’s date, the end
of the week, or the end of the month.

See the chapter on Responding to Alarms for more information on alarms.
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Responding To Alarms

When Memo PLUS triggers an alarm, you will see the following screen.

Alarm Screen

You can respond to the alarm in one of three ways by clicking the correspond-
ing button:

OK Removes the alarm from the screen

Go To Highlights the memo in Memo PLUS. If the alarm appears while
you are in a different application, clicking the Go To button will exit
that program and start Memo PLUS.

Snooze Temporarily removes the alarm screen. Select the amount of time
that you want to snooze from the menu just above the Snooze
button.
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Templates

Templates save you time by giving you a way to start your memos and draw-
ings from previous memos and drawings that you have saved. See the Memo
List chapter for information on starting a new drawing or note from a tem-
plate.

Managing Templates

To edit your templates, choose Edit Drawing Templates, or Edit Note Tem-
plates from the Command menu. You will see a screen similar to the follow-
ing:

Edit Template screen

To create a new template, tap the New Template button. The note or drawing
screen will appear, to let you create the template.

To edit the title of a template, tap on the title of the template you want to
change, and then tap the Edit Title button.

To edit a template itself, select the template by tapping on it, then tap the Edit
Template button.
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Template Editor

Template Editor Screen

Memo PLUS comes with a template editor for Windows 95 and Windows NT
users. To start the editor, double click on the TempEdit.exe file. You will then
see the above screen

Editing Note Templates

To create a note template, choose New Note from the Item menu. Alterna-
tively, you can click the New Note button near the right side of the toolbar, or
right click and choose New Note from the menu.
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Creating a new note

Add the text of your note template in the frame on the right. Click on the
name of the template in the frame on the left to edit the template name.

Editing a Drawing

To create a drawing, first start a paint program of your choice, create your
drawing, then select the drawing and choose Copy from the Edit menu. Switch
back to the Template Editor, and choose New Drawing from the Item menu, or
right click and choose New Drawing from the menu, or tap the New Drawing
icon in the toolbar. Select Paste from the edit menu, and your drawing will be
pasted into the frame at the right.

Creating a new drawing
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When you paste your picture, the Template Editor will convert the picture to
black and white, and crop the picture to 160 pixels x 160 pixels, the size of the
Palm screen.

Saving and Installing Your Templates

Now that you have created some new templates, save the template file by
choosing Save from the File menu. Enter a name for your template file, and
end the name with “.PDB”.

Then, start the Palm Install Tool and install the file that you created. Use the
same procedure you used when you installed Memo PLUS.

HotSync, and start Memo PLUS. Your new templates are now ready to use.

Viewing Current Drawings and Templates

You may use the Template Editor to view drawings that you have created on
your Palm device, and to view your note and drawing templates that are
installed in your Palm device.

Choose Open from the File menu, and navigate to your backup directory. Your
backup directory is in your user name directory. For example, if your user
name is Joe Shmoe, your backup directory would likely be at C:/palm/
ShmoeJ/backup/.

Open the file you would like to view, as follows:

MemoPlusDrawingDB.PDB - Drawings attached to Memos

MemoPlusDrawingModelDB.PDB - Drawing Templates

MemoPlusNoteModelDB.PDB - Note Templates

You can view the contents of these files, but you will not be allowed to save
any changes you make to these files to prevent corruption of your Palm
databases. If you would like to edit your drawings or templates, you must save
them to a different file using the Save As command from the File menu, make
your changes in the new file, then install the new file as a template.

Submitting your Templates

If you a great template that you use all the time, why not submit it for the rest
of the world. We maintain a library of templates on the Hands High Web site
(http://www.handshigh.com/) submitted by Memo PLUS fans like you. To
submit a template, just email it to us at support@handshigh.com!
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Backing Up and Restoring Data

Every time you HotSync, the HotSync manager automatically makes a copy
of your Memo PLUS databases and puts it on your desktop computer.

The name of the backup files are:

MemoPlusDrawingDB.PDB - Drawings attached to memos

MemoPlusNoteModelDB.PDB - Note templates

MemoPlusDrawingModelDB.PDB - Drawing templates

The notes that are attached to memos are backed up in the memopad directory
and are maintained by MemoPad conduit automatically.

It is a good idea to occasionally save a copy of your backup directory in case
your hard disk crashes or your Palm organizer has a problem.

Restoring a Backup

On rare occasions, your Palm organizer may have a problem that requires you
to reinstall your backup files. Do the following steps in order to reinstall each
file.

1) Make a copy of your current backup directory.

2) If Memo PLUS is not installed, follow the installation instructions at the
beginning of this manual to install Memo PLUS.

3) Start the Palm Install tool. This is the same application you used to install
Memo PLUS.

4) Install the .PDB files the same way you would install a Palm application by
clicking the Select button, selecting the file, and clicking the Install button.
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Beaming

If your Palm has an infrared port, you will be able to beam Memo PLUS
memos to other Palm devices with an infrared port and Memo PLUS installed.

Select the memo you want to beam, and choose Beam Memo from the Com-
mand menu. Then, point your Palm device at another Palm device that also
has Memo PLUS installed. The other Palm will display a message asking the
user to confirm acceptance of the memo.

When you beam from the Memo List, the receiving device will get both the
attached note and drawing. If instead you are editing a note or drawing, and
beam from one of those screens, the receiving device will only receive the
information you are viewing.

If you are having trouble beaming, make sure that your  Palm devices are
between one and three feet apart, that the infrared ports are not obstructed,
that ambient light is not extremely bright, and that Beam Receive is on in the
General preferences of the receiving Palm device.

To beam a memo to someone who does not have Memo PLUS, you can do
one of the following:

• Tell you friend what a great application Memo PLUS is and convince him
or her to buy a copy.

• Switch to the built-in MemoPad application and beam from there.
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Common Questions

Can I delete the built-in MemoPad application?

Currently you cannot delete the built-in applications. However, even if you
could, deleting them would not free up any memory. The built-in applications
are stored in ROM and are a permanent part of the Palm device.

What is the largest memo I can create?

Currently you cannot create a memo that is larger than 4000 characters. This
is caused by a limitation in the Palm desktop software. However, Palm Com-
puting will likely fix this in the future.

Is there somewhere I can find templates that others have created?

Yes! See our Web site at http://www.handshigh.com/ for a library of templates
created by other Memo PLUS fans.

Why do I have a greater number of Memo PLUS records than built-in

Memo records when I look in the Memory application?

It is perfectly normal to have a greater number of records when you check
Memo PLUS in the Memory application. Indeed, the total number of records
shown for Memo PLUS equals the number of actual memo items plus the
number of note or drawing templates plus the number of drawings plus the
number of categories!
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