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Image - Renumber Pages, Delete Pages

TIFF and DCX file formats support multiple pages.    When appending an image to an existing file, 
the image is always appended as the last page.    However, the pages can be re-numbered or 
deleted in a separate procedure.

To re-arrange or delete a page

1. Open the document image.    The first page of the image is displayed.

2. From the File menu, choose Renumber/Delete Pages.    The Renumber/Delete Pages window 
appears.

3. In the second column of the grid of page numbers, click the page that you want to move or 
delete. 

4. Choose the Up, Down or Delete button.    To move the page several steps, repeat the process for 
each step.

5. To start over, choose the Refresh button.

6. To execute the move or delete, choose OK.

7. If a page is deleted, the original file is temporarily saved in the SAVEIMG file in the application's 
directory.



Save an Image

To (reformat and) save the active image:

1. From the File menu, choose Save As.    The Save AS form is displayed.

3. Select the directory.

4. In the Graphics Format list, select the format code (normally TIF).

5. In the File Name box, type the file name of the file.

6. Choose OK.

7. TIFF and DCX files support multiple pages.    To append the image to an existing file (as a new 
page), click on the Append button.    The image is appended as a last page.    To rearranged or 
delete a page, choose Renumber and Delete Pages from the File menu. 

 



Image - View, Print

The images are always displayed in the currently active image window.    If you want to display 
the image in a new and separate window, select New Image Window from the File menu in the 
Image window BEFORE you select the new image. 

To display an image

1. In the external application's Search window, run a search.    The search will identify and list all 
matching image files.    If correctly integrated, the external database will pass the file name and 
description to DocView, activate Docview and display the image.

To open an image without a search, choose Open from the File menu in the Image window or 
click the Open Image button in the toolbar.    In the dialog box, select the directory and specify 
the file name. 

2. If necessary, change the viewing aspects.    From the View menu, choose:

Resize Image
Fit to Window (retaining the proportional aspects)
Zoom (see below)
Copy
Rotate 
First, next, prior, last page (multi-page TIFF and DCX formats only)

3. From the File menu, open the next or prior image, as follows, or press the corresponding button 
in the toolbar::

Open - Next File Displays the next fle in the directory
Open - Prior File Displays the prior file in the directory.
Open - Next Query Displays the image from the query.
Open - Prior Query Displays the image from the query.

Pages

The TIFF and DCX files support multi-page formats.    When you open a multi-page file, several 
useful navigational buttons become active in the toolbar.    These buttons allow you to move to the 
first, next, prior and last page of the current file.    The pages of multi-page documents can also be 
viewed in Auto-Display mode (see section below).    The page navigation functions are also available 
from the View menu.

Auto Display

The pages of multi-page images (TIFF or DCX files) can be viewed in a browser ('slide show') mode, 
either in a forward or backward sequence.    To activate the Auto Display, click on a Auto Display 
button (double-arrows) in the toolbar.    The speed of the display (intervals in seconds) can be 
specified by clicking on the Auto Display Setting button (clock).    To pause, press on the Pause 
button (double-bar).    The Auto Display options are available also from the View menu.



Thumbnail View

The pages can be displayed as 'thumbnails', reduced so that 6 or 15 images fit on the screen.    
To view the current page as a thumbnails, choose Thumbnails from the image windows's View 
menu.    The default maximum is set to 6 images per screen.    The setting can be changed in the 
View menu or in the DOCVIEW.INI file.
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To print the image

1. Select and display the image as explained above.

2. From the File menu, choose Print.    The Print Image window appears.

3. Specify the Scale Options.    Select 'Scale to Fit' or choose a specific scale.

4. Specify the top and left margins (offset).

5. If the document consists of several pages, specify the 'from' and 'to' page numbers. Pages are 
supported only for TIF and DCX file formats.

6. To set up the printer, choose Setup Printer.    This step is normally not required.

7. Choose OK.

Zoom

From the View menu, choose Zoom, or click on the Zoom button in the tool bar    The mouse pointer 
changes to a cross-hair.      Select a section of the image with your mouse.    Drag the mouse while 
holding down the left button.    The selected area is indicated by a 'rubber band'.    Release the 
mouse.    The zoomed section is displayed.    To increase the zoom factor, click on the zoomed 
image; to reduce the zoom factor click on the zoomed image while pressing CTRL, or click the right 
mouse button.    To cancel the zoom, click on the main image, click on the Zoom button again, or 
press the Delete key.    The zoomed and the original image can be resized with the Plus (+) and 
Minus (-)buttons in the toolbar.

Copy

To copy a section of the image, choose Copy from the Edit menu.    The mouse pointer changes to a 
cross-hair.      Select a section of the image with your mouse.    Drag the mouse while holding down 
the left button.    The selected area is indicated by a 'rubber band'.    Release the mouse.    The 
selected area is copied to the Windows Clipboard.

Close the Image

An image window may be closed by double-clicking the Control button in the upper-left corner of the 



image window, by choosing Close from the File menu, or by pressing the Delete key.



Change File Formats and Save

Often, the image scanner creates basic uncompressed bitmap files of the image.    The files must 
then be reformatted to a compressed TIFF file and saved in a permanent archive.    DocView 
includes a function that reformats single files, selected files or complete directories.

1. From the File menu of DocView imaging window, choose Global File Reformatting.    The Global 
File Reformatting window appears.

2. Double-click on the directory that holds the source files.    To screen out specific file formats, 
specify the Graphics Format.

3. Highlight the files that you want to convert.    To select a single file, simply click on the file name. 
To select several files, click on each file while holding down the Ctrl key.    To select a range, click 
on the first file and , while holding down the Shift key, click on the last file.

4. Specify the destination directory (double-click).

5. Specify the new graphics format.

6. the TIFF and DCX formats support multiple pages.    Check the Append box if you want to 
append the files as a new page if the file already exists.

7. If you want to be alerted if a file already exists, check the Alert box.

8. If you want the system to automatically delete the source file after creating the destination file, 
check the Automatic Delete box.

9. Click on OK.



System Integration

DocView is an image viewer for document imaging systems.    DocView can readily be integrated into 
existing database systems or used as a stand-alone document viewer. 

The detailed specifications for the integration are contained in the Setup, Preferences section and 
the    INTEGR.TXT file.    Essentially, you need to create a DOCVIEW.INI with the specifications for 
integration.    Without the docview.ini file, DocView will run as a basic viewer and some of the menu 
items and toolbar buttons will be removed.

To create the DOCVIEW.INI file, choose the Setup menu and read the online help or the 
INTEGR.TXT file.

DocView can be used as a stand-alone document viewer with multi-page TIFF file capabilities      and 
can also be launched from other Windows programs and with the C:\DOCVIEW\DOCVIEW.EXE X:
\XXXXX.XXX command (where the X:\XXXXXX.XXX is the image file name).

Informatik Inc. has available, currently free of charge to registered DocView users, several utilities, 
such as image annotation, scanning, conversion tools, TIFF page tools, drivers, etc..    For 
information, please contact Informatik Inc. at info@informatik.com.



Setup. Preferences

Please also read the INTEGR.TXT file.

Link TO the Database EDIT System

The three fields in this section specify the link to the Edit application of the database system.    If 
there is no link to another application, these fields are left blank.    The fields are not used for links 
from other applications to DocView 

DDE Topic

This field specifies the link topic to the master application.    For an outgoing DDE link, enter 
the linked application's DDE Topic.    For the SendKeys method, enter the linked applications 
executable file name (with full path).

DDE Item

This field identifies the link item.    For an outgoing DDE link, enter the linked application's 
DDE Item.    For the SendKeys method, enter the linked applications EXACT title name as 
shown in its title bar. The exact spelling and spacing are important

SendKeys String

This field is used only for the SendKeys method.    The entry represents the key strokes that 
are sent to the database edit application.

Link TO the Database QUERY System

The three fields in this section specify the link to the Query application of the database system.    If 
there is no link to another application, these fields are left blank.    The fields are not used for links 
from other applications to DocView 

DDE Topic

This field specifies the link topic to the master application.    For an outgoing DDE link, enter 
the linked application's DDE Topic.    For the SendKeys method, enter the linked applications 
executable file name (with full path).

DDE Item
This field identifies the link item.    For an outgoing DDE link, enter the linked application's 
DDE Item.    For the SendKeys method, enter the linked applications EXACT title name as 
shown in its title bar. The exact spelling and spacing are important

SendKeys String

This field is used only for the SendKeys method.    The entry represents the key strokes that 
are sent to the database edit application.



Path Prefix

If the database does not specify the path to the image file, it can be entered here.    For example, if 
the database contains an image field name of IMG0001.TIF and the Path Prefix is D:\XXX\, the 
DocView will look for the D:\XXX\IMG0001.TIF file.    Please be sure that you include the backslash 
(\) if necessary.

Path Substitution

If the database does specify the drive letter of the image file, but DocView is run on a PC with a 
different drive letter, the drive letter can be substituted.    For example, the database contains an 
image field name of D:\IMG0001.TIF on a CD, but the CD is loaded on the F:\drive.    If you specify a 
drive substitution of F:\, DocView will look for the F:\IMG0001.TIF file.    The substitution is done on a 
'equal number of characters' basis.    It is therefor possible to substitute not only the drive but the 
directory as sell (but the number of characters must match).

Master Window

This field specifies the opening state of the parent (MDI) window: 
blank or 0 = normal, full screen size

1 = minimized
2 = maximized
3 = Fittoimage, placed in the upperleft corner
x=nnnn y=nnnn will offset the window from the left and the top
x=right y=bottom will place the window at the absolute right and/or bottom of the screen. 

Image Window Width

This field specifies the width of the image display window.    If the value is 2, the window opens 
maximized, otherwise, if the value is 100 or less, the entry represents a percentage of the screen 
width.    If more than 100 it represents the measurement in twips    (1440 twips = 1 inch; 576 twips = 1 
cm).

Image Window Height

This field specifies the height of the image display window.    If the value is 100 or less, the entry 
represents a percentage of the screen height, otherwise it is measured in twips    (1440 twips = 1 
inch; 576 twips = 1 cm).

This field specifies the width of the image display window.    If the value is 100 or less, the entry 
represents a percentage of the screen width, otherwise it is measured in twips    (1440 twips = 1 inch; 
576 twips = 1 cm).
Item 9 is the height of the image display window. If the value is 100 or less.

Magnification List

The View menu of    image display window has various magnification options.    The default 
magnification ratios are: 25, 50 100,150,200,300, in addition to Customize.    The list of 



magnifications can be customized in this field.    If you enter 48,96,150,200,500 the menu list will be 
changed to these specified ratios. 

Options

A number of special options will be added to DocView.

The current options are:

nosave
          The Save As option is disabled.

printall
          Default is set to print ALL pages.

fit
          Opens the initial image 'FittoSize'.

If you use several options in this field, separate them with a comma or a space.

Print Offset Left,    Print Offset Top, Scale-to-Fit

Enter the left margin, top margin and the 'scale-to-fit' default for printing purposes.    The values are 
in inches or centimeters depending on the Windows setup.




