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Product Overview

CLEARweb is the most powerful tool available for collecting, organizing, and publishing Internet
addresses:

e  Automatically create an outline and graphical map of all the pages on a World Wide Web site.
e Reach any web page with a single mouse click.

e  Capture all the addresses from a web page with a single command.

e Use the contents of your Netscape bookmark file to create a personal map of the Internet.

e Publish CLEARweb maps on the Internet, or save them as Netscape bookmark or web page
files.

System Requirements

CLEARweb runs on an IBM PC using Windows 3.1 or higher, with at least 4 megabytes of RAM and 3
megabytes of available disk storage. An Internet connection and a copy of Netscape are required to use
CLEARweb to view and collect Internet addresses. Future versions of CLEARweb will support additional
web browsers.

Pricing

The current beta test version of CLEARweb is available free of charge. When the final version of
CLEARweb is released, it will sell for $49. A free CLEARweb Viewer that allows users to display
CLEARweb maps will also be available for royalty-free distribution along with maps.



What's New in the Latest Beta Test

Beta 0.5 is a major rewrite of the CLEARweb program. Here is a summary of the latest changes:
Single CLEARweb Program

The features of the Outline Editor and Viewer have been combined into a single program. A new, unified
interface allows you to see graphical and outline views, and edit the outline at the same time. The
separate Map Editor has also been removed from the product. Map formatting is done with a dialog box in
CLEARweb. A royalty-free, viewer-only version of CLEARweb will be reintroduced in a later beta test for
free distribution with your maps.

File Format Changes

CLEARweb now uses a new internal format for CWM files, and is unable to read CWM files created by
previous beta versions. Trying to open a CWM file from a previous version will cause an error.
Examples files in the new CWM format were automatically installed in your \clearweb\examples directory,
and any old examples were moved to the \clearweb\examples\old directory.

CWO files created in previous beta tests are still compatible with version 0.5, and they can be used to
recreate your own CWM files. Use Import on the File menu to open the CWO file, and then select Save
from the File menu. This will automatically create a new CWM file in the proper format. You will find
additional information in the section on File Formats.

Improved Outline Editing

The original CLEARweb outline editor has been completely redesigned. Some editing features have
changed and many new ones have been added.

e  Edit boxes for both the name and address of the current item are now available.
e  Drag and drop between two outlines now copies the dropped item, leaving the original in place.

e  Qutline items can be quickly moved to a new location by holding down the Ctrl key and pressing
one of the arrow keys.

e Multiple outline items can be selected by holding down the Shift key and clicking on the
beginning and end of a range of items. Multiple items can be used with Cut, Copy, Paste,
Demote, Promote, and Drag and Drop.

e New Item now inserts an item as the first child instead of the last.

e Qutline items can now be sorted by address as well as by name.

¢ Find and Replace text is available for the name, address, or description portions of an item.
e The dreaded Properties dialog has been removed.

e  The Description for each item can be viewed and edited with a new Description window.

Smarter Address Capturing

The new Address menu includes more reliable and powerful options for automatically adding addresses
to a map. Captured addresses are now inserted into the current outline, instead of creating a new outline.

e Add Browser Address inserts a new item with the title and address of the page displayed in
your web browser.

e Add Browser Contents inserts new items for all of the addresses and headings from the page
displayed in your browser . This creates an automatic set of bookmarks from the addresses in a
single page.

e Explore Website captures an entire website in a single step. Simply enter the starting address
and number of levels to explore, and CLEARweb automatically creates an outline showing the



contents of any website. You can limit the exploration to a single Internet domain, or allow
CLEARweb to follow the addresses wherever they lead on the World Wide Web!

Multiple Right-click Menus

The mouse right-click menu now adapts to the current cursor location. Different right-click menus are
available for the map view, the outline view, and the edit boxes.

Export to Web Page

A CLEARweb map can now be exported to a standard web page file, as well as a Netscape bookmark
file. Addtional formatting options for these web pages will be available in later beta tests.

Print the Map View

Printing has finally been introduced in this beta with the ability to print the map view on a single page.
Printing the outline will be available in the next beta version.

Send a Map Through Email

CLEARweb now includes the ability to send map files through electronic mail. The Send option on the File
menu displays a standard email form. All you have to do is fill in the blanks and select a map to attach to
the message. The CLEARweb installation program asked for your email host name. If you didn't enter it
then, you will have to enter it in the Mail Preferences dialog, available from the Options menu. If you are
unsure of this value, you should contact your Internet provider and ask for the name of your "SMTP host
for sending email.”

Show Addresses in Outline

The View menu now contains an Outline Text item, which allows you to choose whether the Name or
Address is displayed in the outline.

Go Menu

The new Go menu adds the options of Go Back to open the previous item in a browser, and Go Forward
to open the next address.

Options Menu

The Preferences option has been removed from the File menu and expanded into the new Options menu.
Option dialogs are available for general, browser, email, and map preferences.

Uninstall CLEARweb

If you don't find all of these enhancements enough reason to continue using CLEARweb, you can use the
new uninstall option to completely remove CLEARweb from your computer. Uninstall can be run from an
icon in the CLEARweb program group, or from the CLEARweb folder in Windows 95's Start menu.



CLEARweb Quick Start

CLEARweb is a complete system for managing and publishing Internet addresses. This section will
describe the major benefits of the product, and list the most direct ways of using these features.

Menu, Speedbar, Keyboard, and Mouse

As with any Windows program, CLEARweb offers several user interface methods. You can select items
from the pulldown menu system, click icons for common actions on the speedbar, and use keyboard and
mouse shortcuts. For the sake of brevity, complete details on all these interface options will be left to later
sections of this help file.

Opening a Map File

CLEARweb saves Internet addresses in CLEARweb Map (CWM) files. This is a compressed format that
combines an outline and graphical view into half the space of a Netscape bookmark file. The installation
program placed sample maps in the \clearweb\examples subdirectory, and these can be viewed by
selecting Open from the File menu.
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A CLEARweb map displays a collection of Internet addresses as a diagram in the left window panel and
an outline in the right. Each entry in a map can contain a name, an address, and a text description.

Viewing a Map

The View menu controls the display of a map. You can enlarge or shrink the diagram view with Zoom In
and Zoom Out. Fit In Window will automatically resize the entire diagram to match the space available.
The best way to read the text in diagram boxes is to select Actual Size.

Portions of the outline can be hidden with the Collapse option, and revealed with Expand. Collapsing a
section of the outline also causes it to disappear from the graphical view. The outline can also be
expanded and collapsed by double-clicking on the icon for an outline item.



The vertical bar in the middle of the window can be dragged to the left or right to control the relative size
of the two window panels. Either window panel can be hidden by selecting Map Only or Outline Only
from the Split Window option in the View menu.

Outline Icons and Diagram Shapes

Outline items have different icons depending on the type of Internet address they contain. For example,
an item with no address starts with L1, while one with the address of a web page has

B. Box shapes in the diagram view are also based on the address type. A complete listing of the icons
and box shapes is available.

Navigating the Internet

A CLEARweb map can be used along with your web browser as a graphical navigation tool for the
Internet. Double-clicking a map item when the cursor is in the shape of a hand will open the address in
your web browser. If your browser isn't already running, CLEARweb will automatically start it and then
open the requested address. You can also drag an item from a map and drop it onto your web browser to
open it. The Go menu and the Speedbar contain additonal options for navigating to different addresses in
a map.

Downloading Maps from the Internet

Information about the Internet changes often, so CLEARweb allows you to download new maps from web
pages. When a hyperlink points to a CWM file on the Internet, you can click to have the file downloaded

and automatically opened in CLEARweb. You can recognize a CWM file by the "E icon. When a CWM
file is downloaded, it is stored temporarily. When you close the file, it is automatically erased from your
computer. You can use the Save option from the File menu to save a downloaded file permanently with
the name of your choice.

Addresses in a CLEARweb map can point to other maps on the Internet. Double-clicking an entry for a
CWAM file on the Internet will download the file and display it. This allows multiple maps to be
interconnected into a web of their own.

Adding Addresses to a Map

The Address menu contains three options for adding addresses to a map:

e Add Browser Address inserts a new item with the title and address of the current page in your
web browser.

e Add Browser Contents reads the addresses and headings from the page displayed in your
browser and adds them beneath the current outline item. This creates an automatic set of
bookmarks for the addresses in a single page.

e Explore Website lets you capture an entire website in a single step. After you specify the
starting address and number of levels to explore, CLEARweb will automatically create an outline
showing the contents of any website. You can limit the exploration to a single Internet domain,
or allow CLEARweb to follow the addresses wherever they lead on the World Wide Web!

Searching the Internet

CLEARweb is a great tool for doing research with the Internet. The Go menu contains a Search the
Internet option, which displays CLEAR Software's Internet search page in your web browser. You can
use this page to query all of the most popular search engines, and then use the Add Browser Contents
option on the Address menu to automatically capture the search results in your outline. If you find a
website full of great information, use Explore Website to grab the first 2 or 3 levels then edit it down to
just the material on your research topic.

Editing a CLEARweb Map



CLEARweb has edit boxes beneath the speedbar, which give direct access to the name and address of
the current item. You select an item and then type into the edit boxes. The up and down arrow icons next
to the Name edit box allow easy access to the next and previous item for editing. The Edit menu and the
speedbar also offer a wide range of editing options:

e To edit or view an item's description in a separate window, select Description.
¢ New Item inserts a blank entry beneath the current item.

e Anitem can be moved to a higher level of the outline with Promote and a lower level with
Demote.

e Cut, Copy, and Paste are available within a single outline, and between two open outlines. You
can also Drag and Drop within an outline to move the current item, and Drag and Drop between
two open outlines copies the current item.

e  The current outline item can be moved quickly to a new location by holding down the Ctrl key
and pressing the arrow keys.

e Multiple outline items can be selected by holding down the Shift key and clicking on the
beginning and end of a range of items. Multiple items can be used with Cut, Copy, Paste,
Demote, Promote, and Drag and Drop.

e Any portion of an outline can be automatically organised with Sort by Name and Sort by
Address.

¢ Find and Replace text is available for the name, address, or description portions of an item.

e  Formatting options for the map view can be selected with Map Style.

Editing Netscape Bookmark Files

CLEARweb can open a Netscape bookmark file and automatically convert the bookmarks into a map.
This is done with the Open option in the File menu. You need to select files of type *.htm to display the
available bookmark files. The default Netscape bookmark file is called Bookmark.htm, and is usually
found in the same directory as the Netscape program.

Once a bookmark file is opened in CLEARweb, you can use all of the standard editing features.
Bookmarks can also be moved to new maps with copy and paste, or drag and drop. To save the results
back to a Netscape bookmark file, select the Export to Bookmark File option from the File menu.

Publishing Maps on the Internet

CLEARweb maps can be published on the Internet as either web pages or CWM files. Web page files
display an outline version of a map and can be viewed by anyone with a web browser. To create a web
page from an open map, select Export to Web Page from the File menu. This will create a file in
standard web page format with an extension of HTM. You can then post this file on any web server
without modification. You can also can read the file into your normal web page editor and copy the outline
to your own web page files. A CLEARweb user who finds this outline on the World Wide Web can use
Add Browser Contents on the View menu to insert the contents of the outline back into a CLEARweb
map.

Publishing CWM files on the Internet allows users of CLEARweb or the free viewer to download a
complete map and use it immediately. This feature is especially useful when large numbers of your users
are likely to have a copy of the CLEARweb software. You will find complete details for putting CWM files
on the Internet on our website at http://www.clearsoft.com/clearweb/publish.html.



File Menu

This section will be available in a future beta test version.



Edit Menu

This section will be available in a future beta test version.



View Menu

This section will be available in a future beta test version.



Go Menu

This section will be available in a future beta test version.



Address Menu

This section will be available in a future beta test version.



Options Menu

This section will be available in a future beta test version.



Window Menu

This section will be available in a future beta test version.



Help Menu

This section will be available in a future beta test version.



Speedbar Icons

This section will be available in a future beta test version.



Outline Icons and Addresses

This section will be available in a future beta test version.



Keyboard and Mouse Shortcuts

Keyboard

Home - Move to the Top Outline Iltem

End - Move to the Bottom Outline Iltem

Page Up - Move the Outline Cursor Up One Page

Page Down - Move the Outline Cursor Down One Page

Up Arrow, Left Arrow - Move the Outline Cursor Up One Item
Down Arrow, Right Arrow - Move the Outline Cursor Down One Item
Ctrl-Up Arrow - Move the Current Outline Item Up

Ctrl-Down - Move the Current Outline Item Down

Ctrl-Left Arrow - Promote the Current Outline Item

Ctrl-Right Arrow - Demote the Current Outline Item

F1 - Open Help File

F2 - Goto Current Address

F4 - Resize Map to Fit in Graphical Window

F6 - Resize Map Boxes to Actual Size

Shift-F4 - Cascade Multiple Map Windows

Shift-F5 - Tile Multiple Map Windows

Mouse

Double-Click - Goto Current Address in Web Browser (when cursor is a hand)
Double-Click - Expand/Collapse Current Outline Item (when cursor is a pointer)
Right-Click - Open Menu

Drag and Drop - Move item beneath new location

Drag and Ctrl-Drop - Copy item beneath new location



Files Used by CLEARweb

CLEARweb can read and write several file formats:

e CLEARweb's native format is a CLEARweb Map (CWM) file. This is the default format for the
File Open menu option, and it is the only format created with the File Save and File Save As
menu options. CWM is a binary file format that holds both text and graphical information about a
collection of Internet addresses. CWM files are compressed to roughly half the size of a
comparable bookmark file, reducing storage space and downloading time. For information on
publishing CWM files on your own Internet server, see the web page:
http://www.clearsoft.com/clearweb/publish.html.

e To allow open exchange of addresses between different programs, a CLEARweb map can also
be placed in a CLEARweb Output (CWO) file. CWO files contain a text version of the address
information found in a map. The File Open menu item allows the selection of CWO files, and the
File Export menu has an option for saving CWO files.

o HTM files can contain web pages or Netscape bookmarks. CLEARweb can open any HTM file
and automatically convert all of the Internet addresses into an outline. This is done by selecting the File
Open menu item, and setting the file type to *.htm'. CLEARweb outlines can be saved in Netscape
bookmark format or standard web page format with the File Export menu items.



Contacting CLEAR Software, Inc.

Mail: 199 Wells Avenue

Newton, MA 02159

Order Line: 800-338-1759

Fax: 617-965-5310

CLEARweb Product Manager Email: clearweb@clearsoft.com

Company Home Page: http:/lwww.clearsoft.com/
CLEARweb Home Page: http:/lwww.clearsoft.com/clearweb/
CLEARweb User Survey: http:/lwww.clearsoft.com/clearweb/survey.html

CLEARweb Mailing Lists: http:/lwww.clearsoft.com/clearweb/subscrib.html






