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Introduction

Welcome to Extensis Intellihance. You've just purchased an intelligent tool that makes Adobeâ Photoshopâ 
work faster, easier and more efficiently than ever before. 

Intellihance improves the way your digital images appear in print or on the screen by intelligently analyzing 
each image's needs and then automatically applying filters to optimize contrast, brightness, saturation, sharpness 
and despeckle. All you need to do is click the Enhance Image button.

Although we believe Intellihance's default settings will satisfy the majority of users most of the time, you can 
customize Intellihance's intelligent enhancement engine to analyze and enhance each image according to your 
specifications.

We even provide a manual "Fine Tune" area for those few images that you want to tweak a bit further.

Note

¨ While Intellihance should be compatible with all applications that accept Adobe Photoshop Plug-ins, not all 
applications have been thoroughly tested.



Common Questions

¨ Will Intellihance process every image correctly?

Intellihance processes most images in an optimum way. Users have experienced a 1-7% fallout; although, it 
is interesting to note that often it is hard to improve the fallout images beyond that of images processed by 
Intellihance, even when starting from scratch. If image quality degrades after running Intellihance with its 
default preferences, try turning Contrast, Saturation and/or Brightness preference settings Off and running 
Intellihance again.

¨ Which Scanners does Intellihance work with?

Intellihance works with all scanners -- you can optimize images from any source. 

¨ Will Intellihance work with my color management system? 

Intellihance works well with color management systems both inside and outside of Adobe Photoshop..

¨ Does Intellihance require that my scanner be calibrated?

Because Intellihance operates on color balance principles, it works with both calibrated and uncalibrated 
scanners.

¨ Can I run Intellihance multiple times?

Yes, running Intellihance again will often bring the image even closer to your preferences.

¨ Must I calibrate my monitor when using Intellihance?

If you plan to use the monitor display to evaluate the quality of the image before you print, it is very 
helpful -- although not required -- to calibrate your monitor. If you are evaluating grayscale images on the 
monitor, then calibrate your monitor using the monitor preferences in Adobe Photoshop. If you are 
evaluating color images on your monitor, you should use a color calibration system.

¨ My image looks good on the monitor but not in print.

You may need to calibrate your output device or monitor, or both. Refer to Monitor Calibration Tips for 
more information.

¨ My image lacks contrast.

Try reducing the Limits and Dot Gain from Adobe Photoshop. Also, try increasing the Contrast filter 
setting or decreasing the Brightness setting in the Intellihance Preferences dialog box.



Contacting Extensis Technical Support

If you have a question or problem that is not addressed in the documentation, please call technical support at 
503-274-7030 Monday through Friday, between the hours of 8:00 a.m. to 5:00 p.m., Pacific time.

You can send us a Fax at 503-274-0530, or contact us through one of these online services:

¨ CompuServe: 70242,33

¨ America Online: EXTENSIS

¨ E-Mail: support@extensis.com

¨ Web: http://www.extensis.com

When calling Technical Support, please be at your computer and have the following information available:

¨ Your Intellihance registration number.

¨ Your system configuration.

¨ Your question or a description of the difficulty you're experiencing -- what specifically occurs and when. 
Write down any displayed error numbers or messages and any other information you think may be helpful.

Suggestions

We'd love to hear your comments about Intellihance, ideas for new plug-ins or improvements to Intellihance. A 
suggestion sheet is included at the end of the Intellihance manual. Please fax or mail your comments and 
suggestions to Extensis.



Beginning to Use Intellihance

Intellihance improves the way your images appear in print or on the screen by intelligently analyzing each 
image and automatically adjusting only the amount of contrast, brightness, saturation, sharpness and despeckle 
needed to optimize the image. Intellihance measures the amount of these variables in your original image, 
compares the measurements with the preferences table and then automatically enhances the image to match the 
preferences.

The Intellihance default preferences are based on the way most people like to view images in print or on the 
screen. The best way for you to decide if you like the default settings is to try them. Process a variety of images 
with Intellihance, and look at the results. If you like what you see, the default settings are fine for you. 

Another excellent use of Intellihance is with graphics you're preparing for the Internet. Use Intellihance to 
optimize these images.

The following table lists the Intellihance default settings. If you want to change the default preferences, refer to 
the overview about Customizing Intellihance and the topic Adjusting Intellihance Filters.

Intellihance Filter Default setting

Contrast Normal

Brightness Balanced Tone

Saturation Medium

Sharpness Medium Sharpness

Despeckle Off



Using Intellihance with the Default Settings

The following procedure tells you how to use Intellihance with its default settings -- simply open an image in 
Adobe Photoshop, select the Intellihance filter, and click OK. That's all there is to it!

To process an image with Intellihance default settings:

1 From Adobe Photoshop, open an RGB, CMYK or GS image you'd like to process. 

2 Bring up the Intellihance Quick Enhance dialog box by choosing Filter > Intellihance > RGB or CMYK or 
GS.

3 When you see the Quick Enhance dialog box, click Enhance Image. Once you have run Intellihance on 
your first image, you can use the "Control-F" keyboard shortcut to enhance other images.

The Enhance Image dialog box appears the first time you use Intellihance or if you select Intellihance from 
the Filters menu.



Processing an Image Using the Before and After Previews

1 From Adobe Photoshop, open an RGB, CMYK or GS image you'd like to process.

2 Bring up the Intellihance Quick Enhance dialog box by choosing Filter > Intellihance > RGB or CMYK or 
GS.

Intellihance automatically makes available the appropriate GS, RGB or CMYK filter for your image in the 
pull-down menu (the other filters are not available).

3 From the Quick Enhance dialog box, click the Preferences button.

4 From the Intellihance Preview dialog box, click OK to process the image.

The Preview dialog box shows you a preview of the original image and the enhancements Intellihance 
proposes to make when you process it.

Tips

¨ You can use Control-Alt-F to open the Quick Enhance dialog box once the filter has been run.

¨ To display the Preview dialog box every time you open Intellihance, select the Preferences dialog box 
checkbox in the Preferences settings.



Overview of Customizing Intellihance

You can customize the way Intellihance applies the contrast, brightness, saturation, sharpness and despeckle 
filters. Choose these options in the Preferences dialog box pop-up menus.

Intellihance analyzes and compares your original image to the output settings you've chosen -- and then 
automatically processes the image to match your preferences. You determine the way you want your output to 
appear. Make those selections from the menus in the Intellihance Preferences dialog box, and then click OK to 
apply the changes. Then you can apply the same set of preferences to multiple images. You can also save 
different preference settings and load them at a later time.

See also:

Adjusting Intellihance Filters

Using the Intellihance Fine Tune Option

Color Separation Table

Saving and Loading Intellihance Filter Settings

Generating a Report of Changes to the Image



Adjusting Intellihance Filters

You can adjust five separate filters from the Intellihance Preferences dialog box. Each filter has a menu of 
predefined effects. 

Contrast

Brightness

Saturation (available with RGB and CMYK only) 

Sharpness

Despeckle



Adjusting the Contrast Filter

The Contrast filter gives you four options for adjusting tonal correction. The Normal option will brighten 
highlights, darken shadows and establish midtones for best overall contrast. Select the Soft option if you want 
to maintain maximum shadow and highlight detail or if you want to lower contrast overall. Select the Snappy 
option if you want your image to have solid blacks and solid whites or to increase contrast. Select the Hard 
Contrast option if you want images with high contrast or if you want a posterized effect. If you don't want any 
correction, you can turn this filter Off. 

Two additional options are available for special publishing applications. Flatten Highlights may be useful when 
printing on newspaper to allow you to use the paper itself to represent the highlight in the image. Flatten 
Shadows may be useful when you want to push some shadow noise into the blacks.



Adjusting the Brightness Filter

The Brightness filter adjusts or shifts various tonal groups. You can shift shadows, midtones, or highlights, or 
balance the overall tone of the image. This means, for example, that Intellihance can darken overexposed 
photographs and lighten underexposed photographs. If you don't want any correction, you can turn this filter 
Off. 

Brightness is a subjective adjustment. Try each of the settings for the Brightness filter and see what you like 
best. After running the settings on several images, you'll discover which setting provides the most desirable 
results.



Adjusting the Saturation Filter

The Saturation filter (available with RGB and CMYK only) is a color correction filter for automatically 
adjusting the purity of the color. The Medium option provides excellent results for most images. Intellihance 
automatically examines the saturation of the input image and then will increase or decrease the saturation 
according to the setting for this filter. This is very useful with Photo CD images that are often oversaturated. If 
you don't want any saturation correction, you can turn this filter Off. 

Saturation processing will increase the computing time. Unless you have a powerful computer, you may want to 
allow extra time to process images that need more adjustments.



Adjusting the Sharpness Filter

The Sharpness filter sharpens soft images by increasing the contrast of adjacent pixels. 

Like Brightness, Sharpness is also subjective. Try each of the settings for the Sharpness filter on several images 
and see what you like best. If you don't want any correction, you can turn this filter Off. Remember, the 
Sharpness filter will not sharpen noisy images.

Notes

¨ Note for professional users: The Intellihance sharpness algorithm is actually an "unsharp mask" algorithm.

¨ On large images, the Preview dialog box may exaggerate the sharpening effects.



Adjusting the Despeckle Filter

The Despeckle filter removes noise, such as photograin or scanner-induced noise, while preserving detail. 
Intellihance detects the edges in an image (the areas where significant color changes occur) and gently smooths 
all of the selection except those edges. 

If you want to reduce image noise, this filter has three options that will process only noisy pixels without 
changing highlights or other details. 

The Overall option is useful for situations where the image may contain speckles or photograin noise in the 
image. The Dark Tones Only option is for images where you're satisfied with your light tones and only need to 
adjust dark tones. The Light Tones Only option is for images you might enlarge such that the photograin in the 
highlights becomes evident. These last two options allow you to limit the filtering to the darker or lighter areas 
of the image. If you don't want any correction, you can turn this filter Off. 

Note

¨ On large images, the Preview dialog box may exaggerate the Despeckle effects.

See also:

Scanning Tips



Using the Intellihance Fine Tune Option

Although the power of Intellihance lies primarily in its ability to automatically correct and enhance images with 
little or no user intervention, you may occasionally want specific control of image adjustments. You can use the 
Fine Tune dialog box to accomplish this. Fine Tune conveniently locates a variety of separate Photoshop 
functions into one dialog box. The preview shows you the effect of each adjustment. You can preview your 
original image -- without the effects -- by holding down the Control key. 

To manually fine tune an image:

1 Bring up the Intellihance Quick Enhance dialog box by choosing Filter > Intellihance > RGB or CMYK or 
GS. 

2 In the Quick Enhance dialog box, click the Preferences button.

3 Click the Fine Tune... button or press Control -F.

The Fine Tune dialog box appears.

4 Select the tab for the filter you want to adjust.

5 Move each slider to your desired position.

Intellihance will filter the image using the measurements from the slider positions -- while you watch.

Tip

¨ To display the Fine Tune dialog box every time you open Intellihance, select the Fine Tune Always 
checkbox from the Preferences settings in the Intellihance Preview dialog box. Then, every time you select 
Intellihance from the Filter menu, press Control-Alt-F after Intellihance has been run once.

Note

¨ Intellihance processes the image with the automatic settings before you make any adjustments in the Fine 
Tune dialog box.

See also:

Recommended Order of Applying Filters



Recommended Order of Applying Filters

The order in which you apply the filters affects the output. We recommend you use the following order.

1 Set the Tone. Set the white point as low as you can without flattening important highlights. Set the black 
point as high as you can without flattening the shadow data. Set the gamma or midtone point for a balanced 
tone or to emphasize a key element in the image.

2 Adjust the Sharpness. Sharpness can amplify noise if not applied correctly. Set the radius at 2 or 3 
depending on the ppi of the scan, set the Amount % between 30-120% and set the Threshold between 0-20. 
Note that on large images, the Preview dialog box will exaggerate the sharpening effects.

3 Remove noise. The Despeckle filter reduces image noise. Set the lower limit and upper limit to determine 
when noise removal begins and ends. Typically, this filter is applied in the shadows. Note that on large 
images, the Preview dialog box will exaggerate the blurring effects.

4 Adjust Saturation. 

See also:

Enhancement Tips



Color Separation Table

When you want to convert RGB images to CMYK, you can use the PixelCraft ColorAccess professional color 
separation table included with Intellihance. RGB scanners, Photo CD disks and stock photography disks 
produce RGB images that must be converted to CMYK for printing. If you've ever performed these separations 
using other CMYK separation tables, you may have noticed:

¨ Color shifts in color you thought would be pure.

¨ Posterization or a flattening of highly saturated colors.

¨ Overall image darkness and a lack of definition in the shadows or dull highlights.

¨ An overall magenta cast.

¨ A brownish cast in the shadows.

The PixelCraft separation table, included on the Intellihance disk, produces better separations because the 
separation table maps the RGB color gamut to the most printable CMYK colors. This reduces common 
problems with CMYK separations that print too much ink. 

The PixelCraft color separation table was set up especially for Intellihance. PixelCraft separation tables are 
based on industry-standard "Skeletal Black" black generation algorithms and industry standard ink sets. The 
table included with Intellihance emulates a sheet-fed offset press using a commercial ink set on coated paper 
stock.

See also:

Using the Color Separation Table

Improving Color Separation Results

Improving Photo CD Results



Using the Color Separation Table

1 From the File menu, choose Preferences > Separation Tables....

The Separation Tables dialog box displays.

2 Click the Load button.

The File Load dialog box displays.

3 Find the PixelCraft separation table in the Plug-ins folder on your hard drive.

4 Select the PixelCraft separation table and click OK.

This table name displays next to the Use Table radio buttons and will be used in all RGB to CMYK 
separations. It will also be used to view all CMYK data instead of Adobe Photoshop's Printing Inks Setup 
whenever you use Adobe Photoshop.

5 Select Mode > CMYK color.

You'll watch the image change from RGB to CMYK color space.

Tip

¨ The Separation Table's dialog box also converts CMYK images to RGB for viewing CMYK data on the 
screen.



Improving Color Separation Results

1 Calibrate the Printing Inks Setup in Adobe Photoshop.

Follow the calibration procedure in Calibrating Your System, located in the Adobe Photoshop manual for 
entering the Printing Inks Setup information.

2 Calibrate your monitor for tone correction.

Follow the calibration procedure in Calibrating Your System, in the Adobe Photoshop manual.



Improving Photo CD Results

1 From the Intellihance Preference dialog box, set the Saturation filter to Medium.

A Medium Saturation filter will compensate for Photo CD images that are typically oversaturated and 
overexposed. 

2 Open your Photo CD image and convert it to a Lab image in Adobe Photoshop (Mode > Lab Color).

3 Select the lightness channel by pressing Control-1 or by clicking on the Lightness channel.

4 Run the Intellihance GS (grayscale) filter on the L channel.

5 View the entire image by pressing Control-0 or by choosing the Lab channel.

6 If needed, run the appropriate Intellihance filter on the entire image.



Saving and Loading Intellihance Filter Settings

After you set up Intellihance Filters with the specific adjustments you want, you can save these settings and 
then use them automatically.

To save filter adjustments:

1 Bring up the Intellihance Quick Enhance dialog box by choosing Filter > Intellihance > RGB, CMYK or 
GS.

2 In the Quick Enhance dialog box, click the Preferences button.

3 Make sure all the pop-up menus display the settings you want.

4 Click the Save Settings button or press Alt-S. 

5 Select a directory and a name for the settings file.

6 Click Save.

To load filter adjustments previously saved:

1 Bring up the Intellihance Quick Enhance dialog box by choosing Filter > Intellihance > RGB, CMYK or 
GS.

2 In the Quick Enhance dialog box, click the Preferences button.

3 Click the Load Settings button or press Alt-L.

4 Select the directory and name of the settings file to use.

5 Click Open.

The Intellihance Preferences dialog box now displays your saved settings in the pop-up menus.



Generating a Report of Changes to the Image

If you would like to see what Intellihance has done to the image, you can generate a report by holding down the 
Control key when pressing OK in the dialog box. The report gives you parameters that emulate (although not 
exactly) Adobe Photoshop Levels and Unsharp Mask settings.

Notice the Saturation Factor value. This is an indication of how much the saturation increased or decreased. A 
value of 1.0 indicates Saturation was unchanged. Desaturation occurs when this value is less than 1.0. To use 
this value in Adobe Photoshop, multiply this number by 100 and copy into the Hue/Saturation dialog box.

The % Despeckled value indicates what percentage of the image's pixels were filtered as noise pixels.



Scanning Tips

You can use your scanner interface to control your scanner's brightness, color cast, white point and scan 
resolution.

Most scanner interfaces have various controls to set brightness, contrast, gamma, highlight and shadow points. 
These controls, if used improperly, can add noise or flatten the highlights and shadows of the image. That's why 
it's best to turn off your scanner's automatic features. 

To evaluate your scanner's capabilities:

1 Open an image from Adobe Photoshop.

2 Choose Adjust > Levels from the Image menu.

The Levels dialog box displays showing the distribution of pixel values in your image. 

Tip

¨ Turning off your scanner's automatic features will capture all the available data in the image. If this makes 
the image dark, Intellihance will automatically compensate.

See also:

Checking Your Scanner's White Point

Determining Whether to Use the Despeckle Filter

Determining the Scan Resolution



Checking Your Scanner's White Point

You can improve scans by properly setting your scanner's white point, that is, the reflective value the scanner 
sees as white or 0%. If your picture is overly bright and the scanner's white point is low, you may be flattening 
your highlight data. This is especially noticeable when scanning a calibration strip or an image with a broad 
tonal range.

Refer to the documentation provided in your scanner's manual to set the white point. Sometimes the brightness 
control can be used to set the white point of the scanner. If you can't seem to adjust the white point properly, 
you may have a scanner that doesn't allow you to set the white point; these scanners typically adjust the white 
point in software.



Determining Whether to Use the Despeckle Filter

If you want to determine whether to use the Despeckle filter, view speckles or noise. Noise can be previewed 
directly by turning up or increasing the contrast in the tones to an extreme. If the speckles are severe, set the 
Despeckle filter menu to Dark Tones Only from the Intellihance Preference dialog box. This will suppress 
shadow noise. If you are processing a batch of images with severe photo grain noise, set the Despeckle filter 
menu to Overall.



Determining the Scan Resolution

The capability of your output device determines the correct resolution for a scan. As a general rule, to produce a 
high-quality halftone image, the image resolution (measured in pixels-per-inch or ppi) should be 1.5-2 times the 
lines-per-inch (lpi) value of the halftone screen used to print the image. For example, to print a high-quality 
image using a 133-lpi screen, you would need an image resolution between 200 and 266 ppi (133 x 1.5 to 2.0). 
In some cases, however, depending on the image and the output device, ratios of as low as 1.25 produce 
excellent results. 

The size of the final image compared to the original image is also a consideration in setting scan resolution. If 
the final output size is not known, then overscan by a larger factor. For more information about determining the 
final output size, refer to your scanner's manual. 

If you see excessive noise in your scans, your scanner may be taking short cuts. Even though you want a scan at 
225 ppi, many scanners will scan the picture at 300 ppi and remove pixels electronically. In the case of high 
resolution scans, it is common for a scanner to scan at 600 ppi and add pixels to get 1200 ppi. This may result in 
speckle artifacts or blurring. If you see excessive scanner noise, try scanning at 300 or 600 dpi and then scale 
the image in Adobe Photoshop. Remember the scale factor affects the scan ppi.

For more information about determining the scan resolution, refer to Scanning, Importing, and Exporting 
Images in the Adobe Photoshop manual.



Enhancement Tips

After you have processed an image with Intellihance, there are three ways to further enhance the image.

1 Run Intellihance on the image again.

2 Use the Fine Tune adjustments.

3 Use other Adobe Photoshop filters and tools. Refer to the Adobe Photoshop manual for more information 
about image enhancement.

See also:

Run Intellihance on the Image Again

Use the Fine Tune Adjustment



Running Intellihance on the Image Again

When Intellihance processes an image, it compares the input to the settings in the Preferences dialog box and 
decides which filters to run to make the output conform to those settings. Sometimes you can run Intellihance 
again to gradually bring the image closer and closer to your preferences.

You can also run Intellihance again to bring out the effects of a specific filter. For example, maybe the sharpness 
of the image is good, but you want more brightness. If you set the Sharpness filter to Off and run Intellihance 
again, the Brightness filter continues to improve the brightness of the image.

Try running Intellihance with the Despeckle filter set to Dark Tones Only, and all other filters turned Off. This 
will clean up shadow speckles caused by excessive scanner noise.



Using the Fine Tune Adjustment

When you click the Fine Tune... button in the Intellihance Preview dialog box, you can adjust sliders for Tone, 
Saturation, Sharpness and Despeckle. 

Tone

Saturation

Sharpness

Despeckle



Tone

When you select the Tone tab, the Tone panel appears. The first slider adjusts the shadow (dark tone) values in 
your image to become black or the Black Point. The available numerical values are 0 to 253, where 253 is black 
(or 100% solid). Notice that if you adjust the Black Point to a value higher than the mid Point, the mid point 
value slides up also.

The second slider adjusts the middle tone values in your image. You can adjust this slider from 0 to 254. If your 
image contains middle tones (say, 25-75%) that you would like to darken or lighten overall, adjust this slider. 
Mid Point, normally considered to be 50%, is represented by the value 128. 

The third slider adjusts the light tone values in your image to become white or the White Point. You can adjust 
this slider from 1 to 255, where 255 is white (or 0% tone). 



Saturation

When you select the Saturation tab, the Saturation panel appears. The slider bar is calibrated in percentage with 
0% in the center, -100% on the left side and +100% on the right side. A positive percentage value increases the 
color but not the neutral or gray value in your image. A negative value decreases the color saturation. In other 
words, a saturated color tends to be brighter and a desaturated color tends to stay the same.



Sharpness

When you select the Sharpness tab, the Sharpness panel appears. The Amount % slider bar has numerical values 
from 0 to 200%. The Amount % increases relative sharpness of the image. The Radius slider bar has values that 
range from one pixel to three pixels. Radius establishes the width of the sharpened edges. The Threshold slider 
bar has values that range from 0 to 255. Higher Threshold settings reduce sharpening of pixel and photo grain 
noise. We recommend values no greater than 20. 



Despeckle

When you select the Despeckle tab, the Despeckle panel appears. The Amount % slider bar has numerical 
values from 0 to 200%. This slider sets the amount of pixel noise removed. The Lower Limit slider bar has 
values from 0 to 254. This value establishes the lowest level (darkest tone) at which despeckling or noise 
removal begins. The Upper Limit slider has values from 2 to 255. This value establishes the highest level 
(lightest tone) at which noise removal ends. For example, if you want to despeckle or remove noise in the 
shadow tones only, set the lower limit to 0 and the upper limit to 64.



Monitor Calibration Tips

If you want to use your monitor to evaluate halftones and color images on the screen (commonly referred to as 
"soft proofing"), you must calibrate your monitor. To reliably soft proof an image can save time and money in 
proofs and printing jobs. 

Calibration is the process of adjusting your monitor with the color conversion parameters to compensate for 
various factors that affect both the on-screen image and its conversion to printed output. These factors include 
room lighting conditions, the type of viewing light source, and the quality and settings of your monitor and 
display card. 

For comprehensive instructions about how to calibrate your monitor, refer to Calibrating Your System in the 
Adobe Photoshop User Guide.



Printing Tips

After you've processed your image so that you're satisfied with it, the next step is to prepare the image for your 
output device. You need to set the lpi of your output image and then of your output device as follows:

Setting the lpi of Your Output Image

Setting the lpi for Your Laser Printer

Setting the lpi for Your Imagesetter



Setting the lpi of Your Output Image

Selecting the lpi of your printer or imagesetter has a dramatic effect on the quality of your printed image. The 
human eye needs to see at least 64 gray levels for good tonal evaluation. This is why you should consider your 
output printing requirements before you begin setting the ppi of your scanner. If you plan to photocopy, laser 
print or quick print, don't use line screens over 100 lpi. 

In most cases, you can use the setting for your printer's default screen ruling located in your graphics 
application.

If not, calculate the best lpi for your printer based on the resolution of the printer (dpi), the line screen 
frequency (lpi) and the number of shades in your halftone.



Setting the lpi for Your Laser Printer

Use the following table for setting the lpi of your laser printer.

Printer dpi lpi # shades optimal for

300 53 32

600 72 64 600 dpi laser proofing 

600 85 50 newsprint proofing

800 100 64

800 85 88 newsprint proofing

1000 133 56 high resolution

1000 120 69 better tone

1000 100 100

1200 150 64 high resolution

1200 133 81 better tone

1200 100 120

For example, if you have a 600 dpi laser printer, you should use 72 lpi. This provides 64 shades of gray. A 
setting of 85 lpi could also be used in proofing newsprint, which provides about 50 shades of gray.



Setting the lpi for Your Imagesetter

Imagesetters typically have a dpi of 2400 or greater. At this resolution level, it is the press that will determine 
the lpi. A sheet-fed, offset press can reproduce screens as fine as 200 lpi or higher. Since many factors 
determine the maximum lpi of the press, you should consult your print vendor for this information. 



Multitone Tips

Duotones, Tritones and Quadtones (multitones) are useful in creating sepia, old photo, and other colorization 
and special effects. Using two, three or four inks to reproduce a single channel image not only creates these 
wonderful effects but also increases the tonal depth of the image. In either case, Intellihance can be used to 
increase the effectiveness and consistency of Duotones, Tritones and Quadtones. Although you can run 
Intellihance on images that have already been converted to the Duotone mode, we suggest you enhance the 
grayscale image before converting it to a duotone.

Processing an image for Multitone reproduction

When processing an image for Multitone reproduction, it is often desirable to spread the tone of the image over 
the entire dynamic range, sharpen it, and then remove noise from the image. Intellihance does all this for you 
automatically.

If the image is old, you should set the Despeckle filter to Dark Tones Only. You might want to preserve some of 
the image's softness by setting the Contrast filter to Soft. Once Intellihance has been run on the grayscale image, 
it is ready to convert into a Multitone.

Converting an image to Multitone

The Adobe Photoshop manual describes several ways to convert an image to a standard Duotone, Tritone or 
Quadtone.



Glossary
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 
Click the letter of the item you want to look up.

A

B

bitmapped

C

calibration

CMYK (Cyan, Magenta, Yellow, Black)

color correction

contrast

D

dpi (dots per inch)

duotone See multitone. 

E F

G

gamma

grayscale (GS)

H

halftone screen

I J K

L

Lab

lpi    (lines per inch)

M

monitor calibration

multitone

N O

P

pixel    (picture element)

pixelization

posterization

ppi    (pixels per inch)

Q

quadtone    See multitone. 

R



RGB    (Red, Green, Blue)

S

saturation

screen frequency

T

tritone    See multitone. 
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W

white point
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bitmapped

An image formed by a rectangular grid of pixels. The computer assigns a value to each pixel, from one bit of 
information (black or white), to as much as 24 bits per pixel for full color images.



calibration

Setting equipment to a standard measure to produce reliable results from input to output. See also monitor 
calibration.



CMYK    (Cyan, Magenta, Yellow, Black)

The subtractive primaries, or process colors, used in color printing. Black (K) is usually added to enhance 
contrast and to print a true black.



color correction

The process of adjusting an image to compensate for scanner deficiencies or for the characteristics of the output 
device, or the original film.



contrast

The relationship between the lightest and darkest areas of an image.



dpi    (dots per inch)

A common measurement for describing the resolution of input and output devices. See also ppi.



gamma

Measures the contrast that affects the midlevel grays (midtones) of an image. Adjusting the gamma lets you 
change the brightness values of the middle range of gray tones without dramatically altering the shadows and 
highlights.



grayscale (GS)

The depiction of gray tones between black and white.



halftone screen

A pattern of dots of different sizes used to simulate a continuous tone photograph, either in color or black and 
white.



Lab

The Lab color model is based on the original color model proposed by the Commission Internationale 
d'Eclairage (CIE) in 1931 as an international standard for color measurement.



lpi    (lines per inch)

A measure of the frequency of a halftone screen (usually ranging from 55-200). Originally, halftones were made 
by placing an etched glass plate over an image and exposing it to produce dots. Lpi refers to the frequency of 
the horizontal and vertical lines.



monitor calibration

The process of correcting the color rendition settings of a monitor to match the colors of printed output.



multitone

Used to integrate one or more colors into a grayscale image for a design effect.



pixel    (picture element)

The smallest distinct unit of a bitmapped image.



pixelization

If the image resolution is too low, the PostScript language may use the color value of a single pixel to create 
several halftone dots when printing. This results in pixelization, or blocky-looking output. 



posterization

A flattening of highly saturated colors.



ppi    (pixels per inch)

A measure of the amount of scanned information. The finer the optics of the scanner, the higher the scan 
resolution.



RGB    (Red, Green, Blue)

The additive primary colors used for computer monitor displays.



saturation 

The strength or purity of color. Saturation represents the amount of gray in proportion to the hue and is 
measured as a percentage from 0% (gray) to 100% (fully saturated).



screen frequency

The number of lines or dots per inch on a halftone screen. Same as lpi.



white point 

The reflective value that a scanner sees as white or 0%.



Preview Dialog Box Options

Left graphic

Your original image. This is the "before" view of your image.

Right graphic

A preview of the filter adjustments Intellihance will make to the image. This is the "after" view of your image.

OK button

Click OK to process the image. 

Cancel button

Click Cancel to exit the Preview screen.

Load Settings button

Selects a file of previously saved preferences and loads them in the Intellihance Preview dialog box (Alt-L).

Save Settings button

Saves the current preference into a directory and file of your choice (Alt-S).

Fine Tune button

Displays the Fine Tune dialog box that allows you to manually adjust your image (Alt-F).

Help button

Displays Intellihance online help.

Pixel Readouts

When you move your mouse over the preview image, the pointer becomes a crosshair. Move the crosshair over 
the Preview image to see the before and after pixel readouts in CMYK, RGB, or GS values. 

Preferences tab

Click this tab to customize the way Intellihance applies its filters. 

Extensis logo

Click for information about Intellihance and Technical support.



Preferences Dialog Box Options

OK button

Intellihance will process the current image with the output settings defined in the Preferences panel (Enter).

Cancel button

Exits Intellihance with no changes (Escape).

Load Settings button

Selects a file of previously saved settings and loads them in the Intellihance Preferences dialog box (Alt-L).

Save Settings button

Saves the current preference into a folder and file of your choice (Alt-S).

Fine Tune button

Displays the Fine Tune dialog box that allows you to manually adjust your image (Alt-F).

Help button

Displays Intellihance online help.

Pixel Readouts

When you move your mouse over the preview image, the pointer becomes a crosshair. Move the crosshair over 
the Preview image to see the before and after pixel readouts in CMYK, RGB or GS values.

Opening options

Choose which Intellihance dialog box to display as your default dialog box.

Original tab

Click to display the Preview dialog box.

Extensis logo

Click for information about Intellihance and Technical Support.

Preference options

Intelligent Enhancement engine preference pop-up menus.



Fine Tune Dialog Box Options

OK button

Click to apply adjustments to the image (Enter).

Cancel button

Exits Intellihance with no changes (Escape).

Clear All button

Returns to the settings of the original image, before running Intellihance (Alt-L).

Reset All button

Returns to the settings in effect when the Fine Tune dialog box was selected (Alt-R).

Preferences button

Allows you to navigate directly to the Preferences dialog box from the Fine Tune dialog box.

Help button

Displays Intellihance online help.

Pixel Readouts

When you move your mouse over the preview image, the pointer becomes a crosshair. Move the crosshair over 
the Preview image to see the before and after pixel readouts in CMYK, RGB or GS values.

Tabs

Click these tabs to display controls for each filter.

Extensis logo

Click for information about Intellihance or Technical Support.



 




