Tell me about Corel Intranet Server

What is Corel Intranet Server?

Corel Intranet Server is software that turns your own computer into a web server on an internal network (usually
within a company) or intranet. Using Corel WEB.SiteBuilder, you create your web site and, with one click of a
button, you “publish” it to Corel Intranet Server. Anyone within your organization who has a working web
browser can access your web site just by knowing your computer’s name or IP address and the filename of your
initial home page. It’s never been easier to make dynamic information available!

What is the difference between an intranet and the Internet?

An intranet is an organization-wide network of computers that provides similar services to those offered on the
public Internet. For example, a company with an internal network, or intranet, can create their own internal
World Wide Web site using Corel Intranet Server. This would give their employees (locally or around the
world) easy access to information about policies, meeting schedules, job openings, departments, projects, and so
forth. An intranet is very much like the Internet but on a much smaller scale and with access limited to those
who have permission to be on the company’s internal network.

How does Corel Intranet Server Work?

Corel Intranet Server works in conjunction with Core]lWEB.SiteBuilder. You first create your site using

Corel WEB.SiteBuilder, then publish it to Corel Intranet Server. When you publish, you are displaying a list of
all the files that make up your site (including multimedia and image files) in the list box of Corel Intranet
Server. You can view this list by opening Corel Intranet Server. At this point, your site is “live,” meaning it is
now accessible by others on the internal network, just like a web site on the public Internet!

You can add Corel Intranet Server to the Startup menu so that everytime you start Windows 95, Corel Intranet
Server will also open and become minimized on your task bar. You can “shut down” your entire site by either
turning off your computer or simply closing Corel Intranet Server. However, if you want to give your users
continuous access to your site (and you have a full-time Internet connection), you will need to leave your
computer on (you can turn off your computer monitor). This may be especially important if your organization
is world-wide and there are users in different time zones. You can also close portions of your site that you no
longer want users to access. Just select and delete files in the file list box of Corel Intranet Server. The
original file remains intact on your hard drive. Corel Intranet Server also maintains a running log of how many
people visit your web site and how often.

If you have created a web site or an HTML page using another program other than Corel WEB.SiteBuilder (for
example, Corel WordPerfect 7), you can still publish it to Corel Intranet Server. Just drag a file or a folder
containing all your files from the window in Explorer or My Computer to the file list box of Corel Intranet
Server. It’s that easy!

{button ,AL("Setting up your computer as a server on an intranet; Getting Started; How does a user on an
intranet access my web site?; How to')} Related topics



Getting your site onto Corel Intranet Server

Before you can use Corel Intranet Server your computer must have TCP/IP software installed (if you can access
the Internet through a web browser, you already have TCP/IP). You will also need your computer properly set
up to act as a web server on the internal network so that others in your organization can access the site. Click
{button ,AL( Setting up your computer as a server on an intranet',1,”',"second")} for help with setting up your
own computer to act as a web server on an internal network. Once this is accomplished, you can continue with
the information below.

Publishing your web from Corel WEB.SiteBuilder
If you are using Corel WEB.SiteBuilder to create your web site, you can publish directly to Corel Intranet
Server.

When you are finished creating your web in CorelWEB.SiteBuilder, click Web > Publish.
CorelWEB.SiteBuilder will prompt you if you have not specified where you want to publish to. If this
happens, just select Corel Intranet Server from the list, then click OK. Your web is now available to your users.

Click {button ,AL("How does a user on an intranet access my web site?',1,™, second')} for information on how
users access your web site.

Publishing your web from Explorer or My Computer in Windows 95

You can publish your web just by dragging an HTML file or a folder of files from Explorer or My Computer to
the file list box of Corel Intranet Server. You can also click the Add File command from the Edit menu in Corel
Intranet Server to add a file or an entire web site.

If your entire HTML structure resides in a single folder, you can drag the folder to Corel Intranet Server. Your
initial HTML document (or home page) and all files within that folder will then be accessible by your users.

Once you drag your web to the file list box in Corel Intranet Server, it then becomes available for your users to
access.

Click {button ,AL("How does a user on an intranet access my web site?',1,”,"second')} for information on how
users access your web site.

Set program options for your Corel Intranet Server
Set program options for your Corel Intranet Server by clicking the Options command from the Tools menu.
On the Options dialog box, click the Browser tab to configure how Corel Intranet Server launches your web

browser whenever you open an HTML document (or a web page) from within the Corel Intranet Server
window.

Click the Logging tab on the Options dialog box to configure your initial Usage and Error Logs. These logs
keep track of activity on your web site.

{button ,AL("Setting up your computer as a server on an intranet; How does a user on an intranet access my
web site?')} Related topics



Print command (File menu)

Commands: Print...

Shortcuts: Ctrl+P
You can print the list of files and directories that are currently available on your Corel Intranet Server.

To print the list of files and directories:
1. From the File menu, choose the Print command.

2. Set the print options, including any changes to the printer setup, and then click the OK button.

{button ,AL("Print Setup command (File menu)')} Related topics



Print Setup command (File menu)

Commands: Print Setup...
Shortcuts: N/A
Most printers include options for choosing a default printer, paper orientation, and paper selections. However,

the options provided when you choose the Print Setup... command depend on the capabilities of your printer.
For information about these options and settings, see the documentation provided with your printer.

Printer setup options usually identify the printer that's used by default and list other printers which are available
for temporary selection.

Typically, printer setup options also let you choose the paper orientation: landscape or portrait. The landscape
setting prints information horizontally on the page. The portrait setting prints information vertically on the page.

The paper settings let you choose the paper size and the source, which is typically the print tray in which the

selected paper size is located.

To set print options:

1. From the File menu, choose the Print Setup... command.

2. Select the printer setup options and click the OK button.

{button ,AL("Print command (File menu)')} Related topics



Exit command (File menu)

Commands: Exit

Shortcuts: N/A

If you want to stop Corel Intranet Server from running on your system, you can exit the application. When
Corel Intranet Server isn't running, no activity can take place on it. You may also run other applications with

Corel Intranet Server minimized, leaving it running in the background. While Corel Intranet Server is running in
the background, all files and directories available on it can constantly be accessed.

When Corel Intranet Server is minimized, it appears next to the clock on the task bar.

To exit Corel Intranet Server:

1. From the File menu, choose the Exit command.

To minimize Corel Intranet Server and leave it running in the background:

1. From the System menu, choose the Minimize command.



Add File command (Edit menu)

Commands: Add File

Shortcuts: Insert

Adding existing HTML file(s) to Corel Intranet Server.

Generally, unless you are adding an HTML file to replace an existing HTML file on your web site, the file you
add should have a name that is unique to all the public names listed in Corel Intranet Server.

To add a file to your Corel Intranet Server:
1. From the Edit menu choose the Add File command.

2. Type the path and file name in the File name text box, then type a description of the file in the Description
text box.

{button ,AL("Getting Started; Delete command (Edit menu)')} Related topics



Delete command (Edit menu)

Commands: Delete

Shortcuts: Del

Files or directories of files that you no longer want to make available can be deleted from your Corel Intranet
Server.

To delete a file or directory of files from your Corel Intranet Server:

1. Highlight the file or directory of files on your Corel Intranet Server.

2. From the Edit menu, choose the Delete command.

{button ,AL("Add File command (Edit menu)')} Related topics



Properties command (Edit menu)

Commands: Properties

Shortcuts: N/A

The properties of each file or directory available on your Corel Intranet Server can be configured to your own
specifications.

Four tabs are located on the File Properties dialog box which will assist you in configuring these properties.

The General tab enables you to change the filename and path, the public name, and the description of the
highlighted file. The General tab also informs you how many times the highlighted file has been accessed and
enables you to reset this number to zero.

The Advanced tab enables you to define the MIME content type of the highlighted file and to instruct Corel
Intranet Server to parse the Web page, corresponding to the highlighted file, for Corel Intranet Server’s HTML
tags. The latter will default to the appropriate setting.

The Security tab enables you to specify which computers can access the highlighted file. You may want to make
a specific file accessible to only certain computers.

The Links tab enables you to see how many hits the highlighted file has received and from which links (URLs).
A hit only shows up in the links list if it’s from another page which contains a link to the hit page (or highlighted
file).

To access the File Properties dialog box:

1. Highlight a file or directory of files in your Corel Intranet Server.

2. From the Edit menu, choose the Properties command.

{button ,AL("Advanced tab (File Properties dialog box);General tab (File Properties dialog box);Links tab
(File Properties dialog box);Security tab (File Properties dialog box)')} Related topics



Usage Log command (View menu)

Commands: Usage Log
Shortcuts: N/A

All activity on your Corel Intranet Server is recorded in a Usage Log.

To see a record of the current Usage Log:
1. From the View menu, choose the Usage Log command.

{button ,AL("Clear Usage Log command (Tools menu); Error Log command (View menu)')} Related topics



Error Log command (View menu)

Commands: Error Log

Shortcuts: N/A

All errors that occur during the use of the files on your Corel Intranet Server are recorded in an Error Log.

To see a record of the current Error Log:
1. From the View menu, choose the Error Log command.

{button ,AL("Clear Error Log command (Tools menu);Usage Log command (View menu)')} Related topics



Status Bar command (View menu)

Commands: Status Bar

Shortcuts: N/A

You can choose to disable the Status Bar on the Corel Intranet Server screen.

To disable the Status Bar:
1. From the View menu, choose the Status Bar command.



Clear Usage Log command (Tools menu)

Commands: Clear Usage Log
Shortcuts: N/A

The current Usage Log can be cleared of entries if desired.

To clear the Usage Log:
1. From the Tools menu, choose the Clear Usage Log command.

{button ,AL("Usage Log command (View menu)')} Related topics



Clear Error Log command (Tools menu)

Commands: Clear Error Log

Shortcuts: N/A

The current Error Log can be cleared of entries if desired.

To clear the Error Log:
1. From the Tools menu, choose the Clear Error Log command.

{button ,AL("Error Log command (View menu)')} Related topics



Options command (Tools menu)

Commands: Options...
Shortcuts: N/A
The Options command brings up a dialog box with two tabs that enable you to configure program options.

The Browser tab enables you to configure how Corel Intranet Server launches your Web browser whenever you
open an HTML document (or a Web Page) from within the Corel Intranet Server window.

The Logging tab enables you to configure your Usage and Error Logs.

To access the Options dialog box:

1. From the Tools menu, choose the Options... command.

{button ,AL("Options dialog box')} Related topics



Contents command (Help menu)

Commands: Contents

Shortcuts: N/A

Choosing the Contents command displays a list of topics available in this Help file.



About command (Help menu)

Commands: About

Shortcuts: N/A

The About command displays version information about Corel Intranet Server.

To display the version of Corel Intranet Server that you’re using:
1. From the Help menu, choose the About command.



Using Help command (Help menu)

Commands: Using Help
Shortcuts: N/A
If you require help performing any function in Corel Intranet Server, extensive on-line help is included in the

software. If you're unsure of the operation of any menu command or the procedure for a specific function, the
on-line Help in Corel Intranet Server can probably help you.

Method of accessing Type of information provided
Help
Help menu Choosing Contents from the Help menu

displays the Help file's table of contents and
allows you to access the Help file's Index and
full text search. Use the Help menu for
overviews and explanations of procedures.

F1 Key Provides help on the currently selected
object. For example, if you select a menu
command and press F1, information on the
use of the selected command is displayed.

Shift+F1 Keys Provides a context-sensitive help cursor (Show
cursor). For example, you can press Shift+F1
and click a list box to view an explanation of
that list box.

Right mouse click Provides information on the selected object.
For example: right click the mouse on a
check box and choose What's This? from the
menu to view an explanation of that check
box.

Help button Provides an overview of the current dialog
box or window.

Status bar Provides a short description of the menu
command you have currently selected.

You can browse through this Help file to become familiar with the help features available in Corel Intranet
Server.

To open the online Corel Intranet Server Help files:

1. From the Help menu, choose the Contents command or press the F1 key.

To display Help for a specific command:
1. Highlight the command.
2. Press the F1 key.

To display Help for a specific dialog box:
1. Press the Help button on the dialog box.



To display Help for window elements such as buttons and list boxes:

1. Press the Shift and F1 keys at the same time and then click the element.



Applies any changes you've made in the File Properties dialog box to the current session. The File Properties dialog box remains open.



Activates on-line Help for Corel Intranet Server.



Enables you to configure the Usage Log.



Enables you specify a location to store your Usage Log.



Enables you to search for a specific location to store your Log file.



Enables the Usage Log to include the host names with all entries.



Enables the Usage Log to have multi-line entries with full headers.



Enables the Usage Log to display all access denied messages.



Enables you to specify a location to store your Error Log.



Enables to specify a location to store your Error Log.



Enables you to search for a location to store your Log file.



Keyboard Short-cuts

Function Keyboard
Short-cut
Delete Page Del

{button ,AL("Dele
te command (Edit
menu)")}

Print Ctrl+pP
{button ,AL( Print

command (File

menu)")}

Add Page Insert
{button ,AL("Add

File command

(Edit menu)")}

Help F1
{button ,AL("Usin
g Help command
(Help menu)")}

Shift+F1

Context Sensitive
Help



Minimize reduces the window to an icon beside the clock on the task bar. This action occurs when you either
choose the Minimize command from the System menu or click the button that’s furthest to the left in the upper
right corner of the window.



Maximize increases the window to the size of your screen. This action occurs when you either choose the
Maximize command from the System menu or click the middle button in the upper right corner of the window.



Size allows you to drag a border on the window to resize it.



Close shuts down the window.



Restore returns the window to its original size.



Move allows you to drag the window to a new location.



Switch To displays the Task List from which you can activate another application.



Caption bar displays the name of the current directory contents and pane.



Scroll bars advance the information in the current panel.



System menu is activated by clicking the Corel Intranet Server icon in the upper left corner of the Corel
Intranet Server window. It contains commands which enable you to restore, move, size, minimize, maximize,
and close the Corel Intranet Server window.



About

The About Corel Intranet Server dialog box displays version information about Corel Intranet Server.



Add File dialog box

Enables you to add files to Corel Intranet Server.

File name text box enables you to type the file name and path of the file that you’re adding to Corel Intranet
Server.

Description text box enables you to type a description of the file you're adding.

OK button exits from the Add File dialog box and adds the file to your Web server. Click here after you’ve
provided a path and filename, and a description of the file.

Cancel button cancels any changes you’ve made and closes the Add File dialog box.



Enables you to add a file or a directory of files to your Corel Intranet Server.



Type the file name and path of the file that you’re adding to your Corel Intranet Server.



Type the name you want your file to be referred to by the outside world.



Type a description of the file you're adding.



Click here once you’ve provided a filename and path, a public name, and a description of the file.



Cancels any changes that you’ve made and closes the dialog box.



Options dialog box

The Options dialog box allows you to configure Corel Intranet Server's application options.

Browser tab enables you to configure how Corel Intranet Server launches your Web browser whenever you
open an HTML document (or a Web page) from within the Corel Intranet Server window.

Logging tab enables you to configure your Usage and Error Logs.
Help button displays this Help page.
OK button accepts your changes to this dialog box and returns to the Corel Intranet Server main window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Corel Intranet Server
main window.

{button ,AL("Browser tab (Options dialog box);Logging tab (Options dialog box)')} Related topics



Enables you to configure program options.



Applies any changes you’ve made in the Options dialog box to the current session. The Options dialog box remains open.



Displays the Options dialog box Help page.



Accepts your changes to the Options dialog box and returns to the Corel Intranet Server main window.



Cancels any changes you’ve made, exits the dialog box, and returns to the Corel Intranet Server main window.



Browser tab (Options dialog box)

Enables you to configure how Corel Intranet Server launches your Web browser whenever you open an HTML
document (or a Web page) from within the Corel Intranet Server window.

Launch URL button sends the URL of the Web page directly to the Windows 95 operating system. Windows
95 then launches your Web browser and locates the selected Web page.

Launch Program button instructs Corel Intranet Server to launch your Web browser whenever you open an
HTML document (or a Web page) from within the Corel Intranet Server window.

Path text box specifies the path to your Web browser application.

Browse button enables you to view the folders on any drives that are available to your system to make it easier
to locate your Web browser.

Help button displays this Help page.
OK button accepts your changes to this dialog box and returns to the Corel Intranet Server main window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Corel Intranet Server
main window.



Enables you to configure how Corel Intranet Server launches your Web browser whenever you open a Web page from within the Corel
Intranet Server window.



Sends the URL of the Web page directly to the Windows 95 operating system. Windows 95 then launches your Web browser and locates the
selected Web page.



Instructs Corel Intranet Server to launch your Web browser whenever you open a Web page from within the Corel Intranet Server window.



Specifies the path and executable name of your Web browser application.



Enables you to view the folders on any drives that are available to your system to make it easier to locate your Web browser.



Logging tab (Options dialog box)

Enables you to configure the Usage and Error Logs.

Usage Log group enables you to configure your Usage Log.

Log File name text box enables you to specify a location to store your Usage Log.

Browse button enables you to search for a location to store your Log file.

Include host names in log check box enables the Usage Log to include the host names with all entries.

Multi-line log entries with full headers check box enables the Usage Log to have multi-line entries with full
headers.

Log access denied messages check box enables the Usage Log to display all access denied messages.
Error Log group enables you to specify a location to store your Error Log.

Error log name text box enables you to specify a location to store your Error Log.

Browse button enables you to search for a location to store your Log file.

Help button displays this Help page.

OK button accepts your changes to this dialog box and returns to the Corel Intranet Server main window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Corel Intranet Server
main window.



Enables you to configure the Usage and Error Logs.



Enables you to configure your Usage Log.



Enables you to specify a location to store your Usage Log.



Enables you to view the folders on your system to help you search for a specific location for your Log file.



Specifies whether you want the names of the active hosts to be included in the log file. Including the host names may slow down
performance significantly.



Enables the Usage Log to have multi-line entries with full headers. Allowing multi-line entries with full headers may slow down
performance significantly.



Enables the Usage Log to display all access denied messages. Enabling the display of all access denied messages may slow down
performance significantly.



Enables you to specify the location of your Error Log.



Enables you to specify the location of your Error Log.



Enables you to view the folders on your system to help you search for a specific location for your Log file.



File Properties dialog box

Enables you to configure the properties of any file or directory on your Corel Intranet Server.

General tab enables you to change the filename and path, the public name, and the description of the
highlighted file. The General tab also informs you how many times the highlighted file has been accessed and
enables you to reset this number to zero.

Advanced tab enables you to define the MIME content type of the highlighted file and to instruct Corel Intranet
Server to parse the Web page, corresponding to the highlighted file, for Corel Intranet Server’s HTML tags. The
latter will default to the appropriate setting.

Security tab enables you to specify which computers can access the highlighted file. You may want to make a
specific file accessible to only certain computers.

Links tab enables you to see how many hits the highlighted file has received and from which links (URLs). A
hit only shows up in the links list if it’s from another page which contains a link to the hit page (or highlighted
file).

Help button displays this Help page.
OK button accepts your changes to this dialog box and returns to the Corel Intranet Server main window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Corel Intranet Server
main window.

{button ,AL("Advanced tab (File Properties dialog box);General tab (File Properties dialog box);Links tab
(File Properties dialog box);Security tab (File Properties dialog box)')} Related topics



Enables you to configure the properties of any file or directory on your Corel Intranet Server.



Applies any changes you’ve made in the File Properties dialog box to the current session. The File Properties dialog box remains open.



Displays the File Properties dialog box Help page.



Accepts your changes to the File Properties dialog box and returns to the Corel Intranet Server main window.



Cancels any changes you’ve made, exits the dialog box, and returns to the Corel Intranet Server main window.



General tab (File Properties dialog box)

The General tab enables you to change the filename and path, the public name, and the description of the
highlighted file. It also informs you how many times the highlighted file has been accessed and enables you to
reset this number to zero.

File name text box enables you to specify the file name and path of the file you want to make available to the
outside world.

Public name text box enables you to specify the name that you want your file to be referred to by the outside
world.

Description text box enables you to provide a more detailed description of the file you identified in the File
name text box.

Access counter keeps track of the number of times a file on your Corel Intranet Server has been accessed by the
outside world.

Reset button resets the Access counter to zero.
Help button displays this Help page.
OK button accepts your changes to this dialog box and returns to the Corel Intranet Server main window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Corel Intranet Server
main window.



Enables you to change the file name and path, the public name, and the description of the highlighted file. It also informs you how many
times the highlighted file has been accessed and enables you to reset this number to zero.



Specifies the path and file name of the file you want to make available to the outside world.



Specifies the name that you want your file to be referred to by the outside world.



Provides a more detailed description of the file you identified in the File name text box.



Keeps track of the number of times a file on your Corel Intranet Server has been accessed by the outside world.



Resets the Access counter to zero.



Advanced tab (File Properties dialog box)

Enables you to define the MIME content type of the highlighted file and to instruct Corel Intranet Server to
parse the Web page, corresponding to the highlighted file, for Corel Intranet Server’s HTML tags. The latter will
default to the appropriate setting.

MIME Content Type text box enables you to define the MIME content type of the highlighted file. You only
need to specify the MIME type if it isn't automatically detected by Corel Intranet Server.

Parse page for <counter> and <include> tags check box enables you to instruct Corel Intranet Server to parse
the Web page, corresponding to the highlighted file, for Corel Intranet Server’s HTML tags.

The <counter> tag in an HTML document will be replaced with a number representing the page’s hit count. For
example, if you had in one of your document’s “This page has been visited <counter> times.” the user might see
“This page has been visited 452 times.”

The <include> tag lets the user insert a separate file into an HTML document. For example:
Here is your autoexec.bat file:
<samp><pre><include c:\autoexec.bat></pre></samp>
And here is your config.sys file:
<samp><pre><include c:\config.sys></pre></samp>

The filename in the include tag will be sent with no processing done on it’s contents (ie. it cannot include
another <include> tag or a counter).

By default this Parse page for <counter> and <include> tags check box will be on for HTML or HTM
documents and off for all other files. Therefore, it should rarely have to be adjusted.

Help button displays this Help page.
OK button accepts your changes to this dialog box and returns to the Corel Intranet Server main window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Corel Intranet Server
main window.



Enables you to define the MIME content type of the highlighted file and to instruct Corel Intranet Server to parse the Web page,
corresponding to the highlighted file, for Corel Intranet Server’s HTML tags. The latter will default to the appropriate setting.



Enables you to define the MIME content type of the highlighted file. You only need to specify the MIME type if it isn't automatically
detected by Corel Intranet Server.



Enables you to instruct Corel Intranet Server to parse the Web page, corresponding to the highlighted file, for Corel Intranet Server’s HTML
tags.

The <counter> tag in an HTML document will be replaced with a number representing the page’s hit count. For example, if you had in one
of your document’s “This page has been visited <counter> times.” the user might see “This page has been visited 452 times.”

The <include> tag lets the user insert a separate file into an HTML document. For example:
Here is your autoexec.bat file:
<samp><pre><include c:\autoexec.bat></pre></samp>
And here is your config.sys file:
<samp><pre><include c:\config.sys></pre></samp>

The filename in the include tag will be sent with no processing done on it’s contents (ie. it cannot include another <include> tag or a
counter).

By default this setting will be on for HTML or HTM documents and off for all other files. Therefore, it should rarely have to be adjusted.



Security tab (File Properties dialog box)

Enables you to specify which computers can access the highlighted file. You may want to make a specific file
accessible to only certain computers.

No Security button enables you to allow access by all machines to the highlighted file.

Restrict Access button enables you to specify which machines can have access to the highlighted file.

Access list box enables you to view the names of the specific machines that have access to the highlighted file.
Add button enables you to add the name of a machine to the Access list box.

Remove button enables you to remove the name of a machine from the Access list box.

Alternate page text box enables you to designate an alternate Web page to display to those machines that are
denied access to the Web page that's represented by the highlighted file. i.e. You could designate an alternate
Web page that you’ve created that displays the message “You can’t access this file!”.

Help button displays this Help page.
OK button accepts your changes to this dialog box and returns to the Corel Intranet Server main window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Corel Intranet Server
main window.



Enables you to specify which computers can access the highlighted file. You may want to make a specific file accessible to only certain
computers.



Enables you to allow access by all machines to the highlighted file.



Enables you to specify which machines can have access to the highlighted file.



Enables you to view the names of the specific machines that have access to the highlighted file.



Enables you to add the name of a machine to the Access list box.



Enables you to remove the name of a machine from the Access list box.



Enables you to designate an alternate page to display to those machines that are denied access to the page that's represented by the
highlighted file. i.e. You could designate an alternate Web page that you’ve created that displays the message “You can’t access this file!”.



Links tab (File Properties dialog box)

Enables you to see how many hits the highlighted file has received and from which links (URLs). A hit only
shows up in the links list if it’s from another page which contains a link to the hit page (or highlighted file).

Pages with links to this page list box enables you to see how many hits the highlighted file has received and
from which links (URLSs). A hit only shows up in the links list if it’s from another page which contains a link to
the hit page (or highlighted file).

Clear List button enables you to clear the Pages with links to this page list box.
Help button displays this Help page.
OK button accepts your changes to this dialog box and returns to the Corel Intranet Server main window.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the Corel Intranet Server
main window.



Enables you to see how many hits the highlighted file has received and from which links (URLs). A hit only shows up in the links list if it’s
from another page which contains a link to the hit page (or highlighted file).



Enables you to see how many hits the highlighted file has received and from which links (URLs). A hit only shows up in the links list if it’s
from another page which contains a link to the hit page (or highlighted file).



Enables you to clear the Pages with links to this page list box.



Add new site to access list dialog box

Enables you to add the name of a machine to the Access list box to give it access to the highlighted file.

Name or address of machine text box enables you to enter the name or address of the machine that you would
like to add to the Access list.

OK button accepts your changes to this dialog box and returns to the File Properties dialog box.

Cancel button cancels any changes you’ve made, exits the dialog box, and returns to the File Properties dialog
box.



Enables you to add the name of a machine to the Access list box to give it access to the highlighted file.



Enables you to enter the name or address of the machine that you would like to add to the Access list.



Accepts your changes to this dialog box and returns to the File Properties dialog box.



Cancels any changes you’ve made, exits the dialog box, and returns to the File Properties dialog box.



Setting up your computer as a server on an intranet

You may need to make some changes to your operating system for your computer to operate as a web server on
an internal network, or intranet. The steps below can help you accomplish this.

Typically, most organizations and companies that have access to the Internet also have firewalls. A firewall
prevents outside intruders from gaining access to servers and directories on the internal network of a company.
Generally, if your company has a firewall set up (check with your System Administrator), when you publish
your web site to Corel Intranet Server, only those who have access to the internal network of your company will
have access to your web site.

To configure TCP/IP for an internal server

IMPORTANT: If you are set up with an assigned IP address by your System Administrator, complete the steps
below. If you are set up to obtain an IP address automatically using Dynamic Host Configuration Protocol
(DHCP) for WINS Resolution, you should follow the steps below under To find your IP Address. Contact your
System Administrator if you have questions concerning the assignment of an IP address.

In Windows 95, click Start > Settings > Control Panel.

Double-click Network.

Click the Configuration tab.

Double-click TCP/IP in the list box, then click the WINS Configuration tab.
Click Enable WINS Resolution.

o ok W

Check with your system administrator to make sure that you have the proper Primary and Secondary WINS
Server addresses. These two addresses are usually composed of four numbers each, separated by periods. For
example: 120.1.20.100.

7. Click the DNS Configuration tab.
8. Click Enable DNS.

9. In the Domain text box, type the network domain that you access. Check with your System Administrator if
you're unsure of your system's domain.

10. Click the OK button on the TCP/IP Properties dialog box.
11. Click the OK button on the Network dialog box.

To find your IP address:

1. Click the Start button.

2. Choose Run from the menu.

3. In the Run dialog box, type WINIPCFG.
4

The IP Address box contains the address that your users will type in their own browser (along with the
filename of your web) to access your web site as found on Corel Intranet Server.

For example, if your IP address was 10.100.51.185 and the filename of your web site was index.htm, your users
would type 10.100.51.185/index.htm in the Location text box of their browser.

To confirm your IP address:

1. Click the Start button.

2. Choose the Programs menu.

3. From the Programs menu, choose the MS DOS prompt.

4. At the DOS prompt, type PING followed by a space and your IP Address (for example, PING 10.100.51.185).



If your IP address is found, you'll receive replies from the network. If it isn't found, you'll receive an error.
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How does a user on an intranet access my web site?

Once you've set up your computer as a server and published your web site to Corel Intranet Server, anyone on
the intranet, who also has TCP/IP, can now access your site. They just need to know either your computer’s
name or its IP address and the filename of your site, as in the following:

- If your computer is accessible by its name, a user would type [your computer name]/[filename] in the

Location text box of their web browser. For example, the path a user would type might appear like this:
skippy/index.htm. In Windows 95, the computer name is set in the Network Neighborhood Properties under the
Identification tab.

or

. The user would type [ip address]/[filename] in the Location text box of their web browser. For example,

the path a user would type might appear like this: 10.100.51.185/index.htm.
Try testing the access to your own web site to make sure it looks and functions the way you want it to. Start a
web browser, type the name of your computer or your IP address followed by a forward slash, then type the
filename of your initial home page.

Leave your computer on with Corel Intranet Server running

If you want your users to have continuous, 24-hour access to your web site, you should leave your computer on
(you can turn off your monitor, however) and Corel Intranet Server running. Minimize Corel Intranet Server if
you have other tasks to perform. The minimized Corel Intranet Server is represented by an icon on the task bar.

Periodically maximize Corel Intranet Server by double-clicking the appropriate icon on the task bar. Check
your Usage Log for activity by selecting the Usage Log command from the View menu. Remove access to
files by selecting and deleting them from the Corel Intranet Server file list box. The original file will remain
intact on your hard drive.
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Multimedia Internet Mail Extensions (MIME)

MIME is a naming convention for data file types that you're going to provide access to over the Internet.
Whenever you send data other than text, you must specify its MIME type so the data is managed properly
during transmission and when its received. MIME types are stored in the Windows 95 registry.



Uniform Resource Locator (URL) is a unique address that identifies a Web page. Every page on the Web has a
unique URL in the same way that all humans have unique fingerprints. If an application sends a URL to the
Windows 95 operating system, Windows 95 launches the Web browser that you have on your system and goes
to the page specified by the URL.



Corel Home Page

For the latest information on Corel Intranet Server, CorelWEB.SiteBuilder and other Internet/intranet-related
tools, contact the Corel home page at http://www.corel.com . In Corel Intranet Server, you can click Help >
Corel Home Page to launch your web browser and go to the Corel home page.



How to...

System configuration

Configure TCP/IP for an internal server
Confirm your IP address

Find your IP address

Using Corel Intranet Server

Access the File Properties dialog box

Access the Options dialog box

Add a file or directory of files to your Corel Intranet Server
Delete a file or directory of files from your Corel Intranet Server
Disable the Status Bar

Exit Corel Intranet Server

Minimize Corel Intranet Server and leave it running in the background
Print the list of files and directories

Set print options

Error logging

Clear the Error Log

Clear the Usage Log

See a record of the current Error Log
See a record of the current Usage Log

Help

Display Help for a specific command
Display Help for a specific dialog box

Display Help for window elements such as buttons and list boxes
Display the version of Corel Intranet Server that you’re using
Open the online Corel Intranet Server Help files







