
Help is available for each item in this group. Click        at the top of the dialog box, and then click the specific item you want 

information about.



Lists the available columns that can be added to your message list.



Lists the columns currently displayed in your message list and the order in which they appear.



Moves the selected column from the Available Columns list to the Displayed Columns list.



Moves the selected column from the Displayed Columns list to the Available Columns list.



Moves the selected column up one in the Displayed Columns list.



Moves the selected column down one in the Displayed Columns list.



Restores the columns to the settings originally displayed when Internet Mail and News was first installed.



Lists the available news servers. For information about how to add news servers to or remove news servers from your server list, 

look up "Adding news servers" in the Help Index.



Specifies that the list should display all newsgroups that contain the word you type here.



Lists the newsgroups available on the selected server. You can narrow this list to newsgroups that contain a specific word in the 

name or description. In addition, you can click the tabs to display all of the newsgroups available on the selected server or just 

the subscribed or new newsgroups available.



Specifies whether to limit the list of newsgroups to newsgroup names that contain the word you are searching for. If this box is 

checked, the list of newsgroups also includes newsgroups whose descriptions contain the word you are searching for. 



Opens the newsgroup selected in the Newsgroups list.



Adds the selected newsgroup to your Subscribed list. 



Removes the selected newsgroup from your Subscribed list.



Checks for new newsgroups on your server. If there are new newsgroups, Internet News downloads their names and 

descriptions, if descriptions are available.



Specifies whether to download the chosen number of messages when viewing a newsgroup or to download all messages in the 

newsgroup.



Specifies whether to display threads and all replies in the message list when you open a newsgroup. If you clear this check box, 

only the original message is displayed.



Specifies whether to mark a message as read after you have previewed it for the number of seconds indicated. If you clear this 

check box, you can still mark individual messages as read. For more information, look up "Marking messages as read" in the 

Help Index.



Specifies whether to check your news server for new messages and send messages from your Outbox at the interval of minutes 

indicated. If you clear this check box, you can still check for new messages and send messages from your Outbox in Internet 

News by clicking the View menu and then clicking Refresh.



Specifies whether to check for new newsgroups and download their names and descriptions when you start Internet News. If any 

are found, you can view the list of new newsgroups. If you clear this check box, you can still check for newsgroups by clicking 

the Newsgroup menu and then clicking Check For New Newsgroups.



Specifies whether to mark all messages as read when you exit a newsgroup. If you clear this check box, you can still mark 

individual messages as read. For more information, look up "Marking messages as read" in the Help Index.



Specifies whether to display the body of a message in the preview pane whenever the header is selected in the message list. If 

you clear this check box, you can display the message body by selecting the header and then pressing the SPACEBAR.



Specifies whether to use Internet News whenever you click a link on a Web page to go to a newsgroup or choose the News 

command in your Web browser. If you clear this check box, then your browser does not use Internet News, and you must install 

another newsreader to view newsgroups from your browser.



Specifies whether when you want to save copies of the messages you post to newsgroups in the Posted Messages folder. If you 

clear this check box, you can still save a copy of a message by including yourself on the Cc line of the message.



Specifies whether to automatically select whole words when selecting text in the body of your message. If you clear this check 

box, you can select text one character at a time, and you can automatically select whole words by double-clicking a word and 

extending the selection word by word.



Specifies whether to include the text of the original message when you reply to a message. You can edit or cut any of this text. If 

you clear this check box, the body of your message contains only the text you type or paste.



Specifies whether to indent the beginning of each line of original text included in your reply, preceded by the character indicated. 

This distinguishes the text you type from the text in the original message. If you clear this check box, then the original text and 

the text you add appear the same.



Click this to select advanced settings for sending messages, specifying message format and line length, and sending messages 

immediately.



Specifies whether a copy of each message you send is saved in the Sent Items folder. If you clear this check box, you can still 

save a copy of an individual message by including yourself on the To or Cc line of the message.



Specifies whether to use Internet Mail whenever you send e-mail replies to the author of a newsgroup message. If you clear this 

check box, then your browser does not use Internet Mail, and you must install another e-mail program to send messages.



Click this to select advanced settings for sending messages, including specifying the character set, message format, and line 

length, and sending messages immediately.



Specifies whether to use a different international character set than the default character set associated with your Regional 

Settings in Control Panel. If you clear this check box, Internet News uses the default character set.



Specifies that Internet Mail or News should encode your messages using MIME. This is the common format used by most 

Internet mail programs. 



Specifies that Internet Mail or News should encode your messages using Uuencode. This format is commonly used to send 

binary files as attachments in messages posted to newsgroups.



Specifies that Internet Mail or News should break up large messages, so that each part is smaller than the file size indicated. 

Some older servers on the Internet cannot handle messages larger than 64K. By breaking large messages into smaller 

messages, you ensure that the messages are transmitted and received correctly. 



Specifies that Internet Mail or News should automatically wrap the text of outgoing messages so that each line is no more than 

the number of characters indicated. Some older servers on the Internet cannot properly display messages with lines over 80 

characters long. If you clear this check box, your message might appear to have extra line breaks to recipients whose mail or 

newsreading program can display only 80 characters per line.

It is suggested that you set your limit to about 72 characters. Most mail and newsreading programs indent quoted text in replies 

or forwards. Setting the limit to 72 allows the message to be quoted several times without causing extra line breaks.



Specifies whether Internet Mail should immediately forward to your mail server any messages you send. If you clear this check 

box, messages you send are placed in your Outbox and are not sent until you click the Mail menu and then click Send And 

Receive Mail.



Lists the available bit and binary formats for encoding your message.



Specifies the "friendly" name associated with your e-mail address. When you send e-mail or post messages to a newsgroup, this 

friendly name appears in the From field of your outgoing messages.



Specifies your group or organization.



Specifies the e-mail address that people should use when sending mail to you at this account. The e-mail address must be in the 

format name@company—for example, PatSmith@acme.com.



Specifies in outgoing messages a different return e-mail address for replies to your messages. Provides a space where you can 

type the return e-mail address.

For example, you might send messages through one e-mail account, JRS@company.com, and specify to send replies to 

JRSmith@MSN.COM. When a recipient replies to messages from JRS@company.com, the reply is sent to 

JRSmith@MSN.COM, not to the account you sent it from.

If you do not specify anything in this box, replies to your mail are sent to the e-mail account you send them from.



Lists the available news servers.



Click this to add a new news server.



Removes the selected news server from your news-server list.



Click this to change the properties for the news server selected in your news-server list.



Specifies the server, and provides a space where you can type the server name.



Specifies that this news server requires that you log on for access, and transmits your logon settings to this server.



Provides a space for you to type the password assigned to your account on this news server by your service provider. The actual 

characters are not displayed in this box—each character is represented by an asterisk (*) instead, for security purposes.



Sets this news server as your default news server. When you add, remove, or search for newsgroups, or check for new 

newsgroups, this is the news server Internet News selects by default. However, if you have more than one news server, you can 

choose a different one in the Newsgroups dialog box.



Specifies the port number you connect to on your news server. This port number is usually 119.



Specifies how long Internet News waits for a response from this server before it cancels downloading newsgroups or newsgroup 

messages. 

If you have a fast connection to your server, move the slider toward Short.

If you have a slow connection or a busy server, move the slider toward Long to give the server enough time to respond.



Restores the server port numbers to their default settings.



Specifies that Internet News should include descriptions of newsgroups when downloading the newsgroup list or new newsgroup 

names from this server. If this news server carries a large number of newsgroups, clearing this check box reduces the time 

needed to download the newsgroup list or new newsgroup names. Not all newsgroups have descriptions.



Downloads the newsgroup descriptions from your server.



Specifies that you connect to this server by using a LAN connection.



Specifies that you manually connect to this server before you access mail messages or newsgroups.



Specifies that you connect to this server by using Dial-Up Networking.



Lists the Dial-Up Networking connections already set up on your computer.



Displays the settings for the selected Dial-Up Networking connection.



Click this to create a new Dial-Up Networking connection.



Displays how your text appears in outgoing messages. Recipients whose servers or e-mail programs do not support text 

formatting see the text displayed on their computers as plain text.



Displays how text appears in messages you receive as unformatted text. 



Displays how text appears in the original text included in your reply. Recipients whose servers or e-mail programs do not support 

text formatting see the text displayed on their computers as plain text.



Changes the font characteristics, such as font, font style, size, and color. 



Specifies whether to show suggested spellings for misspelled words found during a spelling check. If you clear this check box, 

Internet News displays misspelled words, but it does not suggest correct spellings. However, you can still type the correct 

spelling in the box.



Specifies that Internet News should check the spelling in messages you send and give you a chance to change, ignore, or 

correct any misspelled words.



Specifies whether to ignore words in uppercase letters. This is useful when the text you are sending contains computer 

programming code, which is often in uppercase letters and uses character combinations that do not form identifiable words. If 

you clear this check box, Internet News checks words in uppercase for misspelling. 



Specifies whether to ignore words that contain numbers. If you clear this check box, Internet News checks words that contain 

numbers for misspelling.



Specifies whether to ignore misspelled words in the original text included in a reply or forward. If you clear this check box, 

Internet News checks the original text, in addition to your own, for misspelled words.



Specifies that no signature should be added to your messages.



Specifies that a text file should be used as a signature in your outgoing messages.



Specifies that you want to insert the contents of a text file as your signature. You can type the path and filename to the file you 

want to use, or you can click the Browse button and locate the file.



Specifies whether to add your signature to all outgoing messages. If you clear this check box, outgoing messages do not contain 

your signature unless you add it to an individual message.



Specifies whether to add your signature to all outgoing messages except replies or forwards. If you clear this check box, 

outgoing messages do not contain your signature.



Displays a possible error, such as a misspelled word, a duplicate word, or incorrect capitalization. The word is highlighted in the 

message, so you can see it in the context in which it is used.



Proposes a replacement for the word displayed in the Not In Dictionary box.

To replace the word that is displayed in the Not In Dictionary box, accept the word in the Change To box, type the correct word in 

the Change To box, or select a word in the Suggestions list.

To delete the word in the document, delete the text in the Change To box, and then click Delete. To delete all instances of the 

word in the document, click Delete All.



Lists suggested replacement words from your dictionary when you click Suggest or if you have selected the Always Suggest 

check box on the Spelling tab. 



Specifies the rules that Internet News uses to check spelling.



Reverses the most recent actions made during the spelling check. You can undo several changes by clicking Undo Last several 

times.



Leaves the word in the Not In Dictionary text box unchanged.



Changes the word in the Not In Dictionary text box to the word in the Change To text box.

If the Change To text box is empty, the button name changes to Delete. Click Delete to delete the selected word.



Adds the word in the Not In Dictionary text box to the Internet News dictionary.



Closes this dialog box without saving any changes you've made.



Leaves all instances of the word in the Not In Dictionary text box unchanged in your message.



Changes all instances in this message of the word in the Not In Dictionary text box to the word in the Change To box.



Displays a list of proposed alternatives for a misspelled word.



Specifies whether you want your computer to play a sound when new messages arrive when you are running Internet Mail. If you 

clear this check box, you do not hear any sound when new messages arrive, but the Internet Mail status bar and message list 

indicate that you have unread messages.



Specifies whether a message should be marked as read after you have previewed it for the number of seconds indicated. If you 

clear this check box, messages are not marked as read unless you open the message in a message window, scroll the message 

in the preview pane, or select the message in the list, click the Edit menu, and then click Mark As Read.



Specifies whether to check your mail server for new messages at the interval of minutes indicated. It also sends any messages 

in the Outbox at the same time. If you clear this check box, you can check for new messages only by clicking the Mail menu and 

then clicking Send And Receive Mail. 



Specifies whether Internet Mail should permanently delete messages from the Deleted Items folder when you quit Internet Mail. 

If you clear this check box, deleted messages stay in the Deleted Items folder until you open that folder, select the messages, 

and then delete them.



Specifies whether you want to save copies of the messages you send in the Sent Items folder. If you clear this check box, you 

can still save a copy of a message by including yourself on the To or Cc line of the message.



Specifies whether to use Internet Mail whenever you click a link in a Web page to send an e-mail message, or choose the Mail 

command in your Web browser.



Specifies your SMTP server for outgoing messages, or you can type a different server name. 



Specifies your server for incoming messages, or you can type a different server name. 



Specifies your account name. This is usually the same as the part of your e-mail address to the left of the at sign (@). 



Provides a space for you to type the password assigned to you by your service provider. For security, the actual characters are 

not displayed in this space; each character is represented by an asterisk (*).



Click this to select advanced settings for your mail servers.



Specifies the port number you connect to on your outgoing mail (SMTP) server. This port number is usually 25. 



Specifies the port number you connect to on your incoming mail (POP3) server. This port number is usually 110.



Specifies that messages over a certain size are not downloaded from your incoming mail (POP3) server. This can be useful if 

you want to avoid long connection times. When messages over the size limit are encountered, Internet Mail leaves them on the 

server and displays a warning that messages have been left on the server.



Specifies whether Internet Mail should store on your server a copy of all sent and received messages. If your Internet service 

provider does not allow you to save messages on the server, Internet Mail displays a message that you cannot store messages 

on the server.

If you clear this check box, incoming messages are deleted from your server after you receive them on your computer. Outgoing 

messages are not saved on your server, but they are saved on your computer if you have selected that option. To specify that all 

outgoing messages should be saved on your computer, click the Message menu, click Options, click the Send tab, and then 

select the following check box: Save Copy Of Sent Messages In The 'Sent Items' Folder.



Specifies whether Internet Mail should delete messages left on the server after the number of days indicated. 

Some service providers limit the number of messages you can store on the server, or do not allow you to save messages on the 

server. If you clear this check box, your server might automatically remove messages after a certain period of time or when you 

exceed your limit.



Specifies that Internet Mail should delete a message from the server when you delete the message from the Deleted Items folder 

on your computer. Some service providers limit the number of messages you can store on the server, or do not allow you to save 

messages on the server.



Specifies that you want replies to your outgoing messages sent to a different e-mail address, and provides a space for you to 

type the return e-mail address.

For example, you might send messages through one e-mail account, JRS@company.com, and specify that you want replies sent 

to JRSmith@MSN.COM. When a recipient replies to a message from JRS@company.com, the reply is sent to 

JRSmith@MSN.COM, not to the account the original message was sent from.

If you do not specify otherwise, replies to your e-mail messages are sent to the e-mail account you send them from.



Specifies how long Internet Mail waits for a response from the server before it cancels sending or receiving mail messages. 

If you have a fast connection to your server, move the slider toward Short.

If you have a slow connection or a busy server, move the slider toward Long to give the server enough time to respond.



Restores the server port numbers to their default settings.



Specifies that Internet Mail or News should send your messages with HTML format.



Specifies that Internet Mail or News should send your messages as plain text, with no formatting.



Click this to specify format settings for message encoding.



Click this to start Internet News in the newsgroup selected in the list. If this check box is cleared, Internet New starts in the 

newsgroup you were viewing when you last used Internet News.



Specifies that foreign character sets, high ASCII, or double-byte character sets (DBCS) are allowed in the header without 

encoding. If this check box is cleared, these characters will be encoded.



Specifies your account name. This is usually the same as the part of your e-mail address to the left of the at sign (@). 



Specifies that this news server requires Microsoft Secure Authentication to verify your access with this server.



Specifies that Internet news should delete all newsgroup messages from local storage on your computer after they have been on 

your computer longer than the number of days indicated.



Specifies that Internet News should delete all read newsgroup messages from local storage on your computer when you exit 

Internet News.



Specifies that Internet News should compact local storage files on your computer when the amount of wasted space exceeds the 

percent indicated.



Click this to compact, delete, or remove messages from the local files for any or all of the newsgroup message files on your 

computer. 



Welcome to Internet Mail

With an Internet connection and Microsoft Internet Mail, you can exchange e-mail messages with anyone on the Internet. 

Internet Mail fully supports Internet standards, including SMTP/POP3 and MIME.



Internet Mail features

Microsoft Internet Mail is fast, friendly, and easy to use. Here are a few of the features that make sending and receiving 

messages easy and fun.

    Do everything from the main 
window

    Save e-mail addresses in your 
address book, and insert them into 
messages

    Browse your messages quickly 
and easily

    Create your own folders to 
organize your messages

    Sort the message list
    Add your personal signature to 

your messages

Save e-mail addresses in your address book, and insert them into messages

You can save first names, last names, and Internet e-mail names in the address book. After they're entered, you can insert them 

into messages. You can also check e-mail names to make sure they are in your address book or are valid e-mail addresses.



Do everything from the main window 

You can view and respond to messages and switch folders all from the Internet Mail window. With just a click on the toolbar, you 

can reply to, forward, or create new messages. Or use the toolbar to navigate among messages and folders. All of these 

commands and more are also available from the menus.



Browse your messages quickly and easily 

The message list and preview pane enable you to view a list of messages and preview the messages at the same time in one 

window.

Or, if you prefer, you can view a message in a separate window, and use its toolbar to go to the next or previous message.



Create your own folders to organize your messages 

You can add folders to organize and sort your messages. After you receive messages, you can move them to any folder you 

want.



Sort the message list 

You can sort messages by columns, such as by the subject, who sent it, or when it was received or sent. You can also add, 

remove, or rearrange these columns, and sort them in ascending or descending order.



Add your personal signature to your messages

You can insert text or a text file as your personal signature. 

And you can choose to insert your signature in all outgoing messages, in an individual message, or not at all.



Using keyboard shortcuts for Internet Mail

You can use shortcut keys to choose commands and navigate through the preview pane and the message list.

Mail: main window, view message window, and send message window

To do this Press this

Open help topics F1

Select All CTRL+A

Mail: main window and view message window 

To do this Press this

Print the selected 

message

CTRL+P

Send and receive mail CTRL+M

Delete a message DEL or CTRL+D

Open a new message CTRL+N

Reply to the author CTRL+R 

Forward a message CTRL+F

Reply to all CTRL+SHIFT+R

Go to your Inbox CTRL+I

Go to the next message in 

the list

CTRL+> or CTRL+SHIFT+> or 

ALT+RIGHT ARROW

Go to the previous 

message in the list

CTRL+< or CTRL+SHIFT+< or 

ALT+LEFT ARROW

View the properties of the 

selected message

ALT+ENTER

Mail main window

To do this Press this

Open the selected 

message

CTRL+O or ENTER

Mark a message as read CTRL+SPACEBAR

Move between the 

message list, folder list (if 

the icon bar is on), and the 

preview pane

TAB

Mail message window — viewing or sending

To do this Press this

Close a message ESC

Find text F3 or CTRL+SHIFT+F

Mail message window — sending only

To do this Press this

Check names CTRL+K or ALT+K

Check spelling F7

Send a message CTRL+ENTER or ALT+S



Getting started with Internet Mail

If you are new to e-mail or Internet Mail, here's a quick look at how to get from installing Internet Mail to receiving, viewing, and 

sending e-mail. You may already have completed part of this process when you installed Internet Mail. The steps listed below are 

explained in separate procedures in Internet Mail Help.

Set up your Internet connections

Before you can send and receive e-mail you must have access to the Internet through an Internet service provider or through an 

Internet gateway in your organization. After you have an Internet connection, you can set up specific Internet Mail settings. 

Usually, you connect to the Internet in one of the following ways:
Over phone lines, using a modem. You can manually establish a connection, or you can use Dial-Up Networking to 

automatically connect when you start Internet Mail. Your Internet service provider can provide you with the phone number, modem 
settings, and network protocols required to access the provider.

Through a local area network (LAN). Your organization might provide external access to the Internet from your computer 
through a LAN. Your system administrator can provide you with account information and network protocols to access the mail 
servers.

Add mail servers 

You will need the mail server names, your account name, and password. You must specify an incoming and an outgoing mail 

server. This information is provided to you by your Internet service provider, or by your system administrator if you are using 

Internet News on a LAN. There are two ways to specify this information:
In the Internet Mail Configuration Wizard, the first time you start Internet Mail after installing it. 
In Internet Mail, through the Options command on the Mail menu. Click the Server tab to add or change settings for mail 

servers and account information.

Read messages

When you start Internet Mail, it connects to your mail server, logs on to your e-mail account, and downloads any new messages 

into your Inbox folder. Besides your Inbox folder, Internet Mail includes several other Mail folders, and also enables you to create 

your own. You can organize your messages by moving them to other folders or deleting them.

Messages are stored on your computer; in addition, there is an option to store copies of your messages on your mail server. 

Note that all mail servers do not support this option; for more information, contact your Internet service provider or system 

administrator. 

Send messages

You can create new messages, or forward or reply to messages you've received. Internet Mail includes an address book, so that 

you can store and select from e-mail names of people you communicate with regularly. When you send a message, Internet Mail 

checks all of the names in the To and Cc boxes to make sure they match contacts in your address book or that they are properly 

formatted Internet e-mail names. Internet Mail can also check your spelling if you have Microsoft Office 95 or Word 95 installed 

on your computer.

Customize Internet Mail 
Create shortcuts to start Internet Mail from wherever you want—your desktop, the Start menu, a program group, or your 

StartUp group. 
Arrange the window the way you want. Show or hide the icon bar, toolbar, or status bar. Align the icon bar to the top or left 

side of the window. Hide the preview pane, resize it, or split it vertically or horizontally.
Sort messages by sender, date, or subject. 



Identifying Internet Mail message list icons

The following icons indicate whether messages have files attached, are marked as read or unread, and their priority.

This icon Indicates

The message has one or more files attached.

The message has been marked high priority by 
the sender.

The message has been marked low priority by 
the sender.

The message has been read. The heading 
appears in light type.

The message has not been read. The heading 
appears in bold type.



To view a newsgroup you have subscribed to

1 On the News menu, click Newsgroups. 

2 If a News Servers list appears, click a server.

3 On the Subscribed tab, click a newsgroup, and then click Go To.

Tip 
You can also click the newsgroups list in the Toolbar. 

{button ,AL("a_nwspr_viewing_unsubscribed_newsgroups;")} Related Topics



To view a newsgroup without subscribing to it

1 On the News menu, click Newsgroups.

2 If a News Servers list is displayed, click a server.

3 On the All tab, click a newsgroup, and then click Go To.

Tip 
To subscribe to the newsgroup you are viewing, click the News menu, and then click Subscribe To This Group. 

{button ,AL("a_nwspr_subscribing_newsgroups")} Related Topics



To subscribe to a newsgroup

1 On the News menu, click Newsgroups.

2 If a News Servers list is displayed, click a server.

3 Click the newsgroup that you want to subscribe to, and then click Subscribe.

To cancel your subscription to a newsgroup, click the newsgroup, and then click Unsubscribe.

Tips
To search for newsgroups that contain a specific word in the name, type the word in the Display Newsgroups Which 

Contain box. You can also search for that same word in the newsgroups' descriptions by selecting the Also Search Descriptions 
check box.

If you cannot find a specific newsgroup in the list, your news server might not carry that newsgroup. 

{button ,AL("a_nwspr_viewing_unsubscribed_newsgroups")} Related Topics



To post a reply to a newsgroup

1 In the message list, click the message you want to reply to.

2 On the News menu, click Reply To Newsgroup.

3 In the Newsgroups box, type the names of any other newsgroups on the same server you want to post the reply to, separating 

each name with a semicolon (;).

4 Type the subject of your message. Internet News will not post a message that does not contain a subject.

5 Type your message.

6 On the File menu, click Post Message.

Tips

You can reply with a single message to multiple newsgroups only if all newsgroups are on the same news server. To post 
a reply to newsgroups on other news servers, create a separate reply for each news server that contains newsgroups you want to 
post to.

To select additional newsgroups to post to, click the News menu, and then click Choose Newsgroups. Click a newsgroup 
in the list, and then click Add. You can choose from all newsgroups or only newsgroups you subscribe to.

To send a copy of the posted message to the original author of the message, type the author's e-mail name in the Cc box.
To see more options for posting replies, click the News menu, click Options, and then click the Send tab.



To post a new message to a newsgroup

1 On the News menu, click New Message To Newsgroup.

2 In the Newsgroups box, type the names of any other groups you want to post the message to, separating each name with a 

semicolon (;).

3 Type the subject of your message. Internet News will not post a message that does not contain a subject.

4 Type your message.

5 On the File menu, click Post Message.

Tips

You can post a single message to multiple newsgroups only if all newsgroups are on the same news server. To post a 
message to newsgroups on other news servers, create a separate message for each news server containing newsgroups you want 
to post to.

To select additional newsgroups to post to, click the News menu, and then click Choose Newsgroups. Click a newsgroup 
in the list, and then click Add. You can choose from all newsgroups or only newsgroups you subscribe to.

To send a copy of the posted message by e-mail, type the recipient's e-mail name in the Cc box.
To see more options for posting replies, click the News menu, click Options, and then click the Send tab.

{button ,AL("a_nwspr_posting_replies;a_nwspr_reply_by_mail")} Related Topics



To reply by mail to the author

1 In the message list, click the message you want to reply to.

2 On the Mail or News menu, click Reply To Author. 

To send the message to other individuals, type the e-mail name of each recipient in the To or Cc box, separating each name 

with a semicolon (;).

3 Type your message.

4 On the File menu, click Send Message.

Tips
To select a name from your Internet Mail address book, click the Mail menu, and then click Choose Recipients.
You can also insert a name in the To box by selecting it in the Address Book and then double-clicking it.
To see more options for replying to messages, click the Mail or News menu, click Options, and then click the Send tab.

{button ,AL("a_nwspr_posting_replies;a_nwspr_reply_by_mail")} Related Topics



To forward a message

1 Open or select the message you want to forward.

2 On the Mail or News menu, click Forward.

3 Type the e-mail name of each recipient, separating each name with a semicolon (;).

4 Type your message.

5 On the File menu, click Send Message.

Note
To deliver outgoing messages and check for new messages immediately, click the Mail menu, and then click Send And 

Receive Mail.



To sort messages

On the View menu, point to Sort By, and then click the column heading you want to sort by. 

To switch between ascending and descending sort order, click the View menu, point to Sort By, and then click Ascending or 

Descending.

Tip
You can also change the sort order by clicking the column heading you want to sort by. To switch between ascending and 

descending sort order, click the column heading again.

{button ,AL("a_nwspr_add_remove_columns;a_nwspr_view_threads")} Related Topics



To add or remove columns in the message list

1 On the View menu, click Columns.

2 To add a column, click the column name in the Available Columns list, and then click Add.

To remove a column, click the column name in the Displayed Columns list, and then click Remove.

To change the order in which columns appear, click a column name, and then click Move Up or Move Down.

{button ,AL("a_nwspr_sort_newsgroup_articles")} Related Topics



To view messages by thread

1 On the View menu, point to Sort By, and then select Group Messages By Thread.

2 If you want the message list to display the first message in a thread and all replies to it, select the first message, and then on 

the View menu, click Expand.

If you want the message list to display only the original message in a thread, select the first message, and then on the View 

menu, click Collapse.

Tips
To expand or collapse all threads in the message list, click the Edit menu, and then click Select All. On the View menu, 

click Expand or Collapse.
To display threads expanded in all newsgroups, click the News menu, click Options, and then click the Read tab. Select 

the Auto Expand Conversation Threads check box.
You can also expand or collapse individual threads by clicking the plus (+) or minus (-) sign next to the original message.
For more information about the message list icons and keyboards commands for navigating threads in the message list, 

click Related Topics below.

{button ,AL("A_NEWS_HOTKEYS;A_NEWS_MESSLIST_ICONS")} Related Topics



A thread is an original message and any posted replies. Threads are sorted and grouped according to the original title. For 

example, a thread that starts with a message titled "Please do not post binaries in this newsgroup" includes all of the replies titled 

"RE: Please do not post binaries in this newsgroup."

If you reply to a message and change the title, you start a new thread. For example, posting a reply titled "Let’s end this thread: 

Please do not post binaries in this newsgroup," starts a new thread.



To change the priority of an outgoing message

In the message window, click the Mail menu, point to Set Priority, and then click High, Normal, or Low.

Notes
This setting changes the priority only for the current message.
You cannot assign a priority to a message posted to a newsgroup.

{button ,AL("a_nwspr_reply_by_mail;a_plsml_sending_messages ")} Related Topics



To change the fonts used to display messages

1 On the Mail or News menu, click Options.

2 On the Fonts tab, click the Change button, and then change the settings.



To delete a message

1 In the message list, click the message you want to delete.

2 On the File menu, click Delete.

Notes
To undo deleting a message, open the Deleted Items folder, and then copy the message to the Inbox or other folder.
If you don’t want messages saved in the Deleted Items folder when you quit Internet Mail, click the Mail menu, click 

Options, and then click the Read tab. Select the following check box: Empty The ‘Deleted Items’ Folder Upon Exiting.

{button ,AL("a_plsml_delete_folder")} Related Topics



To add a news server

1 On the News menu, click Options.

2 On the Server tab, click Add.

3 Type the news server name.

4 If required by your Internet service provider or system administrator, select the This Server Requires Me To Logon check box, 

and then type the account name and password.

Tip
To display or change the properties for an existing news server, on the Server tab double-click the name of the news 

server.

{button ,AL("a_nwspr_subscribing_newsgroups")} Related Topics



To save copies of outgoing Mail messages

1 In an outgoing message window, click the Mail menu, and then click Options.

2 On the Send tab, select the following check box: Save Copy Of Sent Messages In The ‘Sent Items’ Folder.

Tips
You cannot delete the Sent Items folder.
If you want to save a copy of only the current message, type your e-mail name in the Cc box.



A cache is a file on your computer that stores the headers and messages for a newsgroup or the list of newsgroups on a news 

server. Each news server you add and each newsgroup you view or subscribe to has its own cache file. Every time you 

reconnect to a newsgroup, most of its information already resides in the cache file on your computer. The only information that 

has to be downloaded is new messages and headings, which speeds up the time it takes to access a newsgroup. Over time, a 

cache file can become quite large, so you occasionally need to delete the cache file for a particular group. For more information, 

look up “cache, purging” in the Help Index.



To automatically mark messages as read

1 On the Mail or News menu, click Options.

2 On the Read tab, select the following check box: Message Is Read After Being Previewed For x Second(s).

Tips
To mark an individual message as read, click the Edit menu, and then click Mark As Read.
To mark a read message as unread, click the Edit menu, and then click Mark As Unread.
To mark a thread as read in Internet News, click on any message in the thread, click the Edit menu, and then click Mark 

Thread As Read. 
To mark all messages as read when you quit Internet News or go to another newsgroup, select the following check box: 

Mark All As Read When Exiting A Newsgroup.

{button ,AL("A_NEWS_VIEW_UNREAD_ONLY")} Related Topics



To view only unread newsgroup messages

On the View menu, click Unread Messages Only.

{button ,AL("a_nwspr_auto_mark")} Related Topics



To view message header information in the preview pane

On the View menu, point to Preview Pane, and then click Header Information.

Tip
To view all the information about a message, such as when it was sent, click the File menu, click Properties, and then click 

the Details tab. 



To move or copy a message to another folder

1 In the message list, click the message you want to move or copy.

2 On the Mail menu, click Move To or Copy To, and then click the folder. 



To customize the Internet Mail or News window

To adjust the area for the preview pane and message list, drag the divider between the preview pane and the message 
list. 

To hide the toolbar, status bar, or icon bar, click the View menu, and then click the command to clear the check mark for each 

item you don’t want to appear.

To hide the header information, click the View menu, point to Preview Pane, and then click Header to clear the check mark.

{button ,AL("a_nwspr_display_preview_pane;a_nwspr_add_remove_columns ")} Related Topics



To display the message list and contents at the same time

On the View menu, point to Preview Pane, and then click Split Vertically or Split Horizontally.

Tip
To display or run an attachment from the preview pane, click the file attachment icon in the preview pane header, and then 

click the file name(s).

{button ,AL("a_nwspr_customize_display")} Related Topics



Internet News Troubleshooter

This troubleshooter helps you identify and solve problems related to using Internet News. Just click to answer the questions, and 

then try the suggested steps to fix the problem.

What's wrong?
                 When I start Internet News, it does not connect to my Internet provider.  
                 My modem doesn't seem to be working.  
                 My modem's fine, but I can't seem to make a connection with my provider.  
                 I can connect to my provider, but I can't get any newsgroups or mail.  
                 I get an error message that there's a news connection error on a specific server. I can connect to some news servers, but   
not all.
                 I get an error message that there's a news connection error on a specific server, but I cannot connect to any news   
servers.



Check the following, and then try connecting to the news server again

There might be a problem with one or more of the settings for the news servers you cannot connect to. These settings are given 

to you by your Internet service provider.

Check the settings for the news server

1 On the News menu, click Options.

2 On the Server tab, click a news server, and then click Properties.

3 On the General tab, check the following:
Does the news server name match the name given to you by your Internet service provider?
Does your Internet service provider require a logon account name and password?
If you are required to log on for this news server, check that the account name and password you have entered match 

those issued to you by your provider.
If you are not required to log on for this news server, clear the following check box: This Server Requires Me To Logon.

4 Click OK to close the dialog boxes.

5 On the News menu, click Newsgroups, and try connecting to this server.

6 Repeat this procedure for each news server that you cannot connect to.

Did this fix the problem?
                 Yes. Close the troubleshooter.  
                 No. I want to try other troubleshooter options.  
                 No. What else could be wrong?  



Contact your Internet service provider

You have encountered a problem that cannot be solved by using the Internet News Troubleshooter. The connection settings or 

account information provided to you by your Internet service provider may be incorrect, or the Internet service provider's servers 

or software may not be working properly.



Check the following, and then try connecting to the news server again

There might be a problem with one or more of the advanced settings for your news servers. These settings are given to you by 

your Internet service provider.

Check the server advanced settings

1 On the News menu, click Options.

2 On the Server tab, click a News Server, and then click Properties.

3 On the Advanced tab, check the following:
Does the port number match the number issued to you by your Internet service provider?
Most Internet service providers use port 119.
Is the server timeout set to Short?
Some servers may take longer to make a connection. To allow more time for your computer to make the connection, move 

the slider toward High.

4 Click OK to close the dialog boxes.

5 On the News menu, click Newsgroups, and then try connecting to a news server.

Did this fix the problem?
                 Yes. Close the troubleshooter.  
                 No. I want to try other troubleshooter options.  
                 No. What else could be wrong?  



Check how you are connecting to your Internet service provider

Try one of the following steps:
Establish the connection to your Internet service provider manually before attempting to download or view newsgroups.
In My Computer, double-click the Dial-Up Networking icon, and then set up Dial-Up Networking. If the icon does not 

appear in My Computer, Dial-Up Networking is not installed on your computer. For instructions on installing it, look up "Add/Remove 
Programs" in Windows Help. 

If Dial-Up Networking is installed but you are having problems with it, look up "Dial-Up Networking" in Windows Help. 

Did this fix the problem?
                 Yes. Close the troubleshooter.  
                 No. I want to try other troubleshooter options.  
                 No. What else could be wrong?  



Check your server settings

1 In Internet News, click the News menu, and then click Options. 

2 Click the Server tab, and then check the settings against those given to you by your service provider. 

If everything looks fine, contact your service provider to verify that you have the correct settings and that their servers are 

operating correctly. 

Did this fix the problem?
                 Yes. Close the troubleshooter.  
                 No. I want to try other troubleshooter options.  



To automatically wrap text in outgoing messages

1 On the Mail or News menu, click Options.

2 On the Send tab, click the Settings button next to Plain Text.

3 Select the following check box: Automatically Wrap Text At x Characters.

4 Type the maximum number of characters to display per line.

Notes
This setting is only needed for messages sent with plain text format. 
Some servers do not display more than 80 characters per line. If you send messages with more than 80 characters per 

line, your message might not appear correctly to others viewing your message.
When messages are quoted in a reply, the original text is usually marked and indented with an additional character. If your 

message is likely to be quoted after posting, set your text to wrap at 70 or 72 characters per line.



To send outgoing messages immediately

1 On the Mail menu, click Options.

2 On the Send tab, click Advanced Settings.

3 Select the Send Messages Immediately check box. 

When you click the File menu and then click Send Message, Internet Mail immediately sends any messages in your Outbox to 

your mail server, and checks for incoming messages.

Tip
If you don't want messages sent immediately, clear this check box. That way, in the outgoing message when you click the 

File menu and then click Send Message, Internet Mail stores messages in your Outbox until you choose the Send and Receive 
command, or you quit Internet Mail.



To use Internet Mail when sending messages from your Web browser

1 On the Mail menu, click Options.

2 On the Send tab, click Set As Default.

When you click a link in a Web page to send an e-mail message, or choose the Mail command in your Web browser, the 

browser will use Internet Mail.



To use Internet News from your Web browser

1 On the News menu, click Options.

2 On the Read tab, select the following check box: Make Microsoft Internet News Your Default News Reader.

When you click a link on a Web page that opens a newsgroup, or choose the Newsreader command in your Web browser, the 

browser will use Internet News.



Setting Internet News to use Internet Mail for e-mail replies and forwards

1 Open Internet Mail.

2 On the Mail menu, click Options.

3 On the Send tab, select the following check box: Use Microsoft Internet Mail, By Default, To Send Messages From Your Web 

Browser.

Note
When you reply to author, forward a posting, or enter an e-mail name on the Cc line of a newsgroup posting, then Internet 

News will use Internet Mail.
When you click a link in a Web page to send an e-mail message, or choose the Mail command in your Web browser, the 

browser will use Internet Mail.



To view a file attachment

1 Select the message in the message list, click the File menu, and then click Open.

2 At the bottom of the message window, double-click the file attachment you want to open or run.

Tips
To save a file attachment, click the File menu, and then click Save Attachments.
To display or run an attachment from the preview pane, click the file attachment icon in the preview pane header, and then 

click the file name(s). To save the attachment from the preview pane, hold down the CTRL key while clicking the file name.

{button ,AL("A_NEWS_COMBINENDECODE")} Related Topics



To post large messages or files

1 Open a new message, or a reply to a newsgroup message.

2 On the News menu, click Options.

3 On the Send tab, click Advanced Settings.

4 Select the format for encoding.

5 Select the following check box: Break Apart Messages Larger Than x KB.

6. Click OK to close the dialog boxes.

7 On the Insert menu, click Attachment.



Encoding enables you to send large messages, and messages or files that are not plain text.

Most mail servers limit the size of individual messages that can be received and sent. Usually this limit is 1 MB per message, 

including all attached files. When you encode a large message, it is compressed, divided into several smaller messages, and 

sent. When the group of messages is received, they can be recombined and decoded by the newsreader or mail program. When 

you set this option, messages are automatically broken up and encoded before being sent.

Messages and file attachments that are not plain text are encoded and converted to plain text before they are sent. When they 

are received, they are decoded to their original form. 



To decode messages

1 In the message list, select the message(s) you want to decode. To select more than one message at a time, hold down the 

CTRL key while you click each message.

2 On the News menu, click Combine And Decode.

3 In the Decode Order list, drag the messages into the correct order, and then click OK.

Note

{bmc bullet.bmp] The order of the messages is usually specified in the subject line. For example, 1/x. 2/x, 3/x, and so on. The 

phrasing varies, depending on the program the author used to post the messages. Arrange the messages from first to last, 

starting with first at the top of the list.



To switch between Internet Mail and Internet News

To run Internet Mail and Internet News in separate windows, click the Start button, point to Programs, and then point to 
Internet Mail or Internet News. Or, if you have shortcuts to these programs on your desktop, double-click each icon.



To delete a folder 

On the File menu, point to Folder, point to Delete, and then click the folder you want to delete.

Note
You cannot delete or rename the Deleted Items, Inbox, Outbox, or Sent Items folders.



To insert your signature into all outgoing messages

1 On the News or Mail menu, click Options.

2 On the Signature tab, click Text, and then type the text you want to appear at the bottom of your message. 

3 Click Add Signature To The End Of All Outgoing Messages.

Tips
When setting this from the Mail menu, this affects new mail, forwards, and replies to authors. When setting this from the 

News menu, this affects only messages posted to newsgroups.
You can also insert the contents of a text file as your signature.
If you choose not to insert your signature in all outgoing messages, you can still insert it in an individual message by 

clicking the Insert menu in an outgoing message and then clicking Signature.



To check the spelling in an outgoing message

On the Mail or News menu in an outgoing message, click Check Spelling. 

Notes
To check the spelling in all outgoing messages, click the Mail or News menu, click Options, and then click the Send tab. 

Select the following check box: Always Check Spelling Before Sending.
If you do not have any Microsoft Office 95 programs installed on your computer, the Check Spelling command will not be 

available. Microsoft Internet Mail and News uses the spelling checker provided with all Office 95 programs — Microsoft Word, Excel, 
and PowerPoint. 



To add a contact or distribution list to your address book

1 On the File menu, click Address Book.

2 In the Address Book window, click New Contact or New Group, and then type the contact's first name, last name, and e-mail 

name.

Tips
You can also add the author of an e-mail or newsgroup message to your address book. Open the message, right-click the 

name, and then click Add To Address Book.
To display the properties for the sender or other recipients, open the message in a separate window, and then double-click 

the name.



To edit a contact in your address book 

1 In Internet Mail, click the File menu, and then click Address Book.

2 Locate the name you want in the address book list, and then double-click it to display information about the contact.

3 Modify the information as needed. 

Tip
To delete a contact, select the contact in the address book list, and then click Delete.



To send a message to a contact from your address book 

1 In an outgoing message window, click the Mail menu, and then click Choose Recipients.

2 Select the name you want, and then click To or Cc.

Tip
You can also insert a name in the To box by selecting it in the address book list and then double-clicking it.



To make sure e-mail names and address book contacts are valid

In an outgoing message, click the Mail menu, and then click Check Names.

If a name matches an address book entry, or is in the correct format for an e-mail name (name@company), then it is a valid e-

mail name and it is underlined. Note that this does not mean the e-mail name actually exists. You can type an e-mail name 

with the correct format, and it will be validated even if the name does not actually exist.

If a name is not a valid e-mail name, then the name and any possible matches are displayed. You can click Show More 

Names to search for other names or add new ones to your address book.

Tip
To add verified e-mail names to your address book, right-click the name, and then click Add To Address Book.



To print a message

1 Select the message in the message list.

2 On the File menu, click Print.



To prevent messages from automatically downloading

1 On the News menu, click Options.

2 On the Read tab, clear the following check box: Automatically Show Message In Preview Pane.

Tip
You can view a message in the preview pane by pressing the SPACEBAR after selecting a message from the list.



To increase disk space by deleting cached messages

1 On the News menu, click Options.

2 On the Advanced tab, select the options you want for maintaining the size of all local message files.

To compact, delete, or remove messages from all or specific message files now, click Clean Up Now, and follow the directions 

on your screen.

Notes
Most news servers periodically remove old messages and headers. The next time you connect to a newsgroup you've 

purged, your cache is rebuilt with just the current messages and headers from your news server.
Each newsgroup has its own cache file on your computer. Purging unused, old, or large newsgroups can significantly 

increase free disk space on your computer. 



To increase disk space by compacting Internet Mail message folders

In Internet Mail, click the File menu, point to Folders, point to Compact, and then click a folder name.

Tips
You can also delete folders to increase free disk space on your computer.
If you are using a program other than Microsoft Internet Mail to send e-mail messages from Internet News, check that 

program's documentation for information about compacting and deleting mail folders.



A header is the row of information about a message that is displayed in the message list and above the message in a message 

window. The header contains information about the item, such as the sender, the subject, the newsgroups it is posted to, and the 

time and date the message was received or sent.



To send a message

1 On the Mail menu, click New Message.

2 In the To box, type the e-mail name of each recipient, separating each name with a semicolon (;).

To send copies, type the e-mail name of each recipient in the Cc box, separating each name with a semicolon.

3 In the Subject box, type the subject of the message.

4 Type your message.

5 On the File menu, click Send Message. 

Your e-mail is delivered to your mail server the next time Internet Mail checks for new mail.

Tips
To send a file with your message, click the Insert menu, click File Attachment, and then double-click the file you want to 

send.
To check for new messages and deliver outgoing messages immediately, click the Mail menu, and then click Send and 

Receive Mail.

{button ,AL("a_nwspr_change_priority;A_MAIL_SEND_IMMEDIATELY;a_nwspr_save_sent_items;A_WAB_INSERTING_CONTA

CTS_INTO_MESSAGE_NEWS;A_NEWS_CHECK_SPELL;WAB_RESOLVE_NAMES_NEWS;")} Related Topics



To automatically check for new messages

1 On the Mail menu, click Options.

2 On the Read tab, select the following check box: Check For New Mail Every x Minutes.

3 Specify how often you want Internet Mail to check for new messages.

Tips
When this check box is selected, Internet Mail also checks for new messages whenever you start the program.
To check for messages immediately, click the Mail menu, and then click Send And Receive Mail.



To change your mail server

1 On the Mail menu, click Options, and then click the Servers tab.

2 In the Full Name box, type your name.

3 In the Account box, type your e-mail name.

4 In the SMTP and POP3 Server boxes, type your server name. Usually these entries are the same.

5 Type the password assigned to your account.



To read your messages

To view the message in a separate window, double-click the message in the message list.

To view the message in the preview pane, click the message in the message list.

Tips
 To display the preview pane, click the View menu, point to Preview Pane, and then click Split Vertically or Split 

Horizontally.
To display or run an attachment from the preview pane, click the file attachment icon in the preview pane header 

information, and then click the filename.
To display the properties for the sender or other recipients, open the message in a separate window, and then double-click 

the name.

{button ,AL("a_plsml_sort_messages;a_plsml_check_new_messages")} Related Topics



To add a folder

1 On the File menu, point to Folder, and then click Create.

2 In the New Folder Name box, type the name.

Note
You cannot delete the Deleted Items, Sent Items, Inbox, or Outbox folders.



To switch to another folder

1 On the View menu, make sure Icon Bar is selected.

2 Click the folder name or the down button in the folder list, and then click a folder name.



Internet Mail Troubleshooter

This troubleshooter helps you identify and solve problems related to using Internet Mail. Just click to answer the questions, and 

then try the suggested steps to fix the problem.

What's wrong?
                 When I start Internet Mail, it does not connect to my Internet service provider.  
                 My modem doesn't seem to be working.  
                 My modem's fine, but I can't seem to connect to my provider.  
                 I can connect to my provider, but I can't send or receive e-mail.  



Check how you are connecting to your Internet provider

Try one of the following steps:
Establish the connection to your Internet service provider manually before attempting to view or download messages.
In My Computer, double-click the Dial-Up Networking icon, and then set up Dial-Up Networking. If the icon does not 

appear in My Computer, Dial-Up Networking is not installed on your computer. For more information about installing it, look up 
"Add/Remove Programs" in Windows Help. 

If Dial-Up Networking is installed but you are having problems with it, look up "Dial-Up Networking" in Windows Help.

Did this fix the problem?
                 Yes. Close the troubleshooter.  
                 No. I want to try other troubleshooter options.  



Check your server settings

1 In Internet Mail, click the Mail menu, and then click Options. 

2 Click the Server tab, and then check the settings against those given to you by your Internet service provider.

If everything looks fine, contact your provider to verify that you have the correct settings and that their servers are operating 

correctly. Also, make sure your provider or LAN server supports PPP, SMTP, and POP3.

Did this fix the problem?
                 Yes. Close the troubleshooter.  
                 No. I want to try other troubleshooter options.  



To show or hide the HTML formatting toolbar

On the View menu of the message window, click Formatting Toolbar. 

A check mark appears when the formatting toolbar is visible.

Notes
If the Formatting Toolbar command is not available, then you need to set Mail or News to use HTML when sending 

messages. For more information, click Related Topics below. 
All messages are saved in HTML format. If the recipient's mail or news program reads HTML formatting, the message 

appears as it is formatted. If the recipient's program does not read HTML formatting, the message appears as plain text with an 
HTML file attached. The recipient can view the attached file with all formatting by opening it in any Web browser. 

{button ,AL("A_MAILNEWS_TURN_ON_HTML")} Related Topics



To use HTML formatting in outgoing messages

On the Format menu, click HTML. This affects the current outgoing message only.

Notes
You can also set all outgoing messages in Internet Mail or News to use HTML. On the Mail or News menu, click Options. 

On the Send tab, click HTML. You must set this option separately for Mail and for News.
All messages are saved in HTML format. If the recipient's mail or news program reads HTML formatting, the message 

appears as it is formatted. If the recipient's program does not read HTML formatting, the message appears as plain text with an 
HTML file attached. The recipient can view the attached file with all formatting by opening it in any Web browser.

{button ,AL("A_MAILNEWS_INSERT_BULLET;A_MAILNEWS_FORMAT_FONT;A_ALIGN_FORMAT_PARAGRAPH")} Related 

Topics



HTML stands for Hypertext Markup Language, the industry-standard language for describing the contents and layout of a Web 

page. HTML is also a standard for marking and displaying rich text in Internet mail and news programs. In Microsoft Internet Mail 

and News, you can send messages with plain text or with HTML formatting.



To create a bulleted list

1 Click the point in your message where you want the bulleted list to start.

2 On the Format menu, click Bullets.

3 Type the first item in the list. When you press ENTER, another bullet is displayed on the next line. 

4 To end the bulleted list, click Bullets again.

Note
All messages are saved in HTML format. If the recipient's mail or news program reads HTML formatting, the message 

appears as it is formatted. If the recipient's program does not read HTML formatting, the message appears as plain text with an 
HTML file attached. The recipient can view the attached file with all formatting by opening it in any Web browser. 

{button ,AL("A_MAILNEWS_TURN_ON_HTML")} Related Topics



To change a font type, style, and size

1 Select the text you want to format.

2 On the Format menu, click Font.

3 Click the options you want.

Tips
To change the font for an entire message, click the Edit menu, click Select All, and then click the Format menu.
All messages are saved in HTML format. If the recipient's mail or news program reads HTML formatting, the message 

appears as it is formatted. If the recipient's program does not read HTML formatting, the message appears as plain text with an 
HTML file attached. The recipient can view the attached file with all formatting by opening it in any Web browser. 

{button ,AL("A_MAILNEWS_TURN_ON_HTML")} Related Topics



To align or center a paragraph

1 Click anywhere in the paragraph you want to format.

2 On the Format menu, point to Align, and then click the setting you want.

Tips
To change the indentation of a paragraph, click the increase or decrease indentation button on the formatting toolbar.
You can also change the alignment by clicking the left, center, or right alignment buttons on the formatting toolbar.
All messages are saved in HTML format. If the recipient's mail or news program reads HTML formatting, the message 

appears as it is formatted. If the recipient's program does not read HTML formatting, the message appears as plain text with an 
HTML file attached. The recipient can view the attached file with all formatting by opening it in any Web browser. 

{button ,AL("A_MAILNEWS_TURN_ON_HTML")} Related Topics



To download individual messages in a newsgroup 

1 In the message list, click the message you want to download.

To select more than one message for downloading, hold down the CTRL key while clicking each message.

2 On the Offline menu, click Mark Message For Download.

3 On the Offline menu, click Download And Post.

Tips
You can mark threads or individual messages in a newsgroup for downloading, so that you can view them after 

disconnecting from your service provider.
You can mark messages in several different newsgroups before choosing Download And Post, as long you are receiving 

the messages via the same connection method (same service provider or LAN connection). 
You can also mark entire newsgroups for downloading. You can download just the headers, or the headers and the body 

of the messages. For more information, click Related Topics below.

{button ,AL("a_nwspr_download_newsgroups")} Related Topics



To download all messages by subscribed newsgroup

1 On the Offline menu, click Mark Newsgroups.

2 Click All Subscribed Newsgroups or Selected Newsgroups.

To select all subscribed newsgroups on a news server, select the check box next to the news server.

To select specific newsgroups on a news server, click the plus (+) icon next to the news server name, and then click the check 

box next to each newsgroup you want to download.

3 Click Download Headers Only, or Download Entire Message.

4 When you've completed marking newsgroups to download, click the Offline menu, and then click Download And Post.

Tips
If you click Download Headers Only, you can later mark and download individual message bodies. For more information, 

click Related Topics below.
You can mark several different newsgroups before choosing Download And Post, as long you are using the same 

connection method (same service provider or LAN connection) for all. 

{button ,AL("a_nwspr_download_articles")} Related Topics



To import mail messages from Exchange folders

1 On the File menu of Internet Mail, point to Import, and then click Messages.

2 Select which e-mail client you want to import messages from.

To import all messages, click All Folders.

To import messages from individual folders, click Selected Folders. To select multiple folders, press and hold down the CTRL or 

SHIFT key while clicking folders.



To import address book entries from a Windows Messaging personal address book

1 In Internet Mail, click the File menu, point to Import, and then click Address Book.

2 Click Options, and select how you want to handle imported names that match an existing Address Book entry.

Note
Imported names may not have the local domain name in the e-mail address, so you will need to add this information 

afterward. For example, an entry like "patsmith" may be missing the local domain name, "@xyz.com." Other e-mail names that were 
outside your local domain name will already have the full Internet e-mail address. 



To export Internet Mail messages to Exchange folders

1 In Internet Mail, click the File menu, point to Export, click Messages, and then click OK.

2 To export all messages, click All Folders.

To export messages from individual folders, click Selected Folders. To select multiple folders, press and hold down the CTRL or 

SHIFT key while clicking folders.



To customize the icon bar

1 On the View menu, make sure Icon Bar is selected.

2 Right-click the icon bar, and then click Customize Toolbar.

3 To add a button to the icon bar, click the button in the Available Buttons list, and then click Add.

To remove a button, click the button name in the Toolbar Buttons list, and then click Remove.

To change the order in which buttons appear, click the button in the Toolbar Buttons list, and then click Move Up or Move 

Down. 

Tip
You can dock the icon bar to the top or the left side of the window. Right-click the icon bar, point to Align, and then click 

Top or Left.



To filter incoming messages

1 On the Mail menu, click Inbox Assistant.

2 Click Add.

3 Type the criteria you want the incoming message to match.

4 Click the folder you want the matching incoming messages moved to.

Tips
You can filter matching incoming messages to automatically go to your Deleted Items folder.
You can specify multiple rules for incoming messages.
To change the priority that messages are sorted in the list, click the up or down arrows next to the rules list to move the 

highest priority rules to the top and lowest to the bottom.
If an incoming message matches more than one rule, then it is sorted according to the first rule it matches in your list.



Welcome to Internet News

With over 10,000 newsgroups, Usenet newsgroups offer something for everyone. From hobbies to politics to computers, 

newsgroups provide forums for exchanging ideas, information, and opinions. 

You can interact with newsgroups as much or as little as you want. You can go to a newsgroup just to read what other people 

have to say, or you can post your own questions, tips, opinions, or answers. 



Getting started with Internet News

If you are new to newsreading or Internet News, here's a quick look at how to get from installing Internet News to viewing 

newsgroups. You may already have completed part of this process when you installed Internet News. Since Internet News 

enables you to set up multiple servers, you can use this list as a checklist for each time you add and use a different server. For 

specific instructions about each step of the process below, see Internet News Help.

Set up your Internet connections

Before you can view newsgroups, you must have access to the Internet, either through an Internet service provider or through an 

Internet gateway in your organization. Connect to the Internet through one of the following:
Phone lines, using a modem. You can establish a connection manually, or you can use Dial-Up Networking to connect 

automatically when you start Internet News. Your Internet service provider can provide you with the phone number, modem settings, 
and network protocols required to access the provider.

A local area network (LAN). Your organization might provide external access to the Internet from your computer through a 
LAN. For account information and the network protocols needed to access the news server, contact your system administrator.

After you have a way to connect to the Internet, you can choose specific Internet News settings.

Add a news server 

You will need the news server name, and if required by the news server, your account name and password. You can get this 

information from your Internet service provider, or from your system administrator if you are using Internet News on a LAN. You 

can specify this information in two ways:
In the Internet News Configuration Wizard, the first time you start Internet News after installing it. This wizard walks you 

through the steps necessary to add your first server.
In Internet News, by using the Options command on the News menu. Click the Server tab to add news servers or to 

change the settings for existing servers.

Subscribe to a newsgroup

You can subscribe to a newsgroup in several ways:
When you add a news server. Internet News prompts you to subscribe to newsgroups on that server. 
From the Newsgroups dialog box. To do this, click the News menu, and then click Newsgroups. You can also use this 

dialog box to go to a newsgroup without subscribing to it.
When you view a newsgroup that you don't subscribe to. To do this, click the News menu, and then click Subscribe To 

This Group. Or, when you exit the newsgroup or Internet News, click OK when you are prompted to subscribe to the newsgroup.

View a newsgroup

You can download a newsgroup and display it on your screen in several ways. The following two methods are for newsgroups 

you already subscribe to: 
Click the newsgroup name list at the top of the message list, and then click a newsgroup.
Click the News menu, point to Go To Newsgroup, point to a news server (if you have more than one), and then click a 

newsgroup. 

The last method is for any newsgroup on your news server(s), whether you subscribe to it or not:
Click the News menu, and then click Newsgroups. Click a server (if you have more than one), and then click the All, 

Subscribed, or New tab.

The first time you view a newsgroup, it takes several minutes for Internet News to download the messages and headers and to 

store that information in a cache on your computer. The next time you go to that newsgroup, it downloads faster, because 

Internet News downloads only new messages and headers.

Customize Internet News 
Create shortcuts to start Internet News from anywhere you want: your desktop, the Start menu, a program group, or your 

StartUp group. 
Arrange the window the way you want. Show or hide the icon bar, toolbar, or status bar. Align the icon bar to the top or left 

side of the window. Hide the preview pane, resize it, or split it vertically or horizontally.
Sort messages by sender, date, or subject. Group them by thread. 



Internet News features

Microsoft Internet News is fast, friendly, and easy to use. Here are a few features that make reading newsgroups easy and fun.
    Do everything from the main 

window 
    Browse newsgroup messages 

quickly and easily
    View, expand, and collapse threads
    Sort the message list
    Keep track of what you've read
    Send messages
    Add your personal signature to 

your messages
    Find newsgroups that interest you
    Subscribe to your favorite 

newsgroups
    Connect to multiple servers
    Download newsgroups now, view 

off-line later

Download newsgroup messages now, view off-line later

You can mark individual messages or entire newsgroups for downloading, so you don't have to be connected to your service 

provider to read messages. You can also just download the headers, view them off-line and then mark just the messages you 

want to download the next time you are connected.

You can also compose messages off-line, and reconnect later to send all of your messages at once. 



Do everything from the main window 

You can view threads, respond to them, switch newsgroups, and switch news servers — all from the Internet News window. With 

just a click on the toolbar, you can respond to messages or add newsgroups to your list of Favorites. Or use the toolbar to 

navigate among messages, threads, or newsgroups. All of these commands and more are also available from the menus, and 

many also have keyboard shortcuts.



Browse newsgroup messages quickly and easily 

You can view a list of messages and preview the messages all in one window by using the message list and preview pane.

Or, if you prefer, you can view a message in a separate window, and use the toolbar to go to the next or previous message.



View, expand, and collapse threads 

You can view a topic and all of the responses posted to it without having to scroll through the entire list of messages. When you 

do view the list of messages, you can expand and collapse individual threads to make it easier to look for messages or threads 

of interest. Icons in the message list make it easy to identify threads and whether they are expanded or collapsed. And you can 

easily navigate through the message list, threads, and messages with the mouse or by using keyboard shortcuts. 



Sort the message list 

You can sort messages by columns, such as by the subject, who posted it, or when it was posted. You can also add, remove, or 

rearrange these columns, and sort them in ascending or descending order.



Keep track of what you've read 

You can mark messages, threads, or entire newsgroups to show that you have read them. The next time you go to that 

newsgroup, you can see which messages you've already read, or you can set Internet News to display only unread messages. 



Send messages 

With the clearly marked and easy-to-view toolbar, it's hard to accidentally post a message to a whole newsgroup when you 

meant to send e-mail only to the author of the message. The toolbar makes it easy to post a message, reply to a newsgroup, or 

reply by e-mail to the author. You can also customize the toolbar by adding, removing, and organizing toolbar buttons.



Add your personal signature to your messages

You can add text or insert a text file. 

And you can choose to append your signature to all outgoing messages, to an individual message, or not at all.



Find newsgroups that interest you

Looking for a newsgroup that matches your work, educational, or leisure interests? You can search for newsgroups that contain 

key words in the newsgroup name or description. Or, you can browse a list of all of the newsgroups available from your Usenet 

provider. There are even newsgroups on Usenet with messages that list each newsgroup and describe its purpose. 



Subscribe to your favorite newsgroups 

When you find a newsgroup that you want to visit regularly, add it to your Subscribed list. If your interests change, or if you find 

you don't visit a newsgroup often, you can easily remove it from the list. 

And you can always go to any newsgroup available from your news servers without subscribing.



Connect to multiple servers

If your Usenet provider uses more than one news server, you can set up separate accounts and passwords for each service. 

This enables you to easily switch between newsgroups on different servers without having to reconfigure your newsreader each 

time.



Using keyboard shortcuts for Internet News

You can use shortcut keys to choose commands and navigate through the preview pane and the message list.

News: main window, view message window, and send message window

To do this Press this

Open help topics F1

Select All CTRL+A

News: main window and view message window 

To do this Press this

Print the selected 

message

CTRL+P

Refresh headers 

and articles

F5

Post a new 

message to the 

newsgroup

CTRL+N

Reply to the author CTRL+R 

Forward a message CTRL+F

Post a reply to the 

newsgroup

CTRL+G or CTRL+SHIFT+R

Go to the next 

message in the list

CTRL+> or CTRL+SHIFT+> or ALT+RIGHT 

ARROW

Go to the previous 

message in the list

CTRL+< or CTRL+SHIFT+< or ALT+LEFT 

ARROW

View the properties 

of the selected 

message

ALT+ENTER

News main window

To do this Press this

Mark all as read CTRL+SHIFT+A

Go to a newsgroup CTRL+W

Open a selected 

message

CTRL+O or ENTER

Expand a thread LEFT ARROW or PLUS SIGN

Collapse a thread RIGHT ARROW or MINUS SIGN

Fill the preview 

pane with the body 

of the selected 

message

SPACEBAR

Mark a message as 

read

CTRL+SPACEBAR

Move between the 

message list and 

the preview pane

TAB

News message window---viewing or sending



To do this Press this

Close ESC

Find Text CTRL+SHIFT+F

News message window---sending only

To do this Press this

Check names CTRL+K or ALT+K

Check spelling F7

Post a message ALT+S



Identifying Internet News message list icons

The following icons indicate whether a thread is expanded or collapsed, and whether messages and headers are marked as 

read or unread. 

This icon Indicates

This level of the thread is collapsed. Click this 

icon to expand the thread.

This level of the thread is expanded. Click this 

icon to collapse the thread.

The message has been marked read, and the 

header and body are cached. The heading 

appears in light type.

The message has been marked as read, and the 

header is cached. The heading appears in light 

type. 

The message has not been marked as read, and 

the header and body are cached. The heading 

appears in bold type.

The message has not been marked as read, and 

the header is cached. The heading appears in 

bold type.

Using Microsoft Internet Mail and News accessibility features 

In addition to Microsoft Windows, Windows NT, and Windows 95 accessibility products and services, the following features make 

Microsoft Internet Mail and News more accessible for people with disabilities:

Sound notification of new messages    In Internet Mail, you can choose to be notified about new messages with a sound. 

Resizable message and list panes    In Internet Mail and News, you can customize how messages and message lists are 

displayed. You can display messages in a preview pane, and split the window horizontally or vertically between the message list 

and the message preview. Or you can display only the message list. In any view, you can open a message from the message list 

in a separate window. 

Large and small toolbars    You can display the regular toolbar buttons, or the larger Internet toolbar or icon bar, or a 

combination of both. You can easily rearrange the Internet toolbar and icon bar to display the information and commands you 

use most. You can choose to display or hide the toolbar, Internet toolbar, or icon bar by using commands on the View menu.

Keyboard access    All features in Microsoft Internet Mail and News are accessible to you by using the keyboard or the mouse. 

Internet Mail and News supports Dvorak keyboard layouts, which make the most frequently typed characters more accessible.




