
A First Look at ASCEND 97



ASCEND 97 for Windows 95

Welcome to ASCEND 97 for Windows 95 from Franklin Quest Co. You have purchased the award-winning 
software that combines the power and convenience of your personal computer with the proven principles of the 
Franklin Day Planner system.    ASCEND 97 Personal Information Management (PIM) software helps you increase 
your productivity and achieve greater personal and professional success. ASCEND 97 software is an easy and 
effective tool to help you identify your priorities, reach your goals, and focus on what matters most.



About ASCEND 97 Backup

As with any important data, you should backup your ASCEND 97 data regularly. Creating a backup saves data 
even in the event of data loss. Remember, hard drives can fail and you don’t want to lose all of the information 
you’ve entered in your data files. A good practice for backing up is:

Back up to a diskette once or twice a week. Additionally, we strongly suggest that you back up your files before 
attempting the following procedures:

¨ Importing data into your Address and Phone book

¨ Rebuilding index data

¨ Purging data from your data files

See Also:
Creating a Backup



About ASCEND 97 Restore

The Restore feature restores data from a backup file to the ASCEND 97 data subdirectory on your hard drive. This 
is a useful command for transferring data between computers. For example, you can transfer data between the 
computer you use at work and the computer you use at home. You can run a Backup routine when you leave one 
computer and do a Restore command when you arrive at the other.

See Also:
Restoring data from a backup file



About ASCEND 97 Tools and Utilities

The Tools and Utilities program is a module that runs outside of ASCEND 97 and will not run unless ASCEND 97 
is closed. Tools and Utilities allow you to:

¨ Backup your ASCEND 97 data files. 

¨ Restore backups to your hard drive. 

¨ Purge old data and compress current data.

¨ Operate ASCEND 97 on more than one machine.

¨ Rebuild (resynchronizes index files with data files).



About Address and Phone  

ASCEND 97 Address and Phone is a powerful personal contact management tool that allows you to keep track of 
addresses, phone numbers, and notes for business contacts, relatives and friends. Using the Address and 
Address and Phone book, you can:

¨ Keep categorized lists of addresses and phone numbers.

¨ Create filters and categories.

¨ Dial (using a modem) any selected number from within ASCEND 97. ASCEND 97’s Speed Dial function is 
Microsoft TAPI compliant.

¨ Print a hard copy of your phone and address book.

¨ Address and Phone Book Tool Bar
¨ Adding an Address and Phone Entry
¨ Personal Window
¨ Address Window 
¨ Notes Window
¨ Important Dates Window 
¨ Contact Management
¨ Creating Phone Categories
¨ Assigning Phone Categories
 ̈     Editing/Deleting Phone Categories  
¨ Sorting Phone Entries With Filters
¨ Creating a New Filter
¨ Loading a Filter
¨ About Importing
¨ Importing Address and Phone Data
¨ About Exporting
¨ Exporting Address and Phone Data
¨ Setting Dialing Preferences
¨ Using the ASCEND 97 Dialing Function
¨ Printing Address and Phone Entries
¨ Printing on Labels
¨ Printing on Envelopes



About Appointment Schedule  

The Appointment Schedule is a powerful organizing tool that helps you manage your time efficiently. When you set 
an alarm you can leave ASCEND 97 running in the background and go into other programs. ASCEND 97 will find 
you in the program you are working in and remind you of your appointment. 

Besides just scheduling appointments, the ASCEND 97 Appointment Schedule lets you attach unlimited notes, set 
alarms, make appointments private and create repeat appointments. 

To open the Appointment Schedule 

¨ Click the Appointment Schedule button on the Main Tool Bar. The Appointment Schedule daily view 
appears. 

The default view is the Daily View starting at 8 a.m., but you can click the scroll buttons to view a 24-hour day. You 
can also change the Daily View to Weekly View or Monthly View. 

¨ Appointment Schedule Tool Bar
¨ Navigating with Date Buttons
¨ Creating a New Appointment
¨ Creating a Repeat Appointment
¨ Entering Appointment Notes
¨ Moving an Appointment
¨ Changing Appointment Times
¨ Adding Alarms
¨ Linking Appointments to Contacts
¨ Attaching a File to a Appointment
¨ Attaching an Object to an Appointment
¨ Weekly View
¨ Monthly View
¨ Yearly View
¨ Changing Appointment Schedule Preferences
¨ Printing Appointment Schedule



About Archiving ASCEND 97 Data

If your files become too large to manage, you can archive important information that you don’t want to delete. For 
example, you don’t want each of your backup disks to store three years worth of data. Archive your old files and 
view them in a text only format whenever you need to refer to old information.

See Also:
Archiving your ASCEND 97 Data



About Exporting
You can use the Export command to export ASCEND 97 Address and Phone data. For example, you might want to 
export your Address and Phone entries to a word-processing program. ASCEND 97 will either export Address and 
Phone entries in its own format or as an ASCII text file. When exporting, ASCEND 97 uses a filter so you can 
customize the export file to include only the data you choose.

When you create an export file, you need to choose the file format    and whether to overwrite or append to the 
existing file. If you choose to export to a file which already exists, ASCEND 97 asks if you wish to overwrite 
(replace) the existing file or if you wish to append (add to) it.

See Also:
Exporting Phone Book data



About Global Search

Global Search is a powerful tool that allows you to search for a word or a line of text within your data files. Global 
Search can search for data in many areas of ASCEND 97, including:

¨ The Prioritized Daily Task List

¨ The Appointment Schedule

¨ Daily Record of Events

¨ Favorite Quotes

¨ Journal 

¨ Address and Phone Book

¨ Red Tabs

¨ Turbo File

¨ Values and Goals 

¨ Locating Information in Global Search

¨ Additional Searching Capabilities



About Importing
In order to import information into the ASCEND 97 Address and Phone book from a text file, or export to a text file 
from the ASCEND 97 Address and Phone book, you must understand how to format your text.

You can import and export ASCEND 97 Address and Phone book information to other applications as long as the 
text is saved in one of the following file formats.

File format                                             Definition                                                                 

Comma Delimited This is the most common of the two styles and allows more flexibility in 
preparing the file. ASCEND 97 interprets comma delimited files as different 
fields separated by a comma for each field. (Some spreadsheet export 
programs use TABS to separate each field.)

Line Delimited This style assumes that each field is on a separate line. ASCEND 97 separates 
one entry from the next simply by the number of fields (in this case, the number 
of lines) associated with each entry. If an entry doesn’t have information in one 
of its fields, it is important to leave a blank line when importing.

See Also:
Importing Address and Phone Data



About Pilot Electronic Organizer

The Pilot is an electronic organizer that complements the ASCEND 97 for Windows 95 software. It is a 
revolutionary way for you to manage your personal and business data in the office or home, and on the road. 

The HotSync software and the organizer's docking cradle let you share information like tasks, addresses and 
phone numbers, appointments and notes between your Pilot and ASCEND 97.

When you use the Pilot with ASCEND 97 software, you can:

¨ Enter Data Once. 

Choose either the writing stylus, the computer keyboard, or the onscreen keypad.

¨ Access Information Instantly. 

Find tasks, appointments, address and phone entries, or any notes in your Pilot.

¨ Accomplish What Matters Most. 

Use the power of the Franklin Quest Time Management system with your Pilot.

¨ Eliminate Double Entry. 

Press the HotSync button to synchronize information between your Pilot and the ASCEND 97 software.

¨ View Your Daily Plan. 

Display your appointment schedule, task list, and notes at the touch of a button. 

¨ Store Thousands of Contacts. 

Organize your contact phone numbers and addresses.

¨ Connecting Pilot to your computer

¨ Using HotSync at your computer

¨ Changing HotSync Options

¨ Using HotSync via Modem

¨ Configuring Your Pilot

¨ Configuring Your Computer

¨ Conducting a HotSync via Modem



About Printing in ASCEND

ASCEND 97’s printing feature ensures that you’ll never be without your valuable personal information. You can 
print your task list, appointments, address and phone lists and more, directly to Franklin Day Planner pages or 
regular printer paper. You can select your Franklin size and filler for a perfect fit.

You can print information from any of ASCEND 97’s modules. You can print on any of the following Franklin Day 
Planner    binder sizes and filler types:

¨ Monarch    8 ½" x 11"

Traditional Green, Computer Edition and plain paper

¨ Classic    5 ½" x 8 ½" 

Traditional Green, Computer Edition, Seasons, Monticello, Championship Edition and plain paper

¨ Compact    4 ¼" x 6 ¾"

Traditional Green, Computer Edition, Seasons, Monticello, Championship Edition and plain paper

¨ Pocket    3 ½" x 6"

Traditional Green, plain paper

Choosing a Printer
Choosing a paper source
Selecting a binder size and filler type
Printing Address and Phone entries
Printing Appointment Schedule
Printing Daily Record of Events
Printing Journal Entries
Printing Quotes
Printing Red Tabs
Printing Your Prioritized Daily Task List
Printing Turbo Files
Printing Values and Goals
Printing Calendars
Printing on Envelopes
Printing on Labels



About Prioritized Daily Task List
The Prioritized Daily Task List helps you manage all your daily activities. Because it incorporates the Franklin Time 
Management principles to help you focus your energy on what matters most. The Task List works hand-in-hand 
with the Values and Goals module, reminding you of the values-based tasks you need to accomplish each day to 
achieve the goals you have set for yourself.

With the Prioritized Daily Task List, you can:

¨ Write and prioritize a list of tasks every day

¨ Forward tasks to a date in the future

¨ Create redo and repeat tasks for tasks you do often

¨ Wrap up your task list at the end of the day with the Group Action button

¨ Link a task to a contact in the Address and Phone book

Prioritizing is the process of organizing your tasks based on what is most important to you. You can assign A, B, C 
or D priorities to each of your tasks, depending on their level of importance.

A priority tasks are tasks that must be completed today.

B priority tasks are tasks that should be completed today.

C priority tasks are tasks that could be completed today.

D priority tasks are personal tasks that should be completed after work hours.

After you have assigned a priority to each of your tasks, the next step is to rank your tasks. Ranking helps you 
organize your prioritized tasks by assigning a number to each task (A1, A2, B1, etc.)

For example, if you are in the process of completing your A1 task when you are interrupted by a coworker who 
would like to discuss a project that you consider a B3 task, you may want to schedule some time with your 
coworker later in the day to work on the B3 project so you can focus your time on more important projects right 
now.

¨ Prioritized Daily Task Tool Bar
¨ Creating a Task
¨ Creating Redo Tasks
¨ Creating Repeat Tasks
 ̈     Linking a Task to a Contact  
 ̈     Entering Task Notes  
 ̈     Moving a Task to a New Date  
 ̈     Editing a Task  
 ̈     Attaching a File to a Task  
 ̈     Attaching an Object to a Task  
¨ Prioritizing Your Task List
¨ The Prioritize Tasks Window
 ̈     Quick Prioritize  
¨ Assigning Action Codes to a Task
¨ Assigning Action Codes to a Group of Tasks
¨ Get Incomplete Tasks



¨ Creating a Task Category
¨ Editing or Deleting a Task Category
¨ Viewing Task Statistics
¨ Prioritized Daily Task List Preferences

¨ Printing 



About Quotes

The ASCEND 97 Quotes module is a place for you to store your favorite quotes for speeches, reports, personal 
inspiration and more. You can quickly reference quotes and even have ASCEND 97 display a different motivational 
quote each day upon startup. 

¨ Quotes Tool Bar
¨ Adding a New Quote
¨ Editing/Deleting a Quote
¨ Creating Quote Categories
¨ Editing Quote Categories
¨ Locating a Quote
¨ Displaying a Quote at Start-up
¨ Printing Quotes



About Red Tabs

The ASCEND 97 Red Tabs window is named after the Red Tab page dividers in the Franklin Day Planner system. 
Like the Day Planner, ASCEND 97 Red Tabs enable you to organize your information under your own categories. 
You can store miscellaneous documents such as gift ideas, books you’d like to read, movies you want to see, and 
so forth. 

¨ Red Tabs Tool Bar
¨ Creating a Red Tab
¨ Editing a Red Tab
¨ Opening a Red Tab Document
¨ Finding Text in a Red Tab File
¨ Creating Red Tab Categories
¨ Editing Red Tab Categories
¨ Inserting the Date and Time
¨ Inserting a Name
¨ Inserting an Object
¨ Changing Red Tab Preferences
¨ Saving Red Tabs
¨ Printing Red Tabs



About Special Days

While daily tasks, appointments and notes take up most of your day, don’t forget those special events that happen 
in your life. The ASCEND 97 Special Days dialog box helps you remember events such as anniversaries, 
birthdays, holidays or even business trips. Once a special day is programmed in the Special Days dialog box, 
ASCEND 97 does all the work of reminding you of these days.

¨ Creating a Special Day



About The Daily Record of Events  

In the Daily Record of Events module, you can record the details of daily commitments, transactions and 
conversations. For example, if you receive an unexpected call from a business associate who asks you to give a 
presentation on Monday, use the Daily Record of Events page to take down the details of the discussion. You can 
later create an appointment on Monday’s Appointment Schedule and use the important information you entered on 
the Daily Record of Events to create tasks to help you prepare for the presentation.

In the Daily Record of Events you can:

¨ Record details of your meetings, conversations and transactions

¨ Format your text entries

¨ Insert names and phone numbers from the Address and Phone Book

¨ Daily Record of Events Tool Bar
¨ Creating a Daily Record of Events Entry
¨ Formatting Text in the DRE
¨ Inserting the Date and Time
¨ Printing your Daily Record of Events



About The Master Task List

Tasks that are not important right now but may become a priority in the future should be entered on the Master 
Task List. For example, you would like to organize a big family party for your parents 50th anniversary next year. 
While this task is not a priority right now, it will probably become a priority in a few months. You can enter the task 
Organize Family Party on your Master Task List and then transfer the task to your Prioritized Daily Task List when 
it becomes a priority.

¨ Entering a Task on the Master Task List
¨ Moving Tasks to the Master Task List
¨ Moving Master Tasks to the Prioritized Daily Task List
¨ Master Task List Categories
¨ Printing Your Master Task List



About Turbo File  

Turbo File is a fast, computerized index that enables you to keep track of all your miscellaneous information such 
as the date and title of an interesting magazine article, or the location of an important piece of mail. Think of Turbo 
File as a sophisticated card file where you can locate items in seconds.

¨ Turbo File Tool Bar
¨ Creating a Turbo File
¨ Opening and Editing Turbo File Entries
¨ Creating Turbo File Categories
¨ Creating Turbo File Types
¨ Tracking Turbo Files
¨ Printing Turbo Files



About Values and Goals

Values and Goals are the heart of the Franklin Time Management System. By building a Personal Productivity 
Pyramid based on your inherent values and goals, you can bring your daily activities in line with your governing 
values. The ASCEND 97 Values and Goals module assists you in this process by helping you decide what matters 
most to you. No other personal management software application has anything like it.

What’s so important about Values and Goals?

All of us have things that we value—whether it's family, financial security, health, or so on. Unfortunately, for many 
of us, there is a gap between the things we value and our daily actions. We may have a personal goal to spend 
more time with our family or get in shape, but we become so distracted by day-to-day urgencies that our goals are 
often neglected.

The ASCEND 97 Values and Goals window is a planning tool that helps you define what you want out of life and 
how you will achieve it. The Values and Goals window is based on the time-management principles of the Franklin 
Quest system. The Franklin Quest system is a method of identifying the things that matter most to you and then 
setting goals to bring your daily actions in line with your values.

¨ Building a Productivity Pyramid
¨ Identifying Governing Values
¨ Setting Long-Range Goals
¨ Creating Intermediate Steps
¨ Creating Daily or Repeating Tasks
¨ Entering a Governing Value
¨ Entering Long-Range Goals
¨ Entering Intermediate Steps
¨ Entering a One-Time Task
¨ Entering a Repeat Task in Values and Goals
¨ Editing Values and Goals
¨ Deleting Values and Goals
¨ Focusing on a Value
¨ Calculating Your Values and Goals Performance
 ̈     Viewing your Completed Personal Productivity Pyramid  
¨ The Values and Goals Wizard
¨ Using the Wizard
¨ Prioritizing Values and Goals
¨ Using the Prioritize Window
 ̈     Prioritizing in the Values and Goals window  
¨ Printing Values and Goals



About the Journal  

The Journal is a great place for recording personal thoughts, important events and special occasions. The Journal 
is a constant daily file—you never need to “open” or “close” any files. ASCEND 97 automatically saves your 
Journal Entry when you exit the Journal. Everyday you have a new journal window at your disposal.

Use the Journal to:

¨ Keep a daily record of your accomplishments.

¨ Remember those special days (birthdays, anniversaries, holidays).

¨ Keep track of the events in the lives of those important to you. For example, academic or extracurricular 
accomplishments of your children, “Katy won her first swim meet today.”

To open the Journal

1 Click the Journal icon on the Main tool bar

or 

Select Journal from the Window menu. The Journal window opens.

¨ The Journal Tool Bar
¨ Adding a Journal Entry
¨ Indexing Journal Entries
¨ Adding Journal Index Entries
¨ Editing Journal Index Entries
¨ Finding past journal Entries
¨ Inserting the Date and Time
¨ Printing Journal Entries 
¨ Printing your Journal Index Entries List



About the Purge Data Option
Purging erases old data to conserve space which, in return, allows ASCEND 97 to run faster. You may specify 
whether you want to Archive (store) the old data or purge it.

In essence, purging your data is the process of permanently removing all of the old data you no longer need from 
your ASCEND 97 directory. How often you use the Purge Data command is dependent on how extensive your 
notes and journal entries are. Some users may find that they need to purge their data once a month, while others 
may find they need only purge data once a year. Purging your data depends, of course, on your system resources 
and how much hard disk space you can spare.

When you purge data from ASCEND 97, you cannot use the data in ASCEND 97 again. If you create an archive, 
the data is saved as a text file and can only be opened by using a word processor or other text-editing programs.

See Also:
Purging data



Adding Alarms

To add an alarm to an appointment

1 Select an appointment.

2 Click the Alarm button.     The Appointment Alarm dialog box appears.

3 In the Sound Alarm field, check the box. 
4 In the Early Warning box, enter the number of minutes before the appointment that you would like this 
alarm to ring. 

Note:    If no early warning time is entered (0), the alarm will sound at the start time of the appointment. 

5 Click OK. When an alarm has been set for a task, the Alarm button appears as a ringing bell. 



Adding Journal Index Entries

To add Journal Index entries

1 Open the Journal window and click on the Index button 

or 
Select Index Entries from the Options menu. The Index Entries dialog box appears.

2 Click Add Index. The Add/Edit Index Entries dialog box appears. 
3 In the Description field, enter a name for your Journal entry.
4 In the Index Date field, select the date the Journal entry was created.
5 Click OK. The Index Entries window appears. 

Repeat this process to add more Index Entries. 

6 When you are finished, click Close.

See Also
Editing Journal Index Entries



Adding a Call Log

To add a call log

1 Click on the Address and Phone record to which you want to add a contact.

2 Click the Edit button.

3 Click the Contact History tab in the Address and Phone Detail window. The Contact History window 
appears.
4 Click the Add button and select Add a New Call Log. The Call Log window appears.
5 Select Incoming or Outgoing from the Call Type pull-down menu.
6 Click the Timer button and select Start to time the duration of the call. Click the Timer button and select 
Stop to stop the timer when you hang up.

7 Enter any notes for the call.

8 Click Follow-Up to add a new task or a new appointment to the contact.

9 Click Save.

See Also:
Adding a task to a contact
Scheduling an appointment with a contact
Attaching a file or object to a contact



Adding a Journal Entry

To add a Journal entry

1 Click the Journal icon on the Main Tool Bar

or 

Select Journal from the Window menu.

2 Type the Journal entry.

3 Apply the text formatting tools to your entry.

4 Click Close.

Journal entries are automatically saved when the Journal window is closed.



Adding a New Quote

To add a new quote

1 Click on the Favorite Quotes button in the Main Tool Bar 

or
Select Favorite Quotes from the Window menu. The Favorite Quotes window appears.

2 Click the Add Quote button    
or
Select Add Quote from the Edit menu. The Edit Quote dialog box appears.

3 In the Author field, enter the author or source of the quote
4 In the Category field, enter a category. Categories let you distinguish between different types of quotes 
(humor, inspirational, motivational and so on). See Entering Categories

5 In the Keywords field, enter any words you associate with the quote.

6 In the Quote field, enter the quote.

7 Click OK to save the quote.



Adding a Task to a Contact

To add a task to a contact

1 Click on the Address and Phone record to which you want to add a contact.

2 Click the Edit button.

3 Click the Contact History tab in the Address and Phone Detail window. The Contact History window 
appears.
4 Click the Add button and select Add a New Task. The Task window appears.
5 Enter a date for the task in the Date field.
6 Enter the task's priority.
7 Enter the Task Code assigned to this task.

8 Enter Notes for this task.

9 Click OK.

See Also:
Scheduling an appointment with a contact
Adding a call log
Attaching a file or object to a contact



Adding an Address and Phone Entry

To create a new Address and Phone book entry

1 Click the Address and Phone icon to open the Address and Phone book. 

2 Click the Add Entry button.     The New Phone Entry window appears.

3 There are five tabs in the New Phone Entry window to help you create a complete Address and Phone 
record: 

Personal
Address 
Notes
Important Dates 

4 Begin creating your Address and Phone entry in the Personal window. 



Additional Searching Capabilities

Although Global Search is an excellent tool for locating data, ASCEND 97 provides other searching features which 
are specific to the modules: 

Filters

Filters can sort information by categories, types and key information to locate important information quickly. You 
can use filters to search for information in Favorite Quotes, Turbo File, and the Address and Phone Book.

Search Features

You can use search features to locate specific information in the Journal and the Address and Phone Book.

Red Tab Find

The Red Tab Find feature helps you locate a specific Red Tab file quickly.



Address and Phone Book Tool Bar

Defining the Tool Bar

      Add a new entry.

      Edit an entry

      Delete an entry

      View phone numbers

      Load a filter 

  



Appointment Schedule



Appointment Schedule Preferences

As you become familiar with the Appointment Schedule, you may want to customize the window to meet your 
specific needs.

To open the Appointment Preferences window

1 Open the Appointment Schedule.

2 Select Preferences from the Options menu.

3 Select Appointment Preferences from the Preferences menu.

Appointment Colors

Appointment Colors make it easy to separate your various appointments. You can create your own color in the 
Appointment Preferences window or use the ASCEND 97 default colors. You can set colors for:

¨ Normal Appointments

¨ Repeat Appointments

¨ Work Time

¨ Off-hours Time

Appointment Grid Preferences

You can customize the appearance of your appointment grid.

¨ Identify your work hours with a color

¨ View an entire workday in your Appointment Schedule grid



Appointment Schedule Tool Bar

Add a new appointment

      Delete the selected appointment

      Cut the currently selected text

      Copy selected text to clipboard

      Paste the text from the clipboard

        Create or edit a Repeat appointment

      Daily view

      Weekly view

      Monthly view

      Yearly view



Archiving Data

To archive your ASCEND 97 data

1 Open the Tools and Utilities program.

Note:    You must close ASCEND 97 before you can open the Tools and Utilities program.

2 Click the Purge/Archive button.  The Purge/Archive window appears.

3 Select the ASCEND 97 information you want to archive in the Elements to purge box.
4 Enter the start and end date of the information you want to archive.
5 Click the Archive box.
6 Type the destination path in the File Name: field. For example, a:\backup.001, then go to step 8.

or

Click the Browse button  to select a backup path, then go to step 7.
7 If you clicked the Browse button, type in the file name, then click the drop-down list arrow from Save File 

as Type. Determine a destination path (drive and directory), then click OK to close the current window 
and return to the Purge/Archive window.

8 Click OK. A window appears with the message “Database is purged/archived.”

9 Click OK. The archive process is complete.



Arrange Icons
You can place your icon bar anywhere within the ASCEND 97 window to make it convenient to access.

To rearrange your icon bar

1 Click in the box surrounding the icon bar.

2 Drag the icon bar anywhere in the ASCEND 97 window.

To return your icon bar to normal position

1 Double click on the drag bar.



Assigning Action Codes to a Group of Tasks

You may find that at the end of a very busy day you have many tasks without action codes. You can quickly wrap-
up your day by using the Group Action window to assign action codes to all of your remaining tasks.

To assign action codes to a group of tasks

1 Click the Group Action button. The Group Action window appears.

2 All incomplete tasks appear in the Incomplete Tasks box.
3 Click on all tasks that have been completed and click the Complete button. The completed tasks appear in 
the Completed Tasks box.
4 Assign an action to all remaining tasks by selecting the task and clicking on the appropriate action code 
button    (Uncomplete, Complete and Forward, Forward, Complete, Delete, and Move).

Note:    When forwarding a task click the Forward button and select the date you would like the task 
forwarded to in the Copy/Forward Date calendar.

5 When you are finished click OK.



Assigning Action Codes to a Task

As your day progresses, keep track of the status of your    tasks with Action Codes. You can select from the 
following action codes to indicate the status of a task: 

        Not Complete

        Task Complete

        Planned Forward... 

        Task Deleted

        Delegated Task

        Planned Forward complete

        In Process

To assign an action code to a task

1 Click    and hold the mouse in the Action Code column next to the task. The Action Codes drop-down 
menu appears. 

2 Drag the mouse to the action code you want to assign to this task. The selected action appears in the 
Action Code column next to the appropriate task.

See Also:
Assigning action codes to a group of tasks



Assigning Address and Phone Categories

Once you have created a phone category, you need to assign the category to the appropriate Address and Phone 
book Entries.

To assign a category to an address and phone entry

1 Open the Address and Phone book

2 Double-click on the listing that you would like to assign a category. The Address and Phone book Detail 
view appears.

3 Click the down arrow in the Category field. 

4 Select the category you want to assign to this record and click the Save button. 

5 Click Close. 
Note: To help you locate Address and Phone records easily assign a category to each new Address and 

Phone entry.



Assigning a Color to a Task Category

To Assign a Color to a Task Category

1 Open the Prioritized Daily Task List Preferences window.

2 Click on the Task Category button in the Prioritized Daily Task List Preferences window. The Color 
window opens. 

3 Click on the color you would like to assign this group of tasks. 

Note:    You can also create a custom color for your task category. For more information on creating 
custom color see your Windows 95 Online Help.

4 Click OK. The new task color appears next to the selected Task Category in the Prioritized Daily Task List 
Preferences window.



Attaching a File or Object to a Contact

To attach a file or object to a contact

1 Click on the Address and Phone record to which you want to add a contact.

2 Click the Edit button.

3 Click the Contact History tab in the Address and Phone Detail window. The Contact History window 
appears.
4 Click the Add button and select Add a New Appointment or Add a New Task. 
5 In the Task or Appointment window, click the Attachments button to link a file or an object to the entry. The 
File Attachments window appears.

6 Click the Add File or Add Object button.

7 Select the file or object you want to link and click OK. You return to the File Attachments window.

8 Click Close to return to the Contact History window.

9 Click Save.

See Also:
Adding a task to a contact
Scheduling an appointment with a contact
Adding a call log



Attaching a File to a Task

To attach a file to a task

1 Select a task.

2    Click on the File icon.       The File Attachments window opens.

3    Click the Add File button.
4    Navigate to the file you would like to attach and click Open.
5    The file now appears in the File Attachments window.
6    A small file icon appears in the Task box.



Attaching a File to an Appointment

To attach a file to an appointment

1    Select    an appointment.

2    Click on the File button.     The Appointment Properties window opens to the Appointment 
Information tab.

3    Click the Attachments button. The File Attachments window opens.
4 Click the Add File button.
5    Navigate to the file you would like to attach and click Open.
6    The file now appears in the File Attachments window.
7    A small file icon appears in the Appointment box.



Attaching an Object to a Task

To attach an object to a task

1 Select    an task.

2 Click on the File icon.       The File Attachments window opens.

3 Click the Add Object button.
4 Select whether you would like to Create New or Create from File by clicking    the preceding radio button.
5 If you select Create New, then select the type of object you will be inserting.

or
If you select Create from File, then click Browse and select the object you would like to insert. Click Insert.

6 Click OK.

7 Click Done in the File Attachments window.

8 A small file icon should appear in the Task box.



Attaching an Object to an Appointment

To attach an object to an appointment

1    Select    an appointment.

2    Click on the File icon.     The Appointment Properties window opens to the Appointment 
Information tab.

3    Click the Attachments button. The File Attachments window opens.
4    Click the Add Object button.
5    Select whether you would like to Create New or Create from File by clicking    the preceding radio button.
6 If you select Create New, then select the type of object you will be inserting.

or

If you select Create from File, then click Browse and select the object you would like to insert.

7    A small file icon appears in the Appointment box.



Building a Productivity Pyramid

The Franklin Time Management system is designed to bridge the gap between your values and your daily 
activities. This section will help you determine your values and create a Productivity Pyramid to help you bring 
your daily activities in line with your values. 

The Productivity Pyramid is composed of four steps, Governing Values, Long-Range Goals, Intermediate Steps, 
and Daily Tasks.

See Also:
Step 1: Identifying your Governing Values
Step 2: Setting Long-Range Goals
Step 3: Identifying Intermediate Steps
Step 4: Translating Intermediate Steps into Daily Tasks



Calculating Your Values and Goals Performance 

You can easily keep track of how well you are living by your values and goals with ASCEND 97's Display Goals 
Evaluation feature. This feature allows you to enter a grade for each Governing Value, Long-Range Goal, and 
Intermediate Step (on a scale of 1-10) based on how you’re doing toward accomplishing that step. If you’ve 
finished, give yourself a 10; if you’re halfway there, give yourself a 5, and so on. ASCEND 97 takes these grades 
and does three things:

¨ Assigns a grade to each goal, based on the average grade of the intermediate steps attached to that goal. 
This grade is displayed in the Grade field in that goal’s dialog box and cannot be edited.

¨ Assigns a grade to each value, based on the cumulative score of the Long-Range Goals under that value. 

¨ Calculates an overall grade which reflects your total performance. This is your Goals Evaluation Grade. 
This grade is displayed next to the pyramid buttons on the Values and Goals display.

To enter a grade for an Intermediate Step

1 Double-click on the Intermediate Step to open its dialog box.

2 In the Grade field, type in a grade, on a scale of 1-10, which reflects how well you’ve done toward 
accomplishing that step.

3 Click OK.



Change the HotSync Options

To change the HotSync options

1    Click the HotSync button on the ASCEND 97 desktop. The HotSync Setup window appears.

2 Click Change if you want to synchronize specific files between ASCEND 97 and the Pilot, like Red Tabs 
or Task List. Otherwise, leave your setting on “synchronize all files.”

3 Choose how far back in time you want to synchronize your events.

4 Select whether you want HotSync to always be available, available when ASCEND 97 is running or run 
manually.

5 Click Apply.



Changing Appointment Times

To change an appointment time

1 Select an appointment.

2 Place the cursor on bar at the start or end of the appointment. Drag it to the new time.

or

Select Edit Appointment in the Edit menu. The Appointment Properties dialog box appears.

3 Click and drag the time bar to the new time period.

4 Click OK.



Changing Red Tab Preferences

Red Tab Preferences give you the option to view an existing Red Tab file after opening the module and/or set a 
default font for your text format.

To access Red Tab preferences select Preferences from the Options menu. Select  Red Tab Preferences from 
the Options menu. The Red Tab Preferences window appears.

To select an existing file each time you open Red Tabs 

1 Select Red Tabs Preferences from the Options menu.

2 Check the Retrieve a file when entering Red Tabs box.

To change the default font in the Red Tabs window

1 Click the Default Font button. The Font window appears.

2 Select the new Font and formatting options you want and click OK.

3 The Red Tab Preferences window appears. The new default font appears next to the Default Font button.



Changing the date using the Floating Calendar

You can move to any date quickly with the Floating Calendar.

To change date using the Floating Calendar

1 Select Calendar from the View menu to open the Floating Calendar.

2 Navigate to a month by clicking the date-control buttons.   

3 Click any day on the calendar. All ASCEND 97 windows change to this date.



Choosing a Paper Source

To select a paper source

1 Select Print from the File menu, the Print window opens.

2 Click the Setup button.

3 In the Print Setup window, click the Source drop-down list to select a paper source.

4 Click OK.



Choosing a Printer
By default ASCEND 97 prints to your default printer in Windows. If you’d like to print to a different printer, change 
the printer selection in the Print Setup box.

To select a different printer

1 Select Print from the File menu, the Print window opens.

2 Click the Setup button.

3 Select your printer from the Name drop-down menu in the Printer box.

4 Click the Properties button to change your default printer settings.

5 Click OK.

6 Click OK.



Compressing Your ASCEND 97 Database

As your ASCEND 97 files grow you may find that you want to purge, archive or compress some of your ASCEND 
97 information to create more space. If you have deleted old tasks, appointments, Red Tab files, etc., compress 
your database to free this space on your hard drive.

To compress your database

1 Open the ASCEND 97 Tools and Utilities program.

Note:    You must close ASCEND 97 before you can open the Tools and Utilities program.

2 Click the Compact Database button.  The Compact Database window appears.

3 Click Yes to compact your database. A confirmation window appears stating “Database is compacted.”
4 Click OK. Your ASCEND 97 files are now compressed.



Conducting HotSync Via Modem

To conduct the HotSync via modem

1 In the HotSync manager window confirm that the modem is connected and turned on.

2 Make sure the HotSync Manager is running with the Modem selected from the Options menu.

3 Connect the special modem cable from the Pilot’s serial connector to the modem.

4 Turn on the Pilot.

5 Tap the Applications button on the Pilot screen.

6 Tap the HotSync application. The HotSync window appears.

7 Tap the Modem Sync button. The HotSync process begins.

See Also:
Configuring Your Pilot

Configuring Your Computer



Configuring Your Computer for Modem HotSync

To configure your computer

1 Open the HotSync Manager.

2 Select Setup from the Options menu.

3 Click the Modem tab.

4 Choose the Serial Port for the modem.

5 Choose a Speed. Try As Fast As Possible.

6 Choose the Modem type.

7 Click OK.

See Also:
Configuring Your Pilot

Conducting a HotSync via Modem



Configuring Your Pilot for Modem HotSync

To configure your pilot

1    Turn on the Pilot and tap the Applications button.

2 Tap the HotSync button. The HotSync window appears.

3 Tap the Modem Setup button. The Modem Setup window appears on the Pilot screen.

4 Enter the telephone number to access your computer’s modem.

5 Click TouchToneª or Rotary to match the telephone system you are using.

6 Select the Modem type that best describes the modem connected to your Pilot. If you are not sure what 
modem you are using, choose Hayes Basic.

7 Select the modem speed that the modem uses to communicate.

8 Tap OK to close the Modem Setup window.

Note: You must perform your first HotSync at your computer before you can HotSync via modem.

See Also:
Configuring Your Computer

Conducting a HotSync via Modem



Connecting Pilot to Your Computer

To connect pilot to your computer

1    Insert the Pilot into the Pilot docking cradle.

2 Plug the cable from the Pilot cradle into the communications port you selected during ASCEND 97 
installation.

3 Open HotSync Manager from the Franklin Day Planner program folder. The HotSync Manager window 
appears.

4 Select Setup from the Options menu. The Setup window appears.

5 Click the Local tab.

6 Make sure the selected Serial Port corresponds to the port number that you connected the Pilot to.

7 Choose a Speed for data transfer. Try As Fast As Possible first and adjust downward if you experience 
problems.

8 Click OK.

See Also:
Using HotSync at your computer

Using HotSync via Modem



Contact Management
With the ASCEND 97 Contact History window, you can track phone calls, task and appointments for all your 
important business and personal contacts. The Contact History tab will become available only after the contact 
has be entered.

The Contact History window allows you to

¨ Keep track of outgoing and incoming calls

¨ Add tasks to a contact

¨ Schedule appointments with a contact

¨ Time your phone calls with contacts

¨ Link    a file or object to a task

See Also:
Adding a task to a contact
Scheduling an appointment with a contact
Adding a call log
Attaching a file or object to a contact



Context Sensitive Help

Context Sensitive Help allows you to find help on specific areas of ASCEND 97 software. Some dialog boxes have 
a Help button. 

To access context sensitive help

¨ Click on a    Help button to open ASCEND 97 Online Help to the specific topic you are looking for. 

or

¨ Click    F1 from anywhere within ASCEND 97 program to open a ASCEND 97 Online Help topic in the area 
you are working.



Converting ASCEND 5.0 Information

Converting ASCEND 5.0 files to ASCEND 97 after installation

1 Double-click My Computer on your Windows Desktop.

2 Locate your ASCEND 97 program file and double-click on the Conversion icon. The Conversion window 
opens.

3 If the correct path for the ASCEND 5.0 Data Files does not appear in the Path for ASCEND 5.0 Data File 
field, click Browse to find the correct path.

4 When you have identified the correct path for the ASCEND 5.0 Data Files, click Convert. 

5 Click Yes to begin the conversion process. 

6 Click OK. The ASCEND data conversion process is now complete.

Review the following changes if you are upgrading from ASCEND 5.0:

¨ ASCEND 5.0 Recurring Tasks and Recurring Appointments are now called Repeat Tasks and Repeat 
Appointments. 

¨ ASCEND 5.0 Repeat Tasks are now called Redo Tasks.



Creating Address and Phone Categories

To help you locate Address and Phone records easily, assign a category to each new Address and Phone entry. 
Categories allow you to fine-tune any Address and Phone book listing for quick reference. For example, suppose 
you need a list of all contacts who work at the Franklin corporation. You would simply create a category called 
“Franklin.” A category can be any subject. It can be general (personal, business) or specific (Franklin).

To create a category

1 Open the Address and Phone book. 

2 Select Edit    Phone Categories from the Options menu. The Phone Categories dialog box appears.

3 Click Add. The Category Properties dialog box appears.

4 Enter a new category name and click OK. 

See Also:
Assigning Phone Categories
Editing or Deleting Phone Categories



Creating Daily or Repeat Tasks

After you've broken your goals into steps, the final step is to create Daily Tasks based on your Intermediate Steps. 
The Daily Task is a single event which helps you reach a Long-Range Goal. For example, a daily task for the 
Intermediate Step “Read the new book entitled Building Better Teams” might be “Read 10 pages a day."    With 
each step you take your daily behavior moves closer to the things you value most.

There are two types of Daily Tasks that you can create in the Values and Goals window:

¨ Recurring Daily Tasks

¨ One-time Daily Tasks

ASCEND 97's Values and Goals Module makes the process of creating your Productivity Pyramid simpler than 
you've ever imagined. 

See Also:
Entering a repeat task
Entering a one-time task



Creating Intermediate Steps

Once you have created your Long-Range Goals, you need to determine the steps you will need to complete them. 
These are called Intermediate Steps. Intermediate Steps can be one-time tasks or smaller goals. For each goal 
make a list of the steps required to reach it.

For example, some Intermediate Steps for the Long-Range Goal “I will successfully accomplish my part of my 
team’s three main objectives by January 1, 1997” might include:

¨ “Be on time for every team meeting this year.”

¨ “Volunteer to make the team presentation to management.”

¨ “Read the new book entitled Building Better Teams.”

See Also:
Entering Intermediate Steps
Creating daily or repeat tasks



Creating Quote Categories

To create a quote category

1 Open the Favorite Quotes window. 

2 Select Quotes Categories from the Options menu. The Quotes Categories dialog box appears. 

3 Click Add. The Edit Quotes Category dialog box appears.

4 Enter a description.

5 Click OK or press Enter to return to the Quotes Categories dialog box.

6 Click Done. 



Creating Red Tab Categories

Red Tab Categories is the organizing tool for all your Red Tab files. You may create as many Red Tab Categories 
as you need.

Some guidelines you might want to keep in mind when creating Red Tab Categories:

¨ Create categories that are specific to a project or activity. For example, if you create a category entitled 
Book Club, you may store all your related Red Tab files (Books to read, Review of Building Better Teams, 
names and addresses of Book Club members).

¨ Make sure to identify a category when creating your Red Tab files. If you don’t find a category that fits the 
new file, create a new category.

To create a Red Tab Category

1 Open Red Tabs.

2 Select Red Tabs Categories from the Options menu. The Categories dialog box appears.

3 Click Add. The Edit Category dialog box appears. 

4 Enter a category description in the Description field. 

5 Click OK to return to the Categories dialog box. 

6 Click Done to return to the Red Tabs window. 



Creating Redo Tasks

A Redo task is rescheduled each time you complete it. For example, you could enter the task, “Get haircut” and 
set it to reoccur every 30 days. ASCEND 97 will not schedule it again until you mark the task as complete.

To create a Redo Task

1 Click on a task in the Prioritized Daily Task List.

2 Select Redo Tasks from the Options menu. The Redo Task dialog box appears.

3 The task that you selected in the Prioritized Daily Task List    appears in    the Task field. 

4 In the Days to Redo field, enter the number of days after completion that you want the task to reappear. 

5 Click OK. 



Creating Repeat Tasks

You can program a task to appear on your task list on a consistent basis. For example, you could set the task 
“Read 10 pages in my book” to appear every day for the next month. Each day this task would automatically 
appear on your Prioritized Daily Task List. 

To create a Repeat Task

1 Click the Repeat Task button  in the Prioritized Daily Task List    Toolbar. The Repeat Task dialog box 
appears.

2 Enter a task description in the Description field.
3 Enter a priority (A, B or C) in the Priority field.
4 Enter any notes related to the task in the Notes field.
5 Enter the date you would like the Repeat task to start appearing on your Prioritized Daily Task list in the 
Start field. 
6 Enter the date you would like the Repeat Task to stop appearing on your Prioritized Daily Task List in the 
End field.

¨ To Create a Weekly Repeating Task

¨ To Create a Monthly Repeating Task

¨ To Create a Yearly Repeating Task



Creating Turbo File Categories

To help you organize your Turbo File entries, you can separate them into categories.

To organize your Turbo Files with Categories

1 Click on the Turbo File button on the Main Tool Bar    

or
Select Turbo File from the Window menu. The Turbo File window appears.

2 Select Turbo File Categories from the Options menu. The Turbo File Categories dialog box appears. 
3 Click Add. The Edit Turbo File Category dialog box appears.
4 Enter a description.
5 Click OK or press Enter to return to the Turbo File Categories dialog box.

6 Click Done. 

To edit an existing Turbo File Category

1 Select a category from the Turbo File Categories dialog box and click Edit. 

2 Edit the description and click OK. 

To delete a Turbo File Category

¨ Select the Category and click Delete. 



Creating Turbo File Types

Turbo File Types make it easier for you to locate a file. For example, under the category “Computers” you might 
have the types “Hardware” and “Software.”

To create a Turbo File Type

1 Click on the Turbo File button on the Main Tool Bar    

or
Select Turbo File from the Window menu. The Turbo File window appears.

2 Select Turbo File Types from the Options menu. The Turbo File Types dialog box appears. 
3 Click Add. The Edit Turbo File Types dialog box appears.
4 Enter a description.
5 Click OK or press Enter to return to the Turbo File Types dialog box.
6 Click Close.

To edit an existing Turbo File Type

1 Select a type from the Turbo File Types dialog box and click Edit. 

2 Edit the description and click OK.

To delete a Turbo File Type

¨ Select a type from the Turbo File Types dialog box and click Delete. 



Creating a Backup

When using the backup option, specify a disk drive and directory in which to place the backup file. If your data will 
not fit on one diskette, ASCEND 97 asks for additional diskettes. ASCEND 97 does not erase any data on the 
diskette used for a backup, nor will it format the diskette. Diskettes used for a backup must already be formatted.

To make a Backup of your ASCEND 97 data

1 Open the Tools and Utilities program.

Note:    You must close ASCEND 97 before you can open the Tools and Utilities program.

2 Click the Backup button.     The Backup window opens.

3 Click OK to create a backup. 
4 When the backup is complete, a confirmation window appears that says “Database backup was successful.”
5 Click OK. Your backup is now complete.



Creating a Daily Record of Events Entry

To make a Daily Record of Events entry

1 Click the Daily Record of Events button on the Main Tool Bar.

or
Select Daily Record of Events from the Window menu. 

2 Enter your data in the text window.
3 You can format your data using the Daily Record of Events Tool Bar. 



Creating a New Appointment

To create a new appointment

1 Click on the line next to the start time of your appointment. 

or 

Click on the New Appointment button. 

or 
Select New Appointment from the Edit menu. The Appointment Properties window appears. Move 

the appointment time block to the starting time with the keyboard arrows.    To adjust the length of the appointment, 
hold down the Shift key and use the keyboard arrows.
2 Enter a appointment description. You can enter up to 255 characters in the Appointment Description field.

Tip:

You can assign categories to each appointment and distinguish you categories with different colors.

To assign a category to an appointment

1 Select the appointment    by clicking it.

2 Select Edit Appointment from the Edit menu.

3 Choose a category from the drop-down menu.

4 Click OK.

Note:    Create appointment categories by selecting Appointment Categories from the Options menu.    You 
can assign category colors in the Appointment preferences.

See Also:
Creating a Repeat Appointment
Editing an Appointment
Entering Appointment Notes



Creating a New Filter

If you want to view certain Address and Phone entries use a filter. For example, create a filter entitled Franklin 
Quest Co. to view all your Address and Phone entries for Franklin Quest Co. 

To create a Filter

1 Open the Address and Phone book. 

2 Click the Filter button.  The Phone Filter window opens.

3 Click the Add button to create a new Phone Filter. The Phone Filter detail view appears.
4 Enter the name of your filter in the Filter Name field.
5 Decide what information you want to appear with this filter. For example, if you want all Address and Phone 
records related to Franklin Quest Co. to appear, enter Franklin Quest Co. in the Company field. You can assign Key 
Codes, Categories, etc. to your filter.

6 Enter the filter criteria in the assigned fields: Last Name, First Name, Hailing, E-Mail, Title, etc.

7 In the Word Match box, you can select the type of filter you wish to create.

8 Select from:

Anywhere    Search for the correct order of letters anywhere in the directory. This includes the correct 
order of letters within another word. For example, if you are looking for “out,” ASCEND 97 searches for 
any entry in the directory containing the letters o-u-t, such as the word “clout.”

Exact Search for words exactly as they are typed. For example, if you have the word “out” typed as 
OUT, ASCEND 97 will not find the match. It must be typed exactly as “out."

Beginning      Search for the correct order of letters at the beginning of any word. For example, if you are 
looking for “out,” ASCEND 97 searches for any entry in the directory with the letters o-u-t in the beginning, 
such as in the word “outer.”

9 Click the Case Sensitive box    if you want ASCEND 97 to search for words in upper and/or lower case 
exactly as entered. For example, if you are searching for “Out,” ASCEND 97 would not find “out”.

10 When you have defined all the fields you want to assign to this filter click OK. The new filter appears in 
the Phone Filters window.

See Also
 Loading a Filter



Creating a Password

Password protection is set up for your security. By creating a password, only you can access your ASCEND 97 
program.

To create a Tools and Utilities Password

1 Open the ASCEND 97 Tools and Utilities program.

Note:    You must close ASCEND 97 before you can open the Tools and Utilities program.

2 Click the Change Password button  in the Tools and Utilities window. The Change Password 
window appears.

3 Add a security password in the New Password field.
4 Retype the password in the Verify New Password field.
5 Click OK. A window appears displaying the message “Password is set.”
6 Click OK. Your ASCEND 97 files are now secured by your password.

To remove your password

1 Open the ASCEND 97 Tools and Utilities program.

Note:    You must close ASCEND 97 before you can open the Tools and Utilities program.

2 Click the Change Password button  in the Tools and Utilities window. The Change Password 
window appears.

3 Type your password in the Old Password field.
4 Click the Remove button.



Creating a Red Tab

Keep tabs on all of the information in your life. Whether it’s ideas for the meeting with the Creative Department 
next week, or keeping track of your son’s Little League schedule, you can organize it all with Red Tabs. You can 
create as many Red Tab files as you want. The Red Tab Categories feature makes retrieval easier than any 
manual filing system. Red Tab files are easy-to-use because you can create, edit and delete Red Tab files with the 
click of a button.

To create a Red Tab File

1 Click the Red Tab button 

or
select Red Tabs from the Window menu.

 An Untitled Red Tab document appears. 
2 Enter text.
3 Format text.

4 Click Save button. 
5 Choose a Red Tab Category from the drop-down menu.
6 Enter a description of the Red Tab in the Description field.
7 Click Save.



Creating a Repeat Appointment
Repeat appointments automatically appear on the days you select. For example, you can create a repeat 
appointment for a staff meeting every Thursday from 9:00 a.m. to 10:30 a.m. Every Thursday, the appointment 
appears on your ASCEND 97 Appointment Schedule. 

To create a Repeat Appointment

1 Open the Appointment Schedule

2 Click the Repeat Appointment button. 

 or
 Select Repeat Appointments from the Options menu.

The Repeat Appointment window appears.
2 Click the Add button. The Add/Edit Repeat Appointment window appears
3 Enter a description of the appointment in the Description field. 
4 Enter any notes in the Notes field.
5 Enter the date you would like the Repeat Appointment to start appearing on your Appointment Schedule in 
the Starting date field.

6 Enter the date you would like the Repeat Appointment to stop appearing on your Appointment Schedule in 
the Ending Date field.

7 Enter the Starting Time.

8 Enter the Duration of the appointment.

9 To set an alarm, check the Alarm box. In the Early Warning field, enter the number of minutes before the 
appointment that you would like to be warned. 

Yearly Appointment

¨ If you want the appointment to appear once a year on a certain date, enter the date in the Day and Month 
fields. 

Monthly Appointment

¨ To create a monthly appointment, enter the number of months before the appointment repeats in the Every 
field, then click the Months button.

¨ To repeat the appointment on a certain day of the month (for example, the second Friday of the month), in 
the Weekdays field click the Friday box and click the 2nd box in the Weeks field.

Tip: If you select the 1st, Last or 5th boxes in the Weeks field, make sure the day you have selected 
occurs in that week. For example, if you select the Thursday and Last boxes, there must be a 
Thursday in the last week of the month or the appointment will not appear.

Weekly Appointment

¨ To create a weekly appointment, enter the number of weeks before the appointment repeats in the Every 
box and click the Weeks button. For example, “Every 2 Weeks”    means the appointment will repeat every 
other week after the Starting Date until the Ending Date is reached.

10 Click Save. 

Note:    To view or edit an existing Repeat appointment, click Find. Click the Delete button to remove a 
Repeat appointment. 



Creating a Special Day in ASCEND 97

To enter a Special Day in your ASCEND 97 program

1 Select Special Days from the File menu

or

Open the Floating Calendar and click on the Special Days icon. 

2 The Special Days dialog box appears.
3 Click New. The Special Days Detail dialog box appears.
4 Enter the name of the Special Day in the Description field.
5 If the event occurs on one specific day (such as a birthday) complete the Month and Day fields. (You must 
complete either the Month and Day fields or the Start Date and End Date fields.)

6 If the event occurs on more than one day (such as a vacation) enter the beginning and ending dates of 
the event in the Start Date and End Date fields. (You must complete either the Month and Day fields, or 
the Start    Date and End Date fields.)

Tip: You can either enter the date in the Start Date and End Date fields, or you can click on the calendar 
and select the date. If you select a date in the calendar, click on the calendar again to close it.

7 Click Early Notification to have ASCEND 97 remind you when a Special Day is approaching. Enter the 
number of days before the event that you would like to be reminded. A reminder will appear on your 
ASCEND 97 desktop.

8 Select a category from the drop-down menu.

9 Enter the days on which you would like the Special Day to appear. 

10 Click OK. 



Creating a Task
Take some time each day to make a list of all the goals that you plan to complete today.

To create a new task

1 Click on a blank task line

or

Select Insert Task from the Edit menu.

2 Enter a task description.

3 Enter any note for this task in the Note field.

4 Click the Date/Time Stamp in the Note field when a task has been completed. This helps you keep an 
accurate record of when tasks have been completed.

5 You can also attach a file to a task or link this task to a contact.

Note:  A task description can have a maximum of    255 characters. To view the remaining characters in the 
slot, click on the far right end of the text. The text will scroll to the left.

See Also:

Creating Redo tasks
Creating Repeat tasks
Prioritizing your task list
Assigning action codes to a task
Linking a task to a contact
Moving a task



Creating a Task Category

Creating Task Categories will help you organize your tasks into specific areas such as work, home and other 
projects.

To create a task category

1 Open the Prioritized Daily Task List.

2 Select Task Categories from the Options menu. The Task Categories dialog box opens.

3 Click Add.

4 Enter a category description in the Description field.

5 Click OK.

See Also:
Editing or Deleting a Task Category



Creating a Turbo File

To create a new Turbo File

1 Click on the Turbo File button on the Main tool bar    

or
Select Turbo File from the Window menu. The Turbo File window appears.

2 Click the Add Turbo File button. 
3 In the Description field, enter the name of the article or title of the document you are filing.
4 In the Keywords field, enter any words that will help you find items in the future.
5 In the Location field, enter the location of the physical file or document. For example, drawer two, file three, 
family room, or safety deposit box.

6 In the Category field, specify the type of item being indexed or filed. Examples of categories include 
Computers, Parenting, Speech Material. 

7 In the Date Entered field, enter the date the turbo file was created or edited.

8 In the Type field, enter the Turbo File Type. You can subcategorize items within each category by defining 
a Turbo File Type. 

9 Enter notes about the file item in the Turbo File Notes field. 

10 Click OK. 



Customizing the Desktop
You can personalize your ASCEND 97 desktop by sizing each ASCEND 97 window to fit your needs and by setting 
your preferences. Options in Global, Prioritized Daily Task List, and Appointment Schedule Preferences allow you 
to change the way your desktop looks.

ASCEND 97 Global Preferences allow you to customize your desktop. In the Global Preferences window you can:

¨ Synchronize dates between modules

¨ Show a Quote of the Day on startup

¨ Show a Governing Value on startup

¨ Set your dialing preferences

You can personalize your task list by changing your Prioritized Daily Task List Preferences. Within the Prioritized 
Daily Task List Preferences window you can:

¨ Auto Forward/Sort tasks

¨ Assign colors to tasks

¨ Delete priorities from incomplete tasks

¨ Forward tasks to the Master Task List

The Appointment Schedule Preferences allow you to:

¨ Select colors for your different appointment types

¨ Designate work and personal time for appointments

¨ Select a Start and End time for your workday

¨ Set the view for the appointment grid (15 minutes, 30 minutes, one hour)

¨ Show or hide any tasks that are related to an appointment



Daily Record of Events



Daily Record of Events Tool Bar

You can format your Daily Record of Events with the Daily Record of Events Tool Bar.

      Cut selected text

      Copy text to clipboard 

      Paste text from clipboard

      Bold text

      Italicize text

      Underline text

      Change font style

      Align text left (default)

      Center text

      Align text right

      Insert bullet

      Date and Time stamp





Decrypting Your Database

You may find that you need to decrypt your database at some point in the future. For example, if you want to be 
able to import and export Address and Phone information you will need to decrypt your ASCEND 97 database 
because this information is transferred directly from the ASCEND 97 database.

To decrypt your ASCEND 97 database

1 Open the ASCEND 97 Tools and Utilities program.

2 Click the Decrypt Database button.  The Decrypt Database window appears.

3 Click Yes to decrypt your database. A confirmation window appears that says “Database is decrypted.”
4 Click OK. Your ASCEND 97 database is now readable by other programs.



Deleting Values and Goals

At times you may want to remove a value, goal, step or task. If, for example, you have reached a goal or you 
discover that a certain value is no longer significant, you may want to delete it.

To delete a Values and Goals entry

1 Open the Values and Goals window.

2 Click the pyramids to expand the list to the appropriate level.

3 Click on the value, goal, step, or task that you want to delete.

4 Click Delete. 

 A message warns you that everything beneath the value, goal, or step will also be deleted.

Warning!    When you delete a value, goal, or step, everything beneath it is also deleted. For example, if 
you delete a Governing Value, ASCEND 97 deletes all the goals, steps and tasks attached to 
the value.

5 Click OK to delete; click Cancel if you do not want to delete your selection.



Displaying a Quote at Start-up

To start each day with an inspirational quote

1 Open the favorite Quotes window.

2 Select Global Preferences from the Option menu. The Global Preferences dialog box appears.

3 Select Show Quote of the Day on Startup.

4 Click OK. ASCEND 97 will display a different quote each time you start up.



Editing Journal Index Entries

To edit Journal Index entries

1 Open the Journal window and click on the Index button 

or 
Select Index Entries form the Options menu. The Index Entries dialog box appears.

2 Click Edit Index. The Add/Edit Index Entries dialog box appears.
3 Make any changes to the entry and click OK. The Index Entries window appears.
4 Repeat this process to edit more Index Entries.
6 When you are finished, click Close.



Editing Quote Categories

To edit an existing Quotes Category 

1 Select a category from the Quotes Categories dialog box

2 Click Edit. 

3 Edit the description and click OK. 

To delete a Quotes Category 

1 Select a category from the Quotes Categories dialog box

2 Click Delete. 



Editing Red Tab Categories

To rename a category

1 Select Red Tab Categories from the Options menu.

2 Click to highlight the category you wish to rename. 

3 Click Edit. The Edit Category dialog box appears.

4 Highlight the text, type in the new name, then click OK.

5 The new name appears in the Categories window.

6 Click Close to exit the dialog box.

To delete a Red Tab category

1 Open the Red Tabs window.

2 Select Red Tab Categories from the Options menu. The Categories window appears.

3 Click to highlight the category you wish to delete.

4 Click Delete.



Editing Values and Goals

To make changes to any Value, Goal, Intermediate Step, or Daily Task

1 Open the Values and Goals window.

2 Click the View All button  to view all levels of your pyramid.

3 Click on the Governing Value, Long-Range Goal, Intermediate Step or Daily Task you want to change. The 
dialog box appears for the value, goal, step or task you selected.
4 Make the changes in the appropriate fields.
5 When you are finished editing, click OK. 



Editing a Journal Entry

To edit a Journal entry

¨ Locate it with the date bar, or in the Index Entries dialog box. Make changes to the entry, they will 
automatically be saved upon closing the Journal window.

See Also:
Finding Past Journal Entries



Editing a Red Tab

You can make changes to Red Tab documents at any time.

To edit a Red Tab document

1 Open the file you want to change.

2 Make the desired changes, then click the Save button.



Editing a Task

ASCEND 97’s editing features allow you to change, cut, copy or delete a task description or note.

To edit an existing task

¨ Double-click on a task description and enter new text.

To edit the note for a task 

1 Click on the task you wish to edit. The note for the selected task appears in the Note field. 

2 Make any changes to the note. The changes are automatically saved when you exit the note field. 

Using the tool bar, menu bar, or right mouse button, you have access to the Cut, Copy and Paste commands. 
However, if you don’t want to cut a task completely from the task list, you can assign it a “Deleted” action code— 
keeping a record of it, with all links, notes and assigned data.



Editing an Address and Phone Entry

Once you have located the Address and Phone entry you want to edit, you may make changes to any field in the 
New Phone Entry window. Use this option if someone changes location (moves, joins a new company, etc.) or 
changes their business or home phone number.

To edit an address and phone entry

1 Select the entry that you would like to edit in the Address and Phone book. 

2 Click the Edit button.  The New Phone Entry window opens with all the Address and Phone 
information for this record.

3 Make changes to the appropriate fields and click Save.

See Also:
Locating existing Phone entries



Editing an Appointment

Appointments are often dependent on other people’s schedule. Consequently, your appointment schedule can 
change often during the day. You can make changes to any appointment description, start time, notes or 
attachments.

To edit an appointment

1 Select Edit Appointment from the Edit menu. This opens the Appointment Properties window.

2 Under the Appointment Information tab you can make changes to the date, duration or description of 
the Appointment. You can also add or delete any attachments to the Appointment. (If you change the date 
field, this appointment will no longer appear on the appointment schedule for this day)

3 Under the Notes tab you can add or edit your appointment notes.

4 Under the Alarms tab you can set how many minutes before the appointment you would like an alarm to 
go off.

See Also:
Moving an appointment
Adding notes to an appointment



Editing or Deleting a Task Category

You can change your Task Categories to fit your current situation. For example, if you complete a project and begin 
another, you may want to delete or edit the category for the old project.

To edit a task category

1 Select Task Categories from the Options menu.

2 Select the category you would like to change in the Category window.

3 Click the Edit button. The Edit Task Category dialog box appears.

4 Make any changes to this category and click OK.

To delete a task category

1 Select Task Categories from the Options menu.

2 Select the category you would like to delete in the Category window.

3 Click Delete. A dialog box will appear asking you "Delete the selected category?"

4 Click Yes.



Editing/Deleting Address and Phone Categories
You may find that you need to change or delete an Address and Phone book category. For example, you create an 
Address and Phone category “Franklin Quest Co.” for all your contacts at Franklin Quest Co. However, you soon 
find yourself with a number of contacts at Franklin Quest Co. It’s time to create more specific categories. You can 
create new categories for each division of Franklin Quest Co. (Franklin Quest Sales, Franklin Quest Technology, 
Franklin Quest Product Support, etc.). You can change or delete any existing category in the Address and Phone 
Categories window.

To edit a category

1 Select Edit Address and Phone Categories from the Options menu. The Edit Categories dialog box 
appears.

2 Select the category that you would like to edit and click Edit.

3 The Category dialog box appears. Make any changes and click OK.

To delete a category

1 Select Edit Address and Phone Categories from the Options menu. The Edit Categories dialog box 
appears.

2 Select the category that you would like to delete and click Delete.



Editing/Deleting a Quote

To edit an existing quote

1 Locate and open the quote you want to edit. See Locating a Quote.

2 Select the quote you would like to change and click the Edit button 

or 
Select Edit Quote from the Edit menu.

3 Make any changes to the quote and click OK.

To delete a quote

1 In the Favorite Quotes window, click on the quote you want to delete.

2 Click the Delete button. 



Encrypting Your Database

By encrypting your database and creating a password for your ASCEND 97 program you can feel secure that your 
information is safe. Encrypting the database makes ASCEND 97 files unreadable outside of the ASCEND 97 
program. While ASCEND 97 can decipher the encrypted text, other users that may have access to your computer 
cannot read these files.

To encrypt your ASCEND 97 database

1 Open the ASCEND 97 Tools and Utilities program.

2 Click the Encrypt Database button.     The Encrypt Database window appears.

3 Click Yes to encrypt your ASCEND 97 database. A window appears confirming the encryption that says 
“Database is encrypted.”
4 Click OK. Your database is now secure.

See Also:
Decrypting your database
Setting a password



Enhanced Features in ASCEND 97
If you’re already familiar with ASCEND, 97 you’ll appreciate the program’s enhanced features, including:

¨ Enhanced Global Search

¨ Refined Prioritized Daily Task List: weekly, monthly and yearly views

¨ Enhanced Appointment Schedule: daily, weekly, monthly and yearly views

¨ Improved printing features for the Franklin Day Planner pages, or labels and envelopes 



Entering Appointment Notes

To enter an appointment note

1 Click on an existing appointment and click in the Notes field below the Appointment Schedule daily view. 

or

Select Edit Appointment from the Edit menu and click the Notes tab. Enter any notes for this 
appointment.

2 When you’ve finished entering your note, click back on the Appointment field. A pencil icon appears 
indicating there is a note attached to this appointment.

3 To review an appointment note, click on the pencil icon in the appointment slot. The appointment notes 
appear in the notes window.



Entering Intermediate Steps

To enter an Intermediate Step

1 Click the View All pyramid button.

2 Select a Long-Range Goal and click the Add Item button 
or 
Select Add Value, Goal or Task from the Edit menu. The Add Item dialog box appears.

3 Select Intermediate Step and click OK. The Intermediate Step dialog box appears.
4 In the Description field, enter a step toward your Long-Range Goal. 
5 In the Clarifying Statement field, describe exactly what you will do to complete this step.

6 In the Priority field, enter a priority (A1, A2, A3). You don't have to prioritize your Intermediate Steps now; 
you can enter steps, then prioritize them in the Values and Goals window. In the meantime, ASCEND 97 
lists your steps in the order that you entered them.

7 If you want, you can enter dates in the Start Date and End Date fields. 

8 Click Save. The Intermediate Step now appears under the Long-Range Goal associated with it.

See Also:
Creating repeat or daily tasks 
Entering a repeat task
Entering a one-time task



Entering Long-Range Goals

To enter a Long-Range Goal

1 Click the View all pyramid button.

2 In the Values and Goals window, click on a Governing Value to which you want to add a goal.

3 Click the Add Item button 
or
Select Add Value, Goal or Task from the Edit menu. The Add Item dialog box appears. 

4 Select Long-Range Goal and click OK. The Long-Range goal window appears.
Note:  If you are not able to select Long-Range Goal in the Add Item dialog box, make sure you have 

associated this goal with    a Governing Value in the Values and Goals window.

5 In the Description field, enter your goal.

6 In the Clarifying Statement field describe in a few sentences:

Why do you want to achieve this goal?

What do you hope to accomplish or change about yourself?

How will this goal help you live a Governing Value?

7 Complete the Priority, Start Date, and End Date fields.

8 Click OK. 

In the Values and Goals window, the Long-Range Goal now appears under the Governing Value it is 
associated with.

See Also:
Creating Intermediate Steps
Entering Intermediate Steps



Entering Task Notes

To add a note to a task 

1 Select    a task.

2 Click in the Notes field.

3 Enter    text.

You can also attach a file or object to the task.

See Also:

Attaching a file to a task

Attaching an object to a task

Linking a contact to a task



Entering a Governing Value

To enter a Governing Value

1 Open the Values and Goals window by clicking the Values and Goals button on the Main Tool Bar.  

or
Select Values and Goals from the Window menu. The Values and Goals window appears.

2 Click the View All pyramid button.  This displays any existing Governing Values, Long-Range Goals, 
Intermediate Steps, and Daily Tasks.

3 Click the Add Item button  
or
Select Add Value, Goal or Task from the Edit menu. The Add Item dialog box appears. 

4 Select Governing Value and click OK. The Governing Value dialog box appears.

5 In the Description field, enter a value description.

6 Write the value as a positive affirmation such as "I am successful in my work."

7 In the Clarifying Statement field, enter a brief statement describing why this value is important to you.

8 In the Priority field, enter a priority.

9 Click Save. The new value appears in the Values and Goals window.

See Also:
Setting Long-Range Goals
Entering Long-Range Goals



Entering a One-Time Task

You can create a value-related task in the Values and Goals window that appears in the Prioritized Daily Task List 
as well as your Productivity Pyramid.

To enter a one-time task in Values and Goals

1 Click in the View all pyramid button.  

2 Select an Intermediate Step and click the Add Item button 
or 
Select Add Value, Goal or Task from the Edit menu. The Add Item dialog box appears.

3 Select Daily Task and click OK. The Repeat Task dialog box appears.
4 Enter the name of the task in the Description field.
5 Enter a Priority (A, B, C, D) in the Priority field. Remember, the goal is to bring your daily actions in line with 
your Governing Values. Value-related tasks should be A priority values.

6 Enter    any notes associated with this task..

7 In the Starting Date and Ending Date fields enter the date you would like the task to occur, including the 
year.

8 Enter the Day you would like the task to occur in the Day field.

9 In the Month field, enter the Month you would like the task to occur. 

10 Click Save. The task now appears in the Values and Goals window and in the Prioritized Daily Task List.



Entering a Repeat Task in Values and Goals

You can create tasks that will occur within a specified time frame. For example, you can create a repeat task “Take 
physical fitness exam” that appears once every 30 days. 

To enter a repeat task in Values and Goals

1 Click in the View All pyramid button.  

2 Select an Intermediate Step and click the Add Item button 
or 
Select Add Value, Goal or Task from the Edit menu. The Add Item dialog box appears.

3 Click the Daily Task radio button and click OK. The Repeat Task dialog box appears.
4 Enter the name of the task in the Description field.
5 Enter a Priority (A,B, C, D) in the Priority field. Remember, the goal is to bring your daily actions in line with 
your Governing Values. 

6 Enter any notes associated with this task.

7 In the Starting Date    field enter the date you would like the task to first occur, including the year. In 
Ending Date enter the date you would like the task to end. 

8 For a task that occurs only once a year, complete the Day and Month fields.

9 Complete the Every field to have the task reappear after a certain number of days, weeks, or months. For 
example, to create a task that repeats every 30 days, enter 30 in the Every field and click Days radio 
button.

or

Complete the Weekdays and Weeks boxes to determine what days of the week and how many weeks a 
month the task needs to occur.



Entering a Task on the Master Task List

To enter a master task

1 Open the Master Task List module.

2 Select the category where you wish to enter the task.    You can create Master Task List Categories if 
desired.

3 Enter the task in the first available line. You can use your mouse or the TAB key to move between 
columns. If you wish, click the Notes field to add a note to the task. 



Exporting Address and Phone Data

To export names, address and numbers

1 Open the Address and Phone Listing View.

2 Select Import/Export Wizard from the File menu. The Import/Export Phone Wizard window appears. 

3 Click the Export to another program radio button. 

4 Click Start. The Address and Phone Export window appears.

5 Choose the fields you want to export.

6 Use the Move Up and Move Down buttons to arrange the fields in the order you want them exported.

7 Click Next.

8 Choose the records you want to export.

9 Click Next.

10 Choose the format you would like to export, from the Format pull-down menu.

11 Click Next.

12 Click Export. A window appears noting how many records were exported.

13 Click OK.



Favorite Quotes



Finding Past Journal Entries

The Index Entries dialog box automatically lists all index entries by date.

You can narrow your search for a specific index entry by:

¨ Searching a specific date range.

In the Display Options box, select a beginning search date and an ending search date.    The list of index 
entries is now limited to dates that fall within the range you specified.

¨ Searching by name.

In the Sort By box, check the Name field. Index entries are now listed by name.

¨ Searching by date.

In the Sort By box, check the Date field. Index entries are now listed by date.



Finding Text in a Red Tab File

To find specific information within a Red Tab file

1 Open the Red Tab you want to search

2 Select Find from the Edit menu. The Find dialog box appears.

3 Enter the text you want to find.

4 Specify if you want to search for a whole word only, such as “in” instead of “inside”.

5 Specify if you only want to search for text that is in the same case.

6 Click Find Next.



Focusing on a Value
To make it easier to concentrate on building your Personal Productivity Pyramid, you can focus all of your attention 

on one value by clicking the Focus button.  When you focus on a value, all other values are “collapsed” (their 
goals, steps and tasks are removed from the display.)

To focus on a value
1 Click to highlight the value on which you want to focus.

2 Select Focus on a Value from the View menu.

or 

Click the Focus button  on the toolbar.

3 Notice that all other values are collapsed.
4 To focus on another value, simply click on that value.
5 To turn focus off, repeat step two or click any pyramid button.



Formatting Text in the DRE

To format text in the Daily Record of Events

¨ Select the text that you would like to format and click on the formatting buttons in the Daily Record of 
Events Tool Bar.

See Also:
The Daily Record of Events Tool Bar



Forwarding tasks in Prioritized Daily Task List Preferences

In the Task Forwarding box you can:

¨ Delete the task priority after a task has been forwarded a certain number of times

¨ Forward incomplete tasks to the Master Task List

To set your forwarding options in the preferences window

1 To delete an A,B or C task priority after the task has been forwarded a certain number of times enter a 
number in the Times to forward A, B, & C Tasks field.

2 To delete a D task priority after the task has been forwarded a certain number of times, enter a number in 
the Times to forward D Tasks field.

3 To forward incomplete tasks to the Master Task List after they have been forwarded a certain number of 
times, enter a number in the Forward to Master Task List field.

4 When you are finished setting your Prioritized Daily Task List Preferences, click OK. 



Get Incomplete Tasks

When you can see all of your incomplete tasks on the current date, it is easier to determine which tasks need to be 
completed, which tasks need to be deleted, which tasks need to be forwarded to another date in the future, and which 
tasks need to be transferred to the Master Task List.

To get incomplete tasks

1 Click the Get Incomplete Tasks button  to bring all incomplete tasks to the current date. 

2 A dialog box appears asking "Move all incomplete tasks to current list?"
3 Click Yes. All of your incomplete tasks will appear on your task list for the current day.
4 You can now determine if they should be completed, forwarded or deleted. 



Getting Help



Getting Started with 



Global Preferences

To set your Global Preferences

1 Select Preferences from the Options menu.

2 Select Global Preferences from the Preferences menu. The Global Preferences window opens.

3 Click Synchronize Dates Between Modules to enter data on the same date within different modules.

For example, you have scheduled an appointment three weeks in the future and you want to set related 
tasks and Daily Record of Events notes for the same date. Rather that move each module to the selected 
date with the Date Control bar you can click Synchronize Dates Between Modules and all modules 
automatically open to the date that appears in the Appointment Schedule.

4 Click Show Quote of the Day on Startup    to display a positive reinforcement each morning when you 
open the ASCEND 97 program.

5 Click Show Governing Value on Startup to display the goals you created in the Values and Goals 
module. 

6 Enter your area code in the Area Code field. (This way ASCEND 97 will not dial an area code when the 
number you are calling has this same area code.)

7 If you must dial a prefix to place a call then enter it in the Dialing Prefix field.

8 If you must dial a suffix or a calling ID number after you place a call, then enter this number in the Dialing 
Suffix field.

9 Enter the dialing format you will be using in the Phone Format field.

10 Click OK.



Global Search



How to Learn About ASCEND 97
To learn to use ASCEND 97 software quickly, we suggest that you do the following:

¨ Read The Day Planner Quick-Reference Card

¨ Start using ASCEND 97 software and experiment as you go

¨ Refer to ASCEND 97 Online Help and the ASCEND 97 User’s Guide

¨ If you can’t find the answer to your question in the User’s Guide or ASCEND 97 Online Help, call the 
ASCEND 97 Product Support team at    1-801-975-9999.

Where to learn more

If you would like to learn more about increasing your personal productivity through effective time 
management, you can attend TimeQuest: Increasing Productivity through Value-Based Time 
Management seminar. In addition to live seminars, Franklin Quest Co. also offers motivational books, 
tapes and videos. Call 1-800-654-1776 for more information.



How to Register

To register your copy of ASCEND 97

1 Fill out the postage-paid registration card in the ASCEND 97 package. 

2 Mail it to Franklin Quest Co.

Note:    If you are upgrading from ASCEND 5.0, you are already registered with your previous version.    
However, we welcome your comments and you may register again if you would like.

3 If you have any questions about registering ASCEND 97, you may call the Franklin Technical Support 
Team at    1-801-975-9999 or send E-mail to support_win@franklinquest.com. 



Identifying Governing Values

Governing Values are the first step to building your Productivity Pyramid. Governing Values are the principles and 
ideals that define who you are, or who you want to be. They can be traits or beliefs, like honesty or a belief in a 
higher power, or represent life-long ambitions, like physical fitness or financial security. Some samples of 
governing values include:

¨ I am successful in my work

¨ I am physically fit.

¨ I am financially secure

To identify your values, ask yourself two questions:

1 What are the highest priorities in my life?

2 Of these priorities, which do I value most?

Keep a list of your values, adding to it with each new value you discover.

See Also:
Entering a Governing Value
Setting Long-Range Goals



Importing Address and Phone Data
When you import a text into the Address and Phone module, you can specify the fields you want to include.

To import names, addresses, and numbers

1 Open the Address and Phone book.

2 From the File menu, choose Import/Export Wizard. The Import/Export Wizard window appears.

3 Click the Import from another program radio button.

4 Click the Start button, the Address and Phone Import window appears.

5 Click Browse. The Open window appears.

6 Select the file you wish to import, then click Open and return to the Address and Phone window.

ASCEND 97 returns to the Address and Phone Import window. This window allows you to select the 
available fields that reflect the names, addresses, and numbers you have selected for Importing.

7 Click Next.

8 Choose each field you wish to import, then choose the related ASCEND 97 field.

9 Click Next. The Address and Phone Import window appears.

10 Click Import to import and add the data to your Address and Phone listings.

11 A dialog box will appear stating the number of Entries Imported, click OK.



Indexing Journal Entries

You can organize your Journal information for quick reference by using the Index feature.

To open the Journal index

Open the Journal window and click the Index button 

or

Select Index Entries from the Options menu. The Index Entries dialog box appears. The Index 
window appears.

Within the Index Entries dialog box you can: 

¨ List all index entries

¨ View entries for a specific time frame

¨ Sort entries by name and date

¨ Mark special entries

¨ Add new index entries

¨ Edit or delete existing entries

See Also:
Adding a Journal Index entry
Editing Journal Index entries



Inserting a Name

To insert a name in a ASCEND 97 text field

1 Click in the text field in which you would like to insert a name.

2 Select Insert Name from the Insert menu. The Insert Name dialog box opens.

3 Enter a name in the Find field or select a name from the contact list.

4 Select the information you would like to include by checking the Paste Options boxes.

5 Click Insert. The contact appears in your notes field with the Information you selected.



Inserting a Name in the DRE

For instant access to contacts related to a note, you can insert the Phone and Address information directly into 
your Daily Record of Events. For example, you need some additional information from the business associate you 
spoke to earlier today. Fortunately, you imported his name and phone number into your Daily Record of Events so 
all the information you need is in one place.

To insert a name in the Daily Record of Events

1 Open the Daily Record of Events.

2 Select Insert Name from the Insert menu. The Insert Name dialog box opens with your contacts listed in 
the window. (You can list contacts by name or company by selecting one in the Sort By box.)

3 Select the contact who’s information you would like to insert. 

4 Select at least one of the options in the Page Options box.

5 Click Insert.

The contact information that you have selected will be inserted into your Daily Record of Events notes.



Inserting a Name in the Journal

You can insert Address and Phone Book information for an individual into your Journal entry by using the Insert 
Name function.

To insert a name in a journal entry

1 Select Insert Name from the Insert menu. The Insert Name window appears.

2 Select the name that you would like to insert.

3 Select which information you would like to paste in this Journal entry in the Paste Options box.

4 Click Insert. The information should appear in the Journal entry.



Inserting an Object

To insert an object in ASCEND 97

1 Click in the text field you would like to insert the object.

2 Select Insert New Object from the Insert menu. The Insert Object dialog box opens.

3 Select Create New or Create from file by clicking in the appropriate radio button.

4 If you select Create New, then select the type of object from the Object Type window.

If you select Create from file then click the Browse button and find the object you would like to insert.

5 Click OK to insert the selected object into your notes field.



Inserting an Object in the DRE

You can use the Daily Record of Events as a place to store important information. For example, rather than search 
all your programs for the pie chart you created for Monday’s meeting, simply import the object into your Daily 
Record of Events.

To insert an object into the Daily Record of Events

1 Open the Daily Record of Events

2 Select Insert New Object from the Insert menu. The Insert Object window opens.

3 Select whether you would like to create a new object or insert an object that has already been created by 
selecting Create New or Create from File.

4 If you select Create from File then browse to the object you would like to insert and click Insert

or 

If you select Create New, then select the type of object you are going to insert and click Insert.

An icon or object document will appear in the DRE window.



Inserting an Object in the Journal

Since the Journal uses ASCEND 97’s Text Editor feature you can insert an object directly into your Journal entry.

To insert an object in a Journal entry

1 Select Insert New Object from the Insert menu. The Insert Object window appears.

2 Select whether you would like to Create New or Create from File by clicking    the preceding radio button.

3 If you select Create New, then select the type of object you will be inserting 

or

If you select Create from File, then click Browse and select the object you would like to insert. Click 
Insert.

4 Click OK.

5 Click Done in the File Attachments window.

6 An object should appear in the Journal entry box.



Inserting the Date and Time

To insert the Date and Time into an ASCEND 97 text field 

1 Click in the field you would like to enter the Date and Time.

2 Select Insert Date and Time from the Insert menu. The Date and Time dialog box appears.

3 Select the format that you would like the date and time to be inserted.

4 Click OK.



Journal



Linking Appointments to Contacts

To link a contact to an appointment

1    Select    an appointment.

2    Click on the Link icon. 

3    The Contact Link Selection List dialog box appears. The Contact Link Selection List dialog box    displays all 
names and companies listed in the Address and Phone directory. 
4    In the Sort By box, select    whether    you would like to view the listing by name or    company. 
5    Click Add to add contacts to this appointment. If you would like to attach all contacts to this appointment 
task, click Select    All.

6    When you are finished adding contacts, click OK. A small link appears on the right side of the 

appointment. The Link icon also changes to interlocked links. 



Linking a Task to a Contact

To link a task to a contact

1 Select    a task.

2 Click on the Link icon. 

3 The Contact Link Selection List dialog box appears. 
The Contact Link Selection List dialog box    displays all names and companies listed in the Address and 

Phone directory. 
4 In the Sort By box, select    whether    you would like to view the listing by name or    company. 
5 Select a contact and click Add to add this contact to this task. If you would like to attach all contacts to this 
task, click Select    All.

6 When you are finished adding contacts, click OK. A small link appears on the right side of the task column 

the contact is linked to and the Link button appears with interlocked links.



Loading a Filter
You must apply the filter criteria to each of the Address and Phone records where you want to apply the filter. For 
example, if the Franklin Quest filter includes Franklin Quest Co. in the Company field make sure all Address and 
Phone records you want to include in this filter contain Franklin Quest Co. in the Company field.

To Set a Filter

1 Click the Filter button. 

or
Select Set Filter from the Options menu. The Phone Filters window appears.

2 Click on the filter you want to apply to the Address and Phone book.
3 Click the Set Filter button.
4 Click Close. All Address and Phone listings that meet the selected filter criteria appear in the Address and 
Phone window.



Locating Existing Address and Phone Entries
After you have entered all your contacts into your Address and Phone book, you can easily locate them with the 
Address and Phone book’s searching capabilities. There are two ways to search for an existing Address and 
Phone entry, the Search feature and filters.

¨ If you are searching for an individual or company, use the Find field.

¨ If you are searching for a list of entries (such as a list of contacts for a company), use the Phone Filters 
option.



Locating Information in Global Search

To locate information using Global Search

1 Select Global Search from the File menu. 

or 

Click the Global Search button on the Floating Calendar.     The Global Search window appears.

2 In the Search for field enter the word or group of words you wish to locate.
3 In the Search where box, select the ASCEND 97 modules you would like to search.
4 In the From field enter the date you would like to begin your search. 
5 In the To field enter the date you would like to end your search. 

6 Click Search. ASCEND 97 displays the search results in the module and Description field. 

7 Click on the entry you would like to view in the Module and Description field. The Additional Information 
field displays task status, task priority, description, category, date entered, address and phone number, 
etc.

8 To find out more information about a Global Search selection click the Go To button. 

9 Global Search locates where the information was found and opens the related ASCEND 97 window.

10 Select Reset to begin another search.

See Also:
Additional Searching Capabilities



Locating a Quote

The Filter option lets you locate a quote or types of quotes using the author’s name, key words or categories as 
search criteria.

To locate a quote using a filter

1 To find a quote, open the Favorite Quotes window. 

2 Click the Filter button 

or
3 Select Filter from the Option menu. The Filter Quotes dialog box appears.
4 Enter the search criteria. 
5 Click OK. The search results appear in the Favorite Quotes window. 



Maintenance Tools and Utilities



Making ASCEND 97 Work For You

Use ASCEND 97 software in a way that is most productive for your work environment and lifestyle. Here are a few 
suggestions of how to adapt ASCEND 97 software to fit your style:

ASCEND 97 at work

If you use a desktop computer regularly, you can use ASCEND 97 software to plan your day, schedule your 
appointments, make phone calls and so on. While traveling, or in meetings, you can keep a printed copy of your 
weekly or monthly schedule with you. 

ASCEND 97 at home

If you use a computer and printer at home, you can plan your daily activities in the ASCEND 97 program in the 
morning, print out your day’s tasks and appointments and work from the printed pages until you get back to your 
computer.

ASCEND 97 between work and home

To use ASCEND 97 both at home and work, install ASCEND 97 on both computers and use a disk or 
modem to transfer your ASCEND 97 data between the two computers.

ASCEND 97 on the go

If you use ASCEND 97 on a laptop or notebook computer, you have the advantages of portability—you’ll be able to 
take your personal information wherever you go. 

What if you don’t use your computer every day?

Many of the ASCEND 97 windows are useful even if you are only at your computer a few times a month. For 
example, you can enter information in the Address and Phone book once, print attractive listings and simply 
update as needed. 



Master Task List



Master Task List Categories

Categories allow you to store tasks under different classifications. Five categories (Home, Work, Misc. A, Misc. B, 
and Personal)    are provided for you. You can create as many as you want.

To create Master Task List categories

1 Select Edit Categories from the Options menu.

2 Type the name for your Master Task List category in the Category box. Your categories can be anything:    
Business, Family and so on.

3 Click Add.

To delete a category

1 Select Edit Categories from the Options menu.

2 Highlight the category you wish to delete.

3 Click Delete.

To rename a category

1 Select Edit Categories from the Options menu.

2 Click to highlight the category you want to rename.

3 Inside the text box, type in the new name, then click Rename.



Monthly View

The Monthly View is a five-week calendar that displays all your appointments for the current month. You can edit 
appointments and view notes, files and contact links for appointments in the monthly view.    The Monthly View can 
be opened from any view within the Appointment Schedule.

To open the Monthly View

1 Open the Appointment Schedule

2 Click the Monthly View icon in the Appointment Schedule Toolbar. 

or
Select Monthly View from the View menu of the Main Menu bar. 

Within the Monthly View you can view all of your appointments for each day. When you click on a specific 
appointment you can view the notes, alarms, attached files and contact links for an appointment.

To add an appointment in the Monthly View

1 Click on the day that you would like to add an appointment.

2 Click the Add Appointment Button.     The Add Appointment dialog box appears.

3 Enter the name of the appointment in the Appointment field.
4 Move the appointment time block to the starting time with the keyboard arrows.    To adjust the length of the 
appointment, hold down the Shift key and use the keyboard arrows.
5 Click OK. The appointment now appears on the Monthly View. 

6 When you click on the appointment in the Monthly View you can add notes, set an alarm and link files and 
contact to the appointment.

To move an appointment in the Monthly View

1 Place the cursor on the appointment you wish to move.

2 Click and hold the left mouse button to grab the appointment. If you have successfully grabbed the 
appointment a small box will appear at the base of the mouse arrow.

3 Drag the appointment to its new location and release the left mouse button.



Moving Master Tasks to the Prioritized Daily Task List

When you’re ready to schedule a task you’ve been storing, you can easily move it back to the Prioritized Daily 
Task List using the Move Task to Date window. In this window, you tell ASCEND 97 what day you want the task 
moved back on your Prioritized Daily Task List.

Using Move Task to date

1 Click the task on the Master Task List.

2 Do one of the following:

¨ Click on the Move Task button, located on the tool bar.

¨ Select Move Task from the Edit menu.
3 Select the date you want the task to appear on the Prioritized Daily Task List.

4 Click OK.

The task is moved to the Prioritized Daily Task List on the date indicated.



Moving Tasks to the Master Task List

When it becomes clear that you won’t be able to get to a daily task for a while, you can move it from the Prioritized 
Daily Task List to the Master Task List and store it until you are ready to work it back into your daily schedule.

There are two ways to move a task to the Master Task List:

¨ Automatic Forwarding

¨ Manual Forwarding

To set automatic forwarding

1 Open the Prioritized Daily Task List module.

2 Select Preferences from the Options menu.

3 Select Prioritized Daily Task List Preferences from the Preferences menu. The Prioritized Daily Task 
List Preferences    window appears.

4 In the Times to forward before Master Task List field, enter the number of times you would like 
ASCEND 97 to forward a daily task until it is moved. When the task has been forwarded the selected 
number of times, ASCEND 97 will ask you if you want to move it to the Master Task List. If you choose 
Yes, make sure you select a category for the task.

Moving Tasks to the Master Task List with Drag and Drop

1 Open the Master Task List and select the category where you want to store the task.

2 Open the Prioritized Daily Task List.

3 Place the cursor on the task in the Prioritized Daily Task List. Click and hold the left mouse button. 

4 Drag the task to the first open slot on the Master Task List, then release the LEFT mouse button.



Moving a Task to a New Date

You can move a task to a future date with the Move To button. 

To move a task to a new date
1 Select the task that you want to move.

2 Click the Move To button.  The Move Task To window appears.

3 Select the new date in the Move To field. 
4 Click OK.



Moving an Appointment

To move an appointment 

1 Click on the appointment you would like to move.

2 In the Notes field, click the Move To button.

3 The Appointment Properties window appears.
4 In the Date field, enter the date you want the appointment    to appear.
5 Click OK. 



Navigating Through Dates in ASCEND 97
You can navigate to an appointment in the past or the future simply by clicking on the Date Navigator bar. 

 One month back

One week back 

 One day back 

    Page date (+ or - the number of days from the current date) 
Double click on the Page Date area to instantly return to the current date.

 One day forward 

 One week forward 

 One month forward 

Go To Date calendar
To navigate to a specific date in the future you can use the Go To Date calendar. Click the Go To Date Calendar 

button  and click the date you want to go to on the calendar. Click OK. Your ASCEND 97 window will change 
to that date.



Navigating with Date Buttons
You can navigate to an appointment in the past or the future simply by clicking on the Date Navigator bar. 

 One month back

One week back 

 One day back 

    Page date (+ or - the number of days from the current date) 
Double click on the Page Date area to instantly return to the current date, 

 One day forward 

 One week forward 

 One month forward 

Go To Date calendar
To navigate to a specific date in the future you can use the Go To Date calendar. 

Click the Go To Date Calendar button  and type in or click on the date you want to go to on the calendar. 
Click OK. Your ASCEND 97 window will change to that date.



New Features in ASCEND 97
New    personal information management software for Windows combines the power of the Franklin Quest Time 
Management system with the convenience of your computer. This new version includes many new features such 
as:

¨ New Quick Prioritize feature. Prioritize your task list with the new Quick Prioritize feature. Simply click on 
the priority you want to assign your tasks and click on the tasks in the order you want to rank them.

¨ Store as many phone numbers and addresses as you want

¨ Attach files and objects to tasks and appointments

¨ Pilot ready software. The new Pilot is a pocket-size electronic organizer that connects to your computer and 
the power of ASCEND 97 software. 



Notes on Upgrading

ASCEND 5.0 users can upgrade all their ASCEND information to ASCEND 97 during installation or at a later time. 

Converting ASCEND 5.0 files during Installation

During installation of ASCEND 97, the ASCEND conversion program will ask for the path to any 
previous versions of the ASCEND program. If you have a previous version of the ASCEND program, it 
will ask you if you want to convert the information into ASCEND 97. 

Converting ASCEND 5.0 files after Installation

If you choose to convert your ASCEND 5.0 data at a later time simply run the Conversion program found in the 
Planner directory.

See Also:
Converting ASCEND 5.0 Information



Online Help

To open ASCEND 97 Online Help, select ASCEND 97 Help from the Help menu in any ASCEND 97 window. 
There are three windows in the ASCEND 97 Online Help file to assist you in locating the information you are 
looking for. The three windows are:

Contents The Contents window provides a hierarchical table of contents with information organized under 

each main area of the ASCEND 97 program. Click on a book  to view the help topics related to 
that subject. Click on a topic to move to the specific help window. 

Index The Index window provides an extensive list of all the subjects found in ASCEND 97 Online Help. Enter the 
subject you are looking for to narrow the search. Click on the topic where you need help.

Find Search for help by entering a word in the Find window. ASCEND 97 Help lists all topics that 
contain this word. 

Note:    When you look for hyphenated words, be sure to type the hyphen.

If you can’t find information in the ASCEND 97 Online Help file, it may be available in the Windows 95 User Guide: 
Introducing Microsoft Window 95. For example, “Adding a printer” and “Turning off your sound effects” are 
Windows functions, so they are available in the Windows 95 Online Help. You can access Windows 95 Online Help 
by clicking the Start button on your task bar and selecting Help.

See Also:
Printing a Help Topic
Context Sensitive Help



Opening a Red Tab Document

To open a Red Tab document

1 Click Open button. The Open dialog box appears.

2 Choose a Category from the drop-down list. 
3 Select a Red Tab title from the Red Tab Description box.
4 Click Open. (or double-click the selected Red Tab title). The selected Red Tab file opens.



Opening and Editing Turbo File Entries

To open and edit a Turbo File

1 Click on the Turbo File button on the Main Tool Bar    

or
Select Turbo File from the Window menu. The Turbo File window appears.

2 In the Turbo File window, double-click on the entry you would like to open
or
Click on the entry you would like to open and click the Edit button.

3 Enter or change information and click OK.



Organizing Your Tasks



Pilot and ASCEND Working Together



Printing Address and Phone Entries

To print your Address and Phone book

1 Open the Address and Phone window.

2 Select Print Address and Phone from the File menu. The Address and Phone Reports window appears.

3 Select the Report Style you want to print, Address and Phone Detail or Phone Index.

4 Select the range of addresses you want to print.

5 Select Pause After Each Page if you would like to print your Address and Phone book to your Franklin 
Day Planner pages. This gives you time to feed the Franklin Day Planner pages into your printer.

6 Select Page Break After Each Letter if you would like to organize your printed Address and Phone book 
by letter.

7 Click Select Size to choose your paper size.

8 Click Preview to view the page(s) you are going to print. This gives you a chance to ensure your margins 
are set correctly for the Franklin Day Planner page you are printing.

9 Click Close. The Address and Phone Reports window appears.

10 Click Print.



Printing Calendars

To print your Weekly Calendar

1 Select Print Calendars from the File menu. The Print Calendars window appears.

2 Select the items you would like to appear on this calendar by checking them in the Items to Print box.

3 Select the Weekly Calendar radio button in the Calendar Type box.

4 Select the dates to print in the From field.

5 Enter the # of weeks to print.

6 Select whether you would like your calendar printed on One Page or Two Pages in the Pages box.

7 Select how you would like the calendar to appear in the Calendar Layout box.

8 Click Paper Size to select the page type you want to print.

9 Click Preview to view your printing selection.

10 Click Print.

To print your Monthly Calendar

1 Select Print Calendars from the File menu. The Print Calendars window appears.

2 Select the items you would like to appear on this calendar by checking them in the Items to Print box.

3 Select the Monthly Calendar radio button in the Calendar Type.

4 Select the Month you would like to print in the From field.

5 Select whether you would like your calendar printed on One Page or Two Pages in the Pages box.

6 Click Paper Size to select the page type you want to print.

7 Click Preview to view your printing selection.

8 Click Print.

To print your Yearly calendar

1 Select Print Calendars from the File menu. The Print Calendars window appears.

2 Select the items you would like to appear on this calendar by checking them in the Items to Print box.

3 Select the Yearly Calendar radio button in the Calendar Type.

4 Click Paper Size to select the page type you want to print.

5 Click Preview to view your printing selection.

6 Click Print.



Printing Daily Record of Events

You can print the information you have entered on your Daily Record of Events page.

To print the Daily Record of Events

1 Open the Daily Record of Events.

2 Select Print Tasks, Appointments and Notes from the File menu. The Tasks, Appointments and Notes 
print window appears.

3 Select the date range to print.

4 Check Daily Record of Events in the Items to Print    box. Remove the check from any items that you do 
not wish to print.

5 Click Preview to view the page(s) you are going to print. This gives you a chance to ensure your margins 
are set correctly for the Franklin Day Planner page you are printing.

6 Click Setup. The Print Setup window appears. 

7 Select your printer and click OK.

8 Click Print.



Printing Journal Entries

You can print your Journal entries and the Journal Index to easily remember those important times in your life.

To print a Journal entry

1 Open the Journal Window

2 Select Print Journal from the File menu.

3 Select the page you are printing from the Filler Size drop-down menu.

4 Set the margins for the paper size you are printing.

5 Click Settings. The Print Setup window appears. 

6 Select your printer and click OK.

7 Click Preview to view your printing selection.

8 Click Print.

See Also:
Printing your Journal Index entries list



Printing Quotes

To print a listing of your favorite quotes

1 Open the Quotes window

2 Select Print Quotes from the File menu. The Print Quotes window appears.

3 If you would like to print a certain category of quotes, select it in the Category drop-down menu. 

4 Select the page you are printing in the Filler Size drop-down menu.

5 Set the margins for the paper you are printing in the Margins in inches box.

6 Click Setup. The Print Setup window appears. 

7 Select your printer and click OK.

8 Click Preview to view your printing selection.

9 Click Print.



Printing Red Tabs

To print a Red Tab

1 Open the Red Tabs window.    

2 Select Print Red Tabs from the File menu.

3 Select the page size you are printing from the Filler Size pull-down menu.

4 Set the margins for the paper size you would like to print.

6      Click Settings. The Print Setup window appears. Select a printer and click OK.

7      Click Preview to view your printing selection.

8      Click Print.



Printing Turbo Files

To print your Turbo Files

1 Open the Turbo Files window.

2 Select Print Turbo Files from the File menu. The Print Turbo Files window appears.

3 Select a range of Turbo File entries to print in the Date Range box.

4 To print specific Turbo Files within a date range, select a Category and Type from the pull-down menus.

5 Select the page you are printing from the Filler Size drop-down menu.

6 Set the margins for the paper you are printing to in the Margins in inches box.

7 Enter a range of entries to print in the Starting Date and Ending Date fields.

8 Click Setup. The Print Setup window appears. 

9 Choose your printer and click OK.

10 Click Preview to view your printing selection.

11 Click Print.



Printing Values and Goals

To print your Personal Productivity Pyramid

1 Open the Values and Goals window.

2 Select Print Values and Goals from the File Menu. The Print Values and Goals window appears.

3 Select the elements of your Productivity Pyramid that you would like to print in the Print Options box by 
clicking them.

4 Select All Values or Current Value in the Scope box.

5 Click Select Size. The Select Paper Size window opens.

6 Select the page size you are printing from the Page Size pull-down menu.

7 Click OK.

3 Click Preview to view the page(s) you are going to print. This gives you a chance to ensure your margins 
are set correctly for the Franklin Day Planner page you are printing.

6 Click Print.



Printing Your Appointment Schedule

To print your Appointment Schedule

1 Open the Appointment Schedule

2 Select Print Tasks, Appointments and Notes from the File menu. The Tasks, Appointments and Notes 
window appears.

3 To select your binder and filler size, click the Select Binder and/or Filler button, the Binder and Filler 
Options dialog box appears.

4 Select your binder and filler sizes from the Binder and Filler drop-down menus. Click OK.

5 Select the date range to print in the From and To fields (automatically defaults to today’s date).

6      Check Appointments in the Items to Print box. Remove the check from any items that you do not want 
to print.

7 To print a specific range of appointments, click Edit Appointment Range in the Appointments box.

8 Select the range you would like to print from the Range Time drop-down menu.

9 Click Preview to view the page(s) you are going to print. This will give you a chance to ensure your 
margins are set correctly for the Franklin Day Planner page you are printing.

10 Click Setup. The Print Setup window appears. 

11 Select the printer you want to print to and click OK.

12 Click Print.



Printing Your Journal Index Entries List

To print a listing of Journal Index entries

1 Select Print Journal Index from the File menu. The Print Index window appears.

2 You can print Index entries by name or date, by selecting from the Sort By pull-down menu.

3 Select the page you are printing from the Filler Size drop-down menu.

4 Set the margins for the paper you are printing to in the Margins in inches box.

5 Enter a range of entries to print in the Starting Date and Ending Date fields.

6 Click Settings. The Print Setup window appears. 

7 Select your printer and click OK.

8 Click Preview to view your printing selection.

9 Click Print.



Printing Your Master Task List

To Print your Master Task List

1 Open the Master Task List.

2 Select Print Master Task List from the File Menu. The Print Master Task List    window opens.

3 Select the page you are printing from the Filler Size drop-down menu.

4 If you would like to print a specific category of tasks, select from the Category drop-down menu.

4 Set the margins for the paper you are printing to in the Margins in inches box.

5 Enter a range of entries to print in the Date From and Date To  fields.

6 Click Settings. Select your printer and click OK. 

7 Click Preview to view the page(s) you are going to print. This gives you a chance to make sure your 
margins are set correctly for the Franklin Day Planner page you are printing.

8 Click Print.

Note:    If your printed page does not line up with your Franklin Day Planner page adjust the margins in 
the Margin Offset box.



Printing Your Prioritized Daily Task List

To print your Prioritized Daily Task List

1 Open the Prioritized Daily Task List

2 Select Print Tasks, Appointments and Notes from the File menu. The Tasks, Appointments and Notes 
print window appears.

3 To select your binder and filler size, click the Select Binder and/or Filler button, the Binder and Filler 
Options dialog box appears.

4 Select your binder and filler sizes from the Binder and Filler drop-down menus. Click OK.

5 Enter the dates you would like to print in the From and To fields in the Date Range box.

6 Check Tasks and Task and Appointment Notes in the Items to Print box. Uncheck the items that you 
do not want to print.

7 Click Preview to view the page(s) you are going to print. This gives you a chance to ensure your margins 
are set correctly for the Franklin Day Planner page you are printing on.

8 Click Setup. The Print Setup window appears.

9 Select the printer you want to print to and click OK.

10 Click Print.



Printing a Help Topic

To Print a Help Topic

1 Navigate to the Help topic you want to print.

2 Select Print Topic from the File menu

    or

Click the Print button. 

This prints only the Help topic you are currently working in.



Printing in ASCEND 97



Printing on Envelopes
If you are printing an envelope for an individual Address and Phone entry, have it open in the Address and Phone 
module.

To print address and phone entries to envelopes

1 Open the Address and Phone book.

2 Select Print Labels and Envelopes from the File menu. The Print window appears.

3 Click the Settings button to choose your envelope type.

4 Select #10 Envelopes (91/2 x 41/8) or Personal Envelopes (61/2 x 35/8) from the Print to pull-down 
menu.

5 To print only one envevelope for the entry you have selected, click the Use Selected Record checkbox.

6 Click Printer Setup to select a printer.

7 Click OK.

8 Select a sorting method under the Sort By pull-down menu.

9 Select the line you would like to appear first, in the 1st line pull-down menu.

10 Click the Preview button to view your page.

11 When you are ready to send the job to the printer, click Print.



Printing on Labels
To create a label for an individual entry

1 Open the Address and Phone book.

2 Select Print Labels and Envelopes from the File menu. The Print window appears.

3 Click the Settings button to choose your label size.

4 Select Custom Labels under the Print To pull-down menu.

5 Enter your label dimensions in the Label Setup box..

6 Enter the label you would like to start printing on in the Start Row and Start Column fields in the Start 
Position box.

7 Click Printer Setup to select a printer.

8 Click OK.

9 Select a sorting method under the Sort By pull-down menu.

10 Select the line you would like to appear first, in the 1st line pull-down menu.

11 Click the Preview button to view your page.

12 When you are ready to send the job to the printer, click Print.



Prioritized Daily Task List



Prioritized Daily Task List Preferences

You can personalize your task list by changing your Prioritized Daily Task List Preferences. Within the Prioritized 
Daily Task List Preferences window you can:

¨ Auto Forward/Sort tasks

¨ Assign colors to tasks

¨ Delete priorities from incomplete tasks

¨ Forward tasks to the Master Task List

Auto Forwarding your tasks in the Prioritized Daily Task List Preferences window

In the Task Auto Forward/Sort box you can :

¨ Auto Forward all incomplete tasks to the current date by clicking the Auto Forward Tasks option in the 
Task Auto Forward/Sort box.

¨ Auto Forward only your incomplete Repeat tasks to the current date by clicking the Auto Forward Repeat 
Tasks option in the Task Auto Forward/ Sort box.

¨ Auto Sort your task list each time you select the Quick Prioritize button in the Prioritized Daily Task List by 
clicking Auto Sort During Quick Prioritize in the Auto Forward/Sort box.

Organizing your tasks by color in the Prioritized Daily Task List Preferences window

In the Task Colors box you can assign a color to each of the following task categories.

¨ Normal Tasks

¨ Repeat Tasks

¨ Redo Tasks

¨ Delegated Tasks

See Also:
Assigning a Color to a Task Category
Forwarding tasks in the Prioritized Daily Task List Preferences



Prioritized Daily Task List Tool Bar

The following icons appear at the top of your Prioritized Daily Task List.

 Add a new task

Delete a task

Cut a task

Copy task

Paste task

  Prioritize your entire Task List

Assign action codes to task list

 Create Repeat Task

Get uncompleted tasks 

 Quick Prioritize



Prioritizing Tasks in the Prioritized Daily Task List window

You can prioritize each task as you enter it in the Prioritized Daily Task List ABC column.

To prioritize your tasks in the Prioritized Daily Task List Window

1 Enter your tasks for the day in the Prioritized Daily Task List so you can easily determine which tasks will 
be A, B, C and D priorities.

2 Assign an A, B, C and D priority to each task in the ABC column of your Prioritized Daily Task List 
window.

3 Review your A priority tasks to determine the rank of each task. Enter the rank (A1, A2, A3, etc.) next to 
the priority in the ABC column. Repeat this process for your B, C and D priority tasks.

4 Select Sort Tasks from the Edit menu. ASCEND 97 sorts your tasks so that your A1 task appears first, 
followed by your A2 task, etc.



Prioritizing Values and Goals

Prioritizing is important because sometimes you will have to make a choice between two of your values. Ask 
yourself, "Which of these values matters most?" By having a prioritized list, you will always know which value is 
more important during a conflict.

How do I prioritize my values?

Prioritizing your values is the process of placing them in sequence of importance. Rate your Governing Values as 
A, B, C or D. The tasks that fall under these Governing Values are then prioritized to show their importance in 
relationship to the value:

¨ Tasks with an A value are vital. Things that you must do today.

¨ Tasks with a B value are important. Things that you should do today.

¨ Tasks with a C value are less important. Things that you could do today.

¨ Tasks with a D value are personal tasks. Things that you need to do at home or after hours.

After a task is given the A, B, C or D category, the next step is to rank each task in order of priority. A1, A2, B1, C1, 
etc. based on the importance of each task within a priority group.

There are two different ways to prioritize your values in the Values and Goals window:

¨ The Prioritize field of the Values and Goals dialog boxes. 

¨ The Prioritize button in the Values and Goals main toolbar.



Prioritizing Your Task List

The ASCEND 97 program has three features to help you with the prioritizing process.

¨ The Prioritize Tasks window    

¨ The Quick Prioritize window    
¨ The Prioritized Daily Task List window.



Prioritizing in the Values and Goals Window

You can prioritize your values and goals as you create them by entering a priority and rank in the Priority Field.

Note: You don't have to prioritize your values at this point. You can prioritize your values in the Values and Goals 
window at a later date. If you don't prioritize your values at this time, ASCEND 97 prioritizes your values in 
the order that you enter them.



Product Support

Call Product Support at 1-801-975-9999, Monday through Friday, 7:00 a.m. to 6:00 p.m. Mountain Standard Time. 

Before calling, please be prepared with the following:

 1 Please have ASCEND 97 running on your computer. The support technician can troubleshoot best if 
you’re ready to step through the sequence that led to the problem. 

2 Have a pencil and paper in hand.

3 Know exactly what you did before the problem occurred and the exact wording of any error message that 
appeared on the screen. 

4 If you have several questions, write them down.

Additionally, please have the following information handy when you call, or provide it in a letter or fax:

¨ ASCEND version number

¨ Amount of memory (RAM)

¨ Operating system version

¨ Printer manufacturer, type and model

To reach Product Support by fax dial 1-801-978-1133. You can also reach Product Support by E-mail at: 
support_win@franklinquest.com    or http://www.franklinquest.com.



Purging Data

To purge data

1 Open the Tools and Utilities program.

Note:    You must close ASCEND 97 before you can open the Tools and Utilities program.

2 Click the Purge/Archive button.  The Purge/Archive window appears.

3 Select the ASCEND 97 information you want to purge in the Elements to purge box.
4 Enter the start and end date of the information you want to purge.
5 Click OK. A window appears with the message “Database is purged/archived.”
6 Click OK. You have finished the Purge process. 

See Also:
Archiving your ASCEND 97 Data
Compressing your ASCEND 97 data



Quick Prioritize

If your daily task list is not very long you can use the Quick Prioritize feature to assign priority and rank to a task.

To prioritize your task list with Quick Prioritize

1 Enter all of your tasks in the Prioritized Daily Task List

2 Click on the Quick Prioritize button. 

3 The Quick Prioritize dialog box appears next to your daily task list.
4 Review your task list to see if there are any tasks that need to be completed, forwarded, deleted or 
delegated. 
5 If there are tasks that need action before you begin prioritizing your daily task list, click on the appropriate 
action (Delete Task, Complete Task, Forward Task, Copy Complete Task) in the Quick Prioritize dialog box.

6 Move the mouse to your Daily Task List and click on the task you would like to assign an action. 

7 In the Quick Prioritize dialog box, click on A priority.

8 Move the mouse to your daily task list and click on the task you would like to assign priority A1. Notice 
that A1 appears in the ABC column next to the selected task.

9 Assign priority and rank to the rest of your A tasks.

Note: You must click on tasks in order of rank.

10 Repeat this process for all B, C and D priority tasks. 

11 Click Close.



Quitting ASCEND 97
When you quit ASCEND 97 all of your information will be saved. If you leave a Red Tab document open when you 
quit, then a dialog box will appear asking "Do you want to save changes?"    Click Yes to save.

To quit the ASCEND 97 program

¨ Select Exit from the File menu.



Quotes Tool Bar

Add quote - click to add a new quote.

Edit quote - click to edit an existing quote.

Delete quotes - click to delete a quote.

Filter quotes - click to filter quotes by categories and keywords.



Red Tabs



Red Tabs Tool Bar

The Red Tabs window incorporates a Text Tool Bar, making it easy to modify text with text editing features such as 
Font, Size, Color, Underline, Italic, etc. 

Red Tabs Tool Bar

Create a new Red Tab document 

      Open an existing Red Tab File

      Save a Red Tab file

      Cut selected text

      Copy text to clipboard 

      Paste text from clipboard

      Bold text

      Italicize text

      Underline text

      Change font style

      Align text left (default)



      Center text

      Align text right

      Insert bullet

      Date and Time stamp



Registration

Registering your copy of ASCEND 97 

Why should you register?

Registering you copy of ASCEND 97 entitles you to receive full customer service and technical support. In 
addition, you will be notified of product enhancements, upgrades, and special pricing on future versions of 
ASCEND 97 software.

See Also:
How to register



Repairing the Database

Repair Database resynchronizes ASCEND 97’s data files with the index files. In other words, it “cleans up” any 
potential problems your index files may have developed due to power failures, poor backups, etc.

To run Repair Database

1 Close your ASCEND 97 program and open Tools and Utilities.

Note:    You must close ASCEND 97 before you can open the Tools and Utilities program.

2 Click the Repair Database button.  The Repair Database window appears.

3 Click Yes to repair the database. A confirmation window appears which states, “Database is repaired.”
4 Click OK. The Repair process is complete.



Restoring Data From a Backup File

To restore data from a backup

1 Open the Tools and Utilities module.

Note:    You must close ASCEND 97 before you can open the Tools and Utilities program.

2 Click the Restore button 

or 
Select Restore from the File menu. The Restore window appears. 

3 Enter the name of the backup file you want to restore
or
Click the Browse button to search for the backup file.

4 Click OK. A window appears with the message “Database is Restored.”
5 Click OK. The Restore process is complete.



Saving Red Tabs

To save a Red Tab 

1 Click the Save button 

or
Select Save from the File menu.



Scheduling an Appointment with a Contact

To add an appointment to a contact

1 Click on the Address and Phone record to which you want to add a contact.

2 Click the Edit button.

3 Click the Contact History tab in the Address and Phone Detail window. The Contact History window 
appears.
4 Click the Add button and select Add a New Appointment. The Appointment window appears.
5 Enter an appointment Description .
6 Enter a date for the appointment in the Date field.
7 Use the Time Bar to adjust the Start Time and Duration of the appointment.

8 Check the Early Warning box to have ASCEND 97 remind you of your appointment.

9 Enter any notes for the appointment.

10 Click OK.

See Also:
Adding a task to a contact
Adding a call log
Attaching a file or object to a contact



Securing Your ASCEND 97 Files
Do not worry about other users reading private information, ASCEND 97 provides tools to ensure that your 
information remains secure. ASCEND 97 provides two methods of security that can be used individually or 
together.

To secure your ASCEND 97 files

¨ Create a password

¨ Encrypt your Database



Selecting a Filler Type and Binder Size

You can print your task list, appointments, phone lists, etc. directly to Franklin Day Planner pages or regular printer 
paper. You can select your Franklin Day Planner size and filler for a perfect fit and preview your pages to ensure 
they print correctly. Choosing the binder settings differs depending on what you are trying to print.

To set your binder and filler type in the Values and Goals or Address and Phone print windows

1 Click the Select Size button in the Values and Goals or Address and Phone print window. The Select 
Paper Size window appears.

2 Select the paper size you want to print to from the Paper Size drop-down list.

3 Click OK.

To set your binder and filler type in the Daily Record of Events, Journal or Red Tabs Print windows

1 Click the Settings button in the Daily Record of Events, Journal or Red Tabs Print window. The Print 
Setup window appears.

2 Select the paper size you want to print to from the Size drop-down list.

To set your binder and filler type in the Favorite Quotes, Turbo File or Tasks, Appointments and Notes 
Print windows

1 Click the Setup button in the Favorite Quotes, Turbo File or Tasks, Appointments and Notes    Print 
windows. The Print Setup window appears.

2 Select the paper size you want to print from the Size drop-down list.



Setting Dialing Preferences

You can change the view of the Contact Detail window to include dialing preferences for Autodial features and 
international preferences for address records.

To change your dialing preferences

1 In the Address and Phone window, select Preferences from the Options menu. Then select Global 
Preferences from the Preferences menu. The Global Preferences window appears.

2 Set an area code, dialing prefix and dialing suffix. 

3 Click OK. Now, these settings appear each time you use ASCEND 97’s Speed Dial feature.

To add international preferences to your address record

1 In the Address and Phone window, select Preferences from the Options menu, then select International 
Preferences from the Preferences menu. The International Preferences window appears.

2 Select the address specifications you would like in the Address and Phone Personal window: United 
States, Canada or International.

3 Click OK. The Contact Detail Address window reflects the preferences you selected.



Setting Long-Range Goals

Long-Range Goals are concrete expressions of your values. They give you clear vision of how you will bring your 
daily behavior in line with your Governing Values. You may have one Long-Range Goal for a Governing Value or 
you may have many.

To create a Long-Range Goal for a value, determine what you need to do to make your value a reality in your life. 
A Long-Range Goal is something that takes a significant amount of time, perhaps a year or more, and may involve 
many smaller steps. Goals for the value "I am successful in my work" could include:    “I will successfully 
accomplish my part of my team’s three main objectives by January 1, 1997.”

For each value, list the goals which will help you live by that value.

See Also:
Entering Long-Range Goals
Creating Intermediate Steps



Sorting Address and Phone Entries With Filters

Filters narrow the list of entries to those that meet specific criteria. For example, you can limit the listing of phone 
entries to only view those contacts who work for a certain company.

See Also:
Creating a New Filter
Loading a Filter



Special Days



The ASCEND 97 Desktop



The ASCEND 97 Text Editor

The Daily Record of Events incorporates the ASCEND 97 Text Editor tool bar. Features such as Font, Size, Color, 
Underline, Italic, etc. allow you to create attractive readable documents. The ASCEND 97 Text Editor allows you to:

¨ Include graphs, pictures, etc. with the power of Object Linking and Embedding (OLE). (An OLE object is an 
object that is created from one program and used by another.)

¨ Format your notes

The ASCEND 97 Text Editor is available in the: 

¨ Daily Record of Events

¨ Red Tabs

¨ Journal

The ASCEND 97 Text Editor includes the following tool bar

      Cut selected text

      Copy text to clipboard 

      Paste text from clipboard

      Bold text

      Italicize text

      Underline text

      Change font style

      Align text left (default)



      Center text

      Align text right

      Insert bullet

      Date and Time stamp



The ASCEND 97 User's Guide

How can ASCEND 97 help you organize your life? The ASCEND 97 User’s Guide provides an overview of each 
ASCEND 97 window and explains special features that help you bring your daily activities in line with your 
governing, values so you can concentrate your time on what matters most to you. For example, did you know you 
can display your working time and personal time by color? 

Note: While the User’s Guide will help you navigate through the ASCEND 97 program and explain where to find 
special features and how they can help you, you’ll find many of the detailed steps to perform each ASCEND 
97 function in these ASCEND 97 Online Help files.



The Address Window
Keep an current record of an individual’s work and home addresses in the Address window.

To enter an address for an individual 

1 Select a description from the Description field drop-down list. You can choose any of the following 
descriptions: Home, Mailing, Shipping and Work.

2 Enter the street address in the Address Line #1 field.

3 Enter the P.O. Box, Suite number, etc. in the Address Line #2 field.

4 Complete the City, State, Zip Code and Country fields.

5 Click the Notes tab to add notes to this record. 



The Address and Phone Book



The Find Field

To search for an existing Address and Phone book entry using the Find field, enter the name of the contact in the 
Find field. The entry should appear highlighted in the Address and Phone book window.

Note:    When using the Find field, as you type Address and Phone entries sort alphabetically. 



The First Step to Organization

The first step to organizing your life is organizing your day. ASCEND 97 software incorporates the Franklin Time 
Management principles to help you focus your daily activities so you spend more time doing the things that are 
most important to you.

The Daily Planning Procedure 
As taught in the TimeQuest® seminar.

1 Select an environment free from distractions.

2 Review values and goals.

3 Review prior day's Prioritized Daily Task List for any incomplete activities.

4 Review prior day's Daily Record of Events page.

5 Review today's prescheduled events/appointments.

6 Review Master Task List for specific activities for today's Prioritized Daily Task List.

7 Write appropriate activities in the Prioritized Daily Task List.

8 Update daily schedule from Monthly Calendar.

9 Review the next few days' schedules for preparation purposes.

10 Prioritize the day's activities according to what is Vital (A), Important (B), and Optional (C). Remember the 
difference between vital and urgent. Analyze your vital tasks and assign A1, A2, A3, etc. accordingly. 
Assign numbers to Bs and Cs as well.



The Floating Calendar

The Floating Calendar is    a one-month calendar containing a toolbar and date control (month) buttons. To open 
the Floating Calendar select Calendar from the View menu.    You can use the Floating Calendar to:

¨ Change the page date quickly

¨ Open the ASCEND 97 Global Text Search dialog box

¨ View Special Days

¨ Access the speed dialing command

¨ View Timers

The Speed Dial Button 

The Speed Dial button can be used if you have a modem. If you have a modem connected, you can click on this 
button to bring up the ASCEND Speed Dial dialog box. 

 The Global Search Button

The Global Search button is a powerful text-searching tool that searches your ASCEND files for key word(s). 

The Special Days Button

The Special Days button allows you to designate recurring special days such as holidays, birthdays, anniversaries, 
etc., and one-time special days such as vacations and business trips. 

The View Timers Button

The View Timers button allows you to track how long a task actually takes to complete. 

See Also:
Changing the Date with the Floating Calendar



The Important Dates Window
Keep track of important dates related to this Address and Phone record in the Important Dates window.

To enter important dates for this contact

1 Enter the name of the individual related to the occasion in the Name field.

2 Enter the Date of the occasion in the Date field.

3 Complete the Gender field to assist you in purchasing a gift or selecting a card for an individual. For 
example, It’s Kelly Green’s birthday. The gift you select for Kelly may be different depending on whether 
Kelly is a male or a female.

4 Select a category from the drop-down list in the Category field.

5 Click the Save button. 



The Journal Tool Bar

The Journal incorporates a Text Tool Bar to assist you in modifying text with text editing features such as Font, Size, 
Color, Underline, Italic, etc.

      Cut selected text

      Copy text to clipboard 

      Paste text from clipboard

      Bold text

      Italicize text

      Underline text

      Change font style

      Align text left (default)

      Center text

      Align text right

      Insert bullet



      Date and Time stamp

      View the index entries



The Main Tool Bar

The Main Tool Bar contains ten icons, each representing an ASCEND 97 module. You can click and drag the tool 
bar to anywhere within the ASCEND 97 window. Clicking on an icon opens a module. You can also open ASCEND 
97 modules from the Window menu or by using the key command shortcuts below.

Tip: 

You can turn the tool bar on or off by selecting Main Toolbar from the View menu.

      Appointment Schedule Control+Shift+F5

     Turbo File Control+Shift+F10

     Quotes Control+Shift+F3

      Prioritized Daily Task List Control+Shift+F2

      Master Task List Control+Shift+F4

      Values and Goals Control+Shift+F9

      Daily Record of Events Control+Shift+F1

        Red Tabs Control+Shift+F8

      Address and Phone Book Control+Shift+F6

      Journal Control+Shift+F7



The Notes Window
Use the Notes window to keep a record of important details for this phone record, such as “Tom Green was 
promoted to VP of Marketing.”

To create notes for an Address and Phone record

1 Enter text in the text window. 

2 Click the Important Dates tab to add important date records to this Address and Phone record. 



The Personal Productivity Pyramid



The Personal Window
The Personal tab opens when you open the New Phone Entry window. 

Enter the following information in this window:

1 Select a salutation from the Salutation drop-down list.

2 Enter the Last name of the individual in the Last field.

3 Enter the first name of the individual in the First field.

4 Enter the name of the contact's spouse in the Spouse field. 

5 Click the Private box if you do not want this record to appear in your Address and Phone List view.

6 Enter the name of the contact’s company in the Company field.

7 Enter a title in the Title field.

8 Enter the name of the contact's assistant in the Assistant field.

9 Enter the name of the Department in the Department field.

10 Select a category from the drop-down list in the Category field.

11 Enter an E-mail address in the E-Mail field. 

12 Check the Speed Dial box to add this record to your Speed Dial window.

13 Check the VIP box if you consider this a very important record. VIP records are labeled in the Address 
and Phone window.

14 Enter the Phone numbers for this record in the Phone Numbers box.

15 Select a description from the Description field. You can choose from the following categories:    Home, 
Car, Fax, Mobile and Work.

16 Click the Address tab to add addresses to this record. 



The Prioritize Tasks Window
If your Daily Task List is long you may want to use the Prioritize Tasks Window to assist you in the prioritizing 
process. The Prioritize Tasks window allows you to group tasks into A, B, C or D priorities. This option can make 
the ranking process easier by allowing you to view all of your important tasks in one location. 

In the Prioritize Task window, all unprioritized tasks appear in the Unprioritized Tasks box. Any tasks that have 
been assigned a priority appear in the A,B,C and D box.

To prioritize your task list in the Prioritize Task window

1 Enter all of your tasks in the Prioritized Daily Task List.

2 Click on the Prioritize Tasks button.  The Prioritize Tasks window appears.

3 Review your task list to see if there are any tasks that need to be completed, forwarded, deleted or 
delegated. These tasks do not belong on your Prioritized Daily Task List for today and should be taken care of before 
you begin the process of prioritizing your day.
4 If you find a task that needs to be taken care of before prioritizing, click on the task and click on the 
appropriate button (Complete, Forward, Delete, Delegate, or Complete and Forward). Use the calendar to forward 
any tasks that should be completed at a future date.

5 Click on all the tasks that you consider “A” priority. 

6 Click the A Tasks button.

7 Follow steps 5 and 6 to assign B, C and D priorities to the remaining tasks.

8 To change a priority, select the task and click on the appropriate Priority button. 

Ranking Tasks in the Prioritize Task window

1 When all tasks have a priority, you can rank them by clicking the Rank button. The Rank Tasks window 
appears. All unranked “A” tasks appear in the Unranked box. 

2 To assign a Rank to a task, click on the task you would like to assign A1 priority and click the Rank #1 
button.

3 Click on the task you would like to rank A2 and click on the Rank #2 button. 

4 Assign a rank to each unranked task and click OK. Your B priority tasks automatically appear in the 
Unranked Tasks box.

5 Assign a rank to each B priority task and complete the same process for your C and D priority tasks. 
When you are finished ranking your tasks the Prioritize Tasks window appears. 

6 Click OK.

Note:    If you rank your task list a second time during the day, all completed, deleted or forwarded tasks 
lose their priority and rank and get moved to the bottom of the list.



The Values and Goals Wizard

Identifying your Governing Values and learning to bring your daily actions in line with what matters most to you is a 
very rewarding process.    However, it can also be very difficult. Many people find that the toughest part is getting 
started. The Values and Goals Wizard was created to assist you in this process. 

The Wizard is a unique tool that takes you step-by-step through the process of identifying your Governing Values 
and setting value-based goals. You can select from the Wizards list of sample values, or use the sample values to 
help you create your own. For each value you select, the Wizard guides you toward goals to bring your daily 
behavior in line with that value.

The power of the Wizard is that it’s structured enough to be easy, yet flexible enough to ensure that the values and 
goals you identify truly reflect your personality. You will leave the Wizard with the foundation of your Personal 
Productivity Pyramid firmly in place.

See Also:
Using the Values and Goals Wizard 



To Create a Monthly Repeating Task

Follow steps 1-6 for creating a Repeat task.

5 Enter the date you want the Monthly task to start appearing on your Prioritized Daily Task List in the Start 
field.

6 Enter the date you want to stop viewing the Monthly task in the End field.

7 Click Month in    the Every field. Enter 1 to view the task every month. Enter 2 to view the task every 
other month and so on.

Note:    The Monthly task appears on the day you enter in the Start field. For example, if you set 9/04/96 
as your start date the task will reappear on the fourth day of each month.

8 Click Save.

See Also:
Creating a Weekly Repeat Task
Creating a Yearly Repeat Task



To Create a Weekly Repeating Task

Follow steps 1-6 for creating a Repeat task.

7 Do one of the following:

¨ Complete the Every field. Enter 1 to have the task reappear each week. Enter 2 to have the task 
reappear every other week.

¨ If you only want the task to appear on certain weeks of the month, click in the Weeks box. For 
example, you want to pay your bills on the first and third Friday of the month. Click Friday in the 
Weekdays box and 1st and 3rd    in the Weeks box.

8 Click the weekdays you want the task to appear in the Weekdays box.

9 Click Save.

See Also
Creating a Monthly Repeat Task
Creating a Yearly Repeat Task



To Create a Yearly Repeating Task

Follow steps 1-6 for creating a Repeat task.

5 Enter the date you want the Yearly task to start appearing on the Prioritized Daily Task List in the Start 
field.

6 Enter the date you want the Yearly task to stop appearing on your Prioritized Daily Task List in the End 
field. For example, you may not want to keep a Repeat task for more than five years. If the start date of 
your Yearly task is 9/04/96, you can enter 9/04/01 in the End field and the Repeat task will stop appearing 
after five years.

7 Enter the day you want the task to appear in the Day field.

8 Enter the month you want the task to appear in the Month field.

9 Click Save.

See Also:
Creating a Weekly Repeat Task
Creating a Monthly Repeat Task



Tracking Turbo Files

The Turbo Files extensive search feature helps you locate any existing Turbo Files. There are two ways to find a 
Turbo File, you can search for a name in the Turbo File Listing box, or you can apply a Filter to your list and 
narrow your search.

Applying a filter

If you have a long list of Turbo File entries to search through, you can create a filter to narrow your search. You 
can create filter criteria based on description, keywords, location, category, and type.

To create a Turbo File filter

1 Click the Filter button

or
Select Filter from the Options menu.

2 Enter Filter criteria for the entry you are trying to find.
3 Click OK to apply the filter to your Turbo File list.



Tracking Your Information



Turbo File



Turbo File Tool Bar

Create a new turbo file.

Edit an existing turbo file.

Delete a turbo file.

Assign a filter to a turbo file.



Using ASCEND 97 with your Franklin Day Planner System

ASCEND 97 software is a perfect complement to the Franklin Day Planner system. The ASCEND 97 program has 
many of the features of the Franklin Day Planner, including the following:

¨ Prioritized Daily Task List 

¨ Appointment Schedule

¨ Daily Record of Events

¨ Monthly and Weekly calendars

¨ Address and Phone Book

¨ Values and Goals

¨ Special Days

In addition, ASCEND 97 includes many unique tools:

¨ Use the Turbo File to create and organize documents

¨ Record your personal thoughts in the Journal

¨ Store motivational quotes in Favorite Quotes 

¨ Schedule several different activities simultaneously with Timers

With the ASCEND 97 program, you can control personal information on your computer, print ASCEND 97 
information on Franklin Day Planner pages, then add the pages to your binder so that your vital information is with 
you at all times. 

How do the Day Planner and ASCEND 97 work together?

If you work at a computer during the day, you can enter most of your information directly into the ASCEND 97 
program, and only use the Day Planner when you are away from your computer. On the other hand, if you use 
your Day Planner often, you only need a few minutes a day to enter key items, such as future tasks and 
appointments from your Day Planner into the ASCEND 97 program. For example, you could spend 10 minutes 
planning your day with the ASCEND 97 program, print your daily tasks and appointments, and then work from the 
printed pages until you return to your computer. 

Do you need a planner to use ASCEND 97?

No. ASCEND 97 software is a very useful organization tool by itself. If you like, you can print on letter size (8 ½" x 
11") paper. 

If you would like to order a Day Planner

If you would like more information about Franklin Day Planner Binders, forms and accessories that work hand-in-
hand with the ASCEND 97 program, call 1-800-654-1776 to request a Franklin Quest Catalog.



Using HotSync Via Modem

You can synchronize the Pilot when you are away from your PC by using a modem. In order to perform a HotSync 
via modem, you need:

¨ A modem connected to your computer

¨ A modem connected to your Pilot 

¨ A special modem cable to connect the modem to the Pilot. This special cable may be ordered by calling 
Franklin Quest Product Services at 1-800-877-1814 in the United States and Canada. In all other areas, 
call 1-801-975-1776.

Note:    You must first HotSync at your computer before you can HotSync via modem.

To be able to conduct a HotSync via modem you must first configure your Pilot and your Computer

See Also:
Configuring Your Pilot

Configuring Your Computer

Conducting a HotSync via Modem



Using HotSync at Your Computer

The first time you use HotSync to synchronize your Pilot with your ASCEND 97 software, you must be at your 
computer.

1    If the HotSync Manager is not already running, double-click the HotSync Manager icon in the Franklin 
Day Planner program menu. The HotSync Manager window appears.

2 Make sure that Local is selected in the Options menu.

3 Press the HotSync button on the front of the Pilot cradle. The HotSync progress window appears on your 
computer.

4 When HotSync is complete, ASCEND 97 displays a final message: “You must now reset your Pilot.”

5 Click the Reset button on the Pilot screen.

See Also:
Using HotSync via Modem



Using Timers
Use Timers to help track how long a task actually takes to complete, or how long you want to spend on a task. 
Timers can also be an effective way of keeping track of time spent with clients for billing purposes.

To set a Timer

1 Click the Timers button  in the Floating Calendar and Tools window 

or
Select Timers from the File menu. The Timers window appears.

2 In the Timers window, click New. The New Timer window appears.
3 Enter a description.
4 By default the timer will count up. If you would like this timer to count down then check the box preceding 
Count-Down Timer. The Duration fields become available. Enter how much time you would like this timer to count 
down.

5 If you would like ASCEND 97 to play a sound when this timer is up then click the Sound button to browse 
for .WAV files.

6 Click OK. 

7 Click Start

To start a Timer

1 Click the Timers button on the Floating Calendar

or

Select Timers from the File menu. The Timers window opens.

2 Select a timer in the Timers window and click Start.

3 To stop the timer click Stop.



Using the ASCEND 97 Dialing Function
Let ASCEND 97 help you save time and effort with the Speed Dial feature. If you have a modem, you can use the 
Address and Phone window to dial phone numbers automatically. 

ASCEND 97’s dialing function works with a program called telephony. These tools work together to make dialing 
your phone as simple as clicking a mouse. For more information about telephony, see your Windows 95 User’s 
Guide.

To add an Address and Phone entry to your Speed Dial directory

1 In the Address and Phone window, select the Address and Phone entry you want to add to your Speed 
Dial directory.

2 Click the Edit Entry button. 

3 Check the Speed Dial box in the lower left-hand corner of the Personal window. This entry now appears 
in the Speed Dial directory.

To Dial a Number

1 Select Speed Dial from the File menu. The Speed Dial window appears.

2 Click on the individual you want to call.

3 Click on the number you want to dial in the Numbers box.

4 If you would like to include an Area Code, Dialing Prefix and Dialing Suffix select these options in the 
Include box.

5 Click Dial.



Using the Prioritize Window

When you have created your list of Governing Values and associated steps, you can prioritize and rank in the 
Prioritize window.

To prioritize values in the Prioritize window

1 Click the Prioritize button.  The Prioritize window appears.

2 The Prioritize window gives you two Governing Values to choose from. It asks you “Which of these Items do 
you feel is MORE important?”    Click the item you feel is more important. 

ASCEND 97 will continue to ask you until all of the items are ranked in a sequential order.



Using the Wizard

To use the Values and Goals Wizard

1 Open the Values and Goals window.

2 Select Wizard from the Option menu

or

Click the Wizard button in the Values and Goals Toolbar. 

The Values and Goals Wizard dialog box appears.
3 Select your age group and click Next. By selecting your age group, you may find the sample Values and 
Goals geared more towards your lifestyle.

The Wizard Summary dialog box opens, listing any values you’ve already identified.
4 To add a new value to this list, click Next. The Wizard Value dialog box opens. 

5 Click on one of the values listed to select it

or

If you don’t identify with any of the values listed, type a new value in the Enter one of your Values here 
field. The Wizard’s list of values may offer some ideas to help you create your own value.

6 Click Next. The Wizard Clarifying Statement dialog box opens, asking you to state the value as a positive 
affirmation. A positive affirmation is a statement that presents the value as if it were already a reality. A 
positive affirmation for the value “Financial Security” is “I am financially secure.”

7 Type your value in the form of a positive affirmation.

8 Click Next. The Wizard Clarifying Statement dialog box opens. A clarifying statement is a sentence or two 
that defines what the value means to you. It is your opportunity to personalize the value. A list of sample 
statements is provided.

9 Click on each statement that clarifies what the value means to you. You may select as many statements 
as you want.

or

Type in your own clarifying statement

or

Combine the two methods, clicking the statements you like and then personalizing them with your own 
statements.

10 Click Next. The Wizard    Long-Range dialog box opens. 

This dialog suggests some Long-Range Goals for your value. If you see a goal you like, you can select it 
from the list. You may select as many goals as you like. If you don’t see any goals with which you can 
identify, skip this step. You can always formulate your own goals later. 

Note: Notice how a clarifying statement appears for a goal when it is selected. You may edit this 
statement to suit your needs.

11 Click Next. The Wizard-Summary dialog box appears displaying the new value you have just created.

12 Repeat this process to create more Governing Values and Long-Range Goals. 

13 When you are finished, click Done. ASCEND 97 gives you the option to prioritize your values.

Prioritizing is the process of organizing your values in order of importance. This is necessary because at 
times one value may conflict with another. Prioritizing helps ensure you know which value is more 
important when you are forced to choose.

14 If most of your values are in place and you feel ready to prioritize them, click Prioritize.

15 If you only have a few values in place, or would like some time to think before prioritizing, click Done to 
exit the Wizard. You can always prioritize later using the Prioritize button in the Values and Goals 
window. 

16 If you click Prioritize the Prioritize dialog box opens. 

17 Here, ASCEND 97 randomly displays two values or goals at a time. Click the “1” or “2” button for the 
value which is more important to you. ASCEND 97 will continue to display your values two at a time. 
Continue to select the one which is more important.

18 When ASCEND 97 has cycled through the possible combinations, you are returned to the Values and 
Goals dialog box, with your values in order of priority.





Viewing Task Statistics

To view task statistics

1 Open the Prioritized Daily Task List

2 Click in the task field.

3 Select Task Statistics from the Options menu.

4 The Task Statistics dialog box will open. In this dialog box you can view information about the task and 
enter the Estimated and Actual Time.

5 Enter how long you think this task will take in the Estimated Time field.

6 Select a category for this task from the Category drop-down list.

7 After you have completed this task enter how long it took you to complete in the Actual Time field.



Viewing Your Completed Productivity Pyramid
By clicking on the pyramids in the Values and Goals Tool Bar, you can see different levels of your Personal 
Productivity Pyramid.

Click This Icon To View This Level

View your Governing Values

View your Governing Values and Long-Range Goals

View your Governing Values, Long-Range Goals and Intermediate Steps

View your complete Personal Productivity Pyramid (Governing Values, Long-Range Goals, Intermediate 
Steps and Daily Tasks)



Weekly View

To open the Appointment Schedule Weekly View

¨ Click the Weekly View button,  

or 

Select Weekly View from the View menu. The Weekly View window appears.

Adding an appointment in Weekly View

1 Click the Add Appointment button 

or
Select New appointment from the Edit menu.

2 The Add Appointment dialog box appears. Enter an Appointment description. 
3 Move the appointment time block to the starting time with the keyboard arrows.    To adjust the length of the 
appointment, hold down the Shift key and use the keyboard arrows.
4 Click OK. 



What is ASCEND 97?
The ASCEND 97 Franklin Day Planner software program is a personal information manager (PIM) for the Windows 
95 operating system. With the ASCEND 97 program you’ll always have your essential information at your fingertips. 
You can use ASCEND 97 to perform many tasks, including the following:

¨ Enter and prioritize daily tasks

¨ Schedule appointments and set alarms

¨ Take notes on commitments, conversations and ideas

¨ Store and print addresses and phone numbers

¨ Print your information on Franklin Day Planner pages or plain paper



What's New



Who Makes ASCEND 97?

ASCEND 97 Franklin Day Planner software is created by Franklin Quest Co., makers of the popular Franklin Day 
Plannerª system. Franklin Quest Co. has taken the proven time-management tools of the Franklin Day Planner 
and combined them with the power of a computer to create ASCEND 97 personal management software. Like the 
day planner, ASCEND 97 is an organizational tool that helps you gain control over your time and become more 
productive. 

How can ASCEND 97 increase your productivity?

With the Franklin Day Planner software program, you can perform many time-saving functions on your computer 
that are not possible with a paper-based planner, such as the following: 

¨ Create repeat tasks and appointments

¨ Set appointment alarms

¨ Store a virtually unlimited amount of information

¨ Search and retrieve information in ASCEND 97

¨ Print attractive forms for your binder

¨ Dial phone numbers automatically (requires a modem)



Yearly View

You can view appointments for any date within the Yearly view. Simply click on the date you want to view and the 
appointments and tasks for this date appear in the Yearly view detail window.

To open the yearly view:

¨ Click the Yearly View icon  in the Appointment Schedule Toolbar.

or 

Select Yearly from the View menu.




