
Motion Works MediaShop     : Interactive Video

Interactive Video (Hot Spot Video) is a software tool that adds interactivity to Video for Windows movie 
files.    This tool consists of two components:

1) a Visual Basic Custom Control, called the Interactive Video Control (IAVI.VBX). 

2) a stand-alone interactive video editor called the Interactive Video Tool (IAVIEDIT.EXE) that is used to 
specify Hot Rectangles for each frame of the movie that the interactive object is visible.

To learn how to use help, press F1.

Contacting Motion Works

Interactive Video Control

Interactive Video Tool



Contacting Motion Works

If you have any questions, comments, or suggestions,    Motion Works would like to hear from you.    You 
can contact Motion Works at:
 

Motion Works USA,
524 Second Street, San Francisco,
CA    94107,
U. S. A. 

Tel: 1-800-800-8476, Direct (415)-541-9333, 
Fax: (415)-541-0555



Interactive Video Control

Properties Run-Time Properties Events

Description The Interactive Video Control is a Custom Visual Basic Control that 
allows the user to define objects within an Audio Visual Interleaved or 
AVI movie and interact with those objects using Visual Basic. 

File Name IAVI.VBX

Object Type IAVI

Remarks This control requires Interactivity Data File with extension .IVD.    Also 
see the documentations on "Interactive Video Editor" for ways of 
creating interactivity data file. 

__________________________________________________________________________________

Distribution Note      When you create and distribute applications that use the Interactive Video Control, 
you should install the file IAVI.VBX in the customer's Microsoft Windows \SYSTEM subdirectory . The 
Visual Basic setup kit included with the Professional Edition provides tools to help you write setup 
programs that install your applications correctly.

__________________________________________________________________________________



PROPERTIES

There are a number of properties used to communicate between 
Interactive Animation and Visual Basic. The following is a list of all 
available properties for this control. Asterisk(*) denotes properties that 
apply to this control only or that require special consideration when 
used with it.

Properties

*About Name
BackColor TabIndex
BorderStyle TabStop
Caption Tag
*DataName Top
DragIcon Visible
DragMode Width
Enabled Height
*FileName
Index
Left



RUN-TIME PROPERTIES

Run-time properties are hidden away from the general 
properties list but can be used inside the Visual Basic 
program.    The following catergories of run-time 
properties are designed to give user movie control.

Run-time movie properties

*AddObjecRect *Displayed *MovieBottom
*AddObject *EditMode *MovieLeft
*Changed *FrameObjCount *MovieRight
*Cued *ListFrameObjBottom *MovieTop
*CurFrame *ListFrameObjID *ObjectCount
*CurObjectBottom *ListFrameObjLeft *Pause
*CurObjectCursor *ListFrameObjRight *Play
*CurObjectID *ListFrameObjTop *RunCursor
*CurObjectLeft *ListObjectCursor *Save
*CurObjectName *ListObjectID *SoundEnabled
*CurObjectRight *ListObjectName
*CurObjectTop *Loop
*DefaultCursor *MaxFrame



EVENTS
The following is a list of all the available events for this control. 
Asterisk(*) denotes events that apply to this control only or that require 
special consideration when used with it.

Events

*Frame *ObjMouseUp
*Load *ObjMouseMove
*Unload *Play
*ObjMouseDblClk
*ObjMouseDown



About Property

Description Displays an About box for the control which contains the name of the 
control, version number and the author.

Visual Basic Not Applicable

Remarks This property can only be used during development time and is 
activated by double clicking on the About property field which displays 
"Click here..."

Data Type Not Applicable



FileName Property

Description Provides the path and name of the digital movie file (with .AVI 
extension) loaded currently.    To invoke the "Open AVI file" dialog, 
simply double click the left mouse button on this property.

Visual Basic [form.]IAVI.FileName[=filename$]

Remarks The path of the .IVD file will also automatically appear under the 
"DataName" property once the .AVI movie is loaded. If the IVD file 
does not exist, then there is no interactivity defined for that digital 
movie.

Setting this property will close the current digital movie and load the 
specified interactivity data file (IVD).    Use "Interactive Video Editor" to 
define an interactivity file.

Data Type String



DataName Property

Description Indicates the path and name of the interactivity data file (with 
extension .IVD).    To invoke the "Open IVD file" dialog, simply double 
click the left mouse button on this property.

Visual Basic [form.]IAVI.DataName[=filename$]

Remarks Setting this property will load the interactivity file for use with the 
current digital movie (see FileName property).    If no objects or 
HotSpots (i.e. interactivities) are defined in an IVD file, this .IVD file will 
be destroyed upon termination of the program.    Use "Interactive Video 
Editor" to define an interactivity file.

Data Type String



CurFrame Property

Description Indicates the current frame of the digital movie being displayed.

Visual Basic [form.]IAVI.CurFrame[=setting]

Remarks Setting this property will seek the digital movie to the specified frame. 
Also see the Event "Frame" of this IAVI control.

Data Type Integer (LONG)



Play Property

Description Indicates if the digital movie is playing.

Visual Basic [form.]IAVI.Play[=setting]

Remarks Setting this property will either start and stop the movie.

Setting Description
TRUE Play
FALSE (Default) Stop.

Data Type Integer (Boolean)



Pause Property

Description Indicates if the digital movie is currently paused.

Visual Basic [form.]IAVI.Pause[=setting]

Remarks Setting this property will either pause and unpause 
the movie.

Setting Description
TRUE (Default) Indication to pause the movie.
FALSE Indication to unpause the movie.

Data Type Integer (Boolean)



Displayed Property

Description Indicates if the digital movie is currently displayed.

Visual Basic [form.]IAVI.Displayed[=setting]

Remarks Setting this property will hide and show the movie.

Data Type Integer (Boolean)



Cued Property

Description Indicates the conditIon of the cue for a digital movie.

Visual Basic [form.]IAVI.Cued[=setting]

Remarks This is a read-only property. Setting this property to TRUE will cue the 
selected digital movie for play-back.

Data Type Integer (Boolean)



SoundEnabled Property

Description Indicates if the digital movie will play any sound associated with the 
movie.

Visual Basic [form.]IAVI.SoundEnabled[=setting]

Remarks Setting this property will either enable or disable sound in the movie.

Data Type Integer (Boolean)



MovieLeft Property

Description Specifies the left offset coordinate of the movie window (in pixels).

Visual Basic [form.]IAVI.MovieLeft[=setting]

Remarks Note that the "origin" of the monitor is located at the top left corner.    
Any length to the right of or underneath the corner is considered 
positive.    Also see properties MovieTop, MovieRight and 
MovieBottom.    The following sketch indicates the different offset 
assigned to each of these properties.

Data Type Integer 



MovieTop Property

Description Specifies the top offset coordinate of the movie window (in pixels).

Visual Basic [form.]IAVI.MovieTop[=setting]

Remarks See also MovieLeft property for the co-ordinates' convention of the 
monitor.

Data Type Integer 



MovieRight Property

Description Specifies the right offset coordinate of the movie window (in pixels).

Visual Basic [form.]IAVI.MovieTop[=setting]

Remarks See also MovieLeft property for the co-ordinates' convention of the 
monitor.

Data Type Integer 



MovieBottom Property

Description Specifies the bottom offset coordinate of the movie window (in pixels).

Visual Basic [form.]IAVI.MovieBottom[=setting]

Remarks See also MovieLeft property for the co-ordinates' convention of the 
monitor.

Data Type Integer 



MaxFrame Property

Description Indicates the number of frames in the digital movie.

Visual Basic [form.]IAVI.MaxFrame

Remarks Since the internal program counter starts counting Frame number one 
at '0', the final number of frames stores in the program counter is 
MaxFrame - 1 not MaxFrame.

Data Type Integer (LONG)



EditMode Property

Description Indicates if the IAVI control is in edit mode where the interactivity data 
can be edited.

Visual Basic [form.]IAVI.EditMode

Remarks Setting Description
TRUE (Default) Activate EditMode.
FALSE Deactivate EditMode

Data Type Integer(Boolean)



ObjectCount Property

Description Indicates the number of objects defined for this digital movie. 

Visual Basic [form.]IAVI.ObjectCount

Remarks Since the first object is counted as '0' in the program counter, the last 
object is actually ObjectCount - 1 not ObjectCount. See also 
ListObjectID, ListObjectName and ListObjectCursor.

Data Type Integer



Changed and Save Properties

The following two properties are used for file management.

Property Name Type Description
Changed integer 

(Boolean)
Indicates if there are any 
changes in the data maintained 
by the IAVI control.    This 
property can only be changed 
from FALSE to TRUE under 
Visual Basic control. Setting the 
Save property (below) to TRUE 
will clear this property to FALSE.

Save integer 
(Boolean)

This is a set-only property. 
Setting this property to TRUE will 
save the current interactivity data 
to the file. Saving the file will 
clear the Changed property to 
FALSE.



ListObjectID, ListObjectName and ListObjectCursor Properties

The following are array properties.    Within Visual Basic, the array properties are accessed via the use of 
a subscript following the property name.    For example, ListObjectName(5) would refer to the name of the 
5th object name in the current movie. See also ObjectCount.

Property Name Type Description

ListObjectID integer This is an array property that contain all the 
object IDs of objects in the interactivity data. 

ListObjectName string This is an array property that contain all the 
object names of objects in the interactivity 
data.

ListObjectCursor integer This is an array property that contain all the 
object cursor IDs of objects in the interactivity 
data.

Related Topic:
Relationship between ListObject..., CurObject... and ListFranmeObj... properties



CurObjectID,CurObjectName,CurObjectCursor,CurObjectTop,CurObjectLeft,CurO
bjectRight, CurObjectBottom, DrawCurObjectRect, AddObject and AddObjecRec 
Properties

The following properties allow users to access the current object information in the Interactivity Video file 
via the Interactive Video Control.    Togther with AddObject and AddObjecRec properties, the user can add 
or delete objects in the interactivity files.

Property Name Type Description

CurObjectID integer A property used for holding the ID of an object 
while information is being sent to or received 
from the IAVI control.

CurObjectName string A property used for holding the name of an 
object while information is being sent to or 
received from the IAVI control.

CurObjectCursor integer A property used for holding the cursor ID of an 
object while information is being sent to or 
received from the IAVI control.

CurObjectLeft integer A property used for holding the left rectangle 
coordinate of an object while information is 
being sent to or received from the IAVI control.

CurObjectTop integer A property used for holding the top rectangle 
coordinate of an object while information is 
being sent to or received from the IAVI control.

CurObjectRight integer A property used for holding the right rectangle 
coordinate of an object while information is 
being sent to or received from the IAVI control.

CurObjectBottom integer A property used for holding the bottom 
rectangle coordinate of an object while 
information is being sent to or received from 
the IAVI control.

AddObject integer This is a set-only property. Setting this 
(Boolean) property to TRUE will add the object specified 

by CurObjectID, CurObjectName, and 
CurObjectCursor to the object list of the 
movie's interactivity data. Setting this property 
to FALSE will delete the object with the ID 
specified by CurObjectID.

AddObjecRect integer 
(Boolean)

This is a set-only property. Setting this 
property to TRUE will add the object rectangle 
to the current frame's interactivity data 
specified by CurObjectID, CurObjectLeft, 
CurObjectTop, CurObjectRight and 
CurObjectBottom. Setting this property to 
FALSE will delete the frame's object rectangle 



specified with the ID specified by 
CurObjectID.

DrawCurObjectRect integer
(Boolean)

This is a set-only property. Setting this 
property to TRUE will draw the object 
rectangle to the current frame's interactivity 
data specified by CurObjectID, CurObjectLeft, 
CurObjectTop, CurObjectRight and 
CurObjectBottom. Setting this property to 
FALSE will not draw the frame's object 
rectangle specified with the ID specified by 
CurObjectID.

Related Topic:
Relationship between ListObject..., CurObject... and ListFranmeObj... properties



FrameObjCount Property

Description Indictates the number of objects defined in the current frame of the 
movie.

Visual Basic [form.]IAVI.FrameObjCount

Remarks Since the internal program counter starts counting the first object at '0', 
the final number of objects stores in the program counter is 
FrameObjCount - 1 not FrameObjCount.

Data Type Integer (LONG)



ListFrameObjID, ListFrameObjLeft, ListFrameObjTop, ListFrameObjRight and 
ListFrameObjBottom Properties

The following properties allow users to maniplate the object information in a frame of the Interactivity file 
via the Interactive Video Control. The following are array properties meaning that they require subscripts 
to gain information access.    For example, ListFrameObjID(3) indicates the use of the third object ID of 
the current frame.

Property Name Type Description

ListFrameObjID integer This is an array property that lists the Objects 
that are defined for the current frame of the 
movie.

ListFrameObjLeft integer This is an array property that contains all the 
objects of the current frame's left rectangle 
coordinate.

ListFrameObjTop integer This is an array property that contains all the 
objects of the current frame's top rectangle 
coordinate.

ListFrameObjRight integer This is an array property that contains all the 
objects of the current frame's right rectangle 
coordinate.

ListFrameObjBottom integer This is an array property that contains all the 
objects of the current frame's bottom 
rectangle coordinate.

Related Topic:
Relationship between ListObject..., CurObject... and ListFranmeObj... properties



Loop Property

Description Indicates if the movie will loop to the beginning when the last frame is 
reached.

Visual Basic [form.]IAVI.Loop[=setting]

Remarks Setting this property will change the looping behaviour of the movie.

Setting Description
TRUE Re-start the movie once the end is reached.
FALSE (Default) Stop the movie once the end is reached.

Data Type Integer (Boolean)



RunCursor and DefaultCursor Properties

The following two properties are used for cursor status.

Property Name Type Description

RunCursor integer Indicates the cursor that is to be used when 
the movie is being played. The following is a 
list of the available cursors and their IDs:

List of Built-In Cursors:

Cursor Logical Windows
Resource Cursor Built-In Cursors
Name Number Label Name 

FINGER_CURSOR

HAND_CURSOR

HANDUP_CURSOR 1
HANDLEFT_CURSOR 2
HANDRGHT_CURSOR 3

HANDWALK_CURSOR 4

HANDGRAB_CURSOR 5

MAGNIFY_CURSOR 6

QUESTION_CURSOR 7
SOUND_CURSOR 8

10000 IDC_ARROW

10001 IDC_IBEAM

10002 IDC_WAIT

10004 IDC_UPARROW

10005 IDC_SIZE
10006 IDC_ICON

10007 IDC_SIZENWSE
10008 IDC_SIZENESW
10009 IDC_SIZEWE

10010 IDC_SIZENS

Property Name Type Description

DefaultCursor integer Specifies the cursor to be used if the cursor is 
over no defined object in the current frame of 
the movie. See also RunCursor.



Frame Event

Description Notifies Visual Basic that the current frame has changed.

Visual Basic Sub IAVI_Frame ( )

Remarks Parameters: FrameNum As Integer

Visual Basic
Example The following codes will play an .AVI movie and display the current 

frame number on label1 at real time.

Sub IAVI1_Frame (FrameNum As 
Long)

IAVI1.Play = True
Label1.Caption = "Current Frame no.:" + IAVI1.CurFrame

End Sub



Load Event

Description Notifies Visual Basic that the current movie has been loaded. This 
indicates that the run-time variables are now valid.

Visual Basic Sub IAVI_Load ( )

Remarks Parameters: None



Unload Event

Description Notifies Visual Basic that the current movie (if any) has been closed. 
This indicates that the run-time variables are no longer valid.

Visual Basic Sub IAVI_Unload ( )

Remarks Parameters: None



ObjMouseDblClk Event

Description Notifies Visual Basic that a double click was detected 
within the IAVI Control. The object's ID as well as the 
location of the mouse cursor is returned.

Visual Basic Sub IAVI_ObjMouseDblClk ( )

Remarks Parameters: X As Integer, Y As Integer, ObjID As 
Integer
                                                  ObjName As Integer



ObjMouseDown Event

Description Notifies Visual Basic that a mouse down was detected within the IAVI 
Control. The object's ID as well as the location of the mouse cursor is 
returned.

Visual Basic Sub IAVI_ObjMouseDown ( )

Remarks Parameters: X As Integer, Y As Integer, ObjID As Integer
                                    ObjName As Integer



ObjMouseUp Event

Description Notifies Visual Basic that a mouse up was detected within the IAVI 
Control. The object's ID as well as the location of the mouse cursor is 
returned.

Visual Basic Sub IAVI_ObjMouseUp ( )

Remarks Parameters: X As Integer, Y As Integer, ObjID As Integer
                                    ObjName As Integer



ObjMouseMove Event

Description Notifies Visual Basic that a mouse move was detected within the IAVI 
Control. The object's ID as well as the location of the mouse cursor is 
returned.

Visual Basic Sub IAVI_ObjMouseMove ( )

Remarks Parameters: X As Integer, Y As Integer, ObjID As Integer 
                                                  ObjName As Integer



Play Event

Description Notifies Visual Basic that the play status has changed.

Visual Basic Sub IAVI_Play ( )

Remarks Parameters: Play As Integer



Relationship between ListObject..., CurObject... and ListFrameObj... properties

The above diagram shows how ListObject... and ListFrameObj... properties are different from 
each other.    CurObject... properties are used togther with AddObject and AddObjecRec 
properties to add or delete objects in the interactivity files (essentially maniplating ObjectIDs 
which is unique to both Movie Object List and Frame Object List).

See Also... 
ListObject...
ListFrameObj...
CurObject...



Interactive Video Tool
Description: The Interactive Video Tool is an editor used to combine data from both 

an Audio Visual Interleaved or AVI file and text to produce an output 
file (an extension of IVD file) which will be used by the Interactive 
Video Control within Visual Basic.    The interactive video Control will 
then match the appropriate region of the AVI picture to the assigned 
text.

How To... 
(General Step by Step Tutorial )
The following are instruction steps of general and frequently used operations in the Interactive Video 
Tool.    Various ways of performing each of the general operation will be discussed.    For a detail 
discussion of every features and operations of this editor, please refer to the Reference Section.

Invoke the Editor
Open a Movie File
Use the General Object Name List
Use the Hot Object Name List
Add Object Name to Hot Object Name List
Delete Object Name from the Hot Object Name List
Create HotSpots on selected Objects
Move between different Frames of the Movie
Link HotSpots to different Objects on different Frames of the Movie
Change a HotSpot Object's Layer
Play a Movie
Save
Exit the Editor
Link the HotSpot Movie File to an Interactive Video Visual Basic Control

Reference Section...
User Interface, Menu and Dialogs Explained 

The Main Editor Screen
The    Movie Playing Screen
The Object Editor



To invoke the Editor

To use the Interactive Video Tool simply select "Run..." from the File menu in Program Manager and 
then execute "IAVIEDIT.EXE" (*** Note: Remember to enter the correct path as well ***).    Another way 

is to create a icon in the Program Manager for the application and then double click on the icon .



To Open a Movie File

Select "Open" under the File Menu Bar (the movie file should have an extension of .AVI).



To Create HotSpots on selected objects

Press down on the left mouse button and drag out a rectangle on the area of the bitmap where you want 
to identify as a HotSpot.



To Use the General Object Name List

The general object name list is shown underneath the combo box.    All members of this list are 
permanent.    The general object name list simply provides a selection of all the objects available to the 
hot object list.

Once the object name is selected and becomes "hot" (e.g. ),    this hot object name can 
be added to or changed positions in the hot object list.    To add an object to the Hot Object List, see topic 
To add an Object to the Hot Object Name List.    To Change Object Name Position, see topic To Change 
HotSpot Object Layer



To Use the Hot Object Name List

The hot object name list is shown as the following.

The list with a highlighted object is the hot object name list.    A highlighted member of this list can be 
deleted as instructed by the user.    To delete an object, member off the list, see topic To Delete Object 
Name from Hot Object List    .



To Add Object Name to Hot Object Name List

Select an object name by highlighting one object name from combo box (e.g. ), and 
then do one of the following to Add the object name to the hot object list.    Note that the object must be 
selected from the combo box first before adding to the hot object list.

Menu: Select "Add/Modify Rect" under Edit menu.

Key Board: Ctrl + A

Toolbar:    



To Delete Object Name from Hot Object Name List

Highlight a hot object name from the hot object name list, and then do one of the following to delete the 
object name from the hot object name list.

Menu: Select "Delete Rect" under Edit menu.

Key Board: Ctrl + D

Toolbar: 



To Move between different Frames of the Movie

Use the horizontal scroll bar to move along different frames of the Movie.    The frame counter is located 
at the bottom left corner of the bar to indicate the current playing frame.



To Link HotSpots to different Objects of a Movie

Steps in linking HotSpots to different objects of a Movie:

1. Select an object name under the combo box .

2. Create a HotSpot on a selected object.    (Assuming that the selected object exists under the current 
frame.    If the object does not exist in the current frame,    go to the frame where the selected object 
starts.)

3. Use the scroll bar to move to the next frame. (This step can be eliminated if "Auto Advance" is selected 
under the Options Menu.)

4. Repeat Steps2 and 3 until the last frame existence of the object in the movie.

5. Repeat Steps 1 to 4 for linking a new object to the movie.

Once the object is linked to an object name, the mouse will change to icon  when it is moved over the 
hot objects.



To Change a HotSpot Object's Layer 

Choices:

1. Bring an Object to the front of the screen
2. Send an Object to the back of the screen
3. Bring an Object one layer closer to the screen
4. Send an Object one layer away from the screen



To Bring an object to the front of the screen

Menu:    Select "Bring to front" under the Edit menu.

Toolbar: 

Click on the icon . The object that is the closest to the computer screen is located at bottom of the Hot 
Object List.



To Send an object to the back of the screen

Menu:
Select "Send to back" under the Edit menu to bring the selected object to the fartherest layer from the 
front of the screen.

Toolbar: 

Click on the icon .    The object that is the fartherest from the computer screen is located at top of the 
Hot Object List.



To Bring an object one layer closer to the screen

Menu:
Select "Bring higher" under the Edit menu to bring the selected object closer to the front of the screen.

Toolbar: 

Click on the icon    .    The object will go one layer down on the on Hot Object List.



To Send an object one layer away from the screen

Menu:
Select "Bring lower" under the Edit menu to bring the selected object farther from the front of the screen.

Toolbar: 

Click on the icon .    The object will go one layer up on the on Hot Object List.



To Play a movie

Select "Play" under the "Play Menu".    User may also select "start" or "end" under the same menu to start 
or end a movie respectively.



To Save an Edited HotSpot Movie file

Choose 'Save' or 'Save As...' from the File Menu.    For the Save As option, you will be prompted with the 
Save As... dialog, where you will have the opportunity to specify a filename of your choice as the name of 
the to-be-saved HotSpot Movie file. 



To Exit the Editor

Choose 'Exit' from the File Menu or left double-click on the editor window's system box (located on the 
top-left corner of the editor's window)



To link the HotSpot Movie File to an Interactive Video Visual Basic Control

1. Add the IAVI.VBX module to your Visual Basic project.    (Choose 'Add File...' from the the File Menu in 

Visual Basic).    The  icon will appear on the toolbox palette if the Interactive Video custom control 
is loaded successfully.

2. Double-click on the  icon on the toolbox to create a Interactive Video control on the Form you are 
working on.

3. Double-click on the FileName   property   from the Property Window and choose the Movie Data File that 
you have just created and saved using the Interactive Video Editor.    If the Movie Data file 
(extension .IVD) is loaded successfully, the Filename property should contain the path of Movie Data file 
created using the editor. 



Movie Editor Screen

The following is a sample figure of the Interactive Movie Editor: This Editor allows user to open, save 
and display an AVI file within the Editor window.



Movie Playing Screen

After the selection of the required .AVI file, the movie file will display on the Movie editor.
There is also a controller that provides various adjustment to the display file.      The controller is the 
heart of this Interactive Editor.

To start playing, just activate "Play" on the menu bar of the Movie Editor.    The following is an example 
of an .AVI movie screen.



Object Editor
Press this screen button  to activate the Object Editor.

The user may add or delete objects interactivity onto the AVI picture through the use of an Object Editor 
like the following diagram: (The three entries are Object ID,    Object Name and Cursor ID.    The ObjectID 
must be unique to each ObjectName, and the Cursor ID would identify different cursor icons associated 
with the specified AVI region. )

Note that the user must associate the selected region of the AVI picture with the text for every frame of 
the movie in order to allow interactivity throughout.    To select an Hotspot, the user can simply drag the 
mouse and release on the same region. An automatic frame number advance mode can be set through 
the 'Option Menu'. 

After editing the objects and saving the work, an    interactive data file (an .IVD extension file) will be 
generated.    This .IVD file together with its associated .AVI    file will be needed for the use of the 
Interactive Video Control.
 



Edit Object Activator Button

Activate this button will bring up the "Object Editor".



General Object Name List Combo Box

Click on the down arrow to see the general object name list.



Hot Object Name Area

Display of Hot object names.



File Menu

Open
Save
Save As
Close

Import Object

Exit



Edit Menu

Add/Modify Rect
Delete Rect

Bring to Front
Send to Back
Bring Higher
Send Lower



Play Menu

Start
Play
End



Options Menu

Auto Advanced
Loop Movie



Close

The Close menu item will save and clear any existing movie file in the session. 



Import Object



Start

Go to the first frame of the movie.



End

Go to the last frame of the movie



Auto Advanced

When this command is active, advancing between frames in a movie will beome automatic as HotSpots 
on an object is created.



Loop Movie

Activating this command will automatically loop the movie to the beginning when the last frame is 
reached.






