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Navigating in Allegro Business 500

Navigating Through Allegro Business 500

There are many ways of navigating through Allegro Business 500. You can select topics from the 
Contents screen, jump from one topic to another from a hot spot, browse through topics that are 
related to one another, retrace your steps backwards (topic by topic), or return to any previously 
viewed topic.



Navigating in Allegro Business 500

Using Links

Topics are linked to one another by means of hot spots. A hot spot can be a word or phrase, or a 
picture or part of a picture. Text hot spots may be underlined, and are usually displayed in a 
different color than the surrounding text. A picture hot spot may have a border around it. You can 
identify a hot spot by noticing the mouse cursor: it changes to a pointing hand when over a hot 
spot.

For example, point to the Navigating icon in the upper left-hand corner of this topic and you will 
see the cursor change into a hand, as shown below:

Click on this icon and it will jump to another topic, which in this case, is the Navigating in Allegro 
Business 500 menu.

In addition to jumping to other topics, hot spots can bring up popup windows. Popups are 
displayed over the main Allegro Business 500 window. To remove the popup, click anywhere 
outside of the popup, or press the ESC key. Click on this hot spot to view a popup window.



Navigating in Allegro Business 500

Browsing Through Topic Sequences

Related topics may be linked to one another using browse sequences. The browse feature lets 
you browse through topics, one by one.

To display the next or previous topic:
* Choose the >> button or << button in the Allegro Business 500    window, 

* Hit the spacebar key to go forward by one screen, or 

* Hit the shift spacebar key to go backward by one screen.

Browsing Through Page Notes

You may use Page Notes that you have created to browse through topics.

To display the next Page Note, choose the ->| button

To display the previous Page Note, choose the |<- button.

See Also
Using Links



Navigating in Allegro Business 500

Jumping to the Table of Contents

The contents button on the Allegro Business 500 button bar returns you to the main screen for 
your title.    If you are in the Main Menu, this screen shows you the basic category and book 
choices.    If you are in an individual book, this screen shows the Table of Contents for that 
particular book.      This screen is like a table of contents, from which you can select a variety of 
topics.

To look up a topic in an individual book:
1 Choose the Contents button in the Allegro Business 500 window to display the contents 

screen for that specific title.

2 Select the name of the topic you want to view from the list.

See Also
Browsing Through Topic Sequences



Navigating in Allegro Business 500

Returning to the Last Topic Viewed

Using the Go Back button, Allegro Business 500 lets you retrace your steps. In this way, you can 
step backwards through the topics viewed.

To backtrack through topics in the order you viewed them:
* Choose the Go Back button in the Allegro Business 500 window.

If the current topic is the first topic you viewed, the Go Back button appears dimmed.

See Also
Returning to Any Topic Viewed



Navigating in Allegro Business 500

Returning to Any Topic Viewed

As you view topics, Allegro Business 500 keeps a record of where you have been. The History 
button displays a list of the topics you've viewed, starting with the most recent. Select any topic 
from this list to return to it.

To jump back to a topic using the History button:
1 Choose the History button in the Allegro Business 500 window.

Allegro Business 500 lists the last 40 topics you have viewed in the History window.

2 Double-click the topic you want to view.

Use the scroll bar to see topics not visible in the list.

3 The History window remains displayed. You can choose another topic. You can also resize or 
move the History window.

Tip: You may want to arrange the Allegro Business 500 window and the History window so that they are side by side.

To close the History window:
* Choose Cancel, or double-click the Control menu box. Pressing the ESC key also closes the 

History window.

See Also
Returning to the Last Topic Viewed
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Finding Information

Ways to Find Information In Your Title

To find information in your title, you can use the following techniques:

- Choose topics from a keyword index

- Perform full-text searches for topic text

Using the index button, you can search on a keyword or words. When the keyword is found, 
Allegro Business 500 displays the topic, or a list of topics containing the keyword.

Using the Search button, you can search on any word or words in the topics. The Search feature 
not only takes you to the topic found, but highlights the word or words found by the search. You 
can use search operators such as AND, OR, NOT, THRU, and NEAR to further narrow your 
search.

See Also
Finding Information Using the Index

Using Full-Text Search



Finding Information

Using Full-Text Search

To search for topics that contain a certain word or phrase:
1 Choose the Search button in the Allegro Business 500 window.

2 In the Search by Word box, type a search query telling Allegro Business 500 what text you are 
searching for.

To enter a search query that you've searched on previously, select the search query from the 
drop-down list box.

3 Under Search In, select All Topics, Current Topic Only, or List of Previous Topics Found.

To search only the topic titles, choose the Options button and select this option, then choose 
the OK button.

4 Choose OK.

Allegro Business 500 lists the title of each topic containing a search hit in the Search Results 
dialog box.

See Also
Browsing Through the Search Results

Using Search Operators



Finding Information

Browsing Through the Search Results

When you choose the OK button to search for information, Allegro Business 500 lists the topics 
that contain search hits in the Search Results dialog box.

To view a topic in the list:
* Double-click the title.

Use the scroll bar to see titles not visible in the list.

or

* Use the Search Results buttons to move through topics.

To view Do this
Selected topic Choose the Go To button or double-

click the topic.
Search dialog box Choose the To Search button.
Next search hit in the 
current topic

Choose the Next Match button.

Previous search hit in 
the current topic

Choose the Previous Match button.

When you view a topic with search hits, Allegro Business 500 highlights the search hits in that 
topic. If you minimize the Search Results window, highlighting turns off until you maximize the 
Search Results window again.

To close the Search Results window:
* Choose the Cancel button in the Search Results window.

For your convenience, the Search Results window always appears on top of the Allegro Business 
500 window. You can resize it, move it, or you can minimize it to an icon and then restore it later 
when you need it.

See Also
Using Full-Text Search

Using Search Operators



Finding Information

Using Search Operators

When you use the Search button to search for information, you can use the search operators 
AND, OR, NOT, and NEAR to narrow your search. Each operator is described below. You can 
enter an operator in either lowercase or uppercase letters ("and" is interpreted the same as 
"AND").

AND

The AND operator selects topics containing all phrases connected by AND operators. If a phrase 
does not appear in quotes, any space between words in the phrase is assumed to represent an 
implicit AND. For example:

Bees love Honey

This phrase finds any topic containing the three words "Bees," "love," and "Honey." This is the 
same as specifying Bees AND love AND Honey. However, when quotes are used, Allegro 
Business 500 searches for the entire phrase. For example:

"Bees love Honey"

This phrase finds any topic containing the phrase "Bees love Honey."

OR

The OR operator selects topics containing either phrase connected by OR operators. For 
example:

Bees OR Honey

This query displays topics containing either the word "Bees" or the word "Honey."

NOT

The NOT operator selects any topic that does contain the phrase preceding NOT, but doesn't 
contain the phrase following NOT. For example:

Bees NOT Honey

This query finds topics containing the word "Bees" but not the word "Honey."

NEAR

The NEAR operator selects any topic in which one phrase appears within a certain number of 
words of the second phrase. The default value is 8 words. For example:

Bees NEAR Honey

This query finds any topic in which the word "Bees" appears within 8 words before or after the 
word "Honey."

To change the default value, choose the Options button in the Search dialog box and enter a 
new number in the NEAR Means Within box. Words that are next to each other are within one 
word of each other.

Tip:    You can choose the Hints button in the Search dialog box for a quick reminder on how to use search operators.

See Also
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Finding Information

Using Multiple Search Operators

When you use the Search button to search for information, you can use multiple search 
operators to define more complex search criteria. For example, if you enter honey AND bees 
NOT hives in the Search by Word box, Allegro Business 500 will match topics that contain the 
words "honey" and "bees" but do not contain the word "hives."

By default, operators are evaluated from left to right. You can use parentheses to specify a 
different order--operators within parentheses are evaluated first.

This query Searches for
honey OR bees AND hives Topics containing either the word honey or the 

word bees in addition to the word hives.
honey OR (bees AND hives) Topics containing the word bees and the word 

hives or topics containing the word honey.
honey OR bees NOT hives Topics containing either the word honey or the 

word bees but not the word hives.
honey OR (bees NOT hives) Topics containing the word bees but not the word 

hives or topics containing the word honey.

Tip:    You can choose the Hints button in the Search dialog box for a quick reminder on how to use search operators.

See Also
Using Full-Text Search

Using Search Operators
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Printing and Copying

Printing and Copying Information in Your Title

You may want to use information in your title in other applications, such as word processors. 
Allegro Business 500 lets you copy text onto the Windows Clipboard. From the Clipboard, you can 
paste the text into any Windows application. You can also print out topics, and change printers 
from within Viewer.

See Also
Printing Topics

Copying Topic Text



Printing and Copying

Changing Printers and Printer Options

Allegro Business 500 prints topics on the default printer. If you have installed more than one 
printer in Windows, you can make any of your installed printers the default printer. You can also 
change the default printer options.

To change printers:
1 From the File menu, choose Print Setup.

2 Select Specific Printer.

3 Select the printer that you want to change to, from the drop down list box.

If this file is not in the list box, switch to the Control Panel, select Printers, and activate the 
printer you want to use. Then switch back to Viewer.

4 Choose OK to close the Print Setup dialog box.

To change printer options:
1 From the File menu, choose Print Setup.

2 Choose the Options button to change the default printer options.

The options available depend on the type of printer you have selected.

3 Choose the options you want, and then choose OK.

4 Choose the OK button to close the Print Setup dialog box.

To change printer orientation, paper size, or source:
1 From the File menu, choose Print Setup.

2 Select Portrait or Landscape for the orientation.

3 Select the paper size you want from the drop down list box.

4 Select the paper source you want from the drop down list box.

5 Choose OK to close the Print Setup dialog box.

For more information on setting up printers, see your Windows documentation.

See Also
Printing Topics



Printing and Copying

Printing Topics

To print an entire Allegro Business 500 topic:
1 Display the topic.

2 From the File menu, choose Print Topic.

To print part of a Allegro Business 500 topic:
1 Display the topic.

2 From the Edit menu, choose Copy.

3 In the Copy dialog box, select the text you want to print, and then choose the Copy button.

4 Paste the text into a word processing application.

5 Use the Print command on the application's File menu to print the text.

See Also
Copying Topic Text



Printing and Copying

Copying Topic Text

To copy Allegro Business 500 text to the Clipboard:
1 Display the topic that contains the text you want to copy.

2 From the Edit menu, choose Copy.

3 Select the text you want to copy in the Copy dialog box.

4 Choose the Copy button.

To paste the Clipboard contents into another document, use the Paste command from the 
application's Edit menu.



Allegro Business 500 Help Contents

Annotating Your Title
Using Page Notes
Jumping to a Page Note
Annotating a Topic
Viewing an Annotation
Copying and Pasting Annotations



Page Notes

Annotating Your Title

The Page Note feature in Allegro Business 500 allow you to save your own information in your title. A 
Page Note is simply a marker which "saves your place" in the Allegro Business 500 title. Like any book, 
you can have many Page Notes in your title. When that particular Page Note is selected, Allegro Business 
500 takes you directly to a specific location in that topic.
Annotated Page Notes (indicated with the letter "A" in the Page Note) are simply notes or comments 
written on that particular Page Note.

See Also
Using Page Notes

Annotating a Topic with Page Notes



Page Notes

Using Page Notes

Just as you can paste notes in a printed book to mark specific references, you can place Page 
Notes at particular locations in the Allegro Business 500 topics you view frequently. Once you 
have placed a Page Note at a topic, you can quickly jump to that location in that particular topic 
from the Page Note menu.

To insert a Page Note:
1 Display the topic at which you want to place a Page Note.    The Page Note will be attached at 

the topic text at the top of the screen.

2 From the Page Note menu, choose Add.

The yellow Page Note icon will appear at the top of the page.

To remove a Page Note:
1 From the Page Note menu, choose Browse.

2 Select the Page Note you want to remove.

3 Choose Delete.

4 Choose Cancel.

To remove the current Page Note:

1 Click on the Page Note.

2 Click on Delete.

See Also
Jumping to a Page Note



Page Notes

Jumping to a Page Note

After you've inserted Page Notes, you can go directly to them at any time.

To go to a marked topic:
* From the Page Note menu, choose Browse.

* Point to the desired Page Note.

* Choose the Go To button.

To browse forward through the Page Notes:

* Click on the Page Note Forward Browse ->|.

To browse backward through the Page Notes:

* Click on the Page Note Backward Browse |<-.

See Also
Using Page Notes



Page Notes

Annotating a Topic

You can attach your own comments to a Page Note. When you annotate a Page Note, Allegro Business 
500 places an "A" in the Page Note icon. This "A" reminds you that there is an annotation attached to this 
topic.

To annotate a Page Note:
1 Create a Page Note.

2 Click on the yellow Page Note icon.

3 Move the cursor into the Annotation box and begin typing.    If you make a mistake, press 
Backspace or the Delete key to erase any unwanted characters and then continue typing.

3 Choose Save when you have finished the annotation.

To remove an annotation:
1 Display the Page Note where you made the annotation.

2 Click the Page Note icon.

3 Highlight the text you would like to remove, then hit the backspace key

4 Click on Save.

See Also
Viewing an Annotation



Page Notes

Viewing an Annotation

To view an annotation:
1 Display the Page Note that is annotated.

2 Click Page Note icon.

3 Choose the Clear button when you have finished reading the annotation.

See Also
Copying and Pasting Annotations

Using Page Notes



Page Notes

Copying and Pasting Annotations

You can copy text from an annotation to the Clipboard or paste text from the Clipboard into an 
annotation.

To copy text from an annotation to the Clipboard:
1 Display the Page Note where you made the annotation.

2 Click the Page Note icon.

3 If you want to copy all of the annotation, choose the Copy button.

If you want to copy only a portion of the annotation, select the text in the Annotate edit box, and 
then choose the Copy button.

To paste text from the Clipboard into an annotation:
1 Display the Page Note where you made the annotation.

2 Click the Page Note icon.

3 Position the insertion point where you want to paste the text.

To position the insertion point, point and click the mouse or press the arrow keys.

4 Choose the Paste button.

If any text is selected when you choose the Paste button, it is replaced by the new text.

See Also
Copying Topic Text
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Buttons and Menus

File Menu Commands

The File menu contains these commands:

- Open

- Print Topic

- Print Setup

- Exit

- Remember and Exit

Scroll down to see descriptions of each command.

Open

Displays a dialog box in which you can select and open a Allegro Business 500 title.

Print Topic

Prints the displayed topic (assuming you have a printer installed and turned on).

Print Setup

Displays a dialog box in which you can change printer settings before printing.

Exit

Closes Allegro Business 500.

Remember and Exit

Closes Allegro Business 500 and remembers your location.    The next time you open that 
particular book you will go directly to that location in the book.

See Also
Changing Printers and Printer Options

Printing Topics



Buttons and Menus

Options Commands

The Options menu contains the Set command, which allows you to select the following Allegro 
Business 500 Options:

- Location Bar

- Cruise Control Speed

- Page Note Notification

Location Bar

Creates a Location Bar icon at the bottom of the page.    The Location Bar graphically how much of 
the book you have read.

Cruise Control Speed

Allows you to set the Cruise Control speed either by directly entering an interval in the dialog box, 
or clicking on the scroll buttons to increase (right button) or decrease (left button) the page interval 
time.

Page Note Notification

Allows you to set an icon that indicates how close you are to a particular Page Note.    You may 
activate this option by clicking on the "Within" circle.    Then, enter the proximity for which the Page 
Note will appear in the dialog box.    The proximity value is based on the percentage of the curent 
book.    For example, if the proximity is set at 1%, the Page Note Direction Indicator will appear 
when you are in a topic that is within 1% of the nearest Page Note.    The Page Note Direction 
Indicator will point either upward, downward or both ways, thus indicating the closest Page Note.



Buttons and Menus

Page Note Menu Commands

The Page Note menu contains these commands:

- Add

- Delete All

- Browse

Scroll down to see descriptions of each command.

Add

Automatically adds a Page Note at the current location.

Delete All

Deletes all the defined Page Notes in the current book.    You must confirm that you would like to 
delete all these Page Notes.

Browse

Allows you to Browse though all the defined Page Notes..

See Also
Using Page Notes

Jumping to a Page Note



Buttons and Menus

Edit Menu Command

The Edit menu contains this command:

- Copy

Copy

Places a copy of the displayed topic in a dialog box, where you can select text to copy to the 
Clipboard.

See Also
Copying Topic Text



Buttons and Menus

Help Menu Commands

The Help menu contains these commands:

- Help on Allegro Business 500

- About Viewer

Help on Allegro Business 500

Displays the Allegro Business 500 Help topics. This is the same as pressing F1 while in Allegro 
Business 500.

About Viewer

Displays a dialog box which displays the Allegro Business 500 version and copyright information.



Buttons and Menus

Using the Button Bar

Use the following buttons to browse and look up information in Allegro Business 500.

Select any button from this illustration to find out what action it performs.

Using the Location Bar

Use the Location Bar to quickly move throughout the book you are using.

Click anywhere on this bar and you will immediately jump to that location in the book.    Double click on 
the bar, or click on the percentage indicator in the bottom right corner, to jump to a specific percentage 
location in the book.



Displays the contents screen for the open title.



Displays the index for the open title. You can select a word from the index list, and then display a 
topic that contains information related to that word. For more information, see Finding Information 
Using the Index.



Backtracks through topics in the order you viewed them. For more information, see Returning to the 
Last Topic Viewed.



Displays a list of the last 40 Allegro Business 500 topics you have viewed. Double-click any topic 
title to redisplay the topic. For more information, see Returning to Any Topic Viewed.



Allows you to search for any combination of words and phrases, and then browse the topics that 
contain search hits. For more information, see Using Full-Text Search.



Displays the previous topic in a browse sequence within the open title.



Displays the next topic in a browse sequence within the open title. Clicking the >> button is like 
turning the page in a printed book.



Starts Cruise Control within the open title.    Cruise Control automatically scrolls pages for you.    You 
may increase or decrease the Cruise Control speed by hitting the "+" or "-" keys on the numeric 
keypad.



Displays the next Page Note, based on your current location, that you have defined.



Displays the previous Page Note, based on your current location.



Keyboard Techniques

Using Accelerator Keys

The following is a list of keyboard shortcuts available in Viewer:

Keys Action
Ctrl+C, Ctrl+Ins Copies the displayed topic to 

the clipboard
Ctrl+Shift+Alt+F1 Jumps to the Contents screen
Ctrl+Shift+Alt+F2 Brings up the Index dialog
Ctrl+Shift+Alt+F3 Takes you to the last topic 

viewed (Go Back)
Ctrl+Shift+Alt+F4 Brings up the History list
Ctrl+Shift+Alt+F5 Displays the previous topic in 

the browse sequence
Ctrl+Shift+Alt+F6 Displays the next topic in the 

browse sequence
Tab Moves to next hot spot
Shift+Tab Moves to previous hot spot
Ctrl+Tab Highlights all hot spots
Esc Removes the top-most popup
SpaceBar Scrolls ahead one screen
Shift SpaceBar Scrolls back one screen
Page Down Scrolls ahead one screen
Page Up Scrolls back one screen
Alt Removes all popups



Contents button

The Viewer button that displays the contents screen for the open title.



Index button

The Viewer button that looks up topics associated with particular words or phrases defined by the title's 
author.



Go Back button

The Viewer button that backtracks through topics in the order you viewed them.



History button

The Viewer button that displays a list of the last 40 topics you have viewed.



>> button

The Viewer button that displays the next topic in the current browse sequence within the open title.



<< button

The Viewer button that displays the previous topic in the current browse sequence within the open title.



Search button

The Viewer button that searches for all topics containing a particular word or combination of words.



Hints button

In the Search dialog box, the button that shows examples of how to enter search queries.



Next Match button

The button in a list of search hits that displays the next search hit not currently displayed on the Viewer 
screen.



Previous Match button

The button in a list of search hits that displays the previous search hit not currently displayed on the 
Viewer screen.



To Index button

The button in the Topics Indexed dialog box that takes you back to the Index dialog box.



To Search button

The button in the Search Results dialog box that takes you back to the Search dialog box.



Options button

The button in the Search dialog box that displays the available search options. The Search Options dialog 
box is where you can change the NEAR value, select topic titles as the search domain, or select to 
search from a list of previous topics found.



Go To button

The button in the Topics Indexed and the Search Results dialog box that displays the selected topic 
from the list.



bookmark

A name associated with a topic for easy reference. Bookmarks appear on the Bookmark menu. 
When you select a bookmark from the menu, Viewer immediately displays the topic associated with 
that bookmark.



Clipboard

The Microsoft Windows application that holds cut or copied information, which you can then insert 
into another file. Whenever you use a Cut, Copy, or Paste command, you are using the Clipboard.



contents screen

The "table of contents" for a title. From this screen you can select which part of the title you want to 
look in.



topic

A single entry or article in a title. Examples of topics might be a quotation, the definition of a word, or 
an article in an encylopedia.



Topics Indexed

An index dialog box that lists topics from an index search which allows you to browse and go to 
topics in the list.



Search Results

The dialog box that lists topics containing search hits from a search query and allows you to 
browse and go to topics in the list.



search query 

A combination of words, phrases, and operators telling the Search command what text to search for.



browse sequence

A sequence of topics arranged so that you view them in sequence when you select the << or >> 
buttons.



topic title

A name identifying a topic found by searches from the Index and Search commands.



jump

A hot spot that displays another topic in the main Viewer window.



hot spot

A word, phrase, or picture that you select to jump to a new Viewer topic, display a window, or 
perform an author-defined Viewer operation.



search hit

An occurrence of text in a topic that matches the search query entered for the Search command.



current position

The position in an audio or video sequence that is currently being played, indicated by the thumb in 
the slider control.



thumb

The pointer in the slider of a controller indicating the current position in the audio or video sequence.



slider

The control in an audio or video sequence that contains the thumb, which indicates the current 
position in the audio or video sequence. The slider may also include tick marks indicating the 
sections in the audio or video segment.



section

A subdivision of an audio or video sequence indicated by tick marks on the slider. Drag the thumb 
on the slider to any tick mark to begin playing the sequence at the corresponding section.



Finding Information

Finding Information Using the Index

Using the Index is like using the index of a book. You can browse through a list of keywords, and 
then jump to a topic by selecting a word from the index.

To look up a topic using the index:
1 Choose the Index button in the Viewer window.

2 Type the word you want to search for or select the word from the Index list.

You can press a key on your keyboard to move quickly to different parts of the list. For 
example, type "S" to move to words beginning with the letter "S" and then type "O" to see 
words beginning with "So."

3 Choose OK.

If only one topic is linked to the word, Viewer jumps to that topic.

If there is more than one topic linked to the word, Viewer displays the topics in the Topics 
Indexed dialog box.

To return to the Index, choose the To Index button.

4 Double-click the topic you want to view, or select the topic and choose the Go To button.

See Also
Using Full-Text Search



Controlling Sound and Video

Using the Multimedia Controller

You can play an audio or video sequence using a control panel that appears within a topic or that 
pops up when you select a hot spot. Either type of sequence may include the multimedia 
controller, as shown below:

Select any control from this illustration to find out what action it performs.

To control a sequence that does not have a control panel:
* Click the window while the sequence is playing to stop it.

* Click the window after stopping the sequence to start playing it again.



Pause/Play Button

Plays the object if it is currently stopped or paused, or pauses the object if it is currently playing. 



Stop Button

Stops playback of the audio or video sequence. 



The slider control lets you drag the thumb to move the current position back (left) or forward 
(right) in the audio or video sequence. 




