
Calendar Commands

To get help with a command, choose the appropriate menu.

File Menu Commands
New
Open
Save
Save As
Print
Page Setup
Printer Setup
Exit

Edit Menu Commands
Cut
Copy
Paste
Remove

View Menu Commands
Day
Month

Show Menu Commands
Today
Previous
Next
Date

Alarm Menu Commands
Set
Controls

Options Menu Commands
Mark
Special Time
Day Settings



File Menu Commands

Use the scroll bar to see more commands.

New
Opens a new document.

When you choose New, Calendar lets you save changes to the current document.

Related Topics
Creating New Documents

Open
Opens an existing document.

When you choose Open, Calendar lets you save changes to the current document.

Select the Read Only check box if you don't want any changes made to the document.

Related Topics
Opening Existing Documents

Save
Saves changes to the current document.

When you choose Save, the document remains open so you can continue working on it.

Related Topics
Saving Documents

Save As
Saves a new or existing document.

You can:
* Name a new document.

* Save an existing document under a new name.
The original remains unchanged.

Related Topics
Saving Documents

Print
Prints appointments.

Related Topics
Printing Appointments

Page Setup
Sets the margins, and adds headers and footers to printed appointments.

You can specify:
* Margins--Left, right, top and bottom.

* Headers or Footers--Text and/or codes.

Related Topics
Printing Headers and Footers
Setting Margins

Printer Setup
Sets printer options for Calendar before printing.



You can:
* Select a printer for Calendar.

* Choose Setup and change options for the printer.
The available options depend on the type of printer selected.

Related Topics
Changing Printers and Printer Options

Exit
Closes the current document    and exits Calendar.

If the file is unsaved, Calendar lets you save it before exiting.



Edit Menu Commands

Use the scroll barto see more commands.

Cut
Deletes text from a document and places it onto Clipboard, erasing the previous Clipboard contents.

Use Paste to place the cut text in the same document, another document, or another application.

Related Topics
Copying, Cutting, and Pasting Text

Copy
Copies text from a document onto Clipboard, leaving the original intact and erasing the previous 
Clipboard contents.

Use Paste to place the copied text in the same document, another document, or another application.

Related Topics
Copying, Cutting, and Pasting Text

Paste
Pastes a copy of the Clipboard contents at the insertion point or replaces selected text in a document.

Related Topics
Copying, Cutting, and Pasting Text

Remove
Removes all entries from a range of appointment days.

Related Topics
Removing Entries from Appointment Days



View Menu Commands

Use the scroll bar to see more commands.

Day
Switches from the Month view to the Day view.

Related Topics
Changing Between the Day and Month View

Month
Switches from the Day view to the Month view.

Related Topics
Changing Between the Day and Month View



Show Menu Commands

Use the scroll bar to see more commands.

Today
Moves to the current day in the Day or Month view.

Related Topics
Moving Around the Month View
Moving to Different Appointment Days

Previous
Moves to the preceding day in the Day view or the preceding    month in the Month view.

Related Topics
Moving Around the Month View
Moving to Different Appointment Days

Next
Moves to the following day in the Day view or the following month in the Month view.

Related Topics
Moving Around the Month View
Moving to Different Appointment Days

Date
Moves to a specific date in the Day or Month view.

Related Topics
Moving to Different Appointment Days
Moving to Specific Days



Alarm Menu Commands

Use the scroll bar to see more commands.

Set
Sets and removes an alarm.

Related Topics
Setting and Removing Alarms for Appointment Times

Controls
Sets the alarm to go off up to 10 minutes before an appointment time, and turns the alarm's sound on or 
off.

Related Topics
Changing the Sound Option
Setting the Alarm for an Early Ring



Options Menu Commands

Use the scroll bar to see more commands.

Mark
Marks and unmarks special days in the Month view.

Related Topics
Marking Dates in a Month

Special Time
Adds and removes special times in an appointment day.

A special time is a time falling between the intervals set in the Day Settings dialog box.

Related Topics
Adding and Removing Special Times

Day Settings
Changes the settings for the Day view.

You can specify:
* The intervals between appointments.

* A 12- or 24-hour clock.

* The starting time appearing at the top of the window.

Related Topics
Changing the Day Settings





active

Describes the selected window or icon that you are currently working with. Windows always applies the 
next keystroke or command you choose to the active window. If a window is active, it appears in front of 
all other windows on the desktop, and its title bar changes color to differentiate it visually from other 
windows. If an icon is made active, its Control menu appears.

Inactive is the opposite of active and describes windows or icons on the desktop that are not selected.



status bar

A line of information located at the bottom of a window. For example, in a directory window the status 
bar tells how many files are selected, how much disk space they occupy, and the total number of files in 
the directory (whether included in the directory window or not). In the Directory Tree window, the status 
bar shows the number of bytes available on the disk and the total disk capacity. Not all windows have a 
status bar.





Calendar Procedures

The Procedure topics give you step-by-step instructions for using Calendar. Use the scroll bar to see 
more topics.

To learn how to use Help, press F1 or choose Using Help from the Help menu.

Choosing Views of Time
Changing Between the Day and Month View

Using the Month View
Moving Around the Month View

Setting up an Appointment
Moving to Different Appointment Days
Moving to Specific Days
Moving to Appointment Times
Entering Appointments
Adding Notes to the Scratch Pad
Copying, Cutting, and Pasting Text
Removing Entries from Appointment Days

Setting an Alarm
Setting and Removing Alarms for Appointment Times
Changing the Sound Option
Setting the Alarm for an Early Ring
Turning off the Alarm

Customizing your Calendar
Adding and Removing Special Times
Changing the Day Settings
Marking Dates in a Month

Printing
Printing Appointments
Changing Printers and Printer Options
Printing Headers and Footers
Setting Margins

Working with Documents
Creating New Documents
Opening Existing Documents
Saving Documents



Changing Between the Day and Month View

To change from the Day to the Month view:
Mouse * Double-click the status line.

Keyboard * Choose Month from the View menu.

To change from the Month to the Day view:
Mouse * Double-click the status line.

Or double-click a specific day.

Keyboard * Choose Day from the View menu.

Or use the direction keys to move to a specific day and press Enter.



Moving Around the Month View

To move to Do this

The next month Click the Right scroll arrow or choose Next from the Show menu.

The previous month Click the Left scroll arrow or choose Previous from the Show menu.

The current month Choose Today from the Show menu.

A specific month Choose Date from the Show menu and type a specific date.

Related Topics
Changing Between the Day and Month View



Moving to Different Appointment Days

To move to the previous day:
* Choose Previous from the Show menu.

Or click the Left scroll arrow in the status bar.

To move to the next day:
* Choose Next from the Show menu.

Or click the Right scroll arrow in the status bar.

To move to the current day:
* Choose Today from the Show menu.

Related Topics
Moving to Specific Days



Moving to Specific Days

To move to a specific day:
1 Choose Date from the Show menu.

2 Type the date.

3 Choose OK.

Related Topics
Moving to Different Appointment Days



Moving to Appointment Times

To move to an appointment time:
Mouse * Click the time.

Keyboard * Use the following keys:

Press To move

Up Arrow To the time above.

Down Arrow or Enter To the time below.

Page Up To the previous screen.

Page Down To the next screen.

Ctrl+Home To the starting time.

Ctrl+End Twelve hours after the starting time.

Related Topics
Entering Appointments



Entering Appointments

To enter text for an appointment day:
1 Move the insertion point to the appointment time.

2 Type the text.

Related Topics
Moving to Appointment Times
Moving to Different Appointment Days
Moving to Specific Days



Adding Notes to the Scratch Pad

The scratch pad is the area below the appointment times.

To use the scratch pad:
1 Click the scratch pad.

Or press Tab.

2 Type up to three lines of text.

3 Press Tab to return to the appointment area.

Related Topics
Copying, Cutting, and Pasting Text



Copying, Cutting, and Pasting Text

To copy and paste or cut and paste text:
1 Select the text.

2 Choose Copy from the Edit menu to copy text.

Or choose Cut to cut text.

3 Move the insertion point where you want the text to appear.

Or select text you want to replace.

4 Choose Paste from the Edit menu.

Related Topics
Adding Notes to the Scratch Pad



Removing Entries from Appointment Days

To remove all entries from a range of appointment days:
1 Choose Remove from the Edit menu.

2 Type the first date in the From box.

3 Type the last date in the To box.
To remove entries from one appointment day, leave the To box blank.

4 Choose OK.



Setting and Removing Alarms for Appointment Times

To set an alarm:
1 Move to the appointment time.

2 Choose Set from the Alarm menu.

When the alarm goes off, Calendar alerts you in one of the following ways:

If Calendar is This happens

The active window A dialog box reminds you of the appointment.

An inactive window Calendar's title bar and borders flash.

An icon The icon flashes.

To remove an alarm:
1 Move to the time the alarm is set for.

2 Choose Set from the Alarm menu.

Related Topics
Changing the Sound Option
Setting the Alarm for an Early Ring
Turning off the Alarm



Changing the Sound Option

To turn the alarm's sound on or off:
1 Choose Controls from the Alarm menu.

2 Select or clear the Sound check box.

3 Choose OK.

Related Topics
Setting the Alarm for an Early Ring
Setting and Removing Alarms for Appointment Times
Turning off the Alarm



Setting the Alarm for an Early Ring

To set an alarm to go off early:
1 Set the alarm for an appointment time.

2 Choose Controls from the Alarm menu.

3 Type a number from 0 to 10 in the Early Ring box to set the number of minutes an alarm goes off 
before an appointment.

4 Choose OK.

Related Topics
Changing the Sound Option
Turning off the Alarm



Turning off the Alarm

To turn off the alarm after it goes off:
* Choose OK.

If the Calendar window is inactive or shrunk to an icon, first make the window active or select the icon. Then 
choose OK.

Related Topics
Changing the Sound Option
Setting the Alarm for an Early Ring
Setting and Removing Alarms for Appointment Times



Adding and Removing Special Times

A time is special if it falls between the regular time intervals of 15, 30, or 60 minutes.

To add a special time:
1 Choose Special Time from the Options menu.

2 Type the time in the Special Time box.

3 Select AM or PM if you are using a 12-hour clock.

4 Choose Insert.

To remove a special time:
1 Move the insertion point to the time.

2 Choose Special Time from the Options menu.

3 Choose Delete.

Related Topics
Changing the Day Settings
Marking Dates in a Month



Changing the Day Settings

To change the day settings:
1 Choose Day Settings from the Options menu.

2 Change the appropriate options and choose OK.

Use this option To specify

Interval 15-, 30-, or 60-minute intervals between appointment times.

Hour Format Either a 12-hour or 24-hour clock.

Starting Time The time that appears at the top of the window when you first view an 
appointment day.

Related Topics
Adding and Removing Special Times
Marking Dates in a Month



Marking Dates in a Month

To mark a special date:
1 Click the date you want to mark.

Or use the direction keys to move to the date.

2 Choose Mark from the Options menu.

3 Choose a mark symbol.

4 Choose OK.

To remove a mark:
1 Move to the marked date.

2 Choose Mark from the Options menu.

3 Clear the check box of the symbol you want to remove.

4 Choose OK.

Related Topics
Adding and Removing Special Times
Changing the Day Settings



Printing Appointments

To print a range of appointments:
1 Choose Print from the File menu.

2 Type the beginning date in the From box.

3 Type the ending date in the To box.
To print one appointment date, leave the To box blank.

4 Choose OK.

Related Topics
Changing Printers and Printer Options



Changing Printers and Printer Options

To change printers:
1 Choose Printer Setup from the File menu.

2 Select the printer you want to print on.

3 Choose Setup to change printer options.

4 Select the options you want and choose OK.

5 Choose OK.

Related Topics
Printing Appointments



Printing Headers and Footers

To print a header or footer:
1 Choose Page Setup from the File menu.

2 Type the header or footer text and/or codes.

Type For

&d The current date.

&p Page numbers.

&f The current filename.

&l Header or footer text (following the code) justified at the left margin.

&r Header or footer text (following the code) justified at the right margin.

&c Header or footer text (following the code) centered between the margins.

&t The current time.

3 Choose OK.

Related Topics
Setting Margins



Setting Margins

To change the margins for printed appointments:
1 Choose Page Setup from the File menu.

2 Type the margins.

3 Choose OK.

Related Topics
Printing Headers and Footers



Creating New Documents

To create a new document:
* Choose New from the File menu.

Related Topics
Opening Existing Documents



Opening Existing Documents

To open an existing document:
1 Choose Open from the File menu.

2 Enter the filename.

3 Select the Read Only check box if you don't want to make any changes to the document.

4 Choose OK.

Related Topics
Creating New Documents



Saving Documents

To save changes to the current document:
* Choose Save from the File menu.

To save a new (untitled) document or the current document under a new name:
1 Choose Save As from the File menu.

2 Enter a filename.

3 Choose OK.





Calendar Help Index

The Index lists the Help topics available for Calendar. Use the scroll bar to see entries not currently 
visible in the Help window.

To learn how to use Help, press F1 or choose Using Help from the Help menu.

Keyboard
Calendar Keys

Commands
Alarm Menu Commands
Edit Menu Commands
File Menu Commands
Options Menu Commands
Show Menu Commands
View Menu Commands

Procedures
Adding Notes to the Scratch Pad
Adding and Removing Special Times
Changing Between the Day and Month View
Changing the Day Settings
Changing Printers and Printer Options
Changing the Sound Option
Copying, Cutting, and Pasting Text
Creating New Documents
Entering Appointments
Marking Dates in a Month
Moving Around the Month View
Moving to Appointment Times
Moving to Different Appointment Days
Moving to Specific Days
Opening Existing Documents
Printing Appointments
Printing Headers and Footers
Removing Entries from Appointment Days
Saving Documents
Setting the Alarm for an Early Ring
Setting Margins
Setting and Removing Alarms for Appointment Times
Turning off the Alarm





Calendar Keys

Use the following keys in Calendar's Day view:

Key(s) Function

Up Arrow Moves to the time above.

Down Arrow or Enter Moves to the time below.

PgUp Moves to the previous screen.

PgDn Moves to the next screen.

Ctrl+Home Moves to the starting time.

Ctrl+End Moves to twelve hours after the starting time.

Tab Moves between the appointment area and the scratch pad.

Shift+Delete Cuts the selection and places it onto Clipboard.

Ctrl+Ins Copies the selection onto Clipboard.

Shift+Ins Pastes the Clipboard contents into the appointment area or scratch pad.

Use the following keys in Calendar's Month view:

Key(s) Function

Up Arrow Moves to the week above.

Down Arrow Moves to the week below.

PgUp Moves to the previous month.

PgDn Moves to the next month.

Tab Moves between a date and the scratch pad.

Enter Changes to Day view.




