
About This Help 

This help system provides a comprehensive guide for using Campaign 3.0 to produce targeted, automated e-mail campaigns.

Before using Campaign, you should be comfortable performing basic procedures in Windows 95, such as using the mouse to point-

and-click, locating and opening files, and using interface elements such as menus and checkboxes.

It is also very helpful to have familiarity with database and e-mail applications, as Campaign works extensively with outside 

applications and services to produce and send e-mail.

More:
Conventions



Conventions

This help system uses the following conventions for certain common commands and navigation in Campaign.

This command Means
Choose View > Messages. From the main menu, open the 

View menu, then choose 
Messages.

Click Add Task. With the mouse, move the pointer 
over the onscreen Add Task button 
and click once.

Press Delete. Press the Delete key on your 
computer's keyboard.

Check the Enable e-mail 
scheduling box.

Uncheck the Enable e-mail 
scheduling box.

Click the checkbox labeled Enable 
e-mail scheduling, so that the box 
contains a checkmark.

Click the checkbox labeled Enable 
e-mail scheduling, so that the box 
is empty.

About Campaign

Campaign may change the way you think about e-mail. 

You can increase your productivity, efficiency and sales with the quick setup and easy automation that Campaign offers.

With this software, you can create targeted, personalized e-mail campaigns to reach customers, prospects, members and other 

important contacts. It's a powerful direct marketing tool that lets you use some of the most popular and proven marketing techniques 

to deliver your message. It's a sales device that automates backend sales with your existing customer base. It's a tool for non-profit 

fundraising and membership drives, customer service, technical support online education, and more.



Features

Runs unattended

Campaign can generate and send e-mail by itself. Tell it to run every few minutes, on the hour or once a day. E-mail campaigns are 

now easier!

And if you have a dial-up Internet account, Campaign can even dial your account automatically.

Automated follow-up

Campaign is the only e-mail tool that lets you automate personalized follow-ups. Turn a one-time broadcast mailing into a 

sophisticated, ongoing communication with new and existing customers, prospects, group members, or subscribers.

Targeted, personalized messages

You don't have to send the same message to everyone in your database. Target your e-mail to a specific audience, using 

Campaign's sophisticated and easy-to-use data filtering capabilities.

There's no telltale multiple recipient headers with Campaign, as each recipient sees only their own address in the header. Plus, you 

can make each message personalized by merging data from your database, and the amount of data that can be merged is nearly 

unlimited.

Always current data 

Campaign reads data directly from your database.

And there's no exporting. You'll never have to keep track of recipient lists or re-export when the addresses get old.

Use with most popular business databases and PIMs

Read data from Access, dBase or Paradox, or link to your favorite contact manager, like ACT, Approach, GoldMine or TeleMagic.



What's New In This Release

Campaign v3.0 offers a number of improvements and entirely new features since the software's previous release.

Attachments

Attach files to your messages.

Broader database compatibility through ODBC

Campaign can now read data from ODBC-compliant databases, giving you access to data in system-level sources, such as 

Microsoft SQL Server, Oracle and Sybase.

Read Access Queries

In addition to reading Microsoft Access tables, Campaign now reads database queries, thereby allowing you to read data across 

tables or to filter data before it's read by Campaign.

User-defined delay

You can define a brief delay between messages for smoother SMTP sending, which prevents the server from getting overloaded 

and interrupting your mailings.

More sending options

New compatibility with popular e-mail clients such as Lotus cc:Mail and Novell GroupWise gives you more choices for distributing a 

Campaign mailing.

Sort Outbox

Preview queued messages in the Out box and sort them by any field.

Scheduler

This new function lets you schedule any Project to run unattended. Set intervals ranging from every 15 minutes to once per day.

Autodial

No need to connect to the Internet manually with dial-up accounts. You can now automatically connect to the Internet as part of any 

Project!

New .sto files

Create a new Campaign Storage file quickly with a menu command.

Signature

Sign your e-mail without retyping your contact information each time you write a message.

Word wrap

Merge It Tasks include a new, fully configurable word wrapping feature that lets you set the length of the text lines in outbound e-

mail, without having to add hard returns manually.



System Requirements

To install and run Campaign, your computer will need:

· Windows 95

· 16MB of RAM

· 20MB hard drive space

· Database or Personal Information Manager (PIM)

(Microsoft Access works best, but Campaign is compatible with many popular applications)

· Working e-mail account and Internet connection



Navigation

When you first open Campaign, you will see the main Projects window. 

Each of Campaign's primary functions has a window that organizes items for you to choose form. For example, the main Database 

Filter window lists all the available Database Filters. To access a particular Filter, first open the Database Filter window, find the 

specific filter you want to open, .

The windows for each function are accessible through the View menu, which is divided into Database Filters, Messages, Projects, 

and Scheduler.

Windows use the same buttons and commands, which are accessible at the right side of the window.

New

Creates a new Message, Filter, Project or Scheduled Item

Edit

Opens the selected item for editing.

Delete

Deletes the selected item.

Rename

Renames the selected item.

Additionally, the Project selection window has two extra buttons:

Schedule

Schedules the selected Project to run automatically.

Run 

Runs the selected Project



Screens

In addition to the selection windows, each individual function has its own configuration screen.

More:
Database Filter

Message

Projects

Scheduler

Mailboxes

Options



Database Filter

The Database Filter takes the place of a static address book or recipient list. Instead, Campaign reads addresses directly from your 

database at the time of the merge, which means you will always have access to the most current information in your database 

without continually having to export data into lists.

The Database Filter screen is divided by tabs into Basic and Advanced. The Basic screen uses drop-down menus to define a filter, 

while the Advanced screen lets you type in SQL statements that filter data.

You can send messages to everyone in your database, or you can define an audience based on specific criteria from the database: 

for example, dates, location, interests, customer status, or any other information in your database. 

If your data is in a Microsoft Access database, you can also use a Database Filter to read individual Tables or    Queries in your 

database.

View Database Filter screen

{button ,AL(`filters;datasource',0,`',`')} Related Topics



Database Filter screen

Click on a section of the graphic to learn more about using Database Filters.



Message

The Message Editor is where you compose or paste your message text. You can also import messages from external text files. The 

Message Editor also makes it easy to personalize a large mailing by indicating where Campaign should insert data from your 

database.

On this screen, you can also attach files to your messages.

View Message Editor screen

{button ,AL(`composing',0,`',`Main')} Related Topics



Message Editor screen

Click on a section of the graphic to learn more about using the Message Editor.



Projects

Projects may consist of one or more Tasks. A Task is an action that does one specific thing, such as merging e-mail. 

Campaign has four types of Tasks.

Merge It

A Merge It Task creates messages by merging data from your data source into your message file, then it queues the resulting 

messages to the Out mailbox until you are ready to send them.

The Merge It screen is where you choose the message and data to merge.

This screen also lets you set up an e-mail campaign using Campaign's ActiveMail™ technology.

View Merge It screen

Mail It

The Mail It Task sends queued e-mail from Campaign's Out mailbox.

On the Mail It screen, you can configure the way Campaign sends your e-mail. Campaign works with many popular business e-mail 

clients and groupware applications, including Microsoft Outlook, Exchange or Windows Messaging; Lotus Notes and cc:Mail; and 

Novell GroupWise. Or you can easily create a direct connection to your SMTP mail server for faster sending.

View Mail It screen

RAS Dial

The RAS Dial Task uses your computer's modem to dial up and connect to your Internet account.

This task is especially useful for automating Campaign with a dial-up Internet account (see About Automating Campaign).

You can still send mail through a dialup connection without using a RAS Dial Task. If you do, however, you will have to log on to the 

Internet manually before you can send mail.

RAS Hangup

The RAS Hangup Task closes a dial-up Internet connection.

There is no configuration screen for the Hangup task.

{button ,AL(`merging;sending;emcampaign',0,`',`')} Related Topics



Merge It screen

Click on a section of the graphic to learn more about using the Merge It Task.



Mail It screen

Click on a section of the graphic to learn more about using the Mail It Task.



Scheduler

Use this screen to automate your mailings. In fact, with the Scheduler, you can automate a whole series of steps in Campaign; 

generating new messages, connecting to your e-mail account, sending messages, and closing the connection!

You can choose from a range of times for automatically running Campaign Projects, from every fifteen minutes to once per day.

View Scheduler screen

{button ,AL(`automating',0,`',`')} Related Topics



Scheduler screen

Click on a section of the graphic to learn more about using the Scheduler.



Options

The Options screen lets you specify default settings for Mail It Tasks, such as e-mail account and mail server information. 

View Options screen



Options screen

Click on a section of the graphic to learn more about setting sending defaults with the Options screen.



Mailboxes

Campaign has two internal mailboxes, the Out box and the Sent box.

· The Out mailbox contains messages that are queued and ready to be sent, but have not been sent yet.

When you merge e-mail, Campaign queues it to the Out mailbox. Messages remain in the Out mailbox until you run a Mail It 

task.

View Out mailbox

· The Sent mailbox displays the messages that Campaign has sent. 

Note that messages sent in one mailing will not overwrite messages that are already in the Sent box from a previous mailing. 

You should delete the contents of the Sent box periodically to conserve hard drive space.

{button ,AL(`sending;previewing',0,`',`')} Related Topics



Out Mailbox screen

Click on a section of the graphic to learn more about using the Out mailbox.



Naming

The only Campaign files that are accessible as files on the hard drive are storage files. Messages, Filters and Tasks are accessible 

only from within Campaign.

Names for Campaign's Messages, Filters, Projects and Tasks are only for use within Campaign. Therefore, you do not need to 

follow Windows naming conventions (such as using filename extensions). 

More:
To create and name a new item

To rename an existing item



To create and name a new item

1. Click New.

2. Enter a name in the dialog box.



To rename an existing item

1. Select the item in the selection window.

2. Click Rename.



Saving

Work is automatically saved when you exit any configuration screen. You do not need to save your work manually.



Getting Help

Campaign's online help is accessible at any time from the Help menu or by pressing F1 on your keyboard. 

The Help menu also provides direct web links, so that when you choose a web site from the Help menu, Campaign will launch your 

web browser and point it to the specified web page.

Available choices include:

Frequently Asked Questions

Answers to common questions asked by Campaign users and customers.

Update 

Download the most recent updates and patches to Campaign.

Comment 

Provide feedback about Campaign. 

Support

Send technical support e-mail or learn about our technical phone support plans.

Uses

See suggestions and bright ideas for using Campaign.

Products

Find out about other e-mail marketing software products that can be used with Campaign.

Order 

Purchase an unlocking serial number to get the most out of Campaign.

News

Find out the latest news about Campaign and other products.

View Testimonials

Read client comments about using Campaign to provide real-world communication solutions.

Multilingual Marketing

Get information on expanding your e-mail campaign into foreign markets and reaching bilingual audiences in the U.S.



Storage Files

A storage file is a collection of Campaign's messages, projects, filters and mailboxes.

The default storage file is campaign.sto, but you can create and use different storage files.

If you use Campaign for a wide range of different mailings, you probably will want to use different storage files to keep your projects 

organized.

More:
To create a new storage file

To open a storage file



To create a new storage file

1. Choose File > New Storage File.

2. Use the dialog box to indicate a location for the new file.

3. Name the storage file and click OK.



To open a storage file

1. Choose File > Open Storage File.

2. Locate the storage file to use.

The dialog box will show only storage files (which have the .sto filename extension).

3. Select a storage file and click OK.



Maintenance

Much as your computer's hard disk needs regular maintenance, Campaign's storage files should be cleaned up regularly. You can 

do this by compacting and repairing storage files.

More:
Compacting a storage file

Repairing a storage file



Compacting a storage file

Compacting a storage file helps defragment the file and free disk space.

When you delete items in a storage file, it will eventually become fragmented and use disk space inefficiently. Compacting the 

storage file helps store the information more efficiently on your hard drive.

WARNING

· Make sure that you have enough hard drive space to hold a temporary copy of the storage file.

During the compression process, Campaign creates a temporary copy of the storage file. If there is not enough hard drive 

space on your computer when you compress a storage file, the storage file may become corrupted. 

· Before you compact or repair a storage file, always create a backup copy of it to prevent loss of data.

To compact a storage file

1. Choose File > Compact Storage File.

2. Locate the storage file to compact and click OK.

3. Click Yes in the confirmation dialog box.



Repairing a storage file

The repair function can help restore a damaged or partially corrupted storage file.

WARNING

· Use Campaign's repair function with caution. Before you compact or repair a storage file, always create a backup copy of it to 

prevent loss of data.

To repair a storage file

1. Choose File > Repair Storage File.

2. In the Browse box, locate the storage file to repair and click OK.

3. Click Yes in the confirmation dialog box.



Updating storage files

If you upgraded to Campaign 3.0 from a previous version, you can still use your existing storage files. However, previous storage 

files require some modification to work with Campaign 3.0.

Basic Database Filters in Campaign 3.0 use different logic for filtering criteria. If you used a Basic Database Filter with Campaign 

2.5, you will need to modify (or possibly recreate) the filter for use with Campaign 3.0.

If you used an Advanced SQL filter as your data source in a previous storage file, you can use the filter as is with Campaign 3.0. No 

changes are necessary.

To update a Campaign 2.5 storage file 

1. In Campaign 3.0, open the existing storage file (File > Open Storage File). 

2. Choose View > Database Filter. 

3. Open an existing Database Filter that uses the Basic Filter interface. 

4. Find the first database field listed in the Fields column. Open the drop-down operator menu to the right of the database field 

name. Campaign will auto-detect the database field's type (text, date, numeric or true/false) and list the appropriate set of 

operators. 

5. Choose an operator. 

6. If your old filter criteria used a wildcard (*) for text filtering, delete the wildcard and use a different operator (such as 'starts 

with"). 

7. If there are additional criteria and operators used in the filter, adjust them as well. Otherwise, exit the current filter screen and 

edit any other filters that use the Basic Filter interface. 



Overview of a Campaign mailing

Here are the basic steps for creating a mailing with Campaign:

1. Define your audience.

Campaign's Database Filters determine who will get your message. Use filter criteria to create a profile for your desired 

audience.

Do you want to send a message to everyone in your database? First-time customers only? Recipients in a certain ZIP code? 

Customers who purchased on a certain date?

2. Compose your message.

With Campaign's Message Editor, you can type in your message directly, or you can paste or import text from an external text 

file. 

It's easy to personalize messages too, because Campaign can merge any information directly from your database.

3. Merge e-mail.

A Merge It Task generates individual e-mail messages for each of your recipients. On this screen, you will pair a data source 

and a message file; when the data is merged, it produces a new e-mail message for each recipient. You can also use the 

Merge It Task to start an automated e-mail campaign that communicates regularly with your customers, prospects, members, 

or subscribers.

The Merge It screen also provides a powerful marketing tool in Campaign's A/B messaging ability, which allows you to test the 

response rate and effectiveness of your marketing messages.

4. Send e-mail.

A Mail It Task actually sends the mail created in the previous step. Messages will be queued in the Campaign Out mailbox until 

you run a Mail It Task.

You can open a direct connection to your mail server for the fastest sending, or transfer e-mail to your favorite e-mail client for 

sending via MAPI.

As you become more proficient using Campaign, you will probably add steps to the simple structure outlined here. For example, you 

may want to automate a mailing or create an e-mail campaign. Any mailing with Campaign will follow the same basic structure.



Wizard

To help you get started configuring Campaign to generate and send e-mail, Campaign now offers easy setup with the Project 

Wizard.

The Project Wizard guides you through the steps of a mailing, from writing a message, to merging data, to sending e-mail.

More:
To set up a Project with the Project Wizard



To set up a Project with the Project Wizard

1. Choose View > Projects.

2. Click New.

3. When you are asked if you want to use the Project Setup Wizard, click Yes.

4. Click Next to move forward through the Wizard, or click Back to return the previous screen.



About Data Sources

When you send e-mail with a typical e-mail client like Outlook or Eudora, you probably store your recipients' e-mail addresses in an 

address book file. And if you have ever tried to send e-mail to a group, you might have built a recipient list for sending.

But Campaign makes large mailings easy by eliminating lists and address books. Instead, you define your audience with a 

Database Filter, which reads information directly from your external database rather than a list or address book. 

The Database Filter also lets you define a particular audience out of all the records in your database. This is an important point -- 

rather than sending a message to everyone on a list, you are sending a message to selected people in your database who fit a 

certain profile or meet certain criteria. 

One advantage of reading data directly, rather than exporting it into a recipient list, is the ability to use information dynamically. This 

makes audience management remarkably easy. Whenever you add new records to your database or edit existing ones, Campaign 

will be using the most current sending information. By contrast, if you export addresses to a mailing list, that list becomes outdated 

as soon as you add or change records in your database.

There are different kinds of Database Filters too. You can create a simple filter in seconds with the easy-to-use Basic screen, or 

create a more complex one in the Advanced screen.



Defining your audience

A database filter can be simple or complex, able to create a broad-based mailing or one that is highly targeted. 

The Database Filter screen is divided by tabs into Basic and Advanced sections. 

More:
Configuring a Basic filter

Configuring an Advanced filter

Compatibility

Notes for specific database applications

ODBC Databases

Additional Resources

{button ,AL(`filters',0,`',`')} Related Topics



Configuring a Basic filter

The Basic screen allows you to define a database filter using a series of drop-down menus. This interface is easy to use and well-

suited for simple data filtering, but it lacks the power and complexity of the Advanced screen.

The Basic filter screen assembles a Database Filter using three elements: field name, operator and filter criteria.

More:
Field name

Operators

True/False Operators

Criteria

To define a Basic database filter



Field name

The field name refers to a field in your database records. A database filter requires at least one specific field to search, with a 

maximum of five fields.

Once you enter the location and name of your database file, Campaign can read the field names automatically. Rather than type the 

field names in manually, you can use drop-down menus to choose the field name from a list.

For example, to filter for customers who live in Texas, the Field name would need to point to the field containing the customers' state 

of residence.

Also important for Campaign is the field type. The field type is important because it affects the way Campaign searches for data. 

Consult your database documentation for assigning field types.



Operators

An operator describes the relationship between the database field and the filter criteria.

A filter will use different operators, depending on the type of database field you choose. There are unique operators for text, 

numeric, date, and true/false type fields. Fortunately, you don't have to keep track of all the different operators; Campaign will 

automatically provide the correct set of operators for each type.

Suppose you choose a text field called LastName. Campaign will read the field and detect that it is a text field. When you open the 

operator menu, Campaign automatically provides the list of possible operators for searching a text field.

Numeric field operators

Text field operators

Date field operators

True/false operators



Numeric Field Operators

If the field is a numeric field, there are six possible operators:

Operator Does this Example Valid Values

Equal to Matches number 
equal to filter 
criteria 

CustomerID 
equal to 10

10

Not equal to Matches 
numbers not 
equal to filter 
criteria

CustomerID not 
equal to 10

1-9, 11-20

Greater than Matches 
numbers larger 
than filter criteria

CustomerID 
greater than 10

11-20

Less than Matches 
numbers smaller 
than filter criteria

CustomerID less 
than 10

1-9

Greater than or 
equal to

Matches 
numbers 

CustomerID 
greater than or 
equal to 10

10-20

Less than or 
equal to

Matches 
numbers

CustomerID less 
than or equal to 
10

1-10

Text Field Operators

For text fields, there are four possible operators:

Operator Does this Example Valid Strings

Contains Matches string 
anywhere in a 
field

FirstName 
contains ph

Philip, 
Persephone, 
Joseph

Starts with Matches string 
at beginning of a 
word

FirstName starts 
with ph

Philip

Ends with Matches string 
at end of a word

FirstName ends 
with ph

Joseph

Exactly like Matches only 
the exact string

State exactly 
like WA

WA

Date Field Operators

For date fields, there are five operators:

Operator Does this Example Valid Date 
Values

On Matches exact 
date

PurchaseDate 
on 4/26/98

4/26/98

Before Matches all 
previous dates

PurchaseDate 
before 4/26/98

4/25/98 and 
earlier

After Matches all 
subsequent 
dates

PurchaseDate 
after 4/26/98

4/27/98 and 
later

On Or Before Matches that 
date and all 
previous dates

PurchaseDate 
on or before 
4/26/98

4/26/98 and 
earlier

On Or After Matches that PurchaseDate 4/26/98 and 



date and all 
subsequent 
dates

on or before 
4/26/98

later

True/False Operators

For true/false fields, there are two operators that also double as the filter criteria.

Operator Does this Example Valid Values

Is true Matches field 
where checkbox 
is checked

Customer is true þ

Is false Matches field 
where checkbox 
is empty

Customer is 
false

¨

Criteria

Filter criteria describe the particular data you want to match. While the Field tells where to look for information, the Criteria tells what 

to look for.

So in a Filter locating database records for customers in Texas, the filter criteria would be "Texas."

The Basic Filter accepts up to 3 criteria per database field.

Boolean searches

The Basic Database Filter screen filters data using implied Boolean AND and OR criteria. 

In a horizontal row of criteria, the Boolean OR is implied. Likewise, the Boolean AND is implied in a vertical column. 

Wildcards

Wildcard characters, such as * and ?, are not necessary in a Basic filter, although they will work. They can be used in an SQL 

statement in the Advanced screen, however.



To define a Basic database filter

1. Choose View > Database Filters.

2. Click New.

3. Name the new filter and click OK.

The Database Filter screen appears.

4. Click Browse. In the Browse box, you can choose the database to use as your data source. In the Type of Database drop-

down menu, specify the file format and the database application you want to use. Next, locate the database. 

5. Click OK.

6. If your data source is a Microsoft Access database, use the Table name drop-down menu to choose a specific Table or Query in 

the Access file. 

· Note: Campaign may be unable to read Access tables or queries that use special characters (such as dashes or symbols) in 

the name. Name your Access tables and queries with only standard alphabetic or numeric characters (A-Z, 1-9) for optimal 

compatibility with Campaign.

7. Locate the column under the heading Database Fields. Click the drop-down box for the top field. 

Notice that the menu lists all the fields in your database. Choose a field containing information to filter. For example, if you want 

to send messages to customers with the last name of Mandrake, you might choose "LastName".

8. Open the drop-down box in the adjacent field and choose an operator. See Configuring a Basic filter for operators and 
field types.

Text field operators

9. In the next field, enter filter criteria. See Configuring a Basic filter for more about using filter criteria.

10. Click Preview to see the matching database records.

11. When you finish previewing records, click OK.

12. Click Save to exit the Database Filter.



Configuring an Advanced filter

An Advanced database filter is more flexible and more powerful than a filter created in the Basic screen. However, Advanced filters 

require some knowledge of Structured Query Language (SQL), a query language used in relational database management.

Advanced filters are actually abbreviated forms of Select. . . From . . .Where SQL statements. See SQL in Campaign for more 

information about SQL.

SQL statements in the Advanced screen allow you to create more detailed filters than is possible in the Basic screen. For example, 

a Basic database filter can search up to five database fields, while an Advanced SQL filter can search many more fields.

Note: You cannot use the Basic and Advanced tabs within the same filter.

More:
To define an Advanced (SQL) database filter



To define an Advanced (SQL) database filter

1. Create or open a Database Filter.

2. Click Browse. Use the Browse box to locate the database.

3. In the Type of Database drop-down menu, specify the type of database format and application you want to use. 

4. Click OK.

5. If your data source is a Microsoft Access database, use the Table name drop-down menu to choose an Access table or Query.

6. Click the Advanced tab.

7. Type an SQL statement in the Advanced field.

In the command, you will need to specify the database fields, operators and filter criteria. The statement should be a shortened 

Select . . .From . . .Where statement, without the Select . . .From.

For example, to filter for customers with the last name of Shearer, the SQL statement would be:

LastName like 'Shearer'

See SQL in Campaign for a discussion of using SQL for filtering data in Campaign.

8. Click Preview to see the matching database records.

9. When you finish previewing records, click OK.

10. Click Save to exit the Database Filter.



Compatibility

Campaign works natively with Microsoft Access (.mdb) databases. It also reads database files in other formats. Listed below are the 

database formats and applications that Campaign can read:

.db (Paradox, ContactPlus )

.dbf (ACT!, dBase, FoxPro, GoldMine, Media Map, Lotus Approach)

.mdb (Access)

.txt (delimited text files)

When you configure a Database Filter, you will need to specify the application and format of your data source, using the drop-down 

menu in the Browse box:

In addition, you can use Campaign with any ODBC-compliant database.

If your database is not listed in the menu of compatible databases, there are several possible workarounds:

· Save the database file into a format that Campaign can read. The most reliable format is a .dbf file.

· Save or export your data into a comma-delimited text (.txt) file.

· If the application is ODBC-compliant, use the database as an ODBC data source.



Notes for specific database applications

Access

ACT! 3.0



Access

Although you can use it with data sources in a variety of applications, Campaign was designed around Microsoft Access.

If you use Access, note that you must use a particular Table or Query as the data source, and avoid using special characters (such 

as *, {, /, and other non-alphanumeric characters) to name Tables or Queries.

The ability to use Access Queries provides additional flexibility and added power for using data.

Here are some advantages of using Access Queries:

· Use more than one source

A Query in Access can read information from several Tables within the same database, while a filter in Campaign can only read 

from one Table at a time. 

· Use Access' native capability and interface

Campaign's ability to read Queries lets you use the Access environment to define your audience, which eliminates the need to 

recreate queries with an SQL Database Filter in Campaign.



ACT! 3.0

Symantec's popular PIM works well with Campaign, except for one peculiarity of the ACT! file structure: addresses in ACT!'s E-Mail 

field are actually stored in a separate file apart from the rest of the database. This structure means that Campaign cannot read the 

E-Mail field.

The workaround for ACT! is to copy e-mail addresses for your existing contacts into a different, unused database field, such as one 

of the User fields. 



ODBC Databases

A new feature in Campaign 3.0 is its ability to link to databases using an ODBC (Open Database Connectivity) server.

The ODBC feature allows Campaign to read data from powerful server-based data sources, such as Microsoft SQL Server, Sybase 

and Oracle.

IMPORTANT: Do not use ODBC to read client-based database files, such as databases created in Microsoft Access, FoxPro or any 

other file on a local machine. The ODBC feature will read only system-level data sources that use Microsoft-supported DSN 

definitions.

More:
To read data from an ODBC database



To read data from an ODBC database

1. On the Database Filter screen, click ODBC.

The Select Data Source screen appears.

2. Choose File Data Source if your data source information is stored in a DSN file. Information from a DSN file is accessible to 

other users and applications in a network, and it will have a .dsn extension.

The default location for DSN files is C:\Program Files\Common Files\Odbc\Data Sources.

· Choose Machine Data Source if your data source information is stored on your computer's Windows Registry. 

Microsoft recommends using a File Data Source instead of a Machine Data Source.

3. Click OK to return to the Database Filter screen. Configure the Filter using the Basic or Advanced interface.



Additional Resources

The Help button on the Select Data Source dialog box brings up Microsoft help files on DSN and ODBC data sources.

For further information about ODBC databases or creating DSN files, first consult your database documentation or system 

administrator. 

You may also want to consult Microsoft's web site ( in particular, the Microsoft Developer's Network) which provides both basic and 

advanced information about using ODBC data sources. 

The URL is http://www.microsoft.com



Text Files

Campaign is a sophisticated tool optimized for reading data from a database. However, if you have a recipient list or address book 

that is not in a database, you can use a tab-delimited text file as your data source.

Make sure the text file follows these conventions: 

· Field names are listed in the first row of data. 

· Data are separated (delimited) by a comma or tab. 

· Each entry is enclosed in quotes. 

· Each line has the same number of fields. 

For instance, if you list a customer's first and last name, ID number and e-mail address, a tab-delimited text file would look like this: 

"First"  "Last" "ID" "Email" 

"John"  "Doe" "1" "jdoe@company.com" 

"Rita"  "Meter" "2" "rmeter@maid.gov" 

"Sally"  "Manella" "3" "sally@isp.net"

"Larry"  "Looter" "4" "larry@school.edu"



About Messages

One of Campaign's strengths as a communications tool lies in its database compatibility. Because it reads your database directly, 

Campaign can easily extract database information and use it in your messages to create personalized, effective direct mailings.



Composing Messages

Campaign allows flexibility in composing your e-mail messages: you can type in a new message, import a text file or paste text from 

another document into the Message Editor.

The Message Editor allows you to spell-check your work, as well as "cleaning" imported text. Cleaning text means that your 

message will be scanned for any non-e-mail compatible characters in the text. For example, curly or "smart" quotes that appear 

normally in Microsoft Word may become unreadable when pasted into Campaign's Message Editor. Cleaning text eliminates that 

problem.

More:
To compose a new message in Campaign

To import a text file into the Message Editor

To clean an imported message

To spell-check a message

To print a message

Hypertext



To compose a new message in Campaign

1. Choose View > Messages.

2. Click New.

3. Name the message and click OK.

The Message Editor appears.

4. Click in the Subject field and type the subject line of your e-mail.

5. Click in the text field and type the message body for your e-mail.



To import a text file into the Message Editor

1. Click Import.

2. Using the Browse box, locate the file to import into the Message Editor. The file must be in plain text (.txt) format and no 
larger than 64K to be imported. 
3. Click Open.



To clean an imported message

Special characters in a word processing document may become unreadable if text is copied or imported into Campaign's Message 

Editor. For example, "smart quotes" or symbols such as ® may not be in a plain text file, so using Campaign's message cleaning 

function can catch unreadable characters in your message before it becomes e-mail.
 Click Clean Message.



To spell-check a message
 Click Check Spelling.



To print a message
 Click Print.



Hypertext

You can add hypertext to messages sent with Campaign; however, whether the text becomes an active link depends on the 

recipient's e-mail client, not on Campaign.

To add a clickable link to a web page in your message, type the full URL (make sure to include the "http://"). If it appears at the end 

of a sentence, do not add a period after the URL.

Example:

Visit our new web site at http://www.arialsoftware.com

In the e-mail, the URL will appear as an active hyperlink:

Visit our new web site at http://www.arialsoftware.com

To add a clickable link that creates an e-mail message, type "mailto:" followed by your e-mail address.

Example:

Drop me a line at mailto:sales@arialsoftware.com

TIP:

Put your contact information in a signature.

To create a signature for your e-mail, choose Options from the main menu. In the signature text field, enter your contact information, 

including clickable links to your web site and e-mail address.

Example:

==============================

Best regards,

Cory Olis

http://www.arialsoftware.com

mailto:cory@arialsoftware.com

==============================



Merging Data

When you use Campaign with a compatible database, there's no need for exporting or importing data to recipient lists. Campaign 

reads data "live," so you will always have the most current information in your database instantly available when you prepare a 

mailing.

Because Campaign reads data directly from your database, it can merge a nearly unlimited amount of data into each e-mail 

message.

You can personalize a message by adding merge fields into your message template. Each merge field will be replaced during a 

Merge It process with information from the database.

A merge field is a database field name in braces. For example, if your database has a field called FirstName, the corresponding 

merge field would be {FirstName}. When you generate e-mail, each message will have the merge field replaced by the contents of 

the FirstName field in your database.

Note: Before you add merge fields to a message, you will need to have a Database Filter already defined. 

More:
To add merge fields to a message



To add merge fields to a message

1. Open a new or existing message in the Message Editor.

2. Enter information in the following fields:

· Get fields from this database filter definition

From the drop-down box, choose a database filter to use as your data source. After you choose a filter, Campaign will read the 

database and list the field names for you.

3. With the mouse, position the cursor where you want to add the merge field. You can add a merge field anywhere in the 

message or the subject line.

· Fields available to insert

This menu lists database fields that can be used in your message as merge fields. Select a field name to use, then double-click 

it.

The field name will be added to your message as a merge field. 

Later, when you merge data into your message, Campaign will replace merge fields with the contents of the corresponding 

database field.

View example

Hint: You can also add merge fields manually. Simply type the name of a database field, enclosed in braces {}, into your message; 

for example {FirstName} for a field labeled FirstName. You must use the exact name of the field, including capital letters. If the field 

name is wrong in the message, Campaign will not recognize the merge field and the data will not be merged. To test it, preview mail 

in the Out mailbox before sending it.

{button ,AL(`merging',0,`',`')} Related Topics



Merge fields example

Start typing your message . . .

 . . .choose a Database Filter to use as the data source . . .

 . . .double-click on a database field name . . .

 . . .and the merge field is added to your message.



Tips and Tricks

· To use a formal greeting in your e-mail (such as "Dear Ms. Williams," rather than "Dear Kim"), add a database field for titles or 

special forms of address. 

Example:

Add a field to your database called Title, and enter Mr., Ms., or other titles. You can then set up e-mail greetings like this:

Dear {Title} {Last Name}

· Remove blank lines by using "~C" after a merge field.

For example, suppose you have a database field called Address2 for supplementary address information. The field contains 

information in some database records, but it may be blank in others. If you try to merge in this format:

{First} {Middle} {Last}

{Address1}

{Address2}

{City}, {State}    {Zip}

some of your resulting messages will contain a conspicuous blank line when there is no data in the field.

But the ~C command after a merge field will add a line only if there is data in the corresponding field

{First} {Middle} {Last}

{Address1}{Address2}~C

{City}, {State}    {Zip}

Putting the ~C at the end of the field instructs Campaign to insert the data, if it is not null or blank, on the next line.    This only 

applies to the field immediately preceding the ~C.

· Specify decimal places for numbers.

Campaign normally merges numeric field contents as whole numbers. So the contents of numeric fields containing decimals 

are rounded to the nearest whole number. For example, the numbers 167.06 and 0.12 would be merged into an e-mail 

message as 167 and 0.

You can specify longer decimal places for a merge field with 

~x

where x is the number of places after the decimal point. So, for example, ~2 would display a number to two decimal places, 

such as 2.64.



Attachments

You may want to attach a file to send with your message. This is easily done in the Message Editor. 

While Campaign doesn't limit the size of attachments, your mail server may limit file size for individual messages and attachments. 

Check with your network administrator or ISP before sending large files as e-mail attachments.

Also, note that because attachments take extra time to send, they may slow down your mailings.

More:
To attach a file to messages



To attach a file to messages

1. Open a new or existing message in the Message Editor.

2. Click Browse.

3. Locate the file to attach and click Open.

IMPORTANT: Make sure the attachment file is not moved or deleted before you merge the e-mail. The file is attached at merge 

time, using the path and file name specified in the Message Editor.



About Merging Data

Writing your message and choosing a data source are the most work you will have to do in Campaign. After that, the really tedious 

work (merging data, generating and sending e-mail) is done by the software.

More:
Projects vs Tasks, Merge vs. Mail

Tasks



Projects vs Tasks, Merge vs. Mail

Campaign's main actions are merging data to create your e-mail, and sending the e-mail after it has been created.

These actions in Campaign are grouped by Projects and Tasks.

A Project consists of one or more related Tasks. A Task is a specific action, such as sending mail, that Campaign carries out when a 

Project is running. You can combine multiple Tasks within a Project, or you can limit each Project to only one Task.

Projects are listed in the Projects window. When you open a Project to edit it, notice that it lists a series of Tasks.

TIP: 

When you create new projects, use descriptive names to help you keep track of the different functions.

For example, using names like "My stuff" or "Merge" will become very confusing as you accumulate more and more projects. By 

contrast, a name like "Welcome message and 3 follow-ups for new customers" will help you find the right Project quickly and easily.

More:
To create a new project

To open an existing project

To delete a project



To create a new project

1. Choose View > Projects.

2. Click New.

3. The Project Wizard dialog box appears. If you want to use the Wizard to set up a Project, click Yes. To configure a Project 

manually, click No.

4. If you are configuring the Project manually, name the Project and click OK. 

To use the Wizard, follow the onscreen instructions.



To open an existing project

1. Choose View > Projects.

2. In the Projects window, select the name of a Project.

3. Double-click the Project name, or click Edit.



To delete a project

1. Choose View > Projects.

2. In the Projects window, select the name of a Project.

3. Click Remove.



Tasks

A Task is a specific action performed by Campaign. Available tasks include generating messages, sending messages, or dialing a 

modem to connect to an e-mail account.

There are 4 different types of Tasks in Campaign (although you do not have to use all 4 to create a Project). Following are 

descriptions of each type.

Merge It

A Merge It Task merges data with a message to create e-mail, which is then queued for sending.

In the Merge It Task screen, you choose a Database Filter and a Message to merge. When the Task runs, it creates an e-mail 

message for each recipient, and merges data into each message to make it personalized.

After messages are generated, they are queued to Campaign's Out mailbox, but they are not mailed. The Merge It Task does not 

send the e-mail; sending requires a separate step called a Mail It Task.

Mail It

A Mail It Task sends messages that are queued in the Out mailbox.

The steps in the mail sending process depends on the sending method you use.

If you use Campaign to send mail using an SMTP connection, your e-mail will be sent out directly.

If you use Campaign with another e-mail client such as Outlook or cc:Mail, there is an additional step in sending messages. When 

you run a Mail It Task, your mail will go from Campaign's Out mailbox to your other mail client's Outbox. From there, you can send 

the e-mail to your recipients.

RAS Dial

This Task uses your computer's modem to connect to a dial-up e-mail account.

Use the RAS Dial and Hangup Tasks only if you have a dial-up Internet connection and are using a direct SMTP connection as your 

e-mail sending method.

RAS Hangup

This Task complements the RAS Dial by closing a dial-up Internet connection.



Generating Mail

The first Task you will need to configure is a Merge It Task, so you can merge the e-mail and get it ready for sending.

More:
To generate e-mail with a Merge it Task



To generate e-mail with a Merge it Task

1. Click Add Task.

The Task Selection box appears.

2. From the list of Tasks, choose Merge It.

The Merge It screen appears.

3. Use the drop-down menus to enter information in the following fields:

· Use this Database Filter definition

Choose the name of the Database Filter to use as your data source.

To see the available Filters, click the  button to open the Filter selection window.
· Get e-mail address from field
Choose the database field that contains your recipients' e-mail addresses. 
Campaign will try to detect the correct field automatically. If it chooses an incorrect field, choose the correct one from the drop-down 
box.

· Use this e-mail message

Choose the name of a message you wrote or imported in Campaign's Message Editor.

To see the available Messages, click the  button.
· Alternate e-mail message (optional)
Choose the name of a message to use as an alternate message. 
This field lets you use Campaign's A/B messaging feature, which is a powerful marketing tool to help you compare response rates 
and the effectiveness of two messages.

To see the available Messages, click the  button.

View example

4. To use the current Merge It Task as part of an e-mail campaign, check the Enable e-mail scheduling box.

See Campaigns for instructions on creating and managing e-mail campaigns.

5. Click OK to exit and save the Task.
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A Merge It Task set up to send a welcome message to new customers.



Other Options

The Merge ItTask has several optional features that can greatly enhance your efficiency and task automation.

More:
Writing to your database

Word Wrap

Alternate Message

X-Header



Writing to your database

Campaign can not only read your database, it can write to the database as well. 

The value of Campaign writing to your database is partly for good recordkeeping, but more importantly, it can modify records for use 

in future database filters.

For example:

You have a Campaign mailing that is set up to send a sales or information brochure to new customers. Your database includes a 

field called "Brochure", which notes whether the brochure was sent. So with a Merge It Task, Campaign can automatically record the 

date that the brochure was sent, saving you from recording the date yourself.

Or, if your database supports checkboxes or True/False fields, the Merge It Task could mark a checkbox to indicate whether the 

brochure was sent.

You can use the Merge It Task to record a date, a number, or text to any database field.

To record data to your database with a Merge It task

1. In a Merge It Task, open the Set field drop-down box.

Choose the name of a database field. This is the field that Campaign will write to. Do not use a field that already contains 

important information, as Campaign will overwrite any existing data in that field when the Merge It Task runs.

2. Now open the drop-down menu in the field to the right of the first one. Choose the type of information that Campaign should 

write in the database. There are four options:

· A Value: Sets the field to a user-specified value after sending. 

· Today's Date: Writes today's date to the database field after merging.

· Increment 1: Increases the value of the field by 1 after sending. This option only works with numeric database fields.

· Decrement 1: Decreases the value of the field by 1 after sending. This options only works with numeric database fields.

3. If you chose A Value in the previous step, a third field labeled Value will appear. Enter the text or number for Campaign to write 

to the database. 

For example, if you enter the word "Yes" as the Value, Campaign will write "Yes" to the specified database field.

Example

{button ,AL(`emcampaign',0,`',`')} Related Topics



This Merge It Task notes that a newsletter was sent to subscribers, by writing "Sent" in the database field called "Newsletter". 



Word Wrap

The word wrap option lets you add carriage returns automatically to your e-mail. This option saves you from having to insert carriage 

returns manually in the text of your message, and ensures that all your recipients will be able to read your message as you 

intended. 

Some e-mail clients, such as Netscape Mail, do not add auto word wrapping to incoming messages. If carriage returns were not 

added to the message when it was composed, some recipients may see an unformatted message as one long line of text.

The value you enter here is the maximum number of characters allowed in each line of your message.

To set word wrapping
 In a Merge It Task, enter a value for Automatically wrap lines at __ characters in the outgoing e-mail.

The default value is 0 (no wrap). 
An average range for word wrapping is 50-60 characters per line.
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Alternate Message

The Alternate Message feature provides a valuable option for direct e-mail marketing. It uses the marketing principle of A/B 

message testing to compare the response rates of two messages with the same intent but different wording. 

When the alternate message option is on, the Merge It Task will generate e-mail by alternating between the first and second 

messages.

To set an alternate message

1. Configure a Merge It Task with the basic required information (Filter, e-mail address field).

2. From the Use this e-mail message menu, choose the first message to send.

3. From the Alternate e-mail message menu, choose the second message to send.
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X-Header

You can use the contents of a database field as extended header information in your e-mail. This data will show up in some e-mail 

clients (such as Eudora Pro) only when the user requests extended sending information.

X-header information can help users filter e-mail before reading it, or for senders to identify clearly the nature or source of the e-

mail.

The X-header feature will also help integrate Campaign with upcoming versions of SignUp, an application by Arial Software that 

posts e-mail web form data to your database.

To set the X-header
From the Set X-header to field menu, choose a database field name.
Information in this database field will be added to the extended header information of your e-mail messages.



Reporting

After you run a Project, Campaign displays a report log. The log file summarizes Campaign's activity, including a count of the 

messages it generated and sent.

You can print the Project summary to keep a record of Campaign's mailing activity.

More:
To print the Project log



To print the Project log
 Click Print.



Campaigns

The unique feature that gives Campaign its name lets you go beyond simple e-mail broadcasts. Campaign's greatest value is its 

ability to send not just one message, but a series of automated follow-ups; an easily executed e-mail "campaign" to communicate 

your sales, marketing, technical support, or customer service messages. 

More:
How an e-mail campaign works

The elements of an e-mail campaign

Setting up



How an e-mail campaign works

1. Suppose you have four e-mail messages in a campaign that go out to each new customer after they buy your product. The 

campaign starts with a thank you message on the day of purchase. After that, each successive message goes out in 1 week 

intervals.

2. John Doe orders your product. His name and contact information is added to your database in a new customer record; the 

record also includes the date of his purchase.

3. Campaign later runs and detects John Doe's new record in the database. The new record triggers the e-mail campaign to start, 

so Campaign sends the first message of the campaign to John Doe and other customers added to the database that day.

4. A week later, the same Campaign Project is run. Campaign reads the customer database and detects that a week has passed 

since Mr. Doe got his first message, which means the second message in the campaign is now due. John then gets his second 

message.

5. In another week, the same process occurs and the third message in the campaign is sent. Finally, in the fourth week, the 

Project runs and sends the last message of the campaign to Mr. Doe.

Carrying out this campaign manually would be a difficult chore. To do so, you would have to continually keep track of each new 

customer, track the status of the mail campaign, write all the messages for their recipients, and prepare the mailing.

Yet with Campaign, it takes only one click to do the same process after you do the initial configuration.



The elements of an e-mail campaign

Open a Merge ItTask. The right half of the screen has a large text box containing data fields and grayed-out text. When you click the 

checkbox that says Enable e-mail campaign scheduling, this section becomes active.

There are three fields on this screen necessary to define a campaign: a starting date, relative sending date, and status.

Starting date

The starting date is the cornerstone of an e-mail campaign, for it determines when each message will be sent. The starting date can 

be the day a customer made a purchase, contacted you for information, or signed your web guestbook, for example. Any date will 

work.

The starting date should never be modified.

In the Merge It Task, the starting date for a campaign is indicated in the field called Field containing campaign starting date.

Use the drop-down box to choose the database field with the starting date. 

Microsoft Access tip

Relative sending date

The value entered for Number of days after start date to e-mail this message determines when each message in a campaign will 

be sent .

The relative sending date is the number of days after the starting date. Campaign compares the current date (according to your 

computer's internal system clock) to the starting date; if the indicated number of days have elapsed, Campaign generates and sends 

the correct e-mail.

For this field, you won't enter a calendar date; instead, enter a number. This number is the number of days after the starting date 

that a message will be sent. 

If your starting date is June 1 and you enter 7 as the sending date, the message will go out on June 8 (7 days after the starting 

date).

Status

The status field, labeled Field to reserve for campaign status on the Merge It screen, is necessary for Campaign to track the 

progression of an e-mail campaign. 

When a message in the campaign is sent, the contents of the status field are updated. For instance, after you send a message that 

goes out 7 days after the starting date, Campaign writes "7" in the status field. 

The status field must be a numeric type field.



Setting up 

Before you create an e-mail campaign, you may need to make additions or changes to your database.

Database

You will need database fields for a starting date and campaign status.

Starting date field

The starting date is the reference point for an e-mail campaign. Campaign uses the starting date to calculate when to send each 

message to each recipient.

Your database records must have a date field in order for the campaign function to work. If you plan to create e-mail campaigns but 

your database records do not have a starting date field, you will need to modify the database to add a date field.

The starting date field must be a date-type field. If the field type is text or numeric, Campaign will not recognize the contents as a 

date and the e-mail campaign will not work properly.

Microsoft Access users: Make sure the starting date field uses Long format. Campaign will not recognize dates in Short format.

Status field

The status field lets Campaign keep track of where each recipient is in a campaign. For example, suppose you have a campaign 

that sends e-mail on a weekly basis. After sending the first week's message, Campaign writes "7" to the status field (meaning that 

the message was sent 7 days after the starting date); when it sends the second week's message, it updates the status field to "14"; 

after the third message, "21", and so on as the campaign progresses.

The status field must be a numeric type field. To set up a status field, simply create a new numeric field in your database. Do not use 

a text or date field for the status; if you do, your campaign will not run correctly.

Also, never edit the contents of the status field manually, especially after a mailing. If you ever change or delete the contents of the 

status field, you will disrupt the e-mail campaign, potentially sending some of your recipients multiple copies of a message they have 

already received.

Campaign

After your database is set up properly, you may also need to prepare Campaign before creating an e-mail campaign.

What you need in Campaign:

Messages

Before you actually assemble an e-mail campaign in a Project, you need the messages that will constitute the campaign. 

A series of related messages is called a "campaign." You will need to write at least two messages to take advantage of Campaign's 

capabilities. 

Your campaign may use the simple structure of one substantial message (such as an order confirmation) with a shorter follow-up 

message sent a few days later. 

Or you can have a longer campaign, consisting of many messages sent over a longer period of time.

For information on using the Campaign Message Editor, see    Composing Messages.

Intervals

Along with writing the messages, planning for your e-mail campaign also requires that you decide how much time should pass 

between sending the messages.

Although you may think in terms of intervals between each message, remember that all sending times are based on the campaign's 



starting date. So to send 3 messages that are each a week apart, the intervals would be 7 days from the starting date for the first 

message, 14 days from the starting date for the second message, and 21 days from the starting date for the third.

More:
To create an e-mail campaign



To create an e-mail campaign

1. Create a new Merge ItTask.

This Task will be for the first message in your campaign.

2. Enter the basic Merge It Task data by supplying information for the following fields:

· Use this Database Filter definition

Choose a Database Filter to use as the data source.

· Get e-mail address from field

Choose the database field containing recipients' e-mail addresses.

· Use this e-mail message

Choose the first message in your e-mail campaign.

3. Check the Enable e-mail scheduling box.

The grayed-out text becomes active. These fields provide scheduling information for your e-mail campaign.

4. Enter information in the campaign fields:

· Field containing campaign start date

From the drop-down box, choose the database field that contains the starting date for the e-mail campaign.

· Number of days after start date to e-mail this message

Enter the number of days that need to pass between the campaign starting date and the day this particular message will be 

sent.

· Field to reserve for campaign status

From the drop-down menu, choose the database field to use for recording the status of the e-mail campaign.

5. Click Save.

6. Click Add Task and create a second Merge It Task.

7. Configure the basic Merge It Task information for Database Filter and e-mail address fields.

8. For Use this e-mail message, choose the second message in your e-mail campaign.

9. Check Enable e-mail scheduling.

10. Enter information to schedule the second message in the campaign:

· Field containing campaign start date

Choose the database field with the starting date. Use the same database field you chose for the first Merge It Task.

· Number of days after start date to e-mail this message

Enter the number of days that will pass between the campaign starting date and sending the second message of the campaign.

· Field to reserve for campaign status

Choose the database field used for tracking the status. Use the same field you chose for the first Merge It Task.

View example

11. Click OK.

12. For the third and each subsequent message in your e-mail campaign, repeat steps 6-11.
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This screen is configured to send a message 7 days after the customer's date of purchase.



About Sending E-Mail

Merging mail is only half the battle of your mailing. The final, most important step is sending the messages to your audience.

Campaign sends e-mail using a Task called Mail It. A Mail It Task sends e-mail that is queued and waiting in Campaign's Out 

mailbox.

More:
Previewing and Sending Messages
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Previewing and Sending Messages

The placement of a Mail ItTask in a Project will affect your ability to preview e-mail before sending it.

When you run a Project, Campaign goes through it and performs each Task in the sequence it is listed. In order to preview 

messages before you send them, you will need to create separate Projects for merging messages and for sending them. 

Suppose you have a Project containing 5 Merge Ittasks and one Mail It task (in that order). When you run the Project, Campaign will 

start with the first Merge It Task, generating e-mail and queuing it to the Out mailbox. Then it runs the second Merge It, followed by 

the third, fourth and fifth. Finally, with all the e-mail from the five Merge It Tasks queued and ready to go, the Mail It Task sends out 

the messages to your recipients.

Immediate sending

If you want to send messages as soon as they're generated, add a Mail It Task to the same Project containing your Merge It Tasks.

For example, if you have a Project containing these tasks:

Merge It

Merge It

Mail It

Campaign will run the first Merge It Task and queue the resulting messages to the Out mailbox. Then the second Merge It Task runs 

and those messages are queued to the Out mailbox. Finally, the Mail It Task runs and sends the queued messages.

When the Project is complete, the messages are all sent, and they are not available for previewing.

Queue before sending

You may want to preview your outgoing messages before they're sent, so you can proofread them and make sure the recipient data 

was merged correctly from your data source.

To queue messages without sending them, you will need to create separate Projects for merging messages and for sending them. 

For example, suppose you have two simple Projects. Project One contains only Merge It Tasks:

Merge It

Merge It

Project Two consists of one Mail It Task:

Mail It

When you run Project One, it runs the first Merge It Task and queues the merged e-mail to Campaign's Out box. The second Merge 

It Task runs, generating a second batch of e-mail which is also queued to the Out box.

When Project One is complete, you can open the Out mailbox and preview the Project One messages, which are queued and 

waiting to be sent. Then, after you view the messages, you run Project Two, which mails the queued e-mail you just viewed.
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Sending Methods

Campaign offers numerous choices for the way to send your e-mail, but there are fundamentally two main options for sending mail: 

using Campaign as a standalone SMTP mail client that connects directly to the mail server to send messages, or using Campaign in 

conjunction with your favorite e-mail client software.

More:
Which Method Should I Use?

ISP Compatibility



Which Method Should I Use?

The way you send e-mail with Campaign depends on the type of Internet connection you have and your personal preferences.

Comparison chart

More:
Direct SMTP connection

Other e-mail clients



Direct SMTP connection

SMTP stands for Simple Mail Transfer Protocol, a widely used method for sending Internet e-mail.

A direct SMTP connection is the fastest method for sending messages with Campaign, because it lets Campaign communicate 

directly with your mail server. 

However, if your computer is part of a corporate LAN using a proxy server, you probably will not be able to send mail with a direct 

connection. Instead, Campaign can be used with your existing e-mail client to send e-mail.

If you have an e-mail account through an Internet Service Provider (except America Online or Juno) or web hosting service, your 

connection is most likely an SMTP connection. 

Different flavors of SMTP

You will notice that the Mail It Task provides a choice between SMTP #1 and SMTP #2. 

Each method uses the SMTP sending protocol but through a different mail control in the Campaign software. The choice is available 

to cover potential mail server incompatibility. If you find that one SMTP option creates difficulty with your mail server, you can use 

the other one.

Also, SMTP #2 does not support e-mail attachments. If you want to send messages through SMTP and attach files to your e-mail, 

use SMTP #1.
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Other e-mail clients

You can use Campaign to generate e-mail from your database, while actually sending the messages using your preferred e-mail 

client. 

Use Campaign with your e-mail client if you are in a corporate network setting that uses a proxy server.

Campaign works with the following e-mail client software:

· Lotus cc:Mail

· Lotus Notes

· Microsoft Outlook

· Microsoft Exchange

· Novell NetWare

· Banyan VINES



Sending methods 

Sending 
Method

Use it if Advantages Disadvantag
es

Direct SMTP 
connection

You have an e-
mail account 
with an Internet 
Service 
Provider*

You are in a 
local area 
network using 
an SMTP mail 
server and no 
proxy server.

Fastest way to 
send e-mail 
with Campaign

Fewer steps

Does not work 
in LAN with 
proxy server or 
non-SMTP 
mail systems

Other e-mail 
client

You prefer to 
send e-mail with 
your regular e-
mail client.

You are in a 
local-area 
network 
environment that 
uses a proxy 
server or 
firewall.

Easy to 
configure

Lets you send 
from familiar 
environment

No server 
information 
required

Extra step of 
transferring 
mail to the mail 
client

Advanced users may also choose mail sending protocols that work with their e-mail clients, including VIM, MHS, or MAPI.



ISP Compatibility

Campaign cannot send e-mail through an account with a proprietary ISP (such as America Online, Juno, Prodigy, or CompuServe) 

that require customers to use their special software to access the Internet. Most Internet Service Providers provide a generic 

connection to the Internet that allows you to use your choice of software. 



Sending Messages With Other E-Mail Clients

When you use Campaign with another e-mail client, you may need to take extra steps in the sending process. 

1. Run a Project containing Merge It Tasks.

The Merge It generates e-mail and queues it in the Campaign Outbox.

2. Run a different Project containing a Mail It Task.

The Mail It Task then sends mail from Campaign's Outbox to the Outbox in your main e-mail client.

So if you're using Campaign with Outlook, the Mail It Task will transfer e-mail from Campaign to Outlook.

3. Depending on the settings in your primary e-mail client, messages may be queued and waiting for you to send manually, or 

they may be sent immediately. 

If they are queued, open your main e-mail client and check the Outbox. Send queued e-mail as you would normally.

4. If you plan to automate a Campaign mailing with the Scheduler, you need to set your main e-mail client for immediate sending. 

Otherwise, campaign will be automated but messages will remain queued in the other e-mail client until you send them.

Consult your e-mail client documentation for instructions on configuring manual or immediate sending.



Configuring Mail It Tasks

After e-mail is generated and queued for sending, you will need to send it. Sending mail requires a Mail It Task.

More:
To create a Mail It Task for direct SMTP sending

To create a Mail It Task for sending through another e-mail client



To create a Mail It Task for direct SMTP sending

1. Open a new or existing Project.

2. Click Add Task.

The Task Selection box appears.

3. From the list of Tasks, choose Mail It.

The Mail It screen appears.

4. Enter information in the following fields:

Send mail via:

From the drop-down box, choose SMTP #1 or SMTP #2. 

Use SMTP #1 if you plan to send attachments with your e-mail.

SMTP Host Name or IP Address

· Enter the name of the mail server that handles your outbound (SMTP) e-mail.

· Alternately, if you know the numeric (IP) address of the mail server, you may also enter it.

Return E-Mail Address

Enter your e-mail address or the address to which recipients should reply.

TIP: To add your name to the address, use this format

"Name" <E-mail address>

Example: "John Doe" <jdoe@company.com>

(This format works with most, but not all mail servers).

Note: Some SMTP mail servers may change the return e-mail address on outgoing mail to the default address of the account 

used for sending. If the address is changed, contact your network administrator or Internet Service Provider.

5. Click Save to save and exit the Task.

If you haven't merged any mail yet, run a project with one or more Merge It Tasks to merge e-mail and queue it to the Out 

mailbox. Once the e-mail is queued, you can send it with the Mail It Task.

6. Choose View > Projects to open the Project selection window. Select the Project containing the Mail It Task you created. Click 

Run.

The Project Status progress box appears. It displays the number of messages being sent and the estimated time 
remaining in the mailing.

7. When the mailing is complete, the Project report appears, displaying the number of messages sent. Click Print to print a hard 

copy of the report.



To create a Mail It Task for sending through another e-mail client

1. Open your main e-mail client (cc:Mail, Outlook, etc) and leave it running.

2. In Campaign, open a new or existing Project.

3. Click Add Task.

The Task Selection box appears.

4. From the list of Tasks, choose Mail It.

The Mail It screen appears.

5. Enter your sending information in the following fields:

· Send mail via

From the drop-down menu, choose the e-mail application you want to use for sending e-mail. Use one of the following options:

MS Exchange or Outlook

Lotus cc:Mail

Lotus Notes

Novell GroupWise

Banyan VINES

· Advanced Users only

Instead of choosing a specific e-mail client, choose a sending protocol:

MAPI

Generic VIM messaging

Generic MHS messaging

6. Enter your account information:

· Profile Name: Enter the profile or user name for your e-mail account.

· Password (if applicable): Enter the password for your e-mail account.

8. Click Save to save and exit the Task.

If you haven't merged any mail yet, run a project with one or more Merge It Tasks to merge e-mail and queue it to the Out 

mailbox. Once the e-mail is queued, you can send it with the Mail It Task.

When you run the Mail It Task, the e-mail will be sent from Campaign's Out mailbox to the Outbox in your main e-mail client.

9. Choose View > Projects to open the Project selection window. Select the Project containing the Mail It Task you created. Click 

Run.

The Project Status progress box appears. It displays the number of messages being sent and the estimated time 
remaining in the mailing.
10. When all messages are sent, the Project report appears, displaying the number of messages sent. Click Print if you want 
a hard copy of the report.

11. If your main e-mail client is set up to send messages immediately, it will begin delivering messages to your recipients.

However, if the e-mail client queues messages until you send them manually, you will now need to send them. 

Open your Outbox of your main e-mail client. The messages from Campaign will be queued for sending. Send e-mail as you 



would normally.



Sending Defaults

You can set Campaign's default sending information in the Options screen, which is accessible from the main menu bar. Options 

marked below with an asterisk (*) apply to SMTP sending only.

Send Mail Thru:

This option sets the default method for sending e-mail. 

Choose SMTP for sending mail through a direct server connection, or choose your preferred e-mail client from the list of compatible 

applications.

Advanced users can choose a specific sending protocol instead of an e-mail application: VIM, MHS, Banyan VINES, or MAPI.

SMTP Host Name or IP Address*

Enter the name of your SMTP mail server. 

Most commercial ISPs use a format like this:

mail.ispname.com 

mail.ispname.net

smtp.ispname.com 

smtp.ispname.net

where "ispname" is the name of the provider. For example, Concentric's mail server is smtp.concentric.net. 

You should be able to find the SMTP Host Name in your main e-mail client's settings or options screen. Look under in the settings 

under Mail Servers or Hosts for the mail server name.

If you do not know the mail server information, contact your network administrator or ISP.

Alternately, you can use the mail server's IP address instead of the DNS name. The IP (Internet Protocol) address is a identifying 

number such as 204.159.111.101. Only use the server's IP address if you are sure of it; otherwise, use the server name.

SMTP Retries*

Sometimes Campaign may be unable to connect to your mail server for various reasons (the server may be busy or rebooting, for 

example). If Campaign cannot connect to the mail server, it will stop and subsequently try again to connect. This field sets the 

number of times that Campaign will try to connect. The default value is 5 tries.

SMTP Timeout*

A timeout occurs when Campaign cannot open an SMTP connection. The value you enter here determines how long Campaign will 

wait when trying to open a connection.

The default value is 30 seconds. That means Campaign will try for 30 seconds to open an SMTP connection; if the server is busy 

and a connection cannot be established, Campaign will stop, then try again. The SMTP Retries option (above) determines how 

many times Campaign will try to make a connection.

Signature

Use the Signature field to enter text that will appended to the end of each outgoing message.

When you activate the Signature in a Mail Ittask, Campaign will append the contents of this box to each e-mail.

Using a Signature allows you to standardize your e-mail with your contact information. It also saves you from having to retype the 

same lines each time you compose a new message with the Message Editor.



Turn on debugging

The log file records exchanges between Campaign and your mail server computer. This information can pinpoint sending problems 

with an SMTP connection. Check this box to create a log file when Campaign sends e-mail.

Do not show startup tutorial

Prevents the tutorial help file from appearing when you launch Campaign.



Mailboxes

Campaign has two mailboxes to help you track messages before and after they are sent: the Out mailbox (holds messages before 

sending) and the Sent mailbox (holds messages after sending).

Note that Campaign does not have an Inbox because it does not receive e-mail; it only sends messages. 

More:
Out mailbox

Sent mailbox
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Out mailbox

The Out mailbox displays all the outgoing e-mail that is waiting to be sent. Mail remains queued (and will accumulate) in the Out 

mailbox until you run a Mail It Task. 

The Out mailbox shows the recipient's e-mail address, the message subject, and the message text. You can manually edit any text 

in the Out mailbox.

To select a queued message

1. Move the pointer into the left-hand column made up of gray boxes. 

2. The pointer will turn into an arrow pointing to the right.

3. Click the gray box in the row with the recipient and subject of you want to select.

More:
Sorting queued messages

Skipping queued messages

Deleting queued messages



Sorting queued messages 

The Out mailbox displays messages in the order they are produced by a Merge It Task. However, you can sort e-mail by recipient 

and by subject.

Sorting only affects message viewing , not message sending.

To sort queued messages by recipient address
 Click the To heading.

To sort queued messages by Subject 
 Click the Subject heading.



Skipping queued messages

As you preview queued mail, you may find messages that you don't want to send right away, but you don't want to delete them 

either. Campaign can skip over selected messages during a mailing, allowing you to leave them queued in the Out mailbox until you 

want to send them.

To skip a selected queued message
 Check the Skip? box next to the recipient's e-mail address.

To skip all queued messages
 Click Skip All.

To remove a skip on a selected queued message
 Uncheck the Skip? checkbox next to the recipient's e-mail address.

To clear all skips
 Click Clear Skips.

To send skipped messages

1. Clear the Skip checkbox for the messages to send.

2. Click OK.

3. Choose View > Projects.

4. Select a Project containing a Mail It Task.

5. Click Run.



Deleting queued messages

When you want to delete messages in the Out mailbox, you can delete individual messages, all skipped messages, or all messages 

in the Out mailbox.

To delete a selected queued message
 Press Delete.

To delete queued messages that are marked as skipped
 Click Delete Skips.

To delete all queued messages
 Click Delete All.



Sent mailbox

The Sent mailbox displays e-mail that Campaign successfully sent. The Sent mailbox has most of the same functions as the Out 

mailbox

More:
Deleting sent mail



Deleting sent mail

Sent messages will accumulate in the Sent mailbox until you delete them. Left unchecked, the Sent mailbox can grow very large 

and consume vast amounts of hard drive space. Delete the contents of the Sent mailbox regularly.

To delete a selected sent message
 Press Delete.

To delete sent messages marked as skipped
 Click Delete Skips.

To delete all sent messages
 Click Delete All.



Connecting to the Internet

With a dial-up account, the RAS Dial and Hangup Tasks are necessary to automate any message sending. 

A Dialup Task will automatically use phonebook entries created with Windows 95 Dialup Networking. To create or edit a phonebook 

entry, use Windows Dialup Networking.

The RAS Dial and Hangup Tasks are only necessary for dial-up Internet accounts. If your computer is on a network with a full 

Internet connection, you do not need to add any special configuration to Campaign to open or close an Internet connection.

More:
To configure an RAS Dial Task



To configure an RAS Dial Task

1. Open a new or existing Project.

2. Click Add Task.

3. Choose RAS Dial from the Task list.

4. Use the drop-down menu to choose a dial-up phonebook entry.

5. Click Save.



About Automating Campaign

If you use Campaign for ongoing communication, such as for an e-mail marketing campaign or regular customer contact, you can 

make it even easier by automating with Campaign's Scheduler.

With the Scheduler, you can make any Project in Campaign run unattended at regularly scheduled intervals. If your database sees 

steady, frequent activity (like customers being added, or website visitors signing your guestbook), you can generate and send mail 

by the hour or minute. For slower activity, you can set a Project to be run once per day. 

And if you use a dial-up Internet connection, Campaign can be set to dial in to your account, send messages, and disconnect.



Scheduler

Campaign does most of the work for a mailing (namely, merging and delivering messages) but it usually needs a user present to 

click Run and start the processes of generating and sending mail.

However, the Scheduler eliminates the need for you to be present to run Campaign. Basically, the Scheduler schedules a Project to 

run at selected intervals. The smallest interval is once per minute; the longest one is once per day.

You can automate any Project listed in the Projects window.

More:
To automate a Project



To automate a Project

1. Choose View > Scheduler

OR 

Click the Schedule button on the Projects window.

2. Click New. Name the new scheduled item and click OK.

The Scheduler screen appears.

3. Using the drop-down boxes, enter information for the following fields:

· Project to run

Choose the name of a Project to automate.

· Run every

Choose the interval for running the project. 

You can choose from 30 intervals, from once per minute to once per day.

4. Check the Active box.

5. Click Save.

6. On the Project selection window, check the Schedule Active box.

 

When the Scheduler is active, the graph icon will be animated.



Preparing for automation

After you schedule a Project for automation, you still need to make sure that your desktop computer is properly set up for Campaign 

to run automatically.

What to leave open:

· Your computer

· Campaign

· Network connection (LANs)

· If you are using Campaign with another e-mail client (such as cc:Mail or Outlook), leave the second e-mail client running.

· If you have an external modem and a dial-up Internet account, make sure that the modem remains on and connected to a 

phone line.

Your database or contact manager application does not have to be open in order for Campaign to merge or send e-mail.

More:
Automating with a dial-up Internet account



Automating with a dial-up Internet account

If you use a modem to up and access your dial-up e-mail account, your automated Projects in Campaign must contain RAS Dial and 

Hangup Tasks.

These special Tasks use the computer's modem to dial your Internet account, open a connection for sending e-mail, then disconnect 

after the messages are sent.

The basic order of the Tasks in a simple automated Project would be:

Merge It (to generate e-mail and queue it for sending)

RAS Dial

Mail It (to send the e-mail)

RAS Hangup

Note that e-mail merging process can be completed offline. The only time that you need to have an open Internet connection is for 

sending messages. 

Note too that the Hangup Task is equally important as the Dial Task. Without the Hangup, your computer could remain connected 

indefinitely (although most ISPs will timeout a connection that remains idle for a long period of time).



Common Problems and Solutions 

Database filter/Merge It can't find e-mail addresses in an ACT! file

Mail transferred to e-mail client has to be sent manually from that client

Campaign stops during a mailing (SMTP connection)

E-mail sent with Campaign has old return address

Recipients see text of e-mail in one long line

Messages won't send

Messages aren't available for preview in the Outbox



Database filter/Merge It can't find e-mail addresses in an ACT! file

If you want to send e-mail from Campaign to contacts in an ACT! database, you will need to take an extra step and modify the 

database. 

The reason lies in the structure of an ACT! contact file. An ACT! database contains a default field called "Email". However, the 

information in that field is stored in a file that is kept physically separate from the rest of the database; in effect, hiding the addresses 

from Campaign.

Solution

In ACT!, copy e-mail addresses for your existing contacts into a different, unused database field, such as one of the User fields. 

{button ,AL(`datasource',0,`',`Main')} Related Topics



Mail transferred to e-mail client has to be sent manually from that client

If you use Campaign with an e-mail client such as Outlook, Notes, cc:Mail, or GroupWise, you will generate messages in Campaign 

but ultimately send messages through the other client software.

Solution

If you have the main e-mail client set up to queue messages until you manually send them, the same situation will happen with a 

Campaign mailing. If you would prefer to eliminate that additional step, you will need to configure your main e-mail client to send 

messages immediately.

Consult the e-mail client documentation for configuring immediate sending.
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Campaign stops during a mailing (SMTP connection)

Campaign sends mail very rapidly when it is connected directly to an SMTP mail server. However, the drawback is that the volume 

and speed of a mailing can overwhelm slow mail servers, causing Campaign to stop in the middle of a mailing.

Solution:

If this occurs, adding a 1 or 2 second delay between each message will pace the mailing more evenly and reduce the pressure on 

the mail server.

To add a delay between messages, open your Mail ItTask, and enter a value for Send messages __ seconds apart. 

Another potential cause of mailing errors may be incomplete e-mail addresses (specifically, addresses without the "@" sign, 

necessary for Internet e-mail). 

You can scan the Out mailbox manually for bad e-mail addresses. An easier way is to add criteria to your Database Filters that filters 

only addresses with the @ sign.

{button ,AL(`sending',0,`',`')} Related Topics



E-mail sent with Campaign has old return address

You may be running a Mail It Task that uses an old return address. 

Solution:

To update the return address on the e-mail, edit the Return E-Mail Address in all existing Mail It Tasks.

OR

Your mail server may be changing the return address. Some mail servers change the return address on outgoing e-mail to the 

default address for the account. 

Solution:

Ask your network administrator to update the e-mail account you are using to send mail with Campaign.



Recipients see text of e-mail in one long line 

Campaign sends your e-mail exactly the way you typed it (or pasted it in from the clipboard). This means that if you don't manually 

put in line breaks, the e-mail may not actually be broken up at the receiving end. 

This is because some e-mail clients will word wrap, but amazingly, others won't. Eudora, for example, forces word wrap for incoming 

mail; Netscape Mail does not.

Solution

Campaign can add line breaks with the auto word wrap function. You can adjust the per line character count in a Merge It Task. The 

default is 0, but 50-70 is a good range if you decide to adjust the line length manually.
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Messages won't send

A common problem for SMTP users is an incorrect mail server or domain name in your Mail Ittask or Options screen. 

Solution

Check that you have entered the correct server and domain settings. If you are unsure about the correct settings, try using the 

settings in your other e-mail software (such as Eudora). Contact your system administrator or Internet Service Provider if you are 

still unsure.

Make sure you are have an active Internet connection before sending e-mail. 

{button ,AL(`sending',0,`',`')} Related Topics



Messages aren't available for preview in the Outbox

You may be using a Project that contains a Mail It Task along with a Merge It Task. This causes messages to be sent immediately, 

without the chance to preview them.

Solution

If you want to preview messages before sending, make sure the Project you used to merge your mail does not contain a Mail It 

Task. Use a separate Project that contains only a Mail It Task.

{button ,AL(`previewing',0,`',`')} Related Topics



Error Messages

"DBQuery (LoadTableBox: Couldn't find file __ ) An error occurred loading the filename or table 

specified. Choose a different filename."

· Campaign cannot find your database file because the path or file name is wrong or outdated. Open the Database Filter and use 

the Browse box to provide the correct path and file name.

"Error: ExecuteProject - There is an error in the Database Filter criteria section or the SQL 

statement.  This can usually be caused by not using operators on number-type fields.  Check the 

criteria of the DB Query."

Open the Database Filter you are using.

· Click Preview. If you cannot preview the filter results

· If you are using an Advanced SQL Filter, check that you are using operators that correspond to the database field types.

"An unknown error has occurred. Edit this project and review the settings."

This message occurs when there is a problem with the data source.

Open the Project that you tried to run. 

· Check each Merge ItTask.

· Is the correct Database Filter selected?

· Is the correct E-Mail Address field selected? 

· Is the correct Message selected?

· Is the database file used by the Database Filter currently open? If so, close it.

· Are you logged on to your computer as the correct user? Do you have user permission to access the database file?

Open each Database Filter being used in the Project.

· Click Preview. Are you able to preview data?

· If you cannot preview the database, the location, name or format of the database may be wrong. Check the settings, and if 

necessary, enter them again until you can preview information.



Technical Support

Your purchase of Campaign comes with 30 days of complimentary telephone technical support and lifetime e-mail support.

You may purchase extended support plan packages. Contact Arial Software for details.

Phone

(503) 646-4515 (8 a.m.- 5 p.m. PST)

E-mail

support@arialsoftware.com

Please include the following information in technical support e-mail so we can better serve you:

1. Your Campaign serial number.

2. Your computer system hardware.

3. What you were doing when the problem occurred.

4. Steps you tried to correct the problem.

5. Your storage file (if applicable).

WWW

Home page

http://www.arialsoftware.com

Go to the main Support section to find these pages:

· Knowledge Base

Specific technical support issues, solutions and workarounds for Campaign

· Frequently Asked Questions

General questions and answers about features and usage of Campaign 3.0



SQL in Campaign

If you're already familiar with SQL, you know that a simple SQL filter    usually starts with the SELECT command, which specifies the 

database you want to filter. In Campaign's SQL window, however, you don't need the SELECT, FROM, or even the WHERE 

command. You also don't need to close a statement with a semicolon.

Normally, a basic SQL statement for locating specific records might begin with Select…From Where, with Select defining the From 

defining the database and Where setting the criteria.

Select From CustomersDB Where LastName like Rogers

However, the Database Filter in Campaign already specifies the full database path in the Database File Location field. Therefore, do 

not use the Select…Where syntax in the Advanced filter. In fact, Campaign will return an error message if you do.

This query in Campaign would be

LastName like Rogers

Note: Campaign can use only one data source per filter. It is not possible to write an SQL command to link relational databases in 

Campaign. 

If you use Microsoft Access, however, you can have Campaign read an Access Query, and you can define relational queries directly 

in Access.



Syntax

Simple SQL filters use English words, such as LIKE, TO, and IN. Yet your searches can be very sophisticated simply by using a few 

basic commands. 

An SQL statement in Campaign follows this syntax:

[field name] [operator] [value]

For example, in the filter LASTNAME='Doe', LASTNAME is the database field name, = is an operator, and Doe is the value. This 

filter would find all database records where the last name is "Doe."

You need to observe a few rules when building an SQL filter in Campaign:

· SQL commands are case-insensitive, but they are capitalized in this section for emphasis. However, you should enter your filter 

data in the same case that it is stored (i.e., if you stored last names with only the first letter capitalized, you would search for a 

name as Flynn, rather than as flynn or FLYNN).

· Text strings must be enclosed in single quotes ( ' ).

· You must separate field names with commas. 

· Field names containing a space (i.e., Last Name, ZIP Code) must be enclosed in brackets [ ].

· The Basic and Advanced screens may not both contain information in the same filter. 



Operators

Operators help define the SQL filter. There are different types of operators that you'll need for SQL filters in Campaign: comparison, 

character, logical, arithmetic, and other.

Comparison operators

Character operators

Logical operators

Arithmetic operators

Other operators



Comparison Operators

Operator Description Example

= Finds text or numbers 
equal to the value you 
specify.

LASTNAME = 'Pool'

AREACODE = 123

>, >= Finds text or numbers 
greater than (or 
greater than or equal 
to) the value you 
specify.

AREACODE > 500

STATE >= 'M*'

<, <= Finds text or numbers 
less than (or less than 
or equal to) the value 
you specify.

STATE < 'I*'

PURCHASES <= 5

<> Finds text or numbers 
not equal to value you 
specify.

STATE <> 'NY'

ZIPCODE <> 05602

TRUE Finds database fields 
that contain data.

EXCLUDE IS TRUE

FALSE Finds empty database 
fields.

EXCLUDE IS FALSE

NULL/NOT NULL Finds fields with or 
without data.

EXCLUDE IS NULL

When the greater than and less than operators are applied to text, Campaign will search in alphabetical order. For instance, in the 

table above, STATE < 'I*' would find state names starting with A through H.

The TRUE/FALSE and NULL/NOT NULL operators are useful if you have database fields that are not filled in for all records, such as 

the checkbox function in Microsoft Access. In the table above, for example, if you have a checkbox for customers who want to be 

excluded from future e-mail notices, the NULL or TRUE/FALSE commands can look for customers who don't have a check in the 

Exclude box.



Character Operators

Operator Description Example

LIKE Finds similar patterns 
of text or numbers; 
used with wildcards

(see below)

* (asterisk) Wildcard for multiple 
characters.

LASTNAME LIKE 
'P*'

E-MAIL LIKE 
'*@*edu'

? (question mark) Wildcard for one 
character.

LASTNAME LIKE '?
p'

AGE LIKE 5?

LIKE is used when you employ wildcards. Use the = operator when you want an exact match (LASTNAME = 'Phillips'), and use 

LIKE for wildcards (LASTNAME LIKE 'P*').



Logical Operators

Operator Description Example

AND Finds data matching 
two or more 
expressions

STATE = 'NY' AND 
PURCHASES >5

LASTNAME LIKE 
'P*' AND 
OCCUPATION = 
'ACCOUNTANT'

OR Finds data matching at 
least one of multiple 
expressions.

ZIPCODE = 02134 
OR ZIPCODE = 
95818

NOT Finds data not 
matching information 
you specify.

LASTNAME NOT 
LIKE 'P*'

AREACODE NOT 
LIKE 8*

Notice that these operators, especially AND, opens the door for very specific filters. The example demonstrating AND in the table 

above, for instance, shows a filter for accountants whose last name starts with P.



Arithmetic Operators

Operator Description Example

+ Adds values in 
different database 
fields.

SALARY + 
COMMISSION > 
50000

- Subtracts values in 
different fields.

SALARY - TAXES > 
50000

* Multiplies values in 
different database 
fields.

PAYMENT * 
INTEREST > 100

/ Divides values in 
different database 
fields.

PURCHASES / 
RETURNS > 5

Arithmetic operators lets you build filters involving simple math functions. For instance, the table shows you how to use the addition 

operator to find all employees whose base salary and commission together exceed $50,000:

SALARY + COMMISSION > 50000

Note that "Salary" and "Commission" are two separate database fields; with SQL, you've just done a simple spreadsheet-type 

calculation.



Other Operators

Operator Description Example

IN Creates a list without 
using separate OR 
statements.

STATE IN ('TX', 
'VT','AK')

BETWEEN Creates a range of 
values.

PURCHASES 
BETWEEN 1 AND 25

The IN and BETWEEN commands let you cut out the wordiness of complex SQL filters.    For instance, if you wanted to find 

customers in four different ZIP codes, you would have to write four OR steps:

ZIPCODE = 02134 OR ZIPCODE = 95818 OR ZIPCODE = 75693 OR ZIPCODE = 49586

But use IN to write a much simpler list:

ZIPCODE IN(02134, 95818, 75693, 49586)

Note that the criteria following IN must be enclosed in parentheses.

BETWEEN eliminates the greater than/less than signs for creating a range of values.

If you wanted to find all customers whose ZIP codes fall within a certain range, you would need greater than/less than symbols:

ZIPCODE >95818 AND ZIPCODE < 97213

That becomes less clunky with BETWEEN:

ZIPCODE BETWEEN 95818 AND 97213



Glossary of Terms

e-mail client

ISP

Mail It

Merge It

Project

SMTP

Task



e-mail client

The software you use normally to send e-mail from your desktop computer. (Client refers to the client/server relationship of a 

computing network.) Campaign can work directly with several e-mail clients from Microsoft, Lotus and Novell.



ISP

Internet Service Provider. A company that provides access to the Internet and other services, such as e-mail accounts and web 

hosting. A personal or commercial ISP account is usually accessed through a dial-up connection with a modem.



Mail It

A task that sends e-mail that is currently queued in Campaign's Out mailbox.



Merge It

A task that generates e-mail by merging data from your data source into your message. You can also use a Merge It task to create 

an e-mail campaign, set word wrap or use A/B messaging.



Project

A series of one or more tasks. You can create a Campaign project consisting of a single task, or of several different types of tasks.



SMTP

Simple Mail Transfer Protocol. A standard method for sending Internet e-mail. Using SMTP is the fastest way to send mail with 

Campaign, because it opens a direct connection with the mail server.



Task

A specific action that Campaign carries out, such as merging data or sending e-mail. 



In Access' Design view, set the default value of the date field to "Date ( )",which will automatically add the current date when a new 

record is created.




