WAV

The filename extension of a file that contains sound that's been recorded and saved in Microsoft's standard WAVE file format.



AUT

The filename extension of a backup file that DemoShield creates in Windows 3.1 when you enable Auto-Save on the Preferences
dialog box. In Windows 95, auto save files are named "Auto Save of .dbd".



.AVI

The filename extension of an Audio Video Interleaved file, which can contain several streams of data including a video sequence
and (optionally) sound.



.BAK

When you save changes to an existing demo (DBD) file, DemoShield automatically backs up the previous version of the DBD file. In
Windows 3.1, these backups are saved with a BAK extension. If a backup copy exists, the current BAK overwrites and replaces the
previous BAK file.

Backup files are identical to DBD files in every other way. To bring a BAK demo file on screen, simply rename the file, giving it a
DBD extension.

In Windows 95, backup files are given the name "Backup of .dbd."
Note: The only filename extensions used in the 32-bit version of DemoShield are .dbd and .tpl (template files).



.BMP

A bitmap file containing an image. The screen captures you make in DemoShield are bitmap files. You can display a bitmap image
on a Bitmap Button, in a closed Graphic Object, or as the background of a scene.



.DBD

Every demo file that you create and save in DemoShield has a .DBD extension.



.EXE

An executable file. Application program files usually have an .EXE extension, like DESIGNER.EXE and DEMO.EXE. You can run an
EXE file and use it in a demo or tutorial that teaches or advertises a software application.




.SCM

ScreenCam Movie (.SCM) files are video files you can play in DemoShield. SCM files are created by Lotus ScreenCam, an
application you can use to create video screen captures of other software applications. For your viewers to play .SCM files in your
demo, you must include the SCPLAYER.EXE file on your distribution disks.



WMF

A Windows metafile containing an image. You can display a metafile image in a closed Graphic Object or as the background of a
scene. When importing a metafile, the Image Option selections are grayed out. After the metafile is imported, you can resize it as

you wish--as long as the .wmf is an Aldus placeable metafile. If the metafile does not have a placeable header, you can import it into
DemoShield but you cannot resize it.



256-color systems

Related steps

A 16-color system has 16 colors, and it can display any of those colors at any time. A 16-million color system has 16-million colors it
can also display at any time. A 256-color system, however, does not mean the screen has 256 colors, and it can display any of those
colors at any time. In fact, the term 256-color system doesn’t mean colors. It means 256 places. In fact, 20 of the 256 places are
reserved for Windows system colors.

When DemosShield is creating the color palette for a scene, it takes the first 256 colors and they come from all types of objects. They
can be object background colors, fill colors, wash colors, or colors in bitmaps or metafiles. DemoShield registers each color, and
when the number reaches 256, it stops and closes the palette. There is one exception: the scene background color has the lowest
order of precedence.

What happens when you try to use too many colors? Imagine a scene in your demo containing three bitmaps and several objects
that together add up to 200 different, distinct colors. Let’s say on top of that you add a wash that alone uses 100 colors. That makes
300 colors and that's too many. DemoShield closes the palette at 256 and the other colors won't appear on your demo screen. For
your objects, DemoShield will map the additional colors to colors it has already created in its color palette for the scene. DemoShield
will use system colors to produce your scene background. As a result, you may get a scene background color totally different from
what you expected. You may like the color and decide to keep it. If not, you'll need to choose another color.

Displaying 256-color bitmaps: graphic objects vs.scenes

Because scene background colors have the lowest order of precedence in creating the color palette, you will realize better results by
importing 256-color images into a Graphic Object or a Bitmap Button instead of a scene.

If you still have problems displaying your bitmap correctly, you may wish to use a graphics conversion program to dither the graphic
to 16 colors.



AV file

A standard file format for storing audio and video data. An AVI (Audio Video Interleaved) file can contain many different streams of

data, including sound and video. AVI files have the extension .AVI. You can play any AVI file in your demos using the Play Video
action or an AVI object.



About Video Files
Create an AVI Object to play an Audio Video Interleaved (AVI) file in your demo. You can also play an AVI (or SCM) file in your demo
using the Play Video action.



About AVI and SCM Files
If your demo contains a video sequence, you will need to click the AVI Support Files and./or Lotus ScreenCam Player check boxes
to tell DemoShield to include the files necessary to play your videos. When you click AVI Support Files, DemoShield automatically

copies the necessary video support files. When you click Lotus ScreenCam Player, a browse box appears for you to select the
SCPLAYER.EXE file to be copied to your distribution disk(s).

Note: If creating a demo for Windows 95 and Windows NT systems, you do not need to include AVI support files. These are
included with Windows 95 and Windows NT.



About Application Objects

Create an Application Object for a live application demo. In a live application tutorial or demo, the software application being

demonstrated runs live, along with the demo, so the viewer can interact with it. You can only create an Application Object in an
Application Scene.



About Application Scenes
In the Scene Properties dialog box, you will find a check box labeled Application Scene. Check this box if you are creating a demo to
advertise or explain a software application, and you plan to run the application with this scene.

You can create only one Application Object in each scene. DemoShield always places the Application Object at the bottom of the
stack order.

Note to Windows 95 users: When creating a windowed mode demo, you do not need to check Application Scene in order to create
an Application Object.



About Auto Save
With Auto Save you can tell DemoShield to create a backup copy of your current demo automatically at regular intervals. Use the
Demo Auto Save field in the File Preferences dialog box to set the number of minutes between automatic saves.



About Auto Size

Choose Auto Size to adjust the width of the RTF text you display. After you choose Auto Size, select the Text Object in the Designer
Window. Then drag on the handles to stretch and shape the Text Object the same way you resize any object. The text formats itself
to the size of the object.



About Bring to Front and Send to Back

When two or more objects are located in the same place onscreen, the object in front can block from view the object(s) behind it.
But often in creating a demo you want more than one object in the same place.

Use Bring to Front and Send to Back to move an object from its current position closer or farther back in the stack. Moving an object
closer to the front is called bringing, and moving an object farther back is called sending.



About Building True and False Actions
After you have entered the data you want to compare in the Comparison dialog box (see To Create a Comparison,) your next step is
to choose one or more actions you want the demo to perform if the comparison is true and/or if the comparison is false.



About Capturing Your Application Screens
Choose Capture Images from the Demo Menu to enter DemoShield's “"capture mode." The Designer is minimized, and you are free
to open and prepare the application you wish to capture. When you are ready, press the shortcut key that corresponds to the type of

capture you wish to make. (These shortcut keys are set in the Preferences dialog box, Capture tab.) When the image is captured,
you will hear a beep. Press Alt+Tab to return to the Designer.



About Choosing Files to Distribute
When this dialog box appears, you will find these two files in the list of files to distribute
] DEMO.EXE

L] DS. DLL
These are the DemoShield files you need to play any demo.

If you include AVI files, you will also see these files:

L AVIFILE.DLL
L MCIAVI.DRV
L MSVIDEO.DLL

If you include SCM files, you will also see this file:
* SCPLAYER.EXE



About Comparisons

When you make a comparison you examine the properties of two objects to see if they are similar or different. You can use a
comparison to make actions happen in your demo. When you compare two things in DemosShield, you say, for example:

If A equals B then perform this action, or
If Ais equal to or greater than B then perform this action, or
If Ais not equal to B then perform this action, and so on.

When you say If A equals B and in fact it turns out that A does equal B, then we say the comparison is true. If A does not equal
B, then the comparison is false.

You start by entering the data you want to compare and the type of comparison you want to make.
For a description of the object properties you can compare, click on Object Properties List..

For a description of the global variables you can compare, click on Global Variables List.

Then you build True Actions and/or False Actions.

A True Action is an action you want your demo to perform if the comparison is true. A False Action is an action your demo will
perform if the comparison is false. If you enter a True Action without entering a False Action, and the comparison is false, your demo
will not perform the True action and nothing else will happen.

Example



About Conditions and Comparisons
You can set up conditions you want to compare, and build actions that will happen:

] If the comparison is true, and/or

] If the comparison is false.

You already know what a condition is: If today is Wednesday, then display this text, or If the viewer clicks Button A, then switch to
Scene 52. The variety of conditions you can create is virtually limitless, and so is the power this gives you to make things happen in
your demos.

Topics

b About Comparisons

b Operators
2 What Can You Compare?




About Creating Action for an Event Object
There are three ways you can create actions for an Event Object:

] You can build actions for an Event Object that will happen when the scene starts. You can make these actions
happen by default when the scene starts. You build these actions using the True Actions dialog box, the same way you would if you
were building actions for an interactive object.

* You can set a time when your demo will perform action. In other words, decide how many seconds after the scene
begins you want the actions to happen. You enter the time, and then build the actions using the True Actions dialog box, the same
way you would if you were building actions for an interactive object (please see Creating Actions and Events.) When the demo's
been playing the number of seconds you set, the actions happen.

* You can create a condition. That is, you can compare the properties or values of objects, variables, and/or constants
using the Comparison dialog box. Once you've entered the data you want to compare, you can build actions you want the demo to
perform if the comparison is true and/or false. To build these actions, use the True Actions and False Actions dialog boxes.



About Creating Distribution Disks

When you are done creating your demo, you will need to copy it to a disk you can distribute to your viewers. Creating the installation
is easy. DemoShield’s Setup Wizard walks you right through it.

The directory where your viewer plays your demo must contain these files:

] DEMO.EXE
] DS.DLL
] The .DBD file(s) containing your demos.

The Wizard automatically places these files on your distribution disk. The DemoShield setup program automatically copies these

files to your system when you install DemoShield. Naturally, if you are using additional files in special situations, you will also need
to include those.

The installation you build with the Setup Wizard creates a new program group in Program Manager (Windows 3.1) or a new
program folder (Window 95), with an icon your viewer can use to run your demo.



About Creating Effects
While an object is moving into a scene or out of a scene, or standing still during its Hold Period, you can change its appearance by
creating an effect.

Effects are not as easy to visualize as motions, or as easy to describe. But anyone who's seen enough movies knows what a
dissolve or a fadeout is. Dissolves and fadeouts are effects. With a Grow/Shrink effect, an object can start out invisible and grow to
full size, or start full size, shrink and disappear.



About Creating Menu Titles
You can enter a title that will appear at the top of the PopUp Menu, and, if you want one, a caption that will go at the bottom.



About Creating Motion
If an object moves into view from right to left or from top to bottom, for example, that's a motion. If the object starts out invisible and
slowly fades in until it is fully visible, or disappears the same way, that's an effect.

The words motion and action seem similar but they have two entirely different meanings in DemoShield. The motion we are talking
about here occurs when an object moves in or out of a scene--and at no other time. You create motions using the Life Properties
dialog box. An action is something you can make happen in your demo. You build actions using the Actions, True Actions, and/or
False Actions Properties dialog boxes. Examples of actions are Go to Scene, Hide, and Display Menu.



About Playing Video
The video you play in your demo has been saved in, or converted to, a computer file format that is compatible with DemoShield.

DemosShield can play a video saved in these file formats:

. Microsoft's Audio Video Interleaved (AVI) file format.
AVI files have the filename extension AVI. You can play any AVI file in DemoShield.

. Lotus Corporation’s Screen Cam Movie (SCM) file format.
SCM files have the filename extension SCM. You can play any SCM file in DemoShield.

We call demos that utilize video and/or sound multimedia demos.



About Creating a Menu Button Caption

You can create a menu with up to five buttons. A check next to a button tells you the button will appear on the PopUp Menu that the
viewer sees in your demo screen. Every button is listed in the Properties dialog box, Object Styles tab underneath the heading
Menu Buttons, whether or not you are using the button.

] To remove a button from the menu, double-click the button in the list underneath Menu Buttons. The check next to the
button disappears.

] To use a button on your menu that currently has no check next to it, double-click the button. The check appears, and you
can assign the button a caption and function using the steps explained next.

VCR Buttons are ready to use the minute you create and place them on your demo screen. Even though you're free to customize
each VCR Button, it comes with a default caption and function. Menu Buttons are different. It may look at first glance like they too
have captions, but they don't. The captions that you see in brackets are only there as examples, and they have no function. Every
Menu Button is user-defined. That is, you give it a caption and decide what it does.



About Creating a PopUp Menu

Adding a PopUp Menu to your demo can change it in one quick step from a simple slide show to a custom software presentation.
We call the Menu a PopUp for obvious reasons. It stays onscreen for as long as the viewer needs it--then it's gone. How your viewer
brings your menu onscreen depends on how you design your demo. A viewer can display your menu either by clicking a button or
any other interactive object, or by pressing a shortcut key. For example, you could create VCR Buttons, and set one of them to
display the PopUp Menu.

Unlike other interactive objects, there are no Life settings to enter for a PopUp Menu Object.



About Creating an AVI Object
You can create an AVI Object that will play your AVI file automatically, independent of your viewer, in the same way that you can use
an Event Object to make action(s) happen without any viewer interaction.

When you use an AVI Object to play an AVI file, the last frame stays onscreen when the AVI file stops playing. It will stay onscreen
until its exit time, or until you play the next AVI file. You can place as many AVI Objects as you want in a scene.

You will find having that last AVI frame onscreen is quite valuable. In a sales demo, for example, you can use graphics and text to
point out and describe different places on the screen.

Maximum Allowed Time

This message appears underneath Exit Time on the Object Styles Properties dialog box for an AVI Object:

Maximum allowed time of __ seconds.

The number that appears in this message is the Scene Length. The only purpose of this message is to let you know how long, after
the AVI file stops playing, the last AVI frame can remain onscreen.

Note You cannot play an SCM file through an AVI Object.



About Creating an Application Object
Before you can make a running application part of your demo, you need to create an Application Object.



About Creating the Group Object
Like every other object, a Group Object can have two names:

] its regular name--the name you enter in the Name edit field

] its Group Name--the name you enter in the Group Name edit field

You must give every object that belongs to this group the identical Group Name.

You do not need to follow any special sequence when you create a group of objects. That is, you can create the Group Object first,
and then the objects. You can create the objects as ordinary objects, without any Group Name, and then go back to an object's
Properties dialog box and enter a Group Name. Any configuration of these steps will work.



About Delay Demo

Use the Delay Demo action to send the demo into a dead loop for the number of seconds you specify. While the demo is in delay

mode, no actions can be processed. If you wish to pause the demo until the viewer provides an event to continue it, use the
Pause/Continue action instead.



The Demo Controller
From time to time as you develop your demo, you will want to see it in action. Use the Demo Controller to test-run your demo in the

Designer Window.
The Demo Controller has a digital clock and VCR-style buttons you can use to:

] Play the current demo in the Designer Window or full screen,
* Reset the scene clock, and

] Switch from the current scene to the next or previous scene.
3 The Clock

» Play

3 Test Mode

g Stop Playing

4 Edit Mode

Note There are certain restrictions when you test-run a demo, even in Full Screen Mode. For example, you cannot play a
video or a macro, or launch an executable. There is no substitute for running your demo with the DemoShield Player to see
it exactly the way your viewers will.



About Demo Properties

Just as objects and scenes have properties, a demo itself has properties you can set or change at any time.

Demo Properties are a number of varied settings that affect both how the demo looks and acts in the Designer, and how your viewer
will interact with the completed demo in the Player.



About Disappearing Objects

There's some trial and error involved in learning how to align. If you inadvertently click the wrong aligning button, it may look like
your objects have disappeared. They haven't: they're just on top of one another. Select an object and drag it away to reveal the
missing object(s).



About Displaying a Rich Text Format File
DemoShield can display text that you have created on a word processor and saved in Rich Text Format. Virtually all major word
processors make it possible to save a document in .RTF format.

You cannot reformat RTF once it is imported into DemoShield. For this reason, you should be sure to choose the font, font size, and
font color on the word processor. Whenever possible, use TrueType fonts, so DemoShield can rescale your text when your demo
plays on larger or smaller screens. Set the background color for the document, and any other formatting available to you, on the
word processor.

You cannot import a single RTF file larger than 10KB (10,240 bytes). You are free, however, to import and use in your demo as
many RTF files as you want.



About Edit Field Object Properties

Use an Edit Field Object to give your viewer a way to type and enter alphanumeric characters. After your viewer has entered the
data, it will be stored in the Edit Field for the length of the scene.

Event Objects can be used to compare the contents of an Edit Field Object against some constant value. After you create the
comparison, you create True Actions to occur when the viewer enters the same value as the constant. You may also create False
Actions to occur when the viewer enters some other value.



About Enable and Disable
Use Enable to make a disabled button active. Use Disable to make an enabled button inactive. Unless an interactive object is
enabled, nothing will happen when the viewer clicks the object or presses a key.

The Enable action works the opposite of the Disable action. You can enable or disable an object when you create it, then during the
demo switch its status to Enable or Disable as appropriate. To disable an object when you create it, uncheck the Enable check box
in the object's General Properties dialog box.



About Entering Your Application Files
Use the Object Data Properties dialog box to enter the path and filenames of your application files, and any other data DemoShield
will need to play your macro. The Object Data Properties dialog box has three fields:

(3 Executable. Type the path/name of the executable file, or click the Browse button to browse for the .exe file.
3 Command Line Parameters. Type the names of any file(s), switch(es), and/or option(s) that also go on the command
line.

[ 2 Additional Required Files. Type the names of any additional file(s) you plan to use with this macro.



About Events and Actions

You can make your demo perform actions interactively or independently.

Interactive actions occur when your viewer clicks on an interactive object or presses a shortcut key. You can create a button or a hot
spot, for example, that the viewer can click to make your demo:

Switch to a different scene

Pause or continue

Display a message

Change the value of a variable
Show or hide an object in any scene

Any of more than 20 additional actions, in any combination
Independent actions happen by themselves, without any interaction from your viewer. You can build actions that happen
independently in your demo by creating an Event Object.

e e i i



About Fill Color
If the fill style you choose for is either a pattern or a wash, you need to choose a second color in addition to the background color.
We call this second color the Fill Color.



About Fixed Size
Choose Fixed Size to display the RTF file in your demo using the same page width that you used to create the file on your word
processor. The height of the text adjusts automatically.



About Font and Font Color
Use the Font dialog box to choose the type, size, and style of the font for your button caption.

Wherever possible, choose a font you know your viewers will have on their systems. You can reasonably expect your viewer's
system to have the fonts that ship with Windows 3.1: Arial, Courier New, Symbol, Times New Roman, Wingdings, MS Serif, and MS
Sans Serif.

When a viewer runs your demo, DemosShield looks first for the font you chose. If that font is not on the viewer's system, DemoShield
tries next to create a TrueType Arial font. If the viewer does not have TrueType Arial, or any TrueType font, DemoShield uses the
Windows system font.

If you need to use a specialized font and cannot be sure the font is available on your viewer's system, create your text in a separate
application and save it as a metafile or a bitmap.



About Go to Sub-Scene and Return From Scene
Use Go to Sub-Scene and Return From Scene to:

» Stop in the middle of your demo

3 Switch to a sub-sequence of scenes that you have created
b Play the sequence of sub-scenes

(3 Return to where you started in your demo

[ 2 Pick up where you left off, and play the rest of your demo

Example



About Hide & Show

Use the Hide and Show actions to change an object's initial visible property setting. Use the Hide action to make a visible object
invisible. Use the Show action to make an invisible object visible.

To set the visible property for an object in its initial state, open the General Properties dialog box. In the group marked Initial State,
select or deselect the check box marked Visible.



About Highlight/De-Highlight
Use Highlight/De-Highlight to create a toggle that alternately adds a highlight to, and removes a highlight from, an object. You can
only use the Highlight and De-Highlight actions with a hot spot or Bitmap Button.

Suppose for example you create a Bitmap Button, you choose the event Left-Clicks Mouse and the action Highlight/De-Highlight. If
the viewer left-clicks when the button is not highlighted, a highlighted border appears around it. If the viewer again left-clicks the
same button, the highlighting disappears.



About How Viewers Displays Your Menu
Your next step after creating a PopUp Menu is to give your viewer a way to display the menu while your demo is playing. To pop up
your menu, the viewer will need to click a button (or type shortcut keys) to trigger an action set for a particular interactive object..



About How a Viewer Plays Your Demo

Anyone can watch your demo on their Windows PC. Your viewers do not need to have the DemoShield program on their hard disk.
They do not need to know how to use DemoShield. All they need to do is run the setup program you created with the Setup Wizard,
and double-click your demo icon.



About How to Align
Suppose you've created the buttons and you want to line them up horizontally in a perfectly straight line. You could drag or nudge
them. But that's not precise enough. Instead, you can lasso them and then align them using the Aligning Tools.



About Importing a Video File
Before you can play an AVI or SCM file in your demo, you have to import the file.



About InstallShield

If the setup screen you create with DemoShield looks familiar, it's because this is the same setup you have probably used in the
past to install major applications. This is the InstallShield setup screen. InstallShield, also from InstallShield Corporation is an

application you can use to create an installation that will set up any Windows software. For information about InstallShield, call 800-
374-4353.



About Jump Mark Actions
Use Go to Next Jump Mark and Go to Previous Jump Mark to reset the demo clock from the current time to the Start Time of an
object that you have selected. You cannot use Jump Marks to switch to a different scene. Everything happens in the same scene.

To place a Jump Mark on an object, open the object's General Properties dialog box and check the Jump Mark check box. Once you

have Jump Marked an object in a scene, you can use the Go to Next Jump Mark or Go to Previous Jump Mark actions to jump to
the marked object while a scene is playing.



About Launching the Player from within the Designer

Open the Preferences dialog box, Demos tab, to select up to 10 demos you can launch from the Help Menu within the Designer.
When you have selected your demos, you can click on the words Play [*.dbd] from the Help Menu. The DemoShield Player will
launch immediately, opening the demo you selected. When the demo finishes playing, you will return to edit mode in the Designer
Window.



About Line Object Styles
Line properties are like those of other Graphic Objects, but there are additional options unique to lines.



About Loading a New Template

When you create a new demo, DemoShield automatically loads the previously used template. If it cannot locate the previous
template, DemoShield loads the default template.

You can create any number of templates, and load a different template file whenever you want. Only one template at a time is active
in the Designer Window.
The name of the current template file appears at the bottom of the Object Palette. When you load a new template, the template does

not change the properties of demos, scenes, and objects you have already created. The new template affects only those demos,
scenes, and objects you create after you load the template.



About Macros
A macro records and plays back your mouse moves and keystrokes. Although you will probably use macros to build demos that
teach or advertise other software applications, you could use a macro to record anything you do while you are using your PC.

When you demo an application using a macro, you save the macro in a separate macro file. Then you insert a separate Play Macro
action in your demo to play the macro file.

When you run your demo, the macro plays back and your viewer sees onscreen all the clicks, keystrokes, and whatever other
functions you performed while you were recording. You may want to record several macros to use in one demo, depending on the
type of demo it is and what you need to show your viewer.

If you create your macros using mouse moves instead of keystrokes, you will need to create every macro in each of the three main
screen resolutions. A macro recorded using only keystrokes will play correctly on any resolution screen.

Note: You cannot play Windows 3.1 macros in a Windows 95 demo. You need to create macros in the same operating system they
will be played under.



About Managing RTF Resources

RTF files that you import with Manage Demo Resources are not yet part of any Text Object. But if you plan to display an RTF file in
a Text Object while your demo is running--whether interactively when the viewer clicks a button, or automatically, independent of the
viewer--you must first make the file a resource in your demo. You do this by importing the file using the Manage Demo Resources
dialog box.

You cannot create borders, border colors, or fill colors for an RTF file the way you can for other Text Objects. You must completely

format an RTF file on your word processor before you import it to DemoShield. You cannot add any properties to an RTF file once
you bring it into DemoShield.



About Moving an Object Out of a Scene
An object enters a scene during its Start Period and exits during its End Period. Choosing how an object will move out of a scene is
practically the same as choosing an entering motion.



About Naming a Scene
DemoShield automatically gives each scene you create a default name which appears in the Scene Name edit field. You can
change the default name.



Name
Type a name for the object. Every object in a scene must have a unique name. Two objects can have the same name if they are in

different scenes. Names are not case-sensitive: for example, you cannot name two different objects Graphic 1 and graphic 1.
An object can have a name up to 32 characters long. Type any characters you want--letters, numbers, or other characters.



About Next and Previous Scene Buttons
Use these two green buttons on the Demo Controller to jump from the current scene in the Designer Window to the next scene or
previous scene. When you click, the current scene changes and the clock resets to 0000.



About Null Scene Color
If your viewer’s monitor is larger or smaller than your demo window, DemoShield fills the unused area of the screen with the Null
Color.



About Object Styles

Many of the objects you can create in DemoShield share properties in common with other types of objects. To illustrate, we will
compare a VCR Button Object with a Text Object. They both contain text. That is, the caption on a VCR Button is text, and a Text
Object is text. So it is possible to say that a Text Object and a VCR Button Object both contain text. They also share other properties
in common. For example, you can choose a font color for the text in both a VCR Button Object and a Text Object, and you use the
same Font Color dialog box to choose the font color for both.

At the same time, however, each type of DemoShield object has its own unique properties that make it different from every other
type of object. A push button object is different from a graphic object. A Graphic Object is different from a VCR Button Object, and so
on. Object Styles are those characteristics of an object that make it different from other types of objects.

For example, a Text Object is not interactive but VCR Buttons are interactive. You can choose a background color and a fill color for
a Text Object. But there is no background color or fill color to choose for VCR Buttons.

Use the Properties dialog box, Object Styles tab to choose or set the properties that are unique to each object. All Font Color,

Background Color, and Fill Color dialog boxes are the same. But the Properties dialog box, Object Styles tab is different for each
type of object.



About the Aligning Tools
Use the Aligning Tools to line up two or more objects automatically on your demo screen.



About Pause/Continue Demo
Use the Pause/Continue demo action to pause the demo until your viewer provides the event to make the demo continue. You may

build a Pause/Continue action for either an Event Object or an interactive object (such as a button).

Typically, you would use an Event Object to pause a demo at a particular scene time. Then you would create a button your user can
press to trigger the Continue action. (You could instead use the same button to pause and continue the demo.)

Pause/Continue is a toggling action. When you click a Pause/Continue button while the demo is running, the clock stops but the
demo continues playing. Your demo can still process actions (such as Show and Hide objects) that do not depend on scene time for
their performance. When you click a Pause/Continue button when the demo is pausing, the clock restarts and the demo continues
as usual.

About the VCR Pause/Continue button

When you use a Button Object or Bitmap Button to build a Pause/Continue action, you can only set one caption for the button. The

VCR Pause/Continue button is an exception. Its default caption is Pause/Continue and the caption changes with the demo. When
the demo pauses, the caption changes to Continue. When the demo plays, the caption changes to Pause.

Note: The Pause Demo action works only when you are using the Player to test-run your demo. If you click a Pause/Continue
button when you are running your demo in the Designer Window, the demo does not pause. Instead, DemoShield returns
you to edit mode.



About Picking Up Styles

Pick Up and Apply Styles is a one-to-one procedure. That is, you cannot select and then pick up styles from more than one object,
or apply styles to more than one object, in the same operation. Both the source and destination objects must exist before you start
the procedure, and they must both be the same type of object. That is, you cannot pick up styles from a graphic object and apply
them to a hot spot or button object.

When you complete a Pickup-Apply Styles procedure, both objects look identical. For example, if you pick up styles from a circle
and apply them to a rectangle, the rectangle will change to a circle.



About Playing Back a Macro
To use a macro in your demo, you need to save it and give it a name. But instead of saving every macro you record, try playing it
before you name it, to see if it does what you want it to do. If not, you'll want to record it again.



About Playing a Macro in Your Demo
There are two ways you can play a macro in your demo:

3 Your viewer can control when the macro plays by pressing a button, or
[ You can play the macro when you want it to play, regardless of what your viewer does.



About Playing Sound

You can play in your demo any sound you have saved using Microsoft's standard WAVE file format for storing waveform audio data.
To play sound, use the Play Sound action. When you link the Play Sound action to an event and your viewer clicks the button, or
other interactive object, the sound plays. The steps for playing sound are nearly the same as those for the Play Video action. WAVE
files have the filename extension .WAV.

Unlike AVI files, you can play and listen to a WAV file when you test-run a demo in the Designer. You can also preview a WAV file's
sound using the Manage Demo Resources dialog box.



About Playing Your Macros Automatically
When a viewer clicks a button, a macro starts playing. For example:

3 The viewer clicks a button.
» The demo switches to the Application Scene.
3 The macro starts playing automatically the moment the scene begins.

The viewer appears to control when the macro plays. But actually, the only thing the viewer controls is when the demo switches to
the Application Scene. Once the demo switches to the Application Scene, it's your Event Object that makes the macro play.



About Mouse Events
The following table shows a few examples of actions you could create for mouse (click) events.

Event What Could Happen (Action)

Left Mouse Click Headline pops on for three
seconds, then disappears.

Scene pauses for a second, then
continues.

New headline pops on.
Demo switches to the next scene.

Bitmap image fades in slowly, then
fades out.

Graphic objects sail across the
screen and out of view.

Right Mouse Click A graphic object drops down from
out of nowhere, then disappears.

A second graphic object appears.
It's identical to the first object
except for a different color, making
it look as if the first object has
changed color.



About Recording a Macro

When you press the Start/Stop Recording Macro key, everything you do from then on is recorded until you press the Start/Stop
Recording Macro Key again. If you're not sure which key you press to start and stop recording a macro, choose Preferences from
the File Menu. The Preferences dialog box opens. Click on the Configure tab to see your current Start/Stop Recording Macro Key.



About Resizing an Object Outside Its Lifespan
You can temporarily reset the Controller clock to make an object appear so you can resize it. All objects that you would want to
resize can be resized by using the mouse or the sizing keys, with the exception of the Bitmap Button Object.




About Saving a Macro

You must save a macro to use it in your demo. If you record a macro and don't save it, DemoShield will hold it in memory only until

you record a second macro. Then DemoShield erases the first macro. DemoShield will also delete an unsaved macro when you quit
a session.

DemosShield displays in brackets next to each macro the screen resolution that you used to record it.



About Scaling Macros

The size and location of the objects on your demo screen can change when a viewer runs your macro in a resolution different from
the resolution you used to create the macro. To make sure your macro scales proportionally on your viewer's screen, record each
macro three times, once for each resolution. Or, you could record your macro using only keystrokes, and no mouse movements.
This type of macro will play back correctly on any resolution screen.

Note: Macros created using Windows 3.1 cannot be played back on Windows 95 systems (and vice versa).



About Scene Length

Use the Scene Length field to enter the number of seconds you want the scene to play. The default scene length is determined by
the current template. If you decide to change the Scene Length but aren't sure what to change it to, guess. You can always reopen
the Scene Properties dialog box and adjust it as needed.



About Scene Properties
Use the General Scene Properties dialog box to create or change essential data for a scene including the scene's name and its
playing time in seconds. Other scene properties you can set are Fill Styles, Background Color, and Fill Color.



About Scene Transitions

Usually you'll want the scenes in your demo to play one after another in ascending numeric order from beginning to end. But you
can play the scenes of a demo in any sequence. At some point, for example, you may want a demo to break away from its numeric
sequence, switch to play a special sequence of scenes, and then return, picking up where it left off, to continue the numeric
sequence as before.

To switch to one of these special sequences, use the action called Go to Sub-Scene. To return from a special sequence, use the
action Return From Scene or the Return From Scene Transition.

The following are the scene transitions you can choose from.

Scene What Happens When the
Transition Scene Ends
Go to Next The next scene starts.
Scene

Go to Previous
Scene

Go to Scene

Replay Current
Scene

Pause on
Scene

Return from
Scene

The previous scene starts.

The demo switches to whatever
scene you choose. When you
choose this, a second combo box
opens showing you every scene in
the current demo. You choose from
this list which scene to go to.

The clock returns to zero and the
current scene plays over again
from the beginning. These actions
will repeat in an endless loop, until
your viewer clicks a button or
presses a keys that starts a new
action or switches to a different
scene.

The clock does not stop. It keeps
going, but the demo does not
switch to another scene or start
playing again from the beginning.
The scene simply stops at the end
and waits for viewer input--a mouse
click or key press--that starts a new
action or switches to a different
scene.

The demo returns to the last Sub-
Scene. This is an advanced Scene
Transition you need not concern
yourself with until you are
thoroughly familiar with
DemosShield.



About Send Object to Back

Instead of clicking the triangular red buttons on the Scene Editor to bring and send a selected object, you can choose these from the
Object Menu:

Move Object to Front

Move Object to Back

Move Object Up

Move Object Down
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About Send, Get, and Set Property
Use the Send, Get, and Set Property actions to send, get, or set one of these properties for an object:

Propert Use this action to Number to Enter
y
Visible Show a hidden object. 1 for visible; 0 for
invisible
Pressed Make a button, hot spot, or 1 for pressed; O for
other interactive object behave unpressed

as if the user has left-clicked
on the object.

Enabled Enable an object that is 1 for enabled; 0 for
currently disabled. disabled

Start Make the Start Time of one A number in

Time object the same as a property milliseconds (1,000
of a second object. milliseconds = 1

second)

Hold Make the Hold Time of one A number in

Time object the same as a property milliseconds
of a second object.

End Make the End Time of one A number in

Time object the same as a property milliseconds
of a second object.

End- Make the length of the End- A number in

Period Period of one object the same milliseconds

Duration as the length of the End-Period
of a second object.



About Set Contents

Use Set Contents to change the resource you are displaying in a Graphic Object, a Bitmap Button Object, or a Text Object. We call
the metafiles (WMF) and bitmap (BMP) images you display in a graphic object or bitmap button resources. A Rich Text Format (RTF)
file that you display in a text object is also a resource. With the Set Contents action you can change the resource you are currently

displaying in an object to a new resource. Before you create the action, you must import the resource into the demo via the Manage
Demo Resources dialog box.




About Setting Properties

Every object you place on your demo screen has properties: characteristics that help describe the object. Scenes and demos also
have properties.



About Setting a Time When a Macro Will Play

You can set a time when a macro will play automatically during a scene without any interaction from your viewer. Suppose, for

example, that you want to give a viewer three seconds to read a headline and then play a macro. Use an Event Object to trigger a
macro at a particular time.



About Timed Action
Atimed action is the simplest type of action you can create for an Event Object. To build a timed action, decide when you want the
action to happen. Then build the actions that you want to happen using the True Actions dialog box.



About demo shortcut keys
When creating a windowed demo to be played on Windows 95 and NT systems, you should not rely on shortcut keys. If another
application has the focus, DemoShield will not be able to recognize demo shortcut keys.



About Stacking Go To Sub-Scene Actions

After a set of sub-scenes, you can again choose the action Go To Sub-Scene and start a second set of sub-scenes. In fact, you can
stack as many Go To Sub-Scenes as you want without ever using a Return From Scene action.

You can return from a sub-scene sequence by using a Return From Scene scene transition, or a Return From Scene action.

If you do want to return from a sequence of sub-scenes by using a Return From Scene action, then you must use a Return From
Scene action to match each Go To Sub-Scene action.

If you have used two Go To Sub-Scene sequences, for example, one right after the other, and you want to end by using a Return
From Scene action, you must use two Return From Scene actions. That is, you need to create two Return From Scene actions.



About Start, Hold, and Exit Times
The settings you make in these fields tell DemoShield when the motions and/or effects you've chosen will happen and how much
time each will take. Before you enter the Start, Hold, End, and Exit settings, you'll need to ask these questions about the object;

(3 When will it start entering?  (Start Time)
3 How long will it take to enter? (Start Period)
» How long will it stay onscreen? (Hold Period)
(3 When will it begin making its exit? (Exit Time)
[ 4 How long will it take to exit?  (End Period)
Period What happens and When
Start The period beginning when the
Period object starts moving into the scene
and ending when it stops.
Hold The period during which the object
Period stays where you placed it when you
created it.
End The period beginning when the
Period object starts moving out of the

scene and ending when it
disappears.



About Step and Jump Time Buttons

Use these buttons to reset the Controller clock forward or back by either a small or large amount of time. When you change the time

by a small amount, we call it a step. When you change the time by a large amount, we call it a jump. To change the default times for
steps and jumps, choose Preferences from the File menu, and open the Options tab.



About System Requirements for Your Viewer
The viewer’s system must have enough power and available memory to launch and run your demo, and an application if necessary.
A typical 486 with 8 megabytes of RAM can easily handle any demo.

To view your Windows 95 demo, your viewer's computer must also run Windows 95 or NT (to be capable of running a 32-bit
application). To view your Windows 3.1 application, your viewer’s computer must run Windows 3.1 or higher. Your viewer's
computer must have enough memory--RAM and hard disk. How much memory is enough? That varies, based on the number of
bitmaps you use, their size, and the number of colors they contain.

In general, bitmaps use more memory than RTF text files. If you run an application in your demo, the application may have its own
memory requirements.

To watch your demo, the viewer should have:

an Intel 386 equivalent, or better

33 MHz clock speed or higher

4 MB of RAM to play demos

a VGA or better monitor

a video card, if you are playing a video file in your demo
a sound card, if you are playing a WAV file in your demo
a mouse
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About Templates
Atemplate is a file, separate from your demo file, that stores the initial properties for every scene and object in your demo.

The template file knows how the scene should look when you create it, and how every object in the scene should look when you
paste it in the Designer Window. The demo itself also has template properties.

So really a scene, an object, and a demo have two types of properties:

3 Their template properties--how they look and work when you first create them. You can think of these as default
properties.
[ The properties that you set as you create the demo, and that make one demo different from another.

You do not need to create an object or a scene in order to change object, scene, or demo template properties. You can change
template properties any time, and create as many templates as you want. See To save a template file.



About Test-Running a Popup Menu
When you're done creating menu button(s) and/or menu shortcut key(s), you'll want to test them to see whether they display your
PopUp Menu.



About Text Object Styles
Once you have opened the Properties dialog box, Object Styles tab for a Text Object, there are two ways you can display text.

You can:

b Type the text directly in the text edit field. The text edit field is the empty white rectangle with the words Right-Click Here.
Display text from a file you've already created on a word processor and saved in Rich Text Format. Documents saved in

Rich Text Format have the extension .RTF.

When you close the Properties dialog box, Object Styles tab and see your text for the first time in the Designer Window, it may not

look right. For example, what if you want the lines to break differently? You have a few options.

You could make the text smaller or bigger by choosing a different point size. Instead of displaying text that you've typed in the text
edit field, you could create and format the same text on a word processor, save it to an RTF file, and display the RTF file on your
demo screen

If you typed your text in the edit field, and it doesn't look right, you'll need to resize the Text Object.




About Trigger Event
Use Trigger Event to send an event to a button or other interactive object. These are the events you can trigger:

Time

Moves Mouse

Left-Clicks Mouse
Left-Double-Clicks Mouse
Right-Clicks Mouse
Right-Double-Clicks Mouse

For example, you can send a left-click from one button to another button. So when a viewer clicks the first button, the demo acts as
if the viewer clicked the second button.
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About Image Fill Styles

You can fill an object, a Bitmap Button, or a scene with any bitmap (.bmp) or Windows metafile (WMF). Metafiles always scale
better than bitmaps. When you fill a Graphic Object or a Bitmap Button with a bitmap, you will usually get the best results by
selecting the Resize Frame image option. This option allows the object to scale to the bitmap, instead of the other way around.

Also, you can choose to make transparent any part of a 16-color or true color bitmap. You simply choose a background color that
corresponds to a color used in the bitmap. Then select the Transparent check box. The color you selected will appear transparent
(i.e. the scene background will show through it).

About 256-color bitmaps

When displaying a 256-color bitmap in your demo, you will get much better results by importing the bitmap into a Graphic Object or
a Bitmap Button. If you display a 256-color bitmap as a scene background, your bitmap may appear with only a fraction of its usual
colors. This is because the scene background has the lowest order of priority in DemoShield's color palette creation.

For more details, see 256-color systems.



About Using the DemoShield Player when Test Running
There are certain restrictions when you test-run a demo in the Designer, even in Full Screen Mode. For example, you cannot play a
macro or a video file. There is no substitute for running your demo with the DemoShield Player to see it the way your viewers will.



About Variable Object Properties
Use a Variable Object to store either a numeric or alphanumeric value. To increase, decrease, or change the value of a variable

while a demo is running, use the Set Variable action. Then you can use an Event Object to compare the value of a variable against a
constant, and create actions for different outcomes.



What Can You Compare?
Here is what you can compare in a demo:

3 An object and one of its properties with a different object and one of its properties
For a description of the object properties you can compare, click on Object Properties List..

3 An object and one of its properties with the value of a variable

» An object and one of its properties with the value of a constant

(3 The value of a variable with the value of a different variable

b The value of a variable with the value of a constant

(3 The value of a global variable with the value of an object and its property

For a description of the global variables you can compare, click on Global Variables List.

3 The value of a global variable with the value of a constant

Compare With This

This

Always This does not compare anything with anything else. Choose
Always if you want the action to happen each time the demo
plays. After you choose this, open the True Actions dialog box
and build the actions you want.

Variable Constant

Variable Object/Property

Global Variable Constant

Global Variable Object/Property

Object/Property Object/Property



About the Objects List in the Scene Editor

The Objects List of the Scene Editor shows you every object in the current scene. A row of four buttons appears at the bottom of the
Scene Editor. With these buttons you can sort and display the objects in the Objects List four different ways. These are the sorting
buttons, from left to right:

Sort Orders

Alphabetically

By Start Time

By Object Type

Stack by Layer
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About the Pause/Continue Button
Clicking the Pause/Continue button while a demo is running pauses the demo. Clicking the same button again restarts the demo.
You can make any button a Pause/Continue button when you create it by choosing Pause/Continue in the Build Action dialog box.

But if you click a VCR Pause/Continue button, not only does the action stop or restart, but the caption on the button changes to
Continue or Pause, as appropriate.




About the Play Video Action
Use the Play Video action to play a video sequence that you've saved as an AVI or an SCM file. When you link the Play Video action
to an event and your viewer performs the event, the video file plays.

Playing a Video File in the Designer Window

AVI and SCM files will not play while you are test-running the demo in the Designer Window. When it's time for the video to play,
you'll see the message "A Play Video action occurred."

To see how the AVI or SCM will look to your viewer, run the demo using the DemoShield Player.



About the Program Item and Icon
The DemoShield Setup Wizard will create a separate Program Item (Windows 3.1) or Shortcut (Windows 95) for each demo file you
include on your distribution disk(s). In this step, you choose an icon and enter a name for each Program Item or Shortcut.

When you have typed a description and selected an icon for the current demo file, click the Next File button to repeat this procedure
for every demo file you are distributing.

The file name of the current demo appears underneath the words Program Item Name (or Shortcut). The message File 1 of 3 further
identifies the file, if you are including more than one demo on your distribution disk(s).



About the Scene Editor
Use the Scene Editor to manage the scenes in your demo and the objects in your scenes. The Scene Editor is a panel with buttons
that appears by default at the top right of your DemoShield screen, but you can drag it elsewhere.

A combo box near the top of the Scene Editor displays the name of the current scene. You can use this combo box to change the
current scene. A list box to the left of the Scene Editor shows you every object in the current scene.

By clicking different buttons at the bottom of the Scene Editor, you can change the order in which objects appear in this list--sorting
them, for example, alphabetically, or according to the time they first appear in the scene.

From the Scene Editor you can open the Properties dialog box or delete an object you have selected. When one object in the
Designer Window overlaps another object in a stack, you can use the red triangular Scene Editor buttons to bring a hidden object
closer to the front or send an object farther back.




About the Scene Sorter

Use the Scene Sorter to:

Change the sequence in which scenes appear in your demo
Create a new scene

Duplicate the current scene

Delete a scene
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About the Slider Bar
In addition to the Step buttons, you can also use the slider bar to reset the current time of the scene. With the slider bar you're not
limited to increasing or decreasing the clock time in big or small steps. You can quickly set the clock anywhere in a scene.



About the Text Options Dialog Box
When you've typed and sized a Text Object, click the Options button on the Properties dialog box, Object Styles tab. You'll see the
Text Options dialog box.

Use the Text Options dialog box to (1) align and create margins for text, or (2) import and display word-processed text you have
saved as an RTF file.

Alignment Buttons

Use these buttons to left-justify, right-justify, or center the text inside a Text Object.

Margin in Pixels

Use this to create a margin of blank space around each edge of your text.

Fill Styles

The actual size of a Text Object includes not just the letters you type but also the space inside the handles. You can make this space
transparent, so your viewer will see only the text with nothing in back of the letters but the scene background. Or you can fill the
space with color.



About windowed playback style

Select Windowed playback style from the Demo Properties, Demo Styles tab to make a demo that plays in a window. Your demo will
no longer play full screen on your viewer's monitor. Instead, it is now a windowed demo. You can select a caption for the window,
and select the background color that will appear behind your demo on your viewer's screen.



Accelerators

Whenever possible, DemoShield has implemented the standard Windows accelerators.
The following are the accelerators for Windows 3.1:

File menu

New - Ctrl+N Open - Ctrl+O

Save - Ctrl+S Exit - Alt+F

Exit menu

Undo - Ctrl+Z Redo - Ctrl+Q

Cut - Ctrl+X Copy - Ctrl+C

Paste - Ctrl+V Delete - Del

Select All - Ctrl+A Clear Selection - Esc
Duplicate - Ctrl+D

Demo menu

Manage Demo Resources - Ctrl+Enter

Object menu

Delete - Del Edit Properties - Enter
Align to Left - Ctrl+L Align to Right - Ctrl+R
Align to Top - Ctrl+T Align to Bottom - Ctrl+B
Control menu

Next Scene - Shift+N

Previous Scene -Shift+P

Window menu

Cascade - Shift+F5

Tile - Shift+F4

Repaint Scene - Alt+P

Help menu

Help - F1



Example: Using Sub-Scenes

Picture this: You are building a demo. It's got 10 main scenes. You want them to play straight through in ascending numeric order
from Scene 1 to Scene 10. You want every viewer to see these 10 scenes. But you have also created a special sub-sequence of five
scenes--Scenes 11 to 15. Not everyone will see the sub-scenes. You want the sub-scenes to play only for viewers who click some
button in Scene 5. If a viewer clicks that button, you want the demo to switch from Scene 5 to Scene 11. Then it will play Scenes 11
to 15, and switch back to Scene 5, and play the rest of the demo as usual, from Scene 5 to Scene 10.

Use the actions Go to Sub-Scene and Return From Scene to go to the first scene and return from the last scene, after playing a
special sub-sequence of scenes that are not part of your main demo.

To switch to the first scene of your sub-sequence, use the action Go to Sub-Scene. To return after the sequence ends and continue
playing your regular demo, use the action Return from Scene (or the Return From Scene transition).




Active Client Window

Captures the smallest active full window, but not a menu or transitory window. For example, if you were capturing a dialog box, you
would see the whole dialog except for the window caption.



Active Window

Captures the window with the focus. Will also show windows open within it.



Aligning Tools

A panel with a row of buttons you can use to line up two or more objects you have selected in the Designer Window. For example,
you can select objects, press the appropriate aligning button, and instantly center the objects in a vertical line. The Aligning Tools
appear by default at the right side of the DemoShield screen, but you can drag them elsewhere.




Allow User Interaction

Check this box to allow the viewer to interact with the running application.

If the Allow User Input check box is not checked, DemoShield effectively disables all keyboard input and mouse clicking by the user.
(DemoShield Send Keys, Play Macro and Send Message actions are not affected by this, however.)

Note The disabling of user input is global in nature. If you are running your application non-maximized, then the user will not be
able to interact with other Windows applications while user input is disabled. Also, when user input is disabled,
DemoShield’s Edit Field objects are also disabled.



Sort Alphabetically

The names of the objects in the scene appear in ascending alphabetical order.



Application Termination

Click on the combo box below Application Termination to select when you want DemoShield to close the running application.
You can terminate (close) the application:

2 when the demo ends
2 when the scene ends
2 never

If you select the Scene Terminate option, DemoShield will close the application when the scene resets. If you select the Demo
Terminate option, DemoShield will hide the application when the scene resets, and close it when the demo ends. With the Never
Terminate option, DemoShield will never hide the window, and the application will stay open after the demo is closed.



Asking us questions

Whenever possible, please send us your questions by CompusServe, the Internet, BBS, or fax. It's the best way to ensure that they
will reach the appropriate DemoShield person and you will get the detailed, accurate answers you need.



Automatic Last Demo Launch

Check this box if you want your last demo to open automatically when you launch DemoShield.



BBS

DemosShield maintains a technical support bulletin board system which is up 24 hours a day, seven days a week. Registered users
can access the bulletin board by dialing:

708-240-9137

To get technical help on the BBS, you must register with your name, address, and phone and fax number. This information must
match the information on your registration card.

The BBS does not replace CompuServe. DemosShield primarily maintains the BBS to upload/download large files, and to provide
technical support to registered users who are waiting for their CompuServe ID. For the fastest response to your technical support
guestions, please use CompusServe.
Click here to read about

How to Log into the BBS




Click the arrow to close this window

Object Palette

#Related steps Click the area of the object palette you want to know more about.
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Click the arrow to close this window

The Aligning Tools

#*Related steis Click the aligning tool you want to know more about.
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Click the arrow to close this window

Demo Controller

#*#Related steps
*More about Click the area of the Controller you want to know more about.
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Click the arrow to close this window

The Scene Sorter

#* Related steﬁs Click the Scene Sorter tool you want to know more about.



Click the arrow to close this window and return to the main menu

The DemosShield Screen
#Related steﬁs Click an area of the screen to see a topic about that area. Note: Each menu is a separate topic.
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Click the arrow to close this window and return to the main menu

The Toolbar

#* Related steﬁs Click the area of the toolbar you want to know more about.



Click the arrow to close this window and return to the main menu

The Status Bar
# Related steps

Type of Object
X and Y Coordinates
Object Width and Height
Object's Life from Start to Exit

Size and F'Dsitlinn the Ohject

Text %140 Y153 Width: 277 Height 48: Life: 3-60 secs.

Current button. object or function



Click the arrow to close this window and return to the main menu

Tools and Palettes

FRelated steps

Control Panel
The Object Palette

The Scene Editor

The Aligning Tools

The Demo
Controller

The Scene Sorter

The Timeline Editor

Description

The Object Palette contains 18 buttons you use to create
objects and place them on your demo screen. These objects
include graphic shapes, such as lines and rectangles; text;
interactive objects, such as buttons your viewer can click to
control how your demo plays; and other objects, such as
Variable Objects and Group Objects. You can also use the
Object Palette to edit each object’s template properties.

More about
Use the Scene Editor to manage the objects in your scenes.

You can use the Scene Editor to switch to any scene, and to
select any object and change its properties.

More about
Use the Aligning Tools to arrange objects automatically on the
demo screen. With the Aligning Tools, for example, you can

select a group of buttons, click a button, and line them up in a
perfectly straight line.

More about
Use the Demo Controller to test-run and edit your demo. The
Controller has a run-time clock with buttons you can use to

play and stop playing the current demo or reset the clock for
the current scene, and other controls.

More about

Use the Scene Sorter to manage the scenes in your demo.
You can add, delete, duplicate, and rearrange scenes.

More about

Use the Timeline Editor to quickly change the life properties of
several objects within a scene without the need to open each
individual property dialog box.

More about



Click this arrow to close this window and return to the main menu

Using the Mouse or the Keyboard

FRelated steps

Keys

Delete
Deletes all selected objects from the scene.
Enter

Opens the Properties dialog box for a
selected object. If you have selected more
than one object, the Properties dialog box
opens for the first object you selected.

Escape
Removes selection from all objects.
Tab and Shift+Tab

Selects the next or previous object in the
scene in the order you created them. Tab
selects the next object. Shift+Tab selects the
previous object.

Resizing Keys

You can use keystrokes to resize an object
more precisely than you can with a mouse.
You will stretch or shrink the selected object
by one grid unit (one pixel by default).

Stretching

Press Ctrl+ the left or right arrow key to
stretch one side of an object horizontally.
Press Ctrl+the up or down arrow key to
stretch one side of an object vertically.
Shrinking

Press Shift+any arrow key to shrink one side
of an object in the selected direction.
Resizing All Sides

Press the plus (+) key on your keypad to
increase all sides by one grid unit.

Press the minus (-) key on your keypad to
decrease all sides by one grid unit.

Mouse

Left Mouse Click

Selects the object underneath the mouse
and deselects any object(s) that you may
have previously selected. If there is no
object underneath the mouse, a left mouse
button click deselects all selected object(s).

Right Mouse Click

Displays the shortcut menu for the closest
object beneath the cursor. Select and left-
click on Object Properties to open the
Object Properties dialog box. If no object is
underneath the cursor, DemoShield
displays a similar shortcut menu for the
Scene.

Shift+Click

Selects the object beneath it even if it is
out of its lifespan. If you left-click on an
object, handles will appear around it to
show it is selected. If you right-click on an
object, will see the shortcut menu with
Object Properties selected. Either way,
press Enter to open the Properties dialog
box.



Click the arrow to close this window
Scene Editor

I Related steps  Click the area of the Scene Editor you want to know more about.
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Click the arrow to close this window

The Timeline Editor

PRelated steﬁs Click the part of the Timeline Editor you want to know more about.
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Sort By Object Type

Objects appear in the list separated by type. For example, Graphic Objects are separate from Text Objects. The objects in each
group are sorted in the order you created them.



Sort By Start Time

The object that appears first in the scene is at the top of the list and the other objects follow in sequence according to their Start
Time. To set the Start Time, use the Life Properties dialog box (See Life).



Capture Images

Lets you capture application screens as bitmap images.

Steps

2 To set your capture keys

» To capture your application screens
b To preview screen captures

4 To use screen captures in your demo



Capture Pointer Image

Select this option if you want to show the mouse pointer in your screen capture. Deselect it to hide the pointer.



Capture
Use the Capture tab to select the keys that will trigger various types of screen captures using DemoShield’s screen capture
capabilities. You can select any function key from F2--F12.

Capture Keys
Active Window

2 Active Client Window
» Full Screen Capture
3 Window Under Pointer

Capture Options
Stop Capture
2 Capture Pointer Image
Steps
» To capture your application screens as images




Check Resources

Check this box if you want DemoShield to check for unused resources each time you save your demo. If an unused resource
(image, RTF, video, or sound) is found, you will be prompted to save or delete the resource. DemoShield cannot check to see if
macro or file resources are being used.



About

Choose About from the Help menu to see:

» The version of DemoShield you are using and copyright information.
2 Your current template file.
b Your native screen resolution.

Note: Click the Demo Info button to see your current template file and screen resolution.



CompuServe

The best way to get technical support is through CompuServe. It's available to you 24 hours a day, seven days a week. We check
the DemoShield CompuServe forum and mail twice a day, six days a week.
You may also use CompuServe to send e-mail and participate in DemoShield Forum discussions. The Forum is the place to look for
maintenance releases, minor updates, updates to the Knowledge Base, sample demos, and other useful information.
Click here to read about
Starting a CompuServe Account
3 CompusServe E-Mail Messages
[ The DemosShield Forum




CompuServe e-mail message

You can log into CompuServe and send a mail message to the DemoShield ID:
74774,552



Configure
Use this tab to select your default new demo resolution and to choose the key or keys that will trigger macro recording.

Options
4 Default New Demo Resolution
» Macro Start/Stop Recording Key




Contacting Us

Click on the CompusServe, BBS, or Internet listings below for information on contacting us via modem and accessing online
information.

Technical support is available, in order of priority, by:

b R R
T
QD
X<

International




Edit Mode
When you click the Stop Playing button, the demo stops running and DemoShield switches to Edit Mode.

In Edit Mode:
You can work with objects in the Designer Window: that is, move them and edit their properties.
Time stops and the Controller clock is inactive.

All the Controller buttons appear activated.
Any tool panels and palettes that were onscreen before you clicked Play reappear.

TFYww



Play
L Click the Play button to play the current scene, starting at the current time.
Note: What you see in the Designer Window is a snapshot of the scene at a given point in time. Only those objects that exist at

that time will be shown. To edit an object outside of its lifespan, double-click on the object's name in the Objects List of the
Scene Editor.



Stop Playing
L Click the Stop Playing button to stop the scene. When you stop a scene the clock stops, and you return to Edit Mode.



Test Mode
When you click the Play button DemoShield switches to Test Mode, and:
3 The current demo starts playing just as it would if your viewer were watching the demo.

[ You can test-run a demo in the Designer Window or in Full Screen Mode.

If you are test-running the demo in the Designer Window, all palettes disappear from the DemoShield screen, leaving only
the Demo Controller.
[ 2 Time begins moving and the Controller clock starts.



The Clock
The clock shows the current time of the current scene in tenths of a second. Each time a new scene starts the clock automatically
returns to zero (0).



Copy Properties and Apply Properties

Use the Pick Up Properties button together with the Apply Properties button to make the properties of one object the same as the
properties of another object. Copy and Apply Properties works only if you copy properties from, and apply them to, the same type of
object.

Clicking the Copy Properties and Apply Properties buttons is the same as choosing Pick Up and Apply Styles from the Edit Menu.




Default New Demo Resolution

Select one of the three major screen resolutions: VGA, SVGA, or XVGA.

This will be the default native resolution for your new demos. Create your demo in the lowest screen resolution that your viewers will

run the demo in. Choose VGA (640 x480) to allow your demo to be played on any resolution monitor.

Note: If you choose to make your demo a windowed demo, the size of the window you select will determine the screen resolution,
overriding your default setting.

Choosing a Native Resolution
b Which Resolution Should | Choose?
3 How Do | Check My Current Demo Resolution?




Delete

Deletes all selected objects from the scene.



Demo Auto Save

Check this box in the Enable Preferences dialog if you want your demo to be saved automatically. Type in the number of minutes
you want between saves (1-100).

] If you are running Windows 3.1: Your last auto save file will be saved as an .AUT file. It will be placed in the same
directory as your DESIGNER.EXE file. The last regular save of your demo will be in the same directory, with a BAK file extension.

* If you are running Windows 95: Your Auto Save files will be named "Auto Save of .dbd" and your regular
backup files will be named "Backup of .dbd".



Demo Controller

A panel with buttons and a digital clock for test-running your demo in the Designer Window. Using buttons or a slider bar, you can
reset the current scene time. The panel appears by default at the right side of the DemoShield window, but you can drag it anywhere
on the screen. Often called simply the Controller.



Size (of Windowed Demo)

Use the Size dialog box to set the size and location of the demo window that will appear on your viewer's screen. You can also
choose to have the window automatically centered on your viewer's screen.

Use this dialog box to make your demo window a fixed size window.

Steps

3 To set the size and location of your demo window



Demo Styles

Use the Demo Styles dialog box to set a number of properties that affect how the demo will look and behave on your viewer’s
screen.

Options

2 Initial Scene

2 Allow Palettized Colors

2 Keep Demo Always on Top
2 Demo Password

2 Windowed Playback Style




Keep Demo Always on Top

By default, DemoShield operates as an "always on top" window. When your demo plays full screen, your viewers cannot switch to
another application. When your demo plays in a window, viewers can switch to another application but the demo always remains on
top.

To allow your viewers to send the demo window to the back, uncheck the box marked Keep Demo Always on Top. This allows your
viewers to fully interact with other applications when running either a full screen or a windowed demo.



Allow Palettized Colors

Check Allow Palettized Colors if you want DemoShield to realize its own color palette when it plays on 256-color systems. There are
two reasons to disable palettized colors:

] You want the demo to run as fast as possible.

] You have selected Windowed Playback Style, and want to avoid the possibility of conflict between DemoShield’s palette
realization and the palettes used by other Windows applications running simultaneously.
Note: This setting only affects your demo if you are using 256-color bitmaps.



Initial Scene

Click on the combo box to the right of Initial Scene to select the first scene your viewer will see when playing your demo. Your
selection will not affect the order of scenes that you view in the DemoShield Designer.



Windowed Playback Style

Select Windowed Playback Style if you want your viewer to see your demo in a window instead of full screen. You choose the size
and the position of the window. By creating a fixed size windowed demo, you can nearly eliminate the possibility of scaling problems
when your demos are played under different screen resolutions.

Steps

» To choose windowed playback style



Demo Password

Check this box to set a password to stop unauthorized individuals from opening your demo file in the Designer. This will not stop
anyone from playing your demo in the Player. Type in any characters (up to 6) for your password. A space is a legitimate character.



Demo Wizard

The Demo Wizard launches when you select Create New Demo from the Welcome dialog. The Demo Wizard is a program that
assists you in starting a new demo by asking a few questions about what you want your demo to look like. The Wizard then creates
a new demo file based on your responses. Don’t worry too much about the selections you make. They are just initial settings. You
can always change them later.

Steps

3 To Create a New Demo



Stirling Reports

So that we can better assist you, we ask that you fill out and send us the technical support form we have provided through the
Stirling Reports file. You will find this file on your DemoShield program disks (or CD).

When you create a tech support request using Stirling Reports, you are given the option to run a program called MSD.EXE. We
suggest that you run this diagnostic tool, and save the results. Send them with your technical support request. The information may
help us solve your problem.



DemoShield Server

The Server is an alternate mode of operation for the DemoShield Player. A programmer can use the Server to control DemoShield
from another application. Your users can then launch your demos from a menu within your application, or any other mechanism your
programmer chooses. For example, a programmer could set up your application’s tutorial so that it would play and then close a

series of demos.
Steps

2 To launch DemosShield demos from other applications



Demos tab

Use the Demos dialog box to choose up to 10 demos you can play in the DemoShield Player by simply selecting the demo’s name
from the Help Menu in the Designer. If you do not select demos in the Demos Preferences dialog box, you will have to exit the

Designer to launch the Player.

Steps
2 To launch the Player from the Help Menu




Describing a problem

If we cannot duplicate a problem, we cannot fix it. As precisely as you can, give us the exact details about the problem or error you
are experiencing. Specifically, we may ask you to tell us:

Any error messages that appear in connection with the problem

What your CONFIG and AUTOEXEC files contain

What versions of DOS and Windows are you running

The make and model of your machine and video driver

The amount of memory you have

Any other devices and peripherals connected to your system

The steps and conditions we will need to recreate the problem

If a problem is intermittent, please describe as well as you can your machine and the conditions just before it occurred.

We may ask you to send us your program and demo file(s).

e e i i



Designer Window

The window in the DemoShield Designer that eventually becomes the screen your viewer sees. When you are creating your demo,
you place your objects in the Designer Window. The objects you see in the Designer Window at any point in time are the visible

objects that exist at that time.



drawing mode

When you click a button on the Object Palette to create a Graphic Object--for example, a rectangle, ellipse, or line--the DemoShield
Designer goes into Drawing Mode. You are in Drawing Mode when you are creating and sizing a graphic object, for example. When
you finish drawing the graphic object, you return to Edit Mode.



Duplicate Scene

Duplicates the current scene. The copied scene will be placed after the current scene. Choosing Duplicate Scene from the Scene
Menu is the same as clicking on the Duplicate Scene button on the Toolbar or the Scene Sorter.



edit mode or

When DemosShield is in Edit Mode, you can use any of the buttons in the Designer. Use Edit Mode to set or change the properties
for an object, and for other tasks such as importing and managing resources, and sorting the scenes in your demo.

See also Drawing Mode and Test Mode.




Enable Preferences

Use the Enable Preferences dialog to turn on or off a number of settings to customize DemoShield to fit the way you work. One
setting you may wish to enable is the Scrollable Design Window view, which assists you in creating demos that will display correctly
on a variety of systems. Before you create your distribution disks, you may wish to enable Check Resources, which will
automaticallly tell you if unused resources exist in your demo.
Options
Shortcut Menus
Startup Dialog
Tooltips
Demo Auto Save
Large Image Preview
Scrollable Design Window
Automatic Last Demo Launch
Check Resources
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End Period

Begins when the object starts moving out of the scene (end time) and lasts until the object disappears (exit time). Displays in cyan.



End Time

When the object begins to move out of the scene.



Enter

Pressing the Enter key opens the Properties dialog box for the selected object. If you have selected more than one object, the
Properties dialog box opens for the first object you selected.



Escape

Removes selection from all objects.



Event Object

Use an Event Object to make some action happen in your demo automatically,without any viewer input. You can create any
action with an Event Object that you can with an interactive object. For example, you could switch to a different scene, display or
hide text, or pause or restart a demo.




Sample code

The following is an example of the code you can use to launch the DemoShield Player.

This is a very simple code sequence that launches the Server, plays a demo called w.dbd, and then closes both the demo and the
Server.

Example Code:

#define DEMO_SERVER_CLASSNAME "DemoShield"

#define DEMO SERVER CAPTION "DemoShield"

#define DEMO_SERVER_ LAUNCH "DemoServerLaunch"

#define DEMO_SERVER PLAY "DemoServerPlay"

#define DEMO_SERVER_CLOSE "DemoServerClose"

#define DEMO_SERVER_ DESTROY "DemoServerDestroy"

#define DEMO_SERVER GO "DemoServerGo"

uiLaunchMsg = RegisterWindowMessage ( (PSZ) DEMO_SERVER_ LAUNCH) ;
uiPlayMsg = RegisterWindowMessage ( (PSZ) DEMO_SERVER PLAY);
uiCloseMsg = RegisterWindowMessage ( (PSZ) DEMO_SERVER CLOSE);
uiDestroyMsg = RegisterWindowMessage ( (PSZ) DEMO_SERVER DESTROY) ;
uiGoMsg = RegisterWindowMessage ( (PSZ) DEMO_SERVER_GO) ;

WinExec ( (PSZ) "demo.exe -s", SW_SHOW );
hwnd = FindWindow( (PSZ) DEMO_SERVER_CLASSNAME, (PSZ) DEMO_SERVER CAPTION ) ;
if (hwnd != NULL) {
//have the server start playing w.dbd demo
PostMessage ( hwndL, uiLaunchMsg, 0, (LPARAM) (PSz) "c:\\w.dbd" );
//immediately close the demo and destroy the server.
PostMessage ( hwndL, uiDestroyMsg, 0, 0L );

}



Example of Comparisons

You can build both True and False Actions. That is, you can build one set of actions your demo will perform if the comparison is true
and a different set of actions the demo will perform if the comparison is false.

Suppose you have two Graphic Objects in a scene and you want to compare one of their properties.This is the data you enter in the
five fields of the Comparison dialog box:

Object Property

Object Property
To say how you want to compare the objects, you open a combo box and choose an operator. The operator we are using here is the
equal sign. The equals sign tells the Comparison dialog box to see whether the objects are identical. You could just as easily ask
whether the objects are not equal, greater or lesser than, and so on for all the standard operators.
Taking this a step further, for example, you could compare two objects to see if they are both visible. Let's assume the names of the
objects are Graphic 1 and Graphic 2, and the property you want to compare is whether or not they are visible. You enter the data to
compare like this:

Graphic 1 Visible

Graphic 2 Visible
You can also compare the value of a variable with the value of a constant. Say you created a Variable Object named Variable 1 and
gave it a value of 102. You want to see if the value of Variable 1 is less than 101. The data you enter for that type of comparison
would look like this:

Variable 1

Constant 101

For some comparisons, you do not need to enter all five items of data. Here, for example, DemoShield already knows the value of
Variable 1 so there is no need to enter that number. When you compare a variable with a constant, you create a temporary constant
on the spot, and give it the value you want to test. In this case, we made the value of the constant 101. This comparison would turn
out to be false since 102 is greater than 101.

If you want something to happen in your demo when the comparison is false, you would need to build that action using the False
Actions dialog box.



Example of stacking

It may help to visualize this if you pretend you're an actor standing on the stage of an auditorium, looking out at the audience. Think
of the Objects List of the Scene Editor as rows of seats in the auditorium. The last row at the top of the list is the object farthest
away. The first row at the bottom of the list is the object closest to you.

When you click the red button pointing down to bring an object closer, the name of the object moves down in the list (closer to the
stage) and the object itself moves forward in the stack. When you click the red up button to send an object farther back, its name
moves up in the list (farther back in the auditorium) and the object itself moves back in the stack.




Example of setting up to multiple disks
If the files you are distributing are too big to fit on one disk, the Wizard creates a separate subdirectory for each disk you will need.

For example, if you need three disks and you entered the subdirectory c:\\demo\viewer, the Wizard will create these subdirectories:
c:\demo\viewer\disk1
c:\demo\viewer\disk2
c:\demo\viewer\disk3



Exit Demo Transition

The demo stops.



Exit Time

The time when the object finally disappears from view.



Fax

You may reach us by fax 24 hours a day, seven days a week. Our fax number is:

708-240-9138

When you fax, please include your name, address, and phone and fax number. This information must match the information on your
registration card.



Full Screen Capture

Captures all windows shown on the screen.



Full Screen Mode

As you create your demo, you will probably want to try testing it numerous times to see how it plays. You can test-run a demo either
in the Designer Window or in Full Screen Mode. In Full Screen Mode, the demo maximizes to fill up the entire screen, and you see
the demo play the way your viewer will see it. The Demo Controller is the only DemoShield palette that remains onscreen in Full
Screen Mode.

See also Test Mode,



Global Variables List

(Comparison Dialog Box)
In the Comparison dialog box, the term Global Variable refers to both the DemoShield Global Variables you set in the Demo
Properties dialog box, as well as the system variables explained below. These system variables (such as Hour) come from

the internal clock of the computer system running the demo. Use the Comparison dialog box to compare a Global Variable
with the property of an object, or with a constant.

Number and String (Global) Variables

These are the DemoShield global variables you set in the Demo Properties dialog box. For information on setting these, see
Chapter 11.

Elapsed Time

The length of time the demo has been running (in milliseconds).
DayName

The name of the current day of the week (Monday, Friday, etc.).
MonthName

The name of the current month (April, etc.)
Day

The numeric value of the current day (10 for the tenth day of the month).
Month

The numeric value of the current month (ie. either 2 for February).
Year

The numeric value of the current year in four digits (i.e. 1995).
Hour

The numeric value of the current hour (i.e. 9).
Minute

The numeric value of the current minute (i.e. 32).
Lock Keys

The following variables refer to the pressed or unpressed property of the key shown. If the key is pressed, it equals 1. If the
key is unpressed, the value is 0.

ScrollLock
NumLock
CapsLock
AltKey
Ctrikey
Shiftkey

For example, you could compare the CtrlKey variable with the constant 1. If your viewer is pressing the Ctrl key at the time of
the event, the comparison is true.

Random
This is a random variable your system generates. It can be any number from 1 to 100.
SystemTime

This is a 32-bit value where the year is the low byte of the low word; the day is the high byte of the low word; and the month is
the low byte of the high word. (Example: 0x00041595 = April 15, 1995.)

WinDir

This variable is your Windows directory (Example: c:\windows).
WinSysDir

This variable is your Windows system directory (Example: c:\windows\system).
X-Extent

This variable is equal to the width of the screen in pixels. For example, if the viewer’s screen was VGA resolution, the X-
Extent value would equal 640.

Use the X- and Y-Extent variables to show a special graphic, macro, or sequence of scenes designed specifically for viewers
running a particular screen resolution. For example, you could use a Set Contents action on a Graphic Object to display a
bigger bitmap to viewers running the demo on an XVGA screen. Likewise, you could use a Play Macro action to play one of
three different macros depending on the viewer’s screen resolution.

Y-Extent
This variable is equal to the height of the screen in pixels. See X-Extent.

Cwd



This variable is your current working directory.
OSVersion

This variable is the major version number of the Windows software currently running. For example, if your viewer runs
Windows 3.1, the OSVersion variable is equal to 3. If the viewer runs Windows 95/NT, the value would equal 4.

OSVersionMinor

This is the minor version number of the Windows software currently running. For example, if your viewer runs Windows 3.1,
the OSVersionMinor variable is 10.



Globals

Click on Globals in the Demo Properties dialog box to set the global variables for your demo. You may set three number and three
string (text) variables. They may be used anywhere in the demo.

Steps
b To set DemosShield's global variables (humber and strin
2 To view initial and current states

» To reset global variables




Glossary of Terms

&
4lEH

>
C
3

= v m B @ @ [>
scphRERl
7 < K Mo [l X

© .
Q
=
(=]
>

Aligning Tools

Application Object button

application
arrow keys
AVI Object button
AVl file
bitmap
Bitmap Button
border style
bring

button
caption

check box
combo box
conditions
constant

Copy Properties and Apply Properties

default

Delete

Demo Controller
Demo Wizard
demo disk

demo



Designer Window
disabled
distribution disk
drag

drawing mode

Duplicate Current Scene

Duplicate Object(s)

edit mode

effect
enabled

end period

end time

Escape

event

Event Object

Exit Demo transition
exit time

fill styles

full screen mode

full screen background (for windowed demo)r

global variable

Go to Next Scene transition

Go to Previous Scene transition

Go to Scene transition

Graphic Object
arid
rou

handles

help screens
hold period

hold time

Hot Spot Object button

hot spot
hypertext
interactive demo
Interactive object
jump mark



key press
lasso

layer

left mouse click

life

ink

live application demo

macro

metafile

motion

Move Cursor action
multimedia
native resolution
Next Scene
non-linear

no scale

Object Palette
object styles
object

objects list

Open Existing Demo

operator
palette
password

Pause on Scene transition

pixel
Play Demo

Play Scene Full Screen

Play Scene

pointer

PopUp Menu button
properties
prototype

Replay Current Scene transition

resize



Resizing Keys

resource

Restart Demo transition

Return from Scene transition

RGB

right mouse click
RTE

runtime file or runtime version

SCM file
Save Demo
scaling
Scene Editor
scene
screen resolution
select
self-running
send

Server

Setup Wizard
shortcut key

slide show
software demo

splash screen

stack order

start period

start time

stop button
Tab and Shift+Tab

template

test mode

Text Object button
timed action
Timeline Editor
TPL

transparent areas on bitmaps

tutorial

Variable Object button




variable

VCR Button Object button

viewer

WAVE file
windowed demo
wizard

X-axis or coordinate

Y-axis or coordinate



Go to Next Scene Transition

The next scene starts.



Go to Previous Scene Transition

The previous scene starts.



Go to Scene Transition

The demo switches to whatever scene you choose. When you choose this, a second combo box opens showing you every scene in
the current demo. You choose from this list which scene to go to.



Graphic object

Graphic objects are visual shapes that you can see on the screen, and use to design your demo, such as lines, rectangles, and
circles. For each one, there is a separate button on the Object Palette.



Grid Settings

DemosShield has an invisible grid you can use to position your objects on the screen. Turn on this grid by checking the Snap to Grid
check box in the Options tab of the Preferences dialog box. (To open the Preferences dialog, choose Preferences from the File
menu.)

When Snap to Grid is on, you can select how far you want an object to move when you use the arrow keys to position it. For
example, you could choose 5 pixels for both height and width. Then, when you press any vertical or horizontal arrow key, the
selected object would move 5 pixels in that direction.

Note: When Snap to Grid is deselected, the object always moves 1 pixel in any direction.



Group

You may want several individual objects to behave onscreen as if they were a single object. The easiest way to do this is to create a
Group Object that contains the individual objects. For example, you might want a number of graphic elements to enter, then
disappear from a scene at precisely the same instant.



Group Name

Enter a Group Name for each object that will belong to a group. Every object that belongs to the same group must have the
identical Group Name. To perform actions on the group, you need to create a Group Object. The Group Object must also have the
same Group Name as all the objects in the group. It can have any object name you wish. Use the Actions property dialog box to
create actions for the Group Object. Those actions will affect every object in the group.



DemoShield Help
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@ Reference Information
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Hold Period

How long the object stays where you placed it when you created it. Equal to the End Time minus the Hold Time. Displays in pink.



Hold Time

The period of time during which the object stays in its final position the screen. Hold Time begins when the object reaches this
position.



Hot Spot Button IH'
Creates a Hot Spot Object. A hot spot is a mouse-sensitive rectangular area onscreen. You can make the same actions happen
when your viewer clicks a hot spot that can happen when your viewer clicks a button. Unlike buttons, however, hot spots are
invisible. You can also make the viewer's mouse pointer change to a different cursor when it enters the hot-spot area.




How Can | Control Demo Scaling?

If the size of the Designer Window is either larger or smaller than the screen your viewer will play your demo on, your demo will
scale to fit the screen.

Scrollable Design Window

Enabling the Scrollable Design Window view from the Preferences dialog box will assist you. When this window view is selected,
you know that you are viewing and editing your objects in a 1:1 ratio with the demo your viewer will eventually see. In other words,
the scrollable Design Window view enables you to edit objects in a What You See is What You Get (WYSIWYG) view.

This does not mean, however, that your objects will not scale. They will, unless you take other steps, such as disabling scaling for
key objects.

Windowed Demo

The ultimate way to avoid scaling problems is to create your demo in a Windowed Playback Style. This allows you to select the
exact size of the window that your viewer will watch the demo in. If you check the Fixed Size option in the Size tab of the Demo
Properties dialog box, your window will be an absolute size. That means the window and all the objects in it will remain the same
size no matter what screen resolution your viewer is running.



How Can | Control Object Scaling?

Often, you will want to create a demo where most of your objects will scale. However, you may wish to set the relative size and
position of some objects.

When you want to disable scaling for only selected objects, you should enable the No Scale property for those objects.

The No Scale Option

If you are layering objects in a demo (such as placing an arrow over a graphic) you will need to select the No Scale option for both
the arrow and the graphic. This will ensure that their relative positions will not change. Allowing both objects to scale will not produce
the same result.

To disable the scaling of specific objects:

1. Open the Properties dialog box for the object you want to stop from scaling.

2. Inthe General Properties dialog box, select the check box marked No Scale.
This will disable scaling for the selected object.

Note: Not all objects scale in the same way. Some objects don't scale at all. Other objects scale in part. Refer to the DemoShield
User's Guide for details on how specific objects scale.



How Do | Check My Current Demo Resolution?

To check the resolution of your demo, select About from the Help Menu. The About DemoShield dialog box opens. Click on the
Demo Info button. The Demo Information dialog box opens. Here you can view: the full path name for your demo; the demo
template you are using; the version of DemoShield you are running; and your demo’s resolution in pixels.

To set the default resolution for your new demos,choose Preferences from the File menu and click on the Configure tab.



How a Programmer Uses the Server

Related steps  Example
Your job in using the Server is to:
1. Call RegisterWindowMessage to register the messages to communicate with the Server.
2. Launch the DemoShield Player in Server mode.
3. Call FindWindow to locate the Server window.
4. Call PostMessage to communicate with the Server.
The list below shows the messages you can send to the Server.

MESSAGE WPARAM LPARAM

‘DemoServerGo’ Scene Ordinal Number or (PSZ) Scene
Causes the demo playing currently to switch to the specific scene name or ordinal number.

‘DemoServerClose’ 0 0
Closes the demo playing currently.

‘DemoServerDestroy’ 0 0

Closes the demo playing currently, and closes the Server.

‘DemoServerLaunch’ 1-Suspended (PSZ) Full Path
O-Start

Initializes the Server to play the demo. If the demo is launched in a suspended mode, then the server will wait
until the play message is received (see below).

‘DemoServerPlay’ 1-Silent Start LOWORD (x coordinate)
0-Standard Start HIWORD (y coordinate)

Starts the demo playback for a demo that was started in a suspended mode through the launch message. The
x and y coordinates are used to position a windowed demo. The silent start option will launch the demo without

the initialization dialog.



Identify Application

1. Click on the Options tab

2. Under the listing Identify Application, you will see a field for the application’s Windows Class Name field and for its Windows
Caption.

For Windows 3.1 applications, these fields should be left blank.
For Windows 95 or Windows NT applications, these fields must be set.
3. If your application is a Windows 95 or Windows NT application, type in the name of your Windows Caption and Windows Class

Name in the appropriate edit fields.



Image Options group

Select an option for how you want the bitmap to be imported.
Option Description

Crop Image If the bitmap is too big for the frame,
DemoShield cuts off any of the image that
won't fit in the frame. If the bitmap is
smaller than the frame, DemoShield
centers the image in the frame.

Shrink Image Alarger bitmap shrinks to fit the frame. A
smaller bitmap stretches to fit in the frame.
Note: This option will usually distort
bitmaps.

Resize Frame A larger frame shrinks to fit the bitmap. A
smaller frame stretches to surround the
bitmap. This option is not available for
scenes.

Note: Image options are irrelevant (and thus grayed out) for Windows metafiles (.wmf files).



Import Video and/or WAV Files by Reference

Check the Import Video and Import WAV boxes to reference those files rather than import them as part of your demo file. When you
select Import by Reference, every new resource of that type that you import will be referenced. At any time you can deselect this
check box to import the remaining resources as part of the demo file.

Note Itis recommended that you import your video (.AVI and .SCM) files by reference.  You may also wish to import any
longer .WAV or application (.EXE) files. Application and video files are unloaded from the demo (.DBD) file when the
DemoShield Player launches the demo. This can significantly delay Player launch.




Import by Reference

Importing a resource by reference means the resource will not be stored as part of your demo file, but separately. This will keep your
demo file small, but you must make sure to include the resource file when you use the Setup Wizard to create your distribution disks
for your final product.

Note: Delivering your .exe file separate from the demo file gives your viewers access to your application outside of the demo.



International

DemosShield provides technical support to registered users throughout the world. Please contact us directly for technical support
regardless of where you purchased the product.

CompusServe is the most effective way of contacting us from international locations. If you already do not have a CompuServe
account, we highly recommend that you obtain one. From our CompuServe forum you can access the most current information and
files.

You may also wish to contact us through the Internet.

When you write us from abroad for technical support, please include your complete address, with city, state or province, and country.
Please include your fax number, phone number, and information on dialing from the United States, if available.

Use these numbers to call CompuServe:

Country/Region Phone Number
United States 1-800-848-8199
United Kingdom 0800-289-378
Germany 0130-37-32

The rest of Europe 44-272-255-111

Ask for Representative 183.



Internet

E-mail

You send e-mail to DemoShield Technical Support via the Internet at:
support@DemoShield.com

Please include your name, company name, and phone number with every message.

File transfer
Use the following address to upload your Stirling Reports technical support forms and demos for our technical support staff to
review:

ftp.DemoShield.com
You will access a server which provides for file uploading and downloading. By default, you will log onto the download-only drive. In
this drive, you can browse for DemoShield files of interest, including maintenance and minor releases, sample demos and updates
to the Knowledge Base.



Key Concepts

What is a Scene?
What is an Object?
What are Resources?
What is Life?

What is Action?
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Large Image Preview

Check this box if you want to be able to preview your large image resources.



To launch the Player from the Help Menu

Related steps More about
Before you can launch the Player from the Help menu, you have to specify the files that will be available to play.
To select the demo files to play from the Help menu:
1. Select Preferences from the File menu and open the dialog box.
2. Inthe Demos tab, you will see edit fields named First Demo, Second Demo, Third Demo, and Fourth Demo.
Click the down arrow key at the right of the Demos dialog box to view the edit fields for up to 10 demos.
3.  Enter the full path name for the demos you wish to play, or click on the Browse button to browse for the files.
4. Click OK when you have made all your selections.

5. To play a demo, select Play [FILENAME] from the Help menu. The demo you selected will launch. When you the demo ends,
you will return to the Designer Window.

The file selections you made in the Preferences dialog will be saved when you save your current working demo. You may, of
course, choose to remove or replace any of these selections at any time.




left mouse click

Selects the object underneath the cursor and deselects any objects that you may have previously selected. If there is no object
underneath the cursor, then a left mouse button click deselects all selected objects.



LifeLine

The LifeLine is a three-color horizontal bar that graphically displays an object's Start, Hold, End, and Exit Times.

It appears in both the Life properties dialog box and the Timeline Editor.

Drag on the edge of any color bar to select the time you want to change. Your cursor turns into the LifeLine cursor shown below.
Drag the cursor left to decrease the time; right to increase it.

The new time will appear simultaneously in the matching edit field.

LifeLine cursor
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Line

Creates a line object.



live application demo

Alive application demo contains an Application Object which launches an application that runs along with your demo. Often, macros
are used to demonstrate application features to your viewer, but you could create a live application demo without macros.



Lotus ScreenCam

Lotus ScreenCam is an application you can use to create video screen captures of your application screens. The files you create
are saved in Lotus Corporation’s Screen Cam Movie (SCM) file format. SCM files have the filename extension SCM. You can play

any SCM file in DemosShield using the Play Video action.




MSD.EXE

Microsoft includes a program called Microsoft Diagnostics (MSD.EXE) as part of the Windows package. MSD.EXE captures detailed
information on your system and outputs the information to a file. MSD.EXE is typically located in your DOS directory.

You may launch MSD.EXE directly from Stirling Reports.

To run MSD.EXE in Stirling Reports
1. Click on the Stirling Reports icon in the DemoShield program group or folder.

2. Click the Technical Support button to create a technical support request form.

3. Fillin the information requested, and press Next to move to each additional screen.

4. In Screen 5 of 6, click on the Run MSD button to launch MSD.EXE.

When the report is finished, you will return to Screen 5.

MSD Report will be automatically selected under "System Files to Attach."”

Check the boxes for any other system files you wish to attach to your tech support request.
Click Next to move to Screen 6.

Click Save As to save your tech support request form.

© N o’

Upload your form (*.srf) and, if possible, your demo file, to DemoShield's technical support staff via CompuServe, BBS, or the
Internet.. You may wish to zip your file(s) before you send them to save time and money. You could also fax or mail your
request.




Macro Start/Stop Recording Key

Select a function key (F2-F12) to serve as your macro Start/Stop Recording key.



Mail
Use this address to send us disks or other information by mail or overnight express:

DemosShield Technical Support
InstallShield Corporation

1100 Woodfield Drive #108
Schaumburg, IL 60173

USA



Maximize Application
You may choose to force the application to run maximized by selecting the Maximize Application check box. However, DemoShield
does not require you to run your applications maximized.

If you do not choose Maximize Application, you may select the position of the application window that will play on your viewer's
screen.



Control menu

The choices on the Control Menu perform the same functions as the Demo Controller. Click a command to learn more:

2 Restart

b Play Scene

[ Full Screen Play
b Play

2 Jump Forward
2 Jump Back

3 Step Forward

» Step Back

b Stop

2 Next Scene

» Previous Scene

2 Go to Scene




Demo menu

Use the Demo Menu to:

Manage the resources in your demo
Make screen captures of your running applications
Record, save, and play macros
Set demo properties such as shortcut keys, demo styles, and global variables
Set demo template properties
emo Menu Selections
Manage Demo Resources
Capture Images
Record Macro
Save Macro

Play Macro

Properties
Template Properties
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Edit menu

Use the Edit Menu to locate commands for copying, deleting, selecting, and modifying objects.
Click a command to learn more:

Undo
Redo
Cut
C
Paste
Paste Special
Delete
Select All
Clear Selection
Duplicate
Pick Up Styles
Apply Styles

v

L

b R R i

v




File menu

Use the File Menu to create, open, and save new or existing demo or template files, and to customize some of the ways
DemoShield looks and works on your system. Click a command to learn more:

2 New

» Open

Close

Save

Save As

Load Template
Save Template
Save Template As
Import Demo
Preferences
Exit
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Help menu

Use the Help menu to open the Help contents, to search for a Help topic, and to read information about DemoShield. You can also
launch the DemoShield Player if demos have been preset to play.

Click a command to learn more:

Contents

Search for Help on
About

Technical Support

Launching the Player
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Object menu

Use the Object Menu to create a new object, delete or change the stack order of a selected object, or align selected objects. Click a
command to learn more.

New Object

Delete

Edit Properties
Bringing and Sending
Aligning Tools
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Scene menu
Use the Scene Menu to create, delete, sort, and manage the scenes in your demo. Click a command to learn more.

New Scene

Delete Scene
Duplicate Scene
Scene Sorter
Move Scene Up
Move Scene Down

Properties
Template Properties
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View menu

Use the View Menu to display, hide, and/or arrange the position of tools, palettes, invisible objects, and the Toolbar and Status Bar
in the Designer Window. Click a command to learn more:
Arrange Tools

Timeline Editor

Demo Controller

Scene Editor

Object Palette

Aligning Tools

Toolbar

Status Bar

Invisible Objects

i e R R R R i




Window menu

Use the Window Menu to switch between demo windows when you have more than one demo open in the Designer Window, and to
clear the Designer Window of stray color pixels from previous operations.

Note: In this version of DemoShield it is possible to display only one demo at a time in the Designer Window. You can, however,
use the Window Menu to view the Timeline Editor when it is hidden by the demo window.

Click a command to learn more:

3 Cascade
b Tile
» Repaint Scene




More about global variables

DemosShield's global variables are variables you set that can be used in any scene. You can set three Number Variables and three
String (alphanumeric) Variables.

You can increment (increase by one) or decrement (decrease by one) number variables through a Set Variable Action. You can also
use a Set Variable Action to assign a new value to any variable.

Then, you can use an Event Object to compare the contents of a Global Variable against a constant or an object property. Finally,
you can create actions to occur if the comparison is true, and actions to occur if the comparison is false.



No Scale

Disables the object's scaling when the demo is played on a screen that is a different size than the screen the demo was created for.



Null Color tab
If your viewer's monitor is larger or smaller than your demo window, DemoShield fills the unused area of the screen with the Null
Color.

Steps
b To set the Null Scene Color




Object Palette

A panel with buttons that you use to create objects. The Object Palette appears by default at the right side of your DemoShield
screen, but you can drag it elsewhere. There is a button on the palette for each object you can create. To create an object, click the
button for the object you want, then click in the Designer Window.



Edit Field Object

Create a standard Windows edit field, in which your viewer can type characters. You must use an Event Object to evaluate the

contents of an Edit Field.
Properties Tabs

General properties tab

Object Styles properties tab

Fill Styles properties tab

Font properties tab

Font Color properties tab

Bkgnd Color properties tab

Border Color properties tab

Life properties tab
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Create an Edit Field Object




Object Properties List
(Comparison Dialog Box)
The following is a list of the Object Properties you can compare using an Event Object’s Comparison dialog box. Not all of an

object’s properties can be compared meaningfully. For example, an Edit Field Object is the only object whose General Data
Property can be evaluated in DemoShield.

Group
Visible
Enabled
Position
Dimension
Start-Time
Hold-Time
End-Time
End-Period-Length Time
General Data
Pressed




AVI Object

Create an AVI Object to play any video sequence in your demo that uses Microsoft's Audio Video Interleaved (AVI) file format.
Use an AVI Object in your demo to play an AVI file in your demo automatically, independent of your viewer. When you use an AVI
Object to play your AVI file, the last frame remains onscreen for as long as you want.
Properties Tabs

General properties tab

2 Object Styles properties tab
How to

2 Create an AVI object




Application Object
Create an Application Object when you want to run some other application software at the same time you run your demo.

Properties Tabs
General properties tab

2 Object Data properties tab
2 Options properties tab
How to

Create an Application Object
[ Choose application and support files to launch



Bitmap Button Object

Create a bitmap button when you want a button that can display a bitmap or metafile image with or without a text caption.
Properties Tabs

General properties tab
Object Styles properties tab
Fill Styles properties tab
Font properties tab

Font Color properties tab
Bkand Color properties tab
Fill Color properties tab
Actions properties tab

Life properties tab
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Create a Bitmap Button

-



Ellipse and Polygon Objects

Create an Ellipse Object when you need a circular shape.
Create a Polygon Object when you need an irregular closed shape, like an object with six sides.

Properties Tabs:

General properties tab

Fill Styles properties tab
Bkand Color properties tab
Fill Color properties tab
Border Styles properties tab
Border Color properties tab
Life properties tab

ow to
Create a Polygon
Create an Ellipse
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Event Object

Use an Event Object to make actions happen in your demo without any viewer interaction.
Properties Tabs

General properties tab
» Time properties tab
b Comparison properties tab
b
b

True Actions properties tab
False Actions properties tab

b Create an Event Object




Group Object

Create a Group Object when you want an object that contains other objects. When you create actions for the Group Object, all of
the objects in the group perform the same actions together.

Properties Tab
General properties tab

How to
b Create a Group Object




Hot Spot Object

Create a sensitive area on the screen that you can click to initiate some action. In DemoShield, for example, you can create a hot
spot that your viewer can click to bring a menu onscreen, display a window with special information, or switch from one scene to
another.

Properties Tabs

2 General properties tab

2 Object Styles properties tab
2 Actions properties tab

2 Life properties tab

How to

b Create a Hot Spot




Line and Poly-Line Objects

Create a Line or a Poly-Line Object when you need lines or arrows.

A Line Object creates straight individual lines.

A Poly-Line Object creates open-ended objects containing two or more lines.
Properties Tabs

General properties tab

Line Styles properties tab

Arrow Styles properties tab

Fill Color properties tab

Line Color properties tab

Life properties tab

ow to
Create a Line Object
Create a Poly-Line Object
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Menu Object

Create a menu that pops up anywhere in your demo when the viewer clicks a button or presses a shortcut key. You can set the
buttons on this PopUp Menu, making it possible for your viewer to control your demo.
Properties Tabs

General properties tab

4 Object Styles properties tab
» Captions tab
How to

Create a PopUp Menu




Push Button, Radio Button,and Check Box Object

Create a standard Windows button object. By clicking this button on the Object Palette, you can create three types of buttons: a
push button, radio button, or check box. When your demo is running, your viewer can click the button to select a menu choice,
change scenes, reveal an answer, display text, or initiate other actions which you select from a list.

Properties Tabs

General properties tab

Font properties tab

Font Color properties tab

Life properties tab

Object Styles properties tab

Bkand Color properties tab

Actions properties tab
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Create a Push Button, Radio Button, or Check Box Object
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Rectangle and Rounded Rectangle Object

Create a rectangular object with square or rounded corners.
Properties Tabs

General properties tab

Fill Styles properties tab

Bkand Color properties tab

Border Styles properties tab

Border Color properties tab

Life properties tab
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Text Object

Create a Text Object to display text in your demo.
Properties Tabs

General properties tab
Object Styles properties tab
Fill Styles properties tab
Font properties tab

Border Styles properties tab
Border Color properties tab
Font Color properties tab
Bkand Color properties tab
Life properties tab

ow to
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Create a Text Object




VCR Button Object

Creates VCR buttons the viewer uses to control the demo.
Properties tabs

General properties tab
» Object Styles properties tab
3 Font properties tab
b
b

Font Color properties tab
Life properties tab

b Create VCR Buttons




Variable Object
Create a Variable Object to store a numeric or string value. A Variable Object is local to the scene, that is, it can only be used in the
scene it is created in. Use a Global Variable to create a variable that can be used anywhere in the demo.

Properties Tabs
General properties tab

2 Variable Data properties tab
How to
2 Create a Variable Object

b Set the properties of a Variable Object



Objects List

The list box in the Scene Editor that displays the name of every object that you have placed in the Designer Window for the current
scene. To select an object, click its name on the Objects List. To open an object's Properties dialog box, double-click its name on the
Objects List.



Options tab

Options
Time Increments for Steps and Jumps
[ Grid Settings
b Import Video and/or WAV Files by Reference




Pause on Scene Transition

During this kind of pause, the clock does not stop. It keeps going, but the demo does not switch to another scene or start playing
again from the beginning. The scene simply stops at the end and waits for viewer input--a mouse click or key press--that starts a
new action or switches to a different scene.




Phone

DemosShield is not a program for the casual computer novice. We rarely resolve anything on the phone. If you call and say "My
demo does not work," there is little we can do to help you. In most cases, we need to examine your demo file, and that takes more
than a quick call.
The fastest, most efficient way to get technical support is through CompuServe. Send us your demo (.DBD) file and describe your
problem in detail before you call. Then when you do call, we can have your answers ready.
Use the same procedure if you send your information to our bulletin board, by fax, or by mail. You must be a registered user before
you call.
Before You Call

Open the Knowledge Base and check the Frequently Asked Questions folder for your question.
3 Go through the DemoShield Questions & Answers file on CompuServe and on our BBS. We continually update this file.
DemosShield technical support hours are Monday through Friday, 9:30 AM to 4:30 PM Central Time.
Click here to read about

User Information We Will Need
b Technical Information We Will Need




Player

The DemoShield Player (demo.exe) is the run-time-only version of the DemoShield Designer (DESIGNER.EXE). The Player is a
separate, smaller executable program file that you copy to the disk you distribute with your demo to your viewers. The Player can
run a demo but you cannot use it to create a demo.



Position Application

If you do not choose Maximize Application, you may select the position of the application window that will play on your viewer's
screen.

] To leave the application in its current position, check the Don’t Move Application check box.

] To position the window, uncheck the box marked Don’t Move Application.
Type in your selected X and Y screen coordinates in the edit fields provided.



Program Item Properties
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This is an example of the Program Item Properties for a
copy of the DemoShield Player. This Player will position
the demo window at an X coordinate of 40 pixels.




RGB

The abbreviation RGB stands for the three basic colors--red, green, and blue. By combining different values of these three colors, it
is possible to create any other color. Using DemoShield's color selection dialog boxes, you can quickly choose from 16 preset
colors, or create any other color.



RTF

Rich Text Format. Use RTF files when you want to display text you have created using a word processor.



Registering

Fill out and send us the software registration card included with your copy of DemoShield. Include your name, address, company
name, phone and fax number, and electronic mail or BBS numbers if available. The registered user must be the person using the
software and calling for tech support--not the software librarian of the company.

For immediate help, fill out and_fax us your registration card.



Replay Current Scene Transition

The clock returns to zero and the current scene plays over again from the beginning. These actions will repeat in an endless loop
until your viewer clicks a button or presses a key that starts a new action or switches to a different scene.




resizing keys

You can use keystrokes to resize an object more precisely than you can with a mouse. +



Restart Demo transition

The demo starts again from the beginning.



Return from Scene transition

The demo returns to the last sub-scene. This is an advanced Scene Transition with which you need not concern yourself until you
are thoroughly familiar with DemoShield.

Usually you'll want the scenes in your demo to play one after another in simple ascending numeric order from beginning to end. But
actually you can play the scenes of a demo in any sequence.

For example, you may want a demo to break away from its numeric sequence, switch to play a special sequence of scenes, and
then return, picking up where it left off, to continue the numeric sequence.

To switch to one of these special sequences, use the action called Go to Sub-Scene. To return from a special sequence, use the
action Return From Scene or this Return From Scene Transition.



right mouse click

If Shortcut Menus is selected in the Preferences dialog box, Enable tab, a right-mouse click will display a shortcut menu. The menu
will contain common commands you can use on the item you selected.

If an object is selected, the shortcut menu for objects will pop up. If no object is beneath the cursor, then DemoShield displays a
shortcut menu for that scene. If you right-click on an inactive area within a Properties dialog box, a menu of all the tabs within that
dialog box will pop up. You can left-click on any tab name to bring it to the front.

If Shortcut Menus are deselected, a right-click on an object will bring up the object's Properties dialog box, and a right-click on an
empty spot in a scene will bring up the Scene Properties dialog box. A right-click within a Properties dialog box will produce no
effect.



Scene Sequence

Introduction
Second Scene

Fourth Scene
Summary
Last Scene
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Scrollable Design Window

To ensure that you are viewing and editing your demo objects in a What You See Is What You Get (WYSIWYG) mode, we
recommend that you enable DemoShield's Scrollable Design Window view.

This is an option available in the Preferences dialog box, Enable tab.

When this option is not enabled, what you see in the Designer Window could be a scaled representation of the demo that your
viewers will actually see. This is because the size of the Designer Window may be either larger or smaller than the size of your final
demo. This can be the case even if you are running DemoShield with your monitor set to the same resolution as your demo's native
resolution.

Say you are creating a demo to be seen at VGA resolution, and you are also running DemoShield at VGA resolution. The Designer
Window (since it does not take up the whole screen) is therefore smaller than your final demo window will be. DemoShield scales
the demo to fit in the window. Therefore, the objects that you see in the Designer Window are a scaled representation of how they
will actually appear in your demo.

Check the Scrollable Design Window box in the Enable tab. The Designer Window changes to a 1:1 representation of your final
demo. Now you can view and edit your objects in a WYSIWYG mode.

If the Designer Window is smaller than your demo window, scroll bars will appear on the Designer Window to allow you to view and
edit the objects that no longer appear.

Hint  Missing Objects. Sometimes an object may become positioned outside the boundaries of the Design Window, even beyond
the reach of the scroll bars. However, there is a way to move it back. Click on the object’'s name in the Scene Editor. Select
Move Object to Front from the Object Menu. Now, hold down the appropriate arrow key(s) on your keyboard to move the
object into position.



Set Times by Typing

Related steps  More about

1.
2.

Click to insert the text cursor in the Start edit field.
Type the Start number in seconds.

In the Start field, type when the object starts appearing.
Click to insert the text cursor in the Hold field.

Type the Hold number in seconds.

In the Hold field, type a number in seconds to say when you want the object to begin holding onscreen in the place where you
created it.

If you typed 4, this tells DemoShield you want the object to begin holding 4 seconds after the scene starts. If the object's Start
Time began when the scene was 2 seconds old, and the object starts holding when the scene is 4 seconds old, that means you
want it to take 2 seconds to move into the scene.

Click in the End field.

Type the End number in seconds.

In the End field, type when the object will start making its exit.
Click in the Exit field.

Type the Exit number in seconds.

In the Exit field, type when you want the object to disappear.

Note: DemoShield immediately validates the numbers you type in the Start, Hold, End, and Exit Time fields against the other

time values already present. If you type in an "invalid" number, such as a Start Time that is higher than the present Hold
Time, DemoShield will automatically reset the new number to a "valid" value. For this reason, you may find it easier at first
to use the mouse to set your life times.



Set Times by Using the Mouse

Related steps  More about

1. Move the pointer to one of the edges of the_LifeLine.

When the pointer touches either the left or right edge of the LifeLine, or the border between one color and another color, it
changes to the LifeLine cursor. You can drag this cursor left or right to change the Start, Hold, End, and/or Exit Time.

2. Click and drag the LifeLine cursor to set the time you want.

As you drag the LifeLine cursor, the color bar for that period of the object's life grows larger or smaller, depending on which way
you drag. At the same time, the number in the matching edit field changes. Dragging to the left decreases the number of
seconds. Dragging to the right increases the number of seconds.

3. When you finish setting the object's Life properties:
# Click another tab to set a different type of property, or

# Click OK to close the Properties dialog box.



Set Times by Using the Timeline Editor

Related steps  More about

1. Select Timeline Editor from the View Menu.

The three-colored bar that appears beneath each object name is used to control its Start, Hold, End, and Exit Times. This bar is
called the LifeLine.

Note If you click your cursor outside the Timeline Editor, or move your cursor over another object or palette, the Timeline Editor
will lose focus and may disappear. It will really be covered up by the Designer Window, which is set to always be on top of
other windows. To bring it back, choose Timeline Editor from the Window menu.

2. Click on either the Decrease Time Scale or Increase Time Scale buttons until you can easily view and edit the lifespan of the
objects you wish to change.

Each time you click on either button, you move up or down through six time scale settings.

You may also minimize and maximize the Timeline Editor window as desired by using your mouse to stretch or shrink the
outside edge of the window, or clicking on the minimize and maximize buttons in the upper right corner.

3. Move your mouse pointer to one of the edges of the LifeLine you want to change. Your cursor will change to the LifeLine
cursor.

4. Click and drag the cursor left or right to change the Start, Hold, End, and/or Exit Time. Dragging to the left decreases the time;
dragging to the right increases it. You can see the time that you are changing in the Status Bar at the bottom of the Designer
Window.

Note As soon as you drag your cursor to change the LifeLine, you have altered your settings for that object. You do not have to
close the Timeline Editor to save these changes.

5. Change the Start, Hold, End, and/or Exit Times for as many objects as you would like.
When you are finished, close the Timeline Editor by double-clicking in the upper left corner of the window.

7. To edit other properties of an object from the Timeline Editor, right click on the name of the object or anywhere on its LifeLine to
open the object’s Properties dialog box.




Setup Wizard

The Setup Wizard walks you right through the steps for creating your distribution disks. The Setup Wizard is based on InstallShield
Corporation's popular InstallShield installation software. The installation you build with the Setup Wizard creates a new program
group on your viewer's desktop, with an icon your viewer can double-click to run your demo. You have several options when building
your installation. For example, you can display a splash screen, or choose to have your demo launch automatically when your
viewer has finished installing the demo.



Shortcut Keys

These are keys both you and your viewers can use to navigate through the demo. For example, the Stop Demo key is the Escape
key by default (in Windows 3.1). You may need to use it to halt your demo in the Player.

Action Description

Pause/Continue Pause the demo while it is running. Continue playing a demo
you have paused.

Stop Stop playing the demo.

Next Scene Jump to the next Jump Marked object in the scene and reset
the scene clock to the object’s Start Time.

Previous Scene Switch to the previous scene.

Next Jump Mark Jump to the next Jump Marked object in the scene and reset
the scene clock to the object’s Start Time.

Previous Jump Mark Jump to the next Jump Marked object in the scene and reset
the scene clock to the object’s Start Time.

Steps
2 To set a demo shortcut key



Shortcut Menus

Uncheck this box in the Enable tab of the Preferences dialog to disable the shortcut menus that pop up when you right-click on an
object (or an empty spot in a scene). When you click on an object or scene when Shortcut Menus are deselected, the (object or
scene) Properties dialog box opens.

When Shortcut Menus are deselected, you will also turn off the menu of tab selections that pops up when you right-click within a
Properties dialog box.



Special Characters table

These are special characters to enter for the Send Keys action.
Use the code to the right of the key you want to send.

Key
Backspace
Break
Caps Lock

Clear
Del

End
Enter
Esc

Help

Home

Code
{backspace}

or {bs} or {bksp}
{break}
{capslock}
{clear}

{delete} or
{del}

{down}
{end}
{enter} or~

{escape} or
{esc}

{help}

{home}

Key

Insert

-

Num Lock
Page Down
Page Up

Print Screen

-
Scroll Lock
Tab

1

F1

F2
F3

F4

Code

{insert}

{left}
{numlock}

{pgdn}
{pgup}

{prtsc}

{right}
{scrollock}
{tab}

{up}
{f1}
{f2}

{f3}

{f4}

Key
F5

F6
F7
F8
F9

F10

F11
F12
F13

F14
F15

F16

Code
{f5}
{f6}
{7}

{fe}
{fo}

{f10}

{11}
{12}
{f13}

{f14}
{f15}

{16}

To enter a key combination that includes Shift, Ctrl, and Alt, precede the regular key code with one or more of these codes:

Key
Shift
Ctrl
Alt

Code

+

N

%



Sort Stack by Layer

Objects appear in the list in their stack order. The object at the top of the Objects List appears onscreen farthest away from the
viewer. The object at the bottom of the Objects List appears closest to the viewer. DemoShield places objects in the stack order in
the sequence you create them. As you design the layout of your demo screen, however, you may need to change the stack order to
move, resize, and/or edit objects in the Designer Window.



Start Period

The period from the moment the object starts moving into the scene until the moment it stops.
This is equal to the object's Hold Time minus its Start Time. Displays in blue.



Start Time

The period during which the object makes its entrance. Start Time lasts from when the object first appears until it reaches its final
position on the screen.



Starting a CompuServe account
You can use the following information to start a CompuServe account. You will need a modem to access CompuServe. For
additional information about CompuServe, write to this address:

CompuServe Inc.
P.O. Box 20212
Columbus, OH 43220

When you are connected to CompuServe, prompts will ask you for information needed to start an account. Once you have an active
account, you can access the DemoShield Forum and send e-mail to our technical support staff.

You can also start an account by calling CompuServe Customer Service (from within the United States) at:
1-800-848-8199



Startup Dialog

Uncheck this box in the Enable tab to turn off the "Welcome to DemoShield" dialog



The DemoShield Player

To launch the Player from the Help menu within the Designer
3 To launch the Player in Windows 3.1
3 To launch the Player in Windows 95/NT




Creating Actions and Events
An action is anything you make your demo do automatically on its own, or when your viewer presses a key or clicks the mouse.

For example, you can make your demo play the next scene automatically after 10 seconds, or when your viewer clicks a button that
says Next.

To make actions happen automatically, create an Event Object. To make actions happen when your viewer presses a key or clicks
the mouse, create an interactive object, such as a button.

for Interactive Objects
» To build an action triggered by your viewer

3 To choose a mouse event

] To choose a shortcut key event

3 To set more than one action for the same event

] To reorder actions linked to one event

[ To edit an action you have already set

3 To remove an action

» To build an action in one scene that happens in a different scene
3 To see all the events and actions you've built

] To create action for a group

for Event Objects

2 To make an action happen automatically

3 To build an action that happens always
To create a timed action

(3
] To create a comparison

3 To edit an action you have already set
b

3

To remove an action

To build an action in one scene that happens in a different scene
] To create action for a group




Creating and Opening Demos
A demo is any kind of presentation you can create with DemoShield. A software demo is a demo that teaches, advertises or sells a
software application.
To start a DemoShield session
To create a new demo
To open an existing demo file
To check your native demo resolution
To create a windowed demo
To set shortcut keys for a demo
To create a demo template
To save changes to a template file
To load a new template file
To save a demo
To end a DemoShield session
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Adding Objects to a Scene
What is an object?

] How do you modify objects?

» To create a Rectangle or Rounded Rectangle Object
] To create a Polygon Object

[ To create an Ellipse (circle) Object

3 To create a Line Object

] To create a Poly-Line Object

3 To create a Text Object

] To create an Event Object

[ To create a Bitmap Button Object
3 To create a Radio Button, Check Box, or Push Button Object
] To create a Hot Spot Object

3 To create a VCR Button Object
] To create a PopUp Menu Object
3 To create an Application Object
3 To create an AVI Object

[ To create a Group Object

3 To create a Variable Object

] To create an Edit Field Object



Creating Scenes

What is a Scene?

To create a scene

To display the Scene Editor

To open the Scene Properties dialog box
_______To change a scene's default name

To change the length of the scene

To choose a scene transition

To choose a fill style

To choose a background color

To choose a fill color

To create a scene template

[ To change the properties of the scene template
3 To change from the current scene to a different scene

] To display the Scene Sorter
3 To set the null scene color

e e i
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The Designer: A Visual Tour
The Designer Window
] Designer Tools and Palettes
3 The Designer Toolbar
3 The Designer Status Bar
] Using the Mouse and the Keyboard




Distributing a Demo
Use DemoShield's Setup Wizard program to create distribution disks for your demo. Before you distribute your demo, you may wish
to check for unused resources.

b To check for unused resources in your demo

4 To create distribution disk(s) for your demo

[ To add video support files to your installation

3 To add an uninstall program and a splash screen to your installation
[ To launch your demo automatically after installation

3 To create a title, default directory and Program Group (Folder) Name

3 To select the files you will distribute to your viewer
3 To choose an icon and name for each demo
3 To choose a different disk size

] To enter the directory where you will build your disks
3 To see a file summary before you build your disks
3 To build your distribution disk(s)

3 To copy your disks now

] To copy your disks later

] To install a demo

3 To play a demo you have installed

] To launch demos from other applications



Go To Scene

To choose Go to Scene

To choose Go to Next Scene

To choose Go to Previous Scene

To Return From Scene after two Go To Sub-Scene Actions

To choose Go to Object in Scene
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Giving Life to Objects

What is Life?
2 To move an object Into a scene
3 To move an object out of a scene
] To create an effect for an object

[ To set an object's Start, Hold, End and EXxit settings
3 To edit an object's properties outside its time period
] To resize an object outside its life



Managing Resources
What are Resources?
4 To open the Manage Demo Resources dialog box and look at any file

3 To delete a resource listed on the Manage Demo Resources dialog box
] To preview a resource

[ To import a resource
3 To import a resource by reference
] To export a resource

3 To import resources and/or scenes from a different demo
] To check for unused resources in your demo




Modifying Objects
To select an object
To delete an object
To copy objects
To paste objects
To edit an object's properties (how it looks, what it does, etc.)

To edit an object's properties outside its time period
To pick up (copy) styles from an object

To appl aste) styles to an object

4 To position or reposition an object
[ To change the name or group name of an object

3 To display an image in an object
To resize an object

To stretch or shrink every side of an object one grid unit
To stretch or shrink one side of an object using sizing handles (The Mouse)
To stretch or shrink one side of an object using the sizing keys

To bring the selected object forward or send the object back
To align two or more objects

To view invisible objects in the Designer Window

T w
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Adding Video and Sound
To record video
2 To play video
» To import a video file

3 To play a video file when the viewer clicks a button or presses keys

[ To play an AVI file without any viewer interaction
3 To play a WAV (sound) file




Creating Popup Menus
2 To create a button your viewer can click to display a menu

] To create a PopUp Menu

3 To create or change a caption on a Menu Button

P Tobuild the action for a Menu Button
[ To create menu titles




Selecting, Resizing, and Moving Objects
To select an object

] To deselect an object in the Designer Window
3 To select two or more objects using keys
] To select two or more objects with the mouse

[ To select two or more objects using the Scene Editor
3 To position or reposition an object

] To resize an object
2 To stretch or shrink every side of an object one grid unit
3 To stretch or shrink one side of an object using sizing handles (The Mouse)

] To stretch or shrink one side of an object using the sizing keys



Steps for Setting Demo Properties
To set demo control shortcut keys

2 To set DemosShield's global variables

» To choose windowed playback style
4 To set the size and location of your demo window




Setting Preferences
Preferences are settings you make to customize DemoShield to suit the way you work.
To open the Preferences dialog box.
To turn Shortcut Menus on or off
To enable or disable the startup dialog
To turn Tooltips on or off
To turn Demo Auto Save on or off
To turn Large Image Preview on or off
To enable or disable Scrollable Design Window
To enable or disable Automatic Last Demo Launch
To enable or disable Check Resources
To set the Null Scene Color
To choose the Start/Stop Recording Macro Key

To set the Step and Jump buttons

e e i
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3 To set the Auto-Save time

[ To set the distance an object will move when you press an arrow key
3 To set the screen capture keys

] To launch demos in the Player from the Help Menu




Setting Properties
To open the Properties dialog box

3 To set or change any type of property for an object
3 To change the name or group name of an object

] To set initial states




Software Demos

2 To create a software (simulation) demo using bitmap overlays
3 To create screen captures using DemoShield
3 To create a software (simulation) demo using video files

3 To create a software (live application) demo using macros
[ To run a live application in a scene

3 To play a macro in your live application demo




Technical Support
Technical Support Policy
] Contacting Us




Testing a Demo

You can test-run a demo in the Designer Window by using the Controller or the Control menu. Or, you can test-run your demo using
the DemoShield Player. You can launch demos in the Player by choosing their names from the Help menu.

3 To reset the clock

(3 To step or jump through a demo

k To test run a demo in the Designer
g
g

To test-run a demo in the Player

Why did my objects move out of alignment?
3 Will my colors look OK on all systems?




Creating Text Objects
To type the text for a Text Object
To align text
To resize a Text Object
To create a margin
To choose the fill style
To choose a font
To choose the border style
To choose a background color, font color, or border color

e R R
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3 To display an RTF file in your demo
[ To see and manage RTF resources
3 To import an RTF file




Using the Aligning Tools
To bring the Aligning Tools onscreen
] To align two or more objects

3 To find object(s) that disappear when you align




Using Tools and Palettes

To bring a tool or palette onscreen

To optimize the arrangement of tools and palettes
To remove a tool or palette from the screen

To minimize an open tool or palette

To move an open or minimized tool or palette

e e i




Using the Scene Editor

To switch scenes
3 To bring the selected object forward or send the object back
3 To open a selected object's Properties dialog box

] To delete an object




Creating VCR Buttons

To create VCR Buttons

To change any setting for a VCR Button

To change the action for a VCR Button

To enable or disable a VCR Button
_______To change a button caption

3 To change both Pause and Continue captions

[ To change from two Pause/Continue captions to a single caption
3 To display symbols instead of words on VCR Buttons

e e i



Creating and Playing Macros

Just as you can record your voice on, and play back, a tape cassette, you can record and play back your mouse moves and

keystrokes with a macro.

To record a macro

To play a macro you've recorded

To save a macro

To record a macro in all three resolutions
To view your macro resources

To play a macro in your demo: basic steps

To create a button that will play a macro

To play a macro with no viewer input

To play a macro at a specific time with no viewer input

e i
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Stop Button

Stops the demo.



Stop Capture

Use the Stop capture key to end capture mode and return to edit mode in the Designer Window. You could also return to the
Designer by pressing Alt+Tab, or simply maximizing the Designer Window.



Displaying Symbol Fonts

You can display symbol fonts (bullets, trademark symbols, etc.) in DemoShield by entering the key combos listed in the Character
Map accessory in Windows.
] To display symbol fonts:
1. Windows 3.1 users: Click on the Accessories icon in Program Manager to access Character Map.
Windows 95/NT users: Choose Character Map from the Programs: Accessories menu.

Note: Character Map is not installed by default in Windows 95/NT, so you may have to install it.
2. Double-click on Character Map to open its dialog box.
Click on the symbol you wish to display. Make sure you select from a font likely to be on your viewer’s system.
The key combo you need to enter appears in the status bar on the bottom right.

4. Create a Text Object and open its Object Styles dialog box. Enter your text as usual. Where you would like the symbol to
appear, type the appropriate key combo. If the combo is Alt+ (a number), you need to hold the Alt key down while typing in the
number using the keypad.

5.  When you are done entering your text, click OK to close the Properties dialog box.
The symbol appears where you placed it in the text.



.TPL

The filename extension of a template file that tells DemoShield how every object and scene should look when you first create it.



Tab and Shift+Tab

Selects the next or previous object in the scene in the order you created them. Tab selects the next object; Shift+Tab selects the
previous object.



Tabbed dialog boxes

The Properties dialog boxes in DemoShield 4.0 feature a new tabbed appearance. Simply click on the tab at the top of the dialog
box that corresponds to the type of property you want to view. Left (< )and right (>) buttons will appear in the upper right corner
when there are more tabs to choose from.

] Click the < and > buttons to scroll up and down through the tabs, or

3 Right-click in any "inactive" area of the dialog to bring up a shortcut menu of all the tabs in the dialog. Then left-click on
the tab you want to see.



Technical information we will need

To pinpoint your problem, we will need the following information when you contact us for technical support:

Your full name

Your address

Your company name

Your phone number and the best time to reach you
The version of DemoShield you are using

Your operating system

Click here to read about

Describing a Problem

Stirling Reports
MSD.EXE
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Technical Support

Choose this item from the Help menu for information on obtaining technical support, included contact numbers to reach DemoShield
Technical Support via phone, fax, CompuServe, the Internet, and bulletin boards.



Technical support policy

We maintain an extensive database of registered users. Each time you use technical support, the precise nature of your problem is
entered into our technical support database, so every user can share the solution. For this reason, technical support and problem
resolution are available only to registered users.

Click here to read about

Regqistering

Asking Us Questions

Contacting Us




Object Template Properties, Size tab

1. Click on the Size tab to set the object's default size.
In the Width field, type in the object's new width (in pixels).
In the Height field, type in the object's new height (in pixels).

> wnN

Click OK to close the dialog box, or click on another tab to change other object template properties.



test mode

You will often want to test your demo as you create it, to see how it looks when it's playing. When you test-run your demo,
DemoShield goes into Test Mode. You can test-run a demo in the Designer Window or full screen. In Test Mode, the editing and

drawing controls are not active. When you stop test-running, you return to Edit Mode and you can use any of the Designer's other
controls.



The DemoShield Forum

You can also contact us on CompuServe at the DemoShield Forum by typing:

GO WINAPC

You will enter the Windows 3rd Party C+ Forum.

Click on Library Sections, and double-click on DemoShield to view DemoShield files for downloading.
Once you're connected, you can:

[ 4 Meet and discuss. Post questions and discuss issues in forum message sections.
3 Upload files. Exchange information and demos with other DemosShield users and developers, and DemoShield technical
support staff.

Download files. Connecting to the DemoShield Forum gives you access to our library from which you can download
maintenance releases, maintenance updates, problem information, sample demos, and other useful information.



Time Increments for Steps and Jumps
Use the Options tab to enter the increments you want for the step and jump times in the Demo Controller.

* Enter the number of seconds you want for each step in the edit field next to the word Small.
L B Enter the number of seconds for each jump in the edit field marked Large.



Timeline Editor

To open the Timeline Editor, choose its name from the View Menu Use the Timeline Editor to quickly change the life times of

several objects in a scene. Change an object's start, hold, end, and exit times by clicking and dragging on the LifeLine that appears
beside (or behind) its name.

To edit other object properties, right-click on the object's name or anywhere on its LifeLine to open its Properties dialog box.



To create a comparison

Related steps  More about  Actions Dictionary

1. Right-click the Event Object, left-click on Object Properties.

You can also click the name of the Event Object in the Objects List of the Scene Editor to select the object, then click the Edit
Properties button on the Scene Editor.

The Properties dialog box for the Event Object appears.
2. Click the Comparison tab.
The Comparison dialog box appears.

3. To make a comparison, you need to choose five items of data. Suppose you have two Graphic Objects in a scene and you
want to compare one of their properties.

This is the data you would enter in the five fields of the Comparison dialog box:

Object Property

Object Property

To say how you want to compare the objects, you open a combo box and choose an operator. The operator we are using here is
the equal sign. The equals sign tells the Comparison dialog box to see whether the objects are identical. You could just as easily
ask whether the objects are not equal, greater or lesser than, and so on for all the standard operators

Click What Can You Compare? for examples of other comparisons you can make.

After creating a comparison, you will need to tell DemoShield what action(s) you want the demo to perform when the comparison is
true and when it is false.

To build actions that will happen if a comparison is false
1. Clickthe False Actions tab to the left of the Properties dialog box.

The False Actions tab appears.
2. Alist appears with each of the actions you can select.
3. Select the action you want to happen if the comparison is false.

To build actions that will happen if a comparison is true
1. Click the True Actions tab to the left of the Properties dialog box.

The True Actions tab appears.
2. Alist appears with each of the actions you can select.
3. Select the action you want to happen if the comparison is true.




To log onto the BBS

Our BBS supports transmission rates up to 57,600 baud and a wide variety of protocols.
To access and log onto the BBS

1.

Dial the BBS number to connect to the BBS.

Use settings N-8-1 at baud rates up to 57,600.

Enter your full first and last name if you are logging in for the first time.

Do not use a company name. The BBS asks if you entered your name correctly.

Reply Yes.

Enter a unique password.

You're asked to register with your name, company name, address, phone, fax and other information.

Enter complete information.

This information is matched against our registration records. Users with incomplete information are removed from the BBS.



To open the Build Action dialog box

Related Steps

1.
2.

Click the True Actions tab.

Click the New Action button.

The Build Action dialog box appears.

Click to open the combo box at the top.

A list appears showing every action you can choose.
Select an action.

Click to open the Object combo box (if one appears).

A list appears showing every object in the current scene.
Select the object on which you want the action performed.
If you want to create another action, repeat steps 2 - 5.
Click OK to close the Build Action dialog box.

The True Actions dialog box reappears.



To add uninstall and a splash screen to your installation
(Step 1 of 1)

Related steps

1. Click the box next to Uninstall to add a special version of InstallShield Corporation's uninstallShield™ product to your viewer's
demo program group (or folder).
Your viewers can click on the uninstall icon to quickly and easily remove all demo files from their systems.

2. Click the Splash Screen Bitmap button to browse for a bitmap file. This file will display briefly before your installation starts.
When you are finished making your selections, click Next.



To add video support files to your installation
(Step 1 of 1)

Related steps  More about

1. Click the check box next to AVI Support Files if you are playing an AVI file in your Windows 3.1 demo.
Note: Windows 95 and Windows NT ship with the necessary AVI support files.
The AVI support files are automatically copied.
2. Click the check box next to Lotus ScreenCam Player if you are playing an SCM file in your demo.
A browse box appears.
Select your SCPLAYER.EXE file.



To align text

Related steps More about

Click on the Object Styles tab.

Click on the Options button.

The Text Options dialog box opens.

In the group marked User-Defined text, you will see three alignment buttons.
&  Click on the button on the left to left align your text.

] Click on the middle button to center align your text.

] Click on the button on the right to right align your text.
4. Click OK to close the Text Options dialog box.



To align two or more objects

Related steps  More about

1. Point somewhere near, but outside, the objects you want to align.

2. Click and hold down the left mouse button.

3. Drag away from the point where you clicked.
A dotted rectangle appears. As you drag, the dotted rectangle enlarges like a rubber band.

4. Release the left mouse button when the dotted rectangle is large enough to lasso all the objects you want to align.
Square braces appear around the objects you're aligning .

5.  Click one of the Aligning Tools buttons.
The objects align automatically.

Steps for Missing Objects

b To find object(s) that disappear when you align



To apply styles to an object

Related Steps * More about
1. Click to select the object you are applying styles to.
Handles surround the object. The Apply Styles toolbar button appears enabled.
2. Choose Apply Styles from the Edit Menu.
The styles of the source and destination objects are now identical and so is their appearance in the Designer Window.



To bring a palette onscreen

Related steps
1. Choose View from the menu bar.
The View Menu appears listing DemoShield's tools and palettes.
2. Click the palette you want to display.
When a palette is open, a small check mark appears next to the palette on the View Menu.



To bring the aligning tools onscreen

Related steps  More about

From the Menu Bar

2 Choose Aligning Tools from the View Menu.
From the Toolbar

Click the Aligning Tools button on the toolbar.



To bring the selected object forward or send the object back

Related steps  More about

Using the Scene Editor
1. Click the Sort Stack by Layer button on the Scene Editor.

Triangular red buttons appear to the right of the Scene Editor. Only when you click to sort the stack by layer do these red
buttons appear.

2. Click the name of the object that you want to bring or send in the Objects List of the Scene Editor.

The object name appears highlighted in the Objects List. The type of object you selected appears in parentheses at the top of
the Objects List, to the right of the word Objects.

3. To bring the object one layer closer, click the red button pointing down.
To send a selected object one layer back, click the red button pointing up.
The object you are bringing moves down on the Objects List.

Example



To build actions that happen every time your demo plays

Related steps  More aboutt  Action Dictionary

1. Create the Event Object.
2.  Click the True Actions tab.

The True Actions dialog box appears. The True Actions dialog box looks and works like the Actions dialog box for an interactive
object.
3. Click the New Action button.

The Build Action dialog box appears.



To build an action in one scene that happens in a different scene

Related steps  More About  Action Dictionary

For certain actions--including Go to Object in Scene, Hide, Show, Enable, Disable, Set Variable and Set Contents--you may choose
to build the action so that it affects an object in a different scene. If you choose one of these actions, an Object combo box and a
Scene combo box will appear.

1. Open the Scene combo box.
A list appears showing every scene in your demo.
2. Choose a different scene.
3.  Open the Object combo box.
The objects in the scene you chose appear in the Object combo box.
4. Choose an object.
Fill in any other information necessary to complete the action.
6. Click OK to close the Build Action dialog box.

o



To build an action your demo will perform

Related steps  More about  Action Dictionary

1.

Right-click on an interactive object in the Designer Window. Left-click on Object Properties or press Enter.
Or double-click the object's name in the Objects List of the Scene Editor.

The object's Properties dialog box opens.

Click on the Actions tab.

Choose an event that will trigger the action(s) from the combo box under "When the viewer does this."
(See_To set a mouse event or To choose a shortcut key event for the steps.)

Click the New Action button.

The Build Action dialog box opens, and whatever mouse or key event you selected appears in brackets within the message
"When the viewer [Left Clicks Mouse] perform the action”.

Click to open the combo box next to the message "perform the action”.
A list appears showing every action you can choose.
Point to an action on the list and click.

If you need to enter more information for the action you chose, additional combo boxes will appear in the Build Action dialog
box.



To build the action for a menu button

Related steps
Click to select a button on the Menu Buttons list.
Click the Edit Action button.
The Build Action dialog box opens.
3. Click to open the combo box.
A list appears showing all the actions you can choose.
4. Choose an action. For example, Go to Scene.
When you choose the action Go to Scene, a new combo box appears so you can choose which scene to switch to.
5. Click the name of the scene you want.
6. Click OK when you are done.
You return to the Object Styles Properties dialog box.
7. Repeat these steps to build an action for each button on the menu.



To build your distribution disk(s)
(Step 6 of 7)

Related steps  More about

3 Click the Build button when you are ready to build your distribution disk(s).

The DemoShield Setup Wizard compresses your files and creates the image for each distribution disk. This may take several
minutes, depending on the size of your files.

When the build is completed, you will be in the Copy Now or Later dialog box.



To capture your application screens as images

Related steps

1.
2.

Launch your application.
Press Alt+Tab to switch to Program Manager or your Windows 95/NT desktop.

Note: Windows 95/NT users can also click on their taskbar buttons to switch between applications.

3.

4.
5.
6

10.
11.

12.

13.

14.

Launch DemoShield.

Choose Preferences from the File menu.

Click on the Capture tab.

Select the appropriate function key which will initiate the type of capture you want to make.

Check "Capture Pointer Image" if you want the cursor to appear in the capture.

Click OK to close the Preferences dialog box.

Choose Capture Images from the Demo Menu.

Press Alt+Tab to switch to your application. Set up your window or screen the way you want it to appear.
Press the function key for the type of capture you are creating.

The capture is made immediately.

You will hear a beep when it's done.

If it is the first capture you've made for the demo, it will have the filename Image01. The second will be Image02 and so on.

When you are ready to capture another image, press the appropriate function key to initiate the type of capture you want to
make.

When you finish capturing images, press the Stop Capture key (F6 by default) or Alt+Tab to return to Edit mode in the Designer
Window.

To preview your images, open the Manage Demo Resources dialog box for Images or import the image into a Scene, Graphic
Object, or Bitmap Button.

Double-click on the image name to see it in the preview window.



To change a VCR button caption

Related steps

Click in the VCR Button text field, delete the current caption, and type a new one.
Click to select the Previous Scene button.

Click to insert the text cursor in the Button Caption field.

Using the same steps, change the caption to Back.

Type Back

Click OK to close the Properties dialog box, Object Styles tab.

I o o

You can enable and use as many VCR Buttons or as few as you need using these steps. To use a VCR Button while your demo is

playing, the user simply points and clicks.



To change a scene's default name

Related steps  More about

1. Click in the edit field next to Scene Name.
The text cursor appears.

2. Type a unique name for the scene.
You may use up to 24 characters.

Names are not case-sensitive: you cannot hame two scenes Intro and intro. You can't use a name ending in a numeral: i.e.
Scene 1, Part 4.



To change any setting for a VCR Button

Related steps

1. Right-click the VCR object in the Designer Window.
Left-click on Object Properties.

2. The VCR Object Properties dialog box appears.
Click the words Object Styles.
The Object Styles tab appears.

4. Click on Related steps above for steps to set the button captions and actions, and to choose how the buttons will appear on the
screen (text or symbols).




To change both Pause and Continue captions

Related steps

Click to insert the text cursor in the Button Caption field.

Delete the current caption and type two captions instead of one, separating them with a slash.

If you want to change the Pause/Continue caption so it toggles back and forth, separate your new captions with a slash mark.
For example, if you decide to make the captions Stop and Go, type Stop/Go

Your new captions will change back and forth as the demo switches, just as they would if the captions were Pause and
Continue.



To change from the current scene to a different scene

Related steps
1. Click to open the Control Menu.
2. Click Go to Scene.
A window appears listing every scene in the current demo.
3. Click the scene you want to make the current scene.
The new scene appears for editing.

The quickest way to bring the next or previous scene onscreen for editing is by using the buttons on the Demo Controller. Click the
green button pointing right to go to the next scene, the left button for the previous scene.

You can also switch scenes by selecting the name of the scene you want to switch to from the Scene List of the Scene Editor.




To change from two Pause/Continue captions to a single caption

Related steps

Click to insert the text cursor in the Button Caption field.
Delete the current caption and type one caption only instead of two.



To change the action for a VCR Button

Related steps
1. Click to select the button on the VCR Buttons list.
The button appears highlighted.
2. Click the Edit Action button.
The Build Action dialog box appears.
3. Choose a new action for the selected VCR Button from this Build Action list.
4. Click to open the combo box next to the message Perform the action.
Alist appears showing every action you can choose
5. Click an action on the list.



To change the length of the scene

Related steps  More about

1. Click to insert the text cursor in the edit field next to Scene Length.
2. Type the number of seconds you want the scene to last.
The longest you can make the Scene Length is 99,999 seconds.



To change the name or group name of an object

Related steps

1.
2.

Click the object's name in the Objects List of the Scene Editor.

Press Enter.

The Properties dialog box opens.

If a dialog box other than General Properties opens, click the General tab.

Click to insert the text cursor in the field next to Name.

Type a name.

To create or change an object's Group Name, use the same steps to type a new name

in the Group Name field.



To change the properties of the scene template

Related steps  More about

1. Choose Template Properties from the Scene menu.
The Scene Template Properties dialog box appears.

2. Set new properties for the object using the steps explained in Setting Scene Properties.
Click OK.



To change the template properties for an object

Related steps More about

1. Right-click the button on the Object Palette for the type of object whose template properties you want to change.
The object's Template Properties dialog box appears. Notice there are no settings for Actions or Life.
2. Setthe new template properties.

Set the template properties the same way you would set regular object properties, with the exception of object size. The Size
tab allows you to set the default size of any object in pixels.

3. Click OK.




To check for unused resources in your demo

#* Related Steps
1. Choose Preferences from the File menu to open the Preferences dialog box.

2. Click the Enable tab.

3. Select the check box marked "Check Resources."
The next time you save the demo, DemoShield will notify you if there are any unused resources in your demo.
You will be asked if you want to save or delete these resources.

Note: DemoShield cannot determine if your macro or file (.EXE, etc.) resources are being used in the demo. You will have to
check for those resources manually.



To check your native demo resolution in DemoShield

Related steps
1. Choose About from the Help menu.
2. Click the Demo Info button.

When your demo plays on a screen with a resolution different from the native resolution you used to create the demo,
DemoShield scales your demo so the graphic and text objects display proportionally on your viewer's screen.

In some cases, you may not want your objects to scale. For example, you may be layering text and arrows on top of graphic
objects. See Why did my objects move out of alignment?



To choose Bring One Layer Closer

Related steps  More about

Use Bring One Layer Closer to move an object from its current position in the stack one layer closer to the front of the stack.
1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Bring One Layer Closer.
Two combo boxes appear.
3. Open the combo box next to the word Object.
Alist appears showing every object in the scene.
4. Choose the object you wan to bring one layer closer.
5.  Open the combo box next to the words In Scene.
A list appears showing every scene in the demo.
. Choose the scene that contains the object to bring.
7. Click OK to close the Build Action dialog box.




To choose Bring to Front

Related steps  More about

Use Bring to Front to move an object from its current position to the front of the stack.
1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Bring to Front.
Two combo boxes appear.
3. Open the combo box next to the word Object.
Alist appears showing every object in the scene.
4. Choose the object you want to bring to the front.
5.  Open the combo box next to the words In Scene.
A list appears showing every scene in the demo.
. Choose the scene that contains the object to bring.
7. Click OK to close the Build Action dialog box.




To choose Delay Demo

Related steps  #More about

Use Delay Demo to enter the number of seconds you want the demo to delay before continuing.
1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Delay Demo.
An edit field appears with the words Length in Seconds.
3. Type the number of seconds you want the demo to delay before continuing.
4. Click OK to close the Build Action dialog box.




To choose Disable

Related steps  More about

Use Disable to make an enabled object inactive. When you disable an object you break the link between the object's events and the
action(s) you have linked to those events. A disabled button may look like a button onscreen, for example, but it is useless. The
Enable action works the opposite of the Disable action.

1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.

2. Scroll to and click Disable.
Two combo boxes appear.

3. Click to open the combo box next to the word Object.
A list appears showing every object in the demo.

4. Choose the object you want to disable.

5. Click to open the combo box next to the words In Scene.
Alist appears showing every scene in the demo.

. Choose the scene that contains the object you want to disable.
7. Click OK to close the Build Action dialog box.




To choose Display Menu

Related steps
Use Display Menu to make a PopUp Menu appear.

1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Display Menu.
. Inthe Menu: box, choose the menu to be displayed.
4. Click OK to close the Build Action dialog box.




To choose Enable

Related steps  More about

1.

Click to open the combo box next to perform the action.
Alist appears showing every action you can choose.
Scroll to and click Enable.

Two combo boxes appear.

Click to open the combo box next to the word Object.

A list appears showing every object in the scene.
Choose the object you want to enable.

Click to open the combo box next to the words In Scene.
A list appears showing every scene in the demo.
Choose the scene that contains the object you want to enable.
Click OK to close the Build Action dialog box.




To choose Get Property
Related steps  More about

Use Get Property to choose an object and make one of its properties the property of the current interactive object.
1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Get Property.
Three combo boxes appear.
3. Click to open the combo box next to Property.
Alist appears showing the properties you can choose.
4. Choose one of the properties listed.
For help, click the words "More about" at the top of this page.
5.  Click to open the combo box From Object.
A list appears showing every object in your demo.
Choose the object you want to get the property from.
7. Click to open the combo box In Scene.
A list appears showing every scene in the demo.
. Choose the scene that contains the object you want to get the property from.
9. Click OK to close the Build Action dialog box.




To choose Go to Next Jump Mark

Related steps  More about

Use Go to Next Jump to jump to, and reset the demo clock to the Start Time of, the next marked object after the current playing
time.

1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.

2. Scroll to and click Go to Next Jump Mark.
Click OK to close the Build Action dialog box.




To choose Go to Next Scene

Related steps

Use Go to Next Scene to switch to the next scene.

1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.

2. Scroll to and click Go to Next Scene.

3. Click OK to close the Build Action dialog box.




To choose Go to Object in Scene

Related steps

Use Go to Object in Scene to switch to another scene and reset the demo clock to the Start Time of an object in the scene that you
select. When the demo performs this action it starts playing the new scene not at the beginning but from the Start Time of the object
you selected.

1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Go to Object in Scene.
Two combo boxes appear so you can choose the Object whose Start Time you want, and the Scene to go to.
3. Click to open the Object combo box.
A list appears showing every object in the scene.
4. Click to choose the object you want.
A list appears showing every scene in the current demo.
5. Click to choose the scene you want to go to.
6. Click OK to close the Build Action dialog box.




To choose Go to Previous Jump Mark

Related steps  More about

Use Go to Previous Jump Mark to jump to, and reset the demo clock to the Start Time of, the previous marked object before the
current time.

1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.

2. Scroll to and click Go to Previous Jump Mark.
Click OK to close the Build Action dialog box.




To choose Go to Previous Scene

Related steps

Use Go to Previous Scene to switch to the previous scene.

1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.

2. Scroll to and click Go to Previous Scene.

3. Click OK to close the Build Action dialog box.




To choose Go to Scene

Related steps  More about

Use Go to Scene to switch the demo to another scene.
A second combo box appears with the word Scene next to it.:
1. Click to open the Scene combo box.

A list appears showing every scene in the current demo.
2. Click to choose the scene you want to go to.

Click OK to close the Build Action dialog box.




To choose Go to Subscene

Related steps  More about

Use Go to Subscene to stop in the middle of the scene that is playing and go to a special sub-scene (or scenes) you have created.
This action is essentially the same as the Go to Scene action. The only difference is that using Go to Sub-Scene allows you to
switch to a different scene or sequence of scenes, and then return to the point where you left off and continue the demo as if the
sub-scenes had never happened.

You may also choose to build additional sequences of sub-scenes. Click About Stacking Go to Sub-Scene Actions for more
information.

When you choose Go to Subscene:
A second combo box appears with the word Scene next to it.:
1. Click to open the Scene combo box.
A list appears showing every scene in the current demo.
2. Click to choose the scene you want to go to (the first scene in your series of sub-scenes).
3. Click OK to close the Build Action dialog box.




To choose Hide

Related steps  About

Use Hide to make a visible object invisible. When you hide an object, the viewer cannot see it. The Hide action works the opposite
of the Show action.

1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Hide.
A combo box appears next to the word Object.
3. Click to open the Object combo box.
Alist appears showing every object in the scene.
4. Click to select the object you want to hide.
A combo box appears next to the words In Scene.
5. Click to open the Scene combo box.
A list appears showing every scene in the demo.
6. Choose a scene.
7. Click OK to close the Build Action dialog box.




To choose Highlight/De-Highlight

Related steps  More about

1.

Click to open the combo box next to perform the action.
Alist appears showing every action you can choose.
Scroll to and click Highlight/De-Highlight.

Two combo boxes appear.

Open the combo box next to the word Object.

A list appears showing every object in the scene.
Choose the object you wan to highlight or de-highlight.
Open the combo box next to the words In Scene.

A list appears showing every scene in the demo.
Choose the scene that contains the object to highlight or de-highlight.
Click OK to close the Build Action dialog box.




To choose Move Cursor

Related steps
The Move Cursor action moves the cursor from its current position on the screen to a position you specify. You select the time that it
takes to complete its movement from a combo box listing several different times.

3 When you choose Move Cursor:
A combo box and two edit fields appear.

1. Click in the Time to Complete combo box and choose the length of time you wish for it to take to complete its movement.
Use the X and Y edit fields to enter the X and Y coordinates for the final location of the cursor.
If you are unsure of the coordinates you want, place your cursor in the Designer Window approximately where you want the
mouse to stop, and look at the X and Y values shown in the Status Bar at the bottom of your screen.

Note If your cursor is moving to a screen coordinate outside of the visible Designer Window, you will be unable to preview the
action. Instead, you will see the following message: "A Move Cursor action occurred outside of the visible Designer Window.
To view this action, play the demo full screen or run the demo using the Player."



To choose Pause/Continue Demo

Related steps  More about

1.

Click to open the combo box next to perform the action.
Alist appears showing every action you can choose.
Scroll to and click Pause/Continue Demo.

Click OK to close the Build Action dialog box.




To choose Play Macro

Related steps  More about

Use Play Macro to play a macro that you have recorded and saved.
1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Play Macro.
A combo box appears showing the name of every macro you can choose.
3. Click to choose the macro you want.
4. Click OK to close the Build Action dialog box.

Play Macro will not work when you use the Controller to test-run a demo in the Designer Window. Instead, a message will tell you
when it's time for a macro to play, and tell you the name of the macro. To see how a macro will look to your viewer, run the demo
using the Player.




To choose Play Sound

Related steps  More about

Use Play Sound to play a WAVE sound file in your demo. WAVE files have the filename extension WAV.
1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Play Sound.
A combo box appears showing the name of every WAVE file you have imported using Manage Demo Resources.
3. Click to choose the WAVE file you want.
4. Click OK to close the Build Action dialog box.
Before you can play a WAVE file in your demo, you must first import the file using Manage Demo Resources.




To choose Play Video

Related steps  More about

Use Play Video to play a video sequence in your demo that you have saved as an AVI or SCM file.
1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Play Video.
A combo box appears showing the name of every AVI or SCM file you have imported into the demo.
3. Click to choose the video file you want.
4. Click OK to close the Build Action dialog box.

Play Video will not work when you use the Controller to test-run a demo in the Designer Window. Instead, a message will tell you
when it's time for the video file to play, and tell you the name of the video file. To see how the video will look to your viewer, run the
demo using the Player.

Before you can play an AVI or SCM file in your demo, you must first import the file using Manage Demo Resources.




To choose Return from Scene

Related steps  More about

Use Return to Scene to:
. Return to where you started in your regular demo before branching off to one or more sub-scenes, and
. Pick up where you left off, and play the rest of your demo.

You can choose Return from Scene either from the list of actions on the Build Action dialog box, or the list of Scene Transitions on
the Scene Properties dialog box.

If you have used two Go To Sub-Scene sequences, for example, one right after the other, and you want to end by using a Return
From Scene action, you must use two Return From Scene actions. The steps below explain how to set these actions.

To return from scene after two Go To Sub-Scene actions

1. Create an Event object in the scene you want to return from.
2. Right-click on the Event object, left-click on the words Object Properties.
The Event Properties dialog box opens.

Click the Time tab.

Enter the a just prior to the end of the scene.

Click the True Actions tab.

Click the New Action button.

The Build Action dialog box appears.

. Choose the action Return From Scene.

8. Click OK.

The Build Action dialog box closes and you return to the True Actions dialog box. Return From Scene appears in the list of
actions.

9. Click the New Action button on the Events Properties dialog box a second time and again choose Return From Scene.
10. Click OK to close the Build Action dialog box.
When the True Actions dialog box again appears, you will see two Return From Scene actions in the list of actions.

o0k~ w

When you start a sequence of sub-scenes with Go to Sub-Scene, it makes no difference how you end the sequence. You are not
required to close every Go to Sub-Scene with Return from Scene. If you want, you can choose Go to Scene, or Go to Next Scene,
for example, or any other Scene Transition.



To choose Send Keys

Related steps

Use Send Keys to send keys to the application you are currently running in a Live Application Demo.
1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Send Keys.
A text edit field appears next to the words Keys to Send.
3. Type the keys you want to send.

4.  Specify the application to receive the keys. If you specify an application, then the application window will receive the keys. If
you choose None the keys will be sent to whichever window has the focus. You cannot send keys to a child window.

5. Click OK to close the Build Action dialog box.

Send Keys will not work when you use the Controller to test-run a demo in the Designer Window. Instead of sending keys, you get a
message telling you that a Send Keys action occurred. If this action occurs when the Player is running your demo, it will send keys
to the application you specified.

Note When playing combinations of ‘Play Macro’ and ‘Send Keys’ actions, you will need to ensure that some events and actions
occur between the ‘Play Macro’ and the ‘Send Keys' actions to maintain DemoShield’s event processing.

Special Characters
Use the Special Characters table to see what to enter for shortcut keys, and keys that do not appear onscreen. For example, if you
wanted to send the Break key, you would type {break}.



To choose Send Message

Related steps  More about

Use Send Message to send a Windows message to a running application that you are using in a Live Application Demo. This is the
only reason to use the Send Message action. Unless you are an advanced Windows programmers, you do not even have to know
this exists. The Send Message action is the Windows API call:

SendMessage (hWnd, wMsg, wParam, lParam);
Two combo boxes and three edit fields appear.

1. Use the combo box "To Application" to choose the application.
If you choose "None," messages will be sent to whichever window has the focus.

2. Use the Scene combo box to choose the scene that contains the application you want to send the message to.
Click to insert the text cursor in the edit field for Message ID.

To find the Message ID, see the Windows Software Development Kit Windows.header file. The header file identifies each
message type with its ID Value.

4. Type the Message ID.

For the wParam and IParam Values you need to enter next, see the Microsoft Windows Software Development Kit
Programmer’s Reference.

5. Click to insert the text cursor in the edit field for "wParam Value," and type the wParam Value.
6. Click to insert the text cursor in the edit field for “IParam Value," and type the IParam Value.
7. Click OK to close the Build Action dialog box.

Note Send Message will not work when you use the Controller to test-run a demo in the Designer Window.

Note to Windows 95/NT users: If converting a Windows 3.1 demo into a Windows 95/NT demo, make sure you rebuild your Send
Message actions for the new operating system.



To choose Send One Layer Back

Related steps  More about

Use Send One Layer Back to move an object from its current position in the stack one layer farther back in the stack.
1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Send One Layer Back.
Two combo boxes appear.
3. Open the combo box next to the word Object.
Alist appears showing every object in the scene.
4. Choose the object you want to send one layer back.
5.  Open the combo box next to the words In Scene.
A list appears showing every scene in the demo.
. Choose the scene that contains the object to send.
7. Click OK to close the Build Action dialog box.




To choose Send Property

Related steps  More about

Use Send Property to send one of the properties of the current interactive object to another object.

1.

Click to open the combo box next to perform the action.

A list appears showing every action you can choose.

Scroll to and click Send Property.

Three combo boxes appear.

Click to open the combo box next to Property.

Alist appears showing the properties you can choose.

Choose one of the properties listed in About Send, Get, and Set Property.
Click to open the combo box To Object.

A list appears showing every object in your demo.

Choose the object you want to send the property to.

Click to open the combo box In Scene.

A list appears showing every scene in the demo.

Choose the scene that contains the object you will send the property to.
Click OK to close the Build Action dialog box.




To choose Send to Back

Related steps  More about

Use Send to Back to move an object in the stack from its current position to the back.
1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Send to Back.
Two combo boxes appear.
3. Open the combo box next to the word Object.
Alist appears showing every object in the scene.
4. Choose the object you want to send to the back.
5.  Open the combo box next to the words In Scene.
A list appears showing every scene in the demo.
. Choose the scene that contains the object to send.
7. Click OK to close the Build Action dialog box.




To choose Set Contents

Related steps  More about

1. Click to open the combo box next to perform the action.
Alist appears showing every action you can choose.
2. Scroll to and click Set Contents.
Two combo boxes and an edit field appear.
3. Click to open the combo box Of This Object.
A list appears showing every object in the scene.
4. Choose the object displaying the resource you want to change.
5. Click to open the Scene combo box.
A list appears showing every scene in the demo.
Choose the scene that contains the object.
7. Click to insert the text cursor in the edit field To This Resource.
Type the name of the resource to replace the current resource.
To see and manage the resources in your demo, use the Manage Demo Resources dialog box.
9. Click OK to close the Build Action dialog box.




To choose Set Property

Related steps More about

Use Set Property to set one of the properties of any object in your demo to any value you want.

1.

10.
11.
12.

13.

Click to open the combo box next to perform the action.

A list appears showing every action you can choose.

Scroll to and click Set Property.

Three combo boxes and an edit field appear.

Click to open the combo box next to Property.

Alist appears showing the properties you can choose.

Choose one of the properties listed in About Send, Get, and Set Property.
Click to open the combo box Of Object.

A list appears showing every object in your demo.

Choose the object whose property you want to set.

Click to open the combo box In Scene.

A list appears showing every scene in the demo.

Choose the scene that contains the object.

Click to open the combo box Property to Set.

A list appears showing the properties you can set.

Choose one of the properties listed in About Send, Get, and Set Property.
Click to insert the text cursor in the edit field To This Value.

Type a value.

For example, to set the Start-Time Property to 4 seconds, type: 4

Click OK to close the Build Action dialog box.




To choose Set Variable

Related steps  More about

Use Set Variable to set the value of a variable that you have created. You can increment, decrement, or assign a new value. You
can perform Set Variable actions on both scene-specific Variable Objects and on demo-wide Global Variables.

1.

10.

Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
Scroll to and click Set Variable.

Two combo boxes and an edit field appear.

Click to open the combo box For Variable.

A list appears showing every variable in the scene.
Click to select the variable whose value you want to set.
Click to open the Scene combo box.

A list appears showing every scene in the demo. If you chose a scene other than the current one, you could then return to the
For Variable box to choose a new variable. If you selected a Global Variable it doesn’t matter which scene you choose.

Choose a scene.
Click to open the Operator combo box.

Choose an operator.
If you choose Increment, the variable will increase by one each time the event is performed.
Decrement means the variable will decrease by one.

If you chose the Assign Value operator, click to insert the text cursor in the edit field marked To This Value.
Type the value you want to set. A numeric value must be from 0 to 999999.

Click OK to close the Build Action dialog box.




To choose Show

Related steps About

Use Show to make an (invisible) object visible. When you show an object, it appears onscreen. The Show action works the opposite
of the Hide action.

1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Show.
A combo box appears next to the word Object.
3. Click to open the Object combo box.
Alist appears showing every object in the scene.
4, Click to select the object you want to display.
A combo box appears next to the words In Scene.
5. Click to open the Scene combo box.
A list appears showing every scene in the demo.
6. Choose a scene.
7. Click OK to close the Build Action dialog box.




To choose Stop Demo
Related steps

Use Stop Demo to quit the demo. For example, if you choose the Stop Demo action for a button, when your viewer clicks the button
the demo will stop.
1. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
2. Scroll to and click Stop Demo.
3. Click OK to close the Build Action dialog box.

Note: When you are test-running the demo in the Designer, a message will appear indicating that a Stop Demo action has
occurred. The demo will then continue playing.



To choose Trigger Event

Related steps  More about

1.

Click to open the combo box next to perform the action.
Alist appears showing every action you can choose.
Scroll to and click Trigger Event.

Three combo boxes appear.

Click to open the combo box for Event to Set.

A list appears showing every event you can set.
Choose an event (click on More about for details).
Click to open the combo box for To Object.

A list appears showing every object in your demo.
Choose the object you want to send the event to.

Click to open the combo box next to the words In Scene.
Alist appears showing every scene in the demo.
Choose the scene that contains the object.

Click OK to close the Build Action dialog box.




To choose a scene transition

Related steps  More about

1. Click to open the combo box for Scene Transition.
A list appears showing all the Scene Transitions you can choose.
2.  Click to select one of the Scene Transitions.



To choose a border style

Related steps
1. Click the Border Styles tab.

The Border Styles dialog box appears.
2. Click the top left button for no border.

Click a different button for a visible border. You may choose from broken or unbroken lines, and a variety of line weights.
3. Click the check box next to Add Shadow to add a shadow.

Text Objects are the only objects you can create a shadow for. You cannot create a shadow around a Text Object with no
border.



To choose a color

The steps for choosing any type of color--background color, font color, border color, line color, fill color, etc.--are the same.

Related steps

1. Click the appropriate Color tab in the object or scene Properties dialog box.

The Color tab appears.
2.  Click one of the color squares.

A black border surrounds the square. The new color appears in the preview window, bottom right.
To choose a custom color using a slider

] Click a slider and drag left or right.
You can also move the slider by clicking the left or right arrow buttons on the slider bar.
The color you select appears in the preview window.

To type a color value

1. Click to insert the text cursor in one of the RGB edit fields.

2. Type a number from 0-255. The higher the number, the lighter the color.
The color you select appears in the preview window.



To choose a different disk size
(Step 5 of 7)

Related steps
1. Click to open the combo box for Diskette Size if your distribution disk(s) are another size.
2. Choose the size of the disk(s) you will distribute.

The Setup Wizard calculates the size of your files and determines how many disks you will need. The default size for distribution
disks is 1.44 megabytes.



To choose a fill style

Related steps  More about

1. Click the Fill Styles tab.
The Fill Styles dialog box appears.
2. Choose the fill style you want.
Text Objects can only have transparent or solid fills.
Edit Field Objects can only have solid, pattern, or wash fills.
Application Scenes always have a transparent fill; non-application scenes cannot have a transparent fill style.
Click Display an Image for the steps to choose an image fill for a Graphic Object, Bitmap Button, or scene.



To choose a font

Related steps  More about

1.

Click the Font tab.

The Font dialog box appears.

Click a font name.

The font name appears highlighted.

Click to open the combo box next to the Point Size.

A list appears showing every point size you can choose.

Click a point size from the drop-down list.

You can also click to insert the text cursor in the edit box and type a point size for the font.
Click Bold, Italic, and/or Underline, as appropriate.

An image of the font appears.

When you finish setting one type of property for an object, you can:

P Click another tab to set a different type of property for the same object

] Click OK to close the Properties dialog box



To choose a line style
1. Click the Line Styles tab.

The Line Styles Properties dialog box opens.
2. Click on the line you want to see.

You may choose an invisible line (top left), double line, or several varieties of thin and thick, broken and unbroken lines.
3. When you finish setting one type of property for an object, you can:

P Click another tab to set a different type of property for the same object.

] Click OK to close the Properties dialog box.



To choose a mouse event

Related steps  More about

1.
2.

Open the Actions dialog box.

Click to open the combo box under the message When the viewer does this.
A window opens listing all the events you can choose.

Click an event involving the mouse, such as Left-Clicks Mouse.




To choose a shortcut key or keys (as events)

Related steps

1.
2.

Open the Actions dialog box.

Click to open the combo box under the message When the viewer does this.

A window opens listing all the events you can choose.

Click the event Key (Choose)

The Choose A Shortcut Key dialog box appears, asking you to press a key or a combination of keys.
Press whatever key, or key combination you want your viewer to press for the shortcut.

The shortcut key(s) you press appear in the dialog box.

Click OK.

DemosShield adds the shortcut keys you create to the list of events.

Now you can create an action tied to the event.



To choose an AVl resource

1. Click to open the combo box next to AVI Resource.
A list appears showing all the AVI files you have imported using Manage Demo Resources.
2. Choose the AVI file you want to play.
Click to insert the text cursor in the edit field for Start Time, and type a number.
The number tells DemoShield how many seconds after the scene starts you want the AVI file to start playing.

4. Click to insert the text cursor in the edit field for Exit Time, and enter the number of seconds you want DemoShield to keep the
last AVI frame onscreen after the AVI file stops playing. The number that appears in the statement "Maximum Allowed Time of
__Seconds" is the scene length.



To choose an action

Related Steps  More about  Action Dictionary

1. Right-click the object in the Designer Window. Left-click on Object Properties or press Enter.
Or double-click the object's name on the Objects List of the Scene Editor.
The object's Properties dialog box appears.
2. For an interactive object: Click the tab named Actions
For an Event Object: Click the True Actions or False Actions tab
3. Click the New Action button.
The Build Action dialog box appears.
4. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
5. Scroll to and click the action you want.




To choose an arrow style for a line

1.

Click the Arrow Style tab.
The Arrow Styles Properties dialog box opens.
Choose your Arrow Head style: triangular or pointed.
Choose one or both pointers: beginning and/or end.
Choose a display option: normal or indented.
Each time you choose an option, the new line will appear in the display box at the bottom right.
When you finish setting one type of property for an object, you can:

P Click another tab to set a different type of property for the same object

] Click OK to close the Properties dialog box



To choose an icon and name for each demo
(Step 4 of 7)

Related steps  More about

1.

Type a name for the demo Program Item (Windows 3.1) or Shortcut (Windows 95/NT) in the edit field under Program ltem
Name (or Shortcut).

Click the Select Icon File button.

The Select Icon File dialog box appears.

Use this dialog box to select an icon for the current demo. Or, type the name of the icon (.ICO) file you want to display .
Click OK.

The Select Icon File dialog box disappears.

Click the Next File button to repeat these steps if you are distributing more than one demo on these disks.

Click Next when you finish entering program (item or shortcut) names and icons.

The Build Disk Location dialog box appears.



To choose the Start/Stop Recording Macro key

Related steps

1.

Choose Preferences from the File menu.

The Demo Preferences dialog box appears.

Click on the Configure tab.

Click to open the combo box next to Start/Stop Recording Macro Key.
A list appears showing the function keys from F2 to F12.

Scroll to, and click, a key.

Click OK to close the dialog box.



To choose windowed playback style

Related Steps  More about

1.
2.
3.

Note
5.

Use the Demo menu to open the Demo Properties dialog box.
Click on the Demo Styles tab.
Select the check box named Windowed playback style.
An edit field and two check boxes appear below.
Select a caption option. You can:
(a) Enter a caption in the field provided, (b) check Use Scene Name for Caption, (c) check Eliminate Caption, or (d) leave the
field blank, thereby selecting the default caption, DemoShield.
If you select Eliminate Caption, your viewers will not be able to move the demo window around on their screens.

Check the Full Screen Background box if you wish to select the color of the background that will fill the viewer’s screen behind
the demo window. If this box is de-selected, the demo will appear on top of whatever the viewer had on his or her screen prior
to launching the demo.

After you check Full Screen Background, click on the Background Color tab.
Choose the color you want the viewer to see on their screen behind the demo window.
Click on the Size tab.

(See To set the size and location of your demo window for the steps.)




To copy one or more objects

Related steps
1. Click the object to select it.

Handles appear around the object.
2. Choose Copy from the Edit Menu, or press Ctrl+C.

To copy more than one object, see Steps for Selecting. on selecting for than one object. When you select more than one object
at the same time, braces surround the objects.



To copy using shortcut keys

1. Click the object to select it.
Handles appear around the object.
2.  Press Ctrl+C.

To copy and paste more than one object, see Steps for Selecting. on selecting for than one object.



To copy your disks later
(Step 7 of 7)

Related steps

1. Inthe Copy Your Disks Now or Later dialog box, click the Copy Later button.
The Setup Wizard closes.

2. When you are ready to copy your disks, find the directory you chose earlier for Build Location (Step 5).
The default build directory is:
C:\PROGRAMF\STIRLING\DSHIELD\WIZARD



To copy your disks now
(Step 7 of 7)

Related steps

1.

2.
3.
4

Choose the floppy drive you will copy to. The default is A:.

Click to open the combo box for Floppy Drive and choose a different drive if you need to.

Insert the first distribution disk.

Click the Copy Now button.

The Wizard copies the first disk.

If you have additional disks to distribute, a prompt appears telling you when it is time to insert the next disk.

When you finish copying this first set of distribution disks, you can copy as many additional sets as you need without exiting the
Wizard.

To repeat this process, click the Copy Now button.
Click the Finished button when you are finished.
The Setup Wizard closes.



To create objects that you want to place in a group
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Related steps More about  Objects Dictionary

Create the first of the objects you want to place in a group using the steps for creating any object.
Right-click the object and press Enter.

You can also double-click the object's name in the Objects List of the Scene Editor.
The Properties dialog box appears.

Click to insert the text cursor in the edit field next to Name.

Type a name for the object.

To create a group, click in the edit field next to Group Name.

Type a name for the group.

Click OK.

Create any other objects you want to place in the Group Object.

Give each object that you want to include in the group exactly the same Group Name.




To create a VCR button object

Related steps  Objects Dictionary

1. Click the VCR button on the Object Palette
2. Click in the Designer Window.
A panel of VCR buttons appears.

Note: Unlike other buttons you can create, VCR buttons come with preset actions. You can use a set of VCR buttons right
away. Click on Related Steps above to learn how to change the properties of VCR buttons.



To create a Bitmap Button Object

Related steps  Objects Dictionary

1. Click the Bitmap Button Object on the Object Palette.
Your pointer changes to the Place Here cursor.

2. Click in the Designer Window.
A Bitmap Button appears, surrounded by handles.

3. Press Enter.

The Bitmap Button Properties dialog box appears.
Now you can edit its properties. See Bitmap Button Object for details.

Note: You cannot change the size of a Bitmap Button by dragging the handles. To resize a Bitmap Button, use the Object Data tab
in the button's Properties dialog box.



To create a Group Object

Related steps  More about  Objects Dictionary

1. Click the Group Object button on the Object Palette.

2. Click in the Designer Window.
If you have made invisible objects visible, the Group Object appears. Otherwise, only handles appear.
DemosShield creates a default name for the object and adds it to the Objects List in the Scene Editor.

3. Type in a name and a group name. The group name must be the same as the group name entered for each object that belongs
to the group.

To create actions for the group, build the actions for the Group Object.




To create a Hot Spot Object

Related steps  Objects Dictionary

1.
2.

Click the Hot Spot button on the Object Palette.

Click in the Designer Window.

The new object appears selected and surrounded by handles.

If you don't see it, choose Invisible Objects from the View menu.
Press Enter.

The Hot Spot Properties dialog box appears.

Change the properties as desired. See _Hot Spot Object for details.




To create a Poly-Line Object

Related steps  Objects Dictionary

1. Click the Poly-Line Object Button on the Object Palette.
2. Click in the Designer Window.
A cursor with cross-hairs appears.
3. Move the mouse to create the first line of the poly-line.
Simply move the mouse--you don't need to drag.
Aline appears. The farther you move from where you first clicked, the longer the line grows.
Click when the line is as long as you want.
Move the mouse to create the poly-line's second line.
Click when the line is as long as you want.
Move the mouse to create the poly-line's third line.
You can repeat this procedure to create additional lines.
8. Double-click when the object is the shape you want.
The completed Poly-Line Object appears, surrounded by handles.

To draw perfectly straight horizontal or vertical lines:
1. Hold down the Shift key while you drag your mouse horizontally or vertically.

2. Click again when the line is as long as you want.
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To create a Polygon Object

Related steps  Objects Dictionary

1.
2.

Click the Polygon Object Button on the Object Palette
Click in the Designer Window.

A cross-hair cursor appears.

Move the mouse to create the polygon's first side.

Simply move the mouse--you don't need to drag. A line appears. The farther you move from where you first clicked, the longer
the line grows.

Click when the line is as long as you want.

Move the mouse to create the polygon's second side.

Click when the line is as long as you want.

A dotted line appears joining where you just clicked with the point where you first clicked.
Move the mouse to create the polygon's third side.

Double-click to close the polygon.

The completed polygon appears, surrounded by handles.



To create a PopUp Menu

Related steps  More about  Objects Dictionary

1. Click the Menu Button on the Object Palette.
2. Click in the Designer Window.

The PopUp Menu Object appears. It's an invisible object, so you may not see it onscreen. A default name for the new menu
appears in the Objects List of the Scene Editor.




To create a Radio Button, Check Box, or Push Button Object

Related steps  Objects Dictionary

1.
2.

o

Click the button marked Button or Check Box on the Object Palette

Click in the Designer Window.

A radio button (or possibly a check box or push button) appears, surrounded by handles.
Press Enter.

The Properties dialog box appears.

Choose Object Styles.

Click to choose the button style you want.

Type a caption for the button.




To create a Text Object

Related steps  More about  Objects Dictionary

1. Click the Text Object button on the Object Palette.
The pointer changes to the Place Here cursor.
2. Move the cursor to the Designer Window.
Click where you want the Text Object to appear on your demo screen.

The Text Object appears selected and surrounded by handles. The words Right-Click Here appear in every Text Object when
you first create it.



To create a Variable Object

Related steps  More about  Objects Dictionary

1. Click the Variable Object button on the Object Palette.
2. Click in the Designer Window.

If you have made invisible objects visible, the Variable Object appears. Otherwise, only handles appear. DemoShield creates a
default name for the object and adds it to the Objects List in the Scene Editor.




To create a button that will play a macro

Related steps  More about

1.

2.
3.
4

o
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11.
12.
13.

Record and save the macro you want to play using the steps explained in To record a macro.
Choose New from the Scene menu to create a new scene.

Choose Replay Current Scene as the Scene Transition.

Create a button.

The type of button you create makes no difference at all. The steps are practically the same whether it's a Push Button, Bitmap
Button, or Hot Spot. You could just as easily use a VCR Button or one of the buttons on a PopUp Menu.

Right-click the button, left-click on Object Properties.

The Properties dialog box appears.

Click to open the Object Styles Properties dialog box.

Give the button an appropriate caption, such as Play Macro.

Click to open the Actions dialog box.

Click the New Action button.

The Build Action dialog box appears.

Choose the action Go to Next Scene,which in this case will be the Application Scene.
Click the green button pointing right on the Demo Controller, to switch to the next scene.
Make the new scene an application scene. (See To Create an Application Scene.)

Create an Application Object to launch the .exe that must run along with the macro. (See To Set the Properties of an
Application Object).



To create a button your viewer can click to display a menu
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10.

11.

Related steps More about

Create VCR buttons. See VCR Buttons.

Right-click the VCR Button Object, left-click on Object Properties.

You could instead double-click the name of the VCR Button Object in the Objects List of the Scene Editor.
Click to select the button your viewer will click to make the menu appear.

Click to insert the text cursor in the Button Caption field.

Delete or type this over the current caption

Click the Edit Action button.

The Build Action dialog box appears

Click to open the combo box.

A list appears showing all the actions you can choose.

Choose the action Display Menu.

A second combo box appears, prompting you to choose which Menu to Display.

Choose the menu you want to display when the user clicks the VCR Button labeled Menu.
Click OK.

You return to the Object Styles Properties dialog box.

Click OK to close the Object Styles Properties dialog box.

NOTE: Instead of using VCR buttons, you could create a Button or Bitmap Button and build the Display Menu action through the

Actions tab.



To create a demo template

Related steps  More about

1.

Choose Template Properties from the Demo menu to set the demo template properties.

Set the demo properties you wish to save in the template. See Demo Properties for more information.

Choose Template Properties from the Scene menu.

Set the scene properties you wish to save in the template. See Scene Properties for more information.

Open the object Template Properties dialog box for each object whose properties you wish to save in the template.
For example, to set the text template properties, right-click on the Text Object Button on the Object Template.

The Text Template Properties dialog box opens. Set the properties you want as defaults. Click OK when you are done.
Repeat the steps given in #3 above to change any other object template properties.

Choose Save Template As to open the Save Template dialog box.

Type a filename for the new template.

The .tpl extension will be added automatically.



To create a Line Object

Related steps  Objects Dictionary

1. Click the Line Object button on the Object Palette.
2. Click in the Designer Window.
The pointer changes to a cross-hair cursor.
3. Move the mouse.
You do not need to drag. As you move away from where you clicked, the line grows.
4. Click again when the line is as long as you want.
Aline appears, surrounded by handles.

To draw perfectly straight horizontal or vertical lines:
1. Click on the Line Object button on the Object Palette, and click in the Designer Window.

2. Hold down the Shift key while you drag your mouse horizontally or vertically.
3. Click again when the line is as long as you want.



To create a margin

Related steps More about

Click the Object Styles tab.

Click the Options button.

Click to insert the text cursor in the Margin in Pixels field.
Type a number.

The number you type represents pixels. Type 10, for example, to create a margin of 10 pixels on all sides of the object--top,
bottom, left and right.
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To create a new demo (using the Demo Wizard)

Related steps
1. Launch DemoShield (see To start a DemoShield session).
The Welcome dialog box opens.
2. Click on Create New Demo.
The Demo Wizard launches.
3. In Step 1, you have three choices:
P One Scene Empty Demo
] Use "Default.dbd" demo
] Create Demo __ Scenes

If you choose either One Scene Empty Demo or default.dbd demo, your new demo opens. One Scene Empty Demo is
just that. Default.dbd demo is a three-scene demo containing several objects you can view and edit to see how they work.

4. If you click "Create Demo ___ Scenes," you must enter the number of scenes you want the demo to have. Remember: you
can add or delete scenes later.
5. Click Next.

The Step 2 dialog box opens.
6. Under Style of Demo, select either Full Screen or Windowed demo.
If you choose Windowed demo, enter the height and width (in pixels) of the demo window that will play on your viewer's screen.
7. Click Next to continue to the Step 3 dialog box.
In the edit field next to Scene Length, type in the default scene length for all scenes in your demo.
9. Inthe combo box next to Scene Transition, click to choose a default scene transition (such as Pause on Scene).
10. In the group marked Options, click to select one or both items to appear in each scene of your demo.
Click Text Title box to place a Text Object in each scene to use for headline text.
Click VCR Controller to place a set of navigational VCR buttons in each scene.
11. Click Finish.
The Demo Wizard closes, and the DemoShield Designer launches.
You are in the first scene of your new demo, demo.dbd.



To create a Rectangle or Rounded Rectangle Object

Related steps  Objects Dictionary

1.

2.
3.
4

Click the Rectangle or Rounded Rectangle button on the Object Palette.

Move the pointer to the Designer Window.

Click where you want to paste the shape, and hold down the left mouse button.

With your finger still pressing the mouse button, move the mouse.

As you drag farther away from the point where you clicked, the shape grows larger, stretching like a rubber band.
Release the mouse button when the outline of your shape is the size you want.

The new object appears selected and surrounded by handles.




To create a scene

Related steps  More about

Choose New Scene from the Scene Menu, click this button gon the Toolbar, or click this button

on the Scene Sorter to create a hew scene.

The new scene appears in the Designer Window. It will follow the scene that was previously the current scene. Its default name is
"# Scene."




To create a scene template

Related steps  More about

1.
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Choose Template Properties from the Scene menu.

The Scene Template Properties dialog box opens.

Edit the properties you want saved in the new template.

Click OK when you are finished.

Choose Save Template As from the File menu.

Choose a filename for the new template. It will automatically become the current template.
To use another template, choose Load Template from the File menu.



To create a software demo using bitmap overlays

Related steps  More about

Here are the basic steps for creating a software demo using bitmap overlays:

1.
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Use the Capture Images command from the Demo menu to capture images of your application screens. The images will be
automatically saved as demo resources with the filename Image x, with x being the number of images you have captured.

Or, you could use another screen capture program, making sure to save your files as 16-color bitmaps, and import the files
using Manage Demo Resources.

Launch DemoShield and create your demo.

Import your new image files into Graphic Objects, Bitmap Buttons, and/or scenes.

Create Text Objects to explain items shown on the bitmaps.

Create Graphic Objects such as arrows and ellipses to point out key functions and to add movement and color to your demo.
Make sure the "No Scale" property is selected for all of your graphic and text objects that will be stacked on top of one another.

Use the Move Cursor action, timed with the appearance of new screen captures, to make it appear as though a macro or video
capture file were playing.

You may also use a Play Sound Action or an Event Object to play sound in your demo.
Test-run the demo using the Player to check for demo scaling problems.



To create a software demo using macros

Related steps  More about

1.

10.
11.

12.
13.
14.

15.

Right-click on an empty spot in the scene background; left-click on Scene Properties.
The Scene Properties dialog box appears.

Click the check box next to Application Scene.

Click OK.

The Scene Properties dialog box closes and the scene background changes to gray. This lets you know the scene background
is transparent, and while your demo runs, you will see the application running underneath.

Click the Application Object button on the Object Palette.
Click in the Designer Window.

A cross-hatching pattern appears in the Designer Window. The cross-hatching tells you an application will run in the
background of this scene. The default name Application 1 appears in the Objects List of the Scene Editor.

Double-click Application 1 (or whatever you name the Application Object) on the Objects List of the Scene Editor.
The Properties dialog box appears.

Click the Object Data tab.

The Object Data dialog box appears.

Enter the filename(s) and parameters for the application you want to launch.

Click on the Options tab, and set any options you choose for controlling your application.

Windows 95 and Windows NT applications: you must set the Windows Class Name and Windows Caption fields in order to
launch your application.

Start the application. If you are maximizing the application in your demo, make sure you maximize the application now.
Set up the application screen exactly the way you want your viewer to see it when you start demonstrating.

Perform each function or procedure that you want your viewer to see, at the same time recording every mouse move and
keystroke you make in a macro.

Record any additional macros you will need for the demo.
Create, play back, and test all your macros.

Create the graphics, text, and other objects you want your viewer to see while the application is running. Use the graphic and
text objects to explain to your viewers what they've seen and what they're about to see.

Test-run and edit the demo.




To create a software demo using video files

Related steps  More about

1.

19.
20.
21.
22.

Launch the application you want to demonstrate.

Set up the application exactly the way you want it to look before you begin recording.
Launch a video capture tool (such as Lotus ScreenCam or Video for Windows).

If creating an AVI file, set the size and position of the window where you will record.
If creating an SCM file, set your screen resolution to 640 x 480 pixels.

Start capturing.

Using the application, perform the functions or procedures that you want to explain to your viewer.
Stop capturing.

Use your video editor to play back and, if necessary, edit the captured sequence.
Save the sequence you captured in an AVI file or an SCM file.

Launch the DemoShield Designer.

Create the demo.

Choose Manage Demo Resources from the Demo menu.

Import the video file(s) you want to play.

Create the scene(s) where you want to run video files.

Make the first scene where you want to run a video file the current scene.

Create a button or other interactive object.

Open the button's Actions Properties dialog box.

Choose the Play Video action and select the AVI or SCM file you just recorded.

Or, create an AVI Object to play an AV file.

Run your demo with the DemoShield Player to see how it will look to your viewer.
Switch to the DemoShield Designer.

Make the scene where you want to play the video the current scene.

Create any graphics or text to make your points: for example, summarize what you have explained to the viewer, introduce
what will appear next in the demo, or include an 800 number that viewers can call to order the product.



To create a timed action for an Event Object

Related steps  More about

1. Create the Event Object.
2. Right-click the Event Object, left-click on Object Properties.
You can also double-click the name of the Event Object in the Objects List of the Scene Editor.
The Properties dialog box for an Event Object opens.
3. Click the Time tab.
The Time Properties dialog box appears.
4.  Type the number of seconds after the start of the scene when you want the action to happen.
For example, type 3 if you want the event to happen when the scene has been playing 3 seconds.
5.  Build the action(s) that you want to happen at the time you just set.




To create a title, default directory and Program Group (or Folder) name
(Step 2 of 7)

Related steps

1.

Type the title for your installation.

This title will appear at the top of your installation screen.

Press Tab.

The text cursor moves to the Default Directory field.

Type the subdirectory where you want to install your demo on your viewer’s hard disk.
Note: The viewer can change this directory during installation.

Press Tab.

The text cursor moves to the Program Group Name edit field.

The setup you produce with DemoShield’s Setup Wizard will create a Program Group (Windows 3.1) or Program Folder
(Windows 95/NT) on your viewer’s machine.

Type a name for the Program Group (or Folder) that your setup will create.
This name will appear on the title bar of the Program Group (or Folder) window.
Click OK.



To create an AVI Object

Related steps  More about  Objects Dictionary

1. Click the AVI Object Button on the Object Palette.
2. Click in the Designer Window.

If you have made invisible objects visible, the AVI Object appears. Otherwise, only handles appear. DemosShield creates a
default name for the object and adds it to the Objects List in the Scene Editor.




To create an Application Object

Related steps  More about  Objects Dictionary

1. Onthe Object Palette click the Application Object button.

2. Click in the Designer Window.
If you have made invisible objects visible, the Application Object appears. Otherwise, only handles appear.
DemosShield creates a default name for the object and adds it to the Objects List in the Scene Editor.




To create an application scene

Related steps More about

1. Point to any empty area in the Designer Window and right-click.
The Scene Properties dialog box appears.
2. Click the Application Scene check box in the General tab.
Click OK to close the dialog box.
The scene background changes to gray, telling you this is a transparent scene.
4.  Click the Application Object Button on the Object Palette.
5.  Click in the Designer Window.
A cross-hatching pattern fills the Designer Window to show that an application will appear in the background.
6. Right-click in the Designer Window; left-click on Object Properties.
The Application Properties dialog box appears.



To create an Edit Field Object

Related steps  More about  Objects Dictionary

1. Click on the Edit Field Object Button on the Object Palette.
2. Click in the Designer Window.
The Edit Field Object appears, selected and surrounded by handles.
Resize the object as necessary.
Right-click the object; left-click on Object Properties. The Properties dialog box opens.
Click the Object Styles tab.
Choose the styles you want to apply to the Edit Field Object.
Alignment
Choose to align the text left, center, or right.
Case

Choose Upper to display the characters the viewer types in uppercase only. Choose Lower to display the characters the
viewer types in lowercase only. Choose Any to display the characters the viewer types as they are.

Horizontal Scroll

When the viewer types more characters than there is room for in the Edit Field, choosing Horizontal Scroll makes it
possible for the viewer to scroll to, display, and edit any hidden characters.

Maximum Length

Click to insert the text cursor in this field to type a number that will limit the number of characters the viewer can type in
the Edit Field.

Password Blanking

Choose Password Blanking to hide the characters the viewer types so they will not appear onscreen
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To create an Event Object

Related steps  More about  Objects Dictionary

1. Click the Event Object button on the Object Palette, then click in the Designer Window.
An Event Object appears.
2. Right-click the Event Object; left-click on Object Properties.
You can also double-click the name of the Event Object in the Objects list of the Scene Editor. The Properties dialog box opens
to the General tab.
Note Make sure the Enabled property is selected for your Event Object. If the Event Object is disabled, it will not trigger the
actions associated with it.
3. Click the words True Actions to the left of the dialog box.
The True Actions dialog box opens.
4. Click the New Action button.
The Build Action dialog box appears.
5. Choose the action Play Macro.
A second combo box opens asking you which Macro to Play.
. Choose the macro you want to play in this Application Scene.
7. Click OK to close the Build Action dialog box.
Click OK to close the Event Properties dialog box.



To create an action for a group

Related steps ~ More about  Actions Dictionary

1. Create the button or other interactive object you want the viewer to click; or create an Event Object.
See Adding Objects for more information.
2. Double-click the object's name in the Objects List of the Scene Editor.

The object's Properties dialog box appears.
3. If the object is a button or other interactive object, click the Actions tab.

If the object is an Event Object, click the Time tab to set the time you want the group action to occur, then click on the True
Actions tab.

4. Click the New Action button.

The Build Action dialog box appears.
5.  Click to open the combo box next to the message Perform the action.

Alist appears showing every action you can choose. Use the Hide action to make an object disappear. For information on how
to build every action, see the Actions Directory.

6. Choose an action (say, Hide).
Two new combo boxes appear.
7. Open the Scene combo box and choose the scene the group object is in.
Open the Object combo box.
A list appears showing all the objects you can hide in that scene.
9. Choose the Group Object. you want to hide.
10. Click OK to close the dialog box.
When the viewer clicks the button, every object in the group will be hidden.



To create an effect for an object

Related steps  More about

1.
2.

Click either Start, Hold, or End (the period in which you want the effect to happen).
Click to open the combo box next to the word Effect.

Alist appears showing all the effects you can choose.

Click to choose the effect you want.

For example, if you have chosen Start and want the object to appear suddenly out of nowhere, choose the Show effect. Show
makes the object pop up completely visible.

Click to select the Hold Period.

Motions appears grayed out because no motions are available during an object's Hold Period.
Set an effect for the object during its Hold Period using the steps explained above.

The default effect for each period is Show.



To create an Ellipse (circle) Object

Related steps  Objects Dictionary

1. Click the Ellipse (circle) button on the Object Palette
2. Click in the Designer Window.

A cross-hair cursor appears.
3. Move the mouse to create the ellipse.

Simply move the mouse--you don't need to drag. A line appears. The farther you move from where you first clicked, the larger
the circle grows.

4. Click when the ellipse is as large as you want.
The completed ellipse appears surrounded by handles.



To create an object

Related steps  More about  Objects Dictionary

1. Click the appropriate button on the Object Palette.
2. Click in the Designer Window.

The object appears. Its name appears in the Objects List of the Scene Editor.
3. Resize the object as you see fit.

4.  Set the object's properties using the Properties dialog box. To open the Properties dialog box, select the object and press
Enter.

For example, you may want a headline to stay onscreen just long enough for the viewer to read but disappear before the macro
starts. Use the Life Properties dialog box to adjust the object's Start, Hold, or End Times.



To create distribution disks for your demo

Related steps  More about

3 Windows 3.1 users: Double-click the Setup Wizard icon in the DemoShield group in Program Manager.

] Windows 95/NT users: Choose the DemoShield Program Folder from your Start Programs menu. Double-click on the
Setup Wizard icon.

The Setup Wizard walks you through the steps for creating your distribution disks.
Click Related Steps (above) for information on specific topics.

Note: Before you run the Setup Wizard, you should have DemoShield check for unused resources in your demo. This willl help
you create the smallest possible .dbd file.



To create menu titles

Related steps  More about

1. Click on the Captions tab.
The Captions dialog box appears.
2. Inthe edit field next to Upper Title, type a title.
In the edit field next to Lower Title, type a caption, if you want one, for the bottom of the menu.



To create or change a caption on a menu button

Related steps  More about

1. Click the name of the button in the list under Menu Buttons.
The button appears highlighted.

2. Inthe edit field underneath Menu Button Text, delete the current caption.
Type the caption you want.




To delete a resource

Related steps

1. Choose Manage Demo Resources from the File menu to open the Manage Demo Resources dialog box.
2. Click on the tab containing the resource you want to delete.
3. Click the resource you want to delete
The resource appears highlighted.
4. Click the Remove button.
The resource name disappears from the list.



To delete an object in the Designer Window

Related steps
1. Click the object's name in the Objects List of the Scene Editor.

You can also click the object in the Designer Window.

The object's name appears highlighted in the Objects List. Handles appear around the object in the Designer Window.
2. Press the Delete key.

You can also click the Delete button.

The object disappears and its name is gone from the Object's list.




To delete an action

Related steps
1. Click the tab that contains the action you want to delete (Actions, True Actions, or False Actions).
2. Click to select the action you want to remove.
3. Click the Delete Action button.
The action is deleted.
4. Click OK to close the dialog box.



To deselect an object in the Designer Window

Related steps

1. Point elsewhere in the Designer Window.
You can point to a different object, or to a blank area in the Designer Window.

2. Click.
The handles around the object disappear in the Designer Window. The highlight on the object name disappears in the Scene
Editor. If you clicked on a different object, the object you clicked now appears highlighted.

To deselect an object using the Scene Editor

Click the name of the object on the Objects List.
The highlight on the object name disappears in the Scene Editor. The handles around the object disappear in the
Designer Window.




To display an RTF file in your demo

10.

11.

Related steps More about

Click the Text Object button on the Object Palette.

Click in the Designer Window.

The Text Object appears.

Press Enter.

The Text Properties dialog box appears.

Click the Object Styles tab.

The Properties dialog box, Object Styles tab appears.

Click the Options button.

The Text Options dialog box appears.

Click the Import button.

The Rich Text Format File Browse dialog box appears.

Choose a word-processed file saved in Rich Text Format (with an RTF extension).
Click OK.

The RTF File Browse dialog box closes and you return to the Text Options dialog box.
Click a radio button in the RTF Files group to choose either Fixed Size or Auto Size.
Click OK.

The Text Options dialog box closes.

Click OK.

The Properties dialog box closes and the text in the RTF file appears onscreen inside the Text Object.




To display an image in a Graphic Object, Bitmap Button, or Scene

Related steps (objects) Related steps (scenes) More about

1. Click the Fill Styles tab.

The Fill Styles dialog box appears.
2. Click the Image radio button.

If the image is a bitmap, click a radio button in the Image Options group. Image options are irrelevant for Windows metafiles.
4.  Click the Import Image button.

The Image Browse box appears.

You can choose either a bitmap file or a Windows metafile. By default, the dialog box lists bitmap files. To display metafiles,
open the List Files of Type combo box and choose Windows Metafiles or All Files.

5. Select an image and click OK.
The file name you selected appears in the list box and the image appears in the preview window.
6. Click OK to close the Fill Styles dialog box.
When the Fill Styles dialog box closes, the image you chose appears on the Bitmap Button, Graphic Object, or Scene.

Note 256-color bitmaps will display with better results in a Graphic Object or Bitmap Button than they will as a scene background.

Tip: To speed up the display of images in Graphic Objects, use an invisible border for the object.

Transparent Backgrounds for Images Displayed in Objects

If the image displayed is a 16-color or true-color bitmap (not a metafile or a 256-color bitmap), you can choose to make part of that
image transparent. You can make any one color used in the image appear “transparent,” that is, the scene background will show
through it, whatever that background is.

1. Open the object's properties dialog box.

2. Click the Background Color tab.

3. Choose the background color that corresponds to the color in the image that you wish to make transparent.

If the color is obscure, you may need to open the application you used to create the image and note its exact RGB values.
Click the Fill Styles tab.

Select the image you are changing.

Check the box marked Transparent.

Click OK to close the dialog box.

The image appears on the screen. The color you selected appears to be transparent, that is, the scene background shows
through it.

The figure below shows a non-transparent image at left. The same image with the blue areas transparent is shown at right.
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To display or close the Toolbar

Related steps
[ To display the toolbar, choose Toolbar from the View Menu.
The toolbar appears and a check appears next to Toolbar on the View Menu.
3 To close the toolbar when it is open, choose toolbar from the View Menu.



To display symbols instead of words on VCR Buttons
Related steps

There is no limit to the number of VCR Button objects you can create in a scene, or the number of scenes in your demo that
can contain VCR Buttons.

3 Click the Symbols radio button under Button Styles.
You can use symbols instead of captions on VCR Buttons.



To display the Scene Editor

Related steps

1. Choose View from the menu bar.
The View Menu appears listing DemoShield's tools and palettes.
2. Click Scene Editor.
When a palette is open, a small check mark appears next to the palette on the View Menu.



To display the scene sorter

Choose Scene Sorter from the View menu.



To duplicate an object

Related steps
1. Click the object to select it.

Handles appear around the object. At the same time, the Duplicate choice appears enabled on the Edit Menu.
2. Choose Duplicate from the Edit Menu or the toolbar.

The newly created object appears to the right side of, and touching the original object.

Clicking the Duplicate Objects toolbar button is the same as choosing Duplicate from the Edit Menu.



To edit an action you have already set

Related steps ~ More about  Action Dictionary

1.
2.
3.

Click on the tab that contains the action you want to edit (Actions, True Actions, or False Actions).
Select the action you want to edit.

Click the Edit Action button or double click on the name of the action.

The Build Action dialog box appears. The current action is selected.

Modify the existing action as desired, or choose a new action.

Click OK to return to the Actions, True Actions, or False Actions dialog box.



To edit an object's properties outside its time period

Related steps

1. Double-click the name of the object in the Objects List of the Scene Editor.
The object's Properties dialog box appears.




To enable or disable Automatic Last Demo Launch

Related steps
1. Choose Preferences from the File menu.
2. Click on the Enable tab.

3. Check the box marked Automatic Last Demo Launch if you want your last demo to open automatically when you launch
DemoShield.

4. Uncheck the box marked Automatic Last Demo Launch if you wish to be prompted for the demo to open.



To enable or disable Scrollable Design Window

Related steps

1. Choose Preferences from the File menu.
2. Click on the Enable tab.

3. To be able to view and edit your demo objects in What You See Is What You Get (WYSIWYG) mode, check the box marked
Scrollable Design Window.

4. Click on the left, right, up and down scroll bars that appear on the Designer Window to view and edit the objects in your scene
that no longer appear in the window.

5. To disable Scrollable Design Window view, uncheck the box marked Scrollable Design Window.




To enable or disable a VCR Button

Related steps
1. Click the button you want to enable or disable on the list of VCR Buttons.

The name of the button appears highlighted.
2. Double-click to disable a button on this list.

The check mark disappears and the button no longer appears on the VCR panel.
4. Double-click a disabled button to enable it again.

The check mark reappears on the list and the button reappears on the VCR panel.



To enable or disable a menu button



To enable or disable the startup dialog

Related steps
1. Choose Preferences from the File menu.
2. Click on the Enable tab.

3. Uncheck the Startup Dialog box to disable the "Welcome to DemoShield" dialog box that appears when you start the
DemoShield Designer.

Instead of the Demo Wizard, you will see the DemoShield Designer screen. Choose New or Open from the File menu to begin.
4. Check the Startup Dialog box to see the startup dialog when you click on the Designer icon.



To end a DemoShield session

Related steps

1. Choose Exit from the File menu.
A message may appear asking if you want to save changes to the current demo.
2. Choose Yes to save the file.
Choose No to exit immediately.
Choose cancel to return to the Designer Window.
If you choose Yes, the Save As dialog box appears.
3. Choose or type a path/file name.
4. Click OK.
The dialog box closes and your session ends.

If DemoShield freezes, or terminates in any other way, before you choose Exit from the File Menu, we recommend that you restart
Windows before you reopen DemoShield.



To enter the directory where you will build your disks
(Step 5 of 7)

Related steps

1. Click to insert the text cursor in the edit field for Build Location.

2. Type a path and the name of a subdirectory on your hard drive where you want the Wizard to build your distribution disks. It's
from this directory that you will copy the setup files for your demo to your distribution disks.
Example

3. Click OK.



To enter your application files

Related steps More about

1. Click the Object Data tab.

The Object Data Properties dialog box appears.

Click to insert the text cursor in the Executable field.

Type the path/filename of the application's executable file, or click the Browse box to browse for the .exe file.

Click to insert the text cursor in the Command Line Parameters field.

Type the path/filename(s) of any other file(s) you will need to add to the command line.

Add to the Command Line Parameters field any switches or options that you need to type on the command line.

Click to insert the text cursor in the Additional Required Files edit field, and type any other files you will run with the application

in this macro.

Note: We suggest that you enter in the Additional Required Files edit field not just the names of additional files you plan to run with

the application in this macro, but every file you intend to use in the macro, including any files you typed in the Command
Line Parameters field. DemoShield will make any files you enter here part of the DBD file when it saves the demo. This
saves you the trouble of copying these files separately to your distribution disks.

8. Uncheck the Import Application Files box if you want to import your application and support files by reference. Check the box if
you want those files to be saved as part of your demo (.dbd) file.

9. Check the Store Full Path box if you know that your viewers will be able to find your executable in a specific path. If you do
not check Store Full Path, the demo will search for the .exe file to launch first in your viewer's TEMP directory, then in the
current working directory, Windows directory, and finally, the Windows System directory.

This is the only way to launch executables that will not be stored in TEMP, the current working directory or Windows directories.

10. Click the Options tab.

The Options dialog box opens.

11. If you are running a Windows 95 or Windows NT application, you must enter your Windows Class Name and Windows Caption
in the fields under the heading Identify Application. If you are running a Windows 3.1 application, those fields should be left
blank.

12. Make any other selections you wish to make in the Options dialog box. For example, you may want to change the setting for
Application Termination (when the application will close).

13. When you are finished selecting your options for application control, click OK to close the Properties dialog box.
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To export a resource

Related steps
1. Click on the tab containing the resource you want to export to another application.
2. Click on the resource to select it.
3. Click the Export button
A browse dialog box appears.

4. The name that the resource file had when it was imported into the demo file will appear as the default. Change the file name
and/or location if you wish.

5. Click OK to close the dialog, and return to the Manage Demo Resources dialog box.
The resource will appear as a separate file in the location you specified.
The resource will also remain part of the demo file.



To find object(s) that disappear when you align

Related steps  More about

1.

Click outside the braces or press Esc.

The braces disappear.

Click the object you see and drag it away.
You will see the other object(s) underneath.



To import a resource

Related steps

1. Click the Import button.
A browse dialog box appears.

2.  Click the file for the resource you want to import.
Click OK.

You return to the Manage Demo Resources dialog box. The name of the resource you imported appears on the list of
resources.



To import a resource by reference

Related steps  More about

You may import .AVI, .SCM, .WAV, and .EXE files by reference.
To import an AVI, SCM, or WAV file by reference:

1.
2.
3.
4.

Choose Preferences from the File menu to open the Preferences dialog box.

Click on the Options tab.

To import your .AVI and .SCM files by reference, check the box marked Import Video Files by Reference.
To import your .WAV files by reference, check the box marked Import WAV Files by Reference.

To import application files by reference:

1.

a kv

Open the Scene Properties dialog box to the General tab and click the box marked Application Scene.
Create an Application Object and open its Properties dialog box.

Click on the Object Data tab.

Uncheck (deselect) the box marked Import Application File if you want to import your .EXE file by reference.

Check the Store Full Path box if you know that your viewers will be able to find your executable in a specific path. This is the
only way to launch executables that will not be stored in TEMP, the current working directory, the Windows directory, or
Windows System directory. If you do not check Store Full Path, the demo will search for your .exe in the previously named
directories, in the order listed.



To import a video file

Related steps  More about

1.

Choose Manage Demo Resources from the Demo menu.
The Manage Demo Resources dialog appears.

Click the Video tab.

The Demo Resources dialog box for video files appears.
Click the Import button.

The File Browse dialog box appears.

Choose an AVI or SCM file to import.



To import an RTF file

Related steps  More about

1. Choose Manage Demo Resources from the Demo menu.
The Manage Demo Resources dialog box appears.
Click the Text tab.
The dialog box for text resources appears.
Click the Import button.
The Rich Text Format File Browse dialog box appears.
Choose a document you created using a word processor and saved in Rich Text Format (with an .RTF extension).
7. Click OK.
The RTF File Browse dialog box closes and you return to the Manage Demo Resources dialog box for text resources.
8. Click Done to close the Manage Demo Resources dialog box.
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To import resources and/or scenes from a different demo

Related steps

1.

Choose Import Demo from the File menu.

The Import Demo dialog box appears

Click the Options button.

The Import Demo Options dialog box appears.

Click the Import Resources check box in the Options group to the left to import the demo's resources.

You may now select what you want to import from another demo. You may import scenes, resources, or both.
To import all the demo’s scenes, click the Import Scenes check box.

DemosShield adds the new scene(s) you import to the end of the demo.

Follow the same process for selecting the types of resources you want to import. You may import images, macros, applications,
video, or sound resources. You cannot import just a specific file, only all the files of that type. You may import more than one
type of resource.

Click a radio button in the Overwrite group to choose whether you want the imported scenes and resources to overwrite current
resources and scenes with the same name. If you select Prompt User, you will be able to say yes or no in each case.

Click OK.

The Import Demo Options dialog box closes and you return to the Import Demo dialog box.
Click the name of the file you want to import resources and/or scenes from and click OK.
Or, simply double-click the file you want.

Either way, the Import Demo dialog box closes and you return to the Designer Window.



To increase or decrease the time scale

3.

Related Steps

Click once on either the Decrease Time Scale button or the Increase Time Scale button.
The time scale will decrease or increase by one setting.

Click again on the same button to move to the next setting.

There are six time scale settings. You will move through each one sequentially.

If you chose the Decrease Time Scale setting, you will move down through the six settings.
If you chose the Increase Time Scale setting, you will move up through the six settings.
Continue clicking on the same button until you see the time scale you want.



To install a demo

Related steps  More about

Windows 3.1 users
1. Open Program Manager.
2. Insert the first distribution disk into the floppy drive.
3. Choose Run from the File menu.
4.  Type:
a:setup
If you inserted the disk in a different drive, substitute the letter of that drive, for example:
b:setup
5. Click OK.
Windows 95/NT users
1. Insert the first demo disk in a diskette drive.
2. From the Start menu, choose Settings: Control Panel.
The Add/Remove Program dialog box opens.
3. Click the Install/Uninstall tab.
4. Click the Install button.
5. DemoShield’s installation program will search for the appropriate files on your disk drives and launch the installation.
Messages appear during the installation prompting you to provide information and to insert disks, if necessary.
Type the requested information and click the Continue button where appropriate.



To launch DemoShield demos from other applications

Related steps
Use the DemosShield Server to control the DemoShield Player from other applications.

Note Unless you are a programmer, you don’t need to know how to use the Server. You only need to know that a programmer
can use it to control the DemosShield Player from an outside application.

In its normal mode of operation, the demo viewer launches the Player. In Server mode, the viewer does not control the player. The
Server does--in a sense. Actually, the Server is a passive program. The programmer launches the Server from another application.
The server runs invisibly in the background, waiting for your application to tell it what to do.

The Server creates a window that will respond to specific Windows messages. The Server will run indefinitely, unless you use the
Windows Task List to end the task, or send a message to the Server to destroy itself.

Steps

3 How a Programmer Uses the Server

3 How to add Command Line Parameters to DEMO.EXE




To launch the Player from the Help Menu (Designer)

Related steps  More about

1.
2.
3.

4.
3.
4.

Choose Preferences from the File menu to open the Preferences dialog box.

Click the Demos tab.

You will see edit fields named First Demo, Second Demo, Third Demo, and Fourth Demo.

Click the down arrow key at the right of the dialog box to access the fields for entering up to 10 demo file names.
Enter the full path name for the demos you wish to play, or click on the Browse button to browse for the files.
Click OK when you have made all your selections.

To play a demo, select Play [FILENAME] from the Help menu.

The DemosShield Player will launch and play the demo you selected. When you exit the demo, the Player will close and you will
return to the Designer Window.



To launch the Player in Windows 3.1

Related steps
From Program Manager

1. Double-click the Player icon.
DEMO.EXE launches.
The DemoShield Player dialog box appears.

2. Browse to select the demo you want to play.

From File Manager by Double-Clicking

1. Double-click the filename DEMO.EXE.
The DemoShield Player dialog box opens.

2. Browse to select the demo you want to play.

From File Manager through the Run Command

1. Choose Run from the File Menu in File Manager.
The Run Command dialog box appears.

2. Type the path and filename of the DemoShield Player. For example:
\WINAPPS\DEMO\DEMO.EXE

3. Click OK.
The Player will launch and by default prompt you to browse for a demo to play.
If you prefer, you can skip a space at the end of the command line and add the name of the demo file you want to play.
For example, to run a demo file named MYDEMO.DBD, type this command
\PATH\DEMO.EXE MYDEMO.DBD



To launch the Player in Windows 95/NT
Related steps

1.

2.
3.
4

Click on the Start button.

Point to Programs

Point to the folder containing the DEMO.EXE file.
Click on DEMO.EXE to launch the Player.

The DemoShield Player dialog box opens.
Browse to select the demo you want to play.



To launch your demo automatically after installation
(Step 1 of 1)

Related steps

1. Inthe Step 1 dialog box, click the check box next to Automatic Demo Launch.
When your viewer finishes the installation, your demo will launch automatically.
2. When you are finished customizing your installation, click Next to continue to the next step.



To load a new template file

Related steps  More about

1. Choose Load Template from the File menu.

The Load Template dialog box appears. It's identical in every way to the Save Template dialog box except that the name at the
top is Load Template.

2. Select or type the file name of the template you want to load.
Click OK.



To make action(s) happen automatically

Related steps  More about

1.
2.

Click the Event Object button on the Object Palette.

Click in the Designer Window.

An Event Object appears, surrounded by handles. The object's default name appears on the Objects list of the Scene Editor.
Press Enter.

The General dialog box appears for Event Properties.

Click on the Time tab. Set the time when you want the action(s) to occur.

Click on the Comparison tab.

Choose Always if you want the action to happen always, or build a comparison (see To Create a Comparison).
Click on the True Actions tab if you want the action to happen when the comparison is true.

Click on the False Actions tab if you want the action to happen when the comparison is false.

Click on the New Action button in either Actions tab to open the Build Action dialog box.

Choose an action from the combo box.

For help in choosing an action, see the Actions Directory.



To view invisible objects in the Designer Window
Related steps

Some objects, such as Hot Spots and Event Objects, are "invisible objects." They were not designed to appear in your demos.
However, when you are working on your demo, you may find it easier to "see" them for editing purposes.

1. Choose Invisible Objects from the View Menu.

2. Acheck appears next to the Invisible Objects menu choice, and any invisible objects you have placed in the Designer Window
appear.



To manage the application (file) resources in a demo

Related steps

Choose Manage Demo Resources from the Demo menu.
Click the File tab.

The File Resources dialog box appears. In the list box under Files, you will see the executable application file, and any
accompanying files you have entered with it.



To minimize a DemoShield palette

Related steps

3 Click the button with the small triangle pointing down in the top-right corner of the palette.
The palette "rolls up" and the triangle on the button now points up.
Click the triangle button again to restore the palette.



To move an object into a scene

Related steps  More about

1.
2.

&

Click the Object Palette button to create the type of object you want.

Click in the Designer Window.

The object appears.

Make the object the shape and size you want (see Adding Objects to a Scene.)

Drag or nudge the object until you've placed it where you want it to stop when it finishes moving onscreen.
Right-click the object in the Designer Window; left-click on Object Properties.

The Properties dialog box appears.

If an object is selected, and has handles around it, you can press Enter instead of right-clicking to open its Properties dialog
box.

Click the Life tab.

The Life Properties dialog box appears.

Decide how you want the object to enter the scene. An object enters a scene during its Start Period.
Click the Start radio button underneath the heading Life Periods.

The Start Period is always selected when you first open the Life Properties dialog box.

Click to open the combo box next to the word Motion.

A list appears showing all the motions you can choose.

Click the motion you want.

If you do not want the object to move, select None.

An object finishes appearing in exactly the spot where you created it.




To move an object out of a scene

Related steps  More about

1.
2.

Click to select the End Period.

Click to open the combo box next to the word Motion.
A list appears showing all the motions you can choose.
Click the motion you want.

If you do not want the object to move, select None.




To move an open or minimized tool or palette

Related steps
1. Point anywhere on the title bar.
2. Click and hold down the mouse button.
3. Drag the pointer to where you want to place the palette.
4. Release the mouse button.
The palette appears in its new position.



To open a DemoShield palette that is minimized
Related steps

3 Click the button in the top-right corner of the palette. The button toggles between a triangle pointing up and one pointing
down.
The palette appears maximized.



To open an object's Properties dialog box
Related

1. Click the name of the object in the Objects List of the Scene Editor.

The object name appears highlighted. Handles appear around the object in the Designer Window. The Edit Properties and
Delete Object buttons appear at the right of the Scene Editor. Only when you select an object in the Objects List do these
buttons appear.

2.  Click the Edit Properties button (or press Enter).
The Properties dialog box appears.
3. Click the tab for the property you want to change.
Right-click anywhere in the dialog box to see a shortcut menu of all tabbed dialog boxes for that object.




To open an existing demo file

Related steps

To open one of your last 4 demos:

1. Choose the demo you wish to open from the list that appears at the bottom of the File Menu.
For example: 1 CADEMOSHIELD\PROGRAM\MYDEMO.DBD
The demo appears.

To open any demo file
Choose Open from the File Menu.

2. Type afile name.
You can also click a file in the list.
3. Click OK.
The first scene of the demo appears in the Designer Window.
DemoShield uses this same Open File dialog box for demos, templates, bitmaps, metafiles, and .RTF files.



To open an object's Properties dialog box

Related steps
To open the Properties dialog box using the object itself
1. Point anywhere on the object in the Designer Window.

2.  Click on the object. Handles appear, showing that the object is selected. When you've selected an object, you can simply press
Enter to open the Properties dialog box. Or, right-click on the words Object Properties.

To open the Properties dialog box using the Scene Editor
1. Double-click the name of the object on the Objects List. of the Scene Editor.

To open the Properties dialog box from the Object Menu
1. Click to select the object in the Designer Window.

Handles appear around the object.
2. Choose Edit Properties from the Object Menu.

To open the Properties dialog box by pressing Enter
1. Click the name of the object in the Objects List of the Scene Editor.

The object name appears highlighted in the Objects List. Handles appear around the object in the Designer Window.
2. Press Enter.

To open an object's Properties dialog box by double-clicking
1. Double-click the name of the object in the Objects List. of the Scene Editor

Once you have opened a Properties dialog box, click on any tab to bring it to the front.



To open an object's properties dialog box from the Timeline Editor

Related Steps

1. Right-click on the name of any object shown in the Timeline Editor, or anywhere on its LifeLine, to open the object's Properties
dialog box.

2. Edit any properties you wish to change.
Click OK when you are done.



To open the Manage Demo Resources dialog box and look at any file

Related steps
1. Choose Manage Demo Resources from the Demo Menu.

Choose To See

Images Preview images of bitmap and/or Windows metafile
resources, as well as screen captures you have made
using DemoShield. If the image is a 256-color bitmap, the
number of colors it uses will appear in brackets.

Text A list of the Rich Text Format (RTF) resources you created
using a word processor and imported into DemoShield.
RTF text does not appear in the preview window.

Macros Macros you have recorded to create a live application
demo, the screen resolutions you used to record them,
and their approximate time length. You cannot preview

macros.

Files Application (.exe) or other files you have imported to run
with the current demo. You cannot preview these.

Video Alist of the video clips in Audio Video Interleaved (AVI)

or Lotus ScreenCam (SCM) format you have imported to
run in your demo. You can preview video files if they are
saved within the demo file.

Sound A list of sound files you have saved in WAV format and

imported to run in your demo. You can preview sound
files if they are saved within the demo file.

2. Click a tab for the type of resource you want to look at or import.

A dialog box appears. These dialog boxes all work the same way, no matter what type of resource you select.
3. Click a file name.

Files that you have already imported as resources appear in the box to the left.



To open the Preferences dialog box
Related steps

2 Choose Preferences from the File menu.



To open the Scene Properties dialog box

Related steps  More about

1. Right-click any place in the Designer Window where there is no object.
2. Left-click on the words "Scene Properties."

You can also open the Scene Properties dialog box by choosing Properties from the Scene menu.



To display the status bar

Related steps
1. Choose View from the menu bar.
The View Menu appears listing DemoShield's tools and palettes.

2. Click Status Bar.
When a palette is open, a small check mark appears next to the palette on the View Menu.



To arrange tools and palettes

Related steps

1. Choose View from the menu bar.
The View menu appears.

2. Choose Arrange Tools.

DemoShield automatically moves to the right side of your screen whatever tools you have open and optimizes their
arrangement. If your DemoShield window is large enough, the tools and palettes appear in this order, starting at the top.

] Scene Editor

[ Demo Controller
] Aligning Tools
] Object Palette
3. If there is not enough room on your screen to display every tool or palette you have open, they will appear on top of one

another.



To paste objects you have copied

Related Steps
1. Copy the objects.

2. Switch to the scene where you want to paste the copy.
3. Press Ctrl+V or choose Paste from the Edit menu.

To paste objects you have copied to the same scene
1. Copy the objects.

2. Choose Paste from the Edit Menu. The objects you paste appear in exactly the same spot as the original objects, so you
cannot see them. They will still have handles or braces.

3. Click inside the handles and drag the objects to their new position.

To paste objects you have copied from one scene to a different scene

1. Copy the objects.

2. Inthe Scene Editor, click the button next to the name of the current scene. The combo box opens listing every scene in the
demao.

3. Click the name of the scene you want to make the current scene. The scene whose name you clicked appears in the Designer
Window.

4. Choose Paste from the Edit Menu. The objects you paste appear in exactly the same spot in the new scene as the objects you
copied in the original scene. They still have handles around them.



To pick up (copy) styles from an object

Related Steps * More About
1. Click to select the object you are picking up (copying) styles from.

Handles surround the object. The Pick Up and Apply Styles toolbar buttons appear enabled.
2. Choose Pick Up Styles from the Edit Menu.

Clicking the Copy Properties toolbar button is the same as choosing Pickup Styles from the Edit Menu.



To play a WAV file in your demo

Related steps  More about

1. Import the WAV file using Manage Demo Resources.
2. Right-click the button, or any other interactive object, that you want your viewer to click to start playing the WAV file.
Press enter to open the object's Properties dialog box.
3.  Click the Actions tab.
The Actions dialog box appears.
4.  Click New Action.
The Build Action dialog box appears.
5. Click to open the combo box next to Perform the action.
A list appears showing every action you can choose.
6. Choose the Play Sound action.
A combo box appears.
7. Click to open the combo box for Sound to play.
A list appears showing the WAV files you have imported using Manage Demo Resources.
8. Choose a WAV file to play.
9. Click OK to close the Build Action dialog box.




To play a demo you have installed

Related steps  More about

Windows 3.1

1. Open Program Manager.

2. Double-click the Player icon for the demo you want to see.
Windows 95/NT

1. Click the Start button.

2. Point to Programs.

3. Point to the folder containing the Player icon for the installed demo.
4. Click on the demo.



To play a macro at a specific time with no viewer input

Related steps  More about

1.
2.

10.
11.

Create an Event Object using the steps explained in To create an event object.

Right-click the Event Object; left-click on Object Properties.

The object's Properties dialog box appears.

Click the Time tab.

The Time dialog box appears.

Click to insert the text cursor in the edit field.

Type a number to say how many seconds after the scene starts you want the event to start.
Click OK to close the dialog box.

Suppose for this example you want to play a macro at 3 seconds into the scene. Use the True Actions dialog box.
Click the True Actions tab.

The True Actions dialog box appears.

Click the New Action button.

The Build Action dialog box appears.

Choose the action Play Macro and the name of the macro you want to play.

Click OK to close the True Actions dialog box.

Click OK to close the Properties dialog box for the Event Object, and you're done.

The macro will automatically start playing three seconds after the scene starts.



To play a macro in your demo

Related steps  More about

Launch DemoShield.

At the same time you run the application, demonstrating the features or functions you want to show your viewer, record your
mouse moves and keystrokes in a macro.

Test and save the macro.
Repeat the above steps to record as many macros as you need to demonstrate the application.
Create your demo.

When you get to a scene where you want to run the application and play a macro, make the scene an Application Scene. An
Application Scene is transparent, so you can see the application running underneath the scene.

Distribute your demo to your viewer, along with the executable application file, and any supporting files you used to
demonstrate the application.

When a viewer plays your demo, the actual application itself runs along with the demo. As the application runs, each macro
recreates the mouse moves and keystrokes you recorded, as if you were sitting at your viewer's computer.



To play a macro with no viewer input

Related steps  More about

1. Create an Event Object using the steps explained in To create an event object.
The Event Object appears in the Designer Window, and a default name for the object appears in the Scene Editor.
2. Right-click the Event Object and press enter, or double-click the Event Object name in the Objects list of the Scene Editor.
The Properties dialog box appears for the Event Object.
There are three ways you can make a macro play using an Event Object:
P Ata specific time during the scene
] When a condition that you've set is true

] When the condition you've set is false
See Steps for Actions and Events for details.



To play a macro you've recorded

Related steps  More about

1.

Choose Play Macro from the Demo Menu.

The Play Macro dialog box appears.

Click to select the name of the macro to play.

To play a macro you have not yet saved, click Unsaved Macro.
Click OK.



To play a video file when a viewer presses a button
or presses keys

Related steps More about

1. Import the AVI or SCM file using Manage Demo Resources.
2. Right-click the button, or any other interactive object, that you want your viewer to click to start the video file.
Press Enter.
The Properties dialog box appears.
3. Click the Actions tab.
The Actions dialog box appears.
4. Click the New Action button.
The Build Action dialog box appears.
5. Click to open the combo box next to perform the action.
A list appears showing every action you can choose.
6. Choose the Play Video action.
A combo box and two edit fields appear.
7. Click to open the combo box and choose which video to play.
A list appears showing the AVI and SCM files you have imported using Manage Demo Resources.
8. Choose an AVI or SCM file.

If you selected an AVI, you must enter the X-coordinate.and Y-coordinate that tell DemoShield where on the screen you want
the AVI file to play. If you make both X and Y zero, the AVI file will play in the top left corner of your demo screen.

The SCM file will always play full screen.
9. Click OK to close the Build Action dialog box.




To play an AVI file without viewer interaction

Related steps  More about

1.

10.
11.

Click the AVI Object button on the Object Palette and click in the spot where you want the AVI file to play in the Designer
Window.

The AVI Object appears, selected and surrounded by handles. A default name for the object appears in the Objects list of the
Scene Editor.

Press Enter to open the AVI Object Properties dialog box.

Type a name for the AVI Object.

Click the Object Styles tab.

The Object Styles Properties dialog box for AVI Objects appears.

Click to open the combo box next to AVI Resource.

A list appears showing all the AVI files you have imported using Manage Demo Resources.

Choose the AVI file you want to play.

Click to insert the text cursor in the edit field for Start Time.

The number you enter here tells DemoShield how many seconds after the scene starts you want the AVI file to start playing.
Type a Start Time number.

Click to insert the text cursor in the edit field for Exit Time.

The Exit Time number that you enter here tells DemoShield how long to keep the last AVI frame onscreen after the AVI file
stops playing.

Type an Exit Time number.

Click OK.



To play video

Related steps  More about

1. Create your demo as usual in the Designer Window.
2. Import the AVI file using Manage Demo Resources.
3. To play the file in your demo, use either the Play Video action, or create an AVI Object (plays AVIs only).




To position objects

Related steps
To position or reposition an object by dragging
1. Click to select the object.
Handles appear.
2. Point anywhere inside the handles.
3. Click and drag.
4. Release the button when the object is where you want it.

To position or reposition an object by nudging
1. Click to select the object.

Handles appear.
3. Press an arrow key.
The object moves in the direction of the arrow.



To preview a resource

To preview a demo resource, choose Manage Demo Resources from the Demo menu.
Related steps

To preview an AVI (video) resource you have imported
3 Double-click the AVI resource name.
A small sample of the video clip plays in the preview window if the AVI file is saved within the demo file, and not
referenced.
To preview any metafile, bitmap, or screen capture image
[ 4 Click the resource name. Screen capture images will be named "Image01”, "Image02", etc.
A small image of the resource appears in the preview window.
To preview the sound in a WAVE file you have imported
Double-click the WAV resource name.
The WAVE file plays (if you have the appropriate sound card installed)

Note: You can view information about--but not actually preview--RTF, macro and file resources.



To record a macro

Related steps  More about

1.

2.
3.
Hint

4.

From the Demo Menu choose Record Macro.

A popup menu appears, reminding you of the Stop/Start Recording Macro key.

DemosShield disappears and you're in Program Manager (Windows 3.1) or your desktop (Windows 95/NT).
Start the application you want to demonstrate.

Click to maximize the application, if you choose.

When recording your macro, you should configure your application to look as it would look if DemoShield launched it. For
example, if you are maximizing the application in your demo, maximize the application before recording it.

Set up the application so that you see onscreen exactly what you want your viewer to see just before you begin demonstrating
what you want to explain.

Choose Record Macro from the Demo menu.
Press the Start/Stop Recording Macro Key.

You will hear a message beep.

Click your application to make sure it has the focus.

Perform the mouse moves, keystrokes, and other functions you want your viewer to see as you explain the application in your
demo.

When you are done, click the Start/Stop Recording Macro Key to stop recording the macro.
A beep sounds again. The application disappears and you return to the DemoShield Designer Window.

Note: If you use keystrokes to record your macro, you will have to record the macro three times, once in each major screen

resolution. This will ensure that the macro will playback correctly on every viewer's system. Also, remember that macros
recorded in Windows 3.1 will not work on Windows 95/NT systems and vice versa.



To record a macro in all three resolutions

Related steps  More about

1. Record the macro using your current screen resolution.
2. Exit DemoShield.

You're in Program Manager (Windows 3.1) or your desktop (Windows 95/NT). Your video card may have its own software for
changing your screen resolution. If it does, and you need information on the steps to use, see the instructions that came with
the card. If not, you can also use the following steps.

Changing Your Resolution in Windows 3.1

1. Double-click the Windows Setup program in Program Manager.
Setup opens.

Click Options on the menu bar.

Click Change System Settings.

Click to open the combo box next to Display.

Choose a screen resolution.

Make sure it's one your monitor and video card support. You must also have a copy of the video driver for that resolution in
your \WINDOWS\SYSTEM subdirectory.

Changing Your Resolution in Windows 95/NT
1. Right-click on an empty area on your desktop.
2. Left-click on Properties.
The Display Properties dialog box opens.
3. Click the Settings tab.

4.  Find the slider under the words Desktop area. Drag the slider to change the screen resolution up or down through the three
settings.

After you change your resolution

1. Restart Windows.

2. Reopen DemoShield.

3. Record the macro again.

4. Repeat these steps to record the macro a third time.

When you save your demo at the end of the session, all three versions of the macro become part of your current demo file. When
your viewer plays your demo, DemoShield determines, and plays the macro appropriate for, your viewer's screen resolution.

a kv



To record video

Related steps

You can play two types of video in DemoShield: video that has been converted from videotape into .AVI format, or video screen
captures which have been saved as either .AVI or .SCM files.
To record an SCM file

1. Launch the application you want to demonstrate, and set it up exactly the way you want it to look. Run your application at VGA
or the lowest screen resolution your viewers are likely to have.

2. Launch Lotus ScreenCam.
3. Perform the capture and save your SCM file.
4. Use a video editor to play back and edit the captured sequence.

To record an AV file
1. Launch the application you want to demonstrate, and set it up exactly the way you want it to look. Maximize the screen if you
will run it maximized in your demo.

Launch Screen Capture in Video for Windows.

Choose Set Capture File from the Screen Capture menu, and enter the file name and location of the AV file.
Choose Preferences from the Screen Capture menu.

Set the frame rate for the AVI file.

Set the audio capture rate for the AVI file.

Choose Capture from the Screen Capture menu.

Perform any actions you want to demonstrate using the application.

Press the Escape key to stop capturing.

Use the VidEdit application in Video for Windows to play back and edit the captured sequence.
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To remove a palette from the screen

Related steps
1. Choose View from the menu bar.

The View menu appears listing DemoShield's tools and palettes. A check mark appears next to any palette that you have open.
2. Click the palette you want to close.

The palette disappears from the Designer screen, and so does the check mark next to the palette's name on the View Menu.



To reorder actions linked to one event

Related steps

1. Open the appropriate Actions tab for the actions you want to reorder.
Do not change the event.

2. Select the action you want to move.
Press the up or down arrow key that appears in the dialog box.
The action will move up or down on the list.

4.  Press the keys again to move the action further up or down.

5. Repeat steps 2-4 until the actions are in the proper order.

6. Click OK to close the Properties dialog box.



To reset global variables

Related steps

1. Click on the Reset Global Variables check box to set the current values of your global variables back to the initial states.
2. Click on another tab, or click OK to close the Demo Properties dialog box.



To reset the clock

Related steps  More about

1. Click the right- or left-arrow button on the slider bar.
The clock moves forward or back one small step.
You can change how much the clock steps or jumps back forward and back by using the Preferences dialog box, Options tab.
If you hold down the mouse button, the clock keeps changing. The longer you hold down the button, the more the clock moves.
2. Release the button when the time is where you want it.
To reset the current time on the clock using the slider
1. Click the Slider button.
2. Drag to the left or right.
The farther you drag, the more the clock changes.
3. Release the button when the time is where you want it.



To resize a text object

Related steps More about

1. Click the object to select it.
Handles appear around the object.
2. Pointto a handle.
. The mouse pointer changes to a sizing cursor.
4. Click the handle and drag.

Drag away from the text, to make the Text Object bigger and create more room so your words can spread out, or toward the
text to make the object smaller, whichever is appropriate.

5. Release the button when the object is the size you want.
The words inside the object rearrange and wrap to fit the object's new size.



To resize an object

Related steps More about
1. Click the object to select it.
Small square handles appear at the corners and sides of the object, framing the object and indicating its current size.

2. Place the mouse pointer on one of the handles at the side or corner whose shape you want to resize.
The mouse pointer changes to a resizing cursor.
3. Click and drag--that is, click, hold down the mouse button, and move the mouse.
The handle moves as you drag, and the size of the object grows larger or smaller, the farther you drag from where you clicked.



To resize an object outside its life

Related steps  More about

1. Click on the Demo Controller to move the scene time to a time within the object's lifespan.
2. Click on the object when you see it.
Handles appear around the object.
3. Drag on the handles to resize the object.
Once you see the object in the Designer Window, of course, you can open its Properties dialog box any way you want.

Note: Do not resize or move an object while it is in the process of a motion or an effect. You will produce unwanted results.



To review data about your files
Related steps

3 Click the Setup Review button to review your file data.

The File Summary panel appears.
Before you build your distribution disks, you can display this File Summary to review essential data about the files and disks you are
distributing.



To run an application in a scene

Related steps  More about

1.

Choose New from the Scene Menu to create a new scene.

The new scene appears in the Designer Window.

Right-click in the Designer Window; left-click on Scene Properties.
The Scene Properties dialog box appears.

In the General tab, click the check box to select Application Scene.

An Application Scene is transparent. That is, you can see the application running behind the buttons and other objects you may
create for the demo.

Click OK to close the dialog box.

The scene background changes to the color gray, and the Application Object button on the Object Palette appears enabled.
The Application Object button only appears enabled when you click the Application Scene check box in the Scene Properties
dialog box.

Click the Application Object button on the Object Palette .
Click in the Designer Window.

A crisscross pattern fills the entire background of the Designer Window to let you know this is an Application Scene . In
addition, a default name for the object--such as Application 1--appears in the Objects list of the Scene Editor.

Click on Application Object for the steps to choose the application file that will be launched, and to set parameters for how the
application will appear and function in the demo.



To save a template file after you change it

Related steps

To save changes to your current template

1. To save new settings for your current template file, choose Save Template from the File menu.
The template file is updated automatically.

To create a new template file
1. To save your template changes in a new template file, choose Save Template As from the File menu.

The Save Template dialog box appears.
2. Select or type a new template file name.

The TPL extension will be automatically added to the filename. You may store a template file in any subdirectory.
3. Click OK.



To save a macro

Related steps  More about

1. Choose Save Macro from the Demo Menu.
The Save Macro dialog box appears.

2. Type a name for the macro you're saving, or click to select and overwrite one of your current macros.
You may use any characters you want in a macro name, including spaces.

3. Click OK.



To save a demo

Related steps

To save a new demo for the first time
1. Choose Save or Save As from the File Menu.

You can also click the Save button on the Toolbar. Either way, the Save As dialog box appears.
2. Type afile name.

You do not need to type the extension. Every demo file has the extension .DBD. If you don't type .DBD when you save the file,
DemoShield adds it automatically. A sample file might have the name MYDEMO.DBD.

Windows 95/NT users: DemoShield 4.0 includes long filename support.
3. Click OK.
To save an existing demo

.. Choose Save from the File Menu, or click the Save button on the Toolbar.

DemoShield saves the file.

When the file you save overwrites an existing file, DemoShield automatically creates a backup file. If you are running
Windows 3.1, DemoShield saves the file with a .BAK extension. If you are running Windows 95/NT, the file is saved under the name
"Backup of .dbd". However, keep in mind that DemoShield makes only one automatic backup at a time by overwriting the
previous backup file.
To save an existing demo and change its file name
1. Choose Save As from the File Menu.

You can also click the Save As button on the toolbar. The Save As dialog box appears.
2. Type afile name. You do not need to type the extension.

Windows 95/NT users: DemoShield 4.0 includes long filename support.
3. Click OK.




To see a file summary before you build your disks
(Step 6 of 7)

Related steps

1.

N e

Click the File Summary button on the Build Distribution Disk(s) dialog box.
The File Summary dialog box opens
Use this dialog to review:

The number of files you will distribute
The total expanded (not compressed) size of all files

The diskette type you entered earlier.
Click OK to return to the Build Distribution Disk(s) dialog box.



To see all the events and actions you've built

Related steps

1. Open the combo box under the words "When the viewer does this."
A list appears showing all the events you can choose. In this list of events, you will also find (Summary of All Events).
2. Choose (Summary of all Events) from the Event list.
The actions you built will occur in your demo in the order they appear in this list.
Note: You cannot reorder actions in the Summary of All Events list; however you can reorder the actions linked to a particular

event (see To Reorder Actions). Thus, if you create actions for the Left-Clicks-Mouse event first; those actions will always
occur before actions linked to a different event.



To see and manage RTF resources in your demo

Related steps More about

1. Choose Manage Demo Resources from the Demo menu.
The Manage Demo Resources dialog box appears.

2. Click the Text tab.
The dialog box for Text resources appears.
Your RTF resources appear in the list box.

You cannot preview an RTF file the way you can a bitmap or metafile. To see information about a file in the list, click to select
the file.



To select arrow styles

Related steps More about

1. Click the Arrow Styles tab in the Properties dialog box.
The Arrow Styles dialog box appears.
2. Click a radio button in the Arrow Head group to choose either a Triangular or a Pointed arrow head.
Click a check box to say whether you want the arrow head at the beginning of the line, the end, or at both ends.
Use the Display Options to choose either a normal arrow, or an indented arrow.
4.  When you finish setting one type of property for an object, you can:
P Click another tab to set a different type of property for the same object
] Click OK to close the Properties dialog box



To select an object

Related steps

in the Designer Window
Click the object.
Handles appear around the object in the Designer Window. The name of the object appears highlighted in the Objects List of
the Scene Editor.
using the Scene Editor

L Click the name of the object in the Objects List in the Scene Editor.
The name of the object appears highlighted in the Objects List of the Scene Editor. Handles appear around the object in
the Designer Window.



To select the files you will distribute to your viewer
(Step 3 of 7)

Related steps  More about

1. Click the Add button.
The Select Distribution Files dialog box appears.
Use this dialog box to select the demo file(s), and any other files, you want to distribute to your viewers.
2. Type the name of the first demo file you want to distribute.
You may also click to choose a file. To select more than one file, press the Ctrl key while you click a file name.
3. Click OK.
You return to the Choose Files to Distribute dialog box.
The file(s) you selected appear in the list.
4. Click the Add button again to select any other files you want to include on your distribution disk(s).
5. Click OK when you are done choosing files.




To select two or more objects using the Scene Editor

Related steps
1. Click each additional object you want to select.
The object's name appears selected on the Objects List of the Scene Editor.

2. Any objects you have already selected remain selected. Square braces appear around the selected objects in the Designer
Window.

If you want to select only one object using the Scene Editor, you must first deselect any other objects you may have previously
selected.



To select two or more objects using keys

Related steps

1. Point to an object you want to select in the Designer Window.
2. Hold down the Shift key while you click.

3. Repeat these steps for each object you want to select.

The object name appears highlighted in the Scene Editor list. The other selected object(s) remain selected. Braces surround
the selected objects in the Designer Window.



To select two or more objects with the mouse

Related steps
1. Pointin the Designer Window somewhere near, but outside, the objects you want to select.
2. Click.
A dotted rectangle appears.
3. Drag away from the point where you clicked.
As you drag, the dotted rectangle enlarges like a rubber band.
4. Release the button when the dotted rectangle is large enough to lasso all the objects you want to select.



To set DemoShield's global variables

Related steps  More about

1. Choose Properties from the Demo menu.
2. Click on the Globals tab.

3. Inthe edit fields in the User-Defined Global Variables group, enter the initial values for up to six variables (three number and
three string).

4. Click OK to close the dialog box.



To set Start, Hold, End, and Exit Times in the Timeline Editor

Related Steps _ About
1. Select Timeline Editor from the View menu.
Each object in the scene appears in the Timeline Editor window.

Note If you click your cursor outside the Timeline Editor, or move your cursor over another object or palette, the Timeline Editor
will lose focus and may disappear. It will really be covered up by the Designer Window, which is set to always be on top of
the other windows. To bring it back, de-select Timeline Editor from the View Menu and then reselect it, or resize the
Designer Window to reveal the Timeline Editor.

Objects with life properties appear with a LifeLine displayed showing the object's Start, Hold, and End Periods.
2. Click on the magnifier icons in the top right corner to increase or decrease the time scale.

Click on the edge of any colored bar.

Your cursor changes to the LifeLine cursor.
4. Drag the cursor left to decrease the time; or drag right to increase it.

As you change the time, the new time is shown in the Status Bar at the bottom of the screen.

The time is changed immediately, even before you close the Timeline Editor.
5. Double-click on the button in the upper left corner of the window to close the Timeline Editor.




To set an object's Start, Hold, End and Exit times

Related steps  More about

You can set an object's Start, Hold, End, and Exit Times three ways. You may find using the mouse to be easiest at first, although
setting times by typing is the most precise method. The Timeline Editor is the best tool for quickly setting life times for several

objects.
Steps
4 Set Times by Typing

] Set Times by Using the Mouse

3 Set Times by Using the Timeline Editor




To set events and actions for an interactive object

Related steps  More about  Actions Dictionary

1. Click the Object Palette to create the interactive object.
2. Click in the Designer Window.

The object appears.
3. Right-click the object and press Enter.

You can also open the Properties dialog box for an object by double-clicking on the object's name in the Objects List of the
Scene Editor.

The Properties dialog box for the object appears.
4. Click the Actions tab.
The Actions dialog box appears.

(See To build an action your demo will perform for the steps.)



To set initial states for an object
Related steps

You use the General tab on the Properties dialog box to set initial states for an object.
Visible
Use this check box to make the selected object's initial setting either visible or invisible. In other words, when this object enters the

scene, do you want the viewer to see it or not?

3 Click Visible to make the object appear on the screen.
[ Unclick Visible to hide the object.
This is an initial setting only, and not permanent. You can create an action to show an invisible object or hide a visible object at any

time during the object's life.
Enable

Use this check box to make a button, hot spot, or other interactive object either active or disabled.

4 Click the Enable check box to make the object active.
3 Unclick the check box to disable the object.

You can create an action to enable a disabled object, or to disable an enabled object.



To set more than one action for the same event

Related steps  More about  Action Dictionary

1.
2.

Do not change the event.
Click the New Action button.

The Build Action dialog box opens, and whatever mouse or key event you selected appears in brackets within the message
"When the viewer [Left Clicks Mouse] perform the action”.

Click to open the combo box next to the message "perform the action”.
A list appears showing every action you can choose.

Point to an action on the list and click.

Repeat these steps to build as many actions as you want.



To set or change any type of property for an object

Related steps
1. Right-click the object in the Designer Window. Left-click on the words Object Properties.
The object's Properties dialog box opens.
2. Click on the type of property you want to change from the tabs that appear at the top of Properties dialog box.

If the property does not appear, right-click on any "“inactive" area of the dialog box to bring up a menu of tabs in the dialog. Left-
click on the tab you want to see.

The Properties dialog box opens for the type of property you selected.
3. Make edits as needed, then:

P Click another tab to set a different type of property for the same object, or
] Click OK to close the Properties dialog box



To set object styles for a Push Button, Radio Button, or Check Box

Related steps  More about

1. Create the button.
The object appears in the Designer Window surrounded by handles.
2.  Press Enter.
The Properties dialog box appears.
3. Click the Object Styles tab.
The Properties dialog box, Object Styles tab appears.
4.  Click one of the Styles radio buttons to choose the type of button you want.
5. Click to insert the text cursor in the edit field underneath Button, and type a caption.

Note: You can't change the caption for an OK or Cancel button. Use a Push Button instead.
6. Now you can:

» Click a different tab to change additional properties for this button
3 Click OK to close the Properties dialog box



To set demo shortcut keys

Related steps  More about

1. Choose Properties from the Demo menu.
The Demo Properties dialog box appears.
2. Click the Shortcut Keys tab.
The Choose Shortcut Key dialog box pops up.
3. Press the key or combination of keys you want your viewer to press.

You can make the shortcut key just one key. The key can be a letter, a number, the Esc key, or any of the function keys (F1-
F12). You can also make the shortcut key more than one key. For example, A+Alt, Alt+Shift+F10, Ctrl+Y.

The key(s) you press appears in the dialog.
4. Repeat the above steps until you are done setting the shortcut keys you want.
Click OK to return to the Demo Properties dialog box.
6. Click OK to close the Demo Properties dialog box.

o



To set the Auto Save time

Related steps  More about

1.

o gk WD

Choose Preferences from the File menu.

The Preferences dialog box appears

Click the Enable tab to open the Enable Preferences dialog box.

Click the Demo Auto Save check box to start using Auto Save if it is currently disabled (unchecked).
Click to insert the text cursor in the edit field.

Type the number in minutes you want between saves.

Click OK to close the Preferences dialog box.

In Windows 3.1, auto save files have the extension .AUT. So if the file name of the current demo is TUTORIAL.DBD,

DemosShield will automatically create a backup file named TUTORIAL.AUT, which you will find in the same subdirectory as
DESIGNER.EXE, the DemoShield program file. AUT files are complete demo files. If for any reason you cannot use your original
file, simply rename the AUT file with a .DBD extension: it will load just like any other demo file, and you are back in business again.

In Windows 95/NT, auto save files are named "Auto Save of .dbd". They can be loaded just like any .dbd file.



To set the Null Scene Color

Related steps  More about

1.

Choose Preferences from the File menu.

The Preferences dialog box appears.

Click the Null Color tab.

The Null Scene Color Preferences dialog box appears.

Click and drag the red, green, and blue sliders to mix and adjust the color.
Or click the slider arrow buttons.

A sample color appears in the Preview Window to the right.

Click OK to close the dialog box.



To set the Object Style properties for a Bitmap Button

Related steps
1 Create a Bitmap Button.

The object appears in the Designer Window surrounded by handles.
2. Press Enter.
The Properties dialog box appears.
3. Click the Object Styles tab.
The Properties dialog box, Object Styles tab for Bitmap Buttons appears.
4. Click to insert the text cursor in the edit field under Button Caption.
5. Delete the words inside and type the caption you want.
Now set the size of the button.
6. Click to insert the text cursor in the Width edit field.
7. Type a number in pixels.
8. Click to insert the text cursor in the Height edit field.
9. Type a number to set the button's height (in pixels).
10. Click a radio button in the Caption Position group to choose the position of the caption.
11. Click a radio button in the Appearance group.
You can choose either a standard, 3-dimensional Windows button, or a flat button appearance.



To set the Object Style properties for a Hot Spot

Related steps
1. Click the Object Styles tab.

The Properties dialog box, Object Styles tab appears.
2. Open the combo box.

Alist appears showing every cursor you can display when the viewer points to the hot spot.
3. Choose a cursor.

If you do not want the viewer's mouse pointer to change, choose None.

Now you can:

P Click another tab to set a different type of property for the hot spot.

] Click OK to close the Properties dialog box.



To set the Step and Jump buttons

Related steps
1. Point to any Step button--it makes no difference which one.
2. Right-click.
The Preferences dialog box appears.
3.  Click the Options tab.
The Options Preferences dialog box appears.
The Small edit field shows the current Step time in seconds. The Large field shows the Jump time.
4. Click to insert the text cursor in the Small edit field.
5. Type the number of seconds you want the clock to change when you click a Step button.

The new number you type overwrites the previous number. To erase anything you type in these fields, use the Delete or
Backspace keys.

6. Press the tab key to change the Jump time.
The highlight moves to the Jump Time field.

7. Type the number of seconds you want the clock to move when you click the Jump button.
To move back to the Step Time field, press Shift+Tab.

9. Click OK to close the Preferences dialog box.



To set the distance an object will move when you press an arrow key

Related steps
1. Choose Preferences from the File menu.
The Preferences dialog box appears.
2. Click the Options tab.
The Options Preferences dialog box appears.
3. Click to insert the text cursor in the edit field next to Width (in the Grid Settings group).
4.  Type the number of pixels you want the object to move.
For example, if you type 10, each time you press an arrow key the selected object will move 10 pixels.
5. Click in the Height edit field.
6. Type a number.



To set the properties for a scene

Related steps  More about

1. Right-click on any empty area in the Designer Window. Left-click on Scene Properties.
Or, choose Properties from the Scene Menu.
The Scene Properties dialog box opens.

2. Click on the tab for the property you want to set.



To set the properties for an Application Object

Related steps

1.

© NOo M

Note:

10.
11.
Note

12.

Double-click the name of the Application Object in the Objects list of the Scene Editor.

The Properties dialog box appears. Change the name of the Application Object if you want.

Click the Object Data tab.

The Object Data dialog box appears.

Click to insert the text cursor in the Executable field.

Type the path/filename of the application's executable file, or click the Browse box to browse for the .exe file.

Click to insert the text cursor in the Command Line Parameters field.

Type the path/filename(s) of any other file(s) you will need to add to the command line.

Add to the Command Line Parameters field any switches or options that you need to type on the command line.

Click to insert the text cursor in the Additional Required Files edit field, and type any other files you will run with the application.

We suggest that you enter in the Additional Required Files edit field not just the names of additional files you plan to run with
the application in this macro, but every file you intend to use in the macro, including any files you typed in the Command
Line Parameters field. DemoShield will make any files you enter here part of the DBD file when it saves the demo. This
saves you the trouble of copying these files separately to your distribution disks.

Uncheck (deselect) the Import Application Files box if you want to import your application and support files by reference. Make
sure the check box is selected if you want those files to be saved as part of your demo (.dbd) file.

Click the Options tab to open the Options dialog box.
Make any selections you wish to make to control how your application runs.

:If you are running a Windows 95 or Windows NT application, you must set the Windows Caption and Windows Class Name
fields under the heading Identify Application.

Click OK to close the dialog box.




To set the properties of a Variable Object

Related steps  More about

1.

Double-click the object's name in the Scene Editor.

The Variable Properties dialog box appears.

Click to insert the text cursor in the Name edit field if you need to change the variable's default name.
Click the tab for Variable Data.

The Variable Data dialog box appears.

Click Text if the variable you are creating will contain letters, or a combination of letters and numbers, like Sally Fields or 1992
Earnings, for example.

Click Numeric if the value of the variable is a number.

Click under Initial Value to insert the text cursor in the edit field. Initial Value is the value you want this variable to have starting
out.

You or the viewer can change this value at any time, according to how you build the demo.
Type a value for the variable.

For example, if you are creating a text variable and you want to give it a value of 1992 Earnings, type 1992 Earnings. If you
clicked Numeric and you want to enter a value of 241, you would type 241.

Click OK to close the Properties dialog box.



To set the screen capture keys

Related steps
1. Choose Preferences from the File menu.
The Preferences dialog box appears.
2. Click the Capture tab.
The Capture Preferences dialog box appears.
3. Click on the combo box next to the type of capture you want to make. For example, click on Active Window.
4. Choose any function key from F2-F12 to initiate the active window capture.
5. If you wish to capture the pointer (cursor) image, check the box marked Capture Pointer Image.



To set the size and location of your demo window

Related Steps  More about

1.
2.

Select Windowed playback style. (See To choose windowed playback style for the steps.)
Click on the Sizes tab.

If you do not enter numbers for the position and size of your demo window, the window will default to the size and location
specified in your current demo template.

Follow the steps below to draw a rough representation of the demo window you want your viewer to see in the "monitor screen"
that appears in the dialog box. The monitor screen represents the monitor on your viewer'’s desktop.

Left-click in the monitor screen at the position where you want the top left corner of your windowed demo to appear. Drag to
draw your new demo window. Unclick when your window is the roughly the size and position you desire.

To start over, simply left-click again in a new position.
Now that you have a rough size and location for your demo window, you can fine-tune your selections.

Type new selections for Window Position, or check the Centered box to have the window appear centered on your viewer's
screen. This will override any selections you made for Window Position.

Type new selections for Window Size.

Now that you have selected your window's size and location, you need to decide if you want the window to be Fixed Size or
not.

Select the Fixed Size check box if you want the size and location of your windowed demo to be absolute coordinates. That
means the coordinates you selected for your demo’s size and position on the screen will be the same on any resolution
monitor. Your demo (and the objects in it) will not scale, regardless of the screen resolution used.

Note The "monitor screen” will not redraw.
Click OK to close the dialog box.




To start a DemoShield session

Related steps

1. Windows 3.1 users: Double-click the Designer icon in Program Manager.
Windows 95/NT users: Click on the Start button, point to Programs, point to the DemoShield folder, and click on the Designer.
The DemosShield Designer launches and the Welcome dialog box appears.

2. To open the demo you were editing in your last session, click Open Your Last Demo.
The demo file you edited most recently appears in the Designer Window.
3. To open a different demo, click Open Existing Demo.
The demo file you selected appears in the Designer Window.
4. To create a new empty demo, click Create Empty Demo.
An empty demo file opens.
5. To create a new demo, click Create a New Demo.
The Demo Wizard launches.
6. Follow the steps explained by the Wizard for setting up your new demo.
When you are done, your new demo opens to its last scene.



To step or jump through a demo

Related steps  More about

To Step Back
Click the Step Back button to move back the current time on the Controller clock one step.
To Jump Back
3 Click the Jump Back button to move the current time on the Controller clock back one jump.
To Step Forward
Click the Step Forward button to move the current time on the Controller clock ahead one step.
To Jump Forward
Click the Jump Forward button to move the current time on the Controller clock ahead one jump.
To change how many seconds the Controller Clock jumps forward or back when you click the Large Step or Small Step Forward or
Back buttons on the Demo Controller, choose Preferences from the File Menu. To bring the Preferences dialog box onscreen
quickly, right-click one of the Jump Buttons on the Controller. Click on the Options tab.



To stretch or shrink every side of an object one grid unit

Related steps
1. Click the object.
The object appears selected and surrounded by handles.

2.  Toincrease all sides of the selected object one grid unit (one pixel by default), press the gray plus ( + ) key at the right side of
the keyboard. (See Grid Settings for the steps to change the grid unit.)

3. To shrink all sides, press the gray minus ( - ) key.




To stretch or shrink one side of an object using sizing handles (The Mouse)

Related steps

1. Click the object to select it.

Handles appear around the object. Use the handles at the corners to resize diagonally. Use the handles at the sides to resize
horizontally or vertically.

2. Point to one of the handles.
The pointer changes to a cursor with double arrows.
3. Click and hold down the left mouse button.
Drag the mouse.
As you drag, the handle you are dragging on moves with the mouse, changing the object's shape.
5. Release the button when the object is the size you want.

A



To stretch or shrink one side of an object using the sizing keys

Related steps
1. Click the object.
Handles appear around the object.

2. To stretch one side of the selected object one grid unit, hold down the Ctrl key while you press the up, down, left or right arrow
keys.

3. To shrink one side of the selected object one grid unit, hold down the Shift key while you press the up, down, left or right arrow
keys.



To test run a demo in the Designer

Related steps  More about

To test-run the entire demo
Click the Play Demo From the Beginning toolbar button.
To test-run the current demo with the Controller
3 Click the Play button.
The current scene starts playing at the current time.
To stop a demo that you are test-running
Click the Stop Playing button.
To test-run the current scene in the Designer Window
3 Click the Play Scene From the Beginning toolbar button.
To test-run the current scene full screen
Click the Play Scene in Full Screen Mode toolbar button.
To test-run a demo full screen from Control Menu
Choose Full Screen Play from the Control Menu.
To stop a demo you are test-running in Full Screen Mode
Press Esc.
You can also click a Pause/Continue VCR button to stop the demo and return to the Designer Window.



To test-run a demo using the DemoShield Player

Related steps  More about
You have two main options for running the Player

b You can quickly launch the Player from the Help menu. First, however, you must take a minute or two to specify the
demos that the Player will be set up to play. After these are set up, you can launch the demo you wish to play by selecting its name
from the Help menu.

. -You can exit the Designer and run the Player from Program Manager or File Manager (Windows 3.1) or the Shell

(Windows 95/NT).

Note By default, DemoShield demos are "topmost" windows. When the Keep Demo Always on Top property is enabled, and
you are playing a full screen demo in the Player, you will not be able to switch to another application, unless that application
is also in a topmost window. To disable the topmost function, choose Properties from the Demo Menu. Click on the Demo
Styles tab, and uncheck the box marked Keep Demo Always on Top.

Click below for more information.
3 To launch the Player from the Help Menu

[ To launch the Player from Program Manager or File Manager (Windows 3.1)

3 To launch the Player from your Windows 95/NT desktop




To turn Demo Auto Save on or off

Related steps  About

1. Choose Preferences from the File menu.

2. Click on the Enable tab.

3. Check the box marked Demo Auto Save if you want your demo to be saved automatically.

4.  Type in the number of minutes you want between saves (1-100).

] Windows 3.1 users: Your last auto save file will be saved as an .AUT file. It will be placed in the same directory as your
DESIGNER.EXE file. The last regular save of your demo will be in the same directory, with a BAK file extension.

[ 4 Windows 95/NT users: Your last auto save file will be saved under the name "Auto Save of filename.dbd". The last regular
save of your demo will be called "Backup of filename.dbd".

o

Uncheck the box marked Demo Auto Save if you do not want automatic saves.



To turn Large Image Preview on or off

Related steps
1. Choose Preferences from the File menu.
2. Click on the Enable tab.

3. Check the box marked Large Image Preview to be able to view your large image resources in the Manage Demo Resources
dialog box.

4. Uncheck this box if you do not want to preview large image resources.



To turn Tooltips on or off

Related steps
1. Choose Preferences from the File menu.
2. Click on the Enable tab.

3. Check the box marked Tooltips to turn on the small, yellow messages that appear when you place your cursor over any
function button in the Designer Window, including each object button in the Object Palette.

4. Uncheck the box to disable Tooltips.



To turn shortcut menus on or off

Related steps
1. Choose Preferences from the File menu.
2. Click on the Enable tab.

3. Check the box marked Shortcut Menus to enable the menus that pop up when you right-click on an object (or an empty spot in
a scene).

When you click on an object or scene when Shortcut Menus are deselected, the (object or scene) Properties dialog box opens.
4. Uncheck the Shortcut Menus box to disable these menus.

Note: When Shortcut Menus are deselected, you will also turn off the menu of tab selections that pops up when you right-click
within a Properties dialog box.



To type the text for a text object

Related steps  More about

1. Click anywhere in the text edit field in the Object Styles dialog box.
Atext cursor appears.
2. Delete the words "Right Click Here" and type the characters you want.

There is no need to press Enter at the end of a line. When the words appear on your demo screen they will wrap automatically,
like on a word processor. However, if you specifically want the text to break at any point and start a new line, press Enter.

3. Click OK when you finish typing the text you want.
The Object Styles Text dialog box closes.

Note You may add symbol fonts (trademark symbols, dashes, etc.) to your text by using the Character Map accessory in
Windows.



To use screen captures

Related steps

1. Create a closed Graphic Object, a Bitmap Button, or a new scene.
2. Click the Fill Styles tab and select the Image radio button.

3. Import your screen capture (Imagel, for example) as a fill.

Note: If you choose Shrink Image as your image option, your bitmap is likely to become distorted.
4. Create your Text and Graphic Objects to point to and describe parts of your screen capture bitmaps.

Remember to set the No Scale property as necessary to ensure that your Text and Graphic Objects display in the correct size
and position in relation to your bitmaps.

5.  You may also wish to create an Event Object to trigger move cursor actions timed to display with each new bitmap.



Using the Timeline Editor

4 To set Start, Hold, End, and Exit Times
2 To increase or decrease the time scale

[ 4 To open an object's properties dialog box




To view initial and current states for global variables

Related steps

1. Click on Current State in the Demo Properties dialog box, Globals tab to view the current settings for your demo's global
variables.

2. Click on Initial State to view the initial settings for your demo's global variables.
To reset the current settings back to the initial settings, check the Reset Global Variables box.

3. Click OK to close the Demo Properties dialog box, or click on another tab to view its properties.



Tooltips

Uncheck the Tooltips box in the Enable tab to turn off the small yellow messages that appear when you place your cursor over any
function button in the Designer Window.



To Send a Clicks Mouse Event

Use the Trigger Event action to send a left-click, left-double-click, right-click, or right-double-click event to another button.

For example, you can send a left-click from Button A to Button B. So when a viewer clicks Button A, the demo acts as if the viewer
clicked Button B.

You could also trigger a left-click event in an Edit Field Object. This simulates the viewer clicking in the edit field, prompting the
viewer to start typing when they see the cursor blinking there.

You can also use this action as a quick way to create a shortcut key (or hot key) for a button with multiple actions. Say you had 20
actions associated with a left-click event. Rather than build those same 20 actions for a shortcut key event, you could use the
Trigger Event action to trigger a left-click event when the shortcut key is pressed.

To send a Clicks Mouse event with Trigger Event:

1. Choose the action Trigger Event.
Three combo boxes appear.

2. Use the combo box marked Event to Set to choose the type of click event you want.
Use the Object combo box to choose the object you want to send the event to.

4. Use the Scene combo box to select the scene contains the object.



To Send a Moves Mouse on Object Event

You can use Trigger Moves Mouse to make an object think that the viewer’s mouse has been placed on top of it. This will cause an
action only if the (Hot Spot or Bitmap Button) has an action set for a Moves Mouse On Object event. You will not see the cursor
move.

For example, you can trigger an event that will make a Hot Spot believe that a Moves Mouse on Object event has occurred,
triggering the action(s) associated with it.

To send a Moves Mouse on Object Event:
1. Choose the action Trigger Event.
Three combo boxes appear.
2. Use the combo box marked Event to Set to choose Moves Mouse.

Use the Object and Scene combo boxes to select the object you are sending the Moves Mouse On action to, and the scene
containing the object.



To Send Time with Trigger Event

You can also use the Trigger Event action to make an object think it's earlier or later in the scene than it really is. Suppose you have
scheduled some actions to happen 72 seconds into the scene. You can use Trigger Event to make the object behave as if the scene
has been playing 72 seconds, even though it's only been playing 12 seconds.

To send time with Trigger Event:
1. Choose the action Trigger Event.
Three combo boxes appear.
2. Click to open the combo box for Event to Set.
A list appears showing every event you can set.
3. Choose Time.
An edit field appears.
4. Choose the object and scene.
5. Click to insert the text cursor in the edit field Set Time To.
DemoShield resets the object's clock to the number you type here.
. Type a number in seconds.
7. Click OK to close the Build Action dialog box.




Bitmap Buttons Object Styles properties tab

Use the Object Styles tab to set or change these properties for a Bitmap Button:

» Create the caption text for the button

2 Set the width and height for the button

4 Give the button either the 3-dimensional look of a standard Windows button, or make it a plain rectangle
3 Place the caption above, below, left, right, or inside the button

Steps

b To set the Object Style properties for a Bitmap Button



Comparison properties tab

Use the Comparison tab to compare two items of data. Here, for example, are a few types of data you can compare:

» The property of one object with the property of another object
See Object Properties

2 The values of two variables

2 The value of a variable with the value of a constant

After you have entered the data you want to compare, you can make actions happen in your demo depending on whether the
comparison is true or false.

Use the True Actions dialog box to make actions happen in the scene if the comparison is true, and the False Actions dialog to make
actions happen if the comparison is false.

Steps

b To create a comparison




False Actions properties tab
Use the False Actions tab to build one or more actions your demo will perform if the comparison is false.

Steps
3 To create a comparison




True Actions properties tab

Use the True Actions tab to build one or more actions your demo will perform if the comparison is true.
Steps
3 To create a comparison




Time properties tab

Use the Time tab to set the time in the scene when you want the action(s) to happen.
Steps
3 To create a timed action for an Event Object



General properties tab, Scenes

To open the Scene Properties dialog box, choose Properties from the Scene menu, or right-click on an empty area of the Design
Window.

Use the Scene General properties tab to set or change:

b Scene Name
(3 Scene Length--how many seconds the scene will play.
[ 2 Scene Transition--what the demo does when the scene ends. For example, you can switch to the next scene, restart the

current scene, or stop the demo.

Application Scene--click this check box to make the scene transparent. You can use a transparent scene, for example, to
run a different application in your demo or to create a tutorial or demo that teaches or advertises the application. To run an
application, you must create an Application Object.

Steps

» To change a scene's default name
] To change the length of the scene
] To choose a scene transition

’ To create a scene template




Visible

Choose this check box to make the selected object's initial setting either Visible or Invisible. You can make an object visible or
invisible in its current state or its initial state.

The object's initial state is how it appears when it enters the scene at its start time. (All objects are invisible outside of their lifespan.)

4 Click Visible to make the object appear on the screen.

(3 Unclick Visible to hide the object.

This is an initial setting only, and not permanent. You can create an action to show an invisible object or hide a visible object at any
time during the object's life.

Steps

3 To create a Show action for an invisible object

3 To create a Hide action for a visible object




Menu Captions tab

Use the Captions tab to:

» Set an upper title for your PopUp Menu.
3 Set a lower title for your PopUp Menu.
Steps

3 To create menu titles




Template Properties dialog box

Use the Template Properties dialog box to set an object's template properties. The Template Properties dialog box for an object has
exactly the same tabs and settings as the object's regular Properties dialog box, with the exception of the Size tab.

Options

3 Size tab

Steps

3 To change the template properties for an object




Variable Data properties tab

Use the Variable Data tab to make the variable either numeric or string, and to enter its value.
Steps
3 To set the properties of a Variable Object



Enable

Choose this check box to make an Event Object, button, hot spot, or other interactive object either active or disabled.

» Click the Enable check box to make the object active.

3 Unclick the check box to disable the object.

You can enable or disable an object in its current state or its initial state.

If you disable the object in its initial state (when it first appears on the scene at its start time), it will remain disabled until you create
an action to enable it. You can use the Enable/Disable actions to enable or disable an object when your viewer performs some
event, like clicking a mouse or pressing a key. Or, you can switch an object's Enable/Disable status automatically by using an Event
Object to trigger the Enable/Disable action.

Note: If you disable an Event Object, you disable the actions triggered by it.




Jump Mark

Choose this check box to place a Jump Mark on an object. At any point in your demo, you can switch to the next object or previous
object that has a Jump Mark.

You can use a Jump Mark with or without interaction from your viewer. Instead of going to the next Jump Mark when your viewer
clicks a button, you could create an Event Object and build an action for an Event Object to make the demo go to the next or
previous Jump Marked object.

There is no limit to the number of Jump Marks you can place in a scene to allow you to bounce back and forth from one object to
another, creating all sorts of effects--hiding text, displaying graphics, or restarting the scene.

It's essential when you create any object to decide whether you want to make it visible or invisible, enabled or disabled. However,
unlike Visible and Enabled, a Jump Mark is optional. In some situations you may find using a Jump Mark is the best way to get the
results you want. At other times, you might decide it's easier to accomplish what you want simply by switching to a different scene.

To make your demo go to the next or previous object that has a Jump Mark, use the Go to Next Jump Mark or Go to Previous Jump
Mark actions.



No Scale
Use this check box to ensure that the size and position of an object remain the same under any screen resolution.

» Check the No Scale check box to turn scaling off.

3 Uncheck the No Scale box to allow the object to scale.

If you leave the default scaling on, all or part of an object (such as a text object or line object) will grow larger or smaller to scale to
the resolution of the screen on which the demo is played.

In general, you will find that allowing objects to scale will produce the best visual results. However, if you are layering objects (such
as placing an arrow over a bitmap) you will need to select the No Scale option for both objects. This will ensure that their relative
positions will not change.

Note: If you are creating a fixed size Windowed demo, you do not need to enable the No Scale option for your layered objects. No
objects will scale in a fixed size demo.



Arrow Styles properties tab

Use the Arrow Styles tab to choose:

» Whether you want an arrow head

2 The type or style of arrow head

[ 4 A narrow or an indented arrow head at the beginning and/or end of the line
Steps

4 To choose an arrow style for a line



AVI Object Styles properties tab

Use the Object Styles tab to choose the AVI resource you will run, and its Start Time and Exit Time.
Steps
3 To choose an AVI resource




Actions properties tab

Use the Actions tab to set up the action(s) you want to happen when your viewer interacts with the object. You also use this tab to
choose the mouse or shortcut key event that the viewer will provide to trigger the action.

Steps
b To choose a mouse event
2 To choose a shortcut key event

» To choose an action




Application Object, Object Data properties tab

Use the Object Data tab to:

Choose the executable application file you will run
Type command line parameters
Enter any additional files you need to run with the application
Choose to import the application and support files into the demo file, or to import them by reference.
Choose to store your path to your executable file
teps
To choose application and support files to launch
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Background Color properties tab
Use the Background Color tab to set the background color of an object (or scene).

Steps
2 To choose a color




Border Color properties tab
Use the Border Color tab to choose the color of a border.

Steps
2 To choose a color



Edit Field Object Styles properties tab
Use the Object Styles tab for an edit field object to:

Align the text left, right, or center
Make the text all caps, upper- or lowercase, or both
Scroll text that is too long to fit in the edit field window
Choose Password Blanking (if the viewer types a password, the characters will not appear onscreen)
Set a Maximum Length of characters the viewer can type
teps

TOFTYFTYVYwW

To create an Edit Field Object




Fill Color properties tab
Use the Fill Color tab to select a fill color for an object or a scene. You must select a fill color if the fill style you are using is either a
pattern or a wash.

Steps
b To choose a color




Fill Styles properties tab

Use the Fill Styles tab to select a fill style for an object or a scene. You can select transparent, solid, pattern, wash, and image fills.

Steps
2 To choose a fill style

» To display an image in a Graphic Object, Bitmap Button, or Scene




Font properties tab
Use the Font tab to choose the font, font size, and font style for the text.

Steps
2 To choose a font




Font Color properties tab
Use the Font Color tab to choose the font color for the text.

Steps
2 To choose a color




Hot Spot Object Styles properties tab
Use the Object Styles tab to set or change the type of cursor that appears when the viewer points to the hot spot.

Steps
2 To create a hot spot

» To set the Object Style properties for a hot spot




Life properties tab

Use the Life tab to set the following times:

» When you want the object to enter the scene

2 When the object will reach its "hold" position on the screen
4 When the object will begin to exit the scene

3 When the object will finally disappear

For more information, see What is Life?
You also use the Life tab to set how you want the object to move in and out of the scene.
You do this by setting motions and effects. Will the object:

(3 Fade in and disappear all at once?
[ 4 Appear from the right, and disappear to the left?
Steps

To set an object's Start, Hold, End and Exit times:
b To set motions and effects




Line Styles and Border Styles properties tab

Use the Line Styles tab or Border Styles tab to choose the type of line or border line you want to appear.

The line displayed can be thick or thin, broken or solid. For border styles, you may choose to display no border. You may also add
shadow to a text border.

Steps

3 To choose a line style

b To choose a border style




Push Button, Radio Button, and Check Box Object Styles properties tab

Use the Object Styles tab to:

» Choose whether you want to make the button a push button, radio button, check box, OK button, or Cancel button.
3 Type the caption.

Steps

3 To create a Radio Button, Check Box, or Push Button

4 To set styles for a Radio Button, Check Box, or Push Button



Text Object Styles properties tab
Use the Object Styles tab to:

» Type the text you want to display
Align the text
4 Create a margin around the text
3 Import and format a Rich Text Format (RTF) file

The Options button opens the Text Options dialog box.
Steps

To create a Text Object

To type the text for a Text Object

To align text

To create a margin

To import an RTF file
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VCR Object & Menu Object Styles properties tab
Use the Object Styles tab to:

» Enable or disable each individual VCR or PopUp Menu button
2 Set the caption for each VCR or PopUp Menu button
[ 4 Create the action(s) you want to happen when the viewer clicks each VCR or PopUp menu button

Steps for VCR Buttons

To create VCR Buttons

To enable or disable a VCR Button

To change any setting for a VCR Button
To change VCR button captions

To change the action for a VCR Button

To display symbols instead of words on VCR Buttons
3 To change both Pause and Continue captions

[ To change from two Pause/Continue captions to a single caption
Steps for PopUp Menus

To create or change a caption on a menu button
b To build the action for a menu button
2 To enable or disable a menu button
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Application Object, Options tab
Use the Options tab to set a number of options to control the use of applications in your demo. Most of these selections are optional.

However, if you are demonstrating a Windows 95 or Windows NT application, you must set the Windows Class Name and Windows
Caption fields, located under Identify Application.

Identify Application
Maximize Application

Position Application
Allow User Interaction

Application Termination

bl e i




General properties tab

The General Properties tab is the first tab to appear when you open an object's Properties dialog box for the first time. Use the
General properties tab to enter or change the object's name and other important settings listed below. Note: Not all objects will
have all of these General properties.
Options
Name
Group Name
Visible
Enable
No Scale

Jump Mark
Menu Object, Captions tab

To create menu titles

TV Tryw
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Steps
b To set initial states for an object



Line Color properties tab

Use the Line Color tab to set the color for a line.

Steps
2 To choose a color




User information we need

Please have this information ready when you call:

The name of the registered DemoShield user
Your name

Your company name

The version of DemoShield you are using
The operating system you are using

The serial number of your DemoShield disks
When you call, be in front of your system and ready to try any commands.

If you miss us or we are helping other customers when you call and need to leave a message, here is a sample message:
"I need technical support on DemoShield version 4.0 for Microsoft Windows version

My name is

My company name is

The best time to reach me is
My phone number is

The DemosShield technical support hotline is:
1-708-240-9135

Ty w

Note: Please use this number only for urgent technical support. Do not call any other InstallShield Corporation nhumber for
technical support.

Click to read about:

3 Technical Information We Need




VCR Buttons

Creates a row of buttons on your demo screen that looks like the controls on a videotape recorder. Your viewer can click the buttons
to move ahead or back in your demo, to pause/continue the demo, to return to a menu, or to stop the demo. You can change what
happens when the viewer clicks any of these buttons, and change the caption for any button.
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Video for Windows

Video for Windows is Microsoft's video screen capture and editing package. Use it to create video captures of your running
applications. These files are saved in the AVI format. Refer to the Knowledge base for the latest information on obtaining Video for
Windows.



WAVE file

Microsoft's standard file format for storing waveform audio data. WAVE files have the filename extension .WAV. You can play any
WAVE file in your demos using the Play Sound action.



What are resources?

A separate and unique group of data that you import into DemoShield for a specific purpose in your demo. Resources include but
are not limited to:

Metafile (WMF) images you can display in Graphic Objects or scenes

Bitmap (.BMP) and screen capture images you can display in Bitmap Buttons, Graphic Objects, or scenes

Rich Text Format (.RTF) files you can display in a text object

Macros and application (EXE) files that you run with your demos

Sound (WAV) files you play in your demos

Scenes and resources from other demos

Audio Video Interleaved (AVI) and Lotus ScreenCam (SCM) files you use to play a video sequence in your demo.

To import and keep track of the resources in your demo, use the Manage Demo Resources dialog box.

Steps

3 To open the Manage Demo Resources dialog box and look at any file

b To delete a resource

3 To preview a resource

[ To import a resource
4
g
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To export a resource

To import resources and/or scenes from a different demo
] To import an RTF file




What is Action?

An action is anything you make your demo do automatically on its own, or when your viewer presses a key or clicks the mouse.

For example, you can make your demo play the next scene automatically after 10 seconds, or when your viewer clicks a button that
says Next.

Actions that happen when your viewer presses a key or clicks the mouse are created through the use of interactive objects. These
objects include buttons, hot spots, and VCR Buttons. This type of action is called interaction.

Anything your viewer does using the keyboard or mouse is an event. One of the ways you make things happen in your demo is to
link one or more actions to an event.

Actions that happen automatically (independent action) are created through the use of an Event Object. With independent action,
the Event Object creates the event. An Event Object can trigger actions that happen automatically, actions that happen at a
particular time, or actions that happen only when a certain condition is met.

The actions that you can create are the same whether they are triggered by viewer interaction or an event object.
For a list of all the actions you can create, see the Action Dictionary.

Steps for Building Interaction (Interactive Objects)

2 To build an action your demo will perform

] To choose a mouse event

[ To choose a shortcut key or combination of keys

3 To see all the events and actions you've built

[ To set more than one action for the same event

3 To edit an action you have already set

] To remove an action

» To build an action in one scene that happens in a different scene
] To create an action for a group

Steps for Building Independent Action (Event Objects)

4 To make an action happen automatically
3 To build an action that happen every time your demo plays

3 To create a timed action

[ To create a comparison

3 To edit an action you have already set
] To remove an action

» To build an action in one scene that happens in a different scene
] To create an action for a group




What is life?

Every object has a lifespan. For example, an object's lifespan could be from 5 seconds into the scene until 10 seconds into the
scene. If the scene time is either before or after that 5-second time period, you will not see the object on the screen. It "exists" only
in its lifespan.

An object does much more than simply appear and disappear. For each object you create, you'll need to set:

3 When the object first starts to appear

4 How the object makes its entrance

(3 How long the object takes to enter

[ 4 How long the object stays on the screen

(3 What the object will do while you can see it on the screen
3 When the object begins making its exit

» How long the object takes to exit

g
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When the object finally disappears
here are four points in time in an object's life:

What Happens

Time

Start When the object first starts to appear

Hold When the object reaches the position where you created it
End When the object begins making its exit

Exit The time when the object finally disappears from view

Using these points in time, we say the object's life has three periods:
Start to Hold: the Start Period
4 Hold to End: the Hold Period
2 End to Exit: the End Period
After you set the Start, Hold, End, and Exit times for your object, you can set motions and/or effects for the Start, Hold, and End
Periods.

Steps

3 To move an object Into a scene

] To move an object out of a scene

] To create an effect for an object

3 To set an object's Start, Hold, End and EXxit settings

[ To edit an object's properties outside its time period
3 To resize an object outside its life




What is a scene?

A scene is nothing more than a blank screen that you create and fill with Text Objects, Graphic Objects, and other objects, such as
VCR Buttons. You decide how many seconds the scene will last (Scene Length), and what will happen when the scene ends (Scene
Transition). For example, when the scene finishes playing, the demo can switch to a different scene, or pause until a viewer to clicks
a button.

A demo may contain up to 256 scenes.

You can control a scene's properties, length, and how to change from one scene to another.

Scene Properties Tabs

2 General

b Fill Styles
Background Color
Fill Color

0n v
-
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o
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To create a scene

To change from the current scene to a different scene

To display the Scene Editor
To open the Scene Properties dialog box

To change a scene's default name
To change the length of the scene
To choose a scene transition

To choose a fill style

To choose a background color
To choose a fill color

To change the properties of the scene template
To create a new scene template

To display the Scene Sorter
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What is an Object?

Everything you put on your screen is an object. A scene can contain up to 256 objects. You use the Object Palette to create objects.

How an object looks and acts are its properties,which you set using the Properties dialog box. Each object has its own Properties
dialog box. Most of the steps for setting an object’s properties are identical no matter what the object is. For example, you choose

the Background Color for a Bitmap Button exactly the same way you choose the Background Color for a rectangle, or the Fill Color
for a font.

For details about working with objects, click a topic below.
Steps

3 Adding Objects to a Scene

b Objects Dictionary




Which Resolution Should | Choose?

When you play your demo in a screen resolution different from the resolution you used to create the demo, you can expect the size
and location of the objects on the demo screen to change. How they change depends on the objects. Fonts change in proportion to
screen size, for example, but objects like VCR Buttons and the PopUp Menu remain the same size in any resolution. It is important
to anticipate and prepare for these changes in creating your demos.

The general rule is this: Create your demo in the smallest resolution possible. This is because demos rescale up more reliably than
they rescale down If you create a demo on a small screen and play it on a large screen, your objects that scale are more likely to
appear proportionally in the correct size and location than if you create large and play small.

Because of this create small, play large rule, the default new demo resolution is 640 x 480.

In addition to choosing the proper default new demo resolution, you may want to consider setting the No Scale property for objects
which are layered on top of each other.

To ensure that you are viewing and editing your objects in a What You See Is What You Get (WYSIWYG) mode, you should also
enable the Scrollable Design Window view.



Why did my objects move out of alignment?

When you use the Player to test-run your demos, you may find that some objects seem to be out of place. They don’t appear to be
the same size, or in the same relative position, as they were in the Designer Window. What happened?

Unless you are creating a Windowed demo, your demo will play full screen. DemoShield scales your demo to fit the resolution of the
screen it is being played on.

For most users, the Designer Window is considerably smaller than their full screen view. Thus, objects that appear close together in
the Designer Window will appear larger and more spread out when played full screen.

Most of the time, this does not negatively impact the demo. However, if you are layering objects on top of one another, such as
arrows stacked on top of a Graphic Object, you will need to do something to disable scaling.

You can disable the scaling of individual objects, or the scaling of all the objects in your demo.
How to:

b Control Demo Scaling

3 Control Object Scaling




Will my colors look OK on all systems?

Related steps
For the purpose of creating demos, you need to concern yourself with only two types of color systems: systems that use 256 colors,
and all other systems.

Note To create demos that use a 256-color system, you will need to test-run your demos on a 256-color system to discover any
color problems.

16-Color Systems
DemosShield operates normally on a basic 16-color system, and there are no restrictions of any kind to keep in mind as you develop
demo for 16-color systems or using only 16-color images. If you use an obscure color, DemoShield displays a dithered color instead.

True Color Systems

Systems that display from 32,000 up to 16 million colors use true colors. Each color has its own RGB value. Your viewer will have no
difficulty seeing these colors exactly as you created them.

256-Color Systems
Many of your viewers will watch your demo on a 256-color system. There are constraints and restrictions to keep in mind when you
create a demo on and for a 256-color system.

Color in Application Scenes

When you create an Application Scene to run a software application in your demo, DemoShield makes the scene transparent so
your viewer can see the application running underneath. In an Application Scene, the application you are running controls the color
palette, not DemoShield. As a result, your objects appear in 16 standard dithered colors.



Window Size

To modify the size of the window, type in new Width and Height selections (in pixels). The width of the window must be 100-640
pixels. The height of the window must be 100-480 pixels. In other words, the window must be equal to or smaller than VGA
resolution. The window size you specify will override the native demo resolution.



Window Under Pointer

Captures the smallest active window, including transitory windows. Use this capture option if you need to capture menus, edit fields,

or other transitory windows. Depending on the type of window being captured, you may capture only the very smallest transitory
window, or the whole dialog box with the open transitory window.



Window position

To modify the position of the demo window, type in new X (horizontal) and Y (vertical) coordinates. If you want the demo to be
centered on the viewer’s screen, check the Centered box at the bottom and ignore the X and Y coordinates.



windowed demo

A windowed demo plays in a window on your viewer's screen, instead of full screen. You select the size of the window. The window
can be 100-640 pixels wide and 100-480 pixels high. Use the Demo Properties dialog box, Demo Styles tab (or the Demo Wizard) to
create a windowed demo. If you check Fixed Size in the Demo Properties dialog box, Size tab, your demo will always remain the
same absolute size. This means no objects in your demo will scale.



Windows Caption

Your Windows Caption is simply the name of the main application window controlled by DemoShield.



Windows Class Name

Windows Class Name refers to the Windows classification for the main window of your application. Ask your developer for the class
name, or use a product such as Microsoft's Spy to determine the Windows class name.



X-axis or coordinate

An object's horizontal position on the screen in pixels.



Y-axis or coordinate

An object's vertical position on the screen in pixels.



action

An action is anything you make your demo do automatically on its own, or when your viewer presses a key or clicks the mouse.
Anything your viewer does using the keyboard or mouse is an event. One of the ways you make things happen in your demo is to
link one or more actions to an event. (For more information, click What is Action?)



application

A computer program that you use to perform specific, practical work. Word and data processing, spreadsheet, desktop publishing,
income tax, and presentation graphics programs are all examples of applications. Application file means the main file that runs the

program. Because this file is capable of running independently on its own, it is also called an executable file and usually has the
filename extension .EXE.



arrow keys

The keys with up, down, left and right arrows that you use to move the cursor in a word processing or spreadsheet program. In

DemoShield you can use the arrow keys to nudge an object you've selected to reposition it in the Designer Window. You can also
use the arrow keys with the Shift or Ctrl key to shrink or stretch an object.



bitmap

A graphic or textual image, made up of tiny dots called pixels, generated and saved on a computer. Bitmap file names have the
extension .BMP. The screen captures you can make using DemoShield are bitmaps.



border style

The type of border you choose for an object. Suppose, for example, you have created a rectangular Graphic Object. An object's
border surrounds the object like a frame around a picture. You can choose a border that is a thick line or a thin line, a broken line or
a solid line, or two lines instead of one. Use the Border Style Properties dialog box to set an object's border style.



bring

When you place more than one object in the same place onscreen, they create a pile or stack, and one of the objects can cover up
and hide another object. You can use the Sort Buttons in the Scene Editor to bring a hidden object to the front, or closer to the front
of this stack, so the object is no longer hidden from you or the viewer.

See send,



button

When you see the word button in this User's Guide without anything more to describe it, the button can be a standard Windows
push button, a radio button, a check box, or a bitmap button.



Cancel button, Scene Sorter

Cancels all selections and closes the Scene Sorter. To save your selections before closing, press OK.



caption

Text that can appear on a button or the title bar of a window.



caption for windowed demo

Choose a caption for your windowed demo if you want your viewers to be able to move the demo window around on their screens.
Use the Demo Properties dialog box, Demo Styles tab to select a caption option. You can type a caption for the window, or select
Use Scene Name for Caption. If you choose Eliminate caption, the window will remain in a fixed location on the screen.



check box

A check box is a standard Windows button used to make selections, primarily in a dialog box. When a check box is pressed
(selected), an X appears inside it.

Shown below are examples of two DemoShield Button Objects set to the check box style.

[ 1Check Box {unpressed)

(JCheck Box (pressed)



combo box
A horizontal box onscreen that you can open to display a list of choices. To the right of the box there is a button with an image of an
arrow pointing down.

When you click the button, a list of items appears underneath the box. The items on this list show the choices you can select. To
choose an item, click the item. The item you select appears in the horizontal box above the list.

If the list is too long, or the items too wide, to display all at once, scroll bars appear that you can use to search for the item you want.



AVl or :

Create an AVI object to play an Audio Video Interleaved (AVI) file in your demo. You can also play an AVI file in your demo using the
Play Video action without creating an AVI Object.

Steps

» To create an AVI Object

3 To import an AVI file




Align Horizontally

Aligns selected objects horizontally.
» Before
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Align Vertically

Aligns selected objects vertically.
» Before

..

After



Align to Bottom

Aligns selected objects to the bottom object.
» Before




Align to Left

Aligns selected objects to the object farthest left.
» Before
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After



Align to Right
Aligns selected objects to the object farthest right.
» Before




Align to Top
Aligns selected objects to the top object.
» Before

2 After



Aligning Tools, Object menu

These menu choices are the same as the buttons on the Aligning Tools palette.

Space Vertically
Space Horizontally
Align Vertically
Align Horizontally
Align to Left

Align to Right
Align to Top

Align to Bottom
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O+

Aligning Tools or =2

Choose this command to displays the aligning tools. Clicking the Aligning Tools toolbar button is the same as choosing Aligning
Tools from the View Menu.



Application or

Creates an Application Object. This selection is disabled until you click the Application Scene check box in the General tab of the
Scene Properties dialog box. For information on creating an Application Object, see Live Application Demos.




i

Clicking the Apply Properties toolbar button is the same as choosing Apply Styles from the Edit Menu.
Steps
3 To apply styles to an object

Apply Styles or




Choose Arrange Tools from the View menu to arrange the following tools neatly on the DemoShield screen: the Scene Editor, the
Demo Controller, the Object Palette and the Aligning Tools.

Arrange Tools automatically moves any tools and palettes you are currently using to the right edge of the screen, and optimizes their
arrangement. If your DemoShield window is large enough, the palettes appear in this order starting at the top:

Arrange Tools or

2 Scene Editor

[ 2 Demo Controller
» Aligning Tools

3 Object Palette
Steps

4 To optimize the arrangement of tools and palettes



Bitmap Button or
Creates a 3-dimensional Windows button that you can use to display an image, a caption, or both.

Steps
2 To create a Bitmap Button




Bringing and Sending

When you place more than one object in the same place onscreen, they create a pile or stack, and one of the objects can cover up
and hide another object. You can choose Bringing and Sending from the Object menu or use the Sort Buttons in the Scene Editor to
bring a hidden object to the front, or closer to the front of this stack, so the object is no longer hidden from you or the viewer. or to
send an object in front farther back in this stack, to hide the object, or to bring a different object into view.

Steps
4 To bring the selected object forward or send the object back



Button or %

Use this to create either a push button, radio button or check box. After you create the button you can also choose from the
Properties dialog box, Object Styles tab to create an OK or Cancel button automatically.

Steps

b To create a radio button, check box, or push button object




Cascade

Arranges your demo windows so they overlap one another displaying only the title bar of each window except the one on top. In this
version of DemoShield it is possible to display only one demo at a time in the Designer Window.



Clear Selection

Deselects the currently selected object(s).



Close

Choose Close when you are done editing to remove the current demo from the Designer Window. If you changed the file after
loading it, a prompt appears asking if you want to save your changes.



Contents (or F1)

Opens the main contents screen of the DemoShield Help file.



Controller

The clock on the Demo Controller keeps time as your demo plays. You can reset the clock forward or back either a step or a jump--
that is, either a little or a lot--or you can use the slider bar to move the clock quickly either way.

Steps

3 To test run a demo




Copy
Use Copy to create an identical copy of one or more objects in the same scene or in a different scene.

Hint: Instead of choosing Copy from the Edit Menu, you can use the standard Windows shortcut keys for Copy.
Steps
3 To copy an object or more than one object




Create New Demo

When you choose Create New Demo from the Welcome dialog box or choose New from the File menu, the Demo Wizard launches.
Follow the steps shown to create a:

P One Scene Empty Demo

] Copy of the "Default.dbd" demo

» New demo with a specified number of scenes
Steps
b To create a new demo




Cut

Deletes the selected object(s). The object you cut is placed in the Clipboard and you can paste it in any scene of the demo.

Hint: Instead of choosing Cut from the Edit Menu, you can use Ctrl+C.



Delete

Deletes the selected object(s). Unless you undo the procedure, Delete permanently deletes the selected object(s).

You can reverse the delete action and reinstate an object you have deleted by choosing Undo from the Edit Menu. Undo will not
work, however, if you perform any of these actions after using Delete:

Creating a new scene
Deleting a scene
Creating a new object
Moving an object
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Delete Scene

Deletes the current scene. Selecting Delete Scene from the menu is the same as clicking the Delete Scene button on the Scene
Sorter.



Demo Controller

To open the Demo Controller, choose Demo Controller from the View Menu. When you are displaying the Demo Controller, a check
appears next to Demo Controller on the View Menu. To remove the Demo Controller from the screen, choose Demo Controller from

the View Menu.



Duplicate or IE

Copies the selected object(s).

Steps
b To duplicate an object




(5

Creates a new scene that is a duplicate of the current scene. Clicking this button is the same as choosing Duplicate from the Scene
Menu.

Duplicate Current Scene or




. |abl
Edit Field or
Creates an Edit Field Object. Use an Event Object to process the characters your viewers type into an edit field.

Steps
3 To create an Edit Field Object




Edit Properties
Opens the Properties dialog box for the selected object.

Steps
2 To open the Properties dialog box




Event or F

Creates an Event Object. Use an Event Object to make some action happen in your demo automatically,without any viewer input.
You can create any action with an Event Object that you can with an interactive object. For example, you could switch to a different
scene, display or hide text, or pause or restart a demo.

Steps
2 To create an Event Object




Exit

Choose Exit to end the current DemoShield session.



Full Screen Play or
Test-runs the current demo in full screen. Clicking the Play Scene in Full Screen Mode toolbar button is the same as choosing Full
Screen Play from the Control Menu.

Steps
» To test run a demo




Go to Scene

Choose Go to Scene to make a different scene in your demo the current scene.
Steps
4 To change from the current scene to a different scene




Graphic

Choose Graphic from the New Object Menu or one of the buttons below from the Object Palette to create these Graphic Objects:
Ellipse (circle)

E
Rectangle

Rounded Rectangle
Polygon

Steps

» To create a Rectangular, Rounded Rectangular, or Ellipse Object
b To create a Polygon Object




Creates a Group Object. You may want several individual objects to behave onscreen as if they were a single object. The easiest
way to do this is to create a Group Object that contains the individual objects. For example, you might want a number of graphic
elements to enter, then disappear from a scene at precisely the same instant.

Steps

b To create a Group Object

Group or




Hot Spot or }

Creates a Hot Spot Object. A hot spot is a sensitive area on the screen that you can click to initiate some action. In DemoShield, for
example, you can create a hot spot that your viewer can click to bring a menu onscreen, display a window with special information,
or switch from one scene to another.

Steps

[ To create a Hot Spot




Import Demo
Use Import Demo to import resources and/or scenes from a different demo into the current demo.

Steps

4 To import resources and/or scenes from a different demo



Invisible Objects

Choose this item from the View menu to view invisible objects.
When invisible objects are visible, they have handles.

The name of an object, visible or not, always appears in the Objects list of the Scene Editor. You can click the object name to select
it and open its Properties dialog box.

Steps
2 To make invisible objects visible




Jump Back

Moves the current time on the Controller clock back one jump. Jump Back works like Jump Forward.



Jump Forward

Moves the current time on the Controller clock ahead one jump.
To set the amount of time the clock moves forward or back per "jump" choose Preferences from the File menu.
Click on the Options tab.



Jump and Step

Use these menu choices to reset the Controller clock forward or back by either a small or large amount of time. When you change
the time by a small amount, we call it a step. When you change the time by a large amount, we call it a jump. To change the default
times for steps and jumps, choose Preferences from the File Menu.

Steps

2 Jump Forward
b Jump Back

4 Step Forward

b Step Back



~\

Line and Poly-Line
P Objects

Choose Line or Poly-Line from the New Object menu or the Object Palette to create a Line Object or Poly-Line Object.

Steps
b To create a line
2 To create a poly-line




Load Template
Choose Load Template to open an existing template file and begin applying its properties to any new objects you create for the
current demo. Objects you have already created will not be changed by the new template.

Steps
b To load a new template file




Manage Demo Resources

Choose Manage Demo Resources from the Demo menu to open the Manage Demo Resources dialog box. Use it to review data for,
import, export, preview, and/or delete:

Images in bitmap and metafile format, including screen captures

Text in Rich Text Format

Macros

Application (.EXE) and support files

AVI and SCM video files

Sound files in WAV format

teps
To open the Manage Demo Resources dialog box and look at any file
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Menu or
Choose Menu from the Object Menu or the Object Palette to create a PopUp Menu. -
Steps

b To create a PopUp Menu




Move Object Down

Sends the selected object one layer farther to the back.

Steps
4 To bring the selected object forward or send the object back



Move Object Up

Brings the selected object one layer closer to the front.

Steps
4 To bring the selected object forward or send the object back



Move Object to Back

Sends the selected object to the back of the stack.
Steps

b To bring the selected object forward or send the object back



Move Object to Front

Brings the selected object to the front of the stack.

Steps
4 To bring the selected object forward or send the object back



Move Scene Down

Changes the position of the current scene so that, when the demo plays, the current scene appears later in the sequence of scenes.
Choosing Move Scene Down from the Scene menu is the same as clicking the "Moves Scene Later in the Sequence" button on the
Scene Sorter.



Move Scene Up

Changes the position of the current scene so that, when the demo plays, the current scene appears earlier in the sequence of
scenes.

Choosing Move Scene Up from the Scene menu is the same as clicking the "Moves Scene Earlier in the Sequence"” button on the
Scene Sorter.



New Object

Choose New Object to create and place a new object in the current demo scene. The New Object menu choices are the same as
the buttons on the Object Palette.
Objects
b Application
AVI
Bitmap Button

b
b
3 Button
b
g

Edit Field
Event
[ Hot Spot
b Group
2 Graphic
Line
Menu
Text
Variable
VCR

T w



New Scene or }
Creates a new scene. Clicking the Create New Scene toolbar button is the same as choosing Create New Scene from the Scene
Menu.

Steps
b To create a scene




Next Scene

Makes the next scene the current scene in the Designer Window.



Null Scene Color

If your viewer's monitor is bigger or smaller than the one you used to create the demo, the size of your running demo will change.
No matter what size your demo window appears on your viewer's screen, however, DemoShield always displays the demo
proportionately. If DemoShield cannot fill your viewer's entire screen with your demo and still display all your text and graphics
proportionally, it will fill any remaining area on the screen with the Null Scene Color.

Steps
4 To set the Null Scene Color




Object Palette

Opens the object palette: a panel with buttons that you use to create objects. The Object Palette appears by default at the right side
of your DemosShield screen, but you can drag it elsewhere. There is a button on the palette for each object you can create. To create
an object, click the button for the object you want, then click in the Designer Window.

Steps

b To create an object




'}

Open orE

Choose Open to open an existing demo file and display the demo in the Designer Window for editing. Clicking the Open Demo
toolbar button is the same as choosing Open from the File Menu.

Steps
b To open an existing demo file




Paste

Use Paste to place in the Designer Window one or more objects that you have copied. With the Paste command you copy all links
that you created for the original object(s).

Tip: Instead of choosing Paste from the Edit menu, you could press Ctrl+V.

Steps

4 To paste object(s) you have copied



Paste Special

The Paste Special command pastes objects you have copied, just like the Paste command, with this one difference: the Paste
Special command preserves only those links you have created for an object's Start, Hold, and End periods using the Life Properties

dialog box.
Steps

2 To paste object(s) you have copied



Pick Up Styles or ]
Use Pick Up Styles when you copy all the properties from one object and apply them to a different object. Pick Up and Apply Styles
always work together.

Steps

b To pick up (copy) styles from an object




Play
Plays the current scene starting with the current time on the Controller clock.

Steps
4 To test run a demo




B

Plays the current demo from the beginning. Clicking this button is the same as choosing Restart from the Control Menu.

Play Demo or




Play Macro

Use Play Macro to play a macro file you have recorded and saved in DemoShield.
1. Choose Play Macro from the Demo menu.

The Play Macro dialog box opens.

The dialog will show each macro you have saved. The macro resolution will appear in brackets after the name.
2. Click Play to play the macro.

Click Cancel to cancel the macro play.



Play Scene or
Plays the current scene from the beginning in the Designer Window. Clicking this button is the same as choosing Play Scene from
the Control menu.

Steps
» To test run a demo




Preferences

Choose Preferences from the File Menu to open the Preferences dialog box and customize a number of default settings that control
the way DemoShield looks and works on your system. For the steps on how to change each of the Preferences settings, see Setting

Preferences.



Previous Scene

Makes the previous scene the current scene in the Designer Window.



Properties, Demo menu

Related Steps  More about

Demo Properties are varied settings that apply to the demo as a whole. Choose Properties from the Demo menu to open the Demo
Properties dialog box. Click on any tab below to change that type of demo property.

Options

[ Shortcut Keys

3 Globals

2 Demo Styles

» Size (of Windowed Demo)




Properties, Scene menu

Opens the Scene Properties dialog box.
Properties Tabs

b General

3 Fill Style

2 Background Color

3 Fill Color

Steps

3 To set the properties for a scene

[ To change a scene's default name
To change the length of the scene

To choose a scene transition
To choose a fill style

To choose a background color
To choose a fill color

b e i




Record Macro

Lets you record a macro.

Steps
2 To record a macro
» To record a macro in all three resolutions




Redo

Reverses an operation you just undid using the Undo command. You can redo only the last Undo operation.



Repaint Scene

Lets you redraw the Designer Window when areas of color remain onscreen from previous procedures.



Restart or ¥

Plays the current demo in the Designer Window starting with the first scene. Clicking the Play Demo From the Beginning toolbar
button is the same as choosing Restart from the Control Menu.



Full Screen Play
Plays the current scene from the beginning in full screen mode.

Steps
4 To test run a demo




Save or @

Saves the current demo file with its current file name. Clicking the Save Demo toolbar button is the same as choosing Save from the
File Menu.

Steps

3 To save an existing demo




Save As

Saves the current demo file with a different file name.



Save Macro

Lets you save a macro you have recorded.
Steps
3 To save a macro




Save Template

Saves the current template file and any template properties you may have changed while the template was loaded.
Steps
3 To save a template file




Save Template As

Saves the current template file with a different file name.



Scene Editor

Displays the Scene Editor. Use the Scene Editor to manage the scenes in your demo and the objects in your scenes. The Scene
Editor is a panel with buttons that appears by default at the top right of your DemoShield screen, but you can drag it elsewhere.




Scene Sorter

Opens the Scene Sorter.



Search for Help on

Allows you to enter a search term. A list of topics containing the keyword will appear. Select the topic you want to go to.



Select All

Selects every object in the current scene.



Space Horizontally

Evenly spaces selected objects in a horizontal line.
» Before

2 After




Space Vertically

Evenly spaces the selected objects in a vertical line.
Before

After
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Status Bar

Choosing this command displays the status bar at the bottom of the screen.
See Basics: The Status Bar for details.



Step Backward

Moves the current time on the Controller clock back one step.
Steps
3 To step or jump through a demo




Step Forward

Moves the current time on the Controller clock one step ahead.
Steps
3 To step or jump through a demo




Stop

Stops playing the demo you are test-running.
Steps
3 To test run a demo




Template Properties, Demo menu

Lets you set demo properties that become part of the current template file.
Steps
3 To create a demo template




Template Properties, Scene menu

Opens the Scene Template Properties dialog box. Use this to set default scene properties and save them to the current template.
Steps
3 To change the properties of the scene template




A

Creates a Text Object.
Steps
3 To create a Text Object

Text or




Tile

Arranges your demo windows so each window occupies a smaller space onscreen but all are visible. In this version of DemoShield
it is possible to display only one demo at a time in the Designer Window.



Toolbar

Choosing Toolbar from the View menu displays the DemoShield toolbar.



Undo

Use Undo to reverse these operations:

Creating a new scene

Deleting a scene

Creating a new object

Deleting an object

Moving an object

Undo keeps only one level of these operations in its memory.

When you select and perform one of the above operations on more than one object, Undo reverses the operation for the last object
only, in the order you created the objects.

TV wyw

When you cannot use Undo, it appears grayed on the Edit Menu.



0|
VCR or

Creates a VCR Button Object.
Steps
b To create VCR Buttons
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Variable or

Creates a Variable Object.
Steps
b To create a variable object




Command Line Parameters

Related steps
You may change the way your demo plays in the Player by adding additional command line parameters to the path which launches
the demo. You may use these command line parameters in conjunction with, or in place of, the DemoShield Server code.

1. Windows 3.1 users: Select the Player icon in Program Manager and press Alt+Enter (or select Properties from the File Menu)
to open the Program Item Properties dialog box.

Windows 95 users: Double-click on My Computer, the correct drive, and then on your folder(s) as necessary to locate the
DEMO.EXE icon. Right-click on the icon and select Properties from the shortcut menu to open the Properties dialog box. Click
on the Shortcut tab.

2. Under the Command Line edit field (Windows 3.1) or the Target field in the Shortcut tab (Windows 95), you will see the full path
to your DEMO.EXE file, followed by a space, and then the name of the .dbd file you are playing.

3. You may add one or more parameters to the command (or target) line. Place a space before each parameter.
These are the command line parameters:

-q Silent DemoShield launch. Launches the demo without displaying the "DemoShield Is
Initializing...Please Wait" dialog.

-Xn Positions a windowed demo at a new fixed X coordinate (n). You can also set the Y
coordinate (see below for example). Only works with windowed demos.

-yn Positions a windowed demo at a new fixed Y coordinate (n). Only works with windowed
demos.

Example: c:\windows\demos\DEMO.EXE window.dbd -x100 -y200



conditions

Any criteria, properties, or values that are required before some action can be performed. For example, you can use an Event
Object to compare the properties of two objects in your demo, and make the demo perform one action if the properties are the same
and a different action if the properties are different.



constant

You can think of a constant as an imaginary place in the computer. You give it a name and assign it a value, which can be either a
number or a string. But whatever the value is, it does not change.

See variable.



current state

The visible/invisible and enable/disable selections under Current State do not have any effect on how your viewer will see the object
in your final demo. The settings only affect how you view the object in the Designer from the time you change the Current State
settings to the end of the scene. As soon as you reload the scene, the object returns to its Initial State settings.

There are two purposes for the Current State settings:
P To serve as a status indicator of the visible/invisible and enable/disable property settings for the object at the current scene time.
At any time during the scene, you can open an object’s General Properties dialog box and view the Current State settings.

P To allow you to temporarily change these properties for debugging purposes. Perhaps you find an invisible object that should
always be visible. Instead of changing the object’s initial setting to visible and then reloading the scene to test it, you could change
both its initial and current settings to visible.



default

An option, setting, or value that the computer will automatically use until you change it.



demo

A commercial presentation of graphics and text that demonstrates or advertises a product or service, and which is created
specifically for viewing on a computer screen. In this Help file and in the User's Guide, we will use the word "demo" to mean any
type of software presentation you can create using DemoShield.



demo disk

A floppy diskette that contains a demo.



The Comparison dialog box

The Comparison dialog box has five fields. To make a comparison, you need to enter five items of data.

Steps
3 To create a comparison




Build Action dialog box
Use the Build Action dialog box to select an action you want the demo to perform.
For a description of the actions you can choose, see the Actions Dictionary.

Steps
[ To choose an action
3 To edit an action




Demo Information dialog box

Choose About from the Help menu to open the About DemoShield dialog box.
Click on the Demo Information button to open the Demo Information dialog box.
The Demo Information dialog contains the following information:

# the current demo name

P the current template

I the demo's resolution (in pixels)

P the version of DemoShield you are using



Manage Demo Resources dialog box
With the Manage Demo Resources dialog you can review data for, import, export, preview, and/or delete:

Images in bitmap and metafile formats (including screen captures)
Text in Rich Text Format
Macros you have created for the current demo
Application files (and their support files) you may run while you run your demo
AVI and SCM video files
Sound files in WAV format
teps
To open the Manage Demo Resources dialog box and look at any file
To delete a resource listed on the Manage Demo Resources dialog box
To preview a resource
To import a resource

[ To export a resource

3 To import resources and/or scenes from a different demo

] To import an RTF file

Options

Images

.WMF and .BMP files; also screen captures created using DemoShield
Text

.RTF files

Macros

Macros created using DemoShield

Files
.EXE files and other files

AVI Sound
WAV files

Video
.AVI and .SCM video files
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Preferences dialog box

Choose Preferences from the File Menu to customize a number of default settings that control the way DemoShield looks and works
on your system.

4 Steps for Setting Preferences
Tabs
2 Enable

» Configure
3 Options
2 Capture
b Demos
[ Null Color



Properties dialog box

Properties are the attributes or qualities that characterize an object onscreen. For example, an object's color, its font style and size,
and the settings that determine its life are all properties. Use the Properties Dialog Box to set the properties for an object you've
placed on the screen. Each object will have a different set of tabs from which to choose, depending on the properties attached to

that object.
For a complete list of objects and their properties, see the Object Dictionary.

» Steps for Setting Properties




Text Options dialog box

Use the Text Options dialog box (1) to align and create margins for text, or (2) to import and display word-processed text you have
saved as an RTF file.

Steps

3 To create a margin
4 To align text

3 To import an RTF file
Options

Alignment Buttons

Use these buttons to left-justify, right-justify, or center the text inside a Text Object. To align the text, click one of the Alignment
buttons.

Margin in Pixels

Use this to create a margin of blank space around your text.

RTF Files

Use this option to choose an RTF file to import into your demo.



Action Dictionary
Click any action for a description of the action and procedures for applying it.

Play Macro
Set Variable
Set Contents
Send Windows Message
Bring to Front
Send to Back
Bring One Layer Closer
Send One Layer Back
Highlight/De-Highlight
Play Sound
Display Menu
Play Video
Move Cursor
Send Property
Get Property
Set Property
Trigger Event
More actions

Action Dictionary
Click the action for a description of the action and procedures for applying it.

i R R e R

(4 To choose an action
Go to Scene
Go to Object in Scene
Go to Next Scene
Go to Previous Scene
Go to Next Jump Mark
Go to Previous Jump Mark
Go to Sub-Scene

4
3
b
3
[
4
3
: Return from Scene
b
3
[
4
3
b
3

Pause/Continue Demo
Delay Demo
Stop Demo
__ Hide
__ Show
Enable
Disable

Send Keys
More actions




Menu Dictionary
Click a menu below to see a description of each of its commands.
3 File Menu

Edit Menu

View Menu

Demo Menu

k
3
3
3 Scene Menu
(3
k
3
b

Object Menu
Control Menu
Window Menu

Help Menu
Click on Accelerators for a list of all the menu shortcuts available (i.e. Ctrl+C for copy).




DemoShield Object Dictionary
Application Object

] AVI Object

3 Bitmap Button Object

3 Edit Field Object

k Ellipse and Polygon Object

3 Event Object

] Group Object

3 Hot Spot Object

] Line and Poly-Line Objects
[ Menu Object (PopUp Menu)

3 Push Button, Radio Button, and Check Box Object
] Rectangle/ Rounded Rectangle Object
3 Text Object

] Variable Object
3 VCR Button Object




disabled

Refers to an interactive object, such as a button, check box, VCR button, menu button, or hot spot. When an interactive object is
disabled, it means that even though you may see it onscreen, it does not work. That is, if the viewer clicks the object the demo will
not perform any action. See enabled.



distribution disk

When you finish creating a demo, you copy the demo to one or more floppy disks along with the appropriate DemoShield files. Then
you give the disk to your viewer. Note: The "distribution disk" could also be a compact disk.



drag

To click and hold down the left mouse button while you move the mouse. For example, you can point to and drag an object you have
selected in the Designer Window.



effect

Changes the way an object appears without moving the object. You can use an effect, for example, to make an object grow from
nothing to full size when it enters the scene, then shrink and disappear in exactly the opposite way when it exits.

There are a number of different effects you can choose, including having the object appear of disappear in strips, rows, and
patterns. By changing the object's Start, Hold, End, and Exit Times, you can make the object appear or disappear more slowly or
quickly.



enabled

Refers to an interactive object, such as a button, check box, VCR button, menu button, or hot spot. When a button is enabled, it
means the button actually works. That is, not only can your viewer see it onscreen, but you can build an action for the button so that
when the viewer clicks it the demo will perform the action.

See also disabled.



event

An event is what triggers action in your demo. Your viewer can provide the event by using the keyboard or mouse. The viewer left-
clicking on a button is one example of an event. The demo switching to another scene is one example of an action. When you
create action that happens independent of your viewer, you use an Event Object to provide the event that triggers the action.



Event Object time indicator

Event Objects appear with a red dot at their "trigger" or start times in the Timeline Editor.
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fill style

What you choose to put inside an object. Suppose for example you have created a graphic object, such as a rectangle. You can fill it
with color--make it a yellow rectangle. You can put nothing inside it and make it transparent. You can display an image inside the

rectangle. The color, image, pattern, wash, or transparency of the object is its fill style.



fixed size

In a fixed size demo, the demo window is an absolute size. The window's exact height and width will remain the same, no matter
what resolution monitor the demo is played on. This means that none of the objects in your demo will scale.

If you do not check fixed size, the dimension and position you specified for your windowed demo will be scaled from a presumed
base resolution of VGA (640 x 480 pixels). For example: you could create a window that takes up 1/4 of the screen on your VGA
monitor. When played on an XVGA monitor, the demo window will still take up approximately 1/4 of the available screen.

Note: When a fixed size 640x480 demo is played on a 640 x 480 screen, the demo will scale slightly to fit. Since the scaling is
minimal, there should be no visible effects on your demo.



full screen background

This option allows you to select the color that will fill your viewer's screen behind your demo window.



global variable

There are two types of Global Variables you choose from in the Comparison dialog box. The first 6 global variables listed in the
combo box are DemoShield's own global variables. These are variables you set using the Demo Properties dialog box. You can set
3 number and 3 string (text) variables. They are global to the demo.

The rest of the global variables listed in the Comparison dialog box are system variables. They can be used by most of your
computer's applications.



grid

A crisscrossing of horizontal and vertical lines on your screen that might look like the lines on graph paper if you could see it. In
DemoShield, the grid on your screen is invisible. You may find a grid useful in moving or lining up objects that you have placed in the
Designer Window. Using the Preferences dialog box, Configure tab, you can make the distance in pixels between the grid lines
wider or narrower. By default, one grid unit equals one pixel.



handles

Small rectangles that appear at the corners and sides of an object in the Designer Window when you click the object. These handles
tell you the object is selected. To resize a graphic or text object, point to a handle and drag.




help screens

A system of online information that explains how to use the software program currently open. Standard Windows help screens are
usually linked with hypertext jumps, hot spots, and search keywords, so the viewer can quickly access a specific topic. To open
Windows Help, you select Help from the menu bar.

See also wizard.




hot spot

A sensitive area on the screen that you can click to initiate some action. In DemoShield, for example, you can create a hot spot that
your viewer can click to bring a menu onscreen, display a window with special information, or switch from one scene to another.




hypertext

Hypertext is multiple screens linked together, containing information on any subject, and organized to give the reader both linear and
non-linear access to information. Instead of asking you to read screens in numbered order, the way you read a book, the author of a
hypertext novel seeks to create a non-linear web of links and branches that associate related thoughts, themes, and subplots
throughout the text.

Embedded at these junctures the reader may find a jump word or a map, diagram or some other graphic with hot spots. Clicking on
one of these hot spots takes you to a different place in the text or initiates a software, video, or other mixed media sequence. Each
of these jumps takes you on a different thought trail, and all of these associations are designed to deepen your understanding of the
work as a whole.



interactive demo

Unlike a self-running demo, the viewer can control and often navigate through an interactive demo. In addition to Pause and Exit
buttons, a typical interactive demo might also contain Next, Previous, and Menu buttons.

Clicking the Menu button in an tutorial, for example, often displays a menu with different lessons the viewer can choose.
See also self-running demo.



interactive object

Interactive objects are sensitive to your viewer's clicks and keystrokes. Your viewer can see and use these objects to run your demo,
or to interact with your demo while its running. Hot Spots, Bitmap Buttons, Buttons, Edit Fields, PopUp Menus, and VCR Buttons are
all interactive objects. Note: You cannot create action with Edit Field Objects.



jump mark

An object property you can set in the General tab for most objects which "tags" the object. When an object is "jump marked," you
can create actions to go to that object's start time. You can set Go to Next Jump Mark or Go to Previous Jump Mark actions.



jump mark indicator

Objects tagged with a jump mark appear with a black diamond at their start times in the Timeline Editor.



key press

When your viewer presses a key, or a combination of keys, we sometimes call it a key press. A key press is an event.



lasso

To surround one or more objects with a dotted rectangle so you can align them. When you click and drag in the Designer Window a
dotted rectangle appears. As you move the mouse farther away from the point where you clicked, the rectangle grows larger, and
you can use it like a lasso to enclose the objects you are aligning.



layer

When you paste more than one object in the same place on your demo screen, the most recent object you paste covers up the
previous object(s). Using the Scene Editor, you can rearrange these layers, and bring an object from the back to the front or send an
object in front to the back of this stack. See also stack order.



life

The period of time an object is onscreen. The life of an object starts when the object begins to appear and ends when the object
finishes disappearing.



linear

Anything you read like a book, whether in print or onscreen. When you read a book, you start at the first page, continue in ascending
numeric sequence, and end at the last page. See hypertext.



link

When you create a button or some other interactive object for your demo, you need to build one or more actions you want your
demo to perform when a viewer clicks the button. The click is an event. What your demo does when it gets the event is an action.
The link is the connection you make between an event and the action(s) that happen following the event.



macro

Just as you can record your voice on, and play back, a tape cassette, you can record and play back your mouse moves and
keystrokes with a macro.

Most likely you will use the macros you record in DemoShield to build demos that teach or advertise other applications. In fact you
can use a macro to record anything you do while you are using your computer.



maximize time scale

Click on the magnifier + icon to increase the time scale displayed in the Timeline Editor. The scale will move up through each of six
settings. The largest time scale shows each vertical (white or gray) bar equal to 60 seconds.



metafile

An image saved using standard Windows metafile format. A metafile is a set of drawing instructions. Windows metafiles have the
extension .WMF. You can display images in your demos either in metafile or bitmap format. Metafiles scale in better proportions

than bitmaps.



minimize time scale

Click this button to decrease the time scale displayed in the Timeline Editor. The scale will move down through each of six settings.
The smallest time scale shows each vertical (white or gray) bar equal to 2 seconds.



motion

A motion, in DemoShield, is when an object moves in or out of a scene. For example, you can make an object enter a scene from
the left edge of the screen, and move right until it reaches some spot near the center of the screen, where you want it to stop, and
hold.

When you have no further use for the object in the scene, you may want it to move from where it's holding to the right until it
disappears off the edge of the screen. When an object enters or exits a scene this way, we call it a motion.

Motions are different from actions. An action affects how something in the demo works. Changing from one scene to another, or
stopping the demo, are examples of actions.

A motion affects only how one object looks. To set motions, use the Life Properties dialog box. To set actions, use the Actions
Properties dialog box.

See action.




Move Cursor action

The Move Cursor action moves the cursor from its current position on the screen to a position you specify. You also select the time
that it takes to complete its movement from a combo box listing several different times. By timing the move cursor action with the
display of a new screen capture image, you can simulate the effect of a running application.



multimedia

Computer hardware and software that combine different media, which can include text, graphics, animation, sound, and video.



native resolution

The size in pixels that your demo will appear on your viewer's screen. The three standard screen resolutions are VGA (640 x 480),
SVGA (800 x 600), and XVGA (1024 x 768). These numbers are the number of pixels on the screen across and down. See also

scaling and screen resolution.



A new look and feel

DemosShield4 has a new look and feel aimed at taking full advantage of Windows 95/NT capabilities.
Other user interface improvements include the Demo Wizard, which assists you in creating new demos.

Demo Wizard

Tabbed dialog boxes
Shortcut Menus

Long filename support
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Additional controls for running applications
Version 4.0 contains a number of options for controlling how your applications will run

& You may choose to run your application maximized, or you may select the exact screen location where your application window
will run.

# You may select to allow or prohibit user interaction with your application.

FyYou may select how you want to close the application. You may have your application terminate when the scene ends, terminate
when the demo ends, or remain open after the demo closes.

Steps

b To select options for running your applications with DemoShield




Check Resources

While you are creating your demo, you will import a variety of resources (such as image, video, and RTF files) from outside
programs. By the time you are ready to distribute your demo, you may no longer need them. Select Check Resources in the
Preferences dialog box to have DemoShield prompt you to save or delete unused resources each time you close the demo file. This
will help you minimize your demo file size.

Steps

[ 2 To check for unused resources in your demo



Global Variables

In addition to the Variable Object, which is local to one scene, DemoShield now offers Global Variables. These are three number
and three string variables that you can use in any scene. You may increment, decrement, or reset the value of either local or global
variables through the Set Variable action in the Build Action dialog box.

Steps

r To set DemoShield's Global Variables



Importing Scenes and Resources from Demos

The process of importing scenes and/or resources from other demos has been improved. You may now choose to import only
resources of a specific type, such as image resources. You may also choose to import only scenes, or a combination of demo
scenes and specific resources. When you import scenes into your current demo, those scenes will appear in their original order after

your current scenes.
Steps
4 To import resources and/or scenes from another demo



Importing Resources by Reference

With DemoShield 4.0, you may choose to import your application, video, and sound resources by reference instead of saving them
within the demo file. This option will make the size of your demo file smaller, and will allow you to work more quickly in the Designer.
You must remember, however, to copy those resources to your final distribution disks.

Also, there is now more information available in the Manage Demo Resources dialog box.
You may now:

] View the number of colors used by your 256-color bitmaps
4 View the approximate length of a macro

3 Export resources from DemoShield to other applications
Steps

To import resources by reference

4 To open the Manage Demo Resources dialog box and look at any file




Improved features

The following are a few of the notable improvements to existing DemoShield capabilities. In addition, a number of performance
enhancements have been implemented.

Improved Method of Importing Resources from Other Demos

New Options for Importing and Managing Resources from Outside Applications

More Precise Timing for Objects

Additional Controls for Running Live Applications

Improved Documentation and Support
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Improved Documentation and Support

In addition to its new context-sensitive Help, DemoShield 4.0 ships with an improved User's Guide and the new DemoShield
Knowledge Base. The Knowledge Base features sample demos; tips, tricks, and techniques; Frequently Asked Questions; and
several technical articles. We will post periodic updates to the Knowledge Base online.

In addition to the improved documentation, you now have more ways than ever to contact DemoShield technical support staff and to
share information with DemoShield users and developers.

Steps

b Steps for Contacting Us



Launching the Player from within the Designer

Now you don't have to exit the Designer to play your demos using the DemoShield Player. Simply open the Preferences dialog box
and click on the Demos tab. Browse for up to 10 files you can preset to play from within the Designer. When you are done
selecting your demo files, click OK to close the dialog. Choose the file you want to play from the list that now appears in the Help
menu.

Steps

3 To launch the Player from the Help menu




Long filename support
(Windows 95 only)
DemosShield 4.0 supports long filenames. If you are running Windows 95, you can now give almost any name to your demo files.

The 32-bit version of DemoShield takes advantage of this feature in naming its own auto save and backup files. In Windows 3.1,
DemosShield saves those files with .AUT and .BAK filename extensions.

In Windows 95, backup files are named in the following manner:

L Auto Save of .dbd
3 Backup of .dbd



Lotus ScreenCam support

New with this release is support for the .SCM video file format. Previously, DemoShield only supported the Audio Video Interleaved
(AVI) video file format. SCM files are video screen captures created with Lotus ScreenCam. To play SCM files in your demos, use
the Play Video action.

When you use the Setup Wizard to create your distribution disks, you will be prompted for the file SCPLAYER.EXE, This file must be
included on your distribution disks to allow your viewers to play .SCM files.

Steps

b To add sound and video to your demos



More precise timing for objects

The Start, Hold, End, and Exit times in an object’ s life may now be set in tenths of a second intervals. You may also use the Demo
Controller to move forward or back in time in tenths of a second intervals.

Examples:

* a Text Object with a Hold Time of 1.3 seconds
b stopping the Controller clock at 10.6 seconds



Move Cursor action

Use the Move Cursor action along with screen capture images to simulate the look of your running application.

The Move Cursor action moves the cursor from its current position on the screen to the X, Y coordinate you specify. You also select
the time that it takes to complete its movement.

Steps
4 To choose the Move Cursor action




New Features

DemosShield4 contains a number of new features to assist you in creating demos. These include a screen capture capability, global
variables, and a method for launching the Player without ever leaving the Designer.

Also, you may now choose to create demos that play in a window on your viewer's screen. By creating a fixed-size, windowed demo
users know their demos will display predictably on any viewer's monitor.

Screen Capture

Launching the Player from within the Designer

Windowed Demo Mode

Scrollable Design Window View

Lotus ScreenCam Support

Timeline Editor

Global Variables

DemoShield Server

Check Resources
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New actions to choose from
DemosShield4 includes two new actions you can create using the Build Action dialog box.

2 Move Cursor
b Set Variable




Scrollable Design Window view

We recommend that you enable Scrollable Design Window view. It assists you in creating demos that will display correctly on all
systems by allowing you to view and edit your objects in a What You See is What You Get (WYSIWYG) mode.

Steps

3 To enable Scrollable Design Window View




Set Variable action

This action now allows you to increment, decrement, or assign a new value to variables. These include both the variables stored in
Variable Objects (local to one scene) and the new, global variables that can be used anywhere in the demo.

Steps
b To choose the Set Variable action




Shortcut Menus

When you right-click on an object, or an empty area of a scene, shortcut menus appear. These menus display common commands
that you can use on the item selected. For example, by right-clicking on any object, you can choose to open its Properties dialog
box, duplicate, delete, or move the object to the front or back of the stack order. A similar menu appears when you right-click on a
scene background. To pick a command, simply highlight a menu item, and left-click.

Shortcut menus also pop up when you right-click within a Properties dialog box. The shortcut menu shows a list of all the tabs within
that dialog box. Left-click on the tab you wish to bring to the front.

Steps

b To disable shortcut menus




Timeline Editor

The Timeline Editor is a new tool which allows you to quickly view and edit the Start, Hold, End, and Exit times for all objects in any
one scene. This tool can save you valuable time when you need to change the lifespans of several objects at once. This is

especially helpful when you need to add an object in the middle of a scene.
Steps
3 To set times by using the Timeline Editor




Windowed Demo Mode

One of the most important new features in DemoShield4 is the Windowed Playback Style option. This allows you to create a demo
that will play in a window (instead of full screen). You choose the exact size and location of the window. You may choose to give the
window a caption, and to set the window to be always on top of other windows.

You may also specify the demo window as "fixed size." None of the objects in a fixed size demo will scale, regardless of their "no
scale" property settings. By creating a fixed-size, windowed demo users know their demos will display predictably on any viewer's
system.

Steps

3 To choose Windowed Playback Style




Screen Capture Program

DemosShield4 includes a new screen capture capability. You can now capture your application screens as bitmap images. Simply
choose Capture Images from the Demo menu to enter "capture mode." Then hit a function key assigned to the type of screen
capture you want to make--active window, full screen, window under pointer, etc. A beep will sound when your screen is captured.
Your captures are automatically saved as demo resources. Display them in DemoShield just as you would any other bitmaps.
Steps

» To capture images




non-linear

In this context, non-linear is the opposite of linear, and refers to the interconnected screens of a work of hypertext.



object

Anything you can place, select, move, or resize in the Designer Window. Objects include graphic shapes such as rectangles and
lines, interactive objects such as VCR Buttons and PopUp Menus, invisible objects such as AVI and Variable objects, and text.




object styles

Many of the objects you can create in DemoShield share properties in common, and yet each is different. Object styles are those
properties about an object that make it unique and different. For example, a text object is not interactive but VCR buttons are. You
can choose a background color and a fill color for a text object. But there is no background color or fill color to choose for VCR
buttons.

Use the Properties dialog box, Object Styles tab to choose or set the properties that make the object unique. All Font Color,
Background Color, and Fill Color dialog boxes are the same, but each Properties dialog box, Object Styles tab is different.



operator

A word or symbol that tells DemoShield how you want to compare objects, variables, and/or constants. If you want to see if the
objects are identical, for example, use the equal ( =) sign.

These are the operators:

Less Than (<)

Greater Than (>)

Less Than or Equal ( <=)
Greater Than or Equal (>=)
Equal (=)

Not Equal (=)
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palette

A panel of buttons you can display on the DemoShield screen. Each button on the palette is a different tool you can use, or object
you can create, in building your demo.



password

Use the Demo Properties dialog box, Demo Styles tab to set a password for your demo. This will prevent people who don't know
your password from opening your demo in the Designer. Your password may be up to 6 characters (any characters, including
spaces). To remove a password, delete all characters from the password edit field.



pixel

The smallest unit of color on a screen monitor. The term pixel combines two words--picture and element.



pointer

A mouse cursor in the shape of an arrow. When you perform certain procedures in DemoShield the pointer changes to a cursor of a
different, more useful shape. For example, a special cursor appears when you drag the LifeLine to change the Start, Hold, End,
and/or Exit Time for an object.




properties

The attributes or qualities that characterize an object , a scene, or the demo itself.

For example, an object's color, its font style and size, and the settings that determine its life are all properties.
A scene's length and a demo's window size are also properties.

Use the Properties Dialog Box to set the properties for an object you've placed on the screen.

To open the Properties Dialog Box for any object, point to the object and right-mouse-click. Then press Enter or left-click on the
words Object Properties.

To open the Properties Dialog Box for a scene, choose Properties from the Scene menu.
To open the Properties Dialog Box for the demo, choose Properties from the Demo menu.




Enabled

The Enabled property is 1 if the object has its Enabled property checked in the General Properties dialog box. If Enabled is not
checked, the value of the Enabled property is 0.



Dimension

The Dimension property refers to the object’s height and width. This is a 32-bit value where the high word equals the object’s
height, and the low word equals the width.



End-Period-Length Time

Equals the object’'s End Period (its Exit Time minus its End Time).



End-Time

Equals the object’'s End Time.



General Data

Use the General Data property to evaluate the contents of an Edit Field.

For example, you could compare the General Data Property of Edit Field 1 with the constant C, which represents the correct answer
to a question. If the viewer types C in the edit field, the comparison is true. If the viewer types anything else, the comparison is
false.

You could also compare the General Data Property of Edit Field 1 with the General Data Property of another Edit Field.



Group

The Group property is the object’'s Group Name. You could use this property in a comparison to see if two objects belonged to the
same group.



Hold-Time

Equals the object’s Hold Time.



Position

The Position property refers to an object’s X and Y coordinates. This is a 32-bit value where the high word equals the X (horizontal)
position and the low word equals the Y (vertical) position.



Pressed

Use the Pressed property to evaluate if a Button Object has been pressed or not.

If the object is pressed, its Pressed property is 1. If the object has not been pressed, its Pressed property is 0. For radio button
and check box Button Objects, you can see if the button has been pressed because they change in appearance.



Start Time

Equals the object’s Start Time.



Visible

The Visible property is 1 if the object has its Visible property checked in the General Properties dialog box. If Visible is not
checked, the value of the visible property is 0.



prototype

A prototype is a software model that looks and works onscreen like a real program. Prototypes give developers the opportunity to
design an application and see their ideas onscreen before committing time and expense to write code.



resize

To resize an object means to change its shape by making it bigger, smaller, wider, and/or narrower. You change the size of an object
in DemoShield in much the same way you resize a window in Microsoft Windows.



resource

A separate and unique group of data that you import into DemoShield for a specific purpose in your demo. Resources include but
are not limited to

Metafile (WMF) and bitmap (.BMP) images you can display in Graphic Objects, Bitmap Buttons, or scenes

Screen capture images you create using DemoShield and display in Bitmap Buttons, Graphic Objects or scenes
Rich Text Format (.RTF) files you can display in a text object

WAVE (WAV) sound files you play in your demos

Macros and application files that you run with your demos, and

Audio Video Interleaved (AVI) and Lotus ScreenCam (SCM) files you use to play a video sequence in your demo.

To import and keep track of the resources in your demo, use the Manage Demo Resources dialog box.

Use the Fill Styles dialog box to display metafiles, bitmaps, and screen capture images in Bitmap Buttons, Graphic Objects and
scenes.

Use the Object Styles dialog box for Text Objects to display RTF resources.
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runtime file or runtime version

Aruntime file is a special version of a complete application program file designed to have limited capabilities. Major software
companies often create runtime versions of their programs and distribute them to prospective customers to advertise their products.
Typically you can use the runtime version to run the program and see how it works, but you cannot save any files you create.
DemoShield's runtime file is DEMO.EXE. DEMO.EXE can run a demo, but you cannot use it to create a demo. For this reason,
DEMO.EXE is a smaller file than the DemoShield program file DESIGNER.EXE. This makes it easier to copy DEMO.EXE to the
diskette you distribute to your viewers.



scaling

When a viewer plays your demo on a screen with a resolution different from the native resolution you used to create the demo,
DemoShield adjusts the size and position of the objects in your scenes proportionally to fit the viewer's resolution. This process is
called scaling or rescaling.

It's important to plan and design your demos with scaling in mind. The most important rule to remember is that a smaller demo will
rescale better on a larger screen than the reverse. For this reason, we recommend that you create your demo using the smallest
resolution possible. When a demo rescales, and objects change their size and position to fit a new resolution, images can appear
distorted.

Whenever you have a choice, use images saved in metafile format because they scale better than images from bitmap files.



scene

A scene is nothing more than a blank screen that you create and fill with Text Objects, Graphic Objects, and other objects, such as
VCR Buttons.

You decide how many seconds the scene will last (Scene Length), and what will happen when the scene ends (Scene Transition).
For example, when the scene finishes playing, the demo can switch to a different scene.

A demo must contain at least one scene and may contain up to 256 scenes.



screen capture

Use DemoShield's screen capture function to capture images of your application screens. These images will be immediately
available in your Manage Demo Resources dialog box. The first capture you make will be named “"Imagel." The second will be
named "Image2" and so on. These captures are bitmaps. You can display them the same way you would display any bitmap: as an
image fill for a closed graphic object, a Bitmap Button, or a scene background.



screen resolution

The number of pixels, or dots, on the screen. The three major resolutions are VGA (640 x 480), SVGA (800 x 600) and XVGA (1024
X 768). These numbers are the screen's dimensions in pixels. A VGA monitor, for example, has 307,200 pixels. Images generally
appear more clearly defined on a screen with more pixels.

See also pixel and scaling.



select

You select an object in the Designer Window by clicking on the object. When you click, handles appear at the corners and sides of

the object that you can use to change the object's size. Before you can perform an operation on an object, such as resizing or
moving, you must select the object.




self-running

A self-running demo is designed to run automatically. Once it starts, the viewer does not need to do anything but sit back and watch.

A self-running demo does not need to have any controls, although many contain the viewer Pause and Exit buttons. Some self-
running demos make it possible for the viewer to control how fast or slowly the demo runs.

See also interactive demo.



send
When you place more than one object in the same place onscreen, they create a pile or stack, and one of the objects can cover up
and hide another object.

You can use the Sort Buttons in the Scene Editor to send an object in front farther back in this stack, to hide the object, or to bring a
different object into view.



shortcut key

A key or combination of keys you can press to perform an action.

There are two types of shortcut keys in DemoShield.

1. Demo control shortcut keys. DemoShield has built-in shortcut keys your viewer can use to control a demo while it is
running. These include Pause/Continue and Stop Demo. To change these defaults and create your own key combinations,
choose Properties or Template Properties from the Demo Menu.

2. Trigger event shortcut keys. You can also set shortcut keys as the event that triggers your interactive object. Click on the
Actions tab to choose an event. Instead of choosing “Left-mouse click," you could choose [Key].

The Choose a Shortcut Key dialog box appears. Use this dialog to choose the key or key combination that will serve as your
viewer event.




slide show

The simplest kind of demo. A slide show can contain any number of scenes intended for linear viewing in numeric order from first to
last. A typical interactive slide show has a VCR panel with three buttons: Continue, Previous, and Exit.

Note You can convert your existing slide show presentations (from PowerPoint, Freelance, etc.) for use in DemoShield by saving
each slide as a separate .WMF file. Refer to the Knowledge Base for the steps.



software demo

A demo that teaches or advertises a software application. Software demos fall into two main types: live application demos and
software simulation demos.




software simulation demos

A software simulation demo could contain bitmap (static) screen captures, video screen captures saved in AVI or SCM format, or
both. A simulation demo gives the appearance of the actual running application without requiring the .exe files necessary in a live
application demo. By using the Move Cursor action, you can effectively simulate the cursor movement in a running application.
However, the viewer can only interact with the real application in a live application demo.




splash screen

An image that appears onscreen for a few seconds while an application is loading, and then disappears before the application
launches. A typical splash screen may contain a company logo, and such boilerplate information as copyright, trademark, license
and/or the user's serial number. You can display a splash screen in the setup program you create to install your demo on your
viewer's computer.



stack order

When you place one object on top of another object in the Designer Window, the first object looks like it's in back and the second
object looks like it's in front. We call this a stack. Each object is one layer in the stack.

Using the Scene Editor, you can sort and change the stack order of the objects in the current scene, sending an object from the
front to the back or bringing an object from the back to the front. This makes it easier to design the layout of your demo screen, and
to move, resize, and edit each individual object.



template

Afile that contains information about the initial settings for each object, scene, and demo you create. Template information tells
DemosShield, for example, how a button should look when you first place it in the Designer Window: its size, color, and caption.

Once you create objects, scenes, and demos, you can change their initial properties using the appropriate Properties dialog boxes.
Information in a template affects only those objects, scenes, and demos you create after you load the template, not before.

Template files have the filename extension .TPL. The name of your current template appears (if space permits) at the bottom of the
Object Palette.



time scale

There are six settings in the time scale for the Timeline Editor. Click on the magnifier icons in the upper right to toggle up or down
through the settings.



timed action

An action that you set to occur at a specific time in a scene.



transparent areas on bitmaps

If you are importing a true-color or 16-color bitmap into a Bitmap Button or Graphic Object, you may choose to make part of that
bitmap appear transparent. You may select one color used in the bitmap to appear transparent to whatever is behind the object.



tutorial

Afile or set of related files, either self-running or interactive, whose purpose is to teach, guide, or instruct a viewer. Tutorials are
usually one-to-one or intended for viewing in small workshop/seminar groups.




variable

Avariable is an imaginary place in the computer where you can store a value. The value can be a text, number, or alphanumeric
string. Unlike a constant, whose value never changes, a variable's value can change at any time. DemoShield contains two kinds of
variables: local variables and global variables. Local variables, which you set using Variable Objects, can be used in only one scene.
Global variables, which you set in the Demo Properties dialog box, can be used anywhere in the demo. Both kinds of variables can
be changed when the demo is running by means of the Set Variable action.



video screen captures

Video screen captures are videos of your application in action. You could, for example, capture a series of actions that would show
how to set user preferences for working in your application. Use Video for Windows or Lotus ScreenCam to create video captures
for use in DemoShield.




viewer

Anyone who will eventually watch your demo when it's complete. A person you are creating your demo for.



wizard

An online information system that asks the user questions and displays specific information based on the answers. A wizard can
execute and run independently. DemoShield's Demo Wizard and Setup Wizard are two examples of typical wizard applications.

See also help screens.









