
WELCOME TO SEEDMASTER FOR WINDOWS!
Your personal computer is now a powerful Bible study tool. SeedMaster (SM/Win) 
combines the entire Bible, an exhaustive word list, advanced concordance searches, 
personal commentary entry, and a sermon/lesson notepad. All in an easy to learn, easy 
to use, windowed program with context sensitive help every step of the way!

This scrolling file contains the following sections:
 * Value of Registering SM/Win
 * Registration Process
 * What if I can't afford $30?
 * Can I get a new, unregistered copy of SM/Win directly from WHS?
 * What about enhanced versions of SM/Win?
 * What about other Bible versions?
 * What if I have comments or questions about SM/Win?
 * Why distribute SM/Win this way?
 * Technical Recognition
 * Trademark Notices

VALUE OF REGISTERING SM/Win
Locating a non-indexed KJV Bible text for $30, moreover a complete, powerful Bible 
concordance package, notepad and commentary functions with context sensitive help 
and full documentation is DIFFICULT. We believe most people will appreciate our efforts 
in creating SM/Win and will honor our request to register this unique package.
 
SM/Win is being distributed in a unique way. We have created SM/Win for broad 
distribution and, under certain conditions, permit you to copy and distribute the KJV 
version to others.

PLEASE READ THE CONDITIONS OUTLINED IN THE INSTALL.DOC FILE BEFORE 
YOU GIVE ANYONE ELSE A COPY.
If you register your copy, you will receive:
 * The latest version of SM/Win.
 * A complete documentation manual (includes an index).
 * Our heartfelt thanks.
You will also be notified of the availability of:
 * Program Updates
 * Enhanced Versions
 * Additional Bible Versions

REGISTRATION PROCESS
The registration fee is $40. After you finish viewing this file you can print a registration 
form from the Help menu. Checks, VISA and MasterCard are accepted. 
Overseas users, please use charge cards, Postal Money orders, or checks drawn on 
U.S. banks PAYABLE in U.S. DOLLARS. Thank you.
Send the fee and the form to:
White Harvest Software, Inc., PO Box 97153, Raleigh, NC 27624-7153



or FAX to: (919) 870-0775
You can also register on our BBS (919) 846-2141 (2400-N-8-1). Allow 2-3 weeks for 
delivery. Checks may require extra time.

WHAT IF I CAN'T AFFORD $30?
Fine. Please use SM/Win anyway - and pass it on to a few hundred of your very closest 
friends.

CAN I GET A NEW, UNREGISTERED COPY OF SM/Win DIRECTLY 
FROM YOU?
Yes. There is a small charge for the diskettes and shipping costs (see the registration 
form). If you are an unregistered user, you can elect to pay the registration fee upon 
requesting a new copy.

WHAT ABOUT ENHANCED VERSIONS OF SM/Win?
As we improve the product, registered SM/Win users will be informed of new releases. 
We have quite a list of potential enhancements!

WHAT ABOUT OTHER BIBLE VERSIONS?
 * Theoretically, SM/Win is compatible with any Bible version (including transliterated 
Hebrew). We want to make as many available as possible. As of November, 1991, 
SM/Win is available in the GNT (UBS Greek New Testament), KJV, NIV, RSV and RVA 
(Spanish) texts.
 * Since most Bible texts other than the KJV are copyrighted (and require royalty 
payments on our part), they cannot be freely distributed and must be purchased directly 
from us. We will make every effort to keep the cost as low as possible. See the 
registration form for versions and prices. Or write us for availability of specific versions 
you don't see there.

WHAT IF I HAVE COMMENTS OR QUESTIONS ABOUT SM/Win?
 * Write us. WHS, Dept Help, POB 97153, Raleigh, NC 27624-7153
 * Call our BBS. (919) 846-2141 2400-N-8-1 We attempt to respond to inquiries in the 
evenings, M-F. To be reasonably certain your question was answered, wait 24 hours 
before checking for a reply.
 * Call our Voice Mail System (919) 870-0775.
 * FAX to (919) 870-0775. We have a fax switch on the voice line.
 * We would deeply appreciate your WRITTEN critiques (that way we have a record--
feel free to supplement verbally later). Be gentle, but direct. Please include your user 
registration number and phone number.

WHY DISTRIBUTE SM/Win THIS WAY?
There are several answers to this question:
 * It simply distributes God's word. After all, byte for byte, we are not the authors of the 
majority of this package, God is!
 * We would sincerely like to have as many people benefit from the SM/Win product as 



possible.
 * Most Bible study software is simply too expensive (but it's gotten cheaper since 
SM/Win was released!). There are two valid reasons to support a high price for 
software, marketing costs and user support. 
    - SM/Win's Shareware distribution process eliminates the lion's share of marketing 
costs.
    - The level of user support (and hence, its cost) should not be a forced option included 
in the price of the software. We have attempted to create a software and documentation 
package that is largely self-supporting. Admittedly, the church is probably not the most 
technologically adept segment of society. As a result, some users may require more 
"hand-holding" as they enter the world of computers. However, today there are few 
pastors, laymen or seminary students who do not have access to someone 
knowledgeable enough about computers to assist them with their questions. Many of 
these users probably would prefer assistance from a live body rather than a phone line, 
especially if it could save them several hundred dollars. One of our goals is to offer this 
opportunity.

TECHNICAL RECOGNITION
This software was developed using the Microsoft C Optimizing Compiler and The 
Microsoft Windows Software Development Kit. 
The "C" language is great, structured enough to be manageable, but "loose" enough to 
allow you to be productive. 
Windows is a great environment for users, but a pretty miserable one for developers. 
Nonetheless, we persevered.
Also, our Alpha testers were a big help. Thanks to Delbert, John, Larry, Jerry, Ed, and 
Craig. Thanks for putting up with all the UAE's.

TRADEMARK NOTICES
Microsoft is a trademark of Microsoft Corp.
IBM is a trademark of IBM Corp.



SM/Win Help Index

The SM/Win Help Index contains a list of all available Help topics.
Items are available in alphabetical order within a category.
You can use the scroll bar to see entries not currently visible in the Help window.

For information on using Help, press <F1> or choose Using Help from the Help Menu.
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Welcome!
Your personal computer is now a powerful Bible study tool. SM/Win combines the entire 
Bible, an exhaustive word list, advanced concordance searches, personal commentary 
entry, and sermon/lesson notepad(s). All in a easy to learn, easy to use menu driven 
program with context sensitive help every step of the way!



Hardware Requirements
    *    IBM AT, PS/2 and most compatibles
    *    Microsoft Windows 3.0
    *    Hard Disk (.5mb program, 4mb full Bible version, 1.3mb for GNT)
    *    Windows Supported Graphics Monitor



SM/Win Overview
SM/Win has three primary components:
    *    STUDY Four Bible study modes
    *    COMMENTARY Enter/edit verse by verse comments
    *    NOTEPAD Enter/edit sermon/lesson notes
You can use many STUDIES and NOTEPADS. Since COMMENTARY is synchronized 
with other windows, you can only create one COMMENTARY.



STUDIES
A STUDY is the most important type of SeedMaster window, and it is a special one 
because it really is a grouping of Four consecutive Bible study modes:
    *    VIEW View and scroll verses
    *    WORD LIST View/search exhaustive list of Bible words
    *    SEARCH Search for a word or phrase
    *    PEEK Peek at a search verse in context

A STUDY can be maximized to fill the entire SM/Win window, or use just a portion of it. 
You can even minimize the study down to an icon to make room for another Study or 
the Notepad or Commentary.

The Study modes VIEW, WORD, SEARCH and PEEK occur in that order, with WORD 
optional, since you can go straight to SEARCH from VIEW. To back up to a prior Study 
mode, press <Esc>.



COMMENTARY
COMMENTARY is a special SeedMaster window since it "sychronizes" its contents to 
other active SeedMaster windows. The active Study window in VIEW, SEARCH or 
PEEK mode will make the COMMENTARY display the verse the Study mode is 
displaying. 

Unlike most Windows editors, you do not have to save changes to the contents of the 
COMMENTARY. Since it sychronizes to verse changes in other windows, it does not 
ask you if you wanted to save changes. Therefore, any changes made to 
COMMENTARY will be automatically saved when the COMMENTARY moves to another 
verse.



NOTEPAD
The SeedMaster NOTEPAD is a simple text editor like the NOTEPAD that comes with 
Windows. You can use it to make lesson outlines and notes or prepare sermons. You 
can open multiple NOTEPADs under SM/Win.



SM/Win and the Multiple Document Interface
SM/Win is a Windows Multiple Document Interface (MDI) application. The MDI 
application type was developed especially for word processing and spreadsheet 
programs to allow their users to edit multiple documents at the same time. SM/Win 
builds upon the MDI concept. Instead of multiple documents, think of SM/Win as a 
manager of multiple Bibles tools (we call them STUDIES ), notepads (we call them 
NOTEPAD ), and a single personal commentary notebook (we call it COMMENTARY ).

Each STUDY, NOTEPAD and the COMMENTARY get their own window within the 
larger SM/Win window. They all share a common menu, and can take advantage of 
special synchronization features to be detailed elsewhere.

The STUDY window type is the most complex, since it has several modes. Normally, 
most people start out viewing Bible text (we call that mode VIEW ), then they look up a 
word in a list (we call that WORD List) or initiate a word or phrase search (we call that 
SEARCH ). As they browse their search, they want to see the search verse in context 
and then return to their search (we call that PEEK).
Numerically, the order is:
 1.    VIEW Bible text.
 2.    Initiate a Phrase SEARCH or a WORD List SEARCH.
 3.    PEEK at the SEARCH results in context.

Pressing the <Esc> key (or selecting Prior Study Mode on the Window menu) takes 
the user back through this sequence in reverse order.

This is a straight forward, logical approach to studying the Bible. However, as they 
study, many people have search/study ideas they would like pursue in the midst of the 
organized process outlined above. But, eventually they would like to come back to their 
point of departure. The Multiple Document Interface of SM/Win allows you to temporarily 
halt your current STUDY, and initiate a new STUDY or NOTEPAD for jotting down a few 
ideas. When you are finished, you can close that window and return to your prior 
STUDY.



VIEW
The VIEW Study Mode lets you to view and print Bible verses and provides access to 
WORD , SEARCH and PEEK modes. The first verse displayed in the window will have 
its complete reference in the window border's top border. This is the "current verse". As 
you scroll through the verses, this reference will be updated to the reflect the new 
current verse.

Moving to a Different Verse
You can move to a specific verse reference by selecting New Verse... from the View     
menu. Select a new book, chapter and verse. 
Changing Bible Versions
Change your Bible version by selecting Switch Version... on the View menu.
Multiple VIEW Windows
You may have an unlimited number of Studies to compare parallel passages or Bible 
versions. Select New Study from the File   menu   to add a new Study window. 
Synchronize Views
You can synchronize multiple VIEW windows to each other. You can use it to examine 
parallel passages. With synchronization ON, the cursor movements will be imitated by 
any other visible VIEW windows. If a VIEW window is minimized to an icon, it will not be 
included in the synchronization. Note that for the purposes of synchronization, a PEEK 
mode Study window is synchronized and considered the same as a VIEW window.
Synchronize Views to Search
You can synchronize VIEW or PEEK mode study windows to a SEARCH mode window. 
Any visible VIEW or PEEK will synchronize to the currently verse in a SEARCH mode 
window. 



WORD
The WORD list is for word studies and logic searches. Open WORD List from VIEW by 
selecting Word List... on the Words   menu  . You supply an intial word. If you want to 
type accented RVA (Spanish) characters, type an apostrophe before the accented 
character. For instance, to type an accented e type 'e. The proper characters will appear 
in the special window below. If you are typing in Greek, the characters in the symbol 
character set will appear in the special window. 

Moving to a New Letter
You can move to the first word beginning with an alphabet letter by pressing <A-Z>. 
Restarting the WORD list
While you are in the WORD list, restart the list to a new word by choosing Word List... 
from the Words menu.
SEARCHing from the WORD List
You can SEARCH a word by pressing <Enter> on a word.
AND/OR Logic Searches
Logic searches can be performed on more than one word. 
AND logic requires each search word be present for a verse to count as a "hit". 
OR logic guarantees at least one word was found in a "hit". 
Your search logic choice (AND or OR) is set in the Words menu.
You indicate your logic search words by "toggling" them. To toggle a word, move the 
selection bar to the word and either press the <Space> bar select Toggle on the Edit 
menu. A special character will appear beside the word. If you press the <Space> bar (or 
select Toggle) again, the character is removed. Only those words which are toggled ON 
(the ones with the special character next to them) will be used for the search. The "|" 
character beside a toggled word is a reminder that you are using OR logic.
To begin a Logic Search, select Combine Toggled on the Edit   menu  . This begins a 
SEARCH on the combined words. The search takes only a little longer than a single 
word search. 



SEARCH
To enter SEARCH from VIEW, select Word/Phrase... from the Search   menu   and enter 
a word or phrase.

Entering Word/Phrases
Wildcards
You can use the asterisk character "*" to act as a wildcard. The wildcard can be placed 
at the beginning and/or the end of the word. 
Punctuation
Punctuation entered in a Word/Phrase search is ignored for searching purposes.
Special Characters
If you want to type accented RVA (Spanish) characters, type an apostrophe before the 
accented character. For instance, to type an accented e type 'e. The proper characters 
will appear in the special window below. If you are typing in Greek, the characters in the 
symbol character set will appear in the special window. 

Options and Performance
Case Sensitivity
You have the choice to enforce Case Sensitivity. If you do, SM/Win screens each verse 
containing the word(s) to verify the case matches.
Word Order
If you are searching for a phrase, you can choose to enforce Word Order.
 *    If you ignore Word Order ("None"), SM/Win finds any verse(s) that have the words--
in any order.
 *    If you enforce Word Order, you use "General" or "Literal" order. "General" order 
requires that the words be found in order, but other words are allowed between them. 
"Literal" order enforces your word order and does not allow words between them. 
Because SM/Win must screen each verse containing the search words, searches that 
enforce Word Order take longer.

Toggling Verse References
Verse references are toggled by pressing the <Space> bar or selecting Toggle on the 
Edit   menu  . If an "*" appears beside the verse, it is toggled ON. If you toggle a reference 
twice, the reference will be toggled OFF. Toggled references are used to print a portion 
of the reference list and to reduce the reference list. 
Reducing Verse References
If you wish to reduce the reference list select Combine Toggled on the Edit menu. All 
toggled verses will be retained.
Adding Verse References
When you want to add a verse or verse range to a verse reference list, select Insert... 
from the Edit menu. You will be asked for the verse range you wish to add.
Deleting Verse References
You can delete one verse by pressing <Del>. 
PEEKing at Verse References in Context
You can PEEK at a verse in context by pressing <Enter>.
Hit Highlighting



All SEARCH phrase words are highlighted - even the words outside the "Literal" Word 
Order. This lets you see uses of your words that you might otherwise miss.

Using SEARCH Files
SEARCH file names have a "SMS" (SeedMaster Search) extension.
Saving SEARCH Files
Save As
To save a new SEARCH file, select Save As... from the File   menu  . This will allow you to 
specify a name for the file. 
Save
To save and update an existing SEARCH file, select Save from the File menu. 
Opening SEARCH Files
When you want to Open a SEARCH file, select Open from the File menu. 
Merging SEARCHes
You can Merge a stored SEARCH with the current SEARCH on the screen using AND, 
OR, XOR or NOT logic. To merge SEARCHes, select Merge... from the File menu. The 
Merge dialog window will appear. It lets you choose your merge type:
OR - This creates a SEARCH containing all verses in either of the original SEARCHes. 
Use it when you want to combine two SEARCH lists into one comprehensive list.
AND - This builds a SEARCH containing only those verses in both of the original 
SEARCHes. Use it when you want to look at verses common to two SEARCHes.
XOR - XOR stands for "eXclusive OR". It creates a SEARCH containing verses in either 
original search -but not both. 
NOT - This removes from the screen SEARCH any verses in the disk-based search. 
After you exit the Merge dialog window, select the SEARCH file you wish to merge. 

Using Search Statistics
Search Statistics gives you a panoramic view of your search, with number of hits by 
book, and within each book, number of hits per chapter. Select Search Statistics... on 
the Search menu. Search Statistics provides the total number of hits within the book, 
and the approximate percentage of the total number of hits. 
You can cursor around on the books using the arrow and tab keys. You can press 
<Enter> to view a chapter by chapter summary of a book.



NOTEPAD Details
NOTEPAD is a paragraph oriented text editor similar to the Windows Notepad. 
NOTEPAD supports "word wrap" to show long lines of text in the window. Word wrap is 
based on window margins, not printer margins. It keeps long lines from going off the 
end of the window where you can't see them. When you print from NOTEPAD, your 
printer margins are enforced at that time. Paragraphs will reformat to printer margins. 

Entering Notes
To enter NOTEPAD, select New Notepad from the File   menu  . You can then type in the 
NOTEPAD using the System font. You cannot type in Greek characters in the Symbol 
font in the NOTEPAD. 
Forward/Backward Search
Forward or Backward Search are available. Select Find... from the Search   menu  . 
Pasting Text
To paste text from the Windows Clipboard, position the cursor where you want the text 
inserted, and select Paste from the Edit   menu  . The text will be inserted.
Printing from Notepad
To print, select Print... from the File menu. Select your options on the Print dialog 
window.
Exiting Notepad
To exit NOTEPAD, select Close from the File menu. If you made any changes to the 
NOTEPAD text since your last save, NOTEPAD will give the opportunity to save the file.

Notepad Files
A Notepad file is a DOS TEXT (or ASCII TEXT) file and can be read by almost any word 
processor. Default NOTEPAD file names have "TXT" extensions. When opening 
NOTEPAD files, SM/Win automatically lists all files with the "TXT" extension. 
Saving Notepad Files
Save As
To save a new NOTEPAD file, select Save As... from the File menu. This will allow you 
to specify a name for the file.
Save
To save and update an existing NOTEPAD file, select Save from the File menu.
Opening Notepad Files
When you want to Open a NOTEPAD file, select Open... from the File menu.



COMMENTARY Details
Like NOTEPAD, COMMENTARY is a paragraph oriented text editor similar to the 
Windows Notepad. You can only open one COMMENTARY in SM/Win since it will 
automatically synchronize with other SM/Win child windows. COMMENTARY supports 
"word wrap" to allow you to see long lines of text in the COMMENTARY window. 
You may type any comments you wish for the current verse. That verse is indicated at 
the top of the COMMENTARY window. You do not need to worry about "saving" your 
comments. SM/Win will do it automatically when you:
    *    Enter new comments for a verse
    *    Edit existing comments
    *    Exit COMMENTARY
    *    Exit SM/Win

Entering COMMENTARY
To begin COMMENTARY, select New Commentary from the File   menu  . You can then 
type in the COMMENTARY using the System font. You cannot type in Greek characters 
in the Symbol font in the COMMENTARY.
Forward/Backward Search
Forward or Backward Search are available. Select Find... from the Search   menu  . 
Pasting Text
To paste text from the Windows Clipboard, position the cursor where you want the text 
inserted, and select Paste from the Edit   menu  . 
Printing from COMMENTARY
To print from COMMENTARY, select Print... from the File menu. SM/Win will ask you 
for the range of COMMENTARY verses that you wish to print. It will then print the 
comments for that verse range.Note: You can also include your COMMENTARY 
comments when you print Bible text from various STUDY modes.
Exiting COMMENTARY
To exit COMMENTARY, select Close from the File menu. The window will be removed, 
any changes to the comments saved, and memory associated with the COMMENTARY 
will be freed.
Recovering Disk Space
As you create and edit comments for verses, "dead" space is left in the main 
commentary file, "COMMENT.SMC". The CLEANCOM.EXE program recovers that dead 
space. You can run CLEANCOM manually or from a batch file. CLEANCOM must be in 
the same directory as the COMMENT.NDX and COMMENT.SMC files. To run 
CLEANCOM, type: CLEANCOM <Enter> at that directory. CLEANCOM will recover the 
dead space from the COMMENT.SMC file and rewrite the COMMENT.NDX file. If there 
is no dead space in the COMMENT.SMC file, CLEANCOM terminates quickly.



OH NO! It Didn't Work!
Deleting OPTIONSW.DAT
The OPTIONSW.DAT file contains option settings. If this file is corrupt, SM/Win behaves 
strangely. Try deleting it and restarting the program. 
Problems in the Bible Texts
The texts have been obtained from good sources. There should be few, if any, 
problems. There are some variations between various KJV texts--you may find some of 
those. If you find a genuine problem, explain it to us. Include a phone number and your 
user registration number. Please note that we will not make changes beyond 
compliance with the original KJV text, even if the KJV text spelling or usage is archaic or 
inconvenient. As a trivial example, the KJV spells "ankle" as "ancle". 
Paragraphing in the KJV Text
We have added the paragraph breaks to the KJV text. Although they have been 
checked and cross-checked, it is possible that a break was omitted or an extra one 
inserted. Also note that different texts show different breaks. We advise that the 
paragraph breaks should not be considered "inspired" or "infallible". We think they 
improve read-ability. If you don't, turn off Paragraph Form in the View menu.
SM/Win Bug Reports
Software developers hear about two types of "bugs":
1. A genuine bug--the software doesn't do what it is supposed to. SM/Win is tested in-
house and by beta testers, but we cannot say it is free of bugs. If you find one, explain it 
(with "Print Screen"'s, printouts, etc.) and send it in. Include your phone number and 
user number. 
2. A "wishful" bug--the software doesn't do something you want it to, but we never said 
it was supposed to. We made an effort to make a flexible and powerful program, but you 
can't please all the people all the time. Example: After a phrase search with "Literal" 
word order, you notice the search words are highlighted--even those outside the 
"Literal" phrase. You might think this is a "bug". We think it is a feature. Since you have 
an interest in the phrase words, highlighting all occurrences of them might help you see 
some word usages you might otherwise miss.
Problems in the Documentation
If you find errors in the manual, explain the problem, suggestions or resolutions. Include 
your user registration number and phone number. All submissions will be the property of 
White Harvest Software, Inc. 



Trademarks
Product names other than SeedMaster and SM/Win are trademarks of their 
manufacturers.



User Registration
SM/Win is distributed in a unique way. We created SM/Win for broad distribution and, 
under certain conditions, permit you to copy it for others. See "Installation/Distribution" 
in this manual before you make a copy of SM/Win. If you find SM/Win useful, we ask 
that you send in a registration form and the "registration fee". A registered user receives:
 *    The latest version of the software program
 *    A complete documentation manual
 *    Our heartfelt thanks

They will also be notified of the availability of Program Updates, Enhanced Versions, 
and Additional Bible Versions. We believe most people will appreciate our efforts in 
creating SM/Win and will honor our request to register this unique package. 
Unregistered users can obtain further information and print a registration form from the 
Help menu. The registration fee is currently $40.

More ... 



Switch Version
Switch Version lets you choose another Bible text for your current VIEW window. 
Unavailable Bible texts will be grayed.
Note: If you are currently displaying on the screen in Interlinear Form, you will not 
detect the change in that VIEW mode.



Copy to Clipboard
The Copy to Clipboard dialog box offers the following selections:

Append to Clipboard Text
If there is already text in the Windows Clipboard, you can choose to replace it or you 
can append the new text at the end of the existing text. If this box is checked, the new 
text will be appended. If this box is not checked, the new text will replace the existing 
text. If this checkbox is grayed, there is no text in the Clipboard.
Paragraph Form
Check the Paragraph Form check box if you want to print Bible text from VIEW or 
PEEK mode in paragraph form. Uncheck the check box if you want the Bible verses 
separated, each beginning on a new line.
Use Interlinear Form
Check the Interlinear Form check box if you want to print using the Interlinear Order 
entered on the Screen Format Dialog Box from the View menu. Uncheck the box if you 
want to use the default Bible version for the currently selected SM/Win client window.
Send Commentary w/ Verses
The Send Commentary With Verses check box field allows you to print 
COMMENTARY text with Bible verses you print from VIEW, SEARCH or PEEK. If the 
box is checked, COMMENTARY will be printed with the verses. 
Send References Only
The Send References Only check box allows you to print only Verse References, 
without the verses' text. This is useful if you want a list of reference verses (from a 
SEARCH) without the accompanying text. If the box is checked, only the references will 
be printed. If you are not printing from SEARCH, this option does not have any meaning 
and this check box field is unavailable. 
Send Toggled Only
The Send Toggled Only check box field allows you to only print SEARCH verses you 
have toggled ON (*). If the box is checked, only toggled verses will print. If the box is not 
checked, all SEARCH verses will be printed. If you are not printing from SEARCH, this 
option does not have any meaning and this check box field is unavailable.
Range Button
When printing from VIEW or PEEK, you need to select a range of verses. The default 
range is the current verse and is shown to the right of the Range Button. Selecting the 
Range Button brings up the Range Dialog Box.
Send Button
Select the Send Button when you are pleased with your settings and are ready to print 
to the Clipboard.
Cancel
Select Cancel to return to your previous SM/Win client window.

See also: Print Dialog



Screen Format
The Screen Format dialog box allows you to set screen options in SM/Win:

Verse Buffer Size
Verse Buffer Size controls the amount of disk buffering performed while viewing 
verses. The lower the number, the faster SM/Win refreshes its disk buffers as you scroll 
verses. In general, low values are best for slower systems. Often, only one half of the 
verses buffered will be displayed in the VIEW or PEEK window at a time. If they do not 
fill up the window, the rest of it will be blank. Valid values range from 30 to 99.
Suppress {Footnotes}
Suppress {Footnotes} lets you remove Bible text footnotes appearing in braces {}. The 
KJV has no footnotes, so if this your only Bible version, this option is unavailable. Most 
SM/Win Bible versions have footnotes. If checked, footnotes will be supressed.
Paragraph Form
Paragraph Form controls formatting of verse. If checked, it prints the maximum number 
of verses in the available space. If you do not use the paragraph form, the verses will be 
separated, each beginning on a new line. Some prefer non-paragraphed display. It fills 
up space with fewer verses than paragraph display, so for the screen you can use a 
lower Verse Buffer Size.
Interlinear Form
Interlinear Form lets you display multiple Bible versions for each verse. Each version 
appears, one after another. The version type appears after the verse text. If checked, 
Interlinear Form will use the Interlienar Order defined under Screen Format.
Interlinear Codes
Interlinear Codes lets you customize the order of interlinear Bible versions. Enter the 
codes for the Bible versions you want displayed, in order. G=GNT, K=KJV, N=NIV, 
R=RSV, V=RVA. For example, If you wanted all the translations shown in alphabetical 
order, you would enter "GKNRV". We can't think why you would want to, but you can 
use the same Bible version more than once. "KKKKK" would sure look strange, but it 
will work.
Verse Fragments
Verse Fragments lets you speed up the display of Search results.
If you select "None", only the verse references (no verse text) will appear. This can 
result in significantly faster searches, especially on slow computers.
If you choose "Verse Start" or "Word Context", a fragment of the verse will be 
displayed in the ajoining window. 
If you use "Verse Start", the beginning of the verse will show. Many people recognize a 
verse by how it starts, rather than    the words in the middle. Also, it is a little faster than 
"Word Context".
If your answer is "Word Context", the context of the searched word(s) will show. If more 
than one word is used, the first one in the verse is keyed on. This helps you quickly 
screen word uses. For example, the word "lie" can indicate falsehood or a reclining 
position.



Save As
Save As lets you specify a file name for your Search or Notepad files. We suggest you 
use "SMS" as a file extension for Search files. For Notepad files, we suggest "TXT".



Directories Dialog
Directories allows you to specify the directories SM/Win uses for COMMENTARY and 
each SeedMaster Bible databases. Any changes will take effect the next time you start 
SM/Win. If you put a SeedMaster Bible database in a different drive or directory than the 
one the SM/Win program is in, you will need to define it here so the next time SM/Win 
starts, it will find the Bible text. 



Merge
You can Merge a stored Search with the current search on the screen using AND, OR, 
XOR or NOT logic. The Merge dialog lets you choose your merge type:
OR
This creates a search containing all verses in either of the original searches. Use it 
when you want to combine two search lists into one comprehensive list.
AND
This builds a search containing only those verses in both of the original searches. Use 
it when you want to look at verses common to two searches.
XOR
XOR stands for "eXclusive OR". It creates a search containing verses in either original 
search--but not both. 
NOT
This removes from the screen search any verses in the disk-based search. Suppose 
your disk search was for the word "hate", and your screen search was for the word 
"love". Examples:

The screen search contains verses:
1, 2, 3, 5
The disk search contains: 1, 2, 4
OR result: 1, 2, 3, 4, 5
AND result: 1, 2
XOR result: 3, 4, 5
NOT result: 3, 5

After you exit the Merge dialog window, the File List will appear. Select the search file 
you wish to merge. SM/Win will then merge that file with the existing search on the 
screen.



Search Ranges
Range(s) allows you to define up to 26 different Search ranges - either continuous or 
non-continuous. The possible ranges include:
Add All Verses
Add Old Test. (Old Testament)
Add New Test. (New Testament)
Add Book... (Specific Book)
Add Range... (Any Specific Range)
You can create overlapping ranges. For instance, you could use Add Old Test. and 
Add All Verses. 
To delete a sub-range, use the Delete button.
When you select the OK button to exit, SM/Win builds the cumulative search range that 
encompasses all defined ranges. This cumulative range will be used for all subsequent 
searches until it is redefined. 



Screen Fonts
You can set screen fonts for four types of text in SM/Win's windows. A brief description 
of the font settings appears in each of the font boxes:

English font is for the KJV, NIV and RSV texts. This is the only place to select a font 
size. All other fonts will be based on the size of the English font. So, even if you don't 
have an English Bible text, you need to set this font if you want to change the size of 
other fonts.
References font is used for showing Book:Chapter:Verse references. We like a bold, 
superscript font like Helv for references.
Greek font is for the GNT text. You may select the Symbol font for Greek characters, an 
ANSI font for transliterated Greek, or the IBM OEM (high ASCII) characters to use our 
"approximated" Greek. Breathing marks are not available in this release.
Spanish font will be used for the RVA text.
Notepad, Commentary font is fixed as the System font, so this font box is grayed. You 
can define a printer font for this text, however.

To define a font, select the Set...   button   in the font box. 



Set Screen Fonts
The following are the input options for the Set Screen Font Dialog:

Font List Box
All available Windows screen fonts will be listed in the Font list box. Note that the 
Windows Roman, Modern and Script fonts are not recommended. 
Size List Box
The Size list box will list all available point sizes for the selected screen font. It is only 
available in the English Screen Font dialog box. All other screen fonts (except the 
Notepad and Commentary's System font) will be based on this font size. You can enter 
a specific size. If the size is not listed, the font may not match your size since SM/Win 
asks Windows to enforce "proof quality" on the fonts.
Character Set
If you check the Use fixed OEM box, the Font and Size selections will be ignored and 
SM/Win will use the OEM character set. In our opinion, this is only really useful for 
displaying Greek text in SM/Win's "approximated" Greek characters. The 
"approximated" Greek set uses the extended IBM ASCII character set to match actual 
Greek characters as closely as possible.
Verse Text
You can choose to make the Bible text Bold and/or Italic if you wish. To distinguish 
search words, these attributes should differ from the Search Hits attributes.
Search Hits
Search words in the Bible text can be displayed as Bold, Italic and Underline. 

Greek and Spanish Fonts
The Greek and Spanish font definitions are similar to the English definition, except that 
you cannot define a font size.

Reference Font
The font defintion for the Verse References differs slightly from the other fonts:

General
You can select any font from the Font list box. The OEM Character Set is available, 
but not recommended. Verse Text refers to the attributes of the verse reference. You 
can choose Bold and or Italic.
Position
The Position choices are a new feature of the Reference Screen Font defintion. To 
use the same    size as the English font, select Normal. Also, you can use a font 
size about half the size of the English font, and make it Subscript or Superscript. If 
your English font size is large enough, we recommend Superscript, as the result 
look similar to many Bibles.



Printer Fonts
You can set screen fonts for five types of text in SM/Win's windows. A brief description 
of the font settings appears in each of the font boxes:

English font is for the KJV, NIV and RSV texts. 
References font is used for showing Book:Chapter:Verse references. We like a bold, 
superscript, sans serif font (like Helv).
Greek font is for the GNT text. If available, you may select the Symbol font. The Symbol 
font is not available on all printers, however. You can also select an ANSI font for 
transliterated Greek, or the IBM OEM (high ASCII) characters to use our "approximated" 
Greek. Breathing marks are not available in this release.
Spanish font will be used for the RVA text.
Notepad, Commentary font is use for printing the Notepad and Commentary text. 

Unlike screen fonts, you can define different font sizes for each type of printed text.
To define a font, select the Set...   button   in the font box. 



Set Printer Fonts
The following are the input options for the Printer Font Dialog:

Font List Box
All available Windows and printer fonts will be listed in the Font list box. Note that if you 
have a graphics printer, the Windows Roman, Modern and Script fonts are available. 
However, be advised that these fonts are generated "on the fly" by Windows an are 
extremely slow compared to your printer's fonts. They are not recommended. 
Size List Box
The Size list box will list all available point sizes for the selected screen font. If the font 
is a scaleable font, common selections will be displayed. You can also enter your own 
specific size. If you enter a size not listed, the font size used may not match that size 
exactly. 
Character Set
If you check the Use fixed OEM box, SM/Win will attempt to print using the extened 
ASCII characters in the OEM IBM ASCII character set. Not all fonts have these 
characters defined, so if your selected font does not use these characters, the results 
are unpredicable and likely undesireable. In our opinion, this is only really useful for 
displaying Greek text in SM/Win's "approximated" Greek characters. The 
"approximated" Greek set uses the extended IBM ASCII character set to match actual 
Greek characters as closely as possible.
Verse Text
You can choose to make the Bible text Bold and/or Italic if you wish. These attributes 
are applied to the Bible text. To distinguish search words, these attributes should differ 
from the Search Hits attributes. If these attributes are unavailable for the selected font, 
they will be grayed.
Search Hits
Search words in the Bible text can be displayed as Bold, Italic and Underline. Select 
different attributes from Verse Text above to help you distinguish search words. If these 
attributes are unavailable for the selected font, they will be grayed.

Greek and Spanish Fonts
The Greek and Spanish font definitions are similar to the English definition.

Reference Font
The font defintion    for Verse References differs slightly from the other fonts:

General
You can select any font from the Font list box. As the other non-English screen 
fonts, you cannot select a size in the Size list box. The OEM Character Set is 
available, but not recommended. Verse Text refers to the attributes of the verse 
reference. You can choose Bold and or Italic.

Position
The Position choices are the new feature of the Reference Screen Font defintion. 
To position the font same as the other fonts, select Normal. In addition, you can 



position the font (if it is smaller) and make it Subscript or Superscript. If your font 
sizes are large enough, we recommend Superscript, as the result look similar to 
many Bibles.



Select Range
The Select Range Dialog lets you select a range of verses. Enter a beginning and 
ending verse, which can overlap book and chapter boundaries.
Note: You can enter the beginning and ending verse in any order in the top and bottom 
entries.



Print Dialog

The Margin fields allow you to control the margins used on your page. The number to 
enter is in tenths of an inch. So, if you want a one inch margin, enter 10. If you wanted 
an inch and one half, enter 15.

Check the Paragraph Form check box if you want to print Bible text in VIEW or PEEK 
mode in paragraph form. Uncheck the check box if you want the Bible verses 
separated, each beginning on a new line.

Check the Interlinear Form check box if you want to print using the Interlinear Order 
entered on the Screen Format...   Dialog Box   from the View menu. Uncheck the box if 
you want to use the default Bible version for the currently selected SM/Win client 
window.

The Print Commentary With Verses check box field allows you to print 
COMMENTARY text with Bible verses you print from VIEW, SEARCH or PEEK. If the 
box is checked, COMMENTARY will be printed with the verses.

The Print References Only check box field allows you to print only Verse References, 
without the verses' text. This is useful if you want a list of reference verses (from a 
SEARCH) without the accompanying text. If the box is checked, only the references will 
be printed. 

The Print Toggled Only check box field allows you to only print SEARCH verses you 
have toggled ON (*). If the box is checked, only toggled verses will print. If it is not, all 
SEARCH verses will be printed. 

When printing from VIEW, PEEK or COMMENTARY, you need to select a Range of 
verses. The default range is the current verse and is shown to the right of the Range 
Button. Selecting the Range Button brings up the Range Dialog Box.

Use the Print Button when you are ready to print.

Select Cancel to return to your previous SM/Win client window.



Registration Form
Registration Form lets you register your copy of SM/Win.
Please enter the information requested. After you are finished, the registration form will 
print. (Make sure your printer is on, etc.) Fill out the rest of the form and send to the 
address at the top of the form.

Thank You!

More Information...



VIEW
The following is a summary of common operations in VIEW mode.

Go to prior book. <Home>
Go to prior chapter. <PgUp>
Move up one verse. <Up> or <Left>
Move down one verse. <Down> or <Right>
Go to next chapter. <PgDn>
Go to next book. <End>

Word or phrase search Search, Word/Phrase
WORD List Word, Word List
Forward Search Search, Find
Switch Bible version View, Switch Version
Select a New Verse View, New Verse
Print a verse range File, Print
New Study File, New Study
Notepad File, New Notepad
Commentary File, New Commentary



COMMENTARY
The following is a summary of common operations in COMMENTARY mode.

Go to top of window. <PgUp>
Go to beginning of a line. <Home>
Move up one line. <Up>
Left one word. <Ctrl><Left>
Left one character. <Left>
Right one character. <Right>
Right one word. <Ctrl><Right>
Move down one line. <Down>
Go to end of line. <End>
Go to bottom of window. <PgDn>
Delete to End of Line <Ctrl><Del>

Close File, Close
Forward Search Search, Find
Paste from Clipboard Edit, Paste
Print comments File, Print



WORD
The following is a summary of common operations in WORD list mode.

Go to beginning of words <Home>
Go to top of window <PgUp>
Move up one line <Up> or <Left>
Move down one line <Down> or <Right>
Go to end of window <PgDn>
Go to end of words <End>

FIND verses for current word <Enter>
FIND search for toggled words Edit, Combine Toggled

New letter (A through Z) <A-Z>
Toggle words ON/OFF <Space>
Restart word list Words, Word List



SEARCH
The following are some options within the SEARCH mode:

Go to beginning of references. <Home>
Go to top of window, scroll if req'd. <PgUp>
Move up one verse. <Up> or <Left>
Move down one verse. <Down> or <Right>
Go to end of window, scroll if req'd. <PgDn>
Go to end of references. <End>

View a verse in context <Enter>
Toggle verses ON/OFF (* = ON) <Space>
View only Toggled Verses Edit, Combine Toggled
Insert Verse(s) <Ins>
Delete the Selected Verse <Del>
Merge with a Search File File, Merge
Save a Search with a new name File, Save As
Save a Search File, Save
Open a Search File File, Open



NOTEPAD
The following is a summary of common operations in NOTEPAD.

Go to top of window. <PgUp>
Go to beginning of a line. <Home>
Move up one line. <Up>
Left one word. <Ctrl><Left>
Left one character. <Left>
Right one character. <Right>
Right one word. <Ctrl><Right>
Move down one line. <Down>
Go to end of line. <End>
Go to bottom of window. <PgDn>
Delete to End of Line <Ctrl><Del>

Forward Search Search, Find
Print file File, Print
Save file File, Save
Save as name  File, Save As
Open file File, Open



Search Statistics
Move forward <Tab>
Move backward <Shift><Tab>
View Chapters or Verses <Enter>
Quit <Esc>

The Search Statistics provide a book by book and chapter by chapter summary of 
Search "hits". Initially, Search Statistics displays a book by book list, also indicating the 
percentage of the total number of search verses to the right    of the number of hits. This 
percentage is calculated using simple integer math, and is subject to a small amount of 
rounding error. If you press <Enter> on a book, the underlying chapters will be 
displayed. If you press <Enter> on a chapter, the search list will be advanced to the first 
verse within that chapter. If there is no hits within that chapter, the search list will be 
advanced to the nearest verse. Search Statistics can be used to quickly advance to 
other hits within a search list.



Single Word Input
Enter a single word.
If you want to type accented RVA (Spanish) characters, type an apostrophe before the 
accented character. For instance, to type an accented e type 'e. The proper characters 
will appear in the special window below. If you are typing in Greek, the characters in the 
symbol character set will appear in the special window. 



Word/Phrase

Find:
Enter the word or phrase words you wish to Search for. 
If you want to type accented RVA (Spanish) characters, type an apostrophe before the 
accented character. For instance, to type an accented e type 'e. The proper characters 
will appear in the special window below. If you are typing in Greek, the characters in the 
symbol character set will appear in the special window. 
You can use the "*" as a wildcard at the beginning and/or end of a search word. For 
instance, you can use "*lov*" to find "beloved", "loved", etc. If you use the wildcard 
symbol "*" at the beginning of a search word, the search will take longer, since SM/Win 
must search through every word in its word list, looking for the word root.

Notes: Punctuation symbols are ignored for searching purposes. The only exception 
is an apostrophe imbedded in a word (such as those indicating possession i.e., "the 
lion's mouth"). Apostrophes at the end of a word are ignored.

Case Sensitive
If the Case Sensitive box is not checked, case sensitivity will not be enforced. This will 
generate the most references from a word combination, and will be the fastest search. If 
the box is checked, case sensitivity will be enforced. SM/Win must then screen potential 
verses containing phrase words for the proper cases. This takes more time.

Word Order
If you select "None", no order will be enforced. This will generate the most references 
from a word combination, and will be the fastest search. 
If you select "General" or "Literal", SM/Win must screen potential verses containing 
phrase words for the proper order. This takes more time than a "None" search, but it will 
be faster than you can screen the verses manually. 
If you choose "General" order, the words will be in order, but other words may be 
BETWEEN the phrase words. 
If you use "Literal" order, only spaces or punctuation will be permitted between words.
If you have enabled Case Sensitivie on the dialog box, adding Word Order won't 
signficantly slow down a search.



New Verse
Select the book, chapter, and verse you want to go to. The valid range of chapters and 
verses will be displayed in each field.



Open File
Select the file you wish to open. 
For SM/Win Search files, the extension should be "SMS".
For Notepad files, the extension should be "TXT".
Make sure you only retrieve the correct types of files, the results of other file types are 
undefined.



Menu Help
The SM/Win menu is grouped by major function area. The menu items are listed 
beneath each function area automatically. Not all menu items are active at all times. 
Active items are displayed in a normal font on your monitor. Inactive items are displayed 
grayed. 
To move to another function area, press the <Left> or <Right> cursor keys.
To select a menu item, move the reverse image bar over the desired menu item (with 
the cursor control keys <Up>, <Down>, etc.) and press <Enter>. Or, press the 
highlighted (or underlined) letter of the menu item description. Once you select your 
menu item, the menu will disappear and SM/Win will perform the task you selected. 
You may quit the menu (not selecting a menu item) by    pressing <Esc>.
Select the following function areas for a brief description of each menu item:

File
Edit
View
Search
Words
Window
Help



File Menu

New Study lets you open a new STUDY window.

New Notepad lets you open a new NOTEPAD window. 

New Commentary lets you open the single COMMENTARY window in SM/Win. If 
grayed, you already have the COMMENTARY open.

Open "opens" existing SEARCH and NOTEPADNotepadGen files, from SEARCH and 
NOTEPAD respectively.

Save "saves" a SEARCH or NOTEPAD file. If the SEARCH or NOTEPAD does not have 
a file name, you will be asked to enter one.

Save As allows you to "save" a SEARCH or NOTEPAD "as" a file name. Use Save As 
when you want to save a file for the first time, or if you want to save a file more than 
once under different names.

Merge lets you "merge" a stored SEARCH with a SEARCH on the screen. The Merge 
dialog window will let you choose your merge logic.

Close is used to close an active SM/Win window. If there is unsaved text in NOTEPAD 
or an unsaved SEARCH, you will be asked to save the file before exiting if you have 
made changes since your last save. In COMMENTARY, your changes are automatically 
saved. 

Directories allows you to specify the Directories SM/Win uses for COMMENTARY and 
each SeedMaster Bible databases. Any changes take effect the next time SM/Win is 
started.. 

Print allows you to print from STUDY (except WORD mode), NOTEPAD and 
COMMENTARY windows. The Print dialog window will appear following this choice. If 
this option is grayed, you do not have a default Windows printer. 

Printer Setup allows you to configure your printer under Windows. This option is not 
available for all printers under Windows, and the options available vary by printers.

Printer Fonts lets you set printer fonts for English, Greek and Spanish Bible text, verse 
references, and NOTEPAD and COMMENTARY text.

Full/Short Menus lets you switch between the Full menu selections and simple, Short 
menus with few selections.

Exit is used to exit SM/Win. 



Edit Menu

Undo lets you undo the last change in NOTEPAD or COMMENTARY.

Cut lets you remove selected text from NOTEPAD or COMMENTARY and move it to the 
Windows Clipboard. 

Copy lets you copy selected text from NOTEPAD or COMMENTARY to the Windows 
Clipboard, without removing it.

Paste is used to paste text from the Windows Clipboard to the NOTEPAD or 
COMMENTARY. If grayed, no compatible text exists.

Delete is used in SEARCH to delete the selected verse reference.

Insert is used to insert a SEARCH verse reference or a verse range. 

Toggle "toggle" words in WORD or verse references in SEARCH.
In WORD, Combine Toggled combines toggled words using the Word Logic (AND or 
OR). In SEARCH, Combine Toggled combines toggled verses and removes non-
toggled from the search.



View Menu

New Verse lets you move to a "new" current verse in VIEW mode.

Switch Version allows you to switch to another Bible version in VIEW.

Synchronize Views allows you to "synchronize" the scrolling of all open VIEW and/or 
PEEK windows. If checked, Synchronize Views is ON. If a VIEW or PEEK window is 
minimized to an icon, it will not be sychronized.

Synchronize Views to Search lets you "synchronize" the scrolling of all open VIEW 
and/or PEEK windows to a SEARCH window. This provides "PEEK" function while the 
SEARCH is still on the screen. If checked, Synchronize Views to Search is ON. If a 
VIEW or PEEK window is minimized to an icon, it will not be sychronized.

Screen Fonts lets you set the screen fonts for English, Greek and Spanish Bible text, 
as well as verse references.

Screen Format lets you set the Verse Buffer Size, Paragraph Form, Suppress 
{Footnotes}, Use Interlinear Form, Interlinear Form and Search Verse Fragments 
display options.



Search Menu

Word/Phrase allows you to initiate a Word/Phrase Search with options to enforce case 
sensitivity and or word order.

Search Statistics brings up the Search Statistics search summary.

Ranges allows you to specify a verse range to be used for WORD List and SEARCH 
searches. Up to 26 non-continuous search ranges may be defined.

Find lets you enter a word to search for in NOTEPAD, COMMENTARY and 
VIEW/PEEK. It then advances to the next occurance of the word.

Next performs a "forward" search in NOTEPAD, COMMENTARY and 
VIEW/PEEK.VIEW, COMMENTARY, WORD, or NOTEPAD. It advances to the next 
occurrence of the word. 

Previous is similar to Next (above), except it finds the previous occurrence of a word.



Words Menu

Word List allows you to change to WORD List mode from VIEW or move to a "new 
word" within the WORD List.

Word Logic allows you to choose AND or OR logic for use in combining toggled words 
in the WORD List. 



Window Menu

Tile allows you to tile open SM/Win windows within the SM/Win main window. 

Cascade lets you arrange open SM/Win windows within the SM/Win main window so 
that they overlap, but the title bar of the window is visible. 

Arrange Icons organizes all SM/Win windows minimized to an icon.

Close All closes all open SM/Win windows.

Prior Study Mode moves you backwards through the VIEW-WORD-SEARCH-PEEK 
sequence to the prior STUDY mode. You can also press <Esc> instead of using this 
menu selection.

(Open Windows)
All open SM/Win windows are listed at the end of the Window menu. You can bring a 
window to the top and make it active by selecting it from this list.



Help Menu

General allows you to view "general" instructions and help for SM/Win.

Index allows you to choose from a index of help topics.

Context Sensitive will move you directly to context sensitive help for your current place 
in SM/Win. This is the same as pressing <F1>.

Registration Info provides information on registering a copy of SM/Win.

Registration Form allows you to enter your name, address and phone number and 
print out a registration/order form for SM/Win and related products.

About SeedMaster lists the copyright notice for SM/Win and the SeedMaster Bible 
databases. 


