
 Purchasing the Licensed Version of WordExpress

The licensed version of WordExpress can be obtained by contacting the vendors listed below.    Click on the vendors 
name to display the information for that vendor.    You can then use File/Print/Topic to print the order form.

There are many benefits to becoming a registered user.    Among them are a printed manual, free technical support, 
product updates, and discounts on other MicroVision products.

Vendor:
MicroVision Development, Inc. United States
The Thompson Partnership United Kingdom
WindowShare SARL France
BroCo Software Nederland
Pro-Soft Denmark

Thank you for using MicroVision products.

Help Contents:

User Basics
Commands
Keyboard



The Thompson Partnership (United Kingdom)
Use File/Print/Topic from the menu to print this form.

You can order from The Thompson Partnership by payment with cheque or credit card.    The credit cards accepted 
are: MC, Visa, Diners Club, and American Express. 

Telephone Orders: 44 (0) 889 564601
Fax Orders: 44 (0) 889 563219
Internet Orders: sales@ttp.co.uk
Internet Support: support@ttp.co.uk

Please use this form when ordering by fax or mail:

Name ________________________________________________

Company _____________________________________________

Address ______________________________________________

Address ______________________________________________

Town ________________________________________________

City _________________________________________________

Country _______________________    Postal Code ___________

Telephone ________________________________

Credit Card Type __________________________

Credit Card Number _______________________

Expiration Date ___________________________

Disk Size 3.5"_____ 5.25"______

Spell Check: Am. English Intl. English German French 

Spanish Italian Danish Dutch

(WordExpress International please select three languages)

____ Copies of WordExpress @ £39.00 £____________

____ Copies of WordExpress International @ £55.00 £____________

____ Additional Languages @ £15.00 £____________

V.A.T.    @ 17.5% £____________

Shipping and Handling £3.00

Total: £____________

Make cheques or EuroCheque payable to: The Thompson Partnership.
(Be sure your card number is on the reverse of the cheque)

Mail to:
The Thompson Partnership
Church Croft
Bramshall,
UTTOXETER
Staffs, England
ST14 5DE



MicroVision Development, Inc.    (United States)
Use File/Print/Topic from the menu to print this form.

Payment by Credit Card:
Payment can be made by MasterCard, VISA, American Express or Discover through PsL.    PsL will notify us 
immediately, and your order will be shipped directly to you.    PsL can take orders only, for all other matters please 
contact MicroVision directly at (619) 438-0305.

(800) 242-4775 Toll Free 
(713) 524-6394 Voice
(713) 524-6398 Fax

Payment by Check:
Make checks payable to: MicroVision Development, Inc.    Checks must be drawn on a US bank.

MicroVision Development, Inc.
P.O. Box 3010
Carlsbad, CA    92009
USA

Order Information:

       Copies of WordExpress    @ $49.95 $_____________

       Copies of WordExpress International @ $69.95 $_____________

       Additional Languages (please specify) @ $20.00 $_____________

CA residents add sales tax $_____________

Shipping/Handling in US or Canada $5.00 $_____________

Shipping/Handling anywhere else $16.00 $_____________

Total: $_____________

Circle or underline disk size and spell check option:

Disk Size: 3.5" 5.25"

Spell Check: Am. English Intl. English German French

Spanish Italian Danish Dutch

(WordExpress International please select three languages)

User Information:

Name _______________________________________________

Company ____________________________________________

Address _____________________________________________

Address _____________________________________________

City _________________________________________________

State ________________________________________________

Country ________________________    Zip Code _____________

Telephone ____________________________________________

Customer Support:



(619) 438-0305 Voice
(619) 438-7406 Fax
CIS: 75201,2104 E-Mail



WindowShare SARL (France)
Faites FICHIER|IMPRIMER LA RUBRIQUE pour imprimer le bon de commande

Paiement par chèque bancaire ou postal, eurochèque ou
carte de crédit (MasterCard et Visa).

Téléphone : +33 87 30 85 57
Télécopie : +33 87 32 37 75
Minitel : 3615 WinShare, boutique Licenseware

Nom ________________________________________________
Société ______________________________________________
Adresse ______________________________________________
Adresse ______________________________________________
Code Postal ___________Ville    ___________________________
Pays _______________________ 

Téléphone ________________________________
Numéro de carte de crédit ________________________________
Date d'expiration _____________/______________

Dictionnaires orthographiques :
 Am. English Intl. English Deutsch Français

Espanol Italiano Dansk Nederlandse
WordExpress International est livré avec trois langues. 
Merci d'indiquer votre sélection en rayant les mentions inutiles.

____ WordExpress à 399 FF TTC ____________
____ WordExpress International à 549 FF TTC ____________
____ Langue supplémentaire à 149 FF TTC ____________

Total : ____________
(Port inclus et TVA 18.6 % incluse)

Adresser ce bon de commande à :
WindowShare SARL
BP 2078
57051 - METZ cedex 2



Pro Soft (Denmark, Norway, Finland and Sweden)
Use File/Print/Topic from the menu to print this form.

You can order from Pro Soft by payment with cheque, Giro or Cash On Delivery. 

Telephone Orders: (+45) 53 61 90 42
Fax Orders: (+45) 53 61 93 91
BBS Orders: (+45) 57 67 17 47, and leave a message.
CompuServe Orders: 100065,1744

Please use this form when ordering by fax or mail:

Name ________________________________________________
Company _____________________________________________
Address ______________________________________________
Address ______________________________________________
Town ________________________________________________
City _________________________________________________

Country _______________________    Postal Code ___________

Telephone ________________________________

Disk Size 3.5" (We do not deliver on 5,25" disks anymore)

Spell Check: Am. English Intl. English German French 
Spanish Italian Danish Dutch

(WordExpress Danish Package has an danish dictionary)
(WordExpress other Scandinavia countries has an Intl. English dictionary)

(WordExpress International please select three languages in total)

____ Copies of WordExpress @ Dkr 420.00 ____________
____ Copies of WordExpress International @ Dkr. 570.00  ____________
____ Additional Languages @ Dkr.150.00 ____________

In Denmark, please add VAT
V.A.T.    @ 25.0%Dkr____________

In Norway, Sweden and Finland VAT will be added at the import.

Shipping and Handling  in Denmark Dkr. 25.00
If send by postopkrav in Denmark, please add Dkr. 22.50.

Shipping and Handling  in Sweden, Norway or Finland Dkr. 50.00
If send with Cash on Delivery please add Dkr. 15,00

Total: Program ____________
Additionally Dict. ____________
VAT Denmark, 25% ____________
Shipping and Handling ____________
Evt. Postopkrav ____________



Total ____________

Mail or fax to:

Pro Soft
Benløse Skel 4 G
DK-4100 Ringsted
Denmark



BroCo software ( Nederland en België )
Selecteer "Bestand / Onderwerp afdrukken" vanaf de menubalk om dit formulier te printen.

Betalingen aan BroCo software zijn te voldoen d.m.v. Eurocheque / postcheque, bank, giro, en EuroCard / 
MasterCard.

Telefonische bestellingen: 31-(0)2155-26650
Fax: 31-(0)2155-14012
Support: 31-(0)2155-29596

Gebruik A.U.B. dit formulier bij schriftelijke bestellingen.

Naam: _______________________________________________________

Bedrijfsnaam: _________________________________________________

Adres: _______________________________________________________

Postcode: ____________________________________________________

Plaats: _______________________________________________________

Land: ________________________________________________________

Telefoon: _____________________________________________________

Credit Kaart Nr.: _______________________________________________

Vervaldatum: __________________________________________________

Disketteformaat:    ALLEEN OP 3.5" LEVERBAAR

Spelling checker: Am. Engels Int. Engels Duits Frans

Spaans Italiaans Deens Nederlands

(Selecteer drie talen voor WordExpress International)

____ Kopieen van WordExpress @ ƒ 119,00 ƒ_____________

____ Kopieen van WordExpress International @ ƒ 169,00 ƒ_____________

____ Aanvullende talen                                          @ ƒ49,00 ƒ_____________

Verzendkosten bij vooruitbetaling ƒ          1 0 , 0 0

Verzendkosten bij remboursement ƒ          1 5 , 0 0

Totaal: ƒ_____________

Stel Eurocheque of postcheque t.n.v. BroCo software, vergeet niet uw pasnummer te vermelden!

Zend dit formulier aan:
BroCo software
Postbus 446
3760 AK    SOEST
Nederland



Benefits of Registration

+ You receive the most current version of WordExpress with your order.

+ Printed manual, master disks, and free technical support

+ Enhanced Spell Check, Thesaurus, and Hyphenator in the language of your choice (English, American English, 
German, French or Spanish).

+ 25 great templates to make using WordExpress easier and more productive

+ Big discounts on other MicroVision products

+ No more registration request screens

+ You're supporting the shareware concept

+ We trust you!



Basics

WordExpress is a tool designed for creating documents such as letters, memos, fax cover pages, reports, newsletters, 
and brochures. It contains commands and features for creating both simple and sophisticated documents. You have 
complete formatting control over characters (font, size, style), paragraphs (indentation, tabs, line height), and whole 
documents (margins, page size).

Documents you create with the WordExpress can include headers and footers, multiple columns, and auto fields such 
as date, time, and page numbers. You can draw simple objects such as lines, rectangles, and ellipses. You can also 
create specialized objects such as text frames, tables, and picture frames -- into which you can import Windows 
Metafile (WMF), Tag Image File Format (TIF), PC Paintbrush (PCX), and Windows Bitmap (BMP) files.

WordExpress has two basic modes: text and object. Text mode is the default mode. This is where you enter, edit, and 
format text. Object mode (also referred to as pointer mode) is where you draw objects and frames, import pictures, 
and create grid lines. You switch between the two modes by clicking the appropriate button on the control strip 
-- the I-beam button places WordExpress in text mode; the pointer button places it in object mode. Clicking 
the right mouse button switches between modes also or you may choose the "Text Mode" or "Object Mode" 
commands from the View menu.

The control strip changes depending on which mode is active. In text mode, the control strip contains command 
buttons for formatting text, changing alignment options, and creating tabs, as well as menus for selecting font, font 
size, and paragraph styles. A paragraph style is a collection of formatting commands which can be applied all at 
once. In object mode the control strip contains buttons for drawing text frames, picture frames, tables, and simple 
objects.

You can control the display of certain WordExpress tools. For example, you can turn the display of the rulers and 
control strip off, giving you more room on screen for your document contents. You determine display options by 
choosing commands from the View menu.

A spell checker and thesaurus let you check for spelling mistakes, correct them, and search for synonyms (words 
with similar meanings). You can add your own words to a customized user dictionary. This is useful for words such 
as personal names and acronyms.

You can also print merge your documents with data from Comma Delimited (CSV) or dBASE (DBF) files. Print 
merging is useful if, for example, you want to print the same document several times, but change address 
information for each document. If you have a datafile containing names and addresses, WordExpress will substitute 
the fields you specify from it each times it prints a copy of the document.



Command Reference

File Menu
The File menu contains commands for working with document files.    These commands let you perform 
such tasks as creating new files, opening and saving existing ones, and printing, for example.

Edit Menu
The Edit menu contains basic text and object manipulation commands.

View Menu
The View Menu contains commands for changing page display size, as well as options for turning on or off 
the display of certain WordExpress tools.

Format Menu
The Format menu contains commands for changing the appearance of characters, paragraphs, and graphic 
objects.

Object Menu
The Object menu contains commands for drawing and manipulating objects, editing the placement of non-
printing guides, and toggling the snap settings of grids and guides.

Insert Menu
The Insert menu contains commands for inserting special items into your documents such as headers and 
footers, page breaks, auto fields, etc.

Table Menu
The Table menu contains commands for working with WordExpress tables.

Utilities Menu
The Utilities menu contains commands for setting up a print merge, spell-checking documents, and 
customizing the speed tools.

Window Menu
The Window menu contains commands to cascade or tile the document windows, to arrange the icons 
which represent minimized document windows, and to close all open documents.



File Menu

The File menu contains commands for working with document files.    These commands let you perform such tasks 
as creating new files, opening and saving existing ones, and printing, for example.

New Create new documents

Open Open existing documents

Close Close documents without exiting

Save Save changes to your documents

Save As Save a document under a new name

Page Setup Change page dimensions and margins

Print Print Documents

Print Envelopes Print envelopes

Printer Setup Change printer settings and select active printer

Exit Quit WordExpress



File / New

Use "New..." to create a new document or template.    Choosing this command displays the "New" dialog box from 
which you select a template and specify whether you want the new document to appear in a new window.

New Dialog Box

Set Default: Click this button if you want the selected template to be the default template when you start 
WordExpress.

New Window: Check this option if you want WordExpress to create the new document in a new window.    If this 
option is not checked, WordExpress will use the current window for the new document; if the current window 
contains a document that has unsaved changed, you are prompted to save them first.

To Press
Create a new document CTRL+N



File / Open

Use "Open..." to open an existing document or template.    Choosing this command displays the "Open" dialog box 
where you can select from a list of documents or templates.

Open Dialog Box

List Files of Type: Select options from this menu to tell WordExpress the type of document you want to open - 
normal document files (the default), templates, text files, or RTF (rich Text Format) filed.    The type you choose 
here determines the available files in the file list.

New Window: Check this option if you want WordExpress to open the document in a new window.    If this option 
is not checked, WordExpress will use the current window; if the current window contains a document that has 
unsaved changed, you are prompted to save them first.

Select the drive and directory where you want WordExpress to look for documents from the Drives and Directories 
list boxes.

To Press
Open a document CTRL+O



File / Close

Use "Close" to close the current document window.    If unsaved changes have been made to the document, you will 
be prompted to save them first.    You can save them, ignore them, or cancel the "Close" command.

To Press
Close a document CTRL+W or CTRL+F4



File / Save

Use the "Save" to save any changes you have made to the current document.    If this is the first time you have saved 
the document, choosing this command displays the "Save As" dialog box where you can specify a file name and 
directory.

To Press
Save a document CTRL+S



File / Save As

Use "Save As..." to save the current document with a new name and/or directory location.    If you enter a filename 
and directory of an existing document or template, another dialog box is displayed asking whether you want to 
overwrite the existing file.    Choosing "Yes" overwrites the existing file; choosing "No" returns you to the "Save As" 
dialog box where you can enter a different name or directory.

Save As Dialog Box

Filename: Enter a name for the document.    The default filename extension for documents is WD1 and is 
automatically appended to the filename you enter, unless you enter a different extension.

List Files of Type: You can save WordExpress document files as different types:

+ Document (*.WD1) - the native format for WordExpress files.

+ Template (*.WT1) - saves the document as a template.    Templates are pre-configured documents.    Their 
purpose is to provide initial settings for new documents you create.    These initial settings might determine 
the default font, character and paragraph styles, page dimensions, the placement of indents and tabs, even 
pre-typed text and graphics such as logos and addresses for letterhead - virtually anything that can be saved 
with a document can also be saved in a template.

+ DOS/PC-8 Text (*.TXT) - saves the document as a plain text file.    Formatting information and graphics 
are not included in text files.    Text files can be opened and edited by all word processors.

+ Windows ANSI Text (*.TXT) - the same as a DOS text file, but saves text using the Windows ANSI 
character set.

+ Rich Text Format (*.RTF) - saves the document and formatting information (fonts, styles, etc.) in a format 
capable of being transferred between different applications or different computers, such as Macintosh.

Create Dir: Click this button to bring up the "Create Directory" dialog box which allows you to create a directory.    
You may enter an absolute path or a path which is relative the current directory.    After the directory is created, the 
current directory will be set to that directory and you will be returned to the "Save As" dialog box.

Select the drive and directory where you wan the file to be saved from the Drives and Directories list boxes.



File / Page Setup

Use "Page Setup..." to change document orientation, paper size, margins, page numbering, and the starting page for 
headers and footers.

Page Setup Dialog Box

Orientation: Click "Portrait" for a top-to-bottom page orientation (long edge vertical); click "Landscape" for a side-
to-side page orientation (long edge horizontal).

Paper Size: Choose from several different paper and envelope sizes.    A4 size (21 by 29.7 cm.) is the default.    To 
use a custom paper size, enter the appropriate values in the Width and Height boxes.

Header/Footer: Enter the number of the first page on which you want headers and/or footers to be displayed.    You 
can also begin page numbers from a number other than one.    This feature is useful if your document is part of a 
series.

Margins: Enter values for left, right, top, and bottom margins.    Margins are the white space around the borders of a 
page.



File / Print

Use "Print..." to print one or more copies of the current document to the active printer (the printer you select from 
the "Printer Setup" dialog box).

Print Dialog Box

Copies: Enter the number of copies you want printed, if you want more than one.

Pages: If you leave "All" selected, WordExpress prints all pages in your document.    Click "Current Page" to print 
the page where the cursor is located.    To print a range of pages, enter the beginning and ending page numbers in the 
"Pages" boxes.

Print To File: This option lets you print to a disk file rather than to a printer.    After selecting "Print To File" and 
clicking "OK", a dialog box is displayed prompting you to enter an output filename.    Enter the path and filename, 
then click OK to create the output file.

Collate Copies: This option prints one complete copy of the document before printing the next copy.

Drop Pictures: Click this option if you do not want imported pictures to be printed.    This is useful for printing 
drafts, for example.

To Press
Print a document CTRL+P



File / Print Envelopes

Use "Print Envelopes..." to print envelopes of several standard types.    You can print a single envelope, or print 
several envelopes using address data from a merged field.

Print Envelopes Dialog Box

Address To: Enter the address of the addressee.    If document text is selected when you choose the "Print 
Envelopes..." command, that text is automatically placed into this field.    If no text is selected, WordExpress will 
attempt to find an address in your document and place that address in this field.

Return Address: Enter the return address.    Once you have entered an address here, the same address will be filled 
in the next time you choose to print envelopes.    Note that the return address will only be printed if you have 
selected the "Print Return Address" option.

Merge Fields: If you have a merge file selected, then you may choose to add merge fields to the "Address To" field. 
To add a merge field, select the desired field and click the "<<Add" button.    The field will be inserted at the current 
cursor location in the "Address To" field.    You can also type the field name by surrounding it with '{}' (e.g. 
{FIELDONE}).

Envelope Type: Choose the type of envelope desired.

Font: Choose the typeface you which to use for the entire envelope.

Point Size: Choose the point size desired for the entire envelope.

Print Return Address: Click this option if you wish for the return address to be printed.

Print: After you have entered the addresses and set the other options to your satisfaction, click this button to print 
the envelope.



File / Printer Setup

Use "Printer Setup..." to select the active printer and specify printer-specific options.

Printer Setup Dialog Box

Printer: Choose the printer you wish to be used for future print jobs from this list.

Setup...: Click this button to bring up a printer specific dialog box which allows you to configure the currently 
selected printer.



File / Exit

Use "Exit" to quit WordExpress and return to the Windows' Program Manager.    If any unsaved changes have been 
made to open documents when you choose this command, you are prompted to save them first.

To Press
Exit WordExpress CTRL + Q or ALT+F4



Edit Menu

The Edit menu contains basic text and object manipulation commands.

Undo Reverses the last action or command

Cut Place text or objects on the Clipboard and remove them from the document

Copy Place text or objects on the Clipboard and leave the document unchanged

Paste Place text or objects which are on the clipboard into the document

Select All Select all of the objects on a page or all of the text in a frame.

Search Locate specific occurrences of text

Replace Locate and replace specific occurrences of text with other text

Find Next Repeat the last "Search" or "Replace" operation

Bring To Front Moves the selected objects such that they are displayed on top of all other objects 
on the page.

Send To Back Moves the selected objects such that they are displayed below all other objects on 
the page.

Document Options Alter certain document settings and defaults.

Preferences Alter certain WordExpress settings and defaults.

User Info Allows you to enter personal information such as name, address, phone and fax 
numbers, etc.



Edit / Undo / Redo

Use "Undo" to reverse the effect of the last action you performed, such as typing, deleting or formatting text, 
creating or moving graphic objects, inserting a page break, etc.

The name of this command changes to reflect the exact nature of the action you want to undo.    For example, if you 
just deleted some text by selecting it and pressing the Delete key, the command name changes to "Unto Typing".    If 
you just formatted some text to Bold, the name changes to "Undo Format".    If you just inserted a page break, the 
name changes to "Undo Insert Page Break".

Upon selecting an "Undo" command, the command changes to "Redo".    The "Redo" command lets you undo the 
last "Undo".

To Press
Undo or Redo ALT+BACKSPACE or CTRL+Z



Edit / Cut

Use "Cut" to delete the selected text or objects from your document and place it on the Clipboard where it can be 
pasted elsewhere in the document, or to a different document.

Text and pictures can be cut and pasted to other Windows programs such as Paintbrush or Write, but objects created 
with WordExpress can only be cut and pasted to other WordExpress documents.

The name of this command changes to identify what you are about to cut.    For example, if you selected some text, 
the command name changes to "Cut Text".    If you selected an object such as a graphic or frame, the name changes 
to "Cut Object".

To Press
Cut text or objects SHIFT+DEL or CTRL+X



Edit / Copy

Use "Copy" to place a duplicate of the selected text or objects onto the Clipboard where it can be pasted elsewhere 
in the document, or to a different document.

Text and pictures can be copied and pasted to other Windows programs such as Paintbrush or Write, but objects 
created with WordExpress can only be copied and pasted to other WordExpress documents.

The name of this command changes to identify what you are about to copy.    For example, if you selected some text, 
the command name changes to "Copy Text".    If you selected an object such as a graphic or frame, the name changes 
to "Copy Object".

To Press
Copy text or objects CTRL+INS or CTRL+X



Edit / Paste

Use "Paste" to place the contents of the clipboard (the last text or object you cut or copied) back into the document, 
or to a different document.

The name of this command changes to identify what you are about to paste.    For example, if you just cut or copied 
some text, the command name changes to "Paste Text".    If you cut or copied an object such as a graphic or frame, 
the name changes to "Paste Object".    Certain objects can be pasted in text mode as well as object mode - pictures 
and tables.    By pasting a picture or table in text mode, you can anchor it to the text.

To Press
Paste text or objects SHIFT+INS or CTRL+V



Edit / Select All

Use "Select All" to highlight, or select, all text in the document, or current text frame, if you are in text mode, or all 
objects on the current page if you are in object mode.

To Press
Select all text or objects CTRL+A



Edit / Search

Use "Search..." to search the document, including text frames, for specific text.

Search Dialog Box

Search For: WordExpress can search for any text you can enter from the keyboard, but cannot located tabs or 
carriage returns.    Spaces are OK, enabling you to search for groups of words.

Ignore Case:    By default, the Search command is not case-sensitive.    With Ignore Case off, or un-checked, 
WordExpress locates text exactly as you type it, looking for exact matches of upper and lower case letters.

Whole Word: You can search for whole words, or just for text embedded within other words.

All Frames: Check this option if you want WordExpress to search for text in text frames as well as normal 
document text.

Search Backwards:    WordExpress can search forward (to the end of the document) or backward (to the beginning 
of the document) from the cursor location.

Find Next: Click the "Find Next" to begin the search.    If WordExpress can't find the search text, it displays an error 
message.    If this happens, you might want to change the direction of the search and click "Find Next" again.

Done: Click this button to close the "Search" dialog box.

Character: Displays the "Character" dialog box.    You can tell WordExpress to search only for text that matches the 
formatting attributes you specify.    For example, if you check the "Italic" option, WordExpress only searches for 
italicized text.

Paragraph: Displays the "Paragraph" dialog box.    This lets you search only in paragraphs that are formatted with 
the attributes you specify.

Clear: Click this button to remove any character and paragraph formatting attributes you may have specified.    
WordExpress will then search in all text, regardless how it's formatted.

Replace: Clicking this button changes the dialog box to the "Replace" dialog box, where you can choose to replace 
the search text with replacement text you specify.

To Press
Search CTRL+F



Edit / Replace

Use "Replace.." to search for and replace one text string with another.

Replace Dialog Box

Search For: WordExpress can search for any text you can enter from the keyboard, but cannot located tabs or 
carriage returns.    Spaces are OK, enabling you to search for groups of words.

Replace With: Specify the text you wish to replace the matched text.

Ignore Case:    By default, the Search command is not case-sensitive.    With Ignore Case off, or un-checked, 
WordExpress locates text exactly as you type it, looking for exact matches of upper and lower case letters.

Whole Word: You can search for whole words, or just for text embedded within other words.

All Frames: Check this option if you want WordExpress to search for text in text frames as well as normal 
document text.

Start: Click the "Start" to begin the search.    If WordExpress can't find the search text, it displays an error message. 
After the first word is found, this button changes to "Skip".    Pressing this button subsequently, will case the 
currently matched word to be skipped and searching will continue starting at the next word.

Replace: Click the "Replace" replace the currently selected word with the text in the "Replace With" field.    
Searching will then continue starting at the next word.

Replace All: Click the "Replace All" if you want to replace all occurrences of the specified word.

Done: Click this button to close the "Replace" dialog box.

Character: If the cursor is in the "Search For" field, then clicking this button allows you to specify the character 
formatting attributes which must be matched as described in the "Search" dialog box.    If the cursor is in the 
"Replace With" field, then clicking this button allows you to specify the character attributes which are to replace the 
matched text.    In this way, you can replace all occurrences of a bold word with the same word italicized, for 
example.

Paragraph:    If the cursor is in the "Search For" field, then clicking this button allows you to specify the paragraph 
attributes which must be matched as described in the "Search" dialog box.    If the cursor is in the "Replace With" 
field, then clicking this button allows you to specify the paragraph attributes which are to replace the matched text.

To Press
Search and replace CTRL+H



Edit / Find Next / Replace Next

Use the "Find Next" command to repeat the last "Search" command you issued.    WordExpress searches for the next 
occurrence of the text you entered in the "Search" dialog box.

If you have just performed a "Replace" command, the "Find Next" command changes to "Replace Next..."    
Choosing it displays the "Replace" dialog box after it has located the next occurrence of the search text.

To Press
Search and/or replace next CTRL+G or F3



Edit / Bring To Front / Send To Back

Use the "Bring To Front" and "Send To Back" commands to change the stacking order of overlapping objects such 
as graphics, text frames, and tables.

To move an object to a position behind any other objects, select it with the pointer tool and choose "Send To Back". 
Choose "Bring To Front" to make it the topmost object on the page.



Edit / Document Options

Use "Document Options..." to change certain document-oriented settings.    Changes you make to these settings 
apply only to the current document.

Document Options Dialog Box

Pictures: Choose the "Display Pictures" option if you want WordExpress to display pictures you've inserted in your 
document; choose the "Use Place Holders" option to turn off the display of pictures - WordExpress instead displays 
a gray rectangle at the picture's location.    All text-wrap, size and position attributes for any pictures remain intact.    
The purpose of this option is to speed up screen display.    Selecting this option does not turn off the printing of 
picture (see "Drop Picture" in the "Print" box.

Inserted Fields:    Check the "Display Field Codes" option if you want WordExpress to display field codes rather 
than the actual data, text or values of inserted fields.    For example, if you inserted the Print Date field in your 
document, and this option is not checked, WordExpress would display the date (e.g., 28-May-94"); if this option is 
checked, it would display the name of the inserted field (e.g., "{Print Data}").    Check the "Show Merge Record" 
option if you want WordExpress to display the merged data from a particular record from a merged database or list. 
This option is gray if no database or list has been merged.

Decimal Separator:    Enter the character which is used as the decimal point.    This will be the character which is 
used for alignment with decimal tabs.



Edit / Preferences

Use "Preferences..." to set preferences for the operation of WordExpress.

Preferences Dialog Box

Generate Backup Files: Click this option if you want WordExpress to automatically generate a backup file each 
time you save a document.    If set, when you save a document, the current file will be renamed to a file with the 
extension '.BAK'.

Show Control Strip: Click this option if you want the control strip to be displayed.    This can also be controlled by 
using the "Show Control Strip" function on the View menu.

Show Status Strip: Click this option if you want the status strip to be displayed.    This can also be controlled by 
using the "Show Status Strip" function on the View menu.

Show Speed Tools: Click this option if you want the speed tools to be displayed.        This can also be controlled by 
using the "Show Speed Tools" function on the View menu.

Use New Window by default: Click this option if you want the "New Window" check box to be checked for "File / 
New" and "File / Open".

Use 3D Dialog Boxes: Click this option if you want WordExpress to use 3D Dialog Boxes.    Otherwise, the more 
traditional dialog boxes will be used.

Display Optimization: Choose the display optimization you desire from this list.    "Fastest" will result in the fastest 
performance with the greatest screen flicker.    "Best" will result in the least screen flicker but may result in slow 
performance, especially on complex pages or pages with a large number of pictures.

Spell Check and Date Language: Choose the language you want used for the spell check dictionary and date 
formats.

Table Guidelines: Click this option if you want the table guidelines displayed by default each    time you create a 
new window.    For an existing window, you can turn the table guidelines on and off via the "View Options" 
command on the View menu.

Frame Guidelines: Click this option if you want the text frame guidelines displayed by default each time you create 
a new window.    For an existing window, you can turn the text frame guidelines on and off via the "View Options" 
command on the View menu.

Paragraph Breaks: Click this option if you want the paragraph breaks displayed via the '¶' character by default 
each time you create a new window.    For an existing window, you can turn the paragraph breaks on and off via the 
"View Options" command on the View menu.

Horizontal Ruler: Click this option if you want the horizontal ruler to be displayed by default each time you create 
a new window.    For an existing window, you can turn the horizontal ruler on and off via the "View Options" 
command on the View menu.

Vertical Ruler: Click this option if you want the vertical ruler to be displayed by default each time you create a new 
window.    For an existing window, you can turn the vertical ruler on and off via the "View Options" command on the 
View menu.



Edit / User Info

Use "User Info..." to enter personal information such as name, address, phone and fax numbers, etc. WordExpress 
uses this information for merge fields (see the "Field..." command under the Insert menu).    For example, you could 
create a document template that automatically inserts your name and address from the "User Information" dialog 
box whenever you open it.    Several of the templates, such as FAX.WT1, use information from this dialog box.



View Menu Commands

The View menu contains commands for changing page display size, as well as options for turning on or off the 
display of certain WordExpress tools.

Text Mode Switch to Text (I-Beam) mode which allows the manipulation of text

Object Mode Switch to Object (Pointer) mode which allows the manipulation of objects

Actual Size Set the view size to the actual size of the document

Fit Page In Window Set the view size so that the entire page fits within the window

Zoom Set an arbitrary zoom level using the mouse

Custom Set a custom zoom level via a dialog box

Show Control Strip Show or hide the control strip

Show Status Strip Show or hide the status strip

Show Speed Tools Show or hide the speed tools

View Options Turn on or off the display of other document items such as ruler bars



View / Text Mode

Use "Text Mode" to switch Text Mode (also know as I-Beam mode) where you enter and format text.    If you are in 
Text Mode, a check will appear next to this command.

You can also switch to text mode by clicking on the ibeam icon  on the control strip.    You can toggle between 
object mode and text mode by clicking the right mouse button any time.



View / Object Mode

Use "Object Mode" to switch to Object Mode (also know as Pointer mode) which you use to create and manipulate 
objects.    If you are in object mode, a check will appear next to this command.

You can also switch to object mode by clicking on the pointer icon  on the control strip.    You can toggle 
between object mode and text mode by clicking the right mouse button any time.



View / Actual Size

Use "Actual Size" to set the page display to the size it will be when printed.    This is the default view.    A check 
mark next to this command indicates that it is currently selected.



View / Fit Page In Window

Use "Fit Page In Window" to set the page display so that an entire page fits within the window.



View / Zoom

Use "Zoom" to change the view size of a page from its current size to a larger, custom size.    The cursor changes to a 
magnifying glass when you choose this command, which you can use to "zoom in" on any portion of the document.

To zoom to a custom size, choose "Zoom" from the View menu, move the mouse to the position in the document 
you would like displayed in the upper left-hand corner of the window.    Press the left mouse button and drag the 
mouse down and to the right.    Drag the mouse so that the rectangle encloses the area you want to zoom in on.    
When you release the mouse button, the view scale and position is set so that region fits within the window.



View / Custom

Use "Custom" to select a view size from a list of available sizes or enter a view size of your own.

Zoom Dialog Box

Zoom Factor:    Select a view size from the list, or type a view size and click "OK."    Custom view sizes you enter 
must be in the range 30 - 400%.    The "Fit Page To Window" option displays an entire page within the window.    
The "Fit Margins to Window" option adjusts the view so that the distance between the page margins fits within the 
width of the window.



View / Show Control Strip

Use "Show Control Strip" to toggle the display of WordExpress control strip.    The control strip contains buttons and 
menus for commonly used text formatting actions, as well as buttons for creating objects such as text frames, picture 
frames, and graphics.

The control strip changes depending on whether you are in text mode or object mode.



Text Mode Control Strip

The control strip displayed when you are in text mode allows you to perform various common formatting functions.

The first two buttons on the control strip allow you to switch between text mode and object mode.

The next drop down combo box provides a list of the available paragraph styles.    You may apply a new style to the 
selected paragraphs by choosing a style from this list.    The combo box displays the style of the selected paragraphs 
(or the paragraph containing the cursor is no paragraphs are selected).

The next drop down combo box provides a list of the available fonts and character styles which may be applied to 
selected text.    Character styles are preceded by the symbol ' ' whereas fonts are preceded by the symbol '

' or '
' depending on whether the font is a True Type font or a Printer font.    The combo box displays the font of the 

selected text (or the text at the current cursor position if no text is selected).

The next drop down combo box provides a list of point sizes which may be applied to selected text.    You may apply 
any of these point sizes by simply selecting the desired size from the drop down list box.    Alternately, you may 
enter any size between 1 and 999 in the edit field of the combo box and press return to apply that size to the selected 
text.    The combo box displays the point size of the selected text (or the text at the current cursor position if no text 
is selected).

The next three buttons allow you to change the Bold, Italic, and Underline attributes of selected text.    These buttons 
work in the same way as the "Bold", "Italic", and "Underline" commands found under the "Format" menu.    These 
buttons also display the current state of each of these attributes of the selected text (or the text at the current cursor 
position if no text is selected).

The next four buttons allow you to modify the paragraph alignment of the selected paragraphs.    You may choose 
left, right, center, or flush aligned paragraphs.    These buttons also display the current alignment of the selected 
paragraphs (or the paragraph containing the cursor if no paragraphs are selected).

The final four buttons allow you to specify the type of tab which will be added to the ruler bar when you click with 
the mouse.    Tabs added to the ruler bar will be added to all selected paragraphs (or the paragraph containing the 
cursor if no paragraphs are selected).    You may choose left aligned, right aligned, center aligned, or decimal 
aligned.



Object Mode Control Strip

The object mode control strip allows you to create new objects.

The first two buttons on the control strip allow you to switch between text mode and object mode.

The next three buttons allows you to create a new text frame, picture object, or table.    These work in the same 
manner as the "New Text", "New Picture", and "New Table" commands on the "Object" menu.

The last four buttons allow you to create new lines, rectangles, rounded rectangles, and ovals.    These work in the 
same manner as the "Tools" command on the "Object" menu.



View / Show Status Strip

Use "Show Status Strip" to toggle the display of WordExpress status strip.    The status strip contains fields which 
tell you how many pages you have, what line, page, and section the cursor in on.    The left most field is used to 
display useful message at various time.    For example, when the mouse passes over a control on the control strip, a 
message is displayed describing what that control does.



View / Show Speed Tools

Use "Show Speed Tools" to toggle the display of WordExpress "Speed Tool" palette.    This Palette consists of a set 
of buttons which provide a short cut for many WordExpress commands.    The palette is user configurable via the 
"Customize Speed Tools..." command under the Utilities menu or by double clicking on any portion of the palette 
which does not contain a button.



View / View Options

Use "View Options" to set the view options for the currently active window.    To set the defaults that are use for 
newly created windows, see the "Preferences" command on the Edit menu.

View Options Dialog Box

Table Guidelines: Click this option if you wish to see table guidelines for tables in the currently active window.

Frame Guidelines: Click this option if you wish to see frame guidelines for frames in the currently active window.

Paragraph Breaks: Click this option if you wish to see paragraph breaks for frames in the currently active window.

Horizontal Ruler: Click this option to display the horizontal ruler in the currently active window.

Vertical Ruler: Click this option to display the vertical ruler in the currently active window.



Format Menu Commands

The Format menu contains commands for changing the appearance of characters, paragraphs, and graphic objects.

Character Set character attributes of selected text

Bold Change selected text to bold and back

Italic Change selected text to italic and back

Underline Change selected text to underline and back

Word Underline Change selected text to word underline and back

Paragraph Set paragraph attributes of selected paragraphs

Tabs Set tab setting of selected paragraphs

Bullets Set bullets for selected paragraphs

Borders Set borders for selected paragraphs or objects

Lines Set line style for selected objects

Shades Set background shade for selected paragraphs or objects

Section Set section attributes for selected sections.

Apply Character Style Apply a character style to selected text

Apply Paragraph Style Apply a paragraph style to selected paragraphs



Format / Character

Use the "Character..." command to change the character formatting attributes of selected text, or to set the attributes 
for new text you type.    Character formatting attributes consist of typeface selection (font and font variations such as 
bold, italic, etc.), font size in points, underlining options, and super/subscripting.

Character Dialog Box

Sample: This area of the Character dialog box displays a sample of the currently selected formatting options, letting 
you see the effect of your formatting choices before applying them.

Style Name: Choose from a list of defined character styles.    (See the description of the "Define Character Style" 
dialog box.)

Face Name: Choose from a list of fonts installed in your system.

Point Size: You can either select a point size from this menu, or type in any size between 1 and 999.    Sizes must be 
whole numbers.    The unit of measurement for fonts is points.    There are 72 points in an inch.

Color: Choose from a list of colors you can apply to text.

Style: Check an option or any combination of options for the available type styles.    Choose the "All    Caps" 
attribute to display text in all uppercase letters.

Underline: There are two different types of underlining attributes: continuous underline and word underline.    
Continuous underline underlines text, spaces, and tabs.    Word underline does not underline spaces or tabs.    For 
either underlining option, you can specify whether you want the underline to be a single or double line.

Super/Subscript: Choose "Superscript" to move text above the baseline (an imaginary line where characters rest); 
choose "Subscript" to move text below the baseline.    If neither option is selected, text is positioned on the baseline. 
The "Position" value determines how much, relative to the normal text height, text should be moved up or down - 
20% is the default.    The "Size" value lets you specify whether super- or subscripted text should be reduced in size. 
The default value of 80% means that text will be reduced by 20%, e.g., if the point size is 10 points, super- or 
subscript text would be set to 8 points.

Apply: Click "Apply" to close the dialog box and apply any formatting options you may have selected.

Cancel: Click "Cancel to close the dialog box without applying any changes.

Default: Click "Default" to return all formatting options to the default state as determined by the current "Style 
Name".

Define: Click "Define" to display the "Define Character Style" dialog box.    Defined styles appear in the "Style 
Name" list.

To Press
Set character attributes CTRL+T
Set face name CTRL+SHIFT+F
Set point size CTRL+SHIFT+P
Toggle bold attribute CTRL+B
Toggle italic attribute CTRL+I
Toggle underline attribute CTRL+U
Toggle word underline attribute CTRL+W



Define Character Styles

Character Styles are a collection of character attributes (font, size, type style, etc.) that you can name, save, and later 
apply to text all at once.    When you choose a character style, all the attributes that make up that style are applied to 
the selected text at once.    In other words, you wouldn't have to apply several character formatting attributes 
individually to text in your document.    All these changes would take place at once simply by selecting a style.

To define a character style:

1) Choose "Character..." from the Format menu.    The "Character" dialog box appears

2) Click the "Define" button.    The dialog box changes to the "Define Character Style" dialog box.

3) Select the font you want for your new style from the "Face Name" list, and likewise change any other 
formatting options such as point size, color, etc.

4) Type a new name for the style in the "Style Name" field (backspace over the existing style name, then type 
a new one).

5) When your are satisfied with your choices, click the "Add" button.

6) Click "Done" to close the dialog box and record your changes.

The style you just defined now appears in the "Font Name" list box of the control strip preceded by the symbol ' '. 
It also appears when you choose the "Apply Character Style" command.



Format / Bold / Italic / Underline / Word Underline

These menu commands alter the respective attributes of the currently selected text.    For example, if the selected text 
is currently not bold and you choose "Bold", the text will be changed to bold.    If the text is currently bold, then it 
will be changed to normal.    That is, the "Bold" command toggles the bold state of the selected text.

If no text is selected, then choosing the "Bold" command will determine what the bold attribute for new text you 
type.    This command once again toggles the bold state.    A check mark will appear next to the "Bold" menu 
command if new text will be bold.    If there is no check next to the command, then new text will be normal.

The "Italic", "Underline", and "Word Underline" commands work in a similar manner.

Note that the "Bold", "Italic", and "Underline" commands perform the same function as pressing the following 
buttons on the text mode control strip: 

To Press
Toggle bold attribute CTRL+B
Toggle italic attribute CTRL+I
Toggle underline attribute CTRL+U
Toggle word underline attribute CTRL+W



Format / Paragraph

Use the "Paragraph..." command to change the paragraph formatting attributes of selected text, or to set the 
attributes for the paragraph containing the cursor.    Paragraph formatting attributes are applied to entire paragraphs, 
rather than single characters or words.    Alignment, indents, line spacing, tab placement, etc., are examples of 
paragraph formatting attributes.

Paragraph Dialog Box

Style Name: Choose from a list of defined paragraph styles.    See the "Define Paragraph Style" dialog box 
description for more information about styles.

Alignment: Choose options from the list to apply left or right alignment to a paragraph, or to center or justify it.

Pagination: Click "Column Break" if you want the paragraph to begin a new column; click "Page Break" if you 
want the paragraph to begin a new page.

Hyphenation: Choose one of the three types of hyphenation from the list - "Adjacent Lines," "2 Line Separation," 
or "3 Line Separation."    By default, hyphenation is set to "None" which means that it is turned off.

The Adjacent Lines options hyphenates eligible words at the end of each line (if necessary).    The 2 and 3 Line 
Separation options hyphenate eligible words, but make sure that at least two or three non-hyphenated lines appear 
between each hyphenated line.

Indent: Enter values in these boxes to control the amount of space between a paragraph and the left or right margin. 
By default, paragraph indents are lined up on the margins, i.e., set to 0.00 centimeters.

Outline Level: Any paragraph can be assigned an outline level.    Paragraphs with outline levels 1 through 9 are 
treated as headings, 1 being the topmost heading level.    Paragraphs with an outline level of 0 - the default outline 
level - are treated as normal text.    Outline Levels are used for auto numbering fields.

Spacing:    Line spacing is the vertical distance between lines of text in a paragraph, and is controlled by two factors: 
the size of the font, and the "Leading" value specified for a paragraph.    A leading value of 100% means no 
additional spacing beyond that built into the font itself (individual fonts may vary considerably).    Entering a larger 
value increases the space between lines, a smaller value decreases the space.

You can also add spacing between paragraphs.    To add extra space between paragraphs, enter values for 
the amount of space you want above, below, or both above and below the current paragraph or selected paragraphs 
in the "Before" and "After" boxes.    These values do not affect the amount of space between lines within a 
paragraph.    The values you enter are, by default, in points, but you may enter the number in inches or centimeters 
by following it with the letters "in" or "cm" (e.g. 1.00in or 2.54cm).    The default is 0 points.

Apply: Click "Apply" to close the dialog box and apply any formatting options you may have selected.

Cancel: Click "Cancel" to close the dialog box without applying any changes to character formatting.

Character...: Click "Character..." to open the "Character" dialog box where you can choose character formatting 
attributes for this paragraph.

Tabs...: Click "Tabs..." to open the "Tabs" dialog box where you can create and edit the placement of tabs.

Bullet...: Click "Bullet..." to open the "Bullet" dialog box where you can create different types of bulleted 
paragraphs.

Shades...: Click "Shades..." to open the "Shades" dialog box where you can select different shades, patterns, and 
colors to apply to paragraphs.



Default: Click "Default" to return all formatting options to the default state as determined by the current "Style 
Name".

Border...: Click "Border..." to open the "Paragraph Border" dialog box where you can control the placement and 
style of paragraph border lines.

Define:    Click "Define" to display the "Define Paragraph Style" dialog box which allows you to create paragraph 
styles.

To Press
Set paragraph attributes CTRL+M
Set paragraph style CTRL+SHIFT+S
Left justify paragraph CTRL+SHIFT+L
Right justify paragraph CTRL+SHIFT+R
Center paragraph CTRL+SHIFT+C
Flush justify paragraph CTRL+SHIFT+J
Single space CTRL+1
One and a half space CTRL+2
Double space CTRL+3



Defining Paragraph Styles

Paragraph Styles are a collection of paragraph attributes (including associated Character Styles) that you can name, 
save, and later apply to text all at once.    When you choose a paragraph style, all the attributes that make up that 
style are applied to the selected paragraph at once.    In other words, you wouldn't have to apply several paragraph 
formatting attributes individually to paragraphs in your document.    All these changes would take place at once 
simply by selecting a style.

To define a paragraph style:

1) Choose "Paragraph..." from the Format menu.    The "Paragraph" dialog box appears.

2) Click the "Define" button.    The dialog box changes to the "Define Paragraph Style" dialog box.

3) Change any paragraph formatting options as necessary for the style

4) Assign a Character Style.    To do so, click the "Character..." button to open the Character dialog box, select 
a character style from the "Style Name" menu (or select any character formatting options you want instead 
of assigning a specific style), and then click "Apply" to record your selections and return you to the "Define 
Paragraph Style" dialog box.

5) Type a new name for the style in the "Style Name" field (backspace over the existing style name, then type 
a new one).

6) When your are satisfied with your choices, click the "Add" button.

7) Click "Done" to close the dialog box and record your changes.

The style you just defined now appears in the "Paragraph Style" list box of the "Text Mode" control strip.    It also 
appears when you choose the "Apply Paragraph Style" command.



Format / Tabs

Use "Tabs..." to set tabs and alter their positions and alignment.    Tabs are used to move the cursor to a specific 
location without using the spacebar.    Tabs are useful for lining up text or numbers in tables, or for aligning text to a 
specific location in the document.    Initially, left-aligned tabs are positioned every centimeter from the left margin to 
the right margin.    You can replace these pre-set tabs by adding your own.

WordExpress lets you create four different types of tabs: left, right, centered, and decimal aligned.    There 
are two ways you can create and edit tab stops: on the ruler using the mouse, or from the "Tabs" dialog box 
described below.    (You can also set tabs via the mouse, see Changing tabs with the mouse.)

Tabs Dialog Box

To add a new tab using the "Tabs" dialog box:

1) Choose "Tabs..." from the Format menu, or click the "Tabs..." button in the "Paragraph" dialog box.    The 
"Tabs" dialog box appears.

2) In the "Set Tabs At" box, enter the position in centimeters - relative to the left margin - where you want to 
place a tab.    You can specify a tab's position to 1/100th of an centimeter.    By default the tab position is 
specified in centimeters but you can also specify the position in inches or points by following the number 
with the letters "in" or "pt" (e.g. 1.00in or 72.0pt).

3) Choose an alignment type from the "Alignment" pull-down list box.    The default is Left, but you can also 
choose Right, Center, or Decimal.

4) Click the "Set" button.    The tab is added to the list.

You can add as many tabs as you need following the above steps.

5) Click "OK" to close the dialog box and add the new tab or tabs to the ruler.    Click "Cancel" to close the 
dialog box without adding any tabs to the ruler.

To remove tabs from the "Tabs" dialog box, highlight the tab to be removed from the "Set Tabs At" list, and click the 
"Clear" button.    The tab is placed in the "Clear Tabs At" list.    If you change your mid, you can select a tab from 
this list and click the "Set" button to place it back in the "Set Tabs At" list.    You can remove all tabs by clicking the 
"Clear All" button.    Click "OK" to close the dialog box and update the ruler with the changes you made.    Click 
"Cancel" to close the dialog box without changing the ruler.



Changing tabs with the mouse

In order to change tabs with the mouse, the control strip and horizontal ruler must be turned on (see the "Control 
Strip" and    "Options" commands on the View menu).

To add an new tab, select the desired tab type from the tab type buttons  of the control strip.    You 
may choose left, right, center or decimal tabs.    Then click in the horizontal ruler at the position you want the tab.    
When you release the mouse button, the tab will be added to all selected paragraphs.

To move an existing tab, simply click on the tab you wish to move and drag it to a new location.

To delete an existing tab, simply click on the tab you wish to delete and drag it downward off of the ruler.



Format / Bullets

Use "Bullets..." to create bullet paragraphs.    Bullet paragraphs can begin with round, diamond, or character bullets. 
The bullet appears on the left side of the paragraph.    WordExpress lets you control the size and color of the bullet, 
and also its position relative to the text.

Bullet Dialog Box

Type: Select the type of bullet desired.    The available types are round, diamond, or character.

Round: To create a round bullet, click on one of the standard size round bullets or enter a custom size in the "Size" 
field to the right.    The "Round" type button will be automatically selected for you.

Diamond: To create a diamond bullet, click on one of the standard size diamond bullets or enter a custom size in the 
"Diamond" field to the right.    The "Diamond" type button will be automatically selected for you.

Character: To create a character bullet, enter the ANSII character number in the "Character" field or select the 
character using the control to the right.    Select the desired the face name from the "Face Name" menu below, and 
enter the desired point size in the "Point Size" field.

Color: Select the desired bullet color from this menu of standard colors.

Horz. Pos: Specify the distance to the left of the paragraph at which you wish the bullet to appear.

Vert. Pos: Specify the vertical position relative to the default position at which you wish the bullet to appear.    A 
zero value results in the default position which is centered.    A positive value will move the bullet up and a negative 
value will move the bullet down.



Format / Borders

Use "Borders..." to create border lines around paragraphs or objects.    WordExpress lets you create several styles of 
borders, as well as controlling their placement relative to the text.    If text is selected then the "Paragraph Border" 
dialog box is displayed.    If an object is selected then the "Frame Border" dialog box is displayed.



Paragraph Border Dialog Box

Sample: This field serves two purposes.    First it displays an example of the currently selected border.    Second it is 
used to specify which edges will be affected when a line style is applied.    The small cursor symbols ' ' are 
used to mark the edges that will be affected.    You can select a edge by clicking on it with the mouse.    Multiple 
edges can be selected by holding the Shift key down while you click.    The outer edges (i.e. the top, bottom, left, and 
right) may be selected by clicking on the interior of the paragraph.

Edit Edge: As an alternative to selecting the edges with the mouse as described above, you can choose the edge(s) 
from this menu.    "Outline" selects the top, bottom, left, and right edges.    The "Middle" edge is used to set the line 
type for lines between selected paragraphs.

Style: You may choose the line style from this menu.    The available styles are no line, a single line, or a double 
line.

Apply Style: Click on one of these predefined styles to apply that line style to the currently selected edges.

Lines: Click on this button to bring up the "Lines" dialog box which will allow you to apply a custom line style to 
the currently selected edges.

Clearance: Specify the distance you desire between each edge and the paragraph.    By default this distance is in 
points, but you may specify inches or centimeters by following the number with the letters "in" or "cm" (e.g. 1.00in 
or 2.54cm)

Bounds: Choose how you want the border to bound the text.    Choose "Margins" if you want the border to extend to 
the page margins.    Choose "Indents" if you want the border to extend only to the paragraph indents.    Choose 
"Text" if you want the border to extend only to the text within.

Color: Choose the color you want for the border from the list of standard colors.



Frame Border Dialog Box

Sample: This field serves two purposes.    First it displays an example of the currently selected border.    Second it is 
used to specify which edges will be affected when a line style is applied.    The small cursor symbols ' ' are 
used to mark the edges that will be affected.    You can select a edge by clicking on it with the mouse.    Multiple 
edges can be selected by holding the Shift key down while you click.    The outer edges (i.e. the top, bottom, left, and 
right) may be selected by clicking on the interior.

Edit Edge: As an alternative to selecting the edges with the mouse as described above, you can choose the edge(s) 
from this menu.    "Outline" selects the top, bottom, left, and right edges.

Style: You may choose the line style from this menu.    The available styles are no line, a single line, or a double 
line.

Apply Style: Click on one of these predefined styles to apply that line style to the currently selected edges.

Lines: Click on this button to bring up the "Lines" dialog box which will allow you to apply a custom line style to 
the currently selected edges.

Color: Choose the color you want for the border from the list of standard colors.



Format / Lines

Use "Lines..." to choose a line thickness and type for graphic objects you create with the drawing tools, as well as 
frame borders.    This command is only active when your are in object (pointer) mode.    However, this is the same 
dialog box that appears when you click the "Lines..." button from the "Paragraph Border" dialog box.

Lines Dialog

Type: Choose the line type desired.    You may choose to have no line, or a single or double line.

Thickness: Choose from one of the predefined line thicknesses, or enter any thickness in the "Thickness / 
Separation / Thickness" edit fields below.    If a single line has been selected, only the first thickness is used.    If a 
double line is selected, you may set the thickness of each line as well as the distance between lines.    By default, the 
thickness is specified in points, but you may enter the value in inches or centimeters by following the number with 
the letters "in" or "cm" (e.g. 1.00in or 2.54cm).



Format / Shades

Use "Shades..." to apply a shade or fill pattern to an object, frame, or paragraph background.

Shades Dialog Box

Shades: Click on one of the pre-defined shades or enter any custom shade value from 0 (white) to 100% (solid 
color).

Patterns: Click on one of the pre-defined fill patterns.

Foreground Color: If you have selected a shade, then this field specifies the color for the shade.    If you have 
selected a pattern, then field specifies the color to be used for the "black" portion of the pattern.

Background Color:    If you have selected a pattern, then this field specifies the color to be used for the "white" 
portion of the pattern.    If you have selected a shade, then this field is not used.



Format / Section

Use "Section..." to set the number of columns, gutter width, column height, and line between columns for a section. 
You can create section breaks via the "Section Break" command on the Insert menu.

Section Dialog Box

Number: Enter the number of columns for this section.    You may have between 1 and 8 columns.

Gutter: Enter the amount of space you want to have between columns.

Height: Enter the height of the column.    You may choose a fixed height or choose "Auto" in which case, the height 
of the columns will be determined by the amount of text, with the columns being automatically balanced.    You may 
also choose "Page Height" to make the column height equal to the entire page.

Line Between...: Click on this button to bring up the "Lines" dialog box which allows you to specify the line style 
of the line (if any) which is drawn between the columns.

Apply To: If you have text selected, you may choose to apply your changes to the selected text, the selected 
sections, or to the whole document.    If no text is selected, then you may apply your changes to the current section, 
from the cursor position to the end of the current section, or to the entire document.

Restart Auto Numbers: Click this option if you want the auto numbers (see "Field" in the Insert menu) to be 
restarted at the beginning of this section.



Format / Apply Character Style

Use "Apply Character Style..." to select from a list of defined character styles you can apply to selected text.    A 
character style is a set of character formatting attributes that can be applied to selected characters and words all at 
once.

The Character Style may also be applied by choosing the style from the Font list box on the control strip.    Character 

styles are distinguished from fonts in this list box by being preceded by the ' ' symbol.

Character Style Dialog Box

Choose the style you wish to apply from the list box on the left and click "Apply" to apply this style to the selected 
text.    If no text is selected, then this will set the character style for new text.

Define...: Click this button to bring up the "Define Character Style" dialog box which allows you to define new 
character styles or modify existing ones.



Format / Apply Paragraph Style

Use "Apply Paragraph Style..." to select from a list of defined paragraph styles you can apply to a paragraph or to a 
group of selected paragraphs.    A paragraph style is a set of paragraph formatting attributes - as well as an associated 
character style - that can be applied to paragraphs all at once.

The Paragraph Style may also be applied by choosing a style from the Paragraph Style list box located on the control 
strip.

Paragraph Style Dialog Box

Choose the style you wish to apply from the list box on the left and click "Apply" to apply this style to the selected 
paragraphs.    If no text is selected, then this will set the paragraph style for the paragraph which currently contains 
the cursor.

Define...: Click this button to bring up the "Define Paragraph Style" dialog box which allows you to define new 
paragraph styles or modify existing ones.



Object Menu Commands

The Object menu contains commands for drawing and manipulating objects, editing the placement on non-printing 
guides and toggling the snap settings of grids and guides.

Tools Displays a sub-menu which allows you to create new text frames, pictures, tables, 
and graphic objects

Attributes Allows you to edit the attributes of an object

Snap to Grid Allows you to precisely position objects relative to a grid you specify

Snap to Guides Allows you to precisely position objects relative to guide lines which you have 
created

Set Grid Lets you specify the "Snap to" grid resolution

Edit Horz. Guides Allows you to create, modify and delete horizontal guides

Edit Vert. Guides Allows you to create, modify and delete vertical guides



Object / Tools

Use "Tools" to display a sub-menu where you can select a drawing tool for creating an object, frame, or table.    
Choosing a tool from the "Tools" sub-menu is the same as choosing one from the control strip.

The cursor changes depending on the tool you select from this menu, or the button you click on the control strip:

Draws lines.    Hold the Shift key while drawing to create horizontal, vertical, or 45° angled lines.

Draws rectangles.    Hold the Shift key while drawing to create squares.

Draws round-corner rectangles.    Hold the Shift key while drawing to create round-corner squares.

Draws ellipses.    Hold the Shift key while drawing to create circles.

Draws text frames.    Text frames are graphic objects that contain text.

Draws frames into which you can import Windows MetaFile, bit map, TIFF, or PCX images.    After you 
draw the frame, the "New Picture" box will be displayed which will allow you to specify the picture you wish to 
import.

Draws tables.    Tables are similar to text frames, but let you create rows and columns for containing tabular 
information.    After you draw the bounds of the table, the "New Table" box will be displayed which will allow you 
to specify the number of rows and columns for the table.

To draw an object, frame, or table, first choose a tool.    Now click the position on the page where you want one 
corner or start-point to be, and while holding down the mouse button, drag to the position you want the opposite 
corner or end-point to be.    When you release the mouse button, the object is drawn.



New Picture Dialog Box

The "New Picture" dialog box allows you specify the picture you which to import.

List Files of Type: Select options from this menu to tell WordExpress the type of picture want to import: Windows 
Bitmap Format (BMP), Tag Image File Format (TIF), Paintbrush format (PCX), or Windows MetaFile (WMF).    
The type you choose here determines the available files in the file list.

Save w/Document: Check this option if you want the picture saved with the document.    If you choose this then the 
original file containing the picture will no longer be needed.

Select the drive and directory where you want WordExpress to look for pictures from the Drives and Directories list 
boxes.



New Table Dialog Box

The "New Table" dialog box allows you to specify the attributes of the new table.

Number of Rows: Enter the number of rows for the new table. For tables attached to a page (i.e. created via the 
"Tools" command of the Object menu) the maximum number of rows is a function of the position of the table and 
the size of the page.    You cannot create a table which is larger than will fit on the page.    For inserted tables (i.e. 
created via the "Table" command of the Insert menu) the maximum number of rows is dependent on the number of 
columns.    The maximum number of cells (i.e. # rows x # columns) cannot exceed 2700.

Number of Columns: Enter the number of columns for the new table.    The maximum number of columns is 200.

Margins: Enter the initial left, right, top, and bottom margins for the cells of the table.



Object / Attributes

Use "Attributes..." to display a dialog box where you can edit the size, position, wrap margins, appearance, and other 
attributes of an object.    Choosing the "Attributes..." command is the same as double-clicking an object.    This 
command is gray if no object is selected (see Selecting Objects).

The dialog box that appears when you choose this command changes depending on what type of object is selected.    
For more information about a specific object choose the object type from the following:

Lines
Rectangles
Round Corner Rectangles
Ellipses
Text Frames
Picture Frames
Tables



Edit Line Dialog Box

If the selected object is a line, then the "Edit Line" dialog box appears when you choose the "Attributes..." command 
or double click on the line.

The "From" and "To" fields determine the co-ordinates of the line relative to the top-left corner of the page.    It 
would probably be easier to change the line's position using the mouse, but you can also to it from this dialog if you 
need to specify exact co-ordinates.    By default, the position is specified in centimeters, but you may specify the 
position in inches or points by following the number with the letters "in" or "pt" (e.g. 1.00in or 72.0pt).

Click a "Thickness" option to change the width of the selected line, or enter a line thickness in points in the 
"Thickness" field.    By default the thickness is specified in points but you may enter the thickness in either inches or 
centimeters by following the number with the letters "in" or "cm" (e.g. 1.00in or 2.54cm).

The "Color" drop down list box allows you to specify the color which is to be used to draw the line.



Rectangle Dialog Box

If the selected object is a rectangle or round-corner rectangle, then the "Rectangle" dialog box appears when you 
choose the "Attributes..." command or double click on the rectangle.

Line Style: Select a pre-set line style from the Line Style options, or click the "Lines..." button to display the 
"Lines" dialog box for more options.

Position: Enter the object's size and position on the page in centimeters.    It's position is measured from the top-left 
corner of the page.    It would probably be easier to change the object's size and position using the mouse (see 
"Resizing an object with the mouse"), but you can also do it from this dialog if you need to specify an exact size and 
position.

Wrap Margin: Enter values for the object's wrap margin in centimeters.    The wrap margins determine the distance 
of the text from each side of the object, or in other words, how close text in your document may appear above, 
below, or to either side of the object before wrapping.    See "Changing wrap margins with the mouse" for more 
detailed information.

By default, the position and wrap margin are specified in centimeters, but you may specify them in inches or points 
by following the number with the letters "in" or "pt" (e.g. 1.00in or 72.0pt).

Wrap: Choose the type of wrap from this pull-down menu.    Choose "None" for no text wrapping, that is, text will 
flow over the object, ignoring its wrap margins; choose "Line" if you want text to jump over the object and continue 
below it; choose "Text" if you want text to wrap around all sides of an object.

Square: Click this option if you want the selected rectangle to be a square, that is, setting the rectangle's height 
equal to its width.    Note that you can create squares by holding down the Shift key while your are resizing the 
rectangle with the mouse.

Rounded Corners: Click this option if you want the rectangle to be round-corner rectangle, all four corners will be 
beveled.

Shades...: Click this button to open the "Shades" dialog box where you can select a shade or fill-pattern for the 
rectangle.    This is the same as choosing the "Shades..." command from the format menu.



Ellipse Dialog Box

If the selected object is an ellipse, the "Ellipse" dialog box appears when you choose the "Attributes..." command or 
when you double click on the ellipse.

Line Style: Select a pre-set line style from the Line Style options, or click the "Lines..." button to display the 
"Lines" dialog box for more options.

Position: Enter the ellipse's size and position on the page in centimeters.    It's position is measured from the top-left 
corner of the page.    It would probably be easier to change the ellipse's size and position using the mouse (see 
"Resizing an object with the mouse"), but you can also do it from this dialog if you need to specify an exact size and 
position.

By default, the position and wrap margin are specified in centimeters, but you may specify them in inches or points 
by following the number with the letters "in" or "pt" (e.g. 1.00in or 72.0pt).

Wrap Margin: Enter values for the ellipse's wrap margin in centimeters.    The wrap margins determine the distance 
of the text from each side of the ellipse, or in other words, how close text in your document may appear above, 
below, or to either side of the ellipse before wrapping.    See "Changing wrap margins with the mouse" for more 
detailed information.    The wrap region is a rectangle.

Wrap: Choose the type of wrap from this pull-down menu.    Choose "None" for no text wrapping, that is, text will 
flow over the ellipse, ignoring its wrap margins; choose "Line" if you want text to jump over the ellipse and 
continue below it; choose "Text" if you want text to wrap around all sides of an ellipse.

Shades...: Click this button to open the "Shades" dialog box where you can select a shade or fill-pattern for the 
ellipse.    This is the same as choosing the "Shades..." command from the format menu.

Circle: Click this option to change the selected ellipse to a circle.    Note that you can create circles with the mouse 
by holding the Shift key while you resize the circle with the mouse (see "Resizing an object with the mouse").



Text Frame Dialog Box

If the selected object is a text frame, the "Text Frame" dialog box appears when you choose the "Attributes..." 
command or double click on the text frame.

Orientation: Choose from one of four orientations for the text frame:    Portrait, Landscape, Inverted, and Reverse 
Landscape.

Wrap: Choose the type of wrap from this pull-down menu.    Choose "None" for no text wrapping, that is, text will 
flow over the text frame, ignoring its wrap margins; choose "Line" if you want text to jump over the text frame and 
continue below it; choose "Text" if you want text to wrap around all sides of the text frame.

Wrap Text: Click this option if you want text contained within the text frame itself to wrap around any objects 
placed within the frame.

Position: Enter the text frame's size and position on the page in centimeters.    It's position is measured from the top-
left corner of the page.    It would probably be easier to change the frame's size and position using the mouse (see 
"Resizing an object with the mouse"), but you can also do it from this dialog if you need to specify an exact size and 
position.

Margins: Enter the margins between the edge of the text frame and the text.    You can change the margins with the 
mouse by holding down the Shift key while you follow the same procedure for resizing the text frame.    Instead of 
being resized, the text margins will be set.

Wrap Margin: Enter values for the text frame's wrap margin in centimeters.    The wrap margins determine the 
distance of text external to the frame from each side of the frame, or in other words, how close text in your 
document may appear above, below, or to either side of the frame before wrapping.    See "Changing wrap margins 
with the mouse" for more detailed information.

By default, the position, margins, and wrap margin are specified in centimeters, but you may specify them in inches 
or points by following the number with the letters "in" or "pt" (e.g. 1.00in or 72.0pt).

Border...: Click this button to open the "Frame Border" dialog box where you can select the style of border to be 
used for the text frame.

Shades...: Click this button to open the "Shades" dialog box where you can select a shade or fill-pattern for the 
background of the text frame.    This is the same as choosing the "Shades..." command from the format menu.



Picture Dialog Box

If the selected object is a picture, the "Picture" dialog box appears when you choose the "Attributes..." command or 
double click on the picture.

Position: Enter the picture's position on the page in centimeters.    It's position is measured from the top-left corner 
of the page.    It would probably be easier to change the picture's position using the mouse (see "Moving objects with 
the mouse"), but you can also do it from this dialog if you need to specify an exact position.

Maintain Aspect Ratio: Click this option if you wish for the original aspect ration of the picture to be preserved 
when it is resized.

Save w/Document: Click this option if you wish for the picture to be saved with the document.    Once the picture 
has been saved with the document, the link to the original file is lost and this option will be automatically checked 
and dimmed.

Save as TIFF: Click this option if you wish for the picture to be saved in a compressed TIFF format when it is 
saved with the document.    This option is only available for bitmap, TIFF, and PCX picture formats.    Choosing this 
option can result is a significantly smaller file.

Size: Enter the size of the picture.    You may either enter the size in centimeters or as a percent of the original 
picture's size.    It may be easier to change the picture's size using the mouse (see "Resizing an object with the 
mouse"), but you can also do it from this dialog if you need to specify an exact size.

Wrap Margin: Enter values for the picture's wrap margin in centimeters.    The wrap margins determine the distance 
of text each side of the picture, or in other words, how close text in your document may appear above, below, or to 
either side of the picture before wrapping.    See "Changing wrap margins with the mouse" for more detailed 
information.

By default, the position, size and wrap margin are specified in centimeters, but you may specify them in inches or 
points by following the number with the letters "in" or "pt" (e.g. 1.00in or 72.0pt).

Foreground Color: Choose the foreground color you wish for the picture.    If you choose "Full Color" then the 
picture will be displayed and using the its original colors.

Background Color: Choose the background color you wish for the picture.    If you have chosen "Full Color" for 
the foreground color, then this value is ignored.

Wrap: Choose the type of wrap from this pull-down menu.    Choose "None" for no text wrapping, that is, text will 
flow over the picture, ignoring its wrap margins; choose "Line" if you want text to jump over the picture and 
continue below it; choose "Text" if you want text to wrap around all sides of the picture.

Note that the Wrap option is only available for pictures which were added using the picture tool under the "Tools" 
command on the Object menu (or from the control strip).    The Wrap option is not available for pictures which are 
inserted into the text via the "Picture" command on the Insert menu. 

Orientation: Choose from one of four orientations for the picture:    Portrait, Landscape, Inverted, and Reverse 
Landscape.

Border...: Click this button to open the "Frame Border" dialog box where you can select the style of border to be 
used for the text frame.

Margins: Click on this button to bring up the "Picture Margins" dialog box which allows you to enter the margins 
between the edge of the frame and the picture.    You can change the margins with the mouse by holding down the 
Shift key while you follow the same procedure for resizing the picture.    Instead of being resized, the picture 



margins will be set.

Crop: Click on this button to bring up the "Crop Picture" dialog box which allows you to enter the cropping values. 
You enter the left, top, right, and bottom crop values as a percentage of the original pictures width and height.    You 
can change the crop the picture with the mouse by holding down the Control key while you follow the same 
procedure for resizing the picture.    Instead of being resized, the picture will be cropped.

File: Click on the button to bring up the "Picture File Name" dialog box which allows you specify a new file name 
for the imported picture.    You can use this option to change the picture.



Table Dialog Box

If the selected object is a table, the "Table" dialog box appears when you choose the "Attributes..." command or 
double click on the table.

Position: Enter the table's size and position on the page in centimeters.    It's position is measured from the top-left 
corner of the page.    You cannot change the height of the table since the height is determined by the table's contents. 
It would probably be easier to change the table's size and position using the mouse (see "Resizing an object with the 
mouse"), but you can also do it from this dialog if you need to specify an exact size and position.

Wrap Margin: Enter values for the table's wrap margin in centimeters.    The wrap margins determine the distance 
of text from each side of the table, or in other words, how close text in your document may appear above, below, or 
to either side of the table before wrapping.    See "Changing wrap margins with the mouse" for more detailed 
information.    Note that if the table has been inserted into the text, the wrap margin is not used and is dimmed.

By default, the position and wrap margin are specified in centimeters, but you may specify them in inches or points 
by following the number with the letters "in" or "pt" (e.g. 1.00in or 72.0pt).

Wrap: Choose the type of wrap from this pull-down menu.    Choose "None" for no text wrapping, that is, text will 
flow over the table, ignoring its wrap margins; choose "Line" if you want text to jump over the table and continue 
below it; choose "Text" if you want text to wrap around all sides of the table.

Grid...: Click this button to bring up the "Lines" dialog box which allows you to specify the line style to be used to 
draw the internal grid lines of the table.

Border...: Click this button to open the "Frame Border" dialog box where you can select the style of border to be 
used for the text frame.

Shades...: Click this button to open the "Shades" dialog box where you can select a shade or fill-pattern for the 
background of the table.    This is the same as choosing the "Shades..." command from the format menu.



Resizing an object with the mouse

To change an object's size, first select the object by clicking it,    then move the mouse directly over one of its sides 
or one of its corners.    Make sure to position the pointer over the object boundary itself and not its wrap margin (the 
light colored border line around the outside of the object).    The pointer changes to a white double arrow:  
depending on which side or corner it is positioned.    Simply click and drag in one of the directions of the double-
arrows to increase or decrease the object's size.

If the object being sized is a rectangle, or ellipse, then holding down the shift key when resizing the object 
constrains its aspect ratio to a square or a circle.

Note that if the wrap margin has been set to zero then you will not be able to size the object without first dragging 
the wrap margin out.



Moving objects with the mouse

To move an object, first switch to object mode, click the pointer anywhere on the object and drag.    The pointer 

changes to  when you position it over a selected object.    When you let go of the mouse button, the object is 
moved to the new location.    It is still selected, allowing you to move it again, format it, delete it, etc.    Objects can 
not be moved past the edges of a page.    If you want to move an object to a different page, you have to cut it, go to 
the destination page, then paste the object.



Changing wrap margins with the mouse

When you select an object, a border line appears around it.    This line represents the object's "wrap margin".    The 
wrap margin determines how close text in your document may appear above, below, or to either side of an object 
before wrapping.    To change an object's wrap margin, first click the object, then move the mouse directly on top of 
the wrap margin you want to change.    The pointer changes to a gray double-arrow:  depending on which 
wrap margin you want to change.    Simply click and drag in one of the directions of the double-arrows to increase or 
decrease the wrap margin.



Selecting An Object

You select objects in object mode by clicking them with the mouse.    When an object is selected, it is highlighted.    
A lighter colored border line also appears around the outside of the object - this is the object's wrap margin.    Wrap 
margins determine how close text in your document will appear to the object before wrapping over or below the 
object. (See Changing wrap margins with the mouse for more information.)

Selecting multiple objects

You can select more than one object at a time by holding down the Shift key when you click.    For example, select 
an object with the mouse, hold down the Shift key, and click another object.    Both objects are now selected.    While 
still holding down the Shift key, click another object.    Now three objects are selected.    Selecting multiple objects 
makes changing their attributes easy because you can change them all at once.    You can also move multiple objects 
together as a group.

A second way to select with multiple objects is to click and drag in the document at a position where there are not 
any objects.    As you drag, a rectangle will be drawn.    When you release the mouse button, all objects which 
intersect with the rectangle will be selected.



Object Mode vs. Text Mode

WordExpress has two modes - text mode and object mode.    Text mode is where you enter and format text.    Objects 
are created and manipulated in object mode, also called pointer mode because you switch to this mode by clicking 
the pointer button.    The difference between the two modes is quite obvious: you select text with the I-beam cursor 
(text mode), and graphic objects wit the arrow pointer (object mode).    Each mode has its own button on the control 
strip:

Click this button to switch to text mode where you can enter, edit, and format text.

Click this button to switch to object mode where you can create, modify, and position graphic objects, 
pictures, text frames, and tables.

You can also switch between text and object modes by clicking the right mouse button or by using the "Text Mode" 
and "Object Mode" commands on the View menu.

WordExpress knows which commands are available in which modes.    Most Format menu commands (except for 
"Borders...", "Lines...", and "Shades..."), for example, are not used to manipulate objects, and are therefore grayed 
out when you click the pointer button.    Likewise, most of the Object menu commands are unavailable when you are 
in text mode.    Certain types of objects - specifically text frames and tables - possess attributes that are edited using 
both modes.    The text contained within a text frame is edited in text mode, but the frame itself - its size, position, 
border, and fill attributes - are edited in object mode.



Object / Snap To Grid

Use "Snap to Grid" to precisely position objects, frames, and tables to the grid increments you specified with the 
"Set Grid..." command.    A check mark next to this command indicates that it is active.



Object / Snap To Guides

Use "Snap to Guides" to precisely position objects, frames, and tables to any guide lines you may have created in 
your document.    A check mark next to this command indicates that it is active.

You can create a guide with the mouse by clicking on the ruler bar (either horizontal or vertical) while in object 
mode and then dragging the mouse into the document.    A guide can be moved by clicking on the guide while in 
object mode and dragging with the mouse.    A guide can be deleted by clicking on the guide while in object mode 
and dragging it up to the ruler.

You can also create, move and delete guides via the "Edit Horz. Guides..." and "Edit Vert. Guides..." commands.



Object / Set Grid

Use "Set Grid..." to determine the horizontal and vertical grid increments for positioning - or "snapping" - objects, 
frames, and tables. 

Snap Dialog Box

Horizontal: Enter the distance between the horizontal grid lines.    If "Snap To Grid" is on, when objects are moved 
or sized, they will be force to align with a multiple of this value.

Vertical: Enter the distance between the vertical grid lines.        If "Snap To Grid" is on, when objects are moved or 
sized, they will be force to align with a multiple of this value.

By default, the horizontal and vertical grid lines are specified in centimeters, but you may specify them in inches or 
points by following the number with the letters "in" or "pt" (e.g. 1.00in or 72.0pt).

Tolerance: Set the tolerance used for the "Snap To Guides" option.    This is the distance from a guide (in pixels) at 
which an which the object's position will be set to the guide position (if "Snap To Guides" is on).



Object / Edit Horz. Guides

Use "Edit Horz. Guides..." to add, delete, and move horizontal guide lines.

Edit Horizontal Guides Dialog Box

To create a new guide, enter the vertical position of where you wan the new guide in the "Position" edit field and 
click "Add".    The new guide will be added to the list of guides in the list box below.    By default, the position is 
specified in centimeters, but you may specify it in inches or points by following the number with the letters "in" or 
"pt" (e.g. 1.00in or 72.0pt).

To delete an existing guide, click on the guide to be deleted (or enter its position in the edit field) and click "Delete".

To move an existing guide, click on the guide to be moved, enter a new horizontal position and then click "Move".

Editing horizontal guides with the mouse

To add a horizontal guide line with the mouse, change to object mode, click anywhere within the horizontal ruler 
and drag into the document. When you release the mouse button, a guide line appears at that position. 

You can move a guide line by clicking and dragging it.

To delete a horizontal guide line with the mouse, click it and drag it back to the horizontal ruler.



Object / Edit Vert. Guides

Use "Edit Vert. Guides..." to add, delete, and move vertical guide lines.

Edit Vertical Guides Dialog Box

To create a new guide, enter the horizontal position of where you wan the new guide in the "Position" edit field and 
click "Add".    The new guide will be added to the list of guides in the list box below.    By default, the position is 
specified in centimeters, but you may specify it in inches or points by following the number with the letters "in" or 
"pt" (e.g. 1.00in or 72.0pt).

To delete an existing guide, click on the guide to be deleted (or enter its position in the edit field) and click "Delete".

To move an existing guide, click on the guide to be moved, enter a new horizontal position and then click "Move".

Editing vertical guides with the mouse

To add a vertical guide line with the mouse, change to object mode, click anywhere within the vertical ruler and drag 
into the document. When you release the mouse button, a guide line appears at that position. 

You can move a guide line by clicking and dragging it.

To delete a vertical guide line with the mouse, click it and drag it back to the vertical ruler.



Insert Menu Commands

The Insert menu contains commands for inserting special items into your documents such as headers and footers, 
page breaks, auto fields, etc.

Field Allows you to insert special fields such as auto page numbers, print date, 
etc.

Insert Header / Footer Allows you to create a header or footer

Column Break Inserts a column break

Section Break Inserts a section break

Page Break Inserts a page break

Picture Inserts a picture into the text

Table Inserts a table into the text



Insert / Field

Use "Field..." to bring up the "Insert Field" dialog box which allows you to insert a special field into your document. 

Insert Field Dialog Box

Field Type: Choose the type of field you desire as follows:

Auto Number A field which generates an number is inserted.    You may choose either "Legal" (e.g. 1., 1.1, 
1.1.1, etc.), or "Outline" (e.g. I, A, i, a, etc.) numbering.    The level is controlled by the 
"Outline Level" setting in the paragraph attribute (see "Paragraph" command under the Edit 
menu).

Create Date The date on which the document was created is inserted.    You may choose from any of a 
number of date formats, or you may click the "Settings..." button which will display the 
"Date/Time Format" dialog box which allows you to enter your own custom format.

Create Time The time at which the document was created is inserted.    You may choose from any of a 
number of time formats, or you may click the "Settings..." button which will display the 
"Date/Time Format" dialog box which allows you to enter your own custom format.

File Name The file name of the document is inserted.    You may choose either the full path or only the 
base file name.

Merge Field A merge field is inserted.    If you have a database selected, the "Data" list box will contain a 
list of the available fields from that database.    Otherwise, the list will contain "Field One", 
"Field Two", etc., which represents the fields of the database in the order they are defined.    
You may click on the "Settings" button to display the "Set Database" dialog box, which 
allows you to select the database to use.

Page Inserts the current page number.    This field is most useful in headers or footers.

Print Date The date on which the document was last printed is inserted.    This field is always updated 
each time you print your document.    You may choose from any of a number of date 
formats, or you may click the "Settings..." button which will display the "Date/Time 
Format" dialog box which allows you to enter your own custom format.

Print Time The time at which the document was last printed is inserted.    This field is always updated 
each time you print your document.    You may choose from any of a number of time 
formats, or you may click the "Settings..." button which will display the "Date/Time 
Format" dialog box which allows you to enter your own custom format.

User Info You may insert any of the fields from the "User Info" dialog box (see "User Info.." under 
the Edit menu.



Date/Time Format Dialog Box

The "Date/Time Format" dialog box allows you to enter an arbitrary date or time format.    You should enter a string 
which consists of codes from the following table which are used to build up the date and/or time:

Date
m Month (numeric) 1
mm Month (numeric 2 digits 01
mmm Month (abbr.) Jan
mmmm Month (full) January
d Day 2
dd Day (2 digits) 02
ddd Day of week (abbr.) Wed
dddd Day of week (full) Wednesday
yy Year (2 digits) 94
yyyy Year (4 digits) 1994

Time
H Hour (12 hour) 1
HH Hour (12 hour, 2 digits) 01
h Hour (24 hour) 13
hh Hour (24 hour, 2 digits) 13
M Minutes 5
MM Minutes (2 digits) 05
S Seconds 9
SS Seconds (2 digits) 09
AM AM/PM PM



Insert / Insert Header / Footer
Insert / Goto Header / Footer

WordExpress makes it easy for you to insert Headers and Footers in you document.    Headers and footers are a 
special type of text frame that are repeated on every page of the document.    Headers appear at the top of the page, 
between the page edge and the top margin;    footers at the bottom of the page between the page edge and the bottom 
margin.    Headers and footers are the ideal place to include automatic page numbers, date, time, and several other 
insert fields.    You can format text and fields contained in headers and footers just like other text frames.

To insert a header or footer into your document:

1) Choose "Insert Header" or "Insert Footer" from the Insert menu.

A text frame is automatically created between the left and right margins.    The initial width of the header depends on 
the position of your left and right margins.

2) Type the text that you want to appear in the header or footer into the frame.

3) Format the header or footer text just as you would other text.

4) Insert any fields into the header or footer - such as auto page numbers, print date, etc. - using the "Insert 
Field..." command under the Insert menu.

5) Resize the header or footer horizontally like you would any other text frame;    you can only resize it 
vertically by adding lines of text or pressing Enter.

Once a header or footer has been inserted, the commands change to "Goto Header" and "Goto Footer".    Choosing 
these commands will place the cursor into the header or footer.



Insert / Column Break

Use "Column Break" to insert a column break at the current cursor location.    This command is only useful if 
multiple columns have been selected for the current section (see the "Section" command under the Format menu).

To Press
Insert a column break CTRL+SHIFT+ENTER



Insert / Section Break

Use "Section Break" to insert a section break at the current cursor location (see the "Section" command under the 
Format menu).



Insert / Page Break

Use "Page Break" to insert a page break at the current cursor location.    Page break cannot be inserted into text 
frames or tables.    You can also insert a page break by holding down the Control key while pressing Enter.

To Press
Insert a page break CTRL+ENTER



Insert / Picture

Use "Picture..." to insert a picture into the text at the current cursor position.    The "New Picture" dialog box will be 
displayed which allows you to enter the name of the picture to import.

This command differs from the Object menu command to create a picture in that the picture is inserted into the text 
rather than attached at an absolute position on the page.    In this way, the picture will move with the surrounding 
text.    Pictures may be inserted anywhere in the document.



Insert / Table

Use "Table..." to insert a table into the text at the current cursor position or into a table cell.    The "New Table" 
dialog box will be displayed which allows you to enter the number of rows and columns for the table.

This command differs from the Object menu command to create a table in that the table is inserted into the text 
rather than attached to an absolute position on the page.    In this way, the table will move with the surrounding text. 
A table may not be inserted into a text frame.    If the cursor is in a table, then this command will create a sub-table 
within the current cell of the table.



Table Menu Commands

The Table menu contains commands for working with WordExpress tables.    Tables are spreadsheet-like objects 
ideal for storing tabular or columnar data such as order forms, price sheets, and invoices.    You can create tables 
with the table tool in object mode, or insert them directly into document text using the "Table..." command under the 
Insert menu.

Edit Rows Edit the attribute of table rows

Edit Cells Edit the attributes of table cells

Insert Rows Insert rows into a table

Insert Columns Insert cells columns into a table

Delete Cells Delete cells from a table

Select Table Select the entire table

Select Rows Select rows of a table

Select Columns Select columns of a table



Table / Edit Rows

Use "Edit Rows" to edit the attributes of rows of a table.    The attributes of all of the currently selected rows will be 
changed.    If no rows are selected, the attributes of the row currently containing the cursor will be changed.

Edit Table Row Dialog Box

# Columns: Enter the number of columns in the selected rows.

Min. Height: Enter the minimum height for each of the selected rows.    The height of the row is determined by the 
height of the largest cell in the row, subject to the limitation that it not be smaller than this minimum.

Keep Together With Next Row: Click this option if you do not want a page break to occur between this row of the 
table and the next.    This option is only available for tables that were inserted into the text using the "Table..." 
command under the Insert menu, i.e., it is not available for tables created using the table tool in object mode.

Break Page At Row: Click this option if you want to force a page break before this row.    If more than one row is 
selected, page breaks are inserted between each of them.    This option is only available for tables that were inserted 
into the text using the "Table..." command of under Insert menu, i.e., it is not available for tables created using the 
table tool in object mode.



Table / Edit Cells

Use "Edit Cells..." to edit the attributes of cells in a table.    The attributes of all selected cells will be changed.    If no 
cells are selected then the attributes of the cell currently containing the cursor will be changed.

Edit Table Cell Dialog Box

Margins: Enter the left, right, top, and left margins.    The margins represent the distance from the edge of a cell to 
the text.

Width: Enter the width of the cell.    If the "Auto Width" option is selected, then the width of the cell is determined 
by the width of the text within the cell and this field is grayed.

Auto Width: Click this option if you wish the width of the cell to be determined by the width of the text within the 
cell.

Right Align: Click this option if you want the cell to be right aligned.    This option is only useful when used in 
conjunction with the "Auto Width" option.    It does not right align the text in the cell, but rather the cell itself.

Align Baselines: Click this option to align the baselines of all of the cells in a row with the "Align Baselines" option 
set.

Changing cell width with the mouse

You can also change the width of selected cell columns with the mouse: switch to text mode, then position the I-
beam over a column border.    The pointer changes to  which lets you move column borders.    Click and drag to 
the right or left to increase or decrease the column width.    If cells are selected, then only the width of the selected 
cells are changed.    If no cells are selected then the widths of all cells in the column are changed.



Table / Insert Rows

Use "Insert Rows" to insert rows into a table.    If there are rows currently selected, then a number of rows equal to 
the number currently selected will be inserted before the first selected row.

If no rows are currently selected, then the "Insert Rows" dialog box will be displayed.    Enter the number of rows 
you wish to insert.    The rows will be inserted before the row which currently contains the cursor.



Table / Insert Columns

Use "Insert Columns" to insert columns into a table.    If there are columns currently selected, then a number of 
columns equal to the number currently selected will be inserted before the first selected column.

If no columns are currently selected, then the "Insert Columns" dialog box will be displayed.    Enter the number of 
columns you wish to insert.    The columns will be inserted before the column which currently contains the cursor.



Table / Delete Cells

Use "Delete Cells" to delete the currently selected cells.    If no cells are selected, this command is grayed.    "Delete 
Cells" differs from the "Cut Cells" command on the Edit menu in that the deleted cells are not copied to the 
clipboard.    You can also delete cells by pressing the delete key when cells are selected.



Table / Select Table

Use "Select Table" to select the entire table currently containing the cursor.



Table / Select Rows

Use "Select Rows" to select entire rows of a table.    If no cells are currently selected then the row    containing the 
cursor is selected.    If cells are selected, then the all of the rows which contain the selected cells are selected.



Table / Select Columns

Use "Select Columns" to select entire columns of a table.    If no cells are currently selected, then the column which 
contains the cursor is selected.    If cells are selected, then all of the columns which contains the selected cells are 
selected.



Utility Menu Commands

The Utilities menu contains commands for setting up a print merge, spell-checking documents, and customizing the 
speed tool.

Set Database Specify the database to use for merging.

Spell Check Check the spelling of words in the document

Thesaurus Lookup and suggest synonyms for a selected word

Word Count Count the number of characters, words, lines, paragraphs, and pages in 
the document, current text frame, or current table.

Customize Speed Tools Configure the speed tools.



Utilities / Set Database

Use "Set Database" to specify the database which is to be used merging.    When the document is printed, you may 
specify that a "Merge" is to take place.    In this case, the document will be printed once for each record in the 
database (or for the range of records specified).    Each time the document is printed, each merge field (see the 
"Field" command on the Insert Menu) in the document will be replace by the associated field from a record of the 
database.

Set Database Dialog Box

List Files of Type: Select options from this menu to tell WordExpress the type of database you want to merge: 
Windows/ANSI Comma Delimited, DOS/PC-8 Comma Delimited, Windows/ANSI dBASE or DOS/PC-8 dBASE. 
The type you choose here determines the available files in the file list.

Use first record for field name: Check this option if you wish to use the first record of the database for the field 
names.    This is particularly useful for Comma Delimited databases which do not have field names.

Select the drive and directory where you want WordExpress to look for databases from the Drives and Directories 
list boxes.



Utilities / Thesaurus

Use "Thesaurus..." to lookup and suggest synonyms (words with similar meanings) for a selected word in your 
document.    The Thesaurus can then replace the word in your document with the synonym you select.

Thesaurus Dialog Box

Word: Specifies the current word whose synonyms are displayed.    This combo-box also keeps a history of words 
you have looked up.    Each time you perform a lookup, the word is added to this list so you can return to that word 
later if you desire.

Synonyms: Displays a list of synonyms.    You may select the synonym you want to replace the selected word and 
press "OK", or you may double click on a synonym to move that synonym up to the "Word" box, generating a new 
list of synonyms.

Usages: Clicking the different usages changes the list of available synonyms.

Definition: Displays a brief definition of the selected word.

To Press
Open the thesaurus F8



Utilities / Spell Check

Use "Spell Check" to check the spelling of words in your document. 

Spell Check Start Dialog Box

You will first be asked if you wish to start at the beginning of the document or at the current cursor position.    Click 
"Start at beginning of document" if you want the entire document (including text in text frames and tables) to be 
checked.    Click "Start at current cursor position" if you want to search only from the current cursor position to the 
end of the document (or text frame).

Click "OK" to begin the spell check.    If a misspelled word is found, the document will be positioned at that word 
and the word will be highlighted.    The "Spell Check" dialog box will be displayed:

Spell Check Dialog Box

Change To: This combo box displays a list of suggested spellings.    Click on the correct spelling or type it in the 
edit field.

Change: Click on this button to change the selected word to the word displayed in the "Change To" field and then 
continue checking the remainder of the document.

Change All: Click on this button to change all future occurrences of this misspelled word to the word displayed in 
the "Change To" field.    Spell checking for other misspelled words continues.

Stop: Click on this button to stop the spell check and return to the document.

Add Word: Click on this button to add the selected word to the user dictionary.    Spell checking for other 
misspelled words continues.

Ignore: Click on this button to ignore this occurrence of this word.

Ignore All: Click on this button to ignore all occurrences of this word.

Undo Last: Click on this button to undo the last changed word.

To Press
Perform a spell check F7



Utilities / Word Count

Use "Word Count" to count the nubmer of characters, words, lines, paragraphs and pages in the document, frame or 
table.    If the cursor is in the body text of the document (or in a table which has been inserted into the document via 
the "Table" command on the Insert menu), then the number of words in the body text of the document is reported.    
If the cursor is in a text frame or a table which was created using the "Tools" command on the Object menu, then the 
number of words in that frame or table is reported.

To Press
Count words F6



Utilities / Customize Speed Tools

Use "Customize Speed Tools..." to configure the speed tool palette.    You can choose which speed tools appear on 
the palette, as well as their order.    The "Customize Speed Tools" dialog box is displayed:

Customize Speed Tools Dialog Box

Tools: Select from this list of tools to add to or remove from the tool palette.

Default: Click this button to install the default set of tools.

Add: Click this button to add the currently selected tool to the palette.    If the tool is currently on the palette, this 
button will be grayed.

Add All: Click this button to add all of the tools to the palette.

Remove: Click this button to remove the currently selected tool from the palette.    If the tool is not currently on the 
palette, this button will be grayed.

Remove All: Click this button to remove all of the tools from the palette.

Position: Choose the palette's position.    The palette may be positioned along the top, bottom, left edge or right 
edge, or may be floating.

Done: Click this button when all modifications are complete.

Configuring the tool palette with the mouse

Display the "Customize Speed Tools" dialog box either by choosing "Customize Speed Tools..." from the Utilities 
menu or double clicking on the speed tools palette.

You can then add tools to the palette with the mouse by clicking on the tool icon below the "Add All" button and 
dragging the tool over to the palette.      You can remove tools from the palette with the mouse by clicking on any 
tool on the palette and dragging it off the palette.    You can re-arrange the order of tools on the palette by clicking on 
any tool on the palette and dragging it to a new position.

Click "Done" when all modifications are complete.



Window Menu

The Window menu contains commands to cascade or tile the document windows, to arrange the icons which 
represent minimized document windows, and to close all open documents.

Cascade Arranges all non-minimized document windows in a cascade fashion starting in the 
upper left corner of the workspace and moving down and to the right

Tile Tiles all non-minimized documents so all are visible simultaneously

Arrange Icons Arranges all the icons which represent minimized documents.

Close All Closes all open documents



Paste Cells Dialog Box

This dialog box is displayed whenever you paste cells into a table.

Insert Rows: Click this option if you want to insert the cells as new rows before the row which currently contains 
the cursor.

Append Rows: Click this option if you want to append the cells as new rows after the last row.

Insert Columns: Click this option if you want to insert the cells as new columns before the column which currently 
contains the cursor.

Append Columns: Click this option if you want to append the cells as new columns after the last column.



Picture Warning Dialog Box

This dialog box appears if you attempt to open a file which uses pictures which are invalid or can no longer be 
found.

Skip: Click this button to skip this picture.    The picture will be displayed as a gray rectangle.    You can later specify 
the picture to use by double clicking on the rectangle or using the    "Attributes..." command under the Object Menu.

Skip All: Click this button to skip this picture and all subsequent invalid pictures.    The invalid pictures will be 
displayed as gray rectangles.    You can later specify the pictures to use by double clicking on the rectangles or using 
the "Attributes..." command under the Object Menu.

File: Click this button to bring up the "New Picture" dialog box which will allow you to specify the picture to use.

Cancel: Click this button to cancel loading this file.



Keyboard Reference

Movement Keys
Text Selection Keys
Formatting Keys
Editing Keys
View Keys
Menu Shortcut Keys



Movement Keys

To Move Press
Left one character
Left one word CTRL+
Right one character
Right one word CTRL+
Up one line
Up one paragraphCTRL+
Down one line
Down one paragraph CTRL+

To the beginning of a line HOME
To the beginning of a document CTRL+HOME
To the end of a line END
To the end of a document CTRL+END

Up one window PGUP
Down one window PGDN
To the next cell (in tables) TAB



Text Selection Keys

To Select Press

Previous character SHIFT+

Previous word SHIFT+CTRL+

Next character SHIFT+

Next word SHIFT+CTRL+

Previous line SHIFT+

Previous paragraph SHIFT+CTRL+
Next line SHIFT+
Next paragraph SHIFT+CTRL+

To the beginning of a line SHIFT+HOME
To the beginning of a document SHIFT+CTRL+HOME
To the end of a line SHIFT+END
To the end of a document SHIFT+CTRL+END

Previous window SHIFT+PGUP
Next window SHIFT+PGDN
Entire document CTRL+A



Formatting Keys

To Format Press
Bold CTRL+B
Italic CTRL+I
Underline CTRL+U
Character CTRL+T
Paragraph CTRL+M
Face name CTRL+SHIFT+F
Paragraph style CTRL+SHIFT+S
Point size CTRL+SHIFT+P
Left justify CTRL+SHIFT+L
Right justify CTRL+SHIFT+R
Center CTRL+SHIFT+C
Flush justify CTRL+SHIFT+J
Word underline CTRL+SHIFT+W
Single line spacing CTRL+1
One and a half line spacing CTRL+2
Double line spacing CTRL+3
Superscript CTRL+PLUS    (on numeric keypad)
Subscript CTRL+MINUS    (on numeric keypad)
No super/subscript CTRL+ASTERISK    (on numeric keypad)



Editing Keys

To Delete Press
Next character or selection DEL
Selected object DEL
Previous character or selection BACKSPACE
Selected object BACKSPACE
Selection and copy to clipboard SHIFT+DELETE or CTRL+X
Object and copy to clipboard SHIFT+DELETE or CTRL+X

To Insert Press
Line break SHIFT+ENTER
Paragraph break ENTER
Column break CTRL+SHIFT+ENTER
Page break SHIFT+ENTER
Text from clipboard SHIFT+INS or CTRL+V

To Copy Press
Selection to clipboard CTRL+INS or CTRL+C
Object to clipboard CTRL+INS or CTRL+C

To Press
Undo / Redo ALT+BACKSPACE or CTRL+Z
Select all text in a frame CTRL+A
Select all objects on a page CTRL+A



View Keys

To Press
View next document CTRL+F6
View previous document CTRL+SHIFT+F6
Maximize application window ALT+F10
Maximize document window CTRL+F10
Minimize application window ALT+F9
Minimize document window CTRL+F9
Restore application window ALT+F5
Restore document window CTRL+F5



Menu Shortcut Keys

Menu Command Shortcut Key
File New CTRL+N

Open CTRL+O
Save CTRL+S
Close CTRL+W or CTRL+F4
Print CTRL+P
Exit ALT+F4 or CTRL+Q

Edit Undo/Redo ALT+BACKSPACE or CTRL+Z
Cut SHIFT+DEL or CTRL+X
Copy CTRL+INS or CTRL+C
Paste SHIFT+INS or CTRL+V
Select All CTRL+A
Search CTRL+F
Replace CTRL+H
Find/Replace Next F3 or CTRL+G

Format Character CTRL+T
Bold CTRL+B
Italic CTRL+I
Underline CTRL+U
Word Underline CTRL+W
Paragraph CTRL+M

Insert Column Break CTRL+SHIFT+ENTER
Page Break SHIFT+ENTER

Utilities Spell Check F7
Thesaurus F8
Count Words F6




