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Chapter Overview

This chapter explains the procedures for performing imaging manipulations and data analyses in 
NCSA Image. You will learn, for example, how to magnify and interpolate images; generate 
raster images, shaded data, contour, and ordered dither plots; and use the XY graphing and 
animation functions provided in the program.

If you are planning just to skim through or skip over this chapter, be sure to read the notes that 
are scattered throughout. They may save you from unnecessary frustration.

Basic Imaging Options

NCSA Image initially displays your image data as a color raster image, but provides alternative 
means of viewing and studying your image data. NCSA Image allows you to perform several 
basic imaging options such as magnifying, interpolating, and plotting. Complete descriptions of 
more complex imaging options that permit in-depth analysis of your data are presented in the 
section entitled "Features for Advanced Analysis."

NOTE:  Only one of the following imaging options affects the actual data in the image—
Interpolation. Other imaging options change only the representation of the data.

Magnifying and Reducing Images
To magnify or reduce your image:

1. Select Magnify from the Tools menu. The dialog box shown in Figure 4.1 appears on the 
screen and allows you to specify the degree of magnification or reduction.

2. Use the text box labeled X&Y to specify the same magnification or reduction for both axes.

3. Use the individual text boxes labeled X or Y to specify different degrees of magnification or 
reduction for each axis.

4. Enter a value greater than 1 but no larger than 99 (for example, 1.5) in the appropriate text 
box to magnify the image.

5. Enter a fractional value less than 1 but no smaller than 0.05 (for example, 0.5) in the 
appropriate text box to reduce the image.

6. Click OK. Your image is enlarged or reduced according to your specifications.
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Figure 4.1 Magnify Dialog Box

OK

Interpolating an Image
Interpolation is similar to magnification or reduction except that it generates a smoothed image. 
The effects of interpolation are not reversible, because the pixels are not merely duplicated; 
rather, a mathematical function is applied to estimate the value of the additional or remaining 
pixels by taking a weighted average of the known values of their neighboring pixels. For the 
same reason, interpolation produces a smoother image than the other method of magnification 
or reduction.

To magnify or reduce your image by means of interpolation:

1. Select Interpolate from the Tools menu. The dialog box shown in Figure 4.1 appears on the 
screen and allows you to specify the degree of magnification or reduction.

2. Use the text box labeled X&Y to specify the same magnification or reduction for both axes.

3. Use the individual text boxes labeled X or Y to specify different degrees of magnification or 
reduction for each axis.

4. Enter a value greater than 1 but no larger than 99 (for example, 1.5) in the appropriate text 
box to magnify the image.

5. Enter a fractional value less than 1 but no smaller than 0.05 (for example, 0.5) in the 
appropriate text box to reduce the image.

6. Click OK. Your image is interpolated according to your specifications.

NOTE:  If you perform an interpolation on an image sequence, the entire sequence is 
interpolated according to your specifications. You cannot interrupt the interpolation process.
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Plotting an Image
NCSA Image provides several methods of visualizing your datasets in color and black-and-
white. The various plots you may generate from image data are described in the following 
sections.

NOTE:  When you plot an image, the entire dataset associated with the image window is 
represented in the plot. NCSA Image does not plot just a selected region of an image. 

Color Raster Plots
To represent your data as a color raster plot, as NCSA Image does when it initially displays your 
dataset, select Raster from the Plot menu, shown in Figure 4.2.

Figure 4.2 Plot Menu

In a color raster plot, each data value is represented by color. In a process called color mapping, 
pixel values are converted to color by interpreting the value as an index in the color table. The 
color table is a set of hardware registers that determine which of the 16 million available colors 
are displayed for each of the 256 possible pixel values. The color table contains red, green, and 
blue values that determine how the values in the image data are displayed.

Contour Plots
A contour plot represents a matrix of data values by drawing contour lines between areas of 
differing contour levels. A contour level is a range of data values that you want distinguished 
from other ranges of values. A contour plot is much like a topographical map, on which lines are 
drawn between areas of differing altitude.

To generate a contour plot for your image data, select Contour from the Plot menu.

The dialog box that appears is shown in Figure 4.3. To define spacing for the contour levels and 
vary the number of levels drawn:

1. Specify a number of contour levels and the maximum and minimum data values.

NOTE:  NCSA Image does not allow you to specify fewer than two contour levels.
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2. Select Evenly Spaced Intervals or User Defined Levels to determine the spacing between 
contour lines.

If you select User Defined Levels, the dialog box pictured in Figure 4.4 appears. Enter the 
spacing you desire in number of pixels, spacing between each as directed.

3. Click OK or press RETURN.

A contour plot of your data is plotted in the image window according to your specifications. A 
sample contour plot is shown in Figure 4.5.

Figure  4.3 Contour Plot Dialog Box

Figure 4.4 User Defined Contour Levels

Figure  4.5 Contour Plot  Window
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3D Plots
To generate a 3D surface plot to visualize your image data, select 3D from the Plot menu.

A 3D plot for the current dataset and the Angle Cube is drawn in the image window.

In a 3D plot, the height of the surface represents the magnitude of the associated value. The 
surface is represented by cross-hatching, a grid-like pattern that resembles a fishing net. The 
surface may be rotated interactively using the Angle Cube.

The Angle Cube is located in the upper-left hand corner of the display. You may use the Angle 
Cube to alter the viewing angle of the 3D plot. To do so, click and drag within the plot window 
while holding down the mouse button. The Angle Cube shifts its position, reflecting the viewing 
angle, and the plot is redrawn accordingly. The window depicted in Figure 4.6 shows a sample 
3D Plot.

Figure  4.6 3D Plot Window

Shaded Data Plots
You can visualize your image data by using a shaded data plot, which represents the values as 
eight different intensities of shading. To do so, select Shade from the Plot menu. A shaded data 
plot window appears on the screen.

The eight patterns used in the shaded data plot represent the values in the ranges 0-31, 32-63, 
64-95, 96-127, 128-159, 160-191, 192-223, and 224-256.

NOTE:  NCSA Image initially represents the higher magnitudes with darker shades and the 
lower magnitudes with lighter shades. To reverse this representation, select Preferences from 
the Edit menu. In the dialog box that appears, select the command Darker shades for lower 
magnitudes. A complete description of the 

Imaging Options for Data Analysis 4.6



4.7 NCSA Image 

Preferences dialog box and options is presented in Chapter 2 in the section entitled 
"Preferences."

A sample shaded data plot is shown in Figure 4.7.

Figure  4.7 Shaded Data Plot Window

Ordered Dither Plots
Like the shaded data plot, an ordered dither plot represents your data as different intensities of 
shading; however, the ordered dither plot uses calculated, rather than predefined, patterns to do 
so. The patterns are generated to present numerous levels of intensity. Consequently, the 
ordered dithered plot may display many more gray levels than the shaded data plot, which uses 
only eight.

To generate an ordered dither plot from your dataset, select Dither from the Plot menu. A dither 
plot window such as the sample window shown in Figure 4.8 appears in the image window.

Figure  4.8 Ordered Dither Plot Window
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Working with Multiple Images
The number of images you can load into NCSA Image is limited only by the amount of memory 
you have available. Each image is presented in a separate window. Any commands that you 
issue apply only to the active window.

Features for Advanced Analysis

NCSA Image provides several alternative means of visualizing your datasets other than simple 
raster images and black-and-white plots. For instance, you may generate XY graphs, 
histograms, and animations from your image data, and you may view the actual data values in a 
dataset.

Generating an XY Graph
NCSA Image provides a rudimentary XY graphing capability which allows you to select three 
different types of lines of data from images:  horizontal, vertical, and freehand.

To generate an XY graph:

Figure 4.9 Graphing Tool

1. Select the graphing tool from the tool chest. The graphing tool is shown in Figure 4.9. This 
puts you in the XY line mode. In this mode you may select data points from the image to be 
plotted and add them to the XY graph.

2. Select a line mode, as instructed in the section entitled "Selecting a Line Mode."

3. Select a dataset from an image, as instructed in the section entitled "Selecting a Dataset."

4. Add the dataset to the XY plot, as instructed in the section entitled "Adding Lines to the XY 
Plot."

Selecting a Line Mode
You may draw lines in any of three line modes:  horizontal, vertical, and freehand. To select one 
of these modes, choose Options from the XY menu. In the dialog box that appears, you may 
specify the line drawing mode. The Options dialog box is presented in Figure 4.12, which 
appears in the following section.

NOTE:  If you attempt to draw a line on an image before specifying a line mode, the Options 
dialog box appears and prompts you to choose a line mode.
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Selecting a Dataset
To select data points from an image, activate the image window and draw a line by clicking and 
dragging through the image. The line is a selection of values; these values become highlighted 
when you drag over them.

When you draw a horizontal or vertical line, the starting point is at the offset where you initially 
click; the end point is where you release the mouse button. In freehand mode, you may draw a 
line of any slope. The starting point of such a line is the horizontal and vertical offset at which 
you initially click.

In horizontal and vertical line modes, dragging vertically or horizontally, respectively, allows you 
to reposition the line you have drawn on different values.

You can plot up to nine horizontal or nine vertical lines simultaneously in a single graph, but only 
a single freehand line at one time. In horizontal or vertical graphing mode, the horizontal or 
vertical offset, respectively, is displayed in the text box. The text box is further described in 
Chapter 3 in the section entitled "Working with Image and Palette Windows."

Adding Lines to the XY Plot
After you draw a line, whether horizontal, vertical, or freehand, you need to add the data points it 
contains to the XY graph. To do so, select Add Dataset from the XY menu, shown in Figure 4.10, 
or press -A. An XY window appears behind the active window, and the data you have selected⌘  
is plotted in it.

Figure 4.10 XY Menu

/Show XY /Hide XY

NOTE:  There is no way to remove just a single plot from the XY graph. To clear the entire 
graph, use the Reset command in the XY menu (described in a subsequent section).

The XY Window
To display the XY window, choose Show XY Window from the XY menu. The XY window is 
brought to the front of the screen, and any datasets you have added to the XY graph are plotted. 
A sample XY window is shown in Figure 4.11. The XY window contains an XY 
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plot and three buttons:  Options, Legend, and Reset. These buttons are described in the 
following sections. To remove the XY window from sight, select Hide XY Window from the XY 
menu.

Figure 4.11 Sample XY Window

Options
NCSA Image allows you to specify a number of option parameters related to XY graphing. To do 
so, press the Options button in the XY window or select Options from the XY menu.

The Options dialog box, shown in Figure 4.12, appears on the screen.

Figure 4.12 Options Dialog Box

Imaging Options for Data Analysis 4.10



4.11 NCSA Image 

Using the Options dialog box, you may enter a title for your plot and for each of its axes. You 
may also specify a boundary rectangle from which datasets are extracted, so that any selection 
line that falls outside the boundary rectangle is clipped off. In addition, you can specify the 
number of tick marks for the x and y axes and choose an XY line mode.

The Legend
You may also specify names for each line that is displayed in the XY window. To do so, click the 
Legend button in the XY window or select Legend from the XY menu. A dialog box, shown in 
Figure 4.13, appears on the screen and prompts you to name the lines in the order that they are 
drawn.

The default label for a line is its vertical offset when you are in horizontal mode, and the 
horizontal offset when you are in vertical mode. In freehand mode, no default label is provided. 
Line One in Figure 4.13 was drawn in freehand mode and manually labeled.

Figure 4.13 Legend Dialog Box

Resetting the Plot
To erase your XY graph, click the Reset button in the XY window or select Reset from the XY 
menu. This clears the plot and deletes all the datasets you added to the XY graph, so that you 
may add new datasets. It does not delete the axis and title labels or the boundary rectangle.
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Viewing Actual Data Values

Figure 4.14 Scope Tool

To view the data values associated with the image, select the scope tool from the tool chest. The 
scope tool is depicted in Figure 4.14. This puts you in scope mode. When you depress the 
mouse and drag within a raster window in this mode, the text box shows the data value currently 
under the cursor. When you move the mouse outside of the window, the text box is cleared.

Making a Selection
Several operations may be performed on a selected portion of an image rather than the entire 
image. Specifically, you may copy, print, or generate histograms from selected regions of an 
image.

Suppose you wish to generate a histogram of only those values which occur in a hot spot on 
your image. To make a selection:

Figure 4.15 Selection Tool

1. Choose the selection tool from the tool chest. The selection tool is shown in Figure 4.15.

2. Select an area of a raster image by clicking and dragging out a rectangular region within the 
image window. Note that the area of the selection is highlighted as you select it.

3. Release the mouse button. The selection remains highlighted.

To remove a selection from a window, click again within the window and the highlighted area 
reverts to its original state.

Creating a Histogram
To generate a histogram of the frequency distribution of data:

1. Select the region of interest using the selection tool.

2. Choose Histogram from the Tools menu. A dialog box, shown in Figure 4.16, appears on the 
screen.

The histogram in the dialog box represents along the y axis the number of instances of a value 
in the selection. The x axis denotes the values in ascending order from left to right.

More specifically, the y axis indicates the relative number of pixels found in the image or 
selection for each of the 256 palette entries, and the x axis represents the 256 entries.

A histogram provides a means of examining how different colors or grays are distributed in your 
image. This information allows you to determine how to enhance the image or manipulate the 
palette. To perform a histogram color adjustment, click the button labeled Adjust Colors. This 
adjusts the color table to increase contrast in the areas where the most data values are located.
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Figure 4.16 Histogram Dialog Box

Top:

Left: Right:

Animating a Sequence of Images

You may also do some quasi-real-time animations in NCSA Image. The animation may be run 
from memory or disk.

From Memory
To run an animation sequence from memory:

1. Select From Memory from the Animate submenu under the File menu. You are presented 
with the directory dialog box shown in Figure 4.17.

2. Open the directory that contains the files you wish to animate by double-clicking on it. Do not, 
however, double-click on any specific files.

3. Click Set to set up the animation sequence and return to the image window.
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Figure 4.17 Animation Dialog Box

The files in the directory you selected are loaded into memory before the animation sequence 
begins. If the directory contains more files than you have memory available to animate, the 
animation proceeds with whatever files fit.

From Disk
To run an animation sequence from disk, select From Disk from the Animate submenu under the 
File menu. Animation from a disk proceeds similarly to animation from memory, although only 
one file is loaded into memory at a time. Before each image is displayed, it must be loaded from 
disk.

Controlling an Animation
After you load an animation sequence, the Animation menu shown in Figure 4.18 appears in the 
menu bar. You may use this menu or key commands to control the animation.

Figure 4.18 Animation Menu

Faster
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Using the Animation Menu
1. Select Forward or Backward to initiate the animation sequence in either direction.

2. Select a value from the Speed submenu, where 10 is the fastest and 1 the slowest, to 
determine the speed of the animation (see Figure 4.19).

3. Select Faster or Slower to increase or decrease the speed of the animation by a single 
degree.

4. Select Step Forward or Step Backward to advance a single frame in either direction.

5. Select Stop to stop the animation.

Figure 4.19 Speed Submenu

Using Keyboard Commands
1. Press the left or right ARROW key to initiate the animation sequence backward or forward, 

respectively.

2. Press a number key, where 1 is the slowest and 0 the fastest, to determine the speed of the 
animation.

3. Press the up or down ARROW to advance a single frame forward or backward, respectively.

4. Press any key other than those mentioned in steps 1 through 3 to stop the animation.
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Deleting an Image

To purge an image window, first verify that the window is active, then click in the close box or 
select Close from the File menu. The image, window, and associated color table are discarded.

NOTE:  This procedure does not save your image or associated information to a file before 
removing it from the screen. If you need to retain this information, you must save the data in the 
manner described in the following section.

Saving an Image

To save an image with its dimensions and associated color table to a file, select Save As from 
the File menu or press -S. A directory dialog box appears and prompts you to name the file ⌘
and indicate the directory in which to store the data. When you click Save, the data is stored in 
HDF format, unless otherwise specified.

Copying and Pasting Images

You can copy black-and-white plots, color raster images, or selected portions of these onto the 
Clipboard, which is used to transfer information between applications on the Macintosh. The 
copied portion of the image can then be pasted into other image processing packages, such as 
NCSA DataScope or NCSA Layout.

To copy an image or selection region, choose Copy from the Edit menu or press -C. You can ⌘
paste this image into NCSA Image by choosing Paste from the Edit menu or pressing -V.⌘

NOTE:  The Clipboard only holds the latest image or plot that you copied. Subsequent copies 
replace the contents of the Clipboard.

Printing Plots

To print any black-and-white plot, including an XY plot, activate its window and select Print from 
the File menu or press -P. More detailed information regarding printing procedures is ⌘
presented in Chapter 1 in the section entitled "Printing an Image."
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