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Commands

File Menu Contains commands that let you create, open, save, close, recall, and print files. 
Additional commands let you add digital images using a scanner or video 
grabber; change the setup of your printer, scanner, or video grabber; and close 
Picture Publisher.

Edit Menu Contains commands that undo operations and transfer images to and from the 
Clipboard. The Edit menu commands also let you specify paste options and 
program preferences.

Map Menu Contains commands that let you adjust the colors and intensities in an image to 
enhance it for output. They include adjustments to contrast, hue, lightness, 
saturation and special effects, such as posterizing and thresholding.You can also 
adjust your monitor and compensate for scanning and printing imperfections.

Mask Menu Contains commands that work in conjunction with the Mask tools to remove, 
load, and save masks. The menu also contains commands that let you crop an 
image to a mask and blend an image to the edges of a pasted image.

Object Menu Contains commands for selecting and deselecting objects; ordering objects; 
feathering objects; merging masks with objects; deleting objects; showing and 
hiding the object list; and anchoring objects to the base image.

Image Menu Contains commands that let you resize, rotate, mirror, invert (positive and 
negative), and filter an image or portions of an image defined by a mask.

Window Menu Contains commands that let you duplicate a window, show or hide elements of 
the window, open a scratchpad, arrange windows on the screen, and close all 
windows.

Help Menu Contains commands that let you view the contents of the help system, how to 
use Picture Publisher, Read Me information, and how to use help.



Error Messages

Are you sure you want to delete (filename)?
Can't initialize the compressed image.
Can't initialize the scanner: (scanner driver name).
Can't open the scanner driver: (scanner driver name).
Cannot write file (filename). The new file requires (file size) bytes of unused disk space. Your disk has 
only (disk space) bytes of unused space.
Could not open the Image Cache file in directory (path name).
Error writing to the Clipboard.
Extended name (extended filename) already exists. Do you want to overwrite it?
(Image name) is a CCITT or Packbits TIFF Image; cannot be opened.
Input points must be in ascending order.
(Map name) is not a valid map file.
(Mask name) is not a valid mask file.
Not enough memory to continue scanning.
(Print style name) is not a valid print style.
Unable to get video or frame grab hardware error.
Unable to open the Clipboard.
Undo will not work on some operations.
Write failed on cache file directory (path name).



Are you sure you want to delete (filename)?

This is to confirm your decision to delete the selected file.

Click Ok to delete the file, click Cancel if you don't want to delete the file.



Can't initialize the compressed image

Picture Publisher discovered an improperly compressed TIFF image.

Open the file in a compatible program and save it in one of the following formats: BMP, TIF, TGA, PCX, or 
GIF. Use LZW Compression, if available.



Can't initialize the scanner: (scanner driver name)

Picture Publisher cannot communicate with the scanner.

Make sure the scanner is turned on, has the proper cables, and is in a ready state. Make sure that the 
correct scanner driver has been selected in the Setup Scanner dialog box. Confirm the proper setting for 
the I/O address. If necessary, reinstall the scanner driver from the original Picture Publisher installation 
disks.



Can't open the scanner driver: (scanner driver name)

Picture Publisher cannot initialize the scanner hardware.

Make sure that the correct driver has been selected in the Setup Scanner dialog box. Identify proper I/O 
address for hardware. Reinstall the scanner driver, if necessary.



Cannot write file (file name). The new file requires (file size) bytes of unused disk 
space. Your disk has only (disk space) bytes of unused space.

There is not enough space on the current disk drive to work with the file.

Locate a hard drive with sufficient memory space and change the Cache Path in the Preferences dialog 
box to read the new Path name, then click Ok.



Could not open the Image Cache file in directory (path name)

Either the filename is not a valid DOS file name, you are trying to write over a protected DOS file, or the 
directory you specified does not exist.

Check the filename being entered and, if protected, unprotect it with the Windows File Manager.



Error writing to the Clipboard

File size is too large to be managed by the Windows Clipboard.

Copy the file to a Picture Publisher Clipboard using the Copy To command in the Edit menu, or create a 
smaller file and try again to copy it to the Windows Clipboard.



Extended name (extended filename) already exists. Do you want to overwrite it?

The name chosen for your file already exists in the file PPNAMES.INI.

Select a different name for your file, or click Ok to overwrite the existing file.



(Image name) is a CCITT or Packbits TIFF Image; cannot be opened.

Picture Publisher does not recognize this TIFF file format.

Open the TIFF file in a program that recognizes this type of file and convert it to an uncompressed TIFF 
file.



Input points must be in ascending order.

Input values are incorrectly ordered when modifying a color map or a calibration map. Values must be 
input in the 11 data boxes from 0 to 100.

Determine which data box contains the incorrectly placed value and enter a number that is in ascending 
order.



(Map name) is not a valid map file.

The map file is not recognized by Picture Publisher.

Confirm the proper file type for your map file. Correct the extension of the file name if it has been 
incorrectly identified. If an updated file type is necessary, load it using the installation program.



(Mask name) is not a valid mask file.

The mask file is not recognized by Picture Publisher.

Confirm the proper file type for your mask file. Correct the extension of the file name if it has been 
incorrectly identified. Recreate the mask file and save it using the Save Mask command in the Mask 
menu.



Not enough memory to continue scanning.

Scanner input requires more memory than available on the current disk drive.

Locate a disk drive that contains enough room for the memory input of the scanner. Change the Cache 
Path in the Preferences dialog box, then click Ok.

Not enough space on the current disk drive to manipulate complex edits.

Choose the Manual Apply command in the Edit menu or the Save or Save As command in the File menu 
to free additional memory. Or locate a disk drive with sufficient memory space and change the Cache 
Path in the Preferences dialog box, then click Ok.



(Print style name) is not a valid print style.

The Print Style file is not recognized by Picture Publisher.

Confirm the proper file type for your Print Style file. Correct the extension of the file name if it has been 
incorrectly identified. Redefine a print style in the Print Style dialog box, then click Save to save the Print 
Style.



Unable to get video or frame grab hardware error.

Picture Publisher cannot initialize the hardware configuration.

Make sure the hardware is turned on and operating properly. Select the correct device driver in the Setup 
Grabber dialog box. Identify the proper I/O address for hardware. Reinstall the device driver, if necessary.



Unable to open the Clipboard

Picture Publisher does not recognize the file type contained in the Windows Clipboard.

Copy a bitmap image to the Clipboard and paste it into Picture Publisher.



Undo will not work on some operations.

There is not enough space on the current disk drive to open an undo buffer.

Choose the Manual Apply command in the Edit menu or the Save or Save As command in the File menu 
to free additional memory. Or locate a disk drive with sufficient memory space and change the Cache 
Path in the Preferences dialog box, then click Ok.



Write failed on cache file directory (path name)

You have run out of disk space on the specified drive.

Close any images that are not essential to immediate editing, or locate a disk drive with sufficient memory 
space and change the Cache Path in the Preferences dialog box, then click Ok.



File Menu Commands

The File menu commands let you create, open, save, close, recall, and print image files. Additional 
commands let you acquire digital images using a scanner or video grabber; change the setup of your 
printer, scanner, or video grabber; and close Picture Publisher.

New Creates a new image.
Open Opens a previously saved file.
Scan Scans or digitizes an image using a scanner.
Acquire Lets you open the TWAIN interface.
Recall Lists the last nine files opened or saved.
Save Saves the file on which you are working, using the current filename.
Save As Assigns a name to a file or makes a copy of the file under a new name.
Revert To Saved Reverts to the last saved version of the file.
Close Closes the current image window.
Print Prints your image to the current printer.
Setup Selects a printer and chooses print styles.
Macro Lets you record and play back macros.
Run Lets you choose other Micrografx applications to run (launch).
Exit Closes Picture Publisher.



New Command

The New command (Ctrl+N) in the File menu opens a dialog box that lets you create a new, blank image.

Related Topics
Dialog Box information
Procedure information
Saving a Drawing



New Image Dialog Box

Image Type List Box
Click the down arrow in the list box to display these options for creating a new image: Line Art, Grayscale, 
RGB Color, and CMYK Color.

Width Area
The Width area lets you set the width of the new image. The default setting is 4 inches. Increasing the 
width increases the amount of memory Picture Publisher requires to create the image.

Units List Box
Click the down arrow to display the available units, including inches, millimeters, picas, centimeters, and 
pixels.

Height Area
The Height area lets you set the height of the new image. The default setting is 5 inches. Increasing the 
height increases the amount of memory Picture Publisher requires to create the image.

Resolution Area
The Resolution area lets you set the resolution (pixels per inch) of the new image. The default setting is 
100 pixels per inch. Increasing the resolution increases the amount of memory Picture Publisher requires 
to create the image.

Image Size Area
Picture Publisher displays the amount of memory required to create the image in the bottom right corner 
of the dialog box.

Related Topics
Command information
Procedure information



Creating a New Image Window

Choose the New command in the File menu to create a new image window.

To create a new image window:

1. Open the File menu and choose New, or press Ctrl+N. The New Image dialog box opens.
2. Choose the image type you want.
3. Type the width, height, and resolution for the new image.
4. Click Create, or press Enter. Picture Publisher creates a new image window.

Related Topics
Command information
Dialog Box information



Open Command

To edit, view, or print an image in Picture Publisher, you first open (or load) the file using the Open 
command (Ctrl+O) in the File menu.

The ImageBrowser dialog box opens when you choose the Open command. 

Related Topics
ImageBrowser dialog box
Opening an image 



Opening an Image

To open an image:

1. Open the File menu and choose Open, or press Ctrl+O. The ImageBrowser dialog box opens.
2. Click the down arrow to the right of the File Types list box. The list box opens and a list of 

available file formats appears.
3. Point to the file format you want to use and click the left mouse button to select it.
4. Click the down arrow to the right of the Drives list box. The Drives list box opens.
5. Double click the drive you want to use and click the left mouse button to select it.
6. Choose the directory containing the file that you want to open. The filename appears in the area 

below the File Name text box.
7. Double click the file you want to open, or highlight the file and click Open. The image appears in 

an image window.

Related Topics
Command information
Dialog Box information
Recalling a file
Photo CD format



Photo CD Format

With Picture Publisher, you can read Kodak's Photo CD format for access to thousands of images stored 
on compact discs.

Photo CD images are images formatted in the Photo CD format and stored on compact discs. These 
images are accessed with a compact disc player connected to your computer. To Picture Publisher, the 
compact disc player appears to be another drive. The images on a Photo CD can be opened like any 
other image file format.

Related Topics
Photo CD Options dialog box
Opening an Image
Saving an Image



Photo CD Options Dialog Box

Data Type List Box
Click the down arrow to choose how you want to open the Photo CD file--in color or grayscale.

Resolution List Box
Click the down arrow to choose the resolution for opening the Photo CD file.

Image Size Area
This area displays the size of the Photo CD image.

Cropped Size Area
This area displays the size of the image at the resolution you have chosen. If you used the Preview area 
to select a portion of the image to open, this area displays the size of the cropped image.

Preview Button
Click the Preview button to view how Picture Publisher will display the file at the resolution you have 
chosen. You can drag the mouse to select a portion of the image that you want to open. If you do not 
select a portion of the image, Picture Publisher opens the entire image.

Related Topics
Photo CD format



Scan Command

The Scan command (F3) lets you scan images, which is the most common method used to acquire 
images. A scanner copies a photograph, slide, or transparency into digital format, which is ready for 
editing.

Make sure your scanner is turned on and is operating properly. Also be sure that the necessary Picture 
Publisher scanner driver is installed with the Scanner command in the File menu.

Related Topics
Dialog Box information
Procedure information



Scan Dialog Box

The Scan dialog box opens when you choose the Scan command in the File menu. Use the scanner 
options to improve the quality of a scanned image.

Note: Options not supported by certain scanners are disabled (grayed).

Speed Option
The Speed option sets the speed at which the image will be scanned. Not all scanners have variable 
speeds. If the scanner has this option, click the desired speed. A setting of five is the fastest scanning 
speed. A setting of one is the slowest scanning speed, and usually offers more accurate digital images.

Use a Calibration Map Option
A calibration map is a curve used to adjust the tonal range of the image to compensate for any 
inconsistencies in the scanner. To use a calibration map, click the Use a Calibration Map option. The 
default calibration map is displayed automatically. To change to another map, click the down arrow to 
display a list of other available calibration maps. Click the map you want to use. To scan without a 
calibration map, deselect the Use a Calibration Map option.

Prescan Button
Unless the exact dimensions and location of the image on the scanner bed are known, you should 
prescan the image by clicking the Prescan button. Prescan produces a low-resolution, quick scan of the 
entire scanning bed. The scanner scans the entire image area and then displays the preview image in the 
Scan dialog box image area. Set the image type prior to prescanning to get a different type of prescan 
display. A crop box lets you define what portion of the image you want to scan.

Adjust the crop box by moving it or by moving each of the four sides to the edges of the image. Set width 
(or scale), height, and resolution to the desired settings, then click Scan to begin high-resolution 
scanning. After the scanner has passed over the image, the image is ready to be saved or edited.

Check Button
The Check button lets you check an image for black-and-white values and levels of gray.

Image Type Options
There are three possible image types: Line Art, Grayscale, and Color. The Color option is not available for 
black-and-white scanners. To choose an image type, click the option you want.

Invert Option
The Invert option lets you choose to have the image scanned as a negative.

Mirror Option
The Mirror option lets you choose to have the image scanned as a mirror image, flipped from left to right.

DMA Option
The DMA (Direct Memory Access) option reduces the amount of time required to scan an image. This 
option is available on some scanners.

Note: Because conflicts can occur between DMA and other devices, such as monitors, I/O cards, network 
cards, and printers, make sure you thoroughly test your scanner before using this option.

Sizing Area
Sizing works interactively with the crop box. When either the width or height dimension is changed, the 
scale adjusts accordingly. Changing the scale percentage also changes the width and height. Once set, 
the aspect ratio of the crop box maintains itself with any scaling.

Contrast and Brightness



Some scanners allow contrast and brightness adjustments to be made as the image is scanned. To 
increase or decrease contrast and brightness in the scanner, set values in the appropriate text boxes. A 
value of 0% is normal for both contrast and brightness, with positive values adding contrast and 
brightness, and negative values subtracting contrast and brightness.

Note: If the scanner has been calibrated, this adjustment should not be necessary except in the case of 
an unusually dark or light photograph. When the scanner and printer are calibrated, you should not have 
to adjust the contrast and brightness.

Scan Button
Click the Scan button to scan the image.

Lock Scan Size Option
Choose this option to set the size of the scanned image.

Options Button
The Scan dialog box may contain an Options button, which opens a dialog box specific to the selected 
scanner. Please refer to your scanner documentation for information on this dialog box.

Related Topics
Command information
Procedure information
Calibrate a scanner



Scanning Images

To scan an image:

1. Open the File menu and choose Scan.
2. Choose the image type, either Line Art, Grayscale, or Color.

Note: Prescanning may be slow in color mode with certain scanners.

3. Click Prescan. The image displays in the scanning bed window.
4. Crop the image by moving and sizing the crop box.

Note: You move and size the crop box by corner and side handles. If you want a new crop box, press and 
hold Shift and drag in the scanning bed window.

5. Set the scanner speed, if available. The speed settings range from 1 to 5. Five is the fastest, and 
1 is the slowest. The slower the speed, the more accurate the scanned image.

6. Adjust the scale field of the image by typing a value in the Scale area to create a larger or smaller 
image than the scanned image.

7. Set the resolution of the image by typing a value in the Res area. Use a minimum resolution of 
1.5 times the maximum screen ruling that you are using to print the image. If printing to a 300 dpi 
laser printer, use a resolution setting of 80 pixels per inch (the standard 53-line screen times 1.5 
approximately equals 80).

8. Click Scan. The image appears in a new image window.

Related Topics
Command information
Dialog Box information



Acquire Command

The Acquire command lets you open the TWAIN interface. Picture Publisher supports the new TWAIN 
driver interface to give you access to more scanners, video grabbers, and other data acquisition devices 
without requiring special drivers.

TWAIN is a protocol developed by leading imaging hardware and software companies to make it easier to 
integrate input peripherals and applications. TWAIN eliminates the need to have hardware-specific 
drivers.

The Acquire command requires a compatible hand scanner or video frame grabber with a video camera 
or videocassette recorder attached to the interface card.

Related Topics
Dialog Box information
Procedure information



Acquire Dialog Box

The options in the Acquire dialog box will vary according to the grabber driver and hardware installed.

Related Topics
Command information
Procedure information



Acquiring an Image

To use the TWAIN driver interface:

· Open the File menu and choose Acquire. A dialog box opens; each Acquire dialog box will be 
different, depending on the device being used.

Related Topics
Dialog Box information
Command information



Save Command

The Save command (Ctrl+S) lets you save the currently active image using the current filename with the 
same file type and image settings.

If the file has never been saved and you choose the Save command, the ImageBrowser dialog box 
opens.

When you choose the Save command, the file is saved where the file was opened or in the directory you 
specified in the ImageBrowser dialog box.

Related Topics
Procedure information



Saving an Existing File

Press Ctrl+S to choose the Save command in the File menu and save an existing file.

Related Topics
Command information



Save As Command

The Save As command (Ctrl+A) lets you assign a new name to a file or make a copy of an existing file by 
giving it a new name. You can also change the file format or image type.

Related Topics
Dialog Box information
Procedure information
Save command



DCS Options Dialog Box

The DCS Options dialog box opens when you save a file as a DCS file, and lets you choose options for 
color separations. A Desktop Color Separations (DCS) file is a variation of the popular encapsulated file 
format (EPS).

Saving a file as DCS lets you create color separations of an image using Picture Publisher. When you 
save a file as DCS, Picture Publisher creates five files: the main EPS file, which contains the TIFF 
preview (optional) and filenames for the other files; and the four files containing the color EPS separations 
(cyan, magenta, yellow, and black). (You can place the main EPS into another application.)

Preview TIFF area
The Preview TIFF area lets you choose how you want to preview the TIFF image of the DCS file: None, 
1-Bit Scattered, or 8-Bit Grayscale. Choose the option that is supported by the application into which you 
are importing the DCS file.

Include Composite option
The Include Composite option turns on and off the RGB composite that is stored in the main file. If you do 
not choose this option, the file size is much smaller and Picture Publisher works faster than if you choose 
the option. Choose this option if the application into which you are importing the DCS file supports 
composites.

Export Clipping Path From Mask Option
Choose this option to create clipping paths for use in applications that accept placeable EPS or DCS files. 
A clipping path allows a bitmap to be clipped so that it is not just a square image. Clipping allows only the 
desired portions to be displayed or printed.

Minimum Line Length Area
This area determines the minimum length of a line segment along a path. A high Minimum Line Length 
causes the path to become blocky, but it does provide a simpler path for the printer to print. 

Tolerance Area
This area determines the amount, in pixels, that the line segment can deviate from the original path. The 
higher the Tolerance, the less accurate the path becomes.

Note: If you cannot print a DCS file, it may be because your printer does not have enough memory, or the 
path is too complex. In the case of a complex path, increase the values for Minimum Line Length and 
Tolerance to create a less complex path. 

Using Print Style Area
This area displays the name of the current print style.

Always Prompt For Options on Save Option
Choose this option to always have the options dialog box open when saving to this format.

Related Topics
Creating a clipping path 
Saving a file



JPEG Options Dialog Box

When you save an image file as a JPEG file, the JPEG Options dialog box opens to give you four JPEG 
methods to save your file: Less Compression, Normal Compression, More Compression, and Custom 
Compression. 

Information is lost when you save files in the JPEG format; the more compression you use, the more 
information that is lost. The JPEG algorithm tries to throw out information that will not be noticed. The 
amount of information you lose depends on the image. Some files may not show any deterioration in 
quality even when you choose the More Compression option. Other files may show an unacceptable 
amount of deterioration when you use the higher levels of compression.

Custom Compression option
The Custom Compression option gives you more flexibility to compress your images. When you choose 
the Custom Compression option, the bottom half of the JPEG Options dialog box is active. 

The Subsampling area lets you choose from three options: Low, Medium, and High Resolution. The 
higher the resolution, the less the compression and the higher the image quality. The lower the resolution, 
the greater the compression and the lower the image quality. 

The Luminance Compression area refers to the non-color component of the image. The Luminance range 
can be any number from 0 to 100; the higher the number, the greater the compression and the lower the 
image quality. 

The Chrominance Compression area refers to the color component of the image. The Chrominance range 
can be any number from 0 to 100; the higher the number, the greater the compression and the lower the 
image quality.

Related Topics
Saving an Image in JPEG format



Saving an Image Using JPEG

To save an image using JPEG:

1. Open the File menu and choose Save As. The Save Image File dialog box opens. (The 
ImageBrowser Save dialog box opens if the View Thumbnails option is selected.)

2. Click the down arrow to the right of the File Types list box. The list box opens and a list of 
available file formats appears.

3. Point to the JPEG file format and click the left mouse button to select it. Any JPEG files in the 
current directory appear.

4. Type a new filename for the image in the File Name text box.
5. Click the down arrow to the right of the Drives list box. A list box opens.
6. Point to the drive you want to save to and click the left mouse button to select it.
7. Double click the directory in the Directories list box to which you want to save your file.
8. Click the down arrow to the right of the Image Type list box. The list box opens.
9. Point to the image type you want and click the left mouse button to select it.
10. Click Save. A dialog box opens.
11. Click the quality setting you want for your image. The higher the quality setting you choose, the 

slower the compression routine and the less image quality you lose.
12. Click OK. The file is saved in the JPEG format.



Saving a File

To save a new or existing file:

1. Open the File menu and choose Save As. The ImageBrowser dialog box opens.
2. Type a new filename for the image in the File Name text box.
3. Click the down arrow to the right of the Drives list box. The list box opens.
4. Point to the drive and click the left mouse button to select it.
5. Click the down arrow to the right of the File Types list box. The list box opens and a list of 

available file formats appears.
6. Point to the file format you want to use and click the left mouse button to select it.
7. In the Directories list box, double click the directory where you want to save the file.
8. Click the down arrow to the right of the Image Type list box. The list box opens.
9. Point to the image type you want and click the left mouse button to select it.
10. Click Save. The file is saved to the specified drive and directory.

When you type an existing filename, the message "Replace existing file (filename)?" appears. Picture 
Publisher defaults to Yes. You can perform one of the following responses, depending on what you want 
to accomplish.

· Press N (for No) to assign another name to the current image. Type a different name in the File 
Name text box and press Enter.

· Press Y (for Yes) to replace the existing image with the current image.

Note: Pressing a character key when a filename is highlighted in the text box makes the name disappear. 
To edit the filename, press the Right Arrow to remove the highlight. Then press the Right or Left Arrow 
to move the text cursor. To delete characters to the left of the text cursor, press Backspace.

Related Topics
Dialog Box information
Command information



Revert To Saved Command

The Revert To Saved command restores the image to the most recently saved version, undoing all 
changes made since you last saved the file.

When you choose the Revert To Saved command, Picture Publisher asks if you are sure you want to 
ignore all changes before reverting to the previous version. Click OK to revert to the previously saved 
version. Click Cancel to return to the current image.

Related Topics
Procedure information



Reverting to a Previous Version

To revert to the most recently saved version:

1. Open the File menu and choose Revert To Saved.
2. Click OK. The most recently saved version opens.

Related Topics
Command information



Close Command

The Close command closes the active image window.

Related Topics
Procedure information



Closing an Image Window

Choose the Close command in the File menu to close the active image window.

To close the active image window:

· Open the File menu and choose Close.

If the image you are working with has been edited, and you did not save it before choosing the Close 
command, Picture Publisher requests that you select one of three choices: Yes, No, or Cancel.

· Yes saves changes to your image before closing the image window.
· No does not save changes to your image and closes the image window.
· Cancel cancels the Close command and returns you to the current image.

Related Topics
Command information



Recall Command

The Recall command in the File menu opens a submenu containing the last nine files you opened or 
saved in Picture Publisher. This command lets you quickly access the most recently used files.

If a file is deleted or is on a drive that is not available, it may still appear in the submenu. When you 
choose one of these files, Picture Publisher displays a message stating that it cannot find the file and 
removes it from the list.

Related Topics
Procedure information



Recalling a File

Choose the Recall command in the File menu to open an image that was previously opened or saved.

To recall a file:

1. Open the File menu and choose Recall. The Recall submenu opens, containing nine previously 
opened or saved files.

2. Click the file you want to recall.

Related Topics
Command information



Print Command

The Print command (Ctrl+P) in the File menu lets you send an image to the selected printer.

Related Topics
Dialog Box information
Procedure information



Print Dialog Box

The Print dialog box contains options to visually, or numerically, place and size the image to be printed. 
You can also change print styles to make adjustments to your printer for optimal results.

Page Setup Area
Choose Visual or Numeric.

Choosing Visual lets you view how the positioning of the image when it is printed. You can move the 
image to change its placement on the printed page.

Choosing Numeric lets you set the width, height, size of the image, and positioning of the image when 
printed. When you choose Numeric, the area below the Numeric option allows the following choices.

Width and Height Areas
The Width and Height areas show the size of the image on the printed page. These values are computed 
automatically from the aspect ratio of the image. The Width and Height areas default to the actual image 
size.

You can change the values in the Width and Height areas. Changing either dimension automatically 
changes the other, unless the Allow Size Distortions option is selected. When you choose this option, the 
width and height can be adjusted independently.

Note: Changing the Width and Height areas does not change the size of the image on the disk or in 
memory. Only the printed version of the image is affected.

WScale and HScale Areas
The WScale and HScale areas show the percent change in the width and height. They are identical if the 
aspect ratio is maintained. If the Allow Size Distortions option is selected, the horizontal and vertical 
dimensions can be scaled independently.

Note: Changing the WScale and HScale areas does not change the size of the image on the disk or in 
memory. Only the printed version is affected.

Center On Page Option
The Center On Page option prints the image on the center of the page. When you deselect this option, 
you can then specify where to position the image relative to the top and left margins.

Allow Size Distortions Option
The Allow Size Distortions option lets you change the Width and Height values independent of each other. 
Use this option to stretch an image when it prints.

Type of Output List Box
The Type of Output list box lets you choose how you want to output an image. Click the down arrow to the 
right of the Type of Output list box and choose the type of output you want.

ScatterPrint Option
ScatterPrint is a special dithered, image-printing technique used to produce high-quality, high-detail 
images on low-resolution printers. Unlike a standard halftone, no screen ruling is required for ScatterPrint. 
Choosing the ScatterPrint option ignores the Screen Ruling option for your printer. See your printer 
documentation for more information on screen ruling.

Printer Selected Area
The Selected Device area displays the currently selected output device.

Print Style Selected Area



The Print Style Selected area displays the currently selected print style.

Print Button
Click Print to send the image to your current printer. A dialog box opens, specifying the current printer 
driver and printer port.

Cancel Button
Click Cancel to close the Print dialog box without printing the image.

Setup Button
The Setup button opens the Setup Printer dialog box.

Test Button
Click Test to print a test page of the image.

Reset Button
Click Reset to reset to the values before changes were made.

Related Topics
Command information
Procedure information



Printing an Image

To print an image:

1. Open the File menu and choose Print, or press Ctrl+P. The Print dialog box opens.
2. Choose the print options and image size that you want.
3. Click Print.

Related Topics
Command information
Dialog Box information



Setup Command

The Setup command opens a submenu containing the following commands:

Printer 
Scanner 
Monitor 
Calibration 



Printer Command

Use the Printer command to set up a printer and choose print styles.

Related Topics
Dialog Box information 
Procedure information 



Setup Printer Dialog Box

Select Print Style Area
The Select Print Style area contains the predefined print styles that are supplied with Picture Publisher, as 
well as any that you have set up and saved yourself. Print styles are collections of default printer settings 
that have been optimized for a variety of output needs. You can define print styles for your own needs and 
add them to the list.

File Options Button
The File Options button opens a submenu containing these commands for print styles: Add, Delete, and 
Rename.

Select Print Device Area
The Select Print Device area lists the currently installed Windows printer drivers. Printer drivers can be 
added or deleted through the Windows Control Panel as with any other application. Any installed printer 
driver can be activated and used by Picture Publisher.

Setup Print Style Button
Click the Setup Print Style button to open the Setup Print Style dialog box.

Setup Print Device Button
Click the Setup Print Device button to open the currently selected printer dialog box. Choose printer 
options and click OK.

Trim Marks Option
Choose this option to automatically place trim marks (crop marks) at the corners of the image. Trim marks 
indicate where the paper should be cut by the print shop to produce the correct page size. The trim marks 
appear as four sets of 1/2-inch horizontal and vertical lines.

Registration Marks Option
Registration marks align the separations during printing. Picture Publisher uses the industry-standard 
circle and crosshairs. The marks appear outside the printed image on the four sides of each separation or 
composite print.

Separation Labels Option
Choose this option to identify the separations and verify the printer colors on a composite. Each label 
appears parallel to the longest edge of the page, at a unique location on the page so that it does not 
overprint the others. This option also prints the print style options on the top-left corner of each page. This 
is useful for determining the controls that were used to create an image when comparing it with other 
images or examining the output for quality improvement.

Step Scale Option
This option adds a set of color bars to help monitor four-color printing quality. The scales appear on each 
separation as halftones at the selected line screen ruling. They print on the right of the black plate and on 
the left of the cyan, magenta, and yellow plates. As a result, the CMY colors overprint to produce grays. 
Print shops use the grayscale in monitoring values for gray color removal and black color replacement. 
The step scale also provides a direct comparison of CMY colors to evaluate dot-for-dot values, screen 
angles, moire, and dot gain.

Printer Type List Box
This list box lets you choose a Monochrome, CMYK or RGB printer. Use Monochrome to print on a single-
color printer. Choose CMYK or RGB to print on color printers.

Negative Option
This option lets you produce film on an imagesetter for platemaking.



Mirror for Emulsion Down Option
Like negative images, most image work is done "right reading," and emulsion side up or down is specified 
as part of the imagesetting process when outputting to film. In most cases, the Mirror command in the 
Image menu is used to flip an image. Choosing the Mirror for Emulsion Down option toggles the mirror 
image to provide emulsion up or down control when sending mixed images to the imagesetter.

Send Binary PostScript Option
This option lets you send the image to the printer as PostScript data in binary format.

Use Printer Screening Option
Choose this option when using non-PostScript printers so that the image goes directly to the printer driver 
and bypasses any print style effects made by Picture Publisher. Non-PostScript printers such as ink jet, 
thermal wax, and dye sub may have better output when this option is on. Calibration will continue to be 
applied if it is selected within the specific print style.

Related Topics
Command information 
Procedure information 



Setup Print Style Dialog Box

Halftone Style List Box
You can choose None, Color PostScript, Monochrome PostScript, or Typesetter.

File Options Button
The File Options button opens a submenu containing these commands for halftone styles: Edit, Add, 
Delete, and Rename.

Print Calibration Style List Box
You can choose None, ScatterPrint, Typesetter, Ink Jet/Paint Jet, Laser Jet, Color PostScript, 
Monochrome PostScript, or Ink Jet/Desk Jet.

File Options Button
The File Options button opens a submenu containing these commands for print calibration styles: Create, 
Edit, Add, Delete, and Rename.

Color Separtion Style List Box
You can choose None, Calibrate - Color PostScript, Calibrate - Typesetter, Color PostScript, Monochrome 
PostScript, Typesetter, Ink Jet/Desk Jet, Ink Jet/Paint Jet, or Calibrate - Mono PostScript.

File Options Button
The File Options button opens a submenu containing these commands for color separation styles: Edit, 
Add, Delete, and Rename.



Using the Printer Command

To use the Printer command:

1. Open the File menu and choose Setup. The Setup submenu opens.
2. Choose Printer. The Setup Printer dialog box opens.
3. Choose the print style you want to use.
4. Choose the printer device you want to use.
5. Set other printing options as necessary.
6. Click OK.

Related Topics
Command information 
Dialog Box information 



Scanner Command

The Scanner command lets you choose a scanner driver and calibration style.

Related Topics
Dialog Box information
Procedure information



Setup Scanner Dialog Box

Scanner Driver Name List Box
The Scanner Driver Name list box displays the available scanner drivers. Click the down arrow to the right 
of the list box, then select a scanner driver name.

File Options Button
The File Options button opens a submenu containing these commands for scanner drivers: Add, Delete, 
and Rename.

Scanner Address Area
Check your scanner documentation for the proper input/output address and adjust it accordingly.

Scanner Calibration Name List Box
The Scanner Calibration Name list box displays the available scanner calibration styles. Click the down 
arrow to the right of the list box, then select a scanner calibration style.

File Options Button
The File Options button opens a submenu containing these commands for print calibration styles: Create, 
Edit, Add, Delete, and Rename.

TWAIN Button
Click this button to open the Select Source dialog box.

Related Topics
Command information
Procedure information



Setting Up Your Scanner

To set up your scanner:

1. Open the File menu and choose Setup. The Setup submenu opens.
2. Choose Scanner. The Setup Scanner dialog box opens.
3. Choose the appropriate driver for your scanner.
4. Set the scanner address.
5. Click OK.

Related Topics
Command information
Dialog Box information



Select Source Dialog Box

 This dialog box is for selecting TWAIN device drivers designed for a specific input device and any 
application with a TWAIN interface. Dialog options include a source list box for choosing the input device 
you want to use. You must select a TWAIN input driver before choosing the Acquire command in the File 
menu.



Monitor Command

The Monitor command (Ctrl+G) lets you compensate for how your monitor displays images to provide 
you with accurate image editing. There are different factors that affect accurate viewing of an image file. 
Different monitors, various lighting conditions in your work area, and varying human perceptions of color 
affect the accuracy of the image display.

With the Monitor command, you can adjust the gamma correction curve for both monochrome and RGB 
color screens. If you are working on a black-and-white screen, your gamma correction edits should be 
concentrated on only the bottom gamma patch. If you are working with a color monitor, you can use all 
four tables in the dialog box.

You should perform the two steps below before using the Monitor command.

The first step to adjusting your gamma curve for your monitor is to establish a norm, or constant 
environment in which you will be working. This includes ambient room light and any color, contrast, and 
brightness controls on your monitor. A change in any one of these could drastically affect how you would 
adjust your gamma curve.

The second step is to make sure that your monitor has been on for at least one hour.

Related Topics
Dialog Box information
Procedure information



Monitor Gamma Dialog Box

The Monitor Gamma dialog box opens when you choose the Monitor Gamma command in the Map 
menu, and it displays three large color patches. Use the slider under each color patch to adjust the 
gamma curve.

Lock Button
Click the Lock button to lock the sliders together so that when you move one you move them all.

Unlock Button
Click the Unlock button to unlock all sliders.

Related Topics
Command information
Procedure information



Adjusting Monitor Gamma

To adjust monitor gamma:

1. Open the image you want to adjust.
2. Open the File menu and choose Setup. The Setup submenu opens.
3. Choose Monitor. The Monitor Gamma dialog box opens.
4. Drag each slider under the three large color patches until the small patch inside each large color 

patch is the same color as its surrounding area.

Note: If the small patch is not visible inside of the large color patch, it is already in adjustment.

5. Click OK to set up the new monitor gamma compensation.

Your new gamma curve is automatically saved in the PP.INI file when you close Picture Publisher.

Note: You can turn off the monitor gamma correction by setting all three values to 1 in the Monitor 
Gamma dialog box.

Related Topics
Command information
Dialog Box information



Calibration Command

The Calibration command opens a submenu containing these commands:

For Scanning 
For Printing 



For Scanning Command

Choose the For Scanning command to open the Calibrate Scanner dialog box.



For Printing Command

Choose the For Printing command to open the Calibrate Printer dialog box.



Macro Command

The Macro command opens a submenu containing the following commands:

Play 
Play Batch 
Record 
Stop 



Play Command

The Play command lets you play back a pre-recorded session.

Related Topics
Dialog Box information 
Procedure information 



Play Macro Dialog Box

Select Macro Name Text Box
Type a name for the macro you want to open, or click the down arrow and choose a macro.

File Options Button
The File Options button opens a submenu containing these commands for macros: Add, Delete, and 
Rename.

Repeat Area
Set the amount of times you want the macro to repeat in this area.

Related Topics
Command information
Procedure information 



Playing a Pre-Recorded Macro

To play a macro:

1. Open the File menu and choose Macro. The Macro submenu opens.
2. Choose Play. The Repeat Macro dialog box opens.
3. Click the down arrow to display the available macros, then highlight one.
4. Click Play to start the Macro.

Related Topics
Command information
Dialog Box information 



Play Batch Command

The Play Batch command lets you run a macro on more than one file. For example, if you wanted to 
change the contrast on several files, you could create a macro changing the contrast, then run it on the 
selected files. 

When you choose the Play Batch command, the Play Macro dialog box opens. Choose the macro you 
want to run, then choose Play. The ImageBrowser dialog box opens. Choose the files on which you want 
to run the macro.

Related Topics
Dialog Box information 
Procedure information 



Play Batch Macro Dialog Box

Select Macro Name Text Box
Type a name for the macro you want to open, or click the down arrow and choose a macro.

File Options Button
The File Options button opens a submenu containing these commands for macros: Add, Delete, and 
Rename.

Related Topics
Command information
Procedure information 



Playing a Macro For a Group of Files

To play a macro for a group of files:

1. Open the File menu and choose Macro. The Macro submenu opens.
2. Choose Play. The Play Macro dialog box opens.
3. Click the down arrow to display the available macros, then highlight one.
4. Click Play. The ImageBrowser dialog box opens.
5. Choose the files you want to process and click Open to start running the macro on all selected 

files.

Related Topics
Command information
Dialog Box information 



Record Command

The Record command lets you perform actions in Picture Publisher (such as opening files), then save 
them in a macro file.

Related Topics
Dialog Box information 
Procedure information 



Record Macro Dialog Box

Enter Macro Name Text Box
Type a name for the macro you want to record, or click the down arrow and choose a macro.

File Options Button
The File Options button opens a submenu containing these commands for macros: Add, Delete, and 
Rename.

Related Topics
Command information 
Procedure information 



Recording a Macro

To record a macro:

1. Open the File menu and choose Macro. The Macro submenu opens.
2. Choose Record. The Record Macro dialog box opens.
3. Type the name of the macro you want to create and click Record to start recording the macro.
4. Complete all of the tasks you want to include in the macro. If you make a mistake, use the Undo 

command in the Edit menu to restore the image to its previous condition. When you run the 
macro on other files, it will make and undo the mistake, just like you recorded it. If you do this a 
lot, you probably want to record the macro from the beginning because making and undoing a lot 
of errors can cause the macro to take a longer amount of time to complete a series of tasks.

5. Open the File menu and choose Macro. The Macro submenu opens.
6. Choose Stop to end recording the macro.

Related Topics
Command information 
Dialog Box information 



Stop Command

The Stop command stops recording the actions in Picture Publisher.



Run Command

The Run command lets you quickly start a Micrografx program from another Micrografx program. When 
you choose the Run command, a submenu opens, displaying the applications you can open.

To open one of the applications:

1. Open the File menu and choose Run. The Run submenu opens.
2. Choose the application that you want to open.



Exit Command

Choose the Exit command (Ctrl+X) in the File menu to close Picture Publisher when you are finished 
working.

If you have made changes to your work, Picture Publisher prompts you to save the file before the window 
closes.

Related Topics
Procedure information



Closing Picture Publisher

Choose the Exit command in the File menu to close Picture Publisher.

To close Picture Publisher:

· Open the File menu and choose Exit.

If the file you are working with has changed, and you did not save it before choosing the Exit command, 
the Save Changes dialog box opens and requests that you select one of three choices: Yes, No, or 
Cancel.

· Yes saves the changes to theimage before closing Picture Publisher.
· No does not save changes to your image and closes Picture Publisher.
· Cancel cancels the Exit command and returns you to the current image.

Related Topics
Command information



Edit Menu Commands

The commands in the Edit menu undo operations and transfer data to and from the Clipboard. The Edit 
menu commands also let you specify paste options and program preferences.

Undo Reverses the last edit or change to an image.
Redo Restores the most recent edit that has been undone.
Manual Apply Manually applies changes to an image.
Auto Apply Automatically applies changes to an image when you are editing.
Cut Cuts the image area defined by a mask to the Clipboard.
Copy Copies the image area defined by a mask to the Clipboard.
Copy To Copies the image area defined by a mask to a file.
Paste Pastes the contents of the Windows Clipboard into the current image.
Paste From Pastes an image from a specific file.
Paste As New Image Pastes the Clipboard contents into a new image.
Delete Deletes the masked portion of an image from the window.
Preferences Lets you specify default settings.



Undo Command

The Undo command (Alt+Backspace) removes all changes made to an image since the last time 
changes were applied. In Auto Apply mode, changes are applied as you proceed to the next edit, so the 
Undo command removes only the last change. In Manual Apply mode, you control when changes are 
applied.

Related Topics
Procedure information



Reversing a Change

To undo a change:

· Open the Edit menu and choose Undo, or press Alt+Backspace. The image appears as it did 
before the last edit.

Related Topics
Command information



Redo Command

The Redo command replaces the Undo command in the Edit menu after the Undo command is selected. 
Redo restores the most recent edit that has been undone. You can toggle between Undo and Redo to see 
an image before and after the latest change.

Related Topics
Procedure information



Redoing Changes to an Image

To redo changes to an image:

· Open the Edit menu and choose Redo. The image appears as it did before you chose the Undo 
command.

Related Topics
Command information



Manual Apply Command

The Manual Apply command (Ctrl+A) is available only when the Manual Apply option is selected in the 
Preferences dialog box. This command lets you control when changes become a permanent part of the 
image. Once changes are applied, they cannot be removed with the Eraser tool or the Undo command.

Note: The changes are not applied to the permanent image file until you use the Save command.

Related Topics
Procedure information



Manually Applying Changes to an Image

To manually apply changes to an image:

· Open the Edit menu and choose Manual Apply, or press Ctrl+A.

Related Topics
Command information



Auto Apply Command

The Auto Apply command appears when the Auto Apply option is selected in the Preferences dialog box. 
Because your edits are automatically applied, the Auto Apply command is disabled (grayed) and appears 
as reference information only.

Related Topics
Manual Apply Command



Cut Command

The Cut command (Shift+Del) cuts an area of the image (defined by a mask) to the Windows Clipboard. 
The cut-out area appears as a white hole in the image. The contents of the Clipboard then can be pasted 
back into a Picture Publisher image or any other Windows application that accepts a bitmap format, such 
as a page layout or graphics presentation program.

The Clipboard retains the most recently cut or copied image. Each subsequent cut or copy from any 
Windows application replaces the contents of the Clipboard.

Related Topics
Procedure information



Cutting Images

To cut an area of an image to the Clipboard:

1. Mask the area you want to cut out of the image.
2. Open the Edit menu and choose Cut, or press Shift+Del. The masked area is cut to the 

Clipboard.

To remove an area of the image without overwriting the contents of the Windows Clipboard, choose the 
Delete command in the Edit menu.

Related Topics
Command information



Copy Command

The Copy command (Ctrl+Ins) sends a duplicate copy of the image area defined by a mask to the 
Windows Clipboard. The working image is unaffected when using the Copy command. The contents of 
the Clipboard can be pasted back into a Picture Publisher image or any other Windows application that 
accepts a bitmap format, such as a page layout or graphics presentation program.

The Clipboard retains the most recently cut or copied image. Each subsequent cut or copy from any 
Window application replaces the contents of the Clipboard.

Related Topics
Procedure information



Copying Images

To copy an area of an image to the Clipboard:

1. Mask the area you want to copy to the Clipboard.
2. Open the Edit menu and choose Copy, or press Ctrl+Ins. The masked area is copied to the 

Clipboard.

Related Topics
Command information



Copy To Command

The Copy To command is similar to the Copy command, except that the Copy To command copies the 
image area defined by a mask to a file instead of to the Clipboard. The Copy To command gives you the 
flexibility to copy to a named file, a new image, a texture, or a custom brush.

Related Topics
Dialog Box information
Procedure information



Copy To Dialog Box

When you choose the Copy To command, the Copy To dialog box opens.

Named Clipboard Option
The Named Clipboard option lets you save a masked area to a Clipboard file.

New Image Option
The New Image option lets you save a masked area to a new image window.

Texture Option
The Texture option lets you save a masked area to a texture file.

Custom Brush Option
The Custom Brush option lets you save a masked area to a custom brush file.

Clipboard Name Text Box
Enter a new filename in the Clipboard Name text box or select an existing clipbit file. 

File Options Button
You can use the File Options button to delete and rename files. 

Related Topics
Command information
Procedure information



Copying Masked Areas of an Image to a File

To copy a masked area to a file:

1. Mask the area you want to copy to a file.
2. Open the Edit menu and choose Copy To. The Copy To dialog box opens.
3. Click a file type. You can choose from Named Clipboard, New Image, Texture, or Custom Brush.
4. Type a filename in the Clipboard Name text box.
5. Click Copy To.

Note: If you choose the New Image option, you do not type a filename in the Clipboard Name text box. 
The mask is automatically copied to a new image window.

You can also delete or rename a file using the Copy To command.

To delete or rename a file:

1. Open the Edit menu and choose Copy To. The Copy To dialog box opens.
2. Click the down arrow to the left of the file icon. A list of files appears.
3. Choose the file you want to delete or rename.
4. Click the file icon. A submenu opens.
5. Choose Delete or Rename, as appropriate. Choosing the Delete command deletes the name as 

well as the DOS file from the Clipbit directory.

Related Topics
Command information
Dialog Box information



Clipboard Name Dialog Box

The Clipboard Name dialog box lets you rename a named clipboard.

Enter New Name Text Box
Type a name for the new file and click OK.



Texture Name Dialog Box

The Texture Name dialog box lets you rename a texture.

Enter New Name Text Box
Type a name for the new file and click OK.



Brush Name Dialog Box

The Brush Name dialog box lets you rename a custom brush.

Enter New Name Text Box
Type a name for the new file and click OK.



Paste Command

The Paste command (Shift+Ins) pastes the contents of the Windows Clipboard into the current image. 
When you choose the Paste command, the ribbon area displays options that you can use with the Mask 
Transform tool.

Related Topics
Procedure information



Pasting Images

The Paste command (Shift+Ins) in the Edit menu retrieves images from the Windows Clipboard that were 
cut or copied to the Clipboard.

To paste an image from the Clipboard:

· Open the Edit menu and choose Paste, or press Shift+Ins. The image appears in the image 
window with the Mask Transform tool active.

Related Topics
Command information



Using the Paste Options

While using the Mask Transform tool, you can use the ribbon area to size, scale, rotate, and skew the 
pasted image. You can also blend the edges and change the quality and transparency of the pasted 
image.

Transformation List Box
The Transformation list box contains the Scale, Skew, Perspective, and Distort options.

Choose the Scale option in the Transformation list box of the ribbon area to change the size of the mask. 
Drag a corner handle to enlarge or shrink the selection using its current aspect ratio. Drag an edge 
handle to move just the height to width. 

Choose the Skew option to rotate or skew the mask. Drag a corner handle or a top and bottom edge 
handle to skew the selection left or right. Drag an edge handle to skew the selection up or down.

Choose the Perspective option to add a three-dimensional appearance to the selection. Dragging a 
corner handle in one direction moves the opposite corner handle an equal distance in the opposite 
direction.

Choose the Distort option to stretch the selection as if it were a rubber sheet. Each corner handle 
operates independently of the others.

Rotation Buttons
The Rotation buttons let you choose a pivot point for rotation. 

Choose to rotate the selection flat, as if you are looking down on a spinning disk.

Choose to rotate the selection by pushing the top back and pulling the bottom forward, or vice versa, as if 
you are turning a barbeque spit. This rotation is actually from a 45 degree angle.

Choose to rotate the selection by pushing the left back and pulling the right forward, or visa-versa, as if 
you are turning a revolving door. This rotation is actually from a 45 degree angle.

Note: A rotation tool resides in the middle of the bounding box surrounding the selection. The rotation tool 
consists of a circle marking the pivot point, a square marking the rotation handle, and a line connecting 
the two. You rotate the selection by dragging the handle. Dragging the pivot point allows you to change 
the center of rotation. You can change the sensitivity of the rotation tool by dragging the handle closer to 
or further away from the pivot point. The tool becomes less sensitive as you drag the handle further away. 
This simply means you must drag the handle more to rotate the image.

Flip Buttons
Choose the Flip Horizontal button to mirror the paste horizontally; choose the Flip Vertical button to mirror 
the paste vertically. Choosing a button turns on mirroring; deselecting a button turns off mirroring.

Quality Area
Select the High check box in the Quality area of the ribbon to improve the quality of the pasted image. 
This is especially useful for rotated or skewed images. This option makes the image less jagged.

Most other programs discard pixels arithmetically, regardless of color value. With Picture Publisher, each 
pixel that remains is newly generated from the color values of the discarded neighboring pixels. Each of 
the pixels in the original image contributes to the pixels in the new image.

Mask Area
The Info check box in the Mask area of the ribbon merges an object with any masks on the image.



Transparency Slider
The Transparency slider lets you set the degree of transparency: The higher the transparency 
percentage, the more the underlying image shows through.

If the pasted image is set to 100% transparency, it is invisible. If it is set to 0% transparency, it is opaque 
and the underlying image cannot be seen.

To change the transparency percentage, move the slider to the right to increase transparency or to the left 
to decrease transparency.

Merge Mode List Box
The Merge Mode list box displays lets you define the way the colors of an object related to the existing 
base image and other overlapping objects merges.



Paste From Command

The Paste From command is similar to the Paste command, except that the Paste From command pastes 
an image from a specific file instead of from the Windows Clipboard.

Related Topics
Dialog Box information
Procedure information



Paste From Named Clipboard Dialog Box

The Paste From Named Clipboard dialog box lets you choose a file to paste from.

Select Clipboard Name Text Box
Click the down arrow to display the available named clipboard files.

File Options Button
You can use the File Options button to add, delete and rename files. 

Related Topics
Command information
Procedure information



Pasting a File

To paste a file to the current image:

1. Open the Edit menu and choose Paste From. The Paste From Named Clipboard dialog box 
opens.

2. Click the down arrow to the left of the File Options button. A list of files appears.
3. Click the file you want to paste.
4. Click Paste From. The file is pasted into the image window.

You can also delete or rename an existing file using the Paste From command.

To delete or rename a file:

1. Open the Edit menu and choose Paste From. The Paste From Named Clipboard dialog box 
opens.

2. Click the down arrow to the left of the file icon. A list of files appears.
3. Choose the file you want to delete or rename.
4. Click the file icon. A submenu opens.
5. Click Delete or Rename, as appropriate. Choosing the Delete command deletes the name as well 

as the DOS file from the Clipbit directory.

Related Topics
Command information
Dialog Box information



Paste As New Image Command

The Paste As New Image command lets you create a new image based on the contents of the clipboard. 
This is a great way to capture screen shots.

Related Topics
Procedure information



Pasting as a New Image

To paste as a new image:

· Open the Edit menu and choose Paste As New Image. The cut or copied selection is pasted as a 
new image.

Related Topics
Command information
Screen captures



Capturing Screen Shots

You can use the Paste As New Image command in the Edit menu to capture screen shots.

To capture screens:

1. Create the screen you want to capture.
2. Press Print Screen. A screen shot of your window is copied to the Windows Clipboard.
3. In Picture Publisher, open the Edit menu and choose Paste As New Image. Picture Publisher 

opens your screen shot.



Delete Command

The Delete command (Ctrl+Del) removes masked portions of an image from the image window. 

Note: You can restore an image that was removed with the Delete command by choosing the Undo 
command in the Edit menu immediately after deleting.

Related Topics
Procedure information



Deleting an Image Area

Choose the Delete command in the Edit menu to delete an image area.

To delete an image area:

1. Mask the area of the image you want to delete.
2. Open the Edit menu and choose Delete.

Related Topics
Command information



Preferences Command

The Preferences command lets you change the default settings for Picture Publisher.

Related Topics
Dialog Box information
Procedure information



Preferences Dialog Box

The Preferences dialog box lets you specify several default settings. All program defaults are stored in the 
PP.INI file located in your Picture Publisher program directory.

Preference Group Area
The Preference Group area contains these options: Memory, Undo, Scratchpad, Units, and 
Miscellaneous. When you choose an option, the right half of the dialog box (panel) changes to reflect the 
associated options.

Memory Panel
The Memory panel contains three options for managing your memory.

The Cache Path text box defines the path of the image cache memory when an image exceeds the 
amount of available memory. Picture Publisher creates temporary files in this directory.

The Minimum Free Memory and Free Memory Per Image options affect how Windows allocates memory 
to your images. The k Minimum free memory option lets you specify the amount of Windows memory 
reserved for programs other than Picture Publisher. Picture Publisher subtracts this amount from the 
available reserve of memory before determining what percentage of it to use for an image. The Free 
Memory Per Image option controls the percent of available Windows memory to allocate to each image.

Note: If the Free Memory Per Image option is set at 50% and the amount of available memory is 1000K, 
the first image uses 500K, the second uses 250K, and the third uses 125K. Each image has an undo 
buffer of equal size.

The Open Line Art as Grayscale option lets you edit line art images as 8-bit images. If the option is 
deselected and you edit a line art image as a 1-bit image, your image requires one-eighth the memory of 
the same image edited as a grayscale image. This could be important if you are editing a large image or if 
you have limited computer memory. When you edit an image as a 1-bit image, you can use only two 
colors: black and white.

Undo Panel
The Mode list box lets you choose No Undo, Manual Apply, or Auto Apply. Auto Apply lets every new 
change or edit be automatically applied to the working image. This is a convenient way to work through a 
session without stopping to manually apply changes.

In Auto Apply mode, the Undo command in the Edit menu and the Eraser tool remove only the last edit. 
Notice that while in Auto Apply, the Auto Apply command is disabled, but the Undo command toggles 
between Undo and Redo, so that you can remove and display the last edit.

If the Manual Apply option is selected, the Manual Apply command in the Edit menu applies all changes 
made since the last manual apply. This lets you evaluate changes in combination before making them 
part of the image. Regardless of which apply mode you use, only the Save and Save As commands 
permanently save changes to a file.

The No Mask Undo option lets you turn on and off undo for mask edits. For example, if you select this 
option, then you cannot undo mask edits.

Scratchpad Panel
The Scratchpad panel lets you create a blank image file to test painting or drawing effects. The image 
size and selection of a grayscale or full-color image are predefined in the Preferences dialog box. This 
feature can be very handy in helping you get the feel of a particular brush setting before applying it to an 
image. It is also a good place to create new colors or blends the same way a traditional artist uses a 
palette. When you are working with very large image files, the repainting and preview of your image 



modifications can become time consuming. By creating a scratchpad large enough to preview your edits, 
you can copy a smaller section of an image to it and experiment with your edits right on the scratchpad.

If your edited section is what you want, you can use that as a reference and apply it to your image file, or 
simply cut and paste the edited section directly from the scratchpad.

When you are working on a full-color image, you may need to compare a section of the image or the full 
image as a grayscale image (for proofing on a monochrome laser printer). By creating a scratchpad that 
has a grayscale format, you can copy sections of your full-color image directly to it and get an example of 
grayscale values.

The maximum size for the scratchpad is 500 pixels by 500 pixels. It can be defined either as a grayscale 
or full-color image format.

You can create an unlimited number of scratchpad windows of various sizes and color definitions. You 
can also use the Duplicate command in the Window menu to open copies of your scratchpad window. To 
close a scratchpad, double click the Scratchpad Control menu box or choose the Close command in the 
File menu.

Units Panel
The Units area controls the unit of measurement used in Picture Publisher for resizing and positioning 
images. You can choose from inches, millimeters, centimeters, and picas.

The Screen width text box lets you specify the active display area on the monitor. The physical size (in 
inches) must be entered correctly, so Picture Publisher can display the actual size of an image.

The Use Rulers option allows you to display a pair of rulers in the current image window. To show or hide 
the rulers, choose the Rulers command in the Show/Hide submenu in the Window menu.

The Use Percentages option lets you display pixel values as percentages.

Miscellaneous Panel
The Names Path text box specifies the location of the file PPNAMES.INI.

The Tablet Pressure list box lets you set how the pressure value is used to affect the retouch tools.

The Mask Tint Color list box lets you set the color used when displaying masks in ruby overlay mode.

The Independent Tool Settings Option lets you choose how setting the preferences for one tool affects the 
preferences for other tools in the group.

Related Topics
Command information
Procedure information



Setting Preferences

To set preferences:

1. Open the Edit menu and choose Preferences. The Preferences dialog box opens.
2. Choose the options you want.
3. Click Save to save the changes for future sessions, or click OK to save the changes for the 

current session only.

Related Topics
Command information
Dialog Box information



Map Menu Commands

The Map menu commands let you adjust the colors and intensities in an image to enhance it for output. 
They include adjustments to contrast, hue, brightness, and saturation and special effects such as 
posterizing and thresholding.

Modify Color Maps Controls the output density of the primary colors, individually and combined, over 
the full range from highlight to shadow.

Contrast/Brightness Sharpens (or softens) and darkens (or lightens) the image, similar to the controls 
on a computer monitor.

Color Balance Increases or decreases the effect of certain colors on an image.
Tone Balance Modifies tonal range.
Posterize/Threshold Produces special effects by reducing the levels of grays and colors in an image.
Hue/Saturation Changes the shade of a range of colors and controls the color purity.
Apply Calibration Map Lets you make adjustments in Picture Publisher to improve the quality of your 

images by compensating for imperfections in scanning and printing devices.



Modify Color Maps Command

The Modify Color Maps command (Ctrl+M) controls the output density of the primary colors, individually 
and combined, over the full range from highlight to shadow. It is used primarily for manipulating color 
shifts and improving poor input-image quality.

Related Topics
Dialog Box information
Procedure information



Modify Color Maps Dialog Box

The Modify Color Maps dialog box let you modify maps, and also add, rename, and delete MAP files.

Maps are saved as MAP files in the Printsty directory, and can have up to 80 characters in the extended 
name. You can add, rename, and delete MAP files by clicking the Load button, then clicking the file icon in 
the Load a Map dialog box.

Channel List Box
The Channel list box displays the seven color channels that you can modify (Master, Red, Green, Blue, 
Cyan, Magenta, and Yellow). Modify either the RGB channels or the complementary CMY channels to 
shift colors.

Editing List Box
The Editing list box provides four options for modifying the channels: 11 Points, 5 Points, 3 Points, and 
Values. Clicking one of the points options displays a graph, and clicking Values displays data boxes for 
input and output data values.

In the graph displayed by clicking a points option, the horizontal axis of the map signifies the input values 
as a gray or color percentage, and the vertical axis signifies the output value as a gray or color 
percentage. An input value is mapped to a new value by locating it on the input (horizontal) axis. To find 
out what output value the curve maps this value to, move straight up from the input point until you touch 
the line graph or curve. Then move to the left until you touch the output (vertical) axis. By reading the 
value, you can determine the new output value for the original input value. This process maps the input 
value to a new output value. For example, if a 66% gray pixel maps to a 33% gray pixel, the output 
appears twice as bright.

Any point on the graph that lies below the 45-degree line brightens an input value, and any point that lies 
above the 45-degree line darkens it. Sometimes this map is called a lookup table because every input 
value can be "looked up" to obtain a corresponding output value. These values could be presented in a 
table and used like a translation dictionary. A map can also be called a "curve," but it refers to the same 
process of mapping pixels.

Unless the map has a straight 45-degree angle, some segments of the map will compress its range of 
gray values while other segments will stretch their range of gray values. These two terms can be used to 
describe the slope (angle) of any segment of the curve. If the slope of a segment has a sharp incline, the 
segment stretches the input tone range. If the slope of the segment has a shallow incline, then the 
segment compresses the input tone range.

Anytime you stretch one range, you compress another. Generally you will find that it is best to stretch 
highlight detail and give up shadow detail in a bright image, and to stretch shadow detail and give up 
highlight detail in an image where most of the values are shadow values.

For a normal image, it is best to give up detail in the shadows because our eyes have a difficult time 
seeing detail in the shadows. This means that extra detail in the shadows is usually wasted.

Make sure that the detail you lose by compressing a tone range is unnecessary or nonexistent because 
once edits have been saved, you can never revert to the original values.

Save Button
Click the Save button to open the Save Map dialog box.

Load Button
Click the Load button to open the Load Map dialog box.

Preview Button



Click the Preview button to preview changes before applying them permanently to the image. The screen 
repaints the image as if the changes were applied.

Reset Button
Click the Reset button to revert to the original settings, either by individual channel or all channels.

Reset All Button
Click the Reset All button to reset all of the color channels.

Related Topics
Command information
Procedure information



Modifying Color Maps

Choose the Modify Color Maps command in the Map menu to adjust color maps.

To modify the color map:

1. Open the Map menu and choose Modify Color Maps, or press Ctrl+M. The Modify Color Maps 
dialog box opens.

2. Click the down arrow to the right of the Channel list box. A list of channels appears.
3. Click the channel you want to modify.
4. Click the down arrow to the right of the Editing box and choose a points option or Values.
5. Move the cursor to a point on the curve, press and hold the left mouse button, and drag the point 

to a new location. Release the left mouse button.
or
Choose the Values option in the Editing list box to display values, then type in new input and 
output values for each of the points to be modified.

6. Click Preview to preview the changes.
7. Click OK. The dialog box closes and the image repaints as modified.

If the changes are not acceptable at this point, you can choose the Undo command to revert to the 
previously applied changes. To make the changes a part of the working image, either choose the Manual 
Apply command in the Edit menu if in manual apply mode or resume editing to automatically apply them 
in auto apply mode.

As you change a point in the point graph, the corresponding input and output values change. Also, as you 
change input and output values, the corresponding point graph changes.

Note: Even though the image may change interactively (with a 256-color Windows display driver) and 
provide feedback as a map is modified, only Preview shows the full effect of all changes. 

Once satisfactory results have been confirmed using Preview, click Save to save the modified map. A 
dialog box opens to prompt you to save the map with a new name.

Note: By changing eraser options in the ribbon area (shape, size, style, feather, fade, and transparency), 
map modifications can be fine-tuned quickly.

Related Topics
Command information
Dialog Box information



Save Map Dialog Box

The Map Name dialog box opens when you click the Save button in the Modify Color Maps dialog box.

Enter Map Name List box
Click the down arrow to show the list of map names available. You also can type a new name for the map, 
then click Save to save the map.

Related Topics
Modifying Color Maps



Load Map Dialog Box

The Load Map dialog box opens when you click the Load button in the Modify Color Maps dialog box.

Select Map Name List Box
Click the down arrow to the right of the Select Map Name list box. A list box opens, displaying map 
names. Choose the map you want, then click Load.

Related Topics
Modifying Color Maps



Contrast/Brightness Command

The Contrast/Brightness command opens a submenu containing the Joystick and Visual commands.



Joystick Command (Contrast/Brightness Submenu)

The Joystick command (Ctrl+J) lets you use the Contrast/Brightness dialog box to sharpen (or soften) 
and darken (or lighten) the image.

Related Topics
Dialog Box information
Procedure information



Contrast/Brightness Dialog Box

The Contrast/Brightness dialog box lets you adjust the contrast and brightness of an image.

Tonal Range List Box
The Tonal Range list box displays the tone ranges that you can choose to affect. They include Full, 
Highlights, Midtones, and Shadows.

Contrast and Brightness Areas
Use these areas for entering the percentage of change you want to apply to these attributes. Enter a 
positive number, such as 10, to increase an attribute. Enter a negative number, such as -10, to decrease 
it. You can increase and decrease the values in small increments by clicking the spin control next to the 
areas. Entering values in these areas    moves the joystick in the Change area.

Change Area
The Change area reflects the changes in contrast and brightness when you move the joystick. You can 
also type the values you want in the Contrast and Brightness areas.

Preview Button
Click the Preview button to preview changes before applying them permanently to the image. The screen 
repaints the image as if the changes were applied. If you are using an eight-bit (256-color) video board, 
Picture Publisher shows the changes as you make them. Preview, however, shows a more accurate 
rendering.

Reset Button
Click the Reset button to revert to the original settings.

Related Topics
Command information
Procedure information



Setting the Contrast/Brightness (Joystick Command)

To adjust brightness and contrast:

1. Open the Map menu and choose Contrast/Brightness. A submenu opens. 
2. Choose Joystick. The Contrast/Brightness dialog box opens, showing a representation of a 

joystick.

Note: Value boxes in the Change area display numerical percentages for changes in contrast and 
brightness. The joystick and numerical displays are interactive, and changes can be made with either 
one.

3. Drag the handle of the joystick or enter numerical values in the Contrast and Brightness areas to 
adjust the image.

Note: Move the joystick up and down to adjust the contrast; move it left and right to adjust the brightness. 
The same results are achieved by entering positive or negative values in the Change boxes. To reset both 
values to 0, click Reset or double click the joystick.

4. Click Preview to preview the changes.

Note: Even though the image may change interactively (with a 256-color Windows display driver) and 
may provide feedback as contrast and brightness are modified, only Preview shows the full effect of all 
changes. 

5. Click OK. The dialog box closes and the image repaints as modified.

If the changes are not acceptable at this point, you can choose the Undo command to revert to the 
previously applied changes. To make the changes a part of the working image, either choose the Manual 
Apply command in the Edit menu (if in manual apply mode) or resume editing to automatically apply them 
(in auto apply mode).

Related Topics
Command information
Dialog Box information



Visual Command (Contrast/Brightness Submenu)

The Visual command (Ctrl+K) lets you the Visual Contrast/Brightness dialog box to sharpen (or soften) 
and darken (or lighten) the image. This dialog box displays a series of small images showing how 
changes alter the image.

Related Topics
Dialog Box information
Procedure information



Visual Contrast/Brightness Dialog Box

Original Image Button
The Original Image button shows the original image.

Modified Image Button
The Modified Image button shows how all current changes alter the image.

Image Buttons
Image buttons display in the dialog box for adjusting the color balance of the image. Labels indicate the 
affect each button has. The images show the change each button will make.

Button Action

Increase darkness, decrease lightness.

Increase darkness.

Increase darkness, increase lightness.

Decrease lightness.

Increase lightness.

Decrease darkness, decrease lightness.

Decrease darkness.

Decrease darkness, increase lightness.

Tonal Range List Box
The Tonal Range list box displays the tone ranges that you can choose to affect. They include Full, 
Highlights, Midtones, and Shadows.

Increments Slider 
The Increments slider lets you enter the percentage of change you want to apply to a color each time you 
click on the one of the image buttons. Move the slider by dragging the control.

Preview Button
Click the Preview button to preview changes before applying them permanently to the image. The screen 
repaints the image as if the changes were applied. If you are using an eight-bit (256-color) video board, 
Picture Publisher shows the changes as you make them. Preview, however, shows a more accurate 
rendering.

Note: Because this dialog box is very large, you may need to move the dialog box to see the preview. 
Move the dialog box by pointing to and dragging the title bar of the dialog box.

Reset Button
Click the Reset button to revert to the original settings.

Related Topics



Command information
Procedure information



Setting the Contrast/Brightness Visual Command)

To modify the contrast and brightness visually:

1. Mask the area you want to modify or use the entire image.
2. Open the Map menu and choose Contrast/Brightness. A submenu opens.
3. Choose Visual. The Contrast/Brightness dialog box opens.
4. Set the increment of change you want to apply.
5. Click the image buttons to apply the changes.
6. Click Preview to see how the changes alter the image. You may need to move the dialog box see 

the image.
7. Click OK to apply the changes to the image.

Related Topics
Command information
Dialog Box information



Color Balance Command

The Color Balance command opens a submenu containing the Joystick and Visual commands.



Joystick Command (Color Balance Submenu)

The Joystick command (Ctrl+F) increases or decreases the effect of certain colors on an image.

Related Topics
Dialog Box information 
Procedure information 



Color Balance Dialog Box

Channel List Box
The Channel list box displays the seven color channels that you can modify (Master, Red, Green, Blue, 
Cyan, Magenta, and Yellow). Make global changes or changes to black-and-white images using the 
Master channel. Modify either the RGB channels or the complementary CMY channels to shift colors.

Tonal Range List Box
The Tonal Range list box displays the tone ranges that you can choose to affect. They include Full, 
Highlights, Midtones, and Shadows.

Contrast and Brightness Areas
Use these areas for entering the percentage of change you want to apply to these attributes. Enter a 
positive number, such as 10, to increase an attribute. Enter a negative number, such as -10, to decrease 
it. You can increase and decrease the values in small increments by clicking the spin control next to the 
areas. Entering values in these areas    moves the joystick in the Change area.

Preview Button
Click the Preview button to preview changes before applying them permanently to the image. The screen 
repaints the image as if the changes were applied. If you are using an eight-bit (256-color) video board, 
Picture Publisher shows the changes as you make them. Clicking the Preview button shows a more 
accurate rendering.

Reset Button
Click the Reset button to revert to the original settings.

Reset All button
Click the Reset All button to reset all of the color channels.

Related Topics
Command information
Procedure information 



Modifying the Color Balance (Joystick Command)

To modify the color balance using the joystick:

1. Mask the area you want to modify or use the entire image.
2. Open the Map menu and choose Color Balance. A submenu opens.
3. Choose Joystick. The Color Balance dialog box opens.
4. Choose the color layer (channel) you want to alter. 
5. Choose the Tonal Range you want to affect.
6. Type in the edit boxes the percentage changes in control and bright you want to apply. You can 

also set these values by dragging the joystick.
7. Click Preview to see how the changes alter the image.
8. Make any additional changes to other channels and values.
9. Click OK to apply the changes to the image.

Related Topics
Command information
Dialog Box information 



Visual Command (Color Balance Submenu)

The Visual command (Ctrl+G) increases or decreases the effect of certain colors on an image.

Related Topics
Dialog Box information 
Procedure information 



Visual Color Balance Dialog Box

Original Image Button
The Original Image button shows the original image.

Modified Image Button
The Modified Image button shows how all current changes alter the image.

Image Buttons
Image buttons display in the dialog box for adjusting the color balance of the image. Labels indicate the 
color each button modifies. Clicking a button always adds color to the image. The images show the 
change each button will make.

Tonal Range List Box
The Tonal Range list box displays the tone ranges that you can choose to affect. They include Full, 
Highlights, Midtones, and Shadows. 

Increments Slider 
The Increments slider lets you enter the percentage of change you want to apply to a color each time you 
click on the one of the image buttons. Move the slider by dragging the control.

Maintain Density Option
This option lets you maintain the overall density of the original image.

Preview Button
Click the Preview button to preview changes before applying them permanently to the image. The screen 
repaints the image as if the changes were applied. If you are using an eight-bit (256-color) video board, 
Picture Publisher shows the changes as you make them. Clicking the Preview button shows a more 
accurate rendering.

Reset Button
Click the Reset button to revert to the original settings.

Reset All button
Click the Reset All button to reset all of the color channels.

Related Topics
Command information
Procedure information 



Modifying the Color Balance (Visual Command)

To modify the color balance visually:

1. Mask the area you want to modify or use the entire image.
2. Open the Map menu and choose Color Balance. A submenu opens.
3. Choose Visual. The Visual Color Balance dialog box opens.
4. Set the increment of change you want to apply.
5. Click the image buttons to apply the changes.
6. Click Preview to see how the changes alter the image. You may need to move the dialog box to 

see the image.
7. Click OK to apply the changes to the image.

Related Topics
Command information
Dialog Box information 



Tone Balance Command

The Tone Balance command (Ctrl+Q) lets you modify tonal range. This usually improves the contrast of 
an image. Suppose the darkest tone of an image is 70% black. You can use the Tone Balance command 
to make it 100% black. The purpose of this command is to let you adjust the highlight, midtone, and 
shadow points in an image.

The amount of image data between each pair of markers controls the expansion or compression of the 
tonal range in each quarter section of the color map. Moving the markers reshapes the color map. For 
this reason, the Tone Balance command is often used first, before fine-tuning the color map with the other 
Map menu commands.

Related Topics
Dialog Box information
Procedure information



Tone Balance Dialog Box

The Tone Balance dialog box displays a histogram of the image. The histogram is a chart, where the 
horizontal axis represents the percentage of gray values and the vertical axis represents the number 
(count) of values. Below the histogram are the highlight and shadow markers. These markers are 
automatically placed at the brightest and darkest values in an image.

Probe Highlights and Probe Shadows Buttons
Click one of these buttons to use the Probe tool to choose a part of the image to reflect highlights and 
shadows.

Sacrifice Highlights and Sacrifice Shadows Sliders
These sliders show you the current starting positions of the highlights and shadows in your image. You 
can also manually adjust them by dragging the controls.

Preview Button
Click the Preview button to see what "stretching" the dynamic range does to the image. Clicking one of 
the markers under the histogram displays a vertical line at its location and changes the data count display 
at the bottom of the dialog box. The count value displayed below the histogram area indicates the 
percentage of data at a specific point. The left and right values indicate the percentage of data on either 
side of the point. These readings are interactive and change as each marker is moved. These data counts 
are used to locate the markers and identify the quantity of image data discarded when the tonal range is 
adjusted.

Reset Button
Click the Reset button to revert to the original settings.

Related Topics
Command information
Procedure information



Setting Tone Balance

To use the Tone Balance command:

1. Open the Map menu and choose Tone Balance, or press Ctrl+Q. The Tone Balance dialog box 
opens, showing a histogram of the image.

2. Drag the highlight, midtone, and shadow markers to new locations on the histogram.
3. Click Preview to preview the changes.
4. Click OK. The dialog box closes and the image repaints as modified.

Note: You can adjust the tonal range in an area of an image by defining the area with a mask.

Related Topics
Command information
Dialog Box information



Posterize/Threshold Command

The Posterize/Threshold command (Ctrl+L) produces special effects. Posterize and Threshold, while 
similar, are independent functions even though the commands appear in the same dialog box.

Posterize limits the number of density levels used by each primary color to achieve a pronounced effect. 
They are modified either by individual channel adjustments or by adjusting all channels by using the 
Master channel.

Threshold turns on individual colors that are pure above the threshold density and turns off colors that are 
below it, in effect creating binary (two-level) posterization. Threshold changes are made to individual 
channels or to all channels by using the Master channel.

Related Topics
Dialog Box information
Procedure information



Posterize/Threshold Dialog Box

Channel List Box
The Channel list box displays the seven color channels that you can modify (Master, Red, Green, Blue, 
Cyan, Magenta, and Yellow). Make global changes or changes to black-and-white images using the 
Master channel. Modify either the RGB channels or the complementary CMY channels to shift colors.

Levels Area
Drag the slider in the Levels area to change posterization, or enter a value for the number of specific 
density levels (up to 256).

Threshold Area
Drag the slider in the Threshold area to change the threshold, or enter a value for the Threshold density 
(up to 100).

Preview Button
Click the Preview button to preview changes before applying them permanently to the image. The screen 
repaints the image as if the changes were applied.

Reset Button
Click the Reset button to revert to the original settings for the currently selected channel.

Reset All Button
Click the Reset All button to reset all of the color channels.

Related Topics
Command information
Procedure information



Setting Posterize/Threshold

To use the Posterize/Threshold command:

1. Open the Map menu and choose Posterize/Threshold, or press Ctrl+L. The Posterize/Threshold 
dialog box opens, showing separate slider controls for Posterize and Threshold.

2. Click the down arrow to the right of the Channel list box. A list of channels appears.
3. Click the channel you want to modify.
4. Drag the slider in the Levels area to change posterization.

or
Enter a value for the number of specific density levels (up to 256).

5. Drag the slider in the Threshold area to change the threshold.
or
Enter a value for the threshold (up to 100).

6. Click Preview to preview the changes.
7. Repeat steps 2 through 6 as necessary, adjusting levels for each channel until you have a 

satisfactory image.
8. Click OK. The dialog box closes and the image repaints as modified.

Note: Even though the image may change interactively (with a 256-color Windows display driver) and 
may provide feedback as posterization and threshold are modified, only Preview shows the full effect of 
all changes. 

If the changes are not acceptable at this point, you can choose the Undo command in the Edit menu to 
revert to the previously applied changes. To make the changes a part of the working image, either choose 
the Manual Apply command in the Edit menu (if in manual apply mode) or resume editing to automatically 
apply them (in auto apply mode).

Related Topics
Command information
Dialog Box information



Hue/Saturation Command

The Hue/Saturation command (Ctrl+H) lets you change the shade of a range of colors, the saturation 
level of colors, and the lightness level of colors.

Related Topics
Dialog Box information
Procedure information



Hue/Saturation/Lightness Dialog Box

The Hue/Saturation dialog box lets you adjust colors and saturation.

Hue Shift Area
The Hue Shift area of the Hue/Saturation dialog box lets you remap 12 hue ranges (colors) to different 
output hue ranges.

Saturation Shift Area
The Saturation Shift area lets you add or subtract gray in all hues.

Lightness Shift Area
The Lightness Shift area lets you increase or decrease lightness to all hues and saturations.

Preview Button
Click the Preview button to preview changes before applying them permanently to the image. The screen 
repaints the image as if the changes were applied.

Reset Button
Click the Reset button to revert to the original settings.

Related Topics
Command information
Procedure information



Setting Hue/Saturation/Lightness

To change the hue and saturation:

1. Open the Map menu and choose Hue/Saturation, or press Ctrl+H. The Hue/Saturation/Lightness 
dialog box opens, showing a row of 12 vertical sliders for hue adjustment. Beneath each slider 
are two color swatches. The lower swatch is the input (old) hue, and the upper swatch is the 
output (new) hue.

2. Drag the 12 hue bars until the color swatches are changed to the desired hues.

Note: Beneath the hue controls is a separate slider control for saturation. Drag the slider to the right to 
increase color saturation. The colors appear purer. Drag the slider to the left to decrease saturation. As 
the slider moves to the left, the color purity decreases toward gray, and becomes black and white at the 
far left. The same result is achieved by entering saturation correction values directly in the box.

3. Drag the saturation slider until the levels are satisfactory.
4. Click Preview to preview the changes.
5. Click OK. The dialog box closes and the image repaints as modified.

Note: Even though the image may change interactively (with a 256-color Windows display driver) and 
may provide feedback as hue and saturation are modified, only Preview shows the full effect of all 
changes. 

If the changes are not acceptable at this point, you can choose the Undo command in the Edit menu to 
revert to the previously applied changes. To make the changes a part of the working image, either choose 
the Manual Apply command in the Edit menu (if in manual apply mode) or resume editing to automatically 
apply them (in auto apply mode).

Related Topics
Command information
Dialog Box information



Apply Calibration Map Command

You can make adjustments in Picture Publisher to improve the quality of your images by compensating for 
imperfections in scanning and printing devices.

Related Topics
Dialog Box information 
Procedure information 



Apply Calibration Map Dialog Box

Scanner Calibration Name List Box
Click the down arrow to choose the calibration map you want to use. If you scanned the image with 
calibration on, choosing a map again applies the calibration a second time.

File Options Button
The File Options button lets you add, delete, and rename scanner calibration maps without leaving 
Picture Publisher.

Printer Calibration Name List Box
Click the down arrow to choose the calibration map you want to use. Applying a printer map to an image 
alters the image so your printer can print it correctly.

File Options Button
The File Options button lets you add, delete, and rename printer calibration maps without leaving Picture 
Publisher.

Related Topics
Command information
Procedure information 



Applying Calibration to an Image

To apply calibration to an image:

1. Use the entire image or mask the part you want to change.
2. Open the Map menu and choose Apply Calibration Map. The Apply Calibration Map dialog box 

opens.
3. Choose a scanner calibration map.
4. Choose a printer calibration map.
5. Click Apply.

Related Topics
Command information
Dialog Box information 



Mask Menu Commands

The Mask menu works in conjunction with the Mask tools to remove, load, and save masks. The menu 
also contains commands that let you crop an image and blend an image to the edges of a pasted image.

Undo/Redo Mask Removes the last change made to a mask.
Remove Deletes all active masks.
Load Loads a previously saved mask and places it in the current image.
Save Saves masks for future use.
Invert Reverses the masked and unmasked areas.
Feather Smooths the edge transition between the masked and unmasked areas of an 

image.
Hide Marquee Hides the masks borders while keeping the masks in place.
Crop Lets you cut out unwanted portions of an image.
Stroke Draws a border outline under a mask.



Undo/Redo Mask Command

The Undo command removes the last change made to a mask.

The Redo command restores the most recent undo. After you use the Undo command, the Redo 
command replaces it in the Mask menu. You can toggle between Undo and Redo to see your mask 
before and after the latest change.

Note: To save memory, you can disable undo for masks with the Undo options in the Preferences 
command.



Remove Command

The Remove command (Ctrl+R) deletes all active masks. You can restore removed masks by choosing 
the Undo command in the Mask menu.

Related Topics
Procedure information



Removing Active Masks

Choose the Remove command in the Mask menu to remove all active masks.

To remove all active masks:

· Open the Mask menu and choose Remove, or press Ctrl+R. All active masks disappear.

Note: While color shields are a masking function, they are unaffected by the Remove command.

Related Topics
Command information



Load Command

The Load command loads a previously saved mask and places it in the current image.

Related Topics
Dialog Box information
Procedure information



Load Mask Dialog Box

The Load Mask dialog box lets you choose a mask file to open.

Select Mask Name Area
Choose a name in the Select Mask Name area, then click Load to open a mask.

File Options Button
The File Options button lets you add, delete, and rename masks without leaving Picture Publisher.

Delete Mask Option
This option removes any other masks in the image, and is active by default.

Related Topics
Command information
Procedure information



Loading a Mask

To load a previously saved mask:

1. Open the Mask menu and choose Load. The Load Mask dialog box opens.
2. Click the down arrow to display mask names, then choose the name of the desired mask and 

click Load. The mask appears on the screen.

Note: To move or edit the mask, use the Mask Transform tool or the Mask Point Editing tool in the Mask 
tool set.

Note: If the mask is a different size from the image, or you have an existing mask, the Mask Transform 
tool becomes available.

Related Topics
Command information
Dialog Box information



Save Command

The Save command saves masks for future use.

Related Topics
Dialog Box information
Procedure information



Save Mask Dialog Box

The Save Mask dialog box lets you name and store a mask that you created.

Enter Mask Name Area
Type a name in the Enter Mask Name area, then click Save to save the mask.

File Options Button
The File Options button lets you add, delete, and rename masks without leaving Picture Publisher.

Related Topics
Command information
Procedure information



Saving a Mask

To save a mask:

1. Open the Mask menu and choose Save. The Save Mask dialog box opens.
2. Type a name for the mask and click Save.

Related Topics
Command information
Dialog Box information



Invert Command

The Invert command (Ins) reverses the masked and unmasked areas. If you mask an area of an image, 
this command removes the mask from that area and masks everything else.

Related Topics
Procedure information 



Inverting a Mask

To invert a mask:

· Open the Mask menu and choose Invert, or press Ins. 

Related Topics
Command information



Feather Command

The Feather command smooths the edge transition between the masked and unmasked areas of an 
image. Feathering helps prevent a hard edge from occurring between an edited masked area and the rest 
of the image.

Related Topics
Dialog Box information 
Procedure information 



Feather Mask Dialog Box

Amount Area
Enter the number of pixels for the feathering to extend from the border.

Edge List Box
Click the down arrow to display the options for selecting how quickly the feathering drops off: hard, 
normal, or soft.

Direction List Box
Click the down arrow to display the options for selecting whether to feather the mask inside the border, 
outside the border, or centered on the border.

Related Topics
Command information
Procedure information 



Feathering a Mask

To feather a mask:

1. Create a mask using one of the mask tools.
2. Open the Mask menu and choose Feather. The Feather Mask dialog box opens.
3. Type the number of pixels to feather.
4. Choose an edge type.
5. Choose a direction for the feathering.
6. Click Feather to feather the mask.

Related Topics
Command information
Dialog Box information 



Hide Marquee Command (Mask Menu)

The Hide Marquee command (Shift+End) keeps all masks in place but hides the mask borders. The 
border, called the marquee, consists of a black and white animated line (red and green in grayscale 
images) denoting the edges of the mask. If the marquee is masking a detailed area of the image, you 
may want to hide it so you can better view any changes you make to the masked area.

Related Topics
Procedure information 



Hiding a Marquee

To hide a marquee:

· Open the Mask menu and choose Hide Marquee, or press Shift+End.

Related Topics
Command information



Crop Command

The Crop command (Ctrl+Y) lets you cut out unwanted portions of an image. 

Related Topics
Procedure information



Cropping an Image to a Mask

To use the Crop command:

1. Mask the portions of your image you wish to keep.
2. Open the Mask menu and choose Crop, or press Ctrl+Y. The screen repaints to the size of the 

masks, crops the image area, and removes the masks.

Note: If more than one mask is defined, the image is cropped to the smallest area that includes all of the 
masks.

Related Topics
Command information



Stroke Command

The Stroke command draws a border outline under a mask. You can use this command to add any 
number of special effects, such as adding a neon border to a masked part of the image. 

Related Topics
Dialog Box information 
Procedure information 



Stroke Mask Dialog Box

Tool List Box 
Lets you select a tool type, including Paint, Airbrush, Texture, Smear, Sharpen, Smoooth, Lighten, and 
Darken.

Stroke Style List Box 
Lets you select a style associated with the selected tool including Solid, Solid (Overlap), Chalk, Colorize, 
Crayon, Dots, Marker, Pencil, Smudgy Marker, Scatter, Scatter (Overlap), Oil Paint, Brushed Oils, and 
WaterColor.

Shape List Box 
Lets you choose the shape of the Stroke tool tip.

Size Area
Lets you define the dimensions of the drawing tip in pixels, from 0 to 99. You can increase and decrease 
the values in small increments by clicking the spin control next to the edit boxes.

Feather Area
Lets you set the size of the smoothing transition between the line and surrounding image. You define the 
size as a percent of the drawing tip size. Feathering applies to both sides of the line.

Merge Mode List Box 
Lets you define the way a line color relates to existing colors in the image.

Transparency/Pressure List Box
Lets you select the amount of transparency or pressure of the stroke.

Note: No masking takes place with this operation.

Related Topics
Command information
Procedure information 



Stroking a Mask

To stroke a mask:

1. Draw a mask using one of the mask tools.
2. Open the Mask menu and choose Stroke. The Stoke Mask dialog box opens.
3. Choose the options you want to use.
4. Click Stroke.

Related Topics
Command information
Dialog Box information 



Image Menu Commands

The Image menu contains commands that let you resize, rotate, mirror, invert (positive and negative), 
stitch two images, and create special effects on an image or portions of an image defined by a mask.

Size Lets you redefine the size of an image without deleting (cropping) any portion of 
it.

Expand Redefines the boundaries of an image without changing the original image.
Rotate Rotates an entire image.
Mirror Flips an image horizontally, vertically, or diagonally.
Channels Lets you view and modify the individual color components of a color image, and 

recombine previously split images.
Convert To Lets you change the image type of any image.
Invert Reverses the colors of an image or portions of an image (defined by a mask).
Stitch Lets you stitch two images together.
Effects Lets you create special effects using the special filters.



Size Command

The Size command lets you redefine the size of an image without deleting (cropping) any portion of it. 
This helps manage file size in memory, adjust resolution for specific output devices, and define height and 
width needed for a specific application.

Note: The Size command can change the resolution and size of an image, providing better control over 
file size. For best results, file size should match the output capability of the imaging device. Excess data 
can result in an oversized file, with some data simply being thrown away if a printer cannot use this data.

Related Topics
Dialog Box information
Procedure information



Size Image Dialog Box

Choosing the Size command in the Image menu opens the Size Image dialog box and displays the image 
file specifications at 100% magnification. This is the actual size of the image as it is loaded into Picture 
Publisher.

Width and Height Areas
The Width and Height areas are used for entering new values in the respective data boxes.

Note: If the Allow Size Distortions option is selected, width and height are independent of each other. If it 
is not selected, changing one automatically changes the other proportionally to maintain the original 
aspect ratio of the image.

Units List Box
The Units list box displays the units available, including inches, millimeters, picas, centimeters, and pixels.

WScale and HScale Areas
The WScale (Width Scaling) and HScale (Height Scaling) areas display the new values for height and 
width as a percentage of the original. WScale and HScale can be changed by entering new percentages 
in the respective data boxes.

Note: If the Allow Size Distortions option is selected, the width scaling and height scaling options are 
independent of one another. If it is not selected, changing one automatically changes the other 
proportionally to maintain the original aspect ratio of the image.

Resolution area
The Resolution area displays image resolution measured in pixels per inch (PPI). Any resolution can be 
entered regardless of the resolution of the image brought into Picture Publisher. This option is used 
primarily to reduce the resolution of an image for output to a low-resolution device or to trade lower 
resolution for a higher width or height. To specify resolution, enter a new value in the data box.

Note: The resolution of a low-resolution image can be increased by entering a higher value in the Res 
area, but the image may not gain any real detail unless you choose the Use SmartSizing option to 
improve quality.

Image Size Area
The Image Size area displays the amount of memory required for the image, providing valuable file size 
management feedback before processing. This area updates each time the settings in the Size Image 
dialog box change.

Note: If the resolution is cut in half, the file size is reduced by a factor of four. Conversely, doubling the 
resolution increases the file size by a factor of four.

Note: Picture Publisher can work with images that require more memory than available in random access 
memory (RAM). Picture Publisher takes advantage of an Image Cache, which uses virtual memory to 
supplement RAM with available hard disk memory. 

Allow Size Distortions Option
The Allow Size Distortions option lets you maintain or distort the aspect ratio of an image. When the Allow 
Size Distortions option is selected, the width and height (WScale and HScale) can be changed 
independently.

Use SmartSizing Option
The Use SmartSizing option uses an advanced sampling algorithm to help maintain most of the detail of 
an image when the size or resolution changes.



When the size or resolution decreases, pixels are discarded. Most other programs discard or replicate 
pixels, regardless of color value. With SmartSizing, each pixel that remains is newly generated from the 
color values of the discarded neighboring pixels. Each of the pixels in the original image contributes to the 
pixels in the new image.

When image size or resolution increases, new pixels are created by sampling the neighboring pixel 
values. Although it takes a little longer for Picture Publisher to process the changes, SmartSizing helps 
the image to retain the best possible quality after resizing.

Maintain File Size Option
Choose this option if you want to change the image dimensions or resolution but keep the file size the 
same. You also can use this option to decrease the size of an image and increase the dpi at the same 
time. When this option is active, the image size remains constant, while changing one of the width, height 
or resolution options changes all of the others. Choosing this option disables the Allow Size Distortion 
option.

Related Topics
Command information
Procedure information



Resizing an Image

To change the size of an image:

1. Open the Image menu and choose Size. The Size Image dialog box opens.
2. Change the options to match the size and resolution you want.
3. Click Size. The dialog box closes and the image repaints based on recalculated image data.

Choose the Undo command in the Edit menu to reverse the changes after clicking Size in the Size Image 
dialog box.

Related Topics
Command information
Dialog Box information



Expand Command

The Expand command redefines the boundaries of an image without changing the original image. This 
command is similar to copying the image into a larger window.

Related Topics
Dialog Box information 
Procedure information 



Expand Image Dialog Box

Width and Height Areas
These areas let you enter the measurements and units of the new boundaries. You can increase the 
values in small increments by clicking the spin control next to the edit boxes. Use the list box to select the 
units of measure. The units always default to the units chosen with the Preferences command.

Left, Right, Top, and Bottom Areas
These areas let you enter the margins to place around the original image. The combined values of the 
Left and Right areas, when added to the width of the original image, equals the width of the new image.

Image Size Area
The Image Size area displays the storage size of the file.

Related Topics
Command information
Procedure information 



Expanding an Image

To expand the boundaries of an image:

1. Open the Image menu and choose Expand. The Expand Image dialog box opens.
2. Change the size.
3. Click Expand to increase the boundaries of the image.

Related Topics
Command information
Dialog Box information 



Rotate Command

The Rotate command is used to rotate an entire image.

When you choose the Rotate command, the following commands appear in the Rotate submenu.

Command Action

90 Clockwise Rotates the image 90 degrees clockwise.

90 Counterclockwise Rotates the image 90 degrees counterclockwise.

180 Degrees Rotates the image 180 degrees.

Arbitrary Angle Lets you specify the angle and direction of rotation.

Related Topics
Dialog Box information
Procedure information



Rotating an Image

To rotate an image:

1. Open the Image menu and choose Rotate. The Rotate submenu opens.
2. Choose a Rotate command. If you choose the Arbitrary Angle command, the Rotate Image dialog 

box opens.
3. Enter the number of degrees of rotation in the data box and click either the clockwise or 

counterclockwise icon. If you select the Use Weighted Averaging option, the pixels are calculated 
from neighboring pixels to eliminate jagged edges (aliasing).

4. Click Rotate.

Related Topics
Dialog Box information
Command information



Rotate Image Dialog Box

Angle Area
Enter the number of degrees for rotation in the Angle area.

Direction Icons
Choose a direction icon to rotate the image in that direction.

Weighted Averaging Option
Choose this option to have Picture Publisher calculate pixels from neighboring pixels to eliminate jagged 
edges (aliasing).

Related Topics
Command information
Procedure information



Mirror Command

The Mirror command lets you flip an image.

When you choose the Mirror command, the following commands appear in the Mirror submenu.

Command Action

Horizontal Flips an image left to right.

Vertical Flips an image top to bottom.

Diagonal Flips an image both left to right and top to bottom.

Note: The Mirror command affects a portion of an image, defined by a mask, or the entire image.

Related Topics
Procedure information



Mirroring an Image

Choose a command in the Mirror submenu to flip an image.

To mirror an image:

1. Open the Image menu and choose Mirror. The Mirror submenu opens.
2. Choose Horizontal, Vertical, or Diagonal. The image flips accordingly.

Choose the Undo command in the Edit menu to reverse a mirroring effect.

Related Topics
Command information



Channels Command

The Channels command lets you view and modify the individual color components of a color image.

When you choose the Channels command, a submenu opens,displaying the following commands.

Command Action

Split RGB Splits the image into red, green, and blue channels.
Split HSL Splits the image into hue, saturation, and lightness channels.
Split CMYK Splits the image in cyan, magenta, yellow, and black channels.
Combine Recombines the split channels of an image.

Picture Publisher creates separate image files and loads them on your screen. These image files appear 
as grayscale images; however, each image represents one of the three subtractive colors (cyan, 
magenta, and yellow) plus black, or the three additive colors (red, green, and blue), and the name of the 
color appears in the title bar. This can be useful in comparing color ranges between the color values and 
identifying methods when editing specific areas.

Possible uses of the Channels command:

· apply smart fills to aid in an auto-mask procedure, then choose the Save Mask command in the 
Mask menu

· apply paint or tooling edits to only one of the three channels to enhance the values in that 
channel

· apply filters to one or more of the channels to intensify a color

You are also able to save these grayscale files as separate image files using the Save and Save As 
commands in the File menu.

Related Topics
Procedure information



Splitting a Color Image

Choose the Channels command in the Image menu to split a color image.

To split a color image:

1. Open the Image menu and choose Channels. The Channels submenu opens.
2. Choose the Split RGB command, Split HSL command, or the Split CMYK command, as 

appropriate. The image is split.

Note: To see individual splits, minimize the top image.

To combine a previously split image:

1. Open the Image menu and choose Channels. The Channels submenu opens.
2. Choose Combine.

Related Topics
Command information



Convert To Command

The Convert To command in the Image menu converts the image type of the image on your screen. You 
also can change the image type by saving an image with the Save As command, but the Convert To 
command is more convenient and offers more choices. When you choose the Convert To command, a 
submenu opens and displays the following commands.

Command Action

Line Art Creates monochrome art.
Scattered Dithers your line art image to give the impression of more shades of gray.
Grayscale Makes an image with up to 256 shades of gray.
Palette Color Creates a one-channel, 8-bit image. Using this command opens the Convert to 

Palette Color dialog box.
RGB Color Makes a 24-bit image. This provides the most colors, up to 16 million.
CMYK Color Converts the image to the primary subtractive colors.

Note: If the source image contains more information than the destination image, you cannot convert the 
destination image back to its original condition unless you choose the Undo command before performing 
any other operation. For example, if you convert a full-color image to a grayscale image (a color image 
contains more information than a grayscale image), all of the color information is lost unless you choose 
the Undo command. If you convert a grayscale image to a full-color image, the image will not contain 
color but is capable of accepting any color available to a full-color image.

Related Topics
Procedure information



Convert to Palette Color Dialog Box

Type List Box
The Type list box lets you choose from 8-color, 16-color, or 256-color. Greater-color images usually look 
better; however, the greater-color images require more disk space than fewer-color images. 

Dither List Box
The Dither list box lets you choose from Pattern or Scattered. The Pattern option lets you simulate a 
greater-color image by dithering the pixels in a repeating "checkerboard" pattern. The Scattered option 
lets you simulate a greater-color image by dithering the pixels in a random fashion. The results you get 
from the Scattered option are similar to those you get when you print with the ScatterPrint option in the 
Print dialog box. The best results are usually obtained from the Scattered option. The None option does 
not dither the colors.

Palette List Box
The Palette list box lets you choose the System palette or the Optimized palette. The System option 
creates an image with colors equally spaced across the RGB color spectrum. An optimized palette 
contains colors based on the predominate colors in the original image, and can help you create better 
results when editing an image.

Related Topics
Procedure information



Converting an Image

Choose the Convert To command in the Image menu to change an image type.

To convert an image:

1. Open the file you want to convert.
2. Open the Image menu and choose Convert To. The Convert To submenu opens.
3. Choose a command. If you choose Palette Color, the Convert to Palette Color dialog box opens.
4. Choose the options you want, if available.
5. Click Convert. The image is converted.

Related Topics
Command information



Invert Command

The Invert command (Ctrl+I) reverses the colors of an entire image or portions of an image defined by a 
mask. A black-and-white image looks like a photo negative. A color image reverses using additive colors.

Related Topics
Procedure information



Inverting an Image

Choose the Invert command in the Image menu to reverse the colors of an image.

To invert an image:

· Open the Image menu and choose Invert, or press Ctrl+I.

Choose the Undo command in the Edit menu to reverse an effect created using the Invert command.

Related Topics
Command information



Stitch Command

The Stitch command offers a simple solution to the problems associated with piecing images together 
manually. With the Stitch command, you only need to scan different areas of the image so there is overlap 
in the images, choose two common points on both images, and click the Stitch button in the ribbon. 
Picture Publisher then creates a new image from the two smaller images.

Before you can use the Stitch command, you must have two open images in Picture Publisher that have 
an overlapping area. An overlapping area is an area where two images are identical. These images can 
be previously loaded images or images that you just scanned.

The Stitch command operates by aligning the image-based markers that you place on two images. You 
begin by placing the images side by side, so you can see the overlapping areas. Then place two identical 
points, one on each image, that are in the overlapping area. These first two points are indicated by small 
circular markers. Next, place two more identical points in the overlapping area. These second points are 
indicated by small square markers. You now have two images with one circular and one square marker 
on each image.

When the Stitch command begins working, it first overlays the top (circular) markers of the images. Only 
one of the images is transformed, and the other image remains unchanged.

It may be difficult to scan images so they are perfectly straight. This is not a problem with the Stitch 
command. The Stitch command rotates the transformed image so the bottom (square) markers of the two 
images are vertically aligned to each other, effectively making the two images perfectly aligned.

Next the Stitch command stretches the transformed image so it is the same size as the other image. Now 
all markers are aligned to each other. Because these markers are aligned, all other points between them 
are also aligned.

Lastly, the Stitch command can compare the brightness of the two images and make changes to the 
transformed image so it matches the other image. The Stitch command also can blend the adjoining 
edges of the images.

After the Stitch command performs all these operations, which are done automatically for you, it creates a 
new image composed of the two images.

Related Topics
Dialog Box information
Procedure information
Stitch Ribbon Options



Stitch Ribbon Options

When you choose the Stitch command (in the Filter tool set), the ribbon area changes to reflect options 
that are specific to this tool.

Locate buttons
The Locate buttons let you move the view of the active image so you can see the round or square 
markers if the markers have been placed but are not in view. If a marker has not been placed, the 
respective Locate button is grayed. If a marker is already in view, nothing happens when you click the 
Locate button.

Markers on Image area
The Markers on Image area lets you place or delete markers on the active image. It contains the filename 
of the images and circular and square marker buttons. If a circular or square marker button is in, the 
respective marker has been placed on the image. If it is out, it has not been placed on the image. To 
place a marker for the first time, you can either click a circular or square marker button or click the left 
mouse button on the active image. To remove a circular or square marker from the active image, click the 
circular or square marker button.

Adjust button
The Adjust button lets Picture Publisher automatically adjust the markers so they align to the exact pixel 
on both images. The markers initially must be placed within 10 pixels of each other in order for them to 
align successfully.

Stitch button
The Stitch button opens the Stitch Options dialog box. Click this button only after you have placed all four 
markers.

Related Topics
Tool information
Dialog Box information
Procedure information



Stitch Options Dialog Box

When you click the Stitch button in the ribbon area, the Stitch Options dialog box opens. This dialog box 
lets you choose additional options before the stitching operation begins.

Transform and Anchor Area
The Transform and Anchor area lets you select which image will be transformed. The green button 
indicates the image that will be transformed. The other image (the anchor) is unchanged.

Blend Seam Option
The Blend Seam option lets you blend the edges of the two images once they are stitched together. You 
can select the amount of blending that occurs when the Blend Seam option is selected by using the slider 
to select low, medium, or high pressure. The smaller the percentage, the lower the pressure.

Adjust Brightness Option
When selected, the Adjust Brightness option changes the brightness of the transformed image so it 
matches the other image. You can adjust the amount of brightness from -100 to 100 percent by typing a 
number or adjusting the slider.

High Quality Transform Option
The High Quality Transform option improves the quality of the image if it is rotated, scaled, or skewed 
during the transformation. This option makes the resulting image look less jagged.

Related Topics
Command information
Procedure information
Stitch Ribbon Options



Using the Stitch Command

Before you can use the Stitch command, you must open two images that have an overlapping area. You 
may find it easier to place the markers if the images are side by side; however, they do not have to be.

To stitch two images together:

1. Click the File menu and choose Open .
2. Locate the first file in the ImageBrowser dialog box and double click the filename. The first image 

opens.
3. Click the File menu and choose Open.
4. Locate the second file in the ImageBrowser dialog box and double click the filename. The second 

image opens.
5. Open the Image menu and choose Stitch. The ribbon area changes.
7. Click the title bar of the first image to make it active, if necessary.
8. Move the cursor to an overlapping point located in the upper part of the image.

Note: Each image must have two markers--a circular marker and a square marker. The circular markers 
must be on identical points in the overlapping area of the images. The square markers also must be on 
identical points in the overlapping area of the images. Typically, the square markers are below the circular 
markers, but they do not have to be.

9. Click the left mouse button. A circular marker appears.
10. Move the cursor to an overlapping point that is located in the lower part of the image.
11. Click the left mouse button. A square marker appears.

Note: To accurately locate each overlapping point, you may need to zoom in on an area of the image by 
using the Zoom tool. You can activate the Zoom tool by clicking the right mouse button.

12. Click the title bar of the second image to make it active.
13. Move the cursor to the point that corresponds to the circular marker in the first image.
14. Click the left mouse button. A circular marker appears.
15. Move the cursor to the point that corresponds to the square marker in the first image.
16. Click the left mouse button. A square marker appears.

Note: If you did not zoom in on your image to place markers, you can have Picture Publisher adjust the 
position of the markers by clicking Adjust. You also can move the markers by dragging them after they are 
placed.

17. Click Stitch. The Stitch Options dialog box opens.
18. Select the options you want in the dialog box.
19. Click Stitch. A new image opens that is composed of the other two images.

The stitched together images should have the same resolution.

The circular and square markers for an image should be placed as far apart as possible vertically so the 
rotation and scaling accuracy is as high as possible.

Related Topics
Command information
Dialog Box information
Stitch Ribbon Options



Effects Command

The Effects command open the EffectsBrowser dialog box and lets you choose from the many different 
effects supplied with Picture Publisher. The effects can be used on part of the image (defined by a 
selection) or the entire image.

You select an effect by choosing an effect name from the Effects area, setting the options for the effect, 
and clicking Apply. The effect is applied to your image. 

Related Topics
Dialog Box information
Procedure information



EffectsBrowser Dialog Box

The EffectsBrowser dialog box lets you choose special effects to apply to your image.

Image Effects List Box
The Image Effects list box contains the effects that are supplied with Picture Publisher.

Preview Area
When you choose an effect, the middle of the dialog box changes to reflect options that are available for 
that effect. To receive help on the effect, click the button at the top of the middle section of the dialog box. 
(The button has the name of the chosen effect.)

In/Out Button
If you have a selection on your image, you can use the In/Out button to limit the effects to inside the 
selection or outside the selection. The In/Out button toggles between In and Out when clicked. If the 
In/Out button it shows "In," the effects are constrained to inside the selection. If the In/Out button shows 
"Out," the effects are constrained to outside the selection. If there is no selection in the image, the In/Out 
button is grayed and the effect is applied to the entire image.

Preview Button
You also can preview the effect before applying it to your image by clicking the Preview button. The effect 
is applied to a small sample of your image and displayed in the preview area.

Reset Button
Click Reset to undo the previewed effect.

Apply Button
If you want to apply multiple effects to your image, you can use the Apply button. This button applies the 
current effect and the EffectsBrowser dialog box remains open so you can choose more effects. When 
you choose OK, the current effect and all other applied effects are applied to the image and the 
EffectsBrowser dialog box closes. If you have applied multiple effects to an image, but you have not 
clicked OK, you can click the Reset button to remove all effects without closing the EffectsBrowser dialog 
box.

Related Topics
Command information
Procedure information



Choosing Image Effects

To apply an image effect:

1. Open the Image menu and choose Effects. The EffectsBrowser dialog box opens.
2. Choose an effect in the Image Effects list box.
3. Set the options in the Preview area, if necessary.
4. Click Preview to preview the effect.
5. Click Apply.
6. Choose additional effects if you want, and click Apply after you choose each one.
7. Click OK. The effects are applied to the image and the EffectsBrowser dialog box closes.

Related Topics
Command information
Dialog Box information



Window Menu Commands

The Window menu contains commands that let you duplicate a window, show or hide elements of the 
window, open a scratchpad, arrange windows on the screen, and close all windows.

Duplicate Creates multiple frames of the same image.
Close Closes the current image window.
Close All Closes all open image windows.
Optimized Preview Lets you view color images with an optimized color palette.
Save Positions Lets you save the locations of al displayed windows and the active window.
Show/Hide Controls which program elements appear in the Picture Publisher window.
Arrange Manages all of the image windows displayed on screen.



Duplicate Command

The Duplicate command lets you create multiple frames of the same image. When you edit one frame, 
the changes appear in all of the frames, provided that they are duplicates of the active window (duplicated 
from the active open image). You can set each frame at a different magnification to see the effects of edits 
at various levels of detail.

The filename for each open image appears at the bottom of the Window menu, numbered in the order 
that they were opened, and the magnification is displayed unless the window has been minimized. The 
active window is identified by a check mark. Minimized images are represented by thumbnail icons at the 
bottom of the application window.

Related Topics
Procedure information



Duplicating a Window

Choose the Duplicate command in the Window menu to create a copy of the current image window.

To duplicate a window:

1. Select the image window you want to duplicate.
2. Click the Window menu and choose Duplicate. The image window is duplicated.

Related Topics
Command information



Close Command

The Close command closes the active image window.

Related Topics
Procedure information



Closing an Image Window

To close the active image window:

· Open the Window menu and choose Close.

If the image you are working with has been edited, and you did not save it before choosing the Close 
command, Picture Publisher requests that you select one of three choices: Yes, No, or Cancel.

· Yes saves changes to your image before closing the image window.
· No does not save changes to your image and closes the image window.
· Cancel cancels the Close command and returns you to the current image.

Related Topics
Command information



Close All Command

The Close All command lets you close all open image windows simultaneously.

Related Topics
Procedure information



Closing All Windows

To close all image windows:

· Click the Window menu and choose Close All. All image windows are closed.

Note: If you have edited any image, Picture Publisher asks you to save the image before closing.

Related Topics
Command information



Optimized Preview Command

If you are using a 256-color display (8-bit), the Optimized Preview command lets you view your color 
images with an optimized color palette. This improves the display quality of the image. The image file is 
not affected, only the way the image appears on your monitor. You cannot edit the image while you are 
viewing it in this mode.

Related Topics
Procedure information



Viewing an Image with an Optimized Color Palette

To view an image with an optimized color palette:

1. Open the Window menu and choose Optimized Preview. The screen redraws with an optimized 
screen palette and a clock appears.

2. Click the left mouse button (or any key) to return to the system color palette.

Note: If you are using a display other than a 256-color display, this command is disabled (grayed out).

Related Topics
Command information



Save Positions Command

The Save Positions command saves the locations of all displayed windows and the active image window. 
This allows you to permanently move such items as the Toolbox and QuickZoom window.



Show/Hide Command

The Show/Hide command in the Window menu lets you control which program elements appear in the 
Picture Publisher window. Choosing the Show/Hide command opens a submenu with the following 
commands.

Command Action

Show/Hide Info Displays and removes an information window used for precise applications such 
as aligning pixels, measuring sizes of areas within an image, and providing RGB 
values.

Show/Hide QuickZoom Displays and removes a view only window of the currently selected image. The 
window allows you to zoom in and out on the image in the currently active edit 
window.

Show/Hide Scratchpad Opens a blank image file.

Show/Hide Toolbox Displays or hides the toolbox.

Show/Hide Status Line Displays or hides the status line at the bottom of the screen.

Show/Hide Rulers Displays or hides rulers in the active image window.

Note: The scratchpad is helpful when you want to test a particular brush setting before applying it to your 
image. This is also a good place to create new colors, or blends, the same way a traditional artist uses a 
palette. Because the scratchpad acts like a regular image file, you can save any work you have done in it.

Related Topics
Procedure information



Using the Show/Hide Commands

To use a Show/Hide command:

1. Click the Window menu and choose Show/Hide. The Show/Hide submenu opens.
2. Choose one of the commands, as appropriate.

Note: If a command in the Show/Hide submenu is already displayed, the command reads "Hide" instead 
of "Show."

Related Topics
Command information



Arrange Command

The Arrange command lets you manage all of the image windows displayed on screen. You can cascade 
or tile the images for ease of viewing or selecting. You can also rearrange the thumbnail icons 
representing images that have been minimized.

Choosing the Arrange command opens a submenu with the following commands.

Command Action

Arrange Icon Images Spaces the thumbnail icons evenly across the bottom of the Picture Publisher 
window

Cascade Windows Overlaps the active image windows diagonally in the order that they were created

Tile Windows Fills the screen with the open image windows, adjusting their size to fit the 
Picture Publisher window's available space

Related Topics
Procedure information



Using the Arrange Command

To use an Arrange command:

1. Click the Window menu and choose Arrange. The Arrange submenu opens.
2. Choose one of the commands, as appropriate.

Related Topics
Command information



The Picture Publisher Toolbox

The toolbox gives you easy access to the tools you use most to change and enhance your image.

Click an icon below to read more information about the tool.

 Click the Selector tool to select individual or multiple objects for transforming, grouping, or 
deleting.

Click the Mask tool to open the Mask tool set.

Click the Retouch tool to open the Retouch tool set.

Click the Filter tool to open the Filter tool set.

Click the Fill tool to open the Fill tool set.

Click the Draw tool to open the Draw tool set.

Click the Custom View tool to change the view of an image.

Click the Text tool to select the Text tool.

Click the Color Probe tool to select an active color in the Color Swatch.

The toolbox puts your most frequently used tools at your fingertips. For example, to zoom in on your 
image, just click the Custom View tool (it looks like a magnifying glass) and then click anywhere within the 
image. That area of the image is magnified.

Tool options determine how a tool behaves. For example, while using a Draw tool you may decide to draw 
thick lines instead of thin. You would go to the ribbon area at the top of the window to increase the tip size 
of the Draw tool.

The tool options you choose remain active until you close Picture Publisher. If you want your new options 
to be the default for a particular tool, you will need to save them.

Related Topics
Choosing a tool
Hiding the toolbox
Moving the toolbox
Power keys
Saving tool settings
Color Swatch



Choosing a Tool

Some tools display a horizontal row of more specific tools when selected. This horizontal row is called a 
tool set. For example, clicking the Draw tool lets you choose from four different kinds of drawing tools 
(pencil, rectangle, ellipse, or freehand lines).

When you click the tool you want, this either activates the tool automatically or displays the tool set. For 
example, if you click the Color Probe tool, you are ready to probe an image for color. If you click the Draw 
tool, you then must choose which type of drawing tool you want.

Notice how the pointer changes to reflect the tool you chose when you move it over an active image. For 
example, the pointer changes to a magnifying glass when you select the Custom View tool and move it 
over the image.

Note: Move the pointer over the toolbox and watch the hint line at the bottom left corner of the screen. It 
gives you a one-line help message about each tool as you pass over it.

Related Topics
Picture Publisher toolbox



Moving the Toolbox

To move the toolbox:

1. Move the pointer to the bar at the top of the toolbox.
2. Press and hold Button 1, and drag the toolbox outline to a new location.
3. Release Button 1.

Related Topics
Picture Publisher toolbox



Hiding the Toolbox

To hide the toolbox:

1. Click the Window menu and choose Show/Hide. The Show/Hide submenu opens.
2. Choose Hide Tools. The toolbox disappears. To restore the toolbox, repeat step 1 and choose 

Show Tools.

Related Topics
Picture Publisher toolbox



Saving Tool Settings:

To save tool settings:

1. Click the tool and change the options in the ribbon area.
2. Click the Tool button at the left side of the ribbon area. A dialog box opens, asking whether you 

want to save your preferences.
3. Click OK. The new options now appear whenever you select this tool.

Related Topics
Picture Publisher toolbox



Power Keys

Power keys can speed up your image editing by letting you change tool settings without moving to the 
ribbon area. Power keys can be used with any applicable tool.

Ctrl Keys
Press Ctrl+Left Arrow or Ctrl+Right Arrow to change the tip or brush styles without using the ribbon 
area.

Press Ctrl+Up Arrow to decrease or Ctrl+Down Arrow to increase the size of the tip or brush styles 
without using the ribbon area.

Press and hold Ctrl while drawing to force a horizontal or vertical line.

Esc Key
Press Esc while you are drawing shapes to undo what you have drawn. You must press Esc before 
releasing Button 1.

Shift Key
Press and hold Shift to constrain a shape during drawing. For example, press and hold Shift while 
drawing a rectangle to force a square. Press and hold Shift while drawing an ellipse to force a circle.

Related Topics
Picture Publisher toolbox



Color Shield Button

Click the Color Shield button in the status bar to open the Color Shields dialog box.

Related Topics
Using the Color Shields



Color Shields Dialog Box

The Color Shields dialog box lets you choose which selected or nonselected colors you want to edit.

Select Colors option
The Select Colors option lets you choose whether to edit selected or nonselected colors or protect 
selected colors and edit all others.

Method area in the ribbon area
The Point Sample option lets you select a color directly below the pointer. When you move the pointer 
over an image, the color in the Color Shields dialog box reflects the color under the pointer.

The Rectangular Average option lets you draw a rectangle over an image. When you draw a rectangle 
over an image, an average of all colors within the rectangle is reflected in the Color Shields dialog box.

Related Topics
Button information
Procedure information



Using the Color Shield

Use the Color Shield tool to protect selected colors of an image.

To use the Color Shields:

1. Click the Color Shield button in the status line. The pointer changes to a shield and crosshairs. 
The Color Shields dialog box opens, and shows only the colors selected with the Color Shield 
tool.

2. Click the button to the left of the shield in the Color to Edit area. Eight shields are available in the 
Color Shields dialog box.

3. Press and hold Button 1, and drag the pointer over the image to define the color to shield. Be 
sure to stay within the area where the color is dominant.

4. Release Button 1. The color is displayed in the selected Color to Edit box.
5. Type a range percentage in the Range Percent data box to define how close the shielded color 

will be to the chosen color. A 0% setting shields only an exact color match; a 100% setting shields 
all colors. The default setting is 10%.

Note: A high range percentage includes many colors similar to the selected color; a lower percentage 
restricts the colors to only those closest to the selected color.

Note: The percent range is based upon the RGB color model. It defines the deviation from the RGB 
values of the color defined in the shield. A 100% setting protects or selects all color values in the image. A 
5% setting allows a tolerance of plus or minus 5% from the defined RGB value. A 0% setting limits the 
shield to a single RGB value.

6. Repeat steps 3 through 6 to define additional shields.
7. Click the down arrow in the dialog box and click either the Protect Colors or Select Colors option 

in the list box. The Protect Colors option protects the selected color ranges from edits; the Select 
Colors option targets the color ranges for edits.

8. Click the On/Off boxes in the dialog box to activate each color shield. The color values are 
selected or protected for use with all editing tools.

Related Topics
Button information
Dialog Box information



Information Button

Click the Information button in the status bar to open the Image Information dialog box, which displays 
specific information about the open image.

Related Topics
Dialog Box information



Image Information Dialog Box

The Image Information dialog box displays information about the open image. The information includes 
filename, file type, width, height, resolution, image size, status of the image, and memory remaining.

Click OK to return to the active image window.

Related Topics
Button information



Ruby Overlay Button

The Ruby Overlay button simulates the thin plastic sheets used to cut overlays on artwork.

Click the Ruby Overlay button to display the overlay on your base image. The color of the overlay is red 
by default. You can change the color with the Mask Tint Color option in the Miscellaneous section of the 
Preferences dialog box.

The color of the Ruby Overlay shows the areas of an image not masked. If you have a complex mask, the 
Ruby Overlay makes it easier to see what is masked and what is not.

When working with Mask Channel you can see how your mask fits on the image by turning on the ruby 
overlay. By working with the ruby overlay on, you can make sure the mask you are creating matches up 
with your image. 



Mask Channel Button

To display the mask channel, click the Mask Channel button in the status line.

The Mask Channel contains a grayscale image of any mask you create with the Mask tools from the 
toolbox. You can work directly on the mask channel and edit the mask directly.

With the Mask Channel displayed, you can use any of the toolbox tools, plus most of the commands in 
the menu to create and manipulate a mask.

For example, you can paste images into the Mask Channel and use any of the Mask Transform tool 
options to manipulate the image.

When working with the Mask Channel you cannot see the base image unless you click the Ruby Overlay 
button in the status line to turn it on.

To create and edit masks as grayscale images on the Mask Channel:

1. Click the Mask Channel button to open the Mask Channel.
2. Choose any of the toolbox tools to edit the image in grayscale only.
3. Paste an image and manipulate it using the options in the Mask Transform ribbon.
4. View how the mask fits on the base image by turning on Ruby Overlay mode.
5. Click the Mask Channel button to close the Mask Channel.

Related Topics
Ruby Overlay mode



Mask Tools

The Mask tools let you select, or mask, areas of an image so that you can edit one area without affecting 
another.

Click an icon below to read more information about the tool.

Click the Rectangular/Elliptical Mask tool to create a rectangular/square or elliptical/circular mask.

Click the Freehand Mask tool to create a custom mask.

 Click the Paint on Mask tool to create an irregularly shaped mask by using paint brushes on 
areas you want to mask.

Click the Smart Mask tool to automatically draw a mask.

Click the Mask Transform tool to move, rotate, skew, or change the size and shape of a mask.

Click the Mask Point Editing tool to change the shape of a mask by moving, adding, or deleting 
points on a mask.

You can use masks to isolate your editing and retouching. You can also use masks to outline areas for 
cutting and copying to create montages. Finally, you can copy masked areas from one place in an image 
to another place in the same image, or into other images or applications.

An outline shows the shape of the mask as you create it. This shape displays as a "marquee" when you 
are finished drawing the mask. The marquee is identified by a moving black and white border on color 
images, and a moving green and red border on grayscale and line art images.

Note: The mask's size and location (relative to where you begin drawing) are shown at the bottom left 
corner of the window as you create the mask.

After you create a mask, you can select which area to protect (the area inside or outside the mask) by 
clicking the In/Out button in the status bar at the bottom of the window.

You can remove all of the masks in the active window by opening the Mask menu and choosing the 
Remove command.

To remove masks individually, use the Mask Transform tool.

The Mask tools are modeled after graphic design and photographic masking tools. For example, the icon 
for several of the Mask tools is a razor knife, a common tool for creating cardboard or film masks.



Rectangular Mask Tool

The Rectangular Mask tool lets you create a rectangular or square mask.

The Rectangular Mask tool creates both rectangles and squares. You'll find this tool especially useful for 
cropping images.

Related Topics
Procedure information
Rectangular Mask options



Rectangular Mask Options

When you choose the Rectangular Mask tool, the ribbon area changes to reflect options specific to this 
tool.

Mode Area
The Mode area provides the Additive, Subtractive, and Reversal modes for masks. The Additive button 
(+) lets you draw an area to add to a part of an existing mask. The Subtractive button (-) lets you draw an 
area to add to part of an existing mask. The Reversal button (+/-) lets you add to the area where mask 
borders touch but do not overlap, and subtract from the area where the mask borders overlap.

Shape List Box
The Shape list box lets you choose whether you want to create rectangular or elliptical masks. Click the 
down arrow in the list box, then click the rectangular or elliptical shape to choose mask shape.

Method List Box
The Method list box describes the constrained proportions you give a finished mask.

Choose Freeform to draw the mask without constraints. Choose Constrain Aspect to draw a mask with a 
specific width to height ratio. Enter the ratio in the Width and Height edit boxes. Choose Constrain size to 
draw a mask of a specific size. Enter the sizes in the Width and Height edit boxes. Choose the units of 
measure from the Units drop-down combo box.

Note: You can press and hold Shift to draw a mask from the center of the window. To constrain the mask 
press and hold Ctrl. Press and hold Shift and Ctrl to constrain and draw from the center of the window.

Related Topics:
Tool information
Procedure information



Creating a Rectangular or Square Mask

To draw a rectangular or elliptical mask:

1. Click the Mask tool in the toolbox to open the Mask tool set.
2. Click the Rectangle/Ellipse Mask tool.
3. Click a mask mode.
4. Choose a shape for the mask (rectangular or elliptical).
5. Choose a method for the mask.

If you choose Constrain Aspect or Constrain Size, type values for the Width and Height and 
select units.

6. Click where you want to start the mask and drag to create the mask.
7. When the mask is the size and location you want, release the left mouse button to display the 

mask.

Press and hold the right mouse button and move the mouse to reposition the mask while you are drawing 
it.

Related Topics
Tool information
Rectangular Mask options



Freehand Mask Tool

The Freehand Mask tool lets you create a custom mask by manually tracing an outline of the area you 
want to mask.

You can draw a freehand mask one point at a time (by clicking the left mouse button), or you can press 
and hold the left mouse button while dragging the pointer (as if you were drawing with a pencil).

Related Topics
Procedure information
Freehand Mask options
Automasking



Freehand Mask Options

When you choose the Freehand Mask tool, the ribbon area changes to reflect options specific to this tool.

Mode Area
The Mode area provides the Additive, Subtractive, and Reversal modes for masks. The Additive button 
(+) lets you draw an area to add to a part of an existing mask. The Subtractive button (-) lets you draw an 
area to add to part of an existing mask. The Reversal button (+/-) lets you add to the area where mask 
borders touch but do not overlap, and subtract from the area where the mask borders overlap.

Method List Box
Click the down arrow in the Method list box to display the following choices: Freehand, AutoMask, and 
Point Edit.

Choose Freehand to draw a mask without constraints.

Choose AutoMask to draw a mask semi-automatically along color break lines. This allows you to trace 
parts of the image distinguished by their color.

Choose Point Edit to edit, add and delete points in a mask. 

The AutoMask option displays the following additional options related to automasking only. 

Color Model List Box
Use this list box to choose a color model to use for creating the mask. For example, if all hues in the mask 
are similar, but there is a wide range of lightness and darkness you might want to use the HSL model to 
draw the mask.

Sensitivity Area
Lets you determine the amount of change in color Picture Publisher uses to trace the mask. If all colors 
are very similar you may want to use a small number so the mask does not expand to too much. A high 
sensitivity gives you more precision, but requires more time to create the mask.

Min. Line Length Area
Lets you determine the minimum line length in pixels Picture Publisher can draw when automasking.

The Point Edit option displays the following additional options related to point editing only.

Bézier Curve Button      
Click this button to activate a Bézier curve editing tool for the selected point. This allows you to curve the 
lines on each side of the point.

Move Point Button      
Click this button to move points in a mask. Do this by dragging a point.

Add Point Button      
Click this button to add points to a mask. Do this by clicking on the marquee between two existing points.

Note: To toggle betwee Add Point mode and Move Point mode, press and hold Shift.

Delete Point Button      
Click this button to delete a point on a mask.



Related Topics
Tool information
AutoMasking



Creating a Freehand Mask

To draw a freehand mask:

1. Click the Mask tool in the toolbox. The Mask tool set opens.
2. Click the Freehand Mask tool. The pointer changes to a razor knife.
3. Select a Mode.
4. Choose a Freehand Method.
5. Click where you want to start the mask and drag to create the mask.
6. When the mask is the size and location you want, release the left mouse button to display the 

mask.

If you make a mistake, press Backspace to delete the last line segment.

Place the last point near the first point before closing the mask. This helps you avoid an unwanted line.

Related Topics
Tool information
Freehand Mask options
AutoMasking



AutoMasking

AutoMasking is a feature of the Freehand Mask that senses the edge of an area by detecting a color 
break, then automatically tracing it.

AutoMasking is used in conjunction with the Freehand Mask tool to create mask outlines in irregular 
areas. This powerful tool has adjustable sensitivity. It can detect the edge of an element based on the 
actual image data, rather than relying on a visual interpretation of a screen display.

Related Topics
Procedure information



Creating a Freehand Mask using AutoMask

To draw a mask using AutoMask:

1. Click the Mask tool in the toolbox. The Mask tool set opens.
2. Click the Freehand Mask tool. The pointer changes to a razor knife.
3. Choose the AutoMask option in the Method list box in the ribbon area.
4. Choose a mask mode.
5. Set the Sensitivity and Minimun Line Length.
6. Click where you want to begin the mask.
7. Drag the pointer and guideline a short distance (about 1/4 to 1/2 inch) along an edge of the 

image, and click. AutoMask automatically traces that edge of the image, approximating the 
guideline.

8. Repeat step 7 until the image is almost completely traced.
9. Double click to close the mask.

If AutoMask can't find a distinct edge, the mask might draw unpredictably. If this happens, click the left 
mouse button to stop the mask from drawing, then press Backspace repeatedly until you return to a good 
outline. Change to the Freehand option by pressing and holding Shift then manually outlining the difficult 
area (the area with no distinct edges).

Related Topics
AutoMask information



Paint On Mask Tool

The Paint On Mask tool lets you create an irregularly shaped mask by painting on areas you want to 
mask.

Related Topics
Procedure information
Paint On Mask options



Paint On Mask Options

Mode Area
The Mode area provides the Additive, Subtractive, and Reversal modes for masks. The Additive button 
(+) lets you draw an area to add to a part of an existing mask. The Subtractive button (-) lets you draw an 
area to add to part of an existing mask.

Paint On List Box
Image Mask is the only option available. You can paint a mask directly onto an image.

Brush Area
Lets you choose a brush shape. You can also choose the Custom command to open the Select Custom 
Brush dialog box.

Size Area
Lets you choose a brush size.

Feather Area
Lets you enter the amount to feather.

Related Topics
Procedure information
Tool information



Painting on a Mask

To paint on a mask:

1. Click the Mask tool in the toolbox. The Mask tool set opens.
2. Click the Paint On Mask tool.
3. Select a mask mode.
4. Choose a brush shape and enter a brush size.
5. Click where you want to start the mask and drag to create the mask.
6. When the mask is the size and location you want, release the left mouse button to display the 

mask.

Related Topics
Tool information
Paint On Mask options
Creating a custom brush 



Select Custom Brush Dialog Box

Custom Brush Name Text Box
Type a name for the custom brush you want to create.

Open Editing Window Option
Choose this option to open an editing window to create the custom brush.

Related Topics
Creating a custom brush 



Creating a Custom Brush

To create a custom brush:

1. Click the Mask tool in the toolbox. The Mask tool set opens.
2. Click the Paint On Mask tool.
3. Click the down arrow in the Brush area and choose Custom. The Select Custom Brush dialog box 

opens.
4. Type a name for the custom brush.
5. Choose the Open editing window option and click OK. An editing window opens that is 99 pixels 

by 99 pixels in size. 
6. Create the brush in the editing window using the drawing tools.
7. Open the File menu and choose Save to save the custom brush.



Smart Mask Tool

The Smart Mask tool automatically draws a mask by sensing color breaks within the image and masking 
between them.

The Smart Mask tool is most effective when the contrast or color break is strong at the edge of the area to 
be masked. For example, the Smart Mask tool is useful for masking black letters when they are displayed 
on a white background.

Related Topics
Procedure information
Smart Mask options



Smart Mask Options

When you choose the Smart Mask tool, the ribbon area changes to reflect options specific to the tool.

Mode Area
The Mode area provides the Additive, Subtractive, and Reversal modes for masks. The Additive button 
(+) lets you draw an area to add to a part of an existing mask. The Subtractive button (-) lets you draw an 
area to add to part of an existing mask. The Reversal button (+/-) lets you add to the area where mask 
borders touch but do not overlap, and subtract from the area where the mask borders overlap.

Wand Range Area
The Wand Range area in the ribbon area determines the sensitivity of the Smart Mask tool to color 
differences. As the wand range percentage increases, the area of color that will be included in the mask 
becomes larger. If you choose a 10% setting, the mask surrounds colors that are within 10% of each 
other (for example, yellow plus or minus 10%). The percentage is the proximity in the RGB color model.

Color Model List Box
Lets you choose color model to use for creating the mask. For example, if all hues in the mask are similar 
but there is a wide range of lightness and darkness you might want to use the HSL model to draw the 
mask.

Similar Button 
Lets you mask similar colors through the image.

Expand Area
Lets you increase the size of the mask by a percentage amount.

Note: The Similar button and the Expand area are only available after you have applied a smart mask.

Related Topics
Tool information
Procedure information



Using Smart Mask

To use the Smart Mask tool:

1. Click the Mask tool in the toolbox. The Mask tool set opens.
2. Click the Smart Mask tool. The pointer changes to a magic wand.
3. Choose a mask mode.
4. Enter a value from 0% to 100% in the Wand Range area in the ribbon area.
5. Select a color model.
6. Click inside the area of the image to be masked. A mask marquee appears.

Note: You can delete your masks by opening the Mask menu and choosing the Remove command or 
opening the Edit menu and choosing the Undo command.

Related Topics
Tool information
Smart Mask options



Mask Transform Tool

The Mask Transform tool lets you copy or move the mask only or both the mask and the image inside the 
mask.

Related Topics
Procedure information
Mask Transform options



Mask Transform Options

When you select the Mask Transform tool, the ribbon area changes to reflect options specific to this tool.

Modify List Box
The Modify list box displays the options for choosing what you want to transform.

Choose Copy Mask to duplicate the mask without changing the image. Choose Move Mask to move the 
mask without changing the image. Choose Copy Image to duplicate the mask and the image inside the 
mask; this is also similar to copying and pasting an image. This creates an object if objects are enabled in 
the Preferences dialog box. Choose Move Image to move the mask and the image inside the mask; this 
is similar to cutting and pasting the image. This creates an object if objects are enabled in the 
Preferences command dialog box.

After selecting a Modify option, drag a selection rectangle around the area you want to transform. If you 
include one or more entire masks, Picture Publisher modifies the box size to include just those masks. 
Drawing the rectangle around just a part of the mask selects the partial mask.

When you choose a mask to transform, the ribbon area changes, and displays the following options.

Mode Area
The Mode area provides the Additive, Subtractive, and Reversal modes for masks. The Additive button 
(+) lets you draw an area to add to a part of an existing mask. The Subtractive button (-) lets you draw an 
area to add to part of an existing mask. The Reversal button (+/-) lets you add to the area where mask 
borders touch but do not overlap, and subtract from the area where the mask borders overlap.

Transformation List Box
Choose a type of change to make to the selection from this list box. After choosing a transformation type, 
you can drag one of the handles on the bounding box surrounding the selection to perform the 
transformation. The transformation choices are: Scale, Skew, Perspective and Distort.

Choose Scale to change the height and width of the selection. Drag a corner handle to enlarge or shrink 
the selection using its current aspect ratio. Drag an edge handle to move just the height to width.

Choose Skew to slant the selection. Drag a corner handle or a top and bottom edge handle to skew the 
selection left or right. Drag an edge handle to skew the selection up or down.

Choose Perspective to add a three-dimensional appearance to the selection. Dragging a corner handle in 
one direction moves the opposite corner handle an equal distance in the opposite direction.

Choose Distort to stretch the selection as if it is a rubber sheet. Each corner handle operates 
independently of the others.

Rotation Buttons
Click a Rotation button rotate the masked area. Click the Rotate Normal button to rotate the selection flat, 
as if you are looking down on a spinning disk.

Click the Rotate X button to rotate the selection by pushing the top back and pulling the bottom forward, 
or vice versa, as if you are turning a barbeque spit. This rotation is actually from a 45 degree angle.

Click the Rotate Y button to rotate the selection by pushing the left back and pulling the right forward, or 
visa-versa, as if you are turning a revolving door. This rotation is actually from a 45 degree angle.

Note: A rotation tool resides in the middle of the bounding box surrounding the selection. The rotation tool 
consists of a circle marking the pivot point, a square marking the rotation handle, and a line connecting 
the two. You rotate the selection by dragging the handle. Dragging the pivot point allows you to change 



the center of rotation. You can change the sensitivity of the rotation tool by dragging the handle closer to 
or further away from the pivot point. The tool becomes less sensitive as you drag the handle further away. 
This simply means you must drag the handle more to rotate the image.

Flip Buttons
Click a Flip button to select a type of mirroring. Pressing the button in enables mirroring. Pressing the 
button to release it removes the mirroring, The buttons are: Horizontal to mirror the selection horizontally 
and Vertical to mirror the selection vertically.

Quality Area
Choose the High option in this area to provide high quality, but slower, processing when altering objects.

Related Topics
Tool information
Procedure information



Using Mask Transform

To use the Mask Transform tool:

1. Click the Mask tool in the toolbox. The Mask tool set opens.
2. Click the Mask Transform tool. The Mask Transform options display in the ribbon area.
3. Draw a rectangle around the mask you want to modify, or click on the image to select all masks. 

The pointer changes to a four-headed arrow. A mask edit box with handles (points) replaces the 
marquee box.

4. Choose the options you want.
5. Double click the left mouse button to anchor the edited mask.

Note: You can delete a mask by selecting it while using the Mask Transform tool and pressing Del.

Note: You can press Esc at any time during this process to exit the transform mode.

Related Topics
Tool information
Mask Transform options



Mask Point Editing Tool

The Mask Point Editing tool lets you change the shape of a mask by moving, adding, or deleting points on 
the mask.

The Mask Point Editing tool lets you fine-tune a mask by adjusting its individual points. The tool is 
especially useful when you need to make minor changes to a mask.

Related Topics
Procedure information
Mask Point Editing option



Mask Point Editing Options

The Mask Point Editing tool lets you fine-tune a mask by adjusting its individual points. The tool is 
especially useful when you need to make minor changes to a mask.

Mode Area
The Mode area provides the Additive, Subtractive, and Reversal modes for masks. The Additive button 
(+) lets you draw an area to add to a part of an existing mask. The Subtractive button (-) lets you draw an 
area to add to part of an existing mask. The Reversal button (+/-) lets you add to the area where mask 
borders touch but do not overlap, and subtract from the area where the mask borders overlap.

Min. Line Length Area
Lets you choose the minimum line length that the program will allow between points when creating the 
shape.

Tolerance Area
Lets you choose the maximum curvature the program will allow when converting to line segments.

Bézier Curve Button      
Click this button to activate a Bézier curve editing tool for the selected point. This allows you to curve the 
lines on each side of the point.

Move Point Button      
Click this button to move points in a mask. Do this by dragging a point.

Add Point Button      
Click this button to add points to a mask. Do this by clicking on the marquee between two existing points.

Delete Point Button      
Click this button to delete a point on a mask.

Related Topics
Tool information
Procedure information



Using the Mask Point Editing Tool

To use the Mask Point Editing tool:

1. Click the Mask tool in the toolbox. The Mask tool set opens.
2. Click the Mask Point Editing tool.
3. Choose a mask mode.
4. Enter for values for Min Line Length and Tolerance.
5. Click the left mouse button on the image or drag a rectangle around the masks you want to affect.

Related Topics
Tool information
Mask Point Editing option



Crop Tool

The Crop tool lets you reduce the size of an image by selecting a rectangular part you want to keep and 
discarding the rest.

Related Topics
Procedure information 
Crop tool options 



Crop Tool Options

Method List Box
Choose Freeform to draw the cropping rectangle without constraints. Choose Constrain Aspect to draw a 
cropping rectangle with a specific width to height ratio. Enter the ratio in the Width and Height edit boxes. 
Choose Constrain size to draw a cropping rectangle of specific size. Enter the sizes in the Width and 
Height edit boxes. Choose the units of measure from the Units list box.

Note: The cropping rectangle's size and location (relative to where you began drawing) are shown in the 
Status line as you create the mask.

Related Topics
Tool information
Crop tool options 



Using the Crop Tool

To draw a cropping rectangle:

1. Click the Mask tool in the toolbox to open the Mask tool set.
2. Click the Crop tool.
3. Choose a mask meethod.

If you choose Constrain Aspect or Constrain Size, type values for the Width and Height and 
select units.

4. Click where you want to start the cropping rectangle. Press the right mouse button to move the 
rectangle while you are drawing it. In free form and constrain aspect, you drag a rectangle; in 
constrain size, you position a box.

5. When the rectangle is the size and location you want, release the left mouse button to crop the 
image.

Related Topics
Tool information
Crop tool options 



Retouch Tools

The Retouch tools let you enhance your image by retouching only the areas that need improvement.

The Retouch tools achieve results like the effects achieved by using airbrush, markers, and pastels in 
traditional artwork. Three of the five retouch tools (Paint, Airbrush, and Smear) simulate conventional art 
or paint on canvas.

The Clone tool, unique to computer graphics, lets you duplicate a portion of your image in a different 
location. The Texture tool lets you paint with a texture selected from a library of texture images or from 
your own image textures.

Click an icon below to read more information about the tool.

Click the Paint tool to apply a color or shade of gray to an image.

Click the Airbrush tool to "spray" paint on an image.

Click the Clone tool to copy a portion of an image to another part of the image.

Click the Texture tool to add a texture to an image.

Click the Smear tool to blend colors in an image.

 Click the Eraser tool to erase changes that have not yet been applied or saved. 

You can use Retouch tools with masks and color shields, like a conventional artist uses friskets (masks) 
to protect selected areas during retouching.

Note: The Retouch tools that apply color (Paint and Airbrush) use the Color Swatch's active color.

Related Topics
Retouch tool options



Retouch Tool Options

The Retouch tool options determine how the Retouch tools work. You can select different options for each 
tool. For example, the options you choose for the Airbrush tool do not affect the settings for the Clone 
tool. These options are in the ribbon area at the top of the window. The options common to each tool are 
described below.

Brush Style List Box
This list box lets you choose the artist tool to simulate, such as chalk, crayon, or pencil. Some styles are 
unique computer graphics, such as erase to white, and erase to background. The options available 
depend on the tool selected.

File Options Button
Click the File Options button to open a submenu that lets you edit, delete, and rename brush styles.

Brush Option
The Brush option lets you choose how the brush applies the stroke. For example, you can choose a 
round or square brush, or you can use a custom brush chosen from a library of brush shapes.

Note: You also can change the brush shape by pressing Ctrl+Right or Ctrl+Left Arrow.

Size Option
The Size option lets you change the size of your brush. Brush sizes range from 1 to 99, with a higher 
setting giving a larger brush.

Note: You also can change the brush size by pressing Ctrl+Up Arrow or Ctrl Down Arrow.

Style Option
The Style option gives you two choices of application patterns: solid or scattered. The solid brush style 
applies a solid color to the image. The scattered style applies color with an irregularly dotted pattern.

Feather Option
The Feather option softens the outer edge of your brush stroke by making the edges fuzzy. Feathering a 
brush stroke can help it blend into an image.

Increase the number to increase the blurriness of the edge; decrease the number to sharpen the edge. 
Set the Feather option to "0" to turn the option off. This option ranges from 0 to 99 (where a setting of 100 
feathers 100% of the brush size).

If the Feather setting is 100, you get a continuous transition from the fill color through the outline color to 
the adjacent background color. This can create an interesting color blending effect.

Transparency Option
The Transparency option lets you determine the transparency of your brush stroke. At 0% transparency, 
the paint stroke is completely opaque; at 99% transparency, the stroke is completely transparent, or 
invisible.

Merge Mode List Box
This list box contains various editing options. When used in conjunction with editing tools, such as Paint 
or Fill, these options let you combine, or mix, colors using additive or subtractive color theory. You also 
can selectively change an image according to hue, saturation, or lightness and make modifications to the 
red, green, or blue channel of an image.

The Normal option is the default setting in the Merge Mode list box. When Normal is selected, Picture 



Publisher behaves as if Merge Mode is off, and no editing effects are possible.

The Additive option lets you mix colors according to the additive color model. If you paint a red image 
with a blue brush, magenta appears in the image as a result of the additive mixing of red and blue. If you 
paint with a green brush on a red background, you get yellow. To calculate the resultant color, simply add 
the RGB values of the colors together and round down any number over 100 to 100.

An example of additive mixing using green and blue is shown below.

Green R(0) G(100) B(0)
Blue R(0) G(0) B(100)

--------------------------------
Cyan R(0) G(100) B(100)

Adding the R column results in 0, adding the G column results in 100, and adding the B column results in 
100. These values represent a color (cyan) that has the value of R(0), G(100), B(100).

Note: Be sure to adjust all numbers so they do not exceed 100. For example, if the total of the B column 
adds to 140, round the value down to 100.

The Subtractive option lets you mix colors according to the subtractive color model. If you paint on a 
cyan image with a magenta brush, blue appears in the image as a result of the subtractive mixing of cyan 
and magenta. If you paint with a yellow brush on a magenta background, you get red. To calculate the 
resultant color, add the RGB values of the colors together, subtract 100 from the answer, round any 
negative value to 0, and round any number over 100 to 100.

An example of subtractive mixing using cyan and magenta is shown below.

Cyan R(0) G(100) B(100)
Magenta R(100) G(0) B(100)

--------------------------------
R(100) G(100) B(200)

-100 -100 -100
--------------------------------

Blue R(0) G(0) B(100)

Adding the R column results in 100, adding the G column results in 100, and adding the B column results 
in 200. Subtract 100 from the resultant R, G, and B values. These ending values represent a color (blue) 
that has the value of R(0), G(0), B(100). Be sure to adjust all numbers so there are no negative numbers 
and no values over 100. For example, if the B column is -20, round the value to 0; if the B column is 140, 
round the value down to 100.

The If Lighter option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value equal to, or higher than that of the image, the 
color of the editing tool is transferred to the image. If the lightness value is not equal to or less than that of 
the image, no change occurs. For example, if you are painting with white (white has a lightness value of 
100), all of the colors in the image are affected. If you paint with black (black has a lightness value of 0), 
none of colors in the image are affected. Notice that any primary color will paint over any other primary 
color (except white) because all primary colors have the same lightness value (except black, which has 
the lowest lightness value, and white, which has the highest lightness value).

The If Darker option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value lower than that of the image, the color of the 



editing tool is transferred to the image. If the lightness value is not lower than the image, no change 
occurs. For example, if you paint with white (white has a lightness value of 100), none of the colors in the 
image are affected. If you are painting with black (black has a lightness value of 0), all of the colors in the 
image are affected.

The Filter option uses a combination of Additive and Multiply to create a filtered effect.

The Multiply option multiplies the value of the image and the editing tool colors.

The Difference option subtracts the value of the editing tool from the value of the existing color to obtain 
a new color.

The Texturize option uses the editing tool as a texture surface on which the image is painted.

The Color option lets you replace the color of an image with the color of the editing tool, or source, used. 
Color is composed of the "H," or hue value, and the "S," or saturation value, in the HSL color model. For 
example, if you are painting with blue (H=240, S=100), all of the painted colors take on the same H and S 
values of blue. This results in a color change; however, the lightness values remain the same.

Note: Hue and saturation values have no affect on black or white. This is because the lightness value of 
black is 0 and the lightness value of white is 100. Any color with the lightness value of 0 is black 
regardless of the hue and saturation values. Any color with the lightness value of 100 is white regardless 
of the hue and saturation values.

The Hue option lets you replace the hue value of an image with the hue value of the editing tool, or 
source, used. For example, if you are painting with green (H=120), all colors (except white and black) that 
are painted become green. Notice that if you paint with red, white, or black, you get the same results. This 
is because all three of these colors have the same hue value (H=0).

The Saturation option lets you replace the saturation value of an image with the saturation value of the 
editing tool, or source, used. For example, if you are painting with any primary color (except white or 
black) onto any other primary color, only white and black are affected; the other colors remain the same. 
This is because all primary colors have the same saturation value (S=100), except for white (S=0) and 
black (S=0). If you are painting with white or black, the colors become grayscale values; remember that 
grayscale images have no saturation.

The Luminance option lets you replace the luminance value of an image with the lightness value of the 
editing tool, or source, used.

The Red option lets you replace the red channel (using the RGB color model) of an image with the value 
of the red channel source. Only the red channel is affected. The results from using the Red Only option 
are the same as if you were to split the RGB channels using the Channels command, make changes to 
the red channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the red 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 0, 0, 
100 (blue). The red value from the brush (0) replaces the red value in the image (100) to create blue.

The Green option lets you replace the green channel (using the RGB color model) of an image with the 
value of the green channel source. Only the green channel is affected. The results from using the Green 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the green channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the green 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 



100) over a red image (RGB value = 100, 0, 0), the result is a color that has an RGB value of 100,100, 0 
(yellow). The green value from the brush (100) replaces the green value in the image (0) to create yellow.

The Blue option lets you replace the blue channel (using the RGB color model) of an image with the 
value of the blue channel source. Only the blue channel is affected. The results from using the Blue 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the blue channel image, and then combine the channels.

To determine the resulting value of mixing the source and image, replace the image value of the blue 
channel with the source value. For example, if you are painting with a green brush (RGB value = 0, 100, 
0) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 100, 0, 
0 (red). The blue value from the brush (0) replaces the blue value in the image (100) to create red.

Related Topics
Retouch tools



Paint Tool

The Paint tool lets you apply a color or shade of gray to an image like paint to a canvas. You can also use 
the Paint tool to paint or retouch portions of your image.

Related Topics
Procedure information
Retouch tool options



Using the Paint Tool

Use the Paint tool to add paint to your image.

To use the Paint tool:

1. Select the active color with which you want to paint. The active color appears in the Color Swatch 
at the bottom of the toolbox.

2. Click the Retouch tool in the toolbox. The Retouch tool set opens.
3. Click the Paint tool. The pointer changes to the brush shape selected in the ribbon area.
4. Set the paint options in the ribbon area, if necessary.
5. Press and hold the left mouse button, and drag the pointer across the image. The speed with 

which you drag the pointer affects the appearance of the paint.
6. Release the left mouse button when you complete painting.
7. Repeat steps 5 and 6 to apply additional paint to the image.

You can achieve greater control if you keep the brush size small, use a transparency setting or the feather 
feature, and make slow and steady brush movements. This allows you to add color gradually for more 
precise image editing.

Note: Press and hold the right mouse button, and drag the pointer to erase your most recent edit.

Related Topics
Tool information



Airbrush Tool

The Airbrush tool applies a color as a spray can or an airbrush does. The degree of coverage is 
determined by how long the spray is applied to the area and how high you set the (air) pressure. Use this 
tool for blending and retouching.

The Airbrush tool offers an option to control pressure in addition to other brush options. Choose low 
pressure for light coverage or high pressure for heavy coverage.

Related Topics
Procedure information
Retouch tool options



Using the Airbrush Tool

Use the Airbrush tool to create an airbrush effect on your image.

To use the Airbrush tool:

1. Select the active color with which to airbrush. The active color appears in the Color Swatch.
2. Click the Retouch tool in the toolbox. The Retouch tool set opens.
3. Click the Airbrush tool. The pointer changes to the brush shape that is selected in the ribbon area.
4. Set the airbrush options in the ribbon area, if necessary. 
5. Press and hold the left mouse button, and drag the pointer across the image. The speed with 

which you drag the pointer affects the appearance of the spray.
6. Release the left mouse button when you complete airbrushing.
7. Repeat steps 5 and 6 to spray additional areas of the image.

Note: Unlike other tools, the Airbrush tool continues to spray if you hold down the left mouse button 
without moving the brush.

Related Topics
Tool information



Clone Tool

The Clone tool lets you easily copy a portion of an image to another part of the image. 

The Clone tool uses two brushes: a source brush (marked with an X) and a destination brush. When you 
activate the tool, whatever is under the source brush is copied, or cloned, to the location of the destination 
brush.

When cloning, the source and destination brushes are locked together and move as a pair. To unlock the 
clone brushes, press and hold Shift and move your mouse to move the destination brush (the brush 
without the X) to where you want the copied image. Release Shift, then press and hold the left mouse 
button to begin copying. 

Related Topics
Procedure information
Retouch tool options
Cloning between two images 



Using the Clone Tool

To use the Clone tool:

1. Click the Retouch tool in the toolbox. The Retouch tool set opens.
2. Click the Clone tool.
3. Set the Clone options in the ribbon area.
4. Click the Source button.
5. Position the source brush and click and hold to set its position.
6. Drag the destination brush to its position and release the mouse button.
7. Drag the source brush across the image to clone parts of the image.

Cloning is a great way to blend out imperfections or blemishes in an image by using adjacent areas to 
match variable colors and textures. Be careful to keep the source brush over the part of the image you 
want to copy. It is possible to clone an area already duplicated, which can create undesirable effects. If 
you want to reverse an undesirable effect, open the Edit menu and choose the Undo command.

Related Topics
Tool information
Cloning between two images 



Cloning Between Two Images

To clone between two images:

1. Open the images that you want to use.
2. Click the Retouch tool in the toolbox. The Retouch tool set opens.
3. Click the Clone tool.
4. Set the Clone options in the ribbon area.
5. Click the Source button.
6. Position the source brush and click and hold to set its position.
7. Drag the destination brush to its position and release the mouse button.
8. Drag the source brush across the image to clone parts of the image.

Note: You can use Shift to reposition the source brush.

Related Topics
Tool information



Texture Tool

The Texture tool lets you paint with a texture instead of a color. 

Textures are bitmap images that can be added to your image. Textures can improve your image by adding 
depth or variety. A common use of textures is to add a background or a "ghosted" effect. For example, 
you can add a crushed velvet background texture behind the image of a diamond ring.

Each texture is stored and used as a square tile. These tiles are laid side by side as you add the texture. 
In some textures, like velvet or crushed paper, the "seam" between the tiles may not be noticeable; other 
textures, like a mountain scene, may produce detectable seams. You can use the merge modes, in some 
cases, to make the seam less detectable.

There are an unlimited number of textures you can apply to an image. We've given you a few to start with, 
but you can create an unlimited library of bitmap textures.

Related Topics
Procedure information
Texture tool options
Adding textures
Deleting textures
Renaming textures



Texture Tool Options

When you choose the Texture tool, the ribbon area changes to reflect options specific to this tool.

The Texture Name list box and Flip button in the ribbon area are unique to the Texture tool and Texture 
Fill tool.

The Texture Name list box lets you choose from the library of textures. You can also add, delete, or 
rename textures. The Flip button lets you flip a texture horizontally or vertically.

The Flip options let you flip every other texture tile horizontally (left/right arrow) or or vertically (up/down 
arrow) before applying it. The option to flip horizontally and vertically while painting with a texture provides 
smooth continuous transitions when texture tiles are butted together in the painting process.

Related Topics
Tool information



Adding Textures to the Library

Choose the Add command in the file icon submenu to add a texture.

To add a texture to the library:

1. Click the file icon to the right of the Texture Name list box. A submenu opens.
2. Choose Add. Change to the appropriate directory and double click the image file.
3. Click OK to add it to the library.

Textures can also be added to the texture library by opening the texture image, masking a portion of it, 
then choosing the Copy To command in the Edit menu. 

Note: The default file format is TIF, but any valid image file (BMP, GIF, PCX, and TGA) can be included in 
the texture library.

Related Topics
Deleting textures
Renaming textures



Deleting Textures from the Library

Choose the Delete command in the file icon submenu to delete a texture.

To delete a texture from the library:

1. Select the texture in the Texture Name list box in the ribbon, then click the File Options button. A 
submenu opens.

2. Choose Delete.
3. Click OK to delete the texture.

Related Topics
Adding textures
Renaming textures



Renaming Textures in the Library

Click the texture you want to rename, then click the file icon and choose Rename.

To rename a texture in the library:

1. Select the texture in the Texture Name list box in the ribbon area, then click the file icon. A 
submenu opens.

2. Choose Rename.
3. Type the new name for the text.
4. Click OK to rename the texture.

Related Topics
Tool information
Adding textures
Deleting textures



Using the Texture Tool

To use the Texture tool:

1. Click the Retouch tool in the toolbox. The Retouch tool set opens.
2. Click the Texture tool. The pointer changes to the brush shape selected in the ribbon area.
3. Select the Brush Style you want to use in the ribbon area.
4. Set the Texture options in the ribbon area, if necessary. 
5. Press and hold the left mouse button, and drag the pointer across the image to apply the texture.
6. Release the left mouse button when you are finished.
7. Repeat steps 5 and 6 to apply texture to additional areas of the image.

Related Topics
Tool information
Adding textures
Deleting textures
Renaming textures



Smear Tool

The Smear tool mixes the colors under the pointer to blend them together. It is similar to smudging 
charcoal on paper.

The Smear tool lets you control the brush pressure in addition to other brush options. Select low pressure 
for light smearing or a high pressure for heavy smearing. Pressure is similar to how hard your finger is 
pressed on paper when smudging charcoal or wet paint.

You can use the Smear tool to blend the edges of a pasted image.

Related Topics
Procedure information
Retouch tool options



Using the Smear Tool

Use the Smear tool to blend colors in an image.

To use the Smear tool:

1. Click the Retouch tool in the toolbox. The Retouch tool set opens.
2. Click the Smear tool. The pointer changes to the brush shape selected in the ribbon area.
3. Set the Smear options in the ribbon area, including brush pressure, if necessary.
4. Press and hold the left mouse button, and drag the pointer across the image. The colors under 

the pointer blend together.
5. Release the left mouse button when you finish.
6. Repeat steps 4 and 5 to smear additional areas of the image.

Related Topics
Tool information



Eraser Tool

The Eraser tool lets you erase changes that have not yet been applied. The Eraser tool differs from the 
Undo command because it lets you selectively remove edits as though your pointer were an eraser.

You can use the Eraser tool to erase changes you made while editing an image. Most often, you will only 
erase small areas. Erasing restores the erased area to the last changes applied, so the previous image 
shows through the hole made by the eraser.

For example, you can erase painted areas as long as they haven't been made part of the image (by 
automatically or manually applying).

You can choose Airbrush Undo, Undo, White, or Background as the Brush Style for erasing parts of an 
image.

Related Topics
Procedure information



Using the Eraser Tool

Use the Eraser tool to remove any changes that have not been applied.

To use the Eraser tool:

1. Click the Retouch tool in the toolbox. The Retouch tool set opens.
2. Click the Eraser tool in the ribbon. The pointer changes to the brush shape selected in the ribbon 

area.
3. Change the Eraser tool options in the ribbon area, if necessary.
4. Move the pointer to the area you want to erase.
5. Press and hold the left mouse button, and drag the pointer over the area until you erase what you 

want.
6. Release the left mouse button when finished.

Note: If you did not choose the Use Manual Apply option in the Preferences dialog box, the last 
completed change is automatically applied each time you start another edit, and only the last change can 
be erased. 

Related Topics
Tool information



Filter Tools

The Filter tools in Picture Publisher let you add a filter effect to a small area of the image using brush 
strokes.

Click an icon below to read more information about the tool.

Click the Sharpen tool to make edges in an image appear more distinct.

Click the Smooth tool to make edges in an image appear less distinct.

Click the Lighten tool to increase the amount of lightness in selected areas in an image.

Click the Darken tool to increase the amount of darkness in selected areas in an image.

When photographers want to create a special photographic effect, they might use a filter on their camera 
lens. For example, a photographer might use a soft-focus filter to give the subject a soft, misty quality.

The Filter tools offer several options to enhance your image, but instead of using a lens filter, you use a 
brush. This gives you greater control over the placement of filtering effects.

Related Topics
Filter tool options



Filter Tool Options

The Filter tool options determine how the Filter tools work. You can choose different options for each tool. 
For example, the options you choose for the Sharpen tool do not affect the options for the Smooth tool. 
These options are in the ribbon area at the top of the window. The options common to each tool are 
described below.

Brush Style List Box
The Brush Style list box gives you these options: All Tones, Highlights, Midnights, Shadows, and Default.

File Options Button
Click the File Options button to open a submenu that lets you edit, delete, and rename brush styles.

Brush Option
The Brush option lets you choose how the brush applies the stroke. For example, you can choose a 
round or square brush, or you can use a custom brush chosen from a library of brush shapes.

Note: You also can change the brush shape by pressing the Ctrl+Right Arrow or Ctrl+Left Arrow.

Size Option
The Size option lets you change the size of your brush. Brush sizes range from 1 to 99, with a higher 
setting giving a larger brush.

Note: You also can change the brush size by pressing the Ctrl+Up Arrow or Ctrl+Down Arrow.

Feather Option
The Feather option softens the outer edge of your brush stroke by making the edges fuzzy. Feathering a 
brush stroke can help it blend into an image.

Increase the number to increase the blurriness of the edge; decrease the number to sharpen the edge. 
Set Feather to 0 to turn the option off. Settings range from 0 to 100 (where a setting of 100 feathers 100% 
of the brush size).

If the Feather setting is 100, you get a continuous transition from the fill color through the outline color to 
the adjacent background color. This can create an interesting color blending effect.

Pressure Option
The Pressure option lets you determine the amount of pressure for the stroke. Zero percent is equal to no 
pressure, while 100% is equal to full pressure.

Related Topics
Filter tools



Sharpen Tool

The Sharpen tool lets you sharpen the edges within an image. This makes the edges in an image appear 
more distinct. 

The Sharpen tool increases contrast by making dark edges darker and surrounding light edges lighter. 
For example, if you sharpen a light-blue edge against a yellow background, the light blue changes to dark 
blue and the yellow becomes white.

You can use the Sharpen tool to increase the readability of type in an image.

Related Topics
Procedure information
Filter tool options



Using the Sharpen Tool

To use the Sharpen tool:

1. Click the Filter tool in the toolbox. The Filter tool set opens.
2. Click the Sharpen tool. The pointer changes to the brush shape selected in the ribbon area.
3. Change the Filter tool options in the ribbon area, if necessary. (For example, choose the Brush 

Style, Brush Size, etc.)
4. Press and hold the left mouse button, and move the pointer over the edges you want to sharpen.
5. Release the left mouse button when you finish.

Note: You can change the brush options while you apply special effects. Ctrl+Up Arrow and Ctrl+Down 
Arrow control the size of the brush, and Ctrl+Left Arrow and Ctrl+Right Arrow change the brush shape.

6. Repeat steps 4 through 5 as many times as you need to sharpen additional areas of an image.

Related Topics
Tool information
Filter tool options



Smooth Tool

The Smooth tool lets you dull the edges within an image. This makes the edges in an image appear less 
distinct. The Smooth tool decreases contrast by making dark edges lighter and light edges darker, 
resulting in softer, somewhat blurred edges.

Related Topics
Procedure information
Filter tool options



Using the Smooth Tool

Use the Smooth tool to soften edges in an image.

To use the Smooth tool:

1. Click the Filter tool in the toolbox. The Filter tool set opens.
2. Click the Smooth tool. The pointer changes to the brush shape selected in the ribbon area.
3. Change the Filter tool settings in the ribbon area, if necessary. (For example, choose the Brush 

Style, Brush Size, etc.)
4. Press and hold the left mouse button, and move the pointer over the edges you want to smooth.
5. Release the left mouse button when you finish.

Note: You can change the brush options while you apply special effects. Ctrl+Up Arrow and Ctrl+Down 
Arrow control the size of the brush, and Ctrl+Left Arrow and Ctrl+Right Arrow change the brush shape.

6. Repeat steps 4 through 5 as many times as you need to smooth additional areas of an image.

Related Topics
Tool information
Filter tool options



Lighten Tool

The Lighten tool lets you lighten selected areas in an image. This tool is used most often to show detail in 
the highlights, midtones, or shadows of an image.

Related Topics
Procedure information
Filter tool options



Using the Lighten Tool

Use the Lighten tool to lighten dark areas in an image.

To use the Lighten tool:

1. Click the Filter tool in the toolbox. The Filter tool set opens.
2. Click the Lighten tool. The pointer changes to the brush shape selected in the ribbon area.
3. Change the Filter tool options in the ribbon area, if necessary. (For example, choose the Brush 

Style, Brush Size, etc.)
4. Press and hold the left mouse button, and move the pointer over the area you want to lighten.
5. Release the left mouse button when you finish.

Note: You can change the brush settings while you apply special effects. Ctrl+Up Arrow and Ctrl+Down 
Arrow control the size of the brush, and Ctrl+Left Arrow and Ctrl+Right Arrow change the brush shape.

6. Repeat steps 4 through 5 to lighten additional areas of an image.

Related Topics
Tool information
Filter tool options



Darken Tool

The Darken tool lets you darken selected areas of an image. This tool is used most often to show detail in 
the highlights, midtones, or shadows of an image.

Related Topics
Procedure information
Filter tool options



Using the Darken Tool

Use the Darken tool to show detail in the highlighted portions of an image.

To use the Darken tool:

1. Click the Filter tool in the toolbox. The Filter tool set opens.
2. Click the Darken tool. The pointer changes to the brush shape selected in the ribbon area.
3. Change the Filter tool options in the ribbon area, if necessary.
4. Press and hold the left mouse button, and move the pointer over the area you want to darken.
5. Release the left mouse button when you complete the task.

Note: You can change the brush settings while you apply special effects. Ctrl+Up Arrow and Ctrl+Down 
Arrow control the size of the brush, and Ctrl+Left Arrow and Ctrl+Right Arrow change the brush shape.

6. Repeat steps 4 through 5 to darken additional areas of an image.

Related Topics
Tool information
Filter tool options



Fill Tools

The Fill tools in Picture Publisher let you fill masked areas of your image with colors or patterns. 

Click an icon below to read more information about the tool.

Click the Gradient Fill tool to create a special effect in which one color gradually changes into 
another.

Click the Texture Fill tool to flood an area with a texture or pattern.

Click the Color Tint Fill tool to fill a masked portion of an image with color.

Click the Smart Fill tool to change a specific color in a specific area of an image.

Fills are particularly useful if you want to add color or texture to your image. Fills can be applied as 
opaque colors, or you can choose a percentage of transparency in the ribbon area. Fills can be applied to 
an entire image or to a section of an image defined by a mask. 

Note: Smart Fill is the exception. It fills areas within a specified color range. 

To add a fill to the image, click anywhere in the image. The fill occurs inside or outside the mask 
depending on the In/Out option in the status bar at the bottom of the window. If you do not have an area 
masked, the entire image is filled.

To remove a fill from an image, choose the Undo command in the Edit menu.

Related Topics
Gradient fill tool settings
Procedure informations 



Gradient Fill Tool Options

When you choose the Gradient Fill tool, the ribbon area changes to reflect options specific to this tool.

Gradient Type
Linear gradients are made up of successive straight lines at any angle, changing from the active color at 
the start of the gradient to the alternate color at the end of the gradient.

Radial gradients are formed by circular arcs radiating out from a starting point and progressively growing 
larger toward an ending point (like ripples when a pebble is tossed into a pond). Circular gradients are 
similar to radial gradients but are formed by complete circles. Elliptical gradients are formed by ovals.

A square or rectangular gradient is formed by increasingly larger squares or rectangles.

Color Sweep Option
Gradients can have from 1 to 99 transitions between the starting and ending points. This option is set in 
the Color Sweep box in the ribbon area.

Multiple color sweeps give the effect of a striped color blend with one to 99 bands (or rings). Whether the 
stripes are linear, circular, or rectangular depends upon the gradient type.

Color Model Option
The Color Model option gives you easy access to gradient fills using the HSL (hue, saturation, and 
lightness) color model. The default setting for the gradient fill color model is RGB (red, green, and blue).

Transition Option
You can choose either the Hard Transition or Soft Transition option. If you choose the Hard Transition 
option, each successive sweep goes from the active color to the alternate color. For example, the first 
fade is from red to yellow and the second is also from red to yellow. 

The Soft Transition option creates a soft edge at the transition to the next sweep by reversing the color 
order in each successive sweep. For example, the first fade is from red to yellow, and the second is from 
yellow to red. This feature lets you create interesting repeating patterns.

Midpoint Option
This option lets you determine where the transition between colors takes place. Setting this to 10 makes 
the transitions take place at the point that is 10 percent of the distant between start and end of the 
gradient area. A setting of 50 makes the transition happen at the half way point.

Transparency Option
The Transparency option lets you determine the degree of transparency of your fill. At 0% transparency, 
the fill is opaque; at 99% transparency, the fill is almost completely transparent or invisible.

Merge Mode List Box
This list box contains various editing options. When used in conjunction with editing tools, such as Paint 
or Fill, these options let you combine, or mix, colors using additive or subtractive color theory. You also 
can selectively change an image according to hue, saturation, or lightness and make modifications to the 
red, green, or blue channel of an image.

The Normal option is the default setting in the Merge Mode list box. When Normal is selected, Picture 
Publisher behaves as if Merge Mode is off, and no editing effects are possible.

The Additive option lets you mix colors according to the additive color model. If you paint a red image 
with a blue brush, magenta appears in the image as a result of the additive mixing of red and blue. If you 
paint with a green brush on a red background, you get yellow. To calculate the resultant color, simply add 
the RGB values of the colors together and round down any number over 100 to 100.



An example of additive mixing using green and blue is shown below.

Green R(0) G(100) B(0)
Blue R(0) G(0) B(100)

--------------------------------
Cyan R(0) G(100) B(100)

Adding the R column results in 0, adding the G column results in 100, and adding the B column results in 
100. These values represent a color (cyan) that has the value of R(0), G(100), B(100).

Note: Be sure to adjust all numbers so they do not exceed 100. For example, if the total of the B column 
adds to 140, round the value down to 100.

The Subtractive option lets you mix colors according to the subtractive color model. If you paint on a 
cyan image with a magenta brush, blue appears in the image as a result of the subtractive mixing of cyan 
and magenta. If you paint with a yellow brush on a magenta background, you get red. To calculate the 
resultant color, add the RGB values of the colors together, subtract 100 from the answer, round any 
negative value to 0, and round any number over 100 to 100.

An example of subtractive mixing using cyan and magenta is shown below.

Cyan R(0) G(100) B(100)
Magenta R(100) G(0) B(100)

--------------------------------
R(100) G(100) B(200)

-100 -100 -100
--------------------------------

Blue R(0) G(0) B(100)

Adding the R column results in 100, adding the G column results in 100, and adding the B column results 
in 200. Subtract 100 from the resultant R, G, and B values. These ending values represent a color (blue) 
that has the value of R(0), G(0), B(100). Be sure to adjust all numbers so there are no negative numbers 
and no values over 100. For example, if the B column is -20, round the value to 0; if the B column is 140, 
round the value down to 100.

The If Lighter option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value equal to, or higher than that of the image, the 
color of the editing tool is transferred to the image. If the lightness value is not equal to or less than that of 
the image, no change occurs. For example, if you are painting with white (white has a lightness value of 
100), all of the colors in the image are affected. If you paint with black (black has a lightness value of 0), 
none of colors in the image are affected. Notice that any primary color will paint over any other primary 
color (except white) because all primary colors have the same lightness value (except black, which has 
the lowest lightness value, and white, which has the highest lightness value).

The If Darker option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value lower than that of the image, the color of the 
editing tool is transferred to the image. If the lightness value is not lower than the image, no change 
occurs. For example, if you paint with white (white has a lightness value of 100), none of the colors in the 
image are affected. If you are painting with black (black has a lightness value of 0), all of the colors in the 
image are affected.

The Filter option uses a combination of Additive and Multiply to create a filtered effect.



The Multiply option multiplies the value of the image and the editing tool colors.

The Difference option subtracts the value of the editing tool from the value of the existing color to obtain 
a new color.

The Texturize option uses the editing tool as a texture surface on which the image is painted.

The Color option lets you replace the color of an image with the color of the editing tool, or source, used. 
Color is composed of the "H," or hue value, and the "S," or saturation value, in the HSL color model. For 
example, if you are painting with blue (H=240, S=100), all of the painted colors take on the same H and S 
values of blue. This results in a color change; however, the lightness values remain the same.

Note: Hue and saturation values have no affect on black or white. This is because the lightness value of 
black is 0 and the lightness value of white is 100. Any color with the lightness value of 0 is black 
regardless of the hue and saturation values. Any color with the lightness value of 100 is white regardless 
of the hue and saturation values.

The Hue option lets you replace the hue value of an image with the hue value of the editing tool, or 
source, used. For example, if you are painting with green (H=120), all colors (except white and black) that 
are painted become green. Notice that if you paint with red, white, or black, you get the same results. This 
is because all three of these colors have the same hue value (H=0).

The Saturation option lets you replace the saturation value of an image with the saturation value of the 
editing tool, or source, used. For example, if you are painting with any primary color (except white or 
black) onto any other primary color, only white and black are affected; the other colors remain the same. 
This is because all primary colors have the same saturation value (S=100), except for white (S=0) and 
black (S=0). If you are painting with white or black, the colors become grayscale values; remember that 
grayscale images have no saturation.

The Luminance option lets you replace the luminance value of an image with the lightness value of the 
editing tool, or source, used.

The Red option lets you replace the red channel (using the RGB color model) of an image with the value 
of the red channel source. Only the red channel is affected. The results from using the Red Only option 
are the same as if you were to split the RGB channels using the Channels command, make changes to 
the red channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the red 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 0, 0, 
100 (blue). The red value from the brush (0) replaces the red value in the image (100) to create blue.

The Green option lets you replace the green channel (using the RGB color model) of an image with the 
value of the green channel source. Only the green channel is affected. The results from using the Green 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the green channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the green 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a red image (RGB value = 100, 0, 0), the result is a color that has an RGB value of 100,100, 0 
(yellow). The green value from the brush (100) replaces the green value in the image (0) to create yellow.

The Blue option lets you replace the blue channel (using the RGB color model) of an image with the 
value of the blue channel source. Only the blue channel is affected. The results from using the Blue 
option are the same as if you were to split the RGB channels using the Channels command, make 



changes to the blue channel image, and then combine the channels.

To determine the resulting value of mixing the source and image, replace the image value of the blue 
channel with the source value. For example, if you are painting with a green brush (RGB value = 0, 100, 
0) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 100, 0, 
0 (red). The blue value from the brush (0) replaces the blue value in the image (100) to create red.

Related Topics
Tool information
Procedure information 



Gradient Fill Tool

The Gradient Fill tool lets you create a special effect in which one color gradually changes into another.

Gradients, also known as blends or vignettes, are graduated color or gray sweeps that can be used to 
create a background or add shading. The gradient types are linear, radial, circular, elliptical, square, and 
rectangular. 

Linear and radial gradients form a gradual fade of one color to another in a specified direction. Shape 
gradients (all types except linear) fade from a start color at the center of the shape to an end color at the 
shape's outer edge.

Gradient fills use the Color Swatch's active and alternate colors as the start and end colors, respectively. 
The active color is where the gradient begins; the alternate color is where the gradient ends. In other 
words, gradients change from the active color to the alternate color.

Related Topics
Gradient Fill tool options
Procedure information 



Creating a Gradient

To create a gradient:

1. Choose the active and alternate colors (using the Color Probe, Color Palette, or Color Picker).
2. Click the Fill tool in the toolbox. The Fill tool set opens.
3. Click the Gradient Fill tool. The pointer changes to crosshairs and a paint bucket.
4. Choose the gradient type you want in the Gradient Type list box in the ribbon area.
5. Set the options in the ribbon area, if necessary. 
6. Move the pointer to where you want to begin the sweep (for linear and radial gradients), then 

press and hold the left mouse button. To create a definition line, drag the point the distance and 
direction you want the sweep to go. The line can extend outside the image area so that you can 
sweep to the corners of the image.
or
Press and hold the left mouse button (for other gradient types), and drag the pointer until the 
bounding box surrounds the image area in which you want to add the gradient. The gradient 
begins at the center of the shape and extends out.

Note: Press Esc before releasing the left mouse button to cancel a definition line or bounding box.

To move the definition line or bounding box while you are drawing it, press and hold the right mouse 
button (don't release the left mouse button) and drag the bounding box to a new position. Release the 
right mouse button when you are finished moving.

7. Release the left mouse button. The gradient appears on the screen. The image area beyond the 
starting point redraws with the solid starting color, and the image area beyond the ending point 
redraws with the solid ending color.

Note: Large gradient areas change color gradually; small gradient areas change color more quickly.

Related Topics
Tool information
Gradient Fill tool options



Texture Fill Tool

The Texture Fill tool lets you flood an area with a texture or pattern.

Use the Texture Fill tool to apply a pattern to your image. Textures can be selected from a texture library, 
or you can add your own. 

Textures are bitmap images that can be added to your image. Textures can improve your image by adding 
depth or variety. A common use of textures is background effects. For example, you could add a crushed 
velvet texture behind the image of a diamond ring.

Each texture is stored and used as a square tile. These tiles are laid side by side as you add the texture. 
In some textures, like velvet or crushed paper, the "seam" between the tiles may not be noticeable; other 
textures, like a mountain scene, may produce detectable seams.

Related Topics
Texture Fill tool options
Procedure information



Texture Fill Tool Options

The Texture Name list box and Flip buttons in the ribbon area are two options unique to the Texture tool 
and Texture Fill tool.

The Texture Name list box in the ribbon area lets you choose from your library of textures. You can also 
add new textures or delete or rename existing textures.

To add a new texture file to the library, click the file icon to the right of the Texture Name list box, then 
choose the Add command. If you have any bitmap files, change to their directory. Double click the image 
file to add it, and click Ok to include it in the library.

Textures can also be added by opening the texture image, masking a portion of it, then choosing the 
Copy To command in the Edit menu.

Note: Any valid image file (BMP, TIF, GIF, PCX, and TGA) can be included in the texture library, but the 
default format is TIF.

The Flip options let you flip every other texture tile horizontally (left/right arrow) or vertically (up/down 
arrow) before applying it. The option to flip horizontally or vertically while painting with a texture provides 
smooth continuous transitions when texture tiles are butted together in the painting process.

There is an unlimited number of textures you can apply to an image. We've given you some textures to 
start with, but you can create an unlimited library of bitmap textures.

The Texture Fill tool is similar to the Texture tool in the Retouch tool set. The difference is that the Texture 
Fill tool fills the entire area of an image or the masked area with a fill pattern; the Texture tool applies the 
texture pattern to the image with a brush.

Transparency Option
The Transparency option lets you determine the degree of transparency of your fill. At 0% transparency, 
the fill is opaque; at 99% transparency, the fill is almost completely transparent or invisible.

Merge Mode List Box
This list box contains various editing options. When used in conjunction with editing tools, such as Paint 
or Fill, these options let you combine, or mix, colors using additive or subtractive color theory. You also 
can selectively change an image according to hue, saturation, or lightness and make modifications to the 
red, green, or blue channel of an image.

The Normal option is the default setting in the Merge Mode list box. When Normal is selected, Picture 
Publisher behaves as if Merge Mode is off, and no editing effects are possible.

The Additive option lets you mix colors according to the additive color model. If you paint a red image 
with a blue brush, magenta appears in the image as a result of the additive mixing of red and blue. If you 
paint with a green brush on a red background, you get yellow. To calculate the resultant color, simply add 
the RGB values of the colors together and round down any number over 100 to 100.

An example of additive mixing using green and blue is shown below.

Green R(0) G(100) B(0)
Blue R(0) G(0) B(100)

--------------------------------
Cyan R(0) G(100) B(100)

Adding the R column results in 0, adding the G column results in 100, and adding the B column results in 
100. These values represent a color (cyan) that has the value of R(0), G(100), B(100).



Note: Be sure to adjust all numbers so they do not exceed 100. For example, if the total of the B column 
adds to 140, round the value down to 100.

The Subtractive option lets you mix colors according to the subtractive color model. If you paint on a 
cyan image with a magenta brush, blue appears in the image as a result of the subtractive mixing of cyan 
and magenta. If you paint with a yellow brush on a magenta background, you get red. To calculate the 
resultant color, add the RGB values of the colors together, subtract 100 from the answer, round any 
negative value to 0, and round any number over 100 to 100.

An example of subtractive mixing using cyan and magenta is shown below.

Cyan R(0) G(100) B(100)
Magenta R(100) G(0) B(100)

--------------------------------
R(100) G(100) B(200)

-100 -100 -100
--------------------------------

Blue R(0) G(0) B(100)

Adding the R column results in 100, adding the G column results in 100, and adding the B column results 
in 200. Subtract 100 from the resultant R, G, and B values. These ending values represent a color (blue) 
that has the value of R(0), G(0), B(100). Be sure to adjust all numbers so there are no negative numbers 
and no values over 100. For example, if the B column is -20, round the value to 0; if the B column is 140, 
round the value down to 100.

The If Lighter option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value equal to, or higher than that of the image, the 
color of the editing tool is transferred to the image. If the lightness value is not equal to or less than that of 
the image, no change occurs. For example, if you are painting with white (white has a lightness value of 
100), all of the colors in the image are affected. If you paint with black (black has a lightness value of 0), 
none of colors in the image are affected. Notice that any primary color will paint over any other primary 
color (except white) because all primary colors have the same lightness value (except black, which has 
the lowest lightness value, and white, which has the highest lightness value).

The If Darker option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value lower than that of the image, the color of the 
editing tool is transferred to the image. If the lightness value is not lower than the image, no change 
occurs. For example, if you paint with white (white has a lightness value of 100), none of the colors in the 
image are affected. If you are painting with black (black has a lightness value of 0), all of the colors in the 
image are affected.

The Filter option uses a combination of Additive and Multiply to create a filtered effect.

The Multiply option multiplies the value of the image and the editing tool colors.

The Difference option subtracts the value of the editing tool from the value of the existing color to obtain 
a new color.

The Texturize option uses the editing tool as a texture surface on which the image is painted.

The Color option lets you replace the color of an image with the color of the editing tool, or source, used. 
Color is composed of the "H," or hue value, and the "S," or saturation value, in the HSL color model. For 



example, if you are painting with blue (H=240, S=100), all of the painted colors take on the same H and S 
values of blue. This results in a color change; however, the lightness values remain the same.

Note: Hue and saturation values have no affect on black or white. This is because the lightness value of 
black is 0 and the lightness value of white is 100. Any color with the lightness value of 0 is black 
regardless of the hue and saturation values. Any color with the lightness value of 100 is white regardless 
of the hue and saturation values.

The Hue option lets you replace the hue value of an image with the hue value of the editing tool, or 
source, used. For example, if you are painting with green (H=120), all colors (except white and black) that 
are painted become green. Notice that if you paint with red, white, or black, you get the same results. This 
is because all three of these colors have the same hue value (H=0).

The Saturation option lets you replace the saturation value of an image with the saturation value of the 
editing tool, or source, used. For example, if you are painting with any primary color (except white or 
black) onto any other primary color, only white and black are affected; the other colors remain the same. 
This is because all primary colors have the same saturation value (S=100), except for white (S=0) and 
black (S=0). If you are painting with white or black, the colors become grayscale values; remember that 
grayscale images have no saturation.

The Luminance option lets you replace the luminance value of an image with the lightness value of the 
editing tool, or source, used.

The Red option lets you replace the red channel (using the RGB color model) of an image with the value 
of the red channel source. Only the red channel is affected. The results from using the Red Only option 
are the same as if you were to split the RGB channels using the Channels command, make changes to 
the red channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the red 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 0, 0, 
100 (blue). The red value from the brush (0) replaces the red value in the image (100) to create blue.

The Green option lets you replace the green channel (using the RGB color model) of an image with the 
value of the green channel source. Only the green channel is affected. The results from using the Green 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the green channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the green 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a red image (RGB value = 100, 0, 0), the result is a color that has an RGB value of 100,100, 0 
(yellow). The green value from the brush (100) replaces the green value in the image (0) to create yellow.

The Blue option lets you replace the blue channel (using the RGB color model) of an image with the 
value of the blue channel source. Only the blue channel is affected. The results from using the Blue 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the blue channel image, and then combine the channels.

To determine the resulting value of mixing the source and image, replace the image value of the blue 
channel with the source value. For example, if you are painting with a green brush (RGB value = 0, 100, 
0) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 100, 0, 
0 (red). The blue value from the brush (0) replaces the blue value in the image (100) to create red.

Related Topics
Creating a texture fill
Texture Fill tool



Creating a Texture Fill

To create a texture fill:

1. Click the Fill tool in the toolbox. The Fill tool set opens.
2. Click the Texture Fill tool. The pointer changes to a paint bucket.
3. Select the texture you want to use from the Texture Name list box.
4. Select other texture options, if necessary.
5. Point to where you want to apply the texture fill and click the left mouse button.

Note: You can use the Texture tool or the Copy To command in the Edit menu to create and add your 
own textures.

Related Topics
Tool information
Texture Fill tool options



Color Tint Fill Tool

The Color Tint Fill tool lets you fill in masked portions of your image (or the entire image) with color.

This tool lets you apply color to large areas of your image. The Color Swatch's active color can be applied 
to the whole image or sections of it by using masks and color shields.

Transparency Option
The Transparency option lets you determine the degree of transparency of your fill. At 0% transparency, 
the fill is opaque; at 99% transparency, the fill is almost completely transparent or invisible.

Merge Mode List Box
This list box contains various editing options. When used in conjunction with editing tools, such as Paint 
or Fill, these options let you combine, or mix, colors using additive or subtractive color theory. You also 
can selectively change an image according to hue, saturation, or lightness and make modifications to the 
red, green, or blue channel of an image.

The Normal option is the default setting in the Merge Mode list box. When Normal is selected, Picture 
Publisher behaves as if Merge Mode is off, and no editing effects are possible.

The Additive option lets you mix colors according to the additive color model. If you paint a red image 
with a blue brush, magenta appears in the image as a result of the additive mixing of red and blue. If you 
paint with a green brush on a red background, you get yellow. To calculate the resultant color, simply add 
the RGB values of the colors together and round down any number over 100 to 100.

An example of additive mixing using green and blue is shown below.

Green R(0) G(100) B(0)
Blue R(0) G(0) B(100)

--------------------------------
Cyan R(0) G(100) B(100)

Adding the R column results in 0, adding the G column results in 100, and adding the B column results in 
100. These values represent a color (cyan) that has the value of R(0), G(100), B(100).

Note: Be sure to adjust all numbers so they do not exceed 100. For example, if the total of the B column 
adds to 140, round the value down to 100.

The Subtractive option lets you mix colors according to the subtractive color model. If you paint on a 
cyan image with a magenta brush, blue appears in the image as a result of the subtractive mixing of cyan 
and magenta. If you paint with a yellow brush on a magenta background, you get red. To calculate the 
resultant color, add the RGB values of the colors together, subtract 100 from the answer, round any 
negative value to 0, and round any number over 100 to 100.

An example of subtractive mixing using cyan and magenta is shown below.

Cyan R(0) G(100) B(100)
Magenta R(100) G(0) B(100)

--------------------------------
R(100) G(100) B(200)

-100 -100 -100
--------------------------------



Blue R(0) G(0) B(100)

Adding the R column results in 100, adding the G column results in 100, and adding the B column results 
in 200. Subtract 100 from the resultant R, G, and B values. These ending values represent a color (blue) 
that has the value of R(0), G(0), B(100). Be sure to adjust all numbers so there are no negative numbers 
and no values over 100. For example, if the B column is -20, round the value to 0; if the B column is 140, 
round the value down to 100.

The If Lighter option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value equal to, or higher than that of the image, the 
color of the editing tool is transferred to the image. If the lightness value is not equal to or less than that of 
the image, no change occurs. For example, if you are painting with white (white has a lightness value of 
100), all of the colors in the image are affected. If you paint with black (black has a lightness value of 0), 
none of colors in the image are affected. Notice that any primary color will paint over any other primary 
color (except white) because all primary colors have the same lightness value (except black, which has 
the lowest lightness value, and white, which has the highest lightness value).

The If Darker option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value lower than that of the image, the color of the 
editing tool is transferred to the image. If the lightness value is not lower than the image, no change 
occurs. For example, if you paint with white (white has a lightness value of 100), none of the colors in the 
image are affected. If you are painting with black (black has a lightness value of 0), all of the colors in the 
image are affected.

The Filter option uses a combination of Additive and Multiply to create a filtered effect.

The Multiply option multiplies the value of the image and the editing tool colors.

The Difference option subtracts the value of the editing tool from the value of the existing color to obtain 
a new color.

The Texturize option uses the editing tool as a texture surface on which the image is painted.

The Color option lets you replace the color of an image with the color of the editing tool, or source, used. 
Color is composed of the "H," or hue value, and the "S," or saturation value, in the HSL color model. For 
example, if you are painting with blue (H=240, S=100), all of the painted colors take on the same H and S 
values of blue. This results in a color change; however, the lightness values remain the same.

Note: Hue and saturation values have no affect on black or white. This is because the lightness value of 
black is 0 and the lightness value of white is 100. Any color with the lightness value of 0 is black 
regardless of the hue and saturation values. Any color with the lightness value of 100 is white regardless 
of the hue and saturation values.

The Hue option lets you replace the hue value of an image with the hue value of the editing tool, or 
source, used. For example, if you are painting with green (H=120), all colors (except white and black) that 
are painted become green. Notice that if you paint with red, white, or black, you get the same results. This 
is because all three of these colors have the same hue value (H=0).

The Saturation option lets you replace the saturation value of an image with the saturation value of the 
editing tool, or source, used. For example, if you are painting with any primary color (except white or 
black) onto any other primary color, only white and black are affected; the other colors remain the same. 
This is because all primary colors have the same saturation value (S=100), except for white (S=0) and 
black (S=0). If you are painting with white or black, the colors become grayscale values; remember that 
grayscale images have no saturation.



The Luminance option lets you replace the luminance value of an image with the lightness value of the 
editing tool, or source, used.

The Red option lets you replace the red channel (using the RGB color model) of an image with the value 
of the red channel source. Only the red channel is affected. The results from using the Red Only option 
are the same as if you were to split the RGB channels using the Channels command, make changes to 
the red channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the red 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 0, 0, 
100 (blue). The red value from the brush (0) replaces the red value in the image (100) to create blue.

The Green option lets you replace the green channel (using the RGB color model) of an image with the 
value of the green channel source. Only the green channel is affected. The results from using the Green 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the green channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the green 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a red image (RGB value = 100, 0, 0), the result is a color that has an RGB value of 100,100, 0 
(yellow). The green value from the brush (100) replaces the green value in the image (0) to create yellow.

The Blue option lets you replace the blue channel (using the RGB color model) of an image with the 
value of the blue channel source. Only the blue channel is affected. The results from using the Blue 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the blue channel image, and then combine the channels.

To determine the resulting value of mixing the source and image, replace the image value of the blue 
channel with the source value. For example, if you are painting with a green brush (RGB value = 0, 100, 
0) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 100, 0, 
0 (red). The blue value from the brush (0) replaces the blue value in the image (100) to create red.

Related Topic
Procedure information



Creating a Tint Fill

To create a tint fill:

1. Choose the active color in the Color Swatch at the bottom of the toolbox. The active color will be 
the tint fill color.

2. Click the Fill Tool in the toolbox. The Fill tool set opens.
3. Click the Color Tint Fill tool. The pointer changes to a paint bucket.
4. Set the options in the Tint Fill ribbon, if necessary.
5. Point to where you want to apply the tint fill and click the left mouse button. The area of the image 

fills with color.

Related Topics
Tool information



Smart Fill Tool

The Smart Fill tool lets you change a specific color on a specific place on your image without drawing a 
mask.

Use the Smart Fill tool to fill a color or range of colors with the Color Swatch's active color. The Fill Range 
area in the ribbon area determines how large an area is filled. It is helpful when you want to fill a localized 
area of similar coloes with a different color. Smart Fill tracks the adjacent color pixels and works within 
masked areas.

Related Topics
Procedure information
Smart Fill tool options



Smart Fill Tool Options

Fill Range option
The Fill Range option determines how selective the Smart Fill is when searching for adjacent colors to 
replace with a new fill.

A low percentage is very selective. A high percentage includes more colors.

For example, if the Fill Range is 0% and you click a blue patch, only the blue is filled with the new color. If 
the Fill range is 10%, the blue patch and all adjacent colors that are within a 10% variant of the selected 
blue are affected.

Note: The percentage range is based upon the RGB (red, green, and blue) color model. It defines the 
percent deviation from the RGB values of the color defined in the shield. A 100% setting protects or 
selects all color values in the image. A 5% setting allows a tolerance of plus or minus 5% from the defined 
RGB values. A 0% setting limits the range to a single RGB value.

Color Model List Box
The Color Model list box gives you easy access to gradient fills using the Normal, or RGB (red, green, 
and blue), and HSL (hue, saturation, and lightness) color models. The default setting for the gradient fill 
color model is Normal..

Transparency Option
The Transparency option lets you determine the degree of transparency of your fill. At 0% transparency, 
the fill is opaque; at 99% transparency, the fill is almost transparent or invisible.

Merge Mode List Box
This list box contains various editing options. When used in conjunction with editing tools, such as Paint 
or Fill, these options let you combine, or mix, colors using additive or subtractive color theory. You also 
can selectively change an image according to hue, saturation, or lightness and make modifications to the 
red, green, or blue channel of an image.

The Normal option is the default setting in the Merge Mode list box. When Normal is selected, Picture 
Publisher behaves as if Merge Mode is off, and no editing effects are possible.

The Additive option lets you mix colors according to the additive color model. If you paint a red image 
with a blue brush, magenta appears in the image as a result of the additive mixing of red and blue. If you 
paint with a green brush on a red background, you get yellow. To calculate the resultant color, simply add 
the RGB values of the colors together and round down any number over 100 to 100.

An example of additive mixing using green and blue is shown below.

Green R(0) G(100) B(0)
Blue R(0) G(0) B(100)

--------------------------------
Cyan R(0) G(100) B(100)

Adding the R column results in 0, adding the G column results in 100, and adding the B column results in 
100. These values represent a color (cyan) that has the value of R(0), G(100), B(100).

Note: Be sure to adjust all numbers so they do not exceed 100. For example, if the total of the B column 
adds to 140, round the value down to 100.

The Subtractive option lets you mix colors according to the subtractive color model. If you paint on a 
cyan image with a magenta brush, blue appears in the image as a result of the subtractive mixing of cyan 
and magenta. If you paint with a yellow brush on a magenta background, you get red. To calculate the 



resultant color, add the RGB values of the colors together, subtract 100 from the answer, round any 
negative value to 0, and round any number over 100 to 100.

An example of subtractive mixing using cyan and magenta is shown below.

Cyan R(0) G(100) B(100)
Magenta R(100) G(0) B(100)

--------------------------------
R(100) G(100) B(200)

-100 -100 -100
--------------------------------

Blue R(0) G(0) B(100)

Adding the R column results in 100, adding the G column results in 100, and adding the B column results 
in 200. Subtract 100 from the resultant R, G, and B values. These ending values represent a color (blue) 
that has the value of R(0), G(0), B(100). Be sure to adjust all numbers so there are no negative numbers 
and no values over 100. For example, if the B column is -20, round the value to 0; if the B column is 140, 
round the value down to 100.

The If Lighter option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value equal to, or higher than that of the image, the 
color of the editing tool is transferred to the image. If the lightness value is not equal to or less than that of 
the image, no change occurs. For example, if you are painting with white (white has a lightness value of 
100), all of the colors in the image are affected. If you paint with black (black has a lightness value of 0), 
none of colors in the image are affected. Notice that any primary color will paint over any other primary 
color (except white) because all primary colors have the same lightness value (except black, which has 
the lowest lightness value, and white, which has the highest lightness value).

The If Darker option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value lower than that of the image, the color of the 
editing tool is transferred to the image. If the lightness value is not lower than the image, no change 
occurs. For example, if you paint with white (white has a lightness value of 100), none of the colors in the 
image are affected. If you are painting with black (black has a lightness value of 0), all of the colors in the 
image are affected.

The Filter option uses a combination of Additive and Multiply to create a filtered effect.

The Multiply option multiplies the value of the image and the editing tool colors.

The Difference option subtracts the value of the editing tool from the value of the existing color to obtain 
a new color.

The Texturize option uses the editing tool as a texture surface on which the image is painted.

The Color option lets you replace the color of an image with the color of the editing tool, or source, used. 
Color is composed of the "H," or hue value, and the "S," or saturation value, in the HSL color model. For 
example, if you are painting with blue (H=240, S=100), all of the painted colors take on the same H and S 
values of blue. This results in a color change; however, the lightness values remain the same.

Note: Hue and saturation values have no affect on black or white. This is because the lightness value of 
black is 0 and the lightness value of white is 100. Any color with the lightness value of 0 is black 
regardless of the hue and saturation values. Any color with the lightness value of 100 is white regardless 
of the hue and saturation values.



The Hue option lets you replace the hue value of an image with the hue value of the editing tool, or 
source, used. For example, if you are painting with green (H=120), all colors (except white and black) that 
are painted become green. Notice that if you paint with red, white, or black, you get the same results. This 
is because all three of these colors have the same hue value (H=0).

The Saturation option lets you replace the saturation value of an image with the saturation value of the 
editing tool, or source, used. For example, if you are painting with any primary color (except white or 
black) onto any other primary color, only white and black are affected; the other colors remain the same. 
This is because all primary colors have the same saturation value (S=100), except for white (S=0) and 
black (S=0). If you are painting with white or black, the colors become grayscale values; remember that 
grayscale images have no saturation.

The Luminance option lets you replace the luminance value of an image with the lightness value of the 
editing tool, or source, used.

The Red option lets you replace the red channel (using the RGB color model) of an image with the value 
of the red channel source. Only the red channel is affected. The results from using the Red Only option 
are the same as if you were to split the RGB channels using the Channels command, make changes to 
the red channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the red 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 0, 0, 
100 (blue). The red value from the brush (0) replaces the red value in the image (100) to create blue.

The Green option lets you replace the green channel (using the RGB color model) of an image with the 
value of the green channel source. Only the green channel is affected. The results from using the Green 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the green channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the green 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a red image (RGB value = 100, 0, 0), the result is a color that has an RGB value of 100,100, 0 
(yellow). The green value from the brush (100) replaces the green value in the image (0) to create yellow.

The Blue option lets you replace the blue channel (using the RGB color model) of an image with the 
value of the blue channel source. Only the blue channel is affected. The results from using the Blue 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the blue channel image, and then combine the channels.

To determine the resulting value of mixing the source and image, replace the image value of the blue 
channel with the source value. For example, if you are painting with a green brush (RGB value = 0, 100, 
0) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 100, 0, 
0 (red). The blue value from the brush (0) replaces the blue value in the image (100) to create red.

Related Topics
Creating a smart fill



Creating a Smart Fill

To create a smart fill:

1. Choose the active color in the Color Swatch at the bottom of the toolbox. The active color will be 
the smart fill color.

2. Click the Fill tool in the toolbox. The Fill tool set opens.
3. Click the Smart Fill tool. The pointer changes to a magic wand.
4. Set the options in the ribbon, if necessary.
5. Point to where you want to apply the Smart Fill color and click the left mouse button. The chosen 

color and all adjacent colors within the specified fill range are filled.

Related Topics
Tool information



Draw Tools

The Draw tools let you draw simple lines and shapes on your image. For example, the Draw tools let you 
insert your image into an oval picture frame.

Click an icon below to read more information about the tool.

Click the Pencil tool to draw straight lines or freehand sketches.

Click the Rectangular/Elliptical Draw tool to draw rectangular or square shapes on an image.

Click the Freehand Draw tool to draw closed, irregular shapes.

Related Topics
Draw tool options



Draw Tool Options

Draw tool options determine how different Draw tools work. They are specific to each tool (the options 
selected for the Pencil tool don't affect those selected for the Freehand Draw tool, for example) and are 
defined in the ribbon area. The options common to each tool are described below. 

Fill Style Option
The Fill Style option lets you choose how to fill solid shapes. For example, you can choose to fill a circle 
with color, show only its outline, or show only the fill with no outline. 

Outline and fill colors are selected with the Color Probe, Color Picker, or Color Palette and are displayed 
in the Color Swatch. The active color is the outline and the alternate color is the interior color, regardless 
of which Fill Style option is selected.

File Options Button
Click the File Options button to open a submenu that lets you edit, delete, and rename brush styles.

Brush Option
The Brush option lets you choose how the brush applies the stroke. For example, you can choose a 
round or square brush, or you can use a custom brush chosen from a library of brush shapes.

You can change the tip shape with the Ctrl+Right Arrow or Ctrl+Left Arrow as you edit your image.

Size Option
The Size option lets you change the size of your drawing tip. A higher setting gives a larger tip.

You can increase or decrease the tip size by pressing Ctrl+Up Arrow or Ctrl+Down Arrow as you edit 
your image.

Draw Style Area
The Draw Style area gives you these options: Solid, Chalk, Colorizer, Crayon, Dotted, Marker, Pencil, 
Scatter, Smudgy Marker, Solid Smear, and Scatter Smear. The options available depend on the draw tool 
selected.

Chalk lets you create the impression that you are drawing with chalk on a chalkboard.

Charcoal lets you create the impression that you are drawing on paper with a piece of charcoal.

Colorizer lets you replace the color of an image with the color of the draw tool.

Crayon lets you create the impression that you are drawing on paper with a crayon.

Dotted lets you create the impression that you are drawing with a dotted brush.

Marker lets you create the impression that you are drawing on paper with an ink marker.

Pencil lets you create the impression that you are drawing on paper with a pencil.

Scatter applies color with an irregularly dotted pattern.

Smudgy Marker lets you create the impression that you are drawing on paper with a worn-out ink 
marker.

Solid Smear lets you create a solid smeared area.

Scatter Smear lets you create a randomly smeared area.



Feather Option
The Feather option softens the outer edge of your draw stroke by making the edges fuzzy. Feathering a 
stroke can help blend it into an image.

Increase this number to increase the blurriness of the edge; decrease the number to sharpen the edge. 
Set Feather to 0 to turn it off. Options range from 0 to 100 (where a setting of 100 feathers 100% of the 
brush size).

 If the Feather setting is 100, you get a continuous transition from the fill color through the outline color to 
the adjacent background color. This can create interesting color blending effects.

Transparency Option
The Transparency option sets the amount of transparency of your draw stroke and interior fill. At 0% 
transparency, the stroke is completely opaque; at 99% transparency, the stroke is almost completely 
transparent or invisible.

Note: Because these tools draw directly onto the image and are not vector-based drawings, they cannot 
be selected and moved after they are drawn. For this reason, it is best to work in the manual apply mode 
while experimenting, so several changes can be undone until you get the desired result.

Note: Press Esc before releasing the left mouse button to cancel a drawing.

Merge Mode List Box
This list box contains various editing options. When used in conjunction with editing tools, such as Paint 
or Fill, these options let you combine, or mix, colors using additive or subtractive color theory. You also 
can selectively change an image according to hue, saturation, or lightness and make modifications to the 
red, green, or blue channel of an image.

The Normal option is the default setting in the Merge Mode list box. When Normal is selected, Picture 
Publisher behaves as if Merge Mode is off, and no editing effects are possible.

The Additive option lets you mix colors according to the additive color model. If you paint a red image 
with a blue brush, magenta appears in the image as a result of the additive mixing of red and blue. If you 
paint with a green brush on a red background, you get yellow. To calculate the resultant color, simply add 
the RGB values of the colors together and round down any number over 100 to 100.

An example of additive mixing using green and blue is shown below.

Green R(0) G(100) B(0)
Blue R(0) G(0) B(100)

--------------------------------
Cyan R(0) G(100) B(100)

Adding the R column results in 0, adding the G column results in 100, and adding the B column results in 
100. These values represent a color (cyan) that has the value of R(0), G(100), B(100).

Note: Be sure to adjust all numbers so they do not exceed 100. For example, if the total of the B column 
adds to 140, round the value down to 100.

The Subtractive option lets you mix colors according to the subtractive color model. If you paint on a 
cyan image with a magenta brush, blue appears in the image as a result of the subtractive mixing of cyan 
and magenta. If you paint with a yellow brush on a magenta background, you get red. To calculate the 
resultant color, add the RGB values of the colors together, subtract 100 from the answer, round any 



negative value to 0, and round any number over 100 to 100.

An example of subtractive mixing using cyan and magenta is shown below.

Cyan R(0) G(100) B(100)
Magenta R(100) G(0) B(100)

--------------------------------
R(100) G(100) B(200)

-100 -100 -100
--------------------------------

Blue R(0) G(0) B(100)

Adding the R column results in 100, adding the G column results in 100, and adding the B column results 
in 200. Subtract 100 from the resultant R, G, and B values. These ending values represent a color (blue) 
that has the value of R(0), G(0), B(100). Be sure to adjust all numbers so there are no negative numbers 
and no values over 100. For example, if the B column is -20, round the value to 0; if the B column is 140, 
round the value down to 100.

The If Lighter option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value equal to, or higher than that of the image, the 
color of the editing tool is transferred to the image. If the lightness value is not equal to or less than that of 
the image, no change occurs. For example, if you are painting with white (white has a lightness value of 
100), all of the colors in the image are affected. If you paint with black (black has a lightness value of 0), 
none of colors in the image are affected. Notice that any primary color will paint over any other primary 
color (except white) because all primary colors have the same lightness value (except black, which has 
the lowest lightness value, and white, which has the highest lightness value).

The If Darker option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value lower than that of the image, the color of the 
editing tool is transferred to the image. If the lightness value is not lower than the image, no change 
occurs. For example, if you paint with white (white has a lightness value of 100), none of the colors in the 
image are affected. If you are painting with black (black has a lightness value of 0), all of the colors in the 
image are affected.

The Filter option uses a combination of Additive and Multiply to create a filtered effect.

The Multiply option multiplies the value of the image and the editing tool colors.

The Difference option subtracts the value of the editing tool from the value of the existing color to obtain 
a new color.

The Texturize option uses the editing tool as a texture surface on which the image is painted.

The Color option lets you replace the color of an image with the color of the editing tool, or source, used. 
Color is composed of the "H," or hue value, and the "S," or saturation value, in the HSL color model. For 
example, if you are painting with blue (H=240, S=100), all of the painted colors take on the same H and S 
values of blue. This results in a color change; however, the lightness values remain the same.

Note: Hue and saturation values have no affect on black or white. This is because the lightness value of 
black is 0 and the lightness value of white is 100. Any color with the lightness value of 0 is black 
regardless of the hue and saturation values. Any color with the lightness value of 100 is white regardless 
of the hue and saturation values.



The Hue option lets you replace the hue value of an image with the hue value of the editing tool, or 
source, used. For example, if you are painting with green (H=120), all colors (except white and black) that 
are painted become green. Notice that if you paint with red, white, or black, you get the same results. This 
is because all three of these colors have the same hue value (H=0).

The Saturation option lets you replace the saturation value of an image with the saturation value of the 
editing tool, or source, used. For example, if you are painting with any primary color (except white or 
black) onto any other primary color, only white and black are affected; the other colors remain the same. 
This is because all primary colors have the same saturation value (S=100), except for white (S=0) and 
black (S=0). If you are painting with white or black, the colors become grayscale values; remember that 
grayscale images have no saturation.

The Luminance option lets you replace the luminance value of an image with the lightness value of the 
editing tool, or source, used.

The Red option lets you replace the red channel (using the RGB color model) of an image with the value 
of the red channel source. Only the red channel is affected. The results from using the Red Only option 
are the same as if you were to split the RGB channels using the Channels command, make changes to 
the red channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the red 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 0, 0, 
100 (blue). The red value from the brush (0) replaces the red value in the image (100) to create blue.

The Green option lets you replace the green channel (using the RGB color model) of an image with the 
value of the green channel source. Only the green channel is affected. The results from using the Green 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the green channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the green 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a red image (RGB value = 100, 0, 0), the result is a color that has an RGB value of 100,100, 0 
(yellow). The green value from the brush (100) replaces the green value in the image (0) to create yellow.

The Blue option lets you replace the blue channel (using the RGB color model) of an image with the 
value of the blue channel source. Only the blue channel is affected. The results from using the Blue 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the blue channel image, and then combine the channels.

To determine the resulting value of mixing the source and image, replace the image value of the blue 
channel with the source value. For example, if you are painting with a green brush (RGB value = 0, 100, 
0) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 100, 0, 
0 (red). The blue value from the brush (0) replaces the blue value in the image (100) to create red.

Related Topics
Pencil tool
Rectangular/Elliptical Draw tool
Freehand Draw tool



Pencil Tool

The Pencil tool lets you draw straight lines or freehand sketches.

Use the Pencil tool just as you would draw with a pencil. The paint is applied when you double click at the 
end of a stroke.

Related Topics
Procedure information
Draw tool options



Using the Pencil Tool

To use the Pencil tool:

1. Click the Draw tool in the toolbox. The Draw tool set opens.
2. Click the Pencil tool. The pointer changes to a pencil.
3. Change the options in the ribbon area, if necessary.

A smaller brush size lets you draw more quickly than a larger brush.

4. Point to where you want to begin drawing.
5. Click from point to point on the image. The points are connected with a straight line.

or
Press and hold the left mouse button, and drag the pointer to draw the line. Release the left 
mouse button.

6. Double click the left mouse button when you finish.

Pressing Ctrl while drawing a line forces a horizontal or vertical line.

Related Topics
Tool information
Draw tool options



Rectangular/Elliptical Draw Tool

The Rectangular/Elliptical Draw tool lets you draw a rectangle or square on your image.

This tool can be used to set off text or provide a background for an image (a drop shadow, for example).

Related Topic
Procedure information
Draw tool options



Using the Rectangular/Elliptical Draw Tool

To draw a rectangle:

1. Click the Draw tool in the toolbox. The Draw tool set opens.
2. Click the Rectangular/Elliptical Draw tool. The pointer changes to a pencil.
3. Change the options in the ribbon area, if necessary.
4. Select the active and alternate colors in the Color Swatch.
5. Point to where you want to begin the shape.
6. Press and hold the left mouse button, and drag the pointer to draw the rectangle.
7. Release the left mouse button when the rectangle is the size you want.

Press and hold Shift while drawing a rectangle to create a square.

Related Topics
Tool Information



Freehand Draw Tool

The Freehand Draw tool lets you draw closed, irregular shapes.

Use the Freehand Draw tool just as you would draw with a pencil. The freehand shape closes when you 
double click the left mouse button; you can then fill the shape with a color.

Related Topics
Procedure information
Draw tool options



Using the Freehand Draw Tool

To draw a freehand symbol:

1. Click the Draw tool in the toolbox. The Draw tool set opens.
2. Click the Freehand Draw tool. The pointer changes to a pencil.
3. Change the options in the ribbon area, if necessary.
4. Point to where you want to begin drawing.
5. Click the left mouse button at each point that you want to connect with a straight line.

or
Press and hold the left mouse button, and drag the pointer to draw the freehand shape. Release 
the left mouse button. If you make a mistake, press Backspace to delete the last line segment.

6. Double click the left mouse button to complete the task. The beginning and ending points are 
connected with a straight line.

Pressing Ctrl while drawing a line forces a horizontal or vertical line.

Note: Make sure the ending point is the same as the beginning point to avoid an unwanted line.

Related Topics
Tool information
Draw tool options



Custom View Tool

The Custom View tool lets you change how your image is displayed by adjusting the magnification and 
the parts of the image that are visible.

The Custom View tool and the controls and buttons in the ribbon area let you zoom in and out, and 
change views.

Related Topics
Using the Custom View Tool
Custom View Tool options
Grabber
Zoom In and Zoom Out
Previous View button
View Actual Size button
View Entire Image button
View Full Screen button
QuickZoom button 



Custom View Tool Options

When you choose the Custom View tool, the ribbon area changes to reflect options specific to this tool.

Function List Box
The Function list box lets you choose the Zoom In or Zoom Out option.

Window Area
Click the Sizable option to allow the window to enlarge or shrink around the image. If the option is 
deselected, the window size does not change unless you manually resize it.

The following buttons also appear in the Custom View ribbon.

 Click the Previous View button to toggle between the current view and the previous view.

 Click the Actual Size button to display the image at its actual size.

 Click the Entire Image button to display the entire image in the window.

 Click the Full Screen button to fill the screen with the image.

 Click the QuickZoom button to display the QuickZoom window.

Related Topics
Custom View tool



Using the Custom View Tool

Use the Custom View tool to choose the magnification and the portion of an image you want to view.

To create a custom view:

1. Click the Custom View tool in the toolbox. The pointer changes to a magnifying glass. 
2. Move the pointer to one corner of the area you want to magnify.
3. Press and hold the left mouse button, and drag the pointer diagonally to the opposite corner of 

the area you want to view.
4. Release the left mouse button. The selected area is magnified.

Note: The magnification percentage and name of the image file are displayed in the title bar of the image 
window.

5. Repeat steps 2 through 4 until you have achieved the desired magnification.

You can also use the Custom View tool to zoom in and out.

Related Topics
Tool information
Previous View
View Actual Size
View Full Image button
View Full Screen
QuickZoom button 



Zoom In and Zoom Out 

The Zoom In and Zoom Out options in the Custom View tool ribbon area are functions of the Custom 
View tool that let you zoom in or out of the image in controlled steps. They allow you to see more detail or 
more of the overall image with each successive use by increasing or decreasing magnification to the 
nearest 100% increment.

Note: Press and hold Shift and click the left mouse buttont to switch between Zoom In and Zoom Out.

Related Topics
Procedure information
Custom View tool



Using Zoom In and Zoom Out

Position the Custom View pointer on the image you want to view.

To zoom in:

1. Choose the Zoom In option in the Function area of the ribbon.
2. Move the pointer on the image where you want the zoom center to be and click the left mouse 

button.
or
Press Page Up at any time with any tool selected.

Note: The image repaints to the next higher 100% increment of magnification.

To zoom out:

1. Choose the Zoom Out option in the Function area of the ribbon.
2. Move the pointer on the image and click the left mouse button.

or
Press Page Down at any time with any tool selected.

The image repaints to the next lower 100% increment of magnification.

Repeat the steps to reach the magnification you want.

Note: The Zoom Out option decreases the magnification by one-half when the magnification goes below 
100%.

Note: You can temporarily switch zoom modes (zoom in or out) by pressing and holding Shift, then 
clicking the image. For example, if you are in zoom in mode, press and hold Shift, then click the image to 
zoom out.

Related Topics
Button information
Custom View tool



View Actual Size Button

The View Actual Size button displays an image at the actual physical size of the captured data.

The View Actual Size button makes it easy to view the image on screen at its actual finished size when 
you are visualizing concepts. You might also discover that some detail at higher magnification does not 
adequately show how the image will look when printed.

Note: For the image to be truly 1:1, you must set the Screen Width in the Units panel in the Preferences 
dialog box to your screen width.

Related Topics
Procedure information
Custom View tool



Viewing Actual Size

To view actual size:

1. Click the Custom View tool in the toolbox.
2. Click the View Actual Size button in the ribbon area. The image repaints to its actual size.

Note: For the image to be truly 1:1, you must set the Screen Width in the Units panel in the Preferences 
dialog box to your screen width.

Related Topics
Button information
Custom View tool



View Entire Image Button

The View Entire Image button shows the entire image as large as possible in the window.

Use the View Entire Image button to see the whole image. The image displays at the maximum 
magnification that fits in the window and maintains the original proportions of the image.

Related Topics
Procedure information



Using the View Full Image Button

Use the View Entire Image button in the ribbon area to view an entire image as large as possible.

To use the View Entire Image button:

1. Click the Custom View tool in the toolbox.
2. Click the View Entire Image button in the ribbon area. The image resizes to fill the window

Press Home at any time with any tool selected to show your entire image in the window.

Related Topics
Button information
Custom View tool



Previous View Button

The Previous View button allows you to toggle between the current view and the previous view.

The Previous View button is particularly useful when you want to zoom in to retouch at a higher 
magnification, but want to return to the larger view (last) to review your changes. The current view and the 
previous view exchange places when the Previous View button is used.

Related Topics
Procedure information
Custom View tool



Using the Previous View Button

To use the Previous View button:

1. Click the Custom View tool in the toolbox.
2. Click the Previous View button in the ribbon area. The image repaints to the previous 

magnification.

Press End at any time with any tool selected to revert to the previous view.

Related Topics
Button information
Custom View tool



View Full Screen Button

The View Full Screen button displays the image with nothing else on the screen.

The View Full Screen button is particularly useful when you want to display an on-screen image as part of 
a presentation. You also can use this option to isolate an image for a screen capture.

Related Topics
Procedure information
Custom View tool



Using the View Full Screen Button

To use View Full Image:

1. Click the Custom View tool in the toolbox.
2. Click the View Full Screen button in the ribbon area. The image resizes in the center of a blank 

screen with no window borders.
3. Press Esc to return to the main window.

Related Topics
Button information
Custom View tool



QuickZoom Button

Click the QuickZoom button to open the QuickZoom window, which contains a view-only copy of the 
active image. It allows you to zoom in and out on the image.

The Show QuickZoom command opens a view-only window of the currently selected image. Viewing 
rectangles that are resizable allow you to zoom in and out on the image in the currently active edit 
window. When originally opened, this window shows a miniature representation of the full image.
The QuickZoom window reflects the aspect ratio of the full image. You can resize the window by dragging 
one of its corners. The QuickZoom window always maintains the aspect ratio of the full image in the 
selected window.
The mouse pointer becomes a magnifying glass when on top of the QuickZoom window. By dragging a 
rectangle on the window, you define a zoom area on the active image window.
You can move the zoom area while maintaining its size by clicking once on a new location on the 
QuickZoom window.
The QuickZoom window also gives you easy and fast access to the functions of the Zoom tool. You use 
the tool in the QuickZoom window, but the resulting zoom in and zoom out take place in the active image 
window. The functions are

- shift+click to zoom out
- ctrl+click to zoom in
- Double click for full view
- page up to zoom in
- page down to zoom out
- home to fit the image to your screen

When zooming in and out, the active window resizes if the Sizable option is active in the ribbon.

Related Topics
Procedure information 



Using the QuickZoom Window

To use the QuickZoom window:

1. Click the Custom View tool in the toolbox.
2. Click the QuickZoom button in the ribbon area. The QuickZoom window opens with a copy of the 

current image displayed.
3. Press and hold the left mouse button, and drag the pointer diagonally to the opposite corner of 

the area you want to view.
4. Release the left mouse button. The selected area is magnified.

Related Topics
Button information



Grabber 

The Grabber tool, in the lower right corner where the scroll arrows meet in an image window, lets you 
move your image within the image window. 

The Grabber is similar to using the scroll bars except that you can move horizontally and vertically at the 
same time. It is used to pan around the image at the same magnification while retouching or editing. 

Note: The Grabber does not appear if there are no scroll bars because the entire image is already visible.

Related Topics
Procedure information
Custom View tool



Using the Grabber 

To use the Grabber:

1. Click the Grabber hand in the lower right corner of the image window (when the window has scroll 
bars).

2. Place the pointer on the image. The pointer changes to a hand.
3. Press and hold Button 1, and drag the image to the desired location.
4. Release Button 1 when complete.
5. Repeat steps 2 through 4 until the image is in the desired location.
6. Click the Grabber hand in the lower right corner of the window to turn it off.

Note: You can use the Arrow keys to move the image up, down, left, or right just as you would use the 
Grabber when it is selected.

Related Topics
Button information
Custom View tool



Text Tool

The Text tool lets you add text to your image, select typefaces and point sizes, and choose text attributes.

Use the Text tool to add short captions or annotations to your image. Text added in this way is great for 
producing comprehensives (concepts) or for printing on relatively low-resolution printers (less than 600 
dpi). Text is added to the image as a mask, giving you the ability to create a variety of graphic effects.

Text added to your image takes on the resolution of the image. Because images almost always have 
lower resolution than your printer, you might want to replace Picture Publisher's text with high-resolution 
vector based fonts when your image is offset printed or used for presentation graphics.

One way to add high-resolution vector fonts is to export your image to a vector-based graphics program 
such as Micrografx Designer, Charisma, or Windows Draw.

Related Topics
Text tool options
Procedure information



Text Tool Options

The Text tool options in the ribbon area let you choose the font and font size, and the attributes you want 
for the font.

Typeface, Points, and Style
The Typeface and Points list boxes let you choose which typeface (font) to use and how large it should 
be. You can also specify special styles (bold, italic, underline, or anti-aliased).

You can select from any available Windows font, whether it is a vector or an outline font, including Adobe 
Type Manager fonts.

Angle Area
Lets you enter a clockwise rotation in degrees for the text. You can enter values from 0 through 359.

Transparency Area
Use this area to set the transparency of the selected objects. Larger numbers make the selected objects 
more transparent. 

Merge Mode Area
Use this area to determine how the object is combined with any underlying images visually. Different 
merge modes create different effects, so the best way to determine the proper merge mode is to cycle 
through them until you reach the effect you want.

Related Topics
Tool information
Procedure information



Adding Text to an Image

To add text to an image:

1. Click the Text tool in the toolbox. The pointer changes to a "T" with crosshairs, and the ribbon 
area changes to show the Text tool options.

2. Change text options, such as font, size, and style.
3. Move the pointer to where you want to insert the text.
4. Click the left mouse button to insert the text cursor. 
5. Type the text.
6. Double click the left mouse button when you finish placing the text. The text anchors to the 

image.

Related Topics
Tool information
Text tool options



Color Swatch

The Color Swatch displays the colors that are used when you add or change a color in your image. It also 
lets you open the Color Picker.

The Color Swatch displays the active color that is used when you perform an action involving color. For 
example, if red appears on the top swatch and you create a circle with the Draw tool, the circle has a red 
outline.

The Color Swatch also displays an alternate color. The active color appears on top of the alternate color 
(though it may be right or left). The active color is used when you perform an action. But when two colors 
are needed, such as to create a gradient fill, the alternate color is also used.

The main purpose of the alternate color is to let you move easily between two different colors.

You can change the colors in the Color Swatch using the following tools.

Color Probe
Color Palette
Color Picker



Color Probe Tool

The Color Probe tool lets you select the active color in the Color Swatch by sampling the colors of your 
image.

The Color Probe tool is particularly useful when you want to select colors that exactly match those in your 
image.

Method Area
Choose Point Sample or Rectangular Average in the Method area of the ribbon to determine how colors 
are selected.

Choose the Point Sample option to "browse" the tool over the image, updating the active color in the 
Color Swatch as you pass over colors in an image.

Choose the Rectangular Average option to draw a rectangle over the image. The color to be selected is 
averaged from all the colors within the rectangle.

Related Topics
Procedure information
Color Palette
Color Picker



Selecting Color with the Color Probe

To select a color using the Color Probe tool:

1. Click the Color Probe tool in the toolbox. The pointer changes to a probe (use the lower left tip to 
point).

2. Choose an option in the Method area of the ribbon.
3. Press and hold the left mouse button, and move the pointer over your image to the color you want 

to select (if you selected the Point Sample option). The color under the pointer appears as the 
active color.
or
Press and hold the left mouse button, and drag a rectangle around the colors you want to 
average (if you selected the Rectangular Average option). The averaged color appears as the 
active color after you release the left mouse button.

4. Release the left mouse button. 
5. To select a second color, click the alternate color in the Color Swatch to make it the active color, 

and repeat steps 2 through 4.

Note: Press and hold Shift before pressing the left mouse button to temporarily switch between the Point 
Sample option and the Rectangular Average option.

Related Topics
Tool information
Color Picker



Color Palette

The Color Palette dialog box contains the File Menu and 
Edit Menu to let you select, save, delete, and change color palettes.

The Color Palette is a collection of colors stored together for easy access. For example, we have created 
a palette called Primaries, which contains the colors red, green, blue, cyan, magenta, yellow, black, and 
white.

One common use for palettes is to create one or more for an image you are editing. These palettes 
contain colors taken from the image (using the Color Probe, for example) so you can easily reach them 
for touch-up work.

You can create palettes that contain more than one palette. For example, you might create a palette 
called Waterfall that contains common colors found in a picture of a waterfall. If you want, you can create 
a palette under Waterfall. For example, if the mist contains 10 different colors, you might create a palette 
called Mist under Waterfall.

The name of the palette is displayed in the title bar of the Color Palette dialog box.

Related Topics
Procedure information
Color Probe
Color Picker



Working with the Color Palette

The Color Palette lets you load different color palettes, change existing colors; add, delete, and rename 
palettes; and insert new colors into existing palettes.

To open the Color Palette:

1. Click the Color Palette button in the status bar. The Color Palette dialog box opens.
2. Open the Palette menu to display a list of available color palettes.
3. Choose the palette containing the colors you want to work with.

To change an existing color:

1. Double click a color in the Color Palette dialog box.
2. Choose a new color in the Color Picker. The original color is replaced by the new color.

Related Topics
File Menu
Edit Menu
Tool information



Color Palette File Menu

The File menu in the Color Palette dialog box contains the following commands for loading and saving 
palette files and merging palettes.

New
Load
Save
Save As
Merge
Reset

Note: Palette file and Palette are synonymous. Both terms refer to a collection of similar palettes under 
one PAL file.



Color Palette New Command

The New command in the File menu of the Color Palette lets you create a new palette.

Related Topics
Dialog Box information
Procedure information



New Palette Dialog Box

Entries to Fill Area
Enter the number of colors that you want in the new palette, from 1 to 256.

Set Colors From Image Option
Choose this option to create the new palette based on the colors in an image. A custom color palette can 
help you when you are retouching an image.

Related Topics
Command information
Procedure information



Creating a New Color Palette

To create a new color palette:

1. Open the Color Palette File menu and choose New. The New Palette dialog box opens.
2. Enter the number of colors you want in the Entries to Fill area.
3. Click the Set Colors from Image option, if you want. (This option is available only if an image is 

open.)
4. Click OK. A custom color palette appears.

After a new color palette is created, you can create new palettes to be added to that set.

Related Topics
Command information
Dialog Box information



Color Palette Load Command

The Load command lets you load (open), add, delete, and rename a palette.

Related Topics
Dialog Box information
Procedure information



Load Palette Dialog Box

Palette Name Text Box
The Palette Name title bar displays the name of the current color palette. To load a different color palette, 
click the down scroll arrow to display a list of available color palettes. Choose the palette you want by 
highlighting it and clicking the left mouse button. The Palette Name text box displays the name of the new 
color palette.

File Options Button
Click the File Options button to open a submenu containing the Add, Delete, and Rename commands. 
Choose the Add command to open the Select File dialog box and add a palette to the File Name text box. 
Choose the Delete command to remove a color palette from the File Name text box. Choose the Rename 
command to assign a new name to a color palette file matching the name appearing in the File Name text 
box.

Load Button
Click the Load button to load the chosen color palette.

Related Topics
Command information
Procedure information



Using the Color Palette Load Command

To load a palette:

1. Open the Color Palette File menu and choose Load. The Load Palette dialog box opens.
2. Click the down scroll area to the right of the list box and choose the name of the palette you want 

to load.
3. Click Load. The selected color palette displays in the dialog box.

Related Topics
Command information
Dialog Box information



Color Palette Save Command

The Save command lets you save a custom color palette as a file with a PAL extension.

Related Topics
Procedure information



Using the Color Palette Save Command

To save a palette:

· Open the Color Palette File menu and choose Save.

Related Topics
Command information



Color Palette Save As Command

The Save As command lets you save a custom color palette as a file with a PAL extension.

Related Topics
Dialog Box information
Procedure information



Save Palette Dialog Box

Palette Name Text Box
The Palette Name text box displays the name of the current color palette. To load a different color palette, 
click the down scroll arrow to display a list of available color palettes. Choose the palette you want by 
highlighting it and clicking the left mouse button. The Palette name text box displays the name of the new 
color palette.

File Options Button
Click the File Options button to open a submenu containing the Delete, and Rename commands. Choose 
the Delete command to remove a color palette from the File Name text box. Choose the Rename 
command to assign a new name to a color palette file matching the name appearing in the File Name text 
box.

Save Button
Click the Save button to save the color palette with a new name.

Related Topics
Command information
Procedure information



Using the Color Palette Save As Command

To save a palette:

1. Open the Color Palette File menu and choose Save As. The Save Palette dialog box opens.
2. Type a filename for the palette.
3. Press Enter. The dialog box closes, and the palette is saved as a PAL file.

Related Topics
Command information
Dialog Box information



Color Palette Merge Command

You can merge one palette with another. 

Related Topics
Dialog Box information
Procedure information



Merge Palettes Dialog Box

Palette Name Text Box
The Palette Name text box displays the name of the current color palette. To merge the current color 
palette with another color palette, click the down scroll arrow to display a list of available color palettes. 
Choose the palette you want by highlighting it and clicking the left mouse button. The Palette Name text 
box displays the name of the new color palette.

File Options Button
Click the File Options button to open a submenu containing the Add, Delete, and Rename commands. 
Choose the Add command to open the Select File dialog box and add a palette to the File Name text box. 
Choose the Delete command to remove a color palette from the File Name text box. Choose the Rename 
command to assign a new name to a color palette file matching the name appearing in the File Name text 
box.

Merge Button
The Merge button combines the color palettes you have chosen.

Related Topics
Command information
Procedure information



Using the Color Palette Merge Command

To merge two palettes:

1. Use the default palette, create a palette, or load a palette.
2. Open the Color Palette File menu and choose Merge.
3. Choose the palette that contains the colors and palettes you want to add to the current palette.
4. Press Enter.

Related Topics
Command information
Dialog Box information



Color Palette Reset Command

The Reset command changes the colors in the color palette back to the colors included in the original 
(default) Picture Publisher color palette.

Related Topics
Procedure information



Using the Color Palette Reset Command

To reset the palette:

· Open the Color Palette File menu and choose Reset. The Picture Publisher default color palette 
is restored to the program.

Related Topics
Command information



Color Palette Edit Menu

The Edit menu contains the following commands that let you update, find, and label your color palettes.

Undo
Insert
Delete
Label
Find
Fill
Options
Copy from Active
Auto Set Active



Color Palette Undo Command

The Undo command reverses the last color change to the palette. You must choose the Undo command 
immediately (before doing anything else) to reverse the change.

Related Topics
Procedure information



Using the Color Palette Undo Command

To use the Undo command:

· Open the Color Palette Edit menu and choose Undo. The color palette appears as it did before 
your last change.

Related Topics
Command information



Color Palette Insert Command

The Insert command places a new color before a highlighted color in an open palette.

Related Topics
Procedure information



Using the Color Palette Insert Command

To insert a new color:

1. Click the Color Palette button to open the Color Palette dialog box.
2. Open the Color Palette Edit menu and choose Insert. A blank space (the color of the active color) 

appears in the Color Palette. This is where you will add the color.
3. Display the color as the active color in the Color Swatch, and choose the Copy from Active 

command in the Edit menu. The added color replaced the blank space.
or
Double click the blank space, and select the color from the Color Picker. The selected color 
replaces the blank space.

Related Topics
Command information



Color Palette Delete Command (Edit menu)

Use this command to delete individual colors from a palette. Highlight the color to delete, then click 
Delete.

This command does not delete the current palette. It only removes the currently highlighted color.

Related Topics
Procedure information



Using the Color Palette Delete Command

To delete a color:

1. Select the color in the color palette that you want to delete.
2. Click the Color Palette to open it.
3. Open the Color Palette Edit menu and choose Delete. The color you selected is removed from 

the color palette.

Related Topics
Command information



Color Palette Label Command

This command lets you name individual colors in a palette.

Related Topics
Dialog Box information
Procedure information



Label Color Dialog Box

Enter Color Label Text Box
The Enter Color Label text box lets you type the name you want given to a specific color in the current 
color palette.

Click OK and the label name is given to the color in the color palette.

Related Topics
Command information
Procedure information



Using the Color Palette Label Command

To use the Label command:

1. Click the Color Palette button to open the Color Palette dialog box, and choose the color you 
want to label.

2. Open the Color Palette Edit menu and choose Label.
3. Type a new name for the chosen color in the Enter Color Label text box.
4. Click OK and the name is given to the color in the current palette. 

Related Topics
Command information
Dialog Box information



Color Palette Find Command

This command lets you search for a color by its color label in a palette. You can type the label or use wild 
card characters. An asterisk (*) represents any number of characters and a question mark (?) represents 
a single character.

For example, if you type B*, Picture Publisher finds black and blue, but not purple. (Case, upper and 
lower, is ignored).

Related Topics
Dialog Box information
Procedure information



Find Color Dialog Box

Enter Color Label Text Box
The Enter Color Label text box lets you type the name of a color you want to locate in the current color 
palette. When the color is located, the name displays in the text window and the color displays below the 
text window.

Colors Found
The Colors Found displays the numbers of various colors associated with a given name.

Previous and Next Buttons
These buttons let you toggle from one associated color to another--previous color, next color.

Select Button
The Select button returns you to the current color palette with the selected color highlighted.

Related Topics
Command information
Procedure information



Using the Color Palette Find Command

To find a color in the current palette:

1. Open the Color Palette Edit menu and choose Find. The Find color dialog box opens.
2. Type the color's label. Use wildcard characters, if necessary. The color and its label are 

displayed.
3. Click Next to view more found colors.
4. Click Select to choose the color displayed in the Color Palette dialog box.

Related Topics
Command information
Dialog Box information



Color Palette Fill Command

The Fill command lets you add colors to the palette by inserting a range of colors between two color 
choices. For example, a fill between black and white displays black, increasingly lighter shades of gray, 
then white.

You can choose the number of color gradients and the color model (RGB or HSL). The RGB model 
produces intuitive gradients (blue to purple to red, for example). The HSL model creates rainbows 
between colors (blue to green to red, for example).

Related Topics
Dialog Box information
Procedure information



Fill Palette Dialog Box

Color End Points Buttons
These buttons display the colors chosen for the beginning and end points. Click a button to open the 
Color Picker dialog box.

Entries To Fill Text Box
The Entries to fill text box lets you type the number of color ranges you want between two colors.

Fill Maximum Entries Option
Toggle this option on to define a range with the greatest number of gradients between two colors.

RGB Fill Option
The RGB model (blue to purple to red) produces intuitive color values.

HSL Fill Option
The HSL model creates a rainbow effect (blue to green to red).

Related Topics
Command information
Procedure information



Using the Color Palette Fill Command

To fill a range of colors:

1. Choose the color from which to begin the fill. The fill progresses from the highlighted color to the 
adjacent color on the right. 

2. Open the Color Palette Edit menu and choose Fill. The Fill Color dialog box opens.
3. Type the number of colors you want. A higher number gives a wider range of colors.

or
Click Fill Maximum Entries to automatically generate the largest number possible between two 
colors. Colors that are closer together on the color model (yellow and light yellow, for example) 
produce a smaller range of colors spaced further apart (red and green, for example).

4. Click a color model (RGB Fill or HSL Fill). Click RGB Fill if you are not sure which one to use.
5. Click OK. The added colors appear between the selected color and the color to its right.

Related Topics
Command information
Dialog Box information



Color Palette Options Command

This command lets you change how your color boxes are displayed. You can set the number of columns 
allowable in a row; or you can set the number of rows per column. When all the color boxes can't be 
displayed at one time, a scroll bar lets you move to the undisplayed colors.

Note: The Options command only affects the appearance of the current palette. Other palettes appear as 
they were last viewed.

Related Topics
Dialog Box information
Procedure information



Palette Options Dialog Box

Set Row Size option
The Set Row Size option lets you designate the number of vertical rows to display.

Set Column Size option
Set Column Size lets you determine how many horizontal rows to display.

Click the appropriate option, then type the number you want in the Rows Per Column text box.

Scroll Bar Area
The Scroll Bar area lets you choose how you want the scroll bar to display, either horizontally or vertically.

Related Topics
Command information
Procedure information



Using the Color Palette Options Command

To use the Options command:

1. Open the Color Palette Edit menu and choose Options. The Palette Options dialog box opens.
2. Click Set Row Size, then type the maximum number of colors you want to display on a horizontal 

row.
or
Click Set Column Size, then type the maximum number of colors you want to display in a vertical 
row.

3. Choose the Horizontal or Vertical scroll bar option.
4. Click OK.

Related Topics
Command information
Dialog Box information



Color Palette Copy from Active Command

Choose this command to replace the highlighted color box in the palette with the color currently displayed 
in the active Color Swatch.

Note: Do not confuse the Copy from Active command with the check box Copy to Active. When the Copy 
to Active check box is on, the highlighted palette color is copied to the active Color Swatch.

Related Topics
Procedure information



Using the Color Palette Copy from Active Command

To use the Copy from Active command:

1. Click the Color Palette to open it.
2. Use the Color Palette, Color Picker, or the Color Probe to select a color for the active color 

swatch.
3. Select the palette color you want to replace with the Swatch's active color.
4. Open the Color Palette Edit menu and choose Copy from Active. The selected palette color is 

replaced by the active Swatch color.

Related Topics
Command information



Auto Set Active Command

The Auto Set Active command copies the active color in the current palette to the active color in the Color 
Swatch. Whenever you choose a color, this color is copied to the active color in the Color Swatch.



Color Picker Dialog Box

You can use the Color Picker dialog box to choose exact shades or colors by defining HSL, RGB, or 
CMYK values. You can also intuitively select colors by moving the pointer over hue variations.

Use the Color Picker dialog box when you need to match your colors to a particular application or output 
format, like RGB for film recording, HSL to match another application or CMYK for process color printing.

Choose a color either by entering hue values (as a percentage), or choosing a color model from the Color 
Model list box and then visually selecting the color by positioning the crosshairs over the desired color.

Note: If you prefer levels (0-255) rather than percentages (0-100%), turn off the Use Percentages option 
in the Units panel of the Preferences dialog box.

Color Models
Choose the color model you want from the Color Model list box directly over the color box. Click the 
pointer on the desired color to select it.

Use the Saturation and Lightness model to choose colors based on their intensity and lightness.

Select Hue and Lightness as the color model and move the slider all the way to the right to see the most 
colors (all the colors in the visual spectrum).

Note: Press and hold the left mouse button while moving the crosshairs to show the current color in the 
New Color box.

Hue and Lightness is similar to Saturation and Lightness except you select the intensity of the hue with 
the slider. The lightness and hue are selected in the color box.

As with Saturation and Lightness, move the crosshairs up for a darker hue, down for a lighter hue. Move 
left and right to select different hues.

Hue and Saturation is similar to Saturation and Lightness except you select the hue's lightness with 
the slider. The hue and hue intensity are selected in the color box.

Move the crosshairs down for more saturation (a purer color). Move up for less saturation (more gray, less 
color). Move left and right to select different hues.

The Green and Blue option show cross sections of the RGB (Red, Green, and Blue) color cube and all 
the colors contained in each cross section.

Since the RGB cube is 3-dimensional, only a cross section can be displayed. The cross section is 
determined by the two colors selected in opposite corners (in this case, green and blue). 

Move the cross section back and forth through the cube by changing the third primary color with the slider 
(in this case, red).

Move the slider all the way left to see the colors as they appear on the face of the cube.

Use the Red and Blue option to select colors based on red and blue.

Use the Red and Green option to select colors based on red and green.



Use the Magenta and Yellow option to select colors based on the secondary colors magenta and yellow.

Use the Cyan and Yellow option to select colors based on the secondary colors cyan and yellow. 

Use the Cyan and Magenta option to select colors based on the secondary colors cyan and magenta.

Related Topics
Procedure information
Color Swatch



Selecting a Color with the Color Picker

Double click the Color Swatch to open the Color Picker, then enter color percent values or select a color 
from one of 9 color models.

To select a color with the Color Picker:

1. Double click the Color Swatch in the toolbox. The Color Picker dialog box opens.
2. Select the RGB (Red, Green, Blue) or CMYK (Cyan, Magenta, Yellow, Black) values.

or
Choose a color model from the Color Model list box. Press and hold the left mouse button, and 
move the pointer in the Color Model window. Release the left mouse button when the desired 
color appears in the New Color window.

3. Choose Hue and Lightness in the color model and move the slider all the way to right to see all 
the colors in the Color Model window.

Related Topics
Tool information
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Active window

The window in which you work is the active window. The active window receives the next action.



Apply changes

Sets into memory any changes and edits you have made to the image. Once edits have been applied, 
they can only be removed by using the Revert to Saved command or by reloading the file. Manual or Auto 
Apply modes can be used.



Aspect ratio

The size relationship between the height and width of a mask. A proportional resize of an image changes 
its size but not its aspect ratio. Distortion occurs when the aspect ratio is not maintained.



Back up

To duplicate files (usually) onto a different medium such as a diskette. Backed-up files insure that 
information is not lost if your hard disk fails, for example.



Bitmap

An image made of individual pixels (dots) on the screen. All Picture Publisher images are bitmaps.



Black printer

Also called the key printer, this is the plate used for the black ink portion of four-color printing. Its purpose 
is to emphasize the neutral tones and detail in the shadow areas and enhance the overall contrast by 
forming a truer black than can be made by the combination of the three ink colors cyan, magenta, and 
yellow.



Bleed

An image that extends beyond the edge of the paper (bleeds off) after the final trim.



Blend

Smooths the hard edges of an image when it is pasted onto another. Blending helps minimize the seam 
that commonly appears between the original and the pasted image.



Bounding box

The invisible rectangle that encloses a mask. When you move, resize, or duplicate a mask, a dotted 
rectangle representing the bounding box appears around the actual mask.



Burning

A procedure used by photographers in traditional darkrooms to darken colors. Use the Darken tool in the 
Retouch tool set to darken color values.



Byte

A common unit of computer measurement consisting of eight bits.



Calibration

The process used to correct and adjust for variations which might occur between scanner input and 
printer output.



Cancel

A command button used to close a dialog box without making changes. The Esc key also closes a dialog 
box.



Cascade windows

A Window submenu command that diagonally stacks windows so that the title bars show.



Check box

A small box inside a dialog box that can be toggled on or off. Check boxes usually set several options.



Chrome

Slang for an original color transparency.



Click

To quickly press and release Button 1. When you click the mouse button, you should hear and feel a click.



Client application

An application capable of accepting objects from OLE-compatible server applications



Compound document

A document containing multiple objects created with different OLE-compatible server applications



Embedded object

An object containing a graphic representation of the object and all the information required by the server 
application to re-create the original object



Linked object

An object containing a graphic representation of the object and information identifying the original server 
data file and application



Original file

A file containing the source (original) object created with the server application. The original object can be 
linked to or embedded into a compound document



Paste Link

A command used by the client application to link an object. The Paste Link command is similar to the 
Paste command



Server application

An application capable of copying OLE-compatible objects to the Clipboard.



Clipboard

(See Named Clipboard or Windows Clipboard.)



CMYK

Cyan, magenta, yellow, black. See also Color model.



Color correction

Any process that compensates for deficiencies in the color separation process and process inks.



Color model

A method of representing the color spectrum. Two of the most common primary color models are the RGB 
(additive model where 100% R+G+B = white) and CMYK (subtractive model where 0% C+M+Y+K = 
white) models.



Color Palette

A collection of commonly used colors, similar to an artist's palette.



Color Shield

A type of mask that affects colors instead of a bordered region. Like any mask, the shielded colors can be 
either protected from or the object of the edits.



Color Swatch

Samples of the active and alternate colors in the toolbox. The top swatch is the active color and the 
bottom swatch is the alternate color.



Color value

Numbers (values) assigned to a color based on the color model in use. For example, in the RGB model, 
red has a color value of (100%, 0%, 0% RGB); purple might have a value of (45%, 0%, 56% RGB). Using 
the CMYK color model, red has a color value of (0%, 100%, 100%, 0% CMYK); purple might have a value 
of (53%, 98%, 42%, 3% CMYK).



Command

A word or phrase usually found in a menu that opens a dialog box, enters a mode, or carries out an 
action.



Continuous tone

Images, such as color or black-and-white photographs, where the colors and shades flow continuously 
from one to another. Continuous-tone images cannot be printed in the conventional offset printing 
process; they must first be converted to halftones or some other black-and-white only format.



Control menu

A menu common to all windows. You use the Control menu to resize, move, minimize, maximize, or close 
Picture Publisher's windows.



Control menu box

The box located in the upper left corner of a window that opens the Control menu.



Control Panel

A Windows accessory containing commands for installing printers and fonts, setting up printers and ports, 
and choosing program options.



Copy

An Edit menu command that sets the masked portion of your image into memory in the Windows 
Clipboard. Copy does not change the appearance of the image.



Copy To

An Edit menu command that stores the masked portion of your image as a named Clipboard, new image, 
texture, or custom brush.



Crop

To define a portion of an image you want to retain and remove the excess.



Crosshair

A controller, also referred to as a joystick, for two interactive settings (for example, Contrast/Brightness). 
You change settings by moving the crosshair.



Cursor

The entry point for placing text.



Custom view

To zoom in on an area by drawing a rectangle around it.



Cut

Removes a masked portion of your image and places it into memory in the Windows Clipboard.



Darken

To darken color values. This is similar to the "burning" procedure used by photographers in traditional 
darkrooms.



Default settings

The preset options built into a program. Use the Preferences command in the Edit menu or click the tool 
button at the left side of the ribbon area to change most of Picture Publisher's defaults.



Dialog box

A window that appears when the program needs information from you before it can carry out an action.



Disabled

An option or command that appears in gray type and is not available.



Dithered

A continuous-tone (high resolution) image converted to single-bit halftones (low resolution). Colors are 
dithered when the video graphics card and display adapter are not of a high enough resolution to support 
all colors. Dithering creates the illusion of a color by placing dots of other colors very close together. 



Direction keys

The arrow keys (up, down, right, and left) and the home, end, page up, and page down keys. When used 
alone, the arrow keys scroll across the image on the screen in the direction indicated.

The home key returns the image to its original size, and the end key returns the image to its previous 
view.

The page down and page up keys zoom in and out, respectively, in set increments.



Dodging

A procedure used by photographers in traditional darkrooms to lighten colors.



Dot gain

An increase in the size of halftone dots when they print. Dot gain produces unwanted shadows and 
colors.



Double click

To press and release Button 1 twice rapidly without moving the mouse.



DPI

The number of dots (pixels) per inch on the display or hard copy. Most laser printers print at 300 dpi. 
High-resolution phototypesetters provide 1270 and 2540 dpi.



Drag

To point to a mask or image with the mouse, press and hold Button 1, and move the mouse so that the 
mask or image moves across the screen.



Driver

A program that translates data from software for use with a specific hardware device. For example, the 
Micrografx Picture Publisher printer driver allows your printer to understand the printing signals being sent 
to it from Picture Publisher.



Duplicate window

A window that contains a copy of an image from another window. If you edit the duplicate image, the 
original is also affected.



Embossing

Raising an image above the surface, as if it is indented from the rear.



Encapsulated PostScript format

An image file output format that is used in many page layout programs. Picture Publisher can store files in 
this format (EPSF or EPS) but cannot import them for editing because EPSF is designed to be passed on 
to a PostScript printer.



Erase

To selectively remove sections of image edits that have not yet been applied.



Expanded memory

Memory beyond the 640 kilobytes available to applications from DOS. To use expanded memory, you 
must have an expanded memory board and special software.



Extended memory

Memory beyond the usual one-megabyte limit, used by memory-disk programs such as IBM VDISK and 
MicrosoftRAM Drive. To use extended memory, you must have an extended memory board and special 
software.



Extended name

Helps define and manage all Picture Publisher files (except image files) by allowing you to name a file 
with up to 30 characters to give it a better description. For example, textures, maps, brushes, masks, and 
print styles can be given extended names. Picture Publisher also applies an eight letter name for the file 
to meet DOS requirements.



Extension

The period and one to three characters at the end of a filename that identify the kind of information in the 
file. For example, .TIF is the extension for many Picture Publisher image files.



File type

A format used to define a file. Picture Publisher recognizes different file types such as TIFF,    BMP, Targa 
(TGA), GIF, and EPS.



Filter

Traditionally, a special lens used by a photographer or developer to enhance a photograph (using a 
softening lens to give an image a misty quality, for example). Picture Publisher's filters provide many of 
the same effects offered by expensive filtering lenses.



Font

A specific set of characters in a specific typeface design.



Frisket

A protective mask, usually within another mask.



Grab

Capturing a frame onto your computer screen from a live video or video cassette for editing.



Gradient

A gradual fade in color intensity or a gradual fade from one color to another.



Gray value

The amount of gray in an image, where a gray value of 100% is black and a gray value of 0% is white.



Grayscale

An image having multiple shades of gray. Also, the ability of a scanner to capture more than just the gray 
values of white and black.



Halftone

An image made of tiny dots of different sizes (like a photograph in a newspaper). The dots in a halftone 
are equally spaced, so larger dots compose the shadows and smaller dots create the highlights. 
Halftones can be color or black and white.



Handles

Square boxes that appear on the corners and sides of the bounding box of a symbol when the symbol is 
selected. You use handles to resize a symbol.



Highlight

The brightest value in a continuous-tone or halftone image.



Hint line

A one-line message at the bottom of the main Picture Publisher window that provides information about a 
feature.



Hourglass cursor

The pointer changes to an hourglass symbol to indicate that the program is performing an operation, such 
as saving a file. When the cursor returns to a pointer, you can continue working.



Hue

The quality of a color that makes it different from other colors. For example, an apple's hue is red even 
though its color value might not be 100% red. The color you use to describe an object is its hue (you 
would never say the apple is green or orange). Lightness and saturation, the two other components of 
color, do not affect the hue (for example, a light yellow banana has a hue of yellow).



Icon

A small graphic symbol that represents a software program, a command, or a tool. You activate the 
program, command, or tool by double clicking or clicking the icon.



Image cache

A temporary RAM-like scratchpad area on the hard disk.



Image window

A window that displays your image. Image windows are displayed in the working area of the Picture 
Publisher window and are manipulated like any window.



Ink correction

Modifies print styles to compensate for tainted inks.



Invert

Reverses colors in an image.



JPEG

An international image file compression standard for continuous tone color and monochrome images.



K

An abbreviation for black, as in CMYK, where K stands for the black printer or black separation.



Kilobyte (K byte)

1,024 bytes. This term is often used as a measure of memory capacity.



Lighten

To lighten color values. This is similar to the "dodging" procedure used by photographers in traditional 
darkrooms.



Lightness

The amount of white or black in a color. Lightness of 100% and 0% creates white and black, respectively. 
Lightness is one of the three components of perceived color. Hue and saturation are the others.



Line art

Images with only two gray values: black and white. If you save a continuous-tone image as line art, the 
colors in the image will be reduced to black and white.



Line screen

Also known as screen ruling. This is a measure of the distance between the centers of halftone dots as 
they repeat along the screen angle. For example, in a 65-line screen at a 45° angle (a typical line screen, 
or screen ruling, for a black-and-white halftone in a newspaper), there are 65 halftone dots in an inch. 
Low (course) line screens, such as 65 and 85, do not produce an illusion of grayscale as successfully as 
medium screens,    such as 100 or 120, or high screens, such as 133 or 150.



List box

A dialog box containing a list of names.



LZW compression

A compression function that compresses bitmap files (TIFF files, for example) to a fraction of their original 
size.



Map

A graph representing the mapping of color values in an image. A map changes the input values to new 
output values. Unedited, it represents a mapping of 1:1 (an input of 50% gray is output at 50% gray, for 
example). You can alter values by manipulating points on the curve (so that an input of 50% gray is output 
at 75% gray, for example).



Mask

An outline placed around an area to indicate that the area is protected from edits or that edits only occur 
within it. Masks can also be used to copy or cut out areas of an image so they can be saved and used 
later. See also Color Shield.



Matrix

The square grid that forms each halftone dot in electronic halftoning. The larger the matrix, the more 
possible variations of dot size and shape, which creates a better illusion of continuous tone because the 
transitions from shade to shade can be more subtle. However, when you raise the spots on a single 
matrix, reduce the line screen.



Menu

A list of commands organized under a title in the menu bar. For example, the Help menu lists commands 
that provide on-line help. 



Menu bar

The bar at the top of the Picture Publisher window (under the title bar) containing menu titles.



Midtones

The middle values, between the highlights and the shadows, in an image.



Minimize and maximize boxes

The boxes located in the upper right corner of each window that are used to reduce or enlarge the 
window. The frame around the window also is used to resize the window.



Mirror

Flips the masked part of an image vertically, horizontally, or diagonally.



Mode

A subset of program features specific to a certain task or set of tasks. For example, when you select the 
Eraser tool in the toolbox, you are in erase mode. Generally, you can only perform actions related to the 
mode you are in (for example, you can't draw masks in erase mode).



Moiré patterns

Undesirable and distracting screen patterns created when two or more screens are used to create a 
halftone.



Monochrome

A single color. Typically, monochrome refers to the color black on a white background.



Montage

A single image created by cutting and pasting other images together.



Mouse

A pointing device that you move across a flat surface to move the pointer on your screen. A mouse can 
have one or more buttons, which you press to carry out various actions.



Named Clipboard

A file used to store or retrieve pasted images.



Object

An object consists of anything you create in Picture Publisher and transfer through the Clipboard.



Offset printing

The process that prints by transferring ink from a flat plate or cylinder to a rubber blanket. The blanket 
then transfers the ink to the paper.



Page orientation

The position of an image on paper. Portrait (vertical) orientation displays a page taller than it is wide. 
Landscape (horizontal) orientation displays a page wider than it is tall.



Palette

See Color Palette.



Paper size

The physical size of the paper in a printing device.



Paste

To insert an image stored in the Clipboard into another image.



Paste From

Inserts an image from a named Clipboard into the working image.



Pivot point

The point around which an object is rotated. In Picture Publisher, the pivot point is the center of a masked 
or pasted image.



Pixel

A picture element. The smallest unit (dot) of a bitmapped image.



Plugging

A kind of dot gain where areas between dots that should remain open get filled in and become solid.



Point size

A measurement of the height of characters in a font. There are approximately 72 points in an inch.



Pointer

A graphic symbol used to show the current screen location of the mouse. You move the pointer by moving 
the mouse. The pointer changes shape to reflect the tool you choose.



Posterize

Posterizing gives a "paint by number" effect by reducing the number of color values in an image. 



Prescan

To take a low-resolution, quick scan of the entire scanning bed.



Press

To press and hold the mouse button momentarily.



Printing plate

The media containing an image that is used to create an impression.



Print spooler

A Windows accessory that creates a print file before printing begins.



Print area

The area, as defined either by a printer driver or by a printer, that can be printed using a specific printer 
driver or printer.



Process color

Also called full color. The type of printing that uses four different printing plates (cyan, magenta, yellow, 
and black) which, when combined together, produce a color image.



Registration marks

Crosshair or target marks in the same place on each color sheet of a color image used to align plates 
properly during printing.



Resize

To change the size of a mask or window. Dragging a handle into the mask or window makes it smaller; 
dragging a handle outward makes it larger.



Resolution

A measurement of data for monitors (usually expressed as pixels per square inch) and printers (dots per 
square inch).



RGB

Red, green, blue. See also Color model.



Ribbon area

The area at the top of the window that displays options associated with the current tool.



Saturation

The intensity or purity of a color. For example, a "reddish" apple is not as saturated as a "red" apple. Zero 
saturation means that the color has been replaced by its corresponding gray value (black-and-white 
television images are good examples of colors with zero saturation). Pure saturation (100%) means the 
color contains no gray. Saturation is one of the three components of color; hue and lightness are the 
others.



Scanner

A device that transfers images from video or paper into the digital format used by computers.



ScatterPrint

Picture Publisher's dithering program that produces an edge-enhanced line art image from a continuous-
tone image.



Screen angle

The angle at which halftone dots repeat, typically 45°, 75°, 90°, and 105°. The most typical in black-and-
white reproduction is 45°, since this is the angle in a single halftone pattern that most easily fools the 
human eye and brain into seeing continuous tone where there is really only line art. For process color 
printing, each image has four halftones, each with a separate screen angle. The most typical angles used 
for process color separations are 90° for yellow, 105° for cyan, 45° for black, and 75° for magenta.



Scroll bars and scroll arrows

The bars and arrows at the right side and bottom of windows that allow you to travel vertically and 
horizontally across the window to see parts of the image that lie beyond the editing window.



Select

To choose an icon, command, check box or option, or symbol or part of a symbol.



Shadow value

Typically, the darkest value in a continuous-tone or halftone image.



Shortcut keys

A function key or a mnemonic key, used with the Alt, Ctrl, or Shift key, that executes a command quickly. 
Shortcut keys appear in the hint line at the bottom of the Picture Publisher window.



Slider

A bar that changes a setting when the wedge underneath it is moved.



Spool

To send a page to a file before printing. When spooling is complete, the page begins to print and you may 
work in the drawing window again or select another print operation.



Step scales

Bars with eleven different values of gray, printed on the page to monitor the printer's output.



Submenu

Opens when you choose a command with an arrow opposite it. Submenus provide additional commands 
related to the desired task you want to accomplish.



Swatch

Traditionally, a sample strip of cloth used to verify the accuracy of a material's color.    See Color Swatch.



Texture

A pattern (rather than a color) such as crushed velvet or woodgrain that can be added to an image.



Threshold

The cutoff point at which the overall color values are either shown or deleted.



TIFF

An image file format. Picture Publisher accepts TIFF files and can save images in this format. TIFF is an 
abbreviation for Tagged Image File Format, whose specifications were developed by Aldus and Microsoft. 
There are line art, grayscale, and color TIFFs.



Title bar

The bar across the top of a window that contains the program name (Picture Publisher) or the filename. 
The title bar also contains the window's Control menu box and maximize and minimize boxes.



Toggle

To alternately turn a function on and off.



Toolbox

The area of the main Picture Publisher window containing the nine Picture Publisher tools: Mask, 
Retouch, Filter, Fill, Draw, Custom View, Eraser, Text, Color Probe. The toolbox also displays the Color 
Swatch.



Tool set

A group of similar tools that can be used to edit an image and are accessed from the main toolbox.



Trim marks

Marks on your film or paper that indicate to the printer your page size and trim boundaries.



Type style

A standard variation within a typeface family. Common styles include roman (also called plain, normal, or 
regular), italic, bold, and bold italic. Each style within a typeface family is a unique typeface design of its 
own. For example, the design of Bitstream Dutch Bold is separate from Bitstream Dutch Roman.



Typeface

The design of a set of characters. Bitstream Charter Roman and Bitstream Charter Italic are examples of 
typefaces. They share a common typeface family: Bitstream Charter; and they each have a particular 
style: roman (also called plain, normal, or regular) and italic.



UCR

Undercolor removal. An option used when equal amounts of CMY values appear together, creating a 
brown hue. UCR replaces the brown with black to reduce the amount of ink used in printing and increase 
details in shadows.



Value

See Color value.



Vignette

See Gradient.



Window

A rectangular area on the screen that displays a program. The Picture Publisher window can contain 
several different image windows within its working area.



Windows Clipboard

A data exchange storage area for an image area that has been masked and then cut or copied from a 
parent image.



Add FileBrowser

The Add FileBrowser lets you add print styles, calibration styles,

Path Area
The Path area displays the current path.

File Name Text Box
Type the name of the file you want to add in the File Name text box.

Files List Box
The files of the selected file format are listed for the current directory in the Files list box below the File 
Name text box.

In the Files list box, type the first letter of a filename to move the cursor to the first file beginning with that 
letter.

Drives List Box
The Drives list box displays the drives available on your computer. Click a drive to see the directories and 
files on that drive. For example, if you choose A, the directories and filenames on the diskette in drive A 
appear in the appropriate list box. 

Directories List Box
The Directories list box displays directories. To see the filenames in another directory, choose the 
directory name or type the directory name separated with backslashes in the File Name text box. For 
example, type c:\pictpub4\tutorial, and press Enter. The filenames associated with the specified drive 
and directory appear in the list box.

To change directories, point to the directory containing the files you want to open and double click the left 
mouse button. The list box changes to the directory you selected.

Size Area
The Size area displays the size of the selected file.

Date Area
The Date area displays the date of the selected file's last save.

Time Area
The Time area displays the time of the selected file's last save.



Edit Command (Halftone Style)

The Edit command lets you change the selected halftone style.

Related Topics
Dialog Box information 
Procedure information 



Edit Halftone Style Dialog Box

Dot List Box
Click the down arrow in the list box to choose the shape of dot (traditional halftone dots) for halftones.

Process Color Swatches
Below the Dot list box are color swatches representing the four process colors (CMYK).

Frequency Column
Enter the desired screen frequency to the right of each color swatch.

Angle Column
Enter the desired screen angle for each color (in degrees or tenths of a degree) in the Angle column.

Minimum Highlight Dot
This is an "overall" setting to establish limits on how small you want the output halftone dots to be.

Maximum Shadow Dot
This is an "overall" setting to establish limits on how large you want the output halftone dots to be.

Related Topics
Command information 
Procedure information 



Defining a Halftone Style

To define a style for halftone screening:

1. Open the File menu and choose Setup. The Setup submenu opens.
2. Choose Printer. The Setup Printer dialog box opens.
3. Highlight the print style you want to edit.
4. Click Setup Print Style. The Setup Print Style dialog box opens.
5. Click the File Options button to the right of the Halftone Style list box. A submenu opens.
6. Choose Edit. The Edit Halftone Style dialog box opens.
7. Define the shape of dot (traditional halftone dots) by clicking one of the three choices represented 

by the shape buttons.
8. Enter the desired screen frequency in the Frequency lines/inch column to the right of each color 

swatch.
9. Enter the desired screen angle for each color (in degrees or tenths of a degree) in the data box to 

the right of the screen frequency.
10. Set the minimum and maximum highlight dot size percentages.
11. Click OK.

Related Topics
Command information 
Dialog Box information 



Add Command

The Add command opens the Add FileBrowser and lets you add a file to a dialog box.



Halftone Style Name Dialog Box

The Halftone Style Name dialog box lets you rename a halftone style.

Enter New Name Text Box
Type a name for the halftone style, then click OK.



Delete Command (File Options Submenu)

The Delete command lets you delete the selected file. When you choose Delete, a confirmation message 
appears. Click Yes to delete the file, or click Cancel to not delete the file and return to the dialog box.



Rename Command

The Rename command lets you rename the selected file.



Create Command

The Create command lets you measure a print scale and save it for printer calibration. Printer calibration 
helps you print consistent images that closely resemble the original.

Related Topics
Dialog Box information 
Procedure information 



Calibrate Printer Dialog Box

The Calibrate Printer dialog box lets you create your own print calibration maps by measuring a step 
scale or using a map supplied with your device or with Picture Publisher. Measuring new maps requires 
you to first print a color step file provided with Picture Publisher. You then scan it back in with a calibrated 
scanner. You use Picture Publisher to measure the image and create an output map for differences 
between the scanned image and a set of values built into Picture Publisher. You can do this for both 
grayscale and color scanners.

Printer Calibration Name List Box
Click the down arrow to display the printer calibration names, then highlight one to select it.

Measure Image Button
Click the Measure Image button to measure the image. Picture Publisher creates an output map, whose 
values are reflected below the color swatches in the dialog box.

Related Topics
Command information 
Procedure information 



Calibrating a Printer

You can calibrate your printer so that the results from your printer look close to the original image. To 
calibrate your printer, print the generated step scale (STEPS.TIF supplied with Picture Publisher) and 
scan the results back into Picture Publisher with a calibrated scanner.

To calibrate a printer:

1. Open the file STEPS.TIF. (This is a color image, but it can be used when calibrating a black-and-
white printer.)

2. Open the File menu and choose Print. The Print dialog box opens.
3. Click Setup. The Setup Printer dialog box opens.
4. Choose one of the calibration print styles that matches your printer.
5. Click OK to close the Setup Printer dialog box.
6. Click Print to send the file STEPS.TIF to your printer.
7. Scan the results from your printer with a scanner that has been calibrated.
8. Open the File menu and choose Setup. A submenu opens.
9. Choose Calibration. A submenu opens.
10. Choose For Printing. The Calibrate Printer dialog box opens.
11. Drag a rectangle around the scanned scale.
12. Click the Measure Image button. A message appears asking if you want to update the readings.
13. Click OK.
14. Click the Save button and type a name for the calibration file. The calibration map is saved and 

can be selected by choosing the Setup Printer command in the File menu.

After you create calibration maps for your scanner and printer and select them in the Setup Scanner and 
Setup Printer dialog boxes, you have achieved "closed-loop" calibration. This means the output you 
receive from the printer is matched to the original scanned image as closely as possible. This calibration 
gives you confidence that you can scan and print with accuracy and eliminates trial-and-error guesswork 
with each image. Once your system is calibrated, you can focus on the more creative aspects of image 
editing.

If you do not calibrate your scanner or edit an image that someone else has scanned, you must adjust the 
gray shades so that they match the shades in the original photograph. Picture Publisher has commands 
to do this, including Apply Calibration Map, Contrast/Brightness and Tone Balance.

If you do not calibrate your printer, you should anticipate printer distortions that can occur and 
compensate with the mapping tools to produce better images. This is a trial-and-error process, so be 
prepared to spend a lot of time using this method. It is better, and more efficient, to calibrate your system.

Related Topics
Command information 
Dialog Box information 



Edit Command (Print Calibration)

The Edit command lets you adjust a print calibration style.

Related Topics
Dialog Box information 
Procedure information 



Edit Print Calibration Style Dialog Box

The Edit Print Calibration Style dialog box is for setting up maps to compensate for differences in output 
devices. You do this by specifying an input intensity and a corresponding output intensity for a range of 
colors.

Color Option Buttons
Click a color option button to select the color you want to change.

Graph Area
The Graph area lets you change the color map visually by dragging the graph points from one place to 
another. The Input and Output edit boxes display the current position of each point as you change it.

Input and Output Edit Boxes
These boxes let you move points on a graph by entering values in a list.

Reset Button
Click the Reset button to restore the currently-selected channel colors to their original setttings.

Reset All Button
Click the Reset All button to restore all channels to their original settings.

Related Topics
Command information 
Procedure information 



Editing a Print Calibration Style

To edit a print calibration style:

1. Open the File menu and choose Setup. The Setup submenu opens.
2. Choose Printer. The Setup Printer dialog box opens.
3. Click Setup Print Style. The Setup Print Style dialog box opens.
4. Click the File Options button. A submenu opens.
5. Choose Edit. The Edit Print Calibration Style dialog box opens.
6. Choose a color button and adjust the map as necessary.
7. Click OK to close the dialog box.

Related Topics
Command information 
Dialog Box information 



Printer Calibration Name Dialog Box

The Printer Calibration Name dialog box lets you rename a printer calibration style.

Enter New Name Text Box
Type a name for the printer calibration style, then click OK.



Create Command (Scanner Calibration)

The Create command lets you create a new calibration style.

Related Topics
Dialog Box information 
Procedure information 



Calibrate Scanner Dialog Box

Scanner Calibration Name List Box
Click the down arrow to display the scanner calibration names, then highlight one to select it.

Measure Image Button
Click the Measure Image button to measure the image. Picture Publisher creates an input map, whose 
values are reflected below the color swatches in the dialog box.

Related Topics
Command information 
Procedure information 



Calibrating a Scanner

Picture Publisher supplies scanner calibration maps for most popular scanners; however, you can also 
create your own scanner calibration map. Making your own map is important because optical and sensing 
technology varies among scanners, even if they are made by the same manufacturer. Also, the optical 
sensors in scanners vary over time in their ability to sense levels of gray. Therefore, to have the most 
accurate calibration map, you should create your own.

Note: If you have a color scanner, perform the following steps twice--once with the Grayscale option 
selected and once with the Color option selected.

To calibrate your scanner:

1. Open the File menu and choose Setup. The Setup submenu opens.
2. Choose Scanner. The Setup Scanner dialog box opens.
3. Click the None option, if it is not already selected.
4. Place the step scale on your scanner bed.
5. Open the File menu and choose Scan. The Scanner dialog box opens.
6. Choose Grayscale the Scan Type list box.
7. Click Prescan to view the step scale in the preview window.
8. Move the cursor to a corner of the step scale and drag a rectangle around the step scale.
9. Release the left mouse button to set the crop rectangle.
10. Type 150 in the Resolution area.
11. Click Scan to scan the image into a new window on your desktop.
12. Open the File menu and choose Setup. The Setup submenu opens.
13. Choose Calibration, then choose For Scanning. The Calibrate Scanner dialog box opens.
14. Drag a rectangle around the step scale. (Do not include the cross-hatch patterns at the top of the 

step scale image.)
15. Release the left mouse button.
16. Click the Measure Image button. A message appears asking if you want to update the readings.
17. Click OK.
18. Click OK again.
19. Click the Save button and type a name for the calibration map. The calibration map is saved and 

can be selected by choosing the Setup Scanner command in the File menu.

Note: If you have a color scanner, repeat all of the above steps, but choose Color in the Scan Type list 
box instead of Grayscale. Measurement for color and gray calibration can be included in a single map, so 
you only need to save a single file.

Related Topics
Command information 
Dialog Box information 



Edit Command (Scanner Calibration)

The Edit command lets you edit scanner calibration maps.

Related Topics
Dialog Box information 
Procedure information 



Edit Scan Calibration Dialog Box

The Edit Scan Calibration dialog box is used to measure the differences between the scanned image and 
the set of known values. You can do this for both grayscale and color scanners.

Color Option Buttons
Click a color option button to select the color you want to change.

Graph Area
The Graph area lets you change the color map visually by dragging the graph points from one place to 
another. The Input and Output edit boxes display the current position of each point as you change it.

Input and Output Edit Boxes
These boxes let you move points on a graph by entering values in a list.

Reset Button
Click the Reset button to restore the currently-selected channel colors to their original setttings.

Reset All Button
Click the Reset All button to restore all channels to their original settings.

Related Topics
Command information 
Procedure information 



Editing a Scanner Calibration Style

To edit a scanner calibration style:

1. Open the File menu and choose Setup. The Setup submenu opens.
2. Choose Scanner. The Setup Scanner dialog box opens.
3. Click the File Options button to the right of the Scanner Calibration Name list box. A submenu 

opens.
5. Choose Edit. The Edit Scan Calibration dialog box opens.
6. Choose a color button and adjust the map as necessary.
7. Click OK to close the dialog box.

Related Topics
Command information 
Dialog Box information 



Edit Command (Color Separation Style)

The Edit command lets you adjust a color calibration style.

Related Topics
Dialog Box information
Defining options for ink correction
Defining options for black generation



Edit Color Separation Style Dialog Box

Recipe for Printing Red
Adjust the percentages of magenta and yellow inks used to print red.

Recipe for Printing Green
Adjust the percentages of yellow and cyan inks used to print green.

Recipe for Printing Blue
Adjust the percentages of cyan and magenta inks used to print blue.

Amount of Black to Generate Area
As with calibration values, Picture Publisher stores black generation values in a table known as a map. 
Each map is stored in a different file. Picture Publisher provides these maps: None, Extra Light, Light, 
Medium, Heavy, Extra Heavy, and Maximum. 

Black Removal (UCR) Area
Gray component replacement (GCR), similar to undercolor removal (UCR), is a technique in which an 
equivalent amount of the CMY colors (called the gray component) is removed from the color and replaced 
with black ink.

Change the percentage settings for GCR amount using the up and down scroll arrows. Increasing GCR 
causes the Black Boost Amount to decrease.

Black Boost Area
The amount of black ink used on the black ink "plate" (the surface carrying the image to be printed) is not 
limited to just what can be removed from the other plates. You can specify any amount of black ink to be 
generated at each level. The difference between the amount generated by GCR is added as a "black 
boost."

Change the percentage settings for Black Boost amount using the up and down scroll arrows. Increasing 
Black Boost causes the GCR amount to decrease.

Related Topics
Command information
Defining options for ink correction
Defining options for black generation



Defining Options for Ink Correction

To define options for ink correction:

1. Click the Ink Correction tool. The right panel changes to display the options for the ink correction. 
(These settings are not used when working with a monochrome printer.)

2. Select the Ink Correction option in the panel if necessary.
3. Change the percentages of magenta and yellow inks used to print red.
4. Change the percentages of yellow and cyan inks used to print green.
5. Change the percentages of cyan and magenta inks used to print blue.

To make a change, place the pointer inside the color band between the two colors. Press and hold the left 
mouse button, and drag it one way or the other to reduce the intensity of one of the component colors. 
The data boxes below are interactive and represent the color shift as a percentage. For specific values, 
type th epercentage directly into the data box.

Related Topics
Command information
Dialog Box information



Defining Options for Black Generation and UCR

To define options for black generation and GCR:

1. Click the Black Generation tool. The right panel changes to display the options for black 
generation and GCR.

2. Click the down arrow at the right of the list box. A list of black generation maps appears. They 
include None, Extra Light, Light, Medium, Heavy, Extra Heavy, and Maximum. 

3. You can change the percentage settings for GCR Amount or Black Boost Amount if desired. Note 
that increasing GCR causes the value for black boost to decrease and vice versa.

Related Topics
Command information
Dialog Box information



Subject Index

Acquire command
Airbrush tool
Album menu 
Apply Calibration Map command
Arrange command
Auto Apply command
Auto Set Active command (Color Palette)
Calibration command 
Chalk or crayon text
Channels   command  
Cleanup Thumbs command (ImageBrowser) 
Clone tool
Close All command
Close command (File menu)
Close command (Window menu)
Color Balance command 
Color Palette
Color Picker
Color Probe tool
Color Swatch
Color Tint Fill tool
Contrast/Brightness command
Convert To command
Copy command (Edit menu)
Copy command (ImageBrowser) 
Copy from Active command (Color Palette)
Copy To command
Create command (ImageBrowser) 
Create command (ImageBrowser Thumbnails menu) 
Crop command
Custom View tool options
Custom View tool
Cut command
Darken tool
Delete command (Album menu) 
Delete command (Color Palette)
Delete command (Edit menu)
Delete command (ImageBrowser) 
Delete command (ImageBrowser Directory submenu) 
Delete Thumbs command (ImageBrowser) 
Deselect All command (ImageBrowser) 
Directory command (ImageBrowser) 
Draw tool
Drop shadow text
Duplicate command
Edit menu
Edit menu (ImageBrowser) 
Effects   command  
Embossed text
Eraser tool 
Exit command
Expand command
Export Album 
Export Database command 



FastBits mode 
Feather command 
File menu (ImageBrowser) 
File menu
Fill command (Color Palette)
Fill tool
Filter tool
Find command (Color Palette)
For Printing command 
For Scanning command 
Freehand Draw tool
Freehand Mask tool
Glow text
Gradient Fill tool
Help menu 
Hide Marquee command 
Hue/Saturation command
Image menu
Import Album 
Import Database command 
Insert command (Color Palette)
Invert command (Image menu)
Invert command (Mask menu) 
Invert Selection command (ImageBrowser) 
Label command (Color Palette)
Lighten tool
Edit menu
Load command (Color Palette)
Low Resolution mode 
Manual Apply command
Map menu
Mask menu 
Mask Point Editing tool
Mask tool
Mask Transform tool
Merge command (Color Palette)
Mirror command
Modify Color Maps command
Monitor command 
Move command (ImageBrowser) 
Move Thumbs command (ImageBrowser) 
Neon text
New command (Album menu) 
New command (Color Palette)
New command
Open command
Optimized Preview command
Options command (Color Palette)
Paint on Mask tool 
Paint tool
Paste As New Image command
Paste command
Paste From command
Pencil tool
Posterize/Threshold command
Preferences command (ImageBrowser) 



Preferences command
Previous View button
Print command
Print Thumbnails command (ImageBrowser) 
Printer command 
QuickZoom button 
Recall command
Rectangular/Elliptical Draw tool
Rectangular/Elliptical Mask tool
Redo command
Rename command (Album menu) 
Rename command (ImageBrowser) 
Rename command (ImageBrowser Directory submenu) 
Reset command (Color Palette)
Retouch tool
Revert To Saved command
Rotate command
Save As command
Save As command (Color Palette)
Save command
Save command (Color Palette)
Save command (Mask menu)
Save Positions command
Scan command
Scanner command 
Select All command (ImageBrowser) 
Setup command
Sharpen tool
Show/Hide command
Size command
Smart Fill tool
Smart Mask tool
Smear tool
Smooth tool
Stitch command 
Stroke command 
Text mask
Text tool
Text tool options
Texture Fill tool
Texture tool
Thumbnails menu (ImageBrowser) 
Tone Balance command
Undo command (Color Palette)
Undo command
Undo/Redo Mask command 
Using the Custom View Tool
View Actual Size button
View Entire Image button
View Full Screen button
View Thumbnails/View File Names command (ImageBrowser) 
Window menu
Zoom In and Zoom Out



Using On-line Help

On-line help messages provide detailed information about commands, dialog boxes, buttons, and tools; 
techniques for drawing and editing; and additional concepts specific to Picture Publisher and the 
Windows environment. Using on-line help is more convenient than using a manual because getting 
information is as easy as pressing a button.

Accessing On-line Help

You can access help one of two ways. The first way involves pressing F1 to access context-sensitive 
help. When you press F1, you receive a help message specific to the command, dialog box, button, or 
tool you choose or open.

The second way involves using the Help menu. The Help menu lets you access information about Picture 
Publisher commands, terms and phrases, error messages and solutions, shortcut keys, and topics 
specific to Picture Publisher and the Windows environment.

How Help Messages are Organized

Finding information in the Picture Publisher help system is easy; it is much like using a roadmap. It 
provides landmarks (related topics) and pointers (jump terms) to easily get you where you want to go.

Help messages are organized hierarchically. Topics are "linked" to subtopics by jump terms. 

All Picture Publisher commands contain a Related Topics section that points you to additional information 
related to the following: command information, dialog box information, and procedure information.

Command Messages
Command messages define and describe commands in Picture Publisher. 

Dialog Box Messages
Dialog box messages list and explain the areas of a dialog box.

Procedure Messages
The procedure message contains step-by-step instructions for performing a particular task.

Jump Terms
Some help messages contain underlined words and phrases called "jump" terms. A jump term takes you 
to a related message for that term. Jump terms let you move throughout the help system without returning 
to the Help menu.

Glossary Terms
Words underlined with a dashed line have definitions attached to them. To view a definition for a word, 
click the left mouse button. After reading the definition, click the left mouse button again to close the 
definition.

Printing Help
You can print a help message using the Print Topic command in the File menu of the Help window.

To print a help message:

· Click the Help File menu and choose Print Topic. 

Closing Help



You can close help and return to the image window in one of three ways.

· Double click the Control menu box in the Help window.
· Click the Help File menu and choose Exit.
· Click the Help Control menu and choose Close, or press Alt+F4.

Picture Publisher Help

Designed, written, and produced by Shannon B. Krakosky.



Using Picture Publisher

Choose one of the following entries to learn more about how to use Picture Publisher.

Printing with Picture Publisher
Setting Up Your Computer Efficiently
Using Text 



Printing with Picture Publisher

Before you print a drawing, make certain that the printer (or other device) you want to use has been 
installed. To install a Windows printer driver, install using the Windows diskettes and the Control Panel. 

To print in a Windows application, you also must select one printer as the default printer. Picture Publisher 
sends output to the default printer unless you specify otherwise with the Printer command in the Setup 
submenu of theFile menu.

Related Topics
Connecting printers to ports
Deleting printers
Setting the default printer



Connecting a Printer to a Port

To connect a printer to a port:

1. In the Program Manager, double click the Control Panel icon. The Control Panel opens.
2. Double click the Printers icon. A dialog box opens.
3. Highlight the printer.
4. Click the Configure button. A dialog box opens.
5. Highlight the port that you want connected to the printer.
6. Click the Setup button to specify printer options and click OK.
7. Click OK to return to the main dialog box.
8. Click OK.



Choosing the Default Printer

To specify the default printer:

1. In the Program Manager, double click the Control Panel icon. The Control Panel opens.
2. Double click the Printers icon. A dialog box opens.
3. Highlight the printer you want as your default printer.
4. Press Alt+D. The printer's name appears in the Default Printer area.
5. Click OK.



Deleting a Printer

To delete a printer:

1. In the Program Manager, double click the Control Panel icon. The Control Panel opens.
2. Double click the Printers icon. A dialog box opens.
3. Highlight the printer you want to delete.
4. Click the Configure button.
5. Click the Remove button. A message appears asking if you want to remove the printer.
6. Click Yes. The printer is deleted.
7. Click OK to return to the main dialog box.
8. Click OK.

Related Topics
Print command



Setting Up Your Computer to run Efficiently

What is the optimum system environment for Picture Publisher? 

· Large portions of RAM memory are the most desirable (and also the most costly) 
because this kind of memory is the quickest for the computer to process.

· The largest permanent swap file is the best setup in most systems. Fast hard disk 
controllers allow quick information transfer time and directly improve performance.

· The memory settings in the Preferences dialog box should be: 

Minimum free memory (Default is 1024KB.) This setting reserves a portion of memory for other 
Windows applications. Some systems may be set up with a value lower so PIcture PUblisher can 
use this memory.

Free memory per image (Default is 75%) This setting is a percentage that should be set 
high to avoid a double caching scenario between the PPCACHE and the hard disk.

Picture Publisher's Memory Handling

Whenever you edit an image, additional files are temporarily created. If the sum total of the size 
of these files is larger than the amount of RAM memory there will be a noticeable performance 
loss. You can get optimal performance of your memory resources by understanding Picture 
Publisher's creation and deletion of these temporary files. 

Approximately 340KB is taken up in memory within Windows by the program. Also, remember 
that images cut to the Clipboard deplete memory resources until the Clipboard is cleared.

Picture Publisher's Memory Modes

In the Preferences dialog box, the Undo panel has three memory options. These options can be 
changed so you can customize your memory handling according to the way you want to work.

All of the options (No undo, Manual apply, and Auto apply) operate the same way at first. As an 
edit initially takes place (i.e. airbrush a portion of an image) a temporary file the same size of the 
entire image is created to allocate a memory block. 

Note: Writing to a file without allocating the entire block could be a better option if memory wasn't 
a consideration. Picture Publisher now uses the allocated block first in order to assure the 
completion of the operation.

As editing continues in manual apply mode, the temporary file is written with any new editing 
changes. The advantage is that allocation takes place only one time (up front) until the temporary 
file is deleted. Another advantage is that there is a pseudo multiple undo with this setting. 

Every editing operation in auto apply mode requires the allocation of a    temporary file to be 
created the same size of the entire image. In this mode, there is one level of undo which provides 
insurance by being able to go back before the change was made. Within memory, every time a 
change takes place, a temporary file is created and a previous file cleared out of memory. The 
disadvantage is the allocation time required for each operation which is more apparent when 
working with large images. If any portion of the hard disk is used during these operations, 
performance will decrease. Brush strokes lag behind and disk activity is apparent.



In undo mode, after a change is completed, the previously stored file is cleared out of memory. 

A temporary file is created when there is any change to an image or when a mask is drawn.

All image temporary files allocate a memory block as large as the image being changed. A mask 
also allocates a block of memory. The mask temporary file is equal to the size of the image if it 
was in grayscale. 

Picture Publisher clears a temporary file from memory after a change takes place in Auto Apply 
mode or No Undo mode. Also if you are in Manual Apply mode or Apply mode, and choose 
Manual Apply in the Edit menu, the temporary file is cleared from memory.

The mask file is equal to the size of the image if it were in grayscale. 

An undo is an option to return to a previously unchanged image that resides in memory.

A redo is an option to return to the changed image that resides in memory.



Shortcut Keys

Key Action

F1 Opens on-line help.
Shift F1 Converts pointer to question mark in ballon. Click on item to open help for the item.
F2 Deselects selected objects and selects objects not currently selected.
Shift+F3 Chooses Acquire in the File menu.
F3 Chooses Scan in the File menu.
Shift+F4 Chooses the Selector tool in the toolbox.
F4 Shows and hides the toolbox.
Shift+F5 Opens the Mask tools in the toolbox.
F5 Switches to the tool last used.
Shift+F6 Opens the Retouch tools in the toolbox.
F6 Opens the Custom View tool in the toolbox.
Shift+F7 Opens the Filter tools in the toolbox.
F7 Mirrors the image or masked area horizontally.
Shift+F8 Opens the Fill tools in the toolbox.
F8 Mirrors the image or masked area vertically.
Shift+F9 Opens the Draw tools in the toolbox.
F9 Shows and hides the rulers in the Show/Hide submenu in the Window menu.
Shift+F10 Accesses the Color Probe tool in the toolbox.
F10 Shows and hides the QuickZoom box in the Show/Hide submenu in the Window menu.
Shift+F11 Enables and disables the Ruby Overlay in the status line.
F11 Shows and hides Info in the Show/Hide submenu in the Window menu.
Shift+F12 Enables and disables direct Mask Channel editing.
Alt+Back Chooses Undo in the Edit menu.
Ctrl+Delete Chooses Delete in the Edit menu.
Shift+Delete Chooses Cut in the Edit menu.
Ctrl+Insert Chooses Copy in the Edit menu.
Shift+Insert Chooses Paste in the Edit menu.
Insert Chooses Invert in the Mask menu.
Shift+Up Scrolls up.
Shift+Down Scrolls down.
Shift+Right Scrolls right.
Shift+Left Scrolls left.
Escape Cancels the current action.
Shift+End Shows and hides the Mask Marquee.
Ctrl+End Shows and hides the Object Marquee.
Ctrl+A Chooses Save As in the File menu.
Ctrl+C Chooses Copy in the Edit menu.
Ctrl+D Chooses Copy To in the Edit menu.
Ctrl+E Chooses Effects in the Image menu.
Ctrl+F Chooses Color Balance Joystick in the Map menu.
Ctrl+G Chooses Color Balance Visual in the Map menu.
Ctrl+H Chooses Hue/Saturation in the Map menu.
Ctrl+I Chooses Invert in the Image menu.
Ctrl+J Chooses Contrast/Brightness Joystick in the Map menu.
Ctrl+K Chooses Contrast/Brightness Visual in the Map menu.
Ctrl+L Chooses Posterize/Threshold in the Map menu.
Ctrl+M Chooses Modify Color Maps in the Map menu.
Ctrl+N Chooses New in the File menu.
Ctrl+O Chooses Open in the File menu.
Ctrl+P Chooses Print in the File menu.
Ctrl+Q Chooses Tone Balance in the Map menu.
Ctrl+R Chooses Remove in the Mask menu.



Ctrl+S Chooses Save in the File menu.
Ctrl+U Chooses Paste As New Image in the Edit menu.
Ctrl+V Chooses Paste in the Edit menu.
Ctrl+W Chooses Paste From in the Edit menu.
Ctrl+X Chooses Cut in the Edit menu.
Ctrl+Y Chooses Crop in the Mask menu.
Ctrl+Z Chooses Undo in the Edit menu.



ImageBrowser Dialog Box (File Name View)

The ImageBrowser menu bar displays these menus:

File 
Edit 
Thumbnails 
Album 

Note: The Album menu is available only if you choose the View Albums button.

Path Area
The Path area displays the current path.

File Name Text Box
Type the name of the file you want to open in the File Name text box.

Files List Box
The files of the selected file format are listed for the current directory in the Files list box below the File 
Name text box.

In the Files list box, type the first letter of a filename to move the cursor to the first file beginning with that 
letter.

File Types List Box
The File Types list box contains the file formats that Picture Publisher supports. Click the down arrow to 
the right of the list box to display the file formats, then choose the one you want.

Drives List Box
The Drives list box displays the drives available on your computer. Click a drive to see the directories and 
files on that drive. For example, if you choose A, the directories and filenames on the diskette in drive A 
appear in the appropriate list box. 

Directories List Box
The Directories list box displays directories. To see the filenames in another directory, choose the 
directory name or type the directory name separated with backslashes in the File Name text box. For 
example, type c:\pictpub4\tutorial, and press Enter. The filenames associated with the specified drive 
and directory appear in the list box.

To change directories, point to the directory containing the files you want to open and double click the left 
mouse button. The list box changes to the directory you selected.

Albums List
The Albums list displays the available albums.

View Directories/View Albums Button
This button is a toggle; if View Directories is displayed, when you click the button, the ImageBrowser 
displays a directory list. If View Albums is displayed, when you click the button, the ImageBrowser 
displays an album list and the Album menu appears in the menu bar.

Mode List Box
The Mode list box contains these options for opening files: Normal, FastBits, and Low Resolution.

The Normal mode for opening files is the standard way to open files. When you open a file in Normal 



mode, the entire file is loaded into memory at one time.

The FastBits mode for opening files displays a preview of an image, and lets you open a segment or 
"chunk" of a file for editing. The edited segment is recombined into the original image when you save the 
file. The FastBits mode is useful when you want to edit a large image on a low-memory computer setup.

The Low Resolution mode for opening files lets you select a new resolution for the file when opening.

Size Area
The Size area displays the size of the selected file.

Note: If you choose multiple files in the Files list box, the Size area shows the cumulative size of the files 
and the Date and Time areas are blank.

Date Area
The Date area displays the date the selected file was last saved.

Time Area
The Time area displays the time the selected file was last saved.

Options Button
Click the Options button to open the TIFF Options dialog box, the EPS Options dialog box, the JPEG 
Options dialog box, or the Picture Publisher Format Options dialog box . The dialog box that opens 
depends on the file type selected.

Note: The Options button is available only when you choose the Save As command.

Info Button
The Info button displays information about a selected file, and lets you add a description to a selected 
album.

Related Topics
Thumbnail view 
FastBits mode 
Low Resolution mode 



ImageBrowser Dialog Box (Thumbnail View)

The ImageBrowser menu bar displays these menus:

File 
Edit 
Thumbnails 
Album 

Note: The Album menu is available only if you choose the View Albums button.

Path Area
The Path area displays the current path.

File Types List Box
The File Types list box contains the file formats that Picture Publisher supports. Click the down arrow to 
the right of the list box to display the file formats, then choose the one you want.

Drives List Box
The Drives list box displays the drives available on your computer. Click a drive to see the directories and 
files on that drive. For example, if you choose A, the directories and filenames on the diskette in drive A 
appear in the appropriate list box. 

Thumbnail Area
The Thumbnail area displays the thumbnails of the files in the current directory.

Directories List Box
The Directories list box displays directories. To see the filenames in another directory, choose the 
directory name or type the directory name separated with backslashes in the File Name text box. For 
example, type c:\pictpub4\tutorial, and press Enter. The filenames associated with the specified drive 
and directory appear in the list box.

To change directories, point to the directory containing the files you want to open and double click the left 
mouse button. The list box changes to the directory you selected.

Albums List
The Albums list displays the available albums.

View Directories/View Albums Button
This button is a toggle; if View Directories is displayed, when you click the button, the ImageBrowser 
displays a directory list. If View Albums is displayed, when you click the button, the ImageBrowser 
displays an album list and the Album menu appears in the menu bar.

Mode List Box
The Mode list box contains these options for opening files: Normal, FastBits, and Low Resolution.

The Normal mode for opening files is the standard way to open files. When you open a file in Normal 
mode, the entire file is loaded into memory at one time.

The FastBits mode for opening files displays a preview of an image, and lets you open a segment or 
"chunk" of a file for editing. The edited segment is recombined into the original image when you save the 
file. The FastBits mode is useful when you want to edit a large image on a low-memory computer setup.

The Low Resolution mode for opening files lets you select a new resolution for the file when opening.

Size Area



The Size area displays the size of the selected file.

Note: If you choose multiple files in the Files list box, the Size area shows the cumulative size of the files 
and the Date and Time areas are blank.

Date Area
The Date area displays the date the selected file was last saved.

Time Area
The Time area displays the time the selected file was last saved.

Options Button
Click the Options button to open the TIFF Options dialog box, the EPS Options dialog box, the JPEG 
Options dialog box, or the Picture Publisher Format Options dialog box . The dialog box that opens 
depends on the file type selected.

Note: The Options button is available only when you choose the Save As command.

Related Topics
File Name view 
FastBits mode 
Low Resolution mode 



FastBits Mode

The FastBits mode displays a preview representation of an image and allows you to open up a segment 
for editing. You can choose the segment to open by dragging your mouse pointer to draw a grid. You then 
select one segment of the grid to open.

Picture Publisher recombines the segment with the rest of the image when you save the segment. This 
allows you to edit a large image in small pieces on a computer with limited memory.

If you are making general changes to an image, such as color balance or contrast and brightness, you 
can record a macro on one segment and replay it on the others. This assures uniform changes 
throughout.



Low Resolution Mode

The Low Resolution mode allows you to open an image a at lower resolution that it was saved. This 
option opens a dialog box for choosing the lower resolution. The dialog box displays the file size for each 
resolution you choose.

Picture Publisher opens the file untitled so you do not accidentally overwrite the original image file. You 
can open a low resolution file to test general changes such as hue and saturation. Because the file is low 
resolution, processing is faster. After deciding on how to change the image, record a macro with the 
changes, open the larger original file and run the macro while you do something else.

Low resolution files can also speed up proof printing on a low resolution printer. Your printer throws away 
all data above its resolution. This requires processing time. Sending an image with the proper resolution 
speeds up printing.



Low Resolution Dialog Box

The Low Resolution dialog displays information about the file you are opening in low resolution mode, 
including: filename, file type, data type, width, height, resolution, and image size.

You can change the resolution of the file in the Open Resolution area. As you change the resolution of the 
file, the image size changes.



TIFF Options Dialog Box

LZW Compressed Tiff Option
Choose this option to use LZW compression when saving a TIFF file.

Use LZW Differencing Option

Always Prompt For Options on Save Option
Choose this option to always have the options dialog box open when saving to this format.



EPS Options Dialog Box

Preview TIFF Area
This area contains three options: None (Macintosh), 1-Bit Scattered, and 8-Bit Grayscale. The None 
option creates an EPS file without a TIFF preview. The 1-Bit Scattered option creates an EPS file with line 
art preview. The 8-Bit Grayscale option creates an EPS file with 256 levels of gray.

Export Clipping Path From Mask Option
Choose this option to create clipping paths for use in applications that accept placeable EPS or DCS files. 
A clipping path allows a bitmap to be clipped so that it is not just a square image. Clipping allows only the 
desired portions to be displayed or printed.

Minimum Line Length Area
This area determines the minimum length of a line segment along a path. A high Minimum Line Length 
causes the path to become blocky, but it does provide a simpler path for the printer to print. 

Tolerance Area
This area determines the amount, in pixels, that the line segment can deviate from the original path. The 
higher the Tolerance, the less accurate the path becomes.

Note: If you cannot print an EPS file, it may be because your printer does not have enough memory, or 
the path is too complex. In the case of a complex path, increase the values for Minimum Line Length and 
Tolerance to create a less complex path. 

Always Prompt For Options on Save Option
Choose this option to always have the options dialog box open when saving to this format.

Related Topics
Creating a clipping path 



Creating a Clipping Path

To create a clipping path:

1. Select only the areas of the image you want to print by masking the desired areas. 
2. Open the File menu and choose Save. The ImageBrowser dialog box opens.
3. Choose the file type you want (DCS or EPS). 
4. Click Options. An options dialog box opens.
5. Select the Export Clipping Path From Mask option.
6. Set the Minimum Line Length and Tolerance.
7. Click OK.
8. Click Save to save the clipping path.



Picture Publisher Format Options Dialog Box

Compress Option
Choose this option to compress when saving in the Picture Publisher format.

Save Mask Channel Option
Choose this option to save the mask channel.

Always Prompt For Options on Save Option
Choose this option to always have the options dialog box open when saving to this format.



File Menu (ImageBrowser)

The File menu contains these commands:

Copy 
Move 
Rename 
Delete 
Search 
Add to Album 
Remove From Album 
Find Original 
Directory 



Copy Command (ImageBrowser)

The Copy command lets you copy selected files to a specified drive and directory.

Related Topics
Dialog Box information 
Procedure information 



Copy Files Dialog Box

Directory Area
The Directory area displays the current directory.

From Text Box
The From text box displays name of the file you are copying.

To Text Box
The To text box lets you define where you want to copy the file and the name of the file.

Copying Area
This area displays the directory and name of the file you are copying.

To Area
This area displays the target destination for the copied file.

Related Topics
Command information 
Procedure information 



Copying Files

To copy files:

1. Open the ImageBrowser File menu and choose Copy. The Copy Files dialog box opens.
2. Type a directory and name for the copied file.
3. Choose Copy. The Confirm Copy File dialog box opens.
4. Choose Yes to copy the file; choose Yes to All if you are copying more than one file; or choose No 

not to copy the file.

Related Topics
Command information 
Dialog Box information 



Move Command (ImageBrowser)

The Move command lets you move selected files to a specified drive and directory.

Related Topics
Dialog Box information 
Procedure information 



Move Files Dialog Box

Directory Area
The Directory area displays the current directory.

From Text Box
The From text box displays name of the file you are moving.

To Text Box
The To text box lets you define where you want to move the file and the name of the file.

Moving Area
This area displays the directory and name of the file you are moving.

To Area
This area displays the target destination for the file you are moving.

Related Topics
Command information 
Procedure information 



Moving Files

To move files:

1. Open the ImageBrowser File menu and choose Move. The Move Files dialog box opens.
2. Type a directory and name for the file.
3. Choose Move. The Confirm Move File dialog box opens.
4. Choose Yes to move the file; choose Yes to All if you are moving more than one file; or choose No 

not to move the file.

Related Topics
Command information 
Dialog Box information 



Rename Command (ImageBrowser)

The Rename command lets you rename a selected file.

Related Topics
Dialog Box information 
Procedure information 



Rename File Dialog Box

Directory Area
The Directory area displays the current directory.

From Text Box
The From text box displays the name of the file you are renaming.

To Text Box
The To text box lets you rename the file, and place a copy of the file on another drive or directory.

Related Topics
Command information 
Procedure information 



Renaming a File

To rename a file:

1. Open the ImageBrowser File menu and choose Rename. The Rename File dialog box opens.
2. Type a directory and name for the file.
3. Choose Rename. The message "OK to rename (filename) to (filename)" appears.
4. Choose OK to rename the file.

Related Topics
Command information 
Dialog Box information 



Delete Command (ImageBrowser)

The Delete command (Ctrl+Del) lets you delete a selected file or files.

Related Topics
Dialog Box information 
Procedure information 



Delete File Dialog Box

Directory Area
The Directory area displays the current directory.

Delete Area
The Delete area displays the name(s) of the file(s) you are deleting.

Related Topics
Command information 
Procedure information 



Deleting a File

To delete a file:

1. Open the ImageBrowser File menu and choose Delete. The Delete File dialog box opens.
2. Choose Delete. The Confirm Delete File dialog box opens.
3. Choose Yes to delete the file; choose Yes to All if you are deleting more than one file; or choose 

No not to delete the file.

Related Topics
Command information 
Dialog Box information 



Search Command

The Search command searches for files in directories and albums. You can search by keyword or file 
filename. 

Related Topics
Dialog Box information 
Procedure information 



Search Dialog Box

Name Text Box
Enter the file name or file specification of the file or files you want to find. You can use wildcards in the file 
specification. Use an asterisk (*) for any number of characters up to eight and ? for one character. For 
example type *.tif to find all files with the tif extension, or type b?l*.tif to display such files as ballons.tif, 
bull.tif, and bulbs.tif.

If you are searching by keyword, enter the keywords in the Name text box.

Search Selected Album Option
Choose this option to search only the selected album.

Search All Albums Option
Choose this option to search all albums that exist.

Search From Directory Option
Choose this option to search the specified directory.

Search by Keyword Option
Choose this option to search for files that contain keywords.

Note: You enter keywords for files by selecting one or more files in the Files list box and clicking the 
Information button.

Search by File Name Option
Choose this option to search for specific filenames.

Case Sensitive Option
Lets you choose whether the keyword search is case sensitive (e.g. upper and/or lowercase).

Directory Text Box
Enter the starting directory for a directory search.

Matches Found Area
Displays the number of matches found.

Directories Searched Area
Displays the directory being searched. The directory name changes throughout the search.

Searching Area
Displays the name of the file being searched.

Search/Stop Button
Click this button to start and stop the search.

View to display found files. The files are in an album named FILE SEARCH. You can rename this album 
by choosing the Rename command from the Album menu.

Related Topics
Command information
Procedure information 



Searching for Files

To search for files:

1. Open the File menu and choose Open. The ImageBrowser dialog box opens.
2. Open the ImageBrowser File menu and choose Search. The Search dialog box opens.
3. Enter the filename for which you want to search in the Name text box.
4. Choose to search an album or directory.
5. Choose to search by keyword or filename.
6. Click Search to begin the search.

Related Topics
Command information
Dialog Box information 



Add To Album Command

The Add To Album command lets you add a file to an album, and manage albums.

Related Topics
Dialog Box information 
Procedure information 



Add To Album Dialog Box

Select Album Text Box
Click the down arrow to choose an album to create, or type a new name for the album.

File Options Button
Click the File Options button to open a menu containing these commands for managing albums: New, 
Rename, and Delete .

Related Topics
Command information 
Procedure information 



Adding a File to an Album

To create a new album:

1. Open the ImageBrowser.
2. Select a file.
3. Open the File menu and choose Add To Album. The Add To Album dialog box opens.
4. Choose the album for which you want to add the file.
5. Click Add to add the selected file to the album.

Related Topics
Command information 
Dialog Box information 



Remove From Album Command

The Remove From Album command removes a selected file from an album. This command is available 
only when viewing albums.

Note: When you remove file from an album, the file is not removed (deleted) from the hard disk. Only the 
reference to the album is removed.

Related Topics
Dialog Box information 
Procedure information 



Remove From Album Dialog Box

Album Area
This area displays the album name for the selected file.

Remove File Area
This area displays the name of the file you want to remove from the album.

Remove Button
Click the Remove button to remove the file from the album.

Related Topics
Command information
Procedure information 



Removing a File from an Album

To remove a file from an album:

1. Open the ImageBrowser. (Make sure you are viewing albums.)
2. Select the file you want to remove in the Files list.
3. Open the File menu and choose Remove From Album. The Remove From Album dialog box 

opens.
4. Click Remove to remove the file from the album.

Related Topics
Command information
Dialog Box information 



Find Original Command

The Find Original command locates the drive and directory of a single file name selected in an album. 
This command is available only when viewing albums.

Choosing this command locates the file and changes the ImageBrowser to directory view.



Directory Command (ImageBrowser)

The Directory command opens a submenu containing these commands:

Create 
Rename 
Delete 
Import Database 
Export Database 



Create Command (Directory Submenu)

The Create command lets you create a new directory.

Related Topics
Dialog Box information 
Procedure information 



Create Directory Dialog Box

Enter Directory Name Text Box
Type a name for the directory in this text box.

Related Topics
Command information 
Procedure information 



Creating a Directory

To create a directory:

1. Open the ImageBrowser File menu and choose Directory. The Directory submenu opens.
2. Choose Create. The Create Directory dialog box opens.
3. Type a name for the new directory.
4. Click Create. The directory is created.

Related Topics
Command information 
Dialog Box information 



Rename Command (Directory Submenu)

The Rename command lets you rename a selected directory.

Related Topics
Dialog Box information 
Procedure information 



Rename Directory Dialog Box

Rename Directory Area
The Rename Directory area displays the selected directory for renaming.

To Directory Text Box
Type a name for the new directory in this text box.

Related Topics
Command information 
Procedure information 



Renaming a Directory

To rename a selected directory:

1. Open the ImageBrowser File menu and choose Directory. The Directory submenu opens.
2. Choose Rename. The Rename Directory dialog box opens.
3. Type a name for the selected directory.
4. Click Rename. The directory is renamed.

Related Topics
Command information 
Dialog Box information 



Delete Command (Directory Submenu)

The Delete command deletes a selected directory.

Related Topics
Procedure information 



Deleting a Directory

To delete a selected directory:

1. Open the ImageBrowser File menu and choose Directory. The Directory submenu opens.
2. Choose Delete. The message "Are you sure you want to delete directory (directory name)?" 

appears.
3. Click OK to delete the directory.

Related Topics
Command information 



Import Database Command

The Import Database command lets you import thumbnails from removable media or a network drive.



Import Directory Database File Dialog Box

Directory Area
Displays the current directory for importing.

Import Subdirectories Option
Choose this option to import all subdirectories of the selected directory.



Export Database Command

The Export Database command lets you copy thumbnails and the database files to removable media or a 
network drive for someone else to use by importing the database for immediate access to the thumbnails.



Export Directory Database File Dialog Box

Directory Area
Displays the current directory for exporting..

Import Subdirectories Option
Choose this option to export all subdirectories of the selected directory.

Copy Thumbs Option
Choose this option to export thumbnails.



Edit Menu (ImageBrowser)

The Edit menu contains these commands:

Select All 
Deselect All 
Invert Selection 
Preferences 



Select All Command

The Select All command selects all files in the current directory.

Related Topics
Procedure information 



Selecting All Files

To select all files:

· Open the ImageBrowser Edit menu and choose Select All. All files in the current directory are 
selected.

Related Topics
Command information 



Deselect All Command

The Deselect All command deselects all selected files in the current directory.

Related Topics
Procedure information 



Deselecting All Files

To deselect all files:

· Open the ImageBrowser Edit menu and choose Deselect All. All selected files in the current 
directory are selected.

Related Topics
Command information 



Invert Selection Command

The Invert Selection command reverses the selection of the files in the Files list box in the ImageBrowser. 
For example, if all the files in the Files list box are selected, and you choose the Invert Selection 
command in the ImageBrowser Edit menu, Picture Publisher deselects all of the files.

Related Topics
Procedure information



Inverting the Selection of the Files

To invert the selection of files:

· Open the ImageBrowser Edit menu and choose Invert Selection. All files that are not selected are 
selected, and all files that are already selected are deselected.

Related Topics
Command information



Preferences Command (ImageBrowser)

The Preferences command lets you select preferences for the ImageBrowser.

Related Topics
Dialog Box information 
Procedure information 



ImageBrowser Preferences Dialog Box

Thumbnails Path Option
This option lets you specify where thumbnail files are stored when you create or save files.

Thumbnail Info Path Option
This option lets you specify where the thumbnail database files are stored.

Save Path Option
This option saves the path of the opened file.

Create Thumbnails on Save Option
This option creates thumbnails every time a new file is saved.

AutoCreate Thumbnails Option
This option automatically creates thumbnails for files that do not have thumbnails. The thumbnails are 
created when you change to a directory.

Confirm On Copy Option
This option toggles on and off the confirmation message you receive when you copy files.

Confirm On Move Option
This option toggles on and off the confirmation message you receive when you move files.

Confirm On Rename Option
This option toggles on and off the confirmation message you receive when you rename files.

Confirm On Delete Option
This option toggles on and off the confirmation message you receive when you delete files.

Save Button
Click the Save button to apply the preference changes to the current session and all future sessions.

OK Button
Click the OK button to apply the preference changes only to the current session.

Related Topics
Command information 
Procedure information 



Setting the ImageBrowser Preferences

To set ImageBrowser preferences:

1. Open the ImageBrowser Edit menu and choose Preferences. The ImageBrowser Preferences 
dialog box opens.

2. Choose the options you want.
3. Click Save to save the options for this and future sessions.

Related Topics
Command information 
Dialog Box information 



Thumbnails Menu (ImageBrowser)

The Thumbnails menu contains these commands:

Create 
Cleanup Thumbs 
Move Thumbs 
Delete Thumbs 
Print Thumbnails 
View Thumbnails/View File Names 



Create Command

The Create command creates thumbnails for an image file. Thumbnails are used to store all information 
about a file, including the file description.

Related Topics
Procedure information 



Creating Thumbnails

To create thumbnails:

1. Open the ImageBrowser.
2. Choose a file type (in either the file view or thumbnail view).
3. Open the ImageBrowser Thumbnails menu and choose Create. 

Related Topics
Command information 



Cleanup Thumbs Command

The Cleanup Thumbs command lets you clean up thumbnails that may not reside in the same directory 
as its file. This can occur when you delete, rename, copy, or move a file outside of the ImageBrowser.

Related Topics
Dialog Box information 
Procedure information 



Cleanup Thumbs Dialog Box

All Thumbnails Option
Choose this option to clean up all thumbnails on your hard disk.

Directory Option
Choose this option to clean up thumbnails in the selected directory.

Clean Subdirectories Option
Choose this option to clean up thumbnails in all subdirectories of the selected directory.

Related Topics
Command information 
Procedure information 



Cleaning Up Thumbnails

To clean up thumbnails:

1. Open the ImageBrowser Thumbnails menu and choose Cleanup Thumbs. The Cleanup Thumbs 
dialog box opens.

2. Choose the clean up options you want.
3. Click Clean.

Related Topics
Command information 
Dialog Box information 



Move Thumbs Command

The Move Thumbs command lets you move selected thumbnails. For example, if you store image files on 
a network drive, you might want to store the thumbnails for the image files on the network also. When you 
move a thumbnail file using the ImageBrowser, all links to the file remains intact.

Related Topics
Dialog Box information 
Procedure information 



Move Selected Thumbs Dialog Box

Move To Local Option
Choose this option to move the selected thumbnails to the default Thumbnails directory.

Move To Remove Option
Choose this option to move the selected thumbnails to the remote directory containing the original files.

Move To Other Option
Choose this option to move the thumbnails to a specified directory. Enter the path for the new location in 
the text box below this option.

Delete Original Thumbs Option
Choose this option to delete the original thumbnails when the thumbnails are moved.

Related Topics
Command information 
Procedure information 



Moving Thumbnails

To move thumbnails:

1. Open the ImageBrowser Thumbnails menu and choose Move Thumbs. The Move Selected 
Thumbs dialog box opens.

2. Choose the move option you want.
3. Choose the Delete Original Thumbs option, if you want.
4. Click Move.

Related Topics
Command information 
Dialog Box information 



Delete Thumbs Command

The Delete Thumbs command lets you delete thumbnail files.

Related Topics
Procedure information 



Deleting Thumbnails

To delete thumbnails:

1. Choose the thumbnails you want to delete.
2. Open the ImageBrowser Thumbnails menu and choose Delete Thumbs. The message    "Ok to 

delete thumbnails for selected images?" appears.
3.  Choose OK to delete the selected thumbnails.

Related Topics
Command information 



Print Thumbnails Command

The Print Thumbnails command lets you print a hard copy of the currently active thumbnails.

Related Topics
Dialog Box information 
Procedure information 



Print Thumbnails Dialog Box

Columns Option
Choose this option to print the thumbnails in columns. Enter the number of columns in the edit box.

Rows Option
Choose this option to print the thumbnails in rows. Enter the number of rows in the edit box.

Selected Files Only Option
Choose this option to print only the selected thumbnails.

Related Topics
Command information 
Procedure information 



Printing Thumbnails

To print thumbnails:

1. Choose the thumbnails you want to print.
2. Open the ImageBrowser Thumbnails menu and choose Print Thumbnails. The Print Thumbnails 

dialog box opens.
3. Choose the Columns or Rows option.
4. Choose the Selected Files Only option, if you want.
5. Click Print.

Related Topics
Command information 
Dialog Box information 



View Thumbnails/View File Names Command

The View Thumbnails and View File Names command is a toggle. Choose View Thumbnails to view 
thumbnails in the ImageBrowser, or choose View File Names to view a list of file names in the 
ImageBrowser.



Album Menu

The Album menu contains these commands:

New 
Rename 
Delete 
Import Album 
Export Album 



New Command (Album Menu)

The New command lets you create a new album while in Album mode.

Related Topics
Dialog Box information 
Procedure information 



New Album Dialog Box

Enter Album Name Text Box
Enter a name for the new album, then click new.

New Button
Click the New button to create a new album with the specified name.

Related Topics
Command information
Procedure information 



Creating an Album

To create a new album:

1. Open the ImageBrowser.
2. Open the Album menu and choose New. The New Album dialog box opens.
3. Enter a name for the new album.
4. Click New. A new album is created.

Related Topics
Command information
Dialog Box information 



Rename Command (Album Menu)

The Rename command lets you rename selected albums.

Related Topics
Dialog Box information 
Procedure information 



Rename Album Dialog Box

To Text Box
Enter a name for the selected album in this text box, then click Rename.

Rename Button
Click the Rename button to rename the selected album.

Related Topics
Command information
Procedure information 



Renaming an Album

To rename an album:

1. Open the ImageBrowser.
2. Select the album you want to rename.
3. Open the Album menu and choose Rename. The Rename Album dialog box opens.
4. Enter name for the album.
5. Click Rename. The selected album is renamed.

Related Topics
Command information
Dialog Box information 



Delete Command (Album Menu)

The Delete command lets you delete the selected album.

Related Topics
Procedure information 



Deleting an Album

To delete an album:

1. Open the ImageBrowser.
2. Select the album you want to delete.
3.  Open the Album menu and choose Delete. The selected album is deleted.

Related Topics
Command information



Import Album Command

The Import Album command imports, from removable media or a network drive, the album selected in the 
Album list box of the ImageBrowser.

Related Topics
Dialog Box information 
Procedure information 



Import Album Dialog Box

Import From Directory Text Box
Enter the drive and directory where the album is located.

Copy Files Local Option
This option lets you choose whether or not to import the files to your local drive. You can save storage 
space by leaving them on a network or removable media.

Copy Thumbs Local Option
This option lets you choose whether or not to import the thumbnails to your local drive. If you have access 
to these through a network of removable media you can save storage space by leaving them there.

Copy Files to Directory Text Box
This text box specifies the destination drive and directory of the images if they are copied.

Related Topics
Command information
Procedure information 



Importing an Album

To import an album:

1. Open the ImageBrowser.
2. Select the album you want to import.
3. Open the Album menu and choose Import Album. The Import Album dialog box opens.
4. Enter the drive and directory where the album is located.
5. Choose to copy files and thumbnails to a local drive, if you want.
6. Enter the drive and directory where you want to copy the album.
7. Click Import to import the selected album.

Related Topics
Command information
Dialog Box information 



Export Album Command

The Export Album command exports to removable media or a network drive the album selected in the 
Album list box of the ImageBrowser.

After you export an album, the album, thumbnails, and files are copied to the remote drive specified. 
Once you have exported an album, anyone with access to the album's location can import the album. 



Export Album Dialog Box

Export Album Area
This area displays the filename of the album you are exporting.

To Directory Text Box
Enter the drive and directory to where you want to export the album.

Copy Files Local Option
This option lets you choose whether or not to import the files to your local drive. You can save storage 
space by leaving them on a network or removable media.

Copy Thumbs Local Option
This option lets you choose whether or not to import the thumbnails to your local drive. If you have access 
to these through a network of removable media you can save storage space by leaving them there.



Exporting an Album

To export an album:

1. Open the ImageBrowser.
2. Select the album you want to export.
3. Open the Album menu and choose Export Album. The Export Album dialog box opens.
4. Enter the drive and directory where you want to copy the album.
5. Choose to copy files and thumbnails to a local drive, if you want.
6. Click Export to export the selected album.



Adding a Description to an Album

To add a description to an album:

1. Open the ImageBrowser. (Make sure you are in Album mode.)
2. Select the album to which you want to add a description.
3. Click the Info button. The Album Info dialog box opens.
4. Enter a description for the album in the Description text box.
5. Use the Previous and Next buttons to add descriptions to other files in the album, if you want.
6. Click OK when you are finished entering descriptions.

Related Topics
Album Info dialog box 



Album Info Dialog Box

Name Area
This area displays the name of the selected album.

Files Area
This area displays the total number of files in the selected album.

Description Text Box
Enter a description for the current file in the selected album.

Previous Button
Click this button to move to the previous file in the album..

Next Button
Click this button to move to the next file in the album.

Related Topics
Procedure information 



Help Menu Commands

The Help menu lets you receive help about Picture Publisher.

Current Topic (F1) Displays help specific to the selected symbol, open dialog box, or highlighted 
command, tool, or button.

Index Displays a list of help topics.

Using Picture Publisher Displays information about ways you can use Picture Publisher.

Read Me Displays information that became available after the user's guide was printed.

Using Help Displays on-line instructions for using the Picture Publisher help system.

About Picture Publisher Displays a dialog box that includes the version number, version date, and serial 
number of your copy of Picture Publisher.



Object Menu Commands

The Object menu contains commands for selecting and deselecting objects; ordering objects; feathering 
objects; merging masks with objects; deleting objects; showing and hiding the object list; and anchoring 
objects to the base image.

Select All Selects all objects.
Hide Marquee Hides the object marquee.
Order Lets you move the object up or down one level on the layers, or more the object 

to the front or back of all other objects.
Feather Lets you feather (anti-alias) the edges of the object.
Merge Mask Combines the active mask to the object's mask channel.
Delete Deletes the currently selected object.
Show/Hide Object List Shows or hides the object list, containing up to six image thumbnails.
Combine Anchors the objects to the base image.



Select All Command

The Select All command selects all objects on all layers. When all objects are selected, you can work on 
them as a group. 

Note: Activating the Group button in the Selector Tool ribbon ties the selected objects together so when 
you select one, you select all.

You can also select multiple objects by holding down Shift while clicking the objects one at a time.

Related Topics
Procedure information 



Selecting All Objects

To select all objects:

· Open the Object menu and choose Select All. All objects are selected.

Related Topics
Command information 



Hide Marquee Command

The Hide Marquee command keeps all selected objects selected but hides their moving borders. The 
border, called the marquee, consists of a cyan and black animated line denoting the edges of the object. 
If the marquee is blocking a detailed area of the image, you may want to hide it so you can better view 
any changes you make to the object.

Related Topics
Procedure information 



Hiding an Object's Marquee

To hide an object's marquee:

· Open the Object menu and choose Hide Marquee.

Related Topics
Command information



Order Command

The Order command changes the layer of one or more selected objects. When you choose the Order 
command, the Order submenu opens and contains these commands:

Move Down 
Move Up 
Move To Back 
Move To Front 



Move Down Command

The Move Down command moves a selected object down one level (layer).

Related Topics
Procedure information 



Move Up Command

The Move Up command moves a selected object up one level (layer).

Related Topics
Procedure information 



Move To Back Command

The Move To Back command moves a selected object to the back of all other objects. It does not, 
however, move it behind the base or original image.

Related Topics
Procedure information 



Move To Front Command

The Move To Front command moves a selected object to the front of all other objects.

Related Topics
Procedure information 



Changing the Order of Objects

To change the order of objects:

1. Select the object you want to affect.
2. Open the Object menu and choose Order. The Order submenu opens.
3. Choose the command you want.

Related Topics
Move Down command 
Move Up command 
Move To Back command 
Move To Front command 



Feather Command

The Feather command smooths the edge transition between the object and the surrounding image. 
Feathering helps prevent a hard edge from occurring between an object and the image.

Related Topics
Dialog Box information 
Procedure information 



Feather Object Dialog Box

Amount Area
Enter the number of pixels for the feathering to extend from the border.

Edge List Box
Click the down arrow to display the options for selecting how quickly the feathering drops off: hard, 
normal, or soft.

Related Topics
Command information
Procedure information 



Feathering an Object

To feather an object:

1. Select the object you want to affect.
2. Open the Object menu and choose Feather. The Feather Object dialog box opens.
3. Type the number of pixels to feather.
4. Choose an edge type.
5. Click Feather to feather the mask.

Related Topics
Command information
Dialog Box information 



Merge Mask Command

The Merge Mask command uses a mask to define one or more edges of an object.

Note: To use the command, you must choose both of the Object options (Allow Floating Objects and 
Allow Masks on Floating Objects check boxes) available in the Preferences dialog box.

Using this command removes the portion of any selected object not inside the border of a mask. Each 
merged object maintains its status as a separate object. After merging it with a mask, you can still select, 
move, and manipulate an object. This command can be used to merge a gradient from the mask into an 
object.

Related Topics
Procedure information 



Merging Masks

To merge objects with a mask:

1. Create a mask using one of the mask tools in the tool box.
2. Click the Selector tool from the tool box.
3. Click the object you want to merge with the mask. If you want to merge more than one object, 

click one object, press and hold Shift, and click additional objects.
4. Open the Object menu and choose Merge Mask.

Note: Using this command removes the portion of any selected object not inside the border of a mask.

Related Topics
Command information 



Delete Command (Object Menu)

The Delete command removes the selected objects from the active image. Picture Publisher displays a 
confirmation message before you delete the objects.

Related Topics
Procedure information 



Deleting Objects

To delete objects:

1. Click the Selector tool in the tool box.
2. Click the object you want to delete. If you want to delete more than one object, click one object, 

press and hold Shift, and click additional objects.
3. Open the Object menu and choose Delete. A confirmation message displays.
4. Choose Yes to delete the selection.

Related Topics
Command information 



Show/Hide Object List Command

The Show/Hide Object List command displays or hides a visual list of objects floating on the active image.

The list appears as a moveable window on the your screen. It consists of small image buttons for 
selecting or deselecting each object. Up and down arrows on top of the list provide for scrolling through a 
long roster of objects.

The button for an object appears pressed down when the image is selected. You can select multiple 
objects by activating more than one button while holding Shift. This is very helpful if you have multiple 
small objects you want to select. It is also useful when searching for objects lost on an image.

When you select this command, its name changes between Show Object List and Hide Object List, 
depending on whether the list is visible or not.



Combine Command

The Combine command permanently incorporates all floating objects into the underlying image. This 
command combines all objects with the image, whether or not the objects are selected. All combined 
objects lose their status as separate objects. You can no longer select, move, and manipulate a combined 
object. You can, however, undo a Combine, if you use the Undo command in the Edit menu immediately 
afterwards.



Using the Text Tool

Creating Chalk or Crayon Text
Creating Neon Text
Creating Embossed Text
Creating Drop Shadow Text
Creating Glow Text
Creating a Text Mask



Creating Chalk or Crayon Text

When you have created a text mask, there is another command that can be used to create realistic 
effects. The Stroke Mask command in the Mask menu allows you to apply any created paint style to the 
border of a mask. Using this command, you can create the illusion of writing on a chalkboard or writing in 
crayon on a piece of paper.

To create chalk or crayon text:

1. Open the image that will be used with the text mask.
2. Click the Mask Channel button in the status bar to turn on Mask Channel.
3. Make sure your active color is set to white.
4. Type in the desired text. Move the text around until you find the desired placement.

Note: For greater accuracy, you can turn on the Ruby Overlay mode by clicking its button in the status 
area. Ruby Overlay mode, combined with Mask Channel mode, allows you to see the image, but only 
affect the Mask Channel.

5. Select Combine from the Object Menu to place the text on the Mask Channel. (If you are not 
working in with objects turned on, then you can ignore step 5.)

6. Click the Mask Channel button to turn if off the Mask Channel.
You now have a black and white marquee in the shape of the text on your screen. If you left the 
ruby overlay on, then the text will appear as cut outs in the overlay. The text can be moved using 
the Move Mask and Copy Mask options in the Mask Transform ribbon. You can also save the 
mask using the Save command in the Mask menu.

7. Open the Mask menu and choose Stroke. The Stroke dialog box opens.
8. Set the Stroke Style to Chalk, Feather to 100%, and the Brush Size to 15 pixels.
9. Click Stroke. 

Your image now has chalk drawn text on it. This effect is more dramatic if the text is created on a black 
background. You can take this same technique to create crayon text or any other paint style available. 
Experiment to see what interesting styles you can create.

Related Topics
Using the Text Tool



Creating Neon Text

To create neon text:

1. Open the image that will be used with the text mask.
2. Click the Mask Channel button in the status bar to turn on the Mask Channel.
3. Make sure your active color is set to white. 
4. Type in the desired text. Move the text around until you find the desired placement.

Note: For greater accuracy, you can turn on the Ruby Overlay mode by clicking its button in the status 
area. Ruby Overlay mode, combined with Mask Channel mode, allows you to see the image, but only 
affect the Mask Channel.

5. Open the Object menu and choose Combine. The text is anchored to the base image. (If you are 
not working in with objects turned on, then you can ignore step 5.)

5. Open the Image menu and choose Effects. The EffectsBrowser dialog box opens.
6. From the list of Distortion effects choose Gaussian Blur.
7. Set the Amount to 20 and apply the effect to the text. 
8. Click OK to close the EffectsBrowser.
9. Click the Mask Channel button in the status bar to turn off the Mask Channel.

You will now have a black and white marquee in the shape of the text on your screen. If you left 
the ruby overlay on, then the text will appear as cut outs in the overlay. The text can be moved 
using the Move Mask and Copy Mask functions of the Mask Transform Tool.

10. Click the Fill tool, then click the Color Tint Fill tool.
11. Select the desired color from the color palette or color picker, and click on your image to fill.
12. Click the Mask Channel button in the status bar to turn on the Mask Channel.
13. Open the Image menu and choose Effects. The EffectsBrowser dialog box opens.
14. From the list of Color Adjust, select Threshold.
15. Adjust the threshold, until only a thin outline of text appears. Average values used are between 10 

and 20%. You can view the change in threshold by using the preview button.
16. From the list of Distortion effects choose Gaussian Blur.
17. Set the Amount to 5 and apply the effect to the text. 
18. Click OK to close the EffectsBrowser.
18. Click the Mask Channel button in the status bar to turn off the Mask Channel.
19. Set your active color to White.
20. Click the Fill tool, then click the Color Tint Fill tool.
21. Set the transparency to 50% in the Color Tint Fill ribbon.
22. Click the image to create the neon highlights.

Note: This technique works best on a black background, and using sans serif fonts such as Arial or 
Helvetica.

Related Topics
Using the Text Tool



Creating Embossed Text

To create embossed text:

1. Open the image that will be used with the text mask.
2. Click the Mask Channel button in the status bar to turn on the Mask Channel.
3. Make sure your active color is set to white. 
4. Type in the desired text. Move the text around until you find the desired placement.

Note: For greater accuracy, you can turn on the Ruby Overlay mode by clicking its button in the status 
area. Ruby Overlay mode, combined with Mask Channel mode, allows you to see the image, but only 
affect the Mask Channel.

5. Open the Object menu and choose Combine. The text is anchored to the base image. (If you are 
not working in with objects turned on, then you can ignore step 5.)

6. Click the Mask Channel button in the status bar to turn off the Mask Channel.
7. Open the Mask menu and choose Save. Type in a name for the mask and click Save.
8. Open the Mask menu and choose Feather. The Feather Mask dialog box opens.
9. Feather the mask 3 pixels, inside, with normal hardness.
10. Click the Mask Channel button in the status bar to turn on the Mask Channel.
11. Open the Image menu and choose Effects. The EffectsBrowser dialog box opens.
12. From the list of Texture Effects, choose Emboss.
13. Depending on the type of embossing you desire, raised or relief, select a different light source 

angle. 
14. Click Apply to apply the effect.
15. Open the Mask menu and choose Load to load the previously saved mask.
16. Open the Map menu and choose Contrast/Brightness. A submenu opens.
17. Choose Joystick. The Contrast/Brightness dialog box opens.
18. Change the brightness to 10% and click OK.
19. Click the Mask Channel button in the status bar to turn off the Mask Channel.
20. Click the Fill tool, then click the Color Tint Fill tool.
21. Fill the image with the color you want.

You can further enhance the text while the mask is still around the text by using contrast/brightnes to 
lighten and darken the text.

Related Topics
Using the Text Tool



Creating Drop Shadow Text

Drop shadow text gives a look of depth and realistism.

To create drop shadow text:

1. Open the image on which the drop shadow is to be created.
2. Click the Mask Channel button in the status bar to turn on the Mask Channel.
3. Make sure your active color is set to white. 
4. Type in the desired text. Move the text around until you find the desired placement.

Note: For greater accuracy, you can turn on the Ruby Overlay mode by clicking its button in the status 
area. Ruby Overlay mode, combined with Mask Channel mode, allows you to see the image, but only 
affect the Mask Channel.

5. Open the Object menu and choose Combine. The text is anchored to the base image. (If you are 
not working in with objects turned on, then you can ignore step 5.)

6. Click the Mask Channel button in the status bar to turn off the Mask Channel.
You now have a black and white marquee in the shape of the text on your screen. If you left the 
ruby overlay on, then the text will appear as cut outs in the overlay. The text can be moved using 
the Move Mask and Copy Mask options in the Mask Transform ribbon.

6. Open the Mask menu and choose Save. Type in a name for the mask and click Save.
7. Open the Mask menu and choose Feather. The Feather Mask dialog box opens.
8. Set the Amount to 5 and the Edge to Soft, then click Feather to apply.
9. Open the Map menu and choose Contrast/Brightness. A submenu opens.
10. Choose Joystick. The Contrast/Brightness dialog box opens.
11. Reduce the brightness by -20% and the contrast by -20%. Click OK to apply changes.

Note: You can vary the settings to change the effect. To do this, change a setting, and click Preview to 
view the change. When the desired effect is achieved, click OK to apply changes.

12. Open the Mask menu and choose Load to load the previously saved mask.
13. Click the Mask tool, then click the Mask Transform tool.
14. Set the mode in the Transform Ribbon area to Move Mask.
15. Drag a bounding rectangle around the text block.
16. Using the arrow keys, move your text up 5 and to the left 5.

You can fill the text mask with a desired color or texture, or paste an image into the text mask.

Note: This procedure for creating a drop shadow makes the drop shadow a permanent part of the image. 

Related Topics
Using the Text Tool



Creating Glow Text

To create glow text:

1. Activate the Mask channel by selecting its button in the status area.
2. Click the Text tool, and set the desired font and points size.
3. Click the left mouse button, and type in the desired text.
4. Open the Object menu and choose Combine. The text is anchored to the base image. (If you are 

not working in with objects turned on, then you can ignore this step.)
5. Click the Mask Channel button in the status bar to turn off the Mask Channel.
6. Open the Mask menu and choose Save. Type a name for the mask and the click Save to save 

the mask.
7. Click the Mask Channel button in the status bar to turn on the Mask Channel.
8. Open the Image menu and choose Effects. The EffectsBrowser dialog box opens.
9. From the list of Distortion effects, choose Gaussian Blur.
10. Set the amount to 10, and click Apply. Click OK to close the EffectsBrowser dialog box.
11. Click the Mask Channel button in the status bar to turn off the Mask Channel.
12. Click the Fill tool, then click the Color Tint Fill tool. Select the desired active color, and click the Fill 

tool on the image to fill the mask.
13. Open the Mask menu and choose Load to load the previously saved mask.
14. Click on the image with the Tint Fill tool.

You should now have a glowing text block on your image. You can vary the effect by trying different blur 
radii and using a different color for the fill and the glow. These steps can be recorded with the macro 
function to be replayed on any desired image.

Related Topics
Using the Text Tool



Creating a Text Mask

You might use a text mask to fill with a texture, cut out a portion of an image, or paste an image into the 
mask.

To create a text mask:

1. Open the image that will be used with the text mask.
2. Click the Mask Channel button to turn on the Mask Channel.
3. Make sure your active color is set to white. 
4. Type in the desired text. Move the text around until you find the desired placement.

Note: For greater accuracy, you can turn on the Ruby Overlay mode by clicking its button in the status 
area. Ruby Overlay mode, combined with Mask Channel mode, allows you to see the image, but only 
affect the Mask Channel.

5. Open the Object menu and choose Combine. The text is anchored to the base image. (If you are 
not working in with objects turned on, then you can ignore step 5.)

6. Click the Mask Channel button to turn off the Mask Channel.

You now have a black and white marquee in the shape of the text on your screen. If you left the ruby 
overlay on, then the text will appear as cutouts in the overlay. The text can be moved using the Move 
Mask and Copy Mask options in the Mask Transform ribbon. You can also save the mask using the Save 
command in the Mask menu.

Related Topics
Using the Text Tool



Edit Command (Brush Styles)

The Edit command lets you edit existing brush styles.

Related Topics
Create Brush Style dialog box 
Create Draw Style dialog box 



Create Brush Style Dialog Box

Brush Style List Box
Click the down arrow to choose a brush style to edit, or type a new name to create a new brush style.

Spacing Area
Use this area to set how far apart the points in a brush stroke are laid down. You can create very solid or 
very dotty brushes. Experiment to get the style you want.

Fade Area
Use this area to set how fast a brush fades to nothing, The size of the brush gets smaller as a brush 
fades.

Merge Mode List Box
This list box contains various editing options. When used in conjunction with editing tools, such as Paint 
or Fill, these options let you combine, or mix, colors using additive or subtractive color theory. You also 
can selectively change an image according to hue, saturation, or lightness and make modifications to the 
red, green, or blue channel of an image.

The Normal option is the default setting in the Merge Mode list box. When Normal is selected, Picture 
Publisher behaves as if Merge Mode is off, and no editing effects are possible.

The Additive option lets you mix colors according to the additive color model. If you paint a red image 
with a blue brush, magenta appears in the image as a result of the additive mixing of red and blue. If you 
paint with a green brush on a red background, you get yellow. To calculate the resultant color, simply add 
the RGB values of the colors together and round down any number over 100 to 100.

An example of additive mixing using green and blue is shown below.

Green R(0) G(100) B(0)
Blue R(0) G(0) B(100)

--------------------------------
Cyan R(0) G(100) B(100)

Adding the R column results in 0, adding the G column results in 100, and adding the B column results in 
100. These values represent a color (cyan) that has the value of R(0), G(100), B(100).

Note: Be sure to adjust all numbers so they do not exceed 100. For example, if the total of the B column 
adds to 140, round the value down to 100.

The Subtractive option lets you mix colors according to the subtractive color model. If you paint on a 
cyan image with a magenta brush, blue appears in the image as a result of the subtractive mixing of cyan 
and magenta. If you paint with a yellow brush on a magenta background, you get red. To calculate the 
resultant color, add the RGB values of the colors together, subtract 100 from the answer, round any 
negative value to 0, and round any number over 100 to 100.

An example of subtractive mixing using cyan and magenta is shown below.

Cyan R(0) G(100) B(100)
Magenta R(100) G(0) B(100)

--------------------------------
R(100) G(100) B(200)

-100 -100 -100
--------------------------------

Blue R(0) G(0) B(100)



Adding the R column results in 100, adding the G column results in 100, and adding the B column results 
in 200. Subtract 100 from the resultant R, G, and B values. These ending values represent a color (blue) 
that has the value of R(0), G(0), B(100). Be sure to adjust all numbers so there are no negative numbers 
and no values over 100. For example, if the B column is -20, round the value to 0; if the B column is 140, 
round the value down to 100.

The If Lighter option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value equal to, or higher than that of the image, the 
color of the editing tool is transferred to the image. If the lightness value is not equal to or less than that of 
the image, no change occurs. For example, if you are painting with white (white has a lightness value of 
100), all of the colors in the image are affected. If you paint with black (black has a lightness value of 0), 
none of colors in the image are affected. Notice that any primary color will paint over any other primary 
color (except white) because all primary colors have the same lightness value (except black, which has 
the lowest lightness value, and white, which has the highest lightness value).

The If Darker option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value lower than that of the image, the color of the 
editing tool is transferred to the image. If the lightness value is not lower than the image, no change 
occurs. For example, if you paint with white (white has a lightness value of 100), none of the colors in the 
image are affected. If you are painting with black (black has a lightness value of 0), all of the colors in the 
image are affected.

The Filter option uses a combination of Additive and Multiply to create a filtered effect.

The Multiply option multiplies the value of the image and the editing tool colors.

The Difference option subtracts the value of the editing tool from the value of the existing color to obtain 
a new color.

The Texturize option uses the editing tool as a texture surface on which the image is painted.

The Color option lets you replace the color of an image with the color of the editing tool, or source, used. 
Color is composed of the "H," or hue value, and the "S," or saturation value, in the HSL color model. For 
example, if you are painting with blue (H=240, S=100), all of the painted colors take on the same H and S 
values of blue. This results in a color change; however, the lightness values remain the same.

Note: Hue and saturation values have no affect on black or white. This is because the lightness value of 
black is 0 and the lightness value of white is 100. Any color with the lightness value of 0 is black 
regardless of the hue and saturation values. Any color with the lightness value of 100 is white regardless 
of the hue and saturation values.

The Hue option lets you replace the hue value of an image with the hue value of the editing tool, or 
source, used. For example, if you are painting with green (H=120), all colors (except white and black) that 
are painted become green. Notice that if you paint with red, white, or black, you get the same results. This 
is because all three of these colors have the same hue value (H=0).

The Saturation option lets you replace the saturation value of an image with the saturation value of the 
editing tool, or source, used. For example, if you are painting with any primary color (except white or 
black) onto any other primary color, only white and black are affected; the other colors remain the same. 
This is because all primary colors have the same saturation value (S=100), except for white (S=0) and 
black (S=0). If you are painting with white or black, the colors become grayscale values; remember that 
grayscale images have no saturation.



The Luminance option lets you replace the luminance value of an image with the lightness value of the 
editing tool, or source, used.

The Red option lets you replace the red channel (using the RGB color model) of an image with the value 
of the red channel source. Only the red channel is affected. The results from using the Red Only option 
are the same as if you were to split the RGB channels using the Channels command, make changes to 
the red channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the red 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 0, 0, 
100 (blue). The red value from the brush (0) replaces the red value in the image (100) to create blue.

The Green option lets you replace the green channel (using the RGB color model) of an image with the 
value of the green channel source. Only the green channel is affected. The results from using the Green 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the green channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the green 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a red image (RGB value = 100, 0, 0), the result is a color that has an RGB value of 100,100, 0 
(yellow). The green value from the brush (100) replaces the green value in the image (0) to create yellow.

The Blue option lets you replace the blue channel (using the RGB color model) of an image with the 
value of the blue channel source. Only the blue channel is affected. The results from using the Blue 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the blue channel image, and then combine the channels.

To determine the resulting value of mixing the source and image, replace the image value of the blue 
channel with the source value. For example, if you are painting with a green brush (RGB value = 0, 100, 
0) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 100, 0, 
0 (red). The blue value from the brush (0) replaces the blue value in the image (100) to create red.

Style Buttons
Choose the type of brush to use, either solid or scattered.

Style Pressure Area
Use this area to set how scattered the scatter style is. A low value creates a very sparse scatter style, and 
a high value creates a very dense scatter style.

Note: This area is available only when the scatter brush style is chosen.

Smoothness Area
Use this area to set how true the brush stroke is to the actual stroke. For example, if the Smoothness 
setting is low, you might get straight lines between brush strokes when moving the brush quickly. Turn up 
the Smoothness setting to record the strokes and place them on the image.

Overlap Brush Strokes Option
Choose this option to specify whether the brush strokes double up when transparency is used. For 
example, you may want a specific transparency to be applied only once to an area of the image. If you 
turn off this option, only one layer of paint is applied per brushing session. However, this option can take 
up more memory when using manual apply mode.

Note: This area is not available for the Filter tools.

Editing Area



Use this area to create the brush style you want.

Note: This area is not available for the Filter tools.

Reset Button
Click the Reset button to clear the editing area.



Create Draw Style Dialog Box

Brush Style List Box
Click the down arrow to choose a draw style to edit, or type a new name to create a new draw style.

Spacing Area
Use this area to set how far apart the points in a brush stroke are laid down. You can create very solid or 
very dotty brushes. Experiment to get the style you want.

Fade Area
Use this area to set how fast a brush fades to nothing, The size of the brush gets smaller as a brush 
fades.

Merge Mode List Box
This list box contains various editing options. When used in conjunction with editing tools, such as Paint 
or Fill, these options let you combine, or mix, colors using additive or subtractive color theory. You also 
can selectively change an image according to hue, saturation, or lightness and make modifications to the 
red, green, or blue channel of an image.

The Normal option is the default setting in the Merge Mode list box. When Normal is selected, Picture 
Publisher behaves as if Merge Mode is off, and no editing effects are possible.

The Additive option lets you mix colors according to the additive color model. If you paint a red image 
with a blue brush, magenta appears in the image as a result of the additive mixing of red and blue. If you 
paint with a green brush on a red background, you get yellow. To calculate the resultant color, simply add 
the RGB values of the colors together and round down any number over 100 to 100.

An example of additive mixing using green and blue is shown below.

Green R(0) G(100) B(0)
Blue R(0) G(0) B(100)

--------------------------------
Cyan R(0) G(100) B(100)

Adding the R column results in 0, adding the G column results in 100, and adding the B column results in 
100. These values represent a color (cyan) that has the value of R(0), G(100), B(100).

Note: Be sure to adjust all numbers so they do not exceed 100. For example, if the total of the B column 
adds to 140, round the value down to 100.

The Subtractive option lets you mix colors according to the subtractive color model. If you paint on a 
cyan image with a magenta brush, blue appears in the image as a result of the subtractive mixing of cyan 
and magenta. If you paint with a yellow brush on a magenta background, you get red. To calculate the 
resultant color, add the RGB values of the colors together, subtract 100 from the answer, round any 
negative value to 0, and round any number over 100 to 100.

An example of subtractive mixing using cyan and magenta is shown below.

Cyan R(0) G(100) B(100)
Magenta R(100) G(0) B(100)

--------------------------------
R(100) G(100) B(200)

-100 -100 -100
--------------------------------

Blue R(0) G(0) B(100)



Adding the R column results in 100, adding the G column results in 100, and adding the B column results 
in 200. Subtract 100 from the resultant R, G, and B values. These ending values represent a color (blue) 
that has the value of R(0), G(0), B(100). Be sure to adjust all numbers so there are no negative numbers 
and no values over 100. For example, if the B column is -20, round the value to 0; if the B column is 140, 
round the value down to 100.

The If Lighter option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value equal to, or higher than that of the image, the 
color of the editing tool is transferred to the image. If the lightness value is not equal to or less than that of 
the image, no change occurs. For example, if you are painting with white (white has a lightness value of 
100), all of the colors in the image are affected. If you paint with black (black has a lightness value of 0), 
none of colors in the image are affected. Notice that any primary color will paint over any other primary 
color (except white) because all primary colors have the same lightness value (except black, which has 
the lowest lightness value, and white, which has the highest lightness value).

The If Darker option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value lower than that of the image, the color of the 
editing tool is transferred to the image. If the lightness value is not lower than the image, no change 
occurs. For example, if you paint with white (white has a lightness value of 100), none of the colors in the 
image are affected. If you are painting with black (black has a lightness value of 0), all of the colors in the 
image are affected.

The Filter option uses a combination of Additive and Multiply to create a filtered effect.

The Multiply option multiplies the value of the image and the editing tool colors.

The Difference option subtracts the value of the editing tool from the value of the existing color to obtain 
a new color.

The Texturize option uses the editing tool as a texture surface on which the image is painted.

The Color option lets you replace the color of an image with the color of the editing tool, or source, used. 
Color is composed of the "H," or hue value, and the "S," or saturation value, in the HSL color model. For 
example, if you are painting with blue (H=240, S=100), all of the painted colors take on the same H and S 
values of blue. This results in a color change; however, the lightness values remain the same.

Note: Hue and saturation values have no affect on black or white. This is because the lightness value of 
black is 0 and the lightness value of white is 100. Any color with the lightness value of 0 is black 
regardless of the hue and saturation values. Any color with the lightness value of 100 is white regardless 
of the hue and saturation values.

The Hue option lets you replace the hue value of an image with the hue value of the editing tool, or 
source, used. For example, if you are painting with green (H=120), all colors (except white and black) that 
are painted become green. Notice that if you paint with red, white, or black, you get the same results. This 
is because all three of these colors have the same hue value (H=0).

The Saturation option lets you replace the saturation value of an image with the saturation value of the 
editing tool, or source, used. For example, if you are painting with any primary color (except white or 
black) onto any other primary color, only white and black are affected; the other colors remain the same. 
This is because all primary colors have the same saturation value (S=100), except for white (S=0) and 
black (S=0). If you are painting with white or black, the colors become grayscale values; remember that 
grayscale images have no saturation.



The Luminance option lets you replace the luminance value of an image with the lightness value of the 
editing tool, or source, used.

The Red option lets you replace the red channel (using the RGB color model) of an image with the value 
of the red channel source. Only the red channel is affected. The results from using the Red Only option 
are the same as if you were to split the RGB channels using the Channels command, make changes to 
the red channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the red 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 0, 0, 
100 (blue). The red value from the brush (0) replaces the red value in the image (100) to create blue.

The Green option lets you replace the green channel (using the RGB color model) of an image with the 
value of the green channel source. Only the green channel is affected. The results from using the Green 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the green channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the green 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a red image (RGB value = 100, 0, 0), the result is a color that has an RGB value of 100,100, 0 
(yellow). The green value from the brush (100) replaces the green value in the image (0) to create yellow.

The Blue option lets you replace the blue channel (using the RGB color model) of an image with the 
value of the blue channel source. Only the blue channel is affected. The results from using the Blue 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the blue channel image, and then combine the channels.

To determine the resulting value of mixing the source and image, replace the image value of the blue 
channel with the source value. For example, if you are painting with a green brush (RGB value = 0, 100, 
0) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 100, 0, 
0 (red). The blue value from the brush (0) replaces the blue value in the image (100) to create red.

Style Buttons
Choose the type of brush to use, either solid or scattered.

Style Pressure Area
Use this area to set how scattered the scatter style is. A low value creates a very sparse scatter style, and 
a high value creates a very dense scatter style.



Editing and Creating Brush Styles

To edit or create a brush style:

1. In the tool ribbon (Retouch or Filter), click the File Options button. A submenu opens.
2. Choose Edit. The Create Brush Style dialog box opens.
3. Set the options that you want.
4. Create the type of brush style you want in the Editing area.
5. Click Create to create the brush style.

Related Topics
Create Brush Style dialog box 



Creating Draw Styles

To edit or create a brush style:

1. In the Draw tool ribbon, click the File Options button. A submenu opens.
2. Choose Edit. The Create Draw Style dialog box opens.
3. Set the options that you want.
4. Create the type of brush style you want in the Editing area.
5. Click Create to create the brush style.

Related Topics
Create Draw Style dialog box 



Delete Command (Brush and Draw Styles)

The Delete command lets you delete brush and draw styles. You can delete only the styles that create.

Related Topics
Procedure information 



Deleting Brush or Draw Styles

To delete brush or draw styles:

1. In the Retouch, Filter, or Draw tool ribbon, click the File Options button. A submenu opens.
2. Choose Delete. A confirmation messages appears, asking "Are you sure you want to delete (style 

name)?".
3. Click OK to delete the style.

Related Topics
Command information 



Rename Command (Brush and Draw Styles)

The Rename command lets you rename selected brush and draw styles.

Related Topics
Dialog Box information 
Procedure information 



Brush Style Name Dialog Box

Enter Name Text Box
Type a new name in this text box.

Related Topics
Command information 
Procedure information 



Renaming a Brush or Draw Style

To rename a brush or draw style:

1. In the Retouch, Filter, or Draw tool ribbon, click the File Options button. A submenu opens.
2. Choose Rename. The Brush Style Name dialog box opens.
3. Enter a name for the selected style.
4. Click OK to rename the style.

Related Topics
Command information 
Dialog Box information 



Creating a Custom Brush

You can create a custom brush one of two ways: use the Custom command, or use the Copy To 
command.

To create a custom brush using the Custom command:

1. In the Retouch, Filter, or Draw tool ribbons, click the down arrow in the Brush list box.
2. Choose Custom. The Select Custom Brush dialog box opens.
3. Type a name for the new custom brush.
4. Select the Open editing window option.
5. Click OK. An editing window opens, 99 pixels by 99 pixels in size. Create the custom brush in the 

editing window.
6. Open the File menu and choose Save to save the custom brush.

To create a custom brush using the Copy To command:

1. Draw a mask around the area you want to make into a custom brush.
2. Open the Edit menu and choose Copy To. The Copy To dialog box opens.
3. Choose Custom Brush option.
4. Type a name for the brush in the Brush Name text box.
5. Click Copy to create the new custom brush.



Select Custom Brush Dialog Box

Custom Brush Name List Box
Type a new name for the custom brush in this box.

File Options Button
Click this button to open a submenu that lets you add, delete, and rename custom brushes.

Open Editing Window Option
Choose this option to open an editing window that lets you create the custom brush.



Specialized How To's

How to Reduce the Rainbow on a Scanned Photo
How to Reduce the Checkerboard Pattern on a Scanned Photo
How to Create Great Line Art
How to Duplicate Objects
How to Create a Good Anti-Aliased Edge
How to Make an Object Fade
How to Clip an Object
How to Erase Parts of an Object
How to Add (Unerase) from an Object
How to Create a Drop Shadow for an Object
How to Merge Two Images Together
How to Make Buffering Effects for Painting or Airbrushing
How to Create a Soft Cameo
How to Create a Multi-Level Threshold
How to Use Masks to Fade (Graduate) Effects
How to Create An Anti-Aliased Edge for Cutting,Copying, and Pasting
How to Create a Wood Grain Texture
How to Create a Brushed Steel Texture



How to Reduce the Rainbow on a Scanned Photo

The rainbow effect is a common problem for anyone who scans in glossy photos rather than matte-
finished photos. You can dampen this effect by putting diffusing film on the photo before scanning. 
Diffusing film is available at most photography stores.

Related Topics
Specialized How To's



How to Reduce Checkerboard Patterns on a Scanned Photo

This is a common problem for anyone who scans magazine and newspapers photos. It comes from 
scanning in a halftone pattern. 

To reduce a checkerboard pattern:

1. Scan in the desired image.
2. Open the Image menu and choose Effects. The EffectsBrowser dialog box opens..
3. Select Remove Pattern from the list of Photographic effects.
4. Choose the desired setting and click Apply.
5. Select Unsharp Mask from the list of Photographic effects.
6. Choose the desired settings and click Apply. 
7. Click OK to close the EffectsBrowser dialog box.

Related Topics
Specialized How To's



How to Create Line Art

One of the potential problems with scanning in line art is that it either comes out too light or too dark. The 
reason is that the computer is deciding to threshold at 50% every time, and that may or may not be right 
for your particular scan. The following procedure allows you to get good line art to your liking every time.

How to create good line art:

1. Scan your image as a grayscale.
2. Open the Image menu and choose Effects. The EffectsBrowser dialog box opens..
3. Select Unsharp Mask from the list of Photographic effects.
4. Choose the desired settings and click Apply. 
5. Click OK to close the EffectsBrowser dialog box.
6. Open the Map menu and choose Select Posterize/Threshold.
7. Adjust the threshold slider, previewing until the desired image is achieved.
8. Open the Image menu and choose Convert To. A submenu opens.
9. Choose Line Art.

This procedure allows you to choose where to threshold the image, rather than relying on the computer to 
make that decision. You can also do a multi-level threshold to grab up more or less levels.

Note: This procedure requires more memory than a standard line art scan, but once the procedure is 
completed it takes up the same memory as a standard line art image.

Related Topics
Specialized How To's



How to Duplicate Objects

To duplicate selected objects using copy and paste:

1. Open the Edit menu and choose Copy.
2. Open the Edit menu and choose Paste.

Press and hold Shift, and press the left mouse button and drag to create a copy of the object or objects.

Related Topics
Specialized How To's



How to Create a Good Anti-Aliased Edge

When an edge is aliased, it has jagged edges, or a stair-step effect. Anti-Aliasing is a process that blends 
the edges of an object, with the surrounding pixels, to remove the jagged edges. This has the effect of 
making the object look as if it really belongs in the image in which it is pasted. Picture Publisher makes 
this process easy with the Feather command in the Object Menu.

To anti-alias an object:

1. Select the object to be feathered.
2. Open the Object menu and choose Feather. The Feather Object dialog box opens.
3. Set the Amount to 1, and the Edge to soft.
4. Click Feather to apply the feathering to the object.

More anti-aliasing may be necessary, depending on how rough the edge is. To anti-alias the object more, 
increase the feather amount.

Related Topics
Specialized How To's



How to Make an Object Fade

The Merge Mask command in the Object Menu makes an object look as if it is blending in with the base 
image, or fading away.

To make an object fade:

1. Select the object(s) that you want to fade.
2. Click the Mask Channel button to turn it on.
3. Click the Ruby Overlay button to turn it on.

Note: You turn on Ruby Overlay mode so that you can see the image, but only affect the Alpha (Mask) 
Channel. This allows you to precisely start and end the effect where you want.

4. Click the Fill tool, then click the Gradient Fill tool.
5. Set the Gradient Type to Linear, Color Model to (Normal), Sweep to 1, Midpoint to 50%, 

Transparency to 0%, and Merge Mode to (Normal).
5. Make sure the active color is white, and the alternate color is black, then draw the gradient from 

where you want the effect to start, and to where you want it to end.
6. Click the Ruby Overlay button to turn it off.
7. Click the Mask Channel button to turn it off.
8. Open the Object Menu and choose Merge Mask. The current mask merges with all selected 

objects, giving them the properties of the mask. So in this example, the objects graduate or fade.

You can take this further by varying the options in the Gradient Fill ribbon, such as Gradient Type, and 
Midpoint.

Related Topics
Specialized How To's



How to Clip an Object

You can use the Merge Mask command to clip objects and put them "behind" pieces of the base image. 
For example, if you have a picture of a person, and you want the object to be behind the person, you 
draw a mask around the person, invert the mask, place the object in the desired location, and choose 
Merge Mask in the Object Menu. Any areas outside the mask will be clipped, giving the illusion that the 
object is behind the person.

Note: To soften the edges of the clipped areas, feather the mask before selecting the Merge Mask 
command. 

Related Topics
Specialized How To's



How to Erase Parts of an Object

Picture Publisher uses the Paint On Mask tool to erase part of an object, or even restore part of an object 
that has been clipped in the past. The Paint On mask tool has two different Paint On modes, Image Mask 
and Object Alpha. Image mode allows you to draw a mask on your screen by painting. Object Alpha mode 
allows you to add or subtract from an object's Mask Channel.

To erase parts of an object:

1. Select the desired object.

Note: This tool can only work on one object at a time.

2. Click the Mask tool, then choose the Paint On Mask tool.
3. Set the Mode to subtractive(-).
4. Paint on the desired location on the object.

Painting erases the object, allowing whatever is below the object to show through. Set the feathering to a 
higher number to create a smoother edge.

Related Topics
Specialized How To's



How to Add (Unerase) from an Object

To add to an object:

1. Select the desired object.

Note: This tool can only work on one object at a time.

2. Click the Mask tool, then choose the Paint On Mask tool.
3. Set the Mode to Additive(+)
4. Paint on the desired location on the object.

Wherever you paint, hidden portions of the object are revealed. Setting the feathering to a higher number 
creates a smoother edge.

Related Topics
Specialized How To's



How to Create a Drop Shadow for an Object

To create a drop shadow for an object:

1. Select the desired object.

Note: A blue and black marquee    surrounds the selected object. If it does not, then it is not an object, or 
the Hide Marquee command in the Object menu is chosen.

2. Press Shift and click and drag to create a copy of the object .
3. Color Tint Fill the copy with black.
4. In the Selector ribbon, set the transparency to 50%.
5. Move the copy to the back by pressing Shift and clicking the down arrow in the Layers Option or 

choosing Move To Back in the Object menu.
6. Move the shadow into the desired position.

Note: You can use the transform options to shrink, enlarge, and distort the shadow's appearance. The 
transform options become available when you click on the Transform Icon in the Selector ribbon.

7. Open the Object menu and choose Feather. The Feather Object dialog box opens.
8. Type in an Amount of 5, an Edge of Soft, and click Feather.

Note: The amount of feathering varies with size of object. The larger the object, the greater the amount 
you should use, while the smaller the object, the lower number you should use.

Related Topics
Specialized How To's



How to Merge Two Images Together

To merge two images together:

1. Select an image to be the base image.
2. Click the Mask Channel button to turn it on.
2. On the Mask Channel, draw a linear gradient from the top left corner to the bottom right corner.
3. Return to the base image by turning off the Mask Channel.
4. Open another image to be the merged image.
5. Copy the image to be merged to the clipboard.
6. Select Paste Into, to paste the merged image into the Mask channel of the base image.
7. Position the merged image, and then double click to commit the image.

Note: If you are in Object mode, you can combine the object with the base at this point, or leave it 
floating. 

Related Topics
Specialized How To's



How to Make Buffering Effects for Painting or Airbrushing

An interesting creative retouching technique is to paint or airbrush an effect, such as charcoal, onto your 
image. This effect can be accomplished in Picture Publisher by running an effect on the image, and then 
using one of the eraser undo brush styles to paint the effect back on the image.

Note: You must use auto apply mode for this technique to work. 

To make buffering effects:

1. Open the desired image.
2. Open the Image menu and choose Effects. The EffectsBrowser opens.
3. Select the desired effect, click Apply, then click Close.
4. Open the Edit menu and choose Undo.
5. Click the Retouch tool, then click the Eraser tool.
6. Select the desired type of undo eraser from the list of brush styles.

Note: You must use an undo eraser, so erase to background, and erase to white will not work.

7. Carefully paint the effect back onto your image.

Note: Because you are painting from your undo, there is no way to undo the eraser changes that you are 
painting onto the image.

Related Topics
Specialized How To's



How to Create a Soft Cameo

Soft cameos are used by photographers for effect. These effects are easily reproducible using Picture 
Publisher's 8-bit masks. It is similar to the filters photographers use to develop the film to create the 
cameos in the darkroom.

To create a soft cameo:

1. Open the desired image.
2. Draw an elliptical mask around the desired subject.
3. Open the Mask menu and choose Feather. The Feather Mask dialog box opens.
4. Set the amount to 10-20 pixels, edge to outside, and a soft hardness setting. Click Feather.
5. Open the Mask menu and choose Invert.
6. Click the Fill tool, then click the Color Tint Fill tool.
7. Set your active color to white, and click on the image to fill in the area around the selected 

subject.

The higher the feathering you use, the softer the cameo effect. Try a different amount, edge, and 
hardness settings for different effects.

Related Topics
Specialized How To's



How to Create a Multi-Level Threshold

Sometimes it is necessary to threshold more than just a standard binary threshold. For example, if you 
want your image to be threshold at 20-30% and 70-80%, then the standard tools will not help you. 
Instead, you can use the Modify Color Maps command in the Maps menu to create a threshold map.

To create a multi-level threshold:

1. Open the desired image to threshold.
2. Open the Map menu and choose Modify Color Maps. The Modify Color Maps dialog box opens.
3. Set the Editing to Values.
4. Type in the following values:
Input: 0, 20, 20, 30, 30, 70, 70, 80, 80, 100, 100.
Output: 0, 0, 100, 100, 0, 0, 100, 100, 0, 0, 0.
5. Now switch the Editing to 11 points to view the map.

Notice the shape of the map. You can use this technique for any level thresholding you care to create. All 
that is necessary, is that the first values be 0,0 and then follow the pattern, outlined above.

Note: This technique can also be used with the calibration maps, and the black generation maps, to 
create strange scans, and prints.

Related Topics
Specialized How To's



How to Use Masks to Fade (Graduate) Effects

Some times there is a desire to have an effect blend into the image, so part of your image looks normal, 
part of you imagelooks like the effect, and the middle part is a transition. Picture Publisher can accomplish 
this task easily with its 8-bit masking capabilities.

To use masks to graduate effects:

1. Click the Mask Channel button to turn it on.
2. Click the Fill tool, then click the Gradient Fill tool.
3. Set the active color to white and the alternate color to black.
4. Draw the desired gradient on the Mask Channel.
5. Click the Mask Channel button to turn it off.
6. Open the Image menu and choose Effects. The EffectsBrowser dialog box opens.
7. Choose the desired effect from the list of effects, and click Apply. Click OK to close the 

EffectsBrowser dialog box.

You can vary this effect by using different types of gradients, changing the sweep and transition, and 
changing the transparency of the gradient.

Related Topics
Specialized How To's



How to Create an Anti-Aliased Edge for Cutting,Copying, and Pasting

Normally when you cut out an object and paste it, it has a rough or aliased edge. Picture Publisher allows 
you to eliminate this edge by using the Feather command in the Mask menu.

The options for feathering are relatively simple:

Amount - How many pixels wide to make the feather.
Edge - How the transition along the edge will be handled.
Direction - Where the feathering will occur.

The last option is possibly the most important option available in the Feather Mask dialog box. For 
example, if you have just masked off an area, and outside of that mask is an undesired green 
background, you would not want to Feather Outside or Center, because it would pick up that green area. 
Instead, you would Feather Inside, giving you a smooth anti-aliased edge. Feather Outside, and Center 
are more useful for special effects rather than creating an anti-aliased edge.

Related Topics
Specialized How To's



How to Create a Wood Grain Texture

How to create a wood grain texture:

1. Create a blank new image. Set Image Type to RGB Color, Width 3 inches, Height 3 inches, and 
Resolution to 150 ppi.

2. Open the Image menu and choose Effects. The EffectsBrowser dialog box opens.
3. From the list of Distortion effects, choose Add Noise.
4. Set the settings to 30% darker, and click Apply.
5. From the list of Distortion effects, choose Motion Blur.
6. Set the direction to the left, the distance to 12, and click Apply. Click OK to close the 

EffectsBrowser dialog box.
7. Open the Map menu and chooose Hue/Saturation. The Hue/Saturation/Lightness dialog box 

opens.
8. Slide the saturation to 25%, the first hue slider down until it has an orange tint, and the lightness 

slider to -25%. Click OK to apply the change to the image.

You can experiment further with wood grain by varying the Hue, Saturation, and Lightness values apply to 
the texture. You can preview your changes before applying them by using the preview button. You can 
further modify the wood grain by changing the distance of the blur and the darkness of the Add Noise.

Related Topics
Specialized How To's



How to Create a Brushed Steel Texture

How to create a brushed steel texture:

1. Create a blank new image. Set Image Type to RGB Color, Width 3 inches, Height 3 inches, and 
Resolution to 150 ppi.

2. Open the Image menu and choose Effects. The EffectsBrowser dialog box opens..
3. From the list of Distortion effects, choose Add Noise.
4. Set the settings to 30% darker, and click Apply.
5. From the list of Distortion effects, choose Motion Blur.
6. Set the direction to the left, the distance to 12, and click Apply. Click OK to close the 

EffectsBrowser dialog box.

You can further modify the brushed steel texture by changing the distance of the blur and the darkness of 
the Add Noise.

Related Topics
Specialized How To's



Picture Publisher Read Me

You can use this on-line "Read Me" file to give you faster access to important information. To see 
information about any topic below, double click on it.

Because of the time required to print the manuals, they may not contain the most recent 
information about Picture Publisher's features. In the few places where the information in the 
manuals does not match the information in on-line help, use the more recent information in on-
line help.

Corrections to the Manual 
AVI Files 
Generating a Black (K) Plate for Color Separations 
Opening Targa Files 
Performance Issues 
PP.INI Additions 
Printing Issues 
Program Information 
Scanning Issues 
Shortcut Keys 
Working with Other Applications 



Generating a Black (K) Plate for Color Separations

When you create a color separation, you must make certain adjustments for ink correction selections to 
make a black plate. The black plate is generated from the ink correction and black generation settings. If 
you do not make these adjustments, the black plate will not be what you expected.

Note: If you want to save the file as an EPS file, then do no split the image into CMYK. If you want to 
save the file as a 32-bit TIFF image, first split it into CMYK channels.

To generate a black plate by splitting it into CMYK:

1. Open the image you want to separate.
2. Open the File menu and choose Setup. A submenu opens.
3.  Choose Printer. The Setup Printer dialog box opens.
4.  Choose Color PostScript Printer in the Print Style list box. (This will automatically enter a color 

separation style in the Setup Print Style dialog box.)
5. Click Setup Print Style. The Setup Print Style dialog box opens. Notice that all the style boxes 

have Color PostScript entered.
6. Click the File Folder icon next to the Color Separation Style box. A menu opens.
7. Choose Edit. The Edit Color Separation Style dialog box opens.
8. You can change the values as necessary, then click OK.



Corrections to the Manual

On page 2-10, in the section Using Smart Mask, add the following after step 7:

8. Open the Mask menu and choose Invert.

On pages 2-27, 2-29, and 2-31, the images in the figures may not look the same as the image you are 
working with.

On page 2-26, change the value in step 8 to 60 instead of 50.

On page 2-28, change the value in step 8 to 10 instead of 50 for light pressure.

On page 2-29, change the value in step 5 to 10 instead of 50 for light pressure.

On page 2-29, change the value in step 6 to 10 instead of 15 for a smaller size brush.



Printing Issues

When printing with a LaserJet II at either 75 or 150 dpi, the image width doubles. The device driver does 
not report the correct resolution for the printer when in low resolution mode. To ensure proper output to 
this device, make sure that the driver is configured for 300 dpi.

When you test print an image in Picture Publisher the labels for the 'thumbnails' can become overlapped if 
the Print Style name is too long.

Printing with any of the Hewlett Packard 500 series printers with the HP printer driver in low-resolution 
mode prints incorrectly. This combination prints correctly if the driver is configured for proof or high-
resolution mode.

If you print to a PostScript device and are experiencing problems (for example, the image looks like it is 
printed at a low resolution), you can set the PRINTSCALING= statement in the PP.INI file to 
PRINTSCALING=1. 

If you experience problems printing to GDI printers (for example, the HP 5550C), choose the Use Printer 
Screening option in the Setup Printer dialog box.

Related Topics
Generating a Black (Y) Plate for Color Separations 



Scanning Issues

If you experience inverted line art when scanning, you can set the SCANLAINVERT= statement in the 
PP.INI file to SCANLAINVERT=1. 



Opening Targa Files

You can open 32-bit CMYK Targa files by changing the TGACMYK= statement in the PP.INI file to 
TGACMYK=1. 

Note: You should modify the PP.INI first, then run Picture Publisher. If you try to change the PP.INI file 
while running Picture Publisher, your changes to the PP.INI file will not be saved.

Note: Picture Publisher does not support saving CMYK Targa files. Save the file as a 32-bit TIFF file for 
future editing.

Picture Publisher does not directly support 32-bit RGBA targa files, but Picture Publisher can read a 32-bit 
RGBA Targa file using the following procedure.

To read a 32-RGBA Targa file into Picture Publisher:

1. Make sure you have changed the TGACMYK statement in the PP.INI file to TGACMYK=1.
2. Open the desired RGBA Targa file.
3. Open the Image menu and choose Channels, then choose Split CMYK.
4. Select the Black channel and cut it to the clipboard.
5. Open the Image menu and choose Channels, then choose Combine.
6. Press Shift+F12 to activate the Mask Channel.
7. Paste the Black channel into the mask channel.
8. Press Shift+F12 to deactivate the Mask Channel.
9. Open the Image menu and choose Convert To, then choose RGB.

Note: There is a macro that ships with Picture Publisher that automates steps 3 through 9 to make the 
conversion easier. It is called CMYK TGA to RGBA TGA. To use it, make sure the TGACMYK statement in 
the PP.INI file is set to TGACMYK=1, open the desired RGBA Targa file, then run the macro on that RGBA 
Targa file.

Note : Picture Publisher does not support saving RGBA Targa files. Save the file as a PP4 file. Choose 
the Save Mask Channel option in the Picture Publisher Format Options dialog box for future editing.



AVI Files

Picture Publisher lets you save AVI frames to the original AVI file. However, when you save the file, 
Picture Publisher does not compress the file. To compress the file, open the file in Videdit then save it.



PP.INI Additions

You can set a default file type for saving scanned and untitled images by adding the following entry to the 
PP.INI file.

DefaultFileType=
The options available are: 0=TIFF, 1=TGA, 2=GIF, 3=BMP, 4=PCX, 7=JPEG, 9=AVI, and 11=PP.

You can create binary Encapsulated PostScript files by changing BinaryEPS=0 (the default) in the PP.INI 
file to BinaryEPS=1. This creates a smaller EPS file. 

By default, Picture Publisher displays a marquee for pasted objects. You can turn off the object marquee 
for pasted objects by changing the following entry in the PP.INI file.

UseObjectMarquee=0
Entering a 0 (zero) turns off the marquee display, and becomes the new default. You can turn on and off 
the Marquee for an editing session by using the Show/Hide Marquee command in the Object menu.

The Visual Color Balance and Visual Contrast/Brightness dialog boxes automatically size themselves 
based on the display resolution. This ensures that when using higher display resolutions, the thumbnails 
will be large enough for you to see the changes. You can turn off automatic sizing by adding the following 
entry to the PP.INI file.

VisualMapSize='Number'
'Number' must be a 1, 2, or a 3 depending on the dialog box size that you want. One is the smallest size 
and three is the largest size.

The Mask Point Editor tool and the Stroke command by default only can handle paths with no more than 
999 points. You can change the maximum number of points by adding the following entry to the PP.INI 
file.

MaxNoCrashShapes='Number'
'Number' can be any number, but if there are too many points, the memory manager may fail, which could 
cause your system to fail.

The ImageBrowser has the built-in ability to cache thumbnails to speed redraw. By default, the 
ImageBrowser caches 25 thumbnails. You can change the number of cached thumbnails by adding the 
following entry to the PP.INI file.

cthmMaxCache='Number'
'Number' can be any number as long as you have enough memory to handle that amount of thumbnails. 
You can use larger numbers for larger displays.

You can disable the warning dialog box for read-only files. The default is for the warning dialog boxes to 
appear when you try to open or save to a read-only file. You can change the following entry in the PP.INI 
file.

WarnReadOnly='Number"
'Number' can either be 1, the default, which is on, or 0, which is off.

The High Quality option in the Mask and Object Transformer ribbons by default only applies during the 
actual transformation. Because of performance reasons, High Quality does not apply interactively on the 
display screen. You can override this by adding 'Quality=1' to your PP.INI file.

You can disable OLE by adding 'OLE=0' to your PP.INI file.

You can disable hint lines by adding 'Hints=0' to your PP.INI file.



Shortcut Keys

To open a FastBits(TM) version of an image in the recall list, press and hold Shift while selecting the 
image from the recall list.

To open a Low Resolution version of an image in the recall list, press and hold Shift and Ctrl while 
selecting the image from the recall list.

To relocate text without leaving edit mode, press and hold Shift and click the left mouse button on the 
new location.

To smart fill an area without using the Smart Fill tool, press and hold Shift while you click and drag the fill 
color from the color palette to the area to be filled. The current Smart Fill tool options, fill range and color 
model, are used.

To move selected objects precisely with the keyboard, press and hold Shift while pressing the arrow 
keys.

To move an object to the top or bottom, press and hold Shift while clicking the up or down Layer button 
respectively in the Selector ribbon.



Working with Other Applications

Picture Publisher 4.0 does not support the WMF (Windows Metafile) clipboard format. If you are trying to 
paste an object into Picture Publisher from an application that only renders WMF to the clipboard, first 
paste the metafile into Paintbrush and copy it back to the clipboard. Paintbrush renders the metafile as a 
bitmap, and then the bitmap can be easily pasted into Picture Publisher.

Embedding a Picture Publisher 4.0 object into Excel 4.0 does not work properly. When you try to embed a 
Picture Publisher object into Excel 4.0 using OLE, a blank box is pasted in, and results in no error 
message. Avoid paste linking into Excel 4.0.

When paste linking a Picture Publisher 4.0 object into Excel 4.0, a misdraw can occur if the object's 
bounding box is resized using the corner handles. The image prints and saves correctly, but may misdraw 
on the screen.

To capture frames from an AVI (Microsoft Video for Windows) file, you must have the runtime or the retail 
version of Microsoft Video for Windows installed on your system.

Picture Publisher 4.0 supports the drag and drop features of Windows 3.1. However, when Picture 
Publisher is minimized and a file is 'dropped' on the icon, Picture Publisher opens the file correctly but 
does not restore itself properly. Double click the Picture Publisher icon to restore it to its proper size.

Picture Publisher 4.0 supports the Adobe Plugin specification, but most of the plugins that ship with 
Adobe PhotoShop will not work with Picture Publisher. If you try to use one of these plugins with Picture 
Publisher, a message appears that states "Sorry, this filter requires PhotoShop 2.5 specific features." This 
is not a Picture Publisher problem.

Thumbnails do not redraw correctly after you rename a directory. If you rename a directory using the 
ImageBrowser in Picture Publisher 4.0, the thumbnails will not redraw. They will redraw if you close the 
ImageBrowser and then reopen it.

The accelerator keystroke for 'Close' in the Control menu, Alt+F4, does not work in the following dialog 
boxes:

Color Shield
Color Palette
Zoombox
Image Information

You can use the mouse to choose the Close command in the Control menu to close the dialog box.



Performance Issues

Some printer drivers cause the Print dialog box to take an extremely long time to display. This problem is 
caused when Picture Publisher 4.0 queries the driver for resolution and page sizes, and the printer driver 
is initialized. Some drivers take longer to return the information to Picture Publisher than others do.



Program Information

Set the Undo mode before you begin working in Picture Publisher, not while an image is open. If you want 
to change the Undo mode when you have an image open, save and close the image and Picture 
Publisher, set the Undo mode, and reopen Picture Publisher and the image.

Selecting 'Zoom by two' by going into the information dialog box while opening an *.AVI file will not resize 
the dialog box properly. The image gets resized properly, but it is cut off by the dialog box, because the 
Window does not get resized properly.

Using an *.AVI file to load as a mask does not function properly. If you choose the Load Mask command, 
and then highlight an AVI file to paste from, the mask will not paste correctly.

When you use the Mask Transformer or the Object Transformer tool to rotate a mask or object, then use 
the handles to size the selection, the direction cursor may or may not reflect the correct sizing direction. 
The tool functions properly, but the cursors may not be correct.

If you use a Custom Brush to retouch an image, then select a standard brush, the brush size remains at 
99 pixels.

Every texture fill that is installed has an associated texture brush that is also installed. When a texture fill 
is deleted the texture brush remains, but cannot be used without the texture fill.

The Picture Publisher 4.0 internal cache can be disabled by deleting the Picture Publisher cache directory 
name in the preferences dialog box. In this mode Picture Publisher will use only Windows memory and 
not our own virtual memory. The Percent Free Memory Per Image value has no effect in this mode.

Monitor Gamma Correction can only be set up when there is an image open. The Monitor command is 
grayed until an image is opened.

If a mask is on the screen and you use a negative masking tool to 'remove' the mask, you will have a 
totally black mask. Because the black portion of the mask is the 'protected' portion of the image, you will 
be unable to retouch any of the image. Use the Remove command (Ctrl+R) in the Mask menu to remove 
masks from an image.

You can turn off the opening herald by simply renaming or deleting LOGO.TIF from the Picture Publisher 
4.0 directory.

If you save a 24-bit image as an 8-bit image (256 color) the image is converted automatically using the 
current options set in the Palette Color dialog box.

In the TIF Options dialog box in the Save and Save As dialog boxes, the Use LZW Differencing option is 
not implemented.



Selector Tool

The Selector tool selects individual or multiple objects for transforming, grouping, or deleting. To select an 
object, click the Selector tool and click the object you want to select. Press Shift and click multiple objects 
to select multiple objects. Drag a selection rectangle around a group of objects to select all objects totally 
inside the rectangle.

You can deselect an individual object without affecting the other selected objects by pressing Shift and 
clicking the object.

Related Topics
Tool options 



Selector Tool Options

Options in the Selector tool ribbon include:

Layer Buttons
Click a button to move selected objects up or down a layer. Each object resides on a different layer. You 
can see this by overlapping the objects and viewing them. Click the down arrow to move the selection 
down, and click the up arrow to move the selection up. Pressing Shift while clicking a button moves the 
selection to the back or front layer.

Note: When you have multiple objects selected on non-consecutive layers, each object moves one layer 
when you click the button. If you hold Shift and then click, all selected objects move to the top or bottom 
in their relative sequence.

Transform Button
Click to display the Transform tool for the selected objects. Controls in this ribbon allow you to change the 
shape and orientation of the selection.

Group Button
Click to group multiple selected objects together, so they can be moved and selected as one object.

Transparency Slider 
Use this area to set the transparency of the selected objects. Larger numbers create more transparency. 
You can set the amount by dragging the slider, typing a value in the edit box or clicking on the spin 
control.

Merge Mode List Box
This list box contains various editing options. When used in conjunction with editing tools, such as Paint 
or Fill, these options let you combine, or mix, colors using additive or subtractive color theory. You also 
can selectively change an image according to hue, saturation, or lightness and make modifications to the 
red, green, or blue channel of an image.

The Normal option is the default setting in the Merge Mode list box. When Normal is selected, Picture 
Publisher behaves as if Merge Mode is off, and no editing effects are possible.

The Additive option lets you mix colors according to the additive color model. If you paint a red image 
with a blue brush, magenta appears in the image as a result of the additive mixing of red and blue. If you 
paint with a green brush on a red background, you get yellow. To calculate the resultant color, simply add 
the RGB values of the colors together and round down any number over 100 to 100.

An example of additive mixing using green and blue is shown below.

Green R(0) G(100) B(0)
Blue R(0) G(0) B(100)

--------------------------------
Cyan R(0) G(100) B(100)

Adding the R column results in 0, adding the G column results in 100, and adding the B column results in 
100. These values represent a color (cyan) that has the value of R(0), G(100), B(100).

Note: Be sure to adjust all numbers so they do not exceed 100. For example, if the total of the B column 
adds to 140, round the value down to 100.

The Subtractive option lets you mix colors according to the subtractive color model. If you paint on a 
cyan image with a magenta brush, blue appears in the image as a result of the subtractive mixing of cyan 
and magenta. If you paint with a yellow brush on a magenta background, you get red. To calculate the 



resultant color, add the RGB values of the colors together, subtract 100 from the answer, round any 
negative value to 0, and round any number over 100 to 100.

An example of subtractive mixing using cyan and magenta is shown below.

Cyan R(0) G(100) B(100)
Magenta R(100) G(0) B(100)

--------------------------------
R(100) G(100) B(200)

-100 -100 -100
--------------------------------

Blue R(0) G(0) B(100)

Adding the R column results in 100, adding the G column results in 100, and adding the B column results 
in 200. Subtract 100 from the resultant R, G, and B values. These ending values represent a color (blue) 
that has the value of R(0), G(0), B(100). Be sure to adjust all numbers so there are no negative numbers 
and no values over 100. For example, if the B column is -20, round the value to 0; if the B column is 140, 
round the value down to 100.

The If Lighter option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value equal to, or higher than that of the image, the 
color of the editing tool is transferred to the image. If the lightness value is not equal to or less than that of 
the image, no change occurs. For example, if you are painting with white (white has a lightness value of 
100), all of the colors in the image are affected. If you paint with black (black has a lightness value of 0), 
none of colors in the image are affected. Notice that any primary color will paint over any other primary 
color (except white) because all primary colors have the same lightness value (except black, which has 
the lowest lightness value, and white, which has the highest lightness value).

The If Darker option lets you edit an image based on the lightness values of the image and the lightness 
value of the editing tool, or source, used. Lightness refers to the "L," or lightness value, in the HSL color 
model. If the editing tool you are using has a lightness value lower than that of the image, the color of the 
editing tool is transferred to the image. If the lightness value is not lower than the image, no change 
occurs. For example, if you paint with white (white has a lightness value of 100), none of the colors in the 
image are affected. If you are painting with black (black has a lightness value of 0), all of the colors in the 
image are affected.

The Filter option uses a combination of Additive and Multiply to create a filtered effect.

The Multiply option multiplies the value of the image and the editing tool colors.

The Difference option subtracts the value of the editing tool from the value of the existing color to obtain 
a new color.

The Texturize option uses the editing tool as a texture surface on which the image is painted.

The Color option lets you replace the color of an image with the color of the editing tool, or source, used. 
Color is composed of the "H," or hue value, and the "S," or saturation value, in the HSL color model. For 
example, if you are painting with blue (H=240, S=100), all of the painted colors take on the same H and S 
values of blue. This results in a color change; however, the lightness values remain the same.

Note: Hue and saturation values have no affect on black or white. This is because the lightness value of 
black is 0 and the lightness value of white is 100. Any color with the lightness value of 0 is black 
regardless of the hue and saturation values. Any color with the lightness value of 100 is white regardless 
of the hue and saturation values.



The Hue option lets you replace the hue value of an image with the hue value of the editing tool, or 
source, used. For example, if you are painting with green (H=120), all colors (except white and black) that 
are painted become green. Notice that if you paint with red, white, or black, you get the same results. This 
is because all three of these colors have the same hue value (H=0).

The Saturation option lets you replace the saturation value of an image with the saturation value of the 
editing tool, or source, used. For example, if you are painting with any primary color (except white or 
black) onto any other primary color, only white and black are affected; the other colors remain the same. 
This is because all primary colors have the same saturation value (S=100), except for white (S=0) and 
black (S=0). If you are painting with white or black, the colors become grayscale values; remember that 
grayscale images have no saturation.

The Luminance option lets you replace the luminance value of an image with the lightness value of the 
editing tool, or source, used.

The Red option lets you replace the red channel (using the RGB color model) of an image with the value 
of the red channel source. Only the red channel is affected. The results from using the Red Only option 
are the same as if you were to split the RGB channels using the Channels command, make changes to 
the red channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the red 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 0, 0, 
100 (blue). The red value from the brush (0) replaces the red value in the image (100) to create blue.

The Green option lets you replace the green channel (using the RGB color model) of an image with the 
value of the green channel source. Only the green channel is affected. The results from using the Green 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the green channel image, and then combine the channels.

To determine the resultant value of mixing the source and image, replace the image value of the green 
channel with the source value. For example, if you are painting with a cyan brush (RGB value = 0, 100, 
100) over a red image (RGB value = 100, 0, 0), the result is a color that has an RGB value of 100,100, 0 
(yellow). The green value from the brush (100) replaces the green value in the image (0) to create yellow.

The Blue option lets you replace the blue channel (using the RGB color model) of an image with the 
value of the blue channel source. Only the blue channel is affected. The results from using the Blue 
option are the same as if you were to split the RGB channels using the Channels command, make 
changes to the blue channel image, and then combine the channels.

To determine the resulting value of mixing the source and image, replace the image value of the blue 
channel with the source value. For example, if you are painting with a green brush (RGB value = 0, 100, 
0) over a magenta image (RGB value = 100, 0, 100), the result is a color that has an RGB value of 100, 0, 
0 (red). The blue value from the brush (0) replaces the blue value in the image (100) to create red.

Related Topics
Tool information 




