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What is Help?

Microsoft Help for the Macintosh provides onscreen information about how to use your application. 

As you use Help, you can:

    Get more information by clicking a word with a dotted underline.
    Move to a related topic by clicking a topic name (displayed with a solid underline).
    Add a bookmark to a topic you want to refer to again.
    Add your own notes to a Help topic.
    Search for a specific topic by typing or choosing a keyword.
    Move among Help topics using the Contents, Back, History, and Browse buttons.
    Copy and paste Help information into another document.
    Print a Help topic.

TIP: It is helpful to size and move both the Help window and the application window so that Help is 
displayed as you work in the application.

To learn more about Help

    Click Using the Help window or Learning Help basics.



Using the Help window

The following illustration describes a Help window. 

Click any area of the illustration to see a brief description. 
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Learning Help basics

Help information is displayed in a window that you can move, size, close, and scroll through like other 
Macintosh windows. You can size and move Help so that it is available as you work in your application.

NOTE: If you are new to the Macintosh, read the documentation that came with your Macintosh to learn 
all the basic Macintosh skills.

 To size and move the Help window

1      Position the mouse pointer on the Help window's size box , and then drag until the window is 
the size you want.

If you want to enlarge the Help window to full-screen size, click the zoom box . 

2      To move the Help window, position the mouse pointer on the Help window's title bar, and then 
drag to move the window where you want it.

For example, you can position the Help window beside, above, or below the application window.

 To move to a Help topic

    Click a topic name displayed with a solid underline.

You can return to the topic you were viewing by clicking the Back button .

 To switch from Help to the application

    Click within the application window, or click the Help window's close box 
.
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Closing or restarting Help

You can close the Help window or close Help at any time. If you later want to refer to Help, you can start 
Help again.

 To close Help 

    Click the Help window's close box 
.

 To reopen Help

If you are using 
System 6

If you are using 
System 7

From the Window menu of your 
application, choose Help. 

From the Help menu 

, choose Help for the 
application you are using.

When you choose Help, you get specific help for where you are working in your application, or you 
get a table of contents from which you can choose the Help topic you want. 

 To quit Help and the application 

    From the File menu, choose Quit.
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Moving around within Help

Use Help buttons to move among topics and to find specific information on a subject.

 To move among Help topics

To move to Single-click

The main Help contents screen. 

A dialog box listing all the Help 
keywords. You can type or select a 
keyword to search for and go to a 
specific Help topic.

The last topic you viewed. Help moves 
back one topic at a time in the order 
you viewed each topic, until you return 
to the Help contents. 

A list of topics you viewed in the 
sequence you viewed them. You can 
double-click a topic name to display the 
topic. 
You can close the History box by 
clicking its close box . 

The previous or next topic, respectively, 
in a series of related topics. When you 
reach the first or last topic in a series, 
the button is dimmed.
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Searching for a Help topic 

You can have Help search for topics that contain a word or phrase, known as a keyword. For example, if 
you want help on printing a document, type print    in the Search dialog box, and Help will display any 
topic(s) related to printing.

 To search for a Help topic

1      Click the Search button .

2      In the first box, type the word or phrase you want to find.
As you type the word or phrase you want to search for, Help displays possible matches based 
on the portion of the word or phrase you've typed. 

Or, scroll through the list of keywords, and then click to select the word or phrase you want.

3      Choose the Show Topics button, or double-click the topic you want in the upper list box. 

4      In the lower list box, choose the topic you want to view.

5      Choose the Go To button, or double-click the topic you want in the list box.
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Using Help menu commands

You can use Help commands to mark topics for future reference, to add your own notes to topics, to cut 
from Help topics and paste to another document, and to print topics.

 To use File menu commands

To Choose

Open another Help file Open 

Close the current Help file Close

Set printer options before printing a 
topic

Page Setup

Print the current topic Print Topic

Quit the application Quit

 To use Edit menu commands

To Choose

Remove information from an 
annotation to the Clipboard

Cut

Copy the text of the current Help topic 
to the Clipboard, or to copy text from 
one annotation to another 

Copy

Paste the contents of the Clipboard 
into another document or into an 
annotation

Paste

Permanently remove information from 
an annotation

Clear

Add your own comments to a Help 
topic. Help adds a paper clip icon to 
the top of the topic to remind you that 
you have added a note to this topic. 

Annotate

 To use Bookmark menu commands

To Choose

Place a bookmark on the current topic 
and add it to the Bookmark menu

Define 

Remove a bookmark Delete

Go to a marked topic A bookmark name 
from the list or the 
More option (if 
more than nine 
bookmarks are 
defined).
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Copying and pasting Help information

You can copy the text of a Help topic onto the Clipboard. From the Clipboard, you can paste the text into 
another document. You can also paste text from one annotation into another annotation or document.

 To copy the current Help topic onto the Clipboard

    From the Edit menu in Help, choose Copy.
Copied text does not retain formatting, and bitmaps are not copied.

 To copy annotation text 

1      Highlight the annotation text you want to copy.

2      From the Edit menu, choose Copy. 

 To paste the Help information into another document

1      Switch to the application and document where you want to paste the copied text.

2      From the application's Edit menu in the application, choose Paste. 
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Annotating a Help topic

You can add your own comments to a Help topic. When you make an annotation, Help places a paper 
clip icon at the beginning of the topic to remind you that you have added a note to the topic.

 To add an annotation to the current Help topic

1      From the Edit menu in Help, choose Annotate.

2      In the Annotation box, type the text you want.

If you make a mistake, press the DELETE (or BACKSPACE) key, and then type the new text. 
Text automatically wraps as you type. To start a new line, press the RETURN key. 

3      Choose the Save button.

 To display an annotation

1      Go to the topic containing the annotation.

2      Click the paper clip icon.

Or, press the TAB key until the paper clip icon is highlighted, and then press the RETURN key; 
or choose Annotate from the Edit menu.

3      When you finish reading the annotation, choose the OK or Cancel button.

 To delete an annotation

1      Go to the topic containing the annotation you want to delete.

2      Click the paper clip icon.

Or, press the TAB key until the paper clip icon is highlighted, and then press the RETURN key; 
or choose Annotate from the Edit menu.

3      Choose the Delete button. 
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Defining and using bookmarks

Just as you place bookmarks in a book to identify favorite passages, you can place a bookmark in a Help 
topic you refer to frequently. 

When you add a bookmark to a topic, Help adds the topic to the Bookmark menu. Then when you want 
to go to a topic you've marked, you can choose it from the Bookmark menu. 

 To place a bookmark in the current topic

1      From the Bookmark menu, choose Define.

2      Type the name you want or accept the proposed name.

3      Choose the Define button. 

Help adds the name to the Bookmark menu. 

 To go to a marked topic

    From the Bookmark menu, choose the topic or bookmark name you want.
Help displays the topic, scrolled to the position it was in when you last displayed it. 

 To delete a bookmark

1      From the Bookmark menu, choose Delete.

2      Under Delete Bookmark, highlight the bookmark you want to delete.

3      Choose the Delete button. 
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Using keyboard shortcuts

You can use the keyboard to move through a Help topic and to locate and display hot spots.

 To use keyboard shortcuts

To Press

Move sequentially through hot spots TAB

Move backward through hot spots SHIFT+TAB

Display a hot spot (definition, more 
information, or a related topic)

RETURN

Move to the beginning of a topic HOME

Move to the end of a topic END

Move down one page PAGE DOWN

Move up one page PAGE UP
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Setting page options

Before you print a Help topic, you can set or change the paper size, page orientation, and page margins. 

 To change page setup options

1      From the File menu, choose Page Setup.

2      In the Page Setup dialog box, choose the options you want.

3      Choose the OK button.

Printing a Help topic



Printing a Help topic

You can print the Help topic currently displayed. Help prints the entire text of the topic.

 To print the current topic

    From the File menu, choose Print Topic.
To cancel printing, press COMMAND+PERIOD.
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Annotation

A note you write, which Help then attaches to the current topic.



Hot spot

An area within a Help topic that displays a definition or more information, or moves to another topic. 

NOTE: When you move the mouse pointer over a hot spot, it changes to a hand.

To display Click

A definition

Another topic 

Descriptive information about 
an illustration

An element within 
the illustration



Formatting

The appearance of characters, paragraphs, and pages in a document. For example, format includes 
font, font size, style (bold, italic, and so on), and color. Paragraph format includes indents and line 
spacing, and page format includes margins.



Highlight

Highlighted text or options typically are displayed white against a black background on a black-and-white 
Macintosh. The highlight indicates where the next action will occur.

To highlight text, double-click a word or drag the mouse pointer across text. To highlight an option in a 
dialog box, click it. 



Margins

The distance from the edges of the page to where the text begins on the left, right, top, and bottom of the 
page.



Bookmark

Marks a topic by placing it in a list on the Bookmark menu. 

To quickly display a marked topic, choose the topic name from the Bookmark menu. If more than nine 
bookmarks are defined, choose More from the Bookmark menu, and then choose a topic name in the 
More dialog box.



Clipboard

A temporary storage area for information you cut or copy. You can paste the contents of the Clipboard 
into another document.



Copy

Duplicates highlighted information and places it on the Clipboard. You can paste information copied to 
the Clipboard into another document. 



Paste

Places the contents of the Clipboard into a document.



Title bar

Drag to move the Help window.



Close box

The box  in the upper-left corner of the Help window. Click the close box to close the Help window.



Zoom box

Click to enlarge the window to full-screen size or restore it to its previous size.



Document name

Displays the name of the current Help document.



Scroll arrow

Use the appropriate scroll arrow to move vertically or horizontally in a Help topic.



Horizontal scroll bar

Use to scroll horizontally through a Help topic.



Vertical scroll bar

Use to scroll vertically through a Help topic.



Scroll box

Drag the scroll box to move through larger sections of a Help topic.



Contents button

Use to return to the main Help contents screen.



Search button

Use to search for a Help topic by a keyword or key phrase.



Back button

Use to display the topic you previously viewed.



History button

Use to display a list of up to the last 40 topics viewed, in the order you viewed them. 

You can display a topic in the History list by double-clicking the topic name. 

You can close the History box by clicking its close box . 



Browse button

Use to display the previous topic in a sequence of Help topics.



Browse button

Use to display the next topic in a sequence of Help topics.



Size box

Drag to size the Help window.






