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Introduction
The Swift Greeting Card Magic program allows you to create an unlimited amount of greeting cards and certificates for all occasions.  
You can use the clip art included with the program or your own clip art or fonts to make your own specialized cards or certificates.  
You can create generic card templates that can be personalized for different occasions or people.  You can create a database of events 
that will prompt you to create cards at the correct time of the year.  And you can do all this quickly and easily.

Useful terms
The following are some terms that are used repeatedly in the manual:
Current Card
The current card is the card that is currently showing.  If more than one card is showing, the current card is the one with the 
highlighted title bar.
Object
Every card is made up of objects.  Objects can be text objects or picture objects.  Objects are placed on the card to make it look like 
you want.
Text Object
A text object is a block of text that can use different fonts, shadowing, and justification to give the effect that you want.
Picture Object
A picture object contains a picture that can be resized.
Current Object
The current object is the object that is highlighted with a box around it.
Panel
Each card has one or more panels, each of which contains objects.  A panel corresponds to a single page of the card after it has been 
folded.  You can view more than one panel at once.  The border between different panels is shown with a gray line.  The printable area 
of a panel (based on the selected printer) is the area of the panel inside any light blue lines.
Current Panel
The current panel is the panel that the current object is on.
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Installing the program
In the Program Manager, select “Run” from the File menu.  Type “X:INSTALL”, where “X” is the letter of the drive that you are 
installing from.  Follow the instructions on the screen to install the program.  After installing the program, read the program’s 
README file (if one exists) to find any changes that have been made to the program since the manual was printed.
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Starting the program
Double-click on the Swift Greeting Card Magic icon.  After an introductory screen, you will see the Program Window.  To exit the 
introductory screen immediately, press the Esc key.

6



Program Window
The Program Window consists of a menu bar, two button bars, a main window, and a status line with two parts.  The menu bar allows 
you to select menu items (detailed in the following sections).  The button bars let you execute commands by pressing a button.  The 
main window is the background on which other windows will appear.  The status line shows the currently selected panel of the card 
and help text for each of the menu items and buttons.

Menu Bar
The menu bar lets you choose commands to help you create your card.  The individual menus and commands are discussed in later 
sections of the manual.

Top button bar (commands)
The top button bar has buttons that correspond to menu commands.  When you click on a button, it performs the same command that 
the related menu item would have done.  Currently disabled buttons are colored all in gray, and cannot be pressed.  If you need to 
know what a particular button does, move the mouse over it.  After a slight wait, a yellow box will pop up over the button that 
describes it.  This information will also appear on the status line.

Bottom button bar (panel views)
Each button on the bottom button bar allows you to see the card in a different way.  The picture on each button corresponds to a panel 
or panels of the card that you can view and edit.  When you click on a button the program will switch to the button's view of the card.  
You can see help for each button just like you did for the top button bar.
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Main window
This is where you edit the card.  You can select an object by clicking on it with the left mouse button.  If more than one object is under 
the mouse cursor when you click, the top object will be selected.  You can move an object around on the card by dragging it with the 
left mouse button.  You can resize an object by dragging the borders of the object's highlight box.  The mouse cursor will change to a 
two-headed arrow to show when it is in the correct position to resize.  Note that text objects can only be resized to make them wider or 
thinner, not shorter or taller.  The height of a text object is based on the width of the object and how the text wraps within that width.  
You can change the properties of a text object by clicking with the right mouse button on it.

Status line
The status line shows two pieces of information:  The name of the current panel (in the left part) and help information (in the right 
part).
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Help
You can get help at any time by pressing the F1 key.  You can also press the help button (the one with the red question mark) while in 
the main window, or press the help button (the one with the blue question mark) while in a dialog box.  Pressing F1 while a menu item 
is highlighted will give you help on that menu item.  Pressing F1 while not in a menu or pressing the button with the red question 
mark will show you the help's table of contents.  Pressing F1 while in a dialog box or pressing a help button with a blue question mark 
will give you help on the current dialog box.
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File Menu
The File Menu has choices for creating, opening, saving, and printing cards, and leaving the program.

New
Creates a new card.  You will be asked if you want to use a template (an existing card) to base your card on, or create a completely 
new card.  If you decide to use a template,  the Open Template dialog will allow you to choose an occasion and description for the 
card so that you will have something to start with.  You can personalize the resulting card and change it as you wish.

Open
Opens an existing card.  You will be prompted to choose the card to open from the Open Card dialog box.

Close
Closes the current card.  If the current card has not been saved, you will be prompted to save it. 

Save
Saves the current card.  If this is the first time you have saved the current card, you will be prompted to give it a name. 

Save As
Saves the current card under a different name.  You would use this to save a modified card but still keep the original card. 
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Save As Template
Saves the current card as a template that can be used to create other cards.  The advantage of saving a card as a template as opposed to 
just saving it is that templates are grouped by occasion and description, so that users can tell what the card is without opening it.  
When you save a card this way you first save it as a normal card file (press the Cancel button in the Save Card dialog box if you want 
to save the card as a template only), and then you assign the card to an occasion and give it a description.

Print
Prints the current card.  As the card is printing, you may receive instructions to flip the card over or turn it 180 degrees.  These steps 
are necessary to make the card look correct after it is printed and folded.  You will probably need to practice with each type of card to 
make it look correct. 

Print Setup
Changes the printer that you are using or sets up the current printer.

Exit
Exits the program.  You will be prompted to save any open, unsaved cards.
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Edit Menu
The Edit Menu has choices for manipulating objects with the clipboard.

Cut
Deletes the current object, but saves it in the clipboard so that it can be pasted back into a card.

Copy
Copies the current object to the clipboard so that it can be pasted into a card.

Paste
Copies the object in the clipboard into the current card. The object will appear as a box that you can move around on the screen.  
When the mouse cursor shows that you can place the object (the mouse cursor is not a circle with a line through it), click the left 
mouse button to place the object.

Delete
Deletes the current object.
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View Menu
The View Menu changes the view of the current card by zooming in to it or zooming out from it, or by changing the current object.

Zoom Out
Zooms the view out from the current card.  The closest view is 400%, and zooming out will change the view through the range 200%, 
150%, 100%, 75%, 67%, 50%, 33%, and finally 25%.

Zoom In
Zooms the view in to the current card.  The farthest view is 25%, and zooming in will change the view through the range 33%, 50%, 
67%, 75%, 100%, 150%, 200%, and finally 400%.

Previous Object
Sets the current object to be the previous object.  The previous object is defined as the object in the current panel that is underneath the 
current object.  If there is more than one panel on the screen and the current object is at the bottom, the current object will be set to the 
top object in another panel.

Next Object
Sets the current object to be the next object.  The next object is defined as the object in the current panel that is on top of the current 
object.  If there is more than one panel on the screen and the current object is at the top, the current object will be set to the bottom 
object in another panel.
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Object Menu
The Object Menu changes the current object, or adds new objects to the card.

Bring To Front
Puts the current object on top of all of the other objects on the current panel.

Send To Back
Puts the current object under all of the other objects on the current panel.

Up One Level
Exchanges the current object with the object directly above it. 

Down One Level
Exchanges the current object with the object directly below it.

Center Horizontally
Centers the current object horizontally on the object's panel.

Center Vertically
Centers the current object vertically on the object's panel.

Restore To Original Size
If the current object is a picture object, will resize the object so that it is the same size as when it was originally created.

Edit Text Object Properties
If the current object is a text object, will allow you to change the properties of the object (text, shadow, font, justification).
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Add Text Object
Creates a new text object.  The Text Object dialog box will come up, and you can set the object's properties (text, shadow, font, 
justification).  When you press the OK button, the object will appear as a box that you can move around on the screen.  When the 
mouse cursor shows that you can place the object (the mouse cursor is not a circle with a line through it), click the left mouse button to 
place the object.

Add Picture Object
Creates a new picture object.  The Add Picture Object dialog box will come up, and you can choose a picture to add.  When you press 
the OK button, the object will appear as a box that you can move around on the screen.  When the mouse cursor shows that you can 
place the object (the mouse cursor is not a circle with a line through it), click the left mouse button to place the object.
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Personalize
The Personalize menu item will personalize the current card by asking you to enter specific information in places where general 
information was entered in the card.  When a card is created for a general purpose (such as a birthday), you may want to use the card 
for many different people.  To do this, you create a text object in a way that tells the computer to prompt for specific information.  For 
example, instead of creating a text object that says "Happy Birthday, Mel" you would create one that says "Happy Birthday, [name]".  
When you choose the Personalize menu item, the program looks for all text objects that contain words in brackets, and prompts you to 
enter information corresponding to the words inside the brackets.  In this example, the computer would prompt you to enter a value for 
"[name]".  If you typed in "Martha", the card's text would change to read "Happy Birthday, Martha".  Many of the template cards use 
this feature to speed up card creation.
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Events Menu
The Events Menu takes you to the part of the program that keeps track of birthdays, anniversaries, and holidays so that you won't 
forget to send a card.  Once an event is entered into the database, every time you start up the program you will be warned if you need 
to create and send a card.

Database
Takes you to the database of events.  Each event has a particular day, description, and warning period associated with it.  If you start 
up the program within the warning period's number of days before the event, you will be told about the upcoming event by its 
description.

Messages
Shows you the current events which you have been warned about.  You can deal with each message by deleting it or moving it forward 
one year (hopefully, you've created the card for the event that it warned you about!).
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Window Menu
The Window Menu arranges the program's windows on the screen.

Cascade
Arranges the windows in a cascading  (overlapped and slightly offset) format.

Tile
Arranges the windows in a tiled  (non-overlapped) format.

Arrange Icons
Arranges the icons of any minimized windows at the bottom of the screen.

Minimize All
Minimizes all windows.
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Help Menu
The Help Menu accesses the program’s on-line help.

Contents
Takes you to the help’s table of contents.

Topic Search
Allows you to look up entries in the help alphabetically by name.

How To Use Help
Shows you help on the Windows help system.

About
Gives copyright and author information on the program.
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WARRANTY

COSMI makes no warranty of any kind, express or implied, including without limitation, any warranties of merchantability and/or 
fitness for a particular purpose.  COSMI shall not be liable for any damages, whether direct, indirect, special or consequential arising 

from a failure of this program to operate in the manner desired by the user.  COSMI shall not be liable for any damage to data or 
property which may be caused directly or indirectly by use of this program.

The disk on which this software is recorded will be replaced within 90 days of purchase if found to be defective in material or 
workmanship.  This shall constitute the sole remedy of purchaser and the sole liability of COSMI, Inc.

IN NO EVENT WILL COSMI BE LIABLE FOR ANY DAMAGES, INCLUDING ANY LOST PROFITS, LOST SAVINGS OR 
OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF YOUR USE OR INABILITY TO USE THE 

PROGRAM, OR FOR ANY CLAIM BY ANY OTHER  PARTY.

The License Agreement and Warranty shall be construed, interpreted and governed by the laws of the state of California.

COSMI, Inc.
2600 Homestead Place

Rancho Dominguez, CA  90220-5610
(310) 833-2000
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