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Chapter 1

MWM

1.1 MWM.guide/Contenuti

+--- - - - - ---+--- - - - - ---+

| ! Benvenuto nel primo generatore di file HTML facile-da-usare! |

+--- - - - - ---+--- - - - - ---+

M W M

-->* Magic WWW (World-Wide Web) files Maker *<--
_______________________________________

|
|
|

Versione 2.02
___________________________________

| |
| from an idea of Maurizio Fabiani |
| developed by Massimo Baglione |
|___________________________________|

Di cosa si tratta ?
La finestra principale --> Tasti speciali
La finestra per la singola linea
La finestra di aiuto
La finestra ’’ What is ? ’’
Il menu

Cosa puo’ fare MWM ? Informazioni generali Ringraziamenti Storia di MWM

Addendum

1.2 MWM.guide/Di cosa si tratta?

DI COSA SI TRATTA ?
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Un giorno il mio amico Maurizio mi chiese: "Hey Max, pensi sia possibile
scrivere un programma per la creazione di file in formato HTML che dia la
possibilita’ all’ utente di caricare normali file ASCII e trasformarli in
HTML selezionando parti di testo utilizzando il mouse ?"

Gli feci capire che non ero in grado di operare miracoli, ma lui insistette.

Bene, ora ci sono quasi riuscito.

MWM infatti consente di caricare un normale file di testo e tramite il mouse
si puo’ applicare alle righe o alle singole parole selezionate le immagini, i
testi e tutto quello che consente il formato HTML.

L’ interfaccia grafica e’ composta essenzialmente da :

- Finestra principale, che mostrera’ il normale file di testo caricato.
Se al testo e’ stata applicata qualche particolare azione, allora verra’
evidenziato con un colore diverso dal resto del testo.
Come molti programmi grafici e word processor, questa finestra contiene
delle piccole immagini associate a delle azioni.

- Finestra per editare una singola linea di testo ed inserire piu’ di un
oggetto nella stessa riga.

- Finestra delle etichette, che mostrera’ le etichette contenute in un
file HTML da linkare. (vedere in seguito)

- Finestra di aiuto, che informa l’ utente su tutto cio’ che sta’
facendo o succedendo.
MWM mette a disposizione tre livelli di informazioni:

- None, ovvero nulla se non l’essenziale.
- Medium, descrizione sommaria dell’ oggetto selezionato.
- High, informazione dettagliata.

- Finestra "What is?", che associa ad ogni riga del testo una piccola
stringa per poter riconoscere "al volo" ogni oggetto.

1.3 MWM.guide/La finestra principale

LA FINESTRA PRINCIPALE.

Una volta caricato il file di testo, lo si potra’ vedere chiaramente in una
delle finestre: la finestra principale.

Con il tasto sinistro del mouse si seleziona una porzione di testo e con
uno dei gadget degli strumenti gli si puo’ assegnare un’ azione che puo’
essere una immagine, un riferimento ad altro testo, una lista e tutte
quelle belle cosette che consente il formato HTML.

Se avete la necessita’ di applicare azioni a singole parole all’ interno di
una riga e’ sufficiente selezionare tale riga con un doppio click.

Una piccola finestra si aprira’ con l’intera riga del testo messa a vostra
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disposizione: la finestra per la singola linea.

Il motivo per il quale non ho implementato tale possibilita’ direttamente nella
finestra principale e’ dovuto al fatto che ho voluto semplificare al massimo
l’ uso del programma e che comunque il tipo di gestione del testo di MWM
renderebbe troppo lenta la visualizzazione in caso di scroll.

Applicando diverse azioni al testo si creano degli oggetti che saranno
visualizzati con colori diversi per poterli distinguere con facilita’.

L’ oggetto viene numerato in base all’ ordine di creazione e selezionandolo
si avra’ la possibilita’ di controllarne i dati essenziali nella finestra di
aiuto.

Partendo dal primo gadget a sinistra troviamo:

TEXT IMAGE LIST FORM MORE HEAD VIEW PREFS

1.4 MWM.guide/Primo gadget TEXT

TEXT gadget

Si intende definire per le linee selezionate un particolare tipo di
testo.

MWM aprira’ una finestra con diversi gadget:

- "Type" gadget:

- Plain; il testo selezionato rimarra’ tale nel file HTML finale..

- Link into this document;
E’ un link ad una etichetta gia’ creata all’ interno del
documento corrente.

- Link to another document;
In questo caso programmi tipo Mosaic evidenzieranno questa
parte di testo e, se l’ utente selezionera’ col mouse questa
porzione, allora verra’ chiamato il nuovo testo definito da
questa azione.

- Link to a site.
E’ un link ad un sito in cui si desidera entrare.

- Preformatted;
Programmi tipo Mosaic sono "obbligati" a formattare il testo
che devono visualizzare seguendo gli standard in vigore.
Con tale azione si intende specificare che tutto il testo
selezionato non dovra’ assolutamente essere influenzato da
tale formattazione.
E’ molto utile per quei testi che perderebbero di significato
se venisse modificata l’ impaginazione originale, ad esempio i
listati dei programmi.
Il testo selezionato sara’ racchiuso tra <PRE> e </PRE> e verra’
visualizzato con un font fixed width (typewriter) dal browser.
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- Address.
Con questa azione MWM inserira’ le linee selezionate nell’ area
dedicata alle informazioni dell’ autore del documento, ovvero fara’
parte del <ADDRESS> del documento HTML.
Programmi tipo Mosaic evidenzieranno questo testo.

- Paragraph.
Il testo selezionato sara’ racchiuso tra <P> e </P>, ovvero faranno
parte di un paragrafo.
Il tipo di allineamento possibile e’:

DEFAULT, LEFT, CENTER, RIGHT, JUSTIFY.

- "Link" gadget:

Attivo per "link to another document", permette di scegliere il file
che dovra’ essere linkato.

- "Label" gadget:

Attivo per "link into this document" e "link to another document",
permette di scegliere la label (etichetta) nel file selezionato che
dovra’ essere linkata.

- "URI" gadget:

Attivo per "link to a site";
MWM vi dara’ i seguenti tipi di URI:

file://localhost/
http://
ftp://
mailto:
news:
gopher:
telnet:

- "Site" gadget:

Attivo per "link to a site";
MWM aprira’ un requester per sapere dove dovra’ prendere il nome del
sito. Si puo’ decidere tra:

- Selected line
Il nome del sito e’ rappresentato dalla prima linea selezionata.
Se le linee selezionate sono piu’ di una, allora MWM le ridurra’
automaticamente a una e prendera’ da essa il nome del sito.

- Keyboard
Il nome del sito dovra’ essere inserito manualmente.

- PATH:file
Il nome del sito e’ definito in un file apposito.
E’ necessario definire una lista di siti prima di usare MWM.
La lista DEVE essere simile a questa:
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www.vol.it
agnus.livewire.com
www.lycos.com
www.yahoo.com
...

Se non diversamente specificato, MWM cerchera’ la lista dei
siti nel file "PROGDIR:MWM.sites".
E’ possibile specificare una diversa locazione del suddetto
file usando la funzione del gadget "PREFS" alla voce
"Sites list".

- "Markup" gadget:

Aggiunge un Markup al testo corrente.
Si puo’ scegliere fra:

- Citation (Typically in italic). (CITE)
- Emphasis (EM)
- Strong emphasis (STRONG)
- Code (CODE)

Looks like preformatted text,
for example: 1 + 1 = 2.

- Author (AU)
For an author of a book, etc.

- Person (PERSON)
For a generic person name.

- Sequence of chars. (SAMP)
- Keyboarded text. (KBD)
- Variable name. (VAR)
- Definition. (DFN)
- Short quote. (Q)
- Acronyms. (ACRONYM)
- Abbreviations. (ABBREV)
- Inserted text. (INS)
- Deleted text. (DEL)
- Bold text. (B)
- Italic text. (I)
- Typewriter text. (TT)
- Underscored text. (U)
- "Lined" text. (S)
- Big text. (BIG)
- Small text. (SMALL)
- Subscripted (SUB)
- Superscripted (SUP)
- Nothing (to clear current markup)

- "Font" gadget:

Con questa funzione e’ possibile cambiare le dimensioni del font per
il testo attualmente selezionato.

Le possibilita’ sono:

- <H1> Font larghissimo, in neretto.
- <H2> Font largo, in neretto.
- <H3> Font largo, in corsivo.
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- <H4> Font normale, in neretto.
- <H5> Font normale, in corsivo.
- <H6> Font piccolo.

C’e’ da dire che queste definizioni sono solo un’ indicazione, dipende
da come il browser e il suo sistema e’ settato, percui il testo puo’
apparire diverso in ciascun sistema.

Per default, MWM imposta a 5 (H5) tale valore che puo’ essere
modificato selezionando il gadget "PREFS" alla voce "HTML defaults".

- "Align" gadget:

Questo gadget e’ usato per specificare l’allineamento per l’heading.

- Left;
- Center;
- Right;
- Justify;

Se si rende necessario ritoccare un oggetto di tipo TESTO, e’ sufficiente
clickare sul gadget "TEXT" quando il suddetto oggetto e’ selezionato
(oppure un doppio click con il tasto sinistro del mouse su di esso).

1.5 MWM.guide/Secondo gadget IMAGE

IMAGE gadget

Con questa azione si intende _SOSTITUIRE_ il testo selezionato con una
immagine.

MWM aprira’ una finestra con i seguenti gadget:

- "Choose" gadget:

Un requester vi permettera’ di selezionare l’immagine desiderata.

- "Alt" gadget:

Qui e’ possibile definire il testo alternativo (ALT) per la
immagine selezionata.

- "Type" gadget:

Con questo gadget si definisce il tipo di immagine:

- Simple; semplice.
- Map; di tipo mappa.
- Link to current; (vedere TEXT Gadget, dietro)
- Link to another; (vedere TEXT Gadget, dietro)
- Link to a site; (vedere TEXT Gadget, dietro)

- "Align" gadget:

Qui si puo’ definire l’allineamneto dell’immagine con l’eventuale
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testo:

- TOP
- MIDDLE
- BOTTOM

- "Link" gadget: (vedere TEXT Gadget, dietro)
- "Label" gadget: (vedere TEXT Gadget, dietro)
- "URI" gadget: (vedere TEXT Gadget, dietro)
- "Site" gadget: (vedere TEXT Gadget, dietro)

Se si rende necessario ritoccare un oggetto di tipo IMMAGINE, e’
sufficiente clickare sul gadget "IMAGE" quando il suddetto oggetto e’
selezionato (oppure un doppio click con il tasto sinistro del mouse
su di esso).

1.6 MWM.guide/Terzo gadget LIST

LIST gadget

Questa azione vi permette di trasformare il testo selezionato in una lista.

MWM aprira’ una finestra con i seguenti gadget:

- "Type" gadget:

- Semplice (unnumbered), del tipo:

* fa caldo

* fa freddo

* piove

- Numerata (numbered), del tipo:

1- Non bere se devi guidare
2- Non guidare se hai bevuto
3- Il cappuccino e’ piu’ buono della birra
4- Il latte e’ finito, datemi una birra!

- Definita (definition), del tipo:

Colori

rosso
verde
blu

Planetario

Mercurio
Marte
Terra
Giove
...
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- "Add image" and "Add text" gadgets:

Questa azione permette di applicare un oggetto di tipo "TESTO"
o di tipo "IMMAGINE" all’ elemento della lista visualizzato nel gadget
in basso.

- "Prev" and "Next" gadgets:

Questi due gadget permettono di muoversi linea per line all’interno
della lista per potervi applicare un testo o una immagine.

Se si rende necessario ritoccare un oggetto di tipo LISTA, e’ sufficiente
clickare sul gadget "LIST" quando il suddetto oggetto e’ selezionato
(oppure un doppio click con il tasto sinistro del mouse su di esso).

1.7 MWM.guide/Quarto gadget FORM

FORM gadget

Questa azione e’ composta da due passi:

nel primo si dovra’ definire la parte di testo che fara’ parte del form.
MWM aprira’ una finestra con i seguenti gadget:

- "Method" gadget:

- GET
- POST

- "Action" gadget:

Con questo gadget si puo’ specificare l’ azione (ACTION) del form, che
e’ una specifica URL. L’ azione sara’ del tipo: "http://x/y/sample".

Dopo questo primo passo noterete che il testo cambia colore ma e’ ancora
possibile (a differenza di tutti gli altri tipi di oggetti) selezionare una
o piu’ linee all’ interno del blocco del form.

Nel secondo passo sara’ possibile definire i vari componenti del form.
La stessa azione fara’ aprire a MWM una finestra con i seguenti gadget:

- "Type" gadget:

- Plain text; e’ un semplice testo
Il testo selezionato sara’ interpretato come un semplice testo,
utile per inserire descrizioni agli oggetti piu’ importanti.

- INPUT;

- List of INPUTs; e’ una lista di INPUT:
Non funzionante se si sta lavorando con la finestra per la
singola linea.
Tutti gli INPUT da definire saranno inclusi in una lista.

- "Input" gadget:
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Questo gadget contiene i seguenti tipi di INPUT:

Text, Password, Checkbox, Radio, Range, Scribble,
File, Hidden, Submit, Image, Reset e Textarea.

Scegliendo il numero 4 (RADIO), MWM controllera’ se il gadget
"Same RADIO group" e’ selezionato o meno.
Se lo e’, allora il gruppo di INPUT del tipo RADIO che
si stanno creando avranno lo stesso campo e quindi, una volta creato
il file HTML, Mosaic (o chi per lui) costruira’ i gadget di tipo
RADIO accertandosi che uno e solo uno possa essere selezionato dallo
user.

- "Name" gadget:

Con questo si puo’ specificare il campo NAME di un INPUT.

- "Value" gadget:

COn questo si specifica il valore di default, o quello iniziale, del
campo VALUE di un INPUT.

- "Width" e "Max" gadgets:

Con questi gadget si definiscono la dimensione in caratteri e il
massimo numero di caratteri permessi per gli input di tipo TEXT e
PASSWORD.

- "From", "To", "Value" gadgets:

Se si sta creando un input di tipo RANGE, tutti questi tre gadget
saranno abilitati per definire i rispettivi campi dell’ input.

- "Rows" e "Cols" gadgets:

Con questi gadget le dimensioni in caratteri per l’elemento TEXTAREA

- "Accept" gadget:

Usato per definire il campo ACCEPT dell’ input di tipo FILE.

- "Source" gadget:

Usato per definire il campo SRC per tutti gli input che lo richiedano.

- "Next" e "prev" gadgets:

Disattivati se il gadget "Same Radio group" non e’ selezionato.
Altrimenti utili per definire i campi VALUE e SELECTED per ogni
elemento del gruppo di gadget del tipo RADIO.

Ogni elemento del form (esclusi quelli inseriti in una lista) sara’ salvato
nel file HTML prefissato con la stringa <P> che serve a separare il testo
riga per riga.

Per inserire due o piu’ elementi del form nella stessa linea e’ possibile
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fare un doppio click su una linea ed editarla con la finestra per la
singola linea.

Se si rende necessario ritoccare un oggetto di tipo FORM, e’ sufficiente
clickare sul gadget "FORM" quando il suddetto oggetto e’ selezionato.

1.8 MWM.guide/Quinto gadget MORE

MORE gadget

MWM considerera’ la prima linea selezionata chiedendo cosa
dovra’ farci. Le possibilita’ sono:

- Insert label here (<ID>) for hyperlinks;
- Insert comment here (<!-- -->);
- Insert empty line. (<P>)
- Insert horizontal graphic line (<HR>).

1.9 MWM.guide/Sesto gadget HEAD

HEAD gadget

Con questa azione si intende specificare che la parte di testo selezionata
e’ l’ HEAD (la testa) del file HTML.
Una finestra verra’ aperta per definire l’HEAD.

1.10 MWM.guide/Ottavo gadget VIEW

VIEW gadget

Questa azione vi permette di chiamare un programma tipo Mosaic per vedere
in qualunque momento il lavoro finale.
Il programma da chiamare e’ definito usando il gadget
"PREFS" alla voce "Browser"

E’ possibile aprire MWM ed il vostro browser preferito usando lo stesso
schermo pubblico.

1.11 MWM.guide/Nono gadget PREFS

PREFS gadget

Questa azione mostrera’ la seguente lista di possibilita’:

- Texts path
Per definire un path comune a tutti i testi.
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- Images path
Per definire un path comune a tutte le immagini.

- Work dir
Per definire la directory di lavoro (ex: RAM:T).

- Browser
Per scegliere il programma che dovra’ effettuare il preview.

- Sites list
Per scegliere il file contenente la lista dei siti.

- Screen prefs

Si puo’ scegliere se aprire lo schermo pubblico di MWM nei modi:

Default | Named | Owner

Se si sceglie il modo "Default", MWM aprira’ tutte le sue
finestre sullo schermo pubblico di default (Workbench).

Se si sceglie il modo "Named", MWM vi chiedera’ con un
requester il nome dello schermo pubblico su cui aprire le
finestre.

Se si sceglie il modo "Owner", MWM vi chiedera’ con un
requester il tipo di risoluzione del suo schermo personale,
che sara’ ugualmente pubblico ma con l’appropriata palette di
colori.

- Select new font
Cambia il font della finestra principale.

- Log Window
Permette di personalizzare la finestra di aiuto.

- Log Level
MWM mette a disposizione tre livelli di informazioni:

- None, ovvero nulla se non l’essenziale.
- Medium, descrizione sommaria dell’ oggetto selezionato.
- High, informazione dettagliata.

- HTML defaults
Per personalizzare alcuni valori standard del formato HTML
generato da MWM.

In questa versione, questa azione vi dara’ il seguente
requester:

- Headings size;

Quando viene caricato un normale file di testo ASCII, MWM
assegna ad ogni linea un valore pari a zero (default)
percui, se c’e’ bisogno di cambiare il valore di default
per gli headings, MWM salvera’ il valore selezionato al
posto di zero.
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Per cambiare questo valore standard e’ necessario
scegliere uno fra

H1 H2 H3 H4 H5 H6

nella listview.

1.12 MWM.guide/La finestra per la singola linea

LA FINESTRA PER LA SINGOLA LINEA.

Selezionando con un doppio click una qualsiasi linea del testo nella finestra
principale, si aprira’ la finestra per la singola linea che permettera’
all’ utente di MWM di editare piu’ in dettaglio il testo.

1.13 MWM.guide/La finestra di aiuto

LA FINESTRA DI AIUTO.

Selezionando un oggetto nella finestra principale si notano dei dati che
vengono visualizzati in un’ altra finestra: la finestra di aiuto.

Questa finestra vi dara’ tutte le informazioni contenute negli oggetti:
il numero, il tipo, il path di immagini e testi, le label a cui punta
ed altro ancora.

Il livello di tali informazioni si puo’ definire selezionando il gadget
"PREFS", scegliendo la voce "Log level".

1.14 MWM.guide/La finestra ” What is? ”

LA FINESTRA "What Is ?".

Questa finestra e’ un supplemento alla finestra di aiuto e si trova alla ←↩
immediata
sinistra della finestra principale.

La funzione di questa finestra e’ essenzialmente quella di dare un immediato ←↩
commento
a tutti gli oggetti creati collaborando con la differenziazione dei colori del
testo per ognuno di essi.

Esempio:

+-----------++----------------------------------+
| What is? || MWM Edit Window |
+-----------++----------------------------------+
| ......... || Uninitialized text |
| txt Hn X || Initialized Text |
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| txt->in || Text linked to current document |
| txt->out || Text linked to another document |
| txt->site || Text linked to a site |
| img simple|| Simple image |
| img->in || Image linked to current document |
| img->out || Image linked to another document |
| img->site || Image linked to a site |
| img map || Map image |
| head || Text of the <HEAD> block |
| Form type || Text of the <FORM> block |
| preformat || Preformatted text <PRE> |
| address || Text of the <ADDRESS> block |
| paragraph || Paragraph text <P> |
| Multi obj || Text including more objects |
| Label || There is a label <ID> |
| Comment || There is a comment <!-- ... --> |
| Lab & Com || There is both label and comment |
| break || There is a break <BR> |
| line || There is an horizontal rule <HR> |
+-----------++----------------------------------+

Descrizione:

Hn = Heading da <H1> a <H6>, <HD> per il valore di default.

X = Allineamento: L = LEFT, C = CENTER, R = RIGHT, J = JUSTIFY

type = Form method GET o POST

Con il tasto del e’ possibile aprire o chiudere questa finestra.

1.15 MWM.guide/Il menu

IL MENU

Nella finestra principale e’ possibile usare un menu con le seguenti voci:

Project Edit Special Action

Load plain Text Cut Go to label Text
Save to HTML Copy Mark location 1 Image
Load project Paste Mark location 2 List
Save project Search new Mark location 3 Form
Delete all Search again Jump to mark 1 More
Help keys Adjust sel lines Jump to mark 2 Head
About Jump to mark 3 Preview
Quit Prefs

1.16 MWM.guide/Project->Load text

Delete all
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Cancella tutto il lavoro o solo tutti gli oggetti.
(Usare con cautela!)

1.17 MWM.guide/Project->Load text

Load text

Permette di caricare un normale file di testo ASCII.

Se un testo e’ gia’ stato caricato, MWM vi chiedera’ se cancellare il
precedente o accodare il nuovo al vecchio.

- Replace
- Insert to the beginning;
- Insert to the end;
- Insert after the first selected line.

1.18 MWM.guide/Project->keys

Tasti speciali

Se il testo e’ piu’ lungo o piu’ largo della capacita’ della finestra, lo si
puo’ scrollare sia con i gadget della finestra, sia con i tasti frecce.

I tasti frecce, da soli, scrollano di una linea o di una colonna. Se
sciftati, scrollano una pagina su / giu’ / destra / sinistra. Premendo il
tasto alt con i tasti frecce il testo si posizionera’ a inizio / fine oppure
tutto a sinistra / destra. Con il tasto control, invece, le frecce
serviranno per dimensionare la finestra principale.

Il tasto help apre o chiude la finestra di Log.

Il tasto del apre o chiude la finestra "What is?".

Il tasto enter permette di editare la prima linea selezionata.

Il tasto return inserisce una linea vuota nel testo.

1.19 MWM.guide/Project->Save HTML

Save HTML

Permette di salvare il lavoro creando il desiderato file HTML.
MWM aprira’ una finestra con cui sara’ possibile definire il campo
BACKGROUND del BODY e il titolo.
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1.20 MWM.guide/Project->Load saved work

Load saved work

Carica un lavoro precedentemente salvato.

1.21 MWM.guide/Project->Save work

Save work

Salva l’ intero lavoro in un file in modo da poterlo richiamare e ←↩
continuare

a lavorare dal punto in cui lo si era lasciato.

1.22 MWM.guide/Project->About

About

Informazioni riguardanti l’ ideatore ed il creatore di MWM.

1.23 MWM.guide/Project->Quit

Quit

Fine del lavoro.
MWM salvera’ le preferences e la posizione/dimensione della
finestra principale nel file "MWM.prefs" in ENV: ed in ENVARC:.

1.24 MWM.guide/Edit->Cut

Cut

Questa azione permette di eliminare completamente le linee selezionate
oppure solamente le informazioni create per esse.
Se le si eliminano completamente, allora il testo cancellato verra’
copiato in clipboard.

1.25 MWM.guide/Edit->Copy

Copy

Questa azione copia le linee selezionate in clipboard.
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1.26 MWM.guide/Edit->Paste

Paste

per inserire il testo contenuto nella clipboard a partire dalla
prima linea selezionata.

Se state usando (per esempio) KCON: per la finestra di log,
potete scrivere cio’ che volete in questa finestra, selezionare
tutto il testo con il mouse e premere "Amiga+C" per copiare il
tutto in clipboard.
RICORDATE: premete return dopo l’ ultima riga altrimenti la

console rimarra’ occupata e MWM non potra’ mandare
messaggi.

Dopo, selezionate la finestra principale di MWM e premete
"Amiga+V".

Questo funzionera’ anche con le commodities ConClip e ConPaste.

1.27 MWM.guide/Edit->Search new

Search new

Cerca una nuova stringa nel testo.

1.28 MWM.guide/Edit->Search again

Search again

Cerca la stessa stringa nel testo.

1.29 MWM.guide/Edit->Adjust selected lines

Edit selected lines

Questa azione permette di editare tutte le linee selezionate.
Se la linea selezionata non e’ un multi object, non verranno modificati
in alcun modo gli oggetti creati precedentemente.
Altrimenti, se c’e’ realmente il bisogno di modificarla, tutti gli
oggetti in essa contenuti dovranno essere cancellati.

1.30 MWM.guide/Cosa puo’ fare MWM ?

COSA PUO’ FARE MWM ?

MWM e’ in grado di gestire le seguenti cose:
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- HEAD LINK REL=Banner
- TITLE
- BODY BACKGROUND="..."
- ADDRESS
- A HREF="...#..."
- A ID="..."
- IMG ISMAP ALIGN=TOP|MIDDLE|BOTTOM SRC="..." ALT="..."
- UL LI
- OL LI
- DL DT DD
- <!-- comment -->
- BR
- HR
- P ALIGN=LEFT|CENTER|RIGHT|JUSTIFY
- CITE
- CODE
- EM
- STRONG
- AUTHOR
- PERSON
- SAMP
- KBD
- VAR
- DFN
- Q
- ACRONYM
- ABBREV
- INS
- DEL
- B
- I
- TT
- U
- S
- BIG
- SMALL
- SUB
- SUP
- &lt; &gt; &amp; &quot;

&Aacute; &Agrave; &Acirc; &Atilde; &Aring; &Auml; &AElig; &Ccedil;
&Eacute; &Egrave; &Ecirc; &Euml; &Iacute; &Igrave; &Icirc; &Iuml;
&ETH; &Ntilde; &Oacute; &Ograve; &Ocirc; &Otilde; &Ouml; &Oslash;
&Uacute; &Ugrave; &Ucirc; &Uuml; &Yacute; &THORN;
&szlig; &aacute; &agrave; &acirc; &atilde; &atilde; &auml; &aelig;
&ccedil; &eacute; &egrave; &ecirc; &euml; &iacute; &igrave; &icirc;
&iuml; &eth; &ntilde; &oacute; &ograve; &ocirc; &otilde; &ouml;
&oslash; &uacute; &ugrave; &ucirc; &uuml; &yacute; &yuml; &thorn;

- URL for the links
- FORM METHOD=GET|POST
- INPUT TYPE=TEXT|PASSWORD|CHECKBOX|RADIO|RANGE|SCRIBBLE|FILE|HIDDEN|

SUBMIT|IMAGE|RESET
TEXTAREA
NAME,VALUE,SIZE,MAXLENGTH,CHECKED,MIN,MAX,SRC,ACCEPT

- List of INPUTs
- Headings: <H1|H2|H3|H4|H5|H6 ALIGN=LEFT|CENTER|RIGHT|JUSTIFY>
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1.31 MWM.guide/Informazioni generali

INFORMAZIONI GENERALI

MWM richiede un sistema operativo dal 3.0 in poi.

Questo programma e’ stato studiato seguendo il piu’ possibile le
specifiche del formato HTML incluse nell’ archivio HTML30GU.LHA reperibile
in qualunque BBS.

MWM lavora con le librerie gadtools e reqtools.

Questa versione e’ assolutamente Copyright ©1996 Massimo Baglione.

Se ti piace questo programma e hai bisogno di tutte le funzioni
disabilitate, puoi spedirmi 40.000 lire italiane al seguente indirizzo:

Massimo Baglione
Via Della Chiesa 1
67019 Civitatomassa
Scoppito L’ AQUILA (Italy)

specificando dove posso mandare il programma completamente funzionante.

Per qualunque consiglio, critica o idea riguardo MWM, contattate subito:

Massimo Baglione Maurizio Fabiani
(MAUI for Amiga BBS)

39:102/1.5 AmigaNet 39:102/1
39:102/2.5 39:102/2

2:335/602.5 FidoNet 2:335/602
2:335/607.5 2:335/607

InterNet

(Maurizio Fabiani) maui@mbox.vol.it

1.32 MWM.guide/Ringraziamenti

RINGRAZIAMENTI

Devo ringraziare tutti i miei betatester per il loro ottimo bug report
riguardo MWM. In particolare, voglio citare:

Troy Bouchard (Snowy Hill) e Mel Greer per le loro incredibili menti!

Alessandro Di Michele ....per i suoi consigli riguardo la GUI.

Kirk Strauser ............per il suo vario e dettagliato bug report.

Girish V Nath ............per il suo professionalissimo report.
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(Sto ancora aspettando la birra...;-)

Paul Stevens .............(un altro birra-dipendente..(;-))

Arnold Schwarzenegger ... (Hey Arnie, sei veramente tu oppure e’ solo
l’effetto della birra ? (;-))

e, per tutto cio’ che riguarda il resto dello sviluppo di MWM:

Ross Delaforce per aver messo a disposizione il suo sito.

Jeff Lavin per il suo grande aiuto riguardo il doc inglese!

David Putzier per il suo fantastico MWMlogo.iff, guardatelo e basta!

Pierluigi Sferrella per il manuale italiano in formato amigaguide.

Mike Handley per il manuale inglese in formato amigaguide.

Wolfgang G. Wettach per il manuale in tedesco.

Poi, un grande bacio (!) lo mando al mio Boss (Maurizio Fabiani) per la
sua infinita pazienza!

L’ ultimo ringraziamento e’ riservato ad Amiga:
(tutti insieme) ...GRAZIE AMIGA!

-----+-----

-=> * \X/ Amiga! \X/ MAUI BBS! \X/ Love and Beer! * <=-

_The revenge of the italian products_

...enjoy this program!!!

1.33 MWM.guide/Storia di MWM

Storia di MWM:

-MWM v. 2.02 Nov 20 1996

- Improved GUI for preferences.
- Added TEXTAREA for FORM (see "addendum" on the docs).
- Fixed my little mistake when opening and drawing windows.
- Added "Load it !" on the "No text loaded" requester when pressing

one of the tools gadgets if no text was loaded.
- Added "line" and "break" to "What is?" window for <HR> and <BR>.
- Now MWM checks if a visitor window is opened before quitting.
- If exists the temporary preview HTML file, MWM will ask you if you

want or not to delete it.
- Fixed hotkeys on Paragraph window.
- Maurizio’s suggestions:

+ Modified "Save HTML" to "HTML save" on the "Project" menu.
+ Added "HTML save as" on the "Project" menu.
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+ Now MWM can be opened on Default, Named or Owner public screen.

-MWM v. 2.01 Nov 06 1996

- First version of the german doc. (Tanks to Wolfgang G. Wettach)
- Now MWM uses ReqTools library instead of ASL.
- Changed four items in project menu:

- "Load text" -> "Load plain text"
- "Save html" -> "Save to HTML"
- "Load saved work" -> "Load project"
- "Save work" -> "Save project"

- Improved gui for HEAD.
- A liiittle bug removed defining headings for multiobjects.

-MWM v. 2.00 Oct 16 1996

- Now MWM uses gadtools.library (...finally ?!? (;-))).
- Improved gui for texts, images, lists and forms.
- Optimized request for "Load text" if another text was loaded.
- Inserted creation’s date into final HTML file.
- Fixed little bug for lists (MORE action).
- Adjusted writing method for labels.
- Fixed little bug writing headings after </P>.
- Fixed strange bug loading saved works.
- Now MWM shows lists to you in a simple preview mode.
- Removed a dangerous bug scrolling main window’s text.
- Removed a bug inserting empty line (RETURN key).
- Removed some other bugs.
- Fixed a little big bug deleting FORMs.
- Improved alternative text (ALT) for images.
- Removed "SIZE" gadget from main window (See TEXT gadget).
- Now you can define TITLE and BACKGROUND in saving phase.
- Optimized "Jump to mark" and "Jump to label" functions.
- Now MWM lets you set three levels for the Log window’s informations.
- Modified infos into "What is?" window.

-MWM v. 1.08 Jul 04 1996

- First amigaguide version of the english manual.
- Fixed a dangerous bug deleting multiobjects inside FORMs.
- Now you can specify a file to be linked into a site also for images and

multiobjects. (MORE gadget)
- Removed a little bug displaying actions gadgets for 4 colors screens.

-MWM v. 1.07 Jun 12 1996

- Assigned ENTER key for "Edit first selected line".
- Assigned RETURN key for "Insert an empty line".
- Scrolling text if dragging vertical gadget (slow, but it works).
- Added "Prefs" gadget on action gadgets.
- Removed "Preferences" from menu.
- Optimized listviews:

UP/DOWN keys -> move desired option;
RETURN key -> make the choice;
ESC key -> exit from listview;

- Kirk Strauser suggestions:
Removed little bug writing multiobjects;
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Remember drawers for load/save work and save HTML.
Now it is possible a link to a document into a site (see MORE gadget).

- Little bug freeng memory removed. (tanks to Sushi)
- First amigaguide version of the italian manual.

-MWM v. 1.06 May 29 1996

- New "About". Tanks to David Putzier for his wonderful logo!!
- Removed small bug defining lists.
- Adjustements for MWM’s texts.
- MWM adjusts position for tools gadgets just to fill upper space.
- Now MWM saves config during quit.
- Snapshot for main window and "What is?" window.
- I hope removed a bug saving prefs for screens.
- Now it’s possible to open/close "What is?" window (Del key).
- Improved "Special" menu:

"Go to label";
"Mark location 1";
"Mark location 2";
"Mark location 3";
"Jump to mark 1";
"Jump to mark 2";
"Jump to mark 3";

-MWM v. 1.05 May 15 1996

- Small bug deleting multiobjects for FORMs removed.
- Adjusted headings size writing lists.
- Improved "Delete all" in "project" menu.
- Adjustements in "Single line" window:

MWM shows infos about a single object when selected;
Now it is possible to delete a single object if previously created;
Better separation between multiobjects;

- Bug fixed version of the english doc! (;-)) Tanks to Jeff Lavin!

-MWM v. 1.04 May 03 1996

- Optimized some functions.
- Small bug removed.
- Adjusting width for lowres screens.
- Adjusted docs to 78 columns.
- Arranged depth between "Main Window" and "What is?" window.
- Improved autosizing for "Single Line" window.
- Now MWM shows all following ASCII value:

9 (TAB) as four spaces (ASCII 32);
10 (LF) and 13 (CR) as end of lines;
32 to 126;
127 to 160 skipped because unused;
161 to 255;

- Added filter for:
&Aacute; &Agrave; &Acirc; &Atilde; &Aring; &Auml; &AElig; &Ccedil;
&Eacute; &Egrave; &Ecirc; &Euml; &Iacute; &Igrave; &Icirc; &Iuml;
&ETH; &Ntilde; &Oacute; &Ograve; &Ocirc; &Otilde; &Ouml; &Oslash;
&Uacute; &Ugrave; &Ucirc; &Uuml; &Yacute; &THORN;
&szlig; &aacute; &agrave; &acirc; &atilde; &atilde; &auml; &aelig;
&ccedil; &eacute; &egrave; &ecirc; &euml; &iacute; &igrave; &icirc;
&iuml; &eth; &ntilde; &oacute; &ograve; &ocirc; &otilde; &ouml;
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&oslash; &uacute; &ugrave; &ucirc; &uuml; &yacute; &yuml; &thorn;

-MWM v. 1.03 Apr 12 1996

- Fixed a liiiittle bug for "Amiga + Q" (quit).
- Fixed a bug changing "heading size" default.

-MWM v. 1.02 (never released)

- New versions of the docs.
- Removed a dangerous bug deleting multiobjects.
- Now MWM uses Cut, Copy and Past via Clipboard.

-MWM v. 1.01 Apr 04 1996

- Now MWM works only on OS 3.0 or higher.
- Removed a bug in opening requesters.

I have never tested MWM without MCP! (;-))
I’m really sorry for this!

-MWM v. 1.00 Apr 01 1996

- ...FINALLY!!!
First release for all Amiga’s Web makers!!

1.34 MWM.guide/Addendum

Ciao!

1>
Un appunto per il manuale in tedesco tradotto da Wolfgang G. Wettach:

probabilmente il suo lavoro non verra’ agiornato dal sottoscritto
ogni volta che uscira’ una nuova versione di MWM, quindi il
manuale in tedesco e’ valido solo per la versione 2.00.

2>

Le versioni dei progetti salvati che contengono i form non possono
piu’ essere caricati da questa versione di MWM (2.02).
Se il progetto non contiene form, allora e’ possibile modificare la
prima linea "WORK_MWM_NEW_1" con "WORK_MWM_NEW_2" usando un comune
text editor.

Grazie di usare MWM!


	MWM
	MWM.guide/Contenuti
	MWM.guide/Di cosa si tratta?
	MWM.guide/La finestra principale
	MWM.guide/Primo gadget TEXT
	MWM.guide/Secondo gadget IMAGE
	MWM.guide/Terzo gadget LIST
	MWM.guide/Quarto gadget FORM
	MWM.guide/Quinto gadget MORE
	MWM.guide/Sesto gadget HEAD
	MWM.guide/Ottavo gadget VIEW
	MWM.guide/Nono gadget PREFS
	MWM.guide/La finestra per la singola linea
	MWM.guide/La finestra di aiuto
	MWM.guide/La finestra '' What is? ''
	MWM.guide/Il menu
	MWM.guide/Project->Load text
	MWM.guide/Project->Load text
	MWM.guide/Project->keys
	MWM.guide/Project->Save HTML
	MWM.guide/Project->Load saved work
	MWM.guide/Project->Save work
	MWM.guide/Project->About
	MWM.guide/Project->Quit
	MWM.guide/Edit->Cut
	MWM.guide/Edit->Copy
	MWM.guide/Edit->Paste
	MWM.guide/Edit->Search new
	MWM.guide/Edit->Search again
	MWM.guide/Edit->Adjust selected lines
	MWM.guide/Cosa puo' fare MWM ?
	MWM.guide/Informazioni generali
	MWM.guide/Ringraziamenti
	MWM.guide/Storia di MWM
	MWM.guide/Addendum


