
The Back Page
Welcome to the back page. You won't find this page unless you're pretty tricky. But, since you're here, 
we'll tell you a little bit about ourselves.
Michael Baldwin is the C++ wizard who coded the actual terminal emulation code and TELNET 
communications code (the inner messy stuff). If you find a bug, blame it on him!
Michael Baldwin Jr. is the VB wizard who designed the interface and threw the application together, 
along with Setup, online Help, Quick Start, the manual, and parts of the box, all while being a 
sophomore in high school at the same time. Pretty slick, huh?
Gene Ninestein wrote Dart's first VT emulation package, which PowerVT is (loosely) based upon. Gene 
also was responsible for all sorts of testing, distributing beta copies, and all sorts of input.

"The faster you move, the slower time passes, the longer you live."
--Peter Diamandis



Contents for PowerVT Help

PowerVT is a tool you can use to communicate with host computers using phone lines, a direct 
connection, or TELNET.
To learn how to use Help, press F1.

Overviews
What is VT220?
Frequently Asked Questions
The toolbar
Command line arguments
Key Remappings

How To...
Connect using a modem
Connect over a network (using TELNET)
Connect using a direct connection
Change communications settings
Change modem commands
Change session options
Change key sequences

Commands
File Menu Commands
Edit Menu Commands
View Menu Commands
Connect Menu Commands
Options Menu Commands
Window Menu Commands
Help Menu Commands



What is VT220?
The VT220 is a computer terminal, consisting of a monitor and keyboard. The terminal connects to host 
computers and displays received data on the screen. The VT220 supports certain control codes--
combinations of characters which have special meanings. An example of a control code would be a 
command to clear the screen, or reverse text.
The VT220's set of control codes has become a standard for terminals. PowerVT interprets VT220 
control codes and displays a screen in a window which matches what a VT220 terminal's screen would 
look like.
PowerVT goes beyond the VT220 terminal in many ways, however. It can connect using TELNET, a 
modem, or a direct connection. You can customize the screen colors, or fonts it uses. You can scroll 
backwards to see what was previously on the screen, and assign key sequences to keys. And best of 
all, you don't need an actual terminal--you can use the PC you already have.



Frequently Asked Questions
 Contacting Dart Communications
Click on a question below to see the anwer.

 How can I open a previous session to change some characteristics without making a connection?
 Why doesn't Auto Print Mode print anything when I check it?
 How can I record the session in a text file?
 Why can't I turn Num Lock on?
 How do I completely uninstall PowerVT?
 How can I change what is sent when I press a key?
 What are the VT220_ascii and VT220_special_fonts?



Command Line Arguments
You can place additional text after the filename of the PowerVT program when you run it using the Run... 
command from the Program Manager or File Manager. You can also place it in the Item Properties for 
the PowerVT icon in the Program Manager.

 To load a particular file into PowerVT, place the filename after the program filename. You must include 
the full path and extension for the filename. For example,
c:\powervt\powervt.exe c:\usr\example.pvt
would load the file example.pvt in the directory c:\usr when PowerVT started up.

 You can also load one of the four most recently used files in PowerVT. To do this, use the argument 
/mfilex where x is the number 1, 2, 3, or 4. For example,
c:\powervt\powervt.exe /mfile1
would load the file you used the last time you used PowerVT. If you commonly use the same file each 
time you use PowerVT, this will automatically load it for you.



How to Connect Using a Modem
 Communication Settings Dialog
 Modem Commands
To connect to a host over phone lines, follow these steps:

1 From the File menu, choose New Modem.
2 Fill in the phone number of the host computer.
3 If you have not configured the modem settings before, click the Advanced... button. Select the 

correct settings for your modem, and click OK.
4 Click the OK button.

The status bar should say, "Connecting to...". If it does not, you may have entered incorrect modem 
settings, or your modem may not be correctly connected to your computer. You can change the modem 
settings at this point by choosing Commuication Settings... from the Options menu. Once you have 
entered the correct settings, choose Connect from the Connect menu.
You should now be connected to the host computer. What you type in the window is immediately sent to 
the host. To hang up the connection, choose Disconnect from the Connect menu.



How to Connect Using a Direct Connection
To connect to a host directly connecting to one of the COM ports on your computer, follow these steps:

1 From the File menu, choose New Direct.
2 If you have not configured the COM port settings before, click the Advanced... button. Select the 

correct settings for your port, and click OK.
3 Click the OK button.

The status bar should say, "Connecting...". If it does not, you may have entered incorrect COM port 
settings, or the host may not be correctly connected to your computer. You can change the port settings 
at this point by choosing Communication Settings... from the Options menu. Once you have entered the 
correct settings, choose Connect again from the Connect menu.
You should now be connected to the host computer. What you type in the window is immediately sent to 
the host. To disconnect, choose Disconnect from the Connect menu.



How to Connect Over a Network (Using TELNET)
To connect to a host on your network or another connected network, follow these steps:

1 From the File menu, choose New TELNET.
2 Fill in the name or IP address of the computer you want to connect to, and click the OK button.
3 From the Connect menu, choose Connect.

The status bar should say, "Connecting...", and soon "Connected". You should now be connected to the 
host computer. What you type in the window is immediately sent to the host. To disconnect, choose 
Disconnect from the Connect menu.



File Menu Commands
Use the scroll bar to see more commands.

New Telnet...
Creates a new window and connects to a Telnet host.

Toolbar shortcut: 

New Modem...
Creates a new window and connects to a host using a modem.

Toolbar shortcut: 

New Direct...
Creates a new window and connects to a host directly connected to your computer.

Toolbar shortcut: 

Open...
Opens a previously saved session.

Toolbar shortcut: 

Close
Disconnects and removes the session window from the screen.

Save...
Saves current session characteristics (such as phone number, colors, fonts, and modem settings) to a 
file on disk.

Toolbar shortcut: 

Save As...
Saves current session characteristics to a new file on disk.

Save Text As...
Saves all text from the entire session (up the the size of the buffer) into a text file on disk.

Print Setup...
Allows you to configure your printer.

Print Screen
Prints the current "screen" in the terminal window (normally 80 columns by the last 24 lines).

Print Selected Lines
Prints the selected text in the window.

Auto Print Mode
Sends all output to the printer as well as to the screen. When Auto Print is on, the text is buffered up in 
memory and printed when you either turn Auto Print off or close the connection.

Printer Controller Mode
This is the same as Auto Print, except that text is sent only to the printer, and not to the screen at all.

Log Mode
Sends all output to a text file as well as to the screen. The first time you turn it on, it prompts you for a 
filename. You can change the filename later on with the Log File... command.

Log File...



Prompts you for a new file to send log output to. If you change the filename while Log Mode is on, then 
output is immediately redirected to the new file.

Exit
Exits PowerVT.

Recent File List
Loads one of the four most recent sessions saved to disk.



Edit Menu Commands
Use the scroll bar to see more commands.

Copy
Copies text from the window and places it onto the clipboard, with carriage returns after each line.

Toolbar shortcut: 

Paste
Sends text from the clipboard across the connection to the host.

Toolbar shortcut: 

Select All
Selects all the text in the window. This is useful if you want to copy the entire contents of the window into 
the clipboard.

Clear All
Clears all text from the window.



View Menu Commands
Use the scroll bar to see more commands.

Toolbar
Shows or hides the toolbar at the top of the window.

Status Bar
Shows or hides the status bar at the bottom of the window.



Connect Menu Commands
Use the scroll bar to see more commands.

Connect
Connects to a host after a new session has been created, after a session has been loaded, or after a 
connection has been broken.

Toolbar shortcut: 

Disconnect
Disconnects from a host.

Toolbar shortcut: 

Send Break
Sends the break command across the connection.



Options Menu Commands
Use the scroll bar to see more commands.

Session Options
Displays the session options dialog box, where you can set options such as window color, font, cursor 
style, buffer size, and more. See the Session Options Dialog for more information.

Key Sequences
Displays the key sequences dialog box, where you can set key sequences to keys on your keyboard. 
See the Key Sequences Dialog for more information.

Phone Number
Allows you to change the phone number and timeout for modem connections. Changes will affect the 
next dial-out, and not a current connection.

Communication Settings
Displays the communications options dialog box, where you can configure your communications port or 
modem. See the Communication Settings Dialog for more information. Changes will affect the next dial-
out, and not a current connection.

Telnet Options
Allows you to change the remote host name and port for Telnet connections. Changes will affect the next 
connection, not a current connection.



Window Menu Commands
Use the scroll bar to see more commands.

Cascade
"Stacks" all windows so that the title bar is visible on each one.

Arrange Icons
Arranges all minimized windows in a row at the lower-left corner of the screen.

Tile
Arranges all windows so that all are completely visible and fill the application's main window.

Window List
Activates the window chosen and brings it to the foreground.



Help Menu Commands
Use the scroll bar to see more commands.

Index
Displays the contents for PowerVT help.

Search For Help On...
Displays a dialog box with keywords for topics to choose from.

How to Use Help
Displays instructions on how to use PowerVT help.

Quick Start
Displays PowerVT Quick Start--a tutorial program which introduces you to PowerVT. To view Quick Start 
now, click here.

Frequently Asked Questions
Displays a help topic with the most commonly asked questions. To view Frequently Asked Questions, 
click here.

Remapping Keys
Displays a help topic which describes how key mappings work. To view the topic, click here.

About
Displays program information and system information, such as the type of processor and amount of 
memory free.



Key Sequences Dialog
 Key Sequences Examples
 Key Remappings
The key sequences dialog lets you assign key sequences to certain keys on the keyboard, and lets you 
remap keys. For example, you could assign your username to the F12 key.
Click on a section of the picture below to learn what it does.

PowerVT allows you to assign a key sequence to almost any key on the keyboard, by itself or with Shift or 
Ctrl. For example, if you wanted to send the characters "LOGIN" when you pressed CTRL+F12, you would 
follow these steps:

1 Click the F12 button on the keyboard in the window.
2 In the Ctrl text box, type LOGIN.
3 Click OK.

Now, when you pressed CTRL+F12, the characters "LOGIN" would be typed instead.
You can insert unprintable characters in the sequence text. A caret (^) followed by a three-digit number 
represents that number's character. If you want to use a caret in your string, use a double-caret instead 
(^^). PowerVT also supports the ^SS3, ^CSI, and ^ESC characters.
See Key Sequences Examples for more information.



Key Sequences Examples
 Key Sequences Dialog
This topic shows several examples of how to use key sequences and remap keys in PowerVT. You must 
choose Key Sequences... from the Options menu before you try each example.

Example 1: Username
If you type in a username each time you make a connection, you may want to assign it to a key 
combination such as CTRL+U. You can do this with any command you use often, also, such as "dir". To 
do this, follow these steps:

1 Click the U button on the keyboard in the window.
2 In the Ctrl text box, type your username (for example, "JohnDoe").
3 After your username, type ^013. This sends a carriage return after the username, the same as 

pressing Enter. If you don't add ^013, your username will appear when you press CTRL+U, but you 
will have to press Enter after it.

Example 2: Remapping PF1-PF4
By default behavior, the VT220's PF1-PF4 keys are assigned to the Num Lock, /, *, and - keys on the 
IBM keyboard's numeric keypad. If you wanted to assign them to the F1-F4 keys on the IBM keyboard, 
you could follow these steps:

1 Click on the F1 button.
2 Look up the code for PF1 in Advanced Keyboard Information. In VT220 Numeric mode, this turns out 

to be the two-character sequence "SS3" "P".
3 In the Normal text box, type ^SS3P. Notice that we use the characters ^SS3 for an SS3 character, 

because it is not accessible from the keyboard.
4 Follow steps 1-3 for the keys F2-F4, using the codes SS3 Q, SS3 R, and SS3 S for PF2, PF3, and 

PF4, respectively. Remember to use ^SS3 for the SS3 character.



Session Options Dialog
 Appearance Tab  Options Tab
 General Tab  Display Tab

The Session Options dialog box lets you change many aspects of each terminal window. When you 
save terminal settings, the settings in the Session Options dialog box are also saved.
The dialog box is divided into four sections, or tabs. To view the options associated with each tab, you 
must click on it.



Appearance Tab
 Session Options Dialog
The appearance tab allows you to change the colors and font used by the terminal window. Click on a 
section below to learn more about it.



Options Tab
 Session Options Dialog
The options tab allows you to change certain options associated with the program. Click on a section 
below to learn more about it.



General Tab
 Session Options Dialog
The general tab allows you to set general terminal options. Click on a section of the graphic below to 
learn more about it.



Display Tab
 Session Options Dialog

The display tab allows you to set terminal display options. Click on a section of the graphic below to 
learn more about it.



Key Remappings
 Advanced

Because the VT220 terminal keyboard contains several keys which the IBM keyboard does not, and vice 
versa, some keys on the IBM keyboard have been remapped to act like certain VT220 keys. The chart 
below lists which keys are remapped. You can override these mappings to create your own through the 
use of key sequences.
VT220 Key IBM Key

Return Enter key above shift
Enter Enter key on numeric keypad

PF1 Num Lock
PF2 Slash (/) key on numeric keypad
PF3 Asterik (*) key on numeric keypad
PF4 Minus (-) key on numeric keypad
Comma (,) Plus (+) on numeric keypad
Minus (-) Ctrl+ Plus key (+) on numeric keypad

Find Insert
Insert Here Home
Remove Page Up
Select Delete
Prev Screen End
Next Screen Page Down

Hold Screen Pause
Print Screen Print Screen
Help F11
Do F12

F6-F10 F6-F10 (same)
Shift+F6-F10 Ctrl+F6-F10
F11-F20 Shift+F1-F10
Shift+F11-F20 Shift+Ctrl+F1-F10



Advanced Keyboard Information
 General Key Remappings

The following tables are provided as a guide to the character strings generated by PowerVT. For more 
advanced tables, contact Digital Equipment Corporation.

Control Sequences 
(used below)

7-bit Mode 8-bit Mode

ESC 1B (hexadecimal) 1B (hexadecimal)
CSI ESC [ 9B (hexadecimal)
SS3 ESC O 8F (hexadecimal)

Main Keypad Function Keys
VT/IBM Key Code Transmitted

Backspace DEL or BS (depending on session options)
Tab HT character
Return CR or CR/LF (depending on session options)
Ctrl, Lock, Shift (none)
Space Bar SP character

Edit Keys
VT Key IBM Key VT220 Code VT100/52 Code

Find Insert CSI 1 ~ None
Insert Here Home CSI 2 ~ None
Remove Page Up CSI 3 ~ None
Select Delete CSI 4 ~ None
Prev Screen End CSI 5 ~ None
Next Screen Page Down CSI 6 ~ None

Cursor Control Keys
VT/IBM Key VT100/220 

Normal Mode
VT100/220 
Application 
Mode

VT52 Normal 
Mode

VT52 
Application 
Mode

Up Arrow CSI A SS3 A ESC A ESC A
Down Arrow CSI B SS3 B ESC B ESC B
Right Arrow CSI C SS3 C ESC C ESC C
Left Arrow CSI D SS3 D ESC D ESC D

Numeric Keypad Keys
VT Key IBM Key VT100/220 

Numeric 
Mode

VT100/220 
Application 
Mode

VT52 
Numeric 
Mode

VT52 
Application 
Mode

0 0 0 SS3 p 0 ESC ? p
1 1 1 SS3 q 1 ESC ? q
2 2 2 SS3 r 2 ESC ? r
3 3 3 SS3 s 3 ESC ? s
4 4 4 SS3 t 4 ESC ? t



5 5 5 SS3 u 5 ESC ? u
6 6 6 SS3 v 6 ESC ? v
7 7 7 SS3 w 7 ESC ? w
8 8 8 SS3 x 8 ESC ? x
9 9 9 SS3 y 9 ESC ? y
, + , SS3 m - ESC ? m
- CTRL-+ - SS3 l , ESC ? l
. . . SS3 n . ESC ? n
Enter Enter CR or CR/LF SS3 M CR or CR/LF ESC ? M
PF1 NumLock SS3 P SS3 P ESC P ESC P
PF2 / SS3 Q SS3 Q ESC Q ESC Q
PF3 * SS3 R SS3 R ESC R ESC R
PF4 - SS3 S SS3 S ESC S ESC S

Top Row Function Keys
VT Key IBM Key VT220 Code VT100/52 Code

Hold Screen F1 (none) (none)
Print Screen F2 (none) (none)
Set-up F3 (none) (none)
Data/Talk F4 (none) (none)
Break F5 (none) (none)
F6 F6 CSI 1 7 ~ (none)
F7 F7 CSI 1 8 ~ (none)
F8 F8 CSI 1 9 ~ (none)
F9 F9 CSI 2 0 ~ (none)
F10 F10 CSI 2 1 ~ (none)
F11 (ESC) SHIFT+F1 CSI 2 3 ~ ESC
F12 (BS) SHIFT+F2 CSI 2 4 ~ BS
F13 (LF) SHIFT+F3 CSI 2 5 ~ LF
F14 SHIFT+F4 CSI 2 6 ~ (none)
Help F11 CSI 2 8 ~ (none)
Do F12 CSI 2 9 ~ (none)
F17 SHIFT+F7 CSI 3 1 ~ (none)
F18 SHIFT+F8 CSI 3 2 ~ (none)
F19 SHIFT+F9 CSI 3 3 ~ (none)
F20 SHIFT+F1

0
CSI 3 4 ~ (none)



Communication Settings Dialog
 Modem Commands dialog

The Communication Settings dialog allows you to configure the terminal window to match your 
communcations port's characteristics.
Click on a section of the graphic below to learn more about it.



Modem Commands Dialog
 Communications Settings Dialog

The Modem Commands dialog allows you to change the commands sent to the modem for initialization, 
dialing, and hanging up. The default settings generally work, but certain settings are required for some 
modems.
Click on a section of the graphic below to learn more about it.



Toolbar

The toolbar allows you to access commonly used menu commands quickly. You can show or hide the 
toolbar with the Toolbar command on the View menu. A list of the toolbar buttons and their descriptions 
is shown below.

Picture Description

Creates a new Telnet session

Creates a new session using the modem

Creates a new direct session

Opens a previously saved session

Saves session characteristics to disk

Copies text from a window onto the Clipboard

Pastes text from the Clipboard into a window

Connects or dials to a host

Disconnects or hangs up from a host

Toggles AutoPrint on and off

Toggles logging to disk on and off



Status Bar

The status bar displays the current state of the program, and also displays the descriptions of toolbar 
buttons when depressed. You can show or hide the toolbar with the Status Bar command on the View 
menu.



Contacting Dart Communications
You can contact Dart Communications in the following ways:

E-mail
support@dart.com

Phone
(315) 841-8106

Fax
(315) 841-8107

Postal
6 Occum Ridge Road
Deansboro, NY 13328



There is an option to prevent a connection from automatically being made when you create a new 
terminal window or open a file. From the Options menu, uncheck AutoConnect.



Using Auto Print, the printer does not print until you do one of the following:

 Turn AutoPrint off

 Close the connection

 Close the window
The same applies to Printer Controller mode.



To record all text received and typed in a text file, choose Log Mode from the File menu. Once you 
select a filename, all text displayed is appended to the text file.

You also use the log to file toolbar button:



The VT220's keyboard contains several keys which the standard IBM keyboard does not. Because of 
this, some of the keys on the IBM keyboard have been remapped to act as VT220 keys (see Key 
Remappings). The Num Lock key has been remapped to become the "PF1" key. Because the PF1 key 
is not a toggle key, pressing it has no effect on the status of Num Lock. Therefore, Num Lock is always 
off.



To completely uninstall PowerVT, do the following:
1 Delete the PowerVT Program Manager group.
2 Delete the PowerVT directory from the File Manager or command line.
3 PowerVT installs certain files into your windows\system directory if they are not already there. You 

may delete the files P16TNTB1.VBX, P16VT2B1.VBX, YATC.VBX, and POWERVT.INI. PowerVT 
also installs other files, but these files are often used by other applications, and may prevent them 
from running if deleted.

NOTE If, after deleting the files in step 3, another application on your hard disk fails to run, you can re-
install PowerVT to replace the missing files.



You can use key sequences. Key sequences let you assign a new key string to a key on the keyboard, 
or Ctrl/Shift+any key. To learn how, see Key Sequences.



The fonts VT220_ascii and VT220_special are automatically loaded from the POWERVT.FON file in 
your \windows\system directory. The font VT220_ascii provides VT220 screen emulation using the 
VT220's character set. For as close VT emulation as possible, you should select this font. The font 
VT220_special is used automatically when special VT220 graphics characters are needed.



IP Address
A four-number phrase in the form x.x.x.x, where each x is a number from 0 to 255. This four-number 
phrase uniquely identifies each computer on a TCP/IP network.



Dial Prefix and Suffix
When a dial command is sent the the modem, it is in the form DIALPREFIX+PHONENUMBER+DIALSUFFIX. 
For most modems, the dial prefix is "ATDT" (ATtention, Dial Tone), and there is no suffix.



Hangup Prefix and Suffix
When a command is sent to the modem to hang up, it is in the form HANGUPPREFIX+HANGUPSUFFIX. For 
most modems, the prefix is "+++", and the suffix is ATH (Attention, Hang up).



Originate
This command is sent to the modem before any others, and initializes it with certain settings.



Modem Defaults
These are default settings for certain modems. Most modems will work with the default "Hayes" settings.



Save As Defaults
Saves the current settings in the dialog to disk, so that they are used as defaults the next time a new 
session is created.



Color Scheme
To change the colors, double-click on the section of the window you would like to change, and select a 
new color from the color dialog box. You may change the background color, text color, and bold text 
colors.



Change Font
This displays a dialog box which allows you to choose a new font for the window. For full VT emulation, 
you should choose the VT220_ascii font. This font uses the VT220's character and graphics sets, to 
provide a screen which matches the VT220's as closely as possible.



Buffer Size
This specifies the size of the scroll buffer, in lines. The higher you set it, the farther back you can scroll.



Mode
This specifies the terminal emulation mode. Select a new option to emulate a different type of terminal. 
This defaults to VT220, 7-bit.



User Features
This specifies whether the host can change options in the General tab or Display tab.



Keypad
This specifies whether the numeric keypad is used to send numbers or the actual keys.



Cursor Keys
This specifies whether the arrow keys are used to move the cursor or send the key code.



Backspace Sends
This specifies whether pressing the Backspace key sends a backspace character or a delete character.



New Line
This specifies whether pressing the Enter key sends a carriage return or a carriage return-linefeed.



Columns
Specifies the number of columns to support.



AutoWrap
Specifies whether text should wrap to the next line when it travels over the right margin, or whether to 
continually stay at the margin.



Scroll
Specifies whether the screen should scroll as fast as it needs to to catch up when text is received, or if it 
should scroll smoothly at a certain speed.



Cursor Style
Specifies whether the cursor should be a block or underline.



Baud Rate
Select the baud rate of your modem, or of the host (for a direct connect).



Data Bits
Select the number of data bits your com port supports.



Stop Bits
Select the number of stop bits your com port supports.



Parity
Select the parity your com port supports.



Com Port
Select the com port you wish to use.



Flow Control
Select the type of flow control you wish to use.



Modem Commands
Display the Modem Commands dialog. You can use this to configure the commands sent to the modem.



Save As Defaults
Saves the current settings in the dialog to disk, so that they are used as defaults the next time a new 
session is created.



Rows
Enter the number of rows. This should usually be set to 24. This is not the same as the buffer size, 
which contains scrolled data.



Keyboard
When you click on a key, you can view its current assigned key sequences. If the letters on the key are 
bold, there are assigned sequences. If they are not, no sequences have been assigned.



Current Key
This displays the current key whose key sequences are being displayed in the four text boxes.



Key Sequence text boxes
These display the current key sequences assigned to the current key. By typing in the boxes, you can 
change the sequences. The key sequence in the Normal box is executed when you type the key. The 
key sequence in the Shift, Ctrl, and Ctrl+Shift boxes are executed when you hold down the appropriate 
modifier key and type the key.
If there is no entry in the box, the key takes on default behavior.



Clear All
This button removes all key sequences, restoring the keys to their default behavior.



Help
This button displays help for the dialog box, the topic you are currently viewing.




