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Adding a Record

1. Click the icon on the Tool Bar representing the module or browser you wish to open, or from the 
View menu, choose the module or browser to view.

2. From the Edit menu, choose Add (Recipe, Coupon, Restaurant, or Pantry) or click the add icon 
on the Tool Bar or place your cursor in the browser and press INSERT.    If you are viewing a 
record, press the Add button to add a new record.
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See Also:

Editing a Record



Editing a Record

1. Click the icon on the Tool Bar representing the module or browser you wish to open, or from the 
View menu, choose the module or browser to view.

2. From the Edit menu, choose Edit (Recipe, Coupon, Restaurant, or Pantry) or doubleclick on the 
record or place your cursor in the browser and press ENTER.
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Adding a Record



Deleting a Record

1. Open any module.

2. Locate and highlight the record(s) you wish to delete.

3. From the Edit menu, choose Delete (if you are in the Recipes view, the menu option will say 
Delete Recipe. If you are in the Coupons view the menu option will say Delete Coupon, etc.) or 
click the delete icon on the Tool Bar or simply press DELETE.

4. At the "Delete selected (recipe)?" prompt, choose Yes.

NOTE: If you are viewing a record you wish to delete, simply choose Delete.
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Creating Reports

1. Click the icon on the Tool Bar representing the module or browser you wish to open, or from the 
View menu, choose the module or browser to view.

2. From the File menu, choose New Report.
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Editing Reports

1. Click the icon on the Tool Bar representing the module or browser you wish to open, or from the 
View menu, choose the module or browser to view.

2. From the File menu, choose Modify Report.

3. Enter the name of the report, or select from the list of files.

4. If your report is in a different location on your system, select the appropriate directory path from 
the Directories section and drive from the Drives list section of the dialog box.

5. If you saved your report with a different extension other than FP, choose a different file type from 
the List Files of Type section of the dialog box.

6. Once you've selected your report, double-click on it or click OK.

See Also:
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Browse

1. Under List Files of Type, use the pull-down menu to choose the types of files you want to find.

2. Under Drives, use the pull-down menu to choose the drive where you want to look for files.

3. Under Directories, double-click to open directories and browse for files. When a directory is 
opened, files matching the current file names will be displayed in the list on the left.

4. When you find the file you're looking for, double-click it or select it, then click OK.    The selected 
path and file name are displayed in the Command Line field in the Customize dialog box.



Browse

1. Under List Files of Type, use the pull-down menu to choose the types of files you want to find.

2. To choose more specific types of files, type their file extensions in the text area under File Name. 
For example, to look for files with .EXE and .BAT extensions, type    *.exe; *.bat

3. Under Drives, use the pull-down menu to choose the drive where you want to look for files.

4. Under Directories, double-click to open directories and browse for files. When a directory is 
opened, files matching the current file names will be displayed in the list on the left.

5. When you find the file you're looking for, double-click it or select it, then click OK.    The selected 
path and file name are displayed in the Command Line field in the Customize dialog box.



Select Report File

1. Open any module first.

2. From the File menu, choose Modify Report.    Recipes displays the Select Report File dialog box.

3. Select the name of the file you wish to modify in the File Name field.

4. Select the directory location for the file from the Directories portion of the dialog box.

NOTE: To change drives, use the list of drives provided in the Drives portion of the dialog box.

5. Click OK.



Converting from Recipes for Windows v1.0

Before you open any views, you MUST run the conversion option to convert your Recipes 1.0 files to 
the Recipes 2.0 format.

To Convert each recipe file and coupon file, do the following:
1.      From the Window menu, choose Close All to close any open recipe window (If any views are 

currently opened).
2.      From the File menu, choose Convert from Recipes v1.0.    Recipes displays the Convert 

dialog box.
3.      Select Recipes 1.0 data directory.    The directory path will be displayed under Directories.
4.      If you need to change drives first, select an alternate drive from the Drives list.
5.      Select the file that you want to convert.    The name will appear in the File Name box. 

IMPORTANT: The only files you should convert are the COUPONS.DB and RECIPES.DB files.    You 
should also convert any recipe file that you have created.    Do NOT select files that begin with an 
UNDERSCORE ( _ ) as those files are internal to Recipes for Windows.    For example,    If you 
wanted to convert the main recipe file - RECIPES.DB - , under the File Name List you would see the 
following two files

RECIPES.DB
_RECIPES.DB

The file to convert is RECIPES.DB and NOT _RECIPES.DB

NOTE: You do not need to convert your coupon and recipe file if you do not have any important data 
in them.    Recipes for Windows v2.0 will automatically create them for you if you dont convert them.

6.      Click OK.    The conversion process will start.    You can monitor the progress of the 
conversion in the Main Status Bar.



Registering Recipes for Windows

One of the very first things you should do before setting up Recipes is to register your product. 
Registering is also important because it gives us your name and address so we can notify you of 
product upgrades and special offers. You will find the Registration Card included in your Recipes for 
Windows package. Be sure to complete the card and mail it in.



If You Have Questions

If you have questions about Recipes, first look in this Users Guide, or consult the Help system. 
Finally, check the Readme document for last-minute changes that may affect your system.

If you cannot find the answer or solution using these suggestions, read the instructions in the 
following section, "Before Calling Technical Support."

To get help

1. Click the question mark (?) on the main tool bar, press F1, or from the Help menu, choose Index 
to go to the main help index and choose the topic you wish. The Help index lets you locate 
information not related to the current screen.

OR

1. From the main screen, press SHIFT and F1. The cursor changes to a question mark.

2. Click on the menu item you need help on.

Additionally, to get Toolbar help, click on a particular icon and hold the left mouse button. A description 
displays in the bottom left corner of your screen on the status bar. If youre curious about what each 
icon represents, click and hold the right mouse button. Slowly move the mouse across each icon. A 
description of each icon displays in the bottom left corner of your screen on the status bar as you 
touch that icon.



Before Calling Technical Support

Please have this users guide available along with the following information:

Computer name and model. Also, the name and model of any additional hardware such as 
expansion cards, video adapter, modem, and external drives.

Amount of RAM. To determine this, type MEM from the DOS prompt (DOS 5.0 and 6.0 only) and 
press ENTER.

Version of DOS and Windows you are using. To determine the version of DOS, type VER from 
the DOS prompt and press ENTER. To determine the version of Windows you are using, from the 
Program Manager, click on Help and then About Program Manager.

Version of the program you are running.

Any information and the actions taken which can reproduce the problem you are experiencing.



Contacting Technical Support

If you need technical assistance during or after setting up Recipes for Windows, you may contact one 
of the following sources for technical assistance.

Ö Mail correspondence to:

Technical Support Department
Odyssey Computing, Inc.
5962 La Place Court, Suite 215
Carlsbad, CA 92008-8807

Ö Phone calls. You may call our Technical Support staff Monday through Friday between 8:00 a.m. 
and 5:00 p.m. (Pacific Time) at (619) 929-7833.

Ö FAX. You may FAX your question or problem to our Technical Support staff at (619) 929-1012.

Ö CompuServe. You can access us using CompuServe number 71034,1367. This allows you to 
exchange information and ideas with Odyssey Computing and other Recipes users. If you do not 
have a CompuServe account, call (800) 524-3388 to request a free Introductory Membership.

This section describes the installation procedure for Recipes for Windows Version 2.0. Recipes 
supplies you with an easy-to-use application called Setup. It guides you through each step of 
installing Recipes.

Recipes for Windows is designed for IBM and compatible systems with a 386 processor or higher. To 
use Recipes, you need:

· A minimum of 2 MB RAM (although we recommend 4 MB RAM).
· 2 MB of free disk space.
· A 1.44 MB or 1.2 MB floppy disk drive.
· A VGA or Hercules monochrome graphics card.
· Windows 3.1 or higher.



Backup Your Hard Disk

Recipes for Windows is completely safe and reliable. However, before making any change to your 
system, it is always a good idea to back up your hard disk.

If you have a regular backup procedure, just follow your normal routine. If you don't have a regular 
backup procedure, consult your DOS manual to get instructions on the BACKUP command. If you'd 
like a faster and more convenient backup system, you should consider one of the many DOS or 
Windows backup programs available.



Create a Boot Disk

One of the easiest precautions you can take before installing any new software is to make a bootable 
floppy disk. It's easy to make one yourself, and it takes just a couple of minutes. If you don't know 
how to make a bootable floppy disk, the following procedure takes you through, step-by-step.

To create a boot disk from Windows
1.      Open the File Manager.
2.      Insert a blank, unformatted floppy disk in drive A (or B).
3.      From the Disk menu, choose Format Disk.
4.      In the Disk In box, select Drive A (or B).
5.      In the Label box, type Boot Disk.
6.      Check the Make System Disk field.
7.      Choose OK.
8.      Choose Yes. When the disk is formatted, it contains all the commands necessary to start 

your computer.
9.      Label the disk "Boot Disk" and put it away. If you ever have trouble starting your system, this 

disk will come in handy.



Make a Copy of Your Setup Disks

Copy and write protect your two original Recipes for Windows disks. Use the copies to install 
Recipes.



Verify Windows 3.1 is Installed

Make sure you have installed or upgraded to Windows 3.1 before installing and setting up Recipes. 
To verify whether or not Windows is installed, from the DOS prompt, type WIN and press ENTER. If 
Windows is installed, your system displays either the Program Manager or the Program Manager icon 
on the screen.

To move through Setup with a mouse, just click to choose a field or button. To move through Setup 
with the keyboard, use hot keys or press ENTER to choose the highlighted button. A hot key is an 
underlined letter in each text label or button; pressing it activates the field or chooses the button. If the 
cursor is in a text entry field, hold down the ALT key while you press the hot key. Alternatively, you can 
press TAB to cycle through all the fields and buttons on the screen. To summarize:

Pressing... Does This...

Hot Key Chooses the button or field

ALT+Hot Key Chooses the button or field when the 
cursor is in a text input field

ENTER Chooses the selected button

TAB Moves highlight from one button or field 
to the next

SHIFT+TAB Cycles through buttons and fields in 
reverse

You have now installed Recipes for Windows. You'll enjoy all the new and exciting ways you can 
organize your kitchen and your ways of cooking. You'll probably want to try out the new restaurant 
feature. Tag a few of your favorite restaurants and see how easy it is to locate those restaurants when 
you are sick of cooking and ready for a night on the town. You can also generate a report listing your 
favorite restaurants. Or drag a recipe from one cookbook to another. Refer to Chapter 10, "Tracking 
Restaurants" and Chapter 7, "Whipping Up a Recipe" for more information.

Important: Recipes for Windows automatically loads SHARE.EXE to your AUTOEXEC.BAT file 
during Setup if it is not already there. If you go to open Recipes and receive an error message telling 
you it must be loaded:

1.      Use any text editor to open your AUTOEXEC.BAT file located in your root directory.
2.      Add C:\DOS\SHARE.EXE to the first line of the file where C:\ is the root directory.
3.      Save the file.
4.      Exit the text editor and Windows (if it is still open).
5.      Restart your machine.



The Right Mouse Button

In Recipes for Windows as in many other Windows applications, you can use the right mouse button 
to pop-up a menu. The menu varies according to the view that you are using.

In Recipes, no matter which view you select, certain parts of the window or screen will always remain 
the same.



The Tool Bar

Recipes for Windows displays the Tool Bar across the top of the screen. The buttons are arranged in 
groups.

The first four icons are associated with the four browsers or views used by the program 
(Recipes, Coupons, Pantry, and Restaurant). When you click on one of these icons, Recipes 
for Windows displays the browser in columns of information displayed in a spreadsheet-like 
format.

The next four icons provide shortcuts for completing common actions. Clickings on these icons 
allow you to add, delete, find (search), and print.

The next two icons provide shortcuts while using the Recipes view or browser and are available 
only when the recipe browser is active. Click on the refrigerator to determine what you can cook 
based upon what you have in your refrigerator (also referred to as the Refrigerator Search). Use 
the Shopping Cart when youre ready to create your shopping list.

The next icon is the notebook.    Use when hen you want to add or edit notes or directions for 
a specific recipe or restaurant.

Click on the sad-faced icon to delete expired coupons or the calendar icon when you need to 
refer to this months calendar. Use the runner icon when you want to run another program or 
the calculator icon when you need to calculate something quickly.

The last three icons allow you to cascade your windows, tile your windows, or get on-line help.

If you do not want the Tool Bar displayed, from the Options menu, uncheck Tool Bar.



Date/Time Bar

Recipes displays the Date/Time Bar (showing the current date and time on your system) directly 
below the Tool Bar. If you do not want the Date/Time Bar displayed, from the Options menu, uncheck 
Date/Time Bar.



Main Status Bar

Recipes displays the main status bar across the bottom of your window. If you click one of the 
browser icons or a menu option with the left mouse button and hold it, a description displays in the 
main status bar. If you click the right mouse button and slowly drag it across the Tool Bar, a 
description of each icon displays in this area as well.

If you do not want the Main Status Bar displayed, from the Options menu, uncheck Main Status Bar.

NOTE: It is recommend that the status bar is always visible because Recipes for Windows uses it to 
display status information during lengthy process.



Browser Status Bar

Recipes displays the browser status bar across the bottom of the current view.

If you do not want the browser Status Bar displayed, from the Options menu, uncheck Browser Status 
Bar.

NOTE: It is recommend that the browser status bar is always visible because Recipes for Windows 
uses it to display important information.



Calendar

To view the current months calendar, click the Calendar icon on the Tool Bar or from the Options 
menu, choose Calendar.

The calendar always displays on top of the current window. To close the calendar, click once on the 
dash (-) in the upper left corner or the Calendar icon on the Tool Bar.



Preferences

Preferences allow you to set Recipes up the way you like to work. For example, you decide how you 
want quantities displayed, and what color youd like to use for tagged items. Additionally, you can tell 
Recipes which other applications you use frequently. After these are set up here, run these programs 
as described in the following section.

To set preferences

1. From the Options menu, choose Preferences. Recipes displays the following dialog box.

Run Options. Recipes defaults to Control Panel, Clipboard, Notepad, and File Manager. If there 
are other programs you use more frequently, change any or all of the four labels and EXE names 
to match those programs or applications.

NOTE: You can get the EXE names and the path by highlighting the program application you use 
(click your left mouse button once on the applications icon) and, from the Program Managers File 
Menu, choosing Properties. The program (EXE) displays in the Command Line field.

Browser Options. Select the color to use for tagged recipes, coupons, pantry items, and 
restaurants. If you want to use the custom browser scroll bars, choose Use Custom Browser 
Scroll Bars.
Display Quantity As. Recipes defaults to Fraction. If you would rather display quantities as 
decimals, choose Decimal.



Run

Once you have set up your Preferences, use Run to do just that -- run the programs you most 
frequently use.

To run a different application
1.      Click the Runner icon on the Toolbar, from the File menu, choose Run or press CTRL and 

then R.
2.      Choose the program you wish to run.
3.      Choose whether you want the application to run Normally, Minimized, or Maximized.
4.      Click OK.
5.      If you want to run a program not displayed on the Run dialog box.    Type the EXE name and 

the entire path if the application is not already in the path or click the Browse button and scroll 
through your directories until you locate the program you want to run. The next time you look 
at the Run dialog box, this program displays in the pull down list eliminating the need to 
retype it again.



Manage User Lists

User lists are fields in the dialog box that contain items you can select or add new items.    Recipes 
provides you with some system defined lists. Recipes distinguishes these with a __ preceding and 
following the name, such as __State__ and cannot be deleted or renamed.

When adding an item, such as a recipe, coupon, pantry item, or restaurant, if you type an entry in a 
user list field (any fields that have drop down list of items where you can select or add a new item), 
Recipes automatically adds this entry to the appropriate user list. If you delete an item from a user list 
that is used, for example, in a recipe, Recipes deletes it from the user list, but not from that individual 
recipe.

Use the Manage User List option for changing and customizing the existing items in the system 
defined lists to match your needs. Since each user list stores between 200 and 500 items, it is helpful 
if you delete the items you dont use on a regular basis from each list.

To add items to the user list
1.      From the Options Menu, choose Manage User Lists.
2.      Select the user list you wish to customize by choosing from the Available User Lists. You are 

now ready to add items to your user list.
3.      Choose Add Item.
4.      Type the name of the item and click OK.

A special User List for shopping list and add ingredients.
When adding items to prepare a new shopping list or adding ingredients to a new recipe, it's nice 
to have a list of items that you can select over and over again without having to retype it each 
time.    Recipes for Windows 2.0 provides you with a special user list called "__Ingredient 
Name__" where you can define the items that you need most frequently.    To define these items:
1.      From the Option menu, select Manage User Lists.

Recipes displays the Manage User Lists dialog box.
2.      From the Available User List, select __Ingredient Name__.

Several predefined items are displayed in the User List Items list box. You can add, edit or 
delete them using the Add, Edit and Delete buttons.

3.      Press Close.
These items will be available in the Name field when you add or edit ingredient from the 
Shopping List or Recipe dialogs.

NOTE: Unlike other User Lists in the program, you can only add, edit or delete items in the 
__Ingredient Name__ list from the Manage User Lists option.    In other User Lists you also have to 
use the Manage User Lists option to edit or delete items, but you can add new items to list when you 
use the list in other dialog boxes.



Calculator

The calculator provided with Recipes is the standard Windows calculator that is also a part of the 
Windows Accessories Program Group. The calculator is great to use when you need to calculate 
something quickly.

To use the calculator
1.      Click the Calculator icon or from the File menu, choose Calculator.
2.      The calculator displays in standard mode. If for some reason you wish to use it in scientific 

mode, from the View menu, choose Scientific.
3.      Make your calculations as you would using any manual calculator.



Cascade Windows

Choosing the Cascade Windows icon next to the Calculator icon on the Toolbar or choosing Cascade 
from the Windows menu allows you to arrange all open windows in an overlapping pattern on the 
desktop. This allows you to see the title bars of all open windows. Click anywhere in a window to 
make it active.

NOTE: The keyboard shortcut for cascading windows is SHIFT+F5.



Tile Windows Horizontally

Choosing the Tile Windows icon on the Toolbar or choosing Tile Horizontal from the Windows menu 
allows you to arrange all windows in a non-overlapping pattern on the desktop. This allows you to see 
partial contents of all open windows. Maximize any window to display more of its contents.

NOTE: The keyboard shortcut for tiling windows horizontally is SHIFT+F4.



Tile Windows Vertically

Choosing the Tile Windows icon on the Toolbar or choosing Tile Horizontal from the Windows menu 
allows you to arrange all windows in a non-overlapping pattern on the desktop. This allows you to see 
partial contents of all open windows. Maximize any window to display more of its contents.

NOTE: The keyboard shortcut for tiling windows vertically is SHIFT+F3.



Split Window

Choosing the Splitcommand from the Windows menu allows you to splits the active window into two 
panes going left to right.

This command is available when the Recipe View is open.



Arrange Icons

You can arrange individual windows in your workspace by dragging them with the mouse.

You can also arrange individual windows in your workspace using the Move and Size commands on 
the Control menu.

The Arrange Icons command arranges all the minimized windows.    Available only when a minimized 
window is active.

All icons will be arranged horizontally from left to right at the bottom of the application window.



New Window

Creates an additional window for the active view so you can view different parts of your data 
simultaneously.

You can open more than one new window for a given document; the maximum number is limited only 
by the available memory.

The title bar shows the original document name followed by a colon and the number of the new 
window.    For example, the second window of your RECIPE view would be named RECIPE:2.



 Close Window

Closes the currently open window.



 Close All

Closes all currently open windows.



 1,2,3,...9 Window

List the currently open windows at the bottom of the Window menu.    Choosing a window switches to 
it.

A check mark is displayed next to    the active window.

If more than nine windows are open, the More Windows command appears at the end of the list.    
Choose it to see a list of all open windows.



 More Windows

Displays a list of open windows and switches to the window you choose.

This command appears on the Window menu only when you have more than nine windows open.



 Weights and Measurement

The Weights and Measurement dialog box displays information about U.S. and European units of 
measurement.



 Can Sizes

The Can Sizes dialog box displays common information on can sizes.



 Food Quantities

Do you have trouble deciding how much of various foods to take to a picnic or gathering.    Use 
the following guidelines taken from a USDA handbook to serve 25, 50 and 100 persons.

            25           50           100
FOOD Servings Servings Servings

Sandwiches:
Bread 50 slices 100 slices 200 slices
Butter 1/2 pound 3/4 to 1 pound 1 1/2 pound
Mayonnaise 1 cup 2 to 3 cups 4 to 6 cups
Mixed Filing 1 1/2 quarts 2 1/2 to 3 quarts 5 to 6 quarts
(meat, eggs,fish)
Mixed Filing 1 quart 1 3/4 to 2 quarts 2 1/2 to 4 quarts
(sweet-fruit)
Lettuce 1 1/2 heads 2 1/2 to 3 heads5 to 6 heads

Meat, Poultry, or Fish:
Wieners (beef) 6 1/2 pounds 13 pounds 25 pounds
Hamburger 9 pounds 18 pounds 35 pounds
Turkey or Chicken 13 pounds 25 to 35 pounds50 to 75 pounds
Fish, large whole 13 pounds 25 pounds 50 pounds
Fish, fillets or steaks 7 1/2 pounds 15 pounds 30 pounds

Salads, Casseroles:
Potato Salad 4 1/4 quarts 2 1/4 gallons 4 1/2 gallons
Scalloped Potatoes 4 1/2 quarts 8 1/2 quarts 17 quarts
Spaghetti 1 1/4 gallons 2 1/2 gallons 5 gallons
Baked Beans 3/4 gallon 1 1/4 gallons 2 1/2 gallons
Jello Salad 3/4 gallon 1 1/4 gallon 2 1/2 gallons

Ice Cream:
Brick 3 1/4 quarts 6 1/2 quarts 12 1/2 quarts
Bulk 2 1/4 quarts 1 1/2 gallons 2 1/2 gallons

Beverages:
Coffee 1/2 pound and 1 pound and 2 pounds and

1 1/2 gal. water 3 gal. water 6 gal. water
Tea 1/12 pound and 1/6 pound and 1/3 pound and

1 1/2 gal. water 3 gal. water 6 gal. water
Lemonade 10 to 15 lemons20 to 30 lemons40 to 60 lemons

1 1/2 gal. water 3 gal. water 6 gal. water

Desserts:
Watermelon 37 1/2 pounds 75 pounds 150 pounds
Whipping Cream 3/4 pint 1 1/2 to 2 pints 3 pints



 Substitutions

If you don't have Substitute

1 cup cake flour 1 cup minus 2 tbspoon all purpose flour
1 tbspoon cornstarch (for thickering) 2 tbspoon all purpose flour
1 teaspoon baking powder 1/2 teaspoon cream of tartar + 1/4

teaspoon baking soda
1 package active dry yeast 1 cake compressed yeast
1 cup sugar 1 cup packed brown sugar
1/4 cup fine dry bread crumbs 3/4 soft bread crumbs
1 cup honey 1/4 cup sugar + 1/4 cup liquid
1 cup corn syrup 1/4 cup sugar + 1/4 cup liquid
1 square (1ounce) unsweetned chocolate 3 tbspoon unsweetened cocoa powder

1 tbspoon shortening or cooking oil
1 cup whipping cream 2 cups whipped desert topping
1 cup buttermilk 1 tbspoon lemon juice or vinegar + 

enough whole milk to make one cup
1 cup whole milk 1/2 cup evaporated milk + 1/2 cup water
1 cup light cream 1 tbspoon melted butter + enough milk(One 
cup).
2 cups tomato sauce 3/4 cup tomato paste + 1 cup water
1 cup tomato juice 1/2 cup tomato sauce + 1/2 cup water
1 small onion chopped (1/3 cup) 1 teaspoon onion powder
1 teaspoon dry mustard (in cooked mixtures) 1 tbspoon prepared mustard



 Ingredient Equivalents

Amount Before Approximate Measure
Food Preparation After Preparation

Cereals:
Macaroni 1 cup (3 1/2 oz.) 2 1/2 cups cooked
Noodles 3 cups (4 oz.) 3 cups cooked
Spaghetti 8 oz. 4 cups cooked
Long Grain Rice 1 cup (7 oz.) 3 cups cooked
Quick Cooking Rice 1 cup (3 oz.) 2 cups cooked
Popcorn 1/3 to 1/2 cup 8 cups cooked

Crumbs:
Bread 1 slice 3/4 cup soft crumbs
Saltine Crackers 14 crackers 1/2 cup finely crushed
Graham Crackers 7 squares 1/2 cup finely crushed
Ginger Snaps 7 cookies 1/2 cup finely crushed
Vanilla Wafers 11 cookies 1/2 cup finely crushed

Fruits:
Apples 1 medium 1 cup sliced
Bananas 1 medium 1/3 cup mashed
Lemons 1 medium 3 tblspoon juice
Limes 1 medium 2 tblspoon juice
Oranges 1 medium 1/4 to 1/3 tblspoon juice
Peaches,Peers 1 medium 1/2 cup sliced
Strawberries 4 cups whole 4 cups sliced

Vegetables:
Cabbage 1 pound (1 small) 5 cups shredded
Carots 1 pound (6 to 8 medium) 3 cups shredded
Celery 1 Stalk 1/2 cup chopped
Green Beans 1 pound (4 cups) 2 1/2 cups cooked
Green Peppers 1 large 1 cup chopped
Lettuce 1 medium head 6 cups torn
Mushrooms 1/2 pound (3 cups) 1 cup cooked
Onions 1 medium 1/2 cup chopped
Potatoes 3 medium 2 cups cubed
Spinach 1 pound 12 cups torn
Tomatoes 1 medium 1/2 cup chopped

Miscellaneous:
Cheese 4 ounces 1 cup shredded
Whipping Cream 1 cup 2 cups whipped
Ground Beef 1 pound raw 2 3/4 cups whipped
Cooked Meat 1 pound raw 3 cups chopped
Chicken Meat 1 pound 3 cups chopped
Chicken Breasts 1 1/2 pound 2 cups chopped



 Cooking Terms

Al Dente Describes spaghetti or other pasta that is cooked.
Baste To moisten foods during cooking with pan drippings or a 

special sauce in order to add flavor and prevent drying.
Beat To make a mixture smooth by briskly whipping or stirring it with a spoon,
Blanch To partially cook fruits, or vegetables, in boiling water or steam to prepare for canning.
Blend To process foods in an electric blender.
Braise To cook food slowly in a small amount of liquid in a thightly covered pan in the 
oven.
Coat To evenly cover foods with crumbs, flour, or a batter.
Crisp-tender Describes vegetables cooked until they're just tender but still somewhat crisp.
Cut in To combine shortening with dry ingredients using a pastry blender or two knives.
Dash An ingredient measure that equals about half of 1/8 teaspoon.
Dissolve To stir a dry substance in a liquid, such as sugar in coffee, until 

no solids remain. Heating the liquid is sometimes necessary.
Dollop To place a spoonful of a semi-liquid food, such as sour cream, on top of another 
food.
Fillet To cut lean meat or fish into pieces without bones.
Flake To brake food gently into small pieces.
Fold To gently mixed ingredients, using a spatula, Turn the bowl frequently for even 
distribution.
Garnish To add visual appeal to finished food by decorating it with small 

pieces of food or edible flowers.
Glaze To brush a mixture on a food to give it a glossy appearance or a hard finish
Grind To use a food grinder or food processor to cut food such as meat

or fruit into fine pieces.
Knead To work dough with the heel of your hand in a presssing and folding motion.
Melt To heat a solid food, such as margarine or sugar, until it is liquid.
Mix To stir, usually with a spoon, until ingredients are thoroughly combined.
Mull To slowly heat beverages, such as red wine or cider, with spices and sugar.
Panbroil To cook meats in a skillet without added fat, removing any fat as it accumulates.
Panfry To cook meats, poultry, or fish in a small amount of hot fat.
Partially Set Describes a gelatin mixture chilled until its consistency resembles unbeaten egg 
whites
Peel To remove the outer layer or skin from fruit or vegetable.
Pit To remove the seed from a piece of fruit.
Preheat To heat an oven to the recommended temperature before cooking in it.
Process To blend a food in a food processor.
Puree To chop food into a liquid or heavy paste, usually in a blender, food processor, or 
food mill.
ReduceTo boil liquids such as sauces so that some of the liquid evaporates, thickening the 
mixture.
Roast To cook meats, uncovered, in the oven.
Sauté To cook or brown food in a small amount of hot fat.
Score To cut narrow grooves or slits partway through the outer surface of a food.
Shuck To remove the shells or husks from food such as oysters, clams, or corn.
Sift To put one or more dry ingredients through a sifter or sieve to incorporate 

air and break up any lumps.
Skim To remove melted fat or other substances from the surface of a liquid.
Stew To cook food in liquid for a long time until tender, usually in a covered pot.
Stir To mix ingredients with a spoon in a circular or figure-8 motion until combined.
Whip To beat food lightly and rapidly using a wire whisk, or electric mixer to increase its 
volume.



Using Layouts

You can select a layout that has already been created or define one from scratch.

To select an existing layout
1.      From the Layout menu, choose Select Layout.    The Select Layout dialog box contains a list 

of the available layouts previously created for the current view. It also displays the name of 
the current layout and the default layout for your information.

2.      Select a layout from the Available Layouts list.
3.      If you want this to be the default layout, choose Use as new default. This option assigns a 

default layout to a view that can be used for a layout that you use most frequently.
4.      Click OK.

See Also:

Default Layout



Default Layout

The default layout is one you have selected and assigned to be the default layout from the Select 
Layout dialog box described in the previous section.

To use the default layout
1.      From the Layout menu, choose Use Default Layout.

The layout you checked displays as the current layout. This option is grayed when no layout has been 
selected as the default.



Manage Layouts

The Manage Layouts option allows you to add, edit, delete, or duplicate layouts. The Manage Layouts 
dialog box displays the name of the current layout, the name of the default layout, if one is selected, 
and a list of available layouts. Each view contains its own separate list of available layouts.

To add or create a layout
1.      From the Layout menu, choose Manage Layouts.
2.      Choose Add. Recipes displays the Add Layout dialog box.
3.      Type the name of the layout in the Name box.
4.      From the Available Columns list, select the fields you want to display in the layout by 

highlighting them.
5.      There are three ways which you can add fields from the Available Columns to the Selected 

Columns.
(1) Choose Insert to move the field from the Available Columns list to just above the 

highlighted field (if there is one) in the Selected Columns list. If you want to move the field 
from the Available Columns list to the bottom of the Selected Columns list, choose 
Append.

(2) Double-click the field you wish to select from the Available Columns list.
(3) Drag and drop. To do this select the field you want, press and hold the left mouse button, 

and then move the mouse to the location in the Selected Columns where you want the 
selected field to be inserted. Release the left mouse button.

6.      You can change the order of the fields in the Selected Columns using drag and drop. To do 
this select the field you want, press and hold the left mouse button, and then move the mouse 
to the location in the Selected Columns where you want the selected field to be inserted. 
Release the left mouse button.

7.      To modify any of the Selected Columns, select the column you want to change. That 
columns attributes display in the Column Options for Field section of the dialog box.
(1) Change the header by selecting the field you wish to change in the Selected Column list. 

This same field is also displayed in the Header field. Position the cursor in the Header 
field and type a new name, position the mouse cursor on any field in the Selected 
Column list and click on the left mouse button once. The new header from the Header 
field now replaces the old field name in the Selected Columns and in the heading in the 
browser.

(2) Change the column width by typing over the number displayed.
(3) Select a different column justification if you wish.

8.      Choose Display Bitmap as Text to display the field as a bitmap or as text.
9.      Choose Cell Font to select the Font, Font Style, Size, and Color for all cells or fields. The cell 

font can be changed later by choosing Cell Font from the Layout menu.
10. Choose Header Font to select the Font, Font Style, Size and Color for all headers. The 

header font can be changed later by choosing Header Font from the Layout menu.
11. Click OK. Recipes redisplays the Manage Layout dialog box with the name of the layout you 

have just created highlighted in the available layouts list box.
12. Choose Use selected layout on exit to view your information using the new layout and click 

OK.

To edit a layout
1.      Choose Edit or double-click a layout in the Available Layouts. Recipes displays the Edit 

Layout dialog box.

See the "Edit Layout" section following for more details on editing a layout.

To delete a layout
1.      Highlight the layout you wish to delete and choose Delete.
2.      At the "Delete Selected Layout?" prompt, choose Yes.

NOTE: If the highlighted layout is the current layout, the Delete button is grayed.



To duplicate a layout
1.      Highlight the layout you wish to duplicate and choose Duplicate. This creates a new layout 

based on the selected layout. After duplicating the layout, make minor changes as needed to 
the new layout.



Edit Layout
1.      From the Layout menu, choose Edit Layouts.
2.      Modify the layout as needed. Refer to procedures on adding or creating a layout on page 21 

for details on each field in the dialog box.
3.      Add fields from the Available Columns to the Selected Columns as described in the previous 

section.
4.      Remove fields from the Selected Columns by highlighting the field you wish to remove and 

either (1) choosing Remove, (2) double-clicking the field in the Selected Columns list you 
wish to remove, or (3) dragging and dropping the field from the Selected Columns to the 
Available Columns list..

5.      To modify any of the Selected Columns, select the column you want to change. That 
columns attributes display in the Column Options for Field section of the dialog box.
(1) Change the header by selecting the field you wish to change in the Selected Column list. 

This same field is also displayed in the Header field. Position the cursor in the Header 
field and type a new name, position the mouse cursor on any field in the Selected 
Column list and click on the left mouse button once. The new header from the Header 
field now replaces the old field name in the Selected Columns and in the heading in the 
browser.

(2) Change the column width by typing over the number displayed.
(3) Select a different column justification if you wish.

6.      Choose Display Bitmap as Text to display the field as a bitmap or as text.
7.      Choose Cell Font to change the Font, Font Style, Size, and Color for all cells or fields. The 

cell font can be changed again later by choosing Cell Font from the Layout menu.
8.      Choose Header Font to change the Font, Font Style, Size and Color for all headers. The 

header font can be changed again later by choosing Header Font from the Layout menu.
9.      Click OK.



Insert column

1. From the Layout menu, choose Insert Column.

NOTE: If you place your cursor in the section of the browser where you want the new column and 
press the right mouse button, Recipes displays the Layout menu.

2. Select the new field to be inserted from the Available Fields list. The Available Fields list contains 
all the fields available in the database you are viewing. The field highlighted in the Available 
Fields displays in the Header field.

3. If you wish, modify the Header by typing a new name over the one displayed.

4. If you want to change the column width, type a new number over the one displayed.

5. If you wish, change the justification to Left, Center, or Right.

6. Select Insert Position First, Before Selection, After Selection, or Last. This option allows you to 
insert a new field into the layout at any position you want. The position where the new column will 
be inserted is relative to column you selected in the layout prior to choosing the Insert Column 
option.

If you select First, the new field will be inserted in the first column of the layout.
If you select Before Selection, the new field will be inserted one column before the column you 
selected prior to choosing the Insert Column option.
If you select After Selection, the new field will be inserted one column after the column you 
highlighted prior to choosing the Insert Column option.
If you select Last, the new field will be inserted in the last column of the layout. This option is 
grayed when the number of columns in the layout is 100.

7. Click OK.



Format column

1. From the Layout menu, choose Format Column.

2. Select the field you want to format from the Available Fields list. The field that is highlighted in the 
Available Fields will be displayed in the Header field.

3. If you wish, modify the Header by typing a new name over the one displayed.

4. If you want to change the column width, type a new number over the one displayed.

5. If you wish to change the justification, choose Left, Center, or Right.

6. Click OK.

Recipes for Windows gives you the ability to globally format or change more than one column at a 
time.

1. Select and highlight the columns requiring change by moving the cursor to the column heading 
until the cursor turns to a down arrow      () and pressing the left mouse button.

2. Hold the SHIFT (to choose successively) or CTRL (to choose randomly) key and choose the 
other columns you want to change.

3. Follow the procedures outlined above for formatting a column.

NOTE: The only attributes that will change are the ones you modified.    For example, if the width is 
not specified it will not change.



Remove column

The Remove Column option removes the highlighted column(s) from the current browser layout. Save 
the layout to make the change permanent by choosing the Save Layout option from the Layout menu. 
If you forget to save the layout, Recipes will ask whether or not you want to save the layout when you 
exit that particular view or browser.

To remove a column
1.      Select the column(s) you wish to remove.
2.      From the Layout menu, choose Remove Column.



Save Layout

If you modify a    layout and you want the changes to be permanent, use the Save Layout option to 
save the new changes. This option is grayed when the layout has not been modified.

To save a layout you have created or changed
1.      From the Layout menu, choose Save Layout.



Selecting the Browser

You can select a single browser or multiple browsers to view. Each browser displays the module or 
view in the title bar across the top and a status bar across the bottom. The status bar displays:

The layout being used for that module.
The sort order for that module.
The tag/untag icon to give you the ability to tag or untag an item in that browser at will.
The untag all icon to give you the ability to untag all tagged items at will.
The tag up icon to assist you in locating the next tagged item above the current item selected.
The tag down icon to assist you in locating the next tagged item below the current item selected.
The number of items contained in that view and the number of those items which are tagged.

To select a browser to view
1.      Click the icon on the Tool Bar representing the module or browser you wish to view, or from 

the View menu, choose the module or browser to view.
2.      Repeat the above step to open a different or multiple browsers.

Recipes displays the browser selected.



Sorting Within the Browser

Once you view the browser, if you decide youd like to view the items in a different order, for example, 
by Group instead of by Name, changing the sort order is easy.

To sort by a different field
1.      Move your cursor to the column heading by which you want to sort. The cursor changes to a 

down arrow ().
2.      Double-click the column heading. This creates an entry in the Available Sorts list of the Sort 

dialog box so you can use this sort again in the future.

OR

From the Layout menu, choose Select Sort. Recipes displays the Select Sort Dialog box indicating 
the current sort order.

3.      Select a different sort order from the list of Available Sorts.
4.      If the field by which you wish to sort is not displayed, choose Add Sort. Recipes displays the 

Add Sort dialog box which contains the fields that have not been sorted.
5.      Select the field by which you wish to sort from the Sort On list and click OK. Recipes returns 

to the Select Sort Dialog box.

NOTE: If the Available Sorts contains a field on which you know youll never want to sort, choose 
Delete Sort. At the "Delete selected sort?" prompt, choose Yes.

6.      With the field on which to sort highlighted, either double-click or click OK.



Cell Fonts

Recipes is so flexible and easy to customize according to the way you work, that it even provides you 
with the ability to change the fonts in the columns (or header) and in the individual fields (or cells).

To change the field (or cell) font
1.      From the Layout menu, choose Cell Font. Recipes displays the Font dialog box.
2.      Select the Font, Font Style, Size, and Color you wish to display in the cells of that browser.
3.      Click OK.



Header Fonts

Recipes is so flexible and easy to customize according to the way you work, that it even provides you 
with the ability to change the fonts in the columns (or header) and in the individual fields (or cells).

To change the column (or header) font
1.      From the Layout menu, choose Header Font. Recipes displays the Font dialog box.
2.      Select the Font, Font Style, Size, and Color you wish to display in your column headings.
3.      Click OK.



Copying to the Clipboard

Recipes, like many other Windows applications, allows you to use the same keyboard commands to 
copy and paste from one field to another.

To copy and paste information from one field into another
1.      Place your cursor in the field of the dialog box from which you want to copy the information.
2.      Press CTRL and then C, or from the Edit menu, choose Copy.
3.      Place your cursor in the field of the dialog box to which you want to copy the information and 

press CTRL and then V. This pastes the information from the clipboard into the field.



Refreshing the Browser

On occasion, the information in the current can become out of date as you are adding or deleting 
information.

To refresh your window
1.      Press F5 or from the Window menu, choose Refresh Window.



Page Setup

Before you print, the first thing you should do is to define how you want the page(s) to look when it 
prints.

To set up your page
1.      From the File menu, choose Page Setup. Recipes displays the Page Setup dialog box.
2.      Customize the page according to the following table.

If you choose 
Header

If you choose Title If you choose 
Footer

(1) Choose 
to print it 
on:

First Page 
Only

All Pages
No Page

(1) Choose to 
print it on:

First Page 
Only

All Pages
No Page

(1) Choose 
to print it 
on:

First Page 
Only

All Pages
No Page

(2) Choose 
Font. 
Recipes 
displays 
the Font 
dialog 
box.

(3) Select the 
Font, 
Font 
Style, 
Size, and 
Color you 
want to 
print and 
click OK.

(2) Choose 
Font. 
Recipes 
displays 
the Font 
dialog 
box.

(3) Select the 
Font, Font 
Style, 
Size, and 
Color you 
want to 
print and 
click OK.

(2) Choose 
Font. 
Recipes 
displays 
the Font 
dialog 
box.

(3) Select 
the Font, 
Font 
Style, 
Size, and 
Color you 
want to 
print and 
click OK.

(4) Type the 
header in 
the Left 
Justified, 
Centered, 
or Right 
Justified 
fields 
according 
to how 
you want 
the 
header 
displayed 
on the 
page.

(5) Choose 
one or 
more of 
the 

(4) Type the 
title in the 
Left 
Justified, 
Centered, 
or Right 
Justified 
fields 
according 
to how 
you want 
the title 
displayed 
on the 
page.

(5) Choose 
one or 
more of 
the 
following if 

(4) Type the 
footer in 
the Left 
Justified, 
Centered
, or Right 
Justified 
fields 
according 
to how 
you want 
the footer 
displayed 
on the 
page.

(5) Choose 
one or 
more of 
the 
following 



following 
if you 
want to 
include 
any of the 
following 
in the 
header:

· Date to 
include 
the 
current 
date

· Time to 
include 
the 
current 
time

· Page # to 
include 
the page 
number 
sequentia
lly

· File 
Name to 
include a 
designate
d file 
name

· Layout to 
incorporat
e the 
layout of 
the 
browser

· Sort to 
sort in the 
same 
order as 
the 
browser

you want 
to include 
any of the 
following 
in the title:

· Date to 
include 
the 
current 
date

· Time to 
include 
the 
current 
time

· Page # to 
include 
the page 
number 
sequential
ly

· File Name 
to include 
a 
designate
d file 
name

· Layout to 
incorporat
e the 
layout of 
the 
browser

· Sort to 
sort in the 
same 
order as 
the 
browser

if you 
want to 
include 
any of 
the 
following 
in the 
footer:

· Date to 
include 
the 
current 
date

· Time to 
include 
the 
current 
time

· Page # to 
include 
the page 
number 
sequentia
lly

· File 
Name to 
include a 
designate
d file 
name

· Layout to 
incorpora
te the 
layout of 
the 
browser

· Sort to 
sort in 
the same 
order as 
the 
browser

(6) Choose 
Print 
Header 
Separatio
n Line to 
include a 
line 
between 
the 
header 
and the 
text.

(6) Choose 
Print 
Footer 
Separatio
n Line to 
include a 
line 
between 
the 
header 
and the 
text.

3.      Type the Top, Bottom, Left, and Right margins.
4.      Click OK.



Print Preview

Now that you've set up your page, before you print, you might want to preview how the printout looks 
before you actually send the information to the printer and waste any printing time or paper.

To preview your printout
1.      From the File menu, choose Print Preview. Recipes displays the first page.
2.      Choose:

· Print to go ahead and print. Refer to the next section for details on printing.
· Next Page to view the next page.
· PrevPage to view the previous page. This option appears grayed out if there are no 

previous pages to display.
· Two Page to view two pages side by side.
· One Page to view a single page at a time. This option only appears when two pages are 

displayed.
· Zoom In to view the page displayed closer.
· Zoom Out to view the page displayed further away. This option appears grayed out if the 

page is displayed as far away as it goes.
· Close to exit the print preview.



Print Setup

Before you actually print, if any of the following apply, proceed through the print setup option before 
printing.

Ö You want to send your printout to a different printer other than the one displayed

Ö You want the printout to print landscaped (sideways)

Ö You want to use legal paper (instead of the standard 8 1/2 x 11)

Ö You want to indicate a different paper tray to use

To change the print setup
1.      From the File menu, choose Print Setup. Recipes displays the Print Setup dialog box.

· To change the printer, choose Specific Printer and select the printer to where you want to 
send your printout from the list.

· To change the orientation from portrait (vertical or up and down), choose Landscape.
· To change the paper size to use, select the size you desire from the Size list.
· To change to a different paper tray, choose from the Source list.

For other print options, refer to your Windows 3.1 documentation.



Printing

Once you've set up and previewed what you want to print, you are now ready to go ahead and print.

To print from the browser
1.      From the File menu, choose Print. Recipes displays the Print dialog box.
The dialog box displays the printer to where the printout will be sent.
2.      Choose All to print all pages or Pages to indicate which pages to print.

NOTE: If you choose Pages, enter the page number range to print; for example, 1 to 3.

3.      Type the number of Copies you want if you desire more than 1 copy.
4.      If you are printing more than one set and you want the sets collated (as opposed to getting 

all the first pages together, all the second pages together, etc., check Collate Copies.
5.      Click OK.



Opening Cookbooks

1. From the Cookbook menu, choose Open Cookbook or, with the recipe view (or browser) open, 
and the Show Cookbooks option is checked from the Cookbook menu, double-click the cookbook 
you wish to open.

NOTE: To open a new window with a different cookbook displayed, press CTRL and then double click 
on the selected cookbook.

The Open Cookbook dialog box displays the currently opened cookbook along with other available 
cookbooks.

2. From the Available Cookbooks list, select the cookbook to open.

3. Click OK.



Showing Cookbooks

The Show Cookbooks option allows you to decide whether or not the cookbooks display as part of the 
Recipe view (or browser). A check mark to the left of the Show Cookbook option indicates cookbooks 
display. Recipes defaults to viewing the cookbooks.

To turn the show cookbooks option on or off
1.      From the Cookbook menu, choose Show Cookbook.



Managing Cookbooks

From the Manage Cookbooks option, you can create or add a cookbook, change the settings of a 
cookbook (such as renaming it), or delete a cookbook. Recipes lists these three capabilities as 
specific options under the Cookbook menu.



Create Cookbook

To create or add a cookbook
1.      From the Cookbook menu, choose Manage Cookbooks.
2.      Choose Create.
3.      Type the name of the cookbook you are creating in the Cookbook Name field.
4.      If there is a database file you wish to associate with the cookbook, type the name of the file 

in the File Associated With Cookbook (optional) field. Otherwise, Recipes automatically 
creates a default database file.

5.      If you do not remember the file name, choose Browse and locate the file. Double-click the 
file or highlight the file and click OK.

6.      Choose Open selected Cookbook on exit to open the cookbook after exiting the dialog box.
7.      Click OK.



Cookbooks Settings

1. From the Cookbook menu, choose Manage Cookbooks and then choose Settings.

OR

From the Cookbook menu, choose Cookbook Settings.

2. If you wish to rename the cookbook, type a new name in the Cookbook Name field.

3. If there is a different database file associated with the cookbook, type the name of the file in the 
File Associated With Cookbook (optional) field.

4. If you do not remember the file name, choose Browse and locate the file. Double-click the file or 
highlight the file and click OK.

5. Choose Open selected Cookbook on exit to open the cookbook after exiting the dialog box.

6. Click OK.



Delete Cookbook

1. From the Cookbook menu, choose Manage Cookbooks and then choose Delete.

OR

From the Cookbook menu, choose Delete Cookbook.

2. At the prompt, "Delete selected Cookbook? All related files will be deleted!" choose Yes.

3. Click OK.



List Fonts

Recipes provides you the opportunity to change the font, font style, size, and color in the title bar of 
the Cookbook view or in the list displaying the cookbooks.

To change the font in the list of cookbooks
1.      From the Cookbook menu, choose Cookbooks List Font.
2.      Choose the font, font style, point size, and color of the font.
3.      Click OK.



Title Fonts

Recipes provides you the opportunity to change the font, font style, size, and color in the title bar of 
the Cookbook view or in the list displaying the cookbooks.

To change the font in the title bar
1.      From the Cookbook menu, choose Cookbooks Title Font.
2.      Choose the font, font style, point size, and color of the font.
3.      Click OK.



Refrigerator Search

Its 6:00 p.m. and youre home after a long day at the office. The kids are outside playing and youre 
now faced with the dilemma of figuring out what to cook for dinner. Recipes simplifies that dilemma 
with the Refrigerator Search feature.

To conduct a refrigerator search
1.      Open the Recipes module by clicking the recipe icon on the Tool Bar, by choosing Recipe 

from the View menu, or by pressing and holding CTRL and then I.
2.      From the Edit menu, choose Refrigerator Search or click the refrigerator icon on the Tool 

Bar. Recipes displays the Refrigerator Search dialog box.
3.      Enter up to four items in your refrigerator in the Ingredients fields.
4.      In the Search Using area of the dialog box, choose AND if you want to conduct the search 

using all the ingredients entered (all ingredients entered must be in the recipe) or choose OR 
if you want to conduct the search using any combination (not necessarily all) the ingredients 
entered (recipes locates recipes containing any one of the ingredients).

5.      Choose a category of recipes (such as Desserts) from the Within Category field (uncheck All 
Categories) or check All Categories to conduct a broader search of all possible categories.

6.      In the Search for only the first # of recipes field, enter the number of recipes you want 
displayed. The smaller the number the faster the search.

7.      Choose Start Search.

The recipes matching the ingredients and search criteria display in the Recipes Found area of the 
dialog box.

8.      Highlight the recipe you wish to prepare in the Recipes Found section of the dialog box.
(1) Choose Goto to go to the highlighted recipe.
(2) Choose View to view the recipe on screen. Recipes displays the View Recipe dialog box 

that provides you with the name of the recipe, serving size, servings, preparation time, 
category, and ingredients. To view the specific directions, choose Directions.

(3) Choose Print to print the recipe.



Recipe Setup

Before you start adding recipes to the 300 recipes available through Recipes for Windows, its a good 
idea to set up a few recipe parameters so you can track, sort, and report on the items that work best 
for you.

To set up your recipe parameters
1.      Open the Recipes module by clicking the recipe icon on the Tool Bar, by choosing Recipe 

from the View menu, or by pressing and holding CTRL AND THEN I.
2.      From the Options menu, choose Recipe Setup. Recipes displays the Recipe Setup dialog 

box.
3.      Type up to four different column headings youd like to see in the Label fields. Recipes 

prompts you for whatever you enter in these fields each time you add a recipe, so its best to 
enter the information important to you. For example, you may choose to enter Calories Per 
Serving, Grams of Fat Per Serving, Food Exchange, and Grams Cholesterol Per Serving.

NOTE: To designate a Hot Key, enter & before the letter you want to be the Hot Key. For example, if 
you want the column label to be Calories Per Serving, type &Calories Per Serving.    Choose a Hot 
Key that is not already used in that particular dialog box.

4.      Choose Use Default Labels to use the standard labels (column headings) provided by 
Recipes or Use As New Default Labels to use the new labels (column headings) entered as 
the default.

5.      Choose the category for new recipes or type a new category in the Category field and click 
OK.

NOTE: When both the Use Default Labels and the Use As New Default Labels are unchecked, 
the labels you defined are only defined for the current record.



Adding Recipes

Recipes for Windows provides you with 300 recipes. In addition, it provides you with the capability to 
add your treasured family recipes to this collection.

To add a recipe
1.      Open the Recipes module by clicking the recipe icon on the Tool Bar, by choosing Recipe 

from the View menu, or by pressing and holding CTRL AND THEN I.
2.      From the Edit menu, choose Add Recipe or click the add icon on the Tool Bar or place your 

cursor in the recipe section of the browser and press INSERT. Recipes displays the Recipe 
dialog box.

NOTE: Recipes provides two other ways for adding recipes:

(1) After conducting a Refrigerator Search (as described in the previous section) and viewing 
the recipe, choose Add.

(2) From the Recipe Browser, double-click the recipe to open the recipe and choose Add.
3.      Type the name of the recipe in the Name field.
4.      Type the serving size of the recipe in the Serving Size field.
5.      Type the number of servings the recipe makes in the Servings field.
6.      Type the time it takes to prepare the recipe in the Prep. Time field.
7.      Choose the category in which the recipe falls or type a new category in the Category field.
8.      Enter information into the next four fields or choose from the lists.

NOTE: The names of these fields default to the column labels entered in the Recipes Setup dialog 
box. Refer to the previous section for more detail.

9.      Move to the Ingredients section of the dialog box and choose Add Ingredient. Recipes 
displays the Ingredient dialog box.

To enter nutritional values for the recipe
1.      Choose Nutrition. Recipes displays the Nutritional Values dialog box.
2.      Enter the information you have available for the recipe:
3.      Click OK.

One last note on adding recipes: if this is a recipe you think youll be using over and over 
again, choose the Tag this Recipe for future use box.



Conversion

1.      Select a new unit and Recipes will display the converted value.



Edit Ingredients

To add an ingredient
1.      Type the quantity of the ingredient to use in the Qty field.
2.      Choose a Unit of the ingredient in the Unit field or type a new one.
3.      Choose a Group.



Edit Ingredients in Shopping List

To add an ingredient
1.      Type the quantity of the ingredient to use in the Qty field.
2.      Choose a Unit of the ingredient in the Unit field or type a new one.
3.      Choose a Group.
4.      Enter any remarks.
5.      Check on the Has Coupon Check box to specify whether you have a coupon for that item.



Edit Recipes

1. Open the Recipes module by clicking the recipe icon on the Tool Bar, by choosing Recipe from 
the View menu, or by pressing and holding CTRL AND THEN I.

2. Locate and highlight the recipe you wish to edit.

3. From the Edit menu, choose Edit Recipe or double-click the recipe or simply press ENTER. 
Recipes displays the Recipe dialog box.

4. Make the required changes to the recipe and click OK.



Deleting Recipes

1. Open the Recipes module by clicking the recipe icon on the Tool Bar or by choosing Recipe from 
the View menu.

2. Locate and highlight the recipe you wish to delete.

3. From the Edit menu, choose Delete Recipe or click the delete icon on the Tool Bar.

4. At the "Delete selected recipe?" prompt, choose Yes.

NOTE: If you are viewing a recipe you wish to delete, simply choose the delete icon on the bottom 
button bar to delete the recipe you are viewing.



Nutritional Values

Recipes gives you the capabilities to add nutritional values for any of the 300 recipes it provides. This 
information is extremely valuable if you're on a special diet for diabetes, high blood pressure, or if 
you're just trying to lose those extra ten pounds.

To enter nutritional values for the recipe
1.      From the Edit menu, choose Nutritional Values or double click the recipe for which you want 

to enter the nutritional values and choose Nutrition from the bottom button bar. Recipes 
displays the Nutritional Values dialog box.

2.      Enter the information you have available for the recipe:
3.      Click OK.



Scaling

The Scaling option in Recipes automatically recalculates the ingredients in the selected recipe for a 
larger or smaller serving size

To scale a recipe
1.      Open the Recipes module by clicking the recipe icon on the Tool Bar, by choosing Recipe 

from the View menu, or by pressing and holding CTRL AND THEN I.
2.      From the Edit menu, choose Scaling or double-click the recipe for which you want to scale 

and click on the Scaling button. Recipes displays the Scaling dialog box.
3.      Enter the number of servings you wish to prepare.
4.      From the Options group, select Scale Quantity Only or Scale Quantity and Units. The 

second option will convert only the units that the program understand.
5.      Click OK. Recipes automatically recalculates the quantity of the ingredients for you.



Moving and Copying Recipes

After using Recipes for Windows for a while, you discover a fabulous recipe in one of the Recipes 
cookbooks. Since you find yourself frequently using this recipe, you decide youd like to have it in the 
personal cookbook you created in Recipes.

To move a recipe from one cookbook to another
1.      Open the Recipes module by clicking the recipe icon on the Tool Bar, by choosing Recipe 

from the View menu, or by pressing and holding CTRL AND THEN I.
2.      Open the cookbook containing the recipe you wish to move by double-clicking the cookbook.
3.      Open the cookbook that you wish to move the recipes to by double-clicking the cookbook.

NOTE: you can tile both windows by selecting Tile Horizontal or Vertical from the Window menu or by 
clicking on the Tile button on the main tool bar (second button from the right).

4.      Locate and highlight the recipe(s) you wish to move.
5.      Click the recipe(s) and the ALT and the left mouse button. The cursor changes to a hand 

holding a recipe.
6.      Drag the recipe(s) to the other cookbook in the recipes area (browser cells) and release the 

left mouse button. You will now be able to locate the recipe(s) in your chosen cookbook.

To copy a recipe from one cookbook to another
1.      Open the Recipes module by clicking the recipe icon on the Tool Bar, by choosing Recipe 

from the View menu, or by pressing and holding CTRL AND THEN I.
2.      Open the cookbook containing the recipe you wish to copy by double-clicking the cookbook.
3.      Open the cookbook that you wish to copy the recipes to by double-clicking the cookbook.
4.      Locate and highlight the recipe(s) you wish to copy.
5.      Click the recipe(s) and hold the CTRL and the left mouse button. The cursor changes to a 

hand holding a recipe.
6.      Drag the recipe(s) to the other cookbook in the recipes area (browser cells) and release the 

left mouse button. You will now be able to locate the recipe(s) in both cookbooks.



Tagging

Recipes provides you with an easy way to locate your favorite or most frequently used records. As 
you enter new records, if the record is one you think youll use often or will need to locate frequently, 
you can tell Recipes to tag the record for future use. You can also tag records provided with the 
software or ones you added which you now find yourself referring to on a regular basis.

To tag records
1.      Open any module.
2.      Locate and highlight the record(s) you wish to tag.
3.      Click the tag icon. Notice the status to the right of those icons tells you the number of 

records you have tagged.

NOTE: The tag icon is a toggle button for tagging and untagging. You can also tag and untag using 
the Tag option from the Edit menu to tag or untag one record or all tagged records.



Tagging Recipes

Recipes provides you with an easy way to locate your favorite or most frequently used recipes. As 
you enter new recipes, if the recipe is one you think you'll use often or will need to locate frequently, 
you can tell Recipes to tag the recipe for future use. You can also tag recipes provided with the 
software or ones you added which you now find yourself referring to on a regular basis.

To tag recipes
1.      Open the Recipes module by clicking the recipe icon on the Tool Bar or by choosing Recipe 

from the View menu.
2.      Locate and highlight the recipe you wish to tag.
3.      Click the tag icon below the recipes. Notice the status to the right of those icons tells you the 

number of recipes you have tagged.

NOTE: You can also tag and untag using the Tag option from the Edit menu to tag or untag one 
recipe or all tagged recipes.

To locate tagged recipes
1.      Click the tag up or tag down icon below the recipes to locate the next tagged recipe.



Find

To locate tagged records
1.      Click the tag up or tag down icon below the records to locate the next tagged record. 

Depending upon which direction you are searching, when Records reaches the top, it loops to 
the bottom and when it reaches the bottom, it loops to the top.

To find any record, tagged or not
1.      Open any module.
2.      Click the find icon on the Tool Bar or from the Edit menu, choose Find. Recipes displays the 

Find dialog box.
3.      Select the field you wish to locate from the Fields displayed. Fields preceded with an asterisk 

(*) are fields selected in the current layout.
4.      Select the Value from the User List or type a new value in the Value field.
5.      If you want to match the case, choose Case Sensitive.
6.      If you want it to find a match that contains any of the letters in that field, choose Containing.
7.      Choose whether you want to start the search from the Top or from where the Cursor is 

located.
8.      Choose Find Next. Keep pressing Find Next until it finds the record you want.
9.      If you want to tag or untag the record you are attempting to locate, choose Tag/Untag.
10. If you want to untag all records located, choose Untag All.
11. Choose Cancel to view the record in the list.

To untag records
1.      Open any module.
2.      Locate and highlight the record you wish to untag.
3.      Click the tag icon below.

To untag all recipes
1.      Open any module.
2.      Click the untag all icon.



Directions

To view, add, or modify the directions of a recipe
1.      Open the Recipes module by clicking the recipe icon on the Tool Bar, by choosing Recipe 

from the View menu, or by pressing and holding CTRL AND THEN I.
2.      Locate and highlight the recipe in which you wish to view, add, or modify the directions.
3.      From the Edit menu, choose Directions or click the directions icon on the Tool Bar. Recipes 

displays the Notes dialog box.
4.      If directions were previously entered, these display. Edit as necessary or type the directions 

for preparing the recipe.
5.      When you are finished, double-click the upper left corner.
6.      At the "Save the new changes?" prompt, choose Yes.

NOTE: Follow the same procedure to add notes    to the Restaurant module. when in in the 
Restaurant View.

See Also

Insert File

Append File

Save File As



New Shopping List

Recipes has made one time-consuming chore simple -- figuring out what you need from the grocery 
store. By simply choosing the recipes you cook most frequently, you can automatically generate your 
shopping list.

To generate a shopping list
1.      Open the Recipes module by clicking the recipe icon on the Tool Bar, by choosing Recipe 

from the View menu, or by pressing and holding CTRL AND THEN I.
2.      Locate and highlight the recipe(s) whose ingredients you wish to include on your shopping 

list.

NOTE: To choose consecutive recipes, press the SHIFT key and click the recipes, or to choose non-
consecutive recipes, press the CTRL key and click the recipes you want to include.

3.      Click the shopping cart on the Tool Bar or from the File menu, choose New Shopping List or 
press CTRL and then L. Recipes displays the Shopping List dialog box displaying the group, 
quantity, ingredients, and whether or not you have a coupon for the item.

4.      Type the name of the shopping list in the Shopping List Name field.
5.      Add, edit, or delete items as described in the following procedures. Change the font, font 

style, or size to print on your list by choosing Font from the bottom button bar.
6.      Click OK. Recipes saves the shopping list for use in the future.



Manage Shopping List

To add an item to the shopping list
1.      Open the Recipes module by clicking the recipe icon on the Tool Bar, by choosing Recipe 

from the View menu, or by pressing and holding CTRL AND THEN I.
2.      From the File menu, choose Manage Shopping Lists. Recipes displays the Manage 

Shopping Lists dialog box.
3.      Highlight the shopping list to which you wish to add the item and choose Edit or double-click. 

Recipes displays the Shopping List dialog box.
4.      Choose Add. Recipes displays the Ingredient dialog box.
5.      Type the quantity in the Qty field.
6.      Type the name of the item you wish to add to the shopping list in the Name field.
7.      Choose the group into which the item falls from the Group list or type in a new group.
8.      If you want to enter a comment or remark, type a comment of up to 25 characters in the 

Remarks field.
9.      Indicate if you have a coupon for this item in the Has Coupon box.
10. If you want to change a conversion for an item, choose Conversion.
11. Click OK.

To edit an item on the shopping list
1.      Open the Recipes module by clicking the recipe icon on the Tool Bar, by choosing Recipe 

from the View menu, or by pressing and holding CTRL AND THEN I.
2.      From the File menu, choose Manage Shopping Lists. Recipes displays the Manage 

Shopping Lists dialog box.
3.      Highlight the shopping list to which you wish to edit an item and choose Edit or double-click. 

Recipes displays the Shopping List dialog box.
4.      Highlight the item you wish to edit or change and choose Edit. Recipes displays the 

Ingredient dialog box.
5.      Edit the item as described in steps 5-11 above and click OK.

To delete an item from the shopping list
1.      Open the Recipes module by clicking the recipe icon on the Tool Bar, by choosing Recipe 

from the View menu, or by pressing and holding CTRL AND THEN I.
2.      From the File menu, choose Manage Shopping Lists. Recipes displays the Manage 

Shopping Lists dialog box.
3.      Highlight the shopping list you wish to delete and choose Delete.
4.      At the "Delete selected shopping list?" prompt, choose Yes.



Print Shopping List

To print your shopping list
1.      Open the Recipes module by clicking the recipe icon on the Tool Bar, by choosing Recipe 

from the View menu, or by pressing and holding CTRL AND THEN I.
2.      From the File menu, choose Manage Shopping Lists. Recipes displays the Manage 

Shopping Lists dialog box.
3.      Highlight the shopping list you wish to print and choose Print.



Menu Planning

Refer to Chapter 11, "Generating Reports" for details on generating a menu plan for the week.



Import

1. Open the Recipes module by clicking the recipe icon on the Tool Bar, by choosing Recipe from 
the View menu, or by pressing and holding CTRL AND THEN I.

2. From the File menu, choose Import. Recipes displays the Import dialog box.

3. Type the name of the file you wish to import in the File Name field.

NOTE: To view the types of files available for importing, view the List of Files Type list and make your 
selection from that list.

4. Select the directory location for the file from the Directories portion of the dialog box.

NOTE: To change drives, use the list of drives provided in the Drives portion of the dialog box.

5. Select the program format to import from the Import from list.

6. Click OK.



Adding Coupons

If you're like most people, you clip coupons on a regular basis and then put those coupons in a box or 
envelope somewhere until its time to go grocery shopping. The problem occurs when you have your 
shopping list ready to go (of course, prepared by Recipes), you know you have a coupon for an item 
on the list, but you can't locate it or when you locate it, you learn it's expired. Okay, so let's get 
organized.

1. Open the Coupon module by clicking the coupon icon on the Tool Bar, by choosing Coupon from 
the View menu, or by pressing and holding CTRL and then U.

2. From the Edit menu, choose Add Coupon or click the add icon on the Tool Bar or simply press 
INSERT. Recipes displays the Coupon dialog box.

3. Type up to a 25 character description of the coupon in the Description field; for example, 
Shredded Wheat Cereal.

4. Select a manufacturer from the pull-down list or type a manufacturer in the Manufacturer field; for 
example, Nabisco.

5. Select the group in which this coupon falls or type a group in the Group field; for example, 
Breakfast Foods.

6. Type the coupon value in the Amount field; for example, $0.75.

7. Choose No Expiration Date or choose Expires on and type the expiration date.

8. If this is a product you use frequently and want to be able to locate it easily later, choose Tag this 
Coupon for future use.

9. Click OK or press and hold ALT and then A to add more coupons.



Editing Coupons

1. Open the Coupon module by clicking the coupon icon on the Tool Bar, by choosing Coupon from 
the View menu, or by pressing and holding CTRL and then U.

2. Locate and highlight the coupon requiring changes.

3. From the Edit menu, choose Edit Coupon or double-click the coupon or simply press ENTER. 
Recipes displays the Coupon dialog box.

4. Make the required changes to the coupon and click OK.

NOTE: For information on entries you can make or moving around this dialog box, refer to the 
previous section, "Adding Coupons" on page 55. All information entered can also be changed or 
edited.



Deleting Coupons

1. Open the Coupon module by clicking the coupon icon on the Tool Bar or by choosing Coupon 
from the View menu.

2. Locate and highlight the coupon you wish to delete.

3. From the Edit menu, choose Delete Coupon or click the delete icon on the Tool Bar.

4. At the "Delete selected coupon?" prompt, choose Yes.

NOTE: If you are viewing a coupon you wish to delete, simply choose the delete icon on the bottom 
button bar to delete the coupon you are viewing.



Deleting Expired Coupons

One of the biggest disappointments is when you have your shopping list (prepared by Recipes, of 
course) and you know you have a coupon for a specific item on the list (Recipes indicates when you 
have a coupon for an item on a shopping list), but when you go to pull that coupon, you learn its 
expired. To prevent this problem from happening, you can go into Recipes for Windows and 
periodically delete your expired coupons.

To delete expired coupons
1.      Open the Coupon module by clicking the coupon icon on the Tool Bar, by choosing Coupon 

from the View menu, or by pressing and holding CTRL and then U.
2.      From the Edit menu, choose Delete Expired Coupons or click the sad face icon on the Tool 

Bar.
3.      At the "Delete all expired coupons?" prompt, choose Yes.



Tagging Coupons

Recipes provides you with an easy way to locate those coupons you use most frequently. As you 
enter a new coupon, if you think you'll use the item often or will need to locate it easily, you can tell 
Recipes to tag the coupon for future use. You can also tag coupons added previously which you now 
find yourself using on a regular basis.

To tag coupons
1.      Open the Coupon module by clicking the coupon icon on the Tool Bar or by choosing 

Coupon from the View menu.
2.      Locate and highlight the coupon you wish to tag.
3.      Click the tag icon below the coupons. Notice the status to the right of those icons tells you 

the number of coupons you have tagged.

NOTE: You can also tag and untag using the Tag option from the Edit menu to tag or untag one 
coupon or all tagged coupons.

To locate tagged coupons
1.      Click the tag up or tag down icon below the coupons to locate the next tagged coupon.

To find any coupon, tagged or not
1.      Open the Coupon module by clicking the coupon icon on the Tool Bar or by choosing 

Coupon from the View menu.
2.      Click the find icon on the Tool Bar. Recipes displays the Find dialog box.
3.      Select the field you wish to locate from the Fields displayed.
4.      Select the Value from the User List or type a new value in the Value field.
5.      If you want to match the case, choose Case Sensitive.
6.      If you want it to contain the information, choose Containing.
7.      Choose whether you want to start the search from the Top or from where the Cursor is 

located.
8.      If you want to tag or untag the coupon you are attempting to locate, choose Tag/Untag.
9.      If you want to untag all coupons located, choose Untag All.
10. Choose Find Next.
11. Choose Cancel to view the coupon in the Coupon list.

To untag coupons
1.      Open the Coupon module by clicking the coupon icon on the Tool Bar or by choosing 

Coupon from the View menu.
2.      Locate and highlight the coupon you wish to untag.
3.      Click the untag icon below the coupons.

NOTE: You can also tag and untag using the Tag option from the Edit menu to tag or untag one 
coupon or all tagged coupons.



Pantry Setup

1. Open the Pantry module by clicking the pantry icon on the Tool Bar, by choosing Pantry from the 
View menu, or by pressing and holding CTRL and then T.

2. From the Options menu, choose Pantry Setup. Recipes displays the Pantry Setup dialog box.

IMPORTANT: Recipes prompts you for whatever you enter in the fields described in the following 
Steps 3-7 each time you add a pantry item, so its best to enter information important to you.

To designate a Hot Key, enter    &    before the letter you want to be the Hot Key. For example, if you 
want the column label to be Manufacturer, type &Manufacturer.

3. Type up to four different column headings youd like to see when you view your pantry items in 
User Lists fields. For example, you may choose to enter Manufacturer, Category, Keyword, and 
Not Used.

4. Type two different date labels in the Date 1 and Date 2 fields. Again, entries made here display as 
column headings when you view your pantry items in the Pantry Browser. In addition, Recipes 
prompts you for these two dates each time you add a pantry item. You may, for example, choose 
to enter Date Purchased and Expiration Date in these two fields.

5. Type a price column label in the Currency field; for example, Price Per Unit.

6. Type a numeric column label in the Numeric field; for example, Weight.

7. Type two column labels, which when prompted, can be answered, "yes" or "no" in the Boolean 
fields. For example, you may choose to enter Freezer Item in the Boolean 1 field and Requires 
Refrigeration in the Boolean 2 field.

8. Click OK.



Adding Pantry Items

1. Open the Pantry module by clicking the pantry icon on the Tool Bar, by choosing Pantry from the 
View menu, or by pressing and holding CTRL and then T.

2. From the Edit menu, choose Add Pantry Item or click the add icon on the Tool Bar or simply press 
INSERT. Recipes displays the Pantry Item dialog box.

3. Type the name of the pantry item in the Name field; for example, Cut Green Beans.

4. Select the group in which this pantry item falls or type a group in the Group field; for example, 
Canned Vegetables.

5. Type the quantity of the pantry item you have on hand in the Quantity field; for example 4 (for 4 
cans).

6. Type up to a 25 character description of the pantry item in the Description field; for example, 
Beans W/Slivered Almonds.

7. Type in any comments you wish about the pantry item in the Comments field.

8. Enter information into the next ten fields or choose from the lists.

NOTE: The names of these fields default to the column labels entered in the Pantry Setup dialog box. 
Refer to the previous section for more detail.

9. If this is a product you use frequently and want to be able to locate it easily later, choose Tag this 
Pantry for future use.

10. Click OK or press and hold ALT and then A to add more pantry items.



Editing Pantry Items

1. Open the Pantry module by clicking the pantry icon on the Tool Bar, by choosing Pantry from the 
View menu, or by pressing and holding CTRL and then T.

2. Locate and highlight the pantry item requiring change.

3. From the Edit menu, choose Edit Pantry Item or double-click the pantry item or simply press 
ENTER. Recipes displays the Pantry Item dialog box.

4. Make the required changes to the pantry item and click OK.

NOTE: For information on entries you can make or moving around this dialog box, refer to the 
previous section, "Adding Pantry Items" on page 60. All information entered can also be changed or 
edited.



Deleting Pantry Items

1. Open the Pantry module by clicking the pantry icon on the Tool Bar or by choosing Pantry from 
the View menu.

2. Locate and highlight the pantry item you wish to delete.

3. From the Edit menu, choose Delete Pantry Item or click the delete icon on the Tool Bar.

4. At the "Delete selected pantry?" prompt, choose Yes.

NOTE: If you are viewing a pantry item you wish to delete, simply choose the delete icon on the 
bottom button bar to delete the pantry item you are viewing.



Tagging Pantry Items

Recipes provides you with an easy way to locate those pantry items you use most frequently. As you 
enter a new pantry item, if you think you'll use the item often or will need to locate it easily, you can 
tell Recipes to tag the pantry item for future use. You can also tag pantry items added previously 
which you now find yourself using on a regular basis.

To tag pantry items
1.      Open the Pantry module by clicking the pantry icon on the Tool Bar or by choosing Pantry 

from the View menu.
2.      Locate and highlight the pantry item you wish to tag.
3.      Click the tag icon below the pantry items. Notice the status to the right of those icons tells 

you the number of pantry items you have tagged.

NOTE: You can also tag and untag using the Tag option from the Edit menu to tag or untag one 
pantry item or all tagged pantry items.

To locate tagged pantry items
1.      Click the tag up or tag down icon below the pantry items to locate the next tagged pantry 

item.

To find any pantry item, tagged or not
1.      Open the Pantry module by clicking the pantry icon on the Tool Bar or by choosing Pantry 

from the View menu.
2.      Click the find icon on the Tool Bar. Recipes displays the Find dialog box.
3.      Select the field you wish to locate from the Fields displayed.
4.      Select the Value from the User List or type a new value in the Value field.
5.      If you want to match the case, choose Case Sensitive.
6.      If you want it to contain the information, choose Containing.
7.      Choose whether you want to start the search from the Top or from where the Cursor is 

located.
8.      If you want to tag or untag the pantry item you are attempting to locate, choose Tag/Untag.
9.      If you want to untag all pantry items located, choose Untag All.
10. Choose Find Next.
11. Choose Cancel to view the pantry item in the Pantry list.

To untag pantry items
1.      Open the Pantry module by clicking the pantry icon on the Tool Bar or by choosing Pantry 

from the View menu.
2.      Locate and highlight the pantry item you wish to untag.
3.      Click the untag icon below the pantry items.

NOTE: You can also tag and untag using the Tag option from the Edit menu to tag or untag one 
pantry item or all tagged pantry items.



Adding Restaurants

1. Open the Restaurant module by clicking the restaurant icon on the Tool Bar, by choosing 
Restaurant from the View menu, or by pressing and holding CTRL and then E.

2. From the Edit menu, choose Add Restaurant Item or click the add icon on the Tool Bar or simply 
press INSERT. Recipes displays the Restaurant dialog box.

3. Type up to a 25 character name of the restaurant in the Name field; for example, Stefanos.

4. If you have a contact at that restaurant, type his or her name in the Contact field.

5. Type the street in the Street field.

6. Choose a city from the list or type it in the City field.

7. Choose a state abbreviation from the list or type one in the State field.

8. Type the restaurants zip code in the Zip field.

9. Choose a country from the list or type one in the Country field.

10. Type the telephone number of the restaurant in the Phone field.

11. If you know the fax number of the restaurant, type it in the Fax field.

12. If you know the restaurants hours, enter them in the Hours section of the dialog box. Recipes 
provides you with the capability to designate the restaurants Breakfast, Lunch, Dinner, Brunch, 
and Happy Hour hours.

13. Indicate which credit cards the restaurant accepts or choose All if the restaurant accepts all 
displayed.

14. Choose the type of cuisine served by the restaurant from the list or type one in the Cuisine field.

15. Type the price range for entrees in the Price Range field.

16. Choose how you would rank the restaurant from the list or type one in the Rank field.

17. Type the kind of attire which should be worn to the restaurant in the Attire field.

18. Type the restaurants specialty in the Specialty field.

19. Indicate if a reservation is needed in the Reservation Needed field.

20. Type the features or the thing(s) that makes the restaurant unique in the Features field.

21. Type more information about the restaurant in the Description field.

22. If this is a restaurant youll be frequenting and want to be able to locate it easily later, choose Tag 
this Restaurant for future use.

To enter notes on the restaurant
(1)      Choose Notes. Recipes displays the Notes dialog box.
(2)      If notes were previously entered, these display. Edit as necessary or type new notes on a 

restaurant.
(3)      When you are finished, double-click the upper left corner.
(4)      At the "Save the new changes?" prompt, choose Yes.

23. Click OK or press and hold ALT and then A to add more restaurants.



Editing Restaurants

1. Open the Restaurant module by clicking the restaurant icon on the Tool Bar, by choosing 
Restaurant from the View menu, or by pressing and holding CTRL and then E.

2. Locate and highlight the restaurant requiring change.

3. From the Edit menu, choose Edit Restaurant or double-click the restaurant item or simply press 
ENTER. Recipes displays the Restaurant dialog box.

4. Make the required changes to the restaurant and click OK.

NOTE: For information on entries you can make or moving around this dialog box, refer to the 
previous section, "Adding Restaurants" on page 63. All information entered can also be changed or 
edited.



Deleting Restaurants

1. Open the Restaurant module by clicking the restaurant icon on the Tool Bar or by choosing 
Restaurant from the View menu.

2. Locate and highlight the restaurant you wish to delete.

3. From the Edit menu, choose Delete Restaurant or click the delete icon on the Tool Bar.

4. At the "Delete selected restaurant?" prompt, choose Yes.

NOTE: If you are viewing a restaurant item you wish to delete, simply choose the delete icon on the 
bottom button bar to delete the restaurant item you are viewing.



Tagging Restaurants

Recipes provides you with an easy way to locate your favorite restaurants or ones that you frequent 
most often. As you enter a new restaurant, if you think you'll want to locate it often or easily, you can 
tell Recipes to tag the restaurant item for future use. You can also tag restaurants added previously to 
which you now find yourself referring on a regular basis.

To tag restaurants
1.      Open the Restaurant module by clicking the restaurant icon on the Tool Bar or by choosing 

Restaurant from the View menu.
2.      Locate and highlight the restaurant you wish to tag.
3.      Click the tag icon below the restaurants. Notice the status to the right of those icons tells you 

the number of restaurants you have tagged.

NOTE: You can also tag and untag using the Tag option from the Edit menu to tag or untag one 
restaurant or all tagged restaurants.

To locate tagged restaurants
1.      Click the tag up or tag down icon below the restaurant to locate the next tagged restaurant.

To find any restaurant, tagged or not
1.      Open the Restaurant module by clicking the restaurant icon on the Tool Bar or by choosing 

Restaurant from the View menu.
2.      Click the find icon on the Tool Bar or from the Edit menu, choose Find Restaurant. Recipes 

displays the Find dialog box.
3.      Select the field you wish to locate from the Fields displayed.
4.      Select the Value from the User List or type a new value in the Value field.
5.      If you want to match the case, choose Case Sensitive.
6.      If you want it to contain the information, choose Containing.
7.      Choose whether you want to start the search from the Top or from where the Cursor is 

located.
8.      If you want to tag or untag the restaurant you are attempting to locate, choose Tag/Untag.
9.      If you want to untag all restaurants located, choose Untag All.
10. Choose Find Next.
11. Choose Cancel to view the restaurant in the Restaurant list.

To untag restaurants
1.      Open the Restaurant module by clicking the restaurant icon on the Tool Bar or by choosing 

Restaurant from the View menu.
2.      Locate and highlight the restaurant you wish to untag.
3.      Click the untag icon below the restaurants.

NOTE: You can also tag and untag using the Tag option from the Edit menu to tag or untag one 
restaurant or all tagged restaurants.



Report Parameters

1. From the File menu, choose Report Parameters.

2. Type up to 36 characters indicating the name of the report in the Report Name field. For example, 
you might enter Menu Plan for the Week of September 1.

3. Choose the format for the dates which appear on the report.

4. Choose the format for the ruler. Choose to hide the ruler, or select inches or centimeters.

5. Indicate if you want to print some trial records, such as a few recipes.

6. Type, in inches, the left, right, top, and bottom margins for the report. Theses values determine 
the size of the report.

7. Click OK.



Filters

1. From the File menu, choose Report Filter.

2. Select a data, such as Calories.

3. Enter the Operator, such as <.

4. Type in the number, such as 300.

5. Click OK.



Entering Dialog Field Tables

Enter dialog fields in a report if you want the user prompted for data when they go to preview or print 
the report. For example, if you want the beginning and ending dates for the report to be entered prior 
to the report being printed, enter Begin Date as one field and End Date as a second field. Dialog 
fields cannot be used in a field expression or entered in a report until they are first created.

To add a dialog field
1.      From the Field menu, choose Edit Dialog Field Table.
2.      Choose Create.
3.      Type the name of the field in the Field Name field.
4.      Select the field type. Choose from Text, Numeric, Double, Logical, or Date.
5.      Click OK.



Selecting Fields to Print on a Report

1. From the Field menu, choose Insert New Field.

2. Choose the type of field you wish to include: Data, Calculation, System, or Dialog.

If you choose Data Field
(1)      Choose the field to include from the list of data files and data fields. The cursor turns to a 

floating dotted line box.
(2)      Move the field to the point where you want it displayed on the report, and click the left 

mouse button.

If you choose Calculation Field, You will be prompt for the name of the calculation 
field.

(1)      Type the name of the calculation field, such as Total_Nutrition and click OK.
(2)      Select a data field, sucha as Calories and click OK.
(3)      Select an operator, such as + and click OK.
(4)      Select a data field, such as Carbohydrates and click OK. The cursor turns to a floating 

dotted line box.
(5)      Move the field to the point where you want it displayed on the report, and click the left 

mouse button. The name of the field is displayed inside the box in the upper left corner of the 
report window. The calculation field you've just defined will calculate the sum of the calories 
and carbohydrates for all of the records you select for report printing.

If you choose System Field
(1)      Choose the system field to include from Select System Fields dialog box and click OK. The 

cursor turns to a floating dotted line box.
(2)      Move the field to the point where you want it displayed on the report, and click the left 

mouse button. The name of the field is displayed inside the box in the upper left corner of the 
report window. The system fields are usually define for the header or footer section of your 
report.

If you choose Dialog Field, you must have first created the dialog field using the Edit 
Dialog Field Table option (see "Entering Dialog Field Tables" section above).

(1)      Choose the dialog field to include from Select Dialog Fields dialog box and click OK. The 
cursor turns to a floating dotted line box.

(2)      Move the field to the point where you want it displayed on the report, and click the left 
mouse button. The name of the field is displayed inside the box in the upper left corner of the 
report window.



Adding a New Section

While creating your report, you may decide that you want more than one section. You can create four 
basic types of sections:

Page Headers. These are descriptive text that print at the top of the page in your report such as 
the report title.

Sort Headers. These display the data that changes when a sort field changes. For example, if 
classification is the sort header field, the report may print all the recipes with American 
classification and then print all recipes with Mexican classification in groups.

Detail Section. This section displays the transaction record fields.

Footers. These are descriptive text that print at the bottom of the page such as page number..

Sections are identified by a section banner at the beginning of the section and a dotted separation 
line at the bottom. You can have up to nine header and footer sections.

To add a new section to the report
1.      From the Section menu, choose New.
2.      Select the section you want to add to the report and click OK.



Editing a Section

1. Select the section you want to edit.

2. From the Section menu, choose Edit or double click on the section.

3. From the dialog box, select if you want a page to advance before or after the section, if you want 
to compress a space before the first or after the last item, and the number of items you want 
displayed across the page.

4. Click OK.



Section Filters

1. From the Section menu, choose Filter.

2. Select a data, system, or dialog field.

3. Enter the Operator.

4. Type in the number.

5. Click OK.



More on Fields in a Section

There are two options for fields within a section: Sort Field and Break Field.

Use the Sort Field option from the Section menu to specify a sort field for a header section. The 
field selected will be used to sort the data records, for example, Low Calorie.

Use the Break Field option from the Section menu to specify a break field for a header section. 
This tells the program how to determine the sort break. It can be the same as the sort field. In 
addition, you can also specify a calculation for a break field.



Adding Lines

To make your report more attractive, you might decide to add lines, possibly above or below the title 
or the field names -- where ever you decide they need to be.

To add a line
1.      From the Line menu, choose Create. The cursor changes to a positioning rectangle.
2.      Move the rectangle to the point where you want it displayed on the report, and click the left 

mouse button. The line is displayed inside the rectangle.



Editing a Line

1. Select the line you want to edit.

2. From the Line menu, choose Edit or double click on the line.

3. Indicate the line angle for the line: horizontal, vertical, diagonal, or back diagonal.

4. Indicate the style you'd like the line to be: solid, dashes, dots, dash and dots.

5. Type the line width in millimeters.

6. Choose Line Color if you want the line to be a color other than black. Select your color and click 
OK.



Adding a Label

Labels are text used for field headings that help to identify the fields in your report.

To add a label
1.      From the Label menu, choose Create. The cursor changes to a positioning rectangle.
2.      Move the rectangle to the point where you want it displayed on the report, and click the left 

mouse button. The word "LABEL" is displayed inside the box and in the box displayed in the 
upper left corner of the report window.



Editing a Label

Once you have placed the label, you may want to change the name of the label to make it more 
meaningful.

To edit a label
1.      Select the label whose name you wish to change.
2.      From the Label menu, choose Edit.
3.      Type the new label over the old name in the upper left corner of the report window.
4.      Press ENTER.



Positioning Text

Once you have place the required fields and labels in your report, you may want to position the text 
for each field differently than centered (the default).

To position text
1.      From the Edit menu, choose Position Text.
2.      Choose whether you want the text to be left, center, or right justified.
3.      Choose whether you want the text to be vertically arranged at the top, center, or bottom 

within the label box.
4.      Click OK.



Outlining Objects

Okay, so you've gotten your fields and labels inserted where you want them and positioned so they 
look good. Now you decide you'd like to outline certain fields on the reports in red.

To outline an object
1.      From the Edit menu, choose Outlines.
2.      Select which sides to draw: left, right, top, bottom. (To create a shadowing effect, select left 

and bottom or right and bottom.)
3.      Indicate the style you'd like the line to be: solid, dashes, dots, dash and dots.
4.      Type the line width in millimeters.
5.      Choose Line Color if you want the line to be a color other than black. Select your color and 

click OK.



Object Background

Now looking over your report, you decide you'd like to shade the background of certain fields on the 
reports.

To change an objects background
1.      From the Edit menu, choose Background.
2.      Choose Paint Item Background.
3.      Indicate the type of paint brush: solid, horizontal hatch, vertical hatch, cross hatch, diagonal 

cross hatch, forward diagonal hatch, backward diagonal hatch.
4.      Choose Paint Brush Color if you want the line to be a color other than black. Select your 

color and click OK.
5.      Click OK.



Selection

To select the items, press and hold the left mouse button (cursor must not be placed on an item). 
Drag the mouse until the dotted rectangle completely or partially covers all the items you want to 
select. Release the mouse button. A rectangle with eight handles is displayed to indicate the area. 
You can expand the rectangle to add more items to the selection or you can shrink the rectangle to 
remove items from the selection. The rectangle can be resized by selecting and draging the handles. 
The top item is the anchor item for alignment. All items will align to the top item.



Horizontal Centering

After reviewing your report, you decide that one or more of the fields should be centered horizontally.

NOTE: This does not change the position of the selected item(s) relative to the selection rectangle.

To center one or more item horizontally
1.      Select the field(s) to be centered. Refer to Selection above on how to select items.
2.      From the Edit menu, choose Center.



Pictures

You can to import picture bitmaps from the clipboard or from a file into your report to "spice" it up.

To import a picture into your report
1.      From the Picture menu, choose either Picture from Clipboard or Picture from Disk File. If you 

choose from Clipboard, you need to first copy the picture into the Windows clipboard.
2.      If you are importing from a disk file, select the BMP file to import.
The cursor changes to a positioning rectangle equal to the dimensions of the picture.
3.      Move the rectangle to the point where you want it displayed on the report, and click the left 

mouse button. The picture is placed inside the rectangle.
4.      Change the picture size by

(1) Selecting the rectangle.
(2) Select one of the eight sizing handles and drag the side to the desired point while holding 

the left mouse button.
(3) Releasing the mouse button.



Fonts

One last thing you may want to do before saving and printing your report is to choose the fonts to 
use.

To select the fonts for your report
1.      Select the field or label whose font you wish to change.
2.      From the Edit menu, choose Fonts.
3.      Choose the Font, Font Style, Size, Effects (Strikeout or Underline), and Color to use for the 

selected field(s) or label(s).
4.      Click OK.



Saving a Report

After taking the time to create your report, it is extremely important that you save your report. This 
way, if it takes you an hour to create a customized report for menu planning, it will only take you 
minutes the following week since you can reuse the report already created.

To save your report
1.      From the File menu, choose Save.
2.      Type the name of your report in the File Name field.
3.      If you want to save your report to a different location on your system, select the appropriate 

directory path from the Directories section and drive from the Drives list section of the dialog 
box.

4.      If you want to save your report with a different extension other than FP, choose a different file 
type from the List Files of Type section of the dialog box.

5.      Click OK.



Editing Fields

When you go back in to print your report again, you decide you want to change word wrap and 
capitalization for a couple of the fields.

To edit a field
1.      Select the field to be changed.
2.      From the Field menu, choose Edit Field.
3.      Choose to wrap text or word wrap text.
4.      Indicate whether or not to use a variable number of lines.
5.      Choose whether to capitalize, capitalize only the first letter of each word, or print all letters in 

lowercase.
6.      If you want to trim the extra spaces from around the words, indicate that by clicking the Trim 

Extra Spaces box.



Editing Field Expressions

If you didn't particularly like the way a calculated field was used on the report, you can go back in and 
change the calculation field expression.

To edit a field expression
1.      Select the calculation field to be changed.
2.      From the Field menu, choose Edit Field Expression.
3.      Position your cursor where you want to insert or change the field and select a data, system, 

or dialog field.
3.      Select the specific function.
4.      Enter the Operator.
5.      Type in the number.
6.      Click OK.



Selecting Data Fields

To select a field
1.      From the Field menu, choose Insert, Data Field or press F2
2.      Doubleclick on the field you want to insert and position the field on the report
3.      Format the field if desired

NOTE:    For recipe reports, you may choose fields from the recipe or ingredient database by selecting 
the corresponding file type in the File Type list.



Editing Dialog Field Tables

Use Dialog fields in a report when you want the user prompted for data as they go to preview or print 
the report. Adding these fields were discussed earlier in this chapter.

To change a dialog field
1.      From the Field menu, choose Edit Dialog Field Table.
2.      Choose Modify
3.      Select the field you wish to change by highlighting it and then double-clicking or clicking OK.
4.      If you want to change the field name, type or modify the name displayed in the User Prompt 

field.
5.      If you want to change the prompt order, type the number in the Prompt Order field.
6.      If you want to change the column width, type the new column width in the Field Width field.
7.      Click OK.



Deleting Dialog Field Tables

As you view the dialog fields, you may see some that you never use.

To delete a dialog field
1.      From the Field menu, choose Edit Dialog Field Table.
2.      Choose Delete.
3.      Select the field you wish to delete by highlighting it and then double-clicking or clicking OK.



Deleting Objects

After you print and review a report you created, you may decide to delete certain fields, sections, 
lines, etc., from the report.

To delete an item from a report
1.      Select the item you wish to delete.
2.      From the Edit menu, choose Delete.



Report Size

If you don't particularly like the appearance of your report once you print it, you can shrink or elongate 
the spaces between fields in the report horizontally or vertically. 

To change the space size between fields
1.      Define the area in the report you want to change. To do this, position the mouse pointer to 

the beginning of the area you want to change, press and hold the left mouse button. Drag the 
mouse left, right, up, or down until it covers the area you want to change. Release the mouse 
button. A rectangle with eight handles is displayed to indicate the area. Modify the size of the 
area again if you need to by selecting and draging on any one of the handles.

2.      From the Edit menu, choose Report Size.
3.      Choose the way in which you wish to change the size of the report from the following:

Expand Horizontally (to widen the report by moving items horizontally)
Expand Vertically (to add height to the report by moving items downward)
Compress Horizontally (to delete extra horizontal space by moving items horizontally)
Compress Vertically (to delete vertical space by moving the items upward)



Alignment

1. Select the items whose alignment you wish to change. Refer to Selection above on how to select 
items for alignment.

2. From the Arrange menu, choose Align.

3. Choose the alignment for the items from the following:

      Align at Horizontal Top Edge to align the items at the top edge.
      Align at Horizontal Bottom Edge to align the items on the bottom edge.
      Align at Horizontal Center Line to align the items on the horizontal center line.
      Align at Vertical Left Edge to align the items at the left edge.
      Align at Vertical Bottom Edge to align the items on the bottom edge.
      Align at Vertical Center Line to align the items on the vertical center line.



Spacing

1. Select the items whose spacing you wish to change. Refer to Selection above on how to select 
items to change the spacing.

2. From the Arrange menu, choose Even Spacing.

3. Choose the spacing for the item from the following:

      Even Spacing Horizontally to space the items horizontally at an equal distance from each 
other.

      Even Spacing Vertically to space the items vertically at an equal distance from each other.



Sizing

1. Select the items whose sizing you wish to change. Refer to Selection above on how to select 
items for sizing.

2. From the Arrange menu, choose Even Sizing.

3. Choose the sizing for the items from the following:

      Set Even Width to change the width of the selected items to the width of the item at the very 
top of the page.

      Set Even Height to change the height of the selected items to the width of the item at the very 
left side of the page.



Undoing a Previous Arrangement

If after changing the arrangement, you do not like the way in which the report looks, you can easily 
undo the arrangement.

To undo a previous arrangement command
1.      From the Arrange menu, choose Undo.



Previewing a Report

Now that you've created or edited your report, before you print, you might want to preview how the 
report looks before you actually send the information to the printer and waste any printing time or 
paper.

To preview a report
1.      Click the icon on the Tool Bar representing the module or browser you wish to open, or from 

the View menu, choose the module or browser to view.
2.      From the File menu, choose Preview Report.
3.      Enter the name of the report, or select from the list of files.
4.      If your report is in a different location on your system, select the appropriate directory path 

from the Directories section and drive from the Drives list section of the dialog box.
5.      If you saved your report with a different extension other than FP, choose a different file type 

from the List Files of Type section of the dialog box.
6.      Choose to display All Cells, a Current Selection, or just Tagged Rows.
7.      Verify the Print Preview box is checked and click OK.
8.      Depending upon what types of fields you included on your report, you may be prompted to 

make an entry. If this occurs, type your entry and click OK.
9.      Choose:

Print to go ahead and print. Refer to the next section for details on printing.
Exit to exit the print preview.



Printing a Report

1. Click the icon on the Tool Bar representing the module or browser you wish to open, or from the 
View menu, choose the module or browser to view.

2. From the File menu, choose Print Report.

3. Enter the name of the report, or select from the list of files.

4. If your report is in a different location on your system, select the appropriate directory path from 
the Directories section and drive from the Drives list section of the dialog box.

5. If you saved your report with a different extension other than FP, choose a different file type from 
the List Files of Type section of the dialog box.

6. Choose to display All Cells, a Current Selection, or just Tagged Rows.

7. Click OK.

8. Depending upon what types of fields you included on your report, you may be prompted to make 
an entry. If this occurs, type your entry and click OK.



Printing Sample Reports

You can create reports with many different sizes, 3x5, 4x6 or any size you want. The procedure below 
will step through the process of creating a 3x5 report. You can use the procedure below to create any 
size report by changing the margins in the report parameters.

Creating a new 3x5 report
1.      Click the icon on the Tool Bar representing the module or browser you wish to open, or from 

the View menu, choose the module or browser to view.
2.      From the File menu, choose New Report.
3.      From the report File menu, choose Report parameters.
4.      Enter My 3x5 Report. You can enter up to 36 character for report name.
5.      Choose the format for the dates which appear on the report.
6.      Choose the format for the ruler. Choose to hide the ruler, or select inches or centimeters.
7.      Indicate if you want to print some trial records, such as a few recipes.
8.      Type 1 for left margin, 2 for right margin, 1 for top margin and 7 for bottom margin.
9.      Click OK.

Predefined Reports

Recipes for Windows 2.0 comes with several built-in reports.    You can usethese reports as they are 
or you can modify any of them to fit you needs.The built-in reports and a brief description are listed 
below.

3x5_5388.fp 3x5 recipe report for the Laser Index cards Avery (tm) 5388.
3x5_dotm.fp 3x5 recipe report for the dot matrix.
Couponsg.fp coupon listing by group.
Couponsd.fp coupon listing by expiration date.
Pantry.fp pantry listing using current sort order.
Recindex.fp recipe names using current sort.
Recdetai.fp regular recipe report.
Restaur.fp restaurant index report with restaurant name, phone, address and cuisine.

Read on-line help on how to use the built-in reports and how to createnew reports.

IMPORTANT All built-in reports were created using the HP Laserjet III printer exceptthe 
3x5_dotm.fp report which was created using the Panasonic KX-P1123. If your printer does not match 
the printer used to create the report, you need to modify the printer setup for each built-in report and 
specify your printer model.

For example, to specify your printer model for the recipes.fp report, do the following:

1.      From the View menu, select the Recipe view or click on the Recipe icon in the main tool bar. 
Recipes displays the Recipe view.

2.      From the File menu, select Modify Report.    Recipes displays the Select Report File dialog 
box.

3.      Select recipes.fp.    Recipes displays the report window.
4.      From the report's File menu, select Printer Setup. Recipes displays the Printer Selection 

dialog box.
5.      Select your printer from the Available Printers list.
6.      From the report's File menu, select Exit.    Recipes prompts you with the message "Do You 

Wish to Save the Modifications?"
7.      Select Yes.
8.      Repeat steps 1 to 7 for each report.



Glossary of Terms

This chapter contains common Recipes terminology along with other terms used throughout this 
User's Guide.

Alt key        A key on your keyboard that, when pressed in combination with another key, gives the 
other key an alternative meaning. In Recipes, pressing ALT plus another key enables you to request 
special functions; for example, pressing ALT and then the letter H causes Help information to display.

AUTOEXEC.BAT        The second of DOS's startup files that are modifiable. AUTOEXEC.BAT is a text 
file on the hard disk containing commands that configure the way DOS looks and behaves.

Boolean        Having to do with logical (true, false) values.

browser        A module or particular view of a module in Recipes; for example, the recipes browser lets 
you view all pertinent information about the recipes in your system.

button        A small box containing a letter or an icon that allows you to perform actions without having 
to remember commands or type them at the keyboard.

cell        The intersection of a row and a column that is an addressable (named or numbered) storage 
unit for information.

click        To press and release a mouse button once without moving the mouse. Clicking is used to 
select or deselect an item or to activate a program or program feature.

column        A series of items arranged vertically within some type of framework -- for example, a 
continuous series of cells running from top to bottom in one of the browsers. A column is equivalent to 
a field in a record, such as Recipe Name.

Control key        A key that, when pressed in combination with another key, gives the other key an 
alternative meaning.

data    An item or items of information.

dialog box        A special window displayed by Recipes to solicit a response from the user. For 
example, when you want to print a report, Recipes displays a dialog box containing controls 
representing various options: landscape vs. portrait mode, type of paper to use, etc.

dialog field        A field that causes user interaction. In Recipes, when a dialog field is entered in a 
report, each time you go to preview or print the report, you are prompted to enter something.

double-click        To press and release a mouse button twice without moving the mouse. Double-
clicking is a means of rapidly selecting and activating a program or program feature.

drag        To move an image or a window from one place on the screen to another by "grabbing" it and 
pulling it to its new location. With a mouse (in Recipes), drag means to hold down the left mouse 
button while moving the pointer on the screen. If the mouse pointer is on top of an object at the time 
the mouse button is pressed, dragging the mouse can also move the object. In Recipes, dragging the 
mouse can select blocks (such as several recipes), move icons on a desktop (or recipes between 
cookbooks), resize a window, etc.

Enter key        The key used to tell the computer that your input is complete.

.EXE        A filename extension that indicates the file is an executable program or one that can be run.

expression        A combination of symbols -- identifiers, values, and operators -- that yields a result 
upon evaluation.



field        A location in a record in which a particular type of data is stored. For example, the Recipe 
record may contain Name, Servings, Serving Size, and Ingredients. Individual fields have their own 
specifications as to the maximum length and the type of data that can be placed in them.

file name        The name given to a file. Using DOS and DOS/Windows applications, a file name can 
be from one to eight characters long, followed by an optional period and from one to three additional 
characters. The first part of the name is called the filename; the second part is called the extension. 
Although DOS allows for a variety of characters, you are better off using numbers and letters.

filter        A program that reads its standard or designated input, transforms the input in some desired 
way, and then writes the output to is standard or designated output destination, such as a report in 
Recipes.

hot key        A one- or two-keystroke command that when pressed, chooses the button or field. In 
recipes it is used    in combination with the ALT key or the CONTROL key.

icon        A small graphic image displayed on the screen to represent an object that can be 
manipulated by you. Icons are visual mnemonics; for example, in Recipes, the grocery cart 
represents a command for opening the shopping list option. Icons allow you to perform several 
actions without having to remember commands or type them at the keyboard.

identifier        Any text string used as a label, such as the name of a procedure or a variable in a 
program, or the name attached to a hard disk drive or a floppy disk.

label        An identifier. In Recipes, a label is a descriptive name, such as Manufacturer or Freezer 
Item, that identifies a group of cells.

operator        A symbol or other character indicating an operation that acts on one or more elements. 
Mathematical operators include the familiar + and - of addition and subtraction; logical operators 
(used in Recipes) include Boolean AND, OR, and NOT enabling programs to evaluate expressions, 
producing either true or false results (such as defining a Boolean field in the pantry setup as, Freezer 
Item).

row        A series of items arranged horizontally within some type of framework -- for example, a 
continuous series of cells running from left to right in a browser.

Shift key        A key that, when pressed, gives an alternative meaning to another key -- for example, 
producing an uppercase character when a letter key is pressed or choosing items successively.

TAB key        A key, often labeled with both left-pointing and right-pointing arrows, that is used in 
Recipes to move from field to field through the available choices.

value        A quantity assigned to a variable, symbol, label, or other such element.



Troubleshooting and Error Messages

This chapter is designed to help you diagnose and treat problems you may experience while using 
Recipes for Windows.

Printing Problems

Symptom
You can't get a report to print to your Desk Jet color printer.

Solution
1.      Verify that you are using the correct and latest driver for the HP550C. This is found in the 

printers portion of the Control Panel in your Main Windows program group. (Refer to your 
Windows documentation for details on the Control Panel.)

2.      If an HP550C or 500C is not available, choose the HP500 driver. The current driver for the 
HP500C is 3.1 per HP

Memory Problems

Symptom
You receive the message "Insufficient memory to run application, try closing one or more 
application."

Solution
1.      Using your regular backup procedure, backup all INI files in the root directory and other files 

you feel are important. If you don't have a regular backup procedure, consult your DOS 
manual to get instructions on the BACKUP command.

2.      Reinstall Windows 3.1 on your system.

Sharing Violation

Symptoms
You receive the message "SHARE MUST BE LOADED".

Solution
1.      Use any text editor to open your AUTOEXEC.BAT file located in your root directory. DO NOT 

EDIT THE SHARE.EXE file.
2.      Add C:\DOS\SHARE.EXE to the first line of the file where C:\ is the root directory.
3.      Save the file.
4.      Exit the text editor and Windows (if it is still open).
5.      Restart your machine.

Symptom
You receive an error message indicating there is a sharing violation on Drive C.

Solution
SHARE.EXE is conflicting with a TSR or some other applications. There are known problems with 
SMARTCAN and IMAGE from Norton Desktop and Recipes. In addition, the positioning of 
SHARE.EXE in your AUTOEXEC.BAT file might cause the error.

1. Using any text editor, open your AUTOEXEC.BAT file.
2. If you are using SMARTCAN and/or IMAGE, type REM at the beginning of those lines.
3. Move SHARE.EXE after the path or in a different location.
4. Save your file and then restart your system.
5. Try running Recipes again.

Corrupted System File



Symptom
You received a "corrupted library file" message.

Solution
1.      Locate the Recipes DLL files in the WINDOWS\SYSTEM subdirectory or the RECIPES2 

directory (depending upon whether or not you let Recipes install the system files in the 
Windows directory when you set up the program). These include the following:
CTL3D.DLL
OCCTRL20.DLL
OCREPORT.DLL
TBPRO1W.DLL
TBPRO2W.DLL
TBPRO3W.DLL
TBPRO6W.DLL
PXENGWIN.DLL

2.      Delete all Recipes DLL from WINDOWS\SYSTEM subdirectory or RECIPES2 directory using 
the ERASE or DEL DOS commands.

3.      Reinstall Recipes for Windows following procedures outlined in Chapter 2, "Setting Up 
Recipes for Windows."

Database Errors

Symptoms
You receive the message "Internal database error 248."

Solution
The database or your indexes may be corrupted.
1.      Exit from Windows and close all applications.
2.      From the DOS prompt, type CHKDSK and press ENTER. This checks for any bad sectors.
3.      If CHKDSK reports any bad sectors, follow the instructions on the screen for fixing those 

sectors.
4.      Change to the RECIPES2\DATA directory.
5.      Type DEL *.px and press ENTER.
6.      Type DEL *.x?? and press ENTER.
7.      Type DEL *.y?? and press ENTER. This deletes index files
8.      Restart Windows and try Recipes again.
9.      If you receive the message again, this indicates there is a problem with your database. Call 

technical support.

Symptom
You receive the message "Secondary Index out of date."

Solution
Indexes are corrupted.
1.      Exit from Windows and close all applications.
2.      From the DOS prompt, type CHKDSK and press ENTER. This checks for any bad sectors.
3.      If CHKDSK reports any bad sectors, follow the instructions on the screen for fixing those 

sectors.
4.      Change to the RECIPES2\DATA directory.
5.      Type DEL *.px and press ENTER.
6.      Type DEL *.x?? and press ENTER.
7.      Type DEL *.y?? and press ENTER. This deletes index files
8.      Restart Windows and try Recipes again.

Program is Slow

Symptoms



Recipes is running slow.

Solution
Recipes runs slow in standard mode and if you only have 2 MB of RAM.
1.      Verify if Windows is running in standard or enhanced mode by selecting About Program 

Manager from the Help menu.
2.      If you are running in standard mode, exit from Windows and close all applications.
3.      From the DOS prompt, type WIN /3 and press ENTER. This causes Windows to run in 

enhanced mode.
4.      Try running Recipes again. If the program is too slow, the Windows swap file is probably 

corrupted.
5.      Exit from Windows and close all applications.
6.      Restart Windows by typing WIN /3 and pressing ENTER.
7.      Delete the Windows swap file and then reinstall a permanent swap drive. Refer to your 

Windows documentation for instructions on the swap file.

Invalid Password Rights

Symptoms
You receive an "invalid password rights" message.

Solution
A duplicate PXENGWIN.DLL file exists.
1.      Locate this DLL file in the WINDOWS\SYSTEM subdirectory and the RECIPES2 directory 

and verify the dates of each one.
2.      Delete the older of the two using the DOS DEL command.
3.      If the newer one is not in the WINDOWS\SYSTEM subdirectory, copy it there using the DOS 

COPY command. Type COPY PXENGWIN.DLL C:\WINDOWS\SYSTEM.

Import Doesn't Seem to Work

Symptoms
When you try to use the Import recipes option, nothing happens.

Solution
1.      Verify you've exported from the other program in an ASCII (text) format.
2.      Try the Import option again.



 Exit

To quit the program choose Exit from the File menu.



 Index Help

Commands in this menu provide help for using Recipes for Windows and access to the standard 
Windows help-for-Help information.



 Context Help

Context sensitive help.    To access, press SHIFT+F1.    Point the question mark on the menu item or 
icon that you wish to get help on.



 Keyboard

Displays a quick reference to keystrokes used by Windows.



 Search

Displays the Search For Dialog Box.    Help is displayed as soon as the user selects a keyword to 
search for.



 Using Help

Explains how to use the Windows Help Engine.



 Windows Tutorial

Launch the Windows Tutorial.    The tutorial will show you some basic hints on using Windows.



 About

Displays the product name, the copyright notice and other useful information about the program.



 Restore

Choosing Restore returns a window to its previous size and position before it was maximized to 
full size.    To restore a window, select Restore from the System Control menu or select the small button 
with an up and a down arrow located in the upper right corner of the window.    (You can also double-click 
on the window's title bar.).



 Move

This System Control menu item lets you move a window or dialog to another screen position.    When 
you choose Move, a four-directional arrow pointer appears.    Use the mouse (or the arrow keys) to 
move the window, then release the mouse button (or press Enter).    You can also move the window or 
dialog by clicking on the title bar and dragging the window to a new screen position.



 Size

This System Control menu item lets you size a window on the desktop.    When you choose Size, a 
four-directional arrow appears.    Use the mouse (or the arrow keys) to size the window, then release 
the mouse (or press Enter).    You can also reposition the window borders by dragging the mouse.



 Minimize

Choosing Minimize reduces a window to an icon.    To minimize a window, select Minimize from 
the System Control menu or select the small button with a down arrow located in the upper right corner of 
the window.    Selecting Minimize in the list window reduces the window to an icon on the desktop.



 Maximize

Choosing Maximize enlarges a window to full size.    To maximize a window, select Maximize from 
the System Control menu or select the small button with an up arrow located in the upper right corner of 
the window.



 Close

Choosing this System Control menu item closes a window or dialog box.



 Task List

Choosing this System Control menu item opens the Task List dialog box which displays a list of    
currently open programs.    To switch to a another program, select it, then choose Switch To. 



 Next or Previous Window (CTRL+F6)

Switches to the next open window.



 Caption

The horizontal bar across the top of the main window.    It contains the title name of the application.    A 
title bar also contains, the System Control-menu box for the application window, and the Maximize 
and Minimize buttons or the Minimize and Restore buttons.



 Horizontal Scroll Bar

A bar that appears at the right side and/or bottom of some windows and in some dialog boxes.    The 
scroll bar contains a scroll arrow at either end and a scroll box that moves within the scroll bar, 
reflecting your position in a file.    Mouse users click the arrows or drag the scroll box to move forward 
or backward through the dialog box or list.    Keyboard users use the direction keys to accomplish the 
same thing.



 Vertical Scroll Bar

A bar that appears at the right side and/or bottom of some windows and in some dialog boxes.    The 
scroll bar contains a scroll arrow at either end and a scroll box that moves within the scroll bar, 
reflecting your position in a file.    Mouse users click the arrows or drag the scroll box to move forward 
or backward through the dialog box or list.    Keyboard users use the direction keys to accomplish the 
same thing.



 Minimize

To minimize a window, select Minimize from the System Control menu or select the small button 
with a down arrow located in the upper right corner of the window.    Selecting Minimize in the list window 
reduces the window to an icon on the desktop.



 Maximize

To maximize a window, select Maximize from the System Control menu or select the small button 
with an up arrow located in the upper right corner of the window.



 Border

You can reposition the window borders by dragging the mouse.

See Also:
Size



 System Control

The rectangular button, located in the upper left corner of the title bar, opens the System Control 
menu.    The System Control menu lets you size, move, minimize, maximize, restore, and close windows 
and dialog boxes, as well as switch to another program.



 Insert File

The Insert File dialog box allows you to insert a text file to the cursor position.    Type the file name 
you want to insert in the File Name edit box or select a file name from the Files list box.    You can 
select a different directory or drive.



 Append File

The Append File dialog box allows you to insert a text file to the end of the current file.    Type the file 
name you want to append in the File Name edit box or select a file name from the Files list box.    You 
can select a different directory or drive.



 Save As

The Save As dialog box allows you to save the current text file to a different name.    Type the new file 
name in the File Name edit box.    You can select a different directory or drive.



 Find Text (Directions)

The Find option allows to find a specific text entry.    Enter the text you want to find, select the 
appropriate options and press Find Next.



 Replace Text

The Replace dialog box allows you to find a specific text and replace it with the new text.    Enter the 
text you wish to replace in the Text to Find edit box and the new text in the Replace With edit box.    
Select the appropriate options.    Use the Find Next and the Replace button to replace one by one.    
Use the Replace All button to replace all the text found with the new text.



 Select Fonts Dialog Box

The Select Font dialog box allows you to change    the font size and type.    All of your directions or 
notes will appear in the font that you have choosen.    A font is a collection of type faces or styles used 
to give your output a particular look. Your choice of type styles depends on the printers you have 
installed.



 Select Fonts Dialog Box

The Select Font dialog box allows you to change    the font size and type.    A font is a collection of 
type faces or styles used to give your output a particular look. Your choice of type styles depends on 
the printers you have installed.





Windows Keys

The keyboard topics below come from Help for Windows. You can create similar keyboard topics for your 
application's Help. Choose from the following list to review the keys used in Windows:

Cursor Movement Keys
Dialog Box Keys
Editing Keys
Help Keys
Menu Keys
System Keys
Text Selection Keys
Window Keys



Cursor Movement Keys

Key(s) Function

DIRECTION key Moves the cursor left, right, up, or down in a field.

End or Ctrl+Right Arrow Moves to the end of a field.

Home or CTRL+Left Arrow Moves to the beginning of a field.

PAGE UP or PAGE DOWN Moves up or down in a field, one screen at a time.



Dialog Box Keys

Key(s) Function

TAB Moves from field to field (left to right and top to bottom).

SHIFT+TAB Moves from field to field in reverse order.

ALT+letter Moves to the option or group whose underlined letter matches the one 
you type.

DIRECTION key Moves from option to option within a group of options.

ENTER Executes a command button.

Or, chooses the selected item in a list box and executes the command.

ESC Closes a dialog box without completing the command. (Same as Cancel)

ALT+DOWN ARROW Opens a drop-down list box.

ALT+UP or DOWN ARROW Selects item in a drop-down list box.

SPACEBAR Cancels a selection in a list box.

Selects or clears a check box.

CTRL+SLASH Selects all the items in a list box.

CTRL+BACKSLASH Cancels all selections except the current selection.

SHIFT+ DIRECTION key Extends selection in a text box.

SHIFT+ HOME Extends selection to first character in a text box.

SHIFT+ END Extends selection to last character in a text box



Editing Keys

Key(s) Function

Backspace Deletes the character to the left of the cursor.

Or, deletes selected text.

Delete Deletes the character to the right of the cursor.

Or, deletes selected text.



Help Keys

Key(s) Function

F1 Gets Help and displays the Help Index for the application. If the Help 
window is already open, pressing F1 displays the "Using Windows Help" 
topics.

In some Windows applications, pressing F1 displays a Help topic on the 
selected command, dialog box option, or system message.

SHIFT+F1 Changes the pointer to  so you can get Help on a specific command, 
screen region, or key. You can then choose a command, click the screen 
region, or press a key or key combination you want to know more about.

(This feature is not available in all Windows applications.)



Menu Keys

Key(s) Function

Alt Selects the first menu on the menu bar.

Letter key Chooses the menu, or menu item, whose underlined letter matches the 
one you type.

Alt+letter key Pulls down the menu whose underlined letter matches the one you type.

LEFT or RIGHT ARROW Moves among menus.

UP or DOWN ARROW Moves among menu items.

Enter Chooses the selected menu item.



System Keys

The following keys can be used from any window, regardless of the application you are using.

Key(s) Function

Ctrl+Esc Switches to the Task List.

Alt+Esc Switches to the next application window or minimized icon, including full-
screen programs.

Alt+TAB Switches to the next application window, restoring applications that are 
running as icons.

Alt+PrtSc Copies the entire screen to Clipboard.

Ctrl+F4 Closes the active window.

F1 Gets Help and displays the Help Index for the application. (See Help 
Keys)



Text Selection Keys

Key(s) Function

SHIFT+LEFT or RIGHT ARROW Selects text one character at a time to the left or right.

SHIFT+DOWN or UP Selects one line of text up or down.

SHIFT+END Selects text to the end of the line.

SHIFT+HOME Selects text to the beginning of the line.

SHIFT+PAGE DOWN Selects text down one window.

Or, cancels the selection if the next window is already 
selected.

SHIFT+PAGE UP Selects text up one window.

Or, cancels the selection if the previous window is 
already selected.

CTRL+SHIFT+LEFT or RIGHT ARROW Selects text to the next or previous word.

CTRL+SHIFT+UP or DOWN ARROW Selects text to the beginning (UP ARROW) or end 
(DOWN ARROW) of the paragraph.

CTRL+SHIFT+END Selects text to the end of the document.

CTRL+SHIFT+HOME Selects text to the beginning of the document.



Window Keys

Key(s) Function

ALT+SPACEBAR Opens the Control menu for an application window.

ALT+Hyphen Opens the Control menu for a document window.

Alt+F4 Closes a window.

Alt+Esc Switches to the next application window or minimized icon, including full-
screen programs.

Alt+TAB Switches to the next application window, restoring applications that are 
running as icons.

Alt+ENTER Switches a non-Windows application between running in a window and 
running full screen.

DIRECTION key Moves a window when you have chosen Move from the Control menu.

Or, changes the size of a window when you have chosen Size from the 
Control menu.





Clipboard

This is a topic that describes the Windows term "clipboard". If you click the "clipboard" term within the 
Copying Text or Glossary topic, this Help topic will be displayed in a pop-up window.

This topic is also tagged with the keyword "clipboard," for use with the WinHelp Search option.



 




