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Chapter 1 Overview
TreeChart  is  a  program to  enable  attractive  organization  charts  (or  other  hierarchy  charts)  to  be
produced with minimal fuss and effort.

All box sizing and positioning is automatic; all you need to do is to decide what boxes look like, what
text to put in them, and what to do for the rest of the day, while you're waiting for your colleagues to
catch up with you.

1.1 Benefits

● Suitable for preparing:

☑ Organization Charts
☑ Work Breakdown Charts
☑ Cost Breakdown Charts
☑ Taxonomy Charts
☑ Parts Lists / Bills of Materials

... in fact, illustrating any hierarchical (or nearly hierarchical) arrangement!

● No drawing skills required: box sizing, positioning, line routing is automatic

● Assists you in achieving a consistent appearance, through style guides

● Preparing a chart is easy, but preparing further similar ones is even easier

● Import text, and prepare a chart the way you want it to look,  almost instantly

● Outlining facilities, to enable you to concentrate on the matter in hand

● Can print the  whole chart, or single departments / sub-systems

● Printing can be previewed, and automatically scaled to fit on a single page

● Simple to incorporate a chart in a word processor document

● Can export pictures for hand-drawn embellishments using other programs

● Special features to support common Organization Chart needs:
Assistants,
Co-Managed staff (shared employees)
Junior staff who report directly to senior staff
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1.2 What kinds of diagram can TreeChart help you produce?
TreeChart  has  been  designed  to  help  you  illustrate  hierarchical information.  We've  probably  all
encountered Organization Charts, but other similarly structured information is also quite common in
our working lives:
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Are there alternatives to using TreeChart?

Of course. For example:

● Avoid graphics, and stick to a table of text. A picture might be worth a thousand
words,  but  sometimes that  benefit  doesn't  outweigh the time or cost to prepare a
diagram.

● Use  pencil  and  paper.  Probably  also  a  ruler  and  eraser.  Somewhat  awkward  to
include a diagram in a word-processor document, and a photocopier is a must if you
want more than one copy.

● Use a general-purpose drawing program. Unless you're using the program regularly,
preparing a diagram will still be a laborious job; aligning boxes and connecting lines,
and matching box sizes, for instance. Making changes can still be a daunting task,
particularly if  the hierarchy is  re-organized.  Drawing programs are also not well
suited to importing text from other programs, nor outlining to concentrate on one
part of your hierarchy at a time. You wouldn't prepare a graph this way, why try to
prepare hierarchy charts?

● Use a competitor's  Organization Charting program. Yes,  there  are other  products
available similar to TreeChart. Each product tends to approach the job differently,
and each has its own strengths and weaknesses. We're confidant that TreeChart will
meet the needs of a great many people, but it might not be the right one for you. If
you can get the chance, try a few different programs before you spend your money.
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1.3 How TreeChart Manages Your Information

To tap  the  full  power  of  TreeChart,  it  is  helpful  to  understand  how  the  program  manages  your
information, and especially the relationship between the text in a box, and how that box appears when
drawn.

What's a Chart?

On one level, you can think of a chart as being what the program outputs to the printer. To TreeChart, a
chart is much more than this because the diagrams it produces are automatically generated from your
information.

You could regard TreeChart as a special-purpose database program. Like a database, you enter records.
Each record is composed of a number of fields. For example, a record might correspond to a person
within an organization; in this case you might choose to have just two fields: the person's name, and
his or her job title.

TreeChart then needs two further bits of information: how are the records related, and how should this
structure be illustrated. When you save a chart to a disk file, these three sets of information (records,
relationships & illustration options) are saved together. The pictures TreeChart makes for you are really
just how you'd like your database to be illustrated.

TreeChart works with information that is hierarchically structured.

What's a Hierarchy?

One of the basic methods people have of organizing information is by distinguishing between whole
objects and their constituent parts. This process happens under many different names: classification,
decomposition, divide & rule, structuring, organizing, breakdown, etc. Whatever terms are used, the
end result is the same: a hierarchical (or tree-like) description of the whole, where branches lead to
other branches and ultimately leaves. Three examples:

9



Organization Charts

A Company is composed of people. It is organized in terms of divisions and departments. Everyone
except the Managing Director reports to someone else.

Computer Filing System

A computer filing system stores files. To provide privacy and organization, files are arbitrarily grouped
into directories, which may themselves be grouped into directories.
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Car Parts List

A car is composed of many components. To organize the assembly, it is logically divided into sub-
systems, assemblies and sub-assemblies.

As you can see, while you can describe a hierarchy in words alone,  pictures enable everyone to grasp
the  structure of the information much more quickly. TreeChart stores and illustrates this structured
information for you.

A bit of terminology

In deciding that  TreeChart  would be a  generalised hierarchy illustration tool,  rather than simply a
Company Organization Charting program (for instance), we've also tried to leave the terminology of
the hierarchy general.

Each position in the chart is called a box, since each position will often (but not always) be drawn as
some text within a box. If you think of TreeChart as a special-purpose database program, each box
corresponds to a record.

Every box is at a certain level in the chart: the box at the top of the tree is at level 1, boxes directly
below that are at level 2, and so on. Despite that, we'll say that a box at level 2 is below a box at level
1. A box at  level  3 is  a  subordinate of the box its connected to at  level  2.  Boxes can only be a
subordinate of one other box, and that other box is always one level up.

Occasionally, we need to talk about a box and its subordinates. When we do, we generally refer to
these boxes as the parent and its children.

The sub-tree of a box is the box plus all boxes below it..
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An example:

Here,
A is at level 1; B & C at level 2; D, E, F & G at level 3; H & I at level 4
D is a subordinate of B; E, F & G are subordinates of C
When C is a parent, E, F & G are its children
The C sub-tree includes C, E, F, G, H & I

What's a Box?

As we've said, a box is TreeChart's term for a record in a hierarchically structured database.

A box is a number of lines of text. Each line of text is termed a Text Field. All boxes within a single
chart have the same number of Text Fields. You must decide how many Text Fields you need for each
chart, and assign each a unique name, so that it can be referred to while preparing the chart.

Isn't this rather restrictive? No -

● You can add, delete or rename Text Fields at any time
● Having constructed a hierarchy of boxes, the way the information is illustrated is

determined by the Layout settings you choose

What's a Layout?

A Layout defines how a box appears in a chart. Settings stored in a Layout include:

● Text: Which Text Fields are visible
Their position
Their font,  size, color, etc

● Box: Shape & interior color
Shadow direction, depth & color
Size (ie text margins, minimum size, aspect ratio control)
Border width & color

● Connections: Arrangement of this Box and its subordinates
12
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Spacing
Line width & color

This distinction between a box and its appearance may initially seem strange to you. You might think it
simpler to be able to say "I'd like this box to be red, and that box to be blue". This arrangement actually
brings great benefits:

● Layouts are style guides, helping you to achieve a consistent appearance
● Newly-inserted boxes can initially use the 'most likely' Layout
● Layouts can be saved without boxes, to form templates for new charts

Layouts are similar to Style Guides found in more sophisticated word processors, and can greatly assist
you in achieving a consistent appearance to your charts. Once you've defined a Layout, you can use it
as often as you like. Every box in a chart uses one of the Layouts you have defined. When you change
the settings of a Layout, it automatically affects every box using that Layout. You can tell a box to use
a different Layout any time you like.

You can define any number of Layouts. Each must be assigned a unique name so that it can be referred
to while preparing the chart. Give a bit of thought to naming your Layouts, since well-chosen names
can make it easier for you to choose which Layout a box should use. Two possible approaches are to
name  Layouts  functionally (eg  Manager,  Assistant,  Other  Staff)  or  descriptively (eg  'blue  circle;
connect centers', 5x3 cream box).

In  choosing  the  arrangement  of  a  box  and  its  subordinates,  each  subordinate  is  automatically
positioned and connected uniformly. For many charts,  this is exactly what you want.  In Company
Organization Charts, for instance, you'll sometimes want to illustrate slightly different arrangements.
TreeChart supports this, by marking individual boxes as exceptions to the normal Layout rules. See
section 3.7 for details.

When you insert a new box, the Layout it initially uses is determined by the Default Layout settings.

What are Default Layouts?

With every chart you can set Default Layouts. This table tells TreeChart which Layout a newly inserted
box should initially use. The Default Layout can be different for each level in your chart  The Default
Layout is just the one you feel a box is most likely to use at any level; you can change which Layout a
box uses at any time.

Not only inserted boxes initially use their Default Layout, but also boxes created when opening a text-
format file. So by defining some Layouts, setting Default Layouts, and storing them in a Template File,
ready-to-print charts can be generated from text-format files almost instantly.

What are Template Files?

A Template is simply a chart that acts as a starting point when you create a new chart or open a text-
format file. A Template contains:
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● A definition of the Text Fields
● A set of Layouts
● A definition of Default Layouts
● Other chart settings

Normally, a Template would contain no boxes, though you can store boxes in a Template file is you
wish - these boxes would then be created automatically for you when you create a new chart.

Can I add title text when printing?

Yes. Charts contain a  Border. This can be thought of as a large box which frames your chart when
printing, copying to the Windows clipboard as a picture, or saving as a picture-format file.

Like a box, the Border can have any number of Text Fields, and it uses a Layout. The Text Fields
defined for the Border are different from those defined for boxes.

1.4 The steps involved in preparing a chart
Preparing a chart is a five step process:

Define a hierarchy of boxes
Enter the text for each box
Specify how the chart should look: individual boxes & interconnections
Specify any titles and border
Print & Save the chart

Naturally, TreeChart lets you jump back and forth between these steps so you can try out your ideas
before committing the chart to paper. TreeChart  also offers a number of facilities for reducing the
amount of work at each step:

● Text can be imported from other programs, or pasted from the Windows Clipboard.
Both routes cause TreeChart to automatically create the boxes for the chart. The text
can even include the information necessary to define how the boxes are organized
within the hierarchy.

● In TreeChart, a Layout defines how a box and it's text looks. It also defines how a
box connects to boxes below it in the hierarchy when its drawn. Each box in a chart
uses one of the Layouts you define. If you change the settings for a Layout, the chart
is  automatically re-drawn to reflect the change in all boxes that  use that  Layout.
Minimising  the  number  of  Layouts  you  define  helps  maintain  a  consistent
appearance to your chart.

● You can even define Default Layouts,  so that whenever you create a new box, it
automatically uses the Layout you think is best for its position in the chart.
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● You can save any Layouts you have defined (together with titles, border, Default
Layouts and other settings) in a Template File. This file is automatically used as the
starting point for any new chart or if you open a text-format file saved by another
program.  Ready-to-print  charts  can  therefore  be  generated  from text-format  files
almost instantly.

Embellishing your charts with free-hand drawings

TreeChart is not one of those programs that seem to include every tool you could ever wish for (and
some you never even imagined): it simply aims to do one job well.

There may be occasions when you need to add free-hand drawings to your chart. TreeChart  doesn't
support this. Some alternative programs do, but almost invariably any embellishments you added are
lost if the charting program redraws your hierarchy. TreeChart  does, however, allow you to import
your chart (as a picture) into other programs better suited for general-purpose drawing; either by Copy
& Paste, or by saving as a picture-format file.

1.5 System Requirements

TreeChart requires Windows 3.1. It will not run under Windows 3.0

A Mouse (or similar pointing device) is not required, but is recommended; a small number of non-
essential operations are unavailable without a mouse.

Memory requirements: Like most Windows programs, the amount of information you can store in a
chart,  and  the  number  of  charts  you can  open simultaneously  are  limited only by the  amount  of
available memory.

Use of TrueType fonts, or comparable third-party font technology such as Adobe Type Manager, is
highly  recommended.  Zooming  & fit-to-page  operations  in  the  program require  scaleable  fonts.
Dialogs requesting font specifications show only scaleable fonts.

1.6 Assumed Audience

This  User  Guide  assumes  its  readers  to  be  familiar  with  working  with  programs  running  under
Microsoft  Windows. The basic,  common, techniques for working with Windows programs are not
described. Only those topics where TreeChart's operation is in any way different from (say) Microsoft
Write are described in detail. Chapters 1 and 2 of your Windows User's Guide provide an excellent
grounding in the basic techniques required to control any Windows program.
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1.7 The Shareware Concept

TreeChart is not free. It is not public domain. Just like a computer program costing ten times as
much, it is copyrighted by its owners, and you must purchase a license to use it.

Unlike a computer program costing ten times as much, you have the chance to try the program
before you commit yourself to purchasing the license. This 'try before you buy' concept is termed
Shareware.

In essence, FineLine Software (the copyright holders) are granting you a limited-time trial-use
license to evaluate this program to determine if it meets your needs. If, after 30 days, you wish to
continue  using  this  program,  you  must  purchase  a  full  license  for  continued  usage.  If  you
continue using this program beyond the 30 day trial-use license we have granted, you are doing
so without a license. This is illegal.

See Appendix 5 for our license agreement.

Purchasing a full license is termed 'Registering the program'. Registration brings many benefits
over and above the right to continue using the program. See Appendix 6 for the benefits of
registration, our upgrade policy and how to register.

This program is produced by a member of the Association of Shareware Professionals (ASP). ASP
wants  to  make  sure  that  the  shareware  principle  works  for  you.  If  you  are  unable  to  resolve  a
shareware-related problem with an ASP member by contacting the member directly, ASP may be able
to help. The ASP Ombudsman can help you resolve a dispute or problem with an ASP member, but
does not provide technical support for member products. Please write to the ASP Ombudsman at 545
Grover Road, Muskegon, MI  49442-9427 U.S.A. or send a CompuServe message via CompuServe
Mail to ASP Ombudsman 70007,3536. The OMB may be contacted by FAX by sending to the ASP
FAX number:  (+1)  (616)  788-2765.  In  communication  with  the  OMB please  include  a  telephone
number and/or FAX if available.

17



1.8 Notation for Keys and Key Combinations
Key names appear as small capitals; for example, CTRL or SHIFT.

Simultaneous key combinations are linked by plus signs; for example, CTRL+B or CTRL+SHIFT+B. This
notation indicates that the user should hold down the CTRL key while pressing the B key, or hold down
the CTRL and SHIFT keys while pressing the B key.

A similar convention is used for actions with the mouse buttons; for example, SHIFT+double click. This
notation means that the user should hold down the  SHIFT key while double clicking the left mouse
button. TreeChart does not use the right mouse button.

Sequential key combinations are linked by commas; for example ALT,F. This notation indicates that the
user should press and release the ALT key, and then press and release the F key.

UP,  DOWN,  LEFT and  RIGHT represent the  DIRECTION (arrow) keys, which are also available on the
numeric keypad if NUM LOCK is off.

When  describing  dialog  controls,  we  refer  to  choosing  buttons;  for  example,  "choose  the  Delete
button". To choose a button in a dialog, either click on the button with the mouse, or press  ALT+ the
underlined letter in the button legend.
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Chapter 2 Getting Started
2.1 Packing List
Files essential to run TreeChart:

TREECHRT.EXE The main program file
TK-TALG.DLL A secondary program file

Files recommended when running TreeChart:

TREECHRT.HLPOnline Help

Non-essential files:

Documentation, in Windows Write format:

TREECHRT.WRI User Guide (this file)
TUTORIAL.WRI Tutorial: Preparing your first chart

Further information, in simple text format:

TREECHRT.TXT Introductory information & late-breaking news
SAMPLES.TXT Lists and describes all sample charts & templates

Sample files:

*.TCF Sample Charts
*.TCT Sample Templates

The samples provided will vary from time to time. SAMPLES.TXT lists and describes the
current samples.

2.2 Installation
Firstly, ensure that all files noted as essential (above) are available. The evaluation copy of TreeChart
is  normally  distributed  via  Shareware  libraries  or  Bulletin  Boards  in  a  form  which  collects  all
associated  files  together  in  a  single  archive  file,  which  is  then  compressed  to  reduce  storage
requirements. The format of the archive file may well vary depending on how you obtained TreeChart,
and your supplier normally provides notes on how to extract the files within an archive.

Since you are reading this document, at least one TreeChart file has been extracted from the archive.
Please check that all the others are, too.

If you have not already done so, please read file TREECHRT.TXT before continuing. This file contains
19



both introductory information and late-breaking news.

After extracting all the files in the archive, the archive file itself is no longer needed. Before deleting it,
why not pass a copy to a friend or colleague to allow them to see how TreeChart can speed up their
work.

TreeChart neither requires nor makes any changes to any system or Windows configuration files.

Where should you put the files?

TreeChart  can be run from a floppy disc, but for performance reasons it is highly recommended that
you copy the files to a hard disc.

We strongly recommend that  you create  a  new directory exclusively for  TreeChart,  and  place  all
TreeChart files in that directory. This makes it simpler if you need to de-install TreeChart, and also
satisfies the program's requirements that a few of the files be in 'known' directories.

If,  for  any  reason,  you  cannot  follow  these  recommendations,  you  must ensure  that  the  files
TREECHRT.HLP and TK-TALG.DLL are:

either in the same directory as TREECHRT.EXE
or in the Working Directory (specified when you start TreeChart)
or in the Windows directory
or in the Windows System directory
or in a directory listed in the PATH environment variable
or in one of the directories mapped in a network

The program will not run if it cannot find TK-TALG.DLL. Online Help will not be available if the
program cannot find TREECHRT.HLP.

Creating an Icon in a Program Manager Group

One of the easiest ways to start a program under Windows is to double-click on the program's icon in
the Program Manager. To create a TreeChart icon in the Program Manager:

1 Select the Program Group you wish the icon to be in
2 From the File menu, choose New
3 In the New Program Object dialog box , confirm Program Item
4 In the Program Item Properties dialog box, enter details of TreeChart.

For example:
Description: TreeChart
Command Line: c:\treechrt\treechrt.exe
Working Directory: c:\treechrt

Specify the directory where you installed the TreeChart files.
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You can optionally open a TreeChart-format data file automatically when you start TreeChart. See
Starting The Program for details.

2.3 De-installation
Removing TreeChart from your system is quite straightforward.

Assuming you followed the recommendations when installing TreeChart, and placed all TreeChart files
in a separate directory on your hard disc:

1 If TreeChart is running, close the application window
2 Delete all files in the TreeChart directory
3 Remove the TreeChart directory

If you created a Program Manager icon for TreeChart, delete the icon by:

1 Click on the TreeChart icon to select it
2 From the Program Manager File menu, choose Delete

If you actually ran TreeChart (either from a floppy disc or after installing it on your hard disc), two
further operations are required to completely tidy up your system.

Delete the TreeChart preferences file

Delete the file TREECHRT.INI. This will be in your Windows directory.

If you omit this tidy-up, nothing serious will happen; you'll just be leaving a very small file on your
hard disk unnecessarily.

De-register with the Windows File Manager

As noted in Starting the Program (below), the first time TreeChart runs it automatically registers itself
with the Windows File Manager. This allows the File Manager to know that it should run TreeChart if
you ever double-click on a TreeChart data file (actually, any file with a .TCF file type).

In Windows File Manager...

1 From the File menu, choose Associate
In the Associate dialog box...

2 In the File with Extension edit control, enter TCF
3 In the Associate With combo, select (None)
4 Choose the OK button

If you omit this tidy-up, nothing serious will happen. If in future you double-click on a .TCF file from
within the File Manager, Windows will simply report an error that the TreeChart program could not be
started.
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2.4 Starting the Program
Starting TreeChart is just like starting any other Windows program. The precise methods depend on
what program(s) you are using to manage your desktop. In this section, we'll assume you're using the
standard Windows Program Manager and/or File Manager. If you're using other programs (eg. Norton
Desktop for Windows), the methods will be similar, but refer to the user guide for those programs for
details.

There are actually two separate operations you can perform from within other programs:

● Opening the TreeChart window (ie starting the program)
● Opening chart windows

These operations can be combined, but some restrictions occur because only one copy of TreeChart
can be running at any time, though that one running copy can have any number of chart windows open
simultaneously.

Program Manager: Starting TreeChart

If you created a TreeChart icon in a program group when installing TreeChart, just double-click on the
icon.

Alternatively, from the Program Manager File menu, choose Run. In the dialog box, enter the full
pathname of TREECHRT.EXE, or click on the Browse button to select from a list of programs.

If TreeChart is already running when you do this, rather than start a second copy, Windows merely
activates the copy that is already running.

Program Manager: Starting TreeChart, and opening a chart

You  can  specify  a  single  TreeChart-format  data  file  to  be  opened  automatically  when  you  start
TreeChart by adding the data file name to the Command Line. For example:

c:\treechrt\treechrt.exe sample.tcf

If you have created a TreeChart icon, the Command Line can be changed by choosing Properties from
the Program Manager File  menu.  If  the data file is  not  in the Working Directory specified in the
Properties, you will need to type its full pathname.

If TreeChart is already running when you do this, rather than start a second copy, Windows merely
activates the copy that is already running, but does not pass any command line options to the program.
TreeChart is therefore unable to open any charts you may have specified.

File Manager: Starting TreeChart

1 Display the directory containing TREECHRT.EXE
23



2 Double-click on TREECHRT.EXE

If TreeChart is already running when you do this, rather than start a second copy, Windows merely
activates the copy that is already running.

File Manager: Starting TreeChart, and opening a chart

This is not available the first time you run TreeChart on your system, but is available subsequently
because TreeChart automatically registers itself with the Windows File Manager.

1 Display the directory containing the TreeChart-format data file (.TCF)
2 Double-click on the .TCF file

If TreeChart is already running when you do this, rather than start a second copy, Windows merely
activates the copy that is already running. If the data file you selected is already open in TreeChart, the
chart window is activated. If the data file is not open, TreeChart opens it and activates the new chart
window. Any charts that are already open will remain open.

File Manager: Opening more charts when TreeChart is already running

This is not available the first time you run TreeChart on your system, but is available subsequently
because TreeChart automatically registers itself with the Windows File Manager.

1 Display the directory containing the TreeChart-format data file(s) (.TCF)
2 Select the .TCF file(s) - you can select more than one file
3 Drag and drop over the TreeChart window or icon

Any data files that are not already open within TreeChart will be opened. Any charts that are already
open will remain open.

2.5 Getting Help
Extensive online Help is  always  available  to  you when you are working  with TreeChart.  Help is
offered on a context-sensitive basis. This means that the help offered normally depends on what you
were doing when you requested help.

Command Prompts

The first level of help offered is command prompts. Whenever you highlight a menu item or press (but
don't release) a Toolbar button, a description of the command is displayed in the Status bar prompt
field (if the Status bar is shown).

Online Help

TreeChart uses the standard Windows Help facility. Once the Help facility has been started, you are
free to browse amongst topics, search for key words or phrases, add your own annotations to topics, or
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print topics. If you are unsure how to use Help, choose How to Use Help from the Help menu in either
TreeChart or Help itself, or press F1 when you are in Help.

Help menu

The TreeChart Help menu enables you to start the Help facility with an overall contents presented. This
can be useful if you are unsure what you need help on.

The Help menu also enables you to search the online Help for particular keywords.

Context-sensitive Help

Pressing F1 requests context-sensitive Help. The topic initially shown depends on what you were doing
when you pressed F1; if you press F1 while a menu command is highlighted, rather than perform the
command, help on the command is presented. If you press F1 while a dialog or message box is shown,
help on that dialog or message box is presented.

Once you have started the Help facility, you are free to browse among topics as normal. 

Help mode

Pressing SHIFT+F1 (or selecting the Help mode button in the toolbar) stops normal TreeChart operation,
and allows you to select something you'd like help on.

In this mode the cursor changes to an arrow with a question mark; just select a menu command or click
the left mouse button over a part of the TreeChart window to select the help topic. If you select a
command, rather than performing the command, help on the command is presented.

Pressing ESC leaves this mode without presenting help.

If you don't have a mouse, you are limited to selecting menu commands.

25



Chapter 3 Working with TreeChart
3.1 Introduction
TreeChart is a program to enable attractive hierarchy charts to be produced with minimal fuss and
effort.

TreeChart is  not a drawing program. All box sizing and positioning is automatic (albeit under your
control).

If you're new to TreeChart, we recommend that you prepare your first chart by working through the
tutorial:

TUTORIAL.WRI The tutorial itself, in Windows Write format
TUTORIAL.TCF The completed Tutorial chart

3.1.1 The parts of the TreeChart window

TreeChart is a standard Windows MDI (Multiple Document Interface) program. This means that the
program allows you to work with more than one chart at a time.

Each open chart is shown in its own window. The windows of all open charts are contained within the
workspace of the TreeChart application window.

If  you're  unfamiliar  with  working  with  multiple  document  (chart)  windows within  an  application
window, chapters 1 and 2 of your Windows User's Guide provide an excellent grounding in the basic
techniques required.

Almost every command you choose or selection you make while working with TreeChart is performed
on the chart in the active chart window. Two exceptions to this rule are:

● The selected printer, paper source, size & orientation
● Program Preferences (see section 3.11)

These  settings  determine  how  the  TreeChart  program  works,  rather  than  the  active  chart.  They
therefore affect every open chart.

The Toolbar

The Toolbar is the row of buttons across the top of the TreeChart window. The buttons are shortcuts for
several commonly used TreeChart commands. See section 3.1.2 for details.
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The Status Bar

The Status Bar is the horizontal bar at the bottom of the TreeChart window that displays information
such as your location in the chart, descriptions of menu commands, keys that are locked and other
information specific to the active chart. See section 3.1.3 for details.

Chart Windows

In a word processor,  a document window allows you to manipulate text. In a drawing program, a
document window allows you to manipulate picture elements (which might include lines, rectangles
and text).

In a TreeChart chart window, you are manipulating boxes, not lines, rectangles or text. You can insert,
delete and re-arrange boxes directly, but you cannot directly select or change the text within boxes, the
style of text or boxes, or how connecting lines are routed.

These attributes of boxes are changed by means of dialog boxes, each shown as a result of choosing a
menu command or pressing a shortcut key. After making a change, TreeChart automatically:

● Re-calculates how large boxes need to be to contain the text

● Re-positions boxes

● Re-routes connecting lines

While re-calculating the chart is automatic, you have a considerable degree of control over how the re-
calculation is done.

The background color of a chart window is the same as the Background Color you choose for the
chart. See section 3.8 for details.

3.1.2 The Toolbar

The Toolbar provides mouse shortcuts to many of the most commonly-used TreeChart commands.

Some of  the Toolbar  controls  are only available  under  certain  circumstances,  and  they  reflect  the
conditions in the active chart. If you switch to a different chart, the controls are updated to reflect the
conditions in the activated chart.

Equivalent menu commands (from left to right):

Open a new chart File / New
Open an existing chart File / Open
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Save the active chart File / Save

Cut selected boxes to the Clipboard Edit / Cut
Copy selected boxes to the Clipboard Edit / Copy
Paste Clipboard contents below Current Box Edit / Paste Below

Select all boxes Edit / Select All
Select Current Box and all boxes below it Edit / Select Sub-Tree
Select Current Box and all at same level Edit / Select Level
Select all subordinates of Current Box Edit / Select Subordinates

Mark Boxes as exceptions to the rules Edit / Mark Boxes

Add, delete, rename or edit Layouts Layout / Define Layouts

Remove Focus and expand collapsed boxes View / View All
Apply or remove Focus View / Focus
Collapse selected boxes View / Collapse
Expand selected boxes View / Expand
Expand all collapsed boxes View / Expand All

Print active view File / Print
Print Preview File / Print Preview

Help mode (no menu equivalent, see section 2.5)

The Toolbar also allows you to change the scale at which your chart is displayed. See section 3.1.14 for
details.

To hide or show the Toolbar:

either From the View menu, choose Toolbar
or Press SHIFT+F2

When the Toolbar is shown, a mark is displayed beside the command name on the View menu. To hide
the Toolbar, choose the command again.

When you start TreeChart, the initial state for Toolbar visibility will be the final state when you last
used TreeChart.

3.1.3 The Status Bar

The Status Bar displays information about the current state of the program or the current chart, and
comprises eight fields:
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Prompt Explains menu items as they are highlighted,
and notifies you of long operations (eg Open File)

Total Levels The number of levels in the active chart
Current Level The level of the Current Box in the active chart
CAP status State of Caps Lock key
NUM status State of Num Lock key
SCRL status State of Scroll Lock key
Total boxes The number of boxes in the active chart
Hidden boxes The number of boxes in the active chart hidden using outlining techniques

Some of the Status Bar fields reflect the conditions in the active chart. If you switch to a different
chart, the information is updated to reflect the conditions in the activated chart.

To hide or show the Status Bar:

either From the View menu, choose Status Bar
or Press CTRL+F2

When the Status Bar is shown, a mark is displayed beside the command name on the View menu. To
hide the Status Bar, choose the command again.

When you start TreeChart, the initial state for Status Bar visibility will be the final state when you last
used TreeChart.

3.1.4 The Caret and the Current Box

In  a  word  processor,  the  current  position  for  text  entry  is  indicated  by  a  caret.  With  graphical
information, a simple caret isn't quite sufficient. In TreeChart, the caret is a thin line which surrounds a
box. The surrounded box is called the Current Box. The color of the caret depends on the background
color of the chart; for a white background, it will be red.

Any  command  that  can  only  operate  on  one  box is  always  performed  on  the  Current  Box.  Any
command that could operate on a number of boxes simultaneously is performed on the selected boxes,
or if no boxes are selected, the Current Box. See section 3.1.7 for details on selecting boxes.

3.1.5 Moving around a chart and a window

Moving the  caret,  and setting the Current  Box is  much like setting the  insertion point  in  a  word
processor:

With a mouse click on a box

Keyboard The HOME key moves the caret to the top-left box.
The END key moves the caret to the bottom-right box.
The DIRECTION keys step the caret around the chart:
LEFT step to prior box at the same level
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RIGHT step to later box at same level
UP step to manager (next level up)
DOWN step to first subordinate (next level down)

The DIRECTION keys cycle; for instance, if you reach the end of one level, then press RIGHT, the caret
steps to the first box at the next level down.

Stepping the caret with the DIRECTION keys works in terms of the hierarchy rather than where boxes
are drawn. For example, if you press the RIGHT key, the caret will always step to the next box at the
same level; if boxes have been drawn down the page, this box would be drawn  below the Current Box.

Note that while this is the normal use for the  DIRECTION,  HOME and  END keys, TreeChart can also
operate in Scroll-lock mode. If Scroll-lock mode is selected, the DIRECTION, HOME and END keys scroll
the chart within the window without affecting the caret. Scroll-lock mode is toggled on & off with the
SCROLL LOCK key. The state of this key is indicated on the TreeChart window status bar.

If you are using a mouse, a number of operations automatically make the box you're pointing at the
Current Box as part of the operation.

When you move the caret the Current Box is automatically scrolled to make it visible within the chart
window.

3.1.6 Inserting Boxes

You can insert a new box above, below, to the left or to the right of an existing box. The existing box
you'd like the new box to connect to must first be made the Current Box.

As with stepping the caret with the DIRECTION keys (see section 3.1.5), box insertion works in terms of
the  hierarchy rather than where boxes are drawn. For example, to add a co-worker under the same
manager, you would always insert left (or right) of an existing box. Where the new box gets drawn in
relationship to the existing box is a separate issue.

After a new box is inserted, the caret  is  always moved to make the new box the Current Box. If
necessary, the chart window is automatically scrolled to make the newly-inserted box visible.

After the new box is inserted, you may automatically be prompted to enter the text associated with the
box. This option is selected in the Preferences dialog (see section 3.11).

The style  of  every  box is  determined  by which  Layout  each  box is  using.  Newly-inserted  boxes
initially use the Default Layout for the level they have been inserted at. See section 3.5 for information
on managing Layouts.

If you insert a new box  below a box that has subordinates, all those subordinates are 'demoted' and
become subordinates of the newly-inserted box. In Organization Chart terms, inserting a box below a
manager creates a new middle manager position.
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If you insert a new box above, to the left or to the right of a box marked as an Assistant, the new box is
automatically marked as an Assistant, too. See section 3.7 for details of marking boxes as exceptions to
the normal Layout rules.

If you make a mistake when inserting a box, you can undo the insertion. From the Edit menu, choose
Undo Insertion. Alternatively,  press CTRL+Z.

Inserting a box with the mouse

With the mouse, you can insert a new box connected to an existing box by simply dragging from the
existing box:

Move the cursor over an existing box and press (and hold down) the left mouse button. Moving the
cursor away from where you pressed causes the cursor to change, indicating the direction of insertion.

Releasing the left mouse button inserts a new box, the direction of insertion being determined by the
cursor shown when you release the button.

If you start a drag operation, you can cancel it by moving back to where you started dragging from.
The  cursor  changes  back  to  the  'Over  Box'  cursor.  Releasing  the  mouse  button  here  cancels  the
insertion.

Inserting a box with the keyboard or menus

Move the caret to the box you'd like the new box to be connected to.

To From the Edit menu Keyboard

Insert Left choose Insert/Left press ALT+LEFT
Insert Right choose Insert/Right press ALT+RIGHT
Insert Above choose Insert/Above press ALT+UP
Insert Below choose Insert/Below press ALT+DOWN

Inserting a box in an empty chart

Inserting a box in an empty chart is just like inserting subsequent boxes, except that you don't have to
tell TreeChart which box the new box should be connected to. The keyboard and menu box insertion
commands are unchanged.

To insert a box in an empty chart with the mouse, drag from anywhere in the chart window.

3.1.7 Selecting Boxes

Some TreeChart commands (for example, edit text) can only meaningfully operate on one box at a
time. These commands always work on the Current Box.
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Other TreeChart commands (for example, delete boxes) can work on a set of boxes simultaneously.
These commands will work on the selected boxes, or if no boxes are selected the Current Box.

Selected boxes are shown on the display by being drawn inverted; white boxes becoming black, for
instance. There are four basic methods of selecting boxes:

● individually
● by region
● by position
● dependent on their marker flag settings (see section 3.7)

By combining these techniques, an arbitrary set of selected boxes can quickly be defined.

To de-select all selected boxes:

either With the mouse, click on the chart
or From the Edit menu, choose Clear Selections
or Press CTRL+G

If you're using the mouse, clicking on a box will move the caret, clicking on the background will leave
the caret unchanged.

To select or de-select an Individual box:

either With the mouse, CTRL+click on the box

or 1 Move the caret to the box
2 Press SPACE

This is just like performing multiple selections in a list box (for example, selecting a group of files in
Windows File Manager).

Selecting a group of boxes by region

This can only be done with a mouse. If you press (and hold down) the left mouse button while not over
a box, then start to drag, a dotted rectangle will be drawn to indicate the selection region. Releasing the
mouse button completes the operation. All boxes entirely within the selection region will be selected. If
you  move  the  mouse  cursor  outside  of  you  chart  window  during  this  operation,  the  window
automatically scrolls.

The caret is moved to the first box in the selection region.

If you hold down  CTRL as you commence the selection, current selections are retained, and boxes
within the selection region are added to the set of selected boxes. If you do not hold down  CTRL,
current selections are cleared before selecting the boxes within the selection region.
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Selecting a group of boxes by position

Four commands let you select a group of boxes:

To Select From the Edit menu Keyboard

All boxes choose Select All press CTRL+A

All boxes at the same Level choose Select Level press CTRL+H
as the Current Box

All boxes directly below choose Select Subordinates press CTRL+I
the Current Box

The Current Box, and all choose Select Sub-Tree press CTRL+T
boxes below it

All of these commands are also available as buttons on the Toolbar.

These commands always add more selections. To remove any existing selections before selecting a
new group, use the Clear Selections command (see above).

3.1.8 Deleting Boxes

To delete boxes:

1 Select the boxes you wish to delete
(if no boxes are selected, the Current Box is deleted)

2 either From the Edit menu, choose Delete
or Press DEL

When  you  delete  a  box  that  has  subordinates,  but  don't  delete  the  subordinates  themselves,  the
subordinates are 'promoted'. For example:
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After deleting the selected box:

If you make a mistake when deleting boxes, you can undo the deletion. From the Edit menu, choose
Undo Delete, or press CTRL+Z.

If you undo the deletion in this example, all the promoted boxes are demoted to restore the chart to its
original state.

3.1.9 To Cut, Copy or Paste Boxes

TreeChart offers the conventional commands to copy information to or from the Windows Clipboard.
The Clipboard can be used to transfer information to another part of the chart, to a different chart or to
a totally different program.

This section describes Clipboard use when preparing a single chart and transferring information from
one chart to another. For a discussion of the wider issues involved in transferring information between
programs, see section 4.1.

To Copy boxes to the Clipboard:

1 Select the boxes you wish to copy
(if no boxes are selected, the Current Box is copied)

2 either From the Edit menu, choose Copy
or Press CTRL+C
or On the Toolbar, click the Copy button

If the boxes you selected were connected, the relative positions are remembered; if you copy a sub-
tree, it can be pasted as a sub-tree.

To Cut boxes to the Clipboard:

1 Select the boxes you wish to cut
(if no boxes are selected, the Current Box is cut)

2 either From the Edit menu, choose Cut
or Press CTRL+X
or On the Toolbar, click the Cut button
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The Cut command is equivalent to Copy followed by Delete.

If the boxes you selected were connected, the relative positions are remembered; if you cut a sub-tree,
it can be pasted as a sub-tree.

As when you delete boxes,  if  you cut a  box that  has  subordinates,  but  don't  cut  the subordinates
themselves, the subordinates are 'promoted'. See section 3.1.8 for an example.

If you make a mistake when cutting boxes, you can undo the deletion. From the Edit menu, choose
Undo Delete, or press CTRL+Z. If you undo a cut that caused boxes to be promoted, all the promoted
boxes are demoted to restore the chart to its original state.

To Paste boxes from the Clipboard:

Pasting boxes is similar to inserting a set of boxes. You can paste the Clipboard contents below, to the
left or to the right of the Current Box.

Move the caret to the box you'd like the pasted boxes to be connected to.

To From the Edit menu Keyboard

Paste Below choose Paste Below press CTRL+V
Paste Left choose Paste Left press CTRL+L
Paste Right choose Paste Right press CTRL+R

Pasting Below is regarded as the 'normal' operation; it is this command that has a Toolbar button, and
has been assigned the standard Paste shortcut key.

If you make a mistake when pasting boxes, you can undo the insertion. From the Edit menu, choose
Undo Insertion. Alternatively, press CTRL+Z.

If  you Paste  below a box that  has  subordinates,  all  those subordinates  are  'demoted'  and  become
subordinates of  the  first pasted box. In Organization Chart  terms, pasting a box below a manager
creates a new middle manager position.

If you Paste to the left or to the right of a box marked as an Assistant, the top-most of the pasted boxes
is automatically marked as an Assistant, too. See section 3.7 for details on marking boxes as exceptions
to the normal Layout rules.

Copying boxes from one chart to another

When TreeChart copies (or cuts) boxes to the Clipboard, the information it saves in the Clipboard is in
an internal format called TreeChart Outline Text format. The information saved includes the name of
the Layout used by each box, but not the actual Layout settings.

It works this way because its the most natural: if a number of boxes use the same Layout, pasted boxes
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will use exactly the same Layouts as they used before they were cut. If you happen to change the
Layout  settings  after  the  cut  command,  but  before  the  paste  command,  the  pasted  boxes  will
automatically  use  the  new  Layout  settings  (not  the  ones  in  force  when  the  cut  command  was
performed).

If you copy boxes from one chart to another, the Layouts used by these boxes might not be defined in
the chart  they're  being pasted into.  Alternatively,  they might be defined,  but  with totally  different
settings.

What TreeChart does when pasting boxes is this: if a box uses a Layout whose name is defined in this
chart, the box will use that Layout, otherwise it will use the Default Layout for the level it has been
inserted at. See section 3.5.2 for a description of Default Layouts.

This means that if you copy boxes from one chart to another, the pasted boxes will have the style &
appearance appropriate for the chart being pasted into, rather than the chart they were copied from.

At present, TreeChart offers no means to copy Layouts between charts.

3.1.10 Swapping box positions

If you need to change the order in which subordinates are presented, the Swap command saves you
having to perform multiple Cut & Paste operations. The Swap command is only available if exactly
two boxes are selected, and both boxes have the same parent box.

The Swap command exchanges the positions of the two selected boxes, and all boxes below these two.

To swap two sub-trees:

1 Select the top-most boxes of the two sub-trees you wish to swap
2 either From the Edit menu, choose Swap

or Press CTRL+W

For example:
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After swapping the selected boxes:

3.1.11 Undoing Changes

The  Undo  command  can  reverse  certain  changes  to  your  chart,  but  only  if  you  choose  Undo
immediately  after  making  the  change.  For  example,  if  you  accidentally  delete  some  Boxes,
immediately choose Undo to restore them.

Currently, the TreeChart Undo command undoes only Box deletion and Box insertion.

To undo recent box insertions or deletions:

either From the Edit menu, choose Undo
or Press CTRL+Z

The Undo command (on the Edit menu) will be shown in one of three states:

Undo (greyed) Nothing to undo
Undo Insertion Remove recently inserted or Pasted Boxes.
Undo Delete Remove recently deleted or Cut Boxes

By and large, any insertion or deletion will be remembered until another insertion or deletion occurs, at
which time it will be permanently enacted, and the new insertion or deletion remembered in case you
wish to undo it.

If you insert or delete a group of Boxes in one operation, and subsequently undo that operation, the
whole group will be affected. In particular, undone deletions will be restored to their original positions
in the tree, no matter how disconnected the set of Boxes.

While this Undo facility seems limited, you probably won't be too aware of the limitation in practise,
since the only operations you perform directly within the chart  window are selecting, inserting &
deleting  Boxes.  Other  operations  (like  changing  a  Box's  appearance)  are  performed  by  means  of
dialogs which offer the option of proceeding with or cancelling any changes you make.

3.1.12 Entering Measurements

A number  of  dialogs within TreeChart  permit  you to  enter  measurements  (margins,  for  example).
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Entering measurements is handled in a consistent fashion:

Measurements can be presented in either metric or imperial units (centimetres or inches). All dialogs
containing measurements offer radio buttons to select the units the measurements are to be presented
in. All measurements within a dialog are presented in the same units.

When a dialog containing measurements appears, the units will be as you last selected them. The units
on program startup are read from an initialisation file, and will be as you last selected them last time
the program was run. If the units cannot be read from the initialisation file, the program uses the units
specified by the International section of the Windows Control Panel.

The  number  of  decimal  places  used  when  measurements  are  presented  is  as  selected  in  the
International section of the Windows Control Panel.

The decimal separator used when measurements are presented is as selected in the International section
of  the  Windows  Control  Panel.  This  decimal  separator  must  also  be  used  when  you  enter
measurements.

You can enter measurements in a variety of units, for example:

3 in 4.25" 2.1 cm 15 mm 72pt (points) 16pi (pica)

Spaces between number and units are ignored. If no units are specified, the current presentation units
(centimetres or inches) are assumed.

All measurements used by TreeChart must be in the range 0" to 22" approximately. Attempting to enter
values outside this range results in an error message when you change presentation units or complete
the dialog.

3.1.13 Using outlining to concentrate on one part of your chart

Outlining is the technique offered by more sophisticated word processors to allow you to hide parts of
a document, and concentrate on other parts.

For example, this describes the structure of a simple document:

The Document
Chapter 1

Section 1
Section 2

Sub-section 1
Sub-section 2

Chapter 2
Section 1
Section 2
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Showing the document in this form already illustrates one aspect of outlining: hiding the actual text
within each section or sub-section, and just concentrating on the section headings. This will have been
achieved by using a command to collapse the sections.

If you wanted to edit the text within Chapter 1, Section 1, this heading would be expanded to show the
text beneath it.

Another example of outlining that you may be familiar with is the directory windows of the Windows
File Manager.

TreeChart offers outlining to perform much the same function: hiding some aspects of your chart, and
allowing you to better concentrate on other aspects.

The example document we described above could be shown in TreeChart terms like this:

If you just wanted to have a 'top-level' view of the chart, you could select the two 'Chapter' boxes, then
use the Collapse command. The chart would be redrawn like this:

Notice that when recalculating the box positions, the 'Chapter' boxes are now placed much closer
together. Boxes placement depends only on visible boxes, so that the chart looks attractive whatever

outlining selections you have chosen.

In an Organization Chart, Collapse is useful for viewing management, and hiding other staff.

If you insert or paste a new box below a box that has been collapsed, the collapsed box is automatically
expanded (to show the new box), and the new box is automatically collapsed (to keep the demoted
subordinates hidden).

If you collapse a box marked as Invisible, this is handled as a special case, as described in section 3.7.4

You reveal whatever's hidden below collapsed boxes by expanding them. Two commands do this: the
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Expand command expands the selected boxes, while the Expand All command expands all collapsed
boxes.

As well as hiding things below a box, TreeChart also allows you to hide things above a box. Returning
to the original chart, we can focus our attention on Chapter 1 by making the 'Chapter 1' box the Current
Box, then using the Focus command. The chart would be redrawn like this:

In saying that this hides all boxes above the Current Box, we're being a bit inaccurate; what the Focus
command really does is leave only the Current Box and all boxes below it visible; all boxes above it or

on different branches are hidden.

In an Organization Chart, Focus is useful for viewing just one department, and hiding all others.

You can only focus on one box at a time. When you are focusing on a box, a mark is displayed beside
the command name on the View menu. To remove the focus, and reveal the true top-level box, choose
the command again.

If the box you have focused on 'disappears', the focus is automatically moved to the parent of the box
that had the focus. This is done to ensure that you can always see the context you're working in. A box
can 'disappear' in two ways: by being deleted, or if you collapse a box marked as Invisible. See section
3.7.4 for a description of how Invisible boxes are handled as special cases.

As you might expect, the Focus & Collapse commands can be combined. For example, you might wish
to focus on Chapter 1, and then collapse the Section boxes to give you this:

A Summary of Outlining commands

To From the View menu Keyboard

Collapse selected boxes choose Collapse press CTRL+K
Expand selected boxes choose Expand press CTRL+E
Expand All boxes choose Expand All press CTRL+SHIFT+E
Focus on the Current Box choose Focus press CTRL+F

40

Chapter 1

Section 1 Section 2

Sub-section 1 Sub-section 2

Chapter 1

Section 1 Section 2



Remove Focus choose Focus press CTRL+F
View the whole chart choose View All press CTRL+Q

All of these commands are also available as buttons on the Toolbar.

The Collapse and Expand commands operate on the Current Box if no boxes are selected. The View
All command removes focus and expands all collapsed boxes.

The  commands  are  unavailable  (dimmed)  if  they're  not  meaningful.  For  example,  the  Expand
command  will  be  unavailable  if  the  Current  Box  (or  at  least  one  of  the  selected  boxes)  is  not
Collapsed. The Toolbar button therefore provides feedback as to whether the Current Box is collapsed
or not.

The Current View

The outlining selections you make define the Current View of the chart.

Wherever sensible, commands you select are always performed on the Current View. For example, the
Select All command selects all boxes in the Current View. 

The only operations that are always performed on the whole chart, rather than the Current View are:

● Saving the chart (in TreeChart format or Text format)
● Adding, deleting or renaming a box Text Field

Any outlining selections you make are  not saved with your chart; when you open a chart, you will
always initially see the whole chart.

Working with the Current View rather than the whole chart is particularly useful when you need to
output the finished chart:

● When you print, its the Current View
● If you copy a picture to the Clipboard, its the Current View
● If you save a picture-format file, its the Current View

TreeChart offers the option of printing as a poster (on a number of sheets of paper) or fitting the chart
to a single sheet of paper. Using outlining with an Organization Chart, for example, you could instead
choose to print each department or layer of management as individual pages, each with its own border
and titles. See section 3.9.1 for details.

The Chart Background Color

A chart has a background color which is used for the chart window, and when choosing box colors.
Some of the box positioning options cause boxes to be framed by other boxes. The background color
of the framed boxes is therefore the interior color of the framing box.
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If you use outlining techniques to Focus on a framed box, to hide all boxes above it and on different
branches, you might want to temporarily adopt the framing box's interior color as the chart background
color, rather than continue to use the normal background color. See section 3.8.3.

The background color used in the chart window is the background color used if you print a chart, copy
a picture to the Clipboard or save as a picture-format file.

3.1.14 Changing the scale at which your chart is displayed

TreeChart normally displays your chart at full size. You can choose to display the chart with various
preset scaling or zoom factors, to see more of the structure of the chart (but with illegible text) or more
clearly see small text sizes (but fewer boxes).

Zoom factors affect only how your chart is displayed on the screen, not how it is printed. Printing does,
however, offer the option of scaling your chart to fit on a page - see section 3.9.1 for details.

All the methods previously described for moving around and editing your chart are available whatever
the zoom factor. Note however, that at small Zoom factors, box shadows are omitted since they tend to
clutter up the chart.

A Summary of Zoom commands

To From the View menu Keyboard

Zoom in (make boxes bigger) choose Zoom In press +
Zoom out (make boxes smaller) choose Zoom Out press -
Reset to normal (100%) zoom choose Zoom Normal press =

You can also choose a specific zoom factor, but only if the Toolbar is shown. To set a specific zoom
factor, open the drop-down list on the toolbar, and select the desired setting. Keyboard users can access
this list:

F2 Opens the zoom list
DIRECTION keys change selection
ENTER confirm selection (closes list)

The Zoom In & Zoom Out commands move to the next preset zoom factor. They are ignored if you are
already displaying the chart at maximum / minimum zoom.

Whichever route you take to change the zoom factor, the current zoom setting (for the active chart) is
indicated on the Toolbar.

The zoom factor is not saved with a chart - when you open a chart the display will be at normal (100%)
scaling until you choose otherwise.
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3.1.15 Choosing and Using Fonts

Font Technologies

With the introduction of version 3.1, Windows has three built in font technologies.

Raster fonts are stored as  bitmaps. These bitmaps are designed for output devices  of a particular
resolution. Each device generally offers only a small range of available sizes. Font styles like bold and
italic, and intermediate sizes are synthesized by Windows, but the results are not always attractive. A
further problem is that the raster fonts available for any given printer generally won't match the raster
fonts available for the screen. The screen display is always an approximation of what will be printed.

Vector fonts are stored as collections of lines. They are time-consuming to generate but are useful for
such devices as plotters, on which bitmapped characters cannot be used. They also can be arbitrarily
scaled, but aren't very attractive whatever size you use.

TrueType fonts are stored as collections of points and hints that define character outlines. Windows
generates attractive bitmapped characters for any size as and when they are needed. There is a very
high degree of compatibility between what can be displayed and what will be printed.

Third-party font technologies (such as Adobe Type Manager) work in a similar fashion to the in-built
TrueType technology, and again permit arbitrarily scaled text.

As mentioned in section 1.5, zooming & fit-to-page operations in TreeChart require scaleable fonts.
These operations are seen as so fundamental to using TreeChart that dialogs letting you choose fonts
list only scaleable fonts.

Font availability

TreeChart stores with the chart details of the fonts you selected. If you subsequently edit the chart on a
different computer, the chosen fonts may not have been installed. When calculating the size of boxes
and displaying or  printing the  chart,  TreeChart  automatically  (and  without  warning) uses  the  font
provided by Windows as the 'nearest match' to what was selected.

This restriction currently affects almost all Windows programs. If you do a lot of this sort of thing,
you've probably already worked out which fonts are safe to use, and which fonts cause problems.

Fonts and text in exported pictures

TreeChart offers the ability to copy a picture of a chart to the Windows Clipboard (to be pasted into
another program) and to save a picture-format file (to be imported into another program). Details of
these operations can be found in Chapter 4 ("Working with other programs"), but a couple of font-
specific issues should perhaps be mentioned here.

TreeChart  copies  or  saves  pictures  in  a  format  known as  Windows  Metafile  (or  Aldus  Placeable
Metafile). This compact format enables the picture to be re-sized without any loss in picture quality
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and allows other programs to edit the constituent parts of a picture. These are considerable benefits
compared to working with bitmap-format pictures.

In its simplest terms, pictures (including text) can be scaled because the font used is selected whenever
the picture is subsequently drawn, rather than when TreeChart copied or saved the picture.

Take care when re-sizing a picture. Programs such as word processors will correctly scale everything
proportionately. Drawing programs, that recognise and work with the individual picture components,
are generally less successful in scaling text than lines & boxes. Additionally, you need to ensure that
the width to height ratio of the picture remains constant, otherwise text may no longer fit within boxes.

A second potential problem is that the fonts you have chosen must be available when needed. If you
copy a chart into a word processor document, then move that word processor document to a different
computer,  when  you  print  the  document  the  required  fonts  may  not  be  installed  on  that  second
computer.  In these circumstances Window uses the 'nearest'  font,  which may be unattractive.  This
restriction currently affects almost all Windows programs. If you do a lot of this sort of thing, you've
probably already worked out which fonts are safe to use, and which fonts cause problems.

The Font dialog box

Font selections are attributes of a particular Text Fields within a particular Layout, and are changed
from the Edit Layout or Edit Border Layout dialog boxes. In both cases, a common font dialog box is
shown.

When the font dialog is first shown, the dialog controls indicate the current settings for the Text Field.
You are then free to change any or all of these settings. Choosing the OK button updates the Layout,
choosing the Cancel button completes the font dialog without changing the Layout.

The Sample shows an example of text using the current settings.

The  Font combo and  Font Style combo are used together to select a font and its weight and slant
(bold, italic, etc). Only scaleable fonts are listed.

The Size combo allows you to select the point size. If you don't see the size you need in the list, you
can enter a number in the edit control.

Check the Strikeout checkbox if you want text to be struck out.
Check the Underline checkbox if you want text to be underlined.

The Color drop-down list allows you to select text color from a range of preset options.
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3.1.16 Choosing and Using Colors

TreeChart allows you to select the color of just about every aspect of a chart, though how well the
select colors are presented depends largely on the capabilities of your display and printer.

Colors are stored at a high resolution. TreeChart then asks the display or printer its using to do the best
it can to match those colors. For instance, printing a chart using color on a monochrome printer results
in various shades of gray. The precise mapping of color to the grayscale is left to the printer.

You can specify chart colors using a monochrome monitor (albeit without much feedback).  If  you
subsequently display the chart on a color monitor, the colors stored with the chart will be used.

Text Colors

Each Text Field (in each Layout) can have a different color. This is selected in the font-picker dialog
box. See section 3.1.15.

Other Colors

All other chart colors are attributes of a particular Layout, and are changed from the Edit Layout or
Edit Border Layout dialog boxes. In every case, a common color dialog box is shown.

The Chart Background Color

One of the attributes of the Border Layout is the Background Color for the chart. The color you choose
for this is used as the background color for the chart window and when choosing box colors. This
allows you to choose box and text colors that complement the background color. See section 3.8.3.

Custom Colors

TreeChart allows you to store 16 custom colors with each chart. These all default to white unless you
define different colors in a Template File. The custom colors simply allow you to enlarge a set of preset
colors, and you can pick a preset or custom color quickly, without having to fiddle around. It doesn't
define  a  'color  scheme'  for  your  chart:  changing  a  custom  color  doesn't change  all  the  chart
components using that color.

The Color dialog box

The color dialog allows you to choose a color. It is initially presented as a simple color-picker, offering
up to 48 preset colors chips and 16 custom colors chips. You can expand the dialog to define a color
different to the displayed preset and custom colors, or to change the custom colors.

The actual number of preset colors displayed is determined by the display driver. For example, a VGA
driver displays 48 colors, and a monochrome display driver displays only 16.

If the color you are changing matches one of the preset  or custom colors,  that color chip will  be
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selected initially.

To select an existing preset or custom color:

1 Click on the color chip
2 Choose the OK button

To modify a custom color:

1 Click on the custom color chip
2 Choose the Define Custom Colors button to expand the dialog
3 Specify the color (see below)
4 Choose the Add to Custom Colors button

To select a custom color:

First, choose the Define Custom Colors button to expand the dialog. Then:

either Specify red, green, and blue (RGB) values by using the Red, Green, and Blue edit
controls.

or Specify hue, saturation, and luminosity (HSL) values by using the Hue, Sat, and Lum
edit  controls.

or Click on the color spectrum control (at the upper-right of the dialog box) to select
hue and saturation values; click on the luminosity control (the rectangle to the right
of the spectrum control). This method is only available if you have a mouse.

Whichever technique you use...

The Color|Solid control displays the dithered and solid colors that correspond to your selection. (A
dithered color is  a  color  created by combining one or more pure or solid colors.) Note that  most
Windows devices are unable to use dithered colors to draw lines. Generally speaking, therefore, color
use is:

Box Border Color Solid
Connections Line Color Solid
Border Color Solid

Box Fill Color Dithered
Box Shadow Color Dithered
Background Color Dithered
Border Shadow Color Dithered

Choosing the OK button after defining a color causes that color to be used; choosing the Cancel button
leaves your chart unchanged (though the custom colors may have been changed). If you wish to add
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the newly-defined color to your table of custom colors, you must choose the Add to Custom Colors
button before choosing OK or Cancel.

Color Models Used by the Choose Color Dialog Box

The Color dialog box uses two models for specifying colors: the RGB model and the HSL model.
Colors you define are presented in both models, but you'll probably find things simpler if you define
your colors using the model you feel most comfortable with.

RGB Color Model

The RGB (red, green, blue) model is used to designate colors for displays and other devices that emit
light. Valid red, green, and blue values are in the range 0 through 255, with 0 indicating the minimum
intensity and 255 indicating the maximum intensity.  (With display devices,  the color black results
when the red, green, and blue values are set to 0--that is, with display technology, black is the absence
of all colors.) 

Example colors and their associated RGB values: 

Color RGB values

Red 255, 0, 0 
Green 0, 255, 0 
Blue 0, 0, 255 
Cyan 0, 255, 255 
Magenta 255, 0, 255 
Yellow 255, 255, 0 
White 255, 255, 255 
Black 0, 0, 0 

HSL Color Model

The Color dialog box provides controls for specifying HSL (hue, saturation, luminosity) values.

To the right of the dialog is a luminosity control. The square color spectrum has saturation on the
vertical axis, and hue on the horizontal axis.

Note that after selecting a white (or near-white) color chip, for instance an unused Custom Color, the
initial luminosity will be maximum, which would cause the color to be white whatever the hue and
saturation settings. If you find that changing hue or saturation has no effect on the Color|Solid control,
you need to adjust the luminosity first.

The saturation and luminosity values are forced to be in the range 0 through 240 and the hue value is
forced to be in the range 0 through 239.
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3.2 Defining Text Fields

The text that appears within a box is organized on the basis of a set of Fields. A Text Field is a single
line of text, up to a limit of 256 characters.  Before being able to enter the text  associated with a
particular Text Field in a particular box, the Text Field must be defined.

All boxes have the same number of named Text Fields. It is for you to choose how many Text Fields
you need, and what to name them. It is also for you to choose whether or not any particular Text Field
appears when a box is drawn.

If you create a new chart, the initially defined Text Fields are specified by the Template File. If you
create a new chart without selecting a Template, TreeChart initially defines two Text Fields: Name and
Position.

To define text fields:

Text Fields are defined in the Define Text Fields Dialog. To show the Define Text Fields dialog:

either From the Chart menu, choose Define Fields
or Press F3

You can build up a series of changes to the Text Fields, then proceed to alter the chart or cancel the
changes.

Note: the Fields list in this dialog permits several Fields to be selected. If you are unfamiliar with
working with extended-selection lists, Appendix 2 summarises keyboard shortcuts, while Chapter 4
("File Manager") of your Windows User's Guide gives step-by-step instructions.

To Rename an existing Field:

1 In the Fields list, select the existing Field you wish to rename
2 In the New Name edit control, enter the new name
3 Choose the Rename button

The Rename button is only enabled when text has been entered in the New Name control, and one
Field has been selected.

Field Names must be unique within a chart, and must be less than 256 characters.

To Add a new Field:

1 In the New Name edit control, enter the name of the new Field
2 Choose the Add button

The Add button is only enabled when text has been entered in the New Name control.
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Field Names must be unique within a chart, and must be less than 256 characters.

To Delete an existing Field:

1 In the Fields list, select the Field (or Fields) you wish to delete
2 Choose the Delete button

The Delete button is only enabled when at least one Field has been selected, and when no text has been
entered into the New Name control.

Any number of Fields can be deleted in one operation by selecting a group of Field Names.

Completing the operation:

After changing the Field definitions, choosing the OK button causes the changes to be applied to every
Box and Layout in the chart.

For newly added Fields, all boxes and Layouts will have the Field added. Box text for this Field will be
initially empty, and the Field will initially be hidden. You will need to edit each Layout in which you
want the Field to be visible.

For deleted Fields, all boxes and Layouts will have the Field deleted.

If you cancel the dialog, no changes will be made to your chart.

3.3 Entering Box Text

The text within the Current Box is entered or modified from the Edit Text Fields dialog.

To show the Edit Text Fields dialog:

either double-click on any box (this also makes it the Current Box)
or From the Edit menu, choose Text
or Press ENTER

Note: the Edit Text Fields dialog box can optionally be shown automatically whenever you insert a
new box. See section 3.11 for details.

Text fields, and their associated text are presented as a table. The number of fields, and their names,
will depend on what Text Fields have been defined for your chart.

Only the associated text can be modified, not the field names. To modify field names, use the Define
Text Fields dialog (see section 3.2).

Movement around the table is similar to a spreadsheet. Note that the  TAB key circulates the focus
between the table, the OK button and the Cancel button. To move around the table, use the DIRECTION
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keys (or, with the mouse, click on a cell).

Individual text fields act like normal single line edit controls. One consequence of this is that you can
only copy and paste individual fields (not a group of fields).

To Press

Copy selected text CTRL+C
Cut selected text CTRL+X
Paste text CTRL+V

Pasting text from another program (via the Clipboard) can result in TAB characters being placed in
your text. These are shown in this dialog as a vertical bar, indicating a non-displayable character. When
you complete the dialog, TreeChart converts each TAB to a single space. 

3.4 Changing a Layout
This section describes the process of editing a Layout, to define what Boxes look like.  Since any
number of boxes may be using the Layout you change, any changes you make will automatically affect
all boxes using the Layout.

Layouts are edited in the Edit Layout dialog.

To edit the Layout used by the Current Box:

either SHIFT+double-click on any Box (this also makes it the Current Box)
or From the Layout menu, choose Edit
or Press SHIFT+ENTER

To edit any Layout in a chart:

1 either From the Layouts menu, choose Define Layouts
or Press CTRL+D
or On the Toolbar, click the Define Layouts button

In the Define Layouts dialog:
2 Select the Layout you wish to edit from the list of defined Layouts
3 Choose the Edit button

This dialog allows you to change every aspect of a box's appearance, and provides immediate feedback
on the effects of any changes you make. Feel free to try various combinations of options; you can
always cancel the changes if you want.

Note that the title bar of the Edit Layout dialog always contains the name of the Layout being edited.

The sample providing feedback uses the Text Field Names to indicate Field position & appearance.
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When the Layout is subsequently used as we draw the chart, the size of the box is determined by
further factors, such as the length of the text and the chart-wide Match Box Size rules. Boxes will
always be made big enough to contain the text you have entered.

The background color of the sample is the same as the Background Color you choose for the chart. See
section 3.8 for details.

Completing the dialog causes all changes to be reflected in all boxes currently using this Layout.

Cancelling the dialog leaves your chart unchanged.

3.4.1 Text Styles

This group of controls allows you to change all options affecting how text appears:

● Which Text Fields are visible
● Vertical placement
● Horizontal alignment
● Font, size & color

All the text controls affect only the Text Field selected in the drop-down list of Field Names. You must
first select the Field you wish to change. The first defined Field is always selected automatically when
you commence this dialog.

The Hide checkbox determines whether the selected Field is visible or hidden. If the Field is hidden,
all other text controls are disabled, since it seems unwise to change options you can't see the effect of,
and will have no effect if modified.

The Font button causes a font selection dialog to appear. This allows not only the font and size to be
selected, but also the color and a number of effects (like underline). See section 3.1.15 for information
on choosing and using fonts.

The Horizontal Alignment list allows the selected Field to be positioned horizontally within the box:
Left-aligned, Centered or Right-aligned.

The Vertical Alignment list allows the selected Field to be positioned vertically with respect to the
box: Above the box, Top-aligned, Centered, Bottom-aligned or Below the box. TreeChart positions
boxes so that any text above one box doesn't overlap text below another, and text above or below a box
will obscure any connecting lines that may interfere with it.

Note that  the various margins affecting the Horizontal & Vertical  position are defined by the Size
button in the group of controls affecting the box itself.

The Up & Down buttons move the selected Field up & down. When a Field exchanges relative order
with a Field with a different Vertical alignment, the Vertical Alignment of this Field is automatically
updated to reflect this. These buttons are disabled when the selected Field can't go any further up (or
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down).
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3.4.2 Box Style

This group of controls allows you to change all options affecting how the box itself appears:

● The box shape
● Drop-shadow direction, depth & color
● Border width & color
● Internal color
● Box Size control

The Shape list allows you to choose the basic shape of the box. This can be augmented by selecting
aspect ratio options when specifying the box size, to make rectangular boxes square, or ellipses circles,
for example.

The  Size button calls up a further dialog permitting minimum box size,  Box aspect  ratio and text
margins to be defined. See below for more details of this dialog.

The Shadow list allows you to choose the drop-shadow style (including no shadow). You can choose
from three shadow depths in each of four directions.

The Border Width list offers a number of preset line widths (including no Border).

The group of Colors buttons allow you to change the Border, Fill or Shadow colors. Each button calls
up an identical color-picker dialog. In addition to standard colors, custom colors can be defined. Up to
16 custom colors will be stored with the chart. See section 3.1.16 for information on choosing and
using colors.

If you select the Transparent checkbox, the Box Fill Color is ignored, and the color is automatically
the same as whatever is underneath the box. This is often the chart background color (see section 3.8),
but might be the color of a surrounding box, as described in the next section.

3.4.3 Connections Style

This group of controls allows you to change all options affecting how this box is connected to its
subordinates:

● Relative position, alignment & spacing of this box & subordinates
(the routing of connecting lines is implied by this)

● The width & color of the connecting lines

The Style list offers a number of preset styles. These can then be modified by choosing alignment for
subordinates. See below for more details.

The Line Width list offers a number of preset line widths (including no lines).

The Line Color button calls up a color-picker dialog identical to those used for box colors. In addition
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to standard colors, custom colors can be defined. Up to 16 custom colors will be stored with the chart.

The  Spacing button calls up a further dialog permitting various distances between this box and its
subordinates to be defined. See below for more details of this dialog.

Connections Style and Alignment

As mentioned above, the most important controls of the Connections section of the Edit Layout dialog
select the relative position, alignment and spacing of a box using this Layout and its subordinates.

The arrangement of boxes is determined by the selections in two Connections list controls:

● Style
● Child Align

We suggest that the easiest way to understand the effect of these controls is to try various combinations
of selections and watch the effect on the sample in the dialog.

Connections Style

This  pictorial  list  indicates  box  arrangement  and  the  routing  of  connecting  lines.  The  way  that
subordinate boxes are positioned and the way connecting lines are routed should generally be obvious,
but a few aspects of the Style need a bit of further explanation.

Stretching the Parent box

Some styles have a parent box drawn wider than normal. This means that when re-calculating the
chart, TreeChart will automatically stretch the parent box to make it 'cover' the subordinate boxes, as
illustrated here:

Stretching boxes is done after calculating their minimum size and size matching; if the parent is
already bigger than its 'stretched' width, it will not be made smaller.
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Parent Alignment

After positioning subordinates (across or down), the parent box is positioned.

The basic options can be summarised as follows:

Offset Left The parent connection point is the left edge of the left-most subordinate - Offset Distance margin
Centered The parent center is the mid-point between the left-most and right-most subordinate edges
Offset Right The parent connection point is the right edge of the right-most subordinate + Offset Distance
margin

For example:

The following options are only available where subordinates are placed across:

Above Left The parent center matches the center of left-most subordinate 
Above Center The parent center matches the center of subordinate nearest the mid-point
Above Right The parent center matches the center of right-most subordinate

For example:

If Above Center alignment is selected and there are only two subordinates, the alignment is interpreted
as Center (it looks strange otherwise).

Options that make use of the Offset Distance margin (see section 3.4.5) are indicated with a filled box.
Options that ignore the Offset Distance margin are indicated with a hollow box.

Not all styles offer all alignment options.
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Boxes that surround (or frame) subordinate sub-trees

Two styles cause the parent  to surround (or  frame) its  subordinate sub-trees,  after  positioning the
subordinate sub-trees across or down:

The size of the parent box is automatically calculated; the subordinate sub-trees effectively replace any
vertically-centered text. Any vertically centered text is therefore normally hidden, but will be shown if

the box has no subordinates, or if its subordinates have been hidden by using outlining techniques.

The distinction between Box Size and Spacing is less obvious with these styles: the distances between
subordinates  are  specified  by  the  Layout's  Spacing  settings,  while  the  distances  between  the
subordinates and the frame (& its text) are specified by the Layout's Size settings.

You can specify a specific aspect ratio for a surrounding box, but not a minimum size. Surrounding
boxes are also ignored when matching box sizes.

If you select a box which frames other boxes, it is highlighted slightly differently: instead of inverting
the whole box, only the area outside the surrounded sub-trees is inverted.

If you use outlining to Focus on a framed sub-tree, you can choose whether TreeChart regards the
frame color as the chart background color, or whether the Border background color is retained. See
section 3.8.3 for details.
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Positioning some boxes across, and some boxes down

Two styles position  some subordinates down the page as a list, then position this list and  remaining
subordinates across the page:

The two styles offer Center or Center-Above parent alignment.

TreeChart automatically determines which subordinates to group into a list: it lists those subordinates
that don't themselves have subordinates.

In an Organization Chart, managers would be positioned across, while non-managers would be listed.
In a  parts list,  sub-assemblies  would be positioned across,  while  individual  components  would be
listed.

In general terms, children that are parents in their own right are positioned across, children who are not
also parents are listed. Using outlining facilities has no effect on this: a collapsed box is still a parent,
even though its children are hidden.

The  order of subordinates is significant for these styles, since only adjacent non-parents are formed
into a list. To form all non-parents into a single list, they must be adjacent. Note that boxes marked as
Assistants (as described in section 3.7.8) are not regarded as non-parents. If you find that non-parents
have  unexpectedly  been  grouped  into  two lists,  its  probably  because  you've  marked  one  of  the
subordinates as an Assistant. To group the parents into a single list, swap the position of the Assistant
with another box. The Swap command is described in section 3.1.10.

Since these styles are hybrids of the basic across or down styles, they use both sets of distances to
specify the spacing between boxes. See section 3.4.5.

Child Alignment

The Child Align list specifies how subordinates are to be aligned as they are positioned. The options
offered depend on whether the subordinates are positioned across or down.

If subordinates are positioned across, either the Top, the Bottom or the Center of the subordinate boxes
will be in a straight (horizontal) line. If the subordinate boxes all happen to have the same height, the
Child Align setting is therefore irrelevant.

If subordinates are positioned down, either the Left, the Right or the Center of the subordinate boxes
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will be in a straight (vertical) line. If the subordinate boxes all happen to have the same width, the
Child Align setting is again irrelevant.

As mentioned above,  two Connections Styles  list  some subordinates,  then position these lists  and
remaining  subordinates  across.  Child  alignment  control  for  these  styles  is  basically  as  if  all
subordinates were placed across: listed subordinates are always Left-aligned, then treated as a single
large  box.  For  example,  selecting  Bottom  for  Child  Alignment  results  in  the  bottom  of  each
subordinate placed across being in a straight (horizontal) line with the bottom of the lowest listed box.

3.4.4 Box Size

Factors determining the size of a box are one of two groups of settings not directly available in the Edit
Layout dialog. To change box size, you use the Box Size dialog.

To change the Box Size of the Layout used by the Current Box:

either From the Layout menu, choose Size
or Press F8

To change the Box Size of any Layout in a chart:

1 either From the Layouts menu, choose Define Layouts
or Press CTRL+D
or On the Toolbar, click the Define Layouts button

In the Define Layouts dialog:
2 Select the Layout you wish to edit from the list of defined Layouts
3 Choose the Edit button

In the Edit Layout dialog:
4 Choose the Size button

Note that the title bar of the Box Size dialog always contains the name of the Layout being edited.

There are two aspects to specifying the size of boxes using this Layout:

● Text margins
● Size Control

Text Margins

Boxes are always big enough to contain their associated text, then various margins are added before
determining the actual  box size.  The meaning of  the eight margins  is  illustrated by the following
diagram:
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Text fields having the same vertical alignment always have single line spacing.

The Above, Below, TopMiddle and BottomMiddle margins are only used if there are text fields above,
below, top or bottom vertically aligned respectively. If this is not the case, these margins are totally
ignored and have no effect on box size or spacing.

The Top, Bottom, Left and Right margins have, in a sense, two meanings:

In determining the initial box size, TreeChart calculates how much space is needed for the text, then
adds these margins to determine an initial box size. If Box Size rules specify a minimum, or Match
Box Size rules require equal sized boxes, the box may then be made bigger.

When drawing a box, these margins are subtracted from the box size to determine where to place text.
The overall  effect,  therefore,  is  that  right-aligned  text  field (for  example)  will  always be  a  fixed
distance from the right edge of the box, irrespective of how wide the box is made to satisfy size
matching rules.

Note that centered text (both vertically and horizontally) is centered within the region defined by the
final box size minus the Top, Bottom, Left and Right margins. If your Top and Bottom margins aren't
equal, or if your Left and Right margins aren't equal, the text will not be centered with respect to the
box itself. This feature allows effects such as this:
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Choosing which margins are used for text positioned above & below the box

The checkboxes Push Out Above and Push Out Below determine the Left and Right margins for text
fields above and below the box. Text fields inside the box are always inside the left and right sides of
the box (the distance inside being determined by the Left and Right margins). Text fields above and
below the box can use the same Left and Right margins, but if the corresponding checkbox is selected
instead regard the outer edge of the box as the left and right margins. The actual placement of text
fields still depends on the horizontal alignment selected in the Edit Layout dialog.

Size Control

Box size calculation is by default automatic: box size being the space needed for the text plus margins.
You can optionally specify a minimum height and/or width for a box. If you specify both a minimum
height and a minimum width, you can also select that these settings amount to a fixed aspect ratio,
which means that boxes using this Layout will always have the same height to width ratio.

Two examples:

To make rectangular box shapes square, or elliptical box shapes circular, select a minimum height and
width of zero, and select Fixed Ratio. Since the minima specified are zero, there is effectively no
minimum size to a box, but they will always be square (or circular) since the ratio is 1:1.

To force boxes to be 5x3, and have a minimum width of 2.5cm, select a minimum width of 2.5cm and
a minimum height of 1.5cm, and select Fixed Ratio.

Selecting a fixed aspect ratio for a box affects the behaviour of any box size-matching rules you may
specify for the chart. See section 3.6 for details

3.4.5 Box Spacing

Factors determining the spacing between a box and its subordinates are one of two groups of settings
not directly available in the Edit Layout dialog. To change spacing, you use the Box Spacing dialog.
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To change the Spacing of the Layout used by the Current Box:

either From the Layout menu, choose Spacing
or Press SHIFT+F8

To change the Spacing of any Layout in a chart:

1 either From the Layouts menu, choose Define Layouts
or Press CTRL+D
or On the Toolbar, click the Define Layouts button

In the Define Layouts dialog:
2 Select the Layout you wish to edit from the list of defined Layouts
3 Choose the Edit button

In the Edit Layout dialog:
4 Choose the Spacing button

Note that the title bar of the Box Spacing dialog always contains the name of the Layout being edited.

When calculating the relative positions of  a box using this Layout and its  subordinates,  up to six
distances can be specified, though not all distances are used for every style and alignment.

Two examples illustrate the use of all distances:

For styles resulting in subordinates being placed across
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Key: A Minimum Distance between this box and subordinates
B Minimum Horizontal Distance between subordinates
C Offset Distance between this box and subordinates
D Vertical Stem Distance

The Minimum Vertical Distance between subordinates is always ignored.

The Horizontal Stem Distance is used only if a subordinate is marked as an Assistant (see section
3.7.8). It is then used to determine both how far from the common connector to position the Assistant,
and the distance between Assistants.

The Offset Distance is used only when certain Connections Styles are selected. Styles using the Offset
Distance are indicated by a solid box in the pictorial Styles list.

The Vertical Stem Distance is ignored for Connections Styles that have no common connector portion.

Note: The Vertical Stem Distance must be less than or equal to the Minimum Distance between this
box and its subordinates. In other words, the horizontal connecting line in an Organization Chart (for
example) must be positioned somewhere between the bottom of this box and the top of the subordinate
boxes. This restriction exists because (at present) the Vertical Stem Distance is used only in drawing
the connecting lines, not in positioning the boxes. While some values outside the accepted range would
produce useful charts without any problems, larger values would cause problems. TreeChart takes the
'safety first' approach here, and doesn't accept an invalid Vertical Stem Distance.
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For styles resulting in subordinates being placed down

Key: A Minimum Distance between this box and subordinates
B Minimum Vertical Distance between subordinates
C Offset Distance between this box and subordinates
D Horizontal Stem Distance

The Minimum Horizontal Distance between subordinates and the Vertical Stem Distance are always
ignored.

The Offset Distance is used only when the Offset Left or Offset Right alignments are selected, and it is
the horizontal distance to the point where the connecting line emerges from this box.

The Horizontal Stem Distance is  also used if a subordinate is marked as an Assistant (see section
3.7.8). It is then used to determine both how far from the common connector to position the Assistant,
and the distance between Assistants.

The Offset Distance is used only when certain Connections Styles are selected. Styles using the Offset
Distance  are  indicated by a  solid  box in the pictorial  Styles  list.  It  then represents  the  horizontal
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distance to the point where the connecting line emerges from this box.

3.5 Managing Layouts

The Layout menu contains all commands for creating, modifying and managing Layouts.

The Layout used by the Current Box can be modified directly:

To Mouse Layout menu Keyboard

Modify the Text, Box SHIFT+double-click choose Edit press SHIFT+ENTER
or Connections styles

Modify Box Size choose Size press F8

Modify Spacing choose Spacing press SHIFT+F8

These operations are described in section 3.4.

The remainder of this section describes more general Layout management commands

3.5.1 Defining Layouts

The Define Layouts  dialog allows new Layouts  to  be created,  existing Layouts  to be renamed or
edited, different Layouts to be used for selected boxes, Default Layouts to be changed and Unused
Layouts to be deleted.

To show the Define Layouts dialog:

either From the Layout menu, choose Define Layouts
or Press CTRL+D
or On the Toolbar, click the Define Layouts button

All existing Layouts are listed, with the Layout used by the Current Box selected automatically.

Choose the Close button (or press ESC) to complete the dialog and return to your chart window.

The dialog has a Close button rather than OK and Cancel since all of the operations available from this
dialog are performed immediately,  and cannot  be undone.  Most  of these operations,  however,  are
actually performed via secondary dialogs, and in these secondary dialogs you have the choice whether
to proceed with or cancel changes you have made.
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To create a new Layout:

Newly created Layouts are always a copy of an existing Layout.

1 In the Layouts list, select one that acts as the best starting point for the new Layout.
2 In the New Name edit control, enter the name of the new Layout
3 Choose the New button

Layout names must be unique within a chart, and must be less than 256 characters.

The newly-created Layout will be added to the Layout list, and automatically selected, since you are
almost certain to want to edit it.

Creating a new Layout takes immediate effect, and cannot be undone. If you make a mistake, you
should either Rename or Delete the new Layout.

To edit a Layout

either In the Layouts list, double-click on the Layout name

or 1 In the Layouts list, select the Layout name
2 Choose the Edit button

The Edit Layout dialog appears. See section 3.4 for details.

To rename a Layout

1 In the Layouts list, select the Layout name
2 In the New Name edit control, enter the new name
3 Choose the Rename button

Layout names must be unique within a chart, and must be less than 256 characters.

Renaming a Layout takes immediate effect, and cannot be undone. If you make a mistake, you should
repeat the Rename operation.

To use a Layout for selected boxes

1 Select the boxes before you enter the Define Layouts dialog
(if no boxes are selected, the Current Box is used)

2 In the Layouts list, select the Layout name
3 Choose the Use button

Using a different Layout takes immediate effect, and cannot be undone. If you make a mistake, you
should repeat the Use operation.
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To change the Default Layouts

Choose the Defaults button. This command is also available on the Layout menu.

The Default Layouts dialog appears. See section 3.5.2 for details

To delete unused Layouts

Choose the Delete button. This command is also available from the Layout menu.

The Delete Unused Layouts dialog appears. See section 3.5.3 for details.

3.5.2 Default Layouts

Default Layouts are selected in the Default Layouts dialog.

To Specify the Default Layout for any Level:

either From the Layout menu, choose Defaults
or In the Define Layouts dialog, choose the Defaults button

The Default Layout for a particular level is determined as a two-step process:

1. If there is a specific Layout named as Default for this level, use it

2. If there is no specific Layout named for this level, use a chart-wide default.

The chart-wide default can be selected from the Default drop-down list.

Defaults for specific levels can be selected from the level-specific drop-down lists. If you don't want to
name a specific Layout as default for a level, just select '(default)' in the list.

Only eight levels can have defaults specified, any boxes inserted at levels nine and above will always
use the chart-wide default. You'll find that in practise, very few charts will have greater than eight
levels.

Choose the OK button to complete the dialog and implement the changes you have made. Choose the
Cancel button to abandon the dialog, leaving your Default Layouts unchanged.

To Use the Default Layout:

While the Default Layout for a given Level is only used when inserting a new box, there are occasions
when its useful to select a group of boxes and set them to use their Default Layout. One occasion is
when you copy a set of boxes to the Clipboard, then paste them somewhere else in the chart. TreeChart
preserves a reference to the Layout they were using and (assuming its still defined) uses that when
pasting back into the chart. Sometimes, this might not be what you want, so in these circumstances,
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select the boxes that have been pasted, then request that they use their Default Layout.

To force  selected  boxes  to  use  their  Default  Layout,  from the  Layout  menu choose  Use  Default.
Alternatively, press CTRL+U.

3.5.3 Deleting Unused Layouts

As you create, modify and use different Layouts, there will probably come a time when some of the
Layouts you have created are no longer needed. As a matter of good housekeeping, you should delete
any Layouts you are sure you won't need in future.

TreeChart itself never deletes Layouts - how could it tell whether or not you intend using them at a
later stage in chart preparation? Furthermore, TreeChart will not allow you to delete Layouts that are
being used. Only unused Layouts can be deleted. There are two situations where  you might think a
Layout is unused, but TreeChart won't agree with you:

● If a Layout is named as a Default
● If a Layout is used by a recently deleted (undo-able) box

Unused Layouts can be deleted in the Delete Unused Layouts dialog.

To delete unused Layouts:

either From the Layout menu, choose Delete Unused
or In the Define Layouts dialog, choose the Delete button

All currently unused Layouts are listed. Select the Layout(s) you wish to delete.

Note: the Layouts list in this dialog permits several Layouts to be selected. If you are unfamiliar with
working with extended-selection lists, Appendix 2 summarises keyboard shortcuts, while Chapter 4
("File Manager") of your Windows User's Guide gives step-by-step instructions.

Choose the OK button to complete the dialog, and delete all selected Layouts.  Choose the Cancel
button to cancel the dialog, leaving layouts untouched.

The Delete Unused Layouts dialog is only available if there are unused Layouts.
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3.6 Matching Box Sizes

While the size of individual boxes is determined by the text that they contain, and Layout options like
Fonts & Box Size, TreeChart also offers a variety of options to automatically make boxes the same
size.

To show the Match Box Size dialog:

From the Chart menu, choose Match Box Sizes

The height and width of Boxes can be controlled independently:

Independent No further size adjustments are made.

Equal Throughout Chart All Boxes will have the same size.

Equal Within Levels All Boxes at the same level will have the same
size.

Equal Among Subordinates All Boxes with the same Parent will have the same size.

Equal Using Layouts All Boxes using the same Layout will have the
same size.

Wherever sizes are changed, they are always increased.

Note: all  boxes  using  the  same  Layout  implicitly  have  the  same  height.  The  height  of  a  box  is
determined by which fields are present, their font sizes and the box margins; it is not determined by the
height of the actual text in the fields.

Marking boxes as exceptions to the size-matching rules

You can mark individual boxes as exceptions to the chosen size-matching rules. The markers allow you
either to ignore a particularly large box (and make all other boxes the same size as the second largest
box), or to prevent a particularly small box from being enlarged. See section 3.7.9 for details.

Matching box sizes when Outlining

As described in section 3.1.13, you can use outlining commands to hide some parts of your chart, and
concentrate on other parts. Using outlining complicates size matching slightly, since it introduces a
choice: should we match the sizes within the Current View or the whole chart?
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Consider, as an example, this chart:

In this example, box widths are made Equal throughout the chart.

If we collapse box 'C', to hide the exceptionally wide box, the chart could be redrawn two ways:

If we matched sizes within the Current View:

If we matched sizes throughout the entire chart:

You can choose which approach TreeChart should take, by changing the selected radio button in the
For Sizes Scan group in the Match Box Sizes dialog:

To Select

Produce the most attractive individual charts Current View

Have consistent box sizes over a set of sub-charts Entire Chart

Size matching rules and fixed-ratio boxes

As explained in section 3.4.4, you can specify a fixed height to width ratio for boxes using a Layout.
This interferes with the strict appliance of size matching rules. In these circumstances, the approach
taken by TreeChart is for the height of such a box to obey the size matching rules, and the width of the
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box to then be re-calculated to obey the aspect ratio rule. The program could then go on to use the new
width for others to be matched against, but the end result would be every box being square. This is
unlikely to be what you intended, since if it were you could have selected a fixed aspect ratio for all
Layouts.

3.7 Marking Boxes as Exceptions to the Rules

TreeChart minimises the amount of work you have to do by making two assumptions:

● That all subordinates to a box are positioned and connected uniformly

● That the hierarchy you are illustrating is 'pure': each box has only one parent

Most of the time you'll  appreciate the benefits of these assumptions, but occasionally you'll  find it
useful to be able to mark some boxes as exceptions to the rules.

You can think of boxes as having a set of flags associated with them. Each flag indicates a particular
exception condition, and you can set a flag to mark a box as an exception to the rule. By default, all the
flags are cleared. The flags are independent, and can be used in any combination.

When you save your chart (in TreeChart native format or TreeChart Outline Text format) the flags are
saved too. If you Cut or Copy boxes to the Clipboard then Paste them into a chart, the flags are copied
along with the box text.

You can set or clear individual marker flags using the Mark Boxes dialog. Many of the flags also have
shortcut keys which sometimes allow you to set or clear flags in common combinations.

You can also select boxes dependent on their marker flag settings using the Select Marked Box dialog.

The  next  two  sections  describe  how  to  use  the  Mark  Boxes  and  Select  Marked  Boxes  dialogs.
Subsequent sections explain in detail the meaning of each individual marker flag.

3.7.1 The Mark Boxes Dialog

The Mark Boxes dialog box allows you to change the individual markers for the selected boxes. If no
boxes are selected, the markers of the Current Box are changed.

To show the Mark Boxes dialog:

either From the Edit menu, choose Mark Boxes
or Press CTRL+M
or On the Toolbar, click the Mark Boxes button

Each individual flag has its own checkbox. The checkboxes are three-state, which means they can be
undefined as well as the normal on and off. The undefined state is indicated by a gray pattern. Clicking
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on a checkbox cycles through the three states.

When the dialog box is initially shown:

A checkbox will have an X if the corresponding flag is set in every selected box. 
A checkbox will be blank if the corresponding flag was clear in every selected box.
A checkbox will be grayed if the corresponding flag is different in the selected boxes.

If you choose the OK button, the dialog box is completed, and the flags in the selected boxes are
changed:

Where a checkbox has an X, the corresponding flag is set in every selected box.
Where a checkbox is blank, the corresponding flag is cleared in every selected box.
Where a checkbox is gray, the corresponding flag remains unchanged.

If you choose the Cancel button, the dialog box is removed without changing any flags.

3.7.2 The Select Marked Boxes Dialog

The Select Marked Boxes dialog box allows select all the boxes whose marker flags are in a state you
choose. The selected boxes are added to those already selected. To de-select any current selections,
click on the chart or use the Clear Selections command before starting this dialog.

To show the Select Marked Boxes dialog:

From the Edit menu, choose Select Marked Boxes

Each individual flag has its own checkbox. The checkboxes are three-state, which means they can be
undefined as well as the normal on and off. The undefined state is indicated by a gray pattern. Clicking
on a checkbox cycles through the three states. When the dialog box is initially shown all checkboxes
will be gray (undefined).

When selecting boxes, the checkboxes combine to form a search pattern. If you choose the OK button,
the dialog box is completed, and all boxes matching the search pattern are selected:

Where a checkbox has an X, the corresponding flag must be set for the box to be selected.
Where a checkbox is blank, the corresponding flag must be cleared for the box to be selected.
Where a checkbox is gray, the corresponding flag is ignored.

If you choose the Cancel button, the dialog box is removed without changing current box selections.
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3.7.3 Disconnect From Parent

Boxes marked in this way are simply 'disconnected' from their parent by omitting their connecting
lines. For example:

This exception is available mainly to support the automatic drawing of dual-reporting structures (Co-
Managers), but does enable some cosmetic effects such as:

To Press

Set the Disconnect from Parent marker CTRL+F9
Clear the Disconnect from Parent marker CTRL+SHIFT+F9

Points to note:

● As illustrated in the first example above, any part of the connector which is drawn
purely to attach a disconnected box is omitted.

● If all subordinates are marked as disconnected, any common part of the connector is
also omitted. If you do want to omit all connecting lines, its often easier to define
and use a new Layout, specifying a connector line width of '(none)'.

3.7.4 Invisible Boxes

Boxes marked in this way are simply not drawn, but their connectors are. This might seem a little
pointless, but its very useful in at least two situations. One is if you need to illustrate Co-Managers (as
described below), the other is if you need a box to be drawn at a level different from which it logically
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belongs. For instance, situations like this can arise in an Organization Chart:

In hierarchical terms, both the Manager and the Researcher are at level 2 (as drawn), since they both
report directly to the Director. Within the organization, however, the Researcher is considered to be at

the same level as the Engineers, since he's not regarded as managerial-grade. The chart would better be
drawn like this:

Effectively, the Researcher should be positioned at level 3, with nobody above him at level 2. To
achieve this, simply insert a box above the Researcher, then mark that new box as invisible.

To Press

Set the Invisible marker F9
Clear the Invisible marker SHIFT+F9

Using Outlining with boxes marked as Invisible

As described in section 3.1.13, you can use the Focus & Collapse commands to perform outlining, to
view only part of your chart. The Collapse command is handled slightly differently for boxes marked
as Invisible. These changes make the chart remain well proportioned, while showing you what you
asked for.

The handling of an Invisible box depends on whether or not the box is also marked as Disconnect from
Parent.
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Invisible, and Disconnected from its Parent

If a box marked as Invisible is  also marked as Disconnect from Parent, then as well as hiding all
subordinates of the Invisible box, the invisible box itself is also hidden. As an example, consider the
chart:

This chart has an Invisible box above the Assistant. The Invisible box is also marked as Co-Manage
Group, as described in section 3.7.7. If you collapse the two Managers and the Invisible box, without

treating the Invisible box as a special case, the Invisible box would remain, creating a large gap
between the Managers:

Treating the Invisible box as a special case results in a chart like this:

Therefore, after collapsing all subordinates of the Director, you (correctly) see only those staff who
report directly to the Director, without any undesirable gaps being introduced.

Since the Invisible box itself  has  been hidden,  it  cannot be made the Current  Box or  selected.  It
therefore cannot be Expanded in the normal way. To expand this box:

either Collapse, then Expand the Invisible box's Parent
or use the Expand All command
or use the Full View Command

74

Director

Manager

Engineer Engineer Assistant

Manager

Engineer Engineer

Director

Manager Manager



75



Invisible, but not Disconnected from its Parent

If a box marked as Invisible is not marked as Disconnect from Parent, the box is not collapsed. As an
example, consider this chart:

If you collapse the Manager and the Invisible box, without treating the Invisible box as a special case,
the chart would look like this:

Treating the Invisible box as a special case results in a chart like this:

Therefore, after collapsing all subordinates of the Director, you (correctly) see all staff who report
directly to the Director.

Other points to note:

● Invisible  boxes  can  still  be  selected  or  made the  Current  Box,  except  where  an
Invisible box has been Collapsed (as described above).

● The size and spacing of an Invisible box is calculated as normal. In the example
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above, to guarantee that the Researcher and the Engineer boxes are aligned, have the
Invisible box use the same Layout as the Manager.

● If you put text in an Invisible box, it is drawn, and obscures any connecting lines that
interfere with it. This can be useful to annotate lines.

● Invisible boxes remain subject to size-matching rules, unless you mark them to be
ignored when matching box sizes (see section 3.7.9).

● Subordinates of an Invisible box are still positioned and connected to the Invisible
box based on the settings of the Layout used by the Invisible box. All necessary
connectors are still drawn.

● Connector line width and color are 'inherited' from the Invisible box's Parent. This
prevents the need to create a new Layout just to stop line characteristics changing in
the middle of an Invisible box.

● Take care using Default Layouts. In the example above, the Researcher has been
moved to level 3. A box added to the left of the Researcher will initially use the
Default Layout for level 3. This will generally be what you'd prefer, but sometimes
won't  be.  If  you  wanted  the  Researcher  to  use  the  same  Default  Layout  as  the
Engineers, you could have inserted the dummy (invisible) box first, then added the
Researcher.

● Invisible boxes can also be useful to override the normal rules for aligning 
subordinates, and for some cosmetic effects. For example:

and (in conjunction with the Disconnect from Parent marker):
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3.7.5 Co-Manage Left

Boxes marked in this way have an additional connecting line drawn automatically: direct from the
center of the marked box to the center of the 'nearest' subordinate of the box to the left on the same
sub-tree. For example:

This is useful to illustrate some situations involving a dual reporting structure. For example:

To Press

Set the Co-Manage Left marker F10
Clear the Co-Manage Left marker SHIFT+F10

Points to note:

● Line  width  and  color  are  the  same  as  the  connectors  to  the  marked  box's
subordinates. Normally, this would be specified by the Layout used by the marked
box, but if the marked box is also marked as Invisible, the settings are inherited from
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the marked box's Parent.

● If there is no box to the left (on the same sub-tree), or if the box to the left has no
subordinates,  no line is  drawn.  The line is  not  drawn in the following situation,
because the box to the left is not on the same sub-tree:

● The 'nearest' subordinates of the box to the left might be the first or the last, depending on
relative positions.

● Apart from ensuring that the added line passes between any box and its shadow, no
intelligent routing is performed. The added line can look ugly in some situations, for
instance:

3.7.6 Co-Manage Right

This exception is exactly the same as Co-Manage Left (above), except that the additional line connects
the center of the marked box to the center of the 'nearest' subordinate of the box to the right on the
same sub-tree. For example:
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This is again useful in illustrating some situations involving a dual reporting structure. For additional
details see section 3.7.4.

To Press

Set the Co-Manage Right marker CTRL+F10
Clear the Co-Manage Right marker CTRL+SHIFT+F10

3.7.7 Co-Manage Group

Boxes marked in this way are disconnected from their subordinates, and those subordinates are instead
connected to the boxes to the left & right of the marked box (on the same sub-tree). For example:

This is useful in illustrating some situations involving a dual reporting structure. The marked box is
effectively a placeholder  grouping a department actually managed by the boxes to its left & right.

To Press

Set the Co-Manage Group marker (see below) F11
Clear the Co-Manage Group marker (see below) SHIFT+F11

Points to note:

● The shortcut keys set & clear the Co-Manager Group marker, and  also set & clear
the Disconnect from Parent and Invisible markers, since these are commonly used
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together. For example:

If this is not what you want, either clear the Disconnect and/or Invisible markers after
pressing F11, or select Co-Manage Group individually from the dialog box instead of pressing F11.

● Since the subordinates are disconnected from the marked box, connector routing is
automatically simplified to a straight line.

● Connecting line width and color for linking subordinates and linking subordinates to
the two Co-Managers is as specified in the Layout used by the marked box (even if
that box is invisible).

● If an outer subordinate is marked as being Disconnected from its Parent, the Co-
Manager link will be to an inner subordinate. For example:

● If all subordinates are marked as Disconnected, no Co-Manager links will be drawn.

● If there is no box to the left of the marked box (on the same sub-tree), no left Co-
Manager link will be drawn. If there is no box to the right, no right Co-Manager link
will be drawn. 

● If you mark adjacent boxes as being Co-Manager Groups, they are all connected 
individually to the first unmarked boxes either side of the marked boxes. For 
example:

81



● As illustrated immediately above, apart from ensuring that the added line
passes between any box and its shadow, no intelligent routing is performed. The

added lines can look ugly in some situations.

● The boxes to the left & right of the marked box can have their own subordinates; the
sub-tree below the marked box is managed by both. In the simple case of a shared
assistant, the marked box should have one subordinate:

● The position of the shared sub-tree is still determined by the position, size &
spacing of the marked box. To pull the shared sub-tree up the page, you might need to
create a new Layout for the marked box to use, then adjust the settings (as done in the

chart immediately above).

● Removing the marked box's invisibility allows effect such as this:
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3.7.8 Assistant

Boxes marked in this way are both positioned and connected to their Parent differently from normal
subordinates. For example:

This is useful in illustrating the common requirement when preparing an Organization Chart to indicate
that this subordinate is actually an assistant, secretary or has a similar relationship to a manager.

To Press

Set the Assistant marker F12
Clear the Assistant marker SHIFT+F12

Points to note:

● A subordinate box marked as an assistant is still a subordinate. If, for example, you
select all subordinates, any assistants will also be selected. The only real differences
between assistants and normal subordinates are in how the boxes are positioned, and
how the connecting lines are routed.

● The order of subordinates is unchanged when you mark a box as an assistant. If you
clear the Assistant marker, the box will be in the same relative position that it was
before. If you use the DIRECTION keys to move between subordinates, the choice of a
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normal subordinate or an assistant as the next box can appear random.

● A box can have any number of its subordinates marked as assistants. Assistants are
always positioned across  the page,  vertically  between the manager and the other
subordinates. The normal intention is that the assistants should be connected to the
common 'stem' of the connecting line. If this is not present, the assistant nearest the
manager is directly connected to the manager. This situation can arise if you choose
certain Connections Styles, if a manager has an assistant but no normal subordinates,
or if all subordinates have been marked as disconnected from their Parent.

Example with common stem:

Example without common stem:

● In positioning assistants differently from other subordinates, TreeChart ensures that boxes and
connectors don't normally interfere with each other. The only complication is when you've chosen a

Connection Style that doesn't have a common portion of the connector; here, lines can appear ugly (as
illustrated above). For this reason, we recommend that you don't use these Connections Styles with

assistants.

● Assistants will be positioned either all to the left or all to the right of the center of
their manager. This position is chosen automatically; dependent on the Connections
Style. Basically, assistants are placed to the right of the Manager, except where a
Connections Style placed the manager to the right of its subordinates.

● As with normal positioning, the Spacing settings of the Layout used by the manager
are used. The horizontal spacing is simply the Horizontal Stem margin. The vertical
positioning is a bit more subtle: effectively, the manager and its normal subordinates
are pushed further apart to accommodate the assistants. A gap is opened up, into
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which the assistants are placed. This gap is in the center of the 'available space'. If
normal subordinates are placed down, the available space is the "Minimum Distance
between this box and Subordinates". If normal subordinates are placed across, the
available space is the "Minimum Distance between this box and subordinates" minus
the Vertical Stem Distance. After placing the assistants, half of the 'available space' is
above the assistants, and half is below them.

● Assistants can still have their own subordinates (and assistants):

● Line width and color are the same as the connectors to the Parent's normal subordinates.
Normally, this would be specified by the Layout used by the marked box's Parent, but if the Parent is

marked as Invisible, the settings are inherited from the Parent's Parent.

● If you insert a new box above, to the left or to the right of an assistant, the new box is
automatically marked as an assistant. If you insert above an assistant, the existing
box remains marked as an assistant, and becomes "an assistant's assistant".

● If you Paste boxes to the left or to the right of an assistant, the first pasted box is
automatically marked as an assistant. Any other boxes pasted that happen to be at the
same level as the first pasted are  not marked as assistants. They will therefore be
normal subordinates of the assistant's manager. This situation only ever arises if you
copy or cut, then paste, an unconnected set of boxes.:

3.7.9 Ignore when matching Heights / Widths

These two markers  enable you to fine-tune the automatic matching of  box sizes.  As described in
section 3.6, the size matching rules allow you to ask TreeChart  to make all boxes (within various
categories) the same size. All the boxes would then be enlarged to match the largest box.

These markers allow you either to ignore a particularly large box (and make all other boxes the same
size as the second largest box), or to prevent a particularly small box from being enlarged.
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As an example, consider the difficulty in trying to achieve some sort of consistency between the widths
of the boxes in the following chart:

If you simply requested widths to be equal among subordinates, the result would be:

You might prefer to mark the largest box to be ignored when matching widths:

Only the remaining three boxes are compared to find the widest box, and the smaller two of these are
then enlarged to match it.

Alternatively, you could have marked the particularly small box to be ignored when matching widths:
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3.8 Creating a Border

When your chart is to be presented, a Border is added. The Border acts as a frame around your chart,
and can add titles, headers, footers or any other text fields that you need. The Border frames your chart
not only when printing, but also when copying the chart to the Clipboard as a picture, and when saving
a file in picture format. It permits results such as this:

The process of defining how the Border appears is very similar to deciding how an individual Box
appears:

● Define what Text Fields you need
● Decide what text to put in those fields
● Define the Layout
● Define the Margins

The similarity goes further, and in most respects the Border can be thought of as a special Box into
which your chart is placed as if it were Centered Text Fields.
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3.8.1 Defining Border Text Fields

To define Border Text Fields:

Border Text Fields are defined in the Define Border Text Fields Dialog. To show the Define Border
Text Fields dialog:

either From the Chart menu, choose Define Border Fields
or Press SHIFT+F3

This dialog is identical to the Define Text Fields dialog used to define the Text Fields for all boxes in
the chart, but the Fields presented will be different. The Border Text Fields are independent of the Box
Text Fields. An additional difference is that any Fields added will initially be visible, but you will need
to edit the Border Layout if the default font or position of newly added Fields is not as you wish.

If you create a new chart, and you have no Template file selected, TreeChart defines four Border Text
Fields: Header, Footer, Title and Subtitle.

You can build up a series of changes to the Border Text Fields, then proceed to alter the chart or cancel
the changes.

Note: the Fields list in this dialog permits several Fields to be selected. If you are unfamiliar with
working with extended-selection lists, Appendix 2 summarises keyboard shortcuts, while Chapter 4
("File Manager") of your Windows User's Guide gives step-by-step instructions.

To Rename an existing Border Field:

1 In the Fields list, select the existing Field you wish to rename
2 In the New Name edit control, enter the new name
3 Choose the Rename button

The Rename button is only enabled when text has been entered in the New Name control, and one
Field has been selected.

Border Field Names must be unique, and an error message is shown if you attempt to rename a Field to
using Name which is already in use

To Add a new Border Field:

1 In the New Name edit control, enter the name of the new Field
2 Choose the Add button

The Add button is only enabled when text has been entered in the New Name control.

Border Field Names must be unique, and an error message is shown if you attempt to add a Field to
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using an Name which is already in use.

To Delete an existing Border Field:

1 In the Fields list, select the Field (or Fields) you wish to delete
2 Choose the Delete button

Completing the operation:

After changing the Field definitions, completing the dialog causes the changes to be applied to the
Border.

For newly added Border Fields, text for this Border Field will be initially empty, and the Field will
initially be visible. You will need to edit the Border Layout  if the default font or position of newly
added Border Fields is not as you wish.

If you cancel the dialog, no changes will be made to your chart.

3.8.2 Entering Border Text

The text within the Current Box is entered or modified in the Edit Text Fields dialog.

To show the Edit Border Text Fields dialog:

either double-click on the chart background (IE not over a box)
or From the Chart menu, choose Border Text
or Press F7

Border Text fields, and their associated text are presented as a table. The number of fields, and their
names, will depend on what Border Text Fields have been defined for your chart.

Only the associated text can be modified, not the field names. To modify field names, use the Define
Border Text Fields dialog (see section 3.8.1).

Movement around the table is similar to a spreadsheet. Note that the  TAB key circulates the focus
between the table, the OK button and the Cancel button. To move around the table, use the DIRECTION
keys (or, with the mouse, click on a cell).

Individual text fields act like normal single line edit controls. One consequence of this is that you can
only copy and paste individual fields (not a group of fields).

To Press

Copy selected text CTRL+C
Cut selected text CTRL+X
Paste text CTRL+V
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Pasting text from another program (via the Clipboard) can result in TAB characters being placed in
your text. These are shown in this dialog as a vertical bar, indicating a non-displayable character. When
you complete the dialog, TreeChart converts each TAB to a single space. 

3.8.3 Defining the Border Layout

The Border Layout can be modified in the Edit Border Layout dialog.

To show the Edit Border Layout dialog:

either SHIFT+double-click on the chart background (IE not over a box)
or From the Chart menu, choose Border Layout
or Press SHIFT+F7

This dialog is similar to the Edit Layout dialog used to change the Layouts associated with Boxes, but
fewer options are available for Borders. Specifically:

● No Connections are associated with a Border
● The Box shape 'ellipse' is not offered for Borders
● Text Fields cannot be vertically centered

The third omission is explained by the fact that your chart effectively acts as the vertically centered
Text Fields for the Border.

Text Styles

This group of controls allows you to change all options affecting how text appears:

● Which Border Text Fields are visible
● Vertical placement
● Horizontal alignment
● Font, size & color

All the text controls affect only the Border Text Field selected in the drop-down list of Field Names.
You  must  first  select  the  Field  you  wish  to  change.  The  first  defined  Field  is  always  selected
automatically when you commence this dialog.

The Hide checkbox determines whether the selected Field is visible or hidden. If the Field is hidden,
all other text controls are disabled, since it seems unwise to change options you can't see the effect of,
and will have no effect if modified.

The Font button causes a font selection dialog to appear. This allows not only the font and size to be
selected, but also the color and a number of effects (like underline). See section 3.1.15 for information
on choosing and using fonts.
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The Horizontal Alignment list allows the selected Field to be positioned horizontally within the box:
Left-aligned, Centered or Right-aligned.

The Vertical Alignment list allows the selected Field to be positioned vertically with respect to the
box: Above the box, Top-aligned, Bottom-aligned or Below the box. Unlike box Layouts, the Border
Layout does not offer vertically-centered text: this is where your chart is positioned.

Note that the various margins affecting the Horizontal & Vertical position are defined by the Margins
button in the group of controls affecting the border itself.

The Up & Down buttons move the selected Field up & down. When a Field exchanges relative order
with a Field with a different Vertical alignment, the Vertical Alignment of this Field is automatically
updated to reflect this. These buttons are disabled when the selected Field can't go any further up (or
down).

Border Style

This group of controls allows you to change all options affecting how the border itself appears:

● The border shape
● Drop-shadow direction, depth & color
● Border width & color
● Background color
● Border Margins control

The Shape list allows you to choose the shape of the border.

The Margins button presents the Border Margins, which allows you to change the distances between
the border and its text fields, and the border and your chart. See section 3.8.4.

The Shadow list allows you to choose the drop-shadow style (including no shadow). You can choose
from three shadow depths in each of four directions.

The Line Width list offers a number of preset border line widths (including no border).

The group of  Colors buttons allow you to change the Border, Background or Shadow colors. Each
button calls up an identical color-picker dialog. In addition to standard colors, custom colors can be
defined. Up to 16 custom colors will be stored with the chart. See section 3.1.16 for information on
choosing and using colors.

The Fixed Background Color checkbox determines how the chart background should be treated when
using outlining techniques. If this checkbox is selected, the Border Background Color you choose will
always be used as the chart background color. If this checkbox is cleared, the chart background color
may vary depending on outlining selections. See section 3.1.13 for details.
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3.8.4 Defining Border Margins

The Border Margins specify the minimum distance between your chart and the border, and the absolute
distance between the border and the Border Text Fields.

When adding the Border to your chart, the margins are interpreted in two different ways:

● When copying a picture of your chart to the Clipboard, or saving as a picture-format
file,  the  Border  (and  Border  Margins)  are  added to  your chart.  The  picture  will
always be bigger than your chart; the extra area being the Border.

● When printing your chart, the Page Margins are  subtracted from the paper size to
determine where the Border is. The Border Margins are then also subtracted to leave
an area of paper available for the chart itself; what happens then depends on what
printing style (poster or fit-to-page) you have selected. See section 3.9.2 for details.

The Border Margins can be modified in the Border Margins dialog.

To show the Border Margins dialog:

either From the Chart menu, choose Border Margins
or Press CTRL+F7
or In the Edit Border Layout dialog, choose the Margins button

This dialog is similar to the Box Size dialog used to change the Sizing rules of individual Boxes, but
offers  no  control  over  minimum  size  or  aspect  ratio.  The  meaning  of  the  individual  margins  is
illustrated below:
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Text fields having the same vertical alignment always have single line spacing.

The Above, Below, TopMiddle and BottomMiddle margins are only used if there are text fields above,
below, top or bottom vertically aligned respectively. If this is not the case, these margins are totally
ignored and have no effect on box size or spacing.

The checkboxes Push Out Above and Push Out Below determine the Left and Right margins for text
fields above and below the border. Text fields inside the border are always inside the left and right
sides of the border (the distance inside being determined by the Left and Right margins). Text fields
above and below the border normally use the same Left and Right margins, but if the corresponding
checkbox is selected instead regard the outer edge of the border as the left and right margins. The
actual placement of text fields still depends on the horizontal alignment selected in the Edit Border
Layout dialog.

3.9 Printing a Chart
Printing TreeChart charts is much the same as printing any Windows document.

To

Print the Current View either From the File menu, choose Print.
or Press CTRL+P
or On the Toolbar, click on the Print button

Preview printing either From the File menu, choose Print Preview
or On the Toolbar, click on the Print Preview button
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Choose a different printer, paper From the File menu, choose Print Setup
size or printer-specific options

Change the margins between From the Chart menu, choose Page Setup
the paper edge and the Border,
or change the Print Style
(poster or fit-to-page)

Change the margins between either From the Chart menu, choose Border Margins.
the Border and the chart or Press CTRL+F7

3.9.1 Different ways of printing your charts

TreeChart can print your chart in two different styles:

Poster where all your fonts, sizes & spacing are absolute, and
your chart  will  be printed as  a  series  of  sheets  of  paper that
you'll need to stick together.

Fit-to-page where all your fonts, sizes & spacing are scaled to fit on a single
sheet of paper

A third option is to combine Fit-to-page printing with outlining.

TreeChart always prints the Current View - that is, if you have applied Focus to any box, or collapsed
any boxes, these outlining selections are applied to the printed chart as well as the chart displayed on
the screen. What you see on the screen is what will be printed. To print the whole chart, you must view
the whole chart.

The advantage of printing the Current View, rather than the whole chart, is that it allows you to print a
chart  as  a  series  of  pages.  With  an  organization  chart,  for  example,  you  could  print  top-level
management  on one page,  then each department on further pages.  Each page would have its  own
Border and titles.

To change the Print Style:

1 From the Chart menu, choose Page Setup

In the Page Setup dialog:
2 Select the Fit-to-Page or Poster radio button
3 Choose the OK button to complete the Print Setup dialog

3.9.2 Page Margins and Border Margins

When  printing,  the  paper  size  is  determined  by  the  selected  printer,  the  paper  source,  and  paper
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orientation.

The Page Margins specify the distance between the edge of the paper and the border, even if no border
is drawn because you chose a Border Line Width of (none) when editing the Border Layout  (see
section 3.8.3)

The Border Margins specify the minimum distance between your chart and the border, and the absolute
distance between the border and the Border Text Fields.

When printing your chart, the Page Margins are subtracted from the paper size to determine where the
Border is. The Border Margins are then also subtracted to leave an area of paper available for the chart
itself. If the chart fits in this area, its printed. If it doesn't fit in the area one of two things will happen:

● If the Print  Style is  Fit  to Page,  the chart will be scaled to fit  in the
available area.

● If  the  Print  Style  is  Poster,  the available  area will  be made larger  to
accommodate the chart.  This is  achieved by increasing the number of
sheets of paper required. The Border will remain at the same distance
from the paper edge, but will only appear on 'outer' sheets of paper.

No matter what size the chart is, or what Print Style is selected, the chart will  always be centered
vertically and horizontally within the 'available area'.

To

Choose a different printer or From the File menu, choose Print Setup
paper size

Change the margins between the From the Chart menu, choose Page Setup
paper edge and the Border, or
change the Print Style (poster
or fit-to-page)

Change the margins between either From the Chart menu, choose Border Margins.
the Border and the chart or Press CTRL+F7

3.9.3 Previewing a Chart before printing

The TreeChart Print Preview command lets you look at the pages of your chart as they will appear
when you print them. By viewing the pages in this way, you can decide what printing settings best suit
this chart before printing.

To preview a chart

either From the File menu, choose Print Preview
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or On the Toolbar, click the Print Preview button

The TreeChart window is replaced by the Print Preview window.

TreeChart opens the print preview window and displays the first one or two pages of the chart.

The Print Preview Toolbar at the top of the window shows the various commands available when
previewing. The Status Bar at the bottom of the window indicates both the selected Print Style (Poster
or Fit-to-Page), and the number of the pages currently being viewed.

Viewing different pages

In print preview, you can view one or two pages at a time, and you can step through the pages as they
would be printed.

To

Move to the next page choose the Next button

Move to the previous page choose the Previous button

View one page at a time choose the One Page button

View two pages at a time choose the Two Page button

TreeChart remembers whether you last previewed one or two pages at a time, and uses this setting the
next time you preview printing.

If you have a mouse, you can also move between pages by using the vertical scroll bar, but only if you
haven't zoomed the preview window.

Zooming the preview window

In print preview, you can look at each page three different ways:

● In the standard view, TreeChart scales down each page, and you can see the entire
page, including any Border Text. This is the initial view setting.

● In half-zoom view, TreeChart displays the pages approximately one-half the size they
would appear when printed.

● In  full-zoom view,  TreeChart displays the pages approximately the same size that
they would appear when printed.

To
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Zoom in to the next level either Choose the Zoom In button
or Click on the page

Zoom out to the previous level Choose the Zoom Out button

When zoomed, the preview window always shows a single page. If you are showing two pages in
standard view when you zoom in, the page you zoom in on depends on how you zoomed in. If you
choose the Zoom In button, you'll zoom in on the left-hand page. If you click on a page to zoom in,
you'll zoom in on the page you clicked.

Scrolling the preview window

The use of the scroll bar(s) depends on which preview view is shown:

In the standard view, only a vertical scroll bar is shown. Scrolling moves you one page forward or
backwards in your chart.

In the zoomed views, the scroll bar(s) scroll the zoomed page. You need to choose the Next Page or
Previous Page preview toolbar buttons to move between pages.

Note:  Scrolling the preview window can only be performed with a mouse;  there  are  no keyboard
equivalents.

Leaving print preview

You can close the print preview window with or without printing your chart:

To

Return to the chart window and Print the chart choose the Print button

Return to the chart window choose the Cancel button

3.10 Managing TreeChart Files

Working with TreeChart files is much the same as working with any other Windows file. For further
information about  working with files  and directories,  see Chapter  2  "Application Basics"  of  your
Windows User Guide.

The maximum size of a TreeChart file is limited only by the amount of memory in your computer.
TreeChart files are stored in a compact special format, and normally would have a filename extension
of .TCF. Template files are in the same format but would normally have a filename extension of .TCT
to show that they serve a different purpose.

TreeChart can also open text-format files saved by other programs to create a new chart, and save files
in a  number  of  other  formats  which  can  then  be  used by other  programs.  See  Appendix  3 for  a

97



description of the text file formats, and Chapter 4 ("Working with other programs") for details of how
to work with other format files.

3.10.1 Creating a new Chart

To create a new chart:

either From the File menu, choose New
or Press CTRL+N
or On the Toolbar, click on the New button

To speed up the process of preparing a chart, TreeChart can use a Template when creating a new chart.
This can specify the Border settings, any number of Layouts, and which Layout should be used for any
level within the hierarchy. 

See section 3.10.4 for information on working with Template Files.
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3.10.2 Opening an existing Chart

To open an existing chart:

1 either From the File menu, choose Open
or Press CTRL+O
or On the Toolbar, click on the Open button

In the File Open dialog:

2 Choose the file name of the chart you want to open

If you type the filename, you do not need to type the filename extension
.TCF. TreeChart automatically adds it to the filename you type.

3 Choose the OK button

3.10.3 Saving a Chart

When you are working with a chart - especially a large chart - you should save your chart often. Doing
so minimizes lost work if there is a power failure.

To save a chart, using the current filename:

either From the File menu, choose Save
or Press CTRL+S
or On the Toolbar, click on the Save button

When you save a newly-created chart for the first time, TreeChart prompts you for a file name.

The Save command is disabled if no changes have been made to the chart since it was opened or last
saved. The Toolbar button (in particular) gives a useful indication of whether or not you need to save
this chart. If you feel the need to save a chart even when the working copy is identical to the disk file,
you'll need to use the Save As command.

To save a chart, using a new name:

1 From the File menu, choose Save As

In the File Save As dialog:
2 In the File Name box, type a name for the file.

You do not need to type the filename extension .TCF.
TreeChart automatically adds it to the filename you type.
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3 Choose the OK button

3.10.4 Working with Template Files

A Template is simply a chart that acts as a starting point when you create a new chart.

A Template contains:

● Definition of Text Fields
● A set of Layouts
● Definition of Default Layouts
● Border text and Layout
● Page margins and print style (poster or fit-to-page)
● Overall box size-matching rules
● Custom color settings

Normally, a Template would contain no boxes, though you can store boxes in a Template file is you
wish - these boxes would then be created automatically for you when you create a new chart.

Template files are the same format as charts, but would normally have a filename extension of .TCT to
show that they serve a different purpose.

There are two situations where a Template is used:

● When you create a new chart
● When you open a text-format file

In both cases, TreeChart simply reads the Template File you have specified before allowing you to
modify the chart or reading the text-format file.

If you change the settings of a Template File, for instance, changing some colors, this will not affect
charts previously created from this Template, only charts created after the change.

If you choose not to specify a Template File, or TreeChart is unable to read the Template File you have
specified, TreeChart uses a built-in default Template.

To create a new Template File:

Since a Template is  simply an empty chart,  creating a Template is  just  like creating a chart,  then
deleting all the chart-specific information (ie the boxes):

1 Prepare a chart

To prepare a chart, you could open an existing chart whose style you wished to
use as a Template, or open an existing Template, or create a chart from scratch.
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2 Delete all the boxes

3 From the File menu, choose Save As

In the File Save As dialog:

4 In the Save File As Type drop-down list, select 'Template File (*.tct)'

5 In the File Name box, type a name for the file.

You do not need to type the filename extension .TCT.
TreeChart automatically adds it to the filename you type.

6 Choose the OK button

To edit an existing Template File:

Since a Template is simply an empty chart, editing a Template is just like editing a chart, then deleting
all the chart-specific information (ie the boxes):

1 either From the File menu, choose Open
or Press CTRL+O
or On the Toolbar, click on the Open button

In the File Open dialog:

2 In the List Files of Type drop-down list, select 'Template Files (*.tct)'

3 In the File Name box, choose the Template you want to open

If you type the filename, you do not need to type the filename extension
.TCT. TreeChart automatically adds it to the filename you type.

4 Choose the OK button

5 Temporarily insert some boxes to illustrate the changes you'll make

6 Make the desired changes

7 Delete all the temporarily inserted boxes

8 From the File menu, choose Save

To specify which Template File to use for newly-created charts:

1 From the File menu, choose Preferences

101



In the Preferences dialog box:

2 either In the Template File edit control, enter the name of the Template File

or 1 Choose the Browse button

In the Select Template dialog:

2 In the File Name box, select the Template to use

If you type the filename, you do not need to type the
filename extension .TCT. TreeChart automatically adds
it to the filename you type.

3 Choose the OK button

3 Choose the OK button to complete the Preferences dialog

The file name you enter can either be a full pathname (including drive & directories) or a relative
pathname. If the latter, the program will look in the default working directory for the file. The default
working directory can be specified as you start the program.

To use TreeChart's built-in default settings rather than a Template File, simply clear the Template File
edit control.

The selected Template will continue to be used until you select a different Template File. The Template
File  name  is  stored  in  TreeChart's  initialisation  file,  and  if  you  choose  to  save  your  program
preferences, the selected Template will also be used the next time you start TreeChart. If you don't save
your program preferences,  the  Template  File  will  be  reset  the  next  time you start  TreeChart.  See
section 3.11 for details on saving program preferences.

3.11 Setting Program Preferences

A number of options determining the operation of TreeChart can be specified by the user. All options
can be saved in an initialisation file, and restored the next time the program is started. Most options can
be set by means of a dialog, but some require the initialisation file to be edited. Full details of this can
be found in Appendix 4.

To change program preferences,  from the  File  menu,  choose  Preferences.  The Preferences  dialog
appears.

Choosing the OK button completes the dialog, and any changes to the preferences will take effect from
then on. Choosing the Cancel button completes the dialog with preferences left unchanged.
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3.11.1 Clipboard

The checkboxes in the Clipboard group determine the optional formats the program uses when copying
or cutting information to the Clipboard. The program always copies information in an internal format
for its own use. Other formats are for transferring information to other programs.

There are two formats in which we can usefully copy information: as text or as a picture. TreeChart
will happily copy both, but this can lead to difficulties in pasting information into other programs.

Choosing Paste in another program requires that program to choose one of the available Clipboard
formats.  All  programs  tend  to  choose  one  format  in  preference  to  another.  Word  processors,  for
example, have a tendency to paste the text copy, rather than the picture copy.

Many more recent Windows programs offer the Paste Special command, usually on an Edit menu.
Using this you can select the format to be pasted into the document.

By setting these  options,  you can  determine  in  what  format  the  information is  presented  to  other
programs, and either avoid the need for Paste Special (where available), or ensure they make the right
choice.

Unless you specify otherwise, the default is to copy as a picture, but not as text.

3.11.2 Dialog Positions

Opinions differ as to whether dialog boxes should appear near the program window (but seemingly
randomly positioned) or consistently in the center of the screen. Its a particularly disputed point among
users having access to large monitors, where they are capable of running two applications side by side,
and  are  nonplused  by  dialogs  appearing  some distance  from the  application  that  prompted  them.
Despite the obvious temptation to irritate users with better monitors than we've got, we do offer the
option of specifying where dialogs appear.

Unless you specify otherwise, the default is to position dialogs in the center of the screen.

3.11.3 Action after Inserting a Box

The checkbox Edit After Insert determines what happens when a new Box is inserted.

If this option is selected the Edit Text dialog appears automatically, to allow you to enter the text
associated with the newly-inserted Box. Disabling this option allows the structure of the chart to be
entered without dealing with the actual text within boxes until later.

Unless you specify otherwise,  the option is not selected, and the Edit Text dialog does not appear
whenever a new Box is Inserted.
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3.11.4 Template File

As described in section 3.10.4, a Template File can form the basis of a newly created chart, or a chart
created by opening a text format file. The preference dialog enables a file to be selected for use as the
Template. You can either type the filename of the Template, or choose from a list of available Template
files.

If you type the filename, it can either be a full pathname (IE including drive & directories) or a relative
pathname. If the latter, the program will look in the default working directory for the file. The default
working directory can be specified as you start the program.

To select from a list of available Template files, choose the Browse button to show the Select Template
dialog.

3.11.5 Saving Preferences

Choosing the Save button causes the preferences as they appear on the dialog at that moment to be
stored in the program's initialisation file immediately.

Checking the Save Preferences on Exit checkbox causes the program to store the preferences in the
initialisation file when you close the program.

Unless you specify otherwise, preferences are saved when the program exits.
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Chapter 4 Working with other Programs
One aim when designing TreeChart was to recognise the importance of sharing information with other
Windows programs. TreeChart will often be used in situations where preparing a chart is only a small
part of a larger job, perhaps preparing a report, a newsletter or a project plan.

For programs to be able to exchange information, they must agree on the format of the information.
TreeChart does not aim to recognise all possible formats, but it does support two of the main formats
for data exchange used by Windows programs, enabling it to input text from another program, and
output text or pictures for use by another program.

Text formats supported are those adopted for tabulated information: a record (Box) being one line of
text, with special characters separating fields. In many cases, you may not need to know the details of
these text formats, but for reference, further information is in Appendix 3.

TreeChart exports pictures as Windows Placeable Metafiles (also known as Aldus Placeable Metafiles).
These permit resizing without any loss of picture quality.

Like most Windows programs, TreeChart can exchange information either by saving & opening files,
or by copy & paste via the Windows Clipboard.

4.1 Using the Windows Clipboard

The Clipboard is a mechanism built into Windows to permit information to be exchanged between
programs. This normally simply involves selecting some information in one program, Copying it to the
Clipboard, starting or switching to the other program, selecting where the information is to be inserted,
then Pasting the information. A further Clipboard operation Cut, is equivalent to Copy followed by
Delete.

This  powerful  Windows  feature  relies  on  programs  agreeing  the  format  of  information  on  the
Clipboard. TreeChart copies chart information in up to three different formats:

Native actually TreeChart Outline Text (see Appendix 3.4)
This format is principally for cut & paste within a chart or between two

different TreeChart documents. The selected boxes (and references to the Layouts
they use) are copied to the Clipboard, or if no boxes are selected, the Current Box.

Text Tab-separated text (see Appendix 3.2)
This format would principally be used for exchanging information with a

word processor or spreadsheet. No Layout or organizational information is copied.
The text fields of the selected boxes are copied, or if no boxes are selected, the text
fields of the Current Box.
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Metafile A scaleable picture format.
This format is used for pasting a picture into a word processor document.

TreeChart  copies  the  entire  Current  View (plus  the  Border)  -  box  selections  are
irrelevant.

TreeChart  always copies to the Clipboard in Native format. The use of Text & Metafile formats is
controlled by means of the Preferences dialog, called up by choosing Preferences from the File menu.
See section 3.11 for further information on this subject.

4.1.1 Copying Text from another program into TreeChart

To a large extent, this works as you might expect. After giving a few examples, we'll describe in more
detail what's going on in the background, so that if you have any problems you might be able to work
around them.

To copy text from Notepad (or similar editor / word processor):

1 Switch to the Windows Notepad accessory
2 Select the lines of text you want to copy
3 From the Edit menu, choose Copy
4 Switch to the TreeChart chart window you wish to paste into
5 Move the caret to select the Current Box
6 From the Edit menu, choose Paste Below, Paste Left or Paste Right (as necessary)

One new box will be created for each line of text you selected.

The conversion of each line of text into Text Fields depends on characters within the text.  In the
simplest case, any TAB character will be interpreted as a Text Field terminator, so if you're going to
paste into a chart with four Text Fields defined, for the fastest results you should place three TAB
characters in each line of text.

If TreeChart wasn't able to correctly identify the various Text Fields, you can either edit the Notepad
document and repeat the operation, or (within TreeChart) call up the Edit Text dialog for each box, and
cut & paste between fields.

To copy text from a Spreadsheet (or a table in Microsoft Word)

This is always simpler than copying text from an editor or word processor, since identifying boxes and
Text Fields is almost foolproof.

1 Switch to the spreadsheet program
2 Select the range of cells you wish to copy
3 From the Edit menu, choose Copy
4 Switch to the TreeChart chart window you wish to paste into
5 Move the caret to select the Current Box
6 From the Edit menu, choose Paste Below, Paste Left or Paste Right (as necessary)

106



One new box will be created for each row copied, and each column corresponds to a Text Field.

Background information

In almost every Windows program, when you select a region of text then choose the Copy command,
an unformatted version of that text will be copied to the Clipboard in addition to 'richer' (formatted)
versions that will be copied for the program's own use.

TreeChart always pastes the unformatted text into a chart. All subsequent formatting is determined by
which Layout the resultant boxes use.

Each newly-created box initially uses the Default Layout for the level it  has been inserted at. See
section 3.5.2 for a discussion of Default Layouts.

When pasting text from the Clipboard, TreeChart interprets the text as if it were opening a text file (as
described in section 4.2). It therefore automatically distinguishes between the various supported text
formats.

Whatever text format is in use, TreeChart assumes that each line of text (terminated by a carriage
return / line feed pair) constitutes a box, and text within that line is divided into fields which constitute
TreeChart Text Fields.

Where no hierarchy information is available in the text to be pasted (normally the case if the text was
copied to the Clipboard by another program), all newly created boxes will be at the same level, and all
will initially use the Default Layout for that level.

To re-organize a flat hierarchy and have boxes use their correct Default Layouts:

1 Cut & Paste the new boxes to define the chart hierarchy

2 Select the boxes that use the 'wrong' Layout (possibly all of them)

3 either From the Layout menu, choose Use Default
or Press CTRL+U

Now all of the selected boxes will use the Default Layout for the level you have placed them at.

If you're using another program purely to prepare TreeChart text, you might like to consider using
TreeChart  Outline Text format.  This enables you to specify (in the other program) the hierarchical
organization  of  the  boxes,  and  you  can  assign  Layouts  for  each  box  to  use.  For  example,  in  a
spreadsheet, using TreeChart Outline Text simply requires adding one row and one column to your
spreadsheet, and filling in the new cells. TreeChart Outline Text format is described in Appendix 3.4.

4.1.2 Copying Text from TreeChart into another program
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1 Select the boxes who's text you'd like to copy
(if no boxes are selected, the text from the Current Box will be copied)

2 From the Edit menu, choose Copy
3 Switch to the program (and document window) you wish to paste into
4 Position the Insertion Point
5 From the Edit menu, choose Paste

Each TreeChart box will correspond to a line of text, with TAB characters separating the TreeChart
Text Fields.

If you paste into a spreadsheet or word processor table, each box will correspond to a row, each text
field to a column.

Note: TreeChart will only copy box information to the Clipboard in text format if the Copy as Text
option is selected in the Preferences dialog (from the File menu, choose Preferences).  See section
3.11.1 for a discussion of this issue.

4.1.3 Copying Pictures from TreeChart into another program

1 From the Edit menu, choose Copy
2 Switch to the program (and document window) you wish to paste into
3 Position the Insertion Point
4 From the Edit menu, choose Paste

A picture of the chart will be inserted into the document. Note that box selections are irrelevant.

TreeChart copies pictures to the Clipboard in a format called Windows Metafile. Not all Windows
programs recognise this format, but most do. If you need to copy a picture into a program that doesn't
recognise a Metafile, it  might be possible to go through an intermediate program that can convert
formats.

When drawing the chart to copy to the Clipboard, TreeChart adds the Border you have specified (just
as if you were printing the chart). The Border Margins determine how much space to leave around the
chart. The Page Setup margins are not used.

Note that Windows imposes a limit on the size of a picture you can copy to the Clipboard (about 11").
If the height or width of the chart is greater than this limit, TreeChart scales the drawing.

Note: TreeChart will only copy a picture to the Clipboard if the Copy as Picture option is selected in
the Preferences dialog (from the File menu, choose Preferences). See section 3.11.1 for a discussion of
this issue.

Changing picture size after pasting into another program

The Windows Metafile format allows the picture to be scaled (more or less) perfectly. In particular, the
fonts used by text fields can be scaled along with the boxes.
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One important  point to note,  however,  is that  the way the program receiving the picture performs
scaling determines whether or not everything in the picture is scaled proportionately. We'll illustrate
this issue by describing one example; you may need to experiment with the specific programs that you
are using to determine the best method of pasting pictures.

Resizing pictures with Word Processors and Drawing programs

If you want to paste a TreeChart picture into Microsoft Word, you can choose whether to paste directly
into the document or insert a picture object (to be edited with the Microsoft Draw mini-application),
and paste the picture into that object.

Pasting into an Microsoft Draw object allows you to add text or lines to your chart or (for example)
change the color of individual lines, though of course TreeChart will never know about any changes
you make.

Whichever approach you take, if you want to resize the overall picture, you should do it from within the
word processor itself, not from within Draw.

The reason for this is that the word processors treats the picture as a single entity. TreeChart informed
them how big it was, and they simply perform an overall scaling. Microsoft Draw, on the other hand,
understands the constituent parts of the picture (lines, rectangles, text, etc), and if you re-size it, you re-
size each individual component. Microsoft Draw doesn't resize text very well, though other drawing
packages might manage it better.

Incidentally, after pasting a TreeChart picture into a Microsoft Word, you'll find that double-clicking
on the picture allows you to edit the picture using the Microsoft Draw mini-application. This is because
these  word  processors  support  OLE  (Object  Linking  and  Embedding).  The  current  version  of
TreeChart does not support OLE.

Maintaining proportions when resizing pictures

If you resize a picture produced by TreeChart, you should try to maintain the overall proportions. If
you fail to do this, you'll find that text no longer fits inside boxes.

In some programs, for example Microsoft Word, retaining picture proportions is easy.

In Microsoft Word, select the picture and resize using only the corner handles (not the edge handles).
Alternatively, from the Format menu, choose Picture. In the dialog specify identical scaling factors for
both the height and width.

In other programs, for example the Windows Write accessory, retaining picture proportions is more
difficult.

In Write, select  the picture, then from the Edit menu choose Size Picture. Pick up a corner of the
picture and adjust the size. Note the size information in the bottom left of the screen. To maintain
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proportions, the X & Y values should be the same. Unfortunately, the values are a bit coarse; ideally,
you should complete the resize operation when both X & Y have both just  changed in the same
direction. For example (to half the size of a picture) resize till 0.6X/0.6Y. Now slowly decrease the size
until 0.5X/0.5Y. Now complete the operation.

4.2 Importing Text
TreeChart  can  open  files  saved  as  text  format  by  other  applications  and  interpret  that  text  as
information defining text fields and boxes. Normally, such files would have the extension .TXT. The
formats supported are those commonly used to store individual records as lines of text, each record
being divided into a number of fields. TreeChart interprets this as each record (line of text) being a
box, and each field within that record being a Text Field.

Details of supported text file formats can be found in Appendix 3. TreeChart automatically determines
which format is in use when opening a file.

To accelerate the process of preparing a chart,  TreeChart can use a Template when opening a text
format file. This can specify any number of Layouts, and which Layout should be used for any level
within the hierarchy. Wherever possible, TreeChart retains Template Layout information when opening
with a text file. If no Template file is used, boxes use a default Layout.

See section 3.10.4 for information on working with Template Files.

To open a text-format file:

1 either From the File menu, choose Open
or Press CTRL+O
or On the Toolbar, click on the Open button

In the File Open dialog:

2 In the List Files of Type drop-down list, choose 'Text Files (*.TXT)'

3 In the File Name box, choose the text file you want to open

If you type the filename, you do not need to type the filename extension
.TXT. TreeChart automatically adds it to the filename you type.

4 Choose the OK button

TreeChart recognises a number of different text formats, and automatically distinguishes between them
when opening a text file. See Appendix 3 for details.

Where no hierarchy information is available in the text file (normally the case if the text file was saved
by another program), all newly created boxes will be at level 1, and all will initially use the Default
Layout for level 1.
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To re-organize a flat hierarchy and have boxes use their correct Default Layouts:

1 Cut & Paste boxes to define the chart hierarchy

2 either From the Edit menu, choose Select All
or Press CTRL+A
or On the Toolbar, click the Select All button

3 either From the Layout menu, choose Use Default
or Press CTRL+U

Now all boxes will use the Default Layout for the level you have placed them at.

4.3 Exporting Text
While you would normally save a file in TreeChart format, there can be occasions when you'd like to
save it in a format that can be opened by other programs. Since saving a chart in these alternative
formats  always loses  some aspects  of  the chart  information,  you should normally save  a chart  in
TreeChart format, and only save a copy of the chart in a different format, and specify a different file
name (or at least a different filename extension) as you do so.

All boxes are saved to the file, irrespective of any outlining settings you may have selected.

You have six possible formatting choices when you save a chart:

Use To save your chart as

TreeChart Files (.TCF) A TreeChart-format file. Use this format to retain all chart
information. This is the normal format for TreeChart use, and the
default selection in the Save File as Type list.

Template  Files (.TCT) A TreeChart-format file that serves as a Template.

Text & Commas (.TXT) A Windows-format data file. Suitable for use with a word
processor or  spreadsheet.  Contains  only Box text;  no Layout or
hierarchy information.

Text & Tabs (.TXT) A Windows-format data file. Suitable for use with a word
processor or  spreadsheet.  Contains  only Box text;  no Layout or
hierarchy information.

Outline Text (.TXT) A Windows-format data file. Similar to Text & Tabs, but
containing  Text  Field  names  &  Box  hierarchy  and  marker
information, plus Layout names (but not their settings).
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Windows Metafile (.WMF) A picture of the chart, similar to as it would be printed (see section
4.4)

See Appendix 3 for a description of the text file formats.
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To save a copy of a chart for use by another program:

1 From the File menu, choose Save As

In the File Save As dialog:

2 In the Save File as Type drop-down list, choose the desired format

3 In the File Name box, enter a name for the file you want to save

If you type the filename, you do not need to type a filename extension.
TreeChart automatically adds an appropriate extension (dependent on the
selected format) to the filename you type.

4 Choose the OK button

Take care to enter a new file name before choosing the OK button, otherwise you might overwrite a
TreeChart-format file, and so lose all Layout information.

4.4 Exporting Pictures
TreeChart can save chart information as a picture, enabling you to import that picture into another
program. Picture-format files lose most of the information used internally by TreeChart, so you would
normally save a picture-format file in addition to TreeChart-format, not instead of TreeChart-format.

A picture of the current view is saved, with the Border added. In other words, any outlining settings
you may have selected are used to prepare the picture: what you see on the screen is what is saved.

To save a picture of a chart for use by another program:

1 From the File menu, choose Save As

In the File Save As dialog:

2 In the Save File as Type list, select 'Windows Metafile (*.WMF)'

3 In the File Name box, enter a name for the file you want to save

If you type the filename, you do not need to type a filename extension
.WMF. TreeChart automatically adds it to the filename you type.

4 Choose the OK button

Take care to enter a new file name before choosing the OK button, otherwise you might overwrite a
TreeChart-format file, and so lose all Layout information.
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Appendices
Appendix 1 Working with a mouse
A mouse is recommended, but not essential, for working with TreeChart. This appendix summarises
mouse operations available within a chart window, but does not describe standard Windows mouse
operations. For details, refer to the main part of the User Guide, or Online Help.

Terminology notes:

TreeChart only uses the left button on the mouse, or the right button if the mouse buttons have been
reversed by settings in the Windows Control Panel.

Click move the mouse
press & release the left mouse button

Double-Click move the mouse
quickly press & release the left mouse button twice

Drag move the mouse
press (and hold down) the left mouse button
move the mouse
release the left mouse button to complete the operation

Click & double-click behaviour largely depends on whether or not the mouse pointer is over a box
when you press the mouse button. When the mouse pointer is over a box, the cursor changes from the
normal arrow to an arrow with a box. In the following descriptions:

on chart background means when the cursor is the normal arrow.
on box means when the cursor is the normal arrow with a box attached.

During drag operations to insert a new box, the cursor changes to show the direction of insertion (up,
down, left, right). The direction used for the insertion depends on the cursor when you  release the
mouse button.

Chart Window Operations

To with mouse

Move caret (set Current Box) click on box

Edit Text associated with box double-click on box
Edit Layout associated with box SHIFT+double-click on box

Edit the Border Text double-click on chart background
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Edit the Border Layout SHIFT+double-click on chart background

Insert box in empty chart or view drag on chart background
Insert a box above existing box drag up from existing box
Insert a box below existing box drag down from existing box
Insert a box left of existing box drag left from existing box
Insert a box right of existing box drag right from existing box
Abandon box insertion drag back to starting point

Toggle box selection status CTRL+click on box
Clear Selections click on chart background
Select a group of boxes drag selection rectangle on chart background
Add a group of boxes to current selection CTRL+drag selection rectangle on chart background

Note: The last two operations automatically scroll the chart window to keep the cursor visible.
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Appendix 2 Working with the keyboard
While a mouse (or similar pointing device) is  recommended for working with TreeChart,  it  is not
essential. Almost all TreeChart operations are also available from the keyboard. This appendix gives a
quick summary of keyboard shortcuts. For a detailed description of each command, refer to the main
part of the User Guide, or Online Help.

Operations not available from the keyboard

Without a mouse, you cannot select a group of boxes by specifying a rectangular region. All other box
selection commands are available.

Without a mouse, Help Mode is limited to obtaining Help on menu commands. You cannot click on
other parts of the TreeChart window.

Keyboard Shortcuts

You can use keyboard shortcuts for commands and actions. Each shortcut  key consists of a letter,
symbol or function key, often pressed in combination with the CTRL, SHIFT and ALT keys.

This appendix lists all TreeChart keyboard shortcuts by topic. Where appropriate, a key may therefore
appear in more than one topic.

Keys to get Help

To Press
Get Help (context dependent) F1
Enter Help mode SHIFT+F1
Leave Help mode without getting Help ESC
See Help contents CTRL+F1

Keys for moving the caret

To move the caret Press
One box left LEFT ARROW
One box right RIGHT ARROW
One box up UP ARROW
One box down DOWN ARROW
To the top-left box HOME
To the bottom-right box END

Moving the caret changes which box is the Current Box. If the new Current Box is not fully on-screen, the chart
window is automatically scrolled to make it visible.

Note that all keys for moving the caret require Scroll Lock mode to be off. If Scroll Lock is on, these keys scroll the
chart window without moving the caret.

The state of Scroll Lock mode is indicated on the TreeChart Status Bar.
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Keys for scrolling a chart window

To scroll the chart window Press
Left a little  (SCRL) LEFT ARROW
Left a lot CTRL+PAGE UP
Right a little (SCRL) RIGHT ARROW
Right a lot CTRL+PAGE DOWN
Up a little (SCRL) UP ARROW
Up a lot PAGE UP
Down a little (SCRL) DOWN ARROW
Down a lot PAGE DOWN
To the top-left of the chart (SCRL) HOME
To the left edge of the chart (SCRL) CTRL+HOME
To the bottom-right of the chart  (SCRL) END
To the right edge of the chart (SCRL) CTRL+END

Scrolling the window 'a little' means 20% of the window; scrolling 'a lot' means 90% of the window.

Note that many keys (marked SCRL) for scrolling the chart window without moving the caret require Scroll Lock
mode to be on. If Scroll Lock is off, these keys move the caret; the chart window may then scroll automatically to
ensure the Current Box is visible.

The state of Scroll Lock mode is indicated on the TreeChart Status Bar.

Keys for selecting boxes

To Press
Toggle the selection status of the Current Box SPACE
Select all boxes CTRL+A
Select the Current Box and all boxes below it CTRL+T
Select all boxes at the same level as the Current Box CTRL+H
Select all boxes immediately below the Current Box CTRL+I
De-select all selected boxes CTRL+G

Keys for adding, removing & re-arranging boxes

To Press
Insert a box in an empty chart or view ALT+any arrow key
Insert a new box above the Current Box ALT+UP
Insert a new box below the Current Box ALT+DOWN
Insert a new box to the left of the Current Box ALT+LEFT
Insert a new box to the right of the Current Box ALT+RIGHT
Paste Clipboard contents below the Current Box CTRL+V
Paste Clipboard contents to the left of the Current Box CTRL+L
Paste Clipboard contents to the right of the Current Box CTRL+R
Swap two selected boxes CTRL+W
Undo last box insertion or box deletion CTRL+Z

The following commands apply to the selected boxes, or if no boxes are selected then the Current Box:

Delete boxes DEL
Copy boxes to Clipboard CTRL+C
Cut boxes to Clipboard (IE copy boxes then delete them) CTRL+X
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Keys for changing box text

To Press
Define the Text Fields F3
Edit Text Fields of the Current Box ENTER

In the Edit Text Fields dialog box:

Move between Text Fields UP or DOWN
Move between text table, OK and Cancel  buttons TAB
Extend selection in a text field SHIFT+DIRECTION key
Extend selection to first character in text field SHIFT+HOME
Extend selection to last character in a text field SHIFT+END
Copy selected text to Clipboard CTRL+C
Cut selected text to Clipboard CTRL+X
Paste text from Clipboard CTRL+V

Keys for editing the Layout used by the Current Box

To change Press
Size settings F8
Spacing settings SHIFT+F8
All other Layout settings SHIFT+ENTER

Note that other boxes may also be using the Layout used by the Current Box. Changing a Layout's settings will 
automatically affect all boxes using that Layout.

Keys for changing which Layout is used by selected boxes

To Press
Choose a Layout from a list of those available CTRL+D to show Define Layouts dialog box
Use the Default Layout for the level each box is at CTRL+U

The above commands apply to the selected boxes, or if no boxes are selected then the Current Box.

Keys for marking boxes as exceptions to the rules

To Press
Change the marker flags CTRL+M to show Mark Boxes dialog box
Set the Invisible marker F9
Clear the Invisible marker SHIFT+F9
Set the Disconnect from Parent marker CTRL+F9
Clear the Disconnect from Parent marker CTRL+SHIFT+F9
Set the Co-Manage Left marker F10
Clear the Co-Manage Left marker SHIFT+F10
Set the Co-Manage Right marker CTRL+F10
Clear the Co-Manage Right marker CTRL+SHIFT+F10
Set the Co-Manage Group marker F11
Clear the Co-Manage Group marker SHIFT+F11
Set the Assistant marker F12
Clear the Assistant marker SHIFT+F12

The above commands apply to the selected boxes, or if no boxes are selected then the Current Box.

Keys for changing the Border

To Press
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Define the Border Text Fields SHIFT+F3
Edit the Border Text Fields F7
Change the Border Layout SHIFT+F7
Change the Border Margins CTRL+F7

In the Edit Border Text Fields dialog box:

Move between Text Fields UP or DOWN
Move between text table, OK and Cancel  buttons TAB
Extend selection in a text field SHIFT+DIRECTION key
Extend selection to first character in text field SHIFT+HOME
Extend selection to last character in a text field SHIFT+END
Copy selected text to Clipboard CTRL+C
Cut selected text to Clipboard CTRL+X
Paste text from Clipboard CTRL+V

Keys for hiding boxes (outlining)

To Press
View the whole chart CTRL+Q
Focus on Current Box or chart root CTRL+F
Collapse selected boxes CTRL+K
Expand selected boxes CTRL+E
Expand all collapsed boxes CTRL+SHIFT+E

Keys for changing the scale at which a chart is displayed

To Press
Zoom In +
Zoom Out -
Restore normal zoom =
Set specific zoom factor F2 to open toolbar list,

then UP and DOWN to change,
then ENTER

Keys for managing application windows

To Press
Open the TreeChart application control menu ALT+SPACEBAR
Quit TreeChart ALT+F4
Switch to next application window or icon ALT+ESC
Switch to next application, restoring if running as an icon ALT+TAB

Move the TreeChart application window ALT+SPACEBAR to open the Control menu
DIRECTION keys to move the window
ENTER to complete the move

Change the TreeChart application window size ALT+SPACEBAR to open the Control menu
DIRECTION key to pick up a window edge
DIRECTION keys to move the window edge
ENTER to complete the re-size

Keys for managing chart windows

To Press
Open the active chart's Control menu ALT+HYPHEN
Close the active chart window CTRL+F4
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Switch to next chart window CTRL+F6
Switch to previous chart window CTRL+SHIFT+F6
Restore minimised chart window to previous size ENTER

Move the active chart window ALT+HYPHEN to open the Control menu
DIRECTION keys to move the window
ENTER to complete the move

Change the active chart window size ALT+HYPHEN to open the Control menu
DIRECTION key to pick up a window edge
DIRECTION keys to move the window edge
ENTER to complete the re-size

Keys for choosing menus and commands

To Press
Get Help F1
Activate the menu bar F10
Choose the TreeChart window control menu ALT+SPACEBAR
Choose the chart window control menu ALT+HYPHEN
Close any open menu ESC
Close a chart window CTRL+F4

Choose the File menu ALT+F
Choose the Edit menu ALT+E
Choose the View menu ALT+V
Choose the Layout menu ALT+L
Choose the Chart menu ALT+C
Choose the Window menu ALT+W
Choose the Help menu ALT+H

Open a new chart CTRL+N
Open an existing chart CTRL+O
Save the active chart CTRL+S
Print the active chart CTRL+P

Show or hide the Toolbar SHIFT+F2
Show or hide the Status Bar CTRL+F2

Keys for working with dialog boxes

To Press
Cancel the dialog ESC
Move between controls or groups TAB
Move between controls or groups (reverse order) SHIFT+TAB
Move directly to control or group ALT+underlined letter
Move between options within a group DIRECTION key
Execute a command button ENTER
Open a drop-down list box ALT+DOWN
Select item in a drop-down list box ALT+UP or ALT+DOWN
Select or clear a checkbox SPACEBAR
Extend selection in a text box SHIFT+DIRECTION key
Extend selection to first character in text box SHIFT+HOME
Extend selection to last character in a text box SHIFT+END
Select next list-item whose name begins with a character character key

Extended-selection list boxes:
Select or cancel selection of item SHIFT+DIRECTION key
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Select all items CTRL+SLASH (/)
Cancel all selections except the current selection CTRL+BACKSLASH (\)
Extend selection SHIFT+DIRECTION key
Extend selection to first item SHIFT+HOME
Extend selection to last item SHIFT+END
Select non-consecutive items SHIFT+F8 to begin 'add mode' (cursor blinks)

DIRECTION keys move between items
SPACEBAR to select or cancel selection of item
SHIFT+F8 to finish 'add mode' (cursor normal)

Keys to access Toolbar buttons

To Access the Press
New button CTRL+N
Open button CTRL+O
Save button CTRL+S
Cut button CTRL+X
Copy button CTRL+C
Paste Below button CTRL+V
Select All button CTRL+A
Select Sub-Tree button CTRL+T
Select Level button CTRL+H
Select Subordinates button CTRL+I
Mark Boxes button CTRL+M
Define Layouts button CTRL+D
View All button CTRL+Q
Focus button CTRL+F
Collapse button CTRL+K
Expand button CTRL+E
Expand All button CTRL+SHIFT+E
Print button CTRL+P
Print Preview button (no shortcut key)
Help Mode button SHIFT+F1
Zoom: open list F2
Zoom: change list selection UP or DOWN ARROW
Zoom: close list ENTER
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Appendix 3 Supported Text File Formats

TreeChart  imports and exports text in common Windows text  formats.  Any application capable of
handling text should be able to exchange information with TreeChart.

TreeChart cannot read or interpret formatting information embedded within text files. The text files it
can import are those saved by applications by selecting 'Save As Text & Tabs', etc.

When importing text (either by opening a text format file or by pasting from the Clipboard) common
text formats contain sufficient information to construct boxes, determine the required number of Text
Fields and to initialise those Text Fields. They do  not contain any information which allows us to
construct a hierarchy of boxes, and all boxes constructed after importing text will be at the same level
in the hierarchy. Constructing the hierarchy then requires moving sets of boxes around,  by cut  &
pasting (as described in section 4.2).

TreeChart Outline Text format is a simple extension of one of the common text formats which  does
allow the program to construct a hierarchy of boxes. To avoid the need to define the hierarchy by cut &
paste after importing text in a common format, you may wish to save the text to a file in the other
application, edit the text file to add hierarchy information (using, for example, the Windows Notepad
accessory, though its a lot easier with a spreadsheet), then save it before opening as text from within
TreeChart.

Character coding is the ANSI Windows standard, not PC standard. 

A3.1 Basic Text format

TreeChart assumes text files to be composed of a number of lines, each terminated with a carriage
return / linefeed character pair. Each line corresponds to a box, individual fields of text within a box
being separated by some marker character.

The formats described below are as used when saving a chart in text format. When opening a chart in
text format, TreeChart automatically detects which format is in use. One quirk of this is that like many
other programs, TreeChart will lose the first character in a Tab-separated field if that character is a
double-quote (").
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An Example chart:

In this example, Molly Jones is Charles Brown's assistant. In TreeChart terms, this means that the
Molly Jones box is a subordinate that has been marked as an Assistant. Fred Emerson is regarded as
having the same seniority as the Sales Managers, despite reporting directly to Charles Brown. This is

illustrated by the Fred Emerson box being subordinate to a box marked as Invisible. Section 3.7
describes how and why to mark boxes as exceptions to the rules.

All boxes in the example are using Layout 'Normal', except for the Molly Jones box, which uses the
Layout 'Assistant'.

A3.2 Tab-separated Text

Fields  are  separated by TAB characters.  Any character  (except  end-of-line or  end-of-file)  is  valid
within a field.

The example, saved in Tab-separated text format:

Charles Brown The "Boss"
June Roberts Sales Director
Don Peterson Sales Manager, America
Sally Smith Sales Manager, Europe
Molly Jones

Fred Emerson Technical Manager

Note that the hierarchy is lost when saving in this format, and that the box marked as Invisible results
in a blank line, since the box contained no text.
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A3.3 Comma-separated Text

Fields are separated by commas (,). Because of the probability of using a comma within a field, fields
are 'quoted' by a leading and trailing double-quote (") character. Where a double-quote character is
actually within the field, it is duplicated. Any program offering to save text in 'Text & Commas' format
(or some similar name) will perform all this automatically.

The example, saved in Comma-separated text format:

"Charles Brown","The ""Boss"""
"June Roberts","Sales Director"
"Don Peterson","Sales Manager, America"
"Sally Smith","Sales Manager, Europe"
"Molly Jones",""
"",""
"Fred Emerson","Technical Manager"

Note that the hierarchy is lost when saving in this format, and that the box marked as Invisible results
in a blank line, since the box contained no text.

A3.4 TreeChart Outline Text

TreeChart Outline Text format is an extension of the Tab-separated text format.

The first line of text is a header containing an identification code ('TreeChart Outline Text'), followed
by fields containing Field Names. Subsequent lines of text are preceded by a numeric field indicating
relative level numbers within the hierarchy.

When reading this format, TreeChart performs error correction if these level numbers are sequenced
incorrectly. The first level number encountered is regarded as a 'base': subsequent level numbers will
be forced to be not less than this base. If any level number is more than one greater than that associated
with the previous line of text, it will be set equal to the previous level+1.

Two pseudo-fields may optionally be present in the header line: $$LAYOUT$$ and $$MARKER$$.

If the $$LAYOUT$$ field is present (at any position), this field within subsequent records is assumed
to contain a Layout Name. This field is removed from each line before constructing the box. If the
Layout Name is defined within the chart, the newly-created box will initially use this Layout. If this
pseudo-field is absent, or if the extracted Layout Name is not known to the chart, the newly-created
box will use the Default Layout for the level it is inserted at.

If the $$MARKER$$ field is present (at any position), this field within subsequent records is assumed
to contain the value of the exception flags for this box (as described in section 3.7). If this field is
absent,  newly  created  boxes  will  have  all  marker  flags  cleared.  Possible  values  for  this  field  are
composed by ORing the following values in any combination, but the setting must be expressed as a
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decimal value:

hexadecimal decimal meaning

0x0001 1 Invisible
0x0002 2 Co-Manage Group
0x0004 4 Co-Manage Left
0x0008 8 Co-Manage Right
0x0010 16 Assistant
0x0020 32 Disconnect from Parent
0x0040 64 Ignore when matching box Heights
0x0080 128 Ignore when matching box Widths

For example, a box marked as Co-Manage Group, Invisible and Disconnect from Parent would have
the value 0x0023 hexadecimal or 35 decimal.

All other values are reserved; using other values may produce unexpected results when your chart is
drawn.

The example, saved in TreeChart Outline Text format:

TreeChart Outline Text $$LAYOUT$$ $$MARKER$$ Name Position
1 Normal 0 Charles Brown The "Boss"
2 Normal 0 June Roberts Sales Director
3 Normal 0 Don Peterson Sales Manager, America
3 Normal 0 Sally Smith Sales Manager, Europe
2 Assistant 16 Molly Jones
2 Normal 1
3 Normal 0 Fred Emerson Technical Manager

Note that the hierarchy is retained when saving in this format, together with box Marker flags and a
reference to the Layout used.

A3.5 Interpretation of Field Names

When importing text, either by opening a text file, or by pasting from the Clipboard, the possibility
arises of a mismatch in the number and names of fields. TreeChart endeavours to preserve Layout
information associated with existing text fields, and to handle additional fields intelligently.

Charts generally will have Text Fields defined before importing text. Even when opening a text file,
TreeChart will precede loading the text by either loading the Template (if you have defined one), or by
creating a default chart, containing the Text Fields Name & Position.

One important constraint is that all boxes in a chart will always have the same number of Fields.

If the text being imported is in TreeChart Outline Text format:
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Then the imported text contains Field Names, and TreeChart attempts to match these against Field
Names already in use in the chart.

Where an imported Field Name matches an existing Field Name, the existing Field (and its associated
Layout information) is used.

Where an imported Field Name does not match an existing Field Name, a new Field is added to the
chart, with the Name used in the imported text. It will be given default Layout information.

If an existing Field Name does not appear in the imported Field Names, it is deleted, but only if the
chart was empty before importing the text. If the chart was not empty, all boxes generated from the
imported text will have an empty Field.

If the text being imported is Tab or Comma Separated Text format:

Then no Field Names are in the text, and we simply match Fields in the imported text against existing
Fields(and their associated Layout information), on a first-come, first-served basis.

In both cases:

If there are more Fields in the imported text than already existed in the chart, new Fields are created,
and given a unique Name (Untitled:NNN) and default Layout information. This is performed on a line
by line basis, and if one line of text has more fields than the others, all other boxes will have empty
Fields added, since all boxes must have the same number of Text Fields.
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Appendix 4 Program options

This Appendix details the contents of the private initialisation file (TREECHRT.INI), which is stored
in your windows directory and specifies various options which define how the program functions.

If the initialisation file is not found on program startup, default settings are used for all options. If the
initialisation file is not found when saving program preferences, it is created with the current settings.

Most of these options can be conveniently changed by choosing Preferences from the File menu, as
described in section 3.11. A few require the initialisation file to be edited. The Windows accessory
Notepad is recommended for this purpose.

The TREECHRT.INI file contains several sections, each of which consists of a group of related entries.
The sections that can appear are:

[Window] Notes window size, position & status between TreeChart sessions
[Recent File List] Recently used files, for direct opening via the File menu
[Preferences] User-selected program options
[Settings] Internal program options

These  section  names  should  not  be  altered.  If  they  are,  the  entries  contained  within  will  not  be
recognised.

[Window] Section

state= Initial program window status. (a group of numbers used
by  Windows)  TreeChart  remembers  window  size,  position  &  state
(minimised,  maximised,  normal).  When you start  TreeChart,  its  window
will be the same size & position as when you last used it. The one exception
is  if  you  explicitly  start  minimized  (eg  checking  the  Run  Minimised
checkbox  on  Program  Manager  Run...  dialog).  If  this  entry  is  absent,
TreeChart starts with a window occupying the whole screen except for one
row of icons at the bottom.

ShowToolbar = 0 | 1 Specifies  whether  TreeChart  should  show  (1)  or  hide  (0)  the  Toolbar.
Default: 1 (show Toolbar). Modified by choosing Toolbar from the View
menu.

ShowStatusbar = 0 | 1 Specifies whether  TreeChart  should show (1) or hide (0) the Status Bar.
Default: 1 (show Status Bar). Modified by choosing Status Bar from the
View menu.

ChildFrame=1 | 3 Initial chart window status. When a new chart window is created,
its  initial size,  position and state are based upon how you've been using
chart windows. If you've been working with maximised chart windows, a

128



new  window  will  be  maximised.  If  you've  been  working  with  non-
maximised chart windows, a new window will be a default size and position
within  the  main  window  client  area.  Possible  values:  1  (normal),  3
(maximised).

[Recent File List] Section

FileN=fnam The full path name of a recently saved file. Up to four such entries
may be present, and are added to the File menu to allow recently used files
to be re-opened quickly. These files must be native TreeChart format files.

[Preferences] Section

SavePreferences=0 | 1 Specifies whether or not program options should be saved automatically
when  you  close  the  program.  Default:1  (Save).  Only  entries  in  the
[Preferences]  section are controlled  by this,  entries  in  other  sections are
always saved on program exit.

AutoEdit = 0 | 1 Specifies whether or not the Edit Text dialog should automatically
be shown when a new Box is inserted. Default: 0 (don't edit text).

CopyText=0 | 1 Specifies whether or not the program should  use Text format when
copying or cutting information to the Windows Clipboard. Default: 0 (don't
copy as  Text).  When pasting  information  from the  Clipboard  into  other
programs,  there  may be  occasions when if  they  are  offered  a  choice  of
formats, the other program may choose the wrong format for your purposes.
This option allows you to determine what choices the other program has to
make, and therefore ensure that it chooses the format you want.

CopyMetaFile=0 | 1 Specifies whether or not the program should  use Metafile picture format
when copying or cutting information to the Windows Clipboard. Default: 1
(copy as picture). When pasting information from the Clipboard into other
programs,  there  may be  occasions when if  they  are  offered  a  choice  of
formats, the other program may choose the wrong format for your purposes.
This option allows you to determine what choices the other program has to
make, and therefore ensure that it chooses the format you want.

CenterDialogs=0 | 1 Specifies whether dialog boxes should be centered within the screen (1) or
not (0). Many users prefer dialogs to appear in a consistent position, but this
might be distracting if you are running two programs side by side on a large
monitor. Default: 1 (center dialogs).

Units=0 | 1 Instructs  TreeChart  to  present  measurements  in  metric  (0)  or
imperial  (1)  units.  Defaults  to  the  international  setting  in  the  Windows
initialisation file. This option specifies how TreeChart will initially present
measurements.  All  dialogs  containing  measurements  offer  the  option  of
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switching between metric and imperial units. If you change units, TreeChart
will continue to use the new units until you change them again. The last
used units are noted in the initialisation file when the program preferences
are saved, either explicitly or automatically on closing the program.

TemplateFile=fnam Specifies the full pathname of the TreeChart file to use as a Template when
creating a new chart  or when Opening a file in one of the Text formats. If
nothing  follows  TemplateFile=,  or  if  this  line  is  missing  from  the
initialisation file, no Template will be used, and the newly created chart will
have default settings.

DragInsertThreshold=n Specifies  the size (in  screen units)  of  the 'dead zone'  around the anchor
position  when  inserting  a  new  Box  by  dragging  from an  existing  Box.
Default is 10. Reducing this setting means that dragged insertions require
less mouse movement, but increases the likelihood of accidently inserting
when intending to simply select a box. Changing this option requires the
initialisation file to be edited.

TrueShadow=0 | 1 Specifies  whether  TreeChart  should  take  a  little  extra  time  to  get  the
sequence of drawing shadows, connectors and boxes perfect  (1) or draw
them fast (0), but sometimes get the shadows and connectors in the wrong
order. This only affects the screen display; printing, copying a picture to the
Clipboard,  and saving as  a picture are always done correctly.  Default:  0
(speed rather than accuracy). Changing this option requires the initialisation
file to be edited.

Dialogs3D=0 | 1 Specifies whether TreeChart should attempt to show dialogs and
message boxes with a 3D appearance (1) or in the normal Windows style
(0). The 3D appearance is only possible with a VGA or better display. If
TreeChart detects that your display is not capable of the 3D appearance, the
normal Windows style will be used irrespective of the state of this option.
Default: 1 (3D). Changing this option requires the initialisation file to be
edited.

[Settings] Section

PreviewPages=1 | 2 Used in Print Preview, this notes whether you last previewed output as a
single page, or two pages side by side.
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Appendix 5 License Agreement

You are encouraged to use this program for 30 days prior to obtaining a permanent license. You may
share this program ("TreeChrt.exe") with anyone you choose as long as you do not change it. You may
not share the registration key, which is supplied to registered users  only.  You may not charge for
sharing a copy unless you comply with the provisions in file 'Vendor.doc'. If you do not have a copy of
this file and wish to distribute our software for a fee,  please contact us at (+353) 91 37560, CIS:
70624,462.

If you choose to continue using the program and register, that registration key may be used only by the
licensee specified in the original order for the license. By ordering a license, you acknowledge that this
key represents a trade secret and agree to protect it as such. Misuse of a registration key is subject to
collection of triple the fees that should have been collected and all legal fees and costs. Licenses are
not transferable and may not be modified.

FINELINE  SOFTWARE  DISCLAIMS ALL WARRANTIES  RELATING  TO  THIS  SOFTWARE,
WHETHER  EXPRESS  OR  IMPLIED,  INCLUDING  BUT NOT  LIMITED  TO  ANY IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, AND
ALL SUCH WARRANTIES ARE EXPRESSLY AND SPECIFICALLY DISCLAIMED. NEITHER
FINELINE  SOFTWARE  NOR  ANYONE  ELSE  WHO  HAS  BEEN  INVOLVED  IN  THE
CREATION, PRODUCTION, OR DELIVERY OF THIS SOFTWARE SHALL BE LIABLE FOR
ANY INDIRECT,  CONSEQUENTIAL,  OR INCIDENTAL DAMAGES ARISING OUT OF THE
USE OR INABILITY TO USE SUCH SOFTWARE EVEN IF FINELINE SOFTWARE HAS BEEN
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES OR CLAIMS. IN NO EVENT SHALL
FINELINE SOFTWARE'S LIABILITY FOR ANY DAMAGES EVER EXCEED THE PRICE PAID
FOR THE LICENSE TO USE THE SOFTWARE, REGARDLESS OF THE FORM OF CLAIM. THE
PERSON  USING  THE  SOFTWARE  BEARS  ALL  RISKS  AS  TO  THE  QUALITY  AND
PERFORMANCE OF THE SOFTWARE. Some states  do not  allow the exclusion  of  the  limit  of
liability for consequential or incidental damages, so the above limitation may not apply to you.

This agreement shall be governed by the laws of the Republic of Ireland and shall inure to the benefit
of FineLine Software and any successors, administrators, heirs and assigns. Any action or proceeding
brought by either party against the other arising out of or related to this agreement shall be brought
only in a court of competent jurisdiction located in the Republic of Ireland. The parties hereby consent
to in personam jurisdiction of said courts.

It is your responsibility to determine if the program will work reliably on your equipment and for your
particular business environment. That's why evaluation copies are made available to you. This software
probably has bugs; no significant software has ever been produced without them. If you feel that this
program or documentation can be improved in some way, we are open to your ideas. If you discover a
problem, please send a copy of your data (.TCF) file to us, and we will attempt to fix the problem. In
any case, your remedy for any problem is limited to the purchase price paid to FineLine Software.

If you don't agree with these conditions, delete the program files from your computer and don't send us
any money.
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Appendix 6 Registering the program

As stated in the Introduction, if, after evaluating TreeChart for up to 30 days you wish to continue
using the program, you must purchase a license to use it. This process is termed Registration.

A6.1 The Benefits of Registration

● Printed and bound User Guide plus Tutorial
● The most recent copy of the program
● Support if file format changes
● Registration remains valid for minor upgrades
● Notification of minor & major upgrades
● Automatic (& free) re-registration if a major upgrade is released within six months
● All registration reminders / 'unregistered version' messages removed
● Its the right thing to do

Changes to the .TCF / .TCT file format

We aim to continuously improve TreeChart, and in so doing it may be necessary to change the way we
store your information. This is of no consequence during an evaluation period, but becomes significant
if you wish to read files saved under an old version of TreeChart into a newer version. The registered
version of TreeChart contains code to automatically detect and handle format changes, unregistered
versions omit this code, and can only report an error if you request an old-format file to be loaded.

See Appendix A6.3 for details of our upgrade policy.

A6.2 How To Register

Registering TreeChart  can  be  done from within  the  program itself:  From the  Help  menu,  choose
Register.

Then follow the instructions in the registration dialog. Since we are actively seeking local agents to
simplify the registration process for you, the precise procedure will vary.

If you have any problems, contact FineLine Software direct. See Appendix 7.

A6.3 Upgrade Policy

We aim to continuously improve TreeChart, and new versions will periodically become available.

Upgrades will be either minor or major. Either type may necessitate a change to the file format. As
noted in Appendix A6.1, evaluation copies omit code that supports old file formats.

For minor upgrades, the main version number will not change; for instance version 1.3 to version 1.4.
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For major upgrades, the main version number is changed; for instance version 1.4 to version 2.0.

Registration keys are valid for a major version number: they work irrespective of the minor version
number. The minimum time between major upgrades will be six months.

Upgrades will be available through the normal shareware distribution channels, but registered users
will be notified of both minor and major upgrades as soon as they are released.

Registered Users - Minor Upgrades

If you obtain the latest  version from your shareware vendor,  your registration key is still  valid. If
the .TCF / .TCT file format changed, the differences are handled automatically.

Registered Users - Major Upgrades

You can choose the most appropriate route for your circumstances:

● you can do nothing, and your license to use your current version continues.

● you can obtain the new version from your shareware vendor for evaluation, and then
decide what action to take.

● you can purchase an upgrade for significantly less than the registration cost. Specific
costs may vary, and will be announced in the upgrade notification.

If a major upgrade is issued within six months of your initial registration, you will automatically be
upgraded to the new version, and a disc-only upgrade (without the printed manual) will be sent to you
automatically and at no cost. If you feel you'd like the latest copy of the printed manual, a nominal
charge may be made. Details will be included when the upgrade is sent to you.

Requests for major-version upgrades should always be referred directly to FineLine Software.  See
Appendix 7 for how to contact us.
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Appendix 7 Contacting FineLine Software

We at FineLine Software actively seek feedback from users, whether registered or not. We aim to
continuously improve TreeChart to better meet your needs.

Being a small company has both benefits and drawbacks. Two advantages of our size are that if you
contact us, you are talking direct to the developers and that we can be very responsive to requests for
changes to our products.  One disadvantage is that the more time we spend being responsive to you, the
less time we have for development.

To register TreeChart, please use the methods described in Appendix 6, but for other matters, we can
be contacted by the following routes:

Post: FineLine Software
Newtown,
Kinvara,
Co. Galway,
Republic of Ireland

Voice/Fax: +353  091 37560

E-mail: 70624.462@compuserve.com

Please note that if you need to contact us by phone that Ireland is in a GMT timezone (more or less).
We are typically 8 hours ahead of California, 5 hours ahead of New York, and 10 hours behind Sydney,
Australia. Like most of you, we become less responsive when phoned in the middle of the night.

A7.1 Support Policy

Registered users are offered lifetime support and a money-back guarantee.

Support is provided by the developers. Where practicable, we would prefer that you contact us by
electronic mail or post; this allows us to better manage our time, and gives us the chance to consider
and investigate the problem.

Bugs will be fixed for free, if possible. If not, a full refund will be offered. A written description of the
fault, a copy of your data file (.TCF), and a description of the hardware / software environment are
essential in notifying us of a fault so that we can duplicate the problem.

Support will be provided to non-registered users on a 'play it by ear' basis. Our general view is that if
you've gone to the effort of contacting us, you deserve a reply.
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Appendix 8 Frequently Asked Questions

Why is TreeChart being released as shareware, rather then as a retail product?

We believe TreeChart compares very favourably to competitors' programs released as retail products.

TreeChart is being released as shareware for commercial reasons. Selling TreeChart in this way lets
our company develop without committing a huge quantity of  cash.  A retail  product might require
$200,000  to  launch:  advertising,  packaging,  dealer  margins,  etc.  If  the  launch  is  a  success,  the
customers are paying that $200,000. If its a failure the company or the investors lose. TreeChart is
shareware to minimize the risk to us, and to minimize the time spent seeking major investment.

How big can a chart be?

This is a bit more complicated than you might imagine.

Firstly, the physical dimensions of the chart. If the Current View is more than about 250" horizontally
or vertically, box placement will wrap-around: boxes 'positioned' at the far right will be drawn at the
left, for instance. TreeChart doesn't report this as an error (or even give a warning), but the effect will
be obvious. You can still work with this chart, though since boxes might be overlapped, box selection
can be awkward. Obviously, if you print the chart in this state it  won't look very impressive.  The
solution is to use outlining to hide some aspects of the chart; the limit is on the Current View, not the
chart itself.

In terms of data capacity or memory use:

The names of things (Text Fields, Layouts, etc) must be less than 255 characters.
The contents of a Text Field must be less than 255 characters.
A few things (eg number of Text Fields) have a limit of about 32,000
Most other things have no fixed limit.

In general, TreeChart will happily make use of all available (physical + virtual) memory.

Why don't you offer dotted line styles or patterned fills?

Because they don't scale properly. Let's re-phrase that: Windows provides support for dotted / dashed
lines and patterned fills, but then doesn't scale them in the same way that it scales other graphical
information.

For dotted / dashed lines, the length of a dot or dash is fixed by the display or printer. For example, a
dash might be one tenth of an inch long. Dotted / dashed connecting lines might look fine when your
boxes are half an inch apart, but if they're scaled to make them a tenth of an inch apart, then your
dotted / dashed line will look bad. Sometimes, it will disappear entirely.

For patterned fills, the same restriction applies. For example, cross-hatching lines are a fixed distance
apart. What will look fine at normal size will look bad when the chart is re-sized.

135



We decided  that  correctly  scaleable  charts  (both  for  printing  and  for  copying  pictures  into  other
documents) was too valuable for you to be disappointed with poor TreeChart  output due to using
unsuitable Windows features.

Plain English version: it looks awful and you'd blame TreeChart. We prevent this happening.

We're open to persuasion on this one.

Why don't you offer to copy or save charts as bitmapped pictures?

Bitmaps generally produce poor results when rescaled. Bitmaps tend to be device dependent. Bitmaps
of charts will get  very large. On the assumption that the program you're importing the image into
supports Windows Placeable Metafiles (most do), the only circumstances where bitmaps seem at all
useful is where the chart (or Current View) is small, you won't want to resize the image, and the fonts
you use in the chart are unavailable when the image is drawn. This combination of circumstances
seemed too unlikely to warrant the extra work for us.

Why no freehand drawing tools?

There are two reasons for this. Firstly, if you added lines or text to a chart TreeChart wouldn't know
what  to  do with  them whenever  it  recalculated  box positions for  you.  Secondly,  you've  probably
already got a drawing program that you're happy working with. Rather than add a zillion features to
TreeChart (and probably still not match the features of your drawing program), we simply enable you
to import a picture of a chart into other programs.

Programs  such  as  the  Microsoft  Draw  mini-app  (bundled  with  Microsoft  Word  and  Works,  for
example)  can  be  used  not  only  to  add text  and  lines,  but  also  to  change the  pictures  TreeChart
produces: for instance, to change the color of one connecting line where TreeChart has colored the
connectors uniformly. More sophisticated drawing programs will  be able to do more sophisticated
changes.

When I try to load a chart I saved some time ago, I get an error message saying that
TreeChart can't cope with a different data file format. What does this mean?

This message can happen in two related situations. Either  might occur if you save a chart with one
version of TreeChart,  and try to open it with a different version. We aim to continuously improve
TreeChart, and in doing so it may be necessary to change the way we store your information. Different
versions of TreeChart may therefore have different .TCF / .TCT file formats.

Where the file format has changed, an earlier version of TreeChart will  never be able to open a file
saved by a later version of TreeChart. This is inevitable: if the earlier version could cope with the
additional or changed data, there would have been no need to change the file format in the first place.

Where the file format has changed, a registered later version of TreeChart will automatically handle
any format differences if a file has been saved by an earlier version of TreeChart (registered or not).
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Unregistered versions do not contain the required data conversion code, and will report an error if you
try to open a file saved by an earlier version.

If you only ever use one version of TreeChart (for example, during the evaluation period), you will
never encounter this message.

See Appendix 6 for details of other benefits of registering, and how to go about it.
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