
Editeur's help index

Editeur is a text editor. Editeur allows large text files to be created and modified very easily 
and efficiently. Editeur also allows small text files such as CONFIG.SYS and AUTOEXEC.BAT to
be created and modified.

Press F1 to learn how to use help.
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Create a text

Create a text

1 Choose the New command from the File menu.
2 Type in your text.

See also

Open existing text files
Modify a text



Open existing text files

Using Editeur makes sense only with text files.

Open existing text files

1 Choose the Open... command from the File menu.
2 Choose the drive and the directory.
3 Select one or more files.
4 Choose the file code.
5 Choose «OK».

Editeur creates a text window for every file opened. The file opened last becomes active.

See also

Create a text
Delete files
Modify a text
Moving between texts



Delete files
Files can be deleted from within the Open or Save as dialogs.

Delete files from within the Open dialog

1 Choose the Open... command from the File menu
2 Choose the drive and the directory.
3 Select the files to be deleted.
4 Press the Del key.

Editeur requests a confirmation for every file to be deleted.

Delete files from within the Save as dialog

1 Choose the Save as... command from the File menu
2 Choose the drive and the directory.
3 Select the file to be deleted (only one single file can be selected).
4 Press the Del key.

Editeur requests a confirmation before deletion.

See also

Open existing text files
Save texts



Save texts

Save a text with a new name

1 Choose the Save as... command from the File menu.
2 Choose the drive and the directory.
3 Type in or select the file name.
4 Choose the file code.
5 Choose «OK».

Save a text with the same name

> Choose the Save command from the File menu.

Save all texts

> Choose the Save all texts command from the File menu.

Remark

When saving a pre-existing file,    Editeur renames the file with a .BAK suffix before saving. 
This ensures the availability of a backup copy.

See also

Delete files
Quit Editeur



Quit Editeur

Quit Editeur

> Select the Quit command from the File menu or
> Select the Close command from the Editeur system menu.

Editeur offers to save every modified text.

Quit Editeur with automatic saving of modified texts

> Select the Save and quit command from the File menu.

See also

Save texts



Modify a text
The location where updates take place is called the Insert Point. This point is highlighted with
a blinking shape.

Insert characters

Make sure you are in Insert Mode, or switch to Insert Mode by pressing the Ins key (in Insert 
Mode, the second square of the status bar includes the word "Insert", and the blinking shape
is a vertical bar).

Then type in your text.

Replace characters

Make sure you are in Overwrite Mode, or switch to Overwrite Mode by pressing the Ins key 
(in Overwrite Mode, the second square of the status bar includes the word "Overwrite", and 
the blinking shape if a full rectangle).

Then type in your text.

See also

Move in a text



Move in a text
Move the insert point in a text

Use the direction and control keys as follows :

Key(s) Function
---------------------------------------------------------------------------------------------------------------------------------
-------
DOWN Move one line down.
UP Move one line up.
RIGHT Move one character right.
LEFT Move one character left.
END Move to the end of the line.
HOME Move to the beginning of the line.
PAGE DOWN Move one window down.
PAGE UP Move one window up.
CONTROL + DOWN Move to the window bottom.
CONTROL + UP Move to the window top.
CONTROL + RIGHT Move one word right.
CONTROL + LEFT Move one word left.
CONTROL + END Move to the end of the text.
CONTROL + HOME Move to the beginning of the text.
CONTROL + PAGE DOWN Move one window right.
CONTROL + PAGE UP Move one window left.

See also

Modify a text
Unselect text



Select text
Select text with the keyboard

Press the Shift key while moving the insert point with the direction and control keys as 
follows :

Key(s) Function
---------------------------------------------------------------------------------------------------------------------------------
-------
SHIFT + DOWN Selects one line down.
SHIFT + UP Selects one line up.
SHIFT + RIGHT Selects one character right.
SHIFT + LEFT Selects one character left.
SHIFT + END Selects to the end of the line.
SHIFT + HOME Selects to the beginning of the line.
SHIFT + PAGE DOWN Selects one page down.
SHIFT + PAGE UP Selects one page up.
SHIFT + CONTROL + DOWN Selects to the window bottom.
SHIFT + CONTROL + UP Selects to the window top.
SHIFT + CONTROL + RIGHT Selects one word right.
SHIFT + CONTROL + LEFT Selects one word left.
SHIFT + CONTROL + END Selects to end of text.
SHIFT + CONTROL + HOME Selects to beginning of text.

Select text with the mouse

Move the mouse while pressing the left button.

Causing the mouse to approach the window border makes the text scroll, allowing extension 
of the selection beyond what was initially visible in the window.

See also

Unselect text
Cut, copy, paste, clear



Unselect text
Unselect all

Move the insert point with the direction and control keys, or click the left button of the 
mouse (see Move in a text).

Reduce the Selection with the keyboard

Press the Shift key while moving the insert point with the direction and control keys.

Reduce the Selection with the mouse

Press the Shift key, then press the left button of the mouse, and then, move the mouse.

Causing the mouse to approach the window border makes the text scroll, allowing for 
reduction of the selection beyond what was initially visible in the window.

See also

Select text
Cut, copy, paste, clear



Handling updates
Editeur records your updates. You can then undo and redo these updates. The number of 
updates undone or redone is not limited.

Undo updates
> Choose the    Undo command from the Edit menu as many times as necessary.

Redo updates
> Choose the Redo command from the Edit menu as many times as necessary.

Repeat the last update in another location
> Choose the Repeat command from the Edit menu.

Updates memory resetting

Any update after having undone modifications without having redone them provokes a 
resetting of the update memory : undoing or redoing previous modifications is then 
impossible.

The update memory is also reset when the text is saved.

See also

Repeat last update
Moving between texts



Repeat last update
Editeur records your last update in every text. You can then repeat this update in another 
location.

To repeat the last update
> Choose the Repeat command from the Edit menu.

See also

Handling updates
Moving between texts



Cut, copy, paste, clear, clear
These commands from the Edit menu allow the text to interact with an intermediate system
memory called the Clipboard.

Cut

Copies the selection into the Clipboard and clears the original ; the copied text replaces the 
previous content of the Clipboard.

Copy

Copies the selection into the Clipboard, but does not delete the original ; the copied text 
replaces the previous content of the Clipboard.

Paste

Inserts a copy of the Clipboard at the insert point.

Clear

Clears the selection.

See also

Select text
Unselect text



Uppercase, lowercase
These commands from the Edit menu allow the selection to be set to uppercase or 
lowercase.

Set the Selection to uppercase
> Choose the Upper command from the Edit menu.

Set the Selection to lowercase
> Choose the Lower command from the Edit menu.



Insert date and time
Insert the date and time at the insert point
> Choose the Date/time command from the Edit menu.



Search for a string

Search for a string

1 Choose the Search... command from the Search menu.
2 Type in the string being searched for.
3 Choose the options.
4 Choose «OK».

Search again for the string

> Choose the Search again command from the    Search menu or

1 Choose the Search... command from the Search menu.
2 Choose «Search again».

See also

Replace a string with another
Special moves



Replace a string with another

Replace a string with another

1 Choose the Replace... command from the Search menu.
2 Type in the string being searched for.
3 Type in the replacement string.
4 Choose the options.
5 Choose «OK» to confirm individual replacements or
> Choose «Replace all» for replacement without any confirmation.

String replacement dialog

Editeur sets up a dialog to drive the replacements. You can move from this dialog to the text 
and vice versa with a mouse click in the appropriate window : this allows for a direct update 
of the text while driving the replacement dialog.

See also

Search for a string
Special moves



Special moves

Go to a line identified by its number

1 Choose the Go to line number... command from the Search menu.
2 Type in the line number.
3 Choose «OK».

Go to the last update
> Choose the Go to last update command from the Search menu.

Set a mark on the current line
> Choose the Set a mark command from the Search menu.

Go to the mark
> Choose the Go to mark command from the Search menu.

See also

Search for a string
Replace a string



Print texts

Print the active text

> Choose the Print command from the File menu.

Print all texts

> Choose the Print all texts command from the File menu.

Remark

Printing does not currently include any option, except for font choice and printer setup.

See also

Change font
Change printer options



Change font
Change font

1 Choose the Font... command from the File menu.
2 Select the name of the font.
3 Type in or select the size of the font.
4 Choose «OK».

Remarks

Font choice applies to the whole text, and not to parts of the text (the Text File format does 
not include any typographic adornment).

Proposed fonts are normal printer fonts only. After your choice, Editeur displays the text with 
the nearest screen font available.

The last selected font becomes the default font.

See also

Print texts



Change printer options

Change printer options

1 Choose the Printer setup... command from the File menu.
2 Choose « Configure...».
3 Change the options.
4 Choose «OK».

See also

Print texts



Moving between texts

Switch between text windows

> Select the text window to be activated from the Window menu or
> Select the Next command    from the active text system menu.

Close a text window

> Select the Close command from the File menu or
> Select the Save and close command from the File menu or
> Select the Close command from the active text system menu.

Close all text windows

> Select the Close all texts command from the Window menu or
> Select the Save and close all texts command from the Window menuor
> Select the Quit command from the File menuor
> Select the Save and quit from the File menu or
> Select the Close command from Editeur system menu.

Remark

Commands with "Save" automatically save every modified text. Other commands request a 
confirmation for every modified text.

See also

Handling updates



Search among several texts

Search for a string among several texts

1 Choose the Search among all texts... command from the Search menu.
2 Type in the string searched for.
3 Choose the options.
4 Choose «OK».

Search for the string again

> Choose the Search again command from the Search menu.

Editeur ensures automatic switching between texts. The original text is reactivated at the 
end of the processing stage.

See also

Replace among several texts



Replace among several texts

Replace a sring with another among several texts

1 Choose the Replace among all texts... command from the Search menu.
2 Type in the string being searched for.
3 Type in the replacement string.
4 Choose the options.
5 Choose «OK» to confirm individual replacements or
> Choose «Replace all» for replacement without any confirmation.

String replacement dialog

Editeur sets up a dialog to drive the replacements. You can move from this dialog to the text 
and vice versa with a mouse click in the appropriate window : this allows for a direct update 
of the text while driving the replacement dialog.

Editeur ensures automatic switching between texts. The original text is reactivated at the 
end of the processing stage.

See also

Search among several texts



Options

Change the options

1 Choose the Options... command from the Options menu.
2 Choose the options.
3 Choose «OK».

The following options are available :

Tab size

This option defines the number of spaces separating two tabulation positions. This value is 
used both for displaying and printing text.

Typing replaces selected text

When this option is activated and a selection exists, typing text provokes the suppression of 
the Selection before the first character is taken into account. When this option is not 
activated, the Selection is simply canceled before the first character is taken into account.

Automatic indentation

When this option is not activated, typing the return key moves the insert point to the 
beginning of the next line. When this option is activated, typing the return key still moves 
the Insert Point to the next line, but shifts the beginning of the text to the level of the first 
preceding non-empty line.

Files in the history (9 max)

The list of the last opened files appears at the bottom of the File menu. By default, this list 
contains 4 entries, but this number may be modified to vary between zero and nine.

File names including directories

This option specifies if text window titles include full pathnames or only file names.

Open dialog at startup

When this option is activated, a file open dialog is offered at Editeur startup.

See also

Convert tabs



Convert tabs

This command allows tab width to be updated without modifying the text appearance, filling 
spaces with an adequate number of tabs and blank characters. This command is particularly
intended for texts created with an editor other than Editeur, where tab widths different from 
8 would not be correctly managed,    which would invalidate their use.

Convert the active text

1 Choose the Convert... command from the Options menu.
2 Type in the tab size "from".
3 Type in the tab size "to".
4 Choose «OK».

Editeur does the conversion, modifies the tab size, and displays the active text window 
again.

Convert all texts

1 Choose the Convert all texts... command from the Options menu.
2 Type in the tab size "from"..
3 Type in the tab size "to".
4 Choose «OK».

Editeur does the conversion, modifies the tab size, and displays all texts again.

See also

Options



File menu commands
New

This command creates a new empty text. The new text becomes active and can be directly 
edited.

Open...

This command opens one or more existing files. The file opened last becomes active and can
be directly edited. File deletion is possible in the "Open" dialog by selecting files to delete 
and pressing the Del key.

Save

This command saves the active text in a file. If the file already exists, it is renamed with 
a .BAK suffix before saving, so as to ensure the availability of a backup copy.

Save all texts

This command saves all open texts under their corresponding file names. The pre-existing 
files are renamed with a .BAK suffix before saving, so as to ensure the availability of backup 
copies.

Save as...

This command saves the active text under a new name. File deletion is possible in the "Save 
as" dialog by selecting a file to be deleted and pressing the Del key.

Close

This command closes the active text. Editeur offers to save the text if it has been modified.

Save and close

This command saves and closes the active text in one single operation.

Print

This command prints the active text on the default printer. Except for the choice of the font 
and the setting of the printer options, no presentation option (date, page number, ...) is 
currently available.

Print all texts

This command prints all open texts.

Font choice...

This command allows the choice of the font used for text printing. A nearby font is selected 
for text displaying. The selected font becomes the default font.

Printer setup...

This command sets up the options of the default printer.



Quit

This command is used to quit Editeur. All open texts are first closed. Editeur offers to save 
every modified text.

Save and quit

This command saves all texts and quits in one single operation.

1, 2, 3, 4, 

These commands are created as files are opened and make up a files history including from 
0 to 9 files. Selecting one of these commands reopens the corresponding file.



Edit menu commands
Undo

This command undoes one update. The update unit consists of a set of characters belonging
to a single line and typed in one single time (with no Insert Point move or menu command 
call). There is no limitation on the number of updates that can be undone or redone, except 
when the update memory is reset : when the text is saved or when the text is modified after 
having undone updates without having redone them.

Redo

This command redoes one previously undone update.

Repeat

This command repeats the last update in another location.

Cut

This command copies the selection into the clipboard and clears the original ;    the copied 
text replaces the previous content of the clipboard.

Copy

This command copies the selection into the clipboard without clearing the original ; the 
copied text replaces the previous content of the clipboard.

Paste

This command inserts the clipboard content at the insert point.

Clear

This command clears the selection.

Upper

This command sets the selection to uppercase.

Lower

This command sets the selection to lowercase.

Date/time

This command inserts the current date and time at the Insert Point.



Search menu commands
Search...

This command searches for a string in the active text or in the Selection. Different options 
are available : match upper/lower case, whole word, forwards/backwards, all texts.

Search among all texts...

This command searches for a string among all open texts. Editeur ensures automatic 
switching between texts when the string searched for is not found in the current text.

Search again

The previous commands are used for finding the first occurence of a string, and the present 
command is used for finding the following occurences.

Replace...

This command replaces a string with another in the active text or in the Selection. Different 
options are available : match upper/lower case, whole word, forwards/backwards, all texts. 
The replacements are driven with a specific dialog. You can move fromthis dialog to the text 
and vice versa with a mouse click in the appropriate window : this brings about for a direct 
update of the text while driving the replacement dialog.

Replace among all texts...

This command replaces a string with another in all open texts. Editeur ensures automatic 
switching between texts when the string searched for is not found in the current text. The 
replacements are driven with a specific dialog. You can move from this dialog to any open 
text and vice-versa with a mouse click in the appropriate window : this brings about for a 
direct update of the texts while driving the replacement dialog.

Go to line number...

This command ensures positioning on a line identified by its number in the active text.

Go to last update

This command ensures positioning on the last update in the active text.

Set a mark, Go to mark

These commands define a location in the active text (Set a mark) where a return (Go to 
mark) is possible quickly.



Options menu commands
Options...

This command allows the following parameters to be defined : tab stops, automatic selection
deletion or unselection when typing a character, automatic indentation, number of files in 
the files history, file names including directories or not, automatic open dialog at Editeur 
startup.

Tools bar

Select this menu item to show the Tools bar. Unselect it to hide the Tools bar.

Convert...

This command changes tab stops in the active text without modifying its appearance. 
Editeur ensures the same appearance by inserting the right number of tabs and spaces.

Convert all texts...

This command changes the tab stops all the open texts without modifying their appearance. 
Editeur ensures the same appearance by inserting the right number of tabs and spaces.



Window menu commands
Cascade

This command rearranges the text windows in a cascade pattern.

Tile

This command rearranges the text windows in a mosaic pattern.

Close all texts

This command closes all open texts. Editeur offers to save every modified text.

Save and close all texts

This command saves and closes all texts in one single operation.

1, 2, 3, 4

These commands are created as text windows are opened and make up a list of open text 
windows. Selecting one of these commands activates the corresponding text window.



? menu commands
Help

This command runs Editeur's help system, provided to answer the questions which could 
come up while using Editeur. This help describes in greater detail the procedures for using 
the commands.

Help on help

This command describes how the help system may be used.

About Editeur...

This command specifies the current version identifier and the name of the licence owner.

Register...

This command registers the name of the licence owner.



Tools Bar

The Tools bar is displayed on top of the application window, under the Menu bar. It affords a 
quick access to the main menu commands with a single mouse click. To show or hide the 
Tools bar, choose the Tools bar command from the Options Menu (ALT, O, T).

Click on To
________________________________________________________________________________

Create a new empty text. The new text becomes active and can be directly 
edited.

Open one or more existing files. The file opened last becomes active and can 
be directly edited. File deletion is possible in the "Open" dialog by selecting files to be 
deleted and pressing the Del key.

Save the active text in a file. If the file already exists, it is renamed with 
a .BAK suffix before saving, so as to ensure the availability of a backup copy.

Close the active text. Editeur offers to save the text if it has been modified.

Modify    the font used for text printing. A nearby font is selected for text 
displaying. The selected font becomes the default font.

Print the active text on the default printer. Except for the choice of the font 
and the setting of the printer options, no presentation option (date, page number, ...) is 
currently available.

Quit Editeur. All open texts are first closed. Editeur offers to save every 
modified text.

Undo one update. The update unit consists of a set of characters belonging to 
a single line and typed in one single time (with no Insert Point move or menu command call).
There is no limitation on the number of updates that can be undone or redone, except when 
the update memory is reset : when the text is saved or when the text is modified after 
having undone updates without having redone them.

This command redoes one previously undone update.



This command repeats the last update in another location.

Copy the selection to the clipboard and clear the original ;    the copied text 
replaces the previous content of the clipboard.

Copy the selection to the clipboard without clearing the original ; the copied 
text replaces the previous content of the clipboard.

Insert the clipboard content at the insert point.

Clear the selection.

Set the selection to uppercase.

Set the selection to lowercase.

Insert current date and time at the insert point.

Search for a string in the active text or in the selection. Different options are 
available : match upper/lower case, whole word, forwards/backwards, all texts.

Search for the next occurence of a string.

Replace a string with another in the active text or in the selection. Different 
options are available : match upper/lower case, whole word, forwards/backwards, all texts. 
The replacements are driven with a specific dialog. You can move from this dialog to the text
and vice versa with a mouse click in the appropriate window : this allows for a direct update 
of the text while driving the replacement dialog.



Text File
A Text File is a recorded sequence of raw characters, with no codes other than tabulations 
and line feeds to control the text appearance.



InsertPoint
The Insert Point is the location where the next update is to take place. It is highlighted with a
blinking shape.



Selection
The selection is the part of a text where the colors of the characters and the background 
have been inverted. The selection allows the scope of operations you ask to be specified and
allows a part of the text to be highlighted by Editeur.



File Code
This refers to the code of the set of characters used. This code may be OEM, for MS-DOS® 
files (e.g., CONFIG.SYS or AUTOEXEC.BAT), or ANSI, for WindowsTM files.

If you are not sure about the file code, choose "Don't know". Editeur will find it out for you 
as follows : Editeur assumes that the file code is OEM, and if it finds an ANSI character in the
first 65,518 bytes, considers that the file code is ANSI.



File Code
This refers to the code of the set of characters used. This code may be OEM, for MS-DOS® 
files (e.g., CONFIG.SYS or AUTOEXEC.BAT), or ANSI, for WindowsTM files.






