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Keyboard

The keyboard functions essentially the same as for any windows application.    The only unique feature 
of the keyboard interface involves selecting items and launching applications.    Use the left and right 
arrow key to move from item to item.    Hitting return will execute the selected item.



Folder Commands

To get help with a command, choose the appropriate menu.

File Menu
    New
    Open
    Save
    Name
    Delete
    Exit

Edit Menu
    Add Item
    Delete Item
    Delete File and Item
    Delete Subfolder
    Move
    Copy
    Command Line

Special Menu
    Item Name
    Item Icon
    View Filename
    Arrange Icons
    Set Default Icons



Folder Procedures

The Procedure topics give you detailed instructions on using the commands available to a folder.

Working with folder items
Adding items to a folder
Changing an item's icon
Changing an item's name
Copying items from folder to folder
Deleting a folder item
Deleting a folder's item and its file
Executing an item
Moving items from folder to folder
Setting an item's command line
Viewing an item's file name

Subfolder Procedures
Changing an item's icon
Changing an item's name
Copying items from folder to folder
Creating a new folder
Deleting a folder item
Deleting a subfolder
Executing an item
Exiting a folder
Moving items from folder to folder
Opening a folder
Saving a folder
Setting the default icons
Viewing an item's file name

Group Level Folder Procedures
Creating a new folder
Deleting a group level folder
Exiting a folder
Opening a folder
Renaming a group level folder
Saving a folder
Setting the default icons



File Menu

New - This command create a new folder.    This can be either a subfolder or a group level folder.    
Group level folders appear as icons in the group specified during the creation process.    Subfolders 
appear as icons in the folder currently opened.    Note that you can create subfolders in subfolders 
allowing for an infinite depth of folders (at least up to the number of folders the program can support).  
Be sure and give each folder an unique name.    Changing the case of a letter will not make a name 
unique.

Open - This command allows you to open or acitvate, if already open, any folder on the system, 
regardless of its location .    This allows you to open a specific folder without having to hunt it up.    The 
file currently open is not closed, thus allowing you to switch between it and any other folder you open.

Save - This command saves any changes made to the folder.    Note that some commands will 
automatically perform a save when executed.    They include move, delete subfolder, rename a 
subfolder, create a subfolder.    Basically, any command that manipulates a subfolder will cause an 
automatic save.

Name - Using this command, a group level folder may be renamed.    It is grayed out in subfolders.    
Subfolders must be renamed by their parent folder using the Special menu command, item name.    
Note that the folder icon in the Program Manager group must also be renamed using the PM's 
properties command.

Delete - This command will delete the group level folder currently open.    That is the folder from which
this command is executed will be deleted.    Like Name it only works for group level folders.    Subfolders
are deleted using the Edit menu command, Delete Subfolder from the parent folder.    Two important 
points to note with this command are, first, no subfolders are deleted.    To prevent having any 
unwanted subfolders left, they must be deleted before this command is executed starting from the 
lowest level.    Second, the folder icon in the Program Manager group must be deleted using the PM's 
delete command.

Exit - Causes the current folder to be closed.    If has not been saved, and changes have been made, 
you will be prompted on whether or not you want the folder saved.



Edit Menu

Add Item - Adds items to the current folder.    A dialog box is presented from which you may choose 
any file on the system.    After choosing, a descriptive name for the item must be entered.    This is the 
name that will show up under the item's icon.    An icon will then appear which represents the item just 
added.    By double-clicking on this icon, the item may be executed.

Delete -
Item - This command removes the selected item from the folder.    It does not delete the file 
associated with the item.    It simply removes it from the folder.

File and Item - This command removes the item from the folder and deletes the file associated 
with the item.    As such, use it only when you wish to remove the file completely from the disk.    If 
you wish to only remove the item from the folder, use the Delete Item command.    This command 
does not function with subfolders.

Subfolder - Use this command to delete a subfolder.    Note that this command completely removes 
the subfolder.    As such, if you have copied it to another folder and wish to be able to still access it 
from this other folder, use the Delete Item command to remove it from the current folder rather than
this command.    Also, any subfolders in this subfolder are NOT deleted.    So be sure and delete these
other subfolders, first.

Move - This command moves the currently selected item to the folder specified.    In doing so, it is 
removed from the current folder.    Note that if the folder you are moving the item to is open, it must be
closed and reopened before the new item will appear.    This commands will work on any item including 
subfolders.

Copy - Works the same as move, but does not remove the item from the current folder.    Use this 
command to link two or more folders to the same subfolder.    Simply create the desired subfolder using
the File menu New command, open it and place whatever items you wish in it.    Then, copy it to 
whatever other folders you wish to be able to access it.

Command Line - Allows you to customize a command line for an item.    Note that this command line 
takes precedence over the file name.    That is, if you have an item whose file is LETTER.TXT and TXT 
files are associated with Notepad, normally executing this item would cause Notepad to be ran using 
the file as the data file.    However, if you specify the command line as WRITE.EXE LETTER.TXT, the 
program Write will be ran rather than Notepad.    By setting the command line to blank, the original 
functionality of the item will be returned.    Note that any type of command may be specified on the 
command line.    It need not have anything to do with the file associated with that item.    As such, you 
could have the item whose file is LETTER.TXT run any application with any data file you cared to 
specify in the command line.



Special Menu

Item Name - This command allows you to rename items and subfolders.    When renaming subfolders, 
an automatic save will be performed.

Item Icon - Allows you to specify which icon is to be used to represent an item.    Twenty-one icons are 
made available for use in folders.

View Filename - This command shows the actual DOS file associated with an item.    As the item 
name need not be at all similar to the file name, this command is useful to find out what the actual file 
is.

Arrange Icons - Arranges the folder icons in an orderly manner.

Set Default Icons - The folders program comes with certain file extensions already associated with 
certain icons.    For example, any item added whose filename's extension is TXT will automatically 
appear as a notepad icon.    This command allows you to add or change these defaults.    Simply specify
the extension, then choose the icon you want associated with it.    Click on Set and the association will 
be recorded.    Make as many associations as desired, hitting Set each time, then hit Done when 
finished.    The new associations will not appear until the folder is closed and reopened.    This is true for
any folder that was open when the changes were made.



Registering Folders

Folders is a shareware program.    As such, if it is used, it needs to be registered with Sloop Software.    
Registration entitles you to support for the program as well as notice of any fixes or upgrades.    You will
also get a version that will support well over one-hundred folders, whereas the shareware version 
supports only fifteen folders.    One of two fees may be paid.    A twenty dollar fee gets you the 
registered version and the next version (not counting maintenance versions) is free of charge.    It will 
automatically be mailed to you as soon as it is released.    Or a fifteen dollar fee may be paid.    This will
get you the registered version of the program, but there will be a ten dollar fee if you desire to upgrade
to the next version.    Payment should be made in US dollars to:

                                Sloop Software
                                6457 Mesedge Lane
                                Colorado Springs, CO 80919

Please include your name, address, name of program, version number and the type of system you are 
using.    Add an additional $1.50 for a 3.5" disk.    Colorado residents please add the applicable sales 
tax.    Address any correspondence to the above address or send mail on CompuServe, id 72540,144.



License Agreement

No part of this manual may be reproduced, transmitted, transcribed, stored in a retrieval system, or 
translated into any language (natural or binary), in any form or by any means, except as described in 
the following license agreement or without the express prior written consent of Sloop Software.
                                                      
The use of Folders is subject to the following terms and conditions.

Title To The Licensed Software
Title to the licensed software is NOT transferred to the end user. The end user is granted an exclusive 
license to use the software on a SINGLE computer or computer work station. EACH computer or 
computer work station must have its own licensed copy of the software.

Copyright Protection
Folders is copyrighted material. It is protected by the copyright laws of the United States, the State of 
Colorado, and other proprietary rights of Sloop Software. You may not make any changes or 
modifications to Folders or this manual. You may not decompile, disassemble, or otherwise reverse-
engineer the software in any way.

You may make copies of Folders only under the terms of the section entitled "Limited License To Copy 
The Licensed Software".

You may use Folders on a trial basis provided you do not violate the protection afforded the licensed 
software by the copyright laws, and you agree to the terms of the license agreement. If you use 
Folders on a regular basis you are obligated to purchase it.

Limited Warranty
Sloop Software does not warrant that the licensed software will meet your requirements or that the 
operation of the software will be uninterrupted or error free.    The warranty does not cover any media 
or documentation which has been subjected to damage or abuse by you.

The software warranty does not cover any copy of the licensed software which has been altered or 
changed in any way.

ANY IMPLIED WARRANTIES INCLUDING ANY WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A 
PARTICULAR PURPOSE ARE LIMITED TO THE TERM OF THE EXPRESS WARRANTIES. Some states do not 
allow limitations on how long an implied warranty lasts, so the above limitation may not apply to you.

Other Warranties
The warranties set forth above are in lieu of any and all other express or implied warranties, whether 
oral, written, or implied, and the remedies set forth above are the sole and exclusive remedies.

Limitation Of Liability
Sloop Software is not responsible for any problems or damage caused by the licensed software that 
may result from using the licensed software. This includes, but is not limited to, computer hardware, 
computer software, operating systems, and any computer or computing accessories. End user agrees 
to hold Sloop Software harmless for any problems arising from the use of the software.

Sloop Software SHALL NOT IN ANY CASE BE LIABLE FOR ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, 
INDIRECT OR OTHER SIMILAR DAMAGES ARISING FROM ANY BREACH OF THESE WARRANTIES EVEN IF 
Sloop Software OR ITS AGENTS OR DISTRIBUTORS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES.    Some states do not allow the exclusion or limitation of incidental or consequential 
damages, so the above limitation or exclusion may not apply to you.



In no case shall Sloop Software's liability exceed the license fees paid for the right to use the licensed 
software, or a sum no greater than one Dollar ($1.00), whichever is less.

Limited License To Copy The Software
You are granted a limited license to copy Folders ONLY FOR THE TRIAL USE OF OTHERS subject to the 
terms of this software license agreement described herein, and the conditions described below are 
met: Folders MUST be copied in an unmodified form and FOLDERS.ZIP MUST contain the following files:

          FOLDERS.EXE        - The Windows executable program (shareware version only)
          FOLDERS.WRI        - The program documentation
          README.TXT            - Installation information
          FOLDERS.INI              - Folders initialization file
          FOLDER.HLP              - Folder help file
          FLD0000.FL0                - Empty folder for manual installation process
          FINSTALL.EXE          - Folders install program
          ORDERFRM.TXT - Folders order form

-> No fee, charge or other compensation may be accepted or requested by anyone without the 
express written permission of Sloop Software.

Public Domain Disk Vendors May NOT CHARGE a fee for Folders itself. However you may include 
Folders on a diskette for which you charge a nominal distribution fee. The purchaser of said diskette 
must be informed in advance that the fee paid to acquire the diskette does NOT relieve said purchaser 
from paying the registration fee for Folders if said purchaser uses Folders.

-> Operators of electronic bulletin board systems (Sysops) may post Folders for downloading by their 
users without written permission ONLY AS LONG AS THE ABOVE CONDITIONS ARE MET.    A fee may be 
charged for access to the BBS AS LONG AS NO SPECIFIC FEE IS CHARGED FOR DOWNLOADING Folders 
files without first obtaining express written permission from Sloop Software to charge such a fee.

The above constitutes the license agreement for Folders. It supersedes any and all previous license 
agreements.



Adding items to a folder

1. Select Add Item from the Edit menu.
2. From the dialog box that appears, choose the file you wish to add.    Click on OK.
3. Enter the descriptive name for the item that you wish to have appear under the item icon.    Click on 
OK.
4. The new item should now appear as an icon in the folder.



Changing an item's icon

1.    Select the item whose icon you want to change    by clicking on it with the mouse.
2.    Select Item Icon from the Special menu.
3.    From the dialog box, choose the new icon to be used to represent this item.    Click OK.
4.    The item should appear with the new icon.

Related Topics
    Setting the default icons



Changing an item's name

1.    Select the item you wish to rename by clicking on it with the mouse.
2.    Select Item Name from the Special menu.
3.    Type in the new name you want for the item.    Click on OK.
4.    The item's name will change to show the new name.

This command is also used for changing the names of subfolders, but not group level folders.

Related Topics
    Renaming a group level folder



Copying items from folder to folder

1.    Select the item you wish to copy by clicking on it with the mouse.
2.    Select Copy from the Edit menu.
3.    From the dialog box, select the folder you want the item copied to.    Click on OK.
4.    The item will now be copied to the specified folder.

Note that if the folder being copied to is already open, the new item will not appear until the folder is 
closed and reopened.    Also, if the folder is open, do not save it before closing it or you will lose the 
copy.

Using this command, one can link the same subfolder to two or more other folders.    Simply copy the 
subfolder to the folder you wish to also have access to it.

Related Topics
    Moving items from folder to folder



Creating a new folder

1.    Select New from the File menu.
2.    Enter the name of the new folder.    This name MUST be unique.    Upper or lower case do not make 
any difference.
3.    Select whether you wish this to be a subfolder or a group level folder.    Subfolders can only be 
accessed from the folder creating it.    They appear as a folder icon in the parent folder.    Group level 
folders are accessed from the Program Managers groups.    They appear as a folder icon in the group 
selected.
4.    If creating a group level folder, you will be prompted to enter the name of the Program Manager 
group you wish the folder to appear in.    This can be an already existing group or an entirely new 
group.    If it is a new group, the group will be created and the folder placed in it.    Once a group level 
folder has been created, it can be moved from group to group just like any other group item.



Deleting a folder item

1.    Select the item you wish to delete by clicking on it with the mouse.
2.    Select Delete Item from the Edit menu.
3.    You will be asked if you wish to delete the selected item.    Click on Yes or No.
4.    If you clicked on Yes, the item will be deleted from the folder.    Note that if you accidentally delete 
an item, close the folder without saving it.    When you reopen it, the item will still be there.

Related Topics
    Deleting a folder's item and its file
      Deleting a group level folder
      Deleting a subfolder



Deleting a folder's item and its file

1.    Select the item you wish to delete by clicking on it with the mouse.
2.    Select Delete File and Item from the Edit menu.
3.    You will be asked if you want to delete the selected item and its file.    Click on Yes or No.
4.    If you clicked on Yes, the item will be removed from the folder and the item's associated file will be 
erased from the disk.    This operation cannot be undone.

Related Topics
    Deleting a folder item
      Deleting a group level folder
      Deleting a subfolder



Deleting a group level folder

1.    Select Delete from the File menu.    Note that this command is only operational from a group level 
folder.
2.    You will be asked if you want to delete the folder.    Click on Yes or No.
3.    If you clicked on Yes, the folder will be closed and deleted from the system.    You must then also 
delete the folder icon from the Program Manager .

Note that subfolders contained in this folder will NOT be deleted.    Unless they are linked to some other
folder, they should all be deleted using the Delete Subfolder command before deleting the folder.

Related Topics
    Deleting a folder item
      Deleting a folder's item and its file
      Deleting a subfolder



Deleting a subfolder

1.    Select the subfolder you wish to delete by clicking on it with the mouse.
2.    Select Delete Subfolder from the Edit menu.
3.    You will be asked if you want to delete this subfolder.    Click on Yes or No.
4.    If you clicked on Yes, the subfolder will be removed from the system.    Note that if the subfolder 
has been copied to other folders, it must be removed from those folders using the Delete Item 
command.

Note that any subfolders contained in the subfolder being deleted will NOT be deleted.    They should 
be removed thru use of this command before deleting the subfolder they are contained within.

Related Topics
    Deleting a folder item
      Deleting a folder's item and its file
      Deleting a group level folder



Executing an item

1.    Double-click on an item's icon to execute it.
                  or
2.    Click on it with the mouse and hit the return key.
                  or
3.    Use the left and right arrow keys to select the item.    Hit    the return key.



Exiting a folder

1.    Select Exit from the File menu or Close from the System menu.
2.    If changes have been made to the folder since the last save, you will be prompted for whether or 
not you wish to save the folder.    Clicking on Yes will save and exit the folder.    Clicking on No will exit 
the folder without saving.    Clicking on Cancel will cancel the exit operation and return you to the 
folder.



Moving items from folder to folder

1.    Select the item you wish to move by clicking on it with the mouse.
2.    Select Move from the Edit menu.
3.    From the dialog box, select the folder you want the item moved to.    Click on OK.
4.    The item will now be moved to the specified folder.

Note that if the folder being moved to is already open, the new item will not appear until the folder is 
closed and reopened.    Also, if the folder is already open, do not save it before closing it or you will lose
the move.

Related Topics
    Copying items from folder to folder



Opening a folder

1.    Select Open from the File menu.
2.    Choose the folder you wish to have opened from the list in the dialog box.    Click on OK.
3.    If the folder selected has not been previously open, it will be opened and appear in a second 
window.    If it is already open, it will be made the acitve window.    If is already open and minimized, its 
icon will be opened into the active window.



Renaming a group level folder

1.    Select Name from the File menu.    Note that this command is only for renaming group level folders. 
Subfolders should be renamed from the parent folder using the Item Name command in the Edit menu.
2.    Enter the new name for the folder.    Click OK.
3.    Rename the folder's icon in the Program Manager group using the PM's Properties command in the 
File menu.

Related Topics
    Changing an item's name



Saving a folder

1.    Select Save from the File menu.
2.    All change made to the folder will be saved.



Setting an item's command line

1.    Select the item whose command line you wish to set by clicking on it with the mouse.
2.    Select Command Line from the Edit menu.
3.    Enter the new command line you want to be ran when the item is executed.    Click on OK.

Note that the command line must be entered exactly as if you were typing it at the DOS prompt.    The 
path must be provided for the data file.    The path for the executable need only be provided if it is not 
located in one of the directories specified in the Path= command in the autoexec.bat file.    The 
command line entered takes precedence over any associations between the data file and executables 
that may have been established using the File Manager's Associate command.    Entering a blank line 
will set the item back to its original functionality before the command line was set.



Setting the default icons

1.    Select Set Default Icons from the Special menu.
2.    Enter the file extension you wish to associate an icon with.
3.    Choose the icon you want associated with the extension from the list presented.    Click on Set.
4.    Repeat the process for whatever extensions you desire.    Click on Done when thru setting the 
defaults.
5.    To see the new icons, close and reopen the folder.

Folders comes with several associations already set up between file extensions and icons.    For 
example, any file you add to a folder with a TXT extension will appear as a notepad icon.    You may 
change or add any association you care to.    Note that these associations will apply to all folders, not 
just the one they are set in.

Related Topics
    Changing an item's icon



Viewing an item's file name

1.    Select the item whose file name you wish to view by clicking on it with the mouse.
2.    Select View Filename from the Special menu.
3.    A message box will appear showing the file associated with the folder item will appear.


