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Introduction to the IRIX Release Process

You do not need to read this section in order to install IRIX on your system.
However, you may wish to refer to it if you have questions about release
streams or the IRIX release process.

This section includes:

• “Understanding Release Streams” on page 3

• “Determining Your Current Release Stream” on page 8

• “Choosing Release Streams” on page 9

• “Switching Release Streams” on page 10

Understanding Release Streams

This section includes:

• “Overview” on page 4

• “Understanding the Release Family” on page 6

• “Release Process Advantages: System Administration and Compatibility”
on page 7
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4 Understanding Release Streams

Overview

Beginning with IRIX 6.5, a new software release process delivers IRIX
upgrades to you in a more easily manageable and consistent fashion.

In this new process, a family of releases is anchored with the initial base
operating system release. Intermediate releases are often referred to as overlays
because they lay on top of (but do not replace) the base operating system.
During your first upgrade to an intermediate release, you are asked to choose
a release stream. (You are not asked to choose a stream in subsequent
upgrades, but you will have the option of switching. See “Choosing Release
Streams” on page 9 and “Switching Release Streams” on page 10.)

The phrase “release stream” refers to a group of products in the intermediate
releases: each intermediate release contains a group of products called the
“feature” stream, and a group of products called the “maintenance” stream.
The maintenance stream contains accumulated bug fixes and basic support for
new hardware. The feature stream contains the same thing, with additional
new software features.

To help clarify the relationships and the elements in a release family, a
diagram of the 6.5 release family is shown in Figure 1.
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Figure 1 Diagram of the IRIX 6.5 Release Family

Note that each intermediate release includes the cumulative fixes and features
of the previous intermediate releases.

 The sections that follow describe these concepts in more detail.
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6 Understanding Release Streams

Understanding the Release Family

Base IRIX releases are those in which Silicon Graphics performs major
infrastructure work. They are generally backward compatible and are the
releases in which support for older platforms and software is discontinued.
Base releases occur in cycles of approximately 24 months, and they are
released on all platforms that are supported at the time of the release.

Intermediate releases (also called overlays) are guaranteed to maintain
backward and forward binary compatibility, which means that applications
built on any release in a release family run correctly on other releases in that
release family. Because intermediate releases are cumulative, each overlay
includes the fixes and features from the previous intermediate release. This
allows you to upgrade to the most current release in one step.

See also Figure 1, Diagram of the IRIX 6.5 Release Family, on page 5.

Intermediate releases (overlays) contain:

• maintenance stream products

• release stream products

• cumulative upgrades from previous
intermediate releases
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Release Process Advantages: System Administration and Compatibility

IRIX 6.5 intermediate releases support all platforms supported by the base
release, as well as later platforms, and therefore system administrators can
maintain just one network distribution or set of CDs to support all IRIX
systems and peripherals. Also, because these releases are cumulative, system
administrators do not have to create archives of IRIX release upgrade media.

For developers, application development is easier because intermediate
releases provide support for virtually all IRIX-based hardware platforms
(see the Start Here document for details). And, an application supported on
any release in the IRIX 6.5 family will run on all subsequent IRIX 6.5 family
releases. Additionally, the application will be compatible with all prior
releases of the IRIX 6.5 family, as long as the application does not utilize a
feature introduced in a later 6.5.x release.
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Determining Your Current Release Stream

If your system is running a 6.5.x version of IRIX, it is on the maintenance or
feature release stream.

You can determine a system’s current release stream in two different ways:

Note: If the system is running base release IRIX 6.5 or earlier, a release stream
has not yet been designated. You are asked to choose the release stream the
first time you install an intermediate release.

In Software Manager In a Shell

Open Software Manager by
choosing System > Software
Manager from the Toolchest.

Below the Lookup button you see
either Stream: Maint or Stream:
Feat. “Maint” indicates
maintenance stream and “Feat”
means feature stream.

Enter uname -R

The output line includes an IRIX
version number that ends with f
or m, where m indicates
maintenance and f  indicates
feature.
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Choosing Release Streams

Intermediate releases are divided into two sets of products, called release
streams, as outlined in the box below.

Choose the maintenance stream if you want to upgrade your system only
with fixes for maintaining stability and compatibility.

Choose the feature stream if you want the maintenance stream content plus
new software features.

Both the maintenance and the feature stream products are on the same CDs,
but once you choose a specific stream, only products in that stream are
displayed by the installation program. (You will not be asked to choose a
stream in subsequent upgrades.) The installation instructions in this booklet
include how to switch to the other release stream.

A maintenance stream contains: A feature stream contains:

• Accumulated bug fixes

• Basic support for new and
upgraded hardware

• Accumulated bug fixes

• Basic support for new and
upgraded hardware

• New software features
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Switching Release Streams

You can switch streams in either of the following situations:

• When upgrading from one 6.5.x version of IRIX to another 6.5.x version.
(In other words, when upgrading from one intermediate release of the 6.5
release family to another).

• When you have already installed a 6.5.x release using one stream, but
would like to switch to the other stream.

To switch release streams, thoroughly follow the instructions in “Installing an
Intermediate Release on IRIX 6.5 or Later” on page 14. (The “Installing an
Intermediate Release on IRIX 6.5 or Later” procedure includes details specific
to switching streams.) If your system does not have a graphical interface, use
“Installing an Intermediate Release on a Nongraphical System Running IRIX
6.5 or Later” on page 52.

Note: If your system is running the IRIX 6.5 base release or an earlier version
of IRIX, it is not possible to switch release streams because you are not yet on
a release stream—release streams began with 6.5.1.
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Troubleshooting Switching to the Feature Stream

In rare cases, you may need to open one or more of the base operating system
CDs when you switch to the feature stream. If this occurs, you are prompted
with conflict messages that look similar to the following (the product names
and numbers vary):

Overlay product eoe.sw.base (1275066720) cannot be
installed because of missing prerequisites: base product
eoe.sw.base (1274627340)

1a. Do not install eoe.sw.base (1275066720)

1b. Also install base product eoe.sw.base (1274627340)
from an additional distribution -- insert another CD
or specify another software distribution

If you see a conflict message like this, choose to open the distribution or CD
that contains the missing product, then select the product for installation. To
do this with Software Manager, follow these steps:

1. Choose to open the new distribution to resolve the conflict. (Choice 1b in
the example above.)

2. Insert the CD that contains the missing product.
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Note: If you are not sure which 6.5 CD the missing product is on, you have
two choices:

• Insert each of the 6.5 CDs and choose Install > Switch to Feature
Stream after opening each CD.

• Or, find the product in the CD Descriptions sections of the Start Here
pages. (Save your place here and see “How to Access the Start Here
Pages” on page 71.)

3. Type /CDROM/dist  (or the remote distribution location if applicable) in
the Distribution field of the Open Additional Distribution dialog.

4. Click Add.

5. Click to select the missing product.

6. Continue with the installation.
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Installing Software

Choose from the following procedures, depending on the type of installation
you need to perform:

• “Installing an Intermediate Release on IRIX 6.5 or Later” on page 14

• “Installing an Intermediate Release on a Pre-6.5 Version of IRIX” on
page 29

• “Installing Applications” on page 47 (not for operating system
installations)

• “Installing Software on a System Without a Graphical Interface” on
page 50
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Installing an Intermediate Release on IRIX 6.5 or Later

Who should use these instructions?
Use these instructions if your system has a graphical user interface and is
running 6.5 or a 6.5.x version of IRIX. Because intermediate releases are
cumulative, you do not need to upgrade to the previous intermediate release
to upgrade to a new one. For example, you can upgrade directly from 6.5.1 to
6.5.3.

If you need to find out what version of IRIX you are running, enter the
following in a shell window: uname -R

How long will it take?
This procedure should take approximately one to two hours, depending on
your installation knowledge and the speed of your system processor.

This section includes:

• “Quick Summary for Experienced Users” on page 15

• “Detailed Instructions: Installing an Intermediate Release on IRIX 6.5 or
Later” on page 18
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Quick Summary for Experienced Users

Silicon Graphics recommends that all users follow the instructions in
“Detailed Instructions: Installing an Intermediate Release on IRIX 6.5 or
Later” on page 18. However, this section provides a quick summary for
experienced Inst users.

1. Preparation Summary

• Print or check the Start Here pages for information you need before
you begin, such as minimum system requirements and any relevant
installation caveats for this release. (Save your place here and see
“How to Access the Start Here Pages” on page 71.)

• Gather the CDs you will use for this upgrade. If you want to switch
to the other release stream during this installation, you should have
the core CDs from the base operating system release on hand. (You
may need them because the files that are replaced in a release stream
are removed.)

2. Patch Installation Summary
(required before overlay installation)

For a live (not miniroot) upgrade, you need the “Installation tools
support for overlays” patch. Install it from the /CDROM/installtools
directory on the Installation Tools and Overlays CD. To use the new
tools you must exit Inst or Software Manager after you install the
patch.
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3. Overlay Installation Summary

Install products from the CDs you received in your intermediate
release package. Important:

• Open IRIX 6.5.x Installation Tools and Overlays first.

• Each CD must be opened and read before you begin the installation
selections. If you are switching from the feature to the
maintenance stream, open the core IRIX 6.5 CDs in addition to the
other CDs.

• To install upgrades and related (prerequisite) products, use the
appropriate command, depending on the type of installation:

In Software Manager In Inst

Install > Select Recommended
Upgrades

keep *
install standard

Install > Switch to Maintenance
Stream

install maint

Install > Switch to Feature
Stream

install feature
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4. Postinstallation Summary

Although every product has an associated release note that informs
you of major bugs and workarounds, Silicon Graphics has collected
information on bugs that could most significantly affect your
experience once you upgrade and has posted it as “Caveats to Read
After Upgrading.” This document is installed on your system by
default. To view it, bring up a Web browser and enter this address:
file:/var/www/htdocs/WhatsNew/precaveats.html

In addition to reviewing this document, you may want to check
”Caveat and Release Note Updates” at http://support.sgi.com/6.5/
for any late-breaking information.



18 Installing an Intermediate Release on IRIX 6.5 or Later

Detailed Instructions:
Installing an Intermediate Release on IRIX 6.5 or Later

Follow these steps sequentially, from Preparation through Postinstallation.
Each subsection is a necessary part of the process.

Preparation

1. Print or check the Start Here pages for information you need before you
begin, such as:

• Minimum system requirements for this release

• Major installation caveats

Save your place here and see “How to Access the Start Here Pages” on
page 71. The Start Here pages include additional useful information, such
as descriptions of each CD.

2. Gather the CDs you will use for this upgrade. If you want to switch to the
other release stream during this installation, you should have the core
CDs from the base operating system release on hand. (You may need
them because the files that are replaced in a release stream are removed.)
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Patch Installation
(required before overlay installation)

To obtain necessary installation software and to be able to perform a live (as
opposed to miniroot) installation, install the “Installation tools support for
overlays” patch as described in the following steps.

Note: Do not install this patch on systems running a pre-6.5 version of IRIX.
(If your system is not running 6.5 or later, you should be following the
procedure in “Installing an Intermediate Release on a Pre-6.5 Version of IRIX”
on page 29 instead.)

3. Insert the 6.5.x “Installation Tools and Overlays” CD in the CD drive. (If
you are using a remote directory instead of a CD, skip this step—you will
open the directory in the next step.)



20 Installing an Intermediate Release on IRIX 6.5 or Later

4. Follow the instructions below to bring up Software Manager and the
distribution that contains the patch:

Note: If a network error message appears, refer to “Troubleshooting

If installing from a CD
connected to your system:

If installing from a remote
system:

■ Double-click the CDROM icon
on your desktop.

■ If a README window
appears, read it and click
Dismiss.

■ Edit the Available Software
field in Software Manager so
that it displays the installtools
directory. Enter:

/CDROM/installtools

■ From your Toolchest, choose
System > Software Manager.

■ In the Available Software
field, enter the remote
system’s name and the
location of the installtools
directory of the “Installation
Tools and Overlays”
distribution.

For example, if you are using
a CD on a remote system
named mars, enter:

mars:/CDROM/installtools

■ If a README dialog appears,
read it and click Dismiss.
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Remote Installations” on page 66.

5. Click the Customize Installation... button.

6. Open the Software menu and make sure that “Short Product Names” is
not selected. (A check mark indicates that it is selected.)

7. Confirm that your system needs this patch:

■ If, in the Software Inventory list, next to “Installation tools support for
overlays,” you see New or Upgrade, proceed to Step 8 to install the
patch.

■ If you see the phrase Older Version or Same Version next to “Installation
tools support for overlays,” this patch is already installed. Quit
Software Manager and cancel the installation, then proceed to Step 11
to begin the overlay installation.

8. Make sure that the “Installation tools support for overlays” patch is
selected.

9. Click the Start button.

10. When the patch installation is complete, an “exit or continue” dialog
appears:

Choose Exit. (Do not install any other products yet.)

You will see the following message:

Requickstarting ELF files (see rqsall(1))...XX% Done.

The requickstarting process searches for old file types to be replaced with
new file types. It may take several minutes.
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Overlay Installation

11. Follow the instructions below to bring up Software Manager and the
software distribution:

Note: If a network error message appears, refer to “Troubleshooting
Remote Installations” on page 66.

If installing from a CD
connected to your system:

If installing from a distribution
or CD on a remote system:

■ The “Installation Tools and
Overlays” CD should still be
in the CD drive. If it is not,
insert it in the drive now.

■ Open Software Manager by
double-clicking the CDROM
icon on your desktop.

The Available Software field
should display /CDROM/dist

■ From your Toolchest, choose
System > Software Manager.

■ Enter the remote system’s
name and the location of the
“Installation Tools and
Overlays” distribution in the
Available Software field.

For example, if it is in a CD
drive on a remote system
named mars, enter:

mars:/CDROM/dist
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12. Click the Customize Installation... button.

13. If you have not done so in a previous installation, a dialog asks you to
select a stream. (If you are not sure what to choose, see “Choosing Release
Streams” on page 9.)

Note: If you are switching streams, this step does not apply to you. You
will make your stream switch selection in a future step.

14. A dialog prompts you to insert any other CDs that were included in the
IRIX overlay package (for example, any WorldView language support
CDs). To do so, use the following instructions.

Note: If Conflicts button highlights, ignore it until Step 16.

You must open all CDs or distributions now because Software Manager
needs to read the product descriptions before you make installation
selections.

(If you are switching from the feature to the maintenance stream, open
the core IRIX 6.5 CDs in addition to the other CDs.)

To open the CDs or distributions:

■ Eject the current CD and insert the next one. See the table below for
location-specific instructions.
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.

■ Click the Add button.

■ When all CDs have been added, click Done.

Software
Location

How to Open a
CD or Distribution

 CD Use the Software Manager Eject button if it appears
in a dialog, otherwise:

Select the desktop CDROM icon (on the system
connected to the CD drive), hold down the right
mouse button, and choose Eject CDROM.
(Alternatively, enter eject /CDROM  in a shell.)

Insert the new CD.

Distribution
directory

Open the next directory, for example:
open <systemname>:/irix/cd2
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15. Make your installation selections, based on the type of upgrade you are
performing:

You may see no matches  messages. This does not indicate an error.

Note: These commands are recommended because they significantly
reduce installation conflicts. Alternatively, you can click to select or
deselect products. A red check mark indicates that the product is selected
for installation.

Type of Upgrade How to Make Selections in Software
Manager

Typical upgrade (no
stream switch)

Choose Install > Select Recommended
Upgrades

Switching from
feature to
maintenance stream

Choose Install > Switch to Maintenance
Stream

Switching from
maintenance to
feature stream

Choose Install > Switch to Feature
Stream
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16. If there are installation conflicts, the Conflicts button text turns red. (If
there are no conflicts, proceed to the next step.) To display and resolve
conflicts, click the Conflicts button.

Too Many Conflicts?

If you have a surprising number of conflicts (for example, over twenty):

■ You may not have opened all the CDs or remote distributions you
needed to open, either because you did not open them all or because
you did not click the Add button each time. Try reopening the CDs that
came with your release package (and, if you are switching from the
feature to the maintenance stream, open the core IRIX 6.5 CDs as well).
To reopen, choose File > Open Additional Distribution..., and carefully
follow the “To open the CDs or distributions:” instructions in Step 14,
then proceed to Step 15.

■ You may not have used the appropriate selection command. Try
repeating Step 15.

Important Notes on Resolving Conflicts

• If you need to resolve conflicts by opening a CD, any installation
selections you previously made on that CD may be altered. Review
what is selected on the CD and deselect or reselect as needed, or repeat
the command you used in Step 15.
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• If a conflict gives you the option of deselecting a product with “eoe” or
“Execution Environment” in the product name, do not choose to
deselect the product. The operating system needs “eoe” products in
order to function properly. Exception: You do not have to install “eoe”
products that are man (manual) pages, relnotes (release notes) or books.

• If you deselected subsystems, conflicts may be generated by
remaining patches that go with the deselected subsystems. However,
because such patches go with subsystems you are not installing, you
do not need to install those patches.

• If you are switching to the feature stream and you have a conflict
about “missing prerequisites,” save your place here and see
“Troubleshooting Switching to the Feature Stream” on page 11.

17. Click the Start button.

You are prompted to open one or more specific CDs (or distribution
directories) as needed by the installation program.

Tip:  Save your place here and see the table in Step 14 for details on
ejecting and opening CDs.
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18. When a dialog appears that says “Installations and removals were
successful,” select Restart the system now and click OK.

You will see:

Requickstarting ELF files (see rqsall(1))...XX% Done.

It may take several minutes.

Restarting completes the installation process.

Postinstallation

Now that the IRIX operating system is upgraded, you can use Software
Manager to select and install any new products that were included with your
upgrade package. See “Installing Applications” on page 47.

Although every product has an associated release note that informs you of
major bugs and workarounds, Silicon Graphics has collected information on
bugs that could most significantly affect your experience once you upgrade
and has posted it as “Caveats to Read After Upgrading.” This document is
installed on your system by default. To see it, bring up a Web browser and
enter this address:
file:/var/www/htdocs/WhatsNew/precaveats.html

In addition to reviewing this document, you may want to check ”Caveat and
Release Note Updates” at http://support.sgi.com/6.5/ for any late-breaking
information.
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Installing an Intermediate Release on a Pre-6.5 Version of IRIX

Who should use these instructions?
Use these instructions if your system has a graphical user interface and has not
yet been upgraded to IRIX 6.5 or later, or if you are installing onto a graphical
system with a clean disk. You will install both the intermediate release and the
6.5 operating system at the same time. For example, you could upgrade
directly from 6.2 to 6.5.3.

If you need to find out what version of IRIX you are running, enter the
following in a shell window: uname -R (On systems running releases prior
to 6.2, enter uname -r )

How long will it take?
This procedure should take approximately one to two hours, depending on
your installation knowledge and the type of system you are using (faster
processors allow faster installation).

This section includes:

• “Quick Summary for Experienced Inst Users” on page 30

• “Detailed Instructions: Installing an Intermediate Release on a Pre-6.5
Version of IRIX” on page 34
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Quick Summary for Experienced Inst Users

Silicon Graphics recommends that all users follow the steps in “Detailed
Instructions: Installing an Intermediate Release on a Pre-6.5 Version of
IRIX” on page 34. However, this section provides a quick summary of the
process for experienced Inst users.

1. Preparation Summary

Collect the CDs you need (listed in Step 1 of “Detailed Instructions:
Installing an Intermediate Release on a Pre-6.5 Version of IRIX” on
page 34).

Print or check the Start Here pages for information you need before
you begin, such as minimum system requirements and any major
installation caveats for this release. (Save your place here and see
“How to Access the Start Here Pages” on page 71.)

2. Preinstallation Summary

• If you are using CDs, insert the IRIX 6.5.x Installation Tools and
Overlays CD now.

• Go to the miniroot.
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3. CD or Distribution Reading Summary

Before you make any selections, you must open all the CDs (as
described in Steps 7 through 12 of “Detailed Instructions: Installing an
Intermediate Release on a Pre-6.5 Version of IRIX” on page 34) so that
Inst can read the product descriptions on each of the CDs or
distribution directories. (This prevents many installation conflicts.)

Important:

• Open IRIX 6.5.x Installation Tools and Overlays first. (It should
already be in the drive.)

• If you have not previously done so, you are prompted to choose a
release stream. See “Choosing Release Streams” on page 9 for
details.
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4. Product Selection Summary

To install upgrades and related (prerequisite) products, refer to the
table below.

5. Installation Summary

Enter go , and resolve conflicts if necessary. Inst prompts you to open
specific CDs when they are needed.

In some cases, the message that indicates which CD to insert may
include Error/Interrupt Menu —this does not signify a problem.
Insert the requested CD, and at the Interrupt prompt enter retry .

Type of Upgrade Commands to Enter

Typical upgrade (no stream
switch)

keep *
install standard

Switching from feature to
maintenance stream

install maint

Switching from maintenance to
feature stream

install feature
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6. Postinstallation Summary

Although every product has an associated release note that informs
you of major bugs and workarounds, Silicon Graphics has collected
information on bugs that could most significantly affect your
experience once you upgrade and has posted it as “Caveats to Read
After Upgrading.” This document is installed on your system by
default. To see it, bring up a Web browser and enter this address:
file:/var/www/htdocs/WhatsNew/precaveats.html

In addition to reviewing this document, you may want to check
“Caveat and Release Note Updates” at http://support.sgi.com/6.5/
for any late-breaking information.
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Detailed Instructions:
Installing an Intermediate Release on a Pre-6.5 Version of IRIX

Follow these steps sequentially, from Preparation through Postinstallation.
Each subsection is a necessary part of the process.

Preparation

1. Confirm that you have the appropriate CDs or distributions. At the
minimum, you need:

• The latest 6.5.x Installation Tools and Overlays
(Use this instead of the base release Installation Tools.)

• Any other CDs that came with the intermediate release package

• From the 6.5 base release package:

– IRIX 6.5 Foundation 1

– IRIX 6.5 Foundation 2

– IRIX 6.5 Applications (use only if a newer Applications CD was not
included in the intermediate release package)

– IRIX 6.5 Development Foundation (use if you are a developer)

– IRIX 6.5 Development Libraries (use if you are a developer)

• In addition to the CDs listed above, you probably received other CDs
with your IRIX 6.5 package, depending on your configuration. For
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example, there are separate CDs for NFS and SoftWindows. If you
have already installed older versions of any of these products,
upgrade them during this installation. If you do not open a CD that
contains a product you have installed, “conflict” messages during
installation prompt you to open it.

2. Print or check the Start Here pages for information you need before you
begin, such as minimum system requirements for this release and major
installation caveats. The Start Here pages include additional useful
information, such as descriptions of each CD.

Save your place here and see “How to Access the Start Here Pages” on
page 71.

Note: Because this is a miniroot installation, you do not need to install the
“Installation tools support for overlays” patch.

Preinstallation

3. If it is not already in the CD drive, insert the IRIX 6.5.x Installation Tools
and Overlays CD. (If you are using a distribution directory instead of a
CD, skip this step—you will open the Installation Tools directory in Step
7.)

Note: Because you need the new installation tools, do not use the IRIX 6.5
Installation Tools CD for this installation. Use your most recent Installation
Tools and Overlays CD instead.
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4. Bring up the system maintenance menu:

■ From the Toolchest, choose System > System Shutdown.

■ If a Shut Down dialog appears, click OK.

■ When you see

Okay to power off

press the Esc  key.

Press the Esc  key immediately again when you see

Starting up the system

A menu screen should appear now. (If it doesn’t, you probably did not
press the Esc key soon enough; begin this step again by restarting your
system.)

5. Click Install System Software on the menu screen.



Installing an Intermediate Release on a Pre-6.5 Version of IRIX 37

6. Specify the location of the new software to install:

The new installation tools are loaded and a command-line interface
appears.

If installing from a CD
connected to your system:

If installing from a remote
system:

■ Click Local CDROM.

■ Click Install.

■ Click Continue in the dialog
box that appears.

■ If you are installing onto a
clean disk, see the Note below.

■ Click Remote Directory.

■ Enter the name of the remote
system that contains the
distribution.

■ Enter the pathname of the
distribution source on the
remote system. For example, if
the source is a CD, enter
/CDROM/dist .

■ Click Install.

If a network error message
appears, refer to
“Troubleshooting Remote
Installations” on page 66.
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Note: If you are installing on a clean disk, a message appears that includes
make new filesystem , and ends with [yes/no/sh/help] . Enter yes
to make the new filesystem. You are asked to confirm this; enter yes . You
are asked to enter a block size. If you do not know what to enter, enter
4096 .

CD or Distribution Reading

Before you make any selections, you must follow Steps 7 through 12 to open
the CDs or distribution directories so that Inst can read the product
descriptions.

If you have not yet determined which CDs you need, save your place here and
refer to Step 1 of this section, “Detailed Instructions: Installing an Intermediate
Release on a Pre-6.5 Version of IRIX” on page 34.
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7. Instruct Inst to read the Installation Tools and Overlays distribution by
entering the appropriate command (depending on the software location),
as described in the table below.

A Readme message may appear.
8. If you have not previously chosen a release stream, you see the following

message. (If you do not see it, proceed to the next step.)
1. Place me on the maintenance stream.
2. Place me on the feature stream.
3. Cancel

Enter 1 or 2.

If you are not sure which stream to choose, refer to “Choosing Release
Streams” on page 9.

Software
Location

How to Open
Installation Tools

Local CD Enter open /CDROM/dist

Remote CD Open the CD distribution directory on the remote
system. For example, if the system is named mars,
enter open mars:/CDROM/dist

Distribution
directory

Open the pathname for the Installation Tools and
Overlays CD, for example:
open mars:/irix/tools
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9. When you see a message similar to

Install software from:[/CDROM/dist]

replace the current CD or distribution directory with the next one, as
described in the table below.

When installing from a CD, make sure that the prompt indicates that the
installation is from the /CDROM/dist directory. For example, if the prompt
changes to reflect the /CDROM/dist/dist6.5 directory, enter /CDROM/dist
at the prompt.

10.  Press Enter  to instruct Inst to read the new CD or distribution directory.

Software
Location

How to Open a
CD or Distribution

Local CD Eject the current CD by pressing the manual eject
button on the CD drive. Insert the new CD.

Remote CD Eject the current CD by selecting the CDROM icon
on the remote desktop, holding down the right
mouse button, and choosing Eject. (Alternatively,
enter eject /CDROM  in a shell on the remote
system.) Insert the new CD.

Distribution
directory

Open the next directory, for example:
open <systemname>:/irix/cd2
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11. Continue to replace and open each CD or distribution directory in the
manner described in the previous two steps. (Use all the CDs you
collected in Step 1.)

Do not enter “done” until all the CDs or distribution directories have
been read. If you enter “done” too early, you can continue to insert the
rest of the CDs, but you will have to use the open command (as described
in Step 7) each time.

12. When all the relevant CDs or distribution directories have been read,
enter done .

Product Selection

13. Choose from the commands below, based on the type of upgrade you are
performing. These commands select upgrades and related (prerequisite)
products.

Note: If you are installing onto a clean disk, these commands select and
install all standard software, plus prerequisite software and patches.

Type of Upgrade Commands to Use

Typical upgrade (no stream
switch)

keep *
install standard
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• You may see no matches  messages. This does not indicate an error.

• If you are familiar with using Inst, you can also choose to install new
products now. Otherwise, proceed to the next step.

Tip: For information on viewing or altering the products that are marked
for installation, save your place on this page and refer to Step 17 of
“Installing an Intermediate Release on a Nongraphical System Running
Pre-6.5 IRIX” on page 54.

Installation

14. Enter go .

15. If there are no “Conflict” messages, proceed to Step 19. Otherwise, go to
the next step.

Switching from feature to
maintenance stream

install maint

Switching from maintenance to
feature stream

install feature

Type of Upgrade Commands to Use
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16. If your installation selections have generated conflicts, Inst asks if you
want to address them now.

Enter 1

for “Address these conflicts now.”

17. To resolve conflicts, enter

conflicts choice choice.

For example, enter conflicts 1b 2a to indicate that for conflict 1 you
choose choice b and for conflict 2 you choose choice a. (You can type
several conflict choices on the same line.)

Too Many Conflicts?

If you have a surprising number of conflicts (for example, over twenty):

■ You may not have opened all the CDs or distributions you needed to
open. Try reopening all CDs or distributions. To reopen each one, use
the open command (examples are given in the table in Step 7), then
proceed to Step 13 above.

■ You may not have used the selection command(s) recommended in
Step 13. Try reviewing and repeating Step 13.

See also important notes for resolving conflicts on the next page.
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Important Notes on Resolving Conflicts

• If you need to resolve conflicts by opening a CD, the installation
selections you already made may be altered on the CD you open.
Review what is selected on the CD and deselect or reselect as needed,
or reenter the command(s) you used in Step 13.

• If the list of conflicts is long, enter q to stop viewing the list and
resolve the conflicts currently visible on the screen. Once you have
resolved the visible conflicts, enter conflicts  again to view the
remaining conflicts. The other option is to write down all of your
choices before you enter them.

• If a conflict gives you the option of deselecting a product with “eoe” or
“Execution Environment” in the product name, do not choose to
deselect the product. The operating system needs “eoe” products to
function properly. Exception: You do not have to install “eoe” products
that are man (manual) pages, relnotes (release notes), or books.

• If you deselected subsystems, conflicts may be generated by
remaining patches that go with the deselected subsystems. However,
because such patches go with subsystems you are not installing, you
do not need to install those patches.

• If you are switching to the feature stream and you have a conflict
about “missing prerequisites,” save your place here and see
“Troubleshooting Switching to the Feature Stream” on page 11.



Installing an Intermediate Release on a Pre-6.5 Version of IRIX 45

18. When there are no more conflicts, enter go .

A preinstallation check begins. It may take several minutes.

19. You are asked to reopen CDs as Inst requires them.

When you see a message similar to

Please insert the “ CD title” CD
Type Ctrl-C to interrupt

insert the specified CD in the CD drive or open the associated remote
distribution directory.

Tip: Save your place here and use the table in Step 9 for details on ejecting
and opening CDs.

In some cases, the message that indicates which CD to insert may include
Error/Interrupt Menu —this does not signify a problem. Insert the
requested CD, and at the Interrupt prompt enter retry .

It may take several minutes for each distribution to install. Eventually a
new message prompts you to insert the next CD or indicates that the
installation is complete.

20. When Inst indicates that the installation is finished, enter quit .

You will see the following message:

Requickstarting ELF files (see rqsall(1))...XX% Done.

The requickstarting process searches for old file types to be replaced with
new file types. It may take several minutes.
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21. When you see

Ready to restart the system. Restart?

enter y.

Postinstallation

Now that the IRIX operating system is upgraded, you can use Software
Manager to select and install new products that were included with your 6.5.x
package. See “Installing Applications” on page 47.

Although every product has an associated release note that informs you of
major bugs and workarounds, Silicon Graphics has collected information on
bugs that could most significantly affect your experience once you upgrade
and has posted it as “Caveats to Read After Upgrading.” This document is
installed on your system by default. To see it, bring up a Web browser and
enter the following address:
file:/var/www/htdocs/WhatsNew/precaveats.html

In addition to reviewing this document, you may want to check “Caveat and
Release Note Updates” at http://support.sgi.com/6.5/ for any late-breaking
information.
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Installing Applications

Who should use these instructions?
Use these instructions if you need to install individual applications, rather
than an operating system. After you upgrade the IRIX operating system, you
can use these instructions to select and install new software products that
were included with your IRIX package.

How long will it take?
Installing individual applications may take anywhere from about five minutes
to thirty minutes, depending on the size of the installation, whether or not you
customize it, and the speed of your system processor.

This section includes:

•  “Installing Applications From a Local CD Drive” on page 48

• “Installing Applications From a Remote CD Drive” on page 49

Note: For more details about software installation, including how to
customize your installation and troubleshoot, refer to the Software Manager
Help menu.
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Installing Applications From a Local CD Drive

To install applications from a CD-ROM drive that is connected to your system:

1. Insert the CD in the CD drive.

2. Open Software Manager by double-clicking the CDROM icon on your
desktop.

3. To install all upgrades and new products, proceed to Step 4; otherwise,
click Customize Installation to select specific products:

■ After the Software Inventory is displayed, click to select the products
you want to install.

■ If a product has release notes, the product name turns blue when you
click it. Click again to display release notes, or choose Selected >
Release Notes.

4. Click the Start button.

5. When the installation is complete, choose File > Quit.

6. Eject the CD from the drive:

Select the CDROM icon, hold down the right mouse button, and choose
Eject.
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Installing Applications From a Remote CD Drive

To install applications from a CD-ROM drive that is connected to another
system on your network:

1. Insert the CD in the remote CD drive.

2. From the Toolchest on your system, choose System > Software Manager.

3. In the Available Software field, enter the remote system’s name and the
distribution directory path. For example:

<systemname>:/CDROM/dist

Note: If a network error message appears, refer to “Troubleshooting
Remote Installations” on page 66.

4. Click the Lookup button.

5. To install all upgrades and new products, proceed to Step 6; otherwise,
click Customize Installation to select specific products:

■ After the Software Inventory is displayed, click to select the products
you want to install.

■ If the product has release notes, the product name turns blue when
you click it. Click again to display release notes, or choose Selected >
Release Notes.



50 Installing Software on a System Without a Graphical Interface

6. Click the Start button.

7. When the installation is complete, choose File > Quit.

8. Eject the CD from the drive:

Select the CDROM icon on the remote system’s desktop, hold down the
right mouse button, and choose Eject.

Installing Software on a System Without a Graphical Interface

Who should use these instructions?
Use these instructions if your system does not have a graphical user interface.

How long will it take?
If you need to follow “Installing Applications on a Nongraphical System,” it
may take anywhere from about five to thirty minutes, depending on the size
of the installation, whether or not you customize it, and the speed of your
system processor.

If you need to follow “Installing an Intermediate Release on a Nongraphical
System Running IRIX 6.5 or Later” or “Installing an Intermediate Release on
a Nongraphical System Running Pre-6.5 IRIX,” it should take approximately
one to two hours, depending on your installation knowledge and the speed of
your system processor.
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This section includes instructions for three different situations:

• “Installing Applications on a Nongraphical System” on page 51

• “Installing an Intermediate Release on a Nongraphical System Running
IRIX 6.5 or Later” on page 52

• “Installing an Intermediate Release on a Nongraphical System Running
Pre-6.5 IRIX” on page 54

Installing Applications on a Nongraphical System

If you are installing application software (not upgrading the IRIX operating
system), it is not necessary to restart the system and perform the installation
from the miniroot. Instead:

1. Open a shell and enter su  to become superuser.

2. Enter inst .

3. Enter from  followed by the distribution path.

For example, if you are installing from a local CD-ROM drive, enter from
/CDROM/dist

4. Proceed to the Product Selection subsection of “Installing an
Intermediate Release on a Nongraphical System Running Pre-6.5 IRIX” on
page 54, but skip Step 22 and the skip the Postinstallation subsection.
Also, you may not have to restart the system after installation. Inst
prompts you to restart only if necessary.
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Installing an Intermediate Release
on a Nongraphical System Running IRIX 6.5 or Later

If you are installing onto a system running IRIX 6.5 or later, you can perform
a live (non-miniroot) intermediate release upgrade if you first install the latest
version of the “Installation tools support for overlays” patch.

To perform the live installation:

1. Install the “Installation tools support for overlays” patch from the
installtools directory of the intermediate release Installation Tools and
Overlays CD:

■ Open a shell and enter su .

■ Enter inst .

■ Enter from  followed by the distribution path. For example, if you are
installing from a local CD-ROM drive, enter from
/CDROM/installtools

■ Select the  “Installation tools support for overlays” patch.

■ Enter go .

■ When Inst indicates that the installation is finished, enter quit .

2. Gather the CDs you will use for this upgrade.

If you want to switch to the other release stream during this installation,
you should have the core CDs from the base operating system release on
hand.
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3. Print or check the Start Here pages for information you need before you
begin, such as minimum system requirements and major installation
caveats. The Start Here pages include additional useful information, such
as CD descriptions.

Save your place here and see “How to Access the Start Here Pages” on
page 71.

4. Enter inst .

5. Enter from  followed by the distribution path.

For example, if you are installing from a local CD-ROM drive, enter
from /CDROM/dist

6. Proceed to the CD or Distribution Reading subsection of “Installing an
Intermediate Release on a Nongraphical System Running Pre-6.5 IRIX” on
page 54.

Important: If you are switching from the feature to the maintenance stream,
use the core IRIX 6.5 CDs (in addition to the intermediate release CDs)
during the CD or Distribution Reading.
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Installing an Intermediate Release
on a Nongraphical System Running Pre-6.5 IRIX

If you are installing onto a system running a pre-6.5 version of IRIX, follow all
the steps below. You may also be interested in the “Quick Summary for
Experienced Inst Users” on page 30.

Follow these steps sequentially, from Preparation through Postinstallation.
Each subsection is a necessary part of the process.

Preparation

1. Confirm that you have the appropriate CDs or distributions. At the
minimum, you need:

• The latest 6.5.x Installation Tools and Overlays
(Use this instead of the base release Installation Tools.)

• Any other CDs included in your intermediate release package

• These CDs from the 6.5 base release package:

– IRIX 6.5 Foundation 1

– IRIX 6.5 Foundation 2

– IRIX 6.5 Applications (use if you did not receive a new Applications
CD in the Overlay package)

– IRIX 6.5 Development Foundation (use if you are a developer)

– IRIX 6.5 Development Libraries (use if you are a developer)
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• In addition to the CDs listed above, you probably received other CDs
with your IRIX 6.5 package, depending on your configuration. For
example, there are separate CDs for NFS and SoftWindows. If you
have already installed older versions of any of these products,
upgrade them during this operating system upgrade. If you do not
open the CDs that contain products you have installed, “conflict”
messages during installation prompt you to open them.

2. Print or check the Start Here pages for information you need before you
begin, such as minimum system requirements and major installation
caveats for this release. The Start Here pages include additional useful
information, such as CD descriptions.

Save your place here and see “How to Access the Start Here Pages” on
page 71.

Preinstallation

3. Insert the 6.5.x Installation Tools and Overlays CD in the CD drive. (It is
important that you load this CD first.)

Note: If you are using a distribution directory instead of a CD, skip this
step—you will load the Installation Tools directory in a future step.

4. Become superuser and shut down the system:

% su

# shutdown
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5. You see the message Do you want to continue with the
shutdown (yes/no) [no]

Enter yes .

6. If prompted, choose Restart, then press Esc  to Stop for Maintenance. (If
you don’t see this prompt, proceed to the next Step.)

7. You are given a list of choices at the system maintenance menu. Enter 2
for Install System Software.

8. Specify the distribution location:

If installing from a CD
connected to your system:

If installing from a remote
system:

■ Enter the number for the local
CD-ROM selection. (You may
have to press Enter  twice.)

■ Enter the number for the
remote directory selection.

■ When prompted, enter the
name of the remote system.

■ Enter the pathname of the
software location on the
remote system. For example, if
the source is a CD, enter
/CDROM/dist .
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9. Press Enter  to start the miniroot and Inst.

Rows of dots and various messages appear. Wait for the Inst prompt.

Note: If a network error message appears, refer to “Troubleshooting
Remote Installations” on page 66.

CD or Distribution Reading

Before you make any selections, you must correctly open all CDs or
distribution directories so that Inst can read the product descriptions. (This
prevents many installation conflicts.)

10. Instruct Inst to read the Installation Tools and Overlays distribution by
entering the appropriate command at the prompt, as described below
(depending on the software location):

Software
Location

How to Open the
Installation Tools

Local CD Enter open /CDROM/dist

Remote CD Open the CD distribution directory on the remote
system. For example, on a system named mars you
would enter: open mars:/CDROM/dist
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A Readme message may appear.

11. If you have not chosen a release stream during a previous upgrade, you
see this message:
1. Place me on the maintenance stream.
2. Place me on the feature stream.
3. Cancel

Enter 1 or 2.

If you are not sure which stream to choose, refer to “Choosing Release
Streams” on page 9 for clarification.

Distribution
directory

Open the pathname for the Installation Tools and
Overlays CD, for example:
open mars:/irix/tools

Software
Location

How to Open the
Installation Tools
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12. When you see a message similar to

Install software from:[/CDROM/dist]

replace the current CD or distribution directory with the next one, using
the following table as a guide.

When installing from a CD, make sure that the prompt indicates that the
installation is from the /CDROM/dist directory. For example, if the prompt
changes to reflect the /CDROM/dist/dist6.5 directory, enter /CDROM/dist
at the prompt.

Software
Location

How to Open a
CD or Distribution

CD Eject the current CD by pressing the manual eject
button on the CD drive. (Or, enter eject /CDROM
in a shell.) Insert the new CD.

Distribution
Directory

Open the next directory, for example:
open <systemname>:/irix/cd2
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13. Press Enter

so that Inst reads the new CD or distribution.

14. Continue to replace and open each CD or distribution directory in the
manner described in the previous two steps. (Use the CDs you collected
in Step 1.)

Do not enter “done” until all the CDs or distribution directories have
been read. If you enter “done” too early, you can continue to insert the
rest of the CDs, but you will have to use the open command (as described
in Step 10) each time.

15. When all the relevant CDs or distribution directories have been read,
enter done .
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Product Selection

16. Choose from the commands below, based on the type of upgrade you are
performing. These commands select upgrades and related (prerequisite)
products.

Note: If you are installing onto a clean disk, these commands select and
install all standard software, plus prerequisite software and patches.)

Note: You may see a no matches  messages. This does not indicate an
error.

Type of Upgrade Commands to Use

Typical upgrade (no stream
switching)

keep *
install standard

Switching from feature to
maintenance stream

install maint

Switching from maintenance to
feature stream

install feature
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17. (Optional) If you want to view or alter the products that are marked for
installation, enter list

Each product is marked:

– The status of products appears as follows: N=new, U=upgrade,
S=same, D=downgrade.

– The selection command that is currently applied to a product appears
as follows: i =install, r =remove, k=keep, where “keep” means that the
product is not marked for installation.

– Product types appear in brackets, as follows: [b] =reBoot needed after
installation is complete, [d] =Default, [r] =Required, [p] =Patch,
[o] =Overlay, [c] =Client only.

You may change the installation status of any product in the distribution
listed. For example:

• To select software that is not already selected, use the install command.
For instance: install ViewKit_dev.sw.lib

• If there is software you do not wish to install, use the keep command.
For instance: keep ViewKit_dev.sw.lib
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Installation

18. Enter go .

If there are no “Conflict” messages, proceed to Step 22.

19. If your installation selections have generated conflicts, Inst asks you if
you want to address them now.

Enter 1 for “Address these conflicts now.”

20. If you need to resolve conflicts, enter conflicts choice choice. For
example, enter conflicts 1b 2a to indicate that for conflict 1 you
choose choice b and for conflict 2 you choose choice a. (You can enter
several choices on one line.)

• If you need to resolve conflicts by opening a CD, the installation
selections you already made may be altered on the CD you open.
Review what is selected on the CD and deselect or reselect as needed,
or reenter the command(s) you used in Step 16.

• If the list of conflicts is long, enter q to stop viewing the list and
resolve the conflicts currently visible on the screen. Once you have
resolved the visible conflicts, enter conflicts  again to view the
remaining conflicts. The other option is to write down all of your
choices before you enter them.
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• If a conflict gives you the option of deselecting a product with “eoe” or
“Execution Environment” in the product name, do not choose to
deselect the product. The operating system needs “eoe” products to
function properly. Exception: You do not have to install “eoe” products
that are man (manual) pages, relnotes (release notes), or books.

• If you deselected subsystems, conflicts may be generated by
remaining patches that go with the deselected subsystems. However,
because such patches go with subsystems you are not installing, you
do not need to install those patches.

• If you are switching to the feature stream and you have a conflict
about “missing prerequisites,” save your place here and see
“Troubleshooting Switching to the Feature Stream” on page 11.

21. When there are no more conflicts, enter go .

A preinstallation check begins.

22. You are asked to reopen specific CDs as Inst requires them.

When you see a message similar to

Please insert the “ CD title” CD
Type Ctrl-C to interrupt

insert the specified CD in the CD drive or open the associate distribution
directory.

Tip:   Save your place here and refer to the table in Step 12 for details on
ejecting and opening CDs.
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In some cases, the message that indicates which CD to insert may include
Error/Interrupt Menu —this does not signify a problem. Insert the
requested CD, and at the Interrupt prompt enter retry .

It may take several minutes for each CD to install. Eventually a new
message prompts you to insert the next CD or indicates that the
installation is complete.

23. When Inst indicates that the installation is finished, enter quit .

You will see the following message:

Requickstarting ELF files (see rqsall(1))...XX% Done.

The requickstarting process searches for old file types to be replaced with
new file types. It may take several minutes.

24. When you see

Ready to restart the system. Restart?

enter y.

Postinstallation

Although every product has an associated release note that informs you of
major bugs and workarounds, Silicon Graphics has collected information on
bugs that could most significantly affect your experience once you upgrade
and has posted it as “Caveats to Read After Upgrading.” This document is
installed on your system by default. To see it, bring up a Web browser and
enter this address:
file:/var/www/htdocs/WhatsNew/precaveats.html



66 Troubleshooting Remote Installations

In addition to reviewing this document, you may want to check “Caveat and
Release Note Updates” at http://support.sgi.com/6.5/ for any late-breaking
information.

Troubleshooting Remote Installations

When a network error message appears during a remote installation, review
the following troubleshooting items to see if they apply to your situation:

• Check the network connection; make sure that the cables are secure.

• If you see an error similar to Cannot load network (0)
bootp()< systemname>:/CDROM/dist , check that tftp access to the
CD-ROM is enabled on the remote system. Detailed instructions are in the
online Personal System Administration Guide. To find the section in the
book, search for “tftp.” You can access the book from the Toolchest
(choose Help > Online Books), or from http://techpubs.sgi.com.

• (Only applicable when installing installation tools.) If your system does not
have its IP address correctly set in nvram, you will see these messages in
the system monitor when your system tries to reach a remote distribution:

Unable to execute network(0)bootp()< distribution path>

could not connect to server

Cannot load network(0)bootp()< distribution path>
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could not connect to server

Unable to continue; press <enter> to return to the
menu.

These messages indicate that you need to change the nvram IP address
entry to match the IP address that is being used by UNIX. This procedure
is described in the following steps:

1. When you see the error messages shown above in the System Monitor,
press Enter  to clear messages.

2. From the system maintenance menu, click Enter System Monitor (or
press 5)

3. Enter printenv netaddr  to display the IP address currently set in
nvram.

4. If the address displayed is correct, then stop. Your nvram is set
correctly, and there is a different problem preventing you from
reaching the distribution server. If the address displayed is incorrect
(or if you are not sure), proceed to the next step.
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5. This step depends on whether you know the correct IP address:

6. Enter exit  or click Done to return to the maintenance menu.

7. Choose Start System (or press 1). Wait until your system starts up, then
log in normally.

8. From the Toolchest, choose Desktop > Open Unix Shell.

If you know your system’s
correct IP address:

If you do not know your
system’s correct IP address:

■ Proceed to Step 15 below. ■ If your system was not
working properly before
starting the installation, or if
you are installing on a clean
disk, you must stop, find out
the correct IP address from
your network administrator,
and proceed to Step 15 below.

■ If your system was working
properly and was already
running IRIX, proceed to Step
6 below.
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9. In the shell window, enter:

/usr/etc/netstat -in

10. Your IP address is listed as a series of four numbers separated by
periods (such as 10.10.61.2 ) under the Address  column, usually
in the first line of output. (Ignore the lo0  line and the 127.0.0.1
address.)

11. To confirm your address, enter:

grep `hostname` /etc/hosts

Be sure to use backward apostrophes (`).

You should see your system’s hostname and the same IP address you
saw in the previous step.

12. Write down your IP address.

13. From the Toolchest, choose System > System Shutdown, then:

– If a Shut Down dialog appears, click OK.

– Press the Esc  key when you see Okay to power off .

– Press the Esc  key immediately again when you see Starting
up the system .

The System Maintenance menu screen should appear now. (If it does
not, you probably did not press the Esc key soon enough; begin this
step again by restarting the system.)
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14. Click Enter System Monitor on the menu screen (or press 5).

15. Enter setenv netaddr  followed by your IP address.

For example: setenv netaddr 10.10.61.2

16. Enter exit  or click Done to return to the maintenance menu.

17. Return to the installation instructions you were originally following.

Accessing Additional Installation Information

This section contains directions on accessing more installation-related
information:

• (Required for IRIX Operating System Installations Only) Follow the
instructions in “How to Access the Start Here Pages” on page 71 before
you install IRIX.

• (Optional) See “How to Access Inst Troubleshooting” on page 72 if you
want to print out troubleshooting documentation for Inst, the program
used for installing an operating system.

• (Optional) See “How to Access Release Notes” on page 73 to find out how
to view product release notes. Product release notes typically include
known bugs and workarounds, a description of changes particular to the
product release, and compatibility information.
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How to Access the Start Here Pages

Reviewing the Start Here pages is the first step in upgrading an IRIX operating
system, but is not applicable for single application upgrades or installations.

1. Insert the “Installation Tools and Overlays” CD that came with your most
recent release.

2. Open a Web browser and enter this address:

file:/CDROM/WhatsNew/yourSystem.html

(Literally type yourSystem.html ; do not type your system name.)

3. Click the Start Here link.

The Start Here pages include key information such as minimum system
requirements, major caveats for this release, CD descriptions, and an
overview of the new software included in the release. After you complete the
upgrade, you can access the Start Here pages by double-clicking the
Welcome_to_SGI icon on your desktop.

Note: You can alternatively find the Start Here pages:

• at http://support.sgi.com/6.5/installing.html

• on your most recent Base Documentation CD

When you are finished with the Start Here pages, return to the page that
referred you here.
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If you did not save your place, locate it in the appropriate section:

• “Installing an Intermediate Release on IRIX 6.5 or Later” on page 14

• “Installing an Intermediate Release on a Pre-6.5 Version of IRIX” on
page 29

• “Installing Software on a System Without a Graphical Interface” on
page 50

How to Access Inst Troubleshooting

There is information about troubleshooting network errors during remote
installations in “Troubleshooting Remote Installations” on page 66.

For information on general Inst troubleshooting, you may also want to access
(or print out) the troubleshooting section of IRIX Admin: Software Installation
and Licensing. To access it:

1. Log in.

2. Insert the IRIX 6.5 Base Documentation CD into the CD-ROM drive.

3. Open a shell: From the Toolchest, choose Desktop > Unix Shell.

4. Go to the CDROM directory.

The default CD-ROM directory location is /CDROM, so at the shell
prompt, enter cd /CDROM

5. Enter ./CDinsight  to launch the IRIS InSight book viewer.
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6. Click the SGI Admin tab and double-click the IRIX Admin: Software
Installation and Licensing book icon.

The Troubleshooting section is the last section of the book.

Note: You can also find this book at the Technical Publications Library
Web site at http://techpubs.sgi.com.

How to Access Release Notes

To view product-specific release notes, follow Steps 1 through 4 in the
previous section, then enter ./CDgrelnotes  to launch the release notes
viewer.

Installing Software Licenses

For products that require a license to run, you must activate a license for that
product on your system. You should have received a license information sheet
or label from Silicon Graphics. If you do not have this sheet or label, contact
Silicon Graphics or your local support provider.

Silicon Graphics uses FLEXlm to license its products. The sections that follow
describe how FLEXlm Nodelocked and floating or concurrent licenses are
installed using License Manager. (The terms “floating license” and
“concurrent license” are interchangeable.)
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Additional licensing information can be found at
http://www.sgi.com/Products/license.html.

Installing a FLEXlm Nodelocked License

To install FLEXlm Nodelocked licenses, you must invoke License Manager
and install the license. If you are installing a license for XFS Volume Plexing
or any other product that must be installed in a directory other than
/var/flexlm, then refer to the release notes for license installation instructions.

To install the license, follow this procedure:

1. Choose System > License Manager from the Toolchest to open License
Manager.

2. Click the Install... button.

3. Select FLEXlm Nodelock.

4. Click the OK button.

5. Copy all requested fields from the license information sheet or label into
the window labeled “License Manager: Install FLEXlm Nodelock
License.”

6. Click the OK button.

7. Repeat Steps 2 through 6 until all licenses are installed.
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8. Click the Close button on the main License Manager window.

You are finished installing the license(s). Save the license information sheet or
label; you may need it again later to reinstall your license(s).

Installing a FLEXlm Floating (Concurrent) License

Note: The information in this section should be used only by the system
administrator of the license server system. If you are an end user of client
software with a floating license that is not functioning, contact your system
administrator.

If you are installing a license for a product that must be installed in a directory
other than /var/flexlm, refer to the product’s release notes for license
installation instructions.

Floating licenses require a network license server. The subsystem
license_eoe.sw.flexlm_server must be installed on that system. Verify that it is
installed by opening a UNIX shell and entering
showprods license_eoe.sw | grep flexlm_server | wc -w

If the result is greater than 0 (for example, 7), the subsystem is installed; if the
result is 0, you must install license_eoe.sw.flexlm_server.
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With FLEXlm, a floating license must be installed on the license server and the
license file copied to every client system. The license manager daemon, lmgrd,
should then be started on the license server. You do not need to start license
daemons on client systems

To install the license on the license server system using License Manager,
follow this procedure:

1. Choose System > License Manager from the Toolchest to open License
Manager.

2. Click the Install... button.

3. Click FLEXlm Floating.

4. Click the OK button.

5. If necessary, enter the Server Host Name in the corresponding field. (To
find the name, enter the UNIX shell command uname -n on the server.)

6. Copy all requested fields from the license information sheet into the
“License Manager-Install FLEXlm Floating License” window.

7. Click the OK button.

8. Repeat Steps 2 through 7 until all licenses for the server are installed.

9. Click the Close button on the main License Manager window.
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Start the license daemon (only on the license server system):

1. Become superuser.

In a UNIX shell, enter su .

2. Enter chkconfig flexlm on

3. Stop the lmgrd daemon.

Enter /etc/init.d/flexlm stop

4. Start the lmgrd daemon.

Enter /etc/init.d/flexlm start

5. Exit the root account: enter exit

On any system you wish to access this license from, you must copy (or mount)
the license file (/var/flexlm/license_<server_name>.dat) from the server system
into the /var/flexlm/license_<server_name>.dat file (on all client systems).

You are finished installing the license. Save the license information sheet or
label; you may need it again later to reinstall this license.
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Troubleshooting FLEXlm Software Licenses

Use the methods described in this section for basic troubleshooting. See
http://www.sgi.com/Products/license.html for more information.

• To analyze the licenses in the license files, enter the UNIX command

/usr/sbin/lmdiag -c /var/flexlm/license.dat

(or /usr/sbin/lmdiag -c /var/flexlm/license_ serverhost.dat )

 If you see an error message that says the HOSTID is incorrect:

– For a Nodelocked license, enter the UNIX command /etc/sysinfo
-s . If the result does not match the HOSTID string for that product in
the license file, this is the problem.

– For a floating license, on the server system, enter the UNIX command
/etc/sysinfo -s . Compare the results with the second argument
on the SERVER line, which corresponds to the product in question. If
the two numbers are not identical, this is the problem.

Conditions that might cause the /etc/sysinfo -s results and the HOSTID to
be different include:

– The license may be for a system different from the one it is
installed on.

– The HOSTID may have been entered incorrectly.
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– The HOSTID on the system may have changed (replacing the
system board or I/O board can change the HOSTID).

• For trouble with a floating FLEXlm license, configure the lmgrd daemon
on the server to send its output to a log file by adding
-c /var/flexlm/license_ server_name.dat -l
/var/tmp/flexlm.log

to the /etc/config/lmgrd.options file, where /var/tmp/flexlm.log is the log file.
(Note that -l  is the lowercase letter l, not the number one.) In a UNIX
shell, enter

/etc/init.d/flexlm stop; /etc/init.d/flexlm start

Look at the log file for error messages.

If the application program (or lmstat) cannot connect to the license server,
one of several things may be wrong:

– The license server may be down, or there may be a network
problem. Verify that the client system can communicate with the
server. In a UNIX shell on the server, enter this command:

setenv LM_LICENSE_FILE /var/flexlm/license_ server_name.dat

Then, enter /usr/sbin/lmstat -a to verify that the vendor daemon
is running.



80 Troubleshooting FLEXlm Software Licenses

In a UNIX shell on the client system, enter lmstat -a  to check if the
system can contact the vendor daemon on the server. Then, from the
client system, enter the command telnet hostname portnumber, where
hostname and portnumber match the SERVER line in the license file.

– The Silicon Graphics vendor daemon may not be running. On the
server, verify that it is running by entering the UNIX command ps
-ef | grep sgifd | grep -v grep . If nothing is returned,
then the vendor daemon is not running.

– The application may not be looking at the expected license file. The
default license file for Silicon Graphics products is
/var/flexlm/license.dat. Verify the contents of /var/flexlm/licensefile.db
to see what files are being looked at. To view contents lists of all
expected license files, enter:

more /var/flexlm/licensefile.db

• If a warning message appears stating that the license expires in an
incorrect number of days, remove or comment out temporary or
evaluation license(s) in the /var/flexlm/license.dat file for this product.

• The License Password may have been entered incorrectly. Check that the
letters l and O were not typed in place of a numeral 1 (one) and 0 (zero).



Troubleshooting FLEXlm Software Licenses 81

• Run the date command by entering date . Make sure the date is not earlier
than the Start Date or later than the Expiration Date listed on the license
information sheet.

For more information on troubleshooting, refer to Appendix B of the FLEXlm
End User Manual. This guide is located in the IRIS InSight Library (on the
EndUser Bookshelf), which you can find by choosing Help > Online Books
from the Toolchest.




